Infos

® für:

alle MS Windows Betriebssysteme

© 1996/2010 by Frank Ullrich , Version: 8.0

29.01.2010

Startseite mit Informationen zur aktuellen WinFAQ, welche die Tipps zu allen Microsoft Betriebssystemen enthält.

Beachten Sie bitte folgende Hinweise:

  • Copyright-Hinweise
  • Nutzungsrecht
  • Danksagungen
  • Neu in dieser Version

Achtung:

Wenn Sie eine Email an uns schreiben wollen, fangen Sie bitte den Betreff immer mit WinFAQ: an. Aufgrund der vielen Spam-Mails werden alle anderen Emails sonst schnell ausgefiltert und gelöscht.

Info Allgemeine Info

Info Mit Fragen, Anregungen, Verbesserungsvorschlägen oder neuen Tipps wenden Sie sich bitte an (E-Mail: ).
Bei Anmerkungen zu Artikeln geben Sie bitte immer die Tippnummer (tipxxxx.htm) oder die genaue Überschrift des Artikels und die Version der von Ihnen verwendeten WinFAQ an. Diese Informationen finden Sie in der Fußzeile jedes Artikels.
Wenn Sie einen Tipp nach dessen Nummer suchen, geben Sie einfach "tipnnnn" in der Suchmaske der .chm-Version ein, wobei "nnnn" der Nummer des Tipps entspricht, nach dem Sie suchen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0026.htm

WinFAQ ® Version 8.0 Copyright © 1996/2010 by Frank Ullrich


Automatische Anmeldung in der Wiederherstellungskonsole (Recovery Console) aktivieren

Neu in dieser Version

Hier finden Sie eine kurze Übersicht über die neuen Tipps in der WinFAQ

Version 8.0 (tipp 2679+)

Neu:

[29.01.2010]

Liste aller Optionen der Systemsteuerung

"Spiele" aus dem "Startmenü" ein-/ausblenden

Akkuanzeige aus der Infobereich der Taskleiste ein-/ausblenden

Infobenachrichtigungen der Taskleiste als Sprechblasen ausschalten

Geändert:

Websuche nach Dateiendungen unterbinden

[01.01.2010]

Fehlermeldung: "Internet Explorer funktioniert nicht mehr"

Internet Explorer: "Bei Dateien dieses Typs immer fragen" wieder zurücksetzen

Übersicht der Dienste unter Windows 7

[25.12.2009]

Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren

ClearType: Helligkeit der Farbtöne für die Schriftglättung

ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Hintergrundbild der Windows Anmeldung verändern

Icon für Bildschirmtastatur auf dem Anmeldebildschirm ein-/ausblenden

[12.11.2009]

Windows 7 Beta oder RC auf aktuelle Windows 7 Version updaten

Aero Peek Vorschauzeit verändern

Update Version auf einem neuen Rechner installieren

Version 7.9 (tipp 2655+)

Neu:

[04.09.2009]

Alte Sucheinträge aus der Suchleiste entfernen

Windows 7 Versionen (Übersicht)

Windows vom USB-Stick installieren

[31.07.2009]

Warnhinweis bei Treibern ohne digitaler Signatur

Flip3D Vorschau deaktivieren

Geändert:

Benutzerkontensteuerung (UAC – User Account Control) : Anpassung für Windows 7

[17.07.2009]

Internet Explorer: Download immer bestätigen

Internet Explorer: Befehlsleiste ein-/ausblenden

Internet Explorer: Favoritenleiste ein-/ausblenden

Internet Explorer: Fixierung der Symbolleisten konfigurieren

[03.07.2009]

Client Performanz-Optimierung mit dem Windows Performance Tool Kit

Notification (Aktualisierung) des Explorers für Netzlaufwerke deaktivieren

Übersicht der Dienste unter Windows 7 - (angefangen)

Geändert:

Windows Vista "Service Pack" Informationen und Integration in die Setup DVD

[05.06.2009]

Windows 7 - Tauglichkeit testen

Windows CE: Internet Explorer Versionsinfo setzen

Geändert:

Infos und Whitepapers von Microsoft

Internet Explorer: Automatisches Update auf neuen Internet Explorer verhindern

[08.05.2009]

Konfiguration der Replikation von Passwortänderungen

Aktualisierung von Replikationstopologien

Domänencontroller/Clients getrennt durch Firewalls

Windows CE: Taskbar automatisch ausblenden

Windows CE: Textseitenaufbau beschleunigen

Windows XP wird mit der Zeit immer langsamer

Erweitert:

Die Windows Taste und deren Funktionen (Shortcuts) -> Neue Windows 7 Funktionen

[17.04.2009]

Vorschaubilder mit Rahmen anzeigen

Outlook: Aufforderung zur Installation der Windows-Desktopsuche deaktivieren

Windows CE: Lesbarkeit der Texte mit ClearType verbessern

Windows CE: Skript Fehler auf dem Pocket PC im Internet Explorer anzeigen lassen

Version 7.8 (tipp 2609+)

Neu:

[06.03.2009]

Ordnererkennung für unterschiedliche Ansichten im Explorer abschalten

Informationen über die Datei "Desktop.ini"

[13.02.2009]

Antwortverhalten bei mehr als einer Netzwerkkarte

Anzahl der automatischen Anmeldungen konfigurieren

Papierkorb deaktivieren (sofort löschen)

[23.01.2009]

Adobe Acrobat: Menüeintrag "Adobe Acrobat erwerben" deaktivieren

Internet Explorer: Einstellung "Formulare löschen" der Internetoptionen aus/-einschalten

Internet Explorer: Einstellung "Kennwörter löschen" der Internetoptionen aus/-einschalten

Adobe Acrobat: Menüeintrag "Adobe Online Dienste" entfernen

[09.01.2009]

Internet Explorer: Online Support Seite (URL) festlegen

Netzwerkkarten Rückmeldung bei WINS Anfragen

Geändert:

Aufklappen im Startmenü für weitere Funktionen aktivieren

[19.12.2008]

Warnmeldungen beim Windowsstart ausschalten

Anhänge in E-Mails werden als "Winmail.dat" beim Empfänger angezeigt

Eigene Programme oder fremde CPLs in die Systemsteuerung einbinden

Geändert:

Idle-Tasks (Ruhezeit-Aktivitäten) sofort starten (Tippfehler im Aufruf)

[04.12.2008]

Windows Suche: Position des Vorschaubereiches konfigurieren

Windows Suche: Dateiendungen für Vorschau konfigurieren

Anzeigen der Mausspur konfigurieren

Debugmodus beim Windows Update

[14.11.2008]

Idle-Tasks (Ruhezeit-Aktivitäten) sofort starten

Error Reporting ab Windows Vista

[31.10.2008]

Smooth Scrolling in Internet Explorer

Smooth Scrolling unter Outlook Express

Aufhebung einer Sperrung der Arbeitsstation geht auch mit gelockten Account

[24.10.2008]

Konfigurieren wo Drucker-Benachrichtigungen angezeigt werden

Outlook Einträge sicher löschen (gelöschte Einträge aus PST/OST-Datei sofort entfernen)

Microsoft Office: Zwischenspeichern von Passwörtern deaktivieren

Microsoft Outlook: Zusätzlichen Anmeldedialog deaktivieren

Konfigurieren der Anzeige des Eingabegebietsschema-Leiste auf dem Desktop

[17.10.2008]

Automatisches Update vom Autodesk-Programmen abschalten

Internet Explorer: Eintrag "Webseite, komplett" aus der Dialogbox "Webseite speichern" entfernen

Abbrechen von Startprogrammen (Autostart) über Shifttaste deaktivieren

Internet Explorer: Menüeintrag "Quelltext" deaktivieren

[10.10.2008]

Anzeigen von Warnmeldungen beim entfernen einer PCMCIA-Karte ausschalten

Erweiterte Log-Einträge für die Fehlersuche

Protokollierung im Gruppenrichtlinien Editor

Shutdown-Scripts während der Ausführung beim Herunterfahren anzeigen

Maximale Wartezeit für das Ausführen von Gruppenrichtlinienskripts konfigurieren

Startskripts gleichzeitig ausführen

[12.09.2008]

Anzahl der Vorlagen im Word Arbeitsbereich anpassen

Outlook Express: Ausführbare Dateianhänge sperren

Access: Konfigurieren der Laufzeitoptionen

Windows CE: Autostart Konfiguration

Windows CE: Warnmeldungen beim einlegen von PCMCIA/Flasch-Karten

Windows CE: Synchronisierung von Dateien auf Speicherkarten konfigurieren

Version 7.7 (tipp 2545+)

Neu:

[29.08.2008]

Internetdrucken auf dem Server ausschalten

Internet Explorer: Toolbar sperren

Internet Explorer: Download Verzeichnis für ActiveX Dateien festlegen

Server Wizard ein-/ausblenden

Internet Explorer: Verbindungen mit Unicode URL-Webseiten ermöglichen

[22.08.2008]

OS/2 und POSIX-Subsysteme deaktivieren

Download Accelerator History löschen

Windows CE: Font-Smoothing aktivieren

[15.08.2008]

Konfigurieren der CPU-Task Priorität

Geschwindigkeit's Optimierung für Systembus und Speicherzugriffe

Browserliste für weitere Domänen

Performanceanalyse - Speicherprobleme - Teil 2

Konvertieren eines IEEE 1394-Festplattenlaufwerkes in ein dynamisches Festplattenlaufwerk

Windows CE: Font-Cache (Schriftspeicher) ändern

[08.08.2008]

Favoriten in einem neuen IE-Fenster öffnen

Netzwerkverbindungen mit Ordneransicht im Explorer öffnen

Internet Explorer: ActiveX Programm Installation deaktivieren

Windows CE: Menü Animation ausschalten

Office: Autovervollständigung in der Dateidialogbox ausschalten

Windows CE: Animation ausschalten

[01.08.2008]

Kontenüberwachung für WSRM aktivieren

E-Mail-Adressen für WSRM-Benachrichtigungen festlegen

Zeitintervall in Minuten für das Protokollierungsintervall

SMTP-Server für den Versand von WSRM-Benachrichtigungen festlegen

Sound beim Starten von Windows ausschalten

[07.07.2008]

Internet Explorer: Sicherheitseinstellungen exportieren/Importieren

Art der EFS-Verschlüsselung konfigurieren

Anzahl der Prozessoren für den Start konfigurieren

Performanceanalyse - Grundlagen - Teil 1

Windows Teamarbeit deaktivieren

Windows Teamarbeitüberwachung deaktivieren

[27.06.2008]

Windows Mail: Communities-Funktion deaktivieren

Windows Mail: Zugriff auf Windows Mail unterbinden

Anwenderdaten (Userprofile) und Programme voneinander trennen

GUI für Dateizugriffsrechte unter XP Home

Geändert:

Bereiche der Systemsteuerung direkt starten

[13.06.2008]

Windows Installer: Flyweight Patching konfigurieren

SideShow: Automatisches Reaktivieren ausblenden und ausschalten

SideShow: Daten vom Gerät beim abmelden löschen

SideShow: PIN-Eingabe für den Zugriff auf die Daten aktivieren

SideShow: Die SideShow Funktion deaktivieren

[04.06.2008]

Excel: Euro-Zeichen wird bei kleiner Schriftart zum Strich

Windows XP Rechner werden nicht in der Netzwerkübersicht von Vista angezeigt

Programmen unterschiedliche Lautstärken zuweisen

[30.05.2008]

Liste der wiederherstellbaren lokalen Dateien ausblenden

Liste der wiederherstellbaren Remotedateien ausblenden

pnputil: Treiberpakete installieren/deinstallern und anzeigen lassen

Benutzerkontensteuerung: Zugriff auf Netzwerklaufwerke mit erweiterten Rechten "Elevated" nicht möglich

Backup-Dateien die nicht aus einer Schattenkopie stammen ausblenden

Wiederherstellung von Remotedateien unterbinden

Wiederherstellen bei Backup-Dateien die nicht aus einer Schattenkopie stammen ausblenden

Geändert:

Suchen aus dem "Startmenü" ein-/ausblenden

[23.05.2008]

Fehlermeldung beim Aufrufen des Outlook Abwesenheitsassistent

Explorer: Auswahl von mehreren Dateien und Ordnern nicht mehr möglich

Automatischer Download von Service Packs unterbinden

Restart-Manager von Windows Installer konfigurieren

Windows Installer: Protokollierung der Paketkonfiguration deaktivieren

Wiederherstellung von lokalen Dateien über Schattenkopie unterbinden

[13.05.2008]

DirectX: DirectDraw und Direct3D Konfiguration

"Nach alternativen Quellen Suchen" im Windows Installer aktivieren

[22.04.2008]

Aufgabenplanung - Task Scheduler

Internet Explorer: Entfernen der Symbolleiste

Service Pack in Microsoft Office 2007 einbinden

Internet Explorer: "Download beendet" - Nachricht de/aktivieren

[18.04.2008]

Windows HotStart Tasten ein-/ausschalten

Windows HotStart Tasten konfigurieren

Standard Autoplay Aufruf zurücksetzen

Siehe auch "Ältere Versionen der WinFAQ".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0442.htm


Ballon Info beim Minimieren des Messengers ausschalten

Ältere Versionen der WinFAQ

Hier finden Sie eine Übersicht von älteren Änderungen in der WinFAQ nach Datum sortiert.

Version 7.6 (tipp 2480+)

Neu:

[17.03.2008]

Acrobat Reader: Menüpunkt "PDF Online erstellen" ausblenden

Windows XP Professional Funktion unter Windows Media Center Edition aktivieren

[14.03.2008]

MediaPlayer: Informationen zur Benutzung nicht an Microsoft senden

MediaPlayer: Entfernen/Deinstallieren aktivieren

Internet Explorer: Ausführen von Javaskript unterbinden

Benutzerkontensteuerung (UAC) für bestimmte Anwendungen deaktivieren

Windows Vista "Service Pack 1" Informationen und Integration in die Setup DVD

[07.03.2008]

Eingebaute Gruppen (built-in group) zu einer lokalen Gruppe hinzufügen?

Datenträgerbereinigung erweitern

Benutzerkontensteuerung für den integrierten Administrator

Benutzerkontensteuerung (UAC – User Account Control)

Benutzerkontensteuerung nur für Dateien die signiert sind ausführen

Benutzerkontensteuerung nur für UIAccess-Anwendungen, die an sicheren Orten installiert sind

[29.02.2008]

Explorer-Band zur Taskleiste hinzufügen

Dialogboxen "Datei öffnen" und Speichern konfigurieren

Mediaplayer: Schaltfläche "Medienseite" konfigurieren

Mediaplayer: Keine Liste der zuletzt geöffneten Dateien erstellen

[22.02.2008]

Gruppe Jeder um "Anonyme Benutzer" erweitern

Office: Zusätzliche Fragebox in der Hilfefunktion ausblenden

Desktop Icon-Darstellung verändern

Websuche nach Dateiendungen unterbinden

Schriftarten der Eingabeaufforderung erweitern

Raid 5-Funktion unter Windows XP Pro freischalten

Verschlüsselung EFS deaktivieren

Neu:

[15.02.2008]

Outlook: Body Codierung für den Nachrichtentext konfigurieren

Neu:

[08.02.2008]

Gruppenrichtlinien als ADMX-Dateien

Gruppenrichtlinieneditor Gpedit.MSC unter Windows XP Home nachinstallieren

Geändert:

Time-Out Zeit des Internet Explorers verändern

Version 7.5 (tipp 2396+)

Neu:

[01.02.2008]

Protokollieren der Autoregistrierung im PKI-System

Fast User Switching aktivieren/deaktivieren

Acrobat Reader: Aufgaben beim Start

Text hinter der Uhrzeit anzeigen

Geändert:

Leistungsoptionen von Desktop Funktionen ändern (X-Mouse/Tooltipps usw.) - UserPreferencesMask

Cool Switch-Funktion (ALT+TAB) aktivieren/deaktivieren

[18.01.2008]

Windows Systemsounds konfigurieren und sichern

Gagscreen in Office 97/2000

Geändert:

Netzwerkkonfiguration leicht wechseln

[08.01.2008]

Netzwerk: IPSec-Ereignisse loggen

Datenträgerkontingentverwaltung aktivieren/deaktivieren

Bei erreichen der Speichergrenze von Datenträgerkontingenten speichern unterbinden

Standarddatenträgerkontingentgrenzen und Warnstufen konfigurieren

Speicherbegrenzung auf Wechseldatenträger anwenden

Protokolleintrag bei Überschreitung der Datenträgerkontingentsgrenze

Protokolleintrag bei Überschreitung der Datenträgerkontingentswarnstufe

Geändert:

Dateien/Ordner über das Kontextmenü verschlüsseln

Internet Explorer: Menüleiste ein-/ausblenden

[21.12.2007]

Anpassungen an Dateitypen unter Ordneroptionen sperren

Windows Scripting Host: Sicherheitsfunktion konfigurieren

Windows Scripting Host: Remote-Ausführung konfigurieren

Windows Scripting Host: Funktion Aus-/Einschalten (WSH deaktivieren)

MediaPlayer: Liste zuletzt verwendeter Dateien löschen

Geändert:

Menü: "Einfügen | Hyperlink..." deaktivieren

[07.12.2007]

Aufgrund der großen Anzahl von Tipps, wurden die einzelnen Tipps in Unterverzeichnisse mit jeweils 500 Einträgen aufgeteilt. Die alten Links werden automatisch weitergeleitet so das diese Veränderung darauf keinen Einfluss hat.

Outlook: Suchfunktion um "Abfrage-Generator" mit AND-Suche erweitern

Internet Explorer: Kontextmenüeinträge entfernen

Geändert:

Funktionen/Befehle der Dateien Rundll.EXE und Rundll32.EXE

[16.11.2007]

Kontextmenü der Taskleiste aktivieren/deaktivieren

Größenänderung der Taskleiste unterbinden

Active Directory nach fehlenden COM-Komponenten durchsuchen

[02.11.2007]

Sicherheitswarnung bei "Öffnen mit" festlegen

Mediaplayer: Ausführen von Scripten aktivieren/deaktivieren

[26.10.2007]

Internet Explorer neu installieren

ICACLS Dokumentation Fehler

Datei und Registry Virtualisierung

XP Home: Verstecktes Administratorkonto

Geändert:

Die Übersicht der Windows Vista-Dienste wurde erweitert: Übersicht der Dienste unter Windows Vista

[19.10.2007]

Windows XP nach Windows VISTA installieren

Outlook: Leiste "Klicken Sie hier, um die Sofortsuche zu aktivieren" ausblenden

In Outlook zusätzliche Dateianhänge sperren

Geändert:

In Outlook gesperrte Dateianhänge (Level1-Dateien) wieder anzeigen

[09.10.2007]

Zugriffsrechte auf Wechseldatenträger festlegen (lesen/schreiben)

Zugriff auf alle Wechseldatenträger unterbinden

VISTA Sprachausgabe auf Deutsch

Fehlermeldung: "Eine Desktopheapzuweisung ist fehlgeschlagen" in der Ereignisanzeige

Preview von PSD Dateien im Explorer als Thumbnail anzeigen

[07.09.2007]

Verschlüsselte Dateien für die Suche Indizieren

Erweitere Indizierungsoptionen aus der Systemsteuerung ausblenden

Speicherort für die Indizierungsdatenbank festlegen

Dateien aus dem Offlinedateicache nicht indizieren

[31.08.2007]

Energiesparmodus für Hybridfestplatten ausschalten

Permanenten Cache deaktivieren

Solid-State-Modus für Hybridfestplatten deaktivieren

Start- und Wiederherstellungsoptimierung deaktivieren

Version 7.4 (tipp 2316+)

Neu:

[21.08.2007]

Maximale Downloadzeit pro BITS-Auftrag

Konfiguration der Netzwerkbandbreite für BITS Übertragungen

Maximale Netzwerkbandbreite für die Übertragung zu anderen BITS-Rechnern

Zeitüberschreitung für inaktive BITS-Aufträge konfigurieren

Mailversand aus Word auch ohne MS-Mail-Programm

Computer lässt sich nicht mehr ohne Fehler Runterfahren

[13.08.2007]

Anzahl der maximalen Bereiche pro BITS-Auftrag festlegen

Anzahl der maximalen BITS-Aufträge pro Rechner festlegen

Anzahl der maximalen BITS-Aufträge pro Anwender festlegen

Anzahl der maximal zulässigen Datei pro BITS-Auftrag

Ruhezustand und Standby zum Dialog "Computer ausschalten" hinzufügen

[10.08.2007]

Funktion des Power-Buttons (Netzschalter) im Startmenü konfigurieren

Dialogfarben der Benutzer-Konten-Steuerung (UAC)

Funktion für Notebook-Deckel schließen konfigurieren

NTFS Komprimierung und Verschlüsselung ausschalten

Benachrichtigungen vom Windows Sicherheitscenter deaktivieren

Funktion für Energiespartastenaktion konfigurieren

Funktion für Netzschalter konfigurieren

Gelöschte Dateien überschreiben

[03.08.2007]

Dateien nach bestimmter Zeit aus dem Cache entfernen

Background Intelligent Transfer Service (BITS) aktivieren

Rechner darf nicht als BITS-Peercaching Client fungieren

Rechner darf nicht als BITS-Peercaching Server fungieren

Speicherplatz für den BITS-Peercache konfigurieren

Geändert:

Ändern der Sicherheit der LAN-Manager-Identifizierung an Windows

[20.07.2007]

Programmkompatibilitäts Assistent ausschalten

Ausführen des Audiorecorders unterbinden

Bei "Als Administrator ausführen" die Administratorkonten auflisten

Gesicherte Eingabe für Anmeldeinformationen benutzen

MSStyle unter Windows Vista wechseln

[13.07.2007]

Zusätzliche Kontextmenü Einträge bei gedrückter Shift-Taste

Sicherheitsmechanismus "Integrity Level" (IL)

Firefox mit niedrigen rechten (Integrity Level) ausführen

Geändert:

Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen (CACLS und ICACLS)

[06.07.2007]

Datenausführungsverhinderung (DEP)

URL für Sidebar-Anwendung ändern

Windows Sidebar deaktivieren

Entpacken und Installieren von nicht signierten Sidebar Anwendungen unterbinden

Benutzereigene Sidebar Anwendungen sperren

Geändert:

Ramdisk für Windows 2000/XP/2003 und Vista

Funktionen/Befehle der Dateien Rundll.EXE und Rundll32.EXE

[29.06.2007]

Klassischen Desktop aktivieren (Visuelle Stile ausschalten)

Miniaturansichten anstelle von Symbolen anzeigen

Taskleisten-Animationen aktivieren/deaktivieren

Windows Vista Basic mit AERO Oberfläche

Freigabe-Assistenten für Netzwerkfreigaben ausschalten

Menüleiste vom Explorer ein-/ausblenden

Geändert:

Leistungsoptionen von Desktop Funktionen ändern (X-Mouse/Tooltipps usw.) - UserPreferencesMask

Informationen über die BOOT.INI

Version 7.3 (tipp 2268+)

Neu:

[22.06.2007]

ReadyBoost für alle USB-Speicher aktivieren

Standardanmeldebild für alle Benutzer

Mediaplayer: Medienfreigabe verhindern

Automatische Updates über Updateservice bereitstellen

Updates Installieren welche nicht von Microsoft Signiert sind

Windows Update kann Rechner für die Updateinstallation aktivieren

[15.06.2007]

Fehlermeldung beim Öffnen von Worddateien über Wordpad

Starten der Anwendung "Sicherungsstatus und -konfiguration" nicht zulassen

Eintrag "Complete PC-Sicherung" aus "Sicherungsstatus und -konfiguration" entfernen

Sicherung auf lokale Datenträger unterbinden

Nach der PC-Wiederherstellung gibt es Probleme bei der Installation von Programmen

Sicherung auf optischen Medien (CDR/DVD) unterbinden

Sicherung auf Netzwerkfreigaben unterbinden

Funktion "Daten sichern" aus "Sicherungsstatus und -konfiguration" sperren

Funktion "Daten wiederherstellen" aus "Sicherungsstatus und -konfiguration" sperren

[08.06.2007]

Aktualisierung von Feeds im Hintergrund deaktivieren

Internet Explorer: Feed-Funktion deaktivieren

Internet Explorer: Feed-Suche deaktivieren

Internet Explorer: Herunterladen von Dateien aus Feeds unterbinden

Internet Explorer: Hinzufügen und Entfernen von Feeds deaktivieren

Version 7.2 (tipp 2211+)

Neu:

[01.06.2007]

Internet Explorer: Einstellung "Ausführen aktiver Inhalte von CDs auf dem lokalen Computer zulassen" konfigurieren

Internet Explorer: Einstellung "Animationen in Webseiten wiedergeben" konfigurieren

Internet Explorer: Ausführen von Browsererweiterungen anderer Hersteller zulassen

[25.05.2007]

Internet Explorer: Einstellung "Links unterstreichen" konfigurieren

Internet Explorer: Einstellung "Browserverlauf löschen" der Internetoptionen aus/-einschalten

Die Menüleiste im Explorer permanent anzeigen

QuickInfos (BallonTipps) "Neue Hardware gefunden" abschalten

Alle digital signierten Treiber gleich bewerten

Keinen Systemwiederherstellungspunkt bei der Treiberinstallation anlegen

Den Eintrag "Sprachauswahl" aus Regions- und Sprachoptionen entfernen

[18.05.2007]

Laden von Anwendungen beschleunigen (EnableSuperfetch)

Anzeige und Aktualisierung des Leistungsindex deaktivieren

Den Eintrag "Verwaltung" aus Regions- und Sprachoptionen entfernen

Den Eintrag "Standort" aus Regions- und Sprachoptionen entfernen

Den Eintrag "Formate" aus Regions- und Sprachoptionen entfernen

Transparenz für die Fenster mit AERO-Oberfläche ausschalten

[11.05.2007]

Internet Explorer: Der Erweitert Tab in den Internetoptionen enthält keine Einträge

Internet Explorer: Einstellung "Platzhalter für den Bilderdownload anzeigen" konfigurieren

Internet Explorer: Einstellung "Optimierten Bildverlauf verwenden" konfigurieren

Internet Explorer: Einstellung "Skriptfehler anzeigen" konfigurieren

Windows Desktopsuche: Indizieren bei begrenztem Festplattenspeicherplatz abbrechen

Windows Desktopsuche: Speichern des Suchverlaufs in der Deskbar deaktivieren

[04.05.2007]

Windows Desktopsuche: Dateitypen definieren, die als Textdateien behandelt werden sollen

Windows Desktopsuche: Indizieren bestimmter Netzwerkfreigaben unterbinden

Windows Desktopsuche: Erweiterte Indizierungsoptionen ausblenden

Windows Defender: Protokollierung von unbekannter Software

Internet Explorer: Fenster "Einstellungen anpassen" beim ersten Start nicht anzeigen

Windows Defender: Updates nur über WSUS-Server beziehen

Windows Defender: SpyNet-Mitgliedschaft konfigurieren

Timeout Zeit für die Auswahl von Hardware-Profilen festlegen

Geändert:

Die 'digitale Treibersignatur' für Gerätetreiber

[27.04.2007]

Windows Defender: Signatur-Satzes vollständig herunterladen

Windows Defender: Zugelassene Software auch protokollieren

Windows Desktopsuche: Deskbar deaktivieren

Windows Desktopsuche: Link "Auf Aktualisierungen überprüfen" ausblenden

Windows Desktopsuche: Den "Anpassungs-Assistenten" ausschalten

Windows Desktopsuche: Das Senden von Nutzungsdaten durch CEIP unterbinden

Windows Desktopsuche: "Öffentliche Ordner" nicht indizieren

Geändert:

Windows Desktopsuche: Windows Such-Assistenten nicht durch die Desktopsuche ersetzen

[20.04.2007]

Ein Favoriten/Lesezeichen-Verzeichnis für den Internet Explorer und Firefox

Mit aktiver Benutzerkontensteuerung auf administrative Freigaben zugreifen

Windows Defender: "Vor Überprüfung nach aktualisierten Signaturen suchen" konfigurieren

Windows Defender: Was macht das Tool?

Windows Defender: Einstellung für "Software, deren Risiko noch nicht eingestuft wurde" festlegen

Geändert:

Standard Icon auf dem Desktop ein-/ausblenden

[13.04.2007]

Windows Desktopsuche: Ablagepfad für die Indexdatei festlegen

Windows Desktopsuche: Indizieren von Netzwerkfreigaben unterbinden

"Senden an" aus dem Kontextmenü ein-/ausblenden

Anwendungen über das Kontextmenü mit "Hoher-Priorität" starten

Tooltipptext von Standardicons ändern

Windows MediaPlayer: 64-Bit Funktion aktivieren

Version 7.1 (tipp 2182+)

Neu:

[30.03.2007]

Standardverzeichnis für Hintergrundbilder verändern

Verändern der Eigenschaften von der Taskleiste unterbinden

Aufrufen des Begrüßungscenters ausschalten

Starten des "Media Center" unterbinden

Benutzerkontensteuerung für die Softwareinstallation konfigurieren

Benutzerkontensteuerung für Standardbenutzer ausschalten

Benutzerkontensteuerung für Adminstratoren ausschalten

Monitor abdunkeln bei der Benutzerkontensteuerung ausschalten (sicherer Desktop)

Die Suche im Startmenü beschleunigen

[23.03.2007]

Internet Explorer: Versionsnummer festlegen die gesendet wird

Internet Explorer: Suchbox aus-/einblenden

Internet Explorer: Menüeintrag "Kundenfeedbackoptionen" aus dem Hilfe Menü ausblenden

Internet Explorer: Menüleiste ein-/ausblenden

Internet Explorer: Navigationsbereich ausblenden

[16.03.2007]

Aktivierung von Windows

Alte Hilfedateien (.HLP) unter Windows Vista

Windows Desktopsuche: Nur "E-Mail" und "Eigene Dateien" indizieren

Windows Desktopsuche: Indizieren von Outlook-Express-Elementen deaktivieren

Windows Desktopsuche: Indizieren von Outlook-Elementen deaktivieren

Internet Explorer: Hilfemenü und Funktion deaktivieren

[09.03.2007]

Windows Defender: Defender ein-/ausschalten

Internet Explorer: Einstellung "Suchen in Adressleiste" konfigurieren

Internet Explorer: Einstellung "Seitenübergänge aktivieren" aktivieren/deaktivieren

Windows Desktopsuche: Dateitypen festlegen die nicht indiziert werden

Windows Ruhezustand deaktivieren und löschen der Datei HIBERFIL.SYS

Windows Desktopsuche: E-Mail Anlagen nicht indizieren

[02.03.2007]

Profilverzeichnis, Startmenü und Homeverzeichnis ab Vista

Windows Desktopsuche: Windows Such-Assistenten nicht durch die Desktopsuche ersetzen

Windows Desktopsuche: Starten bei der Anmeldung unterbinden

Loggen von Systemereignissen ein-/ausschalten

Internet Explorer: Einstellung "UTF-8 für mailto-Links verwenden" konfigurieren

Internet Explorer: Einstellung "Immer ClearType für HTML verwenden" konfigurieren

Internet Explorer: Einstellung "Bilder anzeigen" konfigurieren

Windows Script Host Startinfo ausschalten

Netzwerkkarte wird bei fehlender Verbindung nicht aktiviert

Port für Remoteverbindung ändern

Energie-Einstellungen lassen sich nur mit Administrativen rechten ändern

Verzeichnisrechte und Verzeichniszugriffe unter Windows Vista

Version 7.0 (tipp 2149+)

Info Die Firma cognitas GmbH stellt dem WinFAQ-Team die Software "MadCap Flare", in Version 2.0, zur Verfügung. MadCap Flare ist das XML-basierte Autorensystem für Online-Hilfen mit kompletter Single-Sourcing-Flexibilität.

Wir sind dabei, die aktuelle WinFAQ-Website von "ForeHelp" auf "Flare" umzustellen. Durch die neue Software wird sich gerade die HTML (Online-WinFAQ) mit einem neuen und übersichtlicheren Aussehen präsentieren. Wir bedanken uns hiermit bei der Firma cognitas für die Software "MadCap Flare" und hoffen weiterhin auf eine gute Zusammenarbeit.
Weitere Infos über Flare finden Sie hier.

Neu:

[22.02.2007]

Internet Explorer: Menüleiste oben anordnen

Tabreiter "Dateitypen" in Explorer verschwunden

Anzahl der 3D-Auswahlfenster (Flip3D)

"Hilfe und Support" lässt sich nicht mehr öffnen

Splash Screen von Windows Mail deaktivieren

Internet Explorer: Einstellung "IDN-Servernamen senden" konfigurieren

Windows Backup: Bringt Fehlermeldung 0x80070026

[15.02.2007]

Zugriffsrechte auf unterschiedliche Objekte setzen

Maschinenkonto-Kennwort Änderung ausschalten

Aero Glaseffekt unter allen Grafikkarten

Popup-Animation für die Fenster konfigurieren

Vista Style festlegen

"Minimieren"-, "Maximieren"-, "Schließen"-Buttons ändern

PopUp-Animationen durch die Shift-Taste verlangsamen

Office: Cliparts-Pfad festlegen

[08.02.2007]

Outlook 2007: Verbindung mit Exchange Server ohne Standardgateway

Direct3D-Renderung oder Software-Renderung benutzen

Verschwimm-Effekt für die Glasfenster aktivieren/deaktivieren

Skalierung der Icons und Schriftarten aktivieren/deaktivieren

Windows Desktopsuche: Nur gechachte Exchange Elemente indizieren

[02.02.2007]

Bestehende Partitionen verkleinern oder erweitern

Beschreibung der Funktionen von Diskpart

Internet Explorer: Abspielen von Sounds in Webseiten konfigurieren

Internet Explorer: Einstellung "Auf gesperrte Serverzertifikate überprüfen" aktivieren/deaktivieren

Internet Explorer: Einstellung "Verschlüsselte Seiten nicht auf dem Datenträger speichern" aktivieren/deaktivieren

Internet Explorer: Einstellung "Signaturen von heruntergeladenen Programmen überprüfen" aktivieren/deaktivieren

Internet Explorer: Automatisches Update von IE6 auf IE7 verhindern

Passwort im IE beim Inhaltsratgeber zurücksetzen

Benutzer-Konten-Steuerung (UAC) deaktivieren/aktivieren

Neue Funktionen zur Leistungssteigerung

Vista Versionen (Übersicht)

Vista-Tauglichkeit testen

Vista Testzeit von 30 auf 120 Tage verlängern

Mehrfache gleichzeitige Windows Anmeldungen limitieren

Geändert:

Installation von Windows Vista

Version 6.8 (tipp 2007+)

Info Mit der aktuellen Vista Beta 2 haben wir bereits angefangen, die Tipps durchzugehen und auf Funktionalität unter Vista zu testen. Bei über 2000 Tipps wird diese Umstellung noch etwas dauern.

Sollten Sie einen Tipp finden, welcher noch nicht für Vista gekennzeichnet wurde, aber unter Vista läuft, würden wir uns über eine entsprechende Information freuen.

Neu:

Aufruf von MsiExec.EXE (Parameter)

Autostartfunktion nur für bestimmte Laufwerksbuchstaben ausschalten

Die Windows Firewall konfigurieren

Drucker Hilfe-Link anpassen

Datum und Uhrzeit einfach unter Notepad einfügen

Aufbau des SDDL Formates

Nach "Join Domain" wird die GPO nicht geladen

Zeichenwiederholungsgeschwindigkeit konfigurieren

Strecken des Hintergrundbilds ist nicht mehr vorhanden

Werbeeinträge im Windows Messenger ausblenden

Parameter von Regedit

Fehlermeldung: Sie müssen den Computer neu starten, um die Installation eines Programms oder Updates abzuschließen

BIOS und Systeminformationen in der Registry

Vorschau von AVI-Dateien im Explorer

Aktualisierungsintervall der Uhrzeit (NTP)

Hilfetext auf der Anmeldeseite festlegen

Erweitertes Loging im GUI-Mode Setup aktivieren

Ruhezeit bis ein Systemwiederherstellungspunkt erstellt wird

Verbindung mit einer Dokumentbibliothek zum Windows SharePoint Services nicht möglich

"An Startmenü anheften" auch für Ordner

Fehler bei der Laufwerksverbindung nicht anzeigen

Windows Messenger - URL Konfiguration

Unsichere Emails nur als Text anzeigen

Startmenü alphabetisch sortieren (Menüstil neu)

Autoplay Blockliste pflegen

Werbefenster von Adobe Acrobat Reader deaktivieren

Ausführung aktiver Inhalte auf dem lokalen Computer zulassen (IE)

Startscripts während der Ausführung beim Login anzeigen

Dr. Watson - Inhalt und Typ der Dumpdatei festlegen

Update Berechtigungen konfigurieren

Farbige Markierungen für Eingabeaufforderung festlegen

Worttrennzeichen (Word separators) für Eingabeaufforderung festlegen

Imagegröße der Toolbar des Internet Explorers

Pfadsuche in der Adressleiste konfigurieren

Automatisches umwandeln von Backslash in Slash

Systemsteuerung über RUNAS aufrufen

Windows WGA-Echtheitsprüfung entfernen

REGEDIT zeigt nicht alle Einträge an

Beim Speichern von Exceldateien erscheint die Meldung 'Datei wurde geändert'

Autovervollständigung in der Dialogbox "Öffnen/Speichern" für Dateiname konfigurieren

Tab Taste für Autovervollständigung benutzen

"Verwaltung" im "Startmenü" konfigurieren

"Zuletzt Verwendete Dokumente" im "Startmenü" konfigurieren

Nur Rechner innerhalb der Workgroup anzeigen

Standardauthentifizierung über einen unverschlüsselten Kanal deaktivieren (WinInet)

Tab für 3DFX-Videokarten Übertaktung (Overclocking) einblenden

ImageReady 3.0: Anzahl der zuletzt geöffneten Dateien

Gleichzeitig laufende Prozesse für Access einstellen

Notepad Standardeinstellungen für Schriftzeichen

Statusbar in Notepad anzeigen

EPSON CD Druck Lochdurchmesser konfigurieren

Tab für GeForce Übertaktung (Overclocking) einblenden

Usernamen für die Anmeldung im Yahoo Messenger konfigurieren

Return-Taste vom Yahoo Messenger konfigurieren

URL Angaben im Yahoo Messenger konfigurieren

Symbolgröße für die Öffnen/Speichern Dialogbox in Office festlegen

Babylon - Onlineupdate konfigurieren

Babylon - Startbildschirm anzeigen

Button 'Herausgeber' in den Internetoptionen des Internet Explorers deaktivieren

Hinzufügen weiterer Seiten unter Sicherheit in den Internetoptionen des Internet Explorers ausblenden

Den Button 'Stufe anpassen' und 'Standardstufe' in den Internetoptionen des Internet Explorers ausblenden

Eintrag 'Temporäre Internetdateien' in den Internetoptionen des Internet Explorers ausblenden

Eintrag "Site Zertifikate" in den Internetoptionen des Internet Explorers deaktivieren

Button "persönliche Zertifikate" in den Internetoptionen des Internet Explorers deaktivieren

Wallet Funktion des Internet Explorers deaktivieren

'Connection Wizard' des Internet Explorers deaktivieren

Zusätzliche Icons zur Systemsteuerung hinzufügen

Inaktive Icons aus dem Systray ausblenden

Einstellungen für den Novell Network Client setzen

Remoteunterstützung anbieten

Automatische Bildgrößenanpassung konfigurieren

Start Menü Popup bei neuem Profil

Anzeige des Media Players anpassen (Skin)

Mediadateien im Media Player über das Internet suchen

URLs mit dem Aufbau http[s]://User:Passwort@domain im IE erlauben

Hintergrundbilder und -farben im Internet Explorer mit drucken

Anzeigen der Bild - Toolbar im Internet Explorer aktivieren

Sicherheit von Windows Scripting Host konfigurieren

Modem-Support für nicht unterstütze Modems (Unimodem)

Passwörter nicht in Klartext anzeigen

Verknüpfungen im gleichen Fenster öffnen

Ordneransicht beim hinzufügen von Favoriten automatisch öffnen

Dialogfenster im IE automatisch in einem neuen Tabreiter öffnen

Focus automatisch auf neuen Tabreiter im IE setzen

"Tabbed Browsing" im IE aktivieren

Überwachung des Windows-Sicherheitscenters konfigurieren

Meldungen des Windows-Sicherheitscenters konfigurieren

Digitale Signatur von Controls im IE überprüfen

Installation von Controls mit ungültiger oder fehlerhafter Signatur unterbinden

"Phishing Filter" des Internet Explorers konfigurieren

Temporäre Dateien beim Beenden löschen vom IE löschen

Geschützte Ordner freischalten

Suche in der MS-Knowledge-Base als Shortcut im Internet Explorer einrichten

Verschlüsselung für Anmeldung ausschalten (NT/Samba)

Nachrichten werden in Outlook nicht sofort versendet

Startzeit der Zeichenwiederholung konfigurieren

Anpassung "Outlook Heute": URL zur "Outlook Heute" Seite festlegen

Anpassung "Outlook Heute": Einbindung des Internet Explorer konfigurieren

Anpassung "Outlook Heute": Sortierkriterium für Aufgaben

Anpassung "Outlook Heute": Aufgaben ohne Fälligkeitsdatum anzeigen

Anpassung "Outlook Heute": Seite deaktivieren

Anpassung "Outlook Heute": Anzuzeigende Aufgaben

Anpassung "Outlook Heute": Anzahl der im Kalender anzuzeigenden Tage

Pfad für .OST und .PST Dateien unter Outlook festlegen

Indexsuche von Office konfigurieren

Installation von Windows Vista

Windows "System Recovery" (Wiederherstellungskonsole)

Setup Parameter von Windows Vista

Informationen über den BCD-Store

Integrierten Bildbetrachter ein-/ausschalten

Geändert:

Den Pfad im Arbeitsplatz 'Dateien von <%UserName%>' anpassen

Autologin beim Starten

CHM Hilfe Dateien werden nicht mehr angezeigt

Excel UNDO-Schritte einstellen

Logfile Einstellungen

Logfile Einstellungen vom Taskplaner

Systemkonfigurationsprogramm MSCONFIG.EXE

Nur aufgeführte Shell-Erweiterungen ausführen

Quickinfo für Icons

Dateien oder Verzeichnisse mit "reservierten" Namen löschen

Version 6.7 (tip1971+)

Neu:

Suche im Internet aus der Startmenüeintrag Suche entfernen

Analyse eines Bluescreens

Unbrauchbare Anzeige in der Softwareliste

Programmverknüpfung bei unbekannten Dateien verhindern

Websuche bei unbekannten Dateitypen deaktivieren

Windows Firewall-Einstellungen sichern

Lokalinstallationsquelle (Msocache) von Office konfigurieren

"Alte Dateien komprimieren" aus der Datenträgerbereinigung entfernen

Unbrauchbare Anzeige in der Softwareliste

Fehlerberichterstattung in Internet Explorer konfigurieren

Standardverzeichnis für Windows Brennprogramm anpassen

Standardwerte für die Suchoptionen einstellen

EULA vom Acrobat Reader automatisch akzeptieren

Websuche bei unbekannten Dateitypen deaktivieren

Netzwerktab im Mediaplayer ausblenden

Tatsächliche Brenngeschwindigkeit in Nero anzeigen lassen

Shell festlegen die gestartet werden soll

INI-File Mapping

Windows XP Home nach Windows XP Professional umstellen

Gruppenrichtlinieneditor und der Key 'Group Policy Objects' in der Registry

Kontextmenü um bestimmte Systemfunktionen erweitern

Routen finden mit Pathping

Remote Shutdowns des Computer Browser Service deaktivieren

Auto-Layout-Service ein-/ausschalten

"Ausführen als..." aus dem Kontextmenü entfernen

Peer-to-Peer Nertzwerkdienste deaktivieren

Seedserver festlegen

CD/DVD vollständig bedrucken (Epson 900/950)

Nachfrage zur Suche nach Gerätetreibern im Windows Update Service

Suche nach Gerätetreibern über den Windows Update Service deaktivieren

Benutzung des Offline-Adressbuch im Cached Mode

Entladen von Benutzerprofilen bringt Fehler bzw. dauert lange

CHM Hilfe Dateien werden nicht mehr angezeigt

Fehlermeldung bei der Benutzung des Windows Updateservices

Geändert:

USER Logfile für Fehlersuche aktivieren

Erweitertes Group Policy Log erstellen

Einschränken der Funktionen von GAST Usern

Updates für Windows 95, 98 und ME

Zugriff auf das Diskettenlaufwerk beschleunigen

Disketten und CD-ROM Zugriff auf aktuellen Anwender beschränken

Andere FAQ-Seiten im Internet

Ordnern andere Icons zuweisen

Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen

Automatische Windows-Updates (alt)

Sicherheit der Treibersignierung vorgeben

Funktionen der Dateien RUNDLL.EXE und RUNDLL32.EXE

RTF-Anhänge werden nicht als RTF erkannt

Version 6.6 (tip1747+)

Neu:

Liste der zuletzt geöffneten Programme im Startmenü

Den Eintrag 'Öffnen mit' im Kontextmenü bearbeiten

Der Tabreiter "Sicherheit" wird nicht angezeigt

Abbrechen des Login-Scripts verhindern

Pipelining Funktion in Firefox aktivieren

Timeout für Verbindungsabbruch einstellen

Elemente beim laden sofort anzeigen

Anzahl der gleichzeitigen Verbindungen

Reihenfolge des Laufwerksbuchstaben im Explorer

Öffnen von Freedocs im Exchange zulassen

Blockierte Dateianhänge unter Exchange in OWA zulassen

Kennwortänderung über OWA zulassen

"Updates Anzeigen" unter Software aktivieren

Schnelle Benutzerumschaltung und Willkommenseite konfigurieren

Dateien unverschlüsselt auf dem Server abspeichern

Aufbau einer 32-Bit-DOS Umgebung

Eine erforderliche Installationsdatei .CAB fehlt beim Office update

Der Tabreiter "Automatische Updates" ist doppelt vorhanden

USB-Geräte werden ab SP2 nicht korrekt vom Betriebssystem erkannt

Anpassung im Suchendialog ausblenden

Die Anpassungen des Browsers von anderen Anbietern unterbinden

Automatische Suche von DFÜ-Einstellungen verwenden

Anzeigen von Fehlermeldungen bei Proxyskript konfigurieren

"Einstellungen" der "Eingabehilfen" sichern

Assistenten für den Internetzugang deaktivieren

Popupverwaltung deaktivieren

URL-Liste der zugelassenen Popup-Seiten

Änderung der Zertifikateinstellungen deaktivieren

Autovervollständigung für Formulare deaktivieren

Autovervollständigung für Kennwörter deaktivieren

"Webeinstellungen zurücksetzen" deaktivieren

Systemabsturzermittlung deaktivieren

Die Add-On-Verwaltung deaktivieren

Verwaltung der Identitäten deaktivieren

Anlagen in Outlook Express blockieren

Tabreiter "Datenschutz" der "Internetoptionen" ausblenden

Remotedesktop-Freigabe deaktivieren

Anzeigen des Begrüßungsbildschirms deaktivieren

Automatische Installation von Add-On unterbinden

Automatische Überprüfung auf Softwareupdates unterbinden

Proxyeinstellungen pro Computer setzen

Sicherheitszonen: Benutzer können keine Einstellungen ändern

Sicherheitszonen: Benutzer können keine Sites hinzufügen/entfernen

Sicherheitszonen: Nur Einstellungen pro Computer verwenden

Benachrichtigung über neu installierte Komponenten deaktivieren

Abrufen von Medieninformationen verhindern

Automatisches Update unterbinden

Abruf von vordefinierten Radiosendern verhindern

Abruf von Medieninformationen zu Musikdateien verhindern

Konfigurationsdialog beim ersten Start des MediaPlayers nicht anzeigen

Die Erstellung einer Verknüpfung vom MediaPlayer in der Schnellstartleiste verhindern

Die Erstellung einer Verknüpfung vom MediaPlayer auf dem Desktop verhindern

Videobeschleunigung vom MediaPlayer deaktivieren

Aussehen (Skin) des MediaPlayers festlegen

Anchorfenster im Designmodus des MediaPlayers nicht anzeigen

Tabreiter "Datenschutz" im MediaPlayer ausblenden

Tabreiter 'Sicherheit' im MediaPlayer ausblenden

Codecs Download im MediaPlayer unterbinden

'Updates installieren und herunterfahren' nicht automatisch aktivieren

"Updates installieren und herunterfahren" nicht anzeigen

Clientseitige Zielzuordnung für Updates im Intranet aktivieren

Zeitabstand zur Aufforderung für einen Neustart konfigurieren

Neustart für geplante Installation verzögern

Suchhäufigkeit für automatische Updates

Wartezeit nach Systemstart bevor ein Update durchgeführt werden soll

Starten vom Windows Messenger nicht zulassen

Erweitertes Group Policy Log erstellen

Windows Installer mit System-Rechten ausführen

Windows Installer Suchreihenfolge für Installationsdateien

MSI Benutzerinstallation konfigurieren

Benutzersteuerung bei Installationen zulassen

Durchsuchen aus dem Windows Installer entfernen

Durchsuchen für Installationen mit erhöhten Rechten aktivieren

Entfernen von Updates nicht zulassen

Erstellen von Systemwiederherstellungspunkten von MSI deaktivieren

IE-Sicherheitshinweise für Windows Installer Skripts deaktivieren

Installation von signierten Updates durch Anwender nicht zulassen

Größe für den Basisdateien Cache konfigurieren

Patchverwaltung für Programme mit erhöhter Sicherheit zulassen

Installationen von Patches unterbinden

MSI Installations LOG Einstellungen

MSI Transformdateien an einem sicheren Speicherort ablegen

Strenge Updateregeln für MSI-Installation aktivieren

Verwendung von Wechselmedien bei erweiterten Rechten für Benutzer zulassen

Entsprechende Snap-Ins freigeben oder sperren

Den Menüeintrag 'Verwalten' aus dem Kontextmenü des Explorers ausblenden

Konfiguration der Menü-Animationseinstellungen sichern

Tastaturnavigationsanzeiger ausblenden deaktivieren

"Benachbarte Computer" nicht mehr in der Netzwerkumgebung anzeigen

Installation unter anderen Kontext verhindern

Netzwerkinstallation unter anderen Kontext erlauben

Bestätigungsdialog beim Löschen von Dateien anzeigen

Papierkorbgröße konfigurieren

Dialogbox "Datei öffnen Sicherheitswarnung" kommt beim öffnen von Dateien

Bewertung von Dateianlagen konfigurieren

Zoneninformationen in Dateianlagen nicht speichern

Alternate Data Streams unter NTFS

Entfernen der Zoneninformationen nicht zulassen

Antivirenprogramme beim Öffnen von Anlagen benachrichtigen

Ausführen von 16-Bit-Anwendungen unterbinden

Anwendungskompatibilitätsmechanismus ausschalten

Programmkompatibilitäts-Assistent ausschalten

Programmkompatibilitäts-Eigenschaftenseite entfernen

Aufzeichnung von Anwendungshilfeereignissen einschalten

Konfiguration der Ereignisanzeige für weitere Informationen

Installation vom IIS verhindern

Sicherheitscenter für Domänenrechner aktivieren

Internetzugriff durch Windows Media DRM verhindern

Benutzernamen aus dem Startmenü entfernen

Hinzufügen und Entfernen von 'Aktiven Elementen'

Active Desktop Hintergrundbild festlegen

Nur Bitmaps als Hintergrundbilder zulassen

Suchgröße im Active Directory konfigurieren

Filterleiste im Suchendialog einblenden

Ordner "Active Directory" ausblenden

Angegebene Systemsteuerungssymbole ausblenden

Nur angegebene Systemsteuerungssymbole anzeigen

Standardkategorie für "Neue Programme hinzufügen" festlegen

Bildschirmschoner aktivieren/deaktivieren

Bildschirmschoner festlegen

Kennwortschutz für den Bildschirmschoner aktivieren

Bildschirmschoner Startzeit einstellen

Den Eintrag 'Designs' aus dem Menü 'Eigenschaften der Anzeige' ausblenden

Änderung der Schriftgröße nicht zulassen

Ändern des Farbschemas verhindern

Zu ladende "Visuellen Stil" festlegen

'Point and Print' nur mit bestimmten Servern zulassen

Veröffentlichen von freigegebenen Ordner in der ADS zulassen

Veröffentlichen von DFS-Stämmen in der ADS zulassen

Suchzeit für DFS-Clients nach Domänencontrollern konfigurieren

Die Funktion "Offlinedateien" ein-/ausschalten

Fehlermeldung: "Meldung SU0013" bei der Installation von Windows

Maximalen Festplattenspeicher für Offlinezwischenspeicher festlegen

Dateitypen festlegen die nicht offline verwendet werden können

Den Tabreiter 'Anpassen' aus dem Explorer Eigenschaften entfernen

Dateien und Ordner für die Offlineverwendung festlegen

Dateien und Ordner für die Offlineverwendung sperren

Umgeleitete Ordner nicht automatisch offline verfügbar machen

Untergeordnete Ordner immer offline verfügbar machen

Offlinedateicache verschlüsseln

Umbenennen von LAN/RAS-Verbindungen zulassen

Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)

Zugriff auf die Komponenteneigenschaften einer LAN-Verbindung nicht zulassen

Zugriff auf die Komponenteneigenschaften einer RAS-Verbindung nicht zulassen

Zugriff zu "Erweiterte Einstellungen" im Menü "Erweitert" nicht zulassen

Entfernen/Hinzufügen von Komponenten für RAS/LAN-Verbindungen sperren

Zugriff auf die Eigenschaften einer LAN-Verbindung nicht zulassen

Aktivieren/Deaktivieren der Komponenten einer LAN-Verbindung

Ändern der RAS-Eigenschaften zulassen

Ändern der RAS-Eigenschaften nicht zulassen

Löschen von RAS-Verbindungen nicht zulassen

Löschen von RAS-Verbindungen zulassen

Herstellen und Trennen einer RAS-Verbindung nicht zulassen

Aktivieren/Deaktivieren einer LAN-Verbindung zulassen

Zugriff auf den Assistent für neue Verbindungen nicht zulassen

Umbenennen von LAN-Verbindungen zulassen

Umbenennen von RAS-Verbindungen zulassen

Umbennen privater RAS-Verbindungen nicht zulassen

Zugriff auf "RAS-Einstellungen" im Menü "Erweitert" nicht zulassen

Anzeige des Status aktiver Verbindungen nicht zulassen

Meldung "keine oder eingeschränkte Konnektivität" deaktivieren

Geändert:

Netzwerk Verknüpfungen nicht automatisch zum Ordner Netzwerkumgebung hinzufügen

Andere FAQ-Seiten im Internet

DHCP-Adressen unter Windows

Windows Installer (MSI) deaktivieren

Den Eintrag 'Eigene Dateien' vom Desktop und aus dem Explorer entfernen

Active Desktop aktivieren

'Aktive Elemente' nicht zulassen

Hinzufügen von 'Aktiven Elementen' unterbinden

Info Es wurden viele Tipps überarbeitet und ein Verweis (Pfad) auf die entsprechende Policy Einstellung in der GPO eingetragen. Dadurch kann diese Einstellung in der Gruppenrichtliniejetzt leicht gefunden werden.

Siehe auch "Neu in dieser Version".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1274.htm


CD-Schlüssel

Microsoft hat zuerst bei Windows 95-Software Codenummern eingeführt und diese dann bei Windows NT 4.0 übernommen. Man kann die Software also erst dann installieren, wenn die richtige Nummer eingegeben wurde.

Das Prüfverfahren:

Normale Version 10 Stellen:

xxx-NNNNNNN

Die ersten drei Stellen werden nicht geprüft. Die sieben letzten Ziffern (N) müssen eine Quersumme ergeben, die durch 7 restlos (x modulo 7 = 0) teilbar ist.

z.B.

1234567, weil 1+2+3+4+5+6+7= 28 und 28:7=4 Rest= 0

1111111, weil 1+1+1+1+1+1+1= 7 und 7:7=1 Rest= 0

OEM Version:

xxxyy-OEM-NNNNNNN-zzzzz

Die ersten 5 Ziffern sind folgendermaßen aufgebaut: xxx steht für den laufenden Tag im Jahr (001-366) und yy für das Produktionsjahr (Derzeit von 95-02).

OEM bleibt immer, die nächsten 7 Ziffern setzen eine durch 7 teilbare Quersumme voraus, wobei allerdings die ersten beiden Ziffern immer 00 bleiben müssen.

Die letzten 5 sind einfach eine laufende Nummer, die NICHT mit einer 0 beginnen darf.

Neuer CD-Schlüssel:

xxxx-NNNNNNN

Die sieben Ziffern "N" sind wie früher Modulo 7, die ersten 4 Ziffern "x" sind aber nicht mehr bedeutungslos.

Bekannt sind zwei Möglichkeiten:

0401 bezeichnet eine Vollversion

0402 bezeichnet eine Update-Version

Bei Frontpage kann man damit z.B. festlegen, ob eine Voll/Update-Installation vorgenommen werden soll.

Siehe hierzu auch: Produkttypennummern von Windows

Info Sollten Sie die Product-ID für lhre lizenzierte Software verloren haben, können Sie wie hier beschrieben verfahren. Installieren von illegal erworbener Software verstößt gegen das Urheberrecht!

Info Siehe auch: "Registrierung von Windows durchführen bzw. Produkkey ändern"

Info Für Windows XP finden Sie hier ein Programm womit Sie die Seriennummer auslesen können: http://www.michaelstevenstech.com/ViewKeyXP.htm

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0073.htm


Unterschiedliche Windows Betriebssysteme gemeinsam installieren

Es ist ohne große Mühe möglich, beide Betriebssysteme gleichzeitig zu installieren. Am leichtesten geht es, wenn Sie noch kein Betriebssystem installiert haben.

  1. Richten Sie Ihre Partitionen nach Belieben ein. Ich würde eine Partition für Windows 9x benutzen (das muss die erste Festplatte und die C-Partition sein) und eine extra Partition oder Festplatte für NT (NT ist es egal, wo diese Partition liegt). evtl. noch beliebige Datenpartitionen.
  2. Installieren Sie nun als erstes Windows 9x auf der C-Partition und richten Sie es nach Belieben ein. Wichtig ist, dass Sie die C-Partition nicht FAT32 formatieren, sondern auf Normal FAT belassen. NT kann mit FAT32 noch nicht umgehen (außer mit zusätzlichen Tools aus dem Internet)
  3. Nun installieren Sie NT/2000 auf der anderen Partition (ich würde dafür eine extra Partition benutzen, die ich dann auch noch NTFS formatieren würde, ist aber nicht zwingend notwendig)
  4. Bei der Installation wird NT/2000 feststellen, dass bereits ein Betriebssystem auf Ihrem Rechner installiert ist und dieses Windows im Bootmenü hinzufügen. Es wird nur ein paar wichtige Dateien in das ROOT-Verzeichnis der C-Partition legen (diese Dateien dürfen Sie NIE löschen!).

Nun haben Sie beim Booten ein Menü, mit dem Sie zwischen Windows 9x und NT/2000 wählen können.

Sie haben schon ein NT installiert und wollen nun noch nachträglich Windows 95/98 installieren?

Das geht nur, wenn die C-Partition eine FAT-Partition ist. Ist das der Fall, gehen Sie so vor:

  1. Erstellen Sie eine Rettungsdiskette
  2. Installieren Sie Windows 9x
  3. Nun booten Sie von den NT-Bootdisketten und lassen mit der Rettungsdiskette NT wiederherstellen, NT wird automatisch auch Ihr Windows in das Bootmenü mit einbinden.

Sie haben schon Windows 9x installiert?

Hier können Sie problemlos wie oben beschrieben vorgehen, wenn Sie nicht FAT32 einsetzen.

Info Siehe auch "Informationen über die Boot.INI" bzw. "Anderes Betriebssystem aus NT-Bootmanager starten"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0432.htm


Installationslaufwerk und -pfad ändern (Source-Daten)

Wenn man Windows installiert hat und dann den Laufwerksbuchstaben des Installationslaufwerkes ändert, sucht Windows bei nachträglichen Installationen immer auf dem falschen (ursprünglichen) Laufwerk.

Durch eine Änderung in der Registry können Sie dies aber verhindern. So können Sie z.B. die Windows-CD auf einen Server ablegen und Windows - bei einer nachträglichen Installationen - auf dem richtigen Laufwerk nach den Daten suchen lassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 95/98/ME

Unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup

gibt es den Eintrag "Sourcepath" als Datentyp REG_SZ. Hier geben Sie an, wo sich der Inhalt der Installations-CD befindet (CAB-Dateien).

Ab Windows NT

Hier gibt es zwei Einstellungen der Pfade, die sich auch noch in der Funktion im Vergleich zu Windows 95/98 unterscheiden.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion

und

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup

gibt es die Zeichenfolgen "Sourcepath" als Datentyp REG_SZ so wie "Installation Sources" als Datentyp REG_MULTI_SZ.

Dieses sind die Pfade zur Installation von anderen Produkten, die Windows nicht auf der eigenen CD sucht, also das Standardinstallationslaufwerk, wenn man Software installieren will.

Nun ist das lästige Ändern des Installationspfades nicht mehr notwendig.

Siehe auch "Standard-Installationspfade verändern".

Wie Sie den Pfad für die ServicePack Dateien verändern können, finden Sie im Tipp "Pfad für die Service Pack Dateien ändern"

Konfiguration über die Policy (Gruppenrichtlinie)

Diese Einstellung wird unter dem folgenden Schlüssel angelegt:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Setup

Hier finden Sie den Eintrag "SourcePath" als Datentyp REG_SZ. Dieser Pfad gibt an, wo WINDOWS die Original Installations-CD findet (I386-Verzeichnis).

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Windows-Installationsdateipfad angeben

Info Gilt die Konfiguration nur für den Windows-Dateischutz, wenn die Einstellung über die Gruppenrichtlinienobjekte erfolgt. Diese Einstellungen gelten nicht für Elemente, die das Setup-API verwenden, um die Installation durchzuführen. Wird die Einstellung dort benötigt, müssen Sie die oberen Registryeinträge dafür verwenden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=833615

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0076.htm


Software Einträge aus dem Menü "Software" löschen

Wenn Sie Software nicht über "Systemsteuerung" -> "Software" bzw. ab Vista "Systemsteuerung" -> "Programme und Funktionen" deinstalliert, sondern den Ordner selber gelöscht haben, werden diese Einträge nicht entfernt. Werden diese Einträge jetzt angeklickt, bekommen Sie nur eine Fehlermeldung, aber der Eintrag wird nicht gelöscht.

Das Löschen der Einträge per Hand ist natürlich auch möglich. Die Einträge finden Sie in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall

Löschen Sie hier einfach die nicht mehr benötigten Einträge.

Ab Windows NT finden Sie die Einträge auch noch unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall

Info Mit "Tweak UI 1.33" von MS können Sie solche Einträge einfach entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0184.htm


Standard-Installationspfade verändern

Standardmäßig möchte Windows immer alle Programme in "[Laufwerk]:\Programme" oder "[Laufwerk]:\Program Files" installieren, wobei [Laufwerk] dem Laufwerk des Windows Systemverzeichnisses entspricht.

Benutzer, welche eine eigene Festplatte bzw. Festplattenpartition für zu installierende Software eingerichtet haben, müssen immer den Pfad in der SetUp-Routine des jeweiligen Programms anpassen, was nicht nur lästig, sondern auch zeitraubend ist. Darum kann es sinnvoll sein, unmittelbar nach einer frischen Windows Installation diese Standard-Installationspfade auf die dafür vorgesehene Festplattenpartition umzubiegen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion

befinden sich die drei Einträge

  1. ProgramFilesDir als Datentyp REG_SZ
  2. ProgramFilesPath als Datentyp REG_EXPAND_SZ (bei NT/2000)
    bzw.
    als Datentyp REG_SZ (bei 9x/ME) (Installationspfad für zu installierende Programme)
  3. CommonFilesDir als Datentyp REG_SZ (Installationspfad für "Gemeinsame Dateien").

Diese Pfade können beliebig angepasst werden. Allerdings gibt es häufig auch Softwares, deren Installationsroutine diese Einträge nicht berücksichtigt.

Siehe auch "Installationslaufwerk und -pfad ändern (Source-Daten)".

Info Windows-Update macht Probleme beim Verschieben des "Program Files"-Ordners auf eine andere Partition : Die Updates können nicht mehr ordnungsgemäß installiert werden. Nur wenn ein Pfad auf der gleichen Partition angegeben wird, funktioniert Windows-Update korrekt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0685.htm


Mehrere W9x-Betriebssysteme auf einer Festplatte

Mehrere Windows 9x-Betriebssysteme auf einer Festplatte

Hier wird beschrieben, wie mehrere Windows 9x und ME Betriebssysteme auf einer Festplatte gleichzeitig installieren können.

Beispiel:

Windows 98 Work + Windows 98 Test

Windows 95 Work + Windows 95 Test

Windows ME Work + Windows ME Test

auf einer Festplatte - in logischen Laufwerken.

Die Zutaten:

  • Partition Magic 6.0 oder ein anderes geeignetes Programm zum Kopieren von Partitionen
  • XOSL Bootmanager (http://www.xosl.org)
  • Diverse Lizenzen :-)
  • W98 Bootdiskette mit CD-Rom Treiber, Format und Fdisk (upgedatet für HDs > 64GB)
  • XOSL-Bootdiskette.

Vorgehensweise:

  1. Windows 98 Fdisk: 1 Primäre (1GB, FAT32, "aktiv") und 1 erweiterte Partition anlegen (ohne logische Laufwerke).
  2. Windows 98 installieren (Setup /d /iq /is /it)
  3. PM 6.0 installieren
  4. Per PM die primäre Partition in die erweiterte Partition kopieren. W98 --> W98"
  5. Nach Windows Neustart "sys d:" ausführen [*1], Laufwerkname: W98-1-C
  6. XOSL auf C: installieren, alle logischen Laufwerke [W98" (W98-1-C)] verstecken
  7. Booten mit W98-Diskette
  8. Format C: /q
  9. Win95 (Windows ME,...) installieren (Setup /d /iq /is /it)
  10. XOSL auf C: installieren, primäre Partition (W95) verstecken, W98-1-C aktivieren
  11. siehe 4), W95 --> W95" (ME --> ME",...)
  12. siehe 5) W95-1-C (WME-1-C,...)
  13. weiter bei 6)

[*1] Windows ME benötigt kein "sys d:" (geht auch gar nicht).

Auf diese Weise kann man in den ersten 8 GB eine primäre Partition und bis zu sieben 1 GB große logische Laufwerke einrichten, die alle unabhängig voneinander bootbar sind.

Das komplette Partitionslayout kann dann folgendermaßen aussehen:

pp

ll-1s

ll-2s

ll-3s

ll-4s

ll-5s

ll-6s

ll-7s

ll-progs

ll-sys

ll-1d

ll-2d

ll-3d

ll-4d

ll-5d

ll-6d

ll-7d

pp = primäre Partition 1GB

ll-1s = logisches Laufwerk 1GB W98-1-C

ll-2s = logisches Laufwerk 1GB W95-1-C

ll-3s = logisches Laufwerk 1GB WME-1-C

ll-4s = logisches Laufwerk 1GB W98-2-C

...

ll-7s = logisches Laufwerk Rest bis 8GB RESERVE-1-C

*------- 8GB Grenze ------*

ll-progs = logisches Laufwerk xGB für Programme, die von allen Betriebssystem genutzt werden (jedesmal in den selben Pfad auf Laufwerk D: installiert ) APP-D

ll-sys = logisches Laufwerk xGB für gemeinsam verwendete Betriebssystemdaten (Temp, Swap, Temporary Internet Files,...) SYS-E

ll-1d = logisches Laufwerk xGB für "lokale" Daten W98-1-F

ll-2d = logisches Laufwerk xGB für "lokale" Daten W95-1-F

ll-2d = logisches Laufwerk xGB für "lokale" Daten WME-1-F

ll-2d = logisches Laufwerk xGB für "lokale" Daten W98-2-F

...

ll-7d = logisches Laufwerk xGB für "lokale" Daten RESERVE-2-F

Windows 98 "sieht":

Laufwerk C: | (ll-1s) | W98-1-C
Laufwerk D: | (ll-progs) | APP-D
Laufwerk E: | (ll-sys) | SYS-E
Laufwerk F: | (ll-1d) | W98-1-F

Win95 "sieht":

Laufwerk C: | (ll-2s) | W95-1-C
Laufwerk D: | (ll-progs) | APP-D
Laufwerk E: | (ll-sys) | SYS-E
Laufwerk F: | (ll-2d) | W95-1-F

usw.

Die Laufwerksbezeichnungen (Label) sind so gewählt, dass sie mit den Laufwerksbuchstaben übereinstimmen. So kann man schnell feststellen, welche Partitionen "zusammengehören".

Auf einer 20 GB großen Festplatte kann man beispielsweise folgende Partitionsgrößen wählen

ll-xs | = 1 GB
ll-xd | = 1 GB
ll-progs | = 4 GB
ll-sys | = 1 GB

Somit stehen jedem Betriebssystem sieben GB zu Verfügung.

Die Windows 98-Installation auf der primären Partition verwendet man z.B., um die anderen Partitionen zu verwalten. Dazu stellt man XOSL so ein, dass alle Partitionen sichtbar sind, wenn man von dieser Partition bootet.

Das mehrmalige Installieren von XOSL kann man evtl. durch eine geschicktere Vorgehensweise vermeiden (Setup-Schalter "/ir"?, XOSL in eigene Partition,...).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1270.htm


Mehrere Windows-Installationen auf einer Platte

Wer häufig Programme aus dem Web lädt und installiert, zermüllt sich bald das System mit DLL-Leichen und veralteten Registry-Einträgen.

Um das Problem zu umgehen, kann man eine Kopie des Windows-Ordners erstellen und bei Bedarf einfach unter DOS wieder umbenennen bzw. zurückkopieren.

In einer älteren c't (Ausgabe 17/98) findet sich eine elegantere Lösung, bei der man beim Start zwischen verschiedenen Windows Versionen (im Beispiel eine zum täglichen Arbeiten inkl. Web, eine zum Brennen und eine dritte zum Testen von Shareware) wählen kann.

Der Artikel ist unter http://www.heise.de/ct/98/17/086/nachzulesen. Die erforderliche Batch-Datei findet sich unter dem Link ftp://ftp.heise.de/pub/ct/listings/9909-192.zip.

Siehe auch: Mehrere W9x-Betriebssysteme auf einer Festplatte

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0859.htm


Installation von Windows 95

Selbst bei einer Update-Installation sollte man Windows 95 nicht über Windows 3.x installieren, sondern lieber Windows 3.x bis auf die Dateien WIN.COM und WINVER.EXE (werden zur Überprüfung der Update-Berechtigung benötigt) löschen.

Vor der Installation sollte man alle nicht benötigten Treiber und TSR-Programme aus der CONFIG.SYS und AUTOEXEC.BAT entfernen, da Windows 95 für fast alle Komponenten eigene Treiber installiert. Alte DOS - und Windows 3.x-Treiber verlangsamen das System und sollten daher nur verwendet werden, wenn man noch über keine Windows 95-Treiber verfügt. Es sollte auch kein ONTRACK-Treiber aktiv sein, da Windows 95 damit nicht einwandfrei funktioniert.

Verwenden Sie Utilities zur Anpassung von Monitor und Grafik-Karte, müssen Sie sie möglicherweise in den Konfigurationsdateien stehen lassen. Diese Programme sind bei hohen Auflösungen (ab 1024 x 768) oft notwendig. Wenn Sie sie entfernen, könnte es unter Umständen zu Bildflimmern führen.

Bei der Installation kann es Manchmal notwendig sein, den CACHE (SHADOW RAM/ROM, VGA) zu deaktivieren. SHADOW VGA RAM wird von Windows 95 nicht benötigt, da es die Grafik-Karte nicht über den BIOS ansteuert. Da Windows 95 den Boot-Sektor ändert, muss vor der Installation die Virus-Überprüfung in dem BIOS ausgeschaltet werden.

Man sollte die "Benutzerdefinierte Installation" wählen, da hier alle Einstellungen ebenfalls automatisch vorgenommen werden, man aber auch eingreifen kann (z.B. Zusatzprogramme installieren, die sonst nicht installiert würden).

Will man Windows 95 später deinstallieren, darf man das Windows 3.x- Verzeichnis nicht löschen und auch nicht Windows 95 darüber installieren. Man muss eine Startdiskette erstellen und dem Vorschlag, das alte System zu sichern, folgen. Dadurch wird der Ordner SYSBACK erstellt und Windows 95 lässt sich dann per UNINSTALL problemlos entfernen.

Bei der Installation wird, falls vorhanden, der Boot-Manager von OS/2 deaktiviert. Er kann aber per FDISK (aktive Partition festlegen) erneut aktiviert werden. Soll Windows 95 mit Windows NT koexistieren, muss nach der Installation das NT-Bootmenü per NT-Notfalldiskette restauriert werden. Das NT-Bootmenü kann anschließend mit einem Editor um weitere Einträge ergänzt werden.

Info Wenn man mehrere Partitionen hat: Windows 95-Setup mit "setup /T:Drv:\Verz" starten. Dann legt das Setup bei der Hardware-Erkennung auf dieser Partition (Drv:\Verz) die Temporärdateien an (wenn Drv:\Verz defragmentiert ist). Das ganze läuft dann wesentlich leiser (ohne nerviges Plattenknirschen) und schneller ab.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0183.htm


Installation, Optimierung von Windows 95 und erste Schritte

von Jürgen Vetter

Samstag, 20. April 1996

Dieser Text soll den ersten Einstieg in Windows 95 ein wenig erleichtern.

Die Installation

Vor der Installation sollte man unbedingt die Viruswarnung im BIOS abschalten!

Windows 95 setzt, wie Windows 3.x, ebenfalls auf DOS als Betriebssystem auf. Mit Windows 95 wird ein DOS 7.0 geliefert. Die Version 7.0 umfasst modifizierte Befehle für Windows 95. Einige DOS 6.0 Befehle wurden ersatzlos gestrichen.

Die bisherigen Dateien "SYSTEM.INI", "WIN.INI", "CONFIG.SYS" und "AUTOEXEC.BAT" sind für den Betrieb von Windows 95 nicht nötig. Windows 95 verwendet wie Windows NT eine Registrydatenbank. Programme, die für Windows 95 geschrieben wurden, werden mit Hilfe des Menüpunktes Software im Systemordner entfernt oder modifiziert. Ein manuelles Löschen ist nicht nötig und sollte erst gar nicht durchgeführt werden.

Die Installation von Windows 95 verwendet eine Hardwareerkennung. Diese Hardwareerkennung ist der Pferdefuß. Sie wird jedoch ideal unterstützt, wenn die Installation aus einem installierten Windows 3.11 geschieht. Hier kann das Installationsprogramm Informationen aus der SYSTEM.INI von Windows 3.11 benutzen. Demnach sollte man wie folgt vorgehen:

  1. DOS 6.x installieren
  2. Windows 3.11, nach Möglichkeit ohne weitere Anwendungen in der kleinsten Installationsvariante, also auch ohne Zubehör installieren.
  3. Unter Windows 3.11 keinesfalls besondere Grafikkartentreiber installieren.
    Für spezielle Hardware, die Windows 3.11 nicht kennt, ggf. Treiber installieren. Eine Creative SB16 Soundkarte wird von Windows 95 ohne Information von Windows 3.11 auf IRQ 10 statt auf IRQ 5 installiert. Man kann zwar die automatische Hardwareerkennung nach der Installation von Windows 95 für jedes Gerät deaktivieren und dann den IRQ von Hand ändern, doch ist diese Methode wenig empfehlenswert.
  4. Windows 3.11 starten. Nach Möglichkeit ohne exotische Speicherverwalter wie QEMM oder EMM386.
  5. Es sollten keine Anwendungen unter Windows 3.11, insbesondere im AUTOSTART-Ordner, aktiv sein.
  6. SETUP von der WINDOWS 95 CD aufrufen
  7. CD-Code eingeben. Der CODE wird an bestimmten Stellen mit dem Modulo 7 Verfahren geprüft. Es reicht daher folgende Eingabe 000-1234567. Dies gilt für derzeit alle erhältlichen Microsoft-Programme.
  8. Benutzerdefinierte Installation wählen. Dies ermöglicht die genaue Angabe der zu installierenden Komponenten.
  9. Startdiskette erstellen lassen. Diese muss zu einem späteren Zeitpunkt um die Gerätetreiber für das CD-ROM-Laufwerk erweitert werden. Diese Startdiskette fährt nur DOS 7.0 hoch, obwohl Windows 95 gemeldet wird.
  10. Die Erstellung eines Systembackups kann ignoriert werden. Die UNINSTALL-Funktion von Windows 95 funktioniert nur teilweise. Wesentliche Bestandteile bleiben erhalten. Ein einwandfreier Lauf des vorherigen Betriebssystems ist nicht immer gewährleistet.
  11. Nun können die Bestandteile der Installation ausgewählt werden. Hier ist z.B. die Installation eines PC-Netzwerkes für PC zu PC Kommunikation interessant, die Installation eines Netzwerkmonitors,Systemmonitors oder des BACKUP-Programms. Das Restore von Windows 95 via DOS -Prompt ist hiermit jedoch nicht möglich. Hierzu bietet sich derzeit nur das Programm ARCADE oder eine Kombination aus DOS 6.x BACKUP mit separater Sicherung der langen Dateinamen an.
  12. Zum Schluss werden noch die zu installierenden Hardwarekomponenten angezeigt. Eine Creative Soundkarte wird zwar nicht angezeigt, jedoch im 2. Schritt automatisch erkannt. An dieser Stelle kann man jedoch den unbekannten Bildschirm durch den tatsächlichen Bildschirm ersetzen. So mit wird DPMS von Anfang an unterstützt.
  13. Im nächsten Schritt erfolgt die Installation der Komponenten. Bei der Installation von Exchange kann man hier bei Vorhandensein einer digitalen Vermittlungsstelle von Pulse- auf Tonwahl umstellen.
  14. Bei der Einstellung der Zeitzone kann für Deutschland gewählt werden, ob Windows automatisch von Winterzeit auf Sommerzeit und umgekehrt umschalten soll. Hierbei gilt zu beachten, dass Microsoft die Umstellung in der Registrydatenbank fest verdrahtet hat und somit zu einem falschem Zeitpunkt auf Winterzeit zurückgeschaltet wird. Im Fidonetz werden jedoch bereits die entsprechenden Patches angeboten.

Erweiterte Installation

Nachdem Windows 95 installiert wurde, kann das System optimiert werden. Zunächst wirft man jedoch besser einen Blick auf den Gerätemanager. Hier werden Probleme, z.B. IRQ-Konflikte angezeigt. Hier sieht man auch, ob die Festplatten im 32 Bit- oder Kompatibilitätsmodus angesprochen werden. Bei Problemen mit der Installation hilft auf der einen Seite der Hardwareassistent von Windows 95. Nachdem die Basiskomponenten fehlerfrei installiert wurden, sollte man seine individuellen Hardwaretreiber installieren. Die meisten Hersteller bieten bereits entsprechende Windows 95-Treiber an:

Adaptec EZ SCSI

  • Hewlett Packard Druckerunterstützung HP5L, HP5P, etc.
  • Creative LABS Soundkarten SB16, etc.
  • ELSA GmbH

Diese Hersteller bieten die Treiber entweder bei Onlinediensten, im Internet, in Firmenmailboxen oder via Hotline an. Entsprechende Adressen erhält man z.B. auf Anfrage im Fidonetz in den Echos WIN95.GER, HARDWARE.GER oder weitere.

Erste Schritte und Optimierung der Installation

Nachdem nun die Grundvoraussetzungen für einen fehlerfreien Betrieb geschaffen wurden, kann das System weiter optimiert werden. Zunächst sollte man die STARTDISKETTE um wichtige DOS -Programme und DOS -Treiber erweitern. An erster Stelle steht wohl die Unterstützung von CD-Laufwerken. An dieser Stelle sei vermerkt, dass man auf einer VFAT-Partition auf keinen Fall alte DOS -Utilities, wie ein DOS 6.x SCANDISK anwenden darf. VFAT ist eine Erweiterung des FAT-Dateiformats, das lange Dateinamen unterstützt.

Nachdem eine Rettungsdiskette zur Verfügung steht, können zunächst die eigentlichen Startdateien von Windows 95 optimiert werden:

  • An erster Stelle steht die Entfernung alter 16 Bittreiber für CD-Laufwerke oder andere Geräte.
  • Als nächstes sollte man die unsinnigen MODE-Befehle
  • und die Zeile COUNTRY.SYS aus der CONFIG.SYS und AUTOEXEC.BAT entfernen.
  • Auch HIMEM.SYS und andere Speichertreiber haben hier nichts verloren.
  • Auf eine CONFIG.SYS kann im Prinzip komplett verzichtet werden.
  • Die AUTOEXEC.BAT ist nur für die Umgebungsvariablen von DOS -Programmen notwendig (z.B. für DOS -Spiele und Soundkartenunterstützung).
  • Der Tastaturtreiber ist nur für DOS -Fenster unter Windows 95 interessant. Gleiches gilt für DOS KEY.
  • Einen Maustreiber braucht man Grundsätzlich für DOS -Fenster-Sitzungen nicht.
  • Neben dem automatischen Laden von Treibern werden auch Programme automatisch gestartet. Das Laden von SETVER kann man nur verhindern, indem man dieses Programm löscht, verschiebt oder umbenennt.
  • Auch das Programm SHARE ist nicht notwendig. Seit Windows 3.x gibt es hierfür VSHARE als Programm.

Beim ersten Start von Windows 95 wird eine BOOTLOG.TXT erstellt. Hier werden einige Treiber oder Programme nicht geladen. Das ist nicht weiter schlimm. Windows 95 versucht z.B. automatisch einen Treiber für ein erweitertes BIOS (EBIOS) zu laden. Die Hardwareerkennung lässt sich nur nicht generell abschalten. Für bestimmte Komponenten kann Sie jedoch über den Gerätemanager deaktiviert werden. Dies erfolgt unter GERÄTEMANAGER\GERÄT\EIGENSCHAFTEN\TREIBER.

Die oben genannten Dateien können wie bereits bei Windows 3.11 mit dem Programm SYSEDIT editiert werden. Die Registrydatenbank wird mit dem Programm REGEDIT.EXE editiert. Hier ist jedoch Vorsicht geboten. Jede Änderung kann dazu führen, dass Windows 95 nicht mehr startet. Die Eigenschaften beim Startvorgang werden in der Datei MSDOS .SYS definiert. Diese Datei kann mit diversen Sharewareprogrammen modifiziert werden. Informationen zu Windows 95 findet man in den Textdateien im Verzeichnis C:\WINDOWS oder auf der Windows 95-CD im Verzeichnis HELPFILE im Ordner ADMIN.

Auf der Windows 95-CD sind noch weitere Schätze verborgen. So findet man hier das Programm CHANGECP. Dieses Programm ermöglicht die Umstellung der Codepage für DOS -Sitzungen von 850 auf 437. Nach der Umstellung werden alle Zeichen wieder korrekt angezeigt. Jedoch wird hierbei die Datumsanzeige von TT.MM.JJ auf MM-TT-JJ umgestellt.

Außerdem findet man auf dieser CD einen Winword-Dokumenten-Betrachter, ein Logdateien-Anzeigeprogramm und last but not least das Programm Emergency Recovery Utility. Dieses Programm sichert alle wesentlichen Systemdateien und ermöglicht das Zurückspielen vom DOS PROMPT. Vor der Änderung der Registrydatenbank unbedingt anwenden. Weiterhin findet man hier ein Programm zur Sicherung der langen Dateinamen bei der Verwendung von alten DOS -Utilities. Dies ist jedoch nur bedingt brauchbar. Hier bieten sich bereits entsprechende Sharewareprogramme an, die dann auch von einem DOS 6.x gestartet werden können.

Nachdem die Codepage geändert und evtl. ein Bootmenü eingerichtet wurde, sollte das System weiter optimiert werden.

Installation der POWERTOYS

Das ist eine Programmsammlung von Microsoftmitarbeitern. Sie ermöglichen die Modifizierung der Windows 95-Starteigenschaften, das Beschleunigen des Menüaufbaus, das Verhindern des Textes "Verknüpfung mit" bei der Erstellung von Verknüpfungen und viele weitere Dinge. Für diese Einstellungen ist das Programm TWEAK UI verantwortlich.

  • QUICKRES ermöglicht den Wechsel der Bildschirmauflösung ohne Windows neu zu starten. Evtl. muss jedoch vorher jeder Grafikmodus einmalig durch das Grafikkartenprogramm gespeichert werden (ist bei der ELSA WINNER 2000avi nötig).
  • TARGETS ermöglicht den Menüpunkt Eigenschaften auf das Originalobjekt aus einer Verknüpfung heraus.
  • CABVIEW ermöglicht die Bearbeitung von im CAB-Format komprimierten Archiven.
  • FLEXICD ist ein Ersatz für den CDPLAYER. Wen die automatische Erkennung beim Einlegen einer CD stört, der muss einmalig im Gerätemanager diese deaktivieren. Hierzu wählt man CDROM\EIGENSCHAFTEN\AUTOMATISCHE ERKENNUNG aus und deaktiviert den Button. Nebenbei sind alle Buttons mit einer Onlinehilfe unterstützt.

Anmerkung:

Die Powertoys sind jedoch für die englische Version von Windows 95 gedacht. Man muss also alle Verknüpfungen aus STARTUP in AUTOSTART schieben und ACCESSORIES in ZUBEHÖR\MULTIMEDIA schieben. Hierzu wählt man den STARTBUTTON der Taskleiste mit der rechten Maustaste an und wählt den Menüpunkt öffnen. So lässt sich auf einfachem Weg via Drag´n´Drop das Menü unter dem Startbutton modifizieren. Man kann hier Verknüpfungen verschieben, löschen und erstellen. Dies ist wesentlich einfacher als der Menüpunkt START\EINSTELLUNGEN\TASTKLEISTE\PROGRAMME\ERWEITERT\DURCHSUCHEN. Allerdings kann man hier einmalig das Aussehen der Taskleiste verändern. So kann man die Symbole verkleinern und die Taskleiste bei nicht Benutzung verschwinden lassen und wenn die Maus an den Bildschirmrand geführt wird wieder aktivieren. Die Taskleiste selber kann an allen 4 Seiten des Bildschirms installiert werden. Einfach linke Maustaste halten und dann zum jeweiligen Seitenrand bewegen. Mit der rechten Maustaste auf der Taskleiste kann man sehr schnell alle Fenster minimieren.

Wer die Kontrolle über alle Tasks haben möchte, sollte sich TASKMAN in das Startmenü oder in die AUTOSTART legen. Hierbei sollte man natürlich nur eine Verknüpfung anlegen. Taskman ermöglicht das selektive Beenden mehrerer oder aller Tasks.

EXPLORE FROM HERE ermöglicht das Öffnen eines weiteren Fensters. Das ist nichts Neues, doch ein solches geöffnetes Fenster kann mit gedrückter Shift-Taste derart geschlossen werden, dass auch alle zu diesem Fenster geöffneten Fenster geschlossen werden.

Fenstereinstellungen

Die Sicht auf ein Fenster kann man ebenfalls beeinflussen. Unter dem Menüpunkt Anzeigen gibt es die Optionen:

  • alle Dateien anzeigen
  • Symbolleiste
  • Sortierung der Dateien
  • Verknüpfungen von Programmen zu Dateiendungen löschen oder umstellen

Wer jedoch nicht möchte, dass eine Datei mit einem bestimmten Programm geöffnet wird, nutzt erneut die rechte Maustaste bei gedrückter Shift-Taste. Nun ergibt sich der Menüpunkt "Öffnen mit". Hier kann man nun einmalig oder dauerhaft die Datei mit einer bestimmten Endung mit einem Programm starten. Eine weitere elegante Möglichkeit bietet der Menüpunkt SENDEN AN. Im Verzeichnis SENDTO im Windows Hauptverzeichnis stehen Verknüpfungen zu Programmen, die dann im Menüpunkt "SENDEN AN" angeboten werden.

Verknüpfungen erstellen

Am Beispiel des Menüpunktes SENDEN AN wird nun eine Verknüpfung erstellt. Der Vorgang ist ebenso einfach wie unter dem Konkurrenzbetriebssystem OS/2. Im Gegensatz zu OS/2-Referenzen werden jedoch die Eigenschaften des Originalobjektes bei Windows 95-Verknüpfungen nicht vererbt. Hierzu muss man also Grundsätzlich mit dem Menüpunkt Eigenschaften (rechte Maustaste) diese erneut einstellen. Auch das Löschen des Originalobjektes bewirkt keine Löschung der Verknüpfung. Ebenfalls wird die Verschiebung des Originalobjektes nicht erkannt. Der Vorteil ist natürlich eine schnellere Oberfläche als die von OS/2. Wer die Powertoys mit TWEAK UI (s.o.) installiert hat, braucht sich keine Gedanken über den Text "Verknüpfung mit" machen.

Wie wird nun z.B. ein DOS -ASCII-Dateibetrachter installiert?

Nun, nötig ist so ein Betrachter, da DOS und WINDOWS unterschiedliche Zeichensätze verwenden.Hierfür bietet sich das betagte Programm LIST.COM an.

Verzeichnis mit der DATEI LIST.COM öffnen

  1. Verzeichnis SENDTO öffnen
  2. LIST.COM markieren, mit gedrückter linker Maustaste in das Verzeichnis SENDTO schieben und Maustaste loslassen. Es erscheint ein Menü. Der Menüpunkt "Verknüpfungen hier erstellen" ist bereits hervorgehoben. Diesen einfach auswählen und fertig ist die Verknüpfung.
  3. Nachdem die Verknüpfung erstellt ist, wählt man Eigenschaften an. Hier wird nun unter Programm "beim Beenden schließen" ausgewählt.

Nützliche Menüpunkte im Startmenü in der Taskleiste.

Auf die oben beschriebene Art und Weise kann man nun in der Startleiste nach Gruppen sortiert das Startmenü erweitern. Dieses öffnet man mit der rechten Maustaste und dem Menüpunkt "Öffnen". Jetzt erstellt man sich neue Ordner, z.B. Verzeichnisse, Laufwerke, Dokumente, Hilfe. Aus dem Ordner Arbeitsplatz markiert man mit einem Schlag alle Laufwerke und schiebt sie in den neuen Ordner Laufwerke. Dieser steht dann im Startmenü zur Verfügung. Das ermöglicht den schnellen Zugriffe auf die Laufwerke, auch dann, wenn der Bildschirm bereits mit Fenstern überfüllt ist. Im Ordner Verzeichnisse kann dann eine Verknüpfung zum Windows-, Download und Temp-Verzeichnis erstellt werden. Ebenso kann man sich ein Toolsverzeichnis erstellen oder die Systemdienste aus dem Verzeichnis PROGRAMME\ZUBEHÖR verschieben.

Weitere nützliche Programme

  • FOLDERSIZE ist ein Programm, was die Anzahl der Unterverzeichnisse und die Gesamtgröße eines Verzeichnis liefert.
  • WINGO schreibt sich in die Taskleiste und ermöglicht den schnellen Zugriff auf Verzeichnisse. Eine Beschreibung der Verzeichnis kann angegeben werden.
  • WINRAR ist eine Packershell für das Archivformat RAR und liegt bereits als 32 Bitprogramm vor.
  • WINSHIELD McAfee ist ein Virenscanner, der jede Dateioperation überwacht. Doch Vorsicht ist geboten. Die Macrovirenüberwachung für Winword funktioniert nur mit einer englischen Winword-Version.
  • WINZIP ist eine Packershell für Windows 95 für verschiedene Archivformate, exklusive RAR. Das ZIP-Format wird bevorzugt unterstützt.
  • WASTE zeigt den verschwendeten Plattenplatz bei großen Partitionen. Leider wird bei FAT und VFAT die Clustergröße einer Festplatte von der Größe der Partition bestimmt. Im Extremfall kann also eine 1kBgroße Verknüpfung 32kBPlattenplatz beanspruchen. Einziger Ausweg ist hier die Benutzung der Plattenkomprimierung mit DriveSpace oder der Plattformwechsel auf Windows NT oder OS/2.
  • CHKDSK for Windows zeigt alle Partitionbelegungen und Clustergrößen aller Festplatten an.
  • SNAPSHOT ermöglicht den direkten Ausdruck des Desktops, egal in welcher Größe, eines Ausschnitts oder eines bestimmten Fensters auf einem angeschlossenen Drucker.

Klangqualität verbessern

Windows hat zwar einen verbesserten OPL3-Treiber, doch warum sollte man diesen nutzen, wenn man etwas besseres auf der Soundkarte hat? Also Creative Labs Soundkartenbesitzer gehen in die Systemsteuerung\Multimedia und wählen ADVANCED WAVE EFFECTS für MIDI aus. Hier kann man auch die Aufnahmequalität von 22 kHz (Radioqualität) auf 44 kHz (CD-Qualität) erhöhen.

Hilfeunterstützung oder Dateisuche

Gerade für Anfänger oder Neueinsteiger ist die Hilfe ein absolutes Muss. Hier bietet sich natürlich erst einmal das Programm ONLINE-TOURS an. Einzelne Hilfen z.B. zu Programmen kann man auch in einem Menüpunkt unter dem START-BUTTON sammeln. Dabei ist das oben beschriebene Verfahren Verknüpfungen sehr hilfreich. Es wird zunächst wie beschrieben ein weiterer Ordner im Startmenü erstellt. Nun ruft man aus dem Startmenü den Menüpunkt Dateisuche auf. Neu an diesem Programm ist die Möglichkeit, ohne die sog. Wildcards zu arbeiten (z.B. *.DIZ). Werden die Wildcards weggelassen, so wird der komplette Dateinamen nach einem Teilstring durchsucht und im Ergebnisfenster angelistet. Die Suche mit Ergebnis kann man natürlich auch speichern. Die Speicherung erfolgt direkt auf der Arbeitsoberfläche. Für die Hilfesammlung wird nun HLP oder *.HLP eingeben. Das Ergebnis wird nun komplett in den gerade erstellten Ordner Hilfe geschoben. Hierzu wählt man den Menüpunkt BEARBEITEN\ALLE MARKIEREN aus. Wer lieber mit der Tastatur arbeitet, kann auch STRG A verwenden. Die nun markierten Dateien werden mit gedrückter linker Maustaste in den neuen Ordner verschoben. Jedoch muss man hier aufpassen. Das Menü zeigt Diesmal als Defaultaktion kopieren an. Hier muss man natürlich Verknüpfung erstellen auswählen. Andernfalls werden die Dateien dupliziert.

Schlusswort

Für Einsteiger sind sicherlich Bücher und Computerzeitschriften empfehlenswert. Meiner Meinung nach, ohne jetzt Werbung zu machen, bieten sich hier Bücher aus dem Hause DATA BECKER, die PC Praxis und PC Welt an. Tiefergehende Informationen findet man jedoch besser in Zeitschriften wie die c't, die jedoch sehr technisch ist oder direkt beim Microsoftverlag MICROSOFT PRESS.

An dieser Stelle noch einmal einen besonderen Dank an Jürgen Vetter, der mich mit seinen Infos immer hilfreich unterstützt hat. (gez. Frank Ullrich)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0186.htm


Installation von Windows verkürzen (Setup-Parameter)

Wenn Sie den Installationsvorgang verkürzen wollen, können Sie das Setup mit einigen Parametern starten: z.B. SETUP /IM /ID

Die wichtigsten Setup-Parameter:

/IM | Überspringt die Prüfung des Arbeitsspeichers
/ID | Ignoriert die Prüfung des Festplattenspeicherplatzes
/IS | Überspringt die Routineprüfung (Scandisk)
/IQ | Sucht keine querverbundenen Dateien
/IN | Startet Setup ohne Netzwerk-Setup-Modus
/IW | Lizenzabkommen muss nicht bestätigt werden
/IH | Überspringt die Registrierungsprüfung (funktioniert nur in der Beta-Version)
/IH | Scandisk im Vordergrund starten
/IX | Keine Überprüfung von unterschiedlichen Zeichensätzen
/IP x | Diverse Parameter möglich, interessant scheint nur /P G=n, wobei n die Informationsvielfalt bei der Hardware-Erkennung steuert, 0= keine (Default), 3= max. Infos statt nur des Balkens
/P J | Installation des Powermanagements (ACPI)
/T:d:\TEMP | In diesem Verzeichnis speichert Windows die Setup-Dateien temporär ab
/D | Eine bestehende Windows-Version wird beim Installieren ignoriert (Win.ini und System.ini)
/IL | Dieser Schalter bewirkt, dass eine Logitech Maus bei der Installation beibehalten wird
/C | Smartdrive wird nicht gestartet
/N | Setup ohne Maus durchführen
/IT | Keine Überprüfung auf laufende Hintergrund Programme (TSRs)
Windows 98 / ME
/NF | Die Aufforderung zum Entfernen der Diskette nach Beendigung des Kopierens wird nicht angezeigt. Die Option eignet sich für Besitzer einer bootfähigen CD-ROM von Windows 98 (OEM)
/IE | Es wird nicht nach dem Erstellen einer Notfalldiskette verlangt (wichtig für Laptopbesitzer, die kein Diskettenlaufwerk bei der Installation anschließen können). Der Ordner Windows\Command\EBD wird nicht angelegt
/NM | Es wird keine Prüfung der Mindestvoraussetzung vorgenommen und Windows 9x kann auch auf "schwachen" Rechnern installiert werden
/IR | Unterbindet das Neuschreiben des MBR bei der Installation
/NTLDR | Unterbindet die Suche nach bereits installierten Betriebssystemen
/IV | Unterbindet die Anzeige verschiedener "Werbe"-Grafiken während der Installation
/M | Unterbindet das Abspielen von ".wav" Dateien während der Installation
/NH | Hwinfo.exe wird nicht ausgeführt. Siehe auch "Detaillierte Hardwareinformationen mit HWINFO oder HWDIAG ermitteln"
/NX | Die Version der Setupx.exe wird nicht geprüft

Info Weitere Informationen zu den Setup-Parametern finden Sie unter:
http://support.microsoft.com/?kbid=186111

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0023.htm


Altes DOS nachträglich installieren

Legen Sie im Root-Verzeichnis Ihrer Festplatte das Verzeichnis DOS an und kopieren alle DOS-Befehle dorthin. Erstellen bzw. besorgen Sie sich eine DOS x.x - Bootdiskette, die alle Systemdateien enthält. Kopieren Sie dann folgende DOS x.x Dateien von dieser Diskette ins Hauptverzeichnis Ihres Boot-Laufwerks.

Im Rootverzeichnis müssen Sie allerdings die Endung der Dateien auf .DOS ändern. Wichtig ist, dass Sie den neuen Namen (mit der Extension.DOS ) schon beim Kopieren angeben, da es bereits Dateien mit den alten Namen gibt (von Windows). Diese werden ansonsten überschrieben.

COPY A:\MSDOS.SYS C:\MSDOS.DOS

COPY A:\IO.SYS C:\IO.DOS

COPY A:\COMMAND.COM C:\COMMAND.DOS

COPY A:\AUTOEXEC.BAT: C:\AUTOEXEC.DOS

COPY A:\CONFIG.SYS: C:\CONFIG.DOS

Für die Dateien MSDOS.DOS und IO.DOS müssen die Attribute R+S+H gesetzt werden. Danach trägt man in die Datei MSDOS.SYS unter [Options] BootMulti=1 ein. Nun sollte es möglich sein, durch Drücken von F4 DOS x.x zu starten. Um DOS zu starten, können Sie auch F8 drücken und im Start-Menü die Option "Vorherige DOS-Version" auswählen.

Info In der neuen Version von Windows 95 (B-Version) ist es nicht mehr auf diese Weise möglich.

Wollen Sie ein altes DOS unter Windows 95 B nachträglich installieren, machen Sie folgendes:

Tipp 1:

  1. Die Datei IO.SYS von Windows 95 auf WIN40.SYS kopieren.
  2. Im BootBlock (Block 0) mit einen Diskeditor IO.SYS auf WIN40.SYS ändern.

Info Sollten Sie Windows NT installiert haben, müssen Sie Punkt 2 an der Datei BOOTSECT.DOS durchführen.

Tipp 2:

Windows 95 B installieren

  1. "FDISK /MBR" und "SYS C:" von einer gebooteten Windows 95A Diskette aufrufen.
  2. "COPY IO.SYS C:\" und "COPY COMMAND.COM C:\" von einer Windows 95B Diskette ausführen.

Tipp 3:

Es gibt einen Programmierer, der für das Patchen des Windows 95B Bootsektors ein Programm geschrieben hat. Der Vorteil ist, dass es einfacher zu installieren ist und richtig funktioniert, wenn NT und damit eine BOOTSECT.DOS existiert.

Der Bugfix "W95BOOT V1.20" (25 KB) beseitigt den Multibootfehler von Windows 95B mit DOS, selbst wenn Windows NT auch installiert ist (BOOTSECT.DOS Datei)

Die URL für den Download:
http://www.ing-steen.se/share/pcprog/win/app/w95boot.zip

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0021.htm


Automatisieren und Anpassen des Windows Setup

Automatisierung und Anpassen des Windows Setup

Der Aufbau der Datei "MSBATCH.inf" wird extra beschrieben!

Info Wem die nachfolgend beschriebenen Abläufe zu kompliziert oder unverständlich erscheinen, dem rate ich davon ab, derartige Änderungen vorzunehmen. Ich hafte für keine Probleme, die daraus entstehen könnten.

Als Vorbereitung für alle Anpassungen am Setup, die über das Ändern von inf-Dateien erfolgen, müssen zunächst die "LAYOUT.inf" und die "SETUPPP.inf" aus der "PRECOPY2.cab" ins Setup-Verzeichnis extrahiert werden.

Das Setup-Verzeichnis von Windows muss also auf einem beschreibbaren Datenträger- wie Fest- oder Wechselplatte- kopiert werden. Die Unterverzeichnisse im Windows 98 sind nicht notwendig.

Erklärung zur LAYOUT.inf anhand Ihres eigenen Eintrags bei Windows 98.

Dateiname = Nummer der.cab,,Größe der Datei

Nummer = 0 --> steht im Setup-Verzeichnis

layout.inf=2,,107021

Für alle.inf-Dateien, die extrahiert und bearbeitet werden, müssen diese Einträge in den "LAYOUT.inf", "LAYOUT1.inf" bzw. "LAYOUT2.inf" angepasst werden.

Die LAYOUT-Dateien in der "LAYOUT.inf" sind mit falschen Größen eingetragen und sollten dort geändert werden, wenn sie ins Setup-Verzeichnis extrahiert wurden. Diese Größenangabe scheint aber zumindest nicht oder nur bei einigen der inf-Dateien überprüft zu werden. Durch die Korrektur der Größenangabe können aber mögliche Probleme von vornherein vermieden werden.

Für die "LAYOUT.inf" gilt es also - den Eintrag nach dem Extrahieren - folgendermaßen abzuändern:

layout.inf=0,,51374

(Größe kontrollieren, falls sie abweicht)

Zeichenketten, die zwischen zwei ' ' stehen, sind so, aber ohne diese ' ' zu suchen bzw. einzugeben!

1.a)

Eine kurze Auflistung der Dateien, die bei der nachfolgenden Beschreibung ausgeklammert werden können. In Klammern steht die jeweilige Platzeinsparung, die erzielt wird. Hinzukommt, dass die Verzeichnisse und Startmenüeinträge dieser Module nicht erstellt werden.

Windows 95(A)

MOS.inf | MS Network (1,9MB)
OHARE.inf | Internet Explorer 2.0 (1,7MB)

Windows 95B/C

MOS.inf | MS Network (2MB)
MSINFO.inf | Setups der Online-Dienste (<1MB)
OHARE.inf | Internet Explorer 3.0 (10MB)
ATHENA.inf | Mail & News Modul des IE3 (2MB)

Windows 98

OLS.inf | Online-Dienste (auch MS Network)
MSNCLNUP.inf | Updateprüfung für MSN (1MB)

Die Dateien "MSMAIL.inf", "INETMAIL.inf" und "AWFAX.inf" sind für MS Exchange.(Diese Dateien auszuklammern, bringt keinen Vorteil.)

Die "ATHENA.inf" bei Windows 98 ist für Outlook Express, welche aber beim Setup problemlos abgewählt werden kann. Den IE4 bei Windows 98 wegzulassen, wird durch die starke Integration dieser Komponente schwierig bis unmöglich. Die Frage ist dann auch, ob man dann nicht lieber doch gleich Windows 95 installieren sollte.

Auch wenn die Onlinedienste beim Setup abgewählt wurden, werden trotzdem Reste von MSN installiert. Dazu zählt bei Windows 98 eine Updateprüfung, die alle MSN Dateien von Windows 95, die in Windows 98 nicht mehr existieren, löschen soll. Sinnigerweise hat das Setup von Windows 98 hier auch gleich einen Bug. Wird kein Onlinedienst installiert, so wird das Verzeichnis 'Online Dienste' auch nicht richtig erstellt. Es erscheint dann nur mit seinem kurzen Namen 'Online~1'.

Wenn Sie mit MS BATCH 98 ein automatisches Setup erstellen, wird das AOL-Setup auch dann installiert, wenn es beim Erstellen der "MSBATCH.inf" abgewählt wurde.

Das Problem mit dem AOL-Setup lässt sich durch eine Korrektur im MS Batch 98 beheben. Dies wird unter MS Batch 98 Fehler mit beschrieben.

Mit den im Folgenden beschriebenen Änderungen werden dagegen die Online-Dienste komplett übergangen, so dass auch die Reste vom MSN und die Einträge in "Systemsteuerung/ Software/ Windows Setup" zum Nachinstallieren der Online-Dienste nicht mehr vorhanden sind.

Info Dies darf nicht ausgeführt werden, wenn ein Windows 98 Update über Windows 95 durchgeführt werden soll und dort einer der Online-Dienste installiert ist.

Änderungen:

  1. SETUPPP.inf und LAYOUT.inf öffnen
  2. Die oben genannten Dateien der Module suchen, die ausgeklammert werden sollen und ein ';' davor setzen. Bei der MSINFO.inf den Eintrag ändern. (siehe nächsten Absatz)
  3. Die Größenangabe der SETUPPP.INF und LAYOUT.inf in der LAYOUT.inf anpassen.
  4. Dateien speichern.

Da die MSINFO.inf bei Windows 95B nicht nur für die Setups der Online-Dienste zuständig ist, darf sie nicht komplett ausgeklammert werden, sondern muss als gekürzte Version mit ins Windows 95 Setup-Verzeichnis. Diese geänderte Version finden Sie schon fertig aufbereitet im Help-File: MSINFO.INF

Bei Windows 98 wird die MSINFO.inf nur noch für andere Zwecke verwendet, weshalb sie da nicht interessiert.

Wenn der Internet Explorer auf diese Weise vom Setup ausgeklammert wird, ist auch das Internetsymbol in der Systemsteuerung nicht mehr vorhanden. Es kann dort daher nicht mehr eingestellt werden, dass eine bestimmte DFÜ-Verbindung für den Internetzugang automatisch verwendet werden soll. Da diese Funktion aber auch für den Netscape geeignet ist, gibt es natürlich auch eine Möglichkeit, dies ohne den IE wieder zu aktivieren.

Es muss eine INETCPL.CPL und URL.dll ins \Windows\System kopiert werden. Diese kann man auf jedem PC mit IE finden. Die kleine kompakte Version vom IE2 reicht bereits aus.

Man findet diese Dateien natürlich auch in den Cab-Archiven des Windows-Setup.

Windows 95A: | INETCPL.CPL URL.dll | WIN95_16.CAB Win95_10.CAB
Windows 95B: | INETCPL.CPL URL.dll | WIN95_20.CAB Win95_08.CAB

Mit der kleineren URL.dll vom Windows 95B klappt es leider nicht. Was dort noch fehlt, weiß ich noch nicht. Die beiden Dateien vom Windows 95A funktionieren aber auch mit Windows 95B perfekt.

Außerdem muss man in der Registry noch die beiden folgenden Einträge hinzufügen und den PC neu starten. Der Schlüssel 'Autodial' muss evtl. erst erstellt werden. Am einfachsten ist es, sich die nachfolgenden Zeilen in eine Datei im Windows-Editor zu schreiben, die mit der Endung .REG gespeichert wird. Dann kann diese Änderung über einen Doppelklick auf die Datei automatisch durch den Regedit ausgeführt werden.

Inhalt der AUTODIAL.REG:

REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock\Autodial]

"AutodialDllName32"="url.dll"

"AutodialFcnName32"="AutodialHookCallback"

Über den Sinn, den IE2 bei Windows 95(A) wegzulassen, kann man sich streiten, aber bei mir liegen die Dateien und eine AUTODIAL.REG schon in einem Verzeichnis auf meiner Setup-CDR.

1.b)

Bei Windows 98 wurde das 'Plug and Play' von MS weiter verfeinert.

MS hat mit dem Tool inf-Installer auf der Setup-CD \tools\reskit\infinst ein gutes Werkzeug mitgeliefert, mit dem zusätzliche inf-Dateien hauptsächlich für neue PnP-Komponenten ins Setup eingebunden werden können. Aber da alle mitgelieferten Treiber die Versionsnummer und das Dateidatum von Windows 98 tragen, kommt es häufig vor, dass das Setup trotzdem seine eigenen Treiber installiert.

Bekannt ist mir dieses zur Zeit beim Tekram DC-390U und DC390F, bei denen Windows 98 (trotz Einbinden der neueren Treiber) seine alten Treibern installiert. Das Setup bemerkt gleich dazu "Neue Treiberversionen erforderlich" und crasht, wenn es von einem CDROM an diesem SCSI-Host installiert wird.

Ebenso werden wohl die aktuellen Treiber der Viper- und Vodoo-Karten ignoriert und die mitgebrachten verwendet.

In dem Fall können die inf-Dateien, die für die jeweiligen Treiber zuständig sind, genauso ausgeklammert werden, wie das oben beschrieben wurde. Da viele dieser Einträge nicht in der LAYOUT.inf sondern in der LAYOUT1.inf und LAYOUT2.inf zu finden sind, müssen in dem Fall evtl. auch diese aus der PRECOPY2.cab extrahiert werden.

Im Falle des Tekram SCSI-Host befindet sich das mit allen anderen unterstützen SCSI-Hosts in der SCSI.inf. User, die sich mit inf-Dateien auskennen, können also alternativ auch die SCSI.inf extrahieren und in dieser alle Einträge zu Tekram mit einem ';' deaktivieren.

und immer daran denken, die Einträge in den LAYOUT?.inf für diese Dateien dann zu ändern!

Wenn der inf-Installer einmal eine inf-Datei für eine PnP-Komponente installiert hat, legt er auch gleich zwei Unterverzeichnisse im Windows 98 Setup-Verzeichnis an.

Im wininf\ befinden sich jetzt die Hardware-inf-Dateien von Windows 98. Man kann diese nun also nach einem geeigneten Text (z.B. Hersteller der Komponente) durchsuchen, um so die richtige inf-Datei zu finden.

Im oldinf\ sollen vermutlich dann inf-Dateien abgelegt werden, bei denen der inf-Installer die neuen Treiber als aktuellere Versionen erkannt hat. Diesen Fall hatte ich aber noch nicht.

Beim eigentlichen Setup werden diese Verzeichnisse nicht mehr benötigt.

1.c)

Mit Hilfe des inf-Installers lassen sich auch so nützliche Tools wie Tweak UI gleich automatisch installieren.

Da Tweak UI bei der Installation sich immer mit einem Fenster "Introducing Tweak UI" melden, welches von Hand geschlossen werden muss, kann auch die inf-Datei des Tweak UI bearbeitet werden. Gerade wenn mittels MSBATCH.inf eine automatische Installation durchgeführt werden soll, ist das sonst sehr störend.

  1. Datei TweakUI.inf öffnen
  2. nach dem Text 'ITWEAK' suchen und vor die beiden Zeilen ein ';' setzen
  3. Datei speichern
  4. den inf-Installer ablaufen lassen

Wie sich gezeigt hat, hat MS auch einen Bug in Tweak UI für Windows 98 eingebaut.

Die Funktion "Create as File..." funktioniert nicht.

Die Tweak UI Beta3 für Windows 98 ist zwar etwas größer, hat aber die gleiche Versionsnummer wie die ausgelieferte Version. Sie weist aber diesen Bug nicht auf. Vermutlich hat der Programmierer beim Entfernen des Debug-Codes die Programmzeile für diesen Button mit entfernt.

Es ist kein Problem, die TweakUI.cpl gegen diese Beta3 auszutauschen.

2.a)

Was ist die MSBATCH.inf?

Es handelt sich hierbei um eine Datei, die das Setup von Windows wesentlich vereinfachen kann. Es können hier fast alle Einstellungen des Setup vorgewählt werdenund es ist möglich, damit eine manuelle, halbautomatische oder vollt.omatische Installation durchzuführen.

Auch .REG-Dateien, in denen bestimmte Einstellungen gespeichert sind, können (nur) bei Windows 98 mit eingebunden werden. Die Änderungen an der Registry werden dann am Schluss der Installation gleich mit vorgenommen.

Lediglich die Überprüfung der Update-Berechtigung kann nicht automatisiert werden. Wenn also ein Update verwendet wird und das angegebene Zielverzeichnis keine Windows-Version enthält, muss der Pfad mit der alten Installation bzw. den alten Setup-Dateien von Hand angegeben werden.

Diese Datei wird, wenn Sie im Windows-Setup-Verzeichnis vorhanden ist, automatisch verwendet. Sie kann aber auch einen beliebigen anderen Namen ( max. 8 Zeichen) haben und /oder in einem anderen Verzeichnis liegen.

In dem Fall muss ihr Name und das Verzeichnis der SETUP.exe als Parameter mit übergeben werden.

Auf der CD ist ein MSBatch-Tool, das unabhängig vom Resource Kit extra installiert werden muss.

bei Windows 95: \admin\nettools\bsetup

bei Windows 98: \tools\reskit\batch

Die Parameter der MSBATCH.inf werden in der

"Windows 95 Resource Kit Help" (Win95rk.hlp)

"Windows 98 Resource Kit Tools Help" (rk98book.chm)

sehr ausführlich beschrieben.

Einige der möglichen Parameter werden dort aber nicht erwähnt. Die mir bekannten Parameter beschreibe ich unter: Optional Components für MSBATCH.INF

2.b)

MS Batch 98 Fehler

Für das AOL-Setup:

In der OPTIONAL.ini nach dem Eintrag 'Entry1=America Online,0,AOL' suchen und diesen in 'Entry1=AOL,0,AOL' ändern.

Eine MSBATCH.inf die nun erstellt wird, wird diesen oben erwähnte Fehler nicht mehr aufweisen.

Einige Funktionen im MS Batch 98 funktionieren nicht so, wie es in der Hilfe steht bzw. einige Einstellungen stehen im MS Batch 98 nicht zu Verfügung, obwohl Sie in der Hilfe erwähnt werden oder zumindest in der MSBATCH.inf von Hand geändert werden können.

MS Batch Hilfe:

  • Desktop (Registerkarte im Dialogfeld "Allgemeine Setupoptionen")
    "Diese Optionen werden in der.inf-Datei gespeichert, jedoch nicht wieder eingelesen. Sie müssen diese Optionen beim Speichern der.inf-Datei jedes einmal manuell einstellen und zurücksetzen."
    Dieser Abschnitt ist falsch. Im Gegensatz zu der MS Batch 95 werden diese Optionen von MS Batch 98 beim Öffnen einer MSBATCH.inf wieder eingelesen.
  • Bildschirmeinstellungen (Registerkarte im Dialogfeld "Allgemeine Setupoptionen")
    Dieser dort erwähnte Registerkarte gab es im MS Batch 95, aber im MS Batch 98 fehlt sie völlig. Die dort erwähnten Einstellmöglichkeiten können aber nachträglich per Editor in die MSBATCH.inf eingetragen werden.
  • Gebietsschema (Registerkarte im Dialogfeld "Allgemeine Setupoptionen")
    Diese Einstellungen müssen immer kontrolliert werden. Wenn eine einmal erstellte MSBATCH.inf wieder bearbeitet wird, vergisst MS Batch 98 immer die Zeitzone.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0380.htm


Aufbau der Datei "MSBATCH.INF"

Hier werden die wichtigsten Parameter der MSBATCH.inf beschrieben.

Einige Parameter sind nur in einer bestimmten Windows-Version gültig.

Dies wird extra vermerkt. Andere Parameter werden von dem MS Batch 95/98 Tool erzeugt und sind so komplex, dass nicht weiter auf sie eingegangen wird.

Des weiteren soll dies nur eine Ergänzung zur Hilfedatei des Resource Kits sein. In dieser Hilfe sind die meisten der MSBATCH.inf Parameter beschrieben.

Getestet wurden die meisten Parameter mit

Windows 95 A OSR 1.0

Windows 95 B OSR 2.5

Windows 98 Update

Leichte Abweichungen bei den anderen Versionen

Windows 95 Update

Windows 95 Vollversion

Windows 95 B OSR 2.0 und 2.1

Windows 98 OEM

Windows 98 Vollversion

sind zwar möglich, aber nicht sehr wahrscheinlich.

Zunächst eine Auflistung der Setup-Schritte, wie sie beim "Windows 95 A OSR 1.0 (ProductType=1 in der SETUPPP.inf)" erfolgen. Darauf beziehen sich dann einige der Hinweise in der Parametererklärung.

  1. Start der SETUP.exe
  2. SaveRecovery (wenn ein abgebrochenes Setup festgestellt wird) {A}
  3. Abfrage der Systeminformationen {B}
  4. Verzeichnis wählen {C}
  5. Setup Modus {D}
  6. Benutzerangaben {E}
  7. Hardwareerkennung Ja (Alles) / Nein (einige Ausklammern) {F}
  8. Hardwareerkennung Audio - CDROM - Netzwerkkarte {G}
  9. Hardwareerkennung {H}
  10. Komponentenliste zur Auswahl anzeigen? {I}
  11. Komponenten auswählen {J}
  12. Netzwerk konfigurieren {K}
  13. Computereinstellungen {L}
  14. Startdiskette erstellen {M}
  15. Dateien kopieren {N}
  16. Neustart {O}
  17. PnP- und System-Konfiguration {P}
  18. einer oder mehrere Neustarts {Q}

{E} {F} {K} {L} werden nur bei InstallType=3 angezeigt.

{K} {Q} werden als einzige Punkte bei Express=1 noch von anderen Parametern beeinflusst. Alle anderen laufen bei Express=1 immer automatisch durch.

Das Setup kann mit den Parametern "setup /is /iw" gestartet werden.

/is (unterdrückt Scandisk)

/iw (unterdrückt das Anzeigen des Lizenzvertrages)

Bei Windows 98 kann die Funktion /iw auch in der MSBATCH.inf aktiviert werden.

;MSBATCH.inf

[Setup]

Dieser Abschnitt definiert das Verhalten des Setupvorganges über alle Schritte {A}-{Q} hinweg.

Express=0/1

Schaltet den automatischen Setupablauf aus/ein. Viele der anderen Parameter werden bei 1 mit ihrer Vorgabe verwendet oder ignoriert. Dieser Eintrag kann nur von Hand geändert werden.

Bei den folgenden Parametern wird bei Express=1 der angegebene Wert verwendet:

InstallDir="c:\windows"

{C}

Gibt das Zielverzeichnis für das Setup an. Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

InstallType=0/1/2/3

{D}

Legt den vordefinierten Installationstyp fest.

0=Minimal

1=Standard

2=Laptop

3=Benutzerdefiniert

Da bei 0-2 einige der anderen Optionen auch bei Express=0 nicht angezeigt werden und die zu installierenden Komponenten ohnehin weiter unten angegeben werden können, sollte dieser Eintrag auf 3 belassen werden.

Wenn der Abschnitt [OptionalComponents] vorhanden ist, haben die dort an- und abgewählten Komponenten ohnehin Vorrang vor den sonstigen Standardwerten. Dieser Eintrag kann bei Windows 95 nur von Hand, bei Windows 98 im MS Batch 98 geändert werden.

ProductKey="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Der Eintrag der Seriennummer von Windows 98.

Wird sie im MS Batch 98 mit eingetragen, dann wird sie bei einem automatischem Setup nicht mehr abgefragt.

Dieser Eintrag kann im MS Batch 98 eingegeben werden. Bei Windows 95 ist ein solcher Eintrag von Hand auch möglich.

EBD=0/1

{M}

0=Startdiskette wird nicht erstellt

1=Startdiskette wird erstellt

Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

ShowEula=0/1

0=Lizenzvertrag nicht anzeigen

1=Lizenzvertrag anzeigen

Gilt nur bei Windows 98

Dieser Eintrag kann im MS Batch 98 angegeben werden.

Die folgenden Parameter werden bei Express=1 ignoriert:

ChangeDir=0/1

{C}

0=das Zielverzeichnis kann nicht geändert werden.

1=das Zielverzeichnis kann geändert werden.

Dieser Eintrag kann nur von Hand geändert werden.

OptionalComponents=0/1

{I} {J}

0=das Anzeigen und Ändern der Komponentenliste ist abgeschaltet.

1=das Anzeigen und Ändern der Komponentenliste ist aktiviert und erlaubt.

Dieser Eintrag kann nur von Hand geändert werden.

Die weiteren Parameter sind im Allgemeinen nicht wichtig, weshalb ich sie hier nicht beschreibe.

Ich konnte bei einigen auch keinen Sinn erkennen, da eine Änderung keine Auswirkung hat. Bei den anderen ist eine Beschreibung in der Hilfe zum Resource Kit zu finden.

Die folgenden Parameter sind immer wirksam, unabhängig von der Express= Einstellung:

TimeZone="W. Europe"

Die Zeitzone, diese wird dann beim Setup nicht mehr abgefragt.

Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

NoPrompt2Boot=0/1

{Q}

0=Während der PnP- und System-Konfiguration werden die Neustarts nur nach Bestätigung durchgeführt.

1=Während der PnP- und System-Konfiguration werden die Neustarts automatisch durchgeführt.

Dieser Eintrag kann nur von Hand geändert werden.

[System]

{L}

Hier können die Voreinstellungen für das System-Setup eingetragen werden.

Monitor="Super-VGA 1024x768"

Hier kann der Monitortyp eingetragen werden.

Wenn hier der Eintrag "Plug & Play-Bildschirm (VESA DDC)" für den PnP-Monitor gesetzt wird, wird dieser auch beim Setup gleich richtig erkannt. Die hierfür notwendigen Einträge sind in den MONITOR?.inf Dateien im Abschnitt [Strings] zu finden.

Dieser Eintrag kann nur von Hand geändert werden.

DisplChar=16,800,600

Farbtiefe in Bit und Grafikauflösung, die während des Setups eingestellt werden soll.

Dieser Eintrag kann im MS Batch 95 eingegeben werden.

Bei Windows 98 ist dieser Eintrag nur von Hand möglich.

Mouse="Standard-PS/2-Maus"

Hier kann der Maustyp eingetragen werden, wie er in der Windows 98 Mausliste angezeigt wird. Dies ist aber in der Regel nur nötig, wenn Windows 95/98 die Maus sonst falsch erkennt. Oft wird dieser Wert aber auch dann ignoriert und Windows 95/98 installiert den seiner Meinung nach richtigen Treiber.

Dieser Eintrag kann nur von Hand geändert werden.

Locale=L0407

SelectedKeyboard=KEYBOARD_00000407

Diese beiden werden nur vom MS Batch 98 eingetragen.

[NameAndOrg]

{E}

Name="Benutzername"

Bei Windows 98 wird dieser bei installiertem Netzwerk auch als Vorgabe für die Benutzeranmeldung verwendet.

Fehlt dieser Eintrag, fragt das Setup auch bei Express=1 nach Name und Firma.

Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

Org="Firmenname"

Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

Display=0/1

0=Anzeige der Benutzerangaben immer übergehen.

1=Anzeige erfolgt, wenn Express=0 und InstallType=3 sind.

Dieser Eintrag kann nur von Hand geändert werden.

[Network]

{K}

Ist dieser Abschnitt leer und Display=0 wird die Netzwerkinstallation auch dann übergangen, wenn das DFÜ-Netzwerk mitinstalliert wird oder eine Netzwerkkarte gefunden wird.

ComputerName="Computername"

Workgroup="Arbeitsgruppe"

Description="Beschreibung"

Diese Einträge können im MS Batch 95/98 angegeben werden.

Display=0/1

0=Netzwerkkonfiguration nicht anzeigen

Es werden immer die hier eingetragenen bzw. vom Setup erkannten Netzwerkfunktionen installiert.

1=Netzwerkkonfiguration anzeigen

Dies ist nur bei InstallType=3 und unabhängig vom Express= wirksam.

Dieser Eintrag kann nur von Hand geändert werden.

PrimaryLogon=VREDIR/Windows

Vorgabe der Anmeldung beim Windows-Start

VREDIR=MS Client Netzwerk-Anmeldung

Windows=Windows-Anmeldung

'Windows' funktioniert nicht beim Windows 95 A.

Dieser Eintrag kann im MS Batch 95/98 angegeben werden.

Alle folgenden Einträge und Abschnitte werden vom MS Batch 95/98 vorgenommen bzw. werden in der Hilfe zum Resource Kit beschrieben, weshalb ich auf sie hier nicht weiter eingehe.

Änderungen sind dort nur Anwendern zu empfehlen, die sehr gute Kenntnisse haben und eine MSBATCH.inf für einen PC mit einer Netzwerkkonfiguration zur vollautomatischen Installation erstellen wollen.

[OptionalComponents]

"Eingabehilfen"=0/1

...

"Systemresourcen-Anzeige"=0/1

Hier steht die Liste der zusätzlichen Windows Komponenten.

0=wird nicht installiert

1=wird installiert

Die Einträge hierfür werden mit MS Batch 95/98 mit Hilfe der OPTIONAL.ini erzeugt. Zumindest bei Windows 95 haben diese Einträge Vorrang vor der InstallType= Einstellung.

Da das mir zur Verfügung stehende MS Batch 95 (von der deutschen Windows 95B OEM-CD) für die englische Version ausgelegt ist, funktionieren die darin enthaltenen englischen Einträge natürlich nicht. Ich habe daher die Liste dieser Einträge für Windows 95 A und 95 B in Abschnitt "Optional Components für MSBATCH.INF" zusammengefasst.

Beim MS Batch 98 ist nur der AOL-Eintrag fehlerhaft. Dies habe ich in "Automatisieren und Anpassen des Windows Setup" mit beschrieben.

[Printers]

Dieser Abschnitt wird vollständig vom MS Batch 95/98 erzeugt.

So muss er bei Windows 95 B und Windows 98 heißen.

[Drucker]

Bei Windows 95 A gibt es hier nun diese Falle.

Aus welchem Grund auch immer, muss er bei dieser Version die deutsche Bezeichnung haben. Dies muss man von Hand ändern.

Canon BJC-4000=Canon Bubble-Jet BJC-4000,LPT1

Das ist ein Beispiel, wie die Einträge aussehen.

[InstallLocationsMRU]

Dieser und alle folgenden Abschnitte werden vollständig vom MS Batch 95/98 erstellt

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0024.htm


Wozu dient die Datei SUHDLOG.DAT?

Windows legt bei der Installation im Hauptroot die Datei SUHDLOG.DAT an. Diese Datei enthält nur die Sicherheitskopie des Bootsectors und der alten Systemdateien.

Die Datei wird nur für eine Deinstallation von Windows benötigt und kann gelöscht werden, wenn Sie Windows nicht wieder deinstallieren wollen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0179.htm


Informationen über die Datei "DETLOG.TXT"

Wofür ist die Datei DETLOG.TXT?

Die Datei DETLOG.TXT ist eine ASCII-Textdatei, die Informationen über die während der Installation von Windows erkannte Hardware enthält. Sie enthält Informationen über benötigte I/O-Adressbereiche, benutzte Ressourcen (wenn diese erkannt wurden) und Fehlerbedingungen, die während der Erkennung aufgetreten sind. Diese Datei kann bei der Problembehebung von Nutzen sein, falls die Hardware-Erkennung während der Installation fehlschlug.

Struktur der Datei DETLOG.TXT

Bei der Installation wird während der Hardware-Erkennung jeder Schritt in die Datei DETLOG.TXT eingetragen. Sollte Ihr Computer dabei stehen bleiben, können Sie anhand des zuletzt ausgeführten Schrittes und des entsprechenden Eintrags in der Datei DETLOG.TXT den Fehler ermitteln.

Beginn der Datei DETLOG.TXT

[System Detection: 10/12/94 - 13:40:01]

Entspricht dem Datum und der Uhrzeit, zu der die Erkennung durchgeführt wurde.

Parameters="xxxxxx"

Zeigt die Schalter an, die in der Kommandozeile für das Installationsprogramm angegeben wurden. (z.B. SETUP /p xxxxxx).

Parameters "", Flags=01002233

SDMVer = ########

Gibt die Version der Datei SYSDETMG.DLL an. Das höherwertige Wort gibt die Windows-Version an (normalerweise 0400), das niederwertige Wort ist die Build-Nummer (hexadezimal). Für diese Version von Windows 95 sollte der Eintrag für SDMVer immer 040000bd sein.

SDMVer=040000bd,

WinVer = ########

Gibt die Umgebung an, in der die Erkennung ausgeführt wird. Die MS-DOS -Version wird im höherwertigen Wort und die Windows-Version im niederwertigen Wort angegeben. Windows 3.1 hat z.B. im niederwertigen Wort den Wert 030a, Windows für Workgroups 030b und Windows 95 0400.

WinVer=0614030b,

WinFlags =00000#1#

oder =00000#2#

1 =Ausführung im Standardmodus. Erkennung wurde aus dem Mini-Windows (z.B. während der Installation) gestartet.

2 =Ausführung im Erweiterten-Modus. Erkennung wurde aus Windows 3.1, Windows für Workgroups 3.1, Windows für Workgroups 3.11 oder Windows 95 gestartet.

WinFlags=00000c29

AvoidMem=#####h-#####h

Falls diese Zeile am Anfang der Datei DETLOG.TXT erscheint, werden dadurch Speicherbereiche in den Upper Memory Blocks (UMBs) angegeben. Die Erkennung umgeht diese UMBs.

z.B.: AvoidMem=cd4a0-cd50f

DetectClass: Skip Class Media

Die Erkennung hat keine Hinweise darauf entdeckt, dass im Computer eine Soundkarte eingebaut ist (kein Soundtreiber in der Datei CONFIG.SYS oder SYSTEM.INI). Dadurch werden alle Module zur Erkennung von Soundkarten übersprungen.

z.B.: DetectClass: skip class MEDIA

DetectClass: Skip Class Adapter

Die Erkennung hat keine Hinweise darauf entdeckt, dass im Computer ein proprietärer CD-ROM-Adapter eingebaut ist (z.B. Sony, Mitsumi und Panasonic).

DetectClass: skip class ADAPTER

DetectClass: Skip Class Net

Die Erkennung hat keine Hinweise darauf entdeckt, dass im Computer eine Netzwerkkarte eingebaut ist.

DetectClass: skip class NET

DetectClass Override:

Wenn eine oder mehrere Skip-Class-Zeilen, die oben aufgeführt sind, in der Datei DETLOG.TXT erscheinen, erhalten Sie im Assistenten für die Hardwareerkennung eine Abfrage, um diese Klassen zu überspringen. An dieser Stelle können Sie die getroffene Entscheidung ändern, indem Sie das entsprechende Kontrollfeld anwählen. Für jede Klasse, die Sie auswählen, wird eine Zeile zum Überschreiben der gefundenen Einstellung, in der Datei DETLOG.TXT eingetragen.

Custom Mode:

In dem Dialogfenster für die Hardwareerkennung, können Sie auswählen, ob Sie die während der Installation erkannte Hardware ändern möchten. Die Geräte, die Windows 95 nicht erkennen soll, erscheinen in der Datei DETLOG.TXT als CustomMode-Einträge.

CustomMode: resetting class MEDIA

CustomMode: resetting class ADAPTER

; Deselected via Detection Dialog

; Don't detect EtherLinkIII

CustomMode: DETECTELNK3=0

CustomMode: DETECTELNKII=0

CustomMode: DETECTELNKI=0

CustomMode: DETECTELNK16=0

CustomMode: DETECTELNKPLUS=0

; Don't detect The following video adapters

CustomMode: DETECTCIRRUSMMAPPED=0

CustomMode: DETECTWDLAPTOP=0

CustomMode: DETECTTSENG=0

CustomMode: DETECTTRIDENT=0

CustomMode: DETECTVGA=0

; Don't detect HardCard

CustomMode: DETECTHARDCARD=0

; Don't detect Parallel Port

CustomMode: DETECTLPT=0

; Don't detect the following CD-ROM drives

CustomMode: DETECTMITSUMI=0

Devices verified =

Gibt die Anzahl der Geräte an, die durch die Registrierung bestätigt wurden. Wenn die Zahl 0 ist, zeigt dies an, dass keine Registrierung existiert oder diese leer ist (bei Neuinstallation).

Devices verified: 0

Checking for system devices

Checking for:

Wenn die Erkennung nach einem Gerät sucht, wird der DETLOG.TXT ein Eintrag "Checking for:" hinzugefügt. Er wird gefolgt von einer Beschreibung des gesuchten Gerätes bzw. Geräte-Klasse. Wenn die Erkennung z.B. nach einem Gerät für den Programmable Interrupt Controller (PIC) sucht, wird der Eintrag "Checking for:" gefolgt von der Zeile QueryIOMem:, die den I/O-Bereich angibt, der geprüft wird, der Datei DETLOG.TXT hinzugefügt. Wird ein Gerät gefunden , wird eine Zeile "Detected:" angehängt, die Informationen über die verwendeten Ressourcen enthält.

Checking for: Manual Devices

Checking for: Programmable Interrupt Controller

QueryIOMem: Caller=DETECTPIC, rcQuery=0

IO=20-21,a0-a1

Detected: *PNP0000000 = [1] Programmable Interrupt Controller

IO=20-21,a0-a1

IRQ=2

QueryIOMem:

Beschreibt den Caller, rcQuery und den I/O-Bereich, der durch die Erkennung untersucht wurde.

Detected:

Diese Zeile wird hinzugefügt, wenn ein Gerät erkannt und bestätigt wurde. Anschließend werden die Plug and Play Geräte-ID, Beschreibung der Klasse und die zugewiesenen Ressourcen eingetragen.

Checking for: Manual Devices

Checking for: Programmable Interrupt Controller

QueryIOMem: Caller=DETECTPIC, rcQuery=0

IO=20-21,a0-a1

Detected: *PNP0000000 = [1] Programmable Interrupt Controller

IO=20-21,a0-a1

IRQ=2

Checking for: Direct Memory Access Controller

QueryIOMem: Caller=DETECTDMA, rcQuery=0

IO=0-f,81-83,87-87,89-8b,8f-8f,c0-df

Detected: *PNP0200000 = [2] Direct Memory Access Controller

IO=0-f,81-83,87-87,89-8b,8f-8f,c0-df

DMA=4

Detecting Net Cards

Checking for: Network Cards using Novell ODI Driver

Checking for: Network Cards using Novell IPX.COM

Checking for: EISA Cards

Checking for: Network Cards using Microsoft Windows

Checking for: Network Cards using Microsoft LanMan

PROTOCOL.INI Section in DETLOG.TXT

Wenn die Erkennung eine Datei PROTOCOL.INI findet, wird der Abschnitt der Netzwerkkarte in die Datei DETLOG.TXT übernommen.

Checking for: Network Cards using Microsoft Windows For Workgroups

; path to WFW protocol.INI

WFW: path=d:.ini

; protocol.ini mac driver section

Protocol.ini: [MS$EE16]

Protocol.ini: DriverName=EXP16$

Protocol.ini: IRQ=10

Protocol.ini: IOADDRESS=0x300

Protocol.ini: IOCHRDY=Late

Protocol.ini: TRANSCEIVER=Twisted-Pair(TPE)

Protocol.ini: netcard key=ms$ee16

NCD: detecting net card

Gibt an, dass die Erkennung eine Netzwerkkarte, welche schon früher korrekt erkannt wurde (normalerweise anhand des Eintrags in der Datei PROTOCOL.INI), gefunden hat. Da jedoch ein Modul für die Hardwareerkennung für diese Netzwerkkarte existiert, wird dieses Modul aufgerufen, um diese Karte zu bestätigen. Wird die Karte bestätigt, erscheint die Zeile "Detected".

NCD: detecting net card *pnp812d

QueryIOMem: Caller=DETECTWFW, rcQuery=0

IO=300-30f

Detected: *PNP812D000 = [9] Intel EtherExpress 16 or 16TP

IO=300-30f

IRQ=10

Protocol.ini: [ASYMAC]

Protocol.ini: Ports=1

Protocol.ini: MaxFrameSize=1514

Protocol.ini: CompressSend=1

Protocol.ini: CompressRecv=1

Protocol.ini: FramesPerPort=2

Protocol.ini: XonXoff=0

Protocol.ini: CompressBCast=0

Protocol.ini: netcard key=asymac

Detected: *PNP8387000 = [10] Microsoft Remote Access Driver

Weitere Überprüfung auf Systemgeräte

Die Erkennung fährt mit der Untersuchung der Systemhardware fort. Im folgenden Beispiel wird das Zeichen | in der Zeile IO= (z.B. IO=200-201 | 3e0-3e1) dazu benutzt, um damit einen Bereich von I/O-Einträgen anzuzeigen, der während der Erkennung überprüft werden soll. Die aktuelle Datei DETLOG.TXT enthält jeweils eine Zeile QueryIOMem: und IO= für jede überprüfte I/O-Adresse.

Bei den meisten Geräten werden mehrere (bei einigen sehr viele) I/O-Adressen überprüft. Dadurch kann eine detaillierte und sich wiederholende Liste mit Einträgen für die Erkennung entstehen. Um die Einträge zu verkürzen, werden alle überprüften I/O-Adressen zu einer Zeile zusammengefasst.

Jede Zeile IO= enthält üblicherweise nur eine Adresse (z.B. IO=200-201). Werden mehrere Adressen angegeben, so sind diese durch ein Komma getrennt (z.B. IO=3b0-3bb,3c0-3cf).

Checking for SCSI

Checking for: Acculogic EISApport SCSI Host Adapter

Checking for: UltraStor 24F/24FA EISA SCSI Host Adapter

Checking for: Adaptec AHA-174x EISA SCSI Host Adapter

Checking for: System Bus

Detected: *PNP0A03000 = [11] PCI Bus

Checking for: Advanced Power Management Support

Checking for: PS/2 Style Mouse

QueryIRQDMA: Caller=DETECTPS2MOUSE, rcQuery=0

IRQ=12

Detected: *PNP0F0E000 = [12] PS/2 compatible mouse

IRQ=12

Checking for: ATI Ultra Pro/Plus (Mach 32) Display Adapter

QueryIOMem: Caller=DETECTMACH32, rcQuery=0

IO=3b0-3bb,3c0-3df

QueryIOMem: Caller=DETECTMACH32, rcQuery=0

Mem=a0000-affff

Detected: *PNP090A000 = [13] ATI Ultra Pro (mach32)

IO=3b0-3bb,3c0-3df

Mem=a0000-affff

Checking for: Standard Floppy Controller

QueryIOMem: Caller=DETECTFLOPPY, rcQuery=0

IO=3f0-3f5,3f7-3f7

QueryIOMem: Caller=DETECTFLOPPY, rcQuery=0

IO=370-375,377-377

Detected: *PNP0700000 = [14] Standard Floppy Disk Controller

IO=3f0-3f5,3f7-3f7

IRQ=6

DMA=2

Checking for: Serial Communication Port

QueryIOMem: Caller=DETECTCOM, rcQuery=0

IO=3f8-3ff

Detected: *PNP0500000 = [15] Communications Port

IO=3f8-3ff

IRQ=4

QueryIOMem: Caller=DETECTCOM, rcQuery=0

IO=2f8-2ff

Detected: *PNP0500001 = [16] Communications Port

IO=2f8-2ff

IRQ=3

QueryIOMem: Caller=DETECTCOM, rcQuery=0

IO=3e8-3ef

QueryIOMem: Caller=DETECTCOM, rcQuery=0

IO=2e8-2ef

Checking for: Serial Mouse

Checking for: Generic IDE/ESDI Hard Disk Controller

QueryIOMem: Caller=DETECTESDI, rcQuery=0

IO=1f0-1f7 |3f6-3f6

Detected: *PNP0600000 = [17] Generic IDE/ESDI Hard Disk Controller

IO=1f0-1f7,3f6-3f6

IRQ=14

Checking for: Bus Mouse

QueryIOMem: Caller=DETECTBUSMOUSE, rcQuery=0

IO=23c-23f

Sonstige Hinweise:

Falls Sie Windows aus einer früheren Windows-Version heraus installieren oder den Hardwareassistenten aus der Systemsteuerung benutzen, ruft die Erkennung den Konfigurations-Manager auf, um die vorhandene erkannte Hardware anhand der Registrierung zu überprüfen.

Wenn Sie den Hardwareassistenten in der Systemsteuerung aufrufen und die Hardware automatisch erkennen lassen (was empfohlen wird), erzeugt die Erkennung eine neue Datei DETLOG.TXT.

Die Erkennung findet keine Geräte, wie z.B. ISAPnP-, PCI- und PCMCIA-Geräte.

Falls der Computer während der Erkennung stehen bleibt oder abstürzt und Sie die Installation erneut aufrufen (mit der Option SaveRecovery), hängt die Erkennung neue Informationen an eine vorhandene Datei DETLOG.TXT an, anstatt eine neue Datei zu erstellen. Führen Sie die Installation ohne die Option SaveRecovery aus und eine Datei DETLOG.TXT existiert bereits, wird die vorhandene Datei in DETLOG.OLD umbenannt. Es wird jeweils nur eine *.OLD-Datei gesichert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0178.htm


Versionsnummern von Windows 95/98/ME

Michael Broda (06.10.98)

Email: broda@uni-bremen.de

geändert/angepasst: F. Ullrich (13.09.01)

Windows 95/98 - Versions-Info

Da es teilweise etwas schwierig ist, die genaue Version von Windows 95 zu bestimmen, weil verschiedene Programme unterschiedliche Dateien zur Anzeige der Versionsnummer auslesen, wurde diese Versionsinfo zusammengestellt. Hiermit sollte es jedem möglich sein, die Versionsnummer zu bestimmen. Eine recht ausführliche, wenngleich nicht mehr ganz aktuelle Beschreibung dazu fand sich auch in der PC Welt 6/97.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die hier für die Versionen angegebenen Nummern beziehen sich auf den Eintrag "VersionNumber", der sich in der Registry im Schlüssel befindet:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion

Der nachfolgende Buchstabe bezieht sich auf die Angabe "SubVersionNumber"und gibt allgemein an, ob es sich um die Original-, die A-, eine der B- oder die C-Version handelt.

Alle anderen Anzeigemöglichkeiten geben nicht immer die korrekte Version wieder. Für die Anzeige unter "Systemsteuerung - System" wird die Version aus der Datei "User.Exe" ermittelt, wohingegen z.B. Norton System Info den Funktionsaufruf "GetVersionEx" benutzt. Bei Eingabe von "ver" am DOS -Prompt wird die Datei "Command.Com" ausgelesen.

Originalversion:

4.00.950

Dies ist die erste, originale Version von Windows 95. Das MS-DOS hat die Version 7.0. Sie wird überall mit dieser Nummer angegeben.

OEM Service Release 1 ("A-Version"):

4.00.950 a

Hierbei handelt es sich um das OEM Service Release 1. Durch Installation des Service Packs 1 auf die Original- Version erreicht man auch diese Versionsnummer. Unter "Systemsteuerung - System" wird das OSR 1 als 4.00.950a angegeben. In der DOS -Eingabeaufforderung wird nur 4.00.950 angezeigt und auch Norton System Info gibt noch "4.0 Build 950" an.

Hinweis: Eine Originalversion mit installiertem Service Pack 1 ist mit dem OSR 1 nicht vollkommen identisch, was die Dateien betrifft.

OEM Service Release 2 (ab hier "B-Version"):

4.00.1111 b

Dies ist das OEM Service Release 2, das es aber nicht als Update gibt.

Es ist aber möglich, die Installationsdateien zu modifizieren, so dass man die Komplett-Version doch zum Updaten benutzen kann.

Unter "Systemsteuerung - System" wird das OSR 2 als 4.00.950b angegeben. In der DOS - Eingabeaufforderung wird korrekt 4.00.1111 angezeigt. Ab dieser Version ist auch die MS-DOS Version 7.1 dabei. Die Datei "Io.sys" enthält einen Fehler, der dazu führt, dass der Treiber "Himem.Sys" 45 KB belegt, hierfür gibt es aber einen offiziellen Patch, der den Fehler behebt.

OEM Service Release 2.1:

4.03.1214 b

Dies ist das OEM Service Release 2.1, das die Unterstützung für den USB-Port bietet. Auf der CD ist einfach nur zusätzlich ein Verzeichnis, in dem sich die nachträglich zu installierenden Dateien für die USB-Unterstützung befinden. Ohne die Installation hat man ein ganz Normales OSR 2. ("Systemsteuerung - System" und DOS zeigen weiterhin "4.00.950b" bzw. "4.00.1111" an, Norton System Info gibt "4.0 Build 1212b" an.)

Anmerkung: Installiert man den USB-Support nicht, bleibt auch in der Registry die Nummer auf "4.00.1111".

Hinweis: Evtl. wurde die CD, die dann später nur noch in Verbindung mit der Internet Explorer 4.0-CD als OSR 2.5 B erhältlich war, bereits zuvor schon alleine, sozusagen als "OSR 2.1 ohne Io.sys-Fehler", herausgegeben.

OEM Service Release 2.5 B:

4.03.1214 b

Dies ist das OEM Service Release 2.5. Es unterscheidet sich vom OSR 2.1 nur darin, dass der Io.Sys-Fehler behoben ist. Der USB-Support muss weiterhin nachträglich installiert werden. Außerdem wird das OSR 2.5 in Verbindung mit einer CD, auf der sich der Internet Explorer 4.0 befindet, ausgeliefert.

Anmerkung: Installiert man den USB-Support nicht, hat man ein ganz 'Normales' OSR 2, auch in der Registry bleibt die Nummer auf "4.00.1111". Erkennbar ist das OSR 2.5 dann nur am neueren Datum der Dateien (01.05.1997) und an der Korrektur des Fehlers in der "Io.sys".

OEM Service Release 2.5 C ("C-Version"):

4.03.1214 c

Dies ist das letzte OEM Service Release, welches sich unter "Systemsteuerung - System" als C-Version meldet. Gegegenüber dem OSR 2.5 in der B-Version ist der Internet Explorer 4.01 nun mit auf der CD enthalten. Außerdem sind auf der CD ein zusätzliches Update zum USB-Support, das DirectX 5-Update sowie ein Treiber in einer neuen Version.

Anmerkung: Der "c"-Eintrag in der Registry wird von einer Setup-Datei vorgenommen. Bei den eigentlichen Installationsdateien wurde gegenüber der B-Version nichts geändert. Wie schon bei den B-Versionen wird der USB-Support nicht automatisch installiert, ohne ihn bleibt auch hier in der Registry die Nummer auf "4.00.1111". Erkennbar ist diese Version aber in jedem Fall am "c"-Eintrag.

Windows 98

4.10.1998

Standard Windows 98

Windows 98 SE (Second Edition)

4.10.2222 A

Diese Version gibt es bei MS als Update oder als neue Version. Geändert hat sich folgendes:

- Internet Explorer 5.0

- Windows Media Player 6.1

- DirectX 6.1

- Netmeeting 3.0

- Internet Connection Sharing
- Verbesserte Unterstützung für USB

- Unterstützung für IEEE 1394-Schnittstellen

- Device Bay-Unterstützung
- Wake on LAN

- Neue Energiesparfunktionen

Windows Millennium

4.90.2476

Beta

4.90.3000

Release

Zusätzliches (für "x" Buchstaben der jeweiligen Version einsetzen):

4.10.1423 x

Diese Nummer ergibt sich, wenn man einen Rip-Off aus der Beta-Version 1423 von Windows 98 installiert, der die sogenannten Memphis-Effekte hinzufügt. Die Version ist aber noch etwas fehlerhaft, wenn überhaupt, sollte man die Dateien der nächsten Version installieren.

4.10.1488 x

Diese Nummer ergibt sich, wenn man einen Rip-Off aus der Beta-Version 1488 von Windows 98 installiert, der die sogenannten Memphis-Effekte hinzufügt. Diese Datei geistert im Net herum, ich habe Sie allerdings nur in englisch, außerdem gibt es Probleme mit DirectX. ("Systemsteuerung - System" zeigt korrekt diese Nummer an, während DOS noch immer "4.00.1111" und Norton System Info noch immer "4.0 Build 1212b" anzeigt.)

Außerdem sollen die Versionen der OEM-CDs auch folgendermaßen zu erkennen sein: Auf der CD ist ein Datumscode aufgedruckt, eine vierstellige Zahl, rechts neben dem Loch, in der untersten Zeile links neben der Artikelnummer.

Original

Date-Code 0795

OSR 1

Date-Code 0196

OSR 2

Date-Code 0796

OSR 2.1

Date-Code 0397, außerdem Aufdruck auf der CD: "mit USB-Unterstützung"

OSR 2.5 B

Date-Code 0397, außerdem Aufdruck auf der CD: "mit USB-Unterstützung", dazu IE4-CD

OSR 2.5 C

Date-Code 1297, außerdem Aufdruck auf der CD: "mit USB-Unterstützung" sowie ein Microsoft-Hologramm am Loch.

Allgemein kann man die Änderung der Versionsnummern auch in etwa an folgenden Merkmalen festlegen:

Original

kein Kommentar :-)

OSR 1

kleines Update für das Original

OSR 2

nahezu neue Version mit vielen Änderungen (z.B. Fat32)

OSR 2.1

zusätzlich mit USB-Support

OSR 2.5

zusätzlich mit Internet Explorer 4.0

Wer noch weitere Updates kennt oder einen Fehler gefunden hat, sollte uns das bitte mitteilen - an die bekannte Email -Adresse( [image]). Ein Dank auch an alle User, die durch Unterstützung geholfen haben, diese Liste zu erstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0342.htm


Optional Components für MSBATCH.INF

Optionale Komponenten für MSBATCH.INF

Es folgen die optionalen Komponenten, die bei Windows in der MSBATCH.inf verwendet werden können.

0=wird nicht installiert

1=wird installiert

Liste für Windows 950 und 950 A

Liste für Windows 950 B

Dies ist die Liste für Windows 950 und 950 A

[OptionalComponents]

"Backup"=0

"Datenträgerkomprimierung"=0

"Defrag"=1

"Eingabehilfen"=0

"Microsoft Exchange"=0

"Microsoft Mail-Dienste"=0

"Microsoft Faxdienste"=0

"Microsoft Fax-Viewer"=0

"Audiodateien"=1

"Audiokomprimierung"=1

"Audiorecorder"=0

"CD-Wiedergabe"=1

"Lautstärkeregelung"=1

"Medienwiedergabe"=1

"Musica-Audioschema"=0

"Jungle-Audioschema"=0

"Robotz-Audioschema"=0

"Utopia-Audioschema"=0

"Videokomprimierung"=1

"The Microsoft Network"=0

"DFÜ-Netzwerk"=1

"HyperTerminal"=0

"PC-Direktverbindung"=1

"Wahlhilfe"=0

"Aktenkoffer"=0

"Desktop-Hintergrund "=0

"Dokumentvorlagen"=0

"Mauszeiger"=0

"Netzwerkmonitor"=0

"Online-Benutzerhandbuch"=0

"Paint"=1

"Rechner"=1

"Schnellansicht"=1

"Spiele"=0

"Systemmonitor"=1

"Systemressourcen-Anzeige"=0

"Windows 95-Tour"=0

"WordPad"=1

"Zeichentabelle"=1

"Bildschirmschoner"=0

"Flying Windows"=0

"Zusätzliche Bildschirmschoner"=0

Dies ist die Liste für Windows 950 B

[OptionalComponents]

"Backup"=0

"Datenträgerkomprimierung"=0

"Defrag"=1

"Eingabehilfen"=0

"Internet Mail-Dienste"=0

"Microsoft Exchange"=0

"Microsoft Mail-Dienste"=0

"Microsoft Faxdienste"=0

"Audiodateien"=1

"Audiokomprimierung"=1

"Audiorecorder"=0

"CD-Wiedergabe"=1

"Lautstärkeregelung"=1

"Medienwiedergabe"=1

"Multimedia-Audioschema"=0

"Videokomprimierung"=1

"The Microsoft Network"=0

"DFÜ-Netzwerk"=1

"HyperTerminal"=0

"Microsoft NetMeeting"=0

"PC-Direktverbindung"=1

"Wahlhilfe"=0

"Aktenkoffer"=0

"Desktop-Hintergrund "=0

"Desktop-Verwaltung"=0

"Dokumentvorlagen"=0

"Imaging"=0

"Mauszeiger"=0

"Netzwerkmonitor"=0

"Online-Benutzerhandbuch"=0

"Paint"=1

"Rechner"=1

"Schnellansicht"=1

"Spiele"=0

"Systemmonitor"=1

"Systemressourcen-Anzeige"=0

"Windows 95-Tour"=0

"WordPad"=1

"Zeichentabelle"=1

"Flying Windows"=0

"OpenGL-Bildschirmschoner"=0

"Zusätzliche Bildschirmschoner"=0

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0343.htm


Wie mache ich eine Installation von Windows wieder rückgängig?

Eine Deinstallation ist nur möglich, wenn bei der Installation die Option "Systemdateien sichern" ausgewählt wurde.

Unter Windows:

  1. Klicken Sie auf -> "Start" ->"Einstellungen" -> "Systemsteuerung"
  2. Doppelklicken Sie auf das Symbol "Software"
  3. Klicken Sie auf die Registerkarte "Installieren/Deinstallieren"
  4. Klicken Sie in der Liste der Software, die von Windows entfernt werden kann, auf "Windows 95"
  5. Klicken Sie auf die Schaltfläche "Hinzufügen/Entfernen" und befolgen die Anweisungen auf dem Bildschirm. Das Deinstallationsprogramm löscht nun alle langen Dateinamen von der Festplatte und ruft dann ein MS-DOS -Programm auf, das Windows entfernt und die früheren Systemdateien wiederherstellt.

Wenn Windows nicht geladen ist:

  1. Booten Sie den Rechner mit einer Windows-Startdiskette
  2. Geben Sie an der Eingabeaufforderung UNINSTALL ein

ODER:

  1. Starten Sie den Computer mit einer MS-DOS -Bootdiskette
  2. Wechseln Sie in Verzeichnis <Laufwerk>\Windows\Command
  3. Geben Sie UNINSTALL ein

Bei dieser Vorgehensweise werden die langen Dateinamen nicht gelöscht. Man muss danach ScanDisk aufrufen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0360.htm


Windows 3.x mit einer Windows Vollversion updaten

  1. Windows 3.11 aufrufen
  2. Dateimanager aufrufen
  3. Windows - Verzeichnis verstecken
    (dieser Schritt ist nicht unbedingt nötig)
  4. WIN.COM umbenennen
  5. DOS - Startdateien MSDOS .SYS, IO.SYS und COMMAND.COM löschen
    (dieser Schritt ist nicht unbedingt nötig)
  6. Win95-Startdiskette in Laufwerk A: einlegen
  7. Win95-CD ins CD-ROM Laufwerk einlegen
  8. Windows 3.11 verlassen (es kommt u. U. die Fehlermeldung: COMMAND.COM konnte nicht geladen werden... System angehalten...)
  9. Warmstart
  10. Bei der Frage, in welches Verzeichnis Windows 95 installiert werden soll, das WINDOWS-Verzeichnis angeben
  11. Fertig

Info Es ist aber besser, alles zu löschen und Windows neu zu installieren, ansonsten bleiben zu viele alte Dateien erhalten, die nicht benötigt werden oder gar zu Problemen führen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0361.htm


Windows auf eine neue Festplatte kopieren

Dieser Tipp beschreibt, wie Sie eine bestehende Windows 9x,ME Installation auf eine neue Festplatte kopieren können.

Neue Festplatte partitionieren und formatieren

  1. Windows starten und ein DOS -Fenster öffnen. Beachten Sie bitte, dass sich die Laufwerksbuchstaben der logischen Laufwerke einer evtl. vorhandenen erweiterten Partition der alten Festplatte ändern, solange die neue Festplatte angeschlossen ist.
  2. Xcopy c:\ d:\ /k/h/e/v/c/q/r (Die Fehlermeldung bezüglich WIN386.SWP kann man ignorieren)
  3. Festplatte als Bootplatte im neuen Rechner anschließen
  4. Mit einer Windows Bootdiskette booten, mit FDISK die primäre Partition "aktivieren" (sonst kann nicht von der Platte gebootet werden)und mit FDISK /MBR den neuen Bootsector übertragen.

Info Sie sollten aber die Hinweise unter: "Kopie von Festplatte auch mit kurzen Dateinamen" beachten und die Daten lieber damit kopieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0362.htm


Dualboot mit OS/2

OS/2 und Windows 98 vertragen sich ebenfalls - am einfachsten auf getrennten Partitionen mit dem OS/2 Bootmanager. Beide Partitionen müssen aber PRIMÄR sein.

Die kurzzeitige Deaktivierung des Bootmanagers während des Windows Setups lässt sich durch den Aufruf von FDISK und die Aktivierung der Bootmanager Partition wieder rückgängig machen.

Der OS/2 Bootmanager kann meines Wissens nach aber nicht zwischen primären FAT16 und FAT32 Partitionen wechseln.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0857.htm


Kopie des 'Windows' Ordners erstellen

Zur Sicherheit sollte man eine Kopie des Windows 98-Ordners incl. aller Unterverzeichnisse anlegen. Damit hat man ein lauffähiges Windows auf der Platte hat, falls eine Installation scheitert.

Dazu gibt man im DOS-Fenster von Windows 98 folgende Befehlszeile ein:

xcopy32 c:\windows\*.* c:\winsav\*.* /h/e/c/k >prot.log

Mit dieser Befehlszeile wird Windows in Winsav kopiert und eine LOG-Datei angelegt. Diese Befehlszeile kopiert alle Dateien incl. Subfolder und Dateiattribute. Zum Reaktivieren der gesicherten Version reicht ein einfaches

REN Windows winalt

Ren winsav windows

"/c" verhindert, dass Xcopy beim Zugriff auf Win386.swp einfach abbricht (diese Datei muss nicht mitkopiert werden, Windows erzeugt sie bei Bedarf neu);

"/e" kopiert alle - auch leere - Verzeichnisse;

"/k" sorgt dafür, dass Read-Only-Attribute erhalten bleiben und

/h" bewirkt, dass auch versteckte (System-) Dateien und Ordner mitkopiert werden.

Die Kopien lassen sich auch etwas bequemer mit anderen Dateimanagern anlegen, die sowohl lange Dateinamen beherrschen als auch System-Dateien und -Ordner nebst Attributen kopieren können. Dies empfiehlt sich vor allem für Besitzer älterer Windows-Versionen, denn der Schalter "/k" funktioniert erst ab Windows 95B.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0860.htm


Automatische Update-Benachrichtigung von "wichtigen" Updates konfigurieren

Wird für Ihre Windowsversion ein wichtiges Update zu Verfügung gestellt, werden Sie auf das Update hingewiesen, und Sie haben die Möglichkeit, das Update durchzuführen oder die Aktualisierung zurückzustellen. Standardmäßig fragt Windows nach einem Tag wieder automatisch nach, hier können Sie die Zeit einstellen, die bis zur nächsten Abfrage vergehen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ WindowsUpdate\ Critical Update

Erstellen Sie hier einen neuen Wert mit dem Namen "CurrentDelayInterval" als Datentyp REG_DWORD. Geben Sie hier die Zeit in Sekunden ein (Standard: 86400)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1615.htm


Unbrauchbare Anzeige in der Softwareliste

Wird die Anzeige unter „Start“ -> „Einstellungen“ -> „Systemsteuerung“ -> „Software“ leicht verstümmelt angezeigt (große Lücken oder schwarze breite Balken), liegt das an einer fehlerhaften Iconangabe in der Softwareliste.

Jeder Eintrag in der Softwareliste hat in der ersten Spalte ein Icon, welches in der Registry in Wert "DisplayIcon" angegeben wird. Wenn hier ein Icon angegeben wird, welches nicht vorhanden ist, kommt es zu dieser fehlerhaften Ansicht. Dabei ist auch ein beliebter Fehler, dass die Iconnummer mit einem Minus (-) davor angegeben sind, was aber fehlerhaft ist, da die Indexnummer immer bei 0 beginnen und keine negativen Werte enthalten können.

Um den fehlerhaften Eintrag zu finden gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall\

finden Sie für jede Software bzw. Fix von Microsoft einen entsprechenden Schlüssel (entweder wird der Programmname oder eine ID für das Software angezeigt). Sie müssen jetzt jeden Eintrag öffnen und dort den Wert "DisplayIcon" überprüfen. Dabei kann es sich um einen Eintrag handeln, der auf eine Datei verweist, die nicht mehr vorhanden ist oder um eine fehlerhafte Indexnummer.

Wenn Sie auf das Icon sowieso keinen Wert legen, können Sie einfach überall den Wert "DisplayIcon" löschen. Anschließend wird die Liste wieder übersichtlich, aber ohne Icons angezeigt.

Ansonsten können Sie auch folgendermaßen vorgehen:

  1. Gehen Sie jeden Eintrag durch und ändern Sie den Namen von "DisplayIcon" durch drücken von F2 in "_DisplayIcon".
  2. Öffnen Sie jetzt wieder in der Systemsteuerung den Eintrag "Software" und prüfen Sie, ob die Anzeige richtig ist (F5 zum Aktualisieren drücken).
  3. Das machen Sie so lange, bis Sie den Eintrag gefunden haben, anschließend können Sie die anderen Einträge wieder in "DisplayIcon" umbennen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1997.htm


Windows Installer (MSI) deaktivieren

Mit diesem Tipp können Sie die Verwendung des Windows Installers für die Benutzer einschränken oder ganz deaktivieren.

Sie können hier festlegen, ob Benutzer Software installieren dürfen oder nur Software installiert werden kann, die vom Administrator freigegeben wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableMSI" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

2 | Der Windows Installer ist deaktiviert
1 | "Nur unverwaltete Anwendungen" können nicht installiert werden. Das bedeutet, dass nur Anwendungen installiert werden können, die vom Administrator freigegeben wurden. Ist (Standard) ab Windows 2003
0 | Der Windows Installer ist aktiv. Ist (Standard) für Windows 2000/XP

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Windows Installer deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1544.htm


Windows Installer (MSI) Logfile Einstellungen

Mit dieser Policy stellen Sie ein welche Informationen alles in das LOG-File geschrieben werden. Das kann die Fehlersuche bei der Installation über MSI erleichtern wenn einen Installation einmal mit einem Fehler abgebrochen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "Logging" als Datentyp REG_SZ geben Sie hier folgende mögliche Werte ein.

(Wenn Sie mehr als eine Funktion wollen, hängen Sie die Buchstaben einfach aneinander Beispiel: voicewarmup)

Wert | Bedeutung
v | Erweiterte Ausgabe
o | Ausgabe wenn zu wenig Festplattenspeicherplatz
i | Statusnachrichten
c | UI Parameter
e | Alle Fehlermeldungen
w | Alle Warnungen
a | Startaktionen
r | Ausführende Records
m | Zu wenig Arbeitsspeicher oder Fehler
u | Usereingaben
p | Terminal Parameter
+ | Anhängen an vorhandene Logfile
! | Jede Zeile an das Protokoll anhängen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Protokollieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=223300

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1546.htm


Standardauswahl für Shutdown und Logoff einstellen

Welche Auswahl bei einem Shutdown oder Logoff von Windows standardmäßig angewählt sein soll, speichert Windows in der Registry. Das Verändern dieser Einstellung hat aber keine große Wirkung, da Windows bei jeder Abmeldung diesen Wert überschreibt. Hier schreibt Windows das hinein, was Sie beim letzten einmal ausgewählt haben. Diese Option ist beim nächsten Anmelden wieder die neue Voreinstellung.

Damit Sie aber trotzdem Ihren gewünschten Eintrag als Standardauswahl bekommen, erstellen Sie einfach eine REG-Datei. Diese REG-Datei rufen Sie nun über eine Batch-Datei mit der unten als Beispiel angegebenen Befehlszeile auf. Die Batch-Datei können Sie nun über den Autostart-Ordner bei jedem Systemstart aufrufen lassen und so wird jetzt Ihre Auswahl in die Registry eingetragen.

regedit.exe /s [REG-File-Name]

Durch Angabe des Parameters /S wird die Abfrage, ob diese Datei in die Registry importiert werden soll, unterbunden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Shutdown

finden Sie den Eintrag "Shutdown Setting" als Datentyp REG_DWORD, hier können Sie nun selber die Standardeinstellung festlegen:

Windows NT

0 | Logoff
1 | Systemabschluss
2 | Systemabschluss und Neustart
3 | Systemabschluss und Rechner ausschalten (muss vom Rechner unterstützt werden)

bei Windows 9x/ME und 2000 findet man diesen Key unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Windows 2000

0 | Herunterfahren
1 | USER Abmelden
2 | Herunterfahren
3 | USER Abmelden
4 | Systemabschluss und Neustart
10 | Stand-by-Modus (nur bei aktivem Powermanagement)
20 | Stand-by-Modus (nur bei aktivem Powermanagement), Netzverbindungen werden getrennt!
40 | Ruhezustand (Speicherinhalt wird auf der Festplatte abgelegt und der Rechner wird ausgeschaltet)
80 | Beenden der Terminal Server Verbindung, durch eine erneute Anmeldung kann die Session fortgesetzt werden.

Info Die Werte können sich je nach Betriebssystem unterscheiden, in der Tabelle sind die Werte für Windows NT bzw. Windows 2000 angegeben. Wollen Sie die Werte für Ihr Betriebssystem ermitteln, beenden Sie Ihr System einfach mit der gewünschten Einstellung. Starten Sie dann Ihr System neu und schauen Sie in der Registry nach, welcher Wert dort eingetragen wurde.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=193624

Info Die REG-Datei können Sie einfach mit dem "Registry System Wizard" (RSW) erstellen. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0671.htm


Internet Explorer wird beim Starten von Windows geladen

Wenn bei jedem Start von Windows der Internet Explorer automatisch gestartet wird, obwohl nichts entsprechendes im Autostartordner eingetragen ist, kann das auch an den folgenden Einträgen in der Registry liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Tips

setzen Sie die Einträge für Show und ShowIE4 als Datentyp REG_DWORD auf 0. Jetzt sollte der IE nicht mehr automatisch starten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1235.htm


Autologin beim Starten

Wenn Sie das Anmelden mit Name und Passwort automatisch erledigen lassen wollen, müssen Sie Folgendes machen:

Bei Windows 2000:

Gehen Sie hier über "Start" -> "Einstellungen" -> "Systemsteuerung" und wählen Sie hier den Eintrag "Benutzer und Kennwörter" aus.

Entfernen Sie hier den Haken bei den Eintrag "Benutzer müssen für diesen Computer Benutzernamen und Kennwort eingeben" und klicken auf "Übernehmen". Jetzt müssen Sie noch den Benutzernamen und das Kennwort für den Account eingeben. Klicken Sie anschließend auf OK, um die Angaben zu übernehmen.

Ab Windows XP:

Geben Sie unter "Start" -> "Ausführen" in die Zeile Öffnen: "control userpasswords2" (ohne Anführungszeichen) ein. Jetzt öffnet sich das Fenster "Benutzerkonten".

Klicken Sie auf "Übernehmen". Auch hier werden Sie noch nach dem Passwort gefragt und können auch noch den Benutzeraccount ändern. Klicken Sie anschließend auf OK um die Angaben zu übernehmen.

Sie können das aber auch über die Registry von Windows setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

ab Windows NT/2000/XP

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

folgende Einträge:

Wert | Datentyp | Inhalt | Info
AutoAdminLogon | REG_SZ | 1 | Autologin Ein/Ausschalten
DefaultUserName | REG_SZ | <Benutzername> | Anmeldename des Anwenders
AltDefaultUserName | REG_SZ | <Benutzername> | Anmeldename des Anwenders (Ab Windows 2000 zusätzlich vorhanden)
DefaultPassword | REG_SZ | <Passwort> | Passwort des Anwenders (es muss ein Passwort vorhanden sein)
DefaultDomainName | REG_SZ | <DomainName> | Anmeldung soll über einen anderen Rechner erfolgen. Domänen Name, der bei einer Anmeldung standardmäßig angezeigt werden soll. In einem Netzwerk mit mehr als einer Domäne (Vertrauensstellung) kann es mehr als einen Eintrag in der Liste geben; mit diesem Eintrag wird die Domäne bestimmt, die nach dem Starten als Standard festgelegt werden soll.

nur für Windows 95/98 und ME

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ Current Version\ Winlogon

folgende Einträge:

Wert | Datentyp | Inhalt | Info
AutoAdminLogon | REG_SZ | 1 | Autologin Ein/Ausschalten
DefaultUserName | REG_SZ | <Benutzername> | Anmeldename das Anwenders
DefaultPassword | REG_SZ | <Passwort> | Passwort des Anwenders (es muss ein Passwort vorhanden sein)

Diese Einstellung können Sie auch mit Microsoft's TweakUI vornehmen. Siehe "TweakUI 1.33: Alle Funktionen im Überblick".

Info Es muss ein Passwort vergeben werden (keine leeres Passwort), da es ansonsten maximal nur einmal funktioniert.

Info Es erscheint keine Anmeldebox mehr. Will man sich unter einem anderen Namen anmelden, muss man beim Startvorgang die SHIFT-Taste gedrückt halten. Dann wird man wieder nach Name und Passwort gefragt (ab Windows NT). Das kann aber, wie unter "Autologon kann mit der Shift-Taste unterbunden werden" beschrieben, unterbunden werden.

Info Wird in der Registry kein Passwort eingetragen, funktioniert AutoLogin nur einmal und Windows stellt danach "AutoAdminLogon" wieder auf "0". Die Angabe des Passwortes ist also unbedingt erforderlich. Bedenken Sie, dass dadurch das Passwort für jeden sichtbar in der Registry steht!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0051.htm


Automatisches ScanDisk ausschalten

Für Windows 95/98

Ab der Windows Version: 4.00.950b führt Windows beim Booten automatisch ein ScanDisk aus, falls das System zuvor nicht korrekt heruntergefahren wurde. Dieses lästige Verhalten kann man durch einen Eintrag in der Datei MSDOS .SYS abstellen:

Tragen Sie hierfür im Abschnitt [Options] folgende Zeile ein:

Autoscan=0

Info Beachten Sie aber, dass evt. Fehler in der Verzeichnisstruktur, die durch geöffnete TMP-Dateien verursacht wurden, nicht mehr automatisch gefunden und beseitigt werden.

Ab Windows NT

Mit einem Eintrag in der Registry kann eingestellt werden, dass beim Start des Rechners CHKDSK /F ausgeführt wird. Das automatische Überprüfen eines Laufwerkes können Sie mit chkntfs /x <Laufwerksbuchstabe>ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager

den Eintrag "BootExecute" und ändern Sie die Einstellung

BootExecute | REG_MULTI_SZ | Autocheck Autochk* | nur beim Absturz
BootExecute | REG_MULTI_SZ | Autocheck Autochk /P * | immer

Beim Ausführen von CHKDSK wartet Windows eine gewisse Zeit, auch das kann unter diesem Schlüssel verändert werden

AutoChkTimeOut

REG_DWORD

0 bis 259200 (Sekunden )
Standard ist 10 Sekunden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0048.htm


Neue Tipps beim Windows-Start

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Tips\

können Sie eigene Tipps unterbringen, die dann beim Windows-Start angezeigt werden. Legen Sie eine neue Zeichenfolge an und weisen Sie ihr als Namen eine noch nicht vergebene Nummer zu. Unter Wert können Sie dann den eigentlichen Tipp eingeben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0050.htm


Automatisches Starten von Windows Programmen beim Systemstart

Es gibt Treiber, die bei ihrer Initialisierung direkt Aktionen durchführen (z.B. Einträge in AUTOEXEC.BAT), an denen man sie nicht hindern kann. Diese Programme nutzen die Autostart-Funktionen von Windows.

Es gibt einige Möglichkeiten, Windows-Programme beim Systemstart automatisch zu starten:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 95/98/ME

Auflistung nach Reihenfolge der Ausführung:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServicesOnce

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices

(Benutzeranmeldung)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnce\ Setup

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnce

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnceEx

WIN.INI: LOAD= (Programm wird minimiert gestartet)

WIN.INI: RUN=

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

C:\WINDOWS\All Users\Startmenü\Programme\Autostart

C:\WINDOWS\Startmenü\Programme\Autostart

C:\WINDOWS\Profiles\<Benutzer>Startmenü\Programme\Autostart

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnce

Ab Windows NT

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServicesOnce

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnce

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServicesOnce

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

dort die Werte "Run" oder "Load" als Datentyp REG_SZ

Noch vor dem Einloggen eines USERS werden einige Programme gestartet, die wie folgt eingetragen sind:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services

Autostart Gruppe (Windows 95/98 und NT)

In HKEY_LOCAL_MACHINE sollten computerspezifische Programme aufgerufen werden, in HKEY_CURRENT_USER benutzerspezifische.

Mit den Registry-Einträgen "RunOnce" kann man ein Programm nach dem Neustart eines Rechners einmalig ausführen lassen, danach wird der Eintrag von Windows automatisch aus der Registry entfernt. Dies ist insbesondere für Programmierer hilfreich, die beim Ausführen einer Installations-Routine sicher sein wollen, dass sich keine anderen Programme im Speicher befinden.

Mit HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices werden Programme ausgeführt, bevor sich ein Benutzer eingeloggt hat (z.B. Fax-Empfang).

Um die Registry Einträge zu erstellen oder zu bearbeiten, finden bzw. erstellen Sie die entsprechenden Schlüssel.

Im rechten Fenster mit der rechten Maustaste klicken, -> "Neu" -> "Zeichenfolge" wählen und einen beliebigen Namen eingeben (z.B. den Programmnamen).

Doppelklicken Sie nun auf diesen Eintrag und weisen Sie ihm als Wert den vollständigen Pfad, den Programmnamen und ggf. erforderliche Parameter des gewünschten Programms zu.

Info Siehe auch Tipp: "Ausführen des Autostart Ordners verhindern".

Info Siehe auch Tipp: "Einträge unter RunOnce bei Start nicht ausführen"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0049.htm


Windows ohne Abfrage beenden (Icon auf dem Desktop)

Windows ohne Abfrage beenden (per Icon auf dem Desktop)

Klicken Sie mit der rechten Maustaste auf den Desktop und wählen -> "Neu" -> "Verknüpfung". Geben Sie in der Befehlszeile ein (Groß-/Kleinschreibung beachten!):

Für Windows 95:

Rundll.exe user,ExitWindows

Für Windows 98/ME:

Rundll.exe user,ExitWindows Exec

(Sie können auch
%windir%\Rundll32.EXE Shell32,SHExitWindowsEx 2 (Neustart)
oder
%windir%\Rundll32.EXE Shell32,SHExitWindowsEx 1 (Herunterfahren)
verwenden)

Nun haben Sie auf dem Desktop ein Icon, mit dem Sie Windows ohne weitere Abfrage beenden können.

Mit zwei Einschränkungen:

  • DOS -Programme müssen vorher geschlossen werden.
  • Wurde im Netzwerk auf den PC zugegriffen, kommt eine Abfrage, ob die Verbindung getrennt werden soll.

Eine weitere Möglichkeit, die für alle Betriebssysteme geeignet ist, sind spezielle Programme. Microsoft hat in seinem Resource Kit auch ein Programm Shutdown.exe. Wer das aber nicht extra kaufen will, findet im Internet einige gute kostenlose Programme dieser Art, die meist auch noch viel mehr Funktionalitäten bieten.

Programme:

URL: http://www.freewarepage.de/download/2417.shtml

URL: http://www.snapfiles.com/get/ashutdown.html

Ab Windows XP

Ab Windows XP kann zum Definieren eines Desktop-Symbols zum Herunterfahren der Befehl 'Shutdown.exe' verwendet werden. Erstellen Sie auf dem Desktop eine neue Verknüpfung, die folgende Befehlszeile enthält:

%windir%\SYSTEM32\shutdown.exe -s -f -t 0

Für ein Neustartsymbol müssen Sie die Befehlszeile

%windir%\SYSTEM32\shutdown.exe -r -f -t 0

Angaben zur Bedeutung der verschiedenen Befehlszeilenparameter finden Sie im "Hilfe- und Supportcenter" von Windows ("Start" > "Hilfe und Support"), wenn Sie nach dem Stichwort "Befehlszeilenreferenz" und im Index der Befehlszeilenreferenz nach "shutdown" suchen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0357.htm


Startreihenfolge der Programme im Autostart-Ordner festlegen

Programme, die Sie in den Ordner AUTOSTART legen, werden von Windows beim Starten automatisch gestartet. Leider können Sie hier aber nicht die Reihenfolge festlegen. Sollte es aber nötig sein, dass ein Programm erst gestartet werden kann wenn eine andere Anwendung schon geladen ist, müssen Sie folgendermaßen vorgehen:

Legen Sie eine BATCH-Datei an, die folgende Einträge hat:

START [PROG1.EXE]

START [PROG2.EXE]

usw....

EXIT

Wenn "PROG2" erst starten soll, wenn "PROG1" beendet ist, müssen Sie den Befehlszeilenschalter "/W" verwenden:

START /w [PROG1.EXE]

START [PROG2.EXE]

EXIT

An das Ende der Einträge sollten Sie ein EXIT eintragen, damit die Batch-Datei auch geschlossen wird und kein Fenster mehr offen bleibt.

Starten Sie diese Datei nun im Autostartordner (die anderen Verknüpfungen entfernen Sie natürlich!)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0439.htm


Selbstdefinierte Logon-Texte

Mit folgender Einstellung kann man nach dem Drücken von "STRG+ALT+Entf" und vor dem Anmelden eines Benutzers eine Information anzeigen lassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

LegalNoticeCaption | REG_SZ | Text der Fensterleiste
LegalNoticeText | REG_SZ | Text im Fenster

Bei Windows 95/98 finden Sie die Werte unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Winlogon

Nur NT/2000:

Statt des normalen Anmeldetextes im Anmeldeinformations-Fenster (Geben Sie einen Benutzer...), der von Windows beim Anmelden standardmäßig angezeigt wird, können Sie auch einen eigenen Text definieren. Man kann dort z.B. den Rechner-Namen oder sonstige Informationen anzeigen lassen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Legen Sie hier einen neuen Eintrag mit dem Namen "LogonPrompt" als Datentyp REG_SZ an. Geben Sie als Wert den Text an, der angezeigt werden soll.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0434.htm


Tooltipps deaktivieren

Die Tooltipps in Windows können Sie durch einen Eintrag in der Registry ausschalten.

Diese Funktion, sowie einige andere, finden Sie gesammelt unter "XMouse Funktion aktivieren" ausführlich beschrieben.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1037.htm


Windows Taskplaner ausschalten

Bei der Installation des Internet Explorer auf Windows 95/98 bzw. ME wird automatisch der "Taskplaner" installiert und aktiviert, so dass er automatisch bei jedem Start von Windows geladen wird.

Wenn Sie nicht wollen, dass der Taskplaner gestartet wird, löschen Sie folgenden Schlüssel:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices

löschen Sie den Eintrag "SchedulingAgent" als Datentyp REG_SZ Mit diesem Wert "mstask.exe". Wenn Sie den Taskplaner wieder benötigen, müssen Sie den Wert wieder neu in die Registry Eintragen.

Unter Windows 98/ME können Sie den Taskplaner auch wie folgt deaktivieren:

  1. Start - Ausführen - msconfig - Autostart
  2. Haken bei "SchedulingAgent" entfernen

Dadurch wird der Eintrag in den Registry-Schlüssel

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices-

verschoben. In Windows 95 ist das Programm Msconfig leider nicht enthalten, Sie können aber z.B. "StartMan" von http://home.ptd.net/~don5408/toolbox/startupcpl/verwenden. Dieses Programm ist auch in Deutsch verfügbar.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1310.htm


Windows startet nur noch im 'Abgesicherten-Modus'

Sollte Windows nur noch im Abgesicherten-Modus starten, obwohl eigentlich alles ordentlich funktionieren müsste, prüfen Sie doch einmal , ob sich im Verzeichnis C:\Windows die (schreibgeschützte) Datei "Wnbootng.sts" befindet und löschen Sie dann diese Datei.

Um den Abgesicherten-Modus zu erzwingen, legen Sie einfach eine leere Datei mit dem oben erwähnten Namen im Windows-Verzeichnis an, die Datei wird automatisch wieder gelöscht.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1212.htm


MSDOS.SYS

Die Datei MSDOS.SYS befindet sich im Hauptverzeichnis Ihrer Festplatte und wird beim Booten von Windows automatisch geladen. Diese Datei ist versteckt, system- und schreibgeschützt. Soll MSDOS.SYS verändert werden, müssen zuerst die Attribute geändert werden. Starten Sie ein DOS-Fenster, wechseln Sie ins Hauptverzeichnis und geben "ATTRIB -H -R -S MSDOS.SYS" ein. Nun können Sie die Datei editieren. Danach sollten Sie die Attribute wieder setzen (ATTRIB +H +R +S MSDOS.SYS).

Abschnitt [Paths]

Bedeutung

HostWinBootDrv=C

Root des Boot-Laufwerks

WinBootDir=C:\Windows

Windows - Verzeichnis, welches bei der Installation von Windows angegeben wurde (alle zum Booten benötigten Dateien)

WinDir=C:\Windows

Windows - Verzeichnis, welches bei der Installation von Windows angegeben wurde (in diesem Verzeichnis befindet sich Windows)

UninstallDir=

Pfad zu alten Systemdateien (nur wenn Windows 95 über MS-DOS und Win3.x installiert und "alte Systemdateien sichern" gewählt wurde)

Abschnitt [Options]

Bedeutung

BootDelay=2

[Nur für Windows Version 95]

Anzeigedauer der Meldung "Windows 95 wird gestartet..." in Sekunden. Innerhalb dieser Zeit müssen Sie bestimmte Tasten gedrückt haben, um den Startvorgang zu steuern. Mit 0 wird die Wartezeit deaktiviert.

BootGUI=1

Wenn auf "0" gesetzt, startet Windows im DOS-Modus (DOS 7). Windows kann später mit dem Befehl "WIN" gestartet werden.

BootKeys=1

Wenn auf "0" gesetzt, sind beim Starten die Funktionstasten F4, F5 und F8 abgeschaltet und der Eintrag "BootDelay" wird nicht beachtet.

BootMenu=0

Bei 1 wird beim Start das Windows Startmenü automatisch aufgerufen. Sonst müssen Sie beim Starten von Windows die Taste F8 drücken, damit das Startmenü angezeigt wird.

BootMenuDefault=1

Standardauswahl für das Windows Bootmenü (F8 - Menü). Die Zahl entspricht den Einträgen aus dem Bootmenü. Bei einem Fehler ist der Standardwert 3.

BootMenuDelay=30

Anzeigedauer des Startmenüs nach dem Drücken der F8-Taste in Sekunden. Nach Ablauf der Zeit wird automatisch mit dem unter "BootMenuDefault" eingestellten Menüeintrag der Startvorgang fortgesetzt. Damit dieser Eintrag funktioniert, muss der Eintrag BootMenu auf 1 gesetzt werden.

BootSafe=0

Bei "0" startet Windows standardmäßig Normal.
Bei "1" startet Windows standardmäßig im abgesicherten Modus.

BootMulti=1

Bei "1" wird das Booten eines alternativen Betriebssystems aktiviert (F4-Taste). Damit kann die alte DOS-Version (falls vorhanden) aufgerufen werden.
Bei "0" wird das ausgeschaltet.

BootWarn=1

Schaltet das Startmenü und Warnmeldungen ein/aus.

BootWin=1

Bei "1" wird Windows standardmäßig geladen, bei 0 das sekundäre Betriebssystem. Wenn auf "0" gesetzt, kann Windows mit F4 gestartet werden.

DoubleBuffer=0

Bei "1" wird die doppelte Pufferung z.B. für SCSI - Controller eingeschaltet.
Die Einstellung, ob nun "DoubleBuffer=0" oder "DoubleBuffer=1" kann sehr unterschiedlich ausfallen. Erkennt Windows eine SCSI-Festplatte im System, setzt es den Parameter immer auf 1. Dies ist aber überflüssig, wenn die Platte nicht bootfähig ist, also nicht Laufwerk C:\ darstellt und, dies ist sehr wichtig, die Platte nicht vom Controller-BIOS als INT13-Gerät gesteuert wird. D.h. das BIOS ist deaktiviert. Dann übernimmt Windows das Scannen der SCSI-Geräte und deren Handling. Hier kann also "DoubleBuffer=0" stehen. Dies spart auch ein wenig DOS-Speicher.
Ist im System aber eine SCSI-Festplatte vorhanden, die das Laufwerk C: darstellt und mit Hilfe des Controller-BIOS von dieser Platte gebootet wird, sollte unbedingt "DoubleBuffer=1" in der MSDOS.SYS stehen. Ansonsten hat man extreme Leistungsverluste. Je nach Plattentyp fährt Windows sogar im DOS-Kompatibilitäts-Modus hoch.
Wichtig noch für SCSI-Kontroller: Erkennt Windows den Kontroller, was es nun bei den meisten tut, sollte man nicht die DOS-Treiber laden oder sie gegebenenfalls aus der CONFIG.SYS und AUTOEXEC.BAT entfernen. Windows kann bei geladenen DOS-Treibern die SCSI-Geräte nicht mit den eigenen 32 Bit-Treibern ansprechen. Dies gilt auch für CD-ROM-Treiber (nur SCSI).

Bei "2" wird die doppelte Pufferung immer geladen, auch wenn der SCSI-Controller sie nicht benötigt.

DBLSpace=1

Bei "1" wird DBLSPACE.BIN automatisch geladen.

DRVSpace=1

Bei "1" wird DRVSPACE.BIN automatisch geladen.

LoadTop=1

Bei "0" werden die Dateien COMMAND.COM und DRVSPACE.BIN nicht in den hohen Speicher geladen.

Logo=1

Eine "0" verhindert die Anzeige des Windows-Logos. Die Einstellung 0 vermeidet auch die Verwendung einer Anzahl von Interrupts, die Inkompatibilitäten mit bestimmten Speicherverwaltungsprogrammen von Drittherstellern hervorrufen können.

Network=0

Die "1" bedeutet, dass ein Netzwerk installiert wurde. Im W95-Startmenü wird die Option "Abgesichert mit Netzwerk" hinzugefügt.

Autoscan=1

[Ab Windows Version B bis W98]

Eine "0" verhindert die Ausführung von Scandisk.
Eine "1" führt Scandisk bei einem Neustart aus, wenn Windows nicht korrekt heruntergefahren wurde und erwartet Benutzereingaben.
Eine "2" führt Scandisk bei einem Neustart aus, wenn Windows nicht korrekt heruntergefahren wurde, erwartet aber keine Benutzereingaben.

SystemReg=1

Bei "1" ist das Hardwareprofil aktiviert.
Bei "0" ist das Hardwareprofil deaktiviert.

DisableLog=1

[Ab Windows Version 98]

Bei "0" ist das Logging aktiviert.
Bei "1" ist es deaktiviert.

LoadTop=1

Bei "0" ist das Hochladen einiger Programme und Treiber in den Speicher oberhalb von 640 KByte unter Windows deaktiviert.

Bei "1" ist es aktiviert.

Für alle, die es noch nicht gemerkt haben: Der Eintrag "BootFailSafe" hat keine Funktion und hat seinen Ursprung in einem (längst korrigierten) Fehler im Windows 95 Resource Kit:

List of Documentation Errors in Windows 95 Resource Kit (Q135849): http://support.microsoft.com/?kbid=135849

Info Außerdem gibt es am Ende der MSDOS .SYS einige Zeilen, die mit einem ";" beginnen. Diese Zeilen werden von Windows eigentlich nicht benötigt. Sie sorgen dafür, dass die MSDOS .SYS mindestens 1024 Bytes groß ist. Dies ist aus Kompatibilitätsgründen für einige Programme notwendig.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0022.htm


WINBOOT.INI vor MSDOS .SYS

Wenn Sie sich wundern, warum die Einstellungen in der MSDOS .SYS keine Wirkung zeigen, sollten Sie einmal nachsehen, ob sich nicht im Hauptverzeichnis die Datei WINBOOT.INI befindet.

Ist diese Datei vorhanden, wird sie statt MSDOS.SYS ausgeführt. Alle Einstellungen in der MSDOS.SYS werden in diesem Falle ignoriert.

Beide Dateien haben den gleichen Aufbau. Sehen Sie dazu auch unter MSDOS .SYSnach.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0228.htm


WINBOOT.SYS vor IO.SYS

Ist die Datei WINBOOT.SYS vorhanden, wird sie statt IO.SYS ausgeführt. Alle Einstellungen in der IO.SYS werden in diesem Falle ignoriert.

Beide Dateien haben den gleichen Aufbau.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0789.htm


Windows Bootmenü (unterschiedliche Startarten von Windows)

Wenn Sie Windows starten, sehen Sie üblicherweise das Windows Logo und der Ladevorgang wird gestartet. Sollten Sie jedoch Probleme haben, könnten Sie eine der folgenden Start-Optionen benutzen.

Um eine Windows Start-Option zu benutzen:

Starten Sie den Computer neu. Wenn Sie die Meldung "Windows xx wird gestartet..." auf dem Bildschirm sehen, drücken Sie die Taste <F8> (besser: <SHIFT> für W95, <STRG> für W98/ME) und wählen eine der Optionen im Start-Menü aus.

Die folgende Tabelle beschreibt die Optionen im Start-Menü.

Start-Menü Option | Beschreibung
Normal | Startet das System wie gewöhnlich
Protokolliert | Zeichnet Informationen des Startvorgangs und der Systemtreiber in der Datei BOOTLOG.TXTauf
Abgesichert | Startet Windows im Abgesicherten-Modus, womit die Zahl der Konfigurationsinformationen eingeschränkt wird, die während des Startens ausgeführt werden. Sie können dazu auch die Taste F5 benutzen
Abgesichert mit Netzwerk (Option erscheint nur auf einem System mit Netzwerk) | Startet Windows im Abgesicherten-Modus, erlaubt Ihnen aber zusätzlich den Zugriff auf das Netzwerk. Sie können dazu auch die Taste F6 benutzen. Diese Option ist nur auf einem Computer vorhanden, auf dem ein Netzwerk verfügbar ist
Einzelbestätigung | Dadurch können Sie jede Zeile in der Datei CONFIG.SYS und AUTOEXEC.BAT während des Startvorgangs einzeln ausführen, indem Sie jede Zeile mit JA oder NEIN beantworten [Eingabetaste = J oder ESC = N]. Sie können auch entscheiden, ob der Komprimierungstreiber und die Datei WIN.COM geladen wird. Sie können dazu auch die Tastenkombination[UMSCHALT+F8] benutzen
Nur Eingabeaufforderung | Dadurch können Sie Schalter bei der Ausführung der Datei WIN.COM angeben. Sie können dazu auch die Tastenkombination ALT +F5 benutzen
Abgesichert, nur Eingabeaufforderung | Abgesicherter Start auf die MS-DOS -Eingabeaufforderung. Die Dateien CONFIG.SYS und AUTOEXEC.BAT werden dabei umgangen. Sie können dazu auch die Tastenkombination STRG+F5 benutzen
Vorherige MS-DOS -Version | Dadurch wird die vorherige MS-DOS -Version gestartet, die vor der Installation von Windows 95 auf Ihrem Computer installiert war. Diese Option erscheint nur, wenn in der Datei MSDOS .SYSim Abschnitt [Options] der Eintrag BootMulti = 1 vorhanden ist. Sie können dazu auch die Taste F4 benutzen

Info Sie können durch Einträge in der Datei MSDOS .SYS einstellen, ob das Start-Menü angezeigt wird, welche Optionen verfügbar sind und welche Standardeinstellungen benutzt werden sollen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0069.htm


Dateien im Verzeichnis C

Für alle, die schon immer wissen wollten, welche Dateien wofür im Verzeichnis C:\ sind, hier die Antwort (aus der MS KB):

Autoexec.bat - Windows configuration file

This file contains commands that should be run by Windows before the 32-bit portion of the operating system is started. This file is necessary only if you need to load a real-mode driver.

Autoexec.DOS - Previous MS-DOS Autoexec.bat file

This file contains the original Autoexec.bat file from the previous operating system. It is used if you boot the previous operating system.

Bootlog.prv - Previous Windows startup log file

This file records the progress of the previous Windows startup process. When you request a logged boot (or if Windows performs one automatically), the previous Bootlog.txt file is renamed to Bootlog.prv before the new Bootlog.txt file is created. This file is not necessary for the proper operation of Windows and can be deleted.

Bootlog.txt - Windows startup log file

This file records the progress of the Windows startup (boot) process. It is created if you request a logged boot, and is also created automatically by Windows if Windows detected that the previous boot was unsuccessful. This file is not necessary for the proper operation of Windows and can be deleted.

Command.com - Windows command line processor

This program is the Windows command line processor. This file is necessary for the proper operation of Windows and should not be deleted.

Command.DOS - Previous MS-DOS Command.com file

This file contains the original Command.com file from the previous operating system. It is used if you request to boot the previous operating system.

Config.DOS - Previous MS-DOS Config.sys file

This file contains the original Config.sys file from the previous operating system. It is used if you boot the previous operating system.

Config.sys - Windows configuration file

This file contains parameters that describe the real-mode (16-bit) drivers that should be loaded into memory as part of the Windows startup process. This file is necessary only if you need to load a real-mode driver.

Cvt.log - Drive Converter (FAT32) Log File

This file is created by the Drive Converter (FAT32) when you convert a drive to FAT32 and may be useful for troubleshooting failed conversions. To remove this file, delete it from Windows Explorer.

Detlog.old - Previous Windows detection log file

This file records the progress of the previous Windows hardware detection process. When you request that new hardware be detected, the previous Detlog.txt file is renamed to Detlog.old before the new Detlog.txt file is created. This file is not necessary for the proper operation of Windows and can be deleted.

Detlog.txt - Windows detection log file

This file records the progress of the Windows hardware detection process. It is created during hardware detection and is consulted by the hardware detection recovery process if the previous attempt to detect hardware caused problems.

This file is not necessary for the proper operation of Windows and can be deleted.

Io.DOS - Previous MS-DOS Io.sys file

This file contains the original Io.sys file from the previous operating system. It is used if you boot the previous operating system.

Io.sys - Windows MS-DOS

This file contains Windows MS-DOS . This file is necessary for the proper operation of Windows and should not be deleted.

Logo.sys - Windows logo

This file contains the Windows logo that is displayed as part of the startup process.

MsDOS .DOS - Previous MS-DOS MsDOS .sys file

This file contains the original MsDOS .sys file from the previous operating system. It is used if you boot the previous operating system.

MsDOS .sys - Windows configuration file

This file contains parameters necessary for the early phases of the Windows startup process. For more information, please see the following article in the Microsoft Knowledge Base:Q118579 This file is necessary for the proper operation of Windows and should not be deleted.
http://support.microsoft.com/?kbid=118579

Oemlog.txt - Windows Original Equipment Manufacturer (OEM) log file

This file records the progress of the Windows OEM preinstallation process. This file is not necessary for the proper operation of Windows and can be deleted.

Scandisk.log - ScanDisk log file

This file is created by the ScanDisk program to record the result of the most recent disk scan. This file is not necessary for the proper operation of Windows and can be deleted.

Setuplog.txt - Windows Setup log file

This file is created by Windows Setup to record the progress of the installation procedure. It is consulted by Windows Setup as part of installation recovery. This file is not necessary for the proper operation of Windows and can be deleted.

Suhdlog.dat - Windows Setup hard disk log file

This file contains a copy of all Master Boot Records and Partition Boot Records on the system both before and after the upgrade to Windows. This file is used by Windows Uninstall to restore the hard disk master boot sector as part of the uninstall process. To remove this file, click "Old Windows 3.x and MS-DOS system files" in the Add/Remove Programs tool and then click Add/Remove.

System.1st - Windows first registry

This file contains a copy of the original registry created by Windows setup. Although this file is not necessary for the proper operation of Windows and can be deleted, it is recommended that the file be retained because it can be used to restore the registry should it become damaged.

Videorom.bin - a copy of your video card's ROM.

If you delete this file, Windows 98 will recreate it on the next boot. This file is used by Windows 98 to support multiple monitors.

W95und o.dat - Windows 95 uninstall data file

This file contains a compressed backup of Windows 3.x files that were replaced as part of the Windows 95 installation process. It is created by Windows 95 Setup and is used as part of the Windows 95 uninstall process. To remove this file, click "Old Windows 3.x and MS-DOS system files" in the Add/Remove Programs tool and then click Add/Remove.

W95und o.ini - Windows 95 uninstall script file

This file contains a listing of files backed up in the W95und o.dat file. It is created by Windows 95 Setup and is used as part of the Windows 95 uninstall process. To remove this file, click "Old Windows 3.x and MS-DOS system files" in the Add/Remove Programs tool and then click Add/Remove.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0858.htm


Bootmenü für Windows

Soll Windows nicht automatisch gestartet werden, kann man sich ein Bootmenü zusammenstellen.

Sehr empfehlenswert ist das z.B. bei Spielen, die unter Windows nicht bzw. schlecht laufen.

In der MSDOS.SYS ist unter [Options] folgendes einzutragen:

BootGUI=0 kein automatisches Starten von Windows 95

Hier ein Beispiel einer CONFIG.SYS und AUTOEXEC:BAT:

CONFIG.SYS:

SWITCHES /F

[MENU] -> Auswahlmenü

MENUITEM=WIN,WINDOWS 95

MENUITEM=DOS ,DOS 7.0

MENUITEM=NOEMS,DOS 7.0 (ohne EMM386)

MENUDEFAULT=WIN,10 -> Nach 10sec. automatisch Windows 95 starten

[WIN] ->Windows 95 starten

DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMEM:OFF

DEVICE=C:\WINDOWS\EMM386.EXE FRAME=NONE NOVCPI

DOS =HIGH,UMB

[DOS ] -> Ein möglicher DOS -Start

DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMEM:OFF

DEVICE=C:\WINDOWS\EMM386.EXE RAM HIGHSCAN

DOS =HIGH,UMB

.... Eigene Treiber für CD-ROM usw.

SHELL=C:\WERKZEUG\4DOS .COM C:\WERKZEUG /P

LASTDRIVE=Z

[NOEMS] -> Zweite Möglichkeit

DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMEM:OFF

DOS =HIGH

... Eigene Treiber für CD-ROM usw.

SHELL=C:\WERKZEUG\4DOS .COM C:\WERKZEUG /P

LASTDRIVE=G

[COMMON] -> Wird bei jeder Auswahl ausgeführt

FILES=40

AUTOEXEC.BAT:

@ECHO OFF

PROMPT $p$g

PATH C:\WINDOWS;C:\WINDOWS\COMMAND;C:\DOS ;

SET TEMP=C:\DOS \TMP

SET TMP=C:\DOS \TMP

goto %config% -> Was wurde in der Config.sys ausgewählt

:WIN -> Windows 95 laden

keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

win

goto ende

:DOS

LH C:\WERKZEUG\MMOUSE.COM

LH keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

.... Eigene Treiber wie z.B.: CD-ROM usw.

goto ende

:noems

C:\WERKZEUG\MMOUSE.COM

keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

.... Eigene Treiber Wie z.B.: CD-ROM usw.

goto ende

:ende

Bei diesem Aufbau der Konfigurationsdateien werden für Windows nur die notwendigen Treiber geladen. Sollte man aber DOS starten, werden auch der CD-ROM-Treiber und alle anderen benötigten TSRs in den Speicher geladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0068.htm


'Denkpause' beim Booten

Eine Pause beim Booten kann an der Grafikkarte liegen: Sie versucht, sich mit dem Monitor per DDC zu verständigen. Wenn der Monitor nicht DDC-fähig ist, geht's erst nach einer Timeout-Zeit weiter. Ärgerlicherweise lässt sich das nicht per INI-Eintrag abschalten. Man kann es aber in der Registry versuchen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE/ SYSTEM/ CurrentControlSet/ Services/ Class/ Display/ <nnn>/ Default

"nnn" ist eine 4-stellige Zahl (0000, 0001, 0002...), je nach der Anzahl der verwendeten Grafikkarten und -Treiber. Finden Sie dort den Eintrag "DDC" und falls er auf "1" steht, stellen Sie ihn auf "0". Nun sollte es eigentlich keine Pause mehr geben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0070.htm


Einzelschritte beim Start

(Aus WINDOWS95 --- Das Kompendium Markt & Technik)

Der PC wird eingeschaltet und die Bootsequenz gestartet. Falls es sich um ein Plug&Play BIOS handelt, werden die vorhandenen Plug & Play Erweiterungskarten ermittelt. Über den Master-Bootsektor der Festplatte wird die bootfähige Partition lokalisiert und von ihr die Datei IO.SYS geladen, welche wiederum das Laden von WINDOWS 95 initiiert. IO.SYS lädt unter anderem die Minimalversion des FAT-Dateisystems, um auf die Festplatte und die Diskettenlaufwerke zugreifen zu können.

  1. MSDOS .SYS wird ausgewertet, ggf. wird ein Startmenü angezeigt
  2. REALMODE Treiber werden ggf. geladen
  3. Auswertung der Registrierung, wurde ein Hardwareprofil geladen, dann wird dieses geladen. Das hat den Vorteil, dass ein PC mit verschiedenen Konfiguration hochgefahren werden kann.
  4. BOOTLOG.TXT wird angelegt.
  5. Falls vorhanden, wird nun CONFIG.SYS ausgewertet
  6. HIMEM.SYS, IFSHLP.SYS und SETVER werden über IO.SYS geladen, falls das nicht bereits in der CONFIG.SYS passiert ist
  7. Falls vorhanden, wird nun die AUTOEXEC.BAT ausgewertet
  8. WIN.COM wird im Realmodus gestartet. Diese Komponente führt einen Initialisierungscheck durch und steuert das Laden weiterer Komponenten.
  9. Die WINDOWS- Komponente VMM32.VXD wird geladen. Diese Datei steht eigentlich für das HERZ von Windows 95. Sie lädt unter anderem alle Gerätetreiber.
  10. SYSTEM.INI wird ausgewertet. Treiber die hier mit einem DEVICE stehen, werden geladen, falls Sie nicht mit denen, die VMM32.VXD lädt kollidieren
  11. Prozessor wird in den PROTECTED-MODE geschaltet
  12. KRNL386.EXE wird geladen
  13. GDI.EXE,GDI32.EXE,USER.EXE,USER32.EXE werden geladen
  14. Weitere Ressourcen, z.B. Zeichensätze werden geladen
  15. WIN.INI wird ausgewertet
  16. Die Benutzeroberfläche und der Desktop werden geladen
  17. LOGIN erscheint
  18. Besteht ein Netzwerk, wird nun die Verbindung zum Netzwerk geschaffen
  19. Aktivierung Standard/Benutzereinstellungen des Desktop
  20. AUTOSTART- Ordner wird ausgewertet
  21. WINDOWS ist nun bereit.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0113.htm


Start- und End-Logos von Windows

Beim Starten und Beenden werden von Windows unterschiedliche Bilder angezeigt. Sie können statt dessen auch andere Bilder anzeigen lassen, wenn Sie sich an bestimmte Regeln halten und das Bild im richtigen Verzeichnis ablegen. Erstellen Sie einfach eine *.BMP Datei mit den unten angegeben Werten und benennen Sie diese in *.SYS um.

Format | BMP
Codierung | RGB
Abmessung (in Pixel) | 320 * 400
Farben | 256

Für das Startlogo:

Name | LOGO.SYS
Verzeichnis | Boot Verzeichnis

Info Ist die Datei nicht vorhanden, wird immer das Standard-Logo angezeigt, welches in der Datei Io.sys enthalten ist. Man kann aber eine eigene LOGO.SYS erstellen. Sollte das Logo in der MSDOS .SYS abgeschaltet sein, wird es natürlich nicht angezeigt.

Für das Endlogo:

Name | LOGOS.SYS | für die Anzeige "Shutdown"
 | LOGOW.SYS | für die Anzeige "Wait"
Verzeichnis | Windows-Verzeichnis |

Das ganze geht auch animiert. Wie, ist bei http://www.xrx.ca/logoutils/beschrieben.

LogoMania (Freeware) finden Sie hier: http://www.zdnet.com/downloads/stories/info/0,,77469,.html This document has been removed from the active list

LogoMania Beschreibung: http://www.zdnet.com/pcmag/pctech/content/16/06/ut1606.001.html

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0128.htm


Nach dem Start von Windows sind alle Symbole schwarz

Wenn die Symbole schwarz angezeigt werden, kann es an einer defekten Datei "ShellIconCache" (SHELLI~1) liegen. Sie sollten die Datei löschen und den Computer neu starten. Diese Datei (versteckte Datei im Windows-Verzeichnis) wird nun von Windows automatisch neu erstellt. Wenn das Problem durch das Löschen nicht behoben wurde, starten Sie den Rechner einmal im Abgesicherten-Modus und führen dann einen Neustart durch.

Um eine versteckte Datei löschen zu können, müssen Sie sie sichtbar machen. Sie können das auf folgende Weise tun:

  1. Klicken Sie im Windows-Explorer auf den Menüpunkt "Ansicht" und dann auf "Optionen".
  2. Klicken Sie auf die Registerkarte "Ansicht" und stellen Sie sicher, dass das Kontrollfeld "Alle Dateien anzeigen" ausgewählt ist. Klicken Sie dann auf "OK".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0221.htm


Probleme beim Herunterfahren bzw. mit dem automatischen Ausschalten

Unter Windows gibt es auf einigen Rechnern Probleme mit dem Herunterfahren bzw. dem automatischen Abschalten des Rechners.

Zu diesen Problemen wurden schon einige Tipps in der FAQ gegeben, die nun auf dieser Seite alle übersichtlich aufgeführt werden.

Tipp 1

Wenn Sie Probleme beim automatischen Ausschalten von Windows 98 haben, rufen Sie das Programm MSCONFIG auf. Unter "Allgemein" -> "Weitere Optionen" können Sie durch Deaktivieren der Option "Schnelles herunterfahren" Ihr Problem meist beheben.

oder ändern Sie es in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Shutdown

den Wert "FastReboot" vom Datentyp REG_SZ (DWORD kann auch funktionieren) von "1" auf "0" ändern.

Weitere Tipps:

Mein Rechner hängt beim Herunterfahren. Woran kann das liegen?

Lösung:
Die Gründe hierfür sind verschieden. Daher einige Vorschläge:

  1. Evtl. den Treiber aus Config.sys und Autoexec.bat entfernen.
  2. Sofern Windows 98 über Windows 95 mit dem IE4 installiert wurde, könnte es an dieser Kombination liegen.
    Im IE4.01 gibt es einen Bug in/mit der shell32.dll, die das Herunterfahren von Rechnern verhindert, wenn der Rechner zum Zeitpunkt des Beendens noch mit dem Netzwerk verbunden ist. Dieser Bug ist mit dem IE4.01SP1, der auch in Windows 98 enthalten ist, beseitigt worden. Daher den IE4 vor der Installation von Windows 98 deinstallieren oder das Update aus dem Netz besorgen.
  3. evtl. ist das Powermanagement verantwortlich. Deaktivieren Sie alle Powermanagement-Funktionen im BIOS und Windows 98.
  4. Auch die Grafikkarte könnte die Ursache sein. Daher das Video Shadowing im BIOS deaktivieren und den Treiber updaten.
  5. Verändern Sie auch einmal probeweise die Farbtiefe oder die Bildschirmauflösung. Sollte das Herunterfahren daraufhin beim zweiten einmal funktionieren, liegt das Problem mit hoher Wahrscheinlichkeit beim Treiber für die Grafikkarte.
  6. Die Einträge wie folgt vornehmen:
    1) MSDOS .SYS: Eintrag DoubleBuffer=1
    2) CONFIG.SYS: FILES=50 (ggf. mehr)
    BUFFERS=50 (ggf. mehr)
  7. Oft stört auch die Aktivierung der ACPI-Funktion (Windows 98 SE und ME). Sie sollten ACPI dann am besten im BIOS deaktivieren.
  8. Entfernen Sie alle nicht benötigten Dienste, Protokolle und Bindungen in den Netzwerkeigenschaften, insbesondere die Bindungen "TCP/IP -- Datei- und Druckerfreigabe" und "TCP/IP -- Client für MS-Netzwerke".
  9. Bei Netzwerkeinsatz (Novell / NT) und Windows 95b mit IE4.0 "Active Desktop" deaktivieren.

Beachten Sie bitte, dass sich die meisten der oben genannten Tipps erst beim übernächsten Herunterfahren auswirken. Verfahren Sie also folgendermaßen:

  1. Eine Änderung vornehmen
  2. Herunterfahren
  3. Neustarten
  4. Herunterfahren

Wenn diese Tipps nicht helfen, sollte ein protokollierter Start (mit Bootlog.txt) durchgeführt werden. Während des Bootvorgangs halten Sie die Taste <STRG> (Windows 98) bzw. <SHIFT> (Windows 95) und wählen dann im Bootmenü "Protokolliert". Am Ende der Datei könnte sich dann ein Hinweis auf das Problem finden:

Letzte Zeile | Mögliche Fehler
Terminate=Query Drivers | Speicherproblem.
Terminate=Unload Network | Konflikt mit einem Real-Mode Treiber in der Config.sys
Terminate=Reset Display | Video Shadow im BIOS deaktivieren und Grafikkartentreiber updaten
Terminate=RIT | Probleme mit Soundkarte oder Maus.
Terminate=Win32 | Ein 32-Bit Programm blockiert einen Thread.

Tipp 2

Ist die Option "Dateien und Ordner für andere Benutzer freigeben" aktiviert, kann unter Umständen der Rechner nicht mehr richtig herunterfahren und bleibt hängen.

Lösung:

Erstellen Sie eine Batch-Datei mit folgendem Inhalt:

=== Hier schneiden ===

%WINDIR%

NET.EXE use * /delete
Rundll.exe user,ExitWindows

=== Hier schneiden ===

und fahren Sie den Rechner über diese Batch-Datei herunter.

(Sie können auch
%WINDIR% \Rundll32.EXE Shell32,SHExitWindowsEx 2 (Neustart)
oder
%WINDIR% \Rundll32.EXE Shell32,SHExitWindowsEx 1 (Herunterfahren)
verwenden)

Info Bei MS gibt es dazu noch ein paar Hotfix um das Problem zu beheben:
http://support.microsoft.com/?kbid=239887
http://support.microsoft.com/?kbid=242934(gibt es nur auf Anfrage: 01805/672255)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Auf der folgenden Seite finden Sie noch weitere Infos und Lösungen zu diesem Thema: http://www.jasik.de/shutdown

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0281.htm


Nach Windows Schlussbild den DOS-Modus starten

Wenn man in Windows den Rechner herunterfährt, bekommt man ein Logo angezeigt, dass man den Rechner nun ausschalten kann. Windows befindet sich in diesem Augenblick im DOS-Modus und zeigt nur noch ein Bild an. Durch zwei Tricks kann man dort aber auch zur Eingabeaufforderung gelangen.

Tipp 1:

Starten Sie den Rechner neu, drücken die F8-Taste und wählen "Nur Eingabeaufforderung". Wechseln Sie ins Windows-Verzeichnis und erstellen von der Datei WIN.COM eine Sicherheitskopie (COPY WIN.COM WINCOM.OLD). Erstellen Sie eine Datei WIN.DEB (COPY CON WIN.DEB).

Inhalt der Datei WIN:DEB:

e 01e6 90

e 01e7 90

e 01be 90

e 01bf 90

w

q

Rufen Sie nun DEBUG auf (DEBUG WIN.COM < WIN.DEB).

Info Es kann vorkommen, dass Windows dabei abstürzt. Das hat aber keinen Datenverlust zur Folge. Starten Sie einfach den Rechner neu.

Tipp 2:

Durch die blinde Eingabe von: MODE CO80 und Drücken von ENTER befindet man sich im MS-DOS Modus.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0243.htm


System Tray wird automatisch installiert

Windows installiert auf jedem Rechner automatisch die Funktion "System Tray". StartenysTray.exe wird verwendet, um einige Windows Module im Tray abzulegen bzw. die dazugehörigen Icons anzuzeigen:

  • Akkuanzeige (Battery Meter)
  • PCMCIA Dienst (PC Card Status)
  • Lautstärkeregler (Volume Control)
  • Schnelles Umschalten der Bildschirmeinstellungen (Quickres)
  • Taskplaner (Task Scheduler)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

Hier können Sie den Eintrag "SystemTray" löschen.

Wenn Sie wollen, können Sie auch noch die dafür zuständigen Programme "SysTray.exe" im "Windows" - Verzeichnis und "Batmeter.dll" im "Windows\System" Verzeichnis umbenennen (oder löschen).

Info Das Löschen von SysTray.exe bewirkt, dass keine Programme mehr automatisch in den Tray geladen werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0324.htm


Startdateien von Windows

Hier finden Sie eine Aufstellung alles Windows 9x Startdateien mit einer entsprechenden Beschreibung .

Starten von Windows:
IO.SYS | Windows Datei (Hauptverzeichnis)
MSDOS .SYS | Windows Datei (Hauptverzeichnis)
CONFIG.SYS | Windows Konfigurationsdatei für DOS -Programme (Hauptverzeichnis)
AUTOEXEC.BAT | Windows Konfigurationsdatei für DOS -Programme (Hauptverzeichnis)
COMMAND.COM | Windows Datei (Hauptverzeichnis)
DOS START.BAT | Windows Konfigurationsdatei für MS-DOS -Modus (Windows-Verzeichnis) Diese Datei wird aber erst beim "Beenden von Windows 95" ("Start" -> "Beenden" -> "Computer im MS-DOS -Modus starten") ausgeführt. Beim Normalen Starten von Windows 95 wird Sie nicht ausgewertet.
IO.DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
MSDOS .DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
CONFIG.DOS | DOS x.x-Konfigurationsdatei, wird mit F4 bzw. F8 gestartet
AUTOEXEC.DOS | DOS x.x-Konfigurationsdatei, wird mit F4 bzw. F8 gestartet
COMMAND.DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
Starten von DOS x.x (F4 bzw. F8):
IO.SYS | DOS x.x-Datei
MSDOS .SYS | DOS x.x-Datei
CONFIG.SYS | DOS x.x-Konfigurationsdatei
AUTOEXEC.BAT | DOS x.x-Konfigurationsdatei
COMMAND.COM | DOS x.x-Datei
WINBOOT.SYS JO.SYS | Windows Datei (IO.SYS von Windows) (bei Windows 98)
MSDOS .W40 | Windows MSDOS .SYS Datei
CONFIG.W40 | Windows Konfigurationsdatei
AUTOEXEC.W40 | Windows Konfigurationsdatei
COMMAND.W40 | Windows COMMAND.COM
Nach Start einer Anwendung im MS-DOS -Modus mit neuer MS-DOS Konfiguration:
IO.SYS | Windows Datei
MSDOS .SYS | Windows Datei
CONFIG.SYS | Neue CONFIG.SYS aus den Eigenschaften der Anwendung (+DOS =SINGLE)
AUTOEXEC.BAT | Neue AUTOEXEC.BAT aus den Eigenschaften der Anwendung (+WIN/WX (-> Warmstart)...)
COMMAND.COM | Windows Datei
IO.DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
MSDOS .DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
CONFIG.DOS | DOS x.x-Konfigurationsdatei, wird mit F4 bzw. F8 gestartet
AUTOEXEC.DOS | DOS x.x-Konfigurationsdatei, wird mit F4 bzw. F8 gestartet
COMMAND.DOS | DOS x.x-Datei, wird mit F4 bzw. F8 gestartet
CONFIG.WOS | Windows Datei (Original CONFIG.SYS von Windows)
AUTOEXEC.WOS | Windows Datei (Original AUTOEXEC.BAT von Windows)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0283.htm


Warum verbraucht HIMEM.SYS 40 KB?

In der Windows Version 4.0.950b aller europäischen Versionen ist offenbar ein Bug, so dass HIMEM.SYS statt 1kBnun 40kBDOS -Speicher benötigt. Für das Problem gibt es von MS jetzt einen Patch:iosysupd.exe(IO.SYS v4.71.0306.0 deutsch, KB)

Dieser Bugfix bewirkt, dass Himem.sys nicht mehrkBSpeicher belegt (funktioniert nur für die mitgelieferte Himem.sys Version nur für Windows 950B (OSR 2.0, 2.1)).

Durch Ändern der Datei IO.SYS mit einem HexEditor kann man das Problem aber auch beheben.

Gehen Sie mit einem Diskeditor an Offset 52F5h und ändern Sie dort die Bytefolge "01 BC 02" in "01 58 02". Damit sollte HIMEM.SYS wieder wie gewohnt nur 1 KByte Speicher benötigen.

bzw. mit dem Programm "debug", dafür gehen Sie in die DOS -Eingebeaufforderung. Geben Sie die nachfolgenden Zeilen genau so ein: (Sie müssen sich im Hauptverzeichnis von C:\ befinden)

attrib -s -h -r io.sys

debug io.sys

e 52f5 01 58 02

w

q

attrib +s +r + h io.sys

Info Die Windows 95B OSR 2.5 u. 95C OSR 2.5 haben diesen Fehler nicht mehr!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0352.htm


Command-Line Switches der Datei WIN.COM

Diese Parameter können nicht über die Eingabeaufforderung benutzt werden. Sie müssen dafür Windows beenden, um dann mit den entsprechenden Parametern Windows starten zu können.

Syntax:

WIN {/D:[F] [M] [N] [S] [V] [X]} [/W] [/WX]

Parameter:

/W

Wiederherstellen der Dateien CONFIG.SYS und AUTOEXEC.BAT mit Hilfe der Dateien CONFIG.WOS und AUTOEXEC.WOS. Danach erscheinen folgende Bildschirmmeldungen:

Weiter mit beliebiger Taste...

Jetzt wird das System neu gestartet.

/WX

Wiederherstellen der Dateien CONFIG.SYS und AUTOEXEC.BAT mit Hilfe der Dateien CONFIG.WOS und AUTOEXEC.WOS. Danach wird das System automatisch neu gestartet.

/D:[Werte]

Ermöglicht die Fehlersuche, wenn Windows nicht gestartet werden kann. Die Werte können kombiniert werden:

F Deaktiviert den 32-Bit Datenträgerzugriff. Entspricht dem SYSTEM.INI Eintrag: 32BitDiskAccess=FALSE

M Aktiviert den Abgesicherten-Modus (entspricht dem Start mit F5)

N Aktiviert den Abgesicherten-Modus mit Netzwerkunterstützung (entspricht dem Start mit F6)

S Verhindert, dass Windows den ROM-Adressbereich von F000:0000 bis 1 MB für einen Haltepunkt verwendet. Entspricht dem SYSTEM.INI-Eintrag: SystemROMBreakPoint=FALSE

V Die Interrupts des Festplatten-Controllers werden von der ROM-Routine behandelt. Entspricht dem SYSTEM.IN- Eintrag: VirtualHDIRQ=FALSE

X Schließt den Adapterbereich aus dem Speicherbereich aus, in dem Windows nach freien Speicher sucht. Entspricht dem SYSTEM.INI Eintrag: EMMExclude=A000-FFFF

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0628.htm


Benutzereinstellungen gelten für Alle?

Werden in Windows 95 und Windows 98 mehrere Benutzer angelegt und die Option "Eigener Desktop und Startmenü" gewählt, gelten Änderungen für ALLE Nutzer, wenn man bei NETZWERK als Login die Einstellung "Microsoft Netzwerk" stehen lässt.

Es sollte daher auf "Windows Anmeldung" umgeschaltet werden. Nur so gelten die Einstellungen der Benutzer individuell.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0929.htm


Ständig Scandisk nach richtigem Shutdown

Schnelle CPUs (ab 1 GHz) bringen Windows 98SE und Windows ME beim Herunterfahren aus dem Tritt. Trotz richtigen Beendens des Systems wird bei jedem Neustart Scandisk gestartet. Grund hierfür ist die Tatsache, dass die CPU schneller beendet ist als die Festplatte Daten vom Cache auf die Platte schreiben konnte. Ein Update fügt eine Zeitschleife von 2 Sekunden beim Herunterfahren ein:

http://www.microsoft.com/windows98/downloads/contents/WUCritical/q273017/default.asp

Auch unter Windows 95 und Windows 98 tritt dieses Problem auf, kann aber hier nur manuell behoben werden:

Mit dem Registryeditor wechselt man in den Pfad

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion

und erstellt hier einen neuen Eintrag mit dem Namen "CacheWriteDelay" als Datentyp REG_DWORD und dem Dezimalen-Wert 2000 (für 2 Sekunden ). Sollte dies nicht reichen, gibt man einfach 4000 für 4 Sekunden an.

Weiterhin soll man bei Windows 98 und ME auch noch die Datei "Ifsmgr.vcd" auf den neusten Stand bringen. Das Update finden Sie unter

Windows 98:http://www.microsoft.com/windows98/downloads/contents/wucritical/q273017/default.asp

Windows ME: http://download.microsoft.com/download/winme/Update/11956/Win ME/EN-US/273017USAM.EXE

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=273017

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1085.htm


Benutzerpasswort vergessen

Solange man an einem lokalen System mit Windows 9x/ME arbeitet, kann man sich bei einem vergessenen Passwort wie folgt behelfen:

Wenn man bei der Anmeldung <Abbrechen> drückt, kommt man trotzdem in das System. Dann muss man über die Suchfunktion die Datei USERNAME.pwl suchen und umbenennen (USERNAME steht hier für den Loginnamen des Users), das System neu starten und ein neues Passwort eingeben, und es sollte wieder laufen.

Allerdings gehen so ALLE gespeicherten Kennwörter des Users verloren (z.B. von DFÜ-Verbindungen), so dass diese auch neu einzugeben sind.

Info Dies geht nur, wenn Sie Ihre Anmeldung nicht wie unter "Deaktivieren des Buttons "Abbrechen" beim Anmelden" beschrieben, umgestellt haben.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1140.htm


Ständige Meldung 'Konfigurationsdateien werden aktualisiert...'

Ständige Meldung "Konfigurationsdateien werden aktualisiert..."

Beim Start wertet Windows unter anderem die Datei wininit.ini über die win.com aus. Ist diese Datei vorhanden, wird Wininit.exe ausgeführt, welche dann die Befehle der Wininit.ini auswertet.

In dieser Ini-Datei, die oft nach Installationen angelegt wird, stehen Einträge wie z.B. "Löschen vom Temp-Ordner" oder Installationsaufrufe. Wenn Windows beim Hochfahren längere Zeit mit der Meldung "Konfigurationsdateien werden aktualisiert..." hängt, wäre ein Fehler in der wininit denkbar. Zur Abhilfe sollte man diese Datei unter DOS (mit F8 booten) einfach einmal umbenennen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1170.htm


Hochfahren dauert ewig

Wenn sich der Rechner beim Hochfahren ewig Zeit lässt, kann es an an der Bindung im Netzwerk liegen.

Die Bindung TCP/IP Netzwerkkarte sollte daher gelöscht werden, wenn TCP/IP im Netzwerk nicht benötigt wird. Optional kann man auch eine feste IP-Adresse vergeben:

"Netzwerk" - "Eigenschaften": 192.168.100.1, SubnetMask 255.255.255.0

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0231.htm


Startbanner deaktivieren

Mit diesem Wert können Sie das Anzeigen des Startbanners unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBanner" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es wird kein Banner angezeigt
0 | Banner wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1755.htm


Fehler bei der Laufwerksverbindung nicht anzeigen

Windows gibt eine Fehlermeldung aus, wenn bei der Anmeldung eine Netzwerkverbindung nicht wieder hergestellt werden kann. Mit diesem Tipp können Sie einstellen, dass Windows keine Fehlermeldung ausgibt, auch wenn das Netzwerklaufwerk nicht verbunden werden konnte.

Info Diese Einstellung betrifft nur den Anmeldeprozess.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Network

ändern Sie hier den Wert "RestoreDiskChecked" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Keine Fehlermeldung anzeigen
gelöscht | Fehlermeldung anzeigen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2055.htm


CLSID Nummern der wichtigsten Funktionen

Die wichtigsten Funktionen werden bei Windows über CLSID-Nummern aufgerufen (siehe dazu auch: Was ist eine CLSID?).

In einigen Tipps in dieser FAQ wurden schon etliche dieser Nummern aufgezeigt. Hier finden Sie eine Übersicht der wichtigsten Windows-Funktionen und die dazugehörigen CLSID.

Wenn Sie ein Icon zum Aufruf solcher Funktionen anlegen wollen, legen Sie an der gewünschten Stelle (Desktop oder Startmenü) einen neuen Ordner an. Als Namen für den Ordner geben Sie eine Beschreibung, gefolgt von einem Punkt und dann die CLSID-Nummer [Name.{CLSID-Nummer}] (z.B. Systemsteuerung.{21EC2020-3AEA-1069-A2DD-08002B30309D}) ein.

Typ | CLSID Nummer | NT | Windows 9x | ab Windows 2000 | ab Vista
Aktenkoffer | {85BBD920-42A0-1069-A2E4-08002B30309D} | Ja | Ja | Ja | Ja
Arbeitsplatz | {20D04FE0-3AEA-1069-A2D8-08002B30309D} | Nein | Ja | Ja | Ja
Bitmap | {D3E34B21-9D75-101A-8C3D-00AA001A1652} | Nein | Ja | Ja | Ja
Briefkasten | {85BBD920-42A0-1069-A2E4-08002B30309D} | Nein | Ja | Ja | Nein
Desktop | {00021400-0000-0000-C000-000000000046} | Nein | Ja | Ja | Nein
DFÜ-Netzwerk | {992CFFA0-F557-101A-88EC-00DD010CCC48} | Nein | Ja | Ja | Ja
DFÜ Netzwerk | {A4D92740-67CD-11CF-96f2-00AA00A11DD9} | Ja | Ja | Ja | Nein
Drucker | {2227A280-3AEA-1069-A2DE-08002B30309D} | Ja | Ja | Ja | Ja
History (= URL Verlauf) | {FF393560-C2A7-11CF-BFF4-444553540000} | Ja | Ja | Ja | Ja
Internet Cache | {7BD29E00-76C1-11CF-9DD0-00A0C9034933} | Ja | Ja | Ja | Ja
Internet Einstellungen | {DB2112AD-0000-0000-0002-000004281965} | Nein | Ja | Ja | Nein
Internet Explorer | {FBF23B42-E3F0-101B-8488-00AA003E56F8} | Ja | Ja | Ja | Nein
Internet Mail | {89292102-4755-11cf-9DC2-00AA006C2B84} | Nein | Ja | Ja | Nein
Internet News | {89292103-4755-11cf-9DC2-00AA006C2B84} | Nein | Ja | Ja | Nein
Mailprogramm (MS Exchange/Outlook) | {00020D75-0000-0000-C000-000000000046} | Ja | Ja | Ja | Nein
Netzwerkumgebung | {00028B00-0000-0000-C000-000000000046} | Nein | Ja | Ja | Nein
Netzwerkverbindungen | {208D2C60-3AEA-1069-A2D7-08002B30309D} | Ja | Ja | Ja | Ja
Papierkorb | {645FF040-5081-101B-9F08-00AA002F954E} | Ja | Ja | Ja | Ja
Schriftarten | {BD84B380-8CA2-1069-AB1D-08000948F534} | Nein | Ja | Ja | Nein
Shortcut | {00021401-0000-0000-C000-000000000046} | Nein | Ja | Ja | Nein
Systemsteuerung | {21EC2020-3AEA-1069-A2DD-08002B30309D} | Ja | Ja | Ja | Nein
URL Verlauf | {FF393560-C2A7-11CF-BFF4-444553540000} | Ja | Ja | Ja | Ja
Freigegebene Ordner | {59031a47-3f72-44a7-89c5-5595fe6b30ee} | Nein | Nein | Ja | Ja
Cabinet Datei | {0CD7A5C0-9F37-11CE-AE65-08002B2E1262} | Nein | Ja | Nein | Nein

UICLSID

Typ | CLSID Nummer | NT | Windows 9x | ab Windows 2000 | ab Vista
Schriften | {BD84B380-8CA2-1069-AB1D-08000948F534} | Nein | Ja | Ja | Ja
Temporary Internet Files | {7BD29E00-76C1-11CF-9DD0-00A0C9034933} | Nein | Ja | Ja | Ja

Info Siehe auch: "Systemsteuerung & Co im Startmenü mit Pfeil zum Aufklappen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0354.htm


Active Desktop installieren mit IE 5.0 und 5.5

Active Desktop installieren mit IE 5.0/5.5

Bei der Installation des IE 4.x hatten Sie die Auswahlmöglichkeit, "Active Desktop" zu installieren. Beim IE 5.0 gibt es diese Auswahlmöglichkeit nicht mehr. Wenn Sie aber das große Installationspaket von IE 5 haben (größer als 74 MB), können Sie mit einem Trick trotzdem den Activen Desktop installieren lassen, ohne erst IE 4.x installieren zu müssen. Gehen Sie dazu folgendermaßen vor:

  1. Starten Sie die Installation von IE 5.0
  2. Warten Sie bis die erste Dialogbox zur Auswahl erscheint
  3. Starten Sie jetzt den Windows Explorer und gehen Sie in das Temp-Verzeichnis; hier finden Sie ein neues Verzeichnis mit dem Namen "IXP000.TMP"
  4. Laden Sie die Datei "IESETUP.CIF" mit einem Editor (z.B. Notepad)
  5. setzen Sie jetzt unter den Rubriken [IE4Shell_Win] und [IE4Shell_NTx86]den jeweiligen Eintrag UIVISIBLE auf 1
  6. Speichern Sie die Datei ab

Wenn Sie jetzt die Installation des IE 5.0 fortsetzen, können Sie durch den Menüpunkt "Desktop-Aktualisierung" die Installation von Active Desktop anstoßen.

Dieser Tipp geht auch mit dem IE 5.5. Kopieren Sie dafür noch die folgenden Dateien vom IE 5.0 in das IE 5.5 Installationsverzeichnis:

Fpesetup.cab

Ie4shl95.cab

Ie4shlnt.cab

Ieak5opt.cab

Iejava.cab

Mschat25.cab

Mswallet.cab

Nm2.cab

Swdir.cab

Vrml2c.exe

Wpie5x86.cab

Anschließend gehen Sie wie oben beschreiben vor.

Info Ist der Internet Explorer schon ohne diese Anpassung auf Ihrem System installiert, funktioniert dieser Tipp nicht mehr und es kann zu Problemen kommen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0481.htm


Ziehen und Ablegen funktioniert nicht mehr

Ziehen und Ablegen (Drag & Drop) funktioniert nicht mehr

Wenn die Funktion "Ziehen und Ablegen" mit der Maus (Drag & Drop) nicht mehr funktioniert, kann es an einem beschädigten Eintrag in der Registry liegen. Folgende Datei sollte das Problem beheben:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}]
@="IDataObject"

[HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}\NumMethods]
@="12"

[HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}\ProxyStubClsid32]
@="{00000320-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}]
@="oleprx32_PSFactory"

[HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}\InprocServer32]
@="ole32.dll"

=== Hier schneiden ===

  1. Öffnen Sie Notepad
  2. Markieren Sie die Zeilen (inklusive der letzten Leerzeile) zwischen den Schneidemarken, Rechtsklick, Kopieren
  3. In Notepad: Einfügen
  4. Speichern als "ZiehenAblegen.reg". Geben Sie den Namen mit den Anführungszeichen an, damit Notepad nicht die Dateiendung.txt an den Dateinamen anfügt
  5. Rechtsklick auf "ZiehenAblegen.reg", Zusammenführen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1324.htm


Profile für die Anwender deaktivieren

Mit der folgenden Einstellung können Sie die Benutzung von Benutzerprofilen abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Network\ Logon

erstellen Sie einen neuen Eintrag mit dem Namen "UserProfile" mit dem Datentyp REG_DWORD und setzen den Wert auf 0, um die Verwendung von Benutzerprofilen auszuschalten bzw. auf 1, um die Benutzung von Profilen zu aktivieren.

Info Durch das Deaktivieren von Benutzerprofilen werden die Einstellungen des Desktops nicht mehr für jeden Anwender extra gespeichert und der Desktop sieht bei allen gleich aus.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1343.htm


Desktop/Fenstereinstellungen

Diese Einstellungen bestimmen die Größe der Fensterelemente auf dem Desktop.

Die Werte werden entweder in Pixel (X/Y-Koordinate) oder als Twips (1/20 eines Druckerpunktes = 1/1440 Zoll) angegeben. Zur Unterscheidung werden Angaben in Twips mit einem negativen Vorzeichen (-) in die Registry eingetragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics

Schlüssel | Datentyp | Angabe als | Standard
Rahmenbreite
BorderWidth | REG_SZ | Twips: 1 - 49 | 15
Schriftart der Fenstertitel
CaptionFont | REG_BINARY | Schriftart | MS Sans Serif
Größe der Steuerelemente in der Titelleiste eines Fensters (Höhe)
CaptionHeight | REG_SZ | Twips | -270
Größe der Steuerelemente in der Titelleiste eines Fensters (Breite)
CaptionWidth | REG_SZ | Twips | -270
Schriftart, die für die Symbole verwendet wird
IconFont | REG_BINARY | Schriftart | MS Sans Serif
Größe einer Rasterzelle; beim automatischen Anordnen der Icons auf den Desktop bestimmt das die Abstände der Icons zueinander.
IconSpacing | REG_SZ | Twips | -1125
Angabe, ob Symboltitel umbrochen werden. Bei 1 wird das Umbrechen eingeschaltet und der vertikale Abstand zwischen den Symbolen um 3 Zeilen vergrößert.
IconTitleWrap | REG_SZ | Boolean | 1
Höhe der Symbolzelle
IconVerticalSpacing | REG_SZ | Twips | -900
Die für das Menü verwendete Schriftart
MenuFont | REG_BINARY | Schriftart | MS Sans Serif
Höhe der Menüleiste
MenuHeight | REG_SZ | Twips | -270
Breite der Schaltflächen der Menüleiste
MenuWidth | REG_SZ | Twips | -270
Die für die Meldungsfelder zu verwendende Schriftart
MessageFont | REG_BINARY | Schriftart | MS Sans Serif
Höhe der horizontalen Bildlaufleiste
ScrollHeight | REG_SZ | Twips | -240
Breite der vertikalen Bildlaufleiste
ScrollWidth | REG_SZ | Twips | -240
Farbtiefe der Symbole, die im Explorer zum Einsatz kommen.
Shell Icon BPP | REG_SZ | Bits pro Pixel | 4
Höhe und Breite der Symbole, die im Explorer zum Einsatz kommen.
Shell Icon Size | REG_SZ | Pixel: 16 - 48 | 32
Höhe und Breite der kleinen Symbole, die in Schnellstartleiste, Startmenü etc. verwendet werden.
Shell Small Icon Size | REG_SZ | Pixel: 1 - 48 | 16
Höhe und Breite großer Symbole im Explorer
Size | REG_SZ | Pixel | ?
Schriftart für kleine Titelleisten
SmCaptionFont | REG_BINARY | Schriftart | MS Sans Serif
Höhe kleiner Titelleisten und ihrer Symbole
SmCaptionHeight | REG_SZ | Twips | -225
Breite kleiner Titelleisten und ihrer Symbole
SmCaptionWidth | REG_SZ | Twips | -225
Schriftart für die Statusleisten
StatusFont | REG_BINARY | Schriftart | MS Sans Serif

Info Siehe auch "Icon Einstellungen (was man alles ändern kann)"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0006.htm


Arbeitsplatz um weitere Icons erweitern

Unter dem Icon 'Arbeitsplatz' finden Sie standardmäßig nur die Laufwerke, die Systemsteuerung, das Druckericon usw. Wenn Sie hier noch weitere Icons anlegen bzw. löschen möchten, müssen Sie das direkt über die Registry machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Mycomputer\ NameSpace

Erstellen Sie hier einen neuen Schlüssel. Als Namen müssen Sie die CLSID-Nummer der Funktion eingeben. Eine Aufstellung dazu finden Sie unter: CLSID Nummern der wichtigsten Funktionen.

Wenn Sie jetzt den neuen Schlüssel anklicken, finden Sie auf der linken Seite den Eintrag "Standard", klicken Sie diesen Eintrag an. Geben Sie eine Beschreibung für das Icon ein.

Ab Windows XP:

Hier gibt können auch noch weitere Einträge eingeben unterhalb von:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Mycomputer\ NameSpace\ DelegateFolders

Auch hier können - wie oben beschrieben - Einträge vorgenommen werden, meist über den Eintrag

"{59031a47-3f72-44a7-89c5-5595fe6b30ee}"

werden alle freigegebenen Ordner eingeblendet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0829.htm


Channel-Leiste wieder einblenden

Wenn Sie die Channel-Leiste deaktiviert haben, sie aber doch wieder einblenden möchten, können Sie das schnell über folgenden undokumentierten Befehl machen. Geben Sie unter "Start" -> "Ausführen" einfach folgendes ein:

iexplore -channelband

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0446.htm


'Desktop anzeigen' in der Schnellstartleiste (Quick-Launch) wiederherstellen

Ab IE 4.x gibt es in der Taskleiste die Schnellstart-Symbolleiste (auch Quick-Launch genannt). Hier können Sie selber Programmicons ablegen, die dann über einen einfachen Mausklick sofort gestartet werden.

In dieser Leiste sind schon von MS einige Icons abgelegt worden. Diese Icons können Sie durch Drag & Drop auf den Papierkorb auch leicht aus der Quick-Launch entfernen und durch erneutes Hineinziehen des Programmicons auch wieder anlegen. Problematisch wird es aber, wenn Sie das Desktop-Icon aus Versehen gelöscht haben und wieder anlegen möchten, das geht leider nicht über Drag & Drop.

Die Icons in der Schnellstartleiste sind Verknüpfungen, die im Verzeichnis
"[Profilverzeichnis]\ Anwendungsdaten\ Microsoft\ Internet Explorer\ Quick Launch" angelegt werden.

"Desktop anzeigen" ist eine Funktion, die über ein Skript aufgerufen wird. Wenn Sie das Skript gelöscht haben, müssen Sie eine SCF-Datei (Shortcut File) mit folgendem Inhalt erstellen:

=== Hier schneiden ===

[Shell]
Command=2
IconFile=explorer.exe,3

[Taskbar]
Command=ToggleDesktop
=== Hier schneiden ===

Erstellen Sie die Datei mit einem Normalen Texteditor als ASCII-Datei und speichern Sie diese dann unter dem Namen "Desktop anzeigen.scf".

Wenn Sie keine Benutzerprofile angelegt haben, speichern Sie die SCF-Datei im Verzeichnis

C:\Windows\Anwendungsdaten\Microsoft\Internet Explorer\Quick Launch

Bei Verwendung von Benutzerprofilen verwenden Sie den jeweiligen Profilnamen des Benutzers:

C:\Windows\Profil\[Profilname]\Anwendungsdaten\Microsoft\Internet Explorer\Quick Launch

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=190355

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0603.htm


Papierkorb vom Desktop löschen

Sie können den Papierkorb eigentlich nicht von Desktop löschen (ab Windows Vista ist das löschen auch wieder einfach mit der DEL-Taste möglich). Wenn Sie ihn trotzdem loswerden wollen, müssen/können Sie das über die Registry machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ Desktop\ NameSpace\

alle Einträge für Papierkorb {645FF040-5081-101B-9F08-00AA002F954E} entfernen.

Geht mit den PowerToys (Tweak UI) einfacher!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0263.htm


Papierkorb umbenennen

Den Papierkorb können Sie nicht wie jedes andere Icon einfach so umbenennen (ab Windows Vista, können Sie den Namen durch drücken von F2 einfach verändern). Wenn Sie hier einen anderen Namen haben wollen, müssen Sie über die Registry gehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ {645FF040-5081-101B-9F08-00AA002F954E}

den Wert "Papierkorb" in einen beliebigen Namen ändern.

Ab Windows 2000/XP

HKEY_CLASSES_ROOT\ CLSID\ {645FF040-5081-101B-9F08-00AA002F954E}

hier gibt es einen Eintrag mit den Namen "LocalizedString" als Datentyp REG_SZ wo meist drin steht "@%SYSTEMROOT%\system32\Shell32.dll,-8964". Geben Sie hier einfach den neuen Namen ein.

Anschließend müssen Sie noch den Desktop aktualisieren. Klicken Sie dafür den Papierkorb auf dem Desktop an und drücken Sie die F5 Taste.

Info Siehe auch Tipp: Symbole umbenennen, die geschützt sind (z.B. Posteingang)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0264.htm


Anzeigen der Versionsnummer auf dem Desktop

Durch einen Eintrag in der Registry können Sie sich die aktuelle Versionsnummer unten rechts auf den Desktop einblenden lassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "PaintDesktopVersion" als

Windows 9x, ME:

Datentyp REG_SZ

bzw.

ab Windows 2000:

Datentyp REG_DWORD

und setzen den Wert auf:

1 | Zeigt die Versionsnummer an
0 | Es wird keine Versionsnummer angezeigt (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0563.htm


"Geräte-Manager" als Icon auf dem Desktop

Wer den Gerätemanager aus "Systemsteuerung" -> "System" -> "Gerätemanager" öfter braucht, kann sich ein Icon auf den Desktop legen, womit man diese Ansicht direkt aufrufen kann.

Klicken Sie mit der rechten Maustaste auf den Desktop und wählen im Kontextmenü -> "Neu" -> "Verknüpfung".

In das Feld "Befehlszeile" tragen Sie folgendes ein:

c:\windows\control.exe sysdm.cpl,system,1

bzw. bei Ab Windows 2000

%SYSTEMROOT%\system32\devmgmt.msc

Nach -> "Weiter" kann man für die Verknüpfung einen eigenen Namen vergeben, z.B.: "Gerätemanager" und das Ganze -> "Fertigstellen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0150.htm


Desktop Farben ändern

Mit dem Registry-Editor lassen sich auch die Farben des Desktops ändern, die normalerweise im Dialogfeld "Eigenschaften von Anzeige" nicht änderbar sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_USER\ Control Panel\ Colors

Registry-Eintrag | Bedeutung
Scrollbar | Bildlaufleiste
WindowsFrame | Fensterrahmen
AppWorkspace | Hintergrundfarbe von MDI-Formen (z.B. Progman)
ButtonShadow | 3D-Objekte, innerer Randschatten, rechts und unten, heller Schatten beim deaktivierten Menütext
ButtonHilight | 3D-Objekte, innerer Randschatten links und oben markierte Objekte
ButtonDkShadow | 3D-Objekte, äußerer Randschatten rechts und unten, dunkler Schatten beim deaktivierten Menütext
ButtonLight | 3D-Objekte, äußerer Randschatten links und oben

Diesem Wert können Sie nun die gewünschte Farbe im Format "RR GG BB" zuweisen. Ersetzen Sie "RR", "GG" und "BB" durch den jeweiligen Farbanteil Rot, Grün und Blau.

Farbe | RR | GG | BB
Rot | 255 | 0 | 0
Grün | 0 | 0 | 255
Gelb | 255 | 255 | 0
Cyan | 0 | 255 | 255
Magenta | 255 | 0 | 255
Braun | 42 | 42 | 42
Weiß | 255 | 255 | 255
Schwarz | 0 | 0 | 0

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0028.htm


Zielfenster oder Desktop für 'Ziehen und Ablegen' sind verdeckt

Wenn Sie mitten in einer Drag&Drop (Ziehen und Ablegen) -Aktion feststellen, dass der Zielort durch andere geöffnete Fenster verdeckt ist, müssen Sie nicht die momentane Aktion abbrechen. Je nach gewünschtem Ziel verfahren Sie einfach wie folgt:

  1. Desktop: Bewegen Sie den Mauszeiger über den Systray in der Windows-Taskbar. Nach kurzer Zeit wird der Desktop angezeigt.
  2. Andere Anwendung: Bewegen Sie den Mauszeiger über die Schaltfläche der Anwendung in der Windows-Taskbar.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1245.htm


Desktop 'nicht speichern' ein-/ausschalten

Mit diesem Wert wird eingestellt, ob Windows beim Beenden die Informationen für geöffnete Fenster sowie deren Position und Größe für den nächsten Start speichern soll.

Diese Einstellung hat auch Auswirkungen auf das "Active Desktop". Wenn der Wert auf <1> steht, werden die Symbolleisten und deren individuellen Einstellungen nicht gespeichert.

Auf "Active Desktop" Elemente selber, die auf dem Desktop abgelegt werden, haben diese Einstellung aber keinen Einfluss. Hier werden die Veränderungen/Einstellungen immer gespeichert.

Info Wenn Sie diese Funktion aktivieren, werden alle Änderungen, die den Desktop betreffen, nicht mehr gespeichert! Allerdings werden Verknüpfungen auf dem Desktop immer gespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSaveSettings" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Desktopeinstellungen nicht speichern
gelöscht | Desktopeinstellungen speichern (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Einstellungen nicht beim Beenden speichern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1807.htm


Desktop-Icons ein-/ausschalten

Wenn Sie diese Funktion aktivieren, werden alle Desktop-Icons ausgeblendet.

Info Wenn der Tipp aktiviert wird, steht auch kein Kontextmenü mehr zu Verfügung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDesktop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Desktop-Icons ausblenden
gelöscht | Desktop-Icons nicht ausblenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Alle Desktopsymbole ausblenden und deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1808.htm


Netzwerk-Icon ein-/ausschalten

Wenn Sie diese Funktion aktivieren, wird das Netzwerkicon im System nicht mehr angezeigt (Desktop, Explorer usw.).

Sie verhindert nicht, dass Benutzer anderweitig Netzwerkverbindungen herstellen oder nach freigegebenen Computern im Netzwerk suchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetHood" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Netzwerk-Icon ausblenden
gelöscht | Netzwerk-Icon nicht ausblenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Desktopsymbol "Netzwerkumgebung" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1809.htm


Active Desktop deaktivieren

Wenn Sie diese Funktion aktivieren, wird der "Active Desktop" deaktiviert und verhindert, dass Benutzer diesen aktivieren. Dadurch können Benutzer keine HTML und JPG-Hintergrundbilder benutzen (HTML-Seiten auf dem Desktop).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoActiveDesktop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Active Desktop ausblenden
gelöscht | Active Desktop ist nicht aktiv, kann aber aktiviert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Active Desktop deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Falls die Einstellungen "Active Desktop aktivieren" und "Active Desktop deaktivieren" (dieser Tipp) aktiviert sind, wird die Einstellung "Active Desktop deaktivieren" ignoriert. Falls die Einstellung "Alte Oberfläche im Windows Explorer" aktiviert ist, dann ist der Active Desktop deaktiviert und beide Richtlinien werden ignoriert.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1811.htm


Einstellungsmöglichkeiten von Active-Desktop deaktivieren

Wenn Sie diese Funktion aktivieren, können keine Active-Desktop Einstellungen mehr geändert werden. Durch diese Einstellung wird die Registerkarte "Web" aus der Option "Anzeige" in der Systemsteuerung entfernt und dadurch wird die aktuelle Konfiguration gesichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoActiveDesktopChanges" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Active-Desktop gegen Veränderung sichern
gelöscht | Active-Desktop Veränderung zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Keine Änderungen zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1812.htm


Taskbar wird nicht richtig angezeigt

Wenn die Taskbar verschwunden ist oder nicht mehr richtig angezeigt wird, kann das an einem fehlerhaften Registryeintrag liegen. Um den Fehler zu beseitigen, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Löschen Sie folgenden Schlüssel unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Windows 9x/ME:

den Schlüssel "StuckRects"

Ab NT/2000/XP

den Schlüssel "StuckRects2".

Starten Sie den Rechner neu - Windows wird jetzt wieder die Standardwerte für die KBar setzen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1338.htm


Anzeige der Uhrzeit in der Taskleiste ausschalten

Bei Windows wird die Uhrzeit unten rechts im Infobereich (Systray) der Taskleiste angezeigt. Sie können die Anzeige der Uhrzeit durch einen Klick mit der rechten Maustaste auf die Taskleiste -> Eigenschaften und das Abwählen von "Uhr anzeigen" ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "HideClock" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Uhr wird nicht angezeigt
gelöscht | Uhr wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Uhr aus dem Infobereich des Systems entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1362.htm


Einstellungen der Taskleiste ausblenden

Mit diesem Wert können Sie festlegen, dass der Menüpunkt "Einstellungen" -> "Taskleiste" nicht mehr angezeigt wird.

Auch bei einen Rechtsklick auf die Taskleiste wird "Eigenschaften" nicht mehr angezeigt. Jetzt können keine Veränderungen an der Taskleiste mehr durchgeführt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSetTaskbar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Auf die Einstellungen kann nicht zugegriffen werden.
gelöscht | Die Einstellungen sind verfügbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Ändern der Einstellungen für die Taskleiste und das Startmenü verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1371.htm


Kontextmenü der Taskleiste entfernen

Mit diesem Wert können Sie festlegen, dass kein Kontextmenü mehr angezeigt wird, wenn einer mit der rechten Maustaste auf die Taskleiste, Start-Button, Uhr oder einer KBar Applikation klickt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoTrayContextMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Kontextmenü wird nicht mehr angezeigt
gelöscht | Kontextmenü wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Zugriff auf Kontextmenüs für die Taskleiste deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Bei Windows NT 4.0 ist dieser Eintrag erst ab Service Pack 2 vorhanden

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1375.htm


Symbole in der Taskleiste ohne Text anzeigen

Wenn Sie viele Applikationen offen haben, reicht der Platz für die Applikationen in der Taskleiste meist nicht aus.

Sie können Windows so konfigurieren, dass von den Programmen aber nur das Icon angezeigt wird. Der Programmname (Beschreibung) wird dann nicht mehr mit angezeigt.

Dazu müssen Sie einfach nur die breite der Schaltfläche anpassen, die Anpassung können Sie über die Registry durchführen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics

Erstellen Sie hier einen neuen Eintrag als Datentyp REG_SZ mit den Namen "MinWidth". Geben Sie hier als Wert folgendes ein:

Taskbar Größe | MinWidth Wert
17 | -270
18 | -285
19 | -300
20 | -315
21 | -335

Die aktuelle Größe der Titelbar finden Sie hier: "Systemsteuerung" -> "Anzeige" -> hier im Tabreiter "Darstellung" -> auf den Button "Erweitert" -> das Element "Titelleiste des aktiven Fensters" hier sehen Sie jetzt bei Größe den Wert für Ihre Taskbar.

Sie müssen sich nach der Änderung neu am System anmelden.

Info Ab Windows XP bleibt leider noch der erste Buchstabe neben dem Icon mit sichtbar

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1648.htm


Jedes Explorer-Fenster in einem extra Prozess öffnen

Wenn Sie jedes Explorer-Fenster in einem extra Prozess öffnen, werden bei einem Absturz eines Explorers die anderen nicht beeinträchtigt. Man sollte aber auch bedenken, dass daduch mehr Arbeitsspeicher verbraucht wird.

Sie können die Funktion über den Explorer unter "Extras" -> "Ordneroptionen" - > "Ansicht" über den Eintrag "Ordnerfenster in einem eigenen Prozess starten" aktivieren oder in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

einen neuen Eintrag mit dem Namen “SeparateProcess“ als Datentyp REG_DWORD erstellen und den Wert auf 1 setzen, um die Funktion zu aktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1246.htm


Standardvorgang bei Doppelklick für Dateitypen wiederherstellen

Mit dem Windows Explorer können Sie sich unter Ansicht -> Ordneroptionen -> Dateitypen -> Bearbeiten -> Vorgänge über die Standardaktion bei einem Doppelklick auf einen Dateityp informieren und den Standard ändern.

Um den ursprünglichen Betriebssystemstandard wiederherzustellen, wählen Sie einfach den aktuellen Standard (fett hervorgehoben) an und klicken dann auf "Als Standard". Folgendes geschieht daraufhin:

  1. Keine Änderung: Der aktuelle Wert ist der Systemstandard, oder es existiert kein Systemstandard
  2. Ein anderer Eintrag wird fett hervorgehoben: Der aktuelle Wert war nicht der Systemstandard
  3. Kein Eintrag fett hervorgehoben: Für diesen Eintrag existiert kein Systemstandard

Wenn Sie möchten, dass keine Standardaktion festgelegt wird, klicken Sie auf einen leeren Bereich der Anzeige und wählen Sie dann "Standard".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1244.htm


Explorer startet immer im Verzeichnis 'Eigene Dateien'

Der Dateiexplorer von Windows öffnet beim Start immer den Ordner 'Eigene Dateien'.

Um dies zu ändern, muss man der Verknüpfung entsprechende Parameter übergeben. Hierzu ergänzt man die Verknüpfung (klicken Sie die Verknüpfung mit der rechten Maustaste an und wählen Sie "Eigenschaften") in der Befehlszeile am Ende um "/e,C:\", also z.B. "c:\windows\explorer.exe /e,C:\".

Für "C:\" können Sie natürlich auch ein beliebiges anderes Laufwerk oder Verzeichnis angeben.

Info Siehe auch "Explorer Parameter und bestimmte Aufrufe"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0996.htm


Reihenfolge der Einträge im Explorer-Kontextmenü ändern

Die Reihenfolge der Einträge im Kontextmenü des Explorers richtet sich hauptsächlich nach der zeitlichen Reihenfolge - neue Einträge werden unterhalb der alten Einträge angezeigt.

Eine Umsortierung der Einträge erreichen Sie folgendermaßen:

  1. Starten Sie den Registry-Editor
  2. Gehen Sie zu dem Schlüssel HKEY_CLASSES_ROOT\Folder\shell
  3. Exportieren Sie diesen Zweig als hkcr-folder-shell.reg (=Backup)
  4. Exportieren Sie diesen Zweig als hkcr-fo-sh.reg
  5. Löschen Sie den Schlüssel HKEY_CLASSES_ROOT\Folder\shell
  6. Öffnen Sie die Datei hkcr-fo-sh.reg mit Notepad
  7. Stellen Sie die gewünschte Reihenfolge her
    !! Achten auf die Einträge, die zusammengehören !!
  8. Speichern Sie die Änderungen an hkcr-fo-sh.reg, rechts-klicken, "Zusammenführen"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1322.htm


Bildvorschau für alle unterstützten Formate aktivieren

Wenn Sie im Explorer im Menü "Ansicht" auf die "Miniaturansicht" umschalten bzw. die Web-Ansicht aktivieren, zeigt MS bei Bildern eine Bildvorschau (Thumbnails) an.

Aus einigen System wird aber keine Bildvorschau bei so bekannten Grafikformaten wie GIF oder JPG angezeigt, obwohl diese Bildformate von der Bildvorschau unterstützt werden. Das liegt dann daran, dass ein Eintrag in der Registry für die entsprechende Dateiendung fehlt.

Folgende Dateiendungen werden bei der Miniaturansicht zur Zeit unterstützt:

BMP, ART, DIB, GIF, JFIF, JPE, JPEG, JPG, PNG und WMF

Wollen Sie die Bildvorschau für eine der oben aufgezählten Bildformate aktivieren, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_CLASSES_ROOT\ suchen Sie die entsprechende Dateiendung (bei JPG wäre das dann .JPG(also: HKEY_CLASSES_ROOT\.JPG)

Unter diesem Schlüssel erstellen Sie einen neuen Schlüssel (soweit noch nicht vorhanden) mit dem Namen "ShellEx".

Gehen Sie jetzt auf diesen Schlüssel und legen Sie einen weiteren Schlüssel mit dem Namen:

"{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}" an.

Gehen Sie auf diesen Schlüssel. Geben Sie im rechten Fenster beim Eintrag "Standard" folgendes ein: {7376D660-C583-11d0-A3A5-00C04FD706EC}

Der Registryeintrag für JGP müsste nun folgendermaßen aussehen:

HKEY_CLASSES_ROOT\.JPG\ ShellEx\ {BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

mit einem Eintrag "Standard", der folgenden Wert enthält: {7376D660-C583-11d0-A3A5-00C04FD706EC}

Das gleiche müssen Sie auch für alle anderen Dateiendungen machen, falls die Einträge noch nicht in der Registry vorhanden sind.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1152.htm


Symbolleiste des Explorers verändern

Die Symbolleiste des Explorers können Sie mit einem beliebigen Hintergrundbild versehen. Dazu müssen Sie in der Registry folgenden Wert anlegen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar

erstellen Sie hier einen neuen Wert mit dem Namen "BackBitmapShell" als Datentyp REG_SZ. Geben Sie als Wert den Pfad und die Datei des gewünschten Hintergrundbildes an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1002.htm


Allgemeine Schutzverletzung des Explorers beim Hochfahren

Wenn der Explorer beim Windows-Start nicht mehr startet und statt dessen mit einer Fehlermeldung hängen oder der Desktop leer bleibt, ist vermutlich die Datei shdocvw.dll defekt oder durch einen Virus beschädigt, sofern die Registry keine Fehler hat.

Man startet den Rechner im DOS-Modus und editiert in der System.ini den Eintrag Shell=explorer.exezu shell=winfile.exe, damit statt der Oberfläche der alte Dateimanager geladen wird.

Nach einem Neustart führt man über "Start" -> "File" die "command.com" aus. Jetzt kopiert man aus dem Verzeichnis C:\Windows\Sysbckup die Dateien Shdocvw.dll, Mshtml.dll, Comctl32.dll und Shlwapi.dll, welche dort normalerweise von der IE5-Installation bleiben. Ist dieses Verzeichnis bei Ihnen nicht vorhanden, können Sie diese Dateien auch aus folgenden Archiven extrahieren:

So entpacken Sie:

extract /a <cabinet> <filename> /l <destination>

Beispiel: extract /a a:\win95_02.cab unidrv.dll /l c:\windows\system

In folgenden Archiven können Sie die Dateien finden:

Name der CAB-Datei | Wo zu finden
Windows 95/98/ME
IE_1.CAB in der IE_S1.CAB | Internet Explorer 5 (Downloadversion)
IE_1.CAB in \IE5\EN\IE_S1.CAB | Internet Explorer 5 (von der MS Office 2000 CD-ROM 1)
\WIN98\WIN98_41.CAB | Windows 98 SE
Windows NT/2000:
IENT_2.CAB in der IENT_S2.CAB | Internet Explorer 5 (Downloadversion)
IENT_2.CAB in der \IE5\EN\IENT_S2.CAB | Internet Explorer 5 (von der MS Office 2000 CD-ROM 1)

Entpacken Sie die Dateien in das Systemverzeichnis (z.B. c:\windows\system). Lesen Sie dazu auch:

"Dateien austauschen, die in Benutzung sind".

Danach muss man die System.ini wieder in den vorherigen Zustand versetzen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=249191

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1067.htm


Explorer Parameter und bestimmte Aufrufe

Wollen Sie den Explorer immer in einem bestimmten Ordner öffnen, können Sie das mit folgenden Parametern erreichen:

Explorer /e,[Laufwerk]:\[Pfad]

z.B.: Explorer /e,C:\windows

ab Windows XP geht auch: Explorer C:\,/e

Wollen Sie nur den Explorer öffnen, ohne dass ein Verzeichnis geöffnet wird, müssen Sie folgenden Aufruf benutzen:

Explorer /e,/select

Syntax:

Explorer [/n] [/e][,/root,object][[,/select],subobject]

Parameter:

/root,object | Wenn Sie diesen Parameter angeben, wird der Pfad im Explorer als Root angezeigt (Sie können nicht weiter * blättern) Beispiel: Explorer /e,/root,c:\windows\system
/e | Auf der linken Seite wird ein Verzeichnisbaum angezeigt. Wenn Sie diesen Parameter weglassen, wird im Explorer nur der Ordnerinhalt angezeigt.
/n | Öffnet immer einen neuen Explorer, auch wenn schon einer geöffnet ist.
subobject | Legt den Ordner fest, der den FOCUS erhält, wenn der Explorer gestartet wird. Als Standard ist root definiert. Das ist nicht in Verbindung mit /SELECT möglich
/select | Legt fest, dass ein Ordner geöffnet wird und ein Objekt im Ordner selektiert ist

Info Unter Windows 2000 müssen Sie hinter "/select" noch ein Komma setzen, also
"Explorer /e,/select," bzw. "Explorer /e,/select,C:", ansonsten kommt es zu einem Absturz.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0638.htm


Wiederherstellen der Grafikvorschau im Explorer

Es gibt 2 Möglichkeiten, diese Vorschau wieder herzustellen.

Variante 1:

Bei dieser Variante muss ein Programm gestartet werden. Hierzu klickt man auf den "Start"-Button und danach auf den Befehl "Ausführen".

Nun wird folgender Befehl eingegeben und danach mit Enter bestätigt:

Für Internet Explorer 4 Benutzer:

regsvr32.exe /i shdocvw.dll

Für Internet Explorer 5 Benutzer:

regsvr32.exe /i shdoc401.dll

Variante 2:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die Änderungen müssen in [HEY_CLASSES_ROOT] vorgenommen werden. Öffnen Sie diesen Zweig und suchen Sie nach der gewünschten Dateierweiterung (z.B..JPG). Nun müssen Sie in den Unterordner [ShellEx], wenn dieser nicht vorhanden ist, müssen Sie ihn anlegen. Zum Erstellen dieses Schlüssels klicken Sie mit der rechten Maustaste auf die gewünschte Dateierweiterung und klicken Sie auf "NEU" und "SCHLÜSSEL". Geben Sie dem Schlüssel den Namen "ShellEx". Nun müssen Sie einen weiteren Schlüssel in diesem ShellEx erstellen. Das Vorgehen ist das gleiche.

Nennen Sie den neuen Schlüssel wie folgt:

{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

Nun müssen Sie den Standardwert dieses Schlüssel bearbeiten. Hierzu klicken Sie mit der rechten Maustaste auf das Wort "Standard" und gehen auf Bearbeiten. Jetzt sehen Sie ein Dialogfeld, in dem die letzte Zeile mit dem Namen "Wert" noch leer ist. In dieses Feld schreiben Sie nun folgenden Wert:

{7376D660-C583-11d0-A3A5-00C04FD706EC}

Diese Einträge können Sie nun bei jeder beliebigen Dateierweiterung vornehmen. Bei diesen Einträgen war es nicht notwendig, den Rechner neu zu starten. Bitte bedenken Sie aber, dass es bei manchen Änderungen der Registry-Datei notwendig ist, das System neu zu starten, da sonst die Änderungen nur teilweise oder überhaupt nicht wirksam werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0509.htm


Einstellungsmöglichkeiten des Menüs Ordneroptionen im Explorer erweitern

Viele Einstellungen, die Sie hier in der FAQ finden, beschäftigen sich mit Änderungen in der Registry. Wollen Sie einige Einstellungen nur unter bestimmten Bedingungen aktivieren, müssen Sie sich durch die Registry hangeln.

Unter Windows 95/98 bzw. NT 4.x mit IE 4 haben Sie im Explorer unter dem Menü "Ansicht" -> "Ordneroptionen" den Reiter "Ansicht" hier können Sie bei "Erweiterte Einstellungen" weitere Einträge hinzuzufügen. Ab Windows 2000 finden Sie die "Erweiterten Einstellungen" im Explorer unter "Extras" -> "Ordneroptionen" -> "Ansicht".

Auf meiner Homepage finden Sie im Downloadbereich der FAQ (http://www.winfaq.de) schon eine fertige Registry-Datei, die Sie durch einen einfachen Aufruf in die Registry einbinden können. Danach können Sie fast alle Tipps, die sich mit der Änderung der Registry befassen, durch einfaches Anklicken aktivieren. Diese Datei wird kontinuierlich gepflegt und erweitert.

Durch Löschen des folgenden Registry-Zweiges können Sie alles wieder von Ihrem System entfernen.

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced\ WinFAQ

Info Diese Datei wird nach bestem Wissen des Autors erstellt, allerdings sind Fehler nicht auszuschließen. Die Datei wird von mir auf etlichen Systemen getestet, es werden aber keine Garantien für Ihr System übernommen.

Es folgt eine Beschreibung, wie Sie diese Einträge selber erweitern können.

Beispiel zur Erstellung eigener Einträge:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

finden Sie den Schlüssel "Folder" für die schon vorhanden Einträge von Microsoft.

  1. Legen Sie zur Übersichtlichkeit einen weiteren Schlüssel an, den Sie z.B. "WINFAQ Tipps" nennen.
  2. Markieren Sie den Schlüssel "WINFAQ Tipps" und legen Sie unter diesem Schlüssel folgende Werte an.
Wertname | Datentyp | Inhalt | Beschreibung
Typ | Zeichenfolge | group | Legt fest, dass es sich um eine Gruppe handelt
Text | Zeichenfolge | WinFAQ Tipps | Beschriftung, die nachher sichtbar ist
Bitmap | Zeichenfolge | shell32.dll,1 | Icon für die Anzeige

Nach diesem Muster können Sie jetzt nach Belieben weitere Schlüssel anlegen, um Ihre Einträge weiter zu unterteilen. Für dieses Beispiel wurde noch ein weiterer Schlüssel mit dem Namen "Sicher" angelegt, der folgende Einträge enthält:

Wertname | Datentyp | Inhalt | Beschreibung
Typ | Zeichenfolge | group | Legt fest, dass es sich um eine Gruppe handelt
Text | Zeichenfolge | Sicherheitseinstellungen | Beschriftung, die nachher sichtbar ist
  1. Unter diesem Schlüssel muss jetzt für jeden Eintrag, der als Auswahl zu Verfügung stehen soll, ein weiterer Schlüssel angelegt werden. In diesem Beispiel legen wir unter dem Schlüssel "Sicher" einen neuen Schlüssel mit der Bezeichnung "Systemsteuerung" an.
  2. Markieren Sie jetzt den Schlüssel "Systemsteuerung" und legen Sie die nötigen Werte an. Hier erst einmal die Aufstellung der Einträge für das Beispiel, danach folgt die Beschreibung.
Wertname | Datentyp | Inhalt
Type | Zeichenfolge | Checkbox
Text | Zeichenfolge | Systemsteuerung unter Start ausblenden
RegPath | Zeichenfolge | Software\Microsoft\Windows\CurrentVersion\Policies \Explorer
HkeyRoot | DWORD | 80000001
ValueName | Zeichenfolge | NoSetFolders
CheckedValue | DWORD | 1
UnCheckedValue | DWORD | 0
DefaultValue | DWORD | 0

Type | Typ des Tipps. Mögliche Typen sind: Checkbox -> Zum Ankreuzen radio -> Auswahlmöglichkeiten
Text | Der Text, der dem Anwender angezeigt wird
RegPath | Pfad in der Registry, wo der Eintrag erfolgt. Die Angabe erfolgt hier ohne den ersten Registry Hauptschlüsselnamen
HkeyRoot | Hauptschlüsselname als Hex-Wert: 80000000 -> HKEY_CLASSES_ROOT 80000001 -> HKEY_CURRENT_USER 80000002 -> HKEY_LOCAL_MACHINE 80000003 -> HKEY_USERS
ValueName | Wert, der unter dem Registry-Schlüssel angelegt werden soll
CheckedValue | Wert, der unter dem Schlüssel eingetragen werden soll, wenn diese Funktion ausgewählt wurde. Hier ist zu beachten, dass dieser Wert mit dem Datentyp angelegt werden muss, welcher dem zu erstellenden Registry-Wert entspricht.
UnCheckedValue | Wert, der unter dem Schlüssel eingetragen werden soll, wenn diese Funktion nicht ausgewählt ist. Hier ist zu beachten, dass dieser Wert mit dem Datentyp angelegt werden muss, welcher dem zu erstellenden Registry-Wert entspricht.
DefaultValue | Standardwert Hier ist zu beachten, dass dieser Wert mit dem Datentyp angelegt werden muss, welcher dem zu erstellenden Registry-Wert entspricht.

So wie für diesen Tipp können Sie das für jeden weiteren Eintrag durchführen. Sie können die selbsterstellten Registry-Zweige exportieren und somit nach jeder Neuinstallation schnell wieder einbinden.

Zum besseren Verständnis hier eine kurze Beispielsdatei.

Sie brauchen nur die unteren Zeilen zu markieren und über einen Text-Editor als Textdatei unter einem beliebigen Namen mit der Endung .REG abzuspeichern.

=== Hier schneiden ===

REGEDIT4

; Registryzweig anlegen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ]

"Type"="group"

"Text"="WinFAQ Tipps (Stand: 10.02.2000)"

"Bitmap"="shell32.dll,1"

; Weitere Untergruppe zur Übersichtlichkeit

; ------ Anfang ------

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher]

"Type"="group"

"Text"="Sicherheitseinstellungen"

; Der erste Tipp zum anklicken

; ------ Anfang ------

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Ausführen]

"Text"="Ausführen im Startmenü nicht mehr anzeigen"

"Type"="Checkbox "

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"ValueName"="NoRun"

"UnCheckedValue"=dword:00000000

"CheckedValue"=dword:00000001

"DefaultValue"=dword:00000000

; Der zweite Tipp, hier gibt es mehr als nur zwei Möglichkeiten, darum muss mit RADIO gearbeitet werden

; ------ Anfang ------

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Autorun-INF]

"Type"="group"

"Text"="Festlegen ob die Datei AUTORUN.INF ausgeführt werden soll"

"Bitmap"="shell32.dll,4"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Autorun-INF\00]

"Text"="Bei allen Laufwerken wird die Datei ausgeführt"

"Type"="radio"

"ValueName"="NoDriveTypeAutoRun"

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"CheckedValue"=dword:00000000

"DefaultValue"=dword:00000095

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Autorun-INF\5b]

"Text"="Bei einer CD wird die Datei automatisch ausgeführt"

"Type"="radio"

"ValueName"="NoDriveTypeAutoRun"

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"CheckedValue"=dword:0000005b

"DefaultValue"=dword:00000095

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Autorun-INF\95]

"Text"="Bei einer CD und Festplatten wird die Datei beim Doppelklick ausgeführt"

"Type"="radio"

"ValueName"="NoDriveTypeAutoRun"

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"CheckedValue"=dword:00000095

"DefaultValue"=dword:00000095

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Autorun-INF\FF]

"Text"="Die Datei wird nicht ausgeführt"

"Type"="radio"

"ValueName"="NoDriveTypeAutoRun"

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"CheckedValue"=dword:000000ff

"DefaultValue"=dword:00000095

; ------ Ende -------

; Der dritte Tipp

; ------ Anfang ------

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\WinFAQ\Sicher\Systemsteuerung]

"Text"="Systemsteuerung und Drucker im Startmenü ausblenden"

"Type"="Checkbox "

"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer"

"HkeyRoot"=dword:80000001

"ValueName"="NoSetFolders"

"UnCheckedValue"=dword:00000000

"CheckedValue"=dword:00000001

"DefaultValue"=dword:00000000

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0542.htm


Der Explorer wird beim Starten von Windows automatisch geöffnet

Wird beim Start von Windows automatisch der Explorer geöffnet, obwohl Sie keine Einträge dafür im Autostart eingetragen haben, kann das mehrere mögliche Ursachen haben:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Gehen Sie die unten aufgeführten Schritte in der angegebenen Reihenfolge durch und starten Sie den Rechner nach jeder Änderung neu:

  1. In der WIN.INI Datei befinden sich in der Sektion [windows] "Load" oder "Run" Befehle, deren Argumente mit mehr als einem Leerzeichen voneinander getrennt sind, oder eine der Zeilen enthält ein Komma am Ende. Entfernen Sie die überzähligen Leerzeichen bzw. das Komma am Ende der Zeile.
  2. Es kann auch HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer und dort der Eintrag "DesktopProcess" ein Problem darstellen.
    Ist er auf 1 gesetzt, dann wird eine Instanz von Explorer.exe in einem separaten Speicherbereich ausgeführt. Stürzt dann der Explorer beispielsweise ab (in der 2. Instanz), so ist die Taskleiste weiterhin verfügbar. Allerdings kann dieser Schalter unter Umständen ebenfalls zu Schwierigkeiten führen, z.B. ein beim Start aufpoppender Explorer.
  3. In diesem Fall empfiehlt es sich, den Wert wieder zu löschen. (Bei Windows NT hilft Manchmal auch ein Neuaufspielen des Servicepacks)
  4. Der Zweig HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersionoder HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion ist doppelt vorhanden.
    In diesem Fall muss man überprüfen, ob einer der beiden gefahrlos gelöscht werden kann oder ob er vielleicht Daten enthält, die anderswo fehlen.
  5. In letzterem Fall sollte man die fehlenden Daten einfach in den anderen Zweig kopieren. Danach kann der doppelte CurrentVersion-Zweig gelöscht werden.
  6. Einer der Einträge in Run/RunServices/RunOnce etc. ist korrupt. Will heißen, das Ziel existiert nicht mehr oder der Eintrag enthält Sonderzeichen etc... korrupt eben.
  7. Lösung hierfür: Den korrupten Eintrag löschen. Ein Deaktivieren via MSCONFIG funktioniert übrigens bei dieser Problematik Oftmals nicht!
    Alle Starteinträge finden Sie unter: Automatisches Starten von Windows Programmen beim Systemstart.
  8. Windows XP:
    Der Prozess "userinit" wird durch Winlogon doppelt aufgerufen:

Unter dem Schlüssel

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

findet sich ein Eintrag, der folgendem ähnelt:
"Userinit"="C:\WINDOWS\SYSTEM32\USERINIT.EXE,C:\WINDOWS\SYSTEM32\USERINIT.EXE,"
Ändern Sie diesen wie folgt:
"Userinit"="C:\WINDOWS\SYSTEM32\USERINIT.EXE,"

Andere mögliche Fehlerquellen sind Norton Internet Security und Norton Personal Firewall. Hier sollte man testweise einmal auf das automatische Starten verzichten und NIS nach jedem Booten manuell laden oder die NIS (*.exe) per Verknüpfung im Autostartordner starten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
"Windows Explorer Starts When You Start Your Computer (Q228502)" http://support.microsoft.com/?kbid=228502
"Windows Explorer Starts Each Time Windows 95 Is Started (Q145764)" http://support.microsoft.com/?kbid=145764

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0546.htm


Diskettenlaufwerk rattert beim Aufruf des Explorers

Fehler:

Beim Starten des Explorers erfolgt immer ein Zugriff auf das Diskettenlaufwerk.

Behebung:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

den Eintrag "NoDriveTypeAutorun" auf "95 00 00 00" setzen. Vermutlich steht er gerade auf "00 00 00 00", was die Autostartfunktion auch für Diskettenlaufwerke aktiviert.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Autoplay deaktivieren

Weitere Maßnahmen:

  1. Deaktivieren Sie den MS-Office Indexdienst (Find Fast)
    OFF2000 How to Turn Off the Find Fast Indexer (Q199787): http://support.microsoft.com/?kbid=199787
    OFF97 How to Disable the Find Fast Indexer (Q158705): http://support.microsoft.com/?kbid=158705
  2. Löschen Sie sämtliche Einträge der Dokumentenhistorie C:\Windows\Recent
  3. Prüfen Sie, ob auf dem Desktop oder im Startmenü Verknüpfungen existieren, die auf das Diskettenlaufwerk verweisen
  4. Prüfen Sie die Einstellungen ihres Virenscanners
  5. Weitere Artikel zu diesem Thema:
    Floppy Disk Drive Is Active When Opening or Saving Files (Q216752): http://support.microsoft.com/?kbid=216752
    Floppy Drive Is Accessed When You Open My Computer (Q272242): http://support.microsoft.com/?kbid=272242

Info Siehe auch: "Autostartfunktion für unterschiedliche Laufwerke einstellen"für genauere Informationen zum Verändern der Registry.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0593.htm


Dateien im Windowsverzeichnis werden erst nach Bestätigen eines Warnhinweises angezeigt

Nach der Installation von "Active Desktop" bzw. Windows 98 werden im Explorer die Dateien im Windows-Verzeichnis erst angezeigt, wenn man einen Warnhinweis bestätigt hat. Für erfahrenen Anwender erweist sich das aber als eine nervige Sache.

Das Problem tritt nur auf, wenn VIEW AS WEBPAGE aktiviert ist, da dann für jeden Ordner HTML-Seiten hinterlegt werden können (die für den Ordner Hintergrundbilder oder links am Seitenrand eine Vorschau einblenden etc.) Genaueres zu diesen Dateien finden Sie unter: WEB Ansicht von Ordnern

Bestimmte Ordner haben eine angepasste Version dieser versteckten folder.htt, so auch das Windows-Verzeichnis. Hier ist ein JAVA-Script eingebaut, welches diese Warnung bringt. Um das Problem zu lösen, muss im entsprechenden Verzeichnis die (versteckte) folder.htt gelöscht und durch die im \windows\web Verzeichnis enthaltene, gleichnamige Datei ersetzt werden.

Jetzt werden Sie nicht mehr mit störenden Warnhinweisen belästigt.

Unter Windows 2000 gehen Sie folgendermaßen vor:

Beim Zugriff mit dem Explorer auf das Windows- oder System32-Verzeichnis belästigt Windows den Anwender in der Webansicht mit einem Warnhinweis. Diesen kann man deaktivieren, wenn man die Datei DESKTOP.INI in beiden Verzeichnissen in der Form ändert, dass man den Wert ConfirmFileOp auf 0 setzt.

Wenn das nicht hilft, einfach die Datei löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0545.htm


Ordner immer mit Explorer öffnen

Sie können bei Windows die Einstellungen so ändern, dass Ordner immer mit dem Explorer geöffnet werden:

  • Einen beliebigen Ordner öffnen
  • -> "Extras" -> "Ordneroptionen" -> "Dateitypen"
  • Wählen Sie unter "Registrierte Dateitypen" den Eintrag "Ordner" aus
  • Klicken Sie -> "Erweitert" an und selektieren "explore" unter Vorgänge
  • Klicken Sie nun "Als Standard" an.
  • Ab jetzt werden Ordner immer im Explorer geöffnet.

Um das wieder rückgängig zu machen, müssen Sie wieder "OPEN" als Standard einstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0257.htm


Eigener Adressraum für den Explorer

Der Explorer läuft im selben Adressraum wie die Deskbar und der Windows-Desktop. Stürzt der Explorer bzw. der Desktop ab, werden auch die anderen Anwendungen davon betroffen.

Über den Registry-Editor kann man dem Explorer einen eigenen Adressraum zuweisen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

legen Sie hier nun einen neuen Wert als Datentyp REG_DWORD mit dem Namen: "DesktopProcess" und weisen Sie diesem Eintrag den Wert "1" zu. Siehe aber auch "Der Explorer wird beim Starten von Windows automatisch geöffnet".

Sollte der Explorer nun einmal wieder abstürzen, haben Sie weiterhin Zugriff auf den Desktop und die KBar. Bedenken Sie aber, dass durch diese Umstellung nun etwas zusätzlicher Speicher und mehr Prozessorzeit benötigt wird.

Info Sollte nur bei genügend Prozessorleistung und Arbeitsspeicher aktiviert werden.

Info Unter dem IE 4.0 mit Desktop-Erweiterung kommt es zu schweren Funktionsstörungen, z.B. lässt sich nicht einmal mehr der Arbeitsplatz öffnen!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0060.htm


Explorer-Fenster fehlt oder ist leer

Wenn im Windows Explorer das "Ordner"-Fenster fehlt oder das gesamte Explorer-Fenster leer ist, kann die Ursache ein beschädigter Registry-Schlüssel sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

löschen Sie folgenden Eintrag: ExplorerBar

Hilft das nicht, müssen die Dateien "shdocvw.dll" und "mshtml.dll" neu registriert werden:

Start/Ausführen:

regsvr32.exe /i shdocvw.dll [ENTER]

regsvr32.exe /i mshtml.dll [ENTER]

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1203.htm


Bedeutung von EditFlags (Dateitypen)

Der Wert "EditFlags" legen fest, was in der Dialogbox zum Ändern von Dateitypen angezeigt und verändert werden darf. Die Dialogbox finden Sie unter "Systemsteuerung" -> "Ordneroptionen" -> "Dateitypen" oder auch im Explorer: "Extras" -> "Ordneroptionen" -> "Dateitypen". Mit diesen Werten kann man bestimmte Buttons aus/einblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Der Eintrag "EditFlags" in der Registrydatenbank unter:

HKEY_CLASSES_ROOT\ <Dateityp>

bzw.

HKEY_LOCAL_MACHINE\ Software\ Classes\ <Dateityp>

Als <Dateityp> ist die entsprechende Dateibezeichung gemeint (Beispiel Word.Document.8). Wenn Sie die für eine Dateiendung nicht wissen, finden Sie die unter der Dateiendung. Suchen Sie nach der Dateiendung (Beispiel .DOC) und schauen was bei "(Standard)" als Text steht. Das ist der entsprechende <Dateityp> den Sie jetzt suchen können.

HKEY_CLASSES_ROOT\

  • .DOC
    (Standard) = Word.Document.8
  • ...
  • Word.Document.8
    (Standard) = Microsoft Office Word 97 - 2003-Dokument
    EditFlags = 0x00000000

Unter Windows 9x wurde der Eintrag "EditFlags" als Datentyp REG_BINARY (Binärwerte) angelegt, ab Windows XP werden die Einträge als Datentyp REG_DWORD in der Registry angelegt. Es gibt immer noch Programme die diese Werte in den entsprechenden Windows-Versionen als REG_BINARY anlegen. Windows selber kann aber mit beiden Datentypen umgehen.

Flag | Value (DWORD) HEX | Value (Binary) | Beschreibung
<kein Flag> | 0x00000000 | 0000 00 00 | Alle Operationen sind erlaubt.
FTA_Exclude | 0x00000001 | 01 00 00 00 | Der Dateityp wird unter "Ansicht" -> "Optionen" -> "Dateitypen" nicht angezeigt.
FTA_Show | 0x00000002 | 02 00 00 00 | Zeigt den Dateityp wie ein Ordner an, wenn er mit keinem Dateityp verknüpft ist und sich nur um sondern ein durch seine CLSID representiertes Objekt handelt.
FTA_HasExtension | 0x00000004 | 04 00 00 00 | Der Dateityp hat eine Dateinamenerweiterung.
FTA_NoEdit | 0x00000008 | 08 00 00 00 | "Dateitypen" -> "Bearbeiten..." ist deaktiviert. Es können keine neuen Einträge hinzugefügt werden, vorhandene Einträge können nicht geändert oder gelöscht werden
FTA_NoRemove | 0x00000010 | 10 00 00 00 | "Dateitypen" -> "Entfernen" ist deaktiviert. Es können keine Einträge gelöscht werden.
FTA_NoNewVerb | 0x00000020 | 20 00 00 00 | "Dateitypen" -> "Vorgänge" -> "Neu" ist deaktiviert. Es können keine neuen Aktionen fü einen Dateityp angelegt werden.
FTA_NoEditVerb | 0x00000040 | 40 00 00 00 | "Dateitypen" -> "Vorgänge" -> "Bearbeiten" ist deaktiviert. Bestehende Aktionen (wie Drucken, Öffnen, Edit) können nicht bearbeitet werden.
FTA_NoRemoveVerb | 0x00000080 | 80 00 00 00 | "Dateitypen" -> "Vorgänge" -> "Entfernen" ist deaktiviert. Bestehende Aktionen (wie Drucken, Öffnen, Edit) können nicht gelöscht werden.
FTA_NoEditDesc | 0x00000100 | 00 01 00 00 | "Beschreibung" ist deaktiviert. Die Beschreibung des Dateitypen kann nicht gelöscht oder geändert werden.
FTA_NoEditIcon | 0x00000200 | 00 02 00 00 | "Anderes Symbol" ist deaktiviert. Das zugewiesene Icon für den Dateitypen kann nicht gelöscht oder geändert werden.
FTA_NoEditDflt | 0x00000400 | 00 04 00 00 | "Als Standard" ist deaktiviert. Die als Standard festgelegte Aktion (Öffnen, Drucken, Edit) kann nicht verändert oder gelöscht werden.
FTA_NoEditVerbCmd | 0x00000800 | 00 08 00 00 | "Vorgang" ist beim Bearbeiten deaktiviert. Die mit dem Dateitypen verbundenen Befehle können nicht bearbeitet werden.
FTA_NoEditVerbExe | 0x00001000 | 00 10 00 00 | "Anwendung für diesen Vorgang" ist beim Bearbeiten deaktiviert.
FTA_NoDDE | 0x00002000 | 00 20 00 00 | "DDE Verwenden" ist beim Bearbeiten deaktiviert. Die für den dynamische Datenaustausch (DDE)-verwandten Eingänge können nicht modifiziert oder gelöscht werden.
FTA_NoEditMIME | 0x00008000 | 00 80 00 00 | Die Content-Typen und Standard-Dateiendungen können nicht modifiziert oder gelöscht werden.
FTA_OpenIsSafe | 0x00010000 | 00 00 01 00 | Keine Nachfragen beim Download, die Datei wird geöffnet. Diese Einstellung kann auch ein Sicherheitsrisiko bedeuten, da angeklickte Dateien im Internet Explorer oder Outlook Express einfach geöffnet werden und kein entsprechender Dialog erscheint.
FTA_AlwaysUnsafe | 0x00020000 | 00 00 02 00 | Die Dialogbox "Nicht mehr nachfragen" kann nicht aktiviert werden. Über die Datei-Dialogbox kann der Anwender diese Einstellung überschreiben.
FTA_AlwaysShowExt | 0x00040000 | 00 00 04 00 | Zeigt immer die Dateierweiterung an, auch wenn die Option "Erweiterungen bei bekannten Dateitypen ausblenden" unter "Extras" -> "Ordneroptionen" -> "Ansicht" aktiviert wurde.
FTA_NoRecentDocs | 0x00100000 | 00 00 10 00 | Der Dateityp wird nicht in die Liste "Zuletzt geöffnete Dateien" hinzugefügt.

Natürlich sind auch alle Kombinationen aus diesen Einschränkungen denkbar. Dazu müssen Sie einfach die gewünschten Zahlen Addieren, und tragen Sie nun die Summe als Wert ein. Wollen Sie z.B. FTA_NoEdit und FTA_NoRemove setzen, dann müssen Sie Rechen 8+10=18 und den Wert 18 (Hexadezimal) Eintragen.

EditFlags vom Datentyp REG_BINARY nach REG_DWORD umwandeln

Wenn Sie einen Eintrag als REG_BINARY ab Windows XP finden, können Sie diesen Eintrag selber neu als REG_DWORD anlegen. Gehen Sie dafür folgendermaßen vor:

  1. Gehen Sie mit REGEDIT auf den Eintrag und schreiben Sie sich die Werte auf (Beispiel: 12 34 56 78)
  2. Löschen Sie den Eintrag und legen Sie den Wert als REG_DWORD neu an
  3. Geben Sie nun den oben aufgeschriebenen Wert von hinten ein (Beispiel: 78 56 34 12). Dabei bleiben die Zahlengruppen (12, 34usw.) immer zusammen und werden nicht gedreht.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0111.htm


Darstellung von Systemordnern (Ansicht als Webseite) ändern

Wenn Sie das Aussehen der Ordner in der Ansicht "Als Webseite" ändern möchten, müssen Sie die Datei C:\Windows\Web\Folder.htt editieren.

Für bestimmte Systemordner sind folgende Dateien (ebenfalls im Ordner C:\Windows\Web) zuständig:

Ordner | Datei
Arbeitsplatz | Mycomp.htt
DFÜ-Netzwerk | Dial-up.htt
Drucker | Printers.htt
Netzwerkumgebung | Nethood.htt
Papierkorb | Recycle.htt
Systemsteuerung | Controlp.htt

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1252.htm


Ordnerstruktur beim Anklicken öffnen

Ist die Funktion "Einfache Ordneransicht in der Ordnerliste des Explorers anzeigen" aktiv, wird beim Anklicken eines Ordners im Explorer die darunter liegende Ordnerstruktur geöffnet, ohne das auf das Plus-Zeichen geklickt oder ein Doppelklick ausgeführt werden muss. Zusätzlich werden in der Baumstruktur des Explorers die Verbindungslinien nicht mehr angezeigt. Wenn Sie einen anderes Verzeichnis auswählen, wird das zuletzt geöffnete Verzeichnis automatisch geschlossen.

Ist die Funktion nicht aktiv, werden die Verbindungslinien wieder im Explorer angezeigt. Damit aber der Ordner geöffnet wird, müssen Sie einen Doppelklick auf das Verzeichnis ausführen oder auf das Pluszeichen neben dem Ordner klicken. Weiterhin wird in dieser Konfiguration das vorher geöffnete Verzeichnis nicht automatisch wieder geschlossen.

Die Einstellung können Sie folgendermaßen ändern:

Im Explorer im Menü "Extras" -> "Ordneroptionen" -> auf dem Tabreiter "Ansicht" müssen Sie bei der Option "Einfache Ordneransicht in der Ordnerliste des Explorers anzeigen" welche unter "Dateien und Ordner" aufgeführt wird. Zum deaktivieren der Funktion müssen Sie den Haken entfernen (nicht aktivieren), wenn Sie die Funktion aktivieren wollen, muss der Haken gesetzt sein.

In der Registry ändern sie das

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "FriendlyTree" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Funktion ist aktiviert (Öffnet Ordnerstruktur mit einfachen Mausklick)
0 | Funktion ist ausgeschaltet (Doppelklick bzw. Mausklick auf +-Zeichen ist notwendig)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1354.htm


Wo werden die Einträge der MRU-Listen (Dokumente, RUN usw.) abgelegt?

Windows merkt sich von jedem Benutzer die zuletzt benutzten Dateien und ausgeführten Funktionen. Diese Einstellungen werden nicht in einer extra Datei, sondern in der Registrydatenbank abgelegt.

Auf diese MRU-Einträge der einzelnen USER kann aber auch ein anderer Benutzer über die Registry zugreifen und so feststellen, was der Anwender denn so als letztes auf seinem Rechner gemacht hat.

Wollen Sie das verhindern, müssen Sie jedesmal nach Beenden der Arbeit die jeweiligen Einträge in der Registry löschen, automatisch können Sie das diesem "Einträge aus "Dokumente", "RUN" und "URL-History" löschen" ausführen lassen.

Die MRU-Listen finden Sie unter folgenden Registry-Keys

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Current Version\ Explorer

dort gibt es die Schlüssel:

"Doc Find Spec MRU"

"FindComputerMRU"

"RunMRU"

"RecentDocs"

Löschen Sie hier die gespeicherten Informationen von Windows.

Infos zu "RunMRU":

Das Menü "Ausführen" des Startmenüs führt eingetippte Befehle aus und merkt sich dabei die 26 zuletzt eingegebenen Befehle. Hier finden sich die abgespeicherten Einträge. Jedem Buchstaben ist ein Befehl im Klartext zugewiesen. Um einen Befehl zu löschen, klickt man den entsprechenden Eintrag mit der rechten Maustaste an und wählt im Kontextmenü "Löschen". Man löscht damit zwar den gesamten Eintrag und nicht nur dessen Wert. Neue Einträge legt Windows bei Bedarf aber wieder automatisch an.

Info Das automatische Löschen geht diesem "Einträge aus "Dokumente", "RUN" und "URL-History" löschen" einfacher.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0224.htm


Favoriten im Netzwerk benutzen

Wer seine Favoriten im Netzwerk zentral ablegen oder für alle Benutzer die gleichen Favoriten zur Verfügung stellen möchte, kann dies nur über die Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Man kann den Pfad in der Registry unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders\ Favorites

eingeben.

Dabei ist zu beachten, dass man entweder den UNC-Pfad in der Form \\<Rechner>\<Freigabename>\<Ordner> benutzt (Ordner freigeben) oder den betreffenden Ordner als Laufwerk fest verbindet und dann diesen Pfad benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1201.htm


Den Eintrag 'Öffnen mit' im Kontextmenü bearbeiten

Den Eintrag "Öffnen mit" im Kontextmenü bearbeiten

Wenn Sie im Explorer auf eine Datei mit der rechten Maustaste klicken, wird Ihnen ein Kontextmenü angezeigt. Bei einigen Dateiendungen gibt es hier auch den Eintrag "Öffnen mit".

Über einen Eintrag in der Registry können Sie für jede Datei bestimmen, ob dieser Eintrag angezeigt werden soll oder nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Applications

suchen Sie sich das gewünschte Programm aus, welches Sie konfigurieren wollen. Erstellen Sie hier unterhalb des Programmes einen neuen Wert mit dem Namen "NoOpenWith" als Datentyp REG_SZ.

Sobald der Eintrag vorhanden ist, wird das Programm nicht mehr im Kontextmenü-Eintrag "Öffnen mit" angezeigt. Wenn Sie das wieder möchten, dass dieses Programm in der Liste erscheinen soll, müssen Sie diesen Eintrag "NoOpenWith" einfach nur löschen.

Des Weiteren wird die Liste der Vorschläge unter "Öffnen mit" mit der Zeit immer länger. Hier werden die Programm eingetragen, die Sie schon einmal damit verwendet haben. Diese Liste wird in der Registry jeweils unter der entsprechenden Dateiendung abgelegt. Hier können Sie die Liste auch entsprechend bearbeiten und nicht mehr gewünschte Einträge wieder löschen. Gehen Sie dafür unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ FileExts\ <Dateiendung>\

Ersetzen Sie <Dateiendung> für die Dateiendung wo Sie die Liste bearbeiten wollen.

Hier finden Sie den Schlüssel "OpenWithList", wo Sie jetzt entsprechende Einträge löschen oder hinzufügen können. Alle Einträge müssen hier als Datentyp REG_SZ angelegt werden.

Zusätzlich gibt es noch den Schlüssel "OpenWithProgids". Die Einträge unterhalb dieses Schlüssels sind alternative Programme für diesen Dateitypen. Diese Programme erscheinen auch in der "Öffnen mit" Liste. Wird bei einer Dateiendung das Standard-Programm zum öffnen geändert, wird automatisch das vorherige Programm hier eingetragen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1767.htm


Alte Oberfläche im Windows Explorer

Durch einen Eintrag in der Registry können Sie einige Desktoperweiterungen ausschalten (z.B. den Eintrag Favoriten aus dem Startmenü und die Symbolleiste Schnellstart in der Taskleiste werden ausgeschaltet). Weiterhin wird "Active Desktop" und "Webansicht" deaktiviert, so das die Oberfläche wie die von WIndows NT aussieht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ClassicShell" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Active Desktop" und "Webansicht" deaktivieren
gelöscht | "Active Desktop" und "Webansicht" sind erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Klassische Shell aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dieser Eintrag bringt aber nur wenige KByte Speichergewinn, so dass sich das Ausschalten eigentlich nicht lohnt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0627.htm


Dateien im Explorer verstecken/anzeigen (wie PIF und LNK Dateien)

Die Dateitypen PIF und LNK werden selbst bei Aktivierung von "Anzeige" -> "Optionen" -> "Ansicht" -> "Alle Dateien anzeigen" bzw. ab Windows 2000 unter "Extras" -> "Ordneroptionen" -> Tabreiter "Ansicht" -> "Alle Dateien anzeigen" nicht angezeigt. Wenn Sie diese Dateien auch im Explorer sehen wollen, müssen Sie in der Registry folgende Änderung vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT

finden Sie die Schlüssel "LnkFile" und "PifFile". Löschen Sie dort jeweils die Zeichenkette "NeverShowExt" . Legen Sie eine neue Zeichenfolge mit dem Namen "AlwaysShowExt" an. Nun sollten Sie auch diese Dateien wieder im Explorer sehen.

Info Wenn Sie die Zeichenfolge "NeverShowExt" bei anderen Dateiendungen Eintragen, können Sie damit bestimmen, welche Dateiendungen nicht angezeigt werden.

Info Siehe dazu auch: Wirklich alle Dateien anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0123.htm


BMP-Dateien im Explorer als Thumbnails anzeigen lassen

Statt des Standard Icons kann man sich im Explorer auch eine Mini-Vorschau der BMP-Dateien anzeigen lassen (verlangsamt aber die Anzeige).

Info Siehe auch Tipp "Bildvorschau für alle unterstützten Formate aktivieren" für das neuere Vergehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Schauen Sie unter

HKEY_CLASSES_ROOT\.BMP

im rechten Fenster beim Eintrag "(Standard)" nach, auf welchen Schlüssel die Bilddatei verweist. Standardmäßig ist hier "Paint.Picture" eingetragen. Suchen Sie diesen Eintrag unter HKEY_CLASSES_ROOT\[der Eintrag]\.DefaultIcon. Für den oberen Fall (Windows Standard) müsste es dann so aussehen:

HKEY_CLASSES_ROOT\ Paint.Picture\ DefaultIcon

Jetzt wählen Sie im rechten Fenster den Eintrag "Standard" aus. Dort ist zur Zeit ein Pfad zu einem Icon eingetragen, welches Windows zum Anzeigen von BMP-Bilder benutzen soll (z.B.: "C:\WINDOWS\System\cool.dll,41"). Löschen Sie diese Angabe und ersetzen Sie die durch ein "%1" (die "" nicht mit eingeben).

Das "%1" sagt Windows, es soll in der betreffenden Datei nach dem Icon suchen. Da aber eine BMP-Datei kein Icon enthält, wird Windows dazu veranlasst, eine Mini-Vorschau für das BILD zu erzeugen.

Info Da Windows jedes Vorschaubild selber neu erzeugen muss, wird die Anzeige verlangsamt, diesem : "IconCache erhöhen" kann man das auch noch etwas beschleunigen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0057.htm


Alle Ordner im Explorer mit gleichem Erscheinungsbild

Verstellt man die Ansicht für einen Ordner im Arbeitsplatz oder Explorer, so hat dies noch lange keine Gültigkeit für alle Ordner.

Selbst dann nicht, wenn man unter "Extras" -> "Ansicht" -> "Ordneroptionen" -> "Wie aktueller Ordner" anklickt (für Windows 98 unter "Ansicht" -> "Ordneroptionen" -> "Ansicht"), solange die Funktion "Ansichtoption für jeden Ordner speichern" aktiviert ist. Erst wenn dieses Häkchen deaktiviert wurde, kann man mit der Funktion "wie aktueller Ordner" alle Ordneransichten vereinheitlichen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1129.htm


Farbeinstellung des Verzeichnisbaums

Wenn Sie den Explorer aufrufen, sehen Sie auf der linken Seite den Verzeichnisbaum der Festplatten. Dieser Baum wird durch Striche dargestellt. Die Farbe dieser Striche können Sie in der Registry beliebig ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Colors

gibt es den Wert "GrayText". Hier können Sie die Farbe einstellen.

Diesem Wert können Sie nun die gewünschte Farbe im Format "RR GG BB" zuweisen.
Ersetzen Sie "RR", "GG" und "BB" durch den jeweiligen Farbanteil Rot, Grün und Blau.

Farbe | RR | GG | BB
Rot | 255 | 0 | 0
Grün | 0 | 255 | 0
Gelb | 255 | 255 | 0
Cyan | 0 | 255 | 255
Magenta | 255 | 0 | 255
Braun | 165 | 42 | 42
Weiß | 255 | 255 | 255
Schwarz | 0 | 0 | 0
Blau | 0 | 0 | 255

Info Leider wird diese Einstellung nicht nur für den Explorer-Verzeichnisbaum verwendet, sondern auch für verdunkelte Texte im Kontextmenü.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0258.htm


Dateien werden in der Detailansicht nicht angezeigt

Wenn im Windows Explorer oder im "Suchen"-Fenster keine Dateien angezeigt werden (betrifft nur Detailansicht), liegt es meist daran, dass die Spalten zusammengeschoben sind. Mit der Tastenkombination STRG und "+" wird die Anzeige wiederhergestellt.

Beachten Sie bitte, dass Sie das Pluszeichen vom Ziffernblock der Tastatur verwenden müssen.

Weitere nützliche Tastenkombinationen finden Sie hier.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1198.htm


Explorer: Anordnung der Spalten individuell anpassen

Sie können die Reihenfolge der Spalten im Dateifenster des Windows Explorers (Standard: Dateiname, Größe, Typ, Geändert am, Attribute) einfach ändern, indem Sie auf eine der Spaltenüberschriften klicken und diese dann nach links oder rechts an die gewünschte Stelle ziehen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1204.htm


Explorer: Standard-Dateiansicht einstellen

Sie können in der Registry einstellen, wie der Windows Explorer die Dateien standardmäßig anzeigen soll (Große Symbole, kleine Symbole, Liste, Details).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 95,98,ME

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ExpView

finden Sie den Eintrag "Settings" als Datentyp REG_BINARY, ändern Sie das 45. Byte (Zeile 6, Spalte 5) wie folgt:

Wert | Darstellung als
01 | Große Symbole
02 | Kleine Symbole
03 | Liste
04 | Details

Ist der Eintrag nicht vorhanden, oder zum einfachen Update benutzen Sie folgenden Text

=== Hier schneiden ===

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ExpView]

"Settings"=hex(3):40,00,00,00,00,00,00,00,01,00,00,00,FF,FF,FF,FF,FF,FF,FF,FF,\

FF,FF,FF,FF,FF,FF,FF,FF,42,00,00,00,42,00,00,00,9A,02,00,00,DD,01,00,00,03,00,00,\

00,00,00,00,00,C0,00,00,00,4E,00,02,00,5D,6B,58,01

=== Hier schneiden ===

Speichern Sie den grünen Text in einer Datei mit den Namen Settings.REG (wichtig ist nur die Endung .REG) und klicken Sie die Datei im Explorer an. Bestätigen Sie die Abfrage, ob die Information in die Registry Importiert werden soll.

Die rote Zahl (hier 03) ist der Wert, den Sie nach Ihren Wünschen anpassen können (siehe Tabelle).

Ab Windows 2000 (XP, Vista usw.)

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Streams

hier finden Sie den Eintrag "Settings" als Datentyp REG_BINARY. Öffnen Sie den Wert und ändern Sie das 5 Byte nach Ihren Wünschen ab.

Wert | Darstellung als
01 | Große Symbole
02 | Kleine Symbole
03 | Liste
04 | Details

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1206.htm


Vollständiger Pfad in der Titelleiste des Explorers

Wenn Sie diesen Tipp aktivieren, wird der vollständige Pfad in der Titelleiste angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ CabinetState

Erstellen Sie hier einen neuen Wert mit dem Namen "FullPath" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Vollständigen Pfad anzeigen
0 | Nur Ordnernamen in der Titelleiste anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1704.htm


Vollständiger Pfad in der Adressliste des Explorers

Wenn Sie diesen Tipp aktivieren, wird der vollständige Pfad in der Adressliste angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ CabinetState

Erstellen Sie hier einen neuen Wert mit dem Namen "FullPathAddress" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Vollständigen Pfad anzeigen
0 | Nur Ordnernamen anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1705.htm


Versteckte Dateien und Ordner im Explorer anzeigen

Mit diesem Tipp legen Sie fest, ob versteckte Dateien und Ordner im Explorer angezeigt werden. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Versteckte Dateien und Ordner" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Hidden" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verstecke Dateien und Ordner anzeigen
2 | Verstecke Dateien und Ordner ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1707.htm


Geschützte Systemdateien im Explorer anzeigen

Mit diesem Tipp legen Sie fest, ob geschützte Systemdateien im Explorer angezeigt werden. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> "Ordneroptionen" im Tabreiter "Ansicht" -> {hier die Einstellung "Geschützte Systemdateien ausblenden (empfohlen)"} entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowSuperHidden" als Datentyp REG_DWORD, und setzen Sie den entsprechenden Wert auf:

1 | Systemdateien anzeigen
0 | Systemdateien ausblenden

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced\ Folder\ SuperHidden

Erstellen Sie hier einen neuen Wert mit dem Namen "DefaultValue" als Datentyp REG_DWORD, und setzen Sie den entsprechenden Wert auf:

1 | Systemdateien anzeigen
0 | Systemdateien ausblenden

Wenn Sie jetzt auf den Windowsordner klicken, wird Ihnen nicht die Liste der Dateien angezeigt, sondern einen Warnmeldung (Diese Dateien sind ausgeblendet. Dieser Ordner enthält Dateien, die die Systemstabilität gewährleisten. Sie sollten den Inhalt des Ordners nicht modifizieren.). Hier müssen Sie erst auf "Ordnerinhalte anzeigen" klicken, damit Ihnen der Inhalt angezeigt wird. Wenn Sie das nicht wollen, müssen Sie folgenden Eintrag ändern:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced\ Folder\ SuperHidden

Erstellen Sie den Eintrag mit dem Namen "WarningIfNotDefault" als Datentyp REG_SZ. Löschen Sie den Wert, damit die Meldung nicht mehr angezeigt wird. Wenn Sie den Eintrag wieder anlegen wollen, dann tragen Sie hier folgenden ein: "@shell32.dll,-28964".

Info Werden immer noch nicht alle Dateien angezeigt, beachten Sie auch den Tipp "Wirklich alle Dateien anzeigen"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1710.htm


Dateinamenerweiterung im Explorer anzeigen

Mit diesem Tipp können Sie einstellen, ob die Dateinamens-Erweiterungen im Explorer angezeigt werden sollen. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Erweiterungen bei bekannten Dateitypen ausblenden" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "HideFileExt" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Dateiendungen anzeigen
1 | Dateiendungen nicht anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1711.htm


Den Eintrag 'Eigene Dateien' vom Desktop und aus dem Explorer entfernen

Den Eintrag "Eigene Dateien" vom Desktop und aus dem Explorer entfernen

Durch diesen Tipp können Sie das Symbol "Eigene Dateien" vom Desktop, aus Windows Explorer und aus dem Standarddialog "Öffnen" entfernt.

Durch diese Einstellung wird das Symbol "Eigene Dateien" nicht aus dem Startmenü entfernt. Verwenden Sie dazu den Tipp "Eigene Dateien aus dem 'Startmenü' ein-/ausblenden".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ NonEnum

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ NonEnum

erstellen Sie einen neuen Wert mit dem Namen "{450D8FBA-AD25-11D0-98A8-0800361B1103}" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Eigene Dateien" ausblenden
gelöscht | Desktop-Icons nicht ausblenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Symbol "Eigene Dateien" vom Desktop entfernen

Info:

Wenn Sie die Einstellung über die Oberfläche verändern wird ( "Systemsteuerrung" -> "Anzeige" -> unter dem Tabreiter "Desktop" -> Button "Desktop anpassen..." unter "Desktopsymbole"), wird der Key unter dem folgenden Schlüssel eingetragen:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ HideDesktopIcons\ ClassicStartMenu

Info Sollte das nicht funktionieren, entfernen Sie den entsprechenden Schlüssel unter:
HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1108.htm


Den Eintrag 'Ordneroptionen' entfernen

Mit diesem Wert können Sie festlegen, dass keine Ordneroptionen mehr im Startmenü unter "Einstellungen" und im Explorer angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFolderOptions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Menüeintrag "Ordneroptionen" aus dem Menü "Extras" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1377.htm


Laufwerke ausblenden

Durch einen Eintrag in der Registrydatenbank können Sie Laufwerke ausblenden. Diese Laufwerke werden dann unter "Arbeitsplatz" und im Explorer nicht mehr angezeigt.

Das Ausblenden hat allerdings Auswirkungen auf einige Einträge im Startmenü. Siehe dazu "Aufrufe im START-Button sind grau hinterlegt".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

kann man mit den Schlüssel "NoDrives"

  • als Datentyp REG_BINARY (9x und ME)
  • als Datentyp REG_DWORD (NT und ab 2000)

durch Setzen von Bitmasken Laufwerke ausblenden.

Wird der Schlüssel als Datentyp BINARY angelegt, dann gilti n diesem Fall:

"AA BB CC DD" entsprichtdem DWORD "DDCCBBAA"

Binärwert (von rechts nach links): Byte 1 (ganz rechts) kontrolliert Laufwerk [A: bis H:], Byte 2 [I: bis P:] usw.

Byte 1 Bit 1 bedeutet: 00 00 00 01 -> Laufwerk A

Byte 1 Bit 2 bedeutet: 00 00 00 02 -> Laufwerk B

Byte 1 Bit 3 bedeutet: 00 00 00 04 -> Laufwerk C

Byte 1 Bit 4 bedeutet: 00 00 00 08 -> Laufwerk D

Byte 1 Bit 5 bedeutet: 00 00 00 10 -> Laufwerk E

Byte 1 Bit 6 bedeutet: 00 00 00 20 -> Laufwerk F

etc.

Byte 2 Bit 1 bedeutet: 00 00 01 00 -> Laufwerk I

Über eine einfache Bitliste können Sie den erforderlichen Wert leicht ausrechnen:

b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1
z | y | x | w | v | u | t | s | r | q | p | o | n | m | l | k | j | i | h | g | f | e | d | c | b | a

Schreiben Sie jetzt einfach unter jeden Buchstaben eine "1" für ausblenden bzw. eine "0" für sichtbar. Diese Zahlenreihe rechnen Sie nun mit dem Windows Taschenrechner (Eingabe im Binärmodus) in einen Hexadezimalwert um, den Sie dann in die Registry Eintragen können.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Diese angegebenen Datenträger im Fenster "Arbeitsplatz" ausblenden

Info Laufwerke, die derart ausgeblendet werden, sind trotzdem unter WINFILE.EXE sichtbar. Auch können sie über UNC-Namen (\\Server\Freigabe\...) noch angesprochen werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=158457

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0382.htm


Das Kontextmenü vom Desktop und Explorer deaktivieren

Wenn Sie diese Funktion aktivieren, kommt kein Displaymenü mehr beim Klicken mit der rechten Maustaste auf den Desktop oder Explorer. Bei NT 4.0 erst ab Service Pack 2 möglich.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoViewContextMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Kontextmenü wird nicht angezeigt
gelöscht | Kontextmenü wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Standardkontextmenü aus Windows Explorer entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Bei NT 4.0 erst ab Service Pack 2 vorhanden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1585.htm


'Desktop (Verknüpfung erstellen)' fehlt im 'Senden an'-Menü

"Desktop (Verknüpfung erstellen)" fehlt im "Senden an"-Menü

Sollte einmal der Eintrag "Desktop (Verknüpfung erstellen)" im 'Senden an'-Menü fehlen, können Sie diesen wie folgt wiederherstellen:

  1. Wechseln Sie in das Verzeichnis:
    Win9x/ME: %WINDIR%\SendTo
    Ab Windows NT: %UserProfile%\SendTo
  2. Legen Sie eine neue (leere) Datei an
  3. Benennen Sie die Datei nach Ihrem Geschmack. Die Dateierweiterung (Extension) muss allerdings "desklink" lauten.
    Beispiel: "Desktop (Verknüpfung erstellen).desklink"

Weitere Links unter "Senden an" lauten:

E-Mail-Empfänger.mapimail-> Senden an E-Mail-Empfänger

Eigene Dateien.mydocs-> Senden an Eigene Dateien

ZIP-komprimierten Ordner.ZFSendtoTarget -> Senden an ZIP

Info Wichtig ist hier immer nur der Text nach dem Punkt (.). Den Text davor können Sie nach Ihren Wünschen anpassen. Weiterhin darf nach dem Punkt keine weitere, zusätzliche Dateiendung (z.B. .txt) mehr folgen. Deshalb müssen Sie im Windows-Explorer vorher unter dem Menü "Extras" -> "Ordneroptionen" im Tabreiter "Ansicht" überprüfen, ob die Option "Erweiterungen bei bekannten Dateitypen ausblenden" nicht aktiviert ist.

Info Weitere Informationen zu "Senden an" finden Sie unter: Kontextmenü: Senden an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1290.htm


Kontextmenü im linken Fenster des Explorers bearbeiten

Einige Programme tragen sich in das Kontextmenü des Explorers auf der linken Seite ein. Wenn Sie diese Programm wieder entfernen wollen oder eigene Einträge hinzufügen möchten, können Sie das unter den folgenden Schlüssel machen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_CLASSES_ROOT \ Folder\ shellex\ ContextMenuHandlers

hier finden Sie die entsprechenden Einträge. Wenn Sie einen Eintrag loswerden wollen, müssen Sie nur den Schlüssel löschen.

Siehe auch "Wie kann man das Kontextmenü NEU verändern?".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1278.htm


Diskette kopieren fehlt im Kontextmenü

Sollte der Eintrag "Diskette kopieren" im Kontextmenü fehlen, kann das mehrere mögliche Ursachen haben.

Defekte oder fehlende Einträge in der Registry

Es liegt ein Fehler in den CLSID Schlüsseln der Registry vor.

Folgende Zeilen als .REG-Datei abspeichern, mit der rechten Maustaste anklicken und "Zusammenführen" wählen.

Die letzte Zeile der Datei MUSS leer sein.

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID\{59099400-57FF-11CE-BD94-0020AF85B590}]
@="DiskCopy"

[HKEY_CLASSES_ROOT\CLSID\{59099400-57FF-11CE-BD94-0020AF85B590}\InProcServer32]
@="c:\\windows\\system\\diskcopy.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandlers\{59099400-57FF-11CE-BD94-0020AF85B590}]
@=""

=== Hier schneiden ===

Defekte oder fehlende Datei Diskcopy.dll

  1. Starten Sie den Rechner im MS-DOS -Modus bzw. booten Sie von einer DOS -Bootdiskette
  2. Falls die Datei C:\Windows\System\Diskcopy.dll vorhanden ist, bennenen Sie diese in Diskcopy.old um
  3. Stellen Sie die Datei von der Original-CD wieder her:
    Windows 95: extract /L C:\Windows\System WIN95_17.CAB DISKCOPY.DLL
    Windows 98: extract /L C:\Windows\System win98_28.cab diskcopy.dll
    Windows ME: extract /L C:\Windows\System win_10.cab diskcopy.dll
  4. Geben Sie "Exit" ein bzw. entfernen Sie die Diskette aus dem Laufwerk und starten Sie den Rechner neu

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=154925

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0922.htm


Suchen im Kontextmenü von Systemordnern fehlt

Standardmäßig enthalten die Kontextmenüs der Systemordner "Eigene Dateien" und "Favoriten" keine Option zum Suchen. Auch hier lässt sich über die Registry Abhilfe schaffen.

Eigene Dateien:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell]
[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell\find]
[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell\find\command]
@="C:\\Windows\\Explorer.exe"

[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell\find\ddeexec]
@="[FindFolder(\"%l\", %I)]"

[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell\find\ddeexec\application]
@="Folders"

[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\shell\find\ddeexec\topic]
@="AppProperties"

=== Hier schneiden ===

Favoriten:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell]
[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell\find]
[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell\find\command]
@="C:\\Windows\\Explorer.exe"

[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell\find\ddeexec]
@="[FindFolder(\"%l\", %I)]"

[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell\find\ddeexec\application]
@="Folders"

[HKEY_CLASSES_ROOT\CLSID\{1A9BA3A0-143A-11CF-8350-444553540000}\shell\find\ddeexec\topic]
@="AppProperties"

=== Hier schneiden ===

Info Siehe auch Suchen im Kontextmenü fehlt,

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1208.htm


'Suchen' im Kontextmenü fehlt

Sollte die Funktionen "Suchen" im Kontextmenü fehlen, kann man diese über eine REG-Datei wieder herstellen:

----- Anfang -----
REGEDIT4

[HKEY_CLASSES_ROOT\Drive\shell\find]
@=""
[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec]
"NoActivateHandler"=""
@="[FindFolder(\"%l\", %I)]"

[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec\application]
@="Folders"

[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec\topic]
@="AppProperties"

[HKEY_CLASSES_ROOT\Drive\shell\find\command]
@="C:\\WINDOWS\\Explorer.exe"

----- Ende -----

Info Siehe auch Suchen im Kontextmenü von Systemordnern fehlt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0954.htm


POP-UP Menü des START Buttons in der Taskleiste erweitern

PopUp-Menü des "Start" Buttons in der Taskleiste erweitern

Wenn Sie auf das Startmenü mit der rechten Maustaste klicken, öffnet sich ein kleines Menü (Kontextmenü) mit einigen wenigen Einträgen.

Sie können noch zusätzliche Punkte in das Kontextmenü aufnehmen, hier ein Beispiel zur Aufnahme von "DOS-Fenster öffnen".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Directory\ Shell

hier müssen Sie nun für jeden zusätzlichen Eintrag einen neuen Schlüssel anlegen. Wählen Sie einen beliebigen Namen und tragen Sie unter "(Standard)" den Namen ein, wie er unter dem Menü angezeigt werden soll (Ein & Zeichen vor einem Buchstaben macht diesen zum Hotkey).

Erstellen Sie unter diesem Schlüssel einen neuen Schlüssel mit dem Namen "Command" und tragen Sie unter dem Wert "(Standard)" den Befehl ein, der ausgeführt werden soll.

Hier ein Beispiel für den Eintrag von WordPad in das Kontextmenü

HKEY_CLASSES_ROOT\ Directory\ Shell\ WordPad

der Wert "(Standard)" hat den Eintrag "&WordPad"

HKEY_CLASSES_ROOT\ Directory\ Shell\ WordPad\ Command

der Wert "(Standard)" hat den Eintrag "C:\Programme\Zubehör\WordPad.exe"

Noch ein Beispiel:

  1. Legen Sie unter Shell einen neuen Schlüssel an "Bearbeiten" -> "Neu" -> "Schlüssel" und geben einen beliebigen Namen ein (z.B. "DOS-Fenster")
  2. Markieren Sie diesen Namen und doppelklicken im rechten Fenster auf "Standard". Geben Sie hier die Zeichenfolge ein, die später im Kontextmenü erscheinen soll (z.B. "DOS &Fenster öffnen"). Das & legt die Kurztaste fest, hier wäre es also das F.
  3. Legen Sie unter dem neuen Schlüssel (z.B. "DOS-Fenster") einen weiteren Schlüssel an und nennen ihn "Command".
  4. Markieren Sie "Command" und doppelklicken Sie auf "Standard" (im rechten Fenster)
  5. Tragen Sie dort den Pfad des zu startenden Programms ein. In diesem Falle also (C:\Windows\command.com /K "%1")

Info Durch das Löschen von Schlüsseln unterhalb von "HKEY_CLASSES_ROOT\ Directory\ Shell\" können Sie natürlich auch Einträge aus dem Kontextmenü entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0260.htm


Kontextmenü unter Start bearbeiten

siehe Tipp: "PopUp-Menü des "Start" Buttons in der Taskleiste erweitern"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0209.htm


Kontextmenü vom Arbeitsplatz, Netzwerkumgebung und 'Eigene Dateien' erweitern

Kontextmenü vom Arbeitsplatz, Netzwerkumgebung und "Eigene Dateien" erweitern

Auf dem Desktop befindet sich standardmäßig - bei jedem Anwender - das Icon "Arbeitsplatz". Wenn Sie mit der rechten Maustaste auf dieses Icon klicken, öffnet sich das sogenannte "Kontextmenü". Hier sind einige Funktionen schon von MS abgelegt.

Da dieses Icon sehr zentral liegt, ist es sinnvoll, das Kontextmenü um bestimmte Funktionen zu erweitern. Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ [Kontextmenü ID]\ Shell

Kontextmenü ID:

Papierkorb | {645FF040-5081-101B-9F08-00AA002F954E}
Drucker | {645FF040-5081-101B-9F08-00AA002F954E}
Arbeitsplatz | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Netzwerkumgebung | {208D2C60-3AEA-1069-A2D7-08002B30309D}
Eigene Dateien | {450D8FBA-AD25-11D0-98A8-0800361B1103}

Erstellen Sie unter diesem Schlüssel einen weiteren neuen Unterschlüssel mit dem Namen, der nachher im Kontextmenü als Beschreibung auftauchen soll (z.B. "Explorer"). Klicken Sie diesen neuen Schlüssel an und erstellen Sie wieder einen neuen Unterschlüssel mit dem Namen "Command". Klicken Sie unter diesem Unterschlüssel "Command" auf der rechten Seite den Eintrag "(Standard)" an. Geben Sie hier die gewünschte Befehlszeile ein (z.B. "Explorer /e,C:\").

Nach diesem Vorgehen können Sie dem Kontextmenü beliebige weitere Einträge hinzufügen.

Info Beispiele für nützliche Einträge finden Sie im Tipp: "Kontextmenü um bestimmte Systemfunktionen erweitern"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0468.htm


Kontexteintrag NEU ist verschwunden

Sollte der Kontexteintrag NEU für Dateien oder Ordner plötzlich fehlen, kann dieser über die Registry wieder hergestellt werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New

weisen Sie dem Eintrag "Standard" folgenden Wert zu:

{D969A300-E7FF-11D0-A93B-00A0C90F2719}

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0893.htm


Wie kann man das Kontextmenü "Neu" verändern?

Wenn Sie im Explorer oder auf der Arbeitsoberfläche (Desktop) die rechte Maustaste drücken, öffnet sich ein Kontextmenü. Hier finden Sie u. a. den Auswahlpunkt "NEU", unter dem eine Reihe von Dateitypen zum Anlegen zur Verfügung stehen. Diese Liste können Sie verkürzen oder um weitere Dateitypen erweitern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT

Löschen:

Nehmen wir an, Sie möchten den Eintrag "Textdatei" aus dem Kontextmenü (Option "Neu") entfernen.

Finden Sie die entsprechende Endung (hier also ".TXT"), öffnen Sie den Schlüssel und löschen den Unterschlüssel "ShellNew".

Nun wird "Textdatei" im Kontextmenü nicht mehr angezeigt.

Diese Änderung können Sie auch mit Tweak UI 1.33 vornehmen.
Siehe "Tweak UI 1.33: Alle Funktionen im Überblick".

Neue Einträge einfügen (ohne Vorlage):

Finden Sie die entsprechende Endung (z.B. ".TXT"), öffnen Sie diesen Schlüssel und dann den Unterschlüssel "ShellNew" (falls nicht vorhanden, erstellen) und fügen Sie dort die Zeichenfolge "NullFile" ein (-> "Bearbeiten" -> "Neu" -> "Zeichenfolge").

Im Kontextmenü erscheint nun unter "Neu" der Dateityp, mit dem diese Endung verknüpft ist (z.B. Textdatei für TXT).

Alternative (mit Vorlage):

Öffnen Sie im Explorer %WinDir%\ShellNew und erstellen Sie dort eine Dokumentvorlage für den gewünschten Dateityp (z.B. WINWORD.DOC für *.DOC-Dateien oder DUMMY.BAT für.BAT-Dateien). Diese Datei können Sie leer lassen oder als Vorlage mit Inhalt verwenden. Wenn Sie die Datei editieren, wird in jede neue Datei dieses Typs, die Sie über "Neu" anlegen, dieser Inhalt übernommen.

Als nächstes suchen Sie in der Registry die entsprechende Endung (z.B. ".DOC"), öffnen den dazugehörigen Schlüssel und dann den Unterschlüssel "ShellNew" (falls nicht vorhanden, erstellen). Fügen Sie dort die Zeichenfolge "FileName" ein (-> "Bearbeiten" -> "Neu" -> "Zeichenfolge") und weisen Sie ihr als Wert den Namen der Vorlage zu (hier also WINWORD.DOC).

Nun wird im Kontextmenü der Dateityp erscheinen, der mit dieser Endung verknüpft ist (z.B. Microsoft Word-Dokument für DOC).

Diese Änderung können Sie auch mit Tweak UI 1.33 vornehmen.
Siehe "Tweak UI 1.33: Alle Funktionen im Überblick".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0327.htm


Kontextmenü: Senden an

Kontextmenü "Senden an"

Wenn Sie mit der rechten Maustaste auf eine Datei klicken, gibt es den Unterpunkt "Senden an". Hier können Sie jede Art von Anwendung unterbringen, um eine Datei mit dieser zu bearbeiten. Legen Sie hierfür eine neu Verknüpfung in das Unterverzeichnis "SendTo"

Windows 9x/ME:

Hier finden Sie das SendTo Verzeichnis im Windows-Verzeichnis, weitere Einträge müssen Sie hier als Verknüpfung ablegen.

Ab Windows NT:

Hier finden Sie das Verzeichnis im Profil des jeweiligen Benutzers: "%Userprofile%\SendTo"

Der Pfad zum Verzeichnis finden Sie in der Registry und Sie können hier auch einen anderen Ordner angeben:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

finden den Eintrag "SendTo" als Datentyp REG_EXPAND_SZ (bzw. bei Windows 9x/ME als REG_SZ). Sie können hier jetzt einen beliebigen Pfad eintragen, bei Datentyp REG_EXPAND_SZ können Sie auch mit Variablen (z.B.: %UserProfile%) arbeiten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0205.htm


'Kopieren nach/Verschieben nach' im Kontextmenü

Im Kontextmenü von Dateien und Ordner (bei Rechtsklick auf eine Datei oder einen Ordner) finden Sie den Eintrag "Senden an". Hilfreich wären aber auch die Einträge "In Ordner kopieren" und "In Ordner verschieben". Mit diesem Tipp wird Ihnen gezeigt wie Sie die Einträge hinzufügen können:

- In Ordner kopieren...

- Verschieben nach Ordner...

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_CLASSES_ROOT\ AllFileSystemObjects\ shellex\ ContextMenuHandlers

erstellen Sie jeweils die gewünschten neuen Schlüssel mit den folgenden Werten:

Schlüsselname | Wert für (Standard) | Beschreibung
Send To | {7BA4C740-9E81-11CF-99D3-00AA004AE837} | Senden an
Copy To | {C2FBB630-2971-11D1-A18C-00C04FD75D13} | In Ordner kopieren
Move To | {C2FBB631-2971-11D1-A18C-00C04FD75D13} | In Ordner verschieben

Anschließend haben Sie z.B. den Registryschlüssel

HKEY_CLASSES_ROOT\ AllFilesystemObjects\ shellex\ ContextMenuHandlers\ Copy To

wo der Wert "(Standard)" auf "{C2FBB630-2971-11D1-A18C-00C04FD75D13}" steht.

Wenn Sie die Einträge nicht mehr haben wollen, müssen Sie nur den entsprechenden Eintrag unter "HKEY_CLASSES_ROOT\ AllFilesystemObjects\ shellex\ ContextMenuHandlers" löschen.

Info Leider hat diese Funktion einen Nachteil:
Wenn im Explorer mehr als 1 Worddateien markiert wird ( z.B. 3 Stück) und man klickt im Kontextmenü (rechts) auf Öffnen, so startet nicht nur Word, sondern auch die Fenster "Kopieren nach" und "Verschieben nach" und das sogar doppelt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1300.htm


Kontextmenü um bestimmte Systemfunktionen erweitern

Im Tipp "Kontextmenü vom Arbeitsplatz, Netzwerkumgebung und 'Eigene Dateien' erweitern" wird beschrieben, wie Sie das Kontextmenü um eigene Einträge erweitern können. Hier werden einige nützliche Einträge für die Kontextmenüs aufgeführt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ [Kontextmenü ID]\ Shell\ [Anzeigename] \command

Mögliche [Kontextmenü ID] finden Sie im Tipp "Kontextmenü vom Arbeitsplatz, Netzwerkumgebung und 'Eigene Dateien' erweitern". Hier wird als Beispiel immer die [Kontextmenü ID] des Arbeistplatzes ({20D04FE0-3AEA-1069-A2D8-08002B30309D}) benutzt.

Für [Anzeigename] geben Sie einen Text ein, der im Kontextmenü dafür angezeigt werden soll. Anschließend geben Sie beim Wert "(Standard)" den in der Tabelle gezeigten Text ein.

Beispiel:

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Systemsteuerung\command

Bei (Standard) wird jetzt "rundll32.exe shell32.dll,Control_RunDLL" eingetragen.

Was

Wert für Standard-Einstellung

Systemsteuerung

rundll32.exe shell32.dll,Control_RunDLL

Weitere rundll-Aufrufe finden Sie im Tipp: "Funktionen der Dateien Rundll.EXE und Rundll32.EXE"

Bestimmte CPL-Dateien

control [CPL-Datei-Name]

Hiermit können Sie beliebige CPL-Dateien eintragen und aufrufen. Weiteres zu den CPL-Dateinen finden Sie im Tipp: "Bereiche der Systemsteuerung direkt starten"

Beispiel: "control main.cpl" würde die Mauseigenschaften öffnen

Dienste hinzufügen

Hier müssen wir etwas mehr machen, deshalb habe ich hier den Inhalt einer REG-Datei abgelegt:

=== Hier schneiden ===

Windows Registry Editor Version 5.00

;Dienste zum Kontextmenü des Arbeitsplatzes hinzufügen

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Dienste]

@=hex(2):53,00,65,00,72,00,76,00,69,00,63,00,65,00,73,00,00,00

"SuppressionPolicy"=dword:4000003c

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Dienste\command]

@=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,00,73,\

00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,63,00,2e,00,65,00,78,00,\

65,00,20,00,2f,00,73,00,20,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\

00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\

32,00,5c,00,73,00,65,00,72,00,76,00,69,00,63,00,65,00,73,00,2e,00,6d,00,73,\

00,63,00,20,00,2f,00,73,00,00,00

=== Hier schneiden ===

Kopieren Sie den grünen Text in eine Datei mit dem Namen ServiceToKontext.REG(wichtig ist die Dateiendung .REG) und führen Sie anschließend im Explorer einen Doppelklick auf diese Datei aus.

Systemwiederherstellung

Hier müssen wir etwas mehr machen, deshalb habe ich hier den Inhalt einer REG-Datei abgelegt:

== Hier schneiden ===

Windows Registry Editor Version 5.00

;Systemwiederherstellung zum Kontextmenü des Arbeitsplatzes hinzufügen

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Systemwiederherstellung\command]

@=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,00,73,\

00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,65,00,73,00,74,00,6f,00,72,00,\

65,00,5c,00,72,00,73,00,74,00,72,00,75,00,69,00,2e,00,65,00,78,00,65,00,00,\

00

==== Hier schneiden ===

Kopieren Sie den grünen Text in eine Datei mit dem Namen ServiceToKontext.REG(wichtig ist die Dateiendung .REG) und führen Sie anschließend im Explorer einen Doppelklick auf diese Datei aus.

Gerätemanager

Hier müssen wir etwas mehr machen, deshalb habe ich hier den Inhalt einer REG-Datei abgelegt:

=== Hier schneiden ===

Windows Registry Editor Version 5.00

;Gerätemanager zum Kontextmenü des Arbeitsplatzes hinzufügen

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Gerätemanager]

@=hex(2):44,00,65,00,76,00,69,00,63,00,65,00,20,00,4d,00,61,00,6e,00,61,00,67,\

00,65,00,72,00,00,00

"SuppressionPolicy"=dword:4000003c

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Gerätemanager\command]

@=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,00,73,\

00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,63,00,2e,00,65,00,78,00,\

65,00,20,00,2f,00,73,00,20,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\

00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\

32,00,5c,00,64,00,65,00,76,00,6d,00,67,00,6d,00,74,00,2e,00,6d,00,73,00,63,\

00,20,00,2f,00,73,00,00,00

=== Hier schneiden ===

Kopieren Sie den grünen Text in eine Datei mit dem Namen ServiceToKontext.REG(wichtig ist die Dateiendung .REG) und führen Sie anschließend im Explorer einen Doppelklick auf diese Datei aus.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2012.htm


Anwendungen über das Kontextmenü mit "Hoher-Priorität" starten

Mit diesem Tipp können Sie zum Kontextmenü von .EXE Dateien den Eintrag "Ausführen mit Hoher-Priorität" hinzufügen.

Normalerweise werden Anwendungen die Sie im Explorer anklicken in der "Normalen-Prioritätsklasse" ausgeführt. Durch einen Klick mit der linken Maustaste auf die Anwendung können Sie durch Auswählen dieses Eintrages eine Anwendung in der höheren Prioritätsklasse starten, wodurch der Anwendung mehr Rechenzeit zugeteilt wird.

Sie sollten das aber jetzt nicht für alle Anwendungen machen die Sie starten, da Windows die Prozessorzeit mit den normalen Einstellungen schon selber gut verteilt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Classes\ exefile\ shell\

Erstellen Sie hier jeweils untereinander zwei neue Schlüssel "Ausführen mit Hoher-Priorität" und "COMMAND", so das sich anschließend folgender Pfad ergibt:

HKEY_LOCAL_MACHINE\ Software\ Classes\ exefile\ shell\ Ausführen mit Hoher-Priorität\ COMMAND

Geben Sie hier jetzt beim Wert "(Standard)" je nach Betriebssystem folgenden Befehl ein:

Windows 95/98 und ME | command.com /c start "RSW" /high "%1"
Ab Windows NT | cmd.exe /c start "RSW" /high "%1"

Wenn Sie die Einträge nicht mehr benötigen, dann löschen Sie einfach den ganzen Schlüssel "Ausführen mit Hoher-Priorität".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2223.htm


Eingabeaufforderung direkt über das Kontextmenü des Explorers öffnen

Wenn Sie sich im Explorer durch die Verzeichnisse hangeln, kommt es ab und zu einmal vor, dass Sie in einem bestimmten Verzeichnis eine Eingabeaufforderung (DOS-BOX oder auch Kommandozeilenoberfläche genannt) benötigen. Durch einen zusätzlichen Eintrag in das Kontextmenü können Sie eine Eingabeaufforderung öffnen, die sich genau in diesem Pfad befindet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Classes\ Folder\ shell

Legen Sie hier einen neuen Schlüssel mit dem Namen "CMD" an und geben Sie beim Wert "(Standard)" den TExt ein der im Kontextmenü angezeigt werden soll z.B. "Eingabeaufforderung hier öffnen".

Erstellen Sie unter diesem Schlüssel jetzt einen weiteren neuen Schlüssel mit dem Namen "COMMAND". Klicken Sie unter diesem Schlüssel den Eintrag "(Standard)" an.

Eingabeaufforderung im Kontextmenü

Geben Sie folgenden Wert ein:

Für Windows 9x und ME:

"COMMAND.COM /K CD %1"

Ab Windows NT:

CMD.EXE /S /K pushd "%1"

Sie können diesen Eintrag auch über die folgenden REG-Datei anlegen lassen. Sichern Sie dafür den Inhalt als Eingabeaufforderung.REG ab. Durch einen doppelklick im Explorer wird die Datei in die Registry importiert.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\cmd]

@="Eingabeaufforderung hier öffnen"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\cmd\command]

@="CMD.EXE /S /K pushd \"%1\""

=== Hier schneiden ===

Ab Windows Vista:

Finden Sie diesen Eintrag schon unter:

HKEY_CLASSES_ROOT\ Directory\ shell\ cmd\ command

Wenn Sie die neue Powershell vom Microsoft installiert haben (bzw. ab Windows Vista ist die schon mit dabei), können Sie diese über den folgenden Befehl öffnen lassen:

"C:\Windows\system32\WindowsPowerShell\v1.0\powerschell.exe" -noexit -command "set-location '%V'"

Die Pfadangaben zur PowerShell bitte entsprechend anpassen, was bei späteren neuen Versionen nötig sein könnte. Die folgende REG-Datei würde den Eintrag zusätzlich hinzufügen, Sie können natürlich auch den bestehen Eintrag anpassen.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\PowerShell\command]

@="PowerShell hier öffnen"

[HKEY_CLASSES_ROOT\Directory\PowerShell\cmd\command]

@="\"C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\powerschell.exe\" -noexit -command \"set-location '%V'\""

=== Hier schneiden ===

Info Durch die Angabe von /K wird das Fenster mit DOS -Namen (8 Zeichen) geöffnet. Wenn Sie also nicht den langen Verzeichnisnamen haben wollen, fügen Sie das /K ein z.B.: CMD.EXE /K CD %1

Wenn Sie jetzt z.B. im Explorer auf einem Verzeichnis die rechte Maustaste drücken, haben Sie im Kontextmenü noch als zusätzliche Auswahlmöglichkeit "Eingabeaufforderung hier öffnen". Wenn Sie diese anklicken, wird die Eingabeaufforderung geöffnet, die sich im entsprechenden Verzeichnis befindet.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0831.htm


Pfeil bei Verknüpfung ausblenden

Mit diesem Tipp können Sie die Verknüpfungspfeile bei den Icons ausblenden. Diese kleinen Pfeile werden bei Verknüpfungen Standardmäßig angezeigt und sollen somit eine Verknüpfung in Windows kennzeichnen. Die Verknüpfungen kann man gefahrlos löschen, ohne das dabei das eigentliche Programm, auf das die Verknüpfung zeigt, gelöscht wird.

Teilweise wird angeraten, die folgenden 2 Registry-Einträge zu ändern:

HKEY_CLASSES_ROOT\ piffile und

HKEY_CLASSES_ROOT\ lnkfile

Diese Einträge werden aber von Tweak UI nicht gelöscht.

Möglicherweise wird nämlich dieser Eintrag von einigen Programmen abgefragt. Tweak UI benutzt einen anderen Mechanismus (siehe unten), um zur Laufzeit das Shortcut Overlay zu entfernen, ohne die Eigenschaft: "IsShortcut" zu verändern.

Dieser Eintrag sollte immer bei "IsShortcut"="" bestehen bleiben. Wenn dieser Eintrag gelöscht wird oder nicht vorhanden ist, werden auch keine Pfeile bei Verknüpfungen angezeigt. Danach funktionieren andere Funktionen von Windows 7 nicht mehr; z.B. kann man dann keine Verknüpfungen mehr an die Taskbar anheften.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Icons

können die standardmäßig vorgegebenen System-Icons verändert werden. Erstellen Sie einen neuen Wert mit dem Namen "29" als Datentyp REG_SZ. Hier müssen Sie jetzt noch das Icon angeben, welches angezeigt werden soll.

Wenn Sie kein Icon wünschen, müssen Sie auf ein entsprechendes Icon verweisen, welches keinen Pfeil enthält. Der RSW benutzt dazu die Datei RSWIcon.icl bzw. ab Windows Vista die Datei RSWIcon.ico. Dabei handelt es sich um eine Overlaydatei die keinen Pfeil enthält.

Für Windows 7 musste diese Datei wieder angepasst werden, da hier viele unterschiedliche Icon-Größen benötigt werden. Diese Datei wird erst in einer neueren Version vom RSW mitgeliefert.

Anschließend müssen Sie sich wieder neu anmelden, damit die Einstellung wirksam wird.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0273.htm


Standard Icons für Systemordner verändern

Unter Windows können manche Icons standardmäßig nicht verändert werden. Diese Icons sind in einer DLL oder in der EXPLORER.EXE enthalten. Die Zahl nach dem Komma gibt das Icon an (das erste Icon hat die Zahl "0"), z.B. %SYSTEMROOT%\Explorer.exe,0 welches dem ersten Icon in der Explorer.exe entspricht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Arbeitsplatz- Icon:

HKEY_CLASSES_ROOT\ CLSID\ {20D04FE0-3AEA-1069-A2D8-08002B30309D}\ DefaultIcon

Systemsteuerungs-Icon im Explorer:

HKEY_CLASSES_ROOT\ CLSID\ {21EC2020-3AEA-1069-A2DD-08002B30309D}\ DefaultIcon

Drucker-Icon im Explorer:

HKEY_CLASSES_ROOT\ CLSID\ {2227A280-3AEA-1069-A2DE-08002B30309D}\ DefaultIcon

Anwendung für MS-DOS :

HKEY_CLASSES_ROOT\ comfile\ DefaultIcon

Dateierweiterung der Anwendung (DLL-Files):

HKEY_CLASSES_ROOT\ dllfile\ DefaultIcon

Gerätetreiber (DRV-Files):

HKEY_CLASSES_ROOT\ drvfile\ DefaultIcon

Systemdatei (SYS-Files):

HKEY_CLASSES_ROOT\ sysfile\ DefaultIcon

Virtuelle Gerätetreiber (VXD-Files):

HKEY_CLASSES_ROOT\ vxdfile\ DefaultIcon

Posteingangs-Icon:

HKEY_CLASSES_ROOT\ CLSID\ {00020D75-0000-0000-C000-000000000046}\ DefaultIcon

The Microsoft Network:

HKEY_CLASSES_ROOT\ CLSID\ {00028B00-0000-0000-C000-000000000046}\ DefaultIcon

Papierkorb-Icon:

HKEY_CLASSES_ROOT\ CLSID\ {645FF040-5081-101B-9F08-00AA002F954E}

="Papierkorb"

HKEY_CLASSES_ROOT\ CLSID\ {645FF040-5081-101B-9F08-00AA002F954E}\ DefaultIcon

"Empty"

"Full"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0170.htm


Special Desktop Icons

Einige Icons auf dem Desktop und unter Arbeitsplatz können nicht gelöscht, verschoben bzw. umbenannt werden. Das liegt daran, dass es sich nicht um Dateien handelt, sondern um Objekte, die sich intern durch ihre CLSID repräsentieren und auf eine ganz bestimmte Art und Weise angezeigt werden.

Zu finden sind sie in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Auf dem Desktop:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace\ {Nummer}

Im Arbeitsplatz:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ MyComputer\ NameSpace\ {Nummer}

Es sind verschiedene Manipulationen an diesen Objekten möglich, was hier am Beispiel "Papierkorb" gezeigt wird. Man muss für {Nummer} die CLSID des entsprechenden Objektes benutzen, im Falle des Papierkorbs also {645FF040-5081-101B-9F08-00AA002F954E}

Entfernen des Papierkorbs vom Desktop:

Löschen Sie hier nun einfach den Eintrag unter "NameSpace" (hier also {645FF040-5081-101B-9F08-00AA002F954E})

Eintragen des Papierkorbs auf dem Desktop oder im Arbeitsplatz:

Erstellen des Unterschlüssels {Nummer} unter "Desktop\NameSpace" oder "MyComputer\NameSpace"

Umbenennen:

Den Standard-Wert unter "...\NameSpace\{Nummer}" bearbeiten oder Standard-Wert unter HKEY_CLASSES_ROOT\CLSID\{Nummer} bearbeiten

Ändern des Icons:

HKEY_CLASSES_ROOT\ CLSID\ {Nummer} \ DefaultIcon

oder bei bestimmten Systemanforderern unter

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ explorer\ Shell Icons

Als Normalen Ordner erstellen:

Löschen des Eintrags unter NameSpace. Neuen Ordner erstellen, diesen umbenennen in Name.{Nummer}

"Umbenennen" und "Löschen" im Kontextmenü anzeigen:

Unter: HKEY_CLASSES_ROOT\CLSID\{Nummer}\ShellFolder den Wert: "Attributes": 70 01 00 20

(Siehe auch Werte für HKEY_CLASSES_ROOT)

Folgende Icons werden im Schlüssel

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ explorer\ Shell Icons

verwaltet:

Wert | Typ | Beschreibung
0 | Explorer | Unknown File Type
1 | Explorer | Default Document
2 | Explorer | Default Application
3 | Explorer | Closed Folder
4 | Explorer | Open Folder
5 | Drive | 5.25 inch floppy
6 | Drive | 3.5 inch floppy
7 | Drive | Removable Drive
8 | Drive | Hard Drive
9 | Drive | Network Drive
10 | Drive | Network Drive disconnected
11 | Drive | CD-ROM Drive
12 | Drive | RAM Drive
13 | Global | Entire network
15 | Explorer | Networked Computer
16 | Explorer | Printer(s)
17 | Desktop | Network Neighborhood
18 | Explorer | Workgroup
19 | Startmenu | Programs
20 | Startmenu | Recent documents
21 | Startmenu | Settings
22 | Startmenu | Find
23 | Startmenu | Help
24 | Startmenu | Run
25 | Startmenu | Suspend
26 | Startmenu | Docking
27 | Startmenu | Shutdown
28 | Overlay | Sharing
29 | Overlay | Shortcut
31 | Desktop | Recycle bin empty
32 | Desktop | Recycle bin full
33 | Explorer | Dial-up Networking
34 | Explorer | Desktop
35 | Startmenu | Settings/Control Panel
36 | Startmenu | Programs/Program folder
37 | Startmenu | Settings/Printers
39 | Startmenu | Settings/Taskbar
40 | Explorer | Audio CD
42 | Explorer | Saved search (.fnd)
43 | Explorer und Startmenu | Favorites
44 | Startmenu | Log Off

Ist der entsprechende Wert noch nicht vorhanden, legen Sie die Zahl als Datentyp REG_SZ an und tragen als Wert den Pfad zur Icondatei an (z.B.: C:\Icons\myicon.ico,0) ein.

Die Änderungen werden nach einem Neustart wirksam.

Info Geht mit den PowerToys (Tweak UI) einfacher! Alles lässt sich aber nicht damit einstellen!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0162.htm


Icon-Cache-Größe erhöhen

Windows benutzt zum schnelleren Anzeigen von Icons die Datei "ShellIconCache" bzw. ab Windows XP an der Datei "IconCache.db" liegen.

Die Datei "ShellIconCache" liegt im Verzeichnis "%SYSTEMROOT%"bzw. die Datei "IconCache.db" ab Windows XP jim Profilverzeichnis des jeweiligen Anwenders (%USERPROFILE%\Lokale Einstellungen\Anwendungsdaten).

Nun kann es aber vorkommen, dass der Icon-Cache zu klein ist und dadurch die Icons kurzzeitig nicht angezeigt werden, weil der Cache geleert und wieder neu aufgebaut werden muss, oder die Icons werden überhaupt nicht mehr richtig angezeigt.

Abhilfe schafft ein Eintrag in der Registry, mit dem Sie die Größe des Cache erhöhen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

legen Sie im rechten Fenster mit "Neu" -> "Zeichenfolge" einen neuen Eintrag an.

Diesem Eintrag geben Sie den Namen "Max Cached Icons" als Datentyp REG_SZ und weisen ihm den Wert "4096" zu (der Standardwert lautet 512). Sie können hier einen Wert zwischen 100 und 4096 eingeben.

Löschen Sie danach die Datei "ShellIconCache" aus dem Windowsverzeichnis und starten Sie den Rechner neu. Die Datei wird bei Bedarf automatisch wieder neu angelegt, unter Umständen geschieht dies erst beim nächsten Neustart.

Ab Windows XP heißt die Datei "IconCache.db" und nicht "ShellIconCache". Sie finden diese Datei im Verzeichnis "%USERPROFILE%\Lokale Einstellungen\Anwendungsdaten".

Mit der folgenden Registry-Datei ( .REG) können Sie das Menü des Windows-Explorers erweitern und unter verschiedenen Cache-Größen auswählen (Ansicht - Ordneroptionen - Ansicht oder Extras - Ordneroptionen - Ansicht):

=== Hier schneiden ===
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer]
"Max Cached Icons"="4095"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache]
"Text"="Icon Cache Groesse"
"Type"="group"
"Bitmap"="SHDOC401.DLL,6"
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Small]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="1024 Icons"
"Type"="radio"
"CheckedValue"="1023"
"ValueName"="Max Cached Icons"
"DefaultValue"="4095"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Medium]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="2048 Icons"
"Type"="radio"
"CheckedValue"="2047"
"ValueName"="Max Cached Icons"
"DefaultValue"="4095"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Large]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="4096 Icons"
"Type"="radio"
"CheckedValue"="4095"
"ValueName"="Max Cached Icons"
"DefaultValue"="4095"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"

=== Hier schneiden ===

Speichern Sie die Datei als "IcoCache.reg" ab, klicken Sie mit der rechten Maustaste auf diese Datei und wählen dann "Zusammenführen".

Hinweis:

Info Unter Umständen treten Probleme mit der Einstellung "4096" auf. Wählen Sie dann einen kleineren Wert. Siehe auch:"Probleme mit den Icons auf dem Desktop".

Info Sie können den Icon Cache auch mittels Tweak UI 1.33 reparieren.
Siehe dazu "Tweak UI 1.33: Alle Funktionen im Überblick".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=132668

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0058.htm


Symbole umbenennen, die geschützt sind (z.B. Posteingang)

Bei der Installation von "Exchange" wird auf dem Desktop ein Icon "Posteingang" angelegt. Diese Bezeichnung können Sie nicht wie andere Bezeichnungen einfach so ändern. Durch einen Eingriff in die Registry ist das aber möglich.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ {00020D75-0000-0000-C000-000000000046}\ ShellFolder

ändern Sie bei dem Eintrag "Attributes" den ersten HEX-Wert auf "50".

Sie können in den Bereich CLSID auch nach anderen Symbolen suchen, die schreibgeschützt sind (Papierkorb usw.) und auch dort den Wert auf "50" ändern.

Wollen Sie den Schreibschutz wieder einschalten oder noch andere Symbole schützen, müssen Sie den Wert auf "40" setzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0314.htm


Icongröße ändern

Mit der rechten Maustaste auf den Desktop klicken -> "Eigenschaften" -> "Darstellung" -> "Bildelement" wählen und unter "Symbol" die "Größe" einstellen.

Ab Windows Vista:

Mit der rechten Maustaste auf den Desktop -> "Anpassen" -> "Fensterfarbe und -darstellung" -> Button "Erweitert..." -> hier das gewünschte "Element" auswählen und die Einstellung vornehmen.

Die Werte können auch in der Registry geändert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics

die Werte "IconSpacing" und "IconVerticalSpacing" legen die Werte für die Icons fest.

Die Werte werden entweder in Pixel (X/Y-Koordinate) oder als Twips (1/20 eines Druckerpunktes = 1/1440 Zoll) angegeben. Zur Unterscheidung werden Angaben in Twips mit einem negativen Vorzeichen (-) in die Registry eingetragen.

Info Siehe dazu auch: "Icon Einstellungen (was man alles ändern kann)"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0160.htm


Icons mit 256 Farben

Hierfür ist ein Eintrag in der Registrydatenbank verantwortlich, der normalerweise bei Windows 95 mit der Installation von MS Plus eingefügt wird. Diesen Eintrag kann man aber auch manuell einfügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.Default\ ControlPanel\ Desktop\ WindowMetrics

legen Sie im rechten Fenster (falls nicht vorhanden) mit -> "Neu" -> "Zeichenfolge" einen neuen Eintrag an. Diesem Eintrag geben Sie den Namen "Shell Icon BPP" (Leerzeichen nicht vergessen!).

Als Wert ordnen Sie ihm "16" für 256 Farben bzw. "4" für 16 Farben zu.

Info Dies und die anderen Funktionen, die das PlusPack in die Anzeige-Eigenschaften bringt, können auch ohne das PlusPack installiert werden. Das ist dann wesentlich einfacher und bequemer. Man benötigt dazu die Datei: "w95gray.exe" MS-Plus! v4.70.1163 englisch (KB) die Plus!-Optionen der Anzeige-Eigenschaften auch ohne PlusPack für alle Windows 950, 950A, 950B.
Zu finden ist sie bei MS selbst und auf einigen anderen Freeware- und öffentlichen Windows 95 Homepages.

Info Siehe auch: "Desktop/Fenstereinstellungen"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0161.htm


Text 'Verknüpfung mit...' aus Verknüpfungen entfernen

Text "Verknüpfung mit" aus Verknüpfungen entfernen

Beim Erstellen von Verknüpfungen wird automatisch der Schriftzug: "Verknüpfung mit" bzw. ab Windows Vista nur "Verknüpfung" zum Namen hinzugefügt. Das ist in den meisten Fällen doch etwas nervig, kann aber über die Registry ausgestellt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

erstellen Sie den Wert "Link" als Datentyp REG_BINARY. Setzen Sie den Wert auf "00 00 00 00". Nun wird der Schriftzug "Verknüpfung" nicht mehr erscheinen.

Der Standardwert ist "28 00 00 00" ab Windows Vista "16 00 00 00" bzw. Vista + SP1 "1e 00 00 00".

Nach der Änderung müssen Sie sich neu anmelden, damit die Konfiguration aktiv wird.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0000.htm


Symbolabstand ändern

Rechtsklick auf den Desktop -> "Eigenschaften" -> "Darstellung" und dann unter "Bildelement" "Symbolabstand" (Horizontal) bzw. (Vertikal) anwählen und unter "Größe" den gewünschten Abstand einstellen.

Ab Vista:

Rechtsklick auf den Desktop -> "Anpassen" -> "Fensterfarbe und -darstellung" und dann unter "Element" die Einträge "Symbolabstand (Horizontal)" bzw. "Symbolabstand (Vertikal)" anwählen und unter "Größe" den gewünschten Abstand einstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0171.htm


Icon Einstellungen (was man alles ändern kann)

Für die Einstellung der Icons gibt es recht viele Parameter in der Registry, um Veränderungen vorzunehmen. Aus diesem Grunde hier nun eine Aufstellung aller mir bekannten Parameter.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Schlüssel | Datentyp | Angabe als | Standard
Rasterzellengröße für Symbole auf dem Desktop
IconHorizontalSpacing | REG_SZ | Pixel | 60
Horizontaler Abstand zwischen den Symbolen in Pixel
IconSpacing | REG_SZ | Pixel | 75
Schriftart für Symboltitel
IconTitleFaceName | REG_SZ | Schriftart | Helv
Größe der Schriftart
IconTitleSize | REG_SZ | Zahl | 9
Schriftartstil
IconTitleStyle | REG_SZ | Boolean | 0
Angabe, ob Symboltitel umbrochen werden. Bei 1 wird das Umbrechen eingeschaltet und der vertikale Abstand zwischen den Symbolen um 3 Zeilen vergrößert.
IconTitleWrap | REG_SZ | Boolean | 1
Höhe der Symbolzelle in Pixel
IconVerticalSpacing | REG_SZ | Pixel | 60

Die Werte werden entweder in Pixel (X/Y-Koordinate) oder als Twips (1/20 eines Druckerpunktes = 1/1440 Zoll) angegeben. Zur Unterscheidung werden Angaben in Twips mit einem negativen Vorzeichen (-) in die Registry eingetragen.

Info Siehe auch: "Desktop/Fenstereinstellungen"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0169.htm


Probleme mit den Icons auf dem Desktop

Wenn bei Ihnen nicht die richtigen Icons auf dem Desktop angezeigt werden bzw. diese Icons von anderen überlagert sind, kann es an der Datei "ShellIconCache" bzw. ab Windows XP an der Datei "IconCache.db" liegen. Um den Fehler zu beheben, gehen Sie folgendermaßen vor:

  • Verwenden Sie die "Repair Icons"-Funktion von TweakUI. Siehe auch: "Tweak UI 1.33: Alle Funktionen im Überblick"

Windows 9x-2000:

  • Starten Sie Windows im Abgesicherten-Modus
    Suchen Sie die Datei "ShellIconCache" (liegt in "%SYSTEMROOT%" und ist versteckt), löschen Sie die Datei und starten Sie den Rechner danach neu.

Ab Windows XP:

  • Hier finden Sie die Datei "IconCache.db" jetzt im Profilverzeichnis des jeweiligen Anwenders (%USERPROFILE%\Lokale Einstellungen\Anwendungsdaten). Sie brauchen diese Datei nur zu löschen, Windows legt sie dann automatisch neu an.

Sie können aber auch unter "Eigenschaften der Anzeige" -> Darstellung -> Bildelement -> Auswahl "Symbole" die Icongröße einmal ändern, übernehmen und dann wieder auf die ursprüngliche Größe zurücksetzen.

Siehe auch:"Icon-Cache-Größe erhöhen".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1102.htm


Transparenter Hintergrund für Icons auf dem Desktop

Wer ein Hintergrundbild benutzt, wird sich sicherlich über die Icon-Beschriftung ärgern, welche selber mit der Hintergrundfarbe des Desktops versehen ist.

Windows kann dieses Manko nicht beseitigen.

Abhilfe schafft aber das Tool DIcon. Allerdings nimmt das Tool keine ständige Überwachung vor. Zeichnet ein Programm also den Desktop neu, muss auch das Programm neu gestartet werden. Eine automatische Überwachung bietet aber z.B. Transparent unter http://www.winload.de/download/725/Grafik_Desktop/Bildbearbeitung/Transparent.Icons-1.5.html(Freeware).

Da das Zurückstellen auf die ursprünglichen (nicht transparenten) Werte nicht immer klappt, sollten man folgenden Registryzweig

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ExpView

vorher in eine Datei exportieren.

Bei Windows XP finden Sie das auch unter:

In der "Systemsteuerung" -> "System" auswählen und aus der Dialogbox "Systemeigenschaften" den Tabreiter "Erweitert" auswählen. Unter "Systemleitung" auf den Button "Einstellungen" klicken und aus der Dialogbox "Leistungsoptionen" unter dem Tabreiter "Visuelle Effekte" den Eintrag "Durchsichtigen Hintergrund für Symbolunterschriften auf dem Desktop" aktivieren.

Info Sehr gut ist auch das Freeware-Programm "Durchsicht". Es bietet diverse Optionen zur Konfiguration ( z.B. Autostartfunktion, falls gewünscht). Die Downloadadresse: http://www.mqsoftware.de . Für dieses Programm ist eine kostenlose Registrierung erforderlich.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0974.htm


Desktopicon mit unterschiedlicher Beschriftung

Wenn Sie Windows gestartet haben, finden Sie - je nach Voreinstellung - oben rechts das Desktopicon mit der Bezeichnung "Arbeitsplatz".

In einigen Situationen ist es aber sinnvoller, dort z.B. als Info den gerade angemeldeten USERNAMEN zu sehen.

Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}

für Windows 9x:

Tragen Sie bei (Standard) Datentyp REG_SZ die gewünschte Bezeichnung ein.

für Windows NT:

finden Sie einen Wert ohne Namen, der als Eintrag "Arbeitsplatz" hat. Diesen Wert müssen Sie löschen. Legen Sie nun einen neuen Wert ohne Namen, aber als Datentyp REG_EXPAND_SZ an.

ab Windows 2000:

Finden Sie einen Wert mit dem Namen "LocalizedString", der als Eintrag "Arbeitsplatz" usw. enthält. Diesen Wert müssen Sie löschen. Legen Sie nun einen neuen Wert mit dem Namen "LocalizedString" als Datentyp REG_EXPAND_SZ an.

Diesem Wert können Sie nun eine beliebige Beschreibung zuweisen, auch sind hier jetzt Variablen erlaubt %USERNAME%, %COMPUTERNAME% usw.

Wenn Sie nun auf den Desktop gehen und F5 zum Aktualisieren drücken, sehen Sie die neue Bezeichnung unter dem Arbeitsplatz-Icon.

Info Wenn Sie diesen Wert nicht neu als Datentyp REG_EXPAND_SZ anlegen, werden die Platzhalter nicht ausgewertet. Möchten Sie also keine Platzhalter verwenden, müssen Sie diesen Wert natürlich nicht löschen, sondern können den Eintrag "Arbeitsplatz" einfach mit einer anderen Bezeichnung überschreiben.

Info Da es unter Windows 95/98 den Datentyp REG_EXPAND_SZ nicht gibt, kann dort nicht mit Variablen gearbeitet werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0668.htm


Farbauflösung der Icons einstellen

Mit diesem Tipp können Sie einstellen, in welcher Auflösung die Icons angezeigt werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics

Erstellen Sie hier einen neuen Wert mit dem Namen "Shell Icon BPP" als Datentyp REG_SZ. Setzen Sie den Wert auf:

4 | 16 Farben
8 | 256 Farben
16 | 65.536 Farben
24 | 16,7 Millionen Farben

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1599.htm


'Klicken Sie hier...' entfernen

Mit diesem Wert können Sie festlegen, dass unten kein "Klicken Sie hier..." mehr auf das Startmenü zuläuft.

Sie können Mit diesem Wert aber nicht konfigurieren, dass diese Anzeige erfolgt, sondern Sie können damit lediglich verhindert, dass dieser Text angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartBanner" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Klicken Sie hier..." ausschalten
0 | "Klicken Sie hier..." wird angezeigt (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1374.htm


Startmenüeinträge zum Scrollen anzeigen

Wenn Sie viele Einträge im Startmenü haben, die nicht mehr in einer Spalte auf dem Bildschirm dargestellt werden können, wird von Windows automatisch eine neue Spalte aufgemacht.

Sie können aber einstellen, dass alles in einer Spalte angezeigt wird und Sie in die nicht sichtbaren Bereiche hineinscrollen müssen.

Gehen Sie dazu folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellen Sie einen neuen Wert mit dem Namen "StartMenuScrollPrograms" als Datentyp REG_SZ.

Um das Scrollen zu aktivieren, setzen Sie diesen Wert auf "YES" oder, um wieder die alte Darstellungsart zu aktivieren, auf "NO"

Sie können aber auch folgende .REG Datei verwenden:

=== Hier schneiden ===
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\StartMenuScrollPrograms]
"Type"="* Checkbox "
"Text"="Mehrspaltiges Startmenü"
"HKeyRoot"=dword:80000001
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"ValueName"="StartMenuScrollPrograms"
"CheckedValue"="false"
"UncheckedValue"="true"
"DefaultValue"="true"
"HelpID"="update.hlp"

=== Hier schneiden ===

Speichern Sie die Datei als MCOLUMNS.REG. Mit Rechtsklick - Zusammenführen- werden die Einträge in die Registry übernommen. Danach können Sie per Explorer - Ansicht - Ordneroptionen - Ansicht - Erweiterte Einstellungen - Dateien und Ordner die neue Option "Mehrspaltiges Startmenü" aktivieren bzw. deaktivieren.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0856.htm


Aufklappen im Startmenü für weitere Funktionen aktivieren

Unter Windows sind im Startmenü schon viele Menüpunkte so eingestellt, dass sie eine weitere Ansicht aufklappen, wenn sie angewählt werden. Durch Registryeinträge können Sie das noch für einige andere Funktionen im Startmenü aktivieren.

Die Funktionen können Sie auch über einen Rechtsklick mit der Maus auf die Taskleiste -> Eigenschaften -> unter dem Tabreiter "Startmenü" auf den Button "Erweitert" klicken unter "Einstellungen für Menü Start" setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced\

legen Sie hier für die gewünschten Funktionen die jeweiligen Werte an:

Name | Datentyp | Wert | Beschreibung
CascadeMyDocuments | REG_DWORD | 1 | "Eigene Dateien" wird unter "Start" -> "Dokumente" zum Aufklappen aufgeführt
CascadeControlPanel | REG_DWORD | 1 | Die "Systemsteuerung" wird unter "Start" -> "Einstellungen" zum Aufklappen aufgeführt
CascadeNetworkConnections | REG_DWORD | 1 | Die "Netzwerkverbindungen" wird unter "Start" -> "Einstellungen" zum Aufklappen aufgeführt
CascadePrinters | REG_DWORD | 1 | Die "Drucker" werden unter "Start" -> "Einstellungen" zum Aufklappen aufgeführt
CascadeMyPictures | REG_DWORD | 1 | "Eigene Bilder" werden unter "Start" -> "Dokumente" zum Aufklappen aufgeführt

Info Damit die Einstellungen aktiv werden, muss sich der Anwender neu anmelden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0540.htm


Einträge im Startmenü sortieren

Mit der Maus kann man die Anordnung der Einträge im Startmenü, seid IE 4.x, beliebig verändern. Klicken Sie dazu im Startmenü auf den zu verschiebenden Eintrag und bewegen Sie ihn mit gedrückter rechter Maustaste an die gewünschte Stelle.

Wenn Sie wollen, dass die Einträge - wie früher alphabetisch - sortiert werden, müssen Sie folgenden Registry Wert löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MenuOrder\ Start Menu

hier gibt es den Wert "Order" als Datentyp REG_DWORD. Diesen Eintrag löschen Sie einfach und schon werden die Einträge im Startmenü wieder alphabetisch sortiert angezeigt.

Wenn Sie neue Software nachinstallieren, müssen Sie meist diesen Eintrag wieder löschen, damit wieder alles alphabetisch sortiert angezeigt wird.

Ab Windows XP können Sie einen einzelnen Bereich über das Kontextmenü neu sortieren lassen: Klicken Sie dafür mit der rechten Maustaste auf den gewünschten Ordner im Startmenü und wählen Sie aus dem Kontextmenü "Nach Namen sortieren" aus.

Info Ab der Installation von IE 5 können Sie im Kontextmenü des Startmenüs wieder einstellen, dass die Einträge alphabetisch sortiert angezeigt werden sollen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0800.htm


Systemsteuerung & Co im Startmenü mit Pfeil zum Aufklappen

diesem wird Ihnen gezeigt, wie Sie auf Windowsfunktionen über Ordner zugreifen können. Sie können diese Ordner selbstverständlich auch an anderen Orten (Desktop usw.) anlegen und dadurch auf diese Funktionen zugreifen.

Windows 95/98

Explorer starten und im Verzeichnis: \Windows\Startmenü über "Datei" -> "Neu" -> "Ordner" ein Verzeichnis mit dem entsprechenden Namen anlegen.

Ab Windows NT

Explorer starten und im Verzeichnis: "%UserProfile%\Startmenü" über "Datei" -> "Neu" -> "Ordner" ein Verzeichnis mit dem entsprechenden Namen anlegen (%UserProfile% ist der Pfad zum Profilverzeichnis des jeweiligen Benutzers). Soll die Einstellung für alle Anwender gelten, reicht ein Eintrag unter "All Users".

Funktion | Ordnername
ActiveX-Zwischenspeicher (Downloaded Program Files) | ActiveX Cache.{88C6C381-2E85-11D0-94DE-444553540000}
Aktenkoffer | Aktenkoffer.{85BBD920-42A0-1069-A2E4-08002B30309D}
Arbeitsplatz | Arbeitsplatz.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Desktop | Desktop.{00021400-0000-0000-C000-000000000046}
DFÜ-Netzwerk | DFÜ Netzwerk.{992CFFA0-F557-101A-88EC-00DD010CCC48}
DFÜ-Netzwerk | DFÜ Netzwerk.{A4D92740-67CD-11CF-96f2-00AA00A11DD9}
Drucker | Drucker.{2227A280-3AEA-1069-A2DE-08002B30309D}
Eigene Dateien | Eigene Dateien.{450D8FBA-AD25-11D0-98A8-0800361B1103}
Favoriten | Favoriten.{1A9BA3A0-143A-11CF-8350-444553540000}
Geplante Tasks | Geplante Tasks.{D6277990-4C6A-11CF-8D87-00AA0060F5BF}
Internet | Internet.{3DC7A020-0ACD-11CF-A9BB-00AA004AE837}
Internet Explorer | Internet Explorer.{871C5380-42A0-1069-A2EA-08002B30309D}
Internet Explorer | Internet Explorer.{FBF23B42-E3F0-101B-8488-00AA003E56F8}
Netzwerkumgebung | Netzwerkumgebung.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Papierkorb | Papierkorb.{645FF040-5081-101B-9F08-00AA002F954E}
Posteingang | Posteingang.{00020D75-0000-0000-C000-000000000046}
Schriftarten | Schriftarten.{BD84B380-8CA2-1069-AB1D-08000948F534}
Systemsteuerung | Systemsteuerung.{21EC2020-3AEA-1069-A2DD-08002B30309D}
Temporäre Internet Dateien | Internet Cache.{7BD29E00-76C1-11CF-9DD0-00A0C9034933}
Verlauf | Verlauf.{FF393560-C2A7-11CF-BFF4-444553540000}
Subscription (?) | Subscription Folder.{F5175861-2688-11d0-9C5E-00AA00A45957}

Info Der unterstrichene Teil muss exakt so eingegeben werden, nur der Name vor dem Punkt ist frei wählbar.

Info Siehe auch Tipp: "Aufklappen im Startmenü für weitere Funktionen aktivieren"

Info Nicht alle Ordner funktionieren mit allen IE-Versionen bzw. allen Betriebssystemen. Siehe auch: "CLSID Nummern der wichtigsten Funktionen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0326.htm


IE History als Liste ins Startmenü

Der Internet Explorer legt automatisch eine History Ihrer besuchten Internetseiten an. Wenn Sie öfter auf diese Seiten zurückgreifen wollen, ist es ganz nützlich, diese Liste auch im Startmenü als Linkliste zur Ansicht zu bekommen.

Dazu müssen Sie nur im Startmenüverzeichnis (C:\Windows\Startmenü\Programme) einen neuen Ordner anlegen, der folgende Bezeichnung trägt:

History.{FF393560-C2A7-11CF-BFF4-444553540000}

Jetzt können Sie auch über das Startmenü auf die History Ihres Internetexplorers zurückgreifen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0604.htm


Icon des Startmenüs verändern

Das Icon auf der Taskleiste können Sie nicht so einfach ändern. Das Icon ist in der Datei "USER.EXE" gespeichert und kann nur dort mit Hilfe eines Icon-Editors ersetzt bzw. bearbeitet werden. Die USER.EXE wird allerdings immer von Windows benötigt und kann daher nicht unter Windows editiert werden.

Kopieren Sie diese Datei in ein anderes Verzeichnis und bearbeiten dann die Kopie. Beenden Sie anschließend Windows, kopieren Sie unter DOS die veränderte Kopie ins Windows\System-Verzeichnis zurück und überschreiben das Original. Nun müsste Ihr Start-Button ein anderes Icon aufweisen.

  1. Microangelo *) installieren
  2. "user.exe" im Windows\Systemverzeichnis in ein andere Verzeichnis kopieren "user.exe" & "user.bk1"
  3. Microangelo Librarian starten und "user.exe" öffnen
  4. In der Symbolleiste die Icon-Größe auf "16 x 16, 16 colors" einstellen und dann das Icon "User001" öffnen
  5. Nun können Sie das Icon beliebig verändern oder ein Bitmap einfügen ("Edit, Open Bitmap As Image")
  6. Zum Schluss noch die Library mit "File, Update Librarian" und dann "File, Save" sichern
  7. Windows beenden und den DOS -Modus starten und die "user.exe" wieder in das Windows-Verzeichnis kopieren.
  8. Windows neu starten und sich am Icon erfreuen.

*) Microangelo finden Sie unter: http://www.impactsoft.com/products/products.html

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0159.htm


Aufrufe im START-Button sind grau hinterlegt

Fehler:

Bei einem Rechtsklick auf den START-Button sind einigen Einträge (Öffnen, Explorer) grau hinterlegt und können nicht mehr aufgerufen werden.

Problem:

Dieser Fehler tritt auf, wenn Laufwerke z.B. mit Tweak UI ausgeblendet werden (siehe "Tweak UI 1.33: Alle Funktionen im Überblick").

Wenn Sie alle Laufwerke wieder einblenden, sind die Einträge nach einem Neustart des Rechners wieder aktiviert (siehe auch: Laufwerke ausblenden).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0592.htm


Den Eintrag 'Username abmelden' aus dem Startmenü entfernen bzw. hinzufügen

Den Eintrag 'Username abmelden' aus dem Startmenü entfernen/hinzufügen

Mit diesem Wert können Sie festlegen, ob der Eintrag "<Username> abmelden" im Startmenü angezeigt werden soll. Durch das Setzen dieser Werte wird auch der Eintrag "Abmelden anzeigen" aus den Startmenüeinstellungen entfernt, so dass der Anwender diese Einstellung nicht mehr verändern kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Ab Windows 2000

Abmelden zum Startmenü hinzufügen:

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceStartMenuLogOff" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Abmelden wird zum Startmenü hinzugefügt
gelöscht | Abmelden kann zum Startmenü hinzugefügt/entfernt werden (Standard)

Durch Aktivieren dieser Einstellung, wird der Menüeintrag "<Benutzername> abmelden" im Startmenü angezeigt. Gleichzeitig wird die Option "Abmeldung anzeigen" aus den Startmenüeinstellungen entfernt. Benutzer können somit den Menüeintrag "<Benutzername> abmelden" nicht aus dem Startmenü entfernen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Option "Abmelden" dem Startmenü hinzufügen

Abmelden aus dem Startmenü entfernen:

Erstellen Sie hier einen neuen Wert mit dem Namen "StartMenuLogOff" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Abmelden wird aus dem Startmenü entfernt
gelöscht | Abmelden kann zum Startmenü hinzugefügt/entfernt werden (Standard)

Durch Aktivieren dieser Einstellung, wird der Menüeintrag "<Benutzername> abmelden" im Startmenü nicht angezeigt. Gleichzeitig wird die Option "Abmeldung anzeigen" aus den Startmenüeinstellungen entfernt. Benutzer können somit den Menüeintrag "<Benutzername> abmelden" nicht dem Startmenü hinzufügen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Option "Abmelden" aus dem Startmenü entfernen

Info Es sollte immer jeweils nur einer von diesen Werten gesetzt werden, um einen definierten Zustand zu bekommen.

Info Siehe auch Tipp: "USER-Abmelden aus dem 'Startmenü' ein-/ausblenden"

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0948.htm


Suche nach Personen aus dem Startmenü entfernen

In diesem Tipp wird beschrieben, wie Sie den Eintrag Suche nach Personen aus dem Startmenü entfernen können.

Um den Eintrag "Personen..." aus dem Menü "Start" - "Suchen" zu entfernen, müssen Sie einfach nur folgenden Schlüssel aus der Registry entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ FindExtensions\ Static

entfernen Sie den Schlüssel WabFind. Um andere Einträge aus diesem Menü zu entfernen, verfahren Sie entsprechend.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1333.htm


Entfernt des Eintrag 'Active Desktop' aus dem Startmenü

Mit diesem Wert können Sie festlegen, dass aus dem Startmenü der Eintrag "Active Desktop" unter Einstellungen entfernt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSetActiveDesktop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1376.htm


Den Eintrag 'Systemsteuerung' und 'Drucker' entfernen

Mit diesem Wert können Sie festlegen, dass die Optionen "Systemsteuerung", "Drucker" und "Netzwerkeinstellungen" nicht mehr im Startmenü, Arbeitsplatz und im Explorer angezeigt werden. Zusätzlich können die Programme (wie z. B. Control.exe), die mit diesen Ordnern assoziiert sind, nicht ausgeführt werden.

Benutzer können aber weiterhin auf Funktionen der Systemsteuerung zugreifen, indem sie z. B. mit einem Rechtsklick auf den Desktop "Eigenschaften" die Option "Anzeige" oder mit einem Rechtsklick auf "Arbeitsplatz" die Option "Verwalten" bzw "Eigenschaften" öffnen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSetFolders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Programme im Menü "Einstellungen" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Wenn man diese Funktion aktiviert, werden komischerweise auch die Tastenkombinationen WIN+E usw. deaktiviert. Es erscheint dann die Meldung: "Dieser Vorgang wurde auf Grund von Einschränkungen abgebrochen, die für Ihren Computer gelten. Bitte wenden Sie sich an Ihren Systemadministrator."

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1369.htm


Den Eintrag 'Suchen' entfernen

Mit diesem Wert können Sie festlegen, dass der Eintrag "Suchen" im Startmenü und dem Kontextmenü des Startmenüs entfernt wird. Es wird auch die Windows Tastenfunktion "Windows-Taste + F" und F3 deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFind" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Suchen" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1367.htm


Den Eintrag 'Herunterfahren' entfernen

Mit diesem Wert können Sie festlegen, ob die Einträge "Herunterfahren" aus dem Startmenü und aus "Windows-Sicherheit" (zu erreichen mit STRG+Alt+Enft) entfernt werden.

Diese Einstellung verhindert, dass Benutzer mit Hilfe der Windows-Benutzeroberfläche den Computer herunterfahren. Allerdings hindert die Einstellung Benutzer nicht daran, Programme, die Windows herunterfahren, auszuführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoClose" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Befehl "Herunterfahren" entfernen und Zugriff darauf verweigern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu finden Sie unter: "Herunterfahren im Anmelde-Screen ein/ausblenden"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1368.htm


Den Eintrag 'Ausführen' aus dem Startmenü entfernen

Mit diesem Wert können Sie festlegen, ob der Eintrag "Ausführen" aus dem Startmenü, Internet Explorer und Task-Manager entfernt werden soll.

Folgende Änderungen treten auf, wenn Sie diese Einstellung aktivieren:

  1. Der Befehl "Ausführen" wird aus dem Startmenü entfernt.
  2. Der Befehl "Neuer Task (Ausführen)" wird aus dem Task-Manager entfernt.
  3. Die folgende Benutzereingabe in die Adressleiste in Internet Explorer wird gesperrt:
    Ein UNC-Pfad: \\<Server>\<Freigabe>
    Der Zugriff auf lokale Laufwerke: z. B. C:
    Der Zugriff auf lokale Ordner: z. B. \temp>
  4. Zusätzlich können Benutzer mit erweiterten Tastaturen das Dialogfeld "Ausführen" nicht mehr mit der Anwendungstaste (die Taste mit dem Windows-Logo) +R anzeigen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRun" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Ausführen" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Wenn NoRun auf 1 gesetzt wird, dann kann man im Internet Explorer keine Datei mehr über "Datei" - "Öffnen" oder durch direkte Eingabe in der Adressleiste öffnen. Es erscheint dann die Fehlermeldung: "Der Zugriff auf die Ressource "..." wurde gesperrt". Nur Drag & Drop funktioniert noch und eine lokale Startseite wird auch noch geladen.Details dazu findet man auch bei Microsoft unter folgender URL: http://support.microsoft.com/default.aspx?scid=kb;EN-US;179221

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1366.htm


Einträge aus dem Kontextmenü von Startmenü entfernen

Wenn Sie mit der rechten Maustaste auf das Startmenü klicken, erscheint ein Kontextmenü mit den Einträgen (Öffnen, Suchen, Explorer usw..).

Diese Funktion können Sie leider nicht einfach so deaktivieren, wenn Sie aber nicht mehr wollen, dass diese Funktion benutzt werden kann, müssen Sie folgende Registry-Zweige löschen oder umbenennen, um sie wieder herstellen zu können:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Directory\ shell

und

HKEY_CLASSES_ROOT\ Folder\ shell

(Löschen Sie jeweils die Schlüssel Shell oder ändern Sie den Namen z.B. in Shell_deaktiv, damit werden diese Einträge nicht mehr im Kontextmenü angezeigt)

Sie können natürlich unter Shell auch jeweils nur bestimmte Einträge entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1383.htm


Die Favoriten aus dem Startmenü entfernen

Mit diesem Wert können Sie festlegen, dass die Favoriten nicht mehr im Startmenü angezeigt werden.

Sie können Mit diesem Wert aber nicht konfigurieren, dass die Favoriten im Startmenü angezeigt werden, sondern Sie können damit lediglich verhindert, dass es die Möglichkeit gibt, diesen Eintrag im Startmenü einzublenden.

Das Menü "Favoriten" wird standardmäßig nicht im Startmenü angezeigt. Zum Anzeigen des Menüs "Favoriten" klicken Sie mit der rechten Maustaste auf das Startmenü und anschließend auf "Eigenschaften", "Anpassen" (geht nicht bei "Klassisches Startmenü") und auf die Registerkarte "Erweitert". Aktivieren Sie im Feld "Startmenüelemente" das Kontrollkästchen für "Favoriten anzeigen". Verwenden Sie das klassische Startmenü, aktivieren Sie im Feld "Erweiterte Startmenüoptionen" das Kontrollkästchen für "Favoriten anzeigen".

Wie Sie die Favoriten im Startmenü Einblenden können finden Sie unter: Favoriten Menü aus dem Startmenü entfernen/hinzufügen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFavoritesMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Favoriten werden nicht angezeigt
gelöscht | Favoriten anzeigen ist verfügbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Favoriten" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos unter: http://support.microsoft.com/?kbid=177332

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1378.htm


Benutzerordner aus dem Startmenü ausblenden

Mit diesem Wert können Sie festlegen, dass keine Unterordner mehr im benutzerspezifischen Startmenü (oben) angezeigt werden. Weiterhin werden aber noch alle anderen Objekte und Verknüpfungen angezeigt.

Diese Einstellung ist für die Verwendung von umgeleiteten Ordnern hilfreich. Umgeleitete Ordner werden im Hauptabschnitt (unten) des Startmenüs angezeigt. Allerdings wird die ursprüngliche benutzerspezifische Version des Ordner weiterhin im oberen Abschnitt des Startmenüs angezeigt. Da sich das zweifache Anzeigen von Ordnern mit gleichem Namen auf manche Benutzer störend auswirken kann, können Sie diese Einstellung verwenden, um benutzerspezifische Ordner auszublenden.

Beachten Sie, dass durch diese Einstellung alle benutzerspezifischen Ordner (nicht nur umgeleitete Ordner) ausgeblendet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuSubFolders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Benutzerordner aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1370.htm


Kontextmenü des 'Startmenüs' deaktivieren

Wenn Sie diesen Tipp aktiviert, lässt sich das Kontextmenü des "Startmenüs" nicht mehr öffnen bzw. das Startmenü lässt sich nicht mehr erweitern. Auch wird die "Drag & Drop"- Funktion für das Startmenü ausgeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoChangeStartMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Kontextmenü ausblenden
gelöscht | Kontextmenü wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Drag & Drop-Kontextmenüs aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1756.htm


Windows Update aus dem 'Startmenü' ein-/ausblenden

Windows Update aus dem "Startmenü" ein-/ausblenden

Wenn Sie diese Funktion aktivieren, wird der Eintrag "Windows Update" aus dem "Startmenü" und aus dem Menü "Extras" im Internet Explorer entfernt. Weiterhin können Benutzer nicht auf die Windows Update-Website auf "http://windowsupdate.microsoft.com" zugreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoWindowsUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Windows Update" wird nicht angezeigt
gelöscht | "Windows Update" wird angezeigt (Standard)

Info Ist der Eintrag aktiv (1), wird damit leider auch der Bezug von Updates von einem WSUS-Server (WSUS 3,0 SP2) verhindert. Bei XP war das noch nicht so, ab Windows 7 kommen die WSUS-Updates auch nicht mehr durch.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Verknüpfungen und Zugiff auf Windows Update entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1757.htm


USER-Abmelden aus dem 'Startmenü' ein-/ausblenden

'USER abmelden' aus dem Startmenü ein-/ausblenden

Wenn Sie diese Funktion aktivieren, wird "User abmelden" im "Startmenü" nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoLogoff" als Datentyp REG_BINARY. Setzen Sie den Wert auf:

1 | "User Abmelden" wird nicht angezeigt
0 | "User Abmelden" wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Strg+Alt+Entf-Optionen
Einstellungsname: | Abmeldung entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe auch Tipp: "Den Eintrag 'Username abmelden' aus dem Startmenü entfernen bzw. hinzufügen"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=177903

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1758.htm


Keine Einträge im Startmenü unter Dokumente hinzufügen

Mit diesem Tipp können Sie einstellen, ob unter "Start" -> "Dokumente" von Ihnen geöffneten Dateien hinzugefügt werden sollen. Damit soll Ihnen ein weiterer Zugriff auf diese Dateien erleichtert werden, da sie ab jetzt über das Startmenü aufgerufen werden können. Diese Hisory kann aber auch Nachteile haben, gerade wenn noch andere Personen an Ihren Rechner arbeiten und so schnell sehen, welche Dokumente Sie als letztes geöffnet haben.

Mit diesem Tipp können Sie diese History-Funktion ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRecentDocsHistory" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | History Funktion deaktivieren
gelöscht | History Funktion aktiviert (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Liste der zuletzt geöffneten Dokumente nicht beibehalten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Wenn Sie diese Einstellung aktivieren, aber nicht die Einstellung "'Zuletzt verwendete...' aus dem 'Startmenü' ein-/ausblenden", erscheint das Menü "Dokumente" im Startmenü, ist jedoch leer.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1760.htm


Quickinfo für Icons

Ab Windows 98 bzw. nach der Installation des Internet Explorers erscheinen, wenn Sie einen Moment mit der Maus über einem Icon verweilen, Infotexte - sog. "Quickinfo" - im Explorer oder Startmenü. Diese Texte können Sie natürlich über die Registry bearbeiten oder neue Texte für andere Icons anlegen. Wenn Ihnen diese Infotexte mehr stören als helfen, wird Ihnen hier auch gezeigt, wie Sie die diese Anzeige ausschalten können.

Explorer:

Startmenü:

Die betreffenden Schlüssel dafür finden Sie in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\

dort suchen Sie nach dem Schlüssel "InfoTip" und bekommen damit die bestehenden Infotexte angezeigt.

Gibt es für den entsprechenden Datentyp keine Infotexte, werden Informationen von der Datei angezeigt (Größe, Dateityp usw.). Welche Infos dann angezeigt werden sollen, können Sie unter:

HKEY_CLASSES_ROOT\ *

mit dem Eintrag "InfoTip" vom Datentyp REG_SZ festlegen.

Mögliche Werte sind:

Type; DocAuthor; DocTitle; DocSubject; DocComments; Write; Size

Die Zeile muss immer mit "prop:" anfangen. und die Werte müssen Sie durch ein Semikolon (";") getrennt angegeben werden.

Anzeige der Infos ein-/ausschalten

Wenn Sie die Anzeige der Infotexte stört, können Sie die Texte auch abschalten. Starten Sie den Windows Explorer und wählen Sie aus dem Menü "Extras" -> "Ordneroptionen". Wechseln Sie auf dem Tabreiter "Ansicht" und entfernen den Haken bei "Popupinformationen für Elemente in Ordnern und auf dem Desktop anzeigen"

In der Registry finden Sie den Key unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowInfoTip" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Infos werden angezeigt (Standard)
0 | Die Infos werden nicht angezeigt

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Einstellungen für Infotipps finden Sie unter:
QuickInfos (BallonTipps) abschalten
Popuptexte im Startmenü ausschalten
Ordnerinformationen als Balloontipp anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0254.htm


Animation der Fenster beim Minimieren/Maximieren ausstellen

Animation der Fenster ausstellen beim Minimieren/Maximieren

Wenn Sie ein Fenster unter Windows öffnen oder schließen, wird dieses Fenster nicht einfach nur ausgeblendet, sondern in einer Animation verkleinert, bis es nicht mehr sichtbar ist.

Dieser Vorgang dauert zwar nur einige wenige Millisekunden, kann aber auf nicht so schnellen Rechnern als störend empfunden werden. Wenn Sie diese Animation ausschalten wollen, müssen Sie folgenden Registry-Wert auf 0 setzen.

Ab Windows 2000

finden Sie diese Einstellung unter: "Systemsteuerung" -> "System" oder [Windows-Taste + Pause]. Gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen"

Ab Windows Vista

unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Animation beim Minimieren und Maximieren von Fenstern".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics

im rechten Fenster den Wert "MinAnimate" als Datentyp REG_SZ anlegen und ihm den Wert 0 zuweisen (1 = an).

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD auf 3. Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen").

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Diese Einstellung lässt sich ebenfalls mit Tweak UI 1.33 unter "General" - "Windows animation" einstellen. Siehe auch "Tweak UI 1.33: Alle Funktionen im Überblick".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0025.htm


Smooth Scrolling

Durch diesen Wert können Sie beeinflussen, ob Verzeichnisse "weich" aufgeblendet werden sollen.

Wenn Sie den Eintrag "SmoothScroll" aktivieren (Festlegung auf "1"), ist die Funktion aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

legen Sie dort einen neuen Binärwert an, nennen Sie ihn "SmoothScroll" und weisen ihm als Wert "01 00 00 00" zu. Mit diesem Wert "00 00 00 00" können Sie das "Smooth Scrolling" wieder ausschalten.

Siehe auch Tipp:

Smooth Scrolling in Internet Explorer

Smooth Scrolling unter Telnet

Smooth Scrolling unter Outlook Express

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0388.htm


Leistungsoptionen von Desktop Funktionen ändern (X-Mouse/Tooltipps usw.) - UserPreferencesMask

Hier können Sie einige Desktop Funktionen konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows NT

Unter:

HKEY_CURRENT_USER\ Control Panel\ Mouse

setzen Sie den Eintrag "ActiveWindowTracking" als Datentyp REG_DWORD auf "1". Wenn Sie es später ausschalten möchten, müssen Sie diesen Wert wieder auf "0" setzen

Alle anderen Betriebssysteme

Einige Einstellungen können davon auch in der Oberfläche bei den Leistungsoptionen gesetzt werden und zwar unter:

Ab Windows 2000 finden Sie diese Einstellung unter: "Systemsteuerung" -> "System". Gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen".

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

In der Tabelle (unten) ist, wenn vorhanden, hinter GUI: der Name angegeben, wie die Einstellung in der Tabelle unter Windows zu finden ist.

In der Registry geht das über:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Hier finden Sie den Wert "UserPreferenceMask" (für Windows 9x und ME) "UserPreferencesMask" (für alle anderen Betriebssysteme) als Datentyp REG_BINARY, welcher folgendermaßen aufgebaut ist: "WW XX YY ZZVV". Hier sind 4 Hex-Werte eingetragen, nachfolgend werden alle Einträge als Binär-Wert aufgezeigt.

Info Ab Windows Vista gibt es zusätzlich den VV-Wert, welcher für weitere Einstellungen eingeführt wurde.

Bit | Bedeutung (WW) - Standard-Wert: 9E (hex) | Standard | Echte Bit Nummer
0 | X-Mouse aktiviert, d.h. das Fenster, in dem sich der Mauszeiger befindet, erhält den Fokus | 0 | 0
1 | Menüs in Ansichten ein- bzw. ausblenden (GUI: Menüs in Ansicht ein- oder ausblenden) | 1 | 1
2 | Offene Kombinationsfelder (Comboboxen) einblenden | 1 | 2
3 | Optimierten Bildlauf für Listenfelder (Listboxen) verwenden | 1 | 3
4 | Farbverlauf (Gradient) für Windows Titelbars | 1 | 4
5 | Menü-Unterstreichung aktiviert | 0 | 5
6 | AutoRaise aktiviert, d.h. das Fenster, in dem sich der Mauszeiger befindet, wird in den Vordergrund geholt (geht nur im Zusammenhang mit Bit 0). | 0 | 6
7 | Tool-Tipp Funktion aktivieren | 1 | 7

Bit | Bedeutung (XX) - Standard-Wert: 3E (hex) | Standard | Echte Bit Nummer
0 | Reserviert | 0 | 8
1 | Menü verblassen aktivieren (Enable menu fading) | 1 | 9
2 | Menüelemente nach Aufruf ausblenden (Nur wenn Bit 1 aktiv) (GUI: Menüelemente nach Aufruf ausblenden) | 1 | 10
3 | Quickinfo (Tooltipp) Animation aktivieren (GUI Vista: Quickinfo in Ansicht ein- oder ausblenden) | 1 | 11
4 | Quickinfo (Tooltipp) in Ansicht ein-bzw. ausblenden (nur wenn Bit 3 aktiv) | 1 | 12
5 | Mauscursor-Schatten anzeigen (GUI: Mausschatten anzeigen) | 1 | 13
6 | Zeiger bei Tastatureingabe ausblenden | 0 | 14
7 | Reserviert | 0 | 15

Bit | Bedeutung (YY) - Standard-Wert: 07 (hex) | Standard | Echte Bit Nummer
0 | Zeigerposition beim Drücken der STRG-Taste anzeigen | 1 | 16
1 | Bei Windows 2000: Bewirkt flache Menüs "office xp style" (geht nur im Zusammenhang mit Bit 7 von ZZ). Fehlerhafte Anzeige des Menüs bei Themewechsel Luna -> Zune, da dann das Bit von 1 auf 0 gesetzt wird. Ab Windows Vista: Visuelle Stile für Fenster und Schaltflächen verwenden | 1 | 17
2 | Menüschatten anzeigen (GUI: Menüschatten anzeigen) | 1 | 18
3 | Reserviert | 0 | 19
4 | Reserviert | 0 | 20
5 | Reserviert | 0 | 21
6 | Reserviert | 0 | 22
7 | Reserviert | 0 | 23

Bit | Bedeutung (ZZ) - Standard-Wert: 80 (hex) | Standard | Echte Bit Nummer
0 | Reserviert | 0 | 24
1 | Reserviert | 0 | 25
2 | Reserviert | 0 | 26
3 | Reserviert | 0 | 27
4 | Reserviert | 0 | 28
5 | Reserviert | 0 | 29
6 | Reserviert | 0 | 30
7 | Alle GUI-Effekte können aktiv sein | 1 | 31

Ab Windows Vista:

Bit | Bedeutung (VV) - Standard-Wert: 12 (hex) | Standard | Echte Bit Nummer
0 | Reserviert | 0 | 32
1 | Steuerelemente und Elemente innerhalb von Fenstern animieren | 1 | 33
2 | Reserviert | 0 | 34
3 | Reserviert | 0 | 35
4 | Reserviert | 1 | 36
5 | Reserviert | 0 | 37
6 | Reserviert | 0 | 38
7 | Reserviert | 0 | 39

Wollen Sie also Funktion verändern, gehen Sie folgendermaßen vor:

  • Lesen Sie den ersten Wert WW aus (angenommen hier steht B0)
  • Rechnen Sie den Wert in einen Binär-Wert um (Windows Taschenrechner auf Ansicht "Wissenschaftlich"). Sie erhalten dann für B0 den Wert "10110000".
  • Tragen Sie diese Zahl in die Tabelle ein und aktivieren bzw. deaktivieren Sie an den entsprechenden Stellen die gewünschten Funktionen:

1 | 0 | 1 | 1 | 0 | 0 | 0 | 0
Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0

  • Das gewünschte Ergebnis (hier wurde nur die X-Mouse Funktion aktiviert) rechnen Sie nun wieder in einen Hex-Wert zurück und tragen die Zahl in die Registry ein:

1 | 1 | 1 | 1 | 0 | 0 | 0 | 0
Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0

hier also für WW den Wert F0 Eintragen.

Des weiteren müssen Sie noch unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

den Eintrag "ActiveWndTrkTimeout" als Datentyp REG_DWORD erstellen. Geben Sie hier die Zeit in Millisekunden an, nach der das Fenster, unter dem sich der Mauszeiger befindet, umgeschaltet wird. Zu empfehlen ist ein Wert von ca. 600 ms, da ansonsten zu schnell auf andere Fenster umgeschaltet wird.

Nach einer Neuanmeldung stehen die Funktionen zur Verfügung.

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.

Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Info Wenn AutoRaise eingeschaltet ist, werden schnell auch unbeabsichtigt Fenster in den Vordergrund geholt, wenn die Maus in ein kleineres Fenster auf dem Desktop bewegt wird. Daher besteht die Möglichkeit, die rechte Maustaste zu drücken, während die Maus auf dem Wege zu diesem Fenster ist, dann erfolgt kein AutoRaise.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0371.htm


Menüs nur nach rechts aufklappen

Windows öffnet die Drop-Down Menüs immer links vom Menüicon. Sie können aber über die Registry einstellen, dass die Menüs nach rechts aufgeklappt werden. Ändern Sie dafür einfach folgenden Wert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

erstellen Sie einen neuen Wert mit dem Namen "MenuDropAlignment" als Datentyp REG_SZ. Setzen Sie den Wert auf 1. Nach einem Neustart werden alle Menüs nach rechts ausgerichtet.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1038.htm


Smooth Scrolling unter Telnet

Mit diesem Wert können Sie auch in Telnet das "Smooth Scrolling" aktivieren.

Wenn Sie den Eintrag "SmoothScroll" aktivieren (Festlegung auf "1"), ist die Funktion aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Telnet

Erstellen Sie einen neuen Eintrag mit dem Namen "SmoothScroll" als Datentyp REG_DWORD und setzen den Wert auf "1".

Siehe auch Tipp:

Smooth Scrolling

Smooth Scrolling in Internet Explorer

Smooth Scrolling unter Outlook Express

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1307.htm


Fensterinhalt beim Verschieben anzeigen

Wenn Sie diesen Tipp aktivieren, wird beim Verschieben von Fenstern der Inhalt weiterhin angezeigt. Bei nicht so schnellen Rechnern kann es sich lohnen, wenn Sie diese Funktion deaktivieren.

Diese Einstellung finden Sie unter: "Systemsteuerung" -> "System". Gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen"

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Fensterinhalt beim Ziehen anzeigen"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "DragFullWindows" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Fensterinhalt anzeigen
0 | Fensterinhalt nicht anzeigen

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1601.htm


Wie verhindere ich, dass Symbole in der Systemsteuerung angezeigt werden?

Mit dem Systemrichtlinien-Editor bzw. ab Windows 2000 Gruppenrichtlinien-Editor (GPEDIT.MSC) können Sie für jeden einzelnen Benutzer einstellen, ob die Symbole Anzeige, Netzwerk, Drucker, System und Kennwörter sichtbar sind.

Es gibt außerdem Pläne für das Resource Kit, die eine Einschränkung pro Computer, pro Benutzer und pro Benutzergruppe erlauben sollen. Die Einstellungen in jeder.CPL-Datei (die Datei, die über das Symbol aufgerufen wird) definieren die gültigen Einträge in der Registrierung, damit können bestimmte Teile vor dem Benutzer versteckt werden. CPL-Dateien von Drittherstellern könnten ebenfalls diese Schlüssel für die Richtlinien in der Registrierung implementieren, um den Zugriff auf bestimmte Registerkarten einzuschränken.

Hinweis:

Der Systemrichtlinien-Editor befindet sich auf der CD-ROM im Verzeichnis \ADMIN\APPTOOLS\POLEDIT.EXE. Der Guppenrichtlinien-Editor wird ab Windows 2000 automatisch mit installiert.

Info Siehe auch "Datenschutz mit POLEDIT.EXE" und "Icons der Systemsteuerung ausblenden".

Info Geht mit den PowerToys (Tweak UI) einfacher!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0110.htm


Bereiche der Systemsteuerung direkt starten

Mit den Befehl CONTROL Dateiname.CPL können Sie Zuordnungen der Systemsteuerung direkt aufrufen. Damit ist es also möglich, Aufrufe direkt auf den Desktop oder in das Startmenü zu legen.

Nicht für alle Funktionen gibt es aber CPL-Dateien. Einige Funktionen werden durch eine CPL-Datei aufgerufen und durch Angabe einer Nummer hinter der CPL-Datei ausgewählt (z.B. CONTROL SRVMGR.CPL,@1 für Dienste). Zu beachten ist, dass die Zählung bei 0 beginnt.

Hat eine Funktion noch weitere Register, können Sie diese durch Angabe einer weiteren Zahl gleich aktivieren. Wenn Sie z.B. von "Eigenschaften von Eingabehilfen" das Register "Akustische Signale" aktivieren möchten, sieht der Aufruf folgendermaßen aus: "CONTROL ACCESS.CPL,@0,2".

Bei einigen Funktionen erfolgt der Aufruf in folgendem Format: "CONTROL xxx.CPL,,Nummer".

Hier die Beschreibung der CPL-Dateien. Es kann möglich sein, dass bei Ihnen einige CPL-Dateien nicht installiert sind.

Einige Einstellungen können Sie über Control auch ohne die Angabe einer CPL-Datei öffnen (Spalte "Alternative").

Dateiname | Bedeutung | Ab Betriebssystem | Alternative
ACCESS.CPL | Eigenschaften von Eingabehilfen | alle | -
APPWIZ.CPL | Eigenschaften von Software | alle | -
APPWIZ.CPL,@1 | Eigenschaften von Ordneroptionen | Windows 2000 | -
BDEADMIN.CPL | Borland Database Engine konfigurieren | Windows 98 | -
CONSOLE.CPL | Eigenschaften der Eingabeaufforderung | NT4 | -
DESK.CPL | Eigenschaften der Anzeige (Hintergrund ) | alle | desktop
DESK.CPL,,1 | Anzeige - Bildschirmschoner | alle | -
DESK.CPL,,2 | Anzeige - Darstellung | alle | color
DESK.CPL,,3 | Anzeige - Einstellungen | alle | -
DEVAPPS.CPL | PCMCIA-Karte | NT4 | -
DEVAPPS.CPL,@1 | SCSI-Adapter | NT4 | -
DEVAPPS.CPL,@2 | Bandgeräte | NT4 | -
bthprops.cpl | Bluetooth Einstellungen | Windows XP |
FINDFAST.CPL | Indexerstellung | Office | -
firewall.cpl | Windows Firewall | Windows XP |
HDWWIZ.CPL | Hardware-Assistent | Windows 2000 | -
INETCPL.CPL | Interneteinstellungen | alle | -
INETCPL.CPL benutzer | Benutzerverwaltung | Windows 9x | -
INFRARED.CPL | Infrarot-Monitor | Windows 98 | -
INTL.CPL | Ländereinstellungen | alle | international
irprops.cpl | Drahtlose Verbindungen | Windows XP |
iscsicpl.cpl | Internet Optionen |  |
JOY.CPL | Gamecontroller | Windows 98, Windows 2000 | -
jpicpl32.cpl | Java Control Panel | Wenn installiert |
keymgr.cpl | Stored Passwörter |  |
LICCPA.CPL | Lizenzierungen | NT4 | -
MAIN.CPL | Eigenschaften der Maus | alle | mouse
MAIN.CPL,@1 | Eigenschaften der Tastatur | alle | keyboard
MAIN.CPL,@2 | Druckereinstellungen | Windows 98, NT4 | printers
MAIN.CPL,@3 | Installierte Schriftarten | Windows 98, NT4 | fonts
MLCFG32.CPL | Mail-Internetkonten | NT4 | -
MMSYS.CPL | Multimediaeinstellungen | alle | -
MMSYS.CPL,@1 | Eigenschaften von Akustischen Signalen | Windows 98, NT4 | -
MODEM.CPL | Modemeinstellungen | Windows 98, NT4 | -
nusrmgr.cpl | Benutzerkonten | Windows XP |
netsetup.cpl | Netzwerkinstallations-Assistent | Windows XP |
NCPA.CPL | Netzwerkeigenschaften | NT4, Windows 2000 | -
NCPA.CPL benutzer | Benutzerverwaltung | NT4, Windows 2000 | -
NETCPL.CPL | Netzwerk | Windows 98 | -
NWC.CPL | GSNW | alle | -
ODBCCP32.CPL | ODBC Einstellungen | alle | -
PASSWORD.CPL | Eigenschaften von Kennwörter | Windows 98 | -
PORTS.CPL | Anschlüsse | NT4 | -
POWERCFG.CPL | Eigenschaften von Energieoptionen | Windows 98, Windows 2000 | -
SRVMGR.CPL | Server Einstellungen | NT4 | -
SRVMGR.CPL,@1 | Dienste | NT4 | -
SRVMGR.CPL,@2 | Geräte | NT4 | -
STICPL.CPL | Eigenschaften von Scanner und Kameras | Windows 98, Windows 2000 | -
SYSDM.CPL | Systemeigenschaften | alle | -
SYSDM.CPL,,1 | Gerätemanager | alle | ports
System.cpl | Add New Hardware | Windows 98 | -
TELEPHON.CPL | Telefon | alle | -
Themes.cpl | Desktopmotive | Windows 9x | -
TIMEDATE.CPL | Eigenschaften von Datum/Uhrzeit | alle | date/time
TweakUI.CPL | Tweak UI | Wenn installiert | -
UPS.CPL | USV Gerät | NT4 | -
wuaucpl.cpl | Automatische Updates | Windows XP |
wscui.cpl | Windows-Sicherheitscenter | Windows XP |
WGOCPL.CPL | MS Mail PostOffice |  | -
WGPOCPL.CPL | Administrator PostOffice |  | -
userpasswords2 | Benutzerkonten (ohne .CPL) | Windows 2000 |

Siehe auch: "Icons der Systemsteuerung ausblenden" und "Verwaiste Einträge aus der Systemsteuerung entfernen".

Das Tool "SysInstruction" von http://www.damgf.de bietet eine Übersicht über alle *.cpl und Control Befehle die unter Windows zur Verfügung stehen. Download: http://www.damgf.de/site/index.php?showfile=1&fid=1&p=downloads&area=1&categ=2

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0584.htm


Das Icon "Kennwörter" aus der Systemsteuerung entfernen

Durch folgenden Eintrag können Sie das Icon "Kennwörter" aus der Systemsteuerung entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Schlüssel | Datentyp | Angabe als | Standard
Bei 1 wird der Eintrag Kennwörter aus der Systemsteuerung entfernt
NoSecCPL | REG_SZ | Boolean | 0

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0813.htm


Icons der Systemsteuerung ausblenden

Sie können Icons, die der Anwender nicht sehen soll, aus der Systemsteuerung ausblenden. Für jedes Icon, das nicht in der Systemsteuerung angezeigt werden soll, müssen Sie einen Eintrag in der Registry anlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\

Legen Sie einen neuen Schlüssel-Eintrag mit dem Namen "Don’t Load" (dieser Schlüssel ist in den meisten Fällen noch nicht vorhanden ( ' <- ist das Zeichen über dem # auf der deutschen Tastatur)), der Registry Pfad sieht nun folgendermaßen aus:

HKEY_CURRENT_USER\ Control Panel\ Don’t Load

Unter diesem Schlüssel legen Sie nun die Namen der CPL-Dateien, die nicht angezeigt werden sollen, als neuen Wert mit den Datentyp REG_SZ an. Weisen Sie diesen Einträgen den Wert 1 zu und schon werden die Icons nicht mehr in der Systemsteuerung angezeigt.

Hier eine Liste der Dateinamen der betreffenden Icons aus der Systemsteuerung, CPL-Dateien von anderen Herstellern können damit natürlich auch ausgeblendet werden.

Dateiname | Bedeutung | System
ACCESS.CPL | Eigenschaften der Eingabehilfe | alle bis Vista
APPWIZ.CPL | Eigenschaften von Software | alle
BDEADMIN.CPL | BDE-Verwaltung | Windows 98
BTHPROPS.CPL |  | Vista
CONSOLE.CPL | Eigenschaften der Eingabeaufforderung | NT4
COLLAB.CPL | Personen in meiner Umgebung | Vista
DESK.CPL | Eigenschaften der Anzeige | alle
DEVAPPS.CPL | PCMCIA-Karte | NT4
FINDFAST.CPL | Indexerstellung | Office
FIREWALL.CPL | Windows-Firewall | Ab XP
HDWWIZ.CPL | Hardware-Assistent | Ab 2000
INETCPL.CPL | Interneteinstellungen | alle
INFRARED.CPL | Infrarot-Monitor | Windows 98
INFOCARDCPL.CPL |  | Vista
INTL.CPL | Ländereinstellungen | alle
IRPROPS.CPL | Drahtlose Verbindung | Ab 2000
JOY.CPL | Gamecontroller | alle
LICCPA.CPL | Lizenzierungen | NT4
MAIN.CPL | Eigenschaften der Maus | alle
MLCFG32.CPL | Mail Configuration, Internetkonten | Windows 95, NT4
MMSYS.CPL | Multimediaeinstellungen | alle
MODEM.CPL | Modemeinstellungen | Windows 98, NT4
NCPA.CPL | Netzwerkeigenschaften | Ab NT
NETCPL.CPL | Netzwerk | Windows 98
NETSETUP.CPL | Drahtlosnetzwerkinstallations-Assistent | Windows 2000
NUSRMGR.CPL | Benutzerkonten | Ab Windows 2000
NWC.CPL | Client Service für Netware (GSNW) | alle
ODBCCP32.CPL | ODBC Einstellungen | alle
PASSWORD.CPL | Eigenschaften von Kennwörter | Windows 98
PORTS.CPL | Anschlüsse | NT4
POWERCFG.CPL | Eigenschaften von Energieoptionen | Windows 98, Ab 2000
SAPI.CPL | Sprachen-E in und Ausgabe | Windows 2000
SMScfg | System Management Properties | Windows 2000, Windows XP
SMSrrc | Remote Control Properties | Windows 2000, Windows XP
SRVMGR.CPL | Server Einstellungen | NT4
STICPL.CPL | Eigenschaften von Scanner und Kameras | Windows 98, Windows 2000
SYSDM.CPL | Systemeigenschaften | alle
TABLETPC.CPL | Stift und Eingabegeräte | Vista
TELEPHON.CPL | Telefon | alle
THEMES.CPL | Desktop-Motive | Windows 9x
TIMEDATE.CPL | Eigenschaften von Datum/Uhrzeit | alle
UPS.CPL | USV Gerät | NT4
WSCUI.CPL | Windows-Sicherheitscenter | Ab XP
WGPOCPL.CPL | Arbeitsgruppen-Postoffice | Windows 95
WUAUCPL.CPL | Automatische Updates | Windows XP

Einige bekannte Icons von anderen Herstellern:

Dateiname | Beschreibung
3Deep.cpl | 3Deep Control
Audiohq.cpl | Creative Audio HQ Control
ccpan32.cpl | Calcomp Tablett Treiber
CtDetect.cpl | Creative Disc Detector
ColorificPanel.cpl | Colorific Control
Cpqdiag.cpl | Compaq Diagnose
epshell | EppieDesktop Control
findfast.cpl | Office FindFast Control
HWSetup.cpl | Toshiba Hardware Control
iamcpl.cpl | Atguard Control
irmon.cpl | Infrarot Monitor
mgapanel.cpl | Matrox MGA Control
monctrl.cpl | ELSA Monitor Einstellungen
moreshex.cpl | Rei's More Extensions Control
nvtuicpl.cpl | nView Desktop Manager
nwc.cpl | Novell Netware Client Control
opl3sax.cpl | Soundchip-Einstellungen
pacecfg.cpl | 3COM Netzwerkkonfiguration
plugincplXXX.cpl | Java Plugin (XXX=Version)
prefscpl.cpl | RealPlayer Konfiguration
PWRSave.cpl | Toshiba Power Saver Control
QTW32.cpl | QuickTime Control
QuickTime.cpl | QuickTime Control
Rascpl.cpl | RAS-Dienst
s32lucp1.cpl | Symantec Live-Update
S3COLOR.cpl | S3 Treibereinstellungen
SanCpl.cpl | SiSoft Sandra Control
Timeprop.cpl | Toshiba Mobile-Extensions
Toshcfg.cpl | Toshiba Control
TPwrSave.cpl | Toshiba Power Saver-Eigenschaften
TweakUI.cpl | MS Tweak UI Control
XQXSetup.cpl | Xteq X-Setup

Info Für weitere Namen suchen Sie nach Dateien mit der Erweiterung ".cpl" im Verzeichnis %Systemroot%\System32, um den Dateinamen eines Systemsteuerungsobjekt zu finden.

Siehe auch: "Bereiche der Systemsteuerung direkt starten" und "Verwaiste Einträge aus der Systemsteuerung entfernen".

Info Unter Windows 9x/ME können diese Einträge auch in der Datei "CONTROL.INI" im Verzeichnis "C:\WINDOWS" vorgenommen werden. Dafür erstellen Sie eine neue Sektion mit dem Namen "[dont't load]" und tragen dort zeilenweise die CPL-Dateien ein, die nicht mehr angezeigt werden sollen (z.B.: MAIN.CPL=NO). Starten Sie Windows danach neu.

Info Die Icons werden nur aus der Systemsteuerung ausgeblendet. Wenn der Anwender die CPL-Dateien direkt aufruft, kann er noch auf die Funktionen zugreifen, falls die Rechte nicht anderweitig eingeschränkt wurden (siehe auch "Wie verhindere ich, dass Symbole in der Systemsteuerung angezeigt werden?").

Info Beachten Sie dazu auch den Tipp: Angegebene Systemsteuerungssymbole ausblenden bzw. Nur angegebene Systemsteuerungssymbole anzeigen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0529.htm


Verwaiste Einträge aus der Systemsteuerung entfernen

Falls nach der Deinstallation eines Programms - auch nach einem Neustart - noch ein Icon des Programms in der Systemsteuerung vorhanden ist, können Sie dieses wie folgt indentifizieren und entfernen:

  1. Explorer - Rechtsklick auf C:\Windows - Suchen - Name: *.cpl
  2. Die nun aufgeführten Einträge identifizieren Sie über Rechtsklick - Eigenschaften - Version, oder indem Sie doppelt auf das Icon klicken
  3. Wenn Sie den verwaisten Eintrag lokalisiert haben, können Sie ihn löschen

Siehe auch "Bereiche der Systemsteuerung direkt starten" und "Icons der Systemsteuerung ausblenden".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1302.htm


Eigene Programme oder fremde CPLs in die Systemsteuerung einbinden

In diesem Tipp wird Ihnen gezeigt, wie Sie eigene Programme oder fremde CPLs in die Systemsteuerung einbinden können.

(von Roland Hirsch)

Anhand einer Beispiel-REG-Datei wird verdeutlicht, wie Sie dafür vorgehen müssen.

Ich habe zum Beispiel das frei verfügbare "Startup Control Panel" von Mike Lin (Freeware, http://mlin.net) hinzugefügt. Dazu habe ich die Standalone EXE-Datei genommen und sie umbenannt. Zudem habe ich die Datei in das Verzeichnis "%SystemRoot%\System32" kopiert

Erstellen Sie eine Textdatei mit dem folgenden Inhalt und speichern die Datei mit der Dateiendung .REG ab.

Anschließend können Sie die Einträge über den Explorer (Doppelklick) importieren.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

;Zeigt Startup in der Systemsteuerung an.

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}]

@="Startup Autostart Manager"

"InfoTip"="Programme, die beim Systemstart automatisch geladen werden, abschalten, löschen oder neue Autostart-Einträge erstellen."

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}\DefaultIcon]

@="%SystemRoot%\\System32\\startupcpl.exe,0"

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}\Shell]

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}\Shell\Open]

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}\Shell\Open\command]

@="startupcpl.exe"

[HKEY_CLASSES_ROOT\CLSID\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}\ShellFolder]

"Attributes"=dword:00000030

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{D14ED2E1-C75B-443c-BD7C-FC03B2F08C18}]

@="Fügt Startup-Manager der Systemsteuerung hinzu"

=== Hier schneiden ===

Wenn Sie eigene Programm hinzufügen wollen, müssen Sie folgende Einstellungen in der REG-Datei verändern:

  • Sie müssen die CLSID ändern. Dazu ersetzen Sie die "D14ED2E1-C75B-443c-BD7C-FC03B2F08C18" durch eine neue Nummer (am Besten einfach die letzte Zahl hochzählen, hier würde dann folgendes herauskommen "D14ED2E1-C75B-443c-BD7C-FC03B2F08C19"). Diese Nummer kommt in der REG-Datei öfter vor und muss an allen Stellen ausgetauscht werden. Wichtig ist, dass diese Nummer noch nicht in der Registry verwendet wird!
  • Weiterhin müssen Sie den Aufruf der Datei "startupcpl.exe" ersetzen. Wenn Sie die Datei nicht in das System32- Verzeichnis kopieren, müssen Sie hier auch den Pfad zur Datei angeben. Dabei muss das \ durch ein doppeltes \\ maskiert werden (Beispiel: "C:\\Programme\\Registry System Wizard\\RSW.EXE")
  • Weiterhin sollten Sie noch die Beschreibungen anpassen und auch ein neuen DefaultIcon festlegen.
  • Wenn Sie eine CPL-Datei einbinden wollen, machen Sie das über den Aufruf: rundll32.exe Shell32, Control_RunDLL <Name_deiner.cpl>

Info Siehe dazu auch Tipp: "Zusätzliche Icons zur Systemsteuerung hinzufügen"

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2642.htm


Den Eintrag 'Dateisystem' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Dateisystem" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileSysPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1579.htm


Den Eintrag 'Geräte-Manager' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Geräte-Manager" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDevMgrPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1581.htm


Den Eintrag 'Hardwareprofile' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Hardwareprofile" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoConfigPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1580.htm


Den Eintrag 'Passwortseite' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Passwortseite" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPwdPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1584.htm


Den Eintrag 'Profil-Seite' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Profil-Seite" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoProfilePage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1583.htm


Den Eintrag 'Remote Admin' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Remote Admin" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAdminPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1582.htm


Den Eintrag 'Virtueller Arbeitsspeicher' aus SYSTEM ausblenden

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Virtueller Arbeitsspeicher" unter "Systemsteuerung" -> "System" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoVirtMemPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1578.htm


Meldung wenn 'Geplante Task' nicht ausgeführt werden

Wenn Sie Aufgaben in den Taskplaner (Geplante Task) anlegen, erhalten Sie normalerweise keine Meldung, auch wenn dieser Task zum gewünschten Zeitpunkt nicht ausgeführt werden konnte.

Wenn Sie diese Funktion aktivieren erhalten Sie eine Meldung wenn ein gewünschter Task nicht ausgeführt wurde und erhalten auch die Möglichkeit den Task noch einmal zu wiederholen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ SchedulingAgent

Erstellen Sie hier einen neuen Wert mit dem Namen "NotifyOnTaskMiss" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Meldung ausgeben
0 | keine Meldung Ausgeben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1535.htm


Logfile Einstellungen vom Taskplaner

Mit dieser Einstellung legen Sie fest, wo der Taskplaner sein Logfile ablegen soll und bestimmen die max. Größe der Datei.

Abhängig vom Betriebssystem wird die Datei im Windowsverzeichnis mit den Namen "SchedLog.txt" oder "SchedLgU.txt" angelegt:

Windows 9.x/Me: "%WinDir%\SchedLog.txt"

ab Windows 2000: "%SYSTEMROOT%\SchedLgU.txt"

ab Windows Vista: "%SystemRoot%\Task\SchedLgU.TXT"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ SchedulingAgent

Erstellen Sie hier die folgenden Werte:

Wertname | Datentyp | Beschreibung
LogPath | REG_SZ | Pfad und Dateiname zur Logdatei (Standard:%SYSTEMROOT%\SchedLgU.TXT)
MaxLogSizeKB | REG_DWORD | Größe der Logdatei in KByte (Standard: 20 (HEX))

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1536.htm


Aufbau der DirectX-Versionsnummer

Die Versionsnummer von DirectX hat insgesamt 10 Stellen, die folgenden Regeln entsprechen:

Die 1 beiden Stellen: | Windows Versionsnummer (immer 04)
Die 2 beiden Stellen: | DirectX-Version: 00 gibt es nicht 01 und 02 DirectX 1 03 DirectX 2 04 DirectX 3 05 DirectX 5 06 DirectX 6
Die 3 beiden Stellen: | immer 00
Die letzten 4 Zeichen | Die Build-Nummer, die bei jedem neuen Rebuild um eine Zahl erhöht wird.

Die Versionsnummer können Sie über den Explorer an der Datei "D3DIM.DLL" über das Menü -> rechte Maustaste -> "Eigenschaften" -> "Version" ermitteln.

Ab Windows 2000 gibt es aber einen neuen Aufbau der Versionsnummer:

Die 1 beiden Stellen: | Windows Versionsnummer (hier jetzt 05)
Die 2 beiden Stellen: | immer 0
Die nächsten 4 Stellen: | Die Build-Nummer
Die letzten beiden Stellen: | Bis jetzt immer 1

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0648.htm


Buchstaben der Symboltexte auf Desktop und in Ordnern erscheinen als kleines Rechteck

Sollten nach der Installation von Fonts (Schriften) die Buchstaben der Symboltexte auf dem Desktop und in Ordner als kleines Rechteck erscheinen, hilft eine Umstellung des Fonts.

Dazu gehen Sie unter "Eigenschaften von Anzeige" -> "Darstellung" -> Button "Erweitert" -> "Bildelement" -> "Symbol" auf MS Sans Serif (Western) oder Tahoma und eine Fontgröße von 8 pt.

Außerdem sollte das Bildelement Symbol eine Größe von 32 bekommen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0915.htm


Monitor schaltet beim Start eines Spiels ab

Wenn der Monitor beim Start einer DirectX-Anwendung oder OpenGL-Spiels abschaltet oder dunkel wird, setzt die Anwendung den Monitor in eine zu hohe Frequenz.

Entweder installiert man den richtigen Monitor-Treiber oder geht wie folgt vor:

Man startet über "START" -> "Ausführen" DXDIAG und wechselt dort auf die Registerkarte "Weitere Hilfen". Hier klickt man auf "Außer Kraft setzen"und gibt dort seine Hz-Zahl manuell vor.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0872.htm


Monitor Stromspareinstellungen

Für Monitore, die den "Energy Star" Richtlinien entsprechen, können Sie unter Windows einstellen, nach welcher Zeit der Monitor in den Stromsparmodus geschaltet und wann der Monitor komplett ausgeschaltet werden soll. In der Systemsteuerung können Sie diese Einstellung aber nur in vorgegebenen Schritten ändern, wenn Sie lieber andere Einstellungen haben wollen, müssen Sie die Werte in der Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ PowerCfg\ PowerPolicies\ <nn>

wobei <nn> für die fortlaufende Nummer der einzelnen Energieschemen steht.

In den genannten Zweigen befindet sich ein Eintrag "Policies". Die Bytes 38 und 39 geben die Zeiten in Sekunden im Hex-Format in der Reihenfolge Lower-Byte Higher-Byte wieder, also z.B. 84 03 für 15 Minuten und B0 04 für 20 Minuten.

Mit dem folgenden Key konfigurieren Sie den ScreenSaver:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Aktivieren/Deaktivieren:

"ScreenSaveActive" = 1

"ScreenSaveLowPowerActive" = 1

"ScreenSavePowerOffActive" = 1

Mit diesem Werten "ScreenSaveLowPowerTimeout" und "ScreenSavePowerOffTimeout", als Datentyp REG_SZ, stellen Sie jeweils die Zeit in Sekunden ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1039.htm


Anzeige von Vorschaubildern im Active Desktop geht nicht mehr

Einige Programme (z.B. Photo Impact) deaktivieren die Vorschaufunktion des Active Desktop vom IE4. Andere Dateiformate als *.jpg werden dann links im Arbeitsplatz nicht mehr anzeigt

Man kann den Fehler beheben, indem man in dem Fenster unter "START" -> "Ausführen" folgende Befehlszeile eingibt:

regsvr32.exe /i shdocvw.dll

Nach einem Reboot sollte die Ansicht wieder funktionieren.

Optional können alle REG Schlüssel über die REG-Datei der c't wieder hergestellt werden, welche alle Einträge beinhaltet, die für die Schnellansicht verantwortlich sind. Zu finden unter ftp://ftp.heise.de/pub/ct/listings/9909-193.zip

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1088.htm


Neue Bildschirmschoner einbinden

Kopieren Sie neue Bildschirmschoner in das Verzeichnis:

Windows 9x/ME:

%WINDIR% \SYSTEM

Ab Windows NT:

%WINDIR% \SYSTEM32

Nun können Sie diese unter -> "Systemsteuerung" -> "Anzeige" -> "Bildschirmschoner" bzw. ab Vista -> "Systemsteuerung" -> "Anpassung" -> "Bildschirmschoner" auswählen und aktivieren.

Info werden dort nur Bildschirmschoner angezeigt, die die Dateiendung "SCR" tragen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0248.htm


Hauppauge WinTV meldet, dass kein WFW Treiber installiert ist

Nach der Installation aller nötigen Treiber der Hauppauge WinTV (alle Modelle) und Installation der WinTV Software kann es passieren, dass die Software einen nicht installierten Treiber meldet. Der Fehler tritt vor allem bei Karten auf, die mit der Treiber CD 1.9 ausgeliefert wurden.

Man sollte daher sich zunächst bei Hauppauge die neuen Treiber und WinTV herunterladen.

Zudem benötigt man den Patch wintvid.exe von der Homepage, welcher vor der Installation der neuen Treiber gestartet werden muss. Der Treiber lädt beim Start ein Programm, welches die genaue ID des Chipsatzes ermittelt und Windows mitteilt. Danach wird die Karte erneut erkannt und kann installiert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0877.htm


Bildwiederholfrequenz unter Windows 95A nur 60 Hz

Unter Windows 95 A gibt es noch keine Einstellmöglichkeit für die Bildschirmwiederholrate. Auch mit aktuellen Treibern benutzt Windows meist nur 60 Hz und lässt sich nicht auf höhere Werte einstellen.

Durch einen Eingriff in die Registry können Sie diesen Wert aber beeinflussen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Display\ 0000\ Default

Dort wird der Wert für die Bildschirmwiederholrate unter "RefreshRate" als "-1" oder "0" angegeben, was für optimale bzw. Standard -Wiederholrate steht.

Ändern Sie diesen Wert auf die gewünschte Bildschirmwiederholrate, die Ihr Monitor noch unterstützt durch die Eingabe von 75, 85 oder 100.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0788.htm


DirectX deinstallieren

Lt. Angabe von MS lässt sich DirectX nicht mehr deinstallieren. Es gibt aber ältere Spiele, die mit der neueren DirectX Version nicht zurechtkommen. Da man aber keine ältere Version über eine neuere installieren kann, muss man das DirectX durch manuellen Eingriff entfernen.

Vorher sollten Sie Ihr System sichern.

In der Registry müssen Sie folgende Keys löschen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Direct3D

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DirectDraw

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DirectPlay

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DirectX

Wechseln Sie dann in den MS-DOS Modus und löschen Sie folgende Dateien:

Aus dem C:\Windows\System\ Verzeichnis (Es kann sein, dass einige Dateien nicht vorhanden sind):

ddhelp.exe

ddraw*.*

dsound *.*

dinput*.*

d3d*.*

dplayx.dll

dpmodemx.dll

dpwsockx.dll

directx.cpl

vjoyd.vxd

joy.cpl

dplaysvr.exe

dpwsock.dll

dpserial.dll

dplay.dll

Zusätzlich bei Windows 98 noch aus dem Verzeichnis C:\Windows\Sysbckup

Ddhelp.exe

Ddraw*.*

Dsound *.*

Dinput*.*

D3d*.*

Dplayx.dll*.*

Dpmodemx.dll

Dpwsockx.dll

Unter dem Link: http://www.heise.de/ct/ftp/99/03/204bietet c't eine Möglichkeit, jede DX-Version zu deinstallieren. Der komplette Artikel incl. aller Quellcodes steht dort zum Download bereit.

Optional kann man auch den DirectX Buster verwenden. Die Homepage von DirectX Buster lautet http://www.dxbuster.de

Ebenfalls erfolgversprechend ist folgende Vorgehensweise (Windows 98 "überinstallieren", nicht geeignet für Anwender, dir nur im Besitz einer sogenannten Recovery-CD sind):

  1. Falls noch nicht geschehen, kopieren Sie den WIN98 Ordner der CD auf die Festplatte (z.B. nach C:\WIN98, Platzbedarf ca. 100 MB). Dies ist empfehlenswert, weil Sie dann später die Win-CD nicht benötigen, wenn Windows im Rahmen einer Software- oder Treiberinstallation einige Originaldateien nachinstallieren will, oder wenn Sie eine Datei wiederherstellen möchten. Siehe auch "Installationslaufwerk und -pfad ändern (Source-Daten)" und "Die Systemdateiprüfung (SFC) findet keine geänderten Dateien"
  2. Starten Sie den Rechner neu, halten Sie <STRG> gedrückt, bis das Bootmenü angezeigt wird und wählen Sie "Nur Eingabeaufforderung
  3. Mit "cd \win98" (ohne Anführungszeichen) wechseln Sie in den Ordner, der die Windows 98-Setup-Dateien enthält
  4. Mit "setup" (ohne Anführungszeichen) starten Sie die erneute Installation.
  5. Wenn die Installation abgeschlossen ist, können Sie wieder DirectX (Version 7.x, 8.x) installieren
  6. Die momentan installierte Version von DirectX können Sie mit "Start" - "Ausführen" - "dxdiag" ermitteln. S. dazu auch "Aufbau der DirectX Versionsnummer".
  7. Es kann vorkommen, dass DxDiag ältere Versionen einiger Dateien bemängelt. Wenn die Tests für Anzeige, Sound und Musik fehlerfrei verlaufen, können Sie diese Meldung ignorieren.

Info Zu möglichen Nebenwirkungen, die duch das Überinstallieren von Windows auftreten können, lesen Sie bitte "Keine Windows-Anmeldung nach 'Überinstallieren' von Windows".Unter Umständen müssen Sie noch einige Treiber (Scanner, Netzwerkkarte) nachinstallieren, was aber einer völligen Neuinstallation und dem damit verbundenen Aufwand oft vorzuziehen ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0607.htm


AGP Konflikt bei Installation einer PCI-Grafikkarte

Wenn Ihr Rechner eine AGP -Schnittstelle besitzt, Sie aber eine PCI-Grafikkarte benutzen, kann es bei der Installation des Grafikkartentreibers nach einem Neustart des Rechners zu folgender Fehlermeldung kommen:

Bei der Initialisierung von Gerät VGARTD: Windows-Schutzfehler. Sie müssen einen Neustart durchführen.

Egal wie oft Sie diesen Neustart auch durchführen, der Rechner meldet sich immer wieder mit dieser Fehlermeldung. Der Grund ist, dass die Datei "VGARTD.VXD" für die Unterstützung von AGP -Karten benötigt wird. Auf einem System mit einer PCI-Karte ist diese Datei nicht nötig. Um den Fehler zu beheben, müssen Sie folgendermaßen vorgehen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  1. Löschen Sie die Datei "VGARTD.VXD" aus dem Verzeichnis "C:\Windows\System"
  2. Beim Start von Windows erscheint nun die Fehlermeldung, dass die Datei nicht gefunden werden konnte. Bestätigen Sie diese Meldung. Starten Sie unter Windows REGEDIT.EXE. Lassen Sie hier die Registry nach den Gerätetreiber durchsuchen und löschen Sie den Aufruf dieser Datei aus der Registry.

Jetzt sollte das System fehlerfrei funktionieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0445.htm


Bildschirmschoner bei DEFRAG verhindern

Während der Defragmentierung der Festplatte stört ein laufender Bildschirmschoner das System erheblich.

Man kann das jedoch durch einen Registryeintrag verhindern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Defrag\ Settings

erstellen Sie einen neuen Schlüssel mit dem Namen "DisableScreenSaver" und setzen den Eintrag "(Standard)" als Datentyp REG_SZ auf den Wert "yes" (es kann sein, dass Sie die Schlüssel "Defrag" und "Settings" erst anlegen müssen).

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=229057

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0924.htm


Auflösung lässt sich nicht ändern

Wenn Sie die Auflösung oder die Bildwiederholfrequenz nicht erhöhen können, aber ihre Grafikkarte eigentlich viel mehr kann, kann es daran liegen, dass Windows Ihren Monitortyp nicht richtig erkannt hat.

Installieren Sie keinen Standard-Bildschirmtyp, sondern wählen Sie einen anderen Monitortyp aus. Sollte Ihr Bildschirm nicht aufgelistet sein und Sie haben auch keine Treiber-Diskette, wählen Sie einen ähnlichen (z.B. einen der NEC-Monitore).

Info Man kann sich auch einen Monitor-Typ manuell erstellen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0034.htm


Monitor manuell konfigurieren

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  1. Die Standardeinstellung gegen einen x-beliebigen Monitor austauschen. Wählen Sie aber einen, anhand dessen Bezeichnung man auf seine Bildschirmgröße schließen kann. Zu große Abweichung könnte nämlich unter Umständen Ihren Monitor beschädigen. Wählen Sie zur Sicherheit hohe Farbtiefe und eine geringe Auflösung (640*480, 16 Mio. Farb.)
  2. Starten Sie den Rechner neu.
  3. Aufrufen von REGEDIT.EXE
  4. Im nun geöffneten Registry-Editor auf -> "Bearbeiten" -> "Suchen" klicken. Suchen Sie die Zeichenfolge: "30-6" oder "30.0-6". Wenn alles korrekt verlief, müssten Sie sich jetzt bei einem Eintrag namens "MODE1" befinden (wenn nicht mit F3 weitersuchen). Klicken Sie auf diesen Eintrag.
  5. Nun können Sie die Werte an Ihren Monitor anpassen. Diese entnehmen Sie Ihren Monitor-Unterlagen. Nehmen wir an, da steht 30-60, 50-90,-,- dann stehen die ersten beiden Werte für die Horizontalfrequenz und die beiden anderen für die Vertikalfrequenz. Sie sollten darauf achten, nur die Zahlen und nicht die evtl. auch noch vorhandenen sonstigen Zeichen zu ändern.
  6. Schließen Sie den Registry-Editor und starten Sie Windows neu.

Auf ftp://ftp.diamondmm.de/hotline/files/flimm.exefindet man ein kleines deutsches Freewaretool (27 KB, dass einem die an den Monitor übermittelte Bildwiederhol-, Horizontal- und Vertikalfrequenz anzeigt, damit lassen sich die Einstellungen gut überprüfen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0035.htm


S3 Grafikkarte und COM4 Konflikt

Fehlerbeschreibung zum Problem mit einer S3 Grafikkarte und dem COM-Port im Zusammenspiel unter Windows 95.

Frage:

Ich arbeite mit Windows 95 und habe in meinem Rechner eine S3-Grafikkarte sowie eine COM4-Schnittstelle (internes Modem) eingebaut. Wenn ich nun einen S3-Treiber von Windows 95 installiert habe und auf den COM4-Port zugreifen möchte, schlägt dieser Versuch fehl. Installiere ich statt des S3-Treibers den Standard VGA-Treiber, funktioniert die Kommunikation über den COM-Port problemlos. Woran liegt das?

Antwort:

Die Problematik liegt darin, dass der S3-Chipsatz auf die Adresse 02E8h zugreift. Diese Adresse ist jedoch die Standard-Adresse des COM4-Ports. Da die S3-Grafikkarte, wenn sie mit dem Standard VGA-Treiber angesteuert wird, nicht auf diese Ressource zurückgreift, funktioniert die Kommunikation problemlos. Um die Kommunikation mit dem COM4-Port zu gewährleisten, müssen Sie die E/A-Adresse des COM4-Ports ändern. Dies kann entweder per Hardware (Jumper auf der Schnittstellen-Karte) oder per Software über Systemsteuerung/System und Gerätemanager/Anschlüsse (COM und LPT) /COM-Anschluss (COM4)/Resourcen/E/A-Bereich erfolgen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0242.htm


Refresh Rate einstellen

Bei manchen Grafikkarten spielen die Einstellungen in der Registry keine bzw. eine untergeordnete Rolle. Dann kann man diese auch in die SYSTEM.INI eintragen:

[Display]

RefreshRate= XX

Die RefreshRate wird in Hz angegeben. Für Ihren Monitor zulässige Werte können Sie dem Monitor-Handbuch entnehmen. Für eine Auflösung von 800*600 ist eine RefreshRate von 72 Hz üblich.

Wer nicht weiß, welche RefreshRate im Moment benutzt wird, kann dies z.B. mit Hilfe von WinBench herausfinden (Benchmark Programm vom Ziff-Davis Verlag, Freeware, http://etestinglabs.com/benchmarks/winbench/winbench.asp).Page Not Found

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0286.htm


Schwarzer Bildschirm (DDC-Abfrage)

Tipp 1 (Fehler)

Wenn beim Starten von Windows der Monitor schwarz bleibt, kann es an der DDC (Display Data Control) Abfrage liegen (Kenndatenübermittlung des Monitors). Sie können aber in der Registrydatenbank die DDC-Funktion abschalten. Starten Sie dazu Windows im Abgesicherten-Modus (nun sollten Sie wieder ein Bild sehen) und ändern Sie folgenden Eintrag:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Display\ 0000\ Default

Hier ändern Sie nun den Wert "DDC" von "1" auf "0"

Tipp 2 (Geschwindigkeit)

Auch auf Systemen, auf denen DDC fehlerfrei läuft, kann es Sinn machen, diese Funktion auszuschalten. Ist der Wert eingeschaltet (DDC = 1), wird beim Systemstart jedesmal neu die Bildwiederholrate für den angeschlossenen Monitor ermittelt. Da diese aber meist über die "Systemsteuerung" -> "Monitor" festgelegt ist, kann das Deaktivieren (DCC = 0) das Starten von Windows etwas beschleunigen (1-2 sec.).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0287.htm


SPEA - Logo ausschalten

Öffnen Sie die Datei SYSTEM.INI und ändern Sie folgendes:

[car1k.drv]

Logooff=1

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0294.htm


Virtueller Desktop bei Matrox-Karten

Haben Sie eine Matrox Millennium, Treiber Version 3.0 mit Powerdesk und möchten ein eigenes Display-Schema erstellen, ist dies bei einem virtuellen Desktop von 1000 x 600 leider nicht möglich.

Mit einer kleinen Änderung in der Registry können Sie es jedoch tun:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Finden Sie (ggf. anlegen) unter

HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\ Services\ mga64\ Device0

die Binärwerte "Mga.DesktopX" und "Mga.DesktopY".

Diese Pixelwerte müssen Dezimal eingegeben werden.

Beispiel:

Auflösung :800 x 600

Virtueller Desktop :1000 x 600

Geben Sie folgendes ein:

Mga.DisplayX=800 | Mga.DesktopX=1000
Mga.DisplayY=600 | Mga.DesktopY=600

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0295.htm


Voodoo mit 75 Hz

Um die 3dfx Karten mit Voodoo Chip auf 75 Hz Bildwiederholfrequenz zu setzen, muss in der Autoexec.bat die Zeile

SET SST_SCREENREFRESH 75

eingetragen werden. Spiele werden dadurch minimal langsamer, die Augen aber deutlich geschont.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0701.htm


Overclocking-Tool im Treiber aktivieren

Die NVidia-Detonator-Treiber bieten schon eine Fülle von Einstellmöglichkeiten. Allerdings kann mit einem Eingriff in die Registry ein weiteres Fenster hervorgezaubert werden, welches die Einstellung des Core- und Memory-Taktes ermöglicht. Zudem kann dann auf den sog. VSYNC Einfluss genommen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ NVIDIA Corporation\ Global

einen neuen Schlüssel mit dem Namen "NVTweak" erstellen. In diesem Schlüssel erstellt man einen neuen Eintrag mit dem Namen "Coolbits" als Datentyp REG_DWORD und gibt diesem den Hex-Wert 03.

Nach einem Neustart steht dann unter den erweiterten Einstellungen des Treibers auch die Registerkarte Hardware Options mit den oben beschriebenen Einstellungen zur Verfügung. Die Einstellungen für den VSYNC finden sich unter D3D-Settings -> More D3D-Settings.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0950.htm


Monitor Power-Off in LOGIN-Bildschirm

Mit diesem Tipp können Sie einstellen, dass auch im Login-Bildschirm die Funktion "Power-Off" des Monitors aktiv ist.

Dazu muss "Power-Off" aktiviert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USER\ .DEFAULT\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "PowerOffActive" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Power-Off aktivieren
0 | Power-Off deaktivieren (Standard)

HKEY_USER\ .DEFAULT\ Control Panel\ PowerCfg

Erstellen Sie hier einen neuen Wert mit dem Namen "CurrentPowerPolicy" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Desktop
1 | Tragbar/Laptop
2 | Präsentation
3 | Dauerbetrieb
4 | Maximale Performance
5 | Minimaler Energieverbrauch (Batteriebelastung)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1622.htm


'Weichzeichnen' für die Schrift aktivieren

"Weichzeichnen" für die Schrift aktivieren

Wenn Sie diese Funktion aktivieren, werden die Schriften geglättet dargestellt.

Ab Windows 2000 finden Sie diese Einstellung unter: "Systemsteuerung" -> "System". Gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen"

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Kanten der Bildschirmschriftarten verfeinern"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "FontSmoothing" als Datentyp REG_SZ. Setzen Sie den Wert auf:

0 | deaktivieren die Schriftglättung
1 | Nur Windows 95,98,ME Schaltet die Schriftglättung ein
2 | Ab Windows NT Schaltet die Schriftglättung ein

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Info Siehe dazu auch Tipp:
ClearType: Art der Kantenglättung und Schriftglättung
Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren
ClearType: Helligkeit der Farbtöne für die Schriftglättung
ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1676.htm


DirectX: DirectDraw und Direct3D Konfiguration

Hier finden Sie eine Beschreibung für die Konfiguration von DirectX unter Windows. Dabei handelt es sich in vielen Fällen um besondere Konfigurationen, die meistens nicht verändert werden müssen, aber unter gewissen Umständen doch sehr hilfreich sein können.

Die Einstellungen können auch über das Tool DXDIAG verändert werden. Aufzurufen über "Start" -> "Ausführen" und dort DXDIAG eingeben. Dadurch starten Sie ein Diagnoseprogramm für DirectX.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DirectDraw

Erstellen Sie hier die neuen Einträge aus der Tabelle als Datentyp REG_DWORD und setzen Sie den Wert auf 1 oder 0.

In der Tabelle werden die Auswirkung beschrieben, wenn Sie den Wert auf 1 setzen.

Name | Beschreibung
ForceNoSysLock | Aktiviert bei 1 NoSysLock on Lock für 3D-Videomodi mit niedriger Auflösung
DisableNoSysLock | Deaktiviert bei 1 NoSysLock on Lock für 3D-Videomodi mit niedriger Auflösung
DisableMMX

Deaktiviert bei 1 die Verwendung von MMX-Erweiterungen auf unterstützten CPUs, was auf solchen Systemen eine Leistungsverbesserung bewirken kann.

Dabei handelt es sich um alle Intel-CPUs ab dem Pentium MMX und AMD ab K6.
DisableWiderSurfaces | Deaktiviert bei 1 die 3D Wide Surfaces-Unterstützung auf PCI/AGP-Videocontrollern, die dieses Feature unterstützen (3dfx Banshee/Voodoo3/Voodoo4/Voodoo5, NVidia TNT/TNT2/GeForce usw.).
EnablePrintScreen

Aktiviert bei 1 die Verwendung der Druck-Taste (PrintScreen), um den aktuellen Bildschirminhalt in die Zwischenablage zu kopieren.

Der Inhalt kann mit Grafikprogrammen wie z.B. MS Paint abgespeichert werden.
DisableInactivate | Aktiviert bei 1 den Multi-Monitor Debugger für Troubleshooting, wenn eine Grafikkarte mit zwei Monitorausgängen vorhanden ist.
ShowFrameRate | Aktiviert bei 1 die Anzeige der Bildwiederholrate (Frames per second) bei 3D-Anwendungen und Spielen, die dies unterstützen. Die Funktion ist nur bei 3D-Grafikkarten verfügbar und kann in diesem Fall die Framerate leicht vermindern. Weitere Infos unter: http://www.fraps.com
ModeXOnly | Deaktiviert bei 1 die ModeX-Unterstützung für 320,x 200 (EGA). Gerade bei älteren Grafikkarten kann das hilfreich sein, wenn die Inkompatibilitäten in dieser niedrigen Auflösung sich zeigen.
EmulationOnly

Aktiviert bei 1 den Software Emulation Layer (SEL) für eine bessere Stabilität auf Kosten der Leistung. Das wird nur für ältere Grafikkarten benötigt, da neuere AGP-/PCI-Grafikkarten standardmäßig den Hardware Abstraction Layer (HAL) benutzen.

Es wird empfohlen, diese Einstellung zu deaktivieren, um möglichst viel Leistung zu bekommen.
DisableAGPSupport | Deaktiviert bei 1 die AGP-Unterstützung. Das geht nur, wenn diese Funktion durch die Hardware und den Grafiktreiber unterstützt werden.
DisableDP2

Deaktiviert bei 1 die erweiterte DirectX 6/7 3D-Funktionen auf allen PCI-/AGP-3D-Grafikbeschleunigern.

Es wird empfohlen, diese Einstellung aktiviert zu lassen, um bei Direct3D-Anwendungen/-Spielen maximale Leistung zu erhalten.
SoftwareOnly

Deaktiviert bei 1 die Verwendung der Hardware-Beschleunigung auf allen PCI-/AGP-3D-Grafikkarten.

Es wird empfohlen, diese Einstellung zu aktivieren, um optimale Leistung zu erhalten.
ForceRefreshRate | Den Eintrag "ForceRefreshRate" erstellen Sie auch als Datentyp REG_DWORD, geben hier aber die gewünschte Bildwiederholfrequenz ein. Der Eintrag erzwingt die vorgegebene Bildwiederholrate. Beachten Sie, dass die gewählte Frequenz von der Grafikkarte und vom Monitor unterstützt werden muss, sonst laufen Sie Gefahr, diese zu beschädigen!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2552.htm


Den Eintrag 'Bildschirmschoner' aus dem Menü 'Eigenschaften der Anzeige' ausblenden

Mit diesem Wert können Sie den Eintrag "Bildschirmschoner" aus dem Menü "Eigenschaften der Anzeige" ausblenden.

Diese Einstellung verhindert, dass Benutzer mit Hilfe der Systemsteuerung den Bildschirmschoner auf dem Computer konfigurieren, verändern oder einen hinzufügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispScrSavPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Registerkarte "Bildschirmschoner" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1561.htm


Den Eintrag 'Darstellung' aus dem Menü 'Eigenschaften der Anzeige' ausblenden

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", können die Einstellungen für die Bildschirmanzeige verändert werden.

Mit diesem Wert können Sie den Eintrag "Darstellung" aus dem Menü "Eigenschaften der Anzeige" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispAppearancePage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Registerkarten "Darstellung" und "Designs" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1564.htm


Den Eintrag "Desktop" aus dem Menü "Eigenschaften der Anzeige" ausblenden

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", können die Einstellungen für die Bildschirmanzeige verändert werden.

Mit diesem Wert können Sie den Eintrag "Desktop" aus dem Menü "Eigenschaften der Anzeige" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispBackgroundPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Registerkarte "Desktop" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1563.htm


Den Eintrag 'Einstellungen' aus dem Menü 'Eigenschaften der Anzeige' ausblenden

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", können die Einstellungen für die Bildschirmanzeige verändert werden.

Mit diesem Wert können Sie den Eintrag "Einstellungen" aus dem Menü "Eigenschaften der Anzeige" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispSettingsPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Registerkarte "Einstellungen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1562.htm


Den Zugriff auf die Eigenschaften der Anzeige unterbinden

Mit diesem Wert können Sie den Zugriff auf die Eigenschaften der Anzeige unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispCPL" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eigenschaften der Anzeige kann nicht geöffnet werden
gelöscht | Eigenschaften der Anzeige kann geöffnet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Symbol "Anzeige" aus der Systemsteuerung entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1560.htm


Tab für 3DFX-Videokarten Übertaktung (Overclocking) einblenden

Mit diesem Tipp können bei Video-Karten des Typs 3DFX einen zusätzlichen Tabreiter für "Overclocking" einblenden.

Das Verändern der Werte kann aber auch zu Problemen führen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ 3dfx Interactive\ 3dfx Tools\ Installed\ Tools\ {AB040305-8AA1-11D2-8DD1-00104BB5EAD6}

ändern Sie hier den Wert "CompleteRegistration" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Tabreiter Overclocking einblenden
gelöscht | Tabreiter ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2081.htm


Tab für GeForce Übertaktung (Overclocking) einblenden

Mit diesem Tipp können bei den Karten: NVidia GeForce/2/3/4/FX und Quadro/2/3/4/FX einen zusätzlichen Tabreiter "Overclocking" einblenden. Diese Funktion wird von den Treibern "32.xx, 4x.xx" unterstützt.

Das Verändern der Werte GPU bzw. Memory Core-Frequenzen kann zu höheren Leistungen führen. Die höheren Werte können aber auch zu Problemen führen.

Weitere Infos dazu finden Sie unter: http://www.technologyvault.co.uk/geforce/faq.php

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ NVIDIA Corporation\ Global\ NVTweak

ändern Sie hier den Wert "Coolbits" als Datentyp REG_DWORD und setzen den Wert auf:

4294967295 | Tab Einblenden (Overclocking)
gelöscht | Tab ausblenden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2087.htm


Joystick wird nicht erkannt

Wenn der Joystick nicht von Windows automatisch gefunden wird, gehen Sie so vor:

-> "Systemsteuerung" -> "Hardware" und automatische Erkennung abschalten. Nun klicken Sie auf "Weiter" und wählen dann "Audio, Video and Game Controller". Hier wählen Sie "Microsoft" und anschließend die Option "Gameport Joystick".

Nach der Installation wird der Joystick von Windows erkannt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0044.htm


Windows Tasten deaktivieren

Spez. Windows Taste deaktivieren

Wenn Sie die Extra Windows Taste deaktivieren wollen, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoWinKeys" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Windows-X Tasten sind ausgeschaltet
gelöscht | Windows-X Tasten sind aktiv (Standard)

Mit diesem Eintrag werden die Tasten nicht ganz abgeschaltet. Es werden nur die FunktionenWIN-Taste + E (Explorer starten) usw. unterbunden, ein einfacher Druck auf die Taste öffnet aber immer noch das Startmenü.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Windows+X-Abkürzungstasten deaktivieren

Nur Windows NT/2000/XP

Soll die Taste deaktiviert werden, müssen Sie folgenden Registryeintrag verändern

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Keyboard Layout

erstellen Sie hier einen neuen Regwert mit dem Namen "Scancode Map" als Datentyp REG_BINARY. Setzen Sie den Wert auf "00000000000000000300000000005BE000005CE000000000".

Nach einem Neustart sind die Tasten deaktiviert.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Seihe genaue Beschreibung zum ScanCode: Tasten mittels ScanCode umbelegen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0903.htm


Tastenkombinationen

Hier finden Sie eine Übersicht der Windows Tastenkombinationen und deren Funktionen. Mit der Maus kann man recht schnell arbeiten, will man aber auf eine spezielle Funktion zugreifen,ist man meist mit der richtigen Tastenkombination (Tastatur-Shortcut) schneller.

Allgemeine Ordner/Windows- Explorer- Tastenkombinationen für das markierte Objekt:

Taste | Funktion
F2 | Umbenennen
F3 | Suchen
STRG + X STRG + C STRG + V | Ausschneiden, Kopieren, Einfügen
SHIFT + Entf | Sofort löschen, ohne vorher in den Papierkorb abzulegen
ALT + Enter | Eigenschaften
ALT + Doppelklick | Eigenschaften
ALT + Leertaste | Menü des Fensters
STRG + Klick mit der rechten Maustaste | Alternatives Kontextmenü (Öffnen mit)
SHIFT + Doppelklick | Objekt so explorieren, als hätte es einen Befehl "Explore"
STRG + Datei in einen Ordner ziehen | Datei kopieren
STRG + Shift + Datei in einen Ordner ziehen | Verknüpfung erstellen
STRG + ESC dann TAB dann SHIFT + F10 | Taskleisten- Eigenschaften öffnen

Allgemeine Steuerung von Ordnern/Windows-Explorer:

Taste | Funktion
F4 | Kombinationsfenster anzeigen
F5 | Aktualisieren
F6 | Zwischen den Fensterausschnitten im Explorer wechseln
STRG + G | Gehe zu
STRG + Z | Rückgängig
STRG + A | Alles markieren
Shift + Klick auf schließen Symbol | Schließt diesen und alle übergeordneten Ordner
Rücktaste | Übergeordneten Ordner öffnen

Im Windows Explorer:

Taste | Funktion
* (von der Zehnertastatur rechts) | Blendet alles unterhalb der Auswahl ein
+ (von der Zehnertastatur rechts) | Blendet die Auswahl ein
- (von der Zehnertastatur rechts) | Blendet die Auswahl aus
Nach rechts Taste | Blendet die aktuelle Auswahl ein, sofern diese ausgeblendet ist. Andernfalls Wechsel zum ersten untergeordneten Objekt
Nach links Taste | Blendet die aktuelle Auswahl ein, sofern diese ausgeblendet ist. Andernfalls Wechsel zum übergeordneten Objekt
ALT + Nach links Taste | Zurück zum zuletzt geöffneten Ordner (kann auch mehrmals hintereinander gedrückt werden, um zu den weiteren vorher geöffneten Ordnern zu wechseln)
ALT + Nach rechts Taste | Nach dem Wechseln mit Alt+Links kommt man mit Alt+Rechts wieder zur Ausgangsposition zurück
ALT + P | Anzeigen/Ausblenden des Vorschau Fensters (Ab Windows 7)
STRG + TAB oder STRG + Shift + TAB | Im Eigenschaftsfenster wechsel zwischen den Eigenschaftsregisterkarten

In allgemeinen Dialogfeldern für Öffnen/ Speichern:

Taste | Funktion
F4 | Klappt die Dropdown-Liste auf
F5 | Aktualisiert die Ansicht
Rücktaste | Wechselt zum übergeordneten Ordner, wenn das Ansichtsfenster den Fokus besitzt

Allgemeine Befehle:

Taste | Funktion
F1 | Hilfe
F10 | Wechselt in den Menümodus
F11 | Schaltet zwischen Vollbildschirm (Kiosk-Mode) und Normalbild hin und her
Shift + F10 | Kontextmenü für das markierte Objekt
STRG + ESC | Menü "START" aktivieren
STRG + ESC dann ESC | Fokus an die Schaltfläche "Start" übergeben
ALT + TAB | Zwischen laufenden Programmen umschalten
ALT + Enter | Wechseln von Fullscreen DOS Session in Fenster Windows DOS Session
ALT + ESC | Vollbild-Programm zum Symbol verkleinern
ALT + M | Wenn die Taskleiste den Fokus besitzt werde alle Fenster minimiert
STRG + Klick | Wird es beim Öffnen eines Ordners gedrückt, wird ein neues Fenster geöffnet. (sinnvoll wenn die Option "Alle Ordner in demselben Fenster durchsuchen und anzeigen" aktiviert ist)
Druck | Bildschirminhalt in die Zwischenablage
ALT + Druck | Aktuelle Fenster in die Zwischenablage
Shift + Druck | Sofortiger Ausdruck des Bildschirminhaltes
STRG + Shift + ESC | Taskmanager

Die folgenden Tasten aktivieren die Funktion der Eingabehilfen von Windows 95, wenn diese installiert sind:

Taste | Funktion
Shift (5x drücken) | Ein-/Ausschalten der Einrastfunktion
rechte Shifttaste (8 sek. gedrückt halten) | Ein-/Ausschalten der Anschlagverzögerung
NUM drücken (5 sek.) | Ein-/Ausschalten der Anschlagverzögerung
linke ALT + linke Shift + NUM | Ein-/Ausschalten der Tastaturmaus
linke ALT + linke Shift + Druck | Ein-/Ausschalten von Kontrast
STRG + Shift + F9 | Aero Glass Effekt ausschalten (ab Vista)

Anwendungen:

Taste | Funktion
STRG + S | Lautstärkeregler Anzeige umschalten
F7 | Liste der letzten Befehle in der Kommandozeilenoberfläche

Info Siehe dazu auch Tipp: "Die Windows Taste und deren Funktionen (Shortcuts)"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0331.htm


Tastaturkürzel

Tastaturkürzel für Windows Programme

Unter Windows können Sie für beliebige Programme eigene Tastaturkürzel anlegen. So können Sie häufig verwendete Programme schneller starten.

Ein Beispiel:

Gehen Sie im Startmenü auf eine beliebige Programmverknüpfung und klicken Sie mit der rechten Maustaste auf die Verknüpfung. Wählen Sie aus dem Kontextmenü Eigenschaften und gehen Sie auf den Tabreiter "Verknüpfung" -> tragen Sie im Dialogfeld "Tastenkombination" die gewünschten Tasten ein (Tasten drücken z.B.: SHIFT+ALT+H).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0329.htm


Die Windows Taste und deren Funktionen (Shortcuts)

Hier finden Sie eine Übersicht der Tastenkombinationen für die WINDOWS-Taste und deren Funktionen. Im Vergleich zu den normalen Tastaturen, führen die modernen auch spezielle Tasten (WIN), um ein schnelleres Arbeiten zu ermöglichen.

Dabei gehört bei mir die WIN + Pause und WIN + E Taste zu den sehr häufig benutzen Funktion.

In der Tabelle steht WIN für das drücken der extra Windows Taste.

Taste | Funktion
WIN | Startmenü öffnen
WIN + R | Datei ausführen
WIN + M | Alle Fenster minimieren
SHIFT + WIN + M | Minimieren rückgängig machen
WIN + F1 | Hilfe und Supportcenter
WIN + E | Explorer starten
WIN + F | Dateisuche
STRG + WIN + F | Computer suchen
WIN + TAB | Programmwechsel durch Taskleiste
WIN + PAUSE | Systemeigenschaften
WIN + D | Desktop anzeigen. Ähnlich wie WIN-M, nur das hier direkt mit WIN-D die letzte Ansicht wiederhergestellt wird. (erst ab Windows 98)

Ab Windows XP

Die folgenden Funktionen stehen ab Windows XP zu verfügung.

Taste | Funktion
WIN + L | PC sperren
WIN + U | Hilfsprogramm-Manager öffnen
WIN + Q | Benutzer wechseln

Ab Windows 7

Die Tastatur-Shortcuts wurde ab Windows 7 mal wieder erweitert. Hier wurden einige nützliche Funktionen hinzugefügt.

Taste | Funktion
WIN + Pfeiltaste nach oben | Windows Fenster Maximieren
WIN + Pfeiltaste nach unten | Windows Fenster Minimieren
WIN + Pfeiltaste nach links | Windows Fenster links anheften
WIN + Pfeiltaste nach rechts | Windows Fenster rechts anheften
WIN + Shift + Pfeiltaste nach links | Windows Fenster in den linken Monitor verschieben
WIN + Shift + Pfeiltaste nach rechts | Windows Fenster in den rechten Monitor verschieben
WIN + Home | Minimieren aller anderen Windows Fenster (außer dem aktiven)
WIN + T | Wechseln zum nächsten Taskbareintrag
WIN + Shift + T | Wechseln zum vorherigen Taskbareintrag
WIN + (Ziffern 1-9) | Anwendung in den gewünschten Taskbar-Slot (1-9) einfügen
WIN + Leertaste | Alle Fenster werden durchsichtig (Transparent) - Blick auf Desktop
WIN + G | Gadgegts werden in den Vordergrund geholt
WIN + P | Anzeigeeinstellungen
WIN + X | Mobility Center
WIN + + (Plustaste) | Zoom in (Vergrößern)
WIN + - (Minustaste) | Zoom out (Verkleinern)

Info Siehe dazu auch Tipp: "Tastenkombinationen"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://www.microsoft.com/KB/Germany/support/KB/d301/d301583.htm
"Tastenkombinationen für Windows XP"

"Tastenkombinationen für Windows" http://www.microsoft.com/KB/Germany/support/KB/d36/d36182.htm

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0330.htm


Ausführen des Autostart Ordners verhindern

Windows führt bei jedem Start alle Programme aus, die im Autostartordner eingetragen sind.

Ist das einmal nicht erwünscht, müssen Sie nur nach der Anmeldung die SHIFT-Taste so lange gedrückt halten, bis Windows hochgefahren ist. Dadurch werden keine Programme aus dem Autostartordner ausgeführt.

Das funktioniert nur, solage der Tipp "Abbrechen von Startprogrammen (Autostart) über Shifttaste deaktivieren" nicht aktiviert wurde.

Siehe auch "Automatisches Starten von Windows Programmen beim Systemstart".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0605.htm


Viele Ordner schneller schließen

Wenn Sie eingestellt haben, dass für jedes Verzeichnis ein neuer Ordner geöffnet werden soll und Sie sich durch viele Verzeichnisse gehangelt haben, dann sind auf dem Desktop viele Ordner geöffnet.

Sie müssen nun aber nicht jeden Ordner einzeln schließen. Wenn Sie den letzten Ordner mit gedrückter Shifttaste (Umschalttaste) schließen, werden alle übergeordneten Ordner auf einen Schlag geschlossen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0233.htm


Dezimalpunkt statt Komma im Zehnertastaturfeld

Wenn Sie statt eines Kommas lieber einen Dezimalpunkt auf dem Zehnertastaturfeld (rechts an der Tastatur) haben wollen, müssen Sie folgendermaßen vorgehen.

Hier gibt es zwei Möglichkeiten.

1. Möglichkeit:

Durch Einspielen des folgenden Regfiles in die Registry des Windows Clients wird der Dezimalpunkt auf das Komma des Zehnertastaturfeldes gepatcht.

Erstellen Sie eine Datei mit folgendem Inhalt:

=== Hier schneiden ===

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]

"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,34,00,53,00,00,00,00,00

=== Hier schneiden ===

Info Bitte oben aufgeführte Zeilen (grün) in eine Datei mit Endung reg (z.B. Tastaturpatch.reg) kopieren und ausführen. Anschließend Reboot des Rechners durchführen.

Info Weitere Infos zum ScanCode finden Sie hier: Tasten mittels ScanCode umbelegen

Sie können diesen Wert natürlich auch direkt in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

2. Möglichkeit

Sie installieren unter "Systemsteuerung" -> "Ländereinstellungen" unter "Eingabe" ein neues Tastaturlayout. Klicken Sie hier auf "Hinzufügen" und wählen Sie bei:

Eingabegebietsschema: Deutsch (Schweiz)

Tastaturlayout/IME: Deutsch (Schweiz)

aus. Wenn Sie dieses Tastaturlayout zusätzlich installieren, können Sie zwischen den installierten Layouts umschalten, wobei das Standard-Layout für alle Fenster gilt und das andere immer nur für das Fenster, welches bei der Umschaltung gerade aktiv war. Der Nachteil ist, dass dieser Tastaturtreiber einige Unterschiede zum Deutschen-Tastaturtreiber enthält.

Windows 9x/ME

(Siehe: Windows Tastaturpatch)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1090.htm


Desktop oder einzelnes Fenster als Grafik

Die Taste DRUCK auf jeder Tastatur bewirkt, dass der aktuelle Desktop als Bitmap in die Zwischenablage kopiert wird und hierüber wieder in ein Programm eingefügt werden kann.

Viel praktischer ist aber die Kombination ALT-DRUCK. Mit dieser wird nur das aktuell aktive Fenster kopiert und ist daher ideal für Screenshots von speziellen Programmen oder Erläuterungen hierzu.

Weiterhin gibt es ab Windows Vista unter "Start" -> "Programme" -> "Zubehör" das Programm "Snipping Tool". Mit diesem Programm können z.B. auch vom Startmenü usw. einfach ein Screenshot erstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1178.htm


NumLock, CapsLock oder ScrollLock beim Systemstart

Wenn Sie einer dieser Tasten beim Systemstart schon einen bestimmten Zustand mitgeben wollen, können Sie das in der Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.DEFAULT\ Control Panel\ Microsoft Input Devices\ Keyboard

bzw.

HKEY_CURRENT_USER\ Control Panel\ Microsoft Input Devices\ Keyboard

sind die folgenden Zeichenfolgen zu finden. Will man NumLock beim Windows-Start direkt aktivieren, ersetzt man einfach OFF durch ON.

NumLock | REG_SZ | OFF
CapsLock | REG_SZ | OFF
ScrollLock | REG_SZ | OFF

Sollte der Registryzweig "Keyboard" noch nicht vorhanden sein, können Sie ihn über "Bearbeiten" -> "Neu" -> "Schlüssel" anlegen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0458.htm


Windows Tastaturpatch: Wie wird's gemacht?

Das deutsche Tastatur-Layout hat keinen Punkt auf dem Nummernblock und keine echte Capslock-Funktion.

Mit einem Disk-Editor (z.B. von Norton Utilities) oder mit DEBUG können Sie aber ein Tastatur-Layout erstellen, das diese Funktionen unterstützt.

Info Machen Sie eine Sicherheitskopie der Datei KBDGR. KBD (\%WINDIR%\System)!

Das deutsche Tastaturlayout von Windows 95 versteckt sich in der Datei KBDGR. KBD im System-Verzeichnis von Windows. Dieses Layout-File ist nur ca 500 Byte groß, es ist also ziemlich übersichtlich.

Nun aber zu den eigentlichen Änderungen:

Nummernblock: Punkt statt Komma

Es wird an nur einer einzigen Stelle ein Bytewert geändert und zwar in Byte #316. Soll auf dem Nummernblock ein Komma erscheinen, muss hier der Wert 44(Dezimal) bzw. 2c(hex) stehen, will man einen Dezimalpunkt, gibt man hier 46 (dez, 2e hex) ein. Anders als noch bei Windows 3.11 wird in Windows 95 die Funktion GETKEYSTRING nicht mehr im Tastaturlayout unterstützt; eine Anpassung des Tastennamens kann also entfallen.

Caps Lock Funktion:

Microsoft liefert mit Windows 95 ein zweites deutsches Layout, das genau diese Funktionalität hat: es bildet ein ordentliches CapsLock nach. Dieses Layout sollten Sie nun installieren -> "Systemsteuerung" -> "Tastatur" -> "Sprache" -> "Deutsch (EDV)". Dahinter verbirgt sich das File KBDGR1. KBD, das sich vom Normalen KBDGR. KBD in gerade einmal vier Bytes unterscheidet Die ersten beiden Bytes sorgen für die korrekte CapsLock-Umschaltung und haben die Nummern #4 und #28. Im alten CapsLock-Modus (also eher dem ShiftLock-Modus) enthalten Sie die Werte 0 und 72 (48 hex), beim neuen EDV-Modus sind es dagegen 1 und 10 (0a hex).In dem zweiten Bytepaar (#410, 411 (19a, 19b hex)) stehen die Werte für Semikolon und Doppelpunkt (ShiftLock) bzw. Komma und Punkt (CapsLock).

Wenn schon ein Treiber existiert, warum dann noch patchen?

Der EDV-Treiber unterstützt keinen Dezimalpunkt auf dem Nummernblock. Wenn man nun den Punkt eingepatcht hat (in KBDGR. KBD) und dann das EDV-Layout installiert, ist der Punkt-Patch verloren, weil man auf jenen Treiber nicht mehr zugreift, sondern auf KBDGR1. KBD. Also muss man noch einmal patchen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0363.htm


Windows nur über die Tastatur bedienen

Wenn Sie Windows über die Tastatur bedienen wollen, können Sie die Mausfunktion auf die Tastatur legen. Gehen Sie dafür unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Eingabehilfen" hier den Tabreiter "Maus" auswählen. Aktivieren Sie hier "Tastaturmaus aktivieren" und klicken Sie auf den Button "Einstellungen", wo Sie jetzt folgendes Einstellen:

Unter "Zeigergeschwindigkeit" stellen Sie den Schieberegler "Slider" auf:

Höchstgeschwindigkeit: ganz nach rechts (Hoch) auf die 9. Einteilung

Nun kann man, wenn <NumLock> aktiviert ist, die Maus mit den Ziffern 1-9 bedienen und mit STRG+ZIFFER sogar mit höherer Geschwindigkeit. Die <Enter> Taste ist mit dem Doppelklick belegt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0364.htm


Dateien ohne Umweg über den Papierkorb löschen

Wenn Sie eine größere Menge an Dateien löschen wollen, ist der Umweg über den Papierkorb zeitraubend. Halten Sie einfach vor dem Drücken der ENTF-Taste noch zusätzlich die SHIFT-Taste gedrückt (Sie müssen diese Taste so lange gedrückt halten, bis die Message-Box mit der Löschbestätigung erscheint) und schon werden die Dateien ohne den Umweg über den Papierkorb gelöscht, was bei einer großen Anzahl an Dateien auch viel schneller geht.

Info Bedenken Sie aber, dass nun kein Wiederherstellen der Dateien über den Papierkorb mehr möglich ist.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0259.htm


Alle Explorer Instanzen schließen

Um alle Instanzen des Windows-Explorers zu schließen, müssen Sie folgendes machen:

  1. Öffnen Sie als erstes eine DOS-Box, um wieder den Explorer (Shell) starten zu können
  2. Gehen Sie auf "Start" -> "Herunterfahren"
  3. Im Dialog "Windows beenden" klicken Sie bei gedrückter STRG+ALT+Shift Taste auf den Button Abbrechen.

Windows beendet jetzt ohne Nachfrage alle Windows Explorer Instanzen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1650.htm


Immer 'Nein' beim Kopieren und Verschieben

Wenn Sie Dateien über Windows kopieren oder verschieben und in dem neuen Ordner schon einige Datei vorhanden sind, erscheint eine Dialogbox mit der Frage, wie mit der Datei umgegangen werden soll. Hier haben Sie aber immer nur die Buttons "Ja", "Ja, alle", "Nein" und "Abbrechen". Wenn Sie jetzt wollen, dass keine Datei überschrieben wird, müssen Sie immer auf "Nein" drücken und das bei jeder Datei, da es kein "Nein, alle" Button gibt.

Wenn Sie aber beim Drücken auf den "Nein"-Button die Shift-Taste gedrückt halten, entspricht das einem "Nein, alle" und Windows fragt nicht mehr nach. Es werden jetzt nur noch Dateien in den neuen Ordner abgelegt, die nicht vorhanden sind.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1651.htm


Zeichenwiederholungs-Geschwindigkeit konfigurieren

Mit diesem Tipp legen Sie die Zeit zwischen der Wiederholungen eines Zeichens - bei gedrückter Taste - fest.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Keyboard

Finden Sie den Wert "KeyboardSpeed" als Datentyp REG_SZ. Geben Sie die Zeit in Millisekunden zwischen 0 und 31 ein.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2038.htm


Startzeit der Zeichenwiederholung konfigurieren

Legt die Zeit fest, wie lange Windows wartet, bis bei einer gedrückten Taste die Zeichenwiederholung aktiviert wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Keyboard

ändern Sie hier den Wert "KeyboardDelay" als Datentyp REG_SZ und setzen den Wert auf:

0 | 250 ms
1 | 500 ms (Standard)
2 | 750 ms
3 | 1 Sekunde

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2132.htm


3. Maustaste belegen

Die 3. Maustaste können Sie über den Registry-Editor aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services

je nach Maus entweder "BUSMOUSE", "SERMOUSE" oder "i8042PRT"(ist PS/2 Maus) auswählen.

Dort finden Sie unter "Parameters" den Eintrag "NumberOfButtons". Stellen Sie diesen von 2 auf 3 und starten Windows neu.

Einige Maustreiber liefern keine Möglichkeit, die Tasten mit Funktionen belegen zu können. In diesem Fall benötigen Sie dann das Programm CLICKER (siehe Linkliste). Dieses Programm nimmt die Einstellungen in der Registry automatisch vor.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0043.htm


Mauszeiger automatisch auf den Defaultbutton setzen

Durch einen Eintrag in des Registry können Sie einstellen, dass Windows automatisch den Mauszeiger immer auf den Defaultbutton setzt. So etwas kann aber auch je nach Arbeitsweise sehr lästig werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Mouse

den Wert "SnapToDefaultButton" als Datentyp REG_SZ auf 1 setzen.

Ab Windows 2000 können Sie die Funktion auch über -> "Systemsteuerung" -> "Maus" unter dem Register "Bewegung" einstellen (SmartMove)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0705.htm


Schnelle Eigenschaften

Anstatt immer aus dem Kontextmenü einer Datei den Befehl "Eigenschaften" auszuwählen, können Sie auch bei gedrückter ALT-Taste auf die Datei doppelt klicken. Dies führt Sie automatisch in die Einstellung der Eigenschaften.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0300.htm


Scrollgeschwindigkeit bei IntelliMouse einstellen

Die IntelliMouse besitzt ein Mausrad, mit dem Sie Fensterinhalte leicht auf- und abscrollen können. Wie viele Zeilen bei der Benutzung des Mausrades gescrollt werden sollen, können Sie per Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

erstellen Sie hier einen neuen Eintrag mit dem Namen "WheelScrollLines" als Datentyp REG_SZ. Geben Sie hier als Wert die Anzahl der Zeilen ein, die bei Betätigung des Mausrades gescrollt werden sollen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1188.htm


Windows macht beim Starten solange Pause, bis die Maus bewegt wird

Windows macht beim Starten eine Pause bis die Maus bewegt wird

Hier wird beschrieben, wie Sie das Warten beim Startvorgang auf eine Mausbewegung beim Windows 9x Start ausschalten können.

Ändern Sie in der MOUSEDRV.INI den Eintrag:

Timing=Software

in:

Timing=Hardware

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0366.htm


Maustasten im DOS-Fenster (Vollbild-Modus) vertauschen

Windows hat in der Systemsteuerung eine Option für das Vertauschen der Maustasten. Allerdings gilt die Einstellung, die Sie dort vornehmen, nicht für die DOS-Box im Vollbild-Modus. Um auch dort Maustasten zu vertauschen, erstellen Sie in Ihrem Windows-Verzeichnis eine Datei MOUSE.INI mit folgendem Inhalt:

[mouse]

PrimaryButton=3

SecondaryButton=1

Starten Sie anschließend Windows neu.

Info Windows vertauscht Maustasten immer im Verhältnis zu DOS , d.h.: sind in der Systemsteuerung die Maustasten vertauscht, müssen Sie sie zurück auf rechtshändig stellen, sonst hätten Sie jetzt unter Windows eine Rechtshänder-Maus!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0234.htm


Automatisch gefundene PS/2-kompatible Maus entfernen

  1. Den unerwünschten Mausport löschen (-> "Systemsteuerung" -> "System" -> "Gerätemanager" Maus markieren -> "Eigenschaften" -> "Entfernen")
  2. Unter ->"Konfiguration" die "Ausgangskonfiguration" unter einem neuen Namen kopieren (Konfiguration 2)
  3. Windows neu starten. Dabei wird gefragt, welche Konfiguration (Ausgangskonf. oder Konf. 2) gestartet werden soll. Die neue (ohne PS/2 Port) wählen.
  4. In der Systemsteuerung unter -> "Konfiguration" die nicht genutzte "Ausgangskonfiguration" löschen. Dadurch gibt es nur noch eine Konfiguration und diese wird immer automatisch geladen.

Auf diese Weise kann man sowohl den PS/2-Port als auch andere nicht benötigten Komponenten ausblenden und einen IRQ sparen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0042.htm


Anzeigen der Mausspur konfigurieren

Mit diesem Tipp können Sie einstellen, ob eine Mausspur (Pfad) beim Bewegen des Mauszeigers angezeigt werden soll. Zusätzlich können Sie noch festlegen wie lang diese Spur angezeigt werden soll.

Sie finden diese Einstellung in der "Systemsteuerung" -> "Maus" -> Tabreiter "Zeigeroptionen" unter Sichtbarkeit und auch die Einstellung "Mausspur anzeigen". Wenn Sie diese Einstellung aktivieren, können Sie über die Schieberegler noch die Länge der Mausspur einstellen.

Diese Einstellung können Sie auch über die Registry mit den Wert "MouseTrails" verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Control Panel\ Mouse

Erstellen Sie hier einen neuen Wert mit dem Namen "MouseTrails" als Datentyp REG_SZ und setzen den Wert auf:

0 | Es wird keine Mausspur angezeigt (Standard)
1-7 | Es wird eine Mausspur angezeigt. Die Größe des Wertes legt die Länge der Mausspur fest (1 = kurz bis 7 = lang)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2638.htm


Windows ohne grafische Oberfläche (32Bit Power-DOS)

Windows ohne grafische Oberfläche (32Bit DOS )

Sie können die Funktionen von Windows auch dann nutzen, wenn Sie die speicherhungrige grafische Oberfläche nicht laden wollen. Auf SHARE, SMARTDRV, CD-ROM-Treiber und die meisten sonstigen DOS -Treiber und TSRs können Sie ebenfalls verzichten. Es gibt zwei Varianten des 32Bit DOS :

Windows Hardware-Unterstützung, 32Bit-Dateisystem und DOS -Prompt:

Erstellen Sie im Windows-Verzeichnis eine Datei WINSTART.BAT und rufen dort COMMAND.COM auf.

Wenn Sie Windows booten, erscheint zuerst das Windows Logo, aber dann DOS -Prompt. Starten können Sie nur DOS -Programme und nur auf lokalen Laufwerken. Wenn Sie Windows dennoch komplett starten wollen, müssen Sie EXIT eintippen.

Info Auch auf alten Rechnern mit wenig RAM, langsamem Prozessor und kleiner Festplatte können Sie Windows installieren. Dabei sparen Sie konventionellen Speicher, weil die meisten DOS -Treiber nicht geladen werden müssen.

Alle Windows 95-Funktionen, aber keine Windows-Benutzerführung:

Starten Sie den Explorer und kopieren COMMAND.COM nach DOS 32.COM. Klicken Sie DOS 32.COM mit der rechten Maustaste an und wählen Sie ->"Eigenschaften". Wählen Sie "Als Vollbild", "Beim Beenden schließen", geben in der Kommandozeile den Parameter /P ein (...\DOS 32.COM /P) und deaktivieren Sie "Warnung, wenn noch aktiv". evtl. können Sie noch die "Zugriffstasten von Windows" deaktivieren. Als nächstes öffnen Sie die SYSTEM.INI und ersetzen dort den Eintrag "Shell=EXPLORER.EXE" durch "Shell=DOS 32.COM".

Wenn Sie Windows nun booten, erscheint zuerst das Windows 95-Logo und dann der DOS -Prompt wie bei der ersten Variante. Diesmal stehen Ihnen aber wirklich alle Windows 95-Funktionen, einschließlich Netzwerk und Multimedia zur Verfügung. Sie können alle registrierten Programme ohne Pfadangabe starten (z.B. Startentart Winword) und registrierte Dateitypen lassen sich ebenfalls mit der verknüpften Anwendung öffnen (z.B. Startentart Bild.bmp).

Info Viel höhere Geschwindigkeit, mehr freier Speicher (Explorer verbraucht ca 2 MB, DOS -Box höchstens 640 KB). Wenn Sie mit Batch-Dateien arbeiten, können Sie Windows nun viel bequemer bedienen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0208.htm


Verzeichnisse im DOS-Modus alphabetisch sortieren

Mit diesem Tipp wird gezeigt, wie Sie sich die Verzeichnisse im DOS-Modus alphabetisch sortiert ausgeben lassen können.

In die AUTOEXEC.BAT folgendes Eintragen:

SET DIRCMD=/ogn /A /W /P

Ab sofort werden die Verzeichnisse alphabetisch sortiert angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0335.htm


Undelete von unter DOS gelöschten Dateien

Undelete der unter DOS gelöschten Dateien

Ärgerlich ist es, wenn Sie eine Datei unter Windows wiederherstellen wollen, die Sie selbst im Papierkorb vergebens suchen. Unter Windows gibt es normalerweise kein Werkzeug wie undelete zum Wiederherstellen von Dateien.

Files mit herkömmlichen, kurzen Namen lassen sich dagegen noch retten. Der undelete Befehl befindet sich im DOS-Verzeichnis.

Starten Sie das System im "MS-DOS-Modus". Geben Sie an der Eingabeaufforderung dann das Laufwerk für den direkten Datenträgerzugriff frei. Nutzen Sie dazu den LOCK-Befehl:

z.B.: lock c:\test\et

Bestätigen Sie die Sicherheitsabfrage.

Nun können Sie undelete wie gewohnt einsetzen.

Doch Vorsicht: Mit dieser Methode können Sie die Dateistruktur von Windows zerstören.

Am Ende sollte man das Laufwerk mit UNLOCK c:\test\et wieder sichern.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0315.htm


Speicherbereiche ausklammern

Hier wird beschrieben, wie Sie unter Windows 9x bestimmte Speicherbereiche von der Benutzung durch Windows ausschließen können.

Dazu ruft man folgendes auf:

"Systemsteuerung" -> "System" -> "Geräte Manager" -> "Computer" -> "Eigenschaften" -> "Ressourcen reservieren".

Dort können bestimmte Speicherbereiche gesperrt werden (wie früher mit emm386.exe x=d000-d0ff).

Nun können diese Speicherbereiche von DOS -Programmen benutzt werden. Windows benutzt diesen Bereich jetzt nicht mehr.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0307.htm


SETVER.EXE & IFSHLP.SYS nicht laden

Einige Einstellungen, die früher in der CONFIG.SYS definiert werden mussten, werden bei Windows von der IO.SYS automatisch vorgegeben. Sind in der CONFIG.SYS aber entsprechende Einträge vorhanden, werden die Vorgaben überschrieben. Wenn Sie diese Einstellungen nicht laden wollen, tragen Sie in der CONFIG.SYS "DOS =NoAuto" ein.

Da IFSHLP.SYS für den 32-Bit-Zugriff benötigt wird, sollte man es dann in die CONFIG.SYS Eintragen. BUFFERS und FCBS werden jetzt nicht mehr automatisch in die HMA geladen, daher muss das "HIGH" manuell dahinter gesetzt werden.

IO.SYS-Standard:

C:\...\HIMEM.SYS

C:\...\SETVER.EXE

C:\...\IFSHLP.SYS

DOS =HIGH

FILES=30

LASTDRIVE=Z

BUFFERS=30

STACKS=9,256

FCBS=4

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0304.htm


Optimierung des DOS-Speichers

Windows 95/98 und ME k9e5n(n/t9 628 verschiedene Betriebsarten: MSDOS-Modus und GUI. Beide Betriebsarten setzen auf einen DOS-Kern auf. Einige Funktionen in der GUI werden nach wie vor via Interrupt-Aufrufe, statt über moderne 32-Bit-Architekturkomponenten, aufgerufen.

Der DOS-CommandPrompt für MSDOS -Programme kann hingegen auf viele verschiedene Weisen aufgerufen werden:

Beim Windows 95-Start durch das Bootmenü (siehe MSDOS .SYS)

  • Eingabeaufforderung
  • vorherige DOS-Version (Achtung, nicht Windows 950b = OSR2).

In beiden Fällen handelt es sich um ein vollwertiges MSDOS , welches zum Ansteuern von Peripheriegeräten Realmodetreiber und Programme (z.B. beim CDROM MSCDEX.EXE) benötigt.

Die 32-Bit-Treiber stehen nicht zur Verfügung. Es steht damit auch kein 32-Bit-Cache oder VFAT mit langen Dateinamen zur Verfügung. Beschleunigung erfolgt wie bisher durch Programme wie SMARTDRV oder FASTOPEN.

Dieser Modus ist für alle Programme geeignet, die mit der DOS -Eingabeaufforderung der GUI nicht klar kommen. Einige Programme schließt Wind95 vom Start von der GUI aus. Hierfür gibt es bei Windows 95 eine Kompatibilitätsdatenbank (Lw:\WINDOWS\INF\APPS.INF). Bei diesen Programmen wird automatisch der MSDOS-Modus vorgeschlagen.
Auf der Windows 95-CD befindet sich ein Verzeichnis OLDDOS . In diesem Verzeichnis steht das Werkzeug MEMMAKER und sowie andere alte DOS -Befehle zur Verfügung um diesen Modus zu optimieren.

Von der GUI

  1. DOS-Eingabeaufforderung als Fenstersitzung
  2. DOS-Eingabeaufforderung als Vollbild
  3. MSDOS-Modus

Bei den DOS-Eingabeaufforderungen stehen alle 32Bit-Treiber von Windows zur Verfügung. D.h., dass auch ein CDROM über 32Bit-Treiber angesteuert werden kann und auch den CDROM-Cache von Windows verwendet. Aus diesem Grund kann man auf weitere Treiber und Programme in der CONFIG.SYS und AUTOEXEC.BAT weitgehend verzichten.

Bei einer Update-Installation werden nicht alle Treiber (z.B. CDROM-Treiber) automatisch deinstalliert. Hingegen werden weitere speicherfressende Programme (z.B. MODE-Befehle und KEYBOARD.SYS)mit installiert. Diese sind aber in der Regel nicht nötig. Auch Treiber von Drittherstellern, wie z.B.Soundkarten-Treiber sind nicht notwendig.Selbst die Treiber HIMEM.SYS und EMM386.EXEsind nicht nötig, da HIMEM.SYS bereits durch die IO.SYS geladen wird und EMS-Speicher durch einen 32Bit-Treiber simuliert wird. Die Maus wird ebenfalls durch einen 32Bit-Treiber simuliert. Nur die deutsche Tastatur muss über einen Tastaturtreiber für DOS -Programme aktiviert werden.

Anweisungen wie DOS =HIGH, FILES, BUFFERS oder STACKS sind ebenfalls überflüssig. Auch hier erfolgen, z.B. FILES=30, Defaultzuweisungen in der IO.SYS. Diese Defaultzuweisung wird für die jeweilige Komponente deaktiviert, wenn eine entsprechende Zuweisung in der CONFIG.SYS erfolgt. Hier darf dann aber statt FILES auch FILESHIGH verwendet werden oder DEVICEHIGH statt DEVICE. Soll die automatische Zuweisung in der IO.SYS komplett deaktiviert werden, so muss die erste Zeile in der CONFIG.SYS "DOS =NoAuto" lauten.

Im Idealfall steht in der CONFIG.SYS nur die COUNTRY-Zuweisung:

C OUNTRY=049,437,C:\WINDOWS\COMMAND\COUNTRY.SYS

In der Autoexec sollten sich dann nur ein deutscher Tastaturtreiber und ein paar Zuweisungen für Umgebungsvariablen befinden. Einige Umgebungsvariablen werden bereits durch IO.SYS gesetzt. So ist die Umgebungsvariable PATH, TEMP und TMP bereits belegt, kann aber jeder Zeit durch entsprechende Einträge in der AUTOEXEC erweitert oder überschrieben werden:

=== Hier schneiden ===
@echo off
path=%path%;c:\tools
LH KDRIVE -A- -/-
LH S3VBE20 /INSTALL
SET TEMP=C:\TEMP
SET TMP=C:\TEMP
SET DIRCMD=/OGN /A /W /P
SET SOund =C:\PROGRA~1\CREATIVE\CTSND
SET BLASTER=A220 I5 D1 H5 P330 E620 T6
=== Hier schneiden ===

In diesem Beispiel wird die PATH-Variable erweitert und die Variablen TEMP und TMP werden überschrieben. Weitere Variablen werden hinzugefügt.

Wer noch mehr konventionellen Speicher zur Verfügung stellen möchte, verwendet entweder je DOS -Anwendung eine individuelle MSDOS -Konfiguration, die er über die Eigenschaften des DOS -Programms (rechte Maustaste auf EXE-Datei) konfiguriert, oder startet über eine Verknüpfung zum DOS -Programm eine Stapelverarbeitung. In dieser kann dann z.B. der deutsche Tastaturtreiber statt in der AUTOEXEC.BAT aktiviert werden.

Windows 95 im DOS-Modus beenden
Beim Beenden von Windows 95 wird der DOS-MODUS angeboten, der ohne Warmstart zum DOS-Prompt führt. Auch hier stehen keine 32Bit-Treiber mehr zur Verfügung. Dieser DOS-Prompt setzt per Default auf die bestehenden Dateien CONFIG.SYS und AUTOEXEC.BAT beim Windows 95-Start auf und es wird eine Datei DOS START.BAT ausgeführt. Diese Datei wird einmalig bei der Installation von Windows 95 erstellt, kann jedoch jeder Zeit modifiziert werden.

Für diesen Menüpunkt ist eine Verknüpfung MS-DOS -Modus im Windows-Hauptverzeichnis verantwortlich. Diese Verknüpfung hat ebenfalls ein Eigenschaftsmenü, welches verändert werden kann. Auch hier kann der MSDOS-Modus mit einer individuellen CONFIG.SYS und AUTOEXEC.BAT erzwungen werden. Allerdings führt dies dann unwiderruflich zu einem Warmstart statt direkt zum DOS -Prompt.

Was ist also zu tun?

  1. Man muss entscheiden, ob eine Anwendung unter dem MSDOS -Modus laufen soll oder muss, verzichtet dann aber auf erweiterte Fähigkeiten von Windows 95, wie z.B. lange Dateinamen, schneller 32Bit-Dateizugriff oder Multitasking oder verwendet man eben die DOS-Anwendung von der GUI. Manche Peripheriegeräte verlangen nach wie vor noch 16Bit-Treiber. Anwendungen, die auf diese Treiber angewiesen sind, sollte man ggf. durch moderne Anwendungen ersetzen oder sich moderne Treiber besorgen, damit auf die 16Bit-Treiber verzichtet werden kann.
    Die Standardperipheriegeräte (Maus, Festplatte, CDROM) brauchen i.d.R. keinen Realmodetreiber. Gerade bei Festplatten oder CDROMs ist darauf zu achten 32Bit-Treiber zu verwenden, da sonst ggf. Windows 95 im langsamen Kompatibilitätsmodus arbeiten muss. Das führt zu einer Senkung der Verarbeitungsgeschwindigkeit, Erhöhung der Fehleranfälligkeit, schlechtem Multitaskingbetrieb und weniger DOS -Speicher.
  2. Man optimiert den jeweiligen Modus. Entweder werden RealMode-Treiber bei der Verwendung der GUI entfernt oder, wenn man darauf angewiesen ist, verwendet man kleinere Treiber bzw. lädt Sie erst dann, wenn Sie benötigt werden oder ersetzt Sie durch 32Bit-kompatible. Auf jeden Fall sollten diese in den UMB-Speicher per DEVICEHIGH oder LH geladen werden.
    Verwendet man den MSDOS-Modus oder ist auf RealMode-Treiber angewiesen, optimiert man die Ladereihenfolge und die Speicherbelegung mit Programmen wie Memmaker. Als Faustformel gilt hier, dass man zunächst alle großen Treiber und Programme und anschließend kleinere lädt. (z.B. MSCDEX vor SMARTDRIVE, SMARTDRIVE vor dem Tastaturtreiber).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0250.htm


Neuaufbau-Geschwindigkeit des DOS -Fensters einstellen

In diesem Tipp wird beschrieben, wie Sie die Neuaufbau-Geschwindigkeit des DOS-Fensters einstellen können.

In der SYSTEM.INI folgendes Eintragen:

[386Enh]

WindowUpdateTime=1

Der Wert "WindowUpdateTime" gibt die Neuaufbau-Frequenz in Millisekunden an.

Besagt, wie oft das Fenster einer DOS -Box (nicht Vollbild-Modus!) neu aufgebaut werden soll. Allerdings sind ein schneller Rechner und eine fixe Grafikkarte die Grundvoraussetzung dafür.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0236.htm


Mehr konventioneller Speicher im DOS -Fenster

Es ist Grundsätzlich richtig, dass man unter Windows weder Config.sys noch Autoexec.bat braucht und dass alle benötigten Treiber von Windows selbst geladen werden. Trotzdem möchte man in einigen Situationen den freien konventionellen Speicher erhöhen. Dazu muss man folgende Einträge in der Config.sys vornehmen: (Den [Pfad] muss man natürlich richtig setzen, meistens c:\windows)

DOS =HIGH, UMB

DEVICE=[PFAD]\HIMEM.SYS

DEVICE=[PFAD]\EMM386.EXE NOEMS (oder RAM)

Diese Einträge erlauben den Zugriff auf die sogenannten UMBs (oberer Speicherbereich zwischen 640kBund 1 MB). Wenn man im DOS -Fenster Programme in die UMBs hochladen will, stellt man allerdings fest, dass dieser vollständig von VMM32 besetzt ist. Man kann es ändern:

Eintrag in SYSTEM.INI

[386Enh]

LocalLoadHigh=1

Info Dies wird jedoch nicht empfohlen, da es auf vielen System zu ständigen Abstürzen der DOS -Box führt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0154.htm


Globale Variablen setzen (WINSET.EXE)

Wenn Sie unter Windows in der DOS -Box mit SET eine Variable setzen, so gilt diese nur für das aktuelle Fenster.

Mit dem Programm WINSET.EXE können Sie diese Variable global (d.h. für alle spätere DOS -Fenster bis zum Neustart) setzen.

Soll die Variable auch für die aktuelle DOS -Box gelten, muss sie zusätzlich mit dem SET-Befehl gesetzt werden.

Info WINSET.EXE befindet sich auf der Windows-CD-ROM im Verzeichnis \ADMIN\APPTOOLS\ENVVARS

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0101.htm


DOS-Programme unter Windows

Braucht ein DOS-Programm spezielle Einstellungen bzw. Parameter, ist es am zweckmäßigsten, eine Stapelverarbeitungsdatei zu verwenden.

Öffnen Sie einen Texteditor. Geben Sie die Einstellungen ein als würde es sich um "Autoexec.bat" handeln (denken Sie aber daran, die Befehle, die in Ihren Konfigurationsdateien schon stehen, nicht einzugeben). Speichern Sie die Datei im Verzeichnis des DOS -Programms unter <Programmname>.BAT. Starten Sie nun den Explorer klicken Sie mit der rechten Maustaste auf das Programm und dann auf -> "Eigenschaften" -> "Programm". Geben Sie nun unter "Stapelverarbeitungsdatei" den vollständigen Pfad ihrer neu erstellten *.BAT - Datei ein. Klicken Sie auf -> "OK".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0102.htm


DOS -Dateien starten die Windows-Treiber benötigen

Wenn Sie ein DOS-Programm laden wollen, welches auf Windows-Treiber zurückgreift, können Sie es nicht über die AUTOEXEC.BAT aufrufen.

Legen Sie im Windows-Verzeichnis eine Datei namens "WINSTART.BAT" an und tragen dort die Dateien ein, die nach dem Laden der Windows Treiber gestartet werden sollen (z.B. Startentromper).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0098.htm


DOS 6.2 Hilfe und andere DOS 6.2 Programme nachträglich installieren

Bis zur DOS-Version 6.22 gab es die Möglichkeit, durch die Eingabe von HELP am DOS-Prompt einen Überblick über alle DOS-Befehle zu erhalten. Diese Hilfe kann man nachträglich installieren.

Im Verzeichnis Other\OldmsDOS findet man einige DOS 6.2 - Dateien, die der neuen DOS-7.0 Version fehlen. Wenn man nur die Hilfe installieren will, kopiert man die Dateien: HELP.COM, HELP.HLP und QBASIC.EXE in das Verzeichnis C:\WINDOWS\COMMAND

Nun steht die DOS 6.2 Hilfe wieder zur Verfügung.

Möchte man alle alten DOS Programme installieren, z.B. Memmaker oder Tree, führt man am besten die Datei INSTSUPP.BAT aus (Diese Datei finden Sie auf der MS-CD unter Other\OldmsDOS). Diese Batch-Datei nimmt gleichzeitig die benötigten Setver Änderungen vor.

Bei einigen CDs gibt es das Verzeichnis nicht, hier kann man sich die Tools von MS herunterladen (http://support.microsoft.com/default.aspx?scid= KB;el;135315) dort können Sie unter anderem auch die Datei OldDOS .EXE herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0096.htm


Dateien unter DOS schneller löschen und kopieren

Löschen:

Wenn Sie unter DOS alle Dateien eines Verzeichnisses löschen wollen und "del *.*" eingeben, erscheint zuerst immer eine Sicherheitsabfrage, die Sie bestätigen müssen.

Diese Abfrage können Sie unterdrücken, wenn Sie statt "del *.*" "del **" eingeben.

Info Funktioniert nicht unter der alten DOS -Version, so müssen Sie z.B. bei Windows 98 folgendes verwenden:
del *.?* alle Dateien mit Extension
del *. alle Dateien ohne Extension

Kopieren:

Wenn Sie unter DOS alle Dateien eines Verzeichnisses kopieren wollen, brauchen Sie die Dateimaske "*.*" nicht einzugeben. Ein "." (Punkt) erfüllt diesen Zweck genauso. Die Eingabe von z.B.:

COPY. A:

kopiert alle Dateien des aktuellen Verzeichnisses auf Laufwerk A:\

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0097.htm


Computer im MS-DOS -Modus starten

Wenn man Windows beendet und die Option "Computer im MS-DOS -Modus starten" wählt, bestimmt die Datei "MS-DOS -Modus.pif" im Windows-Verzeichnis, was weiter geschieht. Diese Datei wird angelegt, sobald man zum ersten Mal diesen Vorgang durchführt. Da es sich um eine Normale PIF-Datei handelt, sind alle Einträge möglich, die man auch für andere DOS -Programme vornehmen kann. Insbesondere die Einstellungen für den MS-DOS -Modus. Sind wichtig.

Wählt man: "Neue MS-DOS -Konfiguration angeben", wird der Computer neu gestartet.

Wählt man jedoch "Aktuelle MS-DOS -Konfiguration verwenden", wird Windows beendet, der Computer aber nicht neu gestartet. Statt dessen wird nun die Datei "DOS START.BAT" im Windows-Verzeichnis abgearbeitet. In "DOS START.BAT" kann man alle Treiber laden, die für den Betrieb im DOS -Modus nötig sind.

Es gibt aber die Beschränkung, dass keine Treiber mit der Endung *.SYS in einer Batch-Datei geladen werden können (z.B. ein Treiber für CD-ROM).

Das Problem lässt sich mit dem Programm "CTLoad.com" von Creative Labs umgehen. Das Programm (Archiv CTLOAD.EXE) können Sie downloaden von:

http://www.clok.creaf.com/creative/patches/ctload.exe

Um die Treiber für ein (hier Sony) CD-ROM zu laden, benötigt man z.B. folgende Zeilen in DOS START.BAT:

LH [path]ctload.com [path]\SLCD.SYS /D:SONY_000

LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:SONY_000 /L:F /M:5

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0067.htm


Konfiguration des Windows DOS -Modus

Der einfache Weg

von Jeff Asselin und Greg Fahey, übersetzt von Jürgen Vetter

Info Ich muss vorwegnehmen, es handelt sich nicht um eine 1:1 Übersetzung. Die Originaldatei ist in englisch und zahlreich illustriert im Winword-Format. Dabei handelt es sich um ein sogenanntes Windows 95 Registry Techletter. Es wäre schön, wenn jemand hin und wieder bei Microsoft auf den WEB-Seiten oder CompuServe-Seiten gucken könnte und solche Tipps veröffentlicht.

Das Problem:

Windows 95 schlägt oft vor, ein DOS Programm, z.B. ein Spiel, im DOS -Modus laufen zu lassen. Doch das kann ein Problem werden, wenn man weder die Maus noch das CDROM-Laufwerk zur Verfügung hat. Dann ist es oft sehr aufwändig manuell die notwendige AUTOEXEC.BAT und CONFIG.SYS für das jeweilige Programm zu erstellen.

Die Lösung:

SDAM Automatisierung.

Man kann dieses Utility der Windows 95-Registry nutzen, um automatisch die DOS -Session (SDAM) AUTOEXEC.BAT und CONFIG.SYS zu erstellen. Dieses Dokument beschreibt die notwendigen Anpassungen um diese Lösung zu nutzen.

Vor dem Start:

Da die Windows 95-Registry geändert wird, Grundsätzlich vor jeder Änderung ein Backup der Registry machen.

Anm.: Das geht mit dem Emergency Recovery Tool von der Windows 95 CD.

Die Windows 95 Registry besteht aus der SYSTEM.DAT und USER.DAT. Diese Dateien haben die Attribute SYSTEM, HIDDEN, READONLY und befinden sich im Windows-Verzeichnis.

Man muss eine Kopie dieser Dateien an einem sicheren Platz (Disketten, andere Festplatte usw.) durchführen, damit man diese wieder nutzen kann, falls etwas schief geht.

Schritt 1 - Registry Editor starten:

Der Registry Editor befindet sich im Windows-Verzeichnis und heißt: REGEDIT.EXE. Am einfachsten ruft man den Explorer auf und startet den Editor von hier, wenn er nicht sowieso bereits im Startmenü untergebracht wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Schritt 2 - Registry Einträge:

Sobald der Registry-Editor gestartet ist, öffnet man einen Schlüssel (Anm.: Die Registrydatenbank ist hierarchisch angeordnet und man nennt die einzelnen Komponenten Schlüssel = KEY) wie ein Verzeichnis vom Explorer. Wenn man also die linke Maustaste auf einen Schlüssel drückt, erhält man die Einträge zum jeweiligen Schlüssel.

Es gibt drei unterschiedliche Typen von Einträgen:

  • STRING
  • BINÄR
  • DOPPELWÖRTER (hex. oder dez. Darstellung)

Um einen neuen Schlüssel oder einen neuen Eintrag/Wert eines Schlüssels anzulegen, drückt man die rechte Maustaste auf dem Schlüssel, der geändert werden soll. Danach wählt man einen der drei Typen.

Die aktuellen SDAM Einträge:

Die aktuellen Einträge findet man unter :

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options

Info Man kommt dort ganz einfach hin: BEARBEITEN\SUCHEN\MSDOS -Options

Öffnet man den Schlüssel, findet man dort:

(Standard) [Wert nicht gesetzt]

Unter diesem Hauptschlüssel findet man weitere Schlüssel. Die Bezeichnung selber ist nicht wichtig, außer die für den EMS-Schlüssel. Alle anderen Bezeichnungen können editiert werden.

Wenn die SDAM Session gesetzt wird sieht man den Datenwert des Eintrags, nicht die Bezeichnung des Schlüssels.

An dieser Stelle kann man eine beliebige Anzahl an Schlüsseln hinzufügen. Keinesfalls sollte man jedoch einen Schlüssel entfernen. Es ist besser einen Schlüssel zu deaktivieren. Um einen Schlüssel zu deaktivieren, wird einfach der Binärwert "Flags" auf 00 00 00 00 gesetzt.

Beispiel:

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options findenSie folgende weitere Schlüssel:

  • CD-ROM
  • DOS key
  • DOS Settings
  • EMS
  • Himem
  • VESA
    Wenn Sie diesen Eintrag deaktivieren wollen, dann setzen Sie den Wert "FLAGS" auf "00 00 00 00"

CDROM:

Wenn man mit der Maus auf den Schlüssel CD-ROM geht und diesen mit der linken Maustaste anklickt, sieht man folgendes:

Links: CD-ROM

Rechts:

Name | Wert
(Standard) | CD-ROM
Flags | 00 00 00 00
Order | 00 00 00 17
StdOption | 04 00 00 00
TipText | Ermöglicht Programmen von MS-DOS den direkten Zugriff auf CD-ROM-Laufwerke

Doch bei diesem Schlüssel fehlen Einträge, so dass man nicht auf ein CDROM zugreifen kann, wenn man in einer SDAM-Session ist. An dieser Stelle wird dann die SDAM-Automatik demonstriert.

Tabelle der möglichen Einträge für MS-DOS -Options SDAM Schlüssel:

Name | Typ | Data
(Standard) | String | Textbeschreibung, die der Benutzer sieht
AUTOEXEC.BAT | String | Beschreibt, welche AUTOEXEC-Befehle gestartet werden
CONFIG.SYS | String | Beschreibt, welche CONFIG-SYS-Befehle gestartet werden
FLAGS BINÄR

Wichtigster Bestandteil

Es kann vorkommen, dass der Schlüssel einen Doppelwort Dialog zeigt. In diesem Fall: Schlüssel löschen und einen neuen mit BINÄR, FLAGS (wie hier) anlegen.

00 00 00 00 | Der Benutzer sieht den Schlüssel nicht Der Schlüssel wird nicht benutzt
07 00 00 00 | Der Benutzer sieht den Schlüssel nicht Der Schlüssel wird automatisch benutzt
02 00 00 00 | Der Benutzer sieht den Schlüssel Der Schlüssel kann ausgewählt werden
1b 00 00 00 | Der Benutzer sieht den Schlüssel Der Schlüssel wird aber auch als Default selektiert
ORDER | BINÄR | Legt fest, in welcher Reihenfolge in der AUTOEXEC.BAT oder CONFIG.SYS der Schlüssel erscheint. Die meisten Einträge sollten den Schlüssel 00 00 00 12 oder 00 00 00 13, mit Ausnahme von MEMORY MANAGERN, 00 00 00 09 oder 00 00 00 10, haben. Wenn ein Eintrag einen anderen in Abhängigkeit benötigt, muss man dafür selber sorgen.
StdOption | BINÄR | Windows 95 intern
TipText | STRING | Dieser Text wird am unteren Enden des Schirms angezeigt, wenn der Schlüssel ausgewählt wird.

Der wichtigste Einzelschlüssel bei MS-DOS Option ist der EMS-Schlüssel. Dieser Schlüssel sagt Windows ob oder ob nicht EMS386.EXE in der SDAM-Session geladen wird. niemals sollte ein anderer Eintrag, mit Ausnahme des CONFIG.SYS-Eintrags, hier geändert werden.

Man kann weitere Einträge zum EMS-Schlüssel hinzufügen. Möglich bei EMM386 sind RAM oder HIGHSCAN als Parameter.

Ein Problem mit der Defaulteinstellung in Windows 95 für diesen Eintrag ist, dass irgendein DEVICEHIGH oder LOADHIGH-Befehl entfernt wird, wenn EMS nicht aktiviert ist. Das ist soweit ok, wenn man den Standard EMM386 ohne DEVICEHIGH oder LOADHIGH verwendet.

Wenn man jedoch DEVICEHIGH oder LOADHIGH mit anderen Speichermanagern, wie QEMM verwenden will, ist es notwendig, den CONFIG.SYS Eintrag im EMS-Schlüssel zu löschen. Windows 95 nimmt nach wie vor an, EMS ist aktiviert, doch EMM386.EXE wird nicht geladen. Eine komplette Beschreibung dieser Funktionalität findet man am Ende dieses Textes.

Wenn eine SDAM Session mehrere AUTOEXEC.BAT Einträge benötigt, z.B. StartenET Zuweisungen oder Soundkarten Befehle, kann eine BATCH-DATEI mit diesen Befehlen erzeugt werden, die dann via CALL, z.B. C:\...\DATEI.BAT von einem einzelnem AUTOEXEC.BAT Eintrag aufgerufen wird.

Selbstverständlich kann man auch mehrere AUTOEXEC.BAT Schlüssel erzeugen. Doch es ist einfacher, dies nur mit einem Schlüssel zu machen.

Die Batch-Datei kann selbstverständlich irgendwo im System gespeichert werden. Allerdings muss immer der komplette Pfad im Schlüssel angegeben werden.

Wenn mehrere CONFIG.SYS Einträge benötigt werden, hat man nur die Chance auch mehrere Einträge hier zu erzeugen. Die Möglichkeit über eine BATCH-Datei besteht nicht.

Außerdem sollte man bedenken, dass Umgebungsvariablen nicht definiert werden müssen, die sowieso in der Windows Session aktiv sind. Diese werden an die SDAM-Session einfach vererbt.

Beispiel:

Wichtig! Das folgende Beispiel muss an das jeweilige System angepasst werden.

Beispiel 1 - CDROM-Laufwerk aktivieren

Das Geheimnis des CDROM-Supports in einer SDAM-Session ist das Hinzufügen der jeweiligen CONFIG.SYS und AUTOEXEC.BAT Einträge in den MS-DOS Options. Im Beispiel wird ein NEC CDR-84J CDROM Laufwerk an einem Adaptec AIC 6260 SCSI Adapter verwendet. Es werden folgende Einträge benötigt:

AUTOEXEC.BAT:

=== Hier schneiden ===

LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:ASPICD0 /E /M:12

CONFIG.SYS:

DEVICEHIGH=%WINDIR%\EMM386.EXE RAM

DEVICEHIGH=C:\ASW410\ASWCDNEC.SYS /D:ASPICD0 /NORST

=== Hier schneiden ===

außerdem braucht der Hostadapter noch:

CONFIG.SYS:

=== Hier schneiden ===

DEVICEHIGH=C:\ASPI2DOS .SYS /Z /U-

=== Hier schneiden ===

Dies sind die Befehle für den RealMode, der in einer SDAM-Session verwendet wird. Ferner wird in diesem Beispiel der Parameter RAM bei EMM verwendet, um den konventionellen Speicher zu optimieren.

Info Jedes CDROM hat eine andere Konfiguration. Dies ist nur ein Beispiel für das NEC Laufwerk.

Info Am einfachsten findet man die CDROM-Konfiguration für sein System, indem man sich die alte DOS 6.x Konfiguration ansieht.

Nun geht es los!

  • 2 Schlüssel einfügen
  • 1 Schlüssel ändern

SCSI-Adapter-Schlüssel hinzufügen:

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options\ CD-Rom\ legen Sie den Schlüssel "SCSI-Adapter" an und weisen dort folgende Werte zu:

Name | Wert
(Standard) | SCSI-Adapter
CONFIG.SYS | DEVICEHIGH=C:\ASPI2DOS .SYS /Z /U
FLAGS | 02 00 00 00
ORDER | 00 00 00 16
STDOPTION | 04 00 00 00
TipText | Erlaubt CDROM-Zugriff in MSDOS

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options\ CD-Rom\ legen Sie den Schlüssel "REALCD-ROM" an und weisen dort folgende Werte zu:

Name | Wert
(Standard) | Real-CD-ROM
AUTOEXEC.BAT | LH C:\WINDOWS\COMMAND\MSCDEX /D:ASPICD0 /E /M:12
CONFIG.SYS | DEVICEHIGH=C:\ASW410\ASWCDNEC.SYS /D:ASPICD0 /NORST
FLAGS | 02 00 00 00
ORDER | 00 00 00 17
STDOPTION | 04 00 00 00
TipText | MS DOS realmode CDROM Zugriff

EMS-Änderung:

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options\ CD-Rom\ legen Sie den Schlüssel "EMS" an und weisen dort folgende Werte zu:

Name | Wert
CONFIG.SYS | DEVICEHIGH=%WINDIR%\EMM386.EXE RAM

so sieht der Schlüssel nun wie folgt aus:

Name | Wert
(Standard) | Expanded Memory (EMS)
CONFIG.SYS | DEVICEHIGH=%WINDIR%\EMM386.EXE RAM
FLAGS | 1b 00 00 00
ORDER | 00 00 00 11
STDOPTION | 02 00 00 00
TipText | Lädt EMS Treiber für Expanded Memory und UPPER Memory

Beispiel 2 Maustreiber-Unterstützung:

  • 2 Einträge müssen beim Maus-Schlüssel geändert werden.

AUTOEXEC.BAT hinzufügen, FLAG ändern, damit Maus als Default zur Verfügung steht.

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options\ CD-Rom\ legen Sie den Schlüssel "MOUSE" an und weisen dort folgende Werte zu:

Name | Wert
(Standard) | MOUSE
AUTOEXEC.BAT | LH C:\DOS \MOUSE.COM
FLAGS | 1b 00 00 00
ORDER | 00 00 00 12
STDOPTION | 01 00 00 00
TipText | Ermöglicht die MAUS unter MS-DOS

Info Der Pfad und der Programmname kann bei jedem natürlich anders sein (AUTOEXEC.BAT Eintrag).

Beispiel 3 QEMM statt EMM386 nutzen:

Es ist nicht schwer, QEMM statt EMM zu verwenden, doch nach der Änderung in der Registry sollte man QEMM Optimize starten.

Die Schritte:

  1. Löschen des CONFIG.SYS Eintrages im EMS Schlüssel. Das deaktiviert EMM386.EXE, aber man kann noch DEVICEHIGH und / oder LOADHIGH verwenden. Man kann die Flags noch auf 07 00 00 00 ändern, so dass man diesen Eintrag gar nicht sieht.
  2. FLAGS beim HIMEM Schlüssel auf 00 00 00 00 setzen.
  3. QEMM installieren:

Name | Wert
(Standard) | Qemm
CONFIG.SYS | Device=C:\QEMM\QEMM386.SYS RAM
FLAGS | 1b 00 00 00
ORDER | 00 00 00 09
TipText | QEMM Speichermanager wird aktiviert

Beispiel 4 internationales Tastaturlayout verwenden:

Wer nicht das US-Keyboard verwenden will (wer will das schon :-)), geht so vor:

Unter dem Schlüssel: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Options\ CD-Rom\ legen Sie den Schlüssel "KEYBOARD" an und weisen dort folgende Werte zu:

Name | Wert
(Standard) | KEYBOARD TSR
AUTOEXEC.BAT | lh keyb UK,%WIN%\COMMAND \KEYBOARD.SYS
FLAGS | 02 00 00 00
ORDER | 00 00 00 20
TipText | Englische Tastatur aktiviert

Info Wir als deutsche Nutzer tragen natürlich KEYB GR statt KEYB UK ein!

Das Ergebnis der Bemühungen:

Wenn man nun eine Anwendung für die SDAM-Session (MS-DOS -Modus) konfigurieren will, bekommt man weit mehr als bisher zur Auswahl angeboten. Nämlich alle Erweiterungen, die wir vorgenommen haben.

Das Ganze kann nun so aussehen, dass man einfach weitere Kontrollkästchen angeboten bekommt:

X QEMM

X EMS

X MOUSE

_ DISK CACHE

_ MS-DOS Command Line Editor (DOS KEY)

_ Direct Disk Access

_ SCSI-Adapter

_ READCD-ROM

Wenn dann der Hinweis kommt:

Any Data currently entered for CONFIG.SYS and AUTOEXEC.BAT will be replaced by the new configuration you select. DO you want to continue=drückt man einfach auf JA

(Anm.: Habe den Text einmal nicht übersetzt)

Info Ergänzung: Diese Einstellungen kann man ebenfalls mit dem Programm DOS WZCFG.EXE (MS-DOS Mode Wizard Customization) aus den KernelToys von Microsoft vornehmen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0103.htm


Bildschirmausdruck im DOS-Fenster

Problem:

Es soll aus einem DOS-Programm per "Druck"-Taste gedruckt werden. In der Fenstersitzung wird jedoch der Bildschirm in die Zwischenablage kopiert, anstatt dass der Inhalt des DOS-Fensters an den Drucker gesendet wird.

Lösung:

Klicken Sie mit der rechten Maustaste auf das MS-DOS-Programm (z.B. MS-DOS Eingabeaufforderung) und dann auf

-> "Eigenschaften" -> "Sonstiges" und deaktivieren unter "Zugriffstasten von Windows" die Druck-Taste.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0014.htm


Prompt in der DOS-BOX von Windows definieren

Unter DOS wird der PROMPT mit SET PROMPT= definiert.

In der Windows DOS -BOX kann dies auch mit SET WINPMT= definiert werden

Info Siehe dazu auch: Prompt an der Eingabeaufforderung ändern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0622.htm


Einstellungen für die DOS-Umgebung

Auf Systemen, wo nur Windows-Programme ausgeführt werden, können Sie aus Sicherheitsgründen die DOS-Box deaktivieren.

Wenn noch einige DOS-Programme benutzt werden, können Sie auch den direkten Zugriff auf die Hardware unterbinden, dann liegt die Verwaltung der Hardware bei Windows, wodurch es zu weniger Fehlern kommt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WinOldApp

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WinOldApp

Erstellen Sie hier folgende Werte:

Schlüssel | Datentyp | Angabe als | Standard
Bei '1' wird die DOS -Konsole deaktiviert
Disabled | REG_DWORD | Boolean | 0
Bei '1' wird es DOS -Programmen verboten, direkt auf die Hardware zuzugreifen. Weiterhin wird die Option "Im MS-DOS Modus starten" unter "Start" - "Beenden" ausgeblendet.
NoRealMode | REG_DWORD | Boolean | 0

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0818.htm


Kommandozeilenbefehle durch Makros erweitern (9x/ME)

Windows unterstützt "DOS KEY" in der Kommandozeile (DOS -Fenster) standardmäßig nicht. Durch "DOS KEY" wird z.B. in der Kommandozeile die History - Liste der letzen Befehle zur Verfügung gestellt. Diese Funktion ist den meisten Leuten bekannt, weniger bekannt ist aber, dass man sich mit DOS KEY auch eigene Makros erstellen kann, die komplexe Befehlsaufrufe enthalten können.

So können Sie sich z.B. mit der Eingabe von:

DOS KEY ls=dir /on /a /p

einen neuen Befehl mit dem Namen "LS" erzeugen. Wenn Sie jetzt in der Kommandozeilenoberfläche LS eingeben, werden alle Dateien und Unterverzeichnisse, unabhängig von ihren Attributen, des aktuellen Verzeichnisses alphabetisch sortiert angezeigt und nach jeder vollen Bildschirmseite wird die Ausgabe angehalten.

DOS KEY [/Option...] [Makroname=[Text]]

Parameter | Bedeutung | Standard
/APPEDIT | Aktiviert die Kommandozeilenhistorie in DOS -Programmen (z.B. Debug.exe, List.com) | off
/BUFSIZE:Größe | Definiert die Größe des Befehlsspeichers | 512
/ECHO:on|off | Aktiviert/deaktiviert das Echo von Makroerweiterungen | on
/FILE:Datei | Datei mit einer Makroliste | --
/HISTORY | Zeigt alle gespeicherten Befehle an | --
/INSERT | Neu eingegebener Text wird in den vorhandenen eingefügt | siehe /OVERSTRIKE
/KEYSIZE:Größe | Definiert die Größe des Tastaturspeichers | 15
/LINE:Größe | Definiert die max. Größe des Zeilenspeichers | 128
/MACROS | Zeigt alle DOS KEY-Makros an | --
/OVERSTRIKE | Neu eingegebener Text überschreibt vorhandenen | (Standard)
/REINSTALL | Installiert eine neue Kopie von DOS KEY. | --
Makroname | Name für ein zu erstellendes Makro | --
Text | Befehle, die durch das Makro auszuführen sind | --

NACH-OBEN und -UNTEN rufen Befehle ab.

ESC löscht den aktuellen Befehl.

F7 zeigt die gespeicherten Befehle an.

ALT+F7 löscht die gespeicherten Befehle.

[Zeichen]F8 sucht nach einem Befehl, der mit [Zeichen] beginnt.

F9 wählt einen Befehl anhand seiner Nummer aus.

ALT+F10 löscht Makrodefinitionen.

Besondere Zeichenfolgen in Makrodefinitionen mit DOS KEY:

$T | Befehlstrennzeichen: Ermöglicht mehrere Befehle in einem Makro.
$1-$9 | Ersetzbare Parameter: Entspricht %1-%9 in Stapelverarbeitungsdateien.
$* | Symbol für Elemente, die in der Befehlszeile dem Makronamen folgen.

Info Siehe auch: "Kommandozeilenbefehle durch Makros erweitern (NT/2000/XP)".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1209.htm


Richtiger Zeichensatz (Codepages)

In diesen Tipp wird beschrieben, wie Sie den Zeichensatz einstellen können, der von Windows benutzt werden soll.

Einstellungen für Windows 95/98

TrueType-Schriften im DOS-Fenster und in Windows:

Windows 95:

Kopieren Sie das Programm CHANGECP samt Unterverzeichnis SUPPORT aus dem Verzeichnis "\OTHER\CHANGECP" (Windows 95 CD-ROM) ins Windows-Verzeichnis (SUPPORT als Unterverzeichnis von Windows). Starten Sie dann das Programm und wählen Codepage 437.

Windows 98

Kopieren Sie das Programm CHDOS CP samt Unterverzeichnis CODEPAGE aus dem Verzeichnis "\TOOLS\RESKIT\CONFIG\" (Windows 98 CD-ROM) ins Windows-Verzeichnis (SUPPORT als Unterverzeichnis von Windows). Starten Sie dann das Programm und wählen Codepage 437.

Bitmap-Schriften (außer der 8*12-Schrift):

Hierfür wird die Datei CDDOS APP.FON benötigt. Sie wird von Windows normalerweise nicht installiert und muss daher manuell entpackt werden. Wechseln Sie ins Verzeichnis WINDOWS\FONTS und geben an der Eingabeaufforderung folgendes ein:

EXTRACT /a <Laufwerk>\WIN95\WIN95_02.CAB DOS APP.FON.

Ändern Sie anschließend in der SYSTEM.INI die Zeile "woafont=app850.fon" in "woafont=DOS app.fon"

8*12-Bitmap-Schrift:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_CONFIG\ Display\ Settings\ oemfonts.fon

Nun "vga850.fon" in "vgaoem.fon" ändern.

Im DOS-Prompt sollte nun noch die Schrift 8x12 eingestellt sein.

Dieser Eintrag bleibt nur bis zur nächsten Änderung der Bildschirmauflösung erhalten. Für eine dauerhafte Änderung ist zusätzlich unter HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion \fontsize\ 96\System der Schlüssel "vga850.fon" in "vgaoem.fon" umzubenennen.

Deutsches Datumsformat:

Das deutsche Datumsformat für die DOS -Box muss in die CONFIG.SYS eingetragen werden:

COUNTRY=049,437,C:\WINDOWS\COMMAND\COUNTRY.SYS

Windows ME

Wer für ein DOS-Fenster statt der Codepage 850 eine andere benötigt, kann dies über das Tool MSCONFIG (START -> Ausführen -> MSConfig) unter der Registerkarte "International" festlegen (MS-DOS-Codepage).

Einstellungen ab Windows NT

Ab Windows NT (Deutsch) werden in DOS -Programmen Sonderzeichen nicht korrekt angezeigt, da die falsche Codepage eingestellt ist. Um den Fehler zu beheben, bedarf es folgender Änderung in der Registry:

Codepage und Zeichensatz im Fenster:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Nls\ CodePage

Schlüssel | Datentyp | Angabe als | Wert für 850 | Wert für 437
OEMCP | REG_SZ | Codepage als Zahl | 850 | 437
OEMHAL | REG_SZ | Codepage als Zahl (bei 437 hier OEM eintragen) | vga850.fon | vgaOEM.fon

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ wow\ boot

Schlüssel | Datentyp | Angabe als | Wert für 850 | Wert für 437
oemfonts.fon | REG_SZ | Codepage als Zahl (bei 437 hier OEM eintragen) | vga850.fon | vgaOEM.fon

Zeichensatz im Vollbild:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ GRE_Initialize

Schlüssel | Datentyp | Angabe als | Wert für 850 | Wert für 437
OEMFONT.FON | REG_SZ | Codepage als Zahl (bei 437 hier OEM eintragen) | vga850.fon | vgaOEM.fon

Windows 2000 und Windows XP

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ HardwareProfiles\ Current\ Software\ Fonts

Schlüssel | Datentyp | Angabe als | Wert für 850 | Wert für 437
OEMFONT.FON | REG_SZ | Codepage als Zahl (bei 437 hier OEM eintragen) | vga850.fon | vgaOEM.fon

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0013.htm


Versteckte Dateien per DIR anzeigen

Versteckte Dateien werden von Windows in der "Normaleinstellung" unter Ansicht im Explorer ausgeblendet. Hier können diese auf Wunsch jedoch eingeblendet werden. Die Einstellung hier gilt aber nicht für den DOS -Prompt. Selbst bei der Ansicht von versteckten Dateien zeigt Dir brav nur die "Normalen" Dateien. Erst der Befehl DIR /a macht alle Dateien sichtbar.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1110.htm


Einstellungen für alle DOS -Programme

Gerade unter Windows NT ist es nervig, dass NT DOS-Fenster beim Beenden immer sofort schließt. Wenn man jedoch die Eigenschaften der Datei _default.pif bearbeitet (Farbe, Einstellungen etc.), gelten die Änderungen für alle DOS -Programme, sofern keine eigene PIF-Datei für das jeweilige Programm vorhanden ist.

Ist die Datei _default.pif nicht vorhanden, kopiert man eine andere PIF-Datei ins Windows-Verzeichnis und benennt diese um. Hier muss jedoch dann das Feld "Befehlszeile" gelöscht werden!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0900.htm


Kopie von Festplatte auch mit kurzen Dateinamen

Wenn Sie mit XCopy eine komplette Kopie der Festplatte erstellen möchten, geben Sie hierzu normalerweise xcopy c:\*.* d:\ /c /e /h /k /r /s in einem DOS-Fenster ein. Damit wird C:\ komplett nach D:\ kopiert.

Allerdings kopiert XCopy nur die langen Dateinamen. Einige Programme verwenden in der Registry oder in INI-Dateien aber kurze Pfadangaben. Dies hat zur Folge, dass Zuweisungen wie c:\progra~1\micros~2\ u.U. nicht mehr funktionieren, da die kurzen Dateinamen beim Kopieren neu erstellt werden und die Bezeichnung davon abhängig ist, wie die Ordner heißen oder in welcher Reihenfolge XCopy diese kopiert (ist nur ein Ordner mit Microsoft.. vorhanden, wird dieser dann micros~1 benannt und nicht micros~2).

Abhilfe schafft das für den privaten Gebrauch kostenlose XXCopy von http://www.xxcopy.com/, welches ähnlich wie XCopy bedient wird, aber wesentlich mehr Möglichkeiten bietet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0899.htm


Prompt an der Eingabeaufforderung ändern

Wollen Sie das aktuelle Datum oder die aktuelle Uhrzeit in Ihrem Prompt einbinden?

Hier sind die KommanDOS dafür:

Prompt Befehl | Zeichen
$A | &
$B | | (Pipe)
$C | ( Klammer auf
$F | ) Klammer zu
$D | Datum
$E | Escape code (ASCII Kode 27)
$G | > Größer als
$L | < Kleiner als
$H | Backspace
$N | Laufwerk
$P | Laufwerk mit Pfad
$Q | = Ist gleich
$S | Zwischenraum
$T | Uhrzeit
$V | Windows NT Versionsnummer
$_ | Carriage return
$$ | $ Dollarzeichen

Um folgenden Prompt zu erhalten "Fri 09/05/1997 102946.17 Windows NT Version 4.0 C:\>" einfach
"prompt $D$S$T$S$V$_$P$G" an der Eingabeaufforderung eingeben.

Ab Windows 2000

Hier können Sie die Einstellung der Kommandozeile auch in der Registry ablegen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Environment

Erstellen Sie hier einen neuen Wert mit dem Namen "PROMPT" als Datentyp REG_EXPAND_SZ. Geben Sie als Wert den entsprechenden String als Prompt ein (z.B: $p$g). Als Werte sind hier auch die Standardvariablen %COMPUTERNAME% usw, erlaubt.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0651.htm


Wie kopiere ich Dateien mit Leerzeichen im Namen unter DOS ?

Sind in einem Dateinamen oder im Namen eines Ordners Leerzeichen enthalten, müssen Name und /oder Pfad in Anführungszeichen "" gesetzt werden.

COPY "Das ist ein File mit langem Dateinamen.exe" "C:\Pfad mit Leerzeichen\Lang.exe"

Das ist natürlich nur in einem DOS -Fenster unter Windows möglich, da DOS keine langen Dateinamen unterstützt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0348.htm


Schriftart im DOS - Fenster

Wollen Sie die Schriftart im DOS-Fenster ändern, können Sie das über die Registry durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ MS-DOS Emulation\ Font

suchen Sie den Eintrag "Font" und geben als Wert den vollen Namen der gewünschten Schriftart ein. Starten Sie Windows neu.

Info TrueType-Fonts und proportionale Schriftarten sind für DOS -Fenster nicht geeignet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0252.htm


Darstellung eines Verzeichnisfensters von der Eingabeaufforderung aus

Um von der Eingabeaufforderung aus ein Verzeichnisordner im Explorer anzeigen zu lassen, geben Sie "START." oder "START." ein. Daraufhin erscheint auf den Desktop der Explorer welcher sich im Verzeichnisses befindet.

Weiterhin kann man den Explorer noch mit dem Kommando "@explorer" starten. Hier kann man zusätzlich als Parameter auch noch das Laufwerk und den Ordner mitgeben, der angezeigt werden soll.

Beispiel: "@explorer D:\"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0092.htm


Eingabeaufforderung im Ordner öffnen

Wenn Sie im Explorer ein Verzeichnis ausgewählt haben, ist es öfter einmal nötig, an dieser Stelle die Eingabeaufforderung zu öffnen. Durch eine Erweiterung des Kontextmenüs können Sie das sehr einfach erledigen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Directory\ Shell

und

HKEY_CLASSES_ROOT\ Drive\ Shell

erstellen Sie einen neuen Unterschlüssel mit beliebigem Namen, hier z.B. "Eingabeaufforderung".

Als Standardwert tragen Sie das ein, was später im Kontextmenü angezeigt werden soll.

Klicken Sie den neuen Schlüssel an und erstellen Sie wieder einen neuen Unterschlüssel mit dem Namen "Command" (Der Registrypfad sollte nun folgendermaßen aussehen:

HKEY_CLASSES_ROOT\ Directory\ Shell\ Eingabeaufforderung\ Command).

Gehen Sie nun auf den Schlüssel "Command" und klicken Sie auf der rechten Seite den Eintrag "(Standard)" an. Geben Sie hier an, welches Programm ausgeführt werden soll. Da Sie die Eingabeaufforderung öffnen wollen, müssen Sie je nach Betriebssystem folgendes eingeben:

Windows 95/98: command.com /k cd "%1"

NT oder Windows 2000: cmd.exe /k cd "%1"

Wenn Sie jetzt im Explorer mit der rechten Maustaste auf ein Verzeichnis oder ein Laufwerk klicken, haben Sie im Kontextmenü die Auswahlmöglichkeit "Eingabeaufforderung". Ein Klick darauf öffnet dann eine Eingabeaufforderung im entsprechenden Verzeichnis.

Hier drei Beispiele, die Sie nur kopieren und mit einem Texteditor (NOTEPAD) unter einem beliebigen Namen mit der Endung .REG abspeichern müssen. Wenn Sie diese Datei mit rechten Maustaste anklicken und dann "Zusammenführen" wählen, werden die Einträge für Sie automatisch in die Registry eingetragen.

Beispiel für Windows 9x und ME:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\Directory\shell\Command]
@="Eingabeaufforderung (&MS-DOS ) öffnen"

[HKEY_CLASSES_ROOT\Directory\shell\Command\command]
@="command.com /k cd \"%1\""

[HKEY_CLASSES_ROOT\Drive\shell\Command]
@="Eingabeaufforderung (&MS-DOS ) öffnen"

[HKEY_CLASSES_ROOT\Drive\shell\Command\command]
@="command.com /k cd \"%1\""

=== Hier schneiden ===

Beispiel für Windows NT:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\Directory\shell\Command]
@="Eingabeaufforderung (&CMD) öffnen"

[HKEY_CLASSES_ROOT\Directory\shell\Command\command]
@="cmd.exe /k cd \"%1\""

[HKEY_CLASSES_ROOT\Drive\shell\Command]
@="Eingabeaufforderung (&CMD) öffnen"

[HKEY_CLASSES_ROOT\Drive\shell\Command\command]
@="cmd.exe /k cd \"%1\""

=== Hier schneiden ===

Beispiel ab Windows 2000:

=== Hier schneiden ===
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\Command]
@="Command &Prompt"

[HKEY_CLASSES_ROOT\Directory\shell\Command\command]
@="cmd.exe \\\"%1\\\""

--- oder
@="%SYSTEMROOT%\\system32\\cmd /K \"cd %L\""

=== Hier schneiden ===

Wenn Sie die Kommandozeilenhistorie (DOS KEY) in der Eingabeaufforderung verwenden möchten,

verwenden Sie folgenden Standardwert für "command":

@="command.com /k cd \"%1\" | DOS key"

Info Markieren Sie den "grünen" Text und speichern Sie ihn mit der Endung .REG ab. Wichtig ist, dass die Datei mit einer Leerzeile endet.

Info Das &-Zeichen wird nicht angezeigt, sondern kennzeichnet den Kurzbuchstaben!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0785.htm


Bootdiskette mit RAM-Disk

von Thomas Voss

Zwei Probleme hindern Benutzer von Windows 95A mit Plus-Pack, 95B und von 98 mit kleiner RAM-Disk daran, eine brauchbare Bootdiskette mit RAM-Disk offline (d.h. wenn ein Bootimage fehlt -nach provisorischer Installation) zu erstellen.

Über Systemsteuerung - Software - Startdiskette erhält man bei Windows 95 eine veraltete Diskette, die noch mit dem SYS-Befehl überarbeitet werden muss und keine Ramdisk bietet. Bei Windows 98 wäre man an FINDRAMD.EXE mit RAMDRIVE.SYS gebunden. FINDDRV.EXE müsste auf die Platte kopiert werden.

Hier kann mit dem Windows-Programm NOCOMP.EXE über vorhandene Startdatei-Vorlagen eine Startdiskette zusammengestellt werden (eine BOOTDISK.BAT fehlt Windows 95). Ein Punkt in der NOCOMP.INF verhindert die Auswertung der AUTOEXEC-Vorlage, um spätere Fehlfunktionen zu vermeiden. Eine LLD.BAT sorgt für flexibles Setzen der Laufwerksvariablen (z.B. nach dem Partitionieren / für Boot-CD). Die vergleichbare SETRAMD.BAT wäre einzig und allein für FINDRAMD.EXE (fehlt Windows 95) und ein "MS-RAMDRIVE"-Label der RAM-Disk geeignet.

Bei 95B muss das IO.SYS-Update (siehe "Warum verbraucht HIMEM.SYS 40 KB?") erledigt sein. Fast alle Versionen benötigen Jahr-2000-Updates (COMMAND.COM, ggf. FDISK.EXE, XCOPY.EXE, XCOPY32.EXE). Vor dem Beschreiben sollten Disketten auf volle Lesbarkeit überprüft (z.B. per SCANDISK) oder voll formatiert werden.

Die flexible Offline-Lösung für eine Bootdiskette mit Ramdisk, ohne Findramd.exe, ohne Finddrv.exe, falls vorhanden mit XMSDSK.EXE als Ramdisk-Treiber (RAM-Disk größer als 32 MB) könnte so aussehen:

-----AUTOEXEC.BAT-----

@echo off

set dircmd=/a

if %config%!==QUICK! goto FINAL

if not %RAMD%!==! goto ELSE

call lld.bat * * Z Y X W V U T S R Q P O N M L K J I H G F E D C

if %RAMD%!==! goto FINAL

:ELSE

copy /-y A:\command.com %RAMD%:\

set comspec=%RAMD%:\command.com

set temp=%RAMD%:\

set tmp=%RAMD%:\

path %RAMD%:\;A:\

%RAMD%:

...

-----LLD.BAT-----

@echo off

echo Suche Laufwerk...

:BOW

shift

if %2!==! goto NOD

if not exist %2:\NUL goto BOW

set RAMD=%2

set CDROM=%1

goto END

:NOD

echo Beim Systemstart hat sich ein Fehler ergeben. Mit dieser Konfiguration

echo wurde das LETZTE LOKALE LAUFWERK nicht gefunden.

:END

-----NOCOMP.INF-----

[Options]

;Nur in der CONFIG stehen Festplattenpfade.

;Der "autoexec=."-Verweis ist notwendig.

config=CONFIG.001

autoexec=.

[Multipart]

;Alle Dateien ohne Pfad in CONFIG.??? und AUTOEXEC.??? nur mit passenden

;Pfad-Dateien der CONFIG verknüpfen, weil NOCOMP.EXE Zeilen mit Umgebungs-

;variablen u.a. auskommentiert. Das Überarbeiten der Pfade wäre lästiger

;als ein Umbenennen der AUTOEXEC.??? auf Diskette.

;Fremde Pfade immer ab Hauptverzeichnis benennen ( z.B. \EBD95\RAM.CAB).

;Verzeichnisse unterhalb der CONFIG-Pfade (mit Punkt) werden auch auf Diskette

;erstellt ( z.B..\EBD\HELP.BAT).

himem.sys=CONFIG.TXT,MSDOS DRV.TXT,[Dateien im WINDOWS-Verzeichnis]

atapi_cd.sys.1=.\EBD\MSCDEX.EXE,\EBD95\VC.CAB

country.sys=KEYB.COM,KEYBOARD.SYS,[Dateien im WINDOWS\COMMAND-Verzeichnis]

country.sys.1=DOSKEY.COM,\Progra~1\PLUS!\SYSTEM\AUTOEXEC.001

[Ignore]

;Unpassende Treiber und Dateien der Windows-Konfiguration ausschliessen.

drvspace.sys=1

config.sys=1

autoexec.bat=1

drvspace.exe=1

display.sys=1

ega.cpi=1

...

Anmerkungen zur LLD.BAT:

Vor dem Überschreiben einer COMMAND.COM auf der letzten Partition (z.B. bei fehlendem RAM-Disk-Treiber) wird man per "COPY /-Y" gefragt. Weitere Laufwerksvariablen können durch Versetzen des RAM-Disk-Parameters "%2" nach z.B. "%3" benannt werden. Dummy-Parameter "*" müssten hinzugefügt werden. Ein Ladeproblem ergibt sich bei RAM-Disk "Z" und CDROM "*" usw.

Zur NOCOMP-Konfiguration: Vorlagen und Programm sollten im gleichen Verzeichnis stehen. Verschiedene Konfigurationen unterscheidet man zweckmäßigerweise über die Dateiendung. Eine Batchdatei könnte dann die NOCOMP.??? umkopieren, per "START /W" die NOCOMP.EXE laden und die AUTOEXEC.??? auf der Diskette noch umbenennen. Ohne dieses erreicht man fürs erste die Kommandozeile. Dateien im WINDOWS\COMMAND-Verzeichnis sollten immer mit COUNTRY.SYS statt mit KEYB.COM verknüpft werden, weil bei fehlendem CONFIG-Menü die "install=keyb.com"-Zeile wirkungslos bliebe und folglich KEYB.COM über die AUTOEXEC geladen werden müsste. Je nach Platz werden DBLBUFF.SYS, EDIT.COM, EMM386.EXE, IFSHLP.SYS, MEM.EXE und SETVER.EXE unverlangt auf die Diskette kopiert. Ggf. ausschließen.

Für Benutzer von Windows XP gibt es von Microsoft CABARC.EXE. Über eine sortierte Pfadliste (Umbenennungen beim Packen möglich) kann man (entsprechende Lizenz vorausgesetzt) eine "Datensicherung" seiner MSDOS -7-Diskettenkonfiguration machen. Beim Formatieren des Zieldatenträgers kann der passende Bootsektor erstellt werden. Mit EXTRACT.EXE könnten auch Systemdateien mit Attributen entpackt werden und zu einer wirklich kompletten MSDOS -Diskette ohne Bootimage verhelfen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1565.htm


Windows Scripting Host: Sicherheitsfunktion konfigurieren

Ab der Version 5.6 von Windows Scripting Host (WSH) können Dateien signiert werden. Durch diese Signierung wird sichergestellt, dass es sich um keinen Virus handelt. Scripte von Microsoft werden mit dieser Signatur ausgeliefert und somit auch nach der Aktivierung der Sicherheitsüberprüfung ausgeführt. Leider gibt es im Netz auch noch gutartige Scripte, die nicht signiert sind und nach der Aktivierung des Tipps nicht mehr ausgeführt werden.

Sie benötigen für diese Funktion WSH ab Version 5.6.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows Script Host\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "TrustPolicy" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ausführen für alle Scripte erlauben (Standard)
1 | Warnung anzeigen, wenn ein unsigniertes Script gestartet werden soll
2 | Unsignierte Scripte nicht ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2461.htm


Windows Scripting Host: Funktion Aus-/Einschalten (WSH deaktivieren)

Mit diesem Tipp können Sie einstellen, ob Windows Scripting Host (WSH) Dateien von entfernten Rechnern (über das Netzwerk) ausgeführt werden können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows Script Host\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Enable" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ausführen von WSH-Scripten unterbinden
1 | Ausführen von WSH-Scripten zulassen(Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2463.htm


UNIX/Linux Tools für Windows

Wer oft mit der Kommandozeilenoberfläche und Batches arbeitet, wird oft einige, gute Tools vermissen, die es unter Unix/Linux gibt.

Hier gibt es sehr gute Freeware Produkte, die viele Tools auf Windows umsetzen.

  • http://unxutils.sourceforge.NET
    Hier finden Sie eine umfangreiche Sammlung von Tools welche unter den Namen „GNU Utilities for Win32“ zu bekommen sind. Der Vorteile dieser Tools ist, das es eigenständige EXE-Dateien sind die ohne weitere DLL laufen und so gut in Login-Scripts verwendet werden können.
  • Unter http://www.cygwin.com
    finden Sie dann noch eine bekanntere Freeware Alternative die UNIX noch viel besser in einer extra Shell simuliert. Der Nachteil hier ist halt nur, das diese Tools nicht so direkt ohne DLL unter Windows benutzt werden können.
  • Unter http://gnuwin32.sourceforge.NET/packages/textutils.htm
    Auch hier finden Sie eine sehr aktuelle Toolsammlung

Wie man sieht, gibt es auch für Windows schon genug Alternativen, die etliche Lücken von Windows in das Batch Programmierung schließen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1488.htm


Allgemeine Informationen zu Kommandozeilenbefehlen

Hier finden Sie jetzt eine Vorstellung der Kommandozeilenbefehle von Windows. Ab Windows XP gibt es in Windows eine ausführliche Beschreibung aller Befehle. Um diese Hilfe der Befehlszeile schnell aufrufen zu können, erstellen Sie eine Verknüpfung:

"Neu" -> "Verknüpfung" -> Geben Sie jetzt bei "Speicherort des Elements" folgenden Pfad ein:

%windir%\hh.exe ms-its:%windir%\Help\ntcmds.chm::/ntcmds.htm

Als Name für Die Verknüpfunge geben Sie einen beliebigen Text ein z.B. Kommandozeilenbefehle. Sie können den Befehl (grün unterlegt) natürlich auch über "Start" -> "Ausführen" eingeben und damit die Hilfe öffnen.

Tools, aus dem Resource Kit, die nicht bei Windows enthalten sind, werden extra gekennzeichnet.

Was ist das Resource Kit?

Das Resource Kit ist eine Zusammenstellung von einigen nützlichen Tools von MS.

Wo bekomme ich das Resource Kit her?

Das Resource Kit können Sie bei MS kaufen. So ist das Resource Kit z.B. in der Technischen Referenz von MS enthalten:

Einige Tools aus dem Resource Kit können Sie hier kostenlos herunterladen:

ftp://ftp.microsoft.com/ResKit/win2000/

Eine Beschreibung aller Tools in Englisch finden Sie unter:

Windows 2000 Server Resource Kit Tools

http://www.microsoft.com/windows2000/library/resources/reskit/rktour/server/S_tools.asp

Info Aus Zeitgründen wird auch das etwas dauern. Wer Lust hat und eines der Tools selber benutzt, kann mir gern eine Beschreibung zusenden, die ich dann hier aufnehmen werde.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0850.htm


Parameter von MSCDEX

Der DOS Treiber MSCDEX.EXE, welcher sich normalerweise im Command Ordner von Windows befindet, lässt sich mit Parametern modifizieren. Zunächst muss der Treiber wie folgt in der CONFIG.SYS eingebunden werden:

DEVICE=c:\PFAD\TREIBER /D:MSCD000

Info Man kann den OAKCDROM.SYS der Windows 98 Bootdiskette verwenden, welchen man auf die Festplatte kopiert.

Autoexec.bat:

%WINDIR% \Command\MSCDEX.EXE /D:MSCD000

Wichtig ist der /D:XXX Befehl, da dieser die Kennung des CDROMs beinhaltet.

Dieser muss mit dem der Config.sys übereinstimmen.

Folgende Parameter stehen zur Verfügung:

MSCDEX.EXE: /D:x /M:n /E /V /L:x

/D:X | nennt die Kennung der Angabe aus der Config.sys (siehe oben)
/M:n | bestimmt die Anzahl der Sektoren Buffer, wobei ein Minimum von 4 eingetragen werden sollte, besser ist 16
/E | bestimmt die Nutzung des erweiterten Speichers, falls dieser eingerichtet wurde.
/V | bringt eine Statusmeldung beim Laden des Treibers
/L:x | bestimmt den zu benutzenden Laufwerksbuchstaben (geht nicht unter Windows 95/98, da Windows diesen selber verwaltet)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0792.htm


Parameter von Excel

Beim Starten von Excel können Sie folgende Parameter mit angeben. Dafür starten Sie Excel über die Kommandozeile oder erstellen auf den Desktop eine Verknüpfung zur Excel-Datei (liegt meist unter: C:\Programme\Microsoft Office\Office[Versionsnummer]\excel.exe"). Anschließend können Sie die Parameter bei der Verknüpfung mit angeben.

/e | Startet Excel ohne Startlogo und öffnet keine neue Datei
/p <Pfadangabe> | Legt diesen Ordner als Arbeitsordner fest, egal was unter EXCEL zur Zeit als Arbeitsordner eingestellt ist
/r <Pfad\Dateiname> | Datei wird Schreibgeschützt geöffnet
/automation | Excel wird ohne ADD-INS gestartet
/i | Excel wird im Vollbildmodus gestartet
/m | Excel startet im Makromodus
/o | Schreibt fehlende Einträge in der Registry neu: HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Excel
/s | Excel wird im abgesicherten Modus (SAFE Mode) gestartet
/regserver | Schreibt alle Registry-Schlüssel neu
/unregserver | Löscht alle Registry-Schlüssel
<Pfad\Dateiname> | Es wird die angegebene Datei bei Starten geöffnet

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0566.htm


Parameter von Word

Beim Starten von Word können Sie folgende Parameter mit angeben:

<Dateiname> | Datei, die von Word geladen werden soll (durch Leerzeichen getrennt, können auch mehrere Dateien angegeben werden)
/A | Startet Word mit Standardeinstellungen
/L<Add-in> | Startet Word mit Add-ins
/M | Startet Word ohne Autoexec-Makro
/M>Befehl> | Startet Word mit Word-Befehlen oder einem bestimmten Makro
/N | Startet Word ohne ein leeres Dokument zu öffnen
/R | Word wird neu in der Registry eingetragen (nur Word 97/2000/2003)
/T<Vorlage> | Startet Word mit Vorlagendatei
/U | Löscht die Registrierung (nur Word 97/2000/2003)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0456.htm


Parameter des Lautstärkereglers

Auch den Lautstärkeregler können Sie mit einigen Parametern starten. Rufen Sie dafür den LautstärkereglerSNDVOL32.EXE mit folgenden Parametern auf:

/s | öffnet den Lautstärkeregler in einem kleineren Fenster
/t | öffnet nur die Lautstärkeeinstellung ohne die anderen Funktionen
/r | öffnet direkt die Regler für die Aufnahme (Windows 98 und 2000)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0790.htm


FORMAT.EXE, die Parameter

Wenn Sie Informationen löschen wollen, bietet der FORMAT-Befehl eine der schnellsten und effektivsten Möglichkeiten dafür.

Info Bedenken Sie aber, dass mit den entsprechenden Utilities sich die Daten wieder rekonstruieren lassen.

dokumentierte Parameter:

/V[:Bezeichnung] | Zuzuweisende Datenträgerbezeichnung.
/Q | Führt die Formatierung mit QuickFormat durch.
/F:Größe | Speicherkapazität der zu formatierenden Diskette (mögliche Werte sind 160, 180, 320, 360, 720, 1.2, 1.44 und 2.88).
/B | Reserviert Platz für Systemdateien auf dem formatierten Datenträger.
/S | Kopiert Systemdateien auf den formatierten Datenträger.
/T:Spuren | Formatiert jede Seite mit der angegebenen Anzahl von Spuren.
/N:Sektoren | Formatiert jede Spur mit der angegebenen Anzahl von Sektoren.
/1 | Formatiert nur die erste Seite einer Diskette.
/4 | Formatiert eine 360 KB-Diskette (13,34 cm, entspricht 5,25 Zoll) in einem Laufwerk mit hoher Speicherkapazität.
/8 | Formatiert jede Spur mit acht Sektoren.
/C | 9x/ME: Prüft als fehlerhaft gekennzeichnete Zuordnungseinheiten. NT/2000/XP: Auf NTFS Laufwerken wird das komprimieren aktiviert
/FS:<Dateisystem> | Ab NT: Gibt den TYP an zum Formatieren (FAT, FAT32 oder NTFS).
/X | Ab NT: Hebt das Bereitstellen des Volumens auf.
/A:Größe | Ab NT: Gibt die Größe der Zuordnungseinheiten mit.

undokumentierte Parameter:

/autotest | Formatiert ohne sämtliche Abfragen mit der Standardkapazität des Laufwerks.
/backup | Formatiert mit der Standardkapazität des Laufwerks, fragt dabei nur nach der Datenträgerbezeichnung.
/select | Zerstört den Bootsektor und die Dateizuordnungstabelle (FAT) einer Diskette.
/u | Mit diesem Parameter werden die Datenbereiche auf dem Datenträger überschrieben und nicht lediglich die FAT-Einträge.
/Z:n | Ab Windows 95 OEM2 (Windows 95B-Version) und ME: Formatiert ein Laufwerk mit einer Clustergröße von n einmal 512 Bytes (n ist Anzahl der Sektoren pro Cluster). Damit können Sie die Größe der Zuordnungseinheiten frei bestimmen und je größer die Cluster um so besser ist meist die Performance
/Force | keine Abfrage mehr (nur NT)
/autotest | keine Abfrage mehr (Windows 95)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0131.htm


Undokumentierte Parameter von FDISK

Hier werden die Parameter des Befehls FDISK aufgeführt und entsprechend beschrieben.

fdisk L /pri:ps /ext:es /log:ls

L | physische Laufwerksnummer (1 entspricht dann der 1 Festplatte)
/pri:ps | legt primäre Partition von ps MByte Größe an.
/ext:es | legt erweiterte Partition von es MByte Größe an
/log:ls | legt logisches Laufwerk in der erweiterten Partition von ls MByte Größe an. Achtung: pro Aufruf ist nur eine /log möglich. Für mehrere logische Laufwerke muss fdisk x /log:ls daher mehrfach aufgerufen werden.
/prio: | legt eine 16-Bit primäre Partition an (erst ab Windows 98)
/logo: | legt eine 16-Bit logisches Laufwerk an (erst ab Windows 98)
/Status | Information über die Partitionen
/Q | kein Neustart nach beenden von FDISK
/X | LBA Partitionen nicht ändern
/ACTOK | Überprüfung der TOC ausschalten
/MBR | Master Boot Record der ersten Festplatte neu schreiben
/CMBR <disk> | Master Boot Record für angegebene Festplatte neu schreiben
/fprmt | Benutzt FAT32 auch bei Partitionen kleiner als 512 Megabyte (ab Windows 95b-Version)

Info Die Parameter PRI und EXT überschreiben keine vorhandenen Partitionen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0336.htm


Scandisk Info

Stellt Scandisk beim Check der Platte einen Fehler fest, bietet das Programm die Möglichkeit, diese zu kontrollieren.

Dokumentierte Parameter:

/p | Scandisk unterlässt alle Reparaturen
/n | lässt SC direkt starten
/a | berücksichtigt alle lokalen Festplatten

undokumentierte Parameter:

/f | (/fragment) mit Dateiangabe, zeigt den Fragmentierungsgrad der angegebenen Datei
/s | (/silent) schaltet abschließende Zusammenfassung aus
/o | (/oldfs = old file system) checkt automatisch alle Festplatten und löscht dabei radikal alle langen Dateinamen
/t | (/time) vermutlich wie SKANDISK.INI - Einstellung "ScanTimeOut=ON" - berücksichtigt bei der Oberflächenanalyse hardwarebedingte Aussetzer der Festplatte

ErrorLevel:

1: | wenn ein Fehler vorlag
252: | wenn nicht alle vorhandenen Fehler korrigiert werden konnten
255: | wenn SC wegen Laufzeitfehler abbrechen musste

Scan und o.dat wieder zurückschreiben:

Stellt Scandisk beim Check der Platte einen Fehler fest, bietet Scandisk die Möglichkeit, Veränderungen vorher zu speichern, um diese ggf. rückgängig zu machen. Scandisk erstellt dann eine Scanundo.dat auf einem Laufwerk nach Wahl.

Diese Datei kann, sollte etwas schiefgehen, wieder zurückgespielt werden, indem man im DOS (Booten F8, nur Eingabeaufforderung) oder "Windows Beenden-Im MS-DOS Modus starten" den Befehl

scandisk /und o PFAD:

eingibt. Pfad gibt das Laufwerk (z.B. A:) an, auf dem sich die Scanundo .dat befindet.

Batch:

SC prüft alle lokalen Platten vollautomatisch und ohne jede Abfrage; im Falle eines Fehlers wird das Log angezeigt.

start /w scandisk /s /n /a

if errorlevel 1 edit c:\scandisk.log

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0296.htm


ScanDisk und Defrag automatisch starten/beenden

Hier finden Sie Parameter und Informationen über Scandisk und Defrag.

Programm Scandisk

  • Starten Sie ScanDisk
  • Stellen Sie den Modus auf "Standard" ("Intensiv" ist sehr zeitaufwendig)
  • Klicken Sie auf "Erweitert", wählen Sie "Zusammenfassung nur bei Fehler zeigen" und bestätigen mit "OK"Schließen Sie ScanDisk
  • Klicken Sie mit der rechten Maustaste auf das ScanDisk-Icon (WINDOWS\SCANDSKW) und dann auf "Verknüpfung erstellen"
  • Klicken Sie mit der rechten Maustaste auf die eben erstellte Verknüpfung und wählen "Eigenschaften" -> "Verknüpfung"
  • Im Dialogfeld "Ziel" tragen Sie hinter SCANDSKW.EXE die Laufwerke und den Parameter " /N" ein (z.B. C:\WINDOWS\SCANDSKW.EXE C: D: E: /N)
  • Fertig.

Die Verknüpfung mit ScanDisk kann man jetzt im Ordner "Autostart" platzieren. Dann werden bei jedem Windows-Start die Laufwerke automatisch überprüft und eine Benachrichtigung erfolgt nur bei Fehlern.

Info Siehe auch: "Scandisk Info"

Programm Defrag

  • Bei Defrag nur die Punkte 5-6 ausführen
  • Die Parameter bei Defrag sind: DEFRAG (Laufwerk: /all) (/F/U/Q/P) (/noprompt) (/concise) (/detailed).

Parameter:

Laufwerk | Laufwerksbuchstabe
/all | optimiert alle lokalen, nicht austauschbaren Festplatten-Laufwerke
/F | defragmentiert Dateien und freien Speicherplatz
/U | fasst Dateien zusammen, Leerraum bleibt fragmentiert
/Q | defragmentiert nur Leerraum
/concise | gibt Ergebnisse ohne Details aus
/detailed | gibt Ergebnisse detailliert aus
/noprompt | Programm wartet nicht auf Bestätigung des Benutzers
/P | Dieser sorgt dafür, dass alle Dateien (außer der Swap) defragmentiert werden, also auch die Dateien mit System oder Hidden Attribut
/sageset:[Wert] | Speichert die Einstellungen in der Registry unter dem Schlüsselnamen [Wert] (möglich von 0-9)
/sagerun:[Wert] | Lädt die Einstellungen aus der Registry von Schlüsselname [Wert] (möglich von 0-9)

Soll das Programm automatisch ausgeführt werden, muss es mit dem Parameter "/noprompt" aufgerufen werden (z.B. C:\WINDOWS\DEFRAG.EXE /all /F /noprompt).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0298.htm


Funktionen/Befehle der Dateien Rundll.EXE und Rundll32.EXE

Das Programm rundll32 / rundll32.exe ist ein Programm, welches DLL-Dateien ausführen kann. Dadurch lassen sich über Rundll32.EXE bzw. Rundll.EXE einige Befehle direkt ausführen. Dabei wird die Datei folgendermaßen aufgerufen:

Rundll32 <dll>,<funktion> [<argumente>].

Dadurch lassen sich über die Rundll32 viele Windows Funktionen direkt aufrufen und können auch in Batch-Dateien und auf der Kommandozeile benutzt werden.

In der nachfolgenden Tabelle finden Sie eine Auflistung möglicher Aufrufe. Der Aufruf erfolgt dann über "Rundll32 [Befehl]" bzw. "Rundll [Befehl]", dabei sind die Groß und Kleinschreibung des Befehls genau zu beachten ( z.B.: Rundll32 shell32.dll,Control_RunDLL hotplug.dll).

Rundll32

Befehl | Beschreibung | Betriebssystem
advpack.dll,LaunchINFSection <INF-Datei>,<Section> | Installation aus INF-Files | Alle
appwiz.cpl,NewLinkHere <Verzeichnis> | Neue Verknüpfung anlegen | Alle
desk.cpl,InstallScreenSaver <saver.scr> | Screensaver installieren | Alle
diskcopy.dll,DiskCopyRunDLL <0 oder 1> | Ruft Diskcopy auf | Windows 9x und ME
keymgr.dll,KRShowKeyMgr | Dialog "Gespeicherte Benutzernamen und Kennwörter" | Ab XP
Krnl386.exe,exitkernel | Windows ohne Nachfrage beenden | Windows 9x und ME
maserv.dll,CallerAccess | DFÜ-Server aufrufen | Windows 9x und ME
Msprint2.dll,RunDLL_PrintTestPage | Testdruck auf einen Drucker ausgeben | Windows 9x und ME
rnaui.dll,RnaDial <Provider> | DFÜ Verbindung herstellen | Windows 9x und ME
rnaui.dll,RnaWizard | DFÜ-Netzwerk starten | Windows 9x und ME
Rnaserv,CallerAccess | DFÜ-Server | Windows 9x und ME
setupapi.dll,InstallHinfSection 132 <.inf-Datei> | Installation aus einer INF-Datei | Ab Windows NT
Shell,shellexecute | Explorer öffnen | Windows 9x und ME
Shell32.dll,Control_RunDLL | Systemsteuerung | Alle
shell32.dll,Control_FillCache_RunDLL | Systemsteuerungs-Applets neu einlesen | Alle
Shell32.dll,Control_RunDLL main.cpl,@<Zahl> | Einstellung "Einstellung" aufrufen 0 Maus 1 Tastatur 2 Drucker 3 Schriftarten 4 Energie | Alle
shell32.dll,Control_RunDLL access.cpl,,1 | Eingabehilfen (Tastatur) | Alle
shell32.dll,Control_RunDLL access.cpl,,2 | Eingabehilfen (Sound ) | Alle
shell32.dll,Control_RunDLL access.cpl,,3 | Eingabehilfen (Anzeige) | Alle
shell32.dll,Control_RunDLL access.cpl,,4 | Eingabehilfen (Maus) | Alle
shell32.dll,Control_RunDLL access.cpl,,5 | Eingabehilfen (Allgemein) | Alle
shell32.dll,Control_RunDLL appwiz.cpl,,1 | Software (Neue Programme hinzufügen) | Alle
shell32.dll,Control_RunDLL appwiz.cpl,,2 | Software (Windows Assistenten für Windows Komponenten) | Alle
shell32.dll,Control_RunDLL appwiz.cpl,,0 | Software (Entfernen/Hinzufügen neuer Programme) | Alle
Shell32.dll,Control_RunDLL desk.cpl | Einstellung "Anzeigeeinstellungen" aufrufen | Alle
shell32.dll,Control_RunDLL desk.cpl,,0 | Eigenschaften von Anzeige (Hintergrund ) Ab Vista: Desktop-Symboleinstellungen | Alle
shell32.dll,Control_RunDLL desk.cpl,,1 | Eigenschaften von Anzeige (Bildschirmschoner-Einstellungen) | Alle
shell32.dll,Control_RunDLL desk.cpl,,2 | Eigenschaften von Anzeige (Darstellung) | Alle
shell32.dll,Control_RunDLL intl.cpl,,0 | Ländereinstellungen (Allgemein) Ab Vista: Regions-und Sprachoptionen - Tabreiter: Formate | Alle
shell32.dll,Control_RunDLL intl.cpl,,1 | Ländereinstellung (Zahlen) Ab Vista: Regions-und Sprachoptionen - Tabreiter: Standort | Alle
shell32.dll,Control_RunDLL intl.cpl,,2 | Ländereinstellung (Währung) Ab Vista: Regions-und Sprachoptionen - Tabreiter: Tastaturen und Sprachen | Alle
shell32.dll,Control_RunDLL intl.cpl,,3 | Ländereinstellung (Uhrzeit) Ab Vista: Regions-und Sprachoptionen - Tabreiter: Verwaltung | Alle
shell32.dll,Control_RunDLL intl.cpl,,4 | Ländereinstellung (Datum) | Alle
shell32.dll,Control_RunDLL intl.cpl,,5 | Ländereinstellung (Eingabe) | Alle
shell32.dll,Control_RunDLL joy.cpl,,0 | Gamecontroller (Allgemein) | Alle
shell32.dll,Control_RunDLL joy.cpl,,1 | Gamecontroller (Erweitert) | Alle
shell32.dll,Control_RunDLL main.cpl @0 | Eigenschaften von Maus - Tabreiter: Tasten | Alle
shell32.dll,Control_RunDLL main.cpl @1 | Eigenschaften von Tastatur - Tabreiter: Geschwindigkeit | Alle
shell32.dll,Control_RunDLL mlcfg32.cpl | Mail und FAX | Windows 9x und ME
shell32.dll,Control_RunDLL mmsys.cpl,,0 | Eigenschaften von Sounds und Multimedia (Sounds) Ab Vista: Sound - Tabreiter: Wiedergabe | Alle
shell32.dll,Control_RunDLL mmsys.cpl,,1 | Eigenschaften von Sounds und Multimedia (Audio) Ab Vista: Sound - Tabreiter: Aufnahme | Alle
shell32.dll,Control_RunDLL mmsys.cpl,,2 | Eigenschaften von Sounds und Multimedia (Hardware) Ab Vista: Sound - Tabreiter: Sounds | Alle
shell32.dll,Control_RunDLL modem.cpl | Telefon- und Modemoptionen (Modems) | Alle
shell32.dll,Control_RunDLL netcpl.cpl | Netzwerkeinstellungen | Windows 9x und ME
shell32.dll,Control_RunDLL password.cpl | Passwort-Einstellungen | Windows 9x und ME
shell32.dll,Control_RunDLL sysdm.cpl,,0 | Systemeigenschaften (Allgemein) | bis Windows 2003
shell32.dll,Control_RunDLL sysdm.cpl,,1 | Systemeigenschaften - Tabreiter: Computername | Alle
shell32.dll,Control_RunDLL sysdm.cpl,,2 | Systemeigenschaften - Tabreiter: Hardware | Alle
shell32.dll,Control_RunDLL sysdm.cpl,,3 | Systemeigenschaften (Benutzerprofile) Ab Vista: Systemeigenschaften - Tabreiter: Erweitert | Alle
shell32.dll,Control_RunDLL sysdm.cpl,,4 | Systemeigenschaften (Erweitert) Ab Vista: Systemeigenschaften - Tabreiter: Computerschutz | Alle
shell32.dll,Control_RunDLL timedate.cpl,,0 | Eigenschaften von Datum/Uhrzeit - Tabreiter: Datum und Uhrzeit | Alle
shell32.dll,Control_RunDLL timedate.cpl,,1 | Eigenschaften von Datum/Uhrzeit (Zeitzone) Ab Vista: Datum/Uhrzeit - Tabreiter: Zusätzliche Uhren | Alle
shell32.dll,Control_RunDLL wgpocpl.cpl | Microsoft Mail und Postoffice | Windows 9x und ME
shell32.dll,OpenAs_RunDLL | Box "Öffnen mit" aufrufen | Alle
shell32.dll,OpenAs_RunDLL d:\path\filename.ext | Öffnen mit... mit Dateiangabe | Alle
Shell32.dll,ShellAboutA | Infobox | Alle
Shell32.dll,SHExitWindowsEx 0 | Anwender abmelden | Windows 9x und ME
Shell32.dll,SHExitWindowsEx 1 | Windows beenden | Windows 9x und ME
Shell32.dll,SHExitWindowsEx 2 | Windows neu starten | Windows 9x und ME
Shell32.dll,SHExitWindowsEx 4 | Windows beenden, auch wenn noch Anwendungen offen sind | Windows 9x und ME
Shell32.dll,SHExitWindowsEx 8 | Rechner ausschalten | Windows 9x und ME
Shell32.dll,SHExitWindowsEx 13 | Funktion 1 + 4 + 8 zusammen ausführen | Windows 9x und ME
Shell32.dll,SHExitWindowsEx -1 | Windows Explorer neu starten | Windows 9x und ME
Shell32.dll,SHFormatDrive | Diskette formatieren aufrufen | Windows 9x und ME
shell32.dll,SHHelpShortcuts_RunDLL AddPrinter | Drucker hinzufügen | Alle
shell32.dll,SHHelpShortcuts_RunDLL PrintersFolder | Drucker anzeigen | Alle
printui.dll,PrintUIEntry [Optionen] [@Befehlsdatei] Beispiel: printui.dll,PrintUIEntry /q /in /n \\ServerName\Freigabename | Drucker direkt ohne Assistent hinzufügen (siehe auch diesen Tippfür weitere Infos der Parameter). | Ab Windows NT
shell32.dll,SHHelpShortcuts_RunDLL FontsFolder | Schriftarten anzeigen | Alle
shell32.dll,SHHelpShortcuts_RunDLL Connect | Netzwerklaufwerk verbinden, Dialog öffnen | Alle
shell32.dll,SHHelpShortcuts_RunDLL Disconnect | Netzwerklaufwerk trennen, Dialog öffnen | bis Windows 2003
syncui.dll,Briefcase_Create | Aktenkoffer auf dem Desktop erstellen | bis Windows 2003
syncui.dll,Briefcase_Intro | Aktenkoffer Infotext | bis Windows 2003
Sysdm.cpl,InstallDevice_RunDLL | Schnelle Hardwareerkennung (Hardwareassistent) | Windows 98 und ME
url.dll,TelnetProtocolHandler <IP-Adresse bzw. Hostname> | Telnet-Verbindung öffnen | Alle
url.dll,FileProtocolHandler <URL> | Startet die URL | Alle
url.dll,MailToProtocolHandler <E-Mail Adresse> | E-Mail erzeugen | Alle
url.dll,NewsProtocolHandler <Newsgroup> | Newsreader öffnen | Alle
user32.dll,LockWorkStation | Rechner sperren | Ab Windows NT
shell32.dll,Control_RunDLL hotplug.dll | Hardware sicher entfernen Ist es möglich die Ansicht "Unplug or Eject Hardware" zu öffnen | Ab Windows NT
Keymgr.dll,KRShowKeyMgr | Gespeicherte Benutzernamen und Kennwörter | Ab Windows XP
DwmApi #102 | Aero aktivieren | Ab Windows Vista
DwmApi #104 | Aero deaktivieren | Ab Windows Vista
DwmApi #105 | Flip3D starten (Anzeige der gestarteten Programme) | Ab Windows Vista
powrprof.dll,SetSuspendState | Rechner wird in den Ruhezustand gefahren | Ab Windows Vista
shell32.dll,Control_RunDLL wscui.cpl,Security Center | Windows Sicherheitscenter | Ab Windows 2000
shell32.dll, Options_RunDLL 0 | Ordneroptionen | ME, Ab Windows 2000

Rundll

Die folgenden Funktionen in Verbindung mit USER.EXE sollten mit Rundll.EXE (anstatt Rundll32.EXE) aufgerufen werden, da USER.EXE eine 16-bit-Komponente ist. Beim Aufruf mit Rundll32 findet ein sogenanntes "thunk down" statt, d. h., 32-bit-Adressen/Daten müssen in 16-bit-Adressen/Daten und wieder zurück gewandelt werden.

Befehl | Beschreibung | Betriebssystem
User,cascadechildwindows | Alle geöffneten Tasks automatisch hintereinander anordnen | Windows 9x und ME
User,ExitWindows | Windows beenden (mit Abfrage, wenn Anwendungen offen sind) | Windows 9x und ME
User,ExitWindows Exec | Windows beenden (mit Abfrage, wenn Anwendungen offen sind) | Windows 98
User,repaintscreen | Aktualisieren (F5) | Windows 9x und ME
User,setcursorpos | Setzt Mauscursor links oben in die Ecke | Windows 9x und ME
User,swapmousebutton | Vertauscht die Maustasten (hat nur beim ersten Aufruf eine Wirkung) | Windows 9x und ME
User,tilechildwindows | Alle geöffneten Tasks automatisch nebeneinander anordnen | Windows 9x und ME
User,wnetcancelconnection <Servername> | Trennen der Netzverbindung zum Netwareserver | Windows 9x und ME
User,wnetconnectdialog | Netzwerklaufwerke verbinden aufrufen | Windows 9x und ME
User,wnetdisconnectdialog | Netzwerklaufwerke trennen aufrufen | Windows 9x und ME

    • URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0564.htm


Parameter von Regedit

Hier werden die Parameter von Regedit aufgeführt:

Parameter | Beschreibung | Betriebssystem
/s | Importiert eine REG-Datei ohne Rückfrage. Regedit /s <Datei> Regedit /s test.reg | alle
/a | Exportier einen Schlüssel im ASCII-Format Regedit /a <Datei> <Pfad> Regedit /a test.reg "HKEY_LOCAL_MACHINE\Software\Registry System Wizard" | ab 2000
/e | Exportier einen Schlüssel im Unicode-Format Regedit /e <Datei> <Pfad> Regedit /e test.reg "HKEY_LOCAL_MACHINE\Software\Registry System Wizard" | ab 2000
/m | Öffnet eine weitere Instanz von Regedit Wenn Sie Regedit ohne /m starten, wird keine weitere Instanz geöffnet. Regedit /m | ab XP

Ab Windows 2000

Zusätzlich speichert der Registryeditor noch in der Registry ab, welcher Key als letztes geöffnet wurde und die Position des Programmes. Diese Einträge finden Sie in der Registry unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Regedit

hier finden Sie die Einträge:

Keyname | Datentyp | Beschreibung
FindFlags | REG_DWORD | Die letzten Suchoptionen (Einstellungen der Suche - "Bearbeiten" -> "Suchen STRG-F")
LastKey | REG_SZ | Der letzte Schlüssel, welcher beim beenden ausgewählt war. Dieser Schlüssel wird beim nächsten Start automatisch geöffnet.
View | REG_BINARY | Fenster Position usw.

Wenn Sie die Einträge löschen, wird der Registryeditor mit den Standardeinstellungen gestartet. Wenn nicht gewollt ist, dass immer der letzte geöffnete Schlüssel gespeichert wird, müssen Sie die Rechte auf den Schlüssel "Regedit" nur auf einen lesenden Zugriff beschränken.

Info Siehe auch: "Unterschiede zwischen Regedit und Regedt32"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2045.htm


FOR-Schleifen in Batchdateien

Wenn Sie unter Windows FOR-Schleifen in einer Batch Datei benutzen, sollten Sie bedenken, dass standardmäßig nur mit kurzen Dateinamen in FOR-Schleifen gearbeitet wird. Wenn Sie so eine Batch aber unter Windows ausführen, ist DOS in der Lage, auch mit langen Dateinamen umzugehen.

In diesem Fall können Sie mit dem Befehl "lfnfor on" die Verarbeitung von langen Dateinamen in FOR-Schleifen aktivieren.

Siehe auch den Hinweis auf das Programm DOS LFNBK in "Lange Dateinamen unter DOS sichern/wiederherstellen".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0606.htm


Wie kann ich alle Ausgaben einer Batchdatei umleiten?

Wie kann man alle Ausgaben einer Batchdatei umleiten?

Wenn man eine Batch-Datei aufruft, werden meist sehr viele Informationen ausgeben. Wenn Sie nun diese ganzen Informationen in ein Logfile schreiben wollen, müssen Sie dabei folgendermaßen vorgeben:

DATEI.CMD > c:\log.txt 2>&1

bzw.

DATEI.BAT > c:\log.txt 2>&1

Wenn Sie auf diese Art eine beliebige Batch-Datei aufrufen, werden alle Bildschirmausgaben in die LOG.TXT geschrieben.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1053.htm


Leerzeilen in der Bildschirmausgabe von Batch-Dateien

Die Ausgaben von Batch-Dateien sind oft schwer lesbar, weil Leerzeilen fehlen.

Der Befehl ECHO gibt statt mancher Sonderzeichen (z.B. [ ] , ;. : / \ ) eine Leerzeile aus, wenn das Sonderzeichen direkt (ohne Leerzeichen!) hinter ECHO steht, z.B. "ECHO]"

Bei gewohnter Schreibweise, also z.B. "ECHO ]", wird das Sonderzeichen (hier das ]) natürlich ausgegeben.

Die folgende Batch-Datei:

@echo off

echo Zeile 1

echo.

echo Zeile 3

erzeugt folgende Ausgabe:

Zeile 1

Zeile 3

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0219.htm


Windows Temp-Verzeichnis automatisch löschen

Im Temp-Verzeichnis von Windows bleiben oft viele Dateien liegen. Damit dieses Verzeichnis nicht immer größer wird, sollte man den Inhalt automatisch löschen lassen.

Dafür erstellen Sie einfach folgendes Script:

@echo off

REM Auf das Laufwerk wechseln. Wenn die Verzeichnisse wo anders liegen, anpassen!

%SystemDrive%

REM ******************* Windows Temp

REM *** In das Temp-Verzeichns wechseln

cd "%Windir%\Temp"

REM *** Versteckte Dateien wieder anzeigen

attrib -h -s /S /D "%Windir%\Temp"

REM *** Dateien und alle Unterverzeichnisse löschen (ohne Nachfrage)

RD /S /Q "%Windir%\Temp"

REM *** Sicherheitshalber prüfen ob Verzeichnis noch vorhanden, wenn nicht anlegen

If not exist "%Windir%\Temp" md "%Windir%\Temp"

REM ****************************************

REM ******************* User Temp

REM *** In das Temp-Verzeichns wechseln

cd "%Temp%"

REM *** Versteckte Dateien wieder anzeigen

attrib -h -s /S /D "%Temp%"

REM *** Dateien und alle Unterverzeichnisse löschen (ohne Nachfrage)

RD /S /Q "%Temp%"

REM *** Sicherheitshalber prüfen ob Verzeichnis noch vorhanden, wenn nicht anlegen

if not exist "%Temp%" md "%Temp%"

REM ****************************************

REM ******************* Temp des Internet Explorers s

REM *** In das Temp-Verzeichns wechseln

cd "%Userprofile%\Lokale Einstellungen\Temporary Internet Files"

REM *** Versteckte Dateien wieder anzeigen

attrib -h -s /S /D "%Userprofile%\Lokale Einstellungen\Temporary Internet Files"

REM *** Dateien und alle Unterverzeichnisse löschen (ohne Nachfrage)

RD /S /Q "%Userprofile%\Lokale Einstellungen\Temporary Internet Files"

REM *** Sicherheitshalber prüfen ob Verzeichnis noch vorhanden, wenn nicht anlegen

if not exist "%Userprofile%\Lokale Einstellungen\Temporary Internet Files" md "%Userprofile%\Lokale Einstellungen\Temporary Internet Files"

REM ****************************************

Wichtig ist hierbei, das über "cd %Windir%\Temp" in das entsprechende TEMP-Verzeichnis gewechselt wird. Dadurch wird sichergestellt, dass dieses Verzeichnis nicht mit dem Befehl "RD /S /Q %Windir%\Temp" gelöscht wird.

Man könnte zwar das Verzeichnis ansonsten mit MD %Windir%\Temp wieder anlegen, wenn aber besondere Rechte auf das Verzeichnis gesetzt wurden, ist das nicht immer gewünscht.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2039.htm


Deaktivieren des Zwischenspeicherns des Domain-Passwortes

Standardmäßig wird das Passwort bei der Anmeldung an der Domäne zwischengespeichert, damit es bei weiteren Verbindungen in der Domäne nicht wieder eingegeben werden muss. Windows greift dann automatisch auf das zwischengespeicherte Passwort zurück.

Aus Sicherheitsgründen kann es sinnvoll sein, das Zwischenspeichern zu unterbinden. Das hat aber zur Folge, dass beim ersten Zugriff auf anderen Ressourcen das Passwort abgefragt wird.

Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Network\ Logon

Legen Sie hier einen neuen Eintrag mit dem Namen "NoDomainPwdCaching" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0944.htm


Netzlaufwerke verbinden sich ungewollt automatisch

Wenn sich in unregelmäßigen Abständen der Explorer selbstständig macht und alle noch freien Laufwerksbuchstaben mit Netzlaufwerken anderer Rechner im LAN verbindet, kann als Ursache der Index-Dienst - FindFast.exe- angenommen werden.

Dieser durchsucht alle Laufwerke in regelmäßigen Abständen nach Office-Dateien und greift hierbei auch auf zurückliegende Netzwerkverbindungen mit Laufwerken zurück.

Abhilfe schafft das Löschen aller Index-Tätigkeiten (und -Dateien) über "Systemsteuerung" - "Indexerstellung".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
"OFF97: Wie Sie die Indexerstellung deaktivieren können"
http://www.microsoft.com/kb/Germany/Support/kb/D40/D40047.HTM
"OFF2000: Überblick über die Indexerstellung"
http://www.microsoft.com/kb/Germany/Support/kb/D38/D38527.HTM

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1133.htm


Ändern der Sicherheit der LAN-Manager Identifizierung an Windows

Ändern der Sicherheit einer LAN-Manager-Identifizierung unter Windows

Windows unterstützt zwei Arten der Identifizierung:

  • Die LanManager Identifizierung (LM)
  • NT Identifizierung (NTLM)

Die LanManager Identifizierung ist nicht so sicher wie die NT-Identifizierung, so dass hierüber Angriffe von außen möglich sind (Sicherheitslücken).

Durch einen Registry-Eintrag können Sie die Identifizierung verbessern (bei NT erst ab ServicePack 4). Es stehen dann 6 Sicherheitsstufen zur Verfügung:

Stufe 0 | Sendet LM- und NTLM-Antworten (Standardeinstellung)
Stufe 1 | Benutzt NTLMv2, wenn möglich
Stufe 2 | Sendet nur NTLM-Antworten
Stufe 3 | Sendet nur NTLMv2-Antworten
Stufe 4 | DC verweigert LM-Antworten
Stufe 5 | DC verweigert LM- und NTLM-Antworten (nur NTLMv2)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

finden Sie den Wert "LMCompatibilityLevel" als Datentyp REG_DWORD, wo Sie durch die Eingabe von 0 - 5 den Sicherheitslevel festlegen können. Standard ist 0 bzw. ab Windows Vista 3.

Wenn Sie mit Samba 3.x arbeiten, müssen Sie den Wert auf 1 setzen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base
http://support.microsoft.com/?kbid=147706
http://support.microsoft.com/?kbid=239869

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0943.htm


Netzwerkverbindungen auf dem Desktop verwalten

Erstellen Sie zwei neue Verknüpfungen auf dem Desktop. Vergeben Sie jeweils einen Namen z.B. "Netz verbinden" und "Netz trennen".

Wählen Sie ein passendes Icon aus. Geben Sie unter Ziel jeweils folgendes ein:

  • Verknüpfung (Netz verbinden)
    %WINDIR% \Rundll.EXE user,WNetConnectionDialog
  • Verknüpfung (Netz trennen)
    %WINDIR% \Rundll.EXE user,WNetDisconnectDialog

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0441.htm


Netzwerk starten ohne Passwort und Pause

Wenn man unter Windows ein Netzwerk installiert hat, wird man nach einem Passwort gefragt und muss dieses beim Starten jedesmal eingeben. Das lässt sich durch Löschen eines Registry-Eintrags zwar verhindern, die bessere Lösung ist aber unter:

"Autologin beim Starten" zu finden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Network\ Logon

die Zeichenfolge "PrimaryProvider" samt Wert "Microsoft Network" löschen

oder Sie nutzen folgende Möglichkeit:

Wenn Sie auf Ihren Rechner die Netzwerkoptionen installiert haben, aber das Netzwerk nur selten nutzen, ist es sinnvoll, beim Starten von Windows auf die Netzwerkanmeldung zu verzichten. Ansonsten wird Windows beim Hochfahren immer erst versuchen, das Netzwerk zu durchsuchen, was doch einiges an Zeit kostet. Damit Windows erst beim Zugriff auf das Netzwerk die Netzwerkanmeldung durchführt, stellen Sie folgendes ein:

"Start" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk". Dort klicken Sie auf "Client für Microsoft Netzwerke" (Doppelklick oder über "Eigenschaften") und markieren unter "Netzwerkanmeldeoptionen" die "Schnelle Anmeldung".

Nun wird Ihr Windows erheblich schneller starten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0245.htm


Bevorzugten Netware-Server festlegen

Mit dem folgenden Registry-Eintrag können Sie den Namen des Netware-Servers festlegen, der bevorzugt für die Authentifizierung benutzt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ NWNP32\ NetworkProvider

Erstellen Sie einen neuen Eintrag mit dem Namen "AuthenticatingAgent" als Datentyp REG_SZ und tragen Sie hier den Namen des gewünschten Servers ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1306.htm


PC-Direktverbindung über Nullmodemkabel

Hier wird beschrieben, wie Sie eine Direktverbindung über ein Nullmodemkabel unter Windows 9x und ME herstellen können.

Windows 9x Netzwerk Einstellungen

  1. Es muss wie bei einem richtigen Netzwerk der gleiche Arbeitsgruppenname eingegeben werden.
  2. Es müssen zwei unterschiedliche PC-Namen (und wenn es nur Win1 u. Win2 ist) eingegeben werden.
  3. Das DFÜ-Netzwerk muss mit der PC-Direktverbindung installiert sein.
  4. Der MS-Client für Windows-Netzwerke muss installiert sein.
  5. Als Protokoll ist NetBEUI oder IPX/SPX auf beiden PCs erforderlich und muss an den DFÜ-Adapter gebunden werden. Eines der beiden reicht, welches ist egal.
  6. TCP/IP ist zwar auch möglich, aber nicht zu empfehlen. Für den Zugang zu z.B. T-Online muss das TCP/IP nämlich auf automatischer IP Vergabe eingestellt sein und für die Direktverbindung müssten dagegen auf beiden PCs eine korrekte und zusammenpassende IPs vergeben werden.
  7. Achtung Falle!
    Win95 installiert von selbst NetBEUI und IPX/SPX. Windows 98 installiert dagegen nur TCP/IP. Also hier muss das manuell ergänzt werden.
  8. Protokolle, die hinzugefügt werden, werden erst einmal an alle vorhandenen Netzwerkkarten, Clients und Freigaben gebunden, also auch immer an den DFÜ-Adapter usw.

Bei Windows 95(A) soll es angeblich damit Probleme geben. Ich kann dies aber nicht bestätigen. Wenn doch, sollte das Update des DFÜ-Netzwerks (aktuell v1.3) aber helfen.

Info Über USB-Anschluss kann man auch sehr einfach 2 PCs verbinden, die Installation ist einfach. Das Übertragungstempo ist aber viel schneller als über Nullmodemkabel. Ein USB-Link-Kabel lohnt sich!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0712.htm


Ablagemappe lässt sich nicht freigeben

Wenn Sie im Netzwerk die Ablagemappe freigeben wollen, kann es sein, dass die hierfür notwendigen Menüpunkte fehlen.

Die Ablagemappe benötigt NETDDE.EXE (Dienst für dynamischen Datenaustausch). Manche Programme laden NETDDE.EXE automatisch. Wird die Ablagemappe gestartet während ein solches Programm aktiv ist, stehen Ihnen Menüpunkte für die Freigabe zur Verfügung. Ist dies aber nicht der Fall, müssen Sie NETDDE.EXE entweder manuell starten oder in die WIN.INI (hinter "Load=") Eintragen.

Info Ablagemappe ist nicht identisch mit der Zwischenablage! Die Zwischenablage können Sie mit dem Windows 95-Setup optional installieren, die Ablagemappe befindet sich auf der Windows 95-CD im Verzeichnis \OTHER\CLIPBOOK und kann nur nachträglich über "Systemsteuerung" - "Software" - "Windows-Setup" - "Diskette" installiert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0007.htm


Zugriff auf Samba Server nicht möglich

Unter Windows kommt es zu Problemen, wenn Sie eine Verbindung zu einem Samba-Server aufbauen wollen. Windows 98 benutzt jetzt automatisch immer verschlüsselte Kennwörter die vom Samba-Server aber nicht verstanden werden. Das können Sie nur über einen Eintrag in der Registry ausschalten.

Die neusten Samba-Versionen unterstützen jetzt auch diese Verschlüsselung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

(für Windows NT)

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Rdr\ Parameters

(für Windows 9x / ME)

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsup

(ab Windows 2000)

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanWorkStation\ Parameters

fügen Sie einen neuen Wert als Datentyp REG_DWORD mit dem Namen "EnablePlainTextPassword" ein und stellen diesen Wert auf 1.

Info Da das für die Netzwerksicherheit nicht gerade sehr gut ist, sollte man lieber auf eine neuere SAMBA Version zurückgreifen, die auch verschlüsselte Kennwörter unterstützt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=166730

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0692.htm


Netzwerkverbindung erst beim Zugriff wiederherstellen

Die Anmeldung von Windows kann man beschleunigen, indem man Netzwerkverbindungen nicht sofort aufbauen lässt, sondern erst dann, wenn man auf das entsprechende Laufwerk zugreift.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ NetworkProvider

setzen Sie "RestoreConnection" als Datentyp REG_DWORD auf "0". (Standard: 1)

Nun werden Verbindungen erst dann erstellt, wenn sie benötigt werden.

Eine 0 bewirkt also eine sogenannte "Ghost Connection", d.h. der Eintrag wird gespeichert und der Laufwerksbuchstabe reserviert, aber nicht automatisch eine Verbindung aufgebaut. Eine 1 erzwingt das gewünschte sofortige Verbinden beim Einloggen.

Info Für das setzen dieses Wertes ist die Einstellung "Wiederherstellen der Netzwerkverbindung beim Anmelden deaktivieren" des Remote-Access-Clients verantwortlich.

Diese Einstellung unterscheidet sich völlig von der schnellen Anmeldung bei Windows 95/98. Während bei Windows 95/98 die Laufwerke als verbunden erscheinen und man sofort von überall darauf zugreifen kann, erscheint dies bei NT im Explorer mit einem roten X und erscheint in Programmen, die nicht auf diese Explorerliste zugreifen überhaupt nicht, wenn das Laufwerk nicht vorher z.B. durch einen Zugriff im Explorer verbunden wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0246.htm


PCs ohne Netzwerk verbinden

Kaum etwas ist ärgerlicher als beispielsweise bei einer neuen Softwareinstallation festzustellen, dass die Festplatte einmal wieder zu klein ist: Der Datenträger im Ziellaufwerk ist voll. "Legen Sie einen neuen Datenträger ein" lautet die obligatorische Fehlermeldung, die gerade Anwendern älterer PCs oder Notebooks mit kleinen Festplatten häufig die Arbeit erschwert. Besonders störend ist dies, wenn daneben ein neuer PC steht, dessen Festplatte gerade einmal zu 20 Prozent gefüllt ist. Wer nun glaubt, zur Problemlösung gleich ein Netzwerk mit entsprechend teurer Hard- und Software zu benötigen, der irrt. Innerhalb weniger Minuten lässt sich zumindest jedes Microsoft-Betriebssystem ohne Zusatzsoftware miteinander verbinden. Lediglich eine serielle oder parallele Schnittstelle muss vorhanden sein, um über ein einfaches Kabel für wenig Geld eine entsprechende Direktverbindung zu realisieren. Der Clou dabei ist, dass alle notwendigen Treiber seit MS-DOS 5.0 in den Betriebssystemen enthalten sind und dass wirklich alle Systeme miteinander kommunizieren können - allerdings ist oftmals ein Griff in die Trickkiste erforderlich.

Hinweis:

Unter http://www.datapower.de/ ist eine ebenfalls interessante Lösung zum kleinen Preis verfügbar, welche ohne aufwändige Installation einen Filetransfer zwischen DOS /Windows ermöglicht mit sehr hohen Übertragungsraten.

Das Client/Server-Prinzip

Natürlich liegt es auf der Hand, dass unter DOS oder Windows 3.x nicht die gleichen Softwarekomponenten zum Einsatz kommen wie etwa unter Windows NT 4.0 oder Windows 95. Um dennoch eine Verbindung aufzubauen, ist es zunächst wichtig zu wissen, dass jeder PC-Direktverbindung - ganz gleich, wer mit wem zusammenarbeitet - das Client/Server-Prinzip zu Grunde liegt:

Ein PC arbeitet als Server und stellt seine Ressourcen dem Client zur Verfügung. Über den Client kann der Anwender dann auf den Server zugreifen und den Datenaustausch wie gewünscht vornehmen. Vom Server aus kann hingegen nicht auf die Ressourcen des Clients zugegriffen werden. Es ist also zunächst einmal wichtig, dass sich der Anwender darüber im klaren ist, welchem der PCs die Rolle des Servers gegeben werden soll. Es bietet sich an, den PC, dessen Daten transferiert werden sollen, als Server einzusetzen, da Laufwerksinhalte des Servers über den Client verändert werden können.

Verbindungsarten und Performance

Auch bei der Auswahl des Kabels und der Schnittstelle gibt es einige Besonderheiten zu beachten. Grundsätzlich ist der Datenaustausch über die parallele Schnittstelle zwar um ein Vielfaches schneller als über eine serielle Verbindung, der Nachteil ist jedoch, dass dann nicht mehr alle Betriebssysteme miteinander kommunizieren können. Eine Verbindung von einem Windows-3.1x-PC mit Windows NT 4.0 beispielsweise ist nur über ein serielles Kabel realisierbar - allerdings mit deutlichen Performanceeinbußen, wie es die nachfolgende Auflistung deutlich macht.

Über Interlink-Interserver:

parallel 14 Sekunden

seriell (bei 115200 bps) 7 Minuten

PC-Direktverbindung in Windows 95

parallel 40 Sekunden

seriell bei 19200 bps 7 Minuten

RAS-Verbindung unter Windows NT

nur seriell 7 Minuten

Die ermittelten Zeiten beziehen sich auf die Übertragung einer 1 MByte großen Textdatei. Interessant ist an dieser Stelle, dass bei der seriellen PC-Direktverbindung von Windows 95 nur bei einer Einstellung - on 19 200 bps oder langsame - eine Verbindung zustande kommt. Wird hier eine schnellere Übertragung gewählt, entsteht zwar der Kontakt, eine Datenübertragung erfolgt jedoch nicht. Das parallele Kabel an sich stellt ein modifiziertes Druckerkabel mit zwei männlichen DB-25-Steckern dar. Das Kabel für die Verbindung über die serielle Schnittstelle ist dagegen ein sogenanntes Null-Modem-Kabel mit drei beziehungsweise sieben Adern. Je nach Schnittstellenart müssen dessen Enden mit weiblichen DB-9- oder DB-25-Steckern versehen sein.

Windows-95-PCs unter sich

Am einfachsten sind Verbindungen zwischen zwei Windows-95-Systemen aufzubauen, da sich hierfür die sogenannte PC-Direktverbindung von Windows 95 anbietet.

Diese Verbindung wird bei der Standardinstallation von Windows 95 allerdings nicht berücksichtigt, muss also bei Bedarf nachinstalliert werden. Dies ist jedoch nicht weiter schlimm, da nach dem Aufruf des entsprechenden Menüpunkts in der Systemsteuerung unter /Software/Windows-Setup/Verbindungen/PC-Direktverbindung ein Assistent hilfreich zur Seite steht. Nach der Installation findet sich dann im Startmenü unter Zubehör der neue Eintrag PC-Direktverbindungen. Es gilt lediglich zu beachten, dass die PC-Direktverbindung auf dem DFÜ-Netzwerk basiert, das demzufolge vor der eigentlichen Installation einzurichten ist. Vor dem Verbindungsaufbau muss der Anwender entscheiden, welcher der beiden PCs als Server und welcher als Client arbeiten soll. Zudem müssen die benötigten Laufwerke (und evtl. Drucker) des Servers über die Eigenschaften des jeweiligen Objekts (im Kontextmenü) für den Zugriff freigegeben werden. Vergisst der Anwender diesen Punkt, wird zwar der Server gefunden, es stehen jedoch keinerlei Daten zur Verfügung. Schließlich sind - je nach Kabelart - die beiden Computer entweder über die seriellen oder parallelen Schnittstellen zu verbinden, wobei hier natürlich die parallele Verbindung zu bevorzugen ist. Nach dem Start der PC-Direktverbindung auf beiden PCs ist anzugeben, in welchem Modus der betreffende Rechner arbeiten soll. Für den Server gilt hier die Option Host-Computer, für den Client Gast-Computer. Abschließend ist noch festzulegen, über welche Schnittstellen die Verbindung aufgebaut werden soll. Damit ist die Installation bereits abgeschlossen.

Stimmen die Einstellungen auf beiden Seiten der PC-Direktverbindung, so entsteht innerhalb weniger Sekunden der Kontakt zwischen den entfernten PCs. Beim Client kann anschließend über die Schaltfläche "Host anzeigen" ein Explorer-Fenster geöffnet werden, in dem alle freigegebenen Laufwerke und Drucker des Servers zu sehen sind - so, als wären die PCs über ein richtiges Netzwerk miteinander verbunden.

Für den Fall, dass der Verbindungsaufbau nicht klappen sollte, liegt dies höchstwahrscheinlich an einer falsch gewählten Schnittstelle. In diesem Fall ist zunächst die PC-Direktverbindung auf beiden PCs zu beenden und dann erneut zu starten. Darauf erscheint der Startdialog, in dem sich unter anderem die Schaltfläche "Ändern" befindet. Ein Klick darauf eröffnet einen Dialog, in dem nicht nur die Rolle des jeweiligen Computers änderbar ist, sondern auch die gewählte Schnittstelle gewechselt werden kann. Ein weiteres Problem kann aber auch an den betriebssystemeigenen Schnittstelleneinstellungen liegen: So verfügen etwa serielle Schnittstellen älterer Notebooks nicht über einen Fifo-Chip (Uart16550), so dass über die Schnittstelle zwar mit max. 115 200 bps gesendet aber nicht empfangen werden kann (9600 Bit pro Sekunde).

Mit Windows 95 nach Windows NT und zurück

Die Verbindung zwischen Windows 95 und Windows NT ist - von einer etwas umfangreicheren Installation einmal abgesehen - ähnlich einfach wie von Windows 95 nach Windows 95. Da Windows NT im Gegensatz zu Windows 95 über keine vorkonfigurierte PC-Direktverbindung verfügt, muss jedoch der RAS-Dienst (Remote Access Service) bemüht werden. Soll Windows NT die Rolle des Servers übernehmen, so sind vor dem ersten Kontakt folgende Vorkehrungen zu treffen:

Zunächst ist zu prüfen, ob der RAS-Dienst überhaupt installiert ist. Falls nicht, muss dies über die Netzwerkeigenschaften in der Systemsteuerung nachgeholt werden. Anschließend ist es aufgrund der Sicherheitsvorkehrungen von NT erforderlich, den Windows-95-Namen auch als User-Account über den Benutzermanager im Startmenü von Windows NT einzutragen. Eine Schwierigkeit ist an dieser Stelle allerdings programmiert: Nachdem der User ordnungsgemäß. angelegt ist, muss für ihn eine Einwahlerlaubnis in den RAS-Dienst vergeben werden. Sie ist über die RAS-Verwaltung im Startmenü unter Verwaltung (Allgemein) anzulegen. Wird dieser Punkt vergessen, findet sich zwar der Rechner, ein Loginversuch schlägt jedoch fehl.

Weiterhin gilt es zu beachten, dass unter Windows NT systembedingt keine Parallelverbindung aufgebaut werden kann, sondern lediglich serielle Schnittstellen anzusprechen sind. Schuld an dieser Misere ist der RAS-Dienst, der ursprünglich (auch in Windows 3.11) nur für Modemverbindungen über die serielle Schnittstelle ausgelegt wurde und dies bis heute noch ist.

Zudem ist es wichtig, die Übertragungsgeschwindigkeiten der betreffenden Schnittstellen zu überprüfen und unter Windows NT 4.0 und Windows 95 die gleiche Bitrate einzustellen - sonst kommt die Verbindung nicht zustande, da die Software hier keinen Abgleich durchführt. Diesbezügliche Angaben geschehen unter Windows NT 4.0 über das Modem-Applet in der Systemsteuerung. Der betreffende Eintrag lautet DFÜ-Netzwerk mit seriellem Kabel zwischen 2 PCs. Ein Doppelklick darauf öffnet einen weiteren Dialog, in dem unter anderem die Geschwindigkeit der Übertragung eingestellt werden kann.

In der Praxis stellt sich dabei heraus, dass Übertragungsraten von mehr als 19 200 bps nicht mehr realisierbar sind. Unter Windows NT 3.5x wird die Übertragungsgeschwindigkeit über das RAS-Setup eingestellt, das hierfür die Einträge Nullmodemkabel 9600, Nullmodemkabel 19200 und Nullmodemkabel 38400 bietet. Weitere Angaben sind an dieser Stelle nicht möglich.

Um die Werte unter Windows 95 anzupassen, sind die Systemeigenschaften mit der Registerkarte Geräte-Manager zu öffnen. Dort findet sich der Befehl "Modelle nach Anschluss anzeigen". In der dazugehörigen Liste befindet sich nach der erfolgreichen Installation der PC-Direktverbindung ein Eintrag namens Nullmodemkabel an COMx, dessen Eigenschaftenmenü die Registerkarte Modem enthält. Hier kann die Geschwindigkeitsanpassung in einer Dialogbox erledigt werden.

Sind nun all diese Einstellungen erfolgt (sie sind zum Glück nur ein einziges einmal erforderlich), kann es an den Verbindungsaufbau gehen. Dazu muss zunächst der RAS-Dienst unter Windows NT gestartet werden, um dann die bereits bekannte PC-Direktverbindung unter Windows 95 mit der Option Gast-Computer zu aktivieren (erfreulicherweise sind die beiden zu hundert Prozent kompatibel). Daraufhin meldet sich die Passwortabfrage für das Einloggen auf dem Windows-NT-Server. War dieser Vorgang erfolgreich, kann vom Windows-95-Client auf alle freigegebenen Ressourcen des NT-Servers zugegriffen werden.

Das umgekehrte Szenario "NT ruft Windows 95" ist hingegen weitaus einfacher zu realisieren: Unter Beachtung der richtigen Geschwindigkeit ist lediglich auf dem Windows-95-Computer die PC-Direktverbindung als Host-Computer zu starten. Unter Windows NT ist dann zur Kontaktaufnahme ein neuer Telefonbuch-Eintrag anzulegen, der als Kommunikationsgerät kein Modem, sondern das serielle Verbindungskabel benutzt. Einziger Fehlerfaktor ist an dieser Stelle die Wahl des Protokolls: Nur der Eintrag PPP: Windows NT 4.0, Windows 95, Internet in dem Eigenschaftendialog des Telefonbuch-Eintrags unter der Registerkarte Server ermöglicht die Verbindung.

Windows 3.x ruft Windows 95 und umgekehrt

Um mit Windows 3.x eine Verbindung zu Windows 95 herzustellen, sind die inzwischen fast in Vergessenheit geratenen Programme Interlink und Interserver von MS-DOS Version 5.0 - sozusagen die Urahnen der PC-Direktverbindung - einzusetzen. Übrigens ist gerade dieses Treibergespann ein schönes Beispiel dafür, dass Neuentwicklungen nicht unbedingt immer mit mehr Leistungsfähigkeit einhergehen. Denn in Sachen Übertragungsgeschwindigkeit und Benutzerfreundlichkeit sind die beiden 16-Bit-Treiber nach wie vor das Nonplusultra - und lassen selbst die aktuellste DFÜ-Netzwerksoftware weit hinter sich. Dieses Teiberpaar wurde bisher über alle DOS -Versionen hinweg bis hin zu Windows 95 mit ausgeliefert. Allerdings ist diese Software in letzterem Fall gut auf der CD-ROM im Verzeichnis \OTHERS\OLDMSDOS versteckt.

Die Anwendung und Installation der Treiber geht relativ einfach vonstatten: Zunächst ist die Kabelverbindung herzustellen, wobei es völlig gleich ist, ob die Verbindung seriell oder parallel erfolgt und an welchem Anschluss das Kabel steckt. Soll ein Windows-95-PC Server für einen Windows-3.x-Client sein, so ist zunächst in der Datei config.sys des Clients folgender Eintrag aufzunehmen (das Verzeichnis c:\treiber ist dabei natürlich auf die jeweiligen Gegebenheiten anzupassen):

devicehigh=c:\treiber\interlnk.exe /auto

Der optionale Startparameter /auto sorgt dafür, dass der Treiber nur dann geladen wird, wenn er bei seiner Initialisierung von der Serverseite tatsächlich eine Antwort erhält. Auf dem Windows-95-PC, der im Beispiel als Server fungiert, ist die Datei Intersvr.exe zu starten. Daraufhin erscheint allerdings eine Meldung, dass das Programm nur für den MS-DOS -Modus gedacht sei. Diese kann beruhigt übergangen werden.

Sobald nun Interserver aktiv ist, muss der Client erneut starten, um den Interlink-Treiber über die Datei config.sys ins System einzubinden. Sobald Interlink aufgerufen wird, werden alle verfügbaren Schnittstellen gescannt und nach Möglichkeit eine Verbindung mit dem Interserver auf der anderen Seite des Kabels hergestellt. War dieser Vorgang erfolgreich, werden alle vom Server zur Verfügung gestellten Laufwerke auf Clientseite über eigene Laufwerkskennungen angezeigt. Der Defaultwert steht dabei allerdings bei max. vier anzuzeigenden Laufwerken, was aber über Startparameter geändert werden kann. Genauere Details hierzu stehen in einer vorhandenen Hilfedatei, die sich im selben Verzeichnis wie die Programme auf der CD-ROM befindet.

Übrigens: Selbst Drucker können mit Interlink umgeleitet werden. Nachdem der Windows-3.x-PC als Client gestartet ist, kann etwa mit dem Dateimanager auf die Interlink-Laufwerke des Servers zugegriffen werden. Einen Nachteil hat das Ganze allerdings: Da Windows 3.x keine langen Dateinamen kennt, sind diese nur in ihrer Kurzfassung zu sehen. Um dies zu vermeiden, bietet es sich an, die gesamte Verbindung andersherum aufzubauen: Interlink ist derart transparent, dass beim Einsatz von Windows 3.x als Server und Windows 95 als Client auch auf den Serverlaufwerken mit langen Dateinamen gearbeitet werden kann, da in diesem Falle der Interserver nicht auf der Dateisystemverwaltung aufsetzt, sondern diese selbst übernimmt. In diesem Fall ist Intersvr auf dem Windows-3.1x-Computer zu starten und der besagte Interlink-Eintrag in der Datei config.sys von Windows 95 zu übernehmen (Neustart nicht vergessen).

Von DOS nach Windows und zurück

Da Windows 3.x bekanntlich auf DOS aufsetzt, gelten naturgemäß. alle Angaben zum Aufbau einer PC-Direktverbindung mittels Interlink zwischen Windows 3.1x und Windows 95 auch für DOS und Windows 95 - und daraus folgend ebenso für Verbindungen von DOS und Windows 3.x.

Natürlich kann das Interlink-Interserver-Gespann auch als Ersatz für die PC-Direktverbindung zwischen Windows-95-PCs benutzt werden. Allerdings muss dabei auf das grafische Interface beim Server verzichtet werden, da während der Serverausführung im MS-DOS -Modus an dem betreffenden PC keine anderen Arbeiten verrichtet werden können - doch das Minus an GUI macht sich mit einem deutlichen Plus an Performance bezahlt. und wie bereits gesagt: Die langen Dateinamen werden zu hundert Prozent von Interlink unterstützt!

Windows NT und der Rest der (Microsoft-)Welt

Das A und O für PC-Direktverbindungen mit Windows NT ist dessen DFÜ-Netzwerkunterstützung in Form des RAS-Serverdienstes (Interlink-Verbindungen sind aufgrund der Abhängigkeit der Treiber von DOS nicht zu bewerkstelligen). Wie bereits im Zusammenspiel mit Windows 95 gezeigt, kann man im Handumdrehen einen Windows-NT-PC mit einem anderen über die serielle Schnittstelle verkabeln: Dazu ist einfach auf der als Server bestimmten Maschine der RAS-Serverdienst zu starten und dann über das DFÜ-Netzwerk des Clients darauf zuzugreifen - identische Schnittstellengeschwindigkeit und passende Einwahlrechte vorausgesetzt.

Gleiches gilt auch für die PC-Direktverbindung von Windows für Workgroups 3.11 mit NT: Über das DFÜ-Netzwerk von Windows 3.11 kann sich der Anwender einfach in den RAS-Serverdienst auf dem NT-Computer einwählen. Auch hier ist unbedingt auf gleiche Schnittstellengeschwindigkeit und Einwahlrechte zu achten. Der umgekehrte Fall, dass Windows für Workgroups als Server für Windows NT dient, ist allerdings nicht möglich, da Windows 3.11 keinen RAS-Serverdienst enthält.

Bleibt schließlich noch der Datenaustausch von DOS nach Windows NT und umgekehrt. Da DOS lediglich die Interlink-Verbindungen kennt, diese aber unter NT nicht einsetzbar sind, bleibt nur ein Griff in die Trickkiste. So ist es beispielsweise möglich, unter DOS ein beliebiges Terminalprogramm zu starten, das über ein serielles Kabel mit dem Windows-NT-Hyperterminal Kontakt aufnimmt. Hierbei muss lediglich auf identische Schnittstellengeschwindigkeiten geachtet werden (die recht hoch angesetzt werden könnten)und das DOS DFÜ-Programm sollte das Z-Modem-Protokoll unterstützen, damit beispielsweise automatische Uploads möglich sind. Der Datenaustausch vollzieht sich dabei durch einfaches Hoch- beziehungsweise Herunterladen von einzelnen oder auch mehreren Dateien.

Weitere Möglichkeiten

Die hier gezeigten Vorschläge für den Aufbau von PC-Direktverbindungen quer über verschiedene Plattformen decken bei weitem nicht alle Möglichkeiten ab - sind aber mit Sicherheit die kostengünstigsten.

Daneben gibt es natürlich noch eine ganze Reihe weiterer Tools kommerzieller Anbieter, wie beispielsweise Symantecs PC Anywhere oder Laplink (http://www.laplink.com). Auch im Internet finden sich in vielen Shareware-Foren Testversionen von PC-Direktverbindungs-Utilities, die sich Interessenten herunterladen können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0791.htm


IP Multicasting konfigurieren

Mit diesem Eintrag können Sie das "IP Multicast"-Level anpassen. Die Spezifikation der einzelnen Level sind in der RFC 1112 festgelegt worden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erstellen Sie einen neuen Eintrag mit dem Namen IGMPLevel als Datentyp REG_DWORD und setzen den Wert auf den gewünschten Level:

Wert | Beschreibung
0 | keine Unterstützung von IP Multicasting
1 | Nur für das Senden wird IP Multicasting benutzt
2 | (Standard) Senden und Empfangen wird mit IP Multicasting durchgeführt

Info Änderungen an dieser Einstellung werden erst nach einen Neustart wirksam.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1223.htm


DNS Port für Lookups konfigurieren

Standardmäßig wird der Port 53 für DNS Lookups verwendet. Wenn Sie einen anderen Port dafür benutzen wollen, können Sie das in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erstellen Sie einen neuen Eintrag mit dem Namen DNSServerPort als Datentyp REG_DWORD und tragen den zu benutzenden Port ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1225.htm


Erkennung fehlerhafter Gateways

Mit einer Änderung in der Registry können Sie einstellen, dass Windows automatisch fehlerhafte Gateways erkennt und alternative Gateways benutzt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erstellen Sie einen neuen Wert mit dem Namen DeadGWDetect als Datentyp REG_DWORD und setzen den Wert auf 1, um diese Funktion zu aktivieren. Wenn Sie den Wert auf 0setzen, ist die Erkennung deaktiviert.

Info Diese Änderung wird erst nach einen Neustart wirksam.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1226.htm


Timeout für Broadcast Anfragen konfigurieren

Standardmäßig liegt der Timeout für Broadcast Anfragen bei 750 Millisekunden. Dieser Wert bestimmt, wie lange Windows auf eine Broadcast Anfrage wartet, bis es diese als nicht beantwortet deklariert.

Sie können diesen Wert in der Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erstellen Sie einen neuen Wert mit dem Namen BcastQueryTimeout als Datentyp REG_DWORD und geben hier die Zeit in Millisekunden ein, die Windows nach einem Broadcast warten soll (100 - 0xFFFFFFFF; Standard=0x2EE (750 Dezimal)).

Info Diese Änderung wird erst nach einen Neustart wirksam.

Info Siehe auch: "Anzahl der Versuche für eine Namensauflösung über Broadcast".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1227.htm


Anzahl der Versuche für eine Namensauflösung über Broadcast

Standardmäßig unternimmt Windows drei Versuche für eine Namensauflösung über Broadcast. Wenn in Ihrem Netzwerk die Namensauflösung sowieso nicht über Broadcast läuft, können Sie den Wert in der Registry herabsetzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MS

erstellen Sie einen neuen Eintrag mit dem Namen BcastNameQueryCount als DatenytpREG_DWORD und setzen den Wert auf die Anzahl der Versuche, die Windows dafür durchführen soll (1 - 0xFFFF; Standard = 3).

Info Diese Änderung wird erst nach einen Neustart wirksam.

Info Siehe auch: "Timeout für Broadcast Anfragen konfigurieren".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1228.htm


Probleme mit dem Heimnetzwerk (Peer-to-Peer)

Nachfolgend finden Sie eine kurze Checkliste und einige Links, die bei Problemen mit dem Vernetzen mehrerer PCs helfen sollen.

(Netzwerkumgebung - Eigenschaften):

  1. Verkabelung korrekt
  2. Verbindungstyp der Netzwerkkarte richtig konfiguriert (Coax, BNC,...) - die automatische Erkennung funktioniert nicht bei allen Karten zuverlässig
  3. Arbeitsgruppe identisch (kurz, ohne Umlaute, Sonder- und Leerzeichen)
  4. Rechnernamen eindeutig (kurz, ohne Umlaute, Sonder- und Leerzeichen)
  5. Client f. MS-Netzwerk installiert
  6. Primäre Anmeldung = Client für Microsoft-Netzwerke
  7. TCP/IP installiert
  8. Datei- u. Druckerfreigabe installiert
  9. "Anderen Benutzern soll der Zugriff..." unter Datei- u. Druckerfreigabe aktiviert
  10. IP-Adresse = 192.168.0.1 & 192.168.0.2
    (192.168.x.y -- x=0 bis 254, y=1 bis 254)
  11. Subnet Mask = 255.255.255.0
  12. Auf jedem Rechner mind. ein Ordner oder Laufwerk freigegeben
  13. Freigabenamen ohne Umlaute, Sonder- und Leerzeichen und nicht länger als zwölf Zeichen
  14. Die Windows-Anmeldung beim Starten nicht abbrechen
  15. Name und Kennwort des Benutzers auf beiden Rechnern identisch
  16. Ab XP-SP2 kann es auch an der Konfiguration der Windows Firewall liegen (testweise erst mal kurz abschalten, wenn es dann geht, die Konfiguration anpassen).

Folgende Einträge sollten in der Datei %WINDIR%\HOSTS (Windows 9x) bzw. %WINDIR%\System\Services\etc\HOSTS (Windows NT/2000/XP) vorhanden sein (verwenden Sie die Datei "HOSTS", nicht die Datei "HOSTS.SAM"):
127.0.0.1 localhost
192.168.0.1 pc1
192.168.0.2 pc2

Die Einträge in jeder Zeile sollen mit Leerzeichen voneinander getrennt sein. Die letzte Zeile soll mit <ENTER> (bzw. CRLF) abgeschlossen sein. Die Hosts-Datei ist standardmäßig nicht vorhanden, kann aber mit jedem Texteditor (z.B. NOTEPAD) erstellt werden.

Funktionieren (im DOS -Fenster)
"ping 192.168.0.1" und "ping 192.168.0.2"?

Funktionieren (im DOS -Fenster)
"ping pc1" und "ping pc2"?

Beachten Sie bitte, dass es mehrere Minuten dauern kann, bis die Rechner sich in der Netzwerkumgebung "sehen" (PING sollte allerdings sofort funktionieren). Betätigen Sie einfach im Ordner Netzwerkumgebung öfter die F5-Taste (Aktualisieren), suchen Sie den fehlenden PC über "Start" - "Suchen" - "Computer", oder verwenden Sie "Start" - "Ausführen" - \\pcname, um die Suche abzukürzen.

Das Netzwerk kann nicht durchsucht werden, wenn Sie auf Netzwerkumgebung klicken:

http://www.microsoft.com/kb/Germany/Support/kb/D44/D44220.HTM

Requirements to Browse Network with Windows 95-98-Me Dial-Up Networking Client (Q183368):

http://support.microsoft.com/?kbid=183368

Troubleshooting Browsing with client for Microsoft Networks (Q134304):

http://support.microsoft.com/?kbid=134304

Unable to Browse the Network clicking Network Neighborhood (Q260214):

http://support.microsoft.com/?kbid=260214

How to Troubleshoot Basic TCP-IP problems (Q169790):

http://support.microsoft.com/?kbid=169790

How to Remove and Reinstall Dial-Up Networking and TCP-IP Files:

http://support.microsoft.com/?kbid=181599

T-DSL

http://www.dslteam.de/

http://adsl-support.de/

http://service.t-online.de/t-on/hilf/faq/tdsl/cc/CP/cc-tdsl-faq.html

RASPPPoE (Ersatz für T-Online DSL-Treiber)

http://user.cs.tu-berlin.de/~normanb/

Screenshots einiger Netzwerkeinstellungen:

http://a-kaestner.de/

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1363.htm


Zugriff auf NT-Rechner ohne Anmeldung

Wollen Sie über Windows 95/98 auf das freigegebene Verzeichnis eines NT-Rechners zugreifen, ist immer eine Anmeldung erforderlich. In einem privaten Netzwerk kann das etwas nervig werden. Wollen Sie eine automatische Anmeldung, gehen Sie folgendermaßen vor:

  1. Sie dürfen kein Windows Passwort verwenden
  2. Die Option "Windows Anmeldung" muss als primäre Netzwerkanmeldung aktiviert sein
  3. Es darf auf dem Windows Rechner kein Benutzerprofil aktiviert sein, da ansonsten immer das Kennwort beim Zugreifen weitergeben wird
  4. Entfernen Sie aus der Datei System.ini die ganze Sektion "Password Lists"

Starten Sie den PC neu. Beim Anmelden werden Sie nun als erstes nach einem Windows Kennwort gefragt, hier dürfen Sie nichts eingeben. Jetzt werden Sie nach dem Netzwerkkennwort gefragt, hier müssen Sie das Kennwort des NT-Rechners eingeben, das für die Freigabe benutzt wurde und die Option "Kennwort speichern" ankreuzen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0835.htm


Netzwerkkarten Rückmeldung bei WINS Anfragen

Mit diesem Tipp können Sie einstellen, ob bei mehr als einer Netzwerkkarte alle oder nur eine IP-Adresse bei einer WINS Anfrage zurückgeliefert werden soll.

Befinden sich in Ihrem Rechner mehr als eine Netzwerkkarte, können Sie mit diesem Tipp einstellen, ob Windows bei einer WINS-Anfrage alle oder nur eine IP-Adresse zurückgeliefert werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

Erstellen Sie hier einen neuen Wert mit dem Namen "SingleResponse" als Datentyp REG_DWORD (Achtung: Bei Windows 98 müssen Sie den Eintrag als REG_SZ anlegen) und setzen den Wert auf:

0 | Es werden alle IP-Adressen zurückgegeben
1 | Es wird nur eine IP-Adresse zurückgegeben

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2644.htm


TCP/IP Grundlagen

Die Netzklassen:

Klasse | Anzahl der Netze | Anzahl Hosts pro Netz | Anfang | Ende | Subnet Mask
A | 126 | 16777214 | 1 | 126 | 255.0.0.0
B | 16384 | 65534 | 128 | 191 | 255.255.0.0
C | 2097152 | 254 | 192 | 223 | 255.255.255.0

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0784.htm


Senden von SAP Paketen deaktivieren

Standardmäßig sendet Windows SAP Pakete, um Datei- und Druckershares bekannt zu geben, wenn die Funktion "Datei und Druckerdienste für Netware Networks" aktiviert wurde.

Wenn Sie diese Pakete nicht benötigen, können Sie das Senden von SAP-Paketen unterbinden, um den Netzwerkverkehr zu minimieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ NcpServer\ Parameters

Erstellen Sie einen neuen Wert mit dem Namen "Use_Sap" als Datentyp REG_SZ. Setzen Sie den Wert auf 0, um diese Funktion zu deaktivieren.

Der Standardwert ist 1, was das Senden von SAP-Paketen aktiviert.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1112.htm


Startdiskette (W95/98) mit Netzwerkzugriff

Von M. Startentolte habe ich folgenden Tipp erhalten.

Sie finden diesen Tipp und eine fertige Datei, um die Bootdiskette zu erstellen, auch auf seiner Homepage: http://www.msdatec.de/netwinsf.htm#netwinbootdisk

Falls über die Startdisk ein Netzwerkzugriff mit Windows-eigenen Mitteln (NET-EXE und *.DOS -Kartentreiber) per NetBIOS oder IPX erfolgen soll, ist die Registry erforderlich - bei deren üblichen Größen im Megabytebereich ein hoffnungsloses Unterfangen, wenn nur die 1,44 MB-Disketten zur Verfügung stehen.

Abhilfe schafft hier eine reduzierte Registry, die nur die Daten der Netzwerkkonfiguration enthält und ca. 20kB groß ist. Voraussetzung für deren Erzeugung ist bei folgender Schritt-für-Schritt-Anweisung ein bereits funktionierender Real-Mode-Net-Zugang einer Normalen Windows-Installation.

  1. Startdiskette erstellen
    Erstellen Sie eine gewöhnliche Startdiskette, z.B. mittels des Windows-Explorers oder mit "FORMAT A: /s"und kopieren Sie ggf. weitere erforderliche Dateien (Speichermanager, deutscher Tastaturtreiber, etc.) in das Windows-Verzeichnis A:\WINDOWS. Im folgenden gehe ich davon aus, dass die nötigsten Startdateien im Wurzelverzeichnis liegen und der ganze Rest im Windows-Verzeichnis.
    Kopieren Sie zusätzlich die für den Real-Mode-Netzwerkzugriff benötigten Programme in das Windows-Verzeichnis auf der Diskette. Dies sind die Dateien NET.EXE, NET.MSG, NETH.MSG, PROTMAN.EXE, PROTMAN.DOS , NDISHLP.SYS und die Konfigurationsdatei PROTOCOL.INI.
    Unter Windows 98 findet man die Dateien Protman.DOS und Protman.exe sowie Ndishelp.sys in der Datei win95_02.cab.
    Zusätzlich benötigen Sie in demselben Verzeichnis den Kartentreiber, der unter dem Registrierungsschlüssel [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net] mit dem Eintrag netcard aufgeführt ist; beispielsweise ist dies für eine 3Com-Netzwerkkarte 3C509 die Datei ELNK3.DOS.
  2. Registry-Netzwerkeinträge exportieren
    Für die "Netzwerk-Registry" müssen zunächst alle Einträge, die mit der Netzwerkkarte, dem Treiber und der Konfiguration zu tun haben, als Text aus der Registry der Windows-Installation mit dem funktionsfähigem Real-Mode-Net exportiert werden. Dies sind die Schlüssel
    [HKEY_LOCAL_MACHINE\Enum\Network]
    [HKEY_LOCAL_MACHINE\Enum\Root\Net]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network] (zwingend erforderlich)
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VREDIR]
    Einige Einträge dieser Schlüssel können sicherlich weggelassen werden; auch einige Schlüssel selbst sind vielleicht nicht immer erforderlich. Mit den oben angeführten Einträgen funktioniert aber IPX sowie NetBIOS .
  3. Eine Minimale Registry-Datei für NWREDIR braucht lediglich die Angaben über die nötigen Dateien und die Konfiguration (bevorzugter Server, erstes Netzlaufwerk, etc.) zu enthalten. An der Größe der binären Registry, die bei 8kBeine untere Grenze zu haben scheint, ändert dies jedoch nichts.
    Laufwerks- und Verzeichnisangaben anpassen
    Damit die Windows-Programme wissen, wo sie nach der Registrydatenbank suchen müssen, ist deren Pfadangabe in der Datei A:\MSDOS .SYS zwingend notwendig. Dies geschieht wie weiter unten gezeigt. Alle weiteren Einträge können erhalten bleiben oder gelöscht werden.
    Registry erzeugen
    Die Registrierungs-Textdatei mit den oben beschriebenen Einträgen können Sie unter reinem DOS in eine binäre Registry mit REGEDIT.EXE umwandeln, beispielsweise mit "REGEDIT.EXE /L:A:\WINDOWS\system.dat /R:A:\WINDOWS\user.dat /C network.reg"
    Dabei wird aus der Textdatei network.reg mit den Registrierungsangaben eine neue binäre Registry im Verzeichnis A:\WINDOWS\ erzeugt.
    Die ebenfalls erzeugte Datei USER.DAT ist nicht erforderlich und kann gelöscht werden.
  4. Nacharbeiten
    Falls Sie bereits den ersten Start- und Netzwerkzugriffsversuch mit der Diskette durchgeführt haben, werden Sie sich vielleicht - wie ich - über die Fehlermeldung von PROTMAN.DOS gewundert haben, die Datei PROTOCOL.INI nicht öffnen zu können (der Parameter /VERBOSE zeigt etwas ausführlichere Fehlermeldungen bei NET.EXE). Bisher habe ich nicht ergründen können, wo PROTMAN.DOS die Datei sucht. Da aber die Pfadangabe \LANMAN\PROTOCOL.INI fest codiert in PROTMAN.DOS enthalten ist, legen Sie PROTOCOL.INI eben dorthin - nun sollte der Netzwerktreiber geladen werden.
    Achten Sie ferner darauf, dass NET.EXE aus dem Disketten-Windows-Verzeichnis heraus aufgerufen wird. (Warum? MS wird's wissen...)
    Abschließende Tests sollten Sie mit im BIOS -Setup abgemeldeter Festplatte durchführen, um sicherzustellen, dass die Programme der Startdiskette nicht doch auf darauf zugreifen. Es ist äußerst hinderlich, dies erst dann festzustellen, wenn der HD-GAU eingetreten ist und kein weiterer Rechner zur Verfügung steht...

Inhaltsverzeichnis Bootdisk mit RM-Netzzugang

Auflistung aller Dateien auf einer Startdiskette, die einen Netzwerkzugriff über eine 3C509-Karte ermöglicht:

A:\AUTOEXEC.BAT | Wird von COMMAND.COM beim Start automatisch ausgeführt: @echo off lh keyb gr,,a:\windows\command\keyboard.sys cd windows rem Fuer Netware-kompatible Netze: "net start nwredir" rem Fuer NetBIOS -Netze: "net start workstation"
A:\CONFIG.SYS | Konfigurationsangaben für IO.SYS; u.a. wird hier der Kommandointerpreter bestimmt: set path=a:\;a:\windows;a:\windows\command device=a:\windows\himem.sys device=a:\windows\emm386.exe noems DOS =high,umb shell=a:\windows\command.com a:\windows /E:512 /P set comspec=a:\windows\command.com country=049,850,a:\windows\country.sys
A:\IO.SYS | Betriebssystem-Kern; Näheres siehe Windows Resource Kit
A:\MSDOS .SYS | Konfigurationsdatei für Windows bzw. NET.EXE: [Paths] WinDir=A:\WINDOWS WinBootDir=A:\WINDOWS HostWinBootDrv=A [Options] BootGUI=0 Network=1
A:\LANMAN\PROTOCOL.INI | Konfigurationsdatei für PROTMAN.EXE; Angaben über Netzwerkkartentreiber und -protokolle, hier für eine 3Com 3C509-Netzwerkkarte: [ELNK3$] DriverName=ELNK3$ IOAddress=0x300 [protman$] priority=ndishlp$ DriverName=protman$ [ndishlp$] DriverName=ndishlp$ Bindings=ELNK3$ [data] version=v4.00.950 netcards=ELNK3$,*PNP80F7 [NETBEUI$] DriverName=NETBEUI$ sessions=10 ncbs=12 Bindings=ELNK3$ Lanabase=0 [nwlink$] DriverName=nwlink$ Frame_Type=4 cachesize=0 Bindings=ELNK3$
A:\WINDOWS\COMMAND.COM | der übliche Kommandozeileninterpreter
A:\WINDOWS\COUNTRY.SYS | landesspezifische Ressourcendatei
A:\WINDOWS\ELNK3.DOS | Real Mode-Netzwerkkartentreiber, abhängig vom Hersteller der Netzwerkkarte
A:\WINDOWS\EMM386.EXE | Speicherverwaltungsprogramm
A:\WINDOWS\HIMEM.SYS | Speicherverwaltungsprogramm
A:\WINDOWS\IFSHLP.SYS | Treiber für installierbare Dateisysteme; wer mit der Fehlermeldung leben kann, kann diese Datei löschen
A:\WINDOWS\KEYB.COM | Tastaturtreiber
A:\WINDOWS\KEYBOARD.SYS | Ressourcendatei für KEYB.COM
A:\WINDOWS\NDISHLP.SYS | Netzwerkunterstützungsprogramm, wird von PROTMAN.EXE geladen
A:\WINDOWS\NET.EXE | Netzwerkprogramm für den Benutzer; näheres siehe NET.EXE /?
A:\WINDOWS\NET.MSG | Ressourcen für NET.EXE
A:\WINDOWS\NETH.MSG | Ressourcen für NET.EXE
A:\WINDOWS\PROTMAN.DOS | Treiber für PROTMAN.EXE
A:\WINDOWS\PROTMAN.EXE | Protokoll-Manager; wird von NET.EXE geladen
A:\WINDOWS\SYSTEM.DAT | verkleinerte binäre Registrydatenbank

Eine Minimale Registry-Datei für den RM-Client NWREDIR:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net]

"transport"="*netbeui,*nwlink,ndishlp.sys"

"netcard"="EL90x.DOS "

"LoadRMDrivers"=hex:00,00,00,00

"preferredredir"="VREDIR"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\Frame_Type]

"default"="4"

"type"="enum"

@="2"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\NDIS]

"LogDriverName"="NWLINK"

"MajorNdisVersion"=hex:03

"MinorNdisVersion"=hex:0a

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\NDIS\NDIS2]

"DriverName"="nwlink$"

"FileName"="*nwlink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]

"PreferredTree"=""

"DefaultContext"=""

"NeighborhoodContext"=""

"SearchMode"=hex:00

"FirstNetworkDrive"=hex:06

"Start"=hex:00

"NetClean"=hex:01

"PreserveCase"="1"

"StaticVxD"="nwredir.vxd"

Datei NETWORK.REG (Beispiel):

REGEDIT4

[HKEY_LOCAL_MACHINE\Enum\Network]

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR]

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0000]

"Class"="NetClient"

"Driver"="NetClient\\0000"

"MasterCopy"="Enum\\Network\\VREDIR\\0000"

"DeviceDesc"="Client für Microsoft-Netzwerke"

"CompatibleIDs"="VREDIR"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0000\Bindings]

"VSERVER\\0003"=""

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0002]

"Class"="NetClient"

"Driver"="NetClient\\0000"

"MasterCopy"="Enum\\Network\\VREDIR\\0000"

"DeviceDesc"="Client für Microsoft-Netzwerke"

"CompatibleIDs"="VREDIR"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0002\Bindings]

"VSERVER\\0001"=""

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0001]

"Class"="NetClient"

"Driver"="NetClient\\0000"

"MasterCopy"="Enum\\Network\\VREDIR\\0000"

"DeviceDesc"="Client für Microsoft-Netzwerke"

"CompatibleIDs"="VREDIR"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VREDIR\0001\Bindings]

"VSERVER\\0004"=""

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0000]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0000\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0001]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0001\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0002]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0002\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0003]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0003\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0004]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0004\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0005]

"Class"="NetService"

"Driver"="NetService\\0000"

"MasterCopy"="Enum\\Network\\VSERVER\\0000"

"DeviceDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"CompatibleIDs"="VSERVER"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\VSERVER\0005\Bindings]

[HKEY_LOCAL_MACHINE\Enum\Network\NETBEUI]

[HKEY_LOCAL_MACHINE\Enum\Network\NETBEUI\0000]

"Class"="NetTrans"

"Driver"="NetTrans\\0001"

"MasterCopy"="Enum\\Network\\NETBEUI\\0000"

"DeviceDesc"="NetBEUI"

"CompatibleIDs"="NETBEUI"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\NETBEUI\0000\Bindings]

"VSERVER\\0002"=""

"VREDIR\\0000"=""

[HKEY_LOCAL_MACHINE\Enum\Network\MSTCP]

[HKEY_LOCAL_MACHINE\Enum\Network\MSTCP\0000]

"Class"="NetTrans"

"Driver"="NetTrans\\0002"

"MasterCopy"="Enum\\Network\\MSTCP\\0000"

"DeviceDesc"="TCP/IP"

"CompatibleIDs"="MSTCP"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\MSTCP\0000\Bindings]

"VSERVER\\0000"=""

"VREDIR\\0002"=""

[HKEY_LOCAL_MACHINE\Enum\Network\NWLINK]

[HKEY_LOCAL_MACHINE\Enum\Network\NWLINK\0000]

"Class"="NetTrans"

"Driver"="NetTrans\\0000"

"MasterCopy"="Enum\\Network\\NWLINK\\0000"

"DeviceDesc"="IPX/SPX-kompatibles Protokoll"

"CompatibleIDs"="NWLINK"

"Mfg"="Microsoft"

"ConfigFlags"=hex:10,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Network\NWLINK\0000\Bindings]

"VREDIR\\0001"=""

"VSERVER\\0005"=""

[HKEY_LOCAL_MACHINE\Enum\Root\Net]

[HKEY_LOCAL_MACHINE\Enum\Root\Net\0000]

"Class"="Net"

"Driver"="Net\\0000"

"DeviceDesc"="3Com EtherLink III ISA (3C509/3C509b) in ISA-Modus"

"CompatibleIDs"="*PNP80F7"

"Mfg"="3Com"

"ConfigFlags"=hex:14,00,00,00

"ForcedConfig"=hex:00,04,00,00,00,00,00,00,20,00,00,00,02,00,00,00,01,00,0c,00,\

00,03,0f,03,00,00,00,03,f0,ff,10,00,00,02,ff,03,00,00,00,03,00,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Root\Net\0000\LogConfig]

"0"=hex:00,04,00,00,00,c0,00,00,20,00,00,00,02,00,00,00,01,00,0c,00,00,00,00,\

00,00,00,00,00,f0,ff,10,00,00,02,ff,03,00,00,00,03,00,00,00,00

[HKEY_LOCAL_MACHINE\Enum\Root\Net\0000\Bindings]

"NWLINK\\0000"=""

"MSTCP\\0000"=""

"NETBEUI\\0000"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network]

"nwmigrate"=hex:03,00,00,00

"Installed"="1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net]

"transport"="*netbeui,*nwlink,ndishlp.sys"

"netcard"="elnk3.DOS "

"LoadRMDrivers"=hex:00,00,00,00

"preferredredir"="VREDIR"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net]

@="Netzwerkkarten"

"Installer"="netdi.dll"

"Icon"="-5"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000]

"DriverDesc"="3Com EtherLink III ISA (3C509/3C509b) in ISA-Modus"

"DevLoader"="*ndis"

"DeviceVxDs"="elnk3.vxd"

"EnumPropPages"="netdi.dll,EnumPropPages"

"IOAddress"=hex:02,00,00,00

"InfPath"="NET3COM.INF"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi]

"DeviceID"="*PNP80F7"

"InstallInf"=""

"InfSection"="*PNP80F7.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\Interfaces]

"DefUpper"="ndis2,ndis3"

"DefLower"="ethernet"

"UpperRange"="ndis2,ndis3,odi"

"LowerRange"="ethernet"

"Upper"="ndis3,ndis2"

"Lower"="ethernet"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\Install]

"ndis3"="elnk3.ndis3"

"ndis2"="elnk3.ndis2"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\params\IOAddress]

"resc"=hex:02,00,00,00

"ParamDesc"="I/O Base Address"

"flag"=hex:30,00,00,00

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\params\MaxTransmits]

"ParamDesc"="Maximum Transmits"

"flag"=hex:30,00,00,00

"type"="int"

"default"="6"

"min"="2"

"max"="50"

"step"="1"

"optional"="1"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\NDIS]

"LogDriverName"="ELNK3"

"MajorNdisVersion"=hex:03

"MinorNdisVersion"=hex:0a

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\NDIS\NDIS2]

"DriverName"="ELNK3$"

"FileName"="elnk3.DOS "

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\NDIS\ODI]

"DriverName"="3C5X9,3c509"

"FileName"="3c5X9.com"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient]

@="Netzwerkclient"

"Installer"="netdi.dll"

"Icon"="-7"

"NoUseClass"="1"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000]

"DriverDesc"="Client für Microsoft-Netzwerke"

"InfPath"="NETCLI.INF"

"DevLoader"="*ndis"

"DeviceVxDs"="vredir.vxd"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000\Ndi]

"DeviceID"="VREDIR"

"NdiInstaller"="netdi.dll,MSClientNdiProc"

"NetworkProvider"="Microsoft Network"

"HelpText"="Der Client für Microsoft-Netzwerke ermöglicht das Verbinden mit anderen Microsoft Windows-Computern und -Servern sowie das Verwenden von Dateien und Druckern, die auf diesen freigegeben sind."

"InstallInf"=""

"InfSection"="VREDIR.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000\Ndi\Interfaces]

"DefUpper"="winnet4,vredir"

"UpperRange"="winnet4,vredir"

"DefLower"="netBIOS ,ipxDHost"

"LowerRange"="netBIOS ,ipxDHost"

"ExcludeAny"="winnet31"

"Upper"="winnet4,VREDIR"

"Lower"="netBIOS ,ipxDHost"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000\Ndi\Install]

@="VREDIR.Install"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000\Ndi\Remove]

@="VREDIR.Remove"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient\0000\Ndi\Default]

@="True"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService]

@="Netzwerkdienst"

"Installer"="netdi.dll"

"Icon"="-8"

"NoUseClass"="1"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000]

"DriverDesc"="Datei- und Druckerfreigabe für Microsoft-Netzwerke"

"InfPath"="NETSERVR.INF"

"DevLoader"="*ndis"

"DeviceVxDs"="vserver.vxd"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi]

"DeviceID"="VSERVER"

"HelpText"="Die Datei- und Druckerfreigabe für Microsoft-Netzwerke ermöglicht das Freigeben von Dateien und Druckern für Windows NT- und Windows für Workgroups-Computer."

"InstallInf"=""

"InfSection"="VSERVER.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\Interfaces]

"DefLower"="vredir,netBIOS ,ipxDHost"

"LowerRange"="vredir,netBIOS ,ipxDHost"

"Lower"="VREDIR,netBIOS ,ipxDHost"

"Upper"=""

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\Compatibility]

"ExcludeAll"="NWSERVER"

"RequireAll"="VREDIR"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\Install]

@="VSERVER.Install"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\Remove]

@="VSERVER.Remove"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\params\MaintainServerList]

"location"="System\\CurrentControlSet\\Services\\Vxd\\VNETSUP"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService\0000\Ndi\params\LMAnnounce]

"location"="System\\CurrentControlSet\\Services\\Vxd\\VNETSUP"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans]

@="Netzwerkprotokoll"

"Installer"="netdi.dll"

"Icon"="-6"

"NoUseClass"="1"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001]

"DriverDesc"="NetBEUI"

"InfPath"="NETTRANS.INF"

"DevLoader"="*ndis"

"DeviceVxDs"="netbeui.vxd"

"lananum"="0"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi]

"DeviceID"="NETBEUI"

"MaxInstance"="8"

"HelpText"="Mit dem Protokoll Microsoft NetBEUI können Verbindungen mit Windows NT-, Windows für Workgroups- oder LAN Manager-Servern hergestellt werden."

"InstallInf"=""

"InfSection"="NETBEUI.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\Interfaces]

"DefUpper"="netBIOS "

"DefLower"="ndis2,ndis3,odi"

"UpperRange"="netBIOS "

"LowerRange"="ndis2,ndis3,odi"

"Upper"="netBIOS "

"Lower"="ndis2,ndis3,odi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\Install]

@="NETBEUI.Install"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\Remove]

@="NETBEUI.Remove"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\params\sessions]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NetBeui"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\params\ncbs]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NetBeui"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\Ndi\Default]

@="True"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\NDIS]

"LogDriverName"="NETBEUI"

"MajorNdisVersion"=hex:03

"MinorNdisVersion"=hex:0a

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0001\NDIS\NDIS2]

"DriverName"="NETBEUI$"

"FileName"="*netbeui"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002]

"DriverDesc"="TCP/IP"

"IPAddress"="192.168.1.1"

"IPMask"="255.255.255.224"

"DefaultGateway"="192.168.1.30,192.168.1.29"

"InfPath"="NETTRANS.INF"

"DevLoader"="*ndis"

"DeviceVxDs"="vtdi.386,vip.386,vtcp.386,vdhcp.386,vnbt.386"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi]

"DeviceID"="MSTCP"

"MaxInstance"="8"

"NdiInstaller"="mstcp.dll,TcpNdiProc"

"HelpText"="Das Microsoft TCP/IP-Protokoll dient zum Herstellen von Internet- und WAN-Verbindungen."

"InstallInf"=""

"InfSection"="MSTCP.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\Interfaces]

"DefUpper"="netBIOS ,tdi,winsock"

"DefLower"="ndis2,ndis3,odi"

"UpperRange"="netBIOS ,tdi,winsock"

"LowerRange"="ndis2,ndis3,odi"

"Upper"="netBIOS ,tdi,winsock"

"Lower"="ndis2,ndis3,odi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\Install]

@="MSTCP.Install"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\Remove]

@="MSTCP.Remove"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\Params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\Params\None]

"ParamDesc"="Kein"

"default"=""

"type"="keyonly"

@=""

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\Ndi\RenameBase]

"file1"="C:\\WIN95\\winsock"

"file2"="C:\\WIN95\\SYSTEM\\winsock"

"file3"="C:\\WIN95\\SYSTEM\\win32s\\winsock"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0002\NDIS]

"LogDriverName"="MSTCP"

"MajorNdisVersion"=hex:03

"MinorNdisVersion"=hex:0a

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000]

"DriverDesc"="IPX/SPX-kompatibles Protokoll"

"InfPath"="NETTRANS.INF"

"DevLoader"="*ndis"

"DeviceVxDs"="nwlink.vxd"

"Network_Id"="0"

"Frame_Type"="4"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi]

"DeviceID"="NWLINK"

"MaxInstance"="8"

"NdiInstaller"="netdi.dll,NwlinkNdiProc"

"StaticVxd"="nwlink.vxd"

"HelpText"="Das IPX/SPX-kompatible Protokoll ermöglicht den Datenaustausch zwischen NetWare-, Windows-NT- und Windows 95-Computern."

"InstallInf"=""

"InfSection"="NWLINK.ndi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\Interfaces]

"DefUpper"="ipx,ipxDHost,winsock"

"DefLower"="ndis2,ndis3,odi"

"UpperRange"="ipx,ipxDHost,winsock"

"LowerRange"="ndis2,ndis3,odi"

"Upper"="ipx,ipxDHost,winsock"

"Lower"="ndis2,ndis3,odi"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\Install]

@="NWLINK.Install"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\Remove]

@="NWLINK.Remove"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\Network_Id]

"flag"=hex:20,00,00,00

"default"="0"

"ParamDesc"="Netzwerkadresse"

"type"="dword"

"base"="16"

@="0"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\Frame_Type]

"ParamDesc"="Rahmentyp"

"default"="4"

"type"="enum"

@="4"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\Frame_Type\enum]

"4"="Auto"

"1"="Ethernet 802.2"

"0"="Ethernet 802.3"

"2"="Ethernet II"

"5"="Token Ring"

"6"="Token Ring SNAP"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\maxconnect]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NWLink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\maxsockets]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NWLink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\forceeven]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NWLink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\params\cachesize]

"location"="System\\CurrentControlSet\\Services\\Vxd\\NWLink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\Ndi\RenameBase]

"file1"="C:\\WIN95\\winsock"

"file2"="C:\\WIN95\\SYSTEM\\winsock"

"file3"="C:\\WIN95\\SYSTEM\\win32s\\winsock"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\NDIS]

"LogDriverName"="NWLINK"

"MajorNdisVersion"=hex:03

"MinorNdisVersion"=hex:0a

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000\NDIS\NDIS2]

"DriverName"="nwlink$"

"FileName"="*nwlink"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink]

"Start"=hex:00

"NetClean"=hex:01

"cachesize"="0"

"StaticVxD"="nwlink.vxd"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\maxconnect]

"ParamDesc"="max. Anzahl Verbindungen"

"optional"="1"

"type"="int"

"min"="1"

"max"="128"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\maxsockets]

"ParamDesc"="max. Anzahl Sockets"

"optional"="1"

"type"="int"

"min"="2"

"max"="255"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\forceeven]

"ParamDesc"="Gleiche Paketgrößen erzwingen"

"optional"="1"

"default"="0"

"type"="enum"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\forceeven\enum]

"0"="Nein"

"1"="Ja"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\cachesize]

"ParamDesc"="Source Routing"

"type"="enum"

"default"="0"

@="0"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink\Ndi\params\cachesize\enum]

"0"="Aus"

"16"="16 Einträge Cache (empfohlen)"

"32"="32 Einträge Cache"

"64"="64 Einträge Cache"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]

"PreferredTree"=""

"DefaultContext"=""

"NeighborhoodContext"=""

"SearchMode"=hex:00

"FirstNetworkDrive"=hex:06

"Start"=hex:00

"NetClean"=hex:01

"PreserveCase"="0"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Ndi]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Ndi\params]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Ndi\params\PreserveCase]

"ParamDesc"="Groß-/Kleinschreibung beibehalten"

"default"="0"

"type"="enum"

@="0"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Ndi\params\PreserveCase\enum]

"0"="Nein"

"1"="Ja"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\ServiceProvider]

"Class"=hex:08,00,00,00

"ProviderPath"="sapnsp.dll"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Parameters]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR\Parameters\Winsock]

"HelperDllName"="sapnsp.dll"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VREDIR]

"Start"=hex:00

"NetClean"=hex:01

"StaticVxD"="vredir.vxd"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]

"InstallType"=hex:03,00

"SetupFlags"=hex:08,01,00,00

"DevicePath"="A:\\win95\\inf"

"ProductType"="2"

"InventoryPath"="A:\\WIN95\\SYSTEM\\PRODINV.DLL"

"SystemRoot"="A:\\win95"

Wenn Sie Zugang zu einem NT-Server haben, können Sie auf diesem eine netzwerkfähige Bootdiskette erstellen.

Weiterhin können Sie von http://www.backmagic.de/download/download.htmdas kostenlose Programm Netboot 1.1 herunterladen, welches Sie bei der Erstellung einer Bootdiskette unterstützt.

Weitere Anleitungen finden Sie hier:

http://www.gerd-roethig.de/DOS net.html

http://www.nu2.nu/bootdisk/

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0459.htm


Das eigene LAN

(Autor: Michael Appelt)

Ein Führer zur Einrichtung eines eigenen Netzes unter Windows 98

In vielen Haushalten befinden sich mittlerweile mehr als ein PC. Was liegt da näher, als diese zu vernetzen? Ein eigenes Netzwerk bringt mehrere Vorteile Z.B. kann man die vorhandenen Geräte wie Drucker, Wechsellaufwerk etc. von mehreren Rechnern aus nutzen, was Neuanschaffungen spart. Selbst ein Internetzugang über Modem oder ISDN lässt sich in einem Netzwerk für alle Rechner realisieren. Zuletzt bringt gerade das Spielen im Netz gegen einen menschlichen Gegenpart ein ganz neues Spielerlebnis.

Die Errichtung eines eigenen Netzwerkes auf kleiner Basis bedarf heute keiner Netzwerk-Profis mir. Alles, was man bei der Einrichtung beachten muss, wird im Folgenden erklärt und sollte für die ersten Schritte ausreichen.

Benötigte Hardware

Als Anschaffung für das eigene Netzwerk werden Netzwerkkarten für jeden Rechner benötigt. Es muss dabei keine "Marken-Karte" sein. Sie sollte nur NE-2000 kompatibel sein. Allerdings sollte man nur noch Karten für den PCI-Steckplatz kaufen, welche mit 100 MBit als Datenübertragungsrate arbeiten. Diese 10/100 MBit-Karten können auch mit langsamen 10 MBit-Karten kommunizieren, allerdings dann nur mit dieser Geschwindigkeit.

Die Verkabelung bereitet den Anfängern noch immer die größten Probleme. Die früher üblichen BNC-Verkabelungen werden heute immer mehr durch Twisted-Pair-Kabel ersetzt. Da diese, im Gegensatz zu BNC-Kabeln, nicht in Reihe geschaltet werden können, ist normalerweise ein Hub nötig, welcher als "Kreuzung" zwischen allen Rechnern fungiert.

Jeder Rechner wird am Hub angeschlossen. Sollte ein Rechner ausfallen, ist davon jedoch nicht das gesamte Netzwerk betroffen. Hubs mit 5 Ports (Anschlüsse für Rechner) sollten 100 MBit-Ausführungen haben.

Wer nur 2 Rechner vernetzen möchte, kann auf einen Hub verzichten und dafür ein Cross-Connect-Kabeleinsetzen.

Ab dem dritten Rechner wird aber ein Hub notwendig. Ein 100 MBit-Hub kann allerdings nur dann auch Kontakt zu langsamen 10MBit-Karten aufnehmen, wenn der Hub für jeden Port die Geschwindigkeit separat einstellen kann.

Einrichtung des Betriebssystems

Für den normalen Hausgebrauch oder zum Spielen braucht man keinen eigenen Server auf Windows NT-Basis. Hier reicht Windows 9x als Betriebssystem völlig aus.

Nach dem Einbau der Netzwerkkarten installiert Windows in der Regel einige Komponenten nach. Die Schaltzentrale für das Netzwerk verbirgt sich dann in der Systemsteuerung unter Netzwerk. Hier sollten als Netzwerkkomponenten mindestens eingetragen sein:

"Client für Microsoft Netzwerke",

"Netzwerkkarte",

"TCP/IP->Netzwerkkarte".

Letzteres wird als Bindung bezeichnet und beschreibt, welches Protokoll für welches Gerät benutzt wird. Sollte die Bindung "TCP/IP->Netzwerkkarte" nicht vorhanden sein, kann man diese unter den Eigenschaften der Netzwerkkarte aktivieren. Andere Netzwerkprotokolle wie NetBEUI oder IPX/SPX werden in der Regel nicht benötigt. Solche Bindungen können daher gelöscht werden.

Damit die Rechner wechselseitig auch auf Dateien und Drucker des anderen zugreifen können, muss der Dienst "Datei- und Druckerfreigabe" installiert sein. Sollte dieser fehlen, kann er über "Hinzufügen", "Dienst" installiert werden. Für den Zugriff auf Dateien und Drucker des jeweiligen Rechners muss dies unter dem Button "Datei- und Druckerfreigabe" ausdrücklich aktiviert werden.

Die meisten der Einträge unter "Netzwerk" bieten noch weitere Optionen und Einstellungen, welche sich unter dem Button "Eigenschaften" verbergen, wenn man einen Eintrag selektiert hat. Hier können noch einige Änderungen vorgenommen werden, damit das Netz optimal läuft.

Die Bindung "TCP/IP->Netzwerkkarte" zeigt unter ihren Eigenschaften eine Fülle von Registerkarten.

Von besonderer Bedeutung ist hier die Registerkarte IP-Adresse. Da kein NT-Server im Netz vorhanden ist, muss jeder Rechner eine eigene IP-Adresse bekommen. Für private C-Netzwerke sind folgende IP Adressen zulässig: 192.168.0.1 bis 192.168.255.254. Die dritter Ziffer kann frei gewählt werden, muss aber für alle Rechner im Netz gleich sein, z.B. 192.168.100.100 für Rechner 1, 192.168.100.101 für Rechner 2, SubnetMask 255.255.255.0.

Sofern der Rechner fürs Internet benutzt wird, ist auch eine Bindung "TCP/IP->DFÜ-Adapte r" vorhanden. Bei dieser "Bindungen" muss darauf achten, dass unter den Eigenschaften bei "Client für Microsoft Netzwerke" und "Datei- und Druckerfreigabe" keine Auswahl vorhanden ist. Diese Sicherheitslücke würde es einem Hacker erlauben, auf das Dateisystem des Rechners zuzugreifen, wenn dieser gerade im Internet ist.

Zuletzt muss bei "Netzwerk" unter der Registerkarte "Identifikation" der jeweilige Rechnername und die Arbeitsgruppe angepasst werden. Wichtig ist hierbei, dass die Arbeitsgruppe beider Rechner übereinstimmen und gleichlautend sind, damit sich diese im Netz gegenseitig finden.

Hat man die beschriebenen Einstellungen auf beiden Rechnern vorgenommen, ist das Netzwerk einsatzbereit. Unter dem Symbol "Netzwerkumgebung" auf dem Desktop sollte nach einem Neustart beider Rechner der jeweils andere Rechner angezeigt werden.

Ist dies nicht der Fall, sollte man noch einmal die Vergabe der IP-Adressen und Arbeitsgruppe überprüfen. Möglich wäre auch ein Problem bei der Aushandlung der Verbindungsgeschwindigkeit. Diese kann man ggf. auch manuell unter den Eigenschaften der Netzwerkkarte bei "Erweitert" festlegen. Die automatische Aushandlung scheitert oft, wenn ein Hub eingesetzt wird. Optional sollte man daher die Verbindungsgeschwindigkeit auf 100 Half-Duplex schalten.

Damit man die Ressourcen des anderen Rechners auch nutzen kann, müssen hierfür Freigaben erfolgen. Im Kontextmenü eines jeden Ordners, Laufwerks oder Druckers erscheint hier das Menü "Freigabe". Neben dem Freigabe-Namen legt man hierüber auch die Zugriffsbeschränkung durch Kennwörterfest.

Greift ein anderer Rechner auf diese Ressource zu, verlangt Windows das entsprechende Kennwort, welches gespeichert werden kann. Eine Beschränkung auf Benutzerebene wie Windows NT / 2000 kennt Windows 9x nicht. Aus diesem Grund kann man auf Freigaben eines NT-Rechners nur zugreifen, wenn der Benutzername des Windows 9x-Rechners in der Benutzerdatenbank des NT-Rechners eingetragen ist. Das abgefragte Kennwort ist dann das vergebene Login-Kennwort auf dem NT-Rechner.

Freigegebene Ordner und Laufwerke können über das Kontextmenü auch verbunden werden, d.h. Sie bekommen einen Laufwerksbuc hstaben und erscheinen als Netzwerk-Laufwerk im Explorer und Arbeitsplatz und damit auch in den Dialogboxen "Öffnen" und "Speichern" aller Applikationen.

Sind nicht beide Rechner gleichzeitig angeschaltet, werden verbundene Laufwerke beim Start als nicht vorhanden moniert. Dieses Verhalten kann man unter "Eigenschaften" des "Clients für Microsoft Netzwerke" abschalten, indem man bei Netzwerkanmeldeoptionen "Schnelle Anmeldung" selektiert. Verbundene Laufwerke werden dann erst bei deren Zugriff auf Verfügbarkeit hin überprüft.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0980.htm


IP-Adresse ermitteln

Für einige Aktionen muss man die aktuelle IP-Adresse wissen. Gerade bei Providern, die eine dynamische Vergabe der IP-Adresse vornehmen, bekommt man jedesmal eine neue IP-Adresse und kann somit vom Provider nicht die Information der IP-Adresse bekommen.

Unter Windows gibt es aber ein Tool, welches zu jeder Verbindung die IP-Adresse anzeigt:

Windows 95/98: WINIPCFG.EXE

Ab Windows NT: IPCONFIG.EXE

Mit diesen Tool erhalten Sie alle benötigten Informationen. Unter Windows NT werden die Informationen aber nur in einer Kommandozeile angezeigt.

Mit dem Befehl NBTSTAT.EXE bekommen Sie alle Informationen über NetBIOS -Verbindungen angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0730.htm


MTU-Größe bei Slip-Treibern anpassen

MTU- Größe bei Slip-Treiber anpassen (DFÜ-Geschwindigkeit)

Bei Windows werden für die Parameter der DFÜ-Übertragung Standardeinstellungen verwendet, die in den meisten Fällen nicht gerade optimal eingestellt sind.

Wenn Sie diese Parameter anpassen, können Sie bessere Übertragungsgeschwindigkeiten erzielen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

MTU (Maximum Transmission Unit)

Mit diesem Wert legen Sie die Bytes pro Datenpaket fest. Windows arbeitet hier mit einem Standardwert von 1500 Byte. Die meisten Internetanbieter arbeiten aber oft Mit diesem Wert von 576 Byte.

Wenn Sie zu Ihrem Internetanbieter eine Verbindung aufbauen, wird der jeweils kleinste MTU-Wert für die Verbindung benutzt. Wenn Ihr System auf einen größeren Wert eingestellt ist, muss der Router die Datenpakete extra teilen und extra weiterleiten, was die Verbindung erheblich ausbremst. Sie sollten daher immer versuchen den gleichen Wert wie die Gegenstelle zu benutzen (meist 576).

HKEY_LOCAl_MACHINE\ System\ CurrentControlSet\ Services\ Class\ NetTrans\ 000x.

Es könnte 0001, 0002, oder eine höhere Zahl sein (wenn auch andere Netzwerktreiber installiert sind). Jedenfalls muss in dem Schlüssel "DriverDesc" der Wert auf "TCP/IP" stehen. Fügen Sie nun, je nachdem welche Werte Sie anpassen wollen, die erforderlichen Einträge hinzu:

Schlüsselname | Datentyp | Wert
MaxMTU | REG_SZ | <siehe Tabelle>
MaxMSS | REG_SZ | <siehe Tabelle>

HKEY_LOCAl_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Net\ 000x

Schlüsselname | Datentyp | Wert
IPMTU | REG_SZ | <siehe Tabelle>

Den Defaultwert können Sie hier einstellen:

HKEY_LOCAl_MACHINE\ System\ CurrentControlSet\ Services\ VXD\ MSTCP

Schlüsselname | Datentyp | Wert
DefaultMSS | REG_SZ | <siehe Tabelle>

Empfehlungen:
576 | für Analoge Verbindungen
1500 | für ISDN (Windows Standard)
1492 | für DSL
3000 | DSL / LAN

Sie können den Wert aber auch selber ganz genau überprüfen, gehen Sie dazu folgendermaßen vor:

  1. Bauen Sie eine Verbindung zu Ihren Provider auf
  2. Ermitteln Sie über „winipcfg“ (9x und ME) oder „ipconfig“ (NT,2000,XP) in der Kommandozeilenoberfläche Ihre Adresse zum Standard-Gateway des Providers (es handelt sich um en Adapter der mit PPP-Adapter beginnt).
  3. Führen Sie nun einen PING zum Provider mit folgendem Befehl durch:
    ping -f -l 600 <Standard-Gateway>
  4. Bei diesem Wert sollte noch kein Fehler auftreten, und Sie müssen eine entsprechende Rückantwort bekommen, ansonsten haben Sie eine falsche Adresse für das Standard-Gateway ermittelt.
  5. Erhöhen Sie jetzt den Wert 600 bis Sie die Fehlermeldung „Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt. Jetzt müssen Sie genau den Wert benutzten, wo noch kein Fehler aufgetreten ist, dass ist denn der Wert für die max. MTU (MaxMTU) Größe.

RWIN (max. Datenlänge)

Hiermit legen Sie die Datenmenge fest, die gesendet wird, bevor der Server auf eine Empfangsbestätigung wartet. Windows benutzt hier einen Standardwert von 8192 Byte, der bei Internetverbindungen eher als ungünstig zu bezeichnen ist.

Da hier häufig Übertragungsfehler auftreten, ist ein kleinerer Wert besser. Zur Berechnung des Wertes sollte man sich an dem MTU-Wert orientieren, die Formel lautet: (MTU-40)*4. Den Multiplikator erhöhen Sie dann solange, bis die optimale Einstellung gefunden ist.

HKEY_LOCAl_MACHINE\ System\ CurrentControlSet\ Services\ VXD\ MSTCP

Schlüsselname | Datentyp | Wert
DefaultRcvWindow | REG_SZ | <siehe Tabelle>

Empfehlungen:
(MTU-40) * 4 | für Analoge Verbindungen
(MTU-40) * 6 | für schnelle Analoge und ISDN
(MTU-40) * 8 | für ISDN Verbindungen
32767 | DSL / LAN

TTL (Time to Live)

Dieser Wert bestimmt die Lebensdauer eines Datenpakets über verschiedene Stationen hinaus. Der Windows Standardwert liegt bei 32 Stationen. Da das Internet aber schon sehr groß ist, sind Werte über 100 als sinnvoll anzusehen. Die Änderung dieses Wertes bringt aber keinen spürbaren Geschwindigkeitsvorteil.

HKEY_LOCAl_MACHINE\ System\ CurrentControlSet\ Services\ VXD\ MSTCP

Schlüsselname | Datentyp | Wert
DefaultTTL | REG_SZ | <siehe Tabelle>

Empfehlungen:
128 | für Analoge Verbindungen
64 | für ISDN/ADSL Verbindungen
32 | Windows Standard

Info Die Einstellungen sind erst nach einem Neustart aktiv.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=120642

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0229.htm


Namensauflösung über Windows Sockets

Unter "Bedeutung der Node-Types" wird beschrieben, in welcher Reihenfolge die Namensauflösung bei Anwendungen läuft, die über NBT arbeiten.

Bei Anwendungen, die eine Namensauflösung über Windows-Sockets durchführen, sieht die Reihenfolge ganz anders aus.

  1. Als erstes wird überprüft, ob der Clientname der eigene Name ist
  2. Dann wird der Name in der lokalen HOSTS-Datei gesucht
  3. Wurde er da nicht gefunden , wird eine Anfrage an den DNS-Server gesendet
  4. Als letztes wird versucht, die Namensauflösung über NetBIOS durchzuführen.

Wenn es in Ihrem Netzwerk keinen DNS-Server gibt, kann es sinnvoll sein die Reihenfolge zu ändern und erst eine Namensauflösung über NetBIOS durchführen zu lassen. Ansonsten wird erst auf einen Timeout des DNS-Servers gewartet, bevor über NetBIOS versucht wird, den Namen aufzulösen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Service\ Tcpip\ Parameters

Finden Sie den Eintrag "DnsNbtLookupOrder". Wenn Sie diesen Wert auf 1 setzen, wird erst versucht, über NetBIOS die Namensauflösung durchzuführen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0848.htm


Laufzeiten im Netz ermitteln

Mit den Befehl "TRACERT" an der Eingabeaufforderung können Sie Laufzeiten einer Online-Internetverbindung und die daran beteiligten Server anzeigen lassen. Angezeigt wird eine sog. Routingtabelle mit Laufzeiten.

Usage: tracert [-d] [-h Abschnitte_max] [-j Host-Liste] [-w Timeout] Zielname

Optionen:

-d | Adressen nicht zu Host-Namen auswerten
-h Abschnitte_max | max. Anzahl an Abschnitten (Hops) bei Zielsuche
-j Host-Liste | "Loose Source Route" gem. Host-Liste
-w Timeout | Timeout in Millisekunden für eine Antwort

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0344.htm


Bedeutung der "Node-Types"

Der Node-Type entscheidet über die Art und Weise, in der "NetBIOS name resolution" (Namensauflösung) betrieben wird, d.h. wie die für "NetBIOS over TCP/IP" nötigen Mappings vom Computernamen auf IP-Adressen erstellt werden.

B-Node:

Benutzt Broadcast, d.h. PC A fragt alle Rechner im Netz, ob einer von ihnen PC B ist. Das erzeugt bei großen Netzen viel überflüssigen Traffic und funktioniert vor allem nicht, wenn Netz-Segmente durch Router verbunden sind, weil diese in allgemeinen keine Broadcasts durchlassen.

P-Node:

Benutzt WINS als NetBIOS Name Server, was auch über Router hinweg funktioniert. P-Nodes erzeugt keine Broadcasts und antwortet auch nicht auf diese. Das bedeutet natürlich, dass sich alle Rechner beim WINS registrieren und ihn finden müssen und dass bei einem Ausfall des WINS-Servers kein Rechner mehr den anderen findet.

M-Node:

Kombiniert B-Node und P-Node, indem zuerst versucht wird, einen Rechner per Broadcast zu finden und dann per P-Node. Das hat den Vorteil, dass bei defektem WINS-Server zumindest im lokalen Segment gearbeitet werden kann.

H-Node:

Ist ebenfalls eine Kombination von B-Node und P-Node, aber anders herum. Starten: Es wird erst versucht, den WINS zu befragen. Wenn das fehlschlägt, wird ein Broadcast erzeugt.

Vorteil: solange WINS läuft, werden keine Broadcasts erzeugt und da für jeden Query zuerst ein P-Node Request erzeugt wird, hören die Broadcasts sofort wieder auf, wenn der WINS Server wieder da ist.

Die letzte Möglichkeit für kleine Netze mit Router ist B-Node mit LMHOST. Hier wird erst ein Broadcast erzeugt und dann im LMHOST nach der Adresse gesucht.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0404.htm


Wer wird der Master Browser?

Der Computerbrowser verwaltet eine aktuelle Liste mit Computern in Ihrem Netzwerk und liefert diese Liste an Programme, die sie anfordern. Die Funktion wird in einem Windows Netzwerk benötigt, da z.B. der NET Befehl und der Explorer auf diese Liste zugreifen. Wenn der Dienst nicht aktiv ist, kann Windows keine Rechner und Ressourcen im Netzwerk anzeigen.

Unter Windows gibt es verschiedene Rollen eines Browsers:

Domain Master Browser:

Diesen Browser gibt es nur ein einer Domäne. Der PDC (Primary Domain Controller) hat standardmäßig diese Rolle für die entsprechende Domäne. Hier werden alle Namen der Server und Domänen gesammelt und verwaltet und synchronisieren die Listen mit den „Master Browsern“.

Master Browser:

Erstellt, Pflegt und synchronisieren die Liste der Server in einem Subnetz. Diese Liste wird mit dem „Domain Master Browser“ abgeglichen und an die Backup-Browser im Netzwerk verteilt.

Backup Browser:

Hält eine Kopie der Liste vom "Master Browser" und verteilt sie an andere Computer. Er selber erstellt und pflegt aber keine eigene Liste.

Potential Browser:

Arbeitet nur als „Backup Browser“ wenn er vom „Master Browser“ dazu angewiesen wird. Hat ansonsten die gleichen Aufgaben wie ein „normaler Rechner“.

Normaler Rechner:

Diese Rechner sind keine Browser und sind so konfiguriert, das sie auch nicht diese Rolle bekommen können. Diese Rechner fordern bei bedarf eine entsprechende Liste vom Browser an.

In gemischten Domänen, in denen sich auch Windows 3.x und Windows 95 Rechner befinden, versuchen diese Rechner immer wieder, zu einem Domain-Master-Browser zu werden. Dies wird zwar abgelehnt, erhöht aber die Netzwerklast unnötig.

Sie können es an den jeweiligen Rechnern ausstellen:

Bei Windows 3.x:

SYSTEM.INI

[Network]

MaintainServerList=No

Bei Windows 95:

-> "Systemsteuerung" -> "System" -> "Netzwerk", dort unter -> "Die folgenden Netzwerk Komponenten sind installiert" -> "Datei- und Druckerfreigabe für Microsoft-Netzwerke" anklicken und unter -> "Eigenschaften" die -> "Suchfunktionen" auf "Deaktiviert" setzen.

Ab NT/2000:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Browser\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Rechner wird Browser. Beim Start versucht er, einen Masterbrowser zu finden, wird keiner gefunden , wird eine Wahl veranlasst.
MaintainServerList | REG_SZ | Boolean oder Auto | WS = Auto Server = Auto
Dieser Wert gibt bei TCP/IP an ob die Arbeitsstation in die globale LMHOST-Datei eingetragen werden kann. Wird der Wert auf 1 gesetzt, erhöht sich die Priorität des Rechners für den Suchdienst. Sie sollten den Wert auf einigen Rechnern in der Arbeitsgruppe auf 1 einstellen mit einer Zuordnung in der globalen LMHOST-Datei. Dadurch wird die Suche beschleunigt, wenn einige Rechner für den Hauptsuchdienst zuständig sind.
IsDomainMasterBrowser | REG_SZ | Boolean | 0

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0041.htm


Einstellungen für das SPX-Protokoll verändern

Für den Zugriff auf Novell-Netzwerk wird oft noch das Protokoll SPX unter Windows mit installiert. Veränderungen an diesen Protokolleinstellungen können Sie unter Windows 95/98 noch über die "Systemsteuerung" -> "Netzwerk" -> "Eigenschaften" -> "IPX 32-bit Protocol for the Novell Intranetware Client" -> "Eigenschaften" -> "SPX" vornehmen.

Unter Windows NT wurden diese Einstellungsmöglichkeiten weggelassen. Über die Registry können Sie diese Werte aber auch hier noch konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System \CurrentControlSet \Services \NwLnkIpx \Parameters

Schlüssel | Datentyp | Angabe als | Standard
Hiermit stellen Sie ein wie oft versucht wird, eine Verbindung aufzubauen, bevor ein Fehler ausgegeben wird.
ConnectionCount | REG_DWORD | Zahl (1 - 65535) | 10
Legt die Zeitspanne zwischen jedem "ConnectionCount" fest
ConnectionTimeout | REG_DWORD | 1/2 Sekunden (1 - 65535) | 2 (entspricht 1 Sekunde)
Bei 1 wird dieser Computer als dedizierter Router definiert
DedicatedRouter | REG_DWORD | Boolean | 0
Legt fest, wie oft Keep-Alive Test gesendet werden sollen, bevor ein Fehler ausgegeben wird
KeepAliveCount | REG_DWORD | Zahl (1 - 65535) | 8
Zeitspanne, bevor eine geprüft wird, ob die SPX-Verbindung noch besteht
KeepAliveTimeout | REG_DWORD | 1/2 Sekunden (1 - 65535) | 12 (entspricht 6 Sekunden )
Legt die Zeit fest, wann eine RIP-Aktualisierung für den RIP-Cache der Computer im Netzwerk durchgeführt werden soll.
RipAgeTime | REG_DWORD | Minuten (1 - 65535) | 5
Gibt an, wie lange ein Weg durch das Netzwerk gesucht werden soll, bevor eine Fehlermeldung erscheint.
RipCount | REG_DWORD | Zahl (1 - 65535) | 5
Legt fest, ab welcher Zeit es bei "RipCount" zu einer Zeitüberschreitung kommen soll
RipTimeout | REG_DWORD | 1/2 Sekunden (1 - 65535) | 1 (entspricht 0,5 Sekunden )
Legt fest, wie viele Empfangsstationen zum Empfang von Daten bereitstehen.
WindowSize | REG_DWORD | 1 - 10 IPX-Pakete | 4

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0476.htm


NetBIOS-Computernamen und ihr Aufbau

NetBIOS-Namen sind immer 16-Zeichen lang. Unter Windows dürfen Sie aber nur die ersten 15-Zeichen für einen Computernamen verwenden. Das 16. Zeichen benutzt Windows, um den Typ festzulegen.

Hier eine Auflistung einiger wichtiger Typen:

NetBIOS Name (15 Zeichen) | 16 Zeichen | Typ | Bedeutung
Computername | 00 | U | Workstation Service
Domainname | 00 | G | Domain Name
IS~Computername | 00 | U | IIS
Computername | 01 | U | Messenger Service
\\--__MSBROWSE__-- | 01 | G | Master Browser
Computername | 03 | U | Messenger Service
Username | 03 | U | Messenger Service
Computername | 06 | U | RAS Server Service
Domainname | 1B | U | Domain Master Browser
Domainname | 1C | G | Domain Controllers
INet-Service | 1C | G | IIS
Domainname | 1D | U | Master Browser
Domainname | 1E | G | Browser Service Elections
Computername | 1F | U | NetDDE Service
Computername | 20 | U | File Server Service
Forte_$ND800ZA | 20 | U | DCA Ireinmalan Gateway Server Service
Computername | 21 | U | RAS Client Service
Computername | 22 | U | MS Exchange (Mail Connector)
Computername | 23 | U | MS Exchange Store
Computername | 24 | U | MS Exchange Directory
Computername | 2B | U | Lotus Notes Server Service
IRSMULTICAST | 2F | G | Lotus Notes
Computername | 30 | U | Modem Sharing Server Service
Computername | 31 | U | Modem Sharing Client Service
IRSMULTICAST | 33 | G | Lotus Notes
Computername | 43 | U | SMS Client Remote Control
Computername | 44 | U | SMS Administrator Remote Control
Computername | 45 | U | SMS Client Remote Chat
Computername | 46 | U | SMS Client Remote Transfer
Computername | 4C | U | DEC Pathworks TCPIP Service
Computername | 42 | U | McAfee Antivirus
Computername | 52 | U | DEC Pathworks TCPIP Service
Computername | 87 | U | MS Exchange MTA
Computername | 6A | U | MS Exchange IMC
Computername | BE | U | Network Monitor Agent
Computername | BF | U | Network Monitor Application

Computername, Domainname und Username sind durch die entsprechenden Namen zu ersetzen.

Folgende unterschiedliche Typen gibt es:

Typ | Beschreibung
U | Dieser Typ besitzt nur eine IP-Adresse
G | Dieser Typ besitzt mehr als eine IP-Adresse

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1064.htm


Hand unter den Freigaben entfernen

Standardmäßig blendet Windows unter freigegebenen Verzeichnissen eine Hand ein, damit im Explorer die Freigabe leichter erkannt wird. Eigentlich ist es aus meiner Sicht auch nicht sehr sinnvoll, das zu ändern. Wollen Sie aber dieses Freigabezeichen nicht oder ein anderes, können Sie das an folgender Stelle verändern

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Network\ SharingHandler

Gehen Sie auf den Eintrag "(Standard)" als Datentyp REG_SZ und ändern hier den Wert.

Wenn Sie z.B. den Eintrag löschen und nichts angeben, wird die Freigabe nicht mehr angezeigt. Standardmäßig ist hier folgendes eingetragen:

Windows 9x/ME: | msshrui.dll
ab Windows NT: | ntshrui.dll

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1121.htm


Freigaben ab Windows XP werden unter Windows 9x nicht angezeigt

Wenn Sie Freigaben ab Windows XP erstellen, können die Freigabenamen mehr als 12 Zeichen enthalten.

Das hat aber den Nachteil, dass diese Freigaben unter anderen Betriebssystemen nicht mehr angezeigt werden, da diese nur mit Freigaben umgehen können, die nicht länger als 12 Zeichen sind. Sie sollten darum lieber auf Freigabenamen, die länger als 12 Zeichen sind, verzichten.

Weiterhin sollten Sie keine Umlaute, Sonderzeichen oder Leerzeichen in den Freigabenamen verwenden, da diese ebenso Probleme verursachen können.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1352.htm


Der Netzwerkkarte mehr als eine IP-Adresse zuweisen

Über das Konfigurationsdialog der Netzwerkkarte können Sie nur eine IP-Adresse ihrer Netzwerkkarte zuweisen. Wenn Sie aber mehr als eine Netzwerkadresse benötigen, können Sie das direkt in der Registry erledigen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ NetTrans\ 0000

hier finden Sie die Einträge IPAdress und IPMask, wo die aktuelle Konfiguration Ihrer Netzwerkkarte hinterlegt ist.

Sie können hinter jedem Eintrag jetzt einen weiteren hinzufügen. Dafür fügen Sie hinter dem aktuellen Eintrag ein Komma ein und geben dann die weitere Netzwerkadresse an z.B.: 192.168.0.10,192.168.118.2.

Danach müssen Sie den Rechner neustarten, damit die Einstellungen geladen werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1577.htm


Verknüpfungen werden auf anderen Netzwerkrechner ausgeführt bzw. Mappen automatisch Laufwerke

Verknüpfungen (Links) werden auf anderen Netzwerkrechner ausgeführt

In Ihrem Profil können Sie Verknüpfungen (z.B. auf dem Desktop) ablegen, um schneller auf Programme zugreifen zu können. Verknüpfungsdateien enthalten einen absoluten Pfad zur Originalzieldatei und einen relativen Pfad zu der aktuellen Zieldatei.

Wenn Sie ein Standardprofil erstellen, welches Sie dann anderen Netzwerkanwendern zuweisen wollen, müssen Sie diese Verknüpfungsdateien (*.LNK) noch bearbeiten, da es sonst zu folgendem Fehler kommt:

Bei einem Klick auf die Verknüpfung wird die Datei nicht auf dem jeweiligen Rechner ausgeführt, sondern es wird versucht, die Datei auf dem Rechner auszuführen, auf dem die Verknüpfung ursprünglich erstellt wurde. Dieses geschieht, da Windows in der Verknüpfungsdatei den Pfad zur Anwendung als UNC-Pfad speichert. Dieser UNC-Pfad enthält zusätzlich zur Laufwerksangabe auch den Rechnernamen (Beispiel: \\Rechnername\c:\Programme\.....)

Um den Rechnernamen aus dem UNC-Pfad zu entfernen, können sie folgende Programme verwenden:

SHORTCUT.EXE aus dem Windows NT 4.0 Resource Kit

SCUT.EXE gibt's als Freeware bei http://www.jsifaq.com/SF/Tips/Tip.aspx?id=0422

Wollen Sie die LNK-Dateien nicht bearbeiten, können Sie auch in der Registry einstellen, dass UNC-Angaben in den Verknüpfungen nicht beachtet werden und immer der relative Pfad benutzt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "LinkResolveIgnoreLinkInfo" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es wird nur noch der relative Pfad benutzt
gelöscht | Es wird mit dem Originalpfad gearbeitet (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Shellshortcuts beim Zwischenspeichern auf den Server nicht überwachen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Wenn Sie diesen Key aktiveren, werden Netzwerkverbindungen auch nicht mehr eigenmächtig wieder von Windows hergestellt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0822.htm


Gesamtes Netzwerk aus der Netzwerkumgebung ausblenden

Mit dieser Policy können Sie den Eintrag "Gesamtes Netzwerk" aus der Netzwerkumgebung ausblenden.

Wenn Sie den Tipp aktivieren, werden alle Computer, die nicht zu der Arbeitsgruppe oder lokalen Domäne des Benutzers gehören, entfernt, Diese Einstellung verhindert das Anzeigen und die Verbindungsherstellung zu anderen Computern in der Arbeitsgruppe oder Domäne des Benutzers nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoEntireNetwork" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Symbol "Gesamtes Netzwerk" nicht in "Netzwerkumgebung" anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1469.htm


Das Netzwerkicon vom Desktop entfernen

Mit dieser Policy blenden Sie das Netzwerkicon aus, und es wird kein Icon mehr auf dem Desktop und im Explorer angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetHood" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1490.htm


Arbeitsgruppen im Netzwerk nicht anzeigen

Mit dieser Policy blenden Sie das Netzwerkicon aus, und es wird kein Icon mehr auf dem Desktop und im Explorer angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoWorkgroupContents" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1491.htm


Datei und Druckerfreigabe entfernen

Mit dieser Policy legen Sie fest, dass keine Datei- und Druckerfreigaben mehr angezeigt und erstellt werden können. Bereits erstellte Freigaben bleiben erhalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileSharingControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Datei- und Drucker können nicht mehr freigegeben werden
0 | Datei- und Drucker können freigeben werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1487.htm


Dateifreigaben sperren

Mit dieser Policy können Sie alle Dateifreigaben sperren. Damit ist es nicht mehr möglich, neue Dateifreigaben zu erstellen und bereits erstellte Dateifreigaben werden deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileSharing" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Deaktiviert die Freigaben
0 | Freigabe sind möglich (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1493.htm


Icon für Netzwerksteuerung aus der Systemsteuerung entfernen

Mit dieser Policy wird das Icon zur Netzwerksteuerung in der Systemsteuerung deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetSetup" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
0 | Eintrag ist vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1495.htm


Netzwerkkennung und Identifikationseinstellung entfernen

Mit dieser Policy wird die Möglichkeit entfernt die Netzwerkkennung "Identifikation" (Computername, Domänenzugehörigkeiten usw.) zu verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetSetupIDPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
0 | Eintrag ist vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1496.htm


Zugriffssteuerung aus der Netzwerkumgebung entfernen

Mit dieser Policy entfernen Sie den Registereintrag "Zugriffssteuerung" aus der "Systemsteuerung" -> "Netzwerk".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetSetupSecurityPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
0 | Eintrag ist vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1497.htm


Dial-In Funktion deaktivieren

Mit dieser Policy wird die Dial-In Funktion deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDialIn" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
0 | Eintrag ist vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1498.htm


Timeout Einstellung verändern

Timeout Einstellung des Modems verändern

Wenn eine gewisse Zeit nichts passiert, trennt Windows automatisch die Verbindung. Diese Timeout-Zeit können Sie selber in Windows nicht einstellen. In der Registry können Sie diesen Wert aber verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

unter Windows 9x / ME:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Modem\ xxxx\ Settings

xxxx steht für die Nummer Ihres Modems, meist 0001

ab Windows NT:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Class\ {4D36E96D-E325-11CE-BFC1-08002BE10318}\ xxxx\ Settings

{4D36E96D-E325-11CE-BFC1-08002BE10318} ist die ID Ihres Modems/ISDN

xxxx steht für die Nummer Ihres Modems, meist 0001

hier finden Sie den Eintrag "InactivityTimeOut" als Datentyp REG_SZ.Geben Sie hier die Zeit in Sekunden an, wann eine Verbindung automatisch getrennt werden soll.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base (9x/ME): http://support.microsoft.com/?kbid=138634

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base (NT/2000): http://support.microsoft.com/?kbid=164257

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1044.htm


Übermittlung der MSN bei Verbindungsaufbau

Mit Hilfe des Register S49 können Sie die im D-Kanal übermittelte Rufnummer setzen, wenn Sie die Signalisierung der Rufnummer nicht ausdrücklich beim Netzbetreiber deaktiviert haben lassen. Wenn keine Angabe erfolgt, wird bei einem DSS1-Basisanschluss (Euro-ISDN) die erste MSN aus dem zugewiesen Rufnummernblock gesendet.

Mit dem AT-Befehl S49=<Rufnummer> kann eine spezielle Rufnummer gesetzt werden.

Beachten Sie bitte, dass diese Rufnummer nicht willkürlich gewählt werden kann. Es muss eine Rufnummer aus dem Rufnummernblock sein, der Ihnen vom Netzbetreiber (Telekom) zugewiesen wurde (3 MSN bei Standard- und Komfortanschluss). Wenn Sie eine ungültige MSN Eintragen, wird diese automatisch durch die Vermittlungsstelle ersetzt. Die Einstellungen werden unter Systemsteuerung, Modems, passendes CAPI Modem, Eigenschaften, Einstellungen, Erweitert vorgenommen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0918.htm


TDSL Zugang über DFÜ-Netzwerk

Besitzer der neuen ADSL-Technik der Telekom fragen sich sicherlich, ob eine Einwahl ins Internet auch ohne die T-Online-Software möglich is?

Die T-Online-Software 2.5 für ADSL (oder höher) müssen Sie installieren, damit auch der PPPoE-Treiber (WinPoET) installiert wird.

Tatsächlich bedient sich die T-Online-Software des DfÜ-Netzwerkes von Windows, um auf diesem Wege die Verbindung herzustellen. Folglich können Sie nach der Installation der T-Online-Software auch direkt per DFÜ- Netzwerk-Verbindung zu T-Online einwählen.

Für Windows 95 benötigen Sie mindestens die Version 1.3 des DFÜ-Netzwerkes, diese Version 1.3 ist auf der T-Online-CD enthalten. Bei Windows 98 muss der VPN-Adapter installiert sein.

Anmeldung nach Start der DFÜ-Netzwerk-Verbindung "WinPoET Connection" per Doppelklick:

Benutzername:
AAAAAAAAAAAATTTTTTTTTTT#MMMM@t-online.de

wobei folgende Regeln zu beachten wären:

  1. A = (geheimzuhaltende) 12-stellige Anschlusskennung
  2. T = bis zu 12-stellige T-Online-Nummer (wenn die T-Online-Nummer weniger als 12 Stellen hat, muss das "#"-Zeichen folgen - hat die T-Online-Nummer genau 12 Stellen kann das nachfolgende "#"-Zeichen entfallen)
  3. M = 4-stellige Mitbenutzernummer (i.d.R. 0001 - für den Hauptbenutzer)
  4. danach muss die Zeichenkette "@t-online.de" (ohne Anführungszeichen) angehängt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0520.htm


Onlineverbindung automatisch aufbauen/beenden

Wird eine DFÜ-Verbindung nicht mehr automatisch beendet, kann das an mehreren Einstellungen in der Registry liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Wert | Datentyp | Eintrag
DisconnectIdleTime | REG_BINARY | 05 00 00 00
EnableAutodisconnect | REG_BINARY | 01 00 00 00
EnableAutodial | REG_BINARY | 01 00 00 00
AutoConnect | REG_BINARY | 01 00 00 00

Überprüfen Sie Ihre Werte und passen Sie die Werte gegebenenfalls an.

Info Weitere Infos dazu finden Sie unter "Keine Nachfrage zum Trennen der Verbindung beim Beenden des IE4" und "Automatisch eine Netzverbindung aufbauen".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0595.htm


Erneut unerwünschter Verbindungsaufbau beim Start

In der MS KB (Q191901) liegt ein neuer Eintrag zum Thema: http://support.microsoft.com/?kbid=191901

In diesem heißt es, dass es auf Windows 95/98 Rechnern zu einem unerwünschten Verbindungsaufbau kommen kann, wenn Visual Basic 6, Visual C++ Version 6 und weitere Produkte in der 6er Version installiert sind.

Der Fehler tritt auf, wenn Remote-Verbindungen (auch Internet) eingerichtet wurden.

Zum Beheben des Fehlers geht man wie folgt vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ OLE

Dort den Eintrag erstellen "EnableRemoteConnect"="N"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0702.htm


Windows mit Windows über DFÜ verbinden

Windows 95 mit Windows über DFÜ verbinden

Wenn Sie über DFÜ-Netzwerk versuchen, mit einem NT-Rechner in Verbindung zu treten, der zu einer anderen Workgroup oder Domäne gehört als Ihr Computer, werden Sie nicht als Benutzer akzeptiert, obwohl Sie Zugriffsrechte haben. Das liegt daran, dass Windows 95 beim DFÜ-Netzwerk generell den Namen der Workgroup verwendet, zu der der Benutzer gehört.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ RemoteAccess\ Profile

tragen Sie unter "Domain" den Namen der Workgroup ein, zu der der angerufene Computer gehört.

Info Das Problem tritt bei Win3.x-Client undWindows 95-Server ebenfalls auf.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0129.htm


FAX-Funktion von Exchange

Den meisten Anwendern reicht die FAX-Funktion aus. Komisch ist nur, dass die Geschwindigkeit von Windows standardmäßig nicht gerade sehr hoch eingestellt wird. Damit Sie mit einer schnelleren Geschwindigkeit ein FAX versenden können müssen Sie folgendes ausschalten:

  1. Exchange starten
  2. Im Menü "Extras" das Untermenü "Extras für Microsoft Fax / Optionen" auswählen.
  3. In der erscheinenden Dialogbox "Eigenschaften für Microsoft Fax" die Lasche "Modem" auswählen und auf die Schaltfläche "Eigenschaften" klicken.
  4. In der Dialogbox "Faxmodem-Eigenschaften" auf die Schaltfläche "Erweitert" klicken.
  5. In der Dialogbox "Erweiterte Einstellungen" die Option "Schnelle Übertragung deaktivieren" deaktivieren
  6. Fertig.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0269.htm


HyperTerminal Wählbefehl ändern

Die Wählbefehle für "HyperTerminal" können Sie in der Registry ändern. Damit können Sie z.B. die Wahlsperre für Ihr Modem ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  • Mit ->"Bearbeiten" -> "Suchen" nach "DialPrefix" suchen lassen
  • Wenn man nur ein Modem installiert hat, sollte der "DialPrefix" dann unter
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Modem\ 0000\ Settings stehen (bei mehreren Modems unter...\0001\... oder anderer Nummer)
  • Hier kann man einen anderen Wählstring eingeben.
    Aber Achtung:
    Bei "DialPrefix" steht nur das "D" aus AT_D_P. Um z.B. bei einem Creatix FC 28.8 die Wahlsperre zu umgehen, dürfen Sie unter "DialPrefix" dann auch nur "%TCBD" Eintragen, obwohl der vollständige Wählbefehl zur Umgehung der Wahlsperre für Pulswahl ja eigentlich AT%TCBDP lautet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0157.htm


Automatisch eine Netzverbindung aufbauen

Wem das viele Klicken beim Verbindungsaufbau mit dem DFÜ-Netzwerk zu umständlich ist, der kann Windows so konfigurieren, dass eine Verbindung automatisch startet, sobald eine Anwendung aufgerufen wird, die auf Netzbereiche zugreifen will.

Wenn man zusätzlich die Einwahl ins Netz mit einem Skript automatisiert hat, braucht man wirklich nichts mehr zu machen. Wichtig für die Funktion ist nur, dass sich im Windows\System-Verzeichnis die Datei "URL.DLL" befindet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Winsock\ Autodial\

AutodialDllName32 | url.dll
AutodialFcnName32 | AutodialHookCallback

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\

EnableAutodial

REG_DWORD

01 00 00 00

Ab Windows 2000 muss unter folgendem Eintrag:

HKEY_CURRENT_USER\ RemoteAccess\ Profile\[Providername]

der Wert "AutoConnect" als Datentyp REG_DWORD von 0 auf 1 gesetzt werden.

Info Es gibt noch eine weitere Möglichkeit, diesen Vorgang zu automatisieren. Siehe "DFÜ-Netzwerk per Batch (Rundll32.EXE)"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0045.htm


Werbung bei ICQ-Nachricht an Handy abstellen

Die neue Version von ICQ kann Nachrichten an ein Handy versenden. Dabei wird automatisch an das Ende der Mail ein Text angehängt. Dieser Text enthält Informationen darüber, wo man ICQ downloaden kann. Wenn Sie diesen Anhang nicht wünschen, können Sie das über die Registry ausschalten:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\ Mirabilis\ ICQ\ DefaultPrefs

erstellen Sie einen neuen Eintrag mit dem Namen "Email Message" als Datentyp REG_SZ. Geben Sie hier den Text an, der gesendet werden soll, oder setzten Sie den Eintrag mit "" auf einen leeren Wert.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1303.htm


DFÜ-Server soll erst nach mehrmaligem Klingeln abheben

Wenn Sie den DFÜ-Server so konfigurieren wollen, dass er z.B. erst nach dem 3. Klingelzeichen abhebt, können Sie das nur über die Registry verändern, da MS in den Einstellungen des DFÜ-Servers dafür keine Option vorgesehen hat.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Modem\ 000x\ Answer

(bei einem Modem steht x für 0, für jedes weitere angeschlossene Modem erhöht sich die Zahl um 1)

Hier finden Sie als Wert die Zeichenfolge "1", welche Sie einfach umbenennen (z.B. in "ausschalten")

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Modem\ 000x\ Monitor

(bei einem Modem steht x für 0, für jedes weitere angeschlossene Modem erhöht sich die Zahl um 1)

ändern Sie den Wert "1" von "ATS0=0" in "ATS0=3"

Jetzt hebt das Modem erst nach dem 3. Klingelzeichen ab.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0498.htm


Das DFÜ-Passwort wird nicht gespeichert

Falls das DFÜ-Passwort nicht dauerhaft gespeichert wird oder die Option zum Speichern des Passwortes fehlt, kann das folgende Gründe haben:

  • Die Windows-Anmeldung wurde abgebrochen
  • Die Passwortdatei (*.PWL) ist beschädigt
  • Das Passwort Caching wurde deaktiviert
  • Einige Dateien, die zum DFÜ-Netzwerk gehören, fehlen
  • Die RNA.PWL ist beschädigt
  • "AutoLogon" ist aktiviert
    (siehe auch "Keine Windows-Anmeldung nach 'Überinstallieren' von Windows")
  • Der "Client für Microsoft Netzwerke" ist nicht installiert

Überprüfen Sie als erstes, ob evtl. der Passwort Cache in der Registry ausgeschaltet wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

finden Sie die den Eintrag "DisablePwdCaching" als Datentyp REG_DWORD. Sollte hier eine "1" stehen.

Ist der Cache ausgeschaltet, stellen Sie diesen Wert auf "0".

Als nächstes prüfen Sie, ob "Autologon" aktiviert ist.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Network\ Real Mode Net

löschen Sie den Eintrag "AutoLogon".

Sollte das Problem nach einem Neustart weiterhin bestehen, führen Sie folgende Schritte durch:

  1. Client für Microsoft Netzwerke installieren ("Netzwerk" - "Konfiguration" - "Hinzufügen" - "Dienste")
  2. DFÜ-Netzwerk aus "Systemsteuerung" -> "Software" -> "Windows-Setup" entfernen
  3. Dateien mit der Endung PWL löschen (danach müssen alle Kennwörter erneut eingegeben werden)
  4. Windows herunterfahren und neu starten
  5. DFÜ-Netzwerk wieder installieren
  6. DFÜ-Netzwerkverbindung erstellen, Namen und Passwort eingeben, Feld markieren

Info:

Windows 95A (egal ob 950 + SP1 oder OSR 1.0) enthält einen Bug. Ein Bugfix ist von MS erhältlich:

mspwlupd.exe | Passwort Library v4.71.0728.0 englisch ( KB)
mspwlger.exe | deutsch, Bugfix nur für Windows 950 + ServicePack1 und 950A

Download: http://www.eu.microsoft.com/windows/download/ger/mspwlger.exe

Info Vor der Ausführung dieses Bugfixes sollten alle.pwl Dateien gelöscht werden, da die RNA.pwl danach hinfällig ist und mit in die.pwl der User integriert wird.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0047.htm


DFÜ-Netzwerk per Batch (Rundll32.EXE)

Wenn Sie per DFÜ ins Internet wollen, müssen Sie normalerweise zuerst das DFÜ-Netzwerk starten, Verbindung wählen, diese starten, verbinden und anschließend Netscape bzw. MS IE anklicken. Mit folgender Batch-Datei bedarf es nur eines Mausklicks:

Für Windows 95/98

Rundll rnaui.dll,RnaDial <Provider>

start <laufwerk>\<verzeichnis>\<programm>

Ersetzen Sie "<Provider>" durch die Bezeichnung Ihrer DFÜ-Verbindung. Achten Sie beim Eingeben auf Groß-\Kleinschreibung! Hinter "Start" tragen Sie Pfad und Name ihres WWW-Browsers bzw. E-Mail-Programms ein.

Zu dieser Batch-Datei können Sie nun auf dem Desktop eine Verknüpfung anlegen und ihr ein Icon zuweisen.

Info Es gibt noch eine Möglichkeit, diesen Vorgang zu automatisieren. Siehe "Automatische Netzverbindung aufbauen"

Info Hierfür können Sie auch das Freeware-Programm "Dunce" verwenden. (http://www.vecdev.com/)

Für Windows NT

Hier müssen Sie den Befehl:

rasphone -d <Provider>

Durch die Eingabe von rasphone /? erhalten Sie eine Beschreibung aller Befehle.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0046.htm


DFÜ-Server ohne PlusPack

Wenn man den DFÜ-Server nutzen möchte, muss man nicht erst das PlusPack kaufen. Die benötigte Datei "rnaserv.dll" befindet sich in den CAB- Dateien der Windows 95 CD-ROM.

Bei den OEM-Versionen:

Windows 95 | in CAB 13
Windows 95A | in CAB 10
Windows 95B | in CAB 09

Bei dem Update:

Windows 95

in CAB 06

Am besten CAB-View aus den Powertoys installieren. Dann kann man die CABs wie ein Verzeichnis öffnen, per Drag&Drop die Datei herausziehen und ins System-Verzeichnis kopieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0094.htm


DFÜ Netzwerk installieren

Was benötige ich?

Je nach Art des zu installierenden Netzwerks (DFÜ oder LAN) benötigt man zunächst die entsprechende Hardware. Bei lokalen Netzwerken bedarf es einer Netzwerkkarte oder eines Parallelkabels (Nullmodem), für DFÜ-Netzwerk (Verbindung über die Telefonleitung) brauchen Sie ein Modem oder einen ISDN-Adapter.

Bei der Auswahl der Hardware sollte man bei Netzwerkkarten auf NE2000- und bei Modems auf Hayes-Kompatibilität achten, um späteren Treiber-Problemen möglichst vorzubeugen.

DFÜ-Netzwerk einrichten:

Als erstes sollte man überprüfen, ob DFÜ-Treiber installiert sind.

Den entsprechenden Eintrag finden Sie unter "Systemsteuerung -> Software -> Windows-Setup -> Verbindungen -> Details". Dort sollte "DFÜ-Netzwerk" markiert sein. Ist das nicht der Fall, so markieren Sie es und klicken auf "OK -> Übernehmen".

Danach sollten unter "Netzwerk" folgende Komponenten aufgeführt sein:

  • Client für Microsoft-Netzwerke
  • Client für Netware-Netzwerke
  • DFÜ-Adapter
  • IPX/SPX-kompatibles Protokoll
  • NetBEUI

Wenn Sie keine Verbindung zu Netware-Netzwerken herstellen wollen, können Sie "Client für Netware-Netzwerke" und "IPX/SPX-kompatibles Protokoll" entfernen.

Modem-/ISDN - Installation:

In den meisten Fällen verläuft die Installation problemlos, man muss nur das Gerät anschließen (internes einbauen, externes anschließen und einschalten) und einen Neustart durchführen. Windows 95 müsste nun das Modem selbstständig finden, unter Umständen einen Treiber verlangen und es dann installieren. Sollte ihr Modem/ISDN-Adapter von Windows nicht erkannt werden, können Sie es auch manuell installieren.

Analoges Modem:

Sollte Ihr Modem noch nicht eingerichtet sein, müssten Sie es nun über " Systemsteuerung -> Modems" installieren. Schließen Sie Ihr Modem an den Rechner an und schalten es ein. Nun können Sie versuchen, die automatische Hardware-Erkennung durchzuführen. Wird Ihr Modem von Windows 95 nicht erkannt, sollten Sie sich beim Hersteller eine *.inf-Datei besorgen. Nur so kann gewährleistet werden, dass Sie den ganzen Funktionsumfang Ihres Modems nutzen können. Falls keine Installationsdatei verfügbar ist, können Sie Ihr Modem als Standard-Modem installieren, dadurch bleibt aber ein Teil der Funktionen Ihres Modems ungenutzt.

ISDN-Karte:

Die ISDN-Karten werdenunter Windows 95 wie Netzwerkkarten angesprochen und werden deshalb auch unter -> "Systemsteuerung -> Netzwerk" eingerichtet. Klicken Sie dort nun auf "Hinzufügen -> Netzwerkkarte -> Hinzufügen". Suchen Sie den Hersteller und wählen Ihre Netzwerkkarte aus der Treiber-Liste aus. Sollte Ihre Karte nicht aufgeführt sein, brauchen Sie eine Treiber-Diskette vom Hersteller.

Selber anrufen:

Klicken Sie auf "Arbeitsplatz -> DFÜ-Netzwerk -> Neue Verbindung". Nun werden Sie aufgefordet, einen Namen für die Verbindung einzugeben, den Sie beliebig wählen können (z.B. den Namen der Person, die Sie anrufen wollen). Als nächstes teilen Sie Windows 95 mit, welches der installierten Modems es für die Verbindung nutzen soll. Jetzt können Sie bei Bedarf über "Konfiguration" Wahlparameter und Modem-Einstellungen verändern. Als letztes tragen Sie die Telefonnummer ein und bestätigen mit "OK"

Wenn Sie die Verbindung aufbauen wollen, klicken Sie doppelt auf das Symbol und geben Ihren Benutzernamen und Ihr Kennwort ein.

Server installieren:

Sollten andere auf Ihren Rechner zugreifen können, müssen Sie einen DFÜ-Server installieren. Wenn Sie MS Plus besitzen, rufen Sie nun das Setup auf und wählen "DFÜ-Netzwerk-Server" aus, dadurch werden die Treiber installiert.

Sollten Sie MS Plus nicht besitzen, können Sie den Server trotzdem installieren (siehe: DFÜ-Server ohne PlusPack)

Klicken Sie nun auf "Arbeitsplatz -> DFÜ-Netzwerk" und dort im Menü auf "Verbindungen -> DFÜ-Server" und aktivieren Sie den Zugriff für Anrufer.

Unter "Servertyp" können Sie die Protokoll-Art bestimmen, wobei die Auswahl "Standard" für die meisten Netze gilt.

Freigabe:

Als erstes geben Sie unter -> "Systemsteuerung" -> "Netzwerk" -> "Datei- und Druckerfreigabe" Ihre Dateien und /oder Ihren Drucker für andere Benutzer frei.

Wenn Sie einen Benutzer auf ein Verzeichnis bzw. Laufwerk zugreifen lassen wollen, öffnen Sie den Explorer, klicken Sie mit der rechten Maustaste auf dieses Verzeichnis/Laufwerk und wählen Sie "Freigabe". Als nächstes klicken Sie auf den Menüpunkt "Freigabe als" und geben den Namen an, unter dem das Verzeichnis/Laufwerk beim Anrufenden erscheinen soll.

Jetzt müssen Sie nur noch die Rechte des anderen Benutzers bestimmen und das Kennwort angeben, mit dem er sich bei Ihrem Server anmelden muss, um auf Ihren Rechner zugreifen zu können.

Wenn Sie das Verzeichnis/Laufwerk korrekt freigegeben haben, wird sich nun unter seinem Symbol eine Hand befinden.

Sollten Sie über einen NT-Server oder einen Novell-Server verfügen, können Sie mit Hilfe der USER-Datenbank die Freigaberechte genauer bestimmen. Dafür wählen Sie unter -> "Systemsteuerung" -> "Netzwerk" -> "Zugriffssteuerung" den Punkt "Zugriffssteuerung auf Benutzerebene" und geben den Namen des Server an, auf dem die Datenbank zu finden ist. Windows 95 kann leider keine USER-Datenbank verwalten.

Scripter installieren:

Für den Verbindungsaufbau ist ein Script notwendig, das automatisch die notwendigen Parameter (Username, Passwort, Art der Verbindung) an den angerufenen Rechner übergibt. Diese Funktion übernimmt der Scripter.

Klicken Sie auf "Systemsteuerung" -> "Software" -> "Windows-Setup" -> "Diskette" -> Herstellerdateien kopieren" und installieren Sie ADMIN\APPTOOLS\DSCRIPT\RNAPLUS.INF von der Windows 95 CD-ROM. Nun wird scripter.exe und CSLIP (Protokoll für Aufbau einer SLIP-Verbindung, bei Verwendung von PPP, jedoch überflüssig) installiert.

Info Die Installation von RNAPLUS.INF gelingt nur, wenn man sie wie beschrieben aus dem Windows-Setup Fenster heraus durchführt!

TCP/IP installieren:

-> "Systemsteuerung" -> "Netzwerk" -> "Hinzufügen" -> "Protokoll" -> "Hinzufügen" -> "Netzwerkprotokoll" -> "Microsoft" -> "TCP/IP"

TCP/IP einrichten:

Klicken Sie auf "DFÜ-Netzwerk", dann mit der rechten Maustaste auf eine Ihrer Verbindungen und dann auf "Eigenschaften" unter "Servertyp" wählen Sie "PPP: Windows 95, Windows NT 3.5, Internet" und dann -> "Erweiterte Optionen":

ausschließlich

[X] Am Netzwerk anmelden

[X] Softwarekomprimierung aktivieren

auswählen.

->"Zulässige Netzwerkprotokolle":

ausschließlich

[X] TCP/IP

auswählen.

Unter "TCP/IP Einstellungen" vom Server zugewiesene IP-Adresse und DNS-Adressen Eintragen:

[_] IP-Header-Komprimierung ausschalten!

[X] Standard-Gateway

auswählen.

Login Script zuordnen:

Verlasen Sie das DFÜ-Netzwerk und starten unter "Programme -> Zubehör" die DFÜ-Netzwerk-Script-Verwaltung. Nun können Sie eine Verbindung auswählen und ihr ein Script zuordnen.

Beispiel-Script für das PPP-Protokoll:

;login-Script

;mit Windows 95 und PPP

;03.07.1996

proc main

waitfor "sername:"

transmit $USERID

transmit "^M"

waitfor "assword:"

transmit $PASSWORD

transmit "^M"

waitfor "CS>"

transmit "ppp^M"

endproc

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0093.htm


T-DSL Verbindung optimieren

Folgende Schritte sind notwendig, um Aussetzer bei einer T-DSL-Verbindung zu verhindern:

  1. Klicken Sie das Symbol "Arbeitsplatz", dann "Systemsteuerung".
  2. Doppelklicken Sie das Symbol "Netzwerk".
  3. Den Eintrag "TCP/IP -> Ihre Netzwerkarte für den NTBA" markieren und dann auf die Schaltfläche "Eigenschaften" klicken.
  4. Auf der Registerkarte "IP-Adresse" als feste IP die 192.168.1.1 Eintragen, die Subnetzmaske ist 255.255.255.0
  5. Auf der Registerkarte "WINS-Konfiguration" die "WINS-Auflösung" deaktivieren.
  6. Auf der Registerkarte "Gateway" keinerlei Eintragungen.
  7. Auf der Registerkarte "DNS-Auflösung" die Option "DNS aktivieren" einschalten und als Host die "T-Onlinenummer" und als Domäne "dialin.t-online.de" Eintragen.
    Wichtig: Keinen DNS-Server Eintragen!
  8. Auf der Registerkarte "Bindungen" die "Datei- und Druckerfreigabe" deaktivieren.
  9. Öffnen Sie danach im Verzeichnis "C:\Windows" die Datei "hosts" (ohne Dateiendung) bzw. legen Sie eine solche Datei an. Diese Datei muss mindestens die beiden folgenden Eintragungen enthalten:
    - 127.0.0.1 localhost
    - 192.168.1.1 T-Onlinenummer.dialin.t-online.de
  10. Die Datei speichern (mit Notepad muss der Dateiname in Anführungszeichen eingeschlossen werden, sonst wird die Endung ".txt" ergänzt). System neu starten

Nun dürften keine DSL-Hänger mehr auftreten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1323.htm


ISDN-Karte einrichten (Creatix)

In diesem Tipp wird beschrieben, wie Sie eine ISDN-Karte einrichten können, wenn die ISDN-Karte nicht automatisch erkannt wird.

Automatisch wird die ISDN-Karte nicht erkannt.

Wählen Sie ->"Systemsteuerung" -> "Hardware" -> "Hinzufügen" -> "Netzwerkkarte" -> ISDN-Karte (unter TELES GmbH). Nun können Sie im Netzwerkmenü CAPI 2 als Protokoll auswählen (unter Acotec) und DFÜ-Adapter installieren und unter -> "Eigenschaften" die Teles-Netzwerkkarte konfigurieren (z.B. Basis-Adresse usw.)

Info CAPI-Treiber von Windows 95 funktionieren nicht in der DOS -Box, der Fossil-Treiber erkennt sie nicht. Sie belegen viel DOS -Memory und lassen sich nicht wieder aus dem Speicher entfernen. Möchte man ein DOS -Programm mit den Windows 95-CAPI-Treibern nutzen, erscheint die Fehlermeldung "No Dialtone"

Tipp:

Richten Sie unter ->"Systemsteuerung" -> "Hardware" nur die Teles-Karte ein und installieren Sie die Teles-vxdcapi-Treiber. Entfernen Sie dann alle diesbezüglichen Einträge aus der SYSTEM.INI ([386Enh]) oder kommentieren Sie sie aus (Semikolon davor setzen). Ersetzen Sie alle Windows 95-Treiber im Verzeichnis \%WINDIR%\System durch ihre Teles-Gegenstücke (die Windows 95-Treiber heißen alle CSST*.386, also z.B. CSSTCAPI.386), sichern Sie aber vorher die Originaldateien. Es gibt einen CSST-Treiber (CSSTMAC.386), für den es keine Teles-Entsprechung gibt, aber er wirkt sich auf die Teles-Treiber nicht aus, Sie brauchen ihn also nicht zu löschen.

Jetzt können Sie die Teles-Karte wieder aus der Hardware-Liste entfernen, da sie immer mit einem gelben Ausrufungszeichen gekennzeichnet ist (Windows 95 erkennt falsche Treiber-Version) und die VXD-Treiber in der SYSTEM.INI laden, für die es keine Teles-Entsprechnung gibt, z.B. VXDBund LE.386 oder VXDH221.386.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0167.htm


ISDN-Karte (TELES)

Um die TELES mit Win-3.11 Programmen oder denen von TELES zu nutzen (z.B. EFIX), gehen Sie folgendermaßen vor:

  • Die Capi-Treiber von Windows 95 entfernen (falls installiert)
  • Die original TELES Treiber installieren
  • TELES-DEINSTALL.EXE im WIN\SYSTEM- Datei aufrufen (T_DEINST.EXE) -> alle Treiber in der SYSTEM.INI werden entfernt.
  • Den neusten 32-Bit-Treiber von TELES installieren. Alle INI - Einstellungen sowie IRQ/Adressenangaben werden übernommen

16-Bit Programme funktionieren nun einwandfrei. Wenn Sie im DOS -Fenster CFOS starten, können Sie auch DOS -Programme nutzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0166.htm


ISDN Konfiguration (bei Verwendung einer TK Anlage)

Problem:

Unter Verwendung einer ISDN Karte und einer ISDN TK-Anlage wählt die Karte bei einer DFÜ-Verbindung nicht über die richtige interne MSN (Mehrfachrufnummer). Dies kann Geschwindigkeitseinbußen und andere Konflikte verursachen (z.B., dass unter zwei Rechnern keine interen DFÜ-Verbindung möglich ist).

Voraussetzungen: Windows 95/98

Hier wird die Installation mit einer Fritz-Card an einer ISDN-Anlage beschrieben. Das Problem dürfte auch bei anderen Zusammensetzungen auftauchen und auf diese Art und Weise zu lösen sein:

Download des neuesten Kartentreiber von der Herstellerseite und (sehr wichtig!) des aktuellen ISDN Accelerator Packs von Microsoft unter http://www.microsoft.com/windows/software/localize/gerisdn.htm

Info Die Verweise auf das ISDN Accelerator Pack beziehen sich nur auf W95.

Vorgehensweise:

Die Schritte müssen in dieser Reihenfolge durchgeführt werden!

  1. Deinstallieren Sie in der Systemsteuerung unter Software alles, was mit ihrer ISDN Karte zu tun hat und das DFÜ Netzwerk. Unter Netzwerk muss der NDIS WAN Eintrag gelöscht werden. In der Systemsteuerung entfernen Sie ihre ISDN Karte.
  2. Starten Sie ihren Computer neu. Die Hardwareerkennung erkennt die ISDN Karte. Bitte installieren Sie die heruntergeladenen neuesten Treiber des Herstellers.
  3. Installieren Sie das DFÜ Netzwerk und das ISDN Accelerator Pack v1.1 von Microsoft.
  4. Unter "Systemsteuerung" -> "Netzwerk" klicken Sie auf "Hinzufügen" -> "Netzwerkkarte". Geben Sie als Installationspfad den Pfad des NDIS WAN Treibers auf der Hersteller CD an. Fügen Sie benötigte Netzwerkprotokolle, wie TCP/IP, IPX/SPX oder NetBIOS , hinzu. Nach dem Bestätigen wird das ISDN Accelerator Pack v1.1 gestartet. Folgen Sie den Anweisungen. Geben Sie bei der MSN eine Nummer ein (meist 11 bis 28).
    Nach dem Beenden des Assistenten für die ISDN-Konfiguration werden Sie aufgefordert, die Windows 95-CD-ROM einzulegen. Wird beim Kopieren der Dateien von der CD-ROM ein Versionskonflikt bei der Datei "NDIS.VXD" (Windows NDIS 3.1 Wrapper) gemeldet, antworten Sie bitte auf die Frage "Möchten Sie diese Datei beibehalten?" mit "Ja". Die durch das ISDN Accelerator Pack v1.1 auf Ihrem System bereits installierte Datei "NDIS.VXD" ist aktueller als die Datei auf der Windows 95-CD-ROM.
  5. Starten Sie ihren PC neu.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0747.htm


Echte Verbindungsgeschwindigkeit bei Modemconnect anzeigen

Gängige V90-Modems haben die Eigenart, als Verbindungsgeschwindigkeit stets 115.200 oder 57600 bps im Systray zu melden. Der Fehler liegt aber fast immer am INF-Treiber des Modems. Bei gängigen V90-Modems mit Rockwell Chipsatz kann man aber über Modems->Eigenschaften->Erweitert->mit dem Befehl ATW2 den Fehler beheben und bekommt dann vom DFÜ Netzwerk die richtige Geschwindigkeit angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0928.htm


Modem wählt nicht oder verbindet direkt ohne Amt zu haben

Das ELSA MicroLink 56k Internet c mit Firmwareversion 1.71 wählt unter Windows 95, Windows 98 und Windows NT4.0 bei aktiviertem Feld Systemsteuerung -> Modems -> Eigenschaften -> Einstellungen -> 'Vor dem Wählen auf Freizeichen warten' nicht.

In manchen Fällen ist es bisher auch aufgetreten, dass das Modem nach einem Systemstart einmal wählt und weitere Wahlversuche ohne Neustart verweigert.

In der mdmelsa7.inf vom 22.10.1999 ist erstmals unter dem Eintrag "DialSuffix" der anstatt "" nun ";" eingetragen. Diese Veränderung begründet sich in Vorschriften zum WHQL Test. Aufgrund von des Timings zwischen dem Absetzen eines AT-KommanDOS und dessen Verarbeitung und Quittierung kommt es zu diesem Effekt.

Lösung:Systemsteuerung -> Modems -> Eigenschaften -> Einstellungen -> Vor dem Wählen auf Freizeichen warten deaktivieren. Hierbei ist zu beachten, dass bereits angelegte DFÜ-Netzwerkverbindungen aufgrund der veränderten Grundeinstellung des Modems neu angelegt werden müssen.

Eine endgültige Lösung hat die ELSA AG ab der Firmwareversion 1.77 eingearbeitet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0873.htm


Modem-Konfiguration (Init-String) ändern

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

  1. Modem-Einstellungen für DFÜ findet man in:
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\Modem \xxxx\ Init
  2. Fax-Einstellungen in:
    HKEY_LOCAL_MACHINE\ Software\ Microsoft\ At WorkFax\ LocalModems

Das xxxx steht für die installierte Modemnummer. Diese kann je nach Installation "0000" oder "0001" lauten. Unter

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\Enum

werden die installierten Modems aufgelistet. Hinter DRIVER finden Sie dann die jeweilige Modemnummer.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0239.htm


CRC-Fehler in DOS Boxen verhindern

Wenn Sie in DOS-Boxen CRC-Fehler bekommen, sollten Sie in der SYSTEM.INI unter folgendes eintragen. Damit sollte der Fehler behoben sein.

[386Enh]

COMxBUFFER=2048

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0083.htm


Einrichten einer Nebenstellenanlage

"Systemsteuerung" -> "Modem" -> "Wahlparameter":

bei "Kennzahl zur Deaktivierung der Wartefunktion" "0W" Eintragen

bei Eigenschaften -> Einstellungen "Vor dem Wählen auf Freizeichen warten" -> ausschalten

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0084.htm


Internetzugang für alle Rechner im Netzwerk kostengünstig konfigurieren

Ein Netzwerk ist ja heute fast schon überall zu finden, selbst im privaten Bereich sind oft mehrere Rechner vorhanden, die untereinander vernetzt sind. Meist haben aber nicht alle Rechner im Netzwerk ein Modem und können somit nicht auf das Internet zugreifen. Windows selber stellt keine Möglichkeit zu Verfügung um über das Netzwerk auf die serielle Schnittstelle eines anderen Rechner zuzugreifen und das Modem zu benutzen.

Um nicht mehrere Modems kaufen oder das Modem immer von einem zum anderen Rechner schleppen zu müssen, brauchen Sie ein Programm, welches Ihnen den Zugriff auf das Internet über das Netzwerk zu Verfügung stellt.

Mit einem einfachen Proxy-Server können Sie diese Aufgabe auch meistern. Der Proxy-Server wird dann zwischen Internet und die einzelnen Client-Rechner im Netzwerk geschaltet. Jeder Zugriff auf das Internet geschieht nun ausschließlich über den Proxy-Server, der die benötigten Dateien aus dem Internet besorgt. So einen Proxy-Server können Sie sich z.B. bei der Firma Sambar Technologies (http://www.sambar.com) herunterladen (leider ist die neue Version nicht mehr kostenlos...).

Diesen Proxy-Server müssen Sie nun auf dem Rechner installieren, auf dem auch der Zugang zum Internet Provider eingerichtet ist. Ich beschreibe hier nur kurz die Konfiguration des Proxy-Servers (heißt hier: Sambar Server der Firma Sambar Technologies, da er von dieser Firma im Internet kostenlos vertrieben wird).

Dieses Programm ist eigentlich ein ganzer WEB-Server und bietet daher noch etliche weitere Funktionen. Was Sie davon dann noch weiter verwenden wollen, müssen Sie selber entscheiden.

Ich gehen hier auch davon aus, dass Sie schon ein fertiges Netzwerk mit TCP/IP installiert haben und auf die Rechner im Netzwerk über eine IP-Adresse zugreifen können.

Einrichtung und Konfiguration des Sambar-Servers 4.2 von der Firma: Sambar Technologies

Installieren Sie den Proxy-Server auf Ihren Rechner. Nach der Installation müssen Sie den Sambar-Server über das angelegte Icon starten. Um jetzt an die Dokumentation und Konfigurationseinstellungen zu kommen (der Sambar-Server wird über HTML eingerichtet) müssen Sie einen Internetbrowser (z.B. MS Internet Explorer) starten. Geben Sie nun als Adresse http://127.0.0.1 im Explorer ein und Sie sehen die Startseite des Sambar-Servers. Die Seiten für die Konfiguration und Dokumentationseinstellungen sind alle in Englisch.

Auf der ersten HTML-Seite klicken Sie den Link "System Administrator" an. Es erfolgt nun die Anmeldung an den Sambar-Server, dafür wird eine Anmeldebox geöffnet, in der Sie nach Username und Passwort gefragt werden. Geben Sie als Username: admin ein und lassen das Feld Passwort leer (Sie sollten später ein Passwort vergeben, damit keine unberechtigten Personen den Sambar-Server konfigurieren können.

Jetzt sind Sie im Konfigurationsbereich des Sambar Servers. Unter dem Link "Proxy Configuration" können Sie nun die benötigten Funktionen für Ihren Proxy-Server aktivieren.

Folgende Funktionen müssen Sie, je nach Verwendungszweck, aktivieren:

HTTP | Für den Zugriff auf das Internet
NNTP | Für Zugriff auf Newsgroups
SMTP, POP3, IMAP$ | Für Email-Funktionen
FTP | Für FTP-Dateizugriff

Bei jeder Funktion wird Ihnen eine Portnummer angezeigt. Über diese Portnummer greifen Ihre Clientrechner nachher auf Ihren Proxy-Server zu. Diese Werte müssen Sie auch auf den jeweiligen Netzwerkrechnern in den Anwendungen Eintragen, das werde ich aber am Ende an einem Beispiel noch einmal beschreiben.

Unter SMTP, POP3 und IMAP4 haben Sie jeweils eine Eingabebox. Hier müssen Sie die Adressen Eintragen, die Ihnen von Ihrem Provider mitgeteilt wurden.

SMTP | ist der Postausgang
POP3 | ist der Posteingang

Bei einigen Providern sind diese beiden Adressen gleich.

In Ihrem E-Mail-Programm (bei Outlook 98 unter:

Extras -> Konten -> Eigenschaften -> Server)

Tragen Sie an diesen Stellen nun nicht mehr die Adresse ihres Providers ein (die haben Sie ja gerade oben im Proxy-Server eingetragen), sondern die Adresse des Proxy-Servers (127.0.0.1). Die Netzwerkverbindung stellen Sie nun noch auf (LAN) (bei Outlook 98 unter: Extras -> Konten -> Eigenschaften -> Verbindungen) und nicht auf Modemverbindung. Ab sofort wird Ihr E-Mail Programm beim Post holen nicht mehr versuchen, Ihren Internetprovider anzusprechen, sondern wendet sich über das Netzwerk an Ihren Proxy-Server, der diese Anfragen automatisch an Ihren Provider weiter reicht.

Jetzt müssen Sie auf der Konfigurationsseite des Proxy-Servers nur noch "Dial-On-Demand" einrichten (ganz unten auf der HTML-Seite). Er ist dafür zuständig, bei Anfragen automatisch eine Verbindung zu Ihrem Provider aufzubauen. Dazu schalten Sie diese Funktion an und geben unter "Dial-On-Demand-Entry" den Namen der unter Windows erstellten DFÜ-Verbindung an. Diese finden Sie unter "Arbeitsplatz" -> "DFÜ-Netzwerk" (hier ist auf Groß-und Kleinschreibung zu achten). In den anderen Feldern geben Sie noch Ihren Usernamen und das Passwort ein.

Jetzt ist der Sambar-Server soweit fertig eingerichtet. Klicken Sie am Ende der Seite auf "Update Server Configuration" und danach auf "Restart Server". Jetzt ist Ihr Sambar Server betriebsbereit.

An den Clients müssen Sie nun bei den jeweiligen Programmen (Outlook, Internet Explorer, FTP-Programm usw.) nur noch die jeweiligen Anpassungen vornehmen.

Bei Internet Explorer:

Klicken Sie mit der rechten Maustaste auf das Icon -> "Eigenschaften" -> "Verbindungen" -> und auf den Button "LAN-Einstellungen" bei Proxyserver. Außerdem klicken Sie "Proxy verwenden an" und geben bei Adresse die TCP/IP-Adresse des Rechners ein, auf dem Sie den Proxy-Server installiert haben. Als Port tragen Sie 80 ein (sollten Sie die Einstellung im Proxy-Server verändert haben, müssen Sie selbstverständlich diese Portnummer dort Eintragen). Wenn Sie jetzt den IE starten, sollte er automatisch eine Verbindung zum Internet herstellen.

Sie sparen nun bei mehreren Zugriffen auf das Internet nicht nur Telefonkosten, Sie haben durch den Proxy-Server auch eine höhere Sicherheit, als wenn Sie sich direkt mit dem Internet-Provider verbinden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0091.htm


Compuserve Login Skript

;-------------- Anfang

proc main

set port databits 7

set port parity even

delay 2

transmit "<cr>"

waitfor "ame:"

transmit "CIS<cr>"

waitfor "ID:"

transmit $USERID

transmit "/GO:PPPCONNECT<cr>"

waitfor "word:"

transmit $PASSWORD

transmit "<cr>"

waitfor "PPP"

set port databits 8

set port parity none

endproc

;-------------- Ende

Skript für eine RAS-Verbindung zu CompuServe.

Die Adressen:

149.174.211.5 DNS-Adresse

149.174.213.5 DNS-Adresse

Skript:

;***********************************************

;* Login-Skript für die Einwahl ins

;* Internet über Datex-J und Compuserve

;* (Telefonnummer in Deutschland: 01910)

;***********************************************

;* Version 2.1 (c) 1996 Wolfgang Wirth

;* Letzte Änderung am 22:06 19.09.96

;* Email: 71333.1421@compuserve.com

;***********************************************

proc main

string ErrStr

;***********************************************

;*** Dial-up Port auf 8n1 setzen

set port databits 8

set port parity none

;***********************************************

;*** Hier befinden wir uns auf der T-Online

; Startseite. Als erstes muss ein Dezimalpunkt

; mit <CR> geschickt werden, um auf einen

; "Text-Dekoder" hinzuweisen.

;

delay 3

transmit ".^M"

;***********************************************

;*** Hier befinden wir uns auf der T-Online

; Login-Seite. Wenn das Wort "kennung"

; erscheint, wird die Compuserve-

; Kennung geschickt. Ein <CR> ist nicht

; nötig, da die Seite automatisch nach

; der Kennungseingabe wechselt.

;

waitfor "kennung" until 30

if !$SUCCESS then

Errstr="Datex-J-Kennung"

goto fehler

endif

transmit "000255975978"

;***********************************************

;*** Hier befinden wir uns auf der Compuserve

; Login-Seite. Punkt "2" steht für Login von

; Mitgliedern. Ein <CR> wird geschickt, um

; auch die nachfolgende Seite zu quittieren.

;

transmit "2^M"

;***********************************************

;*** Datex-J haben wir jetzt passiert. Jetzt stehen

; wir bei Compuserve auf der Matte. Das System

; fragt hier nach dem Host-Namen, der in unserem

; Fall "CIS" lautet und mit einem <CR> abgeschlos-

; sen werden muss.

;

waitfor "Host Name:" until 30

if !$SUCCESS then

Errstr="Compuserve Host-Name"

goto fehler

endif

transmit "CIS^M"

;***********************************************

;*** Jetzt muss unsere CIS-Anwenderkennung übermittelt

; werden. Es wird die Systemvariable $USERID benutzt,

; die den entsprechenden Eintrag aus dem Anwahl-

; Dialog enthält. Die ID wird mit dem Parameter

; RAW gesendet, damit keine Steuer- bzw. So nder-

; zeichenübersetzung auf dem Host stattfindet.

; Das Kommando für einen PPP-Connect kann man gleich

; an die ID mitanhängen. Das ganze muss mit einem <CR>

; abgeschlossen werden.

;

waitfor "User ID:" until 30

if !$SUCCESS then

Errstr="Compuserve Anwenderkennung"

goto fehler

endif

transmit $USERID, raw

transmit "/go:pppconnect^M"

;***********************************************

;*** Mit der Übermittlung des Passwortes wird das Login

; abgeschlossen. Es wird die Systemvariable $PASSWORD

; benutzt, die den entsprechenden Eintrag aus dem

; Anwahl-Dialog enthält. Das Passwort wird mit dem

; Parameter RAW gesendet, damit keine Steuer- bzw.

; Sonderzeichenübersetzung auf dem Host stattfindet.

; Das ganze muss mit einem <CR> abgeschlossen werden.

;

waitfor "Password:" until 30

if !$SUCCESS then

Errstr="Compuserve Anwenderpasswort"

goto fehler

endif

transmit $PASSWORD, raw

transmit "^M"

;***********************************************

;*** Damit ist das Login abgeschlossen. Wir warten

; jetzt nur noch auf eine kleine Quittierung vom

; System

;

waitfor "One moment please" until 60

;***********************************************

;*** Hurra - Wir stehen im Internet! Das Skript endet

; hier und das Login-Fenster schließt sich.

;

goto ende

;***********************************************

;*** Mist! Ein Fehler ist aufgetreten.

; Der Grund wird über Modem-Echo ins

; Verbindungsfenster geleitet

;

fehler:

transmit "+++" ; Modem in Kommandomodus schicken

delay 3 ; Kommandomoduszwangspause

waitfor "ok", "0" until 5 ; Auf OK oder 0 warten

transmit "ate1^M" ; Modem: Echo ein

waitfor "ok", "0" until 2 ; Auf OK oder 0 warten

; Fehlerinformation senden (kommt als Echo ins Fenster)

transmit "*** VERBINDUNGSFEHLER:^M^J"

transmit "*** " + ErrStr + " wurde nicht angefordert^M^J"

transmit "*** Das Skript wird daher abgebrochen.^M^J"

delay 3 ; Anwender Zeit zum Lesen lassen

transmit "ath0^M" ; Modem soll auflegen

delay 10 ; Zeit für System zum Gen. des

halt ; Meldungsfensters

;***********************************************

ende:

endproc

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0088.htm


Internet über Compuserve mit Windows Internetdialer

1. Software, die installiert sein muss:

Windows Setup: | DFÜ-Netzwerk
Windows 95 CD: | \ADMIN\APPTOOLS\DSCRIPT
Windows 95 Plus Pack: | Starthilfe-KIT für das Internet

2. TCP/IP installieren

"Systemsteuerung" -> "Netzwerk" -> "Konfiguration" -> "Protokoll" -> "Hinzufügen" -> "Hersteller: Microsoft", -> "Netzwerkprotokolle: TCP/IP"

3. TCP/IP konfigurieren

"Systemsteuerung" -> "Netzwerk" -> "TCP/IP" -> "Eigenschaften"

Gateway: | 198.4.6.2
Bindungen: | Client für Microsoft-Netzwerke
IP-Adresse: | IP-Adresse automatisch beziehen
DNS-Konfiguration: | DNS aktivieren: Host: compuserve.com Domäne: compuserve.com Suchreihenfolge für DNS-Server: 149.174.212.5, 149.174.211.5

Die restlichen Registerkarten ignorieren. "OK"

4. Rechner evtl. neu booten.

5. Internetverbindung konfigurieren

"Systemsteuerung" -> "Internet" -> "Automatischen Verbindungsaufbau aktivieren"

6. Über "Arbeitsplatz" -> "DFÜ-Netzwerk" -> "Neue Verbindung" anlegen

Name: | CompuServe
Rufnummer: | Hier die Tel. von CompuServe angeben

Nachdem die neue Verbindung erstellt wurde, die Verbindung bearbeiten

Servertyp:

PPP: Windows 95, Windows NT 3.5, Internet

Das einzige Kästchen, das in dieser Registrierkarte angeklickt sein darf, ist TCP/IP!

7. Modem- Konfiguration:

Datenbits: | 8
Parität: | N
Stopbits: | 1

Den Rest so lassen.

8. "Start" -> "Programme" -> "Zubehör" -> "DFÜ-Skript-Verwaltung"

Unter Verbindungen CompuServe anwählen

Unter Dateiname z.B. C:\NETSCAPE\CIS.TXT Eintragen

Bearbeiten wählen

Das Compuserve Login Skript einfügen.

Den Editor schließen

Evtl. Terminalfenster minimiert starten anwählen

9. Beim Start eines Internet-Programms (z.B. Netscape)

Benutzername: | Hier User-ID Eintragen
Kennwort: | Hier das CompuServe Passwort Eintragen

Wenn "Kennwort speichern" angewählt wird, bleiben diese Einstellungen dauerhaft erhalten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0090.htm


T-Online Verbindung ohne Decoder

Um T-Online ohne den mitgelieferten Decoder benutzen zu können, müssen Sie unter Windows einige Einstellungen vornehmen, die hier beschrieben werden:

Windows 95/98 und ME

Es muss ein DFÜ-Netzwerk installiert sein. Hierzu eine kurze Anleitung:

DFÜ-Netzwerke einrichten:

"START" -> "Einstellungen" -> "Systemsteuerung" -> "Software" -> "Windows Setup" -> "Verbindungen" -> "DFÜ-Netzwerk aktivieren" -> "OK" -> "OK"

Internet Protokoll einrichten:

"START" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk" -> "Hinzufügen" -> "Microsoft" -> "TCP/IP" -> "OK" -> "IDENTIFIKATION" -> "Computername und Arbeitsgruppe eingeben" -> "OK"

Starten Sie den Rechner neu.

DFÜ-Skript einrichten:

"START" -> "Einstellungen" -> "Systemsteuerung" -> "Software" -> "WindowsSetup" -> "Diskette" ->Windows 95 CD-ROM einlegen und Pfad angeben: \admin\apptools\dscript -> "OK" -> "SLIP-/Scriptunterstützung für DFÜ-Netzwerke" aktivieren -> "Installieren" -> "OK"

Starten Sie den Rechner neu.

Eine neue DFÜ-Verbindung anlegen:

->"Arbeitsplatz" -> "DFÜ-Netzwerk" -> "Neue Verbindung erstellen". Geben Sie den Namen für die Verbindung ein (hier z.B.: T-Online) und bestimmen das zu verwendende Modem. Klicken Sie auf -> "Weiter" und tragen dann die Tel.-Nummer von T-Online ein ("0191011"). Klicken Sie auf -> "Weiter". Jetzt teilt Windows Ihnen mit, dass die Verbindung erstellt wurde.

Jetzt müssen Sie noch die DFÜ-Verbindung vor der Benutzung konfigurieren.

Klicken Sie dazu auf die neue Verbindung mit der rechten Maustaste und wählen Sie "Eigenschaften"

Hier sehen Sie nun die aktuellen Daten. Sie sollten "Landes- und Ortskennzahl verwenden" ausschalten. Wichtig ist hierbei aber nun, dass oben die richtige Telefonnummer stehen bleibt "0191011".

Klicken Sie nun auf den Button "Servertyp" und nehmen Sie folgende Einstellungen vor:

Typ des DFÜ-Servers | PPP: Windows 95, Windows NT...
Erweiterte Optionen: | Am Netzwerk: aus Softwarekompr. ein Verschlüsselt. aus
Zulässige Netzwerkprotokolle: | Nur TCP/IP

Klicken Sie nun auf den Button "TCP/IP-Einstellungen"

Vom Server zugewiesene IP-Adresse | aktivieren
Vom Server zugewiesene Namensserveradressen | aktivieren
IP-Header-Komprimierung | aktivieren
Standard-Gateway im Remote-Netzwerk verwenden | aktivieren

Die DFÜ-Verbindung ist jetzt bis auf Ihre Zugangsdaten fertig konfiguriert. Starten Sie jetzt durch Anklicken der angelegten DFÜ-Verbindung (wenn Sie den Namen oben genommen haben, müsste sie T-Online heißen) den Verbindungsaufbau.

Es erscheint eine Dialogbox, in der Sie folgende Angaben ergänzen müssen:

Benutzername:

Der Benutzername setzt sich aus folgenden Nummern zusammen:
Die 12-stellige Anschlusskennung + T-Online Nummer (bei weniger als 12 Stellen, müssen Sie noch ein # anhängen) + Mitbenutzernummer.
Beispiele:

00021200121200463700423640004 (ohne # Zeichen, da T-Online Nummer 12 Stellen
0003456452340537299#0034 (mit # Zeichen, da T-Online Nummer weniger als 12 Stellen)

Kennwort:

Ihr Kennwort des T-Online Zugangs

Rufnummer:

hier sollte die richtige Nummer stehen (0191011)

Standort

sollte auf "Zuhause" stehen

Ab Windows NT

Vor der Installation muss unter NT der RAS-Server installiert sein!

Erstellen eines Telefonbuch-Eintrages:

Rufen Sie über -> "Arbeitsplatz" -> "DFÜ-Netzwerk" das Telefonbuch auf. Machen Sie das zum ersten einmal, meldet NT, dass noch keine Einträge bestehen und fordert Sie zum Anlegen eines Eintrags auf. Haben Sie schon Einträge angelegt, müssen Sie über -> "Neu" einen neuen Eintrag hinzufügen.

Es wird der "Assistent für Telefonbucheinträge" gestartet. Als erstes werden Sie nach einem Namen für den Telefonbuch-Eintrag gefragt, hier können Sie ein beliebigen Namen eingeben (z.B. T-Online).

Klicken Sie nun auf "Weiter". Es erscheint nun die Dialogbox "Server", in der Sie folgenden Eintrag auswählen sollten "Unverschlüsseltes Kennwort senden, wenn andernfalls keine Verbindung hergestellt werden kann" -> "Weiter".

In der Dialogbox "Rufnummer" geben Sie die Telefonummer von T-Online ein (0191011) -> "Weiter" -> "Fertigstellen".

Ihr neuer Telefonbuch-Eintrag wurde nun angelegt.

Konfigurieren des Telefonbuch-Eintrages:

Sie müssen den neuen Telefonbuch-Eintrag nur noch für die Benutzung richtig einstellen. Dazu gehen Sie folgendermaßen vor:

"Arbeitsplatz" -> "DFÜ-Netzwerk" -> wählen Sie unter "Telefonbuch-Eintrag" Ihren neu angelegten Eintrag aus (nur nötig falls Sie mehr als einen Telefonbuch-Eintrag haben). Klicken Sie nun auf den Button "Weiteres" -> "Eintrags- und Modemeigenschaften bearbeiten.." es erscheint nun die Dialogbox "Telefonbuch-Eintrag bearbeiten"

In dem ersten Register "Einträge" müssten alle Angaben schon vorhanden sein. Klicken Sie auf die zweite Lasche "Server", hier stellen Sie bitte folgendes ein:

Typ des DFÜ-Servers | PPP:Windows NT, Windows 95 Plus...
Netzwerkprotokolle | nur "TCP/IP" aktivieren
Software-Komprimierung aktivieren | ausschalten
LCP-Erweiterungen für PPP aktivieren | ausschalten

Klicken Sie in dieser Dialogbox nun noch auf den Button "TCP/IP-Einstellungen.." und stellen Sie dort folgendes ein:

IP-Adresse, die dem Server zugeordnet ist | aktivieren
Namens-Server-Adressen, die dem Server zugeordnet sind | aktivieren
IP-Vorspann und -Komprimierung verwenden | aktivieren
Standard-Gateway auf dem Remote-Netzwerk verwenden | aktivieren
Registerkarte Sicherheit: Echtheitsbestätigung und Verschlüsselung: Beliebige Echtheitsbestätigung | aktivieren

Weitere Einstellungen brauchen nun nicht mehr durchgeführt werden. Schließen Sie nun alle Dialogboxen wieder, bis Sie wieder bei der Dialogbox "DFÜ-Netzwerk" angelangt sind. Klicken Sie hier nun auf den Button "Wählen" und es erscheint die Dialogbox "Verbindung mit xxx herstellen" (xxx steht für den Telefonbuchnamen der Verbindung)

Hier müssen Sie nun folgendes Eintragen:

Benutzername:

Der Benutzername setzt sich aus folgenden Nummern zusammen:
Die 12-stellige Anschlusskennung + T-Online Nummer (bei weniger als 12 Stellen, müssen Sie noch ein # anhängen) + Mitbenutzernummer.
Beispiele:

00021200121200463700423640004 (ohne # Zeichen, da T-Online Nummer 12 Stellen
0003456452340537299#0034 (mit # Zeichen, da T-Online Nummer weniger als 12 Stellen)

Kennwort:

Ihr Kennwort des T-Online Zuganges

Domäne:

dieses Feld muss leer bleiben

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0199.htm


Internet Mail Logfile Einstellungen

Die Logfile Einstellungen vom MS Internet Mail können nur in der Registry geändert werden. Die Einträge sind dafür schon in der Registry vorhanden, das Logging ist aber standardmäßig ausgeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Mail and News\ Mail

LogFile(POP3) | [Pfad] | Pfad zum Logfile für POP3 | (Zeichenfolge)
LogFile(SMTP) | [Pfad] | Pfad zum Logfile für SMTP | (Zeichenfolge)
LogPOP3(0/1) | [ 0 / 1 ] | Ein- und Ausschalten | (DWort)
LogSMTP(0/1) | [ 0 / 1 ] | Ein- und Ausschalten | (DWort)

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Mail and News\

kann man bei "Store Root" den Pfad des Mailverzeichnisses ändern. Dort kann auch mit UNC Pfaden gearbeitet werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0198.htm


Internetverbindungsfreigabe (ICS) Client manuell konfigurieren

Wenn der "Server" für die Internetverbindungsfreigabe (ICS, Internet Connection Sharing) eingerichtet ist (siehe: "Die Internetverbindungsfreigabe einrichten und konfigurieren", können Sie die Clients, die über den Server auf das Internet zugreifen sollen, auf zwei Arten konfigurieren:

  1. Mit Hilfe der Installationsdiskette, die beim Installieren des Servers erstellt wird
  2. Manuell durch ein paar Einstellungen in den Netzwerkeigenschaften

Für die zweite Methode gehen Sie wie folgt vor:

  1. Rechtsklick auf Netzwerkumgebung - Eigenschaften - Konfiguration
  2. Falls noch nicht geschehen, fügen Sie das TCP/IP Protokoll hinzu (Hinzufügen - Protokoll - Microsoft - TCP/IP)
  3. Wählen Sie TCP/IP des Adapters, der den Client mit dem Server verbindet - Eigenschaften - IP-Adresse
  4. Aktivieren Sie "IP-Adresse festlegen". Geben Sie eine Adresse ein, die in Ihrem Netzwerk noch nicht existiert, z.B. 192.168.0.2 (Wenn der Server beispielsweise die Adresse 192.168.0.1 hat)
  5. Subnetmask: 255.255.255.0
  6. WINS-Konfiguration - WINS-Auflösung deaktivieren
  7. Gateway - Neuer Gateway - IP-Adresse des Servers (in unserem Beispiel: 192.168.0.1) eingeben - Hinzufügen
  8. DNS-Konfiguration: DNS aktivieren
  9. HOST: Rechnername des Clients eingeben und als DNS-Server-Adresse wiederum die IP-Adresse des "Servers" (192.168.0.1) hinzufügen - OK - OK
  10. Windows aktualisiert nun die Netzwerkeinstellungen, u. U. werden Sie aufgefordert, die Betriebssystem-CD einzulegen (siehe auch: "Installationslaufwerk und -pfad ändern (Source-Daten)".)
  11. Starten Sie den Rechner neu

Aktivieren Sie nun auf dem Server die Internetverbindungsfreigabe, und stellen Sie eine Verbindung zum Internet her. Nun starten Sie am Client z.B. den Internet Explorer.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1210.htm


Windows Kennwörter löschen

Wenn man für Internetverbindungen die Kennwörter abgespeichert hat, kann man diese Kennwörter unter Windows nicht mehr löschen. Es gibt aber zwei Möglichkeiten, diese Kennwörter zu entfernen.

  • Sie löschen alle "*.PWL" Dateien auf Ihrem Rechner, damit werden aber alle Kennwörter gelöscht
  • Sie Installieren von der Windows 95/98 CD aus dem Verzeichnis "\Admin\Apptools\Pwledit" bei Windows 95 bzw. "\Tools\Reskit\Netadmin\Pwledit" bei Windows 98 über -> "Systemsteuerung" -> "Software" -> "Windows-Setup" -> "Diskette" gehen Sie hier nun in das entsprechende Verzeichnis und wählen Sie dann den "Kennwortlisteneditor" aus. Nach der Installation finden Sie das Tool unter "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Kennwortlisteneditor". Mit diesem Programm können Sie einzelne Passwörter löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0138.htm


Sicherheitseinstellungen auch für den Arbeitsplatz

Für den Arbeitsplatz können Sie im Internet Explorer keine Einstellungen vornehmen, da er nicht unter Sicherheitseinstellungen erscheint. Durch einen Eintrag in der Registry können Sie aber auch das ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Zones\ 0

hier ändern Sie nun den Wert "Flags" als Datentyp REG_DWORD von "21" auf "47" (HEX).

Ab jetzt taucht auch der "Arbeitsplatz" unter Sicherheitseinstellungen auf.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Dieser Einstellung geht nur unter:

  • Internet Explorer 5.0
  • Internet Explorer 5.5
  • Internet Explorer 6.0 unter:
    Windows NT
    Windows 2000
    Windows XP

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0225.htm


Deaktivieren des DHCP 'Router Discovery'

Standardmäßig kann man unter Windows über IRDP (Internet Router Discovery Protocol) über TCP/IP VB-Scripte ausführen.

Das ist eine große Sicherheitslücke, da so fremde Leute über das Internet Dateien auf Ihren Rechner starten können um damit an Informationen zu gelangen.

Deshalb sollten Sie diese Funktion aus Sicherheitsgründen deaktivieren, da sie sowieso nicht benötigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Windows 95/95 und ME:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ NetTrans\ xxxx

xxxx steht für Ihre aktuelle Binding-Nummer (Wenn nur ein Netzwerktreiber installiert ist 0001).

Ab Windows NT:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "PerformRouterDiscovery" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Deaktiviert "Router Discovery"
1 | "Router Discovery" ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=216141

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0940.htm


Sicherheitsfehler beheben

Um den TCP/IP Port 139 zu sperren, damit WINNUKE und andere Programme den Rechner bei einer bestehenden Internet Verbindung nicht mehr Remote herunterfahren können, folgendes in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erstellen Sie einen neuen Wert mit dem Namen "BSDUrgent" als Datentyp REG_SZ. Setzen Sie den Wert auf "0".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0308.htm


Sicherheitsloch bei Datei- und Druckerfreigabe

Unter Windows 95/98 und ME können Sie für die Datei- und Druckerfreigabe ein Passwort vergeben. Viele Anwender wiegen sich damit in Sicherheit.

Der "Network Security Focus" hat aber einen Fehler gefunden, der aufzeigt, dass es genügt, vom Passwort nur das erste Byte richtig anzugeben, um den Zugriff auf die Freigabe zu erlangen.

Aufgrund dieses Fehlers sollten Sie aufpassen, wenn Sie die Datei- und Druckerfreigabe verwenden und gleichzeitig auch ins Internet gehen. Da Windows automatisch den Dienst an den DFÜ-Adapter bindet, hat man dann über das Internet leichten Zugriff auf Ihre Daten. Entfernen Sie deshalb lieber unter "Netzwerk" -> "Bindung" die Bindung von DFÜ-Adapter.

Von MS gibt es zur Zeit noch keinen deutschen Patch zu diesem Problem (Stand: 22.12.00).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1028.htm


Nur aufgeführte Shell-Erweiterungen ausführen

Mit diesem Tipp können Sie festlegen, ob nur bestimmte Shell-Erweiterungen vom Explorer geladen werden sollen.

Damit legt der Key "EnforceShellExtensionSecurity" fest, ob die Liste benutzt werden soll oder nicht. Ist der Eintrag aktiv, werden nur noch die Shell-Erweiterungen geladen, welchen unter dem andern Schlüssel (siehe unten) aufgeführt sind. Alle anderen Erweiterungen werden nicht mehr geladen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "EnforceShellExtensionSecurity" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Nur angegebene Shell-Erweiterungen ausführen
gelöscht | Keine Einschränkung (Standard)

Die Liste welche Shell-Erweiterungen geladen werden, ist unter folgendem Registry-Schlüssel zu finden

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Shell Extensions\ Approved

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Shell Extensions\ Approved

hier ist für jede Shell-Erweiterung ein Eintrag zu finden. Als Name wird die CLSID verwenden und als Wert wird meist eine entsprechende Beschreibung angegeben um was für eine Erweiterung es sich handelt. Es handelt sich hierbei um Einträge vom Datentyp REG_SZ.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Nur benutzerbezogene oder zugelassene Shellerweiterungen zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1765.htm


Passwörter nicht in Klartext anzeigen

Passwörter nicht im Klartext anzeigen

Mit diesem Eintrag legen Sie fest, ob bei der Eingabe der Passwörter nur Sternchen/Punkte oder das Passwort angezeigt werden sollen. Aus Sicherheitsgründen sollten die Passwörter nicht im Klartext angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AdvancedSoftware\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

ändern Sie hier den Wert "HideSharePwds" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Passwörter nicht anzeigen
0 | Passwörter anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2115.htm


Einsatz von Poledit

von Jürgen Karl, Karl_Juergen@msn.com

Auf mehrfachen Wunsch - hier eine Anleitung zum Gebrauch von Poledit - auf einem Einzelplatzrechner.

Es sollten zusätzlich das Passwort zum BIOS aktiviert sein sowie alle Einträge aus der Registry unter Folder und Drive im Zweig HKEY_CLASSES_ROOT entfernt werden, mit denen es möglich ist, über die rechte Maustaste (auch im Dialogfeld öffnen und speichern) ein Explorerfenster zu öffnen (obwohl der Explorer evtl. nicht freigegeben ist, lässt sich so eine Instanz starten!).

Voraussetzung: Das System muss beim Starten ein Einloggen mit Benutzername + Passwort ermöglichen.

1. System starten und als Administrator (besitzt alle Rechte) einloggen

2. Systemrichtlinien-Editor (Poledit.exe) starten

3. "Datei - Registrierung öffnen"

Erklärung: Die Einstellungen unter "Lokaler Computer" bleiben immer erhalten, egal, unter welchem Namen man sich einloggt. Die Einstellungen unter "Lokaler Benutzer" dagegen werden dem User zugewiesen, der gerade eingeloggt ist. Das heißt, man kann die Zugriffsrechte eines Benutzers nur ändern, wenn man sich unter seinem Namen eingeloggt hat!

Finger weg von "Datei - Neu", das funktioniert auf Einzelplatzrechnern nicht!

Immer "Datei - Registrierung öffnen" verwenden!

4. "Lokaler Computer" öffnen und gewünschte Einstellungen vornehmen

TIPP: Bei "System - Ausführen" vorläufig Poledit.exe Eintragen, dann wird das Programm immer gestartet, egal wer sich einloggt.

Vorteil: Mann kann verschiedene Benutzer konfigurieren, denen man natürlich den Zugriff auf Poledit.exe nicht gewähren darf (sonst könnten sie ja ihre Rechte selbst ändern), wenn man ihnen aber keinen Zugriff gibt, kann man die Rechte ja gar nicht einstellen; also bei "Lokaler Computer" das Programm starten lassen, dann wird es nämlich ausgeführt.

5. "Lokaler Benutzer" öffnen und gewünschte Einstellungen vornehmen:

Als Administrator sich selbst natürlich alle Rechte gewähren und NIE Poledit.exe sperren (nie "Programme zum Bearbeiten der Registrierung deaktivieren" ankreuzen), sonst sperrt man sich selbst aus und kann nichts mehr einstellen!

6. Unter neuem Benutzernamen einloggen und jeweils gewünschte Einstellungen vornehmen. Nicht vergessen, Poledit.exe bei allen anderen zu sperren (System - Zugriffsbeschränkungen - Programme zum Bearbeiten der Registrierung deaktivieren).

7. Damit nun neue Benutzer, die sich mit einem neuen, dem Computer nicht bekannten Usernamen einloggen - oder bei dem Dialog einfach auf "Abbrechen" klicken - keine Rechte haben: den Dialog zum Einloggen öffnen, aber keinen Namen oder Passwort eingeben, sondern auf "Abbrechen" klicken. Dann Poledit starten und bei "Lokaler Benutzer" sämtliche Rechte deaktivieren, unter einem anderen Namen wieder einloggen und fertig!

Nicht vergessen:

Die Einstellungen bei "Lokaler Computer" sind für alle User gültig, die Programme, die dort eingetragen sind (bei Ausführen), werden IMMER gestartet, egal, wer sich einloggt. Also dort am Besten keine Programme starten lassen sondern nur über den Autostart-Ordner.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0869.htm


Datenschutz mit POLEDIT.EXE

Auch unter Windows lassen sich Rechte der einzelnen Benutzer einschränken. Hierfür findet man auf der Windows 95-CD im Verzeichnis \Admin\Apptools\Poledit das Programm POLEDIT (Windows 98: \Tools\Reskit\Netadmin\Poledit). Installieren Sie das Programm, starten es anschließend und wählen -> "Datei" -> "Registrierung öffnen" -> "Lokaler Benutzer".

Unter "Shell" und "System" können nun weitreichende Zugriffsbeschränkungen vergeben werden.

Mit Poledit.EXE lässt sich auch das zukünftige Bearbeiten der Registry mit Regedit und Poledit sperren.

Sollte dies aus Versehen geschehen oder möchten Sie diese Einschränkung aufheben, müssen Sie entweder die Registry durch eine Sicherungskopie ersetzen (hierfür ist das Utility ERU auf der Windows 95-CD von Nutzen; unter Windows 98 starten Sie "scanreg /restore" im DOS -Modus) oder Sie starten Windows einmal im "Abgesicherten-Modus".

Im "Abgesicherten-Modus" wird die Registry nicht verarbeitet und dadurch ist auch die mit Poledit vorgenommene Einstellung unwirksam: Sie können sie nun wieder zurücknehmen. Starten Sie Windows anschließend im "Standard-Modus" neu.

Sollte Ihr Windows das Bootmenü nicht anzeigen und sich nicht im "Abgesicherten-Modus" starten lassen, öffnen Sie die CONFIG.SYS und entfernen dort den Eintrag "SWITCHES=/N".

Info Sollten Sie mit Poledit Einschränkungen für andere Computer im Netzwerk vornehmen, müssen sich Ihre gespeicherten Einstellungen (POL-Dateien) im Verzeichnis POLICIES befinden. Sie werden sonst nicht gefunden !

Info Siehe auch "Wie verhindere ich, dass Symbole in der Systemsteuerung angezeigt werden?"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0108.htm


Funktionen aus dem Media Player entfernen

Mit den folgenden Einstellungen können Sie einige Funktionen aus dem Media Player entfernen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

erstellen Sie folgende Einträge als Datentyp REG_DWORD:

Wert | Funktion
NoRadioBar | Radioleiste
NoMediaFavorites | Favoriten
NoFindNewStations | Neue Sender

Durch Setzen der Werte auf 1, werden die Einstellungen ausgeblendet, mit 0 werden sie wieder angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1341.htm


So schützen Sie ihr Windows 95/98 System

By Robert Fink, Neumünster, 05.03.1999

Sie haben einen Computer und möchten ihn vor fremden Benutzern sichern? Oder Sie möchten ihren Kindern Zugriff nur auf bestimmte Programme erteilen? Hier erkläre ich, wie es fast ohne Aufwand funktioniert.

Vorwort

Ich habe diese Datei für Windows 95 Rechner beschrieben. Auf Windows 98 müsste es ähnlich funktionieren. Bei Detailfragen schicken Sie mir doch eine Email, was Sie natürlich auf bei allen anderen Problemen tun können. Ich empfehle, die Schritte in der vorgegebenen Reihenfolge zu erledigen, da Sie sich sonst selbst vom Computer aussperren!

Ziel dieses Dokuments

Es wird für ihren PC mit Windows 95/98 die Möglichkeit vorgestellt, diesen mit einem Zugriffsschutz bzw. Benutzerverwaltung zu versehen. Es wird ein Administrator (wohl Sie) eingerichtet und beschrieben, wie Sie beliebigen Benutzern den Zugriff auf Programme u. Ä. erlauben.

Einstellungen und Vorsichtsmaßnahmen

Zuerst muss ihr System auf mehrere Benutzer eingestellt werden. Haben Sie dies bereits getan, so können Sie mit dem nächsten Punkt fortfahren.

Rufen Sie in der Systemsteuerung den Eintrag BENUTZER auf und folgen Sie den Anweisungen. Wählen Sie in der Systemsteuerung BENUTZER und klicken Sie auf die Registerkarte Benutzerprofile. Aktivieren Sie den zweiten Punkt (Benutzer können eigene Einstellungen vornehmen). Im unteren Feld müssen beide Punkte mit Häkchen versehen werden. Starten Sie den PC neu. Sie sollten jetzt ein Dialogfeld mit der Aufforderung, Name und Kennwort einzutragen, sehen.

Geben Sie ein Passwort und einen Namen ein. Speichern Sie aus \windows\ System.dat und User.dat in ein separates Verzeichnis. Diese Dateien enthalten die Systemeinstellungen und sollten daher gespeichert werden, bevor Sie weitere Änderungen vornehmen.

Erstellen des Standarddesktops

Klicken Sie in der Taskleiste auf BEENDEN --> unter anderem Namen anmelden und klicken Sie im Anmeldedialog auf ABBRECHEN. Rechtsklicken Sie auf den Startbutton und wählen ÖFFNEN. Doppelklicken Sie auf PROGRAMME. Entfernen Sie sämtliche Ordner, bis auf Autostart. Löschen Sie auf dem Desktop alle Symbole, die löschbar sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Finden Sie auf der linken Seite den Schlüssel:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Rechtsklicken Sie auf der rechten Seite und wählen Sie DWORD-Wert. Geben Sie ihm den Namen NODESKTOP.

Erstellen Sie auf diese Art und Weise auch folgende Einträge:

  • NOFIND (kein SUCHEN in der Taskleiste)
  • NONEIGHBORHOOD (keine NETZWERKUMGEBUNG)
  • NORUN (kein AUSFÜHREN)
  • NOSETFOLDERS (keine SYSTEMSTEUERUNG)
  • NOSETTAS KBAR (keine Veränderung der Taskleiste möglich)
  • NODESKTOP (kein DESKTOP)
  • NOCLOSE (kein BEENDEN)

Doppelklicken Sie auf die Einträge. Geben Sie ihnen jeweils den Wert 1.

Erstellen Sie unter \windows\ eine Batch-Dat namens beenden.bat. Rechtsklicken Sie darauf, schreiben Sie rund ll.exe user,ExitWindows hinein und speichern Sie. Stellen Sie eine Verknüpfung unter \windows\desktop\ mit dieser Datei her und nennen Sie die Datei BEENDEN.

Melden Sie sich erneut an und wählen Sie wieder ABBRECHEN. Sie sollten jetzt nichts mehr auf dem Desktop sehen. Klicken Sie auf den Startbutton. Sie sollten nur PROGRAMME, HILFE und DOKUMENTE sehen; in PROGRAMME nur AUTOSTART.

Erstellen der Mitbenutzer

Klicken Sie auf BEENDEN-->unter anderem Namen anmelden. Geben Sie den Namen des Mitbenutzers (ihres Sohnes, Frau, Bodyguard,...), des Computers und das Passwort ein. Sie sollten nur den beschränkten Zugriff haben, wie oben beschrieben.

Melden Sie sich unter ihrem Namen an und öffnen Sie den Explorer. Rechtsklicken Sie \windows\profiles\BenutzerXY\Startmenü und wählen Sie "NEU" -> "VERKNÜPFUNG". Hier können Sie unter

DURCHSUCHEN das Programm angeben, welches Benutzer XY verwenden darf.

Für weitere Benutzer wiederholen Sie diese Schritte.

Nachwort

Dies ist ein recht simpler Schutz. Ein Normaluser wird ihn wohl nicht knacken können. Aber durch ein paar Handgriffe ist der Schutz verschwunden.

Besserer, aber gefährlicher Schutz:

Öffnen Sie mit WordPad die Datei C:\MSDOS .SYS. Fügen Sie unter [OPTIONS] den Eintrag BOOTKEYS=0 ein. Dies verhindert z.B. das Booten im Abgesicherten-Modus.

Info Falls etwas schief läuft, können Sie nun nur noch unter erschwerten Bedingungen das System reparieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0226.htm


Starten des Registryeditors unterbinden

Wenn Sie wollen, dass ein Anwender den Registryeditor nicht mehr starten kann, können Sie das mit folgendem Registryeintrag aktivieren. Durch Aktivieren dieses Tipps wird dem Benutzer - bei dem Versuch einen Registrierungs-Editor zu starten - eine Fehlermeldung angezeigt, die erläutert, dass der Vorgang aufgrund einer Richtlinie nicht gestattet ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Schlüssel | Datentyp | Angabe als | Standard
Bei 1 wird das Starten des Registry-Editors unterbunden
DisableRegistryTools | REG_DWORD | Boolean | 0

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Nein
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Zugriff auf Programme zum Bearbeiten der Registrierung verhindern

Info Damit wird nur der Start der beiden Programme REGEDIT.EXE und REGEDT32.EXE unterbunden, nicht aber der Zugriff auf die Registry. Wenn der Anwender einen anderen Registryeditor benutzt, kann er weiterhin auf die Registry zugreifen, soweit er dazu die nötigen Berechtigungen besitzt.

Info Wenn Sie also den Zugriff auf bestimmte Schlüssel verhindern wollen, sollten Sie unter NT bzw. Windows 2000 mit REGEDT32 die Rechte auf diesen Schlüssel so verändern, dass der Anwender nicht mehr das Recht hat, etwas zu verändern. Unter Windows 95/98 ist das leider nicht möglich!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0815.htm


Systemrichtlinien auf einen bestimmten Pfad legen

Standardmäßig wird die Policy im Netlogon-Verzeichnis gesucht und von dort geladen. Wenn Sie im Netzwerk aber langsame Verbindungen haben (z.B. Modemverbindungen) kann es sinnvoll sein, die Policy-Datei lokal auf den Rechner abzulegen, um das Anmelden zu beschleunigen. Ändern Sie dazu in der Registry folgende Werte.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Update

Erstellen Sie hier einen neuen Wert "UpdateMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf 2 (manuelles Update)

Mögliche Werte:

0 | Systemrichtlinien sind ausgeschaltet
1 | Systemrichtlinien werden vom Anmeldeserver aus dem NETLOGON gelesen (Standard)
2 | Systemrichtlinien werden aus dem unter NetworkPath angegebenen Pfad geladen.

Erstellen Sie einen weiteren Wert mit dem Namen "NetworkPath" als Datentyp REG_SZ. Geben Sie hier den Pfad zur Policy-Datei an (z.B.: "%SYSTEMROOT%\System32\NTCONFIG.POL")

Sie müssen die Policy-Datei natürlich unter diesen Pfad ablegen und sollten die Rechte auf die Datei aus Sicherheitsgründen so verändern, dass nur Administratoren diese Datei verändern bzw. austauschen dürfen.

Siehe auch: Windows 2000 Clients sollen auch in einer NT 4.x Domäne/Workgroup eine Policy-Datei laden

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0480.htm


Systemrichtlinien-Einstellung

Mit den Systemrichtlinien können Sie Einstellungen für bestimmte Anwender oder Anwendergruppen einfach vornehmen.

Gerade bei der Verwaltung in einem Netzwerk erfolgt die Konfiguration meist über sogenannte Systemrichtlinien, die mit dem Systemrichtlinieneditor erstellt werden. Für fast alle Funktionen gibt es von Microsoft fertige ADM-Dateien, so dass die Änderungen nicht mehr an der Registry durchgeführt werden müssen, sondern durch einfaches Anklicken aktiviert bzw. deaktiviert werden können.

Unter den folgenden Bereichen finden Sie die jeweiligen Registry-Schlüssel, die in der Registry verändert werden:

Funktionen aus dem Startmenü ein/ausblenden

Funktionen des Desktops ein/ausblenden

Funktionen des Explorers ein/ausblenden

Funktionen zur Bildschirmsteuerung ein/ausblenden

Funktionen zur Druckersteuerung ein/ausblenden

Funktionen zur Netzwerksteuerung ein/ausblenden

Funktionen des Internet Explorers ein/ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0201.htm


Nur bestimmte Anwendungen zum Ausführen freigeben

Im Tipp "Ausführen bestimmter Programme sperren" wurde beschrieben, wie man eine Liste von Programmen erstellt, die nicht gestartet werden dürfen.

Möchte man aber nur ein paar wenige Programme freigeben, ist dieses Vorgehen sehr aufwändig. Durch die folgenden Einträge können Sie eine Liste mit Anwendungen erstellen, die ausgeführt werden dürfen. Dadurch kann es auch nicht passieren, dass Sie vergessen, ein Programm zu sperren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

erstellen Sie einen neuen Eintrag mit dem Namen RestrictRun als Datentyp REG_DWORD. Setzen Sie den Wert auf 1, um die Liste zu aktivieren bzw. auf 0, um die Aktivierung aufzuheben.

Die Liste müssen Sie unter folgendem Schlüssel ablegen:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion \ Policies \ Explorer\ RestrictRun

Erstellen Sie dafür einen neuen Eintrag mit dem Namen "1" als Datentyp REG_SZ. Geben Sie als Wert den Namen der Datei an, die ausgeführt werden soll. Für weitere Einträge zählen Sie die Nummer einfach hoch.

Beispiel:

Wert | Datentyp | Eintrag
1 | REG_SZ | wordpad.exe
2 | REG_SZ | winword.exe
3 | REG_SZ | Explorer.exe

usw.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Nein
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Nur zugelassene Windows Anwendungen ausführen

Info Dabei ist aber darauf zu achten, dass notwendige Programme (Explorer usw.) in dieser Liste eingetragen werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0814.htm


Deaktivieren des Buttons "Abbrechen" beim Anmelden

Beim Starten von Windows und der anschließenden Anmeldung werden Sie aufgefordert, Ihren Namen und Ihr Passwort einzugeben. Dort steht aber auch ein Button "Abbrechen" zur Verfügung, womit man diese Anmeldung umgehen kann. Durch einen Eintrag in der Registry können Sie das verhindern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Network\ Logon

Erstellen Sie den Eintrag "MustBeValidated" (Datentyp REG_DWORD). Setzen Sie den Wert auf 1.

Nun erscheint beim Drücken von "Abbrechen" oder ESC der Hinweis, dass ein Kennwort eingegeben werden muss.

Info Das funktioniert aber nur, wenn Sie sich an einem Windows NT Server anmelden, ansonsten müssen Sie noch folgende Punkte beachten: Damit "MustBeValidated" auch ohne Anmeldung an einem NT-Server ausgewertet wird, muss das "Family Logon" (ab Windows 98) in der Netzwerkumgebung mit installiert werden. In der primären Netzwerkanmeldung wählen Sie jetzt das "Microsoft Family Logon" aus, ansonsten werden Sie beim Anmelden nach einer Domäne gefragt. Legen Sie nun noch einen Benutzer an und schon kann auch hier das Anmelden nicht mehr abgebrochen werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0202.htm


Fehlermeldung: Dieser Vorgang wurde aufgrund von Einschränkungen abgebrochen...

Wenn Sie bei dem Versuch, die Ordneroptionen oder die Internetoptionen zu ändern, die Meldung Fehlermeldung: "Dieser Vorgang wurde aufgrund von Einschränkungen abgebrochen, die für Ihren Computer gelten. Wenden Sie sich an den Systemadministrator." erhalten, können Sie durch das Löschen der folgenden Registry-Schlüssel wieder Zugang zu den Einstellungen erlangen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

und /oder

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

löschen Sie den Eintrag NoFolderOptions.

Unter

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

bzw.

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

löschen Sie den Eintrag NoBrowserOptions.

Info Siehe auch "Funktionen des Internet Explorers ein/ausblenden",
"Funktionen aus dem Startmenü ein/ausblenden" und "Funktionen des Explorers ein/ausblenden".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1292.htm


Wichtige Hinweise-Registrydatenbank

Was ist die Registrydatenbank?

Die Registrydatenbank ersetzt bei Windows weitgehend die INI-Dateien von Windows 3.x (diese Dateien sind unter Windows zwar immer noch vorhanden, werden aber größtenteils nur von 16-Bit-Programmen genutzt). In der Registry werden sowohl von Windows selbst als auch von allen 32-Bit-Programmen Informationen über die Konfiguration eingetragen.

Genauere Informationen zur Registry finden Sie unter: Aufbau der Registrydatenbank

Info Ein Fehler in der Registrydatenbank kann dazu führen, dass Windows nicht mehr startet!

Achtung

Beim Arbeiten mit der Registrydatenbank ist einige Vorsicht geboten, da selbst der kleinste Fehler dazu führen kann, dass Windows nicht mehr startet.

Das Arbeiten mit der Registry ist aber manchmal unumgänglich, weil:

  1. Es gibt viele Einstellungen, die sich nur über die Registrydatenbank ändern lassen.
  2. Über den Registry-Editor kann man Werte bei fernen Rechnern ändern (über das Netz)

Da eine fehlerhafte Änderung in der Registry dazu führen kann, dass Ihr System nicht mehr läuft, sollten Sie sich immer eine Sicherheitskopie der letzten funktionsfähigen Registrydatenbank anlegen.

Beachten Sie dazu bitte folgende Informationen:

  • Sichern der Registry [95/98/ME]
  • Sichern der Registry [ab Windows NT]

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0003.htm


Aufbau der Registrierdatenbank

Aufbau der Registrydatenbank

Windows speichert Informationen über die Konfiguration in einer binären, hierarchisch organisierten Datenbank.

Aufbau:

HKEY_CLASSES_ROOT

HKEY_CURRENT_CONFIG

HKEY_LOCAL_MACHINE

HKEY_CURRENT_USER

HKEY_USERS

Zusätzlich unter Regedit.exe sind noch als Zweige zu sehen:

HKEY_DYN_DATA (diesen Schlüssel gibt es nur unter Windows 95/98 und ME)

HKEY_PERFORMANCE_DATA (nur Windows NT)

Diese Unterteilungen sind nun noch in weitere Unterschlüssel aufgegliedert (wie die INI-Dateien in Sektionen [386Enh], [boot], [network] usw.). Bei der Registry-Datei ist die Aufteilung aber viel genauer.

Jeder Schlüssel kann weitere Unterschlüssel und (im rechten Fensterteil) Werteinträge enthalten. Diese Werteinträge setzen sich aus drei Teilen zusammen:

  • "Name",
  • "Datentyp"
  • "Wert".

Windows NT kennt standardmäßig 5 , Windows 95/98 nur 3 Datentypen. Es besteht aber die Möglichkeit, jederzeit benutzerdefinierte Datentypen hinzuzufügen.

Einige Einträge in der Registry sind doppelt vorhanden. Eine Änderung wirkt sich aber immer auf beide aus, da sie unter einander verknüpft sind.

Des Weiteren ist es möglich, dass Sie widersprüchliche Angaben finden.

In diesem Fall haben immer die USER-spezifischen Einstellung Vorrang (also HKEY_CURRENT_USER hat Vorrang vor den Einstellungen unter HKEY_LOCAL_MACHINE).

Info Bei der Bearbeitung der Registrydatenbank sollten Sie bedenken, dass alle Änderungen sofort gespeichert werden!

HKEY_CLASSES_ROOT:

Der Hauptschlüssel HKEY_CLASSES_ROOT ist ein Verweis auf HKEY_LOCAL_MACHINE\Software\Classes. Durchlaufen Sie HKEY_CLASSES_ROOT, so werden Sie auf eine lange Liste von Dateinamenserweiterungen, etwa EXE oder BMP, stoßen. Die meisten Erweiterungen haben zwar keine Unterschlüssel, besitzen aber Zeichenkettenwerte wie "EXEFILE" für EXE-Dateien und "Paint.Picture" für BMP-Dateien.

Weiter unten im Zweig Classes finden Sie die Unterschlüssel zu diesen Zeichenketten. Diese Unterschlüssel enthalten typischerweise weitere Schlüssel, etwa "DefaultIcon" (das Symbol, mit dem Dateien vom betreffenden Typ von der Shell angezeigt werden), "Shell" (Angaben über das Öffnen und Drucken dieses Dateityps) und "Shellex" (enthält eine Liste der Shell Extension's: Erweiterungen des Kontextmenüs und der Registerkarte für die Einstellungen sowie weitere Plug-in-Softwarekomponenten, die von der Windows 95-Shell unterstützt werden).

HKEY_CLASSES_ROOT ist also eine Datenbank voller Anweisungen, anhand derer die Shell andernfalls gewöhnliche Dateien so handhaben kann, als würde es sich um Dokumente handeln, deren internes Dateiformat sie versteht.

Angenommen, Sie Doppelklicken auf eine BMP-Datei oder klicken mit der rechten Maustaste darauf und wählen "Öffnen" aus dem Kontextmenü. Frage, woher weiß die Shell jetzt, wie sie diese BMP-Datei öffnen soll?

Ganz einfach: Sie sucht in HKEY_CLASSES_ROOT nach einem BMP-Eintrag und stößt dabei auf "Paint.Picture". Daraufhin befragt sie den Eintrag "Paint.Picture" nach dem Kommando zum Öffnen der BMP-Datei. In diesem Fall enthält "Paint.Picture" einen Unterschlüssel Shell\Open\Command mit dem Standardwert MSPAINT %1, was der Shell sagt, dass MSPAINT (Windows 95-Paintbrush) zusammen mit dem Dateinamen zu starten sind. Daraufhin startet MSPAINT und lädt die betreffende BMP-Datei.

Hätten Sie statt dessen verlangt, die Bilddatei zu drucken, so hätte sich die Shell in HKEY_CLASSES_ROOT\Paint.Picture\Shell\Print\Command das entsprechende Kommando zum Drucken gesucht (MSPAINT/P %1).

Beispiel:

Mit dem Registry-Editor können Sie Windows anpassen, indem Sie dem Kontextmenü eigene Kommandos hinzufügen.

  1. Wollen Sie etwa dem Kontextmenü von ZIP-Dateien ein Unzip-Kommando hinzufügen, welches dann PKUNZIP aufruft, so führen Sie folgende Schritte aus:
  2. Erstellen Sie unter HKEY_CLASSES_ROOT einen Unterschlüssel namens .ZIP. Setzen Sie seinen Standardwert auf ZIPFILE.
  3. Erstellen Sie unter HKEY_CLASSES_ROOT 3 (drei) aufeinander folgende Unterschlüssel mit folgenden Namen Zipfile\Shell\Unzip. Setzen Sie seinen Standardwert auf &Unzip (das (&) Et-Zeichen steht dabei die Shortcut-Taste [U]).
  4. Fügen Sie HKEY_CLASSES_ROOT\Zipfile\Shell\Unzip einen Kommandounterschlüssel hinzu. Setzen Sie dessen Standardwert auf das Kommando, das PKUNZIP zusammen mit dem Dateinamen startet - beispielsweise C:\DOS UTIL\PKUNZIP %1. Jetzt können Sie die ZIP-Datei einfach dadurch auspacken, indem Sie diese mit der rechten Maustaste anklicken und die entsprechende Option aus dem Kontextmenü wählen.

HKEY_CLASSES_ROOT (HKEY_LOCAL_MACHINE\Software\Classes)

Schlüssel | Unterschlüssel | Name | Wert | Beschreibung
* |  |  |  | Gültig für alle Dateitypen
 | QuickView | Standard | * | Quick-View im Kontextmenü
 | Shell |  |  | Hat verschiedene Unterschlüssel. Deren Werte sind unter Class-Definitions aufgeführt.
 | Shellex |  |  | Hier können sich Programme eintragen, die im Explorer und Desktop integriert sein sollen.

Schlüssel | Unterschlüssel | Name | Wert | Beschreibung
.EXT |  | Standard | Class-Definition | Zeigt auf die Class-Definition. Dieser Name kann nach Belieben gewählt werden, normalerweise Ext-File
 | ShellNew | Standard | nicht gesetzt | Fügt Neu\Datei ins Kontextmenü ein
 |  | NullFile | nicht gesetzt | Neue Datei ohne Vorlage
 |  | FileName | Datei Name | Neue Datei nach Vorlage, diese befindet sich (normalerweise) in ShellNew
 |  | Command | Befehlszeile | Öffnet die Datei, nachdem sie erstellt wurde

Schlüssel | Unterschlüssel | Name | Wert | Beschreibung
Class- Definition |  | Standard | Name | Dieser Name erscheint unter Ansicht\Optionen... \Dateitypen im Explorer
 |  | EditFlags | Binärwert | 4 Bytes enthaltender Binärwert. Beschreibung siehe dort
 |  | NeverShowExt | nicht gesetzt | Zeichenfolge; die Endung wird im Explorer nicht angezeigt, auch wenn "Keine MS-DOS -Erweiterungen für registrierte Dateien" nicht markiert ist
 |  | AlwaysShowExt | nicht gesetzt | Zeichenfolge; die Endung wird im Explorer immer angezeigt, auch wenn "Keine MS-DOS -Erweiterungen für registrierte Dateien" markiert ist
 |  | IsShortcut | nicht gesetzt | Zeichenfolge; Shortcut-Icon Overlay wird angezeigt
 | QuickView | Standard | * |
 | DefaultIcon | Standard | %1 oder Dateiname,# | Gibt das Icon an. Für # ist die entsprechende Nummer anzugeben
 | Shell | Standard | nicht gesetzt oder Name eines Unterschlüssels | Gibt die Standard-Aktion an (auf Doppelklick), wenn der Wert nicht gesetzt ist, ist Open die Standard-Aktion.
 | Shell\Open | Standard | nicht gesetzt oder Benutzer- definierter Name | Dasselbe wie unter Ansicht\Optionen... \Dateitypen im Explorer
 |  | EditFlags | 00 00 00 00 oder 01 00 00 00 | Grenzt EditFlags unter Class-Definitions für den jeweiligen Eintrag ein. Beschreibung auch unter Edit-Flags
 | Shell\Open\ Command | Standard | Befehlszeile | Assoziiertes Programm und Aktion beim Öffnen der Datei
 | Shell\Name |  |  | Wie unter Open, z.B. Drucken
 | Shellex |  |  | Hier können sich Programme eintragen, die im Explorer und Desktop integriert sein sollen

Schlüssel | Unterschlüssel | Name | Wert | Beschreibung
CLSID | Eindeutiger nummerischer Wert | Wie unter Class- Definition |  | Siehe im Hilfe Inhalt
 | Eindeutiger numerischer Wert\ ShellFolder | Attributes | Binärwert | Attribute für die "GetAttributesOf" Methode, bestimmen die Eigenschaften des Objektes, also auch das Kontextmenü. Werte siehe unter ShellFolder Attributes
Directory |  |  |  | "Dateiordner", Erbe von Folder, alle Möglichkeiten wie für Class-Definitions
Drive |  |  |  | "Laufwerk", Erbe von Folder
Folder |  |  |  | "Ordner"
Unknown |  |  |  | Aktionen für unbekannte Datei-Typen

EditFlags

Die EditFlags bestimmen die Bearbeitungsmöglichkeiten des jeweiligen Dateityps im Explorer unter Ansicht\Optionen...\Dateitypen. Der Wert selbst ist in 4 Bytes kodiert, von denen aber nur die ersten beiden Bytes einen Effekt haben. Die letzten beiden Bytes sind immer 0. Um die Werte zu kombinieren, muss man die entsprechenden Bits setzen.

Byte | Bit | Hex-Wert des Bits | Bedeutung wenn Bit gesetzt (=1) ist.
1 | 1 | 1 | Entfernt den Datei-Typ von der Liste der Dateitypen, sofern es sich tatsächlich um eine physikalische Datei handelt
1 | 2 | 2 | Zeigt den Datei-Typ in der Liste der Dateitypen an, auch wenn es sich nicht um eine Datei, sondern um ein durch seine CLSID repräsentiertes Objekt handelt
1 | 3 | 4 | Typ ohne assoziierte Extension
1 | 4 | 8 | "Dateitypen\Bearbeiten..." ist deaktiviert
1 | 5 | 10 | "Dateitypen\Entfernen" ist deaktiviert
1 | 6 | 20 | "Dateitypen bearbeiten\(Vorgänge)Neu..." ist deaktiviert
1 | 7 | 40 | "Dateitypen bearbeiten\(Vorgänge)Bearbeiten..." ist deaktiviert
1 | 8 | 80 | "Dateitypen bearbeiten\(Vorgänge)Entfernen" ist deaktiviert
2 | 1 | 1 | "Dateitypen bearbeiten\Beschreibung" ist deaktiviert
2 | 2 | 2 | "Dateitypen bearbeiten\Anderes Symbol..." ist deaktiviert
2 | 3 | 4 | "Dateitypen bearbeiten\Als Standard" ist deaktiviert
2 | 4 | 8 |
2 | 5 | 10 | "Anwendung für diesen Vorgang" kann nicht geändert werden
2 | 6 | 20 | DDE Einstellungen können nicht verändert werden

Wenn der Vorgang selbst das EditFlag 01 00 00 00 trägt, werden die letzten beiden Einstellungen überschrieben.

ShellFolder Attribute

Attribute für Systemordner, beispielsweise für den Papierkorb. Man sollte an dieser Stelle etwas vorsichtig sein und nur die Eigenschaften setzen, die auch tatsächlich vorhanden sind. Der Explorer scheint zwar alles "zu schlucken", andere Anwendungen sind aber nicht notwendigerweise genauso genügsam. Das eine bestimmte Eigenschaft hier gesetzt ist, bedeutet ja nicht, dass ein Objekt diese Eigenschaft hat (den Papierkorb kann man eben nicht verschieben, jedenfalls nicht so!)

Byte | Bit | Hex-Wert des Bits | Bedeutung, wenn Bit gesetzt (=1) ist.
 |  | 00 00 00 00 | Kein Bit gesetzt: Die Aktion, welche unter dem CLSID Eintrag angegeben ist, ist erlaubt.
1 | 1 | 01 | Kopieren erlaubt
1 | 2 | 02 | Verschieben erlaubt
1 | 3 | 04 | ?
1 | 4 | 08 | ?
1 | 5 | 10 | Umbenennen erlaubt (funktioniert auch mit dem Papierkorb)
1 | 6 | 20 | Löschen erlaubt. Beim Löschen wird der NameSpace Eintrag entfernt
1 | 7 | 40 | HasPropSheet: Hat Eigenschaften
3 | 1 | 01 | Link: Interpretiert als Shortcut
3 | 2 | 02 | Share:
3 | 3 | 04 | ReadOnly:
3 | 4 | 08 | Ghosted: Kann nicht selektiert werden
4 | 6 | 20 | Folder: Öffnen und Explorer erscheint im Kontextmenü

HKEY_CURRENT_CONFIG:

Der Hauptschlüssel HKEY_CURRENT_CONFIG ist ein Verweis auf die aktive Konfiguration in HKEY_LOCAL_MACHINE\Config\0001. Durch diesen Verweis auf die momentane Konfiguration hat Windows schnellen Zugriff auf die Konfigurationsinformationen der aktuellen Windows-Sitzung.

HKEY_DYN_DATA: (diesen Schlüssel gibt es nur unter Windows 95/98)

Der Hauptschlüssel, der "dynamische" Konfigurationsinformationen enthält - Daten, die während der Laufzeit von Windows derart oft gelesen und geschrieben werden, dass sie aus Performance-Gründen im Arbeitsspeicher und nicht auf der Festplatte gehalten werden. Der Zweig Config-Manager enthält eine Aufstellung aller installierten Hardwaregeräte, die Schlüssel, um diese zu identifizieren, sowie den aktuellen Status der einzelnen Geräte. PerfStats wird vom Systemmonitor-Applet eingesetzt, um Performance-Messungen vornehmen zu können.

HKEY_LOCAL_MACHINE:

Unter dem Schlüssel HKEY_LOCAL_MACHINE legt das Betriebssystem Informationen über den Computer ab. Dazu gehört eine Liste der installierten Hardwares, zugehörige Treiber und deren Einstellungen. Der Unterzweig Config (nur Windows 95/98) enthält eine Liste von Hardwarekonfigurationen. Jedesmal wenn Windows startet, untersucht es die Hardware des PCs und greift dabei - sofern möglich - auf eine passende Konfiguration aus HKEY_LOCAL_MACHINE\Config.

Auf diese Weise kann sich Windows an veränderliche Hardwareumgebungen anpassen, etwa bei portablen PCs mit Dockingstations. Ein weiterer interessanter Punkt ist der Unterschlüssel Enum (nur Windows 95/98). Er enthält alle Geräte, die Windows beim Start im Systembus gefunden hat, u.a. die installierten Laufwerke samt ihrer Kennungen. Informationen über die seriellen Schnittstellen sind in einem separaten Zweig namens Hardware abgelegt. Der Unterschlüssel System enthält Informationen zur Hardwarekonfiguration (installierte Dateisysteme, virtuelle Gerätetreiber). Die Daten sind an dieser Stelle in "Control Sets" angeordnet, wodurch jeder eine komplette Hardwarekonfiguration beschreibt. Der Unterschlüssel System\CurrentControlSet enthält die aktuelle Konfiguration.

Der Unterschlüssel Software enthält globale Softwareeinstellungen für Windows und Applikationen. Win32-Setup-Programme schreiben oft in diesen Bereich der Systemregistrierung, wenn neue Anwendungen installiert werden. Der interessanteste Teil des Unterschlüssels Software ist HKEY_LOCAL_MACHINE\Software\Classes, denn hier stehen die Informationen über Dateinamenserweiterungen und wie diese von der Shell behandelt werden sollen. Diese Einträge werden normalerweise nicht direkt, sondern über HKEY_CLASSES_ROOT angesprochen.

Der Unterschlüssel Security enthält Informationen zur Remote Administration.

HKEY_CURRENT_USER:

Der Schlüssel HKEY_CURRENT_USER ist ein Verweis auf den aktuellen HKEY_USERS Profilschlüssel. Wenn Sie HKEY_CURRENT_USER und den Schlüssel des aktuellen Anwenders unter HKEY_USERS öffnen, so werden Sie feststellen, dass ihre Inhalte identisch sind. Mit Verweis ist in diesem Zusammenhang gemeint, dass HKEY_CURRENT_USER ein Schlüssel ist, der auf einen anderen Teil in der Registrierung zeigt. Jede Änderung im aktuellen Anwenderprofil in HKEY_USERS zeigt sich automatisch auch in HKEY_CURRENT_USER.

Zunächst mag die Sache mit dem Verweis überflüssig erscheinen, dennoch gibt es jedoch einen guten Grund dafür. Wenn eine Applikation Ihre privaten Einstellungen in der Registrierung sichert, so lautet der komplette Schlüssel HKEY_CURRENT_USER\Software\FirmenName\ProduktName\Version.

Da HKEY_CURRENT_USER transparent auf den aktuellen Profilunterschlüssel unter HKEY_USERS abgebildet wird, betreffen die zu sichernden Informationen lediglich den momentanen Anwender. Somit ist es unter Windows 95 möglich, dass ein Anwender eine Applikation auf die eine Art und ein anderer auf eine ganz andere Art konfigurieren kann. Jeder bekommt jeweils nur seine Einstellung zu sehen, wenn er das Programm das nächste Mal aufruft. Das setzt freilich voraus, dass die betreffende Applikation auch Gebrauch von der Systemregistrierung macht und sich auch an deren Spielregeln hält. Das gilt jedoch nur für die wenigsten 16-Bit-Programme. Den vollen Nutzen dieser Einrichtung haben Sie also erst dann, wenn Sie vollständig auf 32-Bit-Programme umgestellt haben.

HKEY_USERS:

Der Schlüssel HKEY_USERS enthält Informationen zu den Anwendern und deren Einstellungen. Er enthält zumindest einen Unterschlüssel namens .Default, in dem das Standardprofil für die Anwender gespeichert ist, die ohne persönliches Profil arbeiten..

Ein persönliches Profil wird immer dann angelegt, wenn sich ein neuer Anwender anmeldet und dieser wünscht, dass seine persönlichen Einstellungen beibehalten werden sollen. Voraussetzung hierfür ist allerdings die Aktivierung der entsprechenden Option. Öffnen Sie die Systemsteuerung und darin die Einstellungen für Kennwörter. Klicken Sie auf die Registerkarte Benutzerprofile und markieren Sie die Option "Benutzer können Vorgaben ändern".

Wird anstatt des Standards ein persönliches Profil benutzt, so enthält HKEY_USERS auch einen Unterschlüssel mit dem Profilnamen des betreffenden Anwenders. Eine Liste der gesicherten Profile findet sich in der Registry unter HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ProfileList.

Die Einträge nach "(Standard)" enthalten die Dateipfadnamen auf die Ordner, die die jeweiligen Anwendereinstellungen enthalten. Ein persönliches Profil für die einzelnen Anwender wird während der Laufzeit aus einer PWL-Datei im Windows-Verzeichnis generiert und dort in einem entsprechenden Ordner im Verzeichnis Profile abgelegt - beispielsweise C:\Windows\Profiles\Rudolf.

Die Unterschlüssel enthalten unter anderem AppEvents (für die Klangbelegungen von Bildschirmfarbe und Tastatur) und Netzwerk (für die Speicherung von permanenten und temporären Netzwerkverbindungen).

Der Unterschlüssel Software ist der Ort, an dem die meisten Win32-Programme ihre Sitzungsinformationen ablegen. Unter früheren Versionen von Windows haben Entwickler solche Daten zumeist in WIN.INI oder in privaten INI-Dateien abgelegt.

Für die Entwicklung von Win-95-Applikationen wird den Programmierern dringend empfohlen, solche Daten unter dem Schlüssel Software\Firmenname\Produktname\Version des aktuellen Profils abzulegen. Für Firmenname ist der Name des Entwicklers einzutragen, für Produktname der des Produkts und Version bezieht sich auf die jeweilige Produktversion.

Wenn Sie den Zweig Software\Microsoft erweitern, zeigen sich Unterschlüssel für verschiedene Microsoft-Programme sowie für Windows selbst (Software\Microsoft\Windows). Bei wachsender Zahl von 32-Bit-Applikationen steigt hier auch die Zahl der Einträge.

Datentypen

Hier werden alle möglichen Datentypen aufgelistet, die in der Registry angelegt werden können, über Regedit bzw. Regedt32 können nur einige davon angelegt werden, weshalb bei Anzeigename der Name aufgeführt wird, welcher in diesen Tools benutzt wird.

Über eine REG-Datei können Sie jeden Datentypen erstellen, dafür müssen Sie die Daten bei den nicht Standard-Datentypen als Hexadezimal-Werte angeben:

"name"=hex(<Nr>): 00 11 22 33

Info Ersetzen Sie <Nr> durch die in der Tabelle aufgeführten Nummer.

NR | Bezeichnung | Anzeige | Beschreibung
0 | REG_NONE | - | Daten ohne bestimmten Typ. Diese Daten werden im Registryeditor in hexadezimalen Format als Binärwert angezeigt.
1 | REG_SZ | String (Zeichenfolge) | Normale Zeichenkette
2 | REG_EXPAND_SZ | Wert der erweiterbaren Zeichenfolge | Zeichenkette mit beliebiger Größe. Hier können auch Variable benutzt werden, deren Werte erst zur Laufzeit eingefügt werden (z.B.: %SYSTEMROOT% oder %USERNAME% usw.)
3 | REG_BINARY | Binärwert | Nur für Binärdaten. Meist Daten für Hardware-Setup-Informationen, die Angabe erfolgt meist hexadezimal
4 | REG_DWORD | DWord-Wert (32-Bit) | Binärer Datentyp (4 Bytes lang)
5 | REG_DWORD_BIG_ENDIAN |  | REG_DWORD_BIG_ENDIAN: Binärer Datentyp (4 Bytes lang) als unwichtigstes Byte an der höchsten Adresse DWORD_LITTLE_ENDIAN: Binärer Datentyp (4 Bytes lang) als unwichtigstes Byte an der niedrigsten Adresse
6 | REG_LINK |  | Eine Unicode Zeichenfolge, die einen symbolischen Link bezeichnet
7 | REG_MULTI_SZ | Wert der mehrteiligen Zeichenfolge | Zeichenkette, mehrere Parameter sind möglich. Die einzelnen Parameter sind durch binäre Nullen zu trennen
8 | REG_RESOURCE_LIST |  | Binärwert. Es handelt sich dabei um eine Serie verschachtelter Arrays zur Speicherung einer Resourcenliste, die von einem Hardwaregerätetreiber oder einem der durch diesen Treiber gesteuerten physischen Geräte verwendet wird. Diese Daten werden vom System erkannt und in die Struktur "\ResourceMap" geschrieben. Sollten nicht händisch bearbeitet/erstellt werden!
9 | REG_FULL_RESOURCE_DESCRIPTOR |  | Binärwert. Es handelt sich dabei um eine Serie verschachtelter Arrays zur Speicherung von Resourcenlisten, die von einem physischen Hardwaregerät verwendet werden. Diese Daten werden durch das System erkannt und in die Struktur "\HardwareDescription" geschrieben. Sollten nicht händisch bearbeitet/erstellt werden!
a | REG_RESOURCE_REQUIREMENTS_LIST |  | Binärwert. Es handelt sich dabei um eine Serie verschachtelter Arrays zur Speicherung einer Liste möglicher Hardwareresourcen eines Gerätetreibers. Das System schreibt eine Teilmenge der Liste in die Struktur "\ResourceMap". Sollten nicht händisch bearbeitet/erstellt werden!
b | REG_QWORD | QWord-Wert (64-Bit) | Ab Windows 2000 Daten, die durch eine ganze Zahl mit 64 Bit repräsentiert werden. Diese Daten werden als Binärdaten in Registryeditor angezeigt.

Info Unter Windows 95/98 gibt es für Zeichenketten nur den einen Datentyp "String". Ab Windows NT hat Microsoft für Zeichenketten 3 unterschiedliche Datentypen eingeführt.

Siehe auch: Weitere Infos zur Registry

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0002.htm


Sichern der Registry [95/98/ME]

Wo speichert Windows die Registry-Informationen?

Die Informationen aus der Registry sind in den folgenden Dateien gespeichert:

SYSTEM.DAT | Benutzerunabhängige Daten
USER.DAT | Benutzerbezogene Daten
CLASSES.DAT | Enthält den HKEY_CLASSES_ROOT -Zweig (nur Windows ME)

Diese Dateien befinden sich im Windows-Verzeichnis, haben die Attribute "System" und "Versteckt" und werden daher unter DOS nur angezeigt, wenn man den Befehl "Dir" mit dem Kommandoparameter "/a" verwendet.

Windows legt die Sicherheitskopien dieser Daten wie folgt an:

Windows 95

Bei jedem erfolgreichen Start werden Kopien der Registry-Dateien erstellt. Diese Dateien befinden sich im Windows-Verzeichnis, sind ebenfalls versteckt und heißen: SYSTEM.DA0 und USER.DA0.

Windows 98/ME

Bei jedem ersten Start eines Tages werden Kopien der Registry-Dateien erstellt. Diese Dateien befinden sich im Verzeichnis Windows\Sysbckup und heißen Rb00n.cab. Voreingestellt sind fünf Sicherungen (n = 0 - 5). Die Anzahl der Sicherungen und die Dateien, die in der Sicherung enthalten sein sollen, können in der Datei Windows\Scanreg.ini festgelegt werden.

Sie können die automatische Sicherung abschalten, indem Sie mit Msconfig.exe unter "Autostart" den Eintrag "Scanregw /autorun" deaktivieren (nicht empfehlenswert).

Info Wenn Sie mehrere Benutzer in ihrem System angelegt haben, legt Windows für jeden Benutzer eine individuelle USER.DAT an, die sich im jeweiligen Userverzeichnis befinden (z.B. findet man die USER.DAT von <Benutzer> im Verzeichnis..."C:\Windows\Profiles\<Benutzer>").

Wie sichert man diese Dateien?

Es gibt dazu ein paar Möglichkeiten, Windows liefert selber Dateien mit, um die Registry sichern zu können. Informationen dazu finden Sie unter:

- Sicherheitskopie der Windows Einstellungen: ERU.EXE für Windows 95

- Sicherheitskopie der Windows Einstellungen: SCANREG.EXE ab Windows 98.

Sie können die Dateien aber auch unter DOS mit folgenden einfachen Befehlen sichern:

Kopieren im DOS-Fenster:

  1. In das Windows-Verzeichnis wechseln
  2. Die Dateiattribute zurücksetzen:
    "Attrib user.dat -r -h -s"
    "Attrib system.dat -r -h -s"
  3. Die Dateien kopieren:
    "Copy user.dat <Zielort>"
    "Copy system.dat <Zielort>"
  4. Die Dateiattribute wieder setzen:
    "Attrib user.dat +h +s"
    "Attrib system.dat +h +s"

Bei mehreren Benutzern sollten Sie mit XCOPY arbeiten, damit auch die benutzerspezifischen USER.DAT mit gesichert werden.

  1. In das Windows-Verzeichnis wechseln
  2. Die Dateien kopieren:
    "XCOPY user.dat <Zielort> /s /h"
    "XCOPY system.dat <Zielort> /s /h"

Wie kopiere ich die Dateien im Notfall zurück?

Am besten starten Sie Windows im DOS-Modus. (Wenn die Meldung "Windows wird gestartet.." erscheint, drücken Sie die F8-Taste und wählen "Nur Eingabeaufforderung".)

  1. In das Windows-Verzeichnis wechseln
  2. Dateiattribute zurücksetzen:
    "Attrib user.dat -h -s -r"
    "Attrib system.dat -h -s -r"
  3. Sicherheitskopie zurück kopieren:
    "Copy <Zielort>\user.dat"
    "Copy <Zielort>\system.dat"
  4. Dateiattribute setzen:
    "Attrib user.dat +h +s"
    "Attrib system.dat +h +s"

Bei mehreren Benutzern müssen natürlich auch noch die benutzerspezifischen USER.DAT Dateien zurückgeschrieben werden.

Info Mit dem "Registry System Wizard" (RSW) können Sie auch die Registry sichern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0009.htm


Sicherheitskopie der Windows Einstellungen (ERU.EXE)

Wenn man einmal seine Systemeinstellungen durcheinander gebracht hat und nichts mehr funktioniert, ist es hilfreich, wenn man auf Sicherheitskopien zurückgreifen kann. Auf der Windows-CD findet man das Hilfsprogramm ERU im Verzeichnis "other\misc\eru\eru.exe", welches die aktuellen Systemeinstellungen auf Festplatte oder Diskette speichert. Dieses Programm sichert die Bootdateien, einige wichtige INI-Dateien und die Registrydatenbank.

Info Dieses Programm sichert zwar die Dateien. Starten SYSTEM.DAT und USER.DAT. Wenn Sie aber mehrere Benutzer angelegt haben, werden die benutzereigenen USER.DAT Dateien nicht gesichert.

Info Bug! Sind CONFIG.SYS und AUTOEXEC.BAT nicht vorhanden, bleibt ERU.EXE tatenlos im Speicher hängen.

Zum Wiederherstellen unter DOS gibt es das DOS -Programm "ERD.EXE", dieses ersetzt im Notfall die aktuellen durch die gesicherten Daten. Zum Sichern und Wiederherstellen der Registry (nicht der *.INI-Dateien!) kann REGEDIT.EXE unter DOS ebenfalls verwendet werden.

Man kann die Datei ERU.INF bearbeiten. So können Dateien, die gesichert werden sollen, hinzugefügt werden oder auch andere ausgeklammert werden. Wichtig ist nur, dass ERU nicht mehr Dateien sichert, als beim Sichern im entsprechenden Fenster angezeigt werden können. Durch Ändern der ERU.INF können die nicht vorhandenen Dateien ausgeklammert werden und ERU läuft problemlos. Auch können die IO.SYS und COMMAND.COM ausgeklammert werden, da diese ohnehin mit einem "SYS C:" ersetzbar sind. So bekommen Sie auch gleich mehr Platz, um andere Dateien einzutragen.

Info Siehe auch: "Sicherheitskopie der Windows Einstellungen (SCANREG.EXE)"

Info Das Programm funktioniert auch unter Windows 98. Da es aber nicht zum Lieferumfang gehört, müssen Sie ein altes Windows 95 besitzen!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0109.htm


Die Registrierdatenbank unter DOS bearbeiten

Die Registrydatenbank unter DOS bearbeiten

Mit REGEDIT.EXE können Sie auch unter DOS die Daten der Registry sichern und wiederherstellen. Das DOS-Programm wird aber nur ausgeführt, wenn es außerhalb von Windows aufgerufen wird. Wollen Sie es in einer DOS-Box ausführen, müssen Sie vorher die Option "Keine Windows-Erkennung durch MS-DOS -basierte Programme" in den Eigenschaften der Command.pif-Datei unter "Programm" - "Erweitert" abschalten.

Mit dem Befehl

regedit /L:c:\%WINDIR%\system.dat /e <laufwerk>\<Verzeichnis>\<name>.reg

können Sie unter DOS die Registry komplett sichern. (/e= export). Die exportierte Registry können Sie unter DOS zurückschreiben, indem Sie

regedit /L:c:\%WINDIR%\system.dat /c <laufwerk>\<Win95-Verzeichnis\<name>.reg

eingeben (/c= create).

Mit regedit /? erhalten Sie eine Liste aller möglichen Regedit-Kommandozeilenparameter.

Info Die angegebene REG-Datei muss unbedingt die kompletten Registrierdaten enthalten und nicht nur einen Teil.

Info REGEDIT unterliegt den DOS -üblichen Speicherlimits. Bei sehr großen REG-Dateien (über 1 MB) kann sich der Rechner beim Erstellen der Registry (regedit /c) völlig aufhängen. Starten Sie in diesem Falle Windows im Abgesicherten-Modus und lesen die REG-Datei mit dem Windows-Programm ein (->"Datei" -> "Registry-Datei importieren").

Info Wollen Sie sehen, welche Änderungen ein Programm an der Registrydatenbank vornimmt, exportieren Sie Ihre Registry zuerst vor und dann nach der Installation. Vergleichen Sie anschließend beide REG-Dateien unter DOS mit dem Befehl:
fc 1st.reg 2st.reg (fc= file compare)
Die Änderungen werden dann in Klartext auf dem Bildschirm ausgegeben.

Info Es gibt auch andere Möglichkeiten, die Registry zu sichern. Siehe "Sicherheitskopie der Windows-Einstellungen"

Sie können dann in etwa so vorgehen:

  1. Booten Sie den Rechner im DOS -Modus (halten Sie während des Bootvorgangs <STRG> (Windows 98) bzw. <SHIFT> (Windows 95) gedrückt, bis das Bootmenü angezeigt wird und wählen Sie dann "Nur Eingabeaufforderung")
  2. Geben Sie an der Eingabeaufforderung folgendes ein:
    REGEDIT /L:C:\%WINDIR%\System.dat /E C:\<path>\System.txt
  3. Öffnen Sie die Datei SYSTEM.TXT mit einem Editor, finden Sie die Einträge, die Sie verändern möchten, nehmen Sie die Änderungen vor und speichern Sie die Datei SYSTEM.TXT.
  4. Schreiben Sie die geänderte SYSTEM.DAT zurück:
    REGEDIT /L:C:\%WINDIR%\System.dat /C C:\<path>\System.txt
  5. Starten Sie den Rechner neu.

Info Siehe auch "Registry-Schlüssel und -Werte löschen".

Info Beachten Sie, dass unter DOS einzelne Registry-Dateien editiert werden. Erstreckt sich die Änderung nicht nur auf die SYSTEM.DAT, sondern auch auf die USER.DAT und /oder die benutzerspezifischen USER.DAT Dateien, vergessen Sie nicht, auch diese Dateien wie oben beschrieben, zu exportieren und importieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0207.htm


Kommentare in die Registry Eintragen

Wenn Sie viel mit der Registry arbeiten und nicht den Überblick über Ihre Einträge verlieren wollen, können Sie Ihre Aktionen direkt in der Registrydatenbank dokumentieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Erstellen Sie eine Zeichenfolge mit dem Namen "REM" und tragen als Wert Ihren Kommentar ein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0206.htm


Registrierung ohne Bestätigung

Hat man eine .REG-Datei importiert, gibt REGEDIT standardmäßig eine Meldung aus, die mit -> "OK" bestätigt werden muss.

Diese Meldung können Sie unterdrücken, wenn Sie REGEDIT mit dem Schalter "/S" aufrufen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CLASSES_ROOT\ regfile\ shell\ open\ command

"regedit.exe %1" in "regedit.exe /s %1"

ändern, wird eine erfolgte Registrierung von nun an standardmäßig nicht mehr gemeldet.

Info Beachten Sie, dass Sie nun auch unerwünschte Manipulationen der Registry, z.B. durch Computerviren, nicht bemerken! Diese Einstellung sollte daher nicht auf vernetzten PCs vorgenommen werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0288.htm


Registry Update ohne Re-Boot

Drücken Sie Ctrl+Alt+Del (Strg+Alt+Entf) für den Task-Manager, wählen Sie Explorer und -> "Task beenden".

Die Frage "Windows herunterfahren" beantworten Sie mit "Nein" und klicken bei der nächsten Frage ("Anwendung reagiert nicht") auf -> "Task beenden".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0290.htm


Registry verkleinern

Löscht man Schlüssel aus der Registry, wird man bald feststellen, dass weder die Datei SYSTEM.DAT noch USER.DAT sich verkleinern. Im Extremfall kann die Gesamtgröße dieser Dateien einen Umfang von mehreren MB erreichen. Durch eine Neuorganisation der Registry werden nicht mehr benötigte Schlüssel tatsächlich gelöscht.

Prinzipiell ist das einfach, man muss nur die gesamte Registry im DOS-Modus einmal exportieren und anschließend wieder einlesen. Damit gibt es aber manchmal Probleme, so dass hier zwei Methoden vorgestellt werden, wie man die Registry komprimieren kann.

Bei dem Löschen von Einträgen in der Registry werden die Dateien "system.dat" und "user.dat" nicht wirklich verkleinert. Die Dateigröße bleibt bis auf das letzte Byte gleich groß. Das bedeutet, dass die gelöschten Einträge in Fragmenten bleiben, ähnlich wie bei dem Dateisystem FAT.

Eine weitere Möglichkeit die Registry zu verkleinern und aufzuräumen bietet das Programm SCANREG.EXE von Windows. Es defragmentiert die Registry und verkleinert Sie dadurch um die gelöschten Einträge. StartenCANREG.EXE funktioniert unter Windows (alle Versionen) allerdings nur mit dem Parameter /FIX. Mit Angabe von anderen Parametern kann es zu Abstürzen kommen, oder es funktioniert dann nicht. Sie müssen Windows dafür im DOS -Modus starten.

Info Haben Sie den MS IE 4.0 mit den Desktoperweiterungen installiert und führen Sie nun die unten angegebenen Schritte aus, hängt er sich beim Hochfahren im Abgesicherten-Modus mit der Fehlermeldung: "Explorer caused fault in Explorer.exe" auf. Nach dem Wegklicken der Meldung über "Close" erscheinen keine Icons und keine Taskleiste, die Maus ist aber noch funktionstüchtig.
Führen Sie nun mir der Maus einen linken Doppelklick auf den Desktop aus und es erscheint das Tasks-Fenster. Hier können Sie über das Menü "Datei" -> "Ausführen" auswählen. Geben Sie nun: %WINDIR% \REGEDIT ALL.REG ein. Die Datei ALL.REG wird dann importiert und alles läuft wieder wie es soll. Man muss aber warten, bis der Request "Die Inf...von ALL.REG wurden... eingetragen" erscheint (das kann etwas länger als gewohnt dauern).

Die einfache Methode:

  • Registry sichern.
  • Registry komprimieren.
    a) Im DOS -Modus starten.
    b) Ins Windows-Verzeichnis wechseln und folgendes eingeben:
    regedit /e kompakt.reg
    regedit /c kompakt.reg
  • Computer neu starten.

Wenn das nicht funktioniert, liegt es meistens daran, dass bestimmte Unterschlüssel zu lang sind. Man muss daher eine etwas umständliche Methode einsetzen.

Die 2. Methode:

  • Backup der Registry anfertigen. Dazu benutzt man das Programm "ERU". Es ist aber auch manuell möglich:
    a) DOS -Fenster öffnen.
    b) Ins Windows-Verzeichnis wechseln.
    c) Folgendes eingeben:
    attrib -s -r -h system.dat
    attrib -s -r -h user.dat
    copy system.dat system.bak
    copy user.dat user.bak
    attrib +s +r +h system.dat
    attrib +s +r +h user.dat
  • Exportieren der Registry:
    a) RegEdit starten.
    b) Arbeitsplatz markieren, Registrierung\Registry-Datei exportieren.
    c) Speichern unter C:\WINDOWS\ ALL.REG
  • Öffnen von HKEY_USERS
    a) Dort gibt es entweder einen (.Default) oder bei mehreren Benutzern mehrere Unterpunkte. Die Unterschlüssel "Software" komplett (sic!) löschen.
    b) Exportieren von HKEY_USERS nach C:\ WINDOWS\ HKU.REG
  • Öffnen von HKEY_LOCAL_MACHINE
    a) Ebenfalls den Unterschlüssel Software komplett löschen. Das kann durchaus Minuten dauern.
    b) Exportieren von HKEY_LOCAL_MACHINE nach C:\ WINDOWS\ HKL.REG
  • Regedit beenden, Windows beenden, Computer im DOS -Modus starten.
  • Minimal Registry erzeugen.
    a) Ins Windows-Verzeichnis wechseln.
    b) Folgendes eingeben:
    regedit /c hku.reg
    regedit hkl.reg (wichtig ohne /c)Computer neu starten und Windows im "Abgesicherten-Modus" starten.
    Das kann einige Zeit dauern, irgendwann erhält man den Hinweis, dass man sich im Abgesicherten-Modus befindet. Die Oberfläche sieht jetzt ungewohnt aus
  • Registry wieder importieren.
    Startmenü\Ausführen\"regedit all.reg" (Ohne Anführungszeichen eingeben).
    Nach einiger Zeit erhält man die Meldung das ALL.REG in die Registry übernommen wurde.
  • Computer neu starten.
  • Einmal eine DOS -Box öffnen und wieder schließen (ist für die Übernahme bestimmter Schriftarteinstellungen notwendig).
  • Im Windows-Verzeichnis findet sich eine Datei WIN368.SWP von 0 Byte Größe. Diese kann gelöscht werden, ebenso die Dateien ALL.REG, HKL.REG und HKU.REG.
  • Fertig.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0291.htm


Reset aller Registry Einträge

In diesem Tipp wird beschrieben, wie Sie die Registryeinträge unter Windows 9x wieder auf den Installationszeitpunkt zurücksetzen können.

Installieren Sie die Datei SHELL.INF aus dem Verzeichnis \WINDOWS\INF neu (Rechtsklick auf die Datei dann -> "Installieren" auswählen) und führen Sie anschließend einen Neustart durch.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0292.htm


Übergabe von langen Datei/Verzeichnisnamen in der Registry

Hier wird beschrieben, wie Sie die Übergabe von langen Dateinamen unter Windows aktivieren können.

Wenn Sie in der Registry den Parameter %1 für die Übergabe des Datei/Verzeichnisnamen benutzen, übergibt Windows diese Parameter im 8+3 Dateiformat und kürzt somit die Dateinamen ab. Wenn Sie aber die langen Dateinamen benötigen müssen Sie statt %1 einfach nur %L benutzen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1394.htm


Registry Abkürzungen in INF-Dateien

Hier die Abkürzungen, die Sie für den Registryzugriff in INF-Dateien usw. finden:

Kürzel | Registry Key
HKCR | HKEY_CLASSES_ROOT
HKCU | HKEY_CURRENT_USER
HKLM | HKEY_LOCAL_MACHINE
HKU | HKEY_USERS
HKR | Relativer Schlüssel, den Windows vorgibt

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0164.htm


Registry-Schlüssel per Batch zurücksetzen

Möchte man einen bestimmten Registry-Wert automatisch zurücksetzen, geht man wie folgt (zuvor exportiert man den gewünschten Zweig mit dem Registry-Editor in eine REG-Datei) vor :

Diese kann dann per Batch-Datei automatisch importiert werden, wenn man den undokumentierten Schalter/s in einer Batch verwendet, also z.B.:

regedit.exe /s back.reg

Mit diesem Schalter wird auch das "OK" unterdrückt. Dieses funktioniert auch unter DOS.

Siehe auch "Registry-Schlüssel und -Werte löschen" und "Registrierung ohne Bestätigung".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0486.htm


Registry-Schlüssel und -Werte löschen

Es gibt zwei Möglichkeiten, um Registry-Zweige zu löschen.

Mit einer REG-Datei

Sehr einfach können Sie ganze Registryeinträge über einen undokumentierten Schalter in einer REG-Datei löschen. Sie müssen vor den angegebenen Registry-Schlüssel einfach nur ein Minuszeichen setzen und schon wird der Schlüssel nicht angelegt, sondern entfernt. Erstellen Sie eine Textdateimit folgendem Aufbau.

Einen ganzen Zweig:

=== Hier schneiden ===
REGEDIT4

[-HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies]

=== Hier schneiden ===

Einen einzelnen Wert:

=== Hier schneiden ===
REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies]
@=-

bzw.
"Name"=-

=== Hier schneiden ===

Speichern Sie diese Datei mit der Dateiendung .REG ab. Durch Rechtsklick und "Zusammenführen" wird der angegebene Registryzweig aus der Registry entfernt.

Per INF-Datei

Mit einer INF-Datei kann man einen Unterzweig der Registry bequem entleeren. Man erstellt dazu eine INF-Datei (hier löschen *.inf), welche man über das Kontextmenü mit dem Eintrag "installieren" startet:

[Version]

signature="$chicago$"

[DefaultInstall]

DelReg=Delete

[Delete]

HKLM,"SOFTWARE\weiterer Pfad..."

Für den ersten Wert gilt folgendes:

HKLM = HKey_Local_Machine

HKCU = HKey_Current_User

HKCR = HKey_Classes_Root

HKU = HKey_Users

Wichtig:

Den obigen Text nicht einfach kopieren, da jede Zeile mit einem Return im Editor abgeschlossen werden muss. Dies gilt auch für die letzte Zeile.

Das Script kann auch mehrere Bereiche gleichzeitig löschen, indem man dem Befehl DelReg mehrere Unterbereiche angibt und diese durch Komma trennt, z.B.:

DelReg=Delete1,Delete2

Selbstverständlich müssen die zu löschenden Variablen dann auch unten angegeben werden (in einer eckigen Klammer)

Siehe auch "Registry-Schlüssel per Batch zurücksetzen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0487.htm


Registry aufräumen mit RegClean

Bei MS können Sie das Programm RegClean herunterladen. Mit diesem Programm können Sie die Registry überprüfen lassen und fehlerhafte/ungültige Einträge aus der Registry entfernen.

Wenn Sie das Programm starten und die Registry überprüfen lassen, erstellt das Programm automatisch eine O-Datei, womit Sie die Änderungen wieder zurücksetzen können, wenn etwas nicht mehr funktionieren sollte. Die Datei heißt o Rechnername JJJJMMTT hhmmss.REG, wobei die Zeichen vor dem Punkt für das Datum und die aktuelle Uhrzeit stehen.

RegClean können Sie auch mit folgenden Parametern starten:

/? | Hilfe
/A | Automatisch ohne Oberfläche, ohne Benutzeraktion
/S | Stiller Modus ohne Oberfläche
/D | Detaillierte Oberfläche
/L [file] | mit Logfile

Zum Aufruf müssen die Parameter einfach in den Eigenschaften der Verknüpfung bei Ziel hinzugefügt bzw. in der Kommandozeile mit angegeben werden, z.B. "C:\Regclean\Regclean /D"

Info Einen Link zum Download von RegClean finden Sie unter "Sonstige Programme"

Info Siehe auch: "RegClean bleibt stehen".

Fehler: DirectX wird von RegClean beeinflusst!

Nach jedem Ablauf von RegClean zeigt das DirectX-Daiagnoseprogramm unter dem Tab "Eingabe" die Meldung: "In der Systemregistrierung sind Probleme aufgetaucht. Details sind in der gespeicherten Textdatei nachzulesen."

Nach Zurückspielen der .REG-Datei ist diese Meldung wieder weg.

Die "gespeicherte Textdatei" zeigt zum Fehler an:

-------------

Input Devices

-------------

Poll w/ Interrupt: Yes

Registry: Errors found :

Key 'HKCR\CLSID\{92187326-72B4-11d0-A1AC-0000F8026977}\ProgID' is missing.

Dazu passend findet sich in der Ausgabe von RegClean:

[HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{92187326-72B4-11d0-A1AC-0000F8026977}\ProgID]

@="CPL-Handler für Gamecontroller"

Man sollte sich eine .REG-Datei erstellen, die nur diesem relevanten Teil enthält. Nach Zurückspielen dieser Datei ist die Fehlermeldung in DirectX-Diagnoseprogramm weg!

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1184.htm


Informationen über die Datei SYSTEM.INI

Die Datei SYSTEM.INI enthält Einstellungen, die Windows ermöglichen, sich an die vorhandene Hardware anzupassen. Sie ist in logische Abschnitte gegliedert. Ein neuer Abschnitt beginnt immer mit einem Namen, der in eckige Klammern gesetzt ist. In einem Abschnitt stehen ein oder mehrere Schlüsselnamen, die von einem "="-Zeichen und einem Wert gefolgt sind. Ein Wert kann eine Zeichen- oder Zahlenfolge oder eine Boole'sche Variable (on/off, true/false, yes/no, 1/0) sein.

Die meisten Einträge aus der SYSTEM.INI aus den Abschnitten [386Enh] und [network] findet man unter HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\Vnetsetup

Manche Einstellungen in der SYSTEM.INI sind für Windows nicht mehr relevant. Sie können mit der Systemsteuerung verändert werden, tauchen aber auch in der Registrydatenbank so gut wie nicht auf. Lediglich die Angaben der wichtigen Gerätetreiber (Anzeige, Maus, Tastatur, Sound und Network) erscheinen noch unter HKEY_LOCAL_MACHINE

Info In der SYSTEM.INI sind keine langen Dateinamen erlaubt! Um ein Programm mit langem Dateinamen einzubinden, muss man den kurzen DOS -Namen mit Tilde und Ziffer verwenden.

In der SYSTEM.INI sind standardmäßig folgende Abschnitte vorhanden:

[boot] | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ InstalledFiles
Enthält Gerätetreiber und Module, die bei jedem Start benötigt werden. Alle Einstellungen in diesem Abschnitt (außer CachedFileHandles) sind für den Ablauf erforderlich. Die meisten dieser Einstellungen werden bei der Windows-Installation in die SYSTEM.INI eingetragen und man sollte sie nicht löschen oder verändern.
Schlüsselnamen: |
286Grabber= | Dateiname des Grafiktreibers für den Real-Modus (für Windows nicht relevant)
386Grabber= | Dateiname des Grafiktreibers für den erweiterten Modus
CachedFileHandles= | max. Anzahl der DLL- und EXE-Dateien, die permanent geöffnet bleiben können. Es sind Werte zwischen 2 und 12 möglich.
comm.drv= | Dateiname des Treibers für die serielle Schnittstelle
display.drv= | Dateiname des Bildschirmtreibers (kann über die Systemsteuerung geändert werden)
drivers= | Datei- oder Alias-Name des installierbaren Treibers, die von Windows beim Start geladen werden. Benötigt der Treiber Parameter, müssen diese im Abschnitt [drivers] über den Alias-Namen zugewiesen und definiert werden.
fixedfon.fon= | Schriftart mit fester Zeichenbreite
fonts.fon= | Proportionalschrift
keyboard.drv= | Dateiname des Tastaturtreibers (kann über die Systemsteuerung geändert werden)
language.dll= | Dateiname der DLL, die Informationen über die Sprache beinhaltet. Falls kein Eintrag vorhanden ist, wird "Englisch (USA)" verwendet.
mouse.drv= | Dateiname des Maustreibers (kann über die Systemsteuerung geändert werden)
network.drv= | Dateiname des Netzwerktreibers (kann über die Systemsteuerung geändert werden)
oemfonts.fon= | Schriftarten-Datei für OEM-Zeichensatz.
Shell= | Anwendung, die beim Start von Windows automatisch geladen wird.
sound .drv= | Dateiname des Treibers für Tonsteuerung. (kann über die Systemsteuerung geändert werden)
system.drv= | Dateiname des System-Hardwaretreibers
TaskMan.EXE= | Anwendung für den Taskwechsel, die beim Drücken von Alt+Ctrl+Esc gestartet wird.
[boot.description] |
Einträge, die mit Windows-Setup geändert werden können.
Schlüsselnamen: |
meist Treiber-Datei= | Name der Komponente, wie sie im Setup genannt wird.
[drivers] |
Alias-Namen für installierbare Gerätetreiber.
Schlüsselnamen: |
Alias-Name= | Dateiname des installierbaren Gerätetreibers mit optionalen Parametern. Für jedes Gerät können mehrere Alias-Namen definiert werden.
[keyboard] |
Alle Tastatur-Einstellungen. Alle Einstellungen in diesem Abschnitt werden von Windows benötigt. Man sollte hier nichts löschen.
Schlüsselnamen: |
keyboard.dll= | Dateiname der DLL, die das Layout für nicht-US-Tastaturen enthält. Diese Einstellung wird für alle Tastatur-Typen (ausgenommen IBM XT PC/AT ®, AT&T 301/302, Olivetti, 83-Tasten) benötigt.
oemansi.bin= | Dateiname der Datei, die OEM/ANSI-Code-Umwandlungstabellen enthält. Diese Einstellung wird benötigt, wenn man einen anderen Zeichensatz als Codepage 437 (US-OEM-Zeichensatz) verwendet.
subtype= | Definiert bestimmte Tastaturfunktionen für bestimmte Treiber. Mögliche Einstellung sind: None (Standard), 1 (Olivetti, 102 Tasten auf M24-Systemen), 2 (Olivetti M24, 83 Tasten oder AT&T 6300 301, 83 Tasten) und 4 (AT&T 303 bzw 6300 Plus).
type= | Dateiname des Treibers für einen bestimmten Tastatur-Typ. Mögliche Einstellungen sind: 1(IBM PC oder XT-kompatibel, 83 Tasten), 2 (Olivetti, 102 Tasten, ICO), 3 (IBM AT-kompatibel, 84 bzw. 86 Tasten) und 4 (IBM kompatibel, erweitert, 101 bzw. 102 Tasten). Wird hier nichts eingetragen, wird der Standardtreiber Keyboard.drv verwendet (IBM-kompatible Tastatur).
[mci] |
Hier werden Treiber die für die Medien-Wiedergabe eingetragen. Hier gibt es keine Standard-Schlüsselnamen.
Schlüsselnamen: |
Gerät für Mediensteuerung= | Dateiname des Treibers
[NonWindowsApp] |
Einstellungen für Nicht-Windows-Programme
Schlüsselnamen: |
CommandEnvSize= | Größe der Umgebung von COMMAND.COM und Batch-Dateien. Mögliche Einstellungen sind zwischen 160 und 32768 (Größe in Bytes). Standardeinstellung ist hier 0 (übernimmt die Einstellung aus "SHELL=COMMAND.COM /e:xxxx" in CONFIG.SYS).
DisablePositionSave= | Mögliche Einstellungen sind hier 0 und 1. Dieser Eintrag entscheidet über das Sichern bzw. Nicht-Sichern der Schriftart und der Position der Anwendungen. Wird "Sichern" gewählt, werden die Informationen in die DOS APP.INI eingetragen.
FontChangeEnable= | Mögliche Einstellungen sind hier 0 und 1. Standardeinstellung ist 0. Eine 1 ist nur dann zu setzen, wenn man Windows 3.0 (Achtung NICHT Windows 3.1!)-Treiber verwendet, die beim Ändern von Schriftart bei laufenden Programmen Probleme verursachen
GlobalHeapSize= | Größe des von Windows im Real-Modus benötigten konventionellen Speichers in KB. Im erweiterten Modus wird die Einstellung nicht ausgewertet. (für Windows nicht relevant)
LocalTSRs= | Definiert, welche TSR-Programme in jede Instanz einer virtuellen Maschine kopiert werden. Nur vollkommen Windows-kompatible Programme funktionieren einwandfrei als LokalTSR. Man sollte hier nicht zu viele Programme Eintragen! Standardeinstellung ist "DOS edit, ced"
MouseInDOS Box= | Mögliche Einstellungen sind 0 und 1. Wichtig ist die Einstellung nur, wenn man Windows 3.0 (Achtung NICHT Windows 3.1)-Maustreiber verwendet. In diesem Falle wird bei gesetzter 0 die Maus im DOS -Fenster nicht unterstützt.
NetAsynchSwitching= | Mögliche Einstellungen sind 0 und 1. Definiert, ob nach einem asynchronen Netzwerk-BIOS-Aufruf von der Anwendung weggeschaltet werden kann. Standard-Einstellung ist 0
ScreenLines= | Anzahl der Bildschirmzeilen, die von den Anwendungen angezeigt werden sollen. Standard-Einstellung ist 25. Programme mit eigenem Bildschirm-Modus können die Einstellung überschreiben.
SwapDisk= | Laufwerk und Verzeichnis, auf das die Anwendungen ausgelagert werden. Wenn kein Eintrag vorhanden, werden die *.TMP-Dateien ins TEMP-Verzeichnis (wenn vorhanden), oder ins Root-Verzeichnis ausgelagert.
[386Enh] |
Einstellungen für Windows im erweiterten 386-Modus und für virtuelle Maschinen
Schlüsselnamen: |
32BitDiskAcces= | Schaltet 32 Bit-Festplatten-Zugriff ein und aus. Mögliche Einstellungen on/off
A20EnableCount= | Anzahl der möglichen A20-Enable. Man sollte diese Einstellung möglichst nicht verändern.
AllVMsExclusive= | Legt fest, ob alle Anwendungen im Vollbildmodus ablaufen müssen. Mögliche Einstellungen sind false/true. Wird hier "true" eingetragen, werden Einstellungen in der *.PIF-Datei ignoriert.
AltKeyDelay= | Wartezeit zwischen Alt-Unterbrechung und Tastatur-Unterbrechung in Sekunden. Standard-Einstellung ist ".005" (kann über die Systemsteuerung geändert werden)
AltPasteDelay= | Wartezeit zwischen Drücken der Alt-Taste und Einfügen von Zeichen in Sekunden. Standard-Einstellung ist ".025" (kann über die Systemsteuerung geändert werden)
AllEMSLocked= | Bestimmt, ob der Inhalt des Expanded Memory gesperrt oder auf Platte ausgelagert wird. Mögliche Werte sind false/true. Bei Verwendung eines Platten-Cache-Programms das EMS verwendet, sollte dieser Wert auf "true" gesetzt werden. Standard-Einstellung ist "false". (kann über die Systemsteuerung geändert werden)
AllXMSLocked= | Bestimmt, ob der Inhalt des Extended Memory gesperrt oder auf Platte ausgelagert wird. Mögliche Einstellungen sind false/true. Standard-Einstellung ist "false". (kann über die Systemsteuerung geändert werden)
AutoRestoreScreen= | Bestimmt, ob der Bildschirm-Inhalt von der Anwendung oder von Windows gesichert wird. Mögliche Einstellungen sind true/false. Standard-Einstellung ist "true" (Windows sichert den Bildschirminhalt). Funktioniert nur mit VGA-Bildschirmen.
BkGndNotifyAtPfault= | Bestimmt, ob beim Anwendungswechsel eine Notification an eine Anwendung oder an Windows gesendet wird. Mögliche Einstellungen sind false/true. Standard-Einstellung ist "false" (VGA). Nur für TIGA- und 8514-Bildschirme sollte diese Einstellung auf "true" gesetzt werden.
CGA40WOA.FON= | Schriftart mit fester Schreibschrittteilung für Anwendungen, mit einer Anzeige mit 40 Spalten/25 Zeilen oder weniger.
CGA80WOA.FON= | Schriftart mit fester Schreibschrittteilung für Anwendungen, mit einer Anzeige mit 80 Spalten/25 Zeilen oder weniger.
CGANoSnow= | Mögliche Einstellungen sind no/yes. Standardeinstellung ist "no". Ein "yes" sollte man nur bei CGA-Bildschirmen setzen (verhindert "Schnee" auf dem Bildschirm).
COM1AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle COM1 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Mögliche Einstellungen sind 0-1000. Standard-Einstellung ist "2"
COM2AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle COM2 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Mögliche Einstellungen sind 0-1000. Standard-Einstellung ist "2"
COM3AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle COM3 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Mögliche Einstellungen sind 0-1000. Standard-Einstellung ist "2"
COM4AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle COM4 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Mögliche Einstellungen sind 0-1000. Standard-Einstellung ist "2"
COM1Base= | Adresse der seriellen Schnittstelle COM1. Standard-Einstellung ist "3E8h"
COM2Base= | Adresse der seriellen Schnittstelle COM2. Standard-Einstellung ist "3F8h"
COM3Base= | Adresse der seriellen Schnittstelle COM3. Standard-Einstellung ist "3E8h"
COM4Base= | Adresse der seriellen Schnittstelle COM4. Standard-Einstellung ist "3F8h"
COMBoostTime= | Zeit, die einer virtuellen Maschine für Verarbeitung eines COM-Interrupts zur Verfügung steht (in Millisekunden ). Standard-Einstellung ist "2"
COM1Buffer= | Größe des Puffers für die COM1-Schnittstelle (in Zeichen). Standard-Einstellung ist "128"
COM2Buffer= | Größe des Puffers für die COM2-Schnittstelle (in Zeichen). Standard-Einstellung ist "128"
COM3Buffer= | Größe des Puffers für die COM3-Schnittstelle (in Zeichen). Standard-Einstellung ist "128"
COM4Buffer= | Größe des Puffers für die COM4-Schnittstelle (in Zeichen). Standard-Einstellung ist "128"
COMdrv30= | Besagt, ob der virtuelle COM-Treiber eine eigene Kopie der Interrupt-Routine des Treibers für die serielle Schnittstelle benutzt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off". Nur wenn Anwendungen benutzt werden, die den COM-Treiber für Windows 3.0 benötigen, sollte diese Einstellung auf "On" gesetzt werden.
COM1FIFO= | Besagt, ob für COM1 der FIFO-Puffer benutzt wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird benutzt.
COM2FIFO= | Besagt, ob für COM2 der FIFO-Puffer benutzt wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird benutzt.
COM3FIFO= | Besagt, ob für COM3 der FIFO-Puffer benutzt wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird benutzt.
COM4FIFO= | Besagt, ob für COM4 der FIFO-Puffer benutzt wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird benutzt.
COM1Irq= | Interrupt für die COM1-Schnittstelle. Standard-Einstellung ist "4"
COM2Irq= | Interrupt für die COM2-Schnittstelle. Standard-Einstellung ist "3"
COM3Irq= | Interrupt für die COM3-Schnittstelle. Standard-Einstellung ist "4"
COM4Irq= | Interrupt für die COM4-Schnittstelle. Standard-Einstellung ist "3"
COMIrqSharing= | Besagt, ob für alle COM-Ports der gleiche IRQ benutzt werden darf. Standard-Einstellung ist "Off" - COM1+COM3 und COM2+COM4 benutzen jeweils einen IRQ. Nur bei MCA-Geräten ist diese Einstellung auf "On" zu setzen.
COM1Protocol= | Besagt, ob Windows in einer virtuellen Maschine Zeichen simuliert soll, nachdem die virtuelle Maschine ein XOFF an COM1 gesendet hat. Normalerweise ist diese Einstellung nicht vorhanden. Wenn Anwendungen bei hoher Übertragungsrate Zeichen verlieren, ist diese Einstellung auf "XOFF" zu setzen.
COM2Protocol= | Besagt, ob Windows in einer virtuellen Maschine Zeichen simuliert soll, nachdem die virtuelle Maschine ein XOFF an COM2 gesendet hat. Normalerweise ist diese Einstellung nicht vorhanden. Wenn Anwendungen bei hoher Übertragungsrate Zeichen verlieren, ist diese Einstellung auf "XOFF" zu setzen.
COM3Protocol= | Besagt, ob Windows in einer virtuellen Maschine Zeichen simuliert soll, nachdem die virtuelle Maschine ein XOFF an COM3 gesendet hat. Normalerweise ist diese Einstellung nicht vorhanden. Wenn Anwendungen bei hoher Übertragungsrate Zeichen verlieren, ist diese Einstellung auf "XOFF" zu setzen.
COM4Protocol= | Besagt, ob Windows in einer virtuellen Maschine Zeichen simuliert soll, nachdem die virtuelle Maschine ein XOFF an COM4 gesendet hat. Normalerweise ist diese Einstellung nicht vorhanden. Wenn Anwendungen bei hoher Übertragungsrate Zeichen verlieren, ist diese Einstellung auf "XOFF" zu setzen.
ConservativeSwapfileUsage= | Steuert die Verwendung des virtuellen Speichers (Swapfile, Win386.swp). Mögliche Werte sind 1/0. Standard ist "1" für Windows 95 und "0" für Windows 98. Siehe auch: "Swap-Verhalten beeinflussen".
Device= | Geräte-Treiber für Windows im erweiterten Modus.
Display= | Gerätetreiber für die Bildschirmanzeige (kann über die Systemsteuerung geändert werden).
DMABufferIn1MB= | Besagt, ob Windows den DMA-Puffer im Speicher unterhalb 1MB (aber wenn möglich oberhalb 640 KB) unterbringen soll. Mögliche Einstellungen sind on/off. Standardeinstellung ist "Off" Nur wenn 8-Bit-Master-Karten benutzt werden, ist diese Einstellung auf "On" zu setzen.
DMABufferSize= | Größe des DMA-Puffers in KB (kann über die Systemsteuerung geändert werden)
DOS PromptExitInstruc= | Besagt, ob Windows beim Öffnen der DOS -Box eine Meldung anzeigen soll. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" (kann über die Systemsteuerung geändert werden).
DualDisplay= | Besagt, ob Windows den Speicherbereich B000:0000-B7000 benutzen darf. Mögliche Einstellungen sind on/off. Werden zwei Bildschirme verwendet, muss diese Einstellung auf "On" gesetzt sein.
EBIOS = | Erweitertes BIOS -Gerät das von Windows verwendet wird (wie "Device").
EGA40WOA.FON= | Schriftart mit fester Schreibschrittteilung für Anwendungen mit einer Anzeige mit 40 Spalten/25 Zeilen oder weniger.
EGA80WOA.FON= | Schriftart mit fester Schreibschrittteilung für Anwendungen mit einer Anzeige mit 80 Spalten/25 Zeilen oder weniger.
EISADMA= | Operationsmodus eines erweiterten DMA. (Bits, Words oder Bytes). Mögliche Einstellungen sind: Off; 0,8; 1,8; 2,8; 5,16w; 6,16w; 7,16w. Wird kein EISA-Bus verwendet, ist diese Einstellung auf "Off" zu setzen.
EMMExclude= | Speicherbereich, den Windows nicht verwenden darf. Der Bereich muss sich zwischen A000-EFFF befinden. Der erste Wert wird um Vielfache von 16kBabgerundet, der zweite aufgerundet.
EMMInclude= | Speicherbereich, in dem Windows nach freien Adressen suchen soll. Der Bereich muss sich zwischen A000-EFFF befinden. Der erste Wert wird um Vielfache von 16kBabgerundet, der zweite wird aufgerundet.
EMMPageFrame= | Speicheradresse, an der ein 64 k Seitenrahmen beginnen soll, wenn Windows keinen Seitenrahmen findet.
EMMSize= | Größe des Speichers in k, der EMS zugeordnet werden kann. Mögliche Einstellungen sind 0-6536. Standard-Einstellung ist 6536
FileSysChange= | Besagt, ob Dateimanager eine Meldung bekommt, wenn eine Nicht-Windows-Anwendung eine Datei anlegt/ löscht/ umbenennt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - es erfolgt eine Meldung.
Global= | DOS -Programme, die von Windows nicht wie LocalTSRs behandelt werden sollen.
HardDiskDMABuffer= | Größe des DMA-Puffers für Festplatten. Standard-Einstellung ist "0" für AT- und 64 für MCA-Computer.
HighFloppyReads= | Mögliche Werte sind Yes/No. Standard-Einstellung ist "Yes". Bei Problemen mit dem Floppy-Laufwerk kann man testweise diesen Wert auf "No" setzen, muss dann aber auch EMMExclude=E000-EFFF verwenden.
IdleVMWakeUpTime= | Zeitraum bis zur Reaktivierung einer virtuellen Maschine im Leerlauf mit Hilfe von Timer-Interrupt. Mögliche Einstellungen sind Potenzen von 2. Standard-Einstellung ist 8
IgnoreInstalledEMM= | Besagt, ob Windows im erweiterten Modus starten soll, wenn ein unbekannter EMM-Manager aktiv ist. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - Windows startet nicht.
InDOS Polling= | Besagt, ob Windows die Ausführung anderer Programme verhindern soll, wenn ein TSR auf "InDOS " gesetzt ist. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off"; andere Anwendungen werden ausgeführt.
INT28Critical= | Besagt, ob Windows nach Aufrufen von Int28h ein Timeout verwendet. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - Timeout.
IRQ9Global= | Besagt, ob INT9-Aufrufe als global behandelt werden sollen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - nicht global. Diese Einstellung sollte auf "On" gesetzt werden, wenn Lesen von Disketten zum Systemabsturz führt.
Keyboard= | Tastaturtreiber (kann über die Systemsteuerung geändert werden)
KeyBoostTime= | Zeit, die einer Anwendung im Vordergrund zur Verfügung steht, um einen Tastendruck zu verarbeiten (in Sekunden ). Standard-Einstellung ist "001".
KeyBufferDelay= | Verzögerung vom Einfügen von Eingaben bei vollem Tastatur-Puffer (in Sekunden ). Standard-Einstellung ist "2".
KeyIdleDelay= | Besagt, wie lange Windows Leeraufrufe von der Tastatur ignoriert (in Sekunden ) Standard-Einstellung ist "5".
KeyPasteCRSkipCount= | Besagt, wie oft nach einem Return der Tastatur-Status (Int16h) vom Tastatur-Puffer die Meldung "leer" erhalten soll. Gibt unter anderem an, wie viel Zeit einer Nicht-Windows-Anwendung beim Einfügen von Texten aus der Zwischenablage zur Verfügung steht (Kann über die Systemsteuerung geändert werden)
KeyPasteKeyDelay= | Zeichenwiederholrate (kann über die Systemsteuerung geändert werden),
KeyPasteSkipCount= | Besagt, wie oft nach Einfügen eines Zeichens der Tastatur-Status (Int16h) vom Tastatur-Puffer die Meldung "leer" erhalten soll. Gibt unter anderem an, wie viel Zeit einer Nicht-Windows-Anwendung beim Einfügen von Texten aus der Zwischenablage zur Verfügung steht.
KeyPasteTimeout= | Zeit in Sekunden , die Windows wartet bis es vom Schnelleinfüge- Modus (Int16h) in den Normalen Modus wechselt (Int9h) (kann über die Systemsteuerung geändert werden)
KeybdPasswd= | Passwort für die Tastatur. (für Windows nicht relevant)
KeybdReboot= | Besagt, ob Windows per Alt+Ctrl+Del gebootet wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - nach Beenden von Windows wird keine Aufforderung zum Drücken von Alt+Ctrl+Del angezeigt.
Local= | TSRs die nach Aufruf nur im aktuellen Fenster geladen werden sollen. (für Windows nicht relevant)
LocalLoadHigh= | Besagt, wie Windows UMBs verwendet. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - Windows belegt sämtliche UMBs.
LocalReboot= | Besagt, ob Windows per Alt+Strg+Entf gebootet wird oder nicht reagierende Anwendungen schließt. Mögliche Werte sind on/off. Standard-Einstellung ist "On".
LPT1AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle LPT1 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Standard-Einstellung ist 60. Diese Einstellung erscheint nur, wenn von Windows 3.0 upgedatet wurde.
LPT2AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle LPT2 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Standard-Einstellung ist 60. Diese Einstellung erscheint nur, wenn von Windows 3.0 upgedatet wurde.
LPT3AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle LPT3 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Standard-Einstellung ist 60. Diese Einstellung erscheint nur, wenn von Windows 3.0 upgedatet wurde.
LPT4AutoAssign= | Besagt, wie viele Sekunden eine Anwendung die Schnittstelle LPT4 benutzen darf, bis eine andere, aktive Anwendung darauf zugreifen kann. Standard-Einstellung ist 60. Diese Einstellung erscheint nur, wenn von Windows 3.0 upgedatet wurde.
LRULowRateMult= | Wert, mit dem die Anweisung "LRUSweepFreq" multipliziert wird um die am längsten nicht genutzte untere Auslagerungsrate zu ermitteln. Mögliche Einstellungen sind 1-65335. Standard-Einstellung ist "10"
LRURateChngTime= | Besagt, wie lange der VMM bei einer Auslagerungsrate bleibt, bevor er in den nächsten Status umschaltet (in Millisekunden ). Standard-Einstellung ist "10000". Diese Einstellung sollte möglichst nicht geändert werden.
LRUSweepFreq= | Wert, mit dem die Anweisung "LRUSweepFreq" multipliziert wird um die am längsten nicht genutzte obere Auslagerungsrate zu ermitteln. Mögliche Einstellungen sind 1-65335. Standard-Einstellung ist "250"
LRUSweepLen= | Länge des Bereichs, der bei jedem Sweep-Durchgang durchlaufen wird (in Seiten). Standard-Einstellung ist 1024. Diese Einstellung sollte möglichst nicht geändert werden.
LRUSweepLowWater= | Legt die Seitengröße fest, nach der der am längsten nicht benutzte Sweeper verwendet wird. Standard-Einstellung ist "24". Diese Einstellung sollte möglichst nicht geändert werden.
LRUSweepReset= | Zeit eines ACC-Bit-Resets in Millisekunden für 1024 Seiten (4 MB). Standard-Einstellung ist "500". Diese Einstellung sollte möglichst nicht geändert werden.
MapPhysAddress= | Speicherbereich, der für DOS -Treiber reserviert ist.
MaxBPs= | max. Anzahl der Unterbrechungspunkte, die der VMM benutzen darf. Standard-Einstellung ist "200".
MaxCOMPorts= | max. Anzahl unterstützter COM-Schnittstellen. Standard-Einstellung ist "4"
MaxPagingFileSize= | max.größe des virtuellen Speichers (Win386.swp) in k. Das setzen dieses Wertes ist nur in Ausnahmefällen sinnvoll. Im Normalfall sollte man Windows die Verwaltung der max. Größe überlassen. (kann über die Systemsteuerung geändert werden)
MaxPhysPage= | <Seitennummer in hex> max. physische Seitennummer, die der virtuelle VMM nutzen kann. Den Wert können Sie folgendermaßen berechnen: Den gewünschten Speicher in k durch 4 teilen und diesen Wert als HEX-Zahl hier eingeben.
MaxDMAPGAddress= | max. physische Speicheradresse, die für DMA genutzt werden kann. Standard-Einstellung ist 0FFFFFh für eISA und 0FFFh für andere Computer. (kann über die Systemsteuerung geändert werden)
MCADMA= | Besagt, ob Windows erweiterte DMA für MCA verwendet. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off". Diese Einstellung ist nur für MCA-Computer auf "On" zu setzen.
MessageBackColor= | Hintergrundfarbe der Meldungsbildschirme (für Windows nicht relevant)
MessageTextColor= | Textfarbe der Meldungsbildschirme (für Windows nicht relevant)
MinPagingFileSize= | Mindestgröße des virtuellen Speichers (Win386.swp) in KB. Wenn Sie diesen Wert hinreichend groß wählen, können Sie eine häufige Größenänderung dieser Datei und somit ein weiteres Fragmentieren des Laufwerks vermeiden. (kann über die Systemsteuerung geändert werden)
MinTimeSlice= | Minimale Prozessorzeit in Millisekunden , die einer virtuellen Maschine zugestanden wird. Standard-Einstellung ist "20"
MinUnlockMem= | Minimale Speichermenge in KB, die zur Reaktivierung einer virtuellen Maschine benötigt wird, wenn mehrere virtuelle Maschinen aktiv sind. Standard-Einstellung ist 40. Man sollte diese Einstellung möglichst nicht verändern.
MinUserDiskSpace= | Minimale Größe des Festplattenspeichers, der bei Benutzung von temporärer Auslagerungsdatei frei bleiben muss. Standard-Einstellung ist "2000" (kann über die Systemsteuerung geändert werden)
Mouse= | Maustreiber (kann über die Systemsteuerung geändert werden)
MouseSoftInt= | Besagt, ob Maus per Software- oder per Hardware initialisiert wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - Software-Initialisierung.
NetAsynchFallBack= | Besagt, ob Windows fehlgeschlagene asynchrone NetBIOS -Aufforderung im globalen oder im lokalen Puffer speichert. Mögliche Einstellungen sind on/off. Standard Einstellung ist "Off" - globaler Puffer. Ist diese Einstellung auf "On" verhindert Windows die Ausführung anderer virtueller Maschinen bis die Daten empfangen wurden und die in "NetAsynchTimeout" angegebene Zeit verstrichen ist. (für Windows nicht relevant)
NetAsynchTimeout= | Wartezeit für Bearbeitung asynchroner NetBIOS -Anforderungen in Sekunden. Diese Einstellung wird nur ausgewertet, wenn "NetAsynchFallback=On" gesetzt ist. (für Windows nicht relevant)
NetDMASize= | DMA-Puffer-Größe für NetBIOS -Transportsoftware (in KB). Standard-Einstellung ist "32" für MCA-Computer und "0" für andere. (für Windows nicht relevant)
NetHeapSize= | Größe des Puffers für Übertragung von Netzwerkdaten in KB. Der Wert wird auf das nächste Vielfache von 4kBaufgerundet. Standard-Einstellung ist "12".
Network= | Netzwerktreiber. HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\Vnetsetup
NMIReboot= | Besagt, ob das System neu gebootet wird, wenn ein nicht maskierbarer Interrupt auftritt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - wird nicht gebootet.
NoEMMDriver= | Besagt, ob EMM-Treiber geladen wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - der Treiber wird geladen.
NoWaitNetIO= | Besagt, ob synchrone NetBIOS -Befehle in asynchrone umgewandelt werden. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird umgewandelt.
OverlappedIO= | Besagt, ob virtuelle Maschinen Lese- und Schreibvorgänge ausführen können, bevor eine andere virtuelle Maschine den Speicherzugriff beendet hat. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - Mehrfachanforderungen sind zugelassen. Wenn "InDOS Polling=On" ist diese Anweisung auf "Off" zu setzen.
PageBuffers= | Anzahl der Seitenpuffer, die zum Speichern von Lese- und Schreibseiten benutzt werden. Mögliche Einstellungen sind "0-32" Standard-Einstellung ist "4".
PageOverCommit= | Multiplikator, mit dem die Größe des linearen Adressraums, den der VMM für das System anlegt, ermittelt wird (in MB). Der physische Speicher wird auf das nächste Vielfache von 4kBaufgerundet und dann mit "PageOverCommit" multipliziert. Standard-Einstellung ist "4".
Paging= | Besagt, ob ausgelagert wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - wird ausgelagert. (kann über die Systemsteuerung geändert werden)
PagingDrive= | Festplattenlaufwerk, auf dem ausgelagert wird. Ist hier keine Einstellung vorhanden, lagert Windows Daten auf dem Laufwerk aus, auf dem sich die SYSTEM.INI befindet. (kann über die Systemsteuerung geändert werden)
PagingFile= | Pfad und Dateiname für die temporäre Auslagerungsdatei. Standard-Einstellung ist "C:\WINDOWS\WIN386.SWP".
PerformBackfill= | Besagt, ob Windows volle 640kBkonventionellen Speicher zuweist, falls weniger vorhanden ist. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - 640kBwerden zugewiesen. Diese Einstellung sollte möglichst nicht geändert werden.
PermSwapDOS Drive= | Festplattenlaufwerk für die permanente Auslagerungsdatei.
PermSwapSizeK= | Größe der permanenten Auslagerungsdatei. Standard-Einstellung ist "0" - nicht vorhanden.
PerVMFILES= | Anzahl lokaler Dateizugriffsnummern, die für eine virtuelle Maschine reserviert sind. Dieser Wert darf samt der globalen Zugriffsnummer (FILES=x in CONFIG.SYS) nicht größer als 255 sein.
PSPIncrement= | Besagt, wie viele 4-Wort-PSP-Incremente an Zusatzspeicher Windows für jede nachfolgende virtuelle Maschine reserviert. Mögliche Einstellungen sind 2-64. Standard-Einstellung ist "2". Diese Einstellung ist nur relevant, wenn "UniqueDOS PSP=On" gesetzt ist.
ReflectDOS Int2A= | Besagt, ob Windows Int2A-Aufrufe an andere Anwendungen übergibt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - Int2A-Aufrufe werden übergeben.
ReservedHighArea= | Bereich im hohen Speicher, den Windows nicht nutzen darf. Dieser Bereich muss sich zwischen A000-EFFF befinden. Der erste Wert wird auf das Vielfache von 4kBabgerundet, der zweite abgerundet.
ReservePageFrame= | Besagt, ob der für Seitenrahmen reservierte EMS oder konventioneller Speicher als Übertragungs-Puffer verwendet werden soll. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "
ReserveVideoROM= | Signalisiert Windows, dass Video-ROM vorhanden ist (Seite C6 + C7)
ROMScanThreshold= | Besagt, nach wie vielen Speicherübergängen Windows den Speicher als ROM behandelt. Standard-Einstellung ist "20". Diese Einstellung muss verwenden werden, wenn der Header defekt, oder nicht vorhanden ist "On" - konventioneller Speicher wird benutzt.
ScrollFrequency= | Besagt, wie viele Zeilen gescrollt werden muss, bis eine Nicht-DOS -Anwendung die Anzeige aktualisiert. Standard-Einstellung ist "2" (kann über die Systemsteuerung geändert werden)
SGrabLPT= | <Anschlussnummer> Anschluss, zu dem alle Drucker-Interrupts weitergeleitet werden, wenn sie vom System und nicht von einer virtuellen Maschine verarbeitet werden sollen.
SyncTime= | Besagt, ob Windows regelmäßig die Zeit mit der CMOS-Uhr synchronisiert. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On". Diese Einstellung sollte nur dann auf "Off" gesetzt werden, wenn "TrapTimerPorts=On" gesetzt wurde und Anwendungen ausgeführt werden, die die Häufigkeit des Timer-Interrupts ändern.
SystemROMBreakPoint= | Besagt, ob Windows den ROM-Bereich zwischen F000:0000 und 1MB für den System-Unterbrechungspunkt benutzt. Diese Einstellung nimmt Windows normalerweise automatisch vor. ("On" bei DOS im RealMode und "Off" bei DOS im ProtectedMode beim Start von Windows)
SysVMEMSLimit= | Größe des von Windows benutzten EMS in KB. Standard-Einstellung ist "2048".Bei "0" darf Windows EMS nicht benutzen, bei "-1" darf der ganze verfügbare Expansionsspeicher von Windows genutzt werden.
SysVMEMSLocked= | Besagt, ob Nicht-Windows-Anwendungen von ihnen genutzten EMS auf Festplatte auslagern dürfen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist Off - wird nicht ausgelagert.
SysVMEMSRequired= | Besagt, wie viel EMS inkBfrei sein muss, um Windows zu starten. Standard-Einstellung ist "0"
SysVMV86Locked= | Besagt, ob von einer virtuellen Maschine in erweiterten Modus EMS auf die Festplatte ausgelagert werden darf. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - es wird ausgelagert.
SysVMXMSLimit= | max. Größe des XMS in KB, den DOS -Treiber und TSRs nutzen dürfen. Standard-Einstellung ist "2048". Bei "-1" dürfen DOS -Treiber den gesamten Erweiterungsspeicher belegen.
SysVMXMSLocked= | Besagt, on Nicht-Windows-Anwendungen von ihnen genutzten XMS auf Festplatte auslagern dürfen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist Off - wird nicht ausgelagert
SysVMXMSRequired= | Besagt, wie viel XMS inkBfrei sein muss, um Windows zu starten. Standard-Einstellung ist "0".
TimerCriticalSection= | Länge des Timeout vor und nach einem Timer-Interrupt in Millisekunden. Standard-Einstellung ist "0" - kein Timeout. Wird ein Timeout bestimmt, können Timer-Interrupts gleichzeitig nur von einer virtuellen Maschine benutzt werden (zu empfehlen nur bei globalen TSRs im Netzwerk).
TokenRingSearch= | Besagt, ob Windows bei ISA-Rechnern nach Token-Ring-Adaptern sucht. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - es wird gesucht.
TranslateScans= | Besagt, ob Windows den Scancode einer Tastatur übersetzt, um sie IBM-kompatibel zu machen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off". Diese Einstellung ist nur dann auf "On" zu setzen, wenn IBM-inkompatible Tastatur verwendet wird.
TrapTimerPorts= | Besagt, ob Anwendungen die Häufigkeit des Timer-Interrupts ändern dürfen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off".
Transport= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ (TransportEintrag)
UniqueDOS PSP= | Besagt, ob ein eindeutiger PSP für jede virtuelle Maschine benutzt wird. Mögliche Einstellungen sind on/off. Bei "on" reserviert Windows Speicher unterhalb einer Anwendung, die in einer virtuellen Maschine ausgeführt wird. So startet dann das erste Programm bei Adresse N, das zweite bei N+x, das dritte bei N+2x usw. Bei "off" benutzen alle Anwendungen einen PSP. Standard-Einstellung ist "On" für Microsoft-Netzwerke (MS benutzt PSP zu Identifikation von Anwendungen) und "Off" für alle übrigen.
UseableHighArea= | Gibt einen Bereich im Speicher an, den Windows nach freien Adressen durchsucht. Der Bereich muss sich zwischen A000-EFFF befinden. Der erste Wert muss auf Vielfache vonkBabgerundet, der zweite abgerundet werden. Es können mehrere Speicherbereiche angegeben werden, für jeden weiteren muss aber diese Zeichenfolge noch einmal eingefügt werden. "UseableHighArea" hat Vorrang vor "ReservedHighArea".
UseInstFile= | Legt fest, ob Windows die Datei INSTANCE.386 benutzt, um festzustellen, ob DOS -Datenstrukturen lokal sein müssen. Mögliche Einstellungen sind on/off. Diese Einstellung dient der Kompatibilität zu Windows 2.0. (Windows verwendet eine andere Methode - Int2Fh).
UseROMFont= | Besagt, ob Windows bei Nicht-Windows-Anwendungen im Vollbild-Modus ladbare Schriften des Video-ROM für Anzeige von Meldungen benutzt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On". Werden auf dem Bildschirm Punkte angezeigt, oder stimmt die Schrift der Anzeige mit der der Anwendung nicht überein, ist diese Einstellung auf "Off" zu setzen.
VGAMonoText= | Besagt, ob der Adressraum des Monochrom-Modus bei VGA-Adaptern (B700-B7FFh) ignoriert wird. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" - Windows nutzt diesen Speicher und ignoriert den Monochrom-Modus.
VCPIWarning= | unbekannt.
VideoBackground Msg= | Besagt, ob Windows eine Meldung ausgibt, wenn Anwendungen, die im Hintergrund laufen, vorübergehend aussetzen, oder ihre Bildschirmdaten nicht aktualisieren können. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On".
VideoSuspendDisable= | Besagt, ob Hintergrund Anwendungen angehalten werden, wenn der Bildschirm nicht mehr korrekt angezeigt werden kann. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - Anwendung wird angehalten und eine Meldung angezeigt, wenn VideoBackground Msg=On. Diese Einstellung gilt nur für VGA- Bildschirme.
VirtualHDIrq= | Besagt, ob Windows im 386-Modus Interrupts vom Festplatten- Controller beenden kann. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On" für AT-kompatible und "Off" für andere Computer
WindowKBRequired= | Konventioneller Speicher in KB, der frei sein muss, um Windows zu starten. Standard-Einstellung ist 256.
WindowMemSize= | Konventioneller Speicher in KB, den Windows nutzen darf. Standard-Einstellung ist "-1" - Windows darf allen verfügbaren Speicher nutzen. Der Wert darf nicht über 640kBliegen
WindowUpdateTime= | Zeitspanne, nach der bei Nicht-Windows-Anwendungen, die in einer DOS -Box laufen, das Fenster neu aufgebaut wird (in Millisekunden ). Standard-Einstellung ist 50.
WinExclusive= | Besagt, ob Windows-Anwendungen, die im Vordergrund laufen, die gesamte Prozessorzeit nutzen dürfen. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "Off" - Nicht-Windows-Anwendungen können im Hintergrund ausgeführt werden.
WinTimeSlice= | Bestimmt die relative Prozessorzeit, die Windows- (Vor- und Hintergrund ) und Nicht-Windows-Anwendungen (Hintergrund ) nutzen dürfen. Mögliche Einstellungen sind 2 Zahlen zwischen 1-10000. Standard-Einstellung ist "100-50",
WOAFont= | Schriftart für Nicht-Windows-Anwendungen. Standard-Einstellung ist "DOS APP.FON".
XLATBufferSize= | Größe des Puffers in KB, der von Nicht-Windows-Anwendungen im ProtectedMode für die Zuordnung zum virtuellen 386-Modus benutzt wird. Standard-Einstellung ist 8. Bei Netzwerken, die Pipes benutzen, ist dieser Wert auf ca 4 zu setzen.
XMSUMBInitCalls= | Besagt, ob Windows HIMEM.SYS-Routinen für Verwaltung der UMBs benutzt. Mögliche Einstellungen sind on/off. Standard-Einstellung ist "On". Diese Einstellung sollte möglichst nicht geändert werden.
[network] |
Comment= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsetup
Computername= | Computername HKEY_LOCAL_MACHINE System\ CurrentControlSet\ Control\ComputerName\ ComputerName
EnableSharing= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsetup
LMAnnounce= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsetup
LogonDomain= | HKEY_LOCAL_MACHINE\ Network\ Logon
LogonValidated= | HKEY_LOCAL_MACHINE\ Network\ Logon
MaintainServerList= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsetup
Reshare= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Network\ LanMan\ (Freigabename)
Username= | HKEY_LOCAL_MACHINE\ Network\ Logon
WorkGroup= | HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsetup

Info Weitere Infos finden Sie dazu auch im Tipp "INI-File Mapping"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0177.htm


Informationen über die Datei WIN.INI

Bei Win3.x (und Vorgängerversionen) sind Informationen über Windows-Umgebung und Konfiguration des PC in den Dateien WIN.INI und SYSTEM.INI (Initialisierungsdateien) enthalten. Windows selbst und die Anwendungen, die unter Windows ablaufen, nutzen diese Einstellungen, um sich zu konfigurieren.

Ab Windows 95 werden die Initialisierungsdateien weitgehend durch die Registrydatenbank ersetzt. Aus Kompatibilitätsgründen sind diese Dateien jedoch weiterhin vorhanden und werden von allen 16 Bit-Anwendungen genutzt. Die Einstellungen, die diese Programme dort vornehmen, werden nicht in die Registrydatenbank übernommen. Viele dieser Einstellungen können auch direkt unter Windows geändert werden, einige jedoch kann man ausschließlich über die INI-Dateien modifizieren.

Alle 32 Bit-Anwendungen sollten nur noch die Registrydatenbank nutzen, doch selbst Microsoft bleibt seinen Vorgaben nicht treu. So findet man z.B. in der SYSTEM.INI im Abschnitt [Passwort-Liste] Einträge, die nur Windows betreffen und von keinem 16 Bit-Programm benötigt werden.

Info Manche der beschriebenen INI-Einstellungen sind für Windows (und Windows NT) nicht relevant. Die hier aufgelisteten Parallelen zur Registrydatenbank sollen der Information dienen. Windows erwartet in der Registrydatenbank vielfach (formatmäßig) andere Werte als in den Initialisierungsdateien.

Wo keine Parallelen genannt werden, sind sie entweder dem Autor nicht bekannt, oder aber sind die beschriebenen Einträge ausschließlich über die INI-Dateien modifizierbar.
Viele der hier beschriebenen Einstellungen lassen sich auch mit Hilfe der Systemsteuerung ändern. Von unnötigen Manipulationen an der Registrydatenbank und den Initialisierungsdateien ist unbedingt abzuraten.

WIN.INI

Die Datei WIN.INI enthält Informationen über die Windows-Umgebung. In der Registrydatenbank finden Sie die meisten dieser Einstellungen unter HKEY_CURRENT_USER.

[windows] | KEY_CURRENT_USER\ControlPanel\desktop
Der Abschnitt mit den meisten Schlüsselnamen, beschreibt die Windows-Umgebung. Hier finden Sie Einstellungen für laufende Anwendungen, Warnmeldungen, Drucken, Fenster, Maus, Tastatur und Verknüpfungen.
Schlüsselnamen: |
Beep = | Akustisches Warnsignal. Mögliche Einstellungen sind yes/no.
BorderWidth = | Rahmenbreite aller Fenster mit fester Größe in Pixel. Mögliche Einstellungen sind zwischen 3 und 49. Standardeinstellung ist 3. HKEY_CURRENT_USER\ ControlPanel\ desktop\ WindowMetrics\ BorderWidth
CoolSwitch = | Schneller Taskwechsel. Mögliche Einstellungen sind 1/0. Standardeinstellung ist 1.
CursorBlinkRate = | Zeit zwischen Blinken des Cursors in Millisekunden. Hier können beliebige Zahlen eingegeben werden. Standardeinstellung ist 530. HKEY_CURRENT_USER\ ControlPanel\ desktop
Device = | Standarddrucker. Hier wird ein beliebiger Druckername (aus dem Abschnitt [devices]) eingegeben. Dem Standard-Drucker wird hier ein Treiber (Druckertreiber-Datei ohne Endung) und ein Port (beliebiger Eintrag aus dem Abschnitt [ports]) zugewiesen. (kann über die Systemsteuerung geändert werden)
DefaultQueueSize = | max. Anzahl von Nachrichten, die von einer Meldungsschleife verarbeitet werden kann. Standardeinstellung ist 8.
DeviceNotSelectdTimeout = | Wartezeit in Sekunden zwischen Ansteuern eines Geräts und Anzeigen einer Fehlermeldung, falls das Gerät nicht reagiert (Diese Einstellung ist nicht immer relevant. Manche Geräte geben eine Fehlermeldung sofort aus). Standardeinstellung ist 15.
Documents = | Legt Textdateien an, die mit keiner Anwendung verknüpft sind.
DOS Print = | Bestimmt, ob Drucker DOS -Interrupt verwenden sollen. Mögliche Einstellungen sind no/yes. Standardeinstellung ist "no".
DoubleClickHeight = | max. vertikale Bewegung des Mauszeigers während des Doppelklicks in Pixel. Standardeinstellung ist 4. HKEY_CURRENT_USER\ ControlPanel\ Mouse
DoubleClickSpeed = | Beim Doppelklick die max. Zeitdauer zwischen den einzelnen Mausklicks in Millisekunden. Standardeinstellung ist 452. (kann über die Systemsteuerung geändert werden)
DoubleClickWidth = | max. horizontale Bewegung des Mauszeigers während des Doppelklicks in Pixel. Standardeinstellung ist 4. (kann über die Systemsteuerung geändert werden)
KeyboardDelay = | Zeit bis zur Aktivierung der Tasten-Wiederholungsfunktion in Sekunden. Standardeinstellung ist 2. HKEY_CURRENT_USER\ ControlPanel\ keyboard
KeyboardSpeed = | max. Zeit zwischen Wiederholungen eines Zeichen bei gedrückter Taste in Millisekunden. Standardeinstellung ist 31.
Load = | Programme, die beim Start von Windows als Symbol gestartet werden sollen.
MenuDropAlignment = | Ausrichtung der Menüpunkte. Mögliche Einstellungen sind 0/1. (0 = links, 1 = rechts)
MenuShowDelay = | Wartezeit bis zur Ausgabe des Menüs in Millisekunden. Standard werte sind 0 für 386-er PC und Nachfolger, 400 für 286-er PC (AT)
MouseSpeed = | Beziehung zwischen Mouse und Cursorbewegung. Mögliche Einstellungen sind 0/1/2. Dieser Wert wird auf folgende Weise ausgewertet: Bei 0 wird Cursorbewegung nicht beschleunigt. Bei 1 wird die Cursorgeschwindigkeit verdoppelt, wenn der Wert in MouseThreshold1 überschritten wurde. Bei 2 wird bei überschrittenem Wert in MouseThreshold1 die Cursorgeschwindigkeit verdoppelt und bei überschrittenem Wert in MouseThreshold2 wird sie vervierfacht. (kann über die Systemsteuerung geändert werden)
MouseThreshold1 = | Anzahl der Pixel, über die die Maus zwischen Mausunterbrechungen bewegt werden kann, bevor MouseSpeed aktiviert wird. Ggf. doppelte Cursorgeschwindigkeit. Standardeinstellung ist 5.
MouseThreshold2 = | Anzahl der Pixel, über die die Maus zwischen Mausunterbrechungen bewegt werden kann, bevor MouseSpeed aktiviert wird. Ggf. vierfache Cursorgeschwindigkeit. Standardeinstellung ist 5.
MouseTrails = | Anzahl der angezeigten Mauszeiger, falls Mouse-Spur aktiviert wurde. Mögliche Einstellungen sind zwischen 1 und 7 (funktioniert nur mit EGA-, VGA- und SuperVGA-Bildschirmen). Kann über die Systemsteuerung geändert werden-
NetWarn = | Ausgabe einer Warnmeldung, wenn eine Netzwerk-Konfiguration vorliegt, aber das Netzwerk nicht läuft. In diesem Fall werden alle Netzwerk-Einstellungen zurückgesetzt. Mögliche Einstellungen sind 1/0. Standard-Einstellung ist 1 (Warnung ausgeben).
NullPort = | Name für einen NULL-Anschluss (installiertes Gerät ohne Anschluss). Standardeinstellung ist "None"
Programs = | Erweiterungen, die von Windows als lauffähige Programme interpretiert werden sollen. Standardeinstellung ist: "com exe bat pif "
Run = | Programme, die beim Windows-Start automatisch gestartet werden sollen. Hier können auch verknüpfte Dokumente eingetragen werden. HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run
ScreenSaveActive = | Schaltet Bildschirmschoner ein/aus. Mögliche Einstellungen sind 1/0.
ScreenSaveTimeout = | Zeit bis zur Aktivierung des Bildschirmschoners in Sekunden. Standardeinstellung ist 120.
Spooler = | Schaltet Druckmanager ein/aus. Mögliche Einstellungen sind yes/no. Standardeinstellung ist "yes"
SwapMouseButtons = | Vertauschen der Maustasten. Mögliche Einstellungen sind 0/1. Standardeinstellung ist 0 (Maustasten nicht vertauscht) (kann über die Systemsteuerung geändert werden)
TransmissionRetryTimeout = | max. Zeit in Sekunden zwischen Ansteuerung des Druckers und Ausgabe einer Warnmeldung, falls keine Verbindung zustande kommt. Standardeinstellung ist 90 für Postscript-Drucker, 45 für andere Druckertypen
[display] | HKEY_CURRENT_USER\ Control Panel\ Desktop\ WindowMetrics
Einstellungen zum Bildschirm und Icons.
Schlüsselnamen: |
GridGranularity = | Abstand der Einheiten für Gitterlinien für Fensterpositionierung in 8-Pixel-Einheiten. Mögliche Einstellungen sind zwischen 0 und 49. Standardeinstellung ist 0.
IconSpacing = | Horizontaler Abstand zwischen Icons in Pixel. Standardeinstellung ist 77.
IconTitleFaceName = | Voller Name der Schriftart für Icon-Texte. Standard-Einstellung ist "MS Sans Serif".
IconTitleSize = | Größe der Schriftart für Icon-Texte in Pixel. Standard-Einstellung ist 8.
IconTitleStyle = | Bestimmt, ob Icon-Texte normal oder fett angezeigt werden. Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (Normal).
IconTitleWrap = | Bestimmt Zeilenumbruch für lange Icon-Texte. Mögliche Einstellungen sind 1/0. Standard-Einstellung ist 1 (Zeilenumbruch).
IconTitleVerticalSpacing = | Vertikaler Abstand zwischen Icons in Pixel. Standardmäßig wird diese Einstellung von Windows an Bildschirm und Schriftart angepasst.
Pattern = | Farbmuster für Bildschirmhintergrund . Jede Dezimalzahl entspricht einem Byte.(1 Byte = 8 Pixel). Binärzahl 0 = Hintergrundfarbe, Binärzahl 1 = Vordergrundfarbe (beide Farben beziehen sich auf Text).
TileWallPaper = | Anzeige des Hintergrund -Bitmaps. Mögliche Einstellungen sind 0 (Kacheln) und 1 (zentrieren). Standard-Einstellung ist 0.
WallPaper = | Pfad der Bitmap für Bildschirmhintergrund . Standard-Einstellung ist "None"
WallPaperOriginX = | Horizontale Versetzung des Hintergrund -Bitmaps bei Einstellung "Kacheln" Standard-Einstellung ist 0.
WallPaperOriginY = | Vertikale Versetzung des Hintergrund -Bitmaps bei Einstellung "Kacheln" Standard-Einstellung ist 0.
[extensions] | HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Extensions
Hier werden Dateierweiterungen mit bestimmten Anwendungen verknüpft.
Schlüsselwerte: |
Endung = | Pfad zu dem Programm, das dieses Format lesen soll, gefolgt von ^. Ext.
[intl] | fast alles kann über Systemsteuerung geändert werden.
Ländereinstellungen. Sollten die Einstellungen fehlen, wird die Standard-Konfiguration benutzt (US-Englisch).
Schlüsselnamen: |
iCountry = | Länderzahl (entspricht der internationalen Telefonvorwahl) HKEY_CURRENT_USER\ ControlPanel\ International
iCurrDigits = | Anzahl der Nachkommastellen bei Währungsformaten. Standard-Einstellung ist 2.
iCurrency = | Währungsformat. Mögliche Einstellungen sind 0/1/2/3 (z.B. bei DM. 0=DM1, 1=1DM, 2=DM 1, 3=1 DM Standard-Einstellung ist 0.
iDate = | Datumsformat. Mögliche Einstellungen sind zwischen 0 und 2. (z.B. 0=15/10/96, 1=10/15/96, 2=96/10/15). Standard-Einstellung ist 0. (Achtung gilt nur für Windows 2.0)
iDigits = | Anzahl der Nachkommastellen bei Zahlen. Standard-Einstellung ist 2.
iLZero = | Bestimmt, ob Nullen vor dem Komma angezeigt werden, oder nicht. Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (Null wird nicht angezeigt)
iMeasure = | Maßsystem (metrisch, oder englisch). Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 1 (englisch)
iNegCurr = | Format für negative Zahlen. Mögliche Einstellungen sind zwischen 0 und 10. Standard-Einstellung ist 0. (z.B. bei DM: <0> Format: (DM1), <1> Format: -DM1,<2> Format: DM-1 , <3> Format: DM1-, <4> Format: 1DM, <5> Format: -1DM, <6> Format: 1-DM, <7> Format: 1DM-, <8> Format: -1 DM, <9> Format: -DM 1, <10> Format: DM 1-
iTime = | Uhrzeit-Darstellung (12 oder 24 Stunden). Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (12 Stunden).
iTLZero = | Bestimmt, ob Nullen vor dem Komma bei der Uhrzeit angezeigt werden. Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (Null wird nicht angezeigt)
s1159 = | Zeichenfolge hinter der Uhrzeit vor 12:00 Uhr. Standard-Einstellung ist AM.
s2359 = | Zeichenfolge hinter der Uhrzeit nach 12:00 Uhr. Standard-Einstellung ist PM
sCountry = | Ländername für die Standard- Einstellung. Standard-Einstellung ist "United States"
sCurrency = | Währungssymbol. Standard-Einstellung ist "$" (Dollar).
sDecieinmal = | Dezimal-Trennzeichen. Standard-Einstellung ist "." (Punkt)
sLanguage = | Bestimmt die Sprache, in der gearbeitet wird. Diese Einstellung ist vor allem für die Rechtschreibprüfung wichtig. Standard-Einstellung ist "enu" (US-Englisch).
sList = | Listen-Trennzeichen. Standard-Einstellung ist "," (Komma).
sLongDate = | Langes Datumsformat. Standard-Einstellung ist " dddd, MMMM dd, yyyy" (z.B. Starten und day, 30. Juni 1968).
sShortDate = | Kurzes Datumsformat. Standard-Einstellung ist "M/d/yy " (z.B. Juni/30/68).
sThousand = | Tausender-Trennzeichen. Standard-Einstellung ist "," (Komma).
sTime = | Trennzeichen bei der Uhrzeit. Standard-Einstellung ist ":" (Doppelpunkt).
[ports] | kann über Systemsteuerung geändert werden.
Hier werden alle verfügbaren Anschlüsse aufgelistet. Unter Win3.x werden nur 10 Anschlüsse ausgewertet. (Zahl der ausgewerteten Anschlüsse unter Windows dem Autor unbekannt)
Schlüsselnamen: |
<portname>= | <baud-rate>,<parität>,<wortlänge>,<stopbits>,<p>
[fonts] | HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Fonts kann über Systemsteuerung geändert werden
Hier werden alle verfügbaren Bildschirm-Schriften aufgelistet. (Diese Einstellung gilt nur für Win3.x, für Windows nicht mehr!)
Schlüsselnamen: |
<fontname>= | <fontdatei>
[FontSubstitute] |
Hier werden Ersatz-Schriftarten bestimmt.
Schlüsselnamen: |
<fontname1>= | <fontname2>
[TrueType] |
Optionen für TrueType-Schriftarten.
Schlüsselnamen: |
OutlineThreshold = | Schriftgröße, ab welcher TrueType-Fonts als Outline-Fonts verwendet werden in Quadrat-Pixel. Mögliche Einstellungen bis 300. Standard-Einstellung ist 256.
TTEnable = | Verfügbarkeit der TrueType-Fonts. Mögliche Einstellungen sind 1/0. Standard-Einstellung ist 1 (verfügbar).
TTIfCollisions = | Bestimmt, ob TrueType-Font verwendet wird, wenn andere gleichnamige Schriftart verfügbar ist. Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (der andere Font wird verwendet).
TTOnl = | Bestimmt, ob neben TrueType auch andere Schriftarten zur Auswahl stehen sollen. Mögliche Einstellungen sind 0/1. Standard-Einstellung ist 0 (alle Schriftarten werden aufgelistet).
[mci extensions] |
Einstellungen für Multimedia.
Schlüsselnamen: |
<extension>= | <mci-gerätetyp>
[network] |
drive = | Netzwerkserver
Restore = | Übernahme der Netzwerkverbindung aus der letzten Windows-Session. Mögliche Einstellungen sind 1/0. Standard-Einstellung ist 1 (Verbindungen werden übernommen).
port = | Pfad vom Netzwerkdrucker und ihm zugewiesener Anschluss.
[embedding] |
Informationen zu OLE. Wichtig nur für Windows 3.0-(Achtung nicht Win3.1) Anwendungen.
Schlüsselnamen: |
<Name des Objekts>= | <Objekt-Beschreibung>,<Name in der Liste des Reg-InfoEditors>,<programmname>, <format>.
[WindowsHelp] |
Einstellungen zur Größe, Position und Farben der Windows-Help-Fenster.
Schlüsselnamen: |
M_WindowPosition = | Position und Standardgröße des Hauptfensters. <X-Koordinaten der linken oberen Ecke>, <Y-Koordinaten der linken oberen Ecke>, <Fensterbreite in Pixel>, <Fensterhöhe in Pixel>, < 0 (minimiert) oder 1 >(eingestellte Größe).
H_WindowPosition = | Position und Standardgröße des History-Fensters. <X-Koordinaten der linken oberen Ecke>,<Y-Koordinaten der linken oberen Ecke>, <Fensterbreite in Pixel>, <Fensterhöhe in Pixel>, < 0 (minimiert) oder 1> (eingestellte Größe)
A_WindowPosition = | Position und Standardgröße des Kommentar-Fensters. <X-Koordinaten der linken oberen Ecke>,<Y-Koordinaten der linken oberen Ecke>, <Fensterbreite in Pixel>, <Fensterhöhe in Pixel>, < 0 (minimiert) oder 1 (eingestellte Größe).
C_WindowPosition = | Position und Standardgröße der Copy-Dialog-Box. <X-Koordinaten der linken oberen Ecke>,<Y-Koordinaten der linken oberen Ecke>, <Fensterbreite in Pixel>, <Fensterhöhe in Pixel>, < 0 (minimiert) oder 1> (eingestellte Größe).
JumpColor = | Farbe für Jumps. Anteil an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
PopupColor = | Farbe für PopUp. Anteil an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
MacroColor = | Farbe für Macros. Anteil an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
IfJumpColor = | Farbe für extern Jump. Anteil an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
IfPopupColor = | Farbe für extern PopUp. Anteil an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
[sound s] | HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps\ <Sound für>\.Current
Tonunterstützende System-Ereignisse und ihnen zugeordnete Sound -Dateien.
Schlüsselnamen: |
<System-Ereignis> = | <Name der Sound -Datei>, < Beschreibung des Ereignisses>.
[PrinterPorts] | HKEY_CURRENT_CONFIG\ System\ CurrentControlSet\ Control\ Print\ kann über Systemsteuerung geändert werden
Auflistung aller aktiven und inaktiven Drucker
Schlüsselnamen: |
<Drucker-Name>= | <Treiber-Datei>, <portname>, <DeviceNotSelectedTimeOut>, <TransmissionRetryTimeout>
[programs] | HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ AppPath
Zusätzliche Pfade, die durchsucht werden, wenn eine Verknüpfung geöffnet werden soll.
Schlüsselnamen: |
<gesuchte Programmdatei> = | Pfad zu EXE-Datei.
[colors] | HKEY_CURRENT_USER\ ControlPanel\ Colors kann über Systemsteuerung geändert werden
Einstellungen für Farben verschiedener Windows-Objekte. Mögliche Einstellungen sind Anteile an Farbwerten für ROT, GRÜN, BLAU, jeweils von 0 bis 255.
Schlüsselnamen: |
ActiveBorder = | Aktiver Fensterrahmen.
ActiveTitle = | Hintergrund der Überschrift des aktiven Fensters.
AppWorkspace = | Arbeitsbereich der Anwendungen.
Background = | Desktop.
ButtonFace = | Schaltflächen.
ButtonHilight = | oberer und linker Schaltflächenrand.
ButtonShadow = | unterer und rechter Schaltflächenrand.
ButtonText = | Schaltflächentext.
GrayText = | Disabled Text.
Hilight = | Hintergrund hervorgehobener Texte.
HilightText = | Hervorgehobener Text.
InactiveBorder = | Inaktiver Fensterrahmen.
InactiveTitle = | Hintergrund der Überschrift des inaktiven Fensters.
InactiveTitleText = | Überschrift des inaktiven Fensters.
Menu = | Menü-Hintergrund.
MenuText = | Menü-Text.
Scrollbar = | Bildlaufleiste.
TitleText = | Überschrift des aktiven Fensters.
Window = | Fenster-Arbeitsbereich.
WindowFrame = | Fensterrahmen.
WindowText = | Fenstertext.
[desktop] | HKEY_CURRENT_USER\ ControlPanel\ desktop

Info Weitere Infos finden Sie dazu auch im Tipp "INI-File Mapping"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0137.htm


Was macht die Datei WININIT.INI?

Hin und wieder kommt es vor, dass Installationsprogramme alte DLLs durch neue ersetzen müssen. Eine DLL, die in Benutzung ist, kann aber nicht ersetzt werden. Also wird die neue DLL auf die Festplatte kopiert und mit einem vorläufigen Namen versehen. Das Installationsprogramm trägt außerdem einen entsprechenden Kopierbefehl in die WININIT.INI ein. Diese wird beim Systemstart (bevor irgendwelche DLLs geladen werden) von dem Programm WININIT.EXE bearbeitet. Die WININIT.INI enthält im Abschnitt [rename] den Quell- und Zielpfad für jede neue DLL.

Wird Windows neu gestartet, sucht es automatisch nach einer WININIT.INI.

Findet es eine, arbeitet WININIT.EXE die INI ab und benennt sie in WININIT.BAK um.

Da WININIT.EXE im Protected Mode arbeitet, entsprechen die Dateinamen dem 8.3-Schema.

Aufbau einer WININIT.INI:

[rename]

ZielDateiName=QuellDateiName

also z.B.

[rename]

c:\windows\fonts\arial.ttf=c:\windows\fonts\arial.win

c:\windows\system\advapi32.dll=c:\windows\system\advapi32.tmp

Der Befehl

Nul=QuellDateiName

dient zum Löschen einer Datei.

Die WININIT.EXE befindet sich normalerweise im Windows-Verzeichnis.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0317.htm


Wozu dient die Datei OEMINFO.INI?

Eine weitere Möglichkeit, seine Präsens zu zeigen, wird von Windows in den Systemeinstellungen vorgesehen:

"Start" -> "Systemsteuerung" -> "System" wird auf der Registerkarte „Allgemein“ der Systemeigenschaften ein benutzerdefiniertes Logo eingetragen. Nach der Betätigung eines Schalters können zusätzlich beliebige Textinformationen eingesehen werden.

Zuständig sind die Dateien "OEMINFO.INI" bzw. "OEMLOGO.BMP" aus dem Systemverzeichnis. Bei Windows NT/2000/XP muss die Datei im SYSTEM32 bzw. bei Windows 95/98/ME im SYSTEM-Verzeichnis vorhanden sein.

Natürlich können Sie auch ein anderes Bild einbinden, dafür müssen Sie sich nur an folgende Regeln halten:

Die Datei OEMLOGO.BMP:

Erstellen Sie eine "Windows Bitmap (BMP) Uncompressed" Datei mit den folgenden Daten.

Windows 9x, ME, NT:

Format: | 169*61
Farben: | 16
Ort: | Systemverzeichnis

Ab Windows 2000:

Format: | 180*140
Farben: | 24 Bit RGB
DPI: | 72 oder 96 dpi
Ort: | Systemverzeichnis (%Systemroot%\SYSTEM32)

Die Datei OEMINFO.INI:

Aufbau der Datei

Sektion: [General]

In der Sektion “General” werden die Angaben für den Tabreiter „Allgemein“ der Systemeigenschaften verwaltet. Mögliche Parameter sind:

Parameter | Bedeutung | Verwendung in
Manufacturer* | Name des Unternehmens, dass diesen PC installiert / ausgeliefert hat, als Zeichenkette. Hinweis: Keine nachstehenden Leerzeichen zulässig. | 9x, ME, XP, NT4, 2000
Model | Die Modellbezeichnung als Zeichenkette | 9x, ME, XP, NT4, 2000
Supporturl | Eine gültige Internetadresse als Zeichenkette. Diese URL wird als nutzbarer Link im Fenster dargestellt. | XP, NT4, 2000
LocalFile | Gibt eine WEB-Datei an die Angezeigt werden soll | XP,2000

* Der Parameter ist ein Pflichtparameter

Sektion: [OEMSpecific]

In dieser Sektion können beliebige Einträge in einer beliebigen Länge vorgenommen werden. Diese Einträge werden nicht in Microsoft Windows angezeigt sondern können nur von Supporttechnikern ausgewertet werden, die die Bezeichnung „OEMINFO.INI“ in der Kommandozeile aufrufen.

Hinweis: Die INI – Syntax (Parameter = Wert) ist beizubehalten.

Sektion: [ICW]

Parameter dieser Sektion können von serverseitigen Anwendungen ausgelesen werden um den PC eindeutig zu identifizieren.

Hinweis: Die INI – Syntax (Parameter = Wert) ist beizubehalten. Die Angabe freier Parameter ist nicht möglich.

Parameter | Bedeutung | Verwendung in
Product | Zeichenkette die das Produkt identifiziert | WXP, NT, W2K

* Der Parameter ist ein Pflichtparameter

Sektion: [Support Information]

Hier die Supportinformation angegeben werden die auf einem zusätzlichen Formular angezeigt wird, dass auf der Registerkarte „Allgemein“ der Systemeigenschaften aufgerufen werden kann.

Angaben wie Supporttelefon, Erreichbarkeit (also freier Text ist möglich). Ebenso ein Link zu einer http-Adresse.

Hinweis:

• Die Sektion muss in der OEMINFO.INI eingetragen werden.

• Hierbei wird jede Linie als INI – Paramter „LINExx=“ begonnen wobei xx eine Zahl zwischen 1 und 99 darstellt.

• Es muss zwingend mit 1 begonnen werden. Die Angabe mindestens einer Linie ist notwendig.

• Die Linien werden in der Textbox nicht umgebrochen.

• Das Anzeigeformular verfügt über Scrolleisten vertikal und horizontal.

Beispiele

=== Hier schneiden ===

[General]
Manufacturer=Windows FAQ
Model=http://www.winfaq.de

[Support Information]
Line1=" "
Line2="Tipp aus der Windows 2000 FAQ"
Line3=" "
Line4="Info: wwww.winfaq.de"
=== Hier schneiden ===

Die Daten der Sektion [Support Information] werden angezeigt, wenn Sie "Software Service" anklicken.

"Software Service" wird nur angezeigt, wenn mindestens "Manufacturer" Daten enthält.

OEMINFO.INI für Windows XP:

=== Hier schneiden ===

[General]
Manufacturer = Windows FAQ 2000
Model = Tipps & Tricks
SupportURL = http://www.winfaq.de
LocalFile = C:\Winnt\Web\Datei.htm

[OEMSpecific]

OEM1=Ist ein Beispiel aus der WinFAQ

[ICW]

Product=UAS 1.0 WinFAQ (C)2003

[Support Information]
Line1=" "
Line2="Tipp aus der Windows 2000 FAQ"
Line3=" "
Line4="Info: www.winfaq.de"
Line5=" "
Line6="Zeile 6"
=== Hier schneiden ===

Ab Windows Vista

Ab Windows Vista gibt es nicht mehr die Datei OEMINFO.INI. Diese Informationen können jetzt beim Unattended Setup in der neuen Steuerdatei "UNATTENDED.XML mitgegeben werden. Die neue Steruerdatei wurde Überarbeitet und liegt jetzt im XML-Format vor.

Auszug aus der UNATTENDED.XML (für OEM-Informationen):

=== Hier schneiden ===

<OEMInformation>

<HelpCustomized>false</HelpCustomized>

<Manufacturer>[OEM Name]</Manufacturer>

<Model>[Model Name]</Model>

<Logo>[Pfad und Name zur .bmp Datei]</Logo>

<SupportHours>[Zeit]</SupportHours>

<SupportPhone>[Telefonnummer]</SupportPhone>

<SupportURL>[URL]</SupportURL>

</OEMInformation>
=== Hier schneiden ===

Diese Einstellungen werden ab Windows Vista in der Registry abgelegt und zwar unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ OEMInformation

Erstellen Sie hier die folgenden neuen Werte als Datentyp REG_SZ:

Name | Inhalt/Beschreibung
Manufacturer | Herstellername
Model | Model der Hardware
Logo | Bild: C:\Windows\system32\\oemlogo.bmp
SupportPhone | Telefonnummer
SupportURL | Webseite: http://www.winfaq.de
SupportHours | Zeiten

Info Die Datei muss je nach Betriebssystem in das richtige SYSTEM Verzeichnis gelegt werden. Auch müssen Sie die Anführungszeichen unter [Support Information] mit angeben.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=218176und
http://support.microsoft.com/?kbid=314472.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0340.htm


VCache in hohen Speicher laden

Öffnen Sie die Datei SYSTEM.INI und ändern Sie folgendes.

[386Enh]

LocalLoadHigh=1

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0339.htm


Windows HILFE-Dateien durchblättern

Wollen Sie eine Windows Hilfedatei einmal ganz durchblättern, können Sie das mit einen einfachen Eintrag in der WIN.INI bewerkstelligen.

  1. Laden Sie dazu die Datei WIN.INI aus dem WINDOWS-Verzeichnis mit einem Editor.
  2. Erstellen Sie am Ende der Datei eine neue Sektion [Windows Help] (Sollte diese Sektion schon vorhanden sein brauchen Sie natürlich keinen neuen Eintrag zu erzeugen).
  3. Legen Sie dort nun den Eintrag "SeqTopicKeys=1" an.

Nun können Sie in den Windows Hilfedateien mit STRG+Shift und der jeweiligen Pfeiltaste (rechts/links) durch die Informationen blättern.

Sie können den Eintrag auch in der Registry setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows Help

Erstellen Sie hier einen neuen Wert mit dem Namen "SeqTopicKeys" als Datentyp REG_SZ und Setzen Sie den Wert auf:

0 | Tasten sind nicht aktiv
1 | Tastenfunktion ist aktiv

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0341.htm


Cache-Einstellungen

Wer oft mit großen Grafiken arbeitet und weniger mit vielen Dateien, sollte den File-Cache begrenzen. Windows hat die Eigenschaft, dafür sehr große Werte zu nehmen. Dadurch kann es passieren, dass Windows auch bei 48 MByte RAM nur 10 MByte freien Speicher hat und anfängt, auszulagern.

Der Normale Anwender sollte beim Eintrag MaxFileCache je nach Arbeitsspeicher folgendes einstellen:

Arbeitsspeicher | MaxFileCache
<20 MB | kein Eintrag
20 bis 32 MB | 8192
32 bis 64 MB | 12288
> 64 MB | 16384

Info Diese Werte gelten für Windows 95. Bei Windows 98 sollte man dies aber nicht mehr machen oder zumindest wesentlich höhere Max-Werte Eintragen.

Info Den Eintrag MinFileCache sollten Sie lieber nicht setzen, da er meist keine Vorteile bringt.

In der SYSTEM.INI:

[vcache]

MinFileCache=x (in KB)

MaxFileCache=xxxx (in KB)

Info Wenn ein DOS -Programm im Hintergrund läuft, wird Windows der eingestellte Cache Speicher entzogen. Das kann dazu führen, dass die Meldung "Not enough Memory" erscheint, wenn der virtuelle Speicher begrenzt wurde. Stellen Sie deswegen keinen zu kleinen Wert ein.

Diese Einstellung hat eine höhere Priorität als die Einstellungen, die über die Systemsteuerung vorgenommen werden können.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0085.htm


Auslagerungsdatei (Swap-Datei), Disk-Cache und Speichermanagement

Die Dokumentation zur Auslagerungsdatei und zum Disk-Cache ist in Windows eher mäßig. Im Resource Kit findet man zwar eine Auflistung der Einstellungen für den System-Monitor, mit dem man die Speicherbelegung prüfen kann, aber keine genaue Beschreibung.

Wenn man den System-Monitor startet und sich den freien Speicher anzeigen lässt, stellt man fest (abhängig von Rechner-Konfiguration, Speicher, laufenden Hintergrund -Programmen), dass schon direkt nach dem Start von Windows die Größe des freien Speichers nahezu Null ist. Es stellen sich dann einige Fragen:

  1. Wo ist mein freier Speicher geblieben?
    Ich habe so viel RAM, warum "swapt" Windows überhaupt?
  2. Brauche ich bei (32, 64,...MB) noch eine Swap-Datei?
    Kann ich das Systemverhalten durch Änderung am Speichermanagement irgendwie verbessern?
  3. Permanente Auslagerungsdatei: Ja oder Nein?
    Wenn permanent, wie groß sollte meine Auslagerungsdatei sein?
    Wie groß sollte der Disk-Cache sein?

Als erstes muss man ein bisschen über das Speichermanagement von Windows wissen, um das "Verhalten" bezüglich des Speichers zu verstehen.

  1. Wenn ein 16-Bit Programm (DLL) gestartet wird, werden bestimmte Teile dieses Programms genau einmal ausgeführt, nämlich beim Start. Dieser Code bleibt nicht ständig im RAM, sondern wird später in der Auslagerungsdatei untergebracht. Auf diesen Code wird nie wieder zugegriffen.
  2. Wenn ein Programm Speicher reserviert (auf Englisch heißt das "committed", "reserved" hat eine andere Bedeutung!), wird dieser Speicher nicht unbedingt sofort mit Daten gefüllt. Daher wird er nicht im RAM angelegt (vielleicht greift das Programm ja nie darauf zu), sondern in der Auslagerungsdatei. Erst wenn der reservierte Speicher mit Daten gefüllt wird, wird RAM dafür freigemacht.
  3. Die meisten Programme nutzen nur ganz bestimmte Teile der im Speicher befindlichen Daten ständig. Die Speicherverwaltung von Windows sorgt dafür, dass diese Abschnitte im RAM gehalten werden. Daten, auf die nur sehr selten zugegriffen wird, werden ausgelagert.

Frage: Ist eine Auslagerungsdatei immer notwendig?

Antwort:

Ja, man sollte auf jeden Fall eine Auslagerungsdatei haben (solange Festplattenplatz billiger ist als RAM). Wer meint, dass auf seinem System keine Auslagerungsdatei sein sollte, hat das Speichermanagment von Windows nicht verstanden. Statt die Auslagerungsdatei auszuschalten, kann man auch RAM ausbauen und das Swappen (innerhalb bestimmter Grenzen) wieder zulassen, das aber hat ungünstige Auswirkungen auf die Performance.

Generell gilt:

Die optimale Einstellung für alle Rechner gibt es nicht. Wenn man vermutet, dass man die Leistung seines Rechners durch manuelles Tuning des Speichermanagements verbessern kann, sollte man das System erst einmal mit Hilfe des System-Monitors überwachen, der als Zubehör zu Windows mitgeliefert wird.

Frage: Wie groß muss meine Auslagerungsdatei sein (wenn permanent)?

Antwort:

Genau zur Beantwortung dieser Frage gibt des den System-Monitor. RAM+Swap müssen so groß sein wie der max. erreichte Wert von "Reservierter Speicher".

Frage: Brauche ich nicht 2*RAM oder so als Swap-Datei?

Antwort: Das mag eine gute Faustregel für Netzwerk Computer und /oder andere Betriebssysteme sein, für Windows-PCs gilt das nicht.

Frage: Wie kann ich die Größe des Disk-Caches einstellen?

In der SYSTEM.INI, Abschnitt [VCACHE], MinFileCache = Größe inkB(nicht empfohlen), MaxFileCache = Größe in KB

Frage: Sollte ich die Größe des Disk-Caches nach oben begrenzen?

Antwort:

Es ist nicht notwendig, aber wenn überhaupt, dann auf max. 4 MB. Disk-Caching, was die am meisten bringende Maßnahme für optimale Performance bringt. Man kann sich allerdings darüber streiten, ob ein Disk-Cache von 8 oder 12 MB noch sinnvoll ist. Die dynamische Verwaltung des Disk-Caches sorgt ja dafür, dass der Speicher durch den Cache nicht "verbraucht" wird. Eine generelle Empfehlung kann man nicht geben. Man müsste langfristig die Zahl der Cache-Hits messen. Es gibt aber einige Anhaltspunkte:

  1. Wenn man ständig mehrere MB freien RAM-Speicher hat (bei fester Cache-Obergrenze), sollte man den Cache wieder freigeben.
  2. Öffnet und schließt man oft Programme (auch wiederholt), sollte der Cache nicht begrenzt werden.
  3. Vermutlich hat MS zu dem Zeitpunkt, als die Kriterien des Speichermanagements festgelegt wurden, angenommen, dass 32 MB höchstens auf einem Netzwerkserver installiert wären. Daher der riesige Disk-Cache. Aber ob das wirklich schadet.

Frage: Sollte ich die Größe des Disk-Caches nach unten begrenzen?

Antwort: Nein. Da Windows den Cache sowieso erst dann ganz freigibt, wenn der Speicher bis zum allerletzten Bit gefüllt ist. Da macht es keinen Sinn, die Cache-Größe nach unten festzusetzen.

Wo soll die Auslagerungsdatei hin?

Wenn nur eine Festplatte vorhanden ist, sollte die Auslagerungsdatei auf der Windows-Partition liegen. Bei mehreren Festplatten kann es von Vorteil sein, die Datei auf eine andere Festplatte zu legen.

Die Auslagerungsdatei von Windows sollte nach Möglichkeit immer entweder an den Anfang oder an das Ende einer Partition gelegt werden. Das Verschieben der Auslagerungsdatei ist aber ohne Tools kaum zu bewerkstelligen. Einfach ist es z.B. mit den Norton Utilities (Defrag) möglich, bei denen man angeben kann, dass die Datei an den Anfang der Festplatte verschoben werden soll.

Auch ohne diese Tools können Sie die Auslagerungsdatei auf eine andere Festplatte verlagern. Tragen Sie dafür in der SYSTEM.INI unter [386Enh] folgendes ein:

PagingDrive=D:

Mit dem Eintrag

PagingFile=D:\Swap.ddd

Sie können auch noch einen anderen Namen festlegen (Standard: Win386.swp).

Was soll das bringen?

Meistens bringt das einen besseren Zugriff auf die Swap-Datei, weil der Schreib-/Lesekopf dann weniger bewegt werden muss. Legt man die Auslagerungsdatei an den Anfang der Festplatte, ist der Zugriff um ca 10% schneller im Vergleich zur Festplattenmitte. Legt man die Swap-Datei an das Ende der Festplatte, steigt die Geschwindigkeit noch einmal um ca 10%. Außerdem sollte man darauf achten, dass Windows die Auslagerungsdatei nicht zerstückelt, denn dann muss der Schreib-/Lesekopf noch mehr bewegt werden. Man sollte deshalb möglichst nach fast jeder Windows-Sitzung die Festplatten defragmentieren.

Ich habe dafür aber sowieso eine extra Partition...

In einer Pressemitteilung von Microsoft hieß es, dass man nach Möglichkeit eine Swap-Datei auf derselben Partition anlegen soll, auf der Windows installiert ist, um einen besseren und schnelleren Zugriff zu haben. Der Grund liegt darin, dass Windows bei einer Extra-Partition ein Laufwerk mehr verwalten muss.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0039.htm


Einstellungen des System-Monitors und was sie bedeuten

In diesem Tipp beschreiben wir die Einstellungen des System Monitors und welche Angaben Sie dort auslesen können.

Freier Speicher:

Weniger wichtige Angabe.

Das ist der RAM-Speicher, der nicht benutzt wird. Auf freien Speicher kann besonders schnell zugegriffen werden, wenn Programme neuen Speicher anfordern. Eine schlecht programmierte Anwendung, die häufig den von ihr benötigten Speicher in winzigen Stückchen anfordert, würde also von freien Speicher besonders profitieren.

Reservierter Speicher:

Eine der wichtigsten Angaben. So viel Speicher benötigt man insgesamt (RAM und Swap). Wenn der reservierte Speicher gleich groß ist wie RAM + (permanente) Auslagerungsdatei, sollte man schnell alle Daten sichern und einige Programme schließen. Sollte dies öfter geschehen, muss die Swap-Datei vergrößert werden (wenn permanent).

Größe der Auslagerungsdatei:

Ist nur interessant wenn Windows 95 die Auslagerungsdatei verwaltet. Dann gilt:

Reservierter Speicher = (RAM - freier Speicher)+Auslagerungsdatei. Allerdings ist diese Faustregel nicht ganz genau, da die Größe der Auslagerungsdatei nach dem Schließen von Programmen nicht immer sofort geändert wird. "Größe der Auslagerungsdatei" - "Belegt von Auslagerungsdatei" ist das, was an RAM verschwendet wird, wenn man swappen nicht zulässt.

Belegt von Auslagerungsdatei:

Speicher, der tatsächlich benutzt und bei Bedarf wieder in den Hauptspeicher des Rechners zurückgeschrieben werden kann. Man kann übrigens feststellen, dass auch, nachdem der Hauptspeicher wieder freigegeben wurde, sich hier immer noch Informationen befinden. Das liegt daran, dass die entsprechenden Pages nur noch entfernt und nicht mehr ausgelagert werden müssen. Das bedeutet, dass selbst wenn die Auslagerungsdatei zum großen Teil belegt ist, nicht notwendigerweise ständig darauf zugegriffen wird. Ist dieser Wert ständig sehr hoch, sollte man trotzdem über ein RAM-Upgrade nachdenken. Noch wichtiger ist allerdings die Anzahl der Seitenfehler.

Seitenfehler (Eine Seite = 4kBBelegung):

Eine Anwendung versucht auf Speicher zuzugreifen, den Sie im RAM vermutet. Dieser Speicher befindet sich aber auf HD. Der Speicherinhalt muss nun zunächst von der Festplatte ins RAM geladen werden. (Dies geschieht für die Anwendung vollkommen transparent). Im RAM muss aber zunächst evtl. Platz geschaffen werden.

Entfernte Seiten:

Speicherinhalt, der sich schon in der Swap Datei befindet, also nur entfernt werden muss, um Platz zu schaffen.

Seitenauslagerungen:

Speicherinhalt, der sich noch nicht in der Swap Datei befindet, also vor dem Entfernen aus dem RAM noch gesichert werden muss.

Seiteneinlagerungen:

Speicherinhalte, die von Anwendungen angefordert wurden und nun aus der Swap-Datei in den RAM geschrieben werden sollen.

Größe des Datenträger-Cachespeichers:

Erklärt sich von selbst.

Übrigens: Der Disk-Cache wird natürlich nicht ausgelagert (genau sowenig wie die Auslagerungsdatei gecacht wird).

Gesperrter Speicher:

Nicht auslagerungsfähiger Speicher, zum größten Teil der Disk-Cache.

Sonstiger Speicher:

= Reservierter Speicher - Auslagerungsfähiger Speicher

Es handelt sich beim sonstigen Speicher um 32-Bit Code, d.h. um alle 32-bittigen Programme und DLLs und um sonstige "Memory-mapped files". Die im "Sonstigen Speicher" befindlichen Pages werden nicht geswappt, sondern nur discarded, d.h. aus dem Speicher entfernt, da sie schon auf der Festplatte vorliegen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0087.htm


NT und Windows 95/98 - Eine Auslagerungsdatei

Einige haben NT und Windows 95/98 gleichzeitig auf einen Rechner installiert. Dabei ist es ärgerlich, dass beide Systeme eine andere Auslagerungsdatei benutzen und dadurch den doppelten Speicherplatz belegen. Um für beide Systeme nur eine Auslagerungsdatei benutzen zu können, gehen Sie so vor:

Unter NT

Legen Sie die Auslagerungsdatei auf einem Windows 95/98 Laufwerk ab ("Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Virtueller Arbeitsspeicher"). Die Anfangsgröße und max. Größe müssen identisch eingestellt werden.

Unter Windows 95/98

Legen Sie unter Windows 95/98 die Auslagerungsdatei an die selbe Stelle ("Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Virtueller Arbeitsspeicher"), auch hier muss die Anfangs- und max. Größe identisch eingestellt werden.

Außerdem müssen Sie in der "system.ini" folgendes Eintragen:

[386Enh]

PagingFile=C:\PAGEFILE.SYS

PagingDrive=C:

MinPagingFileSize=

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0412.htm


Nicht benötigte DLLs sofort aus dem Speicher entfernen

Windows hat die Angewohnheit, belegten Speicher durch DLL-Dateien nicht sofort wieder freizugeben, auch wenn die geladene DLL-Datei schon länger nicht mehr verwendet wird. Dadurch wird versucht, die Ladezeiten gering zu halten falls die DLL wieder gebraucht wird. Dieses Verhalten kann nachteilig sein, wenn Sie wenig Arbeitsspeicher haben und oft unterschiedliche Programme starten.

Ab Windows 2000 hat diese Änderung keine Auswirkung mehr auf das System. Hier hat Microsoft das Speichermanagement überarbeitet und diese Funktion fest mit eingebaut.

.

Damit nicht benötigte DLLs sofort aus dem Speicher entfernt werden, setzen Sie folgenden Registry Wert. Wir konnten aber dadurch keinen messbaren Geschwindigkeitsvorteil feststellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\

erstellen Sie einen neuen Schlüssel mit dem Namen "AlwaysUnloadDll". Setzen Sie den Eintrag "(Standard)" vom Datentyp REG_SZ auf 1.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?*

KBid=196480

Info Ab 2000 wird dieser Eintrag von Windows nicht mehr unterstützt: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/shell/programmersguide/shell_basics/shell_basics_programming/debugging.asp

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0537.htm


Probleme mit zuviel Arbeitsspeicher bei Windows

Windows 9x und Windows ME kommen mit mehr als 512 MB RAM nicht immer zurecht. Es kommt hierbei zu Fehlermeldungen wie "Für diese Anwendung ist nicht genügend Arbeitsspeicher verfügbar". Die Ursache ist, dass der Vcache unter Umständen den kompletten Speicher verwendet.

Bei mehr als 512 MB Speicher sollte man den Cache durch den Eintrag

MaxFileCache=524288

in der System.ini unter [VCache]auf 512 MB beschränken. Das bewirkt, dass max. 512 MB zum Cachen von Dateien verwendet werden.

Bei mehr als 128 MB wird empfohlen, max. ca. 70% des Speichers zum Cachen zu verwenden, jedoch nicht mehr als 512 MB.

RAM | MaxFileCache
bis 128 MB | keine Begrenzung nötig
bis 256 MB | 174080
bis 384 MB | 261120
bis 512 MB | 348160
> 512 MB | 524288

Berechnung von MaxFileCache:

RAM (in MB) * 1024 * 0.7

Bei Rechnern mit mehr als 1 GByte Seicher

Sollte es immer noch zu Fehlern kommen (kein Booten mehr möglich - auch wegen zu wenig Speicher), muss folgendes in der System.ini von Windows 9x/ME unter [386Enh] eingetragen werden:

MaxPhysPage=20000

Dieser Eintrag schränkt das RAM auf 512 MB (512 * 1048576 / 4096 = 536870912) ein. Der restliche Speicher bleibt dann komplett ungenutzt. Alternativ können Sie natürlich auch Speicher entfernen (einige Programme laufen sogar erst, wenn Sie den Speicher auf MaxPhysPage=17500 begrenzen).

Info Bringt oft nach einigen Programmaufrufen Bluescreens. Ab physikalisch vorhandenen 1,5 GB RAM funktioniert der Eintrag sehr unstabil, kein Start mehr von Dos Anwendungen (16 Bit Programmen) .

Berechnung von MaxPhysPage:

1 MB = 1048576 Byte

Seitengröße = 4096 Byte

Gewünschte Größe in MB (Dezimal) * 256 = MaxPhysPage-Eintrag

Das Dezimale Ergebnis muss dann noch in einen hexadezimalen Wert umgerechnet werden. Dazu können Sie einfach den Windows-Taschenrechner (Anzeige: Wissenschaftlich) verwenden.

Trick für Windows 98 SE um 4 GByte Speicher zu nutzen (vmm98sed.zip)

Für Windows 98SE gibt es einen Trick, die deutsche Version auch mit bis zu 4 GB Hauptspeicher zu nutzen. Dazu müssen nur zwei Dateien, die vmm32 vxd und die vmm.vxd aus der vmm98sed.zip eingespielt werden.

  1. Vmm98sed.zip downloaden
  2. Die Dateien so wie sie in der ZIP im Verzeichnis eingepackt auf Laufwerk C extrahieren (eventuell den Namen des Windows-Verzeichnisses anpassen)
  3. In der system.ini unter [386Enh] den Eintrag "MaxPhysPage=xxxxx", falls vorhanden, entfernen
  4. Rechner neu starten.

In dieser vmm32.vxd Datei, fehlt die Datei "enable.vxd" für die Eingabehilfe. Hat man in seiner Windows Installation im Setup dies mit installiert, erscheint nach dem überschreiben des alten vmm32.vxd die Fehlermeldung, dass die Datei "enable.vxd" nicht gefunden werden kann. Damit der Fehler nicht mehr kommt, müssen Sie die Eingabehilfe wieder deinstallieren.

Info Sie müssen Windows neu starten, damit die Einstellung benutzt werden.

Info Weitere Informationen zu diesem Thema finden Sie unter "Cache- Einstellungen" in der FAQ und unter folgenden Links in der Microsoft Knowledge Base:
http://support.microsoft.com/?kbid=184447
http://support.microsoft.com/?kbid=108079
http://support.microsoft.com/?kbid=181862
http://support.microsoft.com/?kbid=253912

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1164.htm


Kein Zugriff auf COM-Port über Terminal-Programm möglich

Wenn sich die Datei UNIMODEM.XXX nicht im Windows-Verzeichnis befindet, wird sämtliche Terminalsoftware nicht mehr aktiviert.

Das bezieht sich natürlich nur auf Programme, die keinen eigenen Treiber mitbringen (z.B. Hypertem oder MS Money 4.0) und direkt auf den internen Modemtreiber aufsetzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0153.htm


Geschwindigkeit der seriellen Schnittstelle

Unter Windows gibt es nur eine Möglichkeit, den Bausteintyp der seriellen Schnittstelle zu bestimmen.

Schließen Sie dazu ein Modem an die serielle Schnittstelle und konfigurieren Sie es. Jetzt können Sie unter -> "Systemsteuerung" -> "Modems" -> "Diagnose" die serielle Schnittstelle auswählen und haben die Möglichkeit unter -> "Details" die Informationen über das Modem und den Schnittstellenbaustein zu erhalten.

Sollten Sie keinen UART 16550 besitzen, müssen Sie unter "Systemsteuerung" -> "System" -> "Geräte-Manager" -> "COM-Anschluss" -> "Eigenschaften" -> "Anschlusseinstellungen" -> "Erweitert" die Benutzung des FIFOs ausschalten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0081.htm


COM-Port Einstellungen

COM- Port Einstellungen (UART)

Diese Option COMxFIFO wird verwendet, um die Unterstützung eines COM-Anschlusses mit 16550 Universal Asynchronous Receiver Transmitter (UART) zur aktivieren bzw. auszuschalten. Der 16550 Baustein hat einen 16 Byte FIFO-Puffer für das zwischenspeichern von Daten.

Hiermit aktivieren Sie den FIFO-Baustein und stellen die Puffergröße ein.

[386Enh] | [Einstellung]
COMxFIFO=1 | 1: FIFO aktivieren 0: FIFO ausschalten
COMxBuffer=1024 | Buffergröße einstellen Werte ja nach Schnittstelle: 1024 2048
COMBoostTime=2 | Gibt die Zeit in Millisekunden an, wie oft ein COM-Interrupt (Abfrage) stattfinden soll. Bei Problemen, diesen Wert einfach einmal auf 8 erhöhen.

Info Dabei handelt es sich bei x um die Nummer des Port, wofür die Einstellung gelten soll.

Bei COM1 müssen hier also COM1FIFO=1 und COM1Buffer=1024 eingetragen werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0079.htm


COM-Port Freigabe

In diesem Tipp werden Probleme mit der COM-Port Freigabe (Seriellen Schnittstelle) beschrieben.

Problem:

DOS -Anwendung wird gestartet,

DOS -Anwendung belegt COM-Port,

Windows-Anwendung wird gestartet

Windows-Anwendung will COM-Port belegen

Die Lösung:

Eintrag in SYSTEM.INI:

[386enh]

COMxAutoAssign = -1

Der Eintrag definiert die Zeit für die Erkennung einer Verbindung für den seriellen Anschluss COMx. Diese Einstellung benutzt Windows beim Zugriff mehrerer Anwendungen auf das gleiche Gerät.

Bei der Einstellung <-1> wird der Benutzer gefragt, welche Anwendung den Zugriff erhalten soll.

Bei der Einstellung <0> können alle Anwendungen konkurrierend zugreifen. Bei der Einstellung 1...1000 wird festgelegt, wie lange (in Sekunden ) eine Anwendung das Gerät benutzen darf, bis eine andere Anwendung das Gerät benutzen kann.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0080.htm


Dateien oder Verzeichnisse mit 'reservierten' Namen löschen

Dateien oder Verzeichnisse mit reservierten Namen auf der Festplatte können Sie nicht ohne weiteres löschen. Auch Verzeichnisse, welche am Ende ein zusätzliches Leerzeichen enthalten, können nicht über den Explorer gelöscht werden

Um z.B. die Datei/Ordner "LPT1" zu löschen, müssen Sie folgendes eingeben:

DEL \\.\[Laufwerk]:\[Verzeichnis]\[Dateiname]

also

DEL \\.\C:\LPT1

Auf diese Weise können Sie auch andere Dateien und Verzeichnisse\Ordner löschen.

Wenn Sie z.B. einen Ordner haben, dessen Name am Ende mit einem Leerzeichen aufhört, können Sie den folgendermaßen löschen:

rd "\\.\[Laufwerk]:\[Verzeichnis] "

also:

rd "\\.\C:\Test\Test "

Info Info: Es hat sich gezeigt, dass bei einigen statt eines . (Punkt) auch ein ? (Fragezeichen) zum gewünschten Erfolg führt. Also: RD "\\?\[Laufwerk:]\[Verzeichnis]"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0255.htm


Rätselhafte TMP-Dateien im Windows-Verzeichnis

Wenn sich im Windows-Verzeichnis Dateien wie fffe9ef5_{07E4AA5A-7497-413C-BB2B-3FAA88A3AB03}.tmp finden, stammen diese mit Sicherheit vom Microsoft Debug Manager (MDM), der z.B. mit Office installiert wird. Der Debugger, der meist nur von Programmierern benötigt wird, kann auf folgende Weise deaktiviert werden:

  1. Strg+Alt+Entf drücken und den MDM beenden
  2. MDM.EXE umbenennen (z.B. MDM.E#E)
  3. Im Internet Explorer unter Extras - Internet Optionen - Erweitert - Browsing einen Haken bei "Scriptdebugging deaktivieren" setzen
  4. "Start" -> "Ausführen" -> "msconfig" eintippen -> die Registerkarte "Autostart" auswählen -> Haken bei "Machine Debug Manager" entfernen (deaktivieren) und den Rechner neu starten

Info Die fff-Dateien können Sie gefahrlos löschen.

Da msconfig.exe bei Windows 95 nicht enthalten ist, muss man sich hier mit einem kleinen Programm behelfen, z.B. gibt es zwei Freeware-Programme namens "Startup Manager". Die Links finden Sie unter "Tools".

Den Start des MDM können Sie auch in der Registry abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServices

löschen Sie den Eintrag "MDM.EXE".

Info Eine weitere Ursache können die Komponenten "Ezphoto" und "Pd3" der Adobe PhotoDeluxe Home Edition bzw. Adobe Reader 6.0 sein.

Info Sobald man das Office-Setup neu ausführt (z.B. Nachinstallation von Komponenten), wird der MDM automatisch wieder aktiviert.

Info Siehe auch folgenden Artikel in der Microsoft Knowledge Base: http://support.microsoft.com/?kbid=221438.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1138.htm


Verknüpfungen automatisch ändern

Wenn Sie auf mehreren Rechnern die gleiche Windowsinstallation einrichten oder bei Änderungen der Netzwerk-Software die Verküpfungen ändern müssen, ist das DOS-Utility SHORTCUT.EXE sehr hilfreich.

Mit SHORTCUT.EXE können Sie Namen ("-N") und Pfad der Verknüpfung, Zielprogramm bzw. Zielverzeichnis ("-T"), Icon-Datei ("-I"), Indexzahl des Icons ("-X") und Programm-Parameter ("-A") festlegen.

Beispiel:

Folgende BAT-Datei (benötigt 4DOS ) erstellt Links zu allen EXE-Dateien auf Laufwerk C:\

C:\

md link

global/i for %n in (*.exe)

(shortcut -n c:\link\%@name[%n] -t %n -i %n -x 0)

Mit SHORTCUT.EXE können Sie auch alle Links im aktuellen Verzeichnis anzeigen lassen ("-U ALL")

Info SHORTCUT.EXE finden Sie auf der Windows CD im Verzeichnis ADMIN\APPTOOLS\ENVVARS

Info Wenn Sie vor den Shortcut Befehl "ctty NUL:" einbauen, läuft die Verarbeitung ca. 10 einmal schneller ab.

ctty NUL:
shortcut.exe -n.....
ctty CON:

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0338.htm


Kurze Dateinamen ohne Tilden

Wenn man eine Datei mit einem langen Dateinamen mit einem Programm öffnen will, das nur kurze Dateinamen unterstützt, bekommt man eine merkwürdige Endung zu sehen. So wird aus dem langen Dateinamen "Programme" der kurze Dateiname "Progra~1"und nicht "Programm". Um zu verhindern, dass Windows nur sechs Zeichen, eine Tilde und eine Zahl anzeigt, tun Sie folgendes (nicht empfohlen!):

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_ LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

mit der rechten Maustaste auf das rechte Fenster klicken und Binärwert wählen. Als Namen "NameNumericTail" eingeben und den Wert auf 0 setzen.

Falls Sie später Windows neu installieren wollen, sollten Sie diesen Eintrag löschen, ansonsten könnte Windows-Setup alle Verzeichnisse (diesmal mit Tilde) noch einmal erstellen (oder die Installation bricht mit einer Fehlermeldung ab).

Es führt zu Fehlern bis zum Datenverlust, wenn mehrere Verzeichnisse oder Dateien existieren, die mit den gleichen 8 Zeichen im LFN (Langer Dateiname) beginnen und diese dann kopiert oder gar verschoben werden.

Wird zuerst die Datei "Testname zur Kopie" kopiert und deren kurzer Name war "Testna~1" wird dieser am Ziel zu "Testname" kommt nun eine zweite Datei, die nur "Testname" heißt, kommt es zur Kollision der Namen. Genauso natürlich, wenn ein LFN schon vorhanden ist und eine neue Datei mit nur 8 aber den gleichen 8 Zeichen erstellt wird. Die möglichen Probleme überwiegen den Vorteil extrem.

Info Wenn diese Einstellung aktiviert ist, kann es auch sein, dass Windows nicht mehr installiert werden kann (siehe: Installation von Windows wird mit Dateinamenfehler abgebrochen).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0181.htm


Informationen über lange Dateinamen

Um allen weiteren Spekulationen auf dem Gebiet Dateisystem vorzubeugen, hier ein paar Fakten zum neuen Windows-Dateisystem mit langen Dateinamen:

Das Windows-Dateisystem selbst unterscheidet sich vom Aufbau her nicht vom alten DOS, außer es wird das neue FAT32 installiert (ab der OEM-Version B möglich). Hiermit können nun auch größere Partitionen angelegt werden; dafür ist das Dateisystem aber nicht mehr vom alten DOS lesbar.

  1. DOS-Bootblocks und der Code im 'Master Boot Record' sind geändert, werden aber bei der Installation von Windows automatisch modifiziert, so dass vom Anwender keine Änderungen vorgenommen werden müssen.
  2. Die langen Dateinamen werden durch 'Versteckt', 'System' und 'Volume Label' gekennzeichnete Einträge in den einzelnen Verzeichnissen dargestellt. Diese Einträge enthalten die Informationen, welche Windows dem alten Dateisystem gegenüber zusätzlich besitzt. Unter den alten DOS-Versionen werden Sie nicht angezeigt.
  3. Zu jedem langen, unter dem alten DOS unsichtbaren Dateinamen gibt es auch einen abgekürzten Dateinamen, der normalerweise mit Tilde (~) und Ziffer endet, wobei die Ziffer der Unterscheidung dient, falls ansonsten mehrere lange Dateinamen die gleiche Abkürzung hätten.
  4. DOS- und alte 16-Bit-Windows-Programme können nur mit den abgekürzten Formen langer Dateinamen arbeiten. Da diese Programme lange Dateinamen nicht erkennen, gehen beim Abspeichern die zusätzlichen Informationen verloren. Die Datei hat anschließend die abgekürzte Form als vollen Dateinamen.
  5. Windows versucht zwar, die im vorigen Punkt genannten Aktionen zu erkennen und den langen Dateinamen dennoch beizubehalten, aber dies gelingt nur in gewissen Fällen - und nur, wenn Windows 95 auch läuft! Wenn man unter dem alten DOS arbeitet, dann wird der alte Dateiname gnadenlos durch den kurzen ersetzt.
  6. Falls das Dateisystem beschädigt ist, sollte man den Rechner von einer 'sauberen' Windows Bootdiskette booten und anschließend die Festplatte nach Viren scannen. Wenn kein Virenbefall vorliegt, sollte man versuchen, das Dateisystem mit Scandisk zu reparieren.
  7. Falls sich das Dateisystem mit Scandisk nicht reparieren lässt, könnte Norton Disk Doktor oder ein ähnliches Windows-Reparaturprogramm von Nutzen sein. Aber Achtung, nicht alle diese Programme funktionieren mit DriveSpace.
  8. Sollte auch das nicht geholfen haben, booten Sie das alte DOS und versuchen Sie ein altes DOS-Reparaturprogramm. Doch seien Sie gewarnt: Von den langen Dateinamen werden vermutlich nur die abgekürzten Formen übrig bleiben! Dennoch retten Sie so unter Umständen zumindest noch Ihre Daten!
  9. Sollte auch das nichts nutzen, können Sie nur noch von allen noch lesbaren Dateien ein Backup machen und dann die Festplatte formatieren. Aber dies sollte immer der letzte Schritt sein!
  10. Wenn Sie irrtümlich eine alte DOS-Version über das Windows System installiert haben sollten, booten Sie von einer Windows Bootdiskette, geben Sie erst 'FDISK /STATUS' ein und wenn keine Fehler auftreten, geben Sie 'FDISK /MBR' und dann 'SYS C:' ein. Das sollte Ihre Festplatte wieder in ein Windows System 'zurückverwandeln'.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0165.htm


Datei Informationen (Schnellansicht)

Klickt man mit der rechten Maustaste auf eine Windows-EXE oder DLL-Datei und wählt dann ->"Schnellansicht" (nur möglich, wenn sie mit installiert wurde), erhält man darüber sehr umfangreiche Informationen (z.B. DLLs, die von dem Programm aufgerufen werden, Speicherplatzbedarf usw.).

Diese Funktion wird aber nur für einige Dateiendungen angeboten die von Quickview auch unterstützt werden. Viele Dateien tragen aber andere Endungen, könnten aber mit Quickview angezeigt werden. Wenn Sie möchten, dass Quickview bei allen Dateien zu Verfügung steht, gehen Sie folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\*

Erstellen Sie einen neuen Unterschlüssel mit dem Namen "QuickView". Tragen Sie unter diesem neuen Unterschlüssel auf der rechten Seite unter "(Standard)" nun einfach ein * (Stern) ein.

Jetzt steht Ihnen bei allen Dateiendungen Quickview zu Verfügung. Wird der Dateityp aber nicht von Quickview unterstützt, erscheint beim Aufruf solcher Dateien mit Quickview eine Fehlermeldung.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0065.htm


Lange Dateinamen unter DOS sichern/wiederherstellen

Mit dem Programm LFNBK.EXE, das sich auf der Windows CD-ROM im Verzeichnis \ADMIN\APPTOOL\LFNBACK befindet, kann man unter DOS die langen Dateinamen sichern und danach auch wiederherstellen. Das Programm ist vor allem dann nützlich, wenn man:

16-Bit BackUp-Programme verwendet.

LFNBK /B (für Backup) /x (Laufwerk)

LFNBK /R (für Restore)

Schalter | Eigenschaften
/v | zeigt die Aktionen auf den Bildschirm an
/b | sichert und löscht lange Dateinamen auf dem Datenträger
/r | stellt die gesicherten langen Dateinamen wieder her
/pe | zeigt Fehler in der Sicherungsdatenbank
/nt | Datum und Zeit werden beim Sichern nicht wieder hergestellt
/force | das Programm wird auch unter unsicheren Bedingungen ausgeführt
/p | sucht nur nach langen Dateinamen, diese werden aber nicht in 8.3-Dateinamen umgewandelt.

Es gibt aber auch noch eine bessere Lösung:

DOS LFNBK bis v1.6 Freeware (nur FAT16) aktuell v2.2 Shareware (auch FAT32). Dieses Programm kann unter purem DOS die LFNs (Langer Dateiname) sichern und wiederherstellen. Es ist auch möglich, gezielt nur bestimmte Verzeichnisse zu sichern oder zu überspringen. Hierbei werden die LFNs aber nicht gelöscht, wie das bei dem MS-Tool der Fall ist!

Die URL:

http://www8.pair.com/dmurdoch/programs/doslfnbk.htm

Damit kann man auch das gesamte Windows System z.B. auf eine CDR sichern.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0062.htm


Was ist in welcher CAB-Datei?

Wer kennt das nicht: man hat eine defekte Datei und will nur diese neu installieren, aber in welcher CAB-Datei befindet sich diese Datei? Oder Sie möchten Anwendungen suchen, die Microsoft in den CAB-Dateien versteckt hat und die nicht automatisch installiert werden.

Mit einer einfachen kurzen Batch-Datei können Sie sich schnell eine Liste aller Dateien in den CAB-Dateien erstellen lassen.

Erstellen Sie dafür folgende Batch Datei:

Dateiname: CABVIEW.BAT

Inhalt: for %%x in (%1\*.cab) do extract /d %%x %2 >> Inhalt.txt

Aufruf: CABVIEW [Dateiort] [Suchen]

Dateiort: | Wo liegen die CAB-Dateien
Suchen: | Was soll aufgenommen werden (Standard *.*)

Beispiel Aufruf: CABVIEW F:\WIN98 *.EXE

Erstellt eine Datei namens "Inhalt.txt" im aktuellen Verzeichnis. Diese enthält eine Liste aller EXE - Dateien.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0355.htm


Ansicht der Dateiattribute in Windows 95/98

Die Checkbox "Dateiattribute in der Detailansicht anzeigen" zum Aktivieren ist unter "Ansicht" -> "Ordneroptionen" -> "Ansicht" nicht mehr vorhanden.

Durch einen Eingriff in die Registry lässt sich die Anzeige der Attribute wieder aktivieren (wenn "Active Desktop" installiert ist).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

den Eintrag "ShowAttribCol" als Datentyp REG_DWORD von 0 auf 1 setzen.

Danach müssen Sie noch unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced\ Folder

einen neuen Schlüssel "ShowAttribCol" erstellen. Unter diesem neuen Schlüssel legen Sie nun noch folgende Werte neu an:

Name | Datentyp | Inhalt
Type | Zeichenfolge | "* Checkbox "
Text | Zeichenfolge | "Dateiattribute in der Detailansicht anzeigen"
HKeyRoot | REG_DWORD | 80000001
RegPath | Zeichenfolge | "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced"
ValueName | Zeichenfolge | "ShowAttribCol"
CheckedValue | REG_DWORD | 1
UncheckedValue | REG_DWORD | 0
DefaultValue | REG_DWORD | 0
HelpID | Zeichenfolge | "update.hlp#51071"

Sie können aber auch folgende .REG Datei verwenden:

=== Hier schneiden ===
REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\ShowAttribCol]
"Type"="* Checkbox "
"Text"="Dateiattribute in der Detailansicht anzeigen"
"HKeyRoot"=dword:80000001
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"ValueName"="ShowAttribCol"
"CheckedValue"=dword:00000001
"UncheckedValue"=dword:00000000
"DefaultValue"=dword:00000000
"HelpID"="update.hlp#51071"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowAttribCol"=dword:00000001

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0567.htm


Dateien austauschen, die in Benutzung sind

Dateien, die unter Windows gerade im Speicher geladen sind, werden gegen jede Veränderung geschützt (Löschen, Umbenennen usw.). Damit aber auch Service Packs usw. diese Systemdateien austauschen können, gibt es natürlich auch dafür einen vorgeschriebenen Weg.

Unter Windows 95/98/ME:

Windows sucht während des Startvorgangs, aber noch bevor die graphische Oberfläche geladen wird, im Windows-Verzeichnis nach einer Datei mit dem Namen "WININIT.INI". Ist die Datei vorhanden, wird diese noch im DOS -Modus durch das Programm WININIT.EXE abgearbeitet (zu diesem Zeitpunkt ist es noch erlaubt bzw. möglich, Systemdateien auszutauschen). Dieses Programm erwartet in der INI-Datei unter dem Abschnitt [RENAME] die jeweiligen Anweisungen.

Durch die Anweisung:

[RENAME]

c:\windows\system\test.dll=c:\test\ersatz.dll

wird die Datei TEST.DLL mit der Datei ERSATZ.DLL überschrieben. Danach wird die Datei ERSATZ.DLL aus dem Verzeichnis gelöscht. Nach dieser Aktualisierung sichert Windows die INI-Datei unter dem Namen WININIT.BAK ab und entfernt alle durchgeführten Anweisungen aus der WININIT.INI.

Eine Anweisung der Art "NUL=c:\ordner\wegdamit.dll" löscht die angegebene Datei.

Ab Windows NT

Hier wird statt auf eine Datei auf einen Zweig in der Registry zurückgegriffen, der unter dem Registry Schlüssel

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ PendingfileRenameOperations

abgelegt wird. Dies erfolgt hauptsächlich aus Gründen der Sicherheit, da auf diesen Schlüssel nur ein Administrator Zugriff hat. Darum ist es auch nur möglich, dass ein Administrator ein Service Pack installieren kann, hier werden nämlich einige Systemdateien ausgetauscht.

Sie sollten sich diesen Schlüssel immer nur mit REGEDT32 ansehen, da dieser Wert als Datentyp REG_MULTI_SZ angelegt ist, mit REGEDIT würde man hier also nur HEX Zahlen sehen, was einem wohl wenig weiterhilft.

Microsoft empfiehlt, diesen Wert nicht direkt über den Registry Editor zu verändern, sondern über die Systemfunktion "MoveFileEx", da hier vorher eine Überprüfung durchgeführt wird. Für das obige Beispiel würde das dann so aussehen:

MoveFileEx('c:\test\ersatz.dll','c:\windows\system\test.dll',MOVEFILE_DELAY_UNTIL_REBOOT);

Alte Dateien im Zielverzeichnis werden nur dann durch neuere ersetzt, wenn der letzte Parameter des MoveFileEx-Aufrufs auf (MOVEFILE_REPLACE_EXISTING | MOVEFILE_DELAY_UNTIL_REBOOT) gesetzt wird.

MS liefert dafür auch das Programm INUSE.EXE (aus dem Resource Kit), Informationen dazu finden Sie unter:

MS Knowledge Base: http://support.microsoft.com/?kbid=228930

Das Programm finden Sie unter:

http://download.microsoft.com/download/winntsrv40/Utility/1.3/NT4/EN-US/inuse.exe

Info Nur Administratoren haben die Berechtigung, auf diesen Registry-Schlüssel schreibend zuzugreifen.

Info Es werden nur kurze Dateinamen verarbeitet (8.3).

Info Mit dem Programm "MoveEx" von http://wwwthep.physik.uni-mainz.de/~frink/nt.htmlbekommt man auch die härteren Fälle in den Griff, da die Dateien beim Booten verschoben werden, bevor andere Prozesse starten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0646.htm


EXE-Dateien können nicht mehr gestartet werden

Wenn der Rechner mit einem Virus wie Sircam32 oder einem anderen infiziert war und diese Datei gelöscht wurde, können keine Programme mehr gestartet werden. Als Fehlermeldung wird gemeldet, dass die zuvor gelöschte Datei nicht gefunden werden konnte.

Hintergrund ist die Tatsache, dass der Trojaner sich in der Registry zu jedem Programmaufruf mit starten will. Die Einträge in der Registry hierzu finden sich unter

HKEY_CLASSES_ROOT\ exefile\ shell\ open\ command

bzw.

HKEY_LOCAL_MACHINE\ Software\ CLASSES\ exefile\ shell\ open\ command.

Statt des Eintrags "%1" %*" steht dort dann z.B. "sircam32.exe"%1 %*".

Dummerweise kann man nun auch keinen Registry-Editor mehr laden. Zur Abhilfe benennt man die Regedit.exein der Eingabeaufforderung in Regedit.com um, wodurch sich diese dann starten lässt und man den Eintrag manuell ändern kann. Danach wieder Regedit.com in Regedit.exe umbenennen.

Siehe auch "EXE-Dateien lassen sich nicht mit Doppelklick starten".

Info Weitere Infos auch unter http://www.trojaner-info.de/report_sub7.shtml

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1144.htm


Dateiattribute unter Windows verändern

Die meisten Dateiattribute kann man im Explorer über die "Eigenschaften" verändern. Hat eine Datei das Attribut "s" (System), wird sie von vielen Befehlen (z.B. "del" oder "xcopy") nicht berücksichtigt. Das Attribut "s" lässt sich unter Windows aber nicht unter den "Eigenschaften" editieren. Sie können hierfür natürlich die DOS-Box öffnen und mit "ATTRIB -S [Dateiname]" das Attribut verändern.

Windows 9x/ME und NT:

Zieht man eine Datei in den Papierkorb und stellt sie anschließend wieder her, werden die Attribute "s" und "r" (read only) aber auch automatisch von Windows gelöscht.

Diese Eigenschaft des Papierkorbs können Sie auch nutzen, wenn Sie Dateien von CD-ROM auf die Festplatte kopieren. Nach kurzem Aufenthalt im Papierkorb ist das Schreibschutz-Attribut verschwunden. Ein Aufruf von "ATTRIB -r *.* /s" in einer DOS-Box erfüllt den gleichen Zweck auch in allen weiteren Unterverzeichnissen.

Ab Windows XP:

Hier können Sie das Attribut auch über die Oberfläche einfach für alle Dateien eines Ordners ändern. Klicken Sie dafür mit der rechten Maustaste auf den Ordner und wählen Sie aus dem Kontextmenü "Eigenschaften" aus. Jetzt ändern Sie hier das gewünschte Attribut und klicken dann auf "OK". Sie werden jetzt gefragt, ob die Änderung nur für den Ordner oder auch für alle untergeordneten Ordner ausgeführt werden soll.

Parameter von ATTRIB.EXE:

Aufruf: ATTRIB.EXE [Befehle 1] [Laufwerk Dateiname] [Befehl 2]

Befehle 1 | Hier geben Sie Attribute an, die geändert werden sollen (setzen oder löschen)
+R bzw -R | Schreibgeschützt setzen (+) bzw. löschen (-)
+A bzw -A | Archiv setzen (+) bzw. löschen (-)
+S bzw -S | Systemdatei setzen (+) bzw. löschen (-)
+H bzw -H | Versteckte Datei setzen (+) bzw. löschen (-)

Befehl 2 | Ob Unterverzeichnisse berücksichtigt werden sollen
/S | alle Unterverzeichnisse werden mit berücksichtigt

Beispiel:

ATTRIB.EXE -R +A +H *.BAT /S

Würde alle "BAT" Dateien im aktuellen Verzeichnis und allen Unterverzeichnissen auf "Versteckt" und "Archiv" setzen und den "Schreibschutz" entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0017.htm


Alle Dateien anzeigen

Wirklich alle Dateien anzeigen

Obwohl Sie im Explorer unter "Extras" -> "Ordneroptionen" unter dem Tabreiter "Ansicht" die Einstellung "Erweiterungen bei unbekannten Dateitypen ausblenden" und "Geschütze Systemdateien ausblenden (empfohlen)" deaktiviert haben, um alle Dateien zu sehen, gibt es immer noch Dateien die von Windows nicht angezeigt werden (z.B.: PIF und LNK Dateien).

Windows entscheidet über die Registryeinträge "NeverShowExt" und "AlwaysShowExt" ob die Dateien angezeigt werden oder nicht.

Wenn Sie möchten, dass auch ausgeblendete Dateien angezeigt werden, müssen Sie den Eintrag "NeverShowExt" entfernen und den Eintrag "AlwaysShowExt" hinzufügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT suchen Sie nach "NeverShowExt".

Wollen Sie nun, dass diese Dateien auch im Explorer angezeigt werden, fügen Sie unter diesem Eintrag eine neue Zeichenfolge mit dem Namen "AlwaysShowExt" hinzu und löschen danach den alten Eintrag "NeverShowExt".

Info Durch Hinzufügen des Eintrags "NeverShowExt" können Sie natürlich auch selber weitere Dateiendungen angeben, die im Explorer nicht mehr angezeigt werden sollen.

Wenn Sie die Einstellung für eine bestimmte Dateiendung anpassen wollen, gehen Sie folgendermaßen vor (als Beispiel wird die Dateiendung .PIF genommen):

  • Suchen Sie unter "HKEY_CLASSES_ROOT" die entsprechende Dateiendung (hier HKEY_CLASSES_ROOT\.PIF). Dort finden Sie unter "(Standard)" den nötigen Typnamen (hier "piffile")
  • Suchen Sie jetzt unter "HKEY_CLASSES_ROOT" den Typnamen (hier "HKEY_CLASSES_ROOT\ piffile"). Unter diesem Schlüssel finden Sie bei diesem Dateityp "NeverShowExt" welchen Sie jetzt löschen können. Anschließend legen Sie noch "AlwaysShowExt" an, damit diese Dateiendung auch angezeigt wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0015.htm


GID-File Informationen

Windows erstellt eine .GID (global index) Datei unter folgenden Umständen:

  1. Ein Help-File, das nicht im Windows Help-Format erstellt wurde, wird benutzt. Zu dieser Datei existiert noch keine .GID-Datei.
    Existiert eine veraltete .GID-Datei, wird sie von Windows ersetzt. (Veraltet bedeutet, dass die Datei geändert und seitdem nicht mehr geöffnet wurde.)
  2. Wenn die Nachricht "Setting up Help" erscheint, wird nach der.GID-Datei gesucht und sie wird ggf. erstellt.

Eine .GID hat denselben Namen und liegt (als versteckte Datei) im selben Ordner wie die dazu gehörende .HLP-Datei. Falls auf den Ordner der HLP-Datei nicht schreibend zugegriffen werden kann (z.B. CD oder Netzwerk), wird sie im Windows/Help Ordner erstellt.

Windows speichert Zeiger zu allen Topics und Indexeinträgen einer .HLP in einer .GID-Datei aus folgenden Gründen:

  1. Diese Informationen sind wegen der Größe der Datei-nicht in der .HLP selbst gespeichert.
  2. Windows benutzt die .GID-Files als Status/Config Files, so wird z.B. die Position des Help-Windows abgespeichert.

Windows für Workgroups v3.1 (und höher) kann unter folgender Bedingung die .GID-Files benutzen:

Win32s ist installiert und es wurde der 32-Bit Help Compiler mit den dazu gehörenden DLLs installiert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0124.htm


INF-Dateien

Bei den Installationen von Treibern und Software verwendet Windows INF-Dateien. Die INF-Dateien sind ähnlich aufgebaut wie INI-Dateien und lassen sich mit jedem ASCII-Editor (z.B. Notepad) bearbeiten. INF-Dateien bestehen aus Sektionen, die in eckige Klammer eingeschlossen sind und aus Werten innerhalb der Sektionen.

Jede INF-Datei für Windows beginnt mit folgendem Funktionskopf:

[Version] |
Signature="$Chicago$" | für Betriebssystem und
Class= | für Klasse in der Registry

Beispiel:

Ersetzt die Windows-Oberfläche durch den Programm-Manager:

[version]

signature="$Chicago$"

SetupClass=Base

[DefaultInstall]

UpdateInis=change.shell.progman

[change.shell.progman]

%10%\system.ini, boot, , "shell=progman.exe"

[DefaultUninstall]

UpdateInis=change.shell.explorer

[change.shell.explorer]

%10%\system.ini, boot, , "shell=explorer.exe"

Kopieren Sie das obige Listing in eine Datei (z.B. UPDATE.INF) und speichern Sie sie ab.

Wenn Sie die Datei jetzt mit der rechten Maustaste anklicken und -> "Installieren" wählen, wird zunächst die Funktion "UpdateInis" in der Sektion "[DefaultInstall]" ausgeführt. "UpdateInis" enthält einen Verweis auf eine andere Sektion, nämlich "[change.shell.progman]". Hier wird zuerst das Windows-Verzeichnis ("%10%" ist ein Verweis darauf), dann SYSTEM.INI und dort der Eintrag "shell=" gesucht und schließlich durch "shell=progman.exe" ersetzt.

Um die Änderung wieder rückgängig zu machen, klicken Sie mit der rechten Maustaste auf die Datei (hier UPDATE.INF) und wählen Sie -> "Uninstall".

Diesmal wird die Sektion [DefaultUninstall] ausgeführt und "shell=explorer.exe" in die SYSTEM.INI eingetragen.

In der Registry finden Sie folgende Einträge für "Install" und "Uninstall":

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ inffile\ shell\ install\ command

Windows 9x

Rundll.exe setupx.dll,InstallHinfSection DefaultInstall 132

Rundll.exe setupx.dll,InstallHinfSection DefaultUnInstall 132

Ab Windows NT

Rundll32.exe setupapi,InstallHinfSection DefaultInstall 132

Rundll32.exe setupapi,InstallHinfSection DefaultUnInstall 132

Info Siehe dazu auch: Registry-Abkürzungen in INF-Dateien

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0163.htm


Dateitypen mit verschiedenen Anwendungen verknüpfen

Bestimmte Dateitypen sind unter Windows (z.B. *.DOC) mit bestimmten Anwendungen (hier WINWORD) verknüpft. Oft möchte man aber eine Dateiendung mit verschiedenen Programmen verknüpfen.

Starten Sie den Explorer und wählen dann -> "Extras" -> "Option" -> "Dateitypen".

Info Ab Windows Vista finden die Einstellung unter "Systemsteuerung (Klassische Ansicht)" -> "Indizierungsoptionen" -> hier auf den Button "Erweitert" klicken und es öffnet sich das Fenster "Erweitere Optionen" hier finden Sie jetzt auch den Tabreiter "Dateitypen"

Finden Sie den gewünschten Dateityp und wählen dann -> "Bearbeiten" -> "Neu". Für den Vorgang können Sie eine beliebige Bezeichnung eingeben. Unter "Anwendungen für diesen Vorgang" gibt man den Namen und den kompletten Pfad zu dem Programm an, mit dem der Dateityp verknüpft werden soll.

Wählt man nun mit der rechten Maustaste eine Datei dieses Typs an, besteht eine weitere Möglichkeit, sie zu öffnen/bearbeiten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0106.htm


Unwichtige Dateien

Unwichtige Dateien 'bearbeiten'

Ab und zu sollte man die Festplatte von nicht mehr benötigten Dateien befreien. Hier die periodische Säuberungsaktion:

  1. Klicken Sie auf ->START ->"Suchen" ->"Dateien/Ordner..."
  2. Geben Sie im Feld "Name" folgendes ein:
    *.cln,*.tmp,*.bak,*.old,*.b~k,*.s~y,~*.*,Mscreate.dir
  3. Geben Sie bei "Suchen in" Ihre Laufwerke ein. (Man kann mehrere Laufwerke eingeben. Diese Suchbegriffe müssen mit Semikolon getrennt werden, also: C:;D:;E:;F:)
  4. Klicken Sie auf -> "Starten" und sofort auf ->"Beenden"
  5. Unter dem Menü -> "Optionen" wählen Sie "Ergebnis speichern"
  6. Im Menü ->"Datei" wählen Sie ->"Suche speichern" (damit man nicht jedes einmal die Dateiendungen eintippen muss)
  7. Alle Dateien, die bei der Suche gefunden wurden, können nun mit der Tastenkombination STRG+A und anschließend ENTF in den Papierkorb befördert werden.

Protokolldatei:

Wenn Windows NT abstürzt, legt Windows die Datei "USER.DMP" an. Diese Datei enthält einen vollständigen Speicherauszug und hat deshalb die Größe des jeweiligen Arbeitsspeichers! Durch Löschen dieser Datei kann man viel Speicherplatz freibekommen.

Zu den Dateiendungen

SYD, CLN, BAK, OLD, B~K, S~Y

Sicherungen der Dateien SYSTEM.INI, WIN.INI, AUTOEXEC.BAT und CONFIG.SYS, wenn diese z.B. mit SYSEDIT aus dem Verzeichnis C:\WINDOWS\SYSTEM bearbeitet werden.

TMP

Temporäre Dateien. Hier ist aber einige Vorsicht geboten: Aktive Programme verwenden gerne TMP als SUFFIX für Auslagerungen.

Vorgehen:

Sortiert das Ergebnis immer nach dem Änderungsdatum, lösche die Dateien vor dem dem letzten Neustart in einem Aufwaschen (das funktioniert zu 99%) und die danach dann einzeln - da können dann ein paar Dateien übrig bleiben, die sich nicht löschen lassen, das sind dann genau die aktiven Anwendungs-Auslagerungen, die angesprochen sind.

Nach Löschen dieser unnötigen Dateien empfiehlt sich ein Neustart, da vor allem die ~*.TMP-Dinger noch im RAM residieren könnten, obwohl sie löschbar waren und die können die wunderlichsten Sachen auslösen...

MSCREATE.DIR

wird von Windows beim Anlegen eines Verzeichnisses erzeugt. Diese Datei hat eine Größe von 0kBund ist schreibgeschützt und unsichtbar. Sie wird also von Defrag nicht berücksichtigt.

Gelegentliche Säuberungen lohnen sich, weil durch viele kleine Dateien (kleiner als Clustergröße einer Partition) extrem viel Platz verschwendet wird. Ferner lohnt sich ein gelegentlicher Blick in das TEMP-Verzeichnis

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0274.htm


Individuelle Vorschriften für registrierte Dateitypen

Unter Windows ist es möglich, Bearbeitungsmöglichkeiten für jeden registrierten Dateityp individuell einzuschränken.

Info Siehe dazu die ausführliche Beschreibung im Tipp: "Bedeutung von EditFlags (Dateitypen)"

Ein Beispiel:

BAT-Dateien

Unter "HKEY_CLASSES_ROOT\.bat" ist diese Endung als "batfile" registriert. Nun suchen Sie also den Eintrag: "HKEY_CLASSES_ROOT\ batfile\", wo Sie den Eintrag "EditFlags" finden. Dieser Eintrag steht standardmäßig auf: "D0 04 00 00"

Das bedeutet dann:

D0 ist gleich 80+40+10 | "Vorgänge, Entfernen", "Vorgänge, Bearbeiten" und "Entfernen" wurden deaktiviert.
04 | "Vorgänge, als Standard" ist deaktiviert

Info Diese Einstellungen sind auch unter "Aufbau der Registrydatenbank" beschrieben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0149.htm


Dateisuche als Icon

Erstellen Sie eine leere Datei mit dem Namen "DUMMY.FND". Klicken Sie nun mit der rechtenMaustaste auf den Desktop und erstellen eine Verknüpfung mit dieser Datei. Die Verknüpfung benennen Sie "FileFinder" bzw. "Suchen" und weisen Sie ihr ein Symbol zu.

*.FND-Dateien sind standardmäßig mit der Explorer-Funktion "Suchen" verknüpft. Daher führt der Aufruf einer leeren *.FND-Datei ohne Fehlermeldung zum gewünschten "Suchen nach"-Dialog.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0105.htm


Bei INF-Dateien erscheint kein "Installieren"

Wenn Sie eine *.INF-Datei mit der rechten Maustaste anklicken und dort kein "Installieren" erscheint,führen Sie folgendes durch:

Windows 95/98

Starten Sie den Explorer und suchen Sie unter -> "Ansicht" -> "Optionen" -> "Dateitypen" den Typ "Setup-Informationen" bzw. "INF-Datei".

Doppelklicken Sie auf diesen und prüfen Sie, ob unter "Vorgänge" "Installieren" steht. Wenn nicht, klicken Sie auf -> "Neu". Geben Sie folgendes ein:

unter "Vorgang": &Installieren

unter "Anwendung für diesen Vorgang": %WINDIR%\Rundll.exe setupx.dll,InstallHinfSection DefaultInstall 132

Ab Windows NT

Starten Sie den Explorer und suchen Sie unter -> "Extras" -> "Optionen" -> "Dateitypen" den Typ "Setup-Informationen" bzw. "INF-Datei".

Klicken Sie auf "Erweitert" und prüfen Sie, ob unter "Aktionen" "Installieren" steht. Wenn nicht, klicken Sie auf -> "Neu". Geben Sie folgendes ein:

unter "Vorgang": &Installieren

unter "Anwendung für diesen Vorgang" %WINDIR%\System32\Rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %1

Ab Windows Vista

Sie finden hier die Einstellung unter "Systemsteuerung (Klassische Ansicht)" -> "Indizierungsoptionen" -> hier auf den Button "Erweitert" klicken und es öffnet sich das Fenster "Erweitere Optionen" hier finden Sie jetzt auch den Tabreiter "Dateitypen"

Suchen Sie hier jetzt den Typ "Setup-Informationen" bzw. "INF-Datei".

Klicken Sie auf "Erweitert" und prüfen Sie, ob unter "Aktionen" "Installieren" steht. Wenn nicht, klicken Sie auf -> "Neu". Geben Sie folgendes ein:

unter "Vorgang": &Installieren

unter "Anwendung für diesen Vorgang" %SystemRoot%\System32\InfDefaultInstall.exe "%1"

Sie können das auch in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

und tragen Sie unter HKEY_CLASSES_ROOT\ inffile\ shell\ command bei (Standard) als Datentyp REG_EXPAND_SZ folgendes ein: %SystemRoot%\System32\InfDefaultInstall.exe "%1"

Info Hinter "Rundll.exe" ist unbedingt die Groß-/Kleinschreibung zu beachten!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0064.htm


'Öffnen mit...' bei registrierten Datei-Typen

Dateien mit bereits in der Registry registrierten Dateitypen lassen sich auch mit anderen Programmen öffnen (z.B. *.DOC mit WordPad).

Dazu muss man die Datei markieren und dann bei gedrückter <SHIFT>-Taste mit der rechten Maustaste anklicken. Jetzt erscheint im PopUp-Menü zusätzlich die Option "Öffnen mit...".

Wenn Sie "Öffnen mit..." bei registrierten Dateien ohne das extra Drücken der Shift-Taste angezeigt bekommen wollen, tragen Sie folgendes in die Registry ein:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ *

erstellen Sie einen neuen Schlüssel mit dem Namen "shell". Unter diesem Schlüssel einen weiteren mit dem Namen "openas" und darunter einen weiteren Schlüssel mit dem Namen "command" (der Registryzweig sollte nun folgendermaßen aussehen:

"HKEY_CLASSES_ROOT\ *\ shell\ openas\ command".

Hier tragen Sie nun bei "(Standard)" folgenden Aufruf ein:

"Rundll32 shell32.dll,OpenAs_RunDLL %1"

bzw.

"Rundll32 shell32.dll,OpenAs_RunDLL %2" (Dadurch wird der Eintrag "Diesen Dateityp immer mit diesem Programm öffnen" automatisch deaktiviert).

Ab jetzt wird für alle Dateitypen im Kontextmenü ein weiterer Eintrag "Öffnen mit..." angezeigt.

Sie können auch den Text vorgeben mit dem der Eintrag im Kontextmenü angezeigt werden soll. Dafür geben Sie einfach bei:

HKEY_CLASSES_ROOT\ *\ shell\ openas

unter "(Standard)" den Text an, der angezeigt werden soll. Wenn Sie vor einem Buchstaben noch ein & (Shift + 6) setzen, können Sie auch noch einen Kurzbuchstaben (Shortkey) mitgeben zum direkten Aufruf

Info Wenn Sie hinter %1 noch ein Leerzeichen angeben, wird im "Öffnen mit..." Dialog automatisch der Eintrag "Diesen Dateityp immer mit diesem Programm öffnen" deaktiviert, und Sie können so nicht aus Versehen die Standardverknüpfung zu einem anderen Programm verändern. Es ist aber einfacher dafür dann gleich %2 zu nutzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0215.htm


Ausschalten der langen Dateinamen (FAT)

Soll Windows auf einer FAT-Partition keine langen Dateinamen verwenden, kann man dieses Verhalten in der Registry abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

finden Sie den Eintrag "Win31FileSystem" als Datentyp REG_DWORD und setzen ihn auf "1". Wenn Sie den Wert wieder auf "0" setzen, sind die langen Dateinamen wieder eingeschaltet.

Legt fest, ob FAT das Anlegen, Numerieren, Öffnen oder Suchen nach langen Dateinamen erlaubt und ob zusätzliche Zeitmarken (CreationTime und LastAccessTime) gespeichert werden. Ist dieser Wert auf 1 gesetzt, werden keine langen Dateinamen erzeugt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0030.htm


Allen unbekannten Dateitypen eine Anwendung zuweisen

Wenn Sie unter Windows auf eine Datei klicken, deren Dateiendung in Windows nicht bekannt ist, werden Sie gefragt, mit welcher Anwendung Sie diese Datei öffnen möchten. Sie können einstellen, mit welcher Anwendung diese unbekannten Dateitypen automatisch geöffnet werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Unknown\ shell

einen neuen Schlüssel "Open" anlegen. Legen Sie unter dem neuen Schlüssel einen weiteren Unterschlüssel an und nennen ihn "command". Klicken Sie nun "command" an (der Pfad sieht dann so aus: "HKEY_CLASSES_ROOT\ Unknown\ shell \Open\ command" bzw. ab XP "HKEY_CLASSES_ROOT\ Unknown\ shell \Openas\ command"), dann finden Sie im rechten Fenster die Zeichenfolge "Standard". Weisen Sie nun "Standard" das gewünschte Programm zu (z.B. C:\Windows\notepad.exe %1).

Info Ab Windows XP gibt es den Key "openas", Sie müssen den oben beschriebenen Eintrag jetzt hier durchführen.

Weiterhin können Sie auch allen unbekannten Dateitypen ein Icon zuweisen unter:

HKEY_CLASSES_ROOT\ Unknown\ shell

legen Sie den Schlüssel "DefaultIcon" an. Öffnen Sie nun diesen Schlüssel und weisen Sie der Zeichenfolge "Standard" eine Icon-Datei zu (z.B. C:\Windows\notepad.exe,1)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0016.htm


Autostart von Programmen und Laufwerk-Icons für Festplatten und CD-ROMs

Um eine CD zu erstellen, welche beim Einlegen automatisch ein Programm startet, gehen Sie so vor.

Die CD muss im Hauptverzeichnis die Datei AUTORUN.INF enthalten. Diese Datei muss mindestens aus drei folgenden Zeilen bestehen:

[AutoRun]

OPEN= | <pfad>\<Dateiname> <optionale Parameter> |
ICON= | <pfad>\<Dateiname> |
shell\install= | &Setup | wird im Kontext-Menü angezeigt, mit Accelerator-Key
shell\install\command= | setup.exe | welches Programm ausführen bei obigem Befehl im Kontext-Menü
shell\configure= | &Configure |
shell\configure\command= | executable [Befehlsschalter | Pfad\Dateiname] |
shell\readme= | &Read Me |
shell\readme\command= | executable [Befehlsschalter | Pfad\Dateiname] |
shell\help= | &Help |
shell\help\command= | executable [Befehlsschalter | Pfad\Dateiname] |

Das bei "OPEN=" angegebene Programm startet beim Einlegen der CD automatisch. Hinter "ICON=" sind auch andere Dateiformate erlaubt, nämlich BMP, DLL oder EXE. In diesen Fall muss die Position des Icons mit angegeben werden (z.B. icon=moricons.dll,7). Beachten Sie bitte, dass das erste Icon immer mit "0" angegeben wird.

Info Wenn man die Icon-ID mit negativem Vorzeichen angibt, werden die IDs von -1 bis -x von 1 statt von 0 weg indiziert. Man braucht die Position also nicht mehr um eine Stelle verschieben.

Info Standardmäßig funktioniert das nur bei CDs. Die Einstellung für andere Laufwerke finden Sie unter: "Autostartfunktion für unterschiedliche Laufwerke einstellen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0054.htm


Verknüpfung mit Parametern klappt nicht

Will man unter Windows eine Verknüpfung mit Parametern (/? oder /s etc.) einbauen, bockt Windows manchmal.

Der Grund:

Windows kommt mit Leerzeichen in den Pfadangaben nicht zurecht, wenn sie nicht in Anführungszeichen gesetzt werden. Wenn Sie also z.B. folgendes machen wollen:

C:\Programme\Babylon Translator\babylon.exe /?

dann müssen Sie in der Verknüpfung den Pfad in Anführungszeichen setzen:

"C:\Programme\Babylon Translator\babylon.exe" /?

Info Die Parameter dürfen nicht in Anführungszeichen stehen und ein Leezeichen zwischen dem Parameter muss angegeben werden..

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1075.htm


Das Multimedia Verzeichnis verlegen

Das Multimedia Verzeichnis verschieben

Windows legt die Mediadateien unter dem Verzeichnis "%SYSTEMROOT%\Media" ab. Wenn Sie dieses Verzeichnis an eine andere Stelle verlegen wollen, gehen Sie folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

hier finden Sie den Eintrag "MediaPath" als Datentyp REG_SZ. Ändern Sie diese Pfadangaben einfach auf Ihr gewünschtes Verzeichnis ab. Sie sollten vorher die Dateien aus dem alten Verzeichnis an diese Stelle kopieren.

Ab Windows Vista gibt es den Eintrag "MediaPathUnexpanded" als Datentyp REG_EXPAND_SZ.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0474.htm


WEB-Ansicht von Ordnern

Ab IE 4.x können Sie Ordner in der sogenannten Webansicht darstellen lassen. Diese Ansicht können Sie je nach Belieben total verändern.

Wie ein Ordner dargestellt wird, hängt von der Datei "FOLDER.HTT" ab, die als erstes im aktuellen Ordner gesucht wird. Ist sie da nicht vorhanden, wird die allgemeingültige "FOLDER.HTT" Datei aus dem Verzeichnis "Windows\Web" verwendet. Wollen Sie noch zusätzliche Informationen angezeigt bekommen, müssen Sie diese HTML-Datei Ihren Wünschen entsprechend ändern (aus Sicherheitsgründen sollten Sie die Originaldatei vorher sichern).

Sie können die Datei mit einem HTML-Editor öffnen oder über den Explorer "Ansicht" -> "Ordner anpassen", dort aktivieren Sie "Ein HTML-Dokument erstellen oder bearbeiten".

Die erste Anweisung, die zwischen <object> und </object> eingeschlossen ist, sollten Sie nicht löschen. Sie ist dafür zuständig, dass der Inhalt des Ordners auf dem Bildschirm angezeigt wird. Aus diesen Grunde sollten Sie eine neue "FOLDER.HTT" auch immer über den Explorer erstellen, da er die richtige Class-ID einträgt.

Sie können aber beliebige andere Anweisungen hinzufügen.

Videodateien mit Wiedergabesymbol:

Suchen Sie in der bestehenden Datei nach wantMedia, dieser Wert steht normalerweise auf FALSE. Wenn Sie diesen Wert auf TRUE setzen, erscheinen ab sofort Videodateien im linken Fenster mit dem Wiedergabesymbol.

Automatische Spaltenumschaltung:

Wenn das Fenster des Explorers sehr schmal gemacht wird, blendet Windows automatisch die linke Infozeile aus. Ab welcher Größe das passieren soll, wird mit der Variable threshold festgelegt. Standardmäßig steht dieser Wert auf 400. Wenn Sie diesen Wert auf 3000 setzen, beschränkt sich die Webansicht auf die Nennung des Ordnernamens am oberen Fensterrand.

Die Sektion "/Style"

Hier finden Sie alle Einträge für die wichtigen Elemente in der WEB-Ansicht.

Eintrag | Bedeutung
body | alle Elemente der linken Infozeile
p | Text
p.Title | Ordnername
p.Links | Verknüpfungen
a.Command | anklickbare Befehle
#FileList | Aufbau der rechten Spalte (Inhalt)
#Panel | Aufbau der linken Spalte (Infozeile)

Hinter diesen Begriffen finden Sie in den geschweiften Klammern die Einstellungen. Sie können hier z.B. Schriftart, -größe, -stil, -farbe usw. festlegen.

Die Werte in den geschweiften Klammern sind wie folgt angeordnet:

{position: absolute; width: 200px; height: 100%; visibility: hidden; overflow: auto}

Als erstes wird angegeben, welcher Wert geändert werden soll. Nach dem Doppelpunkt wird der neue Wert angegeben. Einzelne Einträge werden untereinander durch ein Semikolon getrennt.

Bei Größenangaben kann die Angabe entweder in Prozent oder in Punkten erfolgen (% bzw. px). Die Prozentangabe bezieht sich dabei auf die Größe des Fensters.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0256.htm


Schneller Ordner-Überblick

Um einen schnellen Überblick über ein Verzeichnis zu bekommen, können Sie den "Ausführen..." Befehl aus der Startleiste benutzen. Geben Sie dort einfach den Pfad zu dem Verzeichnis an, welches Sie betrachten wollen, also z.B. "C:\WINDOWS\SYSTEM".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0302.htm


Verzeichnis zeigt nur noch HTML-Dateien an (Verlaufsordner)

Ist ein Verzeichnis unter Windows als sogenannter "Verlaufsordner" gekennzeichnet, werden nur noch die HTML-Dateien im Explorer angezeigt.

Wollen Sie das wieder rückgängig machen und alle Dateien im Explorer sehen, müssen Sie die Datei "DESKTOP.INI" aus diesem Ordner löschen. Da aber auch diese Datei nicht angezeigt wird, können Sie die Datei nur über die Eingabeaufforderung bzw. mit dem alten Programm WINFILE (nur noch bei 2000 mit dabei) löschen. Beachten Sie aber, dass diese Datei zusätzlich noch als verstecke Datei markiert ist.

Siehe auch Tipp: Informationen über die Datei "Desktop.ini"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0645.htm


Ordnern andere Icons zuweisen

Ab IE Version 4.x können Sie jedem Ordner individuell ein Icon zuweisen. Gehen Sie dazu folgendermaßen vor:

Legen Sie unter HKEY_CLASSES_ROOT\CLSID mit dem Registry-Editor einen neuen Schlüssel als Class-ID (CLSID) an.

Wichtig ist dabei, dass diese ID noch nicht vorhanden ist.

Eine Class-ID besteht immer aus 8-4-4-4-12 Hex-Ziffern. Damit Sie nicht zufällig eine ID anlegen, die schon von anderen verwendet wird, sollten Sie von hinten hochzählen, eine mögliche ID wäre also {00000000-0000-0000-0000-000000000001}.

Unter diesem Schlüssel müssen Sie nun einen weiteren Schlüssel mit dem Namen "DefaultIcon" anlegen. Jetzt gehen Sie im rechten Fenster auf den Eintrag "Standard" und geben als Wert den Pfad und Dateinamen zu der Datei an, die das gewünschte Icon enthält (z.B.: c:\windows\system\shell32.dll,2). Die Zahl hinter dem Dateinamen gibt an, welches Icon verwendet werden soll, falls die Datei mehr als 1 Icon enthält.

Dann müssen Sie dem entsprechenden Ordner nur noch die Class-ID zuordnen. Dafür gehen Sie im Windows Explorer auf den Ordnernamen und drücken F2 zum Umbenennen. Lassen Sie den Namen stehen und geben Sie dahinter die von Ihnen angelegte Class-ID an. Das ganze muss dann so aussehen, wenn der Ordner z.B. "Daten" heißt:

Daten.{00000000-0000-0000-0000-000000000001}.

Wichtig ist, dass die Class-ID in Spitze-Klammern eingeschlossen und mit einem Punkt vom Namen getrennt wird.

Info Wenn Sie die Änderung durchgeführt haben, wird dem Ordner ein neues Icon zugeteilt. Der einzige Nachteil ist, dass Sie auf so einen geschlossenen Ordner kein Drag & Drop mehr ausführen können.

Alternative (einfacher):

Der betreffende Ordner muss das Attribut System haben. Das können Sie folgendermaßen setzen: Öffnen Sie die "Eingabeaufforderung" (CMD.EXE) und geben Sie hier folgenden Befehl ein: "attrib +s [Ordnername]".

Erstellen Sie in diesem Ordner eine Datei mit dem Namen "Desktop.ini" mit folgendem Inhalt:

=== Hier schneiden ===
[.ShellClassInfo]
Iconfile=C:\Windows\System32\shell32.dll

IconIndex = 0
IconTip=Beschreibung des Ordners
=== Hier schneiden ===

Hiermit können Sie - etwas einfacher und ohne Nachteile - einem Ordner ein neues Icon verpassen. IconIndex bestimmt die Position des Icons. Wenn Sie ein Icon aus einer Datei verwenden, die mehrere Icons enthält; beginnt die Zählung der Icons mit 0.

Durch den Eintrag "IconTip" können Sie noch einen Text angeben, der angezeigt wird, wenn der Cursor einige Zeit auf diesem Icon verweilt (siehe auch: QuickInfo für Icons).

Weiterhin können Sie noch folgende Werte in der Desktop.ini angeben:

Name | Werte | Beschreibung
ConfirmFileOp= | 0 oder 1 | Wenn Sie den Wert auf 0 setzen, bekommen Sie eine Warnmeldung, wenn der Ordner gelöscht oder verschoben werden soll
NoSharing= | 0 oder 1 | Wenn Sie den Wert auf 1 setzen, kann der Ordner nicht mehr freigegeben werden.

Sollte das neue Icon nicht gleich angezeigt werden, versuchen Sie folgendes:

  1. Drücken Sie F5, um die Anzeige zu aktualisieren
  2. Starten Sie Windows neu
  3. Verwenden Sie die "Repair Icons"-Funktion von TweakUI (siehe "Tweak UI 1.33: Alle Funktionen im Überblick")

Siehe dazu auch Tipp: Informationen über die Datei "Desktop.ini"

Info Ein Programm zum Erzeugen von GUIDs finden Sie unter: http://www.aboutvb.de/khw/artikel/khwcreateguid.htm.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0253.htm


Verzeichnisse mit Großbuchstaben erstellen

Wenn Sie unter Windows (speziell Windows 98) ein Verzeichnis anlegen, wandelt der Explorer alle Großbuchstaben (außer das erste Zeichen) in Kleinbuchstaben um. Wenn Sie Verzeichnisse mit Groß- und Kleinbuchstaben anlegen wollen müssen Sie das aktivieren.

Sie können das unter Windows 98 über den Explorer einstellen -> "Ansichten" -> "Ordneroptionen". Dort finden Sie unter der Registerkarte "Ansichten" den Eintrag "Namen in Großbuchstaben ermöglichen" aktivieren.

Sie finden die Einstellungen in der Registry im folgenden Zweig:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "DontPrettyPath" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verzeichnisnamen werden so übernommen (Groß-/Kleinschreibung)
0 | Verzeichnisnamen werden geändert

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1408.htm


Attribut des Systemordners ändern

Der Windows Explorer verwendet standardmäßig das Attribut "Read Only" (Lesen) um zu bestimmen, ob ein Ordner angepasst wurde. Diese Funktion kann bei einigen Programmen dazu führen, dass Sie nicht mehr Speichern können. Mit diesem Tipp können Sie einstellen, dass Windows wieder das Normale Systemattribut verwendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "UseSystemForSystemFolders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Systemattribut verwenden
0 | Systemattribut nicht verwenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1612.htm


Laufwerksbezeichnung/Laufwerkssymbol im Explorer ändern

Bei Windows wird bei den CD-ROM Laufwerken im Explorer meist nur eine kurze Meldung wie "CD-ROM Laufwerk" angezeigt. Wenn man mehr als ein CD-ROM Laufwerk hat, kann man die Laufwerke so schwer am Namen auseinander halten.

Nach der Installation vom IE 4.x bzw. ab Windows 98 können Sie die Laufwerkssymbole nach Belieben abändern. Dafür müssen Sie in der Registry für das entsprechende Laufwerk einen neuen Schlüssel anlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

legen Sie dort einen neuen Schlüssel "DriveIcons" an. Unter dem Schlüssel "DriveIcons" erstellen Sie für jedes Laufwerk, welchem Sie ein neues Icon zuweisen wollen, z.B.: einen weiteren Schlüssel mit dem Laufwerksbuchstaben.

Erstellen Sie jetzt unter jedem Laufwerksbuchstaben einen Schlüssel mit dem Namen "DefaultIcon" und tragen Sie dort beim Wert "(Standard)" den Pfad zum Icon ein.

Beispiel für das Ändern des Icons von Laufwerk C:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ DriveIcons\ C\ DefaultIcon\

dort hat der Wert "(Standard)" den Eintrag "C:\WINDOWS\Moricons.dll,20"

bzw. ab Windows XP: "C:\WINDOWS\system32\shell32.dll,10".

Wenn Sie ein Icon aus einer DLL hinzufügen wollen, müssen nach dem Komma das gewünschte Icon angeben, welches angezeigt werden soll. Dabei ist darauf zu achten, dass hier bei 0 angefangen wird zu zählen. Dem Laufwerk wurde hier aus der Datei MORICONS.DLL also das 21. Icon zugewiesen.

Mit den Schlüssel "DefaultLabel" können Sie über den Wert (Standard) als Datentyp REG_SZ die Bezeichnung angeben, die angezeigt werden soll.

Beispiel:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ DriveIcons\ C\ DefaultLabel

Hier geben Sie beim Wert "(Standard)" den Text ein, welcher angezeigt werden soll.

Info Siehe auch: "Festplatten Laufwerkssymbol ändern"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0005.htm


Bezeichnungen der Geräte im Gerätemanager ändern

Sie können die Bezeichnungen der Geräte, die im Gerätemanager angezeigt werden, manuell über Einträge in der Registry ändern. Dies ist z.B. nützlich, um zwei gleiche installierte Festplatten unterscheiden zu können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ Enum\ ESDI\ GENERIC_IDE__DISK_TYPE47_

(für Festplatten)

und

HKEY_LOCAL_MACHINE\ Enum\ SCSI

(für CD-Laufwerke)

suchen Sie nach dem Eintrag "DeviceDesc" vom Datentyp REG_SZ und ändern ihn wie gewünscht.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1321.htm


Laufwerkskonvertierung auf FAT32

Mit dem Tool Laufwerkskonvertierung ("Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Laufwerkskonvertierung (FAT32)") haben Sie die Möglichkeit, Ihre Partitionen auf das FAT32 Format umzustellen.

Bedenken Sie aber, dass andere Betriebssysteme ohne zusätzliche Tools nicht mehr auf diese Partitionen zugreifen können, darunter auch NT 4.0. Es sind aber schon Tools von Shareware Autoren vorhanden, die zumindest den Read-Only Betrieb zulassen und bestimmt auch bald schreibend auf die Partitionen zugreifen können (http://www.sysinternals.com).

Bedenken Sie auch, dass Windows 98 keine Funktion bietet, die Partition wieder in eine Normale FAT Partition umzuwandeln, auf dem Markt gibt es aber Programme, die auch diese Funktion ohne Datenverlust bieten (http://www.powerquest.com).

Windows-Programm

Programm: | CVT1.EXE
Verzeichnis: | Windows-Verzeichnis
Parameter: | keine

DOS -Programm

Programm: | CVT.EXE
Verzeichnis: | Windows\Command
Parameter: | /noscan Es wird keine Fehlerüberprüfung vorgenommen (Vorsicht!) /cvt32 In FAT 32 umwandeln Mit diesen Parametern ist es möglich, die Partition auf FAT32 umzustellen, auch wenn die normale Umwandlung die Konvertierung mit einer Fehlermeldung beendet (z.B.: cvt c: /nosan /cvt32). Sie sollten dafür aber Windows im DOS -Modus starten.

Die Konvertierung auf FAT32 wird aber erst ab Windows 98 angeboten. Wollen Sie einen bestehenden Windows 95 Rechner auf FAT 32 umstellen, haben Sie dort so ein Tool nicht zu Verfügung.

Sollten Sie aber auf eine Windows 98 Version Zugriff haben, können Sie mit einem Trick trotzdem die Laufwerke konvertieren.

  1. Kopieren Sie die Datei CVT.EXE auf eine Diskette.
  2. Damit Sie das Programm auch unter Windows 95 ausführen können, müssen Sie die Datei MSDOS .SYS folgendermaßen anpassen:
    a) Die Dateiattribute entfernen: attrib -r -h -s c:\msDOS .sys
    b) Öffnen Sie die Datei mit einem Editor und fügen Sie im Abschnitt [Options] folgende Zeile ein: winver=4.10.1998
  3. Starten Sie den PC neu (nur MSDOS Eingabeaufforderung)
  4. Rufen Sie nun CVT.EXE von der Diskette mit folgenden Parametern auf: cvt /cvt32 [Laufwerksbuchstabe:]
    (fügen Sie für Laufwerksbuchstabe das zu konvertierende Laufwerk ein)

Info Dieses dürfen Sie aber nur ab der B/C - Version von Windows 95 machen, alle älteren Versionen unterstützen noch kein FAT32 und können somit nach der Konvertierung nicht mehr auf das Laufwerk zugreifen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0210.htm


Beschleunigung Festplattenzugriffe

Bei jeden Zugriff auf eine Datei wird von Windows das Attribut für das Datum des letzten Zugriffs erneuert.

Mit folgendem Eintrag je Partition in der CONFIG.SYS kann dies umgangen und somit ggf.

der Zugriff auf Festplatten (jeder gesparter Zugriff bedeutet auch in der Regel Beschleunigung) beschleunigt werden:

Syntax:

ACCDATE=[Laufwerk]-

Beispiel:

ACCDATE=C-

In diesem Beispiel wird der Zugriff für das Laufwerk C abgeschaltet.

Info Dieser Befehl funktioniert aber leider nicht und MS hat den Fehler bisher noch nicht behoben, wie Sie in der Knowledge Base auch lesen können: http://support.microsoft.com/?kbid=182465

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0216.htm


Zugriff auf das Diskettenlaufwerk beschleunigen

Sollte der Zugriff auf das Diskettenlaufwerk bei Ihnen ungewöhnlich lange dauern, können Sie es durch Deaktivieren des Buffers beschleunigen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Windows 95/98 und ME:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ FDC\ 0000

Ab Windows 2000:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Fdc

Erstellen Sie hier einen neuen Eintrag mit dem Namen "ForceFIFO" als Datentyp REG_SZ und weisen Sie ihm den Wert 0 zu.

Suchen sie weiterhin den Wert mit den Namen "Int13ToDrvSelMap" als Datentyp REG_BINARY und weisen ihm den Wert "00,1c" zu.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0217.htm


ZIP-Drive einrichten

Dieser Tipp beschreibt die Einrichtung eines ZIP-Laufwerkes unter Windows 9x.

Für Plain-DOS folgende Einstellungen:

[AUTOEXEC.BAT]

SET SCSI_DRIVER = C:\IOMEGA

SET SCSI_UTILITY = C:\IOMEGA

[CONFIG.SYS]

DEVICE=C:\IOMEGA\ASPIPPA3.SYS Scan Info Quiet Country=049

DEVICE=C:\IOMEGA\SCSICFG.EXE /L=049 /V

DEVICE=C:\IOMEGA\SCSIDRVR.SYS /L=049

Diese Einträge sind ausschließlich für DOS.

Unter Windows 95 gibt es nach Einlesen der *.INF-Datei folgenden Eintrag im Gerätemanager:

[SCSI-CONTROLLER]

Iomega Parallel Port Zip Interface

/mode:nibble /port:378 /speed:6

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0337.htm


Laufwerksauswurf beim ZIP-Drive

Wenn beim Herunterfahren von Windows immer das Medium von ZIP-Drive ausgeworfen wird und Sie das doch nicht so gern möchten, können Sie das über die Registry ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Iomega Corporation\ Extensions

Dort finden Sie den Eintrag "ZipShutdownEject", wenn Sie den Wert auf "0" setzen wird Ihr Medium nicht mehr automatisch ausgeworfen.

Alternativ kann man auch den Aufruf des Zip-Icon-Programms aus dem Autostart-Ordner entfernen. Dadurch erscheint nur das ZIP-Drive im Arbeitsplatz ohne Icon als "Wechseldatenträger", alles andere funktioniert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0376.htm


Festplatten andere Laufwerksbuchstaben zuordnen

Auch unter Windows können Sie Festplatten einen anderen Laufwerksbuchstaben zuordnen.Die Voraussetzung ist, dass die HD erst beim Starten der Windows -GUI aktiviert wird, was eigentlich ganz einfach zu verwirklichen ist.

Bei SCSI-Festplatten:

Wenn eine SCSI-HD an einem SCSI-Host ohne BIOS hängt oder wenn Ihre ID aus dem BIOS -Scan ausgeklammert wird.

Bei IDE-Festplatten:

Es sollte auch mit IDE-HDs gehen, wenn diese nicht ins BIOS eingetragen werden, aber von einem Windows-(Busmaster-)Treiber erkannt werden.

Gehen Sie folgendermaßen vor:

Windows erst einmal ganz normal starten. Im Geräte-Manager bei der HD in den Eigenschaften muss das Feld "Wechsellaufwerk" oder "Austauschbarer Datenträger" (je nach Windows Version) angehakt werden. Nun können Sie in den entsprechenden Feldern die gewünschten Laufwerksbuchstaben eingeben.

Wenn diese Felder deaktiviert bleiben, ist eine der oben genannten Voraussetzungen nicht erfüllt.

Bei einer HD mit mehreren Laufwerken müssen natürlich der erste und letzte angegebene Buchstabe entsprechend weit auseinander liegen. Es ist also nicht möglich, einzelnen Partitionen einen anderen Buchstaben zuzuweisen; die Bootfestplatte kann auf keinen Fall verändert werden.

Nachdem die Änderung erfolgreich war, also wenn die HD nach einem Neustart die neuen Buchstaben erhält, kann der Haken aus dem Feld "Wechsellaufwerk" wieder entfernt werden. Die HD wird nun beim nächsten Start wieder als Festplatte erkannt, behält aber die neuen Buchstaben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0299.htm


FDISK kann Kapazität der Festplatte nicht voll nutzen

Festplatten mit einer Kapazität von mehr als 64 GByte können mit FDISK von Windows 95 und Windows 98 nicht voll genutzt werden, da dieses Programm sich intern verrechnet. In der Regel zeigt FDISK als Größe die volle Größe der Platte minus 64 GByte an, also z.B. 6 GByte bei einer 70er Platte.

Mit dem Patch für FDISK lässt sich der Fehler aber beheben:

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=263044

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1084.htm


Disk Cache optimieren

In Windows kann die Arbeitsgeschwindigkeit des Dateisystems und der Datenträger über die Standardnutzung des Rechners gesteuert werden. Diese Einstellungen werden nur vom Benutzer getroffen und sind nicht durch andere Konfigurationsänderungen betroffen.

So optimieren Sie die Arbeitsgeschwindigkeit des Dateisystems.

Unter "Start" -> "Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Dateisystem" -> "Festplatte" können verschiedene Profile ausgewählt werden, die folgende Systemeigenschaften bewirken:

PC | Einstellung soll verwendet werden, wenn mehr als das Minimum an benötigten Hauptspeicher für Windows vorhanden ist und dieser Rechner nicht als Server eingesetzt wird und mit Strom aus der Steckdose betrieben wird. Diese Einstellung ist default
Netzwerkserver | Diese Einstellung ist zu verwenden, wenn der Rechner über eine ausreichende Festplattengeschwindigkeit und RAM-Speicher verfügt, um als Drucker oder Dateiserver in einem Peer-2-Peer-Netzwerk zu dienen. Dem Cache wird eine höhere Priorität bei der Vergabe des verfügbaren Hauptspeichers zugeordnet als Speicher für Anwendungen zur Verfügung gestellt wird. Ab 64 MB Ram darf man diese Einstellung auch verwenden, wenn der Computer eher so verwendet wird, wie es unter der Einstellung PC definiert ist. Mit weniger Speicher bei intensiver Benutzung (Multitasking von Anwendungen) führt diese Einstellung zu einer stärkeren Benutzung der Auslagerungsdatei. Das bedeutet jedoch häufiger Zugriff auf die Festplatte, was die Performance des Computers senkt.
Docking-Station | Computer mit wenig Arbeitsspeicher, die auf Batterie laufen, sollen diese Einstellung verwenden. Hiermit wird der Cache häufig geleert, so dass mehr RAM-Speicher für die Anwendung erhalten bleibt. Dies führt jedoch dazu, dass die Auslagerungsdatei weniger häufig benutzt werden muss und somit ein längerer Betrieb bei Batterienutzung möglich ist (Festplattenzugriffe belasten die Batterie besonders stark). Zwangsläufig laufen mit dieser Einstellung häufige Dateizugriffe langsamer als mit den anderen beiden Einstellungen. Diese Einstellung kann also empfohlen werden, wenn der Rechner wenig Speicher hat und /oder auf Batterie läuft.

Das Einstellen dieser Nutzungsprofile verändert folgende Registry-Einträge:

PathCache | gibt die Größe des Caches an, in dem die zuletzt angeforderten Pfadnamen gespeichert werden. Dieser Cache erhöht die Geschwindigkeit, da das Dateisystem nicht jedesmal beim Zugriff auf einen bereits benutzten Pfad die FAT durchsuchen muss. Die Anzahl der gespeicherten Pfade ist 32 bei "PC", 16 bei "Docking-System" und 64 bei "Netzwerkserver".
NameCache | gibt die Größe des Caches an, in dem die zuletzt angeforderten Dateinamen gespeichert werden. Die Kombination von Pfad- und NameCache bedeutet, dass VFAT niemals auf den Datenträger zugreifen muss, wenn der Speicherort einer im Cache vorhandenen Datei ermittelt wird. Die Anzahl der gespeicherten Dateinamen ist 677 (8 KB) bei "PC", 337 (4 KB) bei "Docking-System" und 2729 (16 KB) bei "Netzwerkserver".
BufferIdleTimeOut BufferAgeTimeOut VolumeIdleTimeOut | bestimmen die zeitlichen Abstände zwischen Platzieren im Puffer und Schreiben auf Datenträger.

Folgende Änderungen in der Registry helfen auch weiter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Die Werte, die jedem Nutzungsprofil zugeordnet werden, sind im folgenden Registrierschlüssel gespeichert:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ FS Templates

Das aktuelle Nutzungsprofil ist im folgenden Registrierschlüssel gespeichert:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Filesystem

Info Siehe auch "Wie kann ich die Geschwindigkeit meines System verbessern?"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0114.htm


Windows überschreibt Felder von Disketten-Bootsektoren

Autor: Matthias Paul

Homepage: http://www.uni-bonn.de/~uzs180/mpdokeng.html

Die Einstellungen im folgenden Tipp verhindern, dass Windows bei einem reinen Lesezugriff eine ID auf die Diskette schreibt. Bei speziellen Disketten kann es passieren, dass die darauf gespeicherten Programme nicht mehr starten, wenn eine bestimmte Kennung auf der Diskette überschrieben wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem\ NoVolTrack

Wenn Sie z.B. folgende Werte als Datentyp REG_BINARY Eintragen

Wert | Inhalt | (Klartext)
boeder disk | 03,00,20,52,50,53,20,35,2E,30 | <bl>RPS 5.0
DAK acct disk | 03,00,50,56,42,41,43,4B,55,50 | PVBACKUP
DR DOS 3 disk | 03,00,44,49,47,49,54,41,4C,20 | DIGITAL<bl>
DR-DOS 6.0 | 03,00,49,42,4D,20,20,33,2E,33 | IBM 3.3
DR-DOS 7.02 disk | 03,00,44,52,44,4F,53,20,20,37 | DRDOS 7
DR-DOS 7.02 FAT32 disk | 03,00,44,52,44,4F,53,37,2E,58 | DRDOS 7.X
DR-OpenDOS 7.02 disk | 03,00,44,52,44,4F,53,37,30,32 | DRDOS 702
FreeDOS disk | 03,00,46,52,45,45,44,4F,53,20 | FREEDOS <bl>
IBM flash disk | 03,00,49,42,4D,20,35,20,33,66 | IBM 5 3f
IBM thinkpad disk | 03,00,49,42,4D,20,35,20,33,79 | IBM 5 3y
MS-DOS 2.0 disk | 03,00,4D,53,44,4F,53,32,2E,30 | MSDOS 2.0
MS-DOS 3.1 disk | 03,00,4D,53,44,4F,53,33,2E,31 | MSDOS 3.1
MS-DOS 3.3 disk | 03,00,4D,53,44,4F,53,33,2E,33 | MSDOS 3.3
MS-DOS 4.0 disk | 03,00,4D,53,44,4F,53,34,2E,30 | MSDOS 4.0
MS-DOS 5.0 disk | 03,00,4D,53,44,4F,53,35,2E,30 | MSDOS 5.0
MS-DOS 7.0 disk | 03,00,4D,53,57,49,4E,34,2E,30 | MSWIN4.0
MS-DOS 7.1 disk | 03,00,4D,53,57,49,4E,34,2E,31 | MSWIN4.1
Novell DOS 7 disk | 03,00,4E,57,44,4F,53,37,2E,30 | NWDOS 7.0
OpenDOS 7.01 disk | 03,00,4F,50,45,4E,44,4F,53,37 | OPENDOS 7
PC DOS 3.1 disk | 03,00,49,42,4D,20,20,33,2E,31 | IBM 3.1
PC DOS 3.2 disk | 03,00,49,42,4D,20,20,33,2E,32 | IBM 3.2
PC DOS 3.3 disk | 03,00,49,42,4D,20,20,33,2E,33 | IBM 3.3
PC DOS 5.0 disk | 03,00,49,42,4D,20,20,35,2E,30 | IBM 5.0
PC DOS 6.1 disk | 03,00,49,42,4D,20,20,36,2E,30 | IBM 6.0
PC DOS 7 disk | 03,00,49,42,4D,20,20,37,2E,30 | IBM 7.0
PTS-DOS 7.0 disk | 03,00,50,54,53,44,4F,53,37,30 | PTSDOS 70
ROMPAQ diag disk | 03,00,4D,53,44,4F,53,35,33,7A | MSDOS 53z
ROMPAQ flash disk | 03,00,4D,53,44,4F,53,35,33,79 | MSDOS 53y
RxDOS 6.0 disk | 03,00,52,78,44,4F,53,36,2E,30 | RxDOS 6.0
RxDOS 7.2 disk | 03,00,52,78,44,4F,53,37,2E,32 | RxDOS 7.2
STAC disk | 1F,00,CD,13,CD,14,CD,01,CD,03 |
Windows 95 | 03,00,4D,53,57,49,4E,34,2E,30 | MSWIN4.0
Windows 9x | 03,00,4D,53,57,49,4E,34,2E,31 | MSWIN4.1

dann unterlässt Windows diese Eigenmächtigkeit für Disketten, die unter anderen Betriebssystemen oder von bestimmten Herstellern formatiert wurden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
Windows 95/98 Overwrites Boot-Sector Field on Floppy Disks (Q148637) http://support.microsoft.com/?kbid=148637und

Understanding Disk Volume Tracking in Windows 95 (Q150582) http://support.microsoft.com/?kbid=150582

Info Sie können auch die REG-Datei von Matthias Paul unter http://www.drDOS .org herunterladen (Download: NOVOLTRK.ZIP)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1242.htm


Autostartfunktion für unterschiedliche Laufwerkstypen einstellen

Autostartfunktion einstellen für unterschiedliche Laufwerkstypen

Standardmäßig funktioniert der Autostart nur bei CDs/DVDs. Man kann aber bei Bedarf in der Registry die Autostartfunktion auch für andere Laufwerke einstellen.

Nicht so schön ist es, dass die Autostartfunktion auch für USB-Geräte durchgeführt wird. Hier durchsucht dann der Wizard erst einmal das Laufwerk, was meist mehr stört als hilft. Anschließend wird dann auch noch ein Dialog mit empfohlenen Aktionen angezeigt. Wenn Sie die Autostartfunktion ausschalten, kommt das nicht mehr.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

bzw.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

beim Eintrag "NoDriveTypeAutoRun" als Datentyp REG_DWORD im ersten Byte einstellen, für welche Geräte die Autostartfunktion gelten soll.

Die Laufwerke sind bitweise codiert:

Bit | Wert | Bedeutung | Einstellung (Standard)
7 | 128 | reserviert und immer gesetzt | 1
6 | 64 | Autostart für RAM-DISK | 0
5 | 32 | Autostart für CD-ROM | 0
4 | 16 | Autostart für Netzwerklaufwerke | 1
3 | 8 | Autostart für feste Datenträger (Festplatte) | 0
2 | 4 | Autostart für wechselbare Datenträger (z.B. Diskettenlaufwerk) | 1
1 | 2 | Laufwerk ohne Root | 0
0 | 1 | Autostart für unbekannte Laufwerkstypen | 1
Hex-Wert: Standard |  |  | 95

Die entsprechenden Bits dieses Bytes aktivieren oder deaktivieren die Autostartfunktion des jeweiligen Laufwerktyps.

Ein Wert von 0 in dem jeweiligen Bit bedeutet, dass die Autostartfunktion aktiviert ist,

eine 1 dagegen schaltet die Funktion aus.

Der Standardwert ist Hex 95 (10010101).

Sie können sich selbst eine gewünschte Konfiguration berechnen. Dazu müssen Sie einfach nur die Zahlen aus der Spalte "WERT" addieren, wo Sie die Autostartfunktion ausschalten wollen. Anschließend tragen Sie den Wert als Dezimalwert ein (also 128+16+4+1 = 149).

Eine weitere Möglichkeit zur Berechnung:

Tragen Sie dafür - wie oben rechts in der Tabelle gezeigt - jeweils in jede Zeile entweder eine 1 (deaktiv) oder eine 0 (aktiv) ein (der erste Wert (Bit 7) ist immer 1). Anschließend öffnen Sie den Taschenrechner (CALC.EXE) in der Wissenschaftlichen-Ansicht und errechnen aus dem Binärwert den HEX-Wert (z.B.: 10010101 = 95).

Hier noch ein paar fertige Werte:

Binär | Hex | Beschreibung
10010101 | 95 | Standard Wert (Autostart für: Festplatten, CD und RAM-Disk)
11111101 | FD | Autostart ist für alle Laufwerke deaktiviert
10011101 | 9D | Auch kein Autostart für Festplatten und USB-Geräte

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Autoplay deaktivieren

Info USB-Festplatten werden nicht als Wechseldatenträger, sondern als Festplatte von Windows erkannt. USB-Sticks dagegen als Wechseldatenträger. Das liegt an der Formatierung, da USB-Sticks meist als Floppy formatiert werden, hingegen Festplatten als Harddisk.

Info Siehe auch Tipp: "Autostart des CD-ROM ein/aus" und "Autostartfunktion nur für bestimmte Laufwerksbuchstaben ausschalten"

Info Diese Einstellung verhindert nicht das Autoplay für Musik-CDs.

Info Sollte die Autostartfunktion trotz Aktivierung nicht gehen, müssen Sie den Eintrag "AllocateCDROMs" überprüfen. Siehe dazu Tipp: "Disketten und CD-ROM Zugriff auf aktuellen Anwender beschränken"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0055.htm


Festplatten Laufwerkssymbol ändern

Das normale Festplatten-Laufwerkssymbol kann auf folgende Weise geändert werden:

Erstellen Sie im Root-Verzeichnis der Festplatte eine AUTORUN.INF und geben dort den Dateinamen des gewünschten Icons ein.

Beispiel:

[autorun]

ICON=WIN95CD.ICO

Sie können dort auch eine Icon-Datei angeben, die sich in einem anderen Verzeichnis befindet, hierfür müssen Sie nur den Pfad mit angeben (z.B. ICON=C:\Icon\win95cd.ICO).

Starten Sie Windows neu, um die Änderung zu aktivieren.

Info Siehe auch "Autostart von Programmen und Laufwerk-Icons für Festplatten und CD-ROMs" für genauere Informationen zur "AUTORUN.INF"

Info Siehe auch "Laufwerkssymbol ändern"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0142.htm


Zugriff auf ZIP-Laufwerke beschleunigen

Beim Zugriff auf das Zip-Laufwerk werden die Daten teilweise recht langsam übertragen. Dieser Fehler tritt durch einen Eintrag in der Registry auf, der bewirkt, dass zu viele Rückmeldungen vom ZIP-Laufwerk erfolgen. Um den Zugriff zu beschleunigen, müssen Sie nur den Polling-Wert verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ SCSIAdapters\ 0000

Bei "Driver=*ISAPPA3" setzen Sie den Wert "Polling=0"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0547.htm


Fehlerhafte Partition ignorieren

Drive Image (von Powerquest) ist sehr genau, wenn es um die Spezifikationen der Partitionstabelle geht und zeigt gelegentlich nach Veränderungen durch den Bruder Partition Magic FEHLERHAFTE PARTITION für das Laufwerk an. Dieses steht dann weder zur Sicherung noch zum Zurückschreiben zur Verfügung und hat eine braunrote Farbe.

Oft sind die Partitionen aber nicht defekt. Startet man Drive Image mit dem Parameter /IPE (Ignore Partition Errors), kann man nun doch auf das Laufwerk zugreifen und ohne Störungen Image-Dateien erstellen oder zurückschreiben.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1082.htm


Rund um das ZIP-Laufwerk

  • Das Guest95.ZIP Programm kollidiert u.U. mit einer NE2000 Netzwerkkarte, was einen Systemabsturz beim Hochfahren verursachen kann. Daher sollten Sie die Netzwerkkarte vorläufig im Gerätemanager deaktivieren.
  • Die Einstellungen des Parallelport ZipDrives können wie folgt geändert werden, sollte der "Beschleuniger" die Schnittstelle nicht optimal einstellen:

    Unter Eigenschaften vom ZIP Drive Interface in dem Gerätemanager trägt man bei Einstellungen folgendes ein:
    /mode:x /port:Adresse /speed:y

    für Mode x gelten:
    nible (sehr langsam, geht bei allen Ports)
    bidir (Bidirektional)
    fast (automatische Erkennung der schnellsten Betriebsart)
    epp (EPP Modus)
    eppecr (EPP/ECp)
    smceppecpsmc (SMP-Chipsatz)
    smcepp (SNO-Chipsatz)

  • Sofern es sich nicht um einen "Uralt-Rechner" handelt, sollte man ruhig EPP oder EPP/ECP wählen. In der Regel wählt der Port-Beschleuniger aber den richtigen Modus. (ECP im BIOS aktivieren)
    • Für Port gilt die Adresse aus dem BIOS (378 in der Regel)
    • Für Speed gelten Zahlenwerte von 1-6, wobei 6 am schnellsten ist.
  • Keine DOS Treiber für das ZIP im Windows 95 laden (Autoexec.bat), da sonst die Funktionen im Kontextmenü verloren gehen .

Stört das Auswerfen des Mediums beim Herunterfahren, kann man in der Registry unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Iomega Corporation\ Software\ Extrensions\ ZIP

finden Sie den Eintrag SchutdownEject und setzen den Wert von 1 auf 0

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0875.htm


Autostartfunktion nur für bestimmte Laufwerksbuchstaben ausschalten

Mit diesen Eintrag kann man die Autostartfunktion für bestimmte Laufwerksbuchstaben ausschalten. Wird durch die "Media Change Notification" (MCN) erkannt, dass ein Medium gewechselt (oder neu angeschlossen) wurde, so wird bei aktiver Autostartfunktion (NoDriveAutorun) auf das Medium zugegriffen. Ist eine AUTORUN.INF vorhanden, wird diese Datei ausgeführt oder andere verschiedene Mendientypen werden automatisch gestartet bzw. abgespielt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie den Eintrag "NoDriveAutorun" als Datentyp REG_DWORD, und geben Sie als Bitliste an, welche Laufwerke ausgeblendet werden sollen.

Über eine einfache Bitliste können Sie den erforderlichen Wert leicht ausrechnen:

b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1 | b8 | b7 | b6 | b5 | b4 | b3 | b2 | b1
z | y | x | w | v | u | t | s | r | q | p | o | n | m | l | k | j | i | h | g | f | e | d | c | b | a

Schreiben Sie jetzt einfach unter jeden Buchstaben eine "1" für Ausblenden bzw. eine "0" für sichtbar.

Diese Zahlenreihe rechnen Sie nun mit dem Windows Taschenrechner (Eingabe im Binärmodus) in einen Hexadezimalwert um, den Sie dann in die Registry Eintragen können.

Info Siehe auch Tipp: "Autostart des CD-ROM ein/aus" und "Autostartfunktion für unterschiedliche Laufwerkstypen einstellen"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2033.htm


Eigene Disktools einbinden (Backup, Defrag, Checkdisk und Cleanup)

Wenn Sie statt des integrierten Backups, Cleanup, Defrag oder CheckDisk Programm von Windows ein anderes, eigenes Programm benutzen wollen, können Sie es in der Registry Eintragen. So mit wird von Windows automatisch immer das Programm und nicht mehr das Windows eigene ausgeführt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Backup Programm

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ mycomputer\ BackupPath

Cleanup Programm

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ mycomputer\ CleanupPath

Defrag Programm

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ mycomputer\ DefragPath

CheckDisk Programm

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ mycomputer\ ChkDskPath

tragen Sie nun Ihr entsprechendes Programm im Wert "(Default)" manuell ein.

Die Standardwerte lauten:

Backup Programm
9x und ME | C:\Windows\Backup.exe
Alle anderen Betriebssysteme | %SystemRoot%\system32\ntbackup.exe
Cleanup Programm
9x und ME | C:\Windows\CleanMgr.exe
Alle anderen Betriebssysteme | %SystemRoot%\system32\cleanmgr.exe /D %c
Defrag Programm
9x und ME | C:\Windows\Defrag.exe
Alle anderen Betriebssysteme | %SystemRoot%\system32\dfrg.msc %c:
CheckDisk Programm
9x und ME | C:\Windows\chkdsk.exe
Alle anderen Betriebssysteme | %SystemRoot%\system32\chkdsk.exe %c:

Wenn Sie jetzt mit der rechten Maustaste ein Laufwerk anklicken und ->"Eigenschaften" -> "Extras" -> die Einträge auswählen, wird das von Ihnen eingetragene Programm gestartet.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0107.htm


CD-ROM Optimierung angeben

Hiermit legen Sie die Geschwindigkeit des CD-Rom Laufwerkes fest. Bei den heutigen CD-Rom Laufwerken können Sie diesen Wert auf den höchsten Wert einstellen.

"Systemsteuerung" -> "System" -> "Leistungsmerkmale" -> "Dateisystem" -> "CD-ROM"

Hauptspeicher | Optimale Einstellung | Cachegröße
8 MB | Einfach | 64 KB
8 MB - 12 MB | Zweifach | 626 KB
12 MB und mehr | Vierfach | 1238 KB

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0056.htm


CD-ROM Erkennung funktioniert nicht!

Wenn nach dem Löschen von Gerätetreibern in der Systemsteuerung die CD-ROM-Laufwerkserkennung nicht mehr funktioniert, löschen Sie den Eintrag NoIDE komplett aus der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ IOS

"StaticVxD"="*IOS"

"Start"=hex:00

"NoIDE"="1" <---- Diesen Eintrag löschen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0066.htm


Audio-CD Daten: Wo werden sie abgelegt?

Audio-CD-Daten werden im Windows-Verzeichnis in der Datei "CDPLAYER.INI" abgelegt. Will man hier die Daten schneller eintragen, kann man erst mehrere CDs erkennen lassen und jeweils nur den CD-Titel angeben, um anschließend mit einem Editor die Titel nachzutragen.

Beim neuen CD-Player (CD Deluxe Version 5.0) werden die Informationen in der Datei "DeluxeCD.mdb" abgelegt

Woran erkennt Windows die CD?

Windows errechnet anhand der TOC (table of contents), in der die Dauer der Titel verzeichnet ist, eine Prüfsumme. Diese Prüfsumme steht als Abschnittsname über der Titel- und Wiedergabeliste (Wiedergabereihenfolge) in der INI-Datei.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0031.htm


Autostart des CD/DVD Laufwerkes ab und zu aus

In diesem Tipp wird beschrieben, wie Sie die Autostartfunktion der Laufwerke kurzzeitig ausschalten können.

Wenn Sie die Autostart-Funktion für eine CD/DVD nicht möchten, halten Sie beim Einlegen der CD/DVD (beim Zugriff auf die CD/DVD) die Shift-Taste gedrückt (ca 10-30 sec.) Dieses gilt auch für andere Datenträger (DVD, externe Festplatten usw. die eine entsprechende Autostartdatei besitzen).

Siehe dazu auch Tipp: "Autostart des CD/DVD-Laufwerkes konfigurieren"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0052.htm


Autostart des CD/DVD-Laufwerkes konfigurieren

In diesem Tipp wird beschrieben, wie Sie die Autostart-Funktion des CD/DVD-Laufwerkes konfigurieren können.

Bis Windows 9x/ME finden Sie diese Einstellung noch in Gerätemanager unter: "Systemsteuerung" -> "System" -> "Gerätemanager" -> Doppelklick auf "CD-ROM" -> Doppelklick auf Ihr CD-ROM -> "Einstellungen" und hier "Automatische Benachrichtigung beim Wechsel" aktivieren/deaktivieren.

Hierdurch wird generell die Benachrichtigung beim Wechseln einer CD abgeschaltet, was allerdings auch dazu führt, dass kein Autostart mehr durchgeführt wird. Dadurch kann es aber je nach Treiber vorkommen, dass Windows nicht mehr erkennt, dass eine neue CD eingelegt wurde und immer noch den Inhalt der alten CD anzeigt.

Wollen Sie nur das automatische Starten von CDs verhindern, welche eine AUTORUN.INF besitzen, müssen Sie die Änderungen an der Registry durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Abspielen von Audio-Datenträgern verhindern

HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ AudioCD\ shell

finden Sie den Eintrag "(Standard)" als Datentyp REG_SZ. Wenn Sie hier den Eintrag leer lassen bzw. den vorhanden Eintrag löschen, werden Audio CDs nicht mehr automatisch abgespielt. Wenn Sie die Funktion wieder aktivieren wollen, müssen Sie hier wieder "play" Eintragen.

Ausführen von "AUTORUN.INF" verhindern

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ cdrom

Tragen Sie dort einen neuen Wert mit dem Namen "Autorun" als Datentyp REG_DWORD ein und weisen Sie ihm den Wert "0" zu. Nach einem Neustart werden CDs nicht mehr automatisch gestartet.

Dieser Eintrag schaltet die Funktion für alle Laufwerke ab. Dadurch wird auch ein Datenträgerwechsel nicht immer mehr automatisch erkannt (abhängig vom Betriebssystem). Bei Windows 2000 kann man das Neueinlesen mit F5 im Explorer starten, leider geht das bei Windows XP nicht mehr, so das man das Autostart hier lieber über die andere Werte ausstellen (siehe Links unten).

Wenn diese Einstellungen nichts bringen, sollten Sie prüfen, ob folgender Key gesetzt ist:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

hier finden Sie den Wert "CDRAutoRun" als Datentyp REG_DWORD, den Sie entweder auf 1 zum Aktivieren bzw. auf 0 zum Deaktivieren setzen können.

Info Siehe auch Tipp: "Autostartfunktion für unterschiedliche Laufwerkstypen einstellen" und "Autostartfunktion nur für bestimmte Laufwerksbuchstaben ausschalten"

Info Sollte die Autostartfunktion trotz Aktivierung nicht gehen, müssen Sie den Eintrag "AllocateCDROMs" überprüfen. Siehe dazu Tipp: "Disketten und CD-ROM Zugriff auf aktuellen Anwender beschränken"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0053.htm


Audio CD/DVD Laufwerke richtig zuordnen

Viele Leute haben heutzutage mehr als ein CD/DVD Laufwerk in ihre Rechner eingebaut (CD-ROM, DVD, Brenner usw.). Windows kann aber nur ein Laufwerk für das Abspielen von Audio-CD verwalten. Es erkennt also nicht automatisch, in welchem Laufwerk die Audio-CD eingelegt ist und überprüft nur ein Laufwerk.

Welches Laufwerk von Windows überprüft werden soll, können Sie folgendermaßen einstellen:

"Systemsteuerung" -> "Multimedia" -> "CD-Musik"

Wählen Sie hier unter "Standard CD-ROM Laufwerk für Musikwiedergabe" das Laufwerk aus, welches Sie zum Abspielen von Audio-CDs verwenden wollen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0032.htm


Systemübersicht ausdrucken

Normalerweise kann man die Systemübersicht des Gerätemanagers nicht in eine lesbare Datei ausgeben. Mit einem kleinen Trick ist es aber möglich.

  • Installieren Sie den "Universal/Nur Text" Druckertreiber unter:
    -> "Arbeitsplatz" -> "Drucker" -> "Neuer Drucker" -> "Weiter" -> "Lokaler Drucker" -> "Weiter". Nun unter Allgemeines den Drucker "Universal/nur Text" markieren -> "Weiter", bei Anschlüsse wählen Sie "File" -> "Weiter". Nun können Sie einen Namen eingeben und festlegen, ob es der Standard-Druckertreiber werden soll.
  • ->"Arbeitsplatz" -> "Systemsteuerung" -> "System" -> "Geräte-Manager" -> "Drucker". Wählen Sie die gewünschte Übersicht -> "Einrichten" -> wählen Sie "Spezieller Drucker" und dort " Universal/Nur Text an File:" aus -> "OK" -> "OK" -> geben Sie einen Dateinamen an -> "OK"

Nun können Sie sich diese Datei mit einem Texteditor anschauen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0325.htm


DOS-Fenster ausdrucken

Den Bildschirminhalt in einem DOS-Fenster kann man auch durch Betätigen der Tasten "Umschaltung-Druck" direkt ausdrucken oder einfach mit der Taste "Druck", wenn unter "Eigenschaften" -> "Sonstiges" -> "Zugriffstasten von Windows", die Taste "Druck" deaktiviert ist.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0072.htm


Drucken ohne Vorspann

Wenn man auf einem Netzwerkdrucker druckt, schaltet Windows automatisch den Vorspann-Modus ein. Dadurch schickt Windows vor jedem Druckauftrag eine Seite mit dem Namen des Anwenders, der gerade druckt. Abschalten kann man das über: ->"Arbeitsplatz" -> "Drucker" -> <Entsprechenden Netzwerkdrucker auswählen> -> "Datei" -> "Eigenschaften" -> Register Einstellungen und deaktivieren Sie das Kontrollkästchen "Vorspann".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0100.htm


DOS-Programm soll Windows-Druckerspooler benutzen

Der Ausdruck von DOS-Programmen soll über den Windows-Druckerspooler laufen.

"Systemsteuerung" -> "Drucker" -> "Eigenschaften" -> "Details" -> "Anschlusseinstellung" -> "DOS -Druckauftrag Zwischenspeichern" ankreuzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0099.htm


Verzeichnisbaum im Explorer drucken

Normalerweise ist es nicht möglich, im Explorer den Verzeichnisbaum zu drucken. Sie können es dennoch tun und zwar auf folgende Weise:

Öffnen Sie einen Texteditor. Geben Sie "DIR >LPT1" ein, wenn ihr Drucker an LPT1 angeschlossen ist (wenn nicht, muss jetzt eine andere Schnittstelle angegeben werden)und speichern Sie die Datei als PRINTDIR.BAT im Windows\Command - Verzeichnis.

Öffnen Sie nun den Explorer und suchen Sie die Datei PRINTDIR.BAT, klicken Sie mit der rechten Maustaste darauf und dann auf "Eigenschaften". Wählen Sie "Ausführen als Symbol" und "Fenster beim Beenden schließen". Speichern Sie die Änderungen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Suchen Sie im linken Fenster den Eintrag:

HKEY_CLASSES_ROOT\ Directory\ shell.

Klicken Sie mit der rechten Maustaste darauf und anschließend im Kontextmenü auf -> "Neu" -> "Schlüssel". Nennen Sie den neuen Schlüssel "Print". Klicken Sie nun auf "Print" und wählen Sie noch einmal -> "Neu" -> "Schlüssel" Diesen Schlüssel nennen Sie "command". Doppelklicken Sie im rechten Fenster auf "Standard" und definieren Sie den Wert als C:\WINDOWS\COMMAND\PRINTDIR.BAT (sollte sich Ihr Windows in einem anderen Verzeichnis befinden, müssen Sie den Eintrag dementsprechend ändern). Wenn Sie nun im Explorer einen Ordner mit der rechten Maustaste anklicken, finden Sie im Kontextmenü den Befehl "Drucken".

Info Dieser Tipp funktioniert mit den heutigen neuen Druckern nicht mehr. Hier müssen Sie auf ein extra Programm zurückgreifen.

Info Ein gutes Tool "CWShex32" finden Sie zum kostenlosen Download unter "http://www.winterfeldt.com".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0333.htm


Drucker wird bei jedem Windows Start neu gefunden

Nach jedem Neustart findet Windows den Drucker erneut, obwohl schon Treiber installiert sind.

Hier ist ein Fehler in der Registry. Zur Abhilfe wie folgt vorgehen:

  1. Drucker entfernen (Menü Drucker - Entfernen)
  2. Neustart, neu installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Sollte dies nicht helfen, den Drucker erneut entfernen und in der Registry unter HKEY_LOCAL_MACHINE\Enum\LPTENUMdiesen Schlüssel löschen. Danach Windows neu starten und den Drucker nach der Aufforderung installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0793.htm


Druckereigenschaften können nicht aufgerufen werden

Bei einigen Installationen (insbesondere FAX-Druckertreiber) kann es vorkommen, dass die Druckereigenschaften nicht aufgerufen werden können und evtl. eine Fehlermeldung erscheint.

Ursache ist meist das Fehlen der generischen Registerkarte für die Standarddrucker von Windows 95/98. Installieren Sie einen weiteren Drucker Standard/Nur-Text. Danach sollte der FAX-Druckertreiber funktionieren und sich Auflösung etc. einstellen lassen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0921.htm


Ausdruck bricht ab

Bei manchen Rechnern kann es zu Problemen mit älteren Nadeldruckern kommen. Bei den betroffenen Rechnern bricht der Ausdruck nach einer Seite oder nach einer Zeile ab. Die Ursache hierfür liegt in der BIOS- Einstellung der Druckerschnittstelle. Ist hier ECP/EPP eingestellt, so kann es zu dem genannten Fehlverhalten kommen. In diesem Fall ist der Eintrag auf Standard (Bidirektional) zu ändern.

(Aufgetreten auf Toshiba Notebooks des Typs T2130 und 110 c't mit älteren EPSON Nadeldruckern / Tintenstrahldruckern)

Dieser Fehler tritt auch bei vielen neueren Druckern auf, wenn ECP im BIOS aktiviert ist und der Drucker den ECP-Modus nicht verwendet.

Fast alle Canon Modelle sind davon betroffen. Sie drucken dann meist nur 1/2 bis 3/4 Seite aus. Die Ursache dafür liegt in einem Bug in der LPT.vxd von Windows. Dieser Fehler ist in allen Versionen (außer vielleicht der Windows 95C OSR 2.5) und auch in der LPT.vxd im Driver-Verzeichnis der CD vorhanden.

Es gibt zwei Lösungen:

  • Im BIOS -Setup den ECP abschalten.
    Alle anderen Modi (EPP, BiDi, Standard) machen keine Probleme.
  • Eine fehlerbereinigte LPT.vxd installieren.
    Canon hat diese (original MS!) Datei schon länger bei ihren Druckertreibern dabei. Bei den ersten Versionen liegt sie aber auf einer Disk und wird nicht automatisch installiert.
    Das Traurige ist, dass die fehlerfreie LPT.vxd noch vor dem Windows 95B OSR 2.1 herauskam und dennoch nicht auf denWindows 95B OSR 2.1 und 2.5 CDs installiert wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0036.htm


Kein Banner auf Netware Printer

In diesem Tipp wird beschrieben, wie Sie das Drucken eines Banners auf einem Netware Printer ausschalten können.

Leiten Sie in der Netzwerkumgebung den Pfad (z.B. YXZ_1) auf LPT1 um, und verbinden Sie dann den Drucker ebenfalls mit LPT1 (NICHT mit Server_1 verbinden!).

Nun wird kein Banner mehr ausgedruckt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0156.htm


Testen aller eingerichteten Drucker mit einem Aufruf

Mit den unten aufgeführten Aufruf kann ein Druckertest aller installierter Drucker, Fax-Geräte usw. gestartet werden, ohne Umwege über die "Systemsteuerung" -> "Drucker".

Erstellen Sie eine Datei mit folgenden Aufruf:

Windows 9x/ME:

%WINDIR%\system\Rundll32.EXE msprint2.dll,RunDLL_PrintTestPage

Ab Windows NT:

%WINDIR%\system\Rundll32.EXE msprint2.dll,RunDLL_PrintTestPage

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0332.htm


Grafikausdruck beschleunigen

Normalerweise erkennt der Treiber automatisch, ob die Grafik als Raster oder Vektor gesendet wird und benutzt dann jeweils die richtige Einstellung zum Ausdruck. Leider passiert es aber auch oft, dass der Treiber es nicht richtig erkennt (gerade beim Ausdruck aus CorelDraw) und dann die falsche Einstellung benutzt, was die Druckzeit erheblich verlängert.

In so einem Fall stellen Sie doch testweise einfach einmal unter Drucker -> Druckereigenschaften die Einstellung für Grafik-Modus von Auto auf "Raster" um.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0347.htm


HP Drucker Einstellungen

Für Drucker ab HP-Serie "HP Deskjet 600", legt das Installationsprogramm eine ausführbare Datei namens "HPFCFG2.EXE" in das Windows-Systemverzeichnis ab.

Mit Hilfe dieses Programms können verschiedene erweiterte Funktionen eingestellt werden.

  • DOS -Spooling
  • schraffierte Flächen skalieren
  • Druckfläche verändern
  • Word 2.0 - Briefumschläge
  • Druckpatrone überprüfen
  • bidirektionale Kommunikation
  • Sub-Sampling
  • True-Type-Schriften laden
  • True-Type-Schriften als Grafiken drucken
  • Rechtecke
  • Windows Drucktechnologie

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0155.htm


Epson Stylus Color 600 bricht Ausruck ab oder druckt kleine Striche zwischendurch

Dieser Fehler tritt auf, wenn Sie zu Ihrem Drucker einen Scanner parallel angeschlossen haben. Als Fehlerbehebung gibt Epson nur diese zwei Möglichkeiten bekannt:

  1. Scanner Treiber deinstallieren (aber wer will das schon, wenn er einen Scanner hat?)
  2. Drucker oder Scanner an eine zweite parallel Schnittstelle anschließen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0585.htm


Drucker im Netzwerk benutzen

Einige Druckertreiber lassen sich nicht als "Normale" Netzwerkdrucker einrichten. Bei solchen Geräten muss der Drucker zunächst auf dem Host-Rechner (dort wo der Drucker angeschlossen ist) lokal installiert und im Netzwerk freigeben werden. Auf dem entfernten Rechner installiert man zunächst ebenfalls den Drucker lokal für LPT1 und fügt dann über Details einen neuen Druckeranschluss hinzu und verbindet diesen mit dem freigegebenen Drucker im Netz.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1134.htm


Drucker druckt zerstückelte Bilder

Wenn der Drucker gelegentlich zerstückelte Bilder druckt oder Texte fehlen, könnte der Rechner zu schnell sein.

Testweise sollte man daher unter "Drucker"-Details bei "nicht gewählt" 300 Sekunden und bei "Übertragungswiederholung" 900 Sekunden Eintragen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0874.htm


Druckertreiber von einem bestimmten Server installieren

Wenn Sie sich über das Netzwerk mit einem freigegebenen Drucker verbinden, werden die benötigten Druckertreiber automatisch installiert. Die Druckertreiber werden in diesen Fall von der aktuellen Maschine geholt, auf dem der Drucker freigegeben wurde.

Das hat den großen Nachteil, dass man keinen Überblick über die installierten Treiberversionen im Netzwerk mehr hat. Durch einen Eintrag in der Registry können Sie bestimmen, dass die Treiber nur noch von einem bestimmten Server installiert werden. So haben Sie es auch leichter, wenn einmal ein Update für die Treiber erfolgen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Printer\ Providers\ LanMan Print Services\

Erstellen Sie hier einen neuen Wert mit dem Namen "LoadTrustedDrivers" als Datentyp REG_SZ. Setzen Sie den Wert auf 1.

Des Weiteren müssen Sie noch einen Wert mit dem Namen "TrustedDriverPath" als Datentyp REG_SZ anlegen und hier den vollständigen Pfadnamen zu der Freigabe für die Druckertreiber eintragen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0826.htm


Drucken von PRN-Dateien

Mann kann unter Windows einen Drucker installieren, obwohl dieser gar nicht angeschlossen ist. Als Anschluss wählt man allerdings "File".

Windows druckt dann die Druckaufträge in eine Datei mit der Endung ".prn". Diese PRN-Dateien lassen sich auf dem echten Drucker dieses Typs später ausgeben (z.B. wenn ein Bekannter nur den guten Fotodrucker hat). Man hat damit den Vorteil, dass die Applikation, mit welcher der Druckjob gestartet wurde, nicht benötigt wird.

Die Ausgabe der PRN-Datei erfolgt auf dem Rechner mit dem Drucker über die Kommandozeile mit folgendem Befehl:

copy /b dateiname.prn lpt1

Wichtig ist der Parameter /b, da es sich dann um Binärdaten handelt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1125.htm


Brother HL 600 gibt eine unlesbare Seite aus

Kopieren Sie von der Windows 95 CD aus dem Verzeichnis \DRIVERS\PRINTERS\LPT die Datei LPT.VXD über die defekte Datei im Verzeichnis \WINDOWS\SYSTEM.

Nun dürfte der Fehler behoben sein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0071.htm


Freigabe von neuen Druckern unterbinden

Mit dieser Policy wird die Funktion Drucker-"Freigabe" gesperrt. Es ist dann nicht mehr mögliche, neue Drucker freizugeben. Bereits freigegebene Drucker sind davon nicht betroffen und bleiben weiterhin aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrintSharingControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1492.htm


Druckerfreigaben sperren

Mit dieser Policy können Sie alle Druckerfreigaben sperren. Damit ist es nicht mehr möglich, neue Druckerfreigaben zu erstellen und bereits erstellte Druckerfreigaben werden deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrintSharing" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Deaktiviert die Freigaben
0 | Freigabe sind möglich (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1494.htm


Den Eintrag 'Allgemein' und 'Details' aus dem Druckermenü entfernen

Mit diesem Wert können Sie festlegen, ob das Menü "Allgemein" und "Details" im Druckermenü sichtbar ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrinterTabs" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Allgemein" und "Details" ausblenden
0 | "Allgemein" und "Details" anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1557.htm


Drucker nicht im Netzwerk freigeben

Mit diesem Wert können Sie festlegen, dass keine Drucker mehr ins Netzwerk freigegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrintSharing" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es werden keine Drucker ins Netz freigegeben
0 | Drucker werden ins Netz freigegeben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1559.htm


Funktion 'Datei und Druckerfreigabe' entfernen

Mit diesem Wert können Sie festlegen, dass keine "Datei und Druckerfreigabe" mehr möglich ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileSharingControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine "Datei und Druckerfreigabe" mehr möglich
0 | "Datei und Druckerfreigabe" erlaubt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1556.htm


Funktion 'Druckerfreigabe' entfernen

Mit diesem Wert können Sie festlegen, ob das Menü Druckerfreigabe zu sehen ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrintSharingControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es können keine Drucker mehr freigegeben werden
0 | Drucker können freigegeben werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1558.htm


Funktion 'Drucker entfernen' entfernen

Mit diesem Wert können Sie festlegen, ob es möglich ist, einen Drucker aus dem System zu löschen.

Bei dem Versuch einen Drucker zu löschen, z. B. mit Option "Löschen" im Ordner "Drucker" in der Systemsteuerung, wird dem Benutzer eine Fehlermeldung angezeigt, die erläutert, dass dieser Vorgang durch eine Einstellung deaktiviert wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDeletePrinter" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Drucker können nicht gelöscht werden
gelöscht | Drucker können gelöscht werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Löschen von Druckern verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1554.htm


Funktion 'Drucker hinzufügen' entfernen

Mit diesem Wert können Sie festlegen, ob es möglich ist, neue Drucker zum System hinzuzufügen.

Durch Aktivieren dieser Einstellung wird die Option "Neuer Drucker" aus dem Startmenü entfernt (Klicken Sie auf Start, Einstellungen, Drucker und Neuer Drucker, um zu dieser Option zu gelangen.) Zusätzlich wird die Option "Neuer Drucker" aus dem Ordner "Drucker" in der Systemsteuerung entfernt.

Außerdem können Benutzer das Symbol "Drucker" nicht in den Druckerordner ziehen und einfügen. Bei dem Versuch diesen Vorgang auszuführen, wird eine Fehlermeldung angezeigt, die erläutert, dass dieser Vorgang durch eine Einstellung deaktiviert wurde.

Allerdings können Benutzer weiterhin Drucker mit dem Hardware-Assistenten hinzufügen. Ebenso können Benutzer weiterhin andere Programme zum Hinzufügen von Druckern ausführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddPrinter" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Drucker können nicht hinzugefügt werden
gelöscht | Drucker können hinzugefügt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Hinzufügen von Druckern verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1553.htm


Keine Drucker mehr im Netz freigeben

Mit diesem Wert können Sie festlegen, dass keine Drucker mehr im Netzwerk freigegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPrinterSharingControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Drucker werden nicht im Netzwerk freigegeben
0 | Drucker können im Netzwerk freigegeben werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1555.htm


Wie kann ich die Geschwindigkeit meines Systems verbessern?

Allgemein

Die beste Performance erhält man, wenn man komplett auf die erweiterten Eigenschaften von Windows aufsetzen kann. Dazu gehört z.B., dass eine Festplatte nicht den Kompatibilitätsmodus, sondern 32Bit-Zugriffe benutzt. Statt SMARTDRIVE oder anderer 16-Bit-Cache-Software sollte das dynamische Cache System von Windows verwendet werden.

Windows wird erheblich durch genügend Speicher (8 bzw. 16 MB reichen nicht aus) und einer schnellen Festplatte, CPU und einem modernem Bussystem beschleunigt. In den nachfolgenden Kapiteln wird erklärt wie man das System durch andere Maßnahmen als Aufrüstung der Hardware noch beschleunigen kann. Allerdings darf man nicht vergessen, dass sich eine Verbesserung der Hardware direkt auf die Performance des Systems auswirkt.

Dabei gilt bei begrenztem Budget folgende Reihenfolge:

  1. Motherboard
    Ein altes Motherboard mit ISA-BUS oder VL-BUS sollte gegen ein modernes Motherboard ausgetauscht werden. Die Gründe hierfür sind:
    - schnelleres, stabiles BUS-System (PCI), Aufrüstmöglichkeit CPU
    - mögliche Verwendung moderner Speicherbausteine (PS/2 SIMMs, DIMMs,...)
    - mögliche Verwendung moderner Peripheriegeräte, wie z.B. moderne Grafikkarten (VL und ISA stirbt weitgehend aus)
    Doch Vorsicht:
    Das Layout der Boards hat sich geändert, neben den alten Motherboards gibt es nun so genannte ATX-Boards. Diese können nicht in alte Gehäuse eingebaut werden.
  2. Speicheraufrüstung
    bis 128 MB, danach nur noch geringer Perfomancegewinn bei Normaler Benutzung. Anwender, die viel mit Grafik bzw. Multimedia Dateien arbeiten, profitieren auch noch von mehr Speicher.
  3. CPU-Aufrüstung
    Eine Pentium-CPU bringt erhebliche Beschleunigungen im Fließkommabereich, aber auch der Integerbereich wirkt sich teilweise auf die Bearbeitungsgeschwindigkeit von allgemeinen Anwendungen aus.
  4. Festplatte
    Beim Neukauf auf folgende Kriterien achten:
    - Datentransferrate, je höher desto besser
    - Zugriffszeit, je kürzer desto besser
    - Umdrehungsgeschwindigkeit (Faustformel je höher, desto bessere Datentransferraten werden erzielt).
  5. BUS-SYSTEM
    Bei massiver Benutzung, z.B. Multitaskingbetrieb, Serverbetrieb lohnt sich die Verwendung von SCSI statt des Standard-EIDE-Systems.

Info Beim Kauf der Komponenten, insbesondere bei Controller, Grafikkarte, Drucker, Soundkarte , Scanner und Streamer darauf achten, dass dem Gerät Windows Treiber beigelegt werden.

Profile für Disk Cache Optionen

Info Siehe hierzu "Disk Cache optimieren"

Mit einem weiteren Wert in der Registry können Sie das Verhalten der Auslagerungsdatei beeinflussen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die Werte, die jedem Nutzungsprofil zugeordnet werden, sind im folgenden Registrierschlüssel gespeichert:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ FS Templates

Das aktuelle Nutzungsprofil ist im Folgenden Registrierschlüssel gespeichert:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Filesystem

ContigFileAllocSize

...größter zusammenhängender Plattenplatz der gesucht wird, wenn Plattenplatz, z.B. für die Auslagerungsdatei, benötigt wird. Per default wird versucht unter den ersten 0,5 MB einen zusammenhängenden freien Speicherplatz zu finden. MSDOS versucht hingegen direkt am Plattenanfang freien Speicher zu finden und diese Methode führt oft zur starker Fragmentierung der Festplatte. Ein kleiner Wert kann zu häufigeren Zugriffen für die Auslagerungsdatei und höherer Fragmentierung der Festplatte führen.

Defragmentierung

Durch häufige Schreibzugriffe wird die Platte mehr und mehr fragmentiert. Im Klartext bedeutet diese Fragmentierung, dass der Zugriffsarm der Festplatte häufiger die Position wechseln muss, um eine Datei komplett von der Festplatte zu lesen. Die Zeit, die dabei verstreicht, bezeichnet man auch als Zugriffszeit und sie verzögert das Laden von Dateien. Zwangsläufig soll man von Zeit zu Zeit das Utility DEFRAG, welches mit Windows ausgeliefert wird, aufrufen.

Tuning CDROM-Zugriff

Der CDROM-Zugriff wird in Windows durch einen vom Dateizugriffscache unabhängigen Cache beschleunigt.

Eingestellt wird die Größe des Cache in

"START" -> "SYSTEMSTEUERUNG" -> "SYSTEM" -> "LEISTUNGSMERKMALE" -> "DATEISYSTEM" -> "CDROM"

Hauptspeicher | Optimale Einstellung | Cachegröße
8 MB | Einfach | 64 KB
8 MB - 12 MB | Zweifach | 626 KB
12 MB und mehr | Vierfach | 1238 KB

Dieser Cache hat keine dynamische Größe. Der Speicher für den Cache wird permanent vom Hauptspeicher abgezogen und steht nicht für andere Dinge zur Verfügung.

Tuning Druckausgabe

Unter "START" -> "EINSTELLUNGEN" -> "DRUCKER" kann über das Eigenschaftsmenü des jeweiligen Druckers (rechte Maustaste) und dann "DETAILS" -> "SPOOLEINSTELLUNG" der Ausdruck optimiert werden.

Damit nach Anstoß der Druckausgabe schneller zur Anwendung zurückgekehrt werden kann, wird der Druck erst nach der letzten Seite begonnen. Wenn es beim Ausdruck keine Probleme geben sollte, dann soll EMF-Format ausgewählt werden. Ebenso führt der bidirektionale Druck zu einer Beschleunigung der Druckausgabe.

Optimierung Hauptspeicher

Windows setzt wie auch Windows 3.x auf einen DOS-Kern auf und kennt daher die Speicherarten LOW-MEMORY (Speicher bis 640 KB), UMB und XMS-Speicher. Es gibt daher auch unter Windows das Problem, dass zu wenig Speicher zur Verfügung steht, obwohl mehrere MB Speicher eingebaut sind.

In Windows, wenn die GUI gestartet wird (das ist der Normalfall), gilt es bei Rechnern mit wenig Hauptspeicher (z.B. 8 MB) ein wenig mit dem Speicher zu haushalten. Praktisch sind 8 MB für Windows zu wenig, dennoch hier ein paar Tricks:

  • nur geringe Auflösung und Farbtiefe verwenden (also nicht gerade 1024x768x24bit)
  • keine Desktop-Hintergrundbilder laden
  • keine Erweiterungen wie z.B. "BMP-ICON als BMP darstellen" verwenden
  • möglichst auf residente Programme (z.B. DESKMENU, QUICKRES, SYSTEMDIENSTE) verzichten
  • per SYSTEM.INI den CACHE (siehe Performance TUNING CACHE) minimieren (z.B. MaxFileCache=2048).
  • Den CDROM-Cache (siehe Performance TUNING CDROM) auf einfach stellen
  • Das Profil DOCKING STATION unter SYSTEM\LEISTUNGSMERKMALE\ verwenden.
  • Auf Tonunterstützung bei Aktivitäten (z.B. Papierkorb leeren) verzichten.

Dadurch ist Windows vielleicht nicht so schön bunt und die Zugriffsgeschwindigkeit auf Dateien mag sinken, doch allgemein wird das System beschleunigt, da die Auslagerungsdatei weniger oft benötigt wird und die Anwendung(en) öfters komplett in den Speicher geladen werden können.

Tuning Dateizugriff

In Windows wird ein dynamischer Cache verwendet. Dieser Cache wirkt sich ausschließlich auf lokale Laufwerke aus, also nicht bei der Übertragung vom Netzwerklaufwerk noch beim Zugriff auf ein Diskettenlaufwerk. Die erste Optimierungsmaßnahme ist das Entfernen aller alten DOS -Beschleuniger wie z.B. smartdrive, kwick cache etc.

Diese Dateien findet man entweder in der CONFIG.SYS oder AUTOEXEC.BAT. Bei einer Update-Installation von Windows werden bekannte DOS - Beschleuniger durch Windows deaktiviert (REM vor dem eigentlichen Befehl).

Dynamischer Cache

Dieser Cache wird von Dateizugriffen oder der Seitenauslagerung durch Windows verwendet. Hingegen werden Aktivitäten auf die Auslagerungsdatei nicht gecacht. Die Strategie von Windows ist dabei, die Seitenauslagerungen ungenutzter Seiten (logische RAM-Einheiten) dann zu betreiben, wenn das System gerade nicht ausgelastet ist. Diese freigewordenen Seiten stehen dann wieder Anwendungen als physikalischer Speicher oder aber dem Cache für Dateizugriffe zur Verfügung.

Diese Seitenauslagerungen/einlagerungen werden jedoch durch REALMODE-Treiber stark eingeschränkt. Im Klartext heißt das, wenn eine Platte im Kompatibilitätsmodus arbeitet, kann weniger Speicher ausgelagert werden, als es normal der Fall wäre.

Kompatibilitätsmodus

Es gilt zu verhindern, dass Windows auf den Kompatibilitätsmodus beim Plattenzugriff angewiesen ist.

Dieser Modus wird aber immer dann verwendet, wenn ein Realmode-Treiber (16 Bit-DOS -Treiber) verwendet werden muss.

Die Dateien IOS.LOG und IOS.INI geben Auskunft über Realmodetreiber. Dieser Realmodetreiber (z.B. ein komprimiertes Stackerlaufwerk) sollte durch einen 32Bit-Protected-Mode-Treiber ersetzt werden.

Busmastering

Bei den meisten Systemen handelt es sich um EIDE-Systeme (Enhanced IDE). Der Durchsatz einer einzelnen Platte wird zwar kaum durch BUSMASTERING (siehe Gerätemanager in Systemsteuerung\System\Festplatten-Controller) beschleunigt, doch wirkt sich dies im allgemeinen beim Anwendungstest aus. Es sollte also das Busmastering bei EIDE-SYSTEMEN aktiviert sein. Für das Busmastering werden individuell zum Motherboard Treiber (in der Regel von INTEL) zur Verfügung gestellt.

Deaktivierung DYNAMIK

Aus Kompatibilitätsgründen ist die SYSTEM.INI in Windows noch vorhanden. Mit dem Paragraphen [VCACHE] lässt sich der Ramspeicher, der Minimal bzw. max. für den Cache verwendet werden soll, exakt begrenzen.

Info Genaueres dazu finden Sie unter "Cache Einstellungen"

Ramdisk benutzen (nicht ME)

In Windows kann man auch eine RAMDISK benutzen. Hierbei wird RAM-Speicher als DISK-Speicher verwendet. Programme oder Dateien, die in einer Ramdisk liegen, werden besonders schnell verarbeitet.

Der Einsatz einer Ramdisk macht aber nur dann Sinn, wenn man über genügend freien Haupstspeicher verfügt. Andernfalls hat das Betriebssystem zu wenig Hauptspeicher zur Verfügung und muss diesen Mangel durch Verwendung des virtuellen Speichers (Swap-Datei) ausgleichen.

Neben der statischen Ramdisk von Microsoft ( max. 8 MB, die Größe kann während des Betriebs nicht geändert werden) gibt es weitere von Dritthersteller:

VRAMDIR ist z.B. eine 32 Bit-Ramdisk, die dynamisch RAM-Speicher zuordnet. Es wird also immer soviel Speicher für die Ramdisk reserviert wie benötigt wird. Dabei ist VRAMDIR in der Lage, Zugriffe auf bestehende Verzeichnisse auf der Festplatte in den Hauptspeicher, z.B. das Temporär-Verzeichnis, umzuleiten.

Ebenfalls empfehlenswert ist XMSDSK/EMSDSK, welches unter http://www.simtel .NET/pub/pd/4825.html heruntergeladen werden kann. Diese Ramdisk kann ebenfalls während des laufenden Betriebs vergrößert bzw. verkleinert werden ( max. 32 MB).

Optimierung DOS -Speicher

Windows kennt zwei verschiedene Betriebsarten. MSDOS -Mode und GUI. Beide Betriebsarten setzen auf einen DOS KERN auf. Einige Funktionen in der GUI werden nach wie vor durch Interruptaufrufe statt über moderne 32-Bit-Architekturkomponenten aufgerufen.

Der DOS -COMMAND-Prompt für MS-DOS -Programme kann hingegen auf viele verschiedene Wege aufgerufen werden:

a) Beim Windows-Start durch das Bootmenü (siehe MSDOS .SYS)

1) Eingabeaufforderung

2) vorherige DOS -Version (Achtung, nicht Windows 950b = OSR2)

In beiden Fällen handelt es sich um ein vollwertiges MSDOS , welches zum Ansteuern von Peripheriegeräten, Realmodetreiber und Programme (z.B. beim CD-ROM MSCDEX.EXE) benötigt. Die 32-Bit-Treiber stehen nicht zur Verfügung. Es steht damit auch kein 32-Bit-Cache oder VFAT mit langen Dateinamen zur Verfügung. Die Beschleunigung erfolgt wie bisher durch Programme wie SMARTDRV oder FASTOPEN. Dieser Modus ist für all die Programme geeignet, die mit der DOS -Eingabeaufforderung von der GUI nicht klar kommen. Einige Programme schließt Windows sowieso aus von der GUI aus zu starten. Hierfür gibt es bei Windows eine Kompatibilitätsdatenbank (Lw:\WINDOWS\INF\APPS.INF). Bei diesen Programmen wird automatisch der MSDOS -Modus vorgeschlagen.

Auf der Windows 95-CD befindet sich ein Verzeichnis OLDDOS . In diesem Verzeichnis stehen unter anderem das Werkzeug MEMMAKER und alte DOS -Befehle zur Verfügung, um diesen Modus zu optimieren.

Info Wie bei einer Vollinstallation von Windows 95 eine vorherige DOS -Version aktiviert werden kann, findet man an anderer Stelle in dieser FAQ.

b) Von der GUI

1) DOS -Eingabeaufforderung als Fenstersitzung

2) DOS -Eingabeaufforderung als Vollbild

3) MSDOS -Modus

Bei den DOS -Eingabeaufforderungen stehen alle 32Bit-Treiber von Windows zur Verfügung. Das heißt nun, dass auch ein CDROM über ein 32Bit-Treiber angesteuert werden kann und auch den CDROM-Cache von Windows verwendet. Aus diesem Grund kann man auf weitere Treiber und Programme in der CONFIG.SYS und AUTOEXEC.BAT weitgehend verzichten.

Bei einer Updateinstallation werden nicht alle Treiber (z.B. CDROM-Treiber) automatisch deinstalliert. Hingegen werden weitere speicherfressende Programme (z.B. MODE-Befehle und KEYBOARD.SYS) installiert. Diese sind aber i.d.R. nicht nötig. Auch Treiber von Drittherstellern, wie z.B. Soundkarten-Treiber, sind nicht notwendig.

Selbst die Treiber HIMEM.SYS und EMM386.EXE sind nicht notwendig, da HIMEM.SYS bereits durch die IO.SYS geladen wird und EMS-Speicher durch einen 32Bit-Treiber simuliert wird. Die Maus wird ebenfalls durch einen 32Bit-Treiber simuliert. Nur die deutsche Tastatur muss über einen Tastaturtreiber für DOS -Programme aktiviert werden.

Anweisungen wie DOS =HIGH, FILES, BUFFERS oder STACKS sind ebenfalls überflüssig. Auch hier erfolgen, z.B. durch FILES=60, Defaultzuweisungen in der IO.SYS. Diese Defaultzuweisung wird für die jeweilige Komponente deaktiviert, wenn eine entsprechende Zuweisung in der CONFIG.SYS erfolgt. Hier darf dann aber statt FILES auch FILESHIGH verwendet werden oder DEVICEHIGH statt DEVICE. Soll die automatische Zuweisung in der IO.SYS komplett deaktiviert werden, so muss die erste Zeile in der CONFIG.SYS DOS =NOAUTO lauten. Im Idealfall steht in der CONFIG.SYS nur die COUNTRY-Zuweisung:

COUNTRY=049,437,C:\WINDOWS\COMMAND\COUNTRY.SYS

In der AUTOEXEC.BAT sollten sich dann nur ein deutscher Tastaturtreiber und ein paar Zuweisungen für Umgebungsvariablen befinden. Einige Umgebungsvariablen werden bereits durch IO.SYS gesetzt. So ist die Umgebungsvariable PATH, TEMP und TMP bereits belegt, kann aber jeder Zeit durch entsprechende Einträge in der AUTOEXEC.BAT erweitert oder überschrieben werden:

=== Hier schneiden ===

@echo off

path=%path%;c:\tools

LH KDRIVE -A- -/-

LH S3VBE20 /INSTALL

SET TEMP=C:\TEMP

SET TMP=C:\TEMP

SET DIRCMD=/OGN /A /W /P

SET MIDI=SYNTH:1 MAP:E MODE:0

SET SOund =C:\PROGRA~1\CREATIVE\CTSND

SET BLASTER=A220 I5 D1 H5 P330 E620 T6

=== Hier schneiden ===

In diesem Beispiel wird die PATH-Variable erweitert und die Variable TEMP und TMP überschrieben. Weitere Variablen werden hinzugefügt.

Wer noch mehr konventionellen Speicher zur Verfügung stellen möchte, verwendet entweder je DOS -Anwendung eine individuelle MSDOS -Konfiguration, die er über die Eigenschaften des DOS -Programms (rechte Maustaste auf EXE-Datei) konfiguriert, oder startet über eine Verknüpfung zum DOS -Programm eine Stapelverarbeitung. In dieser kann dann z.B. der deutsche Tastaturtreiber statt in der AUTOEXEC.BAT aktiviert werden.

c) Windows im DOS -MODUS beenden

Beim Beenden von Windows wird der DOS -MODUS angeboten, der ohne Warmstart zum DOS -Prompt führt. Auch hier stehen keine 32Bit-Treiber mehr zur Verfügung. Dieser DOS -Prompt setzt per default auf die bestehenden Dateien CONFIG.SYS und AUTOEXEC.BAT beim Windows-Start auf und es wird eine Datei DOS START.BAT ausgeführt. Diese Datei wird einmalig bei der Installation von Windows erstellt, kann jedoch jeder Zeit modifiziert werden.

Für diesen Menüpunkt ist eine Verknüpfung MS-DOS -MODUS im Windowshauptverzeichnis verantwortlich. Diese Verknüpfung hat ebenfalls ein Eigenschaftsmenü, welches verändert werden kann. Auch hier kann man den MSDOS -Modus mit einer individuellen CONFIG.SYS und AUTOEXEC.BAT erzwingen. Allerdings führt dies dann unwiderruflich zu einem Warmstart statt direkt zum DOS -Prompt.

Was ist also nun zu tun?

a) Man muss sich entscheiden, ob eine Anwendung unter dem MSDOS -Modus laufen soll oder muss, verzichtet dann aber auf erweiterte Fähigkeiten von Windows, wie z.B. lange Dateinamen, schneller 32Bit-Dateizugriff oder Multitasking oder verwendet eben die DOS -Anwendung von der GUI. Manche Peripheriegeräte verlangen nach wie vor noch 16 Bit-Treiber. Anwendungen, die auf diese Treiber angewiesen sind, sollte man ggf. durch moderne Anwendungen ersetzen oder sich moderne Treiber besorgen, damit auf die 16 Bit-Treiber verzichtet werden kann.

Die Standardperipheriegeräte (Maus, Festplatte, CDROM) brauchen i.d.R. keinen Realmodetreiber. Gerade bei Festplatten oder CDROMs ist darauf zu achten 32Bit-Treiber zu verwenden, da sonst ggf. Windows im langsamen Kompatibilitätsmodus arbeiten muss. Das führt zu einer Senkung der Verarbeitungsgeschwindigkeit, Erhöhung der Fehleranfälligkeit, schlechtem Multitaskingbetrieb und weniger DOS -Speicher.

b) Man optimiert den jeweiligen Modus. Entweder werden Realmodetreiber bei der Verwendung der GUI entfernt oder wenn man darauf angewiesen ist verwendet man kleinere Treiber bzw. erst dann, wenn Sie benötigt werden oder ersetzt Sie durch 32Bit-kompatible Treiber. Auf jeden Fall sollten diese in den UMB-Speicher per DEVICEHIGH oder LH geladen werden. Verwendet man den MSDOS -MODUS oder ist auf REALMODE-Treiber angewiesen optimiert man die Ladereihenfolge und die Speicherbelegung mit Programmen wie Memmaker. Als Faustformel gilt z.B. hier, dass man zunächst alle großen Treiber und Programme und dann anschließend kleinere Treiber und Anwendungen lädt (z.B. MSCDEX vor SMARTDRIVE, SMARTDRIVE vor dem Tastaturtreiber).

Info Für die Konfiguration des MSDOS -Modus stehen weitere Tools auf der Windows-CD sowie im Freewarepaket KERNELTOYS :http://www.microsoft.com/windows95/downloads/contents/wuToys/w95KernelToy/default.asp von MICROSOFT zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0115.htm


Tuning-Tools

Wie kann man den subjektiven Eindruck, dass System sei zu langsam, objektiv beurteilen? Hierzu bieten sich verschiedene Tools an. Ich beschreibe hier kurz die Tools und in einem weiteren Bericht (Wie kann ich die Geschwindigkeit meines Systems verbessern?), wie man sein System beschleunigen kann.

Leistungsmerkeinmale

Liefert Informationen über die Grafikgeschwindigkeit, virtuellen Arbeitsspeicher, Dateisystem und erlaubt performancesteigernde Maßnahmen. Das Programm verfügt über eine Onlinehilfe. Dieses Tool zeigt auch an, ob Windows im Kompatibilitätsmodus betrieben wird.

Bei Windows 95 und 98 finden Sie es unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "System" -> "Leistungsmerkeinmale"

Systemmonitor

Dieses Programm liefert ausschließlich, aber detaillierte Informationen über alle wesentlichen Windows-Komponenten.

Unter "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Systemmonitor" können Sie den Systemmonitor starten. Ist das Programm nicht in der Gruppe zu finden, so muss es zunächst über "Einstellungen" -> "Systemsteuerung" -> "Software" -> "Windows Setup" unter "Zubehör" bzw. bei Windows 98 unter "Systemprogramme" installiert werden.

Unter "Bearbeiten" -> "Datenquelle hinzufügen" können Sie nun bestimme Messwerte abrufen:

Problem:

zu wenig RAM-Speicher

Messwert:

"Speicher-Manager" -> "Seiteneinlagerung" und "Seitenauslagerung"

Anzeige:

hohe Aktivität (ständig wechselnde, hohe Zahlenwerte)
Es lohnt sich auch ein Blick auf die Größe des Caches. Möglicherweise ist ein falsches Profil (Siehe Tuning CACHE) ausgewählt worden, so dass der RAM-Speicher in den Cache gesteckt wird.

Problem:

zu geringe CPU-Leistung

Messwert:

"Kernel" -> "Prozessorauslastung %" und "Threads"

Anzeige:

Dieser Messwert ist relativ ungenau. Verringert man mit "Option" -> "Diagramm.." das Aktualisierungsintervall, wird der Messwert genauer. Laufen DOS -Programme, z.B. DFÜ-DOS -Verbindungen oder wird die Maustaste gedrückt, liefert die Prozessorauslastung ebenfalls ein falsches Bild der CPU-Leistung.

In Verbindung mit "Kernel" -> "Threads" oder aber auch mit dem Programm WinTop (Siehe unten) lässt sich nun feststellen, welche Threads (in der Regel Programme) die meiste CPU-Belastung verursachen.
Mit CTRL ALT DEL lässt sich dann gezielt ein Thread beenden. (Vorsicht: einige Threads sind lebensnotwendig für Windows). Besser die Anwendung ordentlich, z.B. über die Taskleiste am Bildschirmrand, beenden.

Problem:

zu geringe Festplattengeschwindigkeit

Messwert:

"Dateisystem" -> "Geschriebene Byte/Sek." und "Gelesene Bytes/Sek."
"Dateisystem" -> "Lesezugriffe/Sek." und "Schreibzugriffe/Sek."

Anzeige:

Je heftiger das System genutzt wird, desto wichtiger ist es, den Zugriff auf Dateien zu verbessern

Problem:

im laufenden System wird Windows immer langsamer

Messwert:

"Speicher-Manager" -> "Reservierter Speicher", "Gesperrter Speicher", "Seitenauslagerungen", "Sonstiger Speicher und unter "Kernel" -> "Threads"

Anzeige:

Anwendungen sollen nach deren Beendigung Ressourcen und Speicher wieder freigeben. So manche Windows 3.1- Anwendung verhält sich jedoch unkooperativ und gibt Speicher nicht wieder frei. Auf der anderen Seite wird für Windows 3.1 Anwendungen in Windows eine eigene Laufzeitumgebung benötigt, die unter anderem Speicherplatz kostet. Diese Laufzeitumgebung kann aber erst dann wieder entfernt werden, wenn auch die letzte Windows 3.1 Anwendung beendet wurde.

Sonstiger Speicher zeigt z.B. den Speicher an, der nicht in der Auslagerungsdatei liegt, Speicher für den Cache, Speicher der nicht ausgelagert werden kann, Speicher der nicht zugeordnet werden kann (z.B. DLLs wie der von WIN32.DLL). Sonstiger Speicher ist also eine Summe von anderen Messwerten und mehr.

Info Der Systemmonitor kann weitere Messwerte enthalten, die sonst nicht angezeigt werden. Wird z.B. ein weiteres Gerät, eine Windows-Ramdisk benutzt, können diese Geräte hier Werte anzeigen. VRAMDIR (siehe Tuning Dateizugriff) wäre ein solches Programm.

WinTop

In den Microsoft KERNELTOYS finden Sie dieses Programm, welches Sie über die Datei WINTOP.INF installieren müssen.

Info Dieses Programm ist ein echter Knüller. Es zeigt, welche Anwendungen (genauer: Tasks) die meiste CPU-Zeit benötigen. Je höher der IDLE-Wert, desto weniger ist die CPU ausgelastet.

Faustformel: Windows 3.1 Anwendungen und 16-Bit-Anwendungen (siehe Spalte TYPE) sind fehleranfälliger und verbrauchen in der Regel mehr CPU-Zeit als ihre Windows 4.0 bzw. 32 Bit-Kollegen.

Ressourcen-Monitor

Den finden Sie unter "START" -> "Systemsteuerung" -> "System" -> "Leistungsmerkeinmale". Hier finden Sie unter anderem Informationen über die freien "System Ressourcen". Je weniger Ressourcen verfügbar sind, desto langsamer ist Windows.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0623.htm


Festplatten Cache aktivieren/deaktivieren

Wenn diese Funktion aktiviert ist, wird die Festplatte zum Zwischenspeichern von Internetseiten verwendet. Wenn Sie den Wert auf NO setzen, dann werden keine Internetseiten mehr auf die Festplatten zwischengespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main

erstellen Sie hier den Wert "Enable_Disk_Cache" alsDatentyp REG_SZ. Setzen Sie den Wert auf "YES"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0938.htm


Aufklappen des Startmenüs beschleunigen

Wenn Sie sich mit der Maus durch das Startmenü hangeln, wird Ihnen sicherlich schon aufgefallen sein, dass die Unterordner sich erst mit einer gewissen Zeitverzögerung öffnen. Für Leute, die schnell wohin wollen, erweist sich diese Verzögerung als lästig. In der Registry können Sie diesen Wert aber für sich anpassen.

Ich kann trotz Verändern des Wertes keine Veränderung beim Öffnen feststellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Controll Panel\ desktop

Erstellen Sie eine neue Zeichenfolge mit dem Namen "MenuShowDelay" als Datentyp REG_SZ. Nun klicken Sie doppelt auf den neuen Eintrag und weisen ihm einen Wert (Wartezeit in Millisekunden) zu, z.B. 10 oder 0. Die Werte können zwischen 0 und 65534 liegen, der Standardwert ist 400.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0029.htm


Tweak UI 1.33: Alle Funktionen im Überblick

Tweak UI 1.33 ist geeignet für W9x/ME/NT/2000. Einige Optionen sind, je nach Betriebssystem und IE-Version, nicht vorhanden. Ältere Versionen dieses Programms sollten Sie nicht mehr verwenden.

Download

Die Adresse zum Downloaden von Tweak UI 1.33 finden Sie hier.

Tweak XP finden Sie in den Power Toys für Windows XP.

Weitere Informationen zu den meisten Tweak UI Optionen erhalten Sie, wenn Sie mit der rechten Maustaste auf das entsprechende Feld klicken und dann "Direkthilfe" anwählen.

Installation

  1. Kopieren Sie die Installationsdatei in ein leeres Verzeichnis (Installationsverzeichnis), dessen Name nicht mehr als acht Zeichen enthält. Starten Sie die Datei per Doppelklick.
  2. Lassen Sie die Datei in das Installationsverzeichnis entpacken.
  3. Sollten Sie zur Eingabe des Quellverzeichnisses aufgefordert werden, klicken Sie auf "Durchsuchen" und wählen Sie nochmals dasjenige Verzeichnis, in dem die Installationsdatei liegt.
  4. Klicken Sie nun mit der rechten Maustaste auf die .INF-Datei im Installationsverzeichnis und wählen Sie "Installieren".
  5. Evtl. aufpoppende Fenster schließen Sie einfach.
  6. Tweak UI steht ihnen nun unter Start - Einstellungen - Systemsteuerung zur Verfügung.

Desktop

  1. "Show on Desktop":
    setzen Sie einen Haken bei den Symbolen, die auf dem Desktop angezeigt werden sollen
    (die Suchergebnisse sollten NICHT ausgeblendet werden).
  2. "Create as File":
    Markieren Sie einen Eintrag in der Liste und klicken Sie dann auf "Create As File", um einen Ordner zu erstellen, der die jeweiligen Inhalte anzeigt.
    Siehe auch "Systemsteuerung & Co im Startmenü mit Pfeil zum Aufklappen".
  3. Sie können auch die einzelnen Elemente mit der rechten Maustaste anklicken und dann aus dem Kontextmenü "Show on Desktop", "Create as File" oder "Rename" (Umbenennen) auswählen.
  4. "First Icon on desktop" (Erstes Icon auf dem Desktop):
    Legt fest, welches der Systemicons als Erstes auf dem Desktop angezeigt werden soll
    (Änderung NICHT empfohlen).

My Computer

  1. Entfernen Sie den Haken bei den Laufwerken, auf die nicht über "Arbeitsplatz" oder über einen Rechtsklick auf den Start Button zugegriffen werden soll. Wenn auch nur ein einziges Laufwerk "versteckt" wird, stehen die Punkte "Öffnen" und "Explorer" im Kontextmenü des Start-Buttons nicht mehr zur Verfügung.
    (Dies ist kein Fehler, wie oft irrtümlich angenommen, sondern genau der Zweck dieser Funktion).
  2. "Special Folders":
    Hier können Sie verschiedene Systemordner in einen anderen Pfad oder auf ein anderes Laufwerk legen
    (unter Windows ME sollte der Pfad des Ordners "Eigene Dateien" NICHT geändert werden).

Control Panel

  1. Entfernen Sie den Haken bei den Einträgen, die nicht mehr in der Systemsteuerung angezeigt werden sollen. Die Beschreibung einiger Einträge finden Sie unter Icons der Systemsteuerung ausblenden
    (Tweak UI sollte NICHT ausgeblendet werden).

Logon

  1. Um sich die Anmeldung mittels des Anmeldedialogs beim Starten von Windows zu ersparen, aktivieren Sie das so genannte "Autologon" und tragen Sie den Benutzernamen und das Kennwort ein.
    Beachten Sie bitte Autologin beim Starten.

New

  1. Einträge im "Neu"-Kontextmenü:
    Entfernen Sie den Haken bei den Einträgen, die nicht mehr im Kontextmenü - Neu angezeigt werden sollen. Um einen Eintrag zu löschen, markieren Sie den Eintrag und klicken dann auf "Remove" oder klicken Sie mit der rechten Maustaste auf den Eintrag und wählen dann "Remove".
    Um einen neuen Eintrag zu erzeugen, legen Sie eine leere Datei mit dem dazugehörigen Programm an und ziehen Sie dann diese Datei in das Tweak UI-Fenster.
    Siehe auch Wie kann man das Kontextmenü NEU verändern?.

Add/Remove

  1. Einträge unter Systemsteuerung - Software - Installieren/Deinstallieren:
    "New" (Anlegen): Einen irrtümlich gelöschten Eintrag können Sie hier wieder erstellen.
    "Remove" (Löschen): Um einen Eintrag zu löschen, markieren Sie den Eintrag und wählen dann "Remove". Das Programm wird dadurch nicht gelöscht, Sie entfernen lediglich den Verweis auf das Deinstallationsprogramm.
    "Edit" (Ändern): Einen fehlerhaften Eintrag können Sie hier korrigieren.
    Siehe auch Software Einträge aus dem Menü Software löschen.

Boot

  1. "Funktion keys available" (Funktionstasten beim Booten):
    Aktiviert oder deaktiviert die Funktionstasten beispielsweise zum Anzeigen des Bootmenüs (F8) oder zum Starten im Abgesicherten-Modus (F5).
    Siehe auch Windows Bootmenü (unterschiedliche Startarten von Windows).
  2. "Start GUI automatically" (Windowsoberfläche automatisch starten):
    Hier können Sie einstellen, ob nur bis zum DOS -Prompt oder komplett bis zur Anzeige des Desktops gebootet werden soll.
  3. "Display splash screen while booting" (Windows-Logo anzeigen):
    Hier können Sie festlegen, ob während des Bootens das Windows-Logo angezeigt werden soll.
  4. "Allow F4 to boot previous operating system" (Booten des "alten" Betriebssystems zulassen):
    Hier legen Sie fest, ob Sie das Booten in das nach einem Upgrade evtl. vorhandene Betriebssystem zulassen wollen.
  5. "Autorun Scandisk" (Scandisk automatisch starten):
    Hier legen Sie fest, ob und wie Scandisk gestartet wird, wenn Windows nicht ordnungsgem. heruntergefahren wurde
    "Never": Nie (nicht empfohlen)
    "After prompting": Nach Bestätigung
    "Without prompting": Ohne Aufforderung zur Bestätigung
  6. "Always show boot menu" (Bootmenü anzeigen):
    Hier können Sie das Bootmenü zur Auswahl der Startarten (DOS , abgesicherter Modus,...) an- oder ausschalten
  7. "Continue booting after x seconds" (Dauer der Anzeige des Bootmenüs):
    Legt fest, nach wie vielen Sekunden der Bootvorgang fortgesetzt wird, wenn nach der Anzeige des Bootmenüs keine Taste gedrückt wurde.
  8. "Restore factory settings" (Zurücksetzen der Einstellungen):
    Setzt die Einstellungen auf die Standardwerte zurück.

Repair

Wenn sich ein Systemordner wie z.B. Fonts nicht mehr normal verhält (Befehl "Neu" nicht mehr verfügbar), können Sie die ursprünglichen Systemeigenschaften wieder herstellen. Wählen Sie die gewünschte Funktion aus dem Auswahlmenü und klicken Sie dann auf "Repair now" (Jetzt reparieren):

  1. "Rebuild Icons" (Icons reparieren):
    Verwenden Sie diese Funktion, wenn Windows falsche oder schwarze Icons anzeigt.
    Siehe auch Icon-Cache-Größe erhöhen.
  2. "Repair Associations" (Dateizuordnung reparieren):
    Fehlt z.B. die "Installieren"-Option im Kontextmenü beim Rechtsklick auf eine.INF-Datei, verwenden Sie bitte diese Funktion.
  3. "Repair font folder" (Font-Ordner reparieren):
    Wenn der Font-Ordner seine speziellen Eigenschaften verloren hat, können Sie ihn mit dieser Funktion reparieren.
  4. "Repair hotkeys" (Tastaturkürzel reparieren):
    Setzt die Tastaturkürzel zurück, wenn z.B. ein Kürzel für ein Icon auf dem Desktop oder im Startmenü noch aktiv ist, obwohl Sie das Icon bereits entfernt haben.
  5. "Repair Regedit" (Regedit reparieren):
    Wenn im rechten Fenster des Registry-Editors keine Informationen mehr angezeigt werden, verwenden Sie diese Option.
  6. "Repair system files" (Systemdateien reparieren):
    Vergleicht Systemdateien mit den im versteckten Ordner "\Windows\Sysbckup" gespeicherten Sicherungen und ersetzt ggf. defekte Dateien.
  7. "Repair Temporary Internet Files" (Ordner Temporäre Internet Dateien reparieren):
    Wenn dieser Ordner seine speziellen Eigenschaften verloren hat, können Sie auch diesen reparieren.

Paranoia

"Covering your tracks" (Spuren verwischen): Löscht bei jeder Anmeldung folgende Dateien bzw. Registry-Einträge:

  1. "Document history":
    Verknüpfungen zu den zuletzt geöffneten Dateien (Start - Dokumente)
    Dateien: %WINDIR%\Recent\*.*
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 8
  2. "Find computer":
    Historie der Suche nach Rechnern im Netzwerk (Start - Suchen - Computer)
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 4
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FindComputerMRU
  3. "Find files":
    Historie der Suche nach Dateien oder Ordnern auf dem Rechner (Start - Suchen - Dateien/Ordner)
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 2
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Doc Find Spec MRU
  4. "Internet Explorer":
    Löscht die zuletzt besuchten Internetadressen
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 16
  5. "Last User" (Zuletzt verwendeter Benutzername):
    Sorgt dafür, dass der Name der zuletzt angemeldeten Benutzers nicht im Anmeldedialog angezeigt wird
    Registry: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon\DontDisplayLastUserName
  6. "Network connection" (verbundene Netzlaufwerke):
    Bereinigt die Anzeige der zuletzt verwendeten Netzwerklaufwerke
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 32
    HKEY_CURRENT_USER\Network\Recent
  7. "Run" (Zuletzt aufgerufene Programme):
    Löscht die Anzeige der verwendeten Programme (Start - Ausführen)
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 1
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU
  8. "Telnet":
    Löscht die Namen der zuletzt verwendeten Server einer Telnet-Sitzung
    Registry: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\TweakUI\1
    Datentyp REG_SZ, Wert: +/- 64
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

Behind your back:

Hier können Sie einstellen, ob Daten-CDs und Audio-CDs automatisch gestartet werden. Die Option "Benachrichtigung beim Wechsel" muss aktiviert sein.

Illegal operations (Programmfehler): Aktivieren Sie diese Option, wenn Programmabstürze in der Datei Faultlog.txt protokolliert werden sollen.

Mouse

  1. "Menu Speed" (Menü-Geschwindigkeit):
    Hier können Sie einstellen, wie lange es dauert, bis ein Menü aufgeklappt wird, wenn Sie mit der Maus über dem entsprechenden Eintrag verweilen, Zum Testen klicken Sie mit der rechten Maustaste auf das Test-Icon und positionieren dann den Mauszeiger über einen der drei Einträge.
  2. "Mouse sensivity" (Maus-Empfindlichkeit):
    Hier können Sie die Empfindlichkeit einstellen, mit der ein Doppelklick oder eine Drag&Drop-Aktion erkannt werden soll. Zum Testen verwenden Sie wiederum das Test-Icon.
  3. "Use mouse wheel for scrolling" (Mausrad zum Scrollen verwenden):
    Legt fest, ob Sie ein evtl. vorhandenes Mausrad zum seiten-oder zum zeilenweisen Scrollen verwenden.
  4. "XMouse":
    Mit dieser Funktion können Sie einstellen, ob Sie ein Fenster, welches sich nicht im Vordergrund befindet, explizit anklicken müssen oder ob es aktiviert wird, wenn sich der Mauszeiger im Bereich des Fensters befindet.
  5. "Restore Factory Settings" (Standardwerte wiederherstellen):
    Setzt alle Werte dieser Seite auf die Standardwerte zurück.

General

  1. "Always show keyboard indicators" (Tastaturkürzel immer anzeigen):
    Legt fest, ob Tastaturkürzel in Menüs immer durch einen Unterstrich gekennzeichnet werden oder nicht.
  2. "Beep on errors" (Akustische Fehlermeldung):
    Legt fest, ob Windows einen Warnton im Falle eines Fehlers erklingen lässt. Der Warnton kann in der Systemsteuerung unter "Akustische Signale" ausgewählt werden.
  3. "Combo, List, Menu animation" (Animierte Menüs):
    Legt fest, ob die jeweiligen Dialogboxelemente beim anklicken animiert angezeigt werden sollen.
  4. "Mouse hot tracking effects" (Maus-Effekte):
    Legt fest, ob Tooltipps angezeigt werden, wenn Sie mit dem Mauszeiger über Fensterelementen verweilen (z.B. bei den Minimieren-, Maximieren- und Schließen-Schaltknöpfen).
  5. "Show Windows version on desktop" (Windows-Version auf dem Desktop anzeigen):
    Zeigt die Windows-Version und Bildschirminformationen (bei mehreren angeschlossenen Bildschirmen) auf dem Desktop an.
  6. "Smooth scrolling" (Weiches Scrollen):
  7. Schaltet zwischen weichem (animiertem) und zeilenweisem Scrollen um.
  8. "Window animation" (Animierte Fenster):
    Animierte Fenster beim Verkleinern oder Schließen von Fenstern.
  9. "Prevent applications from stealing focus" (Fenster nicht automatisch in den Vordergrund holen):
    Legt fest, ob und nach welcher Wartezeit Fenster, in denen eine Änderung auftritt, automatisch in den Vordergrund geholt werden, oder ob das dazugehörige Symbol in der Taskleiste blinken soll.

Explorer

  1. "Shortcut overlay" (Verknüpfungspfeil):
    Legt fest, ob Verknüpfungen auf dem Desktop mit einem kleinen Pfeil gekennzeichnet werden.
  2. "Manipulate connected files as a unit":
    Dies bedeutete das die *.html und der entsprechenden Ordner als Einheit betrachtet werden. Beispiel Ich speichere eine komplette HTML Seite unter irgendeinen Namen mit der Einstellung Dateityp Webseite komplett. Dann wird nicht nur die Webseite sondern auch ein Ordner erstellt mit dem Namen der Seite. Ist jetzt "Manipulate connected files as a unit": gesetzt, werden die beiden immer als Einheit betrachtet. D.h. lösche,kopiere oder verschiebe ich die *.html oder den Ordner so wird auch der Ordner oder die *.html gelöscht,kopiert oder verschoben. wenn nicht gesetzt bleibt der Ordner bzw. die *.htm da wo sie vorher waren.
  3. "Adjust case of 8.3 filenames" (Kurze Dateinamen anpassen):
    Legt fest, ob Dateinamen in Großbuchstaben, die der 8.3 Konvention entsprechen, in Groß- und Kleinbuchstaben geändert werden (ABCDEFGH.XYZ wird zu Abcdefgh.xyz).
  4. "Prefix 'Shortcut to' on new shortcuts" ("Verknüpfung mit" voranstellen):
    Legt fest, ob die Namen von neu erstellten Verknüpfungen mit einem "Verknüpfung mit" versehen werden.
  5. "Save Explorer window settings" (Explorer-Fenster wiederherstellen):
    Legt fest, ob Ordnereinstellungen beim erneuten Öffnen wiederhergestellt werden.
  6. "Hot tracking" (Link-Farbe):
    Hier können Sie die Farbe festlegen, mit der KBare Elemente (Links) angezeigt werden, wenn Sie mit dem Mauszeiger darüberfahren.

IE

  1. "Enable Windows+X hotkeys" (Windows-Tastaturkürzel aktivieren):
    Legt fest, ob die Standard-Tastaturkürzel (z.B. Win+E) aktiv sind.
  2. "Show Computers Near Me in Network Places":
    Rechner ais dem Netzwerk anzeigen
  3. "Show Control Panel on Start Menu Settings" (Systemsteuerung im Startmenü anzeigen):
    Legt fest, ob der Menüpunkt "Systemsteuerung" im Startmenü angezeigt wird
    (Sollte NICHT deaktiviert werden).
  4. "Show Dial-Up Networking on Start Menu Settings" (DFÜ-Netzwerk im Startmenü anzeigen):
    Legt fest, ob der Menüpunkt "DFÜ-Netzwerk" im Startmenü angezeigt wird.
  5. "Show Help on Start Menu" (Hilfe im Startmenü anzeigen):
    Legt fest, ob der Menüpunkt "Hilfe" im Startmenü angezeigt wird.
  6. "Show My Pictures on Start Menu Documents" (Eigene Bilder im Startmenü anzeigen):
    Legt fest, ob der Menüpunkt "Eigene Bilder" im Startmenü angezeigt wird.
  7. "Add new documents to Documents on Start Menu" (Historie der geöffneten Dateien aktualisieren):
    Legt fest, ob die Liste der zuletzt geöffneten Dateien im Startmenü (Dokumente) beim Öffnen einer Datei per Doppelklick aktualisiert wird.
  8. "Allow Active Desktop to be turned on/off" (Active Desktop an-/ausschalten zulassen):
    Active Desktop-Erweiterungen an-/ausschalten.
  9. "Allow changes to Active Desktop" (Änderungen am Active Desktop zulassen):
    Legt fest, ob Änderungen an den Einstellungen zum Active Desktop zugelassen sind.
  10. "Allow Logoff" (Benutzer abmelden im Startmenü):
    Anzeige des Menüpunkts "Benutzer abmelden" im Startmenü an-/ausschalten.
  11. "Clear document, run, typed-URL history on exit" (Historien-Einträge beim Abmelden löschen):
    Löscht die Historie der geöffneten Dokumente, ausgeführten Befehle und eingegebenen URLs bei jeder Benutzerabmeldung.
  12. "Detect accidental double-clicks" (Versehentliche Doppelklicks in der Web-Ansicht korrigieren):
    Versehentliche Doppelklicks werden wie einfache Mausklicks behandelt.
  13. "Shell enhancements" (Shell-Erweiterungen):
    (Sollte NICHT deaktiviert werden).
  14. "Show Documents on start menu" (Dokumente im Startmenü):
    Menüpunkt "Dokumente" im Startmenü anzeigen.
  15. "Show Favorites on start menu" (Favoriten im Startmenü):
    Menüpunkt "Favoriten" im Startmenü anzeigen.
  16. "Show Links on favorites menu" (Links im Favoritenmenü):
    Ordner "Links" im Ordner "Favoriten" des Startmenüs anzeigen.

Open

  1. "Show Back button on File Open/Save dialog" (Zurück-Schaltfläche im Öffnen/Speichern-Dialog):
    Legt fest, ob die "Zurück"-Schaltfläche im Öffnen/Speichern-Dialog angezeigt wird.
  2. "Remember previously-used filenames" (Zuletzt verwendete Dateinamen erinnern):
    Legt fest, ob die zuletzt verwendeten Dateinamen im Öffnen/Speichern-Dialog angezeigt werden.
  3. "Places Bar -Show default places -Hide places bar -Custom places bar" (Ordner im Öffnen/Speichern-Dialog anzeigen):
    Legt fest, welche Ordner Öffnen/Speichern-Dialog angezeigt werden. Sie können bis zu fünf eigene Ordner festlegen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1277.htm


Windows Start beschleunigen

Beim Starten sucht Windows immer nach der Datei "WINSTART.BAT". Findet Windows diese Datei, wird sie automatisch ausgeführt.

Auf den meisten Rechnern ist diese Datei aber nicht vorhanden, so dass Windows erst einmal alle Ordner nach dieser Datei durchsucht und dann den Bootvorgang weiter fortsetzt. Legt man nun diese Datei WINSTART.BATim WINDOWS Ordner an (z.B. mit den Inhalt "@echo off"), wird die Suche nach dieser Datei verkürzt.

Bei den heutigen schnellen Festplatten wird es wohl nicht mehr einen so großen Zeitgewinn bringen. Wenn Sie aber noch mit einer alten Festplatte arbeiten, können Sie damit doch schon einige Zeit einsparen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0244.htm


Starten von Windows beschleunigen

Suchen Sie in der Datei BOOTLOG.TXT nach Einträgen, die mit "LoadFailed" beginnen. Entfernen Sie nun diese Einträge aus den Dateien WIN.INI und SYSTEM.INI.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Erstellen Sie über -> "Registrierung" -> "Registry-Datei exportieren" eine Sicherheitskopie(im Notfall lässt sich die Registrierung dann per -> "Registry-Datei importieren" wiederherstellen). Löschen Sie nun auch hier die in der BOOTLOG.TXT gefundenen Einträge. Booten Sie Windows neu. Wenn die Meldung "Windows 95 wird gestartet..." erscheint, drücken Sie die F8-Taste. Im Start-Menü wählen Sie "Protokolliert". Dadurch wird erneut eine BOOTLOG.TXT erstellt, die man dann wieder auf "LoadFailed" untersucht. Verfahren Sie auf diese Weise bis Sie keine "LoadFailed"-Einträge mehr finden.

In der Datei Bootlog.txt gibt es zwei "LoadFailed"-Einträge, die auf keinen Fall gelöscht werden dürfen!

  • "LoadFailed = ndis2sup.vxd"
  • "LoadFailed = vshare"

Hier ist das "LoadFailed" ein Programmfehler unter Windows. Wer diese Dateien löscht, legt Windows lahm.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0316.htm


Write Allocate aktivieren

Der K6 von AMD (AMD K6) verfügt über ein Feature, welche sich Write Allocate nennt. Der K6 schreibt in diesem Modus Daten, welche sich noch nicht im Cache befinden, direkt in den Arbeitsspeicher und liest diese danach sofort in den Cache ein. Das Ganze erfolgt im schnellen Burst Modus. Ohne dieses Feature würde die CPU die Information nur im RAM ablegen und hätte diese nicht auch im Cache gespeichert. Der Geschwindigkeitsvorteil beläuft sich mit Write Allocate auf ca. 5-8 Prozent, je nach Anwendung

Neuere Boards bieten dieses Feature im BIOS . Bei älteren Boards hilft ein Patch der c't unter ftp://ftp.heise.de/pub/ct/ctsi/setk6v3.zip

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0876.htm


Geschwindigkeit's Optimierung für Systembus und Speicherzugriffe

Mit diesem Tipp können Sie die Geschwindigkeit steigern, mit dem der Systembus APG und PCI mit dem Speicher arbeitet. Durch das Setzen der Werte werden die Wartezeiten (idle time) reduziert.

Info Diese Wartezeiten werden benutzt, um anderen Systemkompunenten die Möglichkeit zu geben auf die Ressource zuzugreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ BIOS

Erstellen Sie hier jeweils die folgenden Werte als Datentyp REG_DWORD und setzen den Wert auf 1, um die Wartezeiten (idle time) zu verkürzen.

PCIConcur | PCI-Bus Einstellung
AGPConcur | AGP-Bus Einstellung
FastDRAM | DRAM Einstellung

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2598.htm


Konfigurieren der CPU-Task Priorität

Mit diesem Tipp, können Sie die Prioritätenverteilung für Vordergrund- und Hintergrundprozesse festlegen.

Meist ist beim Arbeiten am Rechner der Prozess wichtig, der gerade im Vordergrund läuft. Die Prozesse im Hintergrund können dann ruhig etwas länger brauchen, da man hierauf nicht wartet. So kann das Packen vieler Dateien im Hintergrund ruhig mit einer geringeren Priorität ausgeführt werden, während die Anwendung im Vordergrund schon flüssig laufen sollte. Mit dem Eintrag "CPUPriority" können Sie das in der Registry konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ BIOS

Erstellen Sie hier einen neuen Wert mit dem Namen "CPUPriority" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nicht zu empfehlen Der Vordergrundprozess läuft in Echtzeit. Dadurch können keine anderen Prozesse mehr ausgeführt werden, das System hängt!
1 | Vordergrundprozesse bekommen die maximale Priorität
2 | Vordergrundprozesse haben eine höhere Priorität als Hintergrundprozesse
3 | Vordergrund- und Hintergrundprozesse haben die gleiche Priorität (Standard)

Sie müssen Windows neu Starten, damit die Einstellungen aktiv werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2597.htm


Lautstärkeregler in der Taskleiste

Wollen Sie die Lautstärke schnell verändern, können Sie sich einen Lautsprecher unten in der Taskleiste anzeigen lassen bzw. auch wieder über der Taskleiste entfernen.

-> "Systemsteuerung" -> "Multimedia" -> Registerkarte "Audio" -> "Lautstärkeregelung in Taskleiste anzeigen"

Hier können Sie den Lautstärkeregler aktivieren bzw. deaktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0012.htm


Sound ohne Soundkarte

Wenn Sie keine Soundkarte in Ihren PC besitzen, können Sie über einen Treiber, der von MS bereitgestellt wird, die Soundausgabe auf den PC-Lautsprecher ausgeben lassen.

Hompepage: ftp://ftp.microsoft.com/SoftLib/MSLFiles/speak.exe

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0455.htm


MIDI-Ausgabe verbessern (SB16AWE-Benutzer)

MIDI-Ausgabe verbessern (SB16AWE)

Starten Sie nach der Installation der SB16AWE-Treiber von Creative Labs die Systemsteuerung und wählen dort "Multimedia" aus und stellen in der Registerkarte "MIDI"anstelle von OPL2/3"Advanced SB16 AWE" ein. Dadurch wird die Ausgabequalität von MIDI-Dateien deutlich erhöht.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0222.htm


Anspielzeit von Musikstücken im Audioplayer verlängern

Der CD-Player von MS bietet die Funktion, Musikstücke einer CD kurz anzuspielen und dann automatisch zum nächsten Stück zu wechseln (ist Ihnen sicherlich von Ihrem eigenen CD-Player her bekannt).

Diese Zeit können Sie im "CD-Wiedergabe" im Menü "Optionen" -> "Intro-Scan" nur zwischen den Werten 5-15 sec. verändern. Alle anderen Eingaben werden von Windows automatisch auf diesen gültigen Wertebereich umgestellt.

Wenn Sie einen kleineren oder größeren Wert Eintragen wollen, müssen Sie das direkt über die Registry machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ CdPlayer\ Settings

finden Sie den Eintrag "IntroPlayLen" als Datentyp REG_DWORD.

Hier können Sie jetzt die gewünschte Anspielzeit als Dezimalwert (in Sekunden) eingeben. Die gültigen Werte liegt hier zwischen 1 und 59 Sekunden.

Sobald Sie in der CD-Wiedergabe wieder in das Menü gehen und dieses mit OK verlassen, wird Windows diesen Wert selber wieder in einen gültigen Wert zwischen 5-15 sec. abändern.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1077.htm


WAV ohne Anzeige des Players abspielen

Wenn Sie eine WAV Datei unter Windows anklicken, wird diese Datei standardmäßig mit den Windows Mediaplayer geöffnet. Soll der Windows Mediaplayer nicht angezeigt werden, können Sie das folgendermaßen ändern:

  1. Starten Sie den Explorer
  2. Je nach Version :
    "Ansicht" -> "Optionen" -> "Dateitypen" auswählen
    bzw.: "Extras" -> "Ordneroptionen..." -> Tabreiter "Dateitypen" auswählen
  3. In der Liste die Dateiendung "WAV" auswählen
  4. Unter "Vorgänge" "Wiedergeben" markieren und "Bearbeiten" auswählen
  5. Die dortige Befehlszeile "... /play /close...." mit "/embedding" erweitern

Ab jetzt wird beim Abspielen einer WAV-Datei der Player nicht mehr angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0351.htm


Akustische Signale zuweisen

Hier wird beschrieben, wie Sie beliebigen Anwendungen ein akustisches Signal zuweisen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps

Zunächst wird ein neuer Schlüssel angelegt.

Der Schlüsselname muss der kurze Dateiname ohne Dateiendung (Extension) des Programms sein, dem man die Sound-Effekte zuweisen will. In diesem neuen Schlüssel werden nun weitere "Unterschlüssel" angelegt, mit deren Hilfe bestimmten Events im Programm bestimmte Sound-Effekte zugeordnet werden können. Diese "Unterschlüssel" können aber nicht frei gewählt werden, sondern man kann nur solche Unterschlüsselnamen vergeben, die auch Unter: HKEY_CURRENT_USER\ AppEvents\ EventLabels definiert sind.

Beispiel:

Dem NOTEPAD soll beim Programmstart/ende ein beliebiger Sound zuweisbar sein.

Unter

HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps

folgende Struktur erstellen

Schlüssel | Name | Wert
Notepad | (Standard) | "Notepad-Editor"
Open | (Standard) | (Wert nicht gesetzt)
Close | (Standard) | (Wert nicht gesetzt)

Anschließend REGEDIT beenden und in der Systemsteuerung unter "Akustische Signale" dem NOTEPAD die gewünschten Sound-Effekte zuweisen. (Die weiteren Unterschlüssel unter "Open" und "Close" werden dabei automatisch angelegt.)

Folgende Schlüssel können Sie noch wahlweise anlegen:

Maximize | (zum Vollbild machen)
Minimize | (zum Symbol machen)
RestoreDown | (vom Vollbild zum Normalzustand)
RestoreUp | (vom Symbol zum Normalzustand)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0011.htm


Mehr als 5 Sekunden Audiodaten aufnehmen

Wenn Sie mit dem in Windows 95 enthaltenen Audio-Rekorder mehr als 5 Sekunden Audiodaten aufnehmen wollen, müssen Sie folgendes in der WIN.INI Eintragen:

[Sound rec]

max seconds = x (x = Zeit in Sekunden )

Unter Windows 98 und 2000 bringt dieser Eintrag nichts mehr, hier kann der Audiorecorder schon standardmäßig 60 Sekunden aufnehmen. Wem dieses immer noch nicht reicht, muss etwas tricksen.

Man erstellt zuvor eine Audio-Datei mit entsprechender Länge, indem man z.B. 20 Sekunden Stille aufnimmt und mit dem Befehl Bearbeiten/Kopieren - Bearbeiten/Einfügen die "Leeraufnahme" solange einfügt, bis die ausreichende Länge der WAV-Datei erreicht ist.

Dieses "Dummy-File" kann man dann zum Aufnehmen verwenden, indem man die Record-Marke wieder zum Anfang verschiebt. Die Länge der Aufnahme ist dann nur durch die Dauer der Leerdatei beschränkt. evtl. Leerstellen hinter dem richtigen Sample lassen sich mit dem Befehl Bearbeiten -> Löschen nach aktueller Position abschneiden.

Es gibt aber auch sehr gute Programme im Internet, die das so schon können und zur Bearbeitung von Sound viel besser geeignet sind, (http://me.in-berlin.de/~scorpio).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0218.htm


Windows System Lautsprecher deaktivieren

Wenn Sie die Töne aus dem Systemlautsprecher nicht mehr hören wollen, können Sie diese Töne deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Sound

erstellen Sie hier einen neuen Wert mit dem Namen "Beep" als Datentyp REG_SZ. Setzen Sie den Wert auf "No".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0913.htm


Sound-Ereignisse werden nicht mehr abgespielt

Wenn Sie Sound Ereignisse in der Systemsteuerung -> Sounds und Multimedia eingestellt haben und hier zu hören sind, aber bei der Arbeit am System nicht abgespielt werden, kann das an folgendem Fehler liegen, der per Registry behebbar wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Einige Programme erstellen bei der Installation im Hauptroot der Registry unter HKEY_CURRENT_USER einen Wert mit dem Namen <no name> als REG_SZ.

Standardmäßig sollen keine Werte im Root abgelegt werden. Wenn Sie diesen Eintrag löschen wird auch der Sound wieder abgespielt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0907.htm


Echo bei Mikrophonbenutzung verhindern

Wer eine Applikation wie Internettelefonie, Real-Chat-Systeme oder ähnliches verwendet, kennt das Problem, dass man seine eigene Stimme als Echo vernimmt.

Der Grund ist eine falsche Einstellung der Soundkarte.

Dazu öffnet man den Lautstärkeregler und aktiviert über "Optionen" - "Eigenschaften" bei den aufgelisteten Geräten auch das Mikrophon.

Dieses wird dann im Mixer für die Wiedergabe angezeigt. Hier aktiviert man den Button "TON AUS" (Mute). Dadurch wird eine Reflexion des Tons als Echo behoben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0863.htm


Soundausgabe (Klick) beim Navigieren im Explorer

Beim Navigieren im Explorer wird über die Soundkarte immer ein Klick-Geräusch ausgegeben. Dieses Geräusch können Sie nach Belieben verändern oder ganz abschalten, gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps\ Explorer\ Navigating\.current

finden Sie den Eintrag "(Standard)" als Datentyp REG_SZ. Hier ist eingetragen, welcher Sound abgespielt werden soll. Der Standardeintrag lautet "%SYSTEMROOT%\media\start.wav" (Wobei %SYSTEMROOT% ihr Windows-Verzeichnis ist).

Wenn Sie wollen, dass kein Sound abgespielt wird, tragen Sie hier einfach nichts ein oder setzen Sie den Eintrag auf ein anderes Sound file.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1056.htm


Nachschlagen in der MS Knowledge Base

Microsoft hat für Fehler und Tipps eine Knowledge Base angelegt. Die Artikel in der deutschen Knowledge Base sind mit Nummern versehen, denen ein "D" vorangestellt ist ("Q" bei englischsprachigen Artikeln).

Haben Sie ein Problem, können Sie direkt im Internet nachschlagen und suchen. Die Knowledge Base finden Sie unter:

http://support.microsoft.com/?kbid=KB-Nummer

Wenn vorhanden, wird damit auf einem deutschsprachigen System automatisch der Deutschsprachige Artikel geladen, ansonsten der englischsprachige Artikel.

Die englische Knowledge Base ist aktueller und umfangreicher als die deutsche Version. Um die deutsche Fassung eines englischen Artikels (z.B. Q123456) zu erhalten, suchen Sie einfach nach "Q123456" in der deutschen Datenbank.

Mittlerweile ist Microsoft dazu übergegangen, bei Übersetzungen die gleichen Nummern zu verwenden. Die Übersetzung des Artikels "Q301041" finden Sie also unter "D301041".

Vereinfachter Aufruf von Artikeln der Knowledge Base

Mittels eines Registry-Eintrags können Sie über den Internet Explorer Artikel der Knowledge Base aufrufen, indem Sie einfach "KB nnnnnn" oder "Q nnnnnn" in der Adresszeile des Explorers eingeben.

Folgende Einträge sind hierzu notwendig:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ SearchUrl

Unter diesem Schlüssel erstellen Sie einen neuen Schlüssel mit dem Namen "KB" (und /oder "Q").

Als Standardwert tragen Sie dann die Zeichenfolge "http://support.microsoft.com/?kbid=;%s" ein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0320.htm


Strategie zur Problembehebung

Auszug aus dem Windows 95 Support Assistenten v.1.0a von Microsoft Product

Support Services. Copyright 1995, Microsoft Corporation

Nachdem Sie Informationen gesammelt haben, sollten Sie folgende Schritte ausführen, um eine Strategie für die Problembehebung zu entwickeln.

Analysieren Sie die Symptome und entwickeln Sie eine Strategie

Analysieren Sie die Symptome, um einen Lösungsansatz herauszufinden. Unter welchen Bedingungen tritt das Problem auf und wann tritt es nicht auf? Welche Aspekte innerhalb des Systems beeinflussen diese Bedingungen? Bezieht sich das Problem auf ein Subsystem (z.B. Netzwerk oder Grafik)?

Modifizieren Sie die System- oder Programmeinstellungen und versuchen Sie es erneut. Minimieren Sie die Änderungen zwischen den einzelnen Versuchen. Falls das Problem ab einem bestimmten Punkt nicht mehr auftritt, so machen Sie Ihre Änderungen schrittweise wieder rückgängig, bis Sie die Ursache des Problems eingegrenzt haben.

Grenzen Sie die Fehlerbedingung ein

Versuchen Sie die genaue Ursache des Problems einzugrenzen, indem Sie spezielle Einstellungen ändern und dann austesten, ob sich die Ursache für den Fehler ändert oder noch weiter besteht. Wenn Sie z.B. vermuten, dass die Registrierung defekt ist, sollten Sie die Registrierung umbenennen (Datei SYSTEM.DAT), Sie durch die Datei SYSTEM.DA0 ersetzen und es erneut versuchen.

Falls eine Komponente nicht mehr korrekt arbeitet, nachdem Sie einen neuen Treiber installiert haben, so ersetzen Sie den neuen Treiber wieder durch den ursprünglichen und versuchen Sie es erneut. Falls der Computer beim Starten bei einem Real-Modus Treiber stoppt oder falls Sie vermuten, dass ein anderer Gerätetreiber den Fehler verursacht, dann sollten Sie den Computer neu starten und die Taste F8 drücken, wenn die Meldung "Windows 95 wird gestartet..." auf dem Bildschirm erscheint. Wählen Sie dann aus dem Start-Menü "Abgesichert" aus und übergehen Sie beim Laden den Treiber, der vermutlich den Fehler verursacht.

Testen Sie und schreiben Sie die Ergebnisse auf

Testen Sie jede Veränderung separat und überprüfen Sie, ob das Problem dadurch beseitigt wurde.

Schreiben Sie alle Symptome, Ursachen und Lösungen auf. Damit haben Sie sämtliche Informationen zur Hand, falls Sie den Produkt-Support anrufen und es hilft Ihnen bei der Lösung, falls das Problem noch einmal auftritt.

Überprüfen Sie, ob Ihr Problem bereits bekannt ist

Überprüfen Sie die mitgelieferten Textdateien

(ALLGEM.TXT, ANTWORT.TXT, DRUCKER.TXT, usw.), die Online-Hilfe und die FAQs im Windows 95 Forum in Compuserve, ob das Problem bereits bekannt ist.

Sollte das Problem weiterhin bestehen, könnten Sie im entsprechenden Forum in Compuserve eine Anfrage stellen. Andere Benutzer hatten vielleicht das Problem schon und könnten es bereits gelöst oder einen Workaround dafür gefunden haben. Vorschläge von anderen Benutzern könnten Ihnen Zeit bei der Fehlersuche sparen und außerdem nützliche Ideen geben.

Überprüfen Sie, ob neuere Software verfügbar ist

Falls Sie erfahren, dass das Problem mit einer neuen Datei oder Version gelöst ist, sollten Sie auf jeden Fall sicherstellen, ob das ursprüngliche Problem damit gelöst wurde.

Falls Sie einen Workaround für ein spezielles Problem benutzen, sollten Sie den Workaround wieder entfernen, wenn Sie eine neuere Software erhalten. Man vergisst sehr leicht, dass man etwas am System geändert hat, um ein Problem zu lösen. Man sollte überprüfen, ob das ursprüngliche Problem mit der neuen Software behoben ist.

Stellen Sie das System wieder zurück

Bevor Sie einen Computer wieder verlassen, an dem Sie ein Problem beheben, sollten Sie den Computer möglichst wieder in den Originalzustand bringen, in dem Sie ihn vorgefunden haben. Trotz Ihrer Änderungen am System sollten Sie sicherstellen, dass der Computer voll funktionsfähig bleibt.

Tipps zur Problembehebung

Erstellen Sie immer Sicherungskopien der Konfigurationsdateien (vor allem der Datei SYSTEM.DAT).

Erstellen Sie eine Startdiskette und bewahren Sie diese immer auf.

Testen Sie vor Gebrauch die Funktionsfähigkeit Ihrer Startdiskette.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0019.htm


Alle Fehlercodes des Gerätemanagers

Es gibt Dinge, die Microsoft selbst vor Administratoren gut versteckt. So steht es auch mit der Dokumentation zu den Fehlercodes, welche der Gerätemanager gelegentlich anzeigt. In der techn. Referenz zu Windows 95 und Windows 98 wurde ich auch nicht fündig.

In der MS KB unter der ID Q125174 ist dies aber dennoch versteckt.
Hier sind einige Texte noch im Originaltext (Englisch).

Kurzbeschreibung, wie man bei einigen Fehlern vorgehen sollte:

Fehlernummer | Beschreibung
1, 2, 4, 5, 7, 8, 9, 13, 16, 17, 18, 19, 20, 25, 27, 28, 32 | Installieren Sie die benötigten Treiber für das Gerät neu. Am besten das Gerät entfernen, Windows neustarten und die Treiber neu installieren.
3, 14, 21, 26 | evtl. ist nicht genügend Arbeitsspeicher vorhanden
6, 12, 15 | Es besteht ein Adressenkonflikt mit einer anderen Hardware. Stellen Sie die Adressen im Gerätemanager für diese Hardware mit der Hand auf eine freie Adresse ein.
10, 11, 24, 29, 33 | Ist das Gerät richtig angeschlossen? Ist das Gerät eingeschaltet? Ist es im BIOS aktiviert (serielle/parallele Schnittstelle)

Code 1

This device is not configured correctly.

Das System konnte das Gerät nicht konfigurieren.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung.

Code 2

Windows could not load the driver for this device because the computer is reporting two <type> bus types.

The <type> device loader(s) for this device could not load the device driver.

Das Geräteladeprogramm konnte den Gerätetreiber nicht laden.

Entfernen Sie das Gerät im Geräte-Manager.Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Aktualisieren Sie gegebenenfalls den verwendeten Gerätetreiber.

Code 3

The driver for this device may be bad, or your system may be running low on memory or other resources.

Das System hat nicht genügend Arbeitsspeicher.

Entfernen Sie das Gerät im Geräte-Manager und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Vergrößern Sie gegebenenfalls den konventionellen Speicher.

Code 4

This device is not working properly because one of its drivers may be bad, or your registry may be bad.

Die INF-Datei für das Gerät ist ungültig.

z.B. wird ein Eintrag in Textform erwartet, ist aber in binärem Format abgelegt.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, um eine neue INF-Datei zu erhalten.

Code 5

The driver for this device requested a resource that Windows does not know how to handle.

Ein Gerät hat eine Anfrage an einen Ressource-Abitrator gesendet, der nicht vorhanden ist.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung.

Code 6

Another device is using the resources this device needs.

Es besteht ein Ressource-Konflikt mit einem anderen Gerät. Beheben Sie den Ressource-Konflikt.

ARTICLE-ID: Q133240
TITLE: Troubleshooting Device Conflicts with Device Manager

Code 7

The drivers for this device need to be reinstalled.

Für dieses Gerät kann keine Konfiguration erfolgen.

Arbeitet das Gerät korrekt. müssen Sie keine Maßnahmen ergreifen. Arbeitet das Gerät nicht korrekt, entfernen Sie das Gerät im Geräte-Manager und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, oder besorgen Sie sich anderweitig einen neuen Treiber.

Code 8

A system DevLoader is one that is part of Vmm32.vxd, and typically begins with an asterisk (*). If the DevLoader is a system
This device is not working properly because Windows cannot find the file <name> that loads the drivers for the device.

This device is not working properly because the file <name> that loads the drivers for this device is bad.

Device failure: Try changing the driver for this device. If that doesn't work, see your hardware documentation."

Das Geräteladeprogramm für das Gerät konnte nicht gefunden werden. evtl. verweist die INF-Datei des Gerätes auf eine Datei, die nicht existiert.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, um eine neue INF-Datei zu erhalten.

Code 9

This device is not working properly because the BIOS in your computer is reporting the resources for the device incorrectly.

Die Einstellung für dieses Gerät in der Registrierung sind ungültig.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, um gültige Einstellungen für die Registrierung oder einen neuen Treiber zu erhalten.

Code 10

This device is either not present, not working properly, or does not have all the drivers installed.

Es trat ein Fehler beim Starten des Gerätes auf. Entweder fehlt es oder arbeitet nicht korrekt.

Stellen Sie sicher, dass das Gerät korrekt an den Computer angeschlossen ist. Überprüfen Sie z.B. die Kabel. Handelt es sich um ein internes Gerät, stellen Sie sicher, dass es fest im Steckplatz sitzt. Probieren Sie gegebenenfalls einen anderen Steckplatz aus.

Code 11

Windows stopped responding while attempting to start this device, and therefore will never attempt to start this device again.

Das Gerät konnte nicht geladen werden.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Ziehen Sie ASD zu Rate.

Code 12

This device cannot find any free <type> resources to use.

In einem Ressource-Arbitrator trat ein Fehler auf.

Dieser Code kann z.B. auftreten, wenn ein Gerät über Software konfiguriert wurde und momentan keine Ressourcen benutzt, das System keine freien Ressourcen mehr hat oder eine Ressource angefordert wird, die von einem anderen Gerät benutzt und nicht freigegeben wird. Es kommt zu einem Gerätekonflikt. Beheben Sie den Ressource-Konflikt.

ARTICLE-ID: Q133240
TITLE: Troubleshooting Device Conflicts with Device Manager

Code 13

This device is either not present, not working properly, or does not have all the drivers installed.

Ein Gerät konnte auf Grund eines Fehlers im Gerätetreiber nicht geladen werden.

Entfernen Sie das Gerät im Geräte-Manager und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung oder besorgen Sie sich anderweitig einen neuen Treiber.

Code 14

This device cannot work properly until you restart your computer.

Ein aufgetretenes Problem kann durch einen Neustart behoben werden.

Fahren Sie Ihren Computer herunter. Schalten Sie ihn aus und schalten Sie ihn anschließend wieder ein.

Code 15

This device is causing a resource conflict.

Eine Ressource eines Gerätes steht im Konflikt mit der Ressource eines anderen Gerätes. Es kommt zu einem Gerätekonflikt.

Beheben Sie den Ressource-Konflikt.

ARTICLE-ID: Q133240
TITLE: Troubleshooting Device Conflicts with Device Manager

Code 16

Windows could not identify all the resources this device uses.

Das Gerät wurde nicht vollständig erkannt. Das bedeutet, dass evtl. nicht alle Ressourcen korrekt zugewiesen wurden.

Überprüfen Sie die Ressourcen des Gerätes im Geräte-Managerund passen Sie diese gegebenenfalls an.

Code 17

The driver information file <name> is telling this child device to usea resource that the parent device does not have or recognize.

Ein multifunktionales Gerät hat ein Problem. Das bedeutet, die INF-Datei des Gerätes liefert ungültige Informationen über die Trennung der Ressourcen für mehrere Geräte.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, um eine neue INF-Datei zu erhalten.

Code 18

The drivers for this device need to be reinstalled.

Es ist ein Fehler aufgetreten. Das Gerät muss neu installiert werden.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich mit dem Hersteller in Verbindung, um einen neuen Treiber zu erhalten.

Code 19

Your registry may be bad.

Die Registrierung hat unbekannte Ergebnisse zurück geliefert.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung.

Code 20

Windows could not load one of the drivers for this device.

Der VxD-Loader hat ein unbekanntes Ergebnis zurück geliefert. Es kann sich hier z.B. um einen Versionskonflikt zwischen Treiber und Betriebssystem handeln.

Entfernen Sie das Gerät im Geräte-Manage,r und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung.

Code 21

Windows is removing this device.

Ein aufgetretenes Problem kann durch einen Neustart behoben werden.

Fahren Sie den Computer herunter. Startenchalten Sie ihn aus und anschließend wieder ein.

Code 22

This device is disabled.

This device is not started.

Das Gerät wurde deaktiviert. Dabei kann es sich um Geräte handeln, die im BIOS oder im Geräte-Manager deaktiviert wurden.

Aktivieren Sie das Gerät entsprechend im BIOS oder im Geräte-Manager.

Code 23

This display adapter is functioning correctly.

The problem is with the main adapter.

The loaders for this device cannot load the required drivers.

Das Geräteladeprogramm verzögerte den Start eines Gerätes und informierte das System nicht darüber, dass das Gerät gestartet werden kann.

Entfernen Sie das Gerät im Geräte-Manager. Starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung.

Code 24

This device is either not present, not working properly, or does not have all the drivers installed.

Das Gerät wurde nicht gefunden . z.B. fehlt es oder arbeitet nicht korrekt.

Stellen Sie sicher, dass das Gerät korrekt an den Computer angeschlossen ist. Überprüfen Sie entweder die Kabel, oder stellen Sie bei einem internen Gerät sicher, dass es fest im Steckplatz sitzt. Probieren Sie gegebenenfalls einen anderen Steckplatz aus.

Code 25

Windows is in the process of setting up this device.

Dieser Code tritt nur nach dem ersten Neustart während der Installation auf und ist deshalb auch nicht sichtbar.

Es ist keine Maßnahme weiter notwendig.

Code 26

Windows is in the process of setting up this device.

Ein Gerät konnte nicht geladen werden oder es besteht ein Problem mit dem Treiber. evtl. ist dieser beschädigt.

Entfernen Sie das Gerät im Geräte-Manager, und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich mit dem Hersteller in Verbindung, um einen neuen Treiber zu erhalten.

Code 27

Windows can't specify the resources for this device.

Die Einträge in der Registrierung, die mögliche Ressourcen des Gerätes beschreiben, enthalten ungültige Daten. Das Verhalten kann z.B. auftreten, wenn ein Gerät konfigurierbar ist, aber die INF-Datei feste Werte enthält.

Entfernen Sie das Gerät im Geräte-Manager und starten Sie den Hardware-Assistenten über das Symbol Hardware in der Systemsteuerung. Sollte das Problem weiterhin auftreten, setzen Sie sich bitte mit dem Hersteller in Verbindung, um eine neue INF-Datei zu erhalten.

Code 28

The drivers for this device are not installed

Das Gerät wurde nicht komplett installiert.

Aktualisieren Sie den Treiber über die Registerkarte Treiber im Geräte-Manager.

Code 29

This device is disabled because the BIOS for the device did not give it any resources.

Das Gerät wurde deaktiviert, weil es nicht korrekt arbeitet oder nicht zum Arbeiten gebracht werden kann.

Aktivieren Sie das Gerät im BIOS des Computers. Windows kann diese Einstellungen nicht überschreiben. Wenden Sie sich an den Hersteller, wenn Sie nicht wissen, wie Sie Veränderungen am CMOS Ihres Computers vornehmen können.

Code 30

This device is using an Interrupt Request (IRQ) resource that is in use by another device and cannot be shared. You must change the conflicting setting or remove the real-mode driver causing the conflict.

Ein Interrupt kann nicht geteilt werden. Das Verhalten kann auftreten, wenn ein PCI/EISA-SCSI-Controller einen Interrupt mit einem Gerät teilt, das Real-Modus-Treiber benutzt, für die das System keine Treiber besitzt.

Entfernen Sie den Real-Modus-Treiber, der den gleichen Interrupt benutzt. Diese Einträge befinden sich normalerweise in den Dateien AUTOEXEC.BAT oder CONFIG.SYS

Code 31 (neu in Windows 98)

This device is not working properly because <device> is not working properly.

To view the properties for <device> and see why it is not working, click Properties."

where <device> is the dependent device that must be fixed in order for this device to work properly.

Solution button: Properties

This code appears when a device is dependent on another device to be functioning correctly. This does not include devices that are enumerated by the parent device.

The Properties button displays the properties for the other device. More than likely, the other device will also have one of these Device Manager error codes. Follow all the recommended solutions. If the devices still do not work, remove them from Device Manager and use the Add New Hardware wizard to redetect them. Finally, consult with the hardware manufacturer for updated drivers.

Code 32 (neu in Windows 98)

Windows cannot install the drivers for this device because it cannot access the drive or network location that has the setup files on it.

To fix this problem, click Restart Computer to restart your computer. If that doesn't work copy all the setup files onto your local hard disk, and run setup from there.

Solution button: Restart Computer

This code indicates that the installation disk or CD-ROM was not available to install the drivers. For example the CD-ROM drive or network connection is not available. This error typically occurs during the first or second reboot after all the files are copied during Setup.

To resolve this issue, first attempt to restart as suggested. If this does not resolve the problem, determine why the installation disk or CD-ROM is not available. Typically, these devices also have Device Manager codes (such as the CD-ROM controller or network adapter). Resolve the issue to gain access to the installation disk or CD-ROM prior to resolving this conflict.

Code 33 (neu in Windows 98)

The message text that is displayed for this error is specific to the driver or enumerator. If the driver does not provide information as to why it did not work, the following message is displayed:

This device isn't responding to its driver. For more information, contact your hardware vendor.

Solution button: None

This code typically is displayed when the hardware has failed.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0697.htm


Beschreibung der Felder Fehlerbehebung in der Systemsteuerung, System, Leistungsmerkmale, Dateisystem

>> Beschreibung der Felder << Fehlerbehebung in der Systemsteuerung, System, Leistungsmerkeinmale, Dateisystem

Die Registerkarte Fehlerbehebung hilft Ihnen, einen Fehler im Dateisystem zu bestimmen, sollte aber nur in Ausnahmefällen angewendet werden.

Mit jedem Kontrollkästchen, das Sie zusätzlich aktivieren, wird Ihr Rechner langsamer.

Jede Option setzt einen neuen Eintrag in die Registry-Datenbank unter dem folgenden Schlüssel:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Filesystem

Hier die Bedeutung der sechs Optionen:

Mit der Option "Neue Semantik der Dateifreigabe und -sperrung deaktivieren" können Sie die Regeln für die Freigabe von Dateien und das Sperren der Festplatte festlegen. Diese Regeln befassen sich mit der Verteilung von Prozessen auf offene Dateien. Aktivieren Sie diese Option nur, wenn eine MS-DOS Anwendung Probleme mit der Dateifreigabe unter WINDOWS 95 hat (SoftCompatMode=0).

Die Option "Beibehaltung von langen Dateinamen für alte Programme deaktivieren" erhält die langen Dateinamen, wenn eine Anwendung eine Datei öffnet, die keine langen Dateinamen erkennt. Aktivieren Sie diese Option nur, wenn eine wichtige Anwendung keine langen Dateinamen erkennt (PreserveLongNames=0).

Mit der Option "Behandlungsroutinen für Festplatten Interrupt im Protected-Mode deaktivieren" wird eine Funktion ausgeschaltet, mit deren Hilfe WINDOWS 95 Interrupts vom Festplatten-Controller abfängt und die ROM-Routine für diese Interrupts umgeht. Wenn die Option aktiviert ist, werden die Interrupts von der ROM-Routine behandelt (VirtualHDIRQ=1). Wenn Probleme beim Speichern von Dateien auftreten, dann aktivieren Sie diese Option.

Die Option "Synchrone Pufferzuweisung deaktivieren" schaltet die File-Commit API-Funktion aus. Solche Funktions-Aufrufe kehren erst zur Anwendung zurück, wenn die Daten korrekt auf die Festplatte geschrieben wurden. Wenn Sie diese Option aktivieren, initiiert die File-Commit API-Funktion nur das Schreiben der Daten. Die Anwendung erhält die Kontrolle sofort zurück. In diesem Fall wird nicht sichergestellt, dass die Daten korrekt auf die Festplatte geschrieben werden. Das Auswählen dieser Option erhöht keinesfalls die Leistung. Sie kann sogar zu Integritätsfehlern führen. Benutzen Sie diese Option nur, wenn Sie eine Anwendung (z.B. eine Datenbank) einsetzen, die diese Funktion unbedingt benötigt (AsyncFileCommit=1)

Die Option "32-Bit-Datenträgertreiber für den Protected-Mode deaktivieren" schaltet alle 32-Bit Protected-Mode Treiber für Festplatten aus. Die Option dient nur zur Fehlerbehebung. Sollte der Rechner auf Grund eines Ein-/Ausgabefehlers nicht richtig starten, aktivieren Sie diese Option. Alle Ein-/Ausgabezugriffe werden dann über Real-Mode Treiber oder das BIOS erledigt. Dabei kann es passieren, dass Sie nicht mehr alle Laufwerke in WINDOWS 95 sehen können (ForceRMIO=1).

Die Option "Verzögertes Schreiben für alle Laufwerke deaktivieren" schaltet die Schreibverzögerung aus und sorgt dafür, dass die zu schreibenden Daten direkt auf den Datenträger geschrieben und nicht erst im Cache zwischengespeichert werden. Sie sollten diese Option nur aktivieren, wenn Sie systemkritische Aufgaben erledigen, da Sie hiermit auf alle Vorteile der Schreibverzögerung verzichten (DriveWriteBehind=0).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0887.htm


Reaktion bei Fehler (ErrorControl)

Das Verhalten des Systems im Falle eines Fehlers beim Laden eines Treibers wird durch den Wert "ErrorControl" als Datentyp REG_DWORD) eingestellt.

Diesen Wert finden Sie in jedem Service-Schlüssel unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\

können Sie in den jeweiligen "Teilschlüsseln" durch "ErrorControl" einstellen, was passieren soll:

Wert | Bedeutung
0x3 | Schwerer Fehler: Abbruch des Systemstartes und Neustart mit "LastKnownGood", ist der Fehler beim "LastKnownGood" aufgetreten, wird eine Überprüfungsroutine gestartet.
0x2 | Fehler: Wechseln zu "LastKnownGood", wurde schon mit "LastKnownGood" gestartet, wird der Systemstart mit einem Fehler fortgesetzt.
0x1 | Normal: Ausgeben einer Fehlermeldung und Systemstart fortsetzen
0x0 | Ignorieren: Keine Fehlermeldungen ausgeben und Systemstart fortsetzen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0385.htm


Fehlerprotokoll unter Windows erstellen

Sie können sich unter Windows ein Fehlerprotokoll erzeugen lassen, um evtl. Fehler leichter zu finden. Dazu müssen Sie in der Registry folgenden Wert anlegen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Fault

erstellen Sie hier einen neuen Eintrag mit dem Namen "LogFile" als Datentyp REG_SZ. Geben Sie als Wert den kompletten Pfad und den Dateinamen für das Logfile an, z.B. C:\Errorlog.txt

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1041.htm


Informationen über die Datei BOOTLOG.TXT

Die Datei BOOTLOG.TXT ist eine ASCII-Textdatei, in der alle Informationen über den Startvorgang von Windows enthalten sind. Bei der Installation und beim Starten (wenn die Option "Protokolliert" ausgewählt wurde) trägt Windows sämtliche Schritte des Startvorgangs inklusive evt.r Fehlermeldungen in diese Datei ein. BOOTLOG.TXThilft Ihnen bei der Problembehebung, falls der Startvorgang fehlschlägt.

Die Datei BOOTLOG.TXT wird bei der Installation automatisch erstellt. Während des Startvorgangs können Sie sie erstellen, indem Sie, sobald die Meldung "Windows 95 wird gestartet..." erscheint, die Taste F8 drücken und im Start-Menü die Option "Protokolliert" (BOOTLOG.TXT) wählen. Die Datei BOOTLOG.TXT wird im Hauptverzeichnis Ihres Startlaufwerks (normalerweise Laufwerk C:\) angelegt.

Struktur der Datei BOOTLOG.TXT

Während des Startvorgangs wird jeder Schritt in die Datei BOOTLOG.TXT eingetragen. Sollte beim Starten ein Fehler auftreten, können Sie anhand dieser Einträge seine Ursache feststellen.

Die Datei BOOTLOG.TXT ist in fünf Abschnitte unterteilt:

  1. ATXul0 Laden von Real-Modus Treibern
  2. Laden von VxDs
  3. Systemkritische Initialisierung von VxDs
  4. Initialisierung der Geräte von VxDs
  5. Erfolgreiche Initialisierung eines VxD

1. Laden von Real-Modus Treibern (Beispiel eines Abschnittes)

; Laden von Real-Modus Treibern.

; Falls Windows 95 wegen zu wenig XMS-Speicher nicht startet, überprüfen Sie, ob HIMEM.SYS geladen wird.

Loading Device = G:\WIN95\HIMEM.SYS

LoadSuccess = G:\WIN95\HIMEM.SYS

Loading Device = G:\WIN95\SETVER.EXE

LoadSuccess = G:\WIN95\SETVER.EXE

Loading Device = G:\WIN95\EMM386.EXE

LoadSuccess = G:\WIN95\EMM386.EXE

Loading Device = G:\WIN95\DBLBUFF.SYS

LoadSuccess = G:\WIN95\DBLBUFF.SYS

; Falls Windows 95 auf Ihrer SCSI-Festplatte nicht startet, überprüfen Sie, ob DBLBUFF.SYS geladen wird.

Loading Device = G:.SYS

LoadSuccess = G:.SYS

2. Laden von VxDs (Beispiel eines Abschnittes)

; Laden von Windows 95 Virtual Device Drivers

Loading Vxd = VMM

LoadSuccess = VMM

Loading Vxd = G:\DBLSPACE.BIN

LoadSuccess = G:\DBLSPACE.BIN

; Falls Sie auf D??SPACE-Laufwerke nicht zugreifen können, überprüfen Sie, ob der Kompressionstreiber geladen wird.

Loading Vxd = CONFIGMG

LoadSuccess = CONFIGMG

Loading Vxd = IOS

LoadSuccess = IOS

Loading Vxd = VFAT

LoadSuccess = VFAT

Loading Vxd = vserver.vxd

LoadFailed = vserver.vxd

--(das obere Beispiel zeigt einen Fehler beim Laden eines VxDs)

3. System-critical Initialisierung von VxDs (Beispiel eines Abschnittes)

SYSCRITINIT = VMM

SYSCRITINITSUCCESS = VMM

SYSCRITINIT = CONFIGMG

SYSCRITINITSUCCESS = CONFIGMG

SYSCRITINIT = VFAT

SYSCRITINITSUCCESS = VFAT

4. Initialisierung der Geräte von VxDs (Beispiel eines Abschnittes)

DEVICEINIT = VMM

DEVICEINITSUCCESS = VMM

DEVICEINIT = CONFIGMG

DEVICEINITSUCCESS = CONFIGMG

DEVICEINIT = VFAT

DEVICEINITSUCCESS = VFAT

5. Erfolgreiche Initialisierung von VxDs (Beispiel eines Abschnittes)

INITCOMPLETE = VMM

INITCOMPLETESUCCESS = VMM

INITCOMPLETE = COMFIGMG

INITCOMPLETESUCCESS = CONFIGMG

INITCOMPLETE = SCSIPORT

INITCOMPLETESUCCESS = SCSIPORT

INITCOMPLETE = VFAT

INITCOMPLETESUCCESS = VFAT

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0127.htm


Alle Fehlercodes des DFÜ-Netzwerks

(Fast) alle Fehlercodes des DFÜ-Netzwerks

Bei einem Verbindungsaufbau zeigt das DFÜ Netzwerk gelegentlich eine Fehlermeldung mit einer Nummer. In der KB von Microsoft unter der Nummer Q163111 sind alle Fehlercodes aufgelistet:

600 An operation is pending.

601 The port handle is invalid.

602 The port is already open.

603 Caller's buffer is too einmall.

604 Wrong information pecified.

605 Cannot set port information.

606 The port is not connected.

607 The event is invalid.

608 The device does not exist.

609 The device type does not exist.

610 The buffer is invalid.

611 The route is not available.

612 The route is not allocated.

613 Invalid compression specified.

614 Out of buffers.

615 The port was not found.

616 An asynchronous request is pending.

617 The port or device is already disconnecting.

618 The port is not open.

619 The port is disconnected.

620 There are no endpoints.

621 Cannot open the phone book file.

622 Cannot load the phone book file.

623 Cannot find the phone book entry.

624 Cannot write the phone book file.

625 Invalid information found in the phone book.

626 Cannot load a string.

627 Cannot find key.

628 The port was disconnected.

629 The port was disconnected by the remote machine.

630 The port was disconnected due to hardware failure.

631 The port was disconnected by the user.

632 The structure size is incorrect.

633 The port is already in use or is not configured for Remote Access dialout.

634 Cannot register your computer on the remote network.

635 Unknown error.

636 The wrong device is attached to the port.

637 The string could not be converted.

638 The request has timed out.

639 No asynchronous net available.

640 A NetBIOS error has occurred.

641 The server cannot allocate NetBIOS resources needed to support the client.

642 One of your NetBIOS names is already registered on the remote network.

643 A network adapter at the server failed.

644 You will not receive network message popups.

645 Internal authentication error.

646 The account is not permitted to log on at this time of day.

647 The account is disabled.

648 The password has expired.

649 The account does not have Remote Access permission.

650 The Remote Access server is not responding.

651 Your modem (or other connecting device) has reported an error.

652 Unrecognized response from the device.

653 A macro required by the device was not found in the device.INF file section.

654 A command or response in the device.INF file section refers to an und efined macro

655 The <message> macro was not found in the device.INF file section.

656 The <defaultoff> macro in the device.INF file section contains an und efined macro

657 The device.INF file could not be opened.

658 The device name in the device.INF or media.INI file is too long.

659 The media.INI file refers to an unknown device name.

660 The device.INF file contains no responses for the command.

661 The device.INF file is missing a command.

662 Attempted to set a macro not listed in device.INF file section.

663 The media.INI file refers to an unknown device type.

664 Cannot allocate memory.

665 The port is not configured for Remote Access.

666 Your modem (or other connecting device) is not functioning.

667 Cannot read the media.INI file.

668 The connection dropped.

669 The usage parameter in the media.INI file is invalid.

670 Cannot read the section name from the media.INI file.

671 Cannot read the device type from the media.INI file.

672 Cannot read the device name from the media.INI file.

673 Cannot read the usage from the media.INI file.

674 Cannot read the maximum connection BPS rate from the media.INI file.

675 Cannot read the maximum carrier BPS rate from the media.INI file.

676 The line is busy.

677 A person answered instead of a modem.

678 There is no answer.

679 Cannot detect carrier.

680 There is no dial tone.

681 General error reported by device.

682 ERROR WRITING SECTIONNAME

683 ERROR WRITING DEVICETYPE

684 ERROR WRITING DEVICENAME

685 ERROR WRITING MAXCONNECTBPS

686 ERROR WRITING MAXCARRIERBPS

687 ERROR WRITING USAGE

688 ERROR WRITING DEFAULTOFF

689 ERROR READING DEFAULTOFF

690 ERROR EMPTY INI FILE

691 Access denied because username and/or password is invalid on the domain.

692 Hardware failure in port or attached device.

693 ERROR NOT BINARY MACRO

694 ERROR DCB NOT FOund

695 ERROR STATE MACHINES NOT STARTED

696 ERROR STATE MACHINES ALREADY STARTED

697 ERROR PARTIAL RESPONSE LOOPING

698 A response keyname in the device.INF file is not in the expected format.

699 The device response caused buffer overflow.

700 The expanded command in the device.INF file is too long.

701 The device moved to a BPS rate not supported by the COM driver.

702 Device response received when none expected.

703 ERROR INTERACTIVE MODE

704 ERROR BAD CALLBACK NUMBER

705 ERROR INVALID AUTH STATE

706 ERROR WRITING INITBPS

707 X.25 diagnostic indication.

708 The account has expired.

709 Error changing password on domain.

710 Serial overrun errors were detected while communicating with your modem.

711 RasMan initialization failure. Check the event log.

712 Biplex port is initializing. Wait a few seconds and redial.

713 No active ISDN lines are available.

714 Not enough ISDN channels are available to make the call.

715 Too many errors occurred because of poor phone line quality.

716 The Remote Access IP configuration is unusable.

717 No IP addresses are available in the static pool of Remote Access IP addresses.

718 PPP timeout.

719 PPP terminated by remote machine.

720 No PPP control protocols configured.

721 Remote PPP peer is not responding.

722 The PPP packet is invalid.

723 The phone number, including prefix and suffix, is too long.

724 The IPX protocol cannot dial-out on the port because the computer is an IPX router.

725 The IPX protocol cannot dial-in on the port because the IPX router is not installed..

726 The IPX protocol cannot be used for dial-out on more than one port at a time.

727 Cannot access TCPCFG.DLL.

728 Cannot find an IP adapter bound to Remote Access.

729 SLIP cannot be used unless the IP protocol is installed.

730 Computer registration is not complete.

731 The protocol is not configured.

732 The PPP negotiation is not converging.

733 The PPP control protocol for this network protocol is not available on the server.

734 The PPP link control protocol terminated..

735 The requested address was rejected by the server..

736 The remote computer terminated the control protocol.

737 Loopback detected..

738 The server did not assign an address.

739 The remote server cannot use the Windows NT encrypted password.

740 The TAPI devices configured for Remote Access failed to initialize or were not installed correctly.

741 The local computer does not support encryption.

742 The remote server does not support encryption.

743 The remote server requires encryption.

744 Cannot use the IPX net number assigned by the remote server. Check the event log.

752 A syntax error was encountered while processing a script.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0679.htm


SCANREG Fehlermeldungen

Wenn Sie Scanreg im DOS -Modus ausführen, werden folgende Errorlevel-Werte verwendet:

0 | kein Fehler
1 | Fehler (behebbar) gefunden
2 | Fehler (nicht behebbar) in REG-Datei
-2 | nicht genug Arbeitsspeicher
-3 | keine REG-Datei gefunden (User.dat oder System.dat)
-4 | USER.DAT oder SYSTEM.DAT lässt sich nicht anlegen
-5 | REG-Datei nicht lesbar
-6 | USER.DAT oder SYSTEM.DAT lässt sich nicht anlegen
-7 | Zugriffsverletzung ist aufgetreten

Dazu ist in der Datei "SCANREG.INI" der Parameter Optimize=0 einzustellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0650.htm


Sinnvoller Einsatz von Dr. Watson

Bei Fehlermeldungen von Windows muss nicht immer die genannte Datei die eigentliche Fehlerquelle sein. Handelt es sich bei der betreffenden Datei beispielsweise um ein Programm, welches auf andere DLLs zugreift, so benennt Windows nicht die verursachende DLL, sondern vielmehr das zugreifende Programm.

Abhilfe schafft hier das unscheinbare Programm Dr. Watson (DRWATSON.EXE bzw. DRWTSN32.EXEfür Windows NT und Windows 2000), welches zu jeder Windows-Grund-Installation gehört.

Das Programm protokolliert Fehler und speichert diese in einer *.wgl-Datei (im Ordner "%SystemRoot%\drwatson"). Diese Datei enthält alle Informationen zum Zeitpunkt des Absturzes und meist sogar den Hinweis, wie das Problem gelöst werden kann. Eine Fehler verursachende DLL wird hier namentlich genannt.

Der erweiterte Ansichtenmodus (Ansicht -> Erweitert) gibt zudem Auskunft über geladene VXD-Treiber, Autostartprogramme und Tasks (gilt nicht für Windows 2000).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1107.htm


Warum läuft Windows im Kompatibilitätsmodus?

Das kann verschiedene Ursachen haben. Dieser Modus ist definitiv langsamer als der 32 Bit Modus.

  • Laufwerk mit Stacker <= 4.x komprimiert
  • Laufwerks-Controller braucht einen Treiber, der bei Windows 95 nicht vorliegt. -> Hersteller des Controllers fragen
  • Der Controller verwendet einen DOS -Treiber, der INT13 blockiert, so dass Windows 95 nicht die Kontrolle bekommt
  • Diskmanager Version <= 6.03 installiert
  • CD-ROM-Interface wird von Windows 95 nicht unterstützt und es muss der Realmodetreiber verwendet werden oder dieser ist noch installiert.
  • Bootsektorvirus

Windows benutz,t im Gegensatz zu seinen Vorgängern, ein nach Ebenen unterteiltes Filesystem, das sog. "Layered Filesystem", welches aus 31 Ebenen besteht. Dieses System wird vom Input/Output-Supervisor IOS.VXD eingerichtet und kontrolliert. Alle I/O-Anforderungen werden von diesem Treiber verwaltet. Und genau dieser Treiber ist jetzt größtenteils für den Kompatiblen-Modus verantwortlich. IOS.VXD schaltet jedesmal in diesen Modus, wenn irgendwo vor dem Windows-Start Treiber oder TSRs geladen wurden, die "unbekannt" sind. Das bedeutet aber nicht, dass Windows mit diesen Treibern nicht funktioniert; sie sind eben nur nicht bekannt.

Das lässt sich manuell ändern.

Im Windows-Verzeichnis befindet sich die Datei "IOS.INI". Diese Datei ist im ASCII-Format und enthält eine Liste der Treiber bzw. TSRs, die Windows 95 bereits kennt. Diese Liste kann man jedoch beliebig erweitern. In der Regel genügt es, den Treiber bzw. TSR einfach einzutragen. Falls das nicht ausreichen sollte, können dort auch andere Einträge vorgenommen werden.

Aufbau der IOS.INI

Sektion [SafeList]

Hier werden alle Real-Mode-Programme eingetragen, die Windows 95 "kennen" soll. Diese Treiber werden dann in Ebene 29 u. 30 des Filesystems (RMM) angesiedelt undWindows 95 bzw. IOS.VXD kann diese verwalten.

Syntax: Dateiname,[Einschränkung][; Bemerkung]

Dateiname

Name des Realmode-Treibers bzw. TSR ohne Pfadangabe

Bemerkung

Alles nach dem ";" wird ignoriert und dient nur der besseren Lesbarkeit der IOS.INI.

Einschränkung

Hier kann man dem System mitteilen, wie es den RM-Treiber verwalten soll
do_not_care: Gibt an, dass Windows 95 die PM-Treiber verwenden soll und nicht die RM-Treiber unabhängig davon, ob letztere I/O-Anfragen registrieren können oder nicht. [Default-Einstellung]

must_chain: Gibt an, dass der Treiber bzw. TSR sicher ist, aber einen Anspruch auf den INT13 hat. Windows 95 benutzt zwar seine PM-Treiber, gibt aber zuerst den INT13-Aufruf an den RM-Treiber weiter und übernimmt danach erst wieder die Kontrolle über die PM-Treiber.

must_not_chain: Gibt an, dass der Treiber sicher ist, solange dieser keine INT13 Aufrufe verarbeiten darf. Windows 95 benutzt die PM-Treiber und ignoriert den RM-Treiber.

non_disk: Gibt an, dass der Treiber ein Gerät steuert, welches kein "echtes" Laufwerk ist, z.B. Netz-Laufwerke oder Laufwerke, die über Interlink abgebildet werden. Ein derartiger Treiber sollte aber nur im Notfall verwendet werden, da der IOS diesen zwar verwaltet, ihn aber als unsicher (Unsafe) einstuft. Windows 95 bietet genügend Ersatz-Treiber an, die im Protected-Mode arbeiten.

monolithic: Ähnlich wie non_disk, gibt jedoch an, dass der Treiber sicher ist.

Sektion [CDUnsafe]

Hier werden CD-ROM-Treiber eingetragen, die Windows 95 nicht verträgt. Damit lassen sich viele RM-Treiber in Windows 95 einbinden, ohne dass Windows 95 gleich in den kompatiblen Modus wechselt. Ob es sinnvoll ist oder nicht, bleibt jedem selbst überlassen. Auch sollte man RM-Treiber, die von den PM-Treibern nicht unterstützt werden, weil sie spezielle Funktionen beinhalten (z.B.: Treiber für Datenverschlüsselung, Kompressionssoftware, BadSectorMapper, Defragmentierer usw.), nicht in die SafeList eintragen.

Sollte Windows 95 dennoch in den kompatiblen Modus umschalten, legt IOS im Windows-Verzeichnis eine Log-Datei an (IOS.LOG). Diese Datei ist aber nur dann vorhanden, wenn das System im Kompatibilitätsmodus startet. Dort steht dann, welcher Treiber aus welchem Grund verantwortlich ist.

Info Es kann auch an einen Bootsektorvirus liegen!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0251.htm


Debug-Modus beim Windows Update

Mit diesem Tipp können Sie einstellen, ob das Windows Update im Debug-Modus ausgeführt werden soll. Normalerweise wird beim Windowsupdate nur eine Fortschrittsmeldung beim Download und der Installation angezeigt. Mit den Registrywert "SteppingMode" können Sie die Debug-Modus aktivieren. Jetzt wird bei jedem Zwischenschritt ein Dialogfeld angezeigt, welches auch die Möglichkeit zum Abbruch der Aktion anbietet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Active Setup

Erstellen Sie hier einen neuen Wert mit dem Namen "SteppingMode" als Datentyp REG_SZ und setzen den Wert auf:

Y | Es werden Dialogfelder angezeigt
N | Es werden keine weiteren Informationen angezeigt (Standard)

Starten Sie Ihren Rechner neu, damit diese Einstellung aktiv wird.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=178081

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2639.htm


Probleme mit MSI-Dateien (Microsoft Installer)

Wenn Sie Probleme bei der Installation von Programmen durch den Microsoft Installer (MSI) haben, oder wenn sich MSI-Dateien nicht mehr per Doppelklick starten lassen bzw. folgende Fehlermeldung erscheint: Fehlermeldung "Fehler 1719. Auf den Windows Installer-Dienst konnte nicht zugegriffen werden" beim Hinzufügen bzw. Entfernen von Programmen", verfahren Sie bitte folgendermaßen:

  1. Starten Sie den Rechner neu
  2. Leeren Sie das Temp-Verzeichnis (meist %WINDIR% \Temp)
  3. Deaktivieren Sie Antiviren-Programme
  4. Starten Sie Scandisk und Defrag
  5. Versuchen Sie die Installation erneut.

Wenn das nicht hilft, ändern Sie folgendes in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MSIServer

finden Sie den Eintrag "ImagePath" als Datentyp REG_SZ, über prüfen Sie bitte, ob der Pfad zur MSIEXEC.EXE Datei verweist. Der Standardpfad lautet: "%SYSTEMROOT% \System32\msiexec.exe /V".

Starten Sie danach Ihren Rechner im Abgesicherten-Modus (F8-Taste beim Hochfahren drücken und Abgesicherter Modus auswählen).

Klicken Sie auf Start und anschließend auf Ausführen. Geben Sie folgende Zeile ein: msiexec /regserver. Nach einem Neustart solte nun alles wieder laufen.

Info Wenn Sie immer noch Probleme haben, könnte es daran liegen, dass der MSI beschädigt oder veraltet ist. Links zum Download verschiedener MSI-Versionen finden Sie unter "Updates für alle Betriebssysteme".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1275.htm


Bei der Installation erscheint der Fehler: 168

Wurden Programme unter Windows nicht sauber deinstalliert, kann es passieren dass etliche Einträge in der Registry bleiben. Das kann gerade dann zu Problemen führen, wenn diese Programme alte Einträge unter ShaedDLLs zurücklassen.

Diese Einträge finden Sie in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ SharedDLLs

Ein Registry-Schlüssel kann nicht mehr als 64K Daten enthalten. Ist das Limit erreicht und ein Setup Programm versucht weitere Einträge hinzuzufügen, kommt es zu dieser Fehlermeldung.

Mit dem MS-Programm Shrdll.exe können Sie Einträge, die auf nicht mehr vorhandene Dateien verweisen, leicht auffinden und löschen.

Das Programm finden Sie unter:

http://download.microsoft.com/download/vstudio60pro/Utility/1/WIN98/EN-US/Sharedll.exe

Diese selbstextrahierende Datei enthält Shrdll.exe und eine Readme-Datei.

Der Fehler kann weiterhin folgende Ursachen haben:

  • Fehlende Berechtigung zum Ändern der Registry (NT/2000)
  • Zu viele Fonts installiert bzw. die Namen der Fonts nehmen zu viel Platz in der Registry ein

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
Office97: http://support.microsoft.com/?kbid=163277und http://support.microsoft.com/?kbid=173045
Office97 SetupFix: http://support.microsoft.com/?kbid=186073
MDAC/ADO/RDS: http://support.microsoft.com/?kbid=177514
Visual Studio/ Visual Basic: http://support.microsoft.com/?kbid=185647
Visual Basic: http://support.microsoft.com/?kbid=189625
Software auf 2000-Server: http://support.microsoft.com/?kbid=233587
Visual Studio + Crystal Reports 8: http://support.microsoft.com/?kbid=268553
Visual Studio auf NT: http://support.microsoft.com/?kbid=296108

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0634.htm


Probleme mit AMD K6 Prozessor ab 350 MHz unter Windows

Wenn man stolzer Besitzer eines AMD K6-2 Prozessors mit 350 MHz oder mehr ist, können folgende Fehlermeldungen beim Starten oder beim Installieren von Windows angezeigt werden:

  • Geräte-E/A-Supervisor konnte nicht initialisiert werden. Windows-Schutzfehler. Starten Sie den Computer neu.
  • Windows-Schutzfehler. Starten Sie den Computer neu.
  • Beim Initialisieren des Geräte-E/A-Supervisors: Windows-Schutzfehler

Folgende Artikel der MS Knowledge Base befassen sich mit diesem Problem:

Links zum Download der Patches finden Sie hier: Probleme mit AMD K6 unter Windows 95 beheben

Info Dieser Fehler tritt nur bei Windows 95 auf. Für Windows 98 Benutzer läuft alles Normal, hier gibt es allerdings ein Problem mit dem USB-Port, wenn ein Prozessor schneller als 350 MHz zum Einsatz kommt.

Hierzu können Sie unter http://support.microsoft.com/?kbid=240075 einen Patch herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0180.htm


Installation von Windows wird mit Dateinamenfehler abgebrochen

Wird die Installation mit einem "Dateinamenfehler" abgebrochen, liegt es meist daran, dass die Möglichkeit zum Erstellen von numerischen Dateinamenserweiterungen deaktiviert wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_ LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

löschen Sie den Eintrag "NameNumericTail".

Siehe auch: Kurze Dateinamen ohne Tilden

Info Auf der Windows 98 CD ist im Verzeichnis Tools\Mtsutil (Windows ME: Tools\Pssutil) die Datei NNT.INF enthalten, welche den REG-Eintrag selbständig ändert. Die Datei wird über die rechte Maustaste/Installieren ausgeführt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0141.htm


Schriftarten installieren steht nicht zur Verfügung

Wenn im Ordner "Schriftarten" im Menü "Datei" die Auswahl "Neue Schriftart installieren" nicht zur Verfügung steht, kann das an einem der folgenden Punkte liegen:

  • Überprüfen Sie (z.B. mit dem Explorer), ob für den Schriftarten-Ordner (..\WINDOWS\FONTS) das Attribut "System" gesetzt wurde. Es ist unbedingt erforderlich! Wenn nicht, setzen Sie es durch die Eingabe von "attrib +s %WINDIR%\fonts" in der MS-DOS Eingabebox.
  • Des weiteren kann es auch daran liegen, dass die Datei "fontext.dll" nicht mehr vorhanden ist. Ist das der Fall, können Sie die Datei wieder von der Original CD selber entpacken:
    - Unter Windows 95: extract /a WIN95_11.CAB /l %WINDIR%\system
    - Unter Windows 98: extract /a WIN98_31.CAB /l %WINDIR%\system
  • Es fehlt im Windows-Fonts Ordner die Datei "DESKTOP.INI"
    - Unter Windows 95: extract /a WIN95_03.CAB /l %windir\fonts
    - Unter Windows 98: extract /a WIN98_43.CAB /l %windir\fonts
  • Es fehlen die nötigen Registry-Einträge. Kopieren Sie alle folgenden Befehle in eine Datei (z.B. mit Notepad anlegen) und speichern Sie die Datei mit einem beliebigen Namen ab, als Endung muss die Datei aber .REG und nicht .TXT haben. Klicken Sie nun einfach die Datei mit der rechten Maustaste an und wählen Sie "Zusammenführen".

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}]
@="Schriftarten"
[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\InProcServer32]
@="fontext.dll"
"ThreadingModel"="Apartment"
[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\DefaultIcon]
@="fontext.dll,-101"
[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\Hierarchical]
@="0"
=== Hier schneiden ===

Info Das MS-Tool Tweak UI 1.33 bietet Ihnen die Möglichkeit, Ordner Schriften wieder zu reparieren (und noch viele weitere nützliche Einstellungen). Siehe auch "Tweak UI 1.33: Alle Funktionen im Überblick".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0211.htm


Fehler bei Erstellung von Win2000 Startdisketten unter Win95/98

Fehler bei Erstellung von Windows 2000 Startdisketten unter Windows 95/98

Bei der Erstellung der Setup-Startdisketten für Windows 2000 mit dem Befehl Makeboot.exe erhält man unter Windows 95 und Windows 98 nur undefinierbare Zeichenfolgen.

Um dies zu beheben, deaktiviert man in der Config.sys die Zeile

"Country=*,*,C:\WINDOWS\COMMAND\country.sys"

mit einem REM. (REM Country=*,*,C:\WINDOWS\COMMAND\country.sys)

Starten Sie nun Ihren Computer neu, danach können Sie die Bootdisketten ohne Fehler erstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0833.htm


Programme stürzen mit Fehler im ACMSETUP ab

Bei der Installation von MS Programmen kann es zu einem Fehler: "ACMSETUP caused an invalid page fault in module KERNEL32.DLL at 0177:bff7be97" kommen.

Dieser tritt in der Regel auf, wenn der DMA-Modus für CD-ROM Laufwerke aktiviert wurde. Zur Deaktivierung des DMA-Modus geht man im Gerätemanager auf das entsprechende Laufwerk und deaktiviert dort unter Einstellungen den DMA-Modus

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0353.htm


Installation von Windows wird mit fehlerhafter CAB-Datei abgebrochen

Wird bei Ihnen die Installation von Windows mit der Fehlermeldung beendet, dass eine CAB-Datei defekt ist bzw. eine Datei nicht gefunden werden kann, muss das nicht an der CD liegen.

Wenn die CD keine Fehler aufweist, kann es auch an falschen BIOS -Einstellungen Ihres Rechners liegen. Meist sind dann die Timingzeiten des Hauptspeichers falsch eingestellt. Stellen Sie die Werte (meist unter "Chipset features" bzw. "Chip configuration") auf größere Werte ein und versuchen Sie das Setup noch einmal neu.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0524.htm


Verknüpfungen von Ordner auf dem Desktop

Unter Windows kann man Verknüpfungen von Ordner auf den Desktop legen, um schneller in die Verzeichnisse wechseln zu können. Diese Verknüpfungen sind Dateien, die als Dateiendung "LNK" haben. Aus diesem Grunde sollte man auch beim Erstellen von eigenen Dateien diese Dateiendung nicht benutzen, da man solche Dateien dann nicht mehr laden kann.

Leider gibt es in Windows (Win95, Windows 98 und NT bis Service Pack 4) einen groben Fehler.

Fast alle Programme benutzen zum Speichern von Dateien eine Microsoftfunktion, um in einen bestimmten Ordner zu wechseln und dort dann die Datei zu speichern. Wenn man auf eine bestimmte Weise vorgeht, wird diese Datei immer mit der Endung "LNK" gespeichert und ist somit danach nicht mehr über Windows zu laden. (Sie müssen die Endung dann selber durch die richtige Dateiendung ersetzen, um auf diese Datei zugreifen zu können).

Hier ein Beispiel, wie das passieren kann.

  1. Erstellen Sie eine Verknüpfung zu einem beliebigen Verzeichnis auf dem Desktop
  2. Starten Sie Notepad
  3. Tippen Sie irgendetwas ein und gehen Sie dann auf Speichern
  4. Nun erscheint ein Fenster mit der Möglichkeit zur Auswahl des Verzeichnisses, wo die Datei gespeichert werden soll. Gehen Sie hier über das Icon "Übergeordneter Ordner" (das Icon mit dem Pfeil und dem Ordnersymbol) so lange nach oben, bis Sie auf dem "Desktop" sind.
  5. Klicken Sie hier nun Ihre Verknüpfung für das Verzeichnis an
  6. Windows geht nun in das Verzeichnis. Wenn Sie nun auf "Speichern" klicken, wird die Datei mit der Dateiendung "LNK" abgespeichert und es ist nicht mehr möglich, die Textdatei wieder aufzurufen.

Info Unter Office tritt dieser Fehler nicht auf, da Office eine eigene Routine zur Auswahl des Ordners verwendet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0714.htm


Fehlermeldung: "Folgende Datei ist beschädigt oder wurde..."

Hier finden Sie Informationen über den Fehler "Folgende Datei ist beschädigt oder wurde gegen eine ältere Version ausgetauscht".

Problem:

Erscheint bei Ihnen die Fehlermeldung: "Folgende Datei ist beschädigt oder wurde gegen eine ältere Version ausgetauscht:

C:\WINDOWS\ SYSTEM\ DDEML.DLL". Meist kommt diese Fehlermeldung immer genau 2x direkt hinter einander und das, obwohl alles einwandfrei funktionierte.

Etliches Suchen brachte nur die Gewissheit, dass die "DDEML.DLL" in meinem \SYSTEM-Ordner identisch mit der im \SYSBCKUP und der manuell extrahierten von der Windows-CD war. Auch ein Ersetzen brachte keine Besserung.

Abhilfe:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SessionManager\ CheckVerDLLs

finden Sie den Eintrag. Wenn der Eintrag hier groß geschrieben ist, im Gegensatz zu den anderen Einträgen, sollten Sie das ändern. Sie müssen dazu den Eintrag mit F2 umbenennen. Die Umbenennung geht nur über eine Zwischenstufe (DDEML.DLL -> DDEML.DLL_1 -> ddeml.dll).

Danach sollte der Fehler beseitigt sein.

Wenn das ncht hilft dann:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ CheckVerDlls

und unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ WarnVerDlls

finden Sie die Einträge für die Datei, die diese Fehlermeldungen verursacht (hier also DDEML.DLL) und löschen Sie diese Einträge. Nun wird diese Fehlermeldung nicht mehr erscheinen.

Info Sollte diese Datei irgendwann tatsächlich ausgetauscht werden, wird keine Warnung mehr angezeigt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/default.aspx?scid= KB;de;183479

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0139.htm


Fehlermeldung: VFAT Initialisierung fehlgeschlagen

Initialisierungsfehler (Device Initialization Failure) bei VFAT Geräten.

Ein Gerät oder eine Ressource, die von VFAT benötigt wird, ist nicht vorhanden oder nicht verfügbar.

VFAT kann nicht geladen werden.

Diese Fehlermeldung kann unter folgenden Bedingungen auftreten:

  1. Die Datei CONFIG.SYS enthält einen Eintrag, der auf eine vorherige Version der Datei IFSHLP.SYS zeigt.
  2. Der Abschnitt [Paths] in der Datei "MSDOS .SYS" ist kleiner alskB(1024 Byte).
  3. Eine Datei WINBOOT.INI von einer vorherigen, fehlgeschlagenen Installation ist im Haupt-Verzeichnis des Bootlaufwerks vorhanden.

Je nach Zutreffen der oben genannten Bedingungen gibt es folgende Möglichkeiten der Fehlerbehebung:

  1. Starten Sie den Rechner neu.
    • Wenn Sie die Meldung "Windows 95 wird gestartet..." auf dem Bildschirm sehen, drücken Sie die F8 Taste und wählen aus dem Startmenü "Abgesichert, nur Eingabeaufforderung"
    • Öffnen Sie nun die Datei CONFIG.SYS und entfernen die Zeile, welche die Datei IFSHLP.SYS lädt (WINDOWS lädt diesen Treiber automatisch beim Start des Rechners)
    • Speichern Sie die Änderung in der Datei CONFIG.SYS ab und starten den Rechner erneut.
  2. Starten Sie WINDOWS ebenfalls mit der Option "Abgesichert, nur Eingabeaufforderung", wie zuvor unter 1.) beschrieben.
    Geben Sie nun den folgenden Befehl ein:
    attrib -s -h -r MSDOS.SYS
    und drücken dann die Eingabe-Taste
    • Öffnen Sie mit einem Text-Editor die Datei MSDOS .SYS.
    • Überprüfen Sie bitte, ob folgende Zeilen in der Datei MSDOS .SYS korrekt angegeben sind:
      [Paths]
      WinDir=<Windows>
      WinBootDir=<Windows>
      HostWinBootDrv=C
      wobei <Windows> für das WINDOWS Verzeichnis steht. Wenn Sie eine Festplatten-Komprimierungs-Software einsetzen, ändern Sie die Zeile "HostWinBootDrv=" so, dass diese auf das Host-Laufwerk zeigt. Speichern und schließen Sie die Datei MSDOS.SYS.
    • Geben Sie folgenden Befehl ein:
      attrib +s +h +r MSDOS.SYS
    • Starten Sie jetzt den Rechner neu.
  3. Wählen Sie auch hier "Abgesichert, nur Eingabeaufforderung" beim Start des Rechners.
  4. Löschen Sie die Datei WINBOOT.INI im Haupt-Verzeichnis des Bootlaufwerks.
  5. Starten Sie den Rechner neu.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0140.htm


Konvertierung nach FAT32 wird abgebrochen

Wird die Konvertierung nach FAT32 mit der Fehlermeldung "Fehlerhafte Cluster" abgebrochen, können Sie mit einem Trick die Konvertierung trotzdem starten.

Sie sollten vorher aber sicherheitshalber die Festplatte mit Scandisk überprüfen. Sollte danach immer noch die Fehlermeldung erscheinen starten Sie im MS-DOS Modus die Konvertierung folgendermaßen:

cvt c: /noscan /cvt32

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0193.htm


Fehlermeldung beim Zugriff auf "Eigene Dateien"

Beim Zugriff auf den Ordner "Eigene Dateien" erscheint die Fehlermeldung:
"Explorer verursachte eine allgemeine Schutzverletzung..."

Der Fehler tritt auf, wenn der Pfad zum Ordner "Eigene Dateien" nicht mehr stimmt. In der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ UserShellFolders

muss die Zeichenfolge PERSONAL Mit diesem Wert zu einem Ordner vorhanden sein, z.B. C:\Daten. Die Einstellung kann auch mit Tweak UI vorgenommen werden.

Info Weitere Informationen finden Sie dazu in der MS KB unter: http://support.microsoft.com/?kbid=189952

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0920.htm


Dateien können nicht gelöscht/verschoben werden

Wenn beim Versuch, Dateien innerhalb von Windows zu kopieren/verschieben oder umzubenennen eine Fehlermeldung erscheint, dass die Datei X nicht gelöscht werden kann, weil der Pfad nicht gefunden wurde oder ein Dateisystemfehler 1026 auftritt, ist der Papierkorb beschädigt.

Zur Beseitigung des Problems beendet man Windows und wechselt in den DOS -Modus (oder F8 beim Booten -> nur Eingabeaufforderung).

Die Befehle

attrib -r -s -h c:\recycled

und

del c:\recycled

löschen den Papierkorb. Windows erstellt den Papierkorb beim Neustart wieder automatisch.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0926.htm


Die Meldung: "Nicht bereit beim Lesen von Laufwerk" ausschalten

Wenn Sie unter DOS auf ein Laufwerk zugreifen, in dem sich keine Diskette befindet, erscheint die Meldung:

Nicht bereit beim Lesen von Laufwerk A:

(A)bbrechen, (W)iederholen, (U)ebergehen?

Nun müssen Sie (Manchmal mehrmals) die "U" -Taste drücken und dann, wenn die Meldung "Aktuelles Laufwerk nicht mehr gültig" erscheint, einen anderen Laufwerksbuchstaben eingeben.

Mit einer Einstellung in der CONFIG.SYS können Sie die lästigen Abfragen umgehen:

shell=C:\<Pfad>\COMMAND.COM C:\<COMMAND.COM-Pfad>\ /E:256 /P /F

Ab jetzt können Sie immer sofort wieder weiterarbeiten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0077.htm


Fehlermeldung: Fehlende VXD-Datei beim Starten

Erscheint beim Starten des Rechners die Fehlermeldung, dass eine VXD-Datei fehlt, kann das verschiedene Gründe haben.

Meist liegt es daran, dass bei der Deinstallation einer Software bzw. eines Gerätetreibers etwas schief gelaufen ist und aus diesem Grunde noch der Start des Treibers in der Registry eingetragen ist, obwohl die benötigten Dateien schon gelöscht wurden.

Um den Fehler zu beheben, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD

Suchen Sie den in der Fehlermeldung erwähnten Treibernamen. Löschen Sie den ganzen gefunden Schlüssel mit allen weiteren vorhandenen Unterschlüsseln aus der Registry. Nun sollte der Fehler behoben sein.

Info Bei diesem Vorgehen sollten Sie sich aber ganz sicher sein, dass Sie auch den richtigen Schlüssel löschen. Wenn hier der falsche Treiber gelöscht wird, kann es sein, dass Ihr System nicht mehr startet! Sichern Sie daher lieber vorher Ihre Registry, um sie im Fehlerfalle wieder unter DOS herstellen zu können (siehe dazu: Die Registrydatenbank unter DOS bearbeiten).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0469.htm


Fehlermeldung: Error 1606 Could not access network location

Fehler:

Es kann unter Windows vorkommen, dass man ein bestimmtes Programm nicht installieren kann, da bei jedem Versuch, das Programm zu installieren, die Fehlermeldung "Error 1606 Could not access network location" bzw. "Fehler beim Zugriff auf die Netzwerkadresse..." erscheint.

Bisher ist mir bekannt, dass diese Fehlermeldung beim Versuch der Installationen von:

- Frontpage

- Works

- Omni Page Pro 10

- MS Technet

- WinOnCD

- Norton Personal Firewall

- CorelDraw

und anderen aufgetreten ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Lösung:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

den Wert der Einträge "RECENT" (Datentyp REG_SZ) auf ein vorhandenes Verzeichnis abändern oder den Eintrag einfach löschen, nachdem man den entsprechenden Registryzweig exportiert (gesichert) hat.

Weiterhin muss der Eintrag "Eigene Dateien" auf ein gültiges Verzeichnis verweisen.

Info Wenn Sie eingestellt haben, dass die Historie der zuletzt genutzten Dateien bei jedem Neustart gelöscht wird (Tweak UI), werden alle Einträge in diesem Verzeichnis gelöscht. Sie sollten also entweder das Recent-Verzeichnis oder ein leeres Verzeichnis angeben.

Windows neu starten.

Wenn das nicht hilft, dann:

... kann es auch am Windows Installer liegen.

Von diesem Problem ist auch bei Office-Installationen berichtet worden. Die Ursache ist oft ein nicht korrekt deinstalliertes Office. Die Lösung brachte das Entfernen der *.msi Dateien aus dem windows\installer\ Verzeichnis, das Löschen des Temp-Verzeichnisses und aller Einträge von Office und Installer aus der Registry (!!).

Ich persönlich finde diese Lösung ziemlich kritisch, auf jeden Fall sollte man vorher eine Sicherung der Registry durchführen.

Den Windows Installer upzudaten ist auch einen Versuch wert. Gehen Sie dafür auf die Downloadseite von Microsoft (http://www.microsoft.com/downloads/Search.aspx?displaylang=de) und suchen Sie nach "Windows Installer" (Suchanfrage: Windows Installer)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0518.htm


Error 5: Access denied (Zugriff verweigert)

Wenn Sie versuchen, mit einem Win3.x-Client auf einen Windows-Server zuzugreifen und trotz korrekter Eingabe von Domäne, Name und Passwort die Fehlermeldung: "Error 5: Access denied (Zugriff verweigert)" erhalten, liegt es daran, dass der Windows-Server mit "Zugriffsteuerung auf Benutzerebene" arbeitet und eine andere Domäne nutzt als der Win3.x-Client.

Um das Problem zu lösen, stellen Sie beim Windows-Server "Zugriffsteuerung auf Freigabeebene" ein, oder wählen Sie am Win3.x Rechner dieselbe Domäne wie beim Windows-Server.

Info Das Problem tritt bei Verbindungen mit NT-Rechnern über DFÜ ebenfalls auf.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0082.htm


Freigaben von Win2000 unter WIN98SE nicht sichtbar

Freigaben von Windows 2000 unter Windows 98SE nicht sichtbar

Wenn in einem Netzwerk die freigegebenen Ordner eines Windows 2000-Rechners auf einem Windows 98 System nicht sichtbar sind, kann es an zu langen Freigabenamen liegen. Max. sind 12 Zeichen zulässig.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1241.htm


Netzwerkfehler 10055

Um den "Netzwerkfehler 10055" zu vermeiden, kann man folgenden Eintrag in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ MSTCP

erhöhen Sie den Wert MaxConnections vom Datentyp REG_SZ auf z.B. "256" (100 ist Standard). Ist der Wert nicht vorhanden, legen Sie ihn an.

Nach einem Neustart sollte der Fehler nicht mehr auftreten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=158474

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1243.htm


DFÜ-Netzwerk meldet Fehler 630

Beim Einwahlversuch ins Internet bedeutet der Fehler 630: "Anschluss wurde auf Grund eines Hardwarefehlers getrennt". Mögliche Ursache könnte eine Fehleinstellung in der Systemsteuerung unter "Eingabehilfen" - "Allgemein" - "Externe Eingabehilfen" sein.

Wenn keine solche benutzt wird, sollte die Checkbox deaktiviert werden. Ansonsten muss der COM-Port unter Einstellungen gewechselt werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=227995

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1089.htm


System meldet, dass NTKERN.VXD fehlt

Die Meldung von Windows, dass die NTKERN.VXD fehlt, ist auf einen Bug in Windows zurückzuführen. Die Datei NTKERN.VXD ist zuständig für Tastatur, USB-Controller, Netzwerkkarte und WDM.

Windows packt sechs VXD-Treiber (VDD.VXD, VCOMM.VXD, VMOUSE.VXD, CONFIGMG.VXD, NTKERN.VXD und VDMAD.VXD) in der VMM32.VXD als generischer Treiber.

Das Problem liegt unter Umständen genau hier. Die VMM32.VXD hat schlicht vergessen, einige Treiber mit einzubinden und bringt dann den Fehler, wie oben angegeben. Gerade bei Upgrades des Systems tritt das Problem sehr häufig auf. Zur Abhilfe kann man die betreffenden VXD-Dateien (NUR, wenn diese wie auf der Seite beschrieben, vermisst werden) manuell in das System kopieren.

Info Normalerweise erstellt Windows aus den besagten Dateien die VMM32.VXD. Die Tatsache, dass diese Dateien NICHT auf der Festplatte vorhanden sind, ist daher KEIN Fehler. Wer dennoch die Dateien manuell in das System kopiert, riskiert einen Totalausfall von Windows! Das WinFAQ Team ist nicht für evtl. Fehler durch den Gebrauch der fremden VXDs verantwortlich. Beachten Sie bitte dazu auch folgende Hinweise aus der FAQ: "Fehlende VXD Dateien nach der Installation", "Infos zu VMM32.VXD und Startvorgang" und "Fehlermeldung: NTKERN.VXD".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1163.htm


Fehler 745 - Das Modul zur Sitzungsverwaltung ist ungültig

Sollte beim Aufbau einer DFÜ-Verbindung der Fehler "Fehler 745: Das Modul zur Sitzungsverwaltung ist ungültig" erscheinen, fehlt die Datei Rasapi32.dll oder sie ist beschädigt.

Sollte die Datei auf der Festplatte bereits vorhanden sein, muss diese umbenannt werden. Danach wird die Datei mit dem Befehl in einer DOS BOX für Windows 95 geändert:

extract /a <drive>:\win95\win95_02.cab rasapi32.dll /l c:\<windows>\system

Bei Windows 98 startet man nach dem Umbenennen der Datei die Systemdateiprüfung (SFC) und wählt Wiederherstellen einer Datei, gibt den DLL Namen an und legt die Windows 98 CD ein.

Sollte dies nicht funktionieren, geht man wie folgt vor:

  1. DFÜ-Netzwerk entfernen
  2. rasapi32.dll entfernen oder umbenennen
  3. neue rasapi32.dll von der Windows 95/98-CD ins System-Verzeichnis extrahieren
  4. Löschen des Registry-Schlüssels SMM_Files mittels eines Registry-Editors unter
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RemoteAccess\ Authentication
    (der ganze SMM_Files-Ordner wird gelöscht)
  5. DFÜ-Netzwerk neu installieren

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0796.htm


Fehlermeldung 177 bei Benutzung der Hilfedatei

Bei Benutzung der Suchfunktion einer Hilfedatei kann es passieren, dass Ihnen folgende Fehlermeldung angezeigt wird:

"Das Register Suchen kann nicht angezeigt werden (177)" "Error Message: Unable to Display Find Tab (177)"

Möglichkeit 1:

Ein Fehler ist in der zugehörigen *.FTS-Datei. Diese Datei wird bei der Volltextsuche benutzt und wird automatisch neu angelegt, wenn sie nicht vorhanden ist.

Um das Problem zu lösen, müssen Sie einfach die zugehörige FTS-Datei löschen. Da es meist nicht so einfach ist, die zugehörige FTS-Datei zu finden (der Name ist der gleiche wie der der Hilfedatei), lassen Sie einfach nach der Endung .FTS auf Ihren Rechner suchen und löschen Sie alle Dateien, da diese sowieso neu angelegt werden.

Möglichkeit 2:

Die Datei UPDATE.CNT in z.B. UPDATE.XXX umbenennen und die Datei WINDOWS.GID löschen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=224832

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0554.htm


Scandisk wurde nicht gefunden

Normalerweise sollte Scandisk die Platte prüfen, wenn Windows nicht ordnungsgemäß. gestartet wurde. Auf einigen Systemen ist aber zu beobachten, dass Windows meldet, "Scandisk wurde nicht gefunden ...", obwohl die Datei vorhanden ist. Schuld ist eine beschädigte Win.com, welche z.B. von Programmen wie *Nuts and Bolts* oder 'Norton' verändert wurde.

Zur Fehlerbehebung sucht man die Datei Win.cnf (welche von Microsoft nur umbenannt wurde) in den CAB-Files (bei den meisten Windows 95-Versionen in CAB3) und benennt diese dann unter DOS mit ren WIN.CNF WIN.COM einfach um. Danach muss die Datei nur noch in das Windows-Verzeichnis kopiert werden, um die alte Win.com zu ersetzen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0590.htm


Fehlermeldung: NTKERN.VXD

Wenn Sie versuchen, eine ältere Windows Version über eine neuere Windows Version (OSR 2.x) zu installieren, erhalten Sie diese Fehlermeldung.

Damit Sie die ältere Version trotzdem installieren können, müssen Sie die USB-Unterstützung deinstallieren. Wenn Sie die USB-Unterstützung benötigen, müssen Sie diese nach der Installation wieder nachinstallieren.

Info Siehe auch: "System meldet, dass NTKERN.VXD fehlt".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0614.htm


Probleme beim Servicepack 1 oder 2 von MS Office 97

Eine Voraussetzung für dieses Update auf SP2 ist ein installiertes SP1. Unter manchen Umständen, wenn z.B. das SP1 installiert wurde, nachdem auf Windows 98 upgedatet wurde, werden die Dateien von Office 97 nicht erneuert. Es kommt zu keiner Fehlermeldung, kann aber in der Datei patch.log nachgeprüft werden.

Lösung:

Soll Windows 98 über Windows 95 installiert werden, muss das SP1 vor dieser Aktion gestartet werden. Wird Windows 98 neu installiert, sollte sofort MS Office 97 (ohne vorher den Taskplaner gestartet zu haben) und danach das SP1 installiert werden. Wurde über Windows 95 ohne SP1 upgedatet, muss Office erst wieder installiert werden.

Grund für das Problem ist die Datei Walign.exe von Windows 98, welche bestimmte Dateien leicht verändert, um diese später schneller zu finden und an den Anfang der Platte zu stellen.

Sollte diese Methode scheitern, hilft folgender Kniff:

die beiden Dateien mso97.dll und mso7deu.dll aus dem Office Verzeichnis der Festplatte in ein temporäres Verzeichnis kopieren und von der Office97 CD die original Dateien in das Office Verzeichnis der Platte kopieren, dabei die vorhandenen Dateien überschreiben lassen.

Danach den SR1 Patch starten und anschließend nach einem Neustart die gesicherten Dateien aus dem temporären Verzeichnis wieder zurückkopieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0739.htm


Fehlermeldung: Ein Registrierungsfehler ist aufgetreten....

Sicherlich ist einigen Leuten das leidige Problem bekannt, dass Windows sich auf einmal mit der netten Meldung "Ein Registrierungsfehler ist aufgetreten. Starten Sie den PC neu um die Registrierung zu reparieren." begrüßt.

In den meisten Fällen nützt alles Neustarten nichts, der Fehler bleibt.

Meistens läuft Windows trotz dieser Meldung noch einigermaßen, so dass auch RegClean ausgeführt werden kann. Die Sicherung mit ERU kann man sich dagegen sparen, da es keinen Sinn macht, eine defekte Registry zu sichern. Wenn das nicht geht - einfach überspringen.

Dann den PC neu starten und Windows im Abgesicherten-Modus hochfahren.

Jetzt im Gerätemanager (fast) ALLES entfernen. Lediglich der DFÜ-Adapter, Geräte, die nicht vom Hardwareassistenten erkannt und eingerichtet werden können (z.B. die alte Fritz!-Card) und die Tastatur dürfen stehen bleiben.

Den PC im Normalen-Modus neu starten. Windows wird nun die Hardwareerkennung starten und mit etlichen Neustarts das Hardwaresystem neu einrichten.

Wenn es während und nach dieser Prozedur wieder ohne den Registrierungsfehler startet, war die Reparatur erfolgreich.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0694.htm


Schwerer Ausnahmefehler 0E oder Abstürze ohne Fehlermeldung

Schwerer Ausnahmefehler OE oder Abstürze ohne Fehlermeldung

Wenn diese Fehlermeldung erscheint, liegt es oft an einer falschen BIOS -Einstellung. Man sollte im BIOS Feature Setup den L2 Cache von Wr-Back auf Wr-Through umstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0305.htm


Installierte Schriftarten nicht verfügbar

Fehler 1

Wenn installierte Schriftarten in der Systemsteuerung angezeigt werden, aber in Anwendungen trotzdem nicht zur Verfügung stehen, kann es am fehlenden Drucker (Windows 95-Bug) liegen. Installieren Sie irgendeinen grafikfähigen Drucker, ist der Fehler behoben.

Fehler 2

Des weiteren kann es auch an fehlerhaften Einträgen in der Registry liegen. Um diesen Fehler zu beheben, gehen Sie bitte folgendermaßen vor:

  • Kopieren Sie alle Schriftarten aus dem Windows "Fonts" Verzeichnis (%windir%\Fonts) in beliebiges Tempverzeichnis (z.B. c:\FontTemp)
  • Löschen Sie alle Schriften aus dem Windows "Fonts" Verzeichnis bis auf:
    • framd.ttf
    • frandit.ttf
    • micross.ttf
    • modern.fon
    • script.fon
    • tahoma.ttf
    • tahomabd.ttf

Jetzt müssen Sie in der Registry folgende Änderungen vornehmen - je nach Betriebssystem:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 95/98 und ME
HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Fonts

Ab Windows NT
HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Fonts

Hier löschen Sie alle Einträge aus dem Schlüssel Fonts, bis auf die auch schon oben nicht gelöschten Schriftarten:

  • Franklin Gothic Medium (TrueType) - framd.ttf
  • Franklin Gothic Medium Kursiv (TrueType) - frandit.ttf
  • Microsoft Sans Serif (TrueType) - micross.ttf
  • Modern (Alle Auflösungen) - modern.fon
  • Script (Alle Auflösungen) - script.fon
  • Tahoma (TrueType) - tahoma.ttf
  • Tahoma Fett (TrueType) tahomabd.ttf

Starten Sie den Rechner neu und fügen Sie nun über "Systemsteuerung" -> "Schriftenarten" die Schriften aus dem Temp-Verzeichnis wieder hinzu. Danach können Sie das Verzeichnis wieder löschen.

Nun sollten alle Schriftarten wieder zu Verfügung stehen.

Info Wenn Sie benötigte Schriftarten löschen, kann es dazu führen, dass Windows nicht mehr ordnungsgemäß startet oder komische Buchstaben angezeigt werden. Sie sollten sich ein Backup von der Startpartition anlegen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0189.htm


Beim Zugriff auf den Papierkorb stürzt Windows ab

Wenn Windows 95 beim Zugriff auf den Papierkorb mit einem Fehler abstürzt "Explorer.exe caused an invalid page fault in module kernel32.dll", dann liegt es an der "msvcrt40.dll".

Diese Datei wird bei der Installation oft durch andere Programme ersetzt, was zu diesem Fehler führen kann.

  1. Starten Sie den Rechner nur im DOS-Modus hoch
  2. Löschen Sie die Datei "msvcrt40.dll" aus dem Windows-Verzeichnis
  3. Starten Sie Windows 95 neu
  4. Kopieren Sie eine original "msvcrt40.dll" in das "Windows\System" Verzeichnis.

    5. Eine gültige Datei finden Sie z.B. in folgenden Produkten:
    MS Office 7.0
    MS Plus Pack
    Windows 95 (OEM-Version 2)
    Windows 98/SE: Win_98_36.cab
    MS Internet Explorer (ab 3.01).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0020.htm


Fehlermeldung: Zu wenig WindowMemSize

Die Einstellung gibt an, wie viel konventioneller Speicher Windows zur Verfügung steht.

Der Wert -1 (negativer Wert) erlaubt Windows, soviel Speicherplatz wie nötig zu belegen.

Sollte die Fehlermeldung "zu wenig WindowMemSize" erscheinen, müssen Sie entweder mehr konventionellen Speicher freigeben (sollte unter Windows 95 eigentlich ca. 625-630kBbetragen), oder den Wert WindowMemSize auf einen Wert einstellen, der dem freien konventionellen Speicher auf Ihrem System entspricht (besser noch etwas weniger).

SYSTEM.INI:

[386Enh]

WindowMemSize= -1 (Standardeinstellung)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0130.htm


Allgemeine Schutzverletzung, blauer Bildschirm

Eine sog. 'Allgemeine Schutzverletzung' tritt immer dann auf, wenn ein Konflikt zwischen Hardware, Treibern und Windows besteht. Windows (95, 98, ME) ist aus Kompatibilitätsgründen kein reines 32 Bit-Betriebssystem wie z.B. Windows NT. Daher ist es den Anwendungen erlaubt, direkt auf die Hardware zuzugreifen.

Wenn es häufiger zu Abstürzen der obigen Windows-Betriebssysteme kommt, sollte man zuerst AUTOEXEC.BAT und CONFIG.SYS nach alten 16 Bit-Treibern und TSRs durchsuchen. Wenn Windows einen Ersatz dafür bietet (z.B. CD-ROM), sollten Sie sie löschen. Außerdem könnten Sie versuchen, die Grafik-Beschleunigung zu minimieren (-> "Systemsteuerung" -> "System" -> "Gerätemanager" -> "Leistungsmerkmale" -> "Grafik" und den Regler weiter nach links schieben).

Info Ehemalige Beta-Tester sollten Windows nicht über die Beta-Version kopieren.

Wer Windows als Update installiert, sollte unbedingt alle alten Windows 3.x-Treiber ersetzen (z.B. Grafikkarte).

Besonders beim Update kann es zu Problemen mit Treibern kommen, weil das Update bei der Installation einige Informationen aus der Windows 3.x-SYSTEM.INI übernimmt. Natürlich können auch hier problematische Treiber stehen. Diese befinden sich in der Sektion:

[386Enh]

device= <treibername>.386

VSHARE.386 ==> kann entfernt werden, da es bereits von Windows gestartet wird.

VFINDxx.386 ==> kann ebenfalls entfernt werden, da es von MS-DOS 6.x für das AntiVirus installiert wurde.

In der SYSTEM.INI lassen sich vermutlich noch weitere unnötige Treiber finden, die Sie löschen sollten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0018.htm


RegClean bleibt stehen

RegClean bleibt hängen

Während der Überprüfung der Registry kann es passieren, dass RegClean stehen bleibt und nicht mehr reagiert. Dieses kann durch einen ungültigen Registry-Schlüssel verursacht werden. Um diesen Schlüssel zu ermitteln, gehen Sie wie folgt vor:

  1. Starten Sie RegClean mit dem Befehlszeilenschalter "/L" zum Erstellen der Log-Datei "regclean.log" in dem Verzeichnis, in dem sich RegClean.exe befindet oder verwenden Sie "/L Pfad\Name", um Speicherort und Dateiname explizit anzugeben.
    Achten Sie darauf, dass genügend Plattenplatz vorhanden ist - die Log-Datei kann mehrere MB groß werden.
  2. Wenn RegClean stehen bleibt, öffnen Sie die Log-Datei mit WordPad oder einem Editor ihrer Wahl.
  3. Inspizieren Sie die Einträge am Ende der Log-Datei. Achten Sie auf Fehlermeldungen. In vielen Fällen bleibt RegClean bei einem HELPDIR = "[Nummer]k" Eintrag hängen.
  4. Beenden Sie RegClean über den Taskmanager (Alt-Strg-Entf) und starten Sie den Registrierungs-Editor.
    Suchen Sie den fehlerhaften Eintrag, exportieren Sie vorsichtshalber den entsprechenden Zweig und löschen Sie dann den Eintrag, der das Problem verursacht.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1205.htm


EXE-Dateien lassen sich nicht mit Doppelklick starten

Wenn sich Anwendungen (EXE-Dateien) nur noch per Start - Ausführen starten lassen, aber nicht mehr über ein Icon oder über das Startmenü, können folgende Registry-Einträge helfen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\.exe

setzen Sie Standard (DatentypREG_SZ) auf "exefile" (ohne Anführungszeichen) und

HKEY_CLASSES_ROOT\ exefile\ shell\ open\ command

Standard auf "%1" %* (mit Anführungszeichen).

Sie können auch folgende .REG-Datei erstellen und per Rechtsklick - Zusammenführen in die Registry einpflegen:

=== Hier schneiden ===
REGEDIT4

[HKEY_CLASSES_ROOT\exefile]
"EditFlags"=hex:d8,07,00,00
@="Anwendung"

[HKEY_CLASSES_ROOT\exefile\shell]
@=""

[HKEY_CLASSES_ROOT\exefile\shell\open]
@=""
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shellex]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{86F19A00-42A0-1069-A2E9-08002B30309D}]
@=""

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

=== Hier schneiden ===

Siehe auch "EXE-Dateien können nicht mehr gestartet werden".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1273.htm


Fehlermeldung: Beim Initialisieren des Gerätes VKD...

Wenn Sie beim Starten von Windows folgende Fehlermeldung erhalten: "Beim Initialisieren des Gerätes VKD: Windows Schutzfehler", kann es an einem falschen oder fehlerhaften Tastaturtreiber liegen. Versuchen Sie in diesem Fall folgendes:

  1. Booten Sie den Rechner zur DOS -Eingabeaufforderung.
  2. Wechseln Sie in das Verzeichnis C:\Windows\Command: cd \windows\command
  3. Öffnen Sie die Datei C:\Windows\System.ini mit dem Editor "Edit": edit c:\windows\system.ini
  4. In der Sektion [boot] muss keyboard.drv=keyboard.drv eingetragen sein.
  5. In der Sektion [386Enh] muss keyboard=*vkd eingetragen sein.
  6. Speichern Sie die Änderungen und starten Sie den Rechner neu.

Für diesen, aber auch für alle anderen Schutzfehler kann es sein, dass der Speicher des PCs defekt ist oder zu schnell angesteuert wird; in solchen Fällen können die verschiedenartigsten Schutzverletzungen auftreten.

Stellen Sie im BIOS konservative Timingwerte für den Speicher und ggf. für andere Funktionen ein und schauen Sie, ob der Speicher während des Bootvorgangs korrekt durchgezählt wird. Tauschen Sie ggf. einzelne Module aus.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1279.htm


Fehlermeldung:... ist keine gültige Win32 Anwendung

Wenn Sie beim Installieren oder Starten von Programmen die Fehlermeldung: "... ist keine gültige Win32 Anwendung" erhalten, kann das folgende Ursachen haben:

  1. Ihr System hat einen Virus. Überprüfen Sie den Rechner mit einem aktualisierten Virenscanner.
  2. Der Download der Datei ist fehlerhaft. Laden Sie die Datei erneut herunter. Wenn möglich, probieren Sie eine andere Quelle oder verwenden Sie ein anderes Protokoll (HTTP, FTP).
  3. Wenn Sie zum Downloaden einen Download-Manager verwenden haben, versuchen Sie einen erneuten Download ohne dieses Hilfsprogramm.
  4. Schalten Sie die Option "Proxyserver verwenden" im Internet Explorer ab:
    "Extras" - "Internetoptionen" - "Verbindungen" - "LAN_Einstellungen"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1288.htm


VMM32.VXD Fehlermeldungen

Wenn Sie beim Starten von Windows eine "VMM32.VXD" Fehlermeldung erhalten, können folgende Artikel bzw. Links helfen, die Ursache zu beheben.

Bei Einsatz eines UMAX Scanners oder Verwendung von Genius Scanner Software

Error Message VMM32.VXD Missing-Unable to Load (Q191874):
http://support.microsoft.com/?kbid=191874

UMAX Scanner:

Diese Fehlermeldung tritt in Verbindung mit Prozessoren ab 233 MHz und Boards mit der USB-Schnittstelle. Ersetzen Sie bitte die Datei Umaxis11.386 im Windows und im VistaScan-Verzeichnis durch die aktuelle Version.

Weitere Artikel zum Thema VMM32.vxd

Error Message VMM32.VXD Is Required to Run Windows... (Q194679):
http://support.microsoft.com/?kbid=194679

Missing or Damaged Vmm32.vxd File in OSR2.1 Setup (Q167889):
http://support.microsoft.com/?kbid=167889

Err Msg The Following File is Missing or Corrupted...VMM32.vxd (Q311188):
http://support.microsoft.com/?kbid=311188

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1291.htm


Diskettenlaufwerk läuft nur im Kompatibilitätsmodus

Wenn Sie nicht mehr auf das Diskettenlaufwerk zugreifen können und /oder unter "Eigenschaften von System" - "Leistungsmerkeinmale" angezeigt wird, dass das Laufwerk im so genannten Kompatibilitätsmodus betrieben wird, ersetzen Sie die Datei HSFLOP.PDR im Verzeichnis C:\Windows\System\Iosubsys mit der Datei, die sich auf der Windows-CD befindet.

OS | CAB-Datei
Windows 95 | WIN95_06.cab
Windows 98 | WIN98_48.CAB

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
Extrahieren komprimierter Windows-Originaldateien:
How to Extract Original Compressed Windows Files (Q129605): http://support.microsoft.com/?kbid=129605
Beheben von Diskettenlaufwerkproblemen in Windows
Troubleshooting Floppy Disk Drive Problems in Windows (Q131690): http://support.microsoft.com/?kbid=131690

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1293.htm


Ordner 'Eigene Dateien' wird im 'Datei öffnen' Dialog nicht angezeigt

Wenn Sie in einem Programm "Datei" -> "Öffnen" wählen und der Ordner "Eigene Dateien" nicht angezeigt wird, versuchen Sie folgendes:

  1. Gehen Sie auf "Start" - "Ausführen"
  2. Geben Sie "regsvr32 Mydocs.dll" ein (ohne Anführungszeichen).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1294.htm


Symbole für 'Minimieren', 'Maximieren' und 'Schließen' werden falsch angezeigt

Wenn die Schaltflächensymbole für "Minimieren", "Maximieren" und "Schließen" nicht oder nicht richtig angezeigt werden, oder wenn verschiedene Beschriftungen in diversen Dialogboxen verstümmelt sind, kann unter Umständen der Systemfont "Marlett" beschädigt sein.

Stellen Sie den Font von der Windows-CD (Verzeichnis C:\Windows\Fonts) wieder her:

OS | CAB-Datei
Windows 95 | WIN95_05.CAB oder WIN95_07.CAB
Windows 98 | WIN98_49.CAB
Windows ME | WIN_19.CAB

Nachdem Sie den Font von der CD wiederhergestellt haben, müssen Sie die Dateiattribute "Versteckt" und "System" setzen:

  1. Öffnen Sie die so genannte MS-DOS Eingabeaufforderung (DOS -Fenster)
  2. Wechseln Sie in das Fonts-Verzeichnis: "cd \windows\fonts" (ohne Anführungszeichen)
  3. Geben Sie "attrib +s +h marlett.ttf" ein (ohne Anführungszeichen)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
Extrahieren komprimierter Windows-Originaldateien: http://support.microsoft.com/?kbid=129605
Beschreibung und Fehlerbehebung zur TrueType Schriftart Marlett: http://support.microsoft.com/?kbid=134861

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1295.htm


Fehlermeldung: Fehlernummer 0x80070725 Inkompatible Version des RPC Stub

Wenn Sie bei der Installation von Programmen (mit InstallShield) eine den "RPC Stub" betreffende Fehlermeldung erhalten, kann es an einer fehlerhaften Datei namens Oleaut32.dll liegen. Diese Datei wird häufig durch so genannte AdWare oder SpyWare ausgetauscht.

Zur Behebung des Problems gehen Sie wie folgt vor:

  1. Lassen Sie ihr System mit Ad-aware nach AdWare/SpyWare prüfen
  2. Deinstallieren Sie die von Ad-aware identifizierten Programme
  3. Starten Sie den Rechner neu
  4. Starten Sie Ad-aware erneut, und entfernen Sie die Überbleibsel der deinstallierten Programme aus der Registry und den Systemverzeichnissen
  5. Starten Sie den Rechner neu
  6. Ersetzen Sie nun mit Hilfe von SFC ("Start" - "Ausführen" - "sfc") die Datei Oleaut32.dll mit der Originalversion auf der Windows-CD
  7. Starten Sie den Rechner neu.

Zum Ersetzen von Systemdateien unter NT-basierten Betriebssystemen siehe "Dateien austauschen, die in Benutzung sind".

Ad-aware und Refupdate (zum Aktualisieren der Ad-aware Datenbank) können Sie von http://www.lsfileserv.com/index.html herunterladen.

Die Datei OLEAUT32.DLL finden Sie in folgenden CAB-Dateien:

OS | CAB-Datei
Windows 95 | WIN95_15.CAB
Windows 98 | WIN98_35.CAB
Windows 98 SE | WIN98_38.CAB
Windows ME | WIN_14.CAB
IE 5.5SP2 | MDAC_IE5.CAB

Für Windows 95/98 können Sie auch folgende Dateien für die Reparatur herunterladen, hier ist auch die Datei "OLEAUT32.DLL" enthalten:

Windows 95: DCOM95.EXE

Windows 98: DCOM98.EXE

Weitere Möglichkeiten, den Fehler zu beheben

  • Microsoft Office 2000 oder Office 2000 Komponenten sind installiert:
    Installieren Sie das Office 2000 Service Pack 1 <Download>
  • Microsoft Office 2000 oder Office 2000 Komponenten sind nicht installiert:
    Können Sie den Fehler mit dem Tool MCREPAIR.EXE beheben <Download>

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://www.lsfileserv.com/index.html
Extrahieren komprimierter Windows-Originaldateien:
How to Extract Original Compressed Windows Files (Q129605): http://support.microsoft.com/?kbid=129605
und
InstallShield: Incompatible Version of the RPC Stub http://support.installshield.com/kb/view.asp?articleid=Q105810

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1296.htm


Defrag / Scandisk startet ständig neu

Auf manchen Systemen startet Defrag bzw. Scandisk ständig neu, ohne die Optimierung zu beenden. Grund hierfür sind meist Programme wie Virenscanner etc., welche im laufenden Betrieb Dateien offenhalten, aufrufen oder ändern, während defragmentiert werden soll.

Bekommt man trotz Deaktivierung aller Fehlerkandidaten das Problem nicht in den Griff, kann man optional Defrag bzw. Scandisk auch als Service starten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunServicesOnce

erstellt man einen neuen Wert mit der Bezeichnung "Defrag" als Datentyp REG_SZ und setzt diesen Wert auf Defrag.exe.

Beim nächsten Start wird dann zuerst Defrag ausgeführt, bevor weitere Programme geladen werden. Nach der Ausführung wird der Eintrag automatisch aus der Registry entfernt.

Auf der Installations-CD für Windows 98 befindet sich eine Defrag.inf -Datei im Verzeichnis \win98\tools\mtsutil, die den gleichen Zweck erfüllt. Klicken Sie die Datei mit der rechten Maustaste an und wählen Sie "Installieren".

Info Wenn Sie den Registry Key nicht ändern wollen, gibt es noch eine einfachere Möglichkeit - starten Sie Ihren Rechner im "Abgesicherten-Modus" und führen Sie hier Defrag bzw. Scandisk aus.
Siehe auch "Bildschirmschoner bei DEFRAG verhindern".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0686.htm


Nach dem Formatieren werden keine langen Dateinamen angezeigt

Wenn Sie unter Windows eine Festplatte formatieren, werden im Explorer keine langen Dateinamen mehr angezeigt. Das ist ein Bug von Windows. Wenn Sie F5 zum Aktualisieren drücken, werden die langen Dateinamen wieder angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0616.htm


Fehlermeldung: Zu wenig Stackseiten

Wenn Sie die Fehlermeldung "Zu wenig Stackseiten" erhalten, müssen Sie den Wert MinSPs unter [386Enh] in der SYSTEM.INI anlegen und einen größeren Wert zuweisen (z.B.: MinSPs=4).

  1. Starten Sie Notepad
  2. Öffnen Sie die Datei SYSTEM.INI im Windows-Verzeichnis
  3. Suchen Sie den Abschnitt, der mit [386Enh] gekennzeichnet ist
  4. Prüfen Sie, ob in diesem Abschnitt der Eintrag "MinSPs" vorhanden ist. Sollte das der Fall sein, erhöhen Sie den Wert um 4, andernfalls erstellen Sie eine neue Zeile mit dem Inhalt MinSPs=4

Stackseiten werden von Windows für 32-Bit-Gerätetreiber reserviert. Eine Stackseite belegt 4 KByte und wird auf Anforderung einem Treiber zugeteilt. Wenn nicht mehr genug Stackseiten vorhanden sind, kommt es zu dieser Fehlermeldung.

Mit dem Eintrag "MinSPs=4" legen Sie vier weitere reservierte Stackseiten an. Sollte das nicht ausreichen, erhöhen Sie den Wert in 4er-Schritten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=149083

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0600.htm


Windows-Hilfe erweitern

Dieser Tipp beschreibt die Einbinden der WinFAQ im HLP-Format in die Windows Hilfe. Der Tipp bezieht sich nur auf die alte Help-File Version, für die CHM-Version ist dieser Tipp nicht geeignet.

  1. Einfügen einer Zeile ":include win95faq.cnt" in die Datei "windows.cnt". Position beliebig (vor oder hinter einer anderen include-Zeile).
  2. Erzeugen einer Datei "win95faq.cnt" mit folgenden zwei Zeilen:
    :index Windows 95 FAQ=winfaq.hlp
    :include winfaq.cnt
  3. In der Datei "winFAQ.cnt" die Hierarchiestufen in der ersten Spalte jeweils um 1 erhöhen, also aus 3 wird 4, aus 2 wird 3, usw..
  4. Einfügen einer neuen Zeile "1 Windows FAQ 2000" (Stufe 1) vor der Zeile "2 Infos=Infos" in der Datei winfaq.cnt.
  5. Die Datei "windows.gid" löschen. Windows-Hilfe aufrufen. Fertig.

Die Windows-Hilfe kann auch um andere Hilfe-Dateien erweitert werden.

Einbinden:

Kopieren Sie die Hilfe-Datei (*.HLP und *.CNT), die Sie in die Windows-Hilfe einbinden wollen in das Verzeichnis C:\%WINDIR%\Help.

Öffnen Sie die Datei WINDOWS.CNT mit einem Editor und tragen Sie dort hinter den "Index"-Zeilen und vor den "Link"-Zeilen folgendes ein:

:Index [Name der Hilfe-Datei]=[Dateiname].HLP

"[Name der Hilfe-Datei]" ist der Name, der in der *.CNT Ihrer Hilfe-Datei hinter "Title:" steht. Sollte dort kein Titel vorhanden sein, genügt es, wenn Sie nur den Dateinamen angeben
Dieser Eintrag bewirkt, dass die betreffende *.HLP-Datei aus der Windows 95-Hilfe heraus über ->"Suchen" -> "Optionen" -> "Dateien" aufgerufen werden kann.

  • Fügen Sie am Ende der WINDOWS.CNT folgende Zeile ein:
    :include [Dateiname].CNT
    Dieser Eintrag bewirkt, dass die Themen Ihrer Hilfe-Datei im Inhalt der Windows 95-Hilfe erscheinen.
  • Geben Sie am Ende der Zeile RETURN ein (unbedingt notwendig!) und speichern Sie die WINDOWS.CNT
  • Wenn Sie nun die Windows 95-Hilfe im Start-Menü anklicken, erscheinen die Themen Ihrer Hilfe-Datei im Inhalt und Index und werden der Such-Datenbank hinzugefügt.

Neu Ordnen:

Die meisten Hilfe-Dateien haben ein einzelnes Topic mit Einführung und /oder Copyright-Hinweisen. Verknüpfen Sie eine Hilfe-Datei mit der Windows-Hilfe, wird diese Info im letzten Ordner der ursprünglichen Windows-Hilfe erscheinen. Diese Info können Sie entfernen oder verschieben.

Info Machen Sie eine Sicherheitskopie der betreffenden *.CNT-Dateien.

  • Löschen. Öffnen Sie die *.CNT Ihrer Hilfe-Datei mit einem Editor. Suchen Sie dort die Zeile, die auf das unerwünschte Topic verweist (es ist die 1. Zeile, die mit einer "1" beginnt) und löschen Sie sie dort. Speichern Sie die *.CNT. Damit entfernen Sie das Topic aber nur aus dem Inhaltsverzeichnis, im Index und der Such-Datenbank wird es weiterhin berücksichtigt.

Info Entfernen von Copyright-Hinweisen verstößt gegen das Urheberrecht!

  • Verschieben. Sie können das Topic entweder in einen beliebigen Ordner Ihrer Hilfe-Datei, oder auf die erste Ebene der Windows-Hilfe verschieben.
  • Verschieben in einen Ordner. Öffnen Sie die *.CNT Ihrer Hilfe-Datei, finden dort die Zeile mit dem Namen des Topics, schneiden Sie die ganze Zeile aus und fügen Sie sie dann hinter der Zeile mit dem Namen des gewählten Ordners wieder ein. Speichern Sie die *.CNT.
  • Verschieben auf die oberste Ebene der Windows-Hilfe. Öffnen Sie die *.CNT Ihrer Hilfe-Datei, finden Sie dort die Zeile, die auf dieses Topic verweist und kopieren Sie sie. Öffnen Sie nun die WINDOWS.CNT und fügen dort vor dem ersten Ordner-Namen die aus Ihrer *.CNT kopierte Zeile ein. Ergänzen Sie diese Zeile um folgende Angaben:
    [Zeile aus Ihrer *.CNT]@[Dateiname].HLP>medium.
    Das eingefügte Topic können Sie nun, falls erwünscht, umbenennen.

Info Verändern Sie aber nicht die Angaben hinter dem "=" Zeichen! Diese werden von Windows 95 benötigt. Verändern Sie sie, erscheint das Topic nicht mehr oder es wird beim Anklicken nicht gefunden !

Sollten manche Ordner Ihrer Hilfe-Datei nicht auf der ersten Ebene, sondern als Unterordner im letzten Ordner der ursprünglichen Windows-Hilfe erscheinen, sollten Sie sie eine Ebene höher verschieben. Öffnen Sie in diesem Falle die *.CNT Ihrer Hilfe-Datei mit einem Editor, finden dort die Zeilen, die auf diese Ordner verweisen und ersetzen Sie dort die "2" durch eine "1". Speichern Sie die *.CNT.

Auf diese Weise können Sie natürlich auch die gesamte Anordnung der Ordner und Topics in einer Hilfe-Datei verändern, aber das dürfte viel zu umständlich sein. Benutzen Sie hierfür Entwickler-Tools.

Info Sollten die Änderungen in der Windows-Hilfe nicht erscheinen, müssen Sie die Datei WINDOWS.GID löschen und die Windows-Hilfe erneut starten.

Nun dürfte Ihre Hilfe-Datei nahezu nahtlos in die Windows-Hilfe eingebunden sein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0358.htm


Windows erkennt neues BIOS nicht

Nach einer BIOS -Aktualisierung wird die neue Version nicht in der Systemsteuerung unter System angezeigt. Hierbei handelt es sich um keinen Bug. Windows notiert die BIOS -Version nur bei der Installation und ändert diesen Texteintrag nicht mehr. Die "alten" Einträge stehen in der Registry unter

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Enum\ Root\ PNP0C01\ 0000

und können dort geändert werden, was aber keinen Vorteil bringt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0890.htm


Windows eigene Literatur (auf der CD mitgeliefert)

Wer die englische Sprache beherrscht, findet hilfreiche Informationen zu verschiedenen Themen (Vom Windows Bootmenü bis zur Netzwerkinstallation) auf der Windows CD im Verzeichnis:

ADMIN\RESKIT\HELPFILE\WIN95RK.HLP

Nach der Installation von Windows findet man folgende Dateien im Windows Hauptverzeichnis:

CONFIG.TXT | Enthält Syntaxinformationen für Befehle, die in der CONFIG.SYS verwendet werden.
ANZEIGE.TXT | Enthält Informationen zur Konfiguration der verfügbaren Bildschirmtreiber und zur Behebung von Bildschirmtreiber-Problemen. Außerdem erfahren Sie hier, wie Sie zusätzliche Bildschirmtreiber erhalten.
EXCHANGE.TXT | Enthält Informationen, die Ihnen beim Einrichten und Ausführen von Microsoft Exchange helfen.
EXTRA.TXT | Informationen, wo Sie zusätzlich zu den Dateien, die auf der CD-ROM-Version verfügbar sind, Treiber und Updates finden können.
ANTWORT.TXT | Beantwortet häufig gestellte Fragen zu Windows 95.
ALLGEM.TXT | Informiert Sie über Startprobleme, Programme, die mit Windows 95 geliefert werden, Hilfsprogramme für Datenträger, Disketten und CDs, Treiber, Wechselmedien, Microsoft FAX und Pen-Dienste. Außerdem enthält diese Datei neueste Informationen, die nicht in andere Info-Dateien aufgenommen werden konnten. z.B., wenn Sie eine Frage zu einem Drucker haben, schauen Sie sowohl in der Datei ALLGEM.TXT als auch in DRUCKER.TXT nach.
HARDWARE.TXT | Beschreibt bekannte Hardware-Probleme und deren Behebung. Für bestimmte Probleme sollten Sie auch die Dateien DRUCKER.TXT und MAUS.TXT zu Rate ziehen.
INTERNET.TXT | Enthält Informationen, die Ihnen beim Anschluss an das Internet helfen. Weiterhin erfahren Sie, wo Sie den neuen Web-Browser von Microsoft herunterladen können.
MAUS.TXT | Beschreibt bekannte Maus- und Tastaturprobleme und deren Behebung.
MSDOS DRV.TXT | Enthält Syntaxinformationen für MS-DOS -Gerätetreiber. Weitere Informationen über MS-DOS -Befehle finden Sie unter der Datei CONFIG.TXT. Sie können an der Eingabeaufforderung auch Hilfe zur Befehlszeile aufrufen, indem Sie den Befehlsnamen und /? eingeben.
MSN.TXT | Enthält Informationen, die Ihnen beim Anschluss an das Microsoft Network helfen.
NETZWERK.TXT | Beschreibt Installation und Betrieb von Netzwerk-Servern.
DRUCKER.TXT | Beschreibt bekannte Druckerprobleme und deren Behebung.
PROGRAMM.TXT | Beschreibt, wie Sie bestimmte Windows- und MS-DOS - basierte Anwendungen unter Windows 95 ausführen lassen können.
SUPPORT.TXT | Beschreibt Möglichkeiten, zusätzliche Serviceleistungen für Windows 95 zu erhalten.
TIPS.TXT | Enthält eine Sammlung von Tipps und Tricks zur Verwendung von Windows 95, von denen die meisten nicht in der Online-Hilfe oder den Handbüchern stehen.

Was: | Windows 95 Resource Kit <englisch>
Wo: | Windows 95-CD Pfad >CDROM>:\ ADMIN\ RESKIT\ HELPFILE\ WIN95RK.HLP
 | Tipp: -> "Suchen" ->"Aktualisieren" -> "Suchfunktion maximieren" auswählen interessante Kapitel für Normalbenutzer: Appendixes Windows 95 Reference Installation System Configuration
Was: | Windows 95-Microsoft Knowledge Base <englisch>
Wo: | Internet-Site HTTP://WWW.MICROSOFT.COM/KB
 | Enthält alle Antworten der Microsoft-Hotline und mehr. Wer nicht suchen mag, findet eine Liste aller Q&A der Hotline via FTP unter: FTP://FTP.MICROSOFT.COM/PEROPSYS/WIN95/ KB/ INDEX.TXT
Was: | Microsoft-Internet-Newsgroups
Wo: | Microsoft-News-Server: MSNEWS.MICROSOFT.COM

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0121.htm


Win3.0 - Programme funktionieren unter Windows nicht

Windows 3.0 - Programme funktionieren unter Windows nicht

Manch ältere Windows 3.1-Programme und insbesondere Windows 3.0-Programme arbeiten nicht problemlos unter Windows. Die meisten kann man dennoch unter Windows 95 lauffähig machen und zwar mit Hilfe von "Make Compatible". Dieses Tool ermöglicht es, für jedes Programm besondere Umgebungsvariablen zu setzen. Sie finden es im Windows\System-Verzeichnis unter MKCOMPAT.EXE.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0322.htm


Wie kann ich den Stand-by-Modus einstellen?

Den Stand-by-Modus können Sie auf folgende Weise einstellen:

  1. Mit der rechten Maustaste auf den Bildschirm klicken
  2. "Eigenschaften" wählen
  3. "Einstellungen" wählen
  4. Karteikarte "Konfiguration ändern" wählen
  5. "Bildschirm erfüllt Energy-Star Richtlinien" aktivieren
  6. Karteikarte "Bildschirmschoner" wählen
  7. "StandBy-Betrieb nach" auswählen und einstellen
  8. "Abschalten nach" auswählen und einstellen
  9. Bestätigen und Karteikarte schließen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0350.htm


Was macht die Datei REGSVR32.EXE?

Über die Datei REGSVR32.EXE werden unter Windows DLLs und ActiveX-Steuerelemente in die Registrydatenbank eingetragen. Es werden dabei in der Registrydatenbank neue Class-IDs angelegt, die auf die entsprechende DLL-Datei verweisen. Erst jetzt können diese Funktionen unter Windows genutzt werden. Programme greifen nun auf diese Class-IDs zu, um gewünschte Funktionen auszuführen.

In einigen Fällen kann es vorkommen, dass diese Registrierung nicht stattfindet bzw. die eingetragenen Informationen aus der Registry gelöscht wurden. Wenn Ihnen dann für die Funktion die dafür benötigte DLL bekannt ist, können Sie die DLL mit REGSVR32.EXE neu in Ihrem System registrieren lassen.

Beispiel:

regsvr32 /i <DLL-Name>

Folgende Parameter stehen zu Verfügung:

/u | Deinstallieren
/s | ohne Benutzerausgabe
/i | Registrieren

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0471.htm


Textfarben in Hilfedateien ändern

Die Farben der Hilfe-Dateien kann man in der "WIN.INI" im Abschnitt [Windows help] einstellen:

JumpColor | Definiert die Farbe des Textes, dessen Auswahl zu einer Anzeige eines neuen Fensters führt
PopupColor | Definiert die Farbe des Textes, dessen Auswahl zu einer Anzeige eines PopUp-Fensters führt
IfJumpColor | Definiert die Farbe des Textes, dessen Auswahl zu einer Anzeige eines neuen Fensters führt, dessen Inhalt aus einer neuen Hilfe-Datei stammt
IfPopupColor | Definiert die Farbe des Textes, dessen Auswahl zu einer Anzeige eines neuen PopUp-Fensters führt, dessen Inhalt aus einer anderen Hilfe-Datei stammt

Diesem Wert können Sie nun die gewünschte Farbe im Format "RR GG BB" zuweisen.

Ersetzen Sie "RR", "GG" und "BB" durch den jeweiligen Farbanteil Rot, Grün und Blau.

Farbe | RR | GG | BB
Rot | FF | 00 | 00
Grün | 00 | 00 | FF
Gelb | FF | FF | 00
Cyan | 00 | FF | FF
Magenta | FF | 00 | FF
Braun | A5 | 2A | 2A
Weiß | FF | FF | FF
Schwarz | 00 | 00 | 00

Info Diese Einstellungen sind auch unter "Informationen über WIN.INI" beschrieben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0136.htm


Stromsparfunktionen Einstellungen

Bei Windows 95B lassen sich speziell bei Notebooks noch benutzerspezifische Einstellungen zum Strom sparen einschalten/ändern. Dies betrifft z.B. die Abschaltzeit der Festplatte im Akku- oder Netzbetrieb sowie eine Option, nicht benutzte PC-Cards zu deaktivieren. Die Einstellungen lassen sich über "Start" -> "Systemsteuerung" ->"Energie" -> "Karteikarte Laufwerke" und Karteikarte "PC-Kartenmodems (PCMCIA)" erreichen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0321.htm


Sommer/Winterzeitumstellung - wie geht das?

beschrieben, wo Windows die Konfiguration der Zeitzone ablegt und die Umstellung für die Sommer/Winterzeit speichert. Sie finden diese Einstellungen in der Registry:

Hier wird

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die Zeitzone für Deutschland steht in der Registrydatenbank unter:

Windows 95/98/ME

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Time Zones\ W.Europe\

Ab Windows NT

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Time Zones\ W.Europe Standard Time\

Da steht unter dem Wert TZI als Datentyp REG_BINARY:

C4 FF FF FF 00 00 00 00 C4 FF FF FF 00 00 | 09 00
 | ^-- Winterzeit Ende Monat 9

00 00 05 00 | 03 00 00 00 00 00 00 00 00 00 | 03 00
 | ^-- Umstellung um 3 Uhr | ^-- Sommerzeit Ende Monat 3

00 00 | 05 00 | 02 00 00 00 00 00 00 00
 | ^--- für den letzten Sonntag im Monat | ^-- Umstellung um 2 Uhr

Die Länder mit der GMT (z.B. England) stellen erst Ende Oktober die Zeit um. Unsere Zeitzone entspricht GMT + 1.00. Deshalb werden die ersten vier Hexalwerte in 00 00 0A 00 (wie in GMT) geändert.

Nun erfolgt die Zeitumstellung erst Ende Oktober.

Die "05" in der TZI steht für letzten Sonntag im Monat.Demnach bedeuten

1 : Erster Sonntag

2 : Zweiter Sonntag

3 : Dritter Sonntag

4 : Vierter Sonntag

5 : Letzter Sonntag

Info Geht mit den Kernel-Toys (TZEdit) einfacher!

Patch für Windows 95:

Bei Windows 95 gibt es den Fehler, das dieses System die Winterzeit noch Ende September umstellen möchte, aber eine Umstellung erst im Oktober fällig ist.

=== Hier schneiden ===

REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\TimeZoneInformation]

"StandardStart"=hex:00,00,0a,00,00,00,05,00,03,00,00,00,00,00,00,00

=== Hier schneiden ===

Info Bitte oben aufgeführte Zeilen (grün) in eine Datei mit Endung .REG (z.B. TimePatch.reg) kopieren und ausführen. Anschließend Reboot des Rechners durchführen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0188.htm


Scanner Geschwindigkeit

Preiswerte Scanner haben eine Scan-Geschwindigkeit von ca. 1/2 A4-Seite pro Minuten, um eine zusätzliche Lizenzgebühren zu sparen. (Da es diese Lizenzgebühren nur im deutschen Raum gibt, erhält man durch Installation der englischen Treiber meist eine schnellere Scangeschwindigkeit).

Bei den Mustek-Scannern müssen Sie nicht einmal die englischen Treiber installieren, hier reicht es meist, wenn Sie in der WIN.INI den Eintrag "SLOWSPEEDVER=YES" auf "NO" ändern.

MUSTEK 1200 CP

MUSTEK 1200-CU

Hier wird stattdessen in der Datei "MTWM.INI" der Eintrag "ScanSetting=SLWSPD"

wie SLOWSPEED verwendet.

Nach Löschen dieses Eintrags dauert das Einlesen ein DIN A4 -Seite noch ganze 45 Sekunden, was vorher bei deutlich über 2 Minuten lag.

Info Dieser Tipp hat früher bei den älteren Scannern etwas gebracht. Bei den heutigen neuen Scannern zeigt diese Einstellung keine Wirkung mehr. Der Tipp bleibt aber hier stehen, da einige Leute noch alte Scanner nutzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0444.htm


Registrierungsname ändern

Wer bei der Installation von Windows einen falschen Namen bzw. Firma eingetragen hat, kann das in der Registry unter den unten angegebenen Einträgen ändern. Sie können hier eine neuen Namen und auch die Firmenname ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter Windows 95/98

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

ab Windows NT

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion

finden Sie die Zeichenfolge "RegisteredOwner". Dort können Sie den Namen ändern. Unter "RegisteredOrganization" ändern Sie den Firmennamen.

Info Sie sollten die ganze Registry nach "RegisteredOwner" durchsuchen, da viele andere Programme diesen Schlüsselnamen auch benutzen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0134.htm


Produkttypennummern von Windows

Durch einen Eintrag in der Datei "SETUPPP.INF" wird bestimmt, welche Art der Seriennummer abgefragt wird.

Windows 95 A/B Version

ProduktType = 9

Dies ist der Normale Eintrag in der SETUPPP.inf. Er bewirkt, dass das Setup die 4 teilige OEM-Seriennummer abfragt.

xxxxx-OEM-xxxxxxx-xxxxx

Ohne eine korrekte Nummer wird das Setup nicht fortgesetzt.

ProduktType = 2, = 5 und = 6

Diese Einträge bewirken, dass das Setup eine 10 stellige Produktnummer abfragt. Diese kann mit 'Ignorieren' übergangen werden und die Installation wird fortgesetzt.

Das Setup führt mit keinem dieser Einträge eine Updateprüfung durch. Dies deutet darauf hin, dass bei der Update-Version noch mindestens ein weiterer Unterschied besteht.

ProductType = 1

Dient für Installationen von Windows auf Computern, bei denen die Lizenz extra gekauft wird (z.B. Campuslizenzen für Unis). Dafür gibt es eine eigene CD Edition (je nach Sprache in verschiedenen Farben; Europa hat die Farbe braun), mit denen Mitarbeiter von z.B. EDV Zentren die Rechner installieren können und danach erst die Anzahl der Rechner (respektive deren Software) lizenzieren lassen. Dies gibt es auch für alle anderen Microsoft-Produkte (Windows NT, Office).

Mit diesem Eintrag erfolgt keine Frage nach einer Seriennummer und es wird auch keine Prüfung auf ein vorhandenes Windows durchgeführt.

Info Zumindest der ProductType= 1 kann auch in der MSBATCH.inf eingesetzt werden und hat dann Vorrang vor dem Eintrag in der SETUPPP.INF.

Andere Ziffern als die genannten führen zu einer Fehlermeldung und dem Abbruch des Setup.

Windows 98

ProductType=2 (Update) =9 (OEM)

Obwohl diese Ziffern mit den obigen übereinstimmen, scheinen sie keine Bedeutung mehr zu haben. Auch der ProductType = 1 ist nicht mehr wirksam. Insgesamt ist die Update- und OEM-Prüfung wesentlich verbessert worden und hält auch einige gemeine Fallen bereit.

Als Mittel zu Überprüfung wird jetzt die PRECOPY2.CAB verwendet, die bei der OEM zusätzlich im Setup-Verzeichnis vorhandenen OEMSETUP.* spielen keine Rolle. Wird also die PRECOPY2.CAB ausgetauscht, mutiert ein Update zur OEM und umgekehrt. Wobei sich die Prüfung nicht um eine der darin enthaltenen unterschiedlichen inf-Dateien dreht.

Verbessert wurde die OEM-Installation mittels MSBATCH.INF insofern, dass zwar die Userangaben und Seriennummer mit in der MSBATCH.INF eingetragen werden können und mit einer falschen Seriennummer das Setup bei der OEM auch anfängt, zu arbeiten. Beim ersten Start von Windows 98 werden diese Daten aber dennoch abgefragt und können geändert werden.

Gleichzeitig mit der PRECOPY2.CAB ändert sich auch die Prüfsummenberechnung der Seriennummer. Obwohl das Format der Seriennummer (5 x 5 Zeichen) bei beiden Versionen gleich ist, funktioniert die Nummer eines Updates bei der OEM nicht und umgekehrt.

Siehe hierzu auch CD Schlüssel.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0074.htm


Probleme mit MS Backup auf PCs mit AMD K6-2 CPU

Auszug aus dem Artikel: "Ãnderung der Aktualisierung für die AMD K6-2/350-CPU" der Microsoft Knowledge Base:
http://www.microsoft.com/kb/Germany/support/kb/d42/d42931.htm

Falls Sie die AMD-K6-2-Aktualisierung (Amdk6upd.exe) auf einem Computer installiert haben, auf dem Microsoft Windows 95 OEM Service Release 2 oder 2.1 ausgeführt wird und Sie Microsoft Backup einsetzen, um Sicherungskopien auf bestimmten Typen von Diskettenlaufwerken zu erstellen, wird Ihnen möglicherweise die folgende Fehlermeldung angezeigt:

"Warnung: Das Band muss vor dem Vorgang formatiert werden."

"Microsoft Backup konnte nicht vom Datenträger oder Netzwerklaufwerk lesen.

Beenden Sie Backup, starten Sie es erneut und wiederholen Sie den Vorgang."

"Warnung: Vorgang wurde systembedingt abgebrochen."

Ursache:

Die Version der Datei "Vfbackup.vxd" (4.00.1112), die durch die ursprüngliche AMD-K6-2-Aktualisierung installiert wurde, enthält nicht die Änderungen an der Datei "Vfbackup.vxd", durch die das vorstehend beschriebene Problem gemildert wird. (..)

Hinweise und einen Link zum Download der korrigierten Version der AMD K6-2-Aktualisierung finden Sie unter "Probleme mit AMD K6 Prozessor ab 350 MHz unter Windows".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1282.htm


Anwendung ohne Nachfrage schließen

Hier wird beschrieben, wie Sie beim Herunterfahren von Windows, hängende Anwendungen schnell automatisch beenden lassen können.

Wenn man z.B. eine DOS-Anwendung über den Schließen-Button beendet, wird man mit einer Meldung noch einmal darauf hingewiesen und muss mit "Task-beenden" diese Aktion noch einmal bestätigen.

Wenn Sie diesen Bildschirm nicht mehr sehen wollen, gehen Sie so vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\

Stellen Sie hier den "AutoEndTasks" als Datentyp REG_SZ auf "1".

Bedenken Sie aber, dass nun alle Anwendungen einfach beendet werden, wenn Sie z.B. den Rechner herunterfahren. Das kann natürlich bei 16-Bit Programmen mit geöffneten Dateien zu Datenverlusten führen.

Wenn eine Anwendung sich aufhängt und nicht mehr reagiert, erscheint nach einer gewissen Zeit auch eine Meldung von NT. Diese Wartezeit von Windows können Sie auch unter folgenden Schlüsseln einstellen:

Durch den Wert "HungAppTimeout" als Datentyp REG_SZ wird die Zeit in Millisekunden angegeben bis eine Dialogbox mit der Fehlermeldung erscheint. Der Standardwert hierfür ist 5000 Millisekunden.

Durch einen weiteren Wert "WaitToKillAppTimeout" als Datentyp REG_SZ können Sie festlegen, nach welcher Zeit eine Applikation beim Herunterfahren automatisch beendet werden soll. Der Standardwert hierfür ist 20000 Millisekunden. Nach Ablauf dieser Zeit wird die Applikation je nach Parameter "AutoEndTasks" entweder mit oder ohne Rückfrage beendet.

Info Weitere Infos zu diesen Thema finden Sie noch unter "Herunterfahren des System beschleunigen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0370.htm


Plus-Pack Funktionen ohne Plus-Pack aktivieren

Plus-Pack Funktionen ohne MS Plus aktivieren

Diese Funktionen lassen sich auch ohne MS Plus aktivieren:

  1. im High-Color-Modus Schriften-Anti-Aliasing
  2. Verschieben von Fenstern mit sichtbarem Inhalt
  3. "weiches" Einscrollen der Startleiste

Hat man den msie 4.0 installiert, ist der Eintrag:

HKEY_CURRENT_USER\ Control Panel\ Desktop\ DragFullWindows

schon in der Registry vorhanden, dann muss man den Wert nur noch auf "1" setzen.

Microsoft bietet für Windows 95 ein Plus-Paket an, das unter anderem das Aussehen von Bildschirm-Schriften mit Hilfe von Anti-Aliasing deutlich verbessert und das Verschieben von Fenstern mit sichtbarem Inhalt ermöglicht. Die Redmonder lassen sich das Paket gut bezahlen, mit etwas Aufwand kann man die Neuerungen aber auch kostenlos nutzen.

Microsoft-typisch gibt es auch in Windows 95 einiges Überraschendes zu finden:

Wir haben Funktionen entdeckt, die in den High-Color-Modi Schriften-Anti-Aliasing erlauben. Das neue Verschieben von Fenstern mit sichtbarem Inhalt und das weiche "Einscrollen" der Startleiste funktioniert in allen Farbauflösungen. Die Funktionen sind fest in Windows 95 "verankert", aber - anders als in den Beta-Versionen - abgeschaltet. Um sie zu aktivieren, ist etwas Aufwand nötig. Das Geheimnis liegt in einer kleinen 16-Bit-DLL, die Windows 95, wenn es einen entsprechenden Eintrag in der Registrierung gibt, beim Starten lädt. Die einzige Aufgabe der DLL, die den Namen "COOL.DLL" haben muss, besteht darin, dass Sie die Werte 4245h im AX- und 4152h im DX-Register als Rückgabewert liefert. Den Rest haben die Microsoft-Programmierer schon erledigt. Man muss ihre Routinen nur noch anschalten. Entwicklern, die sich mit Windows-Interna auskennen, werden die ASCII-Zeichen der zurückzuliefernden Werte, nämlich "BEAR", bekannt vorkommen, da Sie in einigen undokumentierten API-Funktionen herumgeistern.

Windows kann die Funktionen einer DLL entweder durch ihren Namen oder mittels einer zugeordneten Nummer aufrufen. Beim Aufruf der Funktion aus COOL.DLL benutzt das Betriebssystem die zweite Variante, indem es die Funktion zwei der DLL aufruft. Wer die DLL selbst kompilieren will, muss also dafür sorgen, dass sich die Funktion auch angesprochen fühlt, wenn Windows nach ihr verlangt. Die Zuordnung von Nummern zu Funktionen wird in der Moduldefinitionsdatei festgelegt. Dort steht für jede Funktion, die exportiert wird, also von anderen Programmen aufrufbar ist, eine Zeile mit dem Aufbau: Funktionsname@Nummer.

Es gibt noch eine Reihe weiterer Einträge, die in dieser kleinen DLL aber nicht notwendig sind. Der Name der Funktion ist egal; ich habe Sie "bear" genannt. Der Quelltext und die fertige DLL sind in unserer Mailbox verfügbar. Windows sucht in all seinen Verzeichnissen nach DLLs; typischerweise stehen Sie aber im Verzeichnis "System".

Nun müssen Sie noch die Registry modifizieren, damit das System die erstellte DLL lädt. Zum Verändern dient das Dienstprogramm REGEDIT im Windows-Verzeichnis. Die Bedienung hat Ähnlichkeit mit der des Explorers.

Aber Vorsicht - mit ungeschickt plazierten Einträgen können Sie ihre gesamte Windows-Konfiguration abschießen. Ändern Sie also nur Werte, bei denen Sie genau wissen, wozu sie dienen.

Windows sucht nach der Zeichenkette cool.dll in dem Ast

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Plus!\ Setup

Der Ast HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft ist wahrscheinlich schon vorhanden. Durch den Menüpunkt "Bearbeiten"-> "Neu" -> "Schlüssel" erzeugt das Programm neue Äste.

Wenn Sie die Äste "Plus!\ Setup" angelegt haben, erstellen Sie eine neue Zeichenfolge mit dem Namen "cool.dll". Das Feld "Wert" sollte leer bleiben. Um die Funktionen zu aktivieren, müssen noch die Zeichenfolgen "DragfullWindows" und "FontSmoothing" im Ast HKEY_CURRENT_USER\ Control Panel\ desktop

integriert und jeweils im Feld "Wert" mit "1" gesetzt werden.

Das Modifizieren der Registry lässt sich auch automatisieren, indem Sie das kurze Script eingeben und in einer Datei mit der Endung .REG sichern. Ein Doppelklick auf die Datei ruft automatisch REGEDIT auf, dass die neuen Zeilen einfügt.

Bei seinem nächsten Start überprüft Windows nun die neuen Werte in der Registry und aktiviert die "versteckten" Funktionen. Läuft irgendetwas schief, löscht Windows den Eintrag "cool.dll" im Ast "...\Setup" automatisch. Er muss also nach jedem missglückten Versuch neu eingetragen werden. Geht alles glatt, können Sie sich ab sofort an der erweiterten Oberflächen-Funktionalität erfreuen.

Die COOL.DLL:

#include <windows.h>

void CALLBACK libMain(HINSTANCE hinst, WORD wDataSeg,

WORD cbHeap, LPSTR lpszCmdLine)

{

}

unsigned long CALLBACK bear(void)

{

return 0x41524245;

}

Die COOL.REG:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Plus!\Setup]

"cool.dll"=""

[HKEY_CURRENT_USER\Control Panel\desktop]

"FontSmoothing"="1"

"DragFullWindows"="1"

;Am Dateiende muss ein Return stehen

Info Dies und die anderen Funktionen, die das PlusPack in die Anzeige-Eigenschaften bringt, können auch ohne das PlusPack installiert werden. Das ist dann wesentlich einfacher und bequemer. Man benötigt dazu die Datei: w95gray.exe{MS-Plus! v4.70.1163 englisch (KB) die Plus!-Optionen der Anzeige-Eigenschaften auch ohne PlusPack für alle Windows 950, 950A, 950B} Zu finden ist sie bei MS selbst und auf einigen anderen Freeware und freiwilligen Windows 95 Homepages.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0278.htm


Plug & Play überlisten

Plug & Play ist sicher eine segensreiche Erfindung, allerdings können sich die Vorteile auch ins Gegenteil verkehren. Nicht benötigte Geräte kann man im Gerätemanager zwar entfernen, aber mit Plug & Play werden sie aber beim nächsten Systemstart wieder erkannt und eingebunden.

Besonders lästig sind Komponenten, die sich im BIOS nicht vollständig abschalten lassen. Dazu zählen vorzugsweise OnBoard - IDE-Controller, die man ja z.B. bei einem reinen SCSI-System nicht benötigt. Prominentes Beispiel ist der IDE-Controller auf zahlreichen Sound Blaster - Karten, der von Windows 95 per PnP eingebunden wird und aufgrund heute fast immer vorhandener OnBoard-Schnittstellen nur unnötig Ressourcen verbraucht.

Solcher unerwünschten Systembestandteile kann man sich aber unter trickreicher Nutzung von Hardwareprofilen entledigen.

  1. Öffnen Sie dazu die Systemsteuerung und dort das Symbol "System". Klicken Sie hier auf die Registerkarte "Hardware-Profile". Im Normalfall ist hier nur eine Konfiguration, die "Ausgangskonfiguration", aufgelistet.
  2. Klicken Sie nun auf den Button Kopieren.... Geben Sie als Namen z.B. "Temporärkonfiguration" (ohne Anführungszeichen) ein. Die neue Konfiguration wird nun aufgelistet (nicht immer?).
  3. Wechseln Sie nun wieder auf die Registerkarte "Geräte-Manager", markieren Sie jeweils die nicht benötigte Komponente und klicken Sie den Button "Entfernen".
  4. Im nun folgenden Dialogfenster markieren Sie (unbedingt!) "Aus einer bestimmten Konfiguration entfernen", stellen in der Listbox darunter Ausgangskonfiguration ein und klicken OK. Falls Windows jetzt einen Neustart nachfragt und Sie noch andere Geräte entfernen möchten, beantworten Sie die Frage zunächst mit "Nein" und bestätigen dies erst nach dem letzten Gerät.
  5. Beim nächsten Neustart fordert Sie Windows 95 nun dazu auf, eine Konfiguration auszuwählen. Wählen Sie hier die Konfiguration, aus der die Geräte entfernt wurden, also Ausgangskonfiguration (Nr.1). und siehe da, Windows 95 "weiß" jetzt, welche Geräte es nicht erkennen "darf", die Ressourcen stehen wieder zur Verfügung.
  6. Jetzt können Sie auch die Temporärkonfiguration unter "Hardware-Profile" wieder löschen, wodurch die Nachfrage beim Systemstart entfällt.

Um ein so ausgeblendetes Gerät wieder einzubinden, müssen Sie über den Hardware - Assistenten (Symbol "Hardware" in der Systemsteuerung) eine automatische Hardwareerkennung laufen lassen. Es werden dann aber alle so ausgeblendeten Geräte wieder eingebunden, so dass obige Vorgehensweise evtl. wiederholt werden muss.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0272.htm


Plug & Play-Geräte hinzufügen ohne Neustart

Wer externe SCSI-Geräte besitzt, muss nicht den Rechner neu starten, wenn er ein ausgeschaltetes Gerät in Betrieb nehmen will.

Auf folgende Weise geht es auch:

  1. SCSI-Gerät einschalten
  2. "Systemsteuerung" -> "System" -> "Gerätemanager"
  3. "Aktualisieren" auswählen

Nach kurzer Zeit steht das Gerät (z.B. Streamer, CD-Brenner) zur Verfügung

Info Wer diese Funktion öfter benutzt, kann sich auch an beliebiger Stelle (z.B. auf dem Desktop) eine Verknüpfung anlegen. Als Ziel muss dort "Control.exe SYSDM.cpl,,1" eingetragen werden. Ein Doppelklick darauf öffnet sofort den Geräte-Manager.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0275.htm


Informationen zum Virtual Machine Manager (VMM)

Der Virtual Machine Manager (VMM) verteilt die Ressourcen an alle Anwendungen und Systemprozesse. Der VMM erzeugt und verwaltet Maschinen, in denen die Anwendungen und Systemprozesse arbeiten.

Eine virtuelle Maschine ist ein separater Speicherbereich, der aus der Perspektive einer Anwendung wie ein eigenständiger Computer erscheint.

  1. Der VMM ist für drei grundlegende Dienste verantwortlich:
  2. Verwaltung der Prozesse im Scheduler
  3. Verwaltung von Speicherseiten
  4. Unterstützung des MS-DOS -Modus für DOS -Anwendungen, die exklusiven Zugriff auf die Systemressourcen benötigen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0334.htm


Informationen über den Gerätemanager

Im Gerätemanager sehen Sie die installierte Hardware und können Änderungen an den Einstellungen vornehmen. Hier sehen Sie auch, ob die Hardware ohne Probleme unter Ihrem System läuft. Durch vier unterschiedliche Symbole werden Sie auf Fehler hingewiesen:

  1. Ein schwarzes Ausrufezeichen auf gelbem Hintergrund:
    Das Gerät funktioniert nicht ordnungsgemäß auf Ihrem Rechner. Das deutet meist auf IRQ bzw. Adressenkonflikte hin. Überprüfen Sie die entsprechenden Einstellungen. Wenn Sie hier keinen Fehler finden, kann es auch sein, dass die Hardware im BIOS deaktiviert wurde.
  2. Ein rotes Kreuz:
    Das Gerät wurde gerade erst installiert (Neustart zur Aktivierung notwendig) oder das Gerät ist in diesem Hardwareprofil deaktiviert. Aktivieren Sie es durch einen Doppelklick auf das Symbol (löschen Sie das Kreuz bei "In diesem Hardwareprofil deaktivieren")
  3. Ein großes gelbes Fragezeichen:
    Windows hat die Hardware erkannt, aber es wurde noch kein Treiber für die Hardware installiert. Sie benötigen einen Treiber vom Hardwarehersteller.
  4. Ein blaues "i" auf weißem Hintergrund :
    Das ist kein Fehler, Sie werden nur darauf hingewiesen, dass die Plug und Play Funktion der Hardware deaktiviert wurde.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0577.htm


Fehlende Schriften in der Fontsliste

Fehlende Schriften in der Fontliste

Es kann vorkommen, dass nicht alle installierten Schriften angezeigt werden. Meist liegt dann ein Fehler in der Registry vor. Um diesen Fehler zu beheben, gehen Sie folgendermaßen vor:

  1. Verschieben Sie alle Schriften aus dem Fontordner in ein beliebiges anderes Verzeichnis (z.B.: C:\Windows\Fonts nach C:\MeineFonts)
  2. Löschen Sie je nach Betriebssystem folgenden Schlüssel aus der Registry:
    Windows 9x:
    HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Fonts
    Ab Windows NT:
    HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Fonts
  3. Erstellen Sie den Schlüssel Fonts neu
  4. Starten Sie den Rechner neu
  5. Installieren Sie alle gesicherten Fonts wieder in den Ordner über "Systemsteuerung" - "Schriftarten" - Menü "Datei" - "Neue Schriftarten installieren". Wählen Sie hier ihren Ordner aus, im dem Sie die Schriften gesichert haben und markieren sie alle.

Jetzt sollten wieder alle Schriftarten angezeigt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1337.htm


Eigene StarOffice Shell wieder abschalten

Die StarOffice 5 Oberfläche ersetzt, wenn geladen, komplett die Shell und Funktionalität der Windows Shell.

Um dies wieder zu deaktivieren, editiert man die Datei soffice.ini und fügt unter Common die Zeile FullScreenDesktop=0 hinzu. Hiermit benimmt sich Star Office wie jede Windows Anwendung.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0728.htm


Detaillierte Hardwareinformationen mit HWINFO oder HWDIAG ermitteln

Mit dem Programm HWINFO.EXE können Sie eine detaillierte Liste der installierten Hardware und der dazugehörigen Treiber erstellen. Der Aufruf des Programms erfolgt über das Kommando "hwinfo /ui".

Beachten Sie bitte, dass das Programm die Datei %WINDIR%\HWINFO.DAT neu erstellt. Sichern Sie also ggf. die alte Datei, bevor Sie das Programm starten (siehe auch "Windows updaten (Aktuelle Updates aus dem Internet laden)").

Für Windows 95 gibt es das Tool HWDIAG.EXE, welches aber standardmäßig beim Setup nicht installiert wird. Sie finden dieses Programm auf der Windows 95-CD unter \Win95\misc\hwtrack

Info Weitere umfangreiche Informationen über ihr System erhalten Sie mit dem Programm MSINFO32 (Start - Programme - Zubehör - Systemprogramme - Systeminformationen).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1297.htm


Deaktivierte Einträge aus Msconfig - Autostart entfernen

Doppelte oder deaktivierte Autostart-Einträge, die sich nach der Deinstallation eines Programmes noch unter "Start" -> "Ausführen" -> "Msconfig" -< "Autostart" finden lassen, können Sie wie folgt entfernt werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

löschen Sie die Einträge der "Run-" und "RunServices-" -Schlüssel, sowie unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion

die Einträge von "Run-".

Außerdem können in der Datei C:\Windows\Win.ini in der Sektion [windows] folgende Einträge gelöscht werden:

noload

norun

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1283.htm


Backup und Restore von Windows

Wenn Sie die gesamte Festplatte samt Windows mit Backup gesichert haben, kann sich das Restore als problematisch erweisen.

Wenn Ihr Backup nur unter Windows funktioniert, müssen Sie vor einem Restore Windows und das Backup-Programm installiert haben, aber wenn Sie versuchen, die gesicherten Dateien nun zurückzuschreiben, erscheint die Fehlermeldung, dass benutzte Dateien nicht überschrieben werden können (unter Windows sind ca 50-70 Dateien und alle Schriftarten-Dateien ständig geöffnet). Die meisten Backup-Programme brechen das Restore jetzt ab.

Wenn Sie Windows im DOS -Modus starten und versuchen, die Daten mit einem DOS -Programm zurückzuspielen, gelingt es zwar, dabei gehen aber alle langen Dateinamen verloren.

Es gibt mehrere Lösungen für dieses Problem:

  • Wenn Sie vor dem Backup die langen Dateinamen unter DOS mit LFNBK.EXEgesichert haben, können Sie das Restore nun unter DOS ausführen und dann die langen Namen wiederherstellen.
  • Wenn Sie die Dateinamen nicht gesichert haben, brauchen Sie für das Restore ein zweites Windows 95. Bevor Sie dieses zweite Windows aus einem eigenen Verzeichnis starten, müssen Sie in der MSDOS .SYS im Abschnitt [PATHSs] die Variablen "WinBootDir=" und "WinDir=" auf das neue Verzeichnis einstellen.
    Nun können Sie Ihre Daten samt langer Dateinamen wiederherstellen.
    setzen Sie anschließend in der MSDOS .SYS die Pfade auf das eigentliche Windows 95-Verzeichnis zurück und löschen Sie das zweite Windows.
  • Windows 98: Sie können die Systemwiederherstellung (System Recovery) von MS verwenden. Bei dieser Lösung wird erst Windows installiert, danach wird das System anhand der Backup-Sicherung wiederhergestellt. Das entsprechende Programm und eine Anleitung finden Sie auf der Windows-CD im Verzeichnis \tools\sysrec.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0061.htm


Kennwort für Bildschirmschoner löschen

Wer das Passwort für seinen ScreenSaver vergessen hat, kann es in der Registry löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_Users\. Default\ Control Panel\ desktop

und löschen Sie dort den Eintrag "ScreenSave_Data".

Info Durch das Löschen der ScreenSaver Einträge in der CONTROL.INI können Sie den Aufruf des Bildschirmschoners auch ausstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0152.htm


Bildschirmschoner über ein Icon starten

Durch eine kleine Änderung in der Registry ist es möglich, Bildschirmschoner (*.scr) über ein Icon aufzurufen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

Tragen Sie unter dem Wert "Programs" als Datentyp REG_SZ hinter den dort schon vorhandenen Endungen "com exe bat pif cmd" zusätzlich noch "scr" ein.

Melden Sie sich nun ab und wieder an. Erstellen Sie eine beliebige Verknüpfung mit einem Screensaver

(z.B.: \Winnt\system32\ssmyst.scr).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0262.htm


Blinkgeschwindigkeit des Cursors einstellen

Unter Windows können Sie die Geschwindigkeit, mit welcher der Cursor blinken soll, verändern oder das Blinken bei Bedarf ganz ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Dort erstellen Sie einen neuen Wert mit dem Namen "CursorBlinkRate" als Datentyp REG_SZ

Hier können Sie nun Werte zwischen 1 und 60000 einstellen. Bei 60000 ist kein Blinken mehr zu erkennen.

Sie können diese Einstellung zwar auch in der Systemsteuerung unter "Eigenschaften der Tastatur" verändern, hier können Sie aber den Wert nicht so hoch einstellen, dass kein Blinken mehr zu erkennen ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0558.htm


Adaware unter Windows 95

Damit Sie Adaware auch unter Windows 95 installieren können, müssen Sie vor der Installation folgende dll-Dateien von Windows 98 kopiert werden:

ws2_32.dll und ws2help.dll (diese Dateien sind unter Windows 95 nicht vorhanden).

Die Dateien ws2_32.dll und ws2help.dll kopieren Sie bitte in den Ordner "C:\Windows\System" kopieren

Sobald die genannten Dateien im Ordner "C:\Windows\System" kopiert sind, kann die Installation unter Windows 95 erfolgen. Das Programm Adaware 6.0 funktioniert dann einwandfrei.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2070.htm


Windows 98/ME installieren ohne NT Bootmenü zu löschen

Bei der Installation von Windows 98/ME nach Windows NT oder 2000 wird das Bootmenü von Windows NT und 2000 durch Windows 98/ME überschrieben. Um das zu verhindern, müssen Sie die Installation mit dem Parameter IR starten.

Aufruf: "SETUP /IR"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1015.htm


25-stelligen Product Key verlegt?

Der 25-stellige Product Key wird in der Registry gespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

beinhaltet der Wert ProductKey vom DatentypREG_SZ den benötigten Schlüssel.

Bei Windows 95 ist der Key unter ProductID gespeichert.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1259.htm


Installation von Windows 98

Die Installation von Windows 98 ist nur noch ab 486-Rechner möglich, 386 werden nicht mehr unterstützt. Auch ist wohl 32 MB Speicher unabdingbar. Man kann es zwar auch noch mit 16 MB Speicher installieren, ob aber ein sinnvolles Arbeiten dann noch möglich ist, wage ich stark zu bezweifeln. Da es nicht mehr möglich ist, Windows 98 ohne Active Desktop (IE 4.0) zu installieren, sollte man aus diesem Grunde bei alten Rechnern doch lieber bei der alten Windows 95 Version bleiben. Das ist sowieso sinnvoll, da alle größeren Änderungen sich halt nur auf das Active Desktop und der Unterstützung von neuen Standards (AGP , DVD, Power-Management usw.) beschränken, was bei alten Rechnern sowieso noch nicht vorhanden ist.

Zur vollen Installation von Windows 98 werden ca. 300 MB Speicherplatz auf der Festplatte benötigt.

Windows 98 unterstützt auch eine Update-Installation von Windows 3.x oder 95 auf 98. Um aber alte, nicht mehr benötigte Treiber und Registry- Einträge loszuwerden, würde ich eine komplette Neuinstallation einer Updateinstallation vorziehen. Achten Sie bei der Update-Installation darauf, dass genügend Speicherplatz auf der Partition zu Verfügung steht (ca. 300 MB), da Windows anscheinend bei dieser Installationsart nicht richtig überprüft ob genügend Speicherplatz vorhanden ist und bei Speicherplatzmangel sich mit einem freundlichen Absturz bei der Installation verabschiedet.

Auch sind evtl. installierte EIDE-Busmastertreiber vor der Updateinstallation zu entfernen, da sich diese Treiber nicht mit den neuen von Microsoft vertragen und das zu erheblichen Problemen führen kann.

Löschen Sie also das alte Windows mit den installierten Windows-Programmen von Ihrer Festplatte und booten Sie von Diskette.

Die Installation wird mit SETUP.EXE von der CD gestartet, mit der Angabe von Parameternkönnen Sie die Installation beeinflussen.

MS hat die Installation in 5 Teilabschnitte aufgeteilt:

  1. Vorbereiten der Installation
  2. Abfragen der Systeminfos
  3. Kopieren der Systemdateien
  4. Neustart des Computers
  5. Einrichten der Hardware und Beenden der Konfiguration

Die Installation läuft nach dem Starten mit SETUP.EXE folgendermaßen ab (wenn Sie das Setup mit Parametern gestartet haben, können Abweichungen auftreten):

  1. Windows 98 überprüft die Festplatte (Scandisk)
  2. Installation des Windows Assistenten
  3. Sie müssen nun dem MS Lizenzvertrag zustimmen.
  4. Eingeben der Produkt-ID (hier hat sich MS wieder eine neue Berechnung der Seriennummer einfallen lassen)
  5. Installationsverzeichnis für Windows 98 angeben
  6. Setup Modus auswählen:
    · Standard
    · Laptop
    · Minimal
    · Benutzerdefiniert
    Ich würde jedem Anwender raten, hier die benutzerdefinierte Installation auszuwählen. Auch wenn Sie sich nicht so auskennen, unterscheidet sich diese Installation von der Standard-Installation nur in dem Punkt, dass Sie alles vorher noch einmal bestätigen müssen und die Möglichkeit haben, Einstellungen zu verändern und noch zusätzliche Programmteile zu installieren. Die Vorauswahl der Optionen entspricht aber immer der Standard-Installation.
    Info: Je nach Installationsart kann es sein, dass einige Installationsschritte nicht abgefragt werden.
  7. Sie werden nach Ihren Benutzerangaben gefragt
  8. Sie können die zu installierenden Komponenten auswählen
    Dieses Auswahlmöglichkeit haben Sie nur bei der benutzerdefinierten Installation. Da aber einige nützliche Tools (Quick View, Backup, Hyperterminal usw.) sonst nicht mit installiert werden, sollten Sie diese Installationsart wählen, um die benötigten Programme auszuwählen und sich das nachträgliche Installieren bzw. Deinstallieren zu ersparen.
  9. Identifikationsangaben für Ihren Rechner
  10. Computereinstellungen
  11. Standortabfrage (hier Deutschland)
  12. Erstellen einer Startdiskette (man sollte sich aus Sicherheitsgründen so eine Diskette erstellen lassen)
  13. Windows wird nun die Installation fertigstellen und die benötigten Dateien auf Ihre Festplatte kopieren.
  14. Neustart des Computers (wird nach 15 sec. automatisch durchgeführt)
  15. Einrichten der Hardware (Hardwareerkennung)
  16. Zeitzone einstellen
  17. Neustart des Computers (wird nach 15 sec. automatisch durchgeführt)
  18. Nach diesem Neustart werden noch einige persönliche Einstellungen vorgenommen und die Installation von Windows 98 ist damit beendet.

Nach der Installation können Sie nun noch das Dateisystem auf FAT32 umstellen, was bei großen Partitionen den Vorteil der kleineren Clustergröße bietet und somit nicht mehr so viel Speicherplatz verschwendet wird.

Das alte Plus-Pack ist standardmäßig in Windows 98 mit eingebunden worden. Das neue Plus-Pack 98 enthält dafür folgende Programme:

  • Desktop Motive
  • McAfee Antivirus Software
  • Picture IT Express
  • Deluxe CD-Player
  • Ein verbessertes Scandisk
  • Spiel: LoseYourMarbles

Für diese Programme lohnt es sich kaum, das Plus-Pack zu erwerben.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0185.htm


Windows 98 ohne Internet Explorer

Laut der Aussage von MS ist es nicht möglich, den IE 4.x aus Windows 98 zu entfernen.

Wie das aber doch möglich ist, wird auf der Internetseite: http://www.litepc.com/98lite.htmlbeschrieben. Dort finden Sie auch fertige Dateien, die den IE automatisch für Sie aus Windows 98 entfernen.

Aus diesen Grunde verzichte ich hier auf eine ausführliche Beschreibung.

Wer aber die letzte Windows 95 Version noch hat, sollte, wenn er den IE 4.x nicht benutzen möchte, doch lieber diese Version installieren. Ich finde, dass diese Version dann noch stabiler läuft als die Windows 98 Version.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0365.htm


Win98 Vollversion über Win95 installieren

Windows 98 Vollversion über Windows 95 installieren

Die Vollversion von Windows 98 lässt sich nur auf einem "nackten" System installieren. Ein Update über Windows 95 scheitert mit dem Hinweis, dass man sich doch ein Update zulegen soll.

Man kann die Platte neu formatieren (der bessere Weg) oder wie folgt vorgehen:

- Man benennt die Win.com, Io.sys und MsDOS .sys von Windows 95 einfach um oder löscht diese und startet das Setup von Windows 98 aus dem DOS.

attrib c:\*.sys -s -r -h
del c:\msDOS .sys
del c:\io.sys
del c:\windows\win.com

Allerdings schlägt die Installation fehl, wenn mit einer Boot-Diskette gestartet wird. Zunächst scheint die Installation zu funktionieren, aber beim abschließenden Neustart gibt es die Fehlermeldung, dass die Datei kernl386.exe nicht gefunden wurde. Man muss daher die die Config.sys und Autoexec.bat auf der Festplatte um einen CD-ROM Treiber und den MSCDEX erweitern:

Config.sys
DEVICE=c:\PFAD\TREIBER /D:MSCD000

Info Man kann den OAKCDROM.SYS der Windows 98 Bootdiskette verwenden, welchen man auf die Festplatte kopiert. Aktueller und zuverlässiger ist allerdings der Treiber der Fa. ACER, der mit nahezu allen Laufwerken harmoniert (APICD214):
http://www.acercm-eu.com/ServiceAndSupport/Drivers/drivers.cfm?product=290

Autoexec.bat
c:\PFAD\MSCDEX.EXE /D:MSCD000 (Hinweis zum PFAD: Dieser ist bei Windows 95 c:\Windows\Command).

Dieses Problem lässt sich übrigens umgehen, indem man das Windows 98-Verzeichnis von der CD auf die Festplatte in ein Verzeichnis (z.B. C:\WIN98) kopiert, in dieses Verzeichnis wechselt und Setup von dort aus startet.

Ein weiterer Anwender (Michael Ortmann) hat es wie folgt geschafft:

"Hallo, ich (Verfasser des Ursprungsthreads) habe es nun doch geschafft.... ich habe zuerst mit der alten Windows 95-Startdisk gebootet, auf der Festplatte die Dateien WIN.COM, IO.SYS, MSDOS.SYS und COMMAND.COM umbenannt und dann das Setup von CD gestartet.....ging auf einmal !

Allerdings nicht unter Windows 95, sondern nur von der DOS -Ebene. Ich habe das ganze allerdings in ein neues Verzeichnis installiert, weil ich mir nicht sicher war, was Windows 98 sonst mit meinem alten Windows 95 gemacht hätte.... daher musste ich alle Programme noch einmal installieren und Windows 95 letztendlich löschen, naja nun habe ich jedenfalls ein ziemlich sauberes System."

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0689.htm


Windows Installation OHNE Seriennummer

Sie müssen beim ersten Booten, wenn normalerweise die Registrierung kommt, F8 drücken und im Abgesicherten-Modusden Rechner hochfahren.

Starten Sie den Registry-Editor mit "Regedit.exe" und wählen den Schlüssel

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

Dort ändern Sie jetzt folgende Werte, die unter diesem Schlüssel aufgeführt sind:

BootCount = 1
ProductID = irgendetwas 20stelliges
RegDone = 1
RegisteredOrganization = irgendetwas
RegisteredOwner = irgendetwas

Beenden Sie Windows und starten das System neu. Jetzt wird die Installation ohne Abfrage der Registrierungsnummer fortgesetzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0706.htm


Win98 SE Vollversion über Win98 installieren

Windows 98 SE Vollversion über Windows 98 installieren

Die Vollversion von Windows 98 SE (Second Editon) lässt sich nur auf einem nackten System installieren.

Ein Update über Windows 98 scheitert mit dem Hinweis, dass man sich doch ein Update zulegen soll. Diese Meldung kommt aber nur bei der OEM-Version, die bei der Auslieferung von Rechnern mit dabei liegt. Eine Vollversion, die Sie extra gekauft haben, können Sie über ein bestehendes System installieren.

Mit etwas Vorarbeit können Sie aber auch diese Version über ein bestehendes Windows installieren:

  1. Kopieren Sie die Installationsdateien von der Windows 98 CD auf ihre Festplatte in ein beliebiges Verzeichnis (z.B. Install)
  2. Starten Sie ihr Windows im MS-DOS Modus
  3. Löschen Sie aus dem Hauptverzeichnis die Dateien:
    IO.SYS
    MSDOS .SYS
    und aus dem Windows-Verzeichnis die Datei
    WIN.COM
  4. Bedenken Sie, dass diese Dateien versteckt und schreibgeschützt sind. Sie müssen sie daher erst mit "attrib -r -h -s [Dateiname]" freigeben

Gehen Sie in das Verzeichnis, in dem die Installationsdateien liegen und starten Sie das Setup. Geben Sie bei der Installation als Windowsverzeichnis das alte Windowsverzeichnis an und übernehmen Sie nicht den Vorschlag von Windows.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0621.htm


ACPI Funktion von Windows aktivieren

Windows 98 bietet ACPI (Advanced Configuration and Power Interface) als neue Funktion. ACPI ist die Weiterentwicklung von APM (Advanced Power Management), welches Sie aus Windows 95 kennen. Hiermit hat Windows mehr Zugriffsmöglichkeiten auf die Energieverwaltungs-Funktion des Rechners.

So haben Sie mit ACPI die Möglichkeit, Ihren Rechner in den Stand-by-Modus zu setzen. Dabei wird der Speicherinhalt auf die Festplatte geschrieben und der Rechner ausgeschaltet (funktioniert bei Windows 98 nur auf FAT16 Partitionen). Wenn Sie den PC nun wieder neu starten, wird nur der Speicherinhalt in den Speicher geladen und der Rechner ist wieder so da, wie Sie Ihn vorher verlassen haben.

Windows installiert nur ACPI, wenn es eine ACPI-fähiges Board erkennt (meist bei Board mit BIOS ab dem 1.1.2000). Damit diese Funktion auch installiert wird, wenn Windows kein ACPI findet, müssen Sie das Setup von Windows 98 mit "Setup /p j" starten, ansonsten werden die Funktionen nicht installiert (siehe auch "Installation von Windows verkürzen (Setup-Parameter)").

Info Versuchen Sie die Funktion bitte nicht zu aktivieren, wenn Sie Windows ohne diesen Parameter installiert haben, das führt zu Problemen.

Nach der Installation müssen Sie noch folgenden Wert in der Registry anlegen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Detect

Legen Sie eine neue Zeichenfolge mit dem Namen "ACPIOption" als Datentyp REG_DWORD an und weisen ihr den Wert 1 zu.

Führen Sie jetzt eine neue Hardwareerkennung durch: "Systemsteuerung" -> "Hardware". Nach einiger Zeit wird Ihnen eine Liste der gefunden Hardware angezeigt, hier sollte nun folgender Eintrag vorhanden sein:

"Advanced Configuration and Power Interface (ACPI) BIOS ".

Nach einem Neustart steht Ihnen die neue Funktion zur Verfügung. In der "Systemsteuerung" können Sie unter "Energieverwaltung" unter dem Reiter "Einstellungen" festlegen, was passieren soll, wenn Sie den Power-Knopf Ihres Computer betätigen.

Info Diese Funktion muss natürlich durch Ihr Motherboard unterstützt werden!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0528.htm


Fix für Shutdown-Problem jetzt zum Download bei Microsoft

Bei Problemen mit dem Herunterfahren von Windows 98SE hilft unter Umständen folgender Artikel der Microsoft Knowledge Base:

"Problembehandlung beim Herunterfahren von Windows 98 Second Edition"

http://www.microsoft.com/kb/Germany/support/kb/d40/d40018.htm

Weiterhin stellt Microsoft mehrere Patches zur Behebung von Problemen beim Shutdown zur Verfügung:

"Windows 98 Second Edition Erweiterung zum Herunterfahren"

http://www.microsoft.com/kb/Germany/support/kb/d41/d41467.htm

"Windows hängt beim Herunterfahren mit zugeordneten Laufwerken"

http://www.microsoft.com/kb/Germany/support/kb/d42/d42968.htm

Achten Sie beim Herunterladen der Korrekturen unbedingt darauf, dass Sie die richtige Betriebssystem- und Sprachversion auswählen.

Siehe auch "Probleme beim Herunterfahren bzw. mit dem automatischen Ausschalten".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0632.htm


Power Profile wird laut MSConfig 2x geladen

Power Profile wird lt. MSConfig 2x geladen

Untersucht man die Autostarteinträge mit MSConfig, stellt man fest, dass der Eintrag "LoadPowerProfile" doppelt vorhanden ist.

Das ist normal, da das System diesen Eintrag VOR und NACH einem Login benötigt. Zuerst wird das Standardprofil der Energieverwaltung geladen, nach der Benutzeranmeldung das entsprechende Benutzerprofil.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: MS Knowledge Base: http://support.microsoft.com/?kbid=187611

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0927.htm


Startmenüaufruf unter Windows 98

Unter Windows 98 können Sie zwar immer noch wie bei Windows 95 mit der Taste F8 das Startmenü aufrufen, da aber hier standardmäßig die Wartezeit von 2 Sekunden nicht eingeschaltet ist, ist es nicht gerade leicht, die Taste rechtzeitig zu drücken.

Es gibt aber noch eine weitere Möglichkeit, das Menü aufzurufen:

  1. Beim (Neu)Start linke STRG-Taste drücken, daraufhin erschient das Windows 98 Startmenü mit der Auswahl
    a.) Protokolliert (bootlog.txt), b.) abgesicherter Modus, c.) Einzelbestätigung... usw.
  2. Beim (Neu)Start linke Umschalt-Taste drücken, daraufhin startet Windows 98 im Abgesicherten-Modus.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0667.htm


Geöffnete Ordner beim Start von Windows wieder herstellen

Mit diesem Tipp können Sie einstellen, ob Windows die geöffneten Ordner, die beim Beenden von Windows offen waren, bei Start von Windows wieder öffnen soll.

Wenn Sie den Tipp aktivieren, dann merkt sich Windows die Ordner und stellt sie beim starten wieder her.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "PersistBrowsers" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Ordner wieder öffnen
0 | Ordner nicht wieder öffnen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1671.htm


Stand-by-Modus verschwunden

Sofern entsprechende Hardware vorhanden ist, kann das System normalerweise über das Startmenü in den Stand-by-Modus versetzt werden. Wacht das System aus dem Stand-by aber nicht mehr ordnungsgemäß auf oder hängt sich beim Versuch, in den Stand-by-Modus zu wechseln, auf, moniert dies Windows beim Neustart. Wenn man dann die Frage, ob man in Zukunft auf den Stand-by-Modus wegen vorausgegangener Probleme verzichten möchte mit "Ja" beantwortet, kann der Stand-by-Modus auf normalem Wege nicht mehr reaktiviert werden.

Abhilfe schafft die folgende Vorgehensweise:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  1. Zunächst entfernt man aus dem Gerätemanager den APM-Support unter den Systemkomponenten.
  2. Nach dem Neustart startet man die Hardwareerkennung, welche den APM-Support erneut finden sollte.
  3. Sollte nach einem erneuten Reboot der Stand-by-Modus jetzt nicht wieder vorhanden sein, entfernt man den Diskettenlaufwerkscontroller aus dem Gerätemanager und startet das System neu.
  4. Jetzt wird der Controller wieder erkannt und automatisch installiert.
  5. Funktioniert der Stand-by jetzt immer noch nicht, wechselt man mit Regedit in den Pfad:

    6. HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VXD\ VPOWERD

    und prüft die Werte für "Flags" und "SuspendFlags". Ist der Wert für Flags größer oder gleich 200, muss man von diesem Wert 200 abziehen und die neu ermittelte Zahl als Wert Eintragen. Für SuspendFlags wird der Wert 0 benötigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1034.htm


Anmeldezwang beim Login

von: Weigel, Steffen

Es können sich nur Benutzer einloggen bzw. anmelden, die vorher als Benutzer eingetragen wurden. Alle, die versuchen, sich mit einer Neuanmeldung (neuer Benutzer / Passwort) Zugang zum PC zu verschaffen, haben Pech; da sich der PC automatisch wieder herunter fährt (da eben dieser "neue Benutzer" nicht in der Kennwortliste von Windows steht).

Darum Vorsicht!!, dass man sich nicht selbst aussperrt (ist jedoch im abgesichertem Modus durch Löschen dieses Schlüssels möglich).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.Default\ Software\ Microsoft\ Windows\ Run

erstellen Sie einen neuen Eintrag als Datentyp REG_SZ mit den Namen "Shutdown" und geben als Text "C:\WINDOWS\Rundll32.EXE user.exe,ExitWindows" ein.

Info Siehe auch Tipp: "Deaktivieren des Buttons Abbrechen beim Anmelden"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1647.htm


Shell festlegen, die gestartet werden soll

Windows startet standardmäßig immer den Explorer als Shell (Arbeitsoberfläche). Diese Shell lädt die Elemente wie Startmenü. Taskleiste und Systray.

Im Internet gibt es viele alternative Shell-Programme. Es ist natürlich auch möglich, ein Programm als Shell starten zu lassen, falls Sie z.B. nur immer eine bestimmte Anwendung benutzen. Die alternativen Shell-Programme erweitern die Windows Funktionen und sehen oft auch optisch ansprechend aus.

Hier werden nur kurz die Einträge beschrieben, wo diese Einträge in der Registry gemacht werden, um eine andere Shell zu laden (die meisten Shellprogramme führen diese Änderungen aber automatisch durch). Weiterhin werden einige Links zu entsprechenden Shells aufgelistet.

Für Windows 98/ME

Bei diesen Betriebssystemen wird noch in der Datei System.INI angegeben, welche Shell geladen werden soll.

Öffnen Sie diese Datei mit einem Editor und suchen Sie die Sektion [boot]. Hier finden Sie die Zeile shell=explorer.exe, wo Sie nun anstatt des Explorers auch jede andere beliebige Anwendung eintragen können

Ab Windows 2000

Bei diesen Beriebssystemen wird die Information, welche Shell geladen werden soll, in der Registry abgelegt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

finden Sie einen Wert mit den Namen Shell als Datentyp REG_SZ, in welchem normalerweise der Eintrag "Explorer.exe" zu finden ist. Hier können Sie selbstverständlich auch jede andere Anwendung eintragen und somit eine andere Shell festlegen, die gestartet werden soll. Hier tragen sich auch die alternative Shell-Programme ein.

In den meisten Fällen wird der Eintrag unter HKEY_LOCAL_MACHINE ausgewertet. Hier wird die Shell für alle Anwender gleich festgelegt. Wie Sie aber oben sehen, können Sie die Shell auch für jeden Anwender extra festlegen.

Damit Windows die Shell benutzerabhängig lädt, müssen Sie folgenden Eintrag ändern.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ IniFileMapping\ System.ini\ Boot

finden Sie ebenfalls den Wert Shell als Datentyp REG_SZ. Dieser Wert gibt aber nicht direkt an welche Shell geladen werden soll, sondern aus welchem Registryanteil der Eintrag ausgelesen wird.

Standardmäßig steht der Wert auf "SYS:Microsoft\Windows NT\CurrentVersion\Winlogon" ändern Sie diesen Eintrag ab auf "USR:Software\Microsoft\Windows NT\CurrentVersion\Winlogon", damit die Shell jetzt für jeden User extra ausgewertet wird. Vergessen Sie aber nicht, den oben angegeben Eintrag für den Benutzer auch hinzuzufügen.

SYS: | Es wird für alle User die gleiche Shell geladen
USR: | Es wird pro Benutzer eine extra Shell geladen

Anschließend müssen Sie noch den Eintrag "Shell" unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon" löschen. Ansonsten wird zwar die neue benutzerabhängige Shell als erste gestartet, sobald Sie aber unter dem Benutzer das erste Mal den Explorer öffnen, lädt Windows automatisch die eigene Shell (Taskleiste usw.) wieder nach. Wenn Sie hier den Eintrag löschen, wird nur der Explorer geöffnet und das ist dann meist auch nur gewollt.

Hier nun einige Internetseiten die andere Shells anbieten:

LiteStep (Freeware) | http://www.litestep.net
GeoShell (Freeware) | http://geoshell.com
Talisman (Shareware) | http://www.lighttek.com
Sphere XP | http://www.hamar.sk/sphere/

Über Google können leicht weitere Seiten mit Shells finden. Wenn Sie eine gute Shell gefunden haben, können Sie sich melden und mir den Link mitteilen, damit ich diesen Link hier aufnehmen kann. Vielleicht machen Sie auch eine entsprechende Beschreibung für die Shell, was sie kann und bietet.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Benutzerdefinierte Benutzerschnittstelle

Info Wenn Sie eine Shell zum Starten eintragen, die nicht im Windows Verzeichnis liegt (bzw. die nicht in der Pfadvariablen eingetragen ist), müssen Sie immer den gesamten Verzeichnispfad zu Anwendung mit eintragen.

Info Durch eine neue Shell werden die Einträge im Autostartordner und unter RUN meist nicht mehr ausgewertet. Dadurch werden diese Programme nicht mehr gestartet.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2007.htm


Anzahl der automatischen Anmeldungen konfigurieren

Mit diesem Tipp können Sie einstellen, wie viele automatische Anmeldungen durchgeführt werden, bevor die Einstellung wieder zurückgesetzt wird.

Im Tipp "Autologin beim Starten" wird beschrieben, wie man das automatische Anmelden aktivieren kann. Wenn Sie diese Funktion, z.B. für das Unattended Setup von Windows, benutzen, kann es nützlich sein, das automatische Anmelden nach einer bestimmten Anzahl von Systemstarts wieder auszuschalten.

Wenn die angegebene Anzahl der Einträge unter "AutoLogonCount" erreicht wird, wird das automatische Anmelden deaktiviert und die Standard Anmeldebox wird wieder angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "AutoLogonCount" als Datentyp REG_DWORD und setzen den Wert auf die Anzahl der automatischen Anmeldungen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2650.htm


Arbeitsplatz, Papierkorb und Online-Dienste als Symbolleiste

Sie können ab Windows 98 den Arbeitsplatz, Papierkorb oder die Online-Dienste als Symbolleiste anzeigen lassen. Am Beispiel Arbeitsplatz wird gezeigt, wie Sie dazu vorgehen müssen.

  1. Markiere den Arbeitsplatz mit der linken Maustaste und halte die Taste gedrückt.
  2. Schiebe das Symbol bis zum linken Bildrand und lasse die Taste wieder los. Voilà - der Arbeitsplatz ist jetzt eine Symbolleiste und zeigt alle Laufwerke an.

Die Leiste lässt sich übrigens auf dem Bildschirm beliebig verschieben. Schließen lässt sich die Symbolleiste wieder über das Kontextmenü der rechten Maustaste.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0665.htm


Strecken des Hintergrundbilds ist nicht mehr vorhanden

Strecken des Hintergrundbildes ist nicht mehr vorhanden

Es kann vorkommen, dass die Einstellung "Strecken" bei den Hintergrundbild des Desktops nicht mehr vorhanden ist. Dieser Fehler kommt, wenn "Active Desktop" mit den TweakUI von Microsoft deaktiviert wurde.

Um den Fehler zu beheben:

- Gehen Sie in die Systemsteuerung und starten Sie "TweakUI"

- Klicken Sie auf den IE4 Tab

- Klicken sie auf die "Active Desktop" Checkbox und anschließend auf Übernehmen

Wenn Sie jetzt wieder auf die Hintergrundeinstellungen gehen, ist der Eintrag wieder vorhanden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2040.htm


Taskplaner (Schedule) in der Taskleiste deaktivieren

Standardmäßig wird der Taskplaner bei Windows mit installiert und auch automatisch gestartet. Da die meisten Anwender aber diese Funktion nicht benötigen (mit den Taskplaner können beliebige Anwendungen zu bestimmten Zeiten gestartet werden), sollte man den Taskplaner deaktivieren.

Das machen Sie unter:

"Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Systeminformationen":

dort unter Extras das Systemkonfigurationsprogramm starten und unter "Autostart" das Kreuz vor "Scheduling Agent" entfernen bzw. über "Start" -> "Ausführen" -> MSCONFIG und unter der Registrierkarte "Autostart" deaktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0633.htm


Alle Festplatten in Taskleiste einbinden

Windows erlaubt das Erstellen einer individuellen Taskleiste. Klickt man mit der rechten Maustaste auf einen freien Bereich in der Taskleiste und wählt dann "Symbolleisten" -> "neue Symbolleiste", erscheint eine Auswahlbox. Hier selektiert man den Arbeitsplatz und klickt auf OK.

Danach erscheint der Arbeitsplatz mit allen Laufwerken in der Taskleiste. Damit das ganze noch komfortabler wird, schiebt man diese neue Leiste über den Anfasser soweit nach rechts zusammen, bis nur noch der Text "Arbeitsplatz" und ein Doppelpfeil sichtbar sind. Klickt man nun auf diesen Doppelpfeil, klappt eine Liste mit allen Laufwerke auf.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1021.htm


Explorer-Band zur Taskleiste hinzufügen

In diesem Tipp wird beschreiben, wie Sie die Explorer-Leiste zur Taskleiste hinzufügen können.

Wenn man mit zwei Monitoren arbeitet und in der Breite viel Platz hat, kann es sinnvoll sein, eine permanente Explorerleiste in die Taskleiste einzubinden.

Damit diese Auswahl angezeigt wird, müssen Sie erst einmal folgenden Eintrag in die Registry hinzufügen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ {EFA24E64-B078-11d0-89E4-00C04FC9E26E}\ Implemented Categories

erstellen Sie hier einen neuen Schlüssel mit den Namen "{00021493-0000-0000-C000-000000000046}". Anschließend sieht der Pfad folgendermaßen aus:

HKEY_CLASSES_ROOT\ CLSID\ {EFA24E64-B078-11d0-89E4-00C04FC9E26E}\ Implemented Categories\ {00021493-0000-0000-C000-000000000046}

Sie können diesen Eintrag auch über die folgenden REG-Datei anlegen lassen. Sichern Sie dafür den Inhalt als ExplorerBand.REG ab. Durch einen doppelklick im Explorer wird die Datei in die Registry importiert.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{EFA24E64-B078-11d0-89E4-00C04FC9E26E}\Implemented Categories\{00021492-0000-0000-C000-000000000046}]

=== Hier schneiden ===

Nach einem Neustart können Sie durch einen Rechtsklick auf die Taskleiste aus dem Kontextmenü unter "Symbolleisten" den Eintrag "Explorer-Band" auswählen und dadurch den Explorer zur Taskleiste hinzufügen.

Anschließend müssen Sie diesen neuen Eintrag in der Taskleiste noch entsprechend vergrößern.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2513.htm


Dateiattribute im Explorer anzeigen

Ab und zu kann es recht hilfreich sein, wenn man die Dateiattribute angezeigt bekommt. Standardmäßig zeigt der Windows Explorer diese Attribute nicht an. Am einfachsten können Sie die Anzeige des Explorers verändern, wenn Sie im Explorer mit der rechten Maustaste auf die Leiste mit den Spaltenüberschriften klicken (Dateiname, Größe, Typ usw.). Hier können Sie dann über "Mehr.." viele Parameter zur Anzeige hinzufügen und auch die Reihenfolge festlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellen Sie einen Wert mit dem Namen "ShowAttribCol" als Datentyp REG_DWORD. Wenn Sie diesen Wert auf 1 setzen, werden die Attribute angezeigt und durch 0 wieder ausgeblendet.

Siehe auch: "Ansicht der Dateiattribute in Windows 95/98".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen. :

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1120.htm


Netzwerkverbindungen mit Ordneransicht im Explorer öffnen

Mit diesem Tipp können Sie einstellen, dass Netzwerkverbindungen über UNC-Namen in der Ordneransicht im Explorer geöffnet werden.

Wenn Sie z.B. über "Start" -> "Ausführen" eine Netzwerkverbindung herstellen wollen ("\\Servername\Freigabe"), wird dieser Aufruf standardmäßig im Explorer ohne Ordneransicht geöffnet.

Wenn Sie aber auf der linken Seite gleich die Ordneransicht haben wollen, müssen Sie den folgenden Registryeintrag ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CLASSES_ROOT\ Folder\ shell\ open\ ddeexec

ändern Sie den Wert mit dem Namen "(Standard)" als Datentyp REG_SZ und tragen dafür "[ExploreFolder(\"%l\", %I, %S)]" ein, damit der Explorer in der Ordneransicht geöffnet wird.

Wenn Sie wieder auf die alte Anzeige zurückstellen wollen, tragen Sie hier "[ViewFolder(\"%l\", %I, %S)]" ein, was auch die Standardeinstellung von Windows ist.

Sie können den Eintrag auch über die folgende REG-Datei erzeugen. Speichern Sie dafür den Inhalt in eine Datei mit dem Namen "UNCExploreFolder.REG" ab, und führen Sie dann die Datei mir einem Doppelklick im Explorer aus.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec]

@="[ExploreFolder(\"%l\", %I, %S)]"

=== Hier schneiden ===

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2591.htm


Falsches Symbol für Favoritenordner

Sollte der Favoritenordner nicht mehr sein normales Symbol haben, kann man dies in der Registry wieder herstellen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ {1A9BA3A0-143A-11CF-8350-444553540000}\ DefaultIcon

muss als Standard eingetragen sein:

C:\WINDOWS\SYSTEM\shell32.dll,-173

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0891.htm


Einträge aus "Dokumente", "RUN" und "URL-History" löschen

Wenn Sie Dokumente usw. öffnen, werden die letzten geöffneten Dokumente unter "Start" -> "Dokumente" bzw. "Start" -> "Zuletzt verwendet" aufgezeichnet und verbleiben dort, bis sie durch neuere Dokumente ersetzt werden. Genauso werden auch unter RUN und in der URL-History die letzten Einträge gespeichert.

Sie können die Einträge vollständig löschen:

Windows 2000/XP

"Start" -> "Einstellungen" -> "Taskleiste und Startmenü.." -> Tabreiter "Startmenü" -> Button "Anpassen" -> "Löschen"

Ab Windows Vista

"Start" -> mit der rechten Maustaste auf "Zuletzt verwendet" klicken und aus dem Kontextmenü "Liste zuletzt verwendeter Elemente löschen" auswählen. Beim "klassischen Startmenü" gehen Sie unter -> rechte Maustaste auf "Start" -> "Eigenschaften" -> Tabreiter "Startmenü" -> Button "Anpassen" -> "Löschen".

Weiterhin können Sie hier auch einstellen, dass die Liste erst gar nicht erzeugt wird. Dafür gehen Sie unter -> rechte Maustaste auf "Start" -> "Eigenschaften" -> Tabreiter "Startmenü" und unter "Datenschutz" entfernen Sie die entsprechenden Haken.

Das System speichert Dokumentverknüpfungen im Benutzerprofil im Ordner "%UserProfile%\Recent".

Wenn Sie wollen, dass der Ordner immer beim Herunterfahren automatisch gelöscht wird, müssen Sie folgenden Eintrag in der Registry setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_Current_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ClearRecentDocsOnExit" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Einträge beim beenden leeren
gelöscht | Einträge lassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Beim Beenden die Liste der zuletzt geöffneten Dokumente leeren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0117.htm


Update-Wizard für Treiber konfigurieren

Mit diesem Tipp können Sie den Wizard deaktivieren, womit nach Updates für neue Treiber in Gerätemanager gesucht werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDevMgrUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Update Wizard ausblenden
0 | Update Wizard anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1658.htm


Diamond Fehler beim Update von Windows 95 auf 98

Bei einem Update von Windows 95 auf Windows 98 und Neuinstallation der Diamond-Treiber der Viper V550 kann man die Eigenschaften von Anzeige nicht mehr aufrufen. Windows meldet dabei immer einen Fehler in der Verarbeitung der Datei DESK.CPL

Lösung:

Löschen Sie alle Einträge von Diamond, die Sie unter folgendem Schlüssel finden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Controls Folder\ Display\ Shellex\ PropertySheetHandlers

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0656.htm


Caps-Lock beim Start immer aktiv

Auf einigen Windows 98-Systemen schaltet sich die Caps-Lock-Taste beim Hochfahren selbstständig ein. Caps-Lock schaltet sich auf Grund einer Inkompatibilität des mit Windows 98 mitgelieferten DOS-Tastaturtreibers KEYB.COM und des Windows-Treibers ein.

Das Problem tritt nicht nur mit USB-Tastaturen auf, wie Microsoft im Artikel Q247853 beschreibt, sondern kann auch bei PS/2-Geräten beobachtet werden.

Zur Abhilfe deaktiviert man in der Autoexec.bat (REM) das Laden von KEYB.COM. Dafür stimmt dann allerdings die Tastaturbelegung im DOS -Modus nicht mehr.

Alternativ kann man statt KEYB.COM einen anderen Tastaturtreiber laden. wie z.B. KDRIVE von http://www.datendienst.com/kdrive/KDrive.htmoder KBD von http://www.helmrohr.de/Download/Downind.htm

Unter dem Artikel Q151715 beschreibt Microsoft, wie man eine Debug-Datei erstellen kann, die Caps-on/off und Num on/off ermöglicht. Soll Caps beim Hochfahren deaktiviert werden, lädt man diese COM-Datei einfach beim Start in der Autoexec.bat

Folgende Änderung in der Autoexece.bat kann auch helfen:

keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

ändern in

keyb gr,,C:\WINDOWS\COMMAND\keybrd2.sys

Dieser alternative Tastaturtreiber wird von Microsoft mitgeliefert und wurde auch schon mit installiert.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=247853
http://support.microsoft.com/?kbid=151715

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1076.htm


Aufbau einer 32-Bit-DOS Umgebung (Xdos)

von: Oliver Riedl

Hier wird die Möglichkeit beschrieben, allein mit den Dateien bigmem.drv, ifsmgr.vxd, ios.vxd, rmm.pdr, vmm32.vxd und win.com ein 32-Bit-DOS zu starten, nachdem man eineDOS-Shell (wie command.com oder 4dos.com) in krnl386.exe umbenannt/kopiert hat. Wenn man Xdos startet, gelangt man in ein "32-Bit-DOS", in dem man:

  1. Zugriff auf lange Dateinamen,
  2. den Vorteil des gegenüber Smartdrv weitaus schnelleren VCACHE,
  3. die meisten Windows-Console-Anwendungen und
  4. den Vorteil eines blitzschnellen Wechsels (mit "exit" bzw. "win") zwischen Pure-Dos und "32-Bit-DOS" hat.

Um eine perfekte bzw. schöne Xdos-Installation zu haben, die

  • mit einem vorhandenen Windows problemlos im gleichen Laufwerk "lebt"
  • mit einem einzigen Befehl gestartet werden kann
  • ohne automatisches Ausschalten des Rechners zu DOS führt
  • nach dem Herunterfahren zu DOS einen Start von Windows erlaubt
  • ohne Fehlermeldungen arbeitet,

sind Massnahmen erforderlich, die ein erhebliches Grundwissen voraussetzen und von Microsoft so nicht vorgesehen sind.

Info Xdos ist unsicher und nur für "Bastler". Es kann abstürzen und aus noch unbekannten Gründen einfach den Rechner neu booten und zu Datenverlust führen. Ohne ein funktionierendes Backup sollte man diese Experimente nicht machen. Auf der anderen Seite haben Sie unter Xdos Zugriff auf lange Dateinamen.

Zur Vereinfachung werden folgende Bezeichnungen verwendet:

DOS | realmode dos 7.x
Windows | normales Windows 9x mit GUI
Xdos | das "32-Bit-Dos" (um das es hier geht)
SYSTEM_X | Umschreibung für einen Vorgang, der an dieser Stelle nicht weiter wichtig oder uns unbekannt ist
(!!) | "buchstäblich übernehmen"
xdos.bat | Batchdatei, mit der Xdos gestartet wird
4start.bat | Batchdatei, deren relative Notwendigkeit weiter unten deutlich wird
------------------ | Symbol für Anfang und Ende einer Text-Datei
Shell | command.com oder 4dos.com oder ...

Anmerkung zur Shell:

Ich empfehle einerseits aus Gründen, die unten deutlicher werden und andererseits wegen der ohnehin gegenüber command.com geradezu phantastischen Möglichkeiten, die Verwendung der 4dos.com.

Folgende Quellen sind wichtig bzw. interessant:

  • Freier Download von 4dos.com: http://jpsoft.com
  • Freier Download von Ralph Browns Interrupt-List: http://www.pobox.com/~ralf
  • Download SETREG.COM von Oliver Riedl: <Download>

Ich nehme hier die zwei bedenklichsten Punkte vorweg, erwähne einige Interna, gehe auf den speziellen Vorteil von 4dos.com unter Xdos ein und beschreibe die konkreten Schritte weiter unten.

Was tun, wenn beim Herunterfahren von Xdos (mit EXIT) nicht wieder DOS kommt, sondern entgegen dem möglichen Wunsch in DOS zu bleiben, Windows zu starten oder wieder Xdos zu starten, der Rechner ausgeht?

Mir ist vorerst nur die Möglichkeit bekannt, mit einem HEX-Editor (notfalls mit edit.com) herumzuhacken (siehe unten). Möglicherweise gibt es aber auch einen Registry-Eintrag, der das automatische Ausschalten verhindern kann. Der ist uns aber noch nicht bekannt.

Beim Start von Xdos sowie beim Start vom Windows sucht das System_X die Datei SYSTEM.DAT in dem Verzeichnis, das in der Datei MSDOS.SYS unter [PATHS] als winbootdir angegeben ist. (Ich dachte immer, die besondere (weil kleingeschriebene und mit dem normalen SET-Befehl nicht zu modifizierende) Umgebungsvariable winbootdir würde von System_X gelesen.)

Mit einem selbstgebastelten, erweiterten Set-Befehl kann man die %winbootdir% ändern, löschen usw. Das ist dem System egal, da es den Pfad zur Registryerkennt. Auch das Löschen der Pfadangabe zum Windows-Verzeichnis in der Umgebungsvariable PATHS ändert daran nichts. Ich kenne zwei Möglichkeiten, das System beim Start von Xdos daran zu hindern, die Windows-Registry zu lesen.

Die erste führt zu (harmlosen) Fehlermeldungen, ist aber auch mit der Unmöglichkeit verbunden, eine (vielleicht später einmal mit einem echten Inhalt versehene) Xdos-Registry einlesen zu lassen. Man benennt in der xdos.bat vor dem eigentlichen Start von Xdos das Windows-Verzeichnis um.

Die zweite Möglichkeit setzt voraus, dass man entweder mein beigelegtes Programm SETREG.COM (für das ich keine Verantwortung übernehmen kann) benutzt oder selbst in der Lage ist, ein solches Programm zu erstellen. Es ruft eine amtliche, aber von Microsoft (laut Interrupt-List von Ralph Brown) verschwiegene DOS-Funktion auf, mit der man den Pfad zur Registry setzen, modifizieren oder löschen kann.

Nach dem (erfolgreichen) Start von Xdos wird - aus mir unbekannten Gründen - nicht wie beim Start einer gewöhnlichen Sub-Shell die DOS-Umgebung (comspec, path, prompt, temp, tmp usw.) übernommen. Sie ist vollkommen weg und man befindet sich (bei Verwendung von command.com) vor dem leeren Prompt C>. Benutzt man 4dos.com, muss man nicht per Hand die 4start.bat aufrufen, die eine Umgebung einrichtet, denn 4dos.com ruft beim Start automatisch (falls vorhanden) 4start.bat auf.

Schritt 1: Sicherstellen, dass beim Einschalten des Rechners nicht Windows geladen wird.

In der MSDOS.SYS unter dem Abschnitt [options] bootgui=0 eintragen.

Schritt 2: Kopieren der benötigten Dateien.

Hier wird als Beispiel

  • das Verzeichnis C:\XDIR zum Root-Verzeichnis von Xdos gewählt,
  • davon ausgegangen, dass Windows im Verzeichnis C:\WINDOWS liegt und
  • weiterhin auch, dass die Umgebungsvariable COMSPEC auf eine gültige Shell zeigt.

md c:\xdir

md c:\xdir\system

md c:\xdir\system\vmm32

md c:\xdir\system\iosubsys

(!!) copy c:\windows\win.com c:\xdir\dos.com

copy c:\windows\system\vmm32.vxd c:\xdir\system

(!!) copy %comspec% c:\xdir\system\krnl386.exe

copy c:\windows\system\vmm32\ios.vxd c:\xdir\system\vmm32

copy c:\windows\system\vmm32\ifsmgr.vxd c:\xdir\system\vmm32

copy c:\windows\system\iosubsys\bigmem.drv c:\xdir\system\iosubsys

copy c:\windows\system\iosubsys\rmm.pdr c:\xdir\system\iosubsys

Info Anmerkung zum ersten (!!): Der Name dos.com dient dazu, dass man nicht aus Versehen Windows bzw. Xdos startet, wenn man eigentlich Xdos bzw. Windows starten will.

Info Anmerkung zu vmm32.vxd: Ich glaube, man darf nicht die vmm32.vxd von der Windows-Installations-CD nehmen, da sie ohne Treiber ist.

Schritt 3: Erstellen einer c:\xdir\system.ini

Für den Anfang genügt eine >>system.ini<<, die einzig und allein

------------------

[386Enh]

------------------

enthält. Für mögliche weitere Einträge siehe unten.

Schritt 4: Notwendige Schönheitsoperationen für den Start

Würde man jetzt (im Verzeichnis c:\xdos) "dos" eingeben, würde er wie in der Einleitung erwähnt in C:\WINDOWS\SYSTEM.DAT lesen (und schreiben?). Man sollte sich eine Batch-Datei (xdos.bat) anfertigen und

in einem Verzeichnis des Pfades (PATHS) ablegen. (Das Verzeichnis xdir muss nicht im Pfad liegen).

Möglichkeit 1: xdos.bat ohne Verwendung von SETREG.COM (Xdos startet, es werden aber Fehlermeldungen ausgeben)

------------------

@echo off

ren c:\windows _windows

c:\xdir\dos

------------------

Möglichkeit 2: xdos.bat mit SETREG.COM und Xdos-Registy

Man erstellt sich eine vorerst leere Registry, indem man erst eine TXT-Datei (zum Beispiel c:\xdir\xdos.reg) mit dem einzigen Inhalt

------------------

REGEDIT4

------------------

erstellt und dann den folgenden Befehl aufruft.

(!!) regedit /l:c:\xdir\SYSTEM.DAT /r:c:\xdir\user.dat /c c:\xdir\xdos.reg

Die Batchdatei könnte dann so aussehen:

------------------

@echo off

setreg C:\XDIR\SYSTEM.DAT

c:\xdir\dos

------------------

Info Anmerkung zu den Batches: Ich habe mir noch eine Abfrage eingebaut, die sicherstellt, dass sich das System in DOS (und nicht in Xdos oder Windows befindet).

Schritt 5: Notwendige Schönheitsoperationen für den Betrieb.

Nach meinen bisherigen Erfahrungen liest (schreibt?) Xdos nicht mehr NACH dem Start in der Registry. Da man damit rechnen muss, dass ein System abstürzt oder dass man nicht in der Lage ist, das automatische Abschalten des Rechners zu umgehen, sollten die Veränderung (Umsetzen der Pfadangabe zur Registry bzw. Umbennenen des Windows-Verzeichnis) jetzt gleich in der 4start.bat rückgängig gemacht werden.

Möglichkeit 1: Ohne Verwendung von SETREG.COM (siehe Schritt 4)

Man muss bei Verwendung von command.com als krnl386.exe per Hand die 4start.bat aufrufen, die wie folgt aussehen könnte. (Benutzt man 4dos.com als krnl386.exe genügt das blosse Vorhandensein der 4start.bat im Verzeichnis c:\xdir\system)

------------------

@echo off

set comspec=(indivudell anpassen)

prompt (indivudell anpassen)

path (indivudell anpassen)

set temp=(indivudell anpassen)

set tmp=(indivudell anpassen)

rem Da jetzt lange Dateinamen verarbeitet werden

rem schreibe ich windows gross

ren c:\_windows WINDOWS

------------------

Möglichkeit 2: Verwendung von SETREG.COM (siehe Schritt 4)

------------------

@echo off

set comspec=(indivudell anpassen)

prompt (indivudell anpassen)

path (indivudell anpassen).

set temp=(indivudell anpassen)

set tmp=(indivudell anpassen)

rem Jetzt braucht's keine Pfadangabe zu SETREG.COM

setreg C:\WINDOWS\SYSTEM.DAT

------------------

Wie man das automatische Ausschalten des Rechners verhindert.

(!!) 1. Wenn man Assembler-Kenntnisse hat:

Man sucht in der dos.com den ERSTEN Aufruf der Funktion "APM 1.0+ Installation-Check" (ax = 5300h, int 15h) und ändert dann mit einem HEX-Editor das erste Byte vom Befehl "int 15h" (CD 15) zum Befehl "cmp al, 15h" (3C 15). Danach sollte dos.com davon ausgehen, dass kein APM vorhanden ist und mit der normalen Meldung: "Sie können den Rechner jetzt ..." enden.

(!!) 2. Wenn man keine Assembler-Kenntnisse hat:

Besteht das Problem darin, dass nicht nur für jede Windows-Version, sondern vermutlich auch für jede Sprachversion der hexadezimale Offset, an dem der Befehl steht, eine andere Adresse hat. Ich kann hier nur eine Angabe für das deutsche Windows98SE machen, in dem die dos.com die Länge 25.399 Byte und die Creation-Time "05.05.1999 22:22" hat.

BEI JEDER ANDEREN VERSION FÄHRT DER FOLGENDE HACK ZU VOLLKOMMEN UNVORHERSEHBAREN ERGEBNISSEN BIS HIN ZUM VÖLLIGEN DATENVERLUST.

Mit "edit /589 c:\xdir\dos.com" die dos.com öffnen, das letzte Zeichen in Zeile 8 von "Í" auf "<" ändern und speichern.

Zur Kontrolle, dass man alles richtig gemacht hat, muss die Ausgabe des Befehls

fc/b c:\xdir\dos.com c:\windows\win.com

genau Verglichen werden... "00001267: 3C CD" sein.

Weitere Möglichkeiten für system.ini's

Diese system.ini verhindert das Erstellen einer SWAP

------------------

[386Enh]

Paging=off

------------------

Diese system.ini sorgt für eine SWAP, man kann die gleiche SWAP wie Windows verwenden

------------------

[386Enh]

ConservativeSwpafileUsage=1

PagingFile=(individuell anpassen)

MinPagingFileSize=(Zahlenwert in Kilobyte individuell anpassen)

MaxPagingFileSize=(Zahlenwert in Kilobyte individuell anpassen)

[vcache]

MinFileCache=(Zahlenwert in Kilobyte individuell anpassen)

MaxFileCache=(Zahlenwert in Kilobyte individuell anpassen)

------------------

Wichtiger Geheimtip für das folgende.

Man kann im DOS-Editor mit "Strg+2" (NICHT die 2 auf dem Ziffernblock, sondern die normale 2) das Zeichen <NUL> (also das Zeichen mit dem Ascii-Code 0) eingeben.

Wen es nervt, dass Xdos die Dateien ios.log und wnbootng.sts erstellt, der kann mit einem Hexeditor oder edit.com in ios.vxd den Eintrag "IOS.LOG" in <NUL>OS.LOG und in vmm32.vxd den Eintrag "WNBOOTNG.STS" in <NUL>NBOOTNG.STS ändern.

Wen es stört, dass die "Handvoll" Dateien von Xdos gleich drei Unterverzeichnisse (system, system/vmm32 und system/iosubsys) brauchen, der kann mit einem Hexeditor oder edit.com in dos.com den Eintrag "system\vmm32.vxd" in "vmm32.vxd<NUL>32.vxd" in ios.vxd den Eintrag "IOSUBSYS\*.vxd" in "IOSUB\..\*.vxd" und in vmm32.vxd den Eintrag "VMM32\*.VXD" in "VM\..\*.VXD" ändern und danach alle Dateien im Verzeichnis C:\Xdos halten.

DOS-CDROM-Treiber ohne mscdex.exe mit den Windows-CDROM-Treiber

Hier wird beschrieben, wie man unter "Xdos" die Windows-CDROM-Treiber einbindet. Man benötigt neben den in meiner Anleitung zur "Installation von xdos" aufgeführten Dateien/Treibern einerseits die folgenden Treiber

C:\WINDOWS\SYSTEM\BIOS.VXD

C:\WINDOWS\SYSTEM\PCI.VXD

C:\WINDOWS\SYSTEM\IOSUBSYS\CDFS.VXD

C:\WINDOWS\SYSTEM\IOSUBSYS\CDTSD.VXD

C:\WINDOWS\SYSTEM\IOSUBSYS\CDVSD.VXD

C:\WINDOWS\SYSTEM\IOSUBSYS\ESDI_506.PDR

C:\WINDOWS\SYSTEM\IOSUBSYS\VOLTRACK.VXD

und andererseits die Registry-Einträge aus

HKEY_LOCAL_MACHINE\ENUM\BIOS

HKEY_LOCAL_MACHINE\ENUM\MF

HKEY_LOCAL_MACHINE\ENUM\PCI

HKEY_LOCAL_MACHINE\ENUM\Root

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCDFSD

Einige irrelevante Unterpunkte dieser Registry-Einträge können (und müssen zur Vermeidung von Fehlermeldungen) gelöscht werden.

Nach der Einbindung verlängert sich die Startzeit bei meinem Rechner (850MHz) von ca. 3 auf ca. 6 Sekunden.

Einige Tips, um ein auf CD gebranntes Windows-9x mit und ohne eingehängte Festplatte(n) von CD zu booten

Ich beschreibe hier die Möglichkeit, nahezu die gesamte (vermutlich immer notwendige RamDisk) als Cache und TEMP-Verzeichnis zu Verfügung zu haben.

Startet man von einer Boot-CD, die mit "Harddisk-Emulation" erstellt wurde, dann beansprucht die Boot-CD die Laufwerksnummer 128 (erste Festplatte) und macht dadurch (zumindest bei Vorhandensein von 2 Festplatten) jede Art von Zugriff auf die erste Festplatte unmöglich.

Man kann einer Boot-CD, die mit "Floppy-Emulation" erstellt wurde, durch folgenden Trick sogar dann den Laufwerksbuchstaben C: zuordnen, wenn das Festplattenlaufwerk C: vorhanden und gültig ist.

subst z: c:\

xmsdsk 16 y: /y

subst c: y:\

xmsdsk /y /u

Zeile 1 ermöglicht den Zugriff auf C: mit Z:,

Zeile 2 lädt temporär eine kleine Ramdisk auf Y:,

Zeile 3 lässt den Laufwerksbuchstaben C: auf Y: zeigen,

Zeile 4 entlädt die temporäre Ramdisk und macht C: damit für MSCDEX frei.

Nach diesem Eingriff ist Y: ungültig, aber NICHT frei. Ein Zugriff auf Y: führt zum Hänger. Es empfiehlt sich daher, vor dem Ende der autoexec.bat (mit subst) Y: auf ein gültiges Laufwerk zeigen zu lassen.

Durch die Möglichkeit, dem CDROM-Laufwerk den Buchstaben C: zuzuordnen, sind kaum Veränderungen nötig, um ein auf der Festplatte C: vorhandenes Windows-9x auf CD zu brennen und von dort zu starten. Die Registry (SYSTEM.DAT + user.dat) muss vor dem Starten von Windows auf eine RamDisk kopiert werden und in der MSDOS.SYS muss unter dem Abschnitt [PATHS] der Eintrag "winbootdir=" auf das RamDisk-Verzeichnis zeigen. Bei Verwendung des Browsers Mozilla muss (unter windows-98) nur in die Datei C:\WINDOWS\Anwendungsdaten\Mozilla\Firefox\profiles.ini ein Verzeichnis auf der RamDisk angegeben werden. Andere Anwendungen, die Daten schreiben müssen oder wollen, müssen in ähnlicher Weise auf die RamDisk umgelenkt werden.

Info Verbesserungsvorschläge zu diesen Tipp nehmen wir gern entgegen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1826.htm


Fehler in DOS wegen fehlender Share.exe

Im Gegensatz zu Windows 95 bietet die 98er-Version keine Share.exe mehr an. Sollte eine DOS-Anwendung nach dieser Datei suchen und dann mit einer Fehlermeldung abbrechen, hilft folgender Tipp:

Man erstellt eine leere Datei (mit Notepad etc.) mit dem Namen Share.exe im Ordner Windows\Command. Das DOS -Programm findet die Datei und begnügt sich mit der Fälschung.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0862.htm


Notfalldiskette aus DOS erstellen

Windows 98 legt im Verzeichnis Windows\Command\EBD eine Kopie der Notfalldiskette an. Diese kann im DOS Prompt mit dem Befehl bootdisk.bat erstellt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0861.htm


Unterstützung der langen Dateinamen für Novell Netware aktivieren

Damit die langen Dateinamen LFN (Long Filenames) von Novell Netware unterstützt werden, müssen Sie folgenden Wert in der Registry eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ NWREDIR

Erstellen Sie hier einen neuen Wert mit dem Namen "SupportLFN" als Datentyp REG_DWORD. Setzen Sie den Eintrag auf einen der folgenden Werte:

0 -> LFN Unterstützung deaktiviert

1 -> LFN Unterstützung ab Netware 3.12

2 -> LFN Unterstützung für alle Netware Server

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0947.htm


Antwortverhalten bei mehr als einer Netzwerkkarte

Dieser Tipp legt fest, welche IP-Adresse Windows bei einer Anfrage zurückgibt.

Standardmäßig gibt Windows die IP-Adresse der Netzwerkkarte zurück, wo die Anfrage auch angekommen ist. Wenn Sie den Wert "RndomAdapter" aktivieren (Festlegung auf "1"), wird eine zufällig aus dem eigenen Adressensatz ausgewählte IP-Addresse zurückgegeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ NetBT\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "RndomAdapter" als Datentyp REG_DWORD (Bei Windows 98 handelt es sich um eine Zeichenfolge - REG_SZ Wert) und setzen den Wert auf:

0 | Adresse der eingehenden Netzwerkkarte (Standard)
1 | Eine zufällige Adresse aus dem IP Adressensatz

Dabei handelt es sich nicht, wie auf einigen Seiten angegeben, um ein echtes Load Balancing.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2649.htm


Windows NT und Windows 98 im Netz über TCP/IP

Ein PC mit Windows 98 und ein zweiter mit Windows NT Workstation sollen Verbunden werden. Auf beiden Rechnern ist TCP/IP installiert, 192.168.0.1 beziehungsweise 192.168.0.2 als IP-Adressen sowie 255.255.255.0 als Subnet-Mask eingestellt. Trotzdem kommt keine Netzwerkverbindung zustande. Es ist nur mit NetBEUI oder IPX/SPX möglich, Daten zu übertragen.

Wenn ein Ping zwischen den Rechnern funktioniert, liegt das Problem vermutlich an der Namensauflösung.

Da Sie wohl keine WINS- oder DNS-Server laufen haben, müssen Sie auf beiden Rechnern eine Datei LMHOSTS anlegen und dort ihre konkreten Angaben Eintragen. Die Datei befindet sich unter NT im Verzeichnis %SYSTEMROOT%\system32\drivers\etcund unter Windows 98 im Stammverzeichnis, standardmäßig C:\windows.

LMHOSTS regelt die Umsetzung von IP-Adressen auf NetBIOS -Namen, wie sie das Windows-Netzwerk verwendet. Für jeden Rechner gibt es eine Zeile. Darin steht die IP-Adresse, gefolgt von mindestens einem Leerzeichen und dem NetBIOS -Namen, also etwa so:

192.168.0.1 erster

192.168.0.2 zweiter.

Die Datei Hosts (im selben Verzeichnis) besitzt ein ähnliches Format. Sie dient der Umsetzung der Host-Namen im TCP/IP-Netz auf IP-Adressen. Zusätzlich kann dem Rechnernamen die Bezeichnung der TCP/IP-Domain sowie ein optionaler Alias-Name folgen:

192.168.0.1 erster.rechner.micha.de erster

192.168.0.2 zweiter.rechner.micha.de zweiter.

Die verwendeten Namen müssen wie üblich in den Dialogen der Netzwerkeinstellungen stehen. Unter NT muss man zusätzlich die Namensauflösung mit LMHOSTS aktivieren (in den Netzwerk-Einstellungen in den Eigenschaften des TCP/IP-Protokolls unter dem Register WINS). Nach einem Neustart beider Systeme sollte alles funktionieren. Unter Umständen ist für die erste Verbindungsaufnahme der Aufruf `Computer suchen´ im Netzwerk-Abschnitt des Explorers notwendig.

(Der Tipp stammt aus der c't 11/99 Seite 200).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0919.htm


Rechner bootet bei eingehendem Anruf

Unter Windows 95 gab es in der Energieverwaltung die Option "Computer bei eingehendem Anruf reaktivieren", mit deren Deaktivierung der Rechner nicht mehr startete, wenn ein Anruf einging.

Unter Windows 98 wird diese Funktion vermisst. Selbst ein Deaktivieren des MODEM-WAKE UP im BIOS bringt keine Hilfe. Möchte man den Rechner dennoch nicht starten lassen, muss Windows 98 im DOS mit dem Parameter Setup /pj installiert werden. Damit wird verhindert, dass der Rechner bei einem eingehenden Anruf gestartet wird.

Wurde Windows 98 über Windows 95 installiert und dort die Funktion bereits deaktiviert, treten keine Probleme auf.

Der Tipp stammt von Asus auf Anfrage von Frank Richter und sollte auch bei anderen Boards funktionieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0930.htm


Beim Online Update von Windows tritt ein Fehler auf

Dieser Fehler kann auftreten, wenn bei Ihnen noch der IE 4.0 Installiert ist. Wenn Sie damit ein Online Update herunterladen wollen kann es passieren, dass die Fehlermeldung "Beim Download ist ein Fehler aufgetreten" auftaucht.

Das liegt daran, dass der IE versucht, die für das Update benötigten Dateien im Verzeichnis "MSDOWNLD.TMP" abzulegen. Wenn sich in diesem Verzeichnis aber noch alte Dateien befinden, kommt es zu dieser Fehlermeldung und das Update kann nicht durchgeführt werden.

Öffnen Sie das Verzeichnis mit dem Explorer (Sie müssen aber eingestellt haben, dass auch versteckte Dateien angezeigt werden, da dieser Ordner als versteckt markiert ist). Löschen Sie einfach den Ordner "MSDOWNLD.TMP" und versuchen Sie es danach noch einmal.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0644.htm


Rechner stürzt beim Faxen ab

Sollte beim Faxversand über MS Exchange der Rechner hängen oder abstürzen, könnte Corel Draw 7 die Ursache sein. Das Programm überschreibt bei der Installation die Datei mapi32.dll, welche in der Version 4.00.736.9 installiert wird und amerikanisch ist. Daher wird Sie vom System als neuer erkannt und eine Ersetzung vom MessageServer zugelassen.

Um diesen Fehler wieder zu beheben, wechselt man in die Systemsteuerung unter Software/Windows Setup und entfernt dort Microsoft Exchange und Microsoft Fax. Nach einem Neustart fügt man beide Applikationen wieder hinzu, und die Dateien werden von der Windows CD zurückgespielt. Dabei meldet Windows, dass eine neuere Datei bereits vorhanden ist. Genau diese sollte man dann überschreiben lassen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0687.htm


Windows 98 und FAX-Programm

Bei Windows 98 wird das FAX-Programm bei der Installation nicht angeboten und auch nicht installiert. MS hat aber das alte FAX-Programm von Windows 95 mit auf die CD gepackt und zwar im Verzeichnis: "\tools\oldwin95\message" liegen die FAX und Messaging Module.Dieses FAX-Programm funktioniert ohne Probleme auch unter Windows 98.

Zunächst startet man von der Windows 98 CD unter Tools\OldWin95 die Datei WMS.exe.

Danach installieren Sie die Datei AWFAX.exe.

Ist die Installation beendet, wechselt man in die Systemsteuerung und klickt auf "MAIL". Hier wird dann gefragt, welche Dienste verwendet werden sollen. Wählen Sie nur FAX-Dienst, da Windows 98 einen E-Mail-Dienst bereits besitzt.

Ist die Installation beendet, erscheint im Kontextmenü des Explorers bei "Senden an" der Eintrag FAX-Empfänger.

Nun stehen wieder alle FAX-Funktionen wie früher zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0349.htm


Meldung DFÜ kann nicht initialisiert werden

Sollte beim Start des DFÜ Netzwerks die Meldung " DFÜ kann nicht initialisiert werden, bitte Computer neu starten oder DFÜ neu installieren" angezeigt werden, hilft nur eine Radikalkur:

In der Systemsteuerung unter SOFTWARE, WINDOWS SETUP deinstalliert man das DFÜ-Netzwerk, startet den Rechner danach neu und installiert das DFÜ-Netzwerk wieder auf dem gleichen Wege.

Tipps zum Deinstallieren:

Das DFÜ Netzwerk entfernt man am besten über die Systemsteuerung/Software. Danach wechselt man in den DOS -Modus und benennt folgende Dateien wie folgt um:

cd \windows\system

ren pppmac.vxd pppmac.dxv

ren rnasetup.dll rnasetup.old

ren rnaapp.exe rnaapp.eex

ren rnaui.dll rnaui.lld

ren rnanp.dll rnanp.lld

ren rnathunk.dll rnathunk.lld

ren rasapi16.dll rasapi16.lld

ren rasapi32.dll rasapi32.lld

ren rnaserv.dll rnaserv.lld

ren smmscrpt.dll smmscrpt.lld

ren smmsetup.dll smmsetup.lld

ren splitter.vxd splitter.dxv

ren spap.vxd spap.dxv

ren vgateway.vxd vgateway.dxv

ren wsock32.dll wsock32.lld

ren rnaph.dll rnaph.lld

ren wsock.vxd wsock.dxv

ren vdhcp.386 vdhcp.683

ren vip.386 vip.683

ren vnbt.386 vnbt.683

ren vtcp.386 vtcp.683

ren vtdi.386 vtdi.683

cd..

ren winsock.dll winsock.old

cd \progra~1\zubehör (bzw. cd \progra~1\access~1)

ren slipmenu.scp slipmenu.old

ren slip.scp slip.old

cd \windows\inf

ren rna.inf rna.fni

Unter Umständen sind einige Dateien nicht vorhanden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=181599

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0868.htm


DFÜ-Ordner von Win98 reagiert nicht mehr

DFÜ-Ordner von Windows 98 reagiert nicht mehr

Sollte sich der Ordner DFÜ-Netzwerk nicht mehr öffnen lassen, installiert man das VPN (Virtual Privat Network unter Software/Windows Setup/Netzwerk) von der Windows 98 CD-Rom und schon geht alles wieder. Danach kann man das VPN wieder deinstallieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0693.htm


AVM-Karte wird nach der Installation nicht gefunden

Wird gem. der Anleitung von AVM (Hardwareassistent, sonstige Geräte, INF-Datei der AVM-Karte wählen) die Karte installiert,so kann es vorkommen, dass die Installation nicht klappt. Man kann diese aber dennoch ohne Ausbau installieren.

Zunächst in den Hardwareassistent =>Neue Komponente =>nicht aufgelistet =>Diskette wählen und dann auf die INF-Datei der AVM-Treiber verweisen. Direkt danach in den Gerätemanager und die Adresse der Karte richtig einstellen (wird keine PNP Karte eingesetzt).

Nach einem Reboot findet die Installationsroutine die Karte dennoch nicht, weil die Karte sich unter sonstige Geräte einträgt. Daher aus dem Gerätemanager löschen und erneut den Hardwareassistenten starten. Jetzt erscheint direkt eine Rubrik AVM-ISDN-Controller. Nach der erneuten Installation (Treiber sind schon im System) ggf. noch die Adresse anpassen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0889.htm


Powermanagement für Modem Cards deaktivieren

Einige Modemkarten funktionieren nicht richtig oder reagieren zu spät beim Wahlversuch, wenn das APM für diese Geräte aktiviert ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ VCOMM

den Schlüssel "EnablePowerManagement" als Datentyp REG_DWORD von 01 00 00 00 auf 00 00 00 00 ändern.

Optional kann man auch das DFÜ-Netzwerk so beeinflussen, dass das System länger wartet, bis das Modem betriebsbereit ist. Dazu ergänzt (oder ändert) man den Eintrag "ConfigDelay" (DWORD Eintrag) auf 6000 (Millisekunden ) unter

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Modem

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0435.htm


Die Internetverbindungsfreigabe einrichten und konfigurieren

Internetverbindungsfreigabe (ICS) einrichten und konfigurieren

Ab Windows 98SE und ab Windows 2000 gibt es die neue Möglichkeit der "Internetverbindungsfreigabe", auch "Internet Connection Sharing" (ICS) genannt. Da ich schon einige Anfragen bekommen habe wie man das denn nun einrichtet, möchte ich es hier kurz beschreiben.

Was ist die Internetverbindungsfreigabe?

Mit dieser Funktion können Sie den Zugang zum Internet über einen Rechner im gesamten Netzwerk zu Verfügung stellen. Dabei fungiert ein Rechner im Netzwerk als Internetserver, der als einziger direkt Zugriff auf das Internet hat (Modem, ISDN usw.). Alle anderen Rechner im Netzwerk greifen über das Netzwerk auf den Internetserver zu, der wiederum die Verbindung zum Internet aufbaut.

Welches Betriebssystem ist als Server besser geeignet?

Da das TCP/IP Protokoll von Windows 2000 sehr verbessert wurde, ist Windows 2000 besser geeignet als Windows 98SE bzw. ME.

Welche Voraussetzungen müssen erfüllt sein?

- Sie müssen ein funktionierendes Netzwerk besitzen, welches mit TCP/IP arbeitet.

- Sie müssen auf dem Server schon die Internetverbindung eingerichtet haben.

Welche Vor- und Nachteile habe ich dadurch?

Der Vorteil ist, dass nur ein Rechner eine Verbindung zum Internet (Provider) aufbauen muss. Alle anderen Rechner können diese Verbindung nutzen. In kleinen Netzwerken (privat) ist diese Funktion gut zu gebrauchen, da sie leicht einzurichten ist.

Da diese Funktion aber nur mit einem bestimmten Bereich von IP-Adressen läuft und kein DHCP möglich ist, ist es in großen Netzwerken schon nicht mehr zu gebrauchen. Ein weiterer Nachteil ist natürlich auch, dass sich alle Rechner die zur Verfügung stehende Bandbreite teilen müssen. Eine andere Möglichkeit dafür finden Sie unter "Internetzugang für alle Rechner im Netzwerk kostengünstig konfigurieren".

Welchen IP-Bereich darf ich benutzen?

Die Internetverbindungsfreigabe funktioniert nur mit den IP Adressen 10.0.0.xxx und 192.168.0.xxx, wobei der Internet-Server immer den Wert 1 in der letzten Stelle trägt. Für xxx können Sie Werte zwischen 1 und 254 verwenden (0 und 255 sind reservierte Adressen, die die absolute Netzadresse und die Broadcast Adressen "verkörpern"). Als Subnetmaske sollten Sie 255.255.255.0 verwenden.

Sie können diese IP-Adressen fest vergeben oder die Vergabe dem integrierten DHCP-Server der Verbindungsfreigabe überlassen. Bei Windows 2000 bringt die Vergabe von festen IP-Adressen meist sogar große Probleme mit sich und es ist nicht möglich, eine Verbindung zum Server zu bekommen. Sollte das passieren, stellen Sie einfach einmal auf DHCP um, meist hat sich das Problem dann erledigt.

Internet Server einrichten

Windows 98 SE oder ME

Hier muss die Internet-Verbindungsfreigabe erst installiert werden. Dazu gehen Sie über "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Software" ins "Windows Setup". Hier finden Sie unter "Internet-Programme" die "Internetverbindungsfreigabe", wo Sie die die Checkbox anklicken und "Übernehmen" auswählen.

Jetzt startet ein Assistent, der Sie bei der Installation unterstützen soll. Als erstes sollten Sie die Verbindungsart (Modem, ISDN usw.) angeben. Danach verlangt Windows nach einer Diskette, um die benötigten Daten für die Client-Konfiguration zu speichern.

Nach der Installation erscheint die Meldung: "Die IP-Adresse Ihres Rechners wird für die gemeinsame Nutzung auf 192.168.0.1 geändert". Bestätigen Sie die Meldung und führen Sie einen Neustart durch.

Nun ist die Internet-Verbindungsfreigabe eingerichtet. Die Einstellungen können Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk" -> "TCP/IP Protokoll Netzwerkkarte" unter "Eigenschaften" überprüfen.

IP-Adresse | 192.168.0.1
Subnetmaske | 255.255.255.0

Client Verbindung einrichten

Wenn Sie als Internet-Server Windows 98 SE/ME benutzt haben, können Sie auch die erstellte Client-Diskette benutzen, um die Clients entsprechend zu konfigurieren. Führen Sie dafür einfach auf den jeweiligen Clients die Datei "iclclset.exe" von der Diskette aus. Daraufhin wird ein entsprechender Assistent gestartet, der bei der Konfiguration hilft. Eingaben sind hierbei von Ihnen nicht mehr nötig.

Die Datei finden Sie auch auf dem Server im Verzeichnis "C:\Windows\System"

Wollen Sie die Konfiguration selbst durchführen oder Windows 2000 als Server benutzen (welches aber keine Diskette für das Anlegen der Clients zur Verfügung stellt), gehen Sie folgendermaßen vor:

Windows 9x/Me

"Start"-> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk" -> "TCP/IP Protokoll" unter "Eigenschaften" die IP-Adresse 192.168.0.xxx(xxx=2-254) eingeben oder auf automatischer Zuweisung stehenlassen. Wenn Sie hier eine Adresse selber angeben, ist es wichtig zu beachten, dass jede Adresse im ganzen Netzwerk nur einmalig vorkommen darf.
Die Subnetmask stellen Sie auf 255.255.255.0 oder lassen die Einstellung auf automatische Zuweisung. Wenn Sie die Adresse angeben, muss hier das gleiche stehen wie beim Server.

Gateway: 192.168.0.1 (die IP-Adresse des Servers)
DNS Server: 192.168.0.1 (die IP-Adresse des Servers)

Info Achten Sie zudem darauf, dass der Eintrag WINS deaktiviert ist. Siehe auch: "Internernetverbindungsfreigabe (ICS) Client manuell konfigurieren".

Ab Windows 2000

Als erstes müssen Sie bei Ihrer erstellten Internetverbindung die gemeinsame Nutzung freigeben. Ihre Internetverbindungen finden Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk- und DFÜ-Verbindungen". Hier klicken Sie nun die Internetverbindung mit der rechten Maustaste an, die Sie im Netzwerk freigeben wollen und wählen aus dem Kontextmenü "Eigenschaften" aus.

Jetzt müssen Sie im Register "Gemeinsame Nutzung" unter dem Eintrag "Gemeinsamer Zugriff" die gemeinsame Nutzung aktivieren. Jetzt erscheint die Meldung: "Die IP-Adresse Ihres Rechners wird für die gemeinsame Nutzung auf 192.168.0.1 geändert".

Sie sollten auch die Einstellung "Wählen bei Bedarf" aktivieren, so dass Windows automatisch die Verbindung aufbaut, wenn eine Verbindung ins Internet benötigt wird. Sie müssen aber selber dafür sorgen, dass die Verbindung bei Nichtgebrauch wieder abgebaut wird.

Egal wie viele verschiedene Internetverbindungen Sie im DFÜ-Netzwerk eingerichtet haben, Sie können immer nur eine Verbindung für die gemeinsame Nutzung freischalten.

Sie müssen jetzt unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk- und DFÜ-Verbindung" die freigegebene Verbindung auswählen und über die rechte Maustaste aus dem Kontextmenü "Eigenschaften" -> "Internetprotokoll (TCP/IP) -> "Eigenschaften" folgendes einstellen:

IP-Adresse | 192.168.0.1
Subnetmaske | 255.255.255.0

So, das war alles, was Sie auf dem Internet Server einrichten müssen. Starten Sie den Rechner neu. Jetzt müssen Sie nur noch die Clients entsprechend konfigurieren.

Windows 2000

"Start"-> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk- & DFÜ- Verbindungen" -> "LAN Verbindung" -> "Datei" -> "Eigenschaften" -> "Internetprotokoll TCP/IP" -> unter "Eigenschaften":

IP-Adresse 192.168.0.xxx (xxx=3-254) oder automatische Zuweisung lassen. Wenn Sie hier eine Adresse selber angeben, ist es wichtig zu beachten, dass jede Adresse im ganzen Netzwerk nur einmalig vorkommen darf.

Subnetmask: 255.255.255.0 oder automatisch zuweisen lassen. (Wenn Sie die Adresse angeben, muss hier das Gleiche stehen wie beim Server).

Gateway: 192.168.0.1 (die IP-Adresse des Servers)
DNS Server: 192.168.0.1 (die IP-Adresse des Servers)

Achten Sie zudem darauf, dass der Eintrag WINS deaktiviert ist.

Damit der Client nun keine eigene Verbindung aufbaut, müssen Sie noch folgendes umstellen:

In der Systemsteuerung unter "Internetoptionen" im Register "Verbindungen" entweder einstellen "keine Verbindung wählen" (Windows 98) oder "Verbindung über ein lokales Netzwerk herstellen" (Windows 95).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1050.htm


Idle-Time für Internet-Verbindungsfreigabe festlegen

Die Internetverbindungsfreigabe trennt nach Ausbleiben von Anfragen die Internetverbindung auf dem Host-Rechner standardmäßig erst nach 300 Sekunden. Man kann den Wert aber auch verkürzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ ICSharing\ Settings\ General

ist hierfür der Wert "HangupTimer" als Datentyp REG_SZ relevant. Der dort angegebene Wert gibt die Sekunden bis zur Trennung an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1165.htm


Internet Verbindungsfreigabe (ICS) konfigurieren

Mit diesem Tipp können Sie die Internet Verbindungsfreigabe (ICS) von Windows konfigurieren. Mit der Internet Verbindungsfreigabe können sich Rechner in Netzwerk das Internet teilen.

Bei IP und Subnet-Mask müssen Sie die IP-Adresse und Subnet des Rechners eingeben, der die Verbindung zum Internet aufbaut und zwar durch ein Komma getrennt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ ICSharing\ Settings\ General

Erstellen Sie hier folgende Werte:

Name | Datentyp | Wert | Beschreibung
Enabled | REG_DWORD | 1 | ICS aktivieren
EnableDHCP | REG_DWORD | 1 | DHCP aktivieren
EnabledDNS | REG_DWORD | 1 | DNS aktivieren
IntranetInfo | REG_SZ | Beispiel: 192.168.0.2,255.255.255.0 | IP und Subnet-Mask

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1610.htm


Passwörter müssen Zahlen enthalten

Wenn Sie möchten, dass Anwender beim Anlegen von Passwörtern unbedingt auch Zahlen mit verwenden, um die Sicherheit etwas zu erhöhen, legen Sie folgenden Eintrag in der Registry an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

legen Sie einen neuen Wert mit dem Namen "AlphanumPwds" als Datentyp REG_SZ an. Setzen Sie diesen Eintrag auf 1, um die Eingabe von Zahlen zu erzwingen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Network

können Sie durch den Eintrag "MinPwdLen" als Datentyp REG_BINARY durch eine Zahl die Mindestlänge des Passwortes festlegen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Kontorichtlinien\Kennwortrichtlinien
Einstellungsname: | Minimale Kennwortlänge

Info Siehe auch: "Verbesserte Passwortsicherheit erzwingen".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0472.htm


Sicherheitskopie der Windows Einstellungen (SCANREG.EXE)

Ab Windows 98 hat MS das Tool ERU durch Scanreg ersetzt. Wenn Sie das alte Windows noch haben, können Sie natürlich dieses Tool auch weiterhin unter Windows 98 benutzen.

Es gibt zwei Dateien:

scanreg -> für DOS

und

scanregw.exe -> für Windows (kann mit dem Parameter "/autorun" z.B. über einen Autostart aufgerufen werden)

Scanreg legt automatisch unter Windows 98 fünf Sicherheitskopien Ihrer Einstellungen an und speichert diese Dateien im Verzeichnis "\Windows\Sysbckup" als "RB00x.CAB" ab (wobei x für eine Zahl von 0-5 steht).

Welche Dateien Scanreg sichern soll, wird durch die INI-Datei "Scanreg.INI" gesteuert, die sich im Windows-Verzeichnis befindet. Dort können Sie Einstellungen ändern und anpassen.

Parameter der Scanreg.INI

Backup= | 1 = legt fest das ein Backup der Registry gemacht wird 0 = deaktiviert das Backup der Registry
Optimize= | 1 = Registry wird automatisch optimiert (wenn mehr als 500 KByte ungenutzer Speicherplatz) 0 = Registry wird nicht optimiert
MaxBackupCopies= | Anzahl der Sicherheitskopien (Standard=5)
BackupDirectory= | Gibt das Verzeichnis für die Backupdateien an (Standard = \Windows\Sysbckup)
Files=[Ordnernummer],[Name] | Hier können Sie die Dateien angeben die noch zusätzlich mitgesichert werden sollen: Dabei gibt es folgende Ordnernummern: 10 -> Windowsordner 11 -> Windowssystemordner 30 -> Bootlaufwerk 31 -> Rootordner Beispiel: Files=30,config.sys,autoexec.bat
BackupCurrentBeforeRestore= | 1 = Sichert die Registry als RBBAD.CAB 0 = Sichert die Registry Normal

Info In der INI-Datei finden Sie auch den Eintrag "MaxBackupCopies=5", welcher die Anzahl der Sicherheitskopien festlegt. Diesen Eintrag sollten Sie auf keinen Fall ändern. Wenn Sie diesen Wert erhöhen, dürfen Sie die Rücksicherung nicht mehr mit "scanreg /restore" aufrufen, da Windows dort nur 5 Einträge zur Auswahl anbietet. Sie müssen dann mit "scanreg /e /y rb00x.cab /l c:\windows" die Rücksicherung starten (x steht hier für die zu benutzende Backupdatei).

Info Auch sollten Sie Scanreg nicht wie ERU zum Erstellen eines Backups von Hand starten, das führt zu einem Fehler. Scanreg versucht, die schon vorhandene Datei zu ersetzen, was es wohl nicht richtig durchführen kann.

Sie können aber ohne weiteres die Einträge für die zu sichernden Dateien erweitern. Wollen Sie z.B. auch noch die Konfigurationsdateien aus dem Systemroot sichern, tragen Sie folgendes in die INI-Datei ein:

Files=30,autoexec.bat,msDOS .sys,config.sys

Die Zahl "30" sagt Windows, dass sich die Dateien im Hauptverzeichnis der Festplatte befinden. Die Bedeutung der einzelnen Zahlen finden Sie in der Datei RK98BOOK.CMD in Verzeichnis "\Tools\Reskit\Help" auf der Windows 98 CD. Suchen Sie hier am besten nach "LDID" (Local Disk Identifier).

Wollen Sie nach einem Fehler einmal die alte Registry usw. wieder herstellen, starten Sie Windows in der DOS Eingabeaufforderung. Hier geben Sie folgendes ein:

scanreg /restore

Ihnen wird die Liste der letzten fünf Sicherungen angezeigt, aus der Sie auswählen können, welches Backup Sie wiederherstellen wollen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0311.htm


Registrierung von Windows neu einlesen

Die Registrierung unter Windows 98 kann mit dem folgendem Aufruf neu eingelesen werden:

%WINDIR%\shell32.dll,SHExitWindowsEx <Parameter>

mit den Parametern "0x" kann Windows beendet werden und mit "1x" neu gestartet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0289.htm


Swap-Verhalten beeinflussen

Windows 98 legt, anders als Windows 95, schon beim Start eine große Auslagerungsdatei an und lagert Bereiche aus, bevor der Arbeitsspeicher ganz ausgenutzt wird. Dieses Verhalten ist gewollt und bringt meist auch zeitliche Vorteile.

Unter gewissen Umständen (Rechner mit viel Arbeitsspeicher) kann aber das alte Swap-Verhalten von Windows 95 besser sein. Durch einen Eintrag in der SYSTEM.INI können Sie dieses Verhalten beeinflussen.

Fügen Sie unter dem Abschnitt [386Enh] folgende Zeile ein:

ConservativeSwapfileUsage=1

Welche Einstellung für welchen Rechner am besten ist, kann man pauschal nicht sagen. Je nach Arbeitsspeicher, Geschwindigkeit der Festplatte und verwendeten Programmen kann die eine oder die andere Einstellung Geschwindigkeitsvorteile bringen. Durch Ausprobieren und Beobachtungen mit dem Systemmonitor können Sie die für Ihr System beste Einstellung ermitteln.

Eine Möglichkeit, die keinerlei Probleme hervorruft, ist folgende:

Beobachten Sie eine Zeitlang die Größe der Auslagerungsdatei mit dem Systemmonitor.

Als Minimalgröße der Swap-Datei verwenden Sie den größten beobachteten Wert, den Sie noch etwas aufrunden (ca. 10%).

Mit dieser Einstellung vermeiden Sie, dass Windows die Swap-Datei vergrößert und verkleinert.

Setzen Sie kein Maximum!

Durch ein gesetztes Maximum verhindern Sie u. U., dass Windows die Größe der Swap-Datei bei Bedarf erhöht, was zu diversen Fehlern führen kann.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0457.htm


Infrarotport als Serial IR-Port ansprechen

Unter Windows 95 wurde der Infrarotport als Serial IR-Port in das System eingebunden. Seit Windows 98 (also auch Windows 2000 und Windows ME) hat Microsoft dies aber geändert und die IR-Schnittstelle als Netzwerkkarte deklariert.

Es können zwar weiterhin virtuelle COM- oder LPT-Ports eingestellt werden, die aber anders in das System eingebunden sind. Ein Großteil der Software, welche auf die IR-Schnittstelle gem. Windows 95 zugreift, kann das IR-Gerät daher nicht ansprechen.

Für Windows 98 und Windows ME kann man mit einem Installationstrick das Problem aber umgehen, was auf der Webseite http://www.infrarotport.de/treiber.HTMLsehr gut beschrieben ist.

Für Windows 2000 steht dort auch ein neuer IR-Treiber zur Verfügung, welcher die IR-Schnittstelle ebenfalls als COM-Gerät in das System einbindet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0953.htm


USB Polling Interval erhöhen

Standardmäßig liegt das Polling Interval für USB bei einer Millisekunde. Selbst wenn keine USB-Geräte angeschlossen sind, wird das Polling durchgeführt. Bei einigen Geräte kann das dazu führen, das der Rechner nicht in den Stromsparmodus geschaltet werden kann. Wenn Sie diese Tipp aktivieren, wird der Intervall erhöht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

98 und ME

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Usb\ 0000

ab 2000

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Class\ {36FC9E60-C465-11CF-8056-444553540000}\ 0000

Erstellen Sie hier einen neuen Wert mit dem Namen "IdleEnable" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Polling Interval erhöhen
0 | Standard Polling Interval (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1661.htm


Infotexte eines Ordners oder einer Datei ändern

Wenn Sie "Webinhalte in Ordnern aktivieren" im Explorer unter "Extras" -> "Ordneroptionen" aktiviert haben, zeigt der Explorer im linken Teil für Ordner und Programme Infotexte an. Diese Texte können Sie beliebig verändern. Gehen Sie dazu folgendermaßen vor:

Für Ordner:

Im Ordner finden Sie eine versteckte Datei mit dem Namen "DESKTOP.INI". In dieser Datei können Sie unter der Sektion [.ShellClassInfo] mit dem Eintrag InfoTip=<text> einen beliebigen Text vorgeben. Das würde dann z.B. so aussehen:

[.ShellClassInfo]
InfoTip=In diesem Ordner liegen meine Dokumente, nicht löschen!

Sollte die Datei "DESKTOP.INI" nicht vorhanden sein, können Sie diese selber anlegen und eine Beschreibung für eigene Ordner vorgeben. Wenn Sie die Datei im Hauptverzeichnis eines Laufwerkes ablegen, wird die Beschreibung beim Laufwerk angezeigt.

Sie können eine Beschreibung für einen Ordner auch folgendermaßen anlegen:

  1. Entsprechenden Ordner im Explorer anwählen und öffnen
  2. im Menü "Ansicht" -> "Ordner Anpassen" auswählen
  3. "Weiter" anklicken
  4. Wählen Sie jetzt "Ein Kommentar für den Ordner hinzufügen" aus und klicken Sie auf "Weiter"
  5. Geben Sie in der Box die Beschreibung ein
  6. Klicken Sie auf "Weiter" -> "Fertigstellen".

Jetzt erstellt Windows selber die Datei "DESKTOP.INI", die aber folgenden Eintrag enthält:

[.ShellClassInfo]
htmlinfoTipFile=file://Folder Settings\Comment.htt
ConfirmFileOp=0

Sie finden jetzt in diesen Ordern einen neuen versteckten Ordner mit dem Namen "Folder Settings", der die Datei "Comment.htt" enthält. Hier hat Windows den Text gespeichert, der angezeigt werden soll. Der Vorteil dieser Art ist, dass hier das Textfenster größer ist. Auch können Sie in der Datei noch die Hintergrund, Farbe, Schriftart usw. anpassen.

Für Dateien:

Auch für einzelne Dateien können Sie Beschreibungen vorgeben, dafür gehen Sie folgendermaßen vor:

Klicken Sie die Datei mit der rechten Maustaste an und wählen Sie aus dem Kontextmenü "Eigenschaften" aus. Unter dem Tabreiter "Dateiinfo" können Sie einige Texte als Beschreibung eingeben. Alles, was Sie unter "Title", "Thema", "Autor", "Kategorie" und "Stichwörter" eingeben, wird eingeblendet, wenn sich der Mauszeiger auf dem Dateinamen befindet (Mausover).

Siehe auch Tipp: Informationen über die Datei "Desktop.ini"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1049.htm


Suche nach verlinkten Dateien unterbinden

Über Verknüpfungen werden andere Dateien geöffnet, somit kann man sich auf den Desktop einen Link anlegen, ohne eine Kopie der Datei erstellen zu müssen. Wird von Ihnen die Zieldatei gelöscht, bleibt die Verknüpfung weiterhin erhalten und zeigt auf eine Datei die nicht mehr vorhanden ist. Wenn Sie diese Verknüpfung jetzt anklicken, sucht Windows automatisch nach einer passenden Datei und zeigt Ihnen nach der Suche alternativen an.

Falls sich die Zieldatei auf einer NTFS-Partition befindet, wird die Kennung der Zieldatei zum Suchen nach einem Pfad verwendet. Falls der Pfad ungültig ist, wird auf dem Ziellaufwerk eine umfassende Suche nach der Datei durchgeführt.

Durch Aktivieren dieser Einstellung wird diese umfassende Suche nicht durchgeführt. Anstelle dessen wird eine Meldung angezeigt, die erläutert, dass die Datei nicht gefunden wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoResolveSearch" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine automatische Suche
gelöscht | Automatische Suche, wenn Datei nicht vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Beim Zuordnen von Shellshortcuts nicht die suchbasierte Methode verwenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe auch: Automatische Rückverfolgung verweister Links unterbinden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1643.htm


Programmverknüpfung bei unbekannten Dateien verhindern

Wenn im Explorer auf eine Datei ein Doppelklick gemacht wird, dessen Dateityp nicht bekannt ist, erscheint eine Dialogbox "Öffnen mit". In der fragt Windows nach, mit welcher Anwendung diese Datei geöffnet werden soll.

Standardmäßig ist in dieser Dialogbox die Option "Dateityp immer mit dem ausgewählten Programm öffnen" aktiviert. Dadurch wird dieser Dateityp automatisch mit der Anwendung verknüpft, und beim nächsten Mal wird die Datei gleich mit dieser Anwendung geöffnet.

Wenn Sie diese Zuordnung nicht durchführen wollen und das Kontrollkästchen standardmäßig nicht aktiv sein soll, müssen Sie folgenden Eintrag ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Unknown\ shell\ openas\ command

klicken Sie auf den Eintrag "(Standard)" und ändern Sie den Eintrag von:

%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1

in:

%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %2

Ab jetzt ist das Kontrollkästchen deaktiviert, kann aber auch nicht mehr aktiviert werden.

Wenn Sie die alte Funktion wieder aktivieren wollen, müssen Sie den Eintrag auf den alten Wert zurückstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1994.htm


Dialogboxen "Datei öffnen" und Speichern konfigurieren

Dialogboxen "Datei öffnen" bzw. "Datei speichern" konfigurieren

Die Dialogbox "Datei öffnen" bzw. "Datei speichern" werden von Windows immer in der gleichen Form angezeigt. Die Veränderung der Größe oder der Anzeigeart auf Details werden nicht gespeichert und beim nächsten Öffnen sieht die Box wieder wie zuvor aus.

Damit diese Einstellungen dauerhaft geändert werden, müssen Sie eine Konfiguration in der Datei "comdlg32.dll" durchführen. Dazu wurde ein entsprechendes Tool "Windows Multienhancer" geschrieben.

Laden Sie sich das Tool von der Homepage "http://www.netcult.ch/elmue/ElmueSoft-de.htm" herunter. Nach dem Start werden einige Informationen angezeigt. Wählen Sie anschließend die Sprache "Deutsch" aus und klicken nun auf "Windows Datei Öffnen Patch".

Lesen Sie sich die entsprechenden Informationen dazu durch. Wenn Sie auf den Button Patch klicken, wird die aktuelle Datei gesichert und die Änderungen werden an der Datei vorgenommen. Nach einem Neustart, steht Ihnen die neue BOX zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2514.htm


DMA-Modus wird automatisch deaktiviert

Bei einer neuen UDMA 66 Platte und einem Board, welches nur UDMA 33 unterstützt, wird der DMA-Betrieb für die Festplatten von Windows eigenständig deaktiviert.

Die Checkbox kann zwar aktiviert werden, wird beim Neustart aber wieder deaktiviert.

Zur Abhilfe schaltet man im BIOS die betreffende Platte, daher nicht auf AUTO, sondern auf PIO Mode 4. Die Platte wird dann von Windows korrekt im DMA-Modus betrieben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0880.htm


Bei Speicherplatzmangel Festplatte aufräumen deaktivieren

Ab Windows 98, hat das System die Angewohnheit, bei vermeintlichen Speichermangel, die Festplatten aufräumen zu wollen. Gerade Leute, die Ihre Größe der Festplatten unterschiedlich eingeteilt haben, werden dadurch meist sehr gestört.

Um das abzustellen gehen Sie folgendermaßen vor:

Über "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" starten Sie das Programm "Datenträgerbereinigung"

(CLEANMGR.EXE).

Wählen Sie nun das Laufwerk aus, jetzt können Sie unter "Einstellungen" die Datenträgerbereinigung für die einzelnen Laufwerke abstellen.

Info Wenn Sie das Programm nicht über das Startmenü sondern über die Laufwerkseigenschaften aufrufen, steht Ihnen diese Auswahl komischerweise nicht zur Verfügung!

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0695.htm


Programm zur Festplattenbereinigung konfigurieren (CLEANMGR.EXE)

Das Programm zur Datenträgerbereinigung "CLEANMGR.EXE", welches Sie bei Windows 98 unter "Start" -> "Programme" -> "Zubehör" bzw. bei 2000 unter "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" finden, zeigt Ihnen nach Auswahl einer Festplatte in einer Liste an, wie viel Speicherplatz Sie durch das Aufräumen wieder gewinnen können. Es werden dabei aber nur der Papierkorb und einige Systemverzeichnisse beachtet. Welche Verzeichnisse durchsucht werden sollen, wird in der Registry festgelegt

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VolumeCaches

Jeder weiterer Unterschlüssel bestimmt einen Eintrag für die Datenträgerbereinigung.

Diese Liste können Sie beliebig erweitern.

Legen Sie dazu einfach einen neuen Unterschlüssel mit einem beliebigen Namen an. Erstellen Sie unter diesem Schlüssel nun folgende Einträge:

Name | Datentyp | Bedeutung
Display | REG_SZ | Anzeigename unter dem CLEANMGR.EXE
Description | REG_SZ | Beschreibungstext im CLEANMGR.EXE
Folder | REG_EXPAND_SZ | Laufwerks und Ordnername der durchsucht werden soll. Für "alle Laufwerke" benutzen Sie das "?". Beispiele: C:\TMP <- Laufwerk C, Verzeichnis TMP ?:\TMP <- Alle Laufwerke
FileList | REG_SZ | Filter für zu suchende Dateien. Beispiele: *.TMP *.?XX
IconPath | REG_EXPAND_SZ | Pfad zum Icon für die Anzeige
(Standard) | REG_SZ | ID (um Dateinamen anzugeben, benutzen Sie einfach folgende ID) {C0E13E61-0CC6-11d1-BBB6-0060978B2AE6}
LastAccess | REG_DWORD | Alter der Datei in Tagen. Bei der Angabe von "2" werden nur die Dateien gelöscht, die älter als 2 Tage sind.

Parameter bei Aufruf:

Parameter | Beschreibung
/TUNEUP:[Nummer] | Zeigt den Dialog "Einstellungen für die Datenträgerbereinigung"
/LOWDISK | Bereinigung mit den Standardeinstellungen
/VERYLOWDISK | Datenbereinigung mit erweiterten Einstellungen
/SETUP | Löschen der Setup-Dateien welche nicht mehr benötigt werden
/sageset:[Nummer] | Zeigt den Dialog "Einstellungen für die Datenträgerbereinigung" an und speichert die Einstellungen in der Registry unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ VolumeCaches" dem Schlüsselnamen "StateFlags[Nummer]" (die Nummer kann zwischen 0 und 65535 liegen)
/sagerun:[Nummer] | Lädt die Einstellungen aus der Registry unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ explorer\ VolumeCaches" dem Schlüsselnamen "StateFlags[Nummer]"

Info Wenn Sie unter Folder bzw. FileList mehr als einen Eintrag angeben wollen, müssen Sie die Einträge mit dem | - Zeichen trennen ([ALT G]r + <> Taste drücken) z.B.: *.TMP|*.~

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0449.htm


Speicherplatzwarnung für alle oder für bestimmte Laufwerke abschalten

Sie können die Warnung, dass auf einem Laufwerk nur noch wenig Platz zur Verfügung steht, in der Registry für alle Laufwerke oder für bestimmte Laufwerke abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

legen Sie den Wert DisableLowDiskSpaceBroadcast vom Datentyp REG_DWORD an und weisen ihm anhand der folgenden Tabelle den Wert des entsprechenden Laufwerks zu. Für mehrere Laufwerke addieren Sie einfach die zugehörigen Werte.

Laufwerk | Wert (Dezimal)
A | 1
B | 2
C | 4
D | 8
E | 16
F | 32
G | 64
H | 128
I | 256
J | 512
K | 1024
L | 2048
M | 4096
N | 8192
O | 16384
P | 32768
Q | 65536
R | 131072
S | 262144
T | 524288
U | 1048576
V | 2097152
W | 4194304
X | 8388608
Y | 16777216
Z | 33554432

Wenn Sie den Wert hier auf FFFFFFFF (Hex) setzen, wird diese Funktion für alle Laufwerke ausgeschaltet.

Die Warnung wird bei Unterschreiten eines bestimmten Wertes gem. folgender Tabelle ausgelöst:

Partitionsgröße | Wert in % | Wert in MB
<= 512 MB | 10.0 | 51.2
<= 1 GB | 5.0 | 51.2
<= 2 GB | 2.5 | 51.2
<= 4 GB | 1.2 | 49.15
<= 8 GB | 0.6 | 49.15
<= 16 GB | 0.3 | 49.15
<= 32 GB | 0.2 | 65.5
> 32 GB | 0.1 | ...

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=188074 und
http://support.microsoft.com/?kbid=191824

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1253.htm


CD-Wiedergabe ohne Verbindungskabel zur Soundkarte

Normalerweise muss das CD-ROM mit der Soundkarte verbunden sein, um abzuspielende Audio-CDs zu hören.

Im Gerätemanager unter Eigenschaften des CD-ROMs lässt sich unter Eigenschaften die digitale CD-Wiedergabe aktivieren. Damit werden Audio-Daten über den Systembus direkt an die Soundkarte weitergeleitet und abgespielt. Sie können sich das Verbindungskabel sparen. Wenn man mehr als ein CD-Laufwerk hat, ist das eine sinnvolle Möglichkeit, über mehrere CD Laufwerke Audio-CDs anzuhören.

Bei Windows 98 finden Sie diese Einstellung unter:

"Systemsteuerung" -> "Multimedia" -> "Musik-CD" -> "Digitales CD-Audio für dieses Gerät aktivieren"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0507.htm


Computer hängt 30 Sek. beim Zugriff auf SCSI-CDROM

Übernommen aus c't-Online, 07.10.99

Wenn der Rechner beim Zugriff auf SCSI-CD-ROM Laufwerke hängt und diese an einem Adaptec-Controller angeschlossen sind, liegt es an einem veralteten Treiber für den SCSI-Adapter. Der in Windows 98 und Windows 98 SE enthaltene Treiber AIC78U2.MPD hat in der Regel die Versionsnummer 3.00a beziehungsweise 3.02 (in SE). Auf Adaptecs Website (http://www.adaptec.com) steht eine Datei namens 7800W9X.EXE zum Download bereit, die einen aktuellen Treiber enthält.

Ein kleines Problem gibt es bei Windows 98 SE. Der dort enthaltene Treiber hat die Version 3.02 4.10.2222, der neue Treiber hat aber 3.03 4.10.2000. Wegen der scheinbar kleineren Versionsnummer weigert sich die Installationsroutine in der Systemsteuerung, den neuen Treiber mit dem empfohlenen Menüpunkt ‘Nach einem besseren als dem derzeit verwendeten Treiber suchen’ zu übernehmen. Wählen Sie daher an dieser Stelle ‘Eine Liste der Treiber in einem bestimmten Verzeichnis zum Auswählen anzeigen’.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0794.htm


Schnelleres Booten durch Deaktivierung der Laufwerkssuche

Windows 98 überprüft bei jedem Start die Diskettenlaufwerke neu, was für Laptops etc. ganz nützlich ist, wenn diese nicht immer am Rechner angeschlossen sind. Auf Standard-PCs kann diese Suche aber i.d.R. entfallen.

Dazu deaktiviert man in der Systemsteuerung, unter "Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Dateisystem" -> "Diskette" die Option "Suche nach neuen Floppylaufwerken".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0680.htm


Soundknackser/-probleme in Windows 9x-Spielen

Wenn beim Spielen plötzlich Soundknackser entstehen, muss es nicht immer an einer Inkompatibilität der Soundkarte liegen. Schuld an dieser Misere sind häufig im Hintergrund laufende Programme wie CPU Cooler (Rain, Waterfall, CPU Idle, die den Rechner in einen Schlafzustand versetzen) oder Antivirenprogramme.

Einfach die genannten Programme vor dem Spielstart abschalten und der Sound sollte wieder normal funktionieren. Oder am Besten gleich alle Hintergrundprogramme beenden.

Manchmal kann es auch helfen, wenn man unter Multimedia Properties die Hardwarebeschleunigung auf die Basisbeschleunigung setzt und die Samplequalität niedrig wählt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0952.htm


DVDs mit dem MediaPlayer abspielen

Auch ohne eine MPEG-Karte kann der Mediaplayer zum Abspielen von DVDs benutzt werden, sofern ein geeigneter DVD-Softwareplayer installiert wurde. Der Mediaplayer von Windows greift dann nach einer Änderung in der Registry auf die installierten MPEG2-Treiber des fremden Players zurück.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_Current_User\ Software\ Microsoft\ MediaPlayer\ Player\ Settings

fügt man einen neuen Eintrag mit dem Namen "EnableDVDUI" als Datentyp REG_SZ ein und gibt diesem den Wert YES.

Mit dieser Änderung steht im Menü "Datei" der Eintrag "DVD öffnen" zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0488.htm


Protokoll über Abstürze

Wenn eine Anwendung abstürzt, wird von Windows ein Protokoll angelegt. Dieses Protokoll wird in einer bestimmten Datei gespeichert, die unter folgendem Registryeintrag angegeben werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Fault

finden Sie den Eintrag mit dem Namen "LogFile" als Datentyp REG_SZ. Hier können Sie angeben, wie das LOG-File heißen soll.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0960.htm


Hardware Fehlersuche mit ASD.EXE

Zur Fehlersuche von Hardware gibt es unter Windows 98 das Tool ASD.EXE. Bei jedem Start des Rechners werden die Startfunktionen - und ob Sie fehlerfrei ausgeführt wurden - in der Registry abgelegt. Diese Informationen finden Sie unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ ASD\ List

Welche Geräte beim Start von ASD überwacht werden sollen, finden Sie unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ ASD\ Prob

Folgende Werte können Sie hier hinter einem Gerätenamen finden:

00 | Gerät arbeitet ohne Fehler
01 | Ein Fehler ist beim Start aufgetreten
11 | Geräte wurde deaktiviert

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0797.htm


Fehler SU0168 beim Installieren von Windows 98

Der Fehler tritt auf, wenn man die OEM-Version von Windows 98 über ein bestehendes Windows 95 installieren will.

Abhilfe schafft folgender Trick:

Setup starten, im Lizenzfenster nicht auf "OK" klicken, sondern den Explorer aufrufen (WIN-Taste + e). Jetzt das Verz.C:\Wininsto.400 öffnen und per Doppelklick die Datei "SETUPPP.INF" in den Editor laden.

Im Abschnitt [Data] die Zeile "OEMUP=1" einfügen, speichern und den Editor schließen.

Jetzt wieder mit <Alt><Tab> zurück zum Installationsprogramm. Wenn man jetzt im Lizenzfenster auf "OK" klickt, sollte keine Fehlermeldung .....SU0168 erfolgen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0666.htm


Recovery Funktion vom Backup funktioniert nicht

Die Recovery Funktion vom neuen Backup ist etwas unglücklich gewählt. Nach einen Systemabsturz kann das Backup nur über ein Not-Windows aufgespielt werden. Dies wird über die Batch-Dat Pcrestor.bat im Ordner Tools\Sysrec gesteuert und im DOS gestartet. Leider funktioniert dies nur, wenn Windows in C:\ installiert wurde. Wurde ein anderer Pfad gewählt, muss man den kompletten Ordner SYSRECauf die Platte kopieren und die Datei msbatch.inf im Eintrag "InstallDir" entsprechend anpassen

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0737.htm


Beim Update auf Windows 98SE wird der IE nicht aktualisiert

Beim Update auf Windows 98SE wird IE nicht aktualisiert

Wenn Sie die Second Edition von Windows 98 als Update über das alte Windows 98 installieren, wird IE nicht erneuert, sondern es wird weiterhin die alte Versionsnummer "V.5.00.2614.3500" angezeigt.

Wenn Sie wollen, dass beim Setup die Dateien erneuert werden, müssen Sie folgendermaßen vorgehen:

  1. Löschen Sie die Datei "Iemigrat.dll" aus dem Windows\System Verzeichnis
  2. Löschen Sie folgenden Registry Wert

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Setup\ Migration\ 100

den Wert "IE System Migration" löschen.

Jetzt wird nach der Installation auch beim IE die Versionsnummer: V.5.00.2615.200 angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0613.htm


Win98 SE über Win98 installieren scheitert mit Fehler

Windows 98 SE über Windows 98 installieren scheitert mit Fehler

Wer Windows 98 SE über Windows 98 installieren will, bekommt unter Umständen eine Fehlermeldung, die besagt, dass die SE Version Windows 98 voraussetzt. Grund hierfür könnte ein installierter IE5 sein. Man sollte daher vorab versuchen, den IE 5 über SOFTWARE in der Systemsteuerung wieder zu deinstallieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0587.htm


Fehlermeldung bei Eingabe der Produktnummer

Wenn bei der Installation von Windows nach der Eingabe der Produktnummer die Fehlermeldung: "MSGSRV32 - ungültiger Vorgang allgemeine Schutzverletzung im Modul Pidgen.dll..." erscheint und dann der Rechner "einfriert", liegt es meist an einem ungültigen SystemDatum.

Setzen Sie vor der Installation von Windows das System-Datum auf das aktuelle Datum.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0443.htm


Fehlende VXD Dateien nach der Installation

Häufig erhalte ich E-Mails mit der Meldung, dass angeblich auch unter Windows ME einige VXD-Dateien nicht installiert werden und nach der Installation fehlen.

Ich hatte unter "Infos zu VMM32.VXD und Startvorgang" dazu schon etwas geschrieben und dabei die Funktion der VMM32.VXD Datei erläutert.

Ich möchte hier noch einmal darauf hinweisen, dass dieses eine Falschmeldung ist und Sie auf keinen Fall diese Dateien auspacken und in das Windows-Verzeichnis kopieren sollten. Sie machen Ihr System dadurch nur langsamer und instabiler.

Folgende Datei werden meist als fehlend angegeben:

VDD.VXD

NTKERN.VXD

CONFIGMG.VXD

VCOMM.VXD

VDMAD.VXD

VFAT.VXD

VFLATD.VXD

VMOUSE.VXD

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1060.htm


Fehlermeldung: Standard Mode: Fault in MS-DOS Extender

Fehlermeldung: Standard Mode "Fault in MS-DOS Extender"

Hier wird beschrieben, was bei bestimmten Fehlermeldung nach dem Start von Scandisk, während der Installation von Windows 98, gemacht werden soll um den Fehler zu beheben.

Standard Mode: Invalid DPMI return.

Standard Mode: Fault in MS-DOS Extender.

Standard Mode: Bad Fault in MS-DOS Extender.

Standard Mode: Unknown stack in fault dispatcher.

Standard Mode: Stack Overflow.

nach dem Scandisk beim Setup von Windows 98 erhält, sollte in der Config.sys die Speichermanager wie Emm386, Qemm und Max386 entfernen. Danach sollte das Setup durchlaufen.

Siehe auch "Fehlermeldung: Standard Mode: Invalid DPMI return from 037F:9FEB".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1068.htm


Fehlermeldung bei der Installation in der Datei PIDGEN.DLL

Bei der Installation von Windows kommt es zu einem Absturz, wenn das BIOS Datum größer als das Jahr 2047 ist. Steht das Jahr z.B. auf 2048, stürzt Windows mit einer Fehlermeldung in der Datei PIDGEN.DLLnach der Eingabe der Seriennummer ab.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0735.htm


Fehlermeldung: 'Meldung SU0013' bei der Installation von Windows

von Jürgen Zier

Erscheint bei der Installation von Windows 98 bzw. ME die folgende Fehlermeldung:

Info Meldung SU0013. Da auf dem Startlaufwerk keine Dateien erstellt werden konnten, kann Windows 98 nicht installiert werden. Bei Festplatten mit HPFS oder NTFS, ist eine MS-DOS-Startpartition zu erstellen. Ein Lantastic-Netzwerk oder die SuperStore-Komprimierung muss deaktiviert werden. (Siehe SETUP.TXT auf der Installationsdiskette 1 bzw. WINDOWS 98-CD.)"

Dann liegt das meist daran, dass sich noch NTFS-Partitionen auf Ihrer Festplatte befinden.

Das Problem können Sie umgehen, wenn Sie die Installation mit den folgenden Parametern starten:

/IR : Unterbindet das Neuschreiben des MBR bei der Installation

/NTLDR : Unterbindet die Suche nach bereits installierten Betriebssystemen

Der Aufruf lautet wie folgt : SETUP.EXE /IR /NTLDR

Info Alle Parameter finden Sie unter: Installation von Windows verkürzen (Setup-Parameter)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1963.htm


NAAPI.VXD Fehler in der Bootlog

Sollte in der Bootlog.txt ein Eintrag stehen, dass die NAAPI.VXD fehlt, kann man diesen Fehler ignorieren, da die Datei nur bei japanischen Treibern von Creative Labs vorhanden ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0888.htm


Bootlog.txt meldet PPA3.MPD Fehler

Hängt der Rechner beim Booten oder Neustart, kann dies an einer alten Version des Iomega Parallelport Treibers für ZIP-Laufwerke liegen.

Ein verbesserter Treiber befindet sich auf der Windows 98 CD unter Drivers/Storage/Iomega/ppa3.

Ersetzen Sie den alten Treiber durch die neuere Version.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0886.htm


Keine Windows-Anmeldung nach 'Überinstallieren' von Windows

Nachdem Sie Windows über eine bestehende Installation installiert haben, wird plötzlich keine Windows-Anmeldung mehr verlangt, und Sie haben keinen Zugriff auf das Netzwerk. Erst wenn Sie den Benutzer abmelden (Start - <Benutzer> abmelden), können Sie sich ordnungsgemäß. anmelden.

Eine mögliche Ursache ist, dass die Option "Autologon" aktiviert wurde, was einem Abbrechen der Anmeldung (ESC im Anmeldefenster) entspricht.

Dieses Verhalten können Sie durch Entfernen eines Eintrags aus der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Network\ Real Mode Net

löschen Sie den Eintrag "AutoLogon". Danach können Sie sich wie gewohnt beim Start von Windows anmelden.

Siehe auch "Das DFÜ-Passwort wird nicht gespeichert".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1211.htm


Systemstillstand bei Nutzung von AGP -Funktionen

Es können Probleme mit den so genannten Large Pages (2 MByte bei PAE: Page Address Extension) auftreten, die unter Windows 2000 im Zusammenspiel mit einigen Video-Treibern (NVidea Geforce, Matrox G400) das System zum Absturz bringen können.

Windows 98/ME

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SessionManager\ MemoryManagement

Windows 2000

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Erstellen Sie einen neuen Eintrag mit den Namen "LargePageMinimum" als Datentyp REG_DWORD und setzen den Wert auf 0xffffffff

Info Weiteres im c't-Artikel http://www.heise.de/newsticker/meldung/12038

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=270715

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1018.htm


Taskplaner führt geplante Vorgänge nicht aus

Fehler:

Bei meinem Windows 98 startet der Taskplaner gar nicht und deshalb werden geplante Tasks auch nicht gestartet. Das Taskicon erscheint nur kurz im Systray.

Grund :

Ihre Festplatte heißt zufällig genauso wie Ihr Windows-Verzeichnis. Ändern Sie den Namen Ihrer Festplatte und schon funktioniert wieder alles:

C:>Label C:<Name>

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0612.htm


Fehlermeldung 'Taskmon...' beim Herunterfahren

Fehlermeldung "Taskmon..." beim Herunterfahren

Wenn der Rechner beim Herunterfahren die Fehlermeldung anzeigt "Taskmon verursacht einen Fehler durch eine ungültige Seite im Modul kernel32.dll", kann dies an den Protokolldateien im Verzeichnis C:\Windows\Applog von Windows liegen. In diesen Dateien wird normalerweise protokolliert, welche Programme wie oft gestartet werden, um diese beim Defragmentieren an den Anfang zu stellen.

Beim Herunterfahren versucht das System, diese Dateien zu aktualisieren. Wenn dies scheitert, meldet Windows den o.a. Fehler. Zur Fehlerlösung benennt man den Ordner Applog einfach um (Applog_bak; vorher aber im Explorer unter Ansicht auch die versteckten Dateien anzeigen lassen). Nach einem Neustart sollte das Problem behoben sein und Windows legt einen neuen Ordner Applog an.

Wenn alles fehlerfrei funktioniert, kann der alte Ordner gelöscht werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1167.htm


Fehlermeldung: Fehler beim Laden von GDI.EXE

Wenn beim Hochfahren die Meldung "Fehler beim Laden von GDI.exe. Installieren Sie Windows neu" erscheint, sind lediglich einige Systemschriften gelöscht oder beschädigt.

Diese Systemfonts liegen in Windows\Fonts und haben die Bezeichnung vga850.fon, vgafix.fon und vgasys.fon. Die Dateien sind schreibgeschützt und versteckt.

Sind diese nicht mehr vorhanden oder beschädigt, müssen sie wiederhergestellt werden. Dies erledigt man wie folgt:

Windows 98 CD einlegen, in das Windows-Verzeichnis der CD (Windows 98) wechseln und folgenden Befehl eingeben:

extract win98_45.cab *.fon /L c:\windows\fonts

Info Es kann auch sein,dass bei euch die Datei im der win9842.cab liegt, einfach einmal probieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0923.htm


Fehlermeldung: Standard Mode: Invalid DPMI return from 037F:9FEB

Fehlermeldung: Standard Mode 'Invalid DPM' return from 037F : 9FEB

Wer seine Festplatte mit Fdisk partitioniert und danach Windows 98 installieren will, kann vom Installations-Assistenten den Fehler

"Standard Mode: Invalid DPMI return from 037F : 9FEB. Bitte entfernen Sie alle Disketten aus den Laufwerken und drücken Sie die Eingabetaste zum Neustart." erhalten und kann Windows nicht installieren.

Dieser oder ähnliche Fehler im Setup-Programm treten unter seltenen Umständen auf, wenn die Partitionstabelle gewisse ‘unglückliche’ Einträge enthält, wie sie etwa das Fdisk-Programm von Windows 98 vornimmt.

Die Wurzel des Übels ist die berüchtigte 1024-Zylinder-Grenze (8 GB - 8032,5 MB): Beginnt ein logisches Laufwerk in der erweiterten Partition genau an dieser Grenze, so "verschluckt" sich das Setup.

Legt man beispielsweise eine 4016 MByte große primäre Partition C:\, gefolgt von einer erweiterten Partition mit einem 4016 MByte großen logischen Laufwerk D: \ sowie einem beliebigen weiteren logischen Laufwerk E:\ an, so landet Laufwerk E:\ exakt an der kritischen Stelle.

Man löscht daher alle logischen Laufwerke in der erweiterten Partition und erstellt diese mit leicht veränderten Größen neu.

Siehe auch "Fehlermeldung: Standard Mode: Fault in MS-DOS Extender".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0898.htm


Win98 - HH verursacht allg. Schutzverletzung

Windows 98 - HH verursacht allg. Startenchutzverletzung

Verursacht die Datei HH beim Aufruf einer Hilfefunktion eine allg. Schutzverletzung, ist die Datei Hhctrl.ocxbeschädigt oder durch eine andere Version ersetzt worden. Zur Abhilfe kopiert man die Original-Datei wieder von der Windows 98 CD (CAB-Dateien mit Explorer öffnen).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0588.htm


MSINFO32 beschädigt oder stürzt ab

Bei bestimmten Systemen kann es vorkommen, dass Frontpage 98 die Dateien von "Systeminformation" (Msinfo32) beschädigt. Sollte Frontpage 98 installiert werden, muss daher vorher der Ordner MSINFOim Ordner Programme\Gemeinsame Dateien\Microsoft Shared gesichert werden, welcher nach der Installation zurückgeschrieben oder zurückkopiert werden kann.

Auch andere Software kann die Systeminfo beschädigen.

Bei einem solchen Vorfall sollte man die SFC.EXE (Systemdateiprüfung) (START-AUSFÜHREN) starten und "Eine Datei von der Installationsdiskette extrahieren" wählen.

Dort gibt man msinfo32.exe an. Windows fragt dann woher und man gibt den Pfad der Windows 98 CD an. Zudem sollte beim SPEICHERN IN Der Pfad "C:\Programme\Gemeinsame Dateien\Microsoft Shared\MSINFO" angegeben sein.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0738.htm


Fehlermeldung: Kann Gerät CONFIGMG nicht starten

Dieser Fehler tritt u. a. auf, wenn Windows die PCI-to-AGP Bridge nicht aktivieren kann. Folgendes kann Abhilfe schaffen:

  1. Man deaktiviert im BIOS den Second Level Cache
  2. Ein neues BIOS des Mainboard-Herstellers wird aufgespielt
  3. Man ersetzt die AGP Grafikkarte durch eine PCI Karte

Fehler beim Booten des PC's

PC bootet nicht bis zur Windows-Oberfläche, sondern hört mit folgender Fehlermeldung auf:

"Beim Initialisieren des Gerätes CONFIGMG: Windows-Schutzfehler. Starten Sie neu."

Ein Neustart bringt immer nur den selben Fehler.

Eine Fehlerursache ist, dass im BIOS die Taktfrequenz des Prozessors verstellt ist, möglicherweise ausgelöst durch eine unbeabsichtigte statische Aufladung oder Spannungsschwankungen im Stromnetz.

Lösung des Problems:

PC starten und über Del- / Entf-Taste ins BIOS wechseln. Beim AMI-BIOS nach "CPU PnP Setup" wechseln und dann unter "CPU Speed" die Taktfrequenz ändern. Hier steht wahrscheinlich 100/100 MHz.

Diesen Wert über die + / - Taste ändern.

bei AMD K7 Athlon TM 1100 auf 100/133 MHz

bei AMP K7 Athlon XP 1800 auf 133/133 MHz

Änderungen beim Verlassen des BIOS speichern und PC neu starten.

Info Die Datei configmg.vxd liegt bei Windows 98SE im Ordner win98_50.cab auf der Windows-CD.

Info Siehe auch: Err Msg While Initializing Device CONFIGMG Windows... (Q187612): http://support.microsoft.com/?kbid=187612

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0707.htm


Fehlermeldung: 0E has occurred at 0028:xxxxx in VXD IOS(04)

Tritt dieser Fehler auf, könnte es an dem Soundblaster 16-Treiber liegen. Zur Behebung des Problems benennt man die Datei sb16.vxd im Ordner Windows\System\Iosubsys einfach in sb16.old um. Dies sollte den Fehler beheben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0699.htm


Geplante Tasks hinzufügen bringt System zum Stillstand

Der Systemdienst von Windows 98 bleibt stehen, wenn ein Task hinzugefügt werden soll. Ursache ist der Name der ERSTEN Festplatte. Diese nennt sich vermutlich genauso wie der Windows 98 Ordner (WINDOWS ?). Nach Umbenennen des Laufwerks (Arbeitsplatz, Eigenschaften von C) funktioniert der Taskplaner wieder.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0691.htm


Taskplaner stürzt ab

Wenn ein neuer Task hinzugefügt werden soll, stürzt der Taskplaner ab und meldet einen schweren Ausnahmefehler. Zudem tritt dann beim Booten die Fehlermeldung auf, dass die Datei Configmg.vxd nicht geladen werden konnte.

Die Datei Configmg.vxd ist vermutlich beschädigt.

Man gibt im DOS Fenster von Windows 98 folgende Befehlszeile an (Laufwerksbuchstaben anpassen):
extract X:\win98\win98_45.cab configmg.vxd c:\

Danach startet man den Rechner im DOS neu (F8) und kopiert die Datei ins Windows-Verzeichnis. Nach einem Reboot sollte es wieder gehen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0690.htm


Fehlermeldung: Die Datei MSVCIRT.DLL ist verknüpft mit dem fehlenden Export-MSVCRT.DLL:??_U@YAPAXI@Z

Stellen Sie sicher, dass MSVCIRT.DLL und MSVCRT.DLL nur im Verzeichnis "%WinDir%\System" vorkommen, indem Sie alle anderen Kopien umbenennen.

Als erstes müssen Sie die Dateien aus der Sourcen der Windows CD entpacken

  1. Geben Sie über "Start" -> "Ausführen" den Befehl "SFC" ein
  2. Gehen Sie unter dem Dialogfeld "Systemdateiprüfung" auf "Eine Datei von der Installationsdiskette extrahieren"
  3. In das Feld "wiederherzustellende Systemdatei" geben Sie den Dateinamen "Msvcrt.dll" ein und klicken Sie danach auf Starten
  4. Legen Sie die Windows CD ein und geben Sie den Pfad zu den Sourcen an
  5. Unter "Speichern in" geben Sie ein beliebiges Verzeichnis an (z.B.: C:\)
  6. Jetzt führen Sie 1-5 noch mal aus und entpacken jetzt aber die Datei "MSVCIRT.DLL" (In Punkt 3 den Dateinamen entsprechend austauschen)
  7. Windows beenden und im DOS -Modus starten.
  8. Benennen Sie beide Dateien im Verzeichnis "%WinDir%\System" in *.bak um
  9. Beispiel:
    rename %WinDir%\System\Msvcrt.dll Msvcrt.bak
    rename %WinDir%\System\Msvcirt.dll Msvcirt.bak
  10. Kopieren Sie die entpacken Dateien in dieses Verzeichnis.
    Beispiel:
    copy C:\Msvcrt.dll %WinDir%\System
    copy C:\ Msvcirt.dll %WinDir%\System
  11. Starten Sie Windows neu.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/kb/296551/de

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1325.htm


Probleme mit IDE Controllern lösen nach DMA Aktivierung

In Gerätemanager unter "Laufwerke" muss der DMA-Modus extra aktiviert werden. Sollte die Festplatte in diesem Modus nicht laufen, kann Windows 98 nur noch abgesichert gestartet werden. Ärgerlicherweise sind die Funktionen zur Deaktivierung der Funktion im Abgesicherten-Modus aber nicht zugänglich.

Über die Registry kann man DMA aber wieder ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControl\ Set\ Services\ Class\ hdc\ 000x\

den Wert von "IDEMASTERDRIVEy" von 01 wieder auf 00 setzen.

Info Das x steht als Platzhalter für den IDE Port (1 oder 2) und das y für den Master oder Slave

Info Alternativ können Sie in den DOS -Modus booten, Scanreg /restore aufrufen und die Registry aus einer der letzten fünf Sicherungen wiederherstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0700.htm


Windows 98 Backup liest Windows 95 Backups nicht zurück

Beim Zurücklesen eines Backups, welches mit Windows 95 erstellt wurde, kann es zu dem Fehler kommen, dass Windows 98 einen Fehler meldet und 0 Bytes zurückliest. Der Fehler tritt i.d.R. auf, wenn aus einem Backup-Satz, der über mehrere Medien erstellt wurde, einzelne Dateien herausgelesen werden sollen. Grund ist eine Änderung des Handlings mit dem QIC Format.

Als Lösung bietet sich nur ein komplettes Zurücklesen an.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0734.htm


Was macht die Datei WINREP.EXE?

WINREP.EXE ist dafür vorgesehen, im Fehlerfalle alle Systemdateien zu sammeln und zusammen mit einem Fehlerprotokoll an Microsoft zu schicken. Diese Informationen werden in einer CAB-Datei zusammengepackt und können dann an MS verschickt werden.

In der CAP-Datei finden Sie auch selber viele Informationen. So finden Sie hier eine vollständige Liste Ihrer Hardware und deren Konfiguration (Adressen usw.).

Wenn Sie WINREP aufrufen, können Sie selber weitere Dateien in die CAB-Datei hinzufügen. Diese Einstellungen werden aber nicht dauerhaft gespeichert und sind beim erneuten Aufruf wieder weg.

In der Registry können Sie diese Seite der Dateien aber beliebig verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Winrep

im Wert "UserFiles" als Datentyp REG_EXPAND_SZ können Sie angeben, welche Dateien gesichert werden sollen. Die einzelnen Dateien müssen durch einen Punkt und ein Leerzeichen getrennt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0786.htm


Temporäre Dateien auf anderes Verzeichnis/Laufwerk legen

Sie werden feststellen, dass weiterhin das Verzeichnis %WINDIR%\TEMP zum Zwischenspeichern einiger Dateien verwendet wird, obwohl Sie in der Autoexec.bat folgende Zeilen eingefügt haben:

Set TEMP=LW:\Verzeichnis

Set TMP=LW:\Verzeichnis

Dieses Verzeichnis können Sie in der Registry festlegen.

Ab Windows NT sollten Sie das am besten über die Systemsteuerung machen:

Unter "Systemsteuerung" -> "System" (je nach Betriebssystem finden Sie es hier in unterschiedlichen Bereichen)

Für XP: Tabreiter "Erweitert" -> Button "Umgebungsvariablen" und hier jeweils die Einstellungen für TEMP und TMP bei den Benutzervariablen und Systemvariablen anpassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VolumeCaches\ Temporary Files

bestimmt der Wert Folder vom Datentyp REG_SZ bzw. ab Windows NT REG_EXPAND_SZ, auf welchem Laufwerk und in welchem Ordner Windows intern temporäre Dateien speichert. Tragen Sie hier den gewünschten Pfad (inklusive Laufwerk) ein.

Info Achten Sie bitte darauf, dass die mit %TEMP% bzw. "Temporary Files" Pfade auch tatsächlich existieren, ansonsten werden einige Programme nicht ordnungsgemäß. funktionieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1207.htm


Systemkonfigurationsprogramm MSCONFIG.EXE

Mit dem Programm MSCONFIG können Sie einfach einige Einstellungen von Windows verändern.

Windows 95/98

Bei Windows 98 finden Sie im Verzeichnis "C:\WINDOWS\SYSTEM" das Programm "MSCONFIG.EXE". Sollte das Programm nicht installiert sein, können Sie es aus den unten angegebenen CAB-Dateien entpacken.

Dieses Programm ist bei Windows 95 nicht vorhanden, wenn Sie die Dateien aus Windows 98 kopieren, läuft es aber auch hier.

Dafür müssen Sie folgende Dateien aus Windows 98 kopieren:

WIN98_40.CAB | msconfig.exe | C:\Windows\system
WIN98_27.CAB | msconfig.chm | C:\Windows\help
WIN98_28.CAB | msconfig.cnt | C:\Windows\help
WIN98_42.CAB | msconfig.hlp | C:\Windows\help
- wird erstellt - | msconfig.lgc | C:\Windows\applog

Allgemein

Auswahl der Windows Startart.

Hier kann angegeben werden, was alles beim Starten abgearbeitet werden soll. U.a. können Sie dort auch unter "Allgemein" -> "Weitere Optionen" einige Speicherzugriffe deaktivieren, was bei Problemen helfen kann. Hier finden Sie auch Einstellungen zum Herunterfahren usw.

Weitere Optionen

Wie oben beschrieben. können Sie hier einige Funktionen deaktivieren. Die meisten Einstellungen verlangsamen Windows allerdings, so dass sich deren Deaktivierung nur lohnt, wenn damit schwerwiegende Fehler beseitigt werden können:

System-ROM-Haltepunkt deaktivieren

Diese Funktion müssen Sie nur aktivieren, wenn noch virtuelle Speichermanager wie 286MAX oder QEMM benutzt werden. Wenn aktiviert, benutzt Windows den Read-Only-Memory zwischen F000:0000 und 1 MB nicht.

Virtuellen HD IRQ deaktivieren

Windows versucht die ROM-Routine zu umgehen, die Interrupt von Festplattencontrollern verwaltet. Dadurch läuft das System schneller. Diese Funktion muss nur bei einigen alten Festplatten aktiviert werden.

EMM:A000-FFFF ausschließen

Windows sucht automatisch nach freiem Systemspeicher. Bei einigen Geräten kann dieses automatische Suchen aber zu Konflikten führen. Wenn das der Fall ist, können Sie mit dieser Funktion das automatische Suchen deaktivieren.

Kompatibilitätsmodus für Datenträgerzugriff aktivieren

Damit wird der 32-Bit Zugriff auf Datenträger unterbunden. Das kann bei Ein-/Ausgabeproblemen sinnvoll sein.

VGA 640*480*12

Nur Standard-Grafikkartentreiber werden geladen

SCSI-Doppelpufferung verwenden

Windows erkennt selbst, ob diese Funktion bei Datenträgerzugriffen benötigt wird. Nur bei fehlerhaften Zugriffen sollte man diese Funktion einmal aktivieren.

ScanDisk nach fehlerhaftem Herunterfahren deaktivieren

Wenn Sie Windows nicht ordnungsgemäß beenden, wird automatisch ein Scandisk ausgeführt. Hier können Sie das für immer ausstellen.

Speicherbegrenzung auf x MB

Hiermit wird die Speicherbelegung auf den von Ihnen eingegebenen Wert begrenzt.

Schnelles Herunterfahren deaktivieren

Hierbei werden vom System geladene Protected-Mode-Gerätetreiber beim Herunterfahren nicht deinitialisiert, wodurch Windows besonders schnell beendet werden kann. Bei vielen Systemen macht diese Funktion nur Probleme, weshalb sie meist deaktiviert werden muss.

UDF-Dateisystem deaktivieren

Hiermit wird die Unterstützung für das UDF-Dateisystem für austauschbare Datenträger deaktiviert.

Pentium F0 (Lock CmpXchg) aktivieren

Ein Fehler im Pentium P5 und MMX kann zu Systemabstürzen führen. Normalerweise benutzen aber Programme diese Funktion nicht.

Config.sys

Hier kann jeder einzelne Eintrag leicht de- bzw. wieder aktiviert werden

Autoexec.bat

Hier kann jeder einzelne Eintrag leicht de- bzw. wieder aktiviert werden

System.ini

Auch hier kann jetzt jeder Eintrag der Datei bearbeitet werden

Für eine Übersicht der möglichen Einträge lesen Sie den Tipp: System.ini

Win.ini

Auch hier kann jetzt jeder Eintrag der Datei bearbeitet werden

Für eine Übersicht der möglichen Einträge lesen Sie den Tipp: WIN.INI

Autostart

Zeigt alle Programme an, die automatisch beim Hochfahren gestartet werden und bietet die Möglichkeit, sie hier zu deaktivieren

Info Haben Sie z.B. Probleme mit dem Herunterfahren von Windows, sollten Sie unter "Allgemein" den Punkt "Schnelles Herunterfahren deaktivieren" aktivieren.

Ab Windows XP

Liegt das Programm unter "%SystemRoot%\pchealth\helpctr\binaries". Über "Start" -> "Ausführen..." und durch eingeben von "MSCONFIG" können Sie das Tool starten.

Tabreitername

Funktion

Allgemein

Hier finden Sie Funktionen für den Systemstart. Sie können hier einstellen, was Windows beim nächsten Systemstart ausführen soll:

- Normaler Systemstart (Alle Gerätetreiber und Dienste laden)

- Diagnosesystemstart (Nur grundlegende Geräte und Dienste laden)

- Benutzerdefinierter Systemstart

An dieser Einstellung sollten Sie normalerweise nichts ändern, da der erste Eintrag "Normaler Systemstart" für das System die richtige Auswahl ist.

Weiterhin können Sie hier über den Button "Systemwiederherstellung starten" die Systemwiederherstellungaufrufen und zu einer alten Sicherung des System zurückkehren.

Über den Button "Datei erweitern..." können Sie noch zusätzliche Dateien zur Systemwiederherstellung hinzufügen.

SYSTEM.INI

Ab Windows 7 nicht mehr vorhanden.

Hier können Einträge deaktiviert und geändert werden. Durch diese Einträge werden Treiber und Schriften usw. für das System geladen.

Für eine Übersicht der möglichen Einträge lesen Sie den Tipp: System.ini.

WIN.INI

Ab Windows 7 nicht mehr vorhanden.

Hier können Einträge deaktiviert und geändert werden. Durch diese Einträge werden Treiber und Schriften usw. für das System geladen.

Für eine Übersicht der möglichen Einträge lesen Sie den Tipp: WIN.INI

BOOT.INI bzw. Start

Über diese Einstellungen können Sie das Booten von Windows steuern.

Weitere Infos dazu finden Sie im Tipp: "Informationen über die Boot.INI"

Dienste

Über diesen Eintrag können Sie sich die vorhandenen Dienste auf Ihren Rechner anzeigen lassen. Sie können hier nicht benötigte Dienste deaktivieren, dabei sollten Sie aber beachten, dass Sie keine wichtigen Dienste ausschalten.

Über die Checkbox "Alle Microsoft-Dienste ausblenden" können Sie leicht alle Microsoft-Dienste ausblenden lassen und sehen somit nur noch die Dienste, welche von anderen Programmen/Herstellern installiert wurden.

Genauere Informationen zu den Diensten finden Sie unter "Die Windows Dienste und Ihre Funktionen"

Systemstart

Dieser Menüpunkt ist für die meisten Anwender der wichtigste Eintrag.

Hier werden weitere Programme und Tools aufgeführt, die beim Starten von Windows automatisch gestartet werden. Informieren Sie sich z.B. über den Namen und den Befehl im Internet, ob Sie diese Einträge benötigen. Durch das Deaktivieren von nicht gebrauchten Einträgen, können Sie den Systemstart oft beschleunigen.
Tools

Ab Windows 7

Hier können Sie die Konfiguration bzw. .Tools von Windows aufrufen. Wählen Sie dafür das entsprechende Tool aus und klicken Sie anschließend auf den Button "Starten"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0282.htm


Rechner erwacht nicht mehr aus Stand-by

Ich konnte unter Microsoft Windows 95 meinen Rechner über die APM-Funktion (Advanced Power Management) in den Stand-by-Modus schalten. Nachdem ich Windows 98 installiert habe und die Funktion auswählte, konnte mein Rechner nicht mehr aktiviert werden, so dass ich einen Neustart ausführen musste. Wie lässt sich das Problem lösen?

Windows 98 installiert die neue, verbesserte APM Version 1.2. Für diese Version ist die Unterstützung der Hardwaregeräte erforderlich. Ihre Computer-Hardware unterstützt aber nur die APM-1.0 Version. Fragen Sie bitte Ihren Hardwarehersteller, ob es neuere Updates für die Komponenten SystemBIOS , Festplatte/Controller und den Bildschirm gibt.

Unter Windows 98 existiert eine Einstellmöglichkeit, welche die Nutzung der Version 1.0 erzwingt und Ihr Problem behebt.

Führen Sie dazu bitte folgende Schritte durch:

  1. Klicken Sie in der Taskleiste auf START - EINSTELLUNGEN - SYSTEMSTEUERUNG - SYSTEM.
  2. Öffnen Sie die Registerkarte GERÄTEMANAGER.
  3. Unter den aufgelisteten Geräten finden Sie SYSTEMKOMPONENTEN. Öffnen Sie diese bitte durch einen Doppelklick.
  4. In der nun erscheinenden Auflistung gibt es den Eintrag UNTERSTÜTZUNG FÜR ADVANCED POWER MANAGER. Klicken Sie diesen Eintrag doppelt an.
  5. Wählen Sie die Registerkarte EINSTELLUNGEN und aktivieren Sie dort die Box "APM 1.0-Modus erzwingen".
  6. Bestätigen Sie die Einstellung bitte zweimal mit OK und starten Sie den Computer neu.

(Übernommen aus der deutschen MS KB, http://support.microsoft.com/default.aspx?scid=kb%3Bde%3BD35112).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0698.htm


Online Registrierung für Update unnötig

Wenn es nach Microsoft geht, ist für ein Update zuerst eine Online-Registrierung nötig. Bei dieser Registrierung werden zwar wirklich nur die eingegebenen Daten übertragen (es hat sich herausgestellt, dass eine eindeutige ID (MAC-Adresse) übertragen wird). MS behauptet zwar, dass diese Daten nicht ausgewertet werden, aber wer gibt trotzdem schon gern seine Adresse weiter, um nachher nur Werbung und sonstigen Müll zu erhalten.

Durch einen Eingriff in die Registry kann man Updates auch ohne Registrierung durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Windows 98 und ME

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

Dort setzen Sie nun einfach den Schlüssel "RegDone" als Datentyp auf "1"und unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Welcome\ RegWiz

die Zeichenfolge "@" auf "1".

Ab Windows 2000

müssen Sie die Einträge unter folgendem Schlüssel durchführen:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion

Fügen Sie einen neuen Eintrag "RegDone" als Datentyp REG_SZ hinzu und setzen Sie den Wert auf "1".

Info Wenn Sie nicht wollen, dass der Registration-Wizard unbeabsichtigt gestartet werden soll, können Sie das Programm über die Eingabeaufforderung deaktivieren. Geben Sie dazu z.B. unter Start -> Ausführen folgendes ein:

regsvr32 /u regwizc.dll

Wird der Wizard benötigt, müssen Sie vorher die DLL wieder registrieren, geben Sie dazu folgendes ein:

regsvr32 regwizc.dll

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0249.htm


HP-Scannersoftware unter Windows 98 installieren

Anwendern eines HP-Scanners ärgern sich darüber, dass die Installationsroutine abbricht, wenn man versucht, diese unter Windows 98 zu installieren (lt. Aussage von HP werden für Windows 98 extra Treiber benötigt, die man bei HP aber kaufen muss).

Die Installationsroutinen enthalten aber auch schon die nötigen Einträge für Windows 98. Wenn man bei der Meldung, dass diese Installationsroutine nicht für Windows 98 geeignet ist, beim Klick auf OKgleichzeitig die STRG-Taste gedrückt hält, funktioniert die Installation unter Windows 98 aber doch.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0280.htm


Die Systemdateiprüfung (SFC) findet keine geänderten Dateien

Grundsätzlich sollte man nach jeder Installation eines Treibers oder Programms die Systemdateiprüfung von Windows 98 durchführen. Sie lässt sich über die neue Systeminfo oder direkt als C:\WINDOWS\SYSTEM\SFC.EXE(auch "Start" - "Ausführen" - "sfc") starten. Nun kann es aber passieren, dass SFC keine Veränderungen findet. Dann müssen Sie unter EINSTELLUNGEN noch einmal ganz unten "Geänderte Dateien suchen" und "Gelöschte Dateien suchen" markieren.

Info Sfc.exe protokolliert alle Änderungen in der Datei C:\Windows\Sfclog.txt. Diese Datei können Sie mit jedem beliebigen Texteditor bearbeiten. Es hat sich als praktisch und hilfreich erwiesen, die jeweiligen SFC-Prüfdurchgänge mit einem aussagefähigen Kommentar zu versehen. So lassen sich auch später noch Änderungen an den Systemdateien leicht nachvollziehen.

Sie können auch beschädigte oder versehentlich gelöschte Dateien mit SFC wiederherstellen.

Wählen Sie dazu "Eine Datei von der Installationsdiskette extrahieren", geben den Namen der wiederherzustellenden Datei an und klicken dann auf "Starten".

In dem darauf folgenden Dialog "Datei extrahieren" ergänzen Sie die Angaben zu "Wiederherstellen von" und "Speichern in" und bestätigen mit "OK". Die Datei wird nun aus den Originaldateien in das angegebene Zielverzeichnis extrahiert. Wenn Sie die Installationsdateien von der CD auf der Festplatte gespeichert haben und "SourcePath" richtig gesetzt ist, ist "Wiederherstellen von" schon richtig vorbelegt. Siehe auch "Installationslaufwerk und -pfad ändern (Source-Daten)".

Sollte die wiederherzustellende Datei gerade von Windows verwendet werden, können Sie die Datei nicht im laufenden Betrieb ersetzen. In diesem Fall extrahieren Sie die Datei in ein anderes Verzeichnis und nehmen die Ersetzung dann unter reinem DOS vor:

  1. Extrahieren z.B. nach C:\Windows\Temp
  2. Booten zur Eingabeaufforderung
  3. copy C:\Windows\Temp\xxx C:\Windows\xxx
  4. del C:\Windows\Temp\xxx

Info In Windows ME finden Sie die Funktion zum Extrahieren von Dateien in Msconfig.exe ("Start" - "Ausführen" - Msconfig").

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:

  • "Extrahieren komprimierter Windows-Originaldateien": http://support.microsoft.com/?kbid=129605
  • "Description of the System File Checker Tool (Sfc.exe)": http://support.microsoft.com/?kbid=185836
  • "Beschreibung des Windows-Systemdatei-Überprüfungsprogramms (XP)": http://support.microsoft.com/?kbid=310747
  • "Das Systemdatei-Überprüfungsprogramm von Windows 2000": http://support.microsoft.com/?kbid=222471

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0736.htm


Infos zu VMM32.VXD und Startvorgang

Hin und wieder gibt es Falschmeldungen zur Datei VMM32.VXD. Von generischen Treibern war die Rede, was absoluter Schwachsinn ist. Außerdem soll Windows angeblich einige VXDs nicht mit auf die Festplatte kopieren. Daher hier einmal einige Klarstellungen:

Die Datei VMM32.VXD beinhaltet einen Großteil der virtuellen Gerätetreiber mit der Endung VXD. Diese sind sog. Real Mode Treiber, welche vor dem Protect-Mode von Windows geladen werden. Für jeden Rechner wird eine eigene VMM32.VXD erstellt. Welche Dateien diese beinhaltet, lässt sich im Abschnitt [386enh] der System.ini betrachten. Die Angaben dort sind nur aus Gründen der Abwärtskompatibilität enthalten.

Soll eine VXD des VMM32 erneut werden, muss diese in das Verzeichnis System\Vmm32 kopiert werden, da diese vorrangig sind. VMM32 lädt dann die dort befindliche Datei statt der eigenen (z.B. Startspezielle Maustreiber)

VMM32 arbeitet beim Booten in 3 Schritten:

Zunächst werden die in der Registrierung angegebenen Treiber geladen. Die REG-Datenbank enthält für alle VXD, denen keine Hardware zugeordnet ist, einen eigenen Eintrag (z.B. Virenscanmodule, PPP).

Die Einträge finden sich unter HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VXD.

Falls VMM32 einen REG-Schlüssel Mit diesem Wert StaticVXD= findet, wird diese VXD geladen und ausgeführt.

Danach lädt VMM32 die statischen VXDs, welche in [386enh] angegeben sind. Die Dateien werden aber direkt aus dem VMM32 geladen.

Erst jetzt schaltet der VMM32 in den Protect-Mode, in welchem das Plug and Play BIOS aktiviert wird und die dynamischen Gerätetreiber ohne VXD-Eintrag, Kernel, GDI und User.exe geladen werden.

Zuletzt werden die Schriftarten geladen, Einträge der WIN.INI ausgeführt und Shell-/Desktopkomponenten geladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0265.htm


Papierkorb deaktivieren (sofort löschen)

Papierkorb deaktivieren (sofortiges Löschen)

Mit diesem Tipp können Sie den Papierkorb deaktivieren, so dass die Dateien sofort gelöscht werden. Das entspricht dem Verhalten, als wenn Sie beim Löschen einer Datei/Verzeichnisses die Shift-Taste gedrückt halten (siehe dazu Tipp: Dateien ohne Umweg über den Papierkorb löschen).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ BitBucket

Erstellen Sie hier einen neuen Wert mit dem Namen "NkeOnDelete" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Papierkorb benutzen (Standard)
1 | Sofort löschen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2651.htm


Unnötige Installationsdateien löschen

Hier finden Sie eine Beschreibung, welche nicht mehr benötigten Installationsdateien nach der Installation von Windows gelöscht werden können.

Windows ME

Windows 2000/XP

Windows ME

Windows ME kopiert alle bei der Installation benötigten Dateien von der CD auf die Festplatte ins Verzeichnis "Windows\options\install". Diese benötigen knapp 150 MB und können gelöscht werden, da der Systemdateienschutz diese im Gegensatz zu Windows 2000 nicht benötigt. Soll eine überwachte Datei gelöscht oder überschrieben werden, kopiert Windows ME diese erst an einen sicheren Ort, um sie ggf. wieder herzustellen.

Will man bei jedem Nachinstallieren nicht immer den neuen Pfad auf die CD angeben müssen, kann man dies über die Registry abändern, indem man unter: HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Setup

den Schlüssel SourcePath auf den Pfad des CD-ROMs setzt, also z.B. x:\win9x\.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 2000/XP

Auch unter Windows 2000 können Sie einiges an Festplattenspeicher freischaufeln:

  • Speicherplatz freigeben durch Löschen des Verzeichnisses
    "%SYSTEMROOT%\system32\dllcache" (ca. 245 MByte)
  • Speicherplatz freigeben durch Löschen der Datei
    "%SYSTEMROOT%\Driver Cache\i386\driver.cab" (ca. 55 MByte)

Beide Verzeichnisse werden nicht benötigt - bei Bedarf (Geräteinstallation) werden die Daten von der Windows 2000 CD geladen.

Den Pfad für den "Driver Cache" können Sie in der Registry auch auf das CD-Rom umstellen und zwar unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Setup

den Eintrag "DriverCachePath" auf die neue Pfadangabe ändern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0987.htm


Rechner geht nicht in den Stand-by-Modus

Viele Anwender verzweifeln unter Windows ME bei dem Versuch, die Stand-by-Methoden zu benutzen. Wenn die BIOS-Einstellungen richtig sind, sind meistens Treiber für die Probleme verantwortlich, da der Hibernate-Modus nicht ausgelöst wird.

Windows ME protokolliert Probleme beim Hibernate-Modus in einer Datei namens nohiber.txt im Windows-Verzeichnis.

In dieser Datei finden sich bei einem Scheitern des Stand-by dann Einträge wie z.B. "Hibernation disabled because hibernate is not supported by the audio driver- emu10k1.vxd." Der Übeltäter ist hier leicht ausgemacht. Ein neuer Treiber (wenn verfügbar) sollte hier das Problem lösen). Bei weiteren Problemen schaut man einfach noch einmal in die Datei, ob jetzt andere Geräte den Stand-by verhindern.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1069.htm


Stand-by von 'Suspend to RAM' auf 'Suspend to Disk' ändern

Bei richtig funktionierendem ACPI wird auf Laptops als Ruhezustand "Suspend to RAM" eingesetzt, sofern dies nicht ausdrücklich umgestellt ist. Das sog. Starten 3 kann aber auf "Suspend to Disk" (S2) geändert werden und spart somit Strom. Die Einstellung lässt sich über "Start" -> "Ausführen" -> "MSConfig" -> "Erweitert" -> "Tiefen Ruhezustand aktivieren" einschalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1098.htm


Standard-Icon auf dem Desktop ausblenden

Hier wird beschrieben wie Sie die Standard-Icons vom Desktop entfernen können.

Ab Windows XP

Hier können Sie das Icon direkt über das Kontextmenü ausblenden, klicken Sie dafür mit der rechten Maustaste auf den "Desktop" -> "Eigenschaften" -> "Desktop" -> "Desktop anpassen.." Hier können Sie unter dem Tabreiter "Allgemein" -> "Desktopsymbole" die nicht benötigten Symbole ausblenden.

Ab Windows Vista finden Sie das unter: rechte Maustaste auf den Desktop -> "Anpassen" -> links im Menü "Desktopsymbole ändern" -> dort können Sie unter "Desktopsymbole" die entsprechenden Icons ausblenden.

Dabei werden folgende Registryeinträge bearbeitet:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ HideDesktopIcons\ ClassicStartMenu\

1 | Icon wird nicht mehr angezeigt
0 | Icon wird angezeigt (Standard)

Als Policy setzen Sie den Key unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ NonEnum

und setzen Sie folgende Werte

Arbeitsplatz Icon ausblenden:

Wert "{20D04FE0-3AEA-1069-A2D8-08002B30309D}" als Datentyp REG_DWORD

Mit dieser Einstellung wird der Arbeitsplatz aus dem Desktop und aus dem neuen Startmenü ausgeblendet. Sie blendet außerdem Verknüpfungen zum Arbeitsplatz in der Webansicht aller Explorer-Fenster aus und blendet den Arbeitsplatz im Fenster Ordnerstruktur von Explorer aus. Wenn der Benutzer mit der Aufwärts-Taste zu Arbeitsplatz wechselt, wird ein leerer Ordner "Arbeitsplatz" angezeigt.

Eigene Dateien ausblenden:

Wert "{450D8FBA-AD25-11D0-98A8-0800361B1103}" als Datentyp REG_DWORD

Siehe auch Tipp: "Den Eintrag "Eigene Dateien" vom Desktop und aus dem Explorer entfernen"

Netzwerkumgebung ausblenden:

Wert "{208D2C60-3AEA-1069-A2D7-08002B30309D}" als Datentyp REG_DWORD

Internet Explorer ausblenden:

Wert "{871C5380-42A0-1069-A2EA-08002B30309D}" als Datentyp REG_DWORD

Papierkorb ausblenden:

Wert "{645FF040-5081-101B-9F08-00AA002F954E}" als Datentyp REG_DWORD

Siehe auch Tipp: "Papierkorb von Desktop und Explorer entfernen"

1 | Icon wird nicht mehr angezeigt
gelöscht | Icon wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Arbeitsplatz Icon ausblenden: Symbol "Arbeitsplatz" vom Desktop entfernen Eigene Dateien ausblenden: Symbol "Eigene Dateien" vom Desktop entfernen Papierkorb ausblenden: Papierkorbsymbol vom Desktop entfernen

Windows ME/2000

Hier müssen Sie leider über die Registry arbeiten, da es hier diese Funktion noch nicht gibt.

Unter:

HKEY_CURRENT_USER\ Software\ Classes\ CLSID\ {20D04FE0-3AEA-1069-A2D8-08002B30309D}\ ShellFolder

Erstellen Sie hier einen neuen Wert mit dem Namen "Attributes" als Datentyp REG_DWORD. Setzen Sie den Wert auf "f0500174"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1393.htm


Besondere Desktopicons setzen

Mit diesem Tipp können Sie besondere Desktopicons auf dem Desktop erstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace

erstellen Sie hier jeweils für die gewünschten Icons einen Nummern Schlüssel mit folgenden Namen:

Schlüsselname | Icon
{D20EA4E1-3957-11d2-A40B-0C5020524153} | Administrative Tools
{D20EA4E1-3957-11d2-A40B-0C5020524152} | Schriftarten
{FF393560-C2A7-11CF-BFF4-444553540000} | Verlauf
{00020D75-0000-0000-C000-000000000046} | Outlook
{450D8FBA-AD25-11D0-98A8-0800361B1103} | Eigene Dateien
{7007ACC7-3202-11D1-AAD2-00805FC1270E} | Netzwerkverbindungen
{2227A280-3AEA-1069-A2DE-08002B30309D} | Drucker und Faxgeräte
{7be9d83c-a729-4d97-b5a7-1b7313c39e0a} | Programm Folder
{E211B736-43FD-11D1-9EFB-0000F8757FCD} | Scanner und Kameras
{D6277990-4C6A-11CF-8D87-00AA0060F5BF} | Geplante Task
{48e7caab-b918-4e58-a94d-505519c795dc} | Start Menü Folder
{7BD29E00-76C1-11CF-9DD0-00A0C9034933} | Temporary Internet Files

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1597.htm


Erstes Desktop Icon festlegen

Mit diesem Tipp können Sie festlegen, welches das erste Icon auf den Desktop sein soll. Sie haben hier die Auswahl zwischen "Eigene Dateien" oder "Arbeitsplatz".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ CLSID\ {450D8FBA-AD25-11D0-98A8-0800361B1103}

Erstellen Sie hier einen neuen Wert mit dem Namen "SortOrderIndex" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

48 | Eigene Dateien
54 | Arbeitsplatz

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1668.htm


Taskleiste auf dem Desktop fixieren

Standardmäßig ist die Taskleiste unter Windows fest unten mit dem Desktop verbunden. Wenn Sie die Größe oder die Position der Taskleiste verändern wollen, müssen Sie die Fixierung deaktivieren, klicken Sie dazu auf die Taskleiste mit der rechten Maustaste und wählen Sie "Taskleiste fixieren" an (dadurch wird der Haken entfernt). Jetzt können Sie die Taskleiste verschieben und die Größe ändern.

Sie können diese Änderung natürlich auch über die Registry durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "TaskbarSizeMove" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Taskleiste veränderbar
0 | Taskleiste fixiert

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1186.htm


Kontextmenü der Taskleiste aktivieren/deaktivieren

Mit diesem Tipp können Sie das Kontextmenü der Taskleiste deaktivieren. Dafür müssen Sie den Eintrag "TaskbarContextMenu" auf 0 setzen. Anschließend müssen Sie sich an Windows neu anmelden, damit die Einstellungen wirksam werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "TaskbarContextMenu" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Kontextmenü wird nicht angezeigt
1 | Kontextmenü wird angezeigt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2455.htm


Größenänderung der Taskleiste unterbinden

Mit diesem Tipp können Sie verhindern, dass die Größe der Taskleiste geändert werden kann. Dafür müssen Sie den Eintrag "TaskbarSizeMove" auf 0 setzen. Anschließend müssen Sie sich an Windows neu anmelden, damit die Einstellungen wirksam werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "TaskbarSizeMove" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Größe der Taskleiste kann nicht geändert werden
1 | Größe der Taskleiste kann geändert werden (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2456.htm


Verändern der Pfade für Eigenen Dateien, Bilder usw. unterbinden

Mit diesem Tipp können Sie einstellen, ob die Anwender die Pfade zu den Verzeichnissen für die Eigenen Dateien, Bilder usw. selber verändern können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier die benötigten Werte als Datentyp REG_DWORD:

Wertname | Beschreibung
DisableMyPicturesDirChange | Eigene Bilder
DisableFavoritesDirChange | Favoriten
DisablePersonalDirChange | Eigene Dateien Standardmäßig können Benutzer den Pfad des Ordners "Eigene Dateien" ändern, indem sie einen neuen Pfad im Feld "Ziel" in den Eigenschaften von "Eigene Dateien" eingeben.
DisableMyMusicDirChange | Eigene Musik

Setzen Sie die Werte auf:

1 | Pfad kann nicht geändert werden
gelöscht | Pfad kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | DisablePersonalDirChange: Pfadänderung für den Ordner "Meine Dateien" nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1763.htm


Ausblenden von selten verwendeten Menüpunkten ein-/ausschalten

Unter Windows werden jetzt auch im Startmenü selten verwendete Menüpunkte ausgeblendet und erst dann wieder angezeigt, wenn Sie unten auf den Pfeil klicken.

Durch diese Funktion soll sich die Oberfläche dem Anwender anpassen und ihm nur noch die häufig verwendeten Funktionen anzeigen.

Diese Funktion kann folgendermaßen deaktiviert werden unter den Eigenschaften des Startmenüs (Taskleiste, rechte Maustaste, Eigenschaften):

  1. Mit der rechten Maustaste auf die Taskleiste klicken
  2. Eigenschaften wählen
  3. Unter dem Tabreiter "Startmenü"
    Klassisches Startmenü:
    hier auf dem Button Anpassen klicken und hier den Punkt "Persönlich angepasste Menüs verwenden" deaktivieren.

Für den Internet Explorer und dessen Favoriten gibt es die gleiche Einstellung unter Extras/Internetoptionen, Erweitert.

In der Registry finden Sie die Einstellung dafür unter folgender Stelle.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "IntelliMenus" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Die benutzerdefinierten Menüs werden deaktiviert
1 | Die benutzerdefinierten Menüs werden angezeigt

Als Policy finden Sie den Key unter (Ist dieser Eintrag vorhanden, wird die obere Einstellung ignoriert):

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "IntelliMenus" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die benutzerdefinierten Menüs werden deaktiviert
gelöscht | Die benutzerdefinierten Menüs werden angezeigt (Standard)

Wenn Sie die Policy aktivieren, werden alle Menüeinträge in der Standardreihenfolge angezeigt. Zusätzlich wird durch diese Einstellung die Option "Persönlich angepasste Menüs verwenden" entfernt, so dass Benutzer nicht versuchen, diese Einstellung zu ändern, während eine Einstellung angewendet wird.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Persönlich angepasste Menüs deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Funktion ist auch abhängig von: Protokollierung von Anwenderaktivitäten ausschalten

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0541.htm


'Zuletzt verwendete...' aus dem 'Startmenü' ein-/ausblenden

"Zuletzt verwendete ..." aus dem "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob "Zuletzt verwendete Dokumente" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Das Menü "Dokumente" enthält Verknüpfungen zu Dateien (die keine Programme sind), die der Benutzer zuletzt geöffnet hat. Diese Verknüpfungen werden angezeigt, um den Zugriff auf diese Dateien zu erleichtern.

Auch wenn Sie den Tipp aktivieren, werden die "Zuletzt verwendete Dokumente" immer noch in der History gespeichert, sie werden nur nicht mehr angezeigt. Wird der Tipp wieder deaktiviert, wird diese Liste wieder angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRecentDocsMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Zuletzt verwendete Dokumente" ausblenden
gelöscht | "Zuletzt verwendete Dokumente" anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Dokumente" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1716.htm


'Eigene Bilder' aus dem 'Startmenü' ein-/ausblenden

"Eigene Bilder" aus dem "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob "Eigene Bilder" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSMMyPictures" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Eigene Bilder" im "Startmenü" ausblenden
gelöscht | "Eigene Bilder" im "Startmenü" anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Symbol "Eigene Bilder" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1717.htm


'Eigene Musik' aus dem 'Startmenü' ein-/ausblenden

"Eigene Musik" aus dem "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob "Eigene Musik" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuMyMusic" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Eigene Musik" ausblenden
gelöscht | "Eigene Musik" anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Symbol "Eigene Musik" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1718.htm


Drag and Drop im 'Startmenü' Aus-/Einschalten (klassische Ansicht)

Mit diesem Tipp können Sie die <Drag und Drop> Funktion im "Startmenü" aus-/einschalten. Diese Einstellung bezieht sich auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "StartMenuChange" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Drag and Drop" aktivieren
0 | "Drag and Drop" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1733.htm


Hilfe und Support im 'Startmenü' ein-/ausblenden

Hilfe und Support im "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob die "Hilfe und Support" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Diese Einstellung gilt nur für das Startmenü. Das Menü "Hilfe" wird nicht aus Windows Explorer entfernt, und Benutzer werden nicht daran gehindert, die Hilfe auszuführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSMHelp" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Hilfe und Support" ausblenden
gelöscht | "Hilfe und Support" wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Hilfe" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1759.htm


Eigene Dateien aus dem 'Startmenü' ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob die "Eigene Dateien" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSMMyDocs" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Eigene Dateien" ausblenden
gelöscht | "Eigene Dateien" wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Symbol "Eigene Dateien" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1761.htm


Aufruf der Systemsteuerung unterbinden

Wenn Sie diesen Tipp aktivieren, wird verhindert, dass die Programmdatei Control.exe gestartet werden kann. Dadurch können keine Einträge aus der Systemsteuerung mehr aufgerufen werden. Wird versucht, einen Eintrag aus der Systemsteuerung zu öffnen, wird eine Fehlermeldung ausgegeben. Weiterhin werden die Option "Systemsteuerung" aus dem Startmenü (Klicken Sie auf "Start", "Einstellungen" und dann "Systemsteuerung", um die Systemsteuerung zu öffnen) und der Ordner "Systemsteuerung" aus Windows Explorer entfernt.

Es können auch die "Eigenschaften" aus dem Kontextmenü beim Rechtsklick auf den Desktop nicht mehr aufgerufen werden. Gilt auch für die Icons "Arbeitsplatz", "Netzwerkumgebung", "IE" und "Outlook"

Ist der Tipp aktiv und wird versucht auf die Systemsteuerung zuzugreifen erscheint die Fehlermeldung "Dieser Vorgang wurde aufgrund von Einschränkungen abgebrochen..."

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoControlPanel" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag ist aktiv, Systemsteuerung gesperrt
gelöscht | Eintrag ist nicht aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung
Einstellungsname: | Zugriff auf die Systemsteuerung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1423.htm


'Drag and Drop' vom Taskplaner deaktivieren

Wenn Sie diese Policy aktivieren, können keine neuen Programm in den Taskplaner über „Drag and Drop“ hinzugefügt bzw. entfernt werden.

Es wird damit auch die Funktion „Einfügen“, "Ausschneiden" und "Kopieren" aus dem Kontextmenü und dem Menü "Bearbeiten" in "Geplante Vorgänge" deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "DragAndDrop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Drag And Drop wird unterbunden
0 | Drag And Drop erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Drag & Drop nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1537.htm


Starten und Stoppen von Task unterbinden

Wenn Sie diesen Tipp aktivieren, können die Anwender keinen Task mehr starten oder beenden.

Es werden nur die geplanten Task ausgeführt und die Anwender haben keinen Einfluss darauf. Durch das Aktivieren des Tipps werden die Einträge "Task ausführen" und "Task beenden" aus dem Kontextmenü, der beim Rechtsklick auf einen Task ausgeführt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Execution" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Starten/Stoppen wird unterbunden
0 | Starten/Stoppen ist erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Ausführen oder Beenden von einem Task verhindern Ab Vista: Ausführen oder Beenden einer Aufgabe verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1538.htm


'Erweiterte Eigenschaften' beim Taskplaner-Assistenten ausblenden

Wenn Sie diese Policy aktivieren, wird im Assistenten vom Taskplaner der Eintrag „Erweiterte Eigenschaften für diesen Task“ beim Klicken auf „Fertig stellen“ ausgeblendet. Der Anwender kann auf die Erweiterten Einstellungen nicht mehr zugreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Disable Advanced" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Erweiterte Einstellungen" sind ausgeblendet
0 | "Erweiterte Einstellungen" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Kontrollkästchen "Erweitert" im "Assistent für geplante Tasks" ausblenden Ab Vista: Kontrollkästchen "Erweitert" im "Assistent für geplante Aufgaben" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1539.htm


Eigenschaften aus dem Kontextmenü von aktuellen Task im Taskplaner entfernen

Wenn Sie diesen Tipp aktivieren, wird aus dem Kontextmenü vorhandener Task im Taskplaner der Eintrag „Eigenschaften“ entfernt. Der Anwender kann die Einstellung der vorhandenen Tasks nicht mehr verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Property Pages" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Eigenschaften" sind ausgeblendet
0 | "Eigenschaften" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Eigenschaftenseiten ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1540.htm


Programm vom Task kann im Taskplaner nicht mehr verändert werden

Mit diesem Tipp wird die Programmauswahl auf neu erstellte und geplante Task des Benutzers eingeschränkt und damit wird verhindert, das der Benutzer geplante Programme eines bestehenden Task verändern kann.

Diese Einstellung entfernt auch die Schaltfläche "Durchsuchen" aus dem "Assistent für geplante Tasks" und von der Registerkarte "Task". Weiterhin können die Anwender nicht das Dialogfeld "Ausführen" oder "Ausführen in" der Programme ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Allow Browse" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Programm kann nicht geändert werden
0 | Programm kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Durchsuchen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1541.htm


Erstellen von neuen Tasks im Taskplaner unterbinden

Wenn Sie diese Policy aktivieren, können keine neuen Tasks mehr im Taskplaner zu der bestehenden Liste hinzugefügt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Task Creation" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es können keine Task erstellt werden
0 | Task können erstellt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Erstellen von neuen Tasks nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1542.htm


Löschen von Tasks im Taskplaner unterbinden

Wenn Sie diese Policy aktivieren, können keine bestehenden Tasks aus der Liste im Taskplaner gelöscht werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Task Scheduler5.0

Erstellen Sie hier einen neuen Wert mit dem Namen "Task Deletion" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es können keine Task gelöscht werden
0 | Task können gelöscht werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Taskplaner
Einstellungsname: | Löschen von Tasks nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1543.htm


Taskplaner Icon anzeigen

Wenn Sie diese Funktion aktivieren, wird in der KBar das Icon vom Taskplaner eingeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Plus!\ System Agent

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableTrayIcon" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Icon anzeigen
0 | Icon nicht anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1547.htm


Eigenen Bildviewer benutzen

Windows ME bringt einen eigenen Bildviewer für Formate wie JPG, GIF, TIF und PNG mit. Dieser wird normalerweise im Arbeitsplatz verwendet, wenn dort die Bildansicht aktiviert ist. Man kann diesen Viewer aber auch anderweitig nutzen, indem man eine Verknüpfung wie folgt erstellt und diese in den Ordner SendTo (Senden an) platziert. Der Viewer steht dann über das Kontextmenü zur Verfügung.

"C:\WINDOWS\Rundll32.EXE C:\WINDOWS\SYSTEM\SHIMGVW.DLL,ImageView_Fullscreen"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1019.htm


Amerikanische Tastatur in DOS -Box

Falls man in "Zubehör" - "Systemprogramme" - "Systeminformation" - "Extras" - "Systemkonfiguration" - "International"

die Spracheinstellung auf Deutsch/ÖsterreichRegistry-Schlüssel ändert, bekommt man in der DOS-BOX den US/ENG-Tastaturtreiber. Man sollte daher besser die Originaleinstellung belassen.

Ab Windows 2000

=== Hier schneiden ===

REM Install German Keyboard in DOS:

lh kb16 gr,,%SystemRoot%\system32\keyboard.sys

=== Hier schneiden ===

Einfügen in die Datei "%systemRoot%\system32\autoexec.nt". Dann hat auch die Dos-Box unter Vista wieder ein deutsches Tastaturlayout.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0988.htm


DOS Modus für ME

Ab Windows ME hat Microsoft die Benutzung bzw. das Booten in den reinen MS-DOS Modus deaktiviert. Welche Gründe MS dazu bewegt haben, kann keiner so genau sagen. Wenn Sie den MS-DOS Modus benötigen, finden Sie im Internet Anleitungen, die beschreiben, wie der DOS -Modus wieder aktiviert werden kann:

Auf dieser Webseite wird in englisch beschrieben, wie die DOS -Amputation wieder rückgängig gemacht werden kann. Damit wird Windows ME wieder echt DOS -fähig.

http://www.geocities.com/mfd4life_2000/

Mittels einer Batch-Datei kann man Window ME im DOS booten und kommt über eine Befehlseingabe wieder zum GUI. Die Methode funktioniert, arbeitet aber im Gegensatz zu der anderen Lösung keine Einträge in der AUTOEXEC.BAT und CONFIG.SYS ab.

Ein kleiner Haken ist auf den ersten Blick aber dabei:

Man kann nach dem Patch nicht mehr über das Drücken der Strg-Taste den Abgesicherten-Modus starten.

Wird dieser aber benötigt (beispielsweise, weil Windows nicht mehr starten will), muss man diesen Modus von Hand mit der Eingabe "WIN /d:m" aktivieren (siehe auch: "Command-Line Switches der Datei WIN.COM").

Sie können den Abgesicherten-Modus aber auch erzwingen, wie im folgenden Artikel beschrieben wird: "Windows startet nur noch im Abgesicherten-Modus".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0982.htm


DOS Files-Eintrag erhöhen

Um in Millennium nur den fehlenden Files Eintrag zu ergänzen, ohne das alte DOS in den Dualboot aufzunehmen, genügt es, in der SYSTEM.INI im Abschnitt [386Enh] die Zeile PerVMFiles=[Wert] einzutragen.Der maximale Wert liegt bei 225 und erhöht dadurch den Eintrag auf 255 da Standardmäßig 30 Dateien geöffnet werden können. Der aktuelle Wert errechnet sich also aus:

30 + [PerVMFiles] = Maximale Anzahl Handles für offene Dateien.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0990.htm


Command.COM beim Start von ME laden

MS hat ja bei Windows ME das Laden von Command.com (MS-DOS ) komplett entfernt. Es gibt aber noch einen einfache Möglichkeit, MS-DOS zu starten.

Beim Start von ME prüft Windows, ob unter %WINDIR%\System\Vmm32 ein Programm mit den Namen LOADER.EXEliegt. Wenn dort so einen Datei vorhanden ist, wird sie vor dem Start von Windows ausgeführt. Möchte man nun MS-DOS starten, muss man dort nur die Datei Command.com mit den Namen "LOADER.EXE" ablegen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1395.htm


Einträge für die Autoexec.bat auch unter WinME nutzen

Einträge für die Autoexec.bat auch unter Windows ME nutzen

Windows ME macht es alten DOS-Programmen und Treibern nicht leicht.

Die Config.sys und Autoexec.bat werden von Windows ME selbstständig von Einträgen gereinigt und die neuen Inhalte zuvor ignoriert. Wer nur Variablen oder sonstige Einträge, die normalerweise in der Autoexec.bat stehen würden, benutzen will, kann diese auch in die Datei cmdinit.bat im Ordner c:\windows\command platzieren, da diese zum Aufrufen von DOS -Umgebungen von Windows ME benutzt wird.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1073.htm


Automatische Netzwerksuche deaktivieren

Windows durchsucht mit der neuen Netcrawling-Funktion in zyklischen Abständen das Netzwerk nach neu erscheinenden Ressourcen. Dieses Feature belastet aber den Rechner während der Suche in größeren Netzwerken.

Sie können die Suche nach Netzlaufwerken und Druckern im Windows Explorer über "Extras" -> "Ordneroptionen" -> "Ansicht" -> "Automatisch nach Netzwerkordnern und Druckern suchen" abschalten, wenn Sie den Haken für diese Option entfernen.

Das Netcrawling lässt sich auch über die Registry deaktivieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellt man einen neuen Eintrag mit dem Namen "NoNetcrawling" als Datentyp REG_DWORD und setzt den Wert auf 1.

(0 aktiviert das Netcrawling wieder).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1066.htm


Netzwerk-Verknüpfungen nicht automatisch zum Ordner Netzwerkumgebung hinzufügen

Wenn direkt über das Netzwerk (ohne Benutzen von Laufwerksbuchstaben) ein Dokument geöffnet wird, wird von Windows automatisch eine Verknüpfung im Ordner "Netzwerkumgebung" hinzugefügt. Damit will man anschließend einen schnellen Zugriff auf diese Dateien gewährleisten.

Werden von Ihnen viele Dateien direkt über das Netzwerk geöffnet, wird der Ordner durch diese Funktion schnell sehr unübersichtlich. Weiterhin entsteht dadurch so was wie eine History auf Ihrem Rechner.

Mit diesem Tipp können Sie das konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRecentDocsNethood" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Netzwerkverknüpfungen nicht automatisch hinzufügen
gelöscht | Netzwerkverknüpfungen hinzufügen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Freigaben von zuletzt geöffneten Dateien nicht in der Netzwerkumgebung hinzufügen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1762.htm


IE 6.0 / OE 6.0 neu installieren

Wenn Sie den Internet Explorer bzw. Outlook Express neu installieren wollen, ist das nicht so einfach möglich, da Ihnen gemeldet wird, dass diese Programm schon installiert sind. Wenn Sie die Programme aber trotzdem neu installieren wollen, gehen Sie folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für Internet Explorer 6.0

Unter:

HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\ Active Setup\ Installed Components\ {89820200-ECBD-11cf-8B85-00AA005B4383}

Erstellen Sie einen neuen Eintrag mit dem Namen "IsInstalled" als Datentyp REG_DWORD und setzen den Wert auf 0.

Für Outlook Express 6.0

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Active Setup\ Installed Components\ {44BBA840-CC51-11CF-AAFA-00AA00B6015C}

Erstellen Sie einen neuen Eintrag mit dem Namen "IsInstalled" als Datentyp REG_DWORD und setzen den Wert auf 0.

Jetzt können Sie die Programme neu installieren.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=318378
OLEXP How to Reinstall or Repair Internet Explorer and Outlook Express (Q318378):

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1317.htm


Ausführen bestimmter Programme sperren

Im Tipp "Nur bestimmte Anwendungen zum Ausführen freigeben" wurde beschrieben, wie man eine Liste von Programmen, die gestartet werden dürfen, erstellt. Möchte man aber nur ein paar wenige Programme sperren, ist dieses Vorgehen sehr aufwändig. Durch die folgenden Einträge können Sie eine Liste mit Anwendungen erstellen, die nicht ausgeführt werden dürfen.

Diese Einstellung verhindert nur die Ausführung von Programmen, die durch den Windows Explorer-Prozess gestartet werden. Sie hindert Benutzer nicht, Programme, wie z. B. Task-Manager, der mit dem Systemprozess oder anderen Prozessen gestartet wird, auszuführen. Außerdem verhindert diese Einstellung nicht, dass Benutzer Programme in der Eingabeaufforderung (falls Sie die Verwendung der Eingabeaufforderung zulassen) starten, die sie andernfalls nicht in Windows Explorer starten dürften.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

erstellen Sie einen neuen Eintrag mit dem Namen DisallowRun als Datentyp REG_DWORD. Setzen Sie den Wert auf 1, um die Liste zu aktivieren bzw. auf 0, um die Aktivierung aufzuheben.

Die Liste müssen Sie unter folgendem Schlüssel ablegen:

[Maschine oder User]\ Software\ Microsoft\ Windows\ CurrentVersion \ Policies \ Explorer\ DisallowRun

Erstellen Sie dafür einen neuen Eintrag mit dem Namen "1" als Datentyp REG_SZ. Geben Sie als Wert den Namen der Datei an, die nicht ausgeführt werden soll. Für weitere Einträge zählen Sie die Nummer einfach hoch.

Beispiel:

Wert | Datentyp | Eintrag
1 | REG_SZ | wordpad.exe
2 | REG_SZ | regedit.exe

usw.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Angegebene Windows-Anwendungen nicht ausführen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1334.htm


Neue Aufteilung der Registry bei Windows Millennium

Der Nachfolger von Windows 95/98 soll Windows Millennium werden, welches zur Zeit als Beta 1 vorliegt.

Eine der größten Veränderungen ist die neue Aufteilung der Registry. Die Registry wurde nun auf 3 Dateien aufgeteilt (SYSTEM.DAT, USER.DAT) wie immer und zusätzlich gibt es jetzt noch die Datei CLASSES.DAT, in welcher nun alle Einträge aus dem Registry-Schlüssel HKEY_CLASSES_ROOT abgelegt werden.

Das wurde gemacht, da die Registry unter Windows 95/98 schon auf eine beachtliche Größen von 4-5 MB anwachsen konnte. Da durch wurde der Startvorgang von Windows verlangsamt.

Durch diese Aufteilung werden beim Starten nur noch die nötigen Registry-Schlüssel geladen, was den Bootvorgang erheblich beschleunigt. Die restlichen Schlüssel werden erst nach dem Bootvorgang nachgeladen.

Info Alte Tools zur Bearbeitung der Registry kommen mit der neuen Aufteilung meist nicht zurecht und können die gesamte Registry zerstören!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0555.htm


Sysedit fehlt

Windows ME besitzt kein Sysedit mehr.

Allerdings kann man das alte Sysedit mit einen Packer (z.B. PowerArchiver) aus der win98_21.cab(bei Windows 98SE) in das Systemverzeichnis von Windows ME extrahieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0989.htm


Einheiten von WEB-Dateien und Ordner unterbinden

Windows bildet con WEB-Dateien und Ordner automatisch eine Einheit. Wird dann so eine Datei verschoben, wird von Windows automatisch der Ordner mit verschoben ( z.B. bei HTML-Dateien und deren Ordnern). Wenn Sie das nicht wollen, müssen Sie nur diesen Wert erstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileFolderConnection" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es werden keine Einheiten gebildet
0 | Es werden Einheiten gebildet (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1471.htm


Den '_Restore' -Ordner im Root der Platten löschen

"_Restore-Ordner" im Root der Platten löschen

Die Systemwiederherstellung von Windows ME speichert alle Zwischenschritte einer Installation im sog. Restore-Ordner eines jeden Laufwerks ab. Da sich aber bei der Neuinstallation eines Systems viele Installationsschritte ergeben, legt Windows auf der Festplatte viele Zwischenschritte ab, die auf der Festplatte unnötig Speicherplatz belegen. Windows ME löscht ältere Sicherungen erst, wenn das Limit gem. der Einstellung in der Systemsteuerung erreicht ist.

Im DOS-Modus kann man den Ordner aber dennoch löschen, wenn man das System über eine DOS,-Diskette oder die Startdiskette startet und im DOS verbleibt. Mit dem Befehl deltree c:\_restore wird der Ordner auf C gelöscht.

Windows erstellt den Ordner später neu.

Will man den Ordner komplett löschen und nicht mehr sehen, muss man erst die Systemwiederherstellungabschalten, danach den Systemdateienschutz abschalten und nach einem Neustart im DOS -Mode noch die "_Restore" - Ordner löschen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1081.htm


Fehler SU0325 bei 10% vom Setup

Wenn bei der Installation bei 10 % der Fehler SU0325 erscheint und das Setup abgebrochen wird, liegt dies meist an einem CD-Lesefehler. Ursache kann ein Kratzer, fehlerhaftes Laufwerk oder Unverträglichkeit der CD mit dem Laufwerk sein.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=270593

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0998.htm


Login-Fehler an Windows-2000-Domäne

Das aktivierte Autodisconnect-Feature des Windows 2000-Servers kann dafür sorgen, dass ein Windows ME-Rechner sich erst nach einem Neustart wieder anmelden kann. Der interne Zwischenspeicher von ME behält hier noch Verschlüsselungdaten von einer vorhergehenden Anmeldung, die der Server aber logischerweise zurückweist. Zur Abhilfe schaltet man das Autodisconnect-Feature von Windows 2000 ab.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

den Wert "AutoDisconnect" als Datenytp "REG_DWORD" auf 0xFFFFFFF setzen.

Info Microsoft bietet auch kostenpflichtig einen Patch an.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=272594

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1159.htm


FireWire-Netzwerkverbindung bricht ständig ab

Wenn die FireWire-Verbindung nach kurzer Zeit abbricht, kann dies an einem Bug in Windows ME liegen.

Der Effekt tritt auf, wenn 2 Rechner per TCP/IP über automatisch vergebene IP-Adressen miteinander verbunden sind und TCP/IP das einzige Protokoll ist. Zur Abhilfe vergibt man feste IP-Adressen 192.168.0.0 bis 192.168.255.255 oder installiert ein weiteres Netzwerkprotokoll.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1161.htm


Windows Millennium - Kosmetik statt Innovation

(Autor: Michael Appelt)

Am 14. September wird das erst ein Jahr alte Windows 98 - Zweite Ausgabe durch den Nachfolger Windows Millennium (Windows ME) ersetzt. Die Neuerungen des Urenkels von Windows 95 fallen aber bei weitem nicht so revolutionär aus, wie im Vorfeld vermutet wurde.

Vor Beginn der Entwicklung zu Windows Millennium war von Microsoft noch die Aussage zu vernehmen, dass es sich bei Windows 98 um das letzte Betriebssystem auf DOS -Basis handelt und der Nachfolger über einen Windows 2000-Kern verfügen würde. Diese Pläne hat Microsoft zwischenzeitlich aber auf den Nachfolger "Whistler" verschoben. Dies ist um so bedauerlicher, da bei Windows Millennium daher die gleichen Probleme wie bei den Vorgängern bleiben. Der interne Systemaufbau ermöglicht es immer noch, dass fehlerhafte Programme das ganze System oder andere Programme zum Absturz bringen. Zudem hätte von einer Zusammenführung beider Windows-Familien auch Windows 2000 durch größere Treiberverfügbarkeit profitiert. Bisher entwickeln ein Großteil der Hardwarehersteller nur zögerlich Windows 2000-Treiber und konzentrieren sich mehr auf das Consumerprodukt Windows 9x.

Damit wird der bisherige DOS -Windows-Cocktail hoffentlich zum letzten Mal gerührt und mit neuen Zutaten versehen.

Neues an der Oberfläche

Eine Vielzahl der optischen Neuerungen vom erst Anfang des Jahres erschienen NT-Nachfolgers Windows 2000, wurden identisch in Windows ME übernommen. Dazu gehören beispielsweise die personalisierten Menüs und bessere Anpassungsmöglichkeit des Startmenüs. Neu ist der integrierte Packer für ZIP- und CAB-Archive. Solche lassen sich über das Kontextmenü erstellen und werden mit einem eigenen Ordersymbol dargestellt. Die Funktionsumfang ist dabei aber so spartanisch, dass man auch dann besser zu Alternativen wie dem kostenlosen Powerarchiver greift, welcher wesentlich mehr Komfort und Funktionalität im Umgang mit Archiven aller Art bietet (z.B. auch RAR). Die Flut von Assistenten aus Windows 2000, welche bei allen erdenklichen Situationen den Anwender begrüßen, erscheinen auch in Windows ME. Mit ihnen wird die Erstellung einer Netzwerkverbindung ins LAN oder Internet wirklich zum Kinderspiel.

Kostenlose Zugaben

Als Webbrowser wird der bis Internet-Explorer 5.5 integriert sein. Zu den auffälligsten Neuerungen seinerseits gehört die verbesserte Druckvorschau von Webseiten. Die Zielrichtung von Windows ME auf den Heimanwendermacht auch der neue Media-Player 7 deutlich. Dessen neue Bedienoberfläche hat nichts mehr mit dem Vorgänger gemeinsam. Das Programm versteht sich als Medienzentrale für Multimediadateien aller Art. Neben der Verwaltung von solcher Daten und dem Erstellen von Playlists kann das Programm auch Audio-CDs auslesen und in komprimierter Form auf die Festplatte speichern. Für das einfache Erstellen von Videos im AVI- oder MPG-Format bietet Windows ME einen eigenen Movie-Maker

Verbesserungen im Hintergrund

Ebenfalls von Windows 2000 stammt das System-File-Protection. Dahinter verbirgt sich ein Mechanismus, mit welchem das Betriebssystem wichtige Systemdateien schützt. Alle relevanten Systembibliotheken werden als Kopie in einem separaten Verzeichnis gehalten. Das System wacht über diese und stellt bei einer Überschreibung durch eine ältere Version oder Löschung die Originaldatei selbstständig wieder her. Dadurch werden die bisher bekannten Probleme durch die verschiedenen Versionen der gleichen DLL-Datei zumindest fürs den Anfang behoben. Allerdings streiken dadurch auch einige Programme, welche eine bestimmte DLL-Version benötigen.

Eine wirkliche Neuerungen gegenüber Windows 98 und Windows 2000 stellt die Systemwiederherstellung dar. Automatisch oder manuell können Wiederherstellungspunkte des Windows-Systems angelegt werden. Gerade vor größeren Änderungen am System oder vor der Installation eines neuen Programms machen diese Sinn. Ein übersichtlicher Assistent erlaubt das Wiederherstellen von zuvor gesicherten Zuständen. Das Konzept belegt natürlich entsprechend Festplattenspeicher. Zudem wird nur die Windows-Umgebung und nicht die gesamte Festplatte überwacht.

Programme wie Second Change 2.0 von Powerquest sind hierbei konsequenter und benötigen im Gegensatz zum Microsoft-Pendant kein lauffähiges System, da die Wiederherstellung hier unter DOS erfolgt. Dennoch schützt die neue Windows-Funktion vor fehlerhaften Installationen oder eignet sich zum gefahrenlosen Testen von Software, da alle Veränderungen an Windows rückgängig gemacht werden können.

Wie auch Windows 2000, kann Windows ME das System in den Ruhezustand versetzen. Dazu wird ein aktuelles Speicherabbild auf die Festplatte gespeichert und der PC heruntergefahren. Beim erneuten Einschalten lädt das System nur die zuvor gespeicherte Datei und stellt die gesicherte Umgebung wieder her. So weit in der Theorie. Unter Windows ME ist dazu jedoch APM oder ACPI erforderlich. Ob hier alle BIOSs der Motherboards mitspielen, darf anhand der bisherigen Erfahrungen in Frage gestellt werden.

Versteckte DOS

Wie oben schon erwähnt, nutzt auch Windows ME die bisherige Windows Architektur aus DOS -, 16- und 32-Bit-Code. Allerdings hat Microsoft ein direktes Starten des DOS -Modus über das Boot- und Startmenü unterbunden. Wer auf eine exklusive DOS -Umgebung angewiesen ist, muss dies über eine Bootdiskette realisieren. Es bleibt abzuwarten, ob Microsoft dieses Versteckspiel auch in der Endversion beibehält.

Schneller?

Nach Angaben von Microsoft soll Windows ME durch Modifkationen an der Registry wesentlich schneller hochfahren. Nach Messungen der c't (Ausgabe 16/00, Seite 119) beläuft sich der Geschwindigkeitsvorteil beim Hochfahren gegenüber Windows 98 SE im besten Fall auf 2 Sekunden. Auch die sonstige Performance von Windows ME ist nicht berauschend. Mit Hilfe der BAPCo SYSMark 2000 wurden Messungen mit 64 und 128 MB RAM durchgeführt und diese mit Windows 98 SE und Windows 2000 verglichen:

CPU | 64 MB | 128 MB
AMD K6-2 550 MHz | Windows 98SE: 74 | Windows 98SE: 79
 | Windows ME: 71 | Windows ME: 76
 | Windows 2000: 60 | Windows 2000: 78
Celeron 266 MHz | Windows 98SE: 44 | Windows 98SE: 47
 | Windows ME: 42 | Windows ME: 44
 | Windows 2000: 42 | Windows 2000: 48
PIII 450 MHz | Windows 98SE: 91 | Windows 98SE: 100
 | Windows ME: 86 | Windows ME: 94
 | Windows 2000: 81 | Windows 2000: 101
PIII 800 MHz | Windows 98SE: 144 | Windows 98SE: 163
 | Windows ME: 132 | Windows ME: 152
 | Windows 2000: 114 | Windows 2000: 161

Bei Spielebenchmarks hingegen liegt Windows ME gegenüber Windows 98 und vor allem Windows 2000 etwas vorn.

Windows ME belegt auch mächtig mehr Platz auf der Festplatte: Ca 500 MByte verbraucht das neue OS in der Standardinstallation (Windows 98 SE 220 MByte, Win2k 850 MByte).

Erste Probleme

Betrachtet man die Reaktionen in den Newsgroups und Berichte aktueller US-Magazine, welche bereits über eine englische Final verfügen, dann kann man feststellen, dass Windows ME eigentlich noch gar nicht ausgeliefert werden dürfte. Beispielsweise sind der integrierte IE 5.5 und MediaPlayer nicht mit den jetzigen Downloadfassungen identisch und auf dem Stand der letzten Beta-Version. Auch der Outlook Express 5.5 zeigt als Eigenart, dass er für jede gelesene Nachricht in Newsgroups eine Temp-Datei im Internet-Cache anlegt und diese nicht mehr löscht. Beta-Tester ärgerten sich darüber, dass Microsoft trotz vieler negativer Rückmeldungen die dt. RC1 als fertig erklärte. Dazu kommen massive Probleme mit diversen Treibern.

Windows ME für wen?

Windows ME ist eine Weiterentwicklung von Windows 98, aber kein neues System. Bekannte Fehler wurden behoben und das System modernisiert. Allerdings ist Windows ME gegenüber dem Vorgänger nicht merklich schneller, benötigt dafür aber wesentlich mehr Platz auf der Festplatte. Ob die Neuerungen ein Update rechtfertigen, soll jeder selbst entscheiden.

Den Internet-Explorer 5.5 und Media-Player 7 gibt es auch kostenlos aus dem Web bei Microsoft und die Systemwiederherstellung übernehmen Fremdprodukte wesentlich umfangreicher. Zudem bietet Windows 2000 schon vieles von dem jetzt, was Windows ME erst für das "kleine" Windows bereithält.

Wer sein PC vorwiegend zum Spielen nutzt oder an sein System keine größere Anforderungen stellt, ist mit Windows ME sicherlich besser bedient als mit Windows 2000, da die meisten Grafikkartentreiber für Windows 2000 leistungsmäßig noch immer Beta-Stadium haben und Windows 2000 etwas Erfahrung erfordert. In allen anderen Fällen ist Windows 2000 aber sicher die bessere Wahl und das modernere System in Sachen Stabilität und Sicherheit.

Es wird sich zeigen, ob Microsoft seine Versprechungen mit "Whistler" wahr macht und mit dem nächsten Windows ein "NT-Light" für den Massenmarkt anbietet. Die Zeit dafür ist mehr als reif. So bleibt nur eine kosmetische Überarbeitung von alt bewährtem 16- und 32-Bit-Code in neuem Gewand ohne echte Innovationen.

Weitere Quellen:

c't-Test zu Windows ME (29.07.00)

ActiveWin-Test von Windows ME englisch

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0975.htm


Warnmeldung des Systemdateienschutzes aktivieren

Der Systemdateienschutz überwacht (und verhindert ggf.) das Löschen und Überschreiben von Systemdateien.

Die Aktivität dieser Funktion wird in der Datei sfplog.txt im Ordner "windows\system\sfp" protokolliert. Man kann die Funktion aber auch mit einer aktiven Warnmeldung versehen, indem man in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ SystemFileProtection

den Wert "ShowPopup" auf 1 setzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0986.htm


Systemwiederherstellung deaktivieren

Die Systemwiederherstellung kann beim Installieren nicht abgewählt werden, lässt sich nachträglich aber deaktivieren, indem man unter
"Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Dateisystem" -> "Problembehandlung" die Funktion "Systemwiederherstellung deaktivieren" einschaltet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0984.htm


Systemwiederherstellung benutzen

Mit der Systemwiederherstellung kann man gesicherte Systemzustände wieder herstellen.

Bei der Installation von Treibern usw. legt Windows automatisch solche Wiederherstellungspunkte an. Die Systemwiederherstellung können Sie über "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Systemwiederherstellung" starten und dann einen neuen Sicherungspunkt anlegen bzw. einen alten Zustand wiederherstellen.

Wenn aber durch einen fehlerhaften Treiber die grafische Oberfläche nicht mehr läuft, müssen Sie das Programm folgendermaßen aufrufen.

  1. Starten Sie Windows im "Safe Mode" mit der Kommandozeilenoberfläche
  2. Melden Sie sich als lokaler Administrator an
  3. Starten Sie das Programm folgendermaßen:
    %SYSTEMROOT%\System32\restore\rstrui.exe

Jetzt können Sie eine Sicherung wieder zurückspielen.

Das Programm rstrui.exe kennt folgende Parameter:

/b und /c | Datum des letzten Wiederherstellungsvorganges (sofern einer durchgeführt wurde)
/v | Systemwiederherstellung sofort starten (ohne Nachfrage)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1328.htm


Systemdateienschutz abschalten

Der Systemdateienschutz überwacht (und verhindert ggf.) das Löschen und Überschreiben von Systemdateien. Man kann diese Funktion aber außer Kraft setzen, indem man mit dem Programm Msconfig unter Autostart die Einträge PCHealth und StateMgr deaktiviert.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0985.htm


System File Protection deaktivieren

Unter ME und 2000 ist es nicht mehr so ohne Weiteres möglich, Systemdateien auszutauschen, wenn das SFP (System File Protection) Feature von Windows aktiv ist. Wenn Sie aber ältere Softwares installieren müssen, ist es oft erforderlich, diese Funktion auszuschalten.

Unter Windows ME

Hier können Sie die Funktion recht einfach ausschalten. Öffnen Sie dafür über "Start" -> "Ausführen" das Programm "MSCONFIG.EXE". Hier deaktivieren Sie nun unter der Registerkarte "Autostart" den Eintrag "*StateMgr" und starten Ihren Rechner neu.

Unter Windows 2000/XP

Methode 1

Wenn Windows 2000 im sog. Abgesicherten-Modus gestartet wird, ist das SFP automatisch für die aktuelle Session deaktiviert.

Methode 2

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

finden Sie den Wert "SFCDisable" als Datentyp REG_DOWRD. Um das SFP auszuschalten, ändern Sie den Wert von 0 auf FFFFFF9D.

Dieser Wert wird aber nur bis Windows 2000 SP1 ausgelesen. Wenn Sie Windows 2000 über SP1 oder gar Windows XP benutzen, müssen Sie vorher SFC.DLL anpassen.

Methode 1 zum aktivieren von SFCDisable

In der Datei müssen Sie mit einem Hex-Editor bearbeiten und die folgenden Werte ändern:

Windows | Dateiname | Offset (HEX-Adresse) | Wert
Windows 2000 SP2/SP3 | SFC.DLL | 6211 | 8BC6 durch 9090
Windows 2000 SP4 | SFC.DLL | 62DB | 8BC6 durch 9090
Windows XP | SFC_OS.DLL | E2B8 | 8BC6 durch 9090
Windows XP SP1 | SFC_OS.DLL | E3BB | 8BC6 durch 9090
Windows XP SP2 | SFC_OS.DLL | ECE9 | 33C0 durch EB01

Tauschen Sie die neue SFC.DLL im System32 und dllcache-Verzeichnis gegen die geänderte Version aus.

Für das Austauschen der Dateien müssen Sie Windows in der Wiederherstellungskonsole (über die CD) starten. Hier können Sie Datei austauschen, da Sie hier nicht überwacht wird. Mit den oberen Keys können Sie jetzt wieder SFC ausschalten.

Methode2 zum aktivieren von SFCDisable

Damit kann man die SFCDisable=ffffff9d Einstellung für alle Windows XP und Windows 2000 wieder aktivieren. Ohne den Offset für die aktuelle Version zu wissen zu müssen.

In der Datei sfc_os_dll nach "0x83 0xf8 0x9D 0x75" suchen und durch "0x83 0xf8 0x9D 0xEB" ersetzen.

Backgroundinfos :

Diese Zeile(PseudoCode) wurde von Microsoft als schneller Fix gegen die undokumentierte '-99' Einstellung eingefügt, als in Sommer 2002 der "W32/CodeRed.D" die Runde machte und diese Einstellung für sich missbrauchte.

Mögliche Werte für SFCDisable

Bei deaktiviertem SFP wird bei jedem Systemstart folgende Meldung in der Ereignisanzeige angezeigt:

"Windows-Dateischutz ist auf diesem Computer nicht aktiviert." mit der ID: 64032.

Mögliche Werte für SFCDisable

0 | aktiviert (ist Standard bei Professional)
1 | deaktiviert, mit Rückfrage zur Aktivierung beim Neustart (nur für den Debug-Modus)
2 | deaktiviert bis zum nächsten Booten, ohne Rückfrage zur Aktivierung (nur für den Debug-Modus)
4 | aktiviert, Popups deaktiviert (Standard auf Server, Advanced Server und Datacenter Server)
FFFFFF9D | komplett ausgeschaltet (nur ohne Service Pack oder mit geänderter Datei)

Ab Windows Vista

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

finden Sie den Wert "SFCDisable" als Datentyp REG_DOWRD. Um das SFP auszuschalten ändern Sie den Wert von 0 auf FFFFFF9D.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen dazu finden Sie unter:
http://support.microsoft.com/?kbid=222473

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0504.htm


Internen Packer installieren/deinstallieren

Bei der Standardinstallation von Windows ME wird der integrierte Packer für ZIP-Dateien leider nicht mit installiert. Über den Weg "Systemsteuerung" -> "Software" -> "Windows Setup" unter Komponenten wählt man "Systemprogramme" und geht auf "Details". Hier aktiviert man "Komprimierte Ordner".

Nach einem Neustart werden ZIP-Dateien mit einem Reißverschluss angezeigt und können auch über das Kontextmenü entpackt oder gepackt werden.

Ab Windows XP ist diese Funktion standardmäßig immer installiert. So werden die Archive hier jetzt immer im Explorer dargestellt. Bei nicht so schnellen Rechnern kann diese Funktion aber stören, da die Geschwindigkeit damit sehr gebremst wird. Um diese Funktion auszuschalten, geben Sie in der Eingabeaufforderung (bzw. Startentart -> Ausführen) folgendes ein:

Funktion ausschalten

regsvr32 /u zipfldr.dll

Funktion einschalten

regsvr32 zipfldr.dll

Info Durch das ausschalten der Funktion wird auch der Eintrag "ZIP-komprimierten Ordner" aus dem Kontextmenü "Senden an" entfernt.

Info Ist die Funktion aktiv, werden bei der Suche auch die ZIP-Datei durchsucht. Wird die Integration ausgeschaltet, kann Windows die ZIP-Dateien nicht mehr öffnen und damit auch nicht mehr durchsuchen. Dadurch wird die Suche bei vielen ZIP-Dateien natürlich auch wieder schneller.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1063.htm


Größe des Caches der Wiederherstellung vergrößern

Die Systemwiederherstellung benötigt mindestens 200 MB freien Festplattenspeicher. Dieser kann jedoch unter der "Systemsteuerung" -> "System" -> "Leistungsmerkeinmale" -> "Dateisystem" -> "Festplatte" vergrößert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0983.htm


Die 'digitale Treibersignatur' für Gerätetreiber

Unter Windows müssen alle Treiber von Microsoft signiert sein, damit sie installiert werden können. Dadurch will MS vermeiden, dass durch schlecht programmierte Treiber die Stabilität des Systems beeinträchtigt wird.

Sie können die Einstellung über den herkömmlichen Weg ändern:

Gehen Sie dazu unter "Einstellungen" -> "Systemsteuerung" -> "System" auf den Tabreiter "Hardware" und wählen Sie im Bereich "Geräte-Manager" die Schaltfläche "Treibersignierung" aus. Hier können Sie nun folgendes einstellen:

Einstellung | Funktion | Policy (s. u.)
Ignorieren | Es werden keine Warnungen ausgegeben | 00 00 00 00
Warnen | Bei nicht signierten Treibern warnen | 01 00 00 00
Sperren | Die Installation von nicht signierten Treibern wird nicht zugelassen | 02 00 00 00

Sie können diese Einstellungen aber auch direkt in der Registry verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

(nur bei Windows 2000)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Non-Driver Signing

(alle anderen Betriebssysteme)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Driver Signing

Mit diesem Wert "Policy" als Datentyp REG_BINARY

00 00 00 00 | Installiert alle Treiber ohne Meldung
01 00 00 00 | Warnt bei der Installation
02 00 00 00 | Lässt die Installation nicht zu.

Info Siehe dazu auch Tipp: "Sicherheit der Treibersignierung vorgeben"
"Warnhinweis bei Treibern ohne digitaler Signatur"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=298503

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0824.htm


Backup-Software nachträglich installieren

Auf den ersten Blick besitzt Windows ME kein Microsoft Backup mehr. Aber es ist auf der Windows ME CD im Ordner "\Add-ons\msbackup" versteckt.

Dort befinden sich zwei Dateien: BACKUP.TXT und MSBEXP.EXE. Das Programm ist eine Lizenzversion des professionellen Backup-Programms "Seagate Backup Exec". Es ist leicht zu bedienen und auch für Profis geeignet.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1086.htm


Automatischen Systemreport erstellen

Unter Windows 2000 so wie Windows ME besitzt das Tool MSINFO32 diverse Startparameter (msinfo32 /?).

Einen kompletten Systemreport, welcher alle systemrelevanten Informationen beinhaltet, lässt sich beispielsweise mit dem Startbefehl:

msinfo32 /report c:\report.txt

im Hintergrund erstellen (Msinfo32 ist während der Erstellung des Reports nicht sichtbar).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1083.htm


Automatischen Download von Updates unterbinden

Die Funktion "Automatisches Update" in der Systemsteuerung sucht bei aktiver Internetverbindung in einem Zeitabstand von 24 Stunden nach Updates und holt diese automatisch aus dem Internet auf die heimische Festplatte. Erst wenn diese "offline" verfügbar ist, fragt Windows ME nach, ob das Update installiert werden soll.

In der Systemsteuerung lässt sich das Verhalten konfigurieren:

  1. Sie können das automatische Update komplett deaktivieren (Windows überprüft dann nicht mehr automatisch, ob neue Updates im Internet vorliegen).
  2. Sie können einstellen, dass Windows zwar prüft ob ein neues Update zur Verfügung steht, aber vor dem Herunterladen der Daten nachfragt, ob das Update überhaupt erwünscht ist.

Zumindest die zweite Option ist bei den meisten Anwendern sinnvoll. Unnötige Downloads werden so vermieden, wenn von vornherein nicht geplant ist, alle Updates von MS installieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1100.htm


Anderes Betriebssystem aus Bootmanager starten (Linux/DOS usw.)

Um ein anderes Betriebssystem (hier als Beispiel "Linux") in den NT-Bootmanager Eintragen zu können, müssen Sie den Boot-Sector als Datei auf die Festplatte schreiben. Dies können Sie auf folgende Weise tun:

  1. NT installieren
    LILO in die Linux Root-Partition installieren. Die BOOT-Partition muss auf dem primären IDE-Port liegen und sich innerhalb der ersten 1024 Zylinder befinden, sonst bootet Linux nicht.
    Info Nicht in den MBR installieren, da hier NT liegt!
  2. Bootblock auf eine Platte kopieren, die von Windows NT gelesen werden kann.
    (z.B.: dd if=/dev/xx bs=512 count=1 of=/DOS c/bootsect.lin)
    xx => entspricht der Linuxplatte
    DOS c => Gemountete DOS -Platte C:

Nun erstellen Sie einen zusätzlichen Eintrag in der BOOT.INI

Beispiel:

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(2)\WINNT40

[operating system]

multi(0)disk(0)rdisk(0)partition(2)\WINNT40="Windows NT Server, Version 4.0"

multi(0)disk(0)rdisk(0)partition(2)\WINNT40="Windows NT Server, Version 4.0 [VGA-Modus]" /basevideo

C:\BOOTSECT.DOS ="MS-DOS "

C:\BOOTSECT.LIN="Linux starten"

Sollte sich bei der Installation von Windows schon DOS auf der Festplatte befund en haben, hat das Setup von Windows einen Eintrag zum Laden von DOS eingefügt. Windows hat dort aber nicht die zu ladende Datei "BOOTSECT.DOS " mit angegeben, da diese beim Starten automatisch gesucht wird. Das muss nun wie oben angegeben abgeändert werden.

Info Auf diese Weise können Sie auch weitere DOS -Versionen hinzufügen, Sie müssen nur die jeweiligen Boot-Sectoren auslesen (mit Disk-Editor) und in eine Datei schreiben. Siehe auch "Windows 95/98 und NT gemeinsam installieren"

Info Mit den Tool BootPart (http://www.winimage.com/bootpart.htm) können Sie den Bootsektor sicher. Mit diesem Programm können Sie auch den Bootsektor wieder herstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0422.htm


Informationen über die BOOT.INI

Die BOOT.INI bestimmt, welches Betriebssystem gestartet wird. Diese Datei befindet sich auf der Startpartition im Hauptverzeichnis und ist versteckt. "Explorer" -> "Erweitert" -> "Ordneroptionen" -> "Ansicht" -> alle Dateien anzeigen und das Häkchen bei "geschützte Systemdateien ausblenden" entfernen.

Aufbau der BOOT.INI

Einträge in der Datei | Beschreibung
[boot loader] | Diese Sektion enthält die Einstellungen für das Verhalten des Bootmenüs. Ist die Sektion nicht vorhanden, wird automatisch der erste Eintrag unter [operating systems] gestartet.
timeout=30 | Wartezeit in Sekunden bis zum automatischen Start. In dieser Zeit wird das Bootmenü angezeigt und es kann eine Auswahl getroffen werden, welches Betriebssystem geladen werden soll. Info: Wenn Sie den Wert auf -1 setzen, wird das Bootmenü solange angezeigt, bis eine Auswahl getroffen wurde. Wird diese Einstellung unter Windows betrachtet, wird der Wert automatisch wieder zurückgesetzt, da die GUI nicht mit -1 zurechtkommt.
default=multi(0)disk(0)rdisk(0)partition(2)\WINNT40 | Betriebssystem, das automatisch gestartet werden soll, wenn die Wartezeit "timeout" abgelaufen ist. Muss mit dem entsprechenden Eintrag aus [operating systems] übereinstimmen.
[operating systems] | Diese Sektion enthält die Einträge für das Bootmenü. Es muss mindestens 1 Eintrag vorhanden sein, damit Windows gestartet werden kann. Wenn diese Sektion nicht vorhanden ist, kann Windows nicht gestartet werden. Erst mal ein paar Beispiele, die anschließend genauer beschrieben werden.
multi(0)disk(0)rdisk(0)partition(2)\WINNT40="Windows NT Server, Version 4.0" | Booteintrag ohne weitere Parameter.
multi(0)disk(0)rdisk(0)partition(2)\WINNT40="Windows NT Server, Version 4.0 [VGA-Modus]" /basevideo | Booteintrag mit einem Parameter /basevideo
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /fastdetect signature(8b467c12)disk(1)rdisk(0)partition(2)\winnt="Windows 2000" | Beispielbooteintrag von Windows 2000
C:\="MS-DOS " | Beispielseintrag um ein anderes Betriebssystem zu starten. Damit kann man über Windows das alte MS-DOS starten.

Aufbau der Booteinträge (ARC-Namen)

Die Pfade werden in der BOOT.INI in der ARC-Namenskonvention (Advanced RISC Computing) angegeben.

Dabei gibt es 3 gültige Formate:

  • multi(<Zahl>)disk(<Zahl>)rdisk(<Zahl>)partition(<Zahl>)\ %systemroot%="Beschreibung" /<Parameter>
  • scsi(<Zahl>)disk(<Zahl>)rdisk(<Zahl>)partition(<Zahl>)\ %systemroot%="Beschreibung" /<Parameter>
  • signature(<Zahl>)disk(<Zahl>)rdisk(<Zahl>)partition(<Zahl>)\ %systemroot%="Beschreibung" /<Parameter>

Mit diesem Werten wird festgelegt, von welcher Platte und Partition das Betriebssystem gestartet werden soll:

ARC-Parameter: Beschreibung
multi(<Zahl>)

Festplatten bzw. SCSI-Controller mit BIOS

Wird benutzt, wenn der NTLDR die Systemdateien über das System-BIOS laden kann. Dazu wird der Interrupt 13 verwendet. Wird für alle Rechner benutzt, die ATA und SCSI-Datenträger über Interrupt 13 ansprechen können.

<Zahl>: Nummer des Controllers bei 0 angefangen
scsi(<Zahl>)

SCSI-Controller ohne BIOS

Wird benutzt, wenn der NTLDR nicht über den Interrupt 13 die Dateien laden kann, da das vom Controller nicht unterstützt wird. Der NTLDR benutzt dann zum Laden der Dateien die Datei NTBOOTDD.SYS. Die NTBOOTDD.SYS ist eine Kopie der Treiberdatei des Controllers und kann sich deshalb zwischen den Systemen unterscheiden.

<Zahl>: Nummer des SCSI-Controllers bei 0 angefangen
disk(<Zahl>)

Nummer des SCSI-Busses

<Zahl>:

Bei multi immer 0

Bei scsi: Nummer der Platte am Controller bei 0 angefangen
rdisk(<Zahl>)

Nummer der entsprechenden Festplatte

<Zahl>:

Bei multi: Nummer der Platte bei 0 angefangen. (0 und 1 jeweils für die primären Platten am Master/Slave Port, 2 und 3 jeweils für die sekundären Platten am Master/Slave Port)

Bei scsi liegen die Werte zwischen 0 und 15 (je nach Controller)
partition(<Zahl>)

Nummer der Partition, auf der sich das Betriebssystem befindet. Die Zählung beginnt bei "1".

<Zahl>: Nummer der Partition angefangen bei 1
signature(<Zahl>)

Ab Windows 2000

Dieser Parameter wird nur in einigen Ausnahmefällen hinzugefügt. Er kommt z.B. vor, wenn zusätzliche Laufwerkscontroller hinzugefügt wurden. Der Wert gibt damit den Controller an (Datenträgersignatur), wo die Daten zu finden sind. Diese Datenträgersignatur, kurz GUID (Globally Unique Identifier), wird von Windows bei der Installation erstellt und auf dem Datenträger geschrieben. Anhand dieser 128-Bit Hexadezimalzahl kann der Datenträger eindeutig erkannt werden.

Bei der Auswertung werden aber nur die ersten 32-Bit der GUID von Windows verwendet, wenn eine der folgenden Bedingungen zutrifft:

  • Die Partition, auf der Sie Windows installiert haben, ist größer als ~ 7,8 GByte oder der Startzylinder liegt über 1024, so dass für das Booten die BIOS Funktion INT13 nicht benutzt werden kann.
  • Sie haben Windows auf einer SCSI-Festplatte installiert, die an einem SCSI-Controller hängt, dessen BIOS ausgeschaltet wurde. Auch hier kann die BIOS Funktion INT13 nicht zum Booten benutzt werden.

Info Durch das Booten über eine Signature, wird der Windows Start erheblich verlangsamt.

Weiterhin ist noch erlaubt eine Datei zum Booten anzugeben. Diese Datei enthält einen gespeicherten Bootsektor, welcher von Windows in den Speicher geladen wird und der Startvorgang wird dann über diese Datei ausgeführt. Mit dieser Möglichkeit können auch andere Betriebsysteme über Windows gestartet werden (Linux, MSDOS usw.)

Beispiele:

  • C:\="MS-DOS"
  • C:\Boot.deb="Linux 3.x"

Wird wie im ersten Beispiel keine Datei angegeben, sucht der Loader nach der Datei "BOOTSECT.DOS", welche den Bootsektor enthalten muss.

Die Parameter in der BOOT.INI

Hier finden Sie die Aufstellung aller gültigen Parameter, welche Sie hinter dem Aufruf verwenden können. Viele der Parameter können kombiniert werden und müssen durch ein Leerzeichen getrennt angegeben werden.

Parameter | Beschreibung
/BASEVIDEO | System verwendet den Standard VGA-Treiber mit einer Auflösung von 640 x 480 und 16 Farben.
/CRASHDEBUG | Lädt den Kerneldebugger beim Start und führt weiters zur automatischen Wiederherstellung des Systems
/NOSERIALMICE

Deaktiviert die Erkennung einer seriellen Maus an der oder den angegebenen Schnittstellen. Diese Einstellung wird verwendet, wenn Windows eine Komponente an dieser Schnittstelle wie z.B. ein Modem für eine Maus hält.

Angabe: [COMx oder COMx,y,z]

(MS Q131976)

/DEBUG

Optional (nur mit /DEBUG)

/BAUDRATE=

/DEBUGPORT=

/CHANNEL=

Ein externer (Kernel-)Debugger ist generell "aktiv". Windows lässt sich von dort aus unterbrechen.

Optionale Parameter

/BAUDRATE=<Port>

Dieser Parameter gibt die Baudrate an, die für das Kerneldebugging verwendet wird. In der Regel 9600 KBit/sec für Modems und bis zu 115.200 Kbit/s bei 1394 (Firewire):

/DEBUGPORT=COMx

Bestimmt den COM-Anschluss für das Kerneldebugging, in der Regel COM1, COM2 oder 1394.

/CHANNEL=<Zahl>

Gibt den Übertragungskanal der 1394-Schnittstelle (Firewire) an. Gültige Werte liegen zwischen 0 bis 62.
/NODEBUG | Dadurch werden keine DEBUG-Informationen überwacht. Da das Überwachen sehr aufwändig ist und nur für Entwickler von Bedeutung ist, kann man damit das System schneller machen
/MAXMEM=n | Gibt an, wie viel Hauptspeicher Windows max. verwenden soll
/SOS | Zeigt die Treiber an, die während des Startens von Windows geladen werden. Das bedeutet nicht, dass diese Treiber auch unbedingt von Windows gestartet werden.
/SCSIORDINAL:n | Wird verwendet, um zwei identische SCSI-Controller voneinander zu unterscheiden. Der Wert sollte beim zweiten SCSI-Controller auf 1 gesetzt werden (MS Q103625)

/WIN95

/WIN95DOS

Nur sinnvoll bei einer Parallelinstallation von DOS, Windows 95 und Windows NT. Ermöglicht die Auswahl des zu ladenden Betriebssystems aus dem Windows-Loader heraus. Der Loader übernimmt dann das Umbenennen der DOS-Dateien (Io.sys, MsDOS.sys, Command.com, Config.sys und Autoexec.bat), was ansonsten Windows 95 übernimmt, wenn beim Starten F4 oder F8 gedrückt wird.

Beispiel:

C:\BOOTSECT.W95="Microsoft Windows 95" /WIN95

C:\BOOTSECT.W95="MS DOS 6.22" /WIN95DOS multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation 4.0"

(MS Q157992)

/WIN95

Sind Startdateien mit der Dateiendung .W40 vorhanden (io.w40, msdos.w40, config.w40, autoexec.w40), so werden die aktuell vorhandenen DOS-Startdateien (io.sys, msdos.sys, config.sys, autoexec.bat) in .DOS umbenannt und jene mit .w40 am Ende in .sys bzw. .bat.

/WIN95DOS

Sind Startdateien mit der Dateiendung .DOS vorhanden (io.dos msdos.dos config.dos autoexec.dos) so werden die Aktuell vorhandenen Startdateien (io.sys msdos.sys config.sys autoexec.bat) in .W40 umbenannt und die mit .dos am Ende in .sys und .bat.
/ONECPU | Startet Mehrprozessorsysteme mit EINER CPU, alle anderen werden ignoriert
/NUMPROC= | Startet Windows mit der angegebenen Zahl von Prozessoren. (Bei einem 4 Prozessor System würde Windows bei /NUMPROC=2 nur mit 2 Prozessoren arbeiten.)
/3GB

Hiermit ändern Sie das Verhältnis zwischen der Trennung von USER und SYSTEM Speicher für die virtuelle Adressenverwaltung. Standardmäßig wird 2 GByte für den USER und 2 GByte für das SYSTEM reserviert. Durch Setzen dieses Schalters werden nun für den USER 3 GByte und für das SYSTEM nur noch 1 GByte Speicher reserviert, diese Einstellung kann bei einigen Programmen zu Geschwindigkeitsvorteilen führen z.B. bei Datenbanken. Allerdings muss die Software mit dem Flag LargeAddressAware übersetzt und gelinkt werden, um das zusätzliche GByte nutzen zu können. Damit Anwendungen diesen Speicher auch nutzen können, muss es sich jedoch um:

  • Enterprise-Version von Windows NT (ab Service Pack 3)
  • Windows 2000 Advanced Server und Datacenter Server
  • Alle 32-Bit .NET Server

handeln.
Bei allen anderen Servern bewirken Sie mit diesem Schalter das Gegenteil. Für das System wird dann nur 1 GByte benutzt, die Anwendungen können aber auch nur 2 GByte adressieren, so dass 1 GByte nicht benutzt wird.

(MS Q171793)
(MS Q328882)

Info Bei 64-Bit-Versionen von Windows benötigen Sie diesen Schalter überhaupt nicht, da Windows automatisch sämtlichen Speicher sieht und Applikationen per Default vier GByte Usermode-Speicher erhalten.
/CLKLVL | Der Multiprozessor x86 (HALMPS.DLL) wird für eine gepufferte Systemuhr konfiguriert
/BREAK

Damit wird eingestellt, dass die HAL an einem bestimmten "Breakpoint" beim Laden stehen bleibt. Windows wartet nun an diesem Punkt, bis eine Debugging-Verbindung hergestellt wurde und setzt dann den Start weiter fort.

Info Wird diese Option ohne den Schalter /DEBUG verwendet, bleibt Windows mit einem "BLUE Screen" (STOP 0x00000078 PHASE0_EXCEPTION) stehen.
/BURNMEMORY= | Mit diesem Wert (in MByte) wird angegeben, wie viel Speicher Windows nicht beachten soll, wohingegen der Schalter /MAXMEM den zu verwendenden Speicher angibt. Bei der Angabe von /BURNMEMORY=84 würde Windows 84 MB vom gesamten Arbeitsspeicher als unbrauchbar weglassen.

/KERNEL=

/HAL=

Mit diesem Schalter stellen Sie ein, dass im NTLDR die Dateien für NTOSKRNL.EXE und HAL.DLL aus dem System Root (WINNT\SYSTEM32) durch die jeweiligen Image Dateien ersetzt werden. Dieser Parameter ist nützlich, um zwischen einer überprüften Kernelumgebung und einer Probe-Kernelumgebung umschalten zu können. Es gibt von MS einige Debugging Dateien, die an bestimmte Leute weitergegeben werden. Mit diesen Dateien müssen Sie folgendes machen:

  • Kopieren Sie die Debugging Kernel-Version in Ihr WINNT\SYSTEM32 Verzeichnis. Geben Sie Ihr den Namen NTOSKCHK.EXE. Bei Rechnern mit einem Prozessor benötigen Sie die Datei mit dem Namen NTOSKRNL.EXE, ansonsten NTKRNLMP.EXE für Multiprozessor-Maschinen.
  • Kopieren Sie die Debugging HAL-Version in Ihr WINNT\SYSTEM32 Verzeichnis. Geben Sie Ihr den Namen HALCHK.DLL. Um zu wissen, welche HAL-Datei Sie dafür verwenden müssen, öffnen Sie die Logdatei "Setup.log" aus dem Windows-Verzeichnis und suchen nach dem Eintrag "\WINNTF\system32\hal.dll=[Dateiname]. Erätzen Sie [Dateiname] durch die für Ihr System benötigte HAL-Datei.
  • In der BOOT.INI sollten Sie nun einfach einen bestehenden Boot-Eintrag kopieren und folgenden zusätzlichen Parameter am Ende anfügen: /KERNEL=NTOSKCHK.EXE /HAL=HALCHK.DLL (den Namen aus dem Bootmenü sollten Sie zur besseren Übersicht auch ändern).

Auf der Windows CD finden Sie im I386-Verzeichnis folgende HAL-Dateien:

Name | Beschreibung
HALMACPI.DL_ | Multiprozessor-PC, mit ACPI
HAL.DL_ | Standard-PC, kein ACPI, kein APIC
HALACPI.DL_ | ACPI PC, kein APIC
HALAPIC.DL_ | Standard-PC, kein APCI, mit APIC
HALAAPIC.DL_ | Standard-PC, mit ACPI, mit APIC
HALMPS.DL_ | Multiprozessor-PC, ohne ACPI

APIC steht für Advanced Programmable Interrupt Controller. Dieser Interrupt-Controller dient zum Steuern von Interrupts in einem Multiprozessor-System.

Auf der Windows CD finden Sie im I386-Verzeichnis folgende KERNEL-Dateien:

Name | Beschreibung
ntoskrnl.ex_ | Standard-Single-Prozessor-Kernel
ntkrnlmp.ex_ | Multi-Prozessor-Kernel
ntkrnlpa.ex_ | Single-Prozessor-Kernel mit PAE-Unterstützung
ntkrpamp.ex_ | Multi-Prozessor-Kernel mit PAE-Unterstützung

Info Während der Installation von Windows wird die jeweils für das System notwendige DLL unter dem Namen hal.dll beziehungsweise ntoskrnl.exe in das System32-Verzeichnis von Windows kopiert.
/PCILOCK

Windows versucht, keine eigenen Einstellungen (dynamische Zuordnung von PCI-Geräten I/O- und IRQ-Ressourcen) zu ermitteln, sondern benutzt die Werte, die im BIOS eingestellt sind. Dadurch sind meist weniger freie Ressourcen verfügbar, weshalb dieser Parameter nur bei Problemen benutzt werden sollte.

(MS Q148501)

/USE8254 | Für Rechner mit altem BIOS. Windows benutzt nun den 8254 Timer Chip. (MS Q169901)
/YEAR= Windows benutzt nicht mehr das Datum, welches im BIOS des Rechners angegeben ist, sondern fährt den Kernel mit den angegebenen Datum hoch. Ist für den Jahr 2000 Test gedacht.

(Windows NT ab Service Pack 4)
/MININT | Dieser Parameter wird von Windows PE (Preinstallation Environment) benutzt. Dadurch wird die Registry SYSTEM als ein löschbarer HIVE-KEY geladen, damit durchgeführte Änderungen nicht wieder zurückgeschrieben werden.
/LASTKNOWGOOD | Das System wird mit der letzten funktionierenden Konfiguration gestartet.

Info Die nachfolgenden Parameter sind erst ab Windows 2000 gültig
/FASTDETECT

Bei einer Installation von Windows NT 4.0 und Windows 2000 wird eine unterschiedliche Arbeitsweise von NTDETECT verlangt. Bei Windows NT 4.0 wurde die Erkennung von parallelen und seriellen Ports noch durch NTDETECT durchgeführt, ab Windows 2000 gibt es dafür einen speziellen Plug und Play Treiber, der dafür verantwortlich ist. Wird dieser Schalter gesetzt, wird die Erkennung über NTDETECT ausgeschaltet.

Wird nur "/FASTDETECT" verwendet, wird es für alle COM-Ports ausgeschaltet. Durch das Angeben der COM-Ports können Sie diese Funktion auf bestimmte Ports beschränken:

/FASTDETECT COM1,3,4

Damit wird die Funktion nur für COM1, COM3 und COM4 ausgeschaltet. Nicht aber für COM2 und weitere Ports nach COM4.
/SAFEBOOT:

Diesen Schalter sollten Sie nicht selber setzen. Wenn Sie die Taste F8 beim Booten drücken, werden diese Schalter automatisch von Windows gesetzt.

Nach dem Doppelpunkt erfolgt die Angabe, in welchen Modus Windows Booten soll: Bei der Angabe von Minimal wird Windows nur mit den minimalen Treibern gestartet, die im Registry Key unter "HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SafeBoot" angegeben sind. (Je nach Option dort unter dem Zweig "Minimal" oder "Network").

Bei der Angabe von NETWORK wird Windows wie Minimal gestartet, halt nur aus dem Zweig Network für die Netzwerkunterstützung. Durch DSREPAIR wird veranlasst, dass Windows das aktuelle Verzeichnis von einem Backup wieder herstellt.

Mit dem zusätzlichen Schalter (ALTERNATESHELL) können Sie angeben, dass die unter "HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ SafeBoot\ AlternateShell" angegebene grafische Benutzeroberfläche anstatt des Explorer geladen wird:

Beispiele:

  • /SAFEBOOT:MINIMAL
  • /SAFEBOOT:NETWORK(ALTERNATESHELL)
/INTAFFINITY | Durch diese Angabe wird bestimmt, dass bei Multiprozessoren (HALMPS.DLL) nur noch der höchste nummerierte Prozessor in einem SMP die Interrupts erhält. Normalerweise erhalten immer alle Prozessoren die Interrupts.
/MAXPROCSPERCLUSTER= | Hiermit stellen Sie die max. zu benutzenden Prozessoren in einem Cluster ein. Das bedeutet, wenn Sie eine 8 Prozessormaschine benutzen und die in 2 Clustern mit jeweils 4 Prozessoren aufgeteilt haben, würden bei der Angabe von /MAXPROCSPERCLUSTER=2 nur jeweils 2 Prozessoren im Cluster verwendet werden.
/TIMERES=

Bei einem Multiprozessorsystem (HALMPS.DLL) setzt diese Option das Verhältnis des Systemtimers. Der von Ihnen angegebene Wert wird auf einen unterstützten Wert aufgerundet. Die Angabe erfolgt in 100 Nanosekunden. Standardmäßig benutzt Windows den Wert 7.8

Mögliche Werte sind:

9766 ->.98

19532 -> 2.0

39063 -> 3.9

78125 -> 7.8

Wenn Sie also angeben /TIMERES=19000, wird Windows einen Wert von 2.0 benutzen.
/BOOTLOG | Wenn Sie diesen Schalter setzen, wird Windows unter %SYSTEMROOT% eine Datei "NTBTLOG.TXT" anlegen. In dieser Datei führt Windows ein Log mit allen Informationen (Treiber die geladen wurden und dabei aufgetretene Fehler) die beim Starten von Windows anfallen.
/CMDCONS

Die Wiederherstellungskonsole wird von der Festplatte gestartet (siehe dazu auch Tipp: Wiederherstellungskonsole ins Bootmenü aufnehmen).

Der Wert ist nicht bei ARC-Pfaden gültig, sondern benötigt die Angabe einer Bootsektor Datei:

C:\WDH\bootsect.dat="Wiederherstellungskonsole" /CMDCONS

Benötigt wird:

  • Eine installierte Wiederherstellungskonsole (siehe Link oben)
  • Ein installiertes Windows

Info Die nachfolgenden Parameter sind erst ab Windows XP gültig
/BOOTLOGO

Hier können Sie ein eigenes Boot-Logo festlegen. Das Bild muss die Größe 640*480 mit 16 Farben haben. Dieses Bild müssen Sie im Windows Verzeichnis %SYSTEMROOT% mit den Namen BOOT.BMP angeben.

Der Parameter musst mit /noguiboot aktiviert werden.
/NOGUIBOOT | Wenn Sie diesen Schalter setzen, wird nicht mehr der Grafiktreiber geladen, der dafür notwendig ist, den Bootvorgang grafisch darzustellen. Dieser Treiber wird zur Anzeige des Bootvorgangs verwendet und um bei einem "Blue Screen" die Informationen auszudrucken.
/SDIBOOT= | Wird bei XP verwendet um das Windows von einem RAM-Disk Image zu booten (SDI -> System Disk Image)

/REDIRECT=

/REDIRECTBAUDRATE=

 Bewirkt, dass Windows den Emergency Management Service (EMS) verwendet und Bootinformationen an einen seriellen Port sendet. Geben Sie bei /REDIRECT= den Port und bei /REDIRECTBAUDRATE= die Baudrate an.
/RDPATH= | Gibt den Pfad zum System Disk Image (SDI) an, die auch auf einem Netzwerk abgelegt werden kann.

/PAE

/NOLOWMENM

Dadurch wird aktiviert, das NTLDR die Datei "NTKRNLPA.EXE" und nicht "NTOSKRNL.EXE" laden soll, wenn mehr als 4 GByte Speicher im System vorhanden ist. Diese Version des x86 Kernels ist in der Lage x86 PAEs zu benutzen.

/NOLOWMENM

Damit werden die untersten 4 GByte Speicher ausgeschaltet und ist erst bei Systemen mit mehr als 4 GByte Speichern sinnvoll.

Der Parameter ist ebenfalls notwendig, wenn Sie ein System mit NUMA-Architektur einsetzen. NUMA-Unterstützung finden Sie im Windows Server 2003.
/NOPAE | Auch bei Systemen mit mehr als 4 GByte Speicher wird die Datei "NTOSKRNL.EXE" und nicht "NTKRLNPA.EXE" geladen.

32-Bit Windows:

/NOEXECUTE

/EXECUTE

64-Bit-Windows nur:

/NOEXECUTE

Ab Service Pack 2 in XP vorhanden. Dabei handelt es sich um die Datenausführungsverhinderung (DEP)

  • /Execute:Datenausführungsverhinderung (DEP) für das gesamte System ausschalten. Kann zusätzlich für einzelne angegebene Anwendungen eingeschaltet werden
  • /NoExecute: Datenausführungsverhinderung (DEP) für das gesamte System einschalten. Es kann zusätzlich für einzelne angegebene Anwendungen ausgeschaltet werden
  • /NoExecute=OptIn: Es werden nur Systemdateien und Anwendungen überwacht, die in der OptIn-Liste stehen. Dadurch wird auch verhindert, dass Windows im "Abgesicherten Modus" starten kann.
  • /NoExecute=OptOut: Es werden die Systemdateien überwacht, außer die, welche in der OptOut-Liste aufgeführt sind.
  • /NoExecute=AlwaysOn: Die Datenausführungsverhinderung ist systemweit für alle ausführbaren Daten aktiv. Die Ausnahmelisten werden nicht ausgewertet.
  • /NoExecute=AlwaysOff: Die Datenausführungsverhinderung wird ausgeschaltet
/USERVA=

Mit diesem Parameter wird der Parameter /3GB noch genauer eingestellt. Sie geben mit diesem Parameter an, wie viel virtueller Adressbereich für Anwendungen bereitgestellt wird.

Sie können hier Werte zwischen 2048 und 3072 angeben.

Der Parameter wird nur im Zusammenhang mit /3GB ausgewertet.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
HOW TO: Edit the Boot.ini File in Windows 2000
http://support.microsoft.com/?kbid=311578
HOW TO Edit the Boot.ini File in Windows XP (Q289022):
http://support.microsoft.com/?kbid=289022

Info An Windows Vista gibt es die Boot.INI nicht mehr, hier werden die Daten in BCD-Store abgelegt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0408.htm


Versionsnummern von Windows NT/2000/XP/2003 und Vista

Versionsnummern von Windows NT/2000/XP/2003/Vista/2008 und Windows 7

Hier finden Sie eine Übersicht der Versionsnummern der Windows Version, die auf Datenträgern/Download verteilt wurden (viele dieser Versionen wurden nur an Tester rausgegeben).

Version: | Build:
Windows NT 3.5 | 3.5.807
Windows NT 3.51 | 3.51.1057
Windows NT 4.00 | 4.00.1381
Windows NT 5.00 (Beta 2) | 5.00.1515
Windows 2000 (Beta 3) 5.00 | 5.00.2031
Windows 2000 (Beta 3 RC2) 5.00 | 5.00.2128
Windows 2000 (Beta 3) 5.00 | 5.00.2183
Windows 2000 (Verkaufsversion) | 5.00.2195
Whistler Server Preview | 2250 (13.07.2000)
Whistler Server alpha | 2257 (24.08.2000)
Whistler Server interim release | 2267 (03.10.2000)
Whistler Server interim release | 2410 (01.04.2001)
Windows XP (RC 1) | 5.1.2505
Windows XP | 5.1.2600
Windows XP - Service Pack 1 | 5.1.2600.1105-1106
Windows XP - Service Pack 2 | 5.1.2600.2180
Windows .NET Server interim | 5.2.3541 (08.19.2001)
Windows .NET Server Beta 3 | 5.2.3590 (11.15.2001)
Windows .NET Server Release Candidate 1 (RC1) | 5.2.3660 (06.24.2002)
Windows .NET Server 2003 RC2 | 5.2.3718 (15.05.2002)
Windows Server 2003 (Beta) | 5.2.3763 (02.07.2003)
Windows Server 2003 | 5.2.3790
Windows Server 2003 - Service Pack 1 | 5.2.3790.1180
Windows Server 2003 | 5.2.3790.1218
Windows Loghorn (Beta) | 6.0.5048
Windows Vista (Beta 1) | 6.0.5112 (20.07.2005)
Windows Vista Community Technology Preview (CTP) | 6.0.5219 (30.08.2005)
Windows Vista TAB Preview | 6.0.5259 (17.11.2005)
Windows Vista CTP (Dezember) | 6.0.5270 (14.12.2005)
Windows Vista CTP (Februar) | 6.0.5308 (17.02.2006)
Windows Vista CTP (Refresh) | 6.0.5342 (21.03.2006)
Windows Vista April EWD | 6.0.5365 (19.04.2006)
Windows Vista (Beta 2 Preview) | 6.0.5381 (01.05.2006)
Windows Vista (Beta 2) | 6.0.5384 (18.05.2006)
Windows Vista (Pre-RC1) | 6.0.5456 (20.06.2006)
Windows Vista (Pre-RC1) | 6.0.5472 (13.07.2006)
Windows Vista (Pre-RC1) | 6.0.5536 (21.08.2006)
Windows Vista (RC1) | 6.0.5600.16384 (29.08.2006)
Windows Vista (Pre-RC2) | 6.0.5700 (10.08.2006)
Windows Vista (Pre-RC2) | 6.0.5728 (17.09.2006)
Windows Vista (RC2) | 6.0.5744.16384 (03.10.2006)
Windows Vista (Pre-RTM) | 6.0.5808 (12.10.2006)
Windows Vista (Pre-RTM) | 6.0.5824 (17.10.2006)
Windows Vista (Pre-RTM) | 6.0.5840 (18.10.2006)
Windows Vista (RTM) | 6.0.6000.16386 (01.11.2006)
Windows Vista - Service Pack 1 und Windows Server 2008 - Service Pack 1 | 6.0.6001 (2008)
Windows 7 (Beta 1) | 6.1.7000

Wo kann ich die Installationsstände auslesen?

Beim Booten von Windows NT wird die Version und falls installiert, die aktuelle Service Pack Nummer angezeigt. Diese Informationen finden Sie auch in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion

Name | Datentyp | Bedeutung
CurrentVersion | REG_SZ | Aktuelle Version von Windows
CurrentBuildNumber | REG_SZ | Aktuelle Build Nummer
CSDVersion | REG_SZ | Service Pack Nummer. Bei einer Beta-Version steht hier: RC x.x
InstallDate | REG_DWORD | Datum und Zeit der Installation
SystemRoot | REG_SZ | Windows Installationsverzeichnis
CurrentBuild | REG_SZ | Aktuelle Version von Windows
CurrentType | REG_SZ | Aktuelle Version von Windows
PathName | REG_SZ | Systemdateien von Windows
SourcePath | REG_SZ | Lage der Installationsdateien

Info Mit Befehl "winver" bekommt man unter Windows die Versionsnummer und das installierte SP angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0637.htm


Wie groß darf die Systempartition maximal sein?

Windows NT unterscheidet zwischen System-Partition und Boot-Partition.

Die Boot-Partition ist die Partition, die das Windows NT Verzeichnis enthält (%SYSTEMROOT%). Diese Partition kann an jeder beliebigen Stelle der Festplatte liegen und unterstützt Festplattengrößen bis zu 2 Terabyte.

Bei der Systempartition sieht es anders aus. Diese Partition enthält die Startdateien von Windows NT (BOOT.INI, NTDETECT.COM, NTLDR). Da Windows NT zum Booten den BIOS INT13 benutzt, unterliegt diese Partition den Beschränkungen früherer Zeiten. Hier werden max. 1024 Zylinder, 256 Köpfe, 63 Sektoren unterstützt. Daraus ergibt sich, dass die Systempartition eine Größe von 7,6 GByte nicht überschreiten darf. Auch muss diese Partition bei größeren Festplatten am Anfang dieser 7,6 GByte liegen da Windows NT sonst nicht mehr booten kann.

Das Setup von Windows unterstützt aber nur das Anlegen von 4 GByte Partitionen. Wollen Sie die 7.6 GByte ausnutzen, haben Sie zwei Möglichkeiten:

  1. Sie installieren NT über das Unattend-Setup (Unattend Setup von Windows NT)
  2. Sie legen eine Fat32 Partition mit Windows 95/98 an. Starten nun die Installation von Windows NT. NT wird jetzt diese Partition anzeigen, aber das Dateisystem nicht erkennen. Löschen Sie diese Partition und erstellen Sie eine neue Partition. Verwenden Sie nun den gesamten Speicherplatz.

Info Windows 2000, Windows 98 und Windows 95 OSR2 haben diese Größenbeschränkung nicht mehr, da sie auf neuere Funktionen zurückgreifen.

Info Auch unter NT können Sie eine Systempartition größer als 7,6 GByte anlegen, solange sich die Dateien (BOOT.INI, NTDETECT.COM, NTLDR) innerhalb der ersten 1024 Zylinder befinden. Hierbei muss man aber aufpassen, dass Tools wie z.B. Defragmentierungsprogramme diese Dateien nicht an das Ende der Partition verschieben. Wenn das passiert, erhalten Sie beim nächsten Booten eine Fehlermeldung!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0639.htm


Neue SID nach Cloning erstellen

Bei gleichen PCs nutzen viele Admins die Möglichkeit des Clonings einer bestehenden Installation mit Programmen wie Partition Magic, um diese auf anderen Clients aufzuspielen. Allerdings erstellt Windows NT und Windows 2000 bei jeder Installation eine eindeutige SID (Computer Security Identifier), wenn der Rechnername im GUI das erste einmal vergeben wird. Durch das Aufspielen eines solchen Images kommt die SID auch auf dem neuen Rechner zum Einsatz. Diese mehrfachen SIDs führen zu Problemen, weshalb Microsoft das Cloning ausdrücklich nicht empfiehlt und vielmehr die Unattended-Installation vorschlägt.

Auf den Seiten von Sysinternals unter http://www.sysinternals.com/ntw2k/source/newsid.shtml wird das Problem der SIDs erläutert und ein Tool bereitgestellt, welches neue SIDs bei bestehenden Systemen erstellen kann.

Weiterhin gibt es das Programm sysprep.exe von Microsoft:

Das Tool kann man von jeder NT-CD (NT4, NT5, NT5.1) aus dem Verzeichnis Support\Tools und der Datei deploy.cab entpacken. Dieses Tools sorgt dafür, wenn es ohne Parameter gestartet wird, dass der PC seine SID und sämtliche persönlichen Daten und Userkonten verliert.

Außerdem wird über PNP die Hardware eingebunden. Mit Parametern wie /nopnp kann man das Tool zum reinen Klonen von PC's nutzen.

Weitere Infos dazu finden Sie auch unter: http://www.computerjockey.de/mcse/mcse/011115.htm

Info Aufgrund vieler Probleme ist das aber eher für kleine Netzwerke geeignet. Bei größeren Netzwerken ist eine Unattended-Installation vorzuziehen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1000.htm


Installation von Windows NT

Die Installation von Windows NT 4.0 und Windows NT 3.51 verläuft unterschiedlich. Da aber die wichtigsten Schritte und Einstellungen (z.B. die Parameter) gleich sind, wird die Installation von Windows NT 3.51 hier nicht gesondert beschrieben.

Je nachdem, ob es sich um Server oder Workstation handelt und je nach gewählten Optionen, werden einige der unten aufgelisteten Einstellungen bei der Installation nicht angezeigt. Fahren Sie dann mit der nächsten, für Sie in Frage kommenden Option, fort.

Starten der Installation:

Die Möglichkeiten:

  1. Installation über Disketten (dafür verwenden Sie die beigelegten Disketten)
  2. Installation über von NT unterstütztes CD-ROM (hierfür werden nur die ersten 3 Bootdisketten benötigt)
    Sollten Sie die Bootdisketten verloren haben, können Sie sie mit "WINNT /OX" jederzeit erstellen. Durch Aufruf von "WINNT /B /OX" werden die Bootdisketten auf die Festplatte kopiert, so dass Sie keine Disketten mehr benötigen.
  3. Installation ohne Disketten.
  4. Update einer älteren NT-Version. Wenn Sie die Installation unter einer älteren NT-Version aufrufen, müssen Sie sie mit "WINNT32" starten.
  5. Installation von der Festplatte (so lässt sich NT auch mehrfach installieren, da die Dateien nicht gelöscht werden).

Info Die Installation von NT können Sie mit Parametern beeinflussen. Alle Parameter finden Sie unter "Installation von Windows NT (Setup-Parameter)".

Installation ohne Disketten:

Die Installation lässt sich normalerweise nicht unter Windows 3.x bzw.Windows 95 durchführen. Mit dem undokumentierten Schalter /W ist sie aber auch unter Windows im DOS -Fenster möglich.

Bei der Installation ohne Disketten, können Sie zwischen "mit Bootdisketten" oder "ohne Bootdisketten" wählen. Wenn Sie mit den drei Bootdisketten arbeiten wollen, rufen Sie "WINNT" auf, dadurch werden die drei benötigten Bootdisketten erstellt (sollten Sie die Disketten schon haben, rufen Sie die Installation mit "WINNT /X" auf). Nach Erstellen der Bootdisketten werden temporäre Dateien auf die Festplatte in das Verzeichnis "$WIN_NT$.~LS" kopiert.

Wenn Sie ohne Boot-Disketten arbeiten wollen, rufen Sie die Installation mit "WINNT /B" auf. Nun werden auch die Boot-Disketten auf die Festplatte kopiert und zwar in das Verzeichnis "$WIN_NT$.~BT". Wenn Sie die Installation aber unter dem MS-DOS -Modus von Windows 95 durchführen wollen, müssen Sie das Laufwerk mit "LOCK C:" vorher freigeben, da Windows 95 sonst nicht zulässt, dass Windows NT den Boot-Sector ändert.

Info Wenn Sie neuere Treiber für Ihre Hardware haben als die, die zu Windows NT beigelegt wurden (z.B. bei neuem Adaptec 2940-Treiber und Windows NT 3.51), sollten Sie die Installation mit "WINNT /B" starten. Nachdem die Windows NT-Dateien auf die Festplatte kopiert wurden, legen Sie eine DOS -Bootdiskette ins Laufwerk und booten von ihr. Nun müssen die neuen Treiber in beide NT-Verzeichnisse ("$WIN_NT$.~LS" und "$WIN_NT$.~BT") kopiert werden. Starten Sie anschließend den Rechner neu.

Installation von der Festplatte:

Bei dieser Vorgehensweise werden die Installationsdateien nach der Installation nicht von der Festplatte gelöscht. Es ist jederzeit möglich, das Setup wieder aufzurufen. Außerdem ist es im Gegensatz zu einer diskettenbasierenden Installation möglich, die automatische Hostadapter-Erkennung zu übergehen und einen vom Hardwarehersteller gelieferten Treiber zu installieren.

Starten Sie das Setup mit "WINNT /B /OX" (Verzeichnis "I386" der NT-CD-ROM) Nun werden alle zum Booten benötigten Dateien auf die Festplatte kopiert.Kopieren Sie nun alle Dateien aus dem Verzeichnis "I386" (NT-CD-ROM) in ein beliebiges Verzeichnis Ihrer Festplatte. Wichtig ist dabei nur, dass Ihr letztes Verzeichnis ebenfalls "I386" heißt.

Danach änderen Sie mit einem Texteditor die Datei "TXTSETUP.SIF" aus dem Verzeichnis C:\. In der Sektion [SourceMedia] entfernen Sie das " ; " vor "upsourcedevice" und tragen dort die Festplatten- und Partitionsnummern ein, wo die Installationsdaten liegen. Sollten Sie das Verzeichnis "I386" nicht ins Hauptverzeichnis der Platte kopiert haben, müssen Sie auch noch unter "setupsourcedir" den Pfad angeben. Alternativ zur Festplatten-Angabe wird dort auch "\device\cdrom" akzeptiert.

Jetzt muss nur noch die Datei "c:\$win_nt$.~bt\winnt.sif" geändert werden. Dort ändern Sie msDOS initiated= "1" in "0" um.

Nach der Installation können Sie durch einfaches Ändern der "BOOT.INI" die Installation jederzeit wieder neu starten. Dazu brauchen Sie nur folgende Zeile einzufügen: C:\$win_nt$.~bt\bootsect.dat="NT-Installation"

  1. Nach dem Kopieren der Dateien wird der Rechner neu gestartet.
  2. Nun haben Sie die Auswahl zwischen Installation oder Reparatur einer bestehenden Installation.
  3. NT zeigt nun alle gefundenen Massenspeichergeräte an:
    Hier werden gefundene Controller angezeigt. Wenn ihr Adapter nicht gefunden wurde, können Sie den Treiber manuell hinzufügen.
  4. Nun wird eine Lizenzabfrage durchgeführt.
  5. Hardwareeinstellung.
    Hier werden gefundene Einstellungen für Computer, Anzeige, Tastatur, Sprache und Maus angezeigt. Sollten die Einstellungen Ihrer Konfiguration nicht entsprechen, können Sie sie nun ändern.
  6. Auswahl der Festplatte bzw. Partition.
    Nun können Sie auswählen, auf welcher Festplatte bzw. Partition NT installiert werden soll. Mit "C" können Sie Partitionen erstellen, mit "D" vorhandene Partitionen löschen.
  7. Dateisystem.
    Hier können Sie das zu installierende Dateisystem wählen. Sie können sich für FAT oder NTFS entscheiden. Wenn die Partition schon formatiert war, können Sie sie umwandeln ohne die Daten zu löschen!
    Es sollte eigentlich immer NTFS gewählt werden, da dieses Dateisystem alle Sicherheitsfunktionen von NT unterstützt.
  8. Verzeichnis.
    Hier können Sie das Installationsverzeichnis angeben.
  9. Überprüfen des Datenträgers.
  10. Kopieren der Systemdateien.
  11. Neustart.
  12. Installationsart.
    Hier können Sie zwischen Standard- oder Benutzerdefinierter Installation wählen. Zu empfehlen ist die "Benutzerdefinierte Installation". Bei dieser Einstellung trifft der Computer auch die Entscheidungen, Sie haben aber die Möglichkeit, einzugreifen und sie zu verändern.
  13. Benutzername.
    Nachdem Sie auf "Weiter" geklickt haben, werden Sie nach Benutzer- und Firmennamen gefragt.
  14. Computernamen.
  15. Administrator-Passwort.
    Jetzt sollen Sie ein Passwort für den Administrator (der Administrator hat alle Rechte) eingeben.
  16. Notfalldiskette.
    Nun werden Sie gefragt, ob NT eine Notfalldiskette erstellen soll. Auf dieser Diskette werden die wichtigsten Einstellungen gespeichert und im Notfall kann damit die Konfiguration wiederhergestellt werden.
  17. Tools auswählen.
    Nun können Sie auswählen, welche Programmteile Sie installieren wollen.
  18. Netzwerk-Einrichtung.
    Sie werden nun gefragt, ob ein Netzwerk installiert werden soll.
  19. Netzwerkkarte.
    Sie können hier mit "START search" automatische Suche nach einer Netzwerkkarte starten oder aber mit "Select from list" selbst eine Netzwerkkarte aus der Liste auswählen.
  20. Netzwerk-Protokoll wählen.
    Hier können Sie die Protokolle auswählen. Zur Auswahl stehen:TCP/IP, IPX/SPX und NetBEUI
  21. Network Services.
    Sie können nun die zu installierenden Dienste auswählen.
  22. Netzwerk Adressen.
    Hier müssen Sie Angaben zur IRQ und E/A-Adresse machen. NT versucht, die Werte automatisch zu erkennen und zeigt vermutlich schon die richtigen Adressen an.
  23. TCP/IP Setup
    Wenn Sie das TCP/IP-Protokoll mit ausgewählt haben, müssen Sie noch weitere Einstellungen vornehmen wie: TCP/IP-Adresse, Subnet Mask usw.
  24. Binding Informationen.
    Hier zeigt NT die einzelnen Bindungen an. Sie können Bindungen ein- bzw. ausschalten
  25. Starten des Netzwerks.
  26. Nun werden Sie nach Ihrer Zeitzone gefragt.
  27. Grafikkarte.
    Hier können Sie die Grafikkarte einstellen. Es können nur Auflösung, Bildwiederholfrequenz und Farbenzahl geändert werden. Ein Ändern der Grafikkarte ist zu diesem Zeitpunkt noch nicht möglich. Sie können die Installation erst fortsetzen, wenn Sie die Auflösung mit "TEST" ausprobiert und die Frage positiv beantwortet haben.
  28. Nun werden die letzten Dateien kopiert.
    Wurde Erstellen einer "Notfall Diskette" angekreuzt, wird diese jetzt erstellt.
  29. Rechner Neustart.

Nun ist die Installation beendet

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0423.htm


Installation von Windows NT (Setup-Parameter)

Bei Windows NT wird die Installation nicht wie unter Windows 95/98 mit SETUP.EXE gestartet. NT wird durch den Aufruf von "WINNT.EXE" (unter DOS bzw. Windows 95/98) bzw. mit "WINNT32.EXE", wenn die Installation unter einem bestehendem NT gestartet werden soll, aufgerufen.

Durch die Angabe von Parametern können Sie die Installation beeinflussen.

/S: Quellpfad | Gibt den Ort der WINDOWS-Quelldateien an.
/T: TempLW | Bestimmt das Laufwerk, auf dem die TEMP-Dateien gespeichert werden sollen
/I: Datei | Gibt die INF-Datei an, die bei der Installation verwendet werden soll. Standard-Angabe ist DOS NET.INF. (ohne Pfad, da sich NT nach der Angabe unter /S richtet)
/O | Nur Setup-Disketten erstellen
/OX | Setup-Disketten für CD-ROM erstellen und Disketten-Installation durchführen
/X | Keine Setup-Disketten erstellen
/F | Keine Überprüfung der Dateien beim Kopieren (nur bei WINNT.EXE)
/C | Keine Überprüfung des Speicherplatzes (nur bei WINNT.EXE)
/B | Installation ohne Disketten, alle Daten werden auf die Festplatte kopiert.
/U | Unbeaufsichtigte Installation durch Angabe einer Skriptdatei. (nur bei WINNT.EXE)
/UDF | Definiert eine Zeichenfolge die verwendet wird, um bestimmte Abschnitte der Skriptdatei für die unbeaufsichtigte Installation durch die mit dieser Zeichenfolge gekennzeichneten Abschnitte in der UDF-Datei zu ersetzen.
/W | Installation unter Windows 3.x bzw. Windows 95
/R | Optionales Verzeichnis erstellen (nur bei WINNT.EXE)
/RX | Optionales Verzeichnis kopieren (nur bei WINNT.EXE)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0424.htm


Installation eines SCSI Scanners

Für SCSI-Scanner wird eine Installationsroutine mitgeliefert, die eine Installation automatisch durchführen kann. Diese Beschreibung ist also mehr als Information gedacht bzw. für NT 3.51, wo man mit diesem Vorgehen auch die Scanner einbinden kann.

Diese Instruktionen beschreiben die Installation eines HP SCSI Scanners unter Windows NT. Folgende Scanner werden unterstützt: HP ScanJet 4c, 3c, IIcx, IIc, IIp und 3p.

Info ScanJet und HP ScanJet plus sowie Interface-Karten C1752-66500 und C1753-66500 werden von Windows NT nicht unterstützt.

Als Rootverzeichnis wird \WINNT\ angenommen.

16 Bit Programme:

Folgende Dateien müssen sich in unten angegebenem Verzeichnissen befinden:

HPSCAN32.DLL %SYSTEMROOT%\system32

HPSCAN16.SYS %SYSTEMROOT%\system32\drivers

In der CONFIG.NT wird folgendes eingetragen:

device=%SYSTEMROOT%\system32\drivers\HPSCAN16.SYS

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Scsiscan

ändert man den Eintrag wie folgt:

Start: value ist 0.

32 Bit Programme:

Folgende Dateien müssen sich in unten angegebenen Verzeichnissen befinden:

hpscnmgr.dll | %SYSTEMROOT%\system32
hpsj32.dll | %SYSTEMROOT%\system32
hpscnmgr.hlp | %SYSTEMROOT%\system32
hpscntst.dll | %SYSTEMROOT%\system32
WNASPI32.DLL | %SYSTEMROOT%\system32
aspi32.sys | %SYSTEMROOT%\system32\drivers

In der Sektion HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services

wird ein SchlüsselEintrag mit dem Namen ASPI32 erstellt.

Danach werden folgende Einträge vorgenommen:

Value Name | Datentyp | Data
ErrorControl | REG_DWORD | 1
Start | REG_DWORD | 2
Type | REG_DWORD | 1

In der Sektion HKEY_CURRENT_USER\ ControlPanel\ MMCPL muss ein Eintrag erstellt werden:

Value Name | Data Type | Data
HPScanJet | REG_SZ | %SYSTEMROOT%\system32\hpscnmgr.dll

Starten Sie den Rechner neu.

Info Wenn möglich, sollte Service Pack 5 installiert werden. Es kann nämlich passieren, dass das Ereignisprotokoll jede Sekunde mit ca. 6 (!) Meldungen aktiv wird, wenn ein Scanner-Programm gestartet wird. Ab Service Pack 4 ist der Fehler behoben.

SCSI-Scanner unter Windows 2000

Um Scanner unter Windows 2000 nutzen zu können, muss man zuerst eine bessere SCSI-Karte hollen und installieren. Ich habe dafür eine von Tekram benutzt.

Als nächstes sucht man in Internet nach wnaspi32.dll und aspi32.sys. Die Dateien sollen möglichst gleiches Datum besitzen oder von dem gleichen Server stammen. Danach hollt man sich von http://www.adaptec.comdie Datei aspi32.exe. Jetzt kopiert man die wnaspi32.dll in den Windows-Systemorder (%SystemRoot%\system32\) und aspi32.sys nach %SystemRoot%\system32\drivers\. Danach offnet man einen Texteditor und fügt folgendes ein:

=== Hier schneiden ===

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASPI32]

"ErrorControl"=dword:00000001

"Start"=dword:00000001

"Typ"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASPI32\Parameters]

"ExcludeMiniports"=""

=== Hier schneiden ===

Das Ganze soll als z.B. ASPI_NT.REG gespeichert werden. Diese Datei führt man aus und startet Windows 2000 neu. Nach dem Neustart installiert man aspi32.exe und startet Windows 2000 wieder neu. Danach installieren Sie die Windows NT Scanner Treiber von der CD und installiert sie (ohne Treiber für die SCSI-Karte, die mit dem Scaner verkauft wird). Jetzt soll der Scaner einwandfrei unter Windows 2000 laufen.

Info Oft gibt es jetzt schon die Treiber für die entsprechenden Betriebssysteme. Dieser Tipp ist also eher für ganz alte Geräte gedacht, wo der Hersteller den Treibersupport eingestellt hat.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0409.htm


Eine zusätzliche CPU nach der Installation von Windows NT hinzufügen

Wenn Sie Windows NT schon installiert haben und nachträglich eine weitere CPU hinzufügen wollen, wird die zusätzliche CPU von Windows NT nicht automatisch erkannt.

Um sich eine Neuinstallation zu ersparen, finden Sie im Resource Kit von MS das Tool "uptomp.exe". Nachdem Sie dieses Tool auf Ihrem PC ausgeführt haben, wird Windows NT die zusätzliche CPU erkennen und auch benutzen.

Das Tool können Sie auch kostenlos unter ftp://ftp.microsoft.com/bussys/winnt/winnt-public/reskit/nt40/uptomp/herunterladen.

Info Wenn ein Service Pack installiert ist, hinterlässt das beschriebene Vorgehen ein nicht mehr bootfähiges System. Gehen Sie in diesem Fall folgendermaßen vor:

  1. Uptomp ausführen
  2. Nicht neu starten
  3. Die installierte Service Pack Version noch einmal installieren
  4. Erst jetzt den Rechner neu starten

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0870.htm


Installation von NT mit Adaptec 2940 funktioniert nicht

Ab BIOS Version 2.21 beendet Windows NT die Installation mit einem Fehler. Das liegt am SCSI-Treiber. Man braucht den neuen Treiber aus dem Service Pack 3 oder von EZ-Drive 4.0.

Installieren Sie Windows NT mit WINNT.EXE /B. Nachdem die Dateien kopiert wurden, starten Sie den Rechner mit einer Bootdiskette, kopieren den aktuellen Treiber (Datei AIC78xx.SYS) ins NT-Installationsverzeichnis (Sie müssen den Treiber 2 einmal kopieren, einmal für die Installationsroutine in das Verzeichnis "$WIN_NT$.~BT"und in das Verzeichnis aus dem die Installation erfolgt "$WIN_NT$.~LS") und überschreiben die alte Version.

Nach Rechner-Neustart kann die Installation nun Normal fortgesetzt werden.

Info Informationen zur Installation finden Sie auch unter "Installation von Windows NT" bzw. unter "Installation mit neuen SCSI-Kontrollern"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0426.htm


Installation von NT auf Festplatten über 8 GByte scheitert

Bereits bei der Installation von Windows NT auf Festplatten über 8 GByte (IDE) kommt es zu Problemen, wenn nicht vor der eigentlichen Installation der Treiber ATAPI.SYS ab Servicepack 4 installiert wird. Dieser ist separat zu finden unter ftp://ftp.microsoft.com/bussys/winnt/winnt-unsup-ed/fixes/nt40/atapi/ATAPI.EXE.

Bei Festplatten über 8 GByte bricht NT mit einer Fehlermeldung beim Erstellen einer Partition ab und zerstört evtl. die komplette Partitionstabelle der Platte. Zur Vermeidung dieses Problems geht man wie folgt vor:

  1. ATAPI.EXE auf einer Diskette starten, damit sich diese entpackt.
  2. Windows NT mit den Bootdisketten installieren, bis das System fragt, ob es nach den Massenspeichergeräten (SCSI etc.) suchen soll. Hier geht man auf die manuelle Auswahl und gibt Diskette an. Danach verlangt NT die Treiberdiskette und meldet dann Microsoft ATAPI Service Pack 4 IDE Driver Disk
  3. Weitere Geräte wie SCSI Controller kann man nun ebenfalls aus der Liste wählen.
  4. Nachdem die Installation fortgesetzt wird, verlangt Windows NT noch einmal die ATAPI Treiber-CD.

Weiterhin muss noch folgendes beachtet werden:

Anfang des Zitats aus der Hilfe von Bootmanagers WWBMU

(...)

Da DOS zu den kritischsten Fällen zählt, sollte man dieses Betriebssystem möglichst nah an den Festplattenanfang legen. Sollte der Platz innerhalb der ersten 2 GByte nicht ausreichen (etwa weil dort noch eine zweite DOS -Partition abgelegt werden soll), so kann man sich durch Auslagerung behelfen: In der zu bootenden primären DOS -Partition legt man nur die für den tatsächlichen Start relevanten Dateien ab. Das sind io.sys, msDOS .sys, command.com sowie config.sys und autoexec.bat, die zusammen kaum 100 KByte benötigen.

Einführung: Limits bei Windows NT

Auf ähnliche Probleme trifft man auch bei Windows NT 4.0. So fern das Betriebssystem auf einer FAT-Partition installiert werden soll, gelten die gleichen Beschränkungen wie für DOS - allerdings auch die gleichen Lösungsansätze: Kritisch ist nur der Start des NT-Loaders ntldr. Das Betriebssystem selbst kann sich dagegen auf einer beliebigen Partition unterhalb von 8 GByte befinden. Für die primäre Ministartpartition werden allein die Dateien ntldr, ntdetect sowie boot.ini benötigt, die zusammen kaum 200 KByte auf die Waage bringen. Eine leichte Linderung bringt übrigens die Formatierung der NT-Startpartition mit NTFS statt FAT. Dann muss der Partitionsanfang nicht unterhalb von 2, sondern immerhin 4 GByte liegen.

Einführung: Limits bei Windows 95/98

Die oben genannten Boot-Probleme der letzten offiziellen DOS -Version wurden in Windows 95/98 vollständig gelöst. Diese Betriebssysteme können an beliebiger Stelle innerhalb der ersten 8 GByte einer Festplatte installiert werden. Bei Partitionen, die diese Grenze überschreiten, muss lediglich sichergestellt werden dass die Datei io.sys noch im vorderen Teil liegt. Eine erweiterte Partition darf unter Windows 9x die 8-GByte-Grenze überschreiten und auch größer als 8 GByte sein. Dies gilt sowohl für das Dateisystem FAT-12/16 (max. Größe hier 32 MByte bzw. 2 GByte), als auch FAT-32.

Einführung:

Limits bei Windows 98 (2. Ausgabe), 2000, XP und Linux

Bei den drei von Windows 2000 unterstützten Dateisystemen ¦FAT-12/16, FAT-32 und NTFS ist lediglich darauf zu achten, dass sich die NT-Loader-Dateien bei FAT12/16 unterhalb von 8 GByte befinden. Bei den anderen gibt es kein Limit.

(...)

Ende des Zitats aus der Hilfe von Bootmanagers WWBMU

Info Wenn Sie die Installation von NT mit "WINNT /B" durchführen, können Sie die ATAPI.EXE natürlich gleich auf der Festplatte in den Installationsverzeichnissen austauschen. Beachten Sie aber, dass Sie die ATAPI.EXE zweimal ersetzen müssen (im Verzeichnis "$WIN_NT$.~LS" und "$WIN_NT$.~BT")

Info Informationen zur Installation finden Sie auch unter "Installation von Windows NT" bzw. unter "Installation mit neuen SCSI-Kontrollern"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
Windows NT 4.0 unterstützt max. 7,8-GB-Systempartition: http://support.microsoft.com/default.aspx?scid= KB%3Bde%3BD42167

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0425.htm


Installation mit neuen SCSI-Kontrollern

Wenn man NT 4.0 auf ein System installieren möchte, das einen neuen Adaptec SCSI Kontroller hat (z.B. AHA 2940U2W), dann wird dieser nicht erkannt und damit auch die daran angeschlossenen Platten. Wird dieser aber nun als zusätzliches Gerät eingetragen, so wird zwar der Kontroller, aber nicht mehr die Platten erkannt.

Damit Sie den Kontroller schon beim Windows Setup zur Verfügung haben, müssen Sie die automatische Erkennung mit F6 abbrechen und den Treiber selber hinzu laden, dann werden auch die daran angeschlossen Festplatten erkannt. Dies ist besonders hilfreich, wenn man die Setupdateien nicht auf Platte kopieren oder mit den Setupdisketten arbeiten möchte, sondern direkt von der CD booten will.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0884.htm


Automatisches Konvertieren nach NTFS bei einer "Unattended" Installation

Laden Sie aus dem Installationsverzeichnis von Windows NT die Datei "INITAIL.INF"und ändern Sie unter SetAcls den Eintrag "Convert Winnt = $($1)" in "Convert Winnt = Yes".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0407.htm


Was bedeuten die Punkte beim Booten auf dem Bildschirm?

Auf dem blauen Bildschirm beim Booten erscheinen unter der Angabe
"Microsoft (R) Windows NT (TM) Version 4.0 (Build xxxx) 1 Systemprozessor (256 MB)"
immer einige Punkte. Die Anzahl der Punkte kann teilweise unterschiedlich sein, wenn noch nicht so viel installiert ist.

1 Punkt | Initialisierung der Low-Level Treiber, die in der vorgehenden Bootphase geladen wurden
2 Punkt | Laden und Initialisieren anderer Treiber
3 Punkt | Laden von Programmen (z.B. CHKDSK)
4 Punkt | Laden und Initialisieren von Diensten
5 Punkt | Erstellen der Pagefile.sys
6 Punkt | Starten der NT Subsysteme

Sie können sich auch statt der Punkte mehr Informationen anzeigen lassen. Dazu müssen Sie in der Boot.INI den Parameter /SOS setzen (siehe: Informationen über die Boot.INI).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0438.htm


Keine Bildschirmmeldungen mehr beim Booten

Unterbrechungen des Bootvorganges, die durch Bildschirmmeldungen verursacht werden, können mit einem Eintrag in der Registry abgestellt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

erstellen Sie einen DWORD-Wert mit dem Namen "NoPopUpsOnBoot".

Sie können diesem Eintrag einen der folgenden Werte zuweisen:

0 | Bildschirmmeldungen zulassen
1 | keine Bildschirmmeldungen zulassen

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0403.htm


NTDETECT - mehr Informationen

Beim Start von NT (auch bei der Installation) führt NT das Programm NTDETECT.COM aus. Das Programm versucht, die installierte Hardware zu erkennen. Bei einigen Rechnern kann es vorkommen, dass NT bei der automatischen Erkennung abstürzt. Da NTDETECT keine Bildschirmausgabe der gefundenen Hardware macht, ist es schwer festzustellen, an welcher Komponente es lag.

Dafür hat MS aber auf der CD eine spezielle Debug-Version abgelegt, die alle Informationen auf den Monitor ausgibt.

Löschen Sie die Original-Datei aus Ihrem Installationsverzeichnis oder bei einer Disketteninstallation von der Boot-Diskette und kopieren Sie die Datei NTDETECT.CHK aus dem Verzeichnis "SUPPORT" von der NT-CD-ROM an deren Stelle. Nun muss nur noch die Datei NTDETECT.CHK in NTDETECT.COM umbenannt werden.

Jetzt wird beim Neustart von NTDETECT die erkannte Hardware auf dem Bildschirm ausgegeben und Sie können möglicherweise erkennen, was den Absturz verursachte.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0436.htm


Startvorgang von Windows NT

Hier finden Sie eine kurze Beschreibung des Startvorgangs von Windows NT, dabei wird der Startablauf in Stichpunkten beschrieben.

Was geschieht, wenn Sie Ihren Computer mit Windows NT starten?

(mehr dazu im "Server Resource Guide" von Microsoft)

Info Sorry - dieser Text enthält zum Teil noch die Texte der engl. NT Version!

Der NT Startvorgang in Stichworten:

Nach dem Starten vom Bootsektor lädt NT gleich den NT-Loader (befindet sich immer auf C:\ und heißt "NTLDR"). Dieses Programm wird schon im 32-Bit-Protected-Mode ausgeführt. Der Bootloader holt sich aus der Datei "C:\boot.ini" die Informationen, auf welcher Partition sich NT befindet und was für etwaige Betriebssysteme noch installiert sind.

Wenn man nun auswählt, dass NT gestartet werden soll, ruft das Programm aus den Verzeichnis C:\ die Datei "NTDETECT.COM" auf. Diese Datei führt eine Art Hardwareerkennung durch und gibt danach die Kontrolle wieder an den Bootloader zurück. Mittels einiger Parameter (BOOT.INI) kann man das Verhalten etwas beeinflussen.

Je nach Hardwareausstattung wird nun entweder ein passender Hostadapter-Treiber geladen oder NTLDR greift auf das System-BIOS zurück, um die Grundkomponenten von der jeweiligen Systempartition zu laden. Nach dem "NTOSKRNL.EXE" und "HAL.DLL" geladen wurden, werden alle eingetragenen Treiber die in der Registry stehen geladen.

Dieses wird durch das Programm "NTOSKRNL.EXE" gesteuert und ist in drei Schritte unterteilt:

  1. Kernel Initialisierung:
    Die Kontrolle wird an den Kernel übergeben. Mit den Hardwareinformationen von "ntdetect" werden nun einige Registry Einträge aktualisiert. Außerdem sichert NT die Konfigurationsdaten und lädt dann noch die Treiber, die das "SYSTEM" Attribut tragen.
  2. Service Load:
    Der Session Manager (SMSS.EXE) bestimmt anhand der Registry, welche Programme beim Systemstart auszuführen sind.
  3. Windows Subsystem Start:
    Startet das Local Security Authority System (LSASS.EXE) welches für die Anzeigen der Security verantwortlich ist. Dieses Programm führt den Logon-Prozess aus und startet alle eingerichteten Treiber und Dienste.

Um Windows NT erfolgreich zu starten, werden folgende Schritte abgearbeitet:

  1. Selbsttest der Hardware (engl. Power On Self Test, POST)
  2. Startprozess initialisieren
  3. Bootprogramm laden
  4. Auswahl des Betriebssystem
    Überprüfen der Hardware
  5. Auswahl der Konfiguration
  6. Kernel laden
  7. Kernel initialisieren
  8. Einloggen

Die Reihenfolge und die Verarbeitung unterscheiden sich bei verschiedener Hardware (z.B. bei INTEL x86 bzw. RISC-CPU). Ich werde mich hier jedoch auf den x86-Teil beschränken.

Der Computer startet, wenn Sie:

  1. Den Computer einschalten.
  2. Bei der Auswahlbox "Computer herunterfahren" bzw. "Computer neu starten" anklicken.
  3. Wenn Sie "Computer neu starten" in der Auswahlbox Windows herunterfahren anklicken.

Wenn Ihnen NT das Anmeldefenster mit dem Text "Drücken Sie Strg + Alt + Entf um sich anzumelden" zeigt, hat der Computer das Betriebssystem Windows NT bereits geladen und den Großteil der Initialisierung beendet. Diese ist abgeschlossen, wenn sich der Anwender erfolgreich anmelden kann.

Windows NT kann nicht richtig starten wenn Hardware nicht richtig erkannt wird oder es zu Problemen bei deren Initialisierung kommt. Auch wenn Dateien defekt sind, Windows NT Dateien nicht findet, bzw. Dateien in falschen Verzeichnissen liegen, schlägt das Starten fehl.

Die folgende Tabelle zeigt, welche Dateien NT wo auf einem Rechner mit x86 CPU zum Starten benötigt:

Datei | Verzeichnis
NTLDR | Hauptverzeichnis der Startdisk
Boot.ini | Hauptverzeichnis der Startdisk
Bootsect.DOS | Hauptverzeichnis der Startdisk
NTDETECT.COM | Hauptverzeichnis der Startdisk
Ntbootdd.sys (SCSI only) | Hauptverzeichnis der Startdisk
NTOSKRNL.EXE | %SYSTEMROOT%\ System32
Hal.dll | %SYSTEMROOT%\ System32
SYSTEM key | %SYSTEMROOT%\ System32\Config
device drivers | %SYSTEMROOT%\ System32\Drivers

Im folgenden werden die oben genannten neun Schritte genau beschrieben:

1. Selbsttest der Hardware

Wenn Sie den Computer einschalten oder durch einen Reset neu starten, führt dieser einen Selbsttest (engl. Power On Self Test, POST) der Hardware durch:

  1. Testen des vorhandenen RAM-Speichers.
  2. Kontrolle, ob die Hardwarekomponenten (z.B. Tastatur) bereit sind.

Sobald der Computer, genauer das BIOS , seinen Selbsttest durchgeführt hat, führt jede Adapterkarte (wie z.B. die Grafikkarte) ihrerseits einen Selbsttest durch. Die Hersteller des BIOS und der Adapterkarten bestimmen, ob und welche Informationen dabei auf dem Bildschirm angezeigt werden.

2. Startprozess initialisieren

Der erste Sektor der Festplatte ist der entscheidende für das Starten. Dieser Sektor enthält den "Master Boot Record" (MBR) und die Partitionstabelle.

Wird der Computer von einer Startdiskette gestartet, enthält ihr erster Sektor den Boot-Sektor.

Starten auf einem x86-basierten Rechner:

Nachdem das BIOS den Selbsttest des Rechners durchgeführt hat, sucht es das Boot-Laufwerk. Falls das Diskettenlaufwerk im BIOS als Boot-Laufwerk eingestellt ist und sich dort eine Diskette befindet, bootet es von dort, falls nicht, nimmt es die erste Festplatte des Systems.

Wenn das Startlaufwerk eine Festplatte ist, liest das BIOS den MBR und lädt ihn in den Speicher. Danach übergibt es die Programmausführung dem Programmcode des MBR. Das Programm im MBR durchsucht als erstes das System nach der primären Festplattenpartition. Hat es diese gefunden, lädt es den Sektor 0 in den Speicher und führt den dort enthaltenen Programmcode aus. Dieser kann ein Programm, ein Diagnoseprogramm oder ein Programm zum Laden des Betriebssystem enthalten. Enthält die erste Festplatte keine primäre Partition, zeigt der Master-Boot-Record eine Fehlermeldung an:

  1. Invalid partition table (ungültige Partitionstabelle)
  2. Error loading operating system (Fehler beim Laden des Betriebssystems)
  3. Missing operating system (Betriebssystem fehlt)

Befindet sich eine Diskette im Diskettenlaufwerk, lädt das BIOS den ersten Sektor in den Arbeitsspeicher. Ist die Diskette bootfähig, dann ist der erste Sektor der Boot Sektor. Ist die Diskette nicht bootfähig, erscheint eine Fehlermeldung wie folgende:

Non-System disk or disk error

Replace and press any key when ready

(keine Systemdiskette oder Diskettenfehler, Diskette austauschen und dann Taste drücken)

3. Bootprogramm laden

Das Bootprogramm ermöglicht es Ihnen, das Betriebssystem zu wählen und lädt dann die notwendigen Dateien von der Festplatte in den Speicher. Dabei gehen die x86 und die RISC Version von NT unterschiedlich vor. Bei Rechnern mit x86 CPU geht das Bootprogramm wie folgt vor:

NTLDR kontrolliert die Auswahl des Betriebssystems und führt eine Hardwareerkennung vor dem Starten des Kernels von NT durch. Das Programm NTLDR muss sich im Hauptverzeichnis der Boot-Festplatte befinden.

Wenn NTLDR zu arbeiten beginnt, wird der Bildschirm gelöscht und folgende Meldung angezeigt:

OS Loader Vx.x

4. Betriebssystem auswählen

Anschließend zeigt NTLDR ein Menü zur Auswahl des Betriebssystems entsprechend den Einstellungen in der BOOT.INI - Datei an. Der Bildschirm sieht dann etwa so aus:

OS Loader Vx.x

Please select the operating system to start:

Windows NT Server Version 4.0

Windows NT Server Version 4.0 (VGA mode)

Use and to move the highlight to your choice.

Press Enter to choose.

Seconds until highlighted choice will be started automatically: 29

Nach Ablauf des Zählers lädt NTLDR automatisch den obersten Eintrag. Das Windows Setup-Programm stellt diesen auf die zuletzt installierte NT Version ein. Dieser Wert kann entweder in der Datei BOOT.INIoder mit einer installierten NT Version in der Systemsteuerung geändert werden.

5. Überprüfen der Hardware

NTDETECT.COM ist für die Erkennung der Hardware bei x86 basierten Computern zuständig. Es sammelt eine Liste von gegenwärtig installierten Hardware Komponenten und gibt diese Information dann an NTLDR zurück. Nachdem Sie ein Betriebssystem bzw. eine Betriebssystemkonfiguration auf dem Boot Bildschirm ausgewählt haben (oder einfach die Zeit abgelaufen ist), beginnt das Programm NTDETECT.COMmit der Arbeit. Sie sehen dann die folgende Zeile auf dem Bildschirm:

NTDETECT Vx.x Checking Hardware...

NTDETECT.COM kontrolliert die folgenden Hardware Komponenten:

  1. Computer ID
  2. Bus/Adapter Typ
  3. Grafikkarte
  4. Tastatur
  5. Serielle Schnittstelle
  6. Parallele Schnittstelle
  7. Diskettenlaufwerke
  8. Mausanschluss

6. Auswahl der Konfiguration

Wenn Sie die Version von Windows NT gewählt haben, wird es gestartet. Nachdem das Bootprogramm die Hardwareinformation gesammelt hat, sehen Sie folgenden Bildschirm:

OS Loader Vx.x

Press spacebar now to invoke Hardware Profile/Last Known Good menu.

Das Bootprogramm wartet einige Sekunden darauf, dass Sie die Leertaste drücken. Wenn Sie die Leertaste nicht drücken nur ein Hardwareprofil haben, lädt das Bootprogramm Windows NT durch Verwenden der letzten Konfiguration. Sonst sehen Sie folgende Bildschirmausgabe:

Hardware-Profil und Wiederherstellung der Konfiguration

Letzte als funktionierend bekannte Konfiguration)

In diesem Menü können Sie ein Hardware-Profil auswählen, das beim Start

von Windows NT verwendet werden soll.

Dieses Menü ermöglicht es Ihnen außerdem, zu einer früheren Systemkonfiguration

zu wechseln, so dass System-Startprobleme vermieden werden können.

WICHTIG: Alle Änderungen der Systemkonfiguration, die seit dem letzten

erfolgreichen Starten gemacht worden sind, gehen verloren.

<HW-Profil 1>

<HW-Profil 2>

Verwenden Sie die NACH-OBEN- oder die NACH-UNTEN-TASTE, um Ihre Auswahl

zu markieren. Drücken Sie die EINGABETASTE, sobald Sie die gewünschte

Auswahl getroffen haben.

Drücken Sie die L-TASTE, um die letzte als funktionierend bekannte

Konfiguration zu verwenden. Drücken Sie die F3-TASTE, um dieses Menü zu

verlassen und den Computer neu zu starten.

Sekunden, bis die markierte Auswahl automatisch gestartet wird:..

Nach ein paar Sekunden wird die markierte Auswahlmöglichkeit automatisch gestartet.

Das erste Hardwareprofil ist hervorgehoben. Wenn Sie andere Hardwareprofile geschaffen haben, verwenden Sie den Abwärtspfeil, um ein anderes zu wählen, welches Sie verwenden wollen. Für mehr Information über Hardwareprofile schauen Sie nach dem Starten von Windows NT unter "Einstellungen" -> "Systemsteuerung" -> "System" -> "Hardwareprofile" nach. Sie können auch zwischen einer als gut bekannten Konfiguration und der zuletzt gewählten Konfiguration wählen. Windows NT verwendet automatisch die letzte Konfiguration, wenn Sie die letzte bekannte gute Konfiguration nicht wählen. Wenn Sie die alte Konfiguration verwenden, verwendet das Bootprogramm die Konfiguration von Windows, die NT beim letzten Herunterfahren gesichert hat.

Wenn Sie auf die letzte bekannte gute Konfiguration durch Drücken von "L" und der Eingabetaste umschalten, verwendet das Bootprogramm die letzte gute Konfiguration (diejenige, die zu einem erfolgreichen Start des Betriebssystems führte).

7. Kernel laden

Wenn Sie die Eingabetaste auf den Hardwareprofil/Konfigurationsholung Menü drücken oder das Bootprogramm die Auswahl für Sie automatisch macht, beginnt der Computer den Kernel zu laden. Sie sehen mehrere Punkte, da das Bootprogramm welches Windows lädt, den NT Kernel (NTOSKRNL.EXE) und die "Hardwareabstraktionsschicht" (besser engl. hardware abstraction layer) HAL.DLL lädt. NT besitzt die HAL, um auf verschiedenen Hardwareplattformen laufen zu können.

An dieser Stelle schafft das Bootprogramm den Kontrollsatz, den es verwenden wird, um den Computer zu initialisieren. Der Kontrollsatz ist entweder ein älterer Kontrollsatz oder der letzte, als gut bekannte, Kontrollsatz. Das Bootprogramm lädt dann die auf den identifizierten Daten basierenden niedrigen Gerätetreiber (engl. low-level device drivers) in die Kontrolle.

8. Kernel initialisieren

Sie wissen, dass der Kernel initialisiert wird, wenn der Bildschirm blau ist und Sie folgenden Text sehen:

Microsoft (R) Windows NT (TM) Version 4.0 (Build 1345)

1 System Processor (64 MB Memory)

Dies bedeutet, dass NTOSKRNL.EXE erfolgreich initialisiert hat und die Kontrolle übernommen hat.

Es folgt die Initialisierungsphase des Kernels:

  1. Initialisieren die niedrigen Gerätetreiber, die in die vorherige Phase geladen wurden.
  2. Laden und initialisieren der anderen Gerätetreiber.
  3. Starten von Programmen wie z.B. Chkdsk, falls erforderlich.
  4. Laden und initialisieren Dienstleistungen (engl. Startenervices).
  5. Erstellen der Auslagerungsdatei (engl. Pagefile).
  6. Starten der Subsysteme, die Windows NT benötigt.

9. Einloggen

Wenn die Kernel-Initialisierung beendet ist, erscheint der Dialogkasten Anmeldung beginnen, welcher den Infotext "Drücken Sie Strg + Alt + Entf um sich anzumelden" enthält. Zu dieser Zeit initialisiert Windows NT immer noch die Netzwerktreiber, aber Sie können sich jetzt schon anmelden.

Beachten Sie, dass Windows NT diesen Start nicht als "gut" betrachtet, bis sich ein Benutzer erfolgreich beim System anmeldet hat. Erst dann wird die Konfiguration als "gut" gespeichert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0266.htm


Speichern der 'aktuellen Konfiguration' unterbinden

Speichern der "aktuellen Konfiguration" unterbinden

Windows speichert automatisch nach jedem erfolgreichen Bootvorgang die letzte Systemkonfiguration ab - Letzte als funktionierende bekannte Konfiguration (Last Known Good). Geht bei einer Installation etwas schief und das System kann nicht mehr gestartet werden, kann man so auf die letzte Konfiguration zurückgreifen. Dafür müssen Sie beim Starten von Windows die F8-Taste drücken.

Hat man aber einmal sein System konfiguriert, ändert man meist wenig am System und deshalb ist es nicht unbedingt nötig, dass Windows bei jedem Systemstart die aktuelle Konfiguration sichert. Mit folgenden Registryeintrag können Sie das unterbinden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "ReportBootOk" als Datentyp REG_SZ. Setzen Sie den Wert auf 0 bzw. wieder auf 1, um das Sichern wieder zu aktivieren.

Dadurch können Sie jetzt bestimmen, wann eine Konfiguration gesichert werden soll und bei Bedarf leicht einen bestimmten Systemzustand wieder herstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1175.htm


Nach Systemabschluss den Rechner ausschalten

Hinweise dazu von: Josef Gartner

Wenn die Auswahlmöglichkeit "APM aktivieren" in den Energieoptionen nicht gegeben ist, liegt das meist daran, wenn keine APM 1.2-Kompatibilität vorliegt oder wenn die Kompatibilität nicht bekannt ist, oder wenn die Funktion im BIOS nicht eingeschaltet ist (dann kann das Gerät auch gar nicht vorhanden sein).

A. Zur korrekten Funktion des automatischen Ausschaltens unter Windows 2000 und XP ist folgendes Voraussetzung:

Entweder

  • Vollständig ACPI-fähiges Board und BIOS (der PC muss auch als ACPI-PC installiert sein), besonders mit den ersten ACPI-Versionen (z.B. bei Asus) gibt es Probleme, BIOS updaten! Oder
  • APM-fähiges Motherboard und BIOS und zwar APM in der Version 1.2 (nicht frühere, im Gegensatz zu Windows 95/98, NT 4.0 mit HAL aus dem SP4), natürlich kann dies 3. Nur bei PC´s funktionieren, die über ein ATX-Netzteil verfügen oder bei PC´s, die bereits vor ATX-Zeiten mit entsprechenden Soft-Off-Funktionen herstellerseitig ausgestattet wurden (z.B. Siemens Nixdorf Scenic Pro-Serie).

Microsoft hat bei der Entwicklung viele Motherboards mit dem entsprechenden BIOS auf APM- bzw. ACPI-Fähigkeit getestet und entsprechende Listen erstellt, welche in die Setup-Routinen von Windows 2000/XP eingebunden wurden. Beim Setup wird Board und BIOS auf dessen Version abgefragt.

Entsprechend der Einträge in den Listen gibt es dabei verschiedene Ergebnisse:

  1. ACPI-kompatibel (automatische Installation als ACPI-PC, kein APM, ausschalten OK)
  2. APM 1.2-kompatibel (Installation als Standard-PC mit aktiviertem APM, ausschalten OK)
  3. nicht APM 1.2- oder ACPI-kompatibel (Installation als Standard-PC mit deaktiviertem APM, dieses lässt sich auch nicht nachträglich aktivieren, ja ist vielleicht im BIOS gar nicht vorhanden, kein automatisches Ausschalten, Ruhezustand, etc. möglich)
  4. nicht getestet, d. h. Kompatibilität unbekannt (Installation als Standard-PC mit deaktiviertem APM, lässt sich aber manuell aktivieren, standardmäßig kein automatisches Ausschalten bzw. Ruhezustand möglich)

Die Varianten 1-3 sind klar. Interessant ist ja eigentlich nur die Variante 4. Klar, dass MS nicht alles testen konnte und dementsprechend viele PC´s unbekannt sind. Man kann hier folgendes versuchen:

Unter

Systemsteuerung >Energieoptionen ist ein Reiter "APM" vorhanden. Hier kann man die <Systemsteuerung>

mittels eines Häkchens APM aktivieren. Funktioniert anschließend das automatische Ausschalten, ist das System APM 1.2-kompatibel. Ist das System nicht APM 1.2-kompatibel, so führt dies i. d. R. zu dem Ergebnis, dass beim Herunterfahren das System nicht abschaltet sondern ein Reboot durchgeführt wird oder es zu Systemhängern oder BlueScreens beim Ruhezustand kommt. Lt. MS ist dieses Verhalten nicht änderbar.

Folgende Versuche führen zu keinem Ergebnis:

  • Den Registry-Schlüssel "PowerDownAfterShutdown" von NT 4.0 gibt´s zwar auch noch unter Windows 2000, ein setzen des Schlüssels von 0 auf 1 bringt jedoch keine Änderung.
  • Programme zum automatischen Ausschalten (z.B. DeskOff von Fujitsu Siemens) funktionieren zwar, schalten den PC aber auch nicht aus, da auch diese auf Betriebssystemfunktionen aufsetzen und je nach aktiviertem bzw. deaktiviertem APM entweder nicht ausschalten oder den PC neu starten.

Folgender "Würgaround" umgeht das Problem:

Man aktiviert APM in den Energieoptionen, obwohl dies zu einem Neustart führt. Dann startet man jedoch über einen Bootmanager automatisch ein anderes Betriebssystem, z.B. DOS oder Linux, welches dann nichts anders macht, als ein Zusatzprogramm (Shareware) auszuführen, das den PC dann abschaltet. Allerdings ist das eine mehr als unelegante Lösung, da dies erstens zu verlängerten Abschaltzeiten führt und zweitens muss man beim Normalen PC-Start das gewünschte Betriebssystem manuell auswählen.

B. Zur korrekten Funktion des Automatischen Ausschaltens unter NT 4.0 ist folgendes Voraussetzung:

  • Das Board und BIOS muss APM in den Versionen 1.0, 1,1 oder 1.2 unterstützen. Mit ACPI kann NT noch nichts anfangen.
  • Der PC muß über ein ATX-Netzteil verfügen oder herstellerseitig bereits vor ATX-Zeiten mit entsprechenden Soft-Off-Funktionen ausgestattet worden sein (z.B. Siemens Nixdorf Scenic Pro-Serie) und entweder
  • Der PC-Hersteller stellt eine spezielle HAL zur Verfügung (z.B. Fujitsu Siemens, ehemals Siemens Nixdorf, mit dem Programm DeskOff, Teil von DeskView). Dies funktioniert nur bei OEM-Computerherstellern, weil Microsoft nur diesen diese spezielle HAL zur Verfügung gestellt hat. z.B. nicht bei einem Asus-Board, da Asus keine Komplett-PC´s herstellt. Oder 4. Auf dem PC ist mindestens ServicePack 4 installiert und es wird gesondert die spezielle HAL aus dem SP4 installiert. Dies funktioniert nur bei bestimmten Motherboards, meist finden sich auf den Herstellerseiten spezielle Hinweise dazu, von Asus wird z.B. die Vorgangsweise dazu ohne Herstelleruntersützung beschrieben. Zusätzlich muss dann 5. In der Registrierung der Schlüssel "PowerDownAfterShutdown" von 0 auf 1 gesetzt werden. Wenn daraufhin ein Restart anstatt des Abschaltens erfolgt, ist das APM-BIOS nicht kompatibel.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

stellen Sie unter "PowerdownAfterShutdown" als Datentyp REG_SZ den Wert auf 1. Dieser Wert hat aber lediglich unter NT 4 noch die gewünschte Funktion.

Info Eigentlich sollte sich dann der PC unter Windows 2000 beim Herunterfahren abschalten, sofern es sich um ein ATX-Modell handelt. Dies ist aber dann z.B. nicht der Fall, wenn man Windows 2000 absichtlich ohne ACPI installiert. Um das Abschalten dennoch zu erreichen, muss man in der Systemsteuerung unter "Energieoptionen" auf der Registerkarte "APM" die "Unterstützung für das Advanced Power Management" aktivieren. Wenn diese Registerkarte fehlt, muss man im Gerätemanager unter "Ansicht" -> "Ausgeblendete Geräte anzeigen" aktivieren. Dann wird in der Geräteliste auch der "Herkömmliche NT-APM Schnittstellenknoten" angezeigt, der vermutlich deaktiviert ist. Diesen Eintrag aktivieren, danach wird in den "Energieoptionen" auch die Registerkarte "APM" angezeigt.

Info Unter Umständen muss auch die "Herkömmliche APM Unterstützung für Windows NT 4.0" durch den Hardware-Assistenten nachinstalliert werden.

Info Unter Windows NT müssen Sie noch die Datei HAL.DLL aus dem Verzeichnis %SYSTEMROOT% gegen die Datei aus dem aktuellen Service Pack ersetzen. Dazu müssen Sie das Service Pack mit dem Parameter "/X" entpacken (siehe auch: Service Pack Installation). Jetzt finden Sie hier die Datei "HAL.DLL.SOFTEX", die Sie unter dem Namen "HAL.DLL" jetzt in das Verzeichnis %SYSTEMROOT% kopieren und damit die alte Datei "HAL.DLL" ersetzen.

Info Auf der folgenden Seite finden Sie noch weitere Infos und Lösungen zu diesem Thema: http://www.jasik.de/shutdown

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0227.htm


Windows NT/2000/XP Bootdiskette

Es ist nicht möglich, eine 100%ige Windows-Bootdiskette zu erstellen. Um Windows von Diskette zu starten, braucht man also trotzdem ein installiertes Windows auf Festplatte.

Warum eine Bootdiskette?

Es kann vorkommen, dass einige wichtige Boot-Dateien auf der Festplatte defekt sind oder sich etwas an den Partitionen geändert hat. Wenn Sie nun Windows auf einer NTFS-Festplatte haben, hätten Sie nicht die Möglichkeit, nur bestimmte Dateien zu ersetzen bzw. die BOOT.INI anzupassen.

Die Bootdiskette hingegen ist nur versionsabhängig, kann aber auf jedem Rechner verwendet werden. Es kann vorkommen, dass man nur die BOOT.INI anpassen muss, wenn NT auf unterschiedlichen Partitionen installiert wurde.

Notfalldiskette:

Sollten Sie eine Notfalldiskette besitzen, spricht nichts dagegen, diese zu benutzen. Aber eine Notfalldiskette hat den Nachteil, dass sie rechnerabhängig ist und dadurch nicht für andere Computer benutzt werden kann.

Man sollte aber trotzdem eine Notfalldiskette anlegen, da bei beschädigter Registry nur mit ihr die Sicherheits-IDs wiederhergestellt werden können (RDISK /F).

Erstellen einer Bootdiskette:

  1. Formatieren Sie eine Diskette unter Windows.
    Benutzen Sie keine unter DOS formatierte Diskette, da diese nach MSDOS .SYS und IO.SYS sucht und nicht nach der von Windows benötigten NTLDR
  2. Kopieren Sie folgende Dateien von der Startpartition auf die Diskette:
    (Es handelt sich um versteckte Dateien, deshalb muss vorher das Anzeigen dieser Dateien im Dateimanager aktiviert werden. Wichtig ist auch, dabei die Reihenfolge beim Kopieren zu beachten)
    1. NTDETECT.COM
    2. NTLDR
    3. NTBOOTDD.SYS (diese Datei ist nicht immer vorhanden und wird nur von sehr wenigen SCSI-Systemen benötigt)
    4. BOOT.INI

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0430.htm


Windows startet AUTOEXEC.BAT

Standardmäßig führt Windows die AUTOEXEC.BAT aus. Dabei werden darin enthaltende Werte für Prompt, Path und die SET-Kommandos ausgeführt. In der heutigen Zeit werden diese Einträge nicht mehr gebraucht und ein ausführen der AUTOEXEC.BAT ist nicht mehr nötig. Mit den folgenden Eintrag können Sie das ausführen der AUTOEXEC.BAT für den aktuellen Benutzer unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

fügen Sie einen neuen Eintrag als Datentyp REG_SZ namens "ParseAutoexec" ein und setzen ihn auf "0".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0437.htm


Windows über Tastatur ohne Abfrage neu starten

Wird Windows über "Start" -> "Beenden" -> "Computer herunterfahren" beendet, dauert das immer einige Zeit, da Windows erst alle offenen Programme usw. beendet.

Durch einen neuen Eintrag in der Registry können Sie Windows mit der Tastatur zu einen schnellen Neustart bewegen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

erstellen Sie hier einen neuen Wert als Datentyp REG_SZ mit dem Namen "EnableQuickReboot". Setzen Sie den Wert auf 1. Starten Sie nun Ihr System neu. Jetzt können Sie über die Tastatur durch gleichzeitiges Drücken von STRG+Shift+Alt+Entf das System ohne weitere Abfragen neu starten

Info Bedenken Sie, dass Windows hierbei keine offenen Programme beendet. Windows führt also kein richtiges "Shutdown" durch, dadurch kann es unter Umständen zu Datenverlust kommen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0629.htm


NT-Systemprozesse

Hier eine Auflistung der Standard Windows NT Prozesse, welche im Taskmanager angezeigt werden und beim Start von Windows automatisch geladen werden.

Systemprozess | Beschreibung
Leerlaufprozess | Prozess, der freie Prozessorzeit bekommt (Idle)
system | Windows NT Subsystem
smss.exe | Session Manager Subsystem
csrss.exe | Client/Server Runtime Subsystem (schützt Systemaufrufe)
winlogon.exe | Login-Dienst zur An- & Abmeldung
services.exe | Service Controller (steuert die Dienste)
lsass.exe | Local Security Authority Subsystem (lokaler Sicherheitsdienst)
spoolss.exe | Spooler Subsystem
locator.exe | Teil des Remote Procedure Call Systems (RPC)
systray.exe | Message-Bereich in Taskbar
rpcss.exe | Remote Procedure Call Subsystem
explorer.exe | Windows Explorer

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0618.htm


Administratoranmeldung über das Netzwerk deaktivieren

Standardmäßig wird bei NT ein Administratoraccount angelegt, der nicht deaktiviert werden kann. Dieser Account bietet durch seinen bekannten Namen eine gute Angriffsmöglichkeit über das Internet.

Aus diesem Grunde sollte man den Account auf Rechnern, die Internetzugang haben, mit einem Tool aus dem Resource Kit von MS bearbeiten.

Im Resource Kit gibt es das Programm "PASSPROP.EXE". Mit diesem Programm können Sie den Administratoraccount bearbeiten und einstellen, so dass keine Anmeldung über das Netzwerk mit diesem Account mehr möglich ist.

Der Aufruf lautet dazu:

PASSPROP /ADMINLOCKOUT

Info Lokal kann man sich mit diesen Account immer noch anmelden!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0519.htm


Entladen von Benutzerprofilen bringt Fehler bzw. dauert lange

Abmeldung von Benutzerprofilen bringt Fehler bzw. dauert lange

Beim Abmelden können möglicherweise eines oder mehrere der folgenden Probleme auf:

  • Ein Benutzerprofil wird nicht entladen.
  • Ein servergespeichertes Profil wird nicht zusammengeführt.
  • Die Größenbeschränkung für die Registrierung wird erreicht.
  • Das Abmelden nimmt viel Zeit in Anspruch, während die folgende Nachricht angezeigt wird:
    Einstellungen werden gespeichert...
  • Um diese(s) Problem(e) zu beheben, verwenden Sie das Tool UPHClean (User Profile Hive Cleanup Service). UPHClean überwacht den Computer beim Entladen von Benutzerprofilen und erzwingt die Freigabe von noch geöffneten Ressourcen. Der Computer kann dann die Benutzerprofile entladen und zusammenführen.

UPHClean ist ein Dienst (Name: User Profile Hive Cleanup), der bei der Benutzerabmeldung hilft, falls Registry-Keys nicht geschlossen werden können. Häufig tritt dies bei schlecht programmierten Programmen auf, die bei der Abmeldung zu langsam geschlossen werden.

Download: http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582

Mach der Installation ist die Anwendung als Dienst installiert und arbeitet automatisch bei Abmelden. Im Eventlog finden Sie entsprechende Informationen über die Aktionen des Dienstes.

Über die Registry können Sie noch folgende Einstellungen konfigurieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Service\ UPHClean\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "REPORT_ONLY" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Dienst ist aktiv und beendet die Prozesse (Standard)
1 | Es wird nur Protokolliert und keine Prozesse beendet

Erstellen Sie hier einen neuen Wert mit dem Namen "CALLSTACK_LOG" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Keine LOG-Datei (Standard)
1 | Ausführliche DEBUG-LOG Datei (geht auf die Geschwindigkeit)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2025.htm


Timeout Zeit für die Auswahl von Hardware-Profilen festlegen

Unter Windows können Sie verschiedene Hardwareprofile anlegen und damit beim Starten bestimmte Treiber nicht laden. Sobald Sie ein zusätzliches Hardwareprofil angelegt haben, erscheint beim Starten eine Liste mit den vorhandenen Profilen, wo Sie das gewünschte Profil auswählen können. Nach einer gewissen Zeit (Timeout), startet Windows automatisch mit dem Standardprofil.

Diese Zeit können Sie in der Oberfläche unter "Systemsteuerung" -> "System" -> Tabreiter "Hardware" -> Button "Hardwareprofile" Hier finden Sie unter "Auswahl der Hardwareprofile" den Eintrag "Das erste aufgeführte Profil auswählen, wenn in xx Sekunden keine Auswhal getroffen wurde.

In diesem Fenster können Sie auch neue Profile anlegen und die Profile über den Button "Eigenschaften" konfigurieren.

Diese Zeit können Sie über den folgenden Registryeintrag verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ DConfigDB

Erstellen Sie hier einen neuen Wert mit dem Namen "UserWaitInterval" als Datentyp REG_DWORD und geben Sie die Zeit in Sekunden als Dezimalwert ein.

Standardmäßig wird das erste Profil in 30 Sekunden automatisch geladen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2245.htm


Warnmeldungen beim Windowsstart ausschalten

Mit diesem Tipp können Sie die Warnmeldungen, welche beim Windowsstart angezeigt werden, ausschalten. Diese Warnmeldungen werden oftmals angezeigt, wenn es Probleme mit den Laufwerken oder Diensten gibt. Meistens sind diese Meldungen aber überflüssig und können deshalb bedenkenlos abgeschaltet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPopUpsOnBoot" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Meldungen Anzeigen(Standard)
1 | Keine Meldungen mehr Anzeigen

Siehe dazu auch Tipp: "Keine Fehlermeldungen anzeigen"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2640.htm


Desktop erst laden, wenn das Loginscript abgearbeitet ist

Wenn Sie wollen, dass Ihr Desktop erst nach dem vollständigen Abarbeiten der LoginScripts geladen wird, müssen Sie einen neuen Eintrag in der Registry einfügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "RunLogonScriptSync" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Windows Explorer (Desktop) erst nach abarbeiten des Loginskripts starten
0 (gelöscht) | Windows Explorer und Skripte gleichzeitig laden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Anmeldeskripts gleichzeitig ausführen

Info Diese Einstellung können Sie einfachmit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0359.htm


Profilverzeichnisse vom Serverabgleich ausschließen

Wenn Sie servergespeicherte Profile benutzen, wird das Profil bei der Anmeldung vom Server heruntergeladen und beim Abmelden wieder mit dem Server abgeglichen. Je nach Größe des Profiles kann das schon einige Zeit dauern, gerade wenn Verzeichnisse wie "Temporary Internet Files" mit abgeglichen werden, da Sie ja standardmäßig mit im Profilverzeichnis abgelegt sind.

Sie können das Profilverzeichnis natürlich verlegen/verschieben (s.Tipp: Ordner Dokumente und Einstellungen auf ein anderes Laufwerk legen). Sie haben aber auch noch die Möglichkeit, Verzeichnisse im Profilverzeichnis anzugeben, die nicht abgeglichen werden sollen, was bei Verzeichnissen die viel Daten enthalten können sinnvoll ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System

geändert werden. Hier einen neuen Wert mit dem Namen "ExcludeProfileDirs" als Datentyp REG_SZ eingeben. Geben Sie auch die Verzeichnisse an, die nicht abgeglichen werden sollen, trennen Sie dabei die unterschiedlichen durch ein Semikolon.

Info Sie dürfen hier nur relative Pfade, ab dem Profilverzeichnis, angeben also z.B.:
Temporary Internet Files;Application Data\Microsoft\Outlook

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Benutzerprofile
Einstellungsname: | Verzeichnisse aus Servergespeichertem Profil ausschließen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1119.htm


Entsperren einer Workstation dauert etwas

Wenn Sie eine gesperrte WS wieder freischalten wollen, kann es sein, dass es etwas dauert bis diese Aktion durchgeführt wird. Das kommt daher, dass Windows die Domainliste standardmäßig alle 2 Minuten updaten will. Das wird gemacht, damit neu angelegte USER auch bekannt sind und evtl. auch die Sperrung der WS aufheben können.

Die Zeit, wie oft die Domäneliste aktualisieren soll, können Sie in der Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Legen Sie hier einen Wert mit dem Namen "DcacheMinInterval" als Datentyp REG_DWORD an.

Sie können hier nun die Zeit in Sekunden angeben, in welchen Abständen die Liste aktualisiert werden soll. Die möglichen Werte müssen zwischen 120 und 86400 liegen. Der Standardwert ist 2 Minuten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=160839

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0934.htm


Windows Passwort vergessen, was tun?

Wenn Sie das Windows Passwort vergessen haben, gibt es mehrere Möglichkeiten, das Passwort zurückzusetzen. Das ist aber nur möglich, wenn der Rechner nicht besonders abgesichert wurde.

  1. Die einfachste Möglichkeit finden Sie unter "http://www.winternals.com". Hier finden sie zwei Programme: NT Locksmith und den ERD Commander, mit denen Sie leicht die Passwörter zurücksetzen können. Diese Programme sind aber kostenpflichtig. Diese Tools bieten auch noch weitere Möglichkeiten und sind für Administratoren fast ein Muss.
  2. Unter "http://www.lOpht.com" finden Sie das Programm LOphtCrack, welches versucht, das Passwort mit Hilfe der SAM zu entschlüsseln. Dafür müssen Sie aber im Besitz der aktuellen SAM des Rechners sein, der das Benutzerkonto verwaltet.
  3. Linux Bootdisk: http://home.eunet.no/~pnordahl/ntpasswd/bootdisk.html
  4. CIA Commander. Mächtiges Tool mit umfangreichen Möglichkeiten. Eine Kurzbeschreibung und einen Link finden Sie unter Netzwerktools .

Diese Programme führen meist zum Erfolg, solange nicht die SAM mit dem Programm SYSKEY (ab Service Pack 3) besser verschlüsselt wurde.

Info Diese Möglichkeiten stellen keine Sicherheitslücken von NT dar. Normalerweise sollten Anwender in einem Netzwerk sowieso keine Möglichkeit haben, auf die Hardware der Server zuzugreifen, so dass die oben genannten Tools dort nicht eingesetzt werden können. Des Weiteren kann man durch gute Wahl des Passwortes und mit einigen Tools von NT die Sicherheit so steigern, dass man auch mit diesen Tools nicht zum Erfolg kommt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0937.htm


Meldung: 'Kein Domain-Controller gefunden' ausschalten

Meldung: "Kein Domain-Controller gefunden " ausschalten

Wird beim Anmelden unter Windows kein Domain-Controller gefunden, gibt Windows eine entsprechende Meldung aus und versucht die Anmeldung mit den zwischengespeicherten Informationen fortzusetzen.

Wenn man Windows auf einem Notebook einsetzt ist diese Meldung aber lästig und wird nicht benötigt. Durch einen entsprechenden Eintrag in der Registry können Sie diese Meldung unterdrücken und Windows versucht sie gleich mit den zwischengespeicherten Informationen anzumelden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Eintrag mit dem Namen "ReportDC" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0, um die Meldung zu deaktivieren bzw. wieder auf 1, um die Meldung wieder anzuzeigen.

Info Beachten Sie dazu auch die Hinweise unter "Wie kann man die lokale Anmeldung ohne Serververbindung unterbinden?". Hier steht beschrieben, wie Sie einstellen können, wie oft man sich ohne Server anmelden kann. Ansonsten werden die lokalen Informationen mit der Zeit ungültig.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1036.htm


Lokales Profil laden, wenn das Anmelden über eine langsame Verbindung erfolgt

Wenn man sich über eine langsame RAS-Verbindung an einen Server anmeldet, ist es besser, wenn das lokale Profil geladen wird und nicht das ganze Profil über die RAS-Verbindung geladen werden muss.

Durch Setzen eines Registry-Wertes können Sie bestimmen, ob bei langsamen Verbindungen das lokale Profil verwendet werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie einen Wert mit dem Namen "SlowLinkProfileDefault" als Datentyp REG_DWORD

1 | Profil immer über die Verbindung laden (Standard bei NT 4.0)
0 | bei langsamen Verbindungen lokales Profil verwenden (Standard bei Windows 2000)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0843.htm


Wie kann man die lokale Anmeldung ohne Serververbindung unterbinden?

Wenn der Server nicht zu Verfügung steht, gibt Windows bei der Anmeldung eine entsprechende Meldung aus und versucht, die Anmeldung mit den lokalen Benutzerinformationen durchzuführen. Unter gewissen Umständen kann dieses Verhalten nicht gewünscht sein.

Es gibt zwei Möglichkeiten. um das zu verhindern.

In der ersten Beschreibung wird eingestellt, dass beim Abmelden jeweils das lokale Benutzerprofil gelöscht werden soll. Dies hat aber den Nachteil, dass bei jedem Anmelden das ganze Profil über das Netzwerk neu geladen werden muss.

Im zweiten Beispiel wird das Benutzerprofil nicht von der lokalen Festplatte gelöscht, so dass beim Anmelden nur die Änderungen am Profil übertragen werden müssen, welches den Anmeldevorgang bei langsamen Verbindungen erheblich beschleunigt. Hier wird lediglich durch einen extra Registry-Schlüssel ein Anmelden ohne Server unterbunden.

Folgendes ist bei beiden Tipps zu beachten:

  1. Die User dürfen nicht als lokale User auf ihren Arbeitsstationen eingetragen sein.
  2. Im Benutzer-Manager für Domänen müssen unter Profile "User Profile Path" die Pfade für serverbasierte Profile für die fraglichen User richtig gesetzt werden (\\Server\netlogon).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Tipp 1:

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

erstellen Sie einen neuen Wert mit dem Namen "DeleteRoamingCache" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

Nun müssen noch evtl. lokal gespeicherte Benutzer-Profile der fraglichen Benutzer über "START" -> "Einstellungen" -> "Systemsteuerung" -> "System" -> "User Profiles" gelöscht werden.

Ist dies geschehen, können sich die Mitarbeiter ganz Normal einloggen, sofern eine Serververbindung aufgebaut wird. Bei Beendigung der ersten "Sitzung" werden die benutzerspezifischen Daten an den Server übergeben und die Speicherung auf der Workstation gelöscht. Bei einer fehlenden Serververbindung sollte es den Benutzern nun nicht mehr möglich sein, sich mit der eigenen User ID lokal auf der Workstation anzumelden, da kein (gecachetes) Profil vorhanden ist.

Tipp 2:

Tragen Sie unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ Current Version\ Winlogon

einen neuen Wert mit dem Namen "CachedLogonsCount" als Datentyp REG_SZ ein. Setzen Sie den Wert auf 0.

Unter "CachedLogonsCount" können Sie angeben, wie viele Profile (von verschiedenen Accounts) für die Anmeldung ohne Netzwerk gespeichert werden sollen. Wenn Sie diesen Wert auf 0 setzen ,kann sich ein Anwender ohne Server nicht mehr anmelden.

Die mögliche Werte für CachedLogonsCount liegen zwischen 0 und 50.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0396.htm


Anmeldung ohne [Strg_Alt_Entf]

Anmeldung ohne [Strg+Alt+Entf]

Unter Windows NT müssen Sie zur Anmeldung immer die 3 Tasten Strg+Alt+Entf drücken. Für den privaten Einsatz ist das meist etwas unpraktisch.

Bei NT können Sie nur einstellen, dass eine automatische Anmeldung erfolgen soll. Das hat aber den Nachteil, dass Ihr System nicht mehr abgesichert ist.

Durch Austauschen der GINA.DLL mit einem Freeware-Programm können Sie die Anmeldung vereinfachen.

Die neue GINA.DLL können Sie unter http://wwwthep.physik.uni-mainz.de/~frink/nt.htmlherunterladen.

Bei diesen Programm können Sie die Tasten für das Anmelden deaktivieren und haben sogar die Möglichkeit, beim Abmelden/Herunterfahren ein Script ausführen zu lassen.

Info Bedenken Sie, dass der Autor keine Haftung für das Programm übernimmt. Bei einer fehlerhaften GINA.DLL kann es passieren, dass Sie sich nicht mehr an Ihrem System anmelden können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0575.htm


Login Bildschirmschoner ein-/ausschalten

Wenn Sie einen eigenen Bildschirmschoner unter Windows einstellen, hat das keinen Einfluss auf den Login-Bildschirmschoner. Wenn niemand am Rechner angemeldet ist, wird standardmäßig der Windows ScreenSaver geladen. Wenn Sie hier einen anderen Bildschirmschoner verwenden möchten, müssen Sie das über die Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.Default\ Control Panel\ Desktop

Schlüssel | Datentyp | Angabe als | Standard
Gibt an, ob ein ScreenSaver angezeigt werden soll. Mit 1 wird der ScreenSaver aktiviert.
ScreenSaveActive | REG_SZ | Boolean | 1
Gibt den Namen des zu verwendenden Bildschirmschoners an.
SCRNSAVE.EXE | REG_SZ | Dateiname | SS3DFO.SCR
Legt die Zeit fest wann der Screensaver geladen werden soll.
ScreenSaveTimeOut | REG_SZ | Sekunden | 30

Wird nach einem Neustart aktiv.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0174.htm


Info anzeigen beim Anmelden eines Users

siehe: Selbstdefinierte Logon Texte

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0172.htm


Eigenes Logo auf dem Anmeldebildschirm von Windows

Erstellen Sie ein Bild und speichern Sie es im Windows-Verzeichnis als BMP-Datei ab. Wichtig ist dabei, dass Sie nur 8 Zeichen als Dateinamen verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS \.DEFAULT\ Control Panel\ Desktop

Wenn der Eintrag "Wallpaper" nicht vorhanden ist, erstellen Sie ihn neu als Datentyp REG_SZ und weisen Sie als Wert den Dateinamen des Logos mit kompletter Pfadangabe zu.

Folgende Werte können Sie noch als Datentyp REG_SZ Typ erstellen und anpassen:

TileWallpaper | 1 -> Bild wird gekachelt 0 -> Bild wird zentriert auf den Bildschirm dargestellt
WallpaperStyle | 0 -> Normal 2 -> vergrößern auf den ganzen Bildschirm
Folgende Einstellungen werden nur ausgewertet, wenn "TileWallpaper"="0" ist.
WallpaperOriginX | Abstand vom linken Bildschirmrand (in Pixel)
WallpaperOriginY | Abstand vom oberen Bildschirmrand (in Pixel)

Info Durch Löschen des Wertes (also Eintrag "Wallpaper" leer) kann auch das Logo weggelassen werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0402.htm


Anmeldebildschirm ohne Eintrag

Dieser Eintrag bewirkt, dass in der Anmeldemaske (nach STRG+ALT+ENTF) der zuletzt angemeldete Benutzer nicht dargestellt wird. Dies ist bei Rechnern, die von verschiedenen Usern genutzt werden, manchmal aus Sicherheistgründen sehr sinnvoll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

dort den Eintrag "DontDisplayLastUserName" als Datentyp REG_SZ anlegen und den Wert "1" zuweisen.

Mögliche Werte

1 | keine Anzeige
0 | eine Anzeige (default)

Unter Windows 2000 kann dieser Eintrag noch an einer zweiten Stelle angegeben werden. Dieser Eintrag hat Vorrang vor der oben angegebenen Adresse. Wenn beide Einträge vorhanden sind, wird der obere durch folgenden Eintrag überschrieben.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Entweder löschen Sie diesen Eintrag, dann wird wieder der obere ausgewertet, oder Sie setzen hier den Wert "DontDisplayLastUserName" als Datentyp REG_DWORD auf die gewünschte Einstellung.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Interaktive Anmeldung: Letzten Benutzernamen nicht anzeigen

Nur Windows 98/ME

Unter:

HKEY_LOCAL_MACHINE\ Network\ Logon

Erstellen Sie einen neuen Eintrag mit den Namen "DontShowLastUser" als Datentyp REG_SZ und setzen den Wert auf 1, um den Namen auszublenden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0400.htm


Anpassen der Logon-Hintergrundfarbe

Unter "Eigenes Logo auf dem Anmeldebildschirm von NT" wird gezeigt, wie Sie sich ihr eigenes Logo unter NT einbinden können.

Sie können aber auch noch die Hintergrundfarbe nach Ihren Wünschen anpassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.DEFAULT \Control Panel\ Colors

finden Sie den Eintrag "Background" als Datentyp REG_SZ. Diesem Wert können Sie nun die gewünschte Farbe im Format "RR GG BB" zuweisen. Ersetzen Sie "RR", "GG" und "BB" durch den jeweiligen Farbanteil Rot, Grün und Blau.

Farbe | RR | GG | BB
Rot | 255 | 0 | 0
Grün | 0 | 0 | 255
Gelb | 255 | 255 | 0
Cyan | 0 | 255 | 255
Magenta | 255 | 0 | 255
Braun | 42 | 42 | 42
Weiß | 255 | 255 | 255
Schwarz | 0 | 0 | 0

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0401.htm


Herunterfahren im Anmelde-Screen ein/ausblenden

Standardmäßig ist bei der Server-Version im Anmeldebildschirm "Herunterfahren" nicht zu sehen. Man muss sich erst anmelden, um den Server herunterfahren zu können. Aus Sicherheitsgründen sollten Sie das auch so lassen, damit nicht jeder den Server herunterfahren kann. Wollen Sie aber trotzdem diesen Eintrag wiederhaben oder diesen Eintrag auch bei einer Workstation verstecken, können Sie dies in der Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

oder als Policies [für den Anwender]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

setzen Sie den Wert "ShutdownWithoutLogon" als Datentyp REG_SZ auf "1".

Wenn Sie den Eintrag auf "0" setzen, können Sie "Herunterfahren" auch auf der Workstation ausblenden.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Windowseinstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Herunterfahren: Herunterfahren des Systems ohne Anmeldung zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0173.htm


Anmeldeoptionen unter Windows

Wenn Sie sich unter Windows anmelden, sehen Sie die Anmeldeoptionen (Domäne / DFÜ usw.). Bzw. ab Windows 2000 können Sie die über den Button "Optionen" einblenden.

Wenn Sie wollen, dass diese Informationen bei jeden Start ausgeblendet sind, ändern Sie folgenden Wert in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Hier finden Sie den Wert "ShowLogonOptions" als Datentyp REG_DWORD, setzen Sie den Wert auf 0 und die Infos werden nicht mehr angezeigt. Der Standardwert ist 1.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0911.htm


Autologon kann mit der Shift-Taste unterbunden werden

Wenn Sie, wie in "Autologin beim Starten" beschrieben, die Autologon-Funktion eingeschaltet haben, können Sie durch Drücken der Shift-Taste beim Windowsstart das wieder ausschalten. Sie können sich dann mit einen beliebigen anderen Account anmelden.

Wenn Sie diesen Tipp aktivieren, kann der Loginvorgang nicht mehr mit der Shift-Taste unterbunden werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "IgnoreShiftOverride" als Datentyp REG_SZ. Setzen Sie den Wert auf:

1 | Shift-Taste deaktivieren
0 | Shift-Taste aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1598.htm


Abbrechen des Login-Scriptes verhindern

Abbrechen des Login-Skripts verhindern

Wird bei der Anmeldung ein "Login-Script" gestartet, hat der Anwender die Möglichkeit über den X-Button, das Login-Script vorzeitig abzubrechen. In den meisten Fällen ist das natürlich nicht gewünscht, da hier oft nötige Einstellungen vorgenommen werden sollen.

Damit der Anwender keine Möglichkeit hat das Login-Script abzubrechen, werden zwei Tools benötigt:

KIX32.EXE

Dieses Tool können Sie sich unter "http://www.kixtart.org/" kostenlos herunterladen. Dieses Tool ist eigentlich eine Erweiterung der Batch Sprache. Sie können also Ihr Login auch hiermit schreiben. Wir benutzen die Datei aber nur, um den X-Button entsprechend zu deaktivieren und arbeiten dann wieder mit der Windows-Batch weiter.

SCRIPTIT.EXE

Dieses Tool können Sie sich unter "http://brianchan.ca/upload/index.php?direction=0&order=rating&directory=" kostenlos herunterladen. Es ist ein Tool von MS (Infos: "http://www.microsoft.com/technet/archive/winntas/downloads/scriptit.mspx"). Damit kann man bestimmte Befehle an entsprechende Anwendungen senden. Wir verhindern damit, dass ein schlauer Anwender den Taskmanager aufrufen und darüber die Batch entsprechend beenden kann (wird nur gebraucht, wenn Sie die Benutzung des Taskmanager nicht sowieso für die Anwender ausgeschaltet haben).

KILL.EXE

Um einen Prozess endgültig beenden zu können. Im Beispiel wird der Befehl TASKKILL benutzt, den es unter Windows XP gibt.

Wenn Sie noch mit einem anderen Betriebssystem arbeiten, müssen Sie sich dafür KILL.EXE besorgen. Sie finden einen Download z.B unter: "http://www.pcwelt.de/index.cfm?pid=662&pk=22162&p=2" bzw. einfach in Google nach KILL.EXE suchen.

Wie gehen Sie jetzt vor:

  1. Sie kopieren Ihre eigentliches Loginscript um z.B. in "LOGIN_START.CMD" dieses Starten wir dann später abgesichert
  2. Sie erstellen auf dem Logonserver in Netlogon ein Verzeichnis Tools und legen da folgende Dateien ab:

    3. SCRIPTIT.EXE

    KIX32.EXE

    logon.kix

    TaskManager.si

    Die Datei "logon.kix" ist die Batchdatei für KIX. Da wir die Befehle von KIX hier nicht benutzen wollen, enthält diese Textdatei nur folgenden Eintrag:

    === Hier schneiden ===
    EXIT

    === Hier schneiden ===

    Die Datei "TaskManaer.si" ist die Steuerdatei für Scriptit.exe und soll den Aufruf des Taskmangers während des Login-Vorganges unterbinden, in diese Textdatei tagen Sie bitte folgendes ein:

    === Hier schneiden ===

    [SCRIPT]

    [ADLIB]

    Windows Task-Manager=~winclose

    === Hier schneiden ===

  3. Erstellen Sie jetzt ein neues Loginscript mit den alten Namen "LOGIN.CMD" (dadurch brauchen Sie die Einstellung im Account des Users nicht zu ändern). Hier tragen Sie jetzt folgendes ein:

    4. === Hier schneiden ===
    @echo off
    %LOGONSERVER%\netlogon\Tools\KIX32.EXE %LOGONSERVER%\netlogon\Tools\logon.kix>NUL
    start %LOGONSERVER%\netlogon\Tools\scriptit.exe %LOGONSERVER%\netlogon\Tools\TaskManager.si>NUL

    CALL %LOGONSERVER%\netlogon\Login_Start.cmd

    === Hier schneiden ===

    Diese Datei wird jetzt als Erste bei der Anmeldung gestartet. Im der ersten Zeile wird die Bildschirmausgabe der Befehle ausgeschaltet. Anschließend wird KIX gestartet um das X auszublenden. Dabei startet KIX nur kurz und beendet sich sofort wieder. Das führt aber dazu, dass auch das X für den gesamten LOGIN-Vorgang gesperrt ist (INFO: Das geht nur in Login-Prozess, wenn Sie die Batch so starten, bleibt das X Aktiv).

    Jetzt müssen Sie noch ans Ende Ihren Login-Skripts (hier die Datei LOGIN_START.CMD) hinzufügen das Scriptit.exe beendet wird, ansonsten bleibt das Programm gestartet. Dafür müssen Sie den entsprechende Prozess einfach beenden. Fügen Sie dazu folgende Zeile am Ende hinzu:

    === Hier schneiden ===
    %SystemRoot%\System32\taskkill /F /IM "SCRIPTIT.EXE" /T>NUL
    === Hier schneiden ===

Info Jeweils immer den Inhalt zwischen "=== Hier schneiden ===" in die angegebene Datei kopieren und abspeichern.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1813.htm


Abbrechen von Startprogrammen (Autostart) über Shifttaste deaktivieren

Mit diesem Tipp können Sie einstellen, dass durch Drücken der Shift-Taste nicht mehr das Ausführen von Programmen aus dem Autostartordner unterbunden werden kann. Wie im Tipp "Ausführen des Autostart Ordners verhindern" beschrieben, kann durch das Gedrückthalten der Shift-Taste während der Anmeldung, das Ausführen der Programme aus dem Autostartordner verhindert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "IgnoreShiftOveride" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Ausführen von Autostart bleibt möglich
0 | Ausführen von Autostart kann über Shifttaste ausgeschaltet werden (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2624.htm


Aufhebung einer Sperrung der Arbeitsstation geht auch mit gelockten Account

Übergehen einer Arbeitsstation-Sperrung - auch bei gelockten Account

Mit diesem Tipp können Sie einstellen, dass beim Entsperren einer Arbeitsstation überprüft wird, ob der Account nicht in der Domäne zwischenzeitlich gelockt wurde und somit eine Anmeldung nicht zugelassen werden soll.

Wird ein Passwort öfters fehlerhaft eingegeben, so wird das Konto in der Domäne gesperrt und weitere Anmeldeversuche werden unterbunden. Ist der Rechner aber nur gesperrt worden oder durch das Ausführen des Passwort-gesicherten-Bildschirmschoners, so wird nach dem Benutzerpasswort gefragt. Dabei erfolgt standardmäßig keine Überprüfung, ob der Account zwischenzeitlich nicht schon gesperrt wurde. Somit können beliebige Anmeldeversuche durchgeführt werden, was eine Sicherheitslücke darstellen kann.

Wenn Sie den Eintrag "ForceUnlockLogon" aktivieren (Festlegung auf "1"), erfolgt eine Überprüfung ob der Account in der Domäne gesperrt wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceUnlockLogon" als Datentyp REG_DWORD und setzen den Wert auf:

0 | keine Überprüfung ob der Account gesperrt wurde (Standard)
1 | Überprüfung ob der Account gesperrt wurde

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2633.htm


Control-Panel [ALT-TAB] erweitern

Zwischen laufenden Programmen können Sie mit der Tastenkombination [ALT + TAB] umschalten. Wenn Sie viele Fenster geöffnet haben, können nicht mehr alle in diesem Auswahlfenster angezeigt werden. Durch einen Eingriff in die Registry können Sie aber die Größe der Anzeige Ihren Bedürfnissen anpassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\

finden Sie folgende Werte:

Schlüssel | Datentyp | Angabe als | Standard
"0" Deaktiviert die Funktion
CoolSwitch | REG_SZ | Zahl | 1
Legt die Anzahl der Spalten in der Anzeige fest
CoolSwitchColumns | REG_SZ | Zahl | 7
Legt die Anzahl der Zeilen in der Anzeige fest
CoolSwitchRows | REG_SZ | Zahl | 3

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0261.htm


Cool Switch-Funktion (ALT+TAB) aktivieren/deaktivieren

Über die "Cool Switch"-Funktion kann mit der Tastenkombination Alt+Tabulator zwischen den laufenden Anwendungen umgeschaltet werden. Mit diesem Tipp können Sie die "Cool Switch"-Funktion aus/einschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "CoolSwitch" als Datentyp REG_SZ und setzen den Wert auf:

0 | Cool Switch deaktivieren
1 | Cool Switch aktiv (Standard)

Weitere Einstellungen finden Sie unter: Control-Panel [ALT-TAB] erweitern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2476.htm


Desktop Themes mit Windows NT 4.0 / 2000

Wenn man unter Windows 95 MS Plus installiert hat, kann man die Windows 95 Desktop Themes auch unter Windows NT 4.0 verwenden.

Kopieren Sie die Dateien THEMES.CPL und THEMES.EXE aus dem Windows 95-Verzeichnis "Windows\System" in das Windows NT-Verzeichnis \%SYSTEMROOT%\System32.

Nun sollte in der NT 4.0 - Systemsteuerung das Desktop Themes - Icon erscheinen.

Kopieren Sie alle Dateien aus dem Verzeichnis "Windows\Msapps\Grphflt" nach \%SYSTEMROOT%\System32, stehen Ihnen auch die Hintergrundbilder zur Verfügung

Sie finden die Datei auch im Internet unter: http://support.microsoft.com/download/support/mslfiles/themes.exe

Info Haben Sie MS Office 97 bzw. MS FrontPage 2.0 installiert, funktioniert THEMES.EXE aus MS Plus nicht mehr. Sie müssen diese Datei durch die THEMES.EXE ersetzen, die mit diesen Anwendungen geliefert wurde (Verzeichnis "\Patches" auf der MS Office-

Info Unter Windows 2000 ist diese Datei zum Aktivieren solcher Themes ebenfalls vorhanden, lässt sich allerdings nur über "START" -> "Ausführen" -> "Themes.exe" starten.
Kopiert man sich die Datei Themes.cpl aus der Datei Win_98_54.cab von der Windows 98 CD nach C:\Winnt\System32, steht das Icon für die Themes ab sofort auch in der Systemsteuerung zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0118.htm


Neustart der Oberfläche bei Fehler unterbinden

Wenn unter Windows auf der Oberfläche bzw. einer Date,i die mit der Oberfläche zusammenhängt (Explorer), ein Fehler auftritt, wird automatisch die Oberfläche (Shell) neu geladen. Den automatischen Neustart der Oberfläche können Sie unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Ändern Sie hier den Wert "AutoRestartShell" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0.

Wenn jetzt nach einem Fehler die Oberfläche nicht mehr ordnungsgemäß. arbeitet, müssen Sie durch An und Abmelden selber für einen Neustart der Oberfläche sorgen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0902.htm


Konfigurieren der Anzeige des Eingabegebietsschema-Leiste auf dem Desktop

Konfiguration der Desktop-Anzeige für die Eingabegebietsschema-Leiste

Mit diesem Tipp können Sie einstellen, ob die Eingabegebietsschema-Leiste auf dem Desktop angezeigt werden soll. Über diese Leiste können Sie zwischen verschiedenen Tastatureinstellungen (Sprachen) wechseln.

Die Konfiguration der Eingabegebietsschema-Leiste finden Sie unter "Start" -> "Systemsteuerung" -> "Regions- und Sprachoptionen" (bzw. mit Aufruf der Datei "INTL.CPL") -> gehen Sie auf den Tabreiter "Sprachen" und klicken hier auf den Button "Details...".

Dort finden Sie auf dem Tabreiter "Einstellungen" den Button "Eingabegebietsschema-Leiste..." womit Sie die Anzeige auf dem Desktop konfigurieren können.

In der Registry finden Sie die Einstellung unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ CTF\ LangBar

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowStatus" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Gebietsschema-Leiste wird angezeigt
3 | Gebietsschema-Leiste wird nicht angezeigt

Mit dem Wert "Transparency" als Datentyp REG_DWORD können Sie einstellen, ob die Leiste transparent angezeigt werden soll. Die Werte als Dezimalwerte eingeben:

128 | Gebietsschema-Leiste, um sie aktiv transparent anzuzeigen
255 | Gebietsschema-Leiste wird immer normal angezeigt (nicht transparent)

Mit dem Wert "ExtraIconsOnMinimized" als Datentyp REG_DWORD können Sie einstellen, ob beim Minimieren der Gebietsschema.eiste zusätzliche Icons in der Taskleiste angezeigt werden sollen, um die Einstellungen weiterhin bearbeiten zu können:

0 | Keine zusätzlichen Symbole oberhalb der Taskleiste anzeigen
1 | Zusätzliche Symbole oberhalb der Taskleiste anzeigen

Mit dem Wert "Label" als Datentyp REG_DWORD können Sie einstellen, ob eine längere Bezeichnung in der Gebietsschemaleiste angezeigt werden soll:

0 | Keine zusätzliche Bezeichnung anzeigen
1 | Symboltitel auf Eingabegebietsschema-Leiste anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2630.htm


Taskmanager beim Windows-Start automatisch in den Systray legen

Wenn Sie wollen, dass der Taskmanager beim Starten von Windows automatisch mit gestartet und in den Systray gelegt wird, müssen Sie folgendes in die Registry Eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

legen Sie einen neuen Eintrag an (z.B. mit dem Namen "TaskManager") als Datentyp REG_SZ und tragen hier folgendes ein:

"%SystemRoot%\system32\cmd.exe" /c "start /min %SystemRoot%\system32\taskmgr.exe"

Info %SystemRoot% müssen Sie durch Ihren Pfad zum Windowsverzeichnis ersetzen (Sie können bei REG_SZ nicht mit Variablen arbeiten). Wenn Sie den Pfad nicht wissen, öffnen Sie eine Eingabeaufforderung und geben Sie folgendes ein: echo %SystemRoot%
Beispiel: "C:\Windows\system32\cmd.exe" /c "start /min C:\Windows\system32\taskmgr.exe"

Nach einem Neustart wird nun der Taskmanager geladen und im Systray abgelegt.

oder

Statt des beschriebenen REG-Patches kann man auch folgendes machen:

Der Taskmanager lässt sich auch durch Ziehen (Datei taskmgr.exe aus dem "%SystemRoot%\System32"-Verzeichnis) in die Autostartgruppe legen und durch Einstellen der Eigenschaft "minimiert ausführen" beim Windows-Start ausführen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0500.htm


Icons im Tray verhindern

Einige Dienste erstellen ein Icon im Tray (rechts unten in der Startleiste neben der Uhr). So z.B. auch die Druckerwarteschlange, wenn Aufträge vorhanden sind.

Ob ein Dienst hier ein Icon einblendet, kann in der Systemsteuerung eingestellt werden.

Bei NT 4.0:

"Start" -> "Einstellungen" -> "Systemsteuerung" -> "Dienste"

Suchen Sie hier den entsprechenden Dienst für das entsprechende Programm und ändern Sie unter "Startart" einfach die Option "Interaktive Beziehung mit Desktop erlauben" nach Ihren Wünschen.

Ab Windows 2000 finden Sie diese Option unter:

"Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Dienste" hier den Dienst auswählen und unter "Eigenschaften" -> "Anmelden" den Eintrag "Datenaustausch zwischen Dienst und Desktop zulassen" nach Ihren Wünschen einstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0955.htm


Text hinter der Uhrzeit anzeigen

Wenn Sie hinter der aktuellen Uhrzeit noch einen Text anzeigen wollen, können Sie das durch eine Veränderung in der Registry erreichen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Control Panel\ International

Finden Sie die Einträge "s1159" und "s2359" als Datentyp REG_SZ. Diese Einträge sind für die Englische Uhrzeit gedacht und enthalten:

s1159 | Zeichenfolge hinter der Uhrzeit vor 12:00 Uhr. Standard-Einstellung ist AM
s2359 | Zeichenfolge hinter der Uhrzeit nach 12:00 Uhr. Standard-Einstellung ist PM

Da diese Werte in der 24-Stunden Anzeige nicht belegt werden, können Sie hier auch einen beliebigen Text eintragen, der angezeigt werden soll (z.B. Uhr). Damit der Text auch angezeigt wird, müssen Sie den Eintrag "sTimeFormat" als Datentyp REG_SZ noch um ein "tt" erweitern (also: "HH:mm:ss tt").

Für die Änderung am Wert "sTimeFormat" muss die Shell neu gestartet werden (neu anmelden). Die Werte aus "s1159" und "s2359" werden jede Minute ausgelesen und dementsprechend aktualisiert. Hier könnte man also über ein Script kurze Informationen eintragen, die dann neben der Uhrzeit angezeigt werden.

Standardmäßig stehen die Werte für die Anzeige der Uhrzeit auf:

Wertname | Eintrag
s1159 | <leer> *)
s2359 | <leer> *)
sTimeFormat | HH:mm:ss
iTimePrefix | 0
sTime | ;

Info *) Für <leer> geben Sie bitte nichts ein.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2479.htm


Der Tabreiter "Sicherheit" wird nicht angezeigt bzw. soll entfernt werden

Wenn Sie im Explorer auf einem Laufwerk oder Verzeichnis mit der rechten Maustaste klicken, können Sie aus dem Kontextmenü den Eintrag Eigenschaften auswählen.

Hier wird Ihnen jetzt ein Fenster angezeigt, welches unterschiedliche Tabreiter enthält. Bei Laufwerken, die mit NTFS formatiert wurden, gibt es auch den Tabreiter "Sicherheit". Wenn dieser Tabreiter nicht angezeigt wird, kann es an folgenden Punkten liegen:

  • Ab Windows 2000 kann der Tabreiter über die Einstellungen in den "Ordneroptionen" -> Tabreiter "Ansicht" über "Einfache Dateifreigabe verwenden (empfohlen)" ausgeblendet werden. Dieser Eintrag darf nicht aktiv sein.
  • In der Home-Version von Windows ist dieser Tabreiter auch nicht vorhanden
  • Es muss sich - wie oben geschrieben - um eine NTFS-Partition handeln. Bei FAT-Partitionen gibt es diesen Tabreiter nicht.

Sind die oberen Punkte alle OK, kann es auch noch an einem fehlenden Registryeintrag liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für Laufwerke unter:

HKEY_CLASSES_ROOT\ Drive\ shellex\ PropertySheetHandlers\

und für die Ordner unter:

HKEY_CLASSES_ROOT\ Directory\ shellex\ PropertySheetHandlers\

muss der Unter-Schlüssel "{1F2E5C40-9550-11CE-99D2-00AA006E086C}" vorhanden sein. Wenn nicht, legen Sie diesen Unter-Schlüssel einfach neu an.

Beispiele

Für Ordner: "HKEY_CLASSES_ROOT\ Directory\ shellex\ PropertySheetHandlers\ {1F2E5C40-9550-11CE-99D2-00AA006E086C}"

Für Laufwerk: "HKEY_CLASSES_ROOT\ Drive\ shellex\ PropertySheetHandlers\ {1F2E5C40-9550-11CE-99D2-00AA006E086C}"

Damit die oberen Einträge fehlerfrei Laufen, müssen die folgenden Registryeinträge vorhanden sein. Wenn nicht kopieren Sie die Einträge in eine .REG-Datei und führen Sie die Datei im Explorer aus.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{1f2e5c40-9550-11ce-99d2-00aa006e086c}]

@="Security Shell Extension"

"AppId"="{1f2e5c40-9550-11ce-99d2-00aa006e086c}"

"LocalizedString"=hex(2):40,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,\

6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\

00,5c,00,72,00,73,00,68,00,78,00,33,00,32,00,2e,00,44,00,4c,00,4c,00,2c,00,\

2d,00,35,00,39,00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{1f2e5c40-9550-11ce-99d2-00aa006e086c}\Elevation]

"Enabled"=dword:00000001

"IconReference"=hex(2):40,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,\

6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\

00,5c,00,69,00,6d,00,61,00,67,00,65,00,72,00,65,00,73,00,2e,00,64,00,6c,00,\

6c,00,2c,00,2d,00,33,00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{1f2e5c40-9550-11ce-99d2-00aa006e086c}\InProcServer32]

@="rshx32.dll"

"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]

"{1F2E5C40-9550-11CE-99D2-00AA006E086C}"="NTFS Sicherheitsseite

=== Hier schneiden ===

Tabreiter Sicherheit aus den Eigenschaften entfernen

Durch Löschen dieses Schlüssels "{1F2E5C40-9550-11CE-99D2-00AA006E086C}" können Sie so natürlich auch den Tabreiter aus den Eigenschaften entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1768.htm


Explorer Anzeigefarben für komprimierte und verschlüsselte Dateien

Komprimierte und verschlüsselte Dateien und Verzeichnisse werden im Explorer in unterschiedlichen Farben angezeigt ("hellblau" für komprimierte und "dunkelgrün" für verschlüsselte Dateien). Möchten Sie die Farbe ändern, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Komprimierte Dateien:

Fügen Sie den neuen Wert "AltColor" als Datentyp REG_BINARY hinzu.

Verschlüsselte Dateien:

Fügen Sie den neuen Wert "AltEncryptionColor" als Datentyp REG_BINARY hinzu.

Diesem Wert können Sie nun die gewünschte Farbe im Format "RR GG BB" zuweisen.
Ersetzen Sie "RR", "GG" und "BB" durch den jeweiligen Farbanteil Rot, Grün und Blau.

Kleine Farbtabelle:

Farbe | RR | GG | BB
Rot | FF | 00 | 00
Grün | 00 | 00 | FF
Gelb | FF | FF | 00
Cyan | 00 | FF | FF
Magenta | FF | 00 | FF
Braun | A5 | 2A | 2A
Weiß | FF | FF | FF
Schwarz | 00 | 00 | 00

Weitere Farbtabelle (wird nur in der HTML und CHM-Version farbig angezeigt):

000000 | 000033 | 000066 | 000099 | 0000CC | 0000FF | 330000 | 330033 | 330066 | 330099 | 3300CC | 3300FF
003300 | 003333 | 003366 | 003399 | 0033CC | 0033FF | 333300 | 333333 | 333366 | 333399 | 3333CC | 3333FF
006600 | 006633 | 006666 | 006699 | 0066CC | 0066FF | 336600 | 336633 | 336666 | 336699 | 3366CC | 3366FF
009900 | 009933 | 009966 | 009999 | 0099CC | 0099FF | 339900 | 339933 | 339966 | 339999 | 3399CC | 3399FF
00CC00 | 00CC33 | 00CC66 | 00CC99 | 00CCCC | 00CCFF | 33CC00 | 33CC33 | 33CC66 | 33CC99 | 33CCCC | 33CCFF
00FF00 | 00FF33 | 00FF66 | 00FF99 | 00FFCC | 00FFFF | 33FF00 | 33FF33 | 33FF66 | 33FF99 | 33FFCC | 33FFFF
660000 | 660033 | 660066 | 660099 | 6600CC | 6600FF | 990000 | 990033 | 990066 | 990099 | 9900CC | 9900FF
663300 | 663333 | 663366 | 663399 | 6633CC | 6633FF | 993300 | 993333 | 993366 | 993399 | 9933CC | 9933FF
666600 | 666633 | 666666 | 666699 | 6666CC | 6666FF | 996600 | 996633 | 996666 | 996699 | 9966CC | 9966FF
669900 | 669933 | 669966 | 669999 | 6699CC | 6699FF | 999900 | 999933 | 999966 | 999999 | 9999CC | 9999FF
66CC00 | 66CC33 | 66CC66 | 66CC99 | 66CCCC | 66CCFF | 99CC00 | 99CC33 | 99CC66 | 99CC99 | 99CCCC | 99CCFF
66FF00 | 66FF33 | 66FF66 | 66FF99 | 66FFCC | 66FFFF | 99FF00 | 99FF33 | 99FF66 | 99FF99 | 99FFCC | 99FFFF
CC0000 | CC0033 | CC0066 | CC0099 | CC00CC | CC00FF | FF0000 | FF0033 | FF0066 | FF0099 | FF00CC | FF00FF
CC3300 | CC3333 | CC3366 | CC3399 | CC33CC | CC33FF | FF3300 | FF3333 | FF3366 | FF3399 | FF33CC | FF33FF
CC6600 | CC6633 | CC6666 | CC6699 | CC66CC | CC66FF | FF6600 | FF6633 | FF6666 | FF6699 | FF66CC | FF66FF
CC9900 | CC9933 | CC9966 | CC9999 | CC99CC | CC99FF | FF9900 | FF9933 | FF9966 | FF9999 | FF99CC | FF99FF
CCCC00 | CCCC33 | CCCC66 | CCCC99 | CCCCCC | CCCCFF | FFCC00 | FFCC33 | FFCC66 | FFCC99 | FFCCCC | FFCCFF
CCFF00 | CCFF33 | CCFF66 | CCFF99 | CCFFCC | CCFFFF | FFFF00 | FFFF33 | FFFF66 | FFFF99 | FFFFCC | FFFFFF

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0059.htm


Komprimierte Dateien und Ordner im Explorer mit anderer Farbe anzeigen

Mit diesem Tipp legen Sie fest, dass komprimierte Dateien und Ordner in einer anderen Farbe angezeigt werden. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Verschlüsselte oder komprimierte NTFS-Dateien in anderer Farbe anzeigen" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowCompColor" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Andere Farbe benutzen
0 | In der gleichen Farbe anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1708.htm


Inhalte von Systemordnern im Explorer anzeigen

Mit diesem Tipp legen Sie fest, ob Inhalte von Systemordnern im Explorer angezeigt werden. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Inhalte von Systemordner anzeigen" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "WebViewBarricade" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Inhalte Anzeigen
0 | Inhalte ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1709.htm


GoTo-Funktion aus dem Explorer ausblenden/einblenden

Mit diesem Tipp können Sie die GoTo Funktion im Explorer ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoGoTo" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
0 | Eintrag ist vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1624.htm


Favoriten und Eigene Dateien direkt im Startmenü

Mit einem Trick kann man auch unter Windows NT 4 erreichen, dass die Favoriten und Eigene Dateiensich im Startmenü befinden und "Aufklappen".Dazu kopiert man beide Ordner (Favoriten und Eigene Dateien) nach

C:\Winnt\Profiles\Username\Startmenü\Programme

Dann passt man in den beiden Registry-Schlüsseln die Pfade entsprechend an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

und

HKEY_USERS\ <KRYPTISCHE NUMMER(SID)>\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

Nach einem Neustart legt der IE die Favoriten und die "Eigene Dateien" im Startmenü ab. Alle Dateien und Ordner sind direkt über das Startmenü erreichbar.

(Danke an Ingo Syllwasschy)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1127.htm


Die 'Allgemeinen Programmgruppen' aus dem Startmenü entfernen

Mit diesem Wert können Sie festlegen, dass die "Allgemeinen Programmgruppen" nicht mehr im Startmenü angezeigt werden sollen.

Dieses sind die Programmgruppen, die im Profil "All Users" unter Programme liegen und normalerweise bei allen Benutzer angezeigt werden.

Diese Einträge finden im Systemlaufwerk unter "Dokumente und Einstellungen\All Users\Startmenü\Programme".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCommonGroups" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Programmgruppen werden nicht angezeigt
gelöscht | Programmgruppen werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Standardprogrammgruppen aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1373.htm


Aufruf des Taskmanagers deaktivieren

Wenn der Anwender keinen Zugriff auf den Taskmanager bekommen soll, können Sie das mit folgendem Eintrag verhindern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Schlüssel | Datentyp | Angabe als | Standard
Bei 1 kann der Taskmanager nicht mehr aufgerufen werden.
DisableTaskMgr | REG_DWORD | Boolean | 0

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Strg+Alt+Entf-Optionen
Einstellungsname: | Task-Manager entfernen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0817.htm


Aufruf des Taskmanagers

Um den Taskmanager aufzurufen ist ab NT 4.0, anders als bei NT 3.51, die Tastenkombination CTRL+ALT+DEL bzw. Strg+Shift+Esc zu wählen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0625.htm


Buttons in der Sicherheitsbox deaktivieren

Wenn Sie beim Anmelden (Strg+Alt+Entf) gedrückt haben, werden Sie aufgefordert, ein Passwort einzugeben. In dieser Box finden Sie weiterhin noch die Buttons "Computer sperren", "Kennwort ändern" und "Task-Manager".

Über die Registry können Sie die Buttons, die dem Anwender nicht zur Verfügung stehen sollen, deaktivieren. Diese Buttons sind dann auch während der Windowssitzung deaktiviert, wenn der Anwender hier auch die Tasten (Strg+Alt+Entf) drückt.

Das Deaktivieren dieser Buttons ist aber bei den meisten Systemen nicht wirklich sinnvoll. Schon allein aus Gründen der Sicherheit sollte jeder Anwender sein Passwort ändern und den Rechner sperren können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

erstellen Sie folgende Werte:

Wertname | Datentyp | Es wird deaktiviert
DisableLockWorkstation | REG_DWORD | Computer sperren
DisableChangePassword | REG_DWORD | Kennwort ändern
DisableTaskMgr | REG_DWORD | Task-Manager

Setzen Sie den Wert auf 1, um die Funktion auszuschalten.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Strg+Alt+Entf-Optionen
Einstellungsname: | Sperren des Computers entfernen Kennwortänderung entfernen Task-Manager entfernen

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=174840

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0473.htm


Den Aufruf von 'Software' aus der Systemsteuerung unterbinden

Mit dieser Policy können Sie den Aufruf von "Software" aus der Systemsteuerung unterbinden.

Durch Aktivieren dieser Einstellung wird das Symbol "Software" aus der Systemsteuerung und der Menüeintrag "Software" aus Menüs entfernt.

Die Option "Software" ermöglicht Benutzern Funktionen und Komponenten von Windows 2000 Professional und eine Vielzahl von Windows-Programmen zu installieren, zu deinstallieren, zu reparieren, hinzuzufügen und zu entfernen. Veröffentlichte oder dem Benutzer zugewiesene Programme werden unter der Option "Software" angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddRemovePrograms" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Start wird vom System unterbunden
gelöscht | Kann gestartet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Systemsteuerungsoption "Software" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1424.htm


IRQ Problem zwischen AGP -Grafikkarte und PCI Karte lösen

Beim Einbau einer PCI Karte kann man eine böse Überraschung erleben. Wer eine AGP Grafikkarte im System hat und dieser (wie fast immer notwendig) im BIOS über Assign IRQ for VGA einen IRQ zugewiesen hat, bekommt bei fast allen Boards dann Probleme, wenn eine weitere PCI Karte im ersten Slot unter dem AGP eingebaut wird, da diese Karte dann den gleichen IRQ wie die AGP Karte bekommt.

Als Lösung bietet sich an, die PCI Karte einfach einen Slot tiefer einzubauen und den "Problemslot" einfach freizulassen oder mit einer Voodoo Karte etc. zu bestücken, da diese keinen IRQ benötigen.

Glücklicherweise bieten einige BIOS Versionen die Möglichkeit, den PCI Slots IRQs speziell zuzuweisen.

Info Die Grafikkarte sollte einen IRQ immer alleine bekommen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0878.htm


Wie kann ich die Bildwiederholfrequenz ändern?

Wenn Ihr Grafikkartentreiber die Veränderung der Bildwiederholfrequenz nicht unterstützt, können Sie es auch direkt in der Registry ändern. Bedenken Sie aber, dass Sie sich sicher sein sollten, ob Ihr Monitor auch diesen Wert unterstützt. Ansonsten werden Sie nach einem Neustart nichts mehr sehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ HardwareProfiles\ Current\ System\ CurrentControlSet\ Services\ [Video-Treiber Name]\ Device0

Für [Video-Treiber Name] müssen Sie den Eintrag für Ihre Grafikkarte suchen, da Sie je nach Grafikkartentyp unterschiedlich ist.

Hier sollten Sie den Wert "DefaultSettings.Vrefresh" finden. Wenn nicht, legen Sie diesen als Datentyp REG_DWORD an und weisen ihm die gewünschte Bildwiederholfrequenz (hexadezimal) zu.

Hier die Umrechnungstabelle für die gewünschten Bildwiederholfrequenzen:

Wiederholfrequenz | hexadezimal
50 | 32
55 | 37
60 | 3C
65 | 41
70 | 46
75 | 4B
80 | 50
85 | 55

Starten Sie nun Ihr Betriebssystem neu.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0643.htm


Maus und Tastaturspeicher verändern

Bewegungen der Maus und Tastatur werden vor der Verarbeitung in einen Zwischenspeicher gepackt und dann abgearbeitet. Unter einigen Systemen kann es vorkommen, dass der Standardwert von 100 nicht ausreicht und es im Ergebnisprotokoll zu folgender Fehlermeldung kommt:

The ring buffer that stores incoming mouse data has overflowed (Überlauf im Mausdatenpuffer)

Dann sollten Sie den Wert auf 256 bzw. 512 erhöhen. Diese Einstellung finden Sie in der Registry unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Busmouse\ Parameters\

den Wert MouseDataQueueSize als Datentyp REG_DWORD für den Mauspuffer

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Busmouse\ Parameters\

Hier den Wert KeyboardDataQueueSize als Datentyp REG_DWORD für die Tastatur

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0601.htm


Maus und Tastatur deaktivieren

Ab und zu kann es nützlich sein, die Maus und Tastatur zu deaktivieren. Wenn Sie z.B. eine Installationsroutine schreiben, die sich automatisch anmeldet und im administrativen Kontext Einstellungen vornimmt. Damit kein Anwender in diesen Moment irgendwelche Einstellungen verändern kann, sollte man die Maus und Tastatur deaktivieren und anschließend die Werte wieder auf 1 setzen, damit nach einem Neustart wieder alle Eingabegeräte zur Verfügung stehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\kbdclass

setzen Sie den Wert Start auf 4, um die Tastatur zu deaktivieren

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Mouclass

setzen Sie den Wert Start auf 4, um die Maus zu deaktivieren

Die Maus und die Tastatur sind dann natürlich erst beim nächsten Neustart des Rechners deaktiviert. Damit Sie diese Funktion sinnvoll nutzen können, müssen Sie auch ein entsprechende automatische Anmeldung einbauen und dafür sorgen, dass jetzt die entsprechenden Scripte/Programme ausgeführt werden. Anschließend müssen Sie die Werte wieder auf 1 setzen und den Rechner neu starten.

Info Achten Sie darauf, Maus und Tastatur wieder zu aktivieren, ansonsten können Sie sich leicht aussperren!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0571.htm


Sondertasten akustisch melden

Bei Windows kann man einstellen, dass Betätigungen der Sondertasten akustisch gemeldet werden. So können unnötige Falscheingaben durch plötzliches Großschreiben vermieden werden.

Unter:

"Systemsteuerung" -> "Eingabehilfe" -> "Tastatur" schalten Sie im Bereich "Statusanzeige" die Option "Statusanzeige aktivieren" ein.

Wenn nun Sondertasten gedrückt werden (Feststelltaste, NumLock, ScrollLock), erfolgt die Ausgabe eines Signaltons. Somit werden Sie auf versehentliches Drücken dieser Tasten aufmerksam gemacht.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0301.htm


NumLock-Taste beim Starten aktivieren/deaktivieren

Durch einen Eintrag in der Registry oder über ein Script können Sie den Status der NumLock-Taste beim Starten von Windows einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Keyboard

InitialKeyboardIndicators: als Datentyp REG_SZ

Range: Number

Default: 0

Dort kann man den Status der Taste bestimmen. Bei 0 ist die Taste nach dem Starten ausgeschaltet, bei 2 eingeschaltet.

Wenn Sie schon bei der Anmeldung die NumLock-Taste aktivieren wollen, müssen Sie den Wert "InitialKeyboardIndicators" auch unter

HKEY_USERS\.DEFAULT\Control Panel\Keyboard auf 2 setzen, da zu diesem Zeitpunkt noch kein Anwender angemeldet ist und

der Wert unter

HKEY_CURRENT_USER\ Control Panel\ Keyboard noch nicht ausgewertet wird.

Script

Ab Windows 2000 können Sie auch mit folgendem Script die NumLock-Taste aktivieren bzw. deaktivieren.

Dadurch wird die NumLock-Taste unabhängig vom vorherigen Zustand aktiviert. Sie sollten dafür den Registry-Eintrag "InitialKeyboardIndicators" auf "0" setzen.

set WshShell = CreateObject("WScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

Speichern Sie dieses Script unter einem beliebigen Namen mit der Endung.VBS ab. Jetzt können Sie das Script z.B. automatisch beim Start von Windows ausführen lassen. Wenn Sie die NumLock-Taste schon beim Hochfahren aktivieren möchten, sollten Sie das Script wie unter "Script beim An-/Abmelden oder Starten/Herunterfahren von Windows ausführen" beschrieben in den Windows-Start integrieren.

Info NT überprüft beim Herunterfahren automatisch den aktuellen Stand der NumLock-Taste und trägt diesen Wert dann selbständig in die Registry ein. Wenn also die NumLock-Taste beim Herunterfahren aktiv war, wird sie beim nächsten Start auch wieder aktiviert.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=154529

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0235.htm


Tasten mittels ScanCode umbelegen

Wenn Sie unter Windows eine Taste drücken, wird ein Abtastcode erzeugt. Dieser Code wird als Nachricht in Windows gesendet.

Wenn Sie jetzt bestimmte Tasten deaktivieren wollen oder Ihnen eine neue Funktion zuweisen möchten, müssen Sie diese Nachricht abfangen und entsprechend verarbeiten.

MS hat unter Windows dafür einen Key "Scancode Map" eingeführt. Wenn es diesen Eintrag in der Registry gibt, vergleicht Windows den Abtastcode einer Taste mit den hier abgelegten Codes. Wird dieser Code hier gefunden, wird erst die Anweisung ausgeführt, bevor der Tastendruck wieder von Windows weiterverarbeitet wird.

Den Eintrag finden Sie unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Keyboard Layout

Wenn der Wert nicht vorhanden ist, erstellen Sie einen neuen Eintrag mit dem Namen "Scancode Map" als Datentyp REG_BINARY.

Der ScanCode hat folgenden Aufbau:

Offset Byte | Größe in Bytes | Wert | Beschreibung
0 | 4 | 00 00 00 00 | Header: Versionsinfo
4 | 4 | 00 00 00 00 | Header: Flags
8 | 4 | 01 00 00 00 | Header: Anzahl der Mappings, muss mindestens 01 enthalten, wenn kein ScanCode mitgeben wird, ansonsten jeweils um die Anzahl der ScanCodes erhöhen
12 | 4 | Siehe Tabelle | Mappings
Ende 4 | 4 | 00 00 00 00 | Markierung des Endes

Die ersten beiden Einträge (bis Offset 8) sind zur Zeit immer auf 0 gesetzt und sollten zum gegenwärtigen Zeitpunkt auch nicht anders belegt werden.

Der dritte Eintrag enthält die nachfolge Anzahl von Scancodes + die der aktuellen Ende-Markierung.

Wird also 1 Scancode (Tastenänderung) mitgegeben, muss dieser Wert auf 2 gesetzt werden, da die Ende-Markierung noch dazukommt.

Ab Offset 12 wird nun der ScanCode mitgegeben. Sie können hier beliebig viele Einträge vornehmen. Bedenken Sie aber, für jeden Eintrag die Anzahl der Mappings anzupassen. Dabei entspricht jeder Eintrag immer einer Taste:

Neue Belegung | Taste
00 00 | 00 00

Der ScanCode besteht aus 4 Stellen und wird von hinten gelesen. Die ersten beiden Stellen stehen für die zu überwachenden Abtastcodes, die zweiten beiden Stellen für die neue Funktion. Wenn Sie für die neue Funktion „00 00“ eingeben, wird die Taste deaktiviert. Den ScanCode für alle Tasten finden Sie hier: ScanCode der Tasten

Beispiele:

Windows Menü Taste deaktivieren

Header | Header | Anzahl | ScanCode | Abschluss (Ende)
00000000 | 00000000 | 02000000 | 00005DE0 | 00000000

Windows Menü Taste und F10 deaktivieren

Header | Header | Anzahl | ScanCode | ScanCode | Abschluss (Ende)
00000000 | 00000000 | 03000000 | 00005DE0 | 00004400 | 00000000

Linke Windows Taste auf die Rollen-Task legen (Tastatur ohne Windows Taste)

Header | Header | Anzahl | ScanCode | Abschluss (Ende)
00000000 | 00000000 | 02000000 | 5BE04600 | 00000000

So können Sie sich jetzt beliebige ScanCode zusammenstellen und in die Registry eintragen. Sie können den Code auch recht einfach mit einer REG-Datei übertragen, dazu erstellen Sie folgende Datei, in der Sie dann einfach Ihren neuen Code hereinkopieren. Hier müssen Sie jedes Offset (immer zwei Stellen) durch ein Komma trennen:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex: 00,00,00,00,00,00,00,00,03,00,00,00,00,00,5b,E0,00,00,44,00,00,00,00,00

Tools zum Thema ScanCode

Hier ein paar Links zum Tabellen und Tools für das Bearbeiten von ScanCode-Einstellungen.

  • Microsoft bietet ein Tool "Microsoft Keyboard Layout Creator" an,mit dem sich die entsprechenden Einträge erzeugen lassen <Download>.
  • Scancode Tabellen von Microsoft zum Download: http://www.microsoft.com/whdc/archive/Scancode.mspx

Info Die ScanCodes der Tasten finden Sie unter: ScanCodes der Tasten

Info Tipps die diese Funktion nutzen:
Dezimalpunkt statt Komma im Zehnertastaturfeld
Windows Tasten deaktivieren.

Info Weitere Infos: http://www.microsoft.com/whdc/device/input/w2kscan-map.mspx

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1575.htm


ScanCodes der Tasten

Hier finden Sie eine Aufstellung der ScanCodes für die einzelnen Tasten, welchen Sie benötigen, wenn Sie die Tasten umbelegen möchten.

Info Info:Die ScanCodes wurden von hier schon gedreht und stehen so wie Sie als Byte-Wert jeweils eingetragen werden müssen.

Scan Code | Taste (Deutsch) | Abweichung Englisch
00 54 | Print / S-Abf |
01 00 | ESC | ESC
02 00 | 1 und ! | 1 und !
03 00 | 2 und " | 2 und &
04 00 | 3 und # | 3 und #
05 00 | 4 und $ | 4 und $
06 00 | 5 und % | 5 und %
07 00 | 6 und & | 6 und ^
08 00 | 7 und / | 7 und &
09 00 | 8 und ( | 8 und *
0A 00 | 9 und ) | 9 und (
0B 00 | 0 und = | 0 und )
0C 00 | ß und ? | - und _
0D 00 | ´ | = und +
0E 00 | Backspace Taste | Backspace Taste
0F 00 | Tabulator Taste | Tabulator Taste
10 00 | Q | Q
11 00 | W | W
12 00 | E | E
13 00 | R | R
14 00 | T | T
15 00 | Z | Y
16 00 | U | U
17 00 | I | I
18 00 | O | O
19 00 | P | P
1A 00 | # | [ und {
1B 00 | + | ] und }
1C 00 | Enter Taste | Enter Taste
1C E0 | Ziffernblock Enter | Ziffernblock Enter
1D 00 | Linke STRG Taste | Linke STRG Taste
1D E0 | Rechte STRG Taste | Rechte STRG Taste
1E 00 | A | A
1F 00 | S | S
20 00 | D | D
20 E0 | Ton Mute |
21 00 | F | F
22 00 | G | G
22 E0 | Play und Pause |
23 00 | H | H
24 00 | J | J
24 E0 | Stop |
25 00 | K | K
26 00 | L | L
27 00 | Ö | ; und :
28 00 | Ä | ' und "
29 00 | ^ | ` und ~
2A 00 | Linke Shift Taste | Linke Shift Taste
2B 00 | < und > | \ und |
2C 00 | Y | Z
2D 00 | X | X
2E 00 | C | C
2E E0 | Lautstärke leiser |
2F 00 | V | V
30 00 | B | B
30 E0 | Lautstärke lauter |
31 00 | N | N
32 00 | M | M
32 E0 | WWW-Taste |
33 00 | , und ; | , und <
34 00 | . und : | . und >
35 00 | - und _ | / und ?
35 E0 | Ziffernblock / | Ziffernblock /
36 00 | Rechte Shift Taste | Rechte Shift Taste
37 00 | Ziffernblock * | Ziffernblock *
37 E0 | Druck | PrtScr
38 00 | Linke ALT Taste | Linke ALT Taste
38 E0 | Rechte ALT Taste | Rechte ALT Taste
39 00 | Leertaste | Leertaste
3A 00 | Feststell Taste | CapsLock
3A 01 | CAPS Lock |
3B 00 | F1 | F1
3C 00 | F2 | F2
3D 00 | F3 | F3
3E 00 | F4 | F4
3F 00 | F5 | F5
40 00 | F6 | F6
41 00 | F7 | F7
42 00 | F8 | F8
43 00 | F9 | F9
44 00 | F10 | F10
45 00 | Num Lock Taste | Num Lock Taste
46 00 | Rollen Taste | Scroll Lock Taste
46 E0 | Crtl+Break | Crtl+Break
47 00 | Ziffernblock 7 und POS | Ziffernblock 7 und Home
47 E0 | Home | Pos 1
48 00 | Ziffernblock 8 | Ziffernblock 8 und Up
48 E0 | hoch | Up
49 E0 | Bild hoch | PgUp
4A 00 | Ziffernblock - | Ziffernblock -
4B 00 | Ziffernblock 4 und Links | Ziffernblock 4 und Left
4B E0 | Links | Left
4C 00 | Ziffernblock 5 | Ziffernblock 5
4D 00 | Ziffernblock 6 und Right | Ziffernblock 6 und Right
4D E0 | Rechts | Right
4E 00 | Ziffernblock + | Ziffernblock +
4F 00 | Ziffernblock 1 und Ende | Ziffernblock 1 und End
4F E0 | Ende | End
50 00 | Ziffernblock 2 | Ziffernblock 2 und Down
50 E0 | Runter | Down
51 00 | Ziffernblock 3 und Bild runter | Ziffernblock 3 und PgDn
51 E0 | Bild runter | PgDn
52 00 | Ziffernblock 0 und Einfg | Ziffernblock 0 und Ins
52 E0 | Einfg | Insert
53 00 | Ziffernblock , und Entf | Ziffernblock , und Del
53 E0 | Entf | Delete
54 00 | Alt + SysRq | Alt + SysRq
57 00 | F11 | F11
58 00 | F12 | F12
5B E0 | Linke Windows Taste | Linke Windows Taste
5C E0 | Rechte Windows Taste | Rechte Windows Taste
5D E0 | Windows Menü Taste | Windows Menü Taste
5E E0 | Power | Power
5F E0 | Sleep | Sleep
63 E0 | Wake | Wake
45 1D E1 | Pause | Pause

Info Gebraucht werden die z.B.: Tasten mittels ScanCode umbelegen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1576.htm


Die 'Wheel Maus' Funktion konfigurieren

Die "Wheel Maus"-(Scroll-Rad) Funktion wird heutzutage von jeder Maus unterstützt. Mit dem folgenden Registry-Schlüssel können Sie die Funktion auf Ihrem System konfigurieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ i8042prt\ Parameters

erstellen Sie einen neuen Eintrag mit dem Namen "EnableWheelDetection" als Datentyp REG_DWORD und geben einen der folgenden Werte an:

0 = deaktiviert

1 = automatische Erkennung

2 = aktiviert

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1312.htm


PS/2 Mausabfrage beschleunigen

Wer eine PS/2 Maus an einem PS/2 Port besitzt, sollte die Abfrage der Maus beschleunigen. Man wird durch ein wesentlich feineres Scrolling der Maus belohnt:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ i8042prt\ Parameters

legen Sie dort den Wert "SampleRate" als Datentyp REG_DWORD und weisen Sie Ihn einen Wert zwischen 0 - 200 zu. Der Standardwert ist 60.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0661.htm


Drag & Drop Einstellungen

Wenn Sie mit der Maus im Explorer arbeiten, kann es leicht vorkommen, dass Windows einen Doppelklick für eine Drag & Drop Operation hält und versucht, etwas zu verschieben oder zu kopieren.

Windows erkennt Drag & Drop daran, wie weit der Mauszeiger auf dem Desktop bewegt wurde. Wenn Sie diese Werte etwas erhöhen, können Sie die Maus ruhig etwas bewegen, ohne dass Windows es gleich für eine Drag & Drop Operation hält.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop\

hier finden Sie folgende Werte (in alten Windows Version stand der Wert noch auf 2 wurde später aber auf 4 vergrößert):

Schlüssel | Datentyp | Angabe als | Standard
Legt die Strecke (in Pixel) der Maus fest, die der Zeiger in horizontaler Richtung zurücklegen muss, damit es Windows nicht für einen Klick hält.
DragHeight | REG_SZ | Pixel | 2 bzw. 4
Legt die Strecke (in Pixel) der Maus fest, die der Zeiger in vertikaler Richtung zurücklegen muss, damit es Windows nicht für einen Klick hält.
DragWidth | REG_SZ | Pixel | 2 bzw. 4

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0200.htm


Maustaste mit Doppelklick belegen

Maustaste mit Doppelklick belegen (Logitech)

Wenn Sie eine 3-Tasten Maus von Logitech haben, können Sie auf die mittlere Maustaste einen Doppelklick legen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Logitech\ MouseWare\ CurrentVersion\ <maus typ>\ 0000\

bei "DoubleClick" stellen Sie "001" ein.

Hinter "DoubleClick" steht nun entweder "000" oder bei Windows 98 und nach evtl. Treiberupdate auch bei Windows 95 "0002"

Davon muss die dritte "0" - nicht die zweite - in "1" geändert werden.

Die Zählung ist also:

erste 0 | linke Taste
zweite 0 | rechte Taste
dritte 0 | mittlere Taste
vierte 0 | vierte Taste der neuen Mäuse

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0232.htm


Mauszeigerbewegung auf Terminal Clients einstellen

Haben Sie auf Ihren Terminal Client Server ruckartige Mausbewegungen, sollten Sie auf den Clients den Wert für den Mauscursor anpassen. Standardmäßig sendet der Client alle 100 Millisekunden die Mausbewegungen an den Terminal Server, in der Registry der jeweiligen Client Rechner können Sie das aber ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Terminal Server Client

Legen Sie einen neuen Eintrag mit dem Namen "Min Send Interval" als DWORD an und weisen Sie Ihm als Wert die Zeit in Millisekunden zu. Sie sollten hier einen kleineren Wert benutzen, bedenken Sie aber, dass sich bei kleineren Werten die Netzwerklast erhöht.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0642.htm


Standardfarbe der Kommandozeilenoberfläche festlegen

Standardmäßig ist die Farbe der Kommandozeilenoberfläche ein schwarzer Hintergrund mit weißem Text. Wenn Sie das gern verändern wollen, können Sie das mit folgendem Registry-Wert erreichen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

Finden Sie den Eintrag "DefaultColor" als Datentyp REG_DWORD. Hier können Sie nun die Farbe als hexadezimalen Wert angeben, wobei der erste Wert die Hintergrundfarbe und der zweite Wert die Textfarbe festlegt.

So ergibt z.B. F0 einen weißen Hintergrund mit schwarzem Text.

Der Standardwert ist 0 für schwarzer Hintergrund mit weißem Text

Welche Farbe hat welche Nummer:

Nummer | Farbe
0 | Schwarz
1 | Dunkelblau
2 | Dunkelgrün
3 | Blaugrün
4 | Dunkelrot
5 | Violett
6 | Ocker
7 | Hellgrau
8 | Dunkelgrau
9 | Blau
A | Grün
B | Cyan
C | Rot
D | Magenta
E | Gelb
F | Weiß

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1117.htm


Path-Variablen werden nicht mehr richtig aufgelöst

Wenn Sie in der Kommandozeilenoberfläche keine Standardbefehle mehr ausführen können und Sie die Fehlermeldung bekommen, dass der Befehl nicht gefunden werden konnte, kann es daran liegen, dass Windows die Path-Variablen nicht mehr auflösen kann.

Ob ein solcher Fehler vorliegt, erkennt man in der Kommandozeile :
Dort "Path" eingeben und kontrollieren, ob im Pfad Variablen-Bezeichner zu sehen sind. Wenn dort %SYSTEMROOT% zu sehen ist, liegt der Fehler vor.

Der Fehler liegt daran, dass einige Setupprogramme in der Registry den Datentyp von REG_EXPAND_SZ auf REG_SZ ändern und so keine Variablen mehr aufgelöst werden.

Einfach können Sie den Fehler beheben, wenn Sie folgendermaßen vorgehen:

Rechte Maustaste auf den Arbeitsplatz -> Eigenschaften unter den Tabreiter "erweitert" -> Umgebungsvariablen. Hier bearbeiten und dann neu abspeichern, Windows behebt dann den Fehler.

Sie können den Fehler aber auch in der Registry beseitigen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Environment

finden Sie den Eintrag Path. Wenn dieser Eintrag vom Datentyp REG_SZ ist, haben Sie genau diesen Fehler. Kopieren Sie die Einträge, die unter Path stehen, in die Zwischenablage und löschen Sie den Schlüssel Path.

Erstellen Sie jetzt einen neuen Schlüssel mit dem Namen Path als Datentyp REG_EXPAND_SZ und kopieren Sie die Einträge aus der Zwischenablage wieder in diesen Schlüssel.

Nach einem Neustart des Rechner ist der Fehler behoben.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1054.htm


Umgebungsspeicher für die DOS -BOX vergrößern

Werden viele Pfade oder Variablen in der DOS -BOX benötigt, kann es vorkommen, dass die standardmäßige Größe für den Umgebungsspeicher nicht ausreicht und entsprechend vergrößert werden muss.

Um den Speicher zu vergrößern, müssen Sie folgen Eintrag in den "CONFIG.NT" hinzufügen (Sie finden Sie unter "%SYSTEMROOT%\System32"):

shell=%WINDIR%\system32\command.com /p /e:[Größe]

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0838.htm


16-Bit Applikationen immer in einer separaten VDM starten

Alle 16-Bit DOS Programme werden von Windows in einer VDM (Virtual DOS Machine) ausgeführt. Dabei wird normalerweise nur eine VDM erstellt, auch wenn mehr als ein DOS Programm gestartet wird, um Arbeitsspeicher zu sparen.

Das hat aber einen kleinen Nachteil: Läuft eine DOS -Applikation nicht stabil und stürzt ab, sind davon auch alle anderen VDM betroffen und werden beendet.

Wenn Sie sicherstellen wollen, dass andere DOS Applikation nicht beendet werden, falls eine Applikation einen Fehler verursacht, müssen Sie die Applikation in einer separaten VDM starten. Dadurch wird zwar mehr Arbeitsspeicher benötigt, aber ein Fehler in einer VDM hat keinen Einfluss mehr auf die anderen VDM.

Wenn 16-Bit Programme separate VDMs (Virtual DOS Machine) benutzen sollen, ist folgender Eintrag in die Registry notwendig:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ WOW

ist der Wert "DefaultSeparateVDM" als Datentyp REG_SZ auf YES zu setzen.

Ab Windows 2000

Hier können Sie einstellen, dass der User selber entscheiden kann, ob eine Anwendung in einer extra VDM gestartet werden soll. Dazu wird eine Checkbox eingeblendet.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

erstellen Sie einen neuen Wert mit dem Namen "MemCheckBoxInRunDlg" als Datentyp REG_DWORD und setzen den Wert auf :

1 | Jetzt gibt es unter "Start" -> "Ausführen" eine Extra-* Checkbox , um die Funktion für das jeweilige. Programm zu aktivieren (getrennter Speicherbereich).
gelöscht | Wird nicht angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Kontrollkästchen "Im getrenntem Speicherbereich ausführen" im Dialogfeld "Ausführen" hinzufügen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Damit der Eintrag wirksam wird, muss Windows neu gestartet werden. Ab Windows 2000 reicht ein Ab- und Anmelden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0652.htm


Windows Kommandozeile mit Autovervollständigung

Mit einem Eintrag in der Registry kann man erreichen, dass Windows auf Tastendruck die Eingabe automatisch vervollständigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Command Processor

Vervollständigen von Filenamen:

der Eintrag "CompletionChar" als Datentyp REG_DWORD

Ein Wert größer als 0 steht hier für die Taste. Der Wert gibt den ASCII-Code der jeweiligen Taste an (z.B. 9 für die Tabulatortaste).

Mögliche Werte liegen zwischen 0x1 - 0x1F.

Alle außer NT

Hier können Sie diese Option aktivieren, indem Sie die Kommandozeile folgendermaßen starten:

CMD /F:ON. Jetzt können Sie Eingaben durch Drücken von STRG+D (für Ordner) und STRG+F(für Programme und Ordner) auch automatisch vervollständigen lassen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Command Processor

Vervollständigen von Pfadnamen:

der Eintrag "PathCompletionChar"als Datentyp REG_DWORD

Ein Wert größer als 0 steht hier für die Taste. Der Wert gibt den ASCII-Code der jeweiligen Taste an (z.B. 9 für die Tabulatortaste).

Mögliche Werte liegen zwischen 0x1 - 0x1F

Info Sie können hierfür auch das Programm 4DOSNT verwenden. Es bietet neben dieser, viele weitere nützliche Funktionen (nur für NT wirklich nützlich).

Info Mit dem festgelegten Buchstaben und STRG lassen Sie die Eingabe vervollständigen. Wenn es mehr als eine Möglichkeit gibt, blättern Sie mit STRG und der Taste weiter bzw. mit SHIFT + STRG und der Taste wieder zurück.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0247.htm


Immer UNC-Pfade in der Kommandozeile erlauben

Windows überprüft in der Kommandozeile die UNC Namen und weist den Befehl mit einer Fehlermeldung ab, wenn Probleme mit einem anderen Prozess auftreten könnten. Diese Überprüfung und die Ausgabe der Fehlermeldung können Sie mit folgendem Eintrag in der Registry ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableUNCCheck" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Überprüfung wird ausgeschaltet
0 | Überprüfung aktiv (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1385.htm


Kommandozeilenbefehle durch Makros erweitern (NT/2000/XP/2003)

Kommandozeilenbefehle durch Makros erweitern (ab NT)

Windows stellt in der CMD-Box standardmäßig den "DOSKEY" - Support zur Verfügung. Durch "DOSKEY" wird z.B. in der Kommandozeile die History - Liste der letzen Befehle zur Verfügung gestellt. Diese Funktion ist den meisten Leuten bekannt, weniger bekannt ist aber, dass man sich mit DOSKEY auch eigene Makros erstellen kann, die komplexe Befehlsaufrufe enthalten können.

So können Sie sich z.B. mit der Eingabe von:

DOSKEY list=dir /on /p

einen neuen Befehl mit dem Namen "LIST" erzeugen. Wenn Sie jetzt in der Kommandozeilenoberfläche LIST eingeben, werden alle Dateien und Unterverzeichnisse des aktuellen Verzeichnisses alphabetisch sortiert angezeigt und nach jeder vollen Bildschirmseite wird die Ausgabe angehalten.

Parameter von DOSKEY:

DOSKEY [/REINSTALL] [/LISTSIZE=Größe] [/MACROS[:ALL|:AusfDatei]] [/HISTORY] [/INSERT|/OVERSTRIKE] [/EXENAME=AusfDatei] [/MACROFILE=Datname] [Makroname=[Text]]

/REINSTALL | Installiert eine neue Kopie von DOS KEY.
/LISTSIZE=Größe | Stellt die Größe des Befehlsspeichers ein.
/MACROS | Zeigt alle DOS KEY-Makros an.
/MACROS:ALL | Zeigt alle DOS KEY-Makros für alle ausführbaren Dateien mit DOS KEY-Makros an.
/MACROS:AusfDatei | Zeigt alle DOS KEY-Makros für die ausführbare Datei an.
/HISTORY | Zeigt alle gespeicherten Befehle an.
/INSERT | Neu eingegebener Text wird in bestehenden eingefügt.
/OVERSTRIKE | Neu eingegebener Text überschreibt bestehenden.
/EXENAME=AusfDatei | Gibt die ausführbare Datei an.
/MACROFILE=Datname | Gibt die Datei mit den zu installierenden Makros an.
Makroname | Name für ein zu erstellendes Makro.
Text | Befehle, die durch das Makro auszuführen sind.

Mit den Pfeiltasten OBEN und UNTEN blättern Sie durch den Befehlspuffer.

ESC | löscht die Befehlszeile.
F7 | zeigt gespeicherte Befehle an.
ALT+F7 | Zeigt alle DOS KEY-Makros an.
F8 | durchsucht die gespeicherten Befehle.
F9 | wählt einen Befehl durch seine Nummer aus.
ALT+F10 | löscht Makro-Definitionen.

Besondere Zeichenfolgen in DOSKEY-Makro-Definitionen:

$T | Befehlstrennzeichen. Erlaubt mehrere Befehle in einem Makro.
$1-$9 | Ersetzbare Parameter. Entspricht %1-%9 in Stapelverarbeitungsdateien.
$* | Symbol für alles, was auf der Befehlszeile dem Makronamen folgt.

Info Siehe auch: "Kommandozeilenbefehle durch Makros erweitern (9x/ME)".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1027.htm


DOS -Bootdiskette mit NT4 erstellen

Auch NT-Benutzer benötigen gelegentlich eine DOS-Umgebung, um z.B. ein BIOS-Update durchzuführen.

Auf der NT4 CD im Ordner Support findet sich im Verzeichnis scsitool bzw. hqtooljeweils das Image einer bootfähigen MS-DOS 6.22 Diskette, die mit der Batch-Dat (im gleichen Verzeichnis) auf eine Diskette entpackt werden kann.

Beide Disketten enthalten weitere Supporttools (SCSI bzw. Hardware), die gelöscht werden können.

Die Disketten enthalten allerdings nur einem US-Tastaturtreiber.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0795.htm


Quick-Edit Modus für die Kommandozeile aktivieren

Für die Kommandozeile können Sie unter Eigenschaften im Tabreiter „Optionen“ die Funktion „Quick-Edit-Modus“ aktivieren.

Wenn Sie diese Funktion aktivieren, können Sie in der Kommandozeile die Maus zum Markieren und Kopieren von Einträgen benutzen und brauchen dafür nicht erst in das Menü „Bearbeiten“ gehen.

Sie können diese Funktion aber auch für alle Fenster über einen Registryeintrag aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Console

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Console

Erstellen Sie hier einen neuen Wert mit dem Namen "QuickEdit" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Quick-Edit-Modus ist aktiviert
0 | Quick-Edit-Modus ist deaktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Wenn Sie den Wert auf 1 steht, gibt es keine Mausunterstützung mehr in der Kommandozeilensitzung. Das kommt daher, da die Maus jetzt ja zum Markieren/Kopieren benutzt wird. Wenn Sie also die Maus in einer Anwendung benutzen wollen, müssen Sie den Wert auf 0 setzen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1517.htm


Windows Scripting Host: Remote-Ausführung konfigurieren

Mit diesem Tipp können Sie einstellen, ob Windows Scripting Host (WSH) Dateien von entfernten Rechnern (über das Netzwerk) ausgeführt werden können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows Script Host\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Remote" als Datentyp REG_SZ und setzen den Wert auf:

0 | Ausführen von Scripten über das Netzwerk unterbinden(Standard)
1 | Ausführen von Scripten über das Netzwerk zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2462.htm


Dateierweiterungen vom Prompt aus verändern

Es gibt 2 Befehle, um die Dateierweiterungen unter Windows zu bearbeiten:

ASSOC zeigt die definierten Erweiterungen

FTYPE zeigt die Verknüpfungen der Erweiterungen mit einer Anwendung.

Wenn Sie am Prompt nun eine neue Verknüpfung eines Dateisuffixes, z.B. .ME, mit einer Anwendung durchführen wollen, gehen Sie wie folgt vor:

Definieren Sie eine Dateiverknüpfung mit Hilfe von: ASSOC.ME=READMEDatei

Nun muss die Dateiverknüpfung noch mit einer Anwendung verbunden werden: FTYPE READMEDatei=winnt\system32\notepad.exe %1

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0654.htm


Löschen von zwischengespeicherten Profilen über das Netzwerk (DELPROF.EXE)

Aus dem Windows Resource Kit

Wenn "Roaming Profiles" in einem Netzwerk eingesetzt werden, wird beim Anmelden eines Anwenders eine Kopie des Profiles unter "%SYSTEMROOT%\Profiles" angelegt.

Mit dem Tool "DELPROF.EXE" können Sie solche Profile über das Netzwerk löschen, wenn sie z.B. Startenchon eine längere Zeit nicht mehr benutzt wurden.

Parameter:

Delprof [/q] [/i] [/p] [/c:\\computername] [/d:Tage] [/?]

/q | Es erfolgen keinen Rückfragen an den Anwender
/i | Fehler werden ignoriert und das Löschen wird fortgesetzt
/p | Gibt einen Meldung aus, bevor das Profil gelöscht wird
/c:\\Computername | Gibt den Rechner an, auf dem die Profile gelöscht werden sollen
/d | Anzahl der Tage, die das Profil nicht benutzt wurde, bevor es gelöscht wird.

Info Wenn Sie das Programm über den Schedule Dienst ausführen, müssen Sie bedenken, dass der Schedule standardmäßig mit einem Local System - Account läuft, der keine Berechtigungen hat. Wenn Sie unter so einem Account dieses Programm ausführen, kann das Profilverzeichnis unter "%SYSTEMROOT%\Profiles" nicht gelöscht werden. Der dazugehörige Eintrag in der Registry "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\ProfilList" wird aber gelöscht. Das hat zur Folge, dass ein neues Profil mit einem neuen Namen (.00x) erstellt wird, wenn sich der USER wieder auf diesen Rechner anmeldet. Deshalb sollten Sie das Programm immer mit "Domain Admin" Rechten ausführen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0852.htm


Feststellen des Betriebssystems im Loginscript (GETTYPE.EXE)

[Aus dem Windows Resource Kit 2000]

Mit diesen Befehl können Sie abfragen, welches Betriebssystem auf einem Rechner läuft.

Parameter:

Gettype [\\Computername] [/s]

\\Computername | Gibt den Rechner an
/s | Ohne Bildschirmausgabe

Folgende Fehlermeldungen werden erzeugt:

1 | Windows NT Workstation
2 | Windows 2000 Professional
3 | Windows NT Server (kein Domain Controller)
4 | Windows 2000 Server (kein Domain Controller)
5 | Windows NT Server (Domain Controller)
6 | Windows 2000 Server (Domain Controller)
7 | Windows NT Enterprise/Terminal Version (Domain Controller)
8 | Windows NT Enterprise/Terminal Version (kein Domain Controller)

Die Fehlermeldung kann über die Variable %Errorlevel% in einem Loginscript abgefragt und weiterverarbeitet werden. So können betriebssystemabhängige Funktionen gesetzt werden.

Beispiel:

Gettype \\%Computername% /s
Goto System%errorolevel%
:System1
....
:System2

usw.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0851.htm


User Manager (CUSRMGR.EXE)

Aus dem Windows Resource Kit 2000

Mit diesen Tool können Sie so gut wie alle Funktionen der User-Verwaltung über die Eingabeaufforderung durchführen. Gerade bei Änderungen, die viele Anwender betreffen, kann man sich mit einem Batch-Programm die Arbeit erleichtern.

Cusrmgr

-u USERID [-m \\Computername] [-r UserName | -d UserName] [-p | -P Passwort] [-rlg AlterGruppenName NeuerGruppenname] [-rgg AlterGruppenName NeuerGruppenName] [-alg LokalerGruppenName] [-agg GloblerGruppenName] [-dlg LoklerGruppenName] [-dgg GloblerGruppenName] [-dgg GloblerGruppenName] [-c Beschreibung] [-f UserName] [-U UserProfil] [-n LogonScript] [-h HomeVerzeichnis] [-H HomeLaufwerk] [+s oder -s Einstellungen]

-u UserID | Accountname, auf den sich einige Funktionen beziehen sollen
-m \\ComputerName | Computername, Standard ist der Computer auf dem das Skript ausgeführt wird
-r UserName | neuer Username, der dem User durch den mit "-u" angegebenen Namen ausgetauscht wird
-d UserName | löscht den Usernamen
-p | setzt Zufallspasswort
-P Passwort | setzt angegebenes Passwort
-tlg AlterGruppenName NeuerGruppenName | Umbenennen einer lokalen Gruppe
-rgg AlterGruppenName NeuerGruppenName | Umbenennen einer globalen Gruppe
-alg LokalerGruppenName | fügt den unter -u angegebenen Anwender in diese lokale Gruppe ein
-agg GlobalerGruppenName | fügt den unter -u angegebenen Anwender in diese globale Gruppe ein
-dlg LokalerGruppenName | entfernt den unter -u angegebenen Anwender aus der lokalen Gruppe
-dgg GlobalerGruppenName | entfernt den unter -u angegebenen Anwender aus der globalen Gruppe
-c | setzt die Beschreibung
-f Username | setzt den vollständigen Anwendernamen
-U UserProfil | setzt das Userprofil
-n | setzt das Logon Script
-h | setzt das Homeverzeichnis
-H | setzt das Homelaufwerk
+S bzw. -S | setzt oder entfernt die Einstellungen mögliche Werte: MustChangePassword CanNotChangePassword PasswordNewerExpires AccountDisabled AccountLockout RASUser

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0879.htm


Environment Variablen setzen (SETX.EXE)

[Aus dem Windows Resource Kit] bzw. ab Windows Vista mit dabei

Mit dem Standard SET.EXE können Sie Environment Variablen setzen. Diese Variablen sind dann aber nur in dieser Session verfügbar. Nach Beendigung der Session ist diese Variable nicht mehr vorhanden.

Wenn Sie in einer Batch-Datei aber eine Variable setzen wollen, auf der Sie auch später noch einmal zugreifen wollen, müssen Sie das Tool SETX.EXE aus dem Resource Kit verwenden. Wird die Variable auch in der aktuellen Session benötigt, müssen Sie zusätzlich noch SET.EXE verwenden.

setx Variable Wert [-m] | Erzeugt eine Variable mit dem Namen Variable und den Eintrag Wert.
setx Variable -k Registry-Schlüssel [-m] | Erzeugt eine Variable Mit diesem Wert aus dem Registry-Schlüssel
setx Variable -f Datei {-a x,y | -r x,y "string"} [-d d] [-x] [-m] | Erzeugt einen Variable mit dem Inhalt aus einer Textdatei

-m | Setzt den Wert im Maschinen Environment, Standard ist USER Environment
-f Datei | Die Datei, aus der die Environment Variable ausgelesen werden soll
-a x,y | Gibt die absoluten Koordinaten zum Auslesen an
-r x,y | Gibt die relativen Koordinaten zum String an
-d d | Gibt einen zusätzlichen Abgrenzer an
-x | Display Koordinaten

Info Mit dem Befehl SET in der Kommandozeilenoberfläche können Sie sich alle aktuellen Environment Variablen anzeigen lassen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1051.htm


ICACLS Dokumentation Fehler

Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen (CACLS und ICACLS)

CACLS.EXE

Mit diesem Programm können Sie die Zugriffskontroll-Listen (ACL - Access Control List) von Dateien anzeigen lassen und ändern.

cacls Dateiname [/t] [/e] [/c] [/g Benutzer:Berechtigung] [/r Benutzer [...]] [/p Benutzer:Berechtigung [...]] [/d Benutzer [...]]

Parameter:

Dateiname | Zeigt die ACLs der angegebenen Datei(en) an.
/t | Ändert die ACLs der angegebenen Dateien im aktuellen Verzeichnis und allen Unterverzeichnissen.
/e | Bearbeitet die ACL, anstatt Sie zu ersetzen.
/c | Führt das Ändern der ACLs fort, ohne Fehler zu beachten.
/g Benutzer:Berechtigung | Weist den angegebenen Benutzern Zugriffsberechtigungen zu. Mögliche Berechtigungen sind: r Lesen c Ändern (Schreiben) f Vollzugriff
/r Benutzer | Hebt die Zugriffsrechte für den angegebenen Benutzer auf. (nur gültig in Verbindung mit /e).
/p Benutzer:Berechtigung | Ersetzt die Zugriffsrechte des angegebenen Benutzers. Mögliche Berechtigungen sind: n Keine r Lesen c Ändern (Schreiben) f Vollzugriff
/d Benutzer | Lehnt angegebene Zugriffsrechte für Benutzer ab.

Es ist möglich, mehrere Dateien oder Benutzer in einem Befehl anzugeben.

Info Leider kann man mit Cacls keine erweiterten Rechte auf Dateien setzen. Dafür können Sie bei Microsoft ein Tool namens "XCACLS" herunterladen (Download). Mit diesem Tool (es ist ein VBS-Programm), können Sie dann auch die erweiterten Rechte auf Dateien/Verzeichnisse setzen.

ICACLS.EXE

Ab Windows Server 2003 SP2 und Windows Vista gibt es ICACLS.EXE als Nachfolger von CACLS.EXE, welches in seinem Funktionsumfang stark erweitert wurde. Die ICALCS-Version vom Windows Server 2003 können Sie auch unter Windows XP benutzen, die Version von Windows Vista nicht, da hier auch noch weitere Funktionen hinzugekommen sind, die nicht für Windows XP zu gebrauchen sind. Ein Vorteil von ICACLS gegenüber CACLS ist, dass vorhandene Vererbungen berücksichtigt und neue Berechtigungen korrekt gesetzt und vererbt werden. Deshalb kann der Einsatz dieses Tools auch unter Windows XP vorteilhaft sein.

Unter Windows Vista wird von ICACLS auch die Rechtevergabe Mandatory IL (Integrity Level) unterstützt.

Siehe dazu auch Tipp: "Sicherheitsmechanismus "Integrity Level" (IL)".

Mit ICACLS werden die Integrity Levels angezeigt und können damit auch bearbeitet werden. Leider lassen sich mit ICACLS wieder einmal nicht alle Rechte setzen (weiter unten verweisen wir auf andere Tools, mit denen das möglich ist).

Über den Befehl ICACLS /? können Sie sich die möglichen Aufrufe anzeigen lassen, hier jetzt die wichtigsten Befehlsparameter:

Info In der Hilfe der Parameter hat sich ein Fehler eingeschlichen, siehe Tipp: "ICACLS Dokumentation Fehler"

Aufruf | Beschreibung
ICACLS <Verzeichnis/Datei> /save <Dateiname> <Parameter> | Sichert die ACL-Einstellungen vom angegebenen Verzeichnis in die angegebene Datei
ICACLS <Verzeichnis/Datei> /restore <Dateiname> <Parameter> | Setzt die ACL anhand der erstellen Sicherungsdatei. Datei muss das Verzeichnis auf dem diese Sicherungs angewendet werden soll richtig angegeben werden, da der Pfad in der Sicherungsdatei nicht gespeichert wird.
ICACLS <Verzeichnis/Datei> /reset </T> | Setzte die ACL wieder auf die Standardmäßig vererbten Berechtigungen zurück.
ICACLS <Verzeichnis/Datei> /setowner <Benutzer> <Parameter> | Setzt den Besitzer "Owner" für eine Datei/Verzeichnis
ICACLS <Verzeichnis/Datei> /setintegritylevel [(CI)(OI)]<Stufe> | Fügt das Integrity Level hinzu: Stufe: L -> Low (Niedrig) M -> Medium (Mittel) H -> High (Hoch) (CI) -> Setzt Containervererbung (Verzeichnisse) (OI) ->Setzt Objektvererbung (Dateien)

Folgende Parameter können optional angegeben werden:

Parameter | Beschreibung
/T | Legt fest, dass auch die Unterordner innerhalb des Verzeichnisses mit berücksichtigt werden sollen. Ansonsten wird der Befehl nur auf den angegebenen Ordner angewendet.
/C | Legt fest, dass die Verarbeitung auch beim Auftauchen eines Fehler weitergeführt werden soll. Standardmäßig wird die Verarbeitung dann abgebrochen.
/L | Legt fest, dass die Verarbeitung auch auf symbolische Links und deren Zielverzeichnis ausgeführt werden soll.
/Q | Es werden keinen Erfolgsmeldungen ausgegeben.

Weitere Tools für das Anzeigen und Bearbeiten von Berechtigungen

Hilfreich ist u.a. hier das Tool "AccessChk" von Mark Russinovich. Mit diesem Tool können Sie sich auch einfach die Integrity Levels anzeigen lassen.

So können Sie sich mit dem Befehl "accesschk -d -e -s c:\" alle Verzeichnisse anzeigen lassen, die einen Integrity Level gesetzt haben.
Download: http://www.microsoft.com/technet/sysinternals/utilities/accesschk.mspx

Ein weiteres hilfreiches Tool ist "CHML" von Mark Minasi. Mit ICACLS kann man sich zwar alle Integrity Levels anzeigen lassen, aber nicht alle Typen setzen (wie z.B. "No Execute Up"). Wenn Sie diese Rechte auch setzen wollen, benötigen Sie dafür das Tool "CHML"
Download: http://www.minasi.com/vista/chml.htm

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0725.htm


Freigebene Drucker per Script/Kommandozeile verbinden/einrichten

Das Tool "Con2prt.exe" ist ein Befehlszeilen-Programm zum Hinzufügen oder dem Entfernen von Netzwerkdruckern.

CON2PRT [ /? | /h | /f | [/c \\printserver\share | /cd \\printserver\share]+]

/? | /h | Hilfe bzw. Parameter
/f | Löscht alle verbundenen Drucker
/c \\RechnerName\Freigabename | Richtet den Drucker ein
/cd \\RechnerName\Freigabename | Richtet diesen Drucker als Standarddrucker ein

Das Tool finden Sie im Zero Adminstration Kit, welches Sie kostenlos bei Microsoft herunter laden können (Download).

Es geht aber auch mit Windows Mitteln und zwar über rundll32 (siehe auch Tipp: Funktionen/Befehle der Dateien RUNDLL.EXE und RUNDLL32.EXE).

rundll32 printui.dll,PrintUIEntry /q /in /n \\ServerName\FreigabeName

Auszug aus der MS Hilfe (Aufruf über "Start" -> "Ausführen" -> rundll32 printui.dll,PrintUIEntry /?):

Syntax: rundll32 printui.dll,PrintUIEntry [Optionen] [@Befehlsdatei]

/a[Datei] | Name der Binärdatei
/b[Name] | Basisdruckername
/c[Name] | UNC-Computername, wenn die Aktion auf einem Remotecomputer ausgeführt wird.
/dl | Löscht den lokalen Drucker
/dn | Löscht die Netzwerkdruckerverbindung.
/dd | Löscht den Druckertreiber.
/e | Zeigt Druckeinstellungen an.
/f[Datei] | Entweder INF-Datei oder Ausgabedatei.
/ga | Fügt Druckerverbindungen pro Maschine hinzu.
/ge | Listet Druckerverbindungen pro Maschine auf.
/gd | Löscht Druckerverbindungen pro Maschine.
/h[Arch] | Eine der folgenden Treiberarchitekturen: Alpha | Intel | IA64 | x64
/ia | Installiert Druckertreiber mithilfe einer INF-Datei.
/id | Installiert Druckertreiber mithilfe des Assistenten.
/if | Installiert Drucker mithilfe der angegebenen INF-Datei.
/ii | Installiert Drucker mithilfe des Assistenten und einer INF-Datei.
/il | Installiert Drucker mithilfe des Assistenten.
/in | Fügt eine Netzwerkdruckerverbindung hinzu.
/j[Anbieter] | Druckanbietername
/k | Druckt eine Testseite auf dem angegebenen Drucker aus. Kann bei der Druckerinstallation nicht verwendet werden.
/l[Pfad] | Quellpfad des Druckertreibers
/m[Modell] | Modellname des Druckertreibers
/n[Name] | Druckername
/o | Zeigt die Druckerwarteschlange an.
/p | Zeigt Druckereigenschaften an.
/q | Stiller Modus. Fehlermeldungen werden nicht angezeigt.
/r[Anschluss] | Anschlussname
/s | Zeigt Servereigenschaften an.
/Ss | Speichert Druckereinstellungen in einer Datei.
/Sr | Stellt Druckereinstellungen aus einer Datei wieder her. Speichert Optionsattribute für Druckereinstellungen oder stellt diese wieder her. Die Attribute müssen am Ende des Befehls stehen: 2 PRINTER_INFO_2 7 PRINTER_INFO_7 c Farbprofil d Druckerdaten s Sicherheitsbeschreibung g Globaler DevMode m Minimale Einstellungen u Benutzer-DevMode r Namenskonflikte lösen f Namen erzwingen p Anschluss zuordnen
/u | Verwendet den vorhandenen Druckertreiber, sofern bereits einer installiert ist.
/t[#] | Nullbasierte Indexseite zum Starten
/v[Version] | Eine der folgenden Treiberversionen: Windows 95, 98 und Me | Windows NT 4.0 | Windows NT 4.0 oder 2000 | Windows 2000 oder XP | Windows XP
/w | Fordert einen Treiber an, wenn der angegebene Treiber nicht in der INF-Datei gefunden wird.
/y | Richtet den Drucker als Standarddrucker ein.
/Xg | Liest Druckereinstellungen.
/Xs | Richtet Druckereinstellungen ein.
/z | Gibt diesen Drucker nicht automatisch frei.
/Z | Erstellt den Druckernamen nicht automatisch
/K | ändert die Bedeutung von /v und /h um 0,1,2,3 (Windows x64 und Windows IA64| Windows NT x86 | Windows NT Alpha_AXP | Windows 4.0) mit einzubeziehen
/Z | Gibt diesen Drucker frei. Verwendung nur mit der Option /if möglich.
/? | Zeigt diese Hilfemeldung an.
@[Datei] | Befehlszeilen-Argumentsdatei.
/Mw[Nachricht] | Zeigt vor Ausführung des Befehls eine Warnung an.
/Mq[Nachricht] | Zeigt vor Ausführung des Befehls eine Bestätigung an.
/W[flags] | beschreibt die Attribute und Parameter für den Assistenten detailliert (für APW & APDW) r führt dazu, dass der Assistent von der letzten Seite aus neu gestartet werden kann
/G[flags] | bestimmt die globalen Attribute und Parameter w unterdrückt die Benutzeroberfläche Installationstreiber-Warnmeldungen (Modus Sehr Leise)

Beispiele:

Startet die Servereigenschaften:

rundll32 printui.dll,PrintUIEntry /s /t1 /n\\Computer

Startet die Druckereigenschaften:

rundll32 printui.dll,PrintUIEntry /p /n\\Computer\Drucker

Startet den Druckerinstallations-Assistent lokal:

rundll32 printui.dll,PrintUIEntry /il

Startet den Druckerinstallations-Assistent auf \\Computer:

rundll32 printui.dll,PrintUIEntry /il /c\\Computer

Startet die Warteschlangenansicht:

rundll32 printui.dll,PrintUIEntry /o /n\\Computer\Drucker

Startet eine INF-Installation:

rundll32 printui.dll,PrintUIEntry /if /b "Testdrucker" /f %windir%\inf\ntprint.inf /r "lpt1:" /m "AGFA-AccuSet v52.3"

Startet den Druckerinstallations-Assistent mithilfe einer INF-Datei:

rundll32 printui.dll,PrintUIEntry /ii /f %windir%\inf\ntprint.inf

Fügt eine Druckerverbindung pro Computer hinzu:

rundll32 printui.dll,PrintUIEntry /ga /c\\Computer /n\\Computer\Drucker /j"LanMan-Druckdienste"

Löscht die Druckerverbindung pro Maschine:

rundll32 printui.dll,PrintUIEntry /gd /c\\Computer /n\\Computer\Drucker

Zählt die Druckerverbindungen pro Maschine auf:

rundll32 printui.dll,PrintUIEntry /ge /c\\Computer

Fügt einen Druckertreiber mithilfe einer INF-Datei hinzu:

rundll32 printui.dll,PrintUIEntry /ia /c\\Computer /m "AGFA-AccuSet v52.3" /h "Intel" /v "Windows 2000 oder XP" /f %windir%\inf\ntprint.inf

Fügt einen Druckertreiber mithilfe einer INF-Datei hinzu:

rundll32 printui.dll,PrintUIEntry /ia /K /c\\Computer /m "AGFA-AccuSet v52.3" /h "WindowsNT x86" /v 3

Entfernt einen Druckertreiber:

rundll32 printui.dll,PrintUIEntry /dd /c\Computer /m "AGFA-AccuSet v52.3" /h "Intel" /v "Windows 2000 oder XP"

Entfernt einen Druckertreiber:

rundll32 printui.dll,PrintUIEntry /dd /K /c\Computer /m "AGFA-AccuSet v52.3" /h "Windows NT x86" /v 3

Richtet den Drucker als Standarddrucker ein:

rundll32 printui.dll,PrintUIEntry /y /n "Drucker"

Richtet einen Kommentar zum Drucker ein:

rundll32 printui.dll,PrintUIEntry /Xs /n "Drucker" Comment "Mein cooler Drucker"

Liest die Druckereinstellungen:

rundll32 printui.dll,PrintUIEntry /Xg /n "Drucker"

Schreibt die Druckereinstellungsergebnisse in eine Datei:

rundll32 printui.dll,PrintUIEntry /f "results.txt" /Xg /n Drucker"

Befehlssyntax für das Einrichten der Druckereinstellungen:

rundll32 printui.dll,PrintUIEntry /Xs /n "Drucker"

Speichert alle Druckereinstellungen in einer Datei:

rundll32 printui.dll,PrintUIEntry /Ss /n "Drucker" /a "datei.dat"

Stellt alle Druckereinstellungen aus einer Datei wieder her:

rundll32 printui.dll,PrintUIEntry /Sr /n "Drucker" /a "datei.dat"

Speichert Level-2-Druckerinformationen in einer Datei:

rundll32 printui.dll,PrintUIEntry /Ss /n "Drucker" /a "datei.dat"

Stellt aus einer Datei die Druckersicherheitsbeschreibung wieder her:

rundll32 printui.dll,PrintUIEntry /Sr /n "Drucker" /a "datei.dat"

Stellt aus einer Datei die globalen Devmode- und Druckerdaten wieder her:

rundll32 printui.dll,PrintUIEntry /Sr /n "Drucker" /a "datei.dat"

Stellt aus einer Datei die minimalen Einstellungen wieder her und löst den Anschlussnamen auf:

rundll32 printui.dll,PrintUIEntry /Sr /n "Drucker" /a "datei.dat" m p

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2028.htm


Umgebungsvariablen in Windows

Windows stellt standardmäßig einige Umgebungsvariablen (Environmentvariablen) zur Verfügung. Diese Variablen können in Loginscripts und Batch-Programmen verwendet werden.

Hier finden Sie eine Liste der Standard Umgebungsvariablen in Windows. Es kann sein das hier Einträge fehlen bzw. bei einigen Betriebssystem die Variablen nicht vorhanden sind. Sie können sich alle Variablen die aktiv sind folgendermaßen anzeigen lassen:

  • Eingabeaufforderungen starten (cmd.exe)
  • Hier jetzt Set eingeben und es wird eine Liste der möglichen Umgebungsvariablen angezeigt
Umgebungsvariable | Bedeutung
ALLUSERSPROFILE | Pfad zum Verzeichnis für ALLUser
APPDATA | Pfad zum Verzeichnis Anwendungsdaten bzw. AppData
COMPUTERNAME | Rechnername
COMMONPROGRAMFILES | Verzeichnis für gemeinsame Dateien
COMSPEC | Kommandoprozessor
HOMEDRIVE | Homelaufwerk
HOMEPATH | Homeverzeichnis
LOCALAPPDATA (ab Vista) | Lokale Programmdaten
LOHGONSERVER | Anmeldeserver (Domain)
NUMBER_OF_PROCESSORS | Anzahl Prozessoren
OS | Windows Name
PATH | Verzeichnisse in denen nach Befehlen gesucht wird. Die Verzeichnisse werden durch ein ; getrennt
PATHEXT | Dateiendungen
PROGRAMDATA (ab Vista) | Entspricht %ALLUSERPROFILE%
PROGRAMFILES | Verzeichnis für installierte Programme
PROMPT | Anzeigeformat der Eingabeaufforderung
PUBLIC (ab Vista) | Ablage für Dokumente usw. die von mehreren Benutzern verwendet werden
PROCESSOR_ARCHITECTURE | Prozessor Typ
PROCESSOR_IDENTIFIER | Prozessor Kennung
PROZESSOR_LEVEL | Prozessor Level
PROZESSOR_REVISION | Prozessor Version
SYSTEMDRIVE | Windows Laufwerk
SYSTEMROOT | Windows Verzeichnis
TEMP | Temp-Verzeichnis
TMP | Temp-Verzeichnis
USERDOMAIN | Domänenname
USERNAME | Name des angemeldeten Benutzers
USERPROFILE | Pfad zum eigenen Profilverzeichnis
WINDIR | Windows Verzeichnis

In der Systemsteuerung -> System -> Tabreiter "Erweitert" -> Button "Umgebungsvariablen" können Sie die Variablen bearbeiten und auch neue Variablen anlegen. Die Variablen werden hier getrennt nach "Benutzervariablen" und "Systemvariablen" angezeigt.

Gespeichert werden die Variablen in der Registry. Die Systemvariablen werden unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Environment" abgelegt und die Benutzervariablen unter "HKEY_CURRENT_USER\ Environment" bzw. ab WIndows Vista unter "HKEY_CURRENT_USER\ Volatile Environment".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0328.htm


Zeichenkettensuche am Prompt oder in einer Batchdatei

Mit dem NT-Proggie FINDSTR können Sie Zeichenketten am Prompt oder innerhalb von Batch-Daten in Dateien suchen.

Eine Liste der Parameter gibt es mit folgendem Parameter: FINDSTR /? |more

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0104.htm


Befehle für die Batchverarbeitung

Hier werden einige kurze Aufrufe gezeigt, die in Batchdateien hilfreich sein können. Weiterhin soll damit auch die Benutzung der Befehle anhand von Beispielen verdeutlicht werden.

Variable mit der aktuellen IP-Adresse setzen:

for /f "Tokens=2 Delims=[] skip=1" %%i in ('ping -n 1 %computername%') do set ip=%%i

echo %ip%

Workgroup/Domain Namen setzen:

For /F "tokens=3" %%i in ('Net Config Workstation^|Find /i "Workstation Domain "') Do @Set WORKGROUP=%%i&SETX WORKGROUP=%%i

echo %WORKGROUP%

Info SETXist ein Befehl aus dem MS Resource Kit, um eine Variable zu setzen, die nicht nur in der aktuellen Shell zu Verfügung steht. (damit können auch Systemvariablen gesetzt werden)

NET USE soll keine Meldungen mehr ausgeben:

NET USE X: 1>NUL 2>&1

Viele Verzeichnisse mit einem bestimmten Namen löschen:

for /d %1 in (tes*.tmp) do rd %1

Info Diese Zeile in eine Datei kopieren und anschließend die Datei mit einem Parameter aufrufen. Mit %1 wird hier der erste Parameter verarbeitet.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1017.htm


Verschieben von DHCP-Datenbanken

Der DHCP-Server speichert die Informationen über den Adressbereich und den Einstellungen in einer JET-Datenbank. Soll nun ein DHCP-Dienst auf einen anderen Server eingerichtet werden, aber die aktuellen Einstellungen (Bereiche und Reservierungen) mit übernommen werden, muss auch die Datenbank auf den anderen Server verschoben werden.

Sie können das auf den neuen Server natürlich alles wieder neu mit der Hand einrichten, so geht es aber etwas leichter:

Windows NT

  1. Installieren Sie den DHCP-Dienst auf den neuen Server
  2. Stoppen Sie den Dienst auf beiden Servern
  3. Kopieren Sie alles aus dem Verzeichnis "%SYSTEMROOT%\system32\dhcp" vom Quellserver auf den Zielserver und überschreiben Sie damit die dort befindlichen Dateien.
  4. Stellen Sie nun noch mit REGEDIT32 den Schlüssel "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\DHCPserver\Configuration"
  5. auf dem neuen System wieder her. Die Informationen dazu finden Sie in der Datei DhcpCfg die Sie im Backup-Verzeichnis unter "%SYSTEMROOT%\system32\dhcp" finden.
  6. Starten Sie den DHCP-Dienst auf den neuen Server und aktivieren Sie die Bereiche wieder

Windows 2000

Auch hier können Sie das Verschieben genauso machen wie oben unter Windows NT beschrieben oder Sie benutzen das Tool "dhcpexim.exe" aus dem "Windows 2000 Resource Kit Supplement 1", welches das Verschieben erleichtert und auch sicherer macht.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1150.htm


Lange Dateinamen auf dem Novell-Server

  • OS2.NAM muss vor dem Mounten des Volumes geladen werden, für das der Name-Space eingerichtet werden soll (also am Besten in der Startup.ncf).
    Das ist nur in den alten Novell Versionen 3.x nötig. Ab Netware 4.2 wird die Unterstützung für langeDateinamen automatisch unterstützt (long). In vorherigen Versionen der Netware (4.x bis 4.1) muss "load long.nam" in der startup.ncf eingetragen sein.
  • Zum (einmaligen) Einrichten des Name-Space für ein Volume muss man (wenn die Name-Space Unterstützung geladen ist) folgenden Befehl an der Konsole eingeben:
    ADD NAME SPACE <name, space-name> [TO [VOLUME]] <volume name>
    Für den OS/2-Name-Space heißt das folgend: add name space os2 to volume sys
    (4.x: add name space long to sys)
  • Nach der (korrekten) Eingabe des Befehls wird der Name-Space dem angegebenen Volume hinzugefügt. Dies kann je nach Größe und Hardware einige Minuten dauern.
  • Nun können Sie ohne Probleme auch unter Netware mit langen Dateinamen arbeiten.
  • Wenn Sie mit 3.11 arbeiten, müssen Sie noch einen Patch aus 311ptd.exe einspielen.
  • Der "Client für NetWare-Netzwerke" muss installiert sein. Mit der Shell von Netware 4.0x kann man leider keine langen Dateinamen benutzen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0212.htm


Doppelte Vergabe von IP-Adressen bei DHCP-Servern vermeiden

Ab dem Service Pack 2 ist es möglich, vor der Vergabe einer IP-Adresse von NT überprüfen zu lassen, ob die Adresse bereits verwendet wird. Dafür ist jetzt im Menü "Eigenschaften" des Befehlsservers ein Menü eingefügt worden, mit dem Sie die Überprüfung einstellen können. Standardmäßig setzt NT den Wert auf 0, was keiner Überprüfung entspricht.

Die Angabe einer Zahl steuert, wie oft NT ein Ping an die Adresse senden soll, bevor es die Adresse vergibt, wenn keine Antwort erfolgt.

Erhält der DHCP-Server auf diesen Ping eine Antwort, wird die Adresse als vergeben gekennzeichnet und durch den Eintrag "BAD_ADDRESS" markiert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0410.htm


Einstellungen des Replikationsdienstes

Windows NT kann Verzeichnisse zwischen mehreren Servern replizieren. In der Registry kann man Einstellungen zum Verhalten des Dienstes vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\Replicator\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Wie oft die zu replizierenden Verzeichnisse auf Veränderung überprüft werden sollen (in Minuten)
Intervall | REG_DWORD | 1 - 60 (Minuten) | 5 (Minuten)
Gibt an, wie lange ein Verzeichnis unverändert bleiben muss, bevor es repliziert werden darf (in Minuten) Dieser Eintrag wird nur bei Verzeichnissen mit "Unterverzeichnissen" berücksichtigt.
GuardTime | REG_DWORD | 0 (halber Wert vom Eintrag in "Interval") | 2 (Minuten)
Wie oft die Aktualisierungsnachricht vom Import-Server versendet wird.
Pulse | REG_DWORD | 1-10 | 3
Dieser Wert wird automatisch vom Verzeichnisreproduktionsdienst gesetzt. Wenn der Wert nach einem Fehlerfall immer noch in der Registry stehen sollte, kann er gelöscht werden.
CrashDir | REG_SZ | Verzeichnisname |
Gibt an, wie lange Importserver max. warten dürfen, bevor Sie eine Aktualisierung anfordern. Der Importserver benutzt die Random Zeit des Exportservers, um die Zufallszahl zu ermitteln, wann der die Daten anfordert. Dadurch werden gleichzeitige Zugriffe von vielen Servern vermieden.
Random | REG_DWORD | 1- 120 (Sekunden ) | 60
Art der Reproduktion: 1: Der Server verwaltet die Replikation. 2: Der Server erhält die Aktualisierungsnachrichten vom Exportserver 3: Der Server exportiert/importiert in beide Richtungen
Replicate | REG_DWORD | 1-3 | 3

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0346.htm


Ausfall des PDC

Wenn im Netz der PDC für längere Zeit ausfällt, kann ein bestehender BDC die Aufgabe übernehmen, indem er zum PDC heraufgestuft wird.

Um aus einem BDC einen PDC zu machen, selektiert man im Servermanager den BDC und wählt unter Computer den Punkt "Promote to Primary Domain Controller".

Geht der ursprüngliche PDC wieder ins Netz, bemerkt er, dass bereits ein PDC vorhanden ist und startet seine Server-Dienste nicht. Nun sollte man ihn über den Servermanager zum BDC konfigurieren, damit seine Datenbank mit der vom jetzigen PDC abgeglichen wird.

Wurde die Datenbank abgeglichen, kann man die ursprünglichen Verhältnisse wiederherstellen, indem man den BDC zum PDC heraufstuft. Dadurch wird automatisch der jetzige PDC zum BDC.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0397.htm


Aktualisierungszeit der Serverliste

Die Server-Liste wird bei Windows standardmäßig alle 12 Minuten aktualisiert. Daher kann es einige Zeit dauern, bis ein neuer Server in der Liste erscheint. Das Entfernen eines nicht mehr existenten Servers dauert sogar noch länger, da ein Server erst nach dem dritten Intervall aus der Liste entfernt wird.

Um diese Zeit zu ändern, müssen Sie bei allen Rechnern folgende Registry-Einträge anpassen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

erstellen Sie dort den Eintrag "Announce" als Datentyp REG_DWORD. Tragen Sie dort die Zeit in Sekunden für die Aktualisierung der Liste ein (Standard = 720 sec.).

Außerdem muss bei allen Browsern die Zeitspanne angepasst werden, nach der diese die aktualisierte Liste beim Master-Browser abholen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Browser\ Parameters

Dieser Wert ist für die Last im WAN verantwortlich:

"MasterPeriodicity" als Datentyp REG_DWORD. Dieser Wert gibt an, wie häufig Domänen Master Browser Informationen zu den Master Browsern verteilen.

Dieser Wert ist für die Last im Subnetz verantwortlich:

"BackupPeriodicity" als Datentyp REG_DWORD. Tragen Sie dort die Zeit in Sekunden ein (Sekunden : 300 - 4294967 (0x418937 = 49 Tage, 8 Stunden), in der die neue Liste beim Master-Browser abgeholt wird (Standard = 720 sec.).

Dieser Wert legt fest, wie oft Informationen zwischen Master Browser und Sicherungs Browser ausgetauscht werden sollen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=134985

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0008.htm


Aktualisierungszeit von BDCs

Unter Windows werden BDCs (Backup Domain Controller) standardmäßig alle 300 Sekundenaktualisiert. Das kann aber Netz und Prozessor belasten.

Sie können in der Registry angeben, wie häufig der PDC (Primary Domain Controller) die BDCs (Backup Domain Controller) aktualisieren soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Netlogon\ Parameters

Schlüssel

Datentyp

Angabe als

Standard

Legt fest, in welchem Zeitabstand alle BDC über neue Daten informiert werden. Innerhalb dieses Zeitraumes werden alle Informationen über SAM/LSA-Änderungen gesammelt.

Ist dieser Wert in der Registrierung nicht angegeben, sucht sich NetLogon selbständig einen Optimalwert, der vom Domänen-Controller abhängig ist.

Pulse

REG_DWORD

60 bis 172 800 Sekunden (48 Stunden)

300 (5 Minuten)

Gib die max. Anzahl der Pulse an, die ein PDC gleichzeitig an einen BDC schickt. Ein großer Wert erhöht die RPC-Aufrufe und steigert damit natürlich die Serverlast. Ist der Wert zu klein, wird natürlich das Zeitintervall für das Versenden der Änderungen vergrößert.

PulseConcurrency

REG_DWORD

1 bis 500 Pulse

20

Bestimmt die Impulshäufigkeit. Jeder BDC schickt mindesten einen Impuls in diesem Abstand ohne Rücksicht darauf, ob seine Datenbank bereits auf dem neuesten Stand ist.

PulseMaximum

REG_DWORD

60 bis 172 800 Sekunden (48 Stunden)

7200 (2 Stunden)

Legt die Zeit fest, wie lange ein PDC auf die Antwort des BDC wartet. Wird in dieser Zeit nicht geantwortet, wird das als Fehler gewertet. Wird der Wert zu klein angegeben, kann es vorkommen, dass ein BDC als nicht antwortend angenommen wird. Antwortet er dann nach dieser Zeit doch, wird die ganze Datenbank repliziert, was die Netzlast unnötig erhöht. Ein zu hoher Wert kann hingegen bei vielen nicht antwortenden BDC die Zeit der Aktualisierung aller Server erhöhen, da nur die unter "PulsConcurrency" angegebene Zahl an Verbindungen aufgebaut wird.

PulseTimeout1

REG_DWORD

1 bis 120 Sekunden

5

Legt die Zeit fest, in welcher der BDC dem PDC nach einer Replication geantwortet haben muss.

PulseTimeout2

REG_DWORD

60 bis 3600 Sekunden

300 (5 Minuten)

Legt fest, wie lange ein BDC wartet, nachdem er einen Impuls vom PDC empfangen hat, bis er sich meldet. Dieser Wert sollte immer kleiner sein als der Wert in "PulseTimeout1".

Ist dieser Wert in der Registry nicht angegeben, sucht sich NetLogon selbständig einen Optimalwert, der vom Domänen-Controller abhängig ist.

Randomize

REG_DWORD

0 bis 120 Sekunden

1

Ist dieser Wert gesetzt, wird beim Start vom "Netlogon"-Dienst immer die Datenbank vollständig synchronisiert.

Update

REG_SZ

Yes oder No

No

Legt Umfang und Häufigkeit der Aufrufe fest. Wird der Wert auf 50% gesetzt, wird nur noch ein 64 KByte Puffer (statt sonst 128 KByte) gesetzt. Setzen Sie diesen Wert nicht zu niedrig an, da ansonsten die Replikation nie vollständig durchgeführt werden kann. Ein Wert von "0" bedeutet, dass nicht mehr repliziert wird, wodurch die Datenbank vollständig durcheinander geraten würde.

ReplicationGovernor

REG_DWORD

0 bis 100 (Prozent)

100

Damit die Einstellung wirksam wird, muss der "Net Logon"- Service am PDC mit dem Servermanager über -> "Computer" -> "Services" angehalten und wieder gestartet werden.

Info Wenn Sie die Einstellungen ändern, müssen Sie sicherstellen, dass alle Änderungen ausreichend schnell vom PDC zum BDC übertragen werden. Ansonsten kann es zu Problemen kommen, da z.B. Änderungen von Kennwörtern nicht beim BDC ankommen.

Info Wenn Sie die Zeiten zu klein wählen und die Änderungen nicht mehr vollständig übertragen werden können, kann es vorkommen, dass das jeweilige Änderungslog keine weiteren Daten mehr aufnehmen kann. Dann wird automatisch eine Vollsynchronisation der Benutzerdatenbank durchgeführt, was eine hohe Netzlast bedeutet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0398.htm


FTP-Verzeichnisanzeige mit Informationen

Das im MS IIS integrierte FTP kann zu jedem Verzeichnis eine Informationsdatei ausgeben. Diese Funktion müssen Sie aber erst in der Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ FTPSVC\ Parameters

setzen Sie den Wert "AnnotateDirectories" auf "1"

Die Informationen, die der FTP-Dienst anzeigen soll, müssen sich im jeweiligen Verzeichnis befinden und zwar in einer Datei mit dem Namen "ftpsvc.ckm". Diese Datei sollte man am besten mit dem Attribut "Hidden" versehen, damit sie nicht im FTP-Verzeichnis angezeigt wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0213.htm


Mehr als 10 Clients an NT-Server (Trial)

Wenn Sie nur eine Trial-Version von Windows NT-Server besitzen, ist die Anzahl der max. n Verbindungen auf 10 Clients eingeschränkt.

Sie können diese Einschränkung mit folgendem Registry-Wert umgehen, bedenken Sie dabei aber, das Sie damit u. U. gegen die Lizenzbedingungen verstoßen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

erstellen Sie einen neuen Eintrag mit dem Namen Users als Datentyp REG_DWORD. Setzen Sie den Wert auf 0xffffffff (entspricht keiner Limitierung).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1336.htm


Windows Server Service konfigurieren

Mit diesem Tipp können Sie den Serverservice manuell konfigurieren. Sie können zwischen "Netzwerkdurchsatz", "geringen Speicherverbrauch" oder "gleichmäßige Verteilung" wählen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ lanmanserver\ parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "Size" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Netzwerkdurchsatz
1 | gleichmäßige Verteilung
2 | geringer Speicherverbrauch

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1616.htm


Automatisches Erkennen von langsamen Netzwerkverbindungen aktivieren

Windows benutzt ein Timeout, um die Geschwindigkeit von Netzwerken zu erkennen und teilt das Netzwerk in "langsam" und "schnell" ein. Windows wartet dafür einfach eine bestimmte Zeit (Standard: 2000 Millisekunden). Erhält das System innerhalb dieser Zeit eine Antwort, ist es eine schnelle Netzwerkverbindung, ansonsten wird eine langsame Netzwerkverbindung erkannt. Diese Funktion können Sie ganz ausschalten bzw. die Zeit angeben, ab wann Windows eine Netzwerkverbindung als langsam einstuft.

In einigen Netzwerken kann es sinnvoll sein, die Standard Timeout-Zeit von 2000 Millisekunden zu verändern, um z.B. bei schmalen Bandbreiten zu verhindern, dass Windows das Profil über die Leitung lädt, oder bei Normalen Netzwerken, wo es zu Hauptanmeldezeiten im Netzwerk zu Verzögerungen kommen kann. Sie können die Zeit erhöhen, um sicherzustellen, dass immer eine schnelle Netzwerkverbindung erkannt wird.

Diese Einstellungen können Sie in der Registry vornehmen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie den Wert "SlowLinkDetectEnabled" als Datentyp REG_DWORD und setzen diesen Wert auf 0, um die automatische Erkennung auszuschalten bzw. auf 1 (Standard), um die Funktion zu aktivieren.

Mit diesem Wert "SlowLinkTimeOut" als Datentyp REG_DWORD stellen Sie die Zeit in Millisekunden ein, nach welcher Zeit eine langsame Netzwerkverbindung erkannt werden soll. Der Standardwert ist hier 2000 Millisekunden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1114.htm


Neue IP-Adresse vom DHCP-Server beziehen

Normalerweise holt sich ein Client erst eine neue IP-Adresse, wenn die Lease-Zeit abgelaufen ist. Am Rechner selber kann man durch die Eingabe von "IPCONFIG /RELEASE" auch dafür sorgen, dass der Client eine neue IP-Adresse vom DHCP-Server anfordert.

Durch Setzen eines entsprechenden Registry-Keys wird der Client dazu veranlasst, sich nach einem Reboot eine neue IP-Adresse zu besorgen. Damit kann man in Netzwerken z.B. durch eine Batch-Datei, ohne großen Aufwand die Neuvergabe von IP-Adressen veranlassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Enum

hier gibt es den Eintrag "NextInstance" als Datentyp REG_DWORD welcher den Wert "00000001" besitzt.

Wenn Sie diesen Wert auf "00000000" ändern, zieht sich der Client nach einem Reboot eine neue Adresse vom DHCP- Server.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0517.htm


Verbindung zu einem Server mit zwei unterschiedlichen USER-ID

Ab und zu ist man unter Windows mit einer bestimmten USER-ID angemeldet und möchte auf einem bestimmten Server etwas ändern, wozu die Rechte dieser USER-ID aber nicht ausreichen.

Wenn man zu diesem Server noch keine Verbindung hat, kann man das auch ohne Probleme machen, indem man beim Verbinden zum Server einfach die andere USER-ID angibt.

Probleme gibt es aber, wenn mit der anderen USER-ID schon eine Verbindung zu diesen Server besteht. Windows wird Ihnen mit einer Fehlermeldung die Verbindung verwehren.

Durch einen Trick können Sie aber trotzdem eine zusätzliche Verbindung zu diesen Server herstellen, ohne erst alle bestehenden Verbindungen, die mit der anderen USER-ID hergestellt wurden, beenden zu müssen. Dazu ist es nötig, dass Sie in einem Netzwerk mit TCP/IP arbeiten, was ja heutzutage in fast allen Netzwerken benutzt wird.

Der Trick ist nun, eine Verbindung zum selben Server herzustellen, ohne dass Windows NT bemerkt, dass es sich um denselben Server handelt.

Da die meisten Verbindungen zu einem Server über den Servernamen erfolgen (NET USE X: \\Server-1\Test), erstellen Sie die zusätzliche Verbindung nicht mit dem Servernamen, sondern mit der IP-Adresse (NET USE F: \\120.120.10.10\Test). Da Windows keine Namensauflösung für IP-Adressen durchführt, geht das Betriebssystem von verschiedenen Rechnern aus und stellt die Verbindung ohne Fehler her.

Wenn Sie die IP-Adresse gerade nicht wissen, können Sie die mit einem Ping die Adresse recht einfach in Erfahrung bringen. Pingen Sie den Server einfach mit seinem Namen an, Windows wird Ihnen dann die IP-Adresse anzeigen (PING Server-1).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0688.htm


Maschinenkonto-Kennwort Änderung ausschalten

Bei der Verbindung eines Client-Rechners mit dem Domänen-Server wird ein Maschinenkonto-Kennwort übermittelt. Aus Sicherheitsgründen wird dieses Kennwort zyklisch geändert.

Wenn Sie jetzt z.B. mit VM-Ware arbeiten und hier ein älteres Snapshot zurückspielen, geht die Anbindung an die Domäne verloren, und Sie müssen den Rechner wieder neu in die Domäne aufnehmen. Das kommt natürlich daher, dass ältere Snapshot mit einem alten Passwort arbeiten und deshalb die Anmeldung an der Domäne scheitert.

Deshalb kann es gerade für VM-Ware-Testumgebungen sinnvoll sein, den automatischen Wechsel des Kennworts zu unterbinden. Ändern Sie dafür einfach folgenden Registryeintrag:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Netlogon\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePasswordChange" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Kennwortänderung ausschalten
0 | Zyklische Kennwortänderung aktiviert(Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2173.htm


Anzeigen der benutzten TCP-Ports

In diesem Tipp wird beschrieben, wie Sie sich die offenen Ports anzeigen lassen können.

Wenn Sie Anwendungen benutzen, die über TCP-Ports kommunizieren, kann es vorkommen, dass zwei Anwendungen die gleichen Ports benutzen. Dies führt unweigerlich zu Fehlern.

Um den Fehler zu beseitigen, müssen Sie wissen, welche Ports überhaupt in Benutzung sind. Hierfür können Sie das Programm "NETSTAT" benutzen.

Wenn Sie "NETSTAT" folgendermaßen aufrufen: NETSTAT -an, erhalten Sie eine Liste aller benutzten Verbindungen.

Wenn Sie "NETSTAT -ao" eingeben, wird Ihnen am ende der Liste noch die PID-Nummer ausgegeben. Bei der PID handelt es sich um die Nummer, welche angibt von welcher Anwendung dieser Port belegt wird. Über den Befehl "TASKLIST" können Sie sich dann den aktuellen Namen zur PID suchen. Sie können aber auch den Taskmanager öffnen und hier im Tabreiter "Prozesse" finden Sie auch die Anwendungen. Jetzt müssen Sie sich nur noch über "Ansicht" -> "Spalten auswählen" durch die Auswahl von "PID (Prozess-ID)" die PID anzeigen lassen und zusätzlich durch die Auswahl von "Prozesse aller Benutzer anzeigen" werden Ihnen auch alle laufenden Anwendungen angezeigt.

Eine Übersicht von häufig verwendeten Ports finden Sie unter http://www.portliste.de/und http://www.iana.org/assignments/port-numbers

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1143.htm


Informationen über Netzwerkverbindungen

Mit den Befehl "NETSTAT.EXE" erhalten Sie detaillierte Informationen über alle aktuellen Netzwerkverbindungen (TCP, UDP und IP).

Damit können Sie feststellen, ob jemand über einen offenen Port auf Ihren Rechner zugreift. Mit dem Befehl "NETSTAT -a 5" wird Ihnen z.B. alle 5 Sekunden die aktuelle Liste aller Netzwerkverbindungen angezeigt.

Angezeigt wird Ihnen dabei:

  • benutztes Protokoll
  • der Port
  • die Netzwerkadresse der Gegenseite
  • Zustand der Verbindung.

Info Öffnen Sie dafür die Kommandozeile und geben Sie dort den Befehl ein.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0799.htm


Netzwerkverbindungen nicht speichern

Wenn Sie nicht möchten, dass ein Anwender dauerhafte Netzwerkverbindungen erstellen kann, können Sie das über die Registry für den Anwender abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\.DEFAULT\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Network\ Persistent Connections\

hier können Sie Mit diesem Wert "SaveConnections" als Datentyp REG_SZ durch Eintragen von "no" das Speichern von Netzwerkverbindungen unterbinden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0579.htm


Timeout für die Anmeldung einstellen

Wenn Sie versuchen, sich an einem Netzwerk anzumelden und die Meldung erhalten "A domain controller for your domain could not be contacted" ist höchstwahrscheinlich die Timeout Zeit zu klein.

In diesem Fall sollten Sie den Timeout-Wert für die Anmeldung in der Registry erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Netlogon\ Parameters

erstellen Sie einen neuen Wert mit dem Namen "ExpectedDialupDelay" als Datentyp REG_DWORD. Geben Sie hier jetzt die Zeit in Sekunden ein, die das System bis zur Timeoutmeldung warten soll. Die möglichen Werte liegen zwischen 0 - 600.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0477.htm


Zentrale Host-Datei im Netzwerk

Normalerweise muss die HOSTS-Datei im Verzeichnis "%SYSTEMROOT%\system32\drivers\etc" liegen.

Will man die HOSTS aber auf einen zentralen Share ablegen, muss man die Pfadangabe verändern. Die Pfadangabe finden Sie in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet \Services\ Tcpip\ Parameters

hier finden Sie den Wert "DataBasePath" als Datentyp REG_EXPAND_SZ, dort ändern Sie nun einfach die Pfadangabe.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0415.htm


Administrative Einstellungen für Netzwerke

Unter -> "Systemsteuerung" -> "Server" -> "Warnungen" können Sie angeben, an welchen Rechner bzw. Benutzer die Warnmeldungen geschickt werden sollen. Wenn Sie einen Rechner angeben, wird die Meldung immer an den Rechner geschickt, unabhängig von dem gerade angemeldeten Benutzer. Geben Sie einen Benutzernamen an, erhält nur dieser die Warnmeldung. Hat sich dieser Benutzer an mehreren Rechnern angemeldet, werden Warnmeldungen trotzdem nur an einen Rechner geschickt.

Warnmeldungen können Sie in der Registry einstellen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet \Services\ LanmanServer\ Parameters

Dort gibt es folgende Parameter:

Schlüssel

Datentyp

Angabe als

Standard

Definiert, wie oft der Server auf Warnzustände prüft und die erforderlichen Warnmeldungen sendet

AlertSched

REG_DWORD

1 - 65535 (Minuten)

5 (Minuten)

Gibt den Prozentsatz an freiem Speicherplatz auf dem Datenträger an, der unterschritten werden muss, damit eine Warnmeldung gesendet wird

DiskSpaceThreshold

REG_DWORD

0- 99 (Prozent)

10 (Prozent)

Legt die Anzahl der Fehler im System fest, die auftreten dürfen, bevor eine Warnmeldung gesendet wird

ErrorThreshold

REG_DWORD

1 - 65535

10

Löst eine Warnung aus, wenn der Prozentsatz abgebrochener Netzwerkoperationen den angegebenen Wert überschreitet

NetworkErrorThreshold

REG_DWORD

1 - 100 (Pozent)

5

Automatische Trennung vom Server konfigurieren

Hiermit wird angegeben, wie lange ein virtueller Kreis ohne eine neue Nachricht bleiben darf, bis die Verbindung getrennt wird. Werden noch Daten bzw. Suchfunktionen ausgeführt, dann wird natürlich keine automatische Trennung durchgeführt. Durch einen niedrigen Wert kann man Ressourcen auf dem Server sparen. Das kann aber zu Verzögerungen bei Clients führen, die öfter eine neue Verbindung zum Server aufbauen müssen.

Über die Kommandozeile kann der Wert auch geändert werden:

net config server /autodisconnect:3

autodisconnect:-1 deaktiviert Autodisconnect

autodisconnect: 0 erzwingt den sofortigen Abbruch der Verbindung

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?KBid=138365

AutoDisconnect

REG_DWORD

0 - 0xFFFFFFF

Minuten

15

Es wird festgelegt, ob NT Server automatisch verborgene Freigabenamen für lokale Laufwerke erzeugen soll (Wert: 1). Auf diese Freigaben haben selbstverständlich nur Administratoren Zugriff

AutoShareServer

REG_DWORD

Boolean

1

Hiermit wird ein Text festgelegt, den der Server bei Meldungen einsetzt und der bei Anfragen über "NetServerGetInfo" auch mit ausgegeben wird

Comment

REG_SZ

Textstring

leer

Bestimmt die Zeit, ab wann die Verbindung zum Server unterbrochen wird, wenn der Client in der Zeit keine Anfrage zum Server geschickt hat. Die Verbindung wird auch unterbrochen, wenn der Client noch offene Dateien auf den Server hat (für IPX)

ConnectionlessAutoDisc

REG_DWORD

15 -

(Minuten)

15

Hiermit geben Sie an, ob alte IPX-Verbindungen (direct host) noch unterstützt werden. Wird nur bei älteren Windows für Workgroups Clients benötigt, die Named Pipes bei IPX nicht richtig unterstützen. Wenn Named Pipes nicht benötigt werden, können Sie diesen Wert auf True setzen und so Normale Dateiein- und ausgaben erlauben

EnableWFW311DirectIpx

REG_DWORD

True oder False

False

Legt fest, ob der Server für andere Rechner zu sehen ist. Beim Ausschalten werden einfach keine Ankündigungsnachrichten mehr verschickt

Hidden

REG_BINARY

Boolean

0

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0395.htm


Verborgene Freigaben

Verzeichnisse, die normalerweise freigegeben werden, sind in der Browserliste für jeden sichtbar, auch wenn er nicht die Berechtigung hat, die Verzeichnisse einzusehen.

Soll ein Verzeichnis nicht in der Browserliste erscheinen, muss dem Freigabenamen ein $ hinzugefügt werden. Will man sich nun mit diesen Verzeichnis verbinden, muss man den Freigabenamen kennen, da er ja nicht mehr angezeigt wird.

Info Beim Verknüpfen muss nun das $ mit angegeben werden.

Windows erstellt standardmäßig einige versteckte Verzeichnisse:

Freigabename: | Lokales Verzeichnis
ADMIN$ | %SYSTEMROOT% (Das Windows NT Verzeichnis)
C$ | Root von C:\
x$ | Root anderer Datenträger

Info Wie man das Erstellen dieser Standardfreigaben unterbinden kann, finden Sie unter: "Entfernen der administrativen Standardfreigaben"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0345.htm


Zeit synchronisieren

Um mit einem Windows Server die Zeit der angeschlossen Clients zu synchronisieren, gehen Sie auf folgende Weise vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

Erstellen Sie hier den Eintrag "TimeSource" als Datentyp REG_DWORD und weisen ihm als Wert "1" zu.

Die Clients können nun mit:

"NET TIME /DOMAIN:<name> /SET /y" synchronisiert werden.

Den Zeitserver kann man mit:

"NET TIME \\<computername> /SET /y" mit einem Rechner synchronisieren, der die Zeit z.B. von einer Atomuhr holt.

Sie müssen bei diesem Vorgehen sicherstellen, dass derjenige, der sich am PC anmeldet, auch das Recht besitzt, die Systemzeit zu verändern. Dazu müssen Sie im Benutzer-Manager unter "Richtlinien" -> "Benutzerrechte" den USER in der Gruppe "Ändern der Systemzeit" bzw. "Change System Time" mit aufnehmen.

Man muss also einem Benutzer mehr Rechte geben, nur wer möchte das gern in seinem Netz machen. Aus diesen Grunde sollte man lieber den TimeServer aus dem Resource Kit von MS installieren. Der TimeServer wird als Dienst installiert und diesem Dienst kann man nun ohne Probleme die benötigten Rechte geben.

XNTP-Server

Wer einen genauen Zeitserver braucht, sollte sich auf seinen Server einen "XNTP-Server" installieren. Für UNIX findet man im Internet ohne Ende Tools dafür. Ich musste aber lange suchen, um auch einen für NT zu finden.

Unter der Adresse:

auf: http://www.jpsdomain.org/public/tools/

findet man die Dateien:

xntp3-5_90_3-gui.zip

xntp3-5_90_3-nongui.zip

Damit können Sie sich einen guten Zeitserver aufbauen, der sehr genau alle Rechner im Netz synchronisieren kann.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0416.htm


Entfernen der administrativen Standardfreigaben

Standardmäßig wird von Windows jedes Festplattenlaufwerk freigegeben (C$, D$, IPC$, Admin$ usw.). Diese Freigaben kann man zwar löschen, Windows stellt Sie aber nach jedem Neustart wieder automatisch her.

Wollen Sie dies endgültig unterbinden, ändern Sie folgendes in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

Für die Server-Version:

AutoShareServer als Datentyp REG_DWORD auf "0" setzen bzw. auf "1", um es wieder zu aktivieren

Für die Workstation-Version:

AutoShareWks als Datentyp REG_DWORD auf "0" setzen bzw. auf "1", um es wieder zu aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0411.htm


Nicht mehr vorhandene Freigaben

Die Freigaben für Verzeichnisse werden in der Registry gespeichert. Wenn Sie nun das Verzeichnis löschen ohne vorher die Freigabe zu beenden, versucht NT trotzdem die Verzeichnisfreigabe zu erstellen und gibt eine Fehlermeldung im Ereignisprotokoll aus.

Sie können diese Freigabe nur noch über den Servermanager beenden oder löschen den entsprechenden Eintrag manuell aus der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\ Shares

finden Sie alle erstellten Freigaben. Löschen Sie einfach die Einträge die nicht mehr benötigt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0609.htm


Rechner im Netzwerk nicht mehr anzeigen

Im Netz werden normalerweise alle aktiven Server und Workstations angezeigt. Wenn Sie es verhindern wollen, können Sie gezielt einzelne Server/Workstations in der Browser-Liste ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

legen Sie den Binärwert "Hidden" als Datentyp REG_DWORD an. Diesem Binärwert können Sie die Werte "0" oder "1" zuweisen.

Wenn Sie "Hidden" auf "1" setzen, wird der Rechner nach aktualisieren der Serverliste nicht mehr im Netz angezeigt. Der Rechner steht aber weiterhin allen Benutzern zur Verfügung und kann über die Freigaben angesprochen werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0719.htm


Deaktivieren des Hinzufügens von Default-Netzwerk-Routen

Windows fügt selbständig Default-Netzwerk-Routen hinzu. Da man dieses Verhalten schlecht kontrollieren kann, sollte man diese Funktion über einen Registrykey deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ [Name]\ Parameters

erstellen Sie hier einen neuen Wert mit dem Namen "DontAddDefaultRoute" als Datentyp REG_DWORD.

setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0942.htm


TCP/IP Source-Routing deaktivieren

Standardmäßig ist das "Source Routing" unter Windows aktiviert. Mit folgen Eintrag in der Registry können Sie diese Funktion deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie den Wert "DisableIPSourceRouting" als Datentyp REG_DWORD. Sie können hier folgende Werte eingeben:

0 | Source Routing aktiviert
1 | Source Routing deaktiviert, wenn IP forwarding aktiviert (Standard)
2 | Source Routing komplett deaktiviert (beste Sicherheit)

Info Weitere Informationen hierzu finden Sie in der Knowledge Base: http://support.microsoft.com/?kbid=217336

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0904.htm


Standard TCP/IP-Ports

Hier folgt eine Auflistung der Standard TCP/IP Ports von Windows.

Es handelt sich um keine vollständige Aufzählung, da zusätzlich installierte Dienste weitere Portnummern belegen (Web-Browser, Mail-Client usw.).

Funktion | Protokoll | Portnummer
Anmeldesequenz | UDP und TCP | 137,138 (UDP), 139 (TCP)
Browser-Dienst (Computersuchdienst) | UDP | 137 und 138
Benutzer Manager | TCP | 139
Client/Server Kommunikation zwischen Exchange Mail-Client und Server | TCP | 135
DHCP-Lease | UDP | 67 und 68
DHCP-Manager (Administration des DHCP-Servers) | TCP | 135
DNS-Administration | TCP | 139
Drucken | UDP, TCP | 137,138 (UDP), 130 (TCP)
DNS-Namensauflösung | UDP | 53
Ereignisanzeige | TCP | 139
Exchange-Administrator | TCP | 135
IMAP (Exchange-Server) | TCP | 143
LDAP (Exchange-Server) | TCP | 389
LDAP unter SSL (Exchange-Server) | TCP | 636
NT-Verbindung (z.B. für Anmeldeprozesse) | UDP, TCP | 137, 138 (UDP), 139 (TCP)
PPTP | TCP | 1723, IP-Protokoll 47
POP3 (Exchange-Server) | TCP | 110
Prüfung von Zugriffen bereits angemeldeter USER im Netz | UDP, TCP | 137, 138 (UDP), 139 (TCP)
Registry-Editor | TCP | 139
RPC, Client-Server-Kommunikation (Exchange Server) | TCP | 135
Server Manager | TCP | 139
Systemmonitor | TCP | 139
SMTP (Exchange Server) | TCP | 25
Verzeichnisreplikation | UDP und TCP | 138 (UDP) und 139 (TCP)
Zugriffe auf den Datei-Server | TCP | 139
Vertrauensstellungen (Trust) | UDP, TCP | 138, 138 (UDP), 139 (TCP)
Windows NT Diagnose | TCP | 139
WINS-Replikation | TCP | 42
WINS-Manager | TCP | 135
WINS-Registrierung | TCP | 137
X.400-MTA (Exchange-Server) | TCP | 102

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0214.htm


TCP/IP forwarding unter Windows aktivieren

Standardmäßig ist unter Windows das "TCP/IP forwarding" (Weiterleiten von IP Paketen) deaktiviert. Wenn Sie einen RAS-Dienst installieren und dort IP-Routing aktiviert haben, wird dieser Eintrag automatisch von Windows gesetzt. Wenn Sie aber auch ohne RAS-Dienst das Weiterleiten von IP-Paketen erlauben wollen, müssen Sie folgenden Wert in der Registry setzen (siehe unten).

Wenn Sie das gemacht haben, erlauben Sie das Weiterleiten von IP-Paketen an andere Rechner im Netzwerk. Jetzt müssen Sie noch eine Routingtabelle anlegen, wohin diese Pakete weitergeleitet werden sollen. Das können Sie mit dem Befehl "route" in der Eingabeaufforderung erledigen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Hier finden Sie den Eintrag "IPEnableRouter" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=140859
http://support.microsoft.com/?kbid=169415
http://support.microsoft.com/?kbid=169548

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0908.htm


LMHOST Suchfunktion konfigurieren

Über die LMHOST-Datei wird die Domänenauflösung durchgeführt. Mit diesem Tipp können Sie beeinflussen, wie Windows diese Suche durchführen soll.

Mit "Anzahl der max. n #PRE Einträge" legen Sie fest, wie viele Einträge aus der Datei max. ausgelesen werden, der Standardwert liegt hier bei 100.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ NetBT\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableLMHOSTS" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | LMHost Datei auswerten (Standard)
0 | LMHost Datei nicht auswerten

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxPreLoad" als Datentyp REG_DWORD und legen Sie hier die Anzahl der max. n #PRE Einträge fest.

Erstellen Sie hier einen neuen Wert mit dem Namen "NodeType" als Datentyp REG_DWORD und legen Sie hier die Reihenfolge fest:

1 | Kein WINS-Server angegeben (B-Node broadcast)
4 | Erst broadcast Anfrage, dann Namenserveranfrage (M-Mode)
8 | WINS-Server abfrage (H-Node)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1627.htm


Deaktivieren der DCOM-Unterstützung in Windows

Das Distributed Component Object Model (DCOM) ist ein Protokoll, das Softwarekomponenten die direkte Kommunikation über ein Netzwerk ermöglicht. DCOM (bisher als "Netzwerk-OLE" bezeichnet) ist für die Verwendung auf mehreren Netzwerk-Transportschichten, u. a. für Internetprotokolle wie HTTP, konzipiert.

Wenn Sie DCOM ausschalten, kann das auf folgende Funktionen Auswirkungen haben:

  • COM-Objekte, die von einem Remote-Standort aus gestartet werden können, funktionieren eventuell nicht ordnungsgemäß.
  • Das lokale COM+ Snap-In kann möglicherweise keine Verbindung zu Remote-Servern herstellen, um den COM+ Katalog abzufragen.
  • Die automatische Zertifikatsregistrierung funktioniert eventuell nicht ordnungsgemäß.
  • Programm von anderen Herstellern, die über DCOM arbeiten.
  • Windows Management Instrumentation (WMI)-Abfragen auf Remote-Servern funktionieren eventuell nicht ordnungsgemäß.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Ole

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableDCOM" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

N | DCOM deaktivieren
Y | DCOM ist aktiv (Standard)

Ab Windows 2000 geht es auch über das Programm "dcomcnfg.exe":

Klicken Sie hier unter Konsolenstamm auf "Komponentendienste" -> "Computer" und hier mit der rechten Maustaste auf "Arbeitsplatz". Im Kontextmenü wählen Sie nun Eigenschaften aus. Ihnen wird jetzt eine Box "Eigenschaften vom Arbeitsplatz" angezeigt, wo Sie unter dem Tabreiter "Standardeigenschaften" über "DCOM (Distributed COM) auf diesem Computer aktivieren" die Funktion ein/ausschalten können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1703.htm


Remute Shutdown des Computer Browser Service deaktivieren

Remote Shutdown des Computer Browser Service deaktivieren

Wenn man über das Netzwerk die Computer Browser beenden kann, kann man seinen eigenen Rechner zum Master-Browser erklären.

Dadurch übernimmt dieser Rechner die "Kontrolle" über das Subnetz. Mit diesem Tipp wird gezeigt, wie man das Herunterfahren der Browserdienste über das Netzwerk verhindern kann.

Für Windows NT oder 2000 müssen Sie noch das entsprechende folgende Patch herunter laden und einspielen:

Download Windows NT

Download Windows 2000

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MrxSmb\ Parameters

legen Sie den Wert "RefuseReset" als Datentyp REG_DWORD an. Setzen Sie diesen Wert auf 1, damit der Dienst nicht Remote (über das Netzwerk) beendet werden kann.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2014.htm


Kommentarfeld der Rechner im Netzwerk verändern

Hier legen Sie den Anzeigenamen im Servermanager und der Netzwerkumgebung fest, die bei einem Rechner zusätzlich mit angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\ Parameters

ändern Sie hier den Wert "srvcomment" als Datentyp REG_SZ und geben Sie die gewünschte Beschreibung ein die angezeigt werden soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2142.htm


Browserliste für weitere Domänen

Browserliste für zusätzliche Domänen

Standardmäßig werden in der Browserliste nur die Rechner vom lokalen Netzwerk aufgenommen. Mit diesem Tipp können Sie diese Liste um zusätzliche Domänen erweitern. Dafür müssen Sie nur im Registrywert "OtherDomains" den Namen der anderen Domänen angeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanWorkstation\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "OtherDomains" als Datentyp REG_MULTI_SZ und für jede weitere Domäne einen weiteren neuen Eintrag mit dem Namen der Domäne.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2599.htm


Verbinden und Trennen von Netzwerklaufwerken aus dem Kontextmenü entfernen

Mit dieser Policy können Sie Verbinden und Trennen von Netzwerklaufwerken aus dem Kontextmenü und dem Explorer entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetConnectDisconnect" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Optionen "Netzlaufwerk verbinden" und "Netzlaufwerk trennen" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1470.htm


IIS schreibt keine Log-Dateien mehr

Beim Internet Information Server 4.0 (IIS) kann es vorkommen, dass keine Log-Dateien mehr geschrieben werden. Das passiert, wenn die LOG-Datei in eine SQL-Server Datenbank geschrieben wird und dabei ein Fehler in der Kommunikation auftritt. Beim Auftreten des ersten Fehlers wird das Schreiben der LOG-Datei beendet und kann nur durch einen Neustart des IIS aktiviert werden.

Mit dem Einspielen von Service Pack 4 ist das Problem behoben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0743.htm


Konfigurieren der TCP/IP Paketfilter (Ports)

Unter Windows Server können Sie in der Netzwerkumgebung unter den Protokollen bei den IP-Eigenschaften festlegen, für welche Ports der Zugriff aktiviert werden soll. Soll diese Einstellung an mehreren Rechnern vorgenommen werden, kann man sich die Arbeit mit einer REG-Datei, welche die benötigten Änderungen direkt in die Registry einträgt, erleichtern.

Führen Sie die Änderung an einem Rechner durch und exportieren Sie dann die betreffenden Schlüssel.

Für das Setzen der Paketfilter sind folgende Registrykeys verantwortlich:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

über:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Wird mit dem Eintrag "EnableSecurityFilters" als Datentyp REG_DWORD die Filterfunktion aktiviert. Wenn Sie diesen Wert auf 1 setzen, ist die Filterfunktion aktiviert. Standardmäßig steht dieser Wert auf 0, wodurch die Filterfunktion deaktiviert ist.

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ [AdapterName]\ Parameters\ Tcpip

(ersetzen Sie [AdapterName] durch die jeweilige Netzwerkadapterbezeichnung)

Unter diesem Schlüssel finden Sie drei identische Einträge für TCP (TcpAllowedPortS), UDP(UdpAllowedPorts) und IP (RawIPAllowedProtocols) als Datentyp REG_BINARY.

Unter diesen Werten werden die zulässigen Portnummern als ASCII-Werte kodiert angegeben. Nach jeder Portangabe erfolgt ein Nullbyte, das gesamte wird durch ein weiteres Nullbyte gekennzeichnet.

Der Eintrag zum Freischalten der Ports 80 und 81 lautet also in hexadezimaler Notierung z.B. 38 30 00 38 31 00 00

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0837.htm


TCP/IP-Timer bei Datenübertragung

Bei der Übertragung von Daten über TCP wird eine Verbindung zwischen Sender und Empfänger aufgebaut. Die Daten werden in einzelnen Paketen gesendet und durchnummeriert. So kann der Empfänger feststellen, ob er alle Pakete erhalten hat und fehlerhafte Datenpakete erneut anfordern.

Der Sender erwartet für jedes Datenpaket eine Bestätigung, dass es fehlerfrei empfangen wurde. Erhält der Sender nun keine Antwort von Empfänger, weiß er nicht, ob das Paket oder nur die Bestätigung verlorengegangen ist. Der Sender wartet standardmäßig 3 Sekunden und sendet das Paket erneut, wenn er innerhalb dieser Zeit keine Bestätigung erhält. Dieses macht der Sender 3 einmal, wobei sich die Wartezeit immer wieder verdoppelt, erst dann wird die Verbindung als fehlerhaft erkannt und die Übertragung abgebrochen.

Also:

Paket senden -> 3 Sekunden auf Bestätigung warten -> Paket erneut senden -> 6 Sekunden auf Bestätigung warten -> Paket erneut senden -> 12 Sekunden auf Bestätigung warten -> Abbruch nach 21 Sekunden !

Diese Zeit können Sie unter Windows und Windows NT ab Service Pack 6 in der Registry konfigurieren. Das kann z.B. bei langsamen VPNs (virtuellen privaten Netzwerken) über das Internet nötig sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "InitialRtt" als Datentyp REG_DWORD.

Der Wertebereich liegt zwischen 0 und 65535 und entspricht der Zeit in Millisekunden. Der Standardwert ist 3000 (3 Sekunden ).

Info Das Verändern dieses Wertes sollte mit Vorsicht erfolgen, da sich hierdurch auch das Erkennen einer fehlerhaften Verbindung verlängert. Verdoppeln Sie z.B. den Wert (auf 6 Sekunden ), so verdoppelt sich der Wert, bis eine fehlerhafte Verbindung erkannt wird, auf 42 Sekunden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0512.htm


Gültigkeitszeit der Dateien im Cache

Greift ein Client auf einen Webserver zu, um sich dort Dateien abzuholen, wird ihm mitgeteilt, wie lange diese Dateien gültig sind. Besitzt der Client einen Cache, holt er sich für diese Zeit die Datei aus dem Cache und greift erst nach Ablauf dieser Zeit wieder auf den Webserver zu.

Der IIS (Internet Information Server) ermittelt diese Zeit, indem er zu der aktuellen Systemzeit einen Wert aus der Registry addiert.

Diesen Wert sollten Sie anpassen, so dass er ungefähr Ihrer Aktualisierungszeit der Webseite entspricht. Dazu müssen Sie folgenden Wert in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ W3SVC\ Parameters

Hier finden Sie den Wert "GlobalExpire" als Datentyp REG_DWORD. Mögliche Werte liegen zwischen 0 und 0 xFFFFFFFF. Die Angabe erfolgt in Sekunden. Wenn Sie 0 Sekunden einstellen, werden die Dateien sofort ungültig und damit erst gar nicht in den Cache des Clients übernommen.

Standardwert: 0xFFFFFFFF

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0830.htm


Protokollierung von angemeldeten FTP-Anwendern abschalten

Der FTP-Dienst unter Windows erzeugt eine LOG-Datei, in der alle Aktionen protokolliert werden. Wird der FTP-Dienst auch im Internet verwendet, können die Log-Dateien schnell sehr groß werden. In der Registry können Sie die Protokollierung für angemeldete Anwender abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ FTPSVC\ Parameters

finden Sie den Wert "LogNonAnonymous" als DatentypREG_DWORD. Setzen Sie hier den Wert auf 0, um das Schreiben eines Logfiles auszuschalten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0534.htm


Kein Verbindungsaufbau im DFÜ-Netzwerk

Scheitert ein Verbindungsaufbau mit einem Internet-Provider aus unerklärlichen Gründen mit Fehlermeldungen wie "Falsches Passwort", "Leitung ist gestört" etc., kann dies auch an dem Versuch von Windows NT liegen, das Passwort verschlüsselt zu übertragen.

Zur Deaktivierung dieser Funktion reicht eine Änderung der Passwortoption in den Eigenschaften des DFÜ-Netzwerks.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1131.htm


Protokollierung der RAS-Dienste konfigurieren

Fehler im RAS (Remote Access Service) werden im Windows Ereignisprotokoll protokolliert.

Bei einer Fehlersuche, sind meist ausführlichere Informationen über einen Fehler sehr hilfreich. Ein ausführlicheres LOG können Sie dafür über die Registry aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RasMan\ Parameters

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RasMan\ PPP

Ändern Sie hier jeweils den Wert "Logging" als Datentyp REG_DWORD von 0 auf 1, um die ausführliche Protokollierung zu starten.

Jetzt wird ein ausführliches Log unter "%SYSTEMROOT%\System32\Ras" die Datei "Device.log" und "PPP.log" erstellt. Die Größe der Datei liegt bei max. 100 KByte, danach werden die alten Einträge wieder überschrieben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0840.htm


Paketgröße von RAS-Verbindungen verändern

Die standardmäßige zulässige Paketgröße bei RAS-Verbindungen liegt bei einem Maximum von 1514 Byte. Wenn man eine sehr schlechte Telefonverbindung hat, kann das Verringern der Paketgröße Vorteile bringen. Da bei der Verringerung der Paketgröße auch der Datendurchsatz sinkt, ist diese Veränderung nur bei sehr schlechten Verbindungen anzuraten.

Die Einstellung können Sie in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ AsyncMacn\ Parameters

ändern Sie den Wert "MaxFrameSize" als Datentyp REG_DWORD entsprechend ab. So können Sie hier den Wert z.B. auf 576 Byte reduzieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0839.htm


RAS (Remote Access Service) Installation

Wollen Sie eine Verbindung über einen ISDN-Adapter aufbauen, muss dieser vor der RAS-Installation als Netzwerkkarte installiert werden. Dafür benötigen Sie eine Treiber-Diskette vom Hersteller der ISDN-Karte. ("Systemsteuerung" -> "Netzwerk" -> "Netzwerkkarte" -> "Hinzufügen" -> "Diskette").

Beim analogen Modem haben Sie die Möglichkeit, es während der RAS-Installation einzubinden. Sollte Ihr Modem aber an eine "intelligente" serielle Schnittstellenkarte mit mehreren Ports angeschlossen sein, müssen Sie die Karte (lt. Herstellerangaben) wie bei ISDN zuerst installieren.

  1. "Systemsteuerung" -> "Netzwerk" und dort das Register "Dienste" auswählen.
  2. "Hinzufügen" -> "RAS-Dienst (Remote Access Service)" auswählen.

NT installiert zuerst einige Treiber von der CD und danach erscheint die Dialogbox "RAS-Gerät", in der alle installierten RAS-fähigen Geräte angezeigt werden. Sollten Sie Ihr Modem noch nicht installiert haben, können Sie nun über "Modem installieren" weitere Modems hinzufügen.

Die meisten gängigen Modems können mit Hilfe der "Automatischen Erkennung" installiert werden. Sollte Ihr Modem nicht erkannt werden, bleibt Ihnen noch die manuelle Konfiguration.

Nachdem Sie ein Modem gewählt haben, erscheint die Dialogbox "RAS-Setup" mit folgenden Möglichkeiten:

Hinzufügen:

Installation von weiteren Modems

Entfernen:

Entfernt das Modem aus der Liste

Konfigurieren:

Hier können Sie Anschlussverwendung einstellen:
- Nur ausgehende Anrufe
- Nur eingehende Anrufe
- Ein- und ausgehende Anrufe
(Für eine Internetanbindung ist "Nur ausgehende Anrufe" ausreichend)

Duplizieren:

Kopieren der Konfiguration auf einen freien Anschluss

Netzwerk:

diese Box sieht je nach Einstellung bei "Konfiguration" unterschiedlich aus:
bei Auswahl von "Nur ausgehende Anrufe" erscheint nur:
Protokolle:

NetBEUI

TCP/IP

IPX/SPX-kompatibles Protokoll

(Für eine Internetanbindung benötigen Sie nur TCP/IP)

bei der Auswahl von "Ein- und ausgehende Anrufe" erscheint zusätzlich noch:

Server Einstellung:

Hier haben Sie die Möglichkeit, nur bestimmte Protokolle zuzulassen. Außerdem sollten Sie bei nur MS-Netzwerken die Option "Nur-Microsoft-verschlüsselte Echtheitsbestätigung" einstellen.

Klicken Sie auf -> "Weiter". Jetzt wird NT die Installation abschließen und nach einem Neustart steht Ihnen der RAS-Dienst zur Verfügung.

Das werden Sie am Anmeldebildschirm sehen, weil es nun die Möglichkeit gibt, sich über RAS bei einem Server anzumelden (natürlich nur, wenn Sie auch "Ausgehende Anrufe" installiert haben).

Info Zur Konfiguration einer Internetanbindung über T-Online lesen Sie weiter unter T-Online Verbindung ohne Decoder.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0089.htm


Wie kann man die 128-Bit RAS Entschlüsselung aktivieren?

Wenn man die 128-BIT Version von Service Pack Installiert hat (ist in Deutschland nicht so ohne weiteres zu bekommen), kann man unter RAS auch die 128-Bit Entschlüsselung aktivieren.

Unter "Systemsteuerung" -> "Netzwerk" -> "Dienste" -> "RAS-Dienst (Remote Access Service)" -> "Properties" dort unter "Netzwerk" aktivieren Sie "Require Microsoft encrypted authentication". Klicken Sie auf "Require data encyption" und bestätigen Sie es mit "OK", die Frage nach einem Neustart müssen Sie verneinen.

Starten Sie den Registry Editor

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RasMan\ PPP\ COMPCP

Erstellen Sie einen neuen Wert als Datentyp REG_DWORD mit dem Namen: ForceStrongEncryption. Setzen Sie den Wert auf 1

Starten Sie den Rechner nun neu.

Wird das von RAS-Client unterstützt, erhalten Sie im Eventlog folgende Meldung:

Event ID: 20107

Source: RemoteAccess

Description: The user RAS connected to port COM1 using strong encryption.

Ansonsten erscheint folgende Meldung und die Verbindung wird beendet:

Event ID: 20077

Source: RemoteAccess

Description: An error occurred in the Point to Point Protocol module on port COM1. The remote computer does not support the required encryption type.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0608.htm


RAS Server soll erst nach mehrmaligem Klingeln abheben

RAS Server soll erst nach mehreinmaligem Klingeln abheben

Normalerweise können Sie das in der Datei "%SYSTEMROOT%\system32\ras\modem.inf" einstellen.

In der Zeile für das betreffende Modem wird einfach der Eintrag

command_Listen=ats0=1<cr>

bearbeitet bzw. hinzugefügt, wobei ats0=n die Anzahl der Rings bestimmt (Neustart erforderlich).

Wenn das RAS aber ein TAPI (Telephony Applikation Programming Interface) Unimodem-gestütztes Device benutzt, muss man anders zu Werke gehen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RasMan\ Parameters

legen Sie einen neuen Wert mit dem Namen "NumberOfRings" als Datentyp REG_DWORD an. Dort können Sie nun die gewünschte Anzahl der Rings Eintragen. Werte über 20 werden durch den Standardwert 1 ersetzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0683.htm


RAS Verbindung beim Abmelden halten

Wenn man sich bei aktiver Internetverbindung vom System abmeldet bzw. einen Benutzerwechsel durchführen möchte, schließt Windows die Verbindung.

Um auch nach dem Abmelden eine RAS-Verbindung (DFÜ-Verbindung) zu halten, ist es notwendig, den folgenden Registryzweig zu editieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

dort ist dem Wert "KeepRasConnections" als Datentyp REG_SZ der Zahlenwert "1" zuzuweisen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0653.htm


RAS-Verbindung nicht automatisch beenden

Normalerweise beendet Windows eine RAS-Verbindung nach 20 min. Inaktivität automatisch. Mit einem Eintrag in der Registry können Sie es aber ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RemoteAccess\ Parameters

Dort wird bei "AutoDisconnect" als Datentyp REG_DWORD angegeben nach welcher Zeitspanne die Verbindung abgebrochen werden soll. Mögliche Werte sind 0-1000 Minuten, wobei 0 für keinen automatischen Abbruch der Verbindung steht (Standard ist 20 Minuten).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0717.htm


Automatisch die RAS-Verbindung zum Anmelden benutzen

Wenn Sie wollen, dass die Anmeldung an Windows automatisch über eine RAS-Verbindung durchgeführt werden soll, müssen Sie nur diese Funktion aktivieren. Dann müssen Sie nicht erst extra beim Anmelden diese Funktion aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

erstellen Sie hier eine neuen Eintrag mit dem Namen "RasForce" als Datentyp REG_SZ. Setzen Sie den Wert auf 1.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=172125

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0939.htm


MODEM.INF

Die Konfigurationsdatei für Modems befindet sich im Verzeichnis %winroot%/system32/rasman und heißt MODEM.INF. Hier findet man alle von NT unterstützten Modems wieder. Jedes hat seinen eigenen Abschnitt. Suchen Sie in dieser Datei den für Sie in Frage kommenden Typ heraus und editieren hier z.B. den Eintrag "COMMAND_INIT", um Ihr Modem entsprechend zu konfigurieren.

Interessant sind vor allem solche Sequenzen, die zwischen "<" und ">" stehen - das sind Konstanten, die an vorangehender Stelle definiert wurden. Möglicherweise müssen Sie auch dort etwas ändern. Grundsätzlich kann man hier aber jedes Modem zum Betrieb bewegen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0241.htm


ELSA 28.8TQV mit RAS

Hier finden Sie die Konfigurationseinstellungen für das ELSA Modem mit RAS Zugriff.

Der Eintrag in der Modem.INF heißt:

[ELSA MicroLink 288TQV - GER]

<hwflowcontrol_off>=\\Q0

<hwflowcontrol_on>=\\Q3

<protocol_off>=\\N0

<protocol_on>=\\N3

<compression_off>=%C0

<compression_on>=%C3

<speaker_off>M0

<speaker_on>=M1

<autodial_on>=ATDT

<autodial_off>=ATD

CALLBACKTIME=30

DEFAULTOFF=

MAXCARRIERBPS=28800

MAXCONNECTBPS=115200

COMMAND_INIT=AT&F L1 X3 S0=0 S2=128 S7=55 S31=64\\V1<cr>

COMMAND_INIT=AT<protocol><compression><hwflowcontrol><speaker><cr>

COMMAND_LISTEN=ATS0=1<cr>

CONNECT=<cr><lf>CONNECT <carrierbps><cr><lf>

CONNECT_EC=<cr><lf>CONNECT <carrierbps>/REL<cr><lf>

COMMAND_DIAL=<autodial><phonenumber><cr>

CONNECT=<cr><lf>CONNECT <carrierbps><cr><lf>

CONNECT_EC=<cr><lf>CONNECT <carrierbps>/REL<cr><lf>

COMMAND_DIAL=<autodial><phonenumber><cr>

CONNECT=<cr><lf>CONNECT <carrierbps><cr><lf>

CONNECT_EC=<cr><lf>CONNECT <carrierbps>/REL<cr><lf>

DETECT_STRING=ATI6<cr>

DETECT_RESPONSE=MicroLink 288ooTL

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0125.htm


ELSA ISDN/TL und RAS

Der Eintrag in der Modem.INF heißt:

;----------------------------------------

; Default - Auto-Mode

; <compression_off> - BTX-VT100-Mode

; <protocol_off> - HDLC transparent

;

[ELSA MicroLink ISDN/TL V.34]

<speaker_off>=M0

<speaker_on>=M1

<hwflowcontrol_off>=\\Q0

<hwflowcontrol_on>=\\Q3

<compression_off>=\\N8

<compression_on>=

<protocol_off>=\\N10%P1

<protocol_on>=

<autodial_on>=ATD

<autodial_off>=ATD

CALLBACKTIME=30

DEFAULTOFF=

MAXCARRIERBPS=64000

MAXCONNECTBPS=115200

COMMAND_INIT=AT&F S0=0 S2=128 \\V1<cr>

COMMAND_INIT=AT<speaker><hwflowcontrol><compression><protocol><cr>

COMMAND_LISTEN=ATS0=1<cr>

CONNECT=<cr><lf>CONNECT <carrierbps><cr><lf>

CONNECT_EC=<cr><lf>CONNECT <carrierbps>/REL<cr><lf>

COMMAND_DIAL=<autodial><phonenumber><cr>

CONNECT=<cr><lf>CONNECT <carrierbps><cr><lf>

CONNECT_EC=<cr><lf>CONNECT <carrierbps>/REL<cr><lf>

;----------------------------------------

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0413.htm


Modem Anpassung unter Windows-NT 4.0

Hier wird einmal das Vorgehen aufgezeigt, um ein Modem anzupassen, was von NT nicht richtig installiert wurde. Je nach Modem ist das Vorgehen etwas unterschiedlich. Diese Beschreibung behandelt das Modem: ETECH E288MX

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  1. Um zunächst den ERROR-Response des Modems zu analysieren, muss das Logging des Modems via "Systemsteuerung" -> "Modem" -> "Eigenschaften-Erweitert" im Feld "Protokolldatei aufzeichnen" eingeschaltet werden. Nach dem missglückten Wahlvorgang steht diese Log-Datei mit dem Geräte-Namen im Verzeichnis %root%\winnt. Sämtliche Hardware-Initialisierungsdateien in Zeichenform (*.inf) und vorkompilierter Form (*.pnf) stehen im Verzeichnis %root%\winnt\inf. Dort ist die Init.-Datei herauszusuchen, die vom Namen am nächsten des zu ändernden Gerätes liegt (hier: mdmetech.inf) und in einen Editor zu laden. Neben den Sektionen "Manufacturer", "Model" oder "Strings" findet man gleich in der ersten Sektion "Version" den Parameter "ClassGUID". Diesen Wert schreibe man auf oder kopiere ihn.
  2. Registry-Editor starten und ins Fenster "HKEY_LOCAL_MACHINE" gehen. Dort im Subtree "SYSTEM\CurrentControlSet\Control\Class" mit der Funktion "Ansicht" -> "Schlüssel-suchen" nach der entsprechenden ClassGUID suchen (im Eingabefeld der Suchfunktion muss der Schlüssel mit "{" und "}" eingegrenzt werden).
  3. Nun entsprechende Änderungen im Subtree "Hangup", "Init" oder "Settings" vornehmen. In diesem Beispiel war im Subtree "Settings" der Parameter "SpeedNegotiation_ON" von "$M1" auf "\J0" und der Parameter "SpeedNegotiation_OFF" von "$M0" auf "\J1" zu setzen, der Wert des Parameters "DialSuffix:REG_SZ" zu löschen und im String des Subtrees "Settings\Init" entsprechende Änderungen vorzunehmen (hier: den AT-Befehl für das Speed-handling entsprechend anpassen).
  4. Außerdem muss der Wiederholwert des Parameters "Init" in der Datei "mdmetech.inf" im Abschnitt "[MfgAddReg]" auf 1 gesetzt werden, damit überflüssige Initialierungsbefehle vermieden werden und verhindert wird, dass nach dem Senden von "ATDT" ein weiteres Senden von "ATDT123456" (123456 steht für die Tel.-Nr) erfolgt, was das Modem mit "Delay_Call" quittiert und im übrigen als Response von der RAS-DFÜ-Schnittstelle nicht verstanden wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0414.htm


Modem-Support für nicht unterstütze Modems (Unimodem)

Windows unterstützt auch Modems, die Windows selber nicht kennt (Unimode Modems). Dafür muss Windows NT die Datei MODEM.INF als Konfigurationsdatei akzeptieren. Damit Windows diese Datei benutzt, müssen Sie diesen Tipp aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ RAS\ PROTOCOLS

ändern Sie hier den Wert "EnableUnimodem" als Datentyp REG_DWORD und setzen den Wert auf:

1 | MODEM.INF auswerten (Unimodem)
0 | MODEM.INF nicht berücksichtigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2114.htm


Deaktivieren der Möglichkeit das DFÜ-Passwort zu speichern

Standardmäßig wird Ihnen bei DFÜ-Verbindungen die Möglichkeit angeboten, das Passwort zu speichern, damit Sie es bei späteren Verbindungen nicht wieder eingeben müssen.

Diese Funktion stellt aber eine Sicherheitslück e da, da jetzt auch andere Personen damit arbeiten können.

Bei sicherheitsrelevanten Rechnern sollten Sie am besten diese Möglichkeit ganz deaktivieren, damit die Speicherung des Kennworts nicht versehentlich aktiviert wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RasMan\ Parameters

Erstellen Sie einen Eintrag mit dem Namen "DisableSavePassword" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0941.htm


PPTP auf bestimmte Adressen begrenzen

PPTP (Point-to-Point Tunneling Protocols) wurden eingeführt, um beliebige Datenpakete über PPP-Verbindungen (Internet) zu transportieren. Ein Vorteil ist auch die Sicherheit, da die Daten verschlüsselt übertragen werden können.

Standardmäßig ist PPTP für alle IP-Adressen freigeschaltet, aus Sicherheitsgründen können Sie PPTP aber auch auf bestimmte IP-Adressen beschränken. Dazu müssen Sie folgende Einträge in der Registry vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RasPptpe\ Parameters\ Configuration

Legen Sie hier einen neuen Wert mit dem Namen "AuthenticateIncoming-Calls" als Datentyp REG_DWORD und weisen Sie ihm den Wert 1 zu. Hiermit stellen sie ein, dass nur noch PPTP-Verbindungen zu Clients aufgebaut werden, die unter folgendem Wert angegeben werden:

Legen Sie dafür den Wert "PeerClientIPAddresses" als Datentyp REG_BINARY an. Geben Sie hier die gewünschten IP-Adressen an.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0825.htm


Anwählen zu lokalen Rechnern abschalten

Haben Sie für das Internet das automatische Anwählen aktiviert, so wird bei Netzwerkadressen, die nicht vorhanden sind, automatisch eine Verbindung aufgebaut. Dabei kann es vorkommen, dass Windows auch bei der Auswahl von lokalen Netzwerkadressen versucht, eine Verbindung aufzubauen.

Das passiert, da NT durch einen Fehler ab und zu auch lokale Netzwerkadressen in diese Liste mit einträgt. Um das zu korrigieren, müssen Sie diese Einträge aus der Registry entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ RASAutodial\ Addresses

Finden Sie die Adressen, für die Windows eine Verbindung aufbauen will und entfernen Sie die IP-Adresse Ihres lokalen Computers.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0527.htm


MDAC Zugriff über das Internet

Mit MDAC (Microsoft Data Access) gibt es über "DataFactory" die Möglichkeit, Daten über das Internet abzurufen.

Durch eine Sicherheitslücke (bis MDAC 2.0) war es möglich, Programme über das Internet auf den Rechner auszuführen. Durch das Aktivieren vom "Save Mode" sichern Sie Ihren Rechner dagegen ab (alle Versionen).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DataFactory\ HandlerInfo

Erstellen Sie hier einen neuen Wert mit dem Namen "HandlerRequired" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Sichert den Rechner gegen Zugriffe ab
0 | Kein "Save Mode"

Info Weitere Informationen dazu finden Sie unter:
http://www.microsoft.com/TechNet/security/bulletin/ms99-025.asp

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1400.htm


Bessere Sicherheit der lokal gespeicherten Benutzerdatenbank

Bei Windows 2000/XP bzw. NT 4.0 ab Service Pack 3 wird auch das Programm "syskey.exe" auf Ihren Rechner installiert. Mit diesem Programm können Sie Ihre Benutzerdatenbank etwas besser verschlüsseln, um gegen Angriffe von außen abgesichert zu sein.

So finden Sie z.B. auf der Homepage "http://www.sysinternals.com" ein Programm, welches durch Booten von Diskette das Passwort von jedem Account ändern kann, dadurch können sich Leute unberechtigt administrative Rechte verschaffen.

Die Programme greifen auf die SAM (Security Account Manager) zu, die als Datei unter %SYSTEMROOT%\System32\Configin jedem System abgelegt sind.

Durch den Aufruf des Programms "Syskey.exe" können Sie mit der Schaltfläche "Aktualisieren" Ihren Systemschutz verbessern. Dabei haben Sie folgende Möglichkeiten:

  1. Unter "Kennwort für den Systemstart" können Sie ein Passwort festlegen. Jetzt müssen Sie bei jedem Systemstart noch vor der eigentlichen Benutzeranmeldung ein zusätzliches Kennwort eingeben.
  2. Mit "Schlüssel für den Systemstart lokal speichern" unter "Vom System generiertes Kennwort" erfolgt die Anmeldung wie immer, das Kennwort wird dabei automatisch erstellt und auf der Festplatte abgelegt.
  3. Mit der Funktion "Schlüssel für den Systemstart auf die Diskette speichern" ebenfalls unter "Vom System generiertes Kennwort" wird das Kennwort auf einer Diskette in einer 16 kB großen Datei (STARTKEY.KEY) abgelegt. Wenn Sie den Rechner jetzt starten wollen, müssen Sie immer die Diskette beim Systemstart einlegen.

Info Bedenken Sie aber, dass diese Verschlüsselung nicht wieder rückgängig gemacht werden kann. Sie sollten sich das eingegebene Kennwort gut merken bzw. eine Sicherheitskopie der Diskette anlegen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0576.htm


Zeit für 'Hinweis auf Passwortänderung' einstellen

Windows teilt einen Anwender standardmäßig 14 Tage vor Ablauf des Passwortes mit, dass das Passwort geändert werden muss. Für viele kommt diese Meldung viel zu früh. In der Registry können Sie diesen Wert beliebig ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie einen neuen Wert "PasswordExpiryWarning" als Datentyp REG_DWORD und tragen als Wert die Anzahl der Tage vor dem Ablauf des Passwortes ein.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=135403

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0672.htm


Passwortschutz beim Bildschirmschoner

Wenn man den Kennwortschutz des Bildschirmschoners unter Windows aktiviert, so hat man ca. 5 Sekunden Zeit, nachdem der Bildschirmschoner aktiviert wurde, um ihn wieder zu beenden, ohne das Passwort einzugeben. Erst wenn man länger wartet, muss das Passwort eingegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "ScreenSaverGracePeriod" als Datentyp REG_SZ. Geben Sie hier einen Wert zwischen 0 - 2.147.483 Sekunden an. Der Standardwertist 5.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1398.htm


Verbesserte Passwortsicherheit erzwingen

Ab Windows NT Service Pack 2 können Sie die Erstellung der Passwörter der Anwender/User beeinflussen.

Wenn Sie die neuen Funktionen aktivieren, müssen die Anwender bei der Vergabe von Passwörtern mindestens drei der folgenden Vorgaben beachten:

  • das Passwort muss mindestens 6 Zeichen lang sein
  • das Passwort muss Klein und Großbuchstaben enthalten
  • das Passwort muss Ziffern enthalten
  • das Passwort muss Sonderzeichen enthalten

Um dieses Feature zu aktivieren, muss sich die Datei "passfilt.dll" im System32-Verzeichnis befinden (ist nach der Installation des Service Pack 2 der Fall), und Sie müssen in der Registry folgenden Key eintragen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

Finden Sie den Wert "Notification Packages" als Datentyp REG_MULTI_SZ. In diesem Wert ist zur Zeit nur "FPNWCLNT" eingetragen. Fügen Sie unter diesem Eintrag noch folgenden Wert hinzu: "Passfilt" und starten Sie das System neu. Ab jetzt werden nur noch Passwörter akzeptiert, die mindestens drei der oben genannten Bedingungen erfüllen.

Ab Windows 2000:

Ab Windows 2000 können Sie diese Funktion über die MMC "Lokale Sicherheitseinstellung" -> Kontorichtlinien -> Kennwortrichtlinien verändern.

Info Siehe auch: "Passwörter müssen Zahlen enthalten".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0553.htm


Disketten und CD-ROM Zugriff auf aktuellen Anwender beschränken

Normalerweise haben alle Prozesse bei Windows auf Disketten und CD-ROM Laufwerke Zugriff. Durch eine Änderung in der Registry können Sie den Zugriff auf den nur noch gerade angemeldeten Benutzer einschränken. Erst nach dem Abmelden des Benutzers steht das CD-ROM wieder allen zur Verfügung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Tragen Sie dort den neuen Wert "AllocateCDRoms" als Datentyp REG_SZ bzw. "AllocateFloppies" als Datentyp REG_SZ ein und weisen Sie ihnen den Wert "1" zu.

Dadurch sind die Laufwerke in anderen Prozessen nicht mehr verfügbar.

Info Wenn Sie den Wert auf 1 setzen, wird dadurch auch die Autostartfunktion von CD-ROM Laufwerken deaktiviert (siehe Info MS: http://support.microsoft.com/?kbid=330135). Wenn Sie die Autostartfunktion erhalten wollen, müssen Sie den Wert auf 0 setzen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=172520

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0112.htm


Standard Benutzergruppen unter Windows NT

Hier eine Übersicht der vordefinierten Gruppen und der ihnen zugewiesenen Rechte und Funktionen. Diese Berechtigungen werden im USERMANAGER unter dem Menü "Richtlinien" -> "Benutzerrechte" vergeben. Dort können Sie auch Veränderungen an diesen Einstellungen vornehmen.

NT Workstation | Admin | Sicherungs Operator | Jeder | Benutzer | Haupt- benutzer | Gäste
Lokale Anmeldung | JA | JA | JA | JA | JA | JA
Zugriff auf diesen Computer vom Netz | JA | - | JA | - | JA | -
Übernehmen des Besitzes an Dateien und Objekten | JA | - | - | - | - | -
Verwalten von Überwachungs- und Sicherheitsprotokoll | JA | - | - | - | - | -
Ändern der Systemzeit | JA | - | - | - | JA | -
System herunterfahren | JA | JA | JA | - | JA | -
Herunterfahren von einem Fernsystem aus | JA | - | - | - | JA | -
Sichern von Dateien und Verzeichnissen | JA | JA | - | - | - | -
Wiederherstellen von Dateien und Verzeichnissen | JA | JA | - | - | - | -
Erzeugen und Verwalten von Benutzerkonten | JA | - | - | - | JA | -
Erzeugen und Verwalten von lokalen Gruppen | JA | - | - | JA | JA | -
Erteilen von Benutzerrechten | JA | - | - | - | - | -
Sperren der Arbeitsstation | JA | - | JA | - | JA | -
Zugriff auf eine gesperrte Arbeitsstation | JA | - | - | - | - | -
Formatieren der Festplatte | JA | - | - | - | - | -
Erzeugen von Gruppen | JA | - | - | - | JA | -
Speichern lokaler Profile | JA | JA | - | - | JA | -
Verzeichnisse freigeben im Netz | JA | - | - | - | JA | -
Drucker freigeben im Netz | JA | JA | - | - | JA | -

NT Server | Admin | Server Operator | Konten Operator | Drucker Operator | Sicherungs Operator | Jeder | Benutzer
Lokale Anmeldung | JA | JA | JA | JA | JA | - | -
Zugriff auf diesen Computer vom Netz | JA | - | - | - | - | JA | -
Übernehmen des Besitzes an Dateien und Objekten | JA | - | - | - | - | - | -
Verwalten von Überwachungs- und Sicherheitsprotokoll | JA | - | - | - | - | - | -
Ändern der Systemzeit | JA | JA | - | - | - | - | -
System herunterfahren | JA | JA | JA | JA | JA | - | JA
Herunterfahren von einem Fernsystem aus | JA | JA | - | - | - | - | -
Sichern von Dateien und Verzeichnissen | JA | JA | - | - | JA | - | -
Wiederherstellen von Dateien und Verzeichnissen | JA | JA | - | - | JA | - | -
Erzeugen und Verwalten von Benutzerkonten | JA | - | JA | - | - | - | -
Erzeugen und Verwalten von globalen Gruppen | JA | - | JA | - | - | - | -
Erzeugen und Verwalten von lokalen Gruppen | JA | - | JA | - | - | - | -
Erteilen von Benutzerrechten | JA | - | - | - | - | - | -
Sperren des Servers | JA | Ja | - | - | - | JA | -
Sperren der Arbeitsstation | JA | JA | - | - | - | - | -
Zugriff auf eine gesperrte Arbeitsstation | JA | - | - | - | - | - | -
Zugriff auf einen gesperrten Server |  | JA | - | - | - | - | -
Formatieren der Festplatte | JA | JA | - | - | - | - | -
Erzeugen von Gruppen | JA | JA | - | - | - | - | -
Speichern lokaler Profile | JA | JA | JA | JA | JA | - | -
Verzeichnisse freigeben im Netz | JA | JA | - | - | - | - | -
Drucker freigeben im Netz | JA | JA | - | JA | - | - | -

Die nun aufgeführten Gruppen werden von NT standardmäßig angelegt und können auch nicht gelöscht werden. Die Aufteilung der Gruppen ist schon recht gut durchdacht, und es bedarf nur einiger Änderungen, um sie den jeweiligen Anforderungen anzupassen.

Administratoren:

Diese Gruppe hat die meisten Rechte und hat damit die größte Kontrolle über das Netz. Trotzdem kann ein Mitglied dieser Gruppe nicht standardmäßig auf alle Dateien im Netz zugreifen. Für den Zugriff auf Dateien muss der Gruppe die Berechtigung dazu vorliegen. Der Administrator kann aber das Eigentumsrecht für eine Datei zu übernehmen, was bei eingeschalteter Überwachung im Sicherheitsprotokoll festgehalten wird. Des Weiteren kann er das Eigentumsrecht nicht wieder an den Eigentümer der Datei zurückgeben.

Info Da diese Gruppe die gesamten Rechte im Netz hat, sollte die Benutzung nur zur Systemverwaltung benutzt werden, die die volle Kontrolle über das System erfordert. Alle anderen Aufgaben sollten nach Möglichkeit von Benutzerkonten erledigt werden, die in anderen Gruppen mit weniger Rechten eingerichtet wurden. Dadurch ist auch der Personenkreis, der zu den Administratoren gehört, sehr klein zu halten.

Domänen-Admins:

Diese Gruppe ist Mitglied in der lokalen Gruppe der Administratoren und somit haben die Personen, die dieser Gruppe angehören, auf allen Rechnern der Domäne administrative Rechte.

Server-Operatoren:

Alle notwendigen Rechte zur Verwaltung der Server und zwar:

  • Druckerfreigabe
  • Netzwerkfreigaben einrichten
  • Anlegen von Sicherungskopien auf dem Server, herstellen von Dateien und setzen der Systemzeit
  • Server herunterfahren

Info Alle Arbeiten auf dem Server, die nicht mehr Rechte benötigen, sollten mit diesen Konto durchgeführt werden.

Sicherungs-Operatoren:

Mitglieder dieser Gruppe können alle Daten sichern und wieder herstellen. Es ist für diese Aufgabe nicht nötig Administrative Rechte zu besitzen.

Reproduktions-Operatoren:

Dieses Konto sollte nicht für Benutzer, sondern ausschließlich nur zum Starten des Reproduktionsdienstes benutzt werden, der einige besondere Rechte benötigt. Die hier eingetragenen Konten sollten nicht über das Recht "Zugriff auf diesen Computer vom Netz" und "Lokale Anmeldung" verfügen, da dies für den Reproduktionsdienst nicht benötigt wird und somit zu einer höheren Sicherheit beiträgt.

Druck-Operatoren:

Mitglieder dieser Gruppe können Drucker auf dem Domänencontroller hinzufügen und die Zugriffsrechte verwalten. Standardmäßig können Sie sich auch an einem Server anmelden und ihn herunterfahren, soll das nicht von diesen Leuten durchgeführt werden, sollte ihnen das Recht genommen werden.

Konten-Operatoren:

Haben die Erlaubnis die meisten Konten anzulegen, zu verwalten und zu löschen. Auf folgende Gruppen haben Sie keine Zugriffsmöglichkeiten:

  • Administratoren
  • Domänen-Admins
  • Konten-Operatoren
  • Sicherungs-Operatoren
  • Druck-Operatoren
  • Server-Operatoren

Info Diese Gruppe entspricht also im weiten Sinne der Gruppe "Hauptbenutzer".

Hauptbenutzer:

Dieser Benutzer hat eingeschränkte administrative Funktionen. So mit kann ein USER aus dieser Gruppe Verzeichnisse im Netz freigeben, Druckertreiber installieren und freigeben und einige allgemeine Programmgruppen verwalten. (Hauptbenutzer, Benutzer und Gäste, auf alle weiteren Gruppen haben Sie aber keinen Einfluss und können Sie auch nicht verändern) sowie neue Gruppen erstellen. Sie haben das Recht sich am Server anzumelden die Domäne herunterzufahren und neue Rechner in die Domäne einzufügen.

Benutzer:

Diese Gruppe enthält alle benötigten Rechte, die ein USER braucht um mit den Rechner arbeiten zu können. Jeder neu angelegte Benutzer wird standardmäßig Mitglied der Gruppe.

Domänen-Benutzer:

Diese Gruppe ist gleichzusetzen mit der Gruppe "Benutzer" und bezieht sich nur auf Domänen. Jeder neu angelegter Benutzer in einer Domäne wird automatisch Mitglied in dieser Gruppe.

Info Alle Benutzer, die nur Normale Arbeiten am Rechner durchführen und keine weiteren Rechte benötigen, sollten nur dieser Gruppe angehören.

Gäste:

Diese Gruppe enthält nur wenige Rechte für Benutzer. Da es trotzdem mit diesen Konto leicht zu einem Sicherheitsrisiko kommen kann, sollte man das Konto deaktivieren. In den meisten Netzen ist es sowieso nicht erwünscht, dass sich nicht bekannte Benutzer anmelden und Zugriff auf einige Ressourcen haben.

Domänen-Gäste:

Siehe "Gäste" nur in Bezug auf die ganze Domäne

Besondere Gruppen:

Diese Gruppen tauchen nicht in der Auflistung des Benutzer - Managers auf und werden nur bei der Verwaltung der Ressourcen angezeigt. Es ist nicht möglich, Mitglieder von Hand diesen Gruppen zuzuweisen.

Ersteller - Besitzer:

Enthält den Benutzer der die neue Datei/Ressource angelegt hat.

Interaktiv:

Benutzer die sich lokal an einem Rechner anmelden sind automatisch Mitglied in dieser Gruppe.

Jeder:

Jeder Benutzer ist Mitglied dieser Gruppe (Lokale und KBenutzer)

Netzwerk:

Benutzer die sich an das Netzwerk anmelden sind automatisch Mitglied in dieser Gruppe.

System:

Zugriff für das System (Dienste usw.) auf die Ressourcen. Dieses Konto ist nur für das Betriebssystem vorgesehen.

Info Mit diesen Gruppen bestimmt man die User, die für die Verwaltung der Userrechte und Aufgaben zuständig sind.
Um die Rechte für den Verzeichniszugriff zu regeln, sollten jetzt noch frei definierte Gruppen angelegt werden, die jeweils den nötigen Aufgaben der Abteilungen entsprechen. Mit solchen Gruppen sollte ausschließlich festgelegt werden, welche Daten die Anwender sehen, lesen und verändern dürfen. Die Vergabe von solchen Rechten sollte aus administrativen Gründen nie direkt an USER- Accounts erfolgen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0599.htm


RAS Sicherheitseinstellungen

Um die Sicherheit der RAS (Remote Access) Verbindungen zu erhöhen, sollten Sie folgende Werte in der Registry beachten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RemoteAccess\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Legt die max. Anzahl der nicht erfolgreichen Anmeldeversuche fest
AuthenticateRetries | REG_DWORD | Zahl (1 - 10) | 2
Legt das Zeitlimit für die Anmeldung fest
AuthenticateTime | REG_DWORD | Sekunden (20 - 600) | 120
Legt fest, wie lange der Server wartet, bis der Client zurückruft, wenn der Client keine eigene Rückrufzeit angibt.
CallbackTime | REG_DWORD | Sekunden (2 - 12) | 2
Zeit bis eine RAS Verbindung getrennt wird
AutoDisconnect | REG_DWORD | Minuten (0-1000) | 20
Legt fest, ob Fernzugriffe überwacht werden sollen. Die Überwachungen werden in das Ereignisprotokoll eingetragen.
EnableAudit | REG_DWORD | Boolean | 1
Ist dieser Wert aktiviert, ist der Zugriff auf das ganze Netzwerk möglich. Ansonsten können die angemeldeten USER nur auf diesen Rechner zugreifen, das Netzwerk sehen die USER nicht.
NetBIOS GatewayEnabled | REG_DWORD | Boolean | 1

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0478.htm


Einschränken der Funktionen von GAST-Usern

Wenn sich USER anonym am Windows anmelden, können sich diese alle Domains, Freigaben und User-Accounts anzeigen lassen.

Durch einen Eintrag in der Registry können Sie das verhindern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

erstellen Sie hier einen neuen Eintrag mit dem Namen "RestrictAnonymous" als Datentyp REG_DWORD. Setzen Sie diesen Wert auf 1.

Des Weiteren gibt es noch den Eintrag "RestrictAnonymousSam" als Datentyp REG_DWORD, welchen Sie auch auf 1 setzen sollten.

Wenn Sie diesen Wert auf 1 setzen, können sich Rechner nicht mehr mit Freigaben dieses Rechners verbinden, ohne sich mit einen gültigen Account anzumelden. Es kommt die Meldung: "Auf [Rechnername] kann nicht mehr zugegriffen werden. Sie haben eventuell keine Berechtigung, diese Netzwerkressource zu verwenden"

Hier sollten Sie auf diesem Rechner aber lieber einen neuen Account mit dem gleichen Namen und Passwort anlegen, als diese Sicherheitslücke wieder zu öffnen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=143474

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0912.htm


Lokale Administratorrechte als USER erlangen

Es gibt ein Tool, mit welchem man als normaler USER unter NT Administratorrechte erlangen kann. Damit dieses Tool unter NT eingesetzt werden kann, muss nur ein Subsystem (POSIX oder OS/2) installiert sein.

Durch einen Eintrag in der Registry können Sie das verhindern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\

Legen Sie hier einen neuen Eintrag mit dem Namen "ProtectionMode" als Datentyp REG_DWORD an und weisen Sie ihm den Wert 1 zu.

Nach einem Neustart ist diese Sicherheitslücke geschlossen.

Info Nach der Installation des Service Packs gibt es durch einen Schreibfehler von MS den Eintrag "Session Manager" zweimal. Einmal wird er dort ohne Leerzeichen geschrieben. Wichtig ist, dass Sie diesen Eintrag dort vornehmen, wo "Session Manager" getrennt geschrieben wurde, auch wenn es in der KB anders beschrieben ist.

Betrifft: | alle NT-Versionen bis Service Pack 4
KB-Artikel: | http://support.microsoft.com/?kbid=218473

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0309.htm


Sicherheitsloch im Hilfesystem von Windows NT

In dem Hilfesystem von Windows NT 4.x hat sich ein weiteres Sicherheitsproblem eingeschlichen. Durch eine Hilfedatei ist es möglich, dass beliebige Programme auf Ihrem Rechner ausgeführt werden können (Viren usw.)

MS hat dafür ein Sicherheitsupdate zur Verfügung gestellt:

http://www.microsoft.com/security/bulletins/ms99-015.asp

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0310.htm


Alternate Data Streams unter NTFS

Hier wird beschrieben, was unter Alternate Data Streams (ADS) zu verstehen ist.

Eine Datei kann auf einer NTFS Partition aus mehreren Streams bestehen. Streams sind einfach nur weitere Anhänge an einer Datei, die auch separat ansprechbar sind. Im Dateisystem wird aber immer nur einer davon angezeigt (lesbar), das ist der umbenannte Hauptstream. Alle anderen Streams sind nicht sichtbar und werden auch vom Explorer nicht angezeigt. Windows berücksichtigt diese Streams noch nicht einmal in der Anzeige der Dateigröße.

Dieser Hauptstream ist bei jeder Datei vorhanden, alle weiteren Streams sind optional und müssen nicht vorhanden sein. Wird so eine Datei von einer NTFS-Partition auf eine FAT-Partition kopiert, gehen alle Streams (bis natürlich auf den Hauptstream) verloren. Windows gibt beim Kopieren eine entsprechende Warnmeldung aus, dass diese Informationen nicht mitkopiert werden.

Windows benutzt diese Streams, um zusätzliche Informationen zu einer Datei abzulegen, beispielsweise die mit Service Pack 2 eingeführten ZoneIDs, um Dateien, die aus dem Internet stammen, zu kennzeichnen.

Auf den Hauptstream kann man wie gewohnt einfach über den Dateinamen zugreifen.

Wie bekommt man jetzt aber die anderen Streams?

Wenn man auf die anderen Streams zugreifen möchte, muss man diese Streams über den Dateinamen durch einen Doppelpunkt getrennt angeben.

Beispiel:

Die Datei heißt Test.txt und die zusätzlichen Streams Stream1 und Stream2

Stream1 sprechen Sie nun folgendermaßen an: Text.txt:Stream1

Stream2 über Text.txt:Stream2

Info:

Die Daten dieses Streams werden intern vom Betriebssystem über Text.txt:Stream1:$DATA angesprochen.

Über die Eingabeforderung kann man relativ einfach Streams anlegen und beschreiben:

echo "Geheimer Text" >> beispiel.txt:stream1.txt

Wenn Sie jetzt den Befehl >>dir<<eingeben, sehen Sie nur die Datei >>beispiel.txt<<. Wenn Sie diese öffnen, enthält diese Datei keinen Text. Da die Dateigröße sich nicht ändert, kann man über solche Streams einfach Dateien verstecken; Streams können Sie auch an Verzeichnisse hängen.

Wenn Ihnen der Name des Streams bekannt ist, können Sie sich jetzt - über Notepad - den Inhalt anzeigen lassen:

notepad beispiel.txt:stream1.txt

Allerdings muss man dazu wissen, an welcher Datei der Stream überhaupt hängt. Diese Informatonen liefern diverse, frei verfügbar Tools, die alle vorhandenen Streams eines Verzeichnisses auflisten können.

Alternate Data Streams auflisten/finden:

http://www.heysoft.de/nt/ep-lads.htm

http://www.sysinternals.com/Utilities/Streams.html

http://www.safer-networking.org/de/tools/tools_ads.html

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1915.htm


Systemrichtlinien Editor

Informationen

Mit den Systemrichtlinien können Sie Einstellungen vornehmen, ohne dass ein Anwender eine Datei ausführen muss oder etwas davon mitbekommt. Beim Anmelden an einen Server wird diese Datei automatisch von NT ausgeführt und die entsprechenden Änderungen in der Registry vorgenommen. Meist handelt es sich dabei um Schlüssel, die Rechte unter Windows beschränken. Sie können damit aber auch den Bildschirmschoner für die Anwender vorgeben.

Beim Windows NT Server wird automatisch der Systemrichtlinien Editor installiert. Bei der WS Version ist er nicht mit dabei, dort muss das Resource Kit installiert werden, damit Sie Zugriff auf den Systemrichtlinien Editor haben. Gestartet wird das Programm über "POLEDIT.EXE"

Mit den Systemrichtlinien können für einzelne Anwender, Benutzergruppen und für bestimmte Computer Einstellungen vorgenommen werden. Diese Einstellungen können auf dem Server hinterlegt werden und gelten dann für alle Anwender, die sich an diesem Server anmelden. Da diese Datei bei jedem Anmelden überprüft wird, kann man so leicht und ohne Probleme Änderungen an Einstellungen vornehmen, die dann für bestimmte Gruppen im Netzwerk gelten.

Es wird dabei zwischen Computer- und Anwenderrichtlinien unterschieden. Diese beiden Richtlinien werden automatisch zusammengeführt und ergänzen sich. Wenn eine Richtlinie doppelt konfiguriert wurde, erhält die Anwenderrichtlinie immer Priorität vor der Computerrichtlinie. Das bedeutet also, wurde für alle Computer die Systemsteuerung deaktiviert, aber es meldet sich ein Anwender an, wo die Systemsteuerung freigeschaltet wurde, hat er Zugriff auf die Systemsteuerung.

Info Die Bearbeitung der Systemrichtlinien Dateien darf nur mit versionsgleichen Systemrichtlinien-Editoren erfolgen. Wenn unterschiedliche Versionen benutzt werden, kann das zu einer Inkonsistenz in den Systemrichtlinien führen.

Benutzer- und Computereinstellungen werden in den Standardvorlagen "COMMON.ADM" und "WINNT.ADM" eingestellt. Durch Erstellung von eigenen ADM - Dateien können noch mehr Richtlinien hinzugefügt oder geändert werden (siehe "Erstellen einer eigenen ADM-Datei"). Werden diese Richtlinien gespeichert, wird die Datei "NTCONFIG.POL" erstellt.

Wenn Sie nur einen Server oder eine Workstation haben bzw. mit der Policy ausstatten wollen, müssen Sie die Datei in das Verzeichnis: "%SYSTEMROOT%\system32\Repl\import\scripts" kopieren. Wenn Sie über mehrere Domänen-Controller verfügen, speichern Sie die Datei in das Verzeichnis: "%SYSTEMROOT%\system32\Repl\export\scripts" und starten Sie auf allen Servern den Verzeichnisreplikationsdienst.

Info Es ist unbedingt wichtig, dass die Datei im richtigen Verzeichnis liegt, ansonsten wird die Datei beim Anmelden eines USERs nicht gefunden und somit auch nicht ausgeführt. Sollten also Einstellungen bei Ihnen nicht vorgenommen werden, überprüfen Sie erst einmal das NETLOGON Verzeichnis, ob die Datei vorhanden ist.

Bei der Anmeldung am Server wird die "NTCONFIG.POL" ausgelesen und auf der NT-WorkStation ausgeführt. Da die Datei zentral auf dem Server liegt, bekommt der Anwender immer die selben Desktop Einstellungen, unabhängig davon, auf welchem Rechner er sich anmeldet.

Info Die Benutzung des Systemrichtlinien - Editors und ein Zugriff auf die Dateien sollte nur Systemadministratoren erlaubt sein. Durch falschen Einsatz ist es auch möglich, allen Administratoren im Netz plötzlich alle Rechte zu entziehen.

Start des Systemrichtlinieneditors

Beim Start des Systemrichtlinieneditors werden als erstes die ADM-Files geladen. Wenn keine ADM-Datei gefunden wird, erscheint ein Fehlermeldung und Sie werden aufgefordert anzugeben, im welchen Verzeichnis sich die ADM-Dateien befinden. Hier können Sie jetzt nur eine Datei angeben die dann vom Policyeditor eingelesen wird. Weitere ADM-Dateien können Sie über das Menü: "Options" -> "Policy Template" hinzufügen.

Über "Datei" -> "Neue Richtlinie" können Sie eine neue Datei anlegen. Sie sehen dann nur die beiden Symbole "Standardbenutzer" und "Standard-Computer". Alle Änderungen die Sie an diesen beiden Gruppen vornehmen gelten jeweils für alle im Netz die sich an den jeweiligen Domänen anmelden auf der die ADM-Datei abgelegt wurde. Sie können noch weitere Gruppen oder einzelne USER anlegen. Auch können einzelne Computer angelegt werden (hier kann man leider keine Gruppen von Computern erstellen, für die die Einstellungen gelten sollen).

Die meisten Einstellungen werden durch setzen von Kontrollkästchen vorgenommen. Die Einstellungen haben folgende Bedeutung:

Aktiviert | der Wert wird in der Registrierung hinzugefügt
Leer | der Wert wird aus der Registrierung gelöscht
Schattiert | der Wert bleibt in der Registrierung unverändert

Beispiele für Konfigurationswerte, die in den ADM-Dateien geändert werden können:

  1. Systemsteuerung
    Einstellen der Systemmöglichkeiten für die Anzeige (Grafikkarte)
  2. Desktop
    Festlegen eines Hintergrundbildes
  3. Shell
    Beschränken von Einstellungen auf dem Desktop (Suchen, Beenden, Ausführen usw.)
  4. System
    Deaktivierung des Registry-Editors und erstellen einer Liste der erlaubten Windows Anwendungen
    Autostart von bestimmten Anwendungen, setzen von SNMP-Zielen
  5. Windows NT Shell
    Anpassen des Startmenüs und der Desktopoberfläche. Festlegen von bestimmten Ordnern usw.
  6. Windows NT System
    Anmeldevorgang (Einlesen der Autoexec.bat, Task-Manager und Anzeigen Meldungen)
  7. Netzwerk
    Umgang mit den Systemrichtlinien
  8. Windows NT Netzwerk
    Aktivieren bzw. deaktivieren der Laufwerksfreigabe
  9. Windows NT-Drucker
    Deaktivieren des Drucker-Spoolers, dadurch wird die System- und Netzwerkleistung gesteigert
  10. Windows NT-Remote-Zugriff
    Festlegung der Zeiten für wiederholte Versuche, eine Echtheitsbestätigung von Server zu bekommen
  11. Windows NT-Benutzerprofile
    Löschen von zwischengespeicherten Server-Profilen
  12. Profilgröße einschränken
    Damit wird die Größe für das persönliche Profilverzeichnis (C:\WINNT\PROFILES\ [USER-ID] festgelegt. Da dieses Verzeichnis bei jeder An- und Abmeldung über das Netzwerk kopiert wird, ist es sinnvoll, dieses auf eine bestimmte Größe zu beschränken. Wird die Größe überschritten, wird der Anwender darauf hingewiesen und kann sich erst abmelden, wenn er das Profilverzeichnis auf die eingestellte Größe anpasst, indem man z.B. Dateien in ein anderes Netzwerklaufwerk kopiert.

Nachdem Sie alle Einstellungen vorgenommen haben, speichern Sie die Datei wie oben angegeben in das entsprechende Verzeichnis ab.

Aufzählung fertiger ADM - Files von MS

ADM Dateien finden Sie bei MS schon für recht viele Programme. Für das OFFICE Paket finden Sie die ADM-Dateien im Resource Kit.

für IE 4.x:

Chat.adm

Conf.adm

Inetres.adm

Inetset.adm

Oe.adm

Shell.adm

Subs.adm

für Windows NT 4.x:

Common.adm (Einstellungen für Windows)

Windows.adm (spezielle Einstellungen für Windows 95/98)

Winnt.adm (spezielle Einstellungen für Windows NT)

für Office:

Access97.adm

Off97nt4.adm (für Windows NT 4.0)

Off97w95.adm (für Windows 95/98)

ADMIN.ADM (Windows 95/98)

Info Siehe auch "Erstellen einer eigene ADM-Datei" und "Systemrichtlinien und Gruppenrichtlinien"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0630.htm


Systemrichtlinien und Gruppenrichtlinien

System- und Gruppenrichtlinien

Ab Windows 2000 können Sie mit Active Directory Gruppenrichtlinien benutzen. Es besteht zwar auch die Möglichkeit, unter 2000 mit den Systemrichtlinien zu arbeiten, aber der Einsatz von Gruppenrichtlinien ist fast nicht zu vermeiden und auch sinnvoll.

Was sind Richtlinien?

  • Eine Richtliniendatei enthält die Informationen für den Client mit Einschränkungen für den Benutzer.
  • Mit den Richtlinien können Sie die Clients zentral und einheitlich konfigurieren und haben die Möglichkeit, diese Einstellungen leicht zu verändern.
  • Mit einer Richtliniendatei werden Werte ist der Registry gesetzt und verändert.
  • Bei jeder Anmeldung an das Netzwerk werden diese Einstellungen der Richtliniendatei mit der aktuellen Computer/Anwendereinstellung verglichen und bei Unterschieden angepasst.
  • Die Richtlinien werden aus den Informationen einer Richtlinienvorlage (ADM-Datei) erstellt.
  • Diese Richtlinienvorlage ist bei den System-/Gruppenrichtlinien weitgehend identisch.

Informationen zum Aufbau finden Sie unter "Erstellen einer eigenen ADM-Datei" und mit der neuen Version des Registry System Wizard (RSW) können Sie auch selber ADM-Dateien erstellen.

Die Erstellung der Richtliniendatei erfolgt bei Windows NT mit dem Systemrichtlinien-Editor (Policy-Editor), der mit Hilfe der ADM-Dateien eine entsprechende Richtliniendatei erzeugt, unter Windows 2000 wird dazu die MMC mit dem Snap-In "Gruppenrichtlinie" verwendet.

Systemrichtlinien:

Die Systemrichtlinien wurden bei Windows NT eingesetzt und können wie oben schon geschrieben auch noch unter Windows 2000 weiter benutzt werden. Aus diesem Grunde gibt es auch in einem 2000-Netzwerk noch die Freigabe "Netlogon", wo die Datei NTCONFIG.POL (bzw. CONFIG.POL für Windows 9x/ME Clients) bereitgestellt werden kann. Dieses Freigabeverzeichnis finden Sie aber nicht wie bei Windows NT unter "%SYSTEMROOT%\System32\repl\import\scripts",

sondern das Verzeichnis liegt bei Windows 2000 jetzt unter

"%SYSTEMROOT%\Sysvol\kuppinger.com\scripts".

Bei der Anmeldung an das Netzwerk suchen die NT Clients automatisch nach der Datei NTCONFIG.POL(bzw. Windows 9x sucht nach CONFIG.POL). Windows 2000 sucht im Gegensatz dazu automatisch nach einer Gruppenrichtlinie - wenn Sie das ändern wollen, beachten Sie dazu den Tipp: "Windows 2000 Clients sollen auch in einer NT 4.x Domäne/Workgroup eine Policy-Datei laden". Aus diesem Grunde können die Systemrichtlinien erst abgeschafft werden, wenn keine Clients mehr im Netzwerk vorhanden sind, die auf Windows NT/9x aufsetzen. Deshalb müssen bei der Planung von 2000 Netzwerken beide Richtlinien berücksichtigt werden.

Gruppenrichtlinien

Wie oben schon beschrieben, werden auch die Gruppenrichtlinien im Prinzip mit Richtlinienvorlagen erstellt. Der große Unterschied ist aber, dass nur der Bereich Computer- und Benutzerverwaltung unter "Administrative Vorlagen" auf diese Vorlagendateien zurückgreift. Darum haben Sie auch nur hier die Möglichkeit, über das Menü "Vorlagen hinzufügen/entfernen" eigene Vorlagendateien einzubinden. Alle anderen Bereiche können vom Administrator praktisch nicht angepasst werden, da diese nur über das Ansprechen einer API erweitert werden können.

Durch diese Erweiterungen können mit Gruppenrichtlinien nicht nur (wie bei Systemrichtlinien) "Registry-Werte" verändert und gesetzt, sondern auch noch andere Werte verändert werden:

  • Registry-Werte setzen und verändern
  • Sicherheitseinstellungen und Zugriffsberechtigungen
  • Softwareinstallation/deinstallation und Softwareupdates
  • Skriptsteuerung: Anmelden/Abmelden usw.
  • Mappings: Hiermit können jetzt Zugriffe auf ein lokales Laufwerk auf Netzwerklaufwerke umgeleitet werden (Ordnerumleitung).

Die Verteilung/Zuweisung von Gruppenrichtlinien erfolgt nicht über die Freigabe "Netlogon", sondern über das Active Directory. Hier werden die Gruppenrichtlinien den entsprechenden Sites bzw. organisatorischen Einheiten zugewiesen und gelten für die dort vorhandenen Computer und Benutzer.

Die Gruppenrichtlinien sind in drei Teile aufgeteilt, die an unterschiedlichen Stellen abgelegt werden können:

Group Policy Container | Liegt im GPC (Group Policy Container) des Active Directory Ort: cn=Policies,cn=System,dc=domäne,dc=com
Group Policy Template | Liegt im GPT (Group Policy Template) im Ordner: SYSVOL Ort: <systemroot>\Sysvol\domain\Policies
Erweiterungen (IPsec-Richtlinien) | Kann frei festgelegt werden.

Die Einstellungen in einer Gruppenrichtlinie werden in so genannten GPOs (Group Policy Object) gespeichert.

Wird einem Container im ADS ein GPO zugewiesen, wird nur ein Link auf das GPO im Container gespeichert und nicht das GPO selber. GPOs können somit an mehreren Stellen gleichzeitig und sogar über Domänengrenzen hinweg benutzt werden. Dabei ist zu beachten, dass ein Domänenkontroller der Domäne im lokalen Standort das GPO besitzt, ansonsten wird über die Standortverbindung auf das GPO zugegriffen, was aus Zeitgründen meist nicht wünschenswert ist.

Standardmäßig gibt es je Domäne eine "Default Domain Policy", die für alle Computer und Benutzer in der Domäne gilt. Alle Einstellungen werden auf die unteren Objekte vererbt, weshalb man sich vor der Konfiguration der Einstellungen Gedanken über den Wirkungsbereich machen sollte (Unterbrechung der Vererbung, Zugriffsberechtigungen). Aus Sicherheitsgründen gibt es für Domänencontroller eine extra Richtlinie.

Lokale Gruppenrichtlinien:

Windows 2000 Clients, die in einem Netzwerk ohne Active Directory betrieben werden, arbeiten standardmäßig auch mit Gruppenrichtlinen, suchen diese aber lokal und können so leider auch nur lokal konfiguriert werden.

Diese lokalen Gruppenrichtlinien werden bei einer Anmeldung an einer Domäne von den dort gesetzten Richtlinien überschrieben. Die lokalen Gruppenrichtlinien können nicht über Gruppen zugeordnet werden, sondern gelten pauschal für alle Benutzer des lokalen Systems, die ein Leserecht auf diese Richtlinie haben.

In der lokalen Gruppenrichtlinien stehen die Einstellungen nicht zu Verfügung für:

  • Softwareinstallation/deinstallation und Softwareupdates
  • Mappings: Hiermit können jetzt Zugriffe auf ein lokales Laufwerk auf Netzwerklaufwerke umgeleitet werden (Ordnerumleitung)

Die Gruppenrichtlinien werden im Verzeichnis "%SYSTEMROOT%\System32\GroupPolicy" abgelegt. Durch das Setzen von Dateizugriffberechtigungen können Accounts von der Benutzung dieser Richtlinien ausgeschlossen werden (sinnvoll für Administrative Accounts); leider können diese Accounts die Gruppenrichtlinien dann auch nicht mehr bearbeiten.

Die lokalen Gruppenrichtlinien können über "Verwaltung" -> "Lokale Sicherheitsrichtlinie" bearbeitet werden. Hier stehen aber nur die Sicherheitsrichtlinien zu Verfügung. Wenn Sie alle Einstellungen bearbeiten wollen, müssen Sie folgendermaßen vorgehen:

  1. Die MMC starten
  2. Datei -> "Snap-In hinzufügen/entfernen" auswählen und im Register "Eigenständig" -> "Hinzufügen" auswählen
  3. Das Snap-In "Gruppenrichtlinie" auswählen -> "Hinzufügen"
  4. "Lokaler Computer" -> "Fertigstellen"

Info Wenn Richtlinienvorlagen (ADM-Dateien) für System-/Gruppenrichtlinien gemeinsam genutzt werden sollen, muss vorher überprüft werden, ob die angesprochenen Registryeinträge auch in beiden Betriebssystemen noch vorhanden sind. Dies ist insbesondere bei Einstellungen zu prüfen, die das Betriebssystem betreffen.

Info Siehe auch "Erstellen einer eigenen ADM-Datei", "Windows 2000 Clients sollen auch in einer NT 4.x Domäne/Workgroup eine Policy-Datei laden", "Systemrichtlinien Editor" und "Gruppenrichtlinien und deren Verarbeitung".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1146.htm


Gruppenrichtlinien und deren Verarbeitung

Gruppenrichtlinien werden beim Start geladen und vom Client abgearbeitet. Durch die Gruppenrichtlinien kann die Konfiguration des Clients gesteuert werden (siehe auch: Systemrichtlinien und Gruppenrichtlinien).

Für die Fehlersuche ist es wichtig zu wissen, wie die Gruppenrichtlinien auf dem Client verarbeitet werden:

  1. lokale Richtlinien
  2. Richtlinien der Site
  3. Richtlinien der Domäne
  4. Richtlinien der organisatorischen Einheit (absteigend in der hierarchischen Struktur)

Folgende Regeln können die Verarbeitung beeinflussen:

  • Zugriffsberechtigungen bzw. Filter der GPOs
  • Einstellung "Kein Vorrang"
    Dadurch werden Einstellungen von untergeordneten Containern überschrieben. Es gelten die Einstellungen der zuerst verarbeiteten Richtlinie (diese Option sollten Sie, wenn möglich, nicht benutzen, da es schnell unübersichtlich werden kann).
  • Richtlinienvererbung deaktiviert: Dadurch wird die Vererbung unterbrochen und die Einstellungen der oberen Ebene werden nicht übernommen (Achtung: Kann durch das Setzen von "Kein Vorrang" übergangen werden).
  • Mehrere GPOs werden in der zugeordneten Reihenfolge bearbeitet.

Standardmäßig werden die Gruppenrichtlinien synchron verarbeitet. Das Umstellen auf asynchrone Verarbeitung (über die MMC "Computerkonfiguration" -> "Administrative Vorlagen" -> "System" -> "Gruppenrichtlinien") ist nicht zu empfehlen, da die Oberfläche geladen wird bevor feststeht, welche Berechtigungen der Anwender hat.

Die synchrone Verarbeitung läuft folgendermaßen ab:

Zuerst werden die computerbezogenen Richtlinien beim Start des Rechners verarbeitet. Die Richtlinien werden vollständig eingelesen, bevor der Anmeldedialog angezeigt wird. Nach der Anmeldung werden die benutzerbezogenen Richtlinien eingelesen und verarbeitet. Die Oberfläche wird erst nach dem vollständigen Abarbeiten der Richtlinien angezeigt.

Diese Verarbeitung muss innerhalb von 60 Minuten erfolgen, ansonsten wird automatisch auf asynchrone Verarbeitung umgeschaltet, was aber nur bei fehlerhaften Vorlagen passieren sollte.

Updates der Richtlinien

Die Gruppenrichtlinien werden jetzt auch auf dem Client aktualisiert, wenn sich der Benutzer nicht mehr abmeldet. Bei dieser Aktualisierung werden nur die Änderungen synchronisiert. Das Intervall für die Synchronisierung liegt standardmäßig bei 90 Minuten zuzüglich einer zufälligen Zeit von 0 - 30 Minuten. Die Zeit können Sie unter (MMC -> "Computerconfiguration" -> "Administrative Vorlagen" -> "System" -> "Gruppenrichtlinien") anpassen. Bei einer Einstellung von 0wird eine Synchronisation von 7 Sekunden eingestellt. Da durch die Synchronisation die Netzlast deutlich erhöht wird, sind eher Werte über 15 Minuten und sinnvoll, da in einem laufenden System meist keine großen Änderungen der Gruppenrichtlinien mehr erfolgen.

Änderungen der Richtlinien an

  • Softwareinstallation/deinstallation und Softwareupdates
  • Skriptsteuerung: Anmelden/Abmelden usw.
  • Mappings: Hiermit können jetzt Zugriffe auf ein lokales Laufwerk auf Netzwerklaufwerke umgeleitet werden (Ordnerumleitung)

Diese werden natürlich nur bei einer Neuanmeldung wirksam.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1289.htm


Erstellen einer eigenen ADM - Datei

Die ADM - Files werden durch den Systemrichtlinieneditor eingelesen, der dann die jeweiligen Einstellungen zu Verfügung stellt. Es gibt von MS schon einige solcher ADM-Files.

Wenn Sie aber Einstellungen verändern wollen, die in den ADM- Files noch nicht vorhanden sind, müssen Sie sich eine eigene Datei erstellen.

Die ADM-Files sind einfache ASCII-Dateien, die mit einem Texteditor erstellt werden können und als ASCII-Datei mit der Endung ".ADM" abgespeichert werden müssen.

Befehle einer ADM - Datei

CLASS MASCHINE bzw. CLASS USER | Hiermit wird festgelegt, ob die Einstellungen für die Maschine (Rechner oder dem Anwender (USER) gelten sollen. Einstellungen für eine Maschine gelten dann für alle Anwender, die sich dort anmelden.
CATEGORY "[Name]" .. END CATEGORY | Jeder neue Eintrag muss in so einer Anweisung eingeschlossen sein. Als [NAME] geben Sie eine Beschreibung ein, die im Richtlineneditor im Auswahlbaum angezeigt werden soll.
POLICY "[NAME]" .. END POLICY | Jeden unterschiedlichen Registry-Schlüssel müssen Sie wiederum in so eine Anweisung einbinden. Hier ist der Name auch wieder für die Anzeige im POLICY Editor gedacht.
KEYNAME "....." | Hier müssen Sie den Registry-Schlüssel angeben, den Sie ändern möchten. Dabei müssen Sie den ersten Schlüsselnamen HKEY_LOCAL_MACHINE bzw. HKEY_CURRENT_USER weglassen. NT trägt das je nach zugeordneter CLASS (MASCHINE oder USER) selbständig ein.
VALUENAME "..." | Hier wird der Wert angegeben, der unter dem Schlüssel verändert bzw. angelegt werden soll. Danach muss die Angabe erfolgen, um welchen TYP es sich handelt und wie er im Systemrichtlinieneditor angezeigt werden soll.
VALUEON NUMERIC 1 VALUEOFF NUMERIC 0 | Datentyp, welcher nur 0 oder 1 enthalten kann: Durch diese Einträge erzeugt der Policyeditor eine BOX zum Ein/Ausschalten
PART !![Variablenname] [Boxart] VALUENAME [NAME] END PART | Verschiedene Eingabe/Auswahlboxen. Mit dieser Anweisung erstellen Sie eine Eingabe bzw. Auswahlbox. Als Variablenname müssen Sie einen Namen angeben, den Sie im unteren Teil definiert haben.
PART !!Info TEXT END PART | Nur als Ausgabe eines Infotextes im Systemrichtlinieneditor. Hier muss der Wert VALUENNAME weggelassen werden
PART !!Test NUMERIC VALUENAME Test END PART | Erstellt einen Registry Key als Datentyp: REG_DWORD
PART !!Test DROPDOWNLIST VALUENAME Test ITEMLIST NAME "Auswahl1" VALUE NUMERIC NAME "Auswahl2" VALUE NUMERIC NAME "Auswahl3" VALUE NUMERIC END ITEMLIST END PART | Zum Erstellen einer Auswahlbox
PART !!Test EDITTEXT VALUENAME Test END PART | Erstellt einen Registry Key als Datentyp: REG_SZ. Wenn Sie hinter EDITTEXT noch REQUIRED angeben, wird eine Fehlermeldung ausgegeben, wenn kein Eintrag bei diesem Wert erfolgt.
PART !!Test EXPANDABLETEXT VALUENAME Test END PART | Erstellt einen Registry Key als Datentyp: REG_EXPAND_SZ
PART !!Test EDITTEXT VALUENAME Test MAXLEN 5 END PART | Gibt die max. Länge für das Eingabefeld an.
PART !!Test NUMERIC DEFAULT 5 VALUENAME Test END PART | Legt einen Vorgabewert fest für Text oder Zahlen.
PART !!Test NUMERIC MIN 5 MAX 100 DEFAULT 10 VALUENAME Test END PART | Legt den größten und kleinsten Wert für die Eingabe fest

Variablen anlegen:

[strings]

[NAME]=[Wert]

Nach dieser Angabe können Sie Variablen festlegen

Beispiel einer ADM - Datei

CLASS MACHINE

CATEGORY "NetBIOS über TCP/IP"
POLICY "DNS für Windows-Auflösung aktivieren"
KEYNAME "System\CurrentControlSet\Services\NetBT\Parameters"
VALUENAME "EnableDNS"
VALUEON NUMERIC 1
VALUEOFF NUMERIC 0
END POLICY
END CATEGORY

CATEGORY "Sicherheit"
POLICY "Löschen der Auslagerungsdatei beim Systemabschluss"
KEYNAME "System\CurrentControlSet\Control\Session Manager\Memory Management"
VALUENAME "ClearPageFileAtShutdown"
VALUEON NUMERIC 1
VALUEOFF NUMERIC 0
END POLICY

POLICY "Anzeigen der WS im Netz ausschalten"
KEYNAME "System\CurrentControlSet\Services\LanmanServer\Parameters"
VALUENAME "Hidden"
VALUEON NUMERIC 1
VALUEOFF NUMERIC 0
END POLICY

POLICY "Adminrechte - Behebung der Sicherheitslücke: Q218473"
KEYNAME "SYSTEM\CurrentControlSet\Control\Session Manager"
VALUENAME "ProtectionMode"
VALUEON NUMERIC 1
VALUEOFF NUMERIC 0
END POLICY
END CATEGORY

CLASS USER

CATEGORY "Bildschirmschoner"
KEYNAME "Control Panel\Desktop"
POLICY "Bildschirmschoner einstellen"
PART !!BildschirmS EDITTEXT
VALUENAME "SCRNSAVE.EXE"
END PART
END POLICY

POLICY "Bildschirmschoner Aktivieren"
VALUENAME "ScreenSaveActive"
VALUEON "1"
VALUEOFF "0"
END POLICY

POLICY "Bildschirmschonerpaßwort"
VALUENAME "ScreenSaverIsSecure"
VALUEON "1" VALUEOFF "0"
END POLICY

POLICY "Bildschirmschoner Zeit"
PART !!ZeitIntervall EDITTEXT
VALUENAME "ScreenSaveTimeOut"
END PART
END POLICY
END CATEGORY

[strings]
BildschirmS="Dateiname"
ZeitIntervall="Zeit in sec."

Info ADM Dateien können einfach mit dem "Registry System Wizard" (RSW) erstellt werden. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Siehe auch "Systemrichtlinien Editor" und "Systemrichtlinien und Gruppenrichtlinien"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1176.htm


Sichern der Registry [ab NT]

Welche Dateien enthält die Registry-Datenbank?

Registry-Informationen befinden sich in allen Dateien, die "SAM", "SECURITY", "SOFTWARE" und "SYSTEM" im Namen enthalten und sich im Verzeichnis "%SYSTEMROOT%\System32\Config" befinden.

Jetzt gibt es noch eine weitere Datei, in der die Registryinformation des jeweiligen Anwenders abgelegt wird. Die Lage dieser Datei kann vom Administrator verändert werden, so dass hier nur der Standardpfad angegeben wird.

In Netzwerken wird das Profilverzeichnis meist auf einen bestimmten Server gelegt, damit diese Informationen auf jedem PC im Netzwerk zu Verfügung stehen.

Diese Datei enthält die Daten aus den Registry-Teilen

HKEY_CURRENT_USER und

HKEY_USERS\Sxxx,

genaueres unter Weitere Infos zur Registry

Windows NT 3.x

Hier lag diese Datei auch noch im Verzeichnis "%SYSTEMROOT%\System32\Config" und hatte den Namen "[USERID]000". Die Bezeichnung [USERID] müssen Sie durch den jeweiligen Anmeldenamen ersetzen.

Windows NT 4.x

Hier liegt die Datei im Profilverzeichnis des jeweiligen Users "%SYSTEMROOT%\Profiles\[USERID]" und hat den Namen NTUSER.DAT.

Windows 2000/XP/2003

Hier wird das Profilverzeichnis standardmäßig von Windows schon nicht mehr mit in das Windowsverzeichnis abgelegt. Sie finden die NTUSER.DAT nun unter %USERPROFILE% (z.B. "C:\Dokumente und Einstellungen\Frank Ullrich").

Wie können diese Dateien gesichert werden?

Da diese Dateien bereits beim Systemstart dauerhaft geöffnet werden, ist es nicht möglich sie durch einfaches Kopieren zu sichern.

Windows NT

Eine Möglichkeit, die Registry zu sichern, bietet das Programm RDISK.EXE. Es befindet sich im Verzeichnis "%SYSTEMROOT%\system32". Dieses Programm ermöglicht es, gleichzeitig eine Rettungsdiskette anzulegen und sichert so die Registry-Informationen. Da die Registry sehr groß werden kann (bei Domänen mehrere Megabyte), kann nicht alles auf einer Diskette gespeichert werden. Deshalb legt das Programm den Großteil in das Verzeichnis "%SYSTEMROOT%\Repair" ab.

RDISK.EXE aktualisiert aber nicht automatisch die Dateien "SAM" und "SECURITY". Damit auch das geschieht, müssen Sie das Programm mit dem undokumentierten Parameter "/S " aufrufen. Geben Sie dafür z.B. im DOS -Fenster "RDISK /S" ein.

Jetzt werden alle Informationen aktualisiert und RDISK fragt Sie außerdem, ob eine Rettungsdiskette angelegt werden soll.

Windows 2000/XP/2003

Unter Windows 2000 werden Sie das Programm RDISK.EXE nicht mehr finden. Hier wurde diese Option in das Backupprogramm integriert. Um nur die Registry zu sichern, müssen Sie folgendermaßen vorgehen:

  1. Rufen Sie das Sicherungsprogramm über "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Sicherung" bzw. durch den direkten Aufruf von NTBACKUP.EXE auf
  2. 2000: Über das Menü "Extras" -> "Notfalldiskette erstellen" können Sie nun die Registry sichern. Dafür müssen Sie im folgenden Menü die Option "Die Registrierung im Wiederherstellungsverzeichnis sichern...." ankreuzen.
  3. ab XP: Hier startet beim ersten Mal der Assistent. Wählen Sie hier den "Erweiterten Modus" ->. Jetzt klicken Sie auf den Tabreiter "Sichern" ->. Hier finden Sie unter Ihrem Rechnernamen die einzelnen Laufwerke und auch den Eintrag "System State". Das müssen Sie nun anklicken, weil darüber die entsprechenden Systemeinstellungen (darunter auch die Registry) gesichert werden können. Klicken Sie abschließend auf den Button "Sicherung Starten".

Anders als bei RDISK wird die Registry nicht auf eine Diskette kopiert, sondern Windows sichert die Dateien der Registry im Verzeichnis "%WINDIR%\Repair".

Auf einer Diskette werden nur die Dateien "CONFIG.NT", "AUTOEXEC.NT" und "SETUP.LOG" gesichert. Die Datei "SETUP.LOG" wird bei der Reparaturfunktion von Windows benötigt.

Info Sie können die Registry natürlich auch durch ein Backup Ihres Systems sichern.

Dafür starten Sie NTBACKUP und zwar unter NT x.x durch den Aufruf von "NTBACKUP /B".

Bei Windows 2000 können Sie das Sichern der Datenbank in der Oberfläche angeben.

Windows Vista

Ab Vista gibt es im Backup keine Möglichkeit mehr, die Registry zu sichern und getrennt wieder herzustellen. Sie haben hier aber zwei Möglichkeiten:

  1. Erstellen Sie einen Wiederherstellungspunkt. Hier werden auch Registryeinstellungen gesichert: Unter "Systemsteuerung" -> "System und Wartung" -> "System" oder [Windows-Taste + Pause] wählen Sie auf der linken Seite "Computerschutz" aus. Im neuen Fenster "Systemeigenschaften" im Tabreiter "Computerschutz" können Sie jetzt über den Button "Erstellen..." einen neuen Wiederherstellungspunkt einrichten.
  2. Starten Sie Regedit.exe und wählen Sie den Schlüssel aus, welchen Sie sichern möchten. Klicken Sie jetzt im Menü auf "Datei" -> "Exportieren" und legen Sie so für den entsprechenden Schlüssel eine Sicherung an.

Allgemeine Informationen:

Mit den im Resource Kit enthaltenen Utilities "REGBACK" und "REGREST" können Sie ebenfalls die Registry sichern bzw. wiederherstellen.

Info Mit dem "Registry System Wizard" (RSW) können Sie auch die Registry sichern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0010.htm


Weitere Infos zur Registry

Unter Registry sichern sind die Dateien, in denen die Daten der Registry gesichert werden, schon beschrieben worden. Hier wird nun genauer darauf eingegangen.

Windows speichert alle Informationen in sogenannten Strukturdateien, die im Verzeichnis "%SYSTEMROOT%\System32\Config" angelegt sind. Für jede Datei ist immer eine Sicherheitsdatei mit der Endung "*.LOG" vorhanden. Das sind aber keine Kopien, sondern Informationen über die letzten Änderungen.

Hier eine Aufstellung der Dateien und welcher Schlüssel in ihnen abgelegt wird.

Dateiname: | Schlüssel:
SAM | HKEY_LOCAL_MACHINE\SAM
SECURITY | HKEY_LOCAL_MACHINE\SECURITY
SOFTWARE | HKEY_LOCAL_MACHINE\SOFTWARE
SYSTEM | HKEY_LOCAL_MACHINE\SYSTEM
DEFAULT | HKEY_USERS\Default
[Benutzername]nnn | HKEY_USERS\Security ID
USER oder ADMIN | HKEY_CURRENT_USER

Ab Windows NT 4.x wird der USER Registryanteil nicht mehr im Verzeichnis "%SYSTEMROOT%\System32\Config" abgelegt. Diese finden Sie jetzt im Verzeichnis "%SYSTEMROOT%\Profiles\[BENUTZERNAME]" bzw. ab Windows 2000 im Verzeichnis "%USERPROFILE%" (z.B. "C:\Dokumente und Einstellungen\Frank Ullrich") in der Datei "NTUSER.DAT".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0033.htm


Unterschiede zwischen Regedit und Regedt32

Unter Windows 95/98 steht Ihnen nur der Registryeditor "REGEDIT.EXE" zur Verfügung. Unter NT und Windows 2000 gibt es zusätzlich den "REGEDT32.EXE".

Info Ab Windows XP gibt es REGEDT32.EXE aus Gründen der Kompatibilität. Die Funktionen wurden aber zusammengefasst, und es wird jeweils das gleiche Programm REGEDIT.EXE gestartet, so dass es hier egal ist, welchen Namen Sie benutzen um das Programm zu starten.

In der Tabelle finden Sie die Unterschiede zwischen den beiden Programme übersichtlich aufgelistet. Auf Systemen, auf denen beide Registry-Editoren vorhanden sind, können Sie für die meisten Aufgaben denjenigen benutzen, der Ihnen am besten gefällt. Folgende Aufgaben können aber nur von Regedt32 durchgeführt werden:

  1. Berechtigungen auf Schlüssel in der Registry vergeben (Sicherheitskonzept ab NT).
  2. Editieren als Datentyp REG_EXPAND_SZ und REG_MULTI_SZ, da REGEDIT.EXE diese Datentypen nicht kennt und darum nur HEX-Zahlen anzeigt, die das Editieren doch etwas erschweren.

Der Vorteil von REGEDIT.EXE ist, dass dieser Registryeditor nicht nur nach Schlüsselnamen, sondern auch nach Einträgen in den Schlüsseln suchen kann. Wenn Sie also einmal etwas bestimmtes in der Registry-Datei suchen möchten, sollten Sie auf diesen Editor zurückgreifen.

Feature | REGEDIT.EXE | REGEDT32.EXE
Automatische Aktualisierung | NEIN | JA
Besitz von Schlüsseln übernehmen | NEIN | JA
Entfernen von Schlüsseln/Werten | JA | JA
Import/Export von Schlüsseln | JA | JA
Laden und Löschen von ganzen Bäumen | NEIN | JA
Remote Änderung der Registry | JA | JA
Schlüssel oder Werte hinzufügen | JA | JA
Schlüssel überwachen | NEIN | JA
Suche nach Schlüsseln | JA | JA
Suche nach Werten | JA | NEIN
Umbenennen von Schlüssel/Werten | JA | NEIN
Zugriffsrechte auf Schlüssel ändern | NEIN | JA
Struktur laden und bearbeiten (z.B. NtUser.dat) | NEIN | JA
Export als .REG-Datei | JA, auch ganze Registry | JA, aber nur Teilbäume
Datentypen: |  |
REG_BINARY | JA | JA
REG_DWORD | JA | JA
REG_EXPAND_SZ | NEIN | JA
REG_MULTI_SZ | NEIN | JA
REG_SZ | JA | JA

Wo finden Sie den Registry-Editor?

Regedit.exe | Die Datei befindet sich im Windows-Verzeichnis und heißt REGEDIT.EXE (-> "Start" -> "Ausführen" REGEDIT eingeben).
Regedt32.exe | Der Registry-Editor befindet sich im Verzeichnis %SYSTEMROOT%\System32\Regedt32.exe. Windows NT/2000: Sie können das Programm aber auch über -> "Verwaltung" -> "Windows-NT-Diagnose" -> "Programme" -> Registry-Editor starten" aufrufen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0004.htm


Benutzerprofile aus der Registry entfernen

Haben Sie einen User-Accounts gelöscht, sollten Sie auch die evtl. vorhandenen User-Profilelöschen, um die Registry nicht unnötig zu belasten.

Gehen Sie folgender Weise vor:

"Systemsteuerung" -> "System" -> "Benutzerprofile".

Ab XP:

"Systemsteuerung" -> "System" -> Tabreiter "Erweitert" -> bei Benutzerprofile "Einstellungen".

Ab Vista:

"Systemsteuerung" -> "System" -> "Erweiterte Systemeinstellungen" -> Tabreiter "Erweitert" -> Button "Einstellungen..." unter "Benutzerprofile"

Wählen Sie dort die nicht mehr benötigten User-Profile aus und klicken Sie dann auf -> "Löschen". Dadurch werden diese Profile aus der Registry entfernt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0399.htm


Größe der Registrierdatenbank

Größe der Registrydatenbank

Die Größe der Registrydatenbank können Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "System"

bei Windows NT unter dem Karteiordner "Leistungsmerkeinmale" -> "Virtueller Arbeitsspeicher" verändern.

bei Windows 2000 unter dem Karteiordner "Erweitert" -> "Systemleistungsoptionen" -> "Ändern" unter "Größe der Registrierung" anpassen.

Die max. Größe ist 80% vom Paged Pool, der einen max. n-Wert von 128 MB hat. Daraus ergibt sich ein max. r-Wert von 102 MB.

Größenbereich:

min. Wert: 4 MB

max. Wert: 102 MB

Die Größe können Sie aber auch direkt in der Registry ändern

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control

Erstellen Sie den Wert "RegistrySizeLimit" als Datentyp REG_DWORD, der Wert wird hier in Byte angegeben.

Der Eintrag muss mindestens eine große von 4 MB haben oder er wird von Windows ignoriert. Wird der Wert kleiner als 4 Megabytes gesetzt, wird automatisch der Minimale Wert von 4 Megabyte benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0548.htm


Fernzugriff auf die Registry ausschalten

Bei NT 3.51 Server und Workstation und bei NT 4.0 Workstation sind Teile der Registry für die Gruppe Deutsch: "Jeder" oder Englisch: "Everyone" für den Fernzugriff freigeschaltet. Dadurch ist es jedem Benutzer in Netz möglich, der Zugriff auf den Registry-Editor hat, die Registry von anderen Rechnern im Netz zu bearbeiten.

Zur Sicherheit im Netz sollte man das auch bei den Workstation nur auf das Administratorkonto beschränken.

Ab Windows XP ist die Gruppe "Jeder" nicht mehr diesem Schlüssel zugewiesen, so das hier schon die Rechte ausreichend eingeschränkt sind.

Um einen Fernzugriff auf die Registry zu unterbinden (Server oder Workstation), muss folgender Schlüssel in die Registry eingetragen werden.

Info Hier wird der ganze Weg angegeben, die Schlüssel sind aber in der NT 4.0-Version schon angelegt und es müssen dort nur die Berechtigungen geändert werden. Bei NT 3.51 WS müssen die Schlüssel erst noch angelegt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

  • In den folgenden Schlüssel wechseln:
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control
  • Mit Menü "Bearbeiten" -> "Schlüssel hinzufügen" folgenden Schlüssel Eintragen:
    Schlüsselname: SecurePipeServers
    Datentyp REG_SZ
  • In den folgenden Schlüssel wechseln
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SecurePipeServers
  • Mit Menü "Bearbeiten" -> "Schlüssel hinzufügen" folgenden Schlüssel Eintragen:
    Schlüsselname: winreg
    Datentyp REG_SZ
  • In den folgenden Schlüssel wechseln
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SecurePipeServers\ winreg
  • Mit Menü "Bearbeiten" -> "Wert hinzufügen" folgenden Wert Eintragen:
    Wertname: Description
    Datentyp: REG_SZ
    Zeichenkette: Registry Server
  • In den folgenden Schlüssel wechseln
    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SecurePipeServers\ winreg
  • Mit Menü "Sicherheit" -> "Berechtigungen". Nun alle Gruppen entfernen, die keine Berechtigung für einen Fernzugriff mehr haben sollen.

Die Änderungen in der Registry sind erst nach einem Neustart des Rechners wirksam.

Sie können natürlich auch durch das hinzufügen von Gruppen den Zugriff auf die Registry erweitern.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0383.htm


Notfalldiskette und Sicherung anlegen

Windows bietet die Möglichkeit eine Sicherung zu erstellen, um in einem Fehlerfall das System wieder reparieren zu können. Diese Sicherung sollten Sie immer wieder aktualisieren, wenn Sie große Änderungen an den Einstellungen vornehmen (Partitionen, Usermanager, Programme usw.). Sollte Windows später einmal nicht mehr starten, können Sie Windows mit der Sicherung wieder reparieren.

Wie erstelle ich eine Sicherung?

NT:

Unter Windows NT 4.0 erstellen Sie eine Rettungsdiskette mit den Befehl "RDISK.EXE". Kopieren Sie anschließend die Datei "setupdd.sys aus dem Service Pack auf die Windows NT 4.0 Setup Diskette 2.

Windows 2000:

Unter Windows 2000 finden Sie das jetzt im Sicherungsprogramm "NTBACKUP.EXE" ("Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Sicherung"). Hier finden Sie unter dem Menü "Extras" den Eintrag "Notfalldiskette erstellen". Wenn Sie das anklicken, werden Sie gefragt, ob die aktuelle Registry im Wiederherstellungsverzeichnis gespeichert werden soll. Das sollten Sie aus Sicherheitsgründen auf jeden Fall mit anklicken, legen Sie dann eine Diskette in das Laufwerk und klicken Sie auf OK.

Windows XP:

Unter Windows 2000 finden Sie das jetzt im Sicherungsprogramm "NTBACKUP.EXE" ("Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Sicherung"). Jetzt unter "Extras" -> "Sicherungs Assistenten" auswählen -> "Weiter" -> "Nur Systemstatus Dateien sichern" -> "Weiter" -> Hier können Sie jetzt eine Diskette auswählen oder es in einem Ordner Speicher, da die Dateien sehr groß sind ist ein Ordner besser. Dann das Sichern mit "Weiter" starten.

MS hat aber auch das Sicherungsprogramm NTBackup erheblich verbessert. So können Sicherungen jetzt auf jedem beliebigen Datenträger angelegt werden und nicht wie unter NT 4.0 nur auf Bandlaufwerken. Sie haben hier nicht nur die Möglichkeit, die Laufwerke zu sichern, sondern Sie haben auch den Auswahlpunkt "Systemstatus". Mit "Systemstatus" werden unter anderem solche Dateien gesichert, die in Benutzung sind und auf die nicht ohne weiteres zugegriffen werden kann (Registry, Active Directory usw.).

Windows Vista:

Hier starten Sie das Backup über "Sicherungsstatus und -konfigurieren" bzw. mit der Datei "sdclt.exe". Es öffnet sich das Fenster "Sicherungsstatus und -konfiguration", wo Sie auf der linken Seite zwischen "Dateien Sichern", "Dateien wiederherstellen" und "Complette PC-Sicherung" auswählen können. Wählen Sie hier die gewünschte Sicherungsart aus und starten Sie die Sicherung. Bei der Einstellung "Dateien Sichern" werden nur bestimmte Dateien gesichert (eigene Daten usw.),

Mit "Complette PC-Sicherung" können Sie die gesamte Windows Installation sichern.

Was mache ich, wenn mein Windows nicht mehr startet?

Sollte Ihr Windows nicht mehr starten, haben Sie verschiedene Möglichkeiten, das System zu reparieren (je nachdem, wie stark es zerstört wurde).

  1. Sie können wie unter "Die Windows "Recovery Console" (Wiederherstellungskonsole)" beschrieben, versuchen die "Recovery Console" aufzurufen.
  2. Sie versuchen das System mit der Notfalldiskette wiederherzustellen. Starten Sie dafür Windows von der CD oder den Bootdisketten. Nach den Booten drücken Sie im ersten Auswahlmenü "C" für die Wiederherstellungskonsole und dann "R" für die Reparatur. Windows wird dann von Ihnen die Notfalldiskette verlangen, die Sie hoffentlich erstellt haben. Auch wenn Sie keine Notfalldiskette haben, können Sie das versuchen. Geben Sie dann einfach an, dass Sie keine Notfalldiskette besitzen. Windows versucht dann selber auf den Festplatten das Betriebssystem zu finden und den Fehler zu beheben. Wenn das System nicht zu sehr zerstört ist, führt auchdas meist zum Erfolg.

Info Die Notfalldiskette und die Wiederherstellungskonsole bieten zwar unter Windows 2000 recht gute Möglichkeiten, das System wiederherzustellen, ersetzen aber auf keinen Fall ein richtiges Backup der Daten auf externe Datenträger. Hier kommen Sie mit dem NT Backupprogramm jetzt schon recht weit. Der Nachteil von NTBackUp ist, dass Sie immer erst ein kleines NT installieren müssen, um das Backupprogramm starten zu können. Hier hat MS leider keine Möglichkeit zur Verfügung gestellt, ein Zurücksichern unter DOS ausführen zu können. Deshalb ist es meist sinnvoller, andere Programme wie z.B. "Norton Ghost" oder "ACRONIS True Image" zu benutzen.

Windows Vista:

Hier ist die Sicherung schon recht gut, so das Sie mit der "Complette PC-Sicherung" einen Rechner recht einfach wieder herstellen können:

  1. Starten Sie Vista vom Installationsdatenträger
  2. Wählen Sie die gewünschte Sprache aus
  3. Wählen Sie "Computer reparieren" aus
  4. Wählen Sie das Betriebssystem aus, welches Sie reparieren möchten
  5. Wählen Sie unter "Systemwiederherstellungsoptionen" -> "Windows CompletePC-Wiederherstellung" aus

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1020.htm


Registry eines Benutzers bearbeiten

Sie können die Registry eines Benutzers auch bearbeiten, ohne dass der Benutzer angemeldet ist bzw. Sie den Benutzer mehr Berechtigungen geben müssen und sich dann mit den Account an einem Rechner anmelden.

Alle Informationen der Registry eines Benutzers werden in der Datei "NTUSER.DAT" abgelegt. Diese Datei befindet sich im Profilverzeichnis des Benutzers. Wenn Sie die Registry eines Benutzers bearbeiten wollen, können Sie das mit REGEDT32 (ab XP geht es auch mit Regedit).

Gehen Sie dafür so vor:

  1. Starten Sie REGEDIT (bei NT unbedingt REGEDT32)
  2. Gehen Sie auf den Schlüssel HKEY_LOCAL_MACHINE in Ihrer Registry
  3. Wählen Sie aus dem Menü "Datei" -> "Struktur laden". Geben Sie dann die Datei des Benutzers an, die Sie bearbeiten wollen
  4. Jetzt werden Sie nach einen Namen gefragt unter dem die Struktur bei Ihnen in der Registry eingebunden werden soll. Hier können Sie einen beliebigen Namen eingeben
  5. Jetzt können Sie die Registry des Benutzers unter der hinzugefügten Struktur bearbeiten
  6. Wenn Sie fertig sind, können Sie die Struktur mit "Datei" -> "Struktur entfernen" wieder aus Ihrer Registry entfernen.

Info Weitere Infos dazu finden Sie unter:
Wo liegen die Dateien der Registry: Windows 9x/ME oder Windows NT/2000/XP.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1412.htm


Registry Tools aus dem Windows NT Resource Kit

Im Windows NT Resource Kit sind einige nützliche Tools enthalten, unter anderem finden Sie hier auch folgende Tools zur Bearbeitung der Registry:

SECADD.EXE | Mit diesen Befehl ändern Sie die Zugriffsrechte auf die Registry. Dieser Befehl dient zum Hinzufügen von Benutzergruppen.
REGSEC.EXE | Mit diesen Befehl ändern Sie die Zugriffsrechte auf die Registry. Dieser Befehl dient zum Entfernen von Benutzergruppen.
SAVEKEY.EXE | Speichert den angegebenen Teilbaum der Registry in einer Textdatei ab.
REGREAD.EXE | Gibt den Wert des angegebenen Registry-Schlüssels aus.
REGDEL.EXE | Löscht den angegebenen Registry-Schlüssel aus der Registry.
RREGCHANGE.EXE | Genau wie REGCHANGE, nur hiermit können Sie die Werte eines anderen Rechners im Netzwerk modifizieren.
REGCHANGE.EXE | Hiermit können Sie einzelne Werte der Registry verändern.
REGREST.EXE | Hiermit können Sie die gesicherte Registry (REGBACK) wieder herstellen.
REGBACK.EXE | Mit diesen Tool können Sie eine vollständige Sicherheitskopie der Registry anlegen.
COMPREG.EXE | Hiermit können Sie zwei Registry-Schlüssel miteinander vergleichen, die sich auf unterschiedlichen Rechnern befinden.
REGKEY.EXE | Hiermit können Sie weitere Einstellungen der Benutzeroberfläche verändern, die Sie sonst nur direkt Durch einen Eingriff in die Registry verändern können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0801.htm


Anonymen Zugriff auf die Registry konfigurieren

Mit diesem Eintrag können Sie definieren, auf welche Schlüssel unterhalb von HKEY_LOCAL_MACHINE ein Benutzer/Dienst anonym auf die Registry zugreifen kann.

Für einige Dienste wird dieser Zugriff benötigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SecurePipeServers\ winreg\ AllowedPaths

Erstellen Sie hier einen neuen Wert mit dem Namen "Machine" als Datentyp REG_MULTI_SZ. Geben Sie hier jeweils die Registry-Zweige an auf den der Zugriff möglich sein soll. Jeder Eintrag ist durch Enter zu trennen.

Unter Windows XP ist hier standardmäßig folgendes eingetragen:

System\CurrentControlSet\Control\ProductOptions

System\CurrentControlSet\Control\Print\Printers

System\CurrentControlSet\Control\Server Applications

System\CurrentControlSet\Services\Eventlog

Software\Microsoft\OLAP Server

Software\Microsoft\Windows NT\CurrentVersion

System\CurrentControlSet\Control\ContentIndex

System\CurrentControlSet\Control\Terminal Server

System\CurrentControlSet\Control\Terminal Server\UserConfig

System\CurrentControlSet\Control\Terminal Server\DefaultUserConfiguration

Ab Windows Vista:

System\CurrentControlSet\Control\Print\Printers

System\CurrentControlSet\Services\Eventlog

Software\Microsoft\OLAP Server

Software\Microsoft\Windows NT\CurrentVersion\Print

Software\Microsoft\Windows NT\CurrentVersion\Windows

System\CurrentControlSet\Control\ContentIndex

System\CurrentControlSet\Control\Terminal Server

System\CurrentControlSet\Control\Terminal Server\UserConfig

System\CurrentControlSet\Control\Terminal Server\DefaultUserConfiguration

Software\Microsoft\Windows NT\CurrentVersion\Perflib

System\CurrentControlSet\Services\SysmonLog

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1533.htm


Fehlerfreie Systemkonfiguration

Wenn Windows mit der momentanen Konfiguration nicht starten kann, erscheint die Meldung "Space-Taste drücken" bzw. über F8, und es wird die letzte fehlerfreie Systemkonfiguration geladen.

Diese Einstellungen speichert Windows in der Registry und zwar

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ ControlSet00x

Es gibt mindestens zwei dieser Einträge 001 und meist 002 oder 003. Einer dieser Einträge entspricht der aktuellen Konfiguration, der andere ist eine Kopie, welche die letzte fehlerfreie startfähige Version widerspiegelt.

Welcher von dieses Schlüsseln der Defaultschlüssel ist, wird unter "HKEY_LOCAL_MACHINE\ System\ Select" unter den Eintrag "Default" festgehalten.

Weiterhin gibt es hier noch den Eintrag "LastKnownGood", welcher den Zweig mit der letzten fehlerfrei gespeicherten Konfiguration enthält.

Die Version, mit der Windows gestartet wurde, findet sich als Kopie unter HKEY_LOCAL_MACHINE \System\ CurrentControlSet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0418.htm


INI-File Mapping

Ab Windows NT wird die Möglichkeit geboten, Einstellungen, die in INI-Files abgelegt werden, in die Registry vom Windows zu mappen.

Da diese Möglichkeit durch eine Windows-Funktion zur Verfügung gestellt wird, funktioniert das nicht nur für die INI-Dateien von Microsoft, sondern auch für INI-Dateien von anderen Anwendungen. Diese geht aber nur, wenn die Anwendungen nicht direkt auf Fileebene auf die INI-Dateien zugreifen, sondern die Windows Funktionen (z.B.: WriteProfileString) benutzen. Windows versucht bei solchen Zugriffen, die Informationen als erstes in der Registry zu finden, nur wenn die Einträge hier nicht gefunden werden, wird auf die physisch vorhandenen .INI-Dateien zurückgegriffen.

Die Mappings werden konfiguriert in der Registry unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ IniFileMapping

Hier wird für jede INI-Datei ein entsprechender Schlüssel mit dem Namen der INI-Datei angelegt. Unterhalb dieses Schlüssels wird für jeden Sektionsnamen ein Wert mit den Namen der Sektion als Datentyp REG_SZ angelegt. Als Wert wird der entsprechende Verweis in der Registry eingetragen, wo diese Einstellung ausgelesen werden soll.

Microsoft benutzt diesen Bereich auch, um einige INI-Einträge aus der SYSTEM.INI usw. hier abzubilden.

Beispiel:

INI-File Name: Test.INI

Sektion Name: Verzeichnis

In der Registry:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ IniFileMapping\ Test.ini

gibt es jetzt einen Wert mit den Namen "Verzeichnis" als Datentyp REG_SZ mit dem Inhalt "USR:TestFirma\Test". Die Abkürzung USR legt fest, ob der Wert unter den Maschinen oder Usereinstellungen abgespeichert werden soll. Die möglichen Werte sind:

SYS: | Der KEY wird unterhalb von HKEY_LOCAL_MACHINE\Software angelegt
USR: | Der KEY wird unterhalb von HKEY_CURRENT_USER\ angelegt
Mögliche zusätzliche Parameter: (werden vor SYS oder USR angegeben)
! | Daten werden in der Registry und in der INI-Datei eingetragen und jeweils abgeglichen
@ | Die Daten werden nicht mehr aus der INI-Datei gelesen, sondern nur noch aus der Registry
# | Wenn sich ein neuer Benutzer anmeldet, wird der Wert aus der INI-Datei in den angegebenen Registry-Key kopiert.

Beispiel: "#USR:TestFirma\Test"

Jetzt wird unterhalb von "HKEY_CURRENT_USER\ Software\ TestFirma\Test" ein Wert mit den Namen "Verzeichnis" angelegt, der dann den entsprechenden Wert aus der INI-Datei enthält (z.B.: C:\Programme\Test)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2009.htm


Performance Einstellungen für den Arbeitsstationsdienst

Mit den folgenden Werten können Sie den Datendurchsatz im Netzwerk beeinflussen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanWorkstation\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Hiermit legen Sie fest wie viel Puffer der Redirector max. zum Steuern des Durchsatzes reserviert. Da dieser Wert die Anzahl der Threads angibt und für jeden Thread 1 KByte Arbeitsspeicher belegt wird (der nicht ausgelagert werden kann). So steigert ein erhöhen des Wertes den Netzwerkdurchsatz, da aber mehr Arbeitsspeicher belegt wird, kann es bei kleinen Arbeitsspeicher auf der WS zu Geschwindigkeitsverlust führen.
MaxCmds | REG_DWORD | 50 bis 65535 | 50
Dieser Wert legt den Schwellwert für die Names Pipe fest, bis wann Zugriffe gepuffert werden. Ist ein Schreibvorgang größer als der angegebene Wert, wird der Vorgang nicht gepuffert was mehr Zeit kostet.
MaxCollectionCount | REG_DWORD | 0 bis 65535 Bytes | 16
MaxThreads | REG_DWORD | 0 bis 255 | 15

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0936.htm


Auslagerung der Kernel-Mode-Programmteile verhindern

Sind unter Windows viele Programme gleichzeitig aktiv, kann es vorkommen, dass NT anfängt, Teile des Kernels auszulagern. Das kann sich sehr negativ auf die Performance auswirken.

Es gibt aber eine Möglichkeit, das Auslagern von Kernel-Mode-Progammteilen zu verhindern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Ändern Sie den Wert "DisablePagingExecutive" als Datentyp REG_DWORD.

0 | Temporäres Auslagern ist erlaubt
1 | Systemcode im RAM behalten (kein Auslagern)

Info Ab NT 4.0 mit Service Pack 3 und Windows 2000 hat dieser Eintrag scheinbar keine Auswirkung mehr. Windows fängt trotzdem an, Kernel-Mode-Programmteile auszulagern!

Info Siehe auch: "Speicherverwaltung/Optimierung"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0230.htm


Speicherverwaltung/Optimierung

In der Registry kann man einige Einstellungen vornehmen, die den Umgang mit dem Speicher bestimmen.

Info Die Größe der Auslagerungsdatei sollten Sie aber nicht über den Registry-Editor ändern. Diesen Wert ändern Sie bitte immer über " Systemsteuerung" -> "System" -> "Leistungsmerkmale" -> "Virtueller Arbeitsspeicher" bzw. ab Vista (Klassische Ansicht) "Systemsteuerung" -> "System" -> "Erweiterte Systemeinstellungen" -> Tabreiter "Erweitert" -> Button "Einstellungen..." unter Leistung -> Tabreiter "Erweitert" -> Button "Ändern..." unter Virtueller Arbeitsspeicher.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Dort gibt es folgende Parameter:

Schlüssel

Datentyp

Angabe als

Standard

Bestimmt, wie der Server-Dienst eingestellt wurde:

0 Speicherbenutzung minimieren

1 Ausgeglichen (Cache und Arbeitsseiten haben dieselbe Priorität)

2 Durchsatz für Dateifreigaben maximieren (höhere Priorität für den Cache)

3 Durchsatz für Netzwerkanwendungen maximieren (Arbeitsseiten haben höhere Priorität als der Cache).

LargeSystemCache

REG_DWORD

0 bis 3

0

Legt fest, ob Windows beim Herunterfahren die Auslagerungsdatei mit Nullen überschreiben soll (Wert = 1) oder nicht (Wert = 0). Einige Bereiche, die vom System bzw. von aktiven Prozessen noch belegt werden, werden trotz alledem nicht überschrieben.

ClearPageFileAtShutdown

REG_DWORD

Boolean

0

Es wird festgelegt, ob Systemcode (Kernel und USER-Teil) in die Auslagerungsdatei mit ausgelagert werden kann. Wird hier eine 1 als Wert eingetragen, wird der Systemcode nicht mehr ausgelagert, was bei Systemen mit genügend Speicher die Systemgeschwindigkeit verbessert.

DisablePagingExecutive

REG_DWORD

Boolean

0

Legt fest, wie viel Speicher max. für Ein-/Ausgabeoperationen belegt werden darf. Der max.wert entspricht dem vorhandenen Arbeitsspeicher, dem Speicher, der für die Verwaltung benötigt wird (dieser benötigte Speicher steigt mit der Größe der Arbeitsspeicher, bei 64 MByte ca. 16 MByte und bei 512 MByte sind es schon 64 MByte). Wird als Wert 0 angegeben, werden standardmäßig 512K Speicher reserviert.

IoPageLockLimit

REG_DWORD

Bytezahl

512 KB

Legt fest, wie viel Speicher eine Anwendung max. bei "Nichtauslastung" belegen darf. Wird mehr Speicher von der Anwendung angefordert, wird von NT die Zuweisung von mehr Speicher verweigert. Bei der Angabe von 0 wird der max.wert automatisch von NT berechnet.

Info Das System verändert diesen Wert dynamisch, um fehlerhaften Anwendungen entgegenzuwirken, die Speicher belegen aber nicht mehr freigeben. Aus diesen Grund sollte man diesen Wert nicht selber verändern!

NonPagedPoolQuota

REG_DWORD

1 bis 128 MB

0

Legt die Größe aller ausgelagerten Seiten in Byte fest. Ist der Wert 0, wird von NT ein Wert berechnet, der vom Arbeitsspeicher abhängig ist. Der max.wert beträgt ca. 80% des Arbeitsspeichers.

NonPagedPoolSize

REG_DWORD

Bytezahl

0

Legt fest, wie viel Speicher eine Anwendung max. bei "Auslastung" belegen darf. Wird mehr Speicher von der Anwendung angefordert, wird von NT die Zuweisung von mehr Speicher verweigert. Bei der Angabe von 0 wird der max. Wert automatisch von NT berechnet.

Info Das System verändert diesen Wert dynamisch um fehlerhaften Anwendungen entgegenzuwirken, die Speicher belegen aber nicht mehr freigeben. Aus diesen Grunde sollte man diesen Wert nicht selber verändern!

PagedPoolQuota

REG_DWORD

1 bis 128 MB

0

Legt die Größe der Auslagerungsdatei fest. Ist der Wert 0, wird von NT automatisch die Größe der Auslagerungsdatei berechnet.

PagedPoolSize

REG_DWORD

0 bis 128 MB

0x3000000 (32 MByte)

Legt den Namen/Ort und den Anfangs-/Endwert der Auslagerungsdatei fest.

PagingFiles

REG_MULTI_SZ

Name und Größe

C:\Pagefile.sys 27 77

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0086.htm


Speicherverwaltung der Workstation ändern

Unter Windows Server-Version haben Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Netzwerk" -> "Dienste" -> "Server Dienst" folgende Einstellmöglichkeiten:

  • Speicherbenutzung minimieren,
  • Ausgeglichen,
  • Durchsatz für Dateifreigaben maximieren,
  • Durchsatz für Netzwerkanwendungen maximieren.

Diese Einstellungen können Sie bei der Workstation nicht auf diesem Wege verändern. Es ist nur über die Registry möglich.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Den Wert "LargeSystemCache" finden Sie unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

den Wert "Size" unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

Stellen Sie dort für die gewünschte Auswahl folgendes ein:

Speicherbenutzung minimieren | LargeSystemCache 0 Size 1
Ausgeglichene Speichernutzung | LargeSystemCache 0 Size 2
Durchsatz für Dateifreigaben maximieren | LargeSystemCache 1 Size 3
Durchsatz für Netzwerkanwendungen maximieren | LargeSystemCache 0 Size 3

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: [Link]

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0126.htm


Verteilung der Auslagerungsdatei auf mehrere Platten

Windows NT unterstützt ein simultanes Schreiben auf mehrere Festplatten. Physikalische Festplatten können quasi simultan ausgeführt werden. Dadurch würde das Schreiben in die Auslagerungsdatei erheblich beschleunigt werden, wenn diese auf mehrere Festplatten verteilt ist. Man benötigt mind. eine 2. Festplatte.

  1. Wählen Sie Einstellungen | Systemsteuerung aus dem Startmenü
  2. "System" doppelklicken
  3. Registerkarte Leistungsmerkeinmale
  4. Im Bereich Arbeitsspeicher auf "Ändern" klicken
  5. Das primäre Volume der 1. physikalischen Platte wählen
  6. Anfangs- und Endgröße der Swap setzen (z.B. 16/48 MB)
  7. "Setzen" anklicken
  8. Jetzt das primäre Volume der 2. Platte wählen und ebenso verfahren (wieder die Größen setzen).

Ab Windows Vista:

Finden Sie die Einstellung unter "Systemsteuerung" -> "System" -> "Erweiterte Einstellungen" -> Tabreiter "Erweitert" -> Button "Einstellungen..." unter Leistung -> Tabreiter "Erweitert" -> Button "Ändern..." unter Virtueller Arbeitsspeicher -> Wenn Sie hier jetzt den Haken bei "Auslagerungsdateigröße für alle Laufwerke automatisch verwalten" entfernen, können Sie selber die Auslagerungsdateien anlegen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0722.htm


Größe des L2-Caches festlegen

Durch den L2-Cach, welcher in Windows unter dem Eintrag „SecondLevelDataCache“ abgelegt wird, wird die Größe des eigenen Prozessor-Speichers bezeichnet.

Wenn dieser Wert auf <0> steht, versucht Windows den Wert selber zu ermitteln und entsprechend richtig einzustellen. Kann Windows den Wert nicht ermitteln, wird der Standard von 256 KByte benutzt.

Sie sollten diesen Wert also in den meisten Fällen auf 0 belassen, da Windows die optimale Einstellung somit selber ermitteln kann. Bei einigen älteren Rechnern kann die Veränderung aber zu einer kleinen Leistungssteigerung führen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Erstellen Sie hier einen neuen Wert mit dem Namen "SecondLevelDataCache" als Datentyp REG_DWORD. Setzen Sie den Wert auf die Größe des Caches (Dezimalwert).

0 | Windows versucht die Größe auszulesen, ansonsten 256 KByte (Standard)
512 | 512 KByte L2-Caches
1024 | 1024 KByte L2-Caches
2048 | 2048 KByte L2-Caches

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1665.htm


Parallelports einrichten

Das geschieht über Änderungen in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Parallel

kann man weitere Ports manuell definieren. Unter dem Schlüssel "Parameters" werden weitere Ports mit dem Schlüsselnamen "Parallelx" (wobei das x durch den LPT-Port zu ersetzen ist z.B. "Parallel2") eingerichtet.

Hier können Sie nun folgende Optionen Eintragen (unbedingt notwendig):

DOS Devices | Name, mit dem der Port angesprochen wird z.B. "LPT3"
PortAddresse | Portadresse in hexadezimaler Schreibweise z.B. "0x278"

Optional:

DisablePort | Der Port wird nach einem Reset gesperrt und steht nicht mehr zu Verfügung, wenn hier eine "1" eingetragen wird
Interrupt | IRQ in hexadezimaler Schreibweise für den Druckerport z.B. "0x5". Ohne diese Angabe erfolgt der Druck softwaremäßig über den Prozessor

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0204.htm


Serielle Ports einrichten

Das Einrichten von seriellen Ports und die erweitere Konfiguration kann in der Registry wie folgt durchgeführt werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Serial

kann man weitere Ports manuell definieren. Unter dem Schlüssel "Parameters" werden weitere Ports mit den Schlüsselnamen "Serialx" (wobei das x durch die Nummer des COM-Ports zu ersetzen ist z.B. "Serial3") eingerichtet.

Hier können Sie nun folgende Optionen Eintragen.

Unbedingt notwendig:

DOS Devices | Namen zum Ansprechen des Ports z.B. "COM3"
Interrupt | Interrupt in hexadeximaler Schreibweise z.B. "0x4"
PortAddresse | Portadresse in hexadezimaler Schreibweise z.B. "0x3e8"

Optional:

DisablePort | Der Port wird nach einem Reset gesperrt und steht nicht mehr zu Verfügung, wenn hier eine "1" eingetragen wird
ForceFifoEnable | Mit diesem Wert "1" können Sie einen vorhandenen FIFO-Buffer aktivieren. Fast alle neuen Rechner verfügen heutzutage über solche Bausteine (z.B. AFM 16550).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0716.htm


Virtuellen Drucker Port hinzufügen

Unter Windows 95/98 können Sie beliebig entsprechende Ports mit Druckern belegen und auf andere umleiten. Bei Windows NT standardmäßig nur bis LPT3. Wenn Sie versuchen, einen Netzwerkdrucker auf LPT4 zu mappen, bekommen Sie eine Fehlermeldung.

Aber auch hier können Sie höhere Ports benutzen, Sie müssen sie nur erst anlegen und das geht so:

Windows NT

"Arbeitsplatz" -> "Drucker" -> "Neuer Drucker" -> "Arbeitsplatz" nun keinen Anschluss auswählen sondern "Hinzufügen" -> "Local Port" auf neuer Anschluss klicken und dort als Namen "LPT4:" eingeben (Wichtig ist, dass der : (Doppelpunkt) mit eingegeben wird). Das können Sie jetzt für beliebig viele Portnummern wiederholen.

Ab Windows 2000

Hier geht es leider nicht mehr so einfach über ein Menü, Sie müssen hier den Eintrag selber in der Registry durchführen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Ports

erstellen Sie einen neuen Eintrag mit den Namen "LPT<Nummer>:" ( z.B.: LPT4:) als Datentyp REG_SZ und geben als Wert nichts ein. Wenn Sie einen COM-Port hinzufügen ("COM<Nummer>:") müssen Sie als Wert die Übertragungsdaten eingeben (Standard: "9600,n,8,1").

Danach müssen Sie noch Windows neu starten oder händisch den Druckerspooler stoppen und starten:

net stop spooler

net start spooler

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0636.htm


IrDA-Schnittstelle unter NT nutzen

Standardmäßig wird die IrDA-Schnittstelle nicht von Windows NT unterstützt. Wollen Sie auf die Funktion aber nicht verzichten, müssen Sie auf die Treiber von Fremdherstellern zurückgreifen.

Die Quickbeam-Suite liefert IrDA-Stacks und -Treiber für Windows - auch Windows NT - sowie ein praktisches, intuitiv zu bedienendes Programm zur Dateiübertragung. Eine genauere Beschreibung finden Sie unter:

http://www.jacobi.de/irda/quickbeam.html

JACOBI C.E.O.S. Computer Equipment & Online Services

Zschertnitzer Str. 42

D-01219 Dresden

Tel.: (+49) (0)351 470 05 08

Fax: (+49) (0)351 470 05 36

http://www.jacobi.de/irda/

E-Mail: olaf@jacobi.de

IrDA mit Nokia6110

Das Nokia 6110 und damit eigentlich die 61xx-Reihe ist nicht 100% IrDA-kompatibel. Allerdings habe ich über das 6150 schon anderes gehört, nämlich dass dort neuere Software-Versionen voll IrDA-kompatibel sind. Ich verweise zu einer Menge von Informationen einmal auf:

http://home.wxs.nl/~deest000/

http://www.actisys.com/files/

http://ourworld.compuserve.com/homepages/martin_guthrie/IR/InfraRed.htm

Der letzte Link dreht sich zwar um Koppelung mit Psion, aber es werden eine Menge Grundlagen in den Windows-Einstellungen für die IrDA-Geschichten beschrieben (Einstellung der Systemsteuerungsparameter usw).

Was ich erfolgreich geschafft habe, ist der Einsatz der Logoeditoren für das 6110 (von http://www.actisys.com/files/). Generell empfiehlt es sich, die NCDS von Nokia zu haben, für deren Einsatz man alle relevanten Infos unter dem Link http://home.wxs.nl/~deest000/ findet.

Die Infrarot-Adapter gibt es im Prinzip immer in 3 Varianten:

  1. Intern auf IrDA-Steckplatz zu verbinden (z.B. BayBeamer, ACT-IR210L)
  2. Extern auf serielle Schnittstelle zu verbinden (z.B. JetEYE, ACT-IR220L und ACT-IR220L+)
  3. Per ISA-Interfacekarte (diese auch für 4 MBit/s, also IrDA 1.1)

Adapter mit USB-Interface sind in Vorbereitung, werden preislich attraktiv sein, aber momentan gibt es da massive Probleme mit der Softwareunterstützung in Windows 98, daher werden diese noch nicht ausgeliefert (von ACTiSYS).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0578.htm


Reservierter Speicher für Ein/Ausgabeoperationen

Windows reserviert standardmäßig einen Teil des Arbeitsspeichers für Ein/Ausgabe und Dateisystemoperationen. Dieser Wert ist speziell auf den Arbeitsspeicher abgestimmt und bietet deshalb schon eine gute Geschwindigkeit.

Je nach dem welche Anwendungen Sie benutzen, kann ein größerer Wert die Performance verbessern.

Die Einstellung ändern Sie

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Erstellen Sie hier einen Wert mit den Namen "IoPageLockLimit" als Datentyp REG_DWORD wird der zu reservierende Speicher angegeben.

Hiermit legt man fest, wie viel Speicher max. für Ein-/Ausgabeoperationen belegt werden darf. Der max. Wert entspricht dem vorhandenen Arbeitsspeicher - dem Speicher, der für die Verwaltung benötigt wird (dieser benötigte Speicher steigt mit der Größe der Arbeitsspeichers, bei 64 MByte ca. 16 MByte und bei 512 MByte sind es schon 64 MByte). Wird als Wert 0 angegeben, werden standardmäßig 512K Speicher reserviert.

Folgende Werte sind meist sinnvoll:

Arbeitsspeicher (MByte) | IoPageLockLimit (Hex) | IoPageLockLimit (Dezimal) (Speicher in KByte)
32 | 1000 | 4096
64 | 2000 | 8192
128 | 4000 | 16384
256 | 10000 | 65536
320 | 12000 | 73728
384 | 14000 | 81920
512 | 20000 | 131072
768 | 30000 | 196608
1024 | 40000 | 262144

Info Damit diese Einstellungen auch verwendet werden, muss noch der Wert "LargeSystemCache" auf 0 und "Size" auf 3 gesetzt werden. (siehe: Speicherverwaltung der Workstation ändern). Dann nutzen alle I/O Operationen diesen Speicher. Durch Erhöhen dieses Wertes kann man einige Blue-Screens vermeiden, da einige Blue-Screens nur Timeouts sind, die nur auftreten, weil die Daten nicht schnell genug durch die 512 KByte kommen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0040.htm


Unterschiedliche DLL-Versionen

Häufig kommt es vor, dass Programme zwar dieselbe DLL benutzen, aber nur mit unterschiedlichen Versionen dieser DLL zusammenarbeiten.

Ab NT können Sie für die Programme Pfade vorgeben, in denen nach den DLL-Dateien gesucht werden soll. So können Sie von einer DLL verschiedene Versionen auf Ihrem Rechner bereitstellen.

Die DLL-Suchpfade können Sie in der Registry angeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsof\ Windows\ CurrentVersion\ App Paths

finden Sie entweder schon den Programmnamen, oder Sie legen einen neuen Schlüssel mit dem Namen der entsprechenden EXE-Datei an.

Unter diesem Schlüssel nehmen Sie zwei Einträge vor:

Schlüsselname | Datentyp | Eintrag
default | REG_SZ | Pfad und Name zum Programm (z.B.: C:\Programme\Microsoft Office\Office\EXCEL.EXE)
Path | REG_SZ | Pfad zum DLL-Verzeichnis (z.B.: C:\Programme\Microsoft Office\Office)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0617.htm


Windows Dateitypenbezeichnungen

In den aktuellen Registryeinstellungen von Windows werden bei Dateiendungen nur die ersten drei Zeichen beachtet. Das bedeutet, wenn Sie z.B. alle HTM-Dateien löschen wollen und dafür DEL *.HTM eingeben, werden auch alle HTML-Dateien gelöscht, da Windows ja nur drei Zeichen beachtet.

Wollen Sie das verhindern, müssen Sie folgendes in der Registry umstellen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Filesystem

Den Wert "Win95TruncatedExtensions" als Datentyp REG_DWORD abändern in "0". Jetzt werden alle Zeichen der Dateiendung beachtet.

0 = ein

1 = aus (nur die ersten drei Zeichen werden beachtet)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0356.htm


NTFS-Berechtigungen beim Kopieren/Verschieben beibehalten

Wenn Sie eine Datei oder Verzeichnis in ein anderes Verzeichnis kopieren oder verschieben, dann übernimmt das Objekt die neuen Berechtigungen des NTFS-Ordners.

Mit diesem Tipp können Sie einstellen, dass auch die Berechtigungen mit kopiert werden und somit erhalten bleiben.

Info Innerhalb des gleichen Volumes (Laufwerk) werden die Daten nicht verschoben, sondern nur die Verzeichnisverweise geändert. Deshalb behalten die verschobenen Daten die bestehenden Rechte. Werden die Daten über Volumegrenzen hinweg verschoben (auf ein anderes Laufwerk), entspricht das der Befehlsfolge Kopieren und Löschen. Die Rechte des Zielverzeichnisses werden übernommen, was durch diesen Tipp geändert werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceCopyAclwithFile" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | NTFS-Berechtigungen bleiben erhalten
0 | NTFS-Berechtigungen werden nicht kopiert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1672.htm


Laufwerksbuchtstabe des Zip-Drive zwischen den Festplatten

Sollte obiges der Fall sein, dann nützt auch ein SP6 nichts. Sie müssen dann folgendes machen, um die Laufwerksbuchstaben wieder zu sortieren.

  1. den Rechner ausschalten und das Datenkabel des Zips abklemmen.
  2. Rechner einschalten und nach dem Hochfahren als Admin anmelden
  3. Festplattenmanager starten und die Laufwerksbuchstaben korrigieren. (als erstes das CD-Rom nach hinten und dann die Buchstaben der Festplatten)
  4. Jetzt Rechner herunter fahren
  5. dann Zip-Laufwerk Datenkabel wieder aufstecken. und wieder starten.

Jetzt sollte eigentlich alles in Ordnung sein.

Info Es geht auch einfacher:
Einfach ein Zip-Medium ins Laufwerk legen und dann den Festplattenmanager starten. Nun wird auch das Zip-Laufwerk angezeigt und es ist möglich, den Buchstaben zu ändern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0966.htm


DMA-Mode für Festplatte einstellen

Unter Windows NT ist der DMA-Modus für die Festplatte standardmäßig nicht aktiviert. Über einen Eintrag in der Registry können Sie das aber einschalten. Wichtig ist, dass Ihr System den DMA-Modus auch unterstützt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ atapi\ Parameters\ Devicex

Das x steht für den jeweiligen Port (wenn der Schlüssel nicht vorhanden ist, müssen Sie ihn selber anlegen).

Device0 | für den ersten Festplattenanschluss
Device1 | für den zweiten Festplattenanschluss

Dort erstellen Sie den Wert "DriverParameter" als Datentyp REG_SZ und setzen diesen Wert auf "DmaDetectionLevel = 0x1"

DmaDetectionLevel kann dabei die Werte 0, 1 und 2 annehmen.

0DMA deaktiviert

1DMA automatisch wählen

2DMA aktivieren

Info Einige Brennerprogramme bringen NT zum Absturz, wenn der DMA-Modus aktiviert ist!

Info Microsoft bietet unter der Adresse " http://support.microsoft.com/?kbid=191774" das Programm DMACHECK an, mit dem Sie diese Einstellungen auch verändern können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0559.htm


Zugriffe auf die Festplatte, obwohl keine Aktivitäten stattfinden

Nach der Installation vom Service Pack 4 bei NT bzw. allen oben angegeben Betriebssystem greift Windows ständig auf die Festplatte zu, obwohl keine Aktivitäten stattfinden. Windows schreibt dabei alle paar Minuten ein Lebenszeichen auf die Festplatte. Diese Funktion war eigentlich nur für die Server-Version von Windows gedacht, hat sich aber auch in der Workstation Version eingeschlichen. Durch einen Eingriff in die Registry können Sie das aber wieder deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Reliability

erstellen Sie einen Wert "TimeStampInterval" als Datentyp REG_DWORD und weisen ihm den Wert 0 zu um die Funktion zu deaktivieren. Dieser Wert gibt die Zeit in Minuten ab wann ein erneuter Zeitstempel geschrieben werden soll, der Standardwert ist 5 Minuten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0594.htm


HPFS trotz NT 4.0

HPFS trotz Windows NT 4.0

Für das Formatieren in HPFS-Format benötigt man die Format-Routine aus der Version 3.5. Damit NT 4.0 HPFS auch lesen kann, wird auch noch der Treiber PINBALL.SYS benötigt, ebenfalls aus NT 3.51. Kopieren Sie diesen Treiber nach

%SYSTEMROOT%\System32\Drivers.

Außerdem sind ein paar Einträge in der Registry notwendig:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Pinball

Schlüssel | Datentyp | Wert
ErrorControl | REG_DWORD | 0x1
Group | REG_SZ | Boot file system
Start | REG_DWORD | 0x1
Type | REG_DWORD | 0x2

Markieren Sie zunächst den Schlüssel "Services", klicken Sie mit der rechten Maustaste darauf und wählen -> "Neu" -> "Schlüssel". Nennen Sie den Schlüssel "Pinball".

Um die restlichen, oben aufgelisteten Einträge einzufügen, öffnen Sie "Pinball", klicken Sie mit der rechten Maustaste auf das rechte Fenster, wählen Sie -> "Neu" -> Datentyp, geben die Einträge ein und weisen ihnen entsprechende Werte zu (Doppelklick auf einen Eintrag und Wert eintippen).

Unter NT 3.51 lautet der Eintrag für den "Start" -Parameter "0x4", das entspricht im Control Panel unter Device dem Status "Disabled". Mit dieser Einstellung startet NT 4.0 das Filesystem nicht mehr. Der von HPFS übernommene Parameter 0x1 (System) funktioniert dagegen problemlos.

Info Sie sollten vorher unbedingt ein Backup durchführen!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0297.htm


Mirroring bzw. Duplexing

Gehört zum Raid Level 1 und wird softwaremäßig von Windows unterstützt.

Disk Mirroring:

Hierbei wird die Festplatte auf eine andere gespiegelt. Das heißt, auf beiden Festplatten befinden sich die gleichen Daten. Bei WindowsNT muss keine ganze Festplatte gespiegelt werden und somit ist es möglich, zwei unterschiedlich große Festplatten zu benutzen. Der Platz der Spiegelung richtet sich nach der kleinsten Festplatte. Der restliche Speicherplatz wird verschwendet!

Disk Duplexing:

Wie Disk Mirroring, nur dass hier die Festplatten jeweils an einen eigenen Controller angeschlossen werden. Dadurch wird die Sicherheit gesteigert, da die Festplatte auch beim Ausfall eines Controllers noch zur Verfügung steht. Gleichzeitig wird dadurch die Performance gesteigert.

Einrichten:

Das Einrichten der beiden Möglichkeiten funktioniert unter NT identisch. Unter NT können sämtliche unterstützten Dateisysteme gespiegelt werden (FAT, HPFS und NTFS).

Um eine Spiegelung einzurichten, starten Sie den Festplatten-Manager, markieren Sie die zu spiegelnde Partition und danach bei gedrückter STRG-Taste die Partition, auf die gespiegelt werden soll (diese Partition muss gleich groß oder größer sein als die zu spiegelnde). Rufen Sie im Menü "Fehlertoleranz" die Option "Spiegelung einrichten" auf und bestätigen Sie die nächste Abfrage.

Um Mirroring bzw. Duplexing nun durchzuführen, klicken Sie entweder im Menü "Partition" auf "Änderung jetzt durchführen" oder beenden Sie den Festplatten-Manager.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0132.htm


Stripe Sets mit Parität

Stripe Set mit Parität

Entspricht Raid Level 5 und wird softwaremäßig von Windows unterstützt.

Info Stripe Set wird nur von der Server-Version unterstützt!

Beim Stripe Set mit Parität wird aus mehreren Partitionen ein logisches Laufwerk gebildet. Dafür werden mindestens drei Festplatten benötigt (von NT werden höchstens 32 Festplatten unterstützt). Auf den Festplatten werden zusätzlich zu den eigentlichen Daten auch Paritäts-Daten abgelegt. So ist es möglich, alle Daten wiederherzustellen, falls eine der Festplatten ausfällt.

Einrichten:

Starten Sie den Festplatten-Manager und markieren Sie die Speicherbereiche, die für das Strip Set verwendet werden sollen (STRG-Taste gedrückt halten). Rufen Sie im Menü -> "Fehlertoleranz" -> "Stripe Set mit Parität" auf. Nun wird eine Dialogbox geöffnet, in der die max. und Minimale Größe angezeigt wird. Geben Sie dort die gewünschte Größe ein und klicken Sie auf -> "OK".Klicken Sie anschließend im Menü "Partition" auf -> "Änderung jetzt durchführen" oder beenden Sie den Festplatten-Manager.

Info Nach der Durchführung wird das System neu gestartet.

Info Es dürfen hierfür keine Systempartitionen benutzt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0421.htm


SCSI-Adapter (Sortierung)

Wenn man zwei oder mehr SCSI-Adapter im System eingebaut hat und Änderungen an der Hardware bzw. NT neu installiert, kann es unter NT zu einem lästigen Problem kommen.

NT sortiert die Adapter neu in eine beliebige Reihenfolge, die aber nicht zum System passt. So wird z.B. der falsche SCSI-Controller zum ersten SCSI-Controller deklariert und dementsprechend will NT nur von diesem Controller booten.

Werden zwei gleiche SCSI-Controller eingesetzt, kann man die Reihenfolge dadurch beeinflussen, dass man den Controller mit der Bootplatte in den PCI-Slot mit der niedrigeren Nummer steckt (siehe Boardbezeichnung) bzw. dem Controller einen niedrigeren Interrupt zuweist (BIOS -Einstellung). Bei unterschiedlichen Controllern erweist sich diese Methode aber als sehr unzuverlässig.

Welcher Controller aber der erste wird, bestimmt lediglich die Reihenfolge, in der die Treiber unter NT geladen werden. Diese Reihenfolge kann man in der Registry vorgeben:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ ServiceGroupOrder

finden Se ein Liste, in welcher Reihenfolge die Treiber unter NT geladen werden.

Gehen Sie Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services

suchen Sie dort die beiden zu vertauschenden SCSI-Controller aus der Liste heraus und notieren Sie sich den "Tag" - Wert (wird in HEX angegeben). Vertauschen Sie diese beiden Werte, und schon werden die SCSI-Treiber beim nächsten Start von NT in einer anderen Reihenfolge geladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0406.htm


Festplattenfehlertoleranz (Raid-Level)

Die Klassifizierung nach RAID wird von vielen Herstellern unterschiedlich ausgelegt. Gerade die Raid-Level größer als 5 sind nicht mehr vergleichbar.

Aus diesen Grunde wurde die Klassifizierung von RAB überarbeitet und in neue Gruppen unterteilt. Die meisten Hersteller benutzen diese neue Einteilung. Eine Auflistung finden Sie am Ende dieser Liste (RAB-Level)

Window NT unterstützt softwaremäßig nur Raid-Level 0, 1 und 5.

Hier werden aber der Vollständigkeit halber alle Raid-Level erklärt:

Raid Level 0:

Wird auch als Striping bezeichnet. Bei diesem Level werden mehrere Festplatten zu einem einzigen Datenbereich zusammengefügt. Der Controller verteilt die Daten auf mehrere Kanäle und Festplatten. Dadurch lässt sich eine höhere I/O- Bandbreite erzielen, weil Daten parallel gelesen und geschrieben werden können. Da keine Datenredundanz vorgesehen ist, sorgt das nur für eine höhere Geschwindigkeit, kann aber keine Datenverluste bei Fehlern verhindern. Aus diesem Grunde wird dieses bei Servern nicht verwendet.

Sicherheit: | Keine, sobald eine Festplatte ausfällt, sind alle Daten verloren.
Nutzfaktor: | Sehr gut, da der gesamte Platz nur für Daten verwendet wird.
Bemerkung: | Sehr hohe Performance bei großen Datenmengen.

Raid Level 1:

Wird auch als Mirroring (Plattenspiegelung) bezeichnet. Hier werden sämtliche Daten parallel auf zwei Festplatten geschrieben.

Sicherheit: | Sehr hoch, denn wenn eine Festplatte ausfällt, stehen die Daten auf der anderen noch zur Verfügung.
Nutzfaktor: | 0,5 und ist damit sehr schlecht, da immer nur die Hälfte der Kapazität zur Verfügung steht.
Bemerkung: | Wird bei Servern bis ca 7 GByte verwendet.

Raid Level 2:

Fügt den Daten einen Fehlerkorrektur-Code hinzu.

Bemerkung: Wird heute so gut wie nicht mehr eingesetzt.

Raid Level 3:

Diese Lösung besteht aus mindestens 3 Festplatten, wobei die eine nur für die Korrekturdaten verwendet wird. Es wird also für jede Datenzeile noch ein Parity-Block angelegt und auf einer zusätzlichen Festplatte gespeichert. Fällt nun eine Festplatte in diesem System aus, können die darauf gespeicherten Daten aus den restlichen Daten und den Parity-Daten wieder hergestellt werden. Dieses System weist bei sequentiellen Lese- und Schreibzugriffen eine gute Performance auf, bei verteilten Schreibzugriffen geht die Geschwindigkeit aber stark nach unten.

Sicherheit: | Ist gegeben; bei Ausfall einer Festplatte können die Daten aus den noch vorhandenen errechnet werden.
Vorteil: | Lese-Performance wird durch kleine Blöcke verbessert.
Nachteil: | Schreiben der Daten recht langsam.
Bemerkung: | Wird bei Servern ab 8 GByte eingesetzt.

Raid Level 4:

Wird auch als Data Guarding bezeichnet. Raid 4 gleicht in der Arbeitsweise Raid 3 hier wird jedoch eine höhere Blockgröße gewählt.

Sicherheit: | wie bei Level 3
Vorteil: | Lese-Performance wird zu Level 3 gesteigert, überlappender Zugriff möglich
Nachteil: | Schreibzugriff zwar schneller als bei Level 3, aber immer noch nicht sehr gut.

Raid Level 5:

Wird auch als Distributed Data Guarding bezeichnet. Wie Level 4, nur dass hier Parity-Daten auf alle Festplatten verteilt werden und nicht auf einer extra Festplatte abgelegt werden. Dadurch werden verteilte Schreibzugriffe beschleunigt. Typischerweise wird Raid 5 bei Servern mit großen Festplattenkapazitäten verwendet. Durch die Berechnung der Parity-Daten kann dieses System nicht die Performance von Raid 0 oder Raid 1- Systemen erreichen.

Sicherheit: | Wie bei Level 3.
Vorteil: | Schreibzugriff schneller, weil nun auch hier ein überlappender Zugriff möglich.
Nutzfaktor: | Hängt von der Anzahl der Festplatten ab. (bei 3 Festplatten ca 0,67, bei 8 Platten steigt er schon auf 0,86).
Bemerkung: | Wird bei Servern ab 8 GByte eingesetzt.

Raid Level 10:

Das ist eine sehr neue Art der Datenspeicherung und ist eine Kombination aus Raid 0 und Raid 1. Da hierbei keine Parity-Daten berechnet werden müssen, eignet sich das System besonders für die Speicherung von großen redundanten Datenmengen.

Sicherheit: | Wie bei Level 1
Vorteil: | Schreibzugriff schnell, da keine Parity-Daten berechnet und geschrieben werden müssen.
Nutzfaktor: | 0,5 und ist damit sehr schlecht, da immer nur die Hälfte der Kapazität zur Verfügung steht.
Bemerkung: | Wird bei Servern größer 10 GByte eingesetzt.

Die neue Aufteilung in RAB-Level:

Es gibt hier nun 3 Gruppen:

Failure-Resistant (FR) | Es werden weiterhin fehlerfreie Daten geliefert, wenn ein Plattenlaufwerk ausfällt
Failure-Tolerant (FT) | Es werden weiterhin fehlerfreie Daten geliefert, auch wenn eine beliebige wechselbare Einheit ausfällt
Disaster-Tolerant (DT) | Es werden weiterhin fehlerfreie Daten geliefert, auch wenn eine ganze Gerätegruppe in einem System aus mehreren Gruppen ausfällt

Zusätze:

DS | Datenspeichersysteme aus Festplatten (z.B. FRDS)
AC | Array Controller
+ | Bezeichnet, dass die Festplatten zusätzlich über Hot-Swap-Funktion verfügen (z.B. FRDS+)

Bei FTDS++ weist das zweite + auf einen zusätzlichen Schutz beim Ausfall von mehreren Festplatten hin.

Genauere Informationen finden Sie dazu unter "http://www.raid-advisory.com"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0145.htm


NT Diskedit

In den Service Packs 5 und 6a hat MS das Programm DISKEDIT.EXE versteckt. Mit diesem Programm können Sie NTFS-Partitionen auf Sektorebene betrachten. Das Programm wird bei der Installation vom Servicepack nicht automatisch mit installiert. Sie müssen das Servicepack mit /x entpacken und können sich dann das Programm herauskopieren.

Info Dieses Tool sollte nur von erfahrenen Anwendern verwendet werden. Da MS keine Beschreibung mitliefert, kann man bei falscher Bedienung sehr viel Schaden anrichten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0479.htm


SCSI-Probleme bei mehreren LUNs

Bei einigen SCSI-Geräte kann es zu Fehlern kommen, wenn der SCSI-Controller unter einer ID nach mehreren LUNs (Logical Unit Numbers) sucht. Das kann dann zu mehrfacher Anzeige des gleichen Gerätes führen oder sogar das ganze System zum Absturz bringen.

In der Registry können Sie das abstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System \CurrentControlSet\ Services\ [Controllername]\ Parameters

(den Eintrag [Controllername] müssen Sie durch die jeweilige Bezeichnung Ihres SCSI-Controllers ersetzen)

hier können Sie Mit diesem Wert "MaximumLogicalUnit" als Datentyp Dword festlegen, nach wie vielen LUNs gesucht werden soll. Standardmäßig steht dieser Wert auf 8. Bei den meisten Geräten reicht es aber, diesen Wert auf 1 zu setzen, da die wenigsten SCSI-Geräte mehr als eine LUN unterstützen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0677.htm


Große Festplatten komprimieren

NT unterstützt bei der Komprimierung nur eine Clustergröße von max. 4096 Bytes. Wird beim Formatieren einer Festplatte aber keine Clustergröße angegeben, setzt NT ab Partitionen größer als 4 GByte die Clustergröße auch höher.

Wenn Sie auch auf solchen Partitionen noch mit komprimierten Daten arbeiten wollen, müssen Sie beim Formatieren der Partition die Clustergröße vorgeben (entweder über die Eingabeaufforderung mit "Format /a:[Clustergröße]" oder im Festplatten-Manager).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0133.htm


Tekram SCSI-Controller unter Windows NT 4.0 einrichten

Beschreibt die Installation eines Tekram SCSI-Controllers unter WIndows NT 4.0.

  1. Erste Installationsdiskette einlegen
  2. Computer starten
  3. In der Zeit des erstmaligen Zugriffes auf die Diskette bis zum Erscheinen des blauen Bildschirmes F5 gedrückt halten (auch wenn der Tastaturbuffer überläuft)
  4. STANDARD PC auswählen
  5. Zweite Diskette gem. Anforderung einlegen
  6. Nächste Abfrage mit ENTER bestätigen
  7. Nächste Abfrage mit A bestätigen
  8. Nächste Abfrage mit Z bestätigen
  9. Tekram SCSI Treiber Disk einlegen (Neuste Version gibt es unter http://www.tekram.de/)
  10. Den gewünschten Treiber auswählen
  11. Mit ENTER bestätigen
  12. Dritte Diskette einlegen
  13. Der Rest der Installation läuft wie immer ab.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0723.htm


Datenträgerauslastung mit dem Systemmonitor protokollieren

Der Windows NT-interne System-Monitor erlaubt keine direkte Überwachung der Festplatten-Performance, weil keine entsprechenden Datenquellen zur Verfügung stehen.

Wenn Sie mit dem Systemmonitor (PERFMON.EXE) die Auslastung Ihrer Datenträger protokollieren wollen, müssen Sie erst einmal die Festplatten dafür freigeben. Dazu müssen Sie diskperf -y \\Computernameeingeben. Nun können Sie nach einem Neustart des Systems die Schreib- und Lesegeschwindigkeit Ihrer Harddisks messen.

Zum Deaktivieren geben Sie an der Eingabeaufforderung diskperf -n ein. Die Option Computernamemüssen Sie nur eingeben, wenn sich der Rechner in einem Netzwerk befindet.

Die Parameter von DISKPERF.EXE:

-y | Starten "Datenträgerdatenquellen" nach einem Systemneustart
-ye | Aktiviert "Datenträgerdatenquellen" die für die Leistungsüberwachung bei physischen Laufwerken mit Stripe Sets verwendet werden.
-n | Beendet "Datenträgerdatenquellen" nach einem Systemneustart
//[Servername] | Führt den Befehl auf einen bestimmten Server aus

Beispiel:

Diskperf -ye \\TestServer

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0620.htm


Features von NTFS

Bei Windows NT und Windows 2000 haben Sie die Möglichkeit, NTFS als Dateisystem zu benutzen. Wenn Sie Windows 2000 installieren, wird automatisch NTFS 5 benutzt. Bei einer Installation auf einem System, welches bereits NTFS 4.0 von NT verwendet, wird das NTFS automatisch auf NTFS 5.0 konvertiert.

Hier finden Sie eine Übersicht der Features von NTFS

Funktion | Beschreibung
Sicherheitseinstellungen | Festlegen der Zugriffsrechte von Benutzern auf Dateien und Ordnern
Protokoll der Festplattenaktivitäten | Zum Wiederherstellen von Daten nach einen Systemausfall (Stromausfall)
Bessere Clustergrößen | Weniger Verschwendung von Festplattenplatz durch kleine Dateien
Komprimieren von einzelnen Dateien oder ganzen Verzeichnissen | Einsparen von Festplattenplatz
Datenträgererweiterung | Speicherplatzerweiterung
Stripeset | Raid-Systeme (Geschwindigkeitsvorteil)
POSIX-Dateizugriff | Für UNIX-Programme
Neue Funktionen von NTFS 5.0 (ab Windows 2000)
Datenträgererweiterung | Jetzt wird die Speicherplatzerweiterung sogar ohne Neustart des Rechners ermöglicht
Verschlüsselung | Verschlüsseln von Dateien und Verzeichnissen
Verknüpfungsüberwachung | Verknüpfungen bleiben auch erhalten, wenn die Daten auf einen anderen Datenträger verschoben werden
Bereitstellungspunkte | Datenträger und Partitionen können zu anderen bestehenden Verzeichnissen hinzugefügt werden.
Indizierung | Ermöglicht das schnellere Suchen von Dateien
Partitionen größer als 4 GB bei der Installation | Sie können bei der Installation jetzt schon Partitionen größer als 4 GByte anlegen.

Info Windows NT 4.0 kann ab Service Pack 4 lesend und schreibend auf NTFS 5 Dateisysteme zugreifen, aber eine Reparatur ist nicht mehr möglich. Da Windows 2000 bei der Installation aber automatisch alle NTFS Laufwerke auf NTFS 5 umwandelt (auch wenn diese Laufwerke versteckt sind), kann man bei einem parallelen Betrieb von Windows 2000 und NT 4.0 keine Reparatur mehr unter NT 4.0 starten, wenn z.B. NT nicht sauber heruntergefahren wurde. Bei "System Internals" finden Sie eine Software, die Teile des Windows 2000 Betriebssystems verwendet, um auch unter NT 4 eine Reparatur ausführen zu können:http://www.sysinternals.com/ntw2k/freeware/NTFSCHK.shtml

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0976.htm


FAT oder NTFS?

Hier finden Sie eine kurze Übersicht und Empfehlung über die Dateisysteme NTFS und FAT.

Grundsätzlich ist immer NTFS zu empfehlen. FAT sollte man nur benutzen, wenn man auf die Partition unter DOS zugreifen will oder man mit Partitionen unter ca. 400 MB arbeitet.

Eigenschaften von NTFS:

  • Bessere Sicherheit und Datenschutz
    Bei NTFS können auch für lokale Benutzer nur bestimmte Bereiche zugänglich gemacht werden (bei FAT haben lokale User Zugriff auf alle Verzeichnisse)
  • Bessere Fehlertoleranz (Hot Fixing)
  • Gelöschte Dateien lassen sich nicht wiederherstellen (nicht immer von Vorteil)
  • Geringere Fragmentierung (es dauert viel länger bis eine Festplatte fragmentiert ist als unter FAT)
  • Erweiterte Attribute
  • Dateinamen bis 255 Zeichen
  • Dateigröße 16 TByte
  • Partitionsgröße 16 TByte
  • Weniger Overhead. Ein Cluster ist bei einer 1,2 GByte Platte nur 2 KByte groß, bei FAT sind es 32 KByte
  • Kleinste Partitionsgröße 50 MByte
    NTFS ist aber für Partitionen über 400 MByte besser geeignet. Bei kleineren Partitionen ist NTFS nicht zu empfehlen.

Ab Windows Vista kann das Betriebssystem selber nur noch auf einer NTFS-Partition installiert werden, FAT wird nicht mehr als Betriebssystempartition unterstützt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0116.htm


FAT in NTFS umwandeln

FAT/HPFS in NTFS umwandeln

Eine vorhandene FAT- oder HPFS-Partition kann jederzeit in eine NTFS-Partition umgewandelt werden.

Dafür stellt Windows das Utility CONVERT.EXE zur Verfügung.

Der Vorgang muss immer an der lokalen Arbeitsstation durchgeführt werden, eine Konvertierung über das Netz ist nicht möglich.

Aufruf/Parameter:

CONVERT Laufwerk: /FS:NTFS [/V] [/NAMETABLE:Dateiname]

Laufwerk | Gibt das Laufwerk an, dass in NTFS konvertiert werden soll. Das aktuelle Laufwerk kann nicht konvertiert werden
/FS:NTFS | Der Datenträger wird in NTFS konvertiert
/V | Ausführliche Anzeige von Infos während CONVERT arbeitet
Dateiname | Es wird eine Namensübersetzungstabelle erstellt

Info Die Konvertierung kann nicht wieder rückgängig gemacht werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0144.htm


Warnmeldung, wenn Festplatte voll

Standardmäßig gibt Windows eine Warnmeldung aus, wenn nur noch 10% der Festplattenkapazität frei sind. Ändern können Sie das in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ LanmanServer\ Parameters

Erstellen Sie hier einen neuen Wert "DiskSpaceThreshold" als Datentyp REG_DWORD. Geben Sie den Wert des freien Speichers in Prozent an, bei welchem Windows eine Warnmeldung ausgeben soll (0 bis 99 Prozent).

Siehe auch "Festplatten-Speicherplatzüberprüfung deaktivieren".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0063.htm


Mitsumi CD-ROM nachträglich installieren

Nachträgliche Installation:

-> "Hauptgruppe" -> "Windows NT-Setup" -> "Optionen" -> "SCSI-Adapter hinzufügen" -> "Mitsumi CD-ROM"

Warum Mitsumi CD-ROMs als SCSI-Adapter verwaltet werden, ist nicht nachvollziehbar, aber es funktioniert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0078.htm


Priorität der Druckaufträge festlegen

Wenn Sie einen Druckauftrag abschicken, wird dafür ein eigener Thread gestartet. Wenn Sie sehr große Druckaufträge versenden, kann das ihr System langsamer machen.

Über einen Eintrag in der Registry können Sie festlegen, mit welcher Priorität ein Druckauftrag bearbeitet werden soll

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print

Dort können Sie über den Wert "PortThreadPriority" als Datentyp REG_DWORD die Verarbeitungspriorität durch die folgenden drei Einträge festlegen:

0(Standard) | niedrige Priorität (THREAD_PRIORITY_ABOVE_Normal)
1 | mehr Priorität (THREAD_PRIORITY_ Normal)
0xFFFFFFFF | weniger Priorität (THREAD_PRIORITY_BELOW_Normal)

Hierbei handelt es sich um den Thread, der die ausgehenden Druckerdaten auf die Drucker verteilt.

Mit diesem Wert "SchedulerThreadPriority" als Datentyp REG_DWORD können Sie den Zeitplandienst konfigurieren und festlegen, wie viel Prozessorzeit für die einzelnen Threads vergeben wird.

0(Standard) | niedrige Priorität
1 | mehr Priorität
0xFFFFFFFF | weniger Priorität

Über den Wert "SpoolerPriority" als Datentyp REG_DWORD können Sie die Priorität für den Druckerspooler festlegen.

0(Standard) | niedrige Priorität (IDLE_PRIORITY_CLASS)
1 | Standard von Windows (Normal_PRIORITY_CLASS)
0xFFFFFFFF | hohe Priorität (HIGH_PRIORITY_CLASS)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0598.htm


Drucker Spooler Verzeichnis

Normalerweise richtet Windows ein Spoolerverzeichnis unter "%SYSTEMROOT%\System32\spool\printers" ein. Man kann es aber ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print\ Printers

finden Sie den Eintrag "DefaultSpoolDirectory" als Datentyp REG_SZ für den globalen Spoolpath.

Diesen Path können Sie aber auch im Druckerfenster über "Datei" -> "Server-Eigenschaften" -> "Optionen" unter "Warteschlangen-Ordner" verändert.

Unter diesem Registry Key gibt es jetzt für jeden angelegten Drucker einen weiteren Schlüssel, hier können Einstellungen für den jeweiligen Drucker vorgenommen werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0285.htm


Tonausgabe beim Druckerfehler deaktivieren

Standardmäßig gibt der Printserver ca. 10 Sekunden einen Beepton von sich, wenn bei einem Printjob ein Fehler auftritt. Sie können die Ausgabe eines Fehlertons in der Registry unterdrücken.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Print

Erstellen Sie hier einen neuen Wert mit dem Namen "BeepEnabled" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tonausgabe ausgeschaltet
0 | Ton wird ausgegeben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0957.htm


Print Info auf dem Server ausschalten

Eine Möglichkeit, um unter Windowsdie Anzeige der Servermeldungen zu unterdrücken ist, über "START" -> "Einstellungen" -> "Systemsteuerung" -> "Drucker" -> "Datei" -> "Server-Eigenschaften" ->.

Hier kann unter Optionen das letzte Häkchen (Benachrichtigen, wenn Remote-Aufträge gedruckt wurden) entfernt werden.

Bei Ab Windows 2000 finden Sie das unter: "Start" -> "Einstellungen" -> "Drucker" im Menü aus "Datei" > "Servereigenschaften" auswählen und unter "Erweiterte Optionen" das Häkchen bei "Benachrichtigen, wenn Remote-Aufträge gedruckt wurden" entfernen.

Die Einstellungen für das PopUp-Infofenster bei Remote-Print-Jobs können Sie auch über die Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print\ Providers

Erstellen Sie hier einen neuen Wert mit dem Namen "NetPopup" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es wird eine Nachricht ausgegeben
0 | Es wird keine Nachricht angezeigt (Standard)

Gibt an, ob eine Nachricht (PopUp-Fenster) bei Remote-Print-Jobs erscheinen soll.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Über die Einstellung "NetPopupToComputer" können Sie wie im Tipp "Konfigurieren wo Drucker-Benachrichtigungen angezeigt werden" beschrieben einstellen, wo die Meldungen angezeigt werden soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0203.htm


Ausgeschaltete Netzwerkdrucker

Wenn Sie im Netz freigegebene Netzwerkdrucker haben, werden diese nach dem Ausschalten noch eine Stunde im Netz als verfügbar angezeigt. Das liegt an einer Standard-Einstellung in der Registry. Diese können Sie aber anpassen:im

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print

Finden Sie den Eintrag "NetPrinterDecayPeriode" als Datentyp REG_DWORD, der den Wert "3600000" (1 Stund e) enthält. Diesen Wert können Sie nun durch einen anderen ersetzen, die Angabe erfolgt in Millisekunden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0038.htm


RPrinter für Novell Netze laden

Printer für Novell-Netze laden

Sie können Ihren lokalen Drucker anderen Novell-Benutzern anbieten.

Klicken Sie in der Systemsteuerung auf -> "Netzwerk" -> "Hinzufügen" -> "Dienst" -> "Hinzufügen" -> "Microsoft" und fügen "Datei- und Druckerfreigabe für NetWare- Netzwerke" hinzu.

Damit man den Windows 95-Rechner mit dem SLIST Befehl sehen kann, tragen Sie unter -> "Eigenschaften"

-> "SAP- Anzeige" [Aktiviert] ein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0284.htm


Printer Pooling

Das Printer Pooling funktionierte bis jetzt nicht so recht zufriedenstellend, mit dem neuen Service Pack 6 soll dieses Problem aber behoben sein.

Mit folgenden Registrykeys können Sie die Funktion konfigurieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print\ Providers

RestartJobOnPoolEnabled | REG_DWORD | 1 <- Schaltet die Funktionen ein
RestartJobOnPoolError | REG_DWORD | Zeit in sec. nachdem ein Job automatisch neu gestartet wird, wenn ein Fehler aufgetreten ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0568.htm


Printer Browsing deaktivieren

Ein installierter Drucker sendet seine Informationen an einem im Netzwerk vorhandenen Printserver und macht sich damit im Netzwerk bekannt. Wenn Sie das nicht wollen können Sie das in der Registry deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Print

erstellen Sie hier einen neuen Wert mit dem Namen "DisableServerThread" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0956.htm


Druckerprobleme von DOS-Programmen unter Windows

Fehler:

Der Ausdruck von einseitigen Formularen beginnt erst nach ca 30 Sekunden, bei mehrseitigen Formularen wird die letzte Seite erst nach ca 30 Sek. ausgedruckt.

Lösung:

Setzen Sie in der Registry folgenden Wert:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ WOW

und setzen Sie dort den Eintrag "LPT_timeout" als Datentyp REG_SZ auf den Wert "1"

Der Wert gibt die Zeit im Sekunden wieder und steht standardmäßig auf 15.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0037.htm


Probleme mit SP5 und Drucken im Novell-Netzwerk

Seit der Installation von SP5 wird beim Drucken auf einem Netzwerkdrucker in einer "Novell Netzwerk Queue", obwohl die Funktion "Vorspann drucken" ausgeschaltet ist, immer ein Vorspann ausgedruckt

Das ist ein Bug von SP5. Ersetzen Sie einfach die Datei "NWPROVAU.DLL" durch die von SP4, damit ist der Fehler behoben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0610.htm


Einträge von Druckerinformationen nicht ins Eventlog eintragen

Wenn Sie diesen Tipp aktivieren, werden Einträge über den Druckerspooler nicht mehr ins Eventlog eingetragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Print\ Providers

Erstellen Sie hier einen neuen Wert mit dem Namen "EventLog" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Einträge unterbinden
1 | Kann ins Eventlog Eintragen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1600.htm


Konfigurieren wo Drucker-Benachrichtigungen angezeigt werden

Drucker-Benachrichtigungsangezeige konfigurieren

Mit diesem Tipp können Sie einstellen, wo die Benachrichtigungen für einen Druckjob angezeigt werden sollen. Sie können die Benachrichtigung auf dem Computer anzeigen lassen, von dem der Auftrag gedruckt wurde oder aber auf dem Rechner, wo sich der Anwender als erstes angemeldet hat.

Diese Einstellung können Sie über "Start" -> "Systemsteuerung" -> "Drucker und Faxgeräte" aus dem Menü "Datei" -> "Servereigenschaften" Tabreiter "Erweiterte Optionen" über die Einstellungen unter "Druckerbenachrichtigungen für Vorgängerversions-Clients" mit dem Eintrag "Computer benachrichtigen, wenn Remoteaufträge gedruckt wurden". Wenn Sie diesen Eintrag aktivieren, werden die Nachrichten an den Computer gesendet, auf dem Sich der Anwender als erstes angemeldet hat.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Print\ Providers

Erstellen Sie hier einen neuen Wert mit dem Namen "NetPopupToComputer" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Meldungen (PopUp) auf dem lokalen Computer anzeigen
1 | Meldungen auf dem Computer anzeigen, wo sich der Anwender als erstes angemeldet hat (Standard)

Info Damit überhaupt eine Meldung angezeigt wird, muss der Eintrag "NetPopup" wie im Tipp "Print Info auf dem Server ausschalten" beschrieben aktiviert werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2626.htm


Timeout 'Level Hook Timeout' für Programme die hängen

Mit diesem Wert legen Sie die Zeit in Millisekunden fest, die Windows wartet, bis es ein Programm beendet, das nicht mehr reagiert.

Wird die Zeit überschritten erkennt Windows das Programm als fehlerhaft und beendet es, innerhalb dieser Zeit hat das Programm selber die Möglichkeit eine Fehlermeldung auszugeben und sich zu beenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "LowLevelHooksTimeout" als Datentyp REG_DWORD. Geben Sie die Zeit in Millisekunden an die Windows warten soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1401.htm


Performance Statistiken

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_DYN_DATA\ PerfStats

Dieser Schlüssel enthält die Performance Statistiken, die auch der System-Monitor benutzt und die von ihm angezeigt werden. Interessant ist dabei eigentlich nur der Unterschlüssel "StatData". Für jeden Performance Parameter, den man im Systemmonitor beobachten kann, gibt es einen Eintrag mit einem 4-Byte Wert. Diese Byte-Werte kann man natürlich in Dezimal-Zahlen umrechnen. Dabei stehen die höherwertigen Bytes rechts, die niedrigen links.

Umrechnung:

Starten Sie den Windows Taschenrechner im wissenschaftlichen Layout. Basis Hex. Achten Sie darauf, dass die Werte von rechts nach links eingegeben werden müssen, also erst Byte 4, dann Byte 3, dann 2 und dann 1. Ändern Sie nun die Basis auf Dezimal. Fertig.

Beispiel:

VMM\cpgDiskcache: Das ist die aktuelle Größe des Datenträger Cache Speichers.

4 Byte Wert: 00 40 3f 00.

Eingeben in Taschenrechner: 3f 40 00 (führende Nullen natürlich nicht).

Dez: 4145152, nachschauen im System-Monitor, ja stimmt.

Es gibt auch Werte, die vom System-Monitor pro Sekunde aktualisiert werden, z.B. Seitenauslagerungen: VMM\cPageOuts oder Dateisystem: Gelesene Bytes/Sec.

Um diese Werte zu interpretieren, muss man einen Blick in:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ PerfStats

werfen.

Unter...\Enum\ Vmm\ cPageOuts findet man die Eintragung: Differentiate "TRUE". Es ist ein schlichter Zähler, der beim Windows Start auf Null gesetzt und von da an immer hochgezählt wird. Deshalb braucht man auch kein Programm, um die Anzahl an Seitenfehlern zu messen (außer, dass der Zähler überlaufen sollte, was bei einem 4 Byte Wert erst bei 4096 MB passiert, so dass man es nur mit Bytes Read\Write verursachen kann). Um also die Anzahl an Seitenfehlern zu messen, schaut man einfach zweimal in die Registry und subtrahiert die Werte voneinander.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0267.htm


Verhalten des NTFS und FAT Dateisystems (Performance)

Unter diesem Schlüssel können Sie einstellen, wie Windows mit dem Dateisystem umgehen soll. Mit einigen Einstellungen kann man die Geschwindigkeit von Windows etwas verbessern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

Schlüssel

Datentyp

Angabe als

Standard

Hiermit kann man einstellen, dass Windows darauf verzichtet, für lange NTFS-Dateinamen eine Kurzform zu generieren. Alte Programme (DOS und Windows) sehen solche Dateien nicht. Vorteile wirken sich dann aus, wenn ein Verzeichnis eine Unzahl von Dateien mit ähnlichen Namen enthält. Wenn der Wert auf 0 steht, werden kurze Dateinamen erzeugt, was aber zu Lasten der Auslastung geht. Die Umstellung hat auf bestehende Daten keinen Einfluss.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=121007

NtfsDisable8dot3NameCreation

REG_DWORD

Boolean

0

Legt fest, ob Sonderzeichen wie Umlaute usw. in kurzen Dateinamen erlaubt sind oder nicht. Durch 0 wird es auf den Standard ASCII Zeichensatz beschränkt.

NtfsAllowExtendedCharacterIn8dot3Name

REG_DWORD

Boolean

0

Wenn man sich unter Windows ein Verzeichnis auf einem NTFS-Laufwerk anzeigen lässt (DIR, Explorer, Command usw.), wird von Windows das LastAccess (Time-Stamp) für das Verzeichnis upgedatet. Das kostet bei großen Verzeichnissen einiges an Zeit und Performance. Mit diesen Key, kann man dieses Verhalten ausschalten, in dem Sie den Wert auf 1 setzen.

NtfsDisableLastAccessUpdate

REG_DWORD

Boolean

0

Legt fest, ob FAT das Anlegen, Numerieren, Öffnen oder Suchen nach langen Dateinamen erlaubt und ob zusätzliche Zeitmarken (CreationTime und LastAccessTime) gespeichert werden. Ist dieser Wert auf 1 gesetzt, werden keine langen Dateinamen erzeugt. Die Umstellung hat auf bestehende Daten keinen Einfluss.

Win31FileSystem

REG_DWORD

Boolean

0

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0431.htm


Beschleunigung / Einstellungen von TCP/IP Netzwerken

Mit einigen Parametern aus der Registry können Sie die Geschwindigkeit und Netzwerklast Ihrer Netzwerkverbindungen verbessern bzw. das Verhalten bei schlechten Verbindungen einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Dieser Wert gibt an, wie viel Bytes empfangen werden können, bevor eine Bestätigung zurückgesendet wird. Größere Werte verbessern bei umfangreichen Verzögerungen und Netzwerken mit großer Bandbreite die Leistung. Das beste Ergebnis liefert ein Wert mit einer Größe, die ein Mehrfaches der MTU des anderen Netzes enthält. Werden oft Timeouts ausgelöst, kann es sinnvoll sein einen kleineren Wert einzustellen, um mehrfaches Senden zu vermeiden.
TcpWindowSize | REG_DWORD | 8192 bis 0xFFFF Bytes | Die TCP-Paketgröße auf dem Netzwerk einmal 4. Daraus ergibt sich durch Aufrundung Ethernet-Netzwerken ein Wert von 8760
Steuert den erneuten Versuch von Übertragungen. Dieser Wert steuert die Zahl der Versuche, eine Verbindung aufzumachen.
TcpMaxConnectRetransmissions | REG_DWORD | 0 bis 0xFFFFFFFF | 3
Steuert den erneuten Versuch von Übertragungen. Dieser Wert steuert die Zahl der Versuche, Daten erneut zu übertragen
TcpMaxDataRetransmissions | REG_DWORD | 0 bis 0xFFFFFFFF | 5
Gibt an, wie viele Endpunkte bei einer TCP-Verbindung max. gleichzeitig geöffnet werden dürfen
TcpNumConnections | REG_DWORD | 0 bis 0xFFFFFFFE | 0xFFFFFE
Legt fest, wie lange die Verbindung nach dem Schließen im Zustand TIME_WAIT (2MSL) bleiben darf.
TcpTimedWaitDelay | REG_DWORD | 0x1E bis 0x12C (Dezimal 30 bis 300) Sekunden | 0xF0 (Dezimal 240)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base
http://support.microsoft.com/?kbid=140552
http://support.microsoft.com/?kbid=120642

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0405.htm


Runterfahren des System beschleunigen

Herunterfahren des System beschleunigen

Beim Herunterfahren des Systems werden alle gestarteten Dienste beendet. Wenn sich einige Dienste nicht selbständig beenden, werden sie nach einer Zeit von 20000 (20 Sekunden) beendet.

Wenn Sie den Wert heruntersetzen (ein Wert kleiner als 2000 ist auf keinen Fall anzuraten), werden solche Dienste eher beendet. Eine Verkürzung der Zeit kann das Herunterfahren also beschleunigen, aber auch zu Problemen bis hin zu Datenverlusten führen. Ein Ändern dieses Wertes ist kaum zu empfehlen und sollte nur nach einem ausführlichen Test und Absichern aller Daten durchgeführt werden.

Achtung: Ist der Tipp "ClearPageFileAtShutdown" aktiviert, darf dieser Wert auf keinen Fall kleiner als 20000 sein!

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control

Erstellen Sie hier einen neuen Wert mit dem Namen "WaitToKillServiceTimeout" als Datentyp REG_SZ und geben Sie einen Wert zwischen 2000 und 20000 in Millisekunden an.

Info Weitere Infos zu diesen Tema finden Sie noch unter: "Anwendung ohne Nachfrage schließen"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1715.htm


Soundkarte unter NT

Soundblaster-kompatible Soundkarten müssen meistens mit einem DOS -Treiber umgeschaltet werden. Da dies unter NT nicht möglich ist, kann man, wenn kein NT-Treiber verfügbar ist, folgenden Trick anwenden:

Man benötigt ein Dualboot mit DOS und NT.

Als erstes startet man DOS , wo in der Startdatei nur der Treiber zum Umschalten der Karte aufgerufen wird. Mit einem kleinen Programm (REBOOT.COM), das einen Rechner-Neustart ausführt, kommt man wieder ins NT-Bootmenü und kann das Starten von NT fortsetzen.

Ihnen fehlt das Programm REBOOT.COM? Kein Problem: Erzeugen Sie die Datei REBOOT.DBG mit dem unten angegebenen Inhalt. Rufen Sie dann auf der Kommandozeile den windowseigenen Assembler DEBUG auf: "DEBUG < REBOOT.DBG".

Inhalt von REBOOT.DBG

n reboot.com

a 100

CLI

JMP F000:FFF0

rcx

6

w

q

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0223.htm


Hotfixpacks bei der Installation des Servicepacks automatisch mit installieren

Wenn Sie das Servicepack auf einem Rechner installieren, müssen Sie evtl. benötigte Hotfixpacks von Hand nachträglich neu installieren. Das kann bei vielen Rechnern dazu führen, dass einige Hot-Fix-Packs vergessen werden.

Sie können aber auch bei der Installation des Servicepacks automatisch die Hot-Fix-Packs mit installieren.

Gehen Sie dazu folgendermaßen vor:

  1. Entpacken Sie das aktuelle Servicepack in ein beliebiges Verzeichnis ([Servicepack] /X)
  2. Erstellen Sie in diesem Verzeichnis ein weiteres Unterverzeichnis mit dem Namen "Hotfix"
  3. Entpacken Sie das Hot-Fix-Pack in dieses Verzeichnis

Beim Aufruf der Datei Update.exe vom Servicepack überprüft das Servicepack, ob ein Verzeichnis "Hotfix" vorhanden ist. In diesem Verzeichnis sucht es nach den Dateien "Hotfix.exe" und "Hotfix.inf". Sind diese vorhanden, werden Sie gefragt, ob Sie die Hot-Fix-Packs auch installieren möchten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0549.htm


Welche Hot Fix Packs sind schon installiert?

Windows zeigt zwar beim Booten und in der Systeminformation an, welches Service Pack auf diesen Rechner installiert ist, wenn Sie aber wissen wollen welche Hot Fix Packs auf diesen Rechner schon eingespielt wurden, finden Sie dort keine Informationen. Diese Information finden Sie nur in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Hotfix

hier sind alle Informationen über die installierten Hot Fix Packs aufgelistet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0783.htm


Woher bekomme ich Hot Fix Packs?

MS macht für Hot-Fix Packs wenig Werbung. Wenn Sie Hot-Fix Packs suchen müssen Sie meist selber auf den MS FTP-Server nachsehen. Auch bei den Hot-Fix Packs ist es wie mit den Service Packs, es sind immer erst die USA-Version und dann erst die Deutschen-Versionen zu bekommen.

Einen guten Dienst um Hot-Fix Packs zu finden ist aber nicht die MS Seite. Auf der Seite http://www.ntbugtraq.comfindet man einen übersichtlich und gut aufgebauten Suchserver. Hier wird Ihnen nach Angabe der NT-Version und einigen anderen Fragen eine übersichtliche Liste aller Hot-Fix Packs erstellt, die zur Zeit bei MS zur Verfügung stehen. Sie können die Dateien dann auch gleich von dort herunterladen.

Die MS FTP Seiten

HotFix Pack für SP1

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp1

HotFix Pack für SP2

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/hotfixes-postsp2

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp2

HotFix Pack für Service Pack 3

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/hotfixes-postsp3

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp3

HotFix Pack für Service Pack 4

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/hotfixes-postsp4

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp4

HotFix Pack für Service Pack 5

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/hotfixes-postsp5

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp5

HotFix Pack für Service Pack 6

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/hotfixes-postsp6

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp6

HotFix Pack für Service Pack 6a

NT 4.0

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/hotfixes-postsp6a

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0663.htm


Fehlercodes und was sich dahinter verbirgt

Wenn Sie als Fehlercode einen Zahlenwert von Windows erhalten, können Sie sich diesen in eine handfeste Fehlermeldung umwandeln lassen.

Geben Sie in der Eingabeaufforderung (CMD.EXE) folgendes ein:

NET HELPMSG 1797

wobei 1797 der Fehlercode ist.

Problem Behandlung bei "STOP" Fehlermeldungen (Links in Microsoft Knowledge Base) finden Sie unter: http://www.jasik.de/shutdown/stop_fehler.htm

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0390.htm


Warnmeldungen versenden

Einige Warnmeldungen können Sie an einen bestimmten Rechner oder Anwender versenden lassen. Leider hat MS nicht viele Möglichkeiten für das Versenden vorgesehen.

Wenn ein Rechner Warnmeldungen versenden soll, müssen Sie das über den Server-Manager konfigurieren.

Starten Sie dafür den Server-Manager und wählen Sie den entsprechenden Server oder die Workstation aus. Gehen Sie nun über das Menü "Computer" -> "Eigenschaften" -> "Warnungen". Hier können Sie User- und Computernamen eintragen.

Die Einträge finden Sie auf den jeweiligen Computer in der Registry unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Alerter\ Parameters

unter dem Wert "AlertNames" als Datentyp REG_MULTI_SZ. Hier können Sie auch direkt die Computer oder Usernamen Eintragen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0836.htm


Absturzverhalten von Windows einstellen

Bei einem Systemabsturz können Sie zum Zwecke der Fehleranalyse Windows anweisen, den Speicherinhalt in eine Datei zu schreiben. Diese Option ist eigentlich nur für erfahrene Leute und Programmierer interessant, die mit Hilfe dieser Informationen den Fehler finden können. Die Fehlercodes der Dump-Datei finden Sie unter: "Fehlercodes der Dump-Datei"

Die Grundeinstellungen dafür können Sie an der folgenden Stelle verändern:

für Windows NT 4.x:

"Systemsteuerung" -> "System" unter "Starten/Herunterfahren" die Option "Debug-Info festhalten" aktivieren.

für Windows 2000/XP/2003:

"Systemsteuerung" -> "System" -> "Erweitert" -> "Starten und Wiederherstellen..."

ab Windows Vista:

"Systemsteuerung" -> "System" -> "Erweiterte Systemeinstellungen" -> Tabreiter "Erweitert" -> Button "Einstellungen..." unter "Starten und Wiederherstellen"

hier können Sie unter "Debuginformationen speichern" folgenden Einstellungen vornehmen:

keine | Es wird kein Speicherabbild erstellt (wenn Sie sich mit dem Auswerten nicht auskennen, ist das die beste Einstellung, da dann auch kein Festplattenplatz für die Daten verschwendet wird).
kleines Speicherabbild (xxMB) | Hier werden nur die nötigsten Informationen abgelegt, um den Fehler analysieren zu können.
Kernelspeicherabbild | Speichert nur die Kernelspeicherdaten ab.
Vollständiges Speicherabbild | Erstellt ein vollständiges Speicherabbild. Dafür muss die Auslagerungsdatei mindestens die Größe des Arbeitsspeichers + 1 MB besitzen. Der Pfad und der Name für die Datei kann unter "Sicherungsdatei" verändert werden. Standardmäßig steht er auf "%SYSTEMROOT%\MEMORY.DMP". Die max. Größe der Datei liegt bei 2 GByte.

Wie kann ich mir diese Dateien ansehen?

Das "kleine Speicherabbild" können Sie mit dem Programm "Dumpchk.exe" bearbeiten. Bei Windows 2000 müssen Sie von der CD unter "\Support\Tools\" die "Support Tools" installieren, damit die Programme auch zur Verfügung stehen. Bei Windows NT 4.0 finden Sie die Tools auf der CD unter "\Support\Debug\i386\".

Für das "Kernelspeicherabbild" und "Vollständiges Speicherabbild" benutzen Sie das Programm "KB.exe", welches Sie unter http://www.microsoft.com/ddk/installW2k.htmherunterladen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ CrashControl

finden Sie folgende Einstellmöglichkeiten:

Schlüssel | Datentyp | Angabe als | Standard
Festlegen, ob nach einem Fehler NT neu gestartet werden soll
AutoReboot | REG_DWORD | Boolean | WS = 0 Server = 1
Legt fest, ob Fehlerinformationen in eine Datei geschrieben werden sollen
CrashDumpEnabled | REG_DWORD | Boolean | NT 4.x: WS = 0 Server = 1 Ab Windows 2000 sind folgende Werte möglich: 0 = None 1 = Complete memory dump 2 = Kernel memory dump 3 = Seinmall memory dump (KB) Standard: WS = 3 Server = 1
Gibt den Ort und die Datei an, in die der Fehlerdump geschrieben werden soll
DumpFile | REG_EXPAND_SZ | Pfad | NT 4.x: "%SYSTEMROOT%\MEMORY.LOG" Windows 2000: "%SYSTEMROOT%\Memory.dmp"
Gibt an, ob Systemereignisse in eine Protokolldatei geschrieben werden sollen
LogEvent | REG_DWORD | Boolean | WS = 0 Server = 1 (siehe auch: Logfile Einstellungen)
Legt fest, ob die Protokolldatei überschrieben werden soll
Overwrite | REG_DWORD | Boolean | WS = 0 Server = 1 (siehe auch: Logfile Einstellungen)
Legt fest, ob eine Administratormeldung ausgegeben werden soll
SendAlert | REG_DWORD | Boolean | WS = 0 Server = 1
Gibt den Ort und die Datei an, in die der Minimale Fehlerdump geschrieben werden soll (ab Windows 2000)
MinidumpDir | REG_EXPAND_SZ | Pfad | "%SYSTEMROOT%\Minidump"

Info Ist "LogEvent" eingeschaltet und "Overwrite" ausgeschaltet, wird bei einer vorhandenen Protokolldatei die Meldung "Die Protokolldatei ist vollgeschrieben" ausgegeben und alle weiteren Fehler werden nicht mehr beachtet (siehe auch: Logfile Einstellungen).

Info Weitere Informationen finden Sie dazu Unter:
http://www.microsoft.com/ddk/ddkdocs/Win2KDB/
http://support.microsoft.com/?kbid=244139

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0392.htm


Logfile Einstellungen

Unter Windows können Sie eine Log-Datei erstellen lassen, in der alle Ereignisse protokolliert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ CrashControl

können Sie einstellen, ob eine Log-Datei angelegt werden soll:

Schlüssel | Datentyp | Angabe als | Standard
Festlegen, ob nach einem Fehler Windows neu gestartet werden soll
AutoReboot | REG_DWORD | Boolean | WS = 0 Server = 1
Legt fest, ob Fehlerinformationen in eine Datei geschrieben werden sollen
CrashDumpEnabled | REG_DWORD | Boolean | WS = 0 Server = 1
Gibt den Ort und die Datei an, in die der Fehlerdump geschrieben werden soll
DumpFile | REG_EXPAND_SZ | Pfad | "%SYSTEMROOT%\MEMORY.LOG"
Gibt an, ob Systemereignisse in eine Protokolldatei geschrieben werden sollen
LogEvent | REG_DWORD | Boolean | WS = 0 Server = 1
Legt fest, ob die Protokolldatei überschrieben werden soll
Overwrite | REG_DWORD | Boolean | WS = 0 Server = 1
Legt fest, ob eine Administratormeldung ausgegeben werden soll
SendAlert | REG_DWORD | Boolean | WS = 0 Server = 1

Info Wenn "LogEvent" aktiviert ist und keine neue Datei erstellt werden kann, wird beim Versuch, das Logfile zu schreiben, eine Fehlermeldung ausgegeben und die Ereignisse werden nicht mehr protokolliert. Ein weiteres Arbeiten mit dem Rechner ist aber noch möglich.

Wollen Sie sicherstellen, dass der Rechner niemals ohne zu protokollieren arbeitet, suchen (ggf. Eintragen) Sie unter

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

die Zeichenfolge "CrashOnAuditFail" und weisen ihr als Wert "1" zu.

Wenn nun beim Erstellen der Log-Datei ein Fehler auftritt, beendet der Rechner die Arbeit und bleibt stehen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ EventLog

In den drei folgenden Schlüsseln:

\Application

\Security

\System

können Sie jeweils in der Zeichenfolge "File" als Datentyp REG_SZ den Pfad und Namen der Log-Datei angeben, die zum Speichern der Dateien verwendet werden soll.

Standardmäßig legt Windows die Datei im Verzeichnis "%SYSTEMROOT%\System32\Config" ab.

Weiterhin können Sie hier jeweils mit dem Eintrag "MaxSize" als Datentyp REG_DWORD die Protokollgröße der Ereignisanzeige ändern. Geben Sie hier die gewünschte Größe in Byte an. Der Standardwert liegt bei 512 KByte (Dezimal: 524288) .

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0393.htm


Fehlercodes der Dump-Datei

Wenn Windows abstürzt, haben Sie die Möglichkeit, sich eine Dump-Datei erzeugen zu lassen, wenn Sie unter Systemsteuerung -> System unter Starten/Herunterfahren die Option "Debug-Info festhalten" aktivieren (siehe auch: "Absturzverhalten von Windows einstellen").

Bei einem Absturz schreibt Windows nun alle Fehlercodes in die Defaultdatei "memory.dmp". Um damit aber auch etwas anfangen zu können, müssen Sie die Datei erst einmal mit Programmen von der Windows CD aus dem Verzeichnis \support\Debug\i386 bearbeiten.

dumpflop | Speicher die DUMP-Datei auf Diskette (nicht unbedingt nötig)
dumpchk | Überprüft die Datei auf Fehler
dumpexam | Zeigt die jeweiligen Fehlercodes an

Damit Sie mit den Fehlercodes etwas anfangen können, hier einmal die wichtigsten:

Fehlercode | Bedeutung
0x00000000 | Division durch 0
0x00000001 | Start des System Debuggers
0x00000003 | Stop Punkt für Debugger
0x00000004 | Überlauf des arithmetischen Operators
0x00000005 | Array hat Speichergrenze erreicht
0x00000006 | Ungültige Operanden
0x00000007 | Aufruf einer Funktion, die vom Coprozessor nicht unterstützt wird
0x00000008 | Auftreten eines Fehlers bei der Fehlerbearbeitung
0x0000000A | Programm mit Task-Status verursachte einen Fehler
0x0000000B | Anwendung versucht, auf ein nicht vorhandenes Speichersegment zuzugreifen
0x0000000C | Speicherzugriff, der außerhalb des erlaubten Bereiches lag
0x0000000D | Unbekannter Fehler

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0602.htm


Keine Fehlermeldungen anzeigen

Fehlermeldungen werden normalerweise als PopUp-Meldungen auf dem Bildschirm angezeigt und können bei Servern Manchmal störend wirken.

Sie können Sie aber mit dem Registry-Editor abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

die Zeichenfolge "ErrorMode" als Datentyp REG_DWORD und nehmen dort die gewünschte Einstellung vor.

Es sind folgende Werte möglich:

0 | Fehlermeldungen als PopUp Meldung anzeigen
1 | keine Systemfehlermeldungen mehr anzeigen. Anwendungen können aber Fehlermeldungen ausgeben
2 | keine Fehlermeldungen ausgeben.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0429.htm


IIS Logfile auf Fehler beschränken

Der Internet Information Server (IIS) schreibt normalerweise alle Zugriffe in ein Logfile. Das kann unter Umständen zu einem sehr großen Logfile führen. Wenn die erfolgreichen Zugriffe nicht benötigt werden (z.B. für Zugriffsauswertungen), können Sie die Protokollierung auf Fehler beschränken.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ W3SVC\ Parameters

Ändern Sie hier den Wert für "LogSuccessfulRequests" als Datentyp REG_DWORD auf 0.

Hier finden Sie auch noch den Eintrag "LogErrorRequests" als Datentyp REG_DWORD. Diesen Wert sollten Sie aber auf 1 belassen, da Sie sonst das Protokollieren von Fehlern ausschalten würden, was in den meisten Fällen nicht sinnvoll ist

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0535.htm


Start von Dr.Watson verhindern

Unter Windows wird standardmäßig das Programm Dr.Watson geladen und bei einen Fehler ausgeführt. Wenn Sie nicht wollen, dass Windows das Programm automatisch startet, können Sie das durch Löschen eines Registry-Schlüssels verhindern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ AeDebug

Wenn Sie diesen Schlüssel entfernen, wird Dr. Watson nicht mehr gestartet. Durch die Eingabe von DRWTSN32 -i können Sie das Programm von Hand starten.

Damit Sie den Eintrag wieder herstellen können, sollten Sie diesen Schlüssel vorher exportieren. Klicken Sie dafür in Regedit den Schlüssel an und wählen Sie aus dem Menü "Datei" -> "Exportieren". Mit dieser Datei können Sie den Eintrag jederzeit wieder herstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0560.htm


Protokollverzeichnis für Dr. Watson festlegen

Mit diesem Key können Sie den Pfad einstellen, wo „Dr. Watson“ seine Protokoll-Dateien ablegen soll, wenn ein Fehler auftritt.

Standardmäßig werden die Dateien unter „C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Dr Watson“ abgelegt.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "LogFilePath" als Datentyp REG_EXPAND_SZ. Geben Sie hier den Pfad zum Verzeichnis an.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1521.htm


Anzeigeverhalten von Dr. Watson anpassen

Kommt der Dr.Watson mit einer Fehlermeldung hoch, wird standardmäßig auch gleich der Debugger mit gestartet. Von den meisten wird der Debugger aber nicht benötigt, da dieser Debugger das System unnötig belastet, können Sie mit diesem Eintrag den Start unterdrücken.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ AeDebug

Erstellen Sie hier einen neuen Wert mit dem Namen "Auto" als Datentyp REG_SZ. Geben Sie folgenden Wert ein:

1 | Debugger ist aktiv (Standard)
0 | Nur Fehlermeldung ausgeben

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1522.htm


Symboltabellen nicht mit in den DUMP einbinden

Mit dieser Funktion legen Sie fest, ob Dr. Watson die Symboltabellen nicht mit in den DUMP mit einbinden soll. Diese Informationen werden meistens nicht benötigt und manchen das DUMP-File nur unnötig groß.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "DumpSymbols" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Symboltabellen sichern
0 | Symboltabellen nicht sichern

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1523.htm


Anzahl der Anweisungen

Legt die max. Anzahl der Anweisung fest, die von Dr. Watson nach der Ausführung eines Programm Counters für einen Thread disassembliert werden.

Ein Counter ist ein Register, in dem die Startposition des Threads abgelegt wird.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "Instructions" als Datentyp REG_DWORD. Geben Sie hier die Anzahl der Anweisung ein. Standardmäßig steht der Wert auf 10.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1524.htm


Alle Threads mit in das Dump einbinden

Wenn diese Funktion aktivieren, werden alle Threads in den Dump einer Applikation mit aufgenommen, die den Fehler verursacht haben.

Wenn Sie das ausschalten, wird nur der Thread aufgezeichnet, der den Fehler verursacht hat.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "DumpAllThreads" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Alle Threads
0 | Nur den "Verursacher" Thread

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1525.htm


Sound für Fehlermeldung festlegen

Wegen dieser Einstellungen können Sie den Sound festlegen, der von Dr. Watson beim Auftreten eines Fehlers abgespielt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "WaveFile" als Datentyp REG_EXPAND_SZ. Geben Sie als Wert den Pfad und den Dateinamen der WAV-Datei an, die bei einem Fehler abgespielt werden soll.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1526.htm


Bei Fehler eine Mitteilungsbox anzeigen

Wenn diese Funktion aktivieren, zeigt Dr. Watson beim Auftreten eines Fehlers ein Popup-Fenster an. Dieses Fenster wird 5 Minuten angezeigt und dann wieder automatisch geschlossen, Sie können das Fenster aber auch selber vor Ablauf der Zeit schließen.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "VisualNotification" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Mitteilungsbox anzeigen
0 | Keine Mitteilung anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1527.htm


Bei Fehler eine Soundmeldung ausgeben

Wenn diese Funktion aktivieren, gibt Dr. Watson beim Auftreten eines Fehlers eine Soundmeldung aus. Dabei kann eine Sounddatei (WAV) für den Ton festgelegt werden (siehe: Sound für Fehlermeldung festlegen)

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "Sound Notification" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Soundmeldung ausgeben
0 | Keine Soundmeldung ausgeben

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1528.htm


Dumpverzeichnis für Dr. Watson festlegen

Mit diesem Key können Sie den Pfad einstellen, wo "Dr. Watson" bei einem Programmabsturz die DUMP-Datei ablegen soll. Standardmäßig werden die Dateien unter "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Dr Watson\User.dmp" abgelegt.

Der angemeldete Anwender muss den Schreibzugriff auf das Verzeichnis haben, ansonsten geht eine Dialogbox auf, wo der Anwender nach einem neuen Pfad gefragt wird.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "CrashDumpFile" als Datentyp REG_EXPAND_SZ. Geben Sie hier den Pfad zum Verzeichnis und den Dateinamen der DUMP-Datei an.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1529.htm


Dump-Fileerstellung von Dr. Watson ausschalten

Standardmäßig wird von Dr. Watson ein DUMP-File erstellt, wenn eine Anwendung einen Fehler verursacht. Mit dieser Funktion können Sie das Erstellen eines DUMP-Files ausschalten.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "CreateCrashDump" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Dump-File erstellen
0 | Dump-File nicht erstellen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1530.htm


Verhalten bei der Protokolldatei von Dr. Watson

Mit dieser Einstellung legen Sie fest, ob Dr. Watson alle Informationen in eine Protokolldatei schreibt oder für jeden Fehler eine neue Protokolldatei erstellt.

Diese Einstellung können Sie auch mit dem Tool "%SYSTEMROOT%\System32\ drwtsn32.exe" verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

Erstellen Sie hier einen neuen Wert mit dem Namen "AppendToLogFile" als Datentyp REG_DWORD. Geben Sie folgenden Wert ein:

1 | Anhängen an die Protokolldatei
0 | Neue Protokolldatei erstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1531.htm


Debugger für Windows festlegen

Sie können über die folgende Einstellung Ihren eigenen Debugger festlegen. So können Sie z.B. für Dr. Watson den „Norton CrashGuard“ von der Firma Symantec verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ AeDebug

Erstellen Sie hier einen neuen Wert mit dem Namen "Debugger" als Datentyp REG_SZ. Geben Sie hier den Pfad und den Namen zum Programm ein welches Sie als neuen Debugger benutzen möchten.

Der Standard-Eintrag ist hier bis Windows 2003: Dr. Watson: drwtsn32 -p %ld -e %ld -g

Ab Windows Vista wird ein anderer Debugger benutzt!

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1532.htm


Fehler: Beim Einloggen will NT "SETUP.EXE" starten

Bei jedem Systemlogin schaut NT nach der Datei "SETUP.EXE" im %SYSTEMROOT%\SYSTEM32 Verzeichnis. Ist diese nicht vorhanden oder durch eine andere Datei ersetzt, kommt es zu einer Fehlermeldung. Ersetzen Sie in diesem Fall die Datei durch die SETUP.EXE Datei von der NT Original CD.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0624.htm


Setup-Dateien lassen sich nicht starten

Fehler:

Es können unter Windows NT keine Setup-Dateien mehr ausgeführt werden. Dieser Fehler tritt meist nach dem Installieren von HP-Scanner Treibern auf.

Lösung:

In Verzeichnis %SYSTEMROOT%\System32 gibt es die Datei CONFIG.NT. Am Ende dieser Datei finden Sie den Eintrag Files=20 und dahinter seltsame Leerzeichen. Wenn Sie diese Leerzeichen löschen, ist das Problem behoben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0720.htm


Absturz bei der Installation (blauer Bildschirm)

Kommt NT bei der Installation nicht über den ersten blauen Bildschirm hinaus, liegt es meist an SCSI-Treibern.

Ändern Sie in diesen Falle die Datei TXTSETUP.SIF. Kommentieren Sie dort unter [Scsi.load] alle Hostadapter-Treiber aus, die Sie nicht benötigen (Semikolon davor setzen). Versuchen Sie dann die Installation erneut.

Beim Versuch, NT auf gleichen Systemen zu installieren, gab es bei der Installation häufig einen blauen Bildschirm, wenn direkt von CD installiert wurde. Unterschiede zwischen den Systemen konnten nicht festgestellt werden. Dieser Fehler scheint im Zusammenhang mit der BIOS /CD-Rom Version zu stehen. In 90% der Fälle konnte man das Problem umgehen, wenn mit den drei Installationsdisketten und anschließend mit der CD gearbeitet wurde. Ohne Disks ging es nicht.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0389.htm


Setup bzw. Einrichten von Druckern nicht mehr möglich

Wenn Sie keine Drucker mehr installieren können bzw. beim Aufruf von Setup "Systemsteuerung" -> "Software" merkwürdige Fehlermeldungen erhalten, liegt das meist daran, dass ein Programm die "SetupApi.Dll" durch eine eigene Version ersetzt hat. Diese Version verfügt aber meist nicht über alle Funktionen wie die Original-DLL von NT. Um wieder die Original-DLL benutzen zu können, gehen Sie so vor:

  1. Öffnen Sie ein DOS -Fenster
  2. Geben Sie folgende Befehle ein:
    rename %SYSTEMROOT%\System32\Setupapi.dll Setupapi.xxx
  3. Entpacken Sie nun von der NT-CD die alte Version
    expand [Laufwerk]:\i386\setupapi.dl_ %SYSTEMROOT%\System32\Setupapi.dll

Jetzt funktionieren alle Setup-Programme wieder ohne Fehler und auch Drucker lassen sich wieder einrichten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0394.htm


Bei der Installation wird die Datei CDROM.SYS nicht kopiert

Wenn Sie die Installation von NT von DOS aus starten, dürfen Sie Ihr CD-ROM Laufwerk nicht mit dem Namen CDROM einbinden. Denn dann kann bei einer Installation von Windows NT die Datei CDROM.SYS nicht kopiert werden und die Installation schlägt fehl.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0704.htm


Fehlermeldung: NT Setup kann Boot-Ladeprogramm nicht installieren

Fehlermeldung "NT Setup kann Boot-Ladeprogramm nicht installieren"

Erscheint beim Setup von Windows NT die Fehlermeldung "Windows NT-Setup kann Boot-Ladeprogramm nicht installieren", kann Windows nicht auf das Laufwerk C:\ zugreifen.

Das kann daran liegen, dass Ihr Laufwerk C:\ noch nicht formatiert ist oder einen Defekt aufweist.

Seit neuestem kann es aber auch daran liegen, dass Sie auf Ihrem System Windows 95/98 installiert haben und das Laufwerk C:\ mit FAT32 formatiert wurde.

Windows NT kann mit FAT32 nichts anfangen und deshalb nicht auf diese Partition zugreifen.

Um Windows NT installieren zu können, müssen Sie entweder die Partition mit einem Bootmanager ausblenden oder das Laufwerk C wieder mit FAT16 formatieren. Mit extra Programmen wie Partition Magic können Sie eine FAT32 Partition ohne Datenverlust in FAT16 umwandeln.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0538.htm


Fehlermeldung: "Zugriff verweigert" beim Update auf NT 4.0 Enterprise Version

Wenn Sie unter NT die Datei WINNTUP.EXE von der Windows NT 4.0 Enterprise Edition ausführen, kann es zu folgender Fehlermeldung kommen:

"Access Is Denied" (Zugriff verweigert)

Das liegt daran, dass die Datei MSVBM50.DLL im Verzeichnis %SYSTEMROOT%\System32 das Attribut "Read Only" hat. Entfernen Sie das Read Only und starten Sie das Update noch einmal.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0909.htm


Fehler beim Öffnen von Dateien über 100 MB

Wenn Sie wiederholt Dateien über 100 MB öffnen, kann es zu folgenden Fehlermeldungen kommen:

Ungenügender Arbeitsspeicher

bzw.

Invalid Handle

Dieser Fehler liegt an der Auslagerungsdatei und ist ab Service Pack 4 behoben. Sie müssen aber noch folgenden Registry Key verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

hier bearbeiten Sie den Wert "DisablePagedPoolHint" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1 (gegebenenfalls müssen Sie den Schlüssel erst anlegen).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0573.htm


CDFS Dateisystem für CD-ROMs wird nicht gestartet

Wird ein CD-ROM Laufwerk unter NT nachträglich installiert, kann es beim Zugriff auf das Laufwerk unter dem Explorer zu folgender Fehlermeldung kommen "[Laufwerk]:\is not accessible"

Dieses wird durch einen fehlerhaften Eintrag in der Registry hervorgerufen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdrom\ 0000.

Speichern Sie diesen Schlüssel über "Registrierung" -> "Schlüssel speichern.." unter einem beliebigen Namen ab.

Gehen Sie nun zum Schlüssel:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdfs\ 0000.

Über das Menü "Registrierung" -> "Wiederherstellen" laden Sie den gesicherten Schlüssel unter diesen Zweig.

Ändern Sie außerdem noch die Rechte unter "Sicherheit" -> "Berechtigungen". Geben Sie der Gruppe "Jeder" bzw. "Everyone" auf diesen Zweig "Full Control".

Jetzt sollten Sie unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdfs\ 0000" die Schlüssel aus "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdrom\ 0000" sehen.

Ändern Sie nun folgende Einträge unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdfs\ 0000" ab:

"DeviceDesc" als Datentyp REG_SZ von "Cdrom Device" nach "Cdfs Device"

und

"Service" als Datentyp REG_SZ von "Cdrom" nach "Cdfs"

Beenden Sie den Registry-Editor und starten Ihr System neu. Nun sollte das CDROM-Laufwerk funktionieren.

Wenn Sie nicht wollen, dass unberechtigte Anwender die Schlüssel verändern, sollten Sie die Berechtigungen von "Everyone" unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ Root\ Legacy_Cdfs\ 0000" wieder auf "Lesen" setzen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0580.htm


Fehlermeldung: "The drive is not ready for use Device/Harddisk0/partition0..."

Wenn Sie beim Start von NT folgende Fehlermeldung erhalten:

The drive is not ready for use Device/Harddisk0/partition0. Its door may be open. Please check drive and make sure that a disk is inserted and that the drive door is closed.

haben Sie nach der Installation der Norton Utilities ein ZIP-Drive installiert. Um diesen Fehler zu beheben, müssen Sie die Norton Utilities deinstallieren und danach mit dem angeschlossenem ZIP-Drive neu installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0641.htm


Fehlermeldung beim Zugriff auf das Diskettenlaufwerk

Wenn Sie mit DOS-Anwendungen arbeiten, kann es vorkommen, dass beim Zugriff auf ein Diskettenlaufwerk die Fehlermeldung "Laufwerk nicht bereit" erscheint. Wenn Sie aber die Anwendung beenden und die Diskette über den Explorer öffnen, funktioniert alles einwandfrei.

Dieser Fehler tritt auf, wenn über ein DOS -Fenster und über die grafische Benutzeroberfläche (z.B. Explorer) von NT gleichzeitig auf das Diskettenlaufwerk zugegriffen wird. NT unterstützt nämlich nur den gleichzeitigen Zugriff von der grafischen Benutzeroberfläche aus. In diesem Fall müssen Sie alle Anwendungen unter NT schließen, die auf das Diskettenlaufwerk zugreifen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0387.htm


Fehlermeldung bei Parallel Port-ZIP-Laufwerk

Wenn ZIP-Laufwerke am Parallelport installiert sind, gibt es immer eine Fehlermeldung, wenn das Laufwerk nicht angeschlossen ist.

Dies kann mit der folgenden Änderung in der Registry abgestellt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ppa3nt

dort den Wert "ErrorControl" von Standard "1" auf "0" ändern.

Info Siehe auch: "Reaktion bei Fehler (ErrorControl)"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0384.htm


Durch falschen Festplattentreiber beschädigtes System retten

Im hektischen Alltagsgeschäft kann es auch dem versiertesten Admin einmal passieren, dass er versehentlich z.B. einen Busmaster-Treiber für Via auf einem Rechner mit Intel-Chipsatz (oder umgekehrt) installiert. Der Neustart endet mit einem Bluescreen: "Inaccessible Boot Device" und der Admin hat ein Problem.

Da man ja nun keinerlei Eingriffsmöglichkeiten mehr hat, kann man eigentlich nur noch ein ganz neues Windows installieren. Schneller geht es aber, wenn man die Treiberdatei des falschen Busmaster-Treibers durch die eines funktionierenden Treibers ersetzt z.B. so:

  1. Booten von der Windows 2000 CD und die R-Console starten, oder von SysInternal den ERD-Commander benutzen, um auf eine NTFS-Partition zugreifen zu können.
  2. In das Windows-System Verzeichnis wechseln
  3. Den Treiber viadsk.sys durch atapi.sys ersetzen

Danach sollte Windows wieder starten.

(Dank an Rainer Liese)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1240.htm


Die Ereignisanzeige

In der Ereignisanzeige werden vom System und Anwendungen Informationen abgelegt, mit deren Hilfe sich Fehler leichter aufspüren lassen. Ggf. lassen sich auch Aktionen auf gewisse Ereignisse auslösen.

Die Ereignisanzeige rufen Sie bei NT über eventvwr.exe und ab Windows 2000 über die MMC auf (eventvwr.msc).

Je nach installieren Anwendungen finden Sie in der Ereignisanzeige folgende Abschnitte:

Anwendungen | Hier werden die Informationen von Anwendungen protokolliert.
Sicherheit | Hier landen alle Informationen, die etwas mit der Sicherheit zu tun haben. Für die meisten Einträge muss vorher die Sicherheitsprotokollierung aktiviert werden.
System | Alle Informationen, die das System betreffen, werden hier abgelegt.
Directory Service | Hier werden die Informationen vom ADS abgelegt. Dabei kann hier gut der Status der Replikation überprüft werden.
DNS Server | Hier werden die Informationen vom DNS-Server abgelegt.
Dateireplikationsdienst | Hier kann man Informationen über Probleme des Replikationsdienstes finden.

Diese Liste kann von entsprechenden Anwendungen/Diensten erweitert werden. Für jeden Eintrag kann über die rechte Maustaste ein Kontextmenü aufgerufen werden ("rechte Maustaste" -> "Eigenschaften").

Auf der ersten Seite sehen Sie unter "Protokollname" den Speicherort und den Namen der Datei, Sie können hier die Datei jederzeit an einen anderen Speicherort Ort verlegen.

Weiterhin können Sie unter Protokollgröße die max. Größe der Datei festlegen und konfigurieren, wie das System verfahren soll, wenn diese Größe erreicht wird.

Besondere Beachtung muss dabei auf die Einstellungen "Ereignisse überschreiben, die älter als xx Tage sind" und "Ereignisse nie überschreiben" gelegt werden.

Ist nämlich die max. Größe erreicht und das System kann nichts mehr in die Logdatei schreiben (Protokoll ist voll gelaufen), hält das System an. Hier muss man die Protokollgröße regelmäßig überprüfen.

Wo werden die Dateien abgelegt?

Standardmäßig werden die Dateien unter "%SYSTEMROOT%\system32\config" abgelegt. Der aktuelle Speicherort kann unter Eigenschaften (siehe oben) oder auch in der Registry geändert werden:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Eventlog

Hier finden Sie für jedes Protokoll einen weiteren Schlüssel. Innerhalb dieses Schlüssels finden Sie den Wert "File", wo der Pfad zur Protokolldatei festgelegt wird.

Wo finde ich Informationen zu den Event-IDs?

Im Internet gib es 2 wichtige Adressen, wo Sie weitere Informationen zu den Ereigniseinträgen finden.

Beschreibung und Links zu MS Artikeln für die IDs: http://www.eventid.NET/

Weiterhin finden Sie bei MS noch einige Informationen, hier können Sie auch eine Excel-Datei mit vielen Event-IDs herunterladen:

http://www.microsoft.com/windows2000/techinfo/reskit/ErrorandEventMessages/default.asp

Hier einmal eine kurze Auflistung einiger IDs und Ihrer Bedeutung:

Event-ID | Beschreibung
1001 | Enthält Informationen, wenn ein Memory-Dump erstellt wurde
1074 | Neu ab XP und .NET, enthält den Grund für den Systemabschluss (wird von User abgefragt und eingeben)
6005 | Kommt auch beim Systemstart und besagt, dass das Ereignisprotokoll gestartet wurde
6006 | Wird bei einem Systemabschluss geschrieben, wenn das Ereignisprotokoll beendet wurde
6008 | Wenn das System unerwartet gestartet wurde, wird hier anhand eines Zeitstempels der ungefähre Zeitpunkt des Absturzes eingetragen.
6009 | Kommt beim Systemstart und enthält unteren anderen Informationen über das Betriebssystem

Wie kann ich auf Event-IDs automatisch reagieren?

MS stellt dafür ein kostenpflichtiges Tool "Microsoft Operations Manager" (MOM) zur Verfügung. Mit diesem Tool können Sie Reaktionen auf Ereignisse konfigurieren. MS hat hierfür schon eine gewisse Anzahl an Filtern vorkonfiguriert. Weitere Informationen zum MOM finden Sie unter: http://www.microsoft.com/mom.

Es gibt aber auch kostenfreie Möglichkeiten:

Mit dem Tool "Eventquery.vbs" (ab .NET) wird Ihnen ein beispielsweise ein Visual Basic Script geliefert, mit welchen Sie Ereignisse abfragen können.

Weit mehr Möglichkeiten bietet das Tool "Eventtriggers.exe". Mit diesem Tool können Sie Trigger konfigurieren, die bei einem bestimmten Ereignis einen Befehl ausführen (EXE, Batch). Sie können mit dem Tool

  • Trigger erstellen (create)
  • Trigger wieder löschen (delete)
  • aktuelle Trigger anzeigen lassen (query).

Weiterhin gibt es noch das Tool "eventquery.pl" (im Resource Kit 2000 Supplement 1)

Mit diesem Perl-Script, können Sie Informationen aus der Ereignisprotokoll abfragen. Dafür muss aber Perl auf Ihrem System installiert sein. Weitere Informationen dazu finden Sie http://www.microsoft.com/mom

Wie kann ich eigene Ereignisse erzeugen?

Mit dem Tool "logevent.exe" aus dem Resource Kit können eigene Events im Anwendungsprotokoll erstellt werden.

Weiterhin gibt es ab .NET Server das Tool "eventcreate.exe". Sie haben auch hier die Möglichkeit, Ereignisse ins System- oder Anwendungsprotokoll zu schreiben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1644.htm


Zugriff auf die Ereignisanzeige beschränken

Normalerweise können sich alle Anwender der Ereignisanzeige anzeigen lassen. Da hier aber viele Programme Informationen ablegen, kann das ein Sicherheitsproblem darstellen. Sie können den Zugriff in der Systemsteuerung aber auf Administratoren und System-Accounts beschränken.

Legen Sie dazu folgenden Registrykey an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ EventLog

Erstellen Sie einen neuen Wert mit dem Namen "RestrictGuestAccess" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1. Der Standardwert ist 0 (alle können sich die Ereignisanzeige anzeigen lassen).

Ab jetzt können nur noch Administratoren auf die Ereignisanzeige zugreifen.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1111.htm


Fehlermeldung 'WinMgmt' bzw. 'WINSPOOL.DRV' in der Ereignisanzeige

Fehlermeldung "WinMgmt" bzw. "WINSPOOL.DRV" in der Ereignisanzeige

Haben Sie den Fehler "WMI-ADAP konnte folgende Leistungsbibliothek "oerfproc.dll" auf Grund eines unbekannten Fehlers innerhalb der Bibliothek nicht laden; 0x0" bzw. "Das Ereignisprotokoll meldet einen Fehler in der winspool.drv." in der Ereignisanzeige, führen Sie bitte folgenden Befehl aus, um den Fehler zu beseitigen:

winmgmt /clearadap

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1142.htm


Eintrag des Fehlers 'PERFDISK.DLL' oder 'PERFPROC.DLL' in der Ereignisanzeige

Eintrag des Fehlers "PERFDISK.DLL" oder "PERFPROC.DLL" in der Ereignisanzeige

Erscheint in der Ereignisanzeige die Fehlermeldung "WMI-ADAP konnte die Leistungsbibliothek "PerfDisk" auf Grunde iner Zeitüberschreitung in der Funktion "open" nicht verarbeiten" bzw. "WMI-ADAP konnte die folgende Leistungsbibliothek "perfproc.dll" auf Grund eines unbekannten Fehlers innerhalb der Bibliothek nicht laden; 0x0", müssen Sie Folgendes tun um, den Fehler zu beseitigen:

Starten Sie aus dem Windows 2000 Resource Kit das Programm "EXCTRLST.EXE" und markieren Sie hier die Zeile: "perfdisk.dll" bzw. "TCP/IP perfproc.dll" und entfernen die Markierung "Performance Counters Enabled".

Nach einem Neustart sollte dieser Fehler nicht mehr in der Ereignisanzeige auftauchen.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1141.htm


Kerberos Anmeldung ins Eventlog Eintragen

Um die Fehlersuche bei Problemen mit der Kerberos Anmeldung zu erleichtern, können Sie aktivieren, dass die Anmeldung mit genaueren Informationen ins Eventlog eingetragen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Lsa\ Kerberos\ Parameters

Erstellen Sie einen neuen Wert mit dem Namen "LogLevel" als Datentyp REG_DWORD. Setzen Sie diesen Wert auf 1.

Nach einem Neustart wird die Anmeldung jetzt in das Eventlog eingetragen, da diese Funktion die Anmeldezeit verlängert, sollten Sie nach der Fehlersuche diesen Eintrag wieder löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0906.htm


IRP-Stack-Size-Fehler in der Ereignisanzeige

Taucht in der Ereignisanzeige im Systemprotokoll der Fehler "Der Wert IRPStackSize" im Registrierungsschlüssel "LanmanServer\Parameters" des Servers als ungültig auf, so wurde der Wert ignoriert . Es liegt dann ein Fehler im Eintrag IRPStackSize vor.

Einige Programme überschreiben den Standardwert; dadurch kommt es zur oben genannten Fehlermeldung.

Um den Fehler zu beheben, müssen Sie wie im Tipp "Fehlermeldung: Nicht genügend Serverspeicher verfügbar" beschrieben vorgehen.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0827.htm


Wenn man sich über einen SFU Client mit Linux verbindet, erscheint eine Fehlermeldung

Wenn Sie eine Verbindung mit einen SFU (Service for Unix) Client Version 2.0 mit einen NFS Share auf einem Linux Server verbinden wollen, erscheint folgende Fehlermeldung: "svc: unknown version(3)"

Das liegt daran, dass Linux mit NFS Version 2.0 arbeitet, SFU aber die Verbindung mit NFS Version 3.0 durchführen will. Damit beim Verbindungsaufbau NFS Version 2.0 verwendet wird, müssen Sie folgenden Wert in der Registry setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Client for NFS\ CurrentVersion\ Default

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableV3" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0871.htm


Fehlermeldung: "Der Nachrichtendienst konnte nicht gestartet werden"

Sie müssen in der Netzwerkumgebung "NetBIOS " installiert haben, damit Sie den Nachrichtendienst benutzen können "Systemsteuerung" -> "Netzwerk" -> "Dienste" -> "Hinzufügen"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0746.htm


Fehler bei NETBIOS-Namen, die nur aus Zahlen bestehen

Unter Windows NT sollte man bei der Verwendung von NetBIOS keine rein numerischen Namen verwenden. Sollten Sie es trotzdem machen, kommt es bei der Verwendung von NetBIOS über TCP/IP zu Problemen.

Das liegt daran, dass TCP/IP den Namen dann für einen IP-Adresse hält und statt der richtigen IP-Adresse den Rechner über die falsche Adresse versucht anzusprechen, was natürlich nicht funktioniert.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0583.htm


Fehlermeldung: "Die angegeben Referenzen passen nicht zu einer bestehenden Referenzmenge"

Eigentlich müsste die Fehlermeldung so lauten: "Sie können Sich nicht gleichzeitig mit zwei unterschiedlichen USER-Konten an einem Server anmelden", damit man sich eher vorstellen kann, was NT eigentlich damit sagen will.

Diese Fehlermeldung bekommen Sie von NT angezeigt, wenn Sie Folgendes versucht haben:

Sie haben eine Netzwerkverbindung unter dem angemeldeten USER auf einem bestimmten Server. Nun versuchen Sie eine zweite Netzwerkverbindung auf diesen Server mit einer anderen USER-ID durchzuführen:

"NET USE X: \\test\C$ /USER:master\Administrator" ,

z.B. um kurzzeitig mit mehr Rechten etwas auf diesen Server durchzuführen.

So etwas dürfen Sie unter NT aber nur auf unterschiedlichen Server machen. NT kann keine zwei Verbindungen mit unterschiedlichen USER-ID auf dem selben Server gleichzeitig erstellen. Das resultiert daraus, dass NT die Anfragen an einen Server immer mit der ID des USERs durchführt. Würden nun zwei Verbindungen zum selben Server mit zwei unterschiedlichen USER-IDs bestehen, wüsste NT nicht, mit welcher SIDer nun die Berechtigungsanfrage auf den Server durchführen soll.

Wollen Sie also mit einer anderen ID auf den Server zugreifen, müssen Sie erst alle bestehenden Verbindungen der anderen USER-ID trennen.

Info Mit einem Trick geht es aber trotzdem "Verbindung zu einem Server mit zwei unterschiedlichen USER-ID"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0708.htm


Modem CRC-Fehler (COM-Port Einstellung)

Der Standard FIFO "16550"ist 32 Byte groß. Es können max. je 16 Byte für das Empfangen und Senden gepuffert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Serial

a) Datenempfang

Der Empfangspuffer des 16550 ist einstellbar auf Schwellwerte von 1, 4, 8 und 14. Die Zahlen geben an, bei welchem "Füllgrad" der Interrupt ausgelöst wird. Bei "1" wird bei jedem Zeichen ein Interrupt ausgelöst, dafür besteht aber noch eine Reserve von 15 Byte für weitere Empfangsbytes, die inzwischen eintreffen. Beim Schwellwert "14" ist die Reserve dagegen Minimal.

Also:

Der Wert "14" ist besonders gefährlich und erzeugt leicht Überlauf- bzw. CRC-Fehler!

Haben Sie viele CRC-Fehler, probieren Sie es einmal Mit diesem Wert 1, der Wert "8" ist als normaler Standard gar nicht so schlecht: wenige Interrupts, einiges an Reserve.

Name "RxFIFO" wählen und Dezimal den Wert 8 Eintragen. -> Empfangspuffer

b) Senden

Der Sendepuffer ist fest auf 16 eingestellt und kann gar nicht verändert werden. Der Vorteil besteht darin, dass die CPU "in einem Rutsch" kleine Datenpakete los wird, was die Sache beschleunigt. Was bei NT mit TxFIFO überhaupt gemeint ist, ist erst einmal völlig unklar.

Man sollte diese Wert auf 16 stehen lassen!

Name "TxFIFO" wählen und Dezimal den Wert 16 Eintragen. -> Sendepuffer

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0240.htm


Service Pack Installation

ServicePacks (SP) für NT sind kumulativ, d.h. in einem neu erschienenen Servicepack sind alle vorhergehenden Änderungen enthalten. Das bedeutet, dass Sie nur das aktuelle Service Pack installieren müssen. Dies allerdings immer, nachdem Sie eine neue Komponente vom NT- Originaldatenträger installiert haben. Wenn Sie z.B. den RAS-Service installieren, müssen Sie das mit Hilfe der original NT-CD durchführen. Nach der Installation ist deshalb eine Komplettinstallation des aktuellen Service Pack nötig.

Folgende Parameter können angegeben werden:

/U | Keine Rückfragen an den Benutzer (Unattended-Modus)
/N | Kein Deinstallationsverzeichnis anlegen
/Z | Kein Neustart des Rechners nach der Installation durchführen
/O | Überschreiben von OEM-Dateien ohne Nachfrage
/Q | Hintergrundmodus, keine Usereingaben
/F | Schließen von anderen Anwendung vor dem Neustart
/X | Service Pack Dateien entpacken

Vor der Installation eines Service Packs sollten Sie ein Backup Ihres Windows-System durchführen. Legen Sie sich auch eine aktuelle Rettungsdiskette an (NT: RDISK /S), um unter Umständen wieder das alte System herstellen zu können.

  1. Installieren Sie immer das SP, das sprachlich zu Ihrer Windows-Version passt.
  2. Installieren Sie das Service Pack erst, nachdem Sie die dazu gehörige READ.ME gelesen haben.
  3. Last but not Least: Installieren Sie ein Service Pack nur, wenn Fehler ihres System dadurch behoben werden.

Wenn ihr PC läuft, verzichten Sie auf die Installation. Nicht umsonst sagt die goldene Regel des Administrators: "Never change a running System".

Was, wenn das Service Pack ein Service Pack braucht?

Wenn es einmal schnell gehen muss, dann setzt MS sog. "Hotfixes" ein. Diese beheben punktuell Fehler, die oft die Systemsicherheit sichern sollen. Zu bekommen sind diese Hotfixes ebenfalls bei MS. Dabei gelten die selben Regeln wie bei den SPs auch.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0440.htm


Service Pack deinstallieren

Bei der Installation eines Service Packs können Sie auch ein Deinstallationsverzeichnis erstellen lassen, so dass Sie ohne Probleme das Service Pack wieder deinstallieren können.

Was aber, wenn Sie dieses Verzeichnis nicht erstellt haben? Wenn Sie versuchen, ein altes Service Pack zu installieren, wird das mit einer Fehlermeldung abgebrochen. Mit etwas Handarbeit geht es aber doch:

  1. Booten Sie von der Original Windows CD oder Diskette und benutzen Sie die R Option (defektes NT Wiederherstellen/Reparaturinstallation). Hierdurch werden wieder die alten Dateien hergestellt (bei den meisten CDs ist das Service Pack 1)
  2. Jetzt haben Sie zwar Service Pack 1 installiert, da bei der Reparaturinstallation das aber in der Registry nicht eingetragen wird, wird immer noch der alte Servicepackstand angezeigt. Damit Sie ein älteres Service Pack installieren können müssen Sie folgende Registry Keys ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\

ändern Sie CSDVersion auf "Service Pack 1"; unter

HKEY_LOCAL_MACHINE\ System\ ControlControlSet\ Control\ Windows

ändern Sie CSDVersion auf 1,

jetzt können Sie wieder jedes beliebige Service Pack installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0574.htm


Fehler bei SMS mit Service Pack 4

Wenn Sie den System Management Server Ver. 1.2 auf einem Windows NT Rechner mit Service Pack 4 benutzen wollen, können Sie die Helpdesk Funktion Remote auf einen Client zu verbinden, nicht mehr benutzen.

Der Grund ist eine fehlerhafte DLL des SMS, die durch die Installation des Service Pack 4 nicht ersetzt wird.

Um den Fehler zu beheben, müssen Sie nur die Datei "sightnt.dll" des Service Packs 4 in das Verzeichnis
....\smsadmin\site.srv\x86.bin der SMS-Installation kopieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0655.htm


Der License Server von Windows NT wird vom Service Pack nicht upgedatet

Wenn Sie unter Windows NT 4 das aktuelle Service Pack installieren, wird der License Server bei der "Internationalen Version" von Windows NT nicht auf den aktuellen Stand gebracht (die englische Version läuft ohne Probleme).

Um den Fehler zu beheben, müssen Sie folgendermaßen vorgehen:

Entpacken Sie das aktuelle Service Pack in ein beliebiges Verzeichnis "<SP NAME>.EXE /X" (siehe auch: Service Pack Installation für die Parameter).

Entpacken Sie nun folgende Dateien durch folgenden Aufruf in das SYSTEM32-Verzeichnis:

EXPAND <Dateiname1> %SYSTEMROOT%\System32\<Dateiname2>

Dateiname1 | Dateiname2
liccpa.cp_ | liccpa.cpl
llsrpc.dl_ | llsrpc.dll
llssrv.ex_ | llssrv.exe
ntlsapi.dl_ | ntlsapi.dll

Dieses müssen Sie für alle 4 Dateien durchführen, danach ist auch der License Server auf dem aktuellen Versionsstand.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0463.htm


Fehler bei der Service Pack Installation

Erscheint bei der Installation des Service Packs die Fehlermeldung "Die Datei setup.log konnte nicht gefunden werden", kann das an zwei Dingen liegen.

Bei der Installation des Service Packs wird die Datei setup.log im Windows Repair-Verzeichnis gesucht (%SYSTEMROOT%\repair). Liegt hier ein Fehler vor, kommt es zu dieser Fehlermeldung.

  1. Ist diese Datei nicht vorhanden, müssen Sie die Datei von Ihrer Notfalldiskette zurückkopieren. Haben Sie keine Notfalldiskette für diesen Computer erstellt, können Sie auch die Datei von einen anderen Rechner benutzen, dann müssen Sie diese Datei aber etwas anpassen. Hier müssen Sie die Pfadangaben "TargetDirectory", "TargetDevice", "SystemPartition" und alle Einträge unter "[Files. Windows NT] an Ihren Gegebenheiten anpassen.
  2. Die Datei ist vorhanden und der Fehler kommt immer noch, stimmen höchst wahrscheinlich die Pfadangaben in der Datei nicht überein. Hier müssen Sie die Angaben in der Datei überprüfen und an ihrer Umgebung anpassen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0550.htm


Fehler in Service Pack 2

Nach der Installation von Service Pack 2 unter NT 4.0 ist eine Verbindung mit RAS nicht mehr möglich.

Um das Problem zu beheben, können Sie entweder das Service Pack deinstallieren oder aber Sie führen folgenden Patch aus:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RasMan\ PPP

Erstellen Sie einen neuen Eintrag als Datentyp REG_DWORD, nennen ihn "DisableMultiLink" und setzen ihn auf "1".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0386.htm


Nach Installation von SP4 läuft NT nicht mehr

Nach der Installation von SP4 kann es passieren, dass nach dem Neustart NT mit einem "Blauen Bildschirm" hochkommt und nicht mehr läuft. Das liegt an einem fehlerhaften Treiber für SCSI-Adapter mit dem NCR 53C810 Chipsatz wie sie teilweise von Asus oder Tekram eingesetzt werden.

Installieren Sie auf solchen Systemen entweder das neuste Service Pack von NT. Sollte das aus bestimmten Gründen nicht möglich sein und es wird unbedingt SP4 benötigt, gehen Sie folgendermaßen vor.

  1. Sichern Sie die Datei "SYM810.SYS" aus dem Verzeichnis "%SYSTEMROOT%\SYSTEM32\Drivers"
  2. Installieren Sie SP4
  3. Kopieren Sie vor dem Neustart die gesicherte Datei SYM810.SYS wieder zurück und überschreiben Sie damit die neue fehlerhafte Datei aus dem Servicepack.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0467.htm


Keine SP6-Installation nach 128-Bit-Update mehr möglich

Wer das 128-Bit Update von Microsoft vor dem SP6 installiert, kann dieses danach nicht mehr installieren.

Es gibt mehrere Möglichkeiten:

Tipp 1:

Entpacken Sie das aktuelle Service Pack mit "sp6i386.exe /x". Nach dem Entpacken finden Sie im Verzeichnis ein weiteres Unterverzeichnis "Update" und dort öffnet man mit einem Editor die Datei "Update.inf". Dann mit Suchen den Abschnitt [CheckSecurity.System32.files]suchen. Es ist allerdings erst der dritte Eintrag (der letzte im Dokument). Hier einfach ein ;vor die Schannel.dll setzen. Dann die "update.inf" wieder speichern und das Servicepack installieren.

Tipp 2:

In der update.inf den ersten Eintrag ändern:

von

Security.System32.files=11

in

Security.System32.files=10

Tipp 3:

Benennen Sie die Datei SChannel.dll um (beispielsweise in SChannel.org), bevor Sie das Update starten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=250867

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0832.htm


Hot Fix Packs für SP4

(Stand: 20.03.99)

Hier nun eine Aufstellung aller mir bekannten Hot-Fix Packs für Windows NT (Deutsch/Englisch), wobei man bei einem Server eigentlich immer die englische Version einsetzen sollte.

Es ist nur ratsam, ein Hot-Fix Pack einzuspielen, wenn bei Ihnen das Problem besteht bzw. es eine erhebliche Sicherheitslücke darstellen würde. Auch sollten Sie beachten, dass nach dem Ändern und Einspielen der Service Packs auch das Hot-Fix Pack neu eingespielt werden muss.

Bei allen hier aufgeführten Hot-Fix Packs muss meist das aktuelle Service Pack für die jeweilige NT Version installiert sein, was für NT 4.0 Service Pack 4 bedeutet.

KB Nummer: | Q196270
Beschreibung: | Der SNMP-Dienst zeigt Speicherfehler, wenn er angesprochen wird. Dieser Fehler tritt auf, weil während der Nachrichtenverarbeitung ein Puffer eingerichtet wird. Dieser Puffer wird aber nicht mehr geleert.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ hotfixes-postSP4/SMS-fix/smsfixi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Sms-fix/smsfixi.exe

KB Nummer: | Q195540
Beschreibung: | Windows NT kann nicht auf die ATAPI Version vom IOMEGA Clik 40 Laufwerk zugreifen. Windows NT hält das Iomega Clik 40 Laufwerk für ein Diskettenlaufwerk und weist ihm den ersten verfügbaren Laufwerksbuchstaben (normalerweise B) zu.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Clik-fix/clikfixi.exe

KB Nummer: | Q195725
Beschreibung: | Fehlermeldung: Netzwerktreiber STOP 0x0000001E bei Multiprozessor Rechner Nach der Installation eines Netzwerktreibers wie z.B. das DynamicAccess von der Firma 3COM, stürzt Windows NT mit einer Fehlermeldung ab: NT STOP mit einem Fehler in der TCPIP.SYS in 0x0000000E. Dieser Fehler tritt nur bei Multiprozessor Geräten auf.
Behebung für: | URL, falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Tcpip-fix/tcpipfxi.exe

KB Nummer: | Q195733
Beschreibung: | Fehler bei Service einer Applikation, die "Named Pipes" über RPC verwendet Ihr Windows NT ist sehr langsam und ein Windows NT Process verbraucht 100% der CPU Performance. Das kann dazu führen, dass der Rechner komplett hängt. Das wird durch einen Angriff auf den RPC-Dienst verursacht.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Nprpc-fix/nprpcfxi.exe

KB Nummer:

Q214802

Beschreibung:

Einfügen-Taste geht im Anmeldefenster!

Durch einen Fehler ist es möglich, dass sich unberechtigte Benutzer auf einem Rechner anmelden können, wo ein Benutzer angemeldet ist und die Konsole für den Zugriff nur gesperrt hat. Durch Benutzung des Clipboards (STRG + V) ist es bei ungünstigen Zuständen möglich sich anzumelden ohne das Passwort kennen zu müssen.

Um den Fehler zu beheben, müssen Sie nur die MSGINA.DLL austauschen, die für die Anmeldung zuständig ist.

Behebung für:

URL falls für die Version etwas vorliegt

NT 4.0 Deutsch:

-

NT 4.0 Englisch:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/

hotfixes-postSP4/Gina-fix/ginafixi.exe

KB Nummer: | Q214840
Beschreibung: |
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Msv1-fix/msv-fixi.exe

KB Nummer: | Q218473
Beschreibung: | Durch den Austausch einer DLL ist es möglich, dass ein Normaler Benutzer zum Systemadministrator wird. Siehe dazu auch: Lokale Administratorrechte als USER erlangen
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | müssen Sie selber in der Registry ändern (siehe dazu: Lokale Admistratorrechte als USER erlangen)
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Smss-fix/smssfixi.exe

KB Nummer: | Q218877, Q221120
Beschreibung: | Die MFC40.DLL veranlasst Programme, nach dem 01/01/2000 ein falsches Datum anzuzeigen. Eine interne Funktion von MFC0.DLL berechnet das Datum nach dem Jahr 2000 falsch. So kann aus dem 01.01.2000 der 01.01.100 werden. Dieser Fehler wurde bei folgenden Programmen festgestellt: - Microsoft System Information (Msinfo32.exe)
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Y2KUPD/y2kupd.exe ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Y2KUPD/y2kupdAx.exe

KB Nummer: | Q221991
Beschreibung: | Fehler im Bildschirmschoner lässt die Möglichkeit zu, USER Berechtigungen zu erhöhen. Windows NT starten den Bildschirmschoner im Systemkontext und schaltet danach wieder in den Kontext des angemeldeten Benutzers. Windows NT überprüft aber nicht, ob das auch erfolgreich durchgeführt wurde. Wenn dabei ein Fehler auftritt, bleibt der Bildschirmschoner in diesem Kontext. Durch einen speziell programmierten Bildschirmschoner ist es möglich, die Berechtigungen des angemeldeten Benutzers zu erhöhen.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-postSP4/Scrnsav-fix/scrnsavi.exe

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0709.htm


Hot Fix Packs für SP5

(Stand: 04.01.2000)

Hier nun eine Aufstellung aller mir bekannten Hot-Fix Packs für Windows NT (Deutsch/Englisch), wobei man bei einen Server eigentlich immer die englische Version einsetzen sollte.

Es ist nur ratsam ein Hot-Fix Pack einzuspielen, wenn bei Ihnen das Problem besteht bzw. es eine erhebliche Sicherheitslücke darstellen würde. Auch sollten Sie beachten, dass nach dem Ändern und Einspielen der Service Packs auch das Hot-Fix Pack neu eingespielt werden muss.

Bei allen hier aufgeführten Hot-Fix Packs muss meist das aktuelle Service Pack für die jeweilige NT Version installiert sein, was für NT 4.0 Service Pack 5 bedeutet.

KB Nummer:

Q216913 und Q241040

Beschreibung:

In Service Pack 5 hat MS schon Fixes für das Jahr 2000 eingebaut. Das war ein Problem mit älteren BIOS -Versionen, die den Jahreswechsel nicht richtig durchgeführt haben.

Zwei Fehler bestehen aber immer noch, die mit diesem Bugfix behoben werden:

- Wenn ein Computer auf eine Zeitzone gestellt wird, die nicht an der Sommerzeit teilnimmt, funktioniert die Aktualisierung für das Jahr 2000 nicht.

- Auch bei Multiprozessorkernel funktioniert jetzt die Umstellung

Behebung für:

URL falls für die Version etwas vorliegt

NT 4.0 Deutsch:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/

Hotfixes-PostSP5/Y2K/BIOS 2-fix/BIOS fixi.exe

NT 4.0 Englisch:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/

hotfixes-PostSP5/Y2K/BIOS 3-fix/BIOS fixi.exe

KB Nummer: | Q229607
Beschreibung: | Wenn Sie auf einem NTFS-Laufwerk Dateien erstellen bzw. löschen, auf dem mehr als 4 Millionen Dateien vorhanden sind, kann es zu folgenden Fehlern kommen: - Gelöschte Dateien werden immer noch auf dem Laufwerk angezeigt - Nicht gelöschte Dateien sind nicht mehr zu sehen - Es werden Ihnen Fehler auf dem Laufwerk angezeigt und Sie sollen CHKDSK ausführen.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/NTFS-fix/ntfsfixi.exe

KB Nummer: | Q230677
Beschreibung: | Ein fehlerhafter Eintrag im Telefonbuch kann verwendet werden, um Sicherheitseinstellungen zu umgehen, auf den der RAS Dienst installiert ist. Ein Anwender kann diesen Eintrag ausnutzen um auf diesen Computer ein Programm ausführen zu lassen, mit welchem er einen Angriff auf den Computer durchführen kann.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/RAS-fix/rasffixi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/RAS-fix/rasffixi.exe

KB Nummer: | Q230681
Beschreibung: | Auch wenn bei der Anmeldung an einen RAS-Server die Einstellung "Passwort Speichern" ausgestellt wird, werden die Daten wie Passwort, USER.ID und Domainname in der Registry gespeichert.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ hotfixes-PostSP5/Perfctrs-fix/Q234351i.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Perfctrs-fix/Q234351i.exe

KB Nummer: | Q231337
Beschreibung: | Wenn ein Clientrechner auf dem Service Pack 4 installiert ist, sich über DDE mit einen Server unterhält und eine WM_DDE_TERMINATE Mitteilung an einen Server sendet, wird von NETDDE.EXE die WM_DDE_TERMINATE Antwort des Servers nicht an den Clientrechner weitergeleitet.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/NetDDE-fix/nddefixi.exe

KB Nummer: | Q231457
Beschreibung: | Eine fehlerhafte Anfrage an das LSA (Local Security Authority) kann durch ein Sicherheitsloch dazu führen, dass der Rechner nicht mehr antwortet und einen Neustart durchführen möchte.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/LSA3-fix/lsarepi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/LSA3-fix/lsareqi.exe

KB Nummer: | Q231605
Beschreibung: | Eine Sicherheitslücke im Hilfesystem von MS kann verwendet werden, um das System zum Stillstand zu bringen wenn ein Anwender die Hilfe Taste (F1) drückt.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/WinHLP32-fix/winhlp-i.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Winhlp32-fix/winhlp-i.exe

KB Nummer: | Q233303
Beschreibung: | Wenn Sie den RAS Service auf Ihren Rechner installiert haben und sich bei der Anmeldung über den Dial-Up Client mit einen Server verbinden, werden Sie aufgefordert, Ihre Benutzerdaten einzugeben. Hier haben Sie auch die Möglichkeit auszustellen, dass die Anmeldeinformationen abgespeichert werden. Egal was Sie hier aber anklicken, der Client speichert die Informationen auf jeden Fall ab.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/RRASPassword-fix/rpwdfixi.exe

KB Nummer: | Q233323
Beschreibung: | Wird auf einen Windows Rechner ein fehlerhafter Dienst installiert, wird dieser vom System abgelehnt. Sind es mehr als die max. Anzahl von Prozessen (Standardmäßig 16), die auf eine Benutzereingabe warten, ohne eine Benutzereingabe zu erhalten, kann es sein, dass der Server angehalten wird.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/CSRSS-fix/csrssfxi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Csrss-fix/csrssfxi.exe

KB Nummer: | Q234351
Beschreibung: | Wenn Sie ein Programm starten, welches Performance Daten eines anderen Computers über das Netz anzeigen soll, aber das entsprechende Protokoll nicht installiert ist, kann es dazu führen dass der Computer hängenbleibt.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ hotfixes-PostSP5/RASPassword-fix/pwdfixi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/RASPassword-fix/pwdfixi.exe

KB Nummer: | Q234351
Beschreibung: | Wenn Sie ein Programm verwenden, welches versuch,t auf einen Dienst zuzugreifen, der nicht installiert ist, kann die Performance abnehmen bzw. sich der Computer aufhängen.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ hotfixes-postsp5/perfctrs-fix/q234351i.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Perfctrs-fix/q234351i.exe

KB Nummer: | Q236359
Beschreibung: | Wenn Sie ein Programm ausführen welches einen IOCTL (Input Output Control) Aufruf für die Maus oder Tastatur startet, kann es sein, dass dieses Programm IOCTL daran hindert, auf weitere Anfragen vom Betriebssystem zu antworten.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/IOCTL-fix/ioctlfxi.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/IOCTL-fix/ioctlfxi.exe

KB Nummer:

Q237185

Beschreibung:

Wenn Sie das DFÜ-Netzwerk beenden, können Sie eine "Access violation" Fehlermeldung erhalten und im Event Viewer können Sie folgende ähnliche Einträge vorfinden:

- The application, exe\dialer.dbg, generated an application error.

- The error occurred on <date> @ <time>

- The exception generated was c0000005 at address 31313131.

Dieser Fehler tritt auf, wenn der Eintrag [letzte gewählte Nummer] in der DIALER.INI zwischen 128 und 256 Zeichen enthält.

Behebung für:

URL falls für die Version etwas vorliegt

NT 4.0 Deutsch:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/

hotfixes-postsp5/dialer-fix/dialrfxi.exe

NT 4.0 Englisch:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/

hotfixes-PostSP5/Dialer-fix/dialrfxi.exe

KB Nummer: | Q238020
Beschreibung: | Das NNTP (Network News Transfer Protocol) kann nicht richtig zweistellige Jahreszahlen umwandeln. Wenn Sie also das Jahr 2000 angeben, betrachtet das Protokoll nur "00" und kann das Jahr 2000 somit in 1900 umwandeln. Erfolgt nun eine Anfrage 2-stellig, kann es dazu kommen, dass diese Anfrage mit einem Fehler zurückgewiesen wird, da das Datum zu alt ist.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ Hotfixes-PostSP5/Y2K/NNTP-fix/q238020i.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Y2K/NNTP-fix/q238020i.exe

KB Nummer: | Q238329
Beschreibung: | Wenn ein Computer unter Windows 98 eine fehlerhafte IGMP (Internet Group Management Protocol) erhält, kann sich die Leistung des Computers verschlechtern bzw. er antwortet überhaupt nicht mehr und muss neu gestartet werden. Windows NT Rechner sind von diesem Fehler auch betroffen, aber andere Dienste verhindern die Auswirkung auf die Geschwindigkeit.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/IGMP-fix/igmpfixi.exe

KB Nummer: | Q238453
Beschreibung: | Wenn Sie das TCP/IP Source Routing - wie im Artikel Q217336 beschrieben - deaktivieren, ist es durch fehlerhafte Informationen möglich, diese Deaktivierung zu umgehen.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Spoof-fix/ipsrfixi.exe

KB Nummer: | Q239132
Beschreibung: | Microsoft Exchange und Outlook Clients hängen sich auf, wenn eine Verbindung über eine langsame Leitung auf einem Exchange Server erfolgt.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Rpcltscm-fix/rpslwfxi.exe

KB Nummer: | Q240195
Beschreibung: | Im Jahr 2000 bringt der Schalter "/times" vom Befehl NET.EXE eine Fehlermeldung zustande.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ hotfixes-PostSP5/Y2K/Times-fix/netfixi.exe

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0543.htm


Hot Fix Packs für SP6

(Stand: 04.01.2000)

Hier nun eine Aufstellung aller mir bekannten Hot-Fix Packs für Windows NT (Deutsch/Englisch), wobei man bei einen Server eigentlich immer die englische Version einsetzen sollte.

Info Es ist nur ratsam ein Hot-Fix Pack einzuspielen, wenn bei Ihnen das Problem besteht bzw. es eine erhebliche Sicherheitslücke darstellen würde. Auch sollten Sie beachten, dass nach Ändern und Einspielen der Service Packs auch das Hot-Fix Pack neu eingespielt werden muss.

Bei allen hier aufgeführten Hot-Fix Packs muss meist das aktuelle Service Pack für die jeweilige NT Version installiert sein, was für NT 4.0 Service Pack 6 bedeutet.

KB Nummer: | Q242294
Beschreibung: | Sicherheitsfehler, wenn der RAS-Server verwendet wird. Ein authentifizierter (bekannter) Anwender kann lokal oder über das Netzwerk einen veränderten Code im Kontext des Systemkontos (also als Administrator) ausführen, auch wenn er dazu keine Berechtigungen hat.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ Hotfixes-PostSP6/Security/Rasman-fix/fixrasi.exe

KB Nummer: | Q245329
Beschreibung: | Die Datei CONVLOG.EXE in Verbindung mit den Internet Information Server 3.0 wandelt Daten nach dem Jahr 2000 falsch um.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/ger/nt40/ hotfixes-postsp6/y2k/convlog-fix/x86/convlog.exe
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ Hotfixes-PostSP6/Y2K/Convlog-fix/x86/convlog.exe

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0544.htm


Hot Fix Packs für SP6a

(Stand: 04.01.2000

Hier nun eine Aufstellung aller mir bekannten Hot-Fix Packs für Windows NT (Deutsch/Englisch), wobei man bei einen Server eigentlich immer die englische Version einsetzen sollte.

Info Es ist nur ratsam ein Hot-Fix Pack einzuspielen, wenn bei Ihnen das Problem besteht bzw. es eine erhebliche Sicherheitslücke darstellen würde. Auch sollten Sie beachten, dass nach Ändern und Einspielen der Service Packs auch das Hot-Fix Pack neu eingespielt werden muss.

Bei allen hier aufgeführten Hot-Fix Packs muss meist das aktuelle Service Pack für die jeweilige NT Version installiert sein, was für NT 4.0 Service Pack 6a bedeutet.

KB Nummer: | Q244599
Beschreibung: | FIX um NT an die C2 Sicherheitsansprüche anzupassen. Siehe dazu auch: http://www.microsoft.com/security/issues/C2Evaluation.asp - Q241041 - Q243405 - Q243404
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ Hotfixes-PostSP6a/C2-fix/Q244599i.exe

KB Nummer: | Q245148
Beschreibung: | Wenn Sie die Funktion "Abmelden und als anderer User Anmelden" auswählen, wird der Bildschirm grau und der Mauszeiger wird zu einer Sanduhr. Der Rechner hängt nun und Sie können nichts mehr machen. Hiermit wird das Problem behoben.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ Hotfixes-PostSP6a/winlogon-fix/Q245148i.exe

KB Nummer: | Q246467
Beschreibung: | Auf einem Windows NT Server mit aktiviertem RAS-Dienst kann es vorkommen, dass keine neuen Point-to-Point Verbindungen mehr aufgebaut werden. Wenn das passiert, werden zwar alle vorhandenen Verbindungen bearbeitet, aber keine neuen Verbindungen mehr aufgemacht. Dieser Fehler tritt nur bei Multiprozessor Maschinen auf.
Behebung für: | URL falls für die Version etwas vorliegt
NT 4.0 Deutsch: | -
NT 4.0 Englisch: | ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ Hotfixes-PostSP6a/PPPConn-fix/Q246467i.exe

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0532.htm


Starke Fragmentierung der MFT führt zu Startfehler

Starke Fragmentierung der MFT führt zu Startfehlern

Wenn die Master File Table (MFT) von NTFS zu stark fragmentiert ist, kann das dazu führen, dass Windows NT 4.0 nicht mehr startet und mit einem blinkenden Cursor oder einer Fehlermeldung stehen bleibt.

Die Fehlermeldung lautet:

"A kernel file is missing from the disk. Please insert a system disk and reboot."

bzw.

"Eine Kerneldatei fehlt auf dem Laufwerk. Legen Sie eine Systemdiskette ein und starten Sie das System neu."

Das passiert deshalb, weil NT beim Booten in der MFT nach der Datei NTLDR sucht, welche den Bootvorgang dann weiter fortsetzen soll. Ist die MFT nun zu stark fragmentiert, reicht der Speicher nicht mehr aus und NT kann denn Bootvorgang nicht mehr fortsetzen.

Als Lösung gibt MS nur die Empfehlung, die Festplatte regelmäßig zu defragmentieren.

Da Windows NT 4.0 dafür kein Tool besitzt, ist man gezwungen, auf Tools anderer Hersteller zurückzugreifen.

Mit dem letzten Service Pack "SP6a" ist dieser Fehler behoben. Ist der Fehler aber schon aufgetreten, müssen Sie folgendermaßen vorgehen:

Info Da sich die MFT einer aktiven Systempartition nicht reparieren lässt, kann die Fehlerbehebung nur mit einer Parallel-Installation von NT durchgeführt werden. Spezialprogramme werden nicht benötigt.

  1. Die angeforderte Systemdiskette ist nichts weiter als eine simple NT-Bootdiskette. Ein Beispiel für die evtl. zu erstellende boot.ini (hier: Laufwerk C: als 1. primäre, aktive Partition der 1. Festplatte):

    [boot loader]
    timeout=1
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server, Version 4.0"
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server, Version 4.0
    [VGA-Modus]" /basevideo /sos
  2. Damit sollte das System nun wieder laufen. Datensicherung ist nun das Gebot der Stund e, wird aber auch bei Punkt 4) miterledigt.

    3. Anm.:

    Image-Programme scheitern evtl. an der defekten MFT! (überprüft mit Ghost 5.1d). Auch ein Defragmentieren der Systempartition (hier: C:) ist für die folgenden Schritte enorm hilfreich! (Voraussetzung?) Leider lässt sich der Fehler damit allein NICHT beheben.

  3. Installation eines (zweiten) Notfall-NT auf der gleichen oder einer zusätzlichen Platte. Da die Reparatur der MFT der Systempartition im laufenden Betrieb NICHT möglich ist, ist dieses ZWINGEND notwendig. Evtl. muss die boot.ini der Systemdiskette von Hand angepasst werden. Beispiel (F: als 3. logisches Laufwerk der erweiterten Partition der 1. Festplatte):

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(4)\WINNT
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server, Version 4.0"
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server, Version 4.0"
    [VGA-Modus]" /basevideo /sos
    multi(0)disk(0)rdisk(0)partition(4)\WINNT="NOTFALL Windows NT Server, Version 4.0"
    multi(0)disk(0)rdisk(0)partition(4)\WINNT="NOTFALL Windows NT Server, Version 4.0 [VGA-Modus]" /basevideo /sos

    Abschließend Einspielen des aktuellen Service Pack nicht vergessen (zur Sicherheit).

  4. Nachdem das Notfall-NT fertig installiert und gestartet wurde, ALLE Dateien von C:\*.* nach z.B. F:\SAV VERSCHIEBEN. Anschließend C: neu formatieren (inkl. Startenchreiben der Systemdateien!). Dann F:\SAV\*.* wieder komplett nach C:\ verschieben (ganz Vorsichtige kopieren).
  5. Die boot.ini auf C: kontrollieren und evtl. anpassen. Beispiele: s.o. unter 1) oder 3). Das sollte es gewesen sein.

Anm.:

Das beschriebene Verfahren wurde erfolgreich auf einem NT4-Server SP4 mit Adaptec 2940UW und einer IBM DDRS-39120UW (9 GB) getestet. Aber Vorsicht: in der boot.ini darf NICHT "scsi" statt "multi" stehen, auch wenn NT hier anderer Meinung ist!

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=228734

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0849.htm


Service konnte nicht gestartet werden

Beim Starten von NT kann es vorkommen, dass Sie die Fehlermeldung erhalten, dass ein "Dienst" nicht gestartet werden konnte. Wenn dann die Installation der Services in Ordnung ist und auch aus dem Event-Log nicht zu entnehmen ist, warum der Dienst nicht gestartet werden konnte, könnte es an NT selber liegen.

Einige Services benutzen einen Eintrag in der Registry mit den Typ "REG_MULTI_SZ", um dort die Log-Datei abzulegen. NT kann aber bei diesen Datentyp nur max. 32 KByte Daten speichern. Wenn nun ein Dienst versucht, beim Hochfahren von NT etwas in die Registry zu schreiben und dabei die 32 KByte überschreitet, wird dieser Versuch scheitern. Das kann dazu führen, das auch der Dienst nicht mehr gestartet wird.

Sollte das der Fall sein, müssen Sie den Service so konfigurieren, das keine Log-Dateien mehr geschrieben werden und die schon vorhandenen Einträge aus der Registry löschen, danach sollte wieder alles funktionieren.

Die Einträge finden Sie in der Registry unter folgendem Schlüssel:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ <Name des Services>

Prüfen Sie unter diesem Schlüssel sämtliche Einträge als Datentyp REG_MULTI_SZ, ob sie zu viele Daten enthalten.

Wenn Sie nicht wissen sollten, welche Einträge Sie da nun löschen können und welche nicht, sollten Sie sich lieber mit dem Hersteller auseinandersetzen. Vielen sind diese Probleme auch schon bekannt und können die gewünschten Einstellungen nennen, damit das Problem nicht wieder auftritt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0721.htm


Outstanding NCP directory searches exceeded?

Diese Fehlermeldung können Sie unter Novell erhalten, wenn Sie von einem NT-Rechner auf einen Novell-Server zugreifen.

Sie wird hervorgerufen, wenn von NT über mehrere Laufwerke (Volumes) eine Suche nach Dateien gestartet wird. Da der Novell-Server für diese große Anzahl von Suchvorgängen nicht genügend Ressourcen reserviert hat, kommt es zu dieser Fehlermeldung.

Damit diese Fehlermeldung nicht mehr kommt, müssen Sie die Ressourcen am Novell-Server erhöhen. Das erreichen Sie mit dem Befehl "set maximum outstanding ncp searches = <WERT>" (Sie können diesen Befehl in die AUTOEXEC.NCF einfügen). Gültige Werte liegen zwischen "10" und "1000".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0726.htm


Fehlermeldungen bei Benutzerprofilen

Wenn Sie die Benutzerprofile auf den Server ablegen, kann es vorkommen, dass beim Anmelden eine Fehlermeldung angezeigt wird. Mit dieser Fehlermeldung kann man wenig anfangen, da hier meist nur gemeldet wird, dass die Aktualisierung gescheitert ist.

NT legt aber im Ereignisprotokoll einen Eintrag für diesen Fehler mit der Ereignis-ID 1000 an. Hier wird nach dieser Textmeldung noch eine weitere Fehlernummer mit angegeben, die Aufschluss über den aufgetretenen Fehler gibt.

Fehlernummer | Fehlermeldung | Bedeutung
2 | Der Anwender verwendet ein verbindliches Profil, das vom System nicht gefunden wurde. | Überprüfen Sie die Pfadangaben im Benutzermanager und ob der Freigabename richtig geschrieben ist.
18 | Das Betriebssystem konnte Ihr Profil nicht laden. Wenden Sie sich an Ihren Netzwerkadministrator. | Die Registry hat die max. eingestellte Größe erreicht
32 | Auf das Profil wird von einem anderen Prozess zugegriffen. | Anwender hat sich schon wo angemeldet
53 | Der Netzwerkpfad wurde nicht gefunden. | Keine Netzwerkverbindung zum Server
67 | Der Netzwerkname wurde nicht gefunden. | Pfadname zum Profilverzeichnis ist fehlerhaft
71 | Der Server, auf dem das Profil gesichert ist, erlaubt keine weiteren Verbindungen. | Die Lizenzen sind überschritten.
1385 | Das Recht Zugriff vom Netzwerk für den Server, auf dem das Profil abgelegt ist, ist nicht gegeben. | Benutzer hat kein Recht, auf das Verzeichnis zuzugreifen.
1450 | RegLoadKey ist mit dem Fehler 1450 für C:\winnt\Profiles\test.001\ntuser.dat gescheitert. | Die Registry hat die max. eingestellte Größe erreicht

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0582.htm


Fehlermeldung: Unable to find function "DLLRegisterServer" in....

Nach der Installation des Internet Explorers 4.01 (SP1 oder SP2) oder dem IE 5.0 kann es nach dem Neustart zu folgenden Fehlermeldungen kommen:

Unable to find function "DLLRegisterServer" in file C:\WNT40\SYSTEM32\COMCAT.DLL.

Error occurred calling "DLLRegisterServer" in C:\ WNT40\SYSTEM32\ASCTRLS.OCX (HRESULT=80004005).

Error occurred calling "DLLRegisterServer" in C:\ WNT40\SYSTEM32\DAXCTLE.OCX (HRESULT=80004005).

Das liegt an einer fehlerhaften Version der Datei %SYSTEMROOT%\System32\COMCAT.DLL. Um diesen Fehler zu beheben, gehen Sie in das Verzeichnis und löschen Sie diese Datei (Sie sollten sie vorher unter einem anderen Namen sichern). Installieren Sie nun den Internet Explorer noch einmal.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0640.htm


Fehlermeldung: Nicht genügend Serverspeicher verfügbar

Erscheint beim Verbinden von Netzwerklaufwerken die Fehlermeldung "Nicht genügend Serverspeicher verfügbar" bzw. "Für diesen Befehl ist nicht genügend Serverspeicher verfügbar!", so liegt das am Eintrag "IRPStackSize" in der Registry.

Dieser Fehler wird immer dann angezeigt, wenn versucht wird, auf einem im Netzwerk freigegebenen Ordner zuzugreifen.

Um den Fehler zu beheben, müssen Sie den Wert IRPStackSize auf dem Rechner erhöhen, auf welchen Sie zugreifen wollen. Gehen Sie dafür folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet \Services \LanmanServer \Parameters

finden Sie den Eintrag "IRPStackSize" als Datentyp REG_DWORD.

Dieser Wert steht standardmäßig auf 11 (Dezimal). Er legt die Anzahl von Steckplätzen in dem vom Server verwendeten IRPs (I/O Request Packets) fest.

Ist der Wert nicht vorhanden, setzen Sie den Wert erst mal auf 11 (Dezimal) und prüfen Sie nach einer neuen Anmeldung, ob der Fehler weg ist. Wenn nicht, Setzen Sie diesen Wert auf 50 (Dezimal) und führen Sie einen kompletten Neustart des Rechners durch, der Fehler sollte nun weg sein.

Info:

Jede Erhöhung um 1 belegt 36 Bytes zusätzlich im Hauptspeicher des Rechners.

Die Werte dürfen zwischen 1-50 (Dezimal) liegen.

Info: Acronis-Probleme lassen sich mit IRPStackSize = 18 (dezimal) lösen.

Info Es kann auch sein, dass Acronis-Software wie "ACRONIS True Image Home 2009" installiert wurde. Oft hilft dann nur eine Deinstallation von "ACRONIS True Image Home 2009".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Wenn der Fehler bei einer Netzwerkverbindung kommt, müssen die Werte auch auf dem anderen Rechner geändert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0475.htm


Die USER32.DLL meldet dass der Speicher voll ist

Trotz größerem RAM-Speicher kommt es vor, dass sich die USER32.DLL mit der Auskunft meldet, der Speicher sei voll.

Diesen Fehler können Sie durch einen kleinen Eintrag in der Registry ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Subsystems\Windows

finden Sie den Eintrag: "SharedSection=xxxx,yyyy"

Wert "xxxx" ist der "Desktop Heap", der Speicher für Interaktionen zw. Anwender und Anwendung.

Wert "yyyy" ist der systemweite Zwischenspeicher von Windows NT

Hinter diesen Wert können Sie nun, durch Komma getrennt, einen dritten Wert setzen. Der sollte mit einer Größe von mind. 512 dafür sorgen, dass das Speicherproblem gelöst ist. Es handelt sich um den "Hidden Desktop Heap", der für nicht interaktive Anwendungen zuständig ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0710.htm


Fehlermeldung: "Nicht genügend Server-Speicherplatz verfügbar...."

Ihr System verfügt über ausreichend viel Speicher, aber trotzdem wird beim Starten oder beim Versuch eine Netzwerkverbindung herzustellen von Windows folgender Fehler angezeigt:

"Dienst kann nicht gestartet werden, nicht genügend Server-Speicherplatz".

Das kann daran liegen, dass einige Programmteile nachinstalliert, aber nicht wieder mit dem aktuellen Service Pack auf den neuesten Stand gebracht wurden oder das ein Registrywert zu klein eingestellt wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

1. Sie müssen in der Registry unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Memory Management

den Wert PagedPoolSize auf 0 stellen.

oder

2. Sie müssen in der Registry unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\ Parameters

den Wert von IrpStackSize erhöhen.

Info Es ist wichtig, dass nach der Durchführung von Änderungen an den Systemdateien das Service Pack erneut installiert wird

Info Wenn der Fehler bei einer Netzwerkverbindung kommt, müssen die Werte auch auf dem anderen Rechner geändert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0433.htm


Kernel Stack Error

Wenn NT einen "Kernel Stack Error" meldet, kann das an einer fehlenden Auslagerungsdatei (Pagefile) liegen. Wurde diese gelöscht, legen Sie einfach eine neue an.

Ist die Auslagerungsdatei aber vorhanden, ist mit aller Wahrscheinlichkeit Ihre Festplatte defekt. Hier hilft je nach Größe des Fehlers nur noch ein Austauschen der Festplatte.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0427.htm


Fehlermeldungen: IRQL_not_less_or_equal

Diese Fehlermeldung "IRQL_not_less_or_equal" tritt auf, wenn ein Kernelmode-Prozess bzw. ein Treiber versucht, in eine falsche Adresse zu schreiben, auf die er keine Zugriffsrechte hat.

Meist passiert das, wenn ein Programm durch einen fehlerhaften Zeiger auf die falsche Adresse verwiesen wird. Das Programm versucht nun, auf diese fehlerhafte Adresse zuzugreifen, was zu einem Fehler führt. Passiert das im Benutzermodus, kommt es zu einer Zugriffsverletzung und das Programm wird beendet. Passiert das aber bei Treibern, die meist im Kernelmodus ausgeführt werden, so wird eine STOP 0x0000000A Meldung ausgegeben.

Um jetzt herauszufinden, welcher Treiber diese Meldung verursachte, muss man diese Fehlermeldung auswerten.

Ich versuche hier einmal anhand einer Beispiel-Fehlermeldung die Anzeige zu erklären.

STOP 0x0000000A(0xZZZZZZZZ,0xYYYYYYYY,0xXXXXXXXX,0xVVVVVVVV)

IRQL_not_less_or_equal

** Address 0xVVVVVVVV has base at [address] - [driver]

Parameter: | Bedeutung:
0xZZZZZZZZ | Falsche Adresse, auf die verwiesen wurde
0xYYYYYYYY | IRQL, der erforderlich war, um auf den Speicher zuzugreifen
0xXXXXXXXX | Zugriffsart (0 lesen oder 1 schreiben)
0xVVVVVVVV | Adresse der Instruktion die versuchte, auf den Speicherbereich zuzugreifen

Liegt der letzte Parameter (0xVVVVVVVV) im Adressbereich eines Gerätetreibers des Systems, wissen Sie, welcher Gerätetreiber gerade lief, als der Speicherzugriff geschah. Dieser Treiber ist oft in der dritten Zeile des STOP Bildschirms zu finden.

siehe auch: Analyse eines Bluescreens

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0391.htm


NT-Backup erkennt BAND nicht

NT-Backup erkennt BAND im Laufwerk nicht

NT versucht immer zuerst das Band im Laufwerk zu erkennen und meldet erst dann die Betriebsbereitschaft. Wird das Band nicht erkannt, gibt NT die Fehlermeldung "Bandlaufwerk antwortet nicht" aus.

Dieser Fehler kann bei Bändern auftreten, die nicht formatiert sind. Damit Sie das Band aber trotzdem formatieren können, starten Sie NT-Backup folgendermaßen:

NTBACKUP /NOPOLL

Nun wird das Backup ohne Banderkennung gestartet und Sie können die Bänder ohne Probleme formatieren.

Info Benutzen Sie diese Option nur zum FORMATIEREN von Bändern und niemals zum Backup. Starten Sie dafür das Backup immer ohne diesen Parameter. Ansonsten kann es zu Fehlern beim Backup bzw. Restore kommen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0417.htm


Fehlermeldung: Der Start eines Dienstes schlug fehl: WinToA...

An vielen NT-4.0 Rechnern tritt beim Einsatz eines ZIP-Laufwerkes folgende Fehlermeldung auf: "Der Start eines Dienstes schlug fehl: WinToA...."

Das bedeutet, dass der Dienst ZipToA nach der Installation von IomegaWare-Software fehlt schlägt.

Dieser Dienst ist ein ATAPI Treiber für die Erkennung des ZIP-Atapi-Laufwerkes als Diskettenlaufwerk durch das BIOS.

Der Windows NT Ereignisdienst zeigt an, dass der Dienst nicht geladen wurde. In den meisten Fällen wird dieser Dienst nicht benötigt und kann abgeschaltet werden.

Zur Behebung dieser Fehlermeldung führen Sie folgende Schritte durch:

  1. START anklicken, EINSTELLUNGEN und SYSTEMSTEUERUNG auswählen.
  2. Dienste mit einem Doppelklick öffnen.
  3. In der Liste ZipToA auswählen und anklicken.
  4. Den Knopf START anklicken und im Fenster DEAKTIVIERT auswählen.
  5. SCHLIESSEN anklicken.

Die Einstellungen werden nach einem Neustart wirksam.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1280.htm


'Geräte' in der Systemsteuerung lässt sich nicht mehr öffnen

Nach der Installation des Programms ICQ kann es vorkommen, dass sich der Eintrag "Geräte" in der Systemsteuerung nicht mehr öffnen lässt und folgende Meldung ausgegeben wird: "Konfigurations-Manager: Diese Routine ist in der aktuellen Version nicht implementiert."

Eine mögliche Ursache kann sein, dass ICQ eine falsche Version (Windows 2000) der Datei CFGMGR32.DLL in das System32-Verzeichnis einspielt und dabei die Version, welche unter NT4.0 Server korrekt funktioniert, überschreibt.

Lösung:

Extrahieren Sie die Datei Cfgmgr32.dll vom aktuellen Service-Pack in das System32-Verzeichnis.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1281.htm


Soundblaster LIVE läuft nicht mit SP4

Nach der Installation der Treiber für die Soundblaster LIVE können Sie sich nicht mehr an Ihrem System anmelden, da sich das System aufhängt. Dieser Fehler ist bekannt und auf der Homepage http://www.sblive.comfinden Sie neue Treiber, die auch mit SP4 von Windows NT fehlerfrei laufen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0631.htm


Fehlermeldung bei Druckerinstallation

Bei einer Druckerinstallation erscheint folgende Fehlermeldung: "Der Vorgang kann nicht abgeschlossen werden. Die Druckverarbeitung ist unbekannt".

Lösung:

Zunächst schauen, ob im Verzeichnis C:\WINNT\system32\spool\prtprocs\w32x86 die Datei WINPRINT.DLL vorhanden ist. Wenn nicht, dann diese Datei, welche sich als WINPRINT.DL_ auf der Windows NT40-CDROM befindet, mit "Expand" in das Verzeichnis "entpacken". Anschließend REGEDT32 aufrufen. Dort in folgende Registrierung hineingehen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Print\ Environments\ Windows NT x86\ PrintProcessors\ winprint

Folgenden Wert hinzufügen: Driver als Datentyp REG_SZ: winprint.dll.

Im Registry-Editor sieht das dann wie folgt aus: Driver:REG_SZ:winprint.dll

Damit sollte der Fehler behoben sein.

Siehe auch "Keine Drucker mehr in Windows 2000 vorhanden".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=105247

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0122.htm


Fehlermeldung: Auslagerungsdatei zu klein oder nicht vorhanden

Erscheint bei Ihnen die Fehlermeldung "PAGEFILE TOO Seinmal OR MISSING", obwohl die Auslagerungsdatei vorhanden und auch groß genug ist, kann das an einem Registry Key liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Finden Sie den Wert "PagingFiles" der angibt, wo und in welcher Größe Auslagerungsdateien vorhanden sind. Finden Sie hier zusätzlich noch den Wert "TempPageFile" als Datentyp REG_DWORD, löschen Sie diesen Eintrag und starten Ihren Rechner neu, der Fehler sollte nun beseitigt sein.

Die Fehlermeldung kann auch dadurch verursacht werden, dass unter:

"COMPUTERVERWALTUNG" -> "DATENTRÄGERVERWALTUNG" -> "EIGENSCHAFTEN VON C:" -> "SICHERHEITSEINSTELLUNGEN" der Benutzer "SYSTEM" fehlt.

Nach Hinzufügen und anschließendem Herunterfahren sollte der Fehler behoben sein.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0552.htm


Probleme bei mehreren Netzwerkkarten

Ein Fehler, der bei TCP/IP mit mehr als einer Netzwerkkarte auftritt ist, dass es zu Verzögerungen beim Verbindungsaufbau kommen kann.

Dieser Fehler kann auftreten:

  1. Es ist eine NetBIOS -Verbindung über TCP/IP (nicht bei Verbindungen über Windows Sockets)
  2. Es wird über beide Netzwerkkarten mit TCP/IP gearbeitet.

Der Fehler liegt daran, dass NT das Netzwerk in der Reihenfolge der Bindungen abarbeitet. Es wird also als erstes bei der ersten Bindung auf eine Antwort gewartet und erst danach werden alle anderen Bindungen abgefragt. Kommt auf der ersten Bindung keine Netzwerkverbindung zustande, wird relativ lange gewartet, bis die anderen Bindungen berücksichtigt werden. Außerdem wird dadurch nicht immer unbedingt die schnellste Verbindungsart ausgewählt.

Sie müssen das aktuelle Service Pack installieren und danach folgenden Schlüssel in der Registry anlegen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Rdr\ Parameters

Der Wert "IgnoreBindingOrder" als Datentyp REG_DWORD

Wenn man diesen Wert auf "1" setzt, wird nicht mehr nach der Reihenfolge der Bindungen vorgegangen, sondern die erste Antwort wird ausgewertet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0715.htm


ISA-Karten in PCI-Systemen

In ganz seltenen Fällen kann eine ISA-Karte in einem PCI-System unter Windows NT nicht korrekt angesprochen werden - meist handelt es sich dabei um Netzwerkkarten. Tritt dieses Problem auf, sollten Sie den entsprechenden Registry-Eintrag im Schlüssel

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ [Adaptername]\ Parameters

ausfindig machen, wobei [Adaptername] meist eine Kurzbezeichnung des Kartentyps ist. In dem betreffenden Schlüssel sollten Sie einen Parameter BusNumber (Typ DWord) vorfinden, der in numerischer Form den Bus bezeichnet, in dem die Karte eingesteckt ist. Welcher Bus welche Nummer trägt, hängt von der Konfiguration ab; im oben beschriebenen Fehlerfall genügt es fast immer, als Bus-Number der Netzwerkkarte 0 einzutragen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0684.htm


Zeitplandienst einrichten (AT-Befehl)

Unter Windows ist es möglich, automatisch zu bestimmten Zeiten Befehle ausführen zu lassen. Dazu muss als erstes unter NT 3.51 der Zeitplandienst gestartet werden (ab Windows 4.x heißt er Schedule bzw. ab XP Taskplaner). Das finden Sie unter "Systemsteuerung" -> "Dienste". Klicken Sie hier nun auf "Zeitplandienst" bzw. "Schedule" oder "Taskplaner" und dann auf "Startart". Stellen Sie die Startart auf "Automatisch". Bei "Anmelden als" ist standardmäßig "Systemkonto" ausgewählt. Sollen aber von dem Zeitplandienst Befehle ausgeführt werden, die besondere Rechte benötigen, müssen Sie ein Konto mit den entsprechenden Rechten anlegen und das unter "Dieses Konto" verwenden angeben.

Nach einem Neustart werden die Zeitplandienste nun automatisch gestartet. Sie können das auch jetzt unter Dienste selbst starten, indem Sie auf "Starten" klicken.

Jetzt müssen Sie noch in der Eingabeaufforderung angeben welche Befehle zu welchem Zeitpunkt ausgeführt werden sollen. Dazu gibt es unter Windows den AT-Befehl mit folgender Syntax:

Mit dem Befehl AT können Befehle und Programme zu einem vorbestimmten Termin gestartet werden. Der Zeitplandienst muss gestartet sein, um den Befehl AT zu verwenden.

AT [\\Computername] [ [ID] [/DELETE] | /DELETE [/YES]]

AT [\\Computername] Zeit [/INTERACTIVE] [ /EVERY:Datum[,...] | /NEXT:Datum[,...]] "Befehl"

\\Computername | Gibt einen Remote-Computer an. Ohne diesen Parameter werden die Befehle auf dem lokalen Computer ausgeführt.
ID | Eine Identifikationsnummer, die dem geplanten Befehl zugeteilt wird.
/DELETE | Löscht geplante Befehle. Ohne ID werden alle geplanten Befehle auf dem Computer gelöscht
/YES | In Verbindung mit /DELETE werden die geplanten Befehle ohne weitere Bestätigung gelöscht.
Zeit | Gibt die Zeit an, zu der ein Befehl ausgeführt werden soll.
/INTERACTIVE | Ermöglicht dem Auftrag Eingaben vom Benutzer anzunehmen, der angemeldet ist, wenn der Auftrag ausgeführt wird.
/EVERY:Datum[,...] | Führt den Befehl zu jedem der angegebenen Tage der Woche oder des Monats aus. Ohne Angabe eines Datums wird der aktuelle Tag des Monats angenommen.
/NEXT:Datum[,...] | Führt den Befehl am nächsten angegebenen Tag aus (z.B. nächsten Montag). Ohne Angabe eines Datums wird der aktuelle Tag des Monats angenommen.
"Befehl" | Ist der auszuführende Windows NT-Befehl oder Stapelprogramm.

Beispiel:

AT 12:00 "CMD /C C:\Test\test.cmd"

würde um 12.00 Uhr die Batch "Test.cmd" starten.

Info Wenn Sie das Resource Kit von Windows NT installiert haben, steht Ihnen als Alternative zum AT Befehl der Befehl WINAT zu Verfügung, der über eine grafische Benutzeroberfläche verfügt.

IE 5.0 bei Windows 2000

Mit der Installation des IE 5.0 und bei Windows 2000 wird das Programm, das hinter dem Dienst "Schedule" steckt, ausgetauscht. Es wird durch das Programm MsTask.exe, zu finden im Verzeichnis %SYSTEMROOT%\System32\ ersetzt. Dieses Programm, dass das Programm ATSVC.EXE ersetzt, lässt es nicht mehr zu, dass man Benutzer einträgt, unter deren Kennung der Zeitplandienst ausgeführt werden soll. Er läuft immer unter dem Systemkonto.

Man kann dies unter Windows in der Registry wieder rückgängig machen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Den Dienst "Task Schedule" (neuer Name) stoppen und deaktivieren, Regedit öffnen und unter

"HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Service\ Schedule"

den Namen des Programms, Wert "ImagePath" von "%SYSTEMROOT%\System32\MsTask.exe" auf "%SYSTEMROOT%\system32\atsvc.exe" ändern. Weiterhin muss noch der Eintrag unter "Type" von 0x120 auf 0x010 geändert werden. Jetzt kann man den Dienst wieder aktivieren und starten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0279.htm


Wo legt Windows die BIOS -Informationen ab?

Für Abfragen in großen Unternehmen ist es oft interessant, die BIOS -Version der Rechner herauszubekommen.

Windows stellt die BIOS -Version fest und legt die Informationen in der Registry unter folgendem Schlüssel ab:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ HARDWARE\ DESCRIPTION\ System

Hier finden Sie folgende Einträge:

SystemBIOS Date | REG_SZ | BIOS Datum
SystemBIOS Version | REG_MULTI_SZ | BIOS Version
VideoBIOS Date | REG_SZ | VIDEO BIOS Datum
VideoBIOS Version | REG_MULTI_SZ | VIDEO BIOS Version

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0845.htm


Wartezeit beim Windows Backup

Mit dem Windows Backup können Sie ihr System sichern. Das Backup-Programm wartet beim Backup bei jeder Datei, die in Benutzung ist und aus diesem Grunde nicht gesichert werden kann, 30 sec. Je nach System kann diese Zeit zu lange sein, da sich dann die gesamte Laufzeit des Backups zu sehr verlängert und es sowieso schon feststeht, dass diese Dateien nicht gesichert werden können. Die Wartezeit können Sie in der Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Ntbackup\ User Interface

können Sie mit dem Eintrag "Wait time" als Datentyp REG_SZ festlegen, wie lange das Backup bei einer Datei warten soll, die gerade in Benutzung ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0611.htm


Unterschiedliche AT Parameter bei NT 3.51 und NT 4.0

MS hat den Aufruf der AT von NT 3.51 nach NT 4.0 etwas verändert.

Windows NT 3.51

AT hh:mm "CMD /C Parameter"

Windows NT 4.0

AT hh:mm CMD /C "Parameter"

Wenn Sie Programme benutzen, die noch auf den alten Aufruf angewiesen sind, können Sie ab Service Pack 4 mit einem Registry Key auch die alte Art des Aufrufs ermöglichen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Schedule

Erstellen Sie hier einen neuen Schlüssel mit dem Namen "Parameters". Unter diesem Schlüssel legen Sie nun einen Wert als REG_DWORD mit dem Namen "UseOldParsing" an und weisen ihm den Wert 1 zu.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0619.htm


Unterschiede zwischen NT Workstation und Server

Hier werden die Unterschiede zwischen Windows NT Workstation und Server beschrieben.

  1. Anzahl der passiven Verbindungen ist bei der Workstation ist auf 10 begrenzt.
  2. Workstation unterstützt bis zu 2 Prozessoren, der Server bis zu 4.
  3. Bei der Workstation kann gleichzeitig nur eine RAS-Verbindung aufgebaut werden, beim Server bis zu 256.
  4. Eine Workstation kann keine Domänenanmeldung bestätigen, d.h. wenn ein Benutzer an mehreren Stationen arbeitet, ist die Benutzerdatenbank auf jeder Workstation entsprechend zu pflegen.
  5. Verzeichnisreproduktion ist bei der Workstation auf Importieren beschränkt.
Funktion: | Workstation: | Server:
Anbindung anderer Clients | 10 | unbegrenzt
Verbindung zu anderen Netzwerken | unbegrenzt | unbegrenzt
Multiprocessing | 2 Prozessoren | 4 Prozessoren
Remote Access Service | 1 Verbindung | 256 Verbindungen
Directory Replication | Import | Import & Export
Macintosh Services | nein | ja
Logon Validation | nein | ja
Disk Fault Tolerance | nein | ja
Netzwerkfunktionalität | Peer-to-Peer | Server

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0238.htm


Suchpfade setzen

Unter -> "Systemsteuerung" -> "System" -> "Umgebung" kann man unter NT die Suchpfade editieren.

Info Falls Windows 95 oder WfW311 installiert ist und man deren Programme nutzen möchte: Pfad nach <Windowsverzeichnis>\System Eintragen. Auf diese Weise funktionieren unter NT auch die Anwendungen, die ihre *.DLL und sonstige Dateien dort ins Systemverzeichnis kopiert haben. Ohne eine Pfad-Angabe würde NT diese Dateien natürlich nicht finden und man müsste die Programme auch unter NT installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0323.htm


SCSI-BUS ohne Neustart nach neuen Geräten absuchen lassen

Sie können den SCSI-BUS auch ohne Neustart des Rechners nach neuen Geräten absuchen lassen, das ist z.B. nützlich, wenn Sie den Scanner erst nachträglich eingeschaltet haben.

Sie müssen nur in der "Systemsteuerung" -> "Bandgeräte" gehen und auf "Erkennen" klicken. Es werden hier nicht nur Bandgeräte, sondern auch alle anderen, zusätzlich eingeschalteten SCSI-Geräte erkannt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0303.htm


ROLLBACK.EXE

Bei Windows NT 4.0 befindet sich auf der CD im Ordner \Support\Deptools\<System> eine Datei mit dem Namen: "ROLLBACK.EXE"

Info Führen Sie diese Datei nicht aus!

Sie löscht ohne weitere Abfrage neben einigen Dateien auch die komplette Registrydatenbank.

Es besteht (lt. Microsoft) keine Möglichkeit, die zerstörten Informationen wiederherzustellen.

Diese Datei ist dafür gedacht, das System wieder in den "Urzustand" zu bringen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0277.htm


Programmen eine bestimmte CPU zuordnen

Die Windows Betriebssysteme ab NT unterstützen mehr als eine CPU, so dass Sie im Taskmanager die Möglichkeit haben, nach dem Start eines Programmes festzulegen, auf welcher CPU das Programm laufen soll.

Der Nachteil an dieser Methode ist leider, dass diese Information nicht gespeichert wird. Die Einstellung muss also nach jedem Neustart des Programm geändert werden.

Von MS gibt es dafür das Programm Imagecfg.exe, mit dem solche Zuordnungen dauerhaft gespeichert werden können. Bei Windows NT finden Sie das Programm noch auf der CD im Verzeichnis "\support\debug\i386". Ansonsten befindet sich das Programm auf der "Windows 2000 Server Resource Kit"-CD.

Das Programm benutzen Sie folgendermaßen:

Imagecfg -a <Prozessor ID> <Pfad zum Programm>

Als Prozessor ID geben Sie die ID der CPU als Hexadezimalzahl an. Die möglichen Werte liegen zwischen 0x1 und 0x1f. Die Nummerierung beginnt bei 0x1.

Info Achtung: Bei dieser Vorgehensweise wird die jeweilige Programmdatei geändert. Legen Sie vorsichtshalber vorher eine Sicherheitskopie der Datei an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1329.htm


Plug & Play Treiber installieren

Bei NT ist ein PnP-Karten Treiber dabei (PnP ISA Enabler Driver), der aber nicht automatisch installiert wird.

Legen Sie die Windows NT-CD-ROM ein, wechseln Sie in das Verzeichnis "DRV-LIB\PNPISA\X86", klicken die Datei PNPISA.INF mit der rechten Maustaste an und wählen Sie "Installieren".

Nach dem Neustart werden PnP-Karten erkannt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0276.htm


Evaluation Copy

Es gibt auch wieder eine Evaluation CD von Windows 2000.

Wenn Sie feststellen wollen wie lange die Version noch bei Ihnen läuft, geben Sie einfach unter "Start" -> "Ausführen" den Befehl WINVER ein. Jetzt erscheint ein Infobildschirm, in welchem das Ablauf-Datum Ihrer Installation angezeigt wird.

Die Unterschiede zu der Normalen Version sind:

  • Die Produkte sind vom Paketinhalt mit den Vollversionen identisch und nicht technisch limitiert.
  • Lizenzrechtlich besteht die Einschränkung, dass diese Produkte nicht in einer Produktionsumgebung eingesetzt und nicht weiter veräußert werden dürfen.
  • Die Evaluationsversionen dürfen selbstverständlich ohne Berechnung zu Testzwecken an Ihre Kunden weitergegeben werden. Ebenso können die Evaluationsversionen intern zu Trainingszwecken z.B. für Ihre Techniker oder Verkaufsberater eingesetzt werden.
  • Die Abgabe der Evaluationsversionen ist auf ein Exemplar je Produkt und Firma beschränkt.
  • Die Evaluationsversionen sind nicht updatefähig (auf die nächste Evaluationsversion). Es kann auch nicht von einer Evaluationsversion auf ein Vollprodukt upgedatet werden.
  • Der Lieferumfang der Produkte umfasst entsprechend den Lieferumfang des Vollproduktes, sowohl die Software auf der CD-ROM als auch die Dokumentation.
  • Die Version ist auf 3 Lizenzen für die Professional und 5 Lizenzen für die Server Version beschränkt, zu bestellen unter 0180/5302525

Info Nach neuer Aussage von MS gibt es die Evaluation Copy nur noch für Händler.

Info Eine 120 Tage Testversion ist bei einigen MS Press Büchern dabei (z.B. MCSE 70-210 Windows 2000 Professional).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0374.htm


Ein Benutzerprofil für unterschiedliche Anwender

Unter Windows können Sie für unterschiedliche Benutzer ein Profil vorgeben, ohne dass es sich dabei um ein verbindliches Profil handelt.

Interessant ist dieses Vorgehen z.B. bei Notebook-Anwendern. Hier wird normalerweise für die Netzwerkanmeldung das Domänenkonto verwendet und für den mobilen Einsatz ein lokales Benutzerkonto. Da Windows für die beiden Anmeldungen jeweils ein eigenes Profilverzeichnis erstellt, arbeitet der Anwender mit zwei unterschiedlichen Profilen, was mit der Zeit doch etwas nervig sein kann.

Damit der Anwender nur noch mit einem Profilverzeichnis arbeitet und damit immer die gleiche Oberfläche zu sehen bekommt, egal wo er sich gerade anmeldet, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

  1. Erstellen Sie ein lokales Benutzerkonto auf dem Rechner
  2. Melden Sie sich mit diesen Benutzerkonto an und wieder ab; das gleiche muss auf diesem Rechner auch einmal für den Domänen-Account durchgeführt werden. Bei der Anmeldung wird für die Konten jeweils ein neues Profilverzeichnis erzeugt und der Pfad zu diesem Profilverzeichnis wird in der Registry eingetragen.
  3. Melden Sie sich mit einem anderen Account an, der administrative Rechte besitzt (keiner der beiden oben erwähnten Accounts darf dafür verwendet werden).
  4. Starten Sie den Registryeditor (regedt32) und laden Sie den Registryzweig des neuen Accounts:
    Dazu wählen Sie das Fenster "HKEY_USERS" aus, klicken Sie nun im Menü "Registrierung" -> "Struktur laden" und wählen Sie die Datei NTUSER.DAT aus dem Verzeichnis "%SYSTEMROOT%\Profiles\[Anwendername]" bei Windows NT oder unter "Dokumente und Einstellungen\[Anwendername]" bei Windows 2000 (für Anwendername benutzen Sie den Namen des Benutzerkontos). Jetzt werden Sie aufgefordert, für den Registryzweig einen Namen anzugeben; geben Sie hier eine beliebige Bezeichnung ein (z.B. Profil).
  5. Ändern Sie jetzt die Zugriffsrechte des hinzugeladenen Zweiges. Damit auch der andere Benutzer dieses Profil verwenden darf, gehen Sie folgendermaßen vor:
    Sie wählen die von Ihnen angegebene Bezeichnung an (z.B. Profil), klicken im Menü "Sicherheit" -> "Berechtigungen" -> "Hinzufügen" und fügen den lokalen Benutzeraccount mit "Vollzugriff" zu dem anderen Namen hinzu.
    Speichern Sie diesen ganzen Zweig nun wieder ab:
    Wählen Sie dazu aus dem Menü "Registrierung" -> "Struktur entfernen". Hiermit wird der Schlüssel wieder aus der Registry entfernt und gespeichert.
  6. Wechseln Sie jetzt zu folgendem Registry-Schlüssel
    HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList
  7. Hier müssen Sie jetzt die SID ihres lokalen Accounts auswählen. Wenn Sie die richtige SID-Nummer Ihres Accounts nicht wissen, können Sie diese mit dem Programm "GETSID.EXE" aus dem Windows Resource Kit ermitteln.
  8. Ändern Sie hier den Eintrag "ProfileImagePath" auf den Pfad des lokalen Profiles ab.

Wenn Sie sich jetzt mit dem lokalen Account anmelden, wird Ihnen das Profil des anderen Accounts angezeigt.

Info Diese Änderung des Pfades funktioniert natürlich nur bei lokalen Profilen.

Info Man muss noch zusätzlich dem lokalen Benutzer das Recht geben, auf das Profil-Verzeichnis des anderen zugreifen zu können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0526.htm


Unterschiede in den Environment Variablen zwischen NT und Windows 2000/XP

Unterschiede in den Environment- Variablen zwischen NT und ab Windows 2000

Zwischen NT und Windows 2000/XP gibt es Unterschiede in den Standard Environment Variablen %HOMESHARE% und %HOMEPATH%. Das hat MS eingeführt, damit das Homelaufwerk direkt mit dem Homeverzeichnis verbunden wird. Der Anwender kann so die darunterliegenden Verzeichnisse nicht mehr sehen.

Windows NT

%HOMESHARE% | \\<Servername>\<Sharename>
%HOMEPATH% | \<Verzeichnis>\<Homeverzeichnis>

Dadurch wird das Homeverzeichnis folgendermaßen verbunden:

NET USE %HOMEDRIVE% \\<Servername>\<Sharename>

Ab Windows 2000

%HOMESHARE% | \\<Servername>\<Sharename>\<Verzeichnis>\<Homeverzeichnis>
%HOMEPATH% | \

Dadurch wird das Homeverzeichnis folgendermaßen verbunden:

NET USE %HOMEDRIVE% \\<Servername>\<Sharename>\<Verzeichnis>\<Homeverzeichnis>

Diese Änderung kann zur Folge haben, dass einige Batch-Programme unter Windows 2000 nicht mehr laufen. Wenn Sie diese Programme nicht erst noch mühevoll überarbeiten wollen, können Sie durch einen Registryeintrag Windows 2000 dazu bewegen, die Variablen wieder wie unter NT zu belegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Legen Sie einen neuen Eintrag mit dem Namen "ConnectHomeDirToRoot" als Datentyp REG_DWORD an und setzen diesen Wert auf 1, jetzt werden die Variablen wieder wie unter NT belegt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Benutzerprofile
Einstellungsname: | Basisverzeichnis mit dem Freigabestamm verbinden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1065.htm


Dienste und Geräte unter Windows

Ein Dienst ist eigentlich nur ein Programm, welches "meistens" keine Bildschirmausgaben durchführt und keine Eingaben von Benutzern erwartet. Fehlermeldungen oder sonstige Meldungen werden in einer LOG-Dateien oder im Ereignisprotokoll eingetragen.

Des weiteren gibt es bei Windows auch noch Geräte. Diese Geräte (Treiber) werden von Windows auch wie Dienste behandelt, die aber mit besonderen Zugriffsrechten ausgestattet sind und werden nicht in der Dienstekonfiguration angezeigt.

Windows NT

Alle Änderungen können Sie unter "Start" -> "Systemsteuerung" bei "Dienste" bzw. "Geräte" vornehmen. Hier sehen Sie, welche Dienste gestartet sind und können selber Dienste Starten/Beenden oder die Startart festlegen. Weitere wichtige Informationen zu den Diensten/Geräten finden Sie noch in der "Windows NT Diagnose". Hier sehen Sie nicht nur welche Dienste/Geräte gestartet sind, sondern können sich durch einen Doppelklick die Abhängigkeiten und weitere Informationen zu den jeweiligen Diensten anzeigen lassen (hier sehen Sie welche Datei durch diesen Dienst geladen wird).

ab Windows 2000

Hier finden Sie die Dienste im MMC unter "Start" -> "Systemsteuerung" -> "Verwaltung" -> "Dienste" oder können die MMC über "Services.msc" auch direkt aufrufen. Dort werden Ihnen alle Informationen über die Dienste angezeigt.

Alle Betreibssysteme

Einige Einstellungen zu den Diensten können Sie so nicht ändern und sind nur in der Registry eingetragen. Die Dienste stehen in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\

Hier gibt es für jeden Dienst einen weiteren Schlüssel. Unter diesem Schlüssel sind folgende Einträge möglich:

Wert | Datentyp | Beschreibung
DependOnGroup | REG_MULTI_SZ | Hier werden die Dienstgruppen angegeben, die vor diesem Dienst gestartet werden müssen.
DependOnService | REG_MULTI_SZ | Abhängigkeit von anderen Diensten
DisplayName | REG_SZ | Der unter Windows angezeigte Name für diesen Dienst
ErrorControl REG_DWORD

Fehlergewichtung des Dienstes. Hier wird festgelegt, was gemacht wird, wenn dieser Dienst nicht gestartet werden konnte:

0 -> Ignorieren Windows setzt den Bootvorgang weiter fort und gibt keine Fehlermeldung aus.

1 -> Normal Windows setzt den Bootvorgang weiter fort und gibt eine Fehlermeldung aus.

2 -> Schwer Windows bricht den Bootvorgang ab und startet das System neu. Dabei wird die letzte funktionierende Konfiguration benutzt. Tritt der Fehler hier wieder auf, wird der Bootvorgang einfach weiter fortgesetzt.

3 -> Kritisch Windows bricht den Bootvorgang ab und startet das System neu. Dabei wird die letzte funktionierende Konfiguration benutzt. Tritt der Fehler hier wieder auf, wird der Bootvorgang abgebrochen und ein Debugging Programm geladen
Group | REG_SZ | Die Gruppe, die diesem Dienst zugeordnet wurde
ImagePath | REG_EXPAND_SZ | Pfad und Dateiname
ObjectName | REG_SZ | Name des Benutzers, unter dem der Dienst gestartet werden soll (Bei LocalSystem wird die Anmeldung von Windows vorgenommen und läuft unter diesem Kontext)
Start REG_DWORD

Zeigt die Startart des Dienstes an (die ersten beiden können nicht über die Oberfläche gesetzt werden und sollten deshalb auch nicht verändert werden):

0 -> wird vom Kernel gestartet

1 -> wird durch das I/O Subsystem gestartet

2 -> wird durch den Dienstkontroll-Manager gestartet (Automatisch)

3 -> wird auf manuell gesetzt und muss durch den Anwender gestartet werden (Manuell)

4 -> wird deaktiviert (Deaktiviert)
Tag | REG_DWORD | Reihenfolge für das Starten der Gruppe
Type REG_DWORD

Die Art des Dienstes, die als Hexadezimalzahl angegeben wird:

0x1 -> Kernelmode Gerätetreiber

0x2 -> Treiber für das Dateisystem

0x4 -> Befehlssatz für Hardware

0x8 -> Dienst für einen Dateisystemtreiber

0x10 -> Windows 32 Programm mit eigenen Prozess

0x20 -> Windows 32 Programm ohne extra Prozessbereich

0x110 -> Windows 32 Programm mit eigenen Prozess, welches benutzerspezifisch gestartet wird.

0x120 -> Windows 32 Programm ohne extra Prozessbereich, welches benutzerspezifisch gestartet wird.
DelayedAutostart REG_DWORD

Ab Windows Vista:
Legt fest ob der Dienst verzögert gestartet werden soll. Dadurch startet Windows schneller, kann aber nicht mit allen Diensten gemacht werden.

0 -> Dienst normal starten.

1 -> Dienst Verzögert starten - Automatisch (Verzögerter Start). Wird nur im Zusammenhang mit Start = 2 benutzt.

Info Mit dem Befehl SC können Sie die Dienste über die Kommandozeilenoberfläche verändern bzw. auch neue Dienste einrichten. Weitere Informationen finden Sie im Tipp: Informationen über den Befehl SC

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0572.htm


Standardvariablen von Windows

Standardvariable von Windows

Siehe dazu Tipp: "Umgebungsvariablen In Windows"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0561.htm


Multi-Prozessor Downgrade

Über einen Eintrag in der Registry lässt sich eine CPU ausschalten, ohne sie aus dem Rechner zu entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ SessionManager\ RegisteredProcessors

steht die Anwahl der von NT verwendeten CPUs. Wenn Sie dort nun eine 1 Eintragen, verwendet NT (nach einem Neustart) nur die erste CPU. Der Wert muss kleiner oder gleich dem unter "LicensedProcessors" eingetragenen sein, sonst gibt es einen "Blue Screen" beim Starten.

Info Durch einen einfachen Eintrag in der Boot.ini wird Windows ebenfalls veranlasst, nur mit einer CPU zu booten (siehe: Boot.ini).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0220.htm


Automatische Sommerzeit-Erkennung ausschalten

Windows versucht automatisch die Sommer/Winterzeitanpassung anhand der Systemuhr - basierend auf der Zeitzone - zu erkennen und durchzuführen. Mit diesem Tipp können Sie diese automatische Erkennung ausschalten und Umstellung der Systemuhr ausschalten bzw. wieder aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ TimeZoneInformation

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAutoDaylightTimeSet" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Autoerkennung ausschalten
0 | Autoerkennung aktiv (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1625.htm


Eingebaute Gruppen (built-in group) zu einer lokalen Gruppe hinzufügen?

In Windows kann man über die Oberfläche (GUI) keine "Eingebauten Gruppen" sogenannte "build-in group" zu einer lokalen Gruppe hinzufügen. Will man z.B. die "build-in group" Interactive zu der Gruppe "Backup Operators" hinzufügen, kann man das nur über die Kommandozeilenoberfläche machen.

Dazu führen Sie folgenden Befehl aus:

Net localgroup "Backup Operators" Interactive /add

Bei der Gruppe "Interactive" handelt es sich um eine Gruppe, die alle Benutzer enthält, die sich an einer Maschine interaktiv anmelden können (Ctrl+Alt+DEL). In der Oberfläche (GUI) wird diese Zuweisung als "NT Authority\Interactive" angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2524.htm


Einführung in Windows NT

Hier finden Sie eine Ausarbeitung zu NT von Michael Schröder. Es wird für Einsteiger ein Überblick über die Funktionsweise und Tools von Windows NT gegeben.

Die Texte wurden uns vom Autor zur Verfügung gestellt, wofür wir uns an dieser Stelle noch einmal bedanken wollen. Die Homepage des Autors finden Sie unter "http://www.bs-welt.de" wo der Originaltext ihm HTML-Format vorliegt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0749.htm


Einführung

Einführung zu Netzwerken

Im Laufe der Entwicklung von Computersystemen werden immer größere Anforderungen, gerade im Hinblick auf Computervernetzung, gestellt.

Peer to Peer ist eine herkömmliche Verfahrensweise beim Aufbau eines Netzwerkes. Im Peer to Peer Netzwerk unter Windows 95 muss der Benutzer eines Rechners jeden fremden Benutzer, der über eine Datenleitung auf sein System zugreifen möchte, einzeln autorisieren und die Benutzerrechte festlegen. Weiterhin muss der Benutzer selbst bei jedem anderem Computerbenutzer, auf dessen System er Zugriff haben möchte, einzeln eine Autorisierung erbitten.

Peer to Peer erfordert also einen schnell ins unermessliche wachsenden Aufwand an Netzwerkverwaltung, wenn man bedenkt, dass bei einem Netzwerk z.B. in einer Unternehmung die Buchhaltung auf weitere Ressourcen (wie Lagerbestände, oder ähnliches) und das Technische Büro (Zeichnungsplotter) usw. Zugriff haben möchten.

Mit der Entwicklung von Windows NT wurde ein Betriebssystem auf den Markt gebracht, dass den Aufwand an Netzwerkverwaltung auf ein Minimum reduziert. Windows NT erlaubt dem Netzwerkadministrator die gezielte Vergabe von Zugriffsrechten, z.B. die Einrichtung einer Benutzergruppe. Eine solche Benutzergruppe kann die Buchhaltung eines Unternehmens sein, deren Teilnehmer mit den entsprechenden Rechten und Ressourcen-Zuweisungen ausgestattet werden.

Windows NT hat viele weitere Optionen, um die Funktionalität und die Sicherheit des Netzwerkes zu gewährleisten. Die einzelnen Computer des Netzwerkes werden mit Windows NT Workstation betrieben, das einen etwas verringerten Leistungsumfang aufweist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0750.htm


Windows NT Struktur

Funktionen des Betriebssystem-Kernel sind umfangreich. Es gibt weitreichende Sicherheitsmechnismen:

  • Unterstützung für den System- Administrator
    Sicherheit des BS wird gewährleistet
    Normale Benutzer dürfen z.B. keine Netzwerktreiber installieren, selbst wenn Sie auf dem Server angemeldet sind.
    Diese Dienste stehen nur dem Administrator zur Verfügung
  • Fehlertoleranz
    Jedes Programm erhält seinen eigenen Speicherbereich
    Kein Programm kann den Speicherbereich eines anderen verletzen oder den des Servers, außer, der Kernel lässt dies zu.
  • Präemptives Multitasking
    Rechenzeitverwaltung erfolgt über das BS
  • Symmetrisches Multiprocessing
    max. 32 Prozessoren werden unterstützt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0751.htm


Welches Netz brauche ich?

Folgende Anforderungen müssen zuerst geklärt werden:

  • Schätzen Sie die zu erwartende Belastung durch die Clients ab.
  • Bestimmen Sie, welche Netzwerk-Hardware diese Belastung bewältigt.
  • Bestimmen Sie, welcher Kabeltyp diese Netzwerk-Hardware unterstützt.
  • Entscheiden Sie, ob Sie zentralisierte oder verteilte Server im Netzwerk einsetzen wollen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0752.htm


Hardwareauswahl

Hardwareauswahl bei Netzwerken

Hier gibt es grundsätzliche Überlegungen, die zu einer Auswahl der erforderlichen Netzwerk-Hardware führen.

z.B. kann man folgende Grundüberlegungen anstellen:

  • Token Ring verwendet höhere Bitübertragungsraten als Ethernet.
  • Bei Token Ring muss ein Netzwerksrechner aber warten, bis er das Token bekommt.
  • Bei Token verlangsamt sich das Netz, sobald mehr Rechner angeschlossen werden.
  • Beim Ethernet kann aber durch die Zunahme der Kollisionen im Netz ein völliger Systemzusammenbruch eintreten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0753.htm


Wie hoch belastet mein Client das Netzwerk?

Hier finden Sie eine Aufstellung der Netzwerklast zu Zeiten von Windows NT, die Zahlen geben dabei die Netzwerklast wieder.

Macintosh

Netzwerklast: 1

Macintoshs erfordern typischerweise sehr wenig Netzwerkleistung, darum verwenden wir einen Macintosh-Client als Basis für die Netzwerkkennzahl.

MS DOS

Netzwerklast: 2

MS DOS Maschinen arbeiten meist mit einfachen Programmen, die dem Netzwerk nicht viel abverlangen.

Diskless MS DOS Clients

Netzwerklast: 9

Diskless MS DOS Clients ohne Laufwerk sind hingegen sehr viel anspruchsvoller. Diese Computer benötigen das Netzwerk für jeden I/O Befehl, der normalerweise über die lokale Festplatte abgewickelt würde.

Windows

Netzwerklast: 3

Windows ist eine komplexere Plattform als MS DOS ,und Programme für Windows sind ebenfalls komplexer und stärker vom Netzwerk abhängig.

Power PC

Netzwerklast: 3

Auf dem Power PC Mikroprozessor basierende Macintosh Computer sind sehr schnell. Obwohl Macintoshs allgemein weniger vom Netzwerk abverlangen als die meisten PC-basierenden Konzepte für gemeinsamen Zugriff auf Dateien, können diese Computer das Netzwerk durch ihre Geschwindigkeit schwer belasten.

Diskless Windows Client

Netzwerklast: 9

Windows Clients ohne Laufwerk sind extrem abhängig von der Windows Netzwerk Bandbreite- mehr als jeder andere Computer.

Windows 95

Netzwerklast: 4

Windows 95 ist ein mächtiges Multitasking-Betriebsssystem,das typischerweise auf schnellen Client Computern läuft.

OS/2

Netzwerklast: 4

OS/2 ist in vielen Beziehungen ähnlich zu Windows 95.Es läuft auf vergleichbarer Hardware und verarbeitet vergleichbare Programme.

Windows NT

Netzwerklast: 5

Windows NT Workstation ist das mächtigste für PCs verfügbare Betriebssystem. Seine Fähigkeit durch Multitasking mehrerer Netzwerkprogramme gleichzeitig reibungslos ablaufen zu lassen, fordert sehr viel vom Netzwerk.

UNIX

Netzwerklast: 5

UNIX Workstations werden meist von bandbreitenintensiven Workstation-Anwendern verwendet, wie Programmierer, Grafiker und CAD Operatoren.

UNIX-X

Netzwerklast: 3

X-Terminals haben kein Laufwerk, doch sie arbeiten Terminal-ähnlich wie einfache Bildschirme. Die Daten zum Bildschirmaufbau werden vom Server gesendet, der jedoch die vom Anwender angeforderten Aufgaben selbst durchführt.

TCP/IP DruckServer

Netzwerklast: 10

Obwohl Druckerserver technisch keine eigene Netzwerklast erzeugen, tun das die zu druckenden Dokumente sehr wohl. Jedes Dokument, das Sie über einen Druckserver drucken, muss das Netzwerk zweimal durchqueren, wenn es vom Computer zum Windows NT Server gesendet wird, der es verarbeitet und noch einmal, wenn es zum Druck Server gesendet wird.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0754.htm


Die Netzwerkkarten

Kapazität (Zahl) = Anzahl der Rechner, mit der das entsprechende Netz betrieben werden kann.

Ethernet

Rechner: 100

Ethernet wurde als Vergleichsbasis gewählt, weil es die derzeit meist verbreitete Datenverbindungs-Technologie ist. Sie können normalerweise 50 DOS Clients an ein einzelnes Ethernet-Subnetzwerk hängen, bevor es sich festfährt.

Token Ring

Rechner: 200

Ein einzelner Token Ring kann ungefähr doppelt so viele Computer aufnehmen wie ein einzelnes Ethernet-Subnetzwerk. Weil Token Ring sanft in der Leistung abfällt, können Sie einen Token Ring auch über diesen Punkt hinaus belasten, doch das Netzwerk wird dann spürbar langsamer.

Fast Ethernet

Rechner: 500

Obwohl die Bitrate von Fast Ethernet zehnmal so hoch ist wie die von Ethernet, kann es wegen der Pausen, die durch verarbeitete Kollisionen verursacht werden, nicht den zehnfachen Netzwerkverkehr verarbeiten.

Fiber Distributed Data Interface (FDDI)

Rechner: 1000

Sie können sinnvollerweise zehn Ethernet Netzwerke durch einen einzelnen FDDI Ring verbinden. Diese Anordnung hängt stark davon ab, wo Sie Ihre Server aufstellen wollen - zentralisierte Server brauchen mehr Leistung vom KBone.

Fiber Channel (1GBit/s)

Rechner: 10000

Gigabit Ethernet arbeitet über den Fiber Channel mit einem Gigabit/Sekunde. Obwohl Gigabit Ethernet das Ethernet im Namen trägt, arbeitet es vollduplex, Punkt zu Punkt und ohne Kollisionen. Es ist eine perfekte KBone-Technik.

ATM-155 OC-3

Rechner: 1000

ATM ist eine switched Network Technik. Sie arbeitet nicht auf Shared. Aus diesem Grund können Sie darauf zählen, dass Sie rund 80% der Bitrate für echten Datenverkehr verwenden können, solange es Ihnen gelingt, konstante Verbindungen zwischen den Servern zu gewährleisten.

ATM OC-12

Rechner: 4000

Die ATM Bandbreite steigt linear mit der Geschwindigkeit. Bei 622 MBit/s ist ATM OC-12 ausreichend für die meisten anspruchsvollen KBone Anwendungen.

ATM OC-48

Rechner: 16000

ATM OC-48 (2,2 GBit/s) wird typischerweise für großstädtische Netzwerke verwendet. Die Kapazität ist auch für Hochgeschwindigkeitsnetze großer Städte geeignet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0755.htm


Wie installiere ich NT Server

Es gibt mehrere Möglichkeiten, NT Server zu installieren:

  • von Startdisketten
  • von CD ROM
  • von einem Netzwerkserver

Mit dem Programm SETUPMGR.EXE kann man Antwortdateien für die unbeaufsichtigte Installation erstellen.

Das Programm befindet sich im Verzeichnis: SUPPORT\DEPTOOLS\i386. Es müssen folgende Punkte vor der Installation festgelegt werden:

  • Computer Name Domänenname
    (nur wenn der Rechner Mitglied einer Domäne werden soll)
  • Arbeitsgruppenname
  • Geräteeinstellungen (z.B. IRQ und DMA der Netzwerkkarte)
  • Festplattenaufteilung
  • Verzeichnis für WINNT
  • Netzwerkprotokolle (IP/ Subnetmask)
  • Ethernet-Informationen (Frame-Typ)
  • Lizenzierungs-Informationen
  • Administrator-Kennwort

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0756.htm


Der Befehl 'winnt' und seine Parameter

Bei der Installation von CD-ROM mit Booten von CD wird dieser Befehl nicht benötigt. Muss man den Rechner von Disketten booten, sollte mindestens winnt/x benutzt werden.

Damit wird verhindert, dass neue Bootdisketten erstellt werden. Sollen mehrere Microsoft Betriebssystemen installiert werden, empfiehlt es sich, NT als letztes zu installieren, weil NT von Windows 9x nicht erkannt wird und es zu Konflikten bei der Laufwerksbuchstabenvergabe kommt. Windows 9x Systeme werden nur in den NT Bootmanager eingebunden, wenn diese auch auf FAT 16 laufen. Es ist also sinnvoll, einen extra Bootmanager zu installieren. Der Linuxbootloader LILO oder der freie XFDisk verrichten diese Aufgabe einwandfrei.

Ins Verzeichnis i386 wechseln und den Befehl mit entsprechenden Optionen eingeben.

Installieren von Windows NT:

WINNT [/S[:]Quellpfad] [/T[:]TempLW] [/I[:]INF-Datei] [/O[X]] [/X | [/F] [/C]] [/B] [/U[:Skriptdatei]] [/R[X]:Verzeichnis] [/E:Befehl]

/S[:]Quellpfad | Gibt den Ort der Windows NT-Quelldateien an. Der Pfad muss in folgender Form vollständig angegeben werden: \[Pfad] oder \\Server\Freigabe[\Pfad]. Die Standardeinstellung ist das aktuelle Verzeichnis.
/T[:]TempLW | Bestimmt ein Laufwerk, dass die temporären Setup-Dateien enthält. Falls nicht angegeben, wird Setup ein Laufwerk für Sie bestimmen.
/I[:]INF-Datei | Bestimmt den Dateinamen der Setup-Informationsdatei (ohne Pfadangabe). Die Standardeinstellung ist DOS NET.INF.
/OX | Setup-Disketten für CD-ROM-Installation erstellen.
/X | Keine Setup-Disketten erstellen.
/F | Keine Überprüfung von Dateien beim Kopieren auf die Setup-Disketten.
/C | Überprüfung des verfügbaren Setup-Diskettenspeicherplatzes auslassen.
/B | Installation ohne Disketten (erfordert /S).
/U | Unbeaufsichtigte Installation und optionale Skriptdatei (erfordert /S).
/R | Optionales Verzeichnis erstellen.
/RX | Optionales Verzeichnis kopieren.
/E | Befehl, der am Ende des Installationsteils im GUI-Modus ausgeführt wird.

Verwenden Sie WINNT /? | MORE, um den Hilfetext seitenweise anzuzeigen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0757.htm


Berechnung des Festplattenbedarfs für einen Datei-Server

Man addiert die Werte für alle Clients lt. der Tabelle über die Anforderungen von Netzwerkclients.

- Der so gewonnene Wert ist mit 50 zu multiplizieren.

- Dann addiert man 300 MB für das Betriebssystem.

- Anschließend wird auf das nächste volle GB aufgerundet.

Bei Verwendung von Spiegelsätzen, Disk-Duplexing oder RAID Level 1 benötigt man den doppelten Speicherplatz. Wenn man Stripe Sets mit Parität oder RAID Level 5 verwendet, braucht man eine zusätzliche Festplatte, um die Paritätsinformationen aufzunehmen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0758.htm


Das Dateisystem von Windows NT

New Technology File System wird allgemein mit NTFS abgekürzt.

NTFS kann nur für Windows NT auf einer NT Workstation oder einem NT Server verwendet werden. Es wurde dafür entwickelt und bietet gegenüber z.B. FAT folgende Vorteile:

  • Sicherheit auf Dateiebene
  • POSIX-Unterstützung (Namenskonventionen im Netzwerk)
  • Datenträgersätze
  • Support für FILE WORKS von MAC-Dateien
  • Log-Dateien für Fehlertoleranz
  • Sehr große Partitionen
  • Reparatur im laufenden Betrieb (Hot Fixing)
  • Kompression auf Dateiebene

NTFS speichert alle Änderungen an Dateien sowie Verzeichnissen (Rückgängigmachen ist möglich).

Das Programm CONVERT.EXE ermöglicht die Konvertierung von FAT, HPFS nach NTFS. Ein Rückgängigmachen ist nicht möglich.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0759.htm


Welches Backup für Bandsicherung

Es bestehen zwei Möglichkeiten der Bandsicherung:

1. lokale Bandsicherung

Vorteile:

  • Daten werden nicht über das Netzwerk übertragen.
  • Sicherungen können während des Betriebs vorgenommen werden.
  • Daten entsprechen weitgehend der Struktur der Festplatte.
  • einfacher Zugriff auf die Registry.
  • Wiederherstellung ohne funktionierendes Netzwerk möglich.
  • Funktioniert mit dem Bandsicherungsprogramm von Windows NT.

Nachteile:

  • Zusätzlicher administrativer Aufwand bei großen Netzwerken.
  • Zusätzliche Hardwarekosten.

s

2. Netzwerk Bandsicherung

Vorteile:

  • Nur ein Bandsicherungsserver kann die Daten vieler Server sichern
  • Weniger administrativer Aufwand bei großen Netzwerken

Nachteile:

  • Massive Sicherungsläufe können länger als eine Nacht dauern und dadurch Belastungen während der Arbeitszeit erzeugen.
  • Massive Sicherungsläufe können länger als eine Nacht dauern und dadurch Belastungen während der Arbeitszeit erzeugen.
  • Konzentriertes Risiko von Archivierungsfehlern. Wenn der Bandsicherungs- Server ausfällt, wird keine Archivierung durchgeführt.
  • Netzwerkfehler verhindern die Datensicherung.
  • Zusätzliche Softwarekosten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0760.htm


Der Festplattenmanager

Es kann vorkommen, dass NT bei der Installation eine größere Festplatte nicht erkennt. Hier hilft es, die Festplatte an ein bereits laufendes NT System anzuschließen, um partitionieren und formatieren zu können.

Funktionen des Festplattenmanagers:

  • Erstellen von Partitionen
  • Formatieren von Festplatten
  • Erstellen von Spiegelsätzen, d.h. die komplette Spiegelung einer Festplatte auf eine zweite, die im Notfall die Aufgaben der ursprünglichen Platte übernimmt.
  • Zuweisung von Laufwerksbuchstaben in beliebiger Reihenfolge.
  • Erstellung von Stripe Sets (mit Parität). Dadurch wird eine simultane Abarbeitung eines Befehls auf mehreren Festplatten ermöglicht.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0761.htm


Netzwerkeinstellungen

Das Programm Netzwerk ist das wichtigste (und komplexeste) Systemsteuerungsprogramm. Es kann über Eigenschaften des Netzwerkdesktopicons oder in der Systemsteuerung unter System aufgerufen werden.

Es ermöglicht die Installation bzw. Konfiguration von Diensten, der Server-Identifikation, Netzwerk-Transportprotokolle, Netzwerkkarten und -Bindungen von Netzwerkkarten mit Protokollen und Protokollen mit Diensten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0762.htm


TCP/IP Einstellungen

Der Internet Domain Name Service konvertiert IPs in mnemotechnische Namen.

Einzugeben ist die IP des Servers, auf dem dieser Dienst läuft. WINS konvertiert die spezifischen Microsoft Computernamen in eine IP. Einzugeben ist die IP des Servers, auf dem dieser Dienst läuft.

IP Adressen sind weltweit eindeutig und werden vom Deutschen Network Information Center DeNIC vergeben. Durch Kombination von IP und Subnetmask stellt der Rechner fest, ob der Zielrechner Mitglied des lokalen Netzwerkes ist. Soll ein Datenpaket zu einem Rechner außerhalb des lokalen Netzwerks übertragen werden, geschieht dies über das Gateway, das auch eine eindeutige IP hat. Gateways sind im TCP/IP Sprachgebrauch dasselbe wie Router. Wenn in einem Netzwerk ein DHCP Dienst vorhanden ist, vergibt dieser die IP und Subnetmask.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0763.htm


Die Systemsteuerung

Es soll hier nur auf die wichtigsten Systemsteuerungsprogramme eingegangen werden, welche Sie unter "Start"-> "Einstellungen" -> "Systemsteuerung" finden.

Anschlüsse

Das Programm Anschlüsse ermöglicht die Konfiguration der COM und LPT-Anschlüsse. Hier können IRQs und E/A Werte eingestellt werden für den Fall, dass es zu Konflikten bei der Zuweisung von NT kommt, z.B. bei der Installation eines internen Modems. Der DFÜ Monitor zeigt aktuelle Statistiken für den RAS Dienst (Remote Access Service) wie Datendurchsatz, Kompressionsstatistik, Verbindungsstatistik für alle aktiven Verbindungen.

Dienste

Das Programm Dienste ermöglicht das Anhalten und Fortsetzen von Diensten. Ein Druckauftrag, der steckengeblieben ist, kann gestoppt und nach Behebung des Problem wieder gestartet werden.

Geräte

Das Programm Geräte ermöglicht das Beenden von Treibern und gleichzeitig auch des Dienstes, der den Treiber benötigt. Normalerweise wird man kaum mit diesem Programm zu tun bekommen. Wenn doch, sollte man sich sehr sicher sein, was man tut, da das Beenden NT spezifischer Dienste schnell dazu führen kann, dass der Server beim Booten versagt.

Multimedia

Mit dem Programm Multimedia können Audio, Video, Midi und CD Musik-Geräte und Treiber installiert werden. Spezifische Server haben keine Verwendung für Multimedia Funktionen.

SCSI-Adapter

Das Programm SCSI- Adapter ermöglicht die Installation von SCSI Treibern für Festplatten, Bandlaufwerke, CD-ROM-Laufwerke und Recorder, magneto-optische Laufwerke oder Scanner. Die Konfiguration der SCSI Adapter erfolgt beim Booten in dem herstellerspezifischen SCSI BIOS . IDE Controller werden auch mit diesem Programm verwaltet.

System

Neben allgemeinen Systeminformationen, Leistungsmerkeinmalen, Boot Optionen und Hardware-Profilen ist das wohl wichtigste Menü "System" im Systemprogramm. Unter System kann die Auslagerungsdatei von NT Server konfiguriert werden. Es können Operationen mit dem virtuellen Arbeitsspeicher bei simultanen Schreib- und Lesezugriffen auf mehreren Festplatten beschleunigt werden.

Server

Das Programm Server zeigt eine Zusammenfassung serverrelevanter Statistiken, wie aktive Sitzungen, Anzahl gesperrter Dateien und Anzahl der offenen Named Pipes. Es ist hilfreich, wenn der Server langsam wird, herauszufinden wie viele Benutzer auf bestimmte Ressourcen zugreifen, um so einen Flaschenhals zu erkennen.

USV

USV bedeutet unterbrechungsfreie Stromversorgung. Sie wird durch ein entsprechendes Zusatzgerät gewährleistet und ist eine sehr sinnvolle Sicherheitseinrichtung, um durch plötzlichen Spannungsverlust des Servers größere Schäden zu vermeiden. USVs versorgen den Server in der Regel so lange mit Netzspannung. wie er zum Herunterfahren benötigt. Mit dem Programm USV in der Systemsteuerung können die genauen Parameter für den Ernstfall festgelegt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0764.htm


Wie funktionieren Dienste?

Die Microsoft Komponenten Architektur als Ersatz für das OSI-Schichtmodell

Der RPC Konfigurationsdienst:

Remote Procedure Call implementiert einen IPC Mechanismus (Inter Process Communication) zum Starten von Programmen auf fremden Computern. Die Prozessorbelastung kann damit auf mehrere Rechner verteilt werden. RPC hat vier Hauptkomponenten:

  1. Remote Procedure Stub bildet Pakete, die an den Server gesendet werden.
  2. RPC Runtime sendet zwischen lokalen und entfernten Computern Pakete.
  3. Application Stub nimmt RPC Anfragen, formatiert Sie und startet den passenden Aufruf für die Remote Procedure.
  4. Remote Procedure ist der eigentliche Prozess, der über das Netzwerk aufgerufen wird

Arbeitsstationen und Server Dienste:

bilden die Netzwerkumgebung, die für den Benutzer sichtbar ist und benutzen den Suchdienst, NetBIOS und RPC. Die Teilnahme an einer Arbeitsgruppe oder an einer Domäne sind die beiden primären Arbeitsweisen dieses Dienstes

Programmier- Schnittstellen (APIs)

ermöglichen die Kommunikation von Anwendungsprogrammen mit beliebigen Dateisystemen und Netzwerkdiensten. Windows NT unterstützt:

  1. NetBIOS
  2. Windows-Sockets
  3. Remote Procedure Calls
  4. Network Dynamic Data Exchange (NetDDDE)

Dateisystem- Treiber

Folgende Komponenten rufen Transportprotokolle auf, um ihre Aufgabe durchzuführen:

Arbeitsstation - und Serverdienst

Named Pipes

Mail Slots

Transport- Treiber Schnittstelle

Das Transport Driver Interface (TDI) ist keine Software, sondern lediglich eine dokumentierte Spezifikation, nach der Programmierer Transportprotokolle schreiben müssen, wenn Sie korrekt mit Windows NT Komponenten zusammenarbeiten sollen. Alle Schnittstellen unter NT sind Spezifikationen.

Transportprotokolle

Entspricht der Kommunikations- und Transportschicht im OSI Modell. Die Transporttreiber Schnittstelle ermöglicht einem Server die gleichzeitige Ausführung mehrerer Protokolle. So kann ein Server zuverlässige Verbindungen zu jedem Client aufbauen, der diese Protokolle versteht.

Transporttreiber Schnittstelle

Bei Windows NT in der Transporttreiber Schnittstellendefinition(NDIS) implementiert. Sie ermöglicht, dass mehrere Netzwerkkarten-treiber mit einer unbegrenzten Zahl von Transportprotokollen kommunizieren.

Netzwerkkartentreiber

Sie arbeiten in der Bitübertragungsschicht des OSI-Modells. Der Treiber muss zu NDIS kompatibel sein und genau wissen, wie er Anfragen vom NDIS Code Wrapper richtig beantwortet.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0765.htm


Ein zentraler Begriff bei Windows NT ist die Domäne

Unter Domäne versteht man die logische Zusammenfassung von Computern, die mit einer gemeinsamen Benutzer- und Sicherheitsdatenbank arbeiten. Eine Domäne besteht aus dem Ersten-Domänen-Kontrollrechner (Primary Domain Controller, PDC) und beliebig vielen Sicherungs-Domänen-Kontrollrechnern (Backup Domain Controller, BDC). Auf dem PDC verwaltet der Administrator die Benutzerkonten und die Verzeichnisdatenbank.

Der BDC hält die Ressourcen des Netzwerkes bereit und enthält eine Kopie der Verzeichnisse und Benutzerkonten des PDC, außerdem erhöht er die Performance des Netzwerkes, indem z.B. die Userprofiles auf ihm verwaltet werden. So mit wird der PDC entlastet, wenn sich ein Client an einer Workstation anmeldet. Es gibt immer nur einen PDC und beliebig viele BDCs. Wird das Netzwerk noch größer und entstehen größere Entfernungen zwischen den Rechnerstandorten, wird es sinnvoll, mehrere Domänen aufzubauen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0766.htm


Single Domain Model

Bei diesem Domänenkonzept werden alle Benutzer und Ressourcen in einer Domäne zusammengefasst. Dieses Modell ist am einfachsten und bietet sich an, wenn die Zahl der Benutzer kleiner als 15.000 ist und das Netzwerk nicht aus organisatorischen Gründen aufgeteilt werden muss.

Vorteile:

Bestes Domänenkonzept für Netzwerke mit wenigen Benutzern und wenigen Ressourcen (z.B. Ingenieurbüro).

Zentrale Verwaltung der Benutzerrechte.

Keine Verwaltung von Vertrauenstellungen zwischen verschiedenen Domänen notwendig.

Lokale Gruppen müssen nur einmal definiert werden.

Nachteile:

Da alle Anmeldungen über einen zentralen Server laufen, sind die Antwortzeiten bei zu vielen Benutzern oder Gruppen schlecht.

Benutzer und ihre Rechte lassen sich nicht den jeweiligen Abteilungen zuordnen.

Ressourcen, wie z.B. Drucker, lassen sich nicht den jeweiligen Abteilungen zuordnen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0767.htm


Single Master Domain

Dieses Domänenkonzept vereinigt die Vorteile zentraler Benutzerkonten mit der Möglichkeit, das Netzwerk den organisatorischen Gründen zu unterteilen. Es existiert eine Domäne, die Master Domäne, auf der alle Benutzerkonten und globalen Gruppen verwaltet werden. Alle anderen Domänen im Netzwerk vertrauen dieser Domäne und können somit auf die dort gespeicherten Benutzer- und Gruppeninformationen zurückgreifen. Die Master Domäne wird normalerweise vom Rechenzentrum verwaltet. Sie fungiert als zentrale Anmeldestelle für alle neuen Benutzerkonten. Andere Domänen verwalten keine Benutzerinformationen, sondern dienen lediglich als Server Domänen. Dies bedeutet aber auch, dass nur der PDC und die BDC (bzw. Starten DC) der Master Domäne eine Kopie der Benutzerkonten haben.

Vorteile:

  1. Bestes Domänenkonzept für Netzwerke in Unternehmen mittlerer Größe.
  2. Zentrale Verwaltung der Benutzerrechte.
  3. Die Netzwerkressourcen können den Abteilungen zugeordnet werden.
  4. Lokale Administratoren können die Ressourcen ihrer Domäne selbst verwalten.

Nachteile:

  1. Da alle Anmeldungen über einen zentralen Server laufen, sind die Antwortzeiten bei zu vielen Benutzern oder Gruppen schlecht.
  2. Lokale Gruppen müssen in allen Domänen, in denen Sie benötigt werden, eingerichtet werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0768.htm


Multiple Master Domain Model

Dieses Domänenkonzept, das für sehr große Netzwerke entwickelt wurde, entspricht logisch dem Master Domänen Konzept. Es erlaubt aber mehrere Master Domänen, die sich gegenseitig vertrauen. Dadurch können Benutzer von den jeweiligen dezentralen Rechenzentren eingerichtet und verwaltet werden. Da die Server Domänen mindestens einer der Master Domänen vertrauen, gelten die so entstandenen Benutzerrechte im gesamten Unternehmen.

Vorteile:

Bestes Domänenkonzept für Netzwerke in großen Unternehmen mit dezentralen Rechenzentren.

Nachteile:

Verwaltung der Vertrauensstellungen.

Benutzerkonten in verschiedenen Domänen (Eindeutigkeit und Sicherung)

Lokale und globale Gruppen müssen mehrfach definiert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0769.htm


Complete Trust Model

Bei diesem Domänen Modell operiert jede Domäne eigenständig. Der Administrator der jeweiligen Domäne richtet alle Benutzerkonten für seine Domäne ein und verwaltet die Ressourcen seiner Domäne. Der Zugriff auf die anderen Domänen im Unternehmen wird dadurch ermöglicht, dass sich alle Domänen gegenseitig vertrauen. Dieses Konzept war von Microsoft für Unternehmen ohne Rechenzentren gedacht. Die Schwierigkeit bei diesem Ansatz ist, dass er auf der Absprache der jeweiligen Administratoren beruht. Wenn nur ein Administrator mit dem in seiner Domäne gültigen Benutzerrechten nicht sorgfältig umgeht, so sind diese Benutzerrechte unternehmensweit gültig.

Vorteile:

  • Eignet sich für Unternehmen ohne Rechenzentrum.
  • Jede Domäne verwaltet ihre Benutzerkonten und Ressourcen selbst.

Nachteile:

  • Sehr unsicher, hängt von Disziplin und Know-How aller Domänen Administratoren ab.
  • Es müssen evtl. viele wechselseitige Vertrauensstellungen verwaltet werden (für n Domänen n hoch (n-1)).
  • Für Unternehmen mit Rechenzentrum ungeeignet, da sehr unübersichtlich

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0770.htm


Benutzermanager

Sicherheit, die Kontrolle der Zugriffe auf Ressourcen sowie die Echtheitsprüfung des Benutzernamens und des Kennwortes sind die wichtigsten Kriterien, um folgende Punkte optimal zu realisieren:

  • Für jeden Benutzer die richtigen Informationen anzeigen (Profil)
  • Abstimmung der Netzwerksitzung auf jeden Benutzer (User)
  • Die richtigen Zugriffsrechte jedes Benutzers zu verwenden

Windows NT erlaubt die Erstellung von lokalen und globalen Benutzergruppen. Im folgenden wird die Planung und Funktion dieser Gruppen erklärt. Grundsätzlich können sich alle Mitglieder einer globalen Gruppe auf allen Workstations in der Heimatdomäne sowie in vertrauenden Domänen anmelden.

Der große Vorteil einer globalen Gruppe für den Administrator ist, dass er der Gruppe Rechte zuweisen kann, die dann für jeden Benutzer dieser Gruppe gelten. Im Gegenteil würde es schnell im Chaos enden, wollte man jedem einzelnen Benutzer Rechte zuweisen.

Jedes Benutzerkonto wird systemweit durch einen Security Identifier (SID) identifiziert. Diese SID wird durch einen Algorithmus generiert, der die Hardware-Adresse der Netzwerkkarte und die aktuelle Systemzeit als Basis beinhaltet. Sie ist somit weltweit eindeutig und bleibt auch als Sicherheitsinformation für bestimmte NT-Objekte (z.B. Dateien) erhalten, wenn ein Benutzerkonto gelöscht wird. Wird also ein Benutzerkonto eröffnet, dann gelöscht und unter gleichem Namen erneut erzeugt, so hat dieses neue Benutzerkonto nicht die Rechte des alten, da es eine andere SID besitzt.

Sinn und Aufbau von Gruppen.

In den meisten Domänen ist jeder Benutzer Mitglied einer oder mehrerer der unter Windows NT vordefinierten Gruppen. Dadurch hat der jeweilige Benutzer die Möglichkeiten, die ihm seine Gruppen bieten.

Es gibt drei vorgegebene globale Gruppen:

  1. Domänenadministratoren Sie können globale Domänenkonten und Computer in der Domäne administrieren
  2. Domänenbenutzer Alle Benutzer der Domäne sind Teil dieser Gruppe
  3. Domänengäste Mitglieder haben Gastrecht für Ressourcen in der Domäne

Darüber hinaus können Gruppen mit speziellen Rechten kreiert werden. Es gibt zwei vorgegebene, spezielle Gruppen:

JEDER
Die Gruppe JEDER ist die Standardberechtigung, die für jede neu angelegte Ressource oder jedes Verzeichnis vergeben wird. Diese Gruppe kann nicht gelöscht werden.

GÄSTE
GÄSTE sind Mitglieder der Gruppe JEDER und haben somit Zugriff auf alle Verzeichnisse mit der Berechtigung JEDER.

Es ist zu empfehlen, die Gästegruppe zu deaktivieren.

Lokale Gruppen gelten nur für den Rechner (Server oder Workstation), auf dem sie erstellt werden. Es gibt vorgegebene lokale Gruppen für Konto, -Sicherungs, -Replikations, -Server und Druckoperatoren

Globale Benutzer

Sie können nur mit dem Benutzermanager für Domänen erstellt werden. Dieser ist standardmäßig nicht auf Workstations verfügbar, kann aber nachinstalliert werden.

Jeder Benutzer, der regelmäßig auf das Netzwerk zugreift, benötigt ein Benutzerkonto. Dieses Benutzerkonto beinhaltet Informationen über den Benutzer, wie Name und Kennwort, sowie die Zugriffsrechte, die seinen Zugriff auf das Netzwerk regeln. Benutzer, die eine ähnliche Funktion haben oder dieselben Ressourcen benötigen, können zu Gruppen zusammengefasst werden. Diese Aufteilung in Gruppen macht die Rechtevergabe und Verwaltung einfacher, da Sie nicht mehr an den einzelnen Benutzer gebunden ist, sondern jeweils für einen ganze Gruppe von Benutzern durchgeführt werden kann. Hierbei lassen sich Gruppen in lokal (= rechnerspezifisch) und global (= domäneweit) unterscheiden. Benutzer und Benutzergruppen werden mit dem Benutzer-Manager definiert.

Mit dem Dateimanager bzw. dem Explorer können den Benutzern oder den Benutzergruppen Zugriffsrechte auf Dateien oder Verzeichnisse zugewiesen werden. Mit dem Druck-Manager können den Gruppen oder den Benutzern Drucker zugewiesen werden. Ein Benutzerkonto setzt sich aus folgenden Informationen zusammen:

Beschreibung:

  • Benutzername, ein systemweit eindeutiger Name, mit dem sich der Benutzer anmeldet.
  • Kennwort, das nur dem Benutzer bekannte Passwort.
  • Anmeldezeiten, die Zeiten, während derer sich der Benutzer anmelden darf.
  • Anmeldearbeitsstationen, eine Liste der Rechner, von denen sich der Benutzer einloggen darf.
  • max. s Kennwortalter, gibt den Zeitpunkt an, zu dem die Anmeldeberechtigung abläuft. Dadurch lässt sich erreichen, dass bestimmte Anmeldungen zeitlich begrenzt sind (z.B. für Gäste oder Studenten).
  • Basisverzeichnis, ist als privates Verzeichnis des Benutzers gedacht und dient dazu, seine persönlichen Daten zu speichern.
  • Benutzerprofil, beschreibt die für den jeweiligen Benutzer gespeicherte Arbeitsumgebung. Dazu gehören die Programmgruppen, die Netzwerkverbindungen, die Farben und Schriften.
  • Anmeldeskript. Eine Skriptdatei, die während jeder Anmeldung des Benutzers ausgeführt wird.

Die Verwaltung der Benutzer ist sowohl auf einzelnen Windows NT-Maschinen als auch innerhalb einer Domäne eine zentrale Aufgabe zur Gewährleistung eines reibungslosen Betriebs. Nur ein Administrator hat die Rechte, neue Benutzer anzulegen oder die Daten bestehender Benutzer zu modifizieren. Das hierfür verwendete Werkzeug ist der Benutzer-Manager auf NT-Workstations und der Benutzer-Manager für Domänen auf NT-Servern. Beim Anlegen eines neuen Benutzers werden eine Reihe von Daten erfragt, wobei die wenigsten (außer dem Login-Namen) angegeben werden müssen. Jeder Benutzer erhält vom NT-System eine eindeutige ID, die mit seinem Login-Namen gekoppelt ist.

Die folgenden Angaben sollten für jeden neuen Benutzer gemacht werden:

  • Benutzername
  • Eindeutiger Login Name
  • Vollständiger Name, Beschreibung
  • Kennwort (Passwort)
  • Gruppenprofil
  • Login-Skript
  • Zeiten, zu denen man sich in der Domäne anmelden darf (nur bei Benutzern einer Domäne)
  • Computer, auf denen sich ein Benutzer anmelden darf (nur bei Benutzern einer Domäne)
  • Kontoattribute, d.h. Datum, zu dem die Zugriffsrechte enden (nur bei Benutzern einer Domäne)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0771.htm


Planung der Rechtevergabe

Es ist nützlich, eine möglichst natürliche Struktur von Benutzergruppen zu schaffen. In einem Unternehmen könnte das z.B. bedeuten, die hierarchische oder organisatorische Struktur zu übernehmen. So würden Gruppen wie z.B. Buchhaltung, Konstruktion und Geschäftsführung leicht in Funktion und Absicht erkennbar.

Als letztes werden die eigentlichen Benutzerkonten angelegt.

Hier wird wieder zwischen globalen und lokalen Benutzern unterschieden, wobei global wieder domänenweit und lokal wieder rechnerspezifisch meint. Es gibt zwei vorkonfigurierte Benutzer, den Administrator, dessen Kennwort bei der Installation eingegeben werden muss und das Gastkonto. Nachdem die Gruppen feststehen, ist es ratsam, die Netzwerkressourcen und Verzeichnisse festzulegen, denen dann gleich die Gruppen zugeordnet werden können, welche Zugriff haben müssen.

Bei der Vergabe von Zugriffsberechtigungen gibt es zwei Ansätze:

  1. Optimistisch, wobei die Benutzer max. Rechte auf Informationen haben. Dies gilt bis auf spezifische Ausnahmen, bei denen die Informationen für Sie nicht verfügbar sein sollen.
  2. Pessimistisch, wobei die Benutzer Zugriff nur auf solche Informationen haben, die Sie für die Durchführung ihrer Arbeit benötigen. In der Praxis findet meistens eine Mischung aus beiden Varianten Anwendung.

NTFS bietet viele Sicherheitsattribute auf Dateiebene. Dazu gehören Berechtigungen, Überwachung und Besitz.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0772.htm


Freigaben für Dateien und Verzeichnisse

Über den Button <Berechtigungen> öffnet sich ein Fenster, in dem eine Auswahl von Benutzergruppen oder Benutzerkonten getroffen werden kann, die Zugriff auf das Verzeichnis haben sollen. Die Möglichkeiten, hier Rechte zu vergeben, beschränken sich durch FAT auf kein Zugriff, lesen, schreiben und Vollzugriff.

Das Hinzufügen eines $ Zeichens macht das Verzeichnis im Netzwerk unsichtbar.

NTFS erlaubt es, speziellere Rechte zu vergeben, jedoch haben die hier vergebenen Rechte oberste Priorität.

Info Die Datei sam._ im Verzeichnis winnt\system32\repair ist standardmässig für jeden lesbar. Mit einem überall im Internet erhältlichen Brute Force Programm kann jeder, der in Besitz dieser Datei kommt, die Serverpasswörter entschlüsseln.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0773.htm


Fernwartung

Administratoren können nicht darauf verzichten, manchen Server aus der Ferne zu warten. Nur um eine kleine Änderung vorzunehmen, könnten schon erhebliche Kosten entstehen. Windows NT Server Programme können deshalb auf NT Workstation oder Windows 95 Clients installiert und zur Fernwartung eingesetzt werden.

Folgende Werkzeuge stehen für Windows 95 Clients zur Verfügung:

  • Ereignisanzeige zum Anzeigen der System-, Sicherheits- und Anwendungsprotokolle
  • Server Manager zum Verwalten von Server Funktionen,Diensten und Replikationen
  • Benutzer Manager für Domänen zum Verwalten von Konten und Gruppen
  • Explorer Erweiterungen zur Verwaltung der Dateisystem-Sicherheit in NTFS Volumes

Auf einer NT Workstation können die gleichen Werkzeuge - wie auf einem NT Server - von der Server CD nachinstalliert werden

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0774.htm


Verzeichnis Replikation

Der Verzeichnis-Replikationsdienst ermöglicht es, beliebige Daten im Netzwerk als Kopie, quasi als Abo zur Verfügung zu stellen. Es ist sinnvoll, auf einem BDC den Verzeichnis-Replikationsdienst z.B. für die Benutzerprofile zu starten und so im Falle eines Serverabsturzes den Benutzern weiterhin ihre persönlichen Einstellungen zur Verfügung zu stellen.

In der Systemsteuerung unter "Server" -> "Replikation" können die zu replizierenden Verzeichnisse angelegt werden. Nur ein NT Server ist in der Lage zu exportieren, Workstation können nur importieren (das Abo beantragen). Die Konfiguration dieses Dienstes geschieht im "Server Manager" -> "Dienste"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0775.htm


Internet Information Server

Der IIS (Internet Information Server) ist ein Paket von Diensten, die einen funktionsfähigen Internet Host ergeben.

Er unterstützt HTTP und FTP.

Client Applikations sind:

  • Exchange für SMTP und POP
  • FTP für befehlsgesteuerte Downloads
  • Finger für die Suche nach Benutzerinformationen
  • Ping für die Fehlersuche bei Verbindungsschwierigkeiten
  • Nslookup für die Übersetzung von Domänennamen in IP Adressen
  • Rsh für Befehlsübermittlung zu UNIX Hosts
  • Tracert für die Verfolgung von Datenpaketen
  • Telnet für die befehlsgesteuerte Administration von Internet Hosts (Fernwartung)
  • Netstat gibt die aktuell verbundenen Rechner an

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0776.htm


Der Systemmonitor

Heisenbergs Unschärferelation besagt, dass das Messen von Quanteneffekten bedeutet, dass man diese ändert.

Das gleiche Prinzip gilt auch für die Messung von Leistung. Der Systemmonitor nimmt geringe CPU Zeiten in Anspruch. Da die Prozesse, die mit dem Systemmonitor angezeigt werden können, sowieso ständig laufen, kann Heisenberg für die Messung mit dem Systemmonitor vernachlässigt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0777.htm


Der Taskmanager

Er ist etwas schwierig zu finden, wohl weil seine Anwendung zu großen Dateiverlusten führen kann. Mit der rechten Maustaste auf die Startleiste klicken und Task Manager bestätigen bzw. durch Drücken von STRG+ALT+ENTF und auswählen von "Taskmanager".

Der Administrator, der Zugriff auf die Domäne hat, ist jetzt in der Lage, z.B. dem Anwender von Pinball die Anwendung zu schließen, "vielleicht, weil die Mittagspause schon längst beendet ist", oder er sieht, dass jemand mit Winzip arbeitet und kann diesen Anwender warnen, dass er die Anwendung beenden soll, weil der Administrator vom Virenscanner alarmiert wurde, dass infizierte zip-Dateien aus dem Internet geladen wurden.

In Windows NT ist das Tool Systemleistung integriert, mit ihm kann man die Prozessorleistung und Speicherauslastung des Servers und der Workstations anzeigen. Das Bild zeigt die Explorer.exe an, obwohl der Explorer gar nicht gestartet war. Das liegt daran, dass die Explorer.exe für die Präsentation eines Teils der Benutzeroberfläche verantwortlich ist. Beendet man jetzt diesen Task, verschwindet die Taskleiste und alle anderen Objekte des Desktops. Es gibt nur eine Rettung. Der Task-Manager muss noch geöffnet sein, um mit dem Befehl "Neuer Task" die Explorer.exe wieder zu starten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0778.htm


Benutzerüberwachung

In den Überwachungsrichtlinien kann der Administrator festlegen, welche Ereignisse auf den einzelnen Rechnern im Netzwerk überwacht werden sollen.

Man kann im NT-Explorer auf Verzeichniseigenschaften das Register Sicherheit anwählen, um die Überwachung zu aktivieren. Außerdem müssen im Benutzermanager noch die Benutzergruppen ausgewählt werden, die überwacht werden sollen.

Es wird die Anmeldung von Benutzern mit besonderen Privilegien protokolliert. Des weiteren haben wir hier die Überwachung von Benutzerkontenänderungen aktiviert, d.h. der Administrator kann in der Protokolldatei nachvollziehen wer, wann und von wo Benutzer geändert, gelöscht oder neu angelegt hat.

Mit der Option Neustarten, Herunterfahren und System werden alle Neustarts, Systemabschlüsse und Ereignisse die Auswirkungen auf die Systemsicherheit bzw. Scherheitsprotokoll haben protokolliert.

Die letzte Option gibt hilfreiche Aufschlüsse bei der Fehlerdiagnose. Mit ihr werden z.B. DLL-Aufrufe überwacht.

Insgesamt gesehen sind die Überwachungsrichtlinien ein mächtiges Werkzeug. Der Administrator sollte aber genau überlegen, was überwacht werden soll, da für jedes Protokoll nur eine vorgegebene Dateigröße zur Verfügung steht. Nicht zuletzt sollte er bedenken, dass Protokolle auch ausgewertet werden müssen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0779.htm


Der Servermanager

Die Aufgabe der Netzwerkverwaltung ist es, Serverdienste zu verwalten, Daten zu sichern und Verzeichnisse zu kopieren. Die Netzwerkverwaltung wird mit einem kombiniertem Konfigurations- und Überwachungstool verwirklicht, dem Server-Manager.

Der Server-Manager ist in der Windows NT Verwaltung zu finden. Öffnet man den Server Manager erscheint zunächst eine Auflistung aller an das Netzwerk angeschlossenen Computer.

Wählt man einen Rechner mit einem Doppelklick aus, so erscheinen die Eigenschaften dieses Rechners, die da sind:

Anzahl der Sitzungen, offenen Dateien, Dateisperren und Verbindungen zu anderen Rechnern.

Das Eigenschaftenfenster führt zu fünf weiteren Menüs.

  1. Benutzer zeigt an welche Benutzer zur Zeit auf den Rechner zugreifen. Von hier ist es möglich, Benutzer vom Rechner zu trennen - mit oder ohne Vorwarnung.
  2. In Benutzung ist so ähnlich wie Benutzer, zeigt aber auch momentan nicht aktiv verbundene Rechner an.
  3. Unter Freigaben werden alle Ressourcen (z.B. Drucker) aufgelistet und als Unterpunkt die jeweilig berechtigten Benutzer.
  4. Unter Warnungen kann man Personen festlegen, die in kritische Situation oder Systemkonflikten benachrichtigt werden.
  5. Replikation dient zur Konfigurierung des Replikationsdienstes, d.h. die Festlegung von Import oder Exportfunktion von Dateien eines Rechners innerhalb der Domäne. Mit diesem Dienst werden z.B. die Benutzerrechte vom Primary Domain Controller (PDC) auf den Backup Domain Controller (BDC) kopiert, da das Kopieren von Dateien, wie man es unter dem Explorer kennt, zu große Fehlerquellen in sich birgt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0780.htm


Automatische Windows-Updates (alt)

Mit dieser Einstellung können Sie einstellen, dass Windows (nicht) nach Updates sucht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier den Wert "NoAutoUpdate" alle als Datentyp REG_DWORD und stellen Sie die gewünschte Konfiguration ein:

0 | Automatisches Update aktiv
1 | Automatisches Update ausschalten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Automatische Windows-Updates

Info Verwenden Sie die neuen Einstellungen für automatische Updates Tipp: "Automatisches Update konfigurieren", falls Windows 2000 Service Pack 4 bzw. Windows XP ab SP1 installiert ist.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2020.htm


Automatisches Update konfigurieren (neu)

Windows 2000 ab SP3 und XP ab SP1

Mit dieser Einstellung können Sie das "Automatische Update" von Windows konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier die folgenden Werte alle als Datentyp REG_DWORD und stellen Sie die gewünschte Konfiguration ein:

NoAutoUpdate

Dieser Wert gibt an, ob automatische Updates deaktiviert werden sollen. Der Effekt für den Endbenutzer ist im Grunde derselbe wie beim Festlegen von AUOptions=1, außer dass Benutzer die Einstellung nicht ändern können, da sie von der Gruppenrichtlinie kommt.

0 | Automatisches Update aktiv
1 | Automatisches Update ausschalten

AUOptions

Richtlinieneinstellung für die Konfiguration von automatischen Updates. Wenn die Einstellung auf einen anderen Wert als 5 festgelegt ist, darf der Benutzer in der Systemsteuerung nichts konfigurieren.

1 | AU ist deaktiviert (ungültig für die Richtlinie)
2 | Vor dem Download und der Installation benachrichtigen
3 | Download automatisch starten, vor der Installation nachfragen
4 | Automatischer Download und nach Zeitplan installieren (nur gültig, wenn auch gültige Werte für ScheduledInstallDay und ScheduledInstallTime angegeben sind).
5 | Automatische Updates werden durchgeführt, aber Endbenutzer können auswählen, wie sie konfiguriert sein sollen. Diese Option ist neu für Windows Update Services.

ScheduledInstallDay

Gibt den Wochentag an, an dem automatische Updates automatisch Updates installiert werden, wenn AUOptions auf 4 steht.

0-7

0=täglich, 1-7 Wochentage (Sonntag - Samstag)

ScheduledInstallTime

Gibt den Zeitpunkt an, zu dem automatische Updates automatisch Updates installiert werden, wenn AUOptions auf 4 steht.

0-23

Zeit in Stunden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Automatische Updates konfigurieren

Info Bis Windows XP SP1 und Windows 2000 Service Pack 4 wurden diesen Einstellungen auch mit diesem Tipp: "Automatisches Windows Update" durchgeführt. Bei neueren System sollten Sie aber diese Einstellung benutzen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1719.htm


Zeitabstand zur Aufforderung für einen Neustart konfigurieren

Mit dieser Einstellung können Sie die Zeit festlegen, wie lange Windows wartet, bis es wieder zu einem Neustart des Rechner auffordert, wenn das Update einen Neustart benötigt. Der Standardwert liegt bei alle 10 Minuten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "RebootRelaunchTimeoutEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zeitabstand konfigurieren
0 | Standard Zeitabstand (10 Minuten) (Standard)

erstellen Sie weiterhin einen neuen Wert mit den Namen "RebootRelaunchTimeout" als Datentyp REG_DWORD und geben Sie hier die Zeit in Minuten als Dezimal-Wert an, die bis zur nächsten Aufforderung gewartet werden soll.

1-1440

(Zeit in Minuten)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Erneut zu einem Neustart für geplante Installationen auffordern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1876.htm


Automatische Updates sofort installieren

Mit dieser Einstellung können Sie festlegen, ob Updates, die weder die Windows-Dienste noch Windows neu starten (Updates ohne Arbeitsunterbrechungen), automatisch installiert werden.

Wenn Sie diesen Tipp aktivieren, werden die Updates nach dem Download sofort automatisch installiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "AutoInstallMinorUpdates" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Kleinere Updates automatisch installieren
0 | Kleinere Updates wie andere Updates behandeln (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Automatische Updates sofort installieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1874.htm


Windows Software Update konfigurieren

Mit diesem Tipp können Sie einen anderen Server als Updateserver einstellen. Dadurch können Sie im Netzwerk einstellen, dass die Updates nicht von MS, sondern von Ihrem Server geholt werden (SUS). Sie haben dadurch die Möglichkeit die Updates erst einmal zu testen und dann freizugeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "UseWUServer" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eigenen Updateserver angeben
0 | Windows Updateserver (Standard)

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate

erstellen Sie die folgenden Einträge als Datentyp REG_SZ:

WUServer | URL des ersten Updateservers
WUStatusServer | URL des Backup-Updateservers

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Internen Pfad für den Micosoft Updatedienst angeben

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" kostenlos herunterladen

Info Weitere Informationen zu SUS finden Sie bei Microsoft: http://www.microsoft.com/windows2000/windowsupdate/sus/.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1603.htm


Clientseitige Zielzuordnung für Updates im Intranet aktivieren

Mit dieser Einstellung können Sie den Zielruppennamen, der zum Empfangen von Updates vom MS Updatedienst im Intranet verwendet wird, einstellen.

Wenn Sie diese Einstellung aktivieren, wird diese Information an den MS Updatedienst im Intranet gesendet und nur die Updates für diese Gruppe zur Verfügung gestellt.

Info: Diese Informationen werden nur im Intranet versendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate

Erstellen Sie hier einen neuen Wert mit dem Namen "TargetGroupEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Gruppeninformation senden
0 | Keine Gruppeninformation senden (Standard)

anschließend müssen Sie einen Wert mit dem Namen "TargetGroup" als Datentyp REG_SZ anlegen und hier den Namen der Gruppe eingeben.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Clientseitige Zielzuordnung aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Windows Software Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1875.htm


Keinen automatischen Neustart nach dem Update durchführen

Mit dieser Einstellung können Sie einstellen, ob der Anwender den Rechner manuell neu starten muss oder der Rechner automatisch nach der Installation neu gestartet wird.

Wenn der Tipp nicht aktiv ist, wird der Benutzer benachrichtigt, dass der Rechner nach 5 Minuten (kann über "Neustart für geplante Installation verzögern" geändert werden) automatisch neu gestartet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAutoRebootWithLoggedOnUsers" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Keinen automatischen Neustart durchführen
0 | Automatischen Neustart durchführen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Keinen automatischen Neustart für geplante Installationen durchführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1877.htm


Neustart für geplante Installation verzögern

Mit dieser Einstellung können Sie einstellen, wie lange der geplante Neustart verzögert werden soll. Die Standardwartezeit beträgt 5 Minuten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "RebootWarningTimeoutEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Installation um angegebene Zeit verzögern
0 | Standardverzögerung um 5 Minuten (Standard)

und erstellen Sie hier einen neuen Wert mit dem Namen "RebootWarningTimeout" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1-30

Zeit in Minuten (Standard: 5 Minuten)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Neustart für geplante Installation verzögern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

Info Dafür müssen die Einstellungen unter "Keinen automatischen neustart nach dem Update durchführen" deaktiviert sein, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1878.htm


Suchhäufigkeit für automatische Updates

Mit dieser Einstellung können Sie einstellen, in welchen Abständen das System nach neuen Updates suchen soll. Standardmäßig schaut Windows alle 22 Stunden nach, wenn Sie diesen Tipp aktivieren, können Sie die Zeit entsprechend verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "DetectionFrequencyEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zeitabstand für das suchen neuer Updates festlegen
0 | Standardwert von 22 Stunden für Suche nach neuen Updates (Standard)

erstellen Sie weiterhin einen neuen Wert mit dem Namen "DetectionFrequency" als Datentyp REG_DWORD und setzen den Wert auf:

0-22

Zeit in Stunden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Suchhäufigkeit für automatische Updates

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

Info Dafür müssen die Einstellungen unter "Windows Software Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1879.htm


Wartezeit nach Systemstart: Bevor ein Update durchgeführt werden soll

Mit dieser Einstellung können Sie einstellen, wie lange der automatische Updates beim Systemstart abwarten sollen, bevor Updates einer verpassten geplanten Installationszeit angewendet werden. Wenn der Wert nicht vorhanden ist, wird das Update 1 Minute nach dem Systemstart durchgeführt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "RescheduleWaitTimeEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Wartezeit bis zum ausführen des Updates angeben
0 | Erst zu nächsten geplanten Installationszeitpunkt installieren

erstellen Sie weiterhin einen neuen Wert mit dem Namen "RescheduleWaitTime" als Datentyp REG_DWORD und setzen den Wert auf:

0-60

Zeitraum in Minuten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Zeitplan für geplante Installationen neu erstellen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Dafür müssen die Einstellungen unter "Automatisches Update konfigurieren" aktiviert werden, ansonsten haben die Einstellungen hier keine Auswirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1880.htm


Integrieren von Hotfixes in die Installation

Es wurde an anderer Stelle schon beschrieben, wie Sie das Service Pack in die original Installationsdateien integrieren können. Meist gibt es aber von MS noch Hotfixes, die noch nicht in dem Service Packs enthalten sind - auch diese können Sie einbinden.

Viele neue Hotfixes lassen sich jetzt auch in die Sourcen der Windows CD einfach über einen Parameter einbinden. Dafür gehen Sie folgendermaßen vor:

  1. Laden Sie Hotfix herunter
  2. Die meisten Hotfix können über: <Hotfixname.exe> /integrate:<Pfad>in das Installationsverzeichnis eingebunden werden. Dazu müssen Sie die Sourcen wie im Tipp "Das Windows Service Pack in die original Installationsdateien einbinden" beschrieben vorher von der Windows CD auf die Festplatte kopieren.
  3. Beispiel:
  4. "Windows XP-KB887742-x86-DEU.exe /integrate:D:\WinSP", wenn alles funktioniert hat, kommt anschließend eine Messagebox mit der Meldung: "Die integrierte Installation wurde erfolgreich abgeschlossen."

Info Über <Hotfixname.exe> /? können Sie sich die weitere, möglichen Parameter anzeigen lassen.

Info Nach einer Integration von Hotfix-Packs können meist keine Service Packs mehr eingebunden werden. Sie sollten sich also immer eine Sicherung der Originalinstallationsdateien aufheben, um spätere Service Packs einbinden zu können.

Wenn das nicht geht, bleibt noch das alte Vorgehen

  1. Erstellen Sie ein Verzeichnis wie unter "Das Windows Service Pack in die original Installationsdateien einbinden" beschrieben und binden Sie, wie dort angegeben, die aktuellen Service Packs ein.
  2. Öffnen Sie unter <Verzeichnis>\I386 die Datei DOS NET.INF und fügen Sie unter der Sektion [OptionalSrcDirs] (wenn die Sektion nicht vorhanden ist, erstellen Sie diese einfach) am Ende der Datei folgendes ein: svcpack. Der Eintrag sollte nun wie folgt aussehen:

    3. [OptionalSrcDirs]
    svcpack

  3. Legen Sie das Verzeichnis unter <Verzeichnis>\I386\ mit dem Namen "svcpack" an.
  4. Kopieren Sie alle gewünschten Hotfixes in das Verzeichnis. Dabei müssen Sie die Dateien aber so umbenennen, dass Sie alle Zeichen nach dem ersten Unterstrich ("_") entfernen.

    5. Beispiel:
    Aus der Datei Q315000_WXP_SP1_x86_ENU.exe wird Q315000.exe, welche in das Verzeichnis <Verzeichnis>\I386\svcpack kopiert wird.

  5. Entpacken Sie danach die jeweiligen Service Packs mit dem Parameter -x.

    6. Beispiel: Q315000.exe -x
    Sie werden gefragt, in welches Verzeichnis die Dateien entpackt werden sollen. Geben Sie hier ein beliebiges temporäres Verzeichnis an, da die Dateien sowieso wieder umkopiert werden müssen z.B.: <Laufwerk>\Temp\Q315000

    Jetzt müssen Sie die entpackten Dateien nach folgenden Kriterien kopieren:
    - Alle Dateien mit der Endung CAT in den Ordner svcpack
    - Kopieren Sie alle übrigen Dateien in das jeweilige Verzeichnis, in dem sich auch die Originaldateien der CD befinden (meist I386). Dabei werden folgende Dateien nicht benötigt:

    UPDATE.EXE
    UPDATE.INF
    SPMSG.DLL
    SPCUSTOM.DLL
    SPUNINST.EXE
    UPDATE.VER
    und alle Dateien aus dem Verzeichnis \Symbols

    Achtung:

    Beim Kopieren müssen Sie folgendes beachten. Die Dateien gibt es auf der Orginal-CD mit dem gleichen Namen. Hier fehlt nur meist bei der Dateiendung ein Buchstabe, der durch ein "_" ersetzt wurde. Diese Datei müssen Sie unbedingt löschen.

  6. Löschen Sie jetzt die Datei SVCPACK.IN_ und erstellen Sie eine neue Datei mit dem Namen SVCPACK.INF mit folgendem Inhalt.

    für Windows 2000:

    [Version]
    Signature="$Windows NT$"
    MajorVersion=5
    MinorVersion=0
    BuildNumber=2195

    [SetupData]
    CatalogSubDir="i386\svcpack"

    [ProductCatalogsToInstall]
    Q315000.CAT

    [SetupHotfixesToRun]
    Q315000.EXE /q /n /z

    für Windows XP:

    [Version]
    Signature="$Windows NT$"
    MajorVersion=5
    MinorVersion=1
    BuildNumber=2600

    [SetupData]
    CatalogSubDir="i386\svcpack"

    [ProductCatalogsToInstall]
    Q315000.CAT

    [SetupHotfixesToRun]
    Q315000.EXE /q /n /z

  7. Unter [ProductCatalogsToInstall] und [SetupHotfixesToRun] müssen Sie jeweils die eingebundenen Hotfixes mit aufnehmen, wie für das Beispiel Q315000 gezeigt.

Jetzt können Sie die CD wie unter "Das Windows Service Pack in die original Installationsdateien einbinden" beschrieben weiter erstellen.

Info Weitere Informationen dazu finden Sie unter: http://support.microsoft.com/?kbid=296723

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1364.htm


Ramdisk für Windows 2000/XP/2003 und Vista

Wozu ist eine RAM-Disk gut?

Als eine RAM-Disk wird ein virtueller, temporärer Datenträger bezeichnet, welcher im Arbeitsspeicher eines Rechners abgelegt wird. Man benutzt eine RAM-Disk hauptsächlich dafür, wenn andere physikalische Speichermedien zu langsam sind und der Arbeitsspeicher nicht direkt benutzt werden kann.

Für die RAM-Disk wird beim Erstellen ein gewisser Teil des Arbeitsspeicher für die RAM-Disk reserviert und steht somit nicht mehr als Arbeitsspeicher für Windows oder andere Anwendungen zur Verfügung.

Dieser Speicher kann jetzt über die RAM-Disk wie eine Festplatte angesprochen und benutzt werden. Da sich dies RAM-Disk im Speicher befindet, ist der Zugriff auf diese Festplatte schneller, als wenn man auf eine richtige Festplatte zugreift.

Die Daten auf der RAM-Disk gehen beim Abschalten des Rechner verloren und müssen vorher entsprechend gesichert werden.

Einrichten und Installieren einer RAM-Disk

Im eigenen PC mit Windows 2000 oder XP haben Sie reichlich Arbeitsspeicher eingebaut. Nun möchten Sie einen Teil des Speichers als Ablage für temporäre Dateien nutzen und dazu eine Ramdisk einrichten.

Unter Windows 95/98 gibt es den mitgelieferten Treiber RAMDRIVE.SYS.

In Windows 2000/XP suchen Sie Vergleichbares vergebens. Sie können unter Windows 2000/XP eine Ramdisk mit einem kostenlosen Treiber von Microsoft nachrüsten.

Der englische Knowledge-Base-Artikel bietet einen Link zur Download-Adresse des Treibers:

http://support.microsoft.com/?kbid=257405 (57 KB).

Info Einen geänderte Version für Windows Vista "Gavotte Ramdisk" finden Sie hier: http://www.winfaq.de/download/ramdisk.zip (Version 1.0.4096.4 vom 2008-01-25). Entpacken Sie für die Installation die ZIP-Datei in ein beliebiges Verzeichnis und rufen Sie anschließend die ramdisk.exe mit administrativen Rechten auf. Klicken Sie anschließend auf den Button "Install Ramdisk", um die RAM-Disk zu installieren. Anschließend müssen Sie die Windows-Sicherheit" mit "Diese Treibersoftware trotzdem installieren" bestätigen, da die Signatur nicht unter Vista bekannt ist.

Die Datei RAMDISK.EXE ist ein selbstentpackendes Archiv, das Sie per Doppelklick in ein beliebiges Verzeichnis dekomprimieren. Den Ramdisk-Treiber binden Sie nun als neues Gerät ins System ein.

  1. Öffnen Sie dazu die Systemsteuerung und gehen Sie dort auf "System".
  2. Hier starten Sie den Hardware-Assistenten im Register "Hardware".
  3. Nach der obligatorischen Begrüßungsmeldung wählen Sie im nächsten Fenster "Gerät hinzufügen", klicken dann auf "Weiter" und danach auf "Neues Gerät hinzufügen".
  4. Anschließend markieren Sie die Option "Nein, die Hardwarekomponenten selbst in der Liste auswählen" und klicken abermals auf "Weiter".
  5. Im darauf folgenden Menü wählen Sie als "Hardwaretyp" den Eintrag "Andere Geräte" und klicken im nächsten Dialogfenster auf den Punkt "Datenträger".
  6. Windows 2000/XP verlangt nun nach dem Pfad der Installationsdateien. Geben Sie das Verzeichnis an, in das Sie den Treiber zuvor entpackt haben.

Nach der Installation steht die Ramdisk unter dem Laufwerksbuchstaben "Z": sofort zur Verfügung. Die Standardgröße der Ramdisk nach der Installation beträgt allerdings nur 1 MB.

Um die Größe zu ändern, starten Sie REGEDIT.EXE, denn die Konfiguration erfolgt komplett über die Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Alle Parameter des Treibers finden Sie im Schlüssel

Microsoft Original Treiber:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Ramdisk\ Parameters

Geänderter und erweiterter Treiber:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ RRamdisk\ Parameters

Name | Datentyp | Beschreibung
DriveLetter | REG'_SZ | Weist der Ramdisk den angegebenen Laufwerksbuchstaben zu
DiskSize REG_DWORD

Legt die Größe in Byte fest. Den Wert geben Sie entweder als Hex-Wert oder als Dezimalwert ein.

Die Größe der "Original Microsoft" Ramdisk ist allerdings auf 1F00000 (hex) limitiert, was einer Größe von rund 31 MB entspricht.

Eine 16 MB-Ramdisk erreichen Sie mit dem Hex-Wert "1000000", mit "800000" würde sie ca. 8 MB fassen. Bei ungültigen Größenangaben verweigert die Ramdisk den Dienst, stört das System aber ansonsten nicht.

Ab RRamdisk (Download: http://www.winfaq.de/download/ramdisk.zip):
MediaType REG_DWORD

Typ des Laufwerkes, Standard ist "Festes Laufwerk":

1 - RAM Disk

2 - Festes Laufwerk

3 - Wechselbares Laufwerk

4 - Diskettenlaufwerk

DiskSizeM

DiskSizeK

 REG_DOWRD Gibt die Größe der RAM-Disk in DiskSizeM (Megabyte) oder DiskSizeK (KByte) an. DiskSizeK hat eine höhere Priorität als DiskSizeM.
SectorsPerCluster REG_DWORD

Gibt die Cluster-Größe pro Sektor an

<= 2MB FAT12 -> Cluster=512

<= 23M FAT16 -> Cluster=512

<=64M FAT16 -> Cluster=1k

<=128M FAT16 -> Cluster=2k

<=256M FAT16 -> Cluster=4k

<=512M FAT32 -> Cluster=2k

<=16G FAT32 -> Cluster=4k
Image | REG_SZ | Gibt ein Image an, welches mit dem Tool "rdutil" erstellt wurde und automatisch geladen wird.

Nach jeder Änderung eines Parameters ist ein Neustart fällig. Sollten Sie die Ramdisk nicht mehr benötigen, können Sie entweder die Größe in der Registry auf Null setzen oder den Treiber über den Hardware-Assistenten wieder de-installieren.

Für diesen Trick möchte ich mich recht herzlich bei Damian Dandik bedanken.

Ein weiteres Programm zum Erstellen einer RAM-Disk für NT/2000/XP finden Sie bei: http://www.arsoft-online.com/index.php?option=com_remository&Itemid=36&func=select&id=2

Eine nicht kostenlose aber auch für Windows Vista und 64-Bit-Systeme geeignete RAM-DISK finden Sie unter: http://www.ramdisk.tk

Die neue Version der "Gavotte Ramdisk" Download: (http://www.winfaq.de/download/ramdisk.zip) läuft jetzt auch unter 64-Bit Systemen.

Info Auf Rechnern, die nur mit NTFS Dateisystemen laufen, muss folgendes angepasst werden:
Ändern Sie während des Aufrufens der Funktion "IoCreateDevice" (Funktion "RamdiskAddDevice" in pnp.c) den Gerätetyp von FILE_DEVICE_VIRTUAL_DISK zu FILE_DEVICE_DISK und rekompilieren Sie dann den Treiber. Starten Sie das System neu, nachdem Sie den Treiber installiert haben, um über den Explorer auf das Laufwerk "Ramdisk" zugreifen zu können.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1260.htm


Installation von Windows 2000

Da Windows 2000 jetzt auch FAT32 unterstützt, können Sie es nun ohne Probleme parallel zu einer vorhandenen Windows 98 Installation installieren. Das Setup erkennt das andere Betriebssystem automatisch und bindet es auch selbständig in das Bootmenü mit ein.

Vorsicht ist geboten, wenn auf Ihrem Rechner schon ein Windows NT installiert ist, welches Sie auch noch weiterhin erhalten möchten. Sie sollten vorher sicherstellen, dass Sie mindestens Service Pack 4 auf Ihrem System installiert haben.

Erst ab Service Pack ist NT 4.0 in der Lage, auch mit NTFS5 umzugehen. Da NT 2000 bei der Installation gnadenlos alle gefundenen NTFS-Partitionen nach NTFS5 umwandelt, würde NT 4.0 ohne Service Pack 4 nicht mehr starten. Sollte Ihnen das trotzdem passieren, starten Sie Ihr System mit NT 2000 und kopieren die Datei NTFS4.SYS aus dem I386-Verzeichnis der NT 2000 CD in das entsprechende Verzeichnis der NT 4.0 Partition als NTFS.SYS. Auch können Sie nachträglich kein NT 4.0 mehr auf diesen Partitionen installieren, da NT ohne Service Pack ja noch nicht mit diesen Dateisystem umgehen kann. Das Kopieren der Installationsdateien auf die Festplatte und das Ersetzen der entsprechenden Dateien mit dem Service Pack 4 führt aber auch hier zum gewünschten Erfolg, aber wer will schon wieder NT 4.0 installieren, wenn er einmal Windows 2000 gesehen hat?

Die Installation können Sie über die bootfähige CD durchführen, oder Sie erstellen sich die Bootdisketten (die sich jetzt auf vier Stück erhöht haben) und führen damit die Installation durch. Alternativ dazu können Sie auch das Installationsverzeichnis auf die Festplatte kopieren und die Installation mit WINNT.EXE starten.

Erfreulicherweise hat MS diesmal nachgedacht; die Installation von der CD wird erst mit einem Tastendruck gestartet. Dadurch ist es nicht mehr nötig, während der Installation und den zahlreichen Bootvorgängen jedesmal die CD herauszunehmen und wieder einzulegen.

Die Möglichkeit, die Bootdisketten über WINNT bzw. WINNT32 erstellen zu lassen, besteht nicht mehr. Dafür gibt es jetzt auf der CD ein Verzeichnis "BOOTDISK", in dem sich zwei EXE-Dateien befinden.

MAKEBOOT.EXE für DOS

MAKEBT32.EXEfür NT

Starten Sie die jeweilige Datei und NT erstellt anhand der IMG-Dateien 4 Bootdisketten.

Sollten Sie die Installation nicht über die Bootdisketten bzw. Boot-CD durchführen, sondern die CD auf die Festplatte (Server) kopieren und dann die Installation von hier aus starten wollen, müssen Sie sich an neue Parameter für den Aufruf der Installation gewöhnen. Gestartet wird die Installation immer noch über die Datei WINNT.EXE bzw. unter NT mit WINNT32.EXE, die Parameter haben sich aber geändert. (Siehe hierzu: Setup Parameter von Windows 2000)

Hier nun der Installationsvorgang in Schritten

  1. Start der Installation
    Zu diesem Zeitpunkt werden Sie durch den Text (F6-Drücken zur Installation eine SCSI-Treibers eines anderen Herstellers) auf die Möglichkeit hingewiesen, andere SCSI-Treiber einzubinden.
  2. NT überprüft die Festplatte auf eine vorhandene NT Installation. Wird eine NT Partition gefunden , zeigt NT sie an, und man kann mit der Taste R die Reparaturfunktion für dieses NT starten oder aber mit ESC eine neue Installation beginnen. Findet NT keine NT Partition, wird die Installation mit ENTER gestartet. Sie haben aber auch hier die Möglichkeit, mit der Taste R eine Reparaturinstallation vorzunehmen.
  3. Wenn Sie die Installation von NT fortgesetzt haben, zeigt Ihnen NT nun alle Festplatten mit evtl. vorhandenen Partitionen an. Hier können Sie nun Partitionen anlegen/löschen und durch die Auswahl einer entsprechenden Partition die Installation fortsetzen
  4. Befinden sich auf dieser Partition Daten, werden Sie darauf hingewiesen, dass ein evtl. vorhandenes Betriebssystem auf dieser Partition nach der Installation nicht mehr korrekt funktionieren könnte. Wenn Sie die Installation fortsetzen wollen, müssen Sie diese Meldung mit C bestätigen.
  5. NT kopiert nun die benötigten Dateien, um die Installation nach einen Neustart im Grafikmodus fortsetzen zu können.
  6. Nach einem Neustart werden Sie vom grafischen Setup-Programm begrüßt. Klicken Sie auf "Weiter"
  7. Windows NT versucht nun die installierte Hardware auf Ihrem Rechner zu finden, das kann einige Minuten dauern.
  8. Jetzt müssen Sie die Ländereinstellungen vornehmen (Gebietsschema und Tastaturlayout)
  9. NT fragt nun nach Ihren persönlichen Informationen (Benutzerinformationen)
  10. In der nächsten Abfrage legen Sie den Computernamen und das Administrator-Passwort fest.
  11. Jetzt werden Sie nach der aktuellen Zeit/Datumseinstellungen gefragt.
  12. Jetzt kommen Sie zur Netzwerkinstallation. Hier können Sie zwischen "Standardeinstellungen" und benutzerdefinierte Einstellungen" wählen.
  13. NT wird die Installation nun vervollständigen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0659.htm


Setup Parameter von Windows 2000/XP

Bei Windows 2000/XP haben sich die möglichen Parameter im Vergleich zu Windows NT erheblich geändert. Hier finden Sie eine Übersicht der Parameter, die Sie bei WINNT.EXE bzw. WINNT32.EXE benutzen können:

Windows 2000

winnt32 [/s:Quellpfad] [/tempdrive:Laufwerk] [/unattend[Zahl]:[Antwortdatei]] [/copydir:Ordner] [/copysource:Ordner] [/cmd:Befehlszeile] [/debug[Ebene]:[Datei]] [/udf:ID[,UDF-Datei]] [/syspart:Laufwerk] [/checkupgradeonly] [/cmdcons] [/m:Ordner] [/makelocalsource] [/noreboot]

Windows XP

WINNT [/s[:Quellpfad]] [/t[:Temporärlaufwerk]] [/u[:Antwortdatei]] [/udf:Kennung[,UDF-Datei]] [/r:Ordner] [/r[x]:Ordner] [/e:Befehl] [/a]

winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons] [/copydir:i386\folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname] [/dushare:pathname] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath] [/syspart:drive_letter] [/tempdrive:drive_letter] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]

Parameter | Beschreibung
/checkupgradeonly | Überprüft, ob es bei einen Upgrade (WIN98, WINNT usw.) zu Problemen kommen kann. Es wird bei NT eine LOG-Datei WINNT32.LOG bzw. bei Windows 95/98 eine Datei UPGRADE.TXT erstellt, wo Sie dann nachlesen können ob es zu Problemen kommen kann. Es wird keine Installation von NT durchgeführt.
/CMD:[Command_Line] | Weist Setup an, vor der Schlussphase von Setup einen bestimmten Befehl auszuführen. Dieser Zeitpunkt liegt nach dem zweimaligen Neustarten des Computers und nachdem Setup die erforderlichen Konfigurationsdaten gesammelt hat, jedoch vor Abschluss von Setup.
/makelocalsource | Kopiert die Quelldateien auf die lokale Festplatte
/syspart:[Laufwerk] | Kopiert die Startdateien auf die lokale Festplatte. Dieser Parameter muss immer im Zusammenhang von /tempdrive verwendet werden.
/unattend | Erstellt ein Update von einer vorherigen Windows 2000 Installation. Alle Benutzereingaben werden von der vorhandenen Installation verwendet.
/unattend[Zeit]:[Antwortdatei] | Die Installation wird ohne Benutzereingaben durchgeführt. Alle Angaben Benutzereingaben werden aus der Datei geholt. Der Parameter [Zeit] gibt an, wie lange NT nach dem Dateikopieren und dem Reboot warten soll.
/tempdrive:[Laufwerk] | Laufwerk, auf dem temporären Dateien abgelegt werden sollen.
/s:[sourcepath] | Legt das Laufwerk fest, auf dem sich die Quelldateien befinden. Sie können auch mehrere /s Schalter für unterschiedliche Server angeben, der erste Server muss aber immer zur Verfügung stehen.
/cmdcons: | Fügt dem Installationsbildschirm eine Reparaturfunktion (Recovery Console) für die durchgeführte Installation hinzu.
/copydir:[Verzeichnisname] | Damit können Sie ein Verzeichnis hinzufügen, welches in Windows 2000 nicht vorhanden ist. Dieses Verzeichnis wird unter dem Windows-Verzeichnis angelegt (z.B.: C:\WINNT\TESTOrdner).
/debug[Level-NR][:Dateiname] | Erstellt ein Fehlerprotokoll mit dem angegebenen Dateinamen. Werden keine Parameter angegeben, wird das Log als C:\WINNT32.LOG als Level 2 erstellt. Die Level bestimmen, wie ausführlich das Protokoll sein soll: Level 0: schwerwiegende Fehler Level 1: Fehler Level 2: Warnungen Level 3: Informationen Level 4: Ausführliche Informationen
/m:[Verzeichnisname] | Legt fest, dass Treiber erst aus diesem Verzeichnis installiert werden sollen. Werden Treiber in diesem Verzeichnis für die Hardware gefunden , haben Sie die Möglichkeit diese Treiber zu verwenden.
/noreboot: | Es wird kein Neustart durchgeführt, wenn Windows das Kopieren beendet hat. Sie haben dann die Möglichkeit, noch weitere Aktionen durchzuführen.
/udf:id[,UDF_file] | Erweiterte Antwortdatei. Diese Datei wird zusätzlich zur Unattend-Antwortdatei benutzt. Alle Einstellungen in dieser Datei setzen gleiche Einstellungen in der Unattend-Datei außer Kraft.
/copysource:Ordner | Erstellt wie "copydir" einen zusätzlichen Ordner. Dieser wird aber nach der Installation automatisch wieder gelöscht.
/dudisable | Deaktiviert das dynamische Update (Windows XP).
/duprepare:Pfadname | Gibt den Pfad zu den Update-Dateien an, die Sie z.B. aus dem Internet heruntergeladen haben (Windows XP).
/dushare:Pfadname | Gibt die Freigabe an, wo Update-Files liegen (Windows XP).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0660.htm


Windows Upgrade-Tauglichkeit testen

Bevor Sie sich für die Installation von Windows entscheiden, können Sie über eine neue Funktion testen lassen, welche Probleme bei einem Upgrade auftreten können. Gehen Sie dazu folgendermaßen vor:

  1. Öffnen Sie eine Eingabeaufforderung
  2. Wechseln Sie auf die CD-Rom in das Verzeichnis I386
  3. Starten Sie die Überprüfung: winnt32 /checkupgradeonly

Nach einigen Minuten (je nach System) finden Sie im Windowsverzeichnis die Datei upgrade.txt, die Ihnen detailliert aufzeigt, wo es Probleme bei der Installation geben wird. Sollten hier zu viele Probleme auftauchen, ist es besser, das System ganz neu zu installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0525.htm


Migrationsreihenfolge von Windows NT 4.0 auf Windows 2000

Bei der Umstellung auf Windows 2000 sollte - wie auch früher - mit dem primären Domänencontroller begonnen werden. Der Grund hierfür liegt bei den SIDs, die automatisch für jeden Computer und Anwender angelegt werden und nur einmal im Netz vorkommen dürfen.

Da Windows 2000 jetzt mit einer Multi-Master-Replikation arbeitet, können Veränderungen wie z.B. das Hinzufügen neuer Benutzer auf allen Domänencontrollern vorgenommen werden. Bei Windows NT 4.0 werden alle Änderungen immer nur auf dem primären Domänencontroller vorgenommen, so dass sichergestellt ist, dass keine doppelten SID entstehen können. Durch dieses neue Vorgehen muss eine zentrale Stelle die Vergabe der SIDs steuern, um doppelte SIDs zu vermeiden.

Diese Aufgabe wird von einem der Domänencontroller übernommen, der als "Betriebsmaster" bezeichnet wird. Dieser Betriebsmaster weist anderen Domänencontrollern einen Pool von "Relativen IDs" (RIDs) zu. Mit diesen RIDs können die anderen Domänencontroller neue SIDs erstellen, die nur einmalig vorkommen. Welcher Rechner der Betriebsmasterwird, wird dynamisch festgelegt.

Da Windows NT 4.0 dieses Konzept nicht kennt, darf es in einem gemischten Windows-Umfeld keinen Windows NT 4.0 primären Domänencontroller mehr geben. Dieser primäre Domänencontroller würde dann ohne Abstimmung mit den Betriebsmaster neue SIDs vergeben, was zu doppelten SIDs im Netzwerk führen könnte. BDC sind aber zulässig und führen zu keinen Problemen.

Sie können bei der Umstellung natürlich auch erst mit den Workstations im Netz beginnen. Da aber natürlich die NT 4.0 Server nicht alle Funktionen zu Verfügung stellen können, sind auch die neuen Funktionen der Workstations eingeschränkt. Aus diesen Grunde ist es sinnvoll, zumindest erst einen NT 2000 Domänencontroller mit Aktive Directory zu installieren, damit auch die Workstation diese Funktionen benutzen können.

Windows 9x Rechner können mit einer neuen Clientsoftware "Active Directory Clients" dann auch auf die neue Struktur von Windows 2000 zugreifen. Für die NT Workstation wird es so eine Clientsoftware nicht geben, hier sollte man auf Windows 2000 umstellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0569.htm


Zweiten Prozessor nachträglich aktivieren

Unter Windows NT war dafür noch ein extra Programm aus dem Windows Resource Kit notwendig. Ab Windows 2000 gehen Sie dafür jetzt folgendermaßen vor:

  1. "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Computerverwaltung"
  2. Im "Gerätemanager" finden Sie unter "Computer" einen weiteren Eintrag, den Sie mit einem Doppelklick öffnen.
  3. Auf dem Reiter "Treiber" klicken Sie nun auf "Treiber aktualisieren" -> "Weiter"
  4. Wählen Sie "Alle bekannten Treiber für das Gerät in der Liste anzeigen... " aus -> "Weiter"
  5. Wählen Sie nun "Alle Hardwarekomponenten dieser Geräteklasse"
  6. Jetzt können Sie aus der Liste die den Treiber für Multiprozessoren installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0461.htm


Deinstallation von Windows 2000

Wollen Sie die Beta-Version von Windows 2000 wieder deinstallieren, gehen Sie je nach vorherigem Betriebssystem folgendermaßen vor:

Sie haben Windows 95/98 und Windows 2000 installiert

  1. Booten Sie mit einer Windows 95/98 Bootdiskette
  2. Geben Sie nun folgende Befehle ein:
    FDISK /MBR
    SYS C:

Jetzt können Sie Ihr Windows wieder von der Festplatte starten

Es sind jetzt nun noch die versteckten Dateien NTLDR, NTDETECT.COM,BOOT.INI und NTBOOTDD.SYSvon der C-Partition zu löschen. Dazu müssen Sie die Dateien jeweils vorher mit Attrib -s -h -r [DATEINAME]freischalten.

Jetzt kommt es nur noch darauf an, wo Sie die Dateien von Windows 2000 hin installiert haben, je nach Partitionstyp und Dateiformat (FAT oder NTFS) können Sie die restlichen Daten im Explorer oder die Partition mit Fdisk löschen. Wenn Sie aber eine erweiterte Partiton auf einem logischen Laufwerk angelegt haben, kann es passieren, dass Ihr DOS -Fdisk diese Partiton nicht löschen kann. Entweder greifen Sie auf einen FDISK Ersatz zurück (siehe: Programme), oder aber Sie booten noch einmal von der NT 2000 CD bis zu dem Punkt wo Sie die Installationspartition auswählen sollen. Hier können Sie auch die Partitionen löschen und damit Windows 2000 endgültig aus Ihren System entfernen

Sie haben Windows NT 4.0 und Windows 2000 installiert

Im Prinzip startet NT 4.0 auch mit den Bootdateien von Windows 2000. Sie bräuchten daher nur Windows 2000 aus der BOOT.INI zu entfernen und die Partition zu löschen. Das hat aber einen Nachteil. Wird NT 4.0 über den neuen Bootloader aufgerufen, ist es nicht mehr in der Lage, CHKDSK zu starten. Sollten also einmal Fehler im Dateisystem auftreten, kann Windows NT diese Fehler nicht mehr beheben. Aus diesen Grunde sollten Sie den Bootloader austauschen.

Benutzen Sie am besten gleich die Dateien aus dem aktuellen Service Pack (entpacken Sie das Service Pack in ein Verzeichnis, indem Sie es mit den Parameter /X aufrufen). Kopieren Sie nun die Dateien NTLDR und NTDETECT.COM in die Startpartition.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0635.htm


Probleme mit ACPI bei der IRQ-Verteilung

Windows versucht bei der Installation, ACPI (Advanced Configuration und Power Management Interface) zu installieren. Da ACPI tief in die Ressourcenverwaltung des PC eingreift (übernimmt die komplette Verwaltung der IRQs), kann es zu Problemen kommen, wenn das Board diese Funktion nicht 100% richtig unterstützt. Wird ACPI benutzt, ignoriert Windows alle IRQ Einstellungen, die im BIOS vorgenommen wurden und auch manuell kann unter Windows nichts an den Einstellungen verändert werden.

Windows aktiviert ACPI eigentlich nur, wenn es ein System findet, was lt. Liste ACPI-tauglich ist bzw. das Datum des BIOS nach dem 01.01.1999 liegt. Aber auch dann kann die Aktivierung von ACPI mehr Probleme als Vorteile bringen. Sollten Sie also Probleme mit der Installation haben bzw. nach der Installation das System mehr schlecht als recht laufen, sollten Sie ACPI vor der Installation deaktivieren (ein nachträgliches Entfernen bringt meist nicht so recht den gewünschten Erfolg und wird auch von MS nicht empfohlen).

Die Möglichkeiten:

  1. Wenn Ihr BIOS die Funktion bietet, ACPI auszuschalten, sollten Sie diese Einstellung hier deaktivieren
  2. Drücken Sie bei der Installation an der Stelle, wo Sie aufgefordert werden, für alternative SCSI-Adapter die F6 Taste zu drücken, einfach die F5 Taste.
    Jetzt sehen Sie eine Liste der unterstützten Computersysteme. Wenn Sie hier jetzt "Standard-PC" auswählen, wird ACPI nicht installiert.

Ist Windows 2000 bereits installiert, entfernt man ACPI wie folgt:

Unter "System" -> "Gerätemanager" -> "Computer" findet sich der Eintrag "ACPI-PC" - nicht zu verwechseln mit "System" -> "Gerätemanager" -> "Systemgeräte" - was leider leicht passiert, da dort die meisten ACPI Einträge sind. Man geht hier auf die Eigenschaften und lässt sich über TREIBER und der Option "alle bekannten Treiber für das Gerät in einer Liste anzeigen..." alle anzeigen und wählt hier "Standard-Computer" -> "Standard-PC".

Jetzt startet Windows 2000 erneut und erkennt alle Geräte neu. Danach ist das System ACPI-frei.

Treten jetzt immer noch Probleme mit den IRQs auf, kann man diese manuell ändern oder im Gerätemanager unter Eigenschaften des Standard-PCs die IRQ-Steuerung komplett deaktivieren. Hier hält sich Windows 2000 dann an die Vorgaben aus dem BIOS.

Siehe auch: "Windows XP mit ACPI Unterstützung installieren".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0484.htm


Standardprogramme unter Software aufführen bzw. erst gar nicht installieren

Standardprogramme unter Software ausführen bzw. erst gar nicht installieren

Ab Windows 2000 können Sie während bzw. nach der Installation die unter "Systemsteuerung" -> "Software" -> "Zubehör und Dienstprogramme" abgelegten Programme weder auswählen noch deinstallieren (ca. 12 MB). Diese Programme werden einfach installiert und können nicht wieder entfernt werden. Unter dieser Gruppe sind folgende Anwendungen aufgeführt:

  • Eingabehilfen-Assistent
  • Kommunikation
  • Multimedia
  • Spiele
  • Zubehör

Wenn Sie diese Programme entfernen wollen, gehen Sie folgendermaßen vor:

Aus dem Verzeichnis "%SYSTEMROOT%\inf" laden Sie die Datei "SYSOC.INF" mit einem Texteditor.

Hier finden Sie im Abschnitt [COMPONENTS] unter "; old base components" hinter jedem einzelnen Abschnitt den zusätzlichen Eintrag "HIDE"

Entfernen Sie dieses HIDE, so dass hier jetzt zwei Kommas hintereinander stehen und speichern Sie die Datei ab. Jetzt können Sie unter Software diese Programme entfernen oder wieder installieren.

Beispiel:

Original | Geändert
Games=ocgen.dll,OcEntry,games.inf,HIDE,7 | Games=ocgen.dll,OcEntry,games.inf,,7

Wenn Sie schon während der Installation von Windows die Möglichkeit der Auswahl haben wollen, müssen Sie folgendes tun:

  1. Kopieren Sie das i386-Verzeichnis von der CD auf einen anderen Datenträger
  2. Entpacken Sie die Datei "SYSOC.IN_" mit folgendem Befehl:
    expand -r sysoc.in_
  3. Öffnen Sie - wie oben beschrieben - auch diese Datei mit einem Texteditor und entfernen Sie den Eintrag "HIDE" aus den Komponenten, die zur Auswahl angezeigt werden sollen.
  4. Bevor Sie jetzt die Installation starten, müssen Sie noch die Originaldatei sysoc.in_entfernen oder umbenennen und die von Ihnen geänderte Datei an diese Stelle kopieren.

Info In dieser Datei gibt es noch einige andere Einträge, die durch HIDE versteckt wurden. Bei diesen ist es aber nicht sinnvoll, diese Anwendungen nicht zu installieren, da sie meist benötigt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0802.htm


Windows 2000 Update kann aktuelle Windows Version nicht feststellen

Wenn Sie unter Windows (NT oder 95/98) eine Updateinstallation von Windows 2000 starten und diese Installation mit der Fehlermeldung abgebrochen wird, dass Windows nicht die aktuelle Windows Version feststellen konnte, kann das an einer fehlerhaften Produkt-ID liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter NT:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\

unter 95/98:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\

ändern Sie den Wert "ProductId" als Datentyp REG_SZ. Geben Sie hier eine gültige Produkt-ID ein.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0805.htm


Falsches Administrator-Passwort bei Unattended-Installation

Wenn Sie bei der Unattended-Installation ein Passwort mitgeben, dieses aber nicht gesetzt wird, kann es am Passwort selber liegen.

Das Problem tritt auf, wenn Ihr Passwort mit einem Sternchen beginnt oder ein Sternchen enthält. Da dieses Sternchen in der Unattended.txt für ein leeres Kennwort steht, kann es dann zu Problemen kommen.

Als Lösung schlägt MS zur Zeit nur vor, in dieser Datei keine Kennwörter zu benutzen, die ein Sternchen enthalten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=257442

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0997.htm


Das Windows Service Pack in die original Installationsdateien einbinden

Windows Service Pack in die Original-Installationsdateien einbinden (Bart's Boot Image)

Ab Windows 2000 können Sie das aktuelle Service Pack in die Erstinstallation mit einbinden und brauchen es nicht mehr nachträglich zu installieren. Das hat auch den Vorteil, dass bei der Nachinstallation von Treibern auch auf das Verzeichnis zurückgegriffen werden kann und man nicht noch einmal das Service Pack installieren muss, wie es noch bei Windows NT nötig war.

Gehen Sie dazu folgendermaßen vor:

  • Kopieren Sie die original Windows CD auf die Festplatte (mit allen Unterverzeichnissen)
    Beispiel (das CDROM Laufwerk ist Z: und die CD wird nach D:\WinSP kopiert):
    xcopy Z:\ D:\WinSP\ /E

    Info: /E wird benötigt, damit auch alle Unterverzeichnisse mit kopiert werden.

Beispiel für Windows XP

(je nach Windows Version kann das Verzeichnis etwas anders aussehen)
  • Nehmen Sie nun die Service Pack CD oder laden Sie sich vom MS Server das aktuelle Service Pack herunter. Hier benötigen Sie aber unbedingt das Service Pack für die "Netzwerk Installation":

Windows 2000:
SP4: http://www.microsoft.com/downloads/details.aspx?FamilyID=1001aaf1-749f-49f4-8010-297bd6ca33a0&displaylang=de

Windows XP:

SP3: http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=5b33b5a8-5e76-401f-be08-1e1555d4f3d4

Info Da die Dateien nach dem Download je nach Service Pack unterschiedlichen heißen (z.B.: Windows XP=-KB835935-SP2-DEU.exe), gehen wir in der weiteren Beschreibung davon aus, dass Sie die Datei umbenannt haben in wsp.exe. Wenn Sie das nicht machen, müssen Sie statt wsp.exe den entsprechenden anderen Namen verwenden.

  • Entpacken Sie nun das Service Pack mit dem Parameter -x in ein beliebiges Verzeichnis. Durch diesen Zwischenschritt können Sie das Laufwerk und das Verzeichnis angeben, wo das Service Pack entpackt abgelegt werden soll:

Der Aufruf würde für unser Beispiel folgendermaßen lauten: D:\wsp.exe -x

Anschließend öffnet sich ein Dialogfenster wo Sie den Pfad angeben können, wo die Dateien abgelegt werden sollen. Wir geben hier D:\wsp als Verzeichnis ein. Anschließend wird das Service Pack von Widnows in das Verzeichnis entpackt.

Info Sie können das einbinden des Service Packs aber auch gleich starten und sich damit das Entpacken (wie oben beschrieben) und einbinden (Punkt 4) als extra Schritte sparen. Dazu starten Sie das einbinden folgendermaßen: [Verzeichnis]:\wsp.exe /integrate:[Verzeichnis]

Also für unser Beispiel: D:\wsp.exe /integrate:D:\winsp

Dabei wird das Service Pack von Windows automatisch in das Temp-Verzeichnis ihres Rechners entpackt und anschließend erst auf das Verzeichnis D:\winsp angewendet.

  • Starten Sie das Service Pack jetzt folgendermaßen:

    Gehen Sie in das Verzeichnis "D:\WSP\i386\update". Dieses Verzeichnis wurde beim entpacken des Service Packs angelegt und geben Sie jetzt folgendes ein:
    Update -S:[Windows Verzeichnis]
    bzw:
    Update /integrate:[Windows Verzeichnis]

    Info: Beide Parameter haben die gleiche Bedeutung. Wenn man UPDATE /? eingibt, wird aber nur noch /integrate: als entsprechender Parameter angezeigt, so das man davon ausgehen kann, das dieser Parameter früher oder später /s ablösen wird, welcher noch aus älteren Service Pack Versionen stammt.

    Für unser Beispiel würde der Aufruf also: Update /integrate:D:\WinSP lauten.

    Info:
    Unter "%SYSTEMROOT%\Svcpack.log" wird ein LOG-File erstellt, mit dem man das Update überprüfen kann.

  • Starten Sie jetzt die neuen Installationen aus diesem Verzeichnis (freigeben oder auf CD-Brennen). Jetzt haben Sie gleich immer ein neues Windows mit dem aktuellen Service Pack.

Eine bootfähige CD erstellen

Benötigt wird:

  • Nero ab Version 5
  • "Bart's Boot Image" oder ISOBUSTER (Freeware-Optionen reichen aus)
  • Die Original-Bootfähige-Windows-CD

    • Bootsektor (Imagedatei) erstellen

    Verfahren:

    Sie können mit dem Tool "Bart's Boot Image", welches Sie unter http://www.nu2.nu/ herunterladen können, leicht den Bootsektor von einer Windows Original CD auslesen. Dazu rufen Sie das Tool einfach in der Eingabeaufforderung mit folgendem Befehl auf: bbie <CD-ROM-Laufwerksbuchstabe>. Sie erhalten dann eine Datei mit dem Namen IMAGE1.BIN, welche den Bootsektor enthält.

    Beispiel: "Bart's Boot Image" - Die Windows CD liegt im Laufwerk Z:

    Das Tool IsoBuster (http://www.smart-projects .NET/isobuster/) bietet diese und weitere Funktionen in einer grafischen Oberfläche:

    ISOBUSTER starten (muss dann auf die eingelegte original CD zugreifen), im linken Treeview den Knoten "Bootable CD", nun im rechten Fenster rechten Mausklick auf die <filename>.img Datei, im Kontextmenü "Extrahieren <filename>.img" wählen und die Datei speichern,

    Nero starten:

    Ein neues Projekt öffnen und dazu "CD-ROM (BOOT)" auswählen. Dabei auf den entsprechenden Tabreitern die jeweiligen Einstellungen vornehmen:

    Tabreiter: Startopt.

  • Unter "Imagedatei" die oben erstelle Imagedatei Datei auswählen
  • "Experten-Einstellungen an" aktivieren
  • "Art der Emulation" : "Keine Emulation"
  • "Startmeldung": lassen
  • "Ladesegment der Sektoren(hex!)" : "07C0"
  • "Anzahl der Sektoren" : "4"

            •

    Beispiel: Nero - Tabreiter: Startopt.
    (Je nach Nero-Version kann die Anzeige entsprechend abweichen)

    Tabreiter:ISO

  • "Datei-Namenslänge": max. 31 Zeichen (ISO-Level 2)" auswählen
  • "Format" : "Mode 1" auswählen
  • "Zeichensatz" : "ISO 9660 (Standard ISO CD-ROM)" auswählen
  • "Joliet" : aktivieren
  • Unter "ISO-Restriktionen lockern" alle aktiviert

            •

    Beispiel: Nero - Tabreiter: ISO
    (Je nach Nero-Version kann die Anzeige entsprechend abweichen)

    Tabreiter: Brennen

  • "CD abschießen (fixieren)" aktivieren

    • Jetzt noch den Inhalt des neuen Windows-Verzeichnisses (hier WinSP) reinkopieren und dann die CD im "Disc-at-Once"–Modus brennen (vor den Brennen sollte Sie vielleicht noch folgenden Tipp beachten: "Integrieren von Hotfixes in die Installation").

    Nero - CD-Inhalt (Beispiel für Windows XP mit SP2)

    Nero - Brennoptionen

    Danach sollten Sie von der CD booten können.

    Info Bedenken Sie aber, dass Sie bei so einer Installation die Installation des Service Packs nicht wieder rückgängig machen können.

    Info Siehe auch "Integrieren von Hotfixes in die Installation".

Info Fehlermeldung nach dem Booten von CD: CDBOOT: Couldn't find NTLDR

Lösung (Nero):
Sie müssen eine neuere Version von NERO benutzen, oder in der Registry im Schlüssel "HKEY_CURRENT_USER\ Software\ ahead\ Nero - Burning ROM\ General" den Wert für "AddISOFileVersion" auf "0" setzen. Nach einem Neustart müssen Sie die CD noch einmal neu erstellen.

Lösung (WinOnCD):
In "HKEY_CURRENT_USER\ SOFTWARE\ CeQuadrat\ WinOnCD\ ISO9660\ AppendVersion" wird "AppendVersion" von "1" auf "0" gesetzt und zwar noch bevor man WinOnCD (Vers. 3.8PE SP1 und höher) aufruft und ein Projekt für die bootbare CD anlegt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1007.htm


Ist mein Rechner für das neue Windows 2000/XP oder 2003 geeignet?

Hier wird beschrieben wie Sie testen können, ob Ihr Rechner für Windows 2000, XP oder 2003 noch geeignet ist.

Für Windows 2000 wurden von MS folgende Mindestanforderungen angegeben:

133 MHz CPU

64 MB Arbeitsspeicher

1 GB Festplattenplatz

Leider weiß man bei diesen Angaben nicht, ob auch die Hardware ohne Probleme unterstützt wird. Auf der Internetseite von MS können Sie in der Hardwarekompatibilitäts Liste nachsehen, ob Ihre Hardware aufgeführt ist. Weiterhin bietet MS ab Windows 2000 die Möglichkeit an, eine Überprüfung der Updateinstallation durchzuführen.

Wenn Sie die Windows CD schon besitzen, starten Sie diese Installation durch den Aufruf von "WINNT /checkupgradeonly" bzw. "WINNT32 /checkupgradeonly". Dabei wird keine Installation von Windows durchgeführt, sondern es wird nur ein Testbericht erstellt, der alle möglichen Probleme aufführt.

Sollten Sie noch kein Windows besitzen und vor dem Kauf diese Überprüfung durchführen wollen, können Sie sich das Programm von MS Server herunterladen: http://www.microsoft.com/windows2000/upgrade/compat/ready.asp

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0806.htm


Programme verlangen Servicepack oder melden falsches Betriebssystem

Viele Programme erkennen Windows 2000 als Windows NT4 und verlangen deshalb bestimmte Versionen des Servicepacks, oder die Programme verweigern unter Windows 2000 direkt den Dienst.

Auf der Windows 2000-CD unter "Support/Tools/" befindet sich eine Light-Version der Microsoft Windows 2000 Support Tools.

Nach der Installation steht das Programm Application Compatibility Tool zur Verfügung. Mit diesem kann man jedes Programm über das eigentliche System täuschen, indem man zwischen den Systemen Windows 95, Windows 98, Windows NT 4 bis Servicepack 5 auswählt.

Siehe auch: Beschreibung des Application Compatibility Tools.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0523.htm


Installation unter anderen Kontext verhinden

Installation unter anderen Kontext verhindern

Wenn Sie diese Policy aktivieren, wird das Dialogfeld "Programm unter anderen Benutzerkennung installieren"bei lokalen und Netzwerkinstallationen entfernt.

Dieses Dialogfeld wird angezeigt, wenn eine Installation mit normalen User-Rechten gestartet wird, aber administrative Rechte für die Installation benötigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRunasInstallPrompt" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Entfernt die Einträge
gelöscht | Einträge werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Keine alternative Anmeldeinformationen anfordern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe auch: Netzwerkinstallation unter anderen Kontext erlauben

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1905.htm


Netzwerkinstallation unter anderem Kontext erlauben

Wenn Sie diese Policy aktivieren, wird das Dialogfeld "Programm unter anderen Benutzerkennung installieren" auch bei Netzwerkinstallationen angezeigt.

Dieses Dialogfeld wird angezeigt, wenn eine Installation mit normalen User-Rechten gestartet wird, aber Administrative-Rechte für die Installation benötigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "PromptRunasInstallNetPath" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Entfernt die Einträge
gelöscht | Einträge werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Anmeldeinformationen für Installation vom Netzwerk anfordern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Wenn der Tipp Installation unter anderen Kontext verhindern aktiv ist, hat dieser Tipp keine Auswirkung mehr.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1906.htm


Erweitertes Loging im GUI-Mode Setup aktivieren

Erweitertes Logging im GUI-Mode Setup aktivieren

Wenn Sie über die Windows-Setup-API einen Treiber installieren, erstellt das Setup in "%windir%\Setupapi.log" eine LOG-Datei mit den entsprechenden Informationen.

Standardmäßig werden hier aber nur Grundinformationen eingetragen. Für eine Fehlersuche kann es aber sinnvoll sein, dass alle Informationen und Änderungen in die Datei eingetragen werden.

Wenn Sie diesen Tipp aktivieren, wird das erweitere Logging aktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup

ändern Sie hier den Wert "LogLevel" als Datentyp REG_DWORD und setzen den Wert auf:

65535 | Erweitertes Loging aktivieren
0 | Standard Loging (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2051.htm


Anwenderdaten (Userprofile) und Programme voneinander trennen

Sehr oft wird die Empfehlung gegeben, Betriebssystem und Anwendungen von den persönlichen Daten zu trennen. Dadurch hat man die Möglichkeit, das System durch ein Image wieder auf einen definierten Stand zurückzusetzen, ohne dabei die persönlichen Daten zu verlieren.

Wie man einzelne Bereiche (Eigene Dateien usw.) verlegt, wird im Tipp "Die Verzeichnisse 'Eigene Dateien' usw. verschieben" beschrieben. Das hat aber keinen Einfluss auf das Profil des Anwenders. Im Profil werden aber Einstellungen für die Anwendungen gespeichert (z.B. E-Mail - Einstellungen von Outlook usw.).

Hier wird beschrieben, wie man das 'ganze Profil' auf ein anderes Laufwerk verlegen kann. Aufgrund der Komplexität wird nicht empfohlen, ein bestehendes Profil zu verschieben.

Falls aber Windows neu installiert wird, kann man mit dem folgenden Vorgehen den entsprechenden Profilordner verlagern.

  1. Legen Sie den ersten Benutzer unter einen beliebigen Namen in Windows an. Dieser Benutzer wird nach dem Verschieben des Profiles gelöscht.
  2. Starten Sie unter diesem Konto regedit.exe, und ändern Sie unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList" den Eintrag "ProfilesDirectory" auf das neue Benutzerverzeichnis ab (z.B. D:\Profile).
    Der alte Wert lautet bei Windows 2000/XP "%SystemDrive%\Dokumente und Einstellungen"; ab Windows Vista entsprechend "%SystemDrive%\Users".
    Windows 2000/XP Profilverzeichnis
  3. Ab Windows Vista: Hier müssen Sie - unter dem oben genannten Registryeintrag - noch den Wert "Public" auf das neue Benutzerverzeichnis (z.B. D:\Profile) ändern. Der alte Wert lautet "%SystemDrive%\Users\Public" .
  4. Ab Windows Vista: Kopieren Sie den Ordner "Public" aus dem Verzeichnis "C:\Users" in das neue Benutzerverzeichnis "D:\Profile\Public".
    Windows Vista Profilverzeichnis
    Info: Die Verzeichnisse sind in der Registry in der richtigen "englischen" Schreibweise angegeben. Der Explorer zeigt die "deutschen" Namen für die Verzeichnisse an. Wenn Sie den Eintrag aus der Registry in die Eingabeleiste des Explorers kopieren, wird automatisch zum richtigen Ordner gewechselt:
    Explorer für Namensauflösung
  5. Windows 2000/XP: Kopieren Sie die Ordner "All Users" und "Default Users" aus dem Ordner "C:\Dokumente und Einstellungen" in den neuen Benutzerordner. Da der Ordner "Default Users" normalerweise nicht im Explorer angezeigt wird, müssen Sie die Einstellung "Geschützte Systemdateien ausblenden" unter Extras -> Ordneroptionen Tabreiter "Ansicht" deaktivieren.
  6. Starten Sie jetzt den Rechner neu und melden Sie sich noch mal mit den alten Benutzernamen an. Erstellen Sie mit diesem Account jetzt die neuen Benutzeraccounts (darunter auch einen neuen administrativen Account), welcher automatisch in dem neuen Benutzerverzeichnis erzeugt werden. Starten Sie dafür aus der Systemsteuerung -> Benutzerkonten um die Benutzerkonten anlegen zu können.
  7. Melden Sie sich jetzt mit diesem Account ab, um sich dann mit einem der neuen Accounts wieder anzumelden.
  8. Löschen Sie über die Benutzerverwaltung den alten Account; anschließend können Sie mit dem Explorer noch die alten Benutzerverzeichnisse löschen:
    2000/XP unterhalb von: "C:\Dokumente und Einstellungen"
    Ab Vista unterhalb von: "C:\Users"
    Das Verzeichnis "Default" sollten Sie im Verzeichnis "C:\Users" bestehen lassen. Der Eintrag wird benötigt, wenn ein neuer Account angelegt wird. Wenn Sie das Verzeichnis auch verschieben wollen, müssen Sie anschließend noch in der Registry den Eintrag "Default" unterhalb von "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList" auf den neuen Pfad anpassen.
  9. Ab Windows Vista: Sie sollten die neuen Benutzerordner noch in die Indizierung mit aufnehmen, damit bei einer Suche die Dateien berücksichtigt werden. Rufen Sie die Indizierungssteuerung über die Systemsteuerung auf. Klicken Sie auf „Ändern“ -> „Alle Orte anzeigen“ und setzen unter „Ausgewählte Orte“ einen Haken im neuen Ordner.
    Indizierungsoptionen

Info Siehe dazu auch noch Tipp: "Ordner 'Dokumente und Einstellungen' auf ein anderes Laufwerk verschieben"

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2577.htm


Fragmentierte Registry verhindert Systemstart

Wie der KB Artikel Q265509 beschreibt, kann Windows 2000 unter Umständen nicht mehr starten, wenn die Systemdatei SYSTEM im Ordner Winnt\system32\config zu stark fragmentiert ist. Der Fehler tritt nur in Zusammenhang mit NTFS-Partitionen auf und wird durch das Servicepack 2 behoben. Wer bereits betroffen ist oder das Servicepack 2 nicht installieren will / kann, muss die Datei von Zeit zu Zeit manuell defragmentieren.

Hierzu startet man den Rechner in der Recovery-Console (Q229716) und kopiert die Datei SYSTEM einfach um:

cd \winnt\system32\config

rename system system.org

copy system.org system

exit

Info Mit Programmen wie Page-Defrag (oder mit anderen kostenpflichtigen Defragmentierern) kann das Problem verhindert werden, da hier unter Windows die Registry defragmentiert wird.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1160.htm


Kein Ruhezustand - Lösungsmöglichkeiten

Wenn Windows 2000 nicht in den Ruhezustand gehen will, kann dies mehrere Ursachen haben.

Das Startlaufwerk sollte über genug Speicherplatz verfügen, da die Ruhezustandsdatei der Größe des RAMs entspricht. Ein paar Megabyte mehr sind aber eigentlich immer nötig.

Weiter können Treiber dafür verantwortlich sein. Gerade bei "fremden" Treibern ist hier eine Prüfung angesagt.

Ist die erste Ursache auszuschließen, prüft man die *.sys-Dateien im Order Winnt\System32\Drivers. Alle Treiber, die nicht das Windows 2000-Datum (10.12.1999) tragen, sind nachträglich aufgespielt. Hier sollte man durch umbenennen oder deinstallieren den Übeltäter finden und ggf. nach neueren Treibern fahnden.

Übrigens gibt Windows 2000 oft SCSI-Adapter und Co als Ursache an, was leider nicht immer stimmt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1061.htm


Ausführlichere Statusmeldungen beim An- und Abmelden

Detaillierte Statusmeldungen beim An-/Abmelden

Zur Erleichterung der Fehlersuche kann es oft sehr hilfreich sein, wenn genauere Statusmeldungen als gewöhnlich ausgegeben werden.

Erstellen Sie dazu in der Registry einen neuen Eintrag:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

erstellen Sie einen neuen Wert mit dem Namen "VerboseStatus" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Erweitere Statusmeldungen aktivieren
gelöscht | Normale Statusmeldungen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Ausführliche im Vergleich zu normalen Meldungen

Info Dieser Eintrag zeigt nur Wirkung, wenn das Ausgeben von Meldungen nicht unter "HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\Policies \ System\ DisableStatusMessages" deaktiviert wurde.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1055.htm


Windows SplashScreen beim Booten ausschalten

Um den Splash Screen (Startbildschirm) beim Starten von Windows abzuschalten, muss man einfach in der BOOT.INI die Option: /noguiboot hinzufügen.

Wenn Sie diesen Schalter setzen, wird der Grafiktreiber, der dafür notwendig ist, den Bootvorgang grafisch darzustellen, nicht geladen. Dieser Treiber wird zur Anzeige des Bootvorgangs verwendet und um bei einem "Blue Screen" die Informationen auszudrucken.

Info Genauere Informationen zum Umgang und weitere Parameter zur BOOT.INI finden Sie unter "Informationen über die BOOT.INI"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1013.htm


Script beim An-/Abmelden oder Starten/Herunterfahren von Windows ausführen

Ab Windows 2000 können Sie beim An-/Abmelden oder beim Starten/Herunterfahren von Windows Scripts ausführen lassen. An dieser Stelle können Sie CMD-Dateien oder VB-Scripts einfügen, die dann ausgeführt werden.

Gehen Sie dazu folgendermaßen vor:

  1. Erstellen Sie ein beliebiges VB-Script (oder eine CMD-Datei)
  2. Speichern Sie das Script im entsprechenden Verzeichnis ab:

    Script für das Starten:
    Verzeichnis: %SYSTEMROOT%\System32\GroupPolicy\Machine\Scripts\Startup
    Script für das Herunterfahren:
    Verzeichnis: %SYSTEMROOT%\System32\GroupPolicy\Machine\Scripts\Shutdown

    Script für das Anmelden:
    Verzeichnis: %SYSTEMROOT%\System32\GroupPolicy\User\Scripts\Logon
    Script für das Abmelden:
    Verzeichnis: %SYSTEMROOT%\System32\GroupPolicy\User\Scripts\Logoff

    Für lokale Systeme in der Domäne müssen Sie das Script unter "%SysVolFolder%\Sysvol\Sysvol\Domainname\Scripts" ablegen.
  3. Starten Sie die Management Konsole ("Start" -> "Ausführen". Geben Sie MMC ein)
  4. Fügen Sie das benötigte Snap-In hinzu:
    "Konsole" -> "Snap-In hinzufügen/entfernen.." -> "Hinzufügen" -> "Gruppenrichtlinie" -> "Fertig stellen" -> "Schließen" -> "OK"
  5. Klicken Sie auf "Konsolenstamm" -> "Richtlinien für Lokaler Computer" jetzt wählen Sie für Starten/Herunterfahren "Computerkonfiguration" bzw. für An/Abmelden "Benutzerkonfiguration" aus.

Jetzt können Sie unter "Windows-Einstellungen" -> "Skripts" die jeweilige Funktion anklicken und das Script hinzufügen.

Klicken Sie z.B. auf "Abmelden", erscheint eine BOX, in der die auszuführenden Scripte angezeigt werden. Hier können Sie nun über "Hinzufügen" weitere Scripts einfügen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1004.htm


Die Windows 'Recovery Console' (Wiederherstellungskonsole)

Windows "Recovery Console" (Wiederherstellungskonsole)

Wenn es Probleme mit Windows gibt, können Sie, anders als bei NT 4.x, nicht nur mit der "Repair Disk" (Notfalldiskette) arbeiten, um die Fehler zu beheben, sondern es wird Ihnen jetzt auch eine "Recovery Console" zur Verfügung gestellt.

Mit der "Recovery Console" können Sie auf das NTFS-Dateisystem zugreifen, auch wenn Windows selber nicht mehr startet. So mit ist es möglich, noch wichtige Daten zu sichern oder einen fehlerhaften Treiber, der das Starten von Windows verhindert, einfach zu löschen.

Um die "Recovery Console" zu starten, gehen Sie folgendermaßen vor:

  1. Legen Sie die Windows CD in der Laufwerk und booten Sie von der CD (oder benutzen Sie die Windows Bootdisketten)
  2. Drücken Sie in der ersten Auswahl "R" für die Reparaturfunktion und dann "C" für die "Recovery Console"
  3. Windows startet jetzt ein kleines Betriebssystem ohne grafische Oberfläche, womit Sie auf alle Laufwerke zugreifen können.

Wenn Sie die "Recovery Console" öfter brauchen oder lieber im Windows Bootmenü haben wollen, können Sie mit folgendem Aufruf die "Recovery Console" auf Ihrem System installieren:

Sie müssen die CD einlegen, von der Sie Windows installiert haben. Dann öffnen Sie über "Start" -> "Ausführen" durch die Eingabe von CMD.EXE die Kommandozeilenoberfläche. Hier jetzt auf das CD-Laufwerk wechseln, in der Sie die CD eingelegt haben (z.B. E:\ - wenn es Laufwerk E ist). Nun mit dem Befehl "cd I386" in das I386-Verzeichnis der CD gehen. Dort durch Eingabe von "winnt32 /cmdcons" (Leerstelle beachten) die Installation starten.

Jetzt werden die notwendigen Dateien (ca. 7 MByte) auf die Festplatte kopiert, und der Eintrag zum Starten der "Recovery Console" wird in die Boot.ini eingetragen.

Info Kommt dabei die Fehlermeldung "Das Setupprogramm kann nicht fortgesetzt werden, da die Version von Windows auf dem Computer neuer ist als die Version auf der CD", haben Sie inzwischen ein neueres Service-Pack installiert. Hier müssen Sie jetzt eine neuere Installations-CD mit integriertem Service Pack erstellen, wie es im Tipp: "Das Windows Service Pack in die original Installationsdateien einbinden" beschrieben wird.

Was kann ich unter der "Recovery Console" alles machen?

In der "Recovery Console" stehen Ihnen alle Kommandozeilenbefehle zur Verfügung. Eine Liste der Befehle können Sie sich mit "Help" anzeigen lassen. Die wichtigsten Befehle in diesem Zusammenhang sind meist folgende:

fixmbr | Repariert den Masterboot-Record
fixboot | Schreibt den Bootrecord
diskpart | FDISK von Windows 2000
chkdsk | Überprüfung der Partition

Um den MBR wieder herzustellen, gibt es auch ein Tool MBRFIX, womit Sie den MBR einfach wieder herstellen können:

Info: http://www.sysint.no/nedlasting/mbrfix.htm

Donwload: http://www.sysint.no/en/Download.aspx

Beispiel Aufruf: MbrFix /drive 0 fixmbr

Info Sie brauchen keine Angst haben, dass Leute damit ohne weiteres auf Ihre Daten zugreifen können, auch hier wird eine Benutzeranmeldung verlangt.

Info Weitere Informationen dazu finden Sie bei MS unter Zugreifen auf die Wiederherstellungskonsole beim Starten: http://support.microsoft.com/?kbid=307654
Leistungserweiterung der Wiederherstellungskonsole durch Verwenden von Gruppenrichtlinie: http://support.microsoft.com/?kbid=310497

Info Wenn Sie die Wiederherstellungskonsole nach dem Auftreten eines Fehler/Absturzes starten, sollten Sie, bevor Sie mit anderen Reparaturfunktionen anfangen, die Verzeichnisstruktur reparieren/kontrollieren lassen. Geben Sie dafür folgenden ein: Chkdsk <Laufwerk> /f /r

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1011.htm


Willkommensmeldung von Windows unterbinden

Wenn sich ein Anwender das erste Mal an Windows 2000 anmeldet, wird Ihm die Willkommensmeldung von Windows 2000 angezeigt. Hier hat man jetzt die Möglichkeit, durch Setzen einer Checkbox, ein künftiges Anzeigen dieser Meldung zu unterbinden.

Durch das Setzen eines Registry-Wertes können Sie beeinflussen, ob die Meldung angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie einen neuen Eintrag mit dem Namen "NoWelcomeScreen" als Datentyp REG_DWORD, folgende Werte können Sie jetzt einstellen:

0 | Der Willkommensbildschirm wird angezeigt (Standard)
1 | Der Willkommensbildschirm wird nicht mehr angezeigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Anmeldung
Einstellungsname: | Willkommenseite für "Erste Schritte" bei der Anmeldung nicht anzeigen

Info Das Anzeigen der Willkommensmeldung kann über "Start" -> "Programme" -> "Zubehör" -> "Systemprogramme" -> "Erste Schritte" wieder aktiviert werden. Ist der Registry-Wert "NoWelcomeScreen" aber auf 1 gesetzt, wird diese Einstellung nicht beachtet und der Willkommensbildschirm wird nicht angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0946.htm


Wiederherstellungskonsole ins Bootmenü aufnehmen

Die Wiederherstellungskonsole von Windows 2000 befindet sich normalerweise auf der CD. Man kann diese mit dem Befehl

winnt32 /cmdcons

aus dem i386-Verzeichnis der CD aber auch ins Bootmenü von Windows 2000 mit aufnehmen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0864.htm


Deaktivieren eines Dienstes, der den Start von Windows verhindert

Wenn ein Dienst oder ein Gerätetreiber automatisch gestartet wird und nicht kompatibel mit der aktuellen Version von Windows 2000 ist, lässt der Dienst oder der Gerätetreiber möglicherweise nicht zu, dass Windows 2000 lange genug läuft, damit Sie den Dienst beenden oder den veralteten Gerätetreiber deaktivieren können.

Um dieses Problem zu beheben, starten Sie die Wiederherstellungskonsole, und melden Sie sich unter Verwendung der folgenden Schritte bei dem Computer an:

  1. Starten Sie den Computer mit den Windows 2000-Startdisketten oder mit der Windows 2000-CD, wenn der Computer Starten vom CD-ROM-Laufwerk unterstützt.
  2. Wenn das Dialogfeld "Willkommen bei Setup" angezeigt wird, drücken Sie R zum Reparieren und drücken anschließend C, um die Wiederherstellungskonsole zu starten.
  3. Wählen Sie die Installation von Windows 2000 aus. Melden Sie sich mit dem Administratorkonto bei dem Computer an.
  4. Wechseln Sie zum Ordner "%SYSTEMROOT%\System32", geben an der Eingabeaufforderung "listsvc" (ohne Anführungszeichen) ein und drücken anschließend die Eingabetaste.
  5. Suchen Sie in der angezeigten Liste den Dienst oder den Treiber, der das Problem verursacht.
  6. Geben Sie "disable <Dienstname>" (ohne Anführungszeichen) ein, wobei <Dienstname> der Name des Dienstes ist und drücken anschließend die Eingabetaste.
  7. Hinweis: Der Befehl "Disable" zeigt den alten Starttyp des Dienstes an, bevor er auf SERVICE_DISABLED zurückgesetzt wird. Sie sollten sich den alten Starttyp notieren, falls der Dienst erneut aktiviert werden muss.
  8. Geben Sie exit ein. Der Computer wird automatisch neu gestartet. Lassen Sie den Computer Normal starten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=244905

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0917.htm


Ausführen von RUN-Einträgen in der Registry ausschalten

Normalerweise werden vom Computer beim Start des Rechners auch die Einträge in der benutzerdefinierten Startliste ausgeführt. Wenn Sie diese Policy aktivieren, werden diese Einträge nicht mehr gestartet.

Das betrifft die Einträge unter:

Anwender: HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Windows\ Run

System: HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows\ Run

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableCurrentUserRun" als Datentyp REG_DWORD

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLocalMachineRun" als Datentyp REG_DWORD.

Setzen Sie die Werte auf:

1 | Einträge werden nicht ausgeführt
0 | Einträge werden ausgeführt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Anmeldung
Einstellungsname: | Herkömmliche Ausführungsliste nicht verarbeiten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1345.htm


Anmeldescript bei der Ausführung anzeigen

Mit diesem Tipp können Sie einstellen, dass Logon-Scripts beim Anmelden angezeigt werden. Anmeldeskripts sind Batchdateien von Anweisungen, die während der Benutzeranmeldung angezeigt werden. Standardmäßig werden die Anweisungen in Anmeldeskripts nicht angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "HideLogonScripts" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Anmeldescript wird nicht angezeigt (Standard)
0 | Anmeldescript wird angezeigt

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Anmeldeskripts sichtbar ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1463.htm


Benutzerdefinierte Startlisten nicht ausführen

Normalerweise wird von Computer beim Start des Rechners auch die Einträge in der Benutzerdefinierten-Startliste ausgeführt. Wenn Sie diese Policy aktivieren, werden diese Einträge nicht mehr gestartet.

Das Betrifft die Einträge unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows\ Run

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLocalUserRun" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Einträge werden nicht ausgeführt
0 | Einträge werden ausgeführt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1457.htm


Einträge unter RunOnce bei Start nicht ausführen

Normalerweise werden vom Computer beim Start des Rechner die Einträge unter dem Registry Key RunOnce einmalig ausgeführt. Wenn Sie diesen Wert aktivieren werden die Einträge ignoriert.

Das betrifft die Einträge unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ RunOnce

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLocalUserRunOnce" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Einträge werden nicht ausgeführt
0 | Einträge werden ausgeführt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Unabhängig von diesem Registry-Key werden RunOnce-Einträge nie ausgeführt, wenn der Benutzer, der sich einloggt, nicht das Recht hat, den RunOnce-Wert aus der Registry zu löschen. Loggt sich ein "normaler" User ein (ohne Admin-Rechte und damit ohne das Recht, Registry-Einträge unter HKLM zu löschen), dann wird der RunOnce-Befehl nicht ausgeführt. (ab Windows XP).

Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=314866

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1460.htm


Shutdown-Scripts während der Ausführung beim Herunterfahren anzeigen

Normalerweise werden Shutdown-Skripts während der Ausführung beim Herunterfahren nicht angezeigt. Für eine Fehlersuche kann es hilfreich sein, wenn solche Skripts während der Ausführung angezeigt werden, weil man somit eventuelle Rückmeldungen auch sichtbar machen kann.

Mit diesem Tipp können Sie das Anzeigen von Skripten aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

ändern Sie hier den Wert "HideShutdownScripts" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Skripte bei der Ausführung anzeigen
1 (gelöscht) | Skripte bei der Ausführung nicht anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Skripts zum Herunterfahren sichtbar ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2619.htm


Maximale Wartezeit für das Ausführen von Gruppenrichtlinienskripts konfigurieren

Mit diesem Tipp können Sie die maximale Wartezeit für das Ausführen von Gruppenrichtlinienskripts konfigurieren. Diese Einstellung legt fest, wie lange das System auf die Ausführung von Skripts, die von Gruppenrichtlinie übernommen wurden, wartet.

Diese Einstellung beschränkt die zugelassene Ausführungszeit - aller von Gruppenrichtlinie festgelegten Skripts- zum Anmelden, Starten und Herunterfahren. Falls Skripts nicht innerhalb der angegebenen Zeit zu Ende ausgeführt wurden, wird der Skriptprozess angehalten und ein Fehlerereignis protokolliert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

ändern Sie hier den Wert "MaxGPOScriptWait" als Datentyp REG_DWORD und geben die gewünschte Wartezeit in Sekunden (als Dezimalwert) an. Es sind Werte zwischen 0 bis 32.000 (als Dezimalwert) erlaubt. Geben Sie den Wert 0 ein, wenn das System so lange warten soll, bis alle Skripts zu Ende ausgeführt wurden.

Standardmäßig kann ein Satz von Skripten bis zu 600 Sekunden (10 Minuten) zum Ausführen verwenden

Info Ein zu kurzes Intervall kann dazu führen, dass vorausgesetzte Vorgänge nicht fertig gestellt werden, und das System zu früh verwendungsfähig erscheint.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Maximale Wartezeit für Gruppenrichtlinienskripts

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2620.htm


Startskripts gleichzeitig ausführen

Mit diesem Tipp können Sie einstellen, dass Startskripts gleichzeitig ausgeführt werden. Startupskripts sind Batchdateien, die vor der Benutzeranmeldung ausgeführt werden. Standardmäßig wird ansonsten ein Startskript nach dem anderen ausgeführt.

Wenn Sie den Eintrag "RunStartupScriptSync" aktivieren (Festlegung auf "0"), wird das Ausführen der Startskripts nicht koordiniert. Folgendermaßen können Startskripts gleichzeitig ausgeführt werden.

Wenn Sie den Eintrag "RunStartupScriptSync" deaktivieren (Festlegung auf "1") oder nicht konfigurieren, kann ein Startskript erst ausgeführt werden, nachdem das vorherige zu Ende ausgeführt wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

ändern Sie hier den Wert "RunStartupScriptSync" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Skripte werden gleichzeitig (parallel) ausgeführt
1 | Skripte werden nacheinander ausgeführt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Startskripts asynchron ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2621.htm


Die Funktion CTRL+ALT+DELETE zum Anmelden deaktivieren

Befindet sich der Rechner nur in einer Workgroup und nicht in einer Domäne, erscheint die Anmeldemaske sofort. Es muss dazu nicht erst noch CTRL+ALT+DELETE (Strg+Alt+Entf) gedrückt werden.

Sobald sich der Rechner aber in einer Domäne befindet, wird von Windows das Anmelden erst nach Drücken dieser Tasten erlaubt. Wenn Sie aber wollen, dass auch hier sofort das Eingabefenster für die Anmeldung erscheint, müssen Sie folgenden Wert in der Registry verändern.

Ab Windows 7 geht es auch über ein Tool:

Klicken Sie auf die Schaltfläche Start und geben Sie im Suchfeld "netplwiz" ein und starten Sie die Anwendung. Klicken auf die Registerkarte Erweitert, aktivieren Sie des Kontrollkästchen bei "Strg+Alt+Entf drücken ist für die Anmeldung erforderlich", und klicken auf OK.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

erstellen Sie einen neuen Eintrag mit dem Namen DisableCAD als Datentyp REG_DWORD und setzen den Wert auf 1, um die Tastenkombination auszuschalten. Wenn Sie den Wert auf 0 setzen, muss man die Tasten wieder drücken.

Standardmäßig ist der Wert nicht vorhanden, Windows benutzt dann folgende Einstellung:

0 | Rechnerkonto befindet sich in einer Domäne
1 | Rechnerkonto befindet sich in einer ARBEITSGRUPPE (Workgroup)

Info Eigentlich sollte man diese Funktion aus Sicherheitsgründen nicht ausschalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1214.htm


Anzeigen von Befehlen im Anmeldescript ausblenden

Anmeldescripts von Windows NT werden unter Windows 2000/XP angezeigt, obwohl ansonsten Windows das ab diesen Versionen nicht mehr macht. Wenn Sie diesen Tipp aktivieren, werden auch diese Scripts nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "HideLegacyLogonScripts" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Logon-Script wird ausgeblendet
0 | Logon-Script wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Legacy-Anmeldeskripts im Hintergrund ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1462.htm


Roaming Profile Eigentümer-Sicherheitsüberprüfung

Ab Windows 2000 SP4 und XP SP1 gibt es eine neue Sicherheitsfunktion. Mit dieser Policy wird überprüft, ob das servergespeicherte Profil wirklich den Benutzer gehört.

Wenn das Profil aber nicht auf einen MS-Server liegt, kann diese Funktion zur folge haben, dass Windows dieses Profil nicht mehr lädt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ Windows\ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "CompatibleRUPSecurity" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Überprüfung wird nicht durchgeführt
0 | Sicherheitsüberprüfung ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1593.htm


Zeitlimit für langsame Netzwerkverbindungen

Mit dieser Einstellung legen Sie fest, ab welcher Geschwindigkeit eine Verbindung als „langsame Netzwerkverbindung“ eingestuft werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ Windows\ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ System

Mit den beiden Werten legen Sie die Schwellwerte fest:

Bei "IP-Netzwerken" über den Wert "UserProfileMinTransferRate" als Datentyp REG_DWORD:

Hier wird die Geschwindigkeit über einen Ping gemessen. Sie geben hier die Minimale Übertragungsrate in kB pro Sekunde an. (Standard: 500 KB/s)

Bei "Nicht IP-Netzwerken" über den Wert "SlowLinkTimeOut" als Datentyp REG_DWORD:

Hier wird die Geschwindigkeit über das Dateisystem ermittelt. Sie geben die Zeit im Millisekunden an, in welcher das Dateisystem auf eine Anfrage reagieren muss. (Standard: 120 Millisekunden)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1589.htm


Mehrfache gleichzeitige Windows Anmeldungen limitieren

Mit einen neuen Tool "LimitLogin" von Microsoft, können Sie eine Limitierung für die gleichzeitigen Anmeldungen festlegen.

Das Programm finden Sie zum Download unter:

http://download.microsoft.com/download/f/d/0/fd05def7-68a1-4f71-8546-25c359cc0842/limitlogin.exe

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2148.htm


Server Wizard ein-/ausblenden

Mit diesem Tipp können Sie den Server Wizard aus-/einschalten, der bei der Anmeldung an einem Windows Server aufgerufen wird. Standardmäßig wird diese Dialogbox bei der Anmeldung an einem Server eingeblendet und enthält Links zu bestimmten Aufgabenbereichen.

Diese Dialogbox können Sie dort auch deaktivieren oder auch über den folgenden Registryeintrag.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Setup\ Welcome

Erstellen Sie hier einen neuen Wert mit dem Namen "srvwiz" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Server Wizard nicht starten
1 | Server Wizard starten (Standard)

Der Server Wizard kann jederzeit über das Startmenü -> "Administrative Tools" -> "Configure Your Server" aufgerufen werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2608.htm


Erweiterte Log-Einträge für die Fehlersuche

Mit diesem Tipp können Sie die Einträge für die Ereignisprotokolleinträge konfigurieren. Gerade bei der Fehlersuche können die zusätzlichen Informationen recht hilfreich sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Diagnostics

Erstellen Sie hier einen neuen Wert mit den folgenden Namen als Datentyp REG_DWORD und setzen den Wert auf 1, um die Funktion zu aktivieren oder auf 0, um die erweiterten Logeinträge wieder auszuschalten:

RunDiagnosticsLoggingGlobal | Anwender/User Information
RunDiagnosticsLoggingGroupPolicy | Protokolliert alle Ereignisse die mit den GPOs zusammenhängen detailliert
RunDiagnosticsLoggingAppDeploy | Protokolliert die Einstellungen der Softwarezuweisungen
RunDiagnosticsLoggingIntelliMrror | Protokolliert die Einstellungen der RIS Richtlinien

Nach einem Neustart des Rechners, finden Sie entsprechend erweitere Informationen in der Ereignisanzeige (Start -> Ausführen -> eventvwr).

Mit dem Wert "AppmgmtDebugLevel" als Datentyp REG_DWORD aktivieren Sie die Protokollierung des Softwarezuweisung. Das LOG wird in die Datei "%windir%\Debug\UserMode\appmgmt.log" geschrieben.

155 | Erweitertes LOG erstellen
0 | Kein erweitertes LOG erstellen

Mit dem Wert "FDeployDebugLevel" als Datentyp REG_DWORD aktivieren Sie die Protokollierung der Ordnerumleitung. Das LOG wird in die Datei "%windir%\Debug\UserMode\fdeploy.log" geschrieben.

15 | Erweitertes LOG erstellen
0 | Kein erweitertes LOG erstellen

Info Siehe dazu auch Tipp:
USER Logfile für Fehlersuche aktivieren
Erweitertes Group Policy Log erstellen
Protokollierung im Gruppenrichtlinien Editor

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.Microsoft.com/?kbid=186454
http://support.Microsoft.com/?kbid=221833

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2617.htm


Secure Desktop Patch

Durch den "Secure Desktop Patch" wird einige Software daran gehindert, über I/O mit dem Desktop zu arbeiten.

Da einige Programme dadurch nicht mehr richtig arbeiten, kann durch Aktivieren folgendes Registry Eintrages der Patch ausgeschaltet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Windows

Erstellen Sie hier einen neuen Wert mit dem Namen "SecureDesktop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | secure
0 | insecure (Funktion nicht mehr aktiv)

Info Bei Windows 2000 erst ab SP1 möglich

Info Weitere Informationen dazu finden Sie unter: http://www.microsoft.com/TechNet/security/bulletin/ms00-020.asp

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1399.htm


Placesbar der Öffnen/Speichern Dialogbox anpassen

Mit diesem Tipp können sie festlegen, welche Einträge im „Öffnen/Speichern“ Dialog in der Placesbar auf der <Linken Seite> angezeigt werden sollen. Sind diese Einträge nicht vorhanden, werden folgende Einträge angezeigt:

  • Verlauf (zuletzt verwendete Dokumente)
  • Desktop
  • Eigene Dateien
  • Arbeitsplatz
  • Netzwerkumgebung.

Sobald sie einen Eintrag anlegt haben, werden nur noch diese Einträge in der Placebar angezeigt. Weiterhin hat diese Einstellung nur auf einige Programme Auswirkungen (z.B. Notepad, Explorer usw.). Andere Programme, wie z.B. WinWord, verwaltet die Placesbar extra.

Wollen sie wieder die Standardeinstellungen haben, müssen sie den Schlüssel "PlacesBar" löschen. Wenn sie nur die Einträge unterhalb von PlacesBar entfernen, werden keine Einträge mehr auf der linken Seite angezeigt. Sobald der Schlüsel "PlacesBar" nicht mehr vorhanden ist, wird wieder die Standardliste angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ comdlg32\ PlacesBar

Erstellen Sie hier einen neuen Wert mit dem Namen "Place[Nummer]".

Für [Nummer] wählen sie einen Wert von 0-4 (es können nur 5 Pfade angegeben werden, größere Nummern werden nicht ausgewertet). Ein gültiger Name wäre somit also Place0 oder Place4.

Fangen sie immer bei 0 an und zählen entsprechend hoch, lassen sie keine Einträge in der Mitte aus.

Als Datentyp können sie REG_SZ oder REG_DWORD benutzen. Benutzen sie REG_SZ, wenn sie einen direkten Pfad zu einem Verzeichnis angeben wollen ( z.B.: E:\Sonstiges). Wenn sie als Datentyp REG_DWORD benutzen, müssen Sie einen Wert aus der unteren Liste angeben, der für einen bestimmten Ordner in Windows steht:

Auswahl | Wert (Hex)
Desktop | 0
Internet Explorer | 1
Programme | 2
Systemsteuerung | 3
Drucker und Faxgeräte | 4
Eigene Dateien | 5
Favoriten | 6
Autostart | 7
Verlauf | 8
Senden An | 9
Papierkorb | A
Startmenü | B
- | C
Eigene Musik | D
Eigene Videos | E
Vorlagen | F
Desktop | 10
Arbeitsplatz | 11
Netzwerkumgebung | 12
Netzwerkumgebung | 13
Fonts | 14
Vorlagen | 15
Startmenü (alle Benutzer) | 16
Programme | 17
Autostart | 18
Desktop | 19
Anwendungsdaten | 1A
Druckerumgebung | 1B
Lokale Einstellungen\Anwendungsdaten | 1C
- | 1D
- | 1E
Favoriten (alle Benutzer) | 1F
Temporäre Internetdateien | 20
Cookies | 21
Verlauf | 22
Anwendungsdaten (alle Benutzer) | 23
%WINDIR% | 24
%SYSTEMROOT% | 25
Programme | 26
Eigene Bilder | 27
Benutzerverzeichnis (Zuletzt verwendet Dokumente) | 28
%SYSTEMROOT% | 29
- | 2A
Programme\Gemeinsame Dateien | 2B
- | 2C
Vorlagen (alle Benutzer) | 2D
Gemeinsame Dokumente | 2E
Verwaltung (alle Benutzer) | 2F
- | 30
Netzwerkumgebung | 31

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Standarddialog "Datei öffnen"
Einstellungsname: | Elemente, die in der Ortsleiste angezeigt werden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1415.htm


Standard Sprache für das System festlegen

Hier können Sie die Systemsprache festlegen, welche Standardmäßig für das System benutzt werden soll. Wenn Sie das machen, werden die Dialoge in der Systemsteuerung zum Ändern der Sprachoptionen deaktiviert.

Ist die Sprache nicht auf dem Zielsystem verfügbar, wird die Standardsprache "Englisch" verwendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "MultiUILanguageID" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

407 | Deutsch
409 | Englisch
c0a | Spanisch
410 | Italienisch
413 | Niederländisch
40b | Finnisch
414 | Norwegisch
406 | Dänisch
40c | Französisch
41d | Schwedisch
40e | Ungarisch
415 | Polnisch
405 | Tschechisch
816 | Portugiesisch
408 | Griechisch
41f | Türkisch
419 | Russisch
411 | Japanisch
412 | Koreanisch
404 | Chinese (Standard)
804 | Chinese (Simpel)
416 | Brasilian
401 | Arabisch

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Regions- und Sprachoptionen
Einstellungsname: | Auswahl der Windows-Menüs und Dialoge einschränken

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1453.htm


Eigene Ordner im Arbeitsplatz ablegen

Eigene Ordner im Arbeitsplatz anlegen

Windows zeigt einige Ordner direkt im Arbeitsplatz an. Hier finden Sie z.B. standardmäßig auch den Ordner "Eigene Dateien". Diese Liste der Ordner können Sie selber erweitern, dafür müssen Sie nur folgende Einträge in der Registry hinzufügen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASS_ROOT\ CLSID

  • Erstellen Sie einen neuen Schlüssel, für ihn müssen Sie eine neue eindeutige CLSID-Nummer erstellen
    (Infos zum Aufbau der CLSID finden Sie hier: Was ist eine CLSID).Der Eintrag in der Registry könnte jetzt z.B. bei Ihnen so aussehen:
    HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}
    Sie müssen hier jetzt folgende neue Schüssel und Werte anlegen:

Einträge unter:

HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}

  • Tragen Sie hier unter (Standard) als Datentyp REG_SZ den Namen des Ordners ein, der im Arbeitsplatz angezeigt werden soll ( z.B.: Privat)
  • Erstellen Sie hier einen neuen Eintrag mit den Namen "InfoTip" als Datentyp REG_SZ.
    Geben Sie als Text eine beliebige Beschreibung für den neuen Ordner ein.

Einträge unter:

HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}\ DefaultIcon

  • Tragen Sie hier unter (Standard) als Datentyp REG_SZ den Pfad und den Dateinamen zur Icondatei an. Sie können dabei auch auf eine DLL mit Icons verweisen.

Einträge unter:

HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}\ InProcServer32

  • Tragen Sie hier unter (Standard) als Datentyp REG_SZ folgendes ein "shell32.dll"
  • Erstellen Sie einen neuen Eintrag mit den Namen "ThreadingModel" als Datentyp REG_SZ. Geben Sie als Wert "Apartment" ein

Einträge unter:

HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}\ Shell\ Open\ Command

  • Tragen Sie hier unter (Standard) als Datentyp REG_SZ die Anwendung ein, die Sie starten wollen (z.B.: explorer /root,c:\).

Einträge unter:

HKEY_CLASS_ROOT\ CLSID\ {11111111-1111-1111-1111-000000000001}\ ShellFolder

  • Erstellen Sie einen neuen Eintrag mit den Namen "Attributes" als Datentyp REG_BINARY. Geben Sie als Wert einen der folgenden gültigen Werte an:
Nummer | Wert für Attributes | Beschreibung
0 | 00000000 | Standard
1 | 020000F0 | Ausschneiden ist erlaubt
2 | 030000F0 | Ausschneiden und Kopieren sind erlaubt
3 | 050000F0 | Kopieren ist erlaubt
4 | 200000F0 | Löschen ist erlaubt
5 | 300000F0 | Löschen und Umbenennen sind erlaubt
6 | 600000F0 | Löschen und Eigenschaften sind erlaubt
7 | 700000F0 | Löschen, Eigenschaften Umbenennen sind erlaubt
8 | 040000F0 | Standard-Menü für Shell Ordner anzeigen
9 | 100000F0 | Umbenennen ist erlaubt
10 | 500000F0 | Umbenennen und Eigenschaften sind erlaubt

Info Die Werte 1,2,3 und 8 können Mit diesem Werten 4,5,6,7,9 und 10 kombiniert werden und ergeben damit die Summe beider Funktionen.

Anschließend muss dieser Eintrag unter den entsprechenden Namespaces Eintragen werden, damit er angezeigt wird:

Anzeigen auf dem Desktop:

Anwender: HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace

Für alle: HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace

Anzeigen unter Arbeitsplatz:

Anwender: HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MyComputer\ NameSpace

Für alle: HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MyComputer\ NameSpace

Erstellen Sie hier jeweils einen neuen Schlüssel, als Namen geben Sie ihre eindeutige CLSID-Nummer von oben ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1510.htm


Internet Explorer Icon auf dem Desktop ausblenden

Wenn Sie diesen Tipp aktivieren, wird das Symbol "Internet Explorer" vom Desktop und von der Schnellstartleiste entfernt.

Diese Einstellung verhindert nicht, dass Benutzer den Internet Explorer anderweitig starten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoInternetIcon" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Internet Explorer Icon ausblenden
gelöscht | Internet Explorer Icon nicht ausblenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Internet Explorer-Symbol auf dem Desktop ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1929.htm


Active Desktop aktivieren

Wenn Sie diese Funktion aktivieren, wird der "Active Desktop" aktiviert und verhindert, dass Benutzer diesen deaktivieren. Dadurch können Benutzer HTML und JPG-Hintergrundbilder benutzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceActiveDesktopOn" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Desktop ist aktiv
gelöscht | Active Desktop ist nicht aktiv, kann aber aktiviert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Active Desktop aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Falls die Einstellungen "Active Desktop aktivieren" (dieser Tipp) und "Active Desktop deaktivieren" aktiviert sind, wird die Einstellung "Active Desktop deaktivieren" ignoriert. Falls die Einstellung "Alte Oberfläche im Windows Explorer" aktiviert ist, dann ist der Active Desktop deaktiviert und beide Richtlinien werden ignoriert.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1932.htm


'Aktive Elemente' nicht zulassen

Wenn Sie diese Funktion aktivieren, werden alle Activen Elemente entfernt und Benutzer daran gehindert, neue hinzuzufügen. Zusätzlich wird die Registerkarte "Web" aus der Systemsteuerungsoption "Anzeige" entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Elemente ausblenden
gelöscht | Active Elemente nicht ausblenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Alle Elemente deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1933.htm


Hinzufügen von 'Aktiven Elementen' unterbinden

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Benutzer Webinhalte zum Active Desktop hinzufügen können.

Durch diese Einstellung wird die Schaltfläche "Neu" von der Registerkarte "Web" aus der Option "Anzeige" in der Systemsteuerung entfernt.

Durch diese Einstellung werden bestehende Webinhalte nicht vom Active Desktop entfernt, und die Einstellung verhindert nicht, dass Benutzer bestehende Webinhalte entfernen (siehe dazu Tipp: Löschen von 'Aktiven Elementen' unterbinden).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddingComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Elemente können nicht hinzugefügt werden
gelöscht | Active Elemente können hinzugefügt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Hinzufügen von Objekten nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1934.htm


Löschen von 'Aktiven Elementen' unterbinden

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Benutzer Webinhalte vom Active Desktop löschen können.

Durch diese Einstellung wird die Schaltfläche "Löschen" von der Registerkarte "Web" aus der Option "Anzeige" in der Systemsteuerung entfernt.

Folgendermaßen können Benutzer nur vorübergehend Webinhalte von ihrem Active Desktop entfernen (siehe dazu Tipp: Schließen von 'Aktiven Elementen' nicht zulassen) aber nicht löschen.

Durch diese Einstellung werden bestehende Webinhalte nicht vom Active Desktop entfernt, und die Einstellung verhindert nicht, dass Benutzer neue Webinhalte hinzufügen können (siehe dazu Tipp: Hinzufügen von 'Aktiven Elementen' unterbinden):

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDeletingComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Elemente können nicht gelöscht werden
gelöscht | Active Elemente können gelöscht werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Löschen von Elementen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1935.htm


Bearbeiten von 'Aktiven Elementen' unterbinden

Bearbeiten von "Aktiven Elementen" unterbinden

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Benutzer Webinhalte im Activen Desktop bearbeiten können.

Durch diese Einstellung wird die Schaltfläche "Eigenschaften" auf der Registerkarte "Web" unter der Option "Anzeige" in der Systemsteuerung deaktiviert. Außerdem wird der Menüeintrag "Eigenschaften" für alle Objekte auf dem Desktop entfernt. Folglich können Benutzer die Eigenschaften eines Objekts nicht ändern, wie z. B. der Synchronisierungszeitplan, das Kennwort oder die Anzeigeeigenschaften.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoEditingComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Elemente können nicht bearbeitet werden
gelöscht | Active Elemente können bearbeitet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Bearbeiten von Elementen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1936.htm


Schließen von 'Aktiven Elementen' nicht zulassen

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Benutzer Webinhalte von ihrem Active Desktop entfernen.

Durch Aktivieren dieser Einstellung können Elemente nicht geschlossen werden, sie erscheinen immer auf dem Desktop. Zusätzlich werden die Kontrollkästchen von den Elementen auf der Registerkarte "Web" in der Option "Anzeige" in der Systemsteuerung entfernt.

Diese Einstellung verhindert nicht, dass Benutzer Elemente von ihrem Active Desktop löschen (siehe dazu Tipp: Löschen von "Aktiven Elementen" unterbinden).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoClosingComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Active Elemente können nicht geschlossen werden
gelöscht | Active Elemente können geschlossen werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Schließen von Elementen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1937.htm


Hinzufügen und Entferen von 'Aktiven Elementen'

Hinzufügen und Entfernen von 'Aktiven Elementen'

Mit Sie diesem Tipp können Sie angegebene Webinhalte hinzufügen oder entfernen.

Unter "Add" können Sie bestimmte, webbasierte Elemente oder Verknüpfungen dem Desktops der Benutzer hinzuzufügen. Benutzer können diese Elemente schließen oder löschen (siehe dazu Tipp: Schließen von 'Aktiven Elementen' nicht zulassen bzw. Löschen von 'Aktiven Elementen' unterbinden), aber die Elemente werden bei jeder Aktualisierung der Einstellung erneut hinzugefügt.

Zusätzlich können Sie über "Delete" bestimmte webbasierter Elemente von den Desktops der Benutzer löschen. Benutzer können diese wieder hinzufügen (siehe dazu Tipp: Hinzufügen von 'Aktiven Elementen' unterbinden), allerdings wird dieses Element bei jeder Aktualisierung der Einstellung wieder gelöscht.

Falls Sie ein Element aus der Liste "Add" in dieser Einstellung entfernen, ist dies nicht dasselbe, als wenn ein Element gelöscht wird. Elemente, die aus der Liste "Add" entfernt wurden, werden nicht vom Desktop entfernt. Sie werden nur nicht wieder erneut hinzugefügt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop\ AdminComponent

Erstellen Sie hier einen neuen Wert mit dem Namen "Add" als Datentyp REG_SZ bzw. "Delete" als Datentyp REG_SZ.

Wertname | Bedeutung
Add | Geben Sie hier die URL der Aktiven Elemente ein, die Sie hinzufügen wollen. Beispiel: http://www.winfaq.de/test.htm
Delete | Geben Sie hier die URL der Aktiven Elemente ein, die Sie löschen wollen. Beispiel: http://www.winfaq.de/test.htm

Wenn Sie mehr als ein Element hinzufügen/löschen möchten, trennen Sie die Angabe durch ein Leerzeichen (Blanc).

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Objekte hinzufügen/entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1938.htm


Active Desktop Hintergrundbild festlegen

Wenn Sie diese Funktion aktivieren, legen Sie den Hintergrund fest, der auf dem Desktop aller Benutzer angezeigt wird.

Geben Sie einen vollständigen gültigen Pfad und Dateinamen ein, wenn Sie diese Einstellung verwenden möchten. Sie können einen lokalen Pfad - wie z. B. C:\Windows\web\wallpaper\home.jpg oder einen UNC-Pfad wie z. B. \\Server\Freigabe\Corp.jpg - angeben.

Es wird kein Hintergrund angezeigt, falls die angegebene Datei bei der Benutzeranmeldung nicht verfügbar ist.

Benutzer können keinen anderen Hintergrund angegeben. Sie können zusätzlich festlegen, ob ein Bild zentriert, nebeneinander oder gestreckt angezeigt werden soll. Benutzer können auch die Bildanzeige nicht selbst bestimmen.

Sie müssen das Active Desktop aktivieren, um diese Einstellung verwenden zu können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "Wallpaper" als Datentyp REG_SZ . Geben Sie hier den Pfad und Dateinamen zum Bild das angezeigt werden soll an.

Erstellen Sie weiterhin hier einen neuen Wert mit dem Namen "WallpaperStyle" als Datentyp REG_SZ.

Setzen Sie den Wert auf:

0 | Zentriert anzeigen
1 | Nebeneinander (Kacheln)
2 | Strecken

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Active Desktop-Hintergrund

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1939.htm


Nur Bitmaps als Hintergrundbilder zulassen

Wenn Sie diese Funktion aktivieren, können nur Bitmaps als Hintergrundbilder benutzt werden.

Mit dieser Einstellung wird der Desktophintergrund auf Bitmapdateien (*.bmp) eingeschränkt. Wenn Benutzer über die Taste Durchsuchen in der Registerkarte Desktop Dateien mit anderen Bildformaten sich einwählen, wie z.B. JPEG, GIF, PNG, oder HTML, wird der Hintergrund nicht geladen. Dateien, die automatisch in ein *.bmp-Format umgewandelt werden, wie z.B. JPEG, GIF, und PNG, können als Hintergrund eingestellt werden, indem mit der rechten Maustaste auf das Bild geklickt und "Als Hintergrundbild" ausgewählt wird.

Siehe auch Tipps "Active Desktop Hintergrundbild festlegen" und "Ändern des Hintergrundbildes verhindern".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoHTMLWallPaper" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Nur Bitmaps zulassen
gelöscht | Alle Standardformate sind zugelassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Desktop
Einstellungsname: | Nur Bitmaphintergrund zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Aktive Elemente:
Mit aktiven Elementen sind z.B. eingebundene Webseiten oder andere Eigenschaften gemeint, die Sie auf dem "Active Desktop" eingebunden haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1940.htm


Ändern des Hintergrundbildes verhindern

Wenn Sie diese Funktion aktivieren, können Benutzer das Hintergrunddesigns des Desktops nicht mehr verändern.

Durch das Aktivieren dieser Einstellung wird dem Benutzer die Registerkarte "Desktop" angezeigt, aber alle Optionen auf der Registerkarte sind deaktiviert.

Standardmäßig können Benutzer über die Registerkarte "Desktop" des Systemsteuerungssymbols "Anzeige" einen Hintergrund dem Desktop hinzufügen.

Verwenden Sie die Einstellung "Registerkarte "Desktop" ausblenden", um die Registerkarte "Desktop" auszublenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ ActiveDesktop

Erstellen Sie hier einen neuen Wert mit dem Namen "NoChangingWallPaper" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Ändern des Hintergrundbildes verhindern
gelöscht | Hintergrundbild kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Ändern des Hintergrundes verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1941.htm


Hinzufügen, Verschieben und Schließen der Symbolleisten in der Taskleiste nicht zulassen

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Benutzer die Desktopsymbolleisten verändern können. Durch Aktivieren dieser Einstellung können Benutzer keine Desktopsymbolleisten hinzufügen oder entfernen.

Zusätzlich können Benutzer Symbolleisten nicht auf die oder von den verankerten Symbolleisten ziehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCloseDragDropBands" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Taskleiste sichern
gelöscht | Taskleiste nicht sichern (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Hinzufügen, Verschieben und Schließen der Symbolleisten der Taskleiste nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Falls Benutzer vorher Symbolleisten hinzugefügt oder entfernt haben, können sie aufgrund dieser Einstellung die Standardeinstellungen nicht wieder hergestellt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1930.htm


Größenänderung der Symbolleisten nicht zulassen

Wenn Sie diese Funktion aktivieren, werden Benutzer dran gehindert, die Länge der Desktopsymbolleisten zu verändern. Außerdem können Benutzer Elemente oder Symbolleisten auf verankerten Symbolleisten nicht verschieben.

Diese Einstellung verhindert nicht, dass Benutzer Desktopsymbolleisten hinzufügen oder entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoMovingBands" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Größe der Taskleiste sichern
gelöscht | Größe der Taskleiste kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Anpassen der Desktopsymbolleisten nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Falls Benutzer vorher Symbolleisten hinzugefügt oder entfernt haben, können sie aufgrund dieser Einstellung die Standardeinstellungen nicht wieder hergestellt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1931.htm


CAB-Dateien werden im Windows Explorer nicht mehr geöffnet

Wenn Sie im Explorer auf ein CAB-File klicken und Ihnen der Inhalt nicht mehr angezeigt wird, liegt es an einer fehlerhaften Registration.

Starten Sie die Eingabeaufforderung "Start" -> "Ausführen" -> "CMD". Geben Sie hier folgendes ein:

Regsvr32 cabview.dll

Jetzt sollte der Explorer auch den Inhalt der CAB-Dateien wieder anzeigen können.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1005.htm


Profilverzeichnis, Startmenü und Homeverzeichnis ab Vista

Die Verzeichnisse 'Eigene Dateien' usw. verschieben

Mit Tweak UI für Windows 2000 (Download) kann man die Ordner für eigene Dateien etc. für jeden Benutzer speziell umlegen. Diese Möglichkeit eignet sich aber nur bei einigen Verzeichnisse wie z.B.: "Eigene Dateien" und "Favoriten".

Weitreichender als mit Tweak UI kann man in der Registry einzelne Ordner manuell auf einen anderen Ordner legen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

gelten folgende Werte:

Name: | Datentyp | Data:
AppData | REG_EXPAND_SZ | %USERPROFILE%\Application Data
Desktop | REG_EXPAND_SZ | %USERPROFILE%\Desktop
Personal | REG_EXPAND_SZ | %USERPROFILE%\My Documents
My Pictures | REG_EXPAND_SZ | %USERPROFILE%\My Documents\My Pictures
Start Menu | REG_EXPAND_SZ | %USERPROFILE%\Start Menu
Favorites | REG_EXPAND_SZ | %USERPROFILE%\Favorites
History | REG_EXPAND_SZ | %USERPROFILE%\Lokale Einstellungen\Verlauf
My Music | REG_EXPAND_SZ | %USERPROFILE%\My Documents\My Music
My Video | REG_EXPAND_SZ | %USERPROFILE%\My Documents\My Video

Ab Windows Vista mit IE7 gibt es für den Internetexplorer eine neue Sicherheitsstufe. Damit der IE in das Verzeichnis schreiben und neue Einträge anlegen kann, müssen Sie auf der Eingabeaufforderung mit dem Tool ICACLS folgenden Befehl ausführen:

icacls [Verzeichnis] /setintegritylevel (CI)(OI)L

Wenn Sie die Favoritenz.B. nach D:\Daten\Favoriten verlegt haben, sieht der Befehl so aus:

"icacls D:\Daten\Favoriten /setintegritylevel (CI)(OI)L"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Wenn ab Windows XP der Eintrag "Personal" geändert wird, sollten Sie folgenden Tipp auch lesen: "Den Pfad im Arbeitsplatz 'Dateien von <%UserName%>' anpassen"

Info Wenn Sie das ganze Verzeichnis 'Dokumente und Einstellungen' verlegen wollen, lesen Sie den Tipp: Ordner 'Dokumente und Einstellungen' auf ein anderes Laufwerk legen

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=242557

Info Weitere Infos finden Sie auch im Tipp "Profilverzeichnis, Startmenü und Homeverzeichnis ab Vista"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0514.htm


Ordner 'Dokumente und Einstellungen' auf ein anderes Laufwerk legen

Ordner 'Dokumente und Einstellungen' auf ein anderes Laufwerk verschieben

In diesem Tipp wird beschrieben, wie Sie den Ordner "Dokument und Einstellungen" auf ein anderes Laufwerk verschieben können.

Windows speichert alle Profile (und somit Benutzerdaten und Einstellungen) auf dem Laufwerk "%SystemDrive%:\Dokumente und Einstellungen".

Den Ordner "Dokumente und Einstellungen" verschieben

Die sicherste Methode ist, das Verzeichnis gleich bei der Installation zu verlegen. Dafür benutzt man die "Unattended"-Installation. Hierbei startet man winnt.exe mit dem Parameter/UNATTEND und übergibt den Pfad des Profiles-Dir in der Datei unattend.txt wie folgt:

[GuiUNattended]

ProfilesDir = D:\Verzeichnisname

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=183245

Wenn Sie Windows schon installiert haben und den Ordner verschieben wollen, müssen Sie folgendermaßen vorgehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Folgendes gilt nur für Benutzerprofil-Verlegung:

  1. Melden Sie sich als Administrator an (nicht als Benutzer, dessen Profil verlegt werden soll).
  2. Erstellen Sie das neue Verzeichnis für das Profil (z.B.: D:\Profiles)
  3. Geben Sie die Rechte auf das Verzeichnis (am Besten die gleichen Rechte - wie Sie auf das Originalverzeichnis von Windows vergeben sind - nämlich: "%SystemDrive%:\Dokumente und Einstellungen").
  4. Gehen Sie unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList". Hier finden Sie jetzt die SIDs aller bestehenden USERPROFILE. Suchen Sie sich Ihren User heraus, in dem Sie auf die SIDs klicken und sich den Pfad im Key "ProfileImagePath" anschauen.
  5. Wenn Sie die entsprechende SID gefunden haben, ändern Sie den Eintrag von "ProfileImagePath" auf das neue Verzeichnis (z.B.: D:\Profiles\TestUser)
  6. Wenn Sie sich jetzt mit diesem neuen Benutzer anmelden, wird unter diesem Pfad ein neues Profil für den Benutzer erstellt. Wenn Sie das alte Profil behalten wollen, kopieren Sie das Profil aus "%SystemDrive%:\Dokumente und Einstellungen\TestUser" noch in das neue Verzeichnis "D:\Profiles\TestUser". Dann müssen Sie aber auch hier die Verzeichnisberechtigungen anpassen.
  7. Wenn Sie auch neue Profile unterhalb (z.B.: D:\Profiles) erstellt werden, müssen Sie noch den Wert "ProfilesDirectory" im Schlüssel "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList" auf das des neuen Profilverzeichnisses ändern. Kopieren Sie anschließend noch das Verzeichnis "C:\Dokumente und Einstellungen\Default User" in das neue Profilverzeichnis "D:\Profiles".

Den ganzen Ordner verschieben (auch die Systemprofile):

Sauber geht das unter Windows XP nur, wenn Sie diese Einstellungen über eine andere Windows-Installation kopieren und die Registry verändern können. Damit Sie den Administrator verschieben können, sollten Sie einen anderen USER dafür anlegen.

  1. Melden Sie sich als Administrator an.
  2. Erstellen Sie das neue Verzeichnis für das Profil (z.B.: D:\Profiles)
  3. Geben Sie die Rechte auf das Verzeichnis (am Besten die gleichen Rechte, wie Sie auf das Originalverzeichnis von Windows vergeben sind: "%SystemDrive%:\Dokumente und Einstellungen").

    4. Kopieren Sie alle Ordner unterhalb von "%SystemDrive%:\Dokumente und Einstellungen" in das neue Verzeichnis. Aber außer dem Benutzer, unter dem Sie gerade angemeldet sind, "LocalService" und "NetworkService". Das Verzeichnis "All Users" kann erst einmal nur kopiert werden (später löschen).

  4. Zuletzt startet man REGEDIT und sucht nach "Dokumente und Einstellungen". Alle Pfadangaben auf den alten Ordner müssen nun auf den neuen Pfad inkl. Laufwerk gelegt werden.

    5. Weiterhin findet man den Pfad auch noch unter:

    HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ hivelist

    Einige Einträge, die z.B. auf "\Device\HarddiskVolum1\Dokument und Einstellungen\<xxx>" verweisen müssen pfadmäßig auch noch entsprechend angepasst werden. Wenn Sie die Partition geändert haben, müssen Sie zudem noch die Nummer hinter "HarddiskVolum1" ändern.

  5. Ändern Sie auch noch den Wert "ProfilesDirectory" im Schlüssel "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList" auf das neue Profilverzeichnis.
  6. Starten Sie den Rechner neu.
  7. Melden Sie sich wieder als Administrator an. Wenn Sie alles richtig gemacht haben, sind auch die Dienste auf das neue Verzeichnis gewandert, und Sie können jetzt das Verzeichnis "Dokumente und Einstellungen" löschen, da keine Datei mehr geöffnet ist.

Info Vor dem Kopieren der Verzeichnisse müssen Sie einstellen, dass sie alle Dateien sehen ("Alle Dateien und Ordner anzeigen" aktivieren und "Geschützte Systemdateien ausblenden" deaktivieren)

Info Achtung: Wenn Sie die Berechtigungen auf die Verzeichnisse falsch setzen, können entweder die Profile nicht angelegt oder nicht geladen werden bzw. alle User können andere Profilverzeichnisse öffnen.

Info Beim Erstellen des Ordners muss unbedingt das System einen Zugriff auf den neu erstellten Ordner haben (Dokumente und Einstellungen), bevor man weitere Operationen vornimmt. Die Vererbung sollte aktiviert bleiben, sonst kann das Benutzerprofil beim nächsten Neustart nicht geladen werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=236621.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1912.htm


Standardwerte für die Suchoptionen einstellen

Mit diesem Tipp können Sie die Standardeinstellungen für die Suchoptionen in Windows entsprechend Ihren Wünschen verändern.

Diese Einstellungen finden Sie, wenn Sie im Suchfenster (F3 im Explorer) das Menü "Weitere Optionen" aufklappen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Erstellen Sie hier die unten aufgeführten neuen Werte als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Aktiviert (Haken gesetzt)
0 | Deaktiviert (Haken nicht gesetzt)

SearchSystemDirs | Legt fest, ob Systemordner mit durchsucht werden sollen
SearchHidden | Legt fest, ob auch versteckte Elemente mit einbezogen werden sollen
CaseSensitive | Legt fest, ob Groß-/Kleinschreibung beachtet werden soll
SearchSlowFiles | Legt fest, ob auch Bandsicherungen mit durchsucht werden sollen
IncludeSubFolders | Legt fest, ob automatisch auch in Unterordnern gesucht werden soll.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2000.htm


Webansicht im Explorer abschalten

Seitenansicht im Explorer konfigurieren

Mit dem folgenden Tipp können Sie die Ansicht im Explorer konfigurieren. Sie können das über das Menü erreichen:

Explorer -> Menü "Extra" -> "Ordneroptionen.." -> unter dem Tabreiter "Allgemein" hier im Bereich "Aufgaben" können Sie zwischen

  • "Allgemeine Aufgaben in Ordner anzeigen" (Web-Ansicht)
  • "Herkömmliche Windows-Ordner verwenden"

bzw. ab Windows Vista:

  • "Vorschau und Filter anzeigen"
  • "Herkömmliche Windows-Ordner verwenden"

Sie können die Einstellung auch in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Eintrag mit den Namen "WebView" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Herkömmliche Windows-Ordner verwenden
1 | "Allgemeine Aufgaben in Ordner anzeigen" bzw. "Vorschau und Filter anzeigen"(Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1587.htm


Ansichtsoptionen für jeden Ordner speichern

Mit diesem Tipp stellen Sie ein, ob für jeden Ordner die Ansichten extra gespeichert werden sollen. Wird dieser Tipp aktiviert, werden die Änderungen pro Ordner gespeichert, ansonsten gelten die Einstellungen pauschal für alle Ordner. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Ansichteinstellungen für jeden Ordner speichern" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ClassicViewState" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Speichern pro Ordner
1 | Nur eine Einstellung für alle Ordner

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1712.htm


Informationen über die Datei "Desktop.ini"

Die Versteckte_Datei Desktop.ini gibt an, wie das Explorerfenster vom geöffneten Ordner aussieht.

Man kann z. B. die Farbe der Schrift festlegen oder ob ein Hintergrundbild zu sehen sein soll. Die Datei "Desktop.ini" wird nur angezeigt, wenn bei "Ordneroptionen" im Tabreiter "Ansicht" unter "Erweiterte Einstellungen" die Option Geschützte_Systemdateien ausblenden (empfohlen) deaktiviert wurde.

Bei dieser Datei handelt es sich um eine einfache Textdatei, welche den Aufbau einer INI-Datei hat. Sie können die Datei z.B. mit Notepad öffnen und bearbeiten.

Anbei der Anfang einer Übersicht von möglichen Einträgen, welche sicherlich noch nicht vollständig ist. Wenn Sie darüber noch Informationen haben, dann schreiben Sie uns bitte (Link siehe unten).

Abschnitt: [.ShellClassInfo]

Eintrag | Beschreibung
CLSID = [CLSID Wert] | Legt besondere Verzeichniseigenschaften fest
CLSID2 = [CLSID Wert] | Legt besondere Verzeichniseigenschaften fest
UICLSID = [CLSID Wert] | Legt besondere Verzeichniseigenschaften fest
ConfirmFileOp=0

Wenn Sie den Wert auf 0 setzen, erhalten Sie eine Warnmeldung,

wenn Sie den Ordner löschen oder verschieben wollen:

<Ordnername> ist ein Windows-Systemordner, ohne den Windows nicht fehlerfrei ausgeführt werden kann. Es kann nicht verschoben oder umbenannt werden.

NoSharing=0

Wenn Sie den Wert auf 1 setzen, kann dieser Ordner nicht mehr freigegeben werden.

Info: Wird ab Windows Vista nicht mehr unterstützt
IconFile=C:\Test.ICO | Geben Sie hier die Datei an, aus der das Icon für die Anzeige das Ordners geladen werden soll. Standardmäßig werden .ico- Dateien erwartete, Sie können aber auch DLL, EXE oder BMP-Dateien verwenden.
IconIndex=0 | Legt den Index des Icons fest, welches angezeigt werden soll. Ist nur ein Icon vorhanden, dann setzen Sie den Wert auf 0 (erstes Icon).
InfoTip=Hierbei handelt es sich um meine Dateien

Legen Sie hier den Text fest, der als Infotipp angezeigt werden soll, wenn sich der Cursor über dem Ordner befindet. Wenn der Ordner geöffnet ist, wird dieser Text im Verzeichnis-Info -Block angezeigt.

Es kann auch eine Ressourcen ID angegeben werden: (@shell32.dll,-12689)
Sharing=0 | Bei 1 wird das Verzeichnis freigegeben.
HTMLInfoTipFile=file://Beschreibung.http

Gibt eine HTML-Datei als Informationsquelle an: file://Beschreibung.http
URL=http://www.downlaod.de | Öffnet das Verzeichnis als eine Webseite: http://www.downlaod.de
Logo=file://C:\WINDOWS\test.bmp | Kleines Logo, wenn das Verzeichnis als Webseite geöffnet wird: file://C:\WINDOWS\test.bmp
WideLogo=file://C:\WINDOWS\testbig.bmp | Großes Logo, wenn das Verzeichnis als Webseite geöffnet wird: file://C:\WINDOWS\testbig.bmp
LocalizedResourceName = @shell32.dll,-21765 | Legt die Ressourcen ID und Datei fest, aus welcher der Verzeichnisname ausgelesen wird
BuyURL = URL | Link der geöffnet wird, wenn auf den Link Beispielbilder geklickt wird:
MusicBuyUrl | Link der geöffnet wird, wenn auf den Link Beispielmusik geklickt wird
RunWizard=1 | Öffnet bei 1 einen Wizard, wenn ein Postfachordner geöffnet wird
DefaultToFS=0 | History
FolderType=Pictures

Verzeichnistyp

Mögliche Werte sind:

MyDocuments
Contacts
Music
MusicIcons
Documents
Pictures
MyPictures
PhotoAlbum
MyMusic
MusicArtist
MusicAlbum
Videos
MyVideos
VideoAlbum
UseLegacyHTT
CommonDocuments

Damit diese Einstellung funktioniert, darf das Verzeichnis noch nicht in der Registry eingetragen sein.
DefaultDropEffect=1

Standardaktion, wenn per Drag & Drop Dateien in das Verzeichnis abgelegt werden.

Mögliche Werte sind:

1 | Kopieren
2 | Verschieben
4 | Verknüpfung

Abschnitt: [ExtShellFolderViews]

Eintrag | Beschreibung
Default= {5984FFE0-28D4-11CF-AE66-08002B2E1262} | Legt die Ansicht für die Standardansicht fest
{BE098140-A513-11D0-A3A4-00C04FD706EC} = {BE098140-A513-11D0-A3A4-00C04FD706EC} | Verzeichnis Ansicht
{8BEBB290-52D0-11d0-B7F4-00C04FD706EC} = {8BEBB290-52D0-11d0-B7F4-00C04FD706EC} | Thumbnail Ansicht
{5984FFE0-28D4-11CF-AE66-08002B2E1262} = {5984FFE0-28D4-11CF-AE66-08002B2E1262} | Web Ansicht

Abschnitt: [{BE098140-A513-11D0-A3A4-00C04FD706EC}]

Eintrag | Beschreibung
Attributes=1 |
IconArea_Image=C:\Logo.jpg | Bild welches angezeigt werden soll
IconArea_Text=0x0000FFFF | Textfarbe
IconArea_TextBackground = 0x00000000 | Hintergrundfarbe

Abschnitt: [{8BEBB290-52D0-11d0-B7F4-00C04FD706EC}]

Eintrag | Beschreibung
MenuName = T&humbnails |
ToolTipText = T&humbnails |
HelpText = Displays items using thumbnail view | Statusbar Text
Attributes = 0x60000000 |

Abschnitt: [{5984FFE0-28D4-11CF-AE66-08002B2E1262}]

Eintrag | Beschreibung
PersistMoniker = file://template.htt |
WebViewTemplate.NT5 = ImgView.htt |
PersistMonikerPreview = \web\imgview.htt |

Abschnitt: [Encryption]

Eintrag | Beschreibung
Disable = 1 | Bei 1 wird die EFS-Verschlüsselung für das Verzeichnis ausgeschaltet

Abschnitt: [ViewState]

Eintrag Beschreibung
FolderType=Pictures

Legt den Ordnertyp fest

Mögliche Werte sind:

NotSpecified | Kein extra Template wurde festgelegt
Contacts | Template für Kontaktdaten
Music | Template für Musikdateien (Ansicht: Details)
MusicIcons | Template für Musikdateien (Ansicht: Icons)
Documents | Template für Dokumentenansicht
Pictures | Template für Bilder

Siehe auch Tipp: "Ordnererkennung für unterschiedliche Ansichten im Explorer abschalten"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://msdn.microsoft.com/en-us/library/bb776832.aspx

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2653.htm


Den Button 'Suchen' aus dem Explorer entfernen

Den Button "Suchen" aus dem Explorer entfernen

Wenn Sie diesen Wert setzen, wird der Button "Suchen" aus dem Explorer ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoShellSearchButton" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Button Suchen ausblenden
gelöscht | Button Suchen wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Schaltfläche "Suchen" aus Windows Explorer entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1123.htm


Anzeigen von Laufwerksinhalten verhindern

Wenn Sie diese Policy aktivieren, werden die Inhalte der angegeben Laufwerke nicht mehr im Explorer und Arbeitsplatz angezeigt. Das Laufwerk selber bleibt aber weiterhin im Explorer sichtbar, es wird nur der Zugriff mit einer entsprechenden Meldung verweigert. Weiterhin kann der Benutzer nicht mehr über die Kommandozeilenoberfläche mit DIR auf die Verzeichnisse zugreifen. Auch werden die Befehle „Netzwerklaufwerk verbinden“ und „Ausführen“ gesperrt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoViewOnDrive" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

Werte | Angegebene Laufwerke sperren
gelöscht | Alle anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Zugriff auf Laufwerke vom Arbeitsplatz nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Mit diesem Eintrag wird weiterhin nicht der Zugriff auf das Laufwerk gesperrt. Mit den entsprechenden Programmen kann weiterhin auf den Inhalt zugegriffen werden.

Info Siehe auch Tipp: Laufwerke ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1511.htm


Die Registerkarte DFS ausblenden

Wenn Sie diese Policy aktivieren, wird der Registry-Eintrag „DFS" (Distributed File System) im Explorer entfernt. Anwender können sich jetzt keine DFS-Einstellungen mehr anzeigen lassen bzw. ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDFSTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tab ausblenden
gelöscht | Tab anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Registerkarte "DFS" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1513.htm


Den Menüeintrag 'Verwalten' aus dem Kontextmenü des Explorers ausblenden

Den Menüeintrag "Verwalten" aus dem Kontextmenü des Explorers ausblenden

Mit diesem Tipp können Sie den Menüeintrag "Verwalten" aus dem Kontextmenü das Explorers ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoManageMyComputerVerb" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Den Menüeintrag "Verwalten" im Windows Explorer-Kontextmenü ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1901.htm


Den Tabreiter 'Anpassen' aus dem Explorer Eigenschaften entfernen

Mit diesem Tipp können Sie den Tabreiter "Anpassen" aus dem Kontextmenü des Explorers (rechte Maustaste auf einen Ordner -> Eigenschaften) entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCustomizeThisFolder" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Der Tabreiter "Anpassen" wird ausgeblendet
0 | Der Tabreiter wird bei den entsprechenden Ordnern angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1966.htm


Dateien/Ordner über das Kontextmenü verschlüsseln

Ab Windows 2000 haben Sie jetzt auch die Möglichkeit, Dateien und Ordner zu verschlüsseln.

Standardmäßig können Sie diese Funktion aber nicht so leicht erreichen, da der Eintrag nicht direkt im Kontextmenü steht, sondern nur über "Eigenschaften" -> "Allgemein" -> "Erweitert" lässt sich die Verschlüsselung aktivieren.

Durch einen Eintrag in der Registry können Sie aber einen neuen Eintrag direkt im Kontextmenü erstellen, über den Sie dann recht schnell auf diese Funktion zugreifen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Legen Sie einen neuen Wert mit dem Namen "EncryptionContextMenu" als Datentyp REG_DWORD an.

Setzen Sie den Wert auf 1 bzw. und auf 0, um den Eintrag wieder aus dem Kontextmenü zu entfernen.

Nach einem Neustart steht Ihnen die Funktion nun direkt im Kontextmenü vom Explorer zur Verfügung.

Info Die Verschlüsselung funktioniert nur auf NTFS-Partitionen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1154.htm


"Senden an" aus dem Kontextmenü ein-/ausblenden

Mit diesem Tipp können Sie den Eintrag "Senden an" aus dem Kontextmenü des Explorers ein-/ausblenden. Mit dem Eintrag "Senden an" können Sie über den Explorer Programme an eingetragene Anwendungen schicken (diese Programme/Dateien werden mit der Anwendung geöffnet).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CLASSES_ROOT\ AllFileSystemObjects\ shellex\ ContextMenuHandlers\ Send To

Löschen Sie den Schlüssel "Send To", um den Eintrag "Senden an" aus dem Kontextmenü zu entfernen.

Wenn Sie den Eintrag wieder im Kontextmenü eintragen wollen, dann legen Sie den Schlüssel "Send To" unterhalb von "HKEY_CLASSES_ROOT\ AllFileSystemObjects\ shellex\ ContextMenuHandlers\ Send To" wieder an und geben Sie beim Wert "(Standard)" als Datentyp REG_SZ den Wert "{7BA4C740-9E81-11CF-99D3-00AA004AE837}" ein.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2222.htm


Netmeeting führt zu fehlerhaften Icon Farben (265-Farben)

Wenn Sie Netmeeting unter Windows 2000 verwenden, kann es dazu führen, dass anschließen alle oder einige Icons nur noch mit 256 Farben angezeigt werden. Wenn Sie die Farben wieder mit einer höheren Farbenanzahl angezeigt bekommen möchten, gehen Sie folgendermaßen vor:

Tipp 1:
1. Netmeeting starten
2. Eigenschaften von Anzeige aufrufen
3. Icons mit höchster Farbanzahl anzeigen deaktivieren
4. Übernehmen anklicken
5. Icons mit höchster Farbanzahl anzeigen aktivieren
6. Übernehmen anklicken
7. Netmeeting schließen

Tipp 2:
1. Netmeeting starten
2. Eigenschaften von Anzeige aufrufen
3. Icons mit höchster Farbanzahl anzeigen deaktivieren
4. Übernehmen anklicken
5. Netmeeting schließen
6. Icons mit höchster Farbanzahl anzeigen aktivieren
7. Übernehmen anklicken.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1503.htm


Tooltipptext von Standardicons ändern

Mit diesem Tipp können Sie den Tooltipp ändern, der angezeigt wird, wenn Sie mit dem Mauszeiger über dem Icon stehenbleiben. Sie können hier einen beliebigen Text eingeben der angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Classes\ CLSID\

Hier suchen Sie die folgenden Schlüssel:

{20D04FE0-3AEA-1069-A2D8-08002B30309D} | Computer
{450D8FBA-AD25-11D0-98A8-0800361B1103} | "Eigene Dateien"
{208D2C60-3AEA-1069-A2D7-08002B30309D} | Netzwerkumgebung
{645FF040-5081-101B-9F08-00AA002F954E} | Papierkorb
{85BBD920-42A0-1069-A2E4-08002B30309D} | Postkasten
{21EC2020-3AEA-1069-A2DD-08002B30309D} | Systemsteuerung
{3DC7A020-0ACD-11CF-A9BB-00AA004AE837} | bis IE 5.0
{871C5380-42A0-1069-A2EA-08002B30309D} | ab IE 5.5
{00020D75-0000-0000-C000-000000000046} | Outlook

Unterhalb dieses Schlüssel finden Sie den Wert "InfoTip" als Datentyp REG_SZ. Hier wird der Text angegeben, der Angezeigt werden soll.

Standardmäßig verweist der Eintrag auf eine DLL, wo der Text ausgelesen wird. Sie können hier aber auch den gewünschten Text eingeben.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2224.htm


Anzahl der Einträge unter Start - Dokumente festlegen

Die max. Anzahl von Einträgen, die Windows unter Start -> Dokumente anzeigt, liegt bei 10.

Werden mehr als 10 Dokumente oder Dateien geöffnet, werden die ältesten Einträge wieder gelöscht. Diese Anzahl der Einträge können Sie folgendermaßen verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Eintrag mit dem Namen "MaxRecentDocs" als Datentyp REG_DWORD. Geben Sie die Zahl der max. Einträge an:

1-9999

Anzahl der Einträge

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Maximale Anzahl von neueren Dokumenten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1122.htm


'Eject'- (Auswurf) Eintrag für PC aus dem Startmenü entfernen

Wenn Sie den Eintrag "Eject PC" (wird bei Docking-Stationen oft angezeigt) aus dem Startmenü entfernen wollen, müssen Sie folgenden Eintrag in der Registry vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ IDConfigDB\ CurrentDockInfo

Erstellen Sie einen neuen Eintrag mit dem Namen EjectableDocks als Datentyp REG_DWORD und setzen den Wert auf 0, um den Eintrag aus dem Startmenü zu entfernen bzw. auf 1, um den Eintrag anzuzeigen (Standard).

Info Dieser Wert wird von Windows automatisch bei jedem Neustart des Rechner gesetzt. Damit Ihre Einstellung erhalten bleibt, müssen Sie den Wert beim Neustart über ein Regfile wieder setzen.

Dazu erstellen Sie eine .REG Datei und tragen den Aufruf der Datei in der Registry unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

als Datentyp REG_SZ ein und setzen den Eintrag auf:

"regedit /s c:\winnt\<dateiname>.reg".

Zum Erstellen dieser Datei exportieren Sie den gerade angelegten Schlüssel und speichern ihn z.B. als c:\winnt\noeject.reg ab.

Der Eintrag im Run-Schlüssel der Registry sollte dann wie folgt aussehen:

"regedit /s c:\winnt\noeject.reg"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1335.htm


Popuptexte im Startmenü ausschalten

Wenn Sie im Startmenü auf einem Eintrag mit der Maus stehen bleiben, öffnet sich bei einigen eine sog. Popupbox mit weiteren Informationen.

Wenn Sie das eher stört, da Sie diese Informationen sowieso nicht gebrauchen könne, dann haben Sie hier die Möglichkeit diese Popupbox auszuschalten.

Durch Aktivieren dieser Einstellung werden folgende Popuptexte nicht angezeigt: "Klicken Sie zum Starten auf diese Schaltfläche" auf der Schaltfläche "Start", "Wo sind die Programme" im Startmenü und "Wo sind die Symbole" im Infobereich.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSMBalloonTip" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Popup wird nicht angezeigt
gelöscht | Popup wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Infosymbole für Startmenüeinträge entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Einstellungen für Infotipps finden Sie unter:
QuickInfos (BallonTipps) abschalten
Quickinfo für Icons
Ordnerinformationen als Balloontip anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1420.htm


Nicht konfigurierte Programme 'grau' unterlegen

Nicht konfigurierte Programme "grau" unterlegen

Programme welche mit dem Windows Installer dem Anwender zugewiesen und schon im Startmenü eingetragen sind, aber noch nicht gestartet wurden und somit noch beim ersten Aufruf konfiguriert werden, können mit diesem Eintrag "grau" hinterlegt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "GreyMSIAds" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird grau unterlegt
gelöscht | Eintrag wird nicht grau unterlegt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Nicht verfügbare Windows Installer-Programme in der Verknüpfungen des Startmenüs deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe auch: Automatische Rückverfolgung verwaister Links unterbinden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1421.htm


Startmenü alphabetisch sortieren

Die Einträge im Startmenü werden in der Reihenfolge angezeigt, wie sie auch angelegt wurden. Wenn Sie mit der rechten Maustaste auf einen Menüeintrag klicken, können Sie die Einträge unterhalb des Ordner über die Auswahl "" alphabetisch sortieren lassen.

Wenn Sie alle Einträge alphabetisch sortieren wollen, müsse Sie einfach nur diesen Tipp aktivieren und speichern, dann werden alle Menüeinträge automatisch alphabetisch sortiert.

Info Die Sortierung gilt nicht für neue Einträge, welche nach der Sortierung eingefügt werden. Sie müssen diesen Tipp dann noch einmal ausführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Für die alte "klassische Ansicht":

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MenuOrder\ Start Menu\ Programs

Für die neue Startmenüansicht:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MenuOrder\ Start Menu2\ Programs

löschen Sie hier den Wert "Order" als Datentyp REG_BINARY. Der Eintrag wird von Windows automatisch neu angelegt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2058.htm


Sperren der Funktion 'Inaktive Symbole ausblenden'

Wenn Sie diese Policy aktivieren, wird der Eintrag "Inaktive Symbole ausblenden" aus dem Kontextmenü der Taskleiste "Eigenschaften von Taskleiste und Startmenü" Tabreiter "Taskleiste" deaktiviert. Weiterhin werden alle Symbole im Infobereich angezeigt.

Der Infobereich befindet sich in der Taskleiste, im Allgemeinen unten auf dem Bildschirm, und er enthält die Uhrzeit sowie aktuelle Informationen. Diese Einstellung legt fest, ob die Elemente immer ausgeblendet oder immer expandiert werden. Die Standardeinstellung ist, dass Informationen ausgeblendet werden. Das Symbol zur Bereinigung des Infobereichs << kann als "Informations-Chevron bezeichnet werden."

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAutoTrayNotify" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Symbole werden nicht ausgeblendet
gelöscht | Symbole werden ausgeblendet (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Bereinigung des Infobereichs deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1437.htm


Favoriten Menü aus dem Startmenü entfernen/hinzufügen

Mit dieser Funktion können Sie einstellen, ob das Favoriten Menü im Startmenü angezeigt werden soll oder nicht

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Legen Sie dazu einen neuen Wert mit dem Namen "StartMenuFavorites" als Datentyp REG_DWORD an. Setzen Sie den Wert auf 0, um diesen Eintrag auszublenden oder auf 1, um diesen Eintrag wieder im Startmenü einzublenden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0949.htm


Einblenden von Administrativen Tools

Standardmäßig wird unter "Start" -> "Programme" die Gruppe "Verwaltung" angezeigt. Hier finden Sie einige Administrative Tools zur Computerverwaltung.

Wenn Sie Gruppe für einige Anwender ausblenden wollen, können Sie das über folgenden Registryeintrag machen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellen Sie einen neuen Eintrag mit dem Namen "StartMenuAdminTools" als Datentyp REG_SZ. Setzen Sie den Wert auf NO. Wenn Sie diese Gruppe wieder einblenden wollen, müssen Sie den Wert auf YES setzen.

NO | Es werden keine "Administrativen Tool" mehr angezeigt
YES | Die Tools werden angezeigt (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1187.htm


Netzwerk- und DFÜ-Verbindungen ausblenden

Wenn Sie diesen Tipp aktivieren, wird verhindert das der Ordner "Netzwerkverbindungen" geöffnet wird, außerdem wird der Eintrag "Netzwerkverbindungen" aus dem Menü "Einstellungen" im Startmenü entfernt.

In der Systemsteuerung und im Windows Explorer wird das Symbol "Netzwerkverbindungen" weiterhin angezeigt, allerdings erhält der Benutzer bei dem Versuch, dieses zu starten, eine Fehlermeldung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNetworkConnections" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Wird ausgeblendet
gelöscht | Wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Netzwerkverbindungen" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1452.htm


Den Eintrag 'Administrative Tools' aus dem Startmenü entfernen

Den Eintrag "Administrative Tools" bzw. "Verwaltung" aus dem Startmenü entfernen

Mit diesem Wert können Sie den Eintrag "Administrative Tools" bzw. "Verwaltung" aus dem Startmenü entfernen.

Siehe dazu Tipp "Einblenden von Administrativen Tools"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1389.htm


Windows Security aus dem Startmenü entfernen

Windows-Sicherheit (Windows Security) aus dem Startmenü entfernen

Terminal Server

Mit diesem Tipp können Sie den Eintrag "Windows-Sicherheit" (NT Security) aus dem Startmenü der Terminal Server Session entfernen. Diese Einstellung kann dazu verwendet werden, dass unerfahrene Benutzer sich nicht versehentlich von Terminalserver abmelden.

Wenn Sie den Tipp aktivieren, erscheint "Windows-Sicherheit" nicht mehr im Startmenü. Deswegen muss zum Öffnen des Dialogfeldes "Windows-Sicherheit" auf dem Client ein Sicherheitsaufruf, etwa STRG+ALT+ENTF, eingegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNtSecurity" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag kann zum Startmenü hinzugefügt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Terminaldienste
Einstellungsname: | Eintrag "Windows-Sicherheit" aus dem Startmenü entfernen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1388.htm


Entfernen des Eintrages 'Programmzugriff und Standards festlegen' aus dem Startmenü

Entfernen des Eintrages "Programmzugriff und Standards festlegen" aus dem Startmenü

Mit diesem Tipp können Sie den Eintrag "Programmzugriff und Standards festlegen" aus dem Startmenü entfernen.

Wenn Sie auf das Symbol "Programmzugriff und -standards" im Startmenü klicken, wird die Systemsteuerungsoption "Software" geöffnet und so Administratoren die Möglichkeit gegeben, Standardprogramme für bestimmte Aktivitäten, wie z. B. Webbrowsen oder Senden von E-Mail, festzulegen, sowie auf welche Programme vom Startmenü, vom Desktop oder anderen Stellen aus zugegriffen werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSMConfigurePrograms" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Programmzugriff und Standards festlegen" ausblenden
gelöscht | "Programmzugriff und Standards festlegen" anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Symbol "Programmzugriff und -standards" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung verhindert nicht, dass die Schaltfläche "Programmzugriff und -standards" unter der Systemsteuerungsoption "Software" erscheint (siehe: Entfernen des Eintrages 'Programmzugriff und Standards festlegen' aus Software)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1660.htm


Ausführen im 'Startmenü' ein-/ausblenden (klassische Ansicht)

Ausführen im "Startmenü" ein-/ausblenden (klassische Ansicht)

Mit diesem Tipp legen Sie fest, ob "Ausführen" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "StartMenuRun" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Ausführen nicht ausblenden
0 | Ausführen ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1732.htm


Icongröße im 'Startmenü' umschalten

Icongröße im "Startmenü" umschalten

Mit diesem Tipp legen Sie fest, ob große oder kleine <Icons> im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_LargeMFUIcons" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Grosse Icons
0 | Kleine Icons

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1734.htm


Suche im Internet aus der Startmenüeintrag 'Suche' entfernen

Mit diesem Tipp können Sie den Eintrag unter "Start" -> "Suche" -> "im Internet" aus dem Startmenü entfernen.

Diese Einstellung bezieht sich auf die alte "klassische Ansicht" und nicht auf die neue Startmenüansicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ FindExtensions\ Static

löschen Sie den ganzen Schlüssel "WebSearch"

Empfehlung:

Sie sollten diesen Schlüssel vorher über das Menü "Datei" -> "Exportieren" als .REG-Datei sichern, damit Sie diesen Eintrag wieder herstellen können, wenn Sie ihn doch wieder benötigen sollten.

Sollten Sie keine Sicherung haben, hier die Standardeinträge als REG-Datei (Speicher Sie einfach den Text zwischen Anfang und Ende in eine Datei mit der Endung .REG ab und klicken Sie diese Datei im Explorer an):

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FindExtensions\Static\WebSearch]

@="{07798131-AF23-11d1-9111-00A0C98BA67D}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FindExtensions\Static\WebSearch\0]

@="Im &Internet..."

"LocalizedString"="@browselc.dll,-13060"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FindExtensions\Static\WebSearch\0\DefaultIcon]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\

64,00,6f,00,63,00,76,00,77,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,00,31,\

00,31,00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FindExtensions\Static\WebSearch\0\HelpText]

@="Im Web suchen"

"LocalizedString"="@browselc.dll,-13061"

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2003.htm


Zeit für das Anzeigen der Erinnerungssymbole festlegen

Mit diesem Tipp legen Sie die Anzeigezeit für die Erinnerungssymbole fest.

Erinnerungssymbole werden angezeigt, wenn die Verbindung mit einer Netzwerkdatei getrennt oder neu hergestellt wird und werden regelmäßig aktualisiert. Standardmäßig wird das erste Erinnerungssymbol eines Ereignisses 30 Sekunden lang angezeigt. Danach werden Aktualisierungen alle 60 Minuten für 15 Sekunden angezeigt. Sie können diese Einstellung verwenden, um die Länge des ersten Erinnerungssymbols zu ändern.

InitialBalloonTimeoutSeconds: Zeit für das erste Erinnerungssymbol

ReminderBalloonTimeoutSeconds: Zeit für alle weiteren Erinnerungssymbole

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit den folgenden Namen:

Wertname | Datentyp | Werte (Dezimal) | Standard
InitialBalloonTimeoutSeconds | REG_DWORD | 10 bis 60 in Sekunden | 30 Sekunden
ReminderBalloonTimeoutSeconds | REG_DWORD | 10 bis 60 in Sekunden | 15 Sekunden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | InitialBalloonTimeoutSeconds: Lebensdauer des ersten Erinnerungssymbols ReminderBalloonTimeoutSeconds: Lebensdauer des Erinnerungssymbols

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1440.htm


ClearType: Art der Kantenglättung und Schriftglättung

Mit diesem Tipp können Sie die Art der Kantenglättung konfigurieren. Microsoft hat die "ClearType Technology" eingeführt, um die Lesbarkeit bei LCD Displays zu verbessern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "FontSmoothingType" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Deaktiviert
1 | Graue Kantenglättung
2 | Farbige Schriftglättung

Standardmäßig steht dieser Wert auf 1.

ClearType auch schon beim Loginbildschirm

Leider ist diese Funktion standardmäßig erst nach dem Login aktiviert. Durch folgenden Eintrag in der Registry können Sie diese Funktion auch schon vorher aktivieren.

HKEY_USERS\ .DEFAULT\ Control Panel\ Desktop

Legen Sie einfach hier den oben beschriebenen Eintrag an.

Info Siehe dazu auch Tipp:
"Weichzeichnen" für die Schrift aktivieren
Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren
ClearType: Helligkeit der Farbtöne für die Schriftglättung
ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=294851

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1263.htm


Systemsteuerung über RUNAS aufrufen

Wenn Sie als normaler User angemeldet sind und als Administrator eine Systemsteuerung benötigen, geht das nicht so einfach.

Für die Systemsteuerung gibt es keine extra Date, die Sie dann aufrufen können. Aufrufe über RUNDLL32 öffnen in einer CMD, welche über RUNAS geöffnet wurde, nur ein Explorerfenster.

Mit folgendem Vorgehen können Sie die Systemsteuerung auch über RUNAS öffnen:

  • Öffnen Sie sich über RUNAS eine Kommandozeile (CMD.EXE)
    RUNAS /User:[Usernmame] CMD.EXE
  • Geben Sie jetzt folgenden Befehl in die Kommandozeile ein (an besten den langen String hier ausschneiden)
    "%ProgramFiles%\Internet Explorer\iexplore.exe" ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{21EC2020-3AEA-1069-A2DD-08002B30309D}

Jetzt wird Ihnen die Systemsteuerung über den Internet Explorer mit administrativen Rechten geöffnet.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2071.htm


Zusätzliche Icons zur Systemsteuerung hinzufügen

Mit diesem Tipp können Sie zusätzliche Icons zur Systemsteuerung hinzufügen. Windows sucht standardmäßig die Dateien aus dem System32- Verzeichnis und zeigt diese an. Hier können Sie die Pfad zu weiteren CPL-Dateien angeben, die angezeigt werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Control Panel\ cpls

hier müssen Sie für jede CPL-Dateien einen neuen Eintrag erzeugen als Datentyp REG_SZ. Als Name geben Sie dabei den Namen der CPL-Datei an und als Wert den Pfad und den Namen der Datei.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2102.htm


Den Eintrag 'Programme ändern/entfernen' aus Software deaktivieren

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Programme ändern/entfernen" unter "Systemsteuerung" -> "Software" entfernt.

Mit der Schaltfläche "Programme ändern oder entfernen" können Benutzer Funktionen von installierten Programmen deinstallieren, reparieren, hinzufügen oder entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRemovePage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Option "Programme ändern oder entfernen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1429.htm


Den Eintrag 'Windows Komponenten hinzufügen/entfernen' aus Software deaktivieren

Wenn Sie diese Policy aktivieren, wird der Eintrag "Programme hinzufügen" unter "Systemsteuerung" -> "Software" entfernt.

Diese Einstellung verhindert, dass Benutzer über die Option "Software" die Verbindung mit "Windows Update" herstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddFromInternet" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Option "Programme von Microsoft hinzufügen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1431.htm


Den Button 'Windows Komponenten hinzufügen/entfernen' aus Software ausblenden

Den Button "Windows Komponenten hinzufügen/entfernen" aus Software ausblenden

diesem können Sie den Button, "Windows Komponenten hinzufügen/entfernen" aus der Systemsteuerung -> Software ausblenden.

Die Schaltfläche "Windows-Komponenten hinzufügen/entfernen" ermöglicht Benutzern installierte Dienste zu konfigurieren und den Assistenten für Windows-Komponenten zum Hinzufügen, Entfernen und Konfigurieren von Windows-Komponenten zu verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoWindowsSetupPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Button wird ausgeblendet
gelöscht | Button ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Dialogfeld "Windows-Komponenten hinzufügen/entfernen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1115.htm


Den Hyperlink 'Supportinformationen' unter Software entfernen

Wenn Sie diese Policy aktivieren, wird der Hyperlink, der bei einigem Programm unter Systemsteuerung -> Software unter "Programme ändern oder entfernen" existiert, nicht mehr angezeigt. Die auf der Seite "Programme ändern oder entfernen ausblenden" aufgeführten Programme können einen Hyperlink "Supportinformationen" enthalten.

Mit einem Mausklick auf den Hyperlink wird ein Dialogfeld geöffnet, das Informationen bezüglich der Problembehandlung anzeigt, wie z. B. einen Link zu den Installationsdateien oder für den Kundendienst erforderliche Daten, wie z. B. die Product ID und Versionsnummer eines Programms. Außerdem enthält das Dialogfeld einen Hyperlink für Supportinformationen im Internet, wie z. B. die Microsoft Support Services-Webseite.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSupportInfo" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Supportinformationen entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1433.htm


Den Eintrag 'Programme hinzufügen' aus Software deaktivieren

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Programme hinzufügen" unter "Systemsteuerung" -> "Software" entfernt.

Die Schaltfläche "Neue Programme hinzufügen" ermöglicht Benutzern veröffentlichte oder vom Systemadministrator zugewiesene Programme zu installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Option "Neue Programme hinzufügen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1428.htm


Die Registerkarte Hardware ausblenden

Wenn Sie diese Policy aktivieren, wird die Registerkarte „Hardware“ aus den Objekten „Tastatur“, „Maus“, „Sounds und Audiogeräte“ und aus allen Eigenschaften von allen Treibern entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoHardwareTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tab in der Registerkarte ausblenden
gelöscht | Tab anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Registerkarte "Hardware" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1512.htm


Den Eintrag 'Programme aus dem Netzwerk hinzufügen' aus Software deaktivieren

Wenn Sie diese Funktion aktivieren, wird der Eintrag "Programme aus dem Netzwerk hinzufügen" unter "Systemsteuerung" -> "Software" im Tabreiter "Neue Programme hinzufügen" entfernt.

Der Abschnitt "Programme aus dem Netzwerk hinzufügen" führt alle veröffentlichte Programme auf und ermöglicht deren Installation. Veröffentlichte Programme werden vom Systemadministrator mit Hilfe eines Programms, wie z. B. Windows Installer, den Benutzern zur Verfügung gestellt. Normalerweise veröffentlichen Systemadministratoren Programme, um Benutzer zu benachrichtigen, dass Programme verfügbar sind, ihre Verwendung zu empfehlen, oder es Benutzern zu ermöglichen, die Programme zu installieren, ohne nach deren Installationsdateien suchen zu müssen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddFromNetwork" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Option "Programme aus dem Netzwerk hinzufügen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1430.htm


Den Eintrag 'Programme von CD oder Diskette hinzufügen' aus Software deaktivieren

Wenn Sie diese Policy aktivieren, wird der Eintrag "Programme von CD oder Diskette hinzufügen" unter "Systemsteuerung" -> "Software" bei "Neue Programme" deaktiviert.

Diese Einstellung verhindert, dass Benutzer über die Option "Software" Programme von Wechselmedien hinzufügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddFromCDorFloppy" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Option "Ein Programm von CD oder Diskette hinzufügen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1427.htm


Entfernen des Eintrages 'Programmzugriff und Standards festlegen' aus Software

Entfernen des Eintrages "Programmzugriff und Standards festlegen" aus Software

Info: Windows 2000 erst ab SP3

Mit diesem Tipp können Sie den Eintrag "Programmzugriff und Standards festlegen" aus der 'Software' entfernen. Dieser Eintrag wird unter Systemsteuerung -> Software links in der Liste angezeigt.

Die Schaltfläche "Programmzugriff und -standards" gibt Administratoren die Möglichkeit, Standardprogramme für bestimmte Aktivitäten, wie z. B. Webbrowsen oder Senden von E-Mail, festzulegen, sowie auf welche Programme vom Startmenü, vom Desktop oder anderen Stellen aus zugegriffen werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoChooseProgramsPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Programmzugriff und Standards festlegen" ausblenden
gelöscht | "Programmzugriff und Standards festlegen" anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Die Seite "Programmzugriff und -standards" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung verhindert nicht, dass das Symbol "Programmzugriff und -standards" im Startmenü erscheint (siehe Tipp: Entfernen des Eintrages "Programmzugriff und Standards festlegen" aus dem Startmenü).

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1659.htm


Den Eintrag 'Ordneroptionen' aus der Systemsteuerung entfernen

Den Eintrag "Ordneroptionen" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Ordneroptionen" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel "{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}" um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel erneut und geben beim Wert "(Standard)" wieder die Beschreibung "Folder Options" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1677.htm


Den Eintrag 'Taskleiste und Startmenü' aus der Systemsteuerung entfernen

Den Eintrag "Taskleiste und Startmenü" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Taskleiste und Startmenü" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel "{0DF44EAA-FF21-4412-828E-260A8728E7F1}" um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Taskleiste und Startmenü" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1678.htm


Den Eintrag 'Netzwerkverbindungen' aus der Systemsteuerung entfernen

Den Eintrag "Netzwerkverbindungen" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Netzwerkverbindungen" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel

"{7007ACC7-3202-11D1-AAD2-00805FC1270E}"

Ab Windows Vista:

"{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}"

um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Netzwerkverbindungen" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1679.htm


Den Eintrag 'Scanner und Kameras' aus der Systemsteuerung entfernen

Den Eintrag "Scanner und Kameras" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Scanner und Kameras" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel

"{E211B736-43FD-11D1-9EFB-0000F8757FCD}"

ab Windows Vista:

"{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}"

um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Scanner und Kameras" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1680.htm


Den Eintrag 'Geplante Task' aus der Systemsteuerung entfernen

Den Eintrag "Geplante Task" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Geplante Task" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel "{D6277990-4C6A-11CF-8D87-00AA0060F5BF}" um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Geplante Task" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1681.htm


Den Eintrag 'Schriftarten' aus der Systemsteuerung entfernen

Den Eintrag "Schriftarten" aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Schriftarten" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel "{D20EA4E1-3957-11d2-A40B-0C5020524152}" um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Schriftarten" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1682.htm


Den Eintrag 'Verwaltung' aus der Systemsteuerung entfernen

Den Eintrag "Verwaltung'' aus der Systemsteuerung entfernen

Wenn Sie diesen Tipp aktivieren, wird der Eintrag "Verwaltung" aus der Systemsteuerung entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ ControlPanel\ NameSpace

Löschen Sie hier den Schlüssel "{D20EA4E1-3957-11d2-A40B-0C5020524153}" um den Eintrag zu entfernen. Wenn Sie den Eintrag wieder anzeigen wollen, erstellen Sie den Schlüssel wieder neu und geben beim Wert "(Standard)" wieder die Beschreibung "Verwaltung" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1683.htm


Angegebene Systemsteuerungs-Symbole ausblenden

Mit diesem Tipp können Sie die angegebenen Systemsteuerungs-Symbole ausblenden.

Durch Aktivieren dieser Einstellung werden Systemsteuerungs-Optionen, wie z. B. "Anzeige", und Ordner, wie z. B. "Schriftarten" aus dem Systemsteuerungs-Fenster und aus dem Startmenü entfernt. Von Ihnen hinzugefügte - aber auch Windows 2000 Professional- oder Windows XP Professional-Systemsteuerungs-Objekte - können entfernt werden.

Geben Sie den Dateinamen eines Objekts, z. B. Ncpa.cpl für "Netzwerk- und DFÜ-Verbindungen" ein, um ein Systemsteuerungs-Objekt auszublenden (Liste der Namen im Tipp: Icons der Systemsteuerung ausblenden). Geben Sie den Ordnernamen, wie z. B. Schriftarten, um einen Ordner auszublenden. Weiterhin können Sie auch den Namen der Objekte Angeben wie Sie in der Systemsteuerung (unter Start -> Einstellungen -> Systemsteuerung) angezeigt werden.

Falls die Einstellungen "Angegebene Systemsteuerungssymbole ausblenden" und "Nur angegebene Systemsteuerungssymbole anzeigen" aktiviert sind, und dasselbe Systemsteuerungsobjekt in beiden Einstellungen angegeben wird, dann wird die Einstellung "Nur angegebene Systemsteuerungssymbole anzeigen" ignoriert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer\ DisallowCpl

Unter diesem Schlüssel legen Sie jetzt für jedes Systemsteuerungssymbol welches Sie ausblenden wollen einen neuen Eintrag als Datentyp REG_SZ an und fangen dabei als Name bei 1 an und zählen jeweils hoch (1,2,3 usw.). Als Wert geben Sie den Namen des Icons oder Ordners an, welchen Sie ausblenden wollen.

Name | Datentyp | Wert | Beschreibung
1 | REG_SZ | Anzeige | Blendet die Anzeige aus
2 | REG_SZ | Schriftarten | Blendet die Schriftarten aus

Diese Liste können Sie beliebig erweitern.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung
Einstellungsname: | Angegebene Systemsterungssymbole ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Beachten Sie dazu auch den Tipp: Icons der Systemsteuerung ausblenden.

Info Diese Einstellung hat keine Auswirkungen auf die Kategorien, die in der Kategorieansicht der neuen Systemsteuerung in Windows XP angezeigt werden. Um die Kategorieansicht zu entfernen, müssen Sie die den Tipp "Anzeigeart der Systemsteuerung" aktivieren.

Info Die Icons werden nur aus der Systemsteuerung ausgeblendet. Wenn der Anwender die CPL-Dateien direkt aufruft, kann er noch auf die Funktionen zugreifen, falls die Rechte nicht anderweitig eingeschränkt wurden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1945.htm


Nur angegebene Systemsteuerungs-Symbole anzeigen

Mit diesem Tipp werden nur die angegeben Systemsteuerungs-Objekte angezeigt, alle anderen werden ausgeblendet.

Durch Aktivieren dieser Einstellung werden alle Systemsteuerungs-Optionen, wie z. B. "Netzwerk- und DFÜ-Verbindungen", und Ordner, wie z. B. "Schriftarten" aus dem Systemsteuerungs-Fenster und aus dem Startmenü entfernt. Von Ihnen hinzugefügte, aber auch Windows 2000- und Windows XP Professional-Systemsteuerungs-Objekte werden entfernt werden. Die einzigen Objekte, die in der Systemsteuerung angezeigt werden, sind die Objekte, die Sie in dieser Einstellung angeben.

Geben Sie den Dateinamen eines Objekts, z. B. Ncpa.cpl für "Netzwerk- und DFÜ-Verbindungen" ein, um ein Systemsteuerungs-Objekt anzuzeigen (Liste der Namen im Tipp: Icons der Systemsteuerung ausblenden). Geben Sie den Ordnernamen, wie z. B. Schriftarten, um einen Ordner anzuzeigen. Weiterhin können Sie auch den Namen der Objekte Angeben wie Sie in der Systemsteuerung (unter Start -> Einstellungen -> Systemsteuerung) angezeigt werden.

Falls die Einstellungen "Angegebene Systemsteuerungssymbole ausblenden" und "Nur angegebene Systemsteuerungssymbole anzeigen" aktiviert sind, wird die Einstellung "Nur angegebene Systemsteuerungssymbole anzeigen" ignoriert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer\ RestrictCpl

Unter diesem Schlüssel legen Sie jetzt für jedes Systemsteuerungs-Symbol, welches Sie einblenden wollen (alle anderen werden nicht angezeigt), einen neuen Eintrag als Datentyp REG_SZ an und fangen dabei als Namen bei 1 an und zählen jeweils hoch (1,2,3 usw.). Als Wert geben Sie den Namen des Icons oder Ordners an, welchen Sie ausblenden wollen.

Name | Datentyp | Wert | Beschreibung
1 | REG_SZ | Anzeige | Die Anzeige wird angezeigt
2 | REG_SZ | Schriftarten | Die Schriftarten werden angezeigt

Diese Liste können Sie beliebig erweitern.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung
Einstellungsname: | Nur angegebene Systemsteuerungs-Symbole anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Beachten Sie dazu auch den Tipp: Icons der Systemsteuerung ausblenden.

Info Diese Einstellung hat keine Auswirkungen auf die Kategorien, die in der Kategorieansicht der neuen Systemsteuerung in Windows XP angezeigt werden. Um die Kategorieansicht zu entfernen, müssen Sie die den Tipp "Anzeigeart der Systemsteuerung" aktivieren.

Info Die Icons werden nur aus der Systemsteuerung ausgeblendet. Wenn der Anwender die CPL-Dateien direkt aufruft, kann er noch auf die Funktionen zugreifen, falls die Rechte nicht anderweitig eingeschränkt wurden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1946.htm


Standardkategorie für 'Neue Programme hinzufügen' festlegen

Mit diesem Tipp können Sie die Standard-Programmkategorie festlegen, die beim Öffnen der Seite "Neue Programme hinzufügen" angezeigt wird.

Durch Aktivieren dieser Einstellung werden nur die in der Kategorie angegebenen Programme beim Öffnen der Seite "Neue Programme hinzufügen" angezeigt. Benutzer können die Liste "Kategorie" verwenden, um auf der Seite "Neue Programme hinzufügen" Programme in anderen Kategorien anzuzeigen.

Geben Sie hier den Namen einer Kategorie an. Sie müssen den Namen einer bereits bestehen Kategorie in "Software" angeben. Verwenden Sie Softwareinstallation, um eine Kategorie festzulegen.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, werden alle Programme (Kategorie: Alle Kategorien) beim Öffnen der Seite "Neue Programme hinzufügen" angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "DefaultCategory" als Datentyp REG_SZ und geben Sie hier den Namen der Kategorie an.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Standardkategorie für 'Neue Programme hinzufügen' festlegen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1947.htm


Nur 60 Hz bei DirectX und OpenGL

Während Windows 9x bei DirectX die für den Desktop und Auflösung eingestellte Bildwiederholrate übernimmt, gilt dies nicht bei Windows 2000. OpenGL oder DirectX werden hier nur mit mageren 60 Hz wiedergegeben, unabhängig der eingestellten Wiederholrate vom Desktop.

Man kann diesen Umstand (der durch die abweichende DX-Implentierung gegenüber Windows 9x zustande kommt und stellenweise mit dem SP1 behoben wird) nur beheben, indem man das Tool DXDIAG (unter C:\WINNT\system32\) startet und unter weitere Hilfe die gewünschte Refresh-Rate einstellt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1022.htm


Direct3D oder AGP nicht verfügbar

Sollte über DXDIAG die AGP - oder Direct3D-Unterstützung nicht aktivierbar sein und auch nicht über DXDiag selber wieder eingeschaltet werden können, hilft unter Umständen ein ganz anderer Weg:

Netmeeting starten, Remote Desktop Sharing unter Extras auswählen und aktivieren, danach noch einmal aufrufen und das Kontrollkästchen wieder abwählen. und siehe da, auf einmal geht es wieder! Warum? Keine Ahnung.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0991.htm


Konfiguration der Menü-Animationseinstellungen sichern

Wenn Sie diese Policy aktivieren, wird verhindert, dass Benutzer die Option zum Animieren von Fenstern, Menüs und Listen wählen können.

Die Einstellung unter "Systemsteuerrung" -> "Anzeige" -> unter dem Tabreiter "Darstellung" -> Button "Effekte..." die Einstellung "Eigenschaften von Anzeige" wird "Folgende Übergangseffekte für Menüs und QuickInfos verwenden" deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoChangeAnimation" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eintrag wird gesichert
gelöscht | Eintrag kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Benutzeroberfläche zum Ändern der Menü-Animationseinstellung entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1902.htm


Tastatur-Navigationsanzeiger ausblenden deaktivieren

Wenn Sie diese Policy aktivieren wird, wird der Tastatur-navigationsanzeigende Buchstabe (wird unterstrichen) erst angezeigt, wenn die ALT-Taste gedrückt wird.

Weiterhin wird die Einstellung unter "Systemsteuerrung" -> "Anzeige" -> unter dem Tabreiter "Darstellung" -> Button "Effekte..." die Einstellung "Eigenschaften von Anzeige" wird "Unterstreiche Buchstaben für Tastaturnavigation ausblenden (mit ALT-Taste einblenden)" gesichert und kann nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoChangeKeyboardNavigationIndicators" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird gesichert
gelöscht | Eintrag kann geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Benuteroberfläche zum Ändern der Einstellung für Tastatur-Navigationsanzeige entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1903.htm


Bildschirmschoner aktivieren/deaktivieren

Mit diesem Tipp können Sie den Bildschirmschoner aktivieren.

Durch Aktivieren dieses Tipps wird der Desktopbildschirmschoner aktiviert, falls die folgenden zweiVoraussetzungen zutreffen.

1. Muss ein gültiger Bildschirmschoner auf dem Client Mit diesem Tipp "Bildschirmschoner festlegen" oder über die Systemsteuerung des Clientcomputers festgelegt worden sein.

2. Muss die Wartezeit für den Bildschirmschoner größer als 0 Mit diesem Tipp "Bildschirmschoner Startzeit einstellen" oder über die Systemsteuerung gesetzt worden sein.

Durch Deaktivieren dieses Tipps kann der Bildschirmschoner nicht verwendet werden. Zusätzlich wird der Abschnitt "Bildschirmschoner" auf der Registerkarte "Bildschirmschoner" der Option "Anzeige" in der Systemsteuerung deaktiviert. Folgendermaßen können Benutzer die Bildschirmschoneroptionen nicht ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "ScreenSaveActive" als Datentyp REG_SZ.

Setzen Sie den Wert auf:

1 | Bildschrimschoner aktivieren
0 | Bildschirmschoner deaktivieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Bildschirmschoner

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1948.htm


Bildschirmschoner festlegen

Mit diesem Tipp können Sie festlegen, welcher Bildschirmschoner gestartet werden soll.

Hier können Sie den Namen des Bildschirmschoner festlegen, der gestartet werden soll. Außerdem wird die Dropdownliste der Bildschirmschoner auf der Registerkarte "Bildschirmschoner" in der Option "Anzeige" in der Systemsteuerung deaktiviert, so dass Benutzer den Bildschirmschoner nicht ändern können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "SCRNSAVE.EXE" als Datentyp REG_SZ, und geben Sie den Namen der Bildschirmschonerdatei, einschließlich der Dateinamenerweiterung .scr, ein. Wenn die Bildschirmschonerdatei nicht unter %Systemroot%\System32 gespeichert ist, müssen Sie auch noch den vollständigen gültigen Dateipfad eingeben.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Programmname des Bildschirmschoners

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe dazu auch Tipp: Bildschirmschoner aktivieren/deaktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1949.htm


Kennwortschutz für den Bildschirmschoner aktivieren

Mit diesem Tipp können Sie den Kennwortschutz beim Start des Bildschirmschoners aktivieren.

Wenn Sie diese Tipp aktivieren ist, sind alle Bildschirmschoner durch ein Kennwort geschützt. Wenn Sie diese Einstellung deaktivieren, kann der Kennwortschutz bei Bildschirmschonern auch nicht eingeschaltet werden.

Dadurch wird außerdem das Kontrollkästchen "Kennwortschutz" deaktiviert, welches sich auf der Registerkarte "Bildschirmschoner" bei der Option "Anzeige" in der Systemsteuerung befindet. Hierdurch können Benutzer die Kennwortschutzeinstellung nicht ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "ScreenSaverIsSecure" als Datentyp REG_SZ.

Setzen Sie den Wert auf:

1 | Kennwortschutz ist aktiv
0 | Kennwortschutz ist nicht aktiv und kann nicht aktiviert werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Kennwortschutz für den Bildschirmschoner verwenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe dazu auch Tipp: "Bildschirmschoner aktivieren/deaktivieren" und "Bildschirmschoner Startzeit einstellen"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1950.htm


Bildschirmschoner Startzeit einstellen

Mit diesem Tipp können Sie die Zeit bis zur Aktivierung des Bildschirmschoners konfigurieren.

Wenn dieser Tipp konfiguriert ist, kann die Leerlaufzeit auf einem Wert zwischen 1 bis 86400 Sekunden (entspricht 24 Stunden) festgelegt werden. Falls der Wert auf 0 gesetzt wird, wird der Bildschirmschoner nicht gestartet.

Diese Einstellung hat in folgenden Fällen keine Auswirkungen:

  • Die Wartezeit wurde auf 0 gesetzt.
  • Die Einstellung aus dem Tipp "Bildschirmschoner aktivieren/deaktivieren" ist aktiviert.
  • Weder im Tipp "Bildschirmschoner festlegen" noch unter der Registerkarte "Bildschirmschoner" der Anzeigeeigenschaften auf dem Client wurde ein gültiges und vorhandenes Bildschirmschonerprogramm angegeben.

Wenn Sie diesen Tipp nicht konfigurieren, beträgt die Wartezeit standardmäßig 15 Minuten, unabhängig von der Wartezeit, die auf dem Client auf der Registerkarte "Bildschirmschoner" der Anzeigeeigenschaften festgelegt wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "ScreenSaveTimeOut" als Datentyp REG_SZ. und

geben Sie die Zeit in Sekunden ein:

1-599940 | Startzeit bis der Bildschrimschoner aktiviert wird
0 | Bildschirmschoner deaktiviert

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige
Einstellungsname: | Bildschirmschoner-Zeitlimit

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe dazu auch Tipp: "Bildschirmschoner aktivieren/deaktivieren" und "Bildschirmschoner Startzeit einstellen"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1951.htm


Joystick nicht nur für Administratoren

Damit unter Windows 2000 auch einem Hauptbenutzer ein vom Administrator eingerichtetes Gamepad oder ein Joystick zur Verfügung steht, müssen die folgenden Berechtigungen mittels des Registrierungstools regedt32.exe (nicht regedit, damit können keine Berechtigungen geändert werden) gesetzt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Den Zweig HKEY_LOCAL_MACHINE auf dem lokalen Computer auswählen. Dann bei den folgenden Einträgen den Menüpunkt Sicherheit aufrufen und beim Hauptbenutzer die Berechtigung auf Vollzugriff einstellen für:

SYSTEM\ CurrentControlSet\ Control\ DeviceClasses\ {4d1e55b2-f16f-11cf-88cb-001111000030}

SYSTEM\ CurrentControlSet\ Control\ DeviceClasses\ {cae56030-684a-11d0-d6f6-00a0c90f57da}

SYSTEM\ CurrentControlSet\ Control\ MediaResources\ Joystick

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1194.htm


Kein deutscher Tastaturtreiber bei der Anmeldung

Wenn Sie bei der Anmeldung unter Windows keinen deutschen Tastaturtreiber haben und der erst nach erfolgreicher Anmeldung geladen wird, überprüfen Sie in der Registry folgende Einstellungen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_USERS\ .default\ Keyboard Layout\ Preload

Hier finden Sie den Wert 1 als Datentyp REG_SZ wo angegeben wird, welches Tastaturlayout geladen werden soll. Dieser Wert sollte für die deutsche Tastatur auf 407 und nicht auf 409 stehen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0933.htm


Kurztasten werden ausgeblendet und erst beim Drücken der ALT Taste angezeigt

Unter Windows 2000 werden neuerdings die Kurztasten standardmäßig in den Menüs nicht mehr angezeigt.

Erst wenn Sie die ALT-Taste drücken, wird die Kenzeichnung der Taste angezeigt. Wenn Sie die Einblendung immer haben wollen, gehen Sie folgendermaßen vor:

Start -> Systemsteuerung -> Anzeige -> Effekte

Hier deaktivieren Sie jetzt die Funktion "Tastaturnavigationsanzeiger ausblenden (mit Alt-Taste einblenden)".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0905.htm


Start eines Programms beim Öffnen der Kommandozeilenoberfläche

Bei einem Zugriff auf die Kommandozeilenoberfläche können Sie automatisch vorab ein Programm starten lassen. So können Sie z.B. durch den Start einer CMD-Datei (ENVSET.CMD) Variablen setzen, die zur Ausführung von Programmen benötigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

Erstellen Sie einen neuen Wert mit dem Namen "AutoRun" als Datentyp REG_SZ. Geben Sie hier den Pfad und die Datei an, die ausgeführt werden soll z.B. "C:\Batch\envset.cmd".

Sie können auch mehr als ein Programm angeben, dann müssen Sie die jeweiligen Programme durch zwei &&voneinander trennen. Der Eintrag würde dann z.B. So aussehen: "C:\Batch\Test1.CMD && C:\Batch\Test2.CMD".

Info Wird eine neue CMD mit den Parameter /D gestartet, werden die Einträge in der Registry unter AutoRun nicht ausgewertet.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1118.htm


QBASIC ist unter Windows 2000/XP nicht mehr vorhanden

Microsoft hat das Programm QBasic bei Windows 2000 nicht mehr mitgeliefert. Wenn Sie aber alte QBasic-Programme noch laufen lassen wollen, müssen Sie sich das QBasic von Windows NT auf Ihr System kopieren.

Sie benötigen die Dateien QBASIC.EXE und QBASIC:HLP, die Sie aus dem I386 Verzeichnis mit EXPAND in das System32 entpacken müssen:

Expand qbasic.ex_ %SYSTEMROOT%\system32\qbasic.exe

Expand qbasic.hp_ %SYSTEMROOT%\system32\qbasic.hlp

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0842.htm


Scripting Engine wechseln

Wenn Sie ein Script ausführen, wird von Windows automatisch die "WSCRIPT" - Shell verwendet. Das bedeutet, dass alle Informationen über Pop-Up Fenster auf dem aktuellen Desktop ausgegeben werden. Wenn man aber damit gerade arbeitet, kann das störend sein. Sie können die Shell über folgenden Befehl umstellen:

CSCRIPT /H:CSCRIPT /S

Jetzt werden keine Informationen mehr in der aktuellen Shell ausgegeben. Über

CSCRIPT /H:WSCRIPT /S

können Sie wieder auf die alte Einstellung umstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1001.htm


Ausführen der Kommandozeilenoberfläche (CMD.EXE) unterbinden

Dieser Tipp legt fest, das Anwender die Eingabeaufforderung (CMD.EXE) nicht ausführen dürfen.Zusätzlich legt die Einstellung fest, ob Batchdateien (.cmd und .bat) auf dem Computer ausgeführt werden dürfen.

Info Sie sollten das Ausführen von Batchdateien nicht deaktivieren, falls Batch-Skripte zum Anmelden, Abmelden, Starten oder Herunterfahren des Computers verwendet werden.

Damit der Anwender die Kommandozeilenoberfläche (CMD.EXE) nicht mehr ausführen kann, müssen Sie folgenden Registry-Schlüssel setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System

legen Sie einen neuen Eintrag mit dem Namen "DisableCMD" als Datentyp REG_DWORD an. Sie können hier jetzt folgende Werte setzen:

0 oder Schlüssel nicht vorhanden | Anwender kann CMD.EXE ausführen
1 | Anwender kann CMD.EXE nicht ausführen, das System kann aber noch Batch-Dateien ausführen
2 | Anwender kann keine CMD.EXE ausführen und das System darf auch keine Batch-Dateien mehr starten.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Zugriff auf Eingabeaufforderung verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1052.htm


Befehlserweiterungen der Kommandozeilenoberfläche deaktivieren

Die Befehlserweiterungen sind standardmäßig aktiviert und können mit der Option "/E:OFF" für einen CMD Aufruf ausgeschaltet werden. Die Einstellung hat Auswirkungen auf folgende Befehle:

Assoc

Call

Color

CD

DEL

Endlocal

For

Ftype

Goto

If

MD

Prompt

Pushd

Popd

Set

Setlocal

Shift

Start

Durch einen Registryeintrag können Sie die Befehlserweiterungen auch immer für alle Kommandozeilenoberflächen ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Command Processor

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableExtensions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Befehle sind deaktiv
1 | Befehle sind aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1518.htm


Verzögerte Umgebungsvariablenerweiterung aktivieren

Wenn Sie die sog. Verzögerte-Umgebungsvariablenerweiterung aktivieren, kann das Ausrufezeichen dazu verwendet werden, um einen Wert aus einer Umgebungsvariable zur Laufzeit zu ersetzen. Diese Funktion ist normalerweise nicht aktiv und kann durch den Parameter „/V:ON“ beim Aufruf der CMD.EXE aktiviert werden.

Durch einen Registryeintrag können Sie die verzögerte Umgebungsvariablenerweiterung für alle Kommandozeilenoberflächen ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Command Processor

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Command Processor

Erstellen Sie hier einen neuen Wert mit dem Namen "DelayedExpansion" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verzögerung ist aktiv
0 | Verzögerung ist deaktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1519.htm


Worttrennzeichen (Word separators) für Eingabeaufforderung festlegen

Mit diesem Tipp legen Sie die Worttrennzeichen fest.

Wenn Sie in einer Eingabeaufforderung mit den Tasten [Strg+Links] und [Strg+Rechts] (ohne die eckigen Klammern!) arbeiten, legen Sie die Trennzeichen fest, wo der Cursor anhält.

Wenn Sie " ,;" " eingeben, legen Sie als Trennzeichen (Leerzeichen, Komma, Semikolon, 2 x Ein-/Ausführungszeichen-oben) fest.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Console

ändern Sie hier den Wert "WordDelimiters" als Datentyp REG_SZ und geben Sie die gewünschten Trennzeichen ein.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2066.htm


Windows Script Host Startinfo ausschalten

Wenn Sie ein cScript starten, wird immer ein Vorspann mit ausgegeben, der über die WSH-Version informiert:

Beispiel: Microsoft (R) Windows Script Host, Version 5.1 für Windows

Copyright (C) Microsoft Corporation 1996-1999. Alle Rechte vorbehalten.

Über die Kommandozeile können Sie das jeweils für diese Sitzung über /Nologo ausschalten. Mit diesem Tipp können Sie diese Infomeldung für alle Sitzungen deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows Script Host\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DisplayLogo" als Datentyp REG_SZ. Setzen Sie den Wert auf:

0 | Displaymeldung ausschalten
1 | Displaymeldung anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2189.htm


CD-Kommando mit neuen Parametern

Auch der CD-Befehl der Kommandozeilenoberfläche wurde von MS überarbeitet. Da ja nicht jeder bei diesem Standardbefehl CD /? ausführt, möchte ich diese nützlichen Erweiterungen hier vorstellen.

Mit dem Parameter /D können Sie jetzt auch Laufwerke wechseln. Beispiel: "CD /D D:\Test" wechselt in das Verzeichnis Test auf Laufwerk D, egal auf welchem Laufwerk Sie sich gerade befinden.

Weiterhin können Sie jetzt auch das Wildcard "*" verwenden und müssen so den Verzeichnisnamen nicht mehr vollständig ausschreiben. So wechselt z.B. "CD PR*" in das Verzeichnis "Programme".

Parameter:

CHDIR [/D] [Laufwerk:][Pfad]

CHDIR [..]

CD [/D] [Laufwerk:][Pfad]

CD [..]

.. | Gibt an, dass Sie in das übergeordnete Verzeichnis wechseln möchten.
/D | Verwenden Sie diese Option, um gleichzeitig das Verzeichnis und das aktuelle Laufwerk zu wechseln.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1009.htm


Anzeigen/Ändern der Verschlüsselungen (CIPHER.EXE)

Mit dem Kommandozeilentool CIPHER können Sie die Verschlüsselungen (EFS)von Verzeichnissen und Dateien auf NTFS-Partitionen anzeigen/verändern.

Aufruf/Parameter:

CIPHER [/E | /D] [/S:dir] [/A] [/I] [/F] [/Q] [/H] [/K] [Verzeichnisname [...]

/E | Verschlüsselt die angegebenen Verzeichnisse. Verzeichnisse werden so gekennzeichnet, dass Dateien, die später hinzugefügt werden, verschlüsselt werden.
/D | Entschlüsselt die angegebenen Verzeichnisse. Verzeichnisse werden so gekennzeichnet, dass Dateien, die später hinzugefügt werden, nicht verschlüsselt werden.
/S | Führt die angegebene Operation für alle Verzeichnisse des angegebenen Verzeichnisses und dessen Unterverzeichnisse aus.
/A | Führt die Operation sowohl für Dateien wie auch für Verzeichnisse aus. Die verschlüsselte Datei wird möglicherweise bei der Bearbeitung entschlüsselt, falls das Stammverzeichnis nicht verschlüsselt ist. Es wird empfohlen, dass sowohl die Datei wie auch das Stammverzeichnis verschlüsselt werden.
/I | Führt die angegebene Operation auch nach Fehlern weiter aus. Standardmäßig wird CIPHER beim Auftreten eines Fehlers abgebrochen.
/F | Erzwingt die Verschlüsselung aller Objekte, selbst wenn diese bereits verschlüsselt sind. Standardmäßig werden Verzeichnisse, die bereits verschlüsselt sind, ignoriert.
/Q | Gibt nur die wichtigsten Informationen aus.
/H | Zeigt versteckte Dateien oder Systemdateien an. Standardmäßig werden diese Dateien nicht angezeigt.
/K | Erstellt einen neuen Schlüssel zum Dateiverschlüsseln für den Benutzer, der CIPHER ausführt. Wenn diese Option gewählt wird, werden alle anderen Optionen ignoriert.
Verzeichnisname: | Gibt ein Muster, eine Datei oder ein Verzeichnis an.

Werden keine Parameter angegeben, gibt CIPHER den Verschlüsselungsstatus des aktuellen Verzeichnisses und der darin enthaltenen Dateien aus. Es können mehrere Verzeichnisse und Platzhalter angegeben werden. Mehrere Parameter müssen durch Leerzeichen getrennt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1006.htm


Die Systemdateienüberprüfung: SFC.EXE

Zur Sicherheit des Betriebssystems hat MS eine Überprüfung der Systemdateien eingebaut. Dafür läuft im Hintergrund ein Dienst, der die wichtigsten Systemdateien (DLL, EXE, SYS und OCX-Dateien) überwacht.

Bei der Installation von Software kann es nun vorkommen, dass eine Systemdatei durch eine andere Version der Software ersetzt wird. Der Systemdateischutz bekommt diesen Austausch mit und überprüft, ob die Signatur der Datei in seiner Katalogdatei vorhanden ist. Wird die Signatur in der Katalogdatei gefunden , handelt es sich um eine korrekte Datei von MS und der Austausch wird zugelassen.

Ist diese Dateisignatur aber nicht verzeichnet, wird die Datei wieder durch die Originaldatei zurück ersetzt. Diese Originalversion wird aus dem Verzeichnis "DLLCache" entnommen. Ist sie dort nicht vorhanden, werden Sie aufgefordert, den Datenträger einzulegen, der das Betriebssystem enthält.

Hiermit soll gewährleistet werden, dass keine Abstürze durch fehlerhafte Dateien entstehen können.

Weiterhin wird mit der Datei "sfcfiles.dll" von MS eine Exclude-Liste festgelegt. In dieser Datei werden die Dateien angegeben, die ausgeschlossen werden und somit nicht von SFC überwacht werden.

Mit dem Programm SFC.EXE (System File Checker) können Sie die Überprüfung beeinflussen.

SFC.EXE [Parameter]

Windows 2000/XP:

/Scannow | Überprüft sofort alle geschützten Systemdateien
/Scanonce | Überprüft einmalig alle geschützten Systemdateien beim nächsten Neustart des Systems
/Scanboot | Überprüft alle geschützten Systemdateien bei jedem Start
/Cancel | Schaltet die Überprüfung aller geschützten Systemdateien ab
/Quiet | Ersetzt alle Systemdateien ohne Benutzerrückfrage
/Purgecache | Löscht den Dateispeicher und überprüft sofort alle Systemdateien
/Cachesize=x | Legt die Größe des Dateispeichers fest
/Enable | Aktiviert SFC

Ab Windows Vista:

/SCANNOW | Überprüft die Integrität alle geschützter Systemdateien und repariert ggf. Dateien mit Fehlern.
/VERIFYONLY | Überprüft die Integrität alle geschützter Systemdateien, führt aber keine Reparatur bei Fehler durch
/SCANFILE | Überprüft die Integrität der angegebenen Datei und repariert ggf. die Fehler
/VERIFYFILE | Überprüft die Integrität der angegebenen Datei, führt aber keine Reparatur der Fehler durch
/OFFBOOTDIR | Gibt den Speicherort des Offlinestartverzeichnisses für Offlinereparaturen an
/OFFWINDIR | Gibt den Speicherort des Offline-Windows-Verzeichnisses für Offlinereparaturen an

Windows 2000/XP:

Dateien, die als ordnungsgem. erkannt werden sollen, müssen dem DLL-Cache hinzugefügt werden. Der DLL-Cache befindet sich im Verzeichnis "%SYSTEMROOT%\System32\DllCache".

Die Einstellungen für WFP (Windows File Protection) können in der Registry vorgenommen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Wert | Datentyp | Bedeutung und Wertebereich
SFCQuota | REG_DWORD | Größe in MBytes für den DLLCache 0x1 bis 0xFFFFFFFF 0x32 <- 50 MB (Standard)
SFCDllCacheDir | REG_EXPAND_SZ | Pfad für den DLLCache Nur bei Windows 2000 bis SP1 möglich (siehe Hinweis unten)
SFCDisable | REG_DWORD | DLL-Cache ausschalten Weitere Infos: (System File Protection deaktivieren) Nur bei Windows 2000 bis SP1 möglich (siehe Hinweis unten)
SFCScan | REG_DWORD | Hier können Sie einstellen wie oft SFC laufen soll. Standard ist 1. 0 = Systemdateien nicht überprüfen 1 = Überprüfen bei jedem Startvorgang 2 = Nur einmalig überprüfen
SFCShowProgress | REG_DWORD | Bestimmt, ob beim Ausführen von SFC eine Bildschirmausgabe erfolgen soll. 0 = aus 1 = ein

Info Ab Windows XP_SP2 bzw. XP wurden diese Funktionen deaktiviert. Auch wenn die Einträge in der Registry vorhanden sind, werden sie nicht mehr ausgelesen. Wenn Sie die Funktionen benutzen wollen, dann müssen Sie die Datei SFC.DLL bearbeiten. Dazu finden Sie unter "(System File Protection deaktivieren)" genauere Informationen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0503.htm


Datenträgerkontingente über die Kommandozeile verwalten

Ab Windows XP gibt es ein neues Tool "FSUTIL.EXE", mit dem Sie über die Datenträgerkontingente das Dateisystem bearbeiten können. Normalerweise können Sie das über die Oberfläche -> "Datenträger" -> rechte Maustaste "Eigenschaften" unter dem Tabreiter "Kontingent" machen.

Parameter:

behavior | Steuert das Dateisystemverhalten
dirty | Verwaltet fehlerhafte Bits auf dem Volume
file | Dateispezifische Befehle
fsinfo | Dateisysteminformationen
hardlink | Hardlinkverwaltung
objectid | Objektkennungverwaltung
quota | Kontingentverwaltung
repasepoint | Analysepunktverwaltung
sparse | Steuert geringe Dateidatendichte
usn | USN-Verwaltung
volume | Volumenverwaltung

Weitere mögliche Parameter von:

behavior / dirty:

query | Aktuelle Einstellung abfragen
set | Aktuelle Einstellung setzen

file:

findbysid | Sucht nach einer Datei mittels der Sicherheitskennung
queryallocranges | Sucht die reservierten Bereiche nach einer Datei ab
setshortname | Legt den Kurznamen für eine Datei fest
setvaliddata | Legt die gültige Datenlänge für eine Datei fest
setzerodata | Setzt Daten einer Datei auf NulL
createnew | Erzeugt eine neue Datei mit der angegebenen Größe

fsinfo:

drives | Listet alle Laufwerke auf
drivetype | Fragt Laufwerkstyp nach einem Laufwerk ab
valumeinfo | Fragt Valueinformationen ab
ntfsinfo | Fragt NTFS-spezifische Valumeinformationen ab
statistics | Fragt Dateisystemstatistik ab

hardlink:

create

Erstellt einen Hardlink

objectid:

query | Fragt die Objektkennung ab
set | Ändert die Objektkennung
delete | Löscht die Objektkennung
create | Erstellt eine Objektkennung

quota:

disable | Aktiviert Kontigentnachverfolgung und -durchsetzung
track | Aktiviert Kontigentnachverfolgung
enforce | Aktiviert Kontigentendurchsetzung
violations | Zeigt Kontigentenüberschreitungen an
modify | Legt das Datenträgerkontingent für einen Benutzer fest
query | Fragt Datenträgerkontigente ab

repasepoint:

query | Fragt einen Analysenpunkt ab
delete | Löscht einen Analysenpunkt

sparse:

setflag | Legt Datendichte fest
queryflag | Fragt Datenträgerdichte ab
queryrange | Fragt Bereich ab
setrange | Legt Datendichtebereich fest

usn:

createjournal | Erstellt ein USN-Journal
deletejournal | Löscht ein USN-Journal
enumdata | Listet USN-Daten auf
queryjournal | Fragt die USN-Daten für ein Volumen ab
readdata | Liest die USN-Daten für eine Datei

volume:

dismount | Hebt die Bereitstellung eines Volumens auf
diskfree | Fragt den freien Speicher eines Volumens ab

Info Dieses Tool kann auch unter Windows 2000 benutzt werden, Sie brauchen nur die Datei zu kopieren, weitere Datei sind nicht nötig.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1441.htm


Routen finden mit Pathping

Bei Windows ist ein praktisches Tool "Pathping" mit dabei. Es ist eine Mischung zwischen Tracert und Ping.

Jedem Rechner auf einer Route werden dabei Pakete zugesendet und der Datenverlust im Laufe der Route wird mit angezeigt. Dadurch kann man relativ leicht herausfinden, welcher der Router oder Rechner auf dem Weg zum Zielrechner Probleme verursacht.

pathping [-g Hostliste] [-h max. Abschnitte] [-i Adresse] [-n] [-p Zeitraum] [-q Abfrageanzahl] [-w Zeitlimit] [-P] [-R] [-T] [-4] [-6] Zielname

Mögliche Optionen:

-g Hostliste | "Loose Source Route" gemäß Hostliste.
-h max. Abschnitte | Max. Anzahl an Abschnitten bei Zielsuche.
-i Adresse | Verwendet die angegebene Quelladresse.
-n | Adressen nicht in Hostnamen auflösen.
-p Zeitraum | Wartezeit in Millisekunden zwischen Pings.
-q Abfrageanzahl | Anzahl der Abfragen pro Abschnitt.
-w Zeitlimit | Zeitlimit in Millisekunden für eine Antwort.
-P | Überprüft RSVP-Pfadkonnektivität.
-R | Überprüft, ob jeder Abschnitt RSVP unterstützt.
-T | Überprüft Verbindung zu jedem Abschnitt mit Layer-2-Prioritätskennungen.
-4 | Erfordert Verwendung von IPv4.
-6 | Erfordert Verwendung von IPv6.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2013.htm


Variablen mit Programmaufruf

Jedem ist so weit bekannt, dass man mit „SET <Variablenname>=<Inhalt>“ eine Variable anlegen kann und auf den Inhalt nachher jederzeit zurückgreifen kann. Weniger bekannt ist aber, dass Sie auch einen Programmaufruf hinterlegen können.

So speichert z.B.: SET TEST=^&notepad

in der Variable Test den Aufruf von Notepad, wenn Sie jetzt diese Variable mit echo.%test% aufrufen, wird nicht etwa Notepad ausgeben, sondern es wird Notepad gestartet.

Für die Batchverarbeitung kann diese Funktion recht nützlich sein.

Bedeutung:

& | Verknüpft Befehle miteinander
^ | Leitet ein, dass das nachfolgende Zeichen nicht als Steuerzeichen interpretiert wird
. (Punkt) | Verhindert bei Echo die Ausgabe von Echo OFF, da durch die Variable %test% eine & Verknüpfung übergeben wurde, würde das echo also als alleiniger Befehl interpretiert

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1486.htm


Zufallszahlen erzeugen

Auch in einer BATCH-Datei können Sie Zufallszahlen erzeugen. Dafür gibt es den neuen Befehl Systemvariable %random% mit der sich Werte zwischen 0 – 32768 erzeugen lassen.

Durch einen entsprechenden Aufruf können Sie den Bereich beliebig bestimmen:

SET MIN=10

SET MAX=50

SET /a Zufall=MIN+(MAX-MIN+1)*%random%/32768

Gibt einen Wert zwischen 10 und 50 aus. Dieser Wert wird der Variable Zufall zugewiesen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1489.htm


Gemischter und einheitlicher Modus

Unter Windows 2000 gibt es den "gemischten Modus" (Mixed Mode) und den "einheitlichen Modus" (Native Mode).

Wenn Sie in ihrem Netzwerk noch Windows NT 4.x BDC Rechner betreiben wollen, muss Windows 2000 im "gemischten Modus" betrieben werden. Haben Sie aber alle Rechner auf Windows 2000 umgestellt (betrifft nur NT 4.x BDC Rechner und keine Memberserver), können Sie in den "einheitlichen Modus" wechseln.

Standardmäßig arbeitet Windows 2000 bei der Einrichtung im "gemischten Modus" und Sie müssen das Umwandeln in den "einheitlichen Modus" selber vornehmen.

Im "gemischten Modus" übernimmt der FSMO von Windows 2000 die Rolle der PDC-Master für die noch im Netz befindlichen Windows NT Server.

Die Umstellung auf den "einheitlichen Modus" ist sehr einfach, Sie sollten aber bedenken, dass Sie eine einmal durchgeführte Umstellung nicht wieder rückgängigmachen können. Haben sie aber keinen NT 4.x BDC mehr im Netzwerk, sollten Sie den Modus ruhig umstellen, da dadurch weitere neue Funktion zur Verfügung stehen, die im "gemischten Modus" nicht angeboten werden (siehe z.B. "Gruppenarten in Windows").

Um die Umstellung durchzuführen, öffnen Sie im der MMC das Snap-In "Active Directory-Benutzer und -Computer" und verbinden sich mit dem Domänen-Controller. Ändern Sie hier jetzt unter Eigenschaften einfach nur den Modus vom "gemischten Modus" in den "einheitlichen Modus". Damit diese Änderung wirksam wird, müssen Sie nach dem Replizieren der Änderung den Domänen-Controller neu starten, danach arbeitet Windows 2000 im "einheitlichen Modus".

Unterschiede im Überblick

Funktion | Mixed Mode | Native Mode
NetBIOS | NetBIOS wird für NT 4.x benötigt und kann nicht abgeschaltet werden | NetBIOS kann abgeschaltet werden
Gruppen | NT 4.x Gruppenzuordnung | Neue Windows 2000 Gruppenzuordnung (siehe: "Gruppenarten in Windows")
Replikation | Der PDC-Master (FSMO) sendet Aktualisierung an Windows NT 4.x BDC Server. | Nur noch die Windows 2000 Replikation wird unterstützt
RID-Belegung | Zentralisiert auf dem FSMO | Verteilt
Echtheitsbestätigung | NT-LAN-Manager-Echtheitsbestätigung wird bei NT Rechnern verwendet. Die Kerberos-Echtheitsbestätigung wird bei Windows 2000 Server benutzt | Nur noch die Kerberos- Echtheitsbestätigung wird unterstützt

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1148.htm


Gruppenarten in Windows

Gruppen wurde eingeführt, damit Rechte nicht direkt an Benutzern vergeben werden müssen. Benötigt ein Benutzer bestimmt Berechtigungen, wird dafür eine entsprechende Gruppe eingerichtet und der Benutzer wird dieser Gruppe zugewiesen. Wenn schon zwei Benutzer die gleiche Berechtigung benötigten, ist diese Art der Rechtevergabe übersichtlicher.

Gruppen bei Windows NT

Bei Windows NT gab es nur zwei Arten von Gruppen (lokale und globale Gruppen). Die Regeln waren hier noch recht einfach und übersichtlich.

Globale Gruppen konnten nur Benutzerkonten aufnehmen und

lokalen Gruppen konnten Benutzerkonten und globale Gruppen enthalten.

Tabelle 1

Art der Gruppe | Benutzer aufnehmen | globale Gruppen aufnehmen
lokal | Ja | Ja
global | Ja | Nein

Standardmäßig wurden über die lokalen Gruppen die Zugriffe auf die Ressourcen geregelt und die Benutzerkonten den globalen Gruppen zugeordnet. Sollte ein Benutzer Zugriff auf eine Ressource bekommen, wurde die globale Gruppe einfach in die lokale Gruppe aufgenommen.

Hinweis:

Administratoren, die Ihr Netzwerk auf Windows 2000 umstellen wollen, sollten diese Regel beachtet haben, da Windows bei der Umstellung der Gruppen von dieser Regelung ausgeht.

Gruppen ab Windows 2000

Ab Windows 2000 gibt es jetzt 3 Arten von Gruppen (lokale, globale und universelle Gruppen) die es jeweils noch als zwei Typen gibt (Sicherheits- und Verteilergruppen). Lokale und globale Gruppen sind die bekannten Gruppen aus Windows NT und können nur innerhalb einer Domäne existieren. Aus diesem Grunde wurden noch die universellen Gruppen für den globalen Katalog eingeführt. Diese Gruppen gelten über die Grenzen einer Domäne hinweg in der gesamten Struktur.

Lokale Gruppen:

Lokale Domänengruppen werden vor allem verwendet, um Berechtigungen für Ressourcen zuzuweisen. Eine lokale Gruppe hat folgende Eigenschaften:

  • Offene Mitgliedschaft
    Es können Personen aus beliebigen Domänen hinzugefügt werden
  • Zugriff auf Ressourcen in einer Domäne
    Über eine lokale Domänengruppe können Berechtigungen auf eine Ressource zugewiesen werden, die sich in der gleichen Domäne befindet, wie die lokale Gruppe

Globale Gruppen:

Globale Gruppen werden in der Regel verwendet, um Benutzer zu organisieren. Eine globale Gruppe hat folgende Merkmale:

  • Eingeschränkte Mitgliedschaften
    Nur Personen aus der gleichen Domäne können in die Gruppe aufgenommen werden.
  • Zugriff auf Ressourcen in allen Domänen
    Über eine globale Gruppe können Berechtigungen auf eine Ressource zugewiesen werden, die sich in einer beliebigen Domäne befinden

Universelle Gruppen:

Universelle Gruppen werden vor allem verwendet, um verbundene Ressourcen in mehreren Domänen Berechtigungen zuzuweisen. Eine universelle Sicherheitsgruppe hat folgende Merkmale:

  • Offene Mitgliedschaft
    Es können Personen aus beliebigen Domänen hinzugefügt werden
  • Zugriff auf Ressourcen in allen Domänen
    Über eine globale Gruppe können Berechtigungen auf eine Ressource zugewiesen werden, die sich in einer beliebigen Domäne befinden
  • Nur im einheitlichen Modus verfügbar (d.h. auch im Mixed Mode 2000/2003)

Was ist eine Sicherheitsgruppe?

Mit Sicherheitsgruppen kann der Zugriff auf das Active Directory, Objekte und Verzeichnisse/Dateien geregelt werden, und sie können in deren ACL (Access Control Lists) auftauchen. Die Mitgliedschaft dieser Gruppen wird bei der Anmeldung überprüft, und alle Benutzerrechte werden hiermit geregelt.

Was ist eine Verteilergruppe?

Gewährt den Zugriff auf Verteilerlisten (E-Mail Verteiler), es können hiermit aber keine Benutzerrechte gesetzt werden. Diese Gruppenart wird bei der Anmeldung nicht berücksichtigt. Das hat den Vorteil, dass selbst, wenn ein Anwender in vielen Verteilerlisten ist, die Anmeldezeit dadurch nicht beeinflusst wird.

Zwei Modi (Mixed/Native Mode)

Will man jetzt betrachten, welche Gruppe in anderen Gruppen aufgenommen werden kann, muss man einen wichtigen Punkt beachten. Je nachdem, in welchem Modus Windows betrieben wird, unterscheidet sich diese Übersicht.

Arbeitet Windows noch im so genannten "gemischten Modus - Mixed Mode" (Windows und NT BDC Server werden noch zusammen eingesetzt) oder im "einheitlichen Modus . Native Mode" (nur noch Windows Server werden eingesetzt) (weitere Infos unter "Gemischter und einheitlicher Modus"). Da sich im "gemischten Modus" der NT BDC noch mit dem Windows FSMO abgleichen muss (dieser übernimmt die Rolle des PDC), müssen auch die Gruppen die Regeln von Windows NT beachten.

Darum habe ich hier zwei Tabellen für den jeweiligen Modus erstellt:

Gemischter Modus (Mixed Mode):

Tabelle 2

 |  | lokal | lokal | global | global
Gruppe | Typ | Verteiler | Sicherheit | Verteiler | Sicherheit
lokal | Verteiler | Ja | Ja | Ja | Ja
lokal | Sicherheit | Nein | Nein | Ja | Ja
global | Verteiler | Nein | Nein | Ja | Ja
global | Sicherheit | Nein | Nein | Nein | Nein

Info Im gemischten Modus gibt es die Gruppenart "universell" nicht!

Einheitlicher Modus (Native Mode):

Tabelle 3

 |  | lokal | lokal | global | global | universell | universell
Gruppe | Typ | Verteiler | Sicherheit | Verteiler | Sicherheit | Verteiler | Sicherheit
lokal | Verteiler | Ja | Ja | Ja | Ja | Ja | Ja
lokal | Sicherheit | Ja | Ja | Ja | Ja | Ja | Ja
global | Verteiler | Nein | Nein | Ja | Ja | Nein | Nein
global | Sicherheit | Nein | Nein | Ja | Ja | Nein | Nein
universell | Verteiler | Nein | Nein | Ja | Ja | Ja | Ja
universell | Sicherheit | Nein | Nein | Ja | Ja | Ja | Ja

Info Die Unterschiede zu Tabelle 2 wurden ROT dargestellt

Umwandeln von Gruppen

Ab Windows 2000 können Sie jetzt jederzeit die Gruppenart verändern. Beim Umwandeln eines Gruppentypen in einen anderen müssen Sie natürlich beachten, dass diese Gruppe keine Einträge enthält, die in der neuen Gruppe nicht vorhanden sein darf.

Wollen Sie z.B. eine lokale Gruppe in eine globale Gruppe umwandeln die aber noch eine lokale Gruppe enthält, wird von Windows 2000 diese Umwandlung nicht durchgeführt, da eine globale Gruppe keine lokale Gruppe enthalten kann.

Sie können im "einheitlichen Modus" auch den Typ der Gruppe ändern und Sicherheitsgruppen <-> Verteilergruppen umwandeln und globale/lokale Gruppen können zu universellen Gruppen umgewandelt werden, wenn sie den Bedingungen aus Tabelle 3 entsprechen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1147.htm


Der DNS-Server löst keine Internetnamen mehr auf

Wenn man bei der Installation von Active Directory die automatische Installation des DNS-Server durchführen lässt, können Sie nachher nicht mehr auf das Internet zugreifen, wenn Sie die eine Nachfrage falsch beantworten.

Bei der Installation von DNS über den Wizard, werden Sie gefragt, ob der DNS-Server zum "Root-Server" gemacht werden soll. Diese Auswahlmöglichkeit ist auch schon als Voreinstellung aktiviert, wenn Sie aber das bestätigen, wird Ihr DNS-Server zum Haupt-DNS-Server. Wenn Sie in Ihrem Browser jetzt auf eine Internetseite zugreifen wollen, wird Ihr DNS-Server zur Namensauflösung benutzt, da Ihr DNS-Server jetzt der "Root-Server" ist, versucht er selber, die URL aufzulösen und leitet diese Anfrage auch nicht mehr weiter. Da er das natürlich nicht kann, erhalten Sie die Fehlermeldung, dass der HOST nicht gefunden werden konnte.

Damit wieder alle Funktionen fehlerfrei funktionieren, müssen Sie aus Ihrem DNS-Server den Root-Domänen Namen entfernen. Die Root-Domäne wird mit einen Punkt (.) als Name gekennzeichnet.

Starten Sie also den DNS-Servermanager und , wenn Ihr DNS-Server als "Root-Server" eingerichtet ist, hat er auf der rechten Seite zusätzlich zu Ihren Domänennamen auch noch einen Punkt (.) als Eintrag. Klicken Sie den Punkt an und löschen Sie diesen Eintrag aus dem DNS-Server.

Damit der DNS-Server Anfragen, die er nicht beantworten kann, weiterreicht, müssen Sie folgende Einstellungen vornehmen:

  1. Klicken Sie auf der linken Seite mit der rechten Maustaste auf den Server-Namen.
  2. Wählen Sie aus dem Kontextmenü "Eigenschaften" -> "Forwarders"
  3. Aktivieren Sie hier die Box "Enable Forwarders"
  4. Tragen Sie darunter die IP-Adresse des DNS-Servers Ihres Providers ein.

Wenn man "Enable Forwarders" nicht aktiviert, versucht der DNS-Server über die DNS-Server Liste unter "Eigenschaften" -> "Root Hints" auch den Namen aufzulösen. Diese Lösung ist aber meist nicht so schnell, da Ihr Internetanbieter oft eine schnellere Internetanbindung hat und die Liste der meisten DNS-Server im Cache hält.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0823.htm


DHCP Backup Zeit

Windows gibt in seiner Hilfe an, dass die Standard DHCP Backupzeit 15 Minuten beträgt. Das ist aber falsch, die Standard Backupzeit beträgt 60 Minuten.

Die Zeit können Sie in der Registry unter folgenden Schlüssel ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ DhcpServer\ Parameters

Hier finden Sie den Eintrag "BackupInterval" als Datentyp REG_DWORD. Die möglichen Werte liegen zwischen 1 bis 71582 und entsprechen der Zeitangabe in Minuten.

Des weiteren finden Sie hier noch den Eintrag "BackupDatabasePath" als Datentyp REG_EXPAND_SZ, welcher das Backupverzeichnis für die DHCP- Client Datenbank angibt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1008.htm


Debug Modus im RIS Server aktivieren

Wenn man einen Fehler auf dem RIS-Server suchen muss, ist man oft auf eine ausführliche Logdatei angewiesen.

Dafür kann man den BinlSvc (Boot Information Negotiation Layer) in einem anderen Debug-Modus starten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Stoppen Sie den "Boot Information Negotiation Layer" Service: "net stopp binlsvc"

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Binlsvc\ Parameters

Erstellen Sie einen neuen Eintrag mit dem Namen "Debug" als Datentyp REG_DWORD und setzen den Wert auf 0x80FFFFFF

(Normaler Debug Modus; 0x00FFFFFF = ausführlicher Debug Modus)

Nun müssen Sie noch zusätzlich noch den Eintrag "ImagePath" unter

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Binlsvc

von "%SYSTEMROOT%\System32\tcpsvcs.exe" auf "ntsd -g -G %SYSTEMROOT%\System32\tcpsvcs.exe" abändern.

Starten Sie den Service wieder neu: "net start binlsvc". Das Log finden Sie unter %SYSTEMROOT%\Debug\Binlsvc.log.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1316.htm


Browsen in Freigaben auf Windows 9x/ME-Systemen sehr langsam

Wenn Windows 2000 in Freigaben auf Windows ME- und Windows 9x-Maschinen browst, wird von Windows 2000 zunächst geprüft, ob geplante Tasks für diese Maschine zu starten sind. Da dies in der Regel nicht der Fall ist, kann man diese Funktion deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ RemoteComputer\ NameSpace

löscht man den Schlüssel {D6277990-4C6A-11CF-8D87-00AA0060F5BF} (vorher bitte über EXPORT sichern) und hat damit die Funktion deaktiviert. Das Anzeigen von Freigaben sollte jetzt etwas zügiger ablaufen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1166.htm


DNS Auflösungscache auf dem Windows Client

Wenn Sie auf Internetseiten zugreifen, muss Windows als erstes den Namen der Seite auflösen. Dafür wird eine Namensanfrage an einen DNS-Server weitergereicht, der die entsprechenden Informationen zurückliefert. Damit Windows diese Anfrage nicht immer für die gleichen Internetadressen durchführen muss, werden die Ergebnisse im DNS-Cache abgelegt. Dieser DNS-Cache ist aber nicht besonders groß, weshalb diese Informationen nicht lange erhalten bleiben. Erst wenn er von dort nach einer gewissen Zeit (TTL-Limit) keine Antwort erhält, wird die Anfrage weitergereicht.

Über die Eingabeaufforderung können Sie sich den Inhalt des Caches anschauen und löschen.

Der Befehl "ipconfig /displaydns" zeigt den aktuellen Inhalt, mit "ipconfig /flushdns" können Sie den Cacheinhalt löschen.

Wenn Sie den Cache entsprechend erhöhen, können Sie dadurch meist die Internet-Geschwindigkeit verbessern. Stellen Sie dafür folgende Werte ein:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Dnscache\ Parameters

Alle Werte, wenn sie noch nicht vorhanden sind, sind als Datentyp REG_DWORD anzulegen:

Wertname

Werte (Dezimal)

Beschreibung

CacheHashTableBucketSize

Standard: 0xa (10 Dezimal)

Bereich: 10-50 (Dezimal)

Empfehlung: 50

Mit diesem Parameter kann die max. Anzahl von Spalten in der Hashtabelle gesteuert werden, die von dem DNS-Cacheauflösungsdienst verwendet wird.

CacheHashTableSize

Standard: 0xD3 (211 Dezimal)

Gültiger Bereich: Jede Primzahl, die größer als 0 ist

Empfehlung: Hier ist jeder Wert über 211 Dezimal (Standard) zu empfehlen.

Mit diesem Parameter kann die max. Anzahl von Zeilen in der Hashtabelle gesteuert werden, die von dem DNS-Cacheauflösungsdienst verwendet wird.

Windows 2000:

MaxCacheEntryTtlLimit

Ab XP:

MaxCacheTtl

Zeit in Sekunden

Standard: 86400 (1Tag)

Bereich: 0-FFFFFFFF

Empfehlung: 172800 (2 Tage)

Mit diesem Wert legen Sie die Gültigkeitsdauer des DNS-Caches in Sekunden fest. Ist die Zeit abgelaufen, wird die Anfrage an den DNS-Server weitergeleitet.

Wenn Sie den Wert auf 1 setzen, werden keine Anfragen mehr über den DNS-Cache aufgelöst und alle Anfragen werden sofort an den DNS-Server weitergeleitet (nicht zu empfehlen).

MaxSOACacheEntryTtlLimit

Standard: 120 (2 Minuten)

Bereich: 0-FFFFFFFF

Empfehlung: 300 (5 Minuten)

Legt die Zeit in Sekunden fest, wie lange SOA (Start of Authority)-Datensätze zwischengespeichert werden. Dieser Wert sollte nicht zu groß gewählt werden, um sicherzustellen, dass die aktuellen Daten verfügbar sind.

Windows 2000:

NegativeCacheTime

Ab XP:

MaxNegativeCacheTtl

Standard: 300 (5 Minuten)

Bereich: 0-FFFFFFFF

Empfehlung: 0

Auch Namensauflösungen, die nicht erfolgreich waren, werden zwischengespeichert (negativer DNS-Cache). Das kann aber auch zu Problemen führen, wenn ein DNS-Server z.B. kurzfristig keine Auflösungen durchführen konnte.

Darum sollte man diesen Funktion lieber ausschalten, da sie selten wirklich nützlich ist.

Nach dem Sie den Rechner neu gestartet haben, steht Ihnen ein größerer DNS-Cache zu Verfügung.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0501.htm


Remote Administration unter Windows 2000

Hier wird die Remote Administration unter Windows 2000 beschrieben. Es werden zwei Arten vorgestellt:

1. Die Terminaldienste

2. Der Telnetserver

Die Terminaldienste

Unter Windows 2000 wurde für die Fernadministration von Servern ein Remoteverwaltungstool entwickelt, der in den Terminal-Server Diensten integriert wurde. Bei Windows 2000 wurden zum Unterschied zu Windows NT die Terminalserverdienste schon integriert und es muss keine extra Version dafür angeschafft werden.

Hier gibt es bei der Installation der Terminaldienste jetzt eine interessante Möglichkeit. Der Terminaldienst kann in zwei Betriebsmodi installiert werden. Sie haben die Möglichkeit zwischen "Remoteverwaltungsmodus" und "Anwendungsmodus".

  1. Der "Remoteverwaltungsmodus" ist ausschließlich für die Fernadministration der Server gedacht. Darum sind hierfür auch keine extra Lizenzen erforderlich. Die Anzahl der möglichen Verbindungen zum Server sind begrenzt
  2. Der "Anwendungsmodus" entspricht dem Ehemaligen Terminal Server weshalb für diesen Modus auch entsprechende Client-Lizenzen erforderlich sind. Hier können dann aber auch 32-Bit Anwendungen über diesen Modus ausgeführt werden.

Installieren der Terminaldienste

Die Terminaldienste werden über den Bereich "Systemsteuerung" -> "Software" eingerichtet. Hier finden Sie unter dem Bereich "Windows-Komponenten" die Terminaldienste. Auf einem Server im Netzwerk muss auch noch die "Terminaldienstelizenzierung" installiert werden.

Bei der Installation der Terminaldienste haben Sie die Möglichkeit zwischen zwei Komponenten:

  1. Terminaldienste aktivieren -> hier wird der Terminalserver installiert und eingerichtet. Nach der Auswahl dieser Option werden Sie noch einmal gefragt, in welchen Modus der Terminalserver betrieben werden soll.
  2. Clienterstellungsdateien -> muss auf mindestens 1 Server installiert werden und bietet dann die Möglichkeit, die Disketten für die Terminalclients zu erstellen

Info Nach der Installation der Terminaldienste muss der Server zur Aktivierung neu gestartet werden.

Wie wirken sich die Terminalserverdienste auf den Server aus?

Ab einem Prozessor mit ca. 200 MHz ist die Last, welche durch den Terminalserver erzeugt wird, fast zu vernachlässigen. Sie liegt bei einer aktiven Sitzung bei ca. 5 Prozent, was auch etwa bei einer lokalen Anmeldung anfallen würde.

Der Speicherverbrauch ist dafür etwas höher. Für eine aktive Sitzung müssen Sie etwa mit 20 MB - 25 MB Speicherverbrauch rechnen. Auch wenn Sie die Sitzung beenden, liegt der Speicherverbrauch im Ruhezustand bei ca. 15 MB. Da der Speicher aber automatisch auf die Festplatte ausgelagert wird, wenn der Terminalserver nicht in Benutzung ist, reduziert sich auch das auf wenige MB.

Die Verbindung zu einem Terminalserver ist auch über Modemleitungen noch recht schnell und lässt sich gut benutzen.

Der Telnetserver

Auch der Telnetserver kann zur Fernadministration benutzt werden und ist aus der UNIX Welt bekannt. Unter Windows NT gab es bis jetzt nur einen Telnet-Client und der Server musste aus dem Resource Kit oder anderen Tools genommen werden.

Windows 2000 liefert nun auch einen Terminal-Server mit, welcher standardmäßig mit installiert wird, aber noch unter den Diensten aktiviert werden muss.

Eine Verbindung zum Telnetserver stellen Sie über "telnet <Servername>" her. Hier können Sie dann alle Serverbefehle über die Befehlszeile ausführen. Da der Telnetserver von Windows 2000 mit der 2000-Authentifizierung arbeitet, besteht hier kein Sicherheitsproblem wie bei anderen Telnetservern, wo das Passwort unterverschlüsselt übermittelt wird.

Info Der Telnetserver belastet den Server weniger als der Terminalserver. Der Telnetserver bietet aber nur eine Befehlszeile, wogegen Sie beim Terminalserver auch die grafischen Administrationstools benutzen können. Da die Serverbelastung beim Terminalserver nicht so groß ist und die meisten Server und Netzwerke nicht an ihren Leistungsgrenzen arbeiten, ist der Einsatz eines Terminalservers meist sinnvoller.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0511.htm


Workstation File-Caching deaktivieren

Mit diesem Tipp können Sie das File-Caching des Workstation Servers unterbinden, wenn Sie Probleme mit der Verbindung zum Server haben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ lanmanworkstation\ parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "UtilizeNtCaching" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | File-Caching ausschalten
1 | File-Caching aktiv

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1636.htm


Prozessor des Netzwerkadapters aktivieren/deaktivieren

Wenn Sie einen Netzwerkadapter (NIC) besitzen, der über einen eigenen Prozessor verfügt, können Sie diesen durch den folgenden Wert aktivieren.

Standardmäßig ist dieser Wert deaktiviert, durch das Aktivieren des Prozessors können Sie die Systemleistung steigern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie einen neuen Wert mit dem Namen "DisableTaskOffload" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | benutzt NIC Prozessor
1 | deaktiviert NIC Prozessor

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1304.htm


DFÜ- und Netzwerkeinstellungen leer

Wenn der Ordner "DFÜ- und Netzwerkeinstellungen" leer ist, obwohl bereits verschiedene Verbindungen eingerichtet wurden und auch entsprechend funktionieren, wurde vermutlich der Dienst Netzwerkverbindungennicht gestartet. Dieser wird auf einigen Systemen durch die Installation von Treibern für ISDN-Karten deaktiviert und startet nicht mehr automatisch.

Zur Abhilfe stellt man den Starttyp des Dienstes über die "Systemsteuerung" -> "Verwaltung" -> "Dienste" -> "Netzwerkverbindungen" auf automatisch und startet das System neu.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1101.htm


Netzwerkkonfiguration leicht wechseln

Hier wird beschrieben, wie Sie einfach zwischen verschiedenen Netzwerkeinstellungen umschalten können.

Wenn Sie z.B. mit Ihrem Notebook in unterschiedlichen Netzwerken arbeiten (feste IP-Konfiguration, DHCP usw), dann müssen Sie jedesmal die Netzwerkkonfiguration entsprechend anpassen (wie IP-Adresse, Gateway usw.). Wenn Sie jetzt noch oft zwischen den Netzwerken wechseln, kann diese Anpassung sehr aufwendig sein

Ab Windows 2000 können Sie aber mit den Befehl "NETSH" die aktuelle Netzwerkkonfiguration sichern und auch wieder herstellen. Sie können sich mit NETSH für jede Netzwerkkonfiguration eine entsprechende Datei mit den Einstellungen erstellen und bei bedarf einfach zwischen den Netzwerkkonfigurationen wechseln.

Netzwerkeinstellungen sichern:

Befehl: netsh -c interface dump >[Dateiname]

Rufen Sie die Kommandozeilenoberfläche auf und sichern Sie die Netzwerkeinstellungen über den folgenden Befehl:

netsh -c interface dump >C:\Einstellung_Test1.txt

Die Einstellungen werden in der Datei "Einstellung_Test1.txt" im Verzeichnis C:\ abgelegt. Hier können Sie natürlich auch ein anderes Verzeichnis und einen Beliebigen Dateinamen angeben.

Ändern Sie jetzt die Einstellungen auf die andere Konfiguration ab und sichern Sie diese Konfiguration in eine weiter Datei (Einstellung_Test2.txt).

Einstellungen wieder herstellen:

Befehl: netsh -f [Dateiname]

Wenn Sie eine gewünschte Netzwerkkonfiguration wieder herstellen wollen, führen Sie den folgenden Befehl aus:

netsh -f C:\Einstellung_Test1.txt

Mit dieser Funktion können Sie nun leicht zwischen verschiedenen Einstellungen hin und her wechseln.

Damit Sie nicht jedes mal die Kommandozeilenoberfläche aufrufen müssen, könne Sie die Befehle in einer Batchdatei (.CMD) speichern und brauchen dann nur die entsprechende Batchdatei aufrufen.

Info Beim ausführen des Befehles "netsh -f [Dateiname]" unter Windows XP wird eine Fehlermeldung ausgegeben, die Sie folgendermaßen beseitigen können: Öffnen Sie die erstellten Sicherungsdateien mit einem Editor und suchen Sie die Zeilen "set dns" und "add dns". Hier entfernen Sie am Ende die Zeilen "register=PRIMARY" und speichern Sie die Datei neu ab.

Beispiel einer Sicherungsdatei (DHCP-Konfiguration):

# ---------------------------------- #

Schnittstellen-IP-Konfiguration

# ----------------------------------

pushd interface ip

# Schnittstellen-IP-Konfiguration für ""LAN-Verbindung""

set address name="LAN-Verbindung" source=dhcp

set dns name="LAN-Verbindung" source=dhcp register=PRIMARY

set wins name="LAN-Verbindung" source=dhcp

popd

# Ende der Schnittstellen-IP-Konfiguration

Das Beispiel enthält nur die IP-Konfiguration, aktuelle Dateien enthalten meist noch weitere Einträge im gleichen Format.Beim ROT-Markierten Teil handelt es sich um den zu löschenden Teil bei WIndows XP.

Info Die Funktion von NETSH wurde von Microsoft geändert, so das man ab Windows Vista nicht mehr damit die Einstellungen sichern und wieder herstellen kann. Mit dem Tool "NetSetMan", kann man diese Einstellungen unter jedem Betriebssystem wechseln <Link>.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1173.htm


DOS-Bootdiskette mit Netzwerkzugriff

Unter Windows NT konnte man sich mit dem Tool "NCADMIN" (ist nur in der NT Server-Version enthalten) recht leicht eine Bootdiskette mit Netzwerkzugriff erstellen lassen. Dieses Tool wurde bei Windows 2000/XP durch das Tool "Microsoft Remote Installation Service" ersetzt - hier kann man sich leider keine solche Bootdisketten mehr erstellen.

Wer aber noch eine Windows NT 4.x Server CD besitzt, kann dieses Tool auch unter Windows 2000 benutzen. Dazu müssen Sie nur mit dem Befehl "expand" folgenden Dateien aus dem "I386"-Verzeichnis entpacken:

expand Z:\i396\NCADMIN.EX_ C:\tools\NCADMIN.EXE

expand Z:\i386\CADMIN.CN_ C:\tools\NCADMIN.CNT

expand Z:\i386\CADMIN.HL_ C:\tools\NCADMIN.HLP

In diesem Beispiel liegt die NT CD im Laufwerk Z und die Dateien werden nach C:\Tools entpackt.

Jetzt kann mit dem Tool wieder eine Bootdiskette erstellt werden, dafür wird die Windows NT Server CD auch noch benötigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1172.htm


Installation des Microsoft Loopbackadapters

Für Testzwecke ist es ab und zu einmal nötig, eine virtuelle Netzwerkkarte zu installieren. Microsoft bietet für diesen Zweck schon seid langer Zeit einen Treiber an (Loopbackadapter), der dafür installiert werden kann.

Bei NT war dieser Treiber unter der Netzwerksteuerung noch leicht einzubinden, ab Windows 2000 müssen Sie jetzt folgendermaßen vorgehen:

  1. Unter "Start" -> "Einstellungen" -> "Systemsteuerung" starten Sie über "Hardware" den Hardware-Assistenten.
  2. Wählen Sie "Gerät hinzufügen bzw. Problem beheben" aus.
  3. Windows sucht jetzt nach neuen Geräten und zeigt Ihnen dann eine Liste der vorhandenen Geräte an, wählen Sie hier den ersten Punkt "Neues Gerät hinzufügen" aus.
  4. In der nächsten Auswahlbox markieren Sie bitte "Nein, die Hardwarekomponenten selber in der Liste auswählen" aus und klicken auf weiter.
  5. In der Liste wählen Sie nun "Netzwerkadapter" aus und klicken auf weiter.
  6. Hier finden Sie jetzt unter "Microsoft" den "Microsoft Loopbackadapter" den Sie durch anklicken jetzt installieren können.

Ab Windows Vista:

  1. Öffnen Sie die "Systemsteuerung" -> "Hardware"
  2. Klicken Sie auf "Weiter"
  3. Wählen Sie "Hardware manuell aus einer Liste wählen und installieren (für fortgeschrittene Benutzer)" -> "Weiter"
  4. Wählen Sie "Netzwerkadapter" -> "Weiter"
  5. Wählen Sie "Microsoft" und dann auf der rechten Seite "Microsoft Loopbackadapter" aus

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0977.htm


DHCP-Adressen unter Windows

Versucht man - ab Windows 2000 - eine IP-Adresse von einem DHCP-Server anzufordern, der kein Microsoft Windows Server ist, kann es zu Problemen kommen. Das merkt man dann, wenn die Clients eine Adresse zwischen 169.254.0.0 - 169.254.255.255 bekommen und nicht die gewünschte Adresse vom DHCP-Server.

Die "Automatic IP Addressing" kurz APIPA Funktion von Windows kann dann die Vergabe einer DHCP-Adresse unterbinden. Diese Funktion ist dafür gedacht, automatisch eine IP-Adresse zu vergeben wenn der Client keinen DHCP-Server findet. Wird aber kein DHCP-Server gefunden, erhält der Client dadurch eine Adresse zwischen 169.254.0.0 - 169.254.255.255 mit einer Submetmask von 255.255.0.0.

Um die automatische Adressenkonfiguration APIPA auszuschalten gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Interfaces\ [Netzwerkkartenname]

für jede einzelne Netzwerkkarte

bzw. unter

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters

für alle installierten Netzwerkkarten

erstellen Sie einen neuen Wert "IPAutoconfigurationEnable" als Datentyp REG_DWORD und weisen Sie den Wert "0" zu.

Standardmäßig ist dieser Wert nicht vorhanden und wird defaultmäßig als Enabeld "1" behandelt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0551.htm


Einstellungen der dynamischen DNS-Registrierung verändern

Windows unterstützt dynamische Domain Name System (DNS)-Aktualisierungen. Die Einstellungen können nur über die Registry verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameter

Schlüssel

Datentyp

Angabe als

Standard

Dieser Schlüssel deaktiviert die Registrierung im Rahmen der dynamischen DNS-Aktualisierung für alle Adapter auf diesem Computer.

Bei der dynamischen Aktualisierung registrieren und aktualisieren DNS-Client-Computer automatisch ihre Ressourceneinträge, wenn Adressänderungen auftreten.

Um die dynamische DNS-Aktualisierung für einen bestimmten Adapter zu deaktivieren, fügen Sie DisableDynamicUpdate zu einem Teilschlüssel <Adaptername> hinzu.

DisableDynamicUpdate

REG_DWORD

Boolean

0

Dieser Schlüssel deaktiviert die im Rahmen der dynamischen DNS-Aktualisierung erfolgende Registrierung von PTR-Einträgen durch diesen.

DNS-Client. PTR ("Zeiger")-Einträge verbinden eine IP-Adresse mit einem Computernamen. Dieser Eintrag wurde für Unternehmen entwickelt, in denen der primäre DNS-Server, der für die Reverse-Lookupzone autorisierend ist, keine dynamischen Aktualisierungen durchführen kann oder nicht dazu konfiguriert ist, diese durchzuführen. Er vermindert unnötigen Netzwerkverkehr und eliminiert Fehler im Ereignisprotokoll, die erfolglose Versuche dokumentieren, PTR-Einträge zu registrieren.

DisableReverseAddressRegistrations

REG_DWORD

Boolean

0

Dieser Schlüssel gibt das Zeitintervall zwischen Neuregistrierungen im Rahmen der dynamischen DNS-Aktualisierung an.

DefaultRegistrationRefreshInterval

REG_DWORD

0x0 - 0xFFFFFFFF Sekunden

0x15180 (24 Stunden)

Dieser Schlüssel gibt den TTL-Standardwert an, der im Header der ausgehenden Registrierungen im Rahmen der dynamischen DNS-Aktualisierung eingestellt ist. Der TTL-Wert bestimmt, wie lange ein Paket, das sein Ziel nicht erreicht hat, auf dem Netzwerk verbleiben kann, bevor es verworfen wird.

DefaultRegistrationTTL

REG_DWORD

0x0 - 0xFFFFFFFF Sekunden

0x4B0 (20 Minuten)

Dieser Schlüssel bestimmt, ob der DNS-Client sichere dynamische Aktualisierung oder standardmäßige dynamische Aktualisierung verwendet.

Windows 2000 unterstützt sowohl dynamische Aktualisierung als auch sichere dynamische Aktualisierung. Bei der sicheren dynamischen Aktualisierung akzeptiert der autorisierende Namenserver nur Aktualisierungen von autorisierten Clients und Servern.

Wert - Bedeutung
0 (0x0) - Sichere dynamische Aktualisierungen nur senden, wenn nicht-sichere dynamische Aktualisierungen abgelehnt werden.
16 (0x10) - Nur nicht-sichere dynamische Aktualisierungen senden.
256 (0x100) - Nur sichere dynamische Aktualisierungen senden.

UpdateSecurityLevel

REG_DWORD

0x0 | 0x10 | 0x100

0x0

Dieser Schlüssel verhindert, dass der DNS-Client einen vorhandenen Ressourcen-Eintrag überschreibt, wenn er während der dynamischen Aktualisierung einen Adressenkonflikt entdeckt. Ein Adressenkonflikt tritt auf, wenn der DNS-Client entdeckt, dass ein vorhandener A-Eintrag seinen DNS-Namen mit der IP-Adresse eines anderen Computers verbindet.

Wert - Bedeutung
0 - Der DNS-Client überschreibt den vorhandenen A-Eintrag mit einem A-Eintrag für seine eigene IP-Adresse.
1 - Der DNS-Client zieht sich aus dem Registrierungsvorgang zurück. Es wird kein Fehler in der Ereignisanzeigeprotokolliert.

DisableReplaceAddressesInConflicts

REG_DWORD

Boolean

0

(Nur DNS-Server)

Dieser Schlüssel gibt die IP-Adressen an, die Sie für den Computer veröffentlichen wollen. Der DNS-Server erstellt A-Einträge nur für die Adresse in dieser Liste. Wenn dieser Eintrag nicht in der Registrierung erscheint oder der entsprechende Wert leer ist, erstellt der DNS-Server einen A-Eintrag für jede IP-Adresse des Computers.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters\

DisableReplaceAddressesInConflicts

REG_DWORD

Boolean

0

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Adapters

Schlüssel | Datentyp | Angabe als | Standard
Dieser Schlüssel deaktiviert die Registrierung im Rahmen der dynamischen Aktualisierung auf diesem Adapter. Bei der dynamischen Aktualisierung registrieren und aktualisieren DNS-Client-Computer automatisch ihre Ressourceneinträge, wenn Adressänderungen auftreten.
DisableDynamicUpdate | REG_DWORD | Boolean | 0
Dieser Schlüssel bestimmt die max. Anzahl von IP-Adressen, die in DNS für diesen Adapter registriert werden können. Wenn der Wert für diesen Eintrag 0 ist, können für diesen Adapter keine IP-Adressen registriert werden.
MaxNumberOfAddressesToRegister | REG_DWORD | 0x0 - 0xFFFFFFFF | 0x1

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Netlogon\ Parameters

Schlüssel | Datentyp | Angabe als | Standard
Dieser Schlüssel bestimmt, ob der Anmeldedienst auf diesem Domänencontroller dynamische DNS-Aktualisierungen verwendet. Netlogon kann dynamische DNS-Aktualisierungen verwenden, um DNS-Namen zu registrieren, die den Domänencontroller identifizieren. Dynamische DNS-Aktualisierungen liefern automatische Aktualisierungen von Zonendaten, wie beispielsweise DNS-Namen, auf dem primären Server der Zone, wenn ein autorisierter Server in der Zone eine Aktualisierung anfordert. Hierdurch wird die statische, manuelle Methode des Hinzufügens und Änderns von Zoneneinträgen ergänzt.
UseDynamicDns | REG_DWORD | Boolean | 1
Dieser Eintrag bestimmt, ob dieser Domänencontroller DNS-A (IP-Adresse)-Einträge für die Domäne registriert. Wenn dieser Domänencontroller eine GC-Ressource ist, bestimmt dieser Eintrag ebenfalls, ob der Domänencontroller DNS-A-Einträge für den globalen Katalog registriert.
RegisterDnsARecords | REG_DWORD | Boolean | 1

Info Damit die an diesem Wert vorgenommenen Änderungen wirksam werden, müssen Sie Windows neu starten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/default.aspx?scid=kb%3Bde%3BD42419

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0993.htm


Telnet Server unter Windows 2000

Telnet Server unter Windows

Unter Windows 2000 ist der Telnet Server als Dienst mitgeliefert. Der Telnet Server wird bei der Installation mit installiert, aber der Dienst wird nicht automatisch gestartet. Wenn Sie also mit dem Telnet Server arbeiten wollen, müssen Sie den Dienst erst einmal starten.

Dazu stehen Ihnen folgende Möglichkeiten zu Verfügung:

  1. Über "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Telnetserververwaltung"
    Hier werden Ihnen jetzt einige mögliche Funktionen angeboten
  2. Über "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Dienste"
    Hier können Sie den Dienst "Telnet" von Hand starten und die Startart verändern, damit er z.B. immer automatisch gestartet wird.
  3. Über die Kommandozeile:
    net start tlntsvr

Info Passworte werden auch im Telnet Server bei NT nur verschlüsselt übermittelt! Aus diesen Grund müssen auch die Clients die Verschlüsselung beherrschen.

Siehe auch "Remote Administration unter Windows 2000".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0539.htm


Netzwerk Fehlerstatistik anzeigen

Mit diesem Tipp können Sie einschalten, dass eine Fehlerstatistik von Netzwerkverbindungen erstellt wird. Diese Statistik kann bei der Fehlersuche hilfreich sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Network\ Connections\ StatMon

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowLanErrors" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Fehlerstatistik aktivieren
0 | Fehlerstatistik deaktiv (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1608.htm


Netzwerkanzeige mit Anzahl der fehlerhaften Pakete

Wenn Sie eine Netzwerkverbindung offen haben, können Sie sich durch einen Klick auf das Netzwerk-Icon (rechts unten in der Taskleiste bzw. über Start -> Systemsteuerung -> Netzwerkverbindung) entsprechende Informationen über die Verbindung anzeigen lassen. Hier werden standardmäßig aber nicht die Anzahl der fehlerhaften Pakete angezeigt, welche Sie mit diesem Eintrag aktivieren können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Network\ Connections\ StatMon

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowLanErrors" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Fehler anzeigen
0 | Fehler nicht anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1667.htm


Suchgröße im Active Directory konfigurieren

Die maximale Anzahl der Ergebnisobjekte wird Mit diesem Tipp bestimmt, die nach den Befehlen "Durchsuchen" und "Suchen" im Active Directory angezeigt werden. Diese Einstellung gilt für alle Ergebnisse für "Durchsuchen" im Active Directory, wie z. B. Lokale Benutzer und Gruppen, Active Directory-Benutzer und -Computer und für die Dialogfelder, die zum Festlegen von Berechtigungen für Benutzer- oder Gruppenobjekte im Active Directory verwendet werden.

Wenn Sie dieser Einstellung deaktivieren oder nicht konfigurieren, werden bis zu 10.000 Objekte angezeigt, wofür ca. 2 MB Speicherplatz erforderlich sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Directory UI

Erstellen Sie hier einen neuen Wert mit dem Namen "QueryLimit" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0-4000000000 | Maximale Anzahl der Suchergebnisse
gelöscht | 10.000 als (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Directory
Einstellungsname: | Maximale Suchgröße von Active Directory

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1942.htm


Aktualisierungsintervall der Uhrzeit (NTP)

Mit diesem Tipp legen Sie das Intervall fest, wie oft die Uhrzeit aktualisiert werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ W32Time\ TimeProviders\ NtpClient

ändern Sie hier den Wert "SpecialPollInterval" als Datentyp REG_DWORD. Geben Sie die Zeit in Sekunden an, wie oft die Uhrzeit abgeglichen werden soll. Der Standardwert liegt bei 3600.

Info Siehe dazu auch Tipp: "Windows Zeit-/Datumsabgleich konfigurieren (Deutsche Server)"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2049.htm


Netzwerkkarte wird bei fehlender Verbindung nicht aktiviert

Durch die Funktion "Media Sense" wird von Windows erkannt, ob eine physikalische Verbindung zum Netzwerk besteht. Wird keine Verbindung festgestellt, werden alle Protokolle vom Adapter getrennt und der Netzwerkadapter wird erst aktviert, wenn eine Verbindung erkannt wird.

Mit diesem Tipp können Sie die "Media Sense"-Funktion ausschalten. Dadurch bleibt dann z.B. eine Netzwerkadresse erhalten, auch wenn das Netzwerkkabel entfernt wurde.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDHCPMediaSense" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Media Sense" ausschalten
0 | "Media Sense" ist aktiv (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2190.htm


Active Directory nach fehlenden COM-Komponenten durchsuchen

Wenn Sie diesen Tipp aktivieren, wird das Active Directory nach fehlenden COM-Komponenten durchsucht, die für die Ausführung der Anwendungen benötigt werden.

Bei den COM-Komponenten (Component Object Model) handelt es sich um Module, die Schnittstellen bereitstellen, welche von anderen Programm verwendet werden. Wenn diese Komponenten nicht vorhanden und auf dem Rechner registriert sind, können die Programme, welche die Komponenten verwenden, nicht ausgeführt werden.

Wird die Komponente im Active Directory gefunden, wird sie auf den Rechner übertragen und registriert. Durch den Suchvorgang und die Übertragung dauert der Startvorgang der Anwendung länger. Der Suchvorgang wird aber nur ausgeführt, wenn die COM-Komponente nicht auf dem Rechner vorhanden ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ App Management

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ App Management

Erstellen Sie hier einen neuen Wert mit dem Namen "COMClassStore" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Es wird nicht nach COM-Komponenten gesucht (Standard)
1 | Es wird nach COM-Komponenten im Active Directory gesucht

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Fehlende COM-Komponenten übertragen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2457.htm


Netzwerk: IPSec-Ereignisse loggen

Mit diesem Tipp können Sie das Logging für IPSec (Internet Protocol Security) aktivieren. Wird der Tipp aktiviert, wird mit Hilfe des IKE (Internet Key Exchange) - Protocol, dass Oakley-Logging aktiviert.

Bei aktivem Loging wird im Verzeichnis "%SystemRoot%\debug" eine Datei OAKLEY.LOG erstellt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ PolicyAgent\ Oakley

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableLogging" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Oakley-Logging nicht aktiv
1 | Oakley-Logging aktiv

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen dazu unter: http://support.microsoft.com/support/kb/articles/Q257/2/25.ASP

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2465.htm


Domänencontroller/Clients getrennt durch Firewalls

Durch Firewalls getrennte Domänencontroller/Clients

In bestimmten Konstellationen werden Domänencontroller untereinander durch Firewalls getrennt oder es befindet sich zwischen den Clients und den Domänencontrollern eine Firewall. Hier werden einige wichtige Informationen dazu beleuchtet.

Soll eine Kommunikation durch eine Firewall erfolgen, gibt es folgende Ansätze:

  • Die Verbindung wird zwischen den Systemen - z.B. über IPsec - getunnelt. In diesem Fall müssen nur die Ports für IPsec in der Firewall geöffnet werden
  • Es wird direkt über TCP/IP kommuniziert, was in den folgenden Fällen durchaus nicht ungewöhnlich ist:
    • Domänencontroller benutzen die Funktion der Internetverbindungsfirewall, was in kleinen Netzwerken durchaus vorkommt.
    • Mitgliedsserver wie z.B. der Microsoft Exchange Server befinden sich in der DMZ, während die Domänencontroller in internen Netzwerk stehen.
    • Die internen Netzwerke sich durch Firewalls segmentiert.
    • Router mit aktivierter Port-Filterung werden eingesetzt.

In solchen Fällen müssen die benötigten Ports entsprechend freigeschaltet werden.

In der folgenden Tabelle finden Sie eine entsprechende Übersicht, welche Ports für die entsprechenden Aufgaben benötigt werden. Bei der Verwendung von IPsec müssen nur die IPsec-spezifischen Ports und die für DNS und Kerberos verwendeten Ports freigeschaltet werden.

Bereich | Funktion | TCP-Port | UDP-Port
Benutzeranmeldung | Zugriff auf das Active Directory | 445 | 445
 | Kerberos-Authentifizierung | 88 | 88
 | LDAP-pings | - | 389
 | DNS-Zugriffe | 53 | 53
Computeranmeldung | Zugriff auf das Active Directory | 445 | 445
 | Kerberos-Authentifizierung | 88 | 88
 | LDAP-pings | - | 389
 | DNS-Zugriffe | 53 | 53
Vertrauensstellungen zwischen Domänen | Zugriff auf das Active Directory | 445 | 445
 | LDAP-Zugriffe | 389 und 686 mit SSL | -
 | LDAP-pings | - | 389
 | Kerberos-Authentifizierung | 88 | 88
 | DNS-Zugriffe | 53 | 53
Authentifizierung von Vertauensstellungen | Zugriff auf das Active Directory | 445 | 445
 | LDAP-Zugriffe | 389 und 686 mit SSL | -
 | LDAP-pings | - | 389
 | DNS | 88 | 88
 | Netzwerkanmeldung | 135 | -
Dateiressourcen (Netlogon usw.) | Nutzung von SMB über TCP/IP | 445 | 445
DNS-Lookups |  | 53 | 53
Active Directory Replikation | Directory-Service RPCs | Konfigurierbar | -
 | LDAP-Zugriffe | 389 und 686 mit SSL | -
 | LDAP-pings | - | 389
 | Kerberos-Authentifizierung | 88 | 88
 | DNS-Zugriffe | 53 | 53
 | Nutzung von SMB über TCP/IP | 445 | 445
IPsec | IPsec Encapsutated payload (ESP) über IP-Protokoll 50 | - | -
 | IKE | - | 500
 | Kerberos-Authentifizierung | 88 | 88
 | DNS-Zugriffe | 53 | 53
 | Bei Verwendung von IPsec AH (authentifizierte Header) noch IP-Protokoll 51 | - | -

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2661.htm


Konfiguration der Replikation von Passwortänderungen

In diesem Tipp wird beschrieben, wie Sie die sofortige Replikation von Passwortänderungen deaktivieren können.

Eine Änderung des Kennwortes wird normalerweise unmittelbar an PDCs (Primäre Domänencontroller) bzw. dem Betriebsmaster mit der Rolle des PDC-Emulators an andere Standorte weitergereicht. Gerade bei WAN-Verbindungen führt das zu einer unnötigen Auslastung.

Mit dem Eintrag "AvoidPdcOnWan" können Sie einstellen, dass Passwortänderungen nicht unmittelbar - sondern erst bei der nächsten regulären Replikation - weiter geleitet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Netlogon\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "AvoidPdcOnWan" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Änderungen werden nicht sofort repliziert
0 | Änderungen werden sofort repliziert (Standard)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=232690

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2660.htm


Aktualisierung von Replikationstopologien

Der KKC (Knowledge Consistency Checker) von Windows aktualisiert in regelmäßigen Abständen die Replikationstopologien. Diese Aktualisierung verursacht einiges an Overhead, ist aber nötig, um auf alle Funktionen bei einer Nichtverfügbarkeit von Domänencontrollern reagieren zu können.

Die Berechnungsintervalle lassen sich über die Registry konfigurieren. Gerade bei Domänencontrollern ist das geeignet, die auch als Bridgehead-Server arbeiten, wo die Berechnung der Replikationstopologie für die Inter-Site-Replikation besonders aufwändig ist.

Die Anpassungen müssen auf allen Domänencontrollern durchgeführt werden, wenn nicht mit designierten Bridgehead-Servern gearbeitet wird, weil sich ansonsten nicht vorhersagen lässt, welcher Rechner diese Aufgabe übernehmen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ NTDS\ Parameters

Mit dem Eintrag "Repl topology update period" als Datentyp REG_DWORD bestimmen Sie das Intervall in Sekunden für die Neuberechnung von Topologien.

Der Standardwert liegt bei 900 Sekunden und sollte auch nicht auf einen kleineren Wert gesetzt werden, da der Rechenaufwand erheblich ist. In einem stabilen Netzwerk kann es aber sehr sinnvoll sein, den Wert bis auf 3600 Sekunden zu erhöhen.

Mit dem Eintrag "Repl topology update delay" als Datentyp REG_DWORD bestimmen Sie die zeitliche Verteilung von Aktualisierungen in Sekunden.

Der Standardwert liegt bei 300 Sekunden. In den meisten Fällen muss dieser Wert aber nicht verändert werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=271988

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2659.htm


'Benachbarte Computer' nicht mehr in der Netzwerkumgebung anzeigen

"Benachbarte Computer" nicht mehr in der Netzwerkumgebung anzeigen

Wenn Sie diese Policy aktivieren, entfernen Sei aus den Listen der Netzwerkressourcen in Windows Explorer und Netzwerkumgebung die Computer aus der Arbeitsgruppe und Domäne des Benutzers.

Durch Aktivieren dieser Einstellung wird die Option "Benachbarte Computer" und die Symbole, die die benachbarten Computer darstellen, aus Netzwerkumgebung entfernt. Zusätzlich werden diese Symbole auch aus der Option "Durchsuchen" in "Netzlaufwerk verbinden" entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoComputersNearMe" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Entfernt die Einträge
gelöscht | Einträge werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | "Benachbarte Computer" nicht mehr in der Netzwerkumgebung anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1904.htm


Filterleiste im Suchendialog einblenden

Die Filterleiste wird oberhalb der Suchergebnisse von Active Directory angezeigt. Sie besteht aus Schaltflächen für das zusätzliche Filtern der Suchergebnisse.

Durch Aktivieren dieser Einstellung wird die Filterleiste angezeigt, wenn das Dialogfeld "Suchen" für Active Directory geöffnet wird. Benutzer können die Leiste jedoch auch ausblenden.

Wenn Sie diese Einstellung nicht konfigurieren, wird die Filterleiste nicht angezeigt, aber Benutzer können die Leiste mit dem Menüeintrag "Filter" aus dem Menü "Ansicht" anzeigen.

Zum Anzeigen der Filterleiste, müssen Sie "Netzwerkumgebung" öffnen, auf "Gesamtes Netzwerk" und dann auf "Verzeichnis" klicken. Klicken Sie dann mit der rechten Maustaste auf eine Windows-Domäne und dann auf "Suchen". Geben Sie den Namen eines Objekts im Verzeichnis ein, wie z. B. >>Administrator<<. Falls die Filterleiste im Ergebnisfenster nicht angezeigt wird, klicken Sie auf "Filter" im Menü "Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Directory UI

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableFilter" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Filterleiste anzeigen
gelöscht | Filterleiste nicht anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Directory
Einstellungsname: | Filter im Dialogfeld "Suchen" aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1943.htm


Ordner 'Active Directory' ausblenden

Blendet den Ordner "Active Directory" im Ordner "Netzwerkumgebung" aus.

Im Ordner "Active Directory" werden Active Directory-Objekte in einem Suchfenster angezeigt. Durch Aktivieren dieser Einstellung wird der Ordner "Active Directory" im Ordner "Netzwerkumgebung" nicht angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Directory UI

Erstellen Sie hier einen neuen Wert mit dem Namen "HideDirectoryFolder" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Ordner ausblenden
gelöscht | Ordner sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop\Active Directory
Einstellungsname: | Ordner "Active Directory" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1944.htm


Umbenennen von LAN/RAS-Verbindungen zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Benutzer LAN/RAS-Verbindungen umbenennen können.

Wenn Sie diese Einstellung aktivieren, steht die Option "Umbenennen" allen Benutzern zur Verfügung.

Benutzer können Verbindungen über das Menü "Datei", oder indem Sie auf das Symbol für eine Verbindung klicken, umbenennen.

Wenn Sie diese Einstellung deaktivieren, steht die Option "Umbenennen" für LAN/RAS-Verbindungen keinem Benutzer (einschließlich Administratoren und Netzwerkkonfigurations-Operatoren) zur Verfügung.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn dieser Tipp konfiguriert ist, hat sie immer Vorrang vor den Einstellungen im Tipp "Umbenennen von LAN-Verbindungen zulassen" und "Umbenennen von RAS-Verbindungen zulassen".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RenameConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Benutzer können LAN/RAS-Verbindungen umbenennen
0 | Benutzer können LAN/RAS-Verbindungen nicht umbenennen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Umbenennen von LAN- oder RAS-Verbindungen für alle Benutzer zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1972.htm


Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)

Mit diesem Tipp können Sie einstellen, das die Einstellungen auch ab Windows XP für Administratoren gelten.

Der Satz von Gruppeneinstellungen für "Netzwerkverbindungen", der in Windows 2000 vorhanden war, ist auch in Windows XP Professional vorhanden. In Windows 2000 Professional weisen all diese Einstellungen die Möglichkeit auf, die Verwendung bestimmter Funktionen für Administratoren nicht zuzulassen.

Standardmäßig weisen die Gruppeneinstellungen für "Netzwerkverbindungen" in Windows XP Professional nicht die Möglichkeit auf, die Verwendung von Funktionen für Administratoren zu unterbinden.

Wenn Sie diese Einstellung aktivieren, weisen die Windows XP-Einstellungen, die in Windows 2000 Professional vorhanden waren, die Möglichkeit auf, die Verwendung bestimmter Funktionen für Administratoren nicht zuzulassen. Wenn diese Einstellung aktiviert ist, weisen die Einstellungen sowohl in Windows 2000 Professional als auch in Windows XP Professional die gleiche Verhaltensweise für Administratoren auf.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, gelten Windows XP-Einstellungen, die in Windows 2000 vorhanden waren, nicht für Administratoren.

Info Diese Einstellung ist für solche Situationen gedacht, in denen das Gruppenrichtlinienobjekt, für das diese Einstellungen gelten, sowohl Computer mit Windows 2000 Professional als auch Computer mit Windows XP umfasst und ein einheitliches Verhalten in Bezug auf die Richtlinie für Netzwerkverbindungen für alle Computer mit Windows 2000 Professional und Windows XP Professional erforderlich ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_EnableAdminProhibits" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Gleiches verhalten unter Windows 2000 und XP
0 | Ab Windows XP gelten die Einstellungen nicht für Administratoren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Windows 2000-Netzwerkverbindungseinstellungen für Administratoren aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1973.htm


Zugriff auf die Komponenteneigenschaften einer LAN-Verbindung nicht zulassen

Zugriff nicht zulassen auf die Komponenteneigenschaften einer LAN-Verbindung

Mit diesem Tipp können Sie einstellen, ob Administratoren und Netzwerkkonfigurations-Operatoren die Eigenschaften von Komponenten ändern können, die von einer LAN-Verbindung verwendet werden.

Das Dialogfeld "Eigenschaften von LAN-Verbindung" enthält eine Liste der Netzwerkkomponenten, die von der Verbindung verwendet werden. Um die Eigenschaften einer Komponente anzuzeigen oder zu ändern, klicken Sie auf den Namen der Komponente und dann auf die Schaltfläche "Eigenschaften" unter der Komponentenliste.

Wenn Sie diese Einstellung aktivieren, steht die Schaltfläche "Eigenschaften" den Administratoren nicht zur Verfügung. Netzwerkkonfigurations-Operatoren wird der Zugriff auf Verbindungskomponenten verweigert und zwar unabhängig von der Einstellung "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)".

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, steht die Schaltfläche "Eigenschaften" den Administratoren und Netzwerkkonfigurations-Operatoren zur Verfügung.

Info Wenn der Tipp "Zugriff auf Eigenschaften einer LAN-Verbindung nicht zulassen" aktiviert ist, können die Benutzer nicht auf die Schaltfläche "Eigenschaften" für LAN-Verbindungskomponenten zugreifen.

Info Netzwerkkonfigurationsoperatoren verfügen nur über die Berechtigung zum Ändern von TCP/IP-Eigenschaften. Eigenschaften für alle anderen Komponenten stehen nicht zur Verfügung

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_LanChangeProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eigenschaften der LAN-Verbindung sichern
0 | Eigenschaften der LAN-Verbindung sind offen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren.Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff auf Komponenteneigenschaften einer LAN-Verbindung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1974.htm


Zugriff auf die Komponenteneigenschaften einer RAS-Verbindung nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Administratoren und Netzwerkkonfigurations-Operatoren die Eigenschaften von Komponenten ändern können, die von einer RAS-Verbindung verwendet werden.

Die Registerkarte "Netzwerk" des Dialogfelds "Eigenschaften von RAS-Verbindung" enthält eine Liste der Netzwerkkomponenten, die von der Verbindung verwendet werden. Um die Eigenschaften einer Komponente anzuzeigen oder zu ändern, klicken Sie auf den Namen der Komponente und dann auf die Schaltfläche "Eigenschaften" unter der Komponentenliste.

Wenn Sie diese Einstellung aktivieren, ist die Schaltfläche "Eigenschaften" für alle Benutzer (einschließlich Administratoren) deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, ist die Schaltfläche "Eigenschaften" für alle Benutzer aktiviert.

Info Wenn der Tipp "Ändern von Eigenschaften einer für alle Benutzer gültigen RAS-Verbindung zulassen" oder "Ändern der Eigenschaften einer für einen Benutzer gültigen RAS-Verbindung nicht zulassen" so festgelegt ist, dass der Zugriff auf das Dialogfeld "Eigenschaften von RAS-Verbindung" verweigert wird, ist die Schaltfläche "Eigenschaften" für Komponenten einer RAS-Verbindung gesperrt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RasChangeProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eigenschaften der RAS-Verbindung sichern
0 | Eigenschaften der RAS-Verbindung sind offen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff auf Komponenteneigenschaften einer RAS-Verbindung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1975.htm


Erweitere TCP/IP-Konfiguration nicht zulassen

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob Benutzer erweiterte TCP/IP-Einstellungen konfigurieren können.

Wenn Sie diese Einstellung aktivieren, ist die Schaltfläche "Erweitert" im Dialogfeld "Internetprotokolleigenschaften (TCP/IP)" für alle Benutzer (einschließlich Administratoren) deaktiviert. Dadurch können Benutzer die Registerkarte "Erweiterte TCP/IP-Einstellungen" nicht öffnen und IP-Einstellungen ändern, wie beispielsweise DNS- und WINS-Serverinformationen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren, steht die Schaltfläche "Erweitert" zur Verfügung, und alle Benutzer können das Dialogfeld "Erweiterte TCP/IP-Einstellungen" öffnen.

Info Unabhängig von dieser Einstellung verfügt kein Benutzer ohne Administratorrechte (mit Ausnahme von Netzwerkkonfigurations-Operatoren) über die Berechtigung für den Zugriff auf die erweiterte TCP/IP-Konfiguration für eine LAN-Verbindung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_AllowAdvancedTCPIPConfig" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Die Erweiterten TCP/IP Einstellungen können nicht geöffnet werden
0 | Die Erweiterten TCP/IP Einstellungen können geöffnet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Erweitere TCP/IP-Konfiguration nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1976.htm


Zugriff zu 'Erweiterte Einstellungen' im Menü 'Erweitert' nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob die Option "Erweiterte Einstellungen" im Menü "Erweitert" unter "Netzwerkverbindungen" für Administratoren aktiviert ist.

Mit der Option "Erweiterte Einstellungen" können Benutzer Bindungen sowie die Reihenfolge anzeigen und ändern, in der Computer auf Verbindungen, Netzwerk- und Druckanbieter zugreift.

Wenn Sie diese Einstellung aktivieren, ist die Option "Erweiterte Einstellungen" für Administratoren deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, ist die Option "Erweiterte Einstellungen" für Administratoren aktiviert.

Info Unabhängig von dieser Einstellung wird Benutzern ohne Administratorrechte der Zugriff auf das Dialogfeld "Erweiterte Einstellungen" verweigert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_AdvancedSettings" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Erweiterte Einstellungen" sperren
0 | "Erweiterte Einstellungen" zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff zu 'Erweiterte Einstellungen' im Menü 'Erweitert' nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1977.htm


Entfernen/Hinzufügen von Komponenten für RAS/LAN-Verbindungen sperren

Mit diesem Tipp können Sie einstellen, ob Administratoren Netzwerkkomponenten für eine LAN- oder RAS-Verbindung hinzufügen und entfernen können. Diese Einstellung wirkt sich nicht auf Benutzer ohne Administratorrechte aus.

Wenn Sie diese Einstellung aktivieren, sind die Schaltflächen "Installieren" und "Deinstallieren" für Komponenten von Verbindungen deaktiviert, und Administratoren können nicht auf Netzwerkkomponenten im Assistenten für Windows-Komponenten zugreifen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, sind die Schaltflächen "Installieren" und "Deinstallieren" für Komponenten von Verbindungen im Ordner "Netzwerkverbindungen" aktiviert. Außerdem können Administratoren im Assistenten für Windows-Komponenten auf Netzwerkkomponenten zugreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_AddRemoveComponents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | RAS/LAN-Verbindungen können nicht Entfernt/Hinzugefügt werden
0 | RAS/LAN-Verbindungen können Entfernt/Hinzugefügt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Entfernen/Hinzufügen von Komponenten für RAS- / LAN-Verbindungen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1978.htm


Zugriff auf die Eigenschaften einer LAN-Verbindung nicht zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer die Eigenschaften einer LAN-Verbindung ändern können.

Mit dieser Einstellung wird festgelegt, ob der Menüeintrag "Eigenschaften" aktiviert ist, und dadurch bestimmt, ob den Benutzern das Dialogfeld "Eigenschaften von LAN-Verbindung" zur Verfügung steht.

Wenn Sie diese Einstellung aktivieren, sind die Menüeinträge "Eigenschaften" für alle Benutzer deaktiviert, und die Benutzer können das Dialogfeld "Eigenschaften von LAN-Verbindung" nicht öffnen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird ein Menüeintrag "Eigenschaften" angezeigt, wenn die Benutzer mit der rechten Maustaste auf das Symbol für eine LAN-Verbindung klicken. Außerdem wird der Eintrag "Eigenschaften" im Menü "Datei" aktiviert, wenn Benutzer die Verbindung auswählen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_LanProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eigenschaften der LAN-Verbindung sichern
0 | Eigenschaften der LAN-Verbindung können geöffnet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff auf Eigenschaften einer LAN-Verbindung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1979.htm


Aktivieren/Deaktivieren der Komponenten einer LAN-Verbindung

Mit diesem Tipp können Sie einstellen, ob Administratoren die Komponenten aktivieren und deaktivieren können, die von LAN-Verbindungen verwendet werden.

Wenn Sie diese Einstellung aktivieren, sind die Kontrollkästchen für das Aktivieren und Deaktivieren von Komponenten deaktiviert. Dadurch können Administratoren die von einer Verbindung verwendeten Komponenten nicht aktivieren oder deaktivieren.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, enthält das Dialogfeld "Eigenschaften" für eine Verbindung ein Kontrollkästchen neben dem Namen jeder von der Verbindung verwendeten Komponente. Durch Aktivierung des Kontrollkästchens wird die Komponente aktiviert, und durch Deaktivierung des Kontrollkästchens wird die Komponente deaktiviert.

Info Wenn der Tipp "Zugriff auf Eigenschaften einer LAN-Verbindung nicht zulassen" aktiviert ist, können die Benutzer nicht auf die Kontrollkästchen zum Aktivieren und Deaktivieren der Komponenten einer LAN-Verbindung zugreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_ChangeBindState" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Aktivieren/Deaktivieren von Komponenten sperren
0 | Aktivieren/Deaktivieren von Komponenten zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Aktivieren/Deaktivieren der Komponenten einer LAN-Verbindung

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1980.htm


Ändern der RAS-Eigenschaften zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob ein Benutzer die Eigenschaften von RAS-Verbindungen anzeigen und ändern kann, die allen Benutzern des Computers zur Verfügung stehen. Um eine für alle Benutzer gültige RAS-Verbindung zu erstellen, klicken Sie im Assistenten für neue Verbindungen auf der Registerkarte "Verfügbarkeit der Verbindung" auf die Option "Für alle Benutzer".

Mit dieser Einstellung wird festgelegt, ob der Menüeintrag "Eigenschaften" aktiviert ist, und dadurch bestimmt, ob den Benutzern das Dialogfeld "Eigenschaften von RAS-Verbindung" zur Verfügung steht.

Wenn Sie diese Einstellung aktivieren, wird ein Menüeintrag "Eigenschaften" angezeigt,wenn ein Benutzer mit der rechten Maustaste auf das Symbol für eine RAS-Verbindung klickt. Außerdem wird der Eintrag "Eigenschaften" im Menü "Datei" angezeigt, wenn ein Benutzer die Verbindung auswählt.

Wenn Sie diese Einstellung deaktivieren, sind die Menüeinträge "Eigenschaften" deaktiviert, und die Benutzer (einschließlich Administratoren) können das Dialogfeld für Eigenschaften der RAS-Verbindung nicht öffnen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung nicht konfigurieren, können nur Administratoren und Netzwerkkonfigurations-Operatoren die Eigenschaften von für alle Benutzer gültigen RAS-Verbindungen ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RasAllUserProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Benutzer können RAS-Eigenschaften ändern
0 | Benutzer können RAS-Eigenschaften nicht ändern (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Ändern von Eigenschaften einer für alle Benutzer gültigen RAS-Verbindung zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1981.htm


Ändern der RAS-Eigenschaften nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Benutzer die Eigenschaften ihrer privaten RAS-Verbindungen anzeigen und ändern können.

Bei privaten Verbindungen handelt es sich um solche Verbindungen, die nur einem Benutzer zur Verfügung stehen. Um eine private Verbindung zu erstellen, klicken Sie im Assistenten für neue Verbindungen auf der Registerkarte "Verfügbarkeit der Verbindung" auf die Option "Nur selbst verwenden".

Mit dieser Einstellung wird festgelegt, ob der Menüeintrag "Eigenschaften" aktiviert ist, und dadurch bestimmt, ob den Benutzern das Dialogfeld "Eigenschaften von RAS-Verbindung" für eine private Verbindung zur Verfügung steht.

Wenn Sie diese Einstellung aktivieren, sind die Menüeinträge "Eigenschaften" deaktiviert und kein Benutzer (einschließlich Administratoren) kann das Dialogfeld "Eigenschaften von RAS-Verbindung" für eine private Verbindung öffnen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird ein Menüeintrag "Eigenschaften" angezeigt, wenn ein Benutzer mit der rechten Maustaste auf das Symbol für eine private RAS-Verbindung klickt. Außerdem wird der Eintrag "Eigenschaften" im Menü "Datei" angezeigt, wenn ein Benutzer die Verbindung auswählt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RasMyProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Ändern von RAS Eigenschaften nicht zulassen
0 | RAS Eigenschaften können geändert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Ändern der Eigenschaften einer für einen Benutzer gültigen RAS-Verbindung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1982.htm


Löschen von RAS-Verbindungen nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Benutzer RAS-Verbindungen löschen können.

Wenn Sie diese Einstellung aktivieren, können Benutzer (einschließlich Administratoren) keine RAS-Verbindungen löschen. Mit dieser Einstellung wird außerdem die Option "Löschen" im Kontextmenü für eine RAS-Verbindung und im Menü "Datei" im Ordner "Netzwerkverbindungen" deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, können alle Benutzer ihre privaten RAS-Verbindungen löschen. Bei privaten Verbindungen handelt es sich um solche Verbindungen, die nur einem Benutzer zur Verfügung stehen. (Standardmäßig können nur Administratoren und Netzwerkkonfigurations-Operatoren Verbindungen löschen, die allen Benutzern zur Verfügung stehen, doch kann diese Standardeinstellung mit "Möglichkeit, alle Benutzer-RAS-Verbindungen zu löschen" geändert werden.)

Wenn dieser Tipp aktiviert ist, hat der Vorrang vor der Einstellung "Möglichkeit, alle Benutzer-RAS-Verbindungen zu löschen". Die Benutzer können keine RAS-Verbindungen löschen, und die Einstellung "Möglichkeit, alle Benutzer-RAS-Verbindungen zu löschen" wird ignoriert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_DeleteConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Löschen von RAS-Verbindungen nicht zulassen
0 | Löschen von RAS-Verbindungen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Löschen von RAS-Verbindungen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1983.htm


Löschen von RAS-Verbindungen zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer für alle Benutzer gültige RAS-Verbindungen löschen können.

Um eine für alle Benutzer gültige RAS-Verbindung zu erstellen, klicken Sie im Assistenten für neue Verbindungen auf der Registerkarte "Verfügbarkeit der Verbindung" auf die Option "Für alle Benutzer".

Wenn Sie diese Einstellung aktivieren, können alle Benutzer gemeinsam genutzte RAS-Verbindungen löschen. Wenn es sich bei Ihrem Dateisystem um NTFS handelt, müssen die Benutzer außerdem über den Schreibzugriff auf "Dokumente und Einstellungen\Alle Benutzer\Anwendungsdaten\Microsoft\Netzwerk\Verbindungen\Pbk" verfügen, um eine gemeinsam genutzte RAS-Verbindung zu löschen.

Wenn Sie diese Einstellung deaktivieren, können die Benutzer (einschließlich Administratoren) keine für alle Benutzer gültigen RAS-Verbindungen löschen. (Standardmäßig können die Benutzer weiterhin ihre privaten Verbindungen löschen, doch kann diese Standardeinstellung mit "Löschen von RAS-Verbindungen nicht zulassen" geändert werden.)

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung nicht konfigurieren, können nur Administratoren und Netzwerkkonfigurations-Operatoren für alle Benutzer gültige RAS-Verbindungen löschen.

Wenn der Tipp "Löschen von RAS-Verbindungen nicht zulassen" aktiviert ist, hat sie Vorrang vor dieser Einstellung. Die Benutzer (einschließlich Administratoren) können keine RAS-Verbindungen löschen, und diese Einstellung wird ignoriert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_DeleteAllUserConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Löschen von RAS-Verbindungen zulassen
0 | Löschen von RAS-Verbindungen sperren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Möglichkeit, alle Benutzer-RAS-Verbindungen zu löschen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1984.htm


Herstellen und Trennen einer RAS-Verbindung nicht zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer RAS-Verbindungen herstellen und trennen können.

Wenn Sie diese Einstellung aktivieren, erfolgt beim Doppelklicken auf das Symbol keine Reaktion, und die Menüeinträge "Verbinden" und "Trennen" sind für alle Benutzer (einschließlich Administratoren) deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, stehen die Optionen "Verbinden" und "Trennen" für RAS-Verbindungen allen Benutzern zur Verfügung. Die Benutzer können eine RAS-Verbindung herstellen oder trennen, indem sie auf das Symbol für die Verbindung doppelklicken, mit der rechten Maustaste darauf klicken oder das Menü "Datei" verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RasConnect" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Herstellen und Trennen nicht zulassen
0 | Herstellen und Trennen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Herstellen und Trennen einer RAS-Verbindung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1985.htm


Aktivieren/Deaktivieren einer LAN-Verbindung zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer LAN-Verbindungen aktivieren/deaktivieren können.

Wenn Sie diese Einstellung aktivieren, stehen den Benutzern (einschließlich Benutzern ohne Administratorrechte) die Optionen "Aktivieren" und "Deaktivieren" für LAN-Verbindungen zur Verfügung. Die Benutzer können eine LAN-Verbindung aktivieren/deaktivieren, indem sie auf das Symbol für die Verbindung doppelklicken, mit der rechten Maustaste darauf klicken oder das Menü "Datei" verwenden.

Wenn Sie diese Einstellung deaktivieren, erfolgt beim Doppelklicken auf das Symbol keine Reaktion, und die Menüeinträge "Aktivieren" und "Deaktivieren" sind für alle Benutzer (einschließlich Administratoren) deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung nicht konfigurieren, können nur Administratoren und Netzwerkkonfigurations-Operatoren LAN-Verbindungen aktivieren/deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_LanConnect" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Aktivieren/Deaktivieren einer LAN-Verbindung zulassen
0 | Aktivieren/Deaktivieren einer LAN-Verbindung nicht zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Aktivieren/Deaktivieren einer LAN-Verbindung zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1986.htm


Zugriff auf den Assistent für neue Verbindungen nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Benutzer den Assistenten für neue Verbindungen verwenden können, mit dem neue Netzwerkverbindungen erstellt werden.

Wenn Sie diese Einstellung aktivieren, wird das Symbol "Neue Verbindung erstellen" weder im Ordner "Netzwerkverbindungen" noch im Startmenü angezeigt. Dadurch können Benutzer (einschließlich Administratoren) den Assistenten für neue Verbindungen nicht starten.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird das Symbol für "Neue Verbindung erstellen" im Startmenü und im Ordner "Netzwerkverbindungen" für alle Benutzer angezeigt. Wenn Sie auf das Symbol für "Neue Verbindung erstellen" klicken, wird der Assistent für neue Verbindungen gestartet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_NewConnectionWizard" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zugriff auf den Assistenten sperren
0 | Zugriff auf den Assistenten zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff auf den Assistent für neue Verbindungen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1987.htm


Umbennen privater RAS-Verbindungen nicht zulassen

Info: 2000 ab SP1

Mit diesem Tipp können Sie einstellen, ob Benutzer ihre privaten RAS-Verbindungen umbenennen können.

Bei privaten Verbindungen handelt es sich um solche Verbindungen, die nur einem Benutzer zur Verfügung stehen. Um eine private Verbindung zu erstellen, klicken Sie im Assistenten für neue Verbindungen auf der Registerkarte "Verfügbarkeit der Verbindung" auf die Option "nur selbst verwenden".

Wenn Sie diese Einstellung aktivieren, ist die Option "Umbenennen" für alle Benutzer (einschließlich Administratoren) deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, ist die Option "Umbenennen" für private RAS-Verbindungen aller Benutzer aktiviert. Die Benutzer können ihre private Verbindung umbenennen, indem sie auf ein Symbol für die Verbindung klicken oder das Menü "Datei" verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RenameMyRasConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Umbennen privater RAS-Verbindungen nicht zulassen
0 | Umbennen privater RAS-Verbindungen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Umbennen privater RAS-Verbindungen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1990.htm


Zugriff auf 'RAS-Einstellungen' im Menü 'Erweitert' nicht zulassen

Mit diesem Tipp können Sie einstellen, ob der Eintrag "RAS-Einstellungen" im Menü "Erweitert" im Ordner "Netzwerkverbindungen" aktiviert ist.

Mit dem Eintrag "RAS-Einstellungen" können Benutzer vor der Anmeldung Verbindungen erstellen und ändern und Funktionen für automatisches Wählen und Rückruf konfigurieren.

Wenn Sie diese Einstellung aktivieren, ist der Eintrag "RAS-Einstellungen" für alle Benutzer (einschließlich Administratoren) deaktiviert.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird der Eintrag "RAS-Einstellungen" für alle Benutzer aktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_DialupPrefs" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zugriff auf die Erweiterten-Einstellungen nicht zulassen
0 | Zugriff auf die Erweiterten-Einstellungen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Zugriff auf 'RAS-Einstellungen' im Menü 'Erweitert' nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1991.htm


Anzeige des Status aktiver Verbindungen nicht zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer den Status einer aktiven Verbindung anzeigen können.

Der Verbindungsstatus kann über das Symbol für den Verbindungsstatus in der Taskleiste und das Dialogfeld "Status" abgerufen werden. Das Dialogfeld "Status" zeigt Informationen zu der Verbindung und ihrer Aktivität an. Es enthält außerdem Schaltflächen, mit denen die Verbindung getrennt und Eigenschaften der Verbindung konfiguriert werden können.

Wenn Sie diese Einstellung aktivieren, stehen den Benutzern (einschließlich Administratoren) das Symbol für den Verbindungsstatus in der Taskleiste und das Dialogfeld "Status" nicht zur Verfügung.

Die Option "Status" ist im Kontextmenü für die Verbindung und im Menü "Datei" im Ordner "Netzwerkverbindungen" deaktiviert. Die Benutzer haben nicht die Möglichkeit, über das Dialogfeld "Verbindungseigenschaften" das Verbindungssymbol in der Taskleiste anzuzeigen.

Info Ab Windows XP muss der Tipp "Netzwerkeinstellungen für Administratoren aktivieren (Windows 2000)" aktiviert sein, ansonsten gelten die Einstellungen nur für Benutzer und nicht für Administratoren.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, stehen das Symbol für den Verbindungsstatus in der Taskleiste und das Dialogfeld "Status" allen Benutzern zur Verfügung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_Statistics" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Anzeige des Status nicht zulassen
0 | Status anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Anzeige des Status aktiver Verbindungen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1992.htm


Meldung 'Keine oder eingeschränkte Konnektivität' deaktivieren

Meldung "keine oder eingeschränkte Konnektivität" deaktivieren

Mit diesem Tipp können Sie einstellen, ob Benachrichtigungen für den Benutzer angezeigt werden sollen, wenn eine für DHCP konfigurierte Verbindung keine IP-Adresse von einem DHCP-Server abrufen kann.

Diese Meldung wird oft durch die automatische Zuweisung einer privaten IP-Adresse (z. B. eine IP-Adresse im Bereich 169.254.*.*) angedeutet. Dadurch wird indiziert, dass kein DHCP-Server erreicht werden konnte bzw. der DHCP-Server wurde erreicht und hat nicht auf die Anforderung, nicht mit einer gültigen IP-Adresse geantwortet. Standardmäßig wird eine Benachrichtigung angezeigt, die dem Benutzer Informationen zur Behebung dieses Problems anbietet.

Wenn Sie diese Einstellung deaktivieren, steht die Option "Umbenennen" für LAN/RAS-Verbindungen keinem Benutzer (einschließlich Administratoren und Netzwerkkonfigurations-Operatoren) zur Verfügung.

Wenn Sie diese Richtlinieneinstellung aktivieren, wird dieser Zustand nicht als Fehler an den Benutzer gemeldet.

Wenn Sie diese Richtlinieneinstellung deaktivieren oder nicht konfigurieren, wird eine für DHCP konfigurierte Verbindung, für die keine IP-Adresse zugewiesen wurde, über eine Benachrichtigung gemeldet. Dem Benutzer werden Informationen zur Problembehebung angeboten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_IpStateChecking" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Meldung nicht anzeigen
0 | Meldung anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Benachrichtigungen deaktivieren, wenn eine Verbindung über keine oder eingeschränkte Konnektivität verfügt

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1993.htm


Offline-Ordner nur bei bestimmter Bandbreite synchronisieren

Konfiguriert den Schwellwert, bei dem Offlinedateien eine Netzwerkverbindung als langsam betrachten. Jede Netzwerkdatenrate unterhalb dieses Wertes wird als langsam betrachtet.

Windows synchronisiert Offline-Ordner automatisch beim An- und Abmelden. Diese Synchronisation findet aber standardmäßig erst ab einer Bandbreite von 64 KBit statt. Je nach Größe der Offline-Ordner und Geschwindigkeit ihrer Netzwerkanbindung kann der Wert zu groß oder zu klein sein.

Haben Sie z.B. nur wenige kleine aber wichtige Dateien, kann es sinnvoll sein, diese Ordner auch bei einer Modemanbindung zu synchronisieren. Es wird aber wohl eher der Fall sein, dass dieser Wert zu klein ist. Da 64 KBit der Geschwindigkeit einer ISDN-Leitung entspricht, würde Windows also auch die Synchronisation über eine ISDN-Verbindung durchführen. Wenn sich nun viele große Dateien in Ihrem Offline-Ordner befinden, kann das die An-/Abmeldezeit erheblich verlängern.

Sie können die Einstellung, wann eine Synchronisierung stattfinden soll, über die Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

Einstellung gilt nur für den User:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Netcache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Netcache

bzw. als Policy:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "SlowLinkSpeed" als Datentyp REG_DWORD und geben die Geschwindigkeit in (Bit/s / 100) an. Wenn Sie zum Beispiel einen Schwellwert von 128.000 Bit/s festlegen wollen, geben Sie den Wert "1280" ein.

Min | Max | in
0 | 100000000 | Minuten (Dezimal)

Der Standardwert liegt bei 640 Bit/s /100

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Übertragungsrate für langsame Verbindungen konfigurieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1192.htm


Ordner DFÜ- und Netzwerkeinstellungen leer

Wenn die Ordner DFÜ- und Netzwerkeinstellungen leer sind, obwohl bereits verschiedene Verbindungen eingerichtet wurden und auch entsprechend funktionieren, wurde vermutlich der Dienst Netzwerkverbindungen nicht gestartet. Dieser wird auf einigen Systemen durch die Installation von Treibern für ISDN-Karten deaktiviert und startet nicht mehr automatisch.

Zur Abhilfe stellt man den Starttyp des Dienstes über die "Systemsteuerung" -> "Verwaltung" -> "Dienste" -> "Netzwerkverbindungen" auf automatisch und startet das System neu.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1032.htm


Nach der Installation von Active Directory funktioniert der Internetzugang nicht mehr

Nach Installation von Active Directory funktioniert der Internetzugang nicht mehr

Wenn man unter Windows 2000 Server "Active Directory" mit dem Standard-Setup einrichtet, kommt es meist zu dem Fehler, dass keine DNS-Namensauflösung für Internetseiten mehr möglich ist. Das passiert, wenn man bei der Installation auf die Frage "DNS-Server zu Root-Server machen" mit "JA" beantwortet. Wenn man das macht, wird der DNS-Server so eingerichtet, als ob er für das ganze Internet zuständig ist und leitet selber keine Anfragen mehr an andere DNS-Server mehr weiter.

Er selber ist aber halt nicht in der Lage, die Namensauflösung durchzuführen und gibt somit die Fehlermeldung "Host nicht gefunden" aus.

Fehler beheben:

Starten Sie den DNS-Server Manager, dort finden Sie als einen zusätzlichen Eintrag einen Punkt (.). Dieser Punkt ist der Name für eine Root-Domäne. Sie müssen diesen Punkt einfach nur löschen und schon sollte wieder alles gehen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0992.htm


Internetverbindung ohne Nachfrage deaktivieren

Benötigt die aktuelle Anwendung eine www-Verbindung, erscheint die Login-Aufforderung von Windows.

Diese kann automatisch gestartet werden, was auch über die Checkbox unten einzustellen ist. Zur Aktivierung/Deaktivierung dieser Funktion muss die Registry für Windows wie folgt geändert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ RemoteAccess\ Profile\ [Providername]

ändert man den Wert "AutoConnect" auf 1 auf 0.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0866.htm


Ballon Info beim Minimieren des Messengers ausschalten

Wenn Sie den Messenger in den Hintergrund schalten, wird Ihnen ein Infotext angezeigt, dass der Messenger weiterhin im Hintergrund ausgeführt wird. Mit diesem Tipp, können Sie die Anzeige diese Informationen deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ MessengerService

Erstellen Sie hier einen neuen Wert mit dem Namen "DSBkgndMode" als Datentyp REG_BINARY. Setzen Sie den Wert auf:

01 00 00 00 | Infotext ausschalten
00 00 00 00 | Infotext anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1634.htm


Protokollierung für PPP aktivieren

Wenn Sie Probleme mit einer PPP-Verbindung haben, kann es meist recht nützlich sein, wenn man sich ein PPP-Protokoll erstellen lässt.

Mit folgenden Befehlen können Sie die Protokollierung aktivieren. Die Logdateien finden Sie dann unter "%SYSTEMROOT%\tracing".

  1. Öffnen Sie die Eingabeaufforderung
  2. Geben Sie hier nun folgendes ein:
    Netsh
    Ras
    Set tracing PPP enable

Info Wenn Sie das Protokoll nicht mehr brauchen, sollten Sie diese Funktion wieder deaktivieren, da hier doch etliche Ressourcen verbraucht werden. Dazu gehen Sie folgendermaßen vor:

  1. Öffnen Sie die Eingabeaufforderung
  2. Geben Sie hier nun folgendes ein:
    Netsh
    Ras
    Set tracing PPP disable

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0853.htm


Remote Account nach Anzahl fehlerhafter Eingaben sperren

Mit diesem Tipp legen Sie fest, nach wie vielen fehlerhaften Eingaben der Account gesperrt wird.

Weiterhin können Sie festlegen wie lange der Account gesperrt bleibt. Wenn Sie die max. Anzahl der Eingaben auf 0 setzen, ist die Funktion ausgeschaltet und der Account wird nicht gesperrt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RemoteAccess\ Parameters\ AccountLockout

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxDenials" als Datentyp REG_DWORD. Geben Sie hier die max. Anzahl der Eingaben an.

Erstellen Sie hier einen neuen Wert mit dem Namen "ResetTime" als Datentyp REG_DWORD. Geben Sie die Zeit im Minuten an, wie lange der Account gesperrt bleibt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1620.htm


Hagenuk-Databox (und andere) funktionieren nicht

Externe ISDN-Adapter wie die Hagenuk-Databox werden vom Betriebssystem in der Regel am COM-Port angesprochen. Trotz richtig installierter Software und Statusmeldungen der Box kommt es zumindest bei der Hagenuk-Box unter Windows 2000 vor, dass direkt beim Einwahlversuch Windows meldet, dass das angeschlossene Gerät nicht richtig funktioniert.

Abhilfe schafft ein erweiterter Eintrag in die Datei Boot.ini (evtl. unter Extras -> Ordneroptionen -> Ansicht auch die Anzeige geschützter Systemdateien aktivieren.)

Direkt hinter den Boot-Eintrag setzt man die Parameter:

/noserialmice=com1 /noserialmice=com2

z.B.

multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect /noserialmice=com1 /noserialmice=com2

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1074.htm


ICS mit PPPoE benötigen Patch am MTU-Wert

Wer das ICS (Internet Connection Sharing) mit einem PPPoverEthernet-Treiber benutzt (z.B. für TDSL unter http://user.cs.tu-berlin.de/~normanb/), muss Modifkationen am MTU-Wert vornehmen, damit die ICS-Clients Daten erhalten.

Die Clients benötigen einen MTU-Wert (Maximum Transmission Unit) unterhalb von 1500. Man sollte daher 1492 einstellen.

Den richtigen MTU-Wert ermittelt man wie folgt:

- Über IPConfig ermittelt man die IP-Adresse (Standardgateway) des ICS-Servers.

- Diesen pingt man wie folgt an: PING -f -l <MTU-Wert> <IP-Adresse des Standardgateways über IPConfig>.

- Man beginnt mit einem MTU-Wert von 1454 und wartet auf eine Antwort. Kommt eine Fehlermeldung, verringert man den MTU-Wert.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=259783. Dieser Artikel ist (derzeit) leider nicht verfügbar

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0973.htm


Automatische Anmeldung in der Wiederherstellungskonsole (Recovery Console) aktivieren

Wenn man die Wiederherstellungskonsole (Recovery Console) startet, wird man nach dem lokalen Administrator-Passwort gefragt und muss dieses für die Anmeldung eingeben.

Mit diesem Tipp können Sie einstellen, dass die Anmeldung an die Wiederherstellungskonsole automatisch erfolgt und kein Passwort eingegeben werden muss.

Aus Sicherheitsgründen sollten Sie immer die Eingabe eines Passwortes verlangen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Setup\ RecoveryConsole

Erstellen Sie hier einen neuen Wert mit dem Namen "SecurityLevel" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Automatische Anmeldung
0 | Passwort wird abgefragt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1630.htm


Keine LAN Manager-Hashwerte bei nächster Kennwortänderung mehr speichern

Man sollte in der Registry den Eintrag zum Anlegen der LM Hashes deaktivieren, da die Verwendung von NT-Hash viel sicherer ist. Leider legt das System, um kompatibel zu alten Systemen zu bleiben, generell erstmals ein LM-Hash mit an (bis Windows XP).

Über den LM-Hash Eintrag kann das Passwort heutzutage in einer Zeit von 2-5 Sekunden geknackt werden.

Wenn Sie den Tipp aktiviert haben, müssen Sie den Rechner neu starten und das Passwort ändern, damit ein Passwort ohne LM-Hash erzeugt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows 2000 ab SP2

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ LSA

Erstellung Sie ein neuen SCHLÜSSEL nicht Wert mit den Namen "NoLmHash". Der Eintrag sieht dann so aus (HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ LSA\ NoLmHash)

Ab Windows XP

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ LSA

Erstellen Sie hier einen neuen Wert mit dem Namen "NoLmHash" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | LM-Hash ausschalten (Standard ab Vista)
0 | LM-Hash speichern (Standard)

Info Ab Windows Vista ist der Wert Standardmäßig auf 1 (keine LM-Hash-Werte)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=299656

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1663.htm


NTFS-Berechtigungen werden bei Konvertierung von FAT nicht übernommen

Wenn Sie Windows ursprünglich in einer FAT- oder FAT32-Partition installiert haben und die Partition später (nach der Installation) mit dem Programm Convert.exe nach NTFS konvertiert haben, werden die Standardsicherheitseinstellungen (Access Control Lists) nicht übernommen.

Mit einem Befehl in der Kommandozeile werden die Standard-NTFS-Berechtigungen für den Windows Ordner und dem Ordner Programme wieder hergestellt:

für Windows 2000 Prof:

Secedit /configure /db C:\winnt\temp\temp.mdb /Cfg c:\winnt\inf\defltwk.inf /areas filestore

für Windows 2000 Server:

Secedit /configure /db c:\winnt\temp\tmp.mdb /Cfg C:\winnt\inf\defltsv.inf /areas filestore

Info Weitere Informationen finden sich im Artikel D42121.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1130.htm


Verschlüsseln von Daten

Windows bietet jetzt auch die Möglichkeit, die Daten auf der Festplatte zu verschlüsseln - Encrypting File System (EFS). Dadurch ist es nicht mehr möglich, dass unbefugte Personen, durch einfaches Installieren einer weiteren Windows Version Ihre Daten lesen können.

Der Vorteil ist, dass Sie als Anwender ohne Probleme auf das Verzeichnis zugreifen können. Das Verschlüsseln wird in Echtzeit automatisch von Windows vorgenommen.

Da das EFS kein eigenes Dateisystem ist, sondern nur ein Zusatz für NTFS, kann es auch nur auf NTFS-Laufwerken benutzt werden. Wenn Sie ein Verzeichnis mit EFS Verschlüsseln, kann man sich immer noch den Inhalt der Verzeichnisse ansehen, erst wenn man die Datei öffnen will, geht das nur mit einem gültigen Schlüssel.

Um ein bestimmtes Verzeichnis zu verschlüsseln, gehen Sie folgendermaßen vor:

  1. Das Dateisystem des Laufwerkes muss NTFS sein. Sollte das noch nicht der Fall sein, müssen Sie das Laufwerk erst nach NTFS konvertieren (siehe: FAT in NTFS umwandeln).
  2. Klicken Sie im Explorer mit der rechten Maustaste auf das entsprechende Verzeichnis
  3. Wählen Sie aus dem Kontextmenü "Eigenschaften"
  4. Klicken Sie auf der Tapreiterseite "Allgemein" auf den Button "Erweitert..."
  5. Aktivieren Sie die Auswahlbox "Inhalt verschlüsseln, um Daten zu schützen" und klicken Sie auf OK
  6. Sie sollten noch festlegen, welche USER auf dieses Verzeichnis Zugriffsrechte haben sollen (unter dem Kontextmenü "Sicherheitseinstellungen")
  7. Wenn Sie fertig sind, klicken Sie auf den Button "Übernehmen". Windows zeigt nun in einer Informationsbox an, welche Änderungen durchgeführt werden. Hier können Sie noch einstellen, ob das Verschlüsseln auch für alle weiteren Unterverzeichnisse gelten soll. Klicken Sie hier das entsprechende an und bestätigen Sie das Verschlüsseln mit OK
  8. Windows verschlüsselt nun das Verzeichnis, je nach Datenmenge dauert das einige Minuten

Sie sollten zusätzlich auch das TEMP-Verzeichnis verschlüsseln, da hier die meisten Programme Dateien auslagern, diese Auslagerungsdateien aber Oftmals nicht wieder löschen.

Auf Systemen, die nicht in einer Domäne arbeiten, wird für den Administrator lokal ein Generalschlüsselaus Sicherheitsgründen hinterlegt. Mit diesem Generalschlüssel können alle Daten entschlüsselt werden. Deshalb darf dieser Schlüssel natürlich nicht auf diesem System verbleiben (Laptop), ansonsten können sich unberechtigte Personen dieses Schlüssels bedienen und alle Daten lesen.

Sie sollten den Generalschlüssel in eine Datei exportieren und den Eintrag des Generalschlüssels löschen. Eine Anleitung finden Sie unter "Sicherheitsschlüssel (EFS) exportieren/importieren".

Die Diskette mit dem Generalschlüssel sollten Sie an einem sicheren Ort verwahren.

EFS-Umgehen

Wenn Sie den Schlüssel verloren haben, ist es nicht mehr möglich an die Daten zu kommen. Unter Windows 2000 können durch einen Sicherheitsfehler die Daten mit dem Tool "AEFSDR" (Advanced EFS Data Recovery) oft wieder hergestellt werden. Das funktioniert aber auch nur, wenn noch ein Teil des EFS-Schlüssels aus Windows ausgelesen werden kann.

Info Durch einen Sicherheitsfehler im Windows 2000 sollte man hier EFS lieber nicht benutzen. Hier müssen nur die Zugangspasswörter geändert werden um auf die Daten zugreifen zu können. Benutzen Sie hier lieber die Software "TrueCrypt". Dieses Programm kann kostenlos unter "http://truecrypt.sourceforge.net/" heruntergeladen werden. Nach meiner Meinung ist das Programm auch unter XP eine sehr gute Alternative.

Windows XP Home

Das Verschlüsseln von Dateien funktioniert unter Windows XP Home nicht. Die benötigten Funktionen sind von Microsoft nicht für die Home-Version von Windows XP vorgesehen.

Damit Sie diese Funktion benutzen können müssen Sie:

  1. Den Tip2010 "Windows XP Home nach Windows XP Professional umstellen" umsetzen
  2. Die Datei "Cipher.EXE" fehlt noch in der XP Home-Version. Diese Datei finden Sie im Service Pack 2 für Windows XP (<Download>). Entpacken Sie das Service Pack über „<Dateiname> /x“.
  3. Jetzt können Sie über expand <Verzeichnis>\i386\cipher.ex_ %windir%\system32\cipher.exe die Datei in den entsprechenden Windows Ordner entpacken.

Jetzt steht auch unter Windows XP Home die Funktion zum Verschlüsseln von Dateien zur verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0782.htm


Passwort wird nicht automatisch in allen Sessions geändert!

Wenn Sie unter Windows 2000 mehr als einmal angemeldet sind und das Passwort in einer Session ändern, wird diese Änderung zwar auch bei den anderen Verbindungen durchgeführt, aber die zwischengespeicherten Informationen werden nicht gelöscht. So kann man mit den alten oder neuen Passwort arbeiten.

Das Löschen dieser alten Passwörter wird nur durch das manuelle Beenden aller Netzwerkverbindungen erreicht.

Beachten Sie dieses bei System Accounts, die meist mehr als eine Session geöffnet haben. Ansonsten können alte Passwörter noch lange Zeit ihre Gültigkeit behalten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0846.htm


Sicherheitsschlüssel (EFS) exportieren/importieren

Wenn Sie, wie unter "Verschlüsseln von Daten" beschrieben, Dateien oder Verzeichnisse verschlüsseln und keine Domäne besitzen, sollten Sie den Sicherheitsschlüssel exportieren und sicher verwahren, um im Notfall auch wieder an die Daten zu kommen.

Um den Sicherheitsschlüssel des "Encrypting File System" (EFS) zu sichern, gehen Sie folgendermaßen vor:

  1. Melden Sie sich als Administrator an
  2. Starten Sie über "Systemsteuerung" -> "Verwaltung" -> "Lokale Sicherheitsrichtlinie" bzw. durch
    "Start" -> "Ausführen" und der Eingabe von "secpol.mmc"
  3. Klicken Sie auf "Richtlinien öffentlicher Schlüssel" -> "Agenten für Wiederherstellung von verschlüsselten Daten"
  4. Klicken Sie mit der rechten Maustaste auf den "Datenwiederherstellung" - Eintrag und wählen Sie aus dem Kontextmenü "Alle Tasks" -> "Exportieren..."
  5. Klicken Sie im Willkommensbildschirm des Assistenten auf "Weiter" -> "Ja, privaten Schlüssel exportieren" -> "Weiter"
  6. Unter "Exportdateiformat" sollten Sie aus Sicherheitsgründen "Privaten Schlüssel nach erfolgreichem Export löschen" auswählen.
  7. Klicken Sie auf "Weiter" -> geben Sie einen Dateinamen ein und speichern den Schlüssel über "Weiter" -> "Fertig stellen".

Diese Datei sollten Sie auf einer Diskette sicher verwahren.

Wenn Sie nicht mehr an die Daten kommen und den Sicherheitsschlüssel benötigen, können Sie ihn wieder folgendermaßen importieren:

  1. Melden Sie sich als Administrator an
  2. Klicken Sie mit der rechten Maustaste auf die Datei (*.pfx)
  3. Wählen Sie aus dem Kontextmenü "Install PFX"
  4. Bestätigen Sie mit "Weiter" -> geben Sie Ihr Passwort ein und bestätigen Sie mit "Weiter".

Info Weitere Informationen hierzu finden Sie unter: http://www.microsoft.com/windows2000/library/howitworks/security/encrypt.asp
Informationen zum Sichern: http://support.microsoft.com/?kbid=241201

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1016.htm


Sicherheit der Treibersignierung vorgeben

Hier können Sie den Sicherheitsgrad regeln, mit dem festgelegt wird, was bei nicht signierten Treibern passieren soll.

Sie können zwar in der Systemsteuerung den Sicherheitsgrad weiterhin verändern, aber es werden hier keine Einstellungen berücksichtigt, die kleiner sind als diese Einstellung.

Über die Oberfläche können Sie das auswählen. Klicken Sie mit der rechten Maustaste auf "Arbeitsplatz" -> "Eigenschaften", wählen Sie die Registerkarte "Hardware" und klicken dann auf "Treibersignierung".

Info Siehe dazu auch Tipp: "Die 'digitale Treibersignatur' für Gerätetreiber"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter (oder als Policies [für den Anwender]):

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Driver Signing

Erstellen Sie hier einen neuen Wert mit dem Namen "BehaviorOnFailedVerify" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | "Ignorieren" -> Installieren von unsignierten Dateien ohne Benachrichtigung
1 | "Warnen" -> Benachrichtigt den Anwender, wenn Dateien nicht digital signiert sind
2 | "Blockieren" -> Verweigert das Installieren von unsignierten Dateien.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Codesignatur für Gerätetreiber

Info Siehe dazu auch Tipp:

Die 'digitale Treibersignatur' für Gerätetreiber

" Warnhinweis bei Treibern ohne digitaler Signatur

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1454.htm


Protokollierung von Anwenderaktivitäten ausschalten

Windows führt ein Protokoll darüber, welche Programme ein Anwender startet und welche Dateien und Dokumente von ihm bearbeitet werden.

Wenn diese Funktion nicht gewünscht ist, kann diese über die Registry ausgeschaltet werden.

Beim Aktivieren wird verhindert, dass Benutzervorgänge, wie Programme, Pfade oder Dokumente, die Benutzer verwenden, nachverfolgt werden. Diese Informationen werden zum Anpassen der Windows-Funktionen, wie z. B. benutzerdefinierte Menüs, verwendet. Benutzerdefinierte Funktionen, die Informationen über die Benutzernachverfolgung verwenden (einschließlich persönlich angepassten Menüs), werden deaktiviert (siehe: Ausblenden von selten verwendeten Menüpunkten ausschalten).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoInstrumentation" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Protokoll ausschalten
gelöscht | Protokoll aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Benutzerüberwachung deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1344.htm


Automatisches Entschlüsseln beim Verschieben von Dateien ausschalten

Mit dieser Policy können Sie verhindern, dass Windows automatisch Dateien entschlüsselt, die in ein nicht verschlüsseltes Verzeichnis verschoben werden.

Diese Konfiguration gilt nur innerhalb einer Platteneinheit. Wird die Datei auf ein anderes Medium verschoben, wird sie automatisch entschlüsselt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoEncryptOnMove" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Beim Verschieben nicht entschlüsseln
0 | Beim Verschieben entschlüsseln (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1571.htm


Herunterladen von fehlenden COM-Objekten

Mit dieser Policy können Sie einstellen, ob automatisch nach fehlenden COM-Objekten im Active Directory gesucht werden soll. Wenn ein Programm auf ein COM-Objekt zugreift, welches nicht installiert ist, sucht Windows nach dem Objekt und installiert es automatisch nach, wenn es gefunden wird.

Wenn Sie diese Funktion ausschalten, wird nicht nach fehlenden COM-Objekten gesucht, was dazu führen kann, dass diese Anwendungen dann nicht laufen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ App Management

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ App Management

Erstellen Sie hier einen neuen Wert mit dem Namen "COMClassStore" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Herunterladen von COM-Objekten ist aktiv
0 | Herunterladen von COM-Objekten ist deaktiv

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1572.htm


Die Windows Dienste und ihre Funktionen

Hier finden Sie eine Zusammenstellung der Windows Dienste mit einer kurzen Beschreibung.

Eine neue und ausführliche Übersicht wurde unter den folgenden Tipps erstellt:

  • Übersicht der Dienste unter Windows XP
  • Übersicht der Dienste unter Windows Vista

Hier finden Sie eine Zusammenstellung der Windows Dienste mit einer kurzen Beschreibung. In der Tabelle ist jeweils die Standardart der Dienste angegeben.

MS startet standardmäßig viele Dienste, die aber von den wenigsten Heimanwendern benötigt werden und so den Rechner nur unnötig verlangsamen. Darum wird in der dritten Spalte eine Empfehlung für die Einstellung des Dienstes gegeben, welche für die meisten Standardsysteme auch sinnvoll ist.

Beim Verändern der Startarten von Diensten sollten Sie aber vorsichtig sein und sich immer anschauen, wofür der Dienst eigentlich zuständig ist. Deaktivieren sollten Sie nur Dienste, von denen Sie auch genau wissen, dass sie nicht benötigt werden. Andernfalls kann es passieren, dass Anwendungen nicht mehr starten oder im schlimmsten Fall Windows selber nicht mehr richtig läuft.

Aus diesem Grunde sind in der Tabelle alle funktionswichtigen Dienste von Windows in 'ROT' dargestellt: Hier sollten Sie unter keinen Umständen Änderungen vornehmen.

Noch ein paar Fragen vorab

Was sind Dienste?

Dienste werden unter Windows eingesetzt, um Treiber für Hardware und Software zur Verfügung zu stellen. Eine Übersicht aller Dienste und ihres Statuses (Getsartet oder nicht) finden Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Dienste".

Was bedeuten die Startarten?

Automatisch | Gibt an, dass der Dienst immer beim Starten des Systems automatisch gestartet werden soll.
Manuell | Gibt an, dass der Dienst nur automatisch gestartet werden soll, wenn er benötigt wird.
Deaktiviert | Gibt an, dass der Dienst nicht mehr gestartet werden soll, auch wenn er angefordert wird.

Wie kann ich die Startart ändern?

Die Dienste können über "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Verwaltung" -> "Dienste" konfiguriert werden. Führen Sie dafür auf dem entsprechenden Dienst einfach einen Doppelklick aus und stellen Sie den entsprechenden Starttyp ein.

Abhängigkeiten:

Wenn Sie einen Dienst beenden, sollten Sie sich vorher die Abhängigkeiten anschauen. Klicken Sie dazu auf den entsprechenden Dienst (Doppelklick oder rechte Maustaste -> Eigenschaften) und wechseln Sie auf den Tabreiter "Abhängigkeiten". Hier finden Sie unter "Diese Systemkomponenten sind von diesem Dienst abhängig" die Dienste, welche diesen Dienst benötigen. Wenn hier ein Dienst dabei ist, den Sie benötigen, dürfen Sie diesen Dienst auch nicht beenden.

Name | Standard | Empfehlung
Ablagemappe | Manuell | Manuell
Unterstützt die Ablagemappe und erlaubt Seiten auf Remoteablagemappen anzuzeigen.
Anmeldedienst | Automatisch | Manuell
Unterstützt Durchsatzauthentifizierung von Kontoanmeldungsereignissen für Computer in einer Domäne.
Anwendungsverwaltung | Manuell | Manuell
Bietet Softwareinstallationsdienste an wie Zuweisung, Veröffentlichung, und Deinstallation.
Arbeitsstationsdienst | Automatisch | Automatisch
Bietet Netzwerkverbindungen und -kommunikation.
COM und Ereignissystem | Manuell | Manuell
Stellt COM-Komponenten und automatische Verteilungen von Ereignissen zur Verfügung.
Computerbrowser | Automatisch | Manuell
Führt eine aktuelle Liste der Computer im Netzwerk und gibt diese an Programme weiter.
Dateireplikation (Server) | Manuell | Manuell
Gewährleistet die Dateisynchronisation von Verzeichnissen über mehrere Server.
Designs | Automatisch | Manuell
Startet die neue Luna Oberfläche von Windows XP. Wer es klassisch mag, kann den Dienst ausschalten.
DHCP-Client | Automatisch | Manuell
Verwaltet die Netzwerkkonfiguration, indem IP-Adressen und DNS-Namen registriert und aktualisiert werden.
Dienst "Ausführen als" | Automatisch | Manuell
Aktiviert das Starten von Prozessen unter alternativen Anmeldeinformationen.
Distributed Transaction Coordinator | Manuell | Manuell
Koordiniert Transaktionen, die über mindestens zwei Datenbanken, Message Queues, Dateisysteme oder andere transaktionsgeschützte Ressourcen-Manager verteilt sind.
DNS-Client | Automatisch | Manuell
Wertet DNS-Namen (Domain Name System) aus und speichert sie zwischen.
Druckwarteschlange | Automatisch | Automatisch
Lädt die Dateien in den Arbeitsspeicher, um sie später zu drucken. Wird dieser Dienst deaktiviert, erkennt Windows die Drucker nicht mehr.
Ereignisprotokoll | Automatisch | Automatisch
Protokolliert von Programmen und Windows gesendete Ereignisnachrichten. Das Ereignisprotokoll beinhaltet Informationen, die zur Diagnose bei Problemen hilfreich sein können. Das Protokoll kann mit der Ereignisanzeige angesehen werden.
Faxdienst | Manuell | Manuell
Unterstützt Sie beim Senden und Empfangen von Faxen.
Gemeinsame Nutzung der Internetverbindung | Manuell | Manuell
Bietet allen Computern über eine DFÜ-Verbindung Netzwerkadressübersetzungs- und Namensauflösungsdienste auf Ihrem Netzwerk.
Geschützter Speicher | Automatisch | Automatisch
Bietet geschützten Speicherplatz für private Daten, wie z. B. private Schlüssel, um Zugriff durch nicht autorisierte Dienste, Prozesse oder Benutzer zu unterbinden.
Hilfsprogramm-Manager | Manuell | Manuell
Startet und konfiguriert Eingabehilfen über einen zentralen Dialog.
Indexdienst | Manuell | Deaktiviert
Indexerstellung
Infrarotüberwachung | Automatisch | Automatisch
Unterstützt auf dem Computer installierte Infrarotgeräte und sucht nach anderen Geräten in Reichweite.
IPSEC-Richtlinienagent | Automatisch | Manuell
Verwaltet IP-Sicherheitsrichtlinien und startet den IKE-Treiber (ISAKMP/Oakley) und den IP-Sicherheitstreiber.
Kerberos-Schlüssel- verteilungscenter (Server) | Deaktiviert | Deaktiviert
Generiert Sitzungsschlüssel und liefert Diensttickets für gegenseitige Client-/Server-Authentifizierung.
Kryptographiedienste | Automatisch | Automatisch
Wird dieser Dienst deaktiviert, ist die Installation von Windows Updates, Service Packs sowie DirectX nicht mehr möglich.
Leistungsdatenprotokolle und Warnungen | Manuell | Manuell
Konfiguriert Leistungsdatenprotokolle und Warnungen.
Lizenzprotokollierdienst | Automatisch | Manuell
Zur Verwaltung der Lizenzen. Die Lizenzinformationen werden automatisch aufgezeichnet.
Nachrichtendienst | Automatisch | Manuell
Sendet und empfängt Nachrichten, die von Administratoren oder vom Warndienst übertragen wurden.
NetMeeting-Remotedesktop-Freigabe | Manuell | Manuell
Ermöglicht autorisierten Personen, auf Ihren Windows-Desktop mit NetMeeting zuzugreifen.
Netzwerk-DDE-Dienst | Manuell | Manuell
Netzwerktransport und Sicherheit für DDE (Dynamic Data Exchange).
Netzwerk-DDE-Serverdienst | Manuell | Manuell
Verwaltet den Austausch von gemeinsamen dynamischen Daten und wird vom Netzwerk-DDE verwendet.
Netzwerkverbindungen | Manuell | Manuell
Verwaltet Objekte im Ordner "Netzwerk- und DFÜ-Verbindungen", in dem sowohl LAN- als auch WAN-Verbindungen angezeigt werden.
NT-LM-Sicherheitsdienst | Manuell | Manuell
Bietet Sicherheit für Remoteprozeduraufrufe (RPC), die andere Transportwege als Named Pipes verwenden.
Plug & Play | Automatisch | Automatisch
Verwaltet Geräteinstallationen sowie -konfigurationen und informiert Programme über Geräteänderungen.
QoS RSVP | Manuell | Manuell
Bietet Programmen und Systemsteuerungssymbolen, die QoS unterstützen, Installationsfunktionen zur Steuerung von Netzwerksignalen und lokalem Netzwerkverkehr.
RAS-Verbindungsverwaltung | Manuell | Manuell
Stellt eine Netzwerkverbindung her.
Remote Access Auto Connection Manager (Server) | Manuell | Manuell
Stellt immer eine Verbindung zu einem Remotenetzwerk her, wenn ein Programm eine Remote-DNS- oder -NetBIOS-Adresse anspricht.
Remoteprozeduraufruf (RPC) | Automatisch | Manuell
Endpunktzuordnung und andere verschiedene RPC-Dienste.
Remote-Registrierungsdienst | Automatisch | Manuell
Ermöglicht die Bearbeitung der Registrierung über das Netzwerk.
Routing und RAS | Deaktiviert | Deaktiviert
Bietet Routingdienste in LAN- und WAN-Netzwerkumgebungen.
RPC-Locator | Manuell | Manuell
Verwaltet die Datenbank für den RPC-Namensdienst.
Server | Automatisch | Manuell
Bietet RPC-Unterstützung sowie Datei-, Drucker-, und Named Pipe-Freigabe.
Sicherheitskontenverwaltung | Automatisch | Manuell
Speichert Sicherheitsinformationen für lokale Benutzerkonten.
Simple Mail-Transportprotokoll (SMTP) (Server) | Automatisch | Manuell
Transportiert E-Mail über das Netzwerk
Smartcard | Manuell | Manuell
Verwaltet und steuert den Zugriff auf eine Smartcard, die sich in einem am Computer angeschlossenen Smartcard-Leser befindet.
Smartcard-Hilfsprogramm | Manuell | Manuell
Unterstützt herkömmliche Smartcard-Leser, die an den Computer angeschlossen sind.
Standortübergreifender Meldungsdienst (Server) | Deaktiviert | Deaktiviert
Ermöglicht das Senden und Empfangen von Nachrichten zwischen Windows Advanced Server-Standorten.
Systemereignis-Benachrichtigung | Automatisch | Manuell
Verfolgt Systemereignisse wie Windows-Anmeldungen sowie Netzwerk- und Stromversorgungsereignisse. Benachrichtigt außerdem COM+ Ereignissystembezieher von diesen Ereignissen.
Taskplaner | Automatisch | Manuell
Ermöglicht es, ein Programm zu einer vorgegebenen Zeit auszuführen.
TCP/IP-NetBIOS-Hilfsprogramm | Automatisch | Manuell
Ermöglicht die Unterstützung vom NetBIOS-über-TCP/IP-Dienst (NetBT) und die NetBIOS-Namensauflösung.
Telefonie | Manuell | Manuell
Bietet Telefonie-API-Unterstützung (TAPI) für Programme, die Telefoniegeräte steuern, sowie IP-basierte Sprachverbindungen am lokalen Computer und über das LAN auf Servern, die diesen Dienst ebenfalls ausführen.
Telnet | Manuell | Manuell
Ermöglicht es einem Remotebenutzer, sich am System anzumelden und Konsolenprogramme unter der Verwendung der Befehlszeile auszuführen.
Terminaldienste (Server) | Deaktviert | Deaktiviert
Bietet eine Multisessionumgebung die es Clientgeräten ermöglicht, auf eine virtuelle Windows 2000 Professional-Desktopsitzung zuzugreifen und Windows-basierte Programme auf dem Server auszuführen.
Überwachung verteilter Verknüpfungen (Client) | Automatisch | Manuell
Sendet Benachrichtigungen über Dateien, die zwischen NTFS-Laufwerken in einer Netzwerkdomäne bewegt werden.
Überwachung verteilter Verknüpfungen (Server) | Manuell | Manuell
Speichert Informationen, damit Dateien, die zwischen Laufwerken verschoben werden, für jedes Laufwerk in der Domäne überwacht werden können.
Unterbrechungsfreie Spannungsversorgung | Manuell | Manuell
Sendet Benachrichtigungen über Dateien, die zwischen NTFS-Laufwerken in einer Netzwerkdomäne bewegt werden.
Verteiltes Dateisystem (DFS) (Server) | Automatisch | Deaktiviert
Verwaltet logische Datenträger, die sich auf einem LAN- oder WAN-Netzwerk befinden.
Verwaltung für automatische RAS-Verbindung | Manuell | Manuell
Erstellt immer eine Verbindung zu einem Remotenetzwerk her, wenn ein Programm eine Remote-DNS- oder -NetBIOS-Adresse anspricht.
Verwaltung logischer Datenträger | Automatisch | Automatisch
Überwachungsdienst für die Verwaltung logischer Datenträger
Verwaltungsdienst für die Verwaltung logischer Datenträger | Manuell | Manuell
Verwaltungsdienst für Datenträgerverwaltungsanforderungen.
Warndienst | Manuell | Manuell
Benachrichtigt bestimmte Benutzer und Computer über administrative Warnungen.
Wechselmedien | Automatisch | Manuell
Verwaltet austauschbare Medien, Geräte und Bibliotheken.
Windows Installer | Manuell | Manuell
Installiert, repariert und entfernt Software anhand von Anweisungen in .MSI-Dateien.
Windows Media-Sendungsdienst (Server) | Manuell | Manuell
Wird zur Gruppierung von Windows Media-Datenströmen zu einer Sendung für den Windows Media-Stationsdienst verwendet.
Windows Media-Stationsdienst (Server) | Manuell | Manuell
Stellt Multicasting und Verteilungsdienst zur Ausstrahlung von Windows Media-Inhalt bereit.
Windows Media-Überwachungsdienst (Server) | Manuell | Manuell
Stellt Dienste zur Überwachung von Client- und Serververbindungen zu den Windows Media-Diensten bereit.
Windows Media-Unicastdienst | Manuell | Manuell
Stellt Clients im Netzwerk Windows Media-Inhalt auf Abruf bereit.
Windows-Verwaltungsinstrumentation | Automatisch | Manuell
Zeigt Systemverwaltungs-Informationen an.
Windows-Verwaltungsinstrumentations- Treibererweiterungen | Manuell | Manuell
Bietet Systemverwaltungsinformationen für und von Treibern.
WWW-Publishingdienst (Server) | Automatisch | Manuell
Stellt Webverbindung und Webverwaltung mit Hilfe des Snap-In der Internet-Informationsdienste zur Verfügung.
Windows-Zeitgeber | Manuell | Manuell
Stellt die Systemuhr.

Info Je nach installierter Software können bei Ihnen noch weitere Dienste eingetragen sein oder einige Dienste nicht auftauchen.

Info Unter "http://www.ntsvcfg.de" finden Sie ein Tool, mit welchem Sie die Dienste automatisch anhand von Gruppierungen konfigurieren können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0995.htm


Dateien unverschlüsselt auf dem Server abspeichern

Wenn Sie eine verschlüsselte Datei von Ihrem Rechner auf einen Windows Server kopieren, wird die Datei auch auf dem Server verschlüsselt abgelegt. Wenn Sie die Datei auf dem Server aber auch für andere zum Lesen ablegen wollen, ist diese Funktion oft nicht erwünscht.

Meist sollen die Daten nur auf dem Notebook zur Sicherheit verschlüsselt abgelegt werden und auf dem Server unverschlüsselt bleiben. Damit Sie nicht immer die Dateien händisch entschlüsseln müssen, ändern Sie die folgende Einstellung auf dem Server.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ FileSystem

finden Sie hier einen Wert mit dem Namen "NtfsEncryptionService" als Datentyp REG_SZ.

Wenn Sie diesen Key löschen, werden die Dateien nicht mehr verschlüsselt auf dem Server abgelegt. Wenn Sie die Dateien wieder verschlüsselt ablegen wollen, legen Sie bitte diesen Key wieder an und tragen Sie als Wert "Efs" ein.

Anschließend müssen Sie den Server neu starten, damit die Änderung geladen wird.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1825.htm


Sicherheit von Windows Scripting Host konfigurieren

Windows Scripting Host (WSH) führt Skriptdateien oder Aufrufe von HTML-Seiten (*.js, *.jse, *.vbe, *.vbs, *.wsf, *.wsh) aus. Dieses wird über die Dateien WSCRIPT.EXE und CSCRIPT.EXE gemacht.

Dies kann ein Sicherheitsrisiko darstellen, weshalb Sie die Funktion über diesen Eintrag deaktivieren können.

Achtung:

Das kann dazu führen, dass Funktionen und Webseiten, die diese Funktion benötigen, nicht mehr funktionieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows Script Host\ Settings

ändern Sie hier den Wert "Enabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | WSH deaktivieren
1 | WSH aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2113.htm


Gelöschte Dateien überschreiben

Wenn Sie unter Windows Dateien löschen, können diese Dateien oft mit entsprechenden Tools wieder hergestellt werden. Wenn Sie das verhindern möchten, können Sie das mit dem Kommandozeilentool "cipher.exe" machen.

Schließen Sie vor der Ausführung des Befehles soviele Anwendung wie möglich, damit auch die meisten Einträge überschrieben werden können. Anschließend öffnen Sie die Eingabeaufforderung und geben Sie folgenden Befehl ein:

cipher /w:<Laufwerksbuchstabe>:

Ale <Laufwerksbuchstabe> gaben Sie das Laufwerk an, auf dem sich die Dateien befunden haben. Windows wird anschließend den gesamten freien Speicherbereich überschreiben.

Beispiel: "cipher /w:C:" um den freien Speicher auf Laufwerk C entsprechend zu überschreiben.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2384.htm


Sicherheitswarnung bei "Öffnen mit" festlegen

Versucht man eine Datei zu öffnen, die mit keiner Anwendung verbunden ist oder benutzt man das Kontextmenü (rechte Maustaste auf die Datei) -> "Öffnen mit", um diese Datei zu öffnen, prüft Windows, ob es für diese Dateiendung eine Sicherheitswarnung gibt und zeigt die entsprechend an:

Windows Standardmeldung:

Diese Dateien werden vom Betriebssystem und verschiedenen Programmen verwendet. Bearbeiten oder Verändern der Dateien kann möglicherweise das System beschädigen.

Klicken Sie auf "Öffnen mit", um die Datei trotzdem zu öffnen oder auf "Abbrechen", um den Vorgang abzubrechen.

Info Diese Meldung wird nur bei Dateien angezeigt die noch mit keiner Anwendung verbunden sind. So wird bei ".TXT" Dateien keine Meldung angezeigt, da dieser Dateityp standardmäßig einer Anwendung zugewiesen ist. Weiterhin darf nicht wie im Tipp "Allen unbekannten Dateitypen eine Anwendung zuweisen" beschrieben, unter "HKEY_CLASSES_ROOT\ Unknown\ shell \Open\ command" eine Anwendung eingetragen sein. Sie müssen den Schlüssel "HKEY_CLASSES_ROOT\ Unknown\ shell \Open\ command" dann löschen.

Bei welchem Dateitypen so eine Sicherheitswarnung angezeigt werden soll, kann in der Registry konfiguriert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\

1. Pfad für NoOpen suchen/festlegen

Suchen Sie die entsprechende Dateiendung heraus.

Gehen wir im folgenden Beispiel einmal von der Dateiendung ".ani" aus. Daraus ergibt sich dann der Registry-Pfad "HKEY_CLASSES_ROOT\.ani".

Dort sollte sich ein Eintrag (Standard) befinden. Ist hier aber als Wert nichts angegeben (Wert nicht gesetzt), dann können Sie den Eintrag "NoOpen" innerhalb dieses Schlüssels anlegen (siehe unten "2. Eintrag anlegen/löschen oder ändern").

Ist bei (Standard) ein Wert eingetragen, dann ist das ein Verweis auf den entsprechenden Kofigurationsknoten in der Registry. Für ".ani" steht hier "anifile".

Gehen Sie jetzt in den Konfigurationsknoten "HKEY_CLASSES_ROOT\[Knotenname]", was in unserem Beispiel also "KEY_CLASSES_ROOT\anifile" wäre und ändern Sie hier- wie unter "2. Eintrag anlegen/löschen oder ändern" angegeben - den Eintrag.

Gibt es ihre gesuchte Dateiendung nicht, legen Sie einfach einen neuen Schlüssel mit den Namen als Dateiendung unterhalb von "HKEY_CLASSES_ROOT\" an (der Eintrag muss mit einem Punkt (.) beginnen).

2. Eintrag NoOpen anlegen/löschen oder ändern

Wird bei dieser Dateiendung die Warnmeldung angezeigt, dann finden Sie hier einen Eintrag mit dem Namen "NoOpen" als Datentyp REG_SZ. Wenn die Warnmeldung nicht mehr gezeigt werden soll, müssen Sie den Eintrag einfach nur löschen.

Ist der Eintrag nicht vorhanden, dann wird keine Warnmeldung angezeigt. Durch das hinzufügen von "NoOpen", können Sie wieder eine Warnmeldung anzeigen lassen.

Wenn bei "NoOpen" als Wert nichts angegeben ist, dann wird die oben beschriebenen Windows Standardmeldung angezeigt. Sie können aber hier einen beliebigen Text angeben, der anstatt des Standardtextes angezeigt werden soll:

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2417.htm


Protokollieren der Autoregistrierung im PKI-System

Ein PKI-Server (public key infrastructure) ist ein Serversystem mit dem man Zertifikate ausstellen, verteilen und überprüfen kann. Die PKI-Zertifikate werden meist für Anwender oder Rechner ausgestellt und für das Sichern von Daten benötigt. Sie können auf einem Windows Server solch ein PKI-System einrichten.

Die meisten Überwachungskriterien lassen sich in der Zertifizierungsstelle aktivieren oder deaktivieren.

Durch die Zertifikatsdienste und deren Tools (z.B. Certificate Authority Monitor), wird eine Reihe von Protokollen erzeugt.

Diese Protokolle werden in den folgenden Verzeichnissen abgelegt:

  • Zertifikatsdienste: %SystemRoot%\certsrv.log (Debug-Protokollierung)
  • Certutil.exe:%SystemRoot%\certutil.log
  • CA-MMC: %windir%\certmmc.log

Die Debug-Protokollierung für die Zertifikatsdienste werden über den folgenden Befehl in der Kommandozeile aktiviert:

Aktivieren: certutil -setreg CA\Debug 0xffffffe3

Deaktiviren: certutil -delreg CA\Debug

Für die Aktivierung der Protokollierung von Autoregistrierungsereignissen muss in der Registry ein neuer Eintrag erzeugt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Cryptography\ Autoenrollment

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Cryptography\ Autoenrollment

Erstellen Sie hier einen neuen Wert mit dem Namen "AEEventLogLevel" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Protokollieren der Autoregistrierung
<löschen> | Nur Fehler werden Protokolliert (Standard)

Weitere Informationen zum Thema PKI:

  • Grundlagen der Kryptografie und der Infrastruktur öffentlicher Schlüssel
  • Optimale Methoden zum Implementieren einer Infrastruktur mit öffentlichem Schlüssel (PKI) unter Microsoft Windows Server 2003

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2475.htm


Verschlüsselung EFS deaktivieren

In diesem Tipp wird gezeigt, wie Sie die EFS-Verschlüsselung ganz oder teilweise deaktivieren können.

Ab Windows 2000 haben Sie die Möglichkeit, Verzeichnisse und Dateien mittels EFS (Encrypting File System) zu verschlüsseln. Wenn Sie aber verhindern wollen, dass die Verschlüsselung benutzt wird, können Sie die Funktion deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Efs

Erstellen Sie hier einen neuen Wert mit dem Namen "EfsConfiguration" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ver- und Entschlüsseln erlauben (Standard)
1 | Ver- und Entschlüsseln nicht möglich

Nach einem Neustart können Sie keine Dateien/Verzeichnisse mehr verschlüsseln. Auch vorab verschlüsselte Verzeichnisse können nicht mehr entschlüsselt werden.

Verschlüsselung pro Ordner abschalten

Sie können die Verschlüsselung auch nur für ein Verzeichnis, einen Ordner anschalten. Gehen Sie dafür folgendermaßen vor:

  • Erstellen Sie die Datei "Desktop.ini" in dem Verzeichnis, welches nicht mehr verschlüsselt werden soll (falls die Datei noch nicht vorhanden ist). Bei der "Desktop.ini" handelt es sich um eine Versteckte-Datei, so dass im Explorer die Einstellung "Alle Dateien und Ordner anzeigen" aktiv sein muss.
  • Öffnen Sie die Datei "Desktop.ini" mit Notepad
  • Fügen Sie am Ende der Datei folgende Zeile ein: [Encryption]
  • Fügen Sie dadrunter folgende, neue Zeile ein: Disable=1
  • Speichern Sie die Datei wieder ab

Jetzt können Sie in diesem Verzeichnis keine Datei mehr mit EFS-Verschlüsseln. Auf vorab verschlüsselte Dateien können Sie aber weiterhin zugreifen.

Siehe auch Tipp: Informationen über die Datei "Desktop.ini"

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2512.htm


Art der EFS-Verschlüsselung konfigurieren

Je nach aktueller Windows Version wird eine andere Art der Verschlüsselung verwendet. Wenn Sie auf die verschlüsselten Dateien aus unterschiedlichen Betriebssystemen zugreifen wollen, müssen Sie die Verschlüsselung so einstellen, dass sie von allen Betriebssystemen verstanden wird. Dabei ist DESX das älteste Verfahren und wird von allen Betriebssystemen unterstützt. Das neue AES (Advanced Encryption Standard) wird erst ab Windows XP mit Service Pack 1 unterstützt.

Damit alle Betriebssysteme auf die Dateien zugreifen können, gehen Sie folgendermaßen vor:

  1. Entschlüsseln Sie alle Dateien, die gemeinsam verwendet werden sollen
  2. Ändern Sie die Art der Verschlüsselung (siehe unten)
  3. Starten Sie den Rechner neu
  4. Verschlüsseln Sie die Dateien
  5. Exportieren Sie die Schlüssel und importieren Sie den Schlüssel auf den anderen Systemen (siehe Tipp: Sicherheitsschlüssel (EFS) exportieren/importieren)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVErsion\ EFS

Erstellen Sie hier einen neuen Wert mit dem Namen "AlgorithmID" als Datentyp REG_DWORD und setzen den Wert auf:

Wert (Hex) | Verschlüselung | Betriebssystem
6610 | AES 256-Bit | Ab Windows XP SP1
6603 | 3DES | Ab Windows XP
6604 | DESX | Windows 2000 und Windows XP

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2581.htm


Gruppenrichtlinieneditor und der Key 'Group Policy Objects' in der Registry

Gruppenrichtlinieneditor und der Key "Group Policy Objects" in der Registry

Wenn Sie den Gruppenrichtlinieneditor starten und damit eine lokale oder eine ADS-Policy bearbeiten, werden die Einstellungen vom Editor geladen und in der Registry unter: "HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Group Policy Objects\" abgelegt.

Hier finden Sie jetzt zwei Schlüssel:

"[UID ]Machine" und

"[UID] User"

Unterhalb dieser Schlüssel werden alle aktivierten Policy Key mit ihren Original Registrypfaden abgelegt.

Wenn Sie jetzt Änderungen durchführen, werden diese hier abgelegt und anschließend in der Policy gespeichert.

Wird der Gruppenrichtlinieneditor beenden, wird der Schlüssel "Group Policy Objects" wieder gelöscht. Ab und zu kann es vorkommen, dass die Einträge erhalten bleiben (wenn der Gruppenrichtlinieneditor abstürzt oder die Keys nicht gelöscht werden konnten). Sie können diese Schlüssel dann auch selber löschen, da diese Keys ansonsten als Registry-Leichen erhalten bleiben, da der Gruppenrichtlinieneditor bei nächsten Start die Einträge unter einer neuen UID dort ablegen wird.

Info Einige Internet-Seiten geben den Tipp, Einstellungen unterhalb von "Group Policy Objects" durchzuführen. Diese Information ist aber falsch, da diese Schlüssel von Windows nicht ausgewertet werden und nur für den Gruppenrichtlinieneditor vorhanden sind.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=828538

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2011.htm


Aktualisierungsintervall für Gruppenrichtlinien festlegen

Normalerweise werden die Gruppenrichtlinen für die Benutzer alle 90 Minuten aktualisiert, dabei kommt noch eine zufällige Verzögerung von 0-30 Minuten zum tragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier die neuen Werte mit dem Namen:

Wertname | Datentyp | Beschreibung
GroupPolicyRefreshTime | REG_DWORD | Gibt die Zeit an, wie oft die Gruppenrichtlinen aktualisiert werden. Bei einer Zahl 0 wird die Gruppenrichtline ca. alle 7 Sekunden erneuert, was eine hohe Belastung des Netzwerkes bedeuten würde.
GroupPolicyRefreshTimeOffset | REG_DWORD | Mit diesem Wert wird der Bereich für die Verzögerung festgelegt. Damit wird erreicht, dass nicht zu viele Clients gleichzeitig die Gruppenrichtlinen laden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1464.htm


Windows 2000/XP Clients sollen auch in einer NT 4.x Domäne/Workgroup eine Policy-Datei laden

Unter Windows 2000/XP Clients benutzen standardmäßig die Gruppenrichtlinen, welche über das Active Directory verteilt werden. Wenn Sie aber keine Windows 2000 Domäne besitzen, können Sie aber doch eine Policy (Systemrichtlinie) verteilen und müssen folgendermaßen vorgehen:

Erstellen Sie mit dem Programm Poledit.exe (finden Sie auf dem Windows 2000-Server) eine Policy-Datei und speichern die Datei unter einem beliebigen Namen ab (z.B. w2kpol.pol).

Legen Sie die Datei auf einem beliebigen Server in einem Verzeichnis ab, welches Sie freigeben haben (z.B. unter NETLOGON, dann brauchen Sie keine neue Freigabe einrichten).

Auf den entsprechenden Windows Clients müssen Sie nun noch in der Registry Eintragen, wo sie die Policy-Datei finden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Update

Erstellen Sie einen Wert mit dem Namen "NetworkPath" als Datentyp REG_SZ. Geben Sie hier den Pfad zur Policy-Datei an (z.B.: "\\<Servername>\<Freigabename>\W2kPol.POL")

Weitere Infos finden Sie dazu unter: Systemrichtlinien auf einen bestimmt Pfad legen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1106.htm


'Nur Richtlinien anzeigen' Standardmäßig bei den Gruppenrichtlinien einschalten

Wenn Sie diese Policy aktivieren, wird die Funktion "Nur Richtlinien anzeigen" im Gruppenrichtlinieneditor eingeschaltet. Dadurch werden keine "bevorzugten Einstellungen" mehr angezeigt.

Mit "bevorzugten Einstellungen" sind die gemeint, die nicht in den Schlüsseln "\Software\Policies\" und "\Software\Microsoft\Windows\CurrentVersion\Policies" abgelegt werden. Es werden also nur noch diese Schlüssel berücksichtigt, ansonsten werden auch Einstellungen unter anderen Schlüssel berücksichtigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Group Policy Editor

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowPoliciesOnly" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Nur "bevorzugte Einstellungen" anzeigen
0 | Alle anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Gruppenrichtlinie
Einstellungsname: | "Nur Richtlinien anzeigen" erzwingen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1458.htm


Aktualisieren der ADM-Dateien ausschalten

Bei Start der Gruppenrichtlinien werden standardmäßig die ADM-Dateien aus dem Verzeichnis %SYSTEMROOT%\inf geladen.

Wenn Sie diese Policy aktivieren werden nur die zuletzt benutzen ADM-Dateien geladen und Sie müssen selber die neuen Gruppenrichtlinien hinzufügen..

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Group Policy Editor

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAutoADMUpdate" als Datentyp REG_DWORD,. Setzen Sie den Wert auf:

1 | Keine Aktualisierung der ADM-Dateien
0 | Dateien werden aktualisiert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Gruppenrichtlinie
Einstellungsname: | Automatische Aktualisierung von ADM-Dateien deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1459.htm


Autorenmodus der Management Console (MMC) unterbinden

Mit diesem Tipp verhindern Sie den Autorenmodus in der MMC. Der Autorenmodus ermöglicht den Benutzer den vollständigen Zugriff auf die gesamt Funktionalität (Snap-Ins hinzufügen, Task erstellen usw.)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ MMC

Erstellen Sie hier einen neuen Wert mit dem Namen "RestrictAuthorMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Autorenmodus unterbinden
0 | Autorenmodus erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Microsoft Management Console
Einstellungsname: | Autorenmodus für Benutzer nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1637.htm


Snap-Ins für die Management Console (MMC) unterbinden

Mit diesem Tipp können Sie Snap-ins für die MMC verbieten. Es werden nur noch die Snap-Ins zugelassen, die über die Gruppen Policy freigegeben wurden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ MMC

Erstellen Sie hier einen neuen Wert mit dem Namen "RestrictToPermittedSnapins" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Snap-ins unterbinden
0 | Snap-ins sind erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Microsoft Management Console
Einstellungsname: | Benutzer auf die Verwendung von zugelassenen Snap-Ins beschränken

Info Wie Sie Snap-Ins freigeben finden Sie unter "Entsprechende Snap-Ins freigeben oder sperren"

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1638.htm


Entsprechende Snap-Ins freigeben oder sperren

Mit diesem Tipp können Sie die Verwendung des Snap-Ins erlauben oder sperren. Dabei hat noch der Tipp "Snap-Ins für die Management Console (MMC) unterbinden" Einfluss auf das Verhalten. Wenn Sie dort die Verwendung aller Snap-Ins sperren, können Sie hier entsprechende Snap-Ins wieder freischalten (sollten Sie nutzen, wenn nur wenige Snap-Ins freigegeben werden sollen). Wenn nur einige wenige Snap-Ins gesperrt werden sollen, sind die Snap-Ins über diesen Tipp entsprechend zu sperren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ MMC\ [Schlüsselname]\

Sie müssen für jedes Snap-In einen neuen Registryschlüssel anlegen.

Für [Schlüsselname] tragen Sie bitte die entsprechende UID aus der unteren Tabelle ein.

Erstellen Sie unterhalb dieses Schlüssels einen neuen Wert mit dem Namen "Restrict_Run" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Das Snap-In kann verwendet werden
0 | Das Snap-In ist nicht freigegeben

(Standard) -> Die Verwendung der Snap-Ins ist erlaubt, wenn nicht "Snap-Ins für die Management Console (MMC) unterbinden" aktiviert wurde.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Microsoft Managment Console\Eingeschränkte/Zugelassene Snap-Ins
Einstellungsname: | Siehe Tabelle-Snap-In Name

Unterhalb von: Eingeschränkte/Zugelassene Snap-Ins:

Snap-In Name | Schlüsselname
Active Directory-Benutzer und -Computer | {E355E538-1C2E-11D0-8C37-00C04FD8FE93}
Active Directory-Domänen und -Vertrauensstellungen | {EBC53A38-A23F-11D0-B09B-00C04FD8DCA6}
Active Directory-Standorte und -Dienste | {D967F824-9968-11D0-B936-00C04FD8D5B0}
ADSI-Bearbeitung | {1C5DACFA-16BA-11D2-81D0-0000F87A7AA3}
ActiveX-Steuerelement | {C96401CF-0E17-11D3-885B-00C04F72C717}
Zertifikate | {53D6AB1D-2488-11D1-A28C-00C04FB94F17}
Zertifizierungsstelle | {de751566-4cc6-11d1-8ca0-00c04fc297eb}
Zertifikatvorlagen | {A994E107-6854-4F3D-917C-E6F01670F6D3}
Drahtlosmonitor | {23DC5869-BD9F-46fd-AADD-1F869BA64FC3}
Komponentendienste | {C9BC92DF-5B9A-11D1-8F00-00C04FC2C17B}
Computerverwaltung | {58221C67-EA27-11CF-ADCF-00AA00A80033}
Geräte-Manager | {90087284-d6d6-11d0-8353-00a0c90640bf}
Datenträgerverwaltung | {8EAD3A12-B2C1-11d0-83AA-00A0C92C9D5D}
Datenträgerdefragmentierung | {43668E21-2636-11D1-A1CE-0080C88593A5}
Verteiltes Dateisystem (DFS) | {677A2D94-28D9-11D1-A95B-008048918FB1}
Ereignisanzeige | {975797FC-4E2A-11D0-B702-00C04FD8DBF7}
Faxdienst | {753EDB4D-2E1B-11D1-9064-00A0C90AB504}
FrontPage-Servererweiterungen | {FF5903A8-78D6-11D1-92F6-006097B01056}
Indexdienst | {95AD72F0-44CE-11D0-AE29-00AA004B9986}
.Net Framework-Konfiguration | {18BA7139-D98B-43c2-94DA-2604E34E175D}
Intertnetauthentifizierungsdienst (IAS) | {8F8F8DC0-5713-11D1-9551-0060B0576642}
Internetinformationsdienste | {A841B6C2-7577-11D0-BB1F-00A0C922E79C}
IP-Sicherheitsrichtlinienverwaltung | {DEA8AFA0-CC85-11d0-9CE2-0080C7221EBD}
IP-Sicherheitsmonitor | {57C596D0-9370-40C0-BA0D-AB491B63255D}
Link auf Webadresse | {C96401D1-0E17-11D3-885B-00C04F72C717}
Lokale Benutzer und Gruppen | {5D6179C8-17EC-11D1-9AA9-00C04FD8FE93}
Leistungsprotokolle und Warnungen | {7478EF61-8C46-11d1-8D99-00A0C913CAD4}
QoS-Zugangssteuerung | {FD57D297-4FD9-11D1-854E-00C04FC31FD3}
Remotedesktops | {3D5D035E-7721-4B83-A645-6C07A3D403B7}
Wechselmedienverwaltung | {3CB6973D-3E6F-11D0-95DB-00A024D77700}
Routing und RAS | {1AA7F839-C7F5-11D0-A376-00C04FC9DA04}
Sicherheitskonfiguration und -analyse | {011BE22D-E453-11D1-945A-00C04FB984F9}
Sicherheitsvorlagen | {5ADF5BF6-E452-11D1-945A-00C04FB984F9}
Dienste | {58221C66-EA27-11CF-ADCF-00AA00A80033}
Freigegebene Ordner | {58221C65-EA27-11CF-ADCF-00AA00A80033}
Systeminformationen | {45ac8c63-23e2-11d1-a696-00c04fd58bc3}
Telefonie | {E26D02A0-4C1F-11D1-9AA1-00C04FC3357A}
Terminaldienste Konfiguration | {B91B6008-32D2-11D2-9888-00A0C925F917}
WMI-Steuerung | {5C659257-E236-11D2-8899-00104B2AFB46}

Unterhalb von: Eingeschränkte/Zugelassene Snap-Ins\Erweiterungs-Snap-Ins:

Snap-In Name | Schlüsselname
AppleTalk-Routing | {1AA7F83C-C7F5-11D0-A376-00C04FC9DA04}
Autorisierungs-Manager | {1F5EEC01-1214-4D94-80C5-4BDCD2014DDD}
Zertifizierungsstellen-Richtlinieneinstellungen | {3F276EB4-70EE-11D1-8A0F-00C04FB93753}
Gemeinsame Verbindungsnutzung (NAT) | {C2FE450B-D6C2-11D0-A37B-00C04FC9DA04}
DCOM-Konfigurationserweiterung | {9EC88934-C774-11d1-87F4-00C04FC2C17B}
Geräte-Manager | {74246bfc-4c96-11d0-abef-0020af6b0b7a}
DHCP-Relayverwaltung | {C2FE4502-D6C2-11D0-A37B-00C04FC9DA04}
Ereignisanzeige | {394C052E-B830-11D0-9A86-00C04FD8DBF7}
Erweiterte Ansicht (Webansicht) | {B708457E-DB61-4C55-A92F-0D4B5E9B1224}
IAS-Protokollierung | {2E19B602-48EB-11d2-83CA-00104BCA42CF}
IGMP-Routing | {C2FE4508-D6C2-11D0-A37B-00C04FC9DA04}
IP-Routing | {C2FE4500-D6C2-11D0-A37B-00C04FC9DA04}
IPX RIP-Routing | {90810502-38F1-11D1-9345-00C04FC9DA04}
IPX-Routing | {90810500-38F1-11D1-9345-00C04FC9DA04}
IPX SAP-Routing | {90810504-38F1-11D1-9345-00C04FC9DA04}
Logische und zugeordnete Laufwerke | {6E8E0081-19CD-11D1-AD91-00AA00B8E05A}
OSPF-Routing | {C2FE4506-D6C2-11D0-A37B-00C04FC9DA04}
Richtlinien öffentlicher Schlüssel | {34AB8E82-C27E-11D1-A6C0-00C04FB94F17}
RSW-Einwahl -Benutzerkonten | {B52C1E50-1DD2-11D1-BC43-00C04FC31FD3}
RAS | {5880CD5C-8EC0-11d1-9570-0060B0576642}
Wechselmedien | {243E20B0-48ED-11D2-97DA-00A024D77700}
RIP-Routing | {C2FE4504-D6C2-11D0-A37B-00C04FC9DA04}
Routing | {DAB1A262-4FD7-11D1-842C-00C04FB6C218}
Erweiterung für freigegebene Ordner | {58221C69-EA27-11CF-ADCF-00AA00A80033}
Konsolenmeldung senden | {B1AFF7D0-0C49-11D1-BB12-00C04FC9A3A3}
Dienstabhängigkeiten | {BD95BA60-2E26-AAD1-AD99-00AA00B8E05A}
SMTP-Protokoll | {03f1f940-a0f2-11d0-bb77-00aa00a1eab7}
SMTP | {7AF60DD3-4979-11D1-8A6C-00C04FC33566}
Systemeigenschaften | {0F3621F1-23C6-11D1-AD97-00AA00B88E5A}

Unterhalb von: Eingeschränkte/Zugelassene Snap-Ins\Gruppenrichtlinien:

Snap-In Name | Schlüsselname
Gruppenrichtlinienverwaltung | {E12BBB5D-D59D-4E61-947A-301D25AE8C23}
Gruppenrichtlinienobjekt-Editor | {8FC0B734-A0E1-11D1-A7D3-0000F87571E3}
Registerkarte "Gruppenrichtlinien" für Active Directory-Programme | {D70A2BEA-A63E-11D1-A7D4-0000F87571E3}
Richtlinenergebnissatz-Snap-In | {6DC3804B-7212-458D-ADB0-9A07E2AE1FA2}

Unterhalb von: Eingeschränkte/Zugelassene Snap-Ins\Gruppenrichtlinien\Gruppenrichtlinien-Snap-In-Erweiterungen:

Snap-In Name | Schlüsselname
Administrative Vorlagen (Computer) | {0F6B957D-509E-11D1-A7CC-0000F87571E3}
Administrative Vorlagen (Benutzer) | {0F6B957E-509E-11D1-A7CC-0000F87571E3}
Ordnerumleitung | {88E729D6-BDC1-11D1-BD2A-00C04FB9603F}
Internet Explorer-Wartung | {FC715823-C5FB-11D1-9EEF-00A0C90347FF}
Remoteinstallationsdienste | {3060E8CE-7020-11D2-842D-00C04FA372D4}
Skripts (Anmelden/Abmelden) | {40B66650-4972-11D1-A7CA-0000F87571E3}
Skripts (Start/Herunterfahren) | {40B6664F-4972-11D1-A7CA-0000F87571E3}
Sicherheitseinstellungen | {803E14A0-B4FB-11D0-A0D0-00A0C90F574B}
Softwareinstallation (Computer) | {942A8E4F-A261-11D1-A760-00C04FB9603F}
Softwareinstallation (Benutzer) | {BACF5C8A-A3C7-11D1-A760-00C04FB9603F}
Richtlinien für Drahtlosnetzwerke (IEEE 802.11) | {2DA6AA7F-8C88-4194-A558-0D36E7FD3E64}

Unterhalb von: Eingeschränkte/Zugelassene Snap-Ins\Gruppenrichtlinien\Richtlinienergebnissatz-Snap-In-Erweiterungen:

Snap-In Name | Schlüsselname
Administrative Vorlagen (Computer) | {B6F9C8AE-EF3A-41C8-A911-37370C331DD4}
Administrative Vorlagen (Benutzer) | {B6F9C8AF-EF3A-41C8-A911-37370C331DD4}
Ordnerumleitung | {c40d66a0-e90c-46c6-aa3b-473e38c72bf2}
Internet Explorer-Wartung | {d524927d-6c08-46bf-86af-391534d779d3}
Skripts (Anmelden/Abmelden) | {40B66661-4972-11d1-A7CA-0000F87571E3}
Skripts (Start/Herunterfahren) | {40B66660-4972-11d1-A7CA-0000F87571E3}
Sicherheitseinstellungen | {fe883157-cebd-4570-b7a2-e4fe06abe626}
Softwareinstallation (Computer) | {7E45546F-6D52-4D10-B702-9C2E67232E62}
Softwareinstallation (Benutzer) | {1BC972D6-555C-4FF7-BE2C-C584021A0A6A}

Info Alle SnapIns sperren können Sie über "Snap-Ins für die Management Console (MMC) unterbinden"

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1900.htm


Gruppenrichtlinien sofort aktualisieren

Werden Gruppenrichtlinien geändert, möchte man unter gewissen Umständen, dass diese Richtlinien sofort aktualisiert werden. Wenn Sie möchten, dass der Client sich die aktuellen Gruppenrichtlinien holt, geben Sie folgende Befehle ein:

Windows 2000

Anwender/User:

secedit /refreshpolicy user_policy /enforce

Computer:

secedit /refreshpolicy machine_policy /enforce

Ab Windows XP

Anwender/User:

gpupdate /target:user /force /wait:0

Computer:

gpupdate /target:computer /force /wait:0

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1736.htm


Erweitertes Group Policy Log erstellen

Für die Fehlersuche für das anwenden von Group Policy kann ein LOG-File oft auch hilfreich sein. Damit ein ausführliches LOG erstellt wird, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon\ GPExtensions\ {827D319E-6EAC-11D2-A4EA-00C04F79F83A}

Erstellen Sie hier einen neuen Wert mit dem Namen "ExtensionDebugLevel" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

2

Erweitertes LOG wird erstellt

Jetzt aktualisieren sie die Gruppenrichtline entweder duch erneutes anmelden oder wie unter "Gruppenrichtlinien sofort aktualisieren" beschrieben. Anschließend finden Sie ein LOG-File im Verzeichnis "%SYSTEMROOT%\Security\Logs" mit den Namen "Winlogon.log"

Um bei der Anmeldung ein erweitertes Group Policy Log zu bekommen, können Sie auch noch folgenden Eintrag setzen:

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Legen Sie hier einen neuen Wert mit dem Namen "GPEditDebugLevel" als Datentyp REG_DWORD an. Setzen Sie den Wert:

Wert (Hex) | Beschreibung
0 | Log ausschalten
10001 | Log mit Standardausgabe (Standard)
10002 | Log mit erweiterter Ausgabe
20001 | Debugging Datei mit Standardausgabe
20002 | Debugging Datei mit erweiterter Ausgabe

Weiterhin setzen Sie den Wert für UserEnvDebugLevel auf 10002 (siehe dazu: USER Logfile für Fehlersuche aktivieren)

Nach einem Neustart finden Sie das Logfile unter: "%SYSTEMROOT%\Debug\UserMode\Gpedit.log"

Info Weitere Infos für ein Anmelde-Log-File finden Sie unter: USER Logfile für Fehlersuche aktivieren.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=324383

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1882.htm


Protokollierung im Gruppenrichtlinien-Editor

Mit diesem Tipp können Sie den Protokollierungsgrad der GPMC konfigurieren. Wenn Sie mit den Gruppenrichtlinien-Editor arbeiten und es zu Fehler kommt, können diese Logs entsprechend hilfreich sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Mit dem Wert "GPTextDebugLevel" als Datentyp REG_DWORD aktivieren Sie die Protokollierung aller Fehler, die beim Ladevorgang der ADM Templates im Gruppenrichtlinien Editor auftreten. Das LOG wird in die Datei "%windir%\Debug\UserMode\gptext.log" geschrieben.

65538 | Erweitertes LOG erstellen
0 | Kein erweitertes LOG erstellen

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Diagnostics

Mit dem Wert "GpMgmtTraceLevel" als Datentyp REG_DWORD aktivieren Sie die Protokollierung aller Meldungen die mit dem Gruppenrichtlinien Editor (GPMC) zusammenhängen. Das LOG wird in die Datei "%temp%\GpMgmt.log" geschrieben.

1 | Es werden nur Fehler protokolliert
2 | Es wird Alles protokolliert

Info Weitere Infos für ein LOG-File zur "Group Policy" finden Sie unter:
Erweitertes Group Policy Log erstellen
Erweiterte Log-Einträge für die Fehlersuche
USER Logfile für Fehlersuche aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2618.htm


Norton Utilities unterbinden Import von bestimmten REG-Dateien

Bei der Installation der Norton Utilities wird das Importieren alter Registry-Dateien (.REG) gesperrt. Wenn Sie so eine Datei anklicken, erscheint folgende Fehlermeldung:

Registrierungs-Editor

"[Laufwerk:\Ordner\Datei] kann nicht importiert werden: Die angegebene Datei ist keine Registry-Datei. Nur Registry-Dateien können importiert werden.

Damit Sie auch weiterhin alte REG-Dateien importieren können, müssen Sie diese Funktion in der Registry freischalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Symantec\ Norton Utilities\ Disable Intro Dialogs

setzen Sie den Wert "Norton Registry Editor" auf 0

Wenn Sie nur wenige alte REG-Dateien importieren möchten, können Sie auch einfach diese Dateien anpassen. Laden Sie dazu die REG-Datei mit einem Texteditor und ersetzen Sie die erste Zeile "Regedit4" durch "Windows Registry Editor Version 5.00" und speichern Sie die Datei ab. Jetzt werden auch diese Dateien wieder eingelesen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1057.htm


Registry defragmentieren und verkleinern

Auch unter Windows 2000 kann die Registry fragmentieren, indem durch gelöschte Einträge Lücken entstehen. Zudem kann die Datei noch "zerstückelt" auf der Festplatte schlummern, da der Standard-Defragmentierer die geöffnete Datei nicht defragmentieren kann. Aber auch unter Windows 2000 gibt es Lösungen für dieses Problem.

  1. Das Tool Pagedefrag von Sysinternals kann sowohl die Auslagerungsdatei als auch die Registry defragmentieren. Dies passiert nach einem Reboot noch vor dem Start der Windows-Oberfläche. Die Funktion ist in besseren Defragmentieren wie OODefrag direkt eingebaut.
  2. Um die Registry zu verkleinern, muss man sich mit einem Trick behelfen. Zunächst startet man das Backupprogramm von Windows 2000, wählt unter Extras "Notfalldiskette erstellen", markiert hier "Die Registrierung im Notfallverzeichnis sichern..." und legt keine Diskette ein. Das Backup schreibt dann die Systemdateien in das Verzeichnis %WINDIR%\repair\regback.

    Jetzt startet man Windows 2000 in der Notfallkonsole und kopiert mit

    copy %WINDIR%\repair\regback\UsrClass.dat %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\system %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\software %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\SAM %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\NTUSER.DAT %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\default %WINDIR%\system32\config
    copy %WINDIR%\repair\regback\SECURITY %WINDIR%\system32\config

    alle Dateien wieder zurück.

Info Siehe auch "Registry aufräumen mit RegClean".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1168.htm


Registry öffnet sich immer beim letzten bearbeitet Schlüssel

Windows speichert beim Beenden in der Registry ab, wo Sie als Letztes waren und öffnet den Registryeditor beim Starten wieder genau an der gleichen Stelle.

Leider gibt es keinen Schalte,r um das zu unterbinden, so dass der Registryeditor z.B. in der gleichen an Ansicht geöffnet wird.

Durch einen Trick können Sie das aber trotzdem bewerkstelligen, in dem Sie sich einfach das Recht entziehen, die aktuelle Einstellung in der Registry abspeichern zu dürfen, gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Regedit

Klicken Sie auf den Wert “LastKey” als Datentyp REG_SZ und geben hier nichts ein, wenn der Editor in der Standardansicht geöffnet werden soll, oder geben hier den gewünschten Key an.

Anschließend klicken Sie im Menü auf „Bearbeiten“ -> „Berechtigungen“. Entfernen Sie hier in Ihren Account die Berechtigung „Vollzugriff“ (es kann sein, dass Sie erst unter „Erweitert“ den Haken bei „Berechtigungen von… vererben..“ entfernen müssen. Die Frage, ob die aktuellen Berechtigungen kopiert werden sollen, bestätigen Sie).

Wenn Sie hier dann alle Berechtigungen zum Speichern entfernt haben, kann Windows nur noch lesend auf diesen Eintrag zugreifen und somit die aktuelle Einstellung des Registryeditors dort nicht mehr ablegen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1534.htm


Fehler unter Windows 2000, wenn der virtuelle Speicher ausgeht

Wenn Windows 2000 der virtuelle Arbeitsspeicher ausgeht, ist der CSP (Cryptographic Service Provider) nicht mehr in der Lage, die GUID (Globally Unique Identifiers) aus der Registry zu lesen. Windows 2000 erstellt nun einfach eine neue GUID und überschreibt damit den alten Eintrag in der Registry.

Das hat aber verheerende Folgen. Da die neue GUID im Netzwerk nicht bekannt ist, wird der Rechner nicht mehr erkannt. Auch können Dienste nicht mehr gestartet und gestoppt werden.

Dieser Fehler soll lt. MS im Service Pack 1 behoben werden. Um sich bis dahin vor diesem Fehler zu schützen, sollten Sie folgendes machen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

1. Holen Sie sich aus der Registry die aktuelle GUID ihres Rechners, die finden Sie unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Cryptography

im Eintrag "MachineGuid".

2. Erstellen Sie folgende REG-Datei und tragen Sie hier Ihrer eigene GUID ein:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography]

"MachineGuid"="Ihre Nummer"

Wenn der Fehler auftritt, brauchen Sie die REG-Datei nur aufzurufen und den Rechner neu zu starten, damit wieder alles funktioniert.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0502.htm


Einstellungen der RamDisk verändern

Wenn Sie unter Windows die RamDisk installieren, wird die Größe auf 1 Mbyte beschränkt und der Buchstabe wird fest auf Laufwerk Z festgelegt, Mit diesem Werten können Sie die Einstellungen verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Ramdisk\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "DriveLetter" als Datentyp REG_SZ. Setzen Sie den Wert auf:

A-Z

Laufwerksbuchstabe, die möglichen Werte liegen zwischen A-Z und müssen mit einem Doppelpunkt am Ende eingegeben werden. ( z.B.: R:)

Erstellen Sie hier einen neuen Wert mit dem Namen "DiskSize" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0-32505856

Größe der RamDisk in Byte. Bei 0 wird die RamDisk ausgeschaltet.

Erstellen Sie hier einen neuen Wert mit dem Namen "RootDirEntries" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0-32505856

Größe der RamDisk in Byte. Bei 0 wird die RamDisk ausgeschaltet.

Info Weitere Infos finden Sie unter: "Ramdisk für Windows 2000/XP"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1456.htm


IOMEGA Parallel Port ZIP-Laufwerk wird nicht erkannt

Wird das ZIP-Laufwerk unter Windows nicht erkannt, ist höchstwahrscheinlich "Legacyerkennung für Plug und Play aktivieren" nicht aktiviert. Um das einzuschalten gehen Sie unter:

"System" -> "Hardware" -> "Geräte-Manager" -> "Anschlüsse (COM und LPT)" -> "ECP-Druckeranschluss (LPT1)" -> "Eigenschaften" -> "Anschlusseinstellungen" und kreuzen "Legacyerkennung für Plug und Play aktivieren" an

Sie können diese Funktion auch in der Registry aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Parallel\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "ParEnableLegacyZip" als Datentyp REG_DWORD. Setzen Sie den Eintrag auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0521.htm


Beim Kopieren von Dateien werden neue kurze Dateinamen erzeugt

Wenn Sie Dateien mit langen Dateinamen, die unter Windows 95/98 erzeugt wurden, nach Windows 2000 kopieren, kann es vorkommen, dass sich der kurze Dateiname verändert. Wenn Sie aber Software verwenden, die mit den kurzen Dateinamen arbeitet, kann das zu Problemen führen.

Der Grund liegt darin, dass Windows 95/98 einen anderen Algorithmus verwendet als Windows 2000, um kurze Dateinamen zu erstellen. Windows 95/98 verwenden die ersten sechs Zeichen und hängen dann eine Tilde mit einer fortlaufenden Nummer an. Bei Windows 2000 werden nur die ersten fünf Buchstaben des Dateinamens verwendet und dann wird eine Tilde (~) mit einer fortlaufenden Nummer angehängt. Weiterhin werden ab der fünften Datei nur noch die ersten zwei Buchstaben des Dateinamens und für die nächsten drei Buchstaben beliebige Zeichen aus dem langen Dateinamen verwendet.

Da sich die kurzen Dateinamen bei diesem Verfahren fast bei jedem Kopieren verändern können, sollten Sie also, wenn Sie die kurzen Dateinamen benötigen, auch nur mit kurzen Dateinamen arbeiten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0994.htm


Suchreihenfolge für DLL festlegen

Mit diesem Tipp können Sie einstellen, wie Windows nach DLL’s suchen soll. Die Einstellung kann wichtig sein, wenn bestimmte Programme nicht laufen, da es unterschiedliche DLL-Versionen gibt. So können Sie die DLL’s im Programmverzeichnis ablegen und dadurch unterschiedliche DLL-Versionen benutzen.

Bei Windows 2000 muss mindestens SP3 installiert sein!

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager

Erstellen Sie hier einen neuen Wert mit dem Namen "SafeDllSearchMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Erst im aktuellen Verzeichnis suchen
1 | Erst im Windows/Systemverzeichnis suchen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1604.htm


Den Eintrag 'Dateien anzeigen' unter Offlinedateien deaktivieren

Wenn Sie diese Funktion aktivieren, wird die Option "Dateien anzeigen" aus der Registrierkarte Offlinedateien deaktiviert.

Folgendermaßen können Benutzer den Ordner "Offlinedateien" nicht anzeigen oder Kopien von lokal gespeicherten Netzwerkdateien öffnen. Außerdem können Benutzer den Ordner nicht verwenden, um Eigenschaften von Offlinedateien, wie z. B. deren Serverstatus, Typ oder Pfad, anzuzeigen.

Diese Einstellung verhindert nicht, dass Benutzer offline arbeiten oder lokale Kopien von offline verfügbaren Dateien speichern. Die Einstellung verhindert auch nicht, dass Benutzer andere Programme, wie z. B. Windows Explorer, verwenden, um Offlinedateien anzuzeigen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCacheViewer" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Verwendung von Offlinedateiordnern verhindern

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1448.htm


Den Eintrag 'Erinnerungen aktivieren' unter Offlinedateien deaktivieren

Durch diesen Tipp legen Sie fest ob die Erinnerungssymbole ein- oder ausgeschaltet sein sollen.

Erinnerungssymbole werden oberhalb des Offlinedateisymbols im Infobereich angezeigt, um Benutzer zu benachrichtigen, dass die Verbindung zu einer Netzwerkdatei getrennt wurde und dass die lokale Kopie der Datei bearbeitet wird. Somit können Benutzer entscheiden, wie sie fortsetzen möchten.

Durch Aktivieren dieser Einstellung werden die Erinnerungssymbole ausgeblendet und verhindert, dass Benutzer sie anzeigen. Weiterhin wird die Einstellung "Erinnerungen aktivieren" auf der Registrierkarte Offlinedateien deaktiviert.

Ist diese Einstellung nicht aktiv, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und wählen dann die Option "Erinnerungen aktivieren".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "NoReminders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Erinnerungssymbole deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1447.htm


Eintrag 'Offline verfügbar machen' aus den Kontextmenüs deaktivieren

Mit diesem Tipp können Sie einstellen, ob Benutzer Netzwerkdateien und -ordner offline verfügbar machen können.

Diese Einstellung entfernt die Option "Offline verfügbar machen" aus dem Menü "Datei" und aus allen Kontextmenüs in Windows Explorer. Folgendermaßen können Benutzer keine Dateien auswählen, die auf ihrem Computer für die Offlineverwendung gespeichert werden sollen.

Allerdings verhindert diese Einstellung nicht, dass lokale Kopien der Dateien auf Netzwerkfreigaben, die automatisch zwischengespeichert werden, gespeichert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "NoMakeAvailableOffline" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | "Offline verfügbar machen" entfernen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1445.htm


Unter den Ordneroptionen den Eintrag 'Offlinedateien' entfernen

Mit diesem Tipp können Sie verhindern, dass Benutzer die Konfiguration von Offlinedateien aktivieren, deaktivieren oder ändern.

Durch diese Einstellung wird die Registerkarte "Offlinedateien" aus den Ordneroptionen entfernt. Außerdem wird der Menüeintrag "Einstellungen" aus dem Kontextmenü der Offlinedateien entfernt und die Schaltfläche "Einstellungen" im Dialogfeld "Offlinedateistatus" deaktiviert. Folgendermaßen können Benutzer die Optionen auf der Registerkarte "Offlinedateien" oder im Dialogfeld "Offlinedateien" nicht anzeigen oder ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "NoConfigCache" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird entfernt
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Benutzerkonfiguration von Offlinedateien nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1444.htm


Vor dem Ruhezustand die Offlinedateien synchronisieren

Wenn Sie diesen Tipp aktivieren, werden die Offlinedateien synchronisiert bevor der Rechner in den Ruhezustand geht. Hier können Sie zwischen zwei Arten auswählen:

- Schnelle Synchronisation:

Es wird nur sichergestellt, dass die Daten im Cache vollständig sind.

- Vollständige Synchronisation:

Stellt sicher das alle zwischengespeicherten Dateien und Ordner auf den neusten Stand sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "SyncAtSuspend" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Schnelle Synchronisation
1 | Vollständige Synchronisation

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Offlinedateien vor der Unterbrechung synchronisieren

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1443.htm


Logmodus des Offlinespeichers einstellen

Mit diesem Tipp legen Sie fest, welche Ereignisse die Funktion "Offlinedateien" im Ereignisprotokoll protokolliert.

Die Funktion "Offlinedateien" protokolliert Ereignisse im Anwendungsprotokoll in der Ereignisanzeige, wenn Fehler ermittelt werden. Standardmäßig wird ein Ereignis nur dann protokolliert, wenn der Cache des Offlinedateispeichers beschädigt ist. Sie können jedoch mit dieser Einstellung zusätzliche Ereignisse, die protokolliert werden sollen, angeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "EventLoggingLevel" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | protokolliert einen Fehler wenn der Offlinespeichercache beschädigt ist.
1 | Protokolliert zusätzlich, wenn der Server, der die Datei zur Verfügung stellt, nicht erreichbar ist.
2 | Protokolliert zusätzlich, das trennen und wieder herstellen der Netzwerkverbindung des Clients.
3 | Protokolliert zusätzlich, wenn der Server, der die Datei zur Verfügung stellt, wieder zu erreichen ist.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Ereignisprotollierungsstufe

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1442.htm


Eintrag 'Erinnerungssymbol alle x Minuten anzeigen' unter Offlinedateien deaktivieren

Durch diesen Tipp legen Sie denn Intervall für die Aktualisierung des Erinnerungssymbols fest.

Erinnerungssymbole werden angezeigt, wenn die Verbindung mit einer Netzwerkdatei getrennt oder neu hergestellt wird und werden regelmäßig aktualisiert. Standardmäßig wird das erste Erinnerungssymbol eines Ereignisses 30 Sekunden lang angezeigt. Danach werden Aktualisierungen alle 60 Minuten für 15 Sekunden angezeigt. Sie können diese Einstellung verwenden, um das Aktualisierungsintervall zu ändern.

Weiterhin wird die Einstellung "Erinnerungssymbol alle x Minuten anzeigen" auf der Registrierkarte Offlinedateien deaktiviert.

Ist diese Einstellung nicht aktiv, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und wählen dann die Option "Erinnerungssymbol alle ... Minuten anzeigen".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "ReminderFreqMinutes" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

Min | Max | in
0 | 1440 | Minuten (Dezimal)

Der Standardwert liegt bei 60 Minuten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Erinnerungssymbolfrequenz

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1446.htm


Festlegen wie Netzwerkdateien behandelt werden ohne Netzwerkanbindung

Mit diesem Tipp legen Sie fest, ob Netzwerkdateien weiterhin verfügbar sind, wenn die Verbindung des Computers mit dem Server, der die Dateien zur Verfügung stellt, getrennt wird.

Folgende Einstellungen werden vorgenommen:

Tipp ist aktiv:

Ist der Server nicht verfügbar, kann nicht mit den Dateien gearbeitet werden.

Tipp ist deaktiv:

Es können lokale Kopien der Netzwerkdateien verwendet werden, wenn Serverzugriff nicht möglich ist.

Weiterhin wird durch diese Einstellung zusätzlich die Option "Bei unterbrochener Netzwerkverbindung" auf der Registerkarte "Offlinedateien" deaktiviert.

Ist diese Einstellung nicht vorhanden, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und wählen dann die Option "Bei unterbrochener Netzwerkverbindung".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Standardeinstellung für alle Server

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "GoOfflineAction" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Offline arbeiten wird unterbunden
0 | Offline arbeiten ist erlaubt (es wird mit der lokalen Kopie weitergearbeitet) (Standard)

Einstellungen für angegebene Server

Diese Einstellung setzt die Standardreaktion, benutzerdefinierte Reaktionen und die oben angegeben Einstellungen (Standardeinstellung für alle Server) außer Kraft.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache\ CustomGoOfflineActions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache\ CustomGoOfflineActions

Erstellen Sie hier einen neuen Wert mit dem Namen des Servers als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Offline arbeiten wird unterbunden
0 | Offline arbeiten ist erlaubt (es wird mit der lokalen Kopie weitergearbeitet) (Standard)

Für jeden Server legen Sie hier einen entsprechenden Eintrag an.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Standardeinstellung für alle Server: Maßnahme bei Serververbindungstrennung Einstellungen für angegebene Server: Maßnahme bei nicht standardmäßiger Serververbindungstrennung

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1449.htm


Offlinedateien beim Abmelden synchronisieren

Mit diesem Tipp können Sie einstellen, ob die Offlinedateien beim Abmelden automatisch synchronisiert werden sollen.

Durch Aktivieren dieser Einstellung werden Offlinedateien vollständig synchronisiert.

Durch Deaktivieren dieser Einstellung wird nur eine schnelle Synchronisation durchgeführt. Somit sind die Dateien vollständig, aber haben nicht unbedingt die neueste Version.

Weiterhin wird die Option "Alle Offlinedateien vor der Abmeldung synchronisieren" zur Einstellung in der Registerkarte "Offlinedateien" wird deaktiviert.

Wenn Sie diese Einstellung nicht konfigurieren, wird standardmäßig eine schnelle Synchronisation durchgeführt, aber Benutzer können diese Option ändern.

Ist diese Einstellung nicht aktiv, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und wählen dann die Option "Alle Offlinedateien vor der Abmeldung synchronisieren".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "SyncAtLogoff" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

1 | Oflinedateien werden synchronisiert beim Abmelden
0 | Oflinedateien werden nicht synchronisiert beim Abmelden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Alle Offlinedateien vor der Abmeldung synchronisieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1450.htm


Offlinedateien beim Anmelden synchronisieren

Mit diesem Tipp können Sie einstellen, ob die Offlinedateien beim Anmelden automatisch synchronisiert werden sollen.

Wenn Sie diese Einstellung aktivieren, werden Offlinedateien beim Anmelden vollständig synchronisiert. Die vollständige Synchronisation stellt sicher, dass Offlinedateien vollständig und aktuell sind. Durch Aktivierung dieser Einstellung wird automatisch die Anmeldesynchronisation in der Synchronisationsverwaltung aktiviert.

Wenn diese Einstellung deaktiviert wird und die Synchronisationsverwaltung auf Anmeldesynchronisation konfiguriert wird, führt das System nur eine Schnellsynchronisation aus. Die Schnellsynchronisation stellt sicher, dass Dateien vollständig sind, stellt jedoch nicht sicher, dass sie aktuell sind.

Weiterhin wird die Option "Alle Offlinedateien beim Anmelden synchronisieren" zur Einstellung in der Registerkarte "Offlinedateien" deaktiviert.

Wenn Sie diese Einstellung nicht konfigurieren, wird standardmäßig eine schnelle Synchronisation durchgeführt, aber Benutzer können diese Option ändern.

Ist diese Einstellung nicht aktiv, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und wählen dann die Option "Alle Offlinedateien beim Anmelden synchronisieren".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "SyncAtLogon" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Oflinedateien werden synchronisiert beim Abmelden
0 | Oflinedateien werden nicht synchronisiert beim Abmelden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Alle Offlinedateien beim Anmelden synchronisieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1451.htm


Die Funktion 'Offlinedateien' ein-/ausschalten

Mit diesem Tipp legen Sie die Funktionalität der "Offlinedateien" fest.

Durch die Funktion "Offlinedateien" wird eine Kopie von Netzwerkdateien auf dem Computer des Benutzers gespeichert, so dass die Datei für Benutzer verfügbar ist, wenn der Computer nicht mit dem Netzwerk verbunden ist.

Durch Aktivieren dieser Einstellung wird die Option "Offlinedateien" aktiviert, und Benutzer können sie auch nicht mehr deaktivieren. Durch Deaktivieren dieser Einstellung wird die Option "Offlinedateien" deaktiviert, und Benutzer können sie auch nicht wieder aktivieren.

Durch diese Einstellung wird die Option "Offlinedateien" auf der Registerkarte "Offlinedateien" deaktiviert.

Standardmäßig ist diese Option unter Windows 2000 Professional/ XP Professional aktiviert, unter Windows 2000 Server und Windows Server 2003-Produktfamilie aber deaktiviert.

Sie können Offlinedateien aktivieren ohne eine Einstellung zu verwenden, indem Sie in Windows Explorer auf das Menü "Extras" und den Menüeintrag "Ordneroptionen" klicken und auf der Registerkarte "Offlinedateien" auf die Option "Offlinedateien aktivieren" klicken.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "Enabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Offlinedateien ist aktiv
0 | Offlinedateien ist deaktiv

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Die Funktion "Offlinedateien" zulassen bzw. nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1962.htm


Maximalen Festplattenspeicher für Offlinezwischenspeicher festlegen

Mit diesem Tipp können Sie einstellen, wie viel Festplattenspeicher in Prozent die Benutzer zum Speichern von automatisch zwischengespeicherten Offlinedateien verwenden können.

Automatisches Zwischenspeichern kann auf allen Netzwerkfreigaben festgelegt werden. Wenn ein Benutzer eine Datei auf einer Freigabe öffnet, wird eine Kopie der Datei automatisch auf dem Computer des Benutzers gespeichert. Diese Einstellung schränkt nicht den verfügbaren Speicherplatz für Dateien ein, die Benutzer manuell offline verfügbar machen.

Außerdem wird durch diese Einstellung die Option "Zu verwendender Speicherplatz für temporäre Offlinedateien" auf der Registerkarte "Offlinedateien" deaktiviert.

Ist diese Einstellung nicht aktiv, können Sie die Konfiguration unter dem folgenden Eintrag ändern:

Klicken Sie in Windows Explorer im Menü "Extras" auf "Ordneroptionen", klicken auf die Registerkarte "Offlinedateien" und den Schieberegler unter der Option "Zu verwendender Speicherplatz für temporäre Offlinedateien" verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "DefCacheSize" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0-10000

Wert in Prozent der Platte * 10.000, der benutzt werden darf. {Für 12,55% geben Sie also den Wert 1255 ein.}

Standardmäßig wird der Speicherplatz für automatisch zwischengespeicherte Dateien auf 10% des Speicherplatzes des Systemlaufwerks eingeschränkt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Standardzwischenspeichergröße

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1964.htm


Dateitypen festlegen, die nicht offline verwendet werden können

Mit diesem Tipp können Sie festlegen, welche Dateitypen nicht offline verwendet werden können.

Diese Einstellung ermöglicht es, bestimmte Dateitypen vom automatischen und manuellen Zwischenspeichern auszuschließen. Dateien, die in dieser Einstellung aufgeführt werden, werden nicht zwischengespeichert, auch dann nicht, wenn sie auf einer Netzwerkfreigabe für die automatische Zwischenspeicherung konfiguriert wurden. Falls ein Benutzer versucht, eine von diesen Dateien für die Offlineverwendung zur Verfügung zu stellen, wird die Meldung, "Dateien diesen Typs können nicht offline verfügbar gemacht werden", in der Synchronisationsverwaltung angezeigt.

Diese Einstellung wurde entwickelt, um Dateien zu schützen, die nicht geteilt werden dürfen, wie z. B. Datenbankkomponenten.

Die folgenden Dateiendungen sind Standardmäßig schon ausgeschlossen:

Dateiendung | Beschreibung
.SLM | Microsoft Source Libary Datei
.MDB | Microsoft Access Datenbank
.LDB | Microsoft Access Security Datei
.MDW | Microsoft Access Workgroup Datei
.MDE | Microsoft Access compildes Modul Datei
.PST | Microsoft Outlook Datei
.DB? | Datenbank Datei

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "ExcludeExtensions" als Datentyp REG_SZ und geben Sie die entsprechenden Dateiendungen mit *.[Dateiendung] an. Trennen Sie die Dateierweiterungen mit einem Semikolon (;), falls Sie mehrere Erweiterungen angeben möchten.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Nicht zwischengespeicherte Dateien

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1965.htm


Dateien und Ordner für die Offlineverwendung festlegen

Mit diesem Tipp legen Sie fest, welche Dateien bzw. Ordner für die Offlineverwendung immer freigegeben werden sollen.

Wenn Sie diese Richtlinie aktivieren, werden die angegebenen Dateien den Benutzern des Computers immer offline zur Verfügung stehen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache\ AssignedOfflineFolders

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache\ AssignedOfflineFolders

Erstellen Sie hier einen neuen Wert mit dem Namen des vollständigen gültigen UNC-Pfad für die Datei bzw. den Ordner als Datentyp REG_SZ an.

Lassen Sie das Feld "Wert" leer.

Beispiel:

Name | Typ | Wert
\\Servername\Freigabe\Ordnername | REG_SZ |

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Vom Administrator zugewiesene Offlinedateien

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1967.htm


Dateien und Ordner für die Offlineverwendung sperren

Mit diesem Tipp legen Sie fest, welche Dateien bzw. Ordner die für die Offlineverwendung gesperrt werden sollen.

Wenn Sie diese Richtlinieneinstellung aktivieren, wird die Option "Offline verfügbar machen" für die von Ihnen aufgeführten Dateien und Ordner entfernt.

Diese Einstellung verhindert nicht, dass Dateien automatisch zwischengespeichert werden, wenn die Netzwerkfreigabe auf "Automatisches Zwischenspeichern" konfiguriert ist. Sie beeinflusst nur die Verfügbarkeit der Menüoption "Offline verfügbar machen" in der Benutzerschnittstelle.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache\ AssignedOfflineFolders

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache\ AssignedOfflineFolders

Erstellen Sie hier einen neuen Wert mit dem Namen des vollständigen gültigen UNC-Pfad für die Datei bzw. den Ordner als Datentyp REG_SZ an.

Lassen Sie das Feld "Wert" leer.

Beispiel:

Name | Typ | Wert
\\Servername\Freigabe\Ordnername | REG_SZ |

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | "Offline zur Verfügung stellen" für diese Dateien und Ordnern nicht zulassen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1968.htm


Offlinedateicache verschlüsseln

Mit diesem Tipp können Sie einstellen, ob Offlinedateien verschlüsselt werden.

Offlinedateien befinden sich auf der Festplatte eines Benutzers und nicht auf dem Netzwerk, und sie werden in einem lokalen Cache des Computers gespeichert. Durch Verschlüsselung der Daten dieses Cachespeichers wird die Sicherheit auf einem lokalen Computer erhöht. Wenn die Daten des Cachespeichers auf dem lokalen Computer nicht verschlüsselt werden, werden alle vom Netzwerk zwischengespeicherten, verschlüsselten Dateien auf dem lokalen Computer nicht verschlüsselt. Dies kann in einigen Umgebungen ein Sicherheitsrisiko darstellen.

Wenn Sie diese Einstellung aktivieren, werden alle Dateien im Offlinedateicache verschlüsselt. Dies gilt für vorhandene Dateien, sowie für später hinzugefügte Dateien. Die zwischengespeicherte Kopie auf dem lokalen Computer wird beeinflusst, die zugehörige Kopie im Netzwerk nicht. Der Benutzer kann Offlinedateien nicht über die Benutzerschnittstelle entschlüsseln.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "EncryptCache" als Datentyp REG_DWORD.

Setzen Sie den Wert zwischen:

1 | Oflinedateien werden verschlüsselt gespeichert
0 | Oflinedateien werden nicht verschlüsselt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Offlinedateicache verschlüsseln

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1971.htm


Datenträgerkontingentverwaltung aktivieren/deaktivieren

Standardmäßig ist die Datenträgerkontigentverwaltung (Diskquota) für NTFS-Laufwerk ausgeschaltet und kann nur vom Administrator aktiviert und konfiguriert werden.

Die Datenträgerkontingentverwaltung finden Sie im Explorer, indem Sie auf einem NTFS-Laufwerk im Kontextmenü (rechte Maustaste auf das Laufwerk) 'Eigenschaften' auswählen. Hier gibt es bei allen - mit NTFS-formatierten Laufwerken - einen Tabreiter "Kontingent".

Mit dieser Konfiguration können Sie festlegen, wie viel Speicherplatz allgemein oder über den Button "Kontingenteinträge..." von einzelnen Benutzerkonten auf diesen Datenträger belegt werden dürfen. Damit können Sie z.B. sicherstellen, dass nicht der gesamte Festplattenspeicher von nur einem Anwender belegt wird.

Mit diesem Tipp aktivieren /deaktivieren Sie die Datenträgerkontingentverwaltung auf allen NTFS-Datenträger des Computers und verhindern, dass Anwender die Einstellung verändern können. Der Tipp konfiguriert in der Datenträgerkontingentverwaltung die Einstellung "Kontingentverwaltung aktivieren"

Wenn Sie den Tipp aktivieren, wird die Kontingentverwaltung aktiviert und kann von den Anwender nicht mehr deaktiviert werden. Wenn Sie den Tipp deaktivieren, dann wird die Kontingentverwaltung deaktiviert und kann vom Anwender nicht aktiviert werden. Wenn der Eintrag nicht vorhanden ist (Standard), kann die Kontingentverwaltung über die oben beschriebene Konfiguration von Anwender eingestellt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Erstellen Sie hier einen neuen Wert mit dem Namen "Enable" als Datentyp REG_DWORD und setzen den Wert auf:

nicht vorhanden | Anwender kann Einstellung konfigurieren
0 | Kontingentverwaltung deaktiviert (nicht änderbar)
1 | Kontingentverwaltung aktiviert (nicht änderbar)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Datenträgerkontingente ermöglichen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2466.htm


Bei erreichen der Speichergrenze von Datenträgerkontingenten speichern unterbinden

Bei Erreichen der Speichergrenze von Datenträgerkontingenten das Speichern unterbinden

Mit diesem Tipp konfigurieren Sie, ob beim Erreichen der Speichergrenze eines Datenträgerkontingent das Speichern unterbunden werden soll. Der Tipp konfiguriert in der Datenträgerkontingentverwaltung die Einstellung "Speicherplatz bei Kontingentüberschreitung verweigern".

Wenn Sie den Tipp aktivieren, kann der Anwender die festgelegten Speichergrenzen nicht mehr überschreiten. Versucht dieser eine Datei nach Erreichen der Speichergrenze zu speichern, verhält sich der Datenträger so, also ob kein Speicherplatz mehr auf den Datenträger vorhanden ist und verweigert das Abspeichern der Datei.

Info Bedenken Sie dabei, dass der Anwender geänderte Dateien gegebenenfalls nicht mehr abspeichern kann, wenn er nicht auf einen anderen Datenträger ausweichen kann und dadurch diese Änderungen verloren gehen.

Wird der Tipp nicht aktiviert, kann die Datenträgerkontingentsgrenze überschritten und die Daten gespeichert werden . Beim Erreichen der Grenze ändert sich nur der Status im Kontingentfenster, aber Benutzer können weiterhin auf den Datenträger schreiben, solange der physikalische Festplattenspeicher nicht voll ist.

Wenn Sie diesen Einstellung konfigurieren, kann die Konfiguration nicht mehr innerhalb der Datenträgerkontingentverwaltung konfiguriert werden. (siehe dazu auch Tipp: "Datenträgerkontingentverwaltung aktivieren/deaktivieren").

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Erstellen Sie hier einen neuen Wert mit dem Namen "Enforce" als Datentyp REG_DWORD und setzen den Wert auf:

nicht vorhanden | Anwender kann Einstellung konfigurieren
0 | Datenträgerkontingentsgrenze kann überschritten werden
1 | Datenträgerkontingentsgrenze kann nicht überschritten werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Datenträgerkontingentsgrenze erzwingen

Info Verwenden Sie die den Tipp "Standarddatenträgerkontingentgrenzen und Warnstufen konfigurieren", um das Datenträgerkontingent einzuschränken. Ansonsten wird der physikalische Platz auf dem Datenträger als Kontingentsgrenze verwendet.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2467.htm


Standarddatenträger-Kontingentgrenzen und Warnstufen konfigurieren

Mit diesem Tipp konfigurieren Sie die Standarddatenträger-Kontingentsgrenze und die Warnstufe für neue Benutzer eines Datenträgers. Der Tipp konfiguriert in der Datenträgerkontingentverwaltung die Einstellung "Speicherplatz beschränken auf" (siehe dazu auch Tipp: "Datenträgerkontingentverwaltung aktivieren/deaktivieren").

Diese Einstellung bestimmt, wie viel Festplattenspeicher jeder Benutzer auf jedem NTFS-Datenträger auf einem Computer verwenden darf. Zusätzlich wird die Warnstufe festgelegt, so dass Benutzer vor der Überschreitung der Datenträger-Kontingentsgrenze (wenn sich der Status im Kontingenteintragsfenster ändert) gewarnt werden.

Die Einstellung hat keinen Einfluss auf den verfügbaren Festplattenspeicher der aktuellen Benutzer oder beeinflusst benutzerdefinierte Grenzen und Warnstufen, die für bestimmte Benutzer (auf der Registerkarte "Kontingent" in den Datenträgereigenschaften) festgelegt wurden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Größenbeschränkung

Erstellen Sie hier einen neuen Wert mit dem Namen "Limit" als Datentyp REG_DWORD. Geben Sie als Dezimalwert den maximalen Speicherplatz ein. Die gültigen Werte liegen zwischen 0 und 1000.

Über den zweiten Wert mit dem Namen "LimitUnits" als Datentyp REG_DWORD legen Sie die Einheit (Megabyte usw.) fest. Mögliche Werte und deren Bedeutung sind weiter unten aufgelistet.

Warnstufe

Erstellen Sie hier einen neuen Wert mit dem Namen "Threshold" als Datentyp REG_DWORD, und geben Sie als Dezimalwert die Speichergröße ein, ab der eine Warnmeldung ausgegeben werden soll. Die gültigen Werte liegen zwischen 0 und 1000.

Über den zweiten Wert mit dem Namen "ThresholdUnits" als Datentyp REG_DWORD legen Sie die Einheit (Megabyte usw.) fest. Mögliche Werte und deren Bedeutung sind weiter unten aufgelistet.

Einheit

In den Einträgen "LimitUnits" und "ThresholdUnits" können Sie folgende Werte als Dezimalwert eintragen.

Wert | Beschreibung
1 | kB (Kilobyte)
2 | MB (Megabyte)
3 | GB (Gigabyte)
4 | TB (Terabyte)
5 | PB (Petabyte)
6 | EB (Exabyte)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Standarddatenträger-Kontingent und Warnstufe

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2468.htm


Speicherbegrenzung auf Wechseldatenträger anwenden

Standardmäßig wird die Datenträgerkontigents konfiguration nicht auf Wechseldatenträger angewendet und gelten nur für eingebaute Datenspeicher. Wenn Sie diesen Tipp aktivieren, gelten die Beschränkungen auch für Wechseldatenträger, die mit den Dateisystem NTFS formatiert wurden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Erstellen Sie hier einen neuen Wert mit dem Namen "ApplyToRemovableMedia" als Datentyp REG_DWORD und setzen den Wert auf:

gelöscht | Wechseldatenträger sind ausgeschlossen
1 | Wechseldatenträger werden auch berücksichtigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Richtlinie auf austauschbare Datenträger anwenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2469.htm


Protokolleintrag bei Überschreitung der Datenträger-Kontingentsgrenze

Mit diesem Tipp legen Sie fest, ob ein Eintrag in das Anwendungsprotokoll der Ereignisanzeige eingetragen werden soll, wenn die Datenträger-Kontingentsgrenze überschritten wird. Der Tipp Konfiguriert in der Datenträger-Kontingentverwaltung die Einstellung "Ereignis bei Kontingentüberschreitung protokollieren" (siehe dazu auch Tipp: "Datenträgerkontingentverwaltung aktivieren/deaktivieren").

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Erstellen Sie hier einen neuen Wert mit dem Namen "LogEventOverLimit" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nicht Protokollieren
1 | Protokollieren

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Ereignis protokollieren, wenn die Datenträger-Kontingentsgrenze überschritten wird

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2470.htm


Protokolleintrag bei Überschreitung der Datenträger-Kontingentswarnstufe

Mit diesem Tipp legen Sie fest, ob ein Eintrag in das Anwendungsprotokoll der Ereignisanzeige eingetragen werden soll, wenn die Datenträger-Kontingentwarnstufe überschritten wird. Der Tipp konfiguriert in der Datenträger.Kontingentverwaltung die Einstellung "Ereignis bei Warnstufenüberschreitung protokollieren" (siehe dazu auch Tipp: "Datenträgerkontingentverwaltung aktivieren/deaktivieren").

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ DiskQuota

Erstellen Sie hier einen neuen Wert mit dem Namen "LogEventOverThreshold" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nicht protokollieren
1 | Protokollieren

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\System\Datenträgerkontingente
Einstellungsname: | Ereignis protokollieren, wenn die Kontingentwarnstufe überschritten wird

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2471.htm


UDMA66 Support aktivieren

In diesem Tipp wird beschrieben, wie Sie die UDMA66 Unterstützung für Ihre Hardware aktivieren können.

Standardmäßig ist UDMA66 deaktiviert. Wenn Sie aber ein Gerät betreiben welches UDMA66 unterstützt und die benötigte Hardware dafür auch zu Verfügung steht können Sie die Funktion über die Registry aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\ 0000

Fügen Sie hier einen neuen Wert mit dem Namen "EnableUDMA66" als Datentyp REG_DWORD hinzu. Setzen Sie den Wert auf 1, um die Funktion zu aktivieren.

Info Zur entgültigen Aktivierung müssen Sie den Rechner neu starten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=247951

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0462.htm


Boot-Laufwerksbuchstabe unter Windows ändern

Wenn Sie im Festplattenmanager versuchen, den Laufwerksbuchstaben des Boot-Laufwerkes zu ändern, wird das mit der Meldung: "Der Laufwerksbuchstabe des System- oder Startdatenträgers kann nicht geändert werden" verweigert.

Da MS keine Änderung des Buchstaben vorsieht, sollte man es eigentlich auch nicht machen. Da aber viele Leute schon danach gefragt haben und mir das in einer Situation schon einmal sehr geholfen hat, will ich hier den Weg beschreiben. Gebraucht wird es z.B., wenn durch das zurückspielen eines Images plötzlich die Buchstaben vertauscht wurden. Dann können Sie diesem auch die Buchstaben vertauschen.

Ich möchte aber darauf hinweisen, dass es zu vielen Problemen kommen kann und im Extremfall Windows nicht mehr startet. Auf jeden Fall sollten Sie vorher Ihre Daten sichern und eine Rettungsdiskette erstellen.

Der Weg führt einmal wieder über den direkten Zugriff auf die Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

In diesen Beispiel wird davon ausgegangen, dass Sie das Systemlaufwerk "D:" mit dem Laufwerksbuchstaben "C:" tauschen wollen. Die Laufwerke wurden nach dem zurückspielen des Images vertauscht und das Systemlaufwerk war vorher C:

  1. Starten Sie REGEDIT.EXE
  2. Gehen Sie zu HKEY_LOCAL_MACHINE\ System\ MountedDevice
  3. Hier finden Sie einige Einträge. Suchen Sie den Eintrag mit dem zu ändernden Laufwerksbuchstaben, in diesem Beispiel: "\DOS Devices\C:"
  4. Klicken Sie diesen Eintrag mit der rechten Maustaste an und wählen Sie "Umbenennen" aus.
  5. Ändern Sie den Buchstaben kurzzeitig ab, damit C wieder frei wird. In diesen Beispiel würde der Eintrag jetzt so aussehen: "\DOS Devices\C:_"
  6. Suchen Sie jetzt das richtige C-Laufwerk. In diesen Beispiel würde der Eintrag jetzt so aussehen: "\DOS Devices\D:"
  7. Ändern Sie den Buchstaben in den gewünschten Laufwerksbuchstaben ab. In diesen Beispiel würde der Eintrag jetzt so aussehen: "\DOS Devices\C:"
  8. Jetzt müssen Sie noch den ersten Eintrag von "\DOS Devices\C:_" auf "\DOS Devices\D:" ändern.
  9. Starten Sie den Rechner neu.

In diesen Beispiel wird davon ausgegangen, dass Sie das Systemlaufwerk "C:" in den neuen Laufwerksbuchstaben "F:" abändern wollen.

  1. Starten Sie REGEDIT.EXE
  2. Gehen Sie zu HKEY_LOCAL_MACHINE\ System\ MountedDevice
  3. Hier finden Sie einige Einträge. Suchen Sie den Eintrag mit dem zu ändernden Laufwerksbuchstaben, in diesem Beispiel: "\DOS Devices\C:"
  4. Klicken Sie diesen Eintrag mit der rechten Maustaste an und wählen Sie "Umbenennen" aus.
  5. Ändern Sie den Buchstaben in den gewünschten Laufwerksbuchstaben ab. In diesen Beispiel würde der Eintrag jetzt so aussehen: "\DOS Devices\F:"
  6. Jetzt muss man unbedingt mit einem geeigneten Registry Editor alle Registry-Einträge von "C:" auf "F:" (in diesem Beispiel) umändern, sonst findet das System diverse Dinge nicht mehr (z.B. die Auslagerungsdatei in
    HKLM\System\CurrentControlSet\Control\Session Manager\Memory Management\PagingFiles). Die meisten dieser Referenzen befinden sich in den Dateien "Software" und "System" in "\WINNT\System32\config\".
  7. Starten Sie den Rechner neu.

Info Beachten Sie bitte die folgenden Hinweise: Diese Änderung des Bootlaufwerkes sollte nur von Anwendern durchgeführt werden, die auch die entsprechende Erfahrung haben, es kann dabei zu folgenden Fehlern kommen:

  1. Einige Programm sind auch noch in Windows mit festen Laufwerksbuchstaben verbunden, so kann es vorkommen, dass Windows diese Programm nicht mehr findet oder sie nicht richtig laufen (das wird wohl auch mit einer der Gründe sein, warum Windows das Ändern des Systemlaufwerks verweigert).
  2. Es kann passieren, dass Windows nicht mehr richtig startet oder sie sich nicht mehr anmelden können (gerade wenn "Offlinefolder" eingerichtet wurden, können diese nicht mehr synchronisiert werden und Windows meldet sie wieder ab).

Wenn Sie sich nach der Änderung nicht mehr anmelden können, aber der Rechner startet und an einem Netzwerk angeschlossen ist, können Sie die Änderung über das Netzwerk wieder rückgängig machen. Starten Sie dazu auf einem anderen Netzwerkrechner Regedt32 und laden Sie damit die Registry des entsprechenden Rechners. Da man mit REGEDT32 keine Werte umbenennen kann, gehen Sie hier folgendermaßen vor:

  1. Klicken Sie den geänderten Eintrag an und kopieren Sie sich die binären Einträge heraus.
  2. Löschen Sie den Eintrag.
  3. Erstellen Sie einen neuen binären Eintrag mit dem Namen "\DOS Devices\[Laufwerksbuchstabe]:", wobei Sie [Laufwerksbuchstabe] durch den alten Buchstaben ersetzen.
  4. Kopieren Sie hier den zwischengespeicherten Eintrag wieder hinein.
  5. Starten Sie den Rechner neu.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1025.htm


Konfigurieren wer austauschbare Medien formatieren bzw. auswechseln darf

Wenn Sie festlegen wollen, wer unter Windows wechselbare Speichermedien formatieren und austauschen darf, müssen Sie auf die Registry zurückgreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Finden Sie den Eintrag "AllocateDASD" als Datentyp REG_SZ.

Diesen Eintrag können Sie auf folgende Werte setzen:

0 | Nur Administratoren
1 | Administratoren und Power User
2 | Administratoren und lokale Anwender

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0841.htm


DirectCD nach Installation von MP7 defekt

Mit dem neuen MediaPlayer 7 von Microsoft treten zumindest unter Windows 2000 Probleme auf, sofern die Brennsoftware EasyCD-Creator bis Version 4.02c oder DirectCD 3.01c installiert ist.

Nach der Installation des MediaPlayer 7 und anschließendem Neustart meldet das DirectCD-Icon in der KBar beim Anklicken "Adaptec DirectCD Wizard, No supported CD-R/CD-RW drive".

Es tritt wohl ein Konflikt zwischen dem CD-Burn-Plugin des MP7 und der Software von Adaptec auf.

Komischerweise ist die Burn-Technologie direkt von Adaptec. Wer hier geschlafen hat, ist mir unklar. Das Problem lässt sich aktuell nur beheben, indem man den MP7 ohne das Brenn-Plugin installiert. Ist das Kind schon in den Brunnen gefallen, kann man das Brenn-Plugin deinstallieren, ebenso wie den DirectCD und diesen dann erneut installieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1104.htm


PacketCD unter Windows 2000

PacketCD führt unter Windows 2000 zu Systemabstürzen. In den meisten Fällen fährt das System nach der Installation nur noch im Abgesicherten-Modushoch. Deinstalliert man PacketCD, ist der Fehler behoben.

Hier die Aussage von CeQuadrat:

Derzeit unterstützt Packet CD die Windowsversionen 95/98/(PacketCD v3.00.209) und NT in der Version 2.50.042 die mit WinOnCD 3.7 ausgeliefert wird. Microsoft hat leider im Datenträgersystem von Windows 2000 eine Vielzahl von Änderungen vorgenommen, die es unmöglich machen, PacketCD in seiner derzeitigen Form auf diesem Betriebssystem zu nutzen. Die Entwicklung an PacketCD 2000 wurde mittlerweile zugunsten von Direct CD eingestellt. Die Anpassung der Software an DirectCD geschieht zur Zeit in unserer Quality-Assurance-Abteilung, wir möchten diese Update so schnell wie möglich anbieten, aber natürlich nicht mit Qualitätslücken. 27.07.2000.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1103.htm


DMA-Modus für CD/DVD Laufwerke aktivieren

Auf vielen Systemen ist der DMA-Modus für das CD-ROM nicht aktiviert, was massive Performance-Einbrüche beim Lesen hat.

Zum Aktivieren des DMA-Modus ruft man über das Kontextmenü des Arbeitsplatzes -> "Eigenschaften" -> "Hardware" -> "Gerätemanager" (oder über die Systemsteuerung, Computerverwaltung) auf. Dort den primären oder sekundären IDE-Kanal (je nachdem, wo das CD-ROM angeschlossen ist) unter dem Punkt IDE ATA/ATAPI-Controller auf.

Klicken Sie den Eintrag mit der rechten Maustaste a und wählen Sie aus dem Kontextmenü Eigenschaften aus. Unter dem Tabreiter "Erweiterte Einstellungen" können Sie nun den DMA-Modus einstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1128.htm


CD/DVD-Laufwerke nicht verfügbar

Unter Windows werden keine CD/DVD-Laufwerke mehr angezeigt und es können keine Datenträger mehr abgespielt werden.

Viele Programme für CD/DVD Laufwerke (Brennprogramme usw.) installieren so genannte Filtertreiber, die sich in die vorhandene Treiberarchitektur einklinken um auf CD- und DVD-Laufwerke zugreifen zu können. Unsauber programmierte (De)Installationsroutinen können erhebliche Probleme verursachen, da sie einige Einträge in der Registry zurücklassen. Die Folge: Windows kann nicht mehr auf die Laufwerke zugreifen, der Geräte-Manager zeigt für alle CD- und DVD-Laufwerke eine Fehlermeldung an, meist mit dem Code 19, 31, 32 oder 39.

Für den Zugriff werden meist keine extra Treiber benötigt, auch wird der Hersteller vermutlich keinen bereitstellen, da der Standardtreiber von Betriebssystem völlig genügt. Um wieder den alten zustand herzustellen, reicht es oft aus die folgenden Registryeinträge zu löschen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

hier löschen Sie die Einträge "Upperfilters" und "LowersFilters" und starten den Rechner neu. Anschließend sollten Sie wieder auf die Laufwerke zugreifen können.

Sollte es immer noch nicht gehen, spielen Sie mal die folgende REG-Datei ein:

Erstellen Sie dafür eine Datei mit den Namen "fix_uninst_ecdc_w2k.reg" und folgendem Inhalt.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]

"Class"="CDROM"

@="DVD/CD-ROM drives"

"EnumPropPages32"="MmSys.Cpl,MediaPropPageProvider"

"Installer32"="storprop.dll,DvdClassInstaller"

"SilentInstall"="1"

"NoInstallClass"="1"

"TroubleShooter-0"="tshoot.chm,hdw_drives.htm"

"Icon"="-51"

"LowerFilters"=hex(7):63,00,64,00,72,00,34,00,5f,00,32,00,4b,00,00,00,00,00

"UpperFilters"=hex(7):70,00,77,00,64,00,5f,00,32,00,4b,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0000]

"DefaultDvdRegion"=dword:00000001

"EnumPropPages32"="storprop.dll,DvdPropPageProvider"

"InfPath"="cdrom.inf"

"InfSection"="cdrom_install"

"ProviderName"="Microsoft"

"DriverDateData"=hex:00,40,99,31,33,2e,bf,01

"DriverDate"="11-14-1999"

"DriverVersion"="5.0.2183.1"

"MatchingDeviceId"="gencdrom"

"DriverDesc"="CD-ROM Drive"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0001]

"DefaultDvdRegion"=dword:00000001

"EnumPropPages32"="storprop.dll,DvdPropPageProvider"

"InfPath"="cdrom.inf"

"InfSection"="cdrom_install"

"ProviderName"="Microsoft"

"DriverDateData"=hex:00,40,99,31,33,2e,bf,01

"DriverDate"="11-14-1999"

"DriverVersion"="5.0.2183.1"

"MatchingDeviceId"="gencdrom"

"DriverDesc"="CD-ROM Drive"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0002]

"DefaultDvdRegion"=dword:00000001

"EnumPropPages32"="storprop.dll,DvdPropPageProvider"

"InfPath"="cdrom.inf"

"InfSection"="cdrom_install"

"ProviderName"="Microsoft"

"DriverDateData"=hex:00,40,99,31,33,2e,bf,01

"DriverDate"="11-14-1999"

"DriverVersion"="5.0.2183.1"

"MatchingDeviceId"="gencdrom"

"DriverDesc"="CD-ROM Drive"

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1023.htm


Weblink zum Druckerinstallations-Assistenten hinzufügen

Mit diesem Tipp können Sie zum Druckerinstallationsassistenten einen Link zu einer Internetseite hinzufügen. Wenn der Benutzer auf den Button <Durchsuchen> klickt, wird der Browser mit der URL geöffnet.

Durch Aktivieren dieser Einstellung und Eingabe einer Internet- oder Intranetadresse im Textfeld, wird die Schaltfläche "Durchsuchen" auf der Seite "Drucker angeben" im Druckerinstallations-Assistent neben der Option "Verbindung mit einem Drucker im Internet oder Heim-/Firmennetzwerk herstellen" hinzugefügt. Wenn Benutzer auf "Durchsuchen" klicken, wird ein Internetbrowser geöffnet und die Webseite mit der angegebenen URL-Adresse angezeigt.

Diese Einstellung erleichtert es Benutzern, vorgegebene Drucker zu installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Printers\ Wizard

Erstellen Sie hier einen neuen Wert mit dem Namen "Printers Page URL" als Datentyp REG_SZ. Geben Sie die URL ein.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Websites nach Druckern durchsuchen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1425.htm


Keine Drucker mehr in Windows 2000 vorhanden

Es kann vorkommen, dass plötzlich keine Drucker mehr in der Systemumgebung vorhanden sind und sich diese auch nicht nachinstallieren lassen.

Manchmal ist die Deinstallation eines Druckers als Ursache auszumachen, wenn Winprint mit deinstalliert wurde. Bewährt hat sich in diesem Fall die Wiederherstellung des nachfolgenden Registry-Eintrages unter Windows 2000:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Print\ Environments\ Windows NT x86\ Print Processors\ winprint

legen Sie den Eintrag Driver vom DatentypREG_SZ mit diesem Wert "localspl.dll" an.

Nach dem Hinzufügen diese Eintrags sollten sämtliche vorher installierten Drucker wieder sichtbar und vor allem ansprechbar sein.

Siehe auch "Fehlermeldung bei Druckerinstallation".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1299.htm


NT 4.0 Druckertreiber unter Windows 2000

Im Gegensatz zu Windows NT4, laufen die Druckertreiber bei Windows 2000 im User-Mode. Microsoft verspricht sich davon eine höhere Systemstabilität, da einige Treiber unter NT zu Problemen führten. Aus diesem Grund sind Windows NT4-Treiber unter Windows 2000 nicht mehr nutzbar.

Sie haben aber eine Möglichkeit, diese Treiber auf für Windows 2000 nutzbar zu machen. Auf der Windows 2000 Server CD finden Sie im Verzeichnis "Printers\FIXPRNSV" die Datei "FIXPRNSV.EXE". Mit dieser Datei können Sie alte Windows NT 4 Treiber für Windows 2000 lauffähig machen.

Gehen Sie dabei folgendermaßen vor:

NT oder Windows 9x Maschine zur Hand nehmen, gewünschten Drucker installieren und freigeben. Danach das Tool auf diesem PC ausführen. Jetzt kann über das Netzwerk der Drucker auf der Windows 2000 Maschine installiert werden.

Info Es ist zu empfehlen, danach auf der NT oder Windows 9x Maschine den Originaltreiber darüber zu installieren, da sonst Probleme bei der Druckqualität auftreten können.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0496.htm


Netzwerkdrucker im Active Directory anzeigen

Wenn Sie Netzwerkdrucker in die ADS einbinden wollen, machen Sie dass über die Eigenschaften des Druckers. Dort finden Sie im Tabreiter "Freigabe" den Eintrag "Im Verzeichnis anzeigen", dafür muss natürlich der Drucker Mitglied ein er ADS-Domäne sein.

Den Drucker finden Sie aber auch jetzt nicht in der Anzeige von Tool "Active Directory Benutzer und Computer". Das liegt daran, dass Computerobjekte als Container definiert sind. Wird ein Drucker auf einem Computer freigegeben, ist er ein Container des Computers.

Diese Container werden nur angezeigt, wenn Sie in der MMC die Option "Benutzer, Gruppen und Computer als Container2 auswählen. Jetzt werden Ihnen dann auch die Netzwerkdrucker angezeigt. Hier können Sie jetzt auch die Eigenschaften des Netzwerkdruckers anpassen. Diese Eigenschaften können später bei der Druckersuche benutzt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1645.htm


Drucker Hilfe-Link anpassen

In der Anzeige "Drucker und Faxgeräte" wird bei "Siehe auch" der Link "Hilfe über Drucken erhalten"- angezeigt.

Wenn man diesen Eintrag anklickt, wird im Browser eine Microsoft Webseite geöffnet. Sie können aber auch den Link ändern und eine eigene Webseite anzeigen lassen.

Info Dieser Eintrag wird nur angezeigt, wenn die Ansicht "Allgemeine Aufgaben in Ordnern anzeigen" unter "Extras" -> "Ordneroptionen..." -> Tabreiter "Allgemein" aktiviert ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Printers

Erstellen Sie hier einen neuen Wert mit dem Namen "SupportLink" als Datentyp REG_SZ. Geben Sie hier nun die URL ein, welche geöffnet werden soll.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2035.htm


Internetdrucken auf dem Server ausschalten

Mit diesem Tipp können Sie die Funktion 'Internetdrucken' auf Webseiten ausschalten. Diese Funktion ermöglicht das Anzeigen von Druckern auf Webseiten und stellt über das Internet/Intranet die Drucker zu Verfügung. Die Drucker selbst können über das Internet verwaltet werden.

Internetdrucken ist eine Erweiterung der Internetinformationsdienste (IIS). Damit das Internetdrucken verwendet werden kann, muss IIS installiert sein, und es müssen Druckunterstützung sowie diese Einstellung aktiviert sein.

Um diese Funktion ausschalten, müssen Sie den folgenden Registryeintrag setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Printers

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableWebPrinting" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Internetdrucken ist nicht mehr möglich
0 | Internetdrucken ist aktiv (Standard)

Info Diese Einstellung bezieht sich nur auf das Serverseitige Internetdrucken.

Weitere Informationen finden Sie unter der Einstellung "Benutzerdefinierte Support-URL im linken Fensterbereich des Ordners 'Drucker'". In diesem Ordner und unter der Einstellung "Websites nach Druckern durchsuchen" unter "Benutzerkonfiguration\Administrative Vorlagen\Systemsteuerung\Drucker".

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Drucker
Einstellungsname: | Webbasiertes Drucken

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2605.htm


Suche nach Netzwerkdrucker aus dem Druckerassistent entfernen

Suche nach Netzwerkdrucker aus dem Druckerassistenten entfernen

Wenn Sie diese Funktion aktivieren, wird die Suche nach Netzwerkdruckern im Druckerinstallationsassistenten ausgeschaltet.

Wenn Sie diese Einstellung aktivieren oder nicht konfigurieren, wird Benutzern eine Liste aller freigegebenDrucker im Netzwerk angezeigt, sowie die Auswahl eines Druckers aus der Liste ermöglicht und wenn Sie "Netzwerkdrucker oder Drucker, der an einen anderen Computer angeschlossen ist" auf Seite 2 des Assistenten auswählen und zusätzlich die Option "Verbindung mit folgendem Drucker herstellen (klicken Sie zum Suchen auf "Weiter")" auf Seite 3 aktivieren und dabei keinen Druckernamen im Feld "Name" eingeben.

Durch Deaktivieren dieser Einstellung steht die Suchseite für Netzwerkdrucker im Druckerinstallations-Assistenten nicht zur Verfügung und Benutzer können das Netzwerk nicht durchsuchen, sondern müssen den Druckernamen selbst eingeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Printers\ Wizard

Erstellen Sie hier einen neuen Wert mit dem Namen "Downlevel Browse" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Suche vorhanden
0 | Suche nach Druckern möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Netzwerk nach Druckern durchsuchen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung gilt nur für den Druckerinstallations-Assistenten. Sie verhindert nicht, dass Benutzer mit anderen Programmen nach freigegeben Netzwerkdruckern suchen oder die Verbindung mit Netzwerkdruckern anderweitig herstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1432.htm


Standardpfad für die Suche nach Drucker im Active Directory konfigurieren

Mit diesem Tipp können Sie den Pfad im Active Directory festlegen, in dem zuerst nach Druckern gesucht werden soll.

Der Drucker-Installations-Assistent ermöglicht Benutzern das Active Directory nach einem freigegebenen Drucker zu durchsuchen. Durch Aktivieren dieser Einstellung wird zuerst auf dem Pfad gesucht, den Sie im Feld "Standardpfad im Active Directory" angeben. Ansonsten wird zuerst im Stammverzeichnis von Active Directory gesucht. Diese Einstellung verhindert nicht, dass Benutzer das Active Directory durchsuchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Printers\ Wizard

Erstellen Sie hier einen neuen Wert mit dem Namen "Default Search Scope" als Datentyp REG_SZ und geben Sie den Pfad des LDAP-Direcktory an (z.B.: LDAP://DC=Domäne,DC=Test,DC=de).

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Standardpfad im Active Directory für die Suche nach Druckern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1957.htm


Performanceanalyse - Grundlagen - Teil 1

Das Leistungsverhalten/Geschwindigkeit (Performance) eines Systems kann nie gut genug sein. Durch einen neuen Prozessor oder zusätzlichen Speicher kann man die Performance eines Systems verbessern. Da die Performance aber von vielen Faktoren abhängig ist, ist die Optimierung eines Systems nicht leicht. So bringt mehr Speicher keine Verbesserung, wenn dieser vom System nicht optimal genutzt werden kann.

Über das Tool "Leistung" (bis Server 2000 als Systemmonitor bezeichnet), kann das System analysiert werden.

Das Tool finden Sie in der "Systemsteuerung" -> "Verwaltung" -> "Leistung";oder es kann über den Befehl "%windir%\system32\perfmon.exe" gestartet werden. Hier können Sie sich mit dem Systemmonitor einen ersten Überblick vom aktuellen Zustand des Systems schaffen.

Ab Windows Vista heißt das Tool jetzt "Zuverlässigkeits- und Leistungsüberwachung" und ist zu finden unter "Systemsteuerung" -> "Verwaltung" -> "Zuverlässigkeits- und Leistungsüberwachung" oder auch durch Aufruf des Befehls "%windir%\system32\perfmon.exe".

Zuverlässigkeits- und Leistungsüberwachung

Ad-hoc Überwachung

Wenn Sie das Tool starten, werden standardmäßig die folgenden Daten angezeigt:

Leistung - Systemmonitor

Systemmonitor: Durch Drücken von STRG+H können Sie den aktuell markierten Eintrag hervorheben.

Seiten/s:

Dieser Wert gibt an, wie viele Seiten pro Sekunden in den Speicher geladen bzw. geschrieben werden. Der Wert ist ein Maß dafür, wie viele Daten zwischen Arbeitsspeicher und dem Datenträger kopiert werden. Mit diesem Wert kann recht gut abgeschätzt werden, ob zu wenig Arbeitsspeicher im System vorhanden ist. Kurzzeitige Spitzen sind normal und entstehen, wenn z.B. neue Anwendungen gestartet werden. Liegt der Wert aber über einen längeren Zeitraum auf einen hohen Wert,dann existiert hier ein entsprechender Engpass.

Durchschnittliche Warteschlangenlänge:

Dieser Wert gibt an, wie viele Aufträge für den Datenträger in der Warteschlange stehen. Wenn zu viele Aufträge anstehen, deutet es auf eine schlechte Performance des Datenträgers hin. Das System muss dann auf die Bereitstellung der gewünschten Daten warten.

Prozessorzeit (%):

Dieser Wert gibt an, wie oft der Prozessor genutzt wird. Auch hier sind evtl. kurzfristige Spitzen normal, sie sollten aber nicht über einen längeren Zeitraum auftreten.

Mit diesen drei Werten können Sie sich schon einen entsprechenden Überblick vom aktuellen System verschaffen. Sollen aber spezielle Fälle oder bestimme Anwendungen untersucht werden, müssen Sie oft entsprechende Leistungsindikatoren hinzufügen.

Ab Windows Vista wird standardmäßig nur noch ein Wert "Prozessorzeit (%)" angezeigt; weitere Leistungsindikatoren müssen Sie hier über das Plus-Zeichen hinzufügen.

Systemmonitor - Vista

Über den Befehl "Leistungsindikatoren hinzufügen", lassen sich weitere Bereiche zur Überwachung hinzufügen. Klicken Sie dafür auf das Plus-Zeichen oder geben die Tastenkombination STRG+I ein.

Windows 2000, XP und 2003

Leistungsindikatoren hinzufügen - Vista

Ab Windows Vista

Die Liste der möglichen Indikatoren wird durch die Installation von Anwendungen auf den Server/Rechner erweitert. So bringt z.B. der Microsoft SQL-Server viele neue Einträge mit.

Erst einmal geben Sie unter "Leistungsobjekt" oder "Datenobjekt" das zu überwachende Objekt an. Anschließend wählen Sie unter Leistungsindikatoren die zu überwachenden Einträge aus. Hier ist die Auswahl "Alle Leistungsindikatoren" meist nicht sinnvoll, da es oft einfach zu viele sind und die Anzeige dadurch nicht gerade übersichtlich wird.

Dann müssen Sie die Instanz angeben, welche überwacht werden soll. Hier lassen sich in der Regel Gesamtwerte (_Total) ermitteln. Die Instanzen sind je nach Typ unterschiedlich:

  • Bei Prozessor -> Prozessoren
  • Bei Threads -> Threads
  • Bei Datenträger -> Festplatten

Über die Eigenschaften (STRG+Q) können Sie über 5 diverse Tabreiter noch folgende Einstellungen verändern:

Tabreiter "Allgemein"

Als wichtigste Einstellung finden Sie hier das "Intervall" für die Erfassung der Systemindikatoren, was je nach Betriebssystem anders bezeichnet wird (Windows XP: "Beispiel automatisch alle x Sekunden erfassen" bzw. Windows Vista "Stichprobe alle x Sekunden"). Die Standardeinstellung liegt hier bei 1 Sekunde, so dass nur Werte der letzten 100 Sekunden angezeigt werden. Da man meist einen längeren Zeitraum überblicken möchte, sollten Sie den Wert z.B. auf 15 Sekunden ändern, so dass Sie jetzt einen Zeitraum von 25 Minuten angezeigt bekommen. Weiterhin legen Sie hier noch die Form der Anzeige der einzelnen Elemente fest.

Tabreiter "Quelle"

Hier können Sie die Daten auch aus anderen Quellen laden und damit auch die Analyse von längeren Datenaufzeichnungen durchführen.

Tabreiter "Daten"

Hier können Sie weitere Leistungsindikatoren hinzufügen (wie oben über das Kontextmenü "Leistungsindikatoren hinzufügen". Zusätzlich können Sie hier auch die Farbe für die Anzeige verändern.

Tabreiter "Grafik"

Hier können Sie alles konfigurieren was für die Anzeige zuständig ist. Sie können hier z.B. Gitternetzlinien (Raster) hinzufügen.

Tabreiter "Darstellung"

Hier können Sie Farben und Schriftarten verändern.

Ab Windows Vista finden Sie noch die "Zuverlässigkeitsüberwachung". Hier wird auf einer Zeitskala der Verlauf von aufgetretenen Fehlern angezeigt. Durch das Anklicken eines entsprechenden Datums können Sie sich die dazu vorhanden Informationen anzeigen lassen.

Überwachung über einen längeren Zeitraum

Das obere Vorgehen ist nur für eine kurze Analyse zu gebrauchen, aber gerade bei Servern muss meist eine Überwachung über einen längeren Zeitraum durchgeführt werden, um aussagekräftige Fakten zu erhalten.

Dafür gibt es die Leistungsindikationsprotokolle, mit denen sich die Werte in eine Datei schreiben lassen. Diese Datei können Sie zu einem späteren Zeitraum auswerten.

Bei Windows 2000, XP und Windows 2003

Ein vordefiniertes Protokoll mit den oben erwähnten 3 Werten ist schon als Beispiel vorhanden. Über das Kontextmenü von "Leistungsindikatorenprotokolle" können Sie eigene Protokolle über den Eintrag "Neue Protokolleinstellungen..." hinzufügen.

Als Erstes müssen Sie hier wieder das Objekt und die Leistungsindikatoren unter dem Tabreiter "Allgemein" festlegen. Hier wird auch das Intervall für die Aufzeichnung festgelegt, dessen Standardwert bei 15 Sekunden liegt.

Leistungsindikationsprotokolle - Allgemein

Unter dem Tabreiter "Protokolldateien" legen Sie fest, wo und in welchem Dateiformat die Daten gespeichert werden sollen. Bei "Binärdatei" können Sie das Protokoll später in den Systemmonitor laden und damit anzeigen lassen. Wenn Sie als Ausgabe 'Textdatei' wählen, können Sie die Daten mit Excel öffnen und entsprechend auswerten.

Leistungsindikationsprotokolle - Protokolldateien

Im Tabreiter "Zeitplan" legen Sie die Start und Endzeit für eine Protokollierung fest.

Leistungsindikationsprotokolle - Zeitplan

Ab Windows Vista

Hier können Sie über das Kontextmenü "Sammlungssatz" unter "Sammlungssätze" -> "Benutzerdefiniert" neue "Sammlungssätze" erstellen.

Als Erstes werden Sie nach einen Namen gefragt. Danach können Sie einen Sammlungssatz über eine "Vorlage" oder "Manuell" erstellen. Bei den Vorlagen handelt es sich um XML-Dateien mit vorgefertigten Einstellungen, welche von Microsoft geliefert werden oder von Ihnen auf einen andere Rechner erstellt wurden und hierher importiert werden können. Wenn Sie diesen Eintrag wählen, können Sie aus den vorhanden Vorlagen eine auswählen.

Über Manuell erstellen Sie einen ganz neuen Sammlungssatz. Wenn Sie das auswählen, werden Sie anschließend gefragt, welcher Datentyp benutzt werden soll. Wählen Sie hier "Leistungsindikatoren" aus und klicken Sie auf "Weiter". Im nächsten Fenster können Sie über den Button "Hinzufügen" die zu überwachenden Leistungsindikatoren zu einer Liste hinzufügen. Dabei stehen die gleichen Werte zur Verfügung wie beim Systemmonitor. Wenn Sie die gewünschten Indikatoren hinzugefügt haben, können Sie noch ein Abtastintervall konfigurieren.

Klicken Sie anschließend auf "Weiter" und geben Sie an, wo die Datei gespeichert werden soll, und klicken Sie anschließend auf "Weiter". Im letzten Dialog können Sie jetzt noch festlegen, unter welchen Account der Sammlungssatz ausgeführt werden soll. Über den Button "Ändern" können Sie einen Benutzeraccount dafür angeben bzw. die Einstellung auf "<Standard>"lassen. Über die Auswahl "Diesen Sammlungssatz jetzt starten" können Sie die entsprechenden Daten sammeln.

Die bestehenden Sammlungssätze oder Ihre eigenen können Sie unter "Sammlungssätze" entsprechend starten oder auch wieder beenden und konfigurieren.

Unterhalb von "Berichte" -> "Benutzerdefiniert" finden Sie die Berichte der durchgeführten Aufzeichnungen

Im nächsten Teil werden wir die wichtigsten Leistungsindikatoren vorstellen und entsprechend beschreiben, wie die gesammelten Werte zu deuten sind und welche Maßnahmen man daraus ableiten kann.

  • Performanceanalyse - Speicherprobleme - Teil 2

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2579.htm


Performanceanalyse - Speicherprobleme - Teil 2

Analyse von Speicherproblemen

Bei der Performance Analyse sollte generell immer mit der Analyse der Speicherauslastung begonnen werden. Der Grund liegt darin, dass sich Engpässe im Hauptspeicher auf andere Systembereiche auswirken können und dadurch auch dort zu Engpässen führen können. Meist haben aber Engpässe in anderen Bereichen keine Auswirkung auf den Arbeitsspeicher.

Ein Beispiel, um das zu verdeutlichen:

Ist zu wenig physischer Speicher vorhanden, führt das dazu, dass Daten ausgelagert werden müssen. Die zusätzliche Arbeit führt zu einer höheren Prozessorauslastung und natürlich zu einem verstärkten Festplattenzugriff. Falls man jetzt als Erstes nur die Festplattenzugriffe analysiert, kann man zum Schluss kommen, dass es hier einen Engpass gibt. Eine schnellere Festplatte würde aber nur das Symptom, nicht aber die Ursache, kurieren. Der Gewinn an Performance wäre nicht so groß als würde man den Arbeitsspeicher erweitern.

Erstanalyse mit dem Task-Manager

Ob Speicherprobleme vorliegen, kann schon grob mit dem Task-Manager ermittelt werden. Hier finden Sie auf dem Tabreiter "Systemleistung" die nötigen Informationen.

Die Informationen "Realer Speicher" und "Zugesicherter virtueller Speicher" geben hierfür wichtige Anhaltspunkte. Im Allgemeinen kann man sagen, dass im Idealfall der "Insgesamt" und "Maximalwert" bei "Zugesicherter virtueller Speicher" nicht viel größer sein sollte als der physikalische Hauptspeicher (Realer Speicher – Insgesamt). Zusätzlich sollte der verfügbare Hauptspeicher stets über 10 MByte liegen.

Windows lagert immer Informationen in den virtuellen Speicher aus, um Platz für Anwendungen zu schaffen (Teil des Kernel-Speichers und Speicherseiten, die länger nicht mehr benutzt wurden). Dadurch kann der tatsächlich benötigte Speicher ruhig über den vorhandenen Hauptspeicher liegen, ohne dass es zu verstärkten Auslagerungen kommt. Weiterhin sorgt Windows stets dafür, dass es immer verfügbaren physikalischen Speicher gibt. Erst wenn das System stark ausgelastet wird, wird dieser Wert entsprechend geringer.

Zusätzlich gibt es noch eine Abhängigkeit zwischen dem Systemcache und dem verfügbaren Speicher. Wenn der physikalische Speicher knapp wird, wird der Speicher für den Systemcache reduziert, was am Ende zu Performanceproblemen führt.

Mit diesen Informationen können Sie also schon Probleme beim Speichern mittels desTask-Managers erkennen.

Taskmanager - Systemleistung

Unter dem Tabreiter "Prozesse" finden Sie die Anwendungen, die den meisten Speicher benötigen. Hier sollten Sie über das Menü "Ansicht" -> "Spalten auswählen..." den Eintrag "Maximale Speichernutzung" hinzufügen. Anhand der Informationen "Speichernutzung" und "Maximale Speichernutzung" können Sie die Prozesse finden, die den meisten Speicher benutzen oder benutzt haben.

Analyse mit dem Systemmonitor

Für eine genauere Analyse (auch über einen längeren Zeitraum), müssen Sie letztendlich auf den sog. Systemmonitor zurückgreifen.

Um den Systemmonitor zu starten, gibt man einfach unter "Ausführen" perfmon.exe ein. Der Funktionsumfang lässt nahezu jede Kleinigkeit messen. Damit erhält man Konfigurationsmöglichkeiten in großer Vielfalt.

Für die Analyse des Speichers sind die folgenden Leistungsindikatoren interessant:

Datenobjekt "Speicher"

  • Cachebytes: Zeigt die Größe des Caches an. Dieser Wert verändert sich bei hoher Speicherauslastung.
  • Seiten/s: Dieser Wert gibt an, wie viele Seiten pro Sekunden vom physikalischen Hauptspeicher in die Auslagerungsdatei geschrieben oder ausgelesen werden. Bei dem Wert handelt es sich um eine der wichtigsten Informationen zur Speicheranalyse. Mit diesem Wert können Sie ermitteln, wie stark die Auslagerungsdatei verwendet wird.
  • Verfügbare Bytes: Gibt die verfügbaren Bytes an, die von Programmen verwendet (reserviert) werden können.
  • Zugesicherte Bytes: Dieser Speicher wurde für Programme reserviert (zugesichert). Der Speicher muss nicht zwingend von den Programmen benutzt werden bzw. wird erst später vom Programm benötigt.
  • Zusagegrenze: Dieser Wert gibt den maximalen Speicher an, der zugesichert werden kann. Hier können nur Veränderungen beobachtet werden. Jedesmal, wenn sich der Wert vergrößert, wird die Auslagerungsdatei entsprechend vergrößert. Das kann dazu führen, dass die Auslagerungsdatei nicht mehr in zusammenhängenden Bereichen auf der Festplatte angelegt wird, was dazu führt, dass die Performance sinkt. Sie sollten die Auslagerungsdatei immer so groß wählen, dass dieser Wert nicht verändert werden muss. Der Wert für die Zusagegrenze sollte immer stabil bleiben.

Datenobjekt "Auslagerungsdatei"

  • Belegung (%): Dieser Wert zeigt an, wie stark die Auslagerungsdatei benutzt wird.

Datenobjekt "Prozess"

Hier müssen Sie jeweils zum Leistungsindikator den entsprechenden Prozess auswählen der überwacht werden soll. Es werden in der Auswahl nur aktuell laufenden Prozesse angezeigt.

  • Arbeitsseiten: Der Wert gibt an, wie viele Arbeitsseiten von einem Prozess belegt werden. Das ist der Speichebedarf, der von der Anwendung benutzt wird. Die Angabe erfolgt in Byte.
  • Arbeitsseiten (max.): Gibt die maximale Speicherbelegung des Prozesses an.
  • Auslagerungsdatei (Bytes): Gibt an, wie viele Bytes der Anwendung gerade ausgelagert sind.
  • Auslagerungsdatei (max. Bytes): Gibt die maximale Größe an, die jemals für die Anwendung ausgelagert wurden.
  • Private Bytes: Zeigt an, wie viele Bytes der Prozess für die eigene Nutzung reserviert hat und die nicht mit anderen Prozessen geteilt werden. Dieser Wert ist ein guter Indikator für die tatsächliche Belastung des Systems

Was kann man gegen knappen Speicher tun?

Wenn Sie feststellen, dass der Speicher nicht ausreicht, können Sie die Situation mit den folgenden Aktionen verbessern:

  • Handelt es sich um Server, besteht die Möglichkeit, Aufgaben auf andere Systeme zu verteilen. Gerade wenn mehrere unterschiedliche Serveranwendungen auf einen System laufen.
  • Sie können den Hauptspeicher erweitern. Hier sollten Sie aber auch beachten, ob das Betriebssystem die Größe des Arbeitsspeicher wirklich unterstützt. So können z.B. Windows XP und Windows Vista in der 32 Bit-Version nur maximal 3 GByte Arbeitsspeicher verwalten. Bei mehr Speicherbedarf muss dann die 64-Bit-Version eingesetzt werden, die aber zur Zeit noch nicht von allen Anwendungen und Treibern unterstützt werden.
  • Sie können den Speicherbedarf reduzieren. Dafür sollten Sie nachschauen, welche Dienste Sie nicht benötigen und entsprechend abschalten können (siehe dazu Tipp "Windows Dienste: Allgemeine Informationen").

Siehe auch Tipp:

  • Performanceanalyse - Grundlagen - Teil 1

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2596.htm


Windows Systempartition dekomprimieren

Wenn Sie Windows 2000 auf einer NTFS-Partition installiert haben, werden automatisch einige Systemdateien komprimiert.

Bei einigen Systemen (gerade bei langsamen Rechnern) kann das dazu führen, dass Ihr System dadurch langsamer wird, da beim Zugriff auf diese Daten das System die Dateien erst dekomprimieren muss.

Wenn Sie also Windows auf einem nicht so schnellen Rechner einsetzen, sollten Sie die Komprimierung wieder rückgängig machen. Gehen Sie dazu folgendermaßen vor:

  1. Beenden Sie alle gestarteten Programme
  2. Markieren Sie im Explorer alle Windows Systemverzeichnisse.
  3. Führen Sie einen Rechtsklick auf die markierten Verzeichnisse aus und wählen Sie im Kontextmenü "Eigenschaften" aus
  4. Klicken Sie unter "Allgemein" auf den Button "Erweitert"
  5. Hier finden Sie unter "Komprimierung oder Verschlüsselung" einen Haken bei "Inhalt komprimieren, um Speicherplatz zu sparen". Entfernen Sie diesen Haken.
  6. Klicken Sie auf "OK" und dann auch "Übernehmen"
  7. Sie werden jetzt gefragt, inwieweit die Änderungen durchgeführt werden sollen, wählen Sie hier "Änderungen für die markierten Objekte, Unterordner und Dateien übernehmen" aus und klicken Sie auf OK.
  8. Sie werden jetzt einige Fehlermeldungen angezeigt bekommen. Da Windows auf geöffnete Dateien nicht zugreifen kann, klicken Sie hier am besten auf "Alle ignorieren".
  9. Je nach Rechner dauert das jetzt einige Zeit.

Info Bedenken Sie aber, dass jetzt auch einiges mehr an Speicherplatz auf der Festplatte für das System benötigt wird.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1003.htm


OS/2 und POSIX-Subsysteme deaktivieren

Windows startet immer noch die OS/2 und POSIX-Subsysteme, welche Sie mit diesem Tipp deaktivieren können. Je weniger Subsysteme der Windows-Sitzungs-Manager (SMSS) laden muss, um so weniger Systemressourcen werden belegt.

Diese optionalen Subsysteme sollten nur dann installiert bleiben, wenn Sie von Anwendungen benötigt werden (was bei den meisten Anwendern nicht der Fall sein sollte).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ SubSystems

hier finden Sie den Eintrag "Optional" als Datentyp REG_MULTI_SZ. Für jedes Subsystem finden Sie einen eigenen Eintrag. Löschen Sie einfach die Subsysteme heraus, welche Sie nicht mehr benötigen. Standardmäßig stehen dort folgenden Subsysteme:

  • OS2
  • Posix

Weiterhin können Sie dann noch die zusätzlichen Einträge unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ SubSystems" verändern:

  • OS2 (REG_EXPAND_SZ) -> Eintrag für OS/2 (enthält: "%SystemRoot%\system32\os2ss.exe")
  • Posix (REG_EXPAND_SZ) -> Eintrag für Posix (enthält: "%SystemRoot%\system32\psxss.exe")

Damit die Änderungen wirksam werden, müssen Sie den Rechner neu starten.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2602.htm


Pfad für die Service Pack Dateien ändern

Wenn Sie ein Windows Service Pack (SP) auf Ihrem Computer installieren, wird dabei evtl. ein Ordner mit - durch das Service Pack aktualisierten Dateien - erstellt, der eingesetzt werden kann, wenn die Funktionalität eines Servers und /oder einer Arbeitsstation erweitert werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup

oder als Policies

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Setup

Hier finden Sie den Wert "ServicePackSourcePath" als Datentyp REG_SZ, wo Sie nun einen neuen Speicherort angeben können.

Geben Sie den neuen Speicherort für die Dateien ein. Bei diesem Speicherort kann es sich entweder um ein lokales Laufwerk oder um einen UNC-Pfad handeln, der auf eine Netzwerkfreigabe verweist. Sie müssen mit den Pfad oberhalb des Ordners "I386" verweisen, da der SetUpAPI-Aufruf "\I386" an den Quellpfad anhängt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Windows-Service Pack-Installationsdateipfad angeben

Info Wird der Eintrag über den Policy gesetzt, gilt die Konfiguration nur für den Windows-Dateischutz, wenn die Einstellung über die Gruppenrichtlinienobjekte erfolgt. Diese Einstellungen gelten nicht für Elemente, die das Setup-API verwenden, um die Installation durchzuführen. Wird die Einstellung dort benötigt, müssen Sie den oberen Registryeintrag dafür verwenden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=833615

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0844.htm


Analyse eines Bluescreens

Durch fehlerhafte Treiber oder defekte Hardware kann unter Windows der "Bluescreen of Death" (BSOD) auftreten. Hier soll kurz erklärt werden, wie man diesem Fehler etwas auf die Spur kommen kann.

Einstellungen für Systemfehler

In der "Systemsteuerung" -> "System" finden Sie unter dem Tabreiter "Erweitert" im Bereich "Starten und Wiederherstellen" den Button "Einstellungen". Öffnen Sie über diesen Button das neu Fenster "Starten und Wiederherstellen".

Unterhalb von "Systemfehler":

Automatisch Neustart durchführen:

Hier sollten Sie den Haken entfernen (außer es handelt sich um einen Server, der wieder neu hochfahren soll, und wenn Sie Glück haben, dann auch weiter läuft). Ansonsten sollte man den Fehler lieber in Ruhe lassen. Einen Neustart kann man dann auch händisch durchführen.

Alle anderen Felder in diesen Bereich sollten Sie angekreuzt lassen.

Unterhalb von "Debuginformationen speichern" finden Sie folgende Einstellungen:

Art des Speicherabbildes:

Hier reicht für die meisten Anwender völlig die Einstellung "Kleines Speicherabbild" aus, da man mit den restlichen Informationen in den meisten Fällen sowieso nichts anfangen kann.

Verzeichnis für kleines Speicherabbild:

Hier wird das Verzeichnis festgelegt, wo das Speicherabbild abgelegt werden soll. Der Standardeintrag ist hier "%SystemRoot%\Minidump". Das Verzeichnis "Minidump" wird automatisch angelegt, sobald ein Speicherabbild erzeugt wird.

Bildschirmeldung

Hier finden Sie oft schon Informationen zum Fehler, die weiterhelfen können. Diese Meldung enthält immer eine Zeile die mit "*** STOP" und einer achtstelligen Hexadezimalzahl beginnt. Diese Nummer liefert einen ersten Hinweis auf die Art des Fehlers, welche aber nicht leicht zu interpretieren ist (siehe dazu Tipp: Fehlermeldungen: IRQL_not_less_or_equal).

In der Nähe befindet sich oft eine kurze Beschreibung des Fehlers, welche oftmals mit IRQL_NOT_LESS_OR_EQUALoder INACCESSIBLE_BOOT_DEVICE beginnt, und damit zumindest ein gutes Stichwort für eine Internetsuche bietet.

Wird noch ein Dateiname angegeben (meist mit der Dateiendung .sys), haben Sie damit auch gleich noch eine verdächtige Datei, leider muss diese Datei aber nicht immer der Übeltäter sein.

Weitere Analyse mit der DUMP-Datei

Zum Öffnen der DUMP-Datei benötigen Sie ein entsprechendes Debugging-Tool, welches Sie sich von Microsoft herunterladen können:

Download (11,3 MB): http://msdl.microsoft.com/download/symbols/debuggers/dbg_x86_6.4.7.2.exe

Nachdem Sie das Programm installiert haben, können Sie den Debugger über "Start" -> "Programme" -> "Debugging Tools für Windows" -> "WinDbg" starten.

Damit Sie mit dem Debugger wirklich sinnvoll Arbeiten können, werden auch noch die sog. Symboldateien benötigt. Da die aber vollständig mit ca. 170 MByte zu Buch schlagen, sie aber sicherlich nicht täglich solche Dumpdateien auswerten wollen, sollten Sie lieber einstellen, dass WinDbg sich selber die benötigten Dateien aus dem Internet holt.

Stellen Sie dafür Folgendes ein:

Im Menü "File" -> "Sybol File Path" tragen Sie in die Eingabebox ein:

"SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols".

Anschließend öffnen Sie mit dem Programm die Dumpdatei aus dem Verzeichnis "%SystemRoot%\Minidump" über "File" -> "Open Crash Dump"

Jetzt wird die Datei geladen und die Informationen dazu angezeigt. Dabei werden zwei Fenster geöffnet "Command" und "Disassembly". Das Fenster "Disassembly" können Sie ruhig wieder schließen, da deren Auswertung doch schon erhebliche Programmierkenntnisse voraussetzt.

Das "Command"-Fenster enthält dagegen meist schon durchaus wertvolle Informationen. Die interessanten Informationen finden Sie im Abschnitt:

***************************

* Bugcheck Analysis *

***************************

Hier finden z.B.: hinter "BugCheck" einen Fehlercode. Diesen Fehlercode können Sie anschließend auch für die Suche in der Microsoft Knowledge Base (http://support.microsoft.com/search/) verwenden. Ist der Fehlercode bekannt, finden Sie hier meist genauere Angaben dazu, welcher Treiber diesen Fehler verursacht hat und oft auch entsprechende Lösungsansätze.

Sie können aber auch im Debugger schon mehr über diesen Fehlercode ermitteln. Geben Sie dafür im Command-Fenster den Befehl "!analyze -v" ein.

Anschließend werden eine Menge von Informationen ausgegeben; hier ist in den ersten Zeilen das in Grossbuchstaben geschriebene Wort, welches die Art des Fehlers wiedergibt.

Wenn Sie darüber hinaus noch weitere Informationen aus der Hilfe benötigen, geben Sie im Command-Fenster ".hh [Das Word in Großbuchstaben]" ein.

Weiterhin finden Sie hier auch die Zeile "Probably caused by" (= Fehler verursacht von:). Hier wird angegeben, welche Datei vermutlich den Fehler verursacht hat. Mit dieser Datei kann man auch wieder eine entsprechende Suche im Internet starten.

Hat man einen Dateinamen, kann man sich auch im Command-Fenster weitere Informationen dazu anzeigen lassen. Mit dem Befehl "lm v m[Dateiname]" bekommen Sie weitere Infos. Dabei muss der Dateiname ohne Dateiendung eingegeben werden. Der Dateiname wird direkt, gleich hinter dem Parameter m (ohne Leerzeichen) eingegeben.

Über den Befehl "!devnode 0 1" können Sie sich noch eine Liste aller geladenen Treiber ausgeben lassen.

Kommen Sie damit nicht weiter, können Sie sich über den Befehl "!thread" im Command-Fenster, weitere Informationen anzeigen lassen. Finden Sie in der Ausgabe die Zeile "IRP List", dann sollten Sie sich weitere Informationen über die Adressen ausgeben lassen. Dazu rufen Sie den Befehl "!irp [Addresse]" auf. In der Auflistung finden Sie wieder Treibernamen, die am Fehler beteiligt waren.

Informationen zu Fehlern und dem Debugging finden Sie unter:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/ddtools/hh/ddtools/TOC_Debugging_b61a3911-d5dc-42de-96af-deb0d7df233b.xml.asp?frame=true

Wenn Sie selber nicht weiterkommen und entsprechende Anfragen in Foren usw. stellen wollen, sollten Sie immer alles aus dem Abschnitt "Bugcheck Analysis" als Informationen weitergeben.

Treiber über das Tool "verifier" überwachen

Dafür starten Sie das Tool über "Start" -> "Ausführen" und geben hier "verifier" ein. Anschließend öffnet sich (ab Windows XP) ein Wizard. Dieses Tool überwacht die Treiber, und wenn ein Treiber sich nicht an die Microsoft-Vorgaben hält, wird ein entsprechender Bluescreen mit Debugausgabe erzeugt. Diese Ausgabe kann dann wieder entsprechend ausgewertet werden.

Info Mit diesem Tool sollten sie aber auch vorsichtig umgehen. Da die Überwachung Zeit kostet, sollte es nur für die Fehlersuche verwendet werden. Weiterhin kann das Tool auch dazu führen, dass der Rechner überhaupt nicht mehr hochfährt, so dass eine entsprechende Sicherung von Windows vorhanden sein sollte.

Für die Fehlersuche sind im Wizard folgende Einstellungen sinnvoll:

  • Benutzerdefinierte Einstellungen erstellen (für Entwickler)
    -> Button „Weiter“
  • Vordefinierte Einstellungen aktivieren:
    Standardeinstellungen -> aktivieren
    Simulierung geringer Ressourcen -> aktivieren
    -> Button „Weiter“
  • Nicht signierte Treiber automatisch wählen“
    -> Button „Weiter“
    Info: Hier kann es auch sinnvoll sein, wenn man einen Verdacht hat, über „Treiber aus einer Liste wählen“ nur einen entsprechenden Treiber zu überwachen
  • Klicken Sie auf „Fertig stellen“

Nach einem Neustart werden die Treiber von Windows überwacht.

Links

Info Gastbeitrag (PC Professionell): "Windows XP - Bluescreen-Analyse":
http://www.microsoft.com/downloads/details.aspx?FamilyID=46f72ffa-8a82-499a-a459-50cffcca5d1b&displaylang=de

Info Problem Behandlung bei "STOP" Fehlermeldungen: http://www.jasik.de/shutdown/stop_fehler.htm

Info Fehlermeldungen: IRQL_not_less_or_equal

Übersicht der Fehlercodes für 95/98 und ME:

http://support.microsoft.com/default.aspx?scid=kb;en-us;q150314

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1999.htm


Fehlermeldungen mit mehr Aussagekraft

Wenn Windows 2000 abstürzt, bekommen Sie eine Fehlermeldung ausgegeben. Wird dieser Fehler durch einen Treiber ausgelöst, sieht die Fehlermeldung folgendermaßen aus:

STOP: 0x000033366 (X1,X2,X3,X4) PROCESS_HAS_LOCKED_PAGES

X1 immer 0

X2 Adresse des Prozesses

X3 Die Pagenummer

X4 Der Zeiger auf den Treiber, der den Fehler ausgelöst hat.

Den meisten Leuten (mir auch) nützt dieser Zeiger recht wenig :-).

Wenn Sie also auch gern wissen möchten, welcher Treiber nun diesen Fehler ausgelöst hat, müssen Sie folgendes in die Registry Eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Erstellen Sie hier einen neuen Eintrag mit dem Namen "TrackLockedPages" als Datentyp REG_DWORD, setzen Sie den Wert auf 1 und starten Sie den Rechner neu.

Wenn der Rechner jetzt einmal wieder wegen fehlerhafter Treiber abstürzt, sieht die Fehlermeldung folgendermaßen aus:

STOP: 0x000033366 (X1,X2,X3,X4) DRIVER_LEFT_LOCKED_PAGES_IN_PROCESS

X1 Die Adresse des Treibers, der die Seite gesperrt hat

X2 Der Aufruf der Adresse des Treibers, der die Seite gesperrt hat

X3 Der Zeiger auf die MDL welcher die gesperrte Seite angesprochen hat

X4 Der Name des Treibers, der den Fehler verursacht hat

Unter X4 wird Ihnen jetzt der Name des Treiber angezeigt, der Schuld an dem Fehler war. Diese Meldung hilft meist etwas mehr.

Beseitigen Sie den Fehler und entfernen Sie den Eintrag wieder aus der Registry

Info Sie dürfen diesen Eintrag auf keinen Fall auf 0 setzen, das funktioniert nicht!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0847.htm


USER Logfile für Fehlersuche aktivieren

Unter Windows NT 4.0 musste man die Datei "USERENV.DLL" gegen eine DEBUG-Version austauschen, um ein LOG-File für die Fehlersuche zu erhalten. In diesem Logfile wird das Abarbeiten der USER Profile und der System Policy protokolliert.

Ab Windows 2000 ist die Funktion schon im System integriert, sie muss nur noch über die Registry aktiviert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Legen Sie hier einen neuen Wert mit dem Namen "UserEnvDebugLevel" als Datentyp REG_DWORD an. Setzen Sie den Wert:

Wert (Hex) | Beschreibung
0 | Log ausschalten
10001 | Log mit Standardausgabe (Standard)
10002 | Log mit erweiterter Ausgabe
20001 | Debugging Datei mit Standardausgabe
20002 | Debugging Datei mit erweiterter Ausgabe

Nach einem Neustart finden Sie das Logfile unter: "%SYSTEMROOT%\Debug\UserMode\Userenv.log"

Info Weitere Infos für ein LOG-File zur "Group Policy" finden Sie unter:
Erweitertes Group Policy Log erstellen
Erweiterte Log-Einträge für die Fehlersuche
Protokollierung im Gruppenrichtlinien Editor

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0464.htm


Fehlermeldung bei der Installation von Programmen unter Windows 2000

Wenn Sie bei der Installation von Programmen unter Windows 2000 fälschlicherweise die Fehlermeldung erhalten, dass Sie eine Beta-Version einsetzen, liegt das an einem falschen Versions-Eintrag in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Active Setup\ Installed Components\ {89820200-ECBD-11cf-8B85-00AA005B4383}

unter dem Eintrag "Version" dürfte eine ältere Versionsnummer stehen. Ändern Sie diese Nummer auf "5,00,2920,0000" ab.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0804.htm


Fehlermeldung: 'Sie müssen den Computer neu starten, um die Installation eines Programms oder Updates abzuschließen'

Erscheint bei Ihnen, wenn Sie die Windows Update Site besuchen immer die Fehlermeldung: "Sie müssen den Computer neu starten, um die Installation eines Programms oder Updates abzuschließen" mit dem Fehlercode: "0x8DD0007" und Sie haben den Rechner aber schon neu gestartet, liegt es an alten Einträgen die in der Registry zurückgeblieben sind.

Damit Sie wieder neue Updates herunter laden können, müssen Sie den folgenden Eintrag in der Registy löschen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ WindowsUpdate\ Auto Update

löschen Sie hier den Schlüssel "RebootRequired" und starten Sie den Rechner neu. Jetzt sollten die Updates wieder gehen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2046.htm


Kopierschutz von CDs sorgt für Meldung 'falsche CD'

Kopierschutz von CDs sorgt für Meldung "falsche CD"

Auf einigen Windows 2000-Systemen ist zu beobachten, dass bei aktiviertem DMA-Modus für das CD-ROM/DVD-Laufwerk der Kopierschutz von Spielen / Programmen versagt.

Deaktiviert man den DMA-Modus (Kontextmenü des Arbeitsplatzes -> Eigenschaften) -> "Hardware" -> "Gerätemanager" -> Eigenschaften des jeweiligen IDE-Controllers, funktioniert auch wieder das betreffende Programm. Sollte es dennoch zu Problemen kommen oder möchte man den DMA-Modus nicht deaktivieren, helfen vielleicht die Deamon-Tools unter http://www.daemon-tools.cc , welche den Kopierschutz emulieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1179.htm


TEAC CDR55S funktioniert nicht (Lampe ständig an)

Auch mit den neusten Brennprogrammen und ASPI-Treibern ist der TEAC CDR55S Brenner nicht zum Funktionieren zu bewegen. Die Kontrollleuchte ist ständig an.

Abhilfe schafft das Firmware Update Version R von Teac unter

http://www.teac.de/support/

Danach läuft der Brenner ohne Probleme mit allen bekannten Brennprogrammen.

Info Das Update kann nur unter Windows 9x/NT eingespielt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0865.htm


Loggen von Systemereignissen ein-/ausschalten

In der Ereignisanzeige (eventvwr.msc) werden Meldungen von Windows und Windows-Programmen aufgezeichnet. Hier werden z.B. Einträge von An/Abmeldungen, Abstürzen usw. eingetragen.

Die Einträge aus der Ereignisanzeige werden im Verzeichnis "%SYSTEMROOT%\System32\WBEM\LOGS" abgelegt.

Mit diesem Tipp können Sie das Aufzeichnen der Meldungen ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ WBEM\ CIMOM

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableEvents" als Datentyp REG_SZ. Setzen Sie den Wert auf:

0 | Keine Events mehr aufzeichnen
1 | Events aufzeichnen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2185.htm


CHM-Hilfe-Dateien werden nicht mehr angezeigt

Wird eine CHM-Datei geöffnet, erscheint die folgende Fehlermeldung: "Datei konnte nicht gestartet werden:mk:@MSITStore:C:\ ... (Pfad der jeweiligen chm.-Datei)" auf der rechten Seite im Content, meist wird das Inhaltsverzeichnis auf der linken Seite noch angezeigt. Auch kann über Start nicht mehr "Hilfe und Support" gestartet werden.

Dieser Fehler wird durch das Sicherheitspatch "KB986358" verursacht, welcher die Anzeige von CHM-Dateien deaktiviert die nicht lokal aufgerufen werden.

Mit den unteren neuen Registrywerten kann man die Anzeige von CHM-Dateien konfigurieren. Sie müssen hier den Wert auf 2 setzen, damit die CHM-Dateien auch wieder angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

(für Helpfiles)

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ HTMLHelp\ 1.x\ HHRestrictions

(für das "InfoTech"-Protokoll)

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ HTMLHelp\ 1.x\ ItssRestrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxAllowedZone" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

Wert | lokal | Intranet | Vertrauenswürdige Sites | Internet | Eingeschränkte Sites
0 | erlaubt | gesperrt | gesperrt | gesperrt | gesperrt
1 | erlaubt | erlaubt | gesperrt | gesperrt | gesperrt
2 | erlaubt | erlaubt | erlaubt | gesperrt | gesperrt
3 | erlaubt | erlaubt | erlaubt | erlaubt | gesperrt
4 | erlaubt | erlaubt | erlaubt | erlaubt | erlaubt

Weiterhin können Sie auch bestimmte Netzwerklaufwerke für die Anzeige von CHM-Dateien freischalten:

Unter:

(für Helpfiles)

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ HTMLHelp\ 1.x\ HHRestrictions

(für das "InfoTech"-Protokoll)

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ HTMLHelp\ 1.x\ ItssRestrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "URLAllowList" als Datentyp REG_SZ. Hier geben Sie jetzt den Netzwerkpfad folgendermaßen ein:

\\ServerName\Freigabename\;file://\\ServerName\Eulanda\

Der zusätzliche Eintrag mit dem Präfix file:// ist hierbei wichtig. Sie müssen also immer zwei Einträge hinzufügen, um einen UNC-Pfad zu einem freigegebenen Netzwerkordner zu aktivieren.

Wenn Sie eine Webseite dafür freigeben wollen, geben Sie folgendes ein:

http://www.winfaq.de

Sie können mehrere Einträge durch ein Semikolon getrennt eingeben.

Ein weiterer Fehler

Weiterhin kann auch eine Ursache sein, dass entsprechende DLL welche für die Anzeige benötigt werden, nicht mehr richtig registriert sind. Führen Sie bitte folgendes aus:

Öffnen Sie die Eingabeaufforderung (Start -> Aufführen -> CMD.EXE)

Geben Sie hier ein:

regsvr32 hhctrl.ocx

regsvr32 itss

Anschließend sollte der Fehler behoben sein.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=896054
http://support.microsoft.com/?kbid=896358
http://support.microsoft.com/?kbid=892675

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2026.htm


Suchfunktion für Treiberquellen festlegen

Wenn Sie einen Treiber installieren, sucht Windows diesen Treiber auf unterschiedlichen Quellen. Hier können entsprechende Quellen ausblenden auf denen Windows nicht mehr nach Treibern suchen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DriverSearching

Erstellen Sie hier jeweils einen neuen Wert mit dem Namen aus der Tabelle als Datentyp REG_DWORD. Setzen Sie den Wert auf 1 um diesen Eintrag auszublenden:

DontSearchFloppies | Diskettenlaufwerke deaktivieren
DontSearchCD | CD Laufwerke deaktivieren
DontSearchWindowsUpdate | Windows Update deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1455.htm


Windows 2000 Versionsübersicht

Windows 2000 Professional

Nachfolger von Windows NT Workstation mit Multimedia Funktionen und der Oberfläche von Windows 98.

Eigenschaften:

Bis zu zwei Prozessoren

Bis zu 4 GByte Arbeitsspeicher

Windows-98 Outfit

Repariert Dateien selbst

Software-Setup über Netzwerk (Automatisch)

Hardwareanforderung:

Prozessor: Intel Pentium kompatibel mit 166 MHz oder höher

Speicher: 64 MB RAM

Festplatte: 1 GB freie Harddisk-Kapazität auf einer 2-GB-Platte

Windows 2000 Server

Nachfolger von Windows NT Server, die Vorteile des Server Betriebssystems liegen im Applikations-, Web-, Datei- und Druckdienstbereich.

Eigenschaften:

Bis zu vier Prozessoren

Bis zu 4 GByte Arbeitsspeicher

Umfangreiche Internet- und Web-Unterstützung

Active Directory

Windows Management Tools

Kerberos- und PKI-Unterstützung

Windows Terminal-Dienste

COM+ Komponentendienste

Hardwareanforderung:

Prozessoren: Intel Pentium 200 MHz oder höher (max. 4 Prozessoren)

Speicher: 256 MB RAM (max. 4 GB)

Festplatte: 1 GB freie Harddisk-Kapazität auf einer 2-GB-Platte

Windows 2000 Advanced Server

Nachfolger der Windows Enterprise Server Version mit den Erweiterungen der Basisversion des Windows 2000 Server.

Eigenschaften:

Bis zu acht Prozessoren

Bis zu 4 GByte Arbeitsspeicher

Alle Windows 2000 Server Funktionen enthalten

Load Balancing der Komponenten

Load Balancing im Netzwerk

Sicherheit gegen Ausfall durch Clustering

Hardwareanforderung

Prozessoren: Intel Pentium 200 MHz oder höher (max. 8 Prozessoren)

Speicher: 256 MB RAM (max. 8 GB)

Festplatte: 1 GB freie Harddisk-Kapazität auf einer 2-GB-Platte

Netz: Clustering mit zwei Knoten

Windows 2000 Datacenter Server

Die Highend Server. Kann auf "mehr" Hardware zurückgreifen, für Unis oder Rechenzentren.

Eigenschaften:

Bis zu 32 Prozessoren

Bis zu 64 GByte Arbeitsspeicher

Sonst wie Advanced Server.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0981.htm


Windows 2000 Infos

Windows 2000 Infos zu Beta 3 Build: 2128

Windows 2000 liegt jetzt in der Beta 3 (Deutsch und Englisch) vor. MS hat bei sich selber schon viel auf Windows 2000 umgestellt und will die endgültige Version noch in diesem Jahr auf den Markt bringen.

Da ich auch die Beta-Version teste, habe ich mich entschieden, schon einmal einige Informationen mit in die FAQ einzubauen. Alle Infos beziehen sich auf die Beta 3 Build: 2128 (Deutsche und Englische Version).

Es wird 4 unterschiedliche Versionen von Windows 2000 geben

  1. Windows 2000 Professional
    entspricht der heutigen WS Version
    - für max. 2 Prozessoren
  2. Windows 2000 Server
    entspricht der heutigen Server Version
    - für max. 4 Prozessoren
    - enthält auch die Terminal Services
  3. Windows 2000 Advanced Server
    entspricht der heutigen Enterprise Server Version
    - für max. 8 Prozessoren
  4. Windows 2000 Datacenter Server
    diese Version wird wohl erst etwas später erscheinen und soll als großer Unterschied mehr CPUs und größere Cluster unterstützen als die anderen Server Versionen
    - bis zu 32 Prozessoren

Was hat sich gegenüber Windows NT verändert?

  1. Verbessertes Plug and Play
  2. Power Management
  3. Schützen der DLL-Dateien vor fehlerhaften Installationsprogrammen
  4. Zusammenfassung der Systemverwaltungswerkzeuge
  5. Intelli Mirror (für Besitzer zum automatischen Abgleich der Dateien mit dem Netzwerk)
  6. NTFS5 (transparente Kompression, Verschlüsselung)
  7. FAT32
  8. Active Directory
  9. DirectX
  10. USB Unterstützung
  11. Verbesserte Reparaturfunktionen
  12. Es sind viel weniger Systemstarts nötig beim Verändern von Systemeigenschaften
  13. Transaction und Message Queue Server sind in der Serverversion als (D)COM integriert
  14. Programme können unter einem anderen Benutzerkontext gestartet werden.

Die Oberfläche ist jetzt sehr stark an Windows 98 angelehnt. Man wird an fast allen Stellen mit Tipps und Hilfetexten überschüttet. Offensichtlich hat MS zur Zeit noch keine Möglichkeit vorgesehen, diese Hilfen auch auszuschalten (jedenfalls nicht über die Oberfläche). Einen erfahrenen Anwender werden diese Hilfen mit der Zeit aber eher stören als helfen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0658.htm


Welche Daten werden beim Backup nicht berücksichtigt?

In der Registry wird unter einem Schlüssel festgelegt, welche Dateien Windows bei einem Backup nicht beachtet bzw. welche Registry-Schlüssel bei einem Restore nicht zurückgeschrieben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ BackupRestore\ FilesNotToBackup

finden Sie die Auflistung der Dateien, die vom Backup nicht beachtet werden.

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ BackupRestore\ KeysNotToRestore

hier finden Sie die Auflistung der Registry-Schlüssel, die beim einem Restore nicht zurückgeschrieben werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0499.htm


Was macht die Datei SVCHOST.EXE?

Wenn Sie unter Windows den Taskmanager starten, werden Sie unter Prozesse feststellen, dass dort die Datei SVCHOST.EXE mehrmals aufgeführt wird.

Die Datei SVCHOST.EXE ist ein generischer Prozessname für Dienstgruppierungen, unter der unterschiedliche DLLs laufen. Beim Starten von Windows wird

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Svchost

geprüft, welche Dienste zu einer Dienstgruppierung zusammengefasst werden sollen. Hier finden Sie unterschiedliche Schlüsselnamen als Datentyp REG_EXPAND_SZ, in dem alle zu dieser Gruppe gehörenden Dienste mit ihren "Dienstnamen" aufgelistet sind.

Den benötigten Aufruf des jeweiligen Dienstes für die SVCHOST.EXE finden Sie unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ <Dienstname>\ Parameters

Hier wird der Pfad und Dateiname unter dem Wert "ServiceDll" als Datentyp REG_EXPAND_SZ für den Dienst angegeben.

Die Anzahl der Einträge unter dem Registry-Schlüssel "Svchost" sind unterschiedlich - je nachdem, ob es sich um die Server oder Professional Version von Windows 2000 handelt bzw. welche zusätzlichen Programme noch installiert wurden.

Diese Gruppen wurden eingeführt, um die Fehlersuche zu erleichtern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0505.htm


Was bedeutet die Datei hiberfil.sys

Ab Windows XP gibt es unter %Systemdrive% die Datei "hiberfil.sys". Diese Datei ist genauso groß wie Ihr Arbeitsspeicher im Rechner und wird dafür genutzt, den Inhalt des Arbeitsspeichers zu sichern, wenn Sie den Rechner in den StandBy Modus fahren.

Wenn Sie diese Funktion nicht benutzten, bzw. ein Image von Ihrer Installation erzeugen wollen, können Sie diese Datei getrost löschen, bzw. diese Funktion deaktivieren.

Unter "Einstellungen" -> "Systemsteuerung" (Control Panel) -> "Energieoptionen" (Power Options) unter dem Tabreiter "Ruhezustand" (Hibernate) müssen Sie nur die Funktion "Ruhezustand aktivieren" ausschalten.

Windows löscht diese Datei jetzt von alleine.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1390.htm


Warum werden im Gerätemanager einige Geräte nicht angezeigt?

Im Gerätemanager von Windows werden einige Geräte nicht angezeigt. So werden standardmäßig nicht-Plug-and-Play Geräte ausgeblendet.

Um alle erkannten Gerätetreiber anzeigen zu lassen, gehen Sie folgendermaßen vor:

Starten Sie unter "Systemsteuerung" -> "Verwaltung" die "Computerverwaltung". Klicken Sie hier unter "System" mit der rechten Maustaste auf den "Geräte-Manager" und wählen Sie "Ansicht". Aktivieren Sie hier "Ausgeblendete Geräte anzeigen".

Jetzt werden im Gerätemanager alle erkannten Geräte angezeigt.

Info Damit auch "ausgeblendete Geräte" angezeigt werden, beachten Sie den Tipp: "Gerätemanager soll mehr Informationen anzeigen"

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0803.htm


Alte MUSTEK Scanner auch unter Windows 2000 einsetzen

Dieser Tipp ist eigentlich nicht mehr notwendig, da Sie auf der Homepage mit Angabe der Serienummer auch für Windows 2000/XP Treiber für Ihren alten Scanner herunterladen können. Wir lassen den Tipp aber so trotzdem noch in der FAQ.

Alte Mustek Scanner können Sie mit einigen Tricks auch unter Windows 2000 noch benutzen. Hier werden zwei Beispiele angegeben, die auch für andere Scannertypen funktionieren könnten:

ScanExpress 6000p

Mustek 600 II und Paragon 1200 SP

ScanExpress 6000p

MUSTEK bietet für die alten Parallelport-Scanner wie ScanExpress 6000p keine Treiber mehr für Windows 2000 an. Die NT-Treiber funktionieren leider auch nicht. Es gibt trotzdem eine Möglichkeit, den Scanner unter Windows 2000 zu nutzen. Gehen Sie dazu folgendermaßen vor:

Kurze Möglichkeit von Agi

  1. Installieren Sie den alten NT 4.0 Treiber
  2. In der Registry nach "AB306p" suchen
  3. Den Inhalt des Schlüssels "DependOnGroup" löschen
  4. Fertig

Geht auch unter XP

Altes Vorgehen:

  1. Installieren Sie den alten NT 4.0 Treiber
  2. Unter %SYSTEMROOT%\System32\drivers suchen Sie nach dem Namen des Scannertreibers, (z.B. a4sii300.sys oder ab306p.sys) je nach Scanner unterschiedlich. Notieren Sie sich diesen Treibernamen
  3. Installieren Sie nun die Treiber des UMAX 610P Scanners (diesen Treiber finden Sie auf der Windows 2000 CD)
  4. Starten Sie den Registryeditor (REGEDIT.EXE)und lassen Sie durch "Bearbeiten" -> "Suchen" die Registry nach den Eintrag "UMAXPCLS.SYS" durchsuchen. Ersetzen Sie diesen Namen durch den unter Punkt 2 notierten Treibernamen
  5. Starten Sie Windows neu
  6. Sie haben jetzt zwei Scanner installiert. Im Control Panel finden Sie noch den Eintrag des UMAX-Scanners, der aber nicht funktioniert. Wenn Sie aber Ihr Bearbeitungsprogramm öffnen, können Sie aus der Auswahlliste auch Ihren Scanner auswählen, der dann funktionieren sollte.

Der Tipp kommt von M. Rübig, der folgenden Eintrag in der Registry ändern musste:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ UMAXPCLS

Den String "ImagePath" mit dem Inhalt "System32\DRIVERS\UMAXPCLS.SYS" muss man nur umändern in "System32\DRIVERS\a4sii300.sys"

Danach funktionierte der Scanner auch unter Windows 2000. Das Vorgehen ist etwas umständlich, aber MUSTEK verweigert leider jeden Support.

Mustek 600 II und Paragon 1200 SP

Einen Treiber für den Paragon 1200 Service Pack finden Sie unter http://www.mustek.de

Treiber: http://driver.mustek.de/p/scsi/1200sp/win2k/p1200sp.exe

Beim Mustek 600 II CD am SCSI-Anschluss von einem Adaptec 2940AU Controller gehen Sie folgendermaßen vor:

Von http://www.adaptec.com/worldwide/support/driverdetail.html?filekey=aspi32.exe einen aktuellen ASPI-Treiber (ASPI32.EXE) herunterladen.

Bitte folgende Treiber von Mustek besorgen:

mustek.inf

fbspnt35.exe

1p32bit.exe

Jetzt in der Datei Mustek.inf den Absatz

[Version]
Signature=$Windows 95$
Class=SCSI-Scanner
Provider=Mustek

durch folgenden ersetzen.

=== Hier schneiden ===

[Version]
LayoutFile=Layout.inf, Layout1.inf, Layout2.inf
Signature="$CHICAGO$"
Class=Image
ClassGUID={6bdd1fc6-810f-11d0-bec7-08002be2092f}
Provider=MUSTEK
DriverVer=12/07/1999,5.00.2195.1

=== Hier schneiden ===

Wenn dieses alles gegeben ist, sollte der Scanner an einem Adaptec 2940 Controller nach folgender Installation laufen:

  1. Wenn "?" im Geräte-Manager angezeigt wird, dann Treiber-aktualisieren, sonst bei der Neu-Installation den Pfad auf die geänderte Mustek.inf Datei setzen.
  2. ASPI32.EXE installieren
  3. fbspnt35.exe installieren und Rechner nicht neu starten, sondern gleich 1p32bit.exe installieren und Rechner neu BOOTEN.

Jetzt müsste der Scanner laufen. Testen z.B. mit Imaging aufrufen und Scanner anwählen und scannen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0951.htm


Software zum Defragmentieren aus Windows 2000 entfernen

Wenn Sie das Defragmentierungsprogramm selber aus Windows 2000 entfernen wollen, werden Sie schnell feststellen, dass Windows 2000 das so nicht zulässt. Selbst wenn Sie nur die Dateien direkt löschen, werden die Dateien von Windows wiederhergestellt (SFP).

Im Internet finden Sie das Programm DfrgFree. DfrgFree ist in der Lage, das Programm von Ihrem System zu entfernen.

Homepage: http://www.heise.de/ct/ftp/00/05/148/

Programm: ftp://ftp.heise.de/pub/ct/listings/0005-148.zip

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0508.htm


Programme unter einem anderen Benutzeraccount ausführen (RUNAS.EXE)

Programme unter einem fremden Benutzeraccount ausführen (RUNAS.EXE)

Ab Windows 2000 haben Sie jetzt mit dem Befehl RUNAS die Möglichkeit, Programme unter einem anderem Benutzerkontext (Account) auszuführen, als unter dem Sie selber gerade angemeldet sind. So können Sie z.B. gerade als Normaler-Domänen-User angemeldet sein, aber den USER-Manager mit einem Administrator Account öffnen. Das hat den Vorteil, dass evtl. auftretende Viren nicht mit Administrator-Berechtigungen über Ihren Account etwas ausführen können, und so der Schaden meist begrenzt wird.

Sie können den Befehl in der Kommandozeilenoberfläche (RUNAS) benutzen oder im Explorer mit gedrückter Schifttaste und der rechten Maustaste auf die entsprechende Datei klicken, dann finden Sie im Kontextmenü den Eintrag "Ausführen als..." wo sie dann nach einem Benutzeraccount gefragt werden.

Parameter von RUNAS:

RUNAS [/profile] [/env] [/netonly] /user:<Benutzername> Programm

/profile | Falls das Benutzerprofil geladen werden muss.
/env | Um die aktuelle Umgebung zu verwenden, anstatt die des Benutzers.
/netonly | Falls Anmeldeinformationen nur für den Remotezugriff gültig sind.
/user | <Benutzername> muss in der Form Benutzer@Domäne oder Domäne\Benutzer angegeben werden.
/savecred | Speichert das Passwort ab (Windows XP Prof.)
Programm | Befehlszeile einer ausführbaren Datei. Siehe unten aufgeführte Beispiele.

Beispiele:

> runas /profile /user:Computer\Administrator cmd

> runas /profile /env /user:Domäne\Admin "mmc %WINDIR%\system32\dsa.msc"

> runas /env /user:Benutzer@Domäne.Microsoft.com "notepad \"Meine Datei.txt\""

Info Geben Sie das Benutzerkennwort nur ein, wenn Sie dazu aufgefordert werden.

Info Der DIENST muss gestartet sein, damit RUNAS auch funktioniert.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1010.htm


Kein Ruhezustand, angeblich wegen SCSI-Adapter oder Diskettenlaufwerk

Wenn Windows meldet, dass es nicht in den Ruhezustand gehen kann, weil der Treiber des SCSI-Adapters dies verhindert, ist vermutlich NERO (Brennprogramm) auf dem System installiert.

Die Datei NeroCDNT.sys (im Windows System-Drivers-Verzeichnis) ist der Übeltäter. Diese Datei kann man auf den meisten Systemen gefahrlos löschen, ohne das NERO nicht mehr funktionieren würde.

Die Ursache kann aber auch in der Software der ISDN-Anlage EUMEX 504 USB liegen:

Im "RVS-CommCenter" muss in der Registerkarte -> Allgemein bei "PC Power-Management" die Option: "Standby-Modus zulassen, wenn Anrufannahme aktiv" eingestellt sein, dann geht auch hier der Ruhezustand.

Folgende Dateien können ebenfalls den Ruhezustand verhindern:

  1. c2scsi.sys aus WinOnCD führt zur Meldung "...SCSI bzw. RAID-Gerätetreiber verhindert den Ruhezustand.Adobe Type Manager
  2. atmhelpr.sys aus Adobe PhotoDeluxe führt zur Meldung "... Standardtastaturtreiber bzw. PS/2 Gerätetreiber verhindert Ruhezustand.
  3. Pgpmemlock.sys und Pgpdisk.sys: Programm pgpdisk 6.02 und 6.5

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=314118

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0460.htm


Ausgeblendete Geräte im Gerätemanager anzeigen

Standardmäßig zeigt der Gerätemanager nur einige wenige Informationen über die Geräte an und blendet alle Geräte aus die nicht mehr vorhanden oder angeschlossen sind. Wenn Sie mehr Informationen erhalten wollen bzw. diese Geräte auch angezeigt werden sollen, müssen Sie folgende Variablen setzen:

Unter:

-> Systemsteuerung -> System, Tabreiter "Erweitert" klicken Sie auf den Button "Umgebungsvariablen" bzw. ab Windows Vista -> Systemsteuerung -> System -> auf der linken Seite "Erweiterte Einstellungen" auswählen -> Tabreiter "Erweitern" auf den Button "Umgebungsvariablen" klicken.

Fügen Sie jetzt folgende Systemvariablen hinzu:

Devmgr_show_details=1 | Zeigt einen erweiterten Tabreiter mit Details an
Devmgr_show_nonpresent_devices=1 | Zeigt auch Geräte an, die in der aktuell laufenden Konfiguration nicht vorhanden sind

Sie können die Variablen auch gleich selber in die Registry Eintragen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Environment

erstellen Sie hier die beiden oben angegeben Variablen mit den Datentyp REG_SZ. Setzen Sie den Wert auf 1.

Sie können auch folgende Befehle in einem DOS -Fenster eingeben (wenn Sie diese Einstellung nicht für immer fest einbinden wollen):

set devmgr_show_details=1

set devmgr_show_nonpresent_devices=1

start devmgmt.msc

Danach klickt man im gestarteten Gerätemanager auf "Ansicht/Ausgeblendete Geräte anzeigen" an, um die Ansicht der Geräte auch wirklich zu erhalten.

Info Die Geräte welche nicht mehr vorhanden sind, werden als halbtransparente Geräte angezeigt. Sie können diese Einträge auch gefahrlos löschen und somit aus dem System entfernen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1220.htm


Die Microsoft Management Console

Ab Windows 2000 finden Sie jetzt eine Management Console 1.2.

Anwender, die schon mit SMS 7.0 gearbeitet haben, werden diese schon kennen, da sie hier schon länger mit installiert wurde.

Die Console wird über MMC.EXE gestartet. Hier können Sie über sog. Snap-In eine Oberfläche zur Verwaltung Ihres Rechner/Netzwerkes aufbauen, wo Sie alle wichtigen Programmaufrufe einbinden und so Ihr Netzwerk übersichtlich verwalten können.

Info Administratoren, die Serversysteme von Windows 2000 Professional aus verwalten wollen, müssen von der Server-CD noch die zusätzlichen Verwaltungstools (Snap-Ins) nachinstallieren. Um die Installation auf der Workstation durchzuführen, starten Sie von der Server CD aus dem I386-Verzeichnis das Installationspaket "adminpak.msi".

Wenn Sie die MMC das erste Mal starten, wird Ihnen nichts angezeigt.

Sie haben jetzt die Möglichkeit, unterschiedliche Verwaltungsoberflächen zu erstellen, die Sie extra abspeichern und so auch anderen Leuten zu Verfügung stellen können. Die Oberflächen werden als *.MSC Dateien abgespeichert. MS liefert im SYSTEM32-Verzeichnis schon einige fertige Verwaltungsoberflächen mit aus.

Dateiname | Beschreibung
azman.msc | Autorisierungs-Manager
Certmgr.msc | Zertifikate für Benutzer, Computer oder Dienste verwalten
certsrv.msc | Zertifizierungsstelle
certtmpl.msc | Zertifikatvorlagen
Ciadv.msc | Übersicht über den Indexdienst
Compmgmt.msc | Verwaltung von lokalen Computern oder Remotecomputern
Dcpol.msc | Standort-Domänencontroller-Sicherheitseinstellungen
Devmgmt.msc | Geräte-Manager stellt die auf Ihrem Computer installierte Hardware in einer grafischen Übersicht dar
Dfrg.msc | Defragmentierungsprogramm
dfsgui.msc | Verteiltes Dateisystem (DFS)
diskmgmt.msc | Datenträgerverwaltung ist ein grafisches Dienstprogramm für die Verwaltung von Datenträgern. Sie ersetzt den Festplatten-Manager
dnsmgmt.msc | DNS-Management
domain.msc | Active Directory-Domänen und Vertrauensstellungen
dompol.msc | Standort-Domänensicherheitseinstellungen
dsa.msc | Active Directory-Benutzer und -Computer
dssite.msc | Active Directory-Standorte und Dienste
faxserv.msc | Mit der Faxdienstverwaltung können Sie Faxe auf dem lokalen Computer oder auf anderen Computern im Netzwerk verwalten
eventvwr.msc | Ereignisanzeige
filesvr.msc | Dateiserververwaltung
fsmgmt.msc | Freigegebene Ordner
gpedit.msc | Mit der Gruppenrichtlinieneinstellungen werden die verschiedenen Komponenten der Desktopumgebung definiert
ias.msc | Internetauthentifizierungsdienst
lusrmgr.msc | Übersicht über Lokale Benutzer und Gruppen
ntmsmgr.msc | Übersicht über Wechselmedien
ntmsoprq.msc | Operatoranforderungen für Wechselmedien
perfmon.msc | Mit dem Systemmonitor können Sie sich Informationen über die Hardwarenutzung und Aktivität von Systemdiensten auf den verwalteten lokalen Computern oder Remotecomputern in Echtzeit anzeigen lassen
rrasmgmt.msc | Routing und RAS
rsop.msc | Richtlinienergebnissatz
secpol.msc | Übersicht über Sicherheitseinstellungen
services.msc | Mit diesem Programm können Sie die Dienste auf einem lokalen oder Remotecomputer starten, beenden, anhalten oder fortsetzen sowie Start- und Wiederherstellungsoptionen konfigurieren
tapimmt.msc | Telefonie
tscc.msc | Terminaldientekonfiguration\Verbindungen
tsmmc.msc | Remotedesktops
wmimgmt.msc | Die WMI-Steuerung (Windows Management Instrumentation Control) ist ein Instrument zur Konfiguration der WMI-Einstellungen auf einem Remotecomputer oder lokalen Computer.
comexp.msc unter System32\Com | Mit dem Verwaltungsprogramm für Komponentendienste können Sie COM-Komponenten und COM+Anwendungen konfigurieren und verwalten
dhcpmgmt.msc | DHCP Verwaltung

Sicherlich werden andere Hersteller für Ihre Programme auch solche fertigen MSC-Dateien anbieten.

Sie haben natürlich auch die Möglichkeit, sich eine eigene MSC-Datei nach Ihren Wünschen zusammenzustellen. Starten Sie dazu die "MMC.EXE", jetzt wird Ihnen eine leere MMC Oberfläche angezeigt.

Info Wenn Sie die MMC mit den Parameter /a starten (mmc /a), wird sie im Autorenmodus geöffnet. Hier haben Sie die Möglichkeit, auch die vorgefertigten Snap-In von MS bearbeiten zu können.

Fügen Sie jetzt über "Konsole" -> "Snap-In hinzufügen/entfernen" -> "Hinzufügen" die von Ihnen benötigten Tools hinzu. Hier erhalten Sie eine Liste aller zur Zeit zu Verfügung stehenden "Snap-Ins". Mit der Zeit werden andere Firmen sicherlich noch weitere "Snap-In-Module" zur Verfügung stellen.

ActiveX-Steuerelement | Steuerungselemente für ActiveX Funktionen
Computerverwaltung | Enthält ein Zusammenstellung vieler anderer Snap-In: - System (Ereignisanzeige, Systeminformation, Leistungsprotokolle, Freigaben, Gerätemanager, Benutzergruppen) - Datenspeicher (Datenträgerverwaltung, Defragmentierungsprogramm, Wechselmedien) - Dienste und Anwendungen (WMI-Steuerung, Dienste, Indexdienst)
Datenträgerverwaltung | Zur Verwaltung der Festplatten und Partitionen
Defragmentierungsprogramm | Zur Defragmentierung von Laufwerken
Dienste | Anzeigen und Verwalten aller Dienste
Ereignisanzeige | Übersicht der Ereignisanzeige
Fax Service Management | Übersicht über die Faxdienste
Freigegebene Ordner | Übersicht über alle freigegebenen Ordner
FrontPage-Servererweiterungen | Verwaltung der Servererweiterungen
Geräte-Manager | Übersicht über die installiere Hardware und die aktiven Treiber
Gruppenrichtlinie | Sicherheitseinstellungen (Entspricht dem Policy-Editor)
Indexdienst | Indexverwaltung
IP-Sicherheitsrichtlinienverwaltung | IP-Sicherheitseinstellungen
Komponentendienste | Verwalten der COM+ Dienste
Leistungsprotokolle und Warnmeldungen | Entspricht dem Ereignisprotokoll und dem Systemmonitor
Lokale Benutzer und Gruppen | User und Gruppenverwaltung
Mit Webadresse verknüpfen | Zugriff auf WEB-Adressen
Ordner | Ordner für die Übersichtlichkeit in der MMC
Sicherheitskonfiguration und -analyse | Erstellen einer aktuellen Sicherheitsdatenbank
Sicherheitsvorlagen | Enthält verschiedene Einstellungen vorgefertigter Sicherheitsstufen
Systeminformationen | Informationen über das gesamte System (Hardware, Software, Treiber usw.)
Wechselmedienverwaltung | Wechselmedienverwaltung (CD-ROM, ZIP usw.)
WMI-Steuerung | Verwaltung des WMI-Dienstes
Zertifikate | Übersicht aller Zertifikate

Info Standardmäßig zeigen einige Snap-Ins (z.B. das "Active Directory-Benutzer und -Computer") nur einen Teil der wichtigen Informationen an. Weitere Funktionen müssen erst unter dem Menüpunkt "Ansicht" aktiviert werden. So finden Sie hier z.B. die Funktion "Erweiterte Funktionen" (hiermit werden einige zusätzliche Informationen eingeblendet) und "Filteroptionen", womit Sie die Anzeige übersichtlicher gestalten können.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0531.htm


Beschreibung des Application Compatibility Tools

Auf der Windows 2000 CD im Ordner "Support" befindet sich das Application Compatibility Tool (apcompat.exe). Das Programm hilft nicht bei Programmen, welche direkt auf Hardware oder Windows 9x spezifische VXDs zugreifen wollen.

Allerdings kann man bei den Programmen das Tool einsetzen, welches eine bestimmte Servicepack-Version von Windows NT erfordern oder Windows ablehnen, da sie nicht davon ausgehen, dass NT über eine DX-Schnittstelle oder USB verfügt.

Die Funktion Disable Heap Manager on Windows 2000 bewirkt, dass die erweiterte Speicherwaltung von Windows 2000 für das spezielle Programm nicht verwendet wird. Einige Programme kommen damit nicht zurecht. Allerdings hat die Einstellung auch zur Folge, dass mehr Arbeitsspeicher benötigt wird.

Der Button Use pre-Windows 2000 Temp Path behebt Probleme bei Programmen, die mit zu langen Pfadangaben für den TEMP-Pfad nicht zurechtkommen (z.B. x:\Dokumente und Einstellungen\Administrator\Profile\temp). Bei Selektion dieses Parameters wird der TEMP Ordner im Root benutzt oder hiermit erstmals erstellt.

Correct Disk Space detection for 2 GB+ drives ist für die Fälle gedacht, wenn ein Programm die Größe des freien Plattenspeichers falsch ermittelt, da Windows 2000 hierfür andere Routinen als das betreffende Programm benutzt.

Zuletzt kann man mit Make the above check box settings permanent die Einstellungen für das betreffende Programm als permanent festlegen, welche dann in der Registry gespeichert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0490.htm


Brennen mit NERO ohne Admin-Rechte

Damit ein Anwender ohne Administrationsrechte unter Windows 2000 auch mit Nero brennen kann, gibt es derzeit folgende Möglichkeit, die von der Fa. Ahead im Support wie folgt bereitgestellt wird:

Sie müssen dafür nur den Patch unter http://www.nero.com/de/631940824944968.html runterladen und ausführen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1145.htm


Applikation Compatibility Mode nach SP2 aktivieren

Microsoft hat im SP2 eine Funktion zur besseren Verträglichkeit mit "alten" Programmen eingebaut. Der sogenannte Applikation Compatibility Mode ist aber standardmäßig nicht aktiviert.

Ruft man auf:

(Start -> Ausführen -> "regsvr32 %SYSTEMROOT%\apppatch\slayerui.dll"),

so steht dem Administrator im Kontextmenü von Verknüpfungen eine neue Funktion zur Verfügung, mit der sich Programme - auch unter Windows 2000 - hoffentlich ausführen lassen.

Weitere Infos gibt es auch unter http://support.microsoft.com/?kbid=279792

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1124.htm


Anwendung wartet auf Eingabe

Wenn Sie mehr als ein Programm gleichzeitig gestartet haben und eine im Hintergrund liegende Anwendung eine Eingabe erwartet, blinkt in der Taskleiste der Button dieser Anwendung 3 einmal und wartet dann 200 Sekunden. Nach dieser Zeit blendet sich die Anwendung automatisch in den Vordergrund.

In der Registry können Sie einstellen, wie oft eine Anwendung blinken soll und wie lange sie wartet, bis sie sich in den Vordergrund schiebt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

finden Sie folgende Werte, mit denen Sie das Verhalten verändern können:

Wertname | Datentyp | Standard | Beschreibung
ForegroundFlashCount | REG_DWORD | 3 | Gibt an, wie oft sich die Anwendung in der Taskleiste bemerkbar macht, bis Sie automatisch in den Vordergrund kommt. Ein guter Wert liegt zwischen 10 und 20
ForegroundLockTimeout | REG_DWORD | 30D40 | Zeit in Millisekunden. Gibt an nach welcher Zeit die Anwendung automatisch in den Vordergrund kommen darf. Ein guter Wert liegt bei FFFFFF was (279 Minuten) entspricht. Wenn man nicht gestört werden möchte.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1035.htm


Agfa Scanner installieren

Die aktuellen Agfa-Scanner (USB- und SCSI- und Parallel-Versionen) bedürfen etwas "Vorsicht" beim Installieren:

Sofern man Windows neu installiert, darf man den Scanner nicht angeschlossen haben, bevor nicht die Agfa-Software (FotoLook 3.5 oder ScanWise 1.4x) installiert wurde. Erst nach einem Reboot kann man den Scanner anschließen und die Software starten.

Hat man dies nicht beachtet und den Scanner schon vorher angeschlossen, läuft dieser Scanner nicht, da Windows 2000 diesen erkennt und einige Registry-Einträge anlegt, die aber einen Betrieb über die Scansoftware verhindern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für USB Scanner

Zur Abhilfe für USB-Scanner wechselt man mit Regedt32.exe unter LOCAL_Machine

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ USB

auf den Eintrag, beginnend mit "vid_06bd&...".

Diesen aktiviert man und wechselt ins Menü SICHERHEIT/Berechtigungen und aktiviert hier für "JEDER" den Vollzugriff.

Danach kann man den Unterschlüssel löschen.

Jetzt deinstalliert man die Scansoftware, bootet erneut und installiert die Software wieder. Dann fährt man den Rechner herunter und schließt nun erst den Scanner an.

Nach einen Neustart wird der Scanner erkannt und ist betriebsbereit.

SCSI- und Parallelport

Für SCSI- und Parallel-Scanner verfährt man wie beim USB-Scanner.

Allerdings ist der Pfad hier

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ SCSI

und der entsprechende Wert "Scanner&Ven_AGFA&Prod_....".

Ansonsten ist die Verfahrensweise wie beim USB Scanner (Berechtigungen ändern und dann löschen).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0787.htm


Absturz auf Tastendruck für Testzwecke

Microsoft hat für Testzwecke unter Windows eine Funktion eingebaut, mit der Sie durch einen Tastendruck einen Blue-Screen verursachen können.

Damit diese Funktion zur Verfügung steht, müssen Sie in der Registry folgenden neuen Wert Eintragen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ i8042prt\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "CrashOnCtrlScroll" als Datentyp REG_DWORD und setzen den Wert auf 1, um die Funktion zu aktivieren bzw. auf 0, um die Funktion wieder auszuschalten

Wenn Sie jetzt die STRG-Taste gedrückt halten und zweimal die "Scroll Lock" Taste betätigen, werden Sie mit einem Blue-Screen belohnt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1048.htm


Corel9: SP1 und SP2 unter Win2000 installieren

Corel 9: SP1 und SP2 unter Windows 2000 installieren

Sollte bei der Installation vom SP1 unter Windows 2000 die Meldung kommen, dass das Service Pack nur auf die deutsche Version 337 von CorelDRAW9 funktioniert, muss man in der Systemsteuerung unter Datum/Uhrzeit auf GMT+8 (Ulan Bator) umstellen.

Nach erfolgtem Installieren vom SP1 den Computer nicht booten, sondern sofort das SP2 installieren. Danach kann man wieder auf GMT+1 einstellen und einen Neustart durchführen.

Sollte das Update dennoch scheitern, stellt man wie o.a. die Zeitzone um, lädt ein Patch vom Corfel "gr9sp2de_fix.exe" (die Datei wurde vom Corel-Server entfernt), kopiert die Datei aus dem Fix-Verzeichnis ins Graphics9\Programs-Verzeichnis und installiert dann beide SPs.

Dann bootet man neu und stellt die Zeit auf GMT+8 um.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0967.htm


Updateüberprüfung und Verhalten einstellen

Windows XP prüft bei einer bestehen Onlineverbindung selbstständig, ob neue Updates zu Verfügung stehen. Dieses Verhalten können Sie über -> Systemsteuerung -> System -> Automatische Updates ausschalten.

In der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ WindowsUpdate\ Auto Update

erstellen Sie einen neuen Eintrag mit dem Namen "AuState" als Datentyp REG_DWORD und setzten Sie den Wert auf:

2 | Updateüberprüfung aktiv
7 | Updateüberprüfung deaktiv

Mit dem Eintrag "AUOptions" als Datentyp REG_DWORD können Sie einstellen, ob Sie über neue Updates benachrichtigt werden:

1 | AU ist deaktiviert (ungültig für die Richtlinie)
2 | vor dem Download nachfragen
3 | Automatischer Download

Info Weitere ausführliche Infos dazu finden Sie im Tipp "Automatisches Update konfigurieren"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1500.htm


Anzahl der Ein/Ausgabe-Puffers (PTEs) konfigurieren

Wird eine große Anzahl von Ein-/Ausgaben durchgeführt, kann es vorkommen, dass der Page-Table-Entries (PTEs) vollständig entleert wird. Wenn das passiert, kommt es zu einem Systemfehler.

Mit diesem Tipp können Sie den Speicher erhöhen, dabei ist 0 der Standardwert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Erstellen Sie einen neuen Wert mit dem Namen "SystemPages" als Datentyp REG_DWORD. Geben Sie hier die Anzahl der PTEs an:

0 | Das System berechnet selber einen optimalen Wert anhand der verwendeten Plattform und des verfügbaren Speichers.
1- 4294967293 (fffffffe) | Ein fest vorgegebener Wert; es wird kein Wert mehr vom System berechnet
4294967295 (ffffffff) | Es wird vom System der größte Wert berechnet und eingestellt. Das System überwacht den Wert und berechnet den Wer dynamisch neu, wenn sich die Konfiguration ändert.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1623.htm


Windows Zeit-/Datumsabgleich konfigurieren (Deutsche Server)

Mit dem W32Time-Dienst können Sie automatisch den Zeit-und Datumsabgleich über einen Zeitserver ausführen lassen. Dieser Dienst stellt sicher, dass die Datums- und Uhrzeiteinstellungen auf allen Computern innerhalb einer Organisation korrekt synchronisiert sind.

Sie können die Quelle für den Zeitserver auch über die Kommandozeile konfigurieren:

Mit:

net time /setsntp:"ptbtime1.ptb.de"

geben Sie z.B. einen neuen Zeitserver an.

Nach einer Änderung der Konfiguration können Sie den Zeitdienst folgendermaßen neu Starten:

net stop w32time

net start w32time

Mit dem Befehl "w32tm" können Sie noch weitere Einstellungen konfigurieren. Über "w32tm /?" können Sie sich die möglichen Parameter anzeigen lassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die automatische Zeitsynchronisation ist ja recht praktisch. Leider werden manche Leute misstrauisch, weil der Name MICROSOFT als Timeserver auftaucht. Wichtiger aber ist es, aus Gründen der lokalen Nähe, die Zeitserver anzupassen.

Die Funktion finden Sie (ab Windows XP), in dem Sie einen Doppelklick auf die Uhr in der Taskleiste ausführen und dann auf den Tabreiter "Internetzeit" wechselt. Hier werden Ihnen jetzt alle Zeitserver angezeigt, die in der Registry unter dem unten angegeben Key angegeben sind.

Folgender Eintrag ändert die Standardeinstellungen.

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ DateTime\ Servers

Hier wird beim Wert "(Standard)" die Zahl für den Zeitserver eingeben, der als Standard benutzt werden soll (z.B. 1). Weiterhin wird für jeden Zeitserver ein Eintrag angelegt (bei 1 beginnen) als Datentyp REG_SZ wo als Wert der Name des Zeitservers eingetragen wird.

Hier eine Liste mit Deutschen Zeitservern:

Wertname | Datentyp | Beschreibung
(Standard) | REG_SZ | Enthält den Standard Zeitserver 1
1 | REG_SZ | Name des ersten Zeitservers ptbtime1.ptb.de
2 | REG_SZ | Weitere Zeitserver ntps1-0.cs.tu-berlin.de
3 | REG_SZ | Weitere Zeitserver ntp1.fau.de
4 | REG_SZ | Weitere Zeitserver ntps1-1.rz.Uni-Osnabrueck.DE
5 | REG_SZ | Weitere Zeitserver swisstime.ethz.ch

Info Eintrag 1 ist vorzuziehen, da er direkt die Physikalisch-Technische Bundesanstalt, Braunschweig abfragt.

Weitere Konfigurationen für den Abgleich (gerade auch für Domänen interessant) finden Sie in der Registry unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ W32Time\ Parameters

Dort können Sie mit den folgenden Einträgen den Dienst konfigurieren:

Wertname

Datentyp

Beschreibung

AvoidTimeSyncOnWan

REG_SZ

Verhindert, dass der Computer mit einem Computer an einem anderen Standort synchronisiert wird.

0 = Der Standort der Zeitquelle wird ignoriert (Standard)

1 = Der Computer wird nicht mit einer Zeitquelle synchronisiert, die sich an einem anderen Standort befindet

GetDcBackoffMaxTimes

REG_DWORD

Die maximale Anzahl von Versuchen, das Backoff-Intervall zu verdoppeln, wenn aufeinander folgende Versuche, einen Domänencontroller zu finden, fehlschlagen. Bei jeder auftretenden Wartezeit maximaler Länge wird ein Ereignis protokolliert.

0 = Die Wartezeit zwischen zwei aufeinander folgenden Versuchen hat immer die minimale Länge, und es wird kein Ereignis protokolliert

7 = (Standard)

GetDcBackoffMinutes

REG_DWORD

Die anfängliche Dauer der Wartezeit in Minuten, bevor nach einem Domänencontroller gesucht wird, wenn der letzte Versuch fehlgeschlagen ist.

15 = (Standard)

LocalNTP

REG_DWORD

Wird verwendet, um den SNTP-Server zu starten.

0 = Der SNTP-Server wird nur gestartet, wenn dieser Computer ein Domänencontroller ist (Standard)

1 = Der SNTP-Server wird immer gestartet

NtpServer

REG_SZ

Wird verwendet, um die Zeitquelle manuell zu konfigurieren. Wählen Sie hierfür den DNS-Namen oder die IP-Adresse des NTP-Servers, mit dem die Synchronisierung erfolgen soll.

Beachten Sie dafür auch den Wert "Type"

Info: Kann auch über net time /setsntp:"ptbtime1.ptb.de" eingestellt werden.

Period

REG_DWORD oder REG_SZ

Wird verwendet, um zu steuern, wie oft der Zeitdienst synchronisiert wird. Wird ein Zeichenfolgenwert angegeben, muss er einem der unten aufgelisteten Werte entsprechen. Wenn Sie den Zeichenfolgenwert über die entsprechenden Nummern (beispielsweise 65535) angeben, muss der Wert als REG_DWORD-Wert erstellt werden. Wenn Sie den Zeichenfolgenwert über das entsprechende Wort (beispielsweise "BiDaily") angeben, muss der Wert als REG_SZ-Wert erstellt werden.

0 = Einmal täglich

65535, "BiDaily" = Einmal alle 2 Tage

65534, "Tridaily" = Einmal alle 3 Tage

65533, "Weekly" = Einmal wöchentlich (7 Tage)

65532, "SpecialSkew" = Einmal alle 45 Minuten, bis drei erfolgreiche Synchronisierungen erfolgen, dann einmal alle acht Stunden (dreimal pro Tag) [Standard]

65531, "DailySpecialSkew" = Einmal alle 45 Minuten, bis eine erfolgreiche Synchronisierung erfolgt, dann einmal pro Tag

ReliableTimeSource

REG_DWORD

Wird verwendet, um anzuzeigen, dass die Zeitanzeige dieses Computers zuverlässig ist.

0 = Diesen Computer nicht als zuverlässigen Zeitgeber kennzeichnen (Standard)

1 = Diesen Computer als zuverlässigen Zeitgeber kennzeichnen (nur bei einem Domänencontroller sinnvoll)

Type

REG_SZ

Wird verwendet, um zu steuern, wie ein Computer synchronisiert wird.

Nt5DS = Synchronisierung nach Domänenhierarchie (Standard)

NTP = Synchronisierung nach manuell konfigurierter Quelle

NoSync = Keine Synchronisierung der Zeit

Bei dem Wert "Nt5DS" kann keine manuell konfigurierte Quelle verwendet werden.

Den Aktualisierungsintervall der Zeitsynchronisation mit einem NTP-Zeitserver legen Sie mit den folgenden Wert fest:

Bei Windows 2000 konnten Sie noch über den Befehl "w32tm -period <Intervallcode>" einstellen in welchen Abständen die Zeit aktualisiert werden sollte. Für <Intervallcode> geben Sie folgende möglichen Werte an:

0 | täglich
65535 | alle zwei Tage
65534 | alle drei Tage
65533 | wöchentlich
65532 | alle 45 Minuten (wenn das 3 mal fehlerfrei funktioniert hat, dann täglich)

Ab Windows XP müssen Sie das über einen Registryeintrag machen:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ W32Time\ TimeProviders\ NtpClient

Erstellen Sie hier einen neuen Wert mit dem Namen "SpecialPollInterval" als Datentyp REG_DWORD und geben Sie die Zeit in Sekunden an.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=223184
http://support.microsoft.com/?kbid=224799
http://support.microsoft.com/?kbid=314054

Info In einem Netzwerk sollten die Clients die Zeit vom einem Server aus dem Netzwerk beziehen. Dadurch stellen Sie sicher, dass alle Rechner innerhalb eines Netzwerkes synchron laufen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1749.htm


Tab-Taste für Autovervollständigung benutzen

Mit diesem Tipp aktivieren Sie, dass durch Drücken der Tab-Taste eine Autovervollständigung durchgeführt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoComplete

ändern Sie hier den Wert "Always Use Tab" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Tab Autovervollständigung aktivieren
0 | Tab Autovervollständigung deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2076.htm


Autovervollständigung in der Dialogbox 'Öffnen/Speichern' für Dateiname konfigurieren

Autovervollständigung in der Dialogbox "Öffnen/Speichern" für Dateiname konfigurieren

In der Dialogbox "Öffnen/Speichern", wo Sie den Dateinamen der Datei angeben können, lässt sich Mit diesem Tipp die Autovervollständigung konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoComplete

ändern Sie hier den Wert "AutoComplete In File Dialog" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Autovervollständigung aktivieren
0 | Autovervollständigung ausschalten

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2075.htm


Anzeigen von Warnmeldungen beim Entfernen einer PCMCIA-Karte ausschalten

Mit diesem Tipp können Sie die Warnmeldung ausschalten, welche angezeigt wird, wenn eine PCMCIA-Karte entfernt wird, bevor diese Karte in Windows abgemeldet wurde.

Setzen Sie dafür den Eintrag "PCMCIAFlags" in der Registry auf 0, damit keine Warnmeldungen mehr im Systray angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ SysTray

Erstellen Sie hier einen neuen Wert mit dem Namen "PCMCIAFlags" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Keine Warnmeldungen anzeigen
1 | Warnmeldungen anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2616.htm


Windows Update deaktivieren

Mit diesem Tipp können Sie einstellen, ob Windows Updates möglich sind.

Wenn Sie diese Tipp aktivieren, werden alle Funktionen von Windows Update entfernt. Die Links im Startmenü für das Windows Update werden deaktiviert und Sie werden auch nicht mehr über neue Updates unterrichtet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WindowsUpdate

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableWindowsUpdateAccess" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Windows Update deaktivieren
0 | Windows Update ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Zugriff auf alle Windows Update-Funktionen entfernen

Info Teilweise findet man den Key auch unter "HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion Policies \ Explorer"

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1873.htm


Windows Update-Dateien speichern

Sie können die Updates für Windows XP herunterladen und speichern, um sie später zu installieren oder bei Bedarf erneut einspielen zu können:

  1. Internet Explorer - Extras - Windows Update
  2. Admistrator-Optionen
  3. Unter "Aktualisieren mehrerer Betriebssysteme" finden Sie den Link "Windows Updates-Katalog"
  4. Hier können Sie jetzt Updates suchen und zum Auswahlkorb hinzufügen. Durch klicken auf den Auswahlkorb (oben rechts), können Sie die Dateien dann runterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1269.htm


Ausführen von geplanten Updates unterbinden

Wenn Sie diese Funktion aktivieren, werden keine geplanten Updates mehr durchgeführt

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Webcheck

Erstellen Sie hier einen neuen Wert mit dem Namen "NoScheduledUpdates" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | deaktiv
0 | aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1481.htm


Update Berechtigungen konfigurieren

Mit diesem Tipp können Sie einstellen, ob normale Benutzer Updates annehmen dürfen. Wenn Sie den Wert deaktivieren, dürfen nur noch Administratoren Updates durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies\ Microsoft\ Windows\ WindowsUpdate

ändern Sie hier den Wert "ElevateNonAdmins" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nur Administratoren dürfen Updates annehmen
1 | Alle dürfen Updates annehmen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Nichtadministratoren gestatten, Updatebenachrichtigungen zu erhalten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2064.htm


'Updates installieren und herunterfahren' nicht anzeigen

"Updates installieren und herunterfahren" nicht anzeigen

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob der Eintrag "Updates installieren und herunterfahren" im Dialogfeld "Windows herunterfahren" nicht angezeigt wird.

Wenn neue Updates zur Verfügung stehen. Wenn Sie den Tipp aktivieren, wird dieser Eintrag nicht angezeigt, auch wenn neue Update verfügbar sind. Ist dieser Tipp nicht aktiv, wird der Eintrag angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAUShutdownOption" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Updates installieren und herunterfahren" wird nicht angezeigt
0 | "Updates installieren und herunterfahren" wird angezeigt, wenn Updates verfügbar sind (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Option "Updates installieren und herunterfahren" im Dialogfeld "Windows herunterfahren" nicht anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1872.htm


'Updates Anzeigen' unter Software aktivieren

"Updates Anzeigen" unter Software aktivieren

Unter "Systemsteuerung" -> "Software" wird Ihnen unter "Programme ändern oder entfernen" die installierten Programme angezeigt, die der Benutzer ändern oder entfernen kann.

Ab Service Pack 2 werden hier nicht mehr die installierten Updates für Windows angezeigt. Wenn Sie die installierten Updates sehen wollen, müssen Sie vorher den Haken bei "Updates Anzeigen" setzen. Durch diese Funktion soll die Lesbarkeit für den Anwender verbessert werden.

Wenn Sie die Updates immer sehen wollen, dann können Sie das über den folgenden Key setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "DontGroupPatches" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Filterfunktion ist ausgeschaltet (Updates werden mit angezeigt)
0 | Filterfunktion ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1822.htm


Updates Installieren welche nicht von Microsoft Signiert sind

Updates installieren, die nicht von Microsoft signiert sind

Mit diesem Tipp können Sie einstellen, ob über den Windows Updateservice (WSUS) auch Updates installiert werden, die nicht von Microsoft signiert sind.

Wenn Sie diesen Tipp aktivieren, werden über den Windows Updateservice auch Updates installiert, die über den lokalen Zertifikatespeicher (Vertrauenswürdige Herausgeber) signiert sind. Ansonsten werden nur Updates installiert, die durch Microsoft signiert wurden, alle anderen Updates werden nicht installiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate

Erstellen Sie hier einen neuen Wert mit dem Namen "AcceptTrustedPublisherCerts" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Es muss nicht Microsoft signiert sein
0 | Updates müssen von Microsoft signiert sein (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Updater
Einstellungsname: | Signierte Inhalte aus internem Speicherort für Microsoft-Updatedienste zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2314.htm


Automatischer Download von Service Packs unterbinden

Automatischen Download von Service Packs unterbinden

Wenn Sie den Windows-Update-Service aktiv haben, wird ein neues Service Pack automatisch geladen, falls es von Microsoft bereitgestellt wird.

Gerade wenn Sie mit langsamen Internetverbindungen arbeiten oder das Service Pack auf andere Wege verteilen wollen, können Sie das Herunterladen der Service Packs mit einen Eintrag in der Registry unterbinden.

Der Eintrag verhindert keine manuelle Installation des Service Packs, weiterhin wird das Service Pack auch nach Ablauf einer bestimmten Zeit automatisch heruntergeladen und installiert:

Service Pack | Zeit
Windows XP SP3 | nach 12 Monaten ab der Veröffentlichung
Windows Server 2003 SP2 | bis März 2008
Windows Vista SP1 | nach 12 Monaten ab der Veröffentlichung

Um den automatischen Download zu unterbinden, setzen Sie den folgenden Registryeintrag.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter.

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate

Erstellen Sie hier einen neuen Wert mit dem Namen "DoNotAllowSP" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Der automatische Download neuere Service Packs wird unterbunden
0 | Neue Service Packs werden automatisch geladen und installiert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2556.htm


Installation von Windows XP

Bei der Installation von Windows XP hat sich im Vergleich zu Windows 2000 recht wenig geändert (siehe auch: "Installation von Windows 2000").

Die Installation ist auch von MS selber hinreichend gut dokumentiert worden.

Hier werden nur einige zusätzliche Informationen aufgeführt:

Im textbasierenden Teil der Installation können Sie den Ablauf durch das Drücken folgender Tasten beeinflussen:

Taste | Funktion
F5 | Auswahl der ACPI Installation
F6 | Es können weitere Gerätetreiber eingebunden werden (für Geräte, die nicht von MS unterstützt werden)
F7 | ACPI wird ausgeschaltet

Im nachfolgenden grafischen Teil der Installation können Sie, während die Geräteerkennung läuft, durch die Tastenkombination SHIFT+F10 die Kommandozeilenoberfläche (CMD.EXE) öffnen. Hier können Sie die Standardbefehle benutzen, weiterhin stehen folgende nützliche Befehle zur Verfügung:

Befehl | Funktion
Diskpart | Datenträgerverwaltung
Driverquery | Erzeugen einer Liste aller Treiber mit Versionsinfo
Netsh | Spezielle Scriptfunktionen für Netzwerkkonfiguration (sichern/wiederherstellen)
SC | Dienste-Konfiguration
Tasklist | Erzeugen einer Liste aller Prozesse mit Informationen
Taskkill | Gestartete Prozesse beenden

Weiterhin gibt es noch SHIFT+F11, um ausführlichere Dialoginfos angezeigt zu bekommen. Dies muss man mehrmals betätigen, jeweils, wenn ein neuer Teil des grafischen Setups gestartet wird, sprich z.B. Netzinstallation, danach nochmals bei der Installation der Dateien, dann nochmals bei der Installation der Startmenüeinträge.

Falls Sie für die Installation Startdisketten benötigen, da Ihr CD-ROM Laufwerk nicht bootfähig ist, können Sie diese von der MS Homepage herunterladen.

Professional Version:

http://download.microsoft.com/download/whistler/Install/310994/WIN98MeXP/DE/Win XP_DE_PRO_BF.EXE

Home Edition:

http://download.microsoft.com/download/Win XPHome/Install/310994/WIN98MeXP/DE/Win XP_DE_HOM_BF.EXE

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1314.htm


Windows XP nach Windows VISTA installieren

Wenn Sie Windows XP auf dem Rechner haben und anschließend Windows VISTA installieren, dann können Sie später über das Bootmenü von VISTA beide Betriebssystem starten. Ist auf dem Rechner aber nur VISTA installiert und soll anschließend XP installiert werden, würde die Installation von XP den Bootsector überschreiben und mit der Bootsector-Version von XP kann Windows VISTA nicht mehr gestartet werden.

Damit Sie anschließend auch wieder VISTA starten können, müssen Sie die Installation folgendermaßen durchführen:

  1. Windows XP auf einer anderen Partition installieren (Da einige Verzeichnis gleich sind, sollten Sie die beiden Betriebssysteme nicht auf derselben Partition installieren).
  2. Windows XP nach der erfolgreichen Installation starten
  3. Kommandozeilenoberfläche (CMD.EXE) starten
  4. Windows VISTA-DVD in das Laufwerk legen und folgenden Befehl eingeben ([Laufwerk] durch den Laufwerksbuchstaben des DVD-Laufwerks ersetzen):
    [Laufwerk]:\boot\bootsect.exe -NT60
  5. Rechner neu booten. Es sollte jetzt wieder Windows VISTA gestartet werden
  6. Kommandozeilenoberfläche (CMD.EXE) als Administrator starten
  7. In der Kommandozeilenoberfläche folgende Befehle ausführen
    • %Systemroot%\system32\bcdedit -create {ntldr} -d "Windows XP starten"
      Sie können für "Windows XP starten" auch einen anderen Text angeben
    • %Systemroot%\system32\bcdedit -set {ntldr} device partition=C:
      Bei C: handelt es sich um die aktive Partition, was meist immer der Fall ist. Wenn es bei Ihnen eine andere Partition ist, müssen Sie den Laufwerksbuchstaben entsprechend anpassen.
    • %Systemroot%\system32\bcdedit -set {ntldr} path \ntldr
    • %Systemroot%\windows\system32\bcdedit -displayorder {ntldr} -addlast

Wenn Sie jetzt den Rechner neu starten, wird im Bootmenü auch Windows XP angezeigt und kann entsprechend ausgewählt werden.

Info Informationen über "bcdedit" finden Sie im Tipp "Informationen über den BCD-Store"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2409.htm


Produktregistrierung nach Windows- und Office XP-Neuinstallation wiederherstellen

Wer Windows oder Microsoft Office XP neu auf derselben oder einer nicht allzu sehr veränderten Hardware installiert, muss normalerweise die Produktregistrierung bei Microsoft neu durchführen.

Wenn man aber nach einer erfolgreich durchgeführten Registrierung die Dateien sichert, braucht man diese Datei nur an denselben Ort zurück zu kopieren, allerdings bevor das erste Office-Programm geöffnet wird. Jetzt wird man nicht mehr mit der unangenehmen Aufforderung zur Registrierung oder Aktivierung belästigt.

Windows XP:

In Windows XP heißt die zu sichernde Datei "wpa.dbl" und findet sich im System32-Unterverzeichnis des Windows Ordners.

Die Methode ist dieselbe, die Datei - nach erstmaliger Aktivierung von Windows XP - auf Diskette zu sichern und nach einer Neuinstallation zurück zu kopieren. Diese Angaben beziehen sich auf die deutsche und englische Version des Release Candidate 1 von Windows XP. (Möglicherweise wird sich der Name "wpa.dbl" bis zum Erscheinen der Endversion noch ändern).

Info Ab "Service Pack 2" geht das nicht mehr.

Office:

Bei Office 2000 sichern Sie die Datei "opa11.dat" aus dem Verzeichnis "...\All Users\Anwendungsdaten\Microsoft\Office\Data"

(ab Windows 2000 finden Sie diesen Pfad unter: "Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Office\Data" bzw. in der englischen Version "Documents and Settings\All Users\Application Data\Microsoft\Office\Data".)

Bei Office XP sichern Sie die Datei "data.dat" aus dem Verzeichnis "...\All Users\Anwendungsdaten\Microsoft\Office\Data" und die "msointl.dll" aus dem Verzeichnis "C:\Programme\Gemeinsame Dateien\Microsoft Shared\Office10\1031".

Es handelt sich um eine versteckte Datei mit dem Attribut "System".

Zusätzlich sichern Sie in der Registry den Schlüssel:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

(für Office 2003)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ 11.0\ Registration

(für Office XP)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ 10.0\ Registration

Gehen Sie dazu auf den Schlüssel und wählen Sie aus dem Menü "Datei" -> "Exportieren" aus, um die Registryeinträge in eine Datei zu sichern.

Müssen Sie eine Neuinstallation von Office vornehmen, kopieren Sie die gesicherten Dateien an dieselbe Stelle zurück.

Achten Sie darauf, dass Sie die Dateien zurückkopieren, bevor Sie eine der Office-Anwendungen zum ersten Mal starten. Weiterhin importieren Sie die gesicherten Registryeinträge durch einen Doppelklick auf die Datei.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1174.htm


Windows XP mit ACPI Unterstützung installieren

Wenn Sie Windows XP installieren, wird die ACPI-Unterstützung nur installiert, wenn das BIOS in der Liste der unterstützten ACPI-BIOS -Versionen eingetragen und jünger als 1.1.1999 ist.

Sie können aber auch vor dem Setup bestimmen, wie Windows installiert wird und das nicht der Überprüfung von Windows überlassen.

Öffnen Sie dafür die Datei \I386\TxtSetup.sifaus dem Installationsverzeichnis und ändern Sie unter der Sektion [GoodACPIBIOS ] den Eintrag ACPIEnable auf den gewünschten Wert:

0 | ACPI ist deaktiviert, die BIOS Funktion wird nicht berücksichtigt
1 | ACPI ist aktiviert wenn ein ACPI fähiges BIOS gefunden wird
2 | (Standard) ACPI aktivieren wenn das BIOS bekannt und neuer als 1.1.1999 ist.

Siehe auch: "ACPI Funktion von Windows aktivieren" und "Probleme mit ACPI bei der IRQ-Verteilung".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1320.htm


XP Installation von Diskette starten

Wenn ihr Rechner nicht von CD booten kann, müssen Sie von Diskette booten, um die XP-Installation zu starten, falls noch ein solches Laufwerk installiert ist.

Ein Programm zum Erstellen der Bootdisketten finden Sie unter folgenden Adressen:

Standard Version:

XP Home: <Download>

XP Professional: <Download>

Version mit SP1:

XP Home: <Download>

XP Professional: <Download>

Die Größe der Downloaddatei beträgt ca. 4,5 MB. Es werden sechs Disketten benötigt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://www.microsoft.com/kb/Germany/Support/kb/D310/D310994.htm

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1238.htm


Nachfrage zur Suche nach Gerätetreibern im Windows Update Service

Info: XP ab SP2

Hier können Sie festlegen, ob bei Administratoren aufgefordert werden soll, über den Windows Update-Service, nach Gerätetreibern zu suchen, wenn der Gerätetreiber lokal nicht gefunden wird.

Wenn Sie diese Einstellung aktivieren, erscheint keine Meldung, nach Gerätetreibern zu suchen. Ansonsten erscheint eine Aufforderung nach Gerätetreibern zu suchen, außer diese Funktion wurde über den Tipp: "Suche nach Gerätetreibern über den Windows Update Service deaktivieren" ausgeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DriverSearching

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ DriverSearching

Erstellen Sie hier einen neuen Wert mit dem Namen "DontPromptForWindowsUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Suchnachfrage für Gerätetreiber ist aktiv (Standard)
1 | Suchnachfrage für Gerätetreiber ausschalten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Eingabeaufforderung zur Suche nach Gerätetreibern auf Windows Update deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Dieser Tipp ist auch abhängig vom Tipp: "Suche nach Gerätetreibern über den Windows Update Service deaktivieren".

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2022.htm


Suche nach Gerätetreibern über den Windows Update Service deaktiven

Suche nach Gerätetreibern über den Windows Update Service deaktivieren

Info: XP ab SP2

Hier können Sie festlegen, ob der Windows Update-Service nach Gerätetreibern suchen soll, wenn der Gerätetreiber lokal nicht gefunden wird.

Wenn Sie diese Einstellung aktivieren, wird nicht nach Gerätetreibern gesucht. Wenn Sie die Einstellung deaktivieren, wird über den Windows Update Service nach Gerätetreibern gesucht, wenn die nicht lokal vorhanden sind.

Wenn die Einstellung nicht konfiguriert ist, können Sie entscheiden, ob über den Windows Update Service nach Geträtetreibern gesucht werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ DriverSearching

Erstellen Sie hier einen neuen Wert mit dem Namen "DontSearchWindowsUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Suche für Gerätetreiber aktivieren
1 | Suchnachfrage für Gerätetreiber ausschalten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Internetkommunikationsverwaltung\Internetkommunikationseinstellungen
Einstellungsname: | Suche nach Gerätetreibern auf Windows Update deaktivieren

Info Dieser Tipp ist auch abhängig vom Tipp: "Nachfrage zur Suche nach Gerätetreibern im Windows Update Service".

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2023.htm


Internet Explorer neu installieren

Wenn Sie die gleiche Version des Internet Explorer neu installieren wollen, da er nicht mehr korrekt läuft, können Sie das nicht über das Setup des Internet Explorer machen.

Um den Internet Explorer neu zu installieren, führen Sie folgendes aus:

  • Legen Sie die XP-CD in das CD-Laufwerk
  • Öffnen Sie die Eingabeaufforderung
  • Geben Sie folgenden Befehl ein:
    rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %SystemRoot%\Inf\ie.inf

Jetzt sollte der IE neu installiert werden. Die Variable %SystemRoot% gibt den Pfad zum Windowsverzeichnis an.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2413.htm


Warnhinweis bei Treibern ohne digitaler Signatur

Wenn Sie Treiber installieren, die keine digitale Signatur von Microsoft haben, bekommen Sie einen Warnhinweis angezeigt. Dieser Hinweis auf verdächtige Treiber ist aber meist nicht hilfreich, da viele Treiberhersteller ihrer Treiber aus Kostengründen nicht von Microsoft zertifizieren lassen.

Bei Windows XP konnte man das unter den "Systemeigenschaften" (Systemsteuerung -> System) finden. Hier können Sie auf dem Tabreiter "Hardware" unter dem Punkt "Treiber" über den Button "Treibersignierung" die Einstellung verändern. Wenn Sie hier die Einstellung "Ignorieren - Software unabhängig von Zulassung installieren" auswählen, werden Sie nicht mehr gefragt, ob Sie den Treiber auch wirklich installieren wollen.

Bei der 64-Bit Version wird Ihnen das Leben noch weiter erschwert. Hier gibt sich das System nicht nur mit einer entsprechenden Warnmeldung zufrieden, sondern es wird Ihnen vollständig die Installation von nicht signierten Treibern verweigert.

Ab Windows Vista müssen Sie diese Einstellung über BCDEDIT ändern. Öffnen Sie dafür die Eingabeaufforderung als Administrator und geben Sie hier folgenden Befehl ein:

Bcdedit.exe /set nointegritychecks ON

Anschließend erhalten Sie auch hier keine Warnmeldung mehr, wenn die Treiber nicht signiert sind. Mit "OFF" können Sie die Warnmeldung wieder aktivieren.

Das Abschalten über bcdedit geht in der 64-Bit Version nicht mehr, hier müssen Sie auf den folgenden Trick zurückgreifen:

Unter der 64-Bit Version von Windows Vista können Sie die Überprüfung der Treibersignatur auch kurzzeitig folgendermaßen umgehen. Drücken Sie beim Start von Windows die F8-Taste und wählen Sie anschließend aus dem Menü den Eintrag "Erzwingen der Treibersignatur deaktivieren" aus. Jetzt können Sie bis zum nächsten Stzart von Windows auch nicht signiert Treiber installieren.

Info Siehe dazu auch Tipp:

Die 'digitale Treibersignatur' für Gerätetreiber

Sicherheit der Treibersignierung vorgeben

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2674.htm


Startbilder und den Startbutton verändern

Das Bootbild von Windows XP ist in der Datei Ntoskrnl.exe abgelegt (zu finden unter %WINDIR%\system32). Erstellen Sie von dieser Datei eine Sicherheitskopie. Wenn Sie Windows XP jetzt im Abgesicherten-Modus starten (F8), können Sie die Datei gegen eine anderen Version austauschen, die ein angepasstes Bootbild enthält.

Fertige Themes finde Sie unter: "http://www.themeworld.com/"

Wollen Sie das Anmelde-Startbild oder den Startbutton selbst verändern, müssen Sie auf das Tool "Resource Hacker" zurückgreifen: http://www.users.on.NET/johnson/resourcehacker/

Einige Daten für die Bilder im Resource Hacker:

Willkommens Bildschirm:

Die Datei Logonui.exe aus dem System32-Verzeichnis müsse Sie kopieren, damit Sie diese Kopie bearbeiten können:

  • Starten Sie den Resource Hacker und laden Sie die Datei. Gehen Sie in der Baumstuktur unter Bitmap auf 100, 1031
  • Wählen Sie aus dem Menü "Aktion" -> "Replace Bitmap"
  • Wählen Sie über "Open..." ein neue BMP-Datei aus, welches Ihrer aktuellen Auflösung entspricht ( z.B. 1024*768). Klicken Sie dann auf Replace
  • Gehen Sie jetzt in der Baumstruktur unter UIFILE auf 1000, 1031 und suchen Sie hier die Zeile "<element id=atom(contentcontainer)". Passen Sie hier "content=rcbmp(100,0,0,219rp,207rp,1,0)" entsprechend Ihrer Bildgröße an ( z.B. Bildgröße 1024 -> content=rcbmp(100,0,0,1024rp,768rp,1,0)
  • Drücken Sie auf die Schaltfläche "Compile Script"
  • Script sichern und die Datei austauschen

Startbild:

Die Datei Ntoskrnl.exe aus dem System32-Verzeichnis müssen Sie kopieren, damit Sie diese Kopie bearbeiten können:

  • Öffnen Sie die Datei mit dem Resource Hacker und gehen Sie in der Baumstruktur unter Bitmap unter 1, 1033
  • Speichern Sie das Bild als BMP-Datei ab.
  • Laden Sie das Bild (z.B. mit Paint Shop Pro)
  • Bearbeiten Sie die Grafik, achten Sie aber auf die Farben, da Windows für das Bild eine extra Farbpalette verwendet
  • Im Resourcen Hacker tauschen Sie jetzt das Bild mit "Aktion" -> "Replace Bitmap" gegen das neue Bild aus.

Info Die Datei müssen Sie im "Abgesicherten-Modus" (F8 - Taste beim starten) austauschen.

Bootbild ändern ohne Eingriff in Systemdatei ntoskrnl.exe:

  • Grafik mit Größe 640 x 480 Pixel und 16-Farben mit dem Namen boot.bmp unter %windir% (C:\ Windows) abspeichern
  • Die Datei C:\boot.ini (siehe auch Tipp: "Informationen über die BOOT.INI")bearbeiten unter Abschnitt [operating systems]. Eintrag hinter /fastdetect ergänzen mit: /bootlogo /noguiboot

Nachteil: Der Laufbalken wird hier aber nicht angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1264.htm


Informations-Tour deaktivieren

Bei Windows XP wird bei den ersten Anmeldungen immer die "Windows Tour" zum Ausführen angeboten. Mit einem Eingriff in die Registry können Sie das für immer (für alle oder für einzelne Benutzer) unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Applets\ Tour

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Applets\ Tour

erstellen Sie einen neuen Wert mit dem Namen RunCount als Datentyp REG_DWORD und setzen den Wert auf 0.

Info Weitere Einstellungen für Infotipps finden Sie unter:
QuickInfos (BallonTips) abschalten
Quickinfo für Icons
Ordnerinformationen als Balloontip anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1265.htm


Im Dialog 'Computer Ausschalten' Ruhezustand anzeigen

Wenn Sie im Startmenü "Computer ausschalten..." auswählen, wird im anschließenden Dialog nur folgendes angezeigt:

- Standby

- Ausschalten

- Neustart

Wenn sie den Rechner aber in den Ruhezustand versetzen wollen, müssen Sie einfach nur die <Shift>-Taste (Umschalttaste) drücken. Jetzt wird statt "Standby" die Schaltfläche "Ruhezustand" angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1284.htm


Abmeldescript bei der Ausführung anzeigen

Mit diesem Tipp wird Ihnen gezeigt wie Sie sich das Abmeldeskript beim Abmelden anzeigen lassen können. Abmeldeskripts sind Batchdateien von Anweisungen, die während der Benutzerabmeldung angezeigt werden. Standardmäßig werden die Anweisungen in Abmeldeskripts nicht angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "HideLogoffScripts" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Abmeldeskript wird nicht angezeigt (Standard)
0 | Abmeldeskript wird angezeigt

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Abmeldeskripts sichtbar ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1465.htm


Rechner beim Hochfahren aus dem Ruhezustand automatisch sperren

Wenn Sie diese Policy aktivieren, wird der Computer automatisch nach dem Hochfahren aus dem Ruhezustand gesperrt. Ansonsten können Sie selber entscheiden, ob der Computer gesperrt werden soll.

Diese Einstellung finden Sie unter: "Start" -> "Systemsteuerung" -> "Energieoptionen" gehen Sie hier auf den Tabreiter "Erweitert". Hier finden Sie dann den Eintrag "Kennwort beim Reaktivieren aus dem Standby-Modus anfordern".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System\ Power

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System\ Power

Erstellen Sie hier einen neuen Wert mit dem Namen "PromptPasswordOnResume" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Rechner wird automatisch gesperrt
0 | Sie können auswählen ob der Rechner gesperrt werden soll (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1461.htm


Bootvorgang beschleunigen (Prefetching)

Ab Windows XP wurde der Startvorgang von Windows noch einmal beschleunigt. Microsoft strebt für Windows XP eine Bootzeit von unter 30 Sekunden an, dafür wurde das sog. Prefetching eingeführt. Dabei werden die nötigen Festplattenaktionen für das Aktivieren von Hardwaretreibern beim Booten direkt ausgeführt, so dass sich Initialisierung der Geräte und darauf folgende Festplattenaktionen überschneiden.

Windows speichert die Prefetch-Dateien in dem Ordner %SystemRoot%\Prefetch. Wenn Sie die häufig benutzten Programme neu optimieren möchten, löschen Sie den Inhalt des Ordners. Windows beginnt dann das Verhalten neu zu analysieren, um das Prefetching zu optimieren.

Benutzte Dateien:

%SystemRoot%\PREFETCH\Layout.ini

Diese Datei wird nach einer Analyse des Rechners automatisch erzeugt und wird bei der Defragmentierung als Hilfe benutzt, in der Reihenfolge, wie die Dateien optimal anzuordnen sind. Benutzt wird diese Datei von Windows für das Prefetching, um gewisse Speicherseiten imVoraus laden zu können.

Diese Datei können Sie über den Befehl (Start -> Ausführen -> "%windir%\system32\rundll32.exe advapi32.dll,ProcessIdleTasks") aktuell erstellen lassen.

%SystemRoot%\PREFETCH\NTOSBOOT-B00DFAAD.PF

Enthält die Seiten, auf denen während des Bootvorganges zugegriffen wird. Hier werden die letzten 8 Bootvorgänge protokolliert.

%SystemRoot%\PREFETCH\*.PF

Wird benutzt, um das Laden der Anwendungen/Dateien zu beschleunigen, da hier die benötigten Sourcen mit protokolliert werden. Hier merkt sich also Windows, welche Dateien, Dlls, Grafiken usw. noch von einer Anwendung geladen wurden, wenn sie geöffnet wurde.

Die Optimierung wird von Windows durchgeführt, wenn gerade nichts zu tun ist. Diese Optimierung wird von Windows alle 3 Tage durchgeführt.

Ob diese Funktion bei Ihnen aktiv ist, können Sie in der Registry überprüfen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Memory Management\ PrefetchParameters

Finden Sie den Eintrag “EnablePrefetcher“, hier sollte als Wert 3 Eingetragen sein, damit die Funktion aktiv ist. Wenn Sie die Funktion deaktivieren wollen, setzen Sie den Wert auf 0.

Folgende Werte sind zulässig:

0 | Prefetch ausschalten
1 | Prefetch für Anwendungen
2 | Prefetch für den Bootvorgang
3 | Prefetch für Anwendungen plus Bootvorgang

Die zweite Funktion zur Beschleunigung des Bootvorgangs finden Sie im Tipp: „Defragmentieren der BOOT-Dateien ein-/ausschalten“ und "Auto-Layout-Service ein-/ausschalten"

Info Microsoft stellt weiterhin ein Tool namens "Bootvis" (Version 1.3) zu Verfügung. (Man sagt dem Programm aber nach, das es NICHT immer fehlerfrei arbeitet. Es ist mit Vorsicht einzusetzen!). Dieses Tool analysiert und beschleunigt den Bootvorgang. Zur Analyse wählen Sie "Trace" -> "Next Boot + Driver Delays". Wenn Sie jetzt Windows neu starten, werden Ihnen die Ergebnisse angezeigt, mit "Trace" -> "Optimize System" können Sie Ihr System Optimieren.

Download: <BootVis>

Info Damit diese Funktion läuft, müssen der Dienst "Taskplaner" und "Windows-Firewall" (Internetverbindungsfirewall) aktiv sein.

Info Siehe dazu auch Tipp: Laden von Anwendungen beschleunigen (EnableSuperfetch)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1502.htm


Auto-Layout-Service ein-/ausschalten

Dieser Service verschiebt die oft benötigten Dateien an die optimale Position auf der Festplatte. Durch das Prefetching werden Seiten im Voraus in den Speicher geladen. Dafür die ist Anordnung der Dateien auf der Festplatte wichtig, um Suchvorgänge auf der Platte zu vermeiden. Diese Funktion sorgt dafür, dass diese Dateien optimal abgelegt werden und wird erst dann ausgeführt, wenn der Rechner gerade nichts zu tun hat.

Info Damit diese Funktion läuft, müssen auch der Dienst "Taskplaner" und die "Windows-Firewall" (Internetverbindungsfirewall) aktiv sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ OptimalLayout

finden Sie den Wert "EnableAutoLayout"als Datentyp REG_DWORD, wo Sie mit 0 die Funktion ausschalten können. Diese Funktion ist Standardmäßig aktiv (1).

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Infos finden Sie im Tipp: "Defragmentieren der BOOT-Dateien ein-/ausschalten" und "Bootvorgang beschleunigen (Prefetching)"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xpehelp/html/xehowdisablingdiskdefragmentation.asp

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2015.htm


'Updates installieren und herunterfahren' nicht automatisch aktivieren

"Updates installieren und herunterfahren" nicht automatisch aktivieren

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob der Eintrag "Updates installieren und herunterfahren" im Dialogfeld "Windows herunterfahren" automatisch aktiviert wird.

Wenn neue Updates zur Verfügung stehen. Wenn Sie den Tipp aktivieren, wird dieser Eintrag nicht automatisch aktiviert, auch wenn neue Update verfügbar sind. Ist dieser Tipp nicht aktiv, markiert Windows diese Einstellung automatisch.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAUAsDefaultShutdownOption" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Updates installieren und herunterfahren" wird nicht automatisch aktiviert
0 | Updates installieren und herunterfahren" wird aktiviert, wenn Updates verfügbar sind (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Update
Einstellungsname: | Die Standardoption "Updates installieren und herunterfahren" im Dialogfeld "Windows herunterfahren" nicht anpassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Wenn die Einstellung "Updates installieren und herunterfahren nicht anzeigen" aktiv ist, hat diese Einstellung keine Wirkung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1871.htm


Ruhezustand und Standby zum Dialog "Computer ausschalten" hinzufügen

In Windows XP ab Service Pack 2 (SP2) können Sie nach der Installation des Windows Updates KB893056 (Download), mit einem zusätzlichen Registryeintrag die Einträge "Ruhezustand" und "Standby" zum Dialog "Computer ausschalten" hinzufügen.

Standardmäßig werden die Einträge "Ruhezustand" und "Standby" in diesem Dialog nicht angezeigt, hier stehen ansonsten nur "Ausschalten" und "Neu starten" zur Verfügung.

Um die Einträge hinzuzufügen gehen Sie folgendermaßen vor:

  • Installieren Sie das Update KB893056 (Download)
    Info: Leider wird der Fix nur noch auf Anfrage von Microsoft zugeschickt und kann nicht mehr direkt heruntergeladen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ System\ Shutdown

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowHibernateButton" als Datentyp REG_DWORD, und setzen den Wert auf:

1 | Die Einträge "Ruhezustand" und "Standby" anzeigen
0 | Standardanzeige (ohne die Einträge) (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Damit Sie die Einstellung über den Explorer unter "Extras" -> "Ordneroptionen" -> "Ansicht" über die Einstellung "Zeige Ruhezustand im 'Ausschalten'-Dialog" konfigurieren können, wurde hier der Inhalt einer REG-Datei abgelegt. Kopieren Sie die Textzeilen in eine neue Textdatei, die Sie z.B. mit Notepad erstellen und speichern Sie die Datei unter einem beliebigen Namen mit der Dateiendung ".REG" ab. Anschließend klicken Sie diese Datei im Explorer doppelt an, um die Einstellungen in die Registry zu übernehmen.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\Shutdown]

"ShowHibernateButton"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\System]

"Bitmap"="SHELL32.DLL,22"

"Text"="System Einstellungen"

"Type"="group"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\System\Hibernate]

"CheckedValue"=dword:00000001

"DefaultValue"=dword:00000000

"HKeyRoot"=dword:80000002

"RegPath"="Software\\Policies\\Microsoft\\Windows\\System\\Shutdown"

"ValueName"="ShowHibernateButton"

"UncheckedValue"=dword:00000000

"Type"="checkbox"

"Text"="Zeige Ruhezustand im 'Ausschalten'-Dialog"

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2389.htm


Willkommensseite mit der Anzahl der neuen Emails

Bei Rechnern, die keiner Domäne angehören, wird standardmäßig eine Willkommensseite angezeigt. Hier finden Sie unter den jeweiligen Namen der Anwender einen Link auf dem Sie sich die Anzahl der nicht gelesenen Email anzeigen lassen können.

Wenn Sie diesen Wert auf 0 setzen wird das nicht mehr angezeigt, die Höhe der Zahl entspricht die Zeit in Tagen wie lange eine Mail als neu gilt.

Diese Funktion wird bisher nur vom Messenger (MSN) und Outlook Express unterstützt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ UnreadMail

Erstellen Sie hier einen neuen Wert mit dem Namen "MessageExpiryDays" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1-30 | Anzahl der Tage wie lange eine Mail als neu gilt
0 | Keine Anzeige

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1467.htm


Automatisches Anmelden ohne Passworteingabe deaktivieren

Diese Funktion ermöglicht unter Windows die automatische Anmeldung ohne die Eingabe eines Passworts.

Die Funktion können Sie über die Registry deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Finden Sie den Eintrag "ForceAutoLogon" als Datentyp REG_SZ. Wenn Sie den Wert auf 0 setzen, wird die Funktion wieder ausgeschaltet.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1355.htm


Benutzerkonten auf der Anmeldemaske

Mit den folgenden Tipp können Sie verhindern, dass Benutzeraccounts in der Anmeldemaske von Windows angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon\ SpecialAccounts\ UserList

Soll ein Benutzer nicht angezeigt werden, erzeugen Sie hier einen neuen Eintrag mit den Namen des Benutzers als Datentyp REG_DWORD und setzen den Wert auf:

0 | Benutzerkonto nicht anzeigen
1 | Benutzerkonto anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Hier eine Ergänzung von "Rainer Liese"

Frage:

Der neue Anmeldebildschirm von Windows XP enthält für alle Benutzer des Systems ein Bildchen und den Benutzernamen zum Anklicken. Starten schön – aber wie melde ich den Administrator an?

Antwort:

Einfach zweimal die altbekannte Tastenkombination [Strg-Alt-Entf] benutzen. Es erscheint das Fenster zur Eingabe von Benutzernamen und Passwort. Leider geht dieser Trick nicht mehr ab Windows Vista.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1550.htm


Passport Balloon Hinweis ausschalten

Wenn Sie sich an Windows anmelden, werden Sie darauf hingewiesen, ein .NET-Passport bei Microsoft einzurichten. Wenn Sie kein MSN oder .NET Passport benutzen, stört dieser Hinweis. Mit diesem Tipp können Sie den Hinweis ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ MessengerService

Erstellen Sie hier einen neuen Wert mit dem Namen "PassportBalloon" als Datentyp REG_BINARY. Setzen Sie den Wert auf:

0A 00 00 00

Balloon Hinweis ausschalten

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1609.htm


Schnelle Benutzerumschaltung und Willkommenseite konfigurieren

Mit diesem Tipp können Sie einstellen, ob beim Start die Anmeldeseite als "Willkommenseite" angezeigt wird (für die Accounts werden entsprechende Icons angezeigt) oder ob die klassische Anzeige mit dem Anmeldedialog verwendet werden soll.

In der klassischen Anzeige muss der Anwender seinen Accountnamen + sein Passwort eingeben.

Wenn Sie die "Willkommenseite" aktiviert haben, dann können Sie noch die "schnelle Benuterumschaltung" aktivieren. Damit können sich mehrere Benutzer gleichzeitig anmelden, und man kann zwischen den Accounts umschalten. Ist diese Funktion nicht aktiv, kann sich immer nur ein Benutzer anmelden.

Die "Willkommenseite" kann nur aktiviert werden, wenn der Rechner sich nicht in einer Domäne befindet. Für Rechner in einer Domäne steht nur die "klassische Anzeige" zu Verfügung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

Erstellen Sie hier einen neuen Wert mit dem Namen "LogonType" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es wird die Willkommenseite verwendet
0 | Es wird die klassische Anmeldeseite verwendet

Wenn Sie LogonType aktiviert haben, können Sie noch folgende Einstellung konfigurieren:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon

bzw. als Policy:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "AllowMultipleTSSessions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Mehrere Anmeldungen zulassen
0 | Nur eine Anmeldung zulassen

Info Wenn Sie beide Einträge deaktivieren (auf 0 setzen), wird eine schwarze Bildschirmseite angezeigt, wenn der Wert "Background" unter "HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon" noch vorhanden ist und auf "0 0 0" steht.

Löschen Sie dann einfach diesen Eintrag, damit die Standardfarbe "blau" verwendet wird.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1823.htm


Hilfetext auf der Anmeldeseite festlegen

Mit diesem Tipp können Sie einen Hilfetext auf der Windows Anmeldeseite festlegen. Wenn Sie hier einen Text eingeben, erscheint neben dem Passworteingabefeld ein ?-Symbol. Wird das Symbol angeklickt, wird der Text angezeigt.

Diese Funktion geht nur, wenn der Rechner:

  • Nicht Mitglied einer Domäne ist.
  • Die Anmeldeoption unter "Systemsteuerung" -> "Benutzerkonten" hier "Art der Benutzeranmeldung ändern "Auswählen. Dort muss jetzt er Eintrag "Willkommenseite verwenden" aktiviert sein.

Ansonsten wird der Eintrag nicht angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Hints\ [Username]

[Username] -> Hier müssen Sie den Anmeldenamen des Accounts (%Username%) eingeben.

geben Sie hier bei (Standard) als Datentyp REG_SZ den Text ein der Angezeigt werden sollen, wenn auf das ?-Symbol geklickt wird.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2050.htm


Startskripts während der Ausführung beim Login anzeigen

Startscripts während der Ausführung beim Login anzeigen

Normalerweise werden Startskripts während der Ausführung beim Login nicht angezeigt. Für eine Fehlersuche kann es hilfreich sein, wenn solche Skripts während der Ausführung angezeigt werden, weil man somit eventuelle Rückmeldungen auch sichtbar machen kann.

Mit diesem Tipp können Sie das Anzeigen von Skripten aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ System

ändern Sie hier den Wert "HideStartupScripts" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Skripte bei der Ausführung anzeigen
1 (gelöscht) | Skripte bei der Ausführung nicht anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Skripts
Einstellungsname: | Startskripts sichtbar ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2062.htm


Windows Dienste: Allgemeine Informationen

Da unter Windows Vista zu den bestehenden Diensten wieder einige neue Dienste hinzugekommen sind und wir viele Anfragen zu den Diensten und deren Konfigurationen erhalten haben, hier nun eine Aufstellung der Dienste.

Zunächst werden wir nur die Windows Vista Dienste betrachtet, was aber nicht bedeutet, dass viele der Dienste nicht auch unter Windows XP;2000 zu finden sind. Wir werden sicherlich auch die Betriebssysteme betrachten und entsprechend das Icon und Anmerkungen hinzufügen, weiterhin finden Sie hier aber auch eine einfache Übersicht im Tipp: "Die Windows Dienste und ihre Funktionen".

Nicht alle Dienste die Standardmäßig von Windows gestartet werden sind nötig, da aber jeder Dienst Arbeitsspeicher und Rechenleistung verbraucht, können Sie durch das beenden von Diensten Ihren Rechner etwas entlasten. Erwarten Sie dadurch aber keinen starken Performance-Gewinn, Sie können damit meist nur leicht die Performance des Rechners verbessern. Wenn Sie nicht so gern experimentieren und lieber auf der sicheren Seite sein wollen das alles geht, sollten Sie die Einstellungen der Dienste lieber nicht verändern.

Die Übersicht kann Ihnen aber auch helfen, wenn Sie Ihre Konfiguration der Dienste verstellt haben, da hier auch die Standardeinstellungen der jeweiligen Betriebsysteme aufgeführt werden.

  • Übersicht der Dienste unter Windows XP
  • Übersicht der Dienste unter Windows Vista
  • Übersicht der Dienste unter Windows Server 2008
  • Übersicht der Dienste unter Windows 7

Einstellungen der Windows Dienste verändern

Mit "SERVICES.MSC" können Sie sich alle Dienste anzeigen lassen und die Einstellungen verändern. Rufen Sie dafür das Programm über Start -> Ausführen oder Suchen bzw. über die Tastenkombination [Windows Taste]+[R] durch die Eingabe von SERVICES.MSC auf.

Es wird ein neues Fenster "Dienste" geöffnet in welchen alle Dienste, die auf dem Computer installiert sind, aufgelistet werden. Die Liste der Dienste enthält auf den meisten Rechnern noch zusätzliche Einträge, welche bei der Installation von anderen Anwendungen (z.B. Virenscanner) hinzugefügt und nicht von Microsoft geliefert wurden.

In der Tabelle sehen Sie in der Spalte "Status", welche Dienste auf Ihrem Rechner aktuell gestartet wurden.

Windows Dienste und die Konfiguration in der Registry

Die Konfiguration der Dienste wird in der Registry gespeichert und kann somit auch über REG-Dateien entsprechend geändert werden. Deshalb haben wir zu jeden Tipp immer den Pfad angegeben, wo der Dienst in der Registry gespeichert wird.

Im Tipp: "Dienste und Geräte unter Windows" finden Sie die möglichen Registryeinträge beschrieben.

Info Mit dem Befehl SC können Sie die Dienste über die Kommandozeilenoberfläche verändern bzw. auch neue Dienste einrichten. Weitere Informationen finden Sie im Tipp: Informationen über den Befehl SC

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2268.htm


Übersicht der Dienste unter Windows XP

Hier finden Sie eine Übersicht der Dienste unter Windows XP und wie diese konfiguriert sind.

Lesen Sie sich immer die Beschreibung des Dienstes durch und überlegen Sie, ob diese Funktion benötigt wird. Es gibt einige Dienste, die zwingend für das Funktionieren von Windows benötigt werden.

Info Eine Deaktivierung eines Dienstes kann dazu führen, dass Windows nicht mehr startet bzw. Sie sich nicht mehr anmelden können.

Info Gehen Sie beim Verändern der Einstellungen vorsichtig vor, da es dazu führen kann, dass bestimmt Funktionen unter Windows nicht mehr laufen.

Wir geben zwei Empfehlungen in der Tabelle an:

  • Empfehlung Normal: Hier werden nur wenige Dienste verändert. Diese Konfiguration sollte auf den meisten Rechnern zu keinen Problemen führen und keine wichtigen Funktionen einschränken.
  • Empfehlung Minimal: In dieser Einstellungen werden schon recht viele Dienste ausgeschaltet. Es stehen nicht mehr viele Funktionen zur Verfügung. Dieses Einstellung ist für Anwender geeignet, die mit dem Rechner nur spielen wollen und dafür jede zusätzliche Leistung benötigen.

Weiteres Infos zu Diensten finden Sie im Tipp: "Windows Dienste: Allgemeine Informationen"

Dienstname | Windows Home | Professional | Empfehlung Normal | Empfehlung Minimal
Ablagemappe | Manuell | Manuell | Deaktiviert | Deaktiviert
Anmeldedienst | Manuell | Manuell | Manuell | Deaktiviert
Anwendungsverwaltung | Manuell | Manuell | Manuell | Deaktiviert
Arbeitsstationsdienst | Automatisch | Automatisch | Automatisch | Deaktiviert
Automatische Updates | Automatisch | Automatisch | Automatisch | Deaktiviert
COM+-Ereignissystem | Manuell | Manuell | Manuell | Manuell
COM+-Systemanwendung | Manuell | Manuell | Manuell | Deaktiviert
Computerbrowser | Automatisch | Automatisch | Manuell | Deaktiviert
DCOM-Server-Prozessstart | Automatisch | Automatisch | Automatisch | Automatisch
Designs | Automatisch | Automatisch | Automatisch | Deaktiviert
DHCP-Client | Automatisch | Automatisch | Automatisch | Deaktiviert
Dienst für Seriennummern der tragbaren Medien | Automatisch | Automatisch | Manuell | Deaktiviert
Distributed Transaction Coordinator | Manuell | Manuell | Deaktiviert | Deaktiviert
DNS-Client | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Druckwarteschlange | Automatisch | Automatisch | Automatisch | Deaktiviert
Eingabegerätezugang | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Ereignisprotokoll | Automatisch | Automatisch | Automatisch | Automatisch
Fehlerberichterstattungsdienst | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Gatewaydienst auf Anwendungsebene | Manuell | Manuell | Manuell | Deaktiviert
Geschützter Speicher | Manuell | Manuell | Manuell | Deaktiviert
Hilfe und Support | Automatisch | Automatisch | Manuell | Deaktiviert
HTTP-SSL | Manuell | Manuell | Deaktiviert | Deaktiviert
IMAPI-CD-Brenn-COM-Dienste | Manuell | Manuell | Deaktiviert | Deaktiviert
Infrarotüberwachungsdienst | Automatisch | Automatisch | Automatisch | Deaktiviert
Intelligenter Hintergrundübertragungsdienst | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell
IPSEC-Dienste | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Kryptografiedienste | Automatisch | Automatisch | Manuell | Manuell
Leistungsprotokolle und -Warnungen | Manuell | Manuell | Deaktiviert | Deaktiviert
Netzwerkverbindungen | Manuell | Manuell | Manuell | Deaktiviert
NLA (Network Location Awareness) | Automatisch | Automatisch | Automatisch | Deaktiviert
Plug & Play | Automatisch | Automatisch | Automatisch | Automatisch
RAS-Verbindungsverwaltung | Manuell | Manuell | Manuell | Deaktiviert
Remoteprozeduraufruf (RPC) | Automatisch | Automatisch | Automatisch | Automatisch
Remote-Registrierung | Manuell | Manuell | Manuell | Deaktiviert
Routing und RAS | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
RPC-Locator | Manuell | Manuell | Manuell | Deaktiviert
Sekundäre Anmeldung | Automatisch | Automatisch | Manuell | Deaktiviert
Server | Automatisch | Automatisch | Manuell | Deaktiviert
Shellhardwareerkennung | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Sicherheitscenter | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell | Manuell
Sicherheitskontenverwaltung | Automatisch | Automatisch | Automatisch | Automatisch
Smartcard | Manuell | Manuell | Deaktiviert | Deaktiviert
SSDP-Suchdienst | Manuell | Manuell | Deaktiviert | Deaktiviert
TCP/IP-NetBIOS-Hilfsdienst | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Telefonie | Manuell | Manuell | Deaktiviert | Deaktiviert
Terminaldienste | Automatisch | Automatisch | Manuell | Deaktiviert
Überwachung verteilter Verknüpfungen (Client) | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Universeller Plug & Play-Gerätehost | Manuell | Manuell | Deaktiviert | Deaktiviert
Verwaltung für automatische RAS-Verbindung | Manuell | Manuell | Deaktiviert | Deaktiviert
Volumeschattenkopie | Manuell | Manuell | Deaktiviert | Deaktiviert
Webclient | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Windows Installer | Manuell | Manuell | Manuell | Manuell
Windows-Audio | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Bilderfassung | Manual | Manual | Manual | Deaktiviert
Windows-Suche | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Verwaltungsinstrumentation | Automatisch | Automatisch | Automatisch | Automatisch
Windows-Zeitgeber | Automatisch | Automatisch | Automatisch | Deaktiviert
WMI-Leistungsadapter | Manuell | Manuell | Deaktiviert | Deaktiviert

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2474.htm


Windows Dienste: Ablagemappe

Der Dienst "ClipSrv" wird für die Ablagemappe in Netzwerken benötigt. Ist der Dienst aktiv, können über das Netzwerk Einträge aus der Ablagemappe mit anderen Rechnern ausgetauscht werden. Da diese Funktion in den meisten Fällen nicht benötigt wird, können Sie den Dienst deaktivieren.

Allgemeine Informationen
Anzeigename | Ablagemappe
Dienstname | ClipSrv
Windows Beschreibung | Ermöglicht der Ablagemappe, Informationen zu speichern und mit Remotecomputern auszutauschen. Wenn dieser Dienst beendet wird, wird die Ablagemappe keine Informationen mehr mit Remotecomputern austauschen können. Wenn dieser Dienst deaktiviert wird, werden alle von diesem Dienst explizit abhängigen Dienste nicht gestartet werden können.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Netzwerk-DDE-Dienst
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ClipSrv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2538.htm


Windows Dienste: Anmeldedienst

Dieser Dienst wird für die Anmeldung an einer Domäne benötigt. Ohne diesen Dienst ist eine Anmeldung nicht möglich.

Gültig für: Alle Windows Vista Versionen

Alle Windows 7 Versionen (außer Starter)

Allgemeine Informationen
Anzeigename | Anmeldedienst
Dienstname | Netlogon
Windows Beschreibung | Unterstützt einen sicheren Kanal zwischen diesem Computer und dem Domänencontroller zum Authentifizieren von Benutzern und Diensten. Möglicherweise wird der Computer die Benutzer und Dienste nicht authentifizieren, und der Domänencontroller kann keine DNS-Einträge registrieren, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Arbeitsstationsdienst
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Netlogon

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2269.htm


Windows Dienste: Anwendungsverwaltung

Dieser Dienst verwaltet die Installation und Deinstallation von Programmen, welche über die Gruppenrichtlinien von Windows verwaltet werden. Wenn der Dienst beendet wird, können Sie keine Programme iInstallieren oder deinstallieren, welche über die Gruppenrichtlinien verteilt wurden. Weiterhin können die installierten Programme auch nicht aufgelistet werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Anwendungsverwaltung
Dienstname | AppMgmt
Windows Beschreibung | Verarbeitet Installations-, Deinstallations- und Auflistungsanforderungen für Software, die über Gruppenrichtlinien bereitgestellt wird. Benutzer können Software, die über Gruppenrichtlinien bereitgestellt wird, nicht installieren, deinstallieren oder auflisten, wenn der Dienst deaktiviert ist. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ AppMgmt

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2273.htm


Windows Dienste: Arbeitsstationsdienst

Der Arbeitsstationsdienst von Microsoft ist ein Netzwerkbasisdienst, und er stellt eine Reihe von grundsätzlichen Funktionen zur Kommunikation zwischen Rechnern und Programmen zur Verfügung. Der Arbeitsstationsdienst (WKSSVC.DLL) wird unter Windows dazu benutzt, um auf freigegebene Ressourcen (Verzeichnisse, Drucker usw.) zuzugreifen. Der Zugriff erfolgt entweder über NetBIOS API oder über MS Direct Share (ab Windows 2000). Dafür benutzt der Arbeitsstationsdienst eine Reihe von RPC-Funktionen (Named Pipes über NetBIOS und Direct Share).

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Arbeitsstationsdienst
Dienstname | LanmanWorkstation
Windows Beschreibung

Erstellt und wartet Clientnetzwerkverbindungen mit Remoteservern unter Verwendung des SMB-Protokolls. Diese Verbindungen sind nicht mehr verfügbar, falls dieser Dienst beendet wird.

Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch

Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind

Benötigt | Browser, Netzwerkspeicher-Schnittstellendienst, SMB 1.x MiniRedirector, SMB 2.0 MiniRedirector
Wird benötigt | Anmeldedienst, Computerbrowser, Terminaldienstekonfiguration

Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")

Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanWorkstation

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2279.htm


Windows Dienste: Windows Update

Der Dienst "wuauserv" ist für die Installation, Erkennung und das Herunterladen von Windows Updates zuständig. Der Dienst wird für die Funktion"Windows Updates" und "Automatische Updates" benötigt. Weiterhin wird der Dienst noch von Programmen benötigt, die über die "Windows Update Agent-Programmierschnittstelle" (WUA) arbeiten.

Wenn Sie den Dienst deaktivieren können also keine Updates mehr durchgeführt werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows XP: Automatische Updates Ab Vista: Windows Update
Dienstname | wuauserv
Windows Beschreibung | Erkennung, Herunterladen und Installation von Updates für Windows und andere Programme. Wenn der Dienst deaktiviert ist, können "Windows Update" bzw. die Funktion "automatische Updates" nicht verwendet werden. Außerdem können Programme dann die Windows Update Agent-Programmierschnittstelle (WUA API) nicht verwenden.
Windows Starttyp | Windows XP: Automatisch Ab Vista: Automatisch (Verzögerter Start)
Empfehlung Starttyp | Windows XP: Automatisch Ab Vista: Automatisch (Verzögerter Start)
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wuauserv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2485.htm


Windows Dienste: COM+-Ereignissystem

Dieser Dienst kümmert sich um die Verteilung von Ereignissen an COM (Component Object Modul) Komponenten. Dadurch müssen die Programme nicht selber nachfragen, ob eine Nachricht (Event) eingetreten ist, sondern werden über die COM+ darüber informiert. Wird der Dienst deaktiviert, werden keinen SENS (System Event Notification) mehr verteilt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | COM+-Ereignissystem
Dienstname | EventSystem
Windows Beschreibung | Unterstützt den Systemereignis-Benachrichtigungsdienst (SENS), mit dem Ereignisse automatisch an abonnierende COM-Komponenten verteilt werden. Nach dem Beenden des Dienstes wird SENS geschlossen, so dass keine weiteren Anmelde- und Abmeldebenachrichtigungen bereitgestellt werden können. Nach dem Deaktivieren des Dienstes können alle Dienste nicht mehr gestartet werden, die explizit auf diesem Dienst basieren.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Benachrichtigungsdienst für Systemereignisse, COM+-Systemanwendung, DFS-Replikation, Intelligenter Hintergrundübertragungsdienst, SL-Benutzerschnittstellen-Benachrichtigungsdienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ EventSystem

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2288.htm


Windows Dienste: COM+-Systemanwendung

Der Dienst "COMSysApp" verwaltet und überwacht die DCOM-Komponenten.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | COM+-Systemanwendung
Dienstname | COMSysApp
Windows Beschreibung | Verwaltet die Komponenten-Konfiguration und -überwachung von COM+-basierten Komponenten. Nach dem Beenden des Dienstes sind die meisten COM+-basierten Komponenten nicht ordnungsgemäß funktionsfähig. Nach dem Deaktivieren dieses Dienstes werden alle Dienste nicht gestartet, die explizit auf diesem Dienst basieren.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Benachrichtigungsdienst für Systemereignisse, COM+-Ereignissystem, Remouteprozedurausruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ COMSysApp

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2289.htm


Windows Dienste: Computerbrowser

Erstellt und Verwaltet eine Liste alle im Netzwerk verfügbaren Computer und Freigaben. Der Dienst gibt diese Liste auch an andere Computer weiter, wenn der Dienst nicht läuft, wird diese Liste nicht mehr aktualisiert. Wird nur in Netzwerken benötigt und kann auch dort deaktiviert werden, wenn der Server diesen Dienst anbietet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Computerbrowser
Dienstname | Browser
Windows Beschreibung | Führt eine aktuelle Liste der Computer im Netzwerk und gibt diese an als Browser fungierende Computer weiter. Diese Liste wird nicht aktualisiert oder gewartet, falls der Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell Kein Netzwerk oder Server übernimmt die Aufgabe: Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Arbeitsstationsdienst, Server
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Browser

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2290.htm


Windows Dienste: DCOM-Server-Prozessstart

Dieser Dienst wird vom RPC benötigt und darf deshalb nicht beendet werden. Dieser Dienst kümmert sich um Funktionen, die eine lokale Systemberechtigung erfordern (Systemkonto).

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | DCOM-Server-Prozessstart
Dienstname | DcomLaunch
Windows Beschreibung | Bietet Startfunktionalität für DCOM-Dienste.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Ab Windows Vista: Remoteprozeduraufruf (RPC)
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ DcomLaunch

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2291.htm


Windows Dienste: Designs

Diese Dienst ist für die neue Desktopoberfläche (Aero) notwendig. Wenn Sie auf die "klassische Oberfläche" umschalten, wird diese Dienst nicht gestartet. Wenn Sie nur mit der klassischen Oberfläche arbeiten, können Sie diesen Dienst deaktivieren.

Für die AERO-Effekte wird der Dienst "Sitzungs-Manager für Desktopfenster-Manager" benötigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Designs
Dienstname | Themes
Windows Beschreibung | Stellt die Designverwaltung zur Verfügung.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Unter der "klassischen Oberfläche": Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Themes

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2292.htm


Windows Dienste: DHCP-Client

Der DHCP-Client holt sich automatisch eine IP-Adresse aus dem Netzwerk. Wenn Sie mit manueller IP-Vergabe arbeiten, können Sie diesen Dienst deaktivieren. Bedenken Sie aber, dass Sie für die Benutzung des Internet, meist diesen Dienst benötigen, da viele Anbieter bei der Einwahl eine IP zuordnen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | DHCP-Client
Dienstname | Dhcp
Windows Beschreibung | Registriert und aktualisiert IP-Adressen und DNS-Einträge für diesen Computer. Dieser Computer kann keine dynamischen IP-Adressen und DNS-Aktualisierungen empfangen, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Ancillary Function Driver for Winsock, NetIO-Legacy-TDI-Supporttreiber, Netzwerkspeicher-Schnittstellendienst
Wird benötigt | WinHTTp-Web Proxy Auto-Discovery-Dienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Dhcp

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2294.htm


Windows Dienste: Dienst für Seriennummern der tragbaren Medien

Der Dienst "WmdmPmSN" wird für das verwalten von geschützten Dateien benötigt. Der Dienst ist nur notwendig für den Anschluss portabler MP3- und Mediaplayer. Über dem Dienst wird die Seriennummer des tragbaren Players ausgelesen, dies ist Voraussetzung für das Übertragen von DRM-geschützter Inhalte auf den Player.

Wenn Sie den Dienst deaktivieren, kann das Übertragen von geschützten Mediendateien (z.B. gekauften WMA's) auf die tragbaren Geräte nicht mehr funktionieren.

Allgemeine Informationen
Anzeigename | Dienst für Seriennummern der tragbaren Medien
Dienstname | WmdmPmSN
Windows Beschreibung | Ruft die Seriennummer aller tragbaren Player für Medien ab, die mit diesem Computer verbunden sind. Wenn der Dienst beendet wird, werden geschützte Inhalte möglicherweise nicht auf das Gerät gedownloadet.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WmdmPmSN

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2539.htm


Windows Dienste: Distributed Transaction Coordinator

Der Dienst "MSDTC" koordiniert Transaktionen, die über verschiedene Computersysteme verteilt sind (z.B. Datenbanken usw.). In den meisten Fällen kann dieser Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Distributed Transaction Coordinator
Dienstname | MSDTC
Windows Beschreibung | Koordiniert Transaktionen, die sich über mindestens zwei Ressourcenverwaltungen wie Datenbanken, Nachrichtenwarteschlangen oder Dateisysteme erstrecken. Wenn der Dienst beendet ist, treten diese Transaktionen nicht auf. Wenn der Dienst deaktiviert ist, können abhängige Dienste nicht gestartet werden.
Windows Starttyp | Windows XP/Vista: Manuell Windows 2008: Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC), Sicherheitskonto-Manager
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MSDTC

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2298.htm


Windows Dienste: DNS-Client

Über den Dienst "Dnscache" DNS-Client (Dynamic Name System) wird die Namensauflösung ausgeführt und zwischengespeichert. In Windows 2000 Domänen wird dieser Dienst für die Kommunikation mit dem Domänen-Controller benötigt. Wenn der Dienst nicht aktiv ist, kann der Rechner nicht über den DNS-Namen mit den Host kommunizieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | DNS-Client
Dienstname | Dnscache
Windows Beschreibung | Der DNS-Clientdienst (dnscache) speichert DNS-Namen (Domain Name System) zwischen und registriert den vollständigen Computernamen für diesen Computer. Wenn der Dienst beendet wird, werden DNS-Namen weiterhin aufgelöst. Die Ergebnisse von DNS-Namensabfragen werden jedoch nicht zwischengespeichert, und der Name des Computers wird nicht registriert. Wenn der Dienst deaktiviert ist, können alle explizit von ihm abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | NetIO-Legacy-TDI-Supporttreiber
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Dnscache

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2299.htm


Windows Dienste: Druckwarteschlange

Die Druckerwarteschlange "Spooler" ist zum Drucken erforderlich. Ohne die Druckerwarteschlange kann auch kein Drucker installiert werden. Wenn Sie über diesen Rechner nicht Drucken, können Sie den Dienst auch deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Druckwarteschlange
Dienstname | Spooler
Windows Beschreibung | Lädt Dateien zum späteren Drucken in den Arbeitsspeicher.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP, Remouteprozeduraufruf (RPC)
Wird benötigt | Fax
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Spooler

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2300.htm


Windows Dienste: Zugriff auf Eingabegeräte

Der Dienst "hidserv" ist für die Funktion von speziellen Eingabegeräten zuständig. Der Dienst ermöglicht die Nutzung der Hot-Buttons von Spezialtastaturen, Fernbedienungen, Scanner- und Fax-Geräten sowie von Multimedia-Peripherien.

Wenn Sie solche Geräte nicht benutzen, dann können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows XP: Eingabegerätezugang Ab Windows Vista: Zugriff auf Eingabegeräte
Dienstname | hidserv
Windows Beschreibung | Ermöglicht einen Standardzugriff auf Eingabegeräte (HID-Geräte), der die Verwendung von vordefinierten Abkürzungstasten auf Tastaturen, Fernbedienungen und anderen Multimediageräten aktiviert und unterstützt. Wenn dieser Dienst beendet wird, werden die von diesem Dienst gesteuerten Abkürzungstasten nicht mehr funktionieren. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Windows XP: Deaktiviert Windows Vista: Manuell Windows 2008: Automatisch
Empfehlung Starttyp | Deaktivieren
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ hidserv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2505.htm


Windows Dienste: Windows-Ereignisprotokoll

Der Dienst "Eventlog" ist dafür, zuständig bestimmte Ereignisse in das Ereignisprotokoll einzutragen. Dabei kann es sich um Fehlermeldungen oder nur um entsprechende Informationen handeln (erfolgreiche Anmeldung usw.). Dieser Dienst sollte nicht deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | XP: Ereignisprotokoll Ab Vista: Windows-Ereignisprotokoll
Dienstname | Eventlog
Windows Beschreibung | Dieser Dienst verwaltet Ereignisse und Ereignisprotokolle. Er unterstützt die Protokollierung, Abfrage und Abonnieren von Ereignissen sowie die Archivierung von Ereignisprotokollen und die Verwaltung von Ereignismetadaten. Er kann Ereignisse im XML- und Nur-Text-Format anzeigen. Durch das Beenden dieses Dienstes können die Sicherheit und Zuverlässigkeit des Systems beeinträchtigt werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Aufgabenplanung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2490.htm


Windows Dienste: Fehlerberichterstattungsdienst

Der Dienst "ERSvc" ist dafür zuständig bei einem Absturz einer Anwendung eine E-Mail mit Informationen an Microsoft zu verschicken (Fehlerberichterstattung). Dazu wird eine entsprechende Info-Box angezeigt und wenn der Anwender die bestätigt, wird eine Mail an Microsoft verschickt. Der Bericht enthält die Fehlermeldung und den Speicherauszug wo der Fehler aufgetreten ist.

Wer diese Informationen sowieso nicht an Microsoft versenden will, kann den Dienst deaktivieren.

Allgemeine Informationen
Anzeigename | Fehlerberichterstattungsdienst
Dienstname | ERSvc
Windows Beschreibung | Ermöglicht die Fehlerberichterstattung für Dienste und Anwendungen, die in nicht standardgemäßen Umgebungen ausgeführt werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ERSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2540.htm


Windows Dienste: Gatewaydienst auf Anwendungsebene

Der Dienst "ALG" (Application Layer Gateway), wird nur benötigt, wenn man das Internet Connection Sharing (ICS) oder die Internetverbindungs-Firewall benutzt. Dieser Dienst benutzt den TCP-Port >3000.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Gatewaydienst auf Anwendungsebene
Dienstname | ALG
Windows Beschreibung | Bietet Unterstützung für Protokoll-Plug-Ins von Drittanbietern für die gemeinsame Nutzung der Internetverbindung.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ALG

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2341.htm


Windows Dienste: Geschützter Speicher

Dieser Dienst "ProtectedStorage" stellt einen geschützten Speicherbereich zur Verfügung, in dem vertrauliche Daten abgelegt werden können (Passwörter, private Schlüssel usw.). Der Zugriff von anderen Benutzern und Prozessen wird auf diesen Speicherbereich verhindert.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Geschützter Speicher
Dienstname | ProtectedStorage
Windows Beschreibung | Bietet geschützten Speicher für schützenswerte Daten, z. B. Kennwörter, und verhindert den Zugriff durch nicht autorisierte Dienste, Prozesse oder Benutzer.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ProtectedStorage

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2343.htm


Windows Dienste: Hilfe und Support

Der Dienst "helpsvc" ist die Basiskomponente des "Microsoft Help and Support Center". Der Dienst aktiviert nach drücken von <F1> oder Aufruf des "Hilfe"-Menüs das Support-Center.

Allgemeine Informationen
Anzeigename | Hilfe und Support
Dienstname | helpsvc
Windows Beschreibung | Aktiviert das Hilfe- und Supportcenter auf diesem Computer. Das Hilfe- und Supportcenter ist nicht verfügbar, wenn dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2541.htm


Windows Dienste: HTTP-SSL

Der Dienst "HTTPFilter" stellt das verschlüsselte HTTPS-Protokoll für sichere HTTP-Verbindungen bereit. Da der Dienst aber nur auf dem Server benötigt wird, können Sie den Dienst auf Client-Rechnern auch deaktivieren.

Allgemeine Informationen
Anzeigename | HTTP-SSL
Dienstname | HTTPFilter
Windows Beschreibung | Implementiert das Secure HyperText Transfer-Protokoll (HTTPS) für den HTTP-Dienst unter Verwendung des Secure Socket Layers (SSL). Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ HTTPFilter

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2542.htm


Windows Dienste: IMAPI-CD-Brenn-COM-Dienste

Der Dienst "ImapiService" ist für die Windows-eigene Brennfunktion von CD/DVDs erforderlich. Wenn Sie zum erstellen von CD/DVDs eine andere Software benutzen, können Sie den Dienst auch deaktivieren.

Allgemeine Informationen
Anzeigename | IMAPI-CD-Brenn-COM-Dienste
Dienstname | ImapiService
Windows Beschreibung | Verwaltet das Aufnehmen von CDs mit IMAPI (Image Mastering Applications Programming Interface). Auf diesem Computer können keine CDs aufgenommen werden, wenn dieser Dienst angehalten wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ImapiService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2543.htm


Windows Dienste: Infrarot-Überwachungsdienst

Dieser Dienst "Irmon" unterstützt auf dem Computer installierte Infrarotgeräte und sucht nach anderen Geräten in Reichweite.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Infrarot-Überwachungsdienst
Dienstname | Irmon
Windows Beschreibung | Erkennt andere Infrarotgeräte in Reichweite und startet die Dateiübertragungsanwendung. Wenn Sie den Dienst anhalten, kann die Dateiübertragung nicht mehr ausgeführt werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | IrDA-Protokoll
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Irmon

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2346.htm


Windows Dienste: Intelligenter Hintergrund-Übertragungsdienst

Bei dem Dienst "BITS" (Intelligenter Hintergrund-Übertragungsdienst) handelt es sich um einen Downloadmanager.

Der Dienst kümmert sich bei automatischen Windows Updates darum, dass die ungenutzte Bandbreite optimal ausgenutzt wird und der Anwender bei seiner Arbeit nicht behindert wird. Wird das Downloaden unterbrochen, wird über diesen Dienst dafür gesorgt, dass der Download zu einem späteren Zeitpunkt automatisch wieder aufgenommen wird.

Info Der Dienst sollte nicht abgeschaltet werden, da er auch für das Windows-Update benötigt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Intelligenter Hintergrund-Übertragungsdienst
Dienstname | BITS
Windows Beschreibung

Überträgt Dateien im Hintergrund unter Verwendung von sich in Leerlauf befindender Netzwerkbandbreite.

Falls dieser Dienst deaktiviert wird, können von BITS abhängige Anwendungen wie Windows Update oder MSN Explorer keine Programme und andere Informationen automatisch herunterladen.
Windows Starttyp | Automatisch (Verzögerter Start)
Empfehlung Starttyp | Automatisch (Verzögerter Start)
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | COM+-Ereignissystem; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ BITS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2348.htm


Windows Dienste: IPsec-Richtlinien-Agent

Der Dienst "IPsec-Richtlinien-Agent" sichert und kontrolliert in Windows die Übertragung von IP-Paketen. IPsec ist zuständig für die Überprüfung, die Authentifizierung und ggf. für die Verschlüsselung der Daten zuständig.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename

XP:IPSEC-Dienste

Ab Vista: IPsec-Richtlinien-Agent
Dienstname | PolicyAgent
Windows Beschreibung

IPsec (Internet Protocol Security) unterstützt die Peer-Authentifizierung auf Netzwerkebene, Datenursprungs-Authentifizierung, Datenvertraulichkeit (Verschlüsselung) und Schutz vor Wiedergabeangriffen.

Dieser Dienst erzwingt die IPsec-Richtlinien, die mit dem Snap-In "IP-Sicherheitsrichtlinien" oder mit dem Befehlszeilentool "netsh ipsec" erstellt wurden. Wenn Sie diesen Dienst beenden, können Probleme mit der Netzwerkkonnektivität auftreten, wenn die Richtlinie IPsec-Verbindungen erfordert. Zudem ist die Remoteverwaltung der Windows-Firewall nicht verfügbar, wenn dieser Dienst beendet wird.
Windows Starttyp

Windows Vista: Manuell

Windows 2008: Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Basisfiltermodul; TCP/IP-Protokolltreiber
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PolicyAgent

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2350.htm


Windows Dienste: Kryptografie-Dienste

Der Dienst "Kryptografiedienste" stellen die Schlüsselverwaltung für den Rechner bereit: Dieser Dienst bestehen aus verschiedenen Komponenten:

  • Katalogdatenbankdienst: Ist für das Hinzufügen, Entfernen und Durchsuchen von Katalogdateien verantwortlich. Katalogdateien werden verwendet, um alle Dateien im Betriebssystem zu signieren. Der Windows-Dateischutz (WFP), die Treibersignatur und das Setup verwenden diesen Dienst.
  • Dienst für geschützten Stammspeicher: Ist für das Hinzufügen und Entfernen von Zertifikaten vertrauenswürdiger Stammzertifizierungsstellen verantwortlich.
  • Schlüsseldienst: ermöglicht es Administratoren, Zertifikate im Auftrag des lokalen Computerkontos zu registrieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Kryptografiedienste
Dienstname | CryptSvc
Windows Beschreibung

Bietet 4 Verwaltungsdienste:

Katalogdatenbankendienst, der die Signaturen von Windows-Dateien bestätigt und die Installation neuer Programme ermöglicht;

Geschützten Stammdienst, der diesem Computer vertrauenswürdige Zertifikate von Stammzertifizierungsstellen hinzufügt und diese daraus entfernt;

Automatischen Aktualisierungsdienst für die Stammzertifizierung der Stammzertifikate vom Windows Update abruft und Szenarien wie SSL aktiviert;

Schlüsseldienst, von dem die Registrierung dieses Computers für Zertifikate unterstützt wird. Wird dieser Dienst beendet, funktionieren diese Verwaltungsdienste nicht ordnungsgemäß. Wird dieser Dienst deaktiviert, können alle ausdrücklich von diesem Dienst abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ CryptSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2351.htm


Windows Dienste: Leistungsprotokolle und -Warnungen

Der Dienst "pla" zeichnet die Systemleistung des Rechners in einem Logfile auf, wenn diese Funktion in den "Einstellungen für die benannte Protokollsammlung" angeordnet wurde und gibt, wenn definiert, auch Warnmeldungen aus.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Leistungsprotokolle und -Warnungen
Dienstname | pla
Windows Beschreibung

"Leistungsprotokolle und -warnungen" sammelt Leistungsdaten von lokalen oder Remotecomputern basierend auf vorkonfigurierten Zeitplanparameter und schreibt die Daten dann in ein Protokoll oder löst eine Warnung aus.

Wenn dieser Dienst beendet wird, werden keine Leistungsinformationen erfasst. Wenn dieser Dienst deaktiviert wird, können alle ausdrücklich von diesem Dienst abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ pla

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2353.htm


Windows Dienste: Netzwerkverbindungen

Der Dienst "Netman" ist für die Verwaltung das Netzwerkcenters zuständig. Im Netzwerkcenter werden alle LAN- und Remoteverbindungen angezeigt.

Wird der Dienst deaktivieren, wird in der Taskleiste kein Icon für Netzwerkverbindungen mehr angezeigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Netzwerkverbindungen
Dienstname | Netman
Windows Beschreibung | Verwaltet Objekte im Ordner "Netzwerk- und Wählverbindungen", in dem LAN- und Remoteverbindungen angezeigt werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Netzwerkspeicher-Schnittstellendienst; Remoteprozeduraufruf (RPC)
Wird benötigt | Gemeinsame Nutzung der Internetverbindung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Netman

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2360.htm


Windows Dienste: NLA (Network Location Awareness)

Der Dienst "NlaSvc" sammelt Informationen über die verbundenen Netzwerke und wird für die Netzwerkfreigabe benötigt. Wenn der Dienst nicht läuft, können andere Rechner nicht auf Ihre Netzwerkfreigaben zugreifen. Zusätzlich wird der Dienst noch von der Windows Firewall benutzt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | NLA (Network Location Awareness)
Dienstname | NlaSvc
Windows Beschreibung

Sammelt und speichert Konfigurationsinformationen für das Netzwerk und benachrichtigt Programme, wenn diese Informationen geändert werden. Wenn dieser Dienst beendet wird, sind die Konfigurationsinformationen möglicherweise nicht verfügbar.

Wenn dieser Dienst deaktiviert wird, können Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Netzwerkspeicher-Schnittstellendienst; Remoteprozeduraufruf (RPC); TCP/IP-Protokolltreiber
Wird benötigt | Netzwerklistendienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ NlaSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2361.htm


Windows Dienste: Plug & Play

Der Dienst "PlugPlay" wird für die automatische Erkennung von Hardwareänderungen benötigt. Erkennt der Dienst eine Hardwareänderung werden, durch den Dienst nötige Folgeoperationen veranlasst. Da der Dienst von vielen weiteren Diensten benötigt wird und die Benutzerfreundlichkeit stark beeinträchtigt ist, sollte der Dienst nicht deaktiviert werden.

Weiterhin kann das deaktivieren des Dienstes die Systemstabilität empfindlich mindern.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Plug & Play
Dienstname | PlugPlay
Windows Beschreibung | Ermöglicht dem Computer, Hardwareänderungen zu erkennen und sich ohne oder mit geringer Benutzerinteraktion darauf einzustellen. Beenden oder Deaktivieren dieses Dienstes wird die Systemstabilität beeinträchtigen.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Fax; Smartcard; Tablet PC-Eingabedienst; Telefonie; Virtueller Datenträger; Windows Driver Foundation - Benutzermodus-Treiberframework; Windows Modules Installer; Windows-Audio-Endpunkteerstellung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PlugPlay

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2366.htm


Windows Dienste: RAS-Verbindungsverwaltung

Der Dienst "RasMan" wird benötigt wenn Sie eine Verbindung über: Modem, VPN, ISDN-Verbindungen herstellen wollen. Bei DSL-Verbindungen wird der Dienst nur benötigt, wenn eine direkte PPPoP-Verbindung hergestellt werden soll für normal DSL-Verbindungen über einen Router ist der Dienst nicht notwendig.

Wenn Sie keine der oben aufgeführten Verbindungen mit Ihrem Rechner benutzen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | RAS-Verbindungsverwaltung
Dienstname | RasMan
Windows Beschreibung | Verwaltet Wähl- und VPN-Verbindungen zwischen diesem Computer und dem Internet oder anderen Remotenetzwerken. Wenn dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Telefonie
Wird benötigt | Gemeinsame Nutzung der Internetverbindung; Routing und RAS; Verwaltung für automatische RAS-Verbindung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RasMan

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2370.htm


Windows Dienste: Remoteprozeduraufruf (RPC)

Der Dienst "RpcSs" ist mit der wichtigste Dienst unter Windows. Die meisten anderen Dienste im System sind von diesem Dienst abhängig und können nicht gestartet werden, wenn dieser Dienst nicht läuft. Ein Deaktivieren dieses Dienstes führt dazu, dass mit Windows nicht mehr gearbeitet werden kann und das System auch nicht mehr richtig startet.

Info Da auch ein nachträgliches Aktivieren nur mit einigen Tricks zu bewerkstelligen ist, sollten Sie diesen Dienst auf keinen Fall deaktivieren.

Wer mehr darüber wissen möchte, findet bei Microsoft einige Informationen: http://technet2.microsoft.com/WindowsServer/de/Library/4c9a2873-2010-4dbb-b9dd-6a7d1e275f0f1031.mspx?mfr=true

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Remoteprozeduraufruf (RPC)
Dienstname | RpcSs
Windows Beschreibung | Dient der Endpunktzuordnung und als COM-Dienststeuerungsverwaltung. Wenn dieser Dienst beendet oder deaktiviert wird, werden Programme, die COM- oder RPC-Dienste verwenden, nicht mehr richtig funktionieren.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | DCOM-Server-Prozessstart
Wird benötigt | Anwendungsinformationen; Aufgabenplanung; Automatische Konfiguration (verkabelt); Automatische WLAN-Konfiguration; Basisfiltermodul; Benutzerprofildienst; CNG-Schlüsselisolation; COM+-Ereignissystem; COM+-Systemanwendung; DFS-Replikation; Distributed Transaction Coordinator; Druckerwarteschlange; Enumeratordienst für tragbare Geräte; Extensible Authentication-Protokoll; Fax; Funktionssuchanbieter-Host; Funktionssuche-Ressourcenveröffentlichung; Geschützter-Speicher; Gruppenrichtlinienclient; Integritätsschlüssel- und Zertifikatverwaltung; IP-Hilfsdienst; Startprogramm für Windows Media Center; Shellhardwareerkennung; Sicherheitscenter; Windows Update; Windows-Audio; Windows-Bilderfassung; Windows-Defender; Windows-Farbsystem; Windows-Remoteverwaltung (WS-Verwaltung); Windows-Sicherung; Windows-Sofortverbindung - Konfigurationsregistrierungsstelle; Windows-Suche; Windows-Verwaltungsinstrumentation; Zertifikatverteilung; usw.
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RpcSs

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2419.htm


Windows Dienste: Remoteregistrierung

Mit dem Dienst "RemoteRegistry" wird der Zugriff auf die Registry über das Netzwerk ermöglicht. Wenn der Dienst nicht mehr läuft, kann sich nicht mit der Registry auf anderen Rechnern verbunden werden. Wenn Sie keinen Remote-Zugriff auf die Registry über das Netzwerk benötigen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Remoteregistrierung
Dienstname | RemoteRegistry
Windows Beschreibung | Ermöglicht Remotebenutzern, Registrierungseinstellungen dieses Computers zu verändern. Wenn dieser Dienst beendet wird, kann die Registrierung nur von lokalen Benutzern dieses Computers verändert werden. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Windows Vista: Manuell Windows 2008: Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RemoteRegistry

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2420.htm


Windows Dienste: Routing und RAS

Der Dienst "RemoteAccess" ermöglicht die Verbindung mit einem Netzwerk über ein Modem oder ISDN. Auf dem Rechner mit dem man sich verbinden möchte, muss der RemoteAccess Dienst laufen, da ansonsten keine Einwahl möglich ist.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Routing und RAS
Dienstname | RemoteAccess
Windows Beschreibung | Bietet Routingdienste in LAN- und WAN-Netzwerkumgebungen.
Windows Starttyp | Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Basisfiltermodul; NetBIOSGroup; RAS-Verbindungsverwaltung; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RemoteAccess

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2422.htm


Windows Dienste: RPC-Locator

Der Dienst "RpcLocator" ist für die Verwaltung der RPC-Dienstnamendatenbank für verteilte Anwendungen im Netz zuständig. Auf den meisten Rechner wird dieser Dienst nicht benötigt und kann deshalb deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | RPC-Locator
Dienstname | RpcLocator
Windows Beschreibung | Verwaltet die RPC-Dienstnamendatenbank.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RpcLocator

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2423.htm


Windows Dienste: Sekundäre Anmeldung

Der Dienst "seclogon" ermöglicht es, Programme/Prozesse in einem anderen User-Kontext zu starten. Unter Windows können Sie das mit dem Befehl "RUNAS.EXE" (im Kontextmenü heißt das "Ausführen als") machen. Das wird benötigt, wenn Sie z.B. nicht als Administrator am Rechner angemeldet sind und eine Programm mit erweiterten Rechten (als Administrator) ausführen wollen.

Wenn Sie den Dienst deaktivieren, können keine Prozesse mehr im anderem User-Kontext gestartet werden. Sie können den Dienst aber auf "Manuell" stellen, so dass er nur gestartet wird, wenn er benötigt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Sekundäre Anmeldung
Dienstname | seclogon
Windows Beschreibung | Aktiviert das Starten von Prozessen mit verschiedenen Anmeldeinformationen. Wenn dieser Dienst beendet wird, wird dieser Typ von Anmeldezugriff nicht mehr verfügbar sein. Wenn dieser Dienst deaktiviert wird, können alle Dienste, die explizit von diesem Dienst abhängen, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ seclogon

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2424.htm


Windows Dienste: Server

Der Dienst "LanmanServer" ist für die Datei- und Druckerfreigabe im Netzwerk zuständig. Dieser Dienst wird automatisch gestartet, wird aber eigentlich nur benötigt, wenn Sie entsprechende Freigaben auf Ihren Rechner eingerichtet haben.

Wenn Sie mit keinen Freigaben auf Ihren Rechner arbeiten, können Sie den Dienst beenden. Da der Dienst von "Computerbrowser" benötigt wird, müssen Sie diesen Dienst auch entsprechend deaktivieren.

Auf Rechnern ohne Netzwerk können Sie den Dienst deaktivieren, ansonsten müssen Sie überlegen, ob Sie Verzeichnisse oder Drucker auf Ihrem Rechner für anderen Anwender freigeben wollen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Server
Dienstname | LanmanServer
Windows Beschreibung | Unterstützt Datei-, Drucker- und Named-Piped-Freigabe für diesen Computer über das Netzwerk. Diese Funktionen sind nicht mehr verfügbar, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Sicherheitskonto-Manager; srv
Wird benötigt | Computerbrowser
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2425.htm


Windows Dienste: Shellhardwareerkennung

Der Dienst "ShellHWDetection" ist für die Auto-Play-Funktion beim Anschließen von Datenträgern oder Einlegen von neuen Datenträgern in ein Laufwerk zuständig. Dieser Dienst sorgt u.a. dafür, dass beim Einlegen eines Datenträgern eine Dialogboxs aufgeht, in der man auswählen kann, mit welchen Programm der Inhalt geöffnet werden soll.

Wer diese Funktion nicht benötigt, kann den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Shellhardwareerkennung
Dienstname | ShellHWDetection
Windows Beschreibung | Zeigt Meldungen für Hardwareereignisse für automatische Wiedergabe an.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Windows-Bilderfassung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ShellHWDetection

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2427.htm


Windows Dienste: Sicherheitscenter

Der Dienst "wscsvc" ist für die Sicherheit zuständig. Mit diesem Dienst werden die Sicherheitseinstellungen überwacht. Die Windows Firewall und der Defender benötigen diesen Dienst.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Sicherheitscenter
Dienstname | wscsvc
Windows Beschreibung | Überwacht Systemsicherheitseinstellungen und -konfigurationen.
Windows Starttyp | Automatisch (Verzögerter Start)
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC); Windows-Verwaltungsinstrumentation
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wscsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2428.htm


Windows Dienste: Sicherheitskonto-Manager

Der Dienst "SamSs" ist für die gesamte Sicherheit in Windows verantwortlich und speichert Sicherheitsinformationen für lokale Benutzerkonten. Dieser Dienst wird von einigen anderen Diensten benötigt und kann aufgrund seiner Wichtigkeit nicht über die MMC (Services.mmc) beendet werden.

Info Die Einstellungen für diesen Dienst sollten nicht verändert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | XP: Sicherheitskontenverwaltung Ab Vist: Sicherheitskonto-Manager
Dienstname | SamSs
Windows Beschreibung | Durch den Start dieses Diensts wird anderen Diensten signalisiert, dass die Sicherheitskontenverwaltung (SAM) bereit ist, Anforderungen anzunehmen. Wenn Sie diesen Dienst deaktivieren, wird verhindert, dass andere Dienste im System benachrichtigt werden, wenn die Sicherheitskontenverwaltung bereit ist. Dies kann wiederum dazu führen, dass diese Dienste nicht korrekt gestartet werden. Dieser Dienst sollte nicht deaktiviert werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Distributed Transaction Coordinator; KtmRm für Distributed Transaction Coordinator; Server
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SamSs

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2429.htm


Windows Dienste: Smartcard

Der Dienst "SCardSvr" wird für den Zugriff auf Smartcards (Lesen und Schreiben) benötigt.

Wenn Sie keine Smartcards benutzen, können Sie diesen Dienst deaktivieren. Meist werden Smartcards zur Authentifizierung (Anmeldung) an das System benutzt, was aber nicht weit verbreitet ist.

Info: Der Dienst wird auch für die weiter verbreiteten Fingerabdruck-Leser benötigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Smartcard
Dienstname | SCardSvr
Windows Beschreibung | Verwaltet den Zugriff auf Smartcards, die von diesem Computer gelesen werden. Wenn dieser Dienst beendet wird, wird dieser Computer keine Smartcards mehr lesen können. Falls dieser Dienst deaktiviert wird, können die von diesem Dienst explizit abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug u. Play
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SCardSvr

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2432.htm


Windows Dienste: SSDP-Suche

Der Dienst "SSDPSRV" ist für die Installation von Geräten im Netzwerk über "UPnP" (Universal Pug & Play) zuständig. Dazu wird das Protokoll SSDP (Simple Service Discovery Protocol), welches zum Ansteuern von IP-Geräten dient, verwendet wird.

Durch das Deaktivieren von "UPnP" und "SSDP" können entsprechende Dienste für Mediageräte nicht mehr im Netzwerk freigegeben werden. Wenn Sie z.B. Medien für die XBox auf dem Rechner freigeben wollen, müssen diese Dienste laufen.

Da es sich hierbei noch um Sonderfälle handelt, können diese Dienste auf dem meisten Rechnern deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | SSDP-Suche
Dienstname | SSDPSRV
Windows Beschreibung | Sucht nach Netzwerkgeräten und -diensten, die das SSDP-Suchprotokoll verwenden, z. B. UPnP-Geräte. Kündigt zudem SSDP-Geräte und -dienste an, die auf dem lokalen Computer ausgeführt werden. Wenn dieser Dienst gestoppt wird, werden SSDP-basierte Geräte nicht entdeckt. Wenn dieser Dienst deaktiviert ist, können alle Dienste, die explizit von diesem Dienst abhängen, nicht gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP
Wird benötigt | UPnP-Gerätehost
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SSDPSRV

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2435.htm


Windows Dienste: TCP/IP-NetBIOS-Hilfsdienst

Der Dienst "lmhost" ist für "NetBIOS over TCP/IP" zuständig. Es handelt es sich um ein Netzwerkhilfsprotokoll (NBT), das es ermöglicht, Netbios-basierte Programme und Rechner in einem TCP/IP-Netzwerk zu verwenden.

Wird für die Anzeige von Schattenkopien benötigt und wenn noch Windows 95 Rechner mit veraltetem Netbios oder WINS (Windows Internet Naming Service) arbeiten. Wenn das nicht der Fall ist, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | TCP/IP-NetBIOS-Hilfsdienst
Dienstname | lmhosts
Windows Beschreibung

Bietet Unterstützung für den NetBIOS-über-TCP/IP-Dienst (NetBT) und die NetBIOS-Namensauflösung für Clients im Netzwerk, so dass Benutzer Daten gemeinsam nutzen, drucken und sich am Netzwerk anmelden können.

Diese Funktionen sind nicht mehr verfügbar, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Ancilliary Function Driver for Winsock; NETBT
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ lmhosts

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2438.htm


Windows Dienste: Telefonie

Der Dienst "TapiSrv" wird für Modemverbindungen und dem FAX-Dienst benötigt. Weiterhin wird die TAPI-Unterstützung (Telephony Application Programming Interface) für Telefonieanwendungen wie etwa Softwaretelefonie oder Videokonferenzprogramme verwendet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Telefonie
Dienstname | TapiSrv
Windows Beschreibung | Bietet Telefonie-API-Unterstützung (TAPI) für Programme, die lokale und über das LAN auf Servern, die diesen Dienst ebenfalls ausführen, angebundene Telefoniegeräte steuern.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug u. Play; Remoteprozeduraufruf (RPC)
Wird benötigt | Fax; RAS-Verbindugsverwaltung; Verwaltung für automatische RAS-Verbindung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TapiSrv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2439.htm


Windows Dienste: Terminaldienste

Der Dienst "TermService" wird für die "schnelle Benutzerumschaltung", "Remoteunterstützung" und "Remotedesktop" benötigt, wenn andere über das Netzwerk auf den Rechner zugreifen wollen.

Durch die Terminaldienste können sich Benutzer über das Netzwerk mit den Rechner verbinden und mit dem Rechner arbeiten als wenn man sich direkt am Rechner angemeldet hat.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Terminaldienste
Dienstname | TermService
Windows Beschreibung

Ermöglicht Benutzern das Herstellen einer interaktiven Verbindung mit einem Remotecomputer. Remotedesktop und Terminalserver funktionieren nur zusammen mit diesem Dienst.

Wenn Sie die Remoteverwendung dieses Computers verhindern möchten, deaktivieren Sie die Kontrollkästchen auf der Registerkarte "Remote" in den Systemsteuerungsoptionen.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufeuf (RPC); Terminal-Gerätetreiber
Wird benötigt | Anschlussumleitung für Terminaldienst im Benutzermodus
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TermService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2440.htm


Windows Dienste: Überwachung verteilter Verknüpfungen (Client)

Der Dienst "TrkWks" ist für die Verknüpfungen von NTFS-Dateien auf vernetzen Rechnern zuständig. Wird eine Datei auf einem Netzwerkrechner verschoben, werden die Verknüpfungen der anderen Netzwerkrechner, die auf diese Datei verweisen, entsprechend geändert. Da diese Funktion selbst bei Netzwerkrechnern eher selten benötigt wird, kann dieser Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Überwachung verteilter Verknüpfungen (Client)
Dienstname | TrkWks
Windows Beschreibung | Hält Verknüpfungen für NTFS-Dateien auf einem Computer oder zwischen Computern in einem Netzwerk aufrecht.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TrkWks

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2443.htm


Windows Dienste: UPnP-Gerätehost

Der Dienst "upnphost" sorgt für die automatische Erkennung UPnP (Universal Plug & Play-Support) fähigen Geräten im Netzwerk. Wenn Sie solche Geräte nicht im Netzwerk verwenden, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename

Windows XP: Universeller Plug & Play-Gerätehost

Ab Vista: UPnP-Gerätehost
Dienstname | upnphost
Windows Beschreibung

Ermöglicht es, dass UPnP-Geräte auf diesem Computer gehostet werden können. Wenn dieser Dienst gestoppt wird, sind alle gehosteten UPnP-Geräte nicht mehr betriebsbereit, und es können keine weiteren gehosteten Geräte hinzugefügt werden.

Wenn dieser Dienst deaktiviert ist, können alle Dienste, die explizit von diesem Dienst abhängen, nicht mehr gestartet werden.
Windows Starttyp

Windows Vista: Automatisch

Windows 2008: Deaktiviert
Empfehlung Starttyp | Deaktivieren
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP; SSDP-Suche
Wird benötigt | Windows Media Player-Netzwerkfreigabedienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ upnphost

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2445.htm


Windows Dienste: Verwaltung für automatische RAS-Verbindung

Der Dienst "RasAuto" stellt auf Anforderungen von Programmen eine Verbindung zu einem Remotenetzwerk her. Der Dienst wird in den meisten Fällen nicht benötigt und kann deaktiviert werden. Wenn Sie im Anmeldevorgang über eine Dial-Up oder DSL-Internet-Verbindung arbeiten, kann es vorkommen, dass der Dienst dafür benötigt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Verwaltung für automatische RAS-Verbindung
Dienstname | RasAuto
Windows Beschreibung | Erstellt eine Verbindung zu einem Remotenetzwerk, wenn ein Programm eine Remote-DNS- oder -NetBIOS-Adresse referenziert.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | RAS-Verbindugsverwaltung; Telefonie
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RasAuto

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2448.htm


Windows Dienste: Volumeschattenkopie

Der Dienst "VSS" wird für die Durchführung und Verwaltung von Schattenkopien benötigt. Wird mit Schattenkopien gearbeitet, werden Dateiveränderungen so aufgezeichnet, dass bei Bedarf auf entsprechende Vorgängerversionen zurückgegriffen werden kann. Durch diese Technik wird die Sicherheit von Dateien erhöht, da bei einem Schreibzugriff die alte Version nicht verändert wird und wenn dabei etwas schiefgeht, auf diese Version zurückgegriffen werden kann. Diese Funktionalität benötigt dafür aber sehr viele Ressourcen.

Bei den meisten Anwendern kann dieser Dienst, wie auch der Dienst "Microsoft-Softwareschattenkopie-Anbieter", deaktiviert werden

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Volumeschattenkopie
Dienstname | VSS
Windows Beschreibung

Verwaltet und implementiert Volumeschattenkopien, die zu Sicherungs- und anderen Zwecken verwendet werden. Wenn dieser Dienst beendet wird, werden keine Schattenkopien für Sicherungen verfügbar sein und die Sicherung kann eventuell fehlschlagen.

Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ VSS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2450.htm


Windows Dienste: Webclient

Der Dienst "Webclient" wird benötigt, damit entsprechende Programme wie Frontpage Internet-Dateien erstellen und darauf zugreifen können. Wenn Sie keine WebDAV-Funktionen verwenden, können Sie diesen Dienst beenden, da er nicht für den normalen Web- und FTP-Zugriff benötigt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Webclient
Dienstname | WebClient
Windows Beschreibung

Ermöglicht Windows-basierten Programmen, Internet-basierte Dateien zu erstellen, darauf zuzugreifen und sie zu verändern. Wenn dieser Dienst beendet wird, werden diese Funktionen nicht mehr zur Verfügung stehen.

Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | WebDav Client Redirector Driver
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WebClient

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2451.htm


Windows Dienste: Windows Installer

Der Dienst "msiserver" ist für die Installation, Deinstallation und Reparatur zuständig von den mit dem Windows Installer (*.MSI-Dateien) erstellten Software-Paketen. Da heutzutage die meisten Programme auf einem Windows Rechner über den MSI-Installer installiert werden, sollten Sie diesen Dienst nicht deaktivieren. Wird der Dienst deaktiviert, funktioniert der Windows Installer nicht mehr.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows Installer
Dienstname | msiserver
Windows Beschreibung | Fügt Anwendungen, die als ein Windows Installer-Paket (*.msi) angeboten werden, hinzu bzw. ändert oder entfernt sie. Wenn dieser Dienst deaktiviert ist, können alle Dienste, die explizit davon abhängen, nicht gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ msiserver

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2454.htm


Windows Dienste: Windows-Audio

Der Dienst "Audiosrv" ist dafür zuständig, die vorhandenen Audiogeräte an die entsprechenden Anwendungen zu verteilen. Damit die Anwendungen Musik ausgeben können, wird dieser Dienst benötigt. Wenn Sie den Dienst deaktivieren, wird kein Ton mehr ausgegeben.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Audio
Dienstname | Audiosrv
Windows Beschreibung | Verwaltet Audioinhalte für Windows-basierte Programme. Wenn dieser Dienst beendet wird, funktionieren Audiogeräte und -effekte nicht ordnungsgemäß. Wenn dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst explizit abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Manuell
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Multimediaklassenplaner; Remouteprozeduraufruf (RPC); Windows-Audio-Endpunkterstellung
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Audiosrv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2486.htm


Windows Dienste: Windows-Bilderfassung

Der Dienst "stisvc" ist unter Windows für die Bildverarbeitung von Scannern und Kameras verantwortlich und wird z.B. dafür benötigt, die Bilder von der Kamera zu laden. Wenn Sie dafür spezielle Software benutzen und nicht die Windows Funktion, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Bilderfassung
Dienstname | stisvc
Windows Beschreibung | Stellt Bilderfassungsdienste für Scanner und Kameras zur Verfügung
Windows Starttyp | Manual
Empfehlung Starttyp | Manual
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC); Shellhardwareerkennung
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ stisvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2488.htm


Windows Dienste: Windows-Suche

Der Dienst "WSearch" wird für die Windows-Suche benötigt. Da die Suchfunktion relativ oft verwendet wird, kann man diesen Dienst nur abschalten, wenn Sie mit einem Tool eines anderen Herstellers arbeiten, um Dokumente und Dateien zu indizieren und zu durchsuchen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Suche
Dienstname | WSearch
Windows Beschreibung | Stellt Inhaltsindizierung und Eigenschaftenzwischenspeicherung für Dateien, E-Mail-Nachrichten und anderen Inhalt (über Erweiterbarkeits-APIs) bereit. Der Dienst reagiert auf Datei- und E-Mail-Benachrichtigungen aufgrund von geändertem Inhalt. Wenn der Dienst angehalten oder deaktiviert ist, können vom Explorer keine virtuellen Ordneransichten von Elementen angezeigt werden, außerdem fällt die Suche im Explorer zurück auf die langsame Element-für-Element-Suche.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WSearch

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2498.htm


Windows Dienste: Windows-Verwaltungsinstrumentation

Der Dienst "Winmgmt" stellt eine Schnittstelle (WMI) für den Zugriff auf Verwaltungsinformationen zu Betriebssystemen, Geräten, Anwendungen und Diensten bereit. Über WMI greifen in Windows die meisten Anwendungen auf Verwaltungsinformationen zu. Der Dienst darf deshalb auch nicht deaktiviert werden, da ansonsten etliche Anwendungen nicht mehr ordnungsgemäß funktionieren würden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Verwaltungsinstrumentation
Dienstname | Winmgmt
Windows Beschreibung | Bietet eine standardmäßige Schnittstelle und Objektmodell zum Zugreifen auf Verwaltungsinformationen über das Betriebssystem, Geräte, Anwendungen und Dienste. Die meiste Windows-basierte Software kann nicht ordnungsgemäß ausgeführt werden, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Gemeinsame Nutzung der Internetverbindung; IP-Hilfsdienst; Sicherheitscenter
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Winmgmt

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2499.htm


Windows Dienste: Windows-Zeitgeber

Der Dienst "W32Time" ist für das Synchronisieren der Uhr über die Internetverbindung zuständig. Der Dienst holt sich die Zeit von einem Rechner, welcher mit einer Atomuhr synchronisiert wird und errechnet die aktuelle Abweichung, um die eigene Uhr entsprechend einstellen zu können. Wenn Sie den Dienst deaktivieren, wird die Uhr nicht mehr synchronisiert.

Ob man so eine genaue Systemzeit wirklich benötigt, muss jeder selber entscheiden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Zeitgeber
Dienstname | W32Time
Windows Beschreibung | Behält Datums- und Zeitsynchronisation auf allen Clients und Servern im Netzwerk bei. Wird dieser Dienst beendet, sind Datums- und Zeitsynchronisation nicht verfügbar. Wird dieser Dienst deaktiviert, können keine explizit von der Synchronisation abhängigen Dienste gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ W32Time

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2500.htm


Windows Dienste: WMI-Leistungsadapter

Der Dienst "wmiApSrv" stellt die WMI-Funktionen im Netzwerk bereit. Der Dienst wird nur für Abfragen von WMI-Funktionen über das Netzwerk benötigt und kann, wenn da nichts gemacht wird, deaktiviert werden. Lokale Scripte und die WMI-Konsole funktionieren auch ohne diesen Dienst.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | WMI-Leistungsadapter
Dienstname | wmiApSrv
Windows Beschreibung | Bietet Leistungsbibliotheksinformationen der Windows-Verwaltungsinstrumentationsanbieter für Clients im Netzwerk. Dieser Dienst wird nur ausgeführt, wenn das Leistungsdaten-Hilfsprogramm aktiviert ist.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wmiApSrv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2502.htm


Gelöschte Dateien nicht in den Papierkorb verschieben

Wenn Sie Dateien löschen, werden diese Dateien meistens erst in den Papierkorb verschoben und dort dann automatisch gelöscht, wenn der Platz für den Papierkorb ausgeht. Wenn Sie diesen Tipp aktivieren, werden die Dateien direkt gelöscht und nicht mehr in den Papierkorb verschoben.

Vorsicht:

Sie können diese gelöschten Dateien dann nicht wieder herstellen!

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRecycleFiles" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Papierkorb deaktivieren
gelöscht | Papierkorb aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Gelöschte Dateien nicht in den Papierkorb verschieben

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1632.htm


Den Pfad im Arbeitsplatz 'Dateien von <%UserName%>' anpassen

Den Pfad im Arbeitsplatz "Dateien von <%UserName%>" anpassen

Unter dem Arbeitsplatz-Icon gibt es den Eintrag "Datei von <%UserName%>" (%UserName%entspricht hier Ihren Namen). Diese Verknüpfung zeigt auf den Standardpfad von:

"Eigene Dateien" also auf "C:\Dokumente und Einstellungen\%UserName%\Eigene Dateien".

Wenn Sie jetzt aber - wie unter "Ordner Dokumente und Einstellungen auf ein anderes Laufwerk legen" beschrieben - den Eintrag "Personal" auf einen anderes Verzeichnis gelegt haben, wird von Windows dieser Link nicht automatisch mit geändert, sondern zeigt immer noch auf dieses alte Verzeichnis.

Jetzt haben Sie dadurch zwei Verzeichnisse für die Ablage der "Eigenen Dateien". Wenn Sie das ändern wollen, müssen Sie auch noch den folgenden Eintrag in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ DocFolderPaths

hier finden Sie für jeden Benutzeraccount einen Eintrag mit dem entsprechenden Anmeldenamen (%Username%) als Datentyp REG_SZ.

Geben Sie als Wert einfach den gewünschten Pfad ein.

Info Wenn Sie mehr als ein Account auf Ihrem Rechner eingerichtet haben, gibt es hier für jeden Account einen Eintrag. Wenn bestimmte Accounts nicht angezeigt werden sollen, müssen Sie einfach nur den entsprechenden Eintrag löschen. Sie können hier auch die Liste erweitern, dafür müssen Sie nur einen neuen Eintrag als (REG_SZ) anlegen, welcher dem entsprechenden Usernamen entspricht und den gewünschten Pfad angeben (wenn der Account in Windows nicht vorhanden ist, wird der Eintrag nicht im Explorer angezeigt).

Wenn Sie diesen Eintrag "Datei von <%UserName%>" aus dem Explorer ausblenden wollen, müssen Sie folgenden Eintrag aus der Registry löschen:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MyComputer\ NameSpace\ DelegateFolders

hier finden Sie den Schlüssel mit den Namen "{59031a47-3f72-44a7-89c5-5595fe6b30ee}". Löschen Sie einfach diesen Schlüssel, wenn der Eintrag "Datei von <%UserName%>" nicht mehr im Explorer angezeigt werden soll. Möchten Sie den Eintrag wieder einblenden, müssen Sie den Schlüssel neu anlegen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1735.htm


Papierkorbgröße konfigurieren

Mit diesem Tipp können Sie die Größe des Papierkorbs festlegen. Wenn Sie den Tipp aktivieren, geben Sie die maximale Größe in Prozentes des Papierkorbes vom aktuellen Plattenspeicherplatzes an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "RecycleBinSize" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0-100 | Größe des Papierkorbes in Prozent vom aktuellen Plattenspeicher
gelöscht | Gesamter Plattenspeicher (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtliniekonfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Maximal zugelassene Papierkorbgröße

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1908.htm


'Gemeinsame Dokumente' vom Arbeitsplatz entfernen

"Gemeinsame Dokumente" vom Arbeitsplatz entfernen

Wenn ein Windows-Client in einer Arbeitsgruppe ist, erscheint ein Symbol "Gemeinsame Dokumente" in der Webansicht von Windows Explorer unter "Andere Orte" und auch unter "Auf diesem Computer gespeicherte Dateien" in Arbeitsplatz. Wenn Sie diesen Tipp aktivieren, wird "Gemeinsame Dokumente" nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSharedDocuments" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Gemeinsame Dokumente" nicht anzeigen
gelöscht | "Gemeinsame Dokumente" anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | "Gemeinsame Dokumente" vom Arbeitsplatz entfernen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1669.htm


Aus dem Kontextmenü vom Papierkorb den Eintrag Eigenschaften entfernen

Wenn Sie diesen Tipp aktivieren, ist die Option "Eigenschaften" nicht vorhanden, wenn der Benutzer mit der rechten Maustaste auf Papierkorb klickt oder Papierkorb öffnet und dann auf Datei klickt. Außerdem hat die ALT-Eingabetaste keine Wirkung, wenn der Papierkorb gewählt ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPropertiesRecycleBin" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Eintrag "Eigenschaften" aus dem Kontextmenü des Papierkorbs entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1472.htm


Aus dem Kontextmenü von Eigene Dateien den Eintrag Eigenschaften entfernen

Wenn Sie diesen Tipp aktivieren, ist die Option "Eigenschaften" nicht vorhanden, wenn der Benutzer mit der rechten Maustaste auf "Eigene Dateien" klickt oder auf "Eigene Dateien" klickt und dann in das Menü "Datei" geht. Außerdem hat ALT-Eingabetaste keine Wirkung, wenn "Eigene Dateien" gewählt ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPropertiesMyDocuments" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Eintrag "Eigenschaften" aus dem Kontextmenü von "Eigene Dateien" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1474.htm


Papierkorb von Desktop und Explorer entfernen

Mit diesem Tipp wird das Papierkorbsymbol vom Desktop, aus Windows Explorer, aus Programmen, die Fenster von Windows Explorer verwenden und aus dem Standarddialog "Öffnen" entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ NonEnum

Erstellen Sie hier einen neuen Wert mit dem Namen "{645FF040-5081-101B-9F08-00AA002F954E}" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Papierkorb entfernt
gelöscht | Papierkorb vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Papierkorbsymbol vom Desktop entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1475.htm


Aus dem Kontextmenü vom Arbeitsplatz den Eintrag Eigenschaften entfernen

Wenn Sie diesen Tipp aktivieren, ist die Option Eigenschaften nicht vorhanden, wenn der Benutzer mit der rechten Maustaste auf Arbeitsplatz klickt und dann in das Menü Datei geht. Außerdem hat ALT-Eingabetaste keine Wirkung, wenn Arbeitsplatz gewählt ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPropertiesMyComputer" als Datentyp REG_DWORD. Setzen Sie den Wert zwischen:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Eintrag "Eigenschaften" aus dem Kontextmenü von "Arbeitsplatz" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1473.htm


Die Symbolleisten aus der Taskbar entfernen

Wenn Sie diese Policy aktivieren, werden die Symbolleisten und die Schnellstartleiste (Quick Launch) aus der Taskbar entfernt.

Die Taskleiste enthält die Schaltfläche "Start", Schaltflächen für laufende Tasks, benutzerdefinierte Symbolleisten, den Infobereich und die Systemuhr. Symbolleisten umfassen Schnellstart, Adresse, Verknüpfungen, Desktop und weitere Symbolleisten, die vom Benutzer oder von einer Anwendung erzeugt wurden.

Wenn Sie diese Einstellung aktivieren, werden in der Taskleiste keine benutzerdefinierten Symbolleisten angezeigt, und der Benutzer kann keine benutzerdefinierten Symbolleisten zur Taskleiste hinzufügen. Darüber hinaus wird der Befehl "Symbolleisten" samt Untermenü aus dem Kontextmenü entfernt. Die Taskleiste zeigt nur die Schaltfläche "Start", Taskleisten-Schaltflächen, den Infobereich und die Systemuhr an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoToolbarsOnTaskbar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Keine benutzerdefinierten Symbolleisten in der Taskleiste anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1434.htm


Gruppenbildung in der Taskleiste

Bei der neuen Oberfläche von Windows XP hat sich auch das Verhalten der Taskleiste geändert. Unter dem alten Windows wurde für jedes offene Programm ein Button in der Taskleiste angezeigt, wenn man nun viele Programme geöffnet hatte oder den Explorer mehrmals öffnete, wurden die Buttons immer schmaler, bis man nichts mehr erkennen konnte.

Darum fasst Windows jetzt automatisch bestimmte Programme zu Gruppen zusammen. So wird, wenn man z.B. den Explorer dreimal öffnet, nur ein Button in der Taskleiste dafür angelegt. Wenn man auf diesen Button klickt, geht eine Box auf, in der alle geöffneten Explorer angezeigt werden.

Wenn Sie das neue Verhalten so nicht mögen, können Sie es über einen Rechtsklick auf die "Taskleiste" -> "Eigenschaften" Tabreiter "Taskleiste" durch den Eintrag "Ähnliche Elemente gruppieren" aus- bzw. einschalten oder auch direkt über die Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellen Sie einen neuen Eintrag mit dem Namen "TaskbarGlomming" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0.

0 -> Gruppenbildung ausgeschaltet

1 -> Gruppenbildung aktiviert

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1185.htm


Den Effekt 'fade = ausblenden' in der Taskleiste deaktiveren

Den Effekt 'fade = ausblenden' in der Taskleiste deaktivieren

Mit diesem Tipp können Sie das "Fade" (ausblenden) der Taskleiste ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects\ KBarFade

erstellen Sie einen neuen Eintrag mit dem Namen "CheckedValue" als Datentyp REG_DWORD und setzen den Wert auf 0, um die Funktion auszuschalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1361.htm


Die Infobereich (Systray) aus der Taskleiste ausblenden

Wenn Sie diese Funktion aktivieren, wird der Informationsbereich(Systray) mit den Tray Items in der Taskleiste ausgeblendet. Es werden nur noch Start, Systemuhr und die benutzerdefinierten Symbolleisten angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoTrayItemsDisplay" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tray Items werden nicht mehr im Systray angezeigt
gelöscht | Tray Items werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Infobereich ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1435.htm


Anzahl der möglichen Gruppen in der Taskleiste definieren

Ab Windows XP wurde die Taskleiste um eine neue Funktion erweitert. Sobald mehr als 3 Instanzen eines gleichen Programmes geöffnet sind, werden diese in der Taskleiste "gruppiert" (also zu einer eigenen Gruppe zusammengefasst, die mit einem Pfeil nach oben geöffnet werden kann). In der Registry können Sie das verhalten entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie einen neuen Eintrag mit den Namen “TaskbarGroupSize” als Datentyp REG_DWORD und geben Sie folgende Werte an:

0 | Älteste Gruppen zuerst
1 | Größte Gruppen zuerst
x | Gruppieren ab x gleiche Programme

Der (Standard) Wert ist 3.

Info Siehe dazu auch Tipp: "Gruppenbildung in der Taskleiste"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1365.htm


Taskleiste sperren

Wenn Sie diese Policy aktivieren, wird die Taskleiste gesperrt und kann dann nicht mehr vom Anwender verschoben oder verkleinert/vergrößert werden.

Die Taskleiste umfasst die Schaltfläche "Start", eine Liste der derzeit aktiven Aufgaben und den Infobereich. Standardmäßig wird die Taskleiste am unteren Rand des Bildschirms angezeigt, kann jedoch an eine beliebige Seite des Bildschirms gezogen werden. Wenn sie gesperrt ist, kann sie nicht verschoben oder ihre Größe geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "LockTaskbar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Taskleiste gesperrt
gelöscht | Taskleiste frei (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Taskleiste fixieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Bei Aktivierung dieser Einstellung werden auch die Schnellstartleiste und alle anderen Symbolleisten gesperrt, die sich auf der Taskleiste des Benutzers befinden. Die Position der Symbolleiste ist festgelegt, und der Benutzer kann nicht mit Hilfe des Taskleisten-Kontextmenüs verschiedene Symbolleisten anzeigen und ausblenden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1438.htm


Gruppierungen von Programm in der Taskleiste ausschalten

Normalerweise werden gleiche Programme in Gruppen zusammengefasst, um die Einträge in der Taskleiste klein zu halten. Mit diesem Tipp können Sie das unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoTaskGrouping" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Gruppierung mehr
gelöscht | Gruppierungen werden gemacht (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Gruppierung von Taskleistenelementen verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1439.htm


Nicht mehr installierte Programme werden im Infobereich angezeigt

Werden bei Ihnen unter rechte Maustaste auf dem Startbutton -> Eigenschaften -> Tabreiter "Taskleiste" -> bei "Inaktive Symbole ausblenden" -> Button "Anpassen", noch Einträge unterhalb von "Vorherige Elemente" von Programmen angezeigt, die Sie schon längst deinstalliert haben, liegt das an Einträgen in der Registry. Im Bereich "Aktuelle Objekte" werden die Programme angezeigt die gerade laufen, im Bereich "Vorherige Elemente" greift Windows auf das Protokoll in der Registry zurück, in dem die Programme aufgeführt werden die schon mal im Infobereich angezeigt wurden.

Wenn diese Liste zu viele veraltete Einträge enthält, können Sie die gesammelten Einträge löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Windows XP/2003

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ TrayNotify

Die beiden Einträge "IconStreams" und "PastIconsStream" löschen.

Windows erstellt diese Einträge wieder neu und nimmt dabei nur die Programm auf, die auch auf Ihrem System installiert sind.

Sie können das auch über folgende REG-Datei erledigen. Speichern Sie dafür folgendes als DelInfo.REG ab:

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-

=== Hier schneiden ===

Ab Windows Vista

HKEY_CLASSES_ROOT\ Local Settings\ Software\ Microsoft\ Windows\ CurrentVersion\ TrayNotify

und

HKEY_CURRENT_USER\ Software\ Classes\ Local Settings\ Software\ Microsoft\ Windows\ CurrentVersion\ TrayNotify

Die beiden Einträge "IconStreams" und "PastIconsStream" löschen.

Windows erstellt diese Einträge wieder neu und nimmt dabei nur die Programm auf, die auch auf Ihrem System installiert sind.

Sie können das auch über folgende REG-Datei erledigen. Speichern Sie dafür folgendes als DelInfo.REG ab:

=== Hier schneiden ===

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-

=== Hier schneiden ===

Nach dem einspielen die explorer.exe über den Taskmanager beenden und wieder neu starten. Danach den PC komplett neu starten. So und nun ist der Infobereich gereinigt und kann wieder angepasst werden über die Eigenschaften der Taskleiste > Infobereich > Anpassen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1499.htm


Speicher für angepasste Ordner erhöhen

Windows merkt sich das Aussehen Ihrer Ordner, der Speicher, dafür ist es aber auf max. 400 bzw. ab Vista 5000 Ordner eingeschränkt.

Ist diese Anzahl erreicht, werden ältere Ansichten wieder überschrieben. Dabei kommt es zu noch einem weiteren Problem. Bei diesem Überschreiben bringt Windows anscheinend etwas durcheinander, so dass nach kurzer Zeit keine neuen Ordneransichten mehr abgespeichert werden können.

Dieser Fehler tritt insbesondere dann auf, wenn für viele Ordner unterschiedliche Ansichten eingestellt wurden und deshalb die Funktion "Ansichten für jeden Ordner speichern“ im den Optionen des Explorers aktiviert wurde.

Mit den folgenden Eintrag in der Registry können Sie diese Grenze erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Shell

und

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ ShellNoRoam

Erstellen Sie hier einen neuen Wert mit dem Namen "BagMRU Size" als Datentyp REG_DWORD. Setzen Sie den Wert auf die gewünschte Ordneranzahl.

Der Standard ist: 400 bzw. ab Vista 5000

Damit die alten Fehlerhaften Einträge nicht in der Registry bleiben und Windows alles wieder sauber neu abspeichert löschen Sie bitte folgenden Schlüssel.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ ShellNoRoam\ BagMRU

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ ShellNoRoam\ Bags

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Shell\ BagMRU

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Shell\ Bags

Starten Sie danach Windows neu, nun sollten die Ansichten wieder gespeichert werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1382.htm


Bild- und Faxanzeige deaktivieren

Wenn Sie die "Bild- und Faxanzeige" bei Windows XP stört, weil Sie die Bilder einem installierten Programm öffnen wollen, haben Sie folgende Möglichkeit:

Bild- und Faxanzeige deaktivieren:

Start ==> Ausführen ==> regsvr32 /u shimgvw.dll

Bild- und Faxanzeige aktivieren:

Start ==> Ausführen ==> regsvr32 shimgvw.dll

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1315.htm


Symbolgröße in der Explorer- und Internet Explorer-Menüleiste anpassen

Standardmäßig werden die Symbole in der Menüleiste mit großen Symbolen angezeigt. Sie können diese Anzeige durch einen Rechtsklick auf die Leiste und das Auswählen von "Anpassen" mittels der Symboloptionen umschalten ("Große Symbole" oder "kleine Symbole"). Sie können diese Einstellung aber auch direkt in der Registry durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ SeinmallIcons

erstellen Sie einen neuen Eintrag mit dem Namen "SeinmallIcons" als Datentyp REG_SZ und setzen den Wert auf YES für die Anzeige von kleinen Symbolen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1351.htm


Sortierordnung im Explorer einstellen

Ab Windows XP mit Service Pack 1 (SP1) gibt es eine neue Methode für die Sortierung von Dateien im Explorer. Es wird jetzt nicht nur nach Zeichensatz sortiert, sondern Nummern werden innerhalb eines Dateinamens auch als Nummern behandelt. Dadurch werden Dateien mit Zahlen und Text durcheinander gewürfelt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStrCmpLogical" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Alte Sortierung aktivieren (Windows 2000)
0 | Neue Sortierung (Standard)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=319827

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1633.htm


Zwischenspeichern der Miniaturbilder deaktivieren

Mit diesem Tipp können Sie einstellen, ob die Bilder in der Miniaturansicht im Explorer zwischengespeichert werden sollen. Durch das Zwischenspeichern der Bilder, soll die Anzeige beschleunigt werden, da die Bilder nicht jedesmal wieder neu erzeugt werden müssen.

Windows legt diese Thumbnails in die Chachedatei "Thumbs.db" ab. Wenn Sie diesen Tipp aktivieren, werden die Bilder nicht mehr zwischengespeichert.

Öffnen Sie den Windows Explorer und gehen Sie in das Menü "Extras" -> "Ordneroptionen" und hier auf den Tabreiter "Ansicht". Unter der Auflistung "Erweiterte Einstellungen:" setzen Sie den Haken bei "Miniaturansicht nicht zwischenspeichern"

Durch diese Einstellung wird folgender Registryeintrag geändert:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableThumbnailCache" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Zwischenspeichern deaktivieren
0 | Zwischenspeichern ist aktiv (Standard)

Die Einstellung können Sie aber auch über die Policies einstellen:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoThumbnailCache" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zwischenspeichern deaktivieren
gelöscht | Zwischenspeichern ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Zwischenspeicherung von Bildern in Miniaturansicht deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1909.htm


'Alte Dateien komprimieren' aus der Datenträgerbereinigung entfernen

"Alte Dateien komprimieren" aus der Datenträgerbereinigung entfernen

Mit diesem Tipp können Sie den Eintrag "Alte Dateien komprimieren" aus dem Auswahlmenü der Datenträgerbereinigung entfernen, welches bei NTFS-Laufwerken angeboten wird.

Info Das Entfernen dieser Funktion kann auch helfen, wenn sich die Datenträgerbereinigung nicht mehr starten lässt, oder aber einfach beim Scanvorgang hängen bleibt. Das passiert oft bei großen Laufwerken mit vielen Dateien.

Dieses Tool finden Sie unter "Programme" -> "Zubehör" -> "Systemprogramme" -> "Datenträgerbereinigung" bzw. über die Eigenschaften im Explorer (rechte Maustaste auf ein Laufwerk -> Eigenschaften):

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VolumeCaches

löschen Sie den ganzen Schlüssel "Compress Old Files"

Wenn Sie diese Funktion wieder einmal benötigen, müssen Sie diesen Schlüssel neu anlegen und dabei folgende Werte setzen:

Name | Datentyp | Wert
Standard | REG_SZ | {B50F5260-0C21-11D2-AB56-00A0C9082678}
Priority | REG_DWORD | 300 (Dezimal)

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2001.htm


Datenträgerbereinigung erweitern

Die Datenträgerbereinigung befindet sich unter "Start -> Alle Programme ->Zubehör -> Systemprogramme".Sie bietet Funktionen an, um den Rechner zu säubern und um nicht mehr gebrauchte Dateien zu löschen.

Im Laufe der Zeit sammelt sich auf jedem System eine ganze Menge Datenmüll an. Die Datenträgerbereinigung durchsucht die Festplatte nach nicht mehr zwingend benötigten Dateien, die man bedenkenlos löschen kann, wie beispielsweise temporäre Interntedateien, Offlinedateien, ActiveX Komponenten oder nach Dateien, die im Papierkorb liegen.

Wenn Sie das Tool aber über die Verknüpfung aus dem Startmenü starten, werden nur die Standardeinstellungen angezeigt, und Sie können nicht auf alle Funktionen zugreifen.

Wenn Sie die Datenträgerbereinigung mit dem folgenden Aufruf starten, werden Ihnen erweiterte Funktionen angezeigt:

"Cleanmgr /sageset:65535 & Cleanmgr /sagerun:65535".

Wenn Sie die erweitere Datenträgerbereinigung öfter benutzen wollen, können Sie natürlich auch eine entsprechende Verknüpfung mit diesem Aufruf anlegen.

Durch die Löschung der Daten lässt sich schnell wieder Speicherplatz auf der Festplatte freigegeben. Vor dem Starten des Programm sollte man alle laufenden Anwendungen schließen und dann erst die Datenträgerbereinigung aufrufen. Je nach Startart muss man noch den Datenträger auswählen, auf dem die Datenträgerbereinigung ausgeführt werden soll.

Anbei eine Übersicht, was alles mit dem Tool (Erweitere Ansicht) bereinigt werden kann:

  • Temporary Setup Files
    Dabei handelt es sich um Dateien, die vom Setup für die Installation erstellt werden, aber nach der Installation nicht mehr gebraucht werden. Diese Dateien werden normalerweise automatisch vom Setup gelöscht, was aber leider nicht immer der Fall ist.
  • Übertragene Programmdateien
    Datei handelt es sich um ActiveX- oder Java-Elemente, die für bestimmte Webseiten benötigt werden.
  • Temporäre Internetdateien
    Beim Aufruf von Webseiten über den Internet Explorer werden Seitenelemente wie Bilder, Animationen, Sound usw. auf die Festplatte zwischengespeichert. Das wird gemacht, damit bei einem weiteren Aufruf der Webseite diese Elemente nicht wieder über das Internet erneut geladen werden müssen.
  • Öfflinewebseiten
    Enthält Seiten, die Sie über den Internet Explorer komplett abgespeichert haben. Diese Seiten können ohne Internetverbindung wieder geöffnet werden.
  • Debug-Speicherabbilddateien
    Bei einem Absturz einer Anwendung wird oft ein Dump-File mit Debuginformationen erstellt. Diese Datei kann für die Fehlersuche benutzt werden. Sie ist in den meisten Fällen nur für den Hersteller der Anwendung interessant.
  • Temporäre Dateien für Microsoft-Fehlerberichterstattung
    Bei Programmfehlern oder Abstürzen speichert Windows in diesem Ordner Informationen für die späterer Fehlerberichterstattung. Auch hier kann wieder ohne Bedenken alles gelöscht werden.
  • Alte CHKDSK-Dateien
    Mit dem Programm CHKDSK können Sie die Festplatte auf Fehler untersuchen und die fehlerhaften Einträge auch beseitigen lassen. Können entsprechende Zuordnungen nicht wieder hergestellt werden, dann werden diese Informationen auf die Festplatte im Rootverzeichnis abgelegt.
  • Papierkorb
    Damit leeren Sie den Papierkorb
  • Temporäre Remotedesktopdateien
    Dieses Dateien werden bei einer Remote-Desktopverbindung erstellt und werden später nicht mehr wieder benötigt.
  • Setup-Protokollierungsdateien
    Diese Dateien enthalten Informationen über den Ablauf der Installation einer Anwendung. In den meisten Fällen werden diese LOG-Dateien nicht wieder benötigt.
  • Temporäre Dateien
    Im den Temp-Verzeichnissen werden beim Start von Programmen TEMP-Dateien angelegt, die für die Ausführung der Anwendung kurzzeitig genötigt werden. Wenn die Anwendung geschlossen wird, werden diese Anwendungen nicht mehr benötigt. Die meisten Anwendungen löschen diese Einträge, durch einen Absturz oder weil es nicht programmiert wurde, können aber Dateien im Temp-Verzeichnis liegenbleiben.
  • WebClient/Publisher Temporary Files
    Dateien, die vom WebClient/Publisher gespeichert wurden, um die Systemleistung zu verbessern.
  • Temporäre Offlinedateien
    Temporäre Offlinedateien sind lokale Kopien der zuletzt besuchten Netzwerkdateien. Diese Dateien werden automatisch im Zwischenspeicher abgelegt, so dass Sie nach Beenden der Netzwerkverbindung offline auf sie zugreifen können
  • Offlinedateien
    Offlinedateien sind lokale Kopien von Netzwerkdateien, die Sie explizit offline zur Verfügung haben möchten, so,dass Sie auch verwendet werden können, wenn Sie nicht mit dem Netzwerk verbunden sind.
  • Alte Dateien komprimieren
    Dadurch werden selten benutzte Dateien komprimiert, um Festplattenplatz zu sparen. Wird auf die Dateien wieder zugegriffen, werden diese automatisch entpackt. Da das Packen/Entpacken Zeit kostet, sollten Sie das nur machen, wenn Sie diesen Plattenplatz unbedingt benötigen. Es werden keine Dateien gelöscht. Der gewonnene Speicherplatz wird ungefähr angegeben, weil die Dateien unterschiedlich komprimiert werden.
  • Katalogdateien für den Inhaltsindex
    Der Windows Indexdienst erstellt Katalogdateien, die für eine Suche benutzt werden und dadurch die Suche entsprechend beschleunigen. Diese Katalogdateien stammen von einem früheren Indizierungsvorgang und können bedenkenlos gelöscht werden.

Info Weitere Infos siehe Tipp: Programm zur Festplattenbereinigung konfigurieren (CLEANMGR.EXE)

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2525.htm


Wirklich alle Dateien anzeigen

Auch wenn Sie schon im Explorer eingestellt haben, dass Windows alle Dateien anzeigen soll, gibt es immer noch Dateien, die Ihnen im Explorer nicht angezeigt werden (in den meisten Fällen ist das aber auch sinnvoll).

Wollen Sie aber doch alle Dateien angezeigt bekommen, müssen Sie folgenden Wert in der Registry eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "SuperHidden" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Alle Dateien werden angezeigt
0 | Es werden nicht alle Dateien angezeigt (Standard)

Info Siehe auch Tipp: "Geschützte Systemdateien im Explorer anzeigen"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1379.htm


Explorer Aufgaben Ansicht für Ordner festlegen

Mit diesem Tipp aktivieren legen Sie die Ansicht von Ordner im Explorer fest. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Allgemein" unter "Aufgaben" konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "WebView" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Allgemeine Aufgaben in Ordnern anzeigen
0 | Herkömmliche Windows Ordner verwenden

Ab Windows Vista:

1 | Vorschau und Filter anzeigen
0 | Herkömmliche Windows Ordner verwenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1706.htm


Rechnernamen in der Netzwerkumgebung vor Beschreibung

Ab Windows XP wird in der Netzwerkumgebung erst die Beschreibung und dann der Rechnername angezeigt, was meist sehr unübersichtlich ist. Dieser Fehler wurde ab SP2 entsprechend behoben, so dass mit dem folgenden Eintrag die Anzeigereihenfolge wieder getauscht werden kann (erst Computername und dann die Beschreibung).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ToggleCommentPosition" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Computername zuerst anzeigen [Computername + Beschreibung + Laufwerksbuchstabe]
0 | Beschreibung vor dem Computernamen anzeigen (Standard) [Beschreibung + Computername + Laufwerksbuchstabe]

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1666.htm


Reihenfolge des Laufwerksbuchstaben im Explorer

Standardmäßig wird der Laufwerksbuchstabe am Ende im Explorer angezeigt. Mit diesem Tipp können Sie einstellen, dass der Buchstabe als erster ober überhaupt nicht angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Eingestellt wird der Wert unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Info Aufgrund eines Fehlers, werden die Policywerte (unten) nicht ausgewertet. Sie können die Einstellung also nur mit den oberen Wert festlegen. Dieser Fehler wird höchstwarscheinlich in einem der nächsten Fixes von MS behoben, weshalb ich hier auch die entsprechenden Policywerte mit angebe.

Oder als Policy:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowDriveLettersFirst" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

<nicht da> | Laufwerksbuchstabe am Ende anzeigen (Standard)
1 | Laufwerksbuchstabe nur bei Remotelaufwerken als erstes anzeigen
2 | Laufwerksbuchstabe nicht anzeigen
4 | Laufwerksbuchstabe bei allen Laufwerken als erstes anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1818.htm


Vorschau von AVI-Dateien im Explorer

Mit diesem Tipp können Sie einstellen, ob eine Vorschau von AVI-Dateien im Explorer angezeigt werden soll oder nicht.

Info Eine Vorschau von AVI-Dateien wird nur angezeigt, wenn der Explorer in der WEB-Ansicht betrieben wird. Wird dann auf eine AVI-Datei geklickt, wird im linken Teil des Explorerfensters eine Vorschau gestartet. Diese Funktion ist recht gut für kleine AVI-Dateien, bei größeren Videos kann es dabei zu Fehlern kommen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ CLSID\ {87D62D94-71B3-4b9a-9489-5FE6850DC73E}\ InProcServer32

tragen Sie hier unter (Standard) als Datentyp REG_EXPNAD_SZ folgendes ein: "%SystemRoot%\system32\shmedia.dll".

Bei vielen AVI-Dateien in einem Verzeichnis, wird der Explorer dadurch langsamer. Wenn Sie dasn nicht wollen, sollten Sie den Registry Schlüssel "{87D62D94-71B3-4b9a-9489-5FE6850DC73E}" löschen, oder umbennen (einfach ein - am Anfang hinzufügen) damit der Eintrag nicht mehr benutzt wird.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2048.htm


Geschützte Ordner freischalten

Windows versteckt wichtige Systemverzeichnisse, damit nicht aus Versehen Änderungen in Ordnern vorgenommen werden können.

Mit diesem Tipp können Sie den Schutz ein-/ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ WebView\ BarricadedFolders

erstellen Sie hier die folgenden Einträge als Datentyp REG_DWORD und setzen Sie den Wert auf 0 um das Verzeichnis anzuzeigen oder auf 1 um es wieder zu verstecken.

shell:ControlPanelFolder | "Control Panel" verstecken
shell:SystemDriveRootFolder | "System Drive" verstecken
shell:ProgramFiles | "Programm Ordner" verstecken
shell:Windows | "Windows Ordner" verstecken
shell:System | "System Ordner" verstecken

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2128.htm


Integrierten Bildbetrachter ein-/ausschalten

Mit diesem Tipp können Sie den integrierten Bildbetrachter ein-/ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ SystemFileAssociations\ image\ ShellEx\ ContextMenuHandlers\ ShellImagePreview

ändern Sie hier den Wert "(Standard)" als Datentyp REG_SZ

leer | Der integrierte Bildbetrachter wird ausgeschaltet
{e84fda7c-1d6a-45f6-b725-cb260c236066} | Der integrierte Bildbetrachter ist aktiv

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2143.htm


Notification (Aktualisierung) des Explorers für Netzlaufwerke deaktivieren

Mit diesem Tipp können Sie das automatische Aktualisieren des Windows Explorers für Netzlaufwerke deaktivieren. Standardmäßig ist die Aktualisierung des Explorers aktiv, was zu folgenden Problem führen kann:

  • Der Explorer flackert, wenn man sich mit einem Netzlaufwerk verbunden hat. Das SMB Protokoll bringt Meldungen:
    • Error Code 52 STATUS OBJECT NAME NOT FOUND
    • SMB NT Create AndX Request, Path: xxx
    • SMB NT Create AndX Response, FID: 0x0000, Error: STATUS_OBJECT_NAME_NOT_FOUND
  • Weiterhin führt das zu einer erhöhten Netzwerklast, wenn viele Netzwerkverzeichnisse im Explorer verbunden sind.

Wenn Sie eine Freigabe einem Laufwerksbuchstaben zuordnen, aktualisiert sich die Ordnerstuktur und der Client reagiert auf "Notify Changes", um die Ansicht im Explorer aktuell zu halten.

Die Einstellung kann in der Registry verändert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Hier erstellen Sie jetzt - wie unten angegeben- für die gewünschte Funktion die folgenden Einträge:

Change Notification des Explorers für Unterordner der Netzlaufwerke deaktivieren

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRemoteRecursiveEvents" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Change Notification des Explorers für Unterordner der Netzlaufwerke deaktivieren
0 | Change Notification ist aktiv (Standard)

Change Notification des Explorers für Netzlaufwerke komplett deaktivieren

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRemoteChangeNotify" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Change Notification des Explorers für Netzlaufwerke komplett deaktivieren
0 | Change Notification ist aktiv (Standard)

Eine Aktualisierung des Explorers muss jetzt per F5-Taste manuell durchgeführt werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=831129

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2669.htm


Brennfunktionen deaktivieren

Wenn Sie ein eigenes Programm zum Brennen von CDs benutzen, werden Sie meist die interne Brennfunktionvon Windows XP nicht benutzen. Sie können daher die Einträge aus dem Explorer usw. mit dem folgenden Registry Eintrag deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

erstellen Sie einen neuen Eintrag mit dem Namen "NoCDBurning" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Optionen zum Erstellen einer CD nicht anzeigen
gelöscht | Optionen zum Erstellen einer CD anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | CD-Brennfunktionen entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1360.htm


Die Ordner 'Meine Musik' und 'Meine Bilder' ausblenden

Bei Windows XP gibt es jetzt zusätzlich zu dem Ordner "Meine Dateien" die Ordner "Meine Musik" und "Meine Bilder". Wenn diese Ordner nicht automatisch eingeblendet werden sollen, müssen Sie folgende Werte in der Registry setzen:

Info...Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Für "Meine Musik":

Erstellen Sie einen neuen Eintrag mit dem Namen "Start_ShowMyMusic" als Datentyp REG_DWORD und setzen den Wert auf 0, um den Ordner auszublenden.

Für: "Meine Bilder":

Erstellen Sie einen neuen Eintrag mit dem Namen "Start_ShowMyPics" als Datentyp REG_DWORD und setzen den Wert auf 0, um den Ordner auszublenden.

Info Sie müssen sich neu anmelden, damit diese Änderung wirksam wird.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1353.htm


Die Registerkarte Sicherheit ausblenden

Wenn Sie diese Policy aktivieren, wird die Registerkarte „Sicherheit“ unter den Eigenschaften von Ordner, Dateien und Laufwerken deaktiviert.

Die Sicherheitseinstellungen für Laufwerke/Verzeichnisse können dann nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSecurityTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tab in der Registerkarte ausblenden
gelöscht | Tab anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Registerkarte "Sicherheit" entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1516.htm


"Ausführen als..."/"Als Administrator ausführen" aus dem Kontextmenü entfernen

Mit diesem Tipp können Sie einstellen, ob der Eintrag "Ausführen als..." bzw. ab Vista "Als Administrator ausführen" im Kontextmenü des Explorers angezeigt werden soll, wenn mit der rechten Maustaste auf eine ausführbare Datei geklickt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "HideRunAsVerb" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Eintrag wird angezeigt (Standard)
1 | Eintrag wird ausgeblendet

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2016.htm


Programm zur Festplattenbereinigung konfigurieren (CLEANMGR.EXE)

Zusätzliche Kontextmenü-Einträge bei gedrückter Shift-Taste

Ab Windows Vista wurde das Kontextmenü um eine neue Funktion erweitert.

Es können jetzt Einträge erstellt werden, die erst dann angezeigt werden, wenn beim Rechtsklick mit der Maustaste zusätzlich noch die Shift-Taste gedrückt wird. Diese erweitere Kontextmenü wird auch mit der Tastenkombination Shift + F10 angezeigt.

Mit dieser Funktion können die Kontextmenüs übersichtlich gestaltet werden, da nur bei gedrückter Shifttaste alle Einträge angezeigt werden und somit - selten gebrauchte Einträge - nicht immer sichtbar sind.

So findet man im Kontextmenü der Ordner (auf der rechten Seite im Explorer), mit 'gedrückter Shifttaste' zusätzliche Einträge "Als Pfad kopieren" und "Eingabeaufforderung hier öffnen".

Wie kann ich solche Einträge im Kontextmenü erstellen?

Diese Art der Einträge können Sie nur über die Registry anlegen und bearbeiten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die Kontextmenüeinträge finden Sie in der Registry unter "HKEY_CLASSES_ROOT".

Hier können Sie das Kontextmenü für eine bestimmte Dateiendung (Extension) "<Dateiendung>", für alle Dateien "*" oder für Ordner "Directory" bearbeiten. Sie finden in der WinFAQ unter dem Stichwort "Kontextmenü" noch weitere Informationen zu Kontextmenüeinträgen.

Wenn man jetzt zu "HKEY_CLASSES_ROOT\ Directory\ Background \shell\ cmd" geht, welches für den Eintrag im Kontextmenü verantwortlich ist, findet man den zusätzlichen Wert "Extended" als Datentyp REG_SZ. Dieser Wert legt fest, dass dieser Eintrag nur bei gedrückter Shift-Taste angezeigt wird. Wenn Sie den Eintrag löschen, wird der Eintrag wieder sofort im Kontextmenü permanent angezeigt.

Wenn Sie andere Kontextmenüeinträge ausblenden wollen, müssen Sie nur einen Eintrag mit den Namen "Extended" - ohne Wert - im entsprechenden Kontextmenüschlüssel erzeugen.

Eine weitere Besonderheit ist hier auch noch der zusätzliche Schlüssel "Background".

Normalerweise finden Sie "shell" schon eine Ebene früher im Tree (der ganze Pfad lautet dann "HKEY_CLASSES_ROOT\ Directory\ shell\") und dieser Eintrag ist auch weiterhin noch vorhanden.

Mit dem neuen, zusätzlichen Eintrag "Background" (s. oben: zwischen "Directory" und "shell") wurde eine weitere Funktion eingeführt.

Einträge, welche unterhalb dieses Schlüssels liegen, werden auch angezeigt, wenn der Mausklick auf den Hintergrund (kein markiertes Ordnerobjekt) ausgeführt wird. Dadurch werden diese Einträge z.B. beim Rechtsklick mit der Maustaste auf dem Desktop angezeigt (Anmerkung: Desktop ist auch nur ein Ordner mit erweiterten Funktionen).

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2328.htm


Automatische Rückverfolgung verweister Links unterbinden

Automatische Rückverfolgung verwaister Links unterbinden

Verhindert, dass die NTFS-Nachlaufverfolgungsfunktion zum Zuordnen einer Verknüpfung verwendet wird.

Standardmäßig werden, wenn die Zieldatei einer Verknüpfung (.lnk) nicht gefunden wird, alle mit einer Verknüpfung assoziierten Pfade durchsucht. Falls sich die Zieldatei auf einer NTFS-Partition befindet, wird die Kennung der Zieldatei für die Pfadsuche verwendet. Falls der ermittelte Pfad nicht stimmt, wird eine ausgiebige Suche auf dem Ziellaufwerk durchgeführt, damit die Datei gefunden wird.

Durch Aktivieren dieser Einstellung wird die Dateisuche mit Hilfe der Dateikennung nicht durchgeführt. Stattdessen wird dieser Vorgang übersprungen und die ausgiebige Suche (siehe: Suche nach verlinkten Dateien unterbinden) auf dem angegebenen Laufwerk auf dem Zielpfad gestartet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoResolveTrack" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verknüpfungen nicht zurückverfolgen
gelöscht | Verknüpfungen zurückverfolgen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Beim Zuordnen von Shellshortcuts nicht die verfolgungsbasierte Methode verwenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Siehe auch: Suche nach verlinkten Dateien unterbinden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1591.htm


Größe der Thumbnails anpassen

Mit diesem Tipp können Sie die Größe der so Thumbnails (Miniaturansicht) unter Windows anpassen. Der Standardwert "100" kann im Wertebereich zwischen 32 und 256 Pixel beliebig umgestellt werden.

Weiterhin können Sie die Qualität der Thumbnails festlegen. Je größer der Wert um so besser die Qualität, dadurch wird die Thumbnails-Datei aber größer.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ThumbnailSize" als Datentyp REG_DWORD. Geben Sie hier die Größe in Pixel an. Der Wert kann zwischen 32 und 256 verändert werden und liegt Standardmäßig bei 100 Pixel.

Weiterhin gib es noch den einen Wert mit den Namen "Thumbnailquality" als Datentyp REG_DWORD. Geben Sie hier die Qualität in Prozent an. Der Wert kann zwischen 50 und 100 liegen und steht Standardmäßig auf 90 Prozent.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1595.htm


Inaktive Icons aus dem Systray ausblenden

Mit diesem Tipp können Sie einstellen, ob inaktive Icons im Systray weiterhin angezeigt oder ausgeblendet werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

ändern Sie hier den Wert "EnableAutoTray" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Inaktive Icons ausblenden
0 | Inaktive Icons nicht ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2103.htm


Auf die klassische Ansicht des Startmenüs umschalten

Das Startmenü hat unter Windows ein neues Aussehen bekommen. Durch einen Klick mit der rechten Maustaste und der Auswahl von "Eigenschaften" können Sie zwischen der neuen und der klassischenAnsicht umschalten. Sie können das Aussehen aber auch direkt in der Registry verändern.

Das klassische Startmenü in Windows 2000 erlaubt es Benutzern, allgemeine Aufgaben durchzuführen, während das neue Startmenü allgemeine Punkte in einem Menü zusammenfasst. Wenn das klassische Startmenü verwendet wird, werden die folgenden Symbole auf dem Desktop angeordnet: Eigene Dokumente, Eigene Bilder, Eigene Musik, Arbeitsplatz und Netzwerkumgebung. Das neue Startmenü startet sie direkt.

Wenn Sie diese Einstellung aktivieren, erscheint das Startmenü als klassisches Startmenü im Stil von Windows 2000 und zeigt die Standarddesktopsymbole.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSimpleStartMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | klassische Ansicht
0 | neue Ansicht (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Klassisches Startmenü erzwingen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1350.htm


Neue Programmeinträge im Startmenü hervorheben

Mit diesem Tipp können Sie einstellen, ob neue Programmeinträge im Startmenü farblich hervorgehoben werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_NotifyNewApps" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Neue Programmeinträge farblich hervorheben
0 | Neue Programmeinträge nicht farblich hervorheben

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1670.htm


Start Button 'Balloon Tipps' ausschalten

Start Button "Balloontipps" ausschalten

Mit diesem Tipp können Sie einstellen, ob Ballon-Tipps beim Start-Button angezeigt werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "StartButtonBalloonTip" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Tooltipps deaktivieren
1 | Tooltipps aktivieren
2 | Erweitere Tooltipps

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1713.htm


'An Startmenü anheften' auch für Ordner

"An Startmenü anheften" auch für Ordner

Wenn Sie das Kontextmenü einer EXE-Datei öffnen (rechte Maustaste auf die Datei) gibt es hier den Eintrag "An Startmenü anheften", bei anderen Dateitypen müssen Sie zusätzlich noch die Shift-Taste gedrückt halten.

Leider funktioniert das aber nicht mit Ordner. Wenn sie diesen Tipp aktivieren, wird auch bei Ordner dieser Eintrag im Kontextmenü angezeigt, wenn Sie bei öffnen des Kontextmenüs die Shift-Taste gedrückt halten.

Info Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Folder\ shellex\ ContextMenuHandlers

legen Sie einen neuen Schlüssel mit den Namen "{a2a9545d-a0c2-42b4-9708-a0b2badd77c8}" an.

Wenn Sie die Eintrag nicht mehr wollen, müssen Sie den Schlüssel wieder löschen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2054.htm


Startmenü Popup bei neuem Profil

Wenn man sich das erste Mal bei Windows anmeldet, erscheint ein Startmenü Popup "Klicken Sie auf die Schaltfläche <Star> ". Wenn Sie das nicht wollen, müssen Sie den folgenden Eintrag im Profil aktivieren.

Nach der ersten Anmeldung wird dieser Wert von Windows automatisch aktiviert. Wenn Sie diesen Wert deaktivieren, wird das Startmenü neu initialisiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "StartMenuInit" als Datentyp REG_DWORD und setzen den Wert auf:

2 | Startmenü nicht initialisieren
1 | Startmenü initialisieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2107.htm


Arbeitsplatz im 'Startmenü' konfigurieren

Arbeitsplatz im "Startmenü" konfigurieren

Mit diesem Tipp legen Sie fest, ob der <Arbeitsplatz> im "Startmenü" angezeigt werden soll. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowMyComputer" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Arbeitsplatz ausblenden
1 | Arbeitsplatz als Link
2 | Arbeitsplatz ausblenden#Arbeitsplatz als Link#Arbeitsplatz als Menü

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1721.htm


Drag and Drop im 'Startmenü' Aus-/Einschalten

Drag and Drop im "Startmenü" Aus-/Einschalten

Mit diesem Tipp können Sie die "Drag und Drop" Funktion im "Startmenü" aus-/einschalten. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_EnableDragDrop" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Drag and Drop" aktivieren
0 | "Drag and Drop" deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1720.htm


Eigene Dateien im 'Startmenü' konfigurieren

Eigene Dateien im "Startmenü" konfigurieren

Mit diesem Tipp legen Sie fest, ob <Eigene Dateien> im "Startmenü" angezeigt werden soll. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowMyDocs" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Eigene Dateien ausblenden
1 | Eigene Dateien als Link
2 | Eigene Dateien als Menü

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1722.htm


Netzwerkverbindungen aus dem 'Startmenü' konfigurieren

Netzwerkverbindungen aus dem "Startmenü" konfigurieren

Mit diesem Tipp legen Sie fest, ob <Netzwerkverbindungen> im "Startmenü" angezeigt werden sollen. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowNetConn" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Netzwerkverbindungen ausblenden
1 | Netzwerkverbindungen als Link
2 | Netzwerkverbindungen als Menü

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1723.htm


Verwaltung im 'Startmenü' konfigurieren

Verwaltung im "Startmenü" konfigurieren

Mit diesem Tipp legen Sie fest, ob die <Verwaltung> im "Startmenü" angezeigt werden soll. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_AdminToolsTemp" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Verwaltung ausblenden
1 | Verwaltung als Link
2 | Verwaltung als Menü

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1724.htm


Hilfe und Support im 'Startmenü' ein-/ausblenden

Hilfe und Support im "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob <Hilfe und Support> im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowHelp" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Hilfe und Support ausblenden
1 | Hilfe und Support einblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1725.htm


Netzwerkumgebung im 'Startmenü' konfigurieren

Netzwerkumgebung im "Startmenü" konfigurieren

Mit diesem Tipp legen Sie fest, ob die <Netzwerkumgebung> im "Startmenü" angezeigt werden sollen. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowNetPlaces" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Netzwerkumgebung ausblenden
1 | Netwerkumgebung als Link
2 | Netzwerkumgebung als Menü

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1726.htm


Liste der am häufigsten benutzten Programme aus dem Startmenü entfernen

Mit diesem Eintrag wird die Liste der am häufigsten benutzten Programme aus dem Startmenü entfernt.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuMFUprogramsList" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Die Programmliste wird angezeigt (Standard)
gelöscht | Die Programmliste wird nicht angezeigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Liste häufig verwendeter Programme aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1417.htm


Den Eintrag 'Netzwerkumgebung' aus dem Startmenü entfernen

Mit diesem Eintrag wird aus dem neuen Startmenü (nicht die klassische Ansicht) der Eintrag "Netzwerkumgebung" entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuNetworkPlaces" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Symbol "Netzwerkumgebung" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1418.htm


Den Eintrag 'PC ausdocken' aus dem Startmenü entfernen

Bei einem Laptop/Notebook mit Dockingstation gibt es den Eintrag "PC ausdocken" im Startmenü.

Sie können mit einem Eintrag in der Registry diesen Eintrag aus dem Startmenü entfernt.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuEjectPC" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Schaltfläche "Abdocken" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1419.htm


Den Eintrag 'Alle Programme' aus dem Startmenü entfernen

Mit diesem Tipp können Sie aus den Eintrag "Alle Programme" entfernt.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuMorePrograms" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Liste "Alle Programme" aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1422.htm


Drucker und Faxgeräte im 'Startmenü' ein-/ausblenden

Drucker und Faxgeräte im "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob <Drucker und Faxgeräte> im "Startmenü" angezeigt werden sollen. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowPrinters" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Drucker und Faxgeräte anzeigen
0 | Drucker und Faxgeräte ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1728.htm


Ausführen im 'Startmenü' ein-/ausblenden

Ausführen im "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob <Ausführen> im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowRun" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Ausführen" einblenden
0 | "Ausführen" ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1729.htm


OEM-Link im 'Startmenü' ein-/ausblenden

OEM-Link im "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob ein <OEM-Link> im "Startmenü" angezeigt werden soll. Die Anzeige erfolgt bei der Aktivierung nur, wenn ein entsprechender Link-Eintrag vorhanden ist. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassischeAnsicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowOEMLink" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | OEM-Link einblenden
0 | OEM-Link nicht einblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1727.htm


Suchen aus dem 'Startmenü' ein-/ausblenden

Suchen aus dem "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob <Suchen> im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ShowSearch" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Suchen ausblenden
1 | Suchen anzeigen

Ab Service Pack 1 für Windows Vista wurde die Suche aus dem Startmenü aufgrund einer Klage an Microsoft entfernt. Leider kann man die Suche nicht so einfach wieder in der rechten Seite des Startmenüs einblenden.

Im Kontextmenü

Mit den folgenden Eintrag fügen Sie die Suche im Kontextmenü (rechte Maustaste auf das Startmenü) im Startmenü wieder ein.

HKEY_CLASSES_ROOT\Directory\shell\find

löschen Sie den Eintrag "LegacyDisable" als Datentyp REG_SZ. Melden Sie sich neu an oder starten Sie den Rechner neu. Anschließend ist der Eintrag vohanden.

Im Startmenü

Erstellen Sie auf dem Desktop über rechte Maustaste -> Neu -> Verknüpfung eine neue Verknüpfung. Geben Sie bei "Geben Sie den Speicherort des Elements ein:" folgendes ein:

C:\Windows\explorer.exe search-ms:

Wählen Sie jetzt "Weiter" und geben Sie bei Name "Suche" ein und erstellen Sie die Verknüpfung über "Fertig stellen".

Ziehen Sie jetzt mit der Maus (Drag and Drop) das Icon auf das Startmenü und legen Sie es oben links im Startmenübereich ab.

Suche - Startmenü

Info Weiterhin können Sie die Suche auch über die Tastenkombination WIN+F aufrufen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1730.htm


Startmenüeinträge unter Programme zum Scrollen anzeigen

Wenn Sie viele Einträge im "Startmenü" unter Programme haben und die nicht mehr in einer Reihe auf den Bildschirm dargestellt werden können, wird von Windows automatisch eine neue Reihe aufgemacht.

Wenn Sie diese Funktion aktivieren, wird alles in einer Reihe angezeigt, und Sie müssen in die nicht sichtbaren Bereiche hineinscrollen.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_ScrollPrograms" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Scroll Funktion aktivieren
0 | Scroll Funktion deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1731.htm


Angeheftete Programme aus dem Startmenü entfernen

Wenn Sie diese Einstellung aktivieren, wird die Liste "Angeheftete Programme" aus dem Startmenü entfernt, und die Kontrollkästchen "Internet" und "E-Mail" werden aus der Systemsteuerungsoption zum Anpassen des einfachen Startmenüs entfernt.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuPinnedList" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Angeheftete Programme ausblenden
gelöscht | Angeheftete Programme werden angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Liste angehefteter Programme aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1764.htm


Liste der zuletzt geöffneten Programme im Startmenü

In der neuen Startmenüansicht (nicht die klassische Ansicht), werden auf der linken Seite im Startmenü die zuletzt geöffneten Programme angezeigt. Dadurch soll Ihnen das Öffnen dieser Programme erleichtert werden, wenn Sie die öfter benötigen. Diese Liste wird dynamisch verwaltet, so dass hier immer nur die zuletzt geöffneten Programme angezeigt werden.

Ob Programme in dieser Liste eingetragen werden, können Sie über die Registry konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Applications

suchen Sie sich das gewünschte Programm aus, welches Sie konfigurieren wollen. Erstellen Sie hier unterhalb des Programmes einen neuen Wert mit dem Namen "NoStartPage" als Datentyp REG_SZ.

Sobald der Eintrag vorhanden ist, werden keine weiteren Links mehr in die Liste aufgenommen, auch wenn es gestartet wird. Wenn Sie wieder möchten, dass dieses Programm in der Liste erscheinen soll, müssen Sie diesen Eintrag "NoStartPage" einfach nur löschen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1766.htm


Benutzernamen aus dem Startmenü entfernen

Wenn Sie diese Einstellung aktivieren, wird der Benutzername aus dem Startmenü entfernt.

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoUserNameInStartMenu" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Benutzername wird nicht angezeigt
gelöscht | Benutzername wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Benutzernamen aus dem Startmenü entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1927.htm


"Verwaltung" im 'Startmenü' konfigurieren

Mit diesem Tipp legen Sie fest, ob "Verwaltung" im "Startmenü" angezeigt werden soll. Der Eintrag wird als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) angezeigt.

Diese Einstellung bezieht sich auf die "neue" Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "Start_AdminToolsRoot" als Datentyp REG_DWORD und setzen den Wert auf:

1 | "Verwaltung" im "Startmenü" anzeigen
0 | "Verwaltung" im "Startmenü" nicht anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2077.htm


'Zuletzt Verwendete Dokumente' im Startmenü konfigurieren

"Zuletzt verwendete Dokumente" im 'Startmenü' konfigurieren

Mit diesem Tipp legen Sie fest, ob "Zuletzt verwendete Dokumente" im "Startmenü" angezeigt werden sollen. Weiterhin können Sie dabei festlegen, ob der Eintrag als Link (es wird erst beim Klick ein neues Fenster mit dem Inhalt geöffnet) oder als Menü (zum Aufklappen wie Programme) angezeigt wird.

Diese Einstellung bezieht sich auf die "neue" Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "Start_ShowRecentDocs" als Datentyp REG_DWORD und setzen den Wert auf:

0 | "Zuletzt Verwendete Dokumente" ausblenden
1 | "Zuletzt Verwendete Dokumente" als Link
2 | "Zuletzt Verwendete Dokumente" als Menü

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2078.htm


QuickInfos (BallonTips) abschalten

Kurze Informationen werden bei Windows über sog. Sprechblasen (BallonTips) angezeigt, um den Benutzer über Ereignisse wie z.B. Installation neuer Programme, zu niedriger Festplattenspeicher und die Ausblendung von Infobereichssymbolen zu informieren.

Es handelt sich hierbei nicht um die Info-Einblendungen, die angezeigt werden, wenn Sie mit dem Mauszeiger auf das entsprechende Symbol gehen, sondern die Sprechblasen, die automatisch bei entsprechenden Ereignissen eingeblendet werden.

Diese Informationen können mit der Zeit sehr störend sein, da man einige dieser Tipps immer wieder schließen muss. Mit folgendem Eintrag in der Registry können Sie diese Funktion abschalten:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableBalloonTips" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Quickinfos werden angezeigt (Standard)
0 | Die Quickinfos werden nicht angezeigt

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Einstellungen für Infotipps finden Sie unter:
Quickinfo für Icons
Popuptexte im Startmenü ausschalten

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1256.htm


Assistent in der Suchfunktion ausschalten

Ab Windows XP hat MS einen Assistenten für die Suchfunktion eingeführt. Sie werden vor der Suche gefragt, nach was Sie suchen wollen, danach nimmt Windows die Einstellungen für die Suche automatisch vor. Wer mit der alten Suchfunktion aber gut vertraut war, findet das eher umständlich und möchte lieber wieder die alte Suchansicht verwenden. Dafür müssen Sie folgenden Registry-Wert setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Suchansicht für den Windows Explorer

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ CabinetState

Erstellen Sie hier einen neuen Eintrag mit dem Namen Use Search Asst als Datentyp REG_SZ. Setzen Sie den Wert auf "no". Jetzt wird kein Assistent mehr angezeigt.

Suchansicht für den Internet Explorer

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Eintrag mit dem Namen Use Search Asst als Datentyp REG_SZ. Setzen Sie den Wert auf "no", jetzt wird kein Assistent mehr angezeigt.

Wenn Sie die Assistenten wieder aktivieren wollen, müssen Sie die Einträge löschen.

Info In der englischen XP-Version sendet die Suchfunktion über den Assistent die Suchanfragen an Microsoft, auch wenn nur eine lokale Suche durchgeführt wird. Aus diesem Grunde ist es auch schon besser die klassische Suchfunktion zu benutzen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1221.htm


Desktopbereinigungs-Assistenten deaktivieren

Ab Windows XP gibt es die neue Funktion "Desktopbereinigung". Diese Funktion ist standardmäßig aktiviert und überprüft alle 60 Tage den Desktop auf Symbole, die nicht mehr benutzt worden sind. Wurden Symbole länger als 60 Tage nicht mehr benutzt, werden sie von Desktop entfernt und in einen extra Ordner verschoben.

Sie finden diese Einstellung unter "Eigenschaften der Anzeige" (rechter Mausklick auf den Desktop und dann Eigenschaften) im Tabreiter "Desktop", Schaltfläche "Desktop anpassen", im Abschnitt "Desktopbereinigung" ausschalten.

Sie können diese Einstellung auch direkt in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Konfiguration

Hiermit wird verhindert, dass der Assistent automatisch gestartet wird, der Anwender kann den Assistenten aber noch jederzeit selber starten.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ CleanupWiz

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRun" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Der Assistent ist aktiviert (Standard)
1 | Der Assistent ist deaktiv

Erstellen Sie hier einen neuen Wert mit dem Namen "Days between clean up" als Datentyp REG_DWORD. Geben Sie auch an, innerhalb welches Zeitraumes der Assistent gestartet werden soll (Standard: alle 60 Tage).

Policy

Wenn Sie wollen, dass der Anwender die Einstellung nicht mehr ändern kann, müssen Sie mit den folgenden Keys arbeiten. Dabei wird der Assistent nicht nur ausgeschaltet, sondern es wird auch verhindert, dass der Anwender den Assistenten selber starten kann.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDesktopCleanupWizard" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Der Desktopbereinigsungs-Assistent kann nicht vom Benutzer gestartet werden und ist deaktiviert.
0 | Wird alle 60 Tage gestartet (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Desktop
Einstellungsname: | Desktopbereinigungs-Assistent entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Falls Benutzer vorher Symbolleisten hinzugefügt oder entfernt haben, können sie aufgrund dieser Einstellung die Standardeinstellungen nicht wieder hergestellt werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1330.htm


Animation der Tooltipps deaktivieren

Wenn Sie die Animation der Tooltipps ausschalten wollen, können Sie das über folgenden Registryeintrag durchführen. Wenn Sie den Wert "CheckedValue" auf 0 setzen, werden keine Animationen beim öffnen der Tooltipps mehr angezeigt, ansonsten werden die Tooltipps animiert geöffnet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects\ TooltipAnimation

erstellen Sie einen neuen Wert mit dem Namen "CheckedValue" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0 (bzw. auf 1, um die Animation zu aktivieren).

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1349.htm


'Smooth Scrolling' der Menüs deaktivieren

Durch folgende Einstellung können Sie beeinflussen, ob Menüs "weich" aufgeblendet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects\ ListBoxSmoothScrolling

Erstellen Sie einen neuen Eintrag mit dem Namen "CheckedValue" als Datentyp REG_DWORD,. Setzen Sie den Wert auf 0 ( bzw. auf 1, um die Funktion wieder zu aktivieren).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1346.htm


Ordnerinformationen als Balloontip anzeigen

Mit diesem Tipp können Sie einstellen, ob Ordnerinformationen als Ballontip angezeigt werden sollen. Diese Einstellung können Sie im Explorer über das Menü "Extras" -> ."Ordneroptionen" im Tabreiter "Ansicht" -> hier die Einstellung "Dateigrößeinformationen in Ordnertipps anzeigen" entsprechend konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "FolderContentsInfoTip" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Verzeichnisinfo nicht anzeigen
1 | Verzeichnisinfo anzeigen

Info Die Verzeichnisinfos werden nur angezeigt, wenn auch zusätzlich der Eintrag "ShowInfoTip" aktiviert ist, siehe dazu Tipp: "Quickinfo für Icons"

Info Weitere Einstellungen für Infotipps finden Sie unter:
QuickInfos (Ballontipps) abschalten
Popuptexte im Startmenü ausschalten
Quickinfo für Icons

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1714.htm


Transparente Ansicht des Auswahlrechteckes ausschalten

Mit diesem Tipp können Sie die transparente Ansicht des Auswahlrechteckes bei Explorer ausschalten. Bei nicht so schnellen Rechner kann diese Funktion eher stören. Mit dem Auswahlrechteck, ist das Rechteck gemeint, was angezeigt wird, wenn Sie im Explorer über die rechte Maustaste mehrere Dateien markieren wollen.

Diese Einstellung finden Sie unter: "Systemsteuerung" -> "System". Gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen"

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Durchsichtiges Auswahlrechteck anzeigen"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ListviewAlphaSelect" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Kein durchsichtiges Auswahlrechteck anzeigen
1 | Durchsichtiges Auswahlrechteck anzeigen (Standard)

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1750.htm


Durchsichtigen Hintergrund für Symboltext auf dem Desktop

Mit diesem Tipp können Sie einstellen, ob der Hintergrund der Symboltexte auf dem Desktop durchsichtig sein soll. Je nach Hintergrund kann das dazu führen, das man die Schrift durch das Hintergrundbild nicht mehr lesen kann.

Diese Einstellung finden Sie unter: "Systemsteuerung" -> "System". Gehen Sie auf den Tabreiter "Erweitert" und klicken unter "Systemleistung" auf den Button "Einstellungen".

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Durchsichtigen Hintergrund für Symbolunterschriften auf dem Desktop".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ListviewShadow" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Kein durchsichtiger Hintergrund für Symboltexte
1 | Durchsichtiger Hintergrund für Symboltexte (Standard)

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert
Eine weitere Möglichkeit, warum der durchsichtige Hintergrund nicht funktioniert:

In den Eigenschaften von Anzeige unter dem Reiter "Desktop" mit dem Button "Desktop anpassen" die Desktopelemente aufrufen. Unter dem Reiter "Web" prüfen, ob eine Webseite angehakt ist. Meistens handelt sich dabei um eine temporäre Datei aus dem IE-Fundus, die angehakt ist. Haken entfernen, übernehmen, fertig.

Eine Transparenz der Symbolunterschriften kann beim Laden eines Desktop-Hintergrundbildes mit Alphakanal (z.B. PNG mit tatsächlichem Alphakanal [es gibt auch PNG's ohne!]) nicht gewährleistet werden. In diesem Falle sollte die Bilddatei in ein anderes Format umgewandelt werden, wobei dann natürlich der Alphakanal verloren geht.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1751.htm


Für jeden Ordnertyp ein Hintergrundbild verwenden

Mit diesem Tipp können Sie einstellen, ob für jeden Ordnertyp ein Hintergrundbild im Explorer verwendet werden soll.

Diese Einstellung finden Sie unter: "Start" -> "Systemsteuerung" -> "System" gehen Sie hier auf den Tabreiter "Erweitert" und klicken Sie unter "Systemleistung" auf den Button "Einstellungen".

Ab Windows Vista unter "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen.

Hier finden Sie dann den Eintrag "Für jeden Ordnertyp ein Hintergrundbild verwenden".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "ListviewWatermark" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Nicht für jeden Ordnertyp ein Hintergrundbild verwenden
1 | Für jeden Ordnertyp ein Hintergrundbild verwenden (Standard)

Damit die Änderung auch unter der Systemsteuerung - Leistungsoptionen (siehe oben) richtig angezeigt wird, muss der folgende Wert in der Registry zusätzlich geändert werden:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects

Setzen Sie hier den Wert "VisualFXSetting" als Datentyp REG_DWORD.auf 3.Die Werte haben hier folgende Bedeutung (nur für die Anzeige "Leistungsoptionen")

0 | Optimale Einstellung automatisch auswählen
1 | Für optimale Darstellung anpassen
2 | Für optimale Leistung anpassen
3 | Benutzerdefiniert

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1752.htm


Anzeigeart der Systemsteuerung

Die Systemsteuerung unter Windows hat ein neues Aussehen bekommen. Statt der alten klassische Ansichtwird sie jetzt in der neuen sog. Kategorieansicht (aufgabenbasierter Stil) dargestellt. Sie können zwischen den Ansichten auf der linken Seite hin und her schalten.

Mit dieser Einstellung können Sie den neuen aufgabenbasierten Stil der Systemsteuerung deaktivieren und den Windows 2000-Stil verwenden, der als klassische Systemsteuerung bezeichnet wird.

Wenn Sie diese Einstellung aktivieren, wird der klassische Stil der Systemsteuerung angezeigt. Der Benutzer kann nicht auf den neuen einfachen Stil umschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceClassicControlPanel" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Klassische Ansicht
0 | Kategorieansicht (aufgabenbasierter Stil)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung
Einstellungsname: | Klassischen Stil der Systemsteuerung erzwingen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1347.htm


Der Tabreiter 'Automatische Updates' ist doppelt vorhanden

Nach Einspielung des ServicePack SP1 oder SP2 kann es dazu kommen, dass der Tabreiter "Automatische Updates" unter Arbeitsplatz -> rechte Maustaste -> Eigenschaften doppelt angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Controls Folder\ System\ shellex\ PropertySheetHandlers

finden Sie unterhalb vom Schlüssel "PropertySheetHandlers" mehrere doppelte Einträge in unterschiedlichen Sprachen.

Der Schlüssel "Auto Update Property Sheet Extension" ist für den Tabreiter "Automatische Updates" zuständig und darf nicht gelöscht werden.

Der Schlüssel "Remote Sessions CPL Extension" ist für den Tabreiter "Remote" zuständig und darf nicht gelöscht werden.

Weiterhin findet man hier noch den Eintrag "Eigenschaftenseitenerweiterung des automatischen Updates".

Dieser Schlüssel ist für den doppelten Eintrag verantwortlich. Wenn Sie diesen Schlüssel löschen, ist der Eintrag weg. Sie sollten vorher diesen Zweig in eine REG-Datei über das Menü "Datei" -> "Exportieren" sichern, um ihn ggf. wieder zurückspielen zu können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1828.htm


Systemsteuerung ausblenden

Wenn Sie den Zugriff auf die Systemsteuerung unterbinden wollen, können Sie die gesamte Systemsteuerung mit folgendem Eintrag in der Registry ausblenden.

Diese Einstllung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

erstellen Sie einen neuen Eintrag mit dem Namen "Start_ShowControlPanel" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0 (bzw. auf 1, um die Systemsteuerung wieder anzuzeigen).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1348.htm


Den Eintrag 'Dienste einrichten' aus Software deaktivieren

Wenn Sie diesen Policy aktivieren, wird der Eintrag "Dienste einrichten" unter "Systemsteuerung" -> "Software" bei "Windows-Komponenten hinzufügen/entfernen" deaktiviert.

Durch diese Einstellung wird der Abschnitt "Dienste einrichten" auf der Seite "Windows-Komponenten hinzufügen/entfernen" entfernt. Der Abschnitt "Dienste einrichten" führt die Systemdienste auf, die noch nicht konfiguriert wurden und ermöglicht Benutzern, die Konfigurationsprogramme zu verwenden.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird der Abschnitt "Dienste einrichten" nur dann angezeigt, wenn Dienste noch nicht konfiguriert wurden. Durch Aktivieren dieser Einstellung wird dieser Abschnitt nie angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Uninstall

Erstellen Sie hier einen neuen Wert mit dem Namen "NoServices" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Software
Einstellungsname: | Direkt zum Assistent für Windows-Komponenten wechseln

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung verhindert nicht, dass Benutzer anderweitig Dienste konfigurieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1426.htm


Den Eintrag 'Designs' aus dem Menü 'Eigenschaften der Anzeige' ausblenden

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", wird der Tabreiter "Designs" angezeigt. Durch Verwendung der Optionen der Registerkarte "Design" kann der Benutzer das Design seines Desktops konfigurieren.

Wenn Sie den Eintrag "NoThemesTab" aktivieren (Festlegung auf "1"), wird der Tabreiter Designs ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoThemesTab" als Datentyp REG_DWORD und setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige\Desktopdesigns
Einstellungsname: | Designoption entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1952.htm


Den Eintrag 'Fenster und Schaltflächen' sichern

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", wird unter dem Tabreiter "Darstellung" der Eintrag "Fenster und Schaltflächen" gesichert.

Dadurch wird verhindert, dass der Benutzer den visuellen Stil, der auf seinem Bildschirm angezeigten Fenster und Schaltflächen, ändern kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoVisualStyleChoice" als Datentyp REG_DWORD. Setzen

Sie den Wert auf:

1 | Eintrag wird gesichert
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige\Desktopdesigns
Einstellungsname: | Auswahl des Fenster- und Schaltflächenstils verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1953.htm


Änderung der Schriftgröße nicht zulassen

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", wird unter dem Tabreiter "Darstellung" der Eintrag "Schriftgrad" gesichert.

Dadurch wird verhindert, dass der Benutzer die Schriftgröße in den auf seinem Bildschirm angezeigten Fenstern und Schaltflächen ändern kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSizeChoice" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eintrag wird gesichert
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige\Desktopdesigns
Einstellungsname: | Auswahl der Schriftartgröße nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1954.htm


Ändern des Farbschemas verhindern

Unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Anzeige" oder beim Rechtsklick auf den Desktop und der Auswahl aus dem Kontextmenü "Eigenschaften", wird unter dem Tabreiter "Darstellung" der Eintrag "Farbschema" gesichert.

Wenn Sie diese Einstellung aktivieren, kann der Benutzer das Farbdesign des aktuellen Desktops nicht ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoColorChoice" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Eintrag wird gesichert
gelöscht | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige\Desktopdesigns
Einstellungsname: | Designfarbauswahl nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1955.htm


Zu ladenen 'Visuellen Stil' festlegen

Zu ladenden 'Visuellen Stil' festlegen

Mit dieser Einstellung können Sie eine bestimmte Datei für den visuellen Stil laden, indem Sie den Pfad der Datei für den visuellen Stil eingeben.

Dies kann ein visueller Stil auf dem lokalen Computer sein (Luna.msstyles) bzw. (%windir%\resources\Themes\Luna\Luna.msstyles) oder eine auf dem entfernten Server liegende Datei, wobei ein UNC-Pfad verwendet wird (\\Server\Share\luna.msstyles).

Wenn Sie diese Einstellung aktivieren, wird die von Ihnen angegebene Datei für den visuellen Stil verwendet.

Die visuellen Stil finden Sie unter "%windir%\resources\Themes\".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "SetVisualStyle" als Datentyp REG_SZ und geben Sie den Pfad und Dateinamen zum "Viszellen Stil" ein.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Anzeige\Desktopdesigns
Einstellungsname: | Bestimmten visuellen Stil laden bzw. "Windows - klassisch" erzwingen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Um den visuellen Stil "Windows - klassisch" zu wählen, lassen Sie das Feld neben "Pfad des visuellen Stils:" leer und aktivieren diese Einstellung.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1956.htm


Fehlerhafte Doppelklicks erkennen

Leicht kann es passieren, dass Windows einen Doppelklick erkennt, wo sie eigentlich keinen Doppelklick ausführen wollten.

Wenn Sie diesen Registry-Wert aktivieren, versucht Windows solche fehlerhaften Doppelklicks auszufiltern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "UseDoubleClickTimer" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Windows versucht fehlerhafte Doppelklicks auszufiltern
0 | Funktion ist ausgeschaltet (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1380.htm


Mausschatten deaktivieren

Den Mausschatten können Sie durch folgenden Registryeintrag aus/einschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ VisualEffects\ CursorShadow

erstellen Sie einen neuen Eintrag mit dem Namen "CheckedValue" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0, um den Mausschatten auszuschalten oder auf 1, um ihn wieder zu aktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1356.htm


Versteckte Funktionen im Logitech-Maustreiber

Bei der Installation des Logitech-Maustreibers werden die Funktionen "Zeigerposition beim Drücken der STRG-Taste anzeigen" und "Zeiger bei Tastatureingaben ausblenden" ausgeblendet.

Möchte man diese Funktion trotzdem verwenden, muss man diese Funktionen vor der Installation aktivieren. Danach bleibt nur noch der Weg über die Registry, sehen Sie dazu die Beschreibung des Registry-Wertes UserPreferencesMask.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1215.htm


Ausführen von 16-Bit-Anwendungen unterbinden

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob die Ausführung des 16-Bit-MS-DOS-Subsystems (ntvdm.exe) für Benutzer nicht zugelassen ist. Diese Einstellung wirkt sich auf den Aufruf von 16-Bit-Anwendungen vom Betriebssystem aus. Standardmäßig dürfen Benutzer das MS-DOS-Subsystem ausführen.

Durch diese Einstellung kann das MS-DOS-Subsystem ausgeschaltet werden, wodurch die Ressourcennutzung verringert wird und 16-Bit-Anwendungen nicht mehr ausgeführt werden können. Wenn 16-Bit-Anwendungen oder Anwendungen mit 16-Bit-Komponenten ausgeführt werden sollen, muss die Ausführung von ntvdm.exeerlaubt sein. Beim Aufruf einer 16-Bit-Anwendung startet das MS-DOS-Subsystem. Sobald der Prozess läuft, starten abhängige 16-Bit-Anwendungen schneller, die Gesamtressourcennutzung des Systems liegt jedoch höher.

Wenn Sie diesen Tipp aktivieren, wird die Ausführung von ntvdm.exe und dadurch auch von 16-Bit-Anwendungen unterbunden. Außerdem können 32-Bit-Anwendungen mit 16-Bit-Installer oder -komponenten nicht mehr ausgeführt werden.

Standardmäßig dürfen Benutzer das MS-DOS-Subsystem ausführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ AppCompat

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "VDMDisallowed" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | 16-Bit-Anwendungen deaktivieren
0 | 16-Bit-Anwendungen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Zugriff auf 16-Bit-Anwendungen verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1918.htm


Farbige Markierungen für Eingabeaufforderung festlegen

Mit diesem Tipp lagen Sie fest, dass Sie farbige Markierungen benutzen können.

Um etwas in der Eingabeaufforderung zu markieren, wählen Sie:

Strg+Ziffer | Hintergrundfarbe markieren
Alt+Ziffer | Textfarbe markieren
Shift+Alt+Ziffer | nach Farbmarkierung suchen (ab Windows Server 2003)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Console

ändern Sie hier den Wert "EnableColorSelection" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Farbige Markierungen aktivieren
0 | Farbige Markierungen deaktivieren

Ziffer | Farbe
0 | Olive
1 | Silber
2 | Grau
3 | Blau
4 | Grün
5 | Aqua
6 | Rot
7 | Rosa
8 | Gelb
9 | Weis

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2065.htm


Schriftarten der Eingabeaufforderung erweitern

In diesen Tipp wird beschrieben, wie Sie die Liste der möglichen Schriftarten für die Eingabeaufforderung erweitern können.

Wenn Sie die Eigenschaften der Eingabeaufforderung öffnen, können Sie hier nur zwischen zwei Schriften "Lucida Console" und "Rasterschriftart" auswählen. Sie können aber die Liste der möglichen Schriftarten über die Registry erweitern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Console\ TrueTypeFont

Erstellen Sie hier einen neuen Wert mit dem Namen "0xxx" als Datentyp REG_SZ und geben den Namen der entsprechenden Schriftart an.

Für xxx müssen Sie jeweils eine weitere 0 hinzufügen. Der erste schon vorhandene Eintrag lautet also "0" und als Schriftart den Eintrag "Lucida Console".

Für die nächste Schriftart legen Sie den Wert "00" an und geben den Namen der Schriftart an. Für jeden weiteren Eintrag fügen Sie eine weitere "0" hinzu.

Damit der Eintrag zu Auswahl angezeigt wird, müssen Sie den Rechner anschließend neu starten.

Info Geeignet sind Schriftarten die nicht proportional sind. Also Schriftarten wo alle Zeichen gleich breit sind.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2511.htm


ICACLS Dokumentation Fehler

In der Dokumentation zu den Parametern von ICACLS hat sich bei Windows Server 2003 und Vista ein Fehler eingeschlichen. Hier wird als Parameter "D" angegeben, um das Recht "deny-delete" zu setzen. Wenn man diesen Parameter aber für eine Gruppe benutzt, darf danach keiner mehr auf das Verzeichnis zugreifen.

Richtig müsste der Parameter "DE" heißen um das entsprechende Recht zu setzen.

Der richtige Aufruf würde dann z.B. so aussehen:

icacls.exe C:\Temp\TestOrdner\ /deny Everyone:(OI)(CI)(DE)

Mit diesem Befehl wird für die Gruppe Everyone ein deny-delete Recht (löschen verweigern) gesetzt.

Info Weitere Infos zu ICACLS finden Sie im Tipp: "Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen (CACLS und ICACLS)"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2414.htm


Informationen über den Befehl SC

Der Befehl kommuniziert mit dem Dienstcontroller und kann Dienste installierten und konfigurieren.

SC.EXE ruft Steuerungsinformationen zu Diensten ab und legt sie fest.

Der Vorteil ist, das mit diesem Befehl auf Remote auf anderen Rechner Einstellungen verändert werden können.

SC <RechnerName> [command] [service name] <option1> <option2>...

Einige Parameter ([command]):

sdset <ServiceName> <SDDL> | Legt mithilfe von SDDL (Service Descriptor Definition Language) die Sicherheitsbeschreibung für einen Dienst fest.
boot <bad|OK> | Gibt an, ob der letzte Start als die letzte noch funktionierend bekannte Konfiguration gespeichert werden soll.
/? | Zeigt die Hilfe
config [Dienstname] [type= {own | share | kernel | filesys | rec | adapt | interacttype= {own | share}}] [start= {boot | system | auto | demand | disabled}] [error= {normal | severe | critical | ignore}] [binpath= Binärdateipfad] [group= Ladegruppe] [tag= {yes | no}] [depend= Abhängigkeiten] [obj= {Kontoname | Objektname}] [displayname= Anzeigename] [password= Kennwort] | Ändert den Wert der Einträge eines Dienstes in der Registrierung und in der Datenbank des Dienststeuerungs-Managers.
continue [Dienstname] | Sendet eine CONTINUE-Steuerungsanforderung an einen Dienst, um einen angehaltenen Dienst fortzusetzen.
stop [Dienstname] | Beendet den Dienst
start [Dienstname] | Startet den Dienst

Beispiel:

SC \\%ComputerName% stop sharedacces-> Beendet die Windows Firewall

Info Weitere Informationen dazu finden Sie bei Microsoft unter <Link>

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2030.htm


Beschreibung der Funktionen von Diskpart

Mit Diskpart haben Sie die Möglichkei,t ihre Datenträger zu verwalten. Sie können mit diesem Tool mehr machen als mit der grafischen Oberfläche, dadurch besteht aber auch die Möglichkeit von Datenverlusten. Sie sollten sich also gut überlegen, welche Aktionen Sie über das Tool ausführen.

Mit "diskpart.exe" können Sie das Tool starten. Hier können Sie sich mit HELP die möglichen Befehle anzeigen lassen.

Befehl | Beschreibung
ADD | Fügt eine Spiegelung einem einfachen Volume hinzu
ACTIVE | Markiert die aktuelle Basispartition als aktive Startpartition
ASSIGN | Weist dem gewählten Volume einen Buchstaben oder einen Bereitstellungspunkt zu
BREAK | Teilt eine Spiegelung auf
CLEAN | Löscht die Konfigurations- oder alle Informationen vom Datenträger
CONVERT | Führt Konvertierungen zwischen Datenträgerformaten durch
CREATE | Erstellt ein Volume oder eine Partition
DELETE | Löscht ein Objekt
DETAIL | Zeigt Details über ein Objekt an
EXIT | Beendet die Datenträgerpartitionierung
EXTEND | Erweitert ein Volume
HELP | Zeigt die Hilfe an
IMPORT | Importiert eine Datenträgergruppe
LIST | Druckt eine Liste aller Objekte
INACTIVE | Markiert die aktuelle Basispartition als inaktive Startpartition
ONLINE | Schaltet einen als offline markierten Datenträger online
REMOVE | Entfernt einen Buchstaben oder eine Bereitstellungspunktzuordnung
REPAIR | Repariert ein RAID-5-Volume
RESCAN | Überprüft den Computer erneut auf Datenträger und Volumes
RETAIN | Setzt eine Sicherungspartition unter ein einfaches Volume
SELECT | Verschiebt den Fokus auf ein Objekt
Ab Vista (Version 6.0.6000):
ATTRIBUTES | Ändert Volume-Attribute
AUTOMOUNT | Aktiviert oder deaktiviert die automatische Bereitstellung des Basis-Volumes
FILESYSTEMS | Zeigt das aktuelle Dateisystem und die unterstützten Dateisysteme auf dem Volume an
FORMAT | Formatiert das Volume oder die Partition
GPT | Weist der ausgewählten GPT-Partition Attribute zu
IMPORT | Importiert eine Datenträgergruppe
SETID | Ändert den Partitionstyp
SHRINK | Verkleinert die Größe des ausgewählten Volumes

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2161.htm


Zugriffsrechte auf unterschiedliche Objekte setzen

[Aus dem Windows Resource Kit]

Das Setzen von Zugriffsrechten (ACL - Access Control List) über das Tool CACLS.EXE ist den meisten Leuten bekannt. Mit diesem Tool können aber nur Rechte von Dateien und Verzeichnissen verändert werden.

Microsoft hat das Tool SUBINACL.EXE heraus gebracht.Mit diesem Tool können Rechte auf alle Objekte gesetzt werden, wo der Zugriff über entsprechende Rechte geregelt werden.

Somit können Sie mit diesem Tool auch Rechte auf Freigaben, Drucker und der Registry setzen.

SubInAcl [/option...] /object_type object_name [[/action[=parameter]...]

Mit SubInAcl /Help können Sie sich die Parameter anzeigen lassen.

Wollen Sie z.B.: Rechte auf ein neu angelegtes Share setzen, müssen Sie folgendes machen:

  • Bestehende Berechtigungen löschen (muss nicht gemacht werden)
    subinacl /share [Freigabename] /perm
  • Rechte setzen:
    subinacl /share [Freigabename] /grant=[Name1]=r /grant=[Name2]=f
  • Bedeutung:
    Gibt Name1 nur Leserechte und Name2 Vollzugriff

Info Es gibt weiterhin auch noch ein sehr gutes Freeware Tool, welches auch Rechte auf unterschiedliche Objekte setzen kann: http://setacl.sourceforge.net

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2174.htm


NetBEUI auch für Windows XP

In der Liste der möglichen Protokolle werden Sie NetBEUI (NetBIOS Extended User Interface) nicht mehr finden. Wenn Sie das Protokoll aber benötigen, können Sie es trotzdem installieren, da MS die benötigten Dateien auf der CD mitliefert.

NetBEUI installieren:

  1. Legen Sie die XP-CD ein und wechseln Sie in das Verzeichnis "Valueadd\MSFT\Net\NetBEUI".
  2. Kopieren Sie "Nbf.sys" in das "%SYSTEMROOT%\System32\Drivers" Verzeichnis.
  3. Kopieren Sie "Netnbf.inf" in das (versteckte) "%SYSTEMROOT%\Inf" Verzeichnis.
  4. Klicken Sie auf Start --> Systemsteuerung
  5. Doppelklicken Sie auf Netzwerkverbindungen.
  6. Klicken Sie mit der rechten Maustaste auf den Netzwerkadapter, dem Sie das NETBEUI-Protokoll hinzufügen möchten.
  7. Klicken Sie auf Eigenschaften.
  8. Auf der "Allgemein"-Seite klicken Sie auf "Installieren".
  9. Klicken Sie auf "Protokoll", dann auf "Hinzufügen".
  10. Wählen Sie das NetBEUI-Protokoll aus und bestätigen Sie dann mit OK.
  11. Starten Sie den Rechner neu, wenn Sie dazu aufgefordert werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=301041

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1255.htm


Nur Rechner innerhalb der Workgroup anzeigen

Mit diesem Tipp können Sie festlegen, dass in der Ansicht "Netzwerkumgebung" nur Rechner angezeigt werden, die sich in der gleichen Workgroup befinden.

Alle anderen Rechner werden nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ NetworkCrawler\ Objects\ WorkgroupCrawler

ändern Sie hier den Wert "WorkgroupOnly" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Nur Rechner aus der Workgroup anzeigen
0 | Alle Rechner anzeigen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2079.htm


Netzwerk Bridge konfigurieren

Mit diesen Funktionen können Sie die Netzwerk Bridge konfigurieren.

Was ist "Spanning Tree":

Der Spanning Tree-Algorithmus dient zur Vermeidung redundanter Netzwerkpfade (Schleifen) im LAN. In einem Netzwerk sollte zu jedem möglichen Ziel immer nur ein Pfad benutzt werden, um zu vermeiden, dass Datenpakete mehrfach am Ziel eintreffen, was die Leistung des Netzwerks vermindern kann. Es sollen aber trotzdem weitere Netzwerkpfade für den Fehlerfall zur Verfügung stehen, damit bei einem Ausfall der anderen Strecke, dass Netzwerk über den anderen Weg weiterhin benutzt werden kann. Das wird alles durch "Spanning Tree" sichergestellt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ BridgeMP

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableForwarding" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Forwarding ausschalten
0 | Forwarding einschalten (Standard)

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableSTA" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Spanning Tree" ausschalten
0 | "Spanning Tree" einschalten (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1605.htm


Anzeigen von Netzwerkverzeichnissen dauert sehr lange

Dauert bei Ihnen die Anzeige von Netzwerklaufwerken sehr lange, dann sollten Sie den Puffer erhöhen. Geben Sie hier einen größeren Wert ein (z.B.: 20000).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "SizReqBuf" als Datentyp REG_DWORD und legen Sie die Puffergröße zwischen 512 - 65535 als Dezimalwert fest (Standard: 4356).

Rechner neu starten oder nur den Netzwerkdienst stoppen und starten:

net stop server

net start server

Weitere Infos dazu finden Sie unter :

http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b177266

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1635.htm


Maximale Anzahl der Verbindungen ändern

Ab den Service Pack 2 gibt es von MS zwei Einschränkungen, die den Verbindungsaufbau beeinflussen. Diese Begrenzung wurden von MS eingebaut, um die Verbreitung von Viren zu bremsen. Leider haben diese Einstellung hat aber auch Auswirkung auf alle anderen laufenden Programme (P2P-Tauschbörsen, Download usw.).

1. Anzahl der Verbindungen im Wartezustand:

Verbindungen, die sich in einem Wartezustand befinden, wurden auf die maximale Anzahl vom 10 gleichzeitigen TCP/IP-Verbindungen begrenzt. Wird diese Grenze erreicht, wird ein Eintrag in der Form von: "EventID 4226: TCP/IP hat das Sicherheitslimit erreicht, das für die Anzahl gleichzeitiger TCP-Verbindungsversuche festgelegt wurde" in das Event-Log eingetragen.

Eine Verbindung befindet sich im Wartezustand, wenn sich eine Verbindung zu einem Server aufgebaut, der aber nicht antwortet. Wenn sich 10 Verbindungen in einem Wartezustand befinden, landen alle anderen Verbindungsversuche in eine Warteschlange (es wird also nicht versucht, diesen Server zu erreichen). Es können also keine weiteren Anfragen mehr zu anderen Servern gesendet werden.

Um diese Begrenzung zu umgehen, müssen Sie ein FIX auf Ihrem System einspielen. Dieses Fix führt eine Änderung an der Datei Tcpip.sys durch und erhöht die Zahl auf 50.

Homepage: http://www.lvllord.de/

Datei: Event ID 4226 Patcher (4226 fix)

2. Anzahl der parallelen Verbindungen:

Auch die Anzahl der parallelen Verbindungen (Ein- und Ausgehend) wurden insgesamt auf die Anzahl von 10begrenzt. Dieser Wert lag vorher standardmäßig bei 16.777.214 parallelen Verbindungen. Mit den folgenden Key können Sie diesen Wert wieder entsprechend erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Tcpip\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "TcpNumConnections" als Datentyp REG_DWORD und setzen Sie den Wert auf 0x00fffffe (16777214). Die zulässigen Werte liegen zwischen 0 - 0xffffe.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1687.htm


Windows Firewall-Einstellungen sichern

Wenn Sie die Firewall nach Ihren Wünschen konfiguriert haben, ist es nützlich, diese Einstellungen entsprechend zu sichern. So können Sie die Einstellungen nach einer Neuinstallation von Windows wieder einspielen oder auch auf anderen Rechnern entsprechend leicht überspielen.

Hier wird beschrieben, wie Sie die Einstellungen aus der Registry exportieren können. Starten Sie dafür den Registry-Editor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SharedAccess\ Parameters\ FirewallPolicy\ StandardProfile\ AuthorizedApplications\ List

werden die Einstellungen abgelegt, die in der Windows-Firewall unter "Ausnahmen" konfiguriert wurden.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SharedAccess\ Parameters\ FirewallPolicy\ StandardProfile\ GloballyOpenPorts\ List

werden die Einstellungen für die geöffneten Ports abgelegt.

Klicken Sie auf die jeweiligen Schlüssel und wählen Sie aus dem Menü "Datei" -> "Exportiert". Geben Sie hier einen beliebigen Dateinamen an und klicken Sie auf Speichern.

Wenn Sie die Einstellungen später wieder importieren wollen, müssen Sie nur im Explorer einen Doppelklick auf diese Datei ausführen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1995.htm


Seedserver festlegen

Info: XP ab SP2

Diese Einstellung legt den Seedserver auf einen bestimmten Knoten im Unternehmen fest. Diese Richtlinieneinstellung kann pro Bereich/Knoten (global, standort- und verbindungslokal) angewendet werden.

PNRP (Peer Name Resolution-Protokoll) ermöglicht verteilte Auflösung eines Namens in eine IPV6-Adresse und Portnummer. Das Protokoll benötigt in manchen Fällen einen Seedserver, um neu gestartet zu werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Peernet\ Pnrp\ [Bereich/Knoten]

Wählen Sie für [Bereich/Knoten] folgende Möglichkeiten aus:

Schlüsselname

Beschreibung

IPv6-Global

Globaler Knoten (Local Area Network)

In diesem Bereich der Richtlinieneinstellung wird ermöglicht, die Seedservereinstellungen in einer Weise zu konfigurieren, dass Benutzer von mobilen Geräten ihre Peer-zu-Peer-Anwendungen sowohl von zu Hause als auch vom Büro aus verwenden können.

Zu diesem Zweck kann die Richtlinieneinstellung aktiviert und auf eine IPv6-Adresse oder den DNS-Namen des Seedservers des Unternehmens festgelegt werden.

Optional kann ein Kontrollkästchen aktiviert werden, dass die Verwendung des globalen Seedservers deaktiviert und nur die Verwendung des internen Seedservers zulässt.

Diese Einstellung ist allerdings nicht zu empfehlen,

da sie verhindert, dass Benutzer von mobilen Geräten Peer-zu-Peer-Anwendungen außerhalb des Unternehmens nutzen können.

IPv6-SiteLocal

Lokaler Sitecloud (Personal Area Network)

In diesem Bereich kann der Administrator den Namen des Seedservers des Unternehmens angeben, wie im Vorfeld unter Globale Knoten erläutert.

IPv6-LinkLocal

Lokaler Linkcloud (Wild Area Network)

In diesem Bereich kann der Administrator den Namen des Seedservers des Unternehmens angeben, wie im Vorfeld unter Globale Knoten erläutert.

Da DNS in Wild Area Network nicht verfügbar ist, können nur IPv6-Adressen für diesen speziellen Bereich angegeben werden.

Erstellen Sie hier einen neuen Wert mit dem Namen "SeedServer" als Datentyp REG_SZ.

Nur für "Globaler Knoten (Local Area Network)":

Erstellen Sie hier einen neuen Wert mit dem Namen "DontIncludeMicrosoftSeedServer" als Datentyp REG_SZ. Setzen Sie den Wert auf:

1 | Globalen Microsoft-PNRP-Seedserver nicht verwenden
gelöscht | Globalen Microsoft-PNRP-Seedserver verwenden

Folgendes Einstellungskombinationen können Sie für "Globaler Knoten (Local Area Network)" durchführen:

SeedServer = leer

DontIncludeMicrosoftSeedServer = nicht angelegt

Der globaler bekannter Seedserver nur im Internet zu verwenden

SeedServer = leer

DontIncludeMicrosoftSeedServer = 1

Kein Seedserver ist zu verwenden.

SeedServer = "Wert"

DontIncludeMicrosoftSeedServer = nicht angelegt

"Wert" = Geben Sie den vollqualifizierten Domänennamen oder die IPv1-Adresse des Firmenseedservers bei "SeedServer" ein.

Firmen-Seedserver und der globale Seedserver werden verwendet. Diese Einstellung ermöglicht Benutzern mobiler Geräte, Peeranwendungen am Arbeitsplatz und zu Hause zu verwenden.

SeedServer = "Wert"

DontIncludeMicrosoftSeedServer = 1

"Wert" = Geben Sie den vollqualifizierten Domänennamen oder die IPv1-Adresse des Firmen-Seedservers bei "SeedServer" ein.

Nur ein Firmen-Seedserver wird verwenden. Wenn Sie nur ihn verwenden, können Benutzer mobiler Geräte ihre Peeranwendungen nicht von zu Hause aus verwenden.

Folgendes Einstellungskombinationen können Sie für "lokaler Sitecloud" und "lokaler Linkcloud" durchführen:

SeedServer = "Wert" | "Wert" = Geben Sie - durch ein Semikolon (;) - getrennt die Liste von IPV6-Adressen ein. Diese Einstellung legt den Seedserver für die lokale Linkcloud auf einen bestimmten Knoten im Unternehmen fest.
SeedServer = leer | Wenn Sie diese Einstellung aktivieren und keine Adresse eingeben, wird kein Seedserver verwendet.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Microsoft Peer-zu-Peer-Netzwerkdienste\Peer Name Resolution-Protokoll\ Globale Wolken Standortlokale Wolken Verbindungslokale Wolken
Einstellungsname: | Seedserver festlegen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2019.htm


Nach 'Join Domain' wird die GPO nicht geladen

Nach "Join Domain" wird die GPO nicht geladen

Wird ein Rechner in die Domäne gehangen, kann es vorkommen das die GPO (Group Policy Object) nicht mehr geladen wird. Dieser Fehler tritt oft auf, wenn die Zeit der Clients nicht mit der Zeit der Server übereinstimmt.

Entweder warten Sie eine kurze Zeit und starten dann den Rechner neu, oder führen Sie folgenden Befehle auf der Kommandozeile aus:

w32tm /config /update

w32tm /resync

Anschließend starten Sie den Rechner neu und die GPO sollte geladen werden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2037.htm


Windows XP Rechner werden nicht in der Netzwerkübersicht von Vista angezeigt

Wenn in einem Netzwerk Windows XP und Windows Vista Rechner benutzt werden, kann es dazu führen, dass die Rechner mit Windows XP nicht in der Netzwerkübersicht von Windows Vista angezeigt werden. Das liegt daran, dass Windows Vista über LLTD (Link-Layer Topology Discovery) arbeitet, um andere Rechner im Netzwerk zu finden.

Diese Komponente ist aber unter Windows XP nicht standardmäßig vorhanden und muss erst nachinstalliert werden.

  • Laden Sie dafür von der Microsoft Seite den Patch KB922120:
    Download: Link Layer Topology Discovery (LLTD) Responder (KB922120)
  • Installieren Sie diesen Patch auf den Windows XP Rechnern.Nach dem Neustart sollen die Rechner jetzt auch in der Netzwerkübersicht von Windows Vista auftauchen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2568.htm


Veröffentlichen von freigegebenen Ordner in der ADS zulassen

Mit diesem Wert können Sie festlegen, ob der Benutzer in Active Directory freigegebene Ordner veröffentlichen kann.

Wenn Sie diese Einstellung aktivieren oder sie nicht konfigurieren, können die Benutzer die Option Veröffentlichen in Active Directory" im Snap-In Freigegebene Ordner verwenden, um freigegebene Ordner in Active Directory zu veröffentlichen.

Wenn Sie diese Einstellung deaktivieren, kann der Benutzer freigegebene Ordner in Active Directory nicht veröffentlichen, und die Option "Veröffentlichen in Active Directory" ist deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ SharedFolders

Erstellen Sie hier einen neuen Wert mit dem Namen "PublishSharedFolders" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Freigegebene Ordner können veröffentlicht werden (Standard)
0 | Freigegebene Ordner können nicht veröffentlicht werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Freigegebene Ordner
Einstellungsname: | Veröffentlichung freigegebener Ordner zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1959.htm


Veröffentlichen von DFS-Stämmen in der ADS zulassen

Mit diesem Wert können Sie festlegen, ob der Benutzer in Active Directory DFS-Stämme veröffentlichen kann.

Wenn Sie diese Einstellung aktivieren oder sie nicht konfigurieren, können die Benutzer die Option "Veröffentlichen in Active Directory" verwenden, um DFS-Stämme als freigegebene Ordner in Active Directory zu veröffentlichen.

Wenn Sie diese Einstellung deaktivieren, kann der Benutzer DFS-Stämme in Active Directory nicht veröffentlichen, und die Option "Veröffentlichen in Active Directory" ist deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ SharedFolders

Erstellen Sie hier einen neuen Wert mit dem Namen "PublishDfsRoots" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | DFS-Stämme können veröffentlicht werden (Standard)
0 | DFS-Stamm können nicht veröffentlicht werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Freigegebene Ordner
Einstellungsname: | Veröffentlichung vom DFS-Stämmen zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1960.htm


Suchzeit für DFS-Clients nach Domänencontrollern konfigurieren

Mit diesem Tipp können Sie festlegen, wie oft ein DFS-Client (Client des verteilten Dateisystems) versucht, Domänencontroller im Netzwerk zu finden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ System\ DFSClient

Erstellen Sie hier einen neuen Wert mit dem Namen "DfsDcNameDelay" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

15-360 | Zeit in Minuten bis wieder nach einen Domänencontroller gesucht werden soll (Dezimal).
gelöscht | Es wird die Standardzeit von 15 Minuten verwendet

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk
Einstellungsname: | Festlegen, wie oft ein DFS-Client Domänencontroller sucht

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Standardmäßig versucht ein DFS-Client alle 15 Minuten Domänencontroller zu finden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1961.htm


Umbenennen von LAN-Verbindungen zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer ohne Administratorrechte eine LAN-Verbindung umbenennen können.

Wenn Sie diese Einstellung aktivieren, wird die Option "Umbenennen" für LAN-Verbindungen aktiviert. Benutzer ohne Administratorrechte können LAN-Verbindungen umbenennen, indem sie auf ein Symbol für die Verbindung klicken oder das Menü "Datei" verwenden.

Wenn Sie diese Einstellung deaktivieren, ist die Option "Umbenennen" nur für Benutzer ohne Administratorrechte deaktiviert.

Wenn Sie diese Einstellung nicht konfigurieren, können nur Administratoren und Netzwerkkonfigurations-Operatoren LAN-Verbindungen umbenennen.

Wenn der Tipp "Umbenennen von LAN/RAS-Verbindungen zulassen" konfiguriert ist (entweder aktiviert oder deaktiviert), gilt diese Einstellung nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RenameLanConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Umbennen von LAN-Verbindungen zulassen
0 | Umbennen von LAN-Verbindungen sperren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Umbenennen von LAN-Verbindungen zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1988.htm


Umbenennen von RAS-Verbindungen zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer ohne Administratorrechte für alle Benutzer gültige RAS-Verbindungen umbenennen können.

Um eine für alle Benutzer gültige RAS-Verbindung zu erstellen, klicken Sie im Assistenten für neue Verbindungen auf der Registerkarte "Verfügbarkeit der Verbindung" auf die Option "Für alle Benutzer".

Wenn Sie diese Einstellung aktivieren, ist die Option "Umbenennen" für die für alle Benutzer gültigen RAS-Verbindungen aktiviert. Jeder Benutzer kann für alle Benutzer gültige Verbindungen umbenennen, indem er auf ein Symbol für die Verbindung klickt oder das Menü "Datei" verwendet.

Wenn Sie diese Einstellung deaktivieren, ist die Option "Umbenennen" nur für Benutzer ohne Administratorrechte deaktiviert.

Wenn Sie diese Einstellung nicht konfigurieren, können nur Administratoren und Netzwerkkonfigurations-Operatoren für alle Benutzer gültige RAS-Verbindungen umbenennen.

Wenn die Tipp "Umbenennen von LAN/RAS-Verbindungen zulassen" konfiguriert ist (entweder aktiviert oder deaktiviert), gilt diese Einstellung nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Network Connections

Erstellen Sie hier einen neuen Wert mit dem Namen "NC_RenameAllUserRasConnection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Umbennen von RAS-Verbindungen zulassen
0 | Umbennen von RAS-Verbindungen sperren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen
Einstellungsname: | Umbenennen von für alle Benutzer gültigen RAS-Verbindungen zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1989.htm


Peer-to-Peer Nertzwerkdienste deaktivieren

Info: XP ab SP2

Diese Einstellung deaktiviert die Microsoft Peer-to-Peer-Netzwerkdienste, wodurch alle abhängigen Anwendungen ebenfalls beendet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Peernet

Erstellen Sie hier einen neuen Wert mit dem Namen "Disabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Peer-to-Peer Protokolle deaktivieren
gelöscht | Peer-to-Peer Protokolle sind aktiv

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Microsoft Peer-zu-Peer-Netzwerkdienste
Einstellungsname: | Microsoft Peer-zu-Peer-Netzwerkdienste deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2018.htm


XP telefoniert 'nach Hause'

Zahlreiche Programme unter Windows XP verbinden sich ohne Ihr Wissen mit Servern im Internet, um Daten auszutauschen. Mit dem Programm XP Antispy von www.xp-antispy.orgkönnen Sie dieses Verhalten recht einfach ändern.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1239.htm


Bandbreite bei DSL freigeben

Ab Windows XP wird bei Netzwerkverbindungen der neue Dienst Quality of Service (QoS) eingesetzt, der aber bei DSL-Verbindungen keinen Sinn macht, aber 20% der Bandbreite beansprucht.

Wenn Sie diese Funktion ausschalten wollen, gehen Sie folgendermaßen vor:

Starten Sie die lokale Gruppenrichtline (Start -> Ausführen -> gpedit.msc) und gehen Sie hier nach:

“Computerkonfiguration“ -> „Administrative Vorlagen“ -> „Netzwerk“ -> „QoS-Paketplaner“.

Setzen Sie die Einstellung von „Reservierbare Bandbreite einschränken“ auf 'Aktiviert'.

Geben Sie als Wert 0% ein .bzw. in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Psched\

Erstellen Sie hier einen neuen Wert mit dem Namen "NonBestEffortLimit" als Datentyp REG_DWORD. Setzen Sie den Wert auf die gewünschte Bandbreite von 0-100. (Gibt das Bandbreitenlimit in % an).

Um die Funktion auszuschalten setzen Sie den Wert auf 0.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\QoS-Paketplaner
Einstellungsname: | Reservierbare Bandbreite einschränken

Info Wenn ein Bandbreitenlimit in der Registrierung für einen speziellen Netzwerkadapter festgelegt ist, wird diese Einstellung beim Konfigurieren dieses Netzwerkadapters ignoriert.

Info Bei Windows XP Home gibt es diese Funktion nicht, so das Sie hier auch nichts deaktivieren müssen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1384.htm


Welche Ports werden von welchem Programm belegt

Mit den Programm "netstat" können Sie sich eine Liste ausgeben lassen, in der alle benutzen Ports sowie die dazugehörigen Protokolle und eine PID-Nummer aufgelistet werden. Geben Sie dazu folgendes ein:

netstat -ano

Anhand der PID-Nummer können Sie nun herausfinden, welches Programm einen bestimmten Port benutzt. Öffnen Sie dazu den Taskmanager. Hier finden Sie unter den Tabreiter "Prozesse" eine Liste aller aktiven Prozesse. Sie können sich auch die PID-Nummer anzeigen lassen. Wird sie bei Ihnen nicht angezeigt, können Sie sie mit der Option "Ansichten" -> "Spalten hinzufügen" hinzufügen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1332.htm


Speichern von .NET Passwörtern unterbinden

Mit diesem Tipp können Sie einstellen, dass keine .NET Passwörter mehr auf dem lokalen System gespeichert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Lsa

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDomainCreds" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Passwörter speichern
0 | Passwörter speichern (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1628.htm


Windows XP-Home: Administrator-Account absichern

in der Home-Version von Windows XP hat Microsoft versäumt für den Administrator-Account ein Passwort zu vergeben. Dadurch kann man sich über diesen Account ohne Passwort am Rechner anmelden oder über das Netzwerk auf entsprechende Ressourcen zugreifen.

Über die Kommandozeile können Sie für dieses Konto ein Passwort vergeben und dadurch diese Sicherheitslücke schließen.

net user Administrator <Kennwort>

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2008.htm


Aufrufen von Anwendungen aus der Online-Hilfe unterbinden

Wenn man die Onlinehilfe öffnet, hat man hier die Möglichkeit, einige Anwendung zu starten. Mit dieser Policy können Sie angeben, welche Anwendungen nicht gestartet werden können. Dabei müssen Sie die Namen der Anwendungen - mit Komma getrennt - eingeben ( z.B.: cmd.exe,mmc.exe).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableInHelp" als Datentyp REG_SZ. Geben Sie die Namen der Anwendungen - durch ein Komma getrennt - ein.

Diese Einstellung kann unter HKLM und HKCU vorgenommen werden. Wenn die Einstellungen in beiden vorgenommen wurde, werden die Listen zusammengeführt und alle angegebenen Programme werden gesperrt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Ausführung aus der Hilfe für folgende Programme nicht zulassen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1468.htm


Windows XP fügt die Administratorengruppe den Besitzern hinzu

Bei Windows XP werden bei der Erstellung einer Datei oder eines Ordners die Administratoren automatisch zu den Besitzern hinzugefügt (Ownership).

Will man das verhindern, muss man folgenden Registry-Schlüssel anlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

erstellen Sie einen neuen Eintrag mit dem Namen "NoDefaultAdminOwner" als Datentyp REG_DWORD. Setzen Sie den Wert auf 0.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1318.htm


Berechtigungen in der Windows XP Home Edition

In der Windows XP Home Edition finden Sie keine Möglichkeit, NTFS-Berechtigungen zu setzen. Auch gibt es bei Netzwerkfreigaben keine Möglichkeit, Berechtigungen auf die Netzwerkfreigabe zu vergeben. Dafür müssen Sie lt. MS auf die Professional Version von Windows XP zurückgreifen.

Diese Funktionen wurden von MS nur ausgeblendet und stehen noch zur Verfügung. Sie haben mehrere Möglichkeiten, Berechtigungen zu vergeben:

  1. Sie können mit dem Kommandozeilentool CACLS.EXE arbeiten. Mit diesem Programm können Sie Berechtigungen auf NTFS-Partitionen setzen. Für ausführliche Informationen starten Sie CACLS /?
  2. NTFS-Dateiberechtigungen lassen sich unter XP Home mit WINFILE.EXE von NT4 einfach bearbeiten (alternative zu CACLS.EXE).
  3. Wenn Sie Windows im Abgesicherten-Modus (mit Netzwerkkartentreiber) starten, sind auch die Original Menüpunkte im Explorer wieder da. Jetzt können Sie wieder wie gewohnt Berechtigungen vergeben. Diese Einstellungen bleiben auch nach einem Neustart erhalten.

Dies funktioniert aber nur, wenn man den Punkt "Einfache Dateifreigabe" unter
Arbeitsplatz --> Extras --> Ordneroptionen --> Ansicht nicht aktiviert.

Standardmäßig ist diese Option aktiviert, sofern der Rechner nicht einer Domäne angehört.

Info Weitere Infos dazu im Tipp: "Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1267.htm


Verschlüsselte Daten nach einer bestimmten Zeit aus dem Speicher entfernen

Mit diesem Tipp können Sie festlegen, nach welchem Zeitraum Windows automatisch verschlüsselte Daten aus dem Speicher entfernen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ EFS

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ EFS

Erstellen Sie hier einen neuen Wert mit dem Namen "KeyCacheValidationPeriod" als Datentyp REG_DWORD. Geben Sie hier die Zeit in Sekunden an, wie lange solche Dateien im Speicher bleiben dürfen.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1592.htm


Geschützten Modus für Schellprotokoll deaktivieren

Info: XP ab SP2

Dieser Tipp ermöglicht die Konfiguration der Funktionalität des Shellprotokolls. Wenn die vollständige Funktionalität dieses Protokolls verwendet wird, können Anwendungen Ordner öffnen und Dateien starten.

Durch den geschützten Modus wird die Funktionalität dieses Protokolls reduziert, wodurch Anwendungen nur einen eingeschränkten Satz an Ordnern öffnen können. Anwendungen können keine Dateien öffnen, wenn dieses Protokoll im geschützten Modus ist. Es wird empfohlen, dieses Protokoll im geschützten Modus zu lassen, um die Sicherheit von Windows zu erhöhen.

Wenn Sie diesen Tipp aktivieren, wird das Protokoll vollständig aktiviert, wodurch das Öffnen von Ordnern und Dateien ermöglicht wird.

Wenn Sie diesen Tipp deaktivieren, ist dieses Protokoll im geschützten Modus, wodurch Anwendungen nur einen eingeschränkten Satz an Ordnern öffnen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreXPSP2ShellProtocolBehavior" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Der geschützte Modus ist deaktiviert
gelöscht | Der geschützte Modus ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Geschützten Modus für Schellprotokoll deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1910.htm


Dialogbox 'Datei öffnen Sicherheitswarnung' kommt beim Öffnen von Dateien

Info: XP ab SP2

Wird eine Datei, die von einem Server heruntergeladen wurde oder eine Datei aus dem Internet aufgerufen, erscheint die Dialogbox "Datei öffnen - Sicherheistwarnung".

Sie müssen jetzt erst diese Sicherheitswarnung bestätigen, um mit der Datei arbeiten zu können.

Diese Sicherheitsüberprüfung AES (Attachment Execution Services) hat MS ab Windows XP SP2 eingebaut. Dabei prüft die AES, ob es für die Dateiendung eine entsprechende Regel gibt, liegen keine Regel und/oder kein Zertifikat vor, wird dieses Sicherheitsmeldung angezeigt. Sie müssen selber entscheiden, wie mit der Datei umgegangen werden soll.

Über die Registry kann diese Sicherheitsrichtline konfiguriert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Associations

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Associations

Erstellen Sie hier einen neuen Wert mit dem Namen "DefaultFileTypeRisk" als Datentyp REG_DWORD.

Setzen Sie den Wert auf (Dezimal):

6150

Hohes Risiko

Falls die Dateianlage in der Liste der Dateitypen mit hohem Risiko aufgeführt ist und aus einer eingeschränkten Zone stammt, werden Benutzer von Windows daran gehindert, auf die Datei zuzugreifen. Falls die Datei aus der Internetzone stammt, wird der Benutzer zum Bestätigen aufgefordert, bevor er auf die Datei zugreifen kann

Folgende Dateitypen werden in diese Gruppe eingestuft:

.ade,.adp,.app,.asp,.bas,.bat,.cer,.chm,.cmd,.com,.cpl,.crt,.csh,.exe,.fxp,.hlp,.hta,.inf,.ins,.isp,.its,.js,.jse,.ksh,.lnk,.mad,.maf,.mag,.mam,.maq,.mar,.mas,.mat,.mau,.mav,.maw,.mda,.mdb,.mde,.mdt,.mdw,.mdz,.msc,.msi,.msp,.mst,.ops,.pcd,.pif,.prf,.prg,.pst,.reg,.scf,.scr,.sct,.shb,.shs,.tmp,.url,.vb,.vbe,.vbs,.vsmacros,.vss,.vst,.vsw,.ws,.wsc,.wsf,.wsh

6151

Mittleres Risiko(Standard)

Falls die Dateianlage in der Liste der Dateitypen mit mittlerem Risiko aufgeführt ist und aus einer eingeschränkten oder der Internetzone stammt, wird der Benutzer zum Bestätigen aufgefordert, bevor er auf die Datei zugreifen kann.

Alle Dateitypen die nicht unter "Hohes Risiko" oder "Niedriges Risiko" aufgeführt werden, fallen unter diese Gruppe.

6152

Niedriges Risiko

Falls die Dateianlage in der Liste der Dateitypen mit niedrigem Risiko aufgeführt ist, wird der Benutzer nicht zum Bestätigen aufgefordert, bevor er auf die Datei zugreifen kann, unabhängig von der Zoneninformation der Datei.

Folgende Dateitypen werden in diese Gruppe eingestuft:

.log,.text,.txt (und die Dateitypen: .bmp,.dib,.emf,.gif,.ico,.jfif,.jpg,.jpe,.jpeg,.png,.tif,.tiff,.wmf nur, wenn sie mit dem Programm "Microsoft Windows Bild- und Faxanzeige" geöffnet werden)

Anschließend müssen Sie noch für die entsprechende Sicherheitszone die Dateiendungen konfigurieren (falls Sie mit dem oberen Standard von Microsoft nicht zufrieden sind). Erstellen Sie dafür zusätzlich unter den oben angegebenen Schlüssel die gewünschten Werte jeweils als Datentyp REG_SZ und geben Sie hier die Dateiendungen an.

HighRiskFileTypes

Dateianlage hohes Risiko

Diese Aufnahmeliste hat Vorrang vor den Aufnahmelisten für Dateianlagen mit mittlerem und niedrigen Risiko (falls eine Dateierweiterung in mehreren Listen aufgeführt ist.)

Beispiel: .com;.exe;.doc

ModRiskFileTypes

Dateianlage mittleres Risiko(Standard)

Diese Aufnahmeliste setzt die in Windows vordefinierte Liste der Dateitypen mit hohem Risiko außer Kraft. Allerdings hat die Aufnahmeliste für Dateitypen mit hohem Risiko Vorrang vor der Aufnahmeliste für Dateianlagen mit mittlerem Risiko.

Aber die Aufnahmeliste für Dateitypen mit mittlerem Risiko hat wiederum Vorrang vor der Aufnahmeliste für Dateianlagen mit niedrigem Risiko (falls eine Dateierweiterung in mehreren Listen aufgeführt ist.)

Beispiel: .com;.exe;.doc

LowRiskFileTypes

Dateianlage niedriges Risiko

Diese Aufnahmeliste setzt die in Windows vordefinierte Liste der Dateitypen mit hohem Risiko außer Kraft. Allerdings haben die Aufnahmelisten für Dateitypen mit hohem und mittlerem Risiko Vorrang vor der Aufnahmeliste für Dateianlagen mit niedrigen Risiko (falls eine Dateierweiterung in mehreren Listen aufgeführt ist.)

Beispiel: .com;.exe;.do

Sind die Einträge nicht vorhanden, wird die in Windows vordefinierte Liste der Dateitypen verwendet.

Info Die Dateierweiterungen immer mit Punkt (.) eingeben; bei mehreren Dateitypen immer mit einem Strichpunkt (;) trennen (Beispiel: .com;.exe;.doc).

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anlagen-Manager
Einstellungsname: | Info: In der MMC wurden diese Einstellungen auf mehreren Seiten aufgeteilt: DefaultFileTypeRisk: Standardrisikostufe für Dateianlagen HighRiskFileTypes: Aufnahmeliste für Dateitypen mit hohem Risiko ModRiskFileTypes: Aufnahmeliste für Dateitypen mit mittlerem Risiko LowRiskFileTypes: Aufnahmeliste für Dateitypen mit niedrigem Risiko

Konfiguration der Internetzone

Rechner aus fremden Netzwerken:

Die Konfiguration der Internetzonen müssen Sie im Internetexplorer unter "Internetoptionen" -> "Sicherheit" -> "Vertrauenswürdige Sites" -> "Sites" vornehmen. Dort können Sie die Server mit einer IP hinzufügen.

Rechner aus eigenem Netzwerk:

Die Konfiguration der Internetzonen müssen Sie im Internetexplorer unter "Internetoptionen" -> "Sicherheit" -> "Lokales Intranet" -> "Sites" -> "Erweitert" vornehmen. Dort können Sie die Server mit einer IP hinzufügen.

Info Damit eine IP-Adresse hinzugefügt werden kann, muss das Häkchen "Für Sites dieser Zone ist einer Serverüberprüfung (https:) erforderlich" entfernt werden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=883260.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1911.htm


Bewertung von Dateianlagen konfigurieren

Info: XP ab SP2

Windows XP verfügt ab Service Pack 2 über den Attachment Execute Service (Anhang-Ausführungsdienst), dessen übergeordnetes Ziel es ist, Benutzern die Möglichkeit zu bieten, Dateien sicher auszutauschen.

Mit diesem Tipp können Sie fetslegen, wie Windows zum Ermitteln von Risiken bei Dateianlagen (z.B. in Outlook) vorgehen soll. Sie können hier also einstellen, ob Windows sich nach dem Dateityp (Dateiendung z.B. .txt, .doc), oder nach dem Dateihandler (mit dem eine Datei geöffnet werden soll wie z.B. notepad, Word) richten soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Attachments

Erstellen Sie einen neuen Wert mit dem Namen "UseTrustedHandlers" als Datentyp REG_DWORD. Setzen Sie den Wert auf (Hexadezimal) :

1 | Dateitypen bevorzugen
2 | Dateihandler bevorzugen
3 | Dateihandler und -typ überprüfen (Standard)

Diese Einstellungen haben folgende Bedeutung:

Dateihandler bevorzugen (1):

Hier richtet sich Windows nur nach dem Dateihandler und nicht nach dem Dateityp. Somit wird auf notepad.exe vertraut, aber damit nicht generell alle .txt-Dateien. Alle Dateien, die als Handler 'notepad.exe' haben, können geöffnet werden, egal welche Dateiendung sie besitzen.

Dateitypen bevorzugen (2):

Hier geht Windows anhand des Dateityps vor. Somit wird generell den .txt-Dateien vertraut unabhängig vom spezifischen Dateihandler der Datei.

Dateihandler und -typ überprüfen (3):

Hier werden Beide überprüft, und nur dann wird den Dateien vertraut.

Standardmäßig verwendet Windows die eingeschränktere Empfehlung, was dazu führt, dass Benutzern mehr Vertrauensaufforderungen angezeigt werden als wenn eine weniger eingeschränkte Option ausgewählt wird.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anlagen-Manager
Einstellungsname: | Vertrauenslogik für Dateianlagen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu im Tipp: Dialogbox "Datei öffnen Sicherheitswarnung" kommt beim öffnen von Dateien

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1913.htm


Zoneninformationen in Dateianlagen nicht speichern

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob Windows die Zoneninformationen in Dateianlagen mit speichern soll.

Standardmäßig speichert Windows zusätzlich zu den Dateien in einem Stream die Zoneninformationen (ZoneIDs) (z.B.: Internet, Intranet, lokal usw.). Windows kann Risiken nicht ordnungsgemäß bewerten, wenn die Zoneninformationen nicht vorhanden sind.

Info Info:Diese Informationen werden nur auf NTFS-Laufwerken gespeichert. Werden solche Dateien auf FAT bzw. von NTFS auf FAT-Laufwerke kopiert, gehen diese Informationen verlohren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Attachments

Erstellen Sie hier einen neuen Wert mit dem Namen "SaveZoneInformation" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zoneninformationen nicht speichern
2 | Zoneninformationen speichern (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anlagen-Manager
Einstellungsname: | Zoneninformationen in Dateianlagen nicht beibehalten

Als Alternative können Sie über eine Umgebungsvariable auch einstellen, dass Windows keine Warnmeldung ausgeben soll.

Die Zoneninformationen werden aber weiterhin in der Datei gespeichert. Dadurch können Sie die Funktion auch leicht wieder aktivieren.

Damit keine Warnmeldung mehr angezeigt wird, erstellen Sie eine neue Umgebungsvariable mit den Namen:

"SEE_MASK_NOZONECHECKS" und setzen Sie den Wert auf 1.

Um so eine Variable zu setzen, gehen Sie folgendermaßen vor: "Start" -> "Einstellungen" -> "Systemsteuerung" -> "System" hier auf den Tabreiter "Erweitert" wechseln und auf den Button "Umgebungsvariablen" klicken. Dort können Sie jetzt unter "Benutzervariablen" oder "Systemvariablen" über den Button "Neu" die Variablen anlegen.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu im Tipp: Dialogbox "Datei öffnen Sicherheitswarnung" kommt beim öffnen von Dateien.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1914.htm


Entfernen der Zoneninformationen nicht zulassen

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob ein Anwender die Zoneninformationen entfernen kann.

Standardmäßig speichert Windows zusätzlich zu den Dateien in einem Stream die Zoneninformationen (ZoneIDs) ab. Windows kann Risiken nicht ordnungsgemäß bewerten, wenn diese Zoneninformationen nicht vorhanden sind.

Standardmäßig kann der Anwender in der Dialogbox "Datei öffnen - Sicherheistwarnung" über das Kontrollkästchen "Vor dem Öffnen dieser Datei immer bestätigen"

bzw. über rechte Maustaste aus dem Kontextmenü "Eigenschaften" unter dem Tabreiter "Allgemein" über den Button "Zulassen" diese Zoneninformationen entfernen.

Wenn Sie diesen Tipp aktivieren, werden diesen Funktionen ausgeblendet und somit kann der Anwender die Zoneninformationen nicht entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Attachments

Erstellen Sie hier einen neuen Wert mit dem Namen "HideZoneInfoOnProperties" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Zoneninformationen können nicht entfernt werden
0 | Zoneninformationen können entfernt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anlagen-Manager
Einstellungsname: | Mechanismus zum Entfernen von Zoneninformationen ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu im Tipp: Dialogbox "Datei öffnen Sicherheitswarnung" kommt beim öffnen von Dateien

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1916.htm


Antivirenprogramme beim Öffnen von Anlagen benachrichtigen

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob die Antivirenprogramme benachrichtigt werden sollen, wenn Anlagen (Streams) geöffnet werden.

Standardmäßig öffnet Windows die Anlagen einfach, ohne ein Antivirenprogramm zu benachrichtigen. Wenn Sie den Tipp aktivieren, senden Windows vor dem Öffnen der Anlagen eine Benachrichtigung an alle registrierten Antivirenprogramme. Diese überprüfen die Dateianlage. Falls diese Überprüfung fehlschlägt, wird die Anlage blockiert und nicht geöffnet.

Wenn die Dateien schon beim Zugriff automatisch durch die Virensoftware geprüft werden, brauchen Sie diese Funktion nicht zu aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Attachments

Erstellen Sie hier einen neuen Wert mit dem Namen "ScanWithAntiVirus" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

2 | Antivirenprogramme benachrichtigen
1 | Antivirenprogramme werden nicht benachrichtigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anlagen-Manager
Einstellungsname: | Antivirenprogramme beim Öffnen von Anlagen benachrichtigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu im Tipp: Dialogbox "Datei öffnen Sicherheitswarnung" kommt beim öffnen von Dateien

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1917.htm


Sicherheitscenter für Domänenrechner aktivieren

Mit diesem Tipp können Sie einstellen, ob das Sicherheitscenter aktiviert oder deaktiviert ist. Diese Einstellung kann nur für Rechte, die Mitglied einer Active Directory-Domäne sind, gemacht werden.

Wenn das Sicherheitscenter aktiviert ist, überwacht es wichtige Sicherheitseinstellungen (Firewall, Antivirusprogramme und automatische Updates) und benachrichtigt den Benutzer, wenn ein Sicherheitsrisiko besteht. Die Systemsteuerungsoption "Sicherheitscenter" in der Kategorieansicht enthält außerdem einen Statusabschnitt, auf dem Benutzern, Empfehlungen angezeigt werden, wie sie die Sicherheit ihres Computern verstärken können. Wenn das Sicherheitscenter deaktiviert ist, werden weder Benachrichtigungen noch der Statusabschnitt angezeigt.

Standardmäßig ist das Sicherheitscenter auf Rechnern einer Domäne deaktiviert

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Security Center

Erstellen Sie hier einen neuen Wert mit dem Namen "SecurityCenterInDomain" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Sicherheitscenter aktivieren
0 | Sicherheitscenter deaktivieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherheitscenter
Einstellungsname: | Sicherheitscenter aktivieren (nur Domänencomputer)

Siehe auch: Benachrichtigungen vom Windows Sicherheitscenter deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Das Sicherheitscenter kann auf Computern, die nicht Mitglied einer Windows-Domäne sind, nicht deaktiviert werden, und diese Richtlinieneinstellung hat in diesem Fall keine Auswirkungen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1925.htm


Die Windows-Firewall konfigurieren

Info: XP ab SP2

In der Systemsteuerung finden Sie den Eintrag "Windows-Firewall", womit Sie die Einstellungen der Firewall anpassen können.

Diese Einstellungen können Sie auch über die Registry durchführen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SharedAccess\ Parameters\ FirewallPolicy\

bzw. als Policy:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsFirewall\

hier finden Sie zwei Schlüssel. Die EInstellungen unterhalb dieser Schlüssel sind identisch, durch die Aufteilung können Sie aber die Firewall unterschiedlich einstellen.

DomainProfile | Definiert die Firewall Einstellung, wenn sich der Rechner in einer Domäne befindet
StandardProfile | Definiert die Firewall Einstellung, wenn sich der Rechner außerhalb einer Domäne befindet.

Wenn Sie die Einstellung verändern wollen, wenn sich der Rechner nicht in einer Domäne befindet, gehen Sie also in den folgenden Registryschlüssel:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SharedAccess\ Parameters\ FirewallPolicy\ StandardProfile

bzw. als Policy:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsFirewall\ StandardProfile

Hier können Sie jetzt mit den folgenden Einträgen als Datentyp REG_DWORD die Firewall konfigurieren:

EnableFirewall | 0 -> Schaltet die Firewall aus, es wird kein Netzwerkverkehr gefiltert. 1 -> Schaltet die Firewall an
DoNotAllowExceptions | 0 -> Die Ausnahmeliste wird beachtet, alles andere wird blockiert 1 -> Auch die Programme aus der Ausnahmeliste werden blockiert
DisableNotifications | Benachrichtigung für ein Programm, das noch nicht in der Ausnahmeliste der Windows-Firewall enthalten ist und sich selbst über die Windows-Firewall-APIs zur Ausnahmeliste hinzufügen will. 0 -> Benachrichtigung aktiv 1 -> Keine Benachrichtigung

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Ja
Benutzerkonfiguration: | Nein
Pfad: | Administrative Vorlagen\Netzwerk\Netzwerkverbindungen\Windows-Firewall\Domänenprofil oder: Administrative Vorlagen\Netzwerk\Netzwerkverbindungen\Windows-Firewall\Standardprofil
Einstellungsname: | Info: In der MMC wurden diese Einstellungen auf mehreren Seiten aufgeteilt: EnableFirewall: Windows-Firewall: Alle Netzwerkverbindungen schützen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2034.htm


Überwachung des Windows-Sicherheitscenters konfigurieren

Mit diesem Tipp können Sie die Überwachung des Windows-Sicherheitscenter für die folgenden Komponenten ausschalten:

- Firewall

- Virenschutz

ab Windows Vista:

AntySpyware

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Security Center

Ab Windows Vista unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Security Center\ Svc

ändern Sie hier den Wert "FirewallOverride" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Firewall Überwachung ausschalten
0 | Firewall Überwachung aktivieren

ändern Sie hier den Wert "AntiVirusOverride" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Virenscanner Überwachung ausschalten
0 | Virenscanner Überwachung aktivieren

Ab Windows Vista gibt es noch zusätzlich:

ändern Sie hier den Wert "AntiSpywareOverride" als Datentyp REG_DWORD und setzen Sie den Wert auf:

1 | Antispyware Überwachung ausschalten
0 | Antispyware Überwachung aktivieren

Info Siehe dazu auch Tipp: "Benachrichtigungen vom Windows Sicherheitscenter deaktivieren"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2121.htm


Meldungen des Windows-Sicherheitscenters konfigurieren

Das Windows-Sicherheitscenter gibt Meldungen aus, wenn sich Änderungen an einer der folgenden 3 Komponenten ergeben:

  • Firewall
  • Virenschutz
  • Windows Update

Mit diesem Tipp können Sie die Meldungen aus-/einschalten

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Security Center

ändern Sie hier den Wert "AntiVirusDisableNotify" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Meldungen für Virenschutz ausschalten
0 | Meldungen für Virenschutz aktivieren

ändern Sie hier den Wert "UpdatesDisableNotify" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Meldungen für Updates ausschalten
0 | Meldungen für Updates aktivieren

ändern Sie hier den Wert "FirewallDisableNotify" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Meldungen für die Firewall ausschalten
0 | Meldungen für die Firewall aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2122.htm


Verschlüsselung für Anmeldung ausschalten (NT/Samba)

Mit diesem Wert können Sie die erzwungene Signierung/Verschlüsselung für die Anmeldung an einer Domäne abschalten. Gebraucht wird das für die Anmeldung an eine NT Domäne oder einer älteren Version von Samba (Linux).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Netlogon\ Parameters

ändern Sie hier den Wert "RequireSignOrSeal" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Verschlüsselung abschalten
1 | Verschlüsselung aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2130.htm


Datenausführungs-Verhinderung (DEP)

Was ist die Datenausführungs-Verhinderung?

Die Datenausführungs-Verhinderung kurz DEP (Data Execution Prevention) ist eine Sicherheitsfunktion, welche ab Windows XP mit Service Pack 2 (SP2) vorhanden ist. Über DEP werden Programme bei der Ausführung überwacht, um sicherzustellen, dass Sie auf die Speicherbereiche sauber zugreifen. Wenn ein Programm versucht, Programmcodes auf eine nicht erlaubte Weise aufzurufen bzw. darauf zuzugreifen, wird das Programm durch DEP beendet.

Dabei kann es vorkommen, dass durch DEP auch "erlaubte" Programme mit einen "stop error" beendet werden.

DEP läuft im Software- und Hardwaremodus. Damit DEP auch im Hardwaremodus laufen kann, muss diese Funktion von Ihrem Prozessor unterstützt werden (XD bei Intel und NX bei AMD stehen für die DEP-Unterstützung). Wenn der Prozessor kein DEP unterstützt, läuft DEP nur im Softwaremodus, und es steht kein Hardwaremodus zur Verfügung, wodurch DEP unter Umständen leichter umgangen werden kann.

DEP wird per Standard automatisch auf allen 64-Bit Systemen aktiviert, bei 32-Bit-Systemen muss die DEP-Funktion händisch aktiviert werden.

Leider bringt DEP auch eigene Probleme mit sich:

  • Programme, die Sie benutzen möchten, führen zu einen "stop-error"
    Lösung: Programm aus der DEP-Überwachung entfernen
  • Unerwartetes Beenden des Windows Explorer
    Lösung: DEP beenden
  • Löschen von Dateien über das Kontextmenü nicht möglich (Explore-Absturz)
    Lösung: Verschieben über den Papierkorb bzw. Programm aus der DEP-Überwachung entfernen.

Programme aus der DEP-Überwachung entfernen

Bei allen 32-Bit Systemen haben Sie die Möglichkeit, eine OptOut- oder OptIn-Liste zu erstellen.

Bei 64-Bit Systemen ist das nicht möglich, da hier die DEP-Funktion immer aktiv ist.

Wenn Sie eine OptOut-Liste (Ausnahmeliste) erstellen, werden nur diejenigen Programme nicht von DEP überwacht, welche sich in der Liste befinden.

Wenn Sie eine OptIn-Liste (Überwachungsliste) erstellen, werden nur diejenigen Programme von DEP überwacht, welche in der Liste angegeben wurden.

Die Einstellungen dafür finden Sie unter:

Windows 2000:

Starten Sie aus der Systemsteuerung den Eintrag 'System' und wählen den Tabreiter "Erweitert" aus. Anschließend klicken Sie in der Gruppe "Leistung" auf den Button "Einstellungen...". Wechseln Sie im neuen Fenster "Leistungsoptionen" auf den Tabreiter "Datenausführungsverhinderung".

Ab Windows Vista:

Starten Sie aus der Systemsteuerung den Eintrag 'System' und wählen aus dem linken Menü den Eintrag "Erweiterte Systemeinstellungen". Klicken Sie hier unter dem Tabreiter "Erweitert" in der Gruppe "Leistung" auf den Button "Einstellungen...". Wechseln Sie im neuen Fenster "Leistungsoptionen auf den Tabreiter "Datenausführungsverhinderung".

Hier können Sie jetzt wählen zwischen

  • "Datenausführungsverhinderung nur für erforderliche Windows-Programme und -Dienste einschalten"
  • "Datenausführungsverhinderung für alle Programme und Dienste mit Ausnahme der ausgewählten einschalten:".

Wenn Sie das Letzte auswählen, arbeiten Sie mit den OptOut- und OptIn-Listen und können über die Button "Hinzufügen" bzw. "Entfernen" die Liste der Ausnahmen bearbeiten.

Fügen Sie dazu über "Hinzufügen" die entsprechenden Anwendungen in die Liste hinzu. Vor jeder Anwendung in der Liste wird ein Kontrollkästchen eingefügt, womit Sie jetzt Folgendes einstellen können:

  • Kontrollkästchen aktivieren (OptOut-Liste):
    Die Datenausführungsverhinderung wird für das Programm deaktiviert
  • Kontrollkästchen deaktivieren (OptIn-Liste):
    Die Datenausführungsverhinderung wird für das Programm aktiviert

Diese Einstellungen werden in die Registry von Windows eingetragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Die Auswahl, ob mit der Ausnahmeliste gearbeitet werden soll, finden Sie unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ AppCompatFlags\ NoExecuteState

Hier befindet sich der Wert mit dem Namen "LastNoExecuteRadioButtonState" als Datentyp REG_DWORD. Setzen Sie den Wert alternativ auf:

36bc | Datenausführungs-Verhinderung nur für erforderliche Windows-Programme/-Dienste einschalten
36BD | Datenausführungs-Verhinderung für alle Programme und Dienste einschalten- mit Ausnahme der ausgewählten

Die Liste der eingetragenen Programme finden Sie unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ AppCompatFlags\ Layers

Hier finden Sie für jeden Eintrag in der Liste einen Eintrag als Datentyp REG_SZ, wobei der Name gleich Pfad und Dateiname der Datei ist und als Wert "DisableNXShowUI" oder "EnableNXShowUI" gültige Einträge darstellen und folgende Bedeutung haben:

  • DisableNXShowUI:
    Die Datenausführungsverhinderung wird für das Programm deaktiviert
    Entspricht: Kontrollkästchen aktiviert (OptOut-Liste)
  • EnableNXShowUI:
    Die Datenausführungsverhinderung wird für das Programm aktiviert
    Entspricht: Kontrollkästchen deaktiviert (OptIn-Liste)

Für die oben abgebildete Liste werden die Einträge dann folgendermaßen aussehen:

Datenausführungsverhinderung (DEP) aus/einschalten

Windows XP und 2003

Die Datenausführungs-Verhinderung kann auch bei Windows XP und Windows 2003 über die BOOT.INI gesteuert werden. Lesen Sie dazu den Tipp: "Informationen über die BOOT.INI"

Ab Windows Vista

Da es ab Windows Vista keine BOOT.INI mehr gibt, werden die Daten in BCD-Store abgelegt. Änderungen im BCD-Store werden über die Eingabeaufforderung durchgeführt. Öffnen Sie dafür die Eingabeaufforderung mit administrativen Rechten.

Aktivierung der OptIn-/OptOut-Liste: bcdedit.exe /set {current} nx AlwaysOn

Deaktivierung der OptIn-/OptOut-Liste: bcdedit.exe /set {current} nx AlwaysOff

Infos über bcdedit finden Sie im Tipp: "Informationen über den BCD-Store"

Datenausführungsverhinderung (DEP) in Internet Explorer 7 (32-Bit) ausschalten

Die Datenausführungs-Verhinderung kann bei einigen AcitveX-Erweiterungen dazu führen, dass der Internet Explorer 7 beendet wird. Sie können DEP für den Internet Explorer folgendermaßen ein/ausschalten:

  • Starten Sie den Internet Explorer
  • Wählen Sie aus dem Menü "Extras" --> "Internetoptionen" aus
  • Wählen Sie den Tabreiter "Erweitert"
  • Suchen Sie in "Einstellungen" unter "Sicherheit" den Eintrag "Speicherschutz aktivieren, um das Risiko von Onlineangriffen zu verringern"
  • Entfernen Sie den Haken, um die DEP auszuschalten bzw. setzen Sie den Haken, um DEP zu aktivieren.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=875351

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2323.htm


XP Home: Verstecktes Administratorkonto

Auch in der Windows XP Home Version wird bei der Installation von Windows ein Administratorkonto eingerichtet. Dieses Konto wird aber nicht in der Oberfläche angezeigt. Leider ist dieses Konto aktiv und verfügt über kein Passwort, dadurch kann sich jeder mit diesem Konto anmelden und hat damit administrative Berechtigungen.

Aus Sicherheitsgründen sollten Sie dem Konto ein Passwort geben, damit sich keiner über diese Sicherheitslücke anmelden kann. Öffnen Sie dafür die Kommandozeilenoberfläche und geben Sie folgenden Befehl ein:

net user Administrator [Passwort]

Geben Sie für [Passwort] das neue Passwort für den Account ein. Da Sie nicht mit dem Account arbeiten, sollten Sie für das Kennwort eine komplizierte Zeichenfolge verwenden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2416.htm


Gruppe 'Jeder' um "Anonyme Benutzer" erweitern

Dieser Tipp beschreibt, wie Sie "Anonyme Benutzer" wieder zur Gruppe 'Jeder' hinzufügen können.

Ab Windows XP hat Microsoft aus der Benutzergruppe 'Jeder' die Anonymen Benutzer entfernt. Dadurch besteht die Gruppe nur noch aus Benutzern, die auch ein entsprechendes Konto auf dem Rechner haben und einem Gast-Konto. Dieses wurde aus Sicherheitsgründen gemacht, damit Benutzer ohne Anmeldung nicht über die Gruppe 'Jeder' Zugriff auf bestimmte Ressourcen bekommen.

Wenn Sie "Anonymen Benutzer" trotzdem Zugriff geben wollen, können Sie durch einen Registryeintrag die Gruppe 'Jeder' wieder um "Anonyme Benutzer" erweitern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Lsa

Erstellen Sie hier einen neuen Wert mit dem Namen "EveryoneIncludesAnonymous" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Anonyme Benutzer nicht zur Gruppe Jeder hinzufügen (Standard)
1 | Anonyme Benutzer werden zur Gruppe Jeder hinzugefügt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2507.htm


GUI für Dateizugriffsrechte unter XP Home

GUI für Dateizugriffsrechte unter Windows XP Home

Unter Windows 2000 und Windows XP Professional wird zum Verändern der Zugriffsrechte von Dateien oder Verzeichnissen im Kontextmenü (rechte Maustaste auf die Datei/Verzeichnis) unter dem Tabreiter 'Sicherheit' die entsprechenden Informationen angezeigt.

Unter Windows XP Home ist dieser Tabreiter nicht vorhanden.

Erst wenn das System im Abgesicherten Modus startet, wird auch unter XP Home der Tabreiter 'Sicherheit' angezeigt.

Info Damit der Tabreiter in Windows XP Professional angezeigt wird, muss die Standardeinstellung "Einfache Dateifreigabe verwenden (empfohlen)", zu finden im Explorer im Menü "Extras" -> "Ordneroptionen" im Tabreiter "Ansicht", deaktiviert werden (Häkchen entfernen).

Mit den Zugriffsrechten können Sie ab Windows NT die NTFS-Laufwerke kontrollieren, auf welche Benutzerkonten man mit bestimmten Verzeichnissen/Dateien zugreifen kann. Mit diesen Rechten können Sie z.B. Verzeichnisse so absichern, dass andere Benutzerkonten (z.B. <Das Kind>), nicht mehr auf das Verzeichnis zugreifen können und somit den Inhalt vor anderen Personen sichern.

Leider fehlt dieser Tabreiter unter Windows XP Home. Hier können Sie die Rechte entweder nur per GUI durch einen Start im Abgesicherten Modus ändern oder über die Eingabeaufforderung mit dem Befehl CACLS.EXE.

Damit Windows XP Home den Sicherheitsdialog auch im Normalen Modus anzeigt, muss die Datei Rshx32.dll geändert werden. Die Datei prüft in einem Registryschlüssel, ob sich der Rechner im Abgesicherten Modus befindet. Wenn dieser Wert auf '1' steht, werden die Sicherheitseinstellungen angezeigt. Da man den Wert in der Registry nicht einfach auf '1' setzen kann, Windows würde dann davon ausgehen, es befindet sich im Abgesicherten Modus , muss also der Key in der Datei geändert werden, denn ansonsten würden dadurch andere Funktion und Treiber deaktiviert.

Damit Sie diese Funktion benutzen können, müssen Sie die folgenden Dateien - wie beschrieben - mit einem Hexeditor bearbeiten. Als Hexeditor können Sie XVI32 (Download: http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm#screenshots) benutzen.

  1. Erstellen Sie - aus Sicherheitsgründen - eine Kopie der Datei Rxhs32.dll als rxhsec.dll
  2. Öffnen Sie die Datei mit dem Hexeditor
  3. Suchen Sie über STRG+F nach "OptionValue"
  4. Ändern Sie den Namen ab, indem Sie z.B. OptionValue ändern in OptionValuX. (e --> X)
  5. Speichern Sie die Datei ab.

Da die Originaldatei nicht verändern werden soll, müssen wir jetzt noch in der Registry eintragen, dass diese Datei beim Starten von Windows geladen wird.

Führen Sie dazu folgende Änderung aus:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Suchen Sie hier über die Taste <F3> nach rshx32.dll; ändern Sie den Namen in den oben vergebenen neuen Namen rxhsec.dll. Diesen Eintrag sollten Sie ca. 2 mal finden, also nach der ersten Änderung so lange weitersuchen bis der alte Name nicht mehr gefunden wird.

Anschließend erstellen Sie unter:

HKEY_LOCALMACHINE\ SYSTEM\ CurrentControlSet\ Control\ Safe

einen neuen Wert mit dem Namen "OptionValuX" (wenn Sie, wie oben beschrieben, diesen Namen gewählt haben. Ansonsten entsprechend ändern) als Datentyp REG_DWORD und setzen den Wert auf 1.

Jetzt wird in Windows XP Home der Tabreiter "Sicherheit" wie gewünscht angezeigt.

Siehe auch:

  • Berechtigungen in der Windows XP Home Edition
  • Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen (CACLS und ICACLS)

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2578.htm


Gruppenrichtlinieneditor Gpedit.MSC unter Windows XP Home nachinstallieren

Mit dem Gruppenrichtlinieneditor (Gpedit.msc) lassen sich eine Vielzahl vom Einstellung am System vornehmen. Leider hat Microsoft dieses Tool aus der Home-Version von Windows XP entfernt.

Mit einen Trick können Sie dieses Tool aber auf Ihren Rechner nachinstallieren, dafür müssen Sie folgendermaßen vorgehen:

  • Besorgen Sie sich das vollständige Service Pack 2 oder 3 (ca. 265 MB) [Donwload SP2] [Donwload SP3]
  • Besorgen Sie sich die Datei "Create_GPEdit_MSC.zip" [Download]
  • Entpacken Sie das Service Pack in einen temporäres Verzeichnis:
    WindowsXP-KB835935-SP2-DEU.exe /x:[Laufwerk:\Verzeichnispfad] (z.B.: WindowsXP-KB835935-SP2-DEU.exe /x D:\WinXPSP2)
    (bzw. anderer Name und Pfad bei SP3 usw.)
  • Nach dem Entpacken müssen Sie aus dem Verzeichnis I386 folgende Dateien mit dem Befehl 'expand' über die Kommandozeile entpacken. Sie müssen "[Laufwerk:\Verzeichnispfad]" durch den Pfad ersetzen, wo Sie das Service Pack entpackt haben (siehe oben), hier im Beispiel also bei: D:\WinXPSP2.
    Nach %Systemroot%\System32\
    expand.exe -r appmgmts.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\I386\appmgr.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\certmgr.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\fdeploy.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\gpedit.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\gptext.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\ieaksie.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\ipsecsnp.dl_ %Systemroot%\System32\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\wsecedit.dl_ %Systemroot%\System32\

    Nach %Systemroot%\System32\GroupPolicy\Adm (Wenn nicht vorhanden, dann anlegen)
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\system.ad_ %Systemroot%\System32\GroupPolicy\Adm\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\IP\inetres.ad_ %Systemroot%\System32\GroupPolicy\Adm\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\inetset.ad_ %Systemroot%\System32\GroupPolicy\Adm\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\conf.ad_ %Systemroot%\System32\GroupPolicy\Adm\
    expand.exe -r [Laufwerk:\Verzeichnispfad]\XPSP2\I386\wuau.ad_ %Systemroot%\System32\GroupPolicy\Adm\
  • Jetzt müssen davon noch einige DLL-Dateien registriert werden. Dafür müssen die folgenden Befehle ausgeführt werden:
    regsvr32 %Systemroot%\System32\gpedit.dll /s
    regsvr32 %Systemroot%\System32\gptext.dll /s
    regsvr32 %Systemroot%\System32\appmgr.dll /s
    regsvr32 %Systemroot%\System32\fdeploy.dll /s
    regsvr32 %Systemroot%\System32\certmgr.dll /s
    regsvr32 %Systemroot%\System32\ieaksie.dll /s
    regsvr32 %Systemroot%\System32\ipsecsnp.dll /s
    regsvr32 %Systemroot%\System32\wsecedit.dll /s
  • Erstellen Sie mit der Datei "Create_GPEdit_MSC.CMD" die Datei "GPEDIT.MSC", und kopieren Sie diese Datei in das Verzeichnis %Systemroot%\System32\

Gehen Sie auf "Start" -> "Ausführen" und geben Sie "GPEDIT.MSC" ein, um den Editor für Gruppenrichtlinien zu starten.

Leider wird im Service Pack die Datei "FDE.DLL" nicht mitgeliefert. Diese Datei ist nur in der Professionell Version von Windows XP vorhanden. Diese Datei wird aber nur für das Setzen einiger weniger Benutzer-Einstellungen benötigt, so dass man auf die Datei für die meisten Einstellungen verzichten kann. Weiterhin finden Sie die Datei auch im Internet zum Download (http://www.dll-datei.de/fde.dll,962).

Ansonsten müssen Sie sich die Datei von einem anderen Windows System kopieren in das Verzeichnis %Systemroot%\System32\, Anschließend müssen Sie dann diese Datei noch über "regsvr32 %Systemroot%\System32\FDE.dll /s" im System registrieren.

Anhang: Beispiel für eine CMD zum Kopieren der Dateien

REM Eventuell Verzeichnis und Laufwerksbuchstaben hier anpassen

Set SourcePath=D:\WinXPSP2

expand.exe -r %SourcePath%\I386\appmgmts.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\appmgr.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\certmgr.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\fdeploy.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\gpedit.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\gptext.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\ieaksie.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\ipsecsnp.dl_ %Systemroot%\System32\

expand.exe -r %SourcePath%\I386\wsecedit.dl_ %Systemroot%\System32\

rem Nach %Systemroot%\System32\GroupPolicy\Adm (Wenn nicht vorhanden, dann anlegen)

expand.exe -r %SourcePath%\I386\system.ad_ %Systemroot%\System32\GroupPolicy\Adm\

expand.exe -r %SourcePath%\I386\IP\inetres.ad_ %Systemroot%\System32\GroupPolicy\Adm\

expand.exe -r %SourcePath%\I386\inetset.ad_ %Systemroot%\System32\GroupPolicy\Adm\

expand.exe -r %SourcePath%\I386\conf.ad_ %Systemroot%\System32\GroupPolicy\Adm\

expand.exe -r %SourcePath%\I386\wuau.ad_ %Systemroot%\System32\GroupPolicy\Adm\

rem Jetzt müssen davon noch einige DLL-Dateien registriert werden. Dafür müssen die

rem folgenden Befehle ausgeführt werden:

regsvr32 %Systemroot%\System32\gpedit.dll /s

regsvr32 %Systemroot%\System32\gptext.dll /s

regsvr32 %Systemroot%\System32\appmgr.dll /s

regsvr32 %Systemroot%\System32\fdeploy.dll /s

regsvr32 %Systemroot%\System32\certmgr.dll /s

regsvr32 %Systemroot%\System32\ieaksie.dll /s

regsvr32 %Systemroot%\System32\ipsecsnp.dll /s

regsvr32 %Systemroot%\System32\wsecedit.dll /s

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2481.htm


REGEDIT zeigt nicht alle Einträge an

Durch einen Fehler in Regedit, werden unter Windows XP Einträge vom Typ REG_SZ oder Schlüssel welche eine Länge von 255 Zeichen überschreiten nicht angezeigt.

Es gibt jetzt auch schon einige Tool und natürlich Viren, die sich mit solchen Einträgen in die Autostarteinträge von Windows "einnisten". Wenn Sie jetzt mit Regedit auf diese Schlüssel gehen, werden die Einträge nicht angezeigt.

MIt den folgenden Tool werden auch solche Einträge angezeigt:

  • "Registry System Wizard" (RSW) Download: "http://www.winfaq.de"
  • "Sysinternals RootkitRevealer" Download: "http://www.sysinternals.com/utilities/rootkitrevealer.html"
  • "REG.EXE" ist bei Windows XP standardmäßig mit dabei

Über das Kommandozeilentool "REG.EXE", welches bei Windows mit dabei ist, können Sie sich auch solche Einträge anzeigen lassen.

Öffnen Sie dafür die Kommandozeile (CDM.EXE) und benutzen Sie dann den Parameter "REG QUERY /?".

Damit Sie z.B. alle Einträge unter RUN angezeigt bekommen geben Sie folgendes ein:

Maschine:

reg query HKLM\Software\Microsoft\Windows\CurrentVersion\Run

User:

reg query HKCU\Software\Microsoft\Windows\CurrentVersion\Run

Info Das Tool "Registry System Wizard" (RSW) enthält auch einen einfachen Registrybrowser, dieses Tool enthält diesen Fehler nicht und zeigt diese Einträge auch an. Sie können das Programm unter "http://www.winfaq.de" finden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2073.htm


Unregistrierte Dateitypen beim Durchsuchen berücksichtigen

Mit diesem Tipp können Sie einstellen, dass beim Suchen von Texten in Dateien, auch Dateien durchsucht werden, dessen Dateiendungen nicht bekannt sind. Standardmäßig werden solche Dateien bei der Suche nicht beachtet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ ContentIndex

Erstellen Sie hier einen neuen Wert mit dem Namen "FilterFilesWithUnknownExtensions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Unbekannte Dateiendungen durchsuchen
0 | Unbekannte Dateiendungen nicht durchsuchen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1642.htm


Bestätigungsdialog beim Löschen von Dateien anzeigen

Mit diesem Tipp können Sie einstellen, dass vor dem Löschen von Dateien ein zusätzliches Bestätiungsdialog eingeblendet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "ConfirmFileDelete" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Bestätigungsdialog einblenden
gelöscht | Keine Bestätigungsdialog (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Bestätigungsdialog beim Löschen von Dateien anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1907.htm


Websuche bei unbekannten Dateitypen deaktivieren

Info: XP ab SP2

Mit diesem Tipp können Sie einstellen, ob die Websuche bei unbekannten Dateien geöffnet werden soll. Wenn Sie auf eine Datei einen Doppelklick ausführen, versucht Windows automatisch die mit der Dateiendung verknüpfte Anwendung zu starten. Ist keine Anwendung mit der Dateiendung verbunden, kann der Anwender auswählen, ob lokal oder im Web nach einer entsprechenden Anwendung gesucht werden soll.

Wenn Sie diesen Tipp aktivieren, steht die Auswahl WEB nicht mehr zur Verfügung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies\ System

Erstellen Sie hier einen neuen Wert mit den Namen "NoInternetOpenWith" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Websuche steht nicht zur Verfügung
0 | Websuche kann verwendet werden

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2004.htm


Websuche nach Dateiendungen unterbinden

Mit diesen Tipp können Sie den Aufruf des Webdienstes für die Suche nach einem geeigneten Programm unterbinden. Sie können damit die Websuche nach Dateiendungen verbieten (Webdienst für die Suche nach dem richtigen Programm verwenden), welche normalerweise bei unbekannten Dateiendungen mit angezeigt wird.

Wenn Sie unter Windows auf eine Datei klicken, deren Dateiendung nicht registriert ist und deshalb nicht ermittelt werden kann, mit welchen Programm die Anwendung geöffnet werden soll, wird ein Dialogfeld geöffnet. Hier haben Sie die Möglichkeit, durch die Auswahl von "Webdienst für die Suche nach einem geeigneten Programm verwenden", im Internet nach einem geeigneten Programm zu suchen, mit dem die Datei zu öffnen ist

.

Diese Suche ist in den meisten Fällen erfolglos und oft auch nicht erwünscht. Über die Registry können Sie die Anzeige dieser Auswahlmöglichkeit deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Nur Windows XP:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "InternetOpenWith" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag wird nicht angezeigt
1 | Eintrag wird angezeigt (Standard)

Alle:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoInternetOpenWith" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: JA
Benutzerkonfiguration: JA
Pfad: Administrative Vorlagen\System\Internetkommunikationsverwaltung\Internetkommunikationseinstellungen
Einstellungsname: Internet-Deteizuordnungsdienst deaktivieren
Beschreibung:

Legt fest, ob der Microsoft-Webdienst verwendet werden soll, um eine Anwendung zum Öffnen einer Datei mit einer nicht bekannten Dateizuordnung zu suchen.

Wenn ein Benutzer versucht, eine Datei mit einer Erweiterung zu öffnen, die keiner Anwendung zugeordnet ist, kann er auswählen, ob eine lokale Anwendung verwendet oder mit dem Webdienst nach einer Anwendung gesucht werden soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2510.htm


Pfad zum Temp-Verzeichnis anpassen

Mit diesen Eintrag können Sie den Pfad zu den Temp-Verzeichnissen Ihren Wünschen anpassen.

Dafür werden die zwei Einträge TEMP und TMP verwendet. Die beiden Einträge zeigen meist auf das gleiche Verzeichnis, sind aber nötig, da einige Programme nach TEMP und andere nach TMP suchen.

Unter XP finden Sie die Einstellung unter "Systemsteuerung" -> "System" -> Tabreiter "Erweitert" -> Button "Umgebungsvariablen". Hier können Sie jetzt die Variablen jeweils für den Benutzer und das System ändern.

Ab Windows Vista "Systemsteuerung (klassische Ansicht)" -> "System" -> links den Eintrag "Erweiterte Systemeinstellungen" auswählen -> Tabreiter "Erweitert" -> Button "Umgebungsvariablen.."

Sie finden die Einstellungen in der Registry unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

für den Anwender:

HKEY_CURRENT_USER\ Environment

für das System (hier überschreibt diese Einstellung nicht die obere Konfiguration des Anwenders, sondern legt das Tempverzeichnis für alle Prozesse fest die durch das System gestartet werden):

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Session Manager\ Enviroment

Dort finden Sie die Einträge "Temp" und "Tmp" als Datentyp REG_EXPAND_SZ. Hier können Sie den Pfad auf ein beliebiges Verzeichnis ändern. Sie können hier auch mit anderen Environment Variablen arbeiten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1416.htm


Standardverzeichnis für Windows Brennprogramm anpassen

Wenn Sie über die Windows Brennfunktion eine CD erstellen, werden die Dateien bis zum Brennen (Daten auf CD schreiben) in einem Ordner zwischengespeichter. Dieser Ordner befinden sich Standardmäßig unter:

"%Userprofile%\Lokale Einstellungen\Anwendungsdaten\Microsoft\CD Burning"

Wenn Sie den Pfad verlegen wollen, können Sie das über den folgenden Eintrag machen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

hier finden Sie den Eintrag "CD Burning" als Datentyp REG_SZ. Geben Sie hier einfach den gewünschten Pfad zum neuen Verzeichnis an, in dem die Dateien zwischengespeichert werden sollen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1998.htm


Autoplay Blockliste pflegen

Wenn die Autoplayfunktion für Laufwerke aktiv ist und eine CD eingelegt wird, sucht Windows automatisch im Rootverzeichnis nach der Datei "Autorun.inf".

Wird diese Datei von Windows gefunden, sucht das System in der Datei nach dem Eintrag "OPEN=" und wertet den Eintrag hinter dem Gleichheitszeichen (=) aus.

Normalerweise würde Windows jetzt automatisch den angegebenen Befehl ausführen und so vielleicht ein Auswahlmenü mit entsprechenden Möglichkeiten öffnen. Da einige Hersteller hier aber auch Programme eingetragen haben, die ohne Nachfrage eine Installation starten, gibt es in Windows eine "Blockliste". Wird der Befehl in der Blockliste gefunden, dann wird der Befehl in der Autostartdatei nicht ausgeführt.

Die Blockliste können Sie in der Registry bearbeiten und ja nach Geschmack neue Einträge hinzufügen oder vorhandene Einträge löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoplayHandlers\ CancelAutoplay\ Files

Hier finden Sie für jede Datei einen Eintrag. Der Name entspricht den Dateinamen der nicht ausgeführt werden soll. Die Einträge werden als Datentyp REG_SZ angelegt. Der Wert selber bleibt aber leer.

Sie können in der Blockliste mit Platzhaltern (*) arbeiten. So ist z.B. ein Standardeintrag "*setup*.exe" vorhanden. Dadurch werden keine Einträge ausgeführt die das Wort Setup im Text enthalten und mit der Extension .EXE enden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2059.htm


Festplatten-Speicherplatzüberprüfung deaktivieren

Windows XP überprüft automatisch den verfügbaren Festplattenspeicher. Wird eine bestimmte Größe an freiem Speicherplatz unterschritten, werden Sie mit der Meldung

"Sehr wenig Speicherplatz - soll die Partition aufgeräumt werden?" darauf hingewiesen.

Ist der geringe verbleibende Platz beabsichtigt, kann diese Meldung schnell störend wirken. Über die Registry können Sie die Überprüfung deaktivieren. Wenn Sie den Eintrag "NoLowDiskSpaceChecks" aktivieren (Festlegung auf "1"), wird keine Meldung mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoLowDiskSpaceChecks" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Keine Meldung anzeigen
0 | Meldung anzeigen (Standard)

Siehe auch Tipp: "Warnmeldung wenn Festplatte voll".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1218.htm


48-BIT LBA Unterstützung einschalten

Durch die 48-BIT LBA Unterstützung, die ATAPI- Laufwerke haben, wird ermöglicht, eine Größe von über 137 GByte zu unterstützen.

Diese Funktion ist standardmäßig nicht aktiviert, da sie bislang nur von wenigen Laufwerken unterstützt wurde, damit diese Funktion funktioniert, müssen Ihr BIOS und Ihr Laufwerk "48-Bit LBA" unterstützen.

  • Windows 2000 kann ab ServicePack 3 den 48-Bit LBA-Modus, er muss aber explizit in der Registry aktiviert werden.
  • Ab Windows XP (ServicePack 1) wird standardmäßig der 48-Bit LBA-Modus benutzt, auch ohne den Eintrag in der Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Atapi\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableBigLba" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | 48-BIT LBA aktiv
0 | 48-BIT LBA deaktiv

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=305098
http://support.microsoft.com/?kbid=303013

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1466.htm


Schreibschutz für USB Storage Device ein-/ausschalten

Ab SP2 kann über diese Funktion ein Schreibschutz für USB Storage Device eingerichtet werden. Wenn Sie diese Funktion aktivieren, kann nicht mehr auf diese Laufwerke geschrieben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ StorageDevicePolicies

Erstellen Sie hier einen neuen Wert mit dem Namen "WriteProtect" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Schreibschutz aktivieren
0 | Kein Schreibschutz aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1686.htm


USB-Geräte werden ab SP2 nicht korrekt vom Betriebssystem erkannt

Ab SP2 werden USB-Geräte, die noch mit SP1 ohne Probleme liefen, nicht mehr richtig erkannt. Dadurch wird die Leistung von Firewire (1394) auf die Hälfte reduziert.

Dafür hat Microsoft ein Update zur Verfügung gestellt welches Sie unter der Knowledge Base vom Microsoft herunterladen können (Link siehe unten).

Anschließend kann man über die Registry die Geschwindigkeit für USB einstellen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ PCI\ 1394_hc_hw_id\ 1394_instance_id\ Device Parameters

Gehen Sie folgendermaßen vor um die 1394_hc_hw_id und 1394_instance_id zu ermitteln:

  • Starten Sie den Gerätemanager (rechte Maustaste auf das Icon Arbeitsplatz und aus dem Kontextmenü "Verwalten" auswählen. Hier finden Sie unter System den Geräte-Manager).
  • Suchen Sie unter "IEEE 1394 Bus-Hostcontroller" Ihren FireWire-Controller oder unter "USB-Controller" Ihren USB-Controller aus
  • Klicken Sie mit der rechten Maustaste auf den Controller und wählen Sie aus dem Kontextmenü "Eigenschaften" aus.
  • Klicken Sie in neuen Fenster "Eigenschaften von...." auf den Tabreiter "Details"
  • Wählen Sie hier "Geräteinstanzkennung" aus
  • Ihnen wird jetzt z.B. folgende Kennung angezeigt "PCI\VEN_8086&DEV_24C2&SUBSYS_C00C144D&REV_03\3&61AAA01&0&E8"
  • Dabei ist:die Nummer nach dem ersten \ (Schrägstrich) die 1394_hc_hw_id
  • Die Nummer nach dem zweiten \ gibt die 1394_instance_id an
  • Erstellen Sie einen neuen Eintrag mit den Namen "SidSpeed" als Datentyp REG_DWORD und setzen den Wert auf:

    0 = S100 Geschwindigkeit

    1 = S200 Geschwindigkeit

    2 = S300 Geschwindigkeit (Standard)

    3 = S400/S800 Geschwindigkeit (Standard von Service Pack 1)

    Werte Größer als 3 werden ignoriert und der Wert wird automatisch auf 0 (S100 Geschwindigkeit) gesetzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=885222

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1829.htm


Raid 5-Funktion unter Windows XP Pro freischalten

In diesem Tipp wird beschrieben, wie die Raid 5-Funktion unter Windows XP Professional freizuschalten sind.

Standardmäßig unterstützt Windows XP Pro lediglich Raid 0. Wenn Sie auch Raid 1 und Raid 5 benutzen möchten, müssen einige Anpassungen an den Systemdateien durchführen.

Damit Sie diese Funktion benutzen können, müssen Sie die folgenden Dateien - wie beschrieben - mit einem Hexeditor bearbeiten. Als Hexeditor können Sie XVI32 (Download: http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm#screenshots) benutzen.

DMBOOT.SYS

  1. Kopieren Sie die Datei "DMBOOT.SYS" aus dem Verzeichnis "%Systemroot%\System32\Drivers" in ein beliebiges Verzeichnis zum Bearbeiten (z.B.: C:\Raid5\)
  2. Öffnen Sie die Datei mit dem Hexeditor
  3. Suchen Sie über STRG+F nach "SERVERNT"
  4. Der Text wird nur einmal gefunden. Gehen Sie bis zu WINNT zurück und geben Sie hier "SERVERNTWINNT" ein und überschreiben Sie die letzten Buchstaben mit den Hexwerten "00".
  5. Geänderte DMBOOT.SYS:

DMCONFIG.DLL

  1. Kopieren Sie die Datei "DMCONFIG.DLL" aus dem Verzeichnis "%Systemroot%\System32" in ein beliebiges Verzeichnis zum Bearbeiten (z.B.: C:\Raid5\)
  2. Öffnen Sie die Datei mit dem Hexeditor
  3. Suchen Sie über STRG+F nach "SERVERNT"
  4. Der Text wird nur einmal gefunden. Überschreiben Sie das SERVERNT mit WINNT und füllen Sie den Rest mit dem Hexwert "00" auf. Anschließend müssen Sie den Wert WINNT durch SERVERNT überschreiben.
  5. Geänderte DMCONFIG.DLL:

DMADMIN.EXE

  1. Kopieren Sie die Datei "DMADMIN.EXE" aus dem Verzeichnis "%Systemroot%\System32" in ein beliebiges Verzeichnis zum bearbeiten (z.B.: C:\Raid5\)
  2. Öffnen Sie die Datei mit dem Hexeditor
  3. Suchen Sie über STRG+F nach "servernt"
  4. Der Text wird nur einmal gefunden. Überschreiben Sie das SERVERNT mit WINNT und füllen Sie den Rest mit dem Hexwert "00" auf.
  5. Geänderte DMADMIN.EXE:

Dateien austauschen

Damit Sie die Dateien austauschen können und Windows sie nicht wieder auf die Originalversion zurückkopiert, müssen Sie die Sicherungen löschen. Dafür löschen Sie die 3 Dateien aus den folgenden Verzeichnis:

  • %windir%\System32\Dllcache
  • %windir%\ServicePackFiles\I386 (nicht auf allen System vorhanden)

ACHTUNG:

Sie sollten sich von den Originaldateien zuvor ein Backup anlegen, damit Sie wieder auf die alten Dateien umstellen können, falls etwas nicht funktioniert.

Jetzt kopieren Sie die geänderten Dateien wieder in die entsprechenden Verzeichnisse zurück, also:

DMBOOT.SYS -> %Systemroot%\System32\Drivers

DMADMIN.EXE -> %Systemroot%\System32

DMCONFIG.DLL -> %Systemroot%\System32

Dabei wird sich der Systemdateischutz melden und versuchen, die Originaldatei wieder herzustellen und verlangt deshalb nach der Windows CD. Brechen Sie diesen Vorgang ab, und bestätigen Sie den Erhalt der neuen Datei mit OK.

Nach dem Neustart können Sie ein Raid-5-Verbund anlegen.

Dazu benötigen Sie aber mindestens 3 (oder mehr) Datenträger, die Sie zu einem Raid 5 zusammenschließen können. Öffnen Sie dafür DISKMGMT.MSC und wandeln die entsprechenden Datenträger in dynamische Datenträger um. Wenn Sie anschließend auf dem Datenträger "Neues Volume" auswählen, können Sie im Assistenten jetzt auch "Gespiegelt (Raid 1)" und "Raid 5" auswählen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2504.htm


Konvertieren eines IEEE 1394-Festplattenlaufwerkes in ein dynamisches Festplattenlaufwerk

Mit diesen Tipp, können Sie ein IEEE 1394-Festplattenlaufwerk (FireWire) in ein dynamisches Laufwerk umwandeln.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Dmadmin\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableDynamicConversionFor1394" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Konvertierung ist aktiv
0 | Keine Konvertierung (Standard)

Info Aktivieren Sie diese Funktion nicht, wenn Sie das Laufwerk auch an anderen Rechnern betreiben. Wenn diese Funktion aktiv ist, müssen Sie das Laufwerk ausschließlich an diesen Rechner betreiben.

Info Dynamische Festplatten werden in der Windows XP Home Edition und auf tragbaren Computern nicht unterstützt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2600.htm


Drucker Spooler PopUp-Infos ausschalten

Normalerweise zeigt Windows XP ab Service Pack 2 eine PopUp-Box mit der Meldung an, dass der Druckauftrag ausgeführt wurde. Mit diesem Tipp können Sie die PopUp (Balloon) Infos vom Drucker-Spooler ausschalten.

Damit die Änderung aktiv wird, müssen Sie entweder den Printerspooler Stoppen und Starten oder den Rechner neu starten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Printers\ Settings

PopUp für lokale Drucker ausschalten:

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableBalloonNotificationsLocal" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | PopUp Infos anzeigen
0 | PopUp Infos ausblenden

PopUp für Netzwerkdrucker ausschalten:

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableBalloonNotificationsRemote" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | PopUp Infos anzeigen
0 | PopUp Infos ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1685.htm


'Point and Print' nur mit bestimmten Servern zulassen

"Point and Print" nur mit bestimmten Servern zulassen

Info: XP ab SP1

Mit diesem Tipp können Sie einstellen, dass Benutzer mit der "Point-and-Print"-Funktionalität nur die aufgeführten Server auswählen können. Diese Einstellungen gilt nur für Clients ohne Druckadministrator und nur, wenn die Computer Domänenmitglieder sind.

Wenn Sie diesen Tipp nicht konfigurieren, ist "Point-and-Print" standardmäßig nur innerhalb der Gesamtstruktur des Clients erlaubt. Durch die Aktivierung (Restricted=1), kann "Point-and-Print" auf einen Server innerhalb der Gesamtstruktur des Clients und/oder auf eine Liste von ausdrücklich vertrauten Servern eingeschränkt werden. Wenn Sie (Restricted=0) deaktivieren, können sich Client-Computer an jeden Server für "Point-and-Print" verbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows NT\ Printers\ PointAndPrint

Erstellen Sie hier einen neuen Wert mit dem Namen "Restricted" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Point-and-Print" auf einen Server innerhalb der Gesamtstruktur des Clients und/oder auf eine Liste von ausdrücklich vertrauten Servern eingeschränkt
0 | "Point-and-Print" auf jeden Server erlauben, dabei sollte "TrustedServers" und "InForest" auf 0 gesetzt werden um einen sauberen Zustand zu erzeugen.

Erstellen Sie hier einen neuen Wert mit dem Namen "TrustedServers" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Die "Point-and-Print"-Funktionalität steht der Server bereit, die im Schlüssel "ServerList" angegebenen wurden
0 | Die Point-and-Print-Funktionalität steht nicht auf anderen Servern bereit

Erstellen Sie hier einen neuen Wert mit dem Namen "ServerList" als Datentyp REG_SZ und geben Sie hier die Liste der Server an. Wenn Sie mehr als einen Server angeben, trennen Sie die Server durch ein Semikolon. Weiterhin müssen Sie hier den voll qualifizierte Domänennamen (FQDNs) verwenden.

Erstellen Sie hier einen neuen Wert mit dem Namen "InForest" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Point-and-Print" auf einen Server innerhalb der Gesamtstruktur des Clients
0 | Wird nicht auf die Gesamtstruktur des Clients beschränkt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Drucker
Einstellungsname: | Point-and-Point-Beschränkungen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=319939.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1958.htm


Client Performanz-Optimierung mit dem Windows Performance Tool Kit

Optimierung der Client Performance mit Windows Performance Tool Kit

In diesem Teil meiner Performanceanalyse möchte ich darauf eingehen, wie man mit dem Tool "Windows Performance Tools" das Bootverhalten detailliert analysieren kann. Sie können mit dem Tool eine Diagnose durchführen und sich das Trace anschließend in grafischer Form anzeigen lassen.

Windows Performance Tool Kit

Zunächst benötigen wird das Windows Performance Tool Kit, welches kostenlos bei Microsoft heruntergeladen werden kann (siehe Link unten).

Das Toolkit selbst können Sie leider nur ab Windows Vista installieren und nicht unter Windows XP.

Wir zeigen hier, wie Sie das Tool trotzdem unter Windows XP starten können.

Nach der Installation können Sie auf die Tools zugreifen. Bei den meisten Tools handelt es sich um reine Kommandozeilen-Anwendungen ohne Oberfläche.

Systemtrace erstellen (XPerf)

Mit dem Tool XPerf können Sie einen Echtzeittrace des Systems erstellen und damit umfangreichere Informationen erhalten als z.B. mit dem Performance Monitor. Wenn Sie in der Kommandozeile Xperf eingeben, wird Ihnen ein Hilfetext mit den möglichen Befehlen angezeigt. Für viele Aufgaben ist die Analyse eines Kernel-Trace schon recht aussagekräftig.

Zum Erstellen eines Traces gehen Sie folgendermaßen vor:

  • Sie Starten den Trace mit: Xperf -start -on DiagEasy
  • Führen Sie die Aktionen/Anwendungen aus, die Sie tracen möchten
  • Erstellen Sie einen DUMP mit dem Befehl: Xperf –d [Dateiname] z.B.: xperf –d C:\testdump.etl
  • Öffnen Sie den Dump mit xperfview (siehe unten)

Dabei wird der Trace automatisch angehalten. Ansonsten müssen Sie den Trace mit "xperf –stop" beenden.

Über "xperf -providers" können Sie festlegen, welche unterschiedlichen Provider betrachtet werden sollen. Wird der Wert nicht angegeben, werden nur die Standardprovider betrachtet.

Mit "xperf -help <Befehl>" können Sie sich die entsprechenden Hilfetexte anzeigen lassen.

Tracen des Bootvorganges (xbootmgr)

Mit dem Tool xbootmgr können Sie einen Trace des Bootvorganges erstellen lassen. Wenn Sie den Befehl ohne Parameter aufrufen, wird Ihnen der entsprechende Hilfebildschirm angezeigt.

Um einen Bootvorgang zu tracen, geben Sie den folgenden Befehl ein:

xbootmgr -trace boot -resultPath C:\TEMP

Info Wenn Sie den Befehl ausführen, werden Sie automatisch abgemeldet und ein Bootvorgang wird durchgeführt und das entsprechende Trace wird erstellt. Das Tracefile wird dann im angegebenen Verzeichnis mit dem Dateinamen *.etl erzeugt.

Auswerten und Anschauen der Tracedateien (xperfview)

Mit dem Tool "Performance Abalyzer" (xperfvioew) können Sie die erzeugten Tracedateien öffnen. Starten Sie das Tool und wählen Sie aus dem Menü "Trace" -> "Open" die entsprechende Datei aus.

Im obersten Fenster sehen Sie die CPU-Auslastung (hier nur für 1 CPU). Je CPU würden Sie eine entsprechende Kurve sehen. Wenn Sie z.B. zwei CPUs haben und eine der Kurvenzüge wäre immer nur bei 0 %, dann könnte die Benutzung der CPU über MSCONFIG ausgeschaltet sein.

Mit der rechten Maustaste können Sie hier einen Bereich markieren und sich über das Kontextmenü (linke Maustaste) anschließend - über den Eintrag "Summery Table" - genauere Informationen anzeigen lassen.

Info Dass die Prozesse hier alle nur den Namen "Idle" haben, liegt daran, dass es sich hierbei um Bilder aus der Windows 7 Beta handelt. In der endgültigen Windows Versionen haben die Prozesse die richtigen Namen.

Im zweiten Fenster werden die "I/O Counts" auf der Festplatte angezeigt. Bis Windows XP gibt es hier nur die Anzeige in Rot (Lesen) und Blau (Schreiben). Ab Windows Vista werden die Aktionen auch noch mit Prioritäten versehen:

Auch hier können Sie wieder die "Summery Table" aufrufen. Zusätzlich gibt es ansonsten noch "Detail Graph" wo Sie auf I/O Ebene die Einsprungspunkte des Schreib/Lese-Kopfes auf der Festplatte sehen.

Wird viel auf der Festplatte gesprungen, kann das auf eine schlechte Defragmentierung hindeuten. Ein stark fragmentiertes System könnte dann so aussehen:

In einem weiteren Fenster werden noch die diversen Prozesse angezeigt.

Für die Übersichtlichkeit wurde die Anzeige so eingestellt, dass nur die Startzeiten angezeigt werden. Standardmäßig werden auch noch die Laufzeiten der Prozesse angezeigt.

Hier können Sie sich die Prozesse anschauen, die gestartet werden. Gerade wenn im Bootprozess viele Kommandozeilen (CMD) geöffnet werden, werden viele Skripte gestartet und ausgeführt. Wenn möglich, sollten keine Skripte im Bootvorgang benutzt werden. Benutzen Sie lieber Gruppenrichtlinen oder ab Server 2008 "Group Policy Preferences".

Verschiedene Trace Aufrufe

Hier finden Sie einige Aufrufbeispiele, um einen Trace für verschiedene Situationen zu erstellen.

Um den Bootvorgang zu Tracen:

xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Um das Herunterfahren zu protokollieren:

xbootmgr -trace shutdown -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Für Standby und Aufwachen:

xbootmgr -trace standby -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Start nach dem Ruhezustand:

xbootmgr -trace hibernate -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Die Tools unter Windows XP/2003 benutzen

Von einem Vista oder Windows Server 2008 kopieren Sie die Dateien "xperf.exe" und "perfctrl.dll" in das Zielsystem. Jetzt können Sie mit xperf.exe einen Trace erstellen.

Sie können jetzt xperf.exe für Windows XP (ab SP2) und Windows Server 2003 für einen Kernel-Trace benutzen.

Beachten

Sie, dass die Funktion "-stackwalk" nicht von Windows XP unterstützt wird (diese Funktion wurde erst ab Windows Vista eingeführt).

Einschränkung: Da xperfview auf XP nicht lauffähig ist, müssen Sie die Traces vom XP-Rechner auf einem anderen System (z.B.: unter Windows Vista) öffnen.

Links und Downloads

Hier finden Sie den Link zu der Software und einige weitere Links mit Informationen zum Tool. Die Dokumentation "On/Off Transition Performance Analysis of Windows Vista" von Microsoft beschreibt recht ausführlich die Benutzung des Tools und die Auswertung des Traces.

Windows Performance Tool (Download):

  • http://msdn.microsoft.com/en-us/performance/default.aspx

Hier finden Sie weitere Informationen zum Tool von Microsoft:

  • Performance Analyzer: System-Performance-Analyse-Tools für Microsoft Windows
  • On/Off Transition Performance Analysis of Windows Vista
  • Windows Performance Analysis

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2667.htm


Suche nach geplanten Tasks bei Netzwerkrechnern unterbinden

Windows sucht automatisch nach evtl. geplanten Task. Wenn Sie das nicht mehr wollen, dann müssen Sie den folgenden Registryeintrag "Geplante Tasks" löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ RemoteComputer\ NameSpace

löschen Sie hier den Schlüssel "{D6277990-4C6A-11CF-8D87-00AA0060F5BF}".

Wenn Sie den Eintrag wieder anlegen wollen, erstellen Sie den Schüssel neu. Setzen Sie den Wert (Standard) wieder auf "Geplante Tasks"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1590.htm


Speicherplatz für Master File Table konfigurieren

Die Master-Dateitabelle (Master File Table, kurz MFT bezeichnet), stellt eines der Kernstücke des NTFS-Dateisystems dar. Die MFT enthält mindestens einen Eintrag für jede Datei auf einem NTFS-Datenträger, einschließlich der MFT selbst. Als erstes wird die MFT bei einem NTFS-Filesystem geladen und ausgewertet. Diese Datei enthält wichtige Informationen zu den gespeicherten Dateien und Ordner auf dem Datenträger.

Da die Größe dieser Datei nicht unendlich ist, wird die Größe der Datei irgendwann überschritten. Dadurch wird die MFT außerhalb des geschützten Bereiches erweitert, was zu einer Fragmentierung der MFT führt.

Da Dienstprogramme zum Defragmentieren die MFT-Einträge nicht verschieben können und da die übermäßige Fragmentierung der MFT die Leistung beeinträchtigen kann, reserviert NTFS Speicherplatz für die MFT, um eine zusammenhängende Speicherung zu ermöglichen.

Bedeutet:

Sie greifen auf ein Verzeichnis mit 100 Dateien zu. Diese Dateiinformationen werden als erstes in die MFT eingetragen, wenn Sie dort noch nicht vorhanden sind. Wird dabei die max. Größe der MFT überschritten, wird die Datei außerhalb des geschützten Bereiches vergrößert, was zu einer Fragmentierung der MFT-Datei führt. Dadurch wird der Zugriff auf diese Datei langsamer. Wenn Sie also mit vielen Dateien arbeiten, ist es sinnvoll die Größe des geschützten Bereiches für die MFT-Datei zu ändern, damit Informationen in einer nicht fragmentierten Datei abgelegt werden. Dadurch wird der Zugriff beschleunigt.

Welche Informationen werden in der MFT abgelegt:

  • Wo liegt die Datei
  • Dateigröße
  • Datum
  • Dateierstellung
  • Zugriffsrechte
  • Datum der letzten Änderung
  • Freigaben
  • Inhalt
  • Dateitypen
  • usw.

Info Sie sollten den Wert frühzeitig erhöhen. Da die MFT auch nur eine Datei ist, kann es hier natürlich auch zu einer Fragmentierung kommen und damit wiederum zu einen Geschwindigkeitsverlust.

Info Die MFT gibt es nur beim NTFS-Dateisystem

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ FileSystem

Erstellen Sie hier einen neuen Wert mit dem Namen "NtfsMftZoneReservation" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Begrenzt MFT auf 12,5% des Laufwerks (Standard)
2 | Für Workstation - Begrenzt MFT auf 25% des Laufwerks
3 | Für Server - Begrenzt MFT auf 37,5% des Laufwerks
4 | Für HighEnd Server - Begrenzt MFT auf 45% des Laufwerks

Sinnvoll sind hier die Werte 1 oder 2, da die beiden anderen Werte erst bei einer sehr großen Anzahl von Dateien benötigt werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=174619

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1594.htm


Windows XP wird mit der Zeit immer langsamer

Hier wird beschrieben, wie man Windows XP wieder beschleunigen kann, um zu verhindern, dass es mit der Zeit nicht immer langsamer wird.

Wer kennt nicht das Problem von Windows XP? Je länger man mit dem System arbeitet um so langsamer arbeitet und reagiert Windows XP. Oft wird das System dann neu installiert, um wieder die alte Performance des Systems zu erhalten.

Das liegt u.a. an der - unter Windows XP neu eingeführten Funktion- "PreFetch". Diese Funktion PreFetch sorgt dafür, dass Dateien, die beim Systemstart geladen werden müssen, proaktiv von der Platte gelesen und im Cache vorgehalten werden. Eigentlich ist das eine recht gute Funktion und führt auch anfangs dazu, dass Windows schneller als sonst startet. Mit der Zeit wird die Liste der PreFetch-Dateien aber immer länger und enthält Dateien, die vom System nicht mehr gebraucht werden. Windows lädt diese Dateien aber immer noch, Dadurch wird auch der Cache-Speicher immer größer, was das System dann nach einer längeren Zeit wieder abbremst.

Info Ab Windows Vista wurde dieser Fehler von Microsoft behoben. Hier optimiert sich diese Funktion wieder von alleine, und es kommt nicht dazu, dass unnötige Dateien geladen werden.

Diesen Fehler können Sie beseitigen, indem Sie den Inhalt des PreFetch-Ordners löschen ("%systemroot%\prefetch").

Anschließend würde Windows das PreFetch-Verzeichnis sofort wieder neu aufbauen, was aber ca. 10 Bootvorgänge von Windows dauert.

Damit diese 10-Bootvorgänge nicht abgewartet werden müssen, benutzen Sie einfach das folgende Skript, welches Sie als "RenewPreFetch.cmd" abspeichern und dann starten (können):

=== Hier schneiden ===

REM PreFetch Verzeichnis leeren

del %systemroot%\prefetch\*.* /q /f

REM PreFetch Verzeichnis neu aufbauen (10 * ProcessIdleTasks starten)

for /L %%i in (1,1,10) do %windir%\system32\rundll32.exe advapi32.dll,ProcessIdleTasks

REM Bootbereich der Festplatte optimieren (5*)

for /L %%d in (1,1,4) do defrag %systemdrive% -b

=== Hier schneiden ===

Es bringt aber nichts, dieses Skript täglich auszuführen. Wenn das System doch merklich langsamer geworden ist, kann ein Aufruf helfen. Ob solch eine Aktionen wirklich merklich Performance bringt, ist und bleibt aber weiterhin ein Bereich für den "Expertenstreit".

Info Siehe auch Tipp "Bootvorgang beschleunigen (Prefetching)"

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2664.htm


Den PC Lautsprecher deaktivieren

Mit dem folgenden Eintrag können Sie den PC Lautsprecher unter Windows XP deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Sound

erstellen Sie einen neuen Eintrag mit dem Namen "ExtendedSounds" als Datentyp REG_SZ und setzen den Wert auf 0, um den Lautsprecher auszuschalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1358.htm


Senden von Problemberichten abschalten

Beim Absturz einer Software will Windows standardmäßig eine E-Mail mit einem Problembericht an MS senden. Da diese Funktion meist nicht benötigt wird, stört die Abfrage, ob diese E-Mail versendet werden soll. Sie können das aber folgendermaßen deaktivieren:

Unter "Arbeitsplatz" -> "Rechte Maustaste" -> "Eigenschaften" -> Registerkarte "Erweitert" -> Schaltfläche "Fehlerberichterstattung". Hier können Sie die Funktion konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ PCHealth\ ErrorReporting

Wertname | Datentyp | Wert | Beschreibung
DoReport | REG_DWORD | 0 | Fehlerberichterstattung deaktivieren
 |  | 1 | Fehlerberichterstattung aktivieren
ShowUI | REG_DWORD | 0 | Fehlerberichterstattung auch für kritische Fehler deaktivieren
 |  | 1 | Fehlerberichterstattung ist für kritische Fehler aktiv
 |  | 3 | Fehlerberichterstattung aktiv, aber nicht für kritische Fehler - Werden nur ausgewertet, wenn DoReport = 1
IncludeKernelFaults | REG_DWORD | 0 | Fehlerberichterstattung für das Windows Betriebssystem deaktiv
 |  | 1 | Aktiv
AllOrNone | REG_DWORD | 1 | Aktiv für alle Programme
 |  | 0 | Aktiv für Programme aus einer Liste
 |  | 2 | Deaktiv für Programme
IncludeMicrosoftApps | REG_DWORD | 0 | Deaktiv für alle MS-Programme
 |  | 1 | Aktiv für alle MS-Programme
IncludeWindowsApps | REG_DWORD | 0 | Deaktiv für alle Windows-Komponenten
 |  | 1 | Aktiv für alle Windows-Komponenten

Weiterhin gibt es unter diesem Registryzweig noch die Ordner:

  • ExclusionList: Alle Programme, die nicht beachtet werden sollen
  • ExclusionList: Alle Programme, die nicht beachtet werden sollen

Diese Ordner werden nur ausgewertet, wenn DoReport auf 1 und AllOrNone auf 0stehen.

Unter diesen Ordnern wird für jedes Programm ein Key mit dem Namen der Datei als Datentyp REG_DWORD angelegt. Steht der Wert auf 1, wird dieser Eintrag entsprechend berücksichtigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1251.htm


Dr. Watson - Inhalt und Typ der Dumpdatei festlegen

Mit diesem Tipp können Sie festlegen, wie umfangreich die Dumpdatei bei einem Absturz sein soll, die von Dr. Watson angelegt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DrWatson

ändern Sie hier den Wert "CrashDumpType" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Windows NT4-Kompatible Dumpdatei
1 | Kleine Dumpdatei (alle Datenabschnitte)
2 | Vollständige Dumpdatei (kompletten Speicherinhalt des Prozesses)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2063.htm


Konfiguration der Ereignisanzeige für weitere Informationen

Mit diesem Tipp können Sie einstellen, was aufgerufen wird, wenn man in der Ereignisanzeige auf "Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter: ...." aktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ EventViewer

Erstellen Sie hier einen neuen Wert mit dem Namen "MicrosoftRedirectionURL" als Datentyp REG_SZ, und geben Sie hier die URL ein, die angezeigt werden soll. Standardmäßig wird hier die URL "http://go.microsoft.com/fwlink/events.asp" angezeigt.

Erstellen Sie hier einen neuen Wert mit dem Namen "MicrosoftRedirectionProgram" als Datentyp REG_EXPAND_SZ und geben Sie hier das Programm an, welches beim Klicken auf den events.asp-Link ausgeführt wird. Standardmäßig ist hier "%SystemRoot%\PCHealth\HelpCtr\Binaries\HelpCtr.exe" eingetragen.

Erstellen Sie hier einen neuen Wert mit dem Namen "MicrosoftRedirectionProgramCommandLineParameters" als Datentyp REG_SZ, und geben hier die Kommandozeilenparameter an, die an das events.asp-Programm weitergegeben werden. Standardmäßig ist hier "-url hcp://services/centers/support?topic=%s" eingetragen. Dabei wird '%s' automatisch durch die URL des Links ersetzt.

Info Um den Informationsaustausch der Ereignisanzeige mit dem Internet zu unterbinden, müssen Sie den Eintrag "MicrosoftRedirectionProgramCommandLineParameters" von "-url hcp://services/centers/support?topic=%s" auf "-url hcp://services/centers/support?topic=" ändern.

Nach dieser Änderung ruft das Klicken des Links und die anschließende Bestätigung mit "Ja" die Hilfe auf, und es wird nicht versuchen, über das Internet auf weitere, das Ereignis betreffende Informationen zuzugreifen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Ereignisanzeige
Einstellungsname: | MicrosoftRedirectionURL: Events.asp-URL MicrosoftRedirectionProgram: Events.asp-Programm MicrosoftRedirectionProgramCommandLineParameters: Events.asp-Programm-Befehlszeilenparameter

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Sollte einer dieser Werte leer sein oder fehlen, wird der Link über ShellExecute direkt ausgeführt; das Löschen dieser Werte stellt keine Maßnahme zur Eindämmung der Internetkommunikation dar.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1923.htm


Durchsuchen von bestimmten Dateitypen geht nicht

Die Windows Dateisuche beachtet einige Dateitypen nicht, auch wenn es sich um einfache Textdatei handelt. Das ist durch einen kleinen Fehler In Windows passiert.

Dateien mit folgenden Endungen: .log, .dll, .js, .asp, .xml, .xsl, .hta, .css, .wsh, .cpp, .c, .php, .php2 oder .h können nicht nach Inhalt durchsucht werden. Selbst wenn diese Dateien das gesuchte Wort enthalten, werden sie nicht aufgelistet.

Bis Windows 2000 wurden alle Dateien nach dem angegebenen Text durchsucht, bei Windows XP will man durch Filter das Suchverhalten verbessern. Da für die oberen Dateitypen aber kein Filter definiert wurde, werden diese Dateien nicht durchsucht.

Um diesen Fehler zu beheben, müssen Sie diesen Dateitypen einen Standardfilter zuweisen. Gehen Sie dafür folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT

suchen Sie hier die entsprechende Dateiendung (z.B.:.cpp) und wählen "PersistentHandler". Ist der Schlüssel nicht vorhanden, müssen Sie den Schlüssel "PersistentHandler" selber anlegen. Setzen Sie den Wert (Standard) als Datentyp REG_SZ auf folgenden Wert: {5E941D80-BF96-11CD-B579-08002B30BFEB} für "Plain Text Persistent Handler".

Verfahren Sie so für jeden Dateityp, der durchsucht werden soll. Sind die entsprechenden Schlüssel nicht vorhanden, legen Sie sie an.

Für *.cpp müsste der komplette Eintrag so aussehen:

HKEY_CLASSES_ROOT\.cpp\ PersistentHandler\ (Standard)

Der Wert steht auf: {5E941D80-BF96-11CD-B579-08002B30BFEB}

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=309173

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1237.htm


Fehlermeldung bei der Benutzung des Windows Update-Services

Über dem Link "Windows Update" kommen Sie auf die Windows Updateseite, wo Sie sich die aktuellen Updates für Ihr Betriebssystem herunter laden können. Dafür ermittelt Windows automatisch, welche Updates Sie benötigen und zeigt diese an.

Dabei kann es zu der folgenden Fehlermeldung kommen:

Error number: 0x800A0046....

Um den Fehler zu beheben, müssen Sie folgenden Befehl in der Kommandozeile eingeben (Start -> Ausführen -> CMD.EXE).

=== Hier schneiden ===

scsdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)

=== Hier schneiden ===

Geben Sie diesen Befehl ohne Zeilenumbruch ein, anschließend müssen Sie folgende Rückmeldung erhalten:

[SC] SetServiceObjectSecurity SUCCESS

Jetzt sollte der Windows Update-Service wieder funktionieren. Durch diesen Befehl wird die Sicherheitseinstellung des Dienstes neu gesetzt, weitere Infos zu SC finden Sie im Tipp: Informationen über den Befehl SC.

Dieser Fehler tritt meist auf, wenn ein Rechner aus einer Domäne entfernt wurde und anschließend der Update-Service gestartet wird.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2029.htm


Fehlermeldung beim Öffnen von Worddateien über Wordpad

Nach der Installation von Service Pack 2 unter XP oder Service Pack 1 unter Windows 2003 kann es vorkommen, dass Sie mit Wordpad keine Worddateien mehr öffnen können.

Wenn Sie versuchen so eine Datei zu öffnen (z. B. ".doc" oder ".wri"), wird Ihnen die folgende Fehlermeldung angezeigt:

Word für Windows 6.0-Dateien können nicht geladen werden (Cannot load Word for Windows 6.0 files)

Ein Dokument kann mit WordPad geöffnet werden und sinnlose oder fehlerhafte Zeichen an Anfang und Ende der Datei enthalten.

Der Fehler kommt daher, dass durch die Installation des Service Packs der "Rich-Text-Format-Konverter" (RTF-Konverter) deaktiviert wird. Damit Sie diese Dokumente wieder öffnen können, müssen Sie folgendes Registryeintrag aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Wordpad

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableLegacyConverters" als Datentyp REG_DWORD und setzen den Wert auf:

0 | RTF-Konverter wird ausgeschaltet
1 | RTF-Konverter ist aktiv

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.Microsoft.com/?kbid=883090
 http://support.Microsoft.com/?kbid=870883

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2301.htm


Computer lässt sich nicht mehr ohne Fehler Runterfahren

Computer fährt nicht mehr fehlerlos herunter

Lässt sich der Computer nicht mehr ordnungsgemäß herunterfahren, wenn Sie ein z.B. USB-Gerät angeschlossen haben (Maus, Tastatur usw.) bzw. der Rechner stürzt nach einer gewissen Zeit ab oder der Rechner reagiert einfach nicht mehr, dann kann das an der aktivierten Energiesparverwaltung von Windows liegen.

In diesem Fall sollten Sie die Funktion für den USB-Hub ausschalten und gehen dazu wie folgt vor:

  • Starten Sie den Gerätemanager (devmgmt.msc)
  • Öffnen Sie USB-Controller im Tree
  • Klicken Sie jeweils auf die Einträge "USB-Root-Hub" mit der rechten Maustaste an, und wählen Sie aus dem Kontextmenü den Eintrag "Eigenschaften" aus
  • Wechseln Sie im Kontextmenü "Eigenschaften von USB-Root-Hub" auf den Tabreiter "Energieverwaltung", und entfernen Sie den Haken bei "Der Computer kann das Gerät ausschalten, um Energie zu sparen"
  • Da die meisten Rechner mehr als einen USB-Hub einsetzen, müssen Sie diese Einstellung für jeden USB-Root-Hub durchführen.

Wenn USB-Geräte diese Funktion unterstützen, führt das gerade bei Notebooks dazu, dass sich die Laufzeit der Akkus bei aktiver Funktion verlängert. Mit der Funktion "Computer kann das Gerät ausschalten, um Energie zu sparen" können Geräte, welche nicht mehr benutzt werden, heruntergefahren werden.

Wird das Gerät wieder gebraucht, dann wird das Gerät durch den Treiber automatisch wieder gestartet. Diese Funktion muss aber vom Gerät und dem Treiber auch unterstützt werden. Sie sollten diesen Funktion daher nicht generell ausschalten, sondern nur wenn es bei Ihnen zu Problem kommt.

Die Energiesparfunktion kann auch dazu führen, dass die Internetverbindung automatisch getrennt wird, wenn der Rechner längere Zeit nicht benutzt wird. Wenn das nicht gewünscht ist, müssen Sie die Funktion "Der Computer kann das Gerät ausschalten, um Energie zu sparen" für den Netzwerkadapter, welche die Internetverbindung herstellt ausschalten. Diesen finden Sie auch im Gerätemanager unter "Netzwerkadapter".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=315664

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2395.htm


Automatisches Abgleichen mit der Internetzeit deaktivieren

Wenn Sie diesen Wert aktivieren, wird das automatische Abgleichen der Computeruhr mit der Internetzeit ausgeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ W32Time\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "Type" als Datentyp REG_SZ. Setzen Sie den Wert auf:

Ntp | aktiv
NoSync | deaktiv

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1485.htm


Remote-Einstellungen ändern

Mit dieser Funktion können Sie die Remote-Einstellungen ändern. Dabei gibt es hier die Remoteunterstützung und den Remotedesktop.

- Bei der Remoteunterstützung kann Ihnen eine Person auf Anforderung helfen wie man eine Problem behebt.

- Beim Remotedesktop können Sie aus der Ferne auf den Rechner zugreifen und so arbeiten, als wenn Sie am Rechner direkt arbeiten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Terminal Server

ändern Sie hier die Werte:

Wert | Datentyp | Beschreibung | Remote sperren | Remote erlauben
fAllowToGetHelp | REG_DWORD | Ermöglicht das Senden von Remoteunterstützungsanforderungen | 0 | 1
fAllowFullControl | REG_DWORD | Remoteunterstützung: Remotesteuerung zulassen | 0 | 1
fDenyTSConnections | REG_DWORD | Remotedesktop (Benutzern erlauben auf Remote zuzugreifen) | 1 | 0

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1484.htm


Registrierung von Windows durchführen bzw. Seriennummer ändern

Nach der Installation von Windows werden Sie aufgefordert, eine Registrierung durchzuführen. Sie können aber die Registrierung auch später durchführen. Windows erinnert Sie dann immer in gewissen Abständen daran, dass die Registrierung noch vorgenommen werden muss.

Sie müssen aber nicht mit der Registrierung so lange warten, bis Windows sich wieder meldet, sondern können über "Start" -> "Ausführen" die Registrierung aktivieren.

Geben Sie hierzu folgendes ein: %systemroot%\system32\oobe\msoobe.exe /a

Ab Windows Vista wird dadurch der "Windows Einrichtungsassistent" gestartet

Info Das funktioniert nur so lange Sie Windows noch nicht registriert haben, danach zeigt die Eingabe keine Wirkung mehr.

Weiterhin können Sie damit auch einen ungültigen Produktkey ändern, dafür müssen Sie folgendermaßen vorgehen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ WPAEvents

hier finden Sie den Eintrag "OOBETimer", den Sie öffnen und den Eintrag beliebig abändern können. Dadurch wird der Eintrag ungültig und Windows ist nicht mehr registriert. Anschließend können Sie die Registrierung mit den oben angegebenen Aufruf (%systemroot%\system32\oobe\msoobe.exe /a) starten.

Wenn Sie jetzt "Ja, telefonisch über den Kundendienst aktivieren" auswählen, gibt es unten den Button "Product Key ändern". Klicken Sie auf den Button und geben Sie den neuen Key ein und klicken Sie dann auf "Aktualisieren". Windows schreibt nun den neuen Key zurück, jetzt können Sie das Fenster über den Button "Später erinnern" verlassen.

Damit können Sie einen Produktkey (CD-Key) ohne Neuinstallation von Windows ändern, falls ein ServicePack die Installation wegen eines ungültigen Keys verweigert.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=328874

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1216.htm


Öffnen/Speichern Dialogbox anpassen

Die Öffnen- und Speichern-Dialogboxen haben Standardmäßig schon eine separate Liste mit "Speziellen" Ordnern, einen Zurück-Button und eine Liste der zuletzt geöffneten Dateien/Ordner. Wenn Sie diesen zusätzlichen Einblendungen in der Dialogbox "Öffnen" bzw. "Speichern" ausblenden wollen, können Sie das über die folgenden Einträge in der Registry machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Comdlg32

Erstellen Sie folgende neuen Werte als Datenytp REG_DWORD und setzen die Werte auf 1.

Wert | Funktion
NoFileMRU | Entfernt die MRU-Liste (Zuletzt geöffnete Dateien/Ordner)
NoBackButton | Entfernt die "Zurück"-Schaltfläche
NoPlacesBar | Entfernt die Auswahlleiste

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Standarddialog "Datei öffnen"
Einstellungsname: | NoPlacesBar: Ortsleiste in Standarddialogen ausblenden NoBackButton:: Standarddialog "Zurück" ausblenden NoFileMRU: Dropdownliste der zuletzt verwendeten Dateien ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1339.htm


Erzwungener 'Abgesicherter-Modus'

Wenn Sie diesen Tipp aktivieren und danach den Rechner neu Starten, wird der PC im Abgesicherten-Modus gestartet, da es aber nicht über die Taste F8 eingeleitet wird, bekommt Windows das erst später mit, so dass die Grafikkartentreiber mit geladen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SafeBoot\ Option

Erstellen Sie hier einen neuen Wert mit dem Namen "OptionValue" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Abgesicherten Modus wieder beenden
1 | ohne Netzwerk
2 | mit Netzwerk

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1477.htm


Unterschiede zwischen Windows XP Home und Professional

Von Windows XP gibt es zwei Versionen. Die etwas "abgespeckte" Home-Version für den Privatanwender und die Professional Version für Firmen. Die Professional Version ist der Nachfolger für Windows 2000 und ist vom Leistungsumfang auch damit zu vergleichen.

Was sind aber nun die wesentlichen Unterscheide zwischen den Versionen?

Funktion: | Home-Version | Professional-Version
Backup | ja | ja
Remote Control | beschränkt | ja
Multiprozessorfähig | nein | ja
Dynamische Datenträger | nein | ja
Netwareunterstützung | nein | ja
Offline Dateien | nein | ja
Benutzerverwaltung | beschränkt | ja
Domäne-Mitgliedschaft | nein | ja
Mehrschirmbetrieb | nein | ja
NTFS-Verschlüsselung | nein | ja
Policies | nein | ja

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://www.microsoft.com/germany/ms/windowsxp/vergleich.htm

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1248.htm


Systemwiederherstellung konfigurieren

Sie können unter "Systemsteuerung" -> "System" auf der Registrierkarte "Systemwiederherstellung" die Einstellungen für die Systemwiederherstellung konfigurieren. Dort können Sie für die Laufwerke festlegen, wie viel Speicherplatz für die Systemwiederherstellung benutzt werden soll. Außerdem können Sie hier auch die Systemwiederherstellung für alle Laufwerke deaktivieren.

Sie können diese Funktion auch über die Registry direkt deaktivieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Aktivieren/Deaktivieren

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ SystemRestore

erstellen Sie einen neuen Eintrag mit dem Namen DisableSR als Datentyp REG_DWORD und setzen den Wert auf 1, um die Funktion auszuschalten bzw. wieder auf 0 zum Aktivieren dieser Funktion.

Jetzt müssen Sie noch den Dienst für die Systemwiederherstellung ausschalten.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SR

setzen Sie den Wert Start als Datentyp REG_DWORD auf 4 (deaktiviert) bzw. auf 0 zum Aktivieren.

Konfigurieren

Die Systemwiederherstellung erstellt nach konfigurierten Zeiten (24 Stunden) eine aktuelle Sicherung des Systems. Sie haben so die Möglichkeit, Veränderungen am System wieder zurückzusetzen, wenn Fehler im System aufgetreten sind.

Diese Sicherungen werden, wie oben geschrieben, entweder automatisch nach einer gewissen Zeit, oder bei der Installation von "nicht signierten Treibern", bei der Benutzung des Windows AutoUpdate und des Backupprogramms angelegt. Bei der Installation von Software mit dem Windows Installer oder mit Install ShieldPro ab Version 7 wird ebenfalls eine Sicherung angelegt.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ SystemRestore

Key | Datentyp | Beschreibung | Standard
DiskPercent | REG_DWORD | max. verwendeter Speicher pro Laufwerk in Prozent | 12
RPGlobalInterval | REG_DWORD | Zeit in Sekunden , bis die Wiederherstellung gestartet wird | 86400 (24 Stunden)
RPLifeInterval | REG_DWORD | Zeit in Sekunden wie lange eine Sicherung aufgehoben wird | 7776000 (90 Tage)
RPSessionInterval | REG_DWORD | Zeit in Sekunden , wie oft in einer aktiven Sitzung Sicherungen angelegt werden sollen | 0 (deaktiviert)
DisableConfig | REG_DWORD | 1 Deaktiviert die Systemwiederherstellung und entfernt den Tabreiter "Systemwiederherstellung" aus der Systemsteuerung -> System | 0

Welche Dateien und Verzeichnisse beachtet werden sollen, wird unter "%SYSTEMROOT%\system32\restore\filelist.xml" angegeben.

Info Der Wert "DiskPercent" ist auch noch unter "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ SystemRestore\ Cfg" vorhanden. Sie sollten beide Einstellungen auf den gleichen Wert einstellen! Der Grund für die beiden Einträge ist noch nicht bekannt.

Info Siehe auch Tipp "Ruhezeit bis ein Systemwiederherstellungspunkt erstellt wird"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1217.htm


Media Player mit höherer Bit-Rate

Mit den folgenden Einträgen können Sie den Media Player dazu bringen, MP3-Dateien auch mit einer höheren Bit-Rate als nur 32/64 Bit abzuspielen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ MediaPlayer\ Settings\ MP3Encoding

erstellen Sie folgende Einträge:

Name | Datentyp | Wert
LowRate | REG_DWORD | 96000
MediumRate | REG_DWORD | 128000
MediumHighRate | REG_DWORD | 192000
HighRate | REG_DWORD | 320000

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1359.htm


Liste der installierten Treiber

Mit dem Kommandozeilenbefehl "driverquery" können Sie sich auf der Kommandozeilenoberfläche eine Liste aller installierten Treiber mit Versionsinfo anzeigen lassen. Gehen Sie dazu folgendermaßen vor:

  1. Starten Sie die Kommandozeilenoberfläche per CMD.EXE
  2. Geben Sie den Befehl "driverquery" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1331.htm


Defragmentieren der BOOT-Dateien ein-/ausschalten

Windows bietet als neue Funktion die Möglichkeit, die BOOT-Dateien zu defragmentieren und an den Anfang der Partition zu legen, damit sie schnell geladen werden können. Standardmäßig ist diese Funktion aktiviert und kann unter dem folgenden Registry-Schlüssel ein- oder ausgeschaltet werden.

Info Damit diese Funktion läuft, müssen auch der Dienst "Taskplaner" und die "Windows-Firewall" (Internetverbindungsfirewall) aktiv sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Dfrg\ BootOptimizeFunction

finden Sie den Wert Enable als Datentyp REG_SZ, wo Sie mit Y für YES bzw. N für NO diese Funktion ein- oder ausschalten können.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Infos finden Sie im Tipp: "Auto-Layout-Service ein-/ausschalten" und "Bootvorgang beschleunigen (Prefetching)"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1266.htm


Backup-Funktion in der XP Home-Version nachinstallieren

Im Gegensatz zur Professional-Version muss das Backup-Programm in der Home-Version von Hand nachinstalliert werden. Dazu müssen Sie auf der CD im Verzeichnis "Valueadd\Msft\Ntbackup" die Datei "ntbackup.msi" anklicken. Nach der Installation steht Ihnen das Backup unter "Zubehör" -> "Systemprogramme" zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1249.htm


Erweiterte Funktionen der Wiederherstellungskonsole freischalten

Wenn Sie Windows XP in der Wiederherstellungskonsole starten, können Sie leider nur auf das Windows-Verzeichnis zugreifen. Das Diskettenlaufwerk ist gesperrt. Im einen Fehlerfall kann aber genau diese Beschränkung stören. Sie können die Beschränkungen mit folgenden Registrykey freischalten:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Setup\ RecoveryConsole

Erstellen Sie hier einen neuen Wert mit dem Namen "SetCommand" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Funktion ist aktiviert
0 | Funktion ist ausgeschaltet (Standard)

Jetzt können Sie über den SET Befehl die benötigten Rechte freischalten:

SET AllowAllPaths = True | Zugriff auf Pfade freischalten
SET AllowWildCards = True | Benutzung der Wildcard (*,? usw.) freischalten
SET AllowRemovableMedia = True | Zugriff auf Wechselmedien freischalten
SET NoCopyPrompt = True | Kopieren ohne Rückfrage

Bei Windows XP Prof können Sie das über eine Gruppenrichtlinie freischalten. Starten Sie Gpedit.msc.

Unter "Richtlinien für lokaler Computer" -> "Computerkonfiguration" -> "Windows-Einstellungen" -> "Sicherheitseinstellungen" -> "Lokale Richtlinien" -> "Sicherheitsoptionen" finden Sie den Eintrag "Wiederherstellungskonsole: "Kopieren von Disketten und Zugriff auf alle Laufwerke und Verzeichnisse zulassen". Aktivieren Sie diese Funktion.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1268.htm


Unnötige DLLs finden

Windows führt eine Liste aller DLLs die von mehreren Applikationen benutzt werden. In dieser Liste gibt Windows an, wie viele Programme sich für die DLL zurzeit registriert haben. Finden Sie in dieser Liste Einträge wo der Wert auf 0 steht, sind keine Programme mehr Registriert die diese DLL benötigen.

Sie können in so einem Fall die DLL aus dem Verzeichnis löschen und den Eintrag in der Registry entfernen.

Die Liste finden Sie in der Registry

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ SharedDLLs

Info Sie sollten die Registry sichern und DLL aufheben und erst endgültig löschen, wenn alles noch läuft. Es kann sein, dass es noch Programm gibt, die diese DLL benötigen, sich aber nicht richtig unter Windows registriert haben.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1501.htm


Concurrent Sessions aktivieren

In der Beta-Version vom "Service Pack 2" von Windows XP wird die sogenannte "Concurrent Sessions" Funktion unterstützen. Unter Concurrent Sessions (Simultane Verbindungen), versteht man die Technologie, die es ermöglicht, dass sich zwei Benutzer gleichzeitig an einem System anmelden und auch damit arbeiten können. So kann sich ein lokaler Benutzer anmelden und zusätzlich einer, der von der Ferne mit Remote auf dem Rechner arbeitet.

Leider geht das nicht mehr in der aktuellen Version vom "Service Pack 2". Wenn Sie aber noch mit der Beta-Version arbeiten, können Sie diese Funktion über den folgenden Registrykey aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Terminal Server\ Licensing Core

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableConcurrentSessions" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Es wird die Willkommenseite verwendet
0 | Es wird die klassische Anmeldeseite verwendet

Info Vieleicht wird diese Funktion später in ein aktuelleres Service Pack wieder eingebaut

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1824.htm


Windows XP Home nach Windows XP Pofessional umstellen

Windows XP Home nach Windows XP Professional umstellen

Info Hinweis: Die aufgeführten Änderungen dürfen nur ausgeführt werden, wenn Sie auch eine entsprechende Lizenz für diese Windows Version besitzen (siehe dazu auch CT 15/2005, Seite 50).

Wenn Sie die Home Version von Windows XP installiert haben, ist diese Version um einige Funktionen beschnitten. Gegenüber der Windows XP Professional-Version, fehlt hier z.B. die Möglichkeit, über eine GUI-Oberfläche die Rechte für Verzeichnisse und Dateien zu setzen und zu verändern. Weiterhin stehen die erweiterten Dateifreigaben, RunAs-Funktion und die Domänen-Anbindung nicht zur Verfügung.

Diese Funktion wurde aber nicht richtig aus der Home-Version entfernt, sondern der Zugriff wurde nur über die Registry deaktiviert.

Es gibt mehrere Möglichkeiten, diese Funktion zu aktivieren, dazu gehört z.B. die Möglichkeit, die Datei "setupreg.hiv" - wie in der CT 12/2005 beschrieben - entsprechend anzupassen. Einen weitere Möglichkeit ist das Verändern des Registrywertes nach der Installation, was dort ebenfalls beschrieben wurde.

Die Änderung der Einstellung ist aber nicht so leicht möglich, da dieser Schlüssel von MS zur Laufzeit überwacht wird und deshalb nicht geändert werden kann. Wenn Sie versuchen, diesen Wert zu ändern, bekommen Sie eine Fehlermeldung, dass eine Lizenzverletzung vorliegt und der Wert wird somit nicht geändert.

Entweder booten Sie also über ein 2-System den Rechner und laden von dort aus die Registry, um den Wert zu ändern oder aber, Sie machen das über den "Registry System Wizard" , wie folgt beschrieben:

  1. Starten Sie den "Registry System Wizard" ab der Version 1.6.5
  2. Erstellen Sie ein Backup Ihrer Registry über das Menü "Datei" -> "Registry Sichern/Herstellen" -> Button "Sichern" und geben Sie dafür einen beliebigen Namen ein.
  3. Laden Sie anschließend dieses Backup mit dem RSW, um dort die Änderung vornehmen zu können:
  4. Menü "Datei" -> "Registy Datei laden/entladen"
  5. Klicken Sie im Bereich "Maschien Registrydatei laden" bei "System Registry laden (z.B.: System)" auf den Button "...", um die Datei auszuwählen.
  6. Gehen Sie dafür in das Backupverzeichnis (welches standardmäßig unterhalb des "RSW"-Verzeichnis angelegt wird), hier z.B.: (C:\Programme\Registry System Wizard\Backup\<TestPC>\<Name>\Windows XP 5.1.2600\2005-09-20_23-39-16). Der Pfad unterscheidet sich natürlich bei Ihnen, da es sich dabei um:
    <TestPC>: Name des Rechners
    <name>: Name des Anwenders (Angemeldeter USER)
    <Windows XP 5.1.2600>: Windows Version (sollte gleich sein)
    <2005-09-20_23-39-16>: Datum und Uhrzeit des Backups
  7. In diesem Verzeichnis markieren Sie die Datei "RSW_HKLM_SYSTEM.bin", um sie zu laden
  8. Klicken Sie auf den Button "Laden", der Button wechselt jetzt in "Entladen"
    WinXP Home to Prof
  9. Verlassen Sie das Fenster über den Button "OK"
  10. Unter dem Menü "Datei" den Eintrag "Tipps auf geladene Struktur anwenden" anklicken und aktivieren
    WinXP Home to Prof
  11. Laden Sie jetzt den Tipp "Windows XP Home nach Windows XP Professional umstellen"
  12. Ändern Sie die Einstellung auf Ihren gewünschten Wert und klicken Sie auf "Speichern":
    WinXP Home to Prof
  13. Über das Menü "Datei" -> "Registy Datei laden/entladen" entladen Sie jetzt diese Struktur wieder über den Button "Entladen".
  14. Über das Menü "Datei" -> "Registry Sichern/Herstellen" wählen Sie jetzt das Backup aus, wo Sie die Datei gerade bearbeitet haben und klicken auf den Button "Herstellen".
  15. Hier wird jetzt ein neues Fenster geöffnet, in dem angezeigt wird, um welches Backup es sich handelt und welche Key wieder hergestellt werden sollen.Da wir nur den Key "System" verändert haben, sollten Sie hier alle Häkchen - außer das bei "Key System herstellen" - entfernen. Anschließend drücken Sie auf den Button "Herstellen":

  16. Starten Sie den Rechner danach wieder neu.

Info Weitere Infos zum Bedienung des "Registry System Wizard" finden Sie in der Hilfe von Programm.

Hier jetzt noch die Übersicht, welche Werte in der Registry geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ ProductOptions

finden Sie den Wert mit dem Namen "ProductSuite" als Datentyp REG_MULTI_SZ. Setzen Sie den Wert auf:

Personal | Windows XP Home
<leer> | Windows XP Professional

Wie man sieht, enthält der Wert unter "Windows XP Professional" keinen Eintrag. Sie müssen hier also einfach nur den Text "Personal" löschen.

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Lsa

finden Sie den Wert mit dem Namen "ForceGuest" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Windows XP Home
0 | Windows XP Professional

Info Wenn Sie die Registrydatei über einen anderen Rechner laden, gibt es den Eintrag "CurrentControlSet" nicht, hier müssen Sie in "ControlSet00x" gehen. Welches gerade die aktuelle Zweignummer (x) ist die geladen wird, finden Sie unter: "HKEY_LOCAL_MACHINE\ SYSTEM\ Select" im Wert "Default". Ersetzen Sie das X durch diese Nummer.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2010.htm


BIOS und Systeminformationen in der Registry

Wenn Windows startet, werden Informationen zum System ausgelesen und in der Registry abgelegt. Diese Informationen finden Sie unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ HARDWARE\ DESCRIPTION\ System

finden Sie die Einträge für System_BIOS und dem Video_BIOS:

SystemBiosDate

SystemBiosVersion

VideoBiosDate

VideoBiosVersion

unter den Schlüssel "CentralProcessor" finden Sie für jeden vorhandenen Prozessor einen weiteren Schlüssel mit entsprechenden Informationen.

Info Es handelt sich hierbei nur um Informationen. Das Ändern von Einträgen bringt nichts, da diese Werte bei jedem Neustart vom System erstellt werden!

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2047.htm


Ruhezeit bis ein Systemwiederherstellungspunkt erstellt wird

Windows legt automatisch Systemwiederherstellungspunkte (Snapshot) an, damit im Fehlerfall auf eine alte Konfiguration zurückgegriffen werden kann.

Mit diesem Parameter legen Sie fest, wie lange der Rechner nicht beschäftigt sein darf (Idle Time), bevor der Job zum Erstellen eines Systemwiederherstellungspunktes gestartet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ SystemRestore

ändern Sie hier den Wert "ThawInterval" als Datentyp REG_DWORD und geben Sie die Zeit in Sekunden ein. Der Standardwert ist 900 (15 Minuten).

Info Siehe auch Tipp: "Systemwiederherstellung konfigurieren"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2052.htm


Windows WGA-Echtheitsprüfung entfernen

Windows WGA-Echtheitsprüfung (auf legalen CD-KEY) entfernen

Mit dem Patch KB905474 hat Microsoft die WGA (Windows Genuine Advantage) Echheitsprüfung eingeführt. Wenn dieses Update installiert wurde, prüft ein Programm, ob das Betriebssystem mit einem legalen CD-KEY installiert wurde.

Stellt das Tool fest, dass es sich um einen illegalen CD-KEY handelt, wird ein entsprechende Meldung ausgegeben. Diese Meldung muss dann immer bestätigt werden.

Weitere Infos zur WGA von Microsoft finden Sie hier: http://www.microsoft.com/genuine/downloads/WhyValidate.aspx.

Sie haben nur die Möglichkeit, die automatische Installation zu verhindern, wenn Sie in den Optionen vom "Automatische Updates", die Auswahl "Benachrichtigen, aber nicht automatsich downloaden oder installieren" aktiviert haben. Die Einstellung finden Sie unter "Start" -> "Einstellungen" -> "Systemsteuerung" -> "Automatische Updates".

Wenn dieses Patch einmal installiert ist, bittet Microsoft selber keinen Möglichkeit an, diesen Patch zu entfernen.

Über Ihre Registry können Sie das Programm aber auch selber entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon\ Notify

löschen Sie den ganzen Schlüssel "WgaLogon"

und zum entfernen des Uninstalleintrages:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall

löschen Sie den ganzen Schlüssel "WGA"

Datei Sie auch noch die Dateien loswerden, müssen Sie folgendes machen:

  • Im Verzeichnis "%WINDIR%\System32" die Dateien "WgaLogon.dll" und "WgaTray.exe" umbenennen (z.B. in WgaLogon.dll.old und WgaTray.exe.old). Das geht über die Kommandozeile mit dem Befehl "rename".
    Beispiel: rename WgaLogon.dll WgaLogon.dll.old
  • Anschließend den Rechner neu starten
  • Jetzt müssen Sie noch die DLL "LegitCheckControl.dll" deregistrieren, geben Sie dafür folgendes ein:

    • regsvr32 %WINDIR%\system32\LegitCheckControl.dll -u

  • Anschließend den Rechner neu starten
  • Jetzt können Sie noch die Umbennten Dateien und die LegitCheckControl.dll löschen:

    • del %WINDIR%\system32\LegitCheckControl.dll /Q

    del %WINDIR%\system32\WgaLogon.dll.old /Q

    del %WINDIR%\system32\WgaTray.exe.old /Q

Zum Eingeben der Befehle müssen Sie die Eingabeaufforderung (Start -> Ausführen -> CMD.EXE) öffnen. Zwischen den Verzeichnissen wechseln Sie mit "CD [Verzeichnisname]" bzw. gehen mit "CD .." ein Verzeichnis zurück (enthält ein Verzeichnisname Leerzeichen, dann müssen Sie den Namen in "" einschließen.

Info Beim nächsten Ausführen des Windowsupdates, müssen Sie jetzt darauf achten, dass Sie dieses Update nicht wieder auswählen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2072.htm


Remoteunterstützung anbieten

Mit diesem Tipp können Sie einstellen, ob Supportpersonen und Administratoren für den Rechner die Remoteunterstützung anbieten können, ohne dass ein Benutzer diese zuerst explizit über einen Kanal, über Email oder Instand Messenger anfordert.

Wird eine Firewall verwendet, dann müssen der Port 135 sowie die folgenden Anwendungen freigeschaltet werden: Sessmgr.exe, Helpsvc.exe und Helpctr.exe

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows NT\ Terminal Services

ändern Sie hier den Wert "fAllowUnsolicited" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Remoteunterstützung kann ohne Aufforderung angeboten werden
0 | Remoteunterstützung kann nicht ohne Aufforderung angeboten werden (Standard)

ändern Sie hier den Wert "fAllowUnsolicitedFullControl" als Datentyp REG_DWORD und setzen Sie den Wert auf:

1 | Helfer dürfen den Computer Remoute steuern
0 | Helfer dürfen den Computer nur ansehen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Remoteunterstützung
Einstellungsname: | Remoteunterstützung anbieten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2105.htm


Port für Remoteverbindung ändern

Über die Remoteverbindug können Sie auf andere Rechner zugreifen und damit den Anwender unterstützen.

Der Remote-Desktop-Server läuft standardmäßig auf dem Port 3389. Da dieser Port allgemein bekannt ist, entsteht dadurch eine Sicherheitslücke, weshalb es besser; ist diese Einstellung zu ändern.

Sie können den Port in der Registry mit folgendem Eintrag verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Terminal Server\ WinStations\ RDP-Tcp

Erstellen Sie hier einen neuen Wert mit dem Namen "PortNumber" als Datentyp REG_DWORD. Geben Sie hier die neue Portnummer ein. Nach einem Neustart läuft der Remote Desktop auf dem neuen Port.

Damit Sie von einem Client auf den Rechner zugreifen können, müssen Sie die Portnummer jetzt bei der Verbindung mit angeben. Dafür hängen Sie die Portnummer mit einem Doppelpunkt getrennt an die Adresse des fernzusteuernden Rechners an (Beispiel: winfaqpc:52777).

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2191.htm


Energie-Einstellungen lassen sich nur mit administrativen Rechten ändern

Ist man auf einem Rechner als Anwender mit eingeschränkten Rechten angemeldet, kann man weder das Energieschema wechseln bzw. noch ein eingestelltes Schema ändern.

Gerade auf Notebooks kann es aber schon recht sinnvoll sein, z.B.: den Prozessortakt zu ändern, damit die Standzeit der Accus verlängert wird.

Wenn Sie das Energieschema von Windows auch als normaler Anwender verändern wollen, müssen Sie die Rechte des folgenden Registryschlüssels ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Controls Folder\ PowerCfg

Verändern Sie die Rechte auf die Schlüssel "GlobalPowerPolicy" und "PowerPolicies". Klicken Sie dafür die Schlüssel mit der rechten Maustaste an. Wählen Sie aus dem Kontextmenü den Eintrag "Berechtigungen" aus. Klicken Sie im neuen Fenster "Berechtigungen für [Schlüsselname]" auf den Button "Erweitert"

In neuen Fenster wählen Sie jetzt unter "Berechtigungseinträge" den Eintrag "Benutzer..." aus und klicken Sie auf den Button "Bearbeiten".

Geben Sie im neuen Fenster nun die Rechte "Wert festlegen" und "Unterschlüssel erstellen" ein.

Dieses müssen Sie machen - wie oben geschrieben - für die Schlüssel:

  • HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Controls Folder\ PowerCfg\ GlobalPowerPolicy
  • HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Controls Folder\ PowerCfg\ PowerPolicies

Jetzt können alle Anwender auch die Energie-Einstellungen verändern.

Info Sie können natürlich auch eine neue Gruppe oder einen Benutzer hinzufügen und nur hier die zusätzlichen Rechtevergeben. Damit können Sie diese Funktion nur für bestimmte Anwender freigeben.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2192.htm


Windows XP Professional Funktion unter Windows Media Center Edition aktivieren

Wenn Sie die Windows Media Center Edition (MCE) installiert haben, können Sie durch einen Eintrag in der Registry die folgenden eingeschränkten Funktionen aktivieren. Dabei handelt es sich um:

  • Nur bei der Installation kann die MCE in eine Domäne eingebunden werden, nach der Installation nicht mehr
  • Der Parameter /savecred vom Befehl RUNAS funktioniert nicht

Info Die aufgeführten Änderungen dürfen nur ausgeführt werden, wenn Sie auch eine entsprechende Lizenz für diese Windows Version besitzen.

Die Änderung der Einstellung ist aber nicht so leicht möglich, da dieser Schlüssel von MS zur Laufzeit überwacht wird und deshalb nicht geändert werden kann. Wenn Sie versuchen, diesen Wert zu ändern, bekommen Sie eine Fehlermeldung, dass eine Lizenzverletzung vorliegt und der Wert wird somit nicht geändert.

Entweder booten Sie also über ein 2-System den Rechner und laden von dort aus die Registry, um den Wert zu ändern oder aber, Sie machen das über den "Registry System Wizard"(siehe dazu Tipp: "Windows XP Home nach Windows XP Professional umstellen").

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ SYSTEM\ WPA\ MedCtrUpg

finden Sie den Wert mit dem Namen "isLegacyMCE" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Einschränkungen sind aktiv
1 | Keine Einschränkungen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2537.htm


Idle-Tasks (Ruhezeit-Aktivitäten) sofort starten

Windows geht in den Idle-Modus, wenn Windows über einen längeren Zeitraum keine Benutzerinteraktionen mehr registriert. In diesem Modus werden bestimmte Aufgaben (Ruhezeit-Aktivitäten) im Hintergrund mit geringer Priorität ausgeführt. Zu diesen Aufgaben gehören:

  • Erstellen von Systemwiederherstellungspunkten
  • Online-Defragmentierung der Festplatte
  • Optimierung der Systemdateien (siehe Tipp: Defragmentieren der BOOT-Dateien ein-/ausschalten)

Wenn Sie diese Aktionen sofort ausführen möchten (z.B. um einen Benchmark-Test laufen zu lassen), können Sie diesen Task über den folgenden Aufruf starten:, indem Sie dafür unter Start -> Ausführen ([Windows Taste] + [R]) folgenden Befehl eingeben:

Rundll32.exe advapi32.dll,ProcessIdleTasks

Durch diesen Befehl, starten Sie das Abarbeiten der Idle-Tasks asynchron im Hintergrund, was je nach Rechner und nötigen Arbeiten bis zu 10 Minuten dauern kann.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2634.htm


Protokoll für Ereignisprotokollierung beim Herunterfahren anzeigen

Protokoll anzeigen für Ereignisprotokollierung beim Herunterfahren

Mit dieser Policy können Sie einstellen, ob beim Herunterfahren die Ereignisprotokollierung aufgerufen werden soll. In diesem Ereignisprotokoll kann der Grund für das Herunterfahren festgehalten werden, welches in die Ereignisanzeige eingetragen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Reliability

Erstellen Sie hier einen neuen Wert mit dem Namen "ShutdownReasonOn" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Protokoll ist aktiv
0 | Protokoll ist nicht aktiv

Weiterhin erstellen Sie einen neuen Wert mit den Namen "ShutdownReasonUI" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Alle Rechner
2 | Wird nur bei Windows XP Workstation angezeigt
3 | Wird nur bei Servern ab 2003 angezeigt

Wenn der Wert nicht konfiguriert ist, gilt folgender Standard:

Windows 2003: aktiv

Windows XP: deaktiv

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1568.htm


Schreiben der Systemstatusdaten in das Ereignisprotokoll konfigurieren

Das Schreiben der Systemstatusdaten ins Ereignisprotokoll konfigurieren

Mit dieser Funktion legen Sie fest, ob im Ereignisprotokoll die Protokollierung beim Herunterfahren für die Systemstatusdaten aktiviert werden soll. In den Systemstatusdaten sind alle Informationen über die laufenden Prozesse und den Systemzustand abgelegt.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Reliability

Erstellen Sie hier einen neuen Wert mit dem Namen "SnapShot" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Systemstatus schreiben (Standard bei Server 2003)
0 | Systemstatusdaten nicht schreiben

Wenn Sie die Funktion aktivieren und das System wird ungeplant heruntergefahren, werden die Systemstatusinformationen in der Ereignisanzeige abgelegt, ansonsten werden diese Informationen nicht abgelegt.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Administrative Vorlagen\System
Einstellungsname: | Systemstatusdatenfeature in "Ereignisprotokollierung für Herunterfahren" aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1569.htm


Serververwaltung bei der Anmeldung nicht anzeigen

Mit dieser Policy legen Sie fest, ob die automatische Anzeige der Serververwaltungsseite nach der Anmeldung angezeigt werden soll.

Wird dieser Wert aktiviert, wird die Seite bei der Anmeldung eines Anwenders nicht mehr angezeigt. Ist der Wert nicht konfiguriert oder aktiv, wird die Seite so lange angezeigt, bis der Anwender das Kontrollkästchen unten auf der Seite aktiviert hat.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ CurrentVersion\ MYS

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableShowAtLogon" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Wird nicht angezeigt
0 | Wird angezeigt (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1567.htm


Verwendung der Domänenressourcen zur Überwachung verteilter Verknüpfungen

Mit dieser Policy legen Sie fest, dass die Clients mit "Distributed Link Tracking" innerhalb einer Domäne arbeiten.

Dabei bleiben Verknüpfungen erhalten, wenn Anwendungen auf NTFS-Laufwerken in andere Ordner, oder sogar anderen Computern verschoben werden. Die Verknüpfungen zeigen dann nicht ins leere, sondern werden auf den neuen Pfad angepasst. Diese Funktion läuft besser, wenn der Client zur Überprüfung von verteilten Verknüpfungen den Server verwenden darf.

Diese Policy sollte nur aktiviert werden, wenn auf allen Domain Controllern der DLT-Server läuft.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "DLT_AllowDomainMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Funktionen aktivieren
0 | Funktion deaktiv

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1573.htm


Anwendungskompatibilitäts-Mechanismus ausschalten

Mit diesem Tipp können Sie einstellen, ob der Anwendungskompatibilitäts-Mechanismus des Systems deaktiviert sein soll.

Der Mechanismus ist Teil des Ladeprogramms von Anwendungen und durchsucht bei jedem Start einer Anwendung eine Kompatibilitätsdatenbank. Wenn eine Anwendung dort gefunden wird, werden entweder Laufzeitlösungen oder Kompatibilitätspatches angeboten oder eine Hilfemeldung der Anwendung ausgegeben, falls das Problem bekannt ist.

Die Systemleistung erhöht sich, wenn der Anwendungskompatibilitätsmechanismus abgeschaltet wird. Dadurch wird jedoch die Kompatibilität mit einer Reihe von gängigen älteren Anwendungen herabgesetzt und es können auch bekanntermaßen inkompatible Anwendungen installiert werden.

Diese Option ist nützlich, wenn die Geschwindigkeit des Servers heraufgesetzt werden soll und die Kompatibilität der eingesetzten Anwendungen bekannt ist. Insbesondere ist dies auf einem Webserver nützlich, auf dem Anwendungen möglicherweise mehrere hundert Mal pro Sekunde gestartet werden und die Leistung des Ladeprogramms entscheidend ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableEngine" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Anwendungskompatibilitätsmechanismus ausschalten
gelöscht | Anwendungskompatibilitätsmechanismus ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Anwendungskompatibilitäts-Mechanismus ausschalten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1919.htm


Systemzeitstempel konfigurieren

Mit dieser Funktion können Sie einstellen, dass Ihr System in dem angegeben Zeitinterwall immer einen aktuellen Zeitstempel auf die Festplatte schreibt. Anhand dieser Informationen, kann man die Zeit für einen unerwarteten Systemausfall ermitteln.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ Relability

Erstellen Sie hier einen neuen Wert mit dem Namen "TimeStampEnabled" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Zeitstempel aktiv (Standard)
0 | Zeitstempel deaktiv

Erstellen Sie hier einen neuen Wert mit dem Namen "TimeStampInterval" als Datentyp REG_SZ. Geben Sie die Zeit in Sekunden an.

Der Zeitstempel wird standardmäßig alle 60 Sekunden erneuert.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1570.htm


Programm-Kompatibilitäts-Assistent ausschalten

Mit diesem Tipp können Sie einstellen, ob der Programm-Kompatibilitäts-Assistent aktiviert ist

Wenn Sie diesen Tipp aktivieren, werden die Startseiten des Assistenten im Hilfe- und Supportcenter und im Startmenü deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableWizard" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Programmkompatibilitäts-Assistent ausschalten
gelöscht | Programmkompatibilitäts-Assistent ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Programm-Kompatibilitäts-Assistent ausschalten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1920.htm


Programm-Kompatibilitäts-Eigenschaftenseite entfernen

Mit diesem Tipp können Sie die Anzeige der Programm-Kompatibilitätsseite steuern.

Diese Shellerweiterung befindet sich in den Eigenschaften einer ausführbaren Datei oder einer Programmverknüpfung und lässt sich über das Kontextmenü anzeigen.

Die Programm-Kombatibilitätsseite enthält eine Liste von Optionen, mit denen sich die bekanntesten Probleme im Zusammenhang mit älteren Anwendungen lösen lassen. Wenn Sie diesen Tipp aktivieren, wird die Eigenschaftenseite vom Kontextmenü entfernt. Kompatibilitätseinstellungen, die zuvor über diese Seite vorgenommen wurden, werden dadurch nicht verändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePropPage" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Programmkompatibilitäts-Eigenschaftenseite ausschalten
gelöscht | Programmkompatibilitäts-Eigenschaftenseite ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Programm-Kompatibilitäts-Eigenschaftenseite entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1921.htm


Aufzeichnung von Anwendungshilfeereignissen einschalten

Mit diesem Tipp können Sie einstellen, ob Ereignissen der Anwendungshilfe im Anwendungsprotokoll eingetragen werden sollen.

Durch die Anwendungshilfe werden bekannte inkompatible Anwendungen blockiert. Es erscheint ein Dialogfeld, welches je nach Problem Weblinks zum Download von Anwendungsupdates, Schritte zur Umgehung des Problems oder grundlegende Information zur Inkompatibilität beinhalten kann.

Wenn Sie diesen Tipp aktivieren, wird die Aufzeichnung von Ereignissen der Anwendungshilfe im Anwendungsprotokoll eingeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "LogAppHelpEvents" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Meldungen aufzeichnen
gelöscht | Meldungen nicht aufzeichnen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Aufzeichnung von Anwendungshilfeereignissen einschalten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1922.htm


Internetzugriff durch Windows Media DRM verhindern

Wenn Sie diesen Tipp aktivieren, wird Windows Media Digital Rights Management (DRM) daran gehindert, auf das Internet (oder Intranet) zuzugreifen. Dadurch ist es dem Programmen nicht möglich, Lizenzen für sichere Inhalte zu erhalten, Windows Media DRM-Sicherheitskomponenten zu aktualisieren oder gesicherte Lizenzen für Inhalte wiederherzustellen.

Sichere Inhalte, die bereits auf dem lokalen Computer lizenziert sind, können weiterhin wiedergegeben werden. Es besteht auch die Möglichkeit, von CD kopierte Musik zu schützen und den geschützten Inhalt auf dem Computer wiederzugeben, da die Lizenz in diesem Fall lokal erzeugt wird.

Standardmäßig wird eine Verbindung zum Internet (oder Intranet) hergestellt, um Lizenzen zu erwerben, Sicherheitsupdates zu downloaden und Lizenz-Wiederherstellungen durchzuführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WMDRM

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableOnline" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Internetzugriff unterbinden
0 | Internetzugriff zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Digital Rights Management
Einstellungsname: | Internetzugriff durch Windows Media DRM verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1926.htm


Automatische Updates über Updateservice bereitstellen

Mit diesem Tipp legen Sie fest, dass sowohl wichtige wie auch empfohlene Updates über den Windows Updateservice "WSUS" bereitgestellt werden. Wenn Sie diesen Tipp aktivieren, werden diese Updates über den Windows Update-Aktualisierungsdienst installiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "IncludeRecommendedUpdates" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Updateservice stellt ausschließlich Updates bereit
0 | Updates können auch von "Automatische Updates" installiert werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Updater
Einstellungsname: | Empfohlene Updates über automatische Updates aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2313.htm


Windows-Update kann Rechner für die Updateinstallation aktivieren

Mit diesem Tipp können Sie einstellen, ob über den Windows-Updateservice (WSUS) der/die Rechner über Energieverwaltungsfeatures automatisch aus dem Ruhezustand aktiviert werden können, um verfügbare Updates zu installieren.

Der Window- Updateservice reaktiviert den Rechner nur dann automatisch, wenn Windows Updates für die automatische Installation von Updates konfiguriert sind. Weiterhin muss sich der Rechner beim Erreichen des Installationszeitpunktes im Ruhezustand befinden und muss am Stromnetz (nicht über Akkus) angeschlossen sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ WindowsUpdate\ AU

Erstellen Sie hier einen neuen Wert mit dem Namen "AUPowerManagement" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Rechner wird automatisch gestartet
0 | Rechner wird nicht automatisch gestartet (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Updater
Einstellungsname: | Windows Update-Energieverwaltung aktivieren, um das System zur Installation von geplanten Updates automatisch zu reaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2315.htm


Nach der PC-Wiederherstellung gibt es Probleme bei der Installation von Programmen

Wenn Sie über das Programm "Complete PC-Sicherung", welches Sie in "Sicherungsstatus und -konfiguration" (SDCLT.EXE) finden, ein Backup Ihres Systems erstellen und es später über die Systemwiederherstellungsoptionen zurückspielen, können keine Programme mehr installiert werden. Es wird meistens folgende Fehlermeldung angezeigt: Der Verzeichnis-Name ist ungültig.

Der Fehler kommt daher, da viele Programme bei der Installation Dateien im TEMP-Verzeichnis ablegen wollen. Das Backup-Programm von Windows, sichert das TEMP-Verzeichnis aber nicht mit und legt bei der Wiederherstellung auch kein TEMP-Verzeichnis mehr an.

Damit Sie wieder Programme installieren können, müssen Sie folgendes machen:

  • Starten Sie die Eingabeaufforderung mit administrativen Rechten
  • Erstellen Sie mit dem folgenden Befehl das Tempverzeichnis

MD %WINDIR%\temp

  • Jetzt müssen Sie nur noch die Rechte auf das Verzeichnis anpassen:

%WINDIR%\temp ICACLS /grant "BUILTIN\Users:(CI)(S,WD,AD,X)" "BUILTIN\Administrators:(F)" "BUILTIN\Administrators:(OI)(CI)(IO)(F)" ""NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)" NT AUTHORITY\SYSTEM:(F) CREATOR OWNER:(OI)(CI)(IO)(F)"

Kopieren Sie den Befehl so raus und führen Sie Ihn in der Eingabeaufforderung aus. Anschließend können Sie wieder Programme fehlerfrei installieren.

Info Geben Sie den Befehl in einer Zeile und unter Beachtung der Anführungszeichen ein

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://supsupport.microsoft.comport.Microsoft.com/?kbid=932142

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2305.htm


Starten der Anwendung "Sicherungsstatus und -konfiguration" nicht zulassen

Mit diesem Tipp können Sie das Starten der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) unterbinden. Wenn Sie den Tipp aktivieren, können normale Anwender dieses Anwendung nicht mehr starten. Über diese Anwendung haben Sie Zugriff auf die Datensicherung, Dateiwiederherstellung und die Komplette PC-Sicherung. Weiterhin wird Ihnen hier noch der aktuelle Sicherungsstatus angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupLauncher" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Die Anwendung kann nicht gestartet werden
0 | Die Anwendung kann gestartet werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Ausführen des Programms Sicherungsstatus- und -konfiguration durch Benutzer nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2302.htm


Eintrag "Complete PC-Sicherung" aus "Sicherungsstatus und -konfiguration" entfernen

Mit diesem Tipp entfernen Sie den Eintrag "Complete PC-Sicherung" aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE). Wenn Sie den Tipp aktivieren, wird diese Funktion nicht mehr im Sicherungscenter zur Auswahl angeboten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableSystemBackupUI" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag "Complete PC-Sicherung" ausblenden
0 | Eintrag "Complete PC-Sicherung" anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Funktion "Complete PC-Sicherung" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2303.htm


Sicherung auf lokale Datenträger unterbinden

Mit diesem Tipp können Sie verhindern, dass für die Datensicherung kein lokaler (interner oder externer) Datenträger benutzt werden kann. Wenn Sie den Tipp aktivieren, können keine lokalen Datenträger für die Sicherung aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) ausgewählt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupToDisk" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Lokale Datenträger für die Sicherung sperren
0 | Lokale Datenträger für die Sicherung zulassen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Sicherung auf lokalen Datenträgern verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2304.htm


Sicherung auf optischen Medien (CDR/DVD) unterbinden

Mit diesem Tipp können Sie verhindern, dass für die Datensicherung keine optische Medien (CDR/DVD) benutzt werden kann. Wenn Sie den Tipp aktivieren, können keine optische Medien für die Sicherung aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) ausgewählt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupToOptical" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Optischen Medien für die Sicherung sperren
0 | Optischen Medien für die Sicherung zulassen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Sicherung auf optischen Medien (CDR/DVD) nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2306.htm


Sicherung auf Netzwerkfreigaben unterbinden

Mit diesem Tipp können Sie verhindern, dass für die Datensicherung Netzwerkfreigaben benutzt werden kann. Wenn Sie den Tipp aktivieren, können keine Netzwerkfreigaben für die Sicherung aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) ausgewählt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupToNetwork" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Netzwerkfreigaben für die Sicherung sperren
0 | Netzwerkfreigaben für die Sicherung zulassen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Sicherung in freigegebenem Netzwerkordnern nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2307.htm


Funktion "Daten sichern" aus "Sicherungsstatus und -konfiguration" sperren

Mit diesem Tipp können Sie verhindern, dass die Funktion "Daten sichern" aufgerufen werden kann. Wenn Sie den Tipp aktivieren, kann die Funktion "Daten sichern" aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) nicht mehr ausgewählt werden. Es können keine Sicherungen von Daten mehr angelegt (Backup) werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupUI" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Zugriff auf "Daten sichern" sperren
0 | Zugriff auf "Daten sichern" zulassen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Sicherungskonfiguration deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2308.htm


Vista Versionen (Übersicht)

Microsoft bringt Windows Vista in 5 unterschiedlichen Versionen raus. Hier finden Sie eine Übersicht über die Unterschiede in den Versionen.

 | Home Basic | Home Premium | Busines | Enterprise | Ultimate
CPUs | 1 | 1 | 2 | 2 | 2
Dual-Core-CPU | Ja | Ja | Ja | Ja | Ja
Maximal Speicher (32 Bit) | 4 GB | 4 GB | 4 GB | 4 GB | 4 GB
Maximal Speicher (64 Bit) | 8 GB | 16 GB | 128 GB | 128 GB | 128 GB
Aero Oberfläche | Nein | Ja | Ja | Ja | Ja
Media Center | Nein | Ja | Nein | Nein | Ja
Jugendschutz | Ja | Ja | Nein | Nein | Ja
Bitlocker | Nein | Nein | Nein | Ja | Ja
Fax- und Scan-Funktion | Nein | Nein | Ja | Ja | Ja
Gruppenrichtlinien | Nein | Nein | Ja | Ja | Ja
Sidebar | Nein | Ja | Ja | Ja | Ja
Schattenkopien | Nein | Nein | Ja | Ja | Ja
DVD Maker | Nein | Ja | Nein | Nein | Ja
Domänenanmeldung | Nein | Nein | Ja | Ja | Ja
Access Protection (Netz) | Nein | Nein | Ja | Ja | Ja
Neue Spiele | Nein | Ja | Ja | Ja | Ja
Smart Cards | Nein | Nein | Ja | Ja | Ja
EFS-Verschlüsselung | Nein | Nein | Ja | Ja | Ja
Offline Dateien | Nein | Nein | Ja | Ja | Ja
Roaming | Nein | Nein | Ja | Ja | Ja
PC-Synchronisierung | Nein | Ja | Ja | Ja | Ja
Anytime Upgrade | Ja | Ja | Ja | Nein | extra
IIS kann installiert werden | Nein | Nein | Ja | Ja | Ja
Movie Maker | Ja | Ja | Nein | Nein | Ja
Remote Desktop | Server | Server | Client/Server | Client/Server | Client/Server
Backup mit Zeitplandienst | Nein | Ja | Ja | Ja | Ja
Mehrsprachig | Nein | Nein | Nein | Ja | Ja
Tablet PC-Funktion | Nein | Ja | Ja | Ja | Ja

Updatemöglichkeiten:

Hier finden Sie noch eine Tabelle, von deren BS-Versionen Sie ohne Neuinstallation auf Windows Vista updaten können.

Ich selber halte solch ein Update nicht für optimal.

Ein Wechsel auf ein neues Betriebssystem gibt einem gleich die Gelegenheit, den Rechner wieder einmal sauber zu installieren. Meist enthält das alte System durch die vielen Installation einige nicht mehr benötigte Dateien und Registryeinträge.

Sie können immer nur 32-Bit zu 32-Bit oder 64-Bit zu 64-Bit Updaten. Wenn Sie einen Wechsel von 32-Bit auf 64-Bit durchführen, muss das Betriebssystem neu installiert werden.

 | Home Basic | Home Premium | Business | Ultimate
Windows 2000 | Nein | Nein | Nein | Nein
XP Home | Ja | Ja | Ja | Ja
XP Pro | Nein | Nein | Ja | Ja
XP Pro 64 | Nein | Ja | Ja | Ja
XP Media Center | Nein | Ja | Nein | Ja
XP Tablet PC | Nein | Nein | Ja | Ja

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2154.htm


Vista-Tauglichkeit testen

Ob Ihr Rechner für Vista geeignet ist, können Sie über den Update Advisor von Microsoft testen. Das Programm können auf der folgenden Webseite herunter laden:

http://www.microsoft.com/windowsVista/getready/upgradeadvisor/default.mspx

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2153.htm


Installation von Windows Vista

Die Beschreibung bezieht sich auf die Version: Windows Vista Beta 2 (Deutsch)

Sie haben zwei Möglichkeiten, die Installation von Windows zu starten:

  • Durch das Booten von der DVD
  • Durch Auswahl der Setup.exe aus einer gestarteten Windows Version heraus (Update)

Hier wird mit dem Booten der DVD angefangen:

Nach dem Einlegen der DVD können Sie durch Drücken einer beliebigen Taste die Installation von der CD starten. Nachdem Windows die nötigen Dateien geladen hat, startet das Setup sofort mit einer grafischen Oberfläche.

  • Erstens werden Sie nach den Spracheinstellungen gefragt und können hier die Sprache für "Installationssprache", "Uhrzeit und Währungsformat" und das "Tastaturlayout" festlegen. Über den Button "Weiter" gelangen Sie zum nächsten Fenster.
  • Hier können Sie jetzt über "Jetzt installieren" mit der Installation von Windows beginnen. Weiterhin haben Sie noch über den Eintrag "Systemwiederherstellungsoptionen" die Möglichkeit, die Wiederherstellungskonsole zu starten.
  • Nach der Auswahl von "Jetzt installieren" startet erst der eigentliche Installationsvorgang von Windows.
  • Dann werden Sie aufgefordert, den Product Key einzugeben. Hier hat Microsoft auch dazugelernt, und es ist nicht mehr notwendig die Bindestriche mit einzugeben, da sie automatisch gesetzt werden. Durch Drücken von <Weiter> wird von Windows der Key überprüft und bei einer gültigen Eingabe die Installation fortgesetzt.

Info Ab diesem Fenster haben Sie die Möglichkeit, eine Eingabeaufforderung über die Tasten (Shift + F10] zu öffnen. Da diese Möglichkeit auch beim Unattended Setup besteht und somit User auf dem Rechner jetzt mit administrativen Rechten Veränderungen vornehmen können, kann man diese Funktion auch deaktivieren. Legen Sie dafür im Setup-Verzeichnis "%Windir%\Setup\Scripts" eine Datei mit dem Namen "DisableCMDRequest.TAG"

  • War der Product Key richtig, werden Ihnen die Lizenzbedingungen angezeigt. Die Installation können Sie erst durch das Akzeptieren der Bedingungen fortsetzen.
  • Anschließend können Sie auswählen, ob Sie eine "Update Installation" oder eine "Neuinstallation" (Benutzerdefiniert erweitert) durchführen wollen. Die "Update Installation" kann aber nur ausgewählt werden, wenn Sie nicht von der CD booten, sondern das Setup aus der alten Windows-Version heraus gestartet haben.

    • Jetzt müssen Sie auswählen, wohin Sie Windows installieren wollen. Dafür werden Ihnen die gefundenen Laufwerke angezeigt. Über "Treiber laden" haben Sie die Möglichkeit, fehlende Treiber nachzuladen.

  • Über "Laufwerksoptionen" können Sie weitere Funktionen einblenden:
    • Löschen: (Damit können Sie bestehen Partitionen löschen)
    • Formatieren: (Damit können Sie eine Partition formatieren). Hier haben Sie jetzt nicht mehr die Möglichkeit, das Dateiformat auszuwählen, es wird immer automatisch NTFS als Dateisystem benutzt.
    • Erweitern: Bestehende Partition vergrößern (ist nur möglich, wenn noch weiterer Speicherplatz hinter der gewählten Partition vorhanden ist)
    • Neu: Wenn Sie auf "Nicht zugewiesenen Speicherplatz auf Datenträger" klicken, können Sie über diesen Button einen neue Partition erstellen.
  • Nach Auswahl der Installationspartition können Sie über <Weiter> die endgültige Installation starten. Ist der Platz ausreichend, startet die Windows Installation und führt folgende Schritte automatisch aus:
    • Windows Dateien kopieren
    • Dateien expandieren
    • Updates installieren.
    • Die Installation wird abgeschlossen
  • Nach der Installation startet Windows mit dem Fenster "Windows einrichten". Hier werden Ihnen als erstes wieder Land und Tastaturlayout angezeigt, welches Sie, wenn nötig,noch mal anpassen können.
  • Nach dem Klick auf <Weiter> können Sie einen Benutzernamen (Anmeldeaccount) und ein Passwort für den Account festlegen. Weiterhin können Sie auch ein Bild (Icon)für Ihren Account auswählen. Über diesen Account werden Sie sich später an Windows anmelden. Dort haben Sie dann auch die Möglichkeit, die Einstellungen für den Account zu verändern oder noch weitere Accounts für andere Benutzer anzulegen.
  • Durch Klicken auf <Weiter> gelangen Sie zum nächsten Fenster. Hier können Sie einen Namen für den Rechner festlegen. Windows benutzt automatisch den Accountnamen und hängt noch ein "-PC" dran. Sie können den Namen aber beliebig ändern. Zusätzlich können Sie hier noch ein Hintergrundbild für den Desktop festlegen (auch dieser kann natürlich später jederzeit wieder geändert werden).
  • In nächsten Fenster werden Sie nach den Windows Sicherheitseinstellungen gefragt, wo Sie zwischen "Empfohlene Einstellungen verwenden", "Nur Updates installieren" und "Später erneut nachfragen" auswählen können. Klicken Sie die gewünschte Option an.
  • Anschließend wird Ihnen die Zeit-und Datumseinstellung angezeigt. Hier müssen Sie die richtige Zeitzone für Deutschland: "(GTM +01:00) Amsterdam, Berlin, Bern, Stockholm, Wien" auswählen und, wenn nötig, Uhrzeit und Datum anpassen.
  • Nach dem Klick auf <Weiter> ist die Installation dann beendigt und kann über "Start" abgeschlossen werden. Windows zeigt Ihnen jetzt das Anmeldefenster wo Sie sich das erste mal mit Ihrem Account anmelden können.

Info Siehe auch: Setup Parameter von Windows Vista

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2144.htm


Setup Parameter von Windows Vista

,

Hier finden Sie die möglichen Setup-Parameter womit Sie die SETUP.EXE aufrufen können.

Setup.exe [/1394debug:<Kanal>] [/usbdebug:<Zielname>] [/debug:<Anschluss> [/baudrate:<Baudrate>]] [/dudisable] [/emsport:<Anschluss> [/emsbaudrate:<baudrate>]] [/noreboot] [/m:<Ordnername>] [/tempdrive:<Laufwerkspfad>] [/unattend:<Antwortdatei>]

Parameter

Beschreibung

/1394debug:<Kanal>

Aktiviert das Kerneldebugging über einen IEEE 1394-Anschluss

/usbdebug:<Zielname>

Aktiviert das Kerneldebugging über einen USB 2.0 Port

/debug:<Anschluss> [/baudrate:<Baudrate>]

Aktiviert das Kerneldebugging über den angegebenen Port

/dudisable

Deaktiviert das "Automatische" Update von Windows während der Installation

/emsport:<Anschluss> [/emsbaudrate:<Baudrate>]

Aktiviert/Deaktiviert die Notverwaltungsdienste "Emergency Management Services" (EMS).

Mit EMS können Rechner, ohne dass eine lokale Tastatur, Maus und Monitor angeschlossen sind, in Notsituationen über Remote verwaltet werden.

Werte:

emsport: {com1|com2|usebiossettings|off}

emsbaudrate: Legt die Baudrate fest, welche für die Übertragung von Daten verwendet wird. Dieser Wert wird nur für X86-Systeme verwendet. Die Baudrate kann 9600, 19200, 57600 oder 115200 betragen, 9600 ist der Standardwert.

/noreboot

Es wird kein Neustart durchgeführt, wenn Windows das Kopieren beendet hat. Sie haben dann die Möglichkeit, noch weitere Aktionen durchzuführen. Es wird nur der erste Neustart unterdrückt, alle anderen werden wieder automatisch durchgeführt.

/m:<Ordnername>

Legt fest, dass Treiber erst aus diesem Verzeichnis installiert werden sollen. Werden Treiber in diesem Verzeichnis für die Hardware gefunden, haben Sie die Möglichkeit, diese Treiber zu verwenden.

/tempdrive:<Laufwerkspfad>

Laufwerk und Pfad, auf dem temporäre Dateien abgelegt werden sollen.

/unattend:<Antwortdatei>

Die Installation wird ohne Benutzereingaben durchgeführt.

Alle Angaben Benutzereingaben werden aus der Datei geholt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2146.htm


Windows Testzeit von 30 auf 120 Tage verlängern

Wenn Sie keinen gültigen Produktschlüssel besitzen, können Sie standardmäßig Windows Vista 30 Tage benutzen. Nach Ablauf der 30 Tage, wird ein gültiger Produktschlüssel verlangt.

Diese Testzeit können Sie mit dem Programm "slmgr.vbs" 3 mal um 30 Tage verlängern, so dass Sie zusammen auf eine Zeit von 120 Tage kommen, danach müssen Sie einen gültigen Produktschlüssel besitzen.

Um die Testzeit um weitere 30 Tage zu verlängern, gehen Sie folgendermaßen vor:

  • Starten Sie den Rechner im abgesicherten Modus.
  • Öffnen Sie die Kommandozeile im administrativen Kontext.
  • Geben Sie hier "slmgr.vbs -rearm" ein.

Folgende weitere Parameter sind noch möglich:

-itk [Key] | Für einen neuen Key (löscht den alten Key).
-upk | Löscht einen Key
-ato | Versucht Windows zu Aktivieren
-dlv | Gibt ausführliche Informationen über den Lizenzstatus aus
-xpr | Erweitere Informationen
-rearm | 30 Tage Textzeit neu setzen
-dli | Status der Aktivierung

Mit slmgr.vbs -dli können Sie sich den Status der Aktivierung anzeigen lassen. Nach dem Aufruf dauert es eine kurze Zeit bis die Messagebox mit den Infos angezeigt wird.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2149.htm


Windows Vista "Service Pack" Informationen und Integration in die Setup DVD

In diesen Tipp wird beschrieben, wie Sie das Service Pack in die Setup DVD integrieren können um somit eine Slipstream-DVD zu erstellen.

Service Pack für Windows Vista

Das Service Pack für Windows Vista wurde von Microsoft zum Downloaden bereitgestellt:

  • Windows Vista Service Pack 1: <Download>
  • Windows Vista Service Pack 1 für 64-Bit-Systeme: <Download>
  • Windows Vista Service Pack 2: <Download>
  • Windows Vista Service Pack 2 für 64-Bit-Systeme: <Download>

Info Wenn Ihr Setup kein Service Pack enthält, müssen Sie zuerst das Service Pack 1 und danach alle weiteren Service Packs installieren. SP1 und SP2 von Windows Vista sind nicht kumulativ!

Durch das Service Pack werden einige fundamentale Fehler beseitigt. Dadurch wird das Arbeiten unter Windows Vista verbessert. Das Service Pack wird es als Update und auch als "Stand-alone-Installer" geben. Das Update enthält nur die nötigen Dateien für die aktuelle Windows Version. Der "Stand-alone-Installer" enthält alle Updates und ist deshalb auch sehr groß:

  • für die 32-Bit-Version: 434 MByte
  • für die 64-Bit-Version: 726 MByte

Diese Version benötigen Sie auch für die Integration, welche weiter unten ausführlich beschrieben wird, um eine Windows Vista Setup DVD mit integriertem Service Pack zu erstellen. Die Installation des Service Pack selbst dauert recht lange, mitunter mehrere Stunden.

Das Service Pack bringt vor allem Bugfixes sowie Fehlerbehebungen mit sich. So stopfen mehr als 479 Patches unter anderem diverse Sicherheitslöcher und verbessern die Leistung, Zuverlässigkeit sowie Stabilität.

Das Kopieren und Entpacken von Dateien wurde deutlich beschleunigt, ist aber immer noch langsamer als bei XP. Das SP 1 enthält außerdem einen neuen Kernel mit der Versionsnummer 6.1 (statt wie bisher 6.0). Der neue Kernel stammt aus der gerade fertiggestellt Windows Server 2008 Version. Für Spieler enthält das SP1 die Unterstützung von DirectX 10.1.

Einige weitere Änderungen:

  • Desktop-Suche: Auf Drängen von Google kann über die Systemsteuerung ("Standardprogramme und Protokolle") der Anwender den Suchanbieter seiner Wahl konfigurieren.
  • Defragmentierung: Hier kann der Anwender jetzt die Laufwerke auswählen.
  • BitLocker-Laufwerksverschlüsselung: Vista-Ultimate oder Enterprise unterstützen jetzt auch BitLocker-Laufwerksverschlüsselung.

Links mit Informationen zum Windows Vista SP1:

  • Vollständige Liste der Änderungen: MS-Technet-Artikel
  • Windows Vista SP1 Guides for IT Professionals

Installation vom Service Pack

Die Installation von Service Pack wird über die Update-Funktion von Windows ausgeführt oder nach dem Herunterladen des Setups durch einfaches Anklicken der EXE-Datei.

Zusätzlich kann die Installation über entsprechende Parameter gesteuert werden. Dabei gibt es folgende Parameter:

/unattend | Führt die Installation im unbeaufsichtigten Modus durch
/quiet | Die Installation wird im Hintergrund ohne Bildschirmausgabe ausgeführt
/nodialog | Zeigt keinen Ergebnisdialog nach Abschluss der Installation
/norestart | Deaktiviert den Neustart nach der Installation des Service Packs
/forcerestart | Neustart nach Abschluss der Installation
/warnrestart[:Zeit] | Anzeige einer Warnung vor dem Restart. Die Zeit wird in Sekunden angegeben. Der Standardwert ist 30 Sekunden.
/promptrestart | Eingabeaufforderung anzeigen
/help | Zeigt die Parameter

Service Pack 1 jetzt schon herunterladen

Mit einem Eintrag in der Registry kann man auch jetzt schon das Service Pack 1 für Vista (x86 und x64) über das Windows Update beziehen. Erstellen Sie eine .REG-Datei (z.B. VistaSP1.REG) mit den folgenden Inhalt:

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\WindowsUpdate\VistaSP1]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\VistaSp1]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\VistaSp1]

"Beta1"="dcf99ef8-d784-414e-b411-81a910d2761d"

=== Hier schneiden ===

Die REG-Datei mit Rechtsklick - "Als Administrator ausführen" starten. Unter "Start" -> "Systemsteuerung" -> "Windows Update" nach Updates suchen lassen. In einigen Fällen werden noch einige andere Updates angeboten, und es muss ein Systemstart durchgeführt werden. Sind alle Updates installiert, sollte nun endlich das Windows Vista Service Pack 1 zum Download angeboten werden.

Service Pack in die Sourcen (Setup-DVD) einbinden

Microsoft hat die Slipstream-Funktion aus dem Service Pack entfernt, da sie an einer neuen Intergrationsmethode arbeiten, die aber erst ab Service Pack 2 zur Verfügung stehen soll. Dadurch gibt es leider keine so einfache Funktion wie unter Windows XP, (siehe Tipp: Windows Service Pack in die Original-Installationsdateien einbinden) um das Service Pack in die Originaldateien zu integrieren.

Eine Hoffnung bittet das Tool "Vista Update Integrator", welches zurzeit leider erst in einer Beta-Version vorliegt. Mit diesem Tool kann man leicht HOT-Fix-Dateien einbinden. Eine Version für Service Pack 1 ist in Arbeit und wird kurz nach Freigabe des aktuellen SP1 erscheinen. Aktuell stehen folgende Funktionen zur Verfügung:

  • Integration von *.msu Updates und Addons (Powershell)
  • Integration von Sprachpaketen
  • Integration von Treibern
  • Apply and Rebuild Feature, dadurch wird eine neue install.wim erstellt, die nur noch die bearbeitete Vista Edition enthält
  • Erstellung von bootfähigen ISO-Images
  • Erstellung von 2in1 DVD Images, die Vista x86 und Vista x64 enthalten. Es können beliebige Editionen ausgewählt werden- z.B. Vista Ultimate x86 und Vista Business x64

Download: http://www.winvistaside.de/downloads/updates/winvistaside-updateinstaller-50/

Da das aber noch nicht geht, gibt es eine noch etwas kompliziertere Möglichkeit, das Service Pack einzubinden, welche hier kurz beschrieben wird.

Was wird benötigt, um das Service Pack einzubinden?

  • Sie benötigen dafür das Tool "Windows Automated Installation Kit" (WAIK), welches Sie von Microsoft herunterladen können.
    Download: http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=94bb6e34-d890-4932-81a5-5b50c657de08
    (Bei dem Download handelt es sich um eine Image-Datei, die 1,2 GB groß ist).
  • Weiterhin benötigen Sie natürlich noch das Service Pack
    Download: (Siehe oben).

Ablauf der Integration des Service Packs in Windows Vista

Für die Integration müssen Sie zusätzlich ein neues Windows Vista installieren.

Diese Installation müssen Sie zwingend auf einer leeren anderen Partition durchführen, auf der noch nichts Weiteres installiert ist. Da diese Installation später wieder in eine Imagedatei eingelesen wird, muss es sich um eine leere Partition handeln.

Auf der ersten Installation von Windows (Arbeitsinstallation) installieren Sie jetzt das Tool "Windows Automated Installation Kit". Dafür entpacken Sie das ISO-Image entweder auf die Festplatte, brennen das Image auf eine CD oder öffnen das Image mit dem Tool "DAEMON Tool" (Download), welches IMAGE-Dateien als Laufwerk im System bereitstellt kann.

Starten Sie anschließend aus der Quelle die Datei "STARTCD.EXE", welche sich im Rootverzeichnis des Images befindet. Wählen Sie aus der Dialogbox "Willkommen" den Eintrag "Windows AIK-Setup" aus, um das benötigte Programm zu installieren. Nach dem Abschluss der Installation können Sie mit dem Setup der (Installationsversion) von Windows Vista beginnen.

  1. Starten Sie das Setup von der Windows Vista DVD
  2. Wählen Sie für die Installation eine leere Partition aus (Sie benötigen mindestens 15 GB freien Speicher)
  3. Bei der Abfrage der Seriennummer geben Sie nichts ein, dadurch werden Sie jetzt nach zwei weiteren Dialogen nach der zu installierenden Windows Vista- Version gefragt.
  4. Wählen Sie hier jetzt die Vista-Version aus, um die Sie das Service Pack erweitern wollen.
  5. Führen Sie jetzt die Installation soweit durch (dabei wird das System einige Male neu gestartet), bis der Dialog zur Eingabe des Benutzernamen und des Kennwortes erscheint, um die Anmeldedaten festzulegen.
  6. Geben Sie hier nichts ein, sondern drücken Sie die Tastenkombination STRG+Shift+F3
  7. Das System wird jetzt wieder neu gestartet und öffnet das Systemvorbereitungsprogramm "Sysprep".
    Info: Das Dialogfenster von "Sysprep" bitte im weiteren Setupvorgang nicht schließen!
    Systemvorbereitungsprogramm
  8. Starten Sie nun das Setup Programm vom Windows Vista Service Pack und installieren das Service Pack (dabei wird das System öfter neu gestartet).
    Wenn noch kein Service Pack eingebunden wurde, müssen Sie alle Service Packs installieren, da das Service Pack 2 nicht die Daten von Service Pack 1 enthält. Also die Punkte 8 und 9 jeweils pro Service Pack ausführen.
  9. Nach Abschluss der Installation löschen Sie über die Kommandozeilenoberfläche (öffnen mit der Windows-Taste + R) den Deinstallationsordner vom Service Pack (diese Dateien wollen Sie ja nicht im neuen Installationsimage haben). Geben Sie dafür folgenden Befehl ein:
    Service Pack 1:
    vsp1cln.exe
    Service Pack 2:
    compcln.exe
    Jetzt wird das System von allen nicht mehr benötigten Dateien bereinigt.
  10. Wählen Sie nun im noch offenen Sysprep-Dialog die Systembereinigungsaktion "Out-of-Box-Experience (OOBE) für System aktivieren" aus. Aktivieren Sie den Eintrag "Verallgemeinern" und aus der Drop-down-Box die Option "Herunterfahren" aus.
    Systemvorbereitungsprogramm
  11. Starten Sie nun wieder die original Windows Vista Version (Arbeitsinstallation), welche mit dem Tool "Vista Update Integrator" vorbereitet wurde. Im Bootmenü sollte das jetzt der zweite Eintrag sein (der erste Eintrag ist das neu installiere Windows).
  12. Öffnen Sie die Eingabeaufforderung des AIK-Tools über "Start" -> "Alle Programme" ->"Microsoft Windows AIK" mit der rechten Maustaste auf "Windows PE Tools-Eingabeaufforderung" und wählen Sie "Als Administrator ausführen" (das müssen Sie nur machen, wenn Sie mit aktiven UAC arbeiten).
  13. In der nun geöffneten Kommandozeilenoberfläche geben Sie den folgenden Befehl ein:

    imagex /compress maximum /flags "[Vista-Kennung]" /capture [Laufwerk Quelle] [Laufwerk und Pfad Ziel] "[Beschreibung]"

    [Vista-Kennung]

    Geben Sie hier die Vista-Kennung ein von der Version, die Sie installiert haben:

    • HomeBasic
    • HomePremium
    • Business
    • Ultimate
    [Laufwerk Quelle] | Laufwerksbuchstabe der Partition auf der das Setup durchgeführt wurde
    [Laufwerk & Pfad Ziel] | Laufwerk, Pfad und Dateiname des Images

    Beispiel:

    imagex /compress maximum /flags "Busines" /capture F: D:\WIM\install.wim "Windows Vista Business"

    Mit dem Befehl : imagex /capture /? können Sie sich Informationen zu dem Befehl anzeigen lassen.

  14. Durch diesen Befehl wird die Windows-Installation in ein Windows-Image (WIM) kopiert, was je nach Rechnerleistung etwas dauern kann. Auf dem Ziellaufwerk wird ca. 2,5 GByte freier Speicher benötigt.
  15. Kopieren Sie anschließend alle Dateien der Windows Vista DVD auf Ihre Festplatte in ein beliebiges Verzeichnis (z.B.: D:\ VistaSetup).
  16. Ersetzen Sie im Ordner "Sources" die Datei Install.wim durch die unter Punkt 13 erstelle Datei.
  17. Jetzt muss aus diesem Verzeichnis wieder eine bootfähige Windows DVD erstellt werden, dafür müssen Sie folgendes machen.
  18. Starten Sie wieder die AIK-Tools über "Start" -> "Alle Programme" -> "Microsoft Windows AIK" mit der rechten Maustaste auf "Windows PE Tools-Eingabeaufforderung" und wählen Sie "Als Administrator ausführen" (das müssen Sie nur machen, wenn Sie mit aktiven UAC arbeiten).
  19. Geben Sie in der Kommando-Zieleoberfläche den folgenden Befehl ein:

    oscdimg /b"%Programfiles%\Windows AIK\Tools\PETools\x86\boot\etfsboot.com" /h /lLRMCFRE_DE_DVD /u2 /o [Quelle der Sourcen] [Ziel des Images]

    [Quelle der Sourcen] | Verzeichnis in das die Windows DVD kopiert wurde
    [Ziel des Images] | Verzeichnis und Name der neuen Image-Datei (zum Brennen)

    Beispiel:

    oscdimg /b"%Programfiles%\Windows AIK\Tools\PETools\x86\boot\etfsboot.com" /h /lLRMCFRE_DE_DVD /u2 /o D:\VistaSetuo D:\VistaSetup\Winodws_Vista_Business_mit_SP1.iso

  20. Brennen Sie die erstelle Image-Datei mit einem beliebigen Brennprogramm (z.B.: Nero) auf eine neue DVD. Anschließend können Sie mit dieser DVD Vista mit Service Pack 1 installieren.
  21. Dann müssen Sie noch die nicht mehr benötigte zusätzliche Installation von Window löschen. Diese Installationsdateien können Sie durch Formatieren der Partition löschen. Um den Eintrag aus dem Bootmenü zu entfernen, müssen Sie eine Kommando-Zeilenoberfläche öffnen und den nicht mehr benötigten Eintrag mit BCDEDIT löschen.
    Geben Sie BCDEDIT ein, um sich die aktuellen Einträge anzeigen zu lassen. Suchen Sie sich anhand des Laufwerksbuchstaben (unter device) den entsprechenden Eintrag heraus. Löschen Sie diesen Eintrag anhand der Bezeichnung. Der zu löschende Eintrag müsste der Eintrag "{default}" sein.
    Löschen Sie den Eintrag durch:
    bcdedit /delete {default}

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2535.htm


Informationen über den BCD-Store

Ab Windows NT gab es zur Steuerung des Bootvorgangs die Datei BOOT.INI. Diese Datei hat Microsoft ab Windows Vista abgeschafft und bezieht seine Konfigurationsparameter nicht mehr aus dieser Datei.

Die Konfigurationsinformationen werden jetzt im BCD-Store (Boot Configuration Data Store) gespeichert. Auch hierbei handelt es wieder um eine Datei, nur jetzt werden die Daten im Binärformat abgelegt.

Zum Bearbeiten der Konfigurationsdatei gibt es das Kommandozeilentool "bcdedit".

Beispiele für Befehle:

bcdedit /? | Informationen über die Parameter
bcdedit /enum all | Zeigt die Konfiguration an
bcdedit /export "C:\BCD\Backup_01" | Erstellt ein Backup der aktuellen Konfiguration
bcdedit /import "C:\BCD\Backup_01" | Wiederherstellen eines Backup
bcdedit /timeout 15 | Wartezeit bis zum automatischen Starten des Standardbetriebssystems
bcdedit /default [Bezeichner] | Legt das Standardbetriebssystem fest. Sind Windows XP und Vista installiert, ist {current} Windows Vista und {legacy} Windows XP. Will man also z.B. XP als Standardbetriebssystem festlegen, gibt man ein: bcdedit /default {legacy}

Info Erscheint die Meldung "Der Speicher für die Startkonfigurationsdaten konnte nicht geöffnet werden. Zugriff verweigert.", dann haben Sie keine administrativen Berechtigungen. Erstellen Sie eine Verknüpfung auf dem Desktop zum Programm "cmd.exe" und führen Sie diese mit einen Klick der rechten Maustaste unter der Auswahl "Als Administrator ausführen", dem Kontextmenü, aus.

Info Mit dem Tool "VistaBootPro" können Sie die Einstellungen mit einer grafischen Oberfläche ändern. Homepage: http://www.pro-networks.org/Vistabootpro

Info Weitere Infos bei Microsoft: http://www.microsoft.com/technet/windowsVista/library/85cd5efe-c349-427c-b035-c2719d4af778.mspx

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2147.htm


Aktivierung von Windows

Ab Windows Vista hat Microsoft bei der Aktivierung einiges verändert. Microsoft vergibt für das gesamte System 35 Punkte, diese Punkte setzen sich folgendermaßen zusammen:

Festplatte | 11
BIOS | 9
Prozessor | 3
IDE Controller | 3
SCSI Controller | 2
Soundkarte | 2
MAC Adresse | 2
Grafikkarte | 1
Zeilengröße | 1
CD/DVD Laufwerk | 1
Zusammen: | 35

Wird die Hardware geändert, wird der entsprechende Wert aus der Tabelle von den 35 Punkten abgezogen. Wird der Wert von 26 Punkte unterschritten, ist eine erneute Aktivierung nötig.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2200.htm


Alle digital signierten Treiber gleich bewerten

Standardmäßig bewertet Windows Treiber besser, die eine signatur für das Betriebssystem haben, als Treiber welche für ältere Betriebssystem signiert oder nur von anderen Anbietern signiert wurden. Diese Treiber werden dann bei einer Installation vorgezogen. Dadurch kann es vorkommen, dass Windows die oft besseren Treiber vom Hersteller nicht installiert.

Wenn Sie diesen Tipp aktivieren, werden alle digital signierten Treiber gleich behandelt. Die Auswahl erfolgt auf Grundlage anderer Kriterien (z. B. anhand der Versionsnummer oder des Erstellungsdatums des Treibers) und nicht anhand der Frage, ob der Treiber durch Microsoft signiert wurde.

Ein signierter Treiber wird jedoch nach wie vor einem nicht signierten vorgezogen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DeviceInstall\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "AllSigningEqual" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Von Microsoft signierte Treiber werden vorgezogen (Standard)
1 | Signierte Treiber werden gleich behandelt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Geräteinstallation
Einstellungsname: | Alle digital signierten Treiber bei Treiberbewertung und Auswahl gleich behandeln

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2262.htm


Keinen Systemwiederherstellungspunkt bei der Treiberinstallation anlegen

Standardmäßig erstellt Windows automatisch bei der Installation von Gerätetreibern einen neuen Systemwiederherstellungspunkt. Dadurch haben Sie die Möglichkeit, wenn nach der Installation der Rechner nicht mehr richtig läuft, auf den alten Installationsstand zurückzukehren.

Wenn Sie diesem Tipp aktivieren, werden bei der Installation oder Aktualisierung eines neuen Gerätetreibers keine Systemwiederherstellungspunkte erstellt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DeviceInstall\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableSystemRestore" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Es wird eine Systemwiederherstellungspunkt angelegt (Standard)
1 | Kein Systemwiederherstellungspunkt anlegen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Geräteinstallation
Einstellungsname: | Bei der Installation eines neuen Gerätetreibers keinen Systemwiederherstellungspunkt erstellen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2263.htm


Windows 'System Recovery' (Wiederherstellungskonsole)

Windows "System Recovery" (Wiederherstellungskonsole)

Die Wiederherstellungskonsole hat Microsoft ab Windows 2000 eingeführt (siehe Tipp: Die Windows 'Recovery Console' (Wiederherstellungskonsole)). Diese Wiederherstellungskonsole konnte aber meist nur von Leuten benutzt werden, die sich mit Windows auskannten und sich damit etwas ausführlicher beschäftigt haben. Ab Vista hat Microsoft aber auch hier einiges getan und eine grafisch geführte Oberfläche eingebaut.

Um die Wiederherstellungskonsole zu starten, legen Sie die Windows- DVD in das Laufwerk und booten Sie davon. Nach kurzer Zeit werden Sie nach den gewünschten Länder/Spracheinstellungen gefragt. Im anschließenden Fenster können Sie über den Eintrag "Systemwiederherstellungsoptionen" die Wiederherstellungskonsole öffnen.

Es öffnen sich jetzt die "System Recovery Options" wo Sie folgendes machen können:

- Als erstes werden Sie nach der Sprache des Keyboard-Layouts gefragt. Durch klicken auf "Next" wird Windows veranlasst nach gültigen Windows Installationen auf der Festplatte zu suchen. Anschließend wird Ihnen eine Liste der gefundenen Installationen zur Auswahl angezeigt.

- Hier haben Sie über den Button "Load Driver" weiterhin noch die Möglichkeit zusätzliche Treiber aus einer anderen Quelle zu laden. Nach der Auswahl der gewünschten Windows-Version wird Ihnen ein neues Fenster geöffnet welches die folgenden Möglichkeiten anbietet:

  • Startup Repair: Automatisches Reparieren von Windows Startproblemen (Bootsector usw.)
  • System Restore: Herstellen von Windows über vorhandene Wiederherstellungspunkte
  • CompletePC Restore: Komplettes wiederherstellen eines Windows-Backups
  • Windows Memory Diagnostic Tool: Arbeitsspeicher auf Fehler überprüfen
  • Command Prompt: Kommandozeile/Eingabeaufforderung

Über die Button "Shut Down" bzw. "Restart" können Sie diese Funktionen verlassen.

In der Kommandozeile stehen Ihnen alle Kommandozeilenbefehle zur Verfügung.

diskpart | FDISK von Windows zum Partitionieren von Festplatten
chkdsk | Überprüfung der Partition auf Fehler. Mit diesen Befehl wird das Laufwerk C:\ auf Fehler überprüft und die Fehler werden behoben: chkdsk c: /f /r
MRT | Microsoft Tool zum Entfernen bösartiger Software Dieses Tool überprüft, ob Trojaner auf Ihrem Rechner vorhanden sind.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2145.htm


Laden von Anwendungen beschleunigen (EnableSuperfetch)

Diese Funktion ist unter Windows XP als Prefetch bekannt und wurde ab VISTA nur erweitert. Prefetch beschleunigte nur den Bootvorgang und die Startumgebung, wobei sich das neue Superfetch auch um alle Programmaufrufe kümmert.

Die Funktion überwacht alle Programmaufrufe und optimiert den Start der Anwendungen. Sie sollten den Wert auf "Superfetch für Anwendungen und dem Bootvorgang" stellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Memory Management\ PrefetchParameters

Finden Sie den Eintrag “EnableSuperfetch“, hier sollte als Wert 3 Eingetragen sein, damit die Funktion aktiv ist. Wenn Sie die Funktion deaktivieren wollen, setzen Sie den Wert auf 0.

Folgende Werte sind zulässig:

0 | Superfetch ausschalten
1 | Superfetch für Anwendungen
2 | Superfetch für den Bootvorgang
3 | Superfetch für Anwendungen und dem Bootvorgang

Info Siehe dazu auch Tipp: Bootvorgang beschleunigen (Prefetching)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2252.htm


Windows Ruhezustand deaktivieren und löschen der Datei HIBERFIL.SYS

Nach der Installation von Windows finden Sie im Hauptverzeichnis die Datei HIBERFIL.SYS. Diese Datei hat die Größe des Arbeitsspeichers und wird von Windows für den Ruhezustand benötigt.

Wenn Sie den Rechner in den Ruhezustand fahren, schreibt Windows den Inhalt des Arbeitsspeichers in diese Datei und schaltet den Rechner aus, beim Hochfahren wird der Inhalt des Arbeitsspeichers aus der Datei wieder hergestellt.

Über die Eingabeaufforderung können Sie aber den Ruhezustand ausschalten und anschließend die Datei löschen, gehen Sie dazu folgendermaßen vor:

  • Öffnen Sie die Eingabeaufforderung (CMD.EXE) mit administrativen rechten
  • Geben Sie nun folgenden Befehl ein: powercfg -H off

Die Datei HIBERFIL.SYS wird nach ausführen des Befehl automatisch gelöscht, da sie nicht mehr benötigt wird.

Info In der Oberfläche gibt es auch eine Möglichkeit, HIBERFIL.SYS zu löschen: Datenträgerbereinigung für das Systemlaufwerk öffnen, Checkbox vor "Ruhezustands-Dateibereinigung" aktivieren und Datenträgerbereinigung über "OK" starten.

Wenn Sie den Ruhezustand wieder aktivieren wollen, müssen Sie einfach folgenden Befehl in der Eingabeaufforderung eingeben: powercfg -H on.

Mit der folgenden REG-Datei, können Sie den Ruhezustand über das Kontextmenü "Energieoptionen" ein- und ausschalten. Speichern Sie die Datei mit der Endung .REG an und führen Sie die Datei im Explorer mit einem Doppelklick aus.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}\Shell]

[HKEY_CLASSES_ROOT\CLSID\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}\Shell\Ruhezustand ausschalten]

[HKEY_CLASSES_ROOT\CLSID\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}\Shell\Ruhezustand ausschalten\command]

@="C:\\Windows\\System32\\powercfg.exe -H off"

[HKEY_CLASSES_ROOT\CLSID\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}\Shell\Ruhezustand einschalten]

[HKEY_CLASSES_ROOT\CLSID\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}\Shell\Ruhezustand einschalten\command]

@="C:\\Windows\\System32\\powercfg.exe -H on"

=== Hier schneiden ===

Info Wenn Sie Windows auf ein anderen Laufwerk/Verzeichnis installiert haben, müsse Sie die Pfadangaben entsprechend anpassen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2198.htm


Verändern der Eigenschaften von der Taskleiste unterbinden

Mit diesem Tipp können Sie das Ändern von Einstellungen der Taskleiste unterbinden. Ist der Tipp aktiv, kann der Anwender die Einstellungen nicht mehr verändern. Auf die Eigenschaften der Taskleiste können Sie zugreifen, wenn Sie mit der rechten Maustaste auf die freie Taskleiste klicken und aus dem Kontextmenü ein Eintrag "Eigenschaften" auswählen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "TaskbarLockAll" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eigenschaften können bearbeitet werden
1 | Eigenschaften der Taskleiste sichern

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Alle Taskleisteneinstellungen sperren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2212.htm


Funktion des Power-Buttons (Netzschalter) im Startmenü konfigurieren

Auf dem Power-Button im Startmenü wird von Windows eine Standardfunktion gelegt (bei Notebook ist das meist "Energie sparen"). Wenn Sie eine andere Funktion wie "Herunterfahren" ausführen wollen, müssen Sie das über das Menü rechts neben dem Startbutton auswählen.

Wenn Sie eine bestimmte Funktion nur noch ausführen wollen, können Sie die Belegung des Buttons folgendermaßen ändern.

Wählen Sie aus der "Systemsteuerung" den Eintrag "Energieoptionen". Hier sehen Sie jetzt die möglichen Energiesparpläne, wählen Sie hier beim aktiven Energiesparplan den Eintrag "Energiesparplaneinstellungen ändern" (Info: Dieses Einstellung müssen Sie für jeden Energiesparplan vornehmen, den Sie verwenden möchten).

Wählen Sie jetzt in nächsten Fenster den Eintrag "Erweitere Energieeinstellungen ändern" aus. Im neuen Fenster "Energieoptionen" können Sie jetzt unter "Netzschalter und Laptopdeckel" die einzelnen Einstellungen für bestimmte Aktionen festlegen. Der Eintrag "Netzschalter im Startmenü" legt dabei die Funktion für den "Power Button" fest.

Diese Einstellung kann auch über die Registry geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Power\ PowerSettings\ A7066653-8D6C-40A8-910E-A1F54B84C7E5

erstellen Sie hier folgende Einträge als Datentyp REG_DWORD

Name | Werte | Beschreibung
DCSettingIndex | 0 -> Energiesparmodus 1 -> Ruhezustand 2 -> Herunterfahren | Einstellung für den Akkubetrieb
ACSettingIndex | 0 -> Energiesparmodus 1 -> Ruhezustand 2 -> Herunterfahren | Einstellung für den Netzbetrieb

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Energieverwaltung\Schaltflächeneinstellungen
Einstellungsname: | Aktion für Netzschalter (Startmenü) auswählen (Akkubetrieb) Aktion für Netzschalter (Startmenü) auswählen (Netzbetrieb)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2377.htm


Funktion für Notebook-Deckel schließen konfigurieren

Wenn Sie den Deckel eines Notebooks schließen, wird von Windows standardmäßig eine entsprechende Aktion ausgeführt. In der Standardeinstellung wird Windows dann in den "Energie sparen" Modus gefahren.

Wenn Sie eine andere Aktion ausführen wollen, können Sie die Belegung folgendermaßen ändern.

Wählen Sie aus der "Systemsteuerung" den Eintrag "Energieoptionen". Hier sehen Sie jetzt die möglichen Energiesparpläne, wählen Sie hier beim aktiven Energiesparplan den Eintrag "Energiesparplaneinstellungen ändern" (Info: Dieses Einstellung müssen Sie für jeden Energiesparplan vornehmen den Sie verwenden möchten).

Wählen Sie jetzt in nächsten Fenster den Eintrag "Erweitere Energieeinstellungen ändern" aus. Im neuen Fenster "Energieoptionen" können Sie jetzt unter "Netzschalter und Laptopdeckel" die einzelnen Einstellungen für bestimmte Aktionen festlegen. Der Eintrag "Deckelschließaktion" legt dabei die Funktion für das "Schließen des Deckels" fest.

Diese Einstellung kann auch über die Registry geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Power\ PowerSettings\ 5CA83367-6E45-459F-A27B-476B1D01C936

erstellen Sie hier folgende Einträge als Datentyp REG_DWORD

Name | Werte | Beschreibung
DCSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Akkubetrieb
ACSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Netzbetrieb

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Energieverwaltung\Schaltflächeneinstellungen
Einstellungsname: | Aktion zum Wechseln des Deckels auswählen (Akkubetrieb) Aktion zum Wechseln des Deckels auswählen (Netzbetrieb)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2379.htm


Funktion für Energiespartastenaktion konfigurieren

Wenn Sie die Energiespartaste drücken, wird von Windows standardmäßig eine entsprechende Aktion ausgeführt. In der Standardeinstellung wird Windows dann in den "Energie sparen"-Modus gefahren.

Wenn Sie eine andere Aktion ausführen wollen, können Sie die Belegung folgendermaßen ändern.

Wählen Sie aus der "Systemsteuerung" den Eintrag "Energieoptionen". Hier sehen Sie jetzt die möglichen Energiesparpläne, wählen Sie hier beim aktiven Energiesparplan den Eintrag "Energiesparplaneinstellungen ändern" (Info: Diese Einstellung müssen Sie für jeden Energiesparplan vornehmen, den Sie verwenden möchten).

Wählen Sie jetzt in nächsten Fenster den Eintrag "Erweitere Energieeinstellungen ändern" aus.

Im neuen Fenster "Energieoptionen" können Sie jetzt unter "Netzschalter und Laptopdeckel" die einzelnen Einstellungen für bestimmte Aktionen festlegen. Der Eintrag "Energiespartastenaktion" legt dabei die Funktion für das Drücken der Energiespartaste fest.

Diese Einstellung kann auch über die Registry geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Power\ PowerSettings\ 96996BC0-AD50-47EC-923B-6F41874DD9EB

erstellen Sie hier folgende Einträge als Datentyp REG_DWORD

Name | Werte | Beschreibung
DCSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Akkubetrieb
ACSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Netzbetrieb

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Energieverwaltung\Schaltflächeneinstellungen
Einstellungsname: | Energiespartastenaktion auswählen (Akkubetrieb) Energiespartastenaktion auswählen (Netzbetrieb)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2382.htm


Funktion für Netzschalter konfigurieren

Wenn Sie den Netzschalter drücken, wird von Windows standardmäßig eine entsprechende Aktion ausgeführt. In der Standardeinstellung wird Windows dann heruntergefahren.

Wenn Sie eine andere Aktion ausführen wollen, können Sie die Belegung folgendermaßen ändern.

Wählen Sie aus der "Systemsteuerung" den Eintrag "Energieoptionen". Hier sehen Sie jetzt die möglichen Energiesparpläne. Wählen Sie hier beim aktiven Energiesparplan den Eintrag "Energiesparplaneinstellungen ändern" (Info: Dieses Einstellung müssen Sie für jeden Energiesparplan vornehmen den Sie verwenden möchten).

Wählen Sie jetzt in nächsten Fenster den Eintrag "Erweitere Energieeinstellungen ändern" aus. Im neuen Fenster "Energieoptionen" können Sie jetzt unter "Netzschalter und Laptopdeckel" die einzelnen Einstellungen für bestimmte Aktionen festlegen. Der Eintrag "Netzschalter" legt dabei die Funktion für das drücken des Netzschalters fest.

Diese Einstellung kann auch über die Registry geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Power\ PowerSettings\ 7648EFA3-DD9C-4E3E-B566-50F929386280

erstellen Sie hier folgende Einträge als Datentyp REG_DWORD

Name | Werte | Beschreibung
DCSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Akkubetrieb
ACSettingIndex | 0 -> keine Aktion ausführen 1 -> Energiesparmodus 2 -> Ruhezustand 3 -> Herunterfahren | Einstellung für den Netzbetrieb

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Energieverwaltung\Schaltflächeneinstellungen
Einstellungsname: | Netzschalteraktion auswählen (Akkubetrieb) Netzschalteraktion auswählen (Netzbetrieb)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2383.htm


Windows HotStart-Tasten konfigurieren

Ab Windows Vista kommt die so genannte "Windows HotStart"-Technologie zum Einsatz, welche die Möglichkeit bietet, spezielle Tasten ("HotStart"-Tasten) mit einer beliebigen Anwendung zu verknüpfen.

Wenn der Anwender diese Taste drückt, wird ohne, dass man sich vorher am Rechner anmelden bzw. den Rechner einschalten muss (diese Funktion muss natürlich auch von der Hardware unterstützt werden), die konfigurierte Anwendung gestartet. Dabei werden lediglich der Prozess (z.B. Windows Mediaplayer) sowie einige Basistreiber für das Programm geladen. Die benötigten Treiber müssen der WDDM-Spezifikationen (Windows Device Driver Model) entsprechen.

Diese sogenannten "HotStart"-Tasten werden vom Hersteller meist mit speziellen Anwendungen belegt (Mediaplayer usw.). Drückt der Anwender auf eine solche Taste, fährt Windows hoch, startet das Programm und fängt z.B. mit der DVD-Wiedergabe an.

Die Belegung der Tasten wird meistens vom Hersteller unter Windows Vista fest eingetragen. In diesem Tipp wollen wir beschreiben, wie Sie die Konfiguration über die Registry ändern können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ ACPI\ PNP0C32\ <ButtonID>

ist die Konfiguration für die jeweiligen HotStart-Tasten abgelegt. Dabei ist die <ButtonID> eine beliebige Nummer (muss nicht mit Null beginnen), die einfach eine beliebige Tastenkonfiguration festlegt.

Für die Konfiguration der Aktion, die beim Drücken einer Taste ausgelöst werden soll, benötigen Sie die <UsageID>, welche aus dem Eintrag "UserHIDBlock" zusammengebaut wird, zu finden unter "HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Enum\ ACPI\ PNP0C32\ <ButtonID>\ Device Parameters".

Dabei wird die <UsageID> über die "Little-Endian (First-Byte-Order)" Methode aus dem "UserHIDBlock"- Eintrag erstellt.

Little-Endian bestimmt die Byte-Reihenfolge und legt fest, dass der Wert von hinten aufgebaut wird. Zusätzlich werden anschließend noch alle führenden Nullen weggeschnitten.

Weitere Infos dazu finden Sie bei Wikipedia unter "Byte-Reihenfolge".

Zwei Beispiele:

  • Unter UserHIDBlock finden Sie den Eintrag: 21 01 00 00. Das ergibt für <UsageID> den Wert: 00000121 und nach dem Entfernen der führenden Nullenden endgültigen Wert 121.
  • Unter UserHIDBlock finden Sie den Eintrag: 04. Aus dem ergibt sich für <UsageID> der Wert: 04 und nach dem Entfernen der führenden Nullen heißt der endgültige Wert 4.

Jetzt wird über die <UsageID> die Taste mit einer Aktion/Anwendung verbunden. Welche Aktion ausgeführt wird, konfigurieren Sie an der folgenden Stelle:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Steuerung\ MobilePC\ HotStartButtons\ <UsageID>

Erstellen Sie hier jetzt einen Eintrag "ApplicationPath" als Datentyp REG_SZ und geben den Pfad und die Anwendung ein, die gestartet werden soll. Zusätzlich können Sie noch benötigte Parameter mit angeben. Die Länge des Eintrages darf aber 260 Zeichen nicht überschreiten.

Wenn Sie z.B. über die oben ermittelte Taste 4 den Windows Media Player mit DVD-Wiedergabe starten wollen, muss der Eintrag folgendermaßen aussehen:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Steuerung\ MobilePC\ HotStartButtons\ 4

Der Wert "ApplicationPath" muss dann folgenden Eintrag haben:

"C:\program files\windows media player\wmplayer.exe" /Device:DVD

Um zu testen, ob das Drücken einer HotStart-Taste auch richtig erkannt wurde, überprüfen Sie den Zeitstempel in der Registry nach dem Drücken der Taste.

Diesen Eintrag finden Sie in der Registry unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ HotStart

mit dem Namen "LastTimeStamp", wohin die aktuelle Zeit der letzten HotStart-Tasten Erkennung eingetragen wird.

Siehe dazu auch:

  • Configuring Windows HotStart
  • Direct Application Launch from System Startup on Windows Vista

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2546.htm


Windows HotStart-Tasten ein-/ausschalten

Ab Windows Vista gibt es die Möglichkeit, spezielle Tasten ("HotStart"-Tasten) mit einer beliebigen Anwendung zu verknüpfen. Weitere Informationen dazu - und wie Sie diese Tasten konfigurieren können - finden Sie im Tipp "Windows HotStart Tasten konfigurieren".

In diesem Tipp wird gezeigt, wie Sie die Funktion der Tasten komplett über die Registry ein-/ausschalten können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "NoHotStart" als Datentyp REG_DWORD und setzen den Wert auf:

0 | HotStart Funktion ausschalten
1 | HotStart Funktion aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Windows HotStart
Einstellungsname: | Windows HotStart deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2545.htm


Aufgabenplanung - Task Scheduler

Aufgabenplanung: Task-Scheduler

Der Task-Scheduler der älteren Windows Versionen wird ab Windows Vista als Aufgabenplanung bezeichnet und wurde vollständig überarbeitet. Über die Aufgabenplanung lassen sich die unterschiedlichsten Aufgaben zeitgesteuert oder aufgrund von Ereignissen ausführen.

Gerade ab Windows Vista sollte man sich mit dieser Funktion etwas befassen. So werden bei Windows Vista mit aktivierten UAC (User Account Control) einige Anwendungen, welche über die normalen Autostartfunktionen ausgeführt werden, geblockt und müssen erst umständlich bestätigt werden.

Über die Aufgabenplanung können Sie solche Anwendung - trotz aktiven UAC - starten und müssen die Ausführung nicht noch extra bestätigen. Wie Sie weitere Anwendung in die Aufgabenplanung einbinden und deren allgemeine Funktionalität werden hier beschreiben.

Die Aufgabenplanung finden Sie unter "Programme" -> "Zubehör" -> "Systemprogramme". Alternativ können Sie auch [Win]+[R] drücken und den Befehl taskschd.msc eingeben, um die Aufgabenplanung zu starten. Beim Start der Aufgabenplanung präsentiert sich ein rundherum überarbeitetes Tool. Die Ansicht der Aufgabenplanung wurde in 3 Teile aufgeteilt.

Im linken Bereich befindet sich die Aufgabenplanungsbibliothek, in der alle definierten Aufgaben angezeigt werden.

Im rechten Bereich finden Sie die Aktionen, mit der Sie die Einstellungen konfigurieren können.

Im mittleren Bereich finden Sie oben eine kurze Beschreibung über das Tool. Darunter finden Sie den aktuellen Aufgabenstatus. Es wird Ihnen angezeigt, welche Aufgaben wann ausgeführt wurden und in welchem Status Sie sich befinden. Unterhalb von "Aktiven Aufgaben" finden Sie die Aufgaben, welche gerade ausgeführt werden und noch aktiv laufen.

Der Aufgabenplaner enthält standardmäßig schon einige Aufgaben, welche Sie unter dem Eintrag "Microsoft\Windows" in weiteren Ordnern strukturiert aufgeteilt vorfinden.

Erstellen einer neuen Aufgabe

Sie haben zwei Möglichkeiten, eine neue Aufgaben zu erstellen. Die Erstellung über den Assistenten werde ich nur kurz beschreiben, bei der Erstellung über "Aufgabe erstellen" werden ich auch gleich anhand eines Beispieles beschreiben, wie Sie Autostarteinträge über eine Aufgabe starten lassen können.

Bevor Sie eine neue Aufgabe erstellen, sollten Sie auf der linken Seite einen neuen Ordner z.B. mit den Namen "Meine Aufgaben" anlegen.

Bevor Sie jetzt eine neue Aufgabe erstellen, wählen Sie diesen Ordner aus, dann wird die neue Aufgabe dort abgelegt, und Sie finden schnell die von Ihnen erstellen Aufgaben wieder. Wenn Sie viele Aufgaben erstellen, können Sie selbstverständlich auch eine entsprechende Baumstruktur dafür anlegen.

Da sich bestehende Aufgaben nicht in der Ordnerstruktur verschieben lassen, müssen Sie vor dem Anlegen einer neuen Aufgabe über "Einfache Aufgabe erstellen" oder "Aufgabe erstellen" den gewünschten Zielordner auf der linken Seite auswählen.

Eintrag "Einfache Aufgabe erstellen"

Über den Eintrag "Einfache Aufgabe erstellen" können Sie mit Hilfe eines Assistenten eine neue Aufgabe hinzufügen.

Zunächst werden Sie nach den Namen für die neue Aufgabe gefragt. Anschließend müssen Sie einen Trigger angeben, womit festgelegt wird, wann die Aufgabe gestartet werden soll. Dabei haben Sie folgende Möglichkeiten:

  • Zeitlich gesteuert (täglich, wöchentliche, monatlich oder nur einmalig)
  • Beim Starten des Rechners: Die Aufgaben werden immer beim Starten des Rechners ausgeführt.
  • Bei der Anmeldung: Die Aufgabe wird bei der Anmeldung ausgeführt
  • Beim Auftreten eines bestimmten Ereignisses: Hier kann man das Ausführen der Aufgabe vom Auftreten eines Ereignisses abhängig machen. Durch diese Funktion kann man z.B. beim Auftreten eines Fehlers eine gewünschte Aktion ausführen lassen (Benachrichtigung).

Als Aktion, die ausgeführt werden soll, kann ein beliebiges Programm, Script oder eine Mail verschickt werden.

Eintrag "Aufgabe erstellen"

Werden über diesen Punkt neue Aufgaben eingerichtet, wird kein Assistent gestartet, dafür stehen aber auch zusätzliche Funktionen zur Verfügung. Hier haben Sie dann auch die Möglichkeit, die Aufgabe unter einem anderen Benutzerkonto ausführen zu lassen.

Beim Ausführen von "Aufgabe erstellen" wird ein neues Dialogfenster geöffnet, wo Ihnen die folgenden Tabreiter angezeigt werden.

Tabreiter: Allgemein

Hier legen Sie den Namen für die neue Aufgabe fest und können noch eine Beschreibung eingeben.

Im Bereich "Sicherheitsoptionen" legen Sie fest, mit welchen Rechten die Anwendung/Script gestartet werden soll. Für Anwendungen, die erweitere Rechte benötigen und deshalb wie oben beschreiben über die Autostartfunktion mit der Meldung "Einige Autostartprogramme wurden geblockt" nicht ausgeführt werden, stellen Sie Folgendes ein:

  • Ein Benutzerkonto mit Administrationsrechten auswählen
  • "Nur ausführen, wenn der Benutzer angemeldet ist" markieren
  • "Mit höchsten Privilegien ausführen" markieren

Aufgabenplanung - Tabreiter Allgemein

Tabreiter: Trigger

Hier können Sie konfigurieren, bei welcher Aktion oder zu welchen Zeitpunkt (täglich usw.) die neue Aufgabe ausgeführt werden soll. Über den Button "Neu" können Sie dafür einen neuen Trigger hinzufügen. Damit der Trigger aktiv ist, müssen Sie unter "Erweitere Einstellungen" bei 'Aktiviert' einen entsprechenden Haken setzen. Anschließend fügen Sie den Trigger über "OK" zur Liste hinzu.

Für Autostartprogramme, welche erweitere Rechte benötigen, stellen Sie hier Folgendes ein:

  • Aufgabe starten: "Bei Anmeldung" auswählen
  • Bei Einstellungen "Jeder Benutzer" markieren
  • Unter Erweiterte Einstellungen "Aktiviert" markieren

Aufgabenplanung - Tabreiter neuer Trigger

Aufgabenplanung - Tabreiter Trigger

Tabreiter: Aktionen

Hier fügen Sie jetzt die Aktionen ein, die ausgeführt werden sollen. Unter Aktionen wird dabei Folgendes angeboten:

  • Ausführen von Programmen/Scripten
  • Anzeigen einer Informationsbox
  • Versenden von Mails

Durch die Möglichkeit, beliebige Programme und Scripte aufrufen zu können, sollten sich damit alle Wünsche erfüllen lassen.

Über den Button "Neu" können Sie dafür entsprechende Aktionen hinzufügen (auch hier sind Sie nicht auf nur eine Aktion beschränkt). Die Aktionen werden in der angegebenen Reihenfolge abgearbeitet, wobei die Reihenfolge nachträglich über die Pfeil-Buttons auf der rechten Seite verändert werden kann.

Aufgabenplanung - Tabreiter neue Aktion

Aufgabenplanung - Tabreiter Aktionen

Tabreiter: Bedingungen

Hier können Sie Voraussetzungen festlegen, die erfüllt sein müssen, damit die Aufgabe ausgeführt wird. So können Sie hier z.B. festlegen, dass eine Aufgabe nur ausgeführt wird, wenn sich der Rechner im Netzwerk befindet.

Aufgabenplanung - Tabreiter Bedingungen

Tabreiter: Einstellungen

Hier können Sie allgemeine Einstellungen für die Aufgabe festlegen. So können Sie z.B. definieren, dass eine Aufgabe nach einer bestimmten Laufzeit automatisch beendet werden soll.

Für Programme, die Sie beim Start des Rechner oder bei der Anmeldung ausführen lassen wollen, sollten Sie hier noch die folgende Funktion aktivieren:

  • Aufgabe so schnell wie möglich nach einem verpassten Start ausführen

Aufgabenplanung - Tabreiter Einstellungen

Aufgaben bearbeiten

Wenn Sie eine bereits vorhandene Aufgabe bearbeiten wollen, wie z.B. Defragmentierung, so müssen Sie in der Aufgabenplanungsbibliothek über die Baumstruktur zu allererst den gewünschten Ordner öffnen. Sie finden die Defragmentierung unter "Microsoft/Windows/Defrag" mit dem Namen "ScheduledDefrag"

Um diese zu bearbeiten, doppelklicken Sie auf die Aufgabe. Anschließend wird Ihnen die Dialogbox angezeigt, die schon oben unter "Aufgabe erstellen" beschrieben wurde und die eine ausführliche Konfiguration der Aufgabe ermöglicht.

Die von Ihnen erstellen Aufgaben finden Sie direkt in dem Ordner, unter dem die Aufgabe angelegt wurde. Wenn Sie sich an der oben genannten Empfehlung gehalten haben, also im Ordner "Meine Aufgaben" unterhalb der Aufgabenplanungsbibliothek.

Wenn Sie diesen Ordner auf der linken Seite im Baum auswählen, werden Ihnen oben in der Mitte die jeweiligen Aufgaben angezeigt. Hier können Sie durch Anklicken der Aufgabe entweder über das Kontextmenü (rechte Maustaste auf die Aufgabe) oder über das Menü auf der rechten Seite folgende Aktionen ausführen:

  • Ausführen: Start der Aufgabe
  • Beenden: Dadurch wird eine laufende Aufgabe beendet
  • Deaktivieren (nur sichtbar, wenn die Aufgabe aktiv ist): Diese Aufgabe wird nicht mehr ausgeführt bis Sie die Aufgabe wieder aktivieren
  • Aktivieren (nur sichtbar wenn die Aufgabe deaktiviert ist): Diese Aufgabe wird wieder ausgeführt.
  • Exportieren: Exportiert die Einstellungen in eine XML-Datei und kann damit auf andere Rechner übertragen und Importiert werden
  • Eigenschaften: Darüber können Sie die Einstellungen der Aufgabe bearbeiten/ändern. Es wird Ihnen dabei das Menü - wie bei der Erstellung einer neuen Aufgabe - angezeigt.
  • Löschen: Damit löschen Sie die Aufgabe vom Rechner.

Aufgabenplanung - Einträge bearbeiten

Zum Austauschen der Aufgaben zwischen den Rechnern, können Sie bestehende Aufgaben exportieren und natürlich auch wieder importieren. Der Export erfolgt in eine XML-Datei, so dass Sie Änderungen an der Datei leicht durchführen können.

Steuerung der Aufgabenplanung per Skript

Die Konfiguration der Aufgabenplanung kann auch über die Kommandozeile ausgeführt werden. Dafür gibt es das Tool "SCHTASKS". Dieses Tool bietet folgende Parameter an:

SCHTASKS /Parameter [Argumente]

Paramter | Beschreibung
/Create | Erstellt eine neue geplante Aufgabe.
/Delete | Löscht geplante Aufgaben.
/Query | Zeigt alle geplanten Aufgaben an.
/Change | Ändert die Eigenschaften der geplanten Aufgabe.
/Run | Führt eine geplante Aufgabe sofort aus.
/End | Beendet die aktive geplante Aufgabe.

Über die Angabe des Parameters und einen zusätzlichen /? können Sie sich die weitere Hilfe zu diesem Parameter anzeigen lassen (z.B.: SCHTASKS /Create /?).

Weitere Links zur Aufgabenplanung

Weitere Informationen dazu finden Sie unter:

  • Windows Vista-Aufgabenplanung: http://technet.microsoft.com/de-de/windowsvista/aa906020.aspx
  • Die Aufgabenplanung reaktiviert den Computer nicht, um in Windows Vista eine geplante Aufgabe auszuführen: http://support.microsoft.com/kb/929463/de

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2548.htm


Anzahl der Prozessoren für den Start konfigurieren

Ab Windows Vista können Sie konfigurieren wie viele Prozessoren verwendet werden. Die Einstellung "Prozessoranzahl" ist lediglich dafür gedacht, auch auf Multi-Prozessor-Systemen ein System mit geringerer Prozessoranzahl zu simulieren.

Standardmäßig benutzt Windows Vista alle verfügbaren Prozessoren (wenn die Einstellung nicht aktiv ist). Durch aktivieren der Einstellung, können Sie die Anzahl der Prozessoren festlegen, die Windows verwenden soll. In den meisten Fällen werden Sie das nicht benötigen, außer Sie benötigen für einen Test weniger Prozessoren.

Um sicherzugehen, dass Sie wirklich alles Prozessoren benutzen, sollten Sie diese Einstellung nicht aktivieren.

Mit den Programm "MSCONFIG.EXE" können Sie konfigurieren, wieviel Prozessoren von Windows benutzt werden sollen. Starten Sie MSCONFIG über "Startmenü" -> "Suche" (oder Windows-Taste + R) und geben hier "MSCONFIG.EXE" ein. Bestätigen Sie die Nachfragen bei aktiver Benutzerkontensteuerung mit "Fortsetzen", damit die Anwendung gestartet wird.

Dann wechseln Sie auf den Tabreiter "Start" und klicken hier auf den Button "Erweiterte Optionen...", wodurch der neue Dialog "Erweitere Startoptionen" geöffnet wird. Hier aktivieren Sie "Prozessoranzahl" und wählen die Anzahl der zu verwendeten Prozessoren aus.

MSCONFIG - Prozessoranzahl

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2582.htm


Sound beim Starten von Windows ausschalten

Beim Starten von Windows wird ein Sound abgespielt. Wenn Sie das nicht wollen, können Sie dies über den folgenden Eintrag deaktivieren: "Systemsteuerung" -> "Sound" -> Tabreiter "Sounds". Bei "Windows-Startsound wiedergeben" den Haken entfernen.

In der Registry finden Sie die Einstellung

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Authentication\ LogonUI\ BootAnimation

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableStartupSound" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Es wird kein Sound mehr abgespielt
0 | Es wird ein Sound abgespielt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2589.htm


Standard-Anmeldebild für alle Benutzer

Mit diesem Tipp legen Sie fest, ob für alle Benutzer ein Standard-Anmeldebild benutzt werden soll. Wenn Sie diesen Tipp aktivieren, wird der Standard-Anmeldebildschirm mit dem Standardbild angezeigt und kann vom Benutzer auch nicht mehr verändert werden.

Das Standardbild wird geladen aus:

Standardbenutzer: "%PROGRAMDATA%\Microsft\User Account Pictures\user.bmp"

Standardgast: "%PROGRAMDATA%\Microsft\User Account Pictures\guest.bmp"

Das Bild hat das Format 128*128 Pixel und eine Farbtiefe von 16 Bit.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "UseDefaultTile" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Standard-Anmeldebild festlegen
0 | Benutzer können das Bild selber festlegen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Systemsteuerung\Benutzerkonten
Einstellungsname: | Standardanmeldebild für alle Benutzer verwenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2311.htm


Fast User Switching aktivieren/deaktivieren

Mit diesem Tipp können Sie das "Fast User Switching" (schnelle Benutzerumschaltung) unter Windows ausschalten. Über diese Funktion kann sich ein anderen Anwender am Rechner anmelden, ohne dass sich der aktuell angemeldete Anwender abmelden muss. Anschließend kann man zwischen den beiden Anmeldungen wechseln. Durch den Tipp wird die Schaltfläche "Benutzer wechseln" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

oder als Policies

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "HideFastUserSwitching" als Datentyp REG_DWORD und setzen den Wert auf:

0 | "Fast User Switching" ist aktiv
1 | "Fast User Switching" ist deaktiv

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Anmeldung
Einstellungsname: | Einstiegspunkte für die schnelle Benutzerumschaltung ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2477.htm


Übersicht der Dienste unter Windows Vista

Hier finden Sie eine Übersicht der Dienste unter Windows Vista und wie diese konfiguriert sind.

Lesen Sie sich immer die Beschreibung des Dienstes durch und überlegen Sie, ob diese Funktion benötigt wird. Es gibt einige Dienste, die zwingend für das Funktionieren von Windows benötigt werden.

Achtung: Eine Deaktivierung eines Dienstes kann dazu führen, dass Windows nicht mehr startet bzw. Sie sich nicht mehr anmelden können.

Weiteres Infos zu Diensten finden Sie im Tipp: "Windows Dienste: Allgemeine Informationen"

Achtung: Gehen Sie beim Verändern der Einstellungen vorsichtig vor, da es dazu führen kann, dass bestimmt Funktionen unter Windows nicht mehr laufen.

Wir geben zwei Empfehlungen in der Tabelle an:

  • Empfehlung Normal: Hier werden nur wenige Dienste verändert. Diese Konfiguration sollte auf den meisten Rechnern zu keinen Problemen führen und keine wichtigen Funktionen einschränken.
  • Empfehlung Minimal: In dieser Einstellungen werden schon recht viele Dienste ausgeschaltet. Es stehen nicht mehr viele Funktionen zur Verfügung. Dieses Einstellung ist für Anwender geeignet, die mit dem Rechner nur spielen wollen und dafür jede zusätzliche Leistung benötigen.

Mit dem Tool "Vista_Service_Config" (Download: http://www.winfaq.de/faqforum/viewtopic.php?p=435#435) können Sie die Konfiguration verändern. Dabei bietet das Tool folgende Funktionen:

  • Sichern der aktuellen Einstellung der Windows Vista Dienste
  • Zurücksetzen auf die Standardwerte (Vista Home Basic, Home Premium, Business, Ultimate)
  • Einstellung auf "Empfehlung Normal"
  • Einstellung auf "Empfehlung Minimal"

Durch das sichern der Einstellungen können Sie leicht Konfigurationen von einem Rechner auf einen anderen übertragen. Wenn Sie eine Einstellung für eine bestimmte Funktion erstellt haben, können Sie die auch gern zusenden um in die Liste der möglichen Konfigurationen aufgenommen zu werden.

Dienstname | Home Basic | Home Premium | Business | Ultimate | Empfehlung Normal | Empfehlung Minimal
Anmeldedienst | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Anschlussumleitung für Terminaldienst im Benutzermodus | - | - | Manuell | Manuell | Manuell | Deaktiviert
Anwendungserfahrung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Anwendungsinformationen | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Anwendungsverwaltung | - | - | Manuell | Manuell | Manuell | Deaktiviert
Arbeitsstationsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Aufgabenplanung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Automatische Konfiguration (verkabelt) | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Automatische WLAN-Konfiguration | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Basisfiltermodul | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Benachrichtigungsdienst für Systemereignisse | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Benutzerprofildienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Block Level Backup Engine Service | - | - | Manuell | Manuell | Manuell | Deaktiviert
CNG-Schlüsselisolation | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
COM+-Ereignissystem | Manuell | Automatisch | Automatisch | Automatisch | Manuell | Manuell
COM+-Systemanwendung | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Computerbrowser | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
DCOM-Server-Prozessstart | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Designs | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
DFS-Replikation | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
DHCP-Client | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Diagnoserichtliniendienst | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Diagnosesystemhost | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Distributed Transaction Coordinator | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
DNS-Client | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Druckwarteschlange | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Enumeratordienst für tragbare Geräte | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Erkennung interaktiver Dienste | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Extensible Authentication-Protokoll | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Fax | - | - | Manuell | Manuell | Deaktiviert | Deaktiviert
Funktionssuchanbieter-Host | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Funktionssuche-Ressourcenveröffentlichung | Manuell | Manuell | Manuell | Automatisch | Deaktiviert | Deaktiviert
Gatewaydienst auf Anwendungsebene | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Gemeinsame Nutzung der Internetverbindung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Geschützter Speicher | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Gruppenrichtlinienclient | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
IKE- und AuthIP IPsec-Schlüsselerstellungsmodule | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Infrarotüberwachungsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Integritätsschlüssel- und Zertifikatverwaltung | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Intelligenter Hintergrundübertragungsdienst | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell
IP-Hilfsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
IPsec-Richtlinien-Agent | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Jugendschutz | Manuell | Manuell | - | Manuell | Deaktiviert | Deaktiviert
Kryptografiedienste | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Manuell
KtmRm für Distributed Transaction Coordinator | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Deaktiviert | Deaktiviert
Leistungsprotokolle und -warnungen | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Microsoft .NET Framework NGEN v2.0.50727_X86 | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Microsoft iSCSI-Initiator-Dienst | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Microsoft-Softwareschattenkopie-Anbieter | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Multimediaklassenplaner | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
NAP-Agent (Network Access Protection) | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Net.Tcp-Portfreigabedienst | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Netzwerklistendienst | Automatisch | Automatisch | Automatisch | Manuell | Manuell | Deaktiviert
Netzwerkspeicher-Schnittstellendienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Netzwerkverbindungen | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
NLA (Network Location Awareness) | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Offlinedateien | - | - | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Peer Name Resolution-Protokoll | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Peernetzwerk-Gruppenzuordnung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Peernetzwerkidentitäts-Manager | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Plug & Play | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
PnP-X-IP-Busauflistung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
PNRP-Computernamenveröffentlichungs-Dienst | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Programmkompatibilitäts-Assistent-Dienst | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
RAS-Verbindungsverwaltung | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
ReadyBoost | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Remoteprozeduraufruf (RPC) | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Remoteregistrierung | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Richtlinie zum Entfernen der Smartcard | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Routing und RAS | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
RPC-Locator | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Sekundäre Anmeldung | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Server | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Server für Threadsortierung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Shellhardwareerkennung | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Sicherheitscenter | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell | Manuell
Sicherheitskonto-Manager | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Sitzungs-Manager für Desktopfenster-Manager | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
SL-Benutzerschnittstellen-Benachrichtigungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Smartcard | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
SNMP-Trap | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Softwarelizenzierung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
SSDP-Suche | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Startprogramm für Windows Media Center | - | Automatisch (Verzögerter Start) | - | Automatisch (Verzögerter Start) | Manuell | Deaktiviert
Superfetch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Tablet PC-Eingabedienst | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
TCP/IP-NetBIOS-Hilfsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Telefonie | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Terminaldienste | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Terminaldienstekonfiguration | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
TPM-Basisdienste | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Überwachung verteilter Verknüpfungen (Client) | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Unterstützung in der Systemsteuerung unter Lösungen für Probleme | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
UPnP-Gerätehost | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Verbessertes Windows-Audio/Video-Streaming | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Verbindungsschicht-Topologieerkennungs-Zuordnungsprogramm | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Verwaltung für automatische RAS-Verbindung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Virtueller Datenträger | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Volumeschattenkopie | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Webclient | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Windows CardSpace | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Driver Foundation - Benutzermodus-Treiberframework | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Installer | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Windows Media Center Extender-Dienst | - | Deaktiviert | - | Deaktiviert | Deaktiviert | Deaktiviert
Windows Media Center-Empfängerdienst | - | Manuell | - | Manuell | Deaktiviert | Deaktiviert
Windows Media Center-Planerdienst | - | Manuell | - | Manuell | Deaktiviert | Deaktiviert
Windows Media Player-Netzwerkfreigabedienst | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Modules Installer | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Presentation Foundation-Schriftartcache 3.0.0.0 | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Update | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell
Windows-Audio | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Audio-Endpunkterstellung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Bilderfassung | Manual | Manual | Manual | Manual | Manual | Deaktiviert
Windows-Defender | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Ereignisprotokoll | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Windows-Ereignissammlung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Farbsystem | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Fehlerberichterstattungsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Windows-Firewall | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Remoteverwaltung (WS-Verwaltung) | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Sicherung | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows-Sofortverbindung - Konfigurationsregistrierungsstelle | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows-Suche | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Verwaltungsinstrumentation | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Windows-Zeitgeber | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
WinHTTP-Web Proxy Auto-Discovery-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
WMI-Leistungsadapter | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Zertifikatverteilung | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Zugriff auf Eingabegeräte | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2322.htm


Windows Dienste: Anschlussumleitung für Terminaldienst im Benutzermodus

Mit diesem Dienst können Sie Drucker und Laufwerke in Termianlverbindungen umleiten. Wenn Sie nicht mit Termianlverbindungen arbeiten, können Sie den Dienst deaktivieren

Gültig für: Ab Windows Vista Business

Allgemeine Informationen
Anzeigename | Anschlussumleitung für Terminaldienst im Benutzermodus
Dienstname | UmRdpService
Windows Beschreibung | Ermöglicht die Umleitung von Druckern, Laufwerken und Anschlüssen für RDP-Verbindungen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Terminaldienste
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ UmRdpService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2270.htm


Windows Dienste: Anwendungserfahrung

Die Anwendungserfahrung ist mit der neuen Oberfläche für die XP-Kompatibilität zuständig. Dieser Dienst wird nur benötigt, wenn die AERO-Oberfläche aktiv .Wenn Sie nicht mit der neuen Oberfläche arbeiten, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Anwendungserfahrung
Dienstname | AeLookupSvc
Windows Beschreibung | Verarbeitet Anwendungskompatibilitäts-Cacheanforderungen beim Start von Anwendungen.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ AeLookupSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2271.htm


Windows Dienste: Anwendungsinformationen

Dieser Dienst ist für das neue Sicherheitskonzept von Windows Vista zuständig. Startet ein Administrator ein Programm, welches administrative Rechte benötigt, erscheint eine Dialogbox, welche vom Anwender bestätigt werden muss.

Wenn der Dienst beendet wird, können keine Anwendungen mehr mit erweiterten Rechten gestartet werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Anwendungsinformationen
Dienstname | Appinfo
Windows Beschreibung | Erleichtert das Ausführen von interaktiven Anwendungen mit zusätzlichen Administratorprivilegien. Wird dieser Dienst angehalten, können die Benutzer keine Anwendungen mit zusätzlichen Administratorprivilegien starten, die zum Ausführen gewünschter Benutzertasks erforderlich sind.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Benutzerprofildienst, Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad wo die Dienstkonfiguration gespeichert wird
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Appinfo

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2272.htm


Windows Dienste: Aufgabenplanung

Dieser Dienst führt die geplanten Aufgaben zur angegebenen Zeit aus. Die Aufgabenplanung finden Sie in der Computerverwaltung (COMPMGMT.MSC) unter "System" -> "Aufgabenplanung". Hier können Sie bestehende Aufgaben bearbeiten oder neue Aufgaben einrichten, die zu bestimmten Zeiten oder Ereignissen (Anmeldung usw.) ausgeführt werden sollen.

Info Weitere Informationen zur Aufgabenplanung finden Sie im Tipp: "Aufgabenplanung: Task-Scheduler"

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Aufgabenplanung
Dienstname | Schedule
Windows Beschreibung | Ermöglicht einem Benutzer, automatische Aufgaben auf diesem Computer zu konfigurieren und zu planen. Wenn dieser Dienst beendet wird, werden diese Vorgänge nicht zu den geplanten Zeiten ausgeführt werden. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC), Windows-Ereignisprotokoll
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Schedule

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2280.htm


Windows Dienste: Automatische Konfiguration (verkabelt)

Dieser Dienst ist für die automatische Konfiguration von Netzwerken zuständig. Es gibt dafür ab Windows Vista dafür zwei Dienste:

  • Einen für verkabelte Netzwerk
  • Einen für drahtlose Netzwerke

Beide Dienste werden bei bedarf von Windows Vista gestartet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Automatische Konfiguration (verkabelt)
Dienstname | dot3svc
Windows Beschreibung | Dieser Dienst führt eine IEEE 802.1X-Authentifizierung auf Ethernet-Schnittstellen aus.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Extensible Authertication-Protokoll, NDIS Usermode I/O Protocol, Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ dot3svc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2281.htm


Windows Dienste: Automatische WLAN-Konfiguration

Dieser Dienst ist für die automatische Konfiguration von Netzwerken zuständig. Es gibt dafür ab Windows Vista dafür zwei Dienste:

  • Einen für verkabelte Netzwerk
  • Einen für drahtlose Netzwerke

Beide Dienste werden bei bedarf von Windows Vista gestartet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Automatische WLAN-Konfiguration
Dienstname | Wlansvc
Windows Beschreibung | Dieser Dienst führt WLAN -Adapter auf und verwaltet WLAN-Verbindungen und -Profile.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Extensible Authertication-Protokoll, NativeWiFi-Filter, NDIS Usermode I/O Protocol, Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Wlansvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2282.htm


Windows Dienste: Basisfiltermodul

Dieser Dienst verwaltet die Windows Firewall, wenn Sie die Dienste "Windows-Firewall", "Routing und RAS" sowie "IPsec und IKE- und AuthIP IPsec-Schlüsselerstellungsmodule" deaktiviert haben oder eine Firewall von einen anderen Anwender benutzen, können Sie diesen Dienst ausschalten

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Basisfiltermodul
Dienstname | BFE
Windows Beschreibung | Das Basisfiltermodul ist ein Dienst, der Firewall- und IPsec-Richtlinien überwacht und eine Benutzermodusfilterung implementiert. Durch das Beenden oder Deaktivieren des BFM-Diensts wird die Sicherheit des Systems erheblich beeinträchtigt. Darüber hinaus zeigen die IPsec-Verwaltungs- und Firewallanwendungen ein unerwartetes Verhalten.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Windows Firewall: Automatisch Siehe Bedingungen oben: Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Gemeinsame Nutzung der Internetverbindung, IKE- und AuthIP IPsec-Schlüsselerstellungsmodule, IPsec-Richtlinien-Agent, Routing und RAS; Windows-Firewall
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ BFE

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2283.htm


Windows Dienste: Benachrichtigungsdienst für Systemereignisse

Dieser Dienst überwacht Systemereignisse und benachrichtigt das COM+Ereignissystem bei gewissen Ereignissen.

ACHTUNG:

Wenn Sie mit einem Notebook arbeiten, sollten Sie den Dienst auf keinen Fall beenden, da dieser Dienst dafür sorgt, dass bei niedrigem Batteriezustand die konfigurierten Aktionen ausgeführt werden.

Wenn Sie auf Ihrem Rechner keine Aktionen haben, die bei gewissen Ereignissen ausgeführt werden, können Sie diesen Dienst auch auf 'Manuell' bzw. 'Deaktiviert' setzen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Benachrichtigungsdienst für Systemereignisse
Dienstname | SENS
Windows Beschreibung | Überwacht Systemereignisse und benachrichtigt Abonnenten des COM+-Ereignissystems bei diesen Ereignissen.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Desktop: Manuell / Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | COM+ Ereignissystem
Wird benötigt | COM+ Systemanwendung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SENS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2284.htm


Windows Dienste: Benutzerprofildienst

Dieser Dienst wird für die Anmeldung an Windows benötigt und darf deshalb nicht ausgeschaltet werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Benutzerprofildienst
Dienstname | ProfSvc
Windows Beschreibung | Dieser Dienst ist für das Laden und Aufhebung von Benutzerprofilen. Wenn dieser Dienst beendet oder deaktiviert wird, können Benutzer sich nicht mehr an- oder abmelden, haben Anwendungen Probleme beim Abruf von Benutzerdaten und Komponenten können keine Ereignisbenachrichtigungen erhalten.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Anwendungsinformationen
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ProfSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2285.htm


Windows Dienste: Block Level Backup Engine Service

Der Dienst "Block Level Backup Engine Service" wird für die Datensicherung und -wiederherstellung auf Blockebene benötigt. Sie können für die Datensicherung optische Medien oder Festplatten-Partitionen als Backupmedium verwenden.

Gültig für: Vista Business, Enterprise, Ultimate

Allgemeine Informationen
Anzeigename | Block Level Backup Engine Service
Dienstname | wbengine
Windows Beschreibung | Modul zur Durchführung der Datensicherung und -wiederherstellung auf Blockebene
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wbengine

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2286.htm


Windows Dienste: CNG-Schlüsselisolation

Speichert und verwaltet die Schlüssel für Kryptographieinformationen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | CNG-Schlüsselisolation
Dienstname | KeyIso
Windows Beschreibung | Der CNG-Schlüsselisolationsdienst wird im LSA-Prozess gehostet. Der Dienst stellt eine Schlüsselprozessisolation für private Schlüssel und zugehörige Kryptografievorgänge gemäß den Anforderungen der allgemeinen Kriterien bereit. Der Dienst speichert und verwendet langlebige Schlüssel in einem sicheren Prozess in Übereinstimmung mit den Anforderungen der allgemeinen Kriterien.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Extensible Authentication-Protokoll
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ KeyIso

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2287.htm


Windows Dienste: DFS-Replikation

Der DFSR-Dienst (Distributed File System Replication) ist eine zustandsbassierte, Multi-Master-Replikationsengiene, die automatisch Updates zu Daten und Ordnern zwischen den Computern kopiert.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | DFS-Replikation
Dienstname | DFSR
Windows Beschreibung | Repliziert Dateien auf mehreren Computern, um sie synchron zu halten. Auf einem Client wird der Dienst für die Serverspeicherung von Ordnern zwischen Computern verwendet. Auf einem Server wird der Dienst verwendet, um eine hohe Verfügbarkeit und einen lokalen Zugriff über ein WAN (Wide Area Network) bereitzustellen. Wenn der Dienst beendet wird, findet keine Dateireplikation statt, und die Dateien auf dem Server sind nicht mehr aktuell. Wenn dieser Dienst deaktiviert wird, werden alle ausdrücklich von diesem Dienst abhängige Dienste nicht gestartet.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | COM+-Ereignissystem, Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ DFSR

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2293.htm


Windows Dienste: Diagnoserichtliniendienst

Der Dienst "DPS" kümmert sich um Problemmeldungen und Problemlösungen für Fehler in Windows Komponenten. Mit diesem Dienst wird auch die Meldung "Dieses Programm wurde möglicherweise nicht richtig installiert.." ausgegeben. In den meisten Fällen kann dieser Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Diagnoserichtliniendienst
Dienstname | DPS
Windows Beschreibung | Der Diagnoserichtliniendienst ermöglicht die Problemerkennung, Problembehandlung und Lösung für Windows-Komponenten. Wenn dieser Dienst beendet wird, funktioniert die Diagnose nicht mehr. Wenn dieser Dienst deaktiviert wird, können alle ausdrücklich von diesem Dienst abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ DPS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2295.htm


Windows Dienste: Diagnosesystemhost

Der Dienst "WdiSystemHost" kümmert sich um die Behandlung und Lösung von Problemen bei Windows-Komponenten. In den meisten Fällen kann dieser Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Diagnosesystemhost
Dienstname | WdiSystemHost
Windows Beschreibung | Der Dienst "Diagnosesystemhost" ermöglicht das Erkennen, Behandeln und Lösen von Problemen für Windows-Komponenten. Wenn dieser Dienst angehalten wird, arbeiten bestimmte Diagnosefunktionen nicht mehr. Wird dieser Dienst deaktiviert, lassen sich alle explizit von diesem Dienst abhängigen Dienste nicht starten.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WdiSystemHost

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2296.htm


Windows Dienste: Enumeratordienst für tragbare Geräte

Der Dienst "WPDBusEnum" wird von einigen MP3-Playern und den Windows Mobile-Devices benötigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Enumeratordienst für tragbare Geräte
Dienstname | WPDBusEnum
Windows Beschreibung | Erzwingt Gruppenrichtlinien für Wechsel-Massenspeichergeräte. Ermöglicht Anwendungen wie Windows Media Player und dem Bildimport-Assistenten, Inhalte unter Verwendung von Wechsel-Massenspeichergeräten zu übertragen und zu synchronisieren.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WPDBusEnum

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2297.htm


Windows Dienste: Erkennung interaktiver Dienste

Der Dienst "UI0Detect" gibt Diensten - ab Windows Vista - die Möglichkeit, über eine Dialogbox mit dem Anwender zu kommunizieren. Da Dienste ab Windows Vista aus Sicherheitsgründen alle mit der Systemsession 0 laufen, können Sie keine Dialogfenster in der Oberfläche des Anwenders anzeigen. Durch diesen Dienst werden solche Meldungen auf der Oberfläche des Anwenders angezeigt.

Da es sehr wenige Dienste gibt, die auf der Benutzeroberfläche Dialoge anzeigen, wird dieser Dienst in den meisten Fällen nicht benötigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Erkennung interaktiver Dienste
Dienstname | UI0Detect
Windows Beschreibung

Aktiviert die Benutzerbenachrichtigung von Benutzereingaben für interaktive Dienste. Dies ermöglicht den Zugriff auf Dialogfelder, die von interaktiven Diensten erstellt werden, wenn sie angezeigt werden. Wenn dieser Dienst beendet wird, funktionieren Benachrichtigungen über neue interaktive Dienstdialogfelder nicht mehr, und der Zugriff auf Dialogfelder von interaktiven Diensten ist eventuell nicht mehr möglich.

Wenn dieser Dienst deaktiviert wird, funktionieren weder die Benachrichtigung über noch der Zugriff auf Dialogfelder von interaktiven Diensten mehr.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktivieren
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ UI0Detec

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2336.htm


Windows Dienste: Extensible Authentication-Protokoll

Über den Dienst "EAPHost" wird eine austauschbare Infrastruktur für verschiedene Authentifizierungsmethoden bereitgestellt. Das Extensible Authentication-Protokoll (EAP), stellt einen einfachen Zugriff auf die Authentifizierungsmethoden bereit, wodurch der Zugriff auf geschützte Netzwerke ermöglicht wird.

Weitere Informationen über EAP finden Sie hier: http://www.microsoft.com/eap

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Extensible Authentication-Protokoll
Dienstname | EapHost
Windows Beschreibung | Der EAP-Dienst (Extensible Authentication Protocol) stellt in folgenden Szenarios eine Netzwerkauthentifizierung bereit: 802.1x (verkabelt und drahtlos), VPN und NAP (Network Access Protection). EAP stellt darüber hinaus APIs (Application Programming Interface, Anwendungsprogrammierschnittstelle) bereit, die von Netzwerkzugriffclients, einschließlich Drahtlosclients und VPN-Clients, beim Authentifizierungsvorgang verwendet werden. Wenn Sie diesen Dienst deaktivieren, kann dieser Computer nicht mehr auf Netzwerke zugreifen, die eine EAP-Authentifizierung verwenden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | CNG-Schlüsselisolation; Remouteprozeduraufruf (RPC)
Wird benötigt | Automatische Konfiguration (verkabelt); Automatische WLAN-Konfiguration
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ EapHost

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2337.htm


Windows Dienste: Fax

Über den Dienst "Fax" wird das Senden und Empfangen von Faxen ermöglicht. Wenn Sie mir Ihrem Rechner keine Faxe versenden wollen, können Sie den Dienst auch deaktivieren.

Gültig für: Vista Business, Enterprise, Ultimate

Allgemeine Informationen
Anzeigename | Fax
Dienstname | Fax
Windows Beschreibung | Ermöglicht das Senden und Empfangen von Faxen mithilfe der Faxressourcen, die auf dem Computer oder im Netzwerk verfügbar sind.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Druckerwarteschlange; Plug & Play; Remoteprozeduraufruf (RPC); Telefonie
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Fax

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2338.htm


Windows Dienste: Funktionssuchanbieter-Host

Der Dienst "fdPHost" wird vom Windows Media Center benutzt. Über diesen Dienst werden mit einem Computer verbundene Geräte erkannt. Wenn Sie den Media Center nicht benutzen und das die Installation von angeschlossenen Geräte selber durchführen wollen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Funktionssuchanbieter-Host
Dienstname | fdPHost
Windows Beschreibung | Hostvorgang für Funktionssuchanbieter.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP; Remoteprozeduraufruf (RPC)
Wird benötigt | PnP-X-IP-Busauflistung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ fdPHost

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2339.htm


Windows Dienste: Funktionssuche-Ressourcenveröffentlichung

Über den Dienst "FDResPub" werden Informationen über angeschlossene Geräte (Laufwerke, Drucker usw.) an andere Computer im Netzwerk weitergeleitet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Funktionssuche - Ressourcenveröffentlichung
Dienstname | FDResPub
Windows Beschreibung | Veröffentlicht diesen Computer und die daran angeschlossenen Ressourcen, damit sie über das Netzwerk gesucht werden können. Wenn dieser Dienst beendet wird, werden die Netzwerkressourcen nicht mehr veröffentlicht, damit sie von anderen Computern im Netzwerk gesucht werden können.
Windows Starttyp | Manuell/Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP; Remoteprozeduraufruf (RPC)
Wird benötigt | Heimnetzgruppen-Anbieter
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ FDResPub

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2340.htm


Windows Dienste: Gemeinsame Nutzung der Internetverbindung

Dieser Dienst "SharedAccess" ist für "Gemeinsame Nutzung der Internetverbindung" und der "Windows-Firewall/Internetverbindungs-Firewall" unter Windows zuständig.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Gemeinsame Nutzung der Internetverbindung
Dienstname | SharedAccess
Windows Beschreibung | Bietet allen Computern in Heim- und kleinen Firmen-Netzwerken Dienste für die Netzwerkadressübersetzung, Adressierung, Namensauflösung und Eindringschutz.
Windows Starttyp | Windows Vista: Manuell Windows 2008: Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Basisfiltermodul; Netzwerkverbindungen; RAS-Verbindungsverwaltung; Windows-Verwaltungsinstrumentation
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SharedAccess

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2342.htm


Windows Dienste: Gruppenrichtlinienclient

Der Dienst "gpsvc" wird für das Beziehen und Anwenden von Gruppenrichtlinien in einer Windows Domäne benötigt. Über die Gruppenrichtlinien können Einstellungen und Restriktionen auf die Computer verteilt werden.

Dieser Dienst ist bei Rechnern, welche sich nicht in einem Netzwerk anmelden, nicht nötigt. Wenn der Dienst aber nicht gestartet ist, kann keine Domänenanmeldung mehr durchgeführt werden.

Die Startart des Dienstes kann ohne Veränderung der Rechte nicht geändert werden. Um die Rechte zu ändern, gehen Sie folgendermaßen vor:

  • Starten Sie den Registryeditor und gehen nun auf den unter "Pfad" angegebenen Schlüssel (Tabelle unten). Klicken Sie den Schlüssel an und wählen Sie im Menü "Bearbeiten" den Eintrag "Berechtigungen..." aus; es wird Ihnen nun das Fenster "Berechtigungen für gpsvc" angezeigt.
  • Damit Sie die Einstellungen der Berechtigungen ändern können, müssen Sie erst einmal den Besitz des Schlüssels übernehmen. Klicken Sie dafür auf den Button "Erweitert" ->. Wechseln Sie hier auf den Tabreiter "Besitzer".
  • In der Auswahlliste "Besitzer ändern nach" wählen Sie den Accounts aus, mit dem Sie arbeiten und setzten zusätzlich noch einen Haken bei "Besitzer der Objekte und untergeordneten Containern ersetzen".
  • Anschließend klicken Sie auf den Button "Übernehmen".
  • Dann wechseln Sie auf den Tabreiter "Berechtigungen". Klicken Sie hier den Eintrag "Administratoren" an, setzen Sie den Haken bei "Vollzugriff" und klicken dann auf "OK".
  • Setzten Sie jetzt noch einen Haken bei "Bestehende vererbbare Berechtigungen aller untergeordneten Objekte durch vererbbare Berechtigungen dieses Objektes ersetzen" und klicken dann auf den Button "Übernehmen". Die anschließende Sicherheitswarnung bestätigen Sie mit "Ja". Jetzt können Sie die Startart des Dienstes verändern.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Gruppenrichtlinienclient
Dienstname | gpsvc
Windows Beschreibung

Von dem Dienst werden Einstellungen angewendet, die von Administratoren mithilfe der Gruppenrichtlinienkomponente für den Computer und Benutzer konfiguriert wurden.

Wenn der Dienst beendet oder deaktiviert wurde, werden die Einstellungen nicht angewendet, und Anwendungen sowie Komponenten können nicht über Gruppenrichtlinien verwaltet werden.

Alle Komponenten oder Anwendungen, die von der Gruppenrichtlinienkomponente abhängen, funktionieren möglicherweise nicht mehr, falls der Dienst beendet oder deaktiviert wird.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Mup; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ gpsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2344.htm


Windows Dienste: IKE- und AuthIP IPsec-Schlüsselerstellungsmodule

Der Dienst "IKEEXT" wird für die Authentifizierung und zum Schlüsselaustausch im Internet Protocol Security (IPSec) benötigt. Sie benötigen diesen Dienst nur, wenn Sie auch IPSec verwenden (IPSEC-Dienste). Auch manche VPN-Clients sind auf den Dienst angewiesen.

Dieser Dienst wird auch für die Verwaltung der lokalen Sicherheitsrichtlinie benötigt.

Microsoft empfiehlt ausdrücklich diesen Dienst in jedem Fall aktiviert zu lassen, es konnten aber noch keine Nachteile bei der Deaktivierung des Dienstes festgestellt werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | IKE- und AuthIP IPsec-Schlüsselerstellungsmodule
Dienstname | IKEEXT
Windows Beschreibung

Die IKEEXT-Diensthosts der Schlüsselerstellungsmodule für IKE (Internet Key Exchange) und Auth-IP (Authenticated Internet Protocol ).

Diese Schlüsselerstellungsmodule werden zur Authentifizierung und zum Schlüsselaustausch in Internet Protocol Security (IPsec) verwendet. Wenn Sie den IKEEXT-Dienst anhalten oder deaktivieren, wird der IKE/AuthIP-Schlüsselaustausch mit Peercomputern deaktiviert.

IPsec ist im Allgemeinen für die Verwendung von IKE/AuthIP konfiguriert, und das Anhalten oder Deaktivieren des IKEEXT-Diensts kann zu einem IPsec-Fehler führen und die Sicherheit des Systems gefährden.

Es wird jedoch dringend empfohlen, den IKEEXT-Dienst auszuführen.
Windows Starttyp

Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Basisfiltermodul
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ IKEEXT

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2345.htm


Windows Dienste: Integritätsschlüssel- und Zertifikatverwaltung

Der Dienst "hkmsvc" (Integritätsschlüssel- und Zertifikatverwaltung) wird für die Benutzung von X.509 Zertifikaten benötigt. Diese Art der Zertifizierung wird oft für die Protokolle SSL/TLS, IPsec, S/MIME, Smartcard, SSH, HTTPS, LDAPv3 und EAP benötigt.

Diese Protokolle werden überwiegend bei Firmen verwendet, doch sie sind mitunter auch auf Rechnern von Privatanwendern notwendig, wenn z.B. die Windows-eigene EFS-Verschlüsselung genutzt wird und das gespeicherte Zertifikat neu importiert werden muss.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Integritätsschlüssel- und Zertifikatverwaltung
Dienstname | hkmsvc
Windows Beschreibung | Stellt ein X.509-Zertifikat und Schlüsselverwaltungsdienste für den NAP-Agent (Network Access Protection) bereit. Die Durchsetzungstechnologien, die X.509-Zertifikate verwenden, funktionieren ohne diesen Dienst möglicherweise nicht ordnungsgemäß.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ hkmsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2347.htm


Windows Dienste: IP-Hilfsdienst

Der Dienst "IP-Hilfsdienst" ermöglicht IPv6 Verbindungen über ein IPv4 Netzwerk. Da es sich beim Internet noch größtenteils um ein IPv4 Netzwerk handelt, sind Sie auf diesen Dienst angewiesen, sobald Sie auf eine IPv6-Site zugreifen möchten.

Da IPv6 noch sehr wenig verwendet wird, können Sie diesen Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | IP-Hilfsdienst
Dienstname | iphlpsvc
Windows Beschreibung | Bietet automatische IPv6-Konnektivität über ein IPv4-Netzwerk. Wenn dieser Dienst beendet wird, verfügt der Computer nur über IPv6-Konnektivität, wenn er an ein IPv6-Netzwerk angeschlossen wird.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | NetIO-Legacy-TDI-Supporttreiber; Netzwerkspeicher-Schnittstellendienst; Remoteprozeduraufruf (RPC); TCP/IP-Protokolltreiber; Windows-Verwaltungsinstrumentation
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ iphlpsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2349.htm


Windows Dienste: Jugendschutz

Der Dienst "WPCSvc" ist für die Verwaltung von Restriktionen für bestimmte Benutzeraccounts unter Windows zuständig. Mit den Jugendschutz-Einstellungen können die Zeiten für den Zugriff, Web-Regeln und Software-Verbote erstellt werden. Wenn Sie keine Benutzer in dieser Hinsicht einschränken wollen (Kinder), können Sie diesen Dienst auch deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Jugendschutz
Dienstname | WPCSvc
Windows Beschreibung | Dieser Dienst aktiviert den Windows-Jugendschutz auf dem Computer. Der Jugendschutz funktioniert nicht, wenn dieser Dienst nicht ausgeführt wird.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktivieren
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WPCSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2517.htm


Windows Dienste: KtmRm für Distributed Transaction Coordinator

Der Dienst "KtmRm" ist eine Sicherheitsfunktion für die verteilten Netzwerkressourcen des Distributed Transaction Coordinator. Damit soll sichergestellt werden, dass der Client-Rechner auch nach einem Systemcrash weiterhin auf die Netzressourcen zugreifen kann.

Der Dienst wird nur benötigt, wenn der Rechner auf verteilte Datenbank im Netzwerk zugreift.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | KtmRm für Distributed Transaction Coordinator
Dienstname | KtmRm
Windows Beschreibung | Koordiniert Transaktionen zwischen MSDTC und dem Kerneltransaktions-Manager (KTM).
Windows Starttyp | Automatisch (Verzögerter Start)
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC); Sicherheitskonto-Manager
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ KtmRm

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2352.htm


Windows Dienste: Microsoft .NET Framework NGEN v2.0.50727_X86

Der Dienst "clr_optimization_v2.0.50727_32" erstellt Dateien, die prozessor-spezifischen Maschinen-Codes enthalten und legt diese im "Native Image Cache" des betreffenden Computers ab. Gebraucht wird das bei System-Updates, wenn die "Runtime Engine" auf diese Images zurückgreift. Die Startart des Dienstes sollte nicht geändert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Microsoft .NET Framework NGEN v2.0.50727_X86
Dienstname | clr_optimization_v2.0.50727_32
Windows Beschreibung | Microsoft .NET Framework NGEN
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ clr_optimization_v2.0.50727_32

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2515.htm


Windows Dienste: Microsoft iSCSI-Initiator-Dienst

Über den Dienst "MSiSCSI" kann Windows über das Netzwerk eine Verbindung zu SCSI-Geräten (Small Computer System Interface) herstellen.

Im privaten Bereich wird es solche Freigaben von SCSI-Geräten sicherlich nicht geben, so dass dieser Dienst deaktiviert werden kann.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Microsoft iSCSI-Initiator-Dienst
Dienstname | MSiSCSI
Windows Beschreibung

Verwaltet Internet SCSI (iSCSI)-Sitzungen, die es zwischen diesem Computer und iSCSI-Remotezielgeräten gibt. Falls dieser Dienst angehalten wird, kann sich dieser Computer nicht an iSCSI-Zielen anmelden und auf diese zugreifen.

Falls der Dienst deaktiviert wird, kann keiner der Dienste, die explizit von diesem Dienst abhängig sind, gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MSiSCSI

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2354.htm


Windows Dienste: Microsoft-Softwareschattenkopie-Anbieter

Der Dienst "swprv" ist für die Verwaltung von softwarebasierten Schattenkopien, welche über den Dienst "Volumenschattenkopie" erstellt werden, zuständig. Bei einer Schattenkopie (Snapshot) handelt es sich um ein Abbild eines Datenträgers zu einem bestimmten Zeitpunkt, welches unter dem Ordner "System Volume Informationen" schreibgeschützt abgelegt wird. Dadurch kann man auf alte Dateiversionen leicht zurückgreifen und diese Dateien aus dem Snapshot wieder herstellen.

Wird der Dienst deaktiviert, ist auch die Ausführung der Systemwiederherstellung nicht mehr möglich. Wer diese Funktionen aber nicht benutzt, kann den Dienst deaktivieren, um die Systemressourcen zu schonen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Microsoft-Softwareschattenkopie-Anbieter
Dienstname | swprv
Windows Beschreibung | Verwaltet softwarebasierte Volumeschattenkopien des Volumeschattenkopie-Dienstes. Softwarebasierte Volumeschattenkopien können nicht verwaltet werden, wenn dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ swprv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2355.htm


Windows Dienste: Multimediaklassenplaner

Der Dienst "MMCSS" verwaltet die laufenden Tasks auf einem Rechner und weist die Prioritätsstufen zu. Dadurch wird gewährleistet, dass Multimediaanwendungen sehr weit oben in der Priorität eingestuft werden.

Der Dienst kann nicht deaktiviert werden, wenn der Rechner "Audio-Funktionen" ausführt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Multimediaklassenplaner
Dienstname | MMCSS
Windows Beschreibung | Ermöglicht eine relative Prioritätseinstufung von Aufgaben basierend auf systemweiten Aufgabenprioritäten. Dies ist vor allem für Multimediaanwendungen bestimmt. Wenn dieser Dienst angehalten wird, werden die einzelnen Aufgaben auf die jeweilige Standardpriorität zurückgesetzt.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Manuell
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Windows-Audio
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MMCSS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2356.htm


Windows Dienste: NAP-Agent (Network Access Protection)

Der Dienst "napagent" legt Sicherheitsrichtlinien für Rechner in einem Netzwerk fest, die sich mit einer Windows-Domäne verbinden. Der Dienst wird nur in Netzwerken mit einer Windows-Domäne benötigt, in welche die Sicherheitsrichtlinien verteilt werden müssen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | NAP-Agent (Network Access Protection)
Dienstname | napagent
Windows Beschreibung | Aktiviert NAP-Funktionen (Network Access Protection) auf Clientcomputern.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ napagent

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2357.htm


Windows Dienste: Net.Tcp-Portfreigabedienst

Der Dienst "NetTcpPortSharing" ermöglicht es, TCP- Ports über das Netzwerk mit anderen Rechnern zu teilen. Der Dienst ist standardmäßig von Microsoft auf jedem Rechner deaktiviert, da er eigentlich nicht verwendet wird. Diese Konfiguration müssen Sie nicht verändern.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Net.Tcp-Portfreigabedienst
Dienstname | NetTcpPortSharing
Windows Beschreibung | Ermöglicht es, TCP-Ports über das Protokoll "Net.Tcp" freizugeben.
Windows Starttyp | Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ NetTcpPortSharing

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2516.htm


Windows Dienste: Netzwerklistendienst

Der Dienst "netprofm" verwaltet und pflegt die Netzwerkliste mit den verbundenen Netzwerken. Er speichert die Einstellungen für die Netzwerkverbindungen ab und informiert Anwendungen, wenn sich die Einstellungen verändern.

Wenn der Dienst nicht aktiv ist, wird in der Taskleiste nicht mehr angezeigt ob man mit dem Netzwerk noch verbunden ist, es können aber weiterhin noch Netzwerkverbindungen aufgebaut werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Netzwerklistendienst
Dienstname | netprofm
Windows Beschreibung | Identifiziert die Netzwerke, mit denen der Computer eine Verbindung hergestellt hatte, sammelt und speichert Eigenschaften für diese Netzwerke, und benachrichtigt Anwendungen, wenn sich diese Eigenschaften ändern.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | NLA (Network Location Awareness); Remoteprozeduraufruf (RPC)
Wird benötigt | SL-Benutzerschnittstellen-Benachrichtigungsdienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ netprofm

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2358.htm


Windows Dienste: Netzwerkspeicher-Schnittstellendienst

Der Dienst "nsi" überwacht die vorhandenen Netzwerkschnittstellen und meldet Änderungen an Systemprogrammen und Anwendungen. Wenn der Dienst nicht läuft, kann man sich nicht mehr mit anderen Rechnern im Netzwerk verbinden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Netzwerkspeicher-Schnittstellendienst
Dienstname | nsi
Windows Beschreibung | Dieser Dienst stellt Netzwerkbenachrichtigungen (z. B. beim Hinzufügen/Löschen von Schnittstellen) für Benutzermodusclients bereit. Wenn Sie diesen Dienst beenden, wird die Netzwerkkonnektivität getrennt. Wenn dieser Dienst deaktiviert wird, können andere Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | NSI proxy service
Wird benötigt | Arbeitsstationsdienst; DHCP-Client; IP-Hilfsdienst; Netzwerkverbindungen; NLA (Network Location Awareness)
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ nsi

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2359.htm


Windows Dienste: Offlinedateien

Der Dienst "CscService" hält den Offline-Dateicache auf dem aktuellen Stand. Der Dienst sorgt dafür, dass die Offlinedateien beim An- und Abmelden eines Anwenders mit dem Netzwerk abgeglichen werden.

Wenn Sie nicht mit Offlinedateien in einem Netzwerk arbeiten, können Sie den Dienst deaktivieren.

Gültig für: Ab Windows Vista Business

Allgemeine Informationen
Anzeigename | Offlinedateien
Dienstname | CscService
Windows Beschreibung | Der Offlinedateiendienst führt Wartungsaktivitäten am Offlinedateiendienst aus, reagiert auf Benutzeranmelde- und -abmeldeereignisse, implementiert die internen Komponenten der öffentlichen API, leitet interessante Ereignisse an Empfänger weiter, die an Offlineaktivitäten interessiert sind, und ändert den Cachestatus.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ CscService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2362.htm


Windows Dienste: Peer Name Resolution-Protokoll

Der Dienst "PNRPsvc" wird für Peer-to-Peer Netzwerke benötigt, um ohne DNS-Server, mit einer Namensauflösung arbeiten zu können.

Ohne diesen Dienst kann es bei den Anwendungen "Windows-Teamarbeit" und bei "Filesharing-Programmen" zu Problemen kommen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Peer Name Resolution-Protokoll
Dienstname | PNRPsvc
Windows Beschreibung | Aktiviert die serverlose Peernamenauflösung über das Internet. Falls dieser Dienst deaktiviert ist, können einige Peer-zu-Peer- und Zusammenarbeitsanwendungen, wie z. B. Windows-Besprechungen, eventuell nicht ausgeführt werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Peernetzwerkidentitäts-Manager
Wird benötigt | Peernetzwerk-Gruppenzuordnung; PNRP-Computernamenveröffentlichungs-Dienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PNRPsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2363.htm


Windows Dienste: Peernetzwerk-Gruppenzuordnung

Der Dienst "p2psvc" ist für die Gruppenzuordnungen bei Peer-to-Peer Netzwerken unter Verwendung des IPv6-Protokoll zuständig.Ohne diesen Dienst kann es bein den Anwendungen "Windows-Teamarbeit" zu problemen kommen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Peernetzwerk-Gruppenzuordnung
Dienstname | p2psvc
Windows Beschreibung | Bietet Peernetzwerk-Gruppenzuordnungsdienste an.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Peer Name Resolution-Protokoll; Peernetzwerkidentitäts-Manager
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ p2psvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2364.htm


Windows Dienste: Peernetzwerkidentitäts-Manager

Der Dienst "p2pimsvc" ist für die Identiizierung von Peer-to-Peer Netzwerken unter Verwendung des IPv6-Protokoll zuständig.Ohne diesen Dienst kann es bein den Anwendungen "Windows-Teamarbeit" zu problemen kommen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Peernetzwerkidentitäts-Manager
Dienstname | p2pimsvc
Windows Beschreibung | Bietet Identitätsdienst für Peernetzwerke.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Peer Name Resolution-Protokoll; Peernetzwerk-Gruppenzuordnung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ p2pimsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2365.htm


Windows Dienste: PnP-X-IP-Busauflistung

Der Dienst "IPBusEnum" erweitert die Plug & Play Funktion um Netzwerkfunktionalität PnP-X (Plug & Play Extensions). Über diesen Dienst werden Geräte im Netzwerk erkannt und wenn nötig automatisch die notwendigen Treiber installiert. Über PnP-X-IP-Busauflistung wird der "Virtual Network Bus" verwaltet, welcher die erkannten Geräte an den Plug & Play Dienst weiterleitet.

Im privaten Bereich wird dieser Dienst nur selten benötigt (Windows Media Center) und kann deshalb deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | PnP-X-IP-Busauflistung
Dienstname | IPBusEnum
Windows Beschreibung | Der PnP-X-Busauflistungsdienst verwaltet den virtuellen Netzwerkbus. Er sucht mithilfe der SSDP/WS-Suchprotokolle nach den mit dem Netzwerk verbundenen Geräten und sorgt dafür, dass sie in PnP als vorhanden gekennzeichnet sind. Wenn dieser Dienst beendet oder deaktiviert wird, wird das Vorhandensein von NCD-Geräten in PnP nicht verwaltet. Alle PnP-X-basierten Szenarios funktionieren in diesem Fall nicht mehr.
Windows Starttyp | Windows Vista: Manuell Windows 2008: Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Funktionssuchanbieter-Host; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ IPBusEnum

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2367.htm


Windows Dienste: PNRP-Computernamenveröffentlichungs-Dienst

Der Dienst "PNRPAutoReg" gehört zum neuen Datenübertragungsprotokoll für Peer-to-Peer Netzwerke und ermöglicht dynamische DNS-Namensveröffentlichung. Durch den Dienst wird ein DNS-Server, welcher normalerweise die Aufagbe der Namensveröffentlichung übernimmt, überflüssig.

Der Dienst unterstützt zwar auch IPv4, ist aber hauptsächlich für IPv6 gedacht so das dieser Dienst deaktiviert werden kann.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | PNRP-Computernamenveröffentlichungs-Dienst
Dienstname | PNRPAutoReg
Windows Beschreibung | Dieser Dienst veröffentlicht einen Computernamen mit dem Peer Name Resolution-Protokoll. Die Konfiguration wird über den netsh-Kontext "p2p pnrp peer" verwaltet.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Peer Name Resolution-Protokoll
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PNRPAutoReg

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2368.htm


Windows Dienste: Programmkompatibilitäts-Assistent-Dienst

Der Dienst "PcaSvc" wird für den "Programm Compatibility Assistant - PCA" benötigt. Der Dienst wurde ab Windows Vista eingeführt und kümmert sich darum, Programme besser laufen zu lassen, die Kompatibilitätsprobleme mit dem neuen Betriebssystem haben. Wird durch den PCA ein bekanntest Problem mit der Software festgestellt, wird der Anwender über das Problem informiert und vorhandene Lösungsvorschläge werden angeboten.

Ist der Dienst nicht aktiv, wird der "Programm Compatibility Assistant" nicht mehr gestartet. Wenn Sie alle alten Programme ausgeführt haben, können Sie den Dienst beenden und bei Bedarf starten.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Programmkompatibilitäts-Assistent-Dienst
Dienstname | PcaSvc
Windows Beschreibung | Bietet Unterstützung für den Programmkompatibilitäts-Assistenten. Wenn dieser Dienst beendet wird, wird der Programmkompatibilitäts-Assistent nicht ordnungsgemäß ausgeführt. Wenn dieser Dienst deaktiviert wird, können alle von diesem Dienst abhängigen Dienste nicht gestartet werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PcaSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2369.htm


Windows Dienste: ReadyBoost

Der Dienst "EMDMgmt" wird für die neue Funktion "ReadyBoost" benötigt. Mit "ReadyBoost" können externe USB-Flash Speicher als zusätzlicher Festplattencache benutzt werden. Bei den meisten Rechnern macht diese Funktion keinen Sinn, da die Rechner schon über ausreichend Speicher verfügen.

Der Dienst wird hier als Empfehlung "Deaktiviert", da wir keinen spürbaren Geschwindigkeitsgewinn feststellen konnten.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | ReadyBoost
Dienstname | EMDMgmt
Windows Beschreibung | Bietet Unterstützung zum Verbessern der Systemleistung mithilfe von ReadyBoost.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | File Information FS MiniFilter; ReadyBoost Caching Driver; Remoteprozeduraufruf (RPC); Softwarelizenzierung
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ EMDMgmt

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2371.htm


Windows Dienste: Richtlinie zum Entfernen der Smartcard

Der Dienst "SCPolicySvc" legt fest, was für Aktionen ausgeführt werden sollen wenn eine Smartcard aus dem Leser entfernt wird. Bei einer Smartcard handelt es sich um Chipkarten (meist in der Größe von Kreditkarten) auf denen z.B. die Informationen für Zugangsberechtigungen abgespeichert werden können.

Wenn Sie keinen Smartcard Leser besitzen, können Sie den Dienst auch abschalten.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Richtlinie zum Entfernen der Smartcard
Dienstname | SCPolicySvc
Windows Beschreibung | Lässt eine Konfiguration des Systems zu, bei der der Benutzerdesktop bei Entfernen der Smartcard gesperrt wird.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SCPolicySvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2421.htm


Windows Dienste: Server für Threadsortierung

Der Dienst "THREADORDER" ist für die optimierte zeitliche Reihenfolge für die Abarbeitung von Kernel-Threads verantwortlich

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Server für Threadsortierung
Dienstname | THREADORDER
Windows Beschreibung | Bietet eine nach Reihenfolge geordnete Ausführung einer Gruppe von Threads innerhalb eines bestimmten Zeitraums.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ THREADORDER

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2426.htm


Windows Dienste: Sitzungs-Manager für Desktopfenster-Manager

Der Dienst "UxSms" ist für die neuen AERO-Effekte zuständig und kümmert sich um Anwendungen, die nicht mit der neuen Oberfläche kompatibel sind, damit diese auch fehlerfrei laufen. Dieser Dienst benötigt sehr viel Ressourcen wie Arbeitsspeicher (RAM: zwischen 30 und 100 MB) und Prozessorleistung.

Wer auf die AERO-Effekte wie Transparenz, Mouseover usw. verzichten kann und einen nicht so leistungsstarken Rechner besitzt, sollte diesen Dienst deaktivieren. Wenn Sie weiterhin den Dienst "Designs" aktiv lassen, bleibt die AERO-Oberfläche noch erhalten.

Ist der Dienst aktiv, wird er im Taskmanager als DWM.EXE angezeigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Sitzungs-Manager für Desktopfenster-Manager
Dienstname | UxSms
Windows Beschreibung | Stellt Start- und Wartungsdienste für den Desktopfenster-Manager bereit
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ UxSms

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2430.htm


Windows Dienste: SL-Benutzerschnittstellen-Benachrichtigungsdienst

Der Dienst "SLUINotify" ist für das Lizenzieren und Überwachen der Lizenzierung der Software notwendig wie z.B. auch die Aktivierung von Windows. Der Dienst gibt auch entsprechende Warnmeldungen aus, wenn Lizenzierungen abgelaufen sind.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | SL-Benutzerschnittstellen-Benachrichtigungsdienst
Dienstname | SLUINotify
Windows Beschreibung | Stellt Softwarelizenzaktivierung und -benachrichtigung zur Verfügung
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | COM+-Ereignissystem; Netzwerklistendienst; Softwarelizenzierung
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SLUINotify

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2431.htm


Windows Dienste: SNMP-Trap

Der Dienst "SNMPTRAP" ist für das SNMP (Simple Network Management Protocol) zuständig. Über dieses Netzwerk-Protokoll werden unterschiedliche Netzwerkkomponenten (Server, Switches, Drucker, Router usw.) von einer zentralen Station aus überwacht. Der Dienst ist dafür zuständig, Nachrichten (TRAP-Nachrichten) von diesen Komponenten zu empfangen und an die SNMP-Management-Programme weiterzuleiten.

Diese Funktion wird nur von Netzwerkadministratoren benötigt und kann deshalb in privaten Umgebungen deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | SNMP-Trap
Dienstname | SNMPTRAP
Windows Beschreibung | Empfängt Trap-Nachrichten, die von lokalen oder Remote-SNMP-Agenten generiert wurden, und leitet die Nachrichten an SNMP-Verwaltungsprogramme, die auf diesem Computer ausgeführt werden, weiter. SNMP-basierte Programme auf diesem Computer empfangen keine SNMP-Trap-Nachrichten, falls dieser Dienst beendet wird. Falls dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst ausschließlich abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SNMPTRAP

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2433.htm


Windows Dienste: Softwarelizenzierung

Der Dienst "slsvc" ist für den Download und die Installation digitaler Signaturen und Lizenzen zuständig.

Info Der Dienst sollte nicht abgeschaltet werden, da er auch für das Windows-Update benötigt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Softwarelizenzierung
Dienstname | slsvc
Windows Beschreibung | Aktiviert das Herunterladen, die Installation und die Durchsetzung digitaler Lizenzen für Windows und Windows-Anwendungen. Wird dieser Dienst deaktiviert, werden das Betriebssystem und lizenzierte Anwendungen in einem reduzierten Funktionsmodus ausgeführt.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | ReadyBoost; SL-Benutzerschnittstellen-Benachrichtigungdienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ slsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2434.htm


Windows Dienste: Startprogramm für Windows Media Center

Der Dienst "ehstart" ist für die Funktion des Windows Media-Centers notwendig. Der Dienst lädt beim Hochfahren des Computers den "Windows Media Center-Empfängerdienst" und den "Windows Media Center-Planerdienst". Wenn Sie die Funktion "Media Center" nicht benutzen, können Sie den Dienst deaktivieren.

Gültig für: Nur Windows Vista Home Premium und Ultimate

Allgemeine Informationen
Anzeigename | Startprogramm für Windows Media Center
Dienstname | ehstart
Windows Beschreibung | Startet den Windows Media Center-Planerdienst und den Media Center-Empfängerdienst beim Start, wenn TV im Windows Media Center aktiviert ist.
Windows Starttyp | Automatisch (Verzögerter Start)
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ehstart

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2518.htm


Windows Dienste: Superfetch

Der Dienst "SysMain" überwacht und protokolliert, welche Programme auf den Rechner gestartet werden und sorgt aufgrund der Informationen dafür, dass oft geladene Programme über den Preload in den Speicher geladen werden, um die Ladezeit entsprechend zu verkürzen. Weiterhin werden diese Programme auf der Festplatte in den Bereich verschoben, von wo aus sie schneller geladen werden können.

Durch diese Funktion wird die Ladezeit der häufig genutzten Anwendungen optimiert, zusätzlich verbraucht diese Funktion selber aber auch Arbeitsspeicher und durch das Verschieben von Anwendungen in andere Bereiche der Festplatte wird auch die Festplatte entsprechend belastet.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Superfetch
Dienstname | SysMain
Windows Beschreibung | Verwaltet und verbessert die Systemleistung im Zeitablauf.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Deaktiviert
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | File Information FS MiniFilter; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SysMain

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2436.htm


Windows Dienste: Tablet PC-Eingabedienst

Der Dienst "TabletInputService" wird nur auf Tablet-PC für die Eingabe über den Zeichenstift benötigt. Da dies auf den wenigsten Rechner der Fall sein sollte, kann dieser Dienst auf den meisten Rechnern deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Tablet PC-Eingabedienst
Dienstname | TabletInputService
Windows Beschreibung | Ermöglicht die Stift- und Freihandfunktionalität von Tablet PC.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug u. Play; Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TabletInputService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2437.htm


Windows Dienste: Terminaldienstekonfiguration

Der Dienst "SessionEnv" ist für die Konfiguration und Verwaltung der Sitzungen der Terminaldienste und Remotedesktop zuständig.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Terminaldienstekonfiguration
Dienstname | SessionEnv
Windows Beschreibung | Die Terminaldienstekonfigurationdienst(TSCS, Terminal Services Configuration Service) ist für alle Konfigurations- und Sitzungsverwaltungsaktivitäten im Zusammenhang mit den Terminaldiensten und Remotedesktop zuständig, die den SYSTEM-Kontext erfordern. Dazu gehören die sitzungsspezifischen temporären Ordner, TS-Themen und TS-Zertifikate.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Arbeitsstationsdienst; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SessionEnv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2441.htm


Windows Dienste: TPM-Basisdienste

Der Dienst "TBS" ist für den Zugriff auf TPM (Trusted Platform Modul) zuständig. Diese Funktion bietet hardware-basierte Verschlüsselungsdienste an, wenn ein entsprechender Chipsatz in Rechner eingebaut ist. Wird diese Verschlüsselung nicht benötigt bzw. ist noch kein TPM-Chipsatz im Rechner vorhanden, kann dieser Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | TPM-Basisdienste
Dienstname | TBS
Windows Beschreibung

Aktiviert den Zugriff auf das TPM (Trusted Platform Module). Es bietet hardwarebasierte kryptographische Dienste für Systemkomponenten und -anwendungen.

Wird dieser Dienst beendet oder deaktiviert, können von den Anwendungen keine durch das TPM geschützten Schlüssel verwendet werden.
Windows Starttyp

Windows Vista: Manuell

Windows 2008: Automatisch (Verzögerter Start)
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TBS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2442.htm


Windows Dienste: Unterstützung in der Systemsteuerung unter Lösungen für Probleme

Der Dienst "wercplsupport" ist für die Funktion "Fehlermeldungen an Microsoft" zu versenden zuständig. Er wird auch für den Eintrag "Lösungen für Probleme" aus der Systemsteuerung benötigt.

Wer keine Daten an Microsoft versenden will, kann diesen Dienst auch deaktivieren und erhält dadurch keine entsprechende Nachfrage mehr, wenn eine Anwendung abstürzt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Unterstützung in der Systemsteuerung unter Lösungen für Probleme
Dienstname | wercplsupport
Windows Beschreibung | Dieser Dienst bietet Unterstützung für das Anzeigen, Senden und Löschen von Problemberichten auf Systemebene für das Applet "Lösungen für Probleme" in der Systemsteuerung.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktivieren
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wercplsupport

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2444.htm


Windows Dienste: Verbessertes Windows-Audio/Video-Streaming

Der Dienst "QWAVE" ist für Audio- und Videostreaming Anwendungen im Netzwerk zuständig. Der Dienst kümmert sich um die Bandbreitenverteilung bei den Streaminganwendungen und überwacht die ordnungsgemäße Funktion aller Komponenten.

Wenn Sie keinen Streaming-Client benutzen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Verbessertes Windows-Audio/Video-Streaming
Dienstname | QWAVE
Windows Beschreibung | Der Windows-Dienst für verbessertes Audio/Video-Streaming (qWave) ist eine Netzwerkplattform für Audio/Video-Streaminganwendungen (AV) auf privaten IP-Netzwerken. qWave verbessert die AV-Streamingleistung und -zuverlässigkeit, indem ein Netzwerk-QoS (Quality-of-Service) für AV-Anwendungen sichergestellt wird. Es werden Mechanismen für Zugangssteuerung, Laufzeitüberwachung und -erzwingung, Anwendungsfeedback sowie Verkehrspriorisierung bereitgestellt.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Link-Layer Topology Discovery Mapper I/O Driver; QoS-Paketplaner; QWAVE-Treiber; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ QWAVE

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2446.htm


Windows Dienste: Verbindungsschicht-Topologieerkennungs-Zuordnungsprogramm

Der Dienst "LLTDSVC" sucht nach Ressourcen im Netzwerk für die Netzwerkübersicht "Netzwerk- und Freigabecenter". In dieser Übersicht werden alle angeschlossenen Geräte und deren Verbindungsstatus dargestellt.

Sie können den Dienst ohne Einschränkungen deaktivieren und können dann immer noch die Netzwerkübersicht aufrufen. Die Daten werden weiterhin angezeigt, nur sind die Daten nicht immer aktuell und werden langsamer als sonst angezeigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Verbindungsschicht-Topologieerkennungs-Zuordnungsprogramm
Dienstname | lltdsvc
Windows Beschreibung | Erstellt eine Netzwerkübersicht, die Computer- und Gerätetopologieinformationen (d.h. Konnektivitätsinformationen) und Metadaten enthält, die jeden Computer und jedes Gerät beschreiben. Wenn dieser Dienst deaktiviert wird, wird die Netzwerkübersicht nicht mehr richtig funktionieren.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Link-Layer Topology Discovery Mapper I/O Driver; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ lltdsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2447.htm


Windows Dienste: Virtueller Datenträger

Der Dienst "VDS" (Virtual Disk Service) ist für die Verwaltung diverser Datenträger im Netzwerk verantwortlich. Durch den Dienst werden verschiedene Speichergeräte virtualisiert und übersichtlich zusammengefasst. Der Dienst wird nur in Netzwerken benötigt ab Windows Server 2003 wo die VDS-Technologie benutzt wird.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Virtueller Datenträger
Dienstname | vds
Windows Beschreibung | Bietet sowohl Verwaltungsdienste für Datenträger, Volumes, Dateisysteme als auch Hardwarearrayobjekte, z. B. Subsysteme, Controller usw.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug u. Play; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ vds

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2449.htm


Windows Dienste: Windows CardSpace

Der Dienst "idsvc" ist für die Authentifizierung (insbesondere bei Web-Seiten und Web-Diensten) zuständig. Der Dienst verwaltet die digitalen Identitäten. Da diese Microsoft-eigene Authentifizierung sich im WEB bis jetzt nicht richtig durchsetzen konnte, wird dieser Dienst in den meisten Fällen nie benötigt und kann deshalb deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows CardSpace
Dienstname | idsvc
Windows Beschreibung | Ermöglicht die sichere Erstellung, Verwaltung und Veröffentlichung digitaler Identitäten.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ idsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2452.htm


Windows Dienste: Windows Driver Foundation - Benutzermodus-Treiberframework

Der Dienst "wudfsvc" ist für die Verwaltung des Treiberhostprozesses im eingeschränkten Benutzermodus zuständig. Der neue Benutzermodus-Treiberframework wurde zur Sicherheit ab Windows Vista eingeführt und wird bei neuen Treibern verwendet. Da man nicht mehr mit administrativen Konten am Rechner arbeiten sollte, sollte der Dienst auch nicht deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows Driver Foundation - Benutzermodus-Treiberframework
Dienstname | wudfsvc
Windows Beschreibung | Verwaltet Benutzermodus-Treiberhostprozesse
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug u. Play
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wudfsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2453.htm


Windows Dienste: Windows Media Center Extender-Dienst

Der Dienst "Mcx2Svc" wird für zusätzliche Geräte im Windows Media Center benötigt. Wenn der Dienst aktiviert wird, kann über eine XBOX auf die Medien im Windows Media Center zugegriffen werden. Wenn Sie keine extra Geräte verwenden, können Sie den Dienst deaktiviert lassen.

Gültig für: Nur Windows Vista Home Premium und Ultimate

Allgemeine Informationen
Anzeigename | Windows Media Center Extender-Dienst
Dienstname | Mcx2Svc
Windows Beschreibung | Ermöglicht Windows Media Center Extender-Geräten, den Computer zu finden und eine Verbindung herzustellen.
Windows Starttyp | Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Funktionssuchanbieter-Host; PnP-X-IP-Busauflistung; SSDP-Suche; Terminaldienste
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Mcx2Svc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2519.htm


Windows Dienste: Windows Media Center-Empfängerdienst

Der Dienst "ehRecvr" wir vom Windows Mediacenter nur benötigt, wenn Sie TV oder Radiosendungen aufnehmen oder über das Mediacenter anschauen wollen. Wenn Sie diese Funktion nicht benutzen, können Sie den Dienst auch deaktivieren.

Gültig für: Nur Windows Vista Home Premium und Ultimate

Allgemeine Informationen
Anzeigename | Windows Media Center-Empfängerdienst
Dienstname | ehRecvr
Windows Beschreibung | Windows Media Center-Dienst für den Empfang von TV- und UKW-Übertragungen
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ehRecvr

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2520.htm


Windows Dienste: Windows Media Center-Planerdienst

Der Dienst "ehSched" steuert den Aufnahmestart und das Beenden der Aufnahme. Wenn Sie über das Mediacenter keine Filme/Musik aufnehmen wollen, können Sie den Dienst auch deaktivieren.

Gültig für: Nur Windows Vista Home Premium und Ultimate

Allgemeine Informationen
Anzeigename | Windows Media Center-Planerdienst
Dienstname | ehSched
Windows Beschreibung | Startet und beendet die Aufzeichnung von TV-Sendungen in Windows Media Center
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remouteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ ehSched

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2521.htm


Windows Dienste: Windows Media Player-Netzwerkfreigabedienst

Der Dienst "WMPNetworkSvc" gibt die digitalen Medien automatisch anderen Rechnern- ab Windows Vista- im LAN-Netzwerk mittels UPnP (Universal Plug & Play) frei.

In den meisten Firmennetzwerken sollte man diesen Dienst deaktivieren, da hier solche Freigaben meist nicht erwünscht sind. Im privaten Bereich kann es in Netzwerken mit Windows Vista Rechnern hilfreich sein, wenn diese Funktion benötigt wird, ansonsten kann auch hier der Dienst deaktiviert werden.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows Media Player-Netzwerkfreigabedienst
Dienstname | WMPNetworkSvc
Windows Beschreibung | Gibt Windows Media Player-Bibliotheken mithilfe des universellen Plug & Play für andere Players und Mediengeräte auf dem Netzwerk frei
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP; UPnP-Gerätehost
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WMPNetworkSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2482.htm


Windows Dienste: Windows Modules Installer

Der Dienst "TrustedInstaller" wird für die Installation, Anpassung/Konfiguration und Deinstallation von Windows Updates und Komponenten benötigt.

Für den automatischen Windows Update Service wird dieser Dienst aber nicht benötigt, so dass er in den meisten Fällen auch deaktiviert werden kann.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows Modules Installer
Dienstname | TrustedInstaller
Windows Beschreibung | Ermöglicht das Installieren, Ändern und Entfernen von Windows-Updates und optionalen Komponenten. Wenn dieser Dienst deaktiviert ist, können beim Installieren oder Deinstallieren von Windows-Updates auf diesem Computer Fehler auftreten.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug & Play
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TrustedInstaller

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2483.htm


Windows Dienste: Windows Presentation Foundation-Schriftartcache 3.0.0.0

Der Dienst "FontCache3.0.0.0" ist für die Optimierung von "Windows Presentation Foundation (WPF)"-Anwendungen zuständig. Bei den Anwendungen handelt es sich um Programme, welche die neue Funktion von Avalon oder WPF benutzen. Die Anwendungen legen die gemeinsam genutzten Schriftarten in einem öffentlichen Cache ab. Durch die neue WPF auf Basis von .NET-Framework soll die alte Win32-API ersetzt werden.

Wenn Sie noch keine WPF-Anwendungen benutzen, können Sie den Dienst deaktvieren. Bei laufenden WPF-Anwendungen kann sich dieDeaktivierung negativ auf die Performance auswirken.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows Presentation Foundation-Schriftartcache 3.0.0.0
Dienstname | FontCache3.0.0.0
Windows Beschreibung | Optimiert die WPF-Anwendungen (Windows Presentation Foundation), indem häufig verwendete Schriftartdaten zwischengespeichert werden. WPF-Anwendungen starten diesen Dienst, wenn er nicht bereits gestartet wurde. Der Dienst kann deaktiviert werden, dadurch wird jedoch die Leistung der WPF-Anwendungen vermindert.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ FontCache3.0.0.0

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2484.htm


Windows Dienste: Windows-Audio-Endpunkterstellung

Der Dienst "AudioEndpointBuilder" ist für die Verwaltung von Audiogeräten wie Lautsprecher, Mikrophone usw. zuständig. Dabei unterstützt der Dienst den Hauptdienst "Windows-Audio". Der Dienst wurde ab Windows Vista aus dem "Windows-Audio" ausgekoppelt und sollte nicht deaktiviert werden, wenn Sound gewünscht ist.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Audio-Endpunkterstellung
Dienstname | AudioEndpointBuilder
Windows Beschreibung | Verwaltet Audiogeräte für den Windows-Audiodienst. Wenn dieser Dienst beendet wird, funktionieren Audiogeräte und -effekte nicht ordnungsgemäß. Wenn dieser Dienst deaktiviert wird, können die Dienste, die von diesem Dienst explizit abhängig sind, nicht mehr gestartet werden.
Windows Starttyp | Windows Vista: Automatisch Windows 2008: Manuell
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Plug & Play
Wird benötigt | Windows-Audio
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ AudioEndpointBuilder

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2487.htm


Windows Dienste: Windows-Defender

Der Dienst "WinDefend" ist der Basisdienst für den Windows Defender von Microsoft. Dieses Tool wurde von Microsoft entwickelt um Spayware und Virensoftware auf Ihren Rechner finden zu können. Der Dienst untersucht den Rechner nach unerwünschter Software und sorgt dafür, dass immer die aktuelle Version vom Windows Defender installiert ist.

Wenn Sie Programme von anderen Herstellern zur Sicherung des Rechners verwenden, dann können Sie den Windows Defender deaktivieren. Dabei sollten Sie den Dienst aber nicht selber über "Services.msc" ausschalten, da Sie ansonsten mit entsprechenden Warnmeldungen konfrontiert werden. Wenn Sie den Windows Defender ausschalten wollen machen Sie das über die Systemsteuerung.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Defender
Dienstname | WinDefend
Windows Beschreibung | Überprüft den Computer auf unerwünschte Software, plant Überprüfungen und lädt die neuesten Softwaredefinitionen herunter.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WinDefend

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2489.htm


Windows Dienste: Windows-Ereignissammlung

Der Dienst "Wecsvc" protokolliert alle möglichen Systemereignisse. Der Dienst kann bei der Hilfe zur Analyse von Systemfehlern hilfreich sein. Bei der normalen Arbeit wird dieser Dienst aber nicht benötigt.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Ereignissammlung
Dienstname | Wecsvc
Windows Beschreibung | Dieser Dienst verwaltet permanente Abonnements für Ereignisse von Remotequellen, die das WS-Verwaltungsprotokoll unterstützen. Hierzu gehören Windows Vista-Ereignisprotokolle sowie Hardware- und IPMI-fähige Ereignisquellen. Der Dienst speichert weitergeleitete Ereignisse in einem lokalen Ereignisprotokoll. Falls dieser Dienst beendet oder deaktiviert wird, können Ereignisabonnements nicht erstellt und weitergeleitete Ereignisse nicht angenommen werden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Wecsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2491.htm


Windows Dienste: Windows-Farbsystem

Der Dienst "WcsPlugInService" ist für das Einbinden fremder Farbsysteme über eine Plug-In-Schnittstelle in das Windows Farbsystem zuständig. In den meisten Fällen können Sie diesen Dienst deaktivieren, es kann aber bei besonderen Anwendungen zu Fehlern in der Darstellung führen.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Farbsystem
Dienstname | WcsPlugInService
Windows Beschreibung | Vom WcsPlugInService-Dienst werden Plug-In-Module von Drittanbietern für Farbgerätemodelle und Palettenzuordnungsmodelle des Windows-Farbsystems gehostet. Diese Plug-In-Module sind herstellerspezifische Erweiterungen zu den standardmäßigen Farbgerätemodellen und Palettenzuordnungsmodellen des Windows-Farbsystems. Wird der WcsPlugInService-Dienst angehalten oder deaktiviert, wird dieses Erweiterungsfeature deaktiviert, und vom Windows-Farbsystem wird die Verarbeitung nach dem Grundmodell anstatt nach der vom Hersteller gewünschten Verarbeitung verwendet. Dies kann zu ungenauem Farbrendering führen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WcsPlugInService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2492.htm


Windows Dienste: Windows-Fehlerberichterstattungsdienst

Der Dienst "WerSvc" ist dafür zuständig eine Benachrichtigungsmail an Microsoft zu versenden, wenn ein Fehler in einer Anwendung auftritt. Vor dem Versenden der Mail, wird der Anwender um die entsprechenden Erlaubnis gefragt. Der Bericht enthält Informationen aus dem entsprechenden Speicherbereich wo der Fehler aufgetreten ist.

Wenn Sie den Dienst deaktivieren, werden keine Benachrichtigungen mehr an Microsoft verschickt, und es erfolgt auch keine entsprechende Nachfrage beim Anwender.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Fehlerberichterstattungsdienst
Dienstname | WerSvc
Windows Beschreibung | Ermöglicht das Berichterstatten über Fehler bei nicht mehr funktionierenden und reagierenden Programmen und das Angeben von Lösungen. Ermöglicht außerdem das Generieren von Protokollen für Diagnose- und Reparaturdienste. Wenn dieser Dienst beendet wird, funktioniert die Fehlerberichterstattung möglicherweise nicht ordnungsgemäß, und die Ergebnisse von Diagnosediensten und Reparaturen werden möglicherweise nicht angezeigt.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WerSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2493.htm


Windows Dienste: Windows-Firewall

Bei dem Dienst "MpsSvc" handelt es sich um die Windows-eigene Firewall.

Durch eine Firewall soll Ihr Rechner von Angriffen aus dem Internet geschützt werden. Wenn Sie keine Firewall eines anderen Herstellers benutzen und Ihr Rechner mit dem Internet verbunden ist, sollten Sie die Firewall nicht ausschalten.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Firewall
Dienstname | MpsSvc
Windows Beschreibung | Die Windows-Firewall trägt zum Schutz des Computers bei, indem der Zugriff durch nicht autorisierte Benutzer auf den Computer über das Internet bzw. ein Netzwerk verhindert wird.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Basisfiltermodul; Windows-Firewallautorisierungstreiber
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MpsSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2494.htm


Windows Dienste: Windows-Remoteverwaltung (WS-Verwaltung)

Der Dienst "WinRM" stellt das "WS-Management"-Protokoll für die Remoteverwaltung der Hard- und Software im Netzwerk bereit. Der Dienst ist für die Bearbeitung von Anfragen über das Netzwerk zuständig. Wenn Sie mit WMI-Abfragen im Netzwerk arbeiten, sollten Sie den Dienst nicht deaktivieren. Wenn Sie aber keine Abfragen über das Netzwerk durchführen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Remoteverwaltung (WS-Verwaltung)
Dienstname | WinRM
Windows Beschreibung | Der Windows-Remoteverwaltungsdienst (WinRM) implementiert das WS-Verwaltungsprotokoll für die Remoteverwaltung. Die WS-Verwaltung ist ein standardmäßiges Webdienstprotokoll für die Remoteverwaltung von Software und Hardware. Der WinRM-Dienst hört das Netzwerk auf WS-Verwaltungsanforderungen ab und verarbeitet diese Anforderungen. Der WinRM-Dienst muss mit dem Befehlszeilentool "winrm" oder über Gruppenrichtlinien mit einem Listener konfiguriert werden, damit er das Netzwerk abhört. Der WinRM-Dienst bietet Zugriff auf WMI-Daten und ermöglicht die Ereigniserfassung. Die Erfassung und Abonnieren von Ereignissen setzt voraus, dass der Dienst ausgeführt wird. WinRM-Nachrichten verwenden HTTP und HTTPS als Transportprotokoll. Der WinRM-Dienst ist nicht von IIS abhängig, ist jedoch zur Freigabe eines Anschlusses mit IIS auf demselben Computer vorkonfiguriert. Das URL-Präfix "/wsman" ist für den WinRM-Dienst reserviert. Um Konflikte mit IIS zu vermeiden, sollten Administratoren sicherstellen, dass für in IIS gehostete Websites nicht das URL-Präfix "/wsman" verwendet wird.
Windows Starttyp

Windows Vista: Manuell

Windows 2008: Automatisch (Verzögerter Start)
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WinRM

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2495.htm


Windows Dienste: Windows-Sicherung

Der Dienst "SDRSVC" wird für die Backup-und Wiederherstellungsfunktionen vom Windows benötigt. Wenn Sie die Backupsoftware von Windows nicht benutzen wollen, können Sie den Dienst auf deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Sicherung
Dienstname | SDRSVC
Windows Beschreibung | Bietet Möglichkeiten zum Sichern und Wiederherstellen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SDRSVC

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2496.htm


Windows Dienste: Windows-Sofortverbindung - Konfigurationsregistrierungsstelle

Der Dienst "wcncsvc" ist für Anmeldung über die Windows "Connect Now" Technologie zuständig, welche für WLAN-Netzwerke eingerichtet wurde. Dadurch soll das Einrichten von WLAN-Netzwerken vereinfacht werden. Über diesen Dienst werden die entsprechenden Zugangsberechtigungen vergeben und überwacht.

Wenn Sie nicht mit WLAN arbeiten, können Sie diesen Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Windows-Sofortverbindung - Konfigurationsregistrierungsstelle
Dienstname | wcncsvc
Windows Beschreibung | Handelt als Registrierungsstelle und gibt Netzwerkanmeldeinformationen an sich registrierende Benutzer aus. Wenn dieser Dienst deaktiviert ist, wird die Windows-Sofortverbindung - Registrierungsstelle nicht ordnungsgemäß funktionieren.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wcncsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2497.htm


Windows Dienste: WinHTTP-Web Proxy Auto-Discovery-Dienst

Der Dienst "WinHttpAutoProxySvc" implementiert das WPAD-Protokoll (Web Proxy Auto-Discovery) für Windows HTTP-Dienste (WinHTTP).

Wird erkannt, dass eine automatische Proxy-Konfiguration vorliegt, werden diese Informationen zentral vom Proxy-Server geladen und verwendet. Wenn Sie nicht mit einem Proxy-Server im Netzwerkwerk arbeiten, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | WinHTTP-Web Proxy Auto-Discovery-Dienst
Dienstname | WinHttpAutoProxySvc
Windows Beschreibung | WinHTTP implementiert den HTTP-Clientstapel und bietet Entwicklern eine Win32-API und COM-Automatisierungskomponente zum Senden von HTTP-Anforderungen und zum Empfangen von Antworten. Außerdem unterstützt WinHTTP die automatische Erkennung von Proxykonfigurationen über die entsprechende Implementierung des WPAD-Protokolls (Web Proxy Auto-Discovery).
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | DHCP-Client
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WinHttpAutoProxySvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2501.htm


Windows Dienste: Zertifikatverteilung

Der Dienst "CertPropSvc" wird für das Verwalten von Zertifikaten von Smartcard-Geräten benötigt. Wenn Sie keinen Smartcard-Leser benutzen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows Vista Versionen

Allgemeine Informationen
Anzeigename | Zertifikatverteilung
Dienstname | CertPropSvc
Windows Beschreibung | Überträgt Zertifikate von Smartcards.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ CertPropSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2503.htm


Anzahl der 3D-Auswahlfenster (Flip3D)

Ab Windows Vista können Sie sich jetzt über die Tasten [WIN + Tab] die offenen Anwendungen mit Flip3D als dreidimensionale 3D-Fenster auf dem Desktop anzeigen lassen und zwischen den Anwendungen umschalten.

Mit diesem Tipp können Sie einstellen, wie viele Fenster gleichzeitig angezeigt werden sollen. Gerade wenn die Geschwindigkeit des Rechners nicht ausreicht und die Anzeige ruckelt, können Sie hiermit die Anzahl der Fenster reduzieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "Max3DWindows" als Datentyp REG_DWORD. Geben Sie die gewünschte Anzahl der Fenster ein, die gleichzeitig angezeigt werden sollen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2176.htm


Standardverzeichnis für Hintergrundbilder verändern

Das Standardverzeichnis für Hintergrundbilder ist "%windir%WebWallpaper". Wenn Sie die Bilder woanders ablegen wollen, können Sie das Verzeichnis in der Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

Erstellen Sie hier einen neuen Wert mit dem Namen "WallPaperDir" als Datentyp REG_SZ und geben Sie das gewünschte Verzeichnis an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2211.htm


Windows Vista Basic mit AERO-Oberfläche

Microsoft gibt an, dass die Windows Vista Version "Home Basic" ohne AERO-Oberfläche geliefert wird. Diese Funktion wird von Microsoft aber nur deaktiviert und kann daher wieder reaktiviert und eingeschaltet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ DWM

Hier müssen die folgenden Einträge angelegt bzw. auf die angegebenen Werte geändert werden:

Name | Datentyp | Wert
Composition | REG_DWORD | 1
CompositionPolicy | REG_DWORD | 2
Folgende Werte sollten auch vorhanden sein:
ColorizationColor | REG_DWORD | 40004ade
ColorizationOpaqueBlend | REG_DWORD | 0

Jetzt muss noch der Desktopfenster-Manager neu gestartet werden. Dafür müssen die Eingeabaufforderung mit administrativen Rechten geöffnet sein und dann Folgendes eingeben:

Dienst stoppen | net stop uxsms
Dienst starten | net start uxsms

Jetzt sollten Ihnen die AERO-Oberfläche angezeigt werden.

Info Bedenken Sie aber, dass Sie eine Grafikkarte benötigen, die DirectX 9-fähig ist (siehe Leistungsindex). Weiterhin müssen die dazu notwendigen Grafikkartentreiber installiert sein. Wenn die Grafikkarte das nicht unterstützt, bringen auch die Änderungen in der Registry nichts.

Mit den folgenden Tools können Sie die Funktionen noch etwas erweitern

  • Miniaturansicht in der Taskleiste für verkleinerte Anwendungen anzeigen: VisualTaskTips
  • ALT-TAB 3D Flip für Vista Home: TopDesk

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2319.htm


Desktop Icon-Darstellung verändern

Ab Windows Vista werden die Desktopicons in einer Größe von 48 Pixeln (als Kantenlänge) angezeigt. Dadurch verbrauchen diese großen Icons schon relativ viel Platz auf dem Desktop.

Sie können die Größe der Icons folgendermaßen abändern.

  1. Klicken Sie mit der rechten Maustaste auf den Desktop und wählen den Tabreiter "Ansicht". Hier können Sie jetzt zwischen "großen", "mittelgroßen" und "klassischen Symbolen" auswählen.
  2. Halten Sie die STRG-Taste gedrückt und drehen Sie am Mausrad. Hier können Sie über das Mausrad unterschiedliche Icon-Größen auswählen
  3. Sie können die Einstellung auch - wie unten beschrieben - über die Registry verändern. Hier haben Sie auch die Möglichkeit, etwas andere Einstellungen vorzunehmen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Shell\ Bags\ 1\ Desktop

hier finden Sie die Einträge "Mode", "LogicalViewMode" und "IconSize" als Datentyp REG_DWORD

Der Wert IconSize legt die Größe der Icons fest und gibt die Kantenlänge in Pixel an. Die beiden anderen Werte legen die Anzeigeart fest.

Anbei eine Tabelle mit den Anzeigearten und den entsprechenden Werten für die Registryeinträge.

Anzeigeart | Werte
Große Symbole | Mode: 5 LogicalViewMode: 3 IconSize: 96
Mittelgroße Symbole | Mode: 5 LogicalViewMode: 3 IconSize: 48
Klassische Symbole | Mode: 5 LogicalViewMode: 3 IconSize: 32
Kleinere Symbole | Mode: 2 LogicalViewMode: 3 IconSize: 16
Liste | Mode: 3 LogicalViewMode: 3 IconSize: 16
Details | Mode: 4 LogicalViewMode: 1 IconSize: 16
Kacheln | Mode: 6 LogicalViewMode: 2 IconSize: 16

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2509.htm


Taskleisten-Animationen aktivieren/deaktivieren

Mit diesem Tipp können Sie die "Taskleisten-Animationen" deaktivieren. Durch die Deaktivierung wird weniger Rechenleistung verbraucht als sonst, und dies ist deshalb gerade für nicht so schnelle Rechner geeignet.

In der Oberfläche finden Sie die Einstellung unter: "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen. Es wird das Fenster "Leistungsoptionen" geöffnet. Hier stellen Sie unter dem Tabreiter "Visuelle Effekte" die Auswahl auf "Benutzerdefiniert" und entfernen anschließend den Haken bei 'Taskleisten-Schaltflächen'.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "TaskbarAnimations" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Taskleisten-Animationen ausschalten
1 | Taskleisten-Animationen aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2318.htm


Akkuanzeige aus der Infobereich der Taskleiste ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob die Akkumessanzeige im Infobereich der Taskleiste angezeigt werden soll. Die Akkuanzeige informiert den Anwender über den Ladezustand des Akkus. Über das Icon kann auch auf die Energieeinstellungen zugegriffen werden und der Anwender kann die Einstellungen verändern.

Wenn Sie die Einstellung aktivieren, kann der Anwender nicht mehr über die Einstellung "Energie" -> "Tabreiter "Infobereich" über "Eigenschaften von Taskleiste und Startmenü" diese Einstellung verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "HideSCAPower" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Akkumessanzeige wird ausgeblendet
0 | Akkumessanzeige wird angezeigt und kann vom Anwender konfiguriert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Nein
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Akkumessanzeige entfernen
Beschreibung: | Verhindert die Anzeige der Akkumessanzeige im Systembereich. Wenn Sie diese Einstellung aktivieren, wird die Akkumessanzeige nicht im Infobereich des Systems angezeigt.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2718.htm


Infobenachrichtigungen der Taskleiste als Sprechblasen ausschalten

Mit diesem Tipp legen Sie fest, dass keine Sprechblasen mit Informationen in der Taskleiste angezeigt werden. Über diese Sprechblasen werden Benachrichtigungen für bestimmte Ereignisse (Status) angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "TaskbarNoNotification" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Sprechblasen mehr anzeigen
0 | Sprechblasen zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Nein
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Alle Sprechblasenbenachrichtigungen deaktivieren
Beschreibung: | Wenn Sie diese Einstellung aktivieren, werden keine Sprechblasenbenachrichtigungen für den Benutzer angezeigt.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2719.htm


Tabreiter "Dateitypen" in Explorer verschwunden

Ab Windows Vista finden Sie den Tabreiter "Dateitypen" nicht mehr in Explorer unter "Extras" -> "Ordneroptionen" wo er unter allen anderen älteren Windowsversionen zu finden war.

Microsoft hat diese Einstellung jetzt in die Systemsteuerung verlegt und hier auch noch gut versteckt. Sie finden die Einstellung unter "Systemsteuerung (Klassische Ansicht)" -> "Indizierungsoptionen" -> "Erweitert" ( hier auf den Button klicken). Es öffnet sich das Fenster "Erweitere Optionen"; hier finden Sie jetzt auch den Tabreiter "Dateitypen"

Leider wurde der Funktionsumfang geändert. Man kann hier nur noch die Dateitypen für die Indizierung der Suche aktivieren und die bestehenden Dateitypen einer Anwendung zuweisen. Die Funktionen wie unter XP bietet es aber nicht. Hat man den Such-Index ausgeschaltet ist auch erweitert nicht anwählbar bzw. ist grau unterlegt. Dadurch haben Sie nicht mehr die Möglichkeit einfach die Dateitypen zu verwalten, es bleibt nur der Weg über die Registry, oder ExtMan.

Das Tool "ExtMan" bietet die Funktion wie Sie unter XP vorhanden waren auch wieder unter Windows Vista.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2175.htm


Gesicherte Eingabe für Anmeldeinformationen benutzen

Administratorkonten auflisten bei "Als Administrator ausführen"

Wenn Sie bei einer Anwendung "Als Administrator ausführen" aus dem Kontextmenü auswählen, werden Ihnen standardmäßig die möglichen Konten nicht angezeigt. Wenn Sie diesen Tipp aktivieren, werden alle administrativen Konten angezeigt, und Sie können ein entsprechendes Konto auswählen und müssen nur noch das entsprechende Kennwort eingeben.

Ist der Tipp nicht aktiv, muss zusätzlich auch noch der Name des administrativen Kontos eingegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ CredUI

Erstellen Sie hier einen neuen Wert mit dem Namen "EnumerateAdministrators" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Liste mit administrativen Konten anzeigen
0 | Name das administrativen Kontos muss eingegeben werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Benutzerschnittstelle für Anmeldeinformationen
Einstellungsname: | Bei Ausführung mit erhöhten Rechten Administratorkonten auflisten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2333.htm


Explorer: Auswahl von mehreren Dateien und Ordnern nicht mehr möglich

Im Windows Explorer lassen sich nicht mehr mehrere Dateien oder Ordner mit der Maus markieren. Auch eine Auswahl über die Tastatur mittels STRG+A scheint keine Auswirkung zu haben. Es lässt sich immer nur noch eine Datei/Ordner markieren.

Wenn dieser Fehler auftritt, liegt das an fehlerhaften Einträge in der Registry. Dort werden bestimmte Einstellungen der Ordner/Dateien in MRU-Listen (Most Recently User) gespeichert. Wenn hier fehlerhafte Einträge vorhanden sind, kommt es im Explorer oft zu Fehlern.

Um den Fehler zu beheben, löschen Sie die folgenden Einträge.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Classes\ Local Settings\ Software\ Microsoft\ Windows\ Shell

löschen Sie die Schlüssel "Bags" und "BagMRU"

Zusätzlich löschen Sie noch den Schlüssel "Default" unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Streams

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2555.htm


Menüleiste vom Explorer ein-/ausblenden

Ab Vista wird die Menüleiste standardmäßig nicht dauerhaft eingeblendet. Wenn Sie die ALT-Taste drücken, wird nach dem Loslassen das Menü kurzzeitig wieder eingeblendet bzw. über die ALT+ Kurztasten können Sie sich durch das Menü hangeln.

Mit diesem Tipp können Sie die Menüleiste wieder dauerhaft einblenden - wie es auch früher im Explorer angezeigt wurde.

Die Einstellung können Sie im Explorer über "Extras" -> "Ordneroptionen" -> Tabreiter "Ansicht" ändern. Hier finden Sie die Einstellung "Immer Menü anzeigen", wo Sie den Haken setzen müssen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "AlwaysShowMenus" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Menü wird nur durch Drücken der ALT-Taste angezeigt
1 | Menü wird immer angezeigt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2321.htm


Preview von PSD Dateien im Explorer als Thumbnail anzeigen

Im Explorer wird in der Iconansicht von Bildern ein Preview (sogenannte Thumbnail) angezeigt. Dadurch kann man meist schon vor den Öffnen erkennen, um was für Bilder es sich handelt. Leider kann Windows von Photoshop keine PSD- Dateien als Thumbnail- Preview anzeigen.

Im Internet finden Sie einen "Photoshop Preview Handler for Windows Vista"-Download.

Wenn Sie dies Tool installieren, werden Ihnen Thumbnail auch von PSD-Dateien im Explorer angezeigt.

Mit dem Programm "Photoshop Preview Handler" Download, erhalten Sie auch eine Vorschau in der Preview Ansicht und in Outlook 2007.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2408.htm


Ordnererkennung für unterschiedliche Ansichten im Explorer abschalten

Ordnertypkennung für unterschiedliche Ansichten im Explorer abschalten

Ab Windows Vista gibt es insgesamt 5 verschiedene Ordneransichten. Je nach Dateitypen, die sich im Verzeichnis befinden, erkennt Windows, um welchen Ordnertyp es sich handelt und zeigt den entsprechenden Ordnertyp an.

Befinden sich im Ordner unterschiedliche Dateitypen, kann es dazu führen, dass Windows den Ordnertyp nicht zuverlässig erkennen kann.

Mit den folgenden Eintrag in der Registry, können Sie die Ordnererkennung abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Classes\ Local Settings\ Software\ Microsoft\ Windows\ Shell\ Bags\ AllFolders\ shell

Erstellen Sie hier einen neuen Wert mit dem Namen "FolderType" als Datentyp REG_SZ und geben als Wert "NotSpecified" ein.

Wenn Sie die gespeicherten Ordneransicht löschen wollen, müssen Sie folgendermaßen vorgehen:

  • Schließen Sie alle offenen Explorerfenster
  • Löschen Sie alle Einträge unterhalb von "HKEY_CURRENT_USER\ Software\ Classes\ Local Settings\ Software\ Microsoft\ Windows\ Shell\ Bags" und "HKEY_CURRENT_USER\ Software\ Classes\ Local Settings\ Software\ Microsoft\ Windows\ Shell\ BagMRU"

Unterhalb des Schlüssels "Bags" werden alle erkannten Ordnereinstellungen von Windows gespeichert. Unterhalb des Schlüssels "BagMRU" werden die zuletzt besuchten Ordner eingetragen.

Wenn Sie einen Ordnertyp einstellen wollen, können Sie das über die Eigenschaften des Ordners machen (rechte Maustaste auf den Ordner -> "Eigenschaften" -> Tabreiter "Anpassen". Hier finden Sie den Eintrag "Diesen Ordnertyp als Vorlage verwenden:", wo Sie aus einer Liste den gewünschten Ordnertyp auswählen können).

Siehe dazu auch Tipp:

Ordnern andere Icons zuweisen

Informationen über die Datei "Desktop.ini"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2652.htm


Vorschaubilder mit Rahmen anzeigen

In diesem Tipp wird gezeigt, wie Sie bei den Vorschaubildern von Windows noch einen Rahmen aktivieren können. Normalerweise werden die Vorschaubilder (auch als Thumbnail bezeichnet) ohne einen Rahmen angezeigt. Sie haben aber die Möglichkeit, aus 3 Rahmentypen einen gewünschten Rahmen auszuwählen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ SystemFileAssociations\ image

Erstellen Sie hier einen neuen Wert mit dem Namen "Treatment" als Datentyp REG_DWORD und setzen den Wert auf:

0 | ohne Rahmen (Standard)
1 | kleiner Rahmen
2 | einfacher Rahmen
3 | Filmstreifen als Rahmen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2655.htm


Die Menüleiste im Explorer permanent anzeigen

Ab Windows Vista wird die Menüleiste im Explorer nicht permanent mehr angezeigt, sondern nur wenn die ALT-Taste gedrückt wird.

Über "Organisieren" -> "Layout" -> "Menüleiste" können Sie einstellen, dass die Menüleiste angezeigt wird.

Wenn Sie diesen Tipp aktivieren, wird die Menüleiste immer angezeigt und kann vom Benutzer auch nicht mehr ausgeblendet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "AlwaysShowClassicMenu" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Die Menüleiste wird angezeigt
0 | Die Menüleiste wird ausgeblendet (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Menüleiste im Windows Explorer anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2260.htm


Freigabe-Assistenten für Netzwerkfreigaben ausschalten

Wenn Sie unter Windows eine Netzwerkfreigabe einrichten wollen (rechte Maustaste auf das Verzeichnis und die Auswahl des Eintrages "Freigabe" aus dem Kontextmenü), wird standardmäßig der Freigabe-Assistent geöffnet, wo nur einige wenige Optionen zur Auswahl stehen.

Wenn Sie diese Funktion ausschalten, wird der Assistent nicht mehr geöffnet, sondern gleich die Eigenschaften des Ordners auf dem Tabreiter "Freigabe" angezeigt.

Hier können Sie dann über den Eintrag "Erweiterte Freigabe..." eine Freigabe einrichten. Zusätzlich wird auf diesem Tabreiter unter "Datei- und Druckerfreigabe im Netzwerk" der Button "Freigabe..." gesperrt.

Die Einstellung können Sie im Explorer über "Extras" -> "Ordneroptionen" -> Tabreiter "Ansicht" finden unter der Einstellung "Freigabe-Assistent verwenden (empfohlen)", wo nur der Haken zu entfernen ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "SharingWizardOn" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Es wird kein Assistent für die Freigaben verwendet
1 | Es wird der Assistent für die Freigaben geöffnet

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2320.htm


NTFS Komprimierung und Verschlüsselung ausschalten

Ab Windows XP können Partitionen, die mit NTFS-formiert sind, komprimiert und verschlüsselt werden. Standardmäßig wird von Windows automatisch der Ordner "DLLCache" komprimiert.

Weiterhin können Ordner und Dateien über die Eigenschaften (rechte Maustaste auf Datei/Ordner) Komprimiert/Verschlüsselt werden.

Mit dem Befehl fsutil können Sie die Komprimierung oder Verschlüsselungsfunktion ausschalten:

Komprimierung ausschalten:

fsutil behavior set disablecompression 1

Verschlüsselung ausschalten:

fsutil behavior set disableencryption 1

Wenn Sie statt der 1 eine 0 angeben, können Sie damit die Funktion wieder aktivieren.

Diese Einstellung können Sie auch in der Registry ändern

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

erstellen Sie hier folgende Einträge als Datentyp REG_DWORD

Name | Werte | Beschreibung
NtfsDisableCompression | 0 -> Komprimieren möglich 1 -> Komprimieren deaktiviert | Komprimieren ein/ausschalten
NtfsDisableEncryption | 0 -> Verschlüsseln möglich 1 -> Verschlüsseln deaktiviert | Verschlüsseln ein/ausschalten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2380.htm


Wiederherstellung von lokalen Dateien über Schattenkopie unterbinden

Mit diesem Tipp können Sie die Schaltfläche "Wiederherstellen" entfernen und somit das Wiederherstellen von alten Dateiversionen aus Sicherungskopie/Schattenkopie unterbinden.

Die Schaltfläche "Wiederherstellen" finden Sie in den Eigenschaften von Dateien und Ordnern auf der Registerkarte "Vorgängerversionen". Wenn Sie den Tipp aktivieren, kann der Benutzer keine Vorgängerversionen mehr wiederherstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLocalRestore" als Datentyp REG_DWORD und setzen den Wert auf:

0 | "Wiederherstellen" ist für lokale Dateien sichtbar (Standard)
1 | "Wiederherstellen" ist nicht für lokale Dateien sichtbar

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Wiederherstellung vorheriger lokaler Versionen verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2559.htm


Die Suche im Startmenü beschleunigen

Wird das Suchfeld im Startmenü benutzt, wird standardmäßig bei der Suche auch auf den Dateiindex zurückgegriffen und dieser mit durchsucht. Dieser Dateiindex enthält alle zu durchsuchenden Dateien der Festplatte und kann deshalb schon recht groß sein. Wenn Sie in der Suche aber nur Startmenüeinträge berücksichtigen wollen, können Sie den Zugriff auf den Index Mit diesem Tipp ausschalten. Dadurch wird die Startmenüsuche beschleunigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "Start_SearchFiles" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Dateiindex nicht durchsuchen (schnellere Suche)
1 | Dateiindex benutzen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2219.htm


"Spiele" aus dem "Startmenü" ein-/ausblenden

Mit diesem Tipp legen Sie fest, ob "Spiele" im "Startmenü" angezeigt werden soll. Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoStartMenuMyGames" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Spiele ausblenden
0 | Spiele wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | Nein
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Startmenü und Taskleiste
Einstellungsname: | Menüeintrag "Spiele" aus dem Menü "Start" entfernen
Beschreibung: | Wenn Sie diese Richtlinie aktivieren, wird im Startmenü kein Link zum Ordner "Spiele" angezeigt.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2717.htm


ClearType: Helligkeit der Farbtöne für die Schriftglättung

Mit diesem Tipp können Sie die Farbtöne für die Schriftglättung konfigurieren. Microsoft hat die "ClearType Technology" eingeführt, um die Lesbarkeit bei LCD Displays zu verbessern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "FontSmoothingGamma" als Datentyp REG_DWORD. Die möglichen Werte liegen zwischen 0 un 2200 (Hex) und legt die Helligkeit der Farbtöne für die Schriftgälttung fest. Je größer der Wert ist, um so heller und blasser erscheint die Glättung. Dabei sind bei Werten zwischen 0 und 1000 kaum sichtbare Unterschiede zu erkennen.

Diese Einstellung hat nur bei der farbigen Schriftglättung (FontSmoothingType = 2 - siehe dazu Tipp "ClearType: Art der Kantenglättung und Schriftglättung") eine sichtbare Auswirkung. Sie sollten die Werte in großen Schritten erhöhen um eine Auswirkung auch zu bemerken (0, 1000, 2000) und eventuell dann in kleineren schritten Anpassen.

Info Siehe dazu auch Tipp:
"Weichzeichnen" für die Schrift aktivieren
Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren
ClearType: Art der Kantenglättung und Schriftglättung
ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=294851

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2683.htm


Skalierung der Icons und Schriftarten aktivieren/deaktivieren

Mit diesem Tipp können Sie die Skalierung der Icons und Schriftarten aktivieren und deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "UseDPIScaling" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Skalierung der Icons und Schriftarten aktivieren
0 | Skalierung der Icons und Schriftarten deaktivieren (Standard)

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2163.htm


Verschwimm-Effekt für die Glasfenster aktivieren/deaktivieren

Mit diesem Tipp können Sie den Verschwimm-Effekt für die Glasfenster aktiviert oder deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "Blur" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Skalierung der Icons und Schriftarten aktivieren
0 | Skalierung der Icons und Schriftarten deaktivieren (Standard)

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2164.htm


Direct3D-Renderung oder Software-Renderung benutzen

Mit diesem Tipp können Sie einstellen, ob die Direct3D-Renderung oder Software-Renderung benutzt werden soll. Wenn Sie die Software-Renderung benutzen, geht das natürlich auf die Geschwindigkeit des Rechners, andernfalls wird die Renderung von der Grafikkarte übernommen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceSoftwareD3D" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Software Renderung
0 | Direct3D-Renderung erzwingen (Standard)

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2165.htm


PopUp-Animationen durch die Shift-Taste verlangsamen

Mit diesem Eintrag können Sie PopUp-Animationen durch die Shift-Taste verlangsamen. Wenn ein Fenster minimiert/maximiert und Sie danach sofort die SHIFT-Taste drücken und gedrückt halten, dann läuft die Animation langsamer ab.

Dadurch haben Sie z.B. die Möglichkeit, diese Animation zum fotografieren:

Info Dafür müssen Aero Glass und die Animationen beim Maximieren/Minimieren aktiviert sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "AnimationsShiftKey" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | PopUp-Animationen verlangsamen
0 | Standard Geschwindigkeit (Standard)

Anschließend müssen Sie sich neu anmelden oder über die folgenden Befehle über die Eingabeaufforderung den Desktopfenster-Manager neu starten:

net stop uxsms

net start uxsms

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2168.htm


"Minimieren"-, "Maximieren"-, "Schließen"-Buttons ändern

Mit diesem Tipp können Sie die Buttons wieder auf das alte Aussehen zurücksetzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "UseAlternateButtons" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Alternative Buttons
0 | Standard Buttons (Standard)

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2169.htm


Vista Style festlegen

Mit diesem Tipp können Sie den Vista Style festlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "Glass" Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Vista Glass Style aktivieren
0 | Vista Glass Style deaktivieren

Erstellen Sie hier einen neuen Wert mit dem Namen "Metal" Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Vista Metal Style aktivieren
0 | Vista Metal Style deaktivieren

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2170.htm


Popup-Animation für die Fenster konfigurieren

Mit diesem Tipp können Sie die Animation von Popup-Fenster ein-/ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "Animations" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Popup-Animation aktivieren
0 | Popup-Animation deaktivieren

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2171.htm


Aero Glaseffekt unter allen Grafikkarten

Mit diesem Tipp stellen Sie ein, dass Windows Vista nicht mehr überprüft, ob der Rechner für Glaseffekte (Aero Oberfläche) ausreicht. Gerade wenn Sie noch keine DirectX9-fähige Grafikkarte besitzen, können Sie trotzdem den Vista Glaseffekt "Aero" nutzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableMachineCheck" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Grafikkarten Aero Test ausschalten
1 | Grafikkarten Aero Test aktiv (Standard)

Info Funktion scheinbar nur in der Betaversion von Windows-Vista vorhanden!

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2172.htm


Transparenz für die Fenster mit AERO-Oberfläche ausschalten

Standardmäßig werden die Fenster in der AERO-Oberfläche Transparent dargestellt:

Wenn Sie diese Transparenz nicht haben wollen, können Sie das über die Oberfläche ausschalten. Klicken Sie dafür mit der rechten Maustaste auf den Desktop und wählen Sie das dem Kontextmenü "Anpassen" aus. Im neuen Fenster klicken Sie auf "Fensterfarbe und -darstellungen" und entfernen den Haken bei "Transparenz aktivieren" (Dieses Fenster sehen Sie nur, wenn die AERO-Oberfläche aktiv ist).

Anschließend werden die Fenster wieder ohne Transparenz dargestellt:

Weiterhin können Sie auf dieser Seite noch festlegen, wie stark Transparent die Leiste sein soll. Verändert Sie dafür den Regler bei Farbintensität auf den gewünschten Wert. Je größer der Wert (Schieber weiter rechts), um so weniger transparent wird das Fenster dargestellt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "ColorizationOpaqueBlend" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Transparenz ausschalten
0 | Transparenz ist aktiv (Standard)

Mit dem Wert "ColorizationColor" als Datentyp REG_DWORD können Sie weiterhin festlegen, wie stark die Transparenz sein soll. Die gültigen Werte liegen zwischen 440642554 und 3645091578 (Dezimal).

Anschließend müssen Sie sich neu anmelden oder über die folgenden Befehle über die Eingabeaufforderung den Desktopfenster-Manager neu starten:

net stop uxsms

net start uxsms

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2257.htm


QuickInfos (BallonTips) "Neue Hardware gefunden" abschalten

Wenn Sie unter Windows neue Hardware anschließen (z.B. USB-Geräte), blendet Windows in der Taskleiste Sprechblasen (BallonTips) ein, um den Benutzer darüber zu informieren, dass neue Hardware gefunden wurde und entsprechende Treiber installiert werden.

Mit diesem Tipp können Sie die Sprechblasen "Neue Hardware gefunden" ausschalten. Windows richtet die Geräte dann im hintergrund ohne die Anzeige der Informationen ein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DeviceInstall\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBalloonTips" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Sprechblasen (BallonTipps) werden angezeigt (Standard)
1 | Es werden keine Sprechblasen "Neue Hardware gefunden" mehr angezeigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Geräteinstallation
Einstellungsname: | Sprechblasen mit der Meldung "Neue Hardware gefunden" während der Geräteinstallation deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2261.htm


Klassischen Desktop aktivieren (Visuelle Stile ausschalten)

Klassischen Desktop aktivieren (visuelle Stils ausschalten)

Mit diesem Tipp können Sie den "Klassischen Desktop" aktivieren. Der braucht wenig Rechenleistung und ist deshalb gerade für relativ langsame Rechner geeignet.

In der Oberfläche finden Sie die Einstellung unter: "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen. Es wird das Fenster "Leistungsoptionen" geöffnet. Hier stellen Sie unter dem Tabreiter "Visuelle Effekte" die Auswahl auf "Benutzerdefiniert" und entfernen anschließend den Haken bei "Visuelle Stile für Fenster und Schaltflächen verwenden".

Wenn Sie jetzt auf OK klicken, wird der "Klassische Desktop" geladen.

In der Registry finden Sie diese Einstellung unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ ThemeManager

ändern Sie hier den Wert "ThemeActive" als Datentyp REG_SZ und setzen den Wert auf:

0 | Klassischen Desktop
1 | Neuen Desktop im visuellen Stil

Wenn Sie den Wert über die Oberfläche verändern, werden die folgenden Registryeinträge gelöscht (Haken entfernt) bzw. angelegt (Haken gesetzt):

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ ThemeManager

Name | Datentyp | Wert
ColorName | REG_SZ | NormalColor
DllName | REG_EXPAND_SZ | %SystemRoot%\resources\themes\Aero\Aero.msstyles
LastLoadedDPI | REG_SZ | 96
LastUserLangID | REG_SZ | 1031
LoadedBefore | REG_SZ | 1
SizeName | REG_SZ | NormalSize

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2316.htm


Miniaturansichten anstelle von Symbolen anzeigen

Miniaturansichten statt Symbole anzeigen

Mit diesem Tipp können Sie die "Miniaturansichten" deaktivieren. Durch die Darstellung der "Miniaturansichten" wird viel Rechenleistung verbraucht, und sie ist daher ungeeignet für nicht so schnelle Rechner.

In der Oberfläche finden Sie die Einstellung unter: "Systemsteuerung (Klassische Ansicht)" -> "Leistungsinformationen und -tools" -> links "Visuelle Effekte anpassen" auswählen. Es wird das Fenster "Leistungsoptionen" geöffnet. Hier stellen Sie unter dem Tabreiter "Visuelle Effekte" die Auswahl auf "Benutzerdefiniert" und entfernen anschließend den Haken bei "Miniaturansichten anstelle von Symbolen anzeigen".

In der Registry finden Sie diese Einstellung unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

ändern Sie hier den Wert "IconsOnly" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Miniaturansichten anzeigen
1 | Nur Symbole anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2317.htm


MSStyle unter Windows Vista wechseln

Damit Sie auch unter Windows Vista (wie bei Windows XP) zu einen MSStyle wechseln können, müssen Sie das Patch für die Datei "UXTHEME.DLL" installieren.

Für Windows Vista 32 oder 64-Bit finden Sie dafür das Programm "VistaGlazz" unter "http://www.codegazer.com/vistaglazz.htm".

Info Wenn Sie dieses Tool installieren, hat das den weiteren Effekt, dass auch bei einem maximierten Fenster die Transparenz erhalten bleibt.

Kopieren Sie jetzt die Styles (.msstyles) in das Verzeichnis:

%SystemRoot%\Resources

Wenn Sie dazu auch noch Themas (.theme) besitzen, kopieren Sie diese Dateien in das Verzeichnis:

%SystemRoot%\Themes

Werden für die Styles zusätzlich noch DLL-Dateien benötigt, müssen Sie darauf achten, dass diese DLL-Dateien im richtigen Format vorliegen (32/64-Bit System).

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2335.htm


Anzeige und Aktualisierung des Leistungsindex deaktivieren

Über Sie Systemsteuerung können Sie sich durch den Eintrag "Leistungsinformationen und -tools", den aktuellen Leistungsindex des Rechners anzeigen lassen und auch aktualisieren. Wenn Sie das Tool aufrufen, wird Ihnen folgendes Bild gezeigt:

Über den Link "Bewertung aktualisieren" können Sie den Leistungsindex neu berechnen lassen. Sie können das auch über die Eingabeaufforderung mit dem Befehl "%windir%\system32\winsat.exe formal" neu berechnen lassen.

Folgende Parameter sind bei dem Befehl möglich:

Aufruf: WINSAT <Parameter> [Optionen]

Parameter | Beschreibung
formal | Vollständige Gruppe von Bewertungen ausführen und Ergebnisse speichern
features | Nur die Featurebewertung ausführen
cpu | CPU-Bewertung ausführen
mem | Systemspeicherbewertung ausführen
dwn | Desktopfenster-Manager-Bewertung ausführen
d3d | D3D-Bewertung ausführen
media | Medienbewertung ausführen
mfmedia | Media Foundation-basierte Bewertung ausführen
disk | Speicherbewertung ausführen

Mit der Option -v können Sie eine ausführliche Anzeige der Informationen aktivieren.

Mit diesem Tipp können Sie die Anzeige des Leistungsindex ausblenden und dadurch kann der aktuelle Leistungsindex auch nicht mehr aktualisiert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Performance Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Control Panel\ Performance Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "PerfCplEnabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Leistungsindex wird ausgeblendet
1 | Leistungsindex wird angezeigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Systemsteuerung - Leistung
Einstellungsname: | Zugriff auf den Leistungscenter-Kernbereich deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2253.htm


Den Eintrag "Verwaltung" aus Regions- und Sprachoptionen entfernen

Mit diesem Tipp können Sie den Tabreiter "Verwaltung" von "Regions- und Sprachoptionen" aus der Systemsteuerung entfernen. Wenn Sie den Tipp aktivieren, wird der Eintrag nicht mehr angezeigt, in diesem Bereich können die Einstellungen von "Sprache für Unicode-inkompatible Programme" und "Reservierte Konten" vorgenommen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Control Panel\ International

Erstellen Sie hier einen neuen Wert mit dem Namen "HideAdminOptions" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Tabreiter "Verwaltung" anzeigen (Standard)
1 | Tabreiter "Verwaltung" ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Regions- und Sprachoptionen
Einstellungsname: | Administrative Optionen in "Regions- und Sprachoptionen" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2254.htm


Den Eintrag "Standort" aus Regions- und Sprachoptionen entfernen

Mit diesem Tipp können Sie den Tabreiter "Standort" von "Regions- und Sprachoptionen" aus der Systemsteuerung entfernen. Wenn Sie den Tipp aktivieren, wird der Eintrag nicht mehr angezeigt, in diesem Bereich legen Sie den aktuellen Standort fest. Diese Einstellung wird für lokale Informationen von einigen Programmen ausgewertet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Control Panel\ International

Erstellen Sie hier einen neuen Wert mit dem Namen "HideCurrentLocation" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Tabreiter "Standort" anzeigen (Standard)
1 | Tabreiter "Standort" ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Regions- und Sprachoptionen
Einstellungsname: | Optionen für geographischen Standort ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2255.htm


Den Eintrag "Formate" aus Regions- und Sprachoptionen entfernen

Mit diesem Tipp können Sie den Tabreiter "Formate" von "Regions- und Sprachoptionen" aus der Systemsteuerung entfernen. Wenn Sie den Tipp aktivieren, wird der Eintrag nicht mehr angezeigt, in diesem Bereich legen Sie das Anzeigeformat für Uhrzeit,, Datum, Währungen usw. fest.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Control Panel\ International

Erstellen Sie hier einen neuen Wert mit dem Namen "HideLocaleSelectAndCustomize" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Tabreiter "Formate" anzeigen (Standard)
1 | Tabreiter "Formate" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Regions- und Sprachoptionen
Einstellungsname: | Optionen zur Auswahl und Anpassung von Benutzergebietsschemas ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2256.htm


Den Eintrag "Sprachauswahl" aus Regions- und Sprachoptionen entfernen

Mit diesem Tipp können Sie den Tabreiter "Sprachauswahl" von "Regions- und Sprachoptionen" aus der Systemsteuerung entfernen. Wenn Sie den Tipp aktivieren, wird der Eintrag nicht mehr angezeigt, in diesem Bereich legen Sie die Sprache für das System fest, weshalb dieser Eintrag auch nur in Multilingualumgebungen vorhanden ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Control Panel\ International

Erstellen Sie hier einen neuen Wert mit dem Namen "HideLanguageSelection" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Tabreiter Sprachauswahl" anzeigen (Standard)
1 | Tabreiter "Sprachauswahl" ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Systemsteuerung\Regions- und Sprachoptionen
Einstellungsname: | Optionsgruppe zur Sprachauswahl ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2264.htm


Erweitere Indizierungsoptionen aus der Systemsteuerung ausblenden

Erweiterte Indizierungsoptionen aus der Systemsteuerung ausblenden

Mit diesem Tipp können Sie einstellen, ob die sog. Erweiterte Indizierungsoptionen in der Systemsteuerung geöffnet werden können. Wenn Sie den Tipp aktivieren, kann man auf den Eintrag "Such- und Indizierungsoptionen" aus der Systemsteuerung nicht mehr zugreifen und die Erweiterten Optionen können nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Search

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventUsingAdvancedIndexingOptions" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | "Such- und Indizierungsoptionen" anzeigen (Standard)
1 | "Such- und Indizierungsoptionen" ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Anzeige erweiterter Indizierungsoptionen in der Systemsteuerung verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2401.htm


Windows Sidebar deaktivieren

Mit diesem Tipp können Sie die Windows Sidebar deaktivieren. Über die Sidebar lassen sich Mini-Anwendungen (Gadget) auf den Desktop einbinden. Über die Applets können Sie auf unterschiedliche Funktionen zugreifen oder sich auch bestimmte Informationen anzeigen lassen. Von vielen Programmieren wurden bereits etliche kleine Mini-Anwendungen entwickelt.

Wenn Sie den Tipp aktivieren, wird die Sidebar von Windows deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

Erstellen Sie hier einen neuen Wert mit dem Namen "TurnOffSidebar" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Sidebar ausblenden
0 | Sidebar anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Sidebar
Einstellungsname: | Windows-Sidebar deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2325.htm


URL für Sidebar-Anwendung ändern

Windows stellt in der Sidebar einen Link zur Verfügung, über den weitere Mini-Anwendungen (Gadget) in die Sidebar eingebunden werden. Standardmäßig verweist der Link auf eine Homepage von Microsoft hin, auf der mehrere Anwendungen zum Download bereitgestellt werden.

Mit diesem Tipp können Sie die URL von Links verändern und dadurch die Anwender auf eine andere Webseite umleiten.

Wenn Sie den Tipp aktivieren, werden die Anwender auf die angegebene URL umgeleitet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

Erstellen Sie hier einen neuen Wert mit dem Namen "OverrideMoreGadgetsLink" als Datentyp REG_SZ und geben die neue URL ein. Wenn Sie wieder auf die Standardseite von Microsoft verlinken wollen, müssen Sie diesen Eintrag nur löschen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Sidebar
Einstellungsname: | URL für Sidebar-Anwendung ändern

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2324.htm


Entpacken und Installieren von nicht signierten Sidebar- Anwendungen unterbinden

Wenn Sie diesen Tipp aktivieren, können Mini-Anwendungen (Gadget) nicht installiert werden, die entpackt werden müssen und nicht digital signiert sind. Dadurch können sich Viren/Trojaner, welche komprimiert sind, nicht so leicht auf einen Rechner einnisten.

Wird der Tipp aktiviert, werden keine unsignierten und gepackten Anwendungen mehr installiert. Standardmäßig werden auch nicht signierte Anwendungen installiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

Erstellen Sie hier einen neuen Wert mit dem Namen "TurnOffUnsignedGadgets" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Gepackte Anwendungen müssen digital signiert sein
0 | Es werden alle Anwendungen installiert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Sidebar
Einstellungsname: | Dekomprimieren und Installieren von Minianwendungen, die nicht digital signiert sind, deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2326.htm


Benutzereigene Sidebar-Anwendungen sperren

Standardmäßig können die Benutzer eigene Mini-Anwendungen (Gadget) installieren und in die Sidebar einbinden. Diese Anwendungen werden im Benutzerprofil des Anwenders abgelegt.

Wenn Sie diesen Tipp aktivieren, können Sie Anwender keine eigenen Minianwendungen mehr installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Windows\ Sidebar

Erstellen Sie hier einen neuen Wert mit dem Namen "TurnOffUserInstalledGadgets" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Anwender: Eigene Minianwendungen nicht zulassen
0 | Eigene Minianwendungen können eingebunden werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Sidebar
Einstellungsname: | Vom Benutzer installierte Windows-Sidebar-Minianwendungen deaktvieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2327.htm


SideShow: Automatisches Reaktivieren konfigurieren

SideShow: Automatisches Reaktivieren ausblenden und ausschalten

Mit diesem Tipp können Sie die Option - zur periodischen Reaktivierung des Computers - zur Aktualisierung von Informationen auf Windows SideShow [image] Die Funktion Sideshow, ermöglicht auf einem separaten Display auch bei ausgeschaltetem Notebook Inhalte abzurufen. Beispielsweise lassen sich so Bilder und Videos anschauen, Mails lesen und Musikdateien anhören. Auch für Desktop-Systeme gibt es Zusatzdisplays, die Informationen aus dem Internet auch dann anzeigen und abrufbar machen, wenn der Rechner selbst heruntergefahren wurde oder im StandBy-Modus läuft. Die SideShow-Minianwendungen hängen direkt mit den Gadgets der Windows Sidebar zusammen.-kompatiblen Geräten deaktiviert.

Wenn Sie den Eintrag "AutoWakeDisabled" aktivieren (Festlegung auf "1"), ist die Option zur automatischen Reaktivierung des Computers in der Windows SideShow Systemsteuerung nicht verfügbar.

Wenn Sie den Eintrag "AutoWakeDisabled" deaktivieren oder nicht konfigurieren, ist die Option zur automatischen Reaktivierung des Computers in der Windows SideShow Systemsteuerung verfügbar.

Die Option ist standardmäßig deaktiviert.

Info Die Informationen auf Windows SideShow-kompatiblen Geräten werden nur aktualisiert, wenn der Computer eingeschaltet und aktiv ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ SideShow

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ SideShow

Erstellen Sie hier einen neuen Wert mit dem Namen "AutoWakeDisabled" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Automatische Reaktivieren ist nicht mehr verfügbar (ausgeblendet)
0 | Automatische Reaktivieren kann konfiguriert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows SideShow
Einstellungsname: | Automatisches Reaktivieren deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2571.htm


SideShow: Daten vom Gerät beim abmelden löschen

SideShow: Daten vom Gerät löschen beim Abmelden

Mit diesem Tipp stellen Sie ein, dass alle Daten, die auf einen Windows SideShow [image] Die Funktion Sideshow, ermöglicht auf einem separaten Display auch bei ausgeschaltetem Notebook Inhalte abzurufen. Beispielsweise lassen sich so Bilder und Videos anschauen, Mails lesen und Musikdateien anhören. Auch für Desktop-Systeme gibt es Zusatzdisplays, die Informationen aus dem Internet auch dann anzeigen und abrufbar machen, wenn der Rechner selbst heruntergefahren wurde oder im StandBy-Modus läuft. Die SideShow-Minianwendungen hängen direkt mit den Gadgets der Windows Sidebar zusammen. kompatiblen Geräten gespeichert sind, bei der Abmeldung gelöscht werden.

Wenn Sie den Eintrag "DeleteDataOnLogoff" aktivieren (Festlegung auf "1"), werden alle Daten gelöscht, die auf Geräten gespeichert sind, auf denen Microsoft-Firmware ausgeführt wird, wenn sich ein Benutzer vom Computer abmeldet. Die Daten werden erneut an das Gerät gesendet, wenn sich der Benutzer wieder anmeldet.

Dies ist eine Sicherheitsmaßnahme, die jedoch die Nützlichkeit der Geräte erheblich einschränkt.

Wenn Sie den Eintrag "DeleteDataOnLogoff" deaktivieren oder nicht konfigurieren, werden die Daten nicht von diesen Geräten gelöscht, wenn sich Benutzer vom Computer abmelden. Die Benutzer können diese Einstellung aber in der Windows SideShow Systemsteuerung aktivieren.

Info SideShow Geräte, auf denen keine Microsoft-Firmware ausgeführt wird, sind nicht von dieser Richtlinieneinstellung betroffen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ SideShow

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ SideShow

Erstellen Sie hier einen neuen Wert mit dem Namen "DeleteDataOnLogoff" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Daten bei der Abmeldung löschen
0 | Daten werden nicht gelöscht (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows SideShow
Einstellungsname: | Daten von Geräten, auf denen Microsoft-Firmware ausgeführt wird, löschen, wenn sich ein Benutzer vom Computer abmeldet

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2572.htm


SideShow: PIN-Eingabe für den Zugriff auf die Daten aktivieren

Mit diesem Tipp stellen Sie ein, dass alle Benutzer eine Standard-PIN (Personal Identification Number, Geheimzahl) eingeben müssen, um das Gerät nach einer angegebenen Dauer ohne Aktivität (Zeitüberschreitungsdauer) zu entsperren und um auf Daten zugreifen zu können.

Diese Einstellung betrifft Windows SideShow [image] Die Funktion Sideshow, ermöglicht auf einem separaten Display auch bei ausgeschaltetem Notebook Inhalte abzurufen. Beispielsweise lassen sich so Bilder und Videos anschauen, Mails lesen und Musikdateien anhören. Auch für Desktop-Systeme gibt es Zusatzdisplays, die Informationen aus dem Internet auch dann anzeigen und abrufbar machen, wenn der Rechner selbst heruntergefahren wurde oder im StandBy-Modus läuft. Die SideShow-Minianwendungen hängen direkt mit den Gadgets der Windows Sidebar zusammen.-kompatible Geräte, auf denen Microsoft-Firmware ausgeführt wird.

Wenn Sie den Eintrag "SetPIN" aktivieren (Festlegung auf "1"), müssen Benutzer die Standard-PIN eingeben, um das Gerät nach der angegebenen Zeitüberschreitungsdauer zu entsperren und um auf Daten zugreifen zu können.

Info Benutzer können die PIN und die Zeitüberschreitungsdauer auf der Seite für die Geräteeinstellungen in der Windows SideShow Systemsteuerung ändern.

Wenn Sie den Eintrag "SetPIN" deaktivieren oder nicht konfigurieren, müssen Benutzer keine Standard-PIN eingeben, um das Gerät nach der angegebenen Zeitüberschreitungsdauer zu entsperren und auf Daten zugreifen zu können. Die Benutzer haben jedoch die Möglichkeit, in der Windows SideShow Systemsteuerung, die PIN-Sperrung zu aktivieren und die Zeitüberschreitungsdauer zu ändern.

Info SideShow Geräte, auf denen keine Microsoft-Firmware ausgeführt wird, sind nicht von dieser Richtlinieneinstellung betroffen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ SideShow

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ SideShow

Erstellen Sie hier einen neuen Wert mit dem Namen "SetPIN" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Um die PIN-Eingabe zu aktivieren
0 | PIN-Eingabe deaktivieren (Standard)

Wenn Sie Eintrag der PIN-Abfrage aktivieren, können Sie das Verhalten über zwei weitere Einträge noch konfigurieren.

Erstellen Sie einen neuen Wert mit dem Namen "PIN" als Datentyp REG_DWORD und geben Sie hier als Dezimalwert eine 4-stellige PIN-Nummer ein. Diese Nummer müssen Sie entsprechend eingeben.

Erstellen Sie einen neuen Wert mit dem Namen "PINTimeout" als Datentyp REG_DWORD und setzen den Wert auf:

65535 | Als Dezimalwert, um die erneute PIN-Eingabe zu aktivieren, wenn der Bildschirm ausgeschaltet wird.
Zeit in <Sekunden> | Gibt als Dezimalwert die Zeit in Sekunden an, bis eine erneute PIN-Eingabe erforderlich ist. 60 -> 1 Minute 120 -> 2 Minuten usw.
0 | PIN läuft nie ab

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows SideShow
Einstellungsname: | PIN anfordern, um auf Daten auf Geräten mit Microsoft-Firmware zuzugreifen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2573.htm


SideShow: Die SideShow-Funktion deaktivieren

Mit diesem Tipp können Sie die Windows-SideShow [image] Die Funktion Sideshow, ermöglicht auf einem separaten Display auch bei ausgeschaltetem Notebook Inhalte abzurufen. Beispielsweise lassen sich so Bilder und Videos anschauen, Mails lesen und Musikdateien anhören. Auch für Desktop-Systeme gibt es Zusatzdisplays, die Informationen aus dem Internet auch dann anzeigen und abrufbar machen, wenn der Rechner selbst heruntergefahren wurde oder im StandBy-Modus läuft. Die SideShow-Minianwendungen hängen direkt mit den Gadgets der Windows Sidebar zusammen. deaktiviert.

Wenn Sie den Eintrag "Disabled" aktivieren (Festlegung auf "1"), wird die Windows-SideShow-Systemsteuerung deaktiviert, und Daten von mit Window-SideShow kompatiblen Minianwendungen werden nicht an angeschlossene Geräte gesendet.

Wenn Sie den Eintrag "Disabled" deaktivieren oder nicht konfigurieren, ist Windows SideShow standardmäßig aktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ SideShow

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ SideShow

Erstellen Sie hier einen neuen Wert mit dem Namen "Disabled" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Windows SideShow deaktivieren
0 | Windows SideShow ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows SideShow
Einstellungsname: | Windows SideShow deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2574.htm


pnputil: Treiberpakete installieren/deinstallieren und anzeigen lassen

Mit dem Kommandozeilentool "pnputil.exe" können Sie sich die Treiber aus dem Driver Store von Windows anzeigen lassen. Der Driver Store liegt unter "%SystemRoot%\System32\Driver Store", hier werden alle Treiber abgelegt, die dem System bekannt sind.

Nicht mehr benötigte, fehlerhafte oder alte Treiber können wieder entfernt oder auch neue Treiber hinzufügen werden, ohne dafür die entsprechende Hardware haben zu müssen.

Der Driver Store wird benötigt, wenn sich normale Anwender (ohne administrative Berechtigungen) am System anmelden und entsprechende Plug&Play Hardware anschließen. Diesen Anwender können nur Treiber aus den Verzeichnis zur Verfügung gestellt werden.

Über den Befehl "pbputil -e" werden alle Treiber von anderen Herstellern aufgelistet, die sich im Driver Store befinden.

Über den Befehl "pnputil -d [treibername]" können Sie einen entsprechenden Treiber entfernen.

Eine Übersicht der Parameter erhalten Sie über pnputil /?

Parameter | Beschreibung
-e | Alle Drittanbieterpakete auflisten
-d [Treibername] | Paket löschen: Beispiel: pnputil -d oem1.inf
-f -d [Treibername] | Löschen des Paketes erzwingen
-a [Verzeichnis\Datei] | Pakete hinzufügen Beispiel: pnputil -a c:\drv\oem11.inf (Sie können auch mit Wildcard arbeiten. Also C:\drv\*.inf fügt alle Treiber aus dem Verzeichnis drv hinzu).
-i -a [Verzeichnis\Datei] | Fügt den Treiber hinzu und installiert ihn anschließend.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2562.htm


Dateien nach bestimmter Zeit aus dem Cache entfernen

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt fest, wie lange Dateien im Peercache Speicher gehalten werden, bevor Sie aus diesem Speicher gelöscht werden. Damit der Speicher effizient verwendet wird, werden Dateien standardmäßig von BITS entfernt, die älter als 14 Tage sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxContentAge" als Datentyp REG_DWORD, und geben Sie die Zeit in Tagen an, wie lange die Dateien im Cache gehalten werden sollen. Die erlaubten Werte liegen zwischen 1 und 120 Tage und werden Dezimal angegeben.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Alter der Elemente im BITS-Peercache beschränken

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2372.htm


Background Intelligent Transfer Service (BITS) aktivieren

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt fest, ob die Peercaching-Funktion auf dem Computer aktiviert ist. Standardmäßig ist die Funktion nicht aktiv und die Dateien werden nur vom angegeben Ursprungsserver heruntergeladen. Wird das BITS-Peercaching aktiviert, werden die Daten zwischengespeichert und anderen BITS-Peers zur Verfügung gestellt. Die Clients mit BITS fordern zuerst bei einem Download die Dateien an, welche sich im selben IP-Subnetz befinden.

Nur wenn keiner der Rechner innerhalb des IP-Subnetzwerk diese Dateien vorhält, werden die Dateien vom Server angefordert. Durch diese Funktion soll die Netzwerklast über IP-Subnetzwerke hinaus klein gehalten werden.

Wenn Sie den Tipp aktivieren, speichert der Client BITS-Aufträge zwischen und reagiert auf Inhaltsanforderungen von anderen Peerclients.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "EnablePeercaching" als Datentyp REG_DWORD und setzen den Wert auf:

1 | BITS-Peercaching aktivieren
0 | BITS-Peercaching deaktivieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | BITS-Peercaching zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2373.htm


Rechner darf nicht als BITS-Peercaching Client fungieren

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt fest, ob der Client als Peercaching-Client fungieren kann. Ist die BITS-Peercaching-Funktion aktiv, fungiert der Computer standardmäßig sowohl als Peercachingserver (der seinen Peers Dateien zur Verfügung stellt) als auch als Peercachingclient (der Dateien von den Peers herunterlädt).

Wenn Sie den Tipp aktivieren, werden keinen Dateien mehr von Peers heruntergeladen, sondern die Dateien werden nur noch vom Ursprungsserver geladen. Der Computer stellt aber weiterhin seine Dateien noch anderen Peers zur Verfügung.

Ist die Funktion nicht aktiv, wird erst versucht die Datei von einen anderen Peers-Client herunterzuladen, bevor auf den Ursprungsserver zugegriffen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePeerCachingClient" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Peercachingclient Funktion aktiv (Standard)
1 | Peercachingclient deaktivieren

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Computer darf nicht als BITS-Peercachingclient fungieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2374.htm


Rechner darf nicht als BITS-Peercaching Server fungieren

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt fest, ob der Client als Peercaching-Server fungieren kann. Ist die BITS-Peercaching-Funktion aktiv, fungiert der Computer standardmäßig sowohl als Peercachingserver (der seinen Peers Dateien zur Verfügung stellt) als auch als Peercachingclient (der Dateien von den Peers herunterlädt).

Wenn Sie den Tipp aktivieren, werden heruntergeladene Dateien nicht mehr auf dem Computer zwischengespeichert und anderen Rechner zur Verfügung gestellt. Der Rechner selber lädt Dateien aber weiterhin noch von anderen Clientrechnern (Peers) herunter.

Ist die Funktion nicht aktiv, werden heruntergeladene Dateien zwischengespeichert und anderen Rechnern zur Verfügung gestellt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePeerCachingServer" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Peercachingserver Funktion aktiv (Standard)
1 | Peercachingserver deaktivieren

Info Diese Einstellung benötigt die Aktivierung und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Computer darf nicht als BITS-Peercachingserver fungieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2375.htm


Speicherplatz für den BITS-Peercache konfigurieren

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt fest, wieviel Prozent des Speicherplatzes für das Speichern (Cachen) der Dateien benutzt werden darf. In diesem Speicher werden die Dateien abgelegt, welche anderen Rechner zur Verfügung gestellt werden. Wenn Sie den Tipp aktivieren, können Sie Werte zwischen 1% bis 80% angeben. Standardmäßig wird 1% des Systemspeicherplatzes für den BITS-Peercache verwendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxCacheSize" als Datentyp REG_DWORD, und geben Sie die Größe des Speicherplatzes in Prozent an. Gültige Werte liegen zwischen 1% bis 80%. Ist der Eintrag nicht vorhanden, wird der Standardwert von 1% verwendet.

Info Diese Einstellung benötigt die Aktivierung und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Größe des BITS-Peercaches beschränken

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2376.htm


Anzahl der maximalen Bereiche pro BITS-Auftrag festlegen

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp gibt die maximal Anzahl von Bereichen an, die einer Datei in einem BITS-Auftrag hinzugefügt werden können. Standardmäßig ist die Anzahl der Datei pro BITS-Auftrag auf 500 Bereiche begrenzt.

Wenn Sie den Tipp aktivieren, können Sie die maximale Anzahl von Bereichen, die einer Datei hinzugefügt werden können, auf einen neuen gewünschten Wert festlegen.

Info BITS-Aufträge, die über Dienste oder administrative Konten erstellt werden, unterliegen der Beschränkung nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxRangesPerFile" als Datentyp REG_DWORD und geben Sie die maximale Anzahl der Bereiche an.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Anzahl von Bereichen, die einer Datei in einem BITS-Auftrag hinzugefügt werden können

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2385.htm


Anzahl der maximalen BITS-Aufträge pro Rechner festlegen

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp gibt die maximal Anzahl von Aufträgen an, die für alle Benutzer des Computers erstellt werden können. Standardmäßig ist die Anzahl auf 300 Aufträge begrenzt.

Wenn Sie den Tipp aktivieren, können Sie die maximale Anzahl von Aufträgen pro Rechner, auf einen neuen gewünschten Wert festlegen.

Info BITS-Aufträge, die über Dienste oder administrative Konten erstellt werden, unterliegen der Beschränkung nicht.

[für das System (alle Anwender)]

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxJobsPerMachine" als Datentyp REG_DWORD und geben Sie die maximale Anzahl der Aufträge an.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Anzahl von BITS-Aufträgen für diesen Computer

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2386.htm


Anzahl der maximalen BITS-Aufträge pro Anwender festlegen

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp gibt die maximal Anzahl von Aufträgen an, die von einem Anwender erstellt werden können. Standardmäßig ist die Anzahl auf 60 Aufträge begrenzt.

Wenn Sie den Tipp aktivieren, können Sie die maximale Anzahl von Aufträgen pro Rechner, auf einen neuen gewünschten Wert festlegen. Dieser Wert muss kleiner sein als der Wert, welcher unter "Anzahl der maximalen BITS-Aufträge pro Rechner festlegen" angegeben wurde. Wenn die Einstellung "Anzahl der maximalen BITS-Aufträge pro Rechner festlegen" nicht konfiguriert wurde, liegt der Maximalwert bei 300.

Info BITS-Aufträge, die über Dienste oder administrative Konten erstellt werden, unterliegen der Beschränkung nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxJobsPerUser" als Datentyp REG_DWORD, und geben Sie die maximale Anzahl der Aufträge an.

Info Diese Einstellung benötigt die Aktivierung und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Anzahl von BITS-Aufträgen für jeden Benutzer

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2387.htm


Anzahl der maximal zulässigen Datei pro BITS-Auftrag

Anzahl der maximal zulässigen Dateien pro BITS-Auftrag

Mit diesen Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp legt die maximale Anzahl von Dateien fest, die ein BITS-Auftrag enthalten kann. Standardmäßig ist die Anzahl der Dateien pro Auftrag auf 200 Dateien begrenzt.

Wenn Sie den Tipp aktivieren, können Sie die maximale Anzahl von Dateien pro BITS-Auftrag festlegen

Info BITS-Aufträge, die über Dienste oder administrative Konten erstellt werden, unterliegen der Beschränkung nicht.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxFilesPerJob" als Datentyp REG_DWORD, und geben Sie als Wert die maximale Anzahl der Dateien an.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Anzahl zulässiger Dateien in einem BITS-Auftrag

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2388.htm


Maximale Downloadzeit pro BITS-Auftrag

Mit diesem Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp begrenzt die Zeit, wie lange ein Download pro BITS-Auftrag maximal dauern darf. Wenn die Zeit überschritten wird, erhält der Auftrag den Status "Fehler" und wird abgebrochen. Standardmäßig verwendet BITS eine maximale Downloadzeit von 15 Tage (54000 Sekunden).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxDownloadTime" als Datentyp REG_DWORD. Geben Sie die maximale Zeit an, die für einen Download pro Auftrag verwendet werden darf, bevor der Auftrag als fehlerhaft eingeordnet wird.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Downloadzeit für BITS-Aufträge

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2390.htm


Konfiguration der Netzwerkbandbreite für BITS- Übertragungen

Mit diesem Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp konfiguriert die Einstellung, wieviel Netzwerkbandbreite für die Übertragung im Hintergrund von BITS-Dienst belegt werden soll. Wenn Sie den Tipp nicht konfigurieren, benutzt der BITS-Dienst die gesamte ungenutzte Bandbreite.

Diese Einstellung gilt nur für die Hintergrundübertragung und nicht für Übertragungen im Vordergrund.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier die folgenden neuen Werte als Datentyp REG_DWORD und geben die entsprechenden Werte an. Wenn Sie die Einträge löschen, wird wieder die Standardeinstellung verwendet.

Name | Werte | Beschreibung
EnableBITSMaxBandwidth | 1 oder <gelöscht> | Legt fest, das mit den unteren Werten die Einstellungen für die Übertragung festgelegt werden.
MaxBandwidthValidFrom | 0-23 | Bandbreitenzeit von (Uhrzeit) 0: 24:00 Uhr 1: 1:00 Uhr ... 23: 23:00 Uhr Legt den Zeitraum fest, in dem die unter "MaxTransferRateOnSchedule" angegebene Bandbreite verwendet wird.
MaxBandwidthValidTo | 0-23 | Bandbreitenzeit bis (Uhrzeit) 0: 24:00 Uhr 1: 1:00 Uhr ... 23: 23:00 Uhr Legt den Zeitraum fest, in dem die unter "MaxTransferRateOnSchedule" angegebene Bandbreite verwendet wird.
MaxTransferRateOnSchedule | 1 bis 4294967295 in KBits/s | Bandbreite, die benutzt wird während der angegebenen Zeitspanne aus "MaxBandwidthValidFrom" und "MaxBandwidthValidTo". Die Angabe erfolgt in Kilobits pro Sekunde.
UseSystemMaximum | 1 oder <gelöscht> | Legt fest, ob außerhalb des unter "MaxBandwidthValidFrom" und "MaxBandwidthValidTo" angegebenen Zeitraums die maximale Bandbreite verwendet werden soll
MaxTransferRateOffSchedule | 1 bis 4294967295 in KBits/s | Gibt die Bandbreite an, die benutzt wird, wenn "UseSystemMaximum" nicht aktiviert (1) wurde.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Netzwerkbandbreite für BITS-Übertragungen im Hintergrund

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2391.htm


Maximale Netzwerkbandbreite für die Übertragung zu anderen BITS-Rechner

Maximale Netzwerkbandbreite für die Übertragung zu anderen Clients

Mit diesem Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp begrenzt die Netzwerkbandbreite, welche die Peercaching Rechner untereinander für die Übertragung der Daten verwenden. Dadurch kann die Belastung der Clients verringert werden, damit ohne Beeinträchtigung mit dem Rechner gearbeitet werden kann. Standardmäßig verwendet BITS bis zu 30% der Bandbreite.

Wenn ein Computer beispielsweise über eine 100-MBit/s-Netzwerkkarte und ein 56-KBit/s-Modem verfügt und beide Schnittstellen aktiv sind, verwendet BITS maximal 30 % von 56 KBit/s.

Wenn Sie diesen Tipp aktivieren, können Sie einen Wert zwischen 1048576 und 4294967200 Bits pro Sekunde (Bit/s) für die maximale Netzwerkbandbreite, die für das Peercaching verwendet wird, angeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxBandwidthServed" als Datentyp REG_DWORD und geben Sie die maximale Bandbreite an, die für die Übertragung verwendet werdet darf. Die Wert dürfen zwischen 1048576 und 4294967200 Bits pro Sekunde (Bit/s) liegen.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Maximale Netzwerkbandbreite für das Peercaching

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2392.htm


Zeitüberschreitung für inaktive BITS-Aufträge konfigurieren

Mit diesem Tipp konfigurieren Sie die Einstellung des BITS (Background Intelligent Transfer Service). Der Tipp gibt an, nach wieviel Tagen ein inaktiver BITS-Auftrag als fehlerhaft erkannt wird. Standardmäßig wird nach 90 Tagen ein BITS-Auftrag als fehlerhaft erkannt und entsprechend beendet. Wird der Zeitraum erreicht, werden sowohl der Auftrag als auch alle - bis zu diesem Zeitpunkt heruntergeladenen Dateien - aus dem Cache Speicher gelöscht.

Wenn der Rechner länger Offline ist und dadurch die Dateien selten herunterladen kann, kann es notwendig sein, diesen Zeitraum entsprechend zu erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ BITS

Erstellen Sie hier einen neuen Wert mit dem Namen "JobInactivityTimeout" als Datentyp REG_DWORD, und geben Sie die maximale Zeit in Tagen an, bis ein Auftrag als fehlerhaft erkannt werden soll.

Info Diese Einstellung benötigt die aktivieren und BITS (siehe Tipp: Background Intelligent Transfer Service (BITS) aktivieren)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS)
Einstellungsname: | Zeitüberschreitung für inaktive BITS-Aufträge

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2393.htm


Benutzer-Konten-Steuerung (UAC) deaktivieren/aktivieren

Ab Windows Vista gibt es die "Benutzerkontensteuerung" (UAC - User Account Control). Durch die UAC arbeiten auch Administratoren mit Standardbenutzerrechten. Wird eine Anwendung gestartet, wo mehr Rechte benötigt werden, muss das extra bestätigt werden. Die Zugriffe auf die Registry erfolgt über einen "Virtuellen Bereich"; somit können auch mit administrativen Rechten im Hintergrund keine Änderungen an wichtigen Einstellungen vorgenommen werden.

Wenn Sie eine Anwendung sofort mit administrativen Rechten starten wollen, können Sie das über Start -> Ausführen machen.

Geben Sie hier den Namen der Anwendung ein und halten Sie nun beim Drücken von Enter die Tasten [SHIFT]+[STRG] gedrückt.

Zusätzlich können Sie das auch bei den Einstellungen der Verknüpfung hinterlegen. Klicken Sie dafür die Verknüpfung mit der rechten Maustaste an, und wählen Sie aus dem Kontextmenü den Eintrag "Eigenschaften" aus. Wechseln Sie hier jetzt auf den Tabreiter "" und wählen Sie "" aus.

Sie können die UAC auch komplett deaktivieren:

Einfach können Sie den Wert über die "Systemsteuerung" unter Benutzerkonten "Benutzerkontensteuerung ein- oder ausschalten" deaktivieren. Weiterhin wird die Einstellung auch noch im Tool MSCONFIG.EXE unter dem Tabreiter "Tools" als Einstellung "Benutzerkontensteuerung deaktivieren" aufgeführt und kann auch hier geändert werden.

In der Registry finden Sie die Einstellung unter:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableLUA" als Datentyp REG_DWORD und setzen den Wert auf:

0

Schaltet UAC aus

Damit werden die Rechte nicht mehr eingeschränkt.

Das Deaktivieren ist nicht zu empfehlen, da man dadurch das neue Sicherheitskonzept von Windows ausschaltet.

Wenn Sie vorher immer schon mit einem eingeschränkten Benutzer gearbeitet haben und den Administratoraccount nur für Wartungsarbeiten benutzt haben, kann man diese Funktion ruhig ausschalten.
1 Schaltet UAC an (Standard)

Für den geschützten Modus des Internet Explorers wird UAC benötigt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Alle Administratoren im Administratorbestätigungsmodus ausführen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2151.htm


Dialogfarben der Benutzer-Konten-Steuerung (UAC)

Bei aktiver Benutzersteuerung (User Account Control - UAC) - siehe Tipp: "Benutzer-Konten-Steuerung (UAC) deaktivieren/aktivieren" -, wird ein entsprechender Dialog eingeblendet, wenn von einer Anwendung administrative Berechtigungen benötigt werden. Dieser Dialog muss bestätigt werden, damit diese Anwendung die nötigen Rechte erhält. Die Überschrift des Dialogs wird mit einer entsprechende Farbe hinterlegt, die darüber Aufschluss gibt, von was für einer Anwendung die Rechte angefordert werden.

Dabei gibt es folgende Farben:

Farbe | Bedeutung
blau | Windows Systemkomponenten
grau | Digital signierte Anwendungen
orange | Unsignierte Anwendungen
rot | Blockierte Anwendungen

Dadurch ist anhand der Farbe leicht ersichtlich, was für ein Typ von Anwendung die Rechte anfordert.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2378.htm


Monitor abdunkeln bei der Benutzerkontensteuerung ausschalten (sicherer Desktop)

Das Monitor-Abdunkeln ausschalten bei der Benutzerkontensteuerung (UAC) (sicherer Desktop)

Öffnet sich die Benutzerkontensteuerung (UAC), wird automatisch der Bildschirm abgedunkelt. Das passiert, weil Windows beim Aufruf der UAC auf den "sicheren Desktop" umschaltet und die Benutzeroberfläche ausblendet.

Mit diesem Tipp können Sie diesen Effekt ausschalten; bedenken Sie aber auch, dass dadurch nicht mehr auf den "sicheren Desktop" umgeschaltet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "PromptOnSecureDesktop" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Keinen "sicheren Desktop" verwenden
1 | "sicheren Desktop" verwenden t (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Bei Benutzeraufforderung nach erhöhten Rechten zum sicheren Desktop wechseln

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2218.htm


Mit aktiver Benutzerkontensteuerung auf administrative Freigaben zugreifen

Mit aktiver Benutzerkontensteuerung (UAC) auf administrative Freigaben zugreifen

Bei aktiver Benutzerkontensteuerung (siehe Tipp: Benutzerkontensteuerung (UAC) deaktivieren/aktivieren), wird der Zugriff auf die administrativen Freigaben (siehe Tipp: Entfernen der administrativen Standardfreigaben) und die Benutzung von Remoteadministrations Anwendungen unterbunden.

Sie können also mit Ihrem Rechner nicht Remote (über das Netzwerk) auf andere Rechner zugreifen. Die UAC geht dabei sogar soweit, dass im Dialogfeld "Servereigenschaften" eines Druckerservers unter dem Tabreiter "Treiber" die Befehle "Hinzufügen" und "Entfernen" ausgeblendet werden.

Wenn Sie diese Funktion aber benötigen und nicht gleich die ganze Benutzerkontensteuerung ausschalten wollen, können Sie das mit folgendem Registryeintrag machen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "LocalAccountTokenFilterPolicy" als Datentyp REG_DWORD und . Setzen Sie den Wert auf:

1 | Remote Zugriffe zulassen
0 | Remote Zugriffe beschränken(Standard)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:http://support.Microsoft.com/?kbid=927832

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2227.htm


Sicherheitsmechanismus "Integrity Level" (IL)

Ab Windows Vista hat Microsoft zusätzlich zum DAC (Discretionary Access Control) den IL (Integrity Level) eingeführt, welcher über dem DAC angeordnet ist. Das bedeutet, selbst wenn man auf ein Objekt über DAC zugreifen kann, kann dieser Zugriff vom IL unterbunden werden.

Jeder Prozess, der unter Windows Vista gestartet wird, bekommt automatisch einen Integrity Level (= Verbindlichkeitsstufe) zugeordnet. Anhand dieser IL kann Windows Vista erkennen, wie vertrauenswürdig die jeweilige Anwendung/Prozess ist.

Es gibt 5 Integrity-Levels und zwar:

  • Untrusted (nicht vertrauenswürdig)
    Diesem untersten Level wird unter Vista standardmäßig kein Prozess zugewiesen. Vorgesehen ist dieser Level, wenn der IE 7 auf "anonyme Zugriffe" für eine Webseite konfiguriert wird.
  • Low (niedrig)
    Einige Ordner werden bei der Installation für dieses Level eingerichtet. Benutzt wird das Level vom Internet Explorer (sehr wenige Rechte, damit sich Trojaner/Viren nicht mehr zu leicht einschleichen können).
  • Medium (mittel)
    Programme mit normalen Benutzerrechten. Alle Prozesse eines Standardbenutzers werden mit diesem Level gestartet.
  • High (hoch)
    Programme mit administrativen Rechten
  • System (System)
    Fürs Betriebssystem wichtige Dienste mit den höchsten Rechten

Diese Information wird im Mandatory Label (= Verbindliche Beschriftung) des Security Descriptor (System Access Control List - SACL) gespeichert. Ein Programm/Prozess kann immer nur auf seine Ebene (Integrity Level) und auf die unteren Ebenen zugreifen. Läuft also ein Programm auf der Stufe "Medium", so kann es zusätzlich noch auf die "Low" Ebene zugreifen, nicht aber auf die höheren Ebenen "High" und "System".

Über die Kommandozeilenoberfläche kann man sich den Level anzeigen lassen. Geben Sie dafür einfach den Befehl "whoami -groups" ein.

Am Ende der Liste finden Sie die entsprechende Sicherheitsgruppe (Benutzer: Verbindliche Beschriftung\ Mittlere Verbindlichkeitsstufe oder Administratoren: Verbindliche Beschriftung\Hohe Verbindlichkeitsstufe).

Die folgende Tabelle gibt die Integritätslevel mit den Bezeichnungen in Betriebssystem und der SID-Nummer an. Dabei wird bei "E" die englische Bezeichnung und bei "D" die deutsche Bezeichnung angegeben:

Level | Bezeichnung | SID | Hex
E: Untrusted D: Nicht vertauenswürdig | E: Mandatory Label\Untrusted Mandatory Level D: Verbindliche Beschriftung\Nicht vertauenswürdige Verbindlichkeitsstufe | S-1-16-0 | 0
E: Low D: Niedrig | E:Mandatory Label\Low Mandatory Level D: Verbindliche Beschriftung\Niedrige Verbindlichkeitsstufe | S-1-16-4096 | 1000
E: Medium D: Mittel | E:Mandatory Label\Medium Mandatory Level D: Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe | S-1-16-8192 | 2000
E: High D: Hoch | E:Mandatory Label\High Mandatory Level D: Verbindliche Beschriftung\Hohe Verbindlichkeitsstufe | S-1-16-12288 | 3000
System | Mandatory Label\System Mandatory Level *) | S-1-16-16385 | 4000

*) In diesem Mandatory Label (= Verbindliche Beschriftung) wird zusätzlich zum Status gespeichert, welche Zugriffe auf die höheren Ebenen unterbunden werden sollen. Dafür gibt es wieder 3 Arten:

  • Schreiben (No Write Up)
  • Lesen (No Read Up)
  • Ausführen (No Execute Up)

Für das Dateisystem wird von Windows standardmäßig "No Write Up" (Schreiben unterbinden) mit Stufe "Medium" verwendet.

Info So haben alle Verzeichnisse standardmäßig die Stufe "Medium" mit "No Write Up", welche benötigt wird, um auf das Verzeichnis schreibend zugreifen zu können. Dadurch ist der Internet Explorer auch nicht mehr in der Lage, in alle Verzeichnisse zu schreiben, auch wenn er über einen Benutzer gestartet wird. Für die IE wurden nur einige wenige Verzeichnisse mit dem Status "Low" versehen, um dort schreiben zu können (%Systemroot%\Users\Appdata\LocalLow, Cookies, Favoriten, Temporäre Internetdateien usw.). Deshalb müssen Sie z.B. auch, wenn Sie den Favoritenordner auf ein anderen Laufwerk verschieben, mit ICACLS die Rechte entsprechend anpassen (siehe Tipp: "Die Verzeichnisse 'Eigene Dateien' usw. verschieben")

Normalerweise bekommt jede Anwendung die Recht des Prozesses von dem aus sie gestartet wurde. Das würde aber bedeuten, dass, wenn ein Anwender den Internet Explorer startet, dieser auch im Integrity Level "Medium" laufen würde.

Um das zu verhindern, gibt es im Access Token eines Accounts den Eintrag "TOKEN_MANDATORY_POLICY_NEW_PROCESS_MIN", welcher bei Benutzeraccounts gesetzt und bei administrativen Accounts nicht gesetzt ist. Ist dieser Eintrag gesetzt, bewirkt er, dass Prozesse, welche gestartet werden, keine höheres Integrity Level bekommen können als wie der EXE-Datei zugewiesen wurde. Da der Datei IEXPLORE.EXE nur das IL "Low" zugewiesen ist, wird diese Datei bei normalen Benutzern auch nur in diesem Level gestartet.

Diese Berechtigungen können in der Kommandozeile mit dem Tool ICACLS bearbeitet und angeschaut werden. Weitere Infos zu dem Programm finden Sie im Tipp: "Zugriffsrechte von Dateien und Verzeichnissen über Batch setzen (CACLS und ICACLS)"

Mit den IL-Rechten können Sie Anwendungen, welche über Zugriffe in das Internet möglicherweise Trojaner oder Viren einschleusen können, durch ein niedriges Level "Low" auf einen kleinen Raum begrenzen. Der Internet Explorer wird schon im IL "Low" ausgeführt.

Wenn Sie aber mitFirefox arbeiten, sollten Sie einmal folgenden Tipp lesen: "Firefox mit niedrigen Rechten (Integrity Level) ausführen".

Mit dem Programm "Process Explorer" von Sysinternals können Sie sich die Integrity Level der aktuell laufenden Prozesse/Anwendungen anzeigen lassen:

Download: http://www.microsoft.com/technet/sysinternals/SystemInformation/ProcessExplorer.mspx

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2329.htm


Gesicherte Eingabe für Anmeldeinformationen benutzen

Mit diesem Tipp können Sie einstellen, das eine 'Gesicherte Eingabe' für Anmeldeinformationen unter Verwendung eines vertrauenswürdigen Pfads benutzt werden. Dadurch können Trojaner ihre Windows-Anmeldeinformationen nicht ausspionieren.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, geben die Benutzer Windows-Anmeldeinfomationen innerhalb ihrer Desktopsitzung ein, sodass möglicherweise gefährlicher Code Zugriff auf diese Anmeldeinformationen hat.

Als Sicherheitsempfehlung sollte diese Einstellung aktiviert sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ CredUI

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableSecureCredentialPrompting" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Anmeldeinformationen gesichert eingeben
0 | Normale Eingabe der Anmeldeinformationen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Benutzerschnittstelle für Anmeldeinformationen
Einstellungsname: | Vertrauenswürdiger Pfad für Anmeldeinformationseintrag erforderlich

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2334.htm


Benachrichtigungen vom Windows Sicherheitscenter deaktivieren

Das Windows Sicherheitscenter überwacht den Status einiger System-Komponenten und meldet den Status, wenn etwas nicht läuft. Dabei werden vom Sicherheitscenter folgende Funktionen überwacht:

  • Firewall
  • Virenschutz (Virensoftware von anderen Anbietern und Windows Defender)
  • Windows Update
  • Internet Security Einstellungen
  • Benutzer-Konten-Steuerung (User Account Control)

Der Anwender wird über ein Popup in der Taskleiste informiert, wenn eine dieser Funktionen nicht richtig läuft.

Diese Popup Meldungen kann man auch ausschalten.

Öffnen Sie dafür in der Systemsteuerung den Eintrag "Sicherheitscenter" und wählen Sie aus dem linken Menü den Eintrag "Die Sicherheitscenter-Benachrichtigungsmethode ändern". Dort wählen Sie im neuen Dialog den Eintrag "Keine Benachrichtigungen senden, aber das Symbol anzeigen" oder "Keine Benachrichtigungen senden und das Symbol nicht anzeigen (nicht empfohlen)" aus.

In der Registry finden Sie die Einstellung an folgender Stelle.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Security Center\ Svc\ [SID]

Geben Sie für [SID] die gültige SID des Benutzers an. Dafür öffnen Sie die Eingabeaufforderung und geben Sie folgenden Befehl ein:

wmic

Hier geben Sie jetzt hinter "wmic:root\cli>" den Befehl "USERACCOUNT" ein und drücken Enter.Suchen Sie in der Spalte "Caption" Ihren Anmeldenamen. Dort finden Sie in der Spalte "SID" die SID, welche Sie als Schlüssel anlegen müssen. Der Pfad müsste dann in etwa so aussehen:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Security Center\ Svc\ S-1-5-21-2739470526-749862721-3710435115-1000

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableNotifications" als Datentyp REG_DWORD und setzen den Wert auf:

gelöscht | Popup-Meldungen mit Informationen und das Symbol werden angezeigt (Standard)
1 | Keine Benachrichtigungen senden, aber das Symbol anzeigen
0 | Keine Benachrichtigungen senden und das Symbol nicht anzeigen (nicht empfohlen)

Sie finden hier auch den Eintrag "EnableNotificationsRef" als Datentyp REG_DWORD, wenn Sie die Konfiguration über die Oberfläche (wie oben beschrieben) geändert haben. Dieser Wert ist einfach nur ein Counter, der bei jeder Änderung der Einstellung nach oben gezählt wird.

Info Siehe dazu auch Tipp: "Überwachung des Windows-Sicherheitscenters konfigurieren"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2381.htm


Zugriffsrechte auf Wechseldatenträger festlegen (lesen/schreiben)

Mit diesen Tipp können Sie den Zugriff auf Wechseldatenträger konfigurieren. Sie können dabei für einen bestimmten Gerätetyp den Lesenden- und/oder Schreibenden-Zugriff unterbinden.

Mit Wechseldatenträger sind USB-Laufwerke oder Firewire-Laufwerke gemeint. Bei WPA-Geräten handelt es sich um Smartphones, MP3-Player oder PDAs auf den Windows Mobile als Betriebssystem installiert ist (Windows Portable Devices).

Info Ist der Tipp: "Zugriff auf alle Wechseldatenträger unterbinden" aktiv, haben die Einstellungen hier keine Auswirkung mehr.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ RemovableStorageDevices\ [Geräteklasse]

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ RemovableStorageDevices\ [Geräteklasse]

Für [Geräteklasse] erstellen Sie einen neuen Schlüssel. In der Tabelle finden Sie alle möglichen Geräteklassen, suchen Sie sich aus der Tabelle die Geräteklassen raus, welche Sie konfigurieren möchten:

Gerätetyp | Geräteklasse (Registry-Schlüssel)
CD/DVD | {53f56308-b6bf-11d0-94f2-00a0c91efb8b}
Diskettenlaufwerke | {53f56311-b6bf-11d0-94f2-00a0c91efb8b}
Wechseldatenträger | {53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
Bandlaufwerke | {53f5630b-b6bf-11d0-94f2-00a0c91efb8b}
WPA-Geräte | PDA: {6AC27878-A6FA-4155-BA85-F98F491D4F33} Smartphone: {F33FDC04-D1AC-4E8E-9A30-19BBD4B108AE}
Benutzerdefinierte Klassen | Geben Sie die Geräteklasse des Gerätetyp an, auf dem Sie den Zugriff einschränken wollen.

Lesezugriff konfigurieren:

Erstellen Sie hier einen neuen Wert mit dem Namen "Deny_Read" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | Lesezugriff erlauben (Standard)
1 | Lesezugriff unterbinden

Schreibzugriff konfigurieren:

Erstellen Sie hier einen neuen Wert mit dem Namen "Deny_Write" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | Schreibzugriff erlauben (Standard)
1 | Schreibzugriff unterbinden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Wechselmedienzugriff
Einstellungsname: | Bandlaufwerke: Lesezugriff verweigern Bandlaufwerke: Schreibzugriff verweigern Benutzerdefinierte Klassen: Lesezugriff verweigern Benutzerdefinierte Klassen: Schreibzugriff verweigern CD und DVD: Lesezugriff verweigern CD und DVD: Schreibzugriff verweigern Diskettenlaufwerke: Lesezugriff verweigern Diskettenlaufwerke: Schreibzugriff verweigern Wechseldatenträger: Lesezugriff verweigern Wechseldatenträger: Schreibzugriff verweigern WPD-Geräte: Lesezugriff verweigern WPD-Geräte: Schreibzugriff verweigern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2404.htm


Zugriff auf alle Wechseldatenträger unterbinden

Mit diesem Tipp konfigurieren Sie den Zugriff auf alle Wechseldatenträger (Medienklassen).Wenn Sie diesen Tipp aktivieren, wird der Zugriff auf alle Medienklassen unterbunden (lesen und schreiben). Es kann auf diese Geräte nicht mehr zugegriffen werden.

Info Den Zugriff auf unterschiedliche Medienklassen können Sie im Tipp "Zugriffsrechte auf Wechseldatenträger festlegen (lesen/schreiben)" konfigurieren. Sobald dieser Tipp aktiv ist, haben die Einstellungen dort keine Bedeutung mehr.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ RemovableStorageDevices

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ RemovableStorageDevices

Erstellen Sie hier einen neuen Wert mit dem Namen "Deny_All" als Datentyp REG_DWORD, und setzen Sie den Wert auf:

0 | Zugriff erlauben (Standard)
1 | Zugriff auf die Geräte unterbinden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\System\Wechselmedienzugriff
Einstellungsname: | Alle Wechselmedienklassen: Jeglichen Zugriff verweigern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2405.htm


Benutzerkontensteuerung (UAC – User Account Control)

In einigen Tipps wurde schon auf die Konfiguration der Benutzerkontensteuerung eingegangen. Hier wird die neue Funktion - ab Windows Vista- genauer beschrieben und alle entsprechenden Informationen dazu geben.

Die Benutzerkontensteuerung oder wie es in der englischen Version heißt User Account Control (UAC), ist dafür verantwortlich, dass bei der Ausführung von administrativen Aufgaben eine zusätzliche Bestätigung erforderlich ist.

Eingeführt wurde das, da immer noch die meisten Anwender unter administrativen Berechtigungen arbeiten und damit für Viren und Angriffen ein erhöhtes Sicherheitsrisiko darstellen. Bis Windows Vista hatten die Angreifer dadurch immer gleich die vollen Berechtigungen auf dem laufenden System.

Vorgesehen war, die administrativen Berechtigungen nur für die Installation und Konfiguration von Windows und den benötigten Anwendungen zu benutzen. Wenn man ganz normal am System arbeitet, sollte man das eigentlich als normaler Benutzer ohne administrative Berechtigungen machen. Nur wer hat sich in der Praxis schon daran gehalten?

Das UAC stellt also ein Kompromiss zu dem oben aufgeführten Konzept dar. Wenn Sie sich mit aktivem UAC als Administrator am System anmelden, arbeiten Sie mit "normalen" Benutzerrechten. Sobald eine Anwendung administrative Berechtigungen für die Ausführung benötigt, wird ein Dialogfeld angezeigt, welches extra zu bestätigen ist, damit für eine Anwendung die entsprechenden Berechtigungen gewährt werden.

Zur schnellen Sicherheits-Einschätzung benutzt Windows in der Benutzerkontensteuerung eine farbkodierte Fensterleiste:

  • blaugrüne Fensterleiste:
    Die "sicherste" Kennzeichnung, die anzeigt, dass es sich bei dem Programm um eine von Microsoft signierte, betriebssystemnahe Applikation wie beispielsweise ein Systemsteuerungs-Addin handelt
  • graue Fensterleiste:
    signiertes Programm von einem Drittanbieter
  • gelbe Fensterleiste:
    Unsignierte Anwendung.

Dadurch können keine Anwendungen im Hintergrund mit administrativen Berechtigungen Änderungen am System vornehmen, weil eine entsprechende Bestätigung notwendig ist.

Das UAC bietet also die Sicherheit eines normalen Benutzeraccounts ohne administrative Berechtigungen. Zusätzlich können aber auch administrative Aufgaben ausgeführt werden, ohne dass eine neue Anmeldung mit einem administrativen Account notwendig wird.

Die Arbeitsweise der Benutzerkontensteuerung (UAC)

Die administrativen Benutzer bekommen zwei Security-Token zugewiesen. Standardmäßig wird mit dem Token gearbeitet, das sie als Standardbenutzer identifiziert. Sie haben also die gleichen Berechtigungen wie ein Standardbenutzer und arbeiten mit eingeschränkten Zugriffsberechtigungen. Nur durch eine explizierte Bestätigung des Anwenders kann ein Prozess auf das zweite Token des Anwenders wechseln, welches ihm volle administrative Berechtigungen gibt. Es wird also zwischen zwei Security-Token gewechselt.

Damit das sauber funktioniert, muss Windows auch erkennen, ob die Anwendung administrative Berechtigungen benötigt. Die Anwendungen werden beim Start in "Integrity Level" (siehe hierzu Tipp: Sicherheitsmechanismus "Integrity Level" (IL)) eingestuft.

Wenn eine Anwendung administrative Berechtigungen benötigt und entsprechend gekennzeichnet ist, wird das von Windows erkannt. Bei Aufruf der Anwendung wird ein Dialog zum Bestätigen eingeblendet. Wird hier die Aktion abgebrochen oder eine längere Zeit keine entsprechende Auswahl getroffen, wird die Anwendung nicht mit administrativen Berechtigungen gestartet. Die Windows-Anwendungen, welche administrative Berechtigungen benötigen, können Sie meist auch schon am Symbol erkennen. Hier finden Sie im Symbol ein buntes Schild.

Dabei stellen ältere Anwendungen ein Problem dar, die nicht für UAC entwickelt wurden. Wenn solch eine ältere Anwendung gestartet wird, fehlt diese Information (welche im sogenannten "Application Manifest" gespeichert werden).

Diese Anwendungen werden weiterhin ausgeführt, aber nicht mit administrativen Berechtigungen gestartet. Greift die Anwendung aber auf systemkritische Bereiche (Registry, Systemdateien) zu, dann werden die Veränderungen in einem Virtualisierten-Bereich ausgeführt. Dabei werden diese Änderungen nur im Benutzerbereich gespeichert und nicht im Windows-System ausgeführt. So hat eine Änderung im Virtualisierten-Bereich von "HKEY_LOCAL_MACHINE\ …" keinen Einfluss auf das Windows System.

Wenn diese Anwendungen auch mit echten administrativen Berechtigungen ausgeführt werden sollen, müssen Sie die Anwendungen über "Als Administrator ausführen" starten.

Klicken Sie dazu die Anwendung mit der rechten Maustaste an und wählen aus dem Kontextmenü den Eintrag "Als Administrator ausführen". Wenn Sie das immer bei dieser Anwendung machen wollen, können Sie auch aus dem Kontextmenü den Eintrag "Eigenschaften" auswählen. Hier finden Sie im Tabreiter "Kompatibilität" unter "Berechtigungsstufe" den Eintrag "Programm als ein Administrator ausführen". Wenn Sie das aktivieren, wird die Anwendung immer mit administrativen Berechtigungen gestartet. Über die Anwendungen "RunLegacyCPLElevated.exe" können ältere Anwendungen/CPL-Dateien mit administrativen Rechten gestartet werden.

Administrator-Account

Der "echte" Administrator Account wird ab Windows Vista nach der Installation automatisch gesperrt. Bei der Installation wird nach einem Namen für einen administrativen Account gefragt, der mit dem angegebenen Passwort angelegt wird. Der "echte" Administrator-Account hat eine Besonderheit, trotz aktiver UAC ist diese Funktion bei diesem Account standardmäßig nicht aktiv (kann über "Benutzerkontensteuerung: Administratorbestätigungsmodus für das integrierte Administratorkonto" aktiviert werden). Sie können den Account über das MMC-SNAP-IN "Lokale Benutzer und Gruppen" oder über die Kommandozeile mit dem folgenden Befehl aktivieren:

net user Administrator /active

Sperren können Sie das Konto wieder über:

net user Administrator /active:no

Der Account ist aus Sicherheitsgründen deaktiviert und sollte deshalb nur aktiviert werden, wenn Sie die den Account benötigen. Da der Name des Accounts bekannt ist (meist wird der Account nicht umbenannt) bietet er den Angreifern ein gern gesehenes Ziel.

Zusätzlich werden beim Erstellen neuer Benutzerkonten nur noch Standardberechtigungen vergeben. Die administrativen Berechtigungen müssen extra zugewiesen werden.

Erweiterungen der Benutzerkontensteuerung ab Windows 7

Die Benutzerkontensteuerung kann ab Windows 7 in 4 Stufen konfiguriert werden. Dazu hat Microsoft einen Schieberegler eingeführt. Sie finden diese Einstellung in Tool "MSCONFIG" unter dem Tabreiter "Tools". Hier klicken Sie auf den Eintrag "UAC Einstellungen ändern" und dann auf den Button "Starten". Sie können das "User Account Control Settings" aber auch direkt über den Befehl "%windir%\system32\UserAccountControlSettings.exe" starten.

  • Stufe 1 (Schieberegler ganz oben):

    Immer Benachrichtigen.

  • Stufe 2:

    Nur benachrichtigen, wenn Änderungen an meinem Computer vom Programmen vorgenommen werden (Standardeinstellung).

  • Stufe 3:

    Nur benachrichtigen, wenn Änderungen an meinem Computer vom Programm vorgenommen werden (Desktop nicht abblenden).

  • Stufe 4 (Schieberegler ganz unten):

    Nie benachrichtigen

Diese Einstellungen können natürlich auch wieder über die Registry verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier die Werte "ConsentPromptBehaviorAdmin" und "PromptOnSecureDesktop" als Datentyp REG_DWORD und setzen Sie die Werte je nach gewünschter Stufe:

Stufe | ConsentPromptBehaviorAdmin | PromptOnSecureDesktop
1 | 2 | 1
2 | 5 | 1
3 | 5 | 0
4 | 0 | 0

Siehe dazu auch die Links unter "Konfiguration der Benutzerkontensteuerung" in diesem Artikel.

Konfiguration der Benutzerkontensteuerung

Die Benutzerkontensteuerung kann über die Gruppenrichtlinien oder lokalen Systemrichtlinien konfiguriert werden. Die Einstellungen finden Sie dort unter: "Computerkonfiguration" -> "Windows-Einstellungen" -> "Sicherheitseinstellungen" -> "Lokale Richtlinien" -> "Sicherheitsoptionen".

Hier finden Sie folgende Einträge:

  • Benutzerkontensteuerung: Administratorbestätigungsmodus für das integrierte Administratorkonto
  • Benutzerkontensteuerung: Alle Administratoren im Administratorbestätigungsmodus ausführen
  • Benutzerkontensteuerung: Anwendungsinstallationen erkennen und erhöhte Rechte anfordern
  • Benutzerkontensteuerung: Bei Benutzeraufforderung nach erhöhten Rechten zum sicheren Desktop wechseln
  • Benutzerkontensteuerung: Datei- und Registrierungsschreibfehler an Einzelbenutzerstandorte virtualisieren
  • Benutzerkontensteuerung: Nur ausführbare Dateien heraufstufen, die signiert und validiert sind
  • Benutzerkontensteuerung: Nur erhöhte Rechte für UIAccess-Anwendungen, die an sicheren Orten installiert sind
  • Benutzerkontensteuerung: Verhalten der Anhebungsaufforderung für Standardbenutzer
  • Benutzerkontensteuerung: Verhalten der Benutzeraufforderung mit erhöhten Rechten für Administratoren im Administratorbestätigungsmodus.
  • Benutzerkontensteuerung (UAC) für bestimmte Anwendungen deaktivieren
  • Benutzerkontensteuerung: Zugriff auf Netzwerklaufwerke mit erweiterten Rechten "Elevated" nicht möglich

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2526.htm


Benutzerkontensteuerung für die Softwareinstallation konfigurieren

Mit diesem Tipp können Sie einstellen, ob die Benutzerkontensteuerung (UAC) eine Softwareinstallation erkennen soll und die benötigten rechte zu verfügung stellen.

Windows versucht selbständig zu erkennen, ob eine Softwareinstallation "administrative" Rechte benötigt. Ist das der Fall, wird nach Bestätigung der Nachfrage das Setup mit den entsprechenden Rechten ausgestattet. Mit diesem Tipp können Sie diese automatische Erkennung ausschalten. Bei Anwendern mit administrativen Rechten wird die Installation dann immer mit solchen administrativen Rechten gestartet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableInstallerDetection" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Automatische Erkennung ausschalten
1 | Automatische Erkennung aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Anwendungsinstallationen erkennen und erhöhte Rechte anfordern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2215.htm


Benutzerkontensteuerung für Standardbenutzer ausschalten

Benutzerkontensteuerung (UAC) für Standardbenutzer ausschalten

Mit diesem Tipp können Sie auch Standardbenutzer von den Nachfragen und Bestätigungen der Benutzerkontensteuerung (UAC) ausschließen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "ConsentPromptBehaviorUser" als Datentyp REG_DWORD und setzen den Wert auf:

0

Keine Aufforderungen mehr

Werden höhere Rechte benötigt, erscheint keine Rückfrage, es werden aber auch keine höhere Rechte erteilt.

Der Anwendung werden also die höheren Rechte verweigert. Das kann dazu führen, dass diese Anwendung dann natürlich nicht mehr läuft.
1

Aufforderung mit Eingabe der Anmeldeinformationen (Standard)

Werden erweiterte Rechte benötigt, muss der Anwender das Administratorkennwort eingeben.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Verhalten der Anhebungsaufforderung für Standardbenutzer

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2216.htm


Benutzerkontensteuerung für Adminstratoren ausschalten

Mit diesem Tipp können Sie die Anwender aus der Administratorengruppe von den Nachfragen und Bestätigungen der Benutzerkontensteuerung (UAC) ausschließen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "ConsentPromptBehaviorAdmin" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Keine Aufforderungen mehr Hiermit werden die Sicherheitshinweise vollständig unterdrückt und die Bestätigung für höhere Rechte wird automatisch erteilt.
1 | Aufforderung mit Eingabe der Anmeldeinformationen Hier muss nicht nur die Anfrage nach höheren Rechten bestätigt , sondern es muss auch noch das Passwort eingegeben werden.
2 | Aufforderung mit einfacher Zustimmung (Standard) Hier muss nur eine einfach Zustimmung per Klick auf einen Button gegeben werden.
5 | Ab Windows 7: Nur benachrichtigen, wenn Änderungen an meinem Computer vom Programmen vorgenommen werden.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Verhalten der Benutzeraufforderung mit erhöhten Rechten für Administratoren im Administratorbestätigungsmodus

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Siehe auch

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2217.htm


Benutzerkontensteuerung für den integrierten Administrator

Benutzerkontensteuerung für den integrierten Administrator-Account

Mit diesem Tipp ändern Sie die Konfiguration des integrierten Administrator-Accounts. Bei der Installation von Windows wird automatisch ein Account mit den Namen „Administrator“ angelegt und deaktiviert, so dass man sich mit diesem Account nicht anmelden kann. Dieser Account wurde von Windows für das Setup benötigt. Sie können diesen Account über die Windows Benutzerverwaltung wieder aktivieren und sich anschließend mit diesem Account am System anmelden. Dabei verhält sich dieser Account etwas anderes, als alle anderen Benutzerkonten mit administrativen Berechtigungen, die von Ihnen angelegt wurden. Denn auch wenn die Benutzerkontensteuerung (UAC) im System aktiviert ist, wird die nicht bei diesem Account benutzt.

Wenn Sie den Tipp aktivieren, dann wird auch bei diesem Account die Benutzerkontensteuerung verwendet. Wird also ein Vorgang ausgeführt, der erhöhte Rechte erfordert, erscheint eine entsprechende Dialogbox, die bestätigt werden muss.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren (der Eintrag wird nicht in der Registry angelegt), wird der integrierte Administrator-Account im XP-kompatiblen Modus angemeldet. Jetzt wird keine zusätzliche Dialogbox mehr angezeigt, die extra bestätigt werden muss.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "FilterAdministratorToken" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ohne Benutzerkontensteuerung (Standard)
1 | Mit Benutzerkontensteuerung

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Administratorbestätigungsmodus für das integrierte Administratorkonto

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2527.htm


Benutzerkontensteuerung nur für Dateien die signiert sind ausführen

Benutzerkontensteuerung nur für Dateien ausführen, die signiert sind

Mit diesem Tipp können Sie einstellen, ob über die Benutzerkontensteuerung (UAC) nur signierte Dateien beachtet werden sollen. Ist der Tipp aktiviert, werden PKI-Signaturüberprüfungen für interaktive Anwendungen erzwungen, die erhöhte Rechte erfordern.

Administratoren in Unternehmen können die Liste der vom Administrator zugelassene Anwendungen durch das Auffüllen von Zertifikaten im Speicher für vertrauenswürdige Herausgeber auf lokalen Computern steuern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "ValidateAdminCodeSignatures" als Datentyp REG_DWORD und setzen den Wert auf:

0 | PKI-Sginierung ist nicht erforderlich (Standard)
1 | Datei muss Signiert sein

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Nur ausführbare Dateien heraufstufen, die signiert und validiert sind

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2528.htm


Benutzerkontensteuerung nur für UIAccess-Anwendungen, die an sicheren Orten installiert sind

Mit diesem Tipp können Sie einstellen, dass sich Anwendungen, die eine Ausführung mit einer UIAccess-Integritätsebene anfordern (über das Kennzeichnen von UIAccess = true in Ihrem Anwendungsmanifest), an einem sicheren Speicherort im Dateisystem befinden müssen.

Sichere Speicherorte sind auf die folgenden Verzeichnisse begrenzt:

  • …\Programme\, einschließlich Unterverzeichnissen
  • …\Windows\system32\
  • …\Programme (x86)\, einschließlich Unterverzeichnissen für 64-Bit-Versionen von Windows

Info Von Windows wird unabhängig vom Status dieser Sicherheitseinstellung eine PKI-Signaturüberprüfung für jede interaktive Anwendung erzwungen, die eine Ausführung mit einer UIAccess-Integritätsebene anfordert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableSecureUIAPaths" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eine Anwendung wird auch dann mit UIAccess-Integrität gestartet, wenn sie sich nicht an einem sicheren Speicherort im Dateisystem befindet
1 | Eine Anwendung wird nur mit UIAccess-Integrität gestartet, wenn sie sich an einem sicheren Speicherort im Dateisystem befindet. (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Nur erhöhte Rechte für UIAccess-Anwendungen, die an sicheren Orten installiert sind

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2529.htm


Benutzerkontensteuerung: Zugriffe auf geschützte Speicherorte umleiten

Mit diesem Tipp können Sie einstellen, dass bei Zugriffen von Legacyanwendungen auf geschützte Speicherbereiche (Dateisystem oder Registry) diese auf einen anderen Bereich umgeleitet werden.

Mit diesem Feature werden die Anwendungen aufgefangen, die in der Vergangenheit unter dem Administratorkonto ausgeführt wurden und Einstellungen zurückgeschrieben haben in "%Programme%, %Windir%, %Windir%\system32" oder "HKLM\Software\...".

Durch die Virtualisierung wird das Ausführen von Legacyanwendungen vor Vista vereinfacht, die in der Vergangenheit nicht als Standardbenutzer ausgeführt werden konnten. Ein Administrator, der nur Windows Vista-kompatible Anwendungen ausführt, kann dieses Funktion deaktivieren, da es dort nicht erforderlich ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableVirtualization" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Für Anwendungen, die Daten in geschützte Speicherorte schreiben, wird wie in vorherigen Windows-Versionen auch ein Fehler zurückgegeben.
1 | Zugriffe auf geschützte Speicherbereiche werden umgeleitet. (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Sicherheitsoptionen
Einstellungsname: | Benutzerkontensteuerung: Datei- und Registrierungsschreibfehler an Einzelbenutzerstandorte virtualisieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2530.htm


Benutzerkontensteuerung (UAC) für bestimmte Anwendungen deaktivieren

Durch die Einführung der Benutzerkontensteuerung (UAC) soll die Sicherheit erhöht werden, wenn Anwender mit administrativen Berechtigungen arbeiten. Wenn Sie eine Anwendung starten, die administrative Berechtigung benötigt, müssen Sie erst eine Dialogbox bestätigen, bevor diese Anwendung gestartet wird.

Wenn Sie nicht gleich die Benutzerkontensteuerung komplett deaktivieren wollen, aber bestimmte Anwendungen öfter benutzen, die Administrative-Berechtigungen benötigen, (wie z.B.: Visual Studio oder Defragmentierungsprogramme usw.) können Sie das mit einem Tool von Microsoft "Microsoft Application Compatibility Toolkits" konfigurieren.

Laden Sie sich das Tool "Microsoft Application Compatibility Toolkits" runter <Download> (Größe ca.: 11 MByte)

Installieren Sie das Programm auf Ihrem Rechner. Starten Sie jetzt aus dem Startmenü im Ordner "Microsoft Application Compatibility Toolkits" den Eintrag "Compatibility Administrator" mittels rechter Maustaste, und wählen Sie "Als Administrator ausführen" (das müssen Sie nur machen, wenn Sie mit aktiven UAC arbeiten).

Application Compatibility Toolkits

Starten Sie - wie oben gezeigt - über das Kontextmenü oder über das Menü "Database" -> "Create New" -> "Application Fix..." den Assistenten zur Konfiguration eines neuen Applikation Fix.

Create new Application Fix - Step 1

Im ersten Schritt werden Sie nach den Namen der Anwendung, dem Hersteller gefragt. Mit dem Button "Browse" müssen Sie noch das entsprechende Programm auswählen. Im Beispiel ist das für den Registry System Wizard gemacht, Sie können hier aber auch jedes andere Programm verwenden. Drücken Sie nach der Eingabe der Daten auf "Weiter >".

Create new Application Fix - Step 2

Jetzt werden Sie gefragt, welches Betriebssystem simuliert werden soll. Da es bei uns aber nur darum geht, die Nachfrage der Benutzerkontensteuerung auszuschalten, wählen Sie hier "None" aus und klicken dann auf "Weiter >"

Create new Application Fix - Step 3

Auf der nächsten Seiten finden wie etliche Einstellungen, die man der Anwendung mitgeben kann. Hier suchen Sie die Einstellung "RunAsInvoker" und aktivieren diesen Eintrag, um die Benutzerkontensteuerung auszuschalten. Über den Button "Test Run..." können Sie prüfen, ob die Änderungen entsprechend funktionieren und das Programm gestartet wird. Wenn Sie fertig sind, klicken Sie auf den Button "Weiter >".

Create new Application Fix - Step 4

Hier werden die Kriterien festgelegt wie das Programm eindeutig identifiziert werden kann. Dazu werden Parameter wie CHECKSUM, BIN_FILE_VERSION usw. verwendet. Das bedeutet natürlich auch, dass nach einen Update diese Einstellungen entsprechend geändert werden müssen. Sie können hier natürlich auch Werte entfernen, welche sich bei einem Update ändern und nur die festen Werte bestehen lassen. Bedenken Sie dabei aber auch, dass sich dadurch die Möglichkeit ergibt,durch Austauschen der EXE-Datei ein anderes Programm ohne Nachfrage als Administrator zu starten.

In den meisten Fällen sollten Sie deshalb die voreingestellten Werte belassen und über den Button "Fertig stellen" den Eintrag in der Datenbank speichern.

Create new Application Fix - Step 5

Jetzt müssen Sie die Datenbank noch über "Save" speichern. Dazu werden Sie nach den Namen der Datenbank gefragt (hier wurde Registry System Wizard genommen). Da Sie in einer Datenbank mehrere Anwendungen hinzufügen können, sollten Sie einen neutralen Namen verwenden. Weiterhin müssen Sie noch den Pfad und den Namen der Datenbank für die Datei eingeben, die mit der Dateiendung .SDB abgespeichert wird.

Create new Application Fix - Step 6

Nun ist diese Konfiguration selber in Vista noch nicht aktiv und muss erst einmal in Vista importiert werden.

Dafür müssen Sie eine Kommandozeilenoberfläche mit administrativen Berechtigungen öffnen und folgenden Befehl eingeben:

sdbinst [Verzeichnis\Dateiname]

Beispiel: sdbinst d:\rsw-konfiguration.sdb

Create new Application Fix - Step 7

Info Oder im Explorer mit der rechten Maustaste auf die Datei klicken und aus dem Kontextmenü den Eintrag "Install" aufrufen.

Wenn Sie jetzt die Anwendungen aus der Datenbank starten, kommt keine Nachfrage mehr vom UAC, ob die Anwendung mit administrativen Berechtigungen ausgeführt werden darf.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=946932

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2534.htm


Benutzerkontensteuerung: Zugriff auf Netzwerklaufwerke mit erweiterten Rechten "Elevated" nicht möglich

Mit diesem Tipp können Sie einstellen, ob die Benutzerkontensteuerung (UAC) die verbundenen Laufwerke auch den administrativen Rechten zur Verfügung stellt.

Wenn die Benutzerkontensteuerung aktiv ist und man sich als Administrator anmeldet, arbeitet man technisch gesehen mit zwei Benutzer-Token. Der hauptsächliche aktive Benutzertoken arbeitet mit eingeschränkten Rechten und schaltet bei Bedarf, nach der Bestätigung des Anwenders, auf den Token mit den administrativen vollen Berechtigungen um.

Die Laufwerksverbindungen werden (z.B. bei der Anmeldung) mit den reduzierten Token durchgeführt. Wird nur eine Anwendung ausgeführt, die administrative Berechtigungen benötigt (z.B. ein Setup usw.), dann wird dafür eine neue Session mit dem anderen Benutzertoken (der mit den administrativen Berechtigungen) geöffnet. Dadurch sind die Laufwerksverbindungen, welche mit dem eingeschränkten Benutzertoken erstellt wurden, in dieser neuen Session nicht sichtbar.

Wenn Sie z.B. ein Setup über das Netzwerk starten, kann es nach der UAC-Abfragen zu den folgenden Fehler kommen: "Das Installationsprogramm hat einen Fehler festgestellt: 0x8007003. Das System kann den angegeben Pfad nicht finden."

Umgehen kann man diesen Fehler auch, indem man mit UNC-Pfaden und nicht mit Laufwerksbuchstaben arbeitet. Das wird aber nicht von allen Programm unterstützt.

Um das zu vermeiden, müssen Sie den Eintrag "EnableLinkedConnections" in der Registry aktivieren. Dadurch werden die Netzwerkverbindungen des Benutzertoken- mit reduzierten Rechten -, auf den zweiten Benutzertoken - mit den erweiterten Rechten - übertragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ System

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableLinkedConnections" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Netzwerkverbindungen werden nicht übernommen (Standard)
1 | Netzwerkverbindungen stehen auch im administrativen Kontext zur Verfügung

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=937624

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2563.htm


Gruppenrichtlinien als ADMX-Dateien

Ab Windows Vista hat Microsoft die ADM-Dateien (siehe Tipp: Erstellen einer eigenen ADM - Datei) für die Gruppenrichtlinien durch ADMX-Dateien ersetzt. Die ADM-Dateien für Gruppenrichtlinien, die ab Windows NT eingeführt wurden, hatten einen textbasierten Aufbau, welcher jetzt auf ein XML-basiertes Format umgestellt wurde.

Gleichzeitig wurden die Gruppenrichtliniendateien in sprachneutrale (.admx-Dateien), welche im Verzeichnis "%systemroot%\PolicyDefinitions" abgelegt werden, sprachspezifisch aufgeteilt - zu finden unter "%systemroot%\PolicyDefinitions\[Sprachkürzel]" (z.B: für Deutsch "%systemroot%\PolicyDefinitions\de-DE"). Auch wurden die großen Gruppenrichtlinien in mehrere kleine Dateien aufgeteilt, so dass mit Windows Vista ca. 130-ADMX-Dateien ausgeliefert werden.

Dass Microsoft noch mehr auf die Gruppenrichtlinien gehen will, sieht man daran, dass die Gruppenrichtlinien-Verwaltungskonsole (GPMC.MSC), die früher noch als zusätzlicher Download geladen werden musste, jetzt mit Windows Vistagemeinsam ausgeliefert wird.

Die alten ADM-Dateien können weiterhin verwendet werden. Sie werden auch weiter im Verzeichnis "%systemroot%\inf" gespeichert. Hier können die alten angepassten ADM-Dateien abgelegt werden und werden in Gruppenrichtlinieneditor (GPEDIT.MSC) auch angezeigt. Diese Einstellungen werden im neuen Gruppenrichtlinieneditor im Unterordner "Klassische Administrative Vorlagen (ADM)" aufgelistet. Dabei werden die durch ADMX-Dateien ersetzten ADM-Dateien nicht mehr angezeigt. Dabei handelt es sich z.B. um die Dateien SYSTEM.ADM, CONF.ADM, WUAU:ADM, INETRES.ADM usw. Anpassungen in diesen Dateien werden ignoriert und müssen in den neuen ADMX-Dateien durchgeführt werden.

In einer Windows-Domäne können die ADMX-Dateien auch über eine zentrale Stelle verwaltet werden. Die Dateien werden vom Gruppenrichtlinieneditor aus dem SYSVOL-Ordner (%systemroot%\sysvol\domain\policies\PolicyDefinitions) eines Domänencontrollers gelesen. Nur wenn dieser Speicherort nicht verfügbar ist, werden die lokal gespeicherten Dateien verwendet.

Der zentrale Speicherort lässt sich nicht konfigurieren. Das Ablegen der Datei im SYSVOL kann auch schon auf einen Windows 2000 Server gemacht werden, und somit kann diese Funktion auch schon jetzt benutzt werden. Die neuen ADMX-Dateien können aber nur von Windows Vista genutzt werden.

Übersicht der Speicherorte von Gruppenrichtlinien:

Gruppenrichtliniendatei | Speicherort
AMD-Dateien | %systemroot%\inf
ADMX-Dateien (lokal) | %systemroot%\policyDefinitions
ADML-Dateien (lokal) | %systemroot%\policyDefinitions\[Sprachkürzel]
ADMX-Dateien (Domäne) | %systemroot%\sysvol\domain\policies\PolicyDefinitions
ADML-Dateien (Domäne) | %systemroot%\sysvol\domain\policies\PolicyDefinitions\[Sprachkürzel]

Einstellungen werden in den Gruppenrichtlinen vorgenommen mit:

lokale Gruppenrichtlinien: GPEDIT.MSC

Domänen Gruppenrichtlinien: GPMC.MSC

Aufbau der neuen ADMX-Dateien

Wer schon mit den alten ADM-Dateien gearbeitet hat, wird mit dem neuen Format schnell zurechtkommen. Wichtig ist, dass man sich an die Trennung von sprachunabhängigen und sprachabhängigen Bestandteilen hält. Am Einfachsten lassen sich ADMX-Dateien mit dem Tool "ADMX-Migrator" (Link siehe unten) bauen und bearbeiten.

Sprachunabhängiger Teil:

Anhand der Datei "AddRemovePrograms.admx" wird der grundlegende neue Aufbau der ADMX-Dateien beschrieben.

Der Kopf (Header) jeder ADMX-Datei hat immer den gleichen Aufbau. Hier wird der allgemeine Namespaces für die Richtliniendateien festgelegt:

<?xml version="1.0" encoding="utf-8"?>

<!-- (c) 2006 Microsoft Corporation -->

<policyDefinitions xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" revision="1.0" schemaVersion="1.0" xmlns="http://schemas.microsoft.com/GroupPolicy/2006/07/PolicyDefinitions">

Im zweiten Teil werden die Präfixe der spezifischen Namespaces festgelegt:

<policyNamespaces>

<target prefix="addremoveprograms" namespace="Microsoft.Policies.AddRemovePrograms" />

<using prefix="windows" namespace="Microsoft.Policies.Windows" />

</policyNamespaces>

Wenn Sie eine eigene ADMX-Datei erstellen, müssen Sie sich einen neuen Namespace erstellen.

Dazu tauschen Sie die Zeile "<target prefix="addremoveprograms" namespace="Microsoft.Policies.AddRemovePrograms" />" durch folgenden Eintrag aus: "<target prefix="winfaq" namespace="winfaq.Policies.[UID/Name]" />".

Für [UID/Name] tragen Sie eine eindeutigen Namen ein (z.B.: 5B9B8C06_291A_4772_8D7A_9ECA8318C51F).

Anschließend wird die Version festgelegt. Diese Version wird überprüft, um zu erkennen, ob diese Richtlinie überhaupt verarbeitet werden kann. Die aktuelle Windows Vista Version fängt mit der Nummer 1.0 an. Bei späteren Erweiterungen der ADMX-Spezifikation wird sich diese Nummer entsprechend erhöhen:

<resources minRequiredRevision="1.0" />

In dem nächsten Bereich werden die Kategorien der Gruppenrichtlinien festgelegt, unter dem die einzelnen Einträge angezeigt werden sollen. Hier wird auch über „$(string.Arp)“ auf einen sprachspezifischen Teil der Richtlinien verwiesen (siehe unten „Sprachabhängiger Teil“), welcher in der Datei "AddRemovePrograms.adml" abgelegt wird.

<categories>

<category name="Arp" displayName="$(string.Arp)">

<parentCategory ref="windows:ControlPanel" />

</category>

</categories>

Der Eintrag "parentCategory" legt die übergeordnete Kategorie fest, wo dieser Eintrag zusätzlich eingefügt wird. Im unteren Bild sehen Sie, wo diese Einträge in GPEdit und im ADMX-Migrator angezeigt werden.

ADMX Policy Einträge

Hier kann mehr als eine Kategorie angelegt werden. Die einzelnen Kategorien werden durch den Tag<category name="[Name]" displayName="$(string.[Name])"> und </category> eingeschlossen.

Jetzt kommt der Hauptteil der Gruppenrichtlinien, wo die einzelnen Tipps/Einstellungen festgelegt werden.

<policies>

<policy name="DefaultCategory" class="User" displayName="$(string.DefaultCategory)" explainText="$(string.DefaultCategory_Help)" presentation="$(presentation.DefaultCategory)" key="Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall">

<parentCategory ref="Arp" />

<supportedOn ref="windows:SUPPORTED_WindowsPreVista" />

<elements>

<text id="DefaultCategoryBox" valueName="DefaultCategory" required="true" />

</elements>

</policy>

[Weitere Einträge…]

</policies>

Innerhalb des Tags <policies>… </policies> können Sie beliebig viele Einträge hinzufügen. Jeder Eintrag wird über die Tags <policy> und </policy> eingeschlossen.

Es gibt jeweils verschieden Anzeigemöglichkeiten, wie die Tipps im Gruppenrichtlinieneditor angezeigt werden. Diese Darstellungen werden hier kurz beschrieben. Vorab werden die Parameter gezeigt, die bei jedem Eintrag vorkommen.

policy name= | Legt den internen Namen für diesen Tipp in der ADMX-Datei fest
class=

Legt fest im welchen Bereich der Tipp angezeigt werden soll.

Dabei sind folgende Werte möglich:

User -> Der Tipp wird unter "Benutzerkonfiguration" angezeigt (HKCU)

Computer -> Der Tipp wird unter "Computerkonfiguration" angezeigt (HKLM)
displayName= | Legt den Anzeigenamen in der Gruppenpolicy fest
explainText= | Legt den Beschreibungstext für den Tipp fest
key= | Legt den Pfad in der Registry zum Eintrag fest
Optional:
valueName=

Legt den Namen des Schlüssels fest der geändert/gesetzt werden soll.

Bei einigen Anzeigearten (siehe weiter unten, wird dieser Wert nicht angegeben).
<parentCategory ref="[Name]" />

Hier wird die Kategorie festgelegt unter dem der Tipp angezeigt werden soll.

Die möglichen Einträge werden wie oben beschrieben unter "<categories>" konfiguriert.
<supportedOn ref="windows:SUPPORTED_WindowsPreVista" />

Legt das Betriebssystem fest für die der Tipp gültig ist. Hier Beispiele für mögliche Werte:

  • SUPPORTED_Win2k
  • SUPPORTED_Win2kOnly
  • SUPPORTED_Win2kSP1
  • SUPPORTED_Win2kSP3
  • SUPPORTED_WindowsXP
  • SUPPORTED_WindowsXPOnly
  • SUPPORTED_WindowsXPOrServerOnly
  • SUPPORTED_WindowsXPSP2
  • SUPPORTED_WindowsXPSP2_Or_WindowsNET
  • SUPPORTED_WindowsXPSP2_Or_WindowsNETSP1
  • SUPPORTED_WindowsXP_SP2_W2K_SP5_NETSERVER_SP1
  • SUPPORTED_WindowsXPWindowsNETorBITS15"
  • SUPPORTED_WindowsXPSP2WindowsNETSP1orBITS20
  • SUPPORTED_WindowsPreVista
  • SUPPORTED_WindowsVista
  • SUPPORTED_WindowsNET_XP
  • SUPPORTED_NetMeeting3
  • SUPPORTED_IE4ONLY
  • SUPPORTED_IE5
  • SUPPORTED_IE5_NONVISTA
  • SUPPORTED_IE5_6
  • SUPPORTED_IE6SRVSP1
  • SUPPORTED_IE6SRVSP1ONLY
  • SUPPORTED_IE6SRVSP1_NONVISTA
  • SUPPORTED_IE6SP2
  • SUPPORTED_IE6ONLY
  • SUPPORTED_IE7
  • SUPPORTED_IE7Vista
  • SUPPORTED_IE7_NONVISTA

Eintrag zum aktivieren/deaktivieren

<policy name="NoAddFromCDorFloppy" class="User" displayName="$(string.NoAddFromCDorFloppy)" explainText="$(string.NoAddFromCDorFloppy_Help)" key="Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall" valueName="NoAddFromCDorFloppy">

<parentCategory ref="Arp" />

<supportedOn ref="windows:SUPPORTED_WindowsPreVista" />

</policy>

Die hier benutzten Einträge wurden oben schon beschrieben. Dieses ist die am meisten benutzte Konfiguration und bietet die einfache Möglichkeit, einen Eintrag zu aktivieren/deaktivieren. In der nächsten erweiterten Form werden noch die Werte angegeben, die in jeweiligen Zustand in die Registry geschrieben werden sollen:

<policy name="NoMyComputerIcon" class="User" displayName="$(string.NoMyComputerIcon)" explainText="$(string.NoMyComputerIcon_Help)" key="Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum" valueName="{20D04FE0-3AEA-1069-A2D8-08002B30309D}">

<parentCategory ref="windows:Desktop" />

<supportedOn ref="windows:SUPPORTED_WindowsXP" />

<enabledValue>

<decimal value="1" />

</enabledValue>

<disabledValue>

<decimal value="0" />

</disabledValue>

</policy>

Eintrag mit Texteingabe

<policies>

<policy name="DefaultCategory" class="User" displayName="$(string.DefaultCategory)" explainText="$(string.DefaultCategory_Help)" presentation="$(presentation.DefaultCategory)" key="Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall">

<parentCategory ref="Arp" />

<supportedOn ref="windows:SUPPORTED_WindowsPreVista" />

<elements>

<text id="DefaultCategoryBox" valueName="DefaultCategory" required="true" />

</elements>

</policy>

[Weitere Einträge…]

</policies>

Bei dieser Art von Policy wird der Eintrag ValueName nicht in der oberen Konfiguration angegeben. Die möglichen Elemente innerhalb der unteren Box werden im Bereich <elements> abgelegt. Für eine Eingabebox wird dafür folgender Eintrag verwendet:

text id= | Legt den internen Namen für diesen Tipp in der ADMX-Datei fest
valueName= | Legt den Namen des Schlüssels fest der geändert/gesetzt werden soll
required= | Legt fest ob dieser Eintrag bei der Eingabe gefüllt werden muss. Die möglichen Wert sind: true -> Eingabe erforderlich false -> Wert kann leer bleiben.

Auswahlbox

<policy name="LockUserUILanguage" class="User" displayName="$(string.LockUserUILanguage)" explainText="$(string.LockUserUILanguage_Help)" presentation="$(presentation.LockUserUILanguage)" key="Software\Policies\Microsoft\Control Panel\Desktop">

<parentCategory ref="RegionalOptions" />

<supportedOn ref="windows:SUPPORTED_WindowsVista" />

<elements>

<enum id="UILangSelect" valueName="PreferredUILanguages" required="true">

<item displayName="$(string.UILang1)">

<value>

<string>en-US</string>

</value>

</item>

[Für jede weitere Auswahlmöglichkeit jeweils ein <item> Eintrag hinzufügen]

</enum>

</elements>

</policy>

Bei diesem Tipp werden dem Anwender bestimmte Möglichkeiten zur Auswahl vorgegeben. In Beispiel wird nur ein Eintrag angegeben, durch weitere Blöcke können Sie diese Liste erweitern.

enum id= | Legt fest, dass es sich um eine Listbox handelt. Hier wird der interne Name im ADMX-File angegeben
valueName= | Legt den Namen des Schlüssels fest, der geändert/gesetzt werden soll
required= | Legt fest ob dieser Eintrag bei der Eingabe gefüllt werden muss. Die möglichen Wert sind: true -> Eingabe erforderlich false -> Wert kann leer bleiben.
item displayName= | Für jede mögliche Auswahl ein Eintrag. Hier wird der Test angegeben, der zur Auswahl angezeigt werden soll.
<value></value> | Dazwischen wird der Wert festgelegt, der bei der Auswahl gesetzt werden soll.
<string>[Text]</string> | Hier wird der Wert angegeben, der bei der Auswahl in der Registry eingetragen wird.

Zahlenwerte

<policy name="AD_QueryLimit" class="User" displayName="$(string.AD_QueryLimit)" explainText="$(string.AD_QueryLimit_Help)" presentation="$(presentation.AD_QueryLimit)" key="Software\Policies\Microsoft\Windows\Directory UI">

<parentCategory ref="ActiveDirectory" />

<supportedOn ref="windows:SUPPORTED_Win2k" />

<elements>

<decimal id="AD_QueryLimit_Box" valueName="QueryLimit" required="true" maxValue="4000000000" />

</elements>

</policy>

Erstellt eine Textbox für die Zahleneingabe. Es werden nur Zahlenwerte in dieser Box zugelassen. Weiterhin kann ein minimaler und maximaler Wert festgelegt werden.

decimal id= | Legt fest das es sich um eine Zahlenbox handelt. Hier wird der interne Name im ADMX-File angegeben
valueName= | Legt den Namen des Schlüssels fest der geändert/gesetzt werden soll
required= | Legt fest ob dieser Eintrag bei der Eingabe gefüllt werden muss. Die möglichen Wert sind: true -> Eingabe erforderlich false -> Wert kann leer bleiben.
Optional: minValue= | Legt den minimalen Wert fest
Optional: maxValue= | Legt den maximalen Wert fest

Checkbox

<policy name="LimitSize" class="User" displayName="$(string.LimitSize)" explainText="$(string.LimitSize_Help)" presentation="$(presentation.LimitSize)" key="Software\Microsoft\Windows\CurrentVersion\Policies\System" valueName="EnableProfileQuota">

<parentCategory ref="UserProfiles" />

<supportedOn ref="windows:SUPPORTED_Win2k" />

<elements>

<text id="SizeMessage" valueName="ProfileQuotaMessage" />

<decimal id="ProfileSize" valueName="MaxProfileSize" required="true" minValue="300" maxValue="30000000" />

<boolean id="IncludeRegInProQuota" valueName="IncludeRegInProQuota" />

<boolean id="WarnUser" valueName="WarnUser" />

<decimal id="WarnUserTimeout" valueName="WarnUserTimeout" required="true" />

</elements>

</policy>

Diesen Beispiel enthält nicht nur Checkboxen sondern auch ein paar anderen Elemente die schon weiter oben beschrieben wurden. Es wird hier gezeigt wie die unterschiedlichen Elemente kombiniert werden können.

boolean id= | Legt fest, dass es sich um eine Checkbox handelt. Hier wird der interne Name im ADMX-File angegeben
valueName= | Legt den Namen des Schlüssels fest, der geändert/gesetzt werden soll

Listwerte

<policy name="Pol_AssignedOfflineFiles_1" clientExtension="{C631DF4C-088F-4156-B058-4375F0853CD8}" class="User" displayName="$(string.Pol_AssignedOfflineFiles)" explainText="$(string.Pol_AssignedOfflineFiles_Help)" presentation="$(presentation.Pol_AssignedOfflineFiles_1)" key="Software\Policies\Microsoft\Windows\NetCache">

<parentCategory ref="Cat_OfflineFiles" />

<supportedOn ref="windows:SUPPORTED_Win2k" />

<elements>

<list id="Lbl_AssignedOfflineFilesList" key="Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders" additive="true" explicitValue="true" />

</elements>

</policy>

<elements>

<list id="DisallowAppsList" key="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun" valuePrefix="" />

</elements>

list id= | Legt fest, dass es sich um eine Listbox handelt. Hier wird der interne Name im ADMX-File angegeben
key= | Legt den Pfad in der Registry zum Eintrag fest
additive=

Ist der Wert "True", werden die vorhandenen Unterschlüssel nicht gelöscht und die Einträge werden hinzugefügt.

Ist der Wert auf "False", werden die vorhandenen Unterschlüssel gelöscht.
explicitValue=

Ist der Wert "True", wird eine Tabelle mit zwei Spalten angezeigt. Der Anwender muss den Schlüsselnamen und den Wert eingeben.

Ist der Wert "False", muss der Anwender nur den Wert eingeben, der Schlüsselname wird automatisch gebildet.
valuePrefix="" | Legt den Präfix für den Registryeintrag fest, der entsprechend hochgezählt wird.

Abschluss der XML-Datei:

</policyDefinitions>

Sprachabhängiger Teil:

Hier wird die Datei "AddRemovePrograms.adml" als Beispiel für eine entsprechende Beschreibung verwendet.

Der Kopf (Header) jeder ADML-Datei hat immer den gleichen Aufbau wie die ADMX-Datei. Hier wird der allgemeine Namespaces für die Richtliniendateien festgelegt:

<?xml version="1.0" encoding="utf-8"?> <!-- (c) 2006 Microsoft Corporation -->

<policyDefinitionResources xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" revision="1.0" schemaVersion="1.0" xmlns="http://schemas.microsoft.com/GroupPolicy/2006/07/PolicyDefinitions">

<displayName>Anzeigenamen hier eingeben</displayName>

<description>Beschreibung hier eingeben</description>

Sprachtexte in der String-Tabelle:

<resources>

<stringTable>

<string id="Arp">Software</string> <string id="DefaultCategory">Standardkategorie für "Neue Programme hinzufügen" festlegen</string>

[weitere Einträge….]

</stringTable>

Sprachdateien in der Presentation-Tabelle:

<presentationTable>

<presentation id="DefaultCategory">

<textBox refId="DefaultCategoryBox">

<label>Kategorie:</label>

</textBox>

</presentation>

[weitere Einträge….]

</presentationTable>

Abschluss der XML-Datei:

</resources>

</policyDefinitionResources>

Tools für die ADMX-Dateien

ADMX-Migrator:

Mit dem kostenlosen Tool können Sie bestehende, alte ADM-Dateien in ADMX-Dateien konvertieren. Weiterhin werden Sie bei der Erstellung eigener ADMX-Dateien unterstützt:

Download:

http://www.microsoft.com/downloads/details.aspx?FamilyId=0F1EEC3D-10C4-4B5F-9625-97C2F731090C&displaylang=en

XML Notepad 2007:

Einfacher XML-Editor zum Bearbeiten von ADMX-Dateien.

Download:

http://www.microsoft.com/downloads/details.aspx?familyid=72d6aa49-787d-4118-ba5f-4f30fe913628&displaylang=en

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2480.htm


Liste der wiederherstellbaren lokalen Dateien ausblenden

Mit diesem Tipp können Sie das Anzeigen und das Wiederherstellen von gesicherten Dateien (vorheriger Versionen) auf lokalen Datenträgern ausblenden. Wenn Sie den Tipp aktivieren, können keine vorherigen Versionen von Dateien wieder hergestellt werden.

Die vorherigen Versionen können aus einer Schattenkopie oder von Sicherungsmedien stammen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLocalPage" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Liste der vorherigen Versionen anzeigen (Standard)
1 | Liste der vorherigen Versionen ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Liste vorheriger Versionen von lokalen Dateien ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2560.htm


Liste der wiederherstellbaren Remotedateien ausblenden

Mit diesem Tipp können Sie das Anzeigen und das Wiederherstellen von gesicherten Dateien (vorheriger Versionen) von Dateifreigaben (Remotedateien) ausblenden. Wenn Sie den Tipp aktivieren, können keine vorherigen Versionen von Dateien wieder hergestellt werden.

Die vorherigen Versionen können aus einer Schattenkopie oder von Sicherungsmedien stammen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableRemotePage" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Liste der vorherigen Versionen anzeigen (Standard)
1 | Liste der vorherigen Versionen ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Liste vorheriger Versionen von Remotedateien ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2561.htm


Backup-Dateien ausblenden, die nicht aus einer Schattenkopie stammen

Mit diesem Tipp können Sie das Anzeigen von Dateien ausblenden, die nur auf einem Sicherungsmedium zur Verfügung stehen und nicht in der Schattenkopie liegen.

Wenn Sie den Tipp aktivieren, werden vorherige Versionen, die sich auf Sicherungskopien befinden, nicht mehr angezeigt. Es werden nur vorherige Versionen angezeigt, die sich in der Datenträger-Schattenkopie befinden.

Die vorherigen Versionen können aus einer Schattenkopie oder von Sicherungsmedien stammen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "HideBackupEntries" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Liste der vorherigen Versionen aus Schattenkopien und Sicherungsmedien (Standard)
1 | Liste der vorherigen Versionen nur aus Schattenkopien

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Vorherige Versionen von Dateien in Sicherungsspeicherorten ausblenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2564.htm


Wiederherstellung von Remotedateien unterbinden

Mit diesem Tipp können Sie die Schaltfläche "Wiederherstellen" entfernen und somit das Wiederherstellen von alten Dateiversionen aus Sicherungskopie/Schattenkopie unterbinden, wenn sich die Datei auf einer Dateifreigabe (Netzwerk) befindet.

Die Schaltfläche "Wiederherstellen" finden Sie in den Eigenschaften von Dateien und Ordnern auf der Registerkarte "Vorgängerversionen". Wenn Sie den Tipp aktivieren, kann der Benutzer keine Vorgängerversionen mehr wiederherstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableRemoteRestore" als Datentyp REG_DWORD und setzen den Wert auf:

0 | "Wiederherstellen" ist für Remotedateien sichtbar (Standard)
1 | "Wiederherstellen" ist nicht für Remotedateien sichtbar

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Wiederherstellung vorheriger Remoteversionen verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2565.htm


Wiederherstellen bei Backup-Dateien die nicht aus einer Schattenkopie stammen ausblenden

Wiederherzustellende Backup-Dateien ausblenden, die nicht aus einer Schattenkopie stammen

Mit diesem Tipp können Sie das Anzeigen von Wiederherstellen auf der Eigenschaftsseite ausblenden, wenn die vorherigen Versionen nur auf einem Sicherungsmedium zur Verfügung stehen und nicht in der Schattenkopie liegen.

Wenn Sie den Tipp aktivieren, wird der Eintrag Wiederherstellen nicht mehr angezeigt, außer die vorherigen Versionen der Datei befinden sich in der Schattenkopie.

Die vorherigen Versionen können aus einer Schattenkopie oder von Sicherungsmedien stammen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ PreviousVersions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ PreviousVersions

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBackupRestore" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Wiederherstellen der vorherigen Versionen aus Schattenkopien und Sicherungsmedien (Standard)
1 | Wiederherstellen nur bei vorherigen Versionen aus Schattenkopien anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer\Vorherige Versionen
Einstellungsname: | Wiederherstellung vorheriger Versionen aus Sicherungen verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2566.htm


Profilverzeichnis, Startmenü und Homeverzeichnis ab Vista

Ab Windows Vista hat Microsoft die Pfade für Profilverzeichnisse verändert, so dass wir hier noch einmal die Änderungen beschreiben wollen.

Die Grundpfade für die Verzeichnisse werden in Umgebungsvariablen abgelegt, welche man über die Kommandozeilenoberfläche abrufen kann. Öffnen Sie dafür die Kommandozeilenoberfläche (CMD.EXE) und geben hier SET ein. Nach dem Drücken der Entertaste werden Ihnen alle gültigen Umgebungsvariablen angezeigt. Weitere Infos zu den Umgebungsvariablen finden Sie im Tipp: "Umgebungsvariablen in Windows"

Profilverzeichnis:

Im Profilverzeichnis werden alle userabhängigen Einstellungen von Windows und die "Eigenen Dateien" abgelegt. Das Profilverzeichnis finden Sie unter "%USERPROFILE%". Nach Auflösung der Umgebungsvariablen könnte der Pfad z.B. so aussehen: "C:\Users\franku"

Startmenü:

Das Startmenü finden Sie jetzt unter "%APPDATA%\Microsoft\Windows\Start Menu". Nach Auflösung der Umgebungsvariablen könnte der Pfad z.B. so aussehen: "C:\Users\franku\AppData\Roaming\Microsoft\Windows\Start Menu".

Weiterhin setzt sich das Startmenü aus zwei Verzeichnissen zusammen. Zusätzlich zum obigen Verzeichnis wird noch das Verzeichnis "%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu" eingeblendet.

Homeverzeichnis:

Mit dem Homeverzeichnis meint man das Verzeichnis, wo Windows die Verzeichnisse für Bilder, Desktop, Dokumente usw. ablegt.

Standardmäßig findet man diese Verzeichnisse unterhalb des Profilverzeichnisses unter "%USERPROFILE%"

Alle Pfadeinstellungen werden in der Registry gespeichert. Hier finden Sie die Pfadangaben an zwei Stellen, welche folgende Bedeutung haben:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

Hier können Sie die Pfade mit Umgebungsvariablen angegeben. Wenn Sie die Pfade verändern wollen, dann müssen Sie den Pfad hier anpassen, wobei Sie auch wieder mit Umgebungsvariablen arbeiten oder aber auch den Pfad direkt angeben können.

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

Hier finden Sie alle Pfade aus dem oberen Key. Der Unterschied besteht aber darin, dass hier die Umgebungsvariablen schon aufgelöst wurden und der richtige Pfad zum Verzeichnis angezeigt wird. Deshalb sollten hier auch keine Änderungen vorgenommen werden, da Windows beim Starten automatisch die aktuellen Werte aus dem oberen Key hier einträgt.

Diese beiden Verzeichnisse gibt es jetzt unter HKEY_LOCAL_MACHINE noch einmal:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders

Dort werden die Pfade gespeichert, welche für alle Anwender gleich sind. Normale Anwender haben auf diese Verzeichnisse nur lesende Rechte und nur Anwender mit administrativen Rechte dürfen hier Änderungen vornehmen.

Verzeichnispfade verändern

Wenn Sie die Verzeichnisse in der Registry ändern, müssen Sie selber die neuen Verzeichnisse anlegen und die Dateien aus dem alten Verzeichnis in das neue Verzeichnis kopieren. Einige Verzeichnisse können Sie aber auch über den Explorer ändern:

  • Öffnen Sie den Explorer und gehen Sie hier in das Profilverzeichnis %USERPROFILE%
    oder:
    Öffnen Sie das Startmenü und klicken Sie dann oben rechts mit der rechten Maustaste auf den entsprechenden Ordnernamen (hier werden aber nicht alle Ordner angezeigt)
  • Klicken Sie mit der rechten Maustaste auf das Verzeichnis, welches Sie verschieben wollen (z.B.: Bilder) und wählen Sie aus dem Kontextmenü "Eigenschaften" aus.
  • Klicken Sie auf dem Tabreiter "Pfad".
  • Klicken Sie auf den Button "Verschieben" oder geben Sie den neuen Pfad in der Eingabezeile oberhalb des Button ein.
  • Wenn Sie auf "Verschieben" geklickt haben: Wählen Sie jetzt das Laufwerk und das Verzeichnis aus, wo die Dateien jetzt abgelegt werden sollen und klicken Sie auf "Ordner auswählen".
  • Klicken Sie auf den Button "Übernehmen".
  • Bestätigen Sie die Sicherheitsabfrage mit "Ja".
  • Windows Verschiebt jetzt alle Dateien innerhalb des Verzeichnisses Bilder in das neue Verzeichnis und ändern den entsprechenden Registrykey (hier "My Pictures") entsprechend ab.

Der Tabreiter "Ordner" wird nur bei den Benutzer Ablageverzeichnissen angezeigt. So finden Sie den Tabreiter natürlich nicht bei Verzeichnis "AppData". Mögliche Ordner dafür sind:

Verzeichnis | Registry | Beschreibung
Desktop | Desktop | Verzeichnis für den Desktop (Die Icons auf dem Desktop und sonstige Dinge, die hier abgelegt wurden)
Dokumente | Personal | Entspricht dem Verzeichnis "Eigene Dateien". Hier sollen z.B. die Worddokumente usw. abgelegt werden.
Download | {374DE290-123F-4565-9164-39C4925E467B} | Verzeichnis für Dateien, die Sie herunter laden
Bilder | My Pictures | Hier werden Bilder angelegt
Favoriten | Favorites | Hier speichert der Internet Explorer die Favoriten ab
Gespeicherte Spiele | {4C5C32FF-BB9D-43B0-B5B4-2D72E54AAA4} | Neue Spiele, die diese Funktion unterstützen, legen hier die Spielstände usw. ab.
Kontakte | {56784854-C6CB-462B-8169-88E350ACB882} | Ihre Kontaktdaten
Links | {BFB9D5E0-C6A9-404C-B2B2-AE6DB6AF4968} | Hier werden die Links abgespeichert
Musik | My Music | Hier werden alle Musikdateien abgelegt
Suchvorgänge | {7D1D3A04-DEBB-4115-95CF-2F29DA2920DA} | Hier werden letzte Suchanfragen abgespeichert
Videos | My Video | Hier werden Filme angelegt

Registry gibt den Wertnamen in der Registry unter "HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders" an.

Bedenken Sie immer, dass natürlich Daten auch noch an anderen Stelle abgelegt werden können. Die Anwendungen welche Sie benutzen, müssen diese Windowsfunktionen auch unterstützen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2182.htm


Verzeichnisrechte und Verzeichniszugriffe unter Windows Vista

Es erreichen uns immer wieder Anfragen, dass man angeblich auch als Administrator auf einige Verzeichnisse nicht zugreifen kann. Meist liegt das aber daran, dass hier einfach nur das Wissen fehlt, wie die neue Verzeichnisstruktur unter Windows Vista jetzt aussieht.

Der Aufbau der Verzeichnisstruktur hat sich gegenüber den alten Windows-Versionen schon stark verändert. Damit aber alte Programme noch die Verzeichnisse finden, wird zusätzlich noch mit NTFS-Links (symbolische Verknüpfung) gearbeitet. Bei solchen NTFS-Links handelt es sich nicht um ein echtes Verzeichnis, sondern - wie der Name schon sagt -, um einen Link auf ein anderes Verzeichnis. Dadurch kann ein Verzeichnis über zwei Pfade angesprochen werden.

  • Über den neuen Verzeichnispfad: "C:\User\Username"
  • Und über den alten Verzeichnispfad (über den Link): "C:\ Dokumente und Einstellungen\Username"

Das Ziel ist aber jeweils immer das gleiche Verzeichnis, weil "C:\User\Username" <=> "C:\Dokumente und Einstellungen\Username".

Info Es handelt sich bei einem NTFS-Link quasi um eine Programmverknüpfung, wie Sie im Startmenü zu finden ist. Hier wird auch nur auf das Programm verwiesen, nicht aber wird eine extra Programmdatei ab/angelegt. Weiterhin kann auch hier die Verknüpfung anders heißen als das Programm, welches gestartet wird; trotzdem handelt es sich immer um dieselbe Anwendung.

Diese Verbindungen (NTFS-Links) muss sich Windows ja irgendwie merken. Deshalb wird für jeden Link ein virtuelles Verzeichnis angelegt.

In der Windows-Standardeinstellung im Explorer werden diese Verzeichnisse nicht angezeigt. Erst wenn man im Explorer unter "Extras" -> "Ordneroptionen" -> Tabreiter "Ansicht" die Funktion "Geschützte Systemdateien ausblenden (empfohlen)" ausschaltet, werden diese Verzeichnisse als Ordner im Explorer angezeigt. Damit man sie im Explorer von normalen Verzeichnissen dennoch unterscheiden kann, wird (meistens) links unten in der Ecke des Symbols ein kleiner Pfeil mit eingeblendet.

Diese Link-Technik wird verwendet, damit auch Programme die neuen Ordner finden, welche nicht die Windows-Funktionen benutzen, um den Pfad zum Verzeichnis zu ermitteln, sondern die mit direkten Pfadangaben arbeiten. Auch wird die Technik für die multilinguale Version von Windows benötigt. Das original Verzeichnis hat immer den gleichen Namen (z.B.: "Program Files"), nur der Name des Links wird entsprechend der Sprache angepasst (z.B.: (bei einem deutschen System auf) "Programme").

Wie oben geschrieben, werden diese NTFS-Links im Explorer nur angezeigt, wenn man die Funktion "Geschützte Systemdateien ausblenden (empfohlen)" nicht aktiviert hat.

Ab Windows Vista macht es keinen Sinn diese Funktion auszuschalten, da -außer diesen NTFS-Links- keine weiteren Verzeichnisse ausgeblendet werden. Um die Übersichtlichkeit zu wahren, sollte man deshalb diese Einstellung nicht verändern, da bei Vista auch die Systemordner schon beim Einblenden der Funktion "Versteckte Dateien anzeigen" anzeigt (war nicht der Fall bei den alten Windows Versionen).

Weiterhin lassen sich in dieser Einstellung recht einfach die Links mit der "ENTF-Taste" löschen. Dabei werden immer nur der Link und nicht das Verzeichnis und deren Inhalt selber gelöscht (löscht man das Original Verzeichnis, wird natürlich automatisch auch der Link vom System automatisch entfernt). Das Löschen der Links macht aber keinen Sinn, weil:

  1. Dadurch kein zusätzlicher Speicherplatz frei wird. Ein Link ist ja nur ein Verweis und dadurch wird kein zusätzlicher Speicherplatz belegt.
  2. Alte Programme finden Ihre Verzeichnisse nicht mehr und können dadurch nicht mehr richtig arbeiten.

Warum wird mir das Verzeichnis nicht geöffnet, wenn ich auf den NTFS-Link mit Pfeil klicke?

Wenn Sie im Explorer auf so einen NTFS-Link klicken, erscheint die Meldung "Zugriff verweigert". Warum das so ist, kann man erkennen, wenn man sich die Rechte von solch einem Link anschaut. Die Gruppe "Jeder" (steht für alle Benutzer eines Systems) hat kein Recht, den Inhalt der Ordner aufzulisten.

Diese Einschränkung hat einen ganz einfachen technischen Grund: Programme, die NTFS-Links nicht kennen und z.B. Verzeichnisbäume aufbauen und auslesen, würden ansonsten solche Verzeichnisse mehrfach durchlaufen. Die Ermittlung von Verzeichnisgrößen bringt in so einem Fall sogar falsche Werte.

Info Die Funktion von NFTS-Links ist keine neue Erfindung von Vista, sondern kann auch schon unter 2000/XP genutzt werden (hier wurde das nur noch nicht von Windows automatisch gemacht, die Programme zum Einrichten der Links muss man extra installieren).

Info Das Programm zum erstellen von NTFS-Links heist "mklink"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2193.htm


Verschlüsselte Dateien für die Suche indizieren

Mit diesem Tipp konfigurieren Sie die Suchfunktion von Windows. Wenn Sie den Tipp aktivieren, wird auch versucht, verschlüsselte Daten zu indizieren. Dazu müssen Sie natürlich über die nötigen Rechte besitzen, um diese Daten entschlüsseln zu können. Wenn Sie den Tipp deaktivieren, werden verschlüsselte Daten nicht berücksichtigt (darunter fallen auch E-Mail-Nachrichten).

Wird der Tipp nicht konfiguriert, dann werden Einstellungen aus der Systemsteuerung verwendet, wo Standardmäßig das indizieren von verschlüsselten Dateien deaktiviert ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Search

Erstellen Sie hier einen neuen Wert mit dem Namen "AllowIndexingEncryptedStoresOrItems" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | Verschlüsselte Daten nicht indizieren (Standard)
1 | Verschlüsselte Daten indizieren

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizieren verschlüsselter Dateien zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2400.htm


Speicherort für die Indizierungsdatenbank festlegen

Mit diesen Tipp können Sie festlegen, wo die Indizierungsdatenbank gespeichert werden soll. Wenn Sie diesen Tipp aktivieren, können Sie einen Pfad zu einem Verzeichnis angeben, in dem die Datenbank abgelegt werden soll. Wenn der Tipp nicht konfiguriert ist, wird die Datenbank in einem Standardverzeichnis abgelegt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Search

Erstellen Sie hier einen neuen Wert mit dem Namen "DataDirectory" als Datentyp REG_SZ, und geben Sie als Wert den Pfad zum entsprechenden Verzeichnis an. Dabei darf der Pfad nicht länger als 250 Zeichen sein.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Datenspeicherort für Indizierung

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2402.htm


Dateien aus dem Offlinedatei-Cache nicht indizieren

Mit diesem Tipp können Sie einstellen, ob Dateien, welche sich im Offlinedatei-Cache befinden, indiziert werden sollen. Bei Dateien aus dem Offlinedatei-Cache handelt es sich um solche, welche aus einer Netzwerkfreigabe Offline verfügbar gemacht wurden. Standardmäßig werden diese Dateien auch mit indiziert.

Wenn Sie den Tipp aktivieren, werden diese Dateien nicht indiziert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Search

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingOfflineFiles" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | Dateien werden indiziert (Standard)
1 | Dateien werden nicht indiziert

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizierung von Dateien im Offlinedateicache verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2403.htm


Windows Desktopsuche: E-Mail Anlagen nicht indizieren

Windows Desktopsuche: Email-Anlagen nicht indizieren

Mit diesem Tipp können Sie einstellen, ob ein Anwender bei der Windows Desktopsuche einstellen kann, dass Email Anlagen mit indiziert werden sollen.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingEmailAttachments" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | E-Mail Anlagen können indiziert werden (Standard)
1 | E-Mail Anlagen können nicht indiziert werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizierung von E-Mail-Anlagen verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2199.htm


Windows Desktopsuche: Indizieren von Outlook-Elementen deaktivieren

Die Windows Desktopsuche indiziert standardmäßig auch Outlook-Elemente. Mit dem folgenden Tipp können Sie Einträge "E-Mail und alle Festplatten" und "E-Mail und Eigene Dateien" aus der Desktopsuche ausblenden. Weiterhin wird dadurch auch das Indizieren von Outlook-Elementen deaktiviert. Ist die Einstellung nicht gesetzt, kann der Anwender diese Funktion konfigurieren.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für die Windows Suche:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Search

Diese Einstellung wird ab Windows-Suche 3.01 oder höher unterstützt.

Für die Windows Desktopsuche:

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingOutlook" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Indizieren von Outlook-Elementen (Standard)
1 | Indizieren von Outlook-Elementen ausschalten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizierung von Microsoft Office Outlook verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2204.htm


Windows Desktopsuche: Nur gechachte Exchange Elemente indizieren

Standardmäßig werden durch die Windows Desktopsuche alle Exchange Elemente indiziert. Befinden sich die Elemente aber nicht im Cache, ist das nicht gerade gut für die Leistung des Rechners.

Mit diesem Tipp können Sie einstellen, dass nur noch Exchange-Elemente indiziert werden, welche sich auch im Cache befinden. Wenn Sie den Tipp nicht aktivieren, kann der Anwender festlegen ob auch nicht im Cache befindliche Elemente indiziert werden sollen.

Der Cache-Modus wird erst ab Outlook 2003 unterstützt, bei älteren Outlook-Version werden nur lokale Elemente wie PST-Dateien indiziert.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingUncachedExchangeFolders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Nur im Cache befindliche Elemente indizieren
0 | Alle Elemente indizieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizierung von nicht zwischengespeicherten Exchange-Ordnern verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2162.htm


Windows Desktopsuche: "Öffentliche Ordner" nicht indizieren

Mit diesen Tipp können Sie das Indizieren von öffentlichen Ordnern in Outlook verhindert. Beachten Sie, dass die Windows-Desktopsuche nur dann öffentliche Ordner im Cache-Modus von Office 2003 indiziert, wenn die Option zum Downloaden öffentlicher Ordner-Favoriten gewählt ist.

Ist der Tipp deaktivieren oder nicht konfigurieren, können die Benutzer festlegen, dass öffentliche Ordner in Outlook 2003 im Cache-Modus indiziert werden sollen.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PeventIndexingPublicFolders" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Öffentliche Ordner werden nicht indiziert
0 | Öffentliche Ordner können indiziert werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Suche
Einstellungsname: | Indizierung von öffentlichen Ordnern verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2237.htm


Standard Autoplay Aufruf zurücksetzen

Wenn Sie einen externen Datenträger anschließen oder eine CD in das Laufwerk legen, öffnet Windows das Autoplay-Fenster, in dem Sie eine gewünschte Aktion auswählen können. Dabei können Sie diese Aktion auch gleich als Standard festlegen, so dass beim nächsten Mal das Autoplay-Fenster nicht mehr angezeigt wird.

Sie können diese Festlegung wieder über die folgende Funktion löschen bzw. hier auch vorab schon entsprechende Aktionen bestimmten Dateninhalten zuordnen.

Dazu das betreffende Laufwerk im Explorer auswählen, darauf rechts-klicken und aus dem Kontextmenü den Eintrag "Eigenschaften" und auf den Tabreiter "AutoPlay" auswählen. Hier können Sie jetzt die Einstellung für die unterschiedlichen Daten zurücksetzen.

Ab Windows Vista können Sie diese Einstellung auch global für alle Laufwerke in der Systemsteuerung vornehmen. Die Einstellung finden Sie unter "Programme" -> "Standardprogramme" -> "Standardeinstellungen für Medien und Geräte ändern" bzw. in der klassischen Ansicht unter "Automatische Wiedergabe". Hier wählen Sie jetzt aus der Liste die gewünschte Aktion aus und können dafür ein entsprechendes Programm vorgeben.

Diese Konfiguration wird in der Registry gespeichert. Wenn Sie viele Einstellungen zurücksetzen wollen, können Sie das durch das Löschen der entsprechenden Einträge dort schneller durchführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoplayHandlers\ UserDefaults

löschen Sie einfach die nicht gewünschten Einträge aus der Liste raus.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2547.htm


Bestehende Partitionen verkleinern oder erweitern

Ab Windows Vista können Sie jetzt auch ohne spezielle Tools Partitionen im laufenden Betrieb verändern.

Über die Oberfläche:

Um Partitionen anzulegen und zu verändern, müssen Sie das Programm Datenträgerverwaltung aufrufen.

"Systemsteuerung (Klassische Ansicht)" -> "Verwaltung" -> "Computerverwaltung" im Treememü links "Datenspeicher" -> "Datenträgerverwaltung". Oder über den Befehl: "diskmgmt.msc":

Hier wählen Sie in linken Tree unter dem Eintrag "Datenspeicher" den Eintrag Datenträgerverwaltung aus. Jetzt werden im mittleren Fenster die Datenträger mit den vorhanden Partitionen angezeigt. Wenn Sie auf eine Partition mit der rechten Maustaste klicken, öffnet sich ein Kontextmenü welches unter anderem die Einträge "Volume erweitern..." und "Volume verkleinern..." enthält.

Wenn kein weitere Speicherplatz mehr frei ist, ist der Eintrag "Volume erweitern..." ausgegraut und kann nicht angewählt werden. Dieser Eintrag ist nur verfügbar, wenn hinter der entsprechenden Partition noch freier Speicherplatz zu verfügung steht.

Volume erweitern oder verkleinern

Volume verkleinern

Nach der Auswahl von "Volume verkleinern..." werden die entsprechen werte ermittelt. Sie können das Volume nur bis zu einem bestimmt Punkt verkleinern, was jeweils von den auf dem Datenträger vorhanden Dateien abhängig ist.

Geben Sie die gewünschte Größe in MB an, um die das Volume verkleinert werden soll und klicken Sie anschließend auf den Button "Verkleinern".

Anschließend wird das Volume verkleinert und der Speicherplatz steht wieder zur Verfügung.

Volume vergrößern

Steht hinter der ausgewählten Partition noch freier Speicherplatz zur verfügung, kann die Partition auch vergrößert werden. Öffnen Sie dafür das Kontextmenü und wählen Sie den Eintrag "Volume vergrößern..." aus. Windows öffnet anschließend einen "Assistent zum Erweitern von Volumes". Als erstes wird Ihnen eine Willkommensmeldung angezeigt, welche Sie mit "Weiter >" bestätigen.

Im nächsten Fenster werden Ihnen die Partitionen angezeigt, wenn nur eine Partition vorhanden ist wird automatisch der gesamte freie Speicherplatz ausgewählt. Hier können Sie jetzt die Größe im MB angeben um die man die Partition vergrößern möchte. Anschließend bestätigen Sie die Auswahl mit "Weiter >".

Anschließend werde die Änderungen noch mal angezeigt, Durch das klicken auf "Fertig stellen" werden diese Änderungen vorgenommen und die Partition wird vergrößert.

Hier wählen Sie die gewünschte Partition aus. Klicken dort mit der rechten Maustaste und wählen aus dem Kontextmenü "Volume verkleinern..." bzw. über das Menü "Aktion" -> "Alle Aufgaben.." -> "Volume verkleinern".

Jetzt wird die verfügbare Größe berechnet, und Sie können unter "Zu verkleinernder Speicherplatz in MB:" den gewünschten Wert eingetragen.

Wenn noch Platz auf der Festplatte verfügbar ist, können Sie die Partition über "Volume erweitern.." auch vergrößern.

Über die Kommandozeile (CMD.EXE)

Sie können über die Eingabeaufforderung mit dem Tool "diskpart" auch die Partitionen bearbeiten.

  • Starten Sie Diskpart
  • Lassen Sie sich mit List Volume die Partitionen anzeigen
  • Wählen Sie mit Select Volume [Nummer] die gewünschte Partition aus (z.B. Select Volume 1)
  • Lassen Sie sich mit Shrink Querymax die Größe ermitteln, um die man die Partition maximal verkleinern kann
  • Mit Shrink Desired=[Größe] die ausgewählte Partition, um die angegebene Größe (im MByte) verkleinern (z.B.: Shrink Desired=10)
  • Nach Beendigung der Aktion wird das Tool über Exit verlassen.

Alternative Programme

Diese Funktion steht erst ab Windows 7 zur Verfügung. Wollen Sie die Partitionsgröße anderer Windows Versionen verändern müssen Sie auf externe Programme zurückgreifen. Zu empfehlen ist hier das Programm "Gnome Partition Editor" welches Sie kostenlos unter "http://gparted.sourceforge.net/index.php" runterladen können.

Das Programm bietet auch gegenüber der Windows Funktionen noch einige weitere Vorteile.

Weitere Informationen über Diskpart finden Sie im Tipp: Beschreibung der Funktionen von Diskpart

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2160.htm


ReadyBoost für alle USB-Speicher aktivieren

Ab Windows Vista hat Microsoft die Funktion ReadyBoost eingeführt. Wird ReadyBoost aktiviert, wird der Flashspeicher (z.B. USB-Stick) als Zwischenspeicher benutzt und damit die Systemleistung von Windows gesteigert.

Wenn Sie einen USB-Stick in den Rechner einstecken erscheint folgendes Bild:

Über den Eintrag "System beschleunigen" können Sie testen, ob der USB-Stick für diese Funktion geeignet ist. Damit ein Stick für diese Funktion benutzt werden kann, muss er einige Voraussetzungen von Microsoft erfüllen:

  • Der Datendurchsatz muss bei 2,5 MB pro Sekunde liegen bei 4-KB-Lesevorgängen
  • und 1,75 MB bei 512-KB-Schreibvorgängen

Wenn der Hersteller die doppelten Werte garantiert, bekommt er das Logo: "Enhanced for Windows ReadyBoost".

Erfüllt der USB-Stick nicht die gewünschten Anforderungen, erscheint folgende Meldung:

Auch wenn der USB-Stick die Anforderungen erfüllt, können Sie ihn nicht für ReadyBoost freischalten. Mit dem folgenden Vorgehen können Sie aber trotzdem diese Funktion aktivieren.

  • Entfernen Sie den USB-Stick aus dem Computer
  • Starten Sie den Registryeditor
  • Löschen Sie unter "HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ EMDMgmt" alle Einträge, die mit einem "_??_" beginnen. Dabei handelt es sich um alle USB-Sticks, die von Windows schon mal getestet wurden. Damit wir den richtigen USB-Stick leichter finden, löschen wir die alten Einträge:

  • Stecken Sie den USB-Stick in den Rechner und führen Sie Überprüfung noch einmal durch.
  • Gehen Sie jetzt wieder unter "HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ EMDMgmt". Hier finden Sie jetzt wieder einen Eintrag, der mit "_??_" anfängt. Dabei handelt es sich jetzt um unseren (den neuen) USB-Stick
  • Gehen Sie auf diesen Eintrag, so dass im rechten Fenster die Werte angezeigt werden, die Sie wie folgt, ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Wertname | Datentyp | auf folgenden Wert
DeviceStatus | REG_DWORD | 2
ReadSpeedKBs | REG_DWORD | 2000 (Dezimal)
WriteSpeedKBs | REG_DWORD | 1500 (Dezimal)

  • Klicken Sie anschließend auf "Noch einmal testen".
  • Windows sollte den Datenträger jetzt akzeptieren.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2310.htm


Energiesparmodus für Hybridfestplatten ausschalten

Mit diesem Tipp können Sie einstellen, dass der Energiesparmodus für Hybridfestplatten nicht vom System aktiviert werden soll. Wenn Sie den Tipp aktivieren, werden die Festplatten nicht mehr in den Energiesparmodus versetzt. Ist dieser Tipp nicht aktiviert, dann wird vom System versucht, die Festplatte in den Energiesparmodus zu schalten. Dabei wird die Rotation der Festplatte ausgeschaltet, wenn nicht auf die Festplatte zugegriffen wird.

Dieser Tipp geht nur, wenn der Tipp: "Permanenten Cache deaktivieren" nicht aktiviert wurde, also der Cache aktiv ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NvCache

Erstellen Sie hier einen neuen Wert mit dem Namen "EnablePowerModeState" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Energiesparmodus ausschalten
1 | Energiesparmodus aktivieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Permanenter Festplattencache
Einstellungsname: | Cache-Energiesparmodus deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2396.htm


Permanenten Cache deaktivieren

Mit diesem Tipp schalten Sie die Cache-Unterstützung für alle Hybridfestplatten im System aus. Der permanente Cache kann zur Optimierung der Start- und Fortsetzungsvorgänge verwendet werden. Dabei werden Daten aus dem Cache gelesen, während die Rotation der Festplatte eingeschaltet wird. Der permanente Cache kann auch verwendet werden, um den Energieverbrauch des Systems zu verringern, indem die Rotation der Festplatte abgeschaltet wird, wenn erfolgreiche Lese- und Schreibvorgänge im Cache möglich sind.

Wenn Sie den Tipp aktivieren, wird der Cache nicht verwendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NvCache

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableNvCache" als Datentyp REG_DWORD, und setzen den Wert auf:

0 | Cache ausschalten
1 | Cache aktivieren (Standard)

Diese Einstellung tritt nach dem nächsten Neustart in Kraft.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Permanenter Festplattencache
Einstellungsname: | Permanenten Cache deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2397.htm


Solid-State-Modus für Hybridfestplatten deaktivieren

Mit diesem Tipp können Sie den "Solid-State-Modus" für Hybridfestplatten ausschalten.

Standardmäßig (Eintrag nicht in der Registry vorhanden oder Eintrag aktiviert (1)) werden häufig verwendete Daten im permanenten Cache gespeichert. Dadurch wird der Zugriff auf die Festplatte verringert, und die Festplatte kann längere Zeit ausgeschaltet bleiben. Wenn Sie den Eintrag deaktivieren (0), werden die Daten eher auf die Festplatte geschrieben und nicht so lange im permanenten Cache gehalten.

Dieser Tipp geht nur, wenn der Tipp: "Permanenten Cache deaktivieren" nicht aktiviert wurde, also der Cache aktiv ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NvCache

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableSolidStateMode" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Solid-State-Modus ausschalten
1 | Solid-State-Modus einschalten (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Permanenter Festplattencache
Einstellungsname: | Solid-State-Modus deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2398.htm


Start- und Wiederherstellungsoptimierung deaktivieren

Mit diesem Tipp können Sie die Start- und Wiederherstellungsoptimierung deaktivieren.

Standardmäßig (Eintrag nicht in der Registry vorhanden oder Eintrag aktiviert (1)) wird der permanent Cache für das Optimieren der Start und Wiederherstellung (Fortsetzung) des Systems verwenden. Dabei wird vom System festgelegt, welche Dateien im permanent Cache gespeichert werden, um das Starten des System zu optimieren.

Die erforderlichen Daten werden beim Herunterfahren bzw. beim Übergang in den Ruhezustand im permanenten Cache gespeichert. Dadurch kann das Herunterfahren bzw. das Umschalten in den Ruhezustand ein wenig länger dauern.

Wenn Sie den Eintrag deaktivieren (0), wird die Optimierung nicht mehr durchgeführt.

Dieser Tipp geht nur, wenn der Tipp: "Permanenten Cache deaktivieren" nicht aktiviert wurde, also der Cache aktiv ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NvCache

Erstellen Sie hier einen neuen Wert mit dem Namen "OptimizeBootAndResume" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Optimierung ausschalten
1 | Optimierung einschalten (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Permanenter Festplattencache
Einstellungsname: | Start- und Fortsetzungsoptimierung deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2399.htm


Neue Funktionen zur Leistungssteigerung

Ab Windows Vista hat Microsoft wieder einige neue Funktionen zur Leistungssteigerung eingeführt, die wir hier kurz vorstellen möchten.

Readyboost:

Bei Readyboost wird der virtuelle Speicher nicht nur auf die Festplatte, sondern wenn vorhanden auf einen USB-Stick ausgelagert. Dabei werden USB-Sticks ab einer Größe von 1 GByte unterstützt.

Die SWAP-Datei wird jetzt auf den USB-Stick abgelegt, da der Zugriff auf einen USB-Stick meist schneller ist als auf die Festplatte. Da die meisten Festplatten aber schon heute schnell sind, ist meist kein spürbarer Geschwindikskeitsgewinn zu bemerken.

Superfetch:

Diese Funktion ist unter Windows XP als Prefetch bekannt und wurde ab Vista nur erweitert. Prefetch beschleunigte nur den Bootvorgang und die Startumgebung, wobei sich das neue Superfetch auch um alle Programmaufrufe kümmert.

Die Funktion überwacht alle Programmaufrufe und optimiert den Start der Anwendungen.

Readydrive:

Durch diese Funktion wird der Flash-Speicher, den Hybrid-Festplatten besitzen, benutzt, um den Startvorgang zu beschleunigen. Es wird dort die Bootumgebung bzw. die Hibernate-Datei vom Ruhezustand abgelegt.

Weiterhin gibt es zum Ruhezustand die neue Funktion "Energie sparen", die im Gegensatz zum Ruhezustand weiterhin eine Stromversorgung benötigt. Dafür lässt sich der Rechner aber innerhalb weniger Sekunden wieder starten.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2152.htm


Programmkompatibilitäts-Assistent ausschalten

Der Programmkompatibilitäts-Assistent überwacht zur Laufzeit die vom Benutzer gestarteten Programme. Erkennt er ein bekanntes Kompatibilitätsproblem mit einer Anwendung, werden entsprechende Hinweise und Empfehlungen zur Problemlösung angezeigt.

Mit diesem Tipp können Sie den Programmkompatibilitäts-Assistent ausschalten, welcher standardmäßig aktiv ist. Durch das Ausschalten kann die Leistung des Systems verbessert werden. Wenn Sie also keine Anwendungen mehr starten, wo Ihnen eventuelle Probleme nicht bekannt sind, können Sie den Assistenten ruhig ausschalten.

Info: Damit der Programmkompatibilitäts-Assistent gestartet wird, müssen die Dienste "Diagnoserichtliniendienst" und "Programmkompatibilitäts-Assistent-Dienst" gestartet sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ AppCompat

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ AppCompat

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePCA" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Programmkompatibilitäts-Assistent nicht ausführen
<gelöscht> | Programmkompatibilitäts-Assistent ausführen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Anwendungskompatibilität
Einstellungsname: | Programmkompatibilitäts-Assistent ausschalten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2331.htm


Kontenüberwachung für WSRM aktivieren

Mit diesem Tipp können Sie die Kontenüberwachung für WSRM (Windows System Resource Manager) aktivieren.

Mit dem Tool "WSRM" können Sie den Ressourcen Verbrauch einer Anwendung ermitteln und kontrollieren. Weiterhin haben Sie auch die Möglichkeit, die maximale Nutzung von Speicher und CPU für bestimmte Anwendungen einzuschränken. Die WSRM-Konsole finden Sie im Server 2008 oder auch in den "Remote Server Administration Tools für Vista", welches Sie bei Microsoft herunterladen können:

  • Microsoft Remote Server Administration Tools for Windows Vista SP1 32-bit Edition (KB941314)
  • Microsoft Remote Server Administration Tools for Windows Vista SP1 64-bit Edition (KB941314)

Wenn Sie den Eintrag "AccountingEnabled" aktivieren (Festlegung auf "1"), startet der Windows-Systemressourcen-Manager (WSRM) die Kontenüberwachung für die Nutzungsstatistik der Prozesse.

Wenn Sie diese Einstellung deaktivieren, wird die Protokollierung der Nutzungsstatistik der Prozesse durch WSRM beendet. Falls Sie diese Einstellung nicht konfigurieren, können die Benutzer die Kontenüberwachung aktivieren oder deaktivieren.

Standardmäßig ist die Kontenüberwachung der Prozesse deaktiviert.

Mithilfe von Kontoführungsdaten können Sie die Ressourcennutzung überwachen, die tatsächliche und erwartete Leistung vergleichen, beurteilen, ob die physikalischen Ressourcen des Computers für die geplanten Aufgaben ausreichend sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WSRM

Erstellen Sie hier einen neuen Wert mit dem Namen "AccountingEnabled" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Kontenüberwachung für WSRM ist aktiv
0 | Kontenüberwachung ist deaktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Systemressourcen-Manager
Einstellungsname: | Kontoführung für WSRM aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2585.htm


Ausführen des Audiorecorders unterbinden

Mit dem Audiorecorder können Sie Audiosignale über ein Audioeingabegerät aufzeichnen und abspeichern. Wenn Sie diesen Tipp aktivieren, kann der Audiorecorder nicht mehr gestartet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ SoundRecorder

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ SoundRecorder

Erstellen Sie hier einen neuen Wert mit dem Namen "Soundrec" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Audiorecorder kann nicht gestartet werden
0 | Audiorecorder kann gestartet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Audiorecorder
Einstellungsname: | Ausführen des Audiorecorders nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2332.htm


VISTA Sprachausgabe auf Deutsch

Mit Windows VISTA wird auch ein Screen Reader mit ausgeliefert. Die Sprachausgabe finden Sie unter "Start" -> "Alle Programme" -> "Zubehör" -> "Erleichterte Bedienung" -> "Sprachausgabe" oder direkt über "narrator.exe".

Da in der deutschen Version keine Sprachdatei für Deutsch mitgeliefert wird, erscheint als erste die Meldung "Installieren Sie eine Stimme für Text-in-Sprache, die zur aktuellen Windows-Sprache passt".

Damit diese Meldung nicht mehr kommt und die Sprachausgabe nicht "komisch" wirkt, sollten Sie die entsprechende Sprachdatei von Microsoft runterladen:

Download: RealSpeak TTS Deutsch - Steffi (Datei wurde von Microsoft entfernt - vista_german.zip -)

Anschließend entpacken Sie die ZIP-Datei "RSSolo4German.zip" in ein beliebiges Verzeichnis und starten die Installation über die Datei "RSSolo4GermanSteffi.exe".

Starten Sie jetzt die Anwendung neu und stellen Sie unter "Spracheinstellungen" die Sprache auf "ScanSoft Steffi_Dri40_16kHz".

Weitere Informationen zu den Funktionen der Sprachausgabe finden Sie in der Windows-Hilfe.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2406.htm


Error Reporting ab Windows Vista

Windows Error Reporting (ab Windows Vista)

Ab Windows Vista gibt es das Tool Dr. Watson (DRWTSN32.EXE) nicht mehr. Mit diesem Tool wurde beim Absturz einer Anwendung ein entsprechendes Crashdump-File erzeugt, welches für die Fehlersuche recht hilfreich sein konnte.

Ab Windows Vista wurde dafür das "Windows Error Reporting" (WER) eingeführt. Leider stellt sich jetzt die Frage, wie man an diese Informationen (Minidump) kommt, wenn man keinen WER-Account mehr besitzt und die Anwendung nicht signiert ist.

Standardmäßig legt Windows nicht für alle Anwendungen einen entsprechenden Eintrag unter "Problemberichte und Lösungen" an. Es werden nur entsprechende Minidumps für signierte Programme erzeugt bzw. nur, wenn diese Informationen vom WER-Server angefordert wurden.

Wenn Sie für alle Anwendungen diese Informationen angelegen wollen, müssen Sie den folgenden Registryeintrag ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ Windows Error Reporting

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Windows Error Reporting

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceQueue" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Es wird automatisch entschieden, ob der Bericht in die Warteschlange gestellt wird oder der Benutzer gefragt wird, diesen Bericht zu versenden
1 | Es werden alle Berichte in die Warteschlange gestellt bis der Benutzer benachrichtigt wird
2 | Es werden alle Berichte in die Warteschlange gestellt bis der Administrator benachrichtigt wird

Damit die Berichte für alle Anwendungen abgelegt werden, setzen Sie den Wert auf 1.

Die Dumps werden unter:

%UserProfile%\AppData\Local\Temp

C:\ProgramData\Microsoft\Windows\WER\ReportQueue

abgelegt und erhalten die Dateiendung .mdmp.

Auf die Einträge können Sie über "Systemsteuerung" -> "System und Wartung" -> "Problemberichte und Lösungen" -> "Problemberichte anzeigen und überprüfen" zugreifen. Dort findet man für das entsprechende Programm einen Eintrag mit dem gewünschten Crash-Dump, wo Sie sich über "Details" weitere Informationen anzeigen lassen können.

Gibt es für den Eintrag einen Dump-File, dann finden Sie hier den Eintrag "Temporäre Kopie dieser Datei anzeigen". Diesen können Sie anzeigen und an den Entwickler senden.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=931673 (Erstellen einer Prozess-Speicher-Abbild-Datei in Windows Vista in Benutzermodus)

Siehe dazu auch:

"Windows Error Reporting: Getting Started"

"WER Settings"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2635.htm


"Hilfe und Support" läßt sich nicht mehr öffnen

"Windows Hilfe und Support" lässt sich nicht mehr öffnen

Durch die Installation von Software unter Windows Vista, kann es passieren, dass beim Öffnen von "Windows Hilfe und Support" zum Beispiel über F1, eine leere Seite mit folgender Fehlermeldung angezeigt wird:

/ von help kann nicht heruntergeladen werden.

Das kommt daher, dass einige Programme die XML-Dateiverknüpfungen verändern und dadurch die Hilfe nicht mehr geöffnet werden kann. Um den Fehler zu beheben, müssen Sie folgende Einstellungen wieder setzen:

=== Hier schneiden ===
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]

@="xmlfile"

"Content Type"="text/xml"

"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]

@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]

@="{7E9D844-6926-426F-AA2B-217A819A5CCE}"
=== Hier schneiden ===

Schneiden Sie den Text aus und speichern Sie den Inhalt in eine Textdatei mit der Endung .reg ab. Anschließend führen Sie im Explorer einen Doppelklick auf die Datei aus. Nach der Bestätigung des Sicherheitshinweises, sollte die Hilfe wieder funktionieren.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2177.htm


Fehlermeldung: "Eine Desktopheapzuweisung ist fehlgeschlagen" in der Ereignisanzeige

Fehlermeldung in der Ereignisanzeige: "Eine Desktopheapzuweisung ist fehlgeschlagen"

Hängt sich der Rechner nach einer Anmeldung auf oder öffnet sich der Speicherdialog "Datei" -> "Speichern Unter" nicht mehr, sollten Sie in der Ereignisanzeige unter "System" nach einem Eintrag mit folgender Bezeichnung nachschauen:

Ereignis-ID: 243 - Quelle: Win32k - Beschreibung: Eine Desktopheapzuweisung ist fehlgeschlagen

Wenn Sie dort diese Fehlermeldung finden, sollten Sie den Desktopheap erhöhen, dazu gehen Sie folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager\ SubSystems

Hier finden Sie den Eintrag "Windows" als Datentyp REG_EXPAND_SZ mit folgenden Inhalt:

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows SharedSection=1024,3072,512 Windows=On SubSystemType=Windows ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3 ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off MaxRequestThreads=16

Ändern Sie hier nur bei "SharedSection=1024,3072,512 " die Zahl 3072 (rot markiert) auf 4096 und lassen Sie allen anderen Werte unverändert. Der Eintrag sollte nun folgendermaßen aussehen:

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows SharedSection=1024,4096,512 Windows=On SubSystemType=Windows ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3 ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off MaxRequestThreads=16

Dadurch wird der Desktopheap von 3 MB auf 4 MB vergrößert. Weiterhin muss unter "Systemsteuerung" -> "System" -> "Erweiterte Einstellungen" -> Tabreiter "Erweitert" -> Button "Einstellungen..." unter Leistung -> Tabreiter "Erweitert" -> Button "Ändern..." unter Virtueller Arbeitsspeicher -> Die Einstellung "Größe wird vom System verwaltet" aktiviert sein.

Info Weitere Infos zur Ereignisanzeige finden Sie im Tipp: Die Ereignisanzeige

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2407.htm


Windows Mail: Splash Screen deaktivieren

Windows Mail: Splash Screen von deaktivieren

Um den Splash Screen von Windows Mail auszuschalten, müssen Sie folgenden Schlüssel in der Registry anlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows Mail

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSplash" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keinen Splash Bildschirm anzeigen
0 | Splash Bildschirm anzeigen(Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2178.htm


Alte Hilfedateien (*.HLP) unter Windows Vista

Microsoft hatte eigentlich vor, mit Windows Vista die Unterstützung des alten Hilfeformats (.HLP) einzustellen. Scheinbar war die Nachfrage aber doch größer als erwartet, denn Microsoft hat die nötigen Dateien auf die Homepage gestellt.

Download: http://www.microsoft.com/downloads/details.aspx?FamilyID=6ebcfad9-d3f5-4365-8070-334cd175d4bb&amp;DisplayLang=de

Wenn man noch das alte Windows XP besitzt, braucht man nur die WINHELP32.EXE aus dem System32-Verzeichnis in Windows Vista einzubinden und kann darüber die alten Hilfedateien öffnen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2201.htm


Starten des "Media Center" unterbinden

Mit diesem Tipp können Sie das Starten des "Media Center" unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaCenter

[für das System (alle Anwender)]

HKEY_LOCAL_MACINE\ Software\ Policies \ Microsoft\ WindowsMediaCenter

Erstellen Sie hier einen neuen Wert mit dem Namen "MediaCenter" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Mediacenter kann gestartet werden
1 | Mediacenter kann nicht gestartet werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Center
Einstellungsname: | Ausführen von Windows Media Center nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2214.htm


Windows Mail: Zugriff auf Windows Mail unterbinden

Windows-Mail: Zugriff auf unterbinden

Mit diesem Tipp können Sie in den Windows-Mail-Anwendungen deaktivieren. Der Anwender kann dann die Windows-Mail-Anwendungen nicht mehr starten.

Wenn Sie den Eintrag "ManualLaunchAllowed" aktivieren (Festlegung auf "1"), wird der Zugriff auf die Windows-Mail-Anwendung verweigert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows Mail

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Mail

Erstellen Sie hier einen neuen Wert mit dem Namen "ManualLaunchAllowed" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Windows-Mail-Anwendung deaktivieren
1 | Windows-Mail-Anwendung können gestartet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Mail
Einstellungsname: | Windows Mail-Anwendung deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2576.htm


Windows-Mail: Communities-Funktion deaktivieren

Mit diesem Tipp können Sie in den Windows-Mail Anwendungen die Suche auf Newsgroupservern nach Communities-Unterstützung deaktivieren.

Wenn Sie den Eintrag "DisableCommunities" aktivieren (Festlegung auf "1"), werden Newsgroupserver nicht auf Communities-Unterstützung überprüft.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows Mail

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Mail

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableCommunities" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Überprüfung auf Communities-Unterstützung deaktivieren
0 | Überprüfung auf Communities-Unterstützung ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Mail
Einstellungsname: | Communities-Features deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2575.htm


Windows-Teamarbeit deaktivieren

Mit diesem Tipp können Sie die Windows-Teamarbeit deaktivieren.

Windows-Teamarbeit ist eine Funktion, mit der Sie einfach eine Besprechung einrichten und Dokumente, Programme oder Ihren Desktop für bis zu zehn Personen freigeben können.

Wenn Sie den Eintrag "TurnOffWindowsCollaboration" aktivieren (Festlegung auf "1"), wird die Windows-Teamarbeit deaktiviert. Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird die Windows-Teamarbeit aktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Windows Collaboration

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Collaboration

Erstellen Sie hier einen neuen Wert mit dem Namen "TurnOffWindowsCollaboration" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Windows Teamarbeit deaktivieren
0 | Windows Teamarbeit aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Teamarbeit
Einstellungsname: | Windows Teamarbeit deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2583.htm


Windows-Teamarbeitüberwachung deaktivieren

Mit diesem Tipp können Sie die Überwachung in Windows-Teamarbeit deaktivieren.

Windows-Teamarbeit ist eine Funktion, mit der Sie einfach eine Besprechung einrichten und Dokumente, Programme oder Ihren Desktop für bis zu zehn Personen freigeben können.

Wenn Sie den Eintrag "TurnOnWindowsCollaborationAuditing" aktivieren (Festlegung auf "1"), überwacht Windows-Teamarbeit verschiedene Ereignisse, die während einer Sitzung auftreten (z.B., wenn ein Benutzer eine Sitzung erstellt, einer Sitzung beitritt oder eine Präsentation startet) und nimmt entsprechende Einträge im Ereignisprotokoll vor. Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, wird die Windows-Teamarbeitüberwachung deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Windows Collaboration

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Windows Collaboration

Erstellen Sie hier einen neuen Wert mit dem Namen "TurnOnWindowsCollaborationAuditing" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Überwachung der Windows Teamarbeit aktivieren
0 | Überwachung der Windows Teamarbeit deaktivieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Teamarbeit
Einstellungsname: | Windows Teamarbeitüberwachung deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2584.htm


E-Mail-Adressen für WSRM-Benachrichtigungen festlegen

Mit diesem Tipp können Sie die E-Mail-Adressen für WSRM-Benachrichtigungen (Windows System Resource Manager) festlegen.

Mit dieser Einstellung weisen Sie die E-Mail-Adresse(n) zu, an die Benachrichtigungen gesendet werden. Verwenden Sie ein Semikolon (;) als Trennzeichen zwischen mehreren E-Mail-Adressen.

Wenn Sie den Eintrag "EmailIds" aktivieren (E-Mail-Adressen eintragen), sendet WSRM Benachrichtigungen an die angegebene(n) Adresse(n).

Wenn Sie diese Einstellung nicht konfigurieren, können die Benutzer E-Mail-Adressen für den Empfang von Benachrichtigungen angeben. Dieser Wert kann entweder ein E-Mail-Alias oder eine E-Mail-Adresse - einschließlich Domänenname - (z. B. jemand@example.com) sein.

An diese E-Mail-Adressen werden Benachrichtigungen über Ereignisse gesendet, die für den Benachrichtigungsdienst ausgewählt wurden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WSRM

erstellen Sie einen neuen Wert mit dem Namen "EmailIds" als Datentyp REG_SZ und geben die E-Mail-Adresse ein. Wenn Sie mehr als eine Adresse angeben wollen, trennen Sie die einzelnen Adressen durch ein (blankes) Semikolon (;) voneinander ab.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Systemressourcen-Manager
Einstellungsname: | E-Mail-IDs festlegen, an die Benachrichtigungen gesendet werden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2586.htm


Zeitintervall in Minuten für das Protokollierungsintervall

Mit diesem Tipp können Sie das Zeitintervall für WSRM (Windows System Resource Manager) festlegen. Sie geben an, in welchen Zeitabständen die Daten protokolliert werden sollen.

Wenn Sie den Eintrag "RecordWriteInterval" aktivieren (Festlegung auf "1"), legt der WSRM den angegebenen Wert als Kontoführungsintervall fest.

Wenn Sie diese Einstellung nicht konfigurieren, kann ein Kontoführungsintervall vom Benutzer angegeben werden (Standardwert = 10 Minuten).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WSRM

erstellen Sie einen neuen Wert mit dem Namen "RecordWriteInterval" als Datentyp REG_DWORD, und geben Sie einen Wert zwischen 2 und 60.000 Minuten an.

Der Standardwert beträgt 10 Minuten. Dies ist der optimale Wert, wenn zahlreiche Remoteserver Daten protokollieren. Wenn Sie für einen Server in einem Netzwerk mit mehr als 20 Computern die Daten remote protokollieren, ein Schreibintervall für Kontoführungsdatensätze von weniger als 10 Minuten angeben, kann dies Leistungseinbußen zur Folge haben.

Info Je höher die Anzahl der Computer im Netzwerk, desto länger sollte das Schreibintervall für Kontoführungsdatensätze sein, um eine Netzwerküberlastung zu vermeiden.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Systemressourcen-Manager
Einstellungsname: | Zeitintervall in Minuten für die Protokollierung von Kontoführungsdaten festlegen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2587.htm


SMTP-Server für den Versand von WSRM-Benachrichtigungen festlegen

SMTP-Server festlegen für den Versand von WSRM-Benachrichtigungen

Mit diesem Tipp können Sie für den SMTP-Server für WSRM (Windows System Resource Manager) festlegen, welcher die Benachrichtigungen versenden soll.

Wenn Sie den Eintrag "SMTPServer" aktivieren (Festlegung auf "1"), legt der WSRM den angegebenen Wert für den SMTP-Server fest. Falls Sie diese Einstellung nicht konfigurieren, kann ein SMTP-Server vom Benutzer angegeben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ WSRM

erstellen Sie einen neuen Wert mit dem Namen "SMTPServer" als Datentyp REG_SZ und geben den SMTP-Server an.

Als Wert ist der NetBIOS-Name oder der vollqualifizierte Domänenname des SMTP-Servers (Simple Mail Transfer Protocol) zulässig. Dieser Server enthält die E-Mail-Adressen, die für den Empfang von Benachrichtigungen konfiguriert wurden.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows-Systemressourcen-Manager
Einstellungsname: | SMTP-Server für den Versand von Benachrichtigungen festlegen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2588.htm


Übersicht der Dienste unter Windows Server 2008

Hier finden Sie eine Übersicht der Dienste unter Windows Server 2008 und wie diese konfiguriert sind.

Lesen Sie sich immer die Beschreibung des jeweiligen Dienstes durch und überlegen Sie, ob diese Funktion benötigt wird. Es gibt einige Dienste, die zwingend für das Funktionieren von Windows benötigt werden.

Achtung:

Eine Deaktivierung eines Dienstes kann dazu führen, dass Windows nicht mehr startet bzw. Sie sich nicht mehr anmelden können.

Weiteres Infos zu Diensten finden Sie im Tipp: "Windows Dienste: Allgemeine Informationen"

Achtung:

Gehen Sie beim Verändern der Einstellungen vorsichtig vor, da es dazu führen kann, dass bestimmt Funktionen unter Windows ansonsten nicht mehr laufen.

Dienstname | Enterprise
Anmeldedienst | Manuell
Anschlussumleitung für Terminaldienst im Benutzermodus | Manuell
Anwendungserfahrung | Automatisch
Anwendungsinformationen | Manuell
Anwendungsverwaltung | Manuell
Arbeitsstationsdienst | Automatisch
Aufgabenplanung | Automatisch
Automatische Konfiguration (verkabelt) | Manuell
Basisfiltermodul | Automatisch
Benachrichtigungsdienst für Systemereignisse | Automatisch
Benutzerprofildienst | Automatisch
CNG-Schlüsselisolation | Manuell
COM+-Ereignissystem | Automatisch
COM+-Systemanwendung | Manuell
Computerbrowser | Deaktiviert
DCOM-Server-Prozessstart | Automatisch
Designs | Deaktiviert
DFS-Replikation | Manuell
DHCP-Client | Automatisch
Diagnoserichtliniendienst | Automatisch
Diagnosesystemhost | Manuell
Distributed Transaction Coordinator | Automatisch (Verzögerter Start)
DNS-Client | Automatisch
Druckwarteschlange | Automatisch
Enumeratordienst für tragbare Geräte | Manuell
Erkennung interaktiver Dienste | Manuell
Extensible Authentication-Protokoll | Manuell
Funktionssuchanbieter-Host | Manuell
Funktionssuche-Ressourcenveröffentlichung | Manuell
Gatewaydienst auf Anwendungsebene | Manuell
Gemeinsame Nutzung der Internetverbindung | Deaktiviert
Geschützter Speicher | Manuell
Gruppenrichtlinienclient | Automatisch
IKE- und AuthIP IPsec-Schlüsselerstellungsmodule | Automatisch
Integritätsschlüssel- und Zertifikatverwaltung | Manuell
Intelligenter Hintergrundübertragungsdienst | Automatisch (Verzögerter Start)
IP-Hilfsdienst | Automatisch
IPsec-Richtlinien-Agent | Automatisch
Kryptografiedienste | Automatisch
KtmRm für Distributed Transaction Coordinator | Automatisch (Verzögerter Start)
Leistungsprotokolle und -warnungen | Manuell
Microsoft .NET Framework NGEN v2.0.50727_X86 | Manuell
Microsoft iSCSI-Initiator-Dienst | Manuell
Microsoft-Softwareschattenkopie-Anbieter | Manuell
Multimediaklassenplaner | Manuell
NAP-Agent (Network Access Protection) | Manuell
Netzwerklistendienst | Automatisch
Netzwerkspeicher-Schnittstellendienst | Automatisch
Netzwerkverbindungen | Manuell
NLA (Network Location Awareness) | Automatisch
Offlinedateien | Deaktiviert
Plug & Play | Automatisch
PnP-X-IP-Busauflistung | Deaktiviert
RAS-Verbindungsverwaltung | Manuell
Remoteprozeduraufruf (RPC) | Automatisch
Remoteregistrierung | Automatisch
Richtlinie zum Entfernen der Smartcard | Manuell
Routing und RAS | Deaktiviert
RPC-Locator | Manuell
Sekundäre Anmeldung | Automatisch
Server | Automatisch
Server für Threadsortierung | Manuell
Shellhardwareerkennung | Automatisch
Sicherheitskonto-Manager | Automatisch
Sitzungs-Manager für Desktopfenster-Manager | Automatisch
SL-Benutzerschnittstellen-Benachrichtigungsdienst | Manuell
Smartcard | Manuell
SNMP-Trap | Manuell
Softwarelizenzierung | Automatisch
SSDP-Suche | Deaktiviert
Superfetch | Deaktiviert
TCP/IP-NetBIOS-Hilfsdienst | Automatisch
Telefonie | Manuell
Terminaldienste | Automatisch
Terminaldienstekonfiguration | Manuell
TPM-Basisdienste | Automatisch (Verzögerter Start)
Überwachung verteilter Verknüpfungen (Client) | Automatisch
Unterstützung in der Systemsteuerung unter Lösungen für Probleme | Manuell
UPnP-Gerätehost | Deaktiviert
Verbindungsschicht-Topologieerkennungs-Zuordnungsprogramm | Manuell
Verwaltung für automatische RAS-Verbindung | Manuell
Virtueller Datenträger | Manuell
Volumeschattenkopie | Manuell
Windows Driver Foundation - Benutzermodus-Treiberframework | Manuell
Windows Installer | Manuell
Windows Modules Installer | Manuell
Windows Update | Automatisch (Verzögerter Start)
Windows-Audio | Manuell
Windows-Audio-Endpunkterstellung | Manuell
Windows-Ereignisprotokoll | Automatisch
Windows-Ereignissammlung | Manuell
Windows-Farbsystem | Manuell
Windows-Fehlerberichterstattungsdienst | Automatisch
Windows-Firewall | Automatisch
Windows-Remoteverwaltung (WS-Verwaltung) | Automatisch (Verzögerter Start)
Windows-Verwaltungsinstrumentation | Automatisch
Windows-Zeitgeber | Automatisch
WinHTTP-Web Proxy Auto-Discovery-Dienst | Manuell
WMI-Leistungsadapter | Manuell
Zertifikatverteilung | Manuell
Zugriff auf Eingabegeräte | Automatisch

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2544.htm


Programmen unterschiedliche Lautstärken zuweisen

Einzelnen Programmen unterschiedliche Lautstärken zuweisen

Ab Windows Vista ist es möglich, die Lautstärke für einzelne Programme zu konfigurieren. Sie können eine separate Lautstärke für jede Anwendung festlegen. Dadurch kann man verhindern, dass während einer Musikwiedergabe ein anderes Programm z.B. Windows ein lautes "Ping" wiedergibt.

Um das einzustellen, gehen Sie folgendermaßen vor:

  1. Öffnen Sie über einen Klick auf das Lautsprecher-Symbol (zu finden in der Taskleisten unten rechts) die Einstellung für die Lautstärke.
  2. Klicken Sie auf den Link "Mixer"
    Lautstärke
  3. Jetzt öffnet sich eine erweitere Anzeige, in der für jedes aktive Programm (Anwendung) ein extra Lautstärkeregler angezeigt wird. Mit "Windows Sounds" sind die Töne von Windows selber gemeint. Mit diesen Regler stellen Sie die Lautstärke und das Verhältnis zu den einzelnen Anwendungen ein. Diese Einstellung wird entsprechend abgespeichert.
    Lautstärke pro Anwendung

Wenn Sie später über den Lautstärkeregler die Lautstärke verändern, wird die Lautstärke der Anwendungen im gleichen Verhältnis verändert.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2569.htm


Windows 7 Versionen (Übersicht)

Von Windows 7 wird es insgesamt 6 Versionen geben. Die ersten beiden Versionen (Starter und Home Basic) sind für Schwellenländer oder die Starter Version für Notebooks vorgesehen. Diese Version werden in Deutschland nicht zum Verkauf angeboten.

Starter | Diese Version ist stark eingeschränkt und wird nur als 32-Bit Version vertrieben. Die Funktion wie Aero, Multi-Touch sind hier nicht vorhanden. Diese Version wird nur als OEM-Lizenz erhältlich sein.
Home Basic | Diese Version wird nur in einigen Schwellenländern vertrieben. Dabei handelt es sich um eine stark abgespeckte Version. Es werden nur die Basicfunktionen angeboten und keine Multimedia-Unterstützung. Der Virtuelle XP-Modus ist nicht verfügbar.
Home Premium | Diese Version ist für den privaten Anwender konzipiert.
Professional | Diese Version ist mehr für Unternehmen vorgesehen. Hier ist dann auch der virtuelle XP-Modus enthalten, so dass auch ältere Anwendungen ausgeführt werden können.
Ultimate | Diese Version enthält alle Funktion der andere Windows 7 Versionen und richtet sich an kleine Unternehmen die den Rechner privat wie auch geschäftlich benutzen wollen. Zusätzlich ist hier die Festplattenverschlüsselung BitLocker enthalten.
Enterprise | Dabei handelt es sich um ein Windows 7 Ultimate welches als Volumenlizenz vertrieben wird. Hier werden die Spiele nicht automatisch mit installiert.

Vergleich der Funktionen unter Windows 7

Funktion | Starter | Home Basic | Home Premium | Professional | Ultimate | Enterpise
Neue Taskleiste & Jump Lists | Ja | Ja | Ja | Ja | Ja | Ja
Windows Suche | Ja | Ja | Ja | Ja | Ja | Ja
HomeGroup (Heimnetzgruppe) | Ja | Ja | Ja | Ja | Ja | Ja
Schneller Benutzerwechsel | Nein | Ja | Ja | Ja | Ja | Ja
Windows Media Center | Nein | Nein | Ja | Ja | Ja | Ja
DVD Wiedergabe & Bearbeitung | Nein | Nein | Ja | Ja | Ja | Ja
Domänenverwaltung | Nein | Nein | Nein | Ja | Ja | Ja
GUI-Zugriff auf verschlüsseltes Dateisystem (EFS) | Nein | Nein | Nein | Ja | Ja | Ja
Netzwerk Sicherung | Nein | Nein | Nein | Ja | Ja | Ja
Offline Dateien | Nein | Nein | Nein | Ja | Ja | Ja
Remotedesktopverbindung | Nein | Nein | Nein | Ja | Ja | Ja
XP-Mode | Nein | Nein | Nein | Ja | Ja | Ja
Erweitertes Backup (Netzwerk & Gruppenrichtlinien) | Nein | Nein | Nein | Ja | Ja | Ja
Applocker (Ausführung von unerwünschten Programmen unterbinden über Gruppenrichtlinien (Black- & Whitelist)) | Nein | Nein | Nein | Nein | Ja | Ja
Bitlocker & BitLocker To Go | Nein | Nein | Nein | Nein | Ja | Ja
Branche Cache (SMB & HTTP(S) - benötigt R2 Server) | Nein | Nein | Nein | Nein | Ja | Ja
Direct Access (Remote-Zugriff via Server 2008) (VPN Alternative setzt IPv6 & IPsec vorraus) | Nein | Nein | Nein | Nein | Ja | Ja
Mehrsprachinge Oberfläche (Sprachpakete) | Nein | Nein | Nein | Nein | Ja | Ja
Ortsabhängiger Standarddrucker | Nein | Nein | Nein | Nein | Ja | Ja
Unix-Subysytem | Nein | Nein | Nein | Nein | Ja | Ja
VHD-Boot | Nein | Nein | Nein | Nein | Ja | Ja
Maximaler Arbeitsspeicher (32-Bit) | 4 GB* | 4 GB* | 4 GB* | 4 GB* | 4 GB* | 4 GB*
Maximaler Arbeitsspeicher (64-Bit) | - | - | 16 GB | 16 GB | 16 GB | 16 GB

* Maximal 4 GB werden unterstützt, aufgrund von System-Beschränkungen unter 32-Bit werden aber nur 3,2 GB genutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2677.htm


Windows 7 - Tauglichkeit testen

Windows 7: Tauglichkeit auf derzeitigen PC testen

Ob Ihr Rechner für Windows 7 geeignet ist, können Sie über den Update Advisor von Microsoft testen.

Dieser Windows 7 Upgrade Advisor scannt Ihr System sowie installierte Programme und Geräte und gibt Ihnen nach wenigen Minuten einen Bericht aus. Diesem können Sie entnehmen, ob der PC die Systemvoraussetzungen erfüllt, ob es mögliche Kompatibilitätsprobleme gibt und welche Upgradeoptionen zu Windows 7 bestehen.

Das Programm können auf der folgenden Webseite herunter laden:

http://www.microsoft.com/downloads/details.aspx?familyid=1B544E90-7659-4BD9-9E51-2497C146AF15&displaylang=en

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2665.htm


Windows 7 (Beta)

Windows 7 wurde unter den Codenamen "Vienna" und "Blackcomb" im Jahr 2000 angekündigt und sollte eigentlich Windows XP ablösen. Später - 2006- änderte sich der Codename von "Blackcomb" zu "Vienna" und wurde endgültig nach dem Erscheinen von Windows Vista im Februar 2007 in "Windows 7" umgeändert.

Eine erste Vorab-Version wurde am 28. Oktober 2008 an die Teilnehmer der PDC verteilt, und am 9. Januar 2009 stellte Microsoft die erste öffentliche Beta-Version zum freien Download zur Verfügung.

Die Beta und weitere Infos zu Windows 7 finden Sie auf dem Microsoft Server:

http://www.microsoft.com/germany/windows/windows-7/default.aspx

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2654.htm


Update Version auf einem neuen Rechner installieren

Sie haben eine Update-Version von Windows 7, möchten das System aber trotzdem lieber auf einem leeren Rechner installieren bzw. nicht erst vorher eine ältere Vorgängerversion von Windows einspielen.

Leider können Sie die Update-Version aber nur installieren, wenn sich ein zum Upgrade berechtigtes Windows auf der Festplatte befindet. Leider kann man nicht mehr einfach den alten Datenträger bzw. die alte Seriennummer eingeben, um Windows vom der Berechtigung des Updates zu überzeugen.

Mit einem Trick können Sie das aber umgehen:

  1. Installieren Sie Windows 7 vom Datenträger
  2. Bei der Nachfrage nach einer Seriennummer, geben Sie Nummer ein (die Seriennummer für die Update-Version würde er sowieso als ungültige Nummer abweisen)
  3. Entfernen Sie den Haken bei "Windows automatisch aktivieren..."
  4. Führen Sie die Installation bis zum Ende durch

Nachdem die Installation durchgeführt wurde, müssen wir nur noch eintragen, dass Windows als Update installiert wurde. Öffnen Sie dazu folgenden Registryeintrag:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup\ OOBE

Hier finden Sie hier den Wert mit dem Namen "MediaBootInstall" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Windows wurde als Update Installiert
1 | Windows wurde auf einem leeren System installiert

Öffnen Sie anschließend die Kommandozeile als Administrator und geben Sie folgenden Befehl ein:

=== Hier schneiden ===

slmgr -rearm

=== Hier schneiden ===

Info Zum Befehl "slmgr" finden Sie weitere Informationen im Tipp: "Windows Testzeit von 30 auf 120 Tage verlängern"

Dadurch wird die Lizenz zurückgesetzt und Sie werden anschließend aufgefordert das System neu zu starten. Nach dem Neustart, müssen Sie noch den Lizenzkey eintragen. Öffnen Sie dafür in der Systemsteuerung den Eintrag System (oder drücken Sie die beiden Tasten [Win] + [Pause]). Hier können Sie unten die Seriennummer eingeben, welche von Windows jetzt auch akzeptiert wird.

Info Dieses vorgehen dürfen Sie natürlich nur machen, wenn Sie auch eine berechtigte Update-Lizenz besitzen. Halten Sie sich dabei an die Lizenzbestimmungen von Microsoft.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2680.htm


Windows vom USB-Stick installieren

Ab Windows 7 haben Sie auch die Möglichkeit, die Installation über einen USB-Stick ausführen zu lassen. Das hat unter anderem gegenüber einer DVD Installation den Vorteil, dass die Installation schneller durchgeführt wird. Dazu müssen Sie den USB-Stick nur folgendermaßen vorbereiten:

Als erstes müssen Sie den USB-Stick bootfähig machen, wofür Sie zwei Möglichkeiten haben:

  • Microsoft Tool "Diskpart"
  • HP USB Disk Storage Format Tool <Download>

Diskpart

Hierfür müssen Sie Diskpart ab Windows Vista benutzen. Das Tool Diskpart von Windows XP kann noch nicht mit USB Geräten umgehen.

Alle vorhanden Daten auf dem Stick werden dabei gelöscht!

  • Stecken Sie das USB Gerät an den Rechner
  • Starten Sie Diskpart mit administrativen Rechten aus der Eingabeaufforderung. Geben Sie hier Diskpart ein
  • Geben Sie nun den Befehl "List Disk" damit Ihnen alle vorhanden Medien angezeigt werden. Ermitteln Sie hier die Nummer für den USB Stick.
  • Über den Befehl "select disk <Nummer>" wechseln Sie auf den Datenträger. Hat Ihr USB-Stick die Nummer 2 müssen Sie hier "select disk 2" eingeben.
  • Überprüfen Sie durch die erneute Eingabe von "select disk" ob hinter dem entsprechendem Medium ein * (Sternchen) angezeigt wird. Nur wenn das der Fall ist, werden alle weiteren Befehle auf dem richtigen Laufwerk ausgeführt.
  • Löschen Sie nun alles auf dem Stick über den Befehl "clean"
  • Erzeugen Sie eine neue primäre Partition über den Befehl "create partition primary" und aktivieren Sie anschließend diese Partition über den Befehl "active".
  • Formatieren Sie jetzt noch die neue Partition über den Befehl "format fs=fat32 quick".
  • Weisen Sie jetzt noch über den Befehl "assign" einen entsprechenden Laufwerksbuchstaben zu.
  • Jetzt können Diskpart mit dem Befehl "exit" beenden.

Als zweites müssen Sie jetzt noch die Dateien von der DVD auf den Stick kopieren. Wenn Sie ein Image benutzen, dann müssen Sie das Image entpacken. Kopieren Sie die Dateien mit dem Befehl "xcopy <Quelle>:\*.* /e /f <Ziel>:\ " rüber. Für Quelle tragen Sie den Buchstaben des DVD-Laufwerkes ein für Ziel den Buchstaben des USB-Sticks.

Wenn Sie die Dateien über den Explorer kopieren, müssen Sie sicherstellen das in den Ordneroptionen unter Ansicht die Einstellung "Alle Dateien und Ordner anzeigen" aktiviert ist. Ansonsten werden nicht alle Dateien kopiert.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2678.htm


Windows 7 Beta oder RC auf aktuelle Windows 7 Version updaten

Wenn Sie auf Ihren Rechner eine Vorabversion von Windows 7 (Beta oder RC) installiert haben, können Sie die nicht mit der finalen Version von Windows 7 aktualisieren. Ein Update ist nur für Windows Vista mit SP1 von Microsoft vorgesehen.

Wenn Sie aber schon alle Anwendungen installiert haben und Windows 7 von Ihnen eingerichtet wurde, wollen Sie sich vermutlich die Arbeit für eine ein Installation von Windows sparren und nur die aktuelle Version benutzen. Gehen Sie dafür folgendermaßen vor:

  1. Kopieren Sie den Inhalt der Windows 7 DVD auf die Festplatte in ein beliebiges Installationsverzeichnis (z.B.: Win7Setup)
  2. Wechseln Sie nach dem kopieren in das Verzeichnis "SOURCES"
  3. Öffnen Sie mit Notepad die Datei "cversion.ini"
  4. Ändern Sie hier unter [HostBuild] den Eintrag MinClient auf eine kleinere Build-Version ab, als Sie von Windows 7 installiert haben. Wenn Sie aktuell die Version 7100 benutzen, dann müssen Sie hier 7099.0 eintragen.
  5. Speichern Sie die veränderte Datei ab.

Der Inhalt der Datei sollte nun so aussehen:

=== Hier schneiden ===

[HostBuild]

MinClient=7099.0

MinServer=7100.0

=== Hier schneiden ===

Jetzt können Sie das Setup unter dem gestartete Windows 7 ausführen und können den Punkt "Update" fehlerfrei ausführen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2679.htm


Hintergrundbild der Windows Anmeldung verändern

Hier wird beschrieben, wie Sie das Hintergrundbild von der Windows Anmeldung verändern können. Wenn Sie eine OEM-Version von Windows benutzen, kann es sein das Sie hier schon ein anderes Hintergrundbild sehen, als Standardmäßig von Windows verwendet wird. Hier haben dann die Hersteller oft schon Ihr eigenes Bild eingebunden und das können Sie natürlich über ein paar Einträge in der Registry auch machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Authentication\ LogonUI\ Background

oder als Policies

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "OEMBackground" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Es wird kein Hintergrund bild angezeigt
1 | Es wird, wenn hinterlegt, ein Hintergrundbild geladen

Nachdem Sie den Wert auf 1 gesetzt haben, müssen Sie noch im Verzeichnis "%Systemroot%\system32\oobe\info\backgrounds" (wenn Die Verzeichnisse "Info" und "backgrounds" nicht vorhanden sind, müssen Sie diese Verzeichnisse entsprechend anlegen) die Grafik für das Hintergrundbild anlegen (bei %Systemroot% handelt es sich um Ihr Windows Verzeichnis, wenn Sie %Systemroot% im der Adresse oben eingeben, löst Windows den Pfadnamen automatisch auf).

Hier müssen Sie jetzt ein JPG-Bild mit den Namen "BackgroundDefault.jpg" mit einer maximalen Größe von 256 KByte ablegen. Da Bild sollte in der Größe ihrer Bildschirmauflösung erstellt sein. Weiterhin darf das Bild auch keinen anderen Namen haben, da von Windows nur nach diesem Bild in den oben angegebenen Verzeichnis gesucht wird.

Info Die Dateigröße vom Bild darf nicht größer als 256 KByte sein!

Sie können in das Verzeichnis "backgrounds" auch für verschiedene Auflösungen Dateien ablegen, die folgenden Namen sind dabei zulässig:

Dateiname | Anmerkung
backgroundDefault.jpg | Standard Bild, wird immer benutzt wenn kein extra Bild für die Auflösung vorhanden ist.
background768x1280.jpg | Für die Auflösung 786*1280
background900x1440.jpg | Für die Auflösung 900*1440
background960x1280.jpg | Für die Auflösung 960*1280
background1024x1280.jpg | Für die Auflösung 1024*1280
background1280x1024.jpg | Für die Auflösung 1280*1024
background1024x768.jpg | Für die Auflösung 1024*768
background1280x960.jpg | Für die Auflösung 1280*960
background1600x1200.jpg | Für die Auflösung 1600*1200
background1440x900.jpg | Für die Auflösung 1440*900
background1920x1200.jpg | Für die Auflösung 1920*1200
background1280x768.jpg | Für die Auflösung 1280*768
background1360x768.jpg | Für die Auflösung 1360*768

Das Bild "backgroundDefault.jpg" wird also geladen, wenn für die Auflösung kein Bild gefunden wird und automatisch auf die Bildgröße erweitert.

Info Ist das Bild zu gross oder kann nicht geladen werden, wird automatisch das original Bild aus der Datei imageres.dll geladen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\System\Anmelden
Einstellungsname: | Immer benutzerdefinierten Anmeldehintergrund verwenden

Zusätzlich können Sie noch das Aussehen des Anmeldebuttons verändern

Hier können Sie einstellen, wie der Button und der Text aussehen soll. Je nach Hintergrundbild und Farben ist der eine oder andere Buttontyp besser zu lesen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Authentication\ LogonUI

Erstellen Sie hier einen neuen Wert mit dem Namen "ButtonSet" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Heller Text Schatten (Windows Standard)
2 | Etwas dunklerer Text Schatten mit leicht lichtdurchlässigen Button
3 | Normaler Text ohne Schatten mit lichtduchlässigen Button (für sehr dunkle Hintergründe).

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2685.htm


Icon für Bildschirmtastatur auf dem Anmeldebildschirm ein-/ausblenden

Mit dieser Einstellung, können Sie die Bildschirmtastatur auf dem Anmeldebildschirm anzeigen lassen. Dafür müssen Sie den folgenden Registryeintrag verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Authentication\ LogonUI

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowTabletKeyboard" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Bildschirmtastatur nicht anzeigen
1 | Bildschirmtastatur anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2687.htm


Windows Dienste: ActiveX-Installer (AxInstSV)

Der Dienst "AxInstSV" wird für die Installation von ActiveX-Steuerelementen aus dem Internet benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | ActiveX-Installer (AxInstSV)
Dienstname | AxInstSV
Windows Beschreibung | Bietet eine Bewertung der Benutzerkontensteuerung für die Installation von ActiveX-Steuerelementen aus dem Internet und ermöglicht die Verwaltung der ActiveX-Steuerelementinstallation basierend auf Gruppenrichtlinieneinstellungen. Dieser Dienst wird bei Bedarf gestartet. Bei Deaktivierung wird die Installation der ActiveX-Steuerelemente gemäß den Standardbrowsereinstellungen ausgeführt.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ AxInstSV

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2689.htm


Windows Dienste: Adaptive Helligkeit

Der Dienst "SensrSvc" passt die Helligkeit der Anzeige der Umgebungshelligkeit an, wenn ein entsprechender Sensor vorhanden ist. Wenn Sie keinen Sensor haben, können Sie diesen Dienst auch deaktivieren.

Gültig für: Alle Windows 7 Versionen (außer Starter)

Allgemeine Informationen
Anzeigename | Adaptive Helligkeit
Dienstname | SensrSvc
Windows Beschreibung | Überwacht Umgebungslichtsensoren, um Änderungen im Umgebungslicht zu erkennen und die Helligkeit der Anzeige anzupassen. Wird dieser Dienst beendet oder deaktiviert, wird die Anzeigehelligkeit nicht auf die Lichtbedingungen der Umgebung angepasst.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SensrSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2690.htm


Übersicht der Dienste unter Windows 7

Hier finden Sie eine Übersicht der Dienste unter Windows 7 und wie diese konfiguriert sind.

Lesen Sie sich immer die Beschreibung des Dienstes durch und überlegen Sie, ob diese Funktion benötigt wird. Es gibt einige Dienste, die zwingend für das Funktionieren von Windows benötigt werden.

Achtung: Eine Deaktivierung eines Dienstes kann dazu führen, dass Windows nicht mehr startet bzw. Sie sich nicht mehr anmelden können.

Weiteres Infos zu Diensten finden Sie im Tipp: "Windows Dienste: Allgemeine Informationen"

Achtung: Gehen Sie beim Verändern der Einstellungen vorsichtig vor, da es dazu führen kann, dass bestimmt Funktionen unter Windows nicht mehr laufen.

Wir geben zwei Empfehlungen in der Tabelle an:

  • Empfehlung Normal: Hier werden nur wenige Dienste verändert. Diese Konfiguration sollte auf den meisten Rechnern zu keinen Problemen führen und keine wichtigen Funktionen einschränken.
  • Empfehlung Minimal: In dieser Einstellungen werden schon recht viele Dienste ausgeschaltet. Es stehen nicht mehr viele Funktionen zur Verfügung. Dieses Einstellung ist für Anwender geeignet, die mit dem Rechner nur spielen wollen und dafür jede zusätzliche Leistung benötigen.

Dienstname | Starter | Home Basic | Home Premium | Professional | Enterprise | Ultimate | Empfehlung Normal | Empfehlung Minimal
ActiveX-Installer (AXInstSV) | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Adaptive Helligkeit | - | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Anmeldedienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Anmeldeinformationsverwaltung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Anschlussumleitung für Remotedesktopdienst im Benutzermodus | - | - | - | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Anwendungserfahrung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Anwendungsidentität | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Anwendungsinformationen | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Anwendungsverwaltung | - | - | - | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Arbeitsstationsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Aufgabenplanung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Automatische Konfiguration (verkabelt) | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Automatische WLAN-Konfiguration | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Basisfiltermodul | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Benachrichtigungsdienst für Systemereignisse | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Benutzerprofildienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
BitLocker-Laufwerksverschlüsseldungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Blockebenen-Sicherungsmodul | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Bluetooth-Unterstützungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
BranchCache | - | - | - | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
CNG-Schlüsselisolation | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
COM+-Ereignissystem | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
COM+-Systemanwendung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Computerbrowser | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
DCOM-Server-Prozessstart | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Defragmentierung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Designs | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
DHCP-Client | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Diagnoesediensthost | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Diagnoserichtliniendienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Manuell | Deaktiviert
Diagnosesystemhost | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Distributed Transaction Coordinator | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
DNS-Client | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Druckwarteschlange | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Enumeratordienst für tragbare Geräte | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Erkennung interaktiver Dienste | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Extensible Authentication-Protokoll | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Fax | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Funktionssuchanbieter-Host | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Funktionssuche-Ressourcenveröffentlichung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Gatewaydienst auf Anwendungsebene | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Gemeinsame Nutzung der Internetverbindung | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Geschützter Speicher | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Gruppenrichtlinienclient | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Heimnetzgruppen-Anbieter | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Heimnetzgruppen-Listener | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
IKE- und AuthIP IPsec-Schlüsselerstellungsmodule | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Integritätsschlüssel- und Zertifikatverwaltung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Intelligenter Hintergrundübertragungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
IP-Hilfsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
IPsec-Richtlinien-Agent | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Konfiguration für Remotedesktops | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Kryptografiedienste | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
KtmRm für Distributed Transaction Coordinator | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Leistungsprotokolle und -warnungen | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Media Center Extender-Dienst | - | - | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Microsoft .NET Framework NGEN v2.0.50727_X86 | Manual | Manuell | Manuell | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell | Manuell | Manuell
Microsoft iSCSI-Initiator-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Microsoft-Softwareschattenkopie-Anbieter | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Multimediaklassenplaner | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
NAP-Agent (Network Access Protection) | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Net.Tcp-Portfreigabedienst | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Netzwerklistendienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Netzwerkspeicher-Schnittstellendienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Netzwerkverbindungen | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
NLA (Network Location Awareness) | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Offlinedateien | - | - | - | Automatisch | Automatisch | Deaktiviert | Deaktiviert | Deaktiviert
Parental Controls | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert |
Peer Name Resolution-Protokoll | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Peernetzwerk-Gruppenzuordnung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Peernetzwerkidentitäts-Manager | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Plug & Play | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
PnP-X-IP-Busauflistung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
PNRP-Computernamenveröffentlichungs-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Programmkompatibilitäts-Assistent-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
RAS-Verbindungsverwaltung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Remotedesktopdienste | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Remoteprozeduraufruf (RPC) | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Remoteregistrierung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Richtlinie zum Entfernen der Smartcard | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Routing und RAS | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
RPC-Endpunktzuordnung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
RPC-Locator | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Sekundäre Anmeldung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Server | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Server für Threadsortierung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Shellhardwareerkennung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Sicherheitscenter | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell | Deaktiviert
Sicherheitskonto-Manager | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Sitzungs-Manager für Desktopfenster-Manager | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Smartcard | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
SNMP-Trap | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Software Protection | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
SPP-Benachrichtigungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
SSDP-Suche | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
SSTP-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Stromversorgung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Superfetch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Tablet PC-Eingabedienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
TCP/IP-NetBIOS-Hilfsdienst | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Telefonie | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
TPM-Basisdienste | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Überwachung verteilter Verknüpfungen (Client) | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert | Deaktiviert
Unterstützung in der Systemsteuerung unter Lösungen für Probleme | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
UPnP-Gerätehost | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Verbessertes Windows-Audio/Video-Streaming | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Verbindungsschicht-Topologieerkennungs-Zuordnungsprogramm | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Verschlüsselndes Dateisystem (EFS) | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Verwaltung für automatische RAS-Verbindung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Virtueller Datenträger | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Volumeschattenkopie | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Webclient | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows CardSpace | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Defender | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Deaktiviert
Windows Driver Foundation - Benutzermodus-Treiberframework | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Installer | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell
Windows Media Center-Empfängerdienst | - | - | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Media Center-Planerdienst | - | - | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Media Player-Netzwerkfreigabedienst | Manuell | Manuell | Automatisch | Automatisch | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows Modules Installer | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Presentation Foundation-Schriftartcache 3.0.0.0 | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows Search | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Deaktiviert | Deaktiviert
Windows Update | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Automatisch (Verzögerter Start) | Manuell
Windows-Audio | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Audio-Endpunkterstellung | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Bilderfassung (WIA) | Manual | Manual | Manual | Manual | Manual | Manual | Manual | Deaktiviert
Windows-Biometriedienst | Manual | Manual | Manual | Manual | Manual | Manual | Deaktiviert | Deaktiviert
Windows-Dienst für Schriftencache | Manual | Manual | Manual | Manual | Manual | Manual | Manual | Manual
Windows-Ereignisprotokoll | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Windows-Ereignissammlung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Farbsystem | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Fehlerberichterstattungsdienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Firewall | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Deaktiviert
Windows-Remoteverwaltung (WS-Verwaltung) | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Windows-Sicherung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows-Sofortverbindung - Konfigurationsregistrierungsstelle | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
Windows-Verwaltungsinstrumentation | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch | Automatisch
Windows-Zeitgeber | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
WinHTTP-Web Proxy Auto-Discovery-Dienst | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
WMI-Leistungsadapter | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert
WWAN-automatische Konfiguration | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Zertifikatverteilung | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert
Zugriff auf Eingabegeräte | Manuell | Manuell | Manuell | Manuell | Manuell | Manuell | Deaktiviert | Deaktiviert

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2668.htm


Windows Dienste: Anmeldeinformationsverwaltung

Der Dienst "VaultSvc" ist für das Speichern und Abrufen von Anmeldeinformationen zuständig.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Anmeldeinformationsverwaltung
Dienstname | VaultSvc
Windows Beschreibung | Ermöglicht das sichere Speichern und Abrufen von Anmeldeinformationen für Benutzer, Anwendungen und Sicherheitsdienstpakete.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | Windows-Biometriedienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ VaultSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2691.htm


Windows Dienste: Anwendungsidentität

Der Dienst "AppIDSvc" wird für die Bestimmung er Identität einer Anwendung benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Anwendungsidentität
Dienstname | AppIDSvc
Windows Beschreibung | Bestimmt und überprüft die Identität einer Anwendung. Durch Deaktivierung dieses Diensts wird verhindert, dass AppLocker erzwungen wird.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Anwendungs-ID-Treiber; Kyptografiedienste; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ AppIDSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2692.htm


Windows Dienste: BitLocker-Laufwerkverschlüsselungsdienst

Der Dienst "BDESVC" wird für die BitLocker-Laufwerksverschlüsselung benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | BitLocker-Laufwerkverschlüsselungsdienst
Dienstname | BDESVC
Windows Beschreibung | BDESVC hostet den BitLocker-Laufwerkverschlüsselungsdienst. Die BitLocker-Laufwerkverschlüsselung ermöglicht einen sicheren Start des Betriebssystems sowie eine vollständige Volumeverschlüsselung für Betriebssystemvolumes, eingebaute Volumes oder austauschbare Volumes. Mithilfe dieses Diensts können Benutzer durch BitLocker aufgefordert werden, bei der Bereitstellung von Volumes verschiedene Aktionen auszuführen. Erfolgt keine Benutzeraktion, werden die Volumes automatisch gesperrt. Darüber hinaus werden Wiederherstellungsinformationen in Active Directory gespeichert, sofern verfügbar. Zudem wird mit dem Dienst sichergestellt, dass die aktuellsten Wiederherstellungszertifikate verwendet werden. Wenn der Dienst deaktiviert oder beendet wird, können Benutzer diese Funktionen nicht mehr nutzen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ BDESVC

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2693.htm


Windows Dienste: Blockebenen-Sicherungsmodul

Der Dienst "wbengine" wird für die Windows Sicherung- und Wiederherstellung benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Blockebenen-Sicherungsmodul
Dienstname | wbengine
Windows Beschreibung | Der WBENGINE-Dienst wird von der Windows-Sicherung verwendet, um Sicherungs- und Wiederherstellungsvorgänge auszuführen. Wenn dieser Dienst vom Benutzer beendet wird, kann beim derzeit ausgeführten Sicherungs- und Wiederherstellungsvorgang ein Fehler auftreten. Wenn dieser Dienst deaktiviert wird, werden die Sicherungs- und Wiederherstellungsvorgänge auf diesem Computer, für die die Windows-Sicherung verwendet wird, möglicherweise deaktiviert.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ wbengine

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2694.htm


Windows Dienste: Bluetooth-Unterstützungsdienst

Der Dienst "bthserv" wird für die Zuordnung von Remote-Blutooth-Geräten benötigt. Da die wenigsten Leute mit Remote-Blutooth Geräten arbeiten, kann der Dienst deaktiviert werden.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Bluetooth-Unterstützungsdienst
Dienstname | bthserv
Windows Beschreibung | Die Erkennung und Zuordnung von Remote-Bluetooth-Geräten wird vom Bluetooth-Dienst unterstützt. Wird der Dienst beendet oder deaktiviert, funktionieren bereits installierte Bluetooth-Geräte möglicherweise nicht mehr ordnungsgemäß, und neue Geräte werden unter Umständen nicht mehr erkannt oder zugeordnet.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ bthserv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2695.htm


Windows Dienste: BranchCache

Der Dienst "PeerDistSvc" speichert Netzwerkinhalte von lokalen Subnetzen zwischen. In den meisten Fällen wir dieser Dienst nicht benötigt

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | BranchCache
Dienstname | PeerDistSvc
Windows Beschreibung | Mit diesem Dienst werden Netzwerkinhalte von Peers im lokalen Subnetz zwischengespeichert.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | HTTP
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ PeerDistSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2696.htm


Windows Dienste: Defragmentierung

Der Dienst "defragsvc" wird für die Defragmentierung der Laufwerke benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Defragmentierung
Dienstname | defragsvc
Windows Beschreibung | Stellt Funktionen zur Datenträgerfragmentierung bereit.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ defragsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2697.htm


Windows Dienste: Diagnosediensthost

Der Dienst "WdiServiceHost" wird für Analysen benötigt, die als lokaler Dienst laufen müssen.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Diagnosediensthost
Dienstname | WdiServiceHost
Windows Beschreibung | Der Diagnosediensthost wird vom Diagnoserichtliniendienst als Host für Diagnosen verwendet, die im Kontext eines lokalen Diensts ausgeführt werden müssen. Wird dieser Dienst beendet, funktionieren alle davon abhängigen Diagnosen nicht mehr ordnungsgemäß.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WdiServiceHost

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2698.htm


Windows Dienste: Heimnetzgruppen-Anbieter

Der Dienst "HomeGroupProvider" wird für die Unterstützung der Konfiguration von Netzwerken benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Heimnetzgruppen-Anbieter
Dienstname | HomeGroupProvider
Windows Beschreibung | Führt Netzwerkaufgaben bezüglich der Konfiguration und Wartung von Heimnetzgruppen aus. Wenn dieser Dienst beendet oder deaktiviert wird, kann der Computer andere Heimnetzgruppen nicht erkennen, und Ihre Heimnetzgruppe kann möglicherweise nicht ordnungsgemäß ausgeführt werden. Es wird empfohlen, diesen Dienst weiterhin auszuführen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Funktionssuchanbieter-Host; Funktionssuche-Ressourcenveröffentlichung; Netzwerklistendienst
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ HomeGroupProvider

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2699.htm


Windows Dienste: Heimnetzgruppen-Listener

Der Dienst "HomeGroupListener" wird für die Zuordnung und Konfiguration von Netzwerken benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Heimnetzgruppen-Listener
Dienstname | HomeGroupListener
Windows Beschreibung | Nimmt Änderungen am lokalen Computer vor, die der Konfiguration und der Wartung des Computers zugeordnet sind, der einer Heimnetzgruppe angehört. Wenn der Dienst angehalten oder deaktiviert wird, kann der Computer nicht wie vorgesehen in einer Heimnetzgruppe verwendet werden, und die Heimnetzgruppe kann möglicherweise ebenfalls nicht ordnungsgemäß verwendet werden. Es empfiehlt sich, den Dienst weiterhin auszuführen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Server
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ HomeGroupListener

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2700.htm


Windows Dienste: Konfiguration für Remotedesktops

Der Dienst "SessionEnv" wird für die Konfiguration und Verwaltung von Remotedesktop benötigt. Diese Funktion wird von den meisten Leuten nicht benötigt, deshalb kann der Dienst deaktiviert werden.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Konfiguration für Remotedesktops
Dienstname | SessionEnv
Windows Beschreibung | Der Remotedesktop-Konfigurationsdienst (RDCS, Remote Desktop Configuration Service) ist für alle Konfigurations- und Sitzungsverwaltungsaktivitäten im Zusammenhang mit den Remotedesktopdiensten und Remotedesktop zuständig, die den SYSTEM-Kontext erfordern. Dazu gehören die sitzungsspezifischen temporären Ordner, Remotedesktopthemen und Remotedesktopzertifikate.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Arbeitsstationsdienst; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SessionEnv

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2701.htm


Windows Dienste: Media Center Extender-Dienst

Der Dienst "Mcx2Svc" wird für die Installation von ActiveX-Steuerelementen aus dem Internet benötigt.

Gültig für: Windows 7 ab Home Premium

Allgemeine Informationen
Anzeigename | Media Center Extender-Dienst
Dienstname | Mcx2Svc
Windows Beschreibung | Ermöglicht Media Center Extender-Geräten, den Computer zu suchen und eine Verbindung mit diesem herzustellen.
Windows Starttyp | Deaktiviert
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Funktionssuchanbieter-Host; PnP-X-IP-Busenumerator; Remotedesktopdienste; SSDP-Suche
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Mcx2Svc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2702.htm


Windows Dienste: Parental Controls

Der Dienst "WPCSvc" wird für die Jugendschutzfunktion benötigt und wird nur aus Kompatibilitätsgründen bereitgestellt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Parental Controls
Dienstname | WPCSvc
Windows Beschreibung | Dieser Dienst ist ein Stub für die Windows-Jugendschutzfunktion, der unter Vista vorhanden war. Er wird nur zu Zwecken der Abwärtskompatibilität bereitgestellt.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WPCSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2703.htm


Windows Dienste: Remotedesktopdienste

Der Dienst "TermService" wird für die "schnelle Benutzerumschaltung", "Remoteunterstützung" und "Remotedesktop" benötigt, wenn andere über das Netzwerk auf den Rechner zugreifen wollen.

Durch die Terminaldienste können sich Benutzer über das Netzwerk mit den Rechner verbinden und mit dem Rechner arbeiten als wenn man sich direkt am Rechner angemeldet hat.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Remotedesktopdienste Alter Name: Terminaldienste
Dienstname | TermService
Windows Beschreibung | Ermöglicht Benutzern das Herstellen einer interaktiven Verbindung mit einem Remotecomputer. Remotedesktop und Remotedesktop-Hostserver können nur zusammen mit diesem Dienst verwendet werden. Wenn Sie die Remoteverwendung dieses Computers verhindern möchten, deaktivieren Sie die Kontrollkästchen auf der Registerkarte "Remote" in den Systemsteuerungsoptionen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufeuf (RPC); Terminal-Gerätetreiber
Wird benötigt | Anschlussumleitung für Terminaldienst im Benutzermodus; Media Center Extender-Dienst
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ TermService

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2704.htm


Windows Dienste: RPC-Endpunktzuordnung

Der Dienst "RpcEptMapper" wird für die RPC-Auflösung (Remote Procedure Call) benötigt benötigt. Die Einstellung sollte nicht verändert werden.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | RPC-Endpunktzuordnung
Dienstname | RpcEptMapper
Windows Beschreibung | Löst RPC-Schnittstellen-IDs für den Transport von Endpunkten auf. Wenn dieser Dienst angehalten oder deaktiviert wird, können Programme, für die Remoteprozeduraufruf-Dienste (Remote Procedure Call, RPC) verwendet werden, nicht ordnungsgemäß ausgeführt werden.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | Remoteprozeduraufruf (RPC)
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ RpcEptMapper

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2705.htm


Windows Dienste: Software Protection

Der Dienst "sppsvc" wird für die Verwaltung von digitalen Lizenzen benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Software Protection
Dienstname | sppsvc
Windows Beschreibung | Aktiviert das Herunterladen, die Installation und die Durchsetzung digitaler Lizenzen für Windows und Windows-Anwendungen. Wenn der Dienst deaktiviert wird, werden das Betriebssystem und lizenzierte Anwendungen in einem Benachrichtigungsmodus ausgeführt. Es wird dringend empfohlen, den Softwareschutzdienst nicht zu deaktivieren.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ sppsvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2706.htm


Windows Dienste: SPP-Benachrichtigungsdienst

Der Dienst "sppuinotify" wird für die Softwarelizenzverwaltung benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | SPP-Benachrichtigungsdienst
Dienstname | sppuinotify
Windows Beschreibung | Stellt Softwarelizenzaktivierung und -benachrichtigung zur Verfügung
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | COM+-Ereignissystem
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ sppuinotify

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2707.htm


Windows Dienste: SSTP-Dienst

Der Dienst "SstpSvc" stellt SSTP (Secure Socket Tunneling-Protokoll) für VPN-Verbindungen zu verfügung.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | SSTP-Dienst
Dienstname | SstpSvc
Windows Beschreibung | Unterstützt SSTP (Secure Socket Tunneling-Protokoll), um über VPN eine Verbindung mit Remotecomputern herzustellen. Wenn dieser Dienst deaktiviert ist, können Benutzer SSTP nicht für den Zugriff auf Remoteserver verwenden.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | RAS-Verbindungsverwaltung
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ SstpSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2708.htm


Windows Dienste: Stromversorgung

Der Dienst "Power" wird für die Verwaltung der Energierichtlinien benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Stromversorgung
Dienstname | Power
Windows Beschreibung | Verwaltet die Energierichtlinie und die Zustellung der Energierichtlinienbenachrichtigung.
Windows Starttyp | Automatisch
Empfehlung Starttyp | Automatisch
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Power

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2709.htm


Windows Dienste: Verschlüsselndes Dateisystem (EFS)

Der Dienst "EFS" wird für die Dateiverschlüsselung auf NTFS-Laufwerken benötigt. Wenn Sie keine Verschlüsselung benutzen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Verschlüsselndes Dateisystem (EFS)
Dienstname | EFS
Windows Beschreibung | Stellt die Kerntechnologie für die Dateiverschlüsselung dar, die zum Speichern von verschlüsselten Dateien auf NTFS-Dateisystemvolumes verwendet wird. Wenn dieser Dienst angehalten oder deaktiviert wird, können Anwendungen nicht auf verschlüsselte Dateien zugreifen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ EFS

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2710.htm


Windows Dienste: Windows Defender

Der Dienst "WinDefend" wird für den Schutz gegen Spyware benötigt

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Windows Defender
Dienstname | WinDefend
Windows Beschreibung | Schutz gegen Spyware und möglicherweise unerwünschte Software
Windows Starttyp | Automatisch (Verzögerter Start)
Empfehlung Starttyp | Automatisch (Verzögerter Start)
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WinDefend

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2711.htm


Windows Dienste: Windows Search

Der Dienst "WSearch" wird für die Indizierung der Suchfunktion benötigt. Wenn Sie die Windows Suche nicht verwenden, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Windows Search
Dienstname | WSearch
Windows Beschreibung | Stellt Inhaltsindizierung und Eigenschaftenzwischenspeicherung und Suchergebnisse für Dateien, E-Mails und andere Inhalte bereit.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WSearch

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2712.htm


Windows Dienste: Windows-Biometriedienst

Der Dienst "WbioSrvc" wird für den Zugriff auf biometrische Daten benötigt. Wenn Sie diese Funktion nicht benötigen, können Sie den Dienst deaktivieren.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Windows-Biometriedienst
Dienstname | WbioSrvc
Windows Beschreibung | Mit dem Windows-Biometriedienst können in Clientanwendungen biometrische Daten erfasst, verglichen, geändert und gespeichert werden, ohne dass ein direkter Zugriff auf biometrische Hardware oder Proben erfolgt. Der Dienst wird in einem privilegierten SVCHOST-Prozess gehostet.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | Anmeldeinformationsverwaltung; Remoteprozeduraufruf (RPC); Windows Driver Foundation - Benutzermodus-Treiberframework
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WbioSrvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2713.htm


Windows Dienste: Windows-Dienst für Schriftartencache

Der Dienst "FontCache" wird für die Speicherung von Schriften benötigt um den Zugriff zu beschleunigen.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | Windows-Dienst für Schriftartencache
Dienstname | FontCache
Windows Beschreibung | Optimiert die Leistung von Anwendungen durch Speichern häufig verwendeter Schriftartendaten. Dieser Dienst wird von Anwendungen gestartet, wenn er nicht bereits ausgeführt wird. Er kann deaktiviert werden, dadurch wird jedoch die Leistung von Anwendungen herabgesetzt.
Windows Starttyp | Manuell
Empfehlung Starttyp | Manuell
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | keine Abhängigkeiten
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ FontCache

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2714.htm


Windows Dienste: WWAN - automatische Konfiguration

Der Dienst "WwanSvc" wird für die Erleichterung der Benutzung von mobilen Breitbandgeräten benötigt.

Gültig für: Alle Windows 7 Versionen

Allgemeine Informationen
Anzeigename | WWAN - automatische Konfiguration
Dienstname | WwanSvc
Windows Beschreibung | Mit dem Dienst werden mobile Breitbanddatenkarten (GSM & CDMA)/ eingebettete Moduladapter und Verbindungen durch die automatische Konfiguration der Netzwerke verwaltet. Die Ausführung des Diensts wird aus Gründen der Benutzerfreundlichkeit mobiler Breitbandgeräte dringend empfohlen.
Windows Starttyp | Manuell
Empfehlung Starttyp | Deaktiviert
Gibt an, welche Dienste benötigt werden oder welche Dienste von diesem Dienst abhängig sind
Benötigt | NDIS Usermode I/O Protokol; NLA (Network Location Awareness); Plug &Play; Remoteprozeduraufruf (RPC)
Wird benötigt | keine Abhängigkeiten
Registrypfad vom Dienst (Beschreibung: "Dienste und Geräte unter Windows")
Pfad | HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WwanSvc

Info Grundlegende Informationen über die Dienste und der Registrykonfiguration finden Sie im Tipp: Windows Dienste: Allgemeine Informationen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2715.htm


Aero Peek Vorschauzeit verändern

Die neue Funktion "Aero Peek" zeigt bei einem Mouseover über Programmeinträge in der Taskleiste Vorschaubilder & Jumplisten an.

Windows wartet dabei Standardmäßig 500 Millisekunden bis das Vorschaubild eingeblendet wird. Wenn Ihnen diese Zeit zu lang oder zu kurz ist, können Sie den Wert über die Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced

Erstellen Sie hier einen neuen Wert mit dem Namen "DesktopLivePreviewHoverTime" als Datentyp REG_DWORD und geben Sie die Wartezeit (Delay) in Millisekunden als Dezimalwert an.

Standardmäßig steht der Wert dezimal auf 500 (1f4 Hex).

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2681.htm


Alte Sucheinträge aus der Suchleiste entfernen

Über die linke Maustaste, können Sie sich m Eingabefeld der Suchleiste alle alten Suchbegriffe anzeigen lassen, die schon mal eingegeben wurden.

Aus der angezeigten Liste, können Sie durch einzelne Einträge über die ENTF-Taste löschen. Dazu zeigen Sie mit den Mauszeiger auf den Eintrag und drücken dann die ENTF-Taste. Wenn Sie alle Einträge löschen wollen, können Sie das auch über die Registry machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer

finden Sie den Schlüssel "WordWheelQuery". Unterhalb des Schlüssels sind die Suchbegriffe aufgeführt. Wenn Sie den Schlüssel löschen, werden alle Suchbegriffe entfernt. Der Schlüssel wird bei der Eingabe von neuen Suchbegriffen wieder automatisch angelegt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2676.htm


ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Mit diesem Tipp können Sie die Pixelstruktur für die Schriftglättung konfigurieren. Microsoft hat die "ClearType Technology" eingeführt, um die Lesbarkeit bei LCD Displays zu verbessern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Control Panel\ Desktop

Erstellen Sie hier einen neuen Wert mit dem Namen "FontSmoothingType" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Standard-LCD-Monitor
2 | Extra-LCD-Monitor

Welchen Wert Sie benutzen müssen hängt davon ab, welcher Monitortyp zum Einsatz kommt. Bei den meisten Monitoren (Standard-LCD-Monitor) sind die Monitorpixel im RGB-Format angeordnet (3 schmale Streifen in der Reihenfolge Rot, Grün, Blau). Sehr viel seltendern (Extra-LCD-Monitor) sind Monitore, welche die BGR-Reihenfolge benutzen (3 schmale Streifen in der Reihenfolge Blau, Grün, Rot). Wenn Sie so einen Monitor besitzen, müssen Sie die Einstellung auf 2 setzen, ansonsten ist in den meisten Fällen 1 als Wert einzutragen.

Diese Einstellung hat nur bei der farbigen Schriftglättung (FontSmoothingType = 2 - siehe dazu Tipp "ClearType: Art der Kantenglättung und Schriftglättung") eine Auswirkung.

Info Siehe dazu auch Tipp:
"Weichzeichnen" für die Schrift aktivieren
Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren
ClearType: Art der Kantenglättung und Schriftglättung
ClearType: Helligkeit der Farbtöne für die Schriftglättung

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=294851

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2684.htm


Bildqualität: Lesbarkeit von texten verbessern und Farbwiedergabe kalibrieren

In diesem Tipp wird beschrieben, wie Sie die Lesbarkeiten von texten verbessern und die Farbwiedergabe kalibrieren können.

In Windows gibt es ein paar versteckte Tools, mit denen Sie Einstellungen am System vornehmen können. Um diese Programme zu starten, geben Sie einfach unter "Start" -> "Programme/Dateien durchsuchen" den entsprechenden Programmnamen ein. Mit den hier vorgestellten Programmen, können Sie die Bildqualität verbessern, was gerade sehr hilfreich ist, wenn Sie einen externen Projektor oder Monitor angeschlossen haben.

ClearType Funktion

Mit dem Tool "cttune" (ClearType Text Tunig) können Sie die Darstellung von texten verbessern. Wenn Sie das Tool starten, können Sie mit Hilfe eines Assistenten die Darstellung konfigurieren.

Mit der ClearType Funktion soll die Lesbarkeit auf den LCD Flachbildschirmen verbesser werden.

Diese Einstellungen sind eigentlich nichts neues und können jetzt nur über das Tool leichter konfiguriert werden, Die entsprechenden Registryeinträge wurden schon in den folgenden Tipps beschrieben:

  • "Weichzeichnen" für die Schrift aktivieren
  • ClearType: Art der Kantenglättung und Schriftglättung
  • ClearType: Helligkeit der Farbtöne für die Schriftglättung
  • ClearType: Art der Pixelstruktur für Schriftglättung festlegen

Farbwiedergabe kalibrieren

Mit dem Tool "dccw" (Display Color Calibration) kalibrieren Sie die Farbwiedergabe. Nach dem Aufrufen des Tools startet ein Assistenten der Sie durch die Konfiguration führt. Gerade wenn Sie viel mit Bildern arbeiten, kann diese Einstellung dafür sorgen, dass die echten Farben angezeigt werden.

Wenn Sie einen anderen Monitor an Ihren Rechner anschließen, müssen Sie die Einstellungen erneut durchführen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2682.htm


Liste aller Optionen der Systemsteuerung

Mit diesem Tipp können Sie sich eine Liste aller Optionen der Systemsteuerung erstellen lassen.

Gerade wenn man sich mal einen Überblick über die möglichen Einstellung der Systemsteuerung verschaffen möchte, ist das durch die Sortierung in Unterordner doch recht umständlich.

An Windows 7 können Sie sich über einen Trick einen Ordner erstellen, der bei öffnen eine Liste aller Möglichkeiten enthält.

Erstellen Sie dazu einen Ordner an einer beliebigen Stelle, hier im Beispiel machen wir das auf dem Desktop. Sie können den Ordner aber auch im Startmenü oder an einer anderen beliebigen Stelle anlegen.

Klicken Sie mit der rechten Maustaste bei Desktop auf die rechte freie Fläche und wählen Sie aus dem Kontextmenü den Eintrag "Neu" -> "Ordner" aus.

Geben Sie den Ordner anschließend folgenden Namen: "Konfiguration.{ED7BA470-8E54-465E-825C-99712043E01C}" und bestätigen Sie die Eingabe mit Enter. Sie können den Namen des Ordners bis zum Punkt frei wählen (hier wurde Konfiguration verwendet), alles nach dem Punkt muss genau so eingegeben werden (am besten kopieren).

Anschließend wird der neue Ordner angelegt und er bekommt automatisch das Icon der Systemsteuerung zugewiesen.

Wenn Sie jetzt diesen Ordner öffnen, erhalten Sie eine Liste aller Einstellungen der Systemsteuerung:

Wie Sie sehen bei dieser Windows 7 Version sind das 274 Einstellungen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2716.htm


Fehlermeldung: "Internet Explorer funktioniert nicht mehr"

Stürzt der Windows Internet Explorer öfter mit der Fehlermeldung "Internet Explorer funktioniert nicht mehr" ab, kann das an fehlerhaften Add-Ons liegen.

Um den Fehler zu suchen und zu beheben gehen Sie folgendermaßen vor:

Unter "Systemsteuerung" -> "System und Sicherheit" -> "Wartungscenter" hier auf "Problembehandlung" klicken. Im neuen Fenster klicken Sie jetzt auf "Programme", wodurch eine Liste von Anwendungen angezeigt wird. Hier wählen Sie unter "Webbrowser" den Eintrag "Leistung von Internet Explorer" aus.

Es startet jetzt ein Assistent, der Sie durch die Überprüfung der entsprechenden Anwendung führt. Dabei wird ein Check durchgeführt und die Probleme werden behoben. Meist liegt es an gewissen add-ons, welche den Internet Explorer zum Absturz bringen.

Nach dem deaktivieren der add-ons dürfte der Fehler nicht mehr auftreten, oft läuft der Internet Explorer anschließend auch wieder schneller., da die Fehlerhaften add-ons den Internet Explorer ausbremsen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2686.htm


Dialog: 'Speichern' oder 'Ausführen' kommt nicht mehr

Standardmäßig fragen Programme wie der Internet Explorer oder Outlook Express beim Herunterladen einer EXE-Datei nach, ob diese geöffnet oder gespeichert werden soll.

Deaktiviert man die Option "Öffnen von Dateien dieses Typs immer bestätigen", gibt es keinen normalen Weg, diesen Dialog wieder zu bekommen und der IE startet die EXE-Dateien ohne Nachfrage nach dem Download.

Zum Reaktivieren der Nachfrage gehen Sie folgendermaßen vor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ Exefile\

ändern Sie hier den Eintrag "EditFlags", hier steht als Wert zur Zeit "d8 07 01 00", ändern Sie diesen Eintrag auf "d8 07 00 00" und schon ist die Abfrage wieder da.

Bei anderen Dateitypen müssen Sie unter den entsprechenden Dateitypen nachschauen. Bei DOC-Dateien währe das unter "Word.Document.8"

Info Zuständig dafür, dass der Eintrag ohne Nachfrage geöffnet wird, ist das 3 Byte, welches einfach nur auf 00 gesetzt werden muss. Alle anderen Stellen haben andere Bedeutungen und sollten nicht geändert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0696.htm


Die unter "Uninstall" angezeigten Programme

Die in der "Systemsteuerung" -> "Software" unter "Installieren/Deinstallieren" (APPWIZ.CPL) angezeigten Einträge sind zum Deinstallieren der Programme gedacht.

Wenn Sie ein Programm von Hand löschen, ist dieser Eintrag immer noch vorhanden. Der Aufruf bringt eine Fehlermeldung zu Tage. Um diesen Eintrag aus der Liste zu löschen, müssen Sie in die Registry eingreifen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall

finden Sie eine Liste der unter Anzeige Uninstall eingetragenen Programme (die Schlüsselnamen müssen nicht mit der Anzeige übereinstimmen). Suchen Sie den entsprechenden Eintrag heraus, den Sie entfernen möchten und löschen Sie den gesamten Registryzweig. Um sicherzugehen, dass Sie auch den richtigen Eintrag löschen, sollten Sie im entsprechenden Registry-Schlüssel den Eintrag "DisplayName" überprüfen. Hier steht das, was von Windows unter Uninstall angezeigt wird.

Siehe auch "Installierte Programme werden nicht unter 'Software' angezeigt".

Die Einträge können auch mit Tweak UI 1.33 bequem entfernt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0135.htm


Installierte Programme werden nicht unter 'Software' angezeigt

Wenn unter Start - Einstellungen Systemsteuerung - Software - Installieren/Deinstallieren keine Programme mehr angezeigt werden, überschreiten evtl. der Name des entsprechenden Schlüssels oder der Anzeigename in der Registry die zulässige Größe von 63 Zeichen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall

Wenn ein Ordner unter diesem Key einen zu langen Namen enthält, ändern Sie den Namen (max. 63 Zeichen).

Suchen Sie in den Einträgen den Wert "DisplayName" (Datentyp REG_SZ), der mehr als 63 Zeichen enthältund kürzen Sie ihn entsprechend.

Siehe auch "Die unter Uninstall angezeigten Programme".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=240348

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1276.htm


Probleme mit dem Windows-Update

Wenn Sie Probleme haben, die Windows-Update-Seite aufzurufen oder der Internet Explorer nicht auf einen Klick auf den Produktupdate-Links reagiert, führen Sie folgende Schritte durch:

  1. Neustart des Rechners
  2. Schließen Sie alle Anwendungen
  3. Löschen Sie den Ordner %WINDIR% \msdownld.tmp
  4. Start - Ausführen: regsvr32 /u %WINDIR% \system\wuv3is.dll
  5. Benennen Sie die Datei %WINDIR% \System\wuv3is.dll um in wuv3is.#ll
  6. Systemsteuerung - Internetoptionen - Allgemein - Dateien löschen - OK
    Unter Umständen müssen Sie den Internet-Cache komplett per Hand löschen:
    Explorer - Rechtsklick auf %WINDIR% \Temporary Internet Files\Content.IE5 - Suchen - Starten
    Löschen Sie nun alle Dateien außer der Datei Index.dat
  7. Systemsteuerung - Internetoptionen - Allgemein - Einstellungen - Objekte anzeigen -
  8. Rechtsklick auf den Eintrag "CV3 Class" - Entfernen
  9. Alle Dateien und Unterverzeichnisse des Ordners C:\Programme\Windowsupdate löschen, mit Ausnahme der Datei wuhistv3.log
  10. Neustart des Rechners
  11. Schließen Sie alle Anwendungen, auch ggf. Virenscanner, Firewall, Werbeblocker etc.
  12. Deaktivieren Sie ggf. die Internetverbindungsfreigabe
  13. Deaktivieren Sie ggf. die Verwendung eines Proxy-Servers:
    Internetoptionen - Verbindungen - LAN-Einstellungen - "Proxyserver verwenden" deaktivieren
  14. Internetverbindung herstellen, IE starten und http://windowsupdate.microsoft.com/aufrufen

Sollten Sie beim Aufruf der Windows-Update-Seite an den Netzwerkadministrator verwiesen werden, obwohl der Rechner nicht vernetzt ist oder in ein Heimnetzwerk integriert ist, verfahren Sie wie folgt (%WINDIR% bezeichnet Laufwerk und Ordner, in dem Windows installiert ist):

  1. Abmelden der Datei WUPDINFO.DLL
    Start - Ausführen - REGSVR32 /u WUPDINFO.DLL
  2. Wiederherstellen der Datei WUPDINFO.DLL von der Windows 9x-CD: Windows 98: Start - Ausführen - sfc
    Windows ME: Start - Ausführen - msconfig
    "Eine Datei von der Installationsdiskette installieren" auswählen
    WUPDINFO.DLL eingeben
    "Starten" anklicken
    Den Ordner oder das Laufwerk angeben, in welchem sich der Ordner \win98 befindet; als Zielort den Ordner %WINDIR%\system angeben
    "OK" anklicken
  3. Registrieren der Datei WUPDINFO.DLL
    Start - Ausführen - REGSVR32 WUPDINFO.DLL
  4. Rechner neu starten und erneut versuchen, die Updateseite aufzurufen

Sollte das Problem weiterhin bestehen, versuchen Sie folgendes:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Löschen Sie in der Registry sämtliche Einträge (außer "Standard") aus folgenden Schlüsseln:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsUpdate\ LocalURL

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsUpdate\ RemoteURL

Es kann sein, dass bei Ihnen nicht alle Schlüssel der oben aufgeführten Schlüssel vorhanden sind. Nachdem Sie die Einträge gelöscht haben, führen Sie einen Neustart des Rechners durch und rufen Sie dann die Updateseite erneut auf.

Eine umfangreiche Sammlung von Tipps und Links zu dem Thema Windows Update finden Sie bei http://members.bellatlantic.NET/~mrscary/winupfaq.htm.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1301.htm


Tipp zum Installieren von Anwendungen auf Netzlaufwerken

von: Matthias Stolte

Die Installationsprogramme mancher Anwendungen (z.B. Photoshop 7.0, Internet Explorer) lassen die Auswahl von Netzlaufwerken erst gar nicht zu. Dann hilft eines der folgenden Verfahren möglicherweise weiter (als Installationsziel wird F:\GRAFIK\EBODA\7\0 angenommen):

a) mittels SUBST (ein Windows-eigenes Laufwerk-Umleitungs-Programm aus DOS -Zeiten)

Vorgehensweise:

  1. Trennen Sie die Verbindung zum bestehenden Netzlaufwerk F:
  2. Definieren Sie mittels SUBST eine Umleitung von einem leeren Pfad auf einer lokalen Platte auf ein virtuelles Laufwerk F: ( z.B. mit "subst F:\TMP")
  3. Lassen Sie das Installatationsprogramm laufen. Geben Sie als Installationsziel F:\GRAFIK\EBODA\7\0 an. Das Installationsprogramm wird nun "unwissentlich" die Dateien nach C:\TMP\GRAFIK\EBODA\7\0 kopieren, aber die Pfadangabe F:\GRAFIK\EBODA\7\0 in der Registry und anderen Konfigurationsdateien Eintragen.
  4. Lösen Sie die Umleitung mittels "subst F: /D"
  5. Stellen Sie die Verbindung zum Normalen Netzlaufwerk F: wieder her und verschieben nun alle Dateien und Verzeichnisse aus C:\TMP\GRAFIK\EBODA\7\0 nach F:\GRAFIK\EBODA\7\0

b) mittels Registry-Anpassung

  1. Installieren Sie die Anwendung auf einem lokalen Laufwerk, aber mit gleichem Pfad ( z.B. C:\GRAFIK\EBODA\7\0)
  2. Kopieren Sie alle Dateien und Verzeichnisse aus C:\GRAFIK\EBODA\7\0 nach F:\GRAFIK\EBODA\7\0
  3. Ändern Sie alle Vorkommen von C:\GRAFIK\EBODA\7\0 nach F:\GRAFIK\EBODA\7\0 in der Registry und anderen Konfigurationsdateien ( z.B. C:\GRAFIK\EBODA\7\0\*.ini)
  4. Starten Sie vorsichtshalber Windows neu, um zu gewährleisten, dass die Änderungen auch wirksam werden
  5. Löschen Sie C:\GRAFIK\EBODA\7\0. Falls Windows dabei den Hinweis anzeigt, dass sich die Löschung gegebenenfalls auf installierte Programme auswirken könne, haben Sie mindestens einen Eintrag in der Registry übersehen.

Bei beiden Verfahren ist zu beachten, dass bei der Installation in manchen Fällen kurze Dateinamen in der Registry eingetragen werden, die mit vom Server gelieferten kurzen Dateinamen nicht notwendigerweise übereinstimmen müssen. Bei Samba/Linux hilft es, einen Link mit dem kurzen Dateinamen auf die Datei mit dem langen Dateinamen anzulegen. Bei einem Windows-Server lässt sich die Nummerierung der kurzen Dateinamen durch die Reihenfolge der Erzeugung beeinflussen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1646.htm


Gemeinsames Wörterbuch für alle

Wo sich bei MS-Produkten das Wörterbuch befindet, steht in der Registry unter

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Shared Tools\ Proofing Tools\ Custom Dictionaries

Dort steht unter "1" der Pfad zur Wörterbuchdatei. Hier sind auch UNC-Pfadangaben möglich, so dass man ein gemeinsames Wörterbuch im Netzwerk zur Verfügung stellen kann.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0678.htm


Import von MS-Access-Adressen im Windows-Adressbuch

von Rainer Skibb

Auf meinem Büro-PC sind Windows 95, IE4, Outlook Express 4 und MS Office 97 installiert. Dort habe ich meine Access-Adressdatenbank mit ca. 4500 Anschriften aufgerufen, das Fenster geschlossen (das "Formular") und das Datenblatt geöffnet, dann die Exportfunktion aufgerufen und definiert, dass ich es als *.csv-Datei abspeichern will.

Nach dem Bestätigen öffnet sich der Export-Assistent von Access mit der Stelle, die für den ganzen Vorgang wichtig ist: Standardmäßig enthält das Kästchen für die Dezimalstellenangabe ein Komma - das muss unbedingt auf Semikolon geändert und für die Texttrennung ein Komma gewählt werden. Wenn beide Felder ein Komma enthalten, wird der Export mit dem Hinweis auf einen nicht definierten Fehler verweigert. Wenn die Texttrennung mit "Semikolon" definiert wird, klappt zwar die Speicherung als *.csv-Datei, aber hinterher gibt's ein Problem.

Wenn also die korrekt erstellte *.csv-Datei vorhanden ist, sollte man das Windows-Adressbuch öffnen (über Outlook Express oder auch direkt), Menü Datei anklicken so wie Importieren anklicken und Adressbuch. In dem sich öffnenden Fenster "Textdateien (csv)" auswählen, im Rahmen der Installationsroutine (Durchsuche, etc.) die zuvor erstellte Datei auswählen und den Importvorgang initiieren. Hierbei müssen die (selbst erstellten?) Access-Feldnamen denjenigen zugeordnet werden, die das Windows-Adressbuch vorgibt (wenn vorher als Texttrennungszeichen das Semikolon definiert wurde, erkennt das Importprogramm die Trennung nicht und das Ganze scheitert) - und los geht's. Ca. 4200 von den 4500 habe ich auf diese Weise konvertiert. Die anderen 300 wurden - so vermute ich - wegen Unsauberkeiten nicht akzeptiert (schlechte Pflege des Access-Datenbestandes).

Ob dies unter Windows 98 auch so läuft, weiß ich nicht. Zuhause jedenfalls hat das Einlesen der *.csv-Datei aus meinem Büro ins Windows-Adressbuch nicht geklappt: Offenbar wird das Format nicht erkannt. Ich vermute, das ist erst durch MS Office überhaupt ins System gelangt - da ich Office unter Windows 98 noch nicht installiert hatte, wird es wohl vorläufig noch nichts damit.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0854.htm


Office XP: Persönliche Informationen nicht in Dokumenten speichern

Bei den Office XP Anwendungen gibt es, gut versteckt unter Extras -> Optionen... -> Registerkarte "Sicherheit", einen Haken "Persönliche Informationen beim Speichern aus dieser Datei entfernen".

Diese Option gilt allerdings immer nur für die gerade offene Datei. Um dies zur Voreinstellung für alle Dokumente zu machen, geht man wie folgt vor:

Word XP

Man öffnet über Datei -> Öffnen -> "Dateityp" "Dokumentenvorlage (*.dot) die Normal.dot. Dann setzt man unter Extras -> Optionen... -> Registerkarte "Sicherheit" den Haken bei "Persönliche Informationen beim Speichern aus dieser Datei entfernen", bestätigt dies mit OK und speichert die Normal.dot.

Damit gilt diese Vorgabe für alle Dateien.

Excel & Powerpoint:

Für PowerPoint XP gilt:

  1. Klicken Sie auf der Standardsymbolleiste auf Neu.
  2. Zeigen Sie im Menü Ansicht auf Master und klicken Sie dann auf Folienmaster.
  3. Nehmen Sie auf dem Folienmaster die Änderungen vor, die in jeder neuen Präsentation enthalten sein sollen. (Unter Extras -> Optionen... -> Registerkarte "Sicherheit" den Haken bei "Persönliche Informationen beim Speichern" aus dieser Datei entfernen)
  4. Klicken Sie auf der Symbolleiste Folienmasteransicht auf "Masteransicht schließen".
  5. Klicken Sie im Menü Datei auf "Speichern unter".
    Anmerkung: Damit die Datei blank.pot standardmäßig verwendet wird, müssen Sie im Dialogfeld "Speichern unter" unter dem Standardpfad speichern.
  6. Wählen Sie im Feld Dateityp die Option "Entwurfsvorlage" aus. Geben Sie blank.pot im Feld Dateiname ein und klicken Sie dann auf Speichern.
  7. Schließen Sie die Vorlage.
    Anmerkung: Der Vorlagenname "blank.pot" muss unabhängig von der verfügbaren Sprachversion von PowerPoint und der installierten Sprache verwendet werden. Auch die Abwandlung des Namens in "blank presentation.pot" ist nicht möglich.

Excel XP

Eine leere Arbeitsmappe öffnen, um eine Standardmustervorlage für Arbeitsmappen (Standardvorlage für Arbeitsmappen: Die Mustervorlage Mappe.xlt) zu erstellen, wenn Sie das Standardformat neuer Arbeitsmappen ändern möchten. Excel verwendet diese Mustervorlage zum Erstellen einer leeren Arbeitsmappe, wenn Sie Excel starten oder eine neue Arbeitsmappe erstellen, ohne eine Vorlage anzugeben.

oder eine

Standardmustervorlage für Tabellenblätter (Standardvorlage für Tabellenblätter: Die Mustervorlage Blatt.xlt) erstellen, wenn Sie das Standardformat neuer leerer Tabellenblätter ändern möchten. Excel verwendet diese Mustervorlage zum Erstellen des leeren Tabellenblatts, wenn Sie einer Arbeitsmappe ein neues Arbeitsblatt hinzufügen.

Zum Erstellen wählen Sie entweder den Ordner XLStart oder den alternativen
C:\Programme\Microsoft Office\Office10\1031\ Startordner aus.

Der Pfad des Ordners XLStart ist normalerweise
C:\Programme\Microsoft Office\Office10\XLStart

Um eine benutzerdefinierte Arbeitsmappen- oder Arbeitsblattvorlage zu erstellen, wählen Sie den Ordner Vorlagen aus. Dieser befindet sich normalerweise unter
C:\Dokumente und Einstellungen\Benutzer_Name\Anwendungsdaten\Microsoft\Vorlagen.

Unter Extras -> Optionen... -> Registerkarte "Sicherheit" den Haken bei "Persönliche Informationen beim Speichern" aus dieser Datei entfernen.

Geben Sie den Namen der Vorlage in das Feld "Dateiname" ein. Führen Sie eine der folgenden Aktionen aus:

Arbeitsmappenvorlage:

Geben Sie Mappe.xlt ein, wenn Sie eine Standardmustervorlage für Arbeitsmappen erstellen möchten.

Arbeitsblattvorlage:

Geben Sie Blatt.xlt ein, wenn Sie eine Standardmustervorlage für Tabellenblätter erstellen möchten.

Klicken Sie auf "Speichern" und klicken Sie dann im Menü "Datei" auf "Schließen".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1199.htm


Word und Excel ohne neues Dokument starten

Word und Excel erstellen beim Start immer ein leeres Dokument. Mit dem Schalter word.exe /n wird keine leere Seite erstellt; für Excel nennt sich der Schalter excel.exe /e.

Beide Schalter können bei den Eigenschaften der Verknüpfung ergänzt werden. Seit Office 2000 bieten die Verknüpfungen im Startmenü keine Möglichkeit, um die Parameter mit anzugeben. Man löscht daher die Verknüpfungen aus dem Startmenü und erstellt diese einfach neu:

"C:\Programme\Microsoft Office\Office\WINWORD.EXE" /n bzw. "C:\Programme\Microsoft Office\Office\EXCEL.EXE" /e

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0731.htm


Indexerstellung von WinWord

Mit der Installation von WinWord wird ohne Nachfrage auch die Indexerstellung installiert. Die Indexerstellung von WinWord ist ein Programm, was so gut wie von keinem Anwender benötigt wird. Es wird aber ohne Nachfrage installiert und automatisch beim Systemstart gestartet.

Die Systemlast, die durch das Programm hervorgerufen wird, ist beträchtlich. Außerdem legt das Programm auf jeder Partition im Hauptroot einige Dateien mit dem Namen "ffsatun" an, die auch noch einiges an Speicherplatz verschwenden.

Die meisten Anwender können diese Funktion nie gebrauchen, aus diesem Grunde sollten Sie die Indexerstellung auch abstellen, Ihr Prozessor wird es Ihnen danken (aus "Autostart" die Verknüpfung löschen).

Info "Systemsteuerung" -> "Indexerstellung" -> "?" -> "Info" halten Sie "STRG" + "Shift" gedrückt und führen Sie einen Doppelklick auf das Logo am linken Rand aus. Nun wissen Sie, wer das Programm bei Microsoft verbrochen hat.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0727.htm


Schlechte Performance unter Access bei großen Datenbanken

Wenn eine große Datenbank (Access) in Netzwerk liegt, kann es vorkommen, dass Abfragen auf diese Datenbank über das Netzwerk sehr viel länger dauern, als wenn die Datenbank lokal liegt und von dort abgefragt wird.

Das kann daran liegen, das Windows standardmäßig immer nur einzelne Seiten für den Zugriff sperrt. Wird nun aber auf sehr viele Datensätze zugegriffen, ist es viel sinnvoller, die gesamte Tabelle für diese Zeit zu sperren.

Sie können das selber einstellen und zwar:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Jet\ 4.0\ Engines\ Jet 4.0

Dort finden Sie den Eintrag "PagesLockedToTableLock" als Datentyp REG_DWORD der standardmäßig auf 0 steht, was bedeutet das diese Funktion deaktiviert ist.

Hier können Sie jetzt einstellen ,ab nach wie vielen Zugriffen die gesamte Tabelle gesperrt wird.

Geben Sie hier z.B. 10 an, wird nach dem 11 Zugriff die gesamte Tabelle gesperrt. Das ist natürlich einfach zu verwalten und erhöht damit auch die Geschwindigkeit bei der Abfrage.

Diese Einstellung bringt natürlich nur etwas bei größeren Datenbanken, auf denen Sie auch größere Abfragen laufen lassen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1397.htm


Jahreszahlen in Excel auf vier Stellen erweitern

Standardmäßig benutzt Excel nur zweistellige Jahreszahlen. Über folgenden Eintrag in der Registry können Sie das auf eine vierstellige Anzeige erweitern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Excel\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie einen neuen Eintrag mit dem Namen EnableFourDigitYearDisplay als Datentyp REG_DWORD und setzen den Wert auf 1, um die Funktion zu aktivieren bzw. auf 0 für die 2-stellige Anzeige.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1230.htm


MS Assistenten ausschalten

Um den lästigen Assistenten in den Office-Programmen los zu werden, können Sie ihn in der Registry durch einen Key ausschalten:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 8.0\ Common\ Assistant

Erstellen Sie dort einen neuen Eintrag mit dem Namen "AsstState". Setzen Sie den Wert auf 0.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0647.htm


Personalisierte Menüs in Office 2000 deaktivieren

Personalisierte Menüs in ab Office 2000 deaktivieren

In Office gibt es die so genannten "Personalisierten Menüs". Diese neue Funktion können Sie über folgenden Registryeintrag deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ Toolbars

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie einen neuen Eintrag mit dem Namen AdaptiveMenus als Datentyp REG_SZ und setzen den Wert auf 0 zum Deaktivieren bzw. auf 1 zum Aktivieren dieser Funktion.

Diese Einstellung kann auch folgendermaßen gesetzt werden:

  1. Beliebiges Office-Programm ( z.B. Word) starten.
  2. Menü Extras -> Anpassen, in der folgenden Maske Reiter "Optionen" anwählen, Kontrollkästchen bei "Menüs zeigen zuletzt verwendete Befehle zuerst an" ausschalten.

Die Einstellung gilt dann für alle Office-Programme.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1229.htm


Standarddateiendung von HTML auf HTM bei Word ändern

Möchten Sie unter Word HTML-Dateien erstellen und diese abspeichern, hat Word als Endung standardmäßig HTML eingestellt. Wenn Sie aber alles als HTM abspeichern möchten, müssen Sie diese Einstellung immer verändern, besser ist es dann, wenn Word als Standard dann auch HTM benutzt.

Wenn Sie das wollen müssen Sie folgenden Eintrag in der Registry verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Shared Tools\ Text Converters\ Export\ HTML

Den Eintrag "Extensions" als Datentyp REG_SZ von "HTML HTM HTX" in "HTM HTML HTX"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1096.htm


Formatvorlagen unter Office sind unsichtbar

Die Icons für neue Dokumente (Formatvorlagen) unter Office (Version: 95 und 8.0) sind für die Benutzer unsichtbar, wenn diese in einem Netzwerkpfad liegen. Nur ein Administrator kann die Icons sehen.

Ursache:

Beim Eingeben eines Dateipfades unter dem Menüpunkt -> "Extras" -> "Optionen" -> Register "Dateiablage" wird ein eingegebener Pfad (z.B.: W:\ OFFICE97\ VORLAGEN) in den UNC Namen umgewandelt (z.B.: \\SERVERNAME\ software$\ office97\ vorlagen).

Der Benutzer kann zwar auf das Verzeichnis zugreifen und die Vorlagen laden, die Icons und Beschriftungen werden jedoch nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Fehlerbehebung:

Den von MS eingetragenen UNC Pfad in den von Ihnen zugewiesenen Laufwerkspfad ändern.

HKEY_CURRENT_USER\ Software\ Microsoft\ MicrosoftOffice\ [Version: also 95 oder 8.0] \ FileNew\ Local Templates\

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0146.htm


Excel UNDO-Schritte einstellen

Standardmäßig werden unter Excel nur die letzten 16 Änderungen gespeichert und können daher auch wieder zurückgenommen werden. Wenn Ihnen diese Anzahl der Schritte nicht ausreichen sollte können Sie den Wert in der Registry erhöhen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

für Excel 97:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 8.0\ Excel\ Microsoft Excel

ab Office 2002:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Excel\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Legen Sie hier einen neuen Wert mit dem Namen "UndoHistory" als Datentyp REG_DWORD an. Geben Sie als Wert die möglichen Rückschritte ein (0-100).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0557.htm


Nur 2 Schriften in Word verfügbar

Sind in Word nur 2 Schriften verfügbar, wurde kein Druckertreiber installiert. Auch wenn gar kein Drucker angeschlossen ist, sollte einer installiert werden, um dieses Problem zu beheben. Der STANDARD-Drucker hilft dabei aber nicht. Am besten nimmt man einen HP Deskjet 500 o.ä. von der WinCD.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0925.htm


Mehr freier Speicher nach Office97 Installation

Bei der Installation von Office97 legt die Setuproutine eine Verknüpfung in den Startordner, die sich Office Start nennt. Hierbei handelt es sich um ein Routine, die mehrere DLL-Dateien von Office beim Start von Windows bereits in den Arbeitsspeicher lädt.

Wer nicht ständig die Office-Boliden aktiviert, sollte diese Verknüpfung besser aus dem Startordner löschen. Die DLL-Dateien werden dann erst bei Aktivierung der Programme angefordert.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0319.htm


Mehrfaches Editieren von Office Dokumenten unterbinden

In Office XP und Word 2002 gibt es eine neue Funktion, die es ermöglicht, Dokumente gleichzeitig von mehr als einer Person zu editieren (Multi-User Editing).

Wird ein bereits geöffnetes Dokument von einem weiteren Benutzer geladen, wird automatisch eine lokale Kopie des Dokuments angelegt und die Änderungen werden in das Originaldokument übertragen.

Ist das nicht gewünscht, kann die Funktion wieder deaktiviert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie einen neuen Eintrag mit dem Namen "NoPromptToForkDocuments" als Datentyp REG_DWORD und

setzen den Wert auf 1 (deaktivieren; Standard = 0).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1311.htm


Erzwungene Sonderzeichenumwandlung

Frontpage kann bisher Umlaute und Sonderzeichen nicht gem. ISO-8859-1-Norm kodieren und schreibt diese "Normal" in den Quelltext. Wer dennoch eine Umwandlung wünscht, muss die HTML-Codierung des Dokuments über die Seiteneigenschaften von 1252 die griechische Codierung 1253 umschalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1132.htm


Euro als Währung nutzen

Das alte Excel 97 wird zwar durch die Servicepacks 1 und 2 für den Euro fit gemacht, kann diesen aber erst mit einigen Kniffen richtig nutzen.

Startet man die Systemwährung (ab 2002) über "Systemsteuerung" - "Ländereinstellungen" - "Währung" - "Währungssymbol" fest auf Euro um, verwenden Excel und Co. bei der Formatierung der Währung automatisch das Euro Symbol. Für die Übergangszeit und solange, bis aus dem letzten Datenblatt die DM-Währung verschwunden ist, bietet sich aber folgende Lösung an:

Microsoft bietet unter http://office.microsoft.com/germany/downloads/9798/eurotlbr.aspxeine Euro-Schaltfläche zum Download an, welche den Button "Währung formatieren" um die Euro-Funktionalität erweitert. So kann man zeitweise beide Währungen benutzen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1158.htm


Diagramme als Grafik speichern

Diagramme in Excel lassen sich zwar mit der Tabelle speichern, nicht aber extern als Grafik.

Von Bernd Held (Autor bekannter Fachbücher zu Excel) stammt das folgende Macro, welches das Diagramm als GIF oder JPG speichert. Hierzu muss im Quelltext einfach GIF durch JPG ersetzt werden. Mit dem Macro für Excel97/2000 wird das Diagramm genau in der Größe gespeichert, wie es auf dem Bildschirm gerade zu sehen ist und im Ordner abgelegt, der als Const PfadDiagramm angegeben ist.

Sub DiagrameinmalsGifSpeichern()

Dim GDiagramm As Chart

Dim NameT As String

Const PfadDiagramm = "C:\temp\"

Set GDiagramm = ActiveChart

NameT = InputBox("Name der Datei:", "Export Chart", ActiveChart.Name)

If NameT <> "" Then

GDiagramm.Export Filename:=PfadDiagramm & NameT & ".GIF", FilterName:="GIF"

End If

End Sub

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1094.htm


Dialogbox der Zwischenablage abschalten

Die Zwischenablage von Office 2000 / XP kann mehrere Objekte aufnehmen. Allerdings wird hierzu bei jedem Aufnehmen neuer Objekte auch die Zwischenablage als eigenes Fenster angezeigt. Wenn dies nervt, kann man das Fenster deaktivieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Office 2000

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Office\ 9.0\ Common\ General

Office XP

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Office\ 10.0\ Common\ General

Erstellen Sie hier einen neuen Wert mit dem Namen "AcbControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1 (0 aktiviert die Dialogbox wieder).

Das Fenster der Zwischenablage ist auch weiterhin verfügbar, muss aber manuell angezeigt werden (in Word und Excel unter "Ansicht" -> "Symbolleisten" -> "Zwischenablage").

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1059.htm


Office 2000 bei der Installation von Office XP behalten

Wenn zum neuen Office XP auch das alte Office 2000 erhalten bleiben soll, muss die Installationsart "Benutzerdefiniert" gewählt werden. Nach dem Klick auf <Weiter> erscheint die Selektion der zu installierenden Komponenten.

Im folgenden Screen zeigt das Setup, welche Anwendungen es entfernen möchte. Hier kann man einzelne Applikation gezielt vom Löschen ausnehmen. Lediglich Outlook 2000 kann nicht erhalten werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1136.htm


Office 2000 Grammatikprüfung funktioniert nicht

Wenn Sie Office 2000 über Office 97 als Update installieren, funktioniert die Grammatikprüfungnicht mehr. Beim Aktivieren der Grammatikprüfung erhalten Sie die Fehlermeldung "Kann Grammatikprüfung nicht starten". Um den Fehler zu beheben gehen Sie folgendermaßen vor:

  1. Deinstallieren Sie als erstes über das Office-Setup unter "Office Tools" die "Korrekturhilfen"
  2. Rechner neu starten
  3. Löschen Sie aus dem Verzeichnis "Programme\Gemeinsame Dateien\Microsoft Shared" das Verzeichnis "Proof"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

löschen Sie die zwei Registry Schlüssel:

HKEY_CURRENT_USER\ Software\ Novell
HKEY_LOCAL_MACHINE\ Software\ Novell

  1. Installieren Sie die Korrekturhilfen über das Office-Setup wieder neu
  2. Rechner neu starten

Jetzt sollte auch die Grammatikprüfung wieder funktionieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0536.htm


Dialogbox Öffnen/Speichern anpassen

Die neue Form der Dialogbox von "Öffnen und Speichern", die ab Office 2000 von MS eingeführt wurde, hat auf der linken Seite eine Navigationsleiste. Diese Navigationsleiste enthält standardmäßig die Einträge "Verlauf", "Eigene Dateien", "Desktop", "Favoriten" und "Netzwerkumgebung".

Sie können diese Leiste aber auch Ihren eigenen Wünschen anpassen, um z.B. bestimmte Standardordner dort zu hinterlegen. Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ Open Find\ Places

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Hier finden Sie die beiden Schlüssel "StandardPlaces" und "UserDefinedPlaces".

Im Schlüssel "StandardPlaces" finden Sie die oben aufgezählten Einträge. Wollen Sie einen dieser Standardeinträge ausblenden, legen Sie einfach unterhalb dieses Schlüssel einen neuen Wert mit dem Namen "Show" als Datentyp REG_DWORD an. Setzen Sie den Wert auf 0. Wenn Sie den Wert auf 1 setzen, wird der Eintrag wieder angezeigt.

Unter dem Schlüssel "UserDefinedPlaces" können Sie eigene Einträge anlegen. Sie müssen unter diesem Schlüssel einfach nur einen weiteren Unterschlüssel mit dem Namen "PlacesX" erstellen (das X ersetzen Sie durch eine fortlaufende Zahl, z.B. 1, was dann Places1 bringt).

Unter diesem Schlüssel müssen Sie nun einen neuen Wert mit dem Namen "Name" als Datentyp REG_SZ anlegen.

Hier geben Sie jetzt die Bezeichnung ein, die im Dialog angezeigt werden soll (z.B. Arbeitsablage). Zudem müssen Sie noch einen weiteren Eintrag mit dem Namen "Path" als Datentyp REG_SZ anlegen, hier geben Sie den Pfad zum gewünschten Ordner an (z.B.: C:\Dokumente\Arbeit).

Mit den Eintrag "View" als Datentyp REG_DWORD können Sie noch die Art der Anzeige festlegen. Den Eintrag View können Sie unter dem Schlüssel "StandardPlaces" oder "UserDefinedPlaces" anlegen. Folgende Werte könne Sie angeben:

1 | Listenansicht
2 | Detailansicht
3 | kurze Info über die markierte Datei
4 | Vorschau

Info Da erst ab Office XP mehr als 5 Einträge angezeigt werden können, müssen Sie bei Office 2000 für jeden neuen Eintrag einen der vorhandenen Einträgen im Schlüssel "StandardPlaces" entfernen.

Info Ab Office XP ist die Anzahl der Einträge nicht mehr auf 5 begrenzt, Sie können hier bis zu 256 Einträge aufnehmen. Weiterhin können die Einträge auch in Office anpassen. Öffnen Sie dazu den "Datei öffnen/speichern" Dialog. Gehen Sie hier dann auf den gewünschten Ordner, welchen Sie hinzufügen wollen und wählen Sie aus dem Menü "Extras" den Eintrag "Zu meiner Umgebung hinzufügen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1153.htm


Setup Pfad der Office97 CD

Will man nachträglich Komponenten von Office 97 hinzufügen, verlangt das Setup zunächst die CD. Haben sich mittlerweile die Laufwerksbuchstaben geändert ist das etwas nervig. Um das anzupassen, gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ MS Setup(ACME)\ Table Files\

hier gibt es einige Einträge, unter anderem auch einen Verweis auf eine.STF Datei (je nach Installation ist das unterschiedlich. Beispiel: C:\Programme\Microsoft Office\Office\Setup\Off97Pro.STF). Laden Sie diese Datei mit einem Editor und ändert Sie hinter "Source Directory" den entsprechende Pfad nach Ihren Wünschen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0742.htm


Deaktivieren von CTFMON.EXE

Bei der Installation von Office XP wird der Dienst CTFMON.EXE mit installiert und ab Windows XP mit ins Betriebssystem aufgenommen. Dieser Dienst wird für die alternative Benutzereingabe benutzt und bremst gerade ältere Rechner aus.

Wenn Sie den Dienst CTFMON.EXE entfernen wollen, gehen Sie folgendermaßen vor:

  1. Unter „Systemsteuerung“ -> „Software“ -> „Microsoft Office“ müssen Sie dem Eintrag aus den verfügbaren Feature entfernen -> "Microsoft Office Feature hinzufügen oder entfernen ("Erweiterte Anpassung von Anwendungen" aktivieren)
  2. Unter „Systemsteuerung“ -> „Tastatur“ über Tabreiter die „Hardware“-Treiber löschen bis auf den für die Tastaturtreiber
  3. Deregistrieren sie noch die DLLs:
    regsvr32 /u msimtf.dll
    regsvr32 /u msctf.dll

Info Die CTFMON.EXE ist auch für den Wechsel des Eingabegebietsschemas (also ein Wechsel des Tastaturschemas von z.B. Deutsch nach Englisch) zuständig. Falls Sie diese Funktion verwenden, sollten Sie die CTFMON.EXE daher nicht entfernen!

Da diese Methode bei Office 2007 mangels "Feature hinzufügen oder entfernen" im Setup nicht funktioniert und ab Windows XP ohne Office auch nicht verfügbar ist, gibt es dafür ein Programm. Dieses Programm setzt einen Dummy für die cftmon.exe ein und verhindert damit das ständige Wiederladen der Datei.

Download: CTFMON-Remover

Beschreibung: Der CTFMON-Remover hilft beim Entfernen der lästigen CTFMON.EXE von Ihrem Windows Betriebssystem.

Das einfach zu bedienende Programm zeigt an, ob die CTFMON.EXE bei Ihnen installiert und aktiv ist. Sie haben dann die Möglichkeit, das störende Programm zu entfernen. Sollten Sie die CTFMON.EXE wieder einmal benötigen, ist eine Wiederherstellung natürlich auch möglich.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=282599

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1381.htm


Dateien öffnen und speichern dauert immer länger in Office

Seid Office 97 gibt es in Outlook die neue Journal-Funktion. Mit dieser Funktion wird jedes Öffnen und Schließen einer Datei durch Office Anwendungen protokolliert. Diese Funktion kostet aber einiges an Zeit, was das Öffnen und Speichern von Dokumenten verlängert.

Über die Registry können Sie diese Funktion für jedes Office Programm gesondert ein- und ausschalten

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Shared Tools\ Outlook\ Journaling

Finden Sie für jede Office-Anwendung einen weiteren Unterschlüssel; hier müssen Sie jeweils nur den Eintrag "Enabled" als Datentyp REG_DWORD auf 0 setzen, um die Funktion auszuschalten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0565.htm


Bearbeitungszeit in Office Dokumenten speichern

Bei Office können Sie sich bei jedem Dokument unter dem Menü "Datei" -> "Eigenschaften" unter der Registrierkarte "Statistik" Informationen über das Dokument anzeigen lassen. Hier finden Sie auch den Eintrag "Bearbeitungszeit" der standardmäßig von Word aber nicht gemessen wird (ist nach Arbeitsschutzgesetzt auch verboten). Im privaten Bereich können Sie aber diese Funktion auf Wunsch hier aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ General

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "NoTrack" (Office 97/2000/XP) bzw. ("NoTracking" und "NoEditTime" bei Office 95) als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Informationen werden nicht im Dokument gespeichert
0 | Die Informationen werden gespeichert

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1402.htm


Ausführliches LOG bei der Office Installation

Wenn die Installation von Office mit einer Fehlermeldung die laufende Installation abbricht, aber nicht zu erkennen ist, was der Grund dafür ist, können Sie die Installation so starten, dass Windows eine ausführliche LOG-Datei erstellt:

setup /L*v! C:\Instlog.txt

Das besondere ist das Ausrufezeichen (!), welches dafür sorgt, dass Windows alle Informationen sofort in die LOG-Datei schreibt und nicht in einem Puffer vorhält, was bei einem Absturz dazu führen kann, dass die letzten Infos in der LOG-Datei fehlen. Bedenken Sie aber, dass die Installation sich dadurch sehr verlängert.

Liegt der Fehler schon am Anfang der Installation, können Sie auch diesen zur Erstellung einer LOG-Datei bewegen:

Instmsi.exe /c:"Msiinst.exe /i instmsi.msi /l*v C:\Instlog.txt /qb+"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1413.htm


Ausschalten der UNC-Pfadangaben bei MS Office

MS Office wandelt automatisch Verweise auf Servern in UNC-Pfade um. Das kann aber teilweise zu Fehlern führen und ist auch nicht immer erwünscht.

Durch einen Registry Eintrag können Sie das ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

8.0 | Office 97
9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie einen neuen Eintrag mit dem Namen "DontUseUNC" als Datentyp REG_DWORD. Setzen Sie diesen Eintrag auf "1". Ab jetzt arbeitet Word wieder mit den Laufwerksbuchstaben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0581.htm


Anzeige des Textes während des Scrollens auch bei Word 97

Wenn Sie bei Word 97 gerne möchten, dass der Text beim Scrollen angezeigt wird (wie beispielsweise bei Office 2000), dann müssen Sie nur folgenden Eintrag in der Registry hinzufügen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 8.0\ Word\ Options

erstellen Sie einen neuen Eintrag mit dem Namen "LiveScrolling" als Datentyp REG_SZ. Setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1105.htm


Ansichtenmodus dauerhaft speichern

Word startet neue Dokumente in der Ansicht "Normal".

Möchte man alle Dokumente lieber in der Ansicht "Seiten-Layout", muss man die Datei Normal.dot aus dem Vorlagenverzeichnis öffnen, dann über ANSICHT auf Seiten-Layout umschalten und die Vorlage wieder speichern. Ab dann werden alle neuen Dokumente in der Ansicht "Seiten-Layout" erstellt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1099.htm


Anzahl der Rückgängig (Undo) - Schritte in Access

Anzahl der Undo (Rückgängig)-Schritte in Access

Mit diesem Tipp können Sie einstellen wie viele Änderungen sich Access für die Undo-Funktion merkt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Access\ Settings

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "Number of Undos" als Datentyp REG_DWORD. Geben Sie hier die Anzahl der UNDO-Schritte ein, die sich Access merken soll.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1619.htm


Drucken von Sonderzeichen in Word aktivieren

Wenn Sie einen Text mit erweiterten Sonderzeichen (z.B. griechische Symbole) auf Druckern ausdrucken, die keine Unicode unterstützen, dann wird auf diesen Druckern meist nur viereckige Kästchen gedruckt. Wenn Sie diesen Tipp aktivieren, sollte das Problem auf den meisten Druckern gelöst sein und die Zeichen richtig gedruckt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "NoWideTextPrinting" als Datentyp REG_SZ. Setzen Sie den Wert auf:

1 | Drucken von Sonderzeichen aktivieren
0 | Normaler Druck

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1673.htm


Netzwerkpfad bei Word-Dokumenten im Netzwerk

Wenn Sie ein Word-Dokument im Netzwerk erstellen, dann können Sie hier festlegen, mit welchen Pfad Word arbeiten soll. So können Sie festlegen, ob immer mit Laufwerksnamen oder mit UNC-Pfaden gearbeitet werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "VolumePref" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Laufwerksbuchstaben und UNC benutzen
1 | UNC nach Laufwerksbuchstaben umwandeln wenn verbunden
2 | Laufwerksbuchstaben nach UNC umwandeln

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1674.htm


Zwischenspeicher für Word-Dateien konfigurieren

Wird in Word eine Datei geöffnet, werden die Daten in einen Zwischenspeicher für die Bearbeitung geladen. Dieser Zwischenspeicher hat standardmäßig eine Größe von 64 KByte.

Bei größeren Dokumenten (gerade bei der Bearbeitung über das Netzwerk) ist dieser Puffer zu klein und es kann deshalb zu längeren Wartezeiten beim Nachladen kommen. Mit diesem Tipp können Sie den Puffer vergrößern. Der neue Wert muss in 64 KByte Schritten eingestellt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "CacheSize" als Datentyp REG_DWORD und geben Sie den Speicher in KByte ein. Dabei muss der Wert in 64 KByte schritten erhöht werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1675.htm


Verlinkte Bilder in Office nicht laden

Mit diesem Tipp können Sie verhindern, dass verlinkte Bilder in Office Dokumenten automatisch geladen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "BlockHTTPImages" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verlinkte Bilder nicht laden
0 | Verlinkte Bilder laden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1688.htm


Aufpoppen des Zwischenablagen-Fensters in Office unterbinden

Wird in Office mehr als ein Objekt in die Zwischenablage kopiert, poppt eine Symbolleiste mit der Bezeichnung "Zwischenablage" auf. Mit diesem Tipp können Sie das unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ General

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "AcbControl" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Zwischenablage nicht anzeigen
0 | Zwischenablage anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1689.htm


Symbolbezeichnung in Office anzeigen

Mit diesem Tipp können Sie einstellen, dass die Symbolbezeichnungen in Office angezeigt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ General

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "SymbolNameDisplay" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Symbolbezeichnungen nicht anzeigen
200 | Symbolbezeichnungen anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1690.htm


Eine erforderliche Installationsdatei *.CAB fehlt beim Office Update

Eine erforderliche Installationsdatei *.CAB fehlt beim Office 2003 Update

2003

Kommt beim Office 2003 Update die Fehlermeldung "Eine erforderliche Installationsdatei, xxxx.CAB, konnte nicht gefunden werden" (für xxxx steht ein Name einer Datei, z.B.: SKU011), wird nach der Office CD verlangt. Legt man die benötigte Office CD ein, wird die Datei aber nicht gefunden, obwohl sie auf der CD vorhanden ist.

Das liegt oft am fehlerhaften CDCache, um den Fehler zu beheben, müssen Sie folgenden Registrywert ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Office\ 11.0\ Delivery\ {GUID (Globally Unique Identifiers) }

(Die GUID (Globally Unique Identifiers) besteht aus einer Zahlenkombination aus verschiedenen 8-4-4-4-12-stelligen Nummern.

Ändern Sie den Wert "CDCache" vom Datentyp REG_SZ auf >0<.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1827.htm


Lokalinstallationsquelle (Msocache) von Office konfigurieren

Die "Lokalinstallationsquelle" ist ein Setup-Feature, das die Installationsquellendateien vom Microsoft Office (z. B.: Office 2003-CD-ROM) in den verborgenen Ordner "Msocache" auf der lokalen Festplatte kopiert. Dieser Ordner belegt ca. 270 MB Speicherplatz auf der Festplatte. Muss Office später aber entsprechende Optionen nachinstallieren bzw. wird der Reparaturmodus gestartet, dann verlangt Office nicht mehr nach der Installations-CD.

Dieser Ordner bleibt nur erhalten, wenn Sie nach dem Office-Setup nicht die Option „Installationsdateien löschen" aktivieren.

Wenn Sie den Ordner später löschen wollen, um den Speicherplatz wieder freizubekommen, führen Sie einfach die Datenträgerbereinigung auf dem entsprechenden Laufwerk aus.

Der Ordner "Msocache" wird bei der Installation automatisch auf der Festplatte erzeugt, wo der meiste Speicherplatz vorhanden ist, wenn Sie den Ordner auf ein anderes Laufwerk legen wollen, müssen Sie folgenden Eintrag in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ 11.0\ Delivery\ {CLSID-Nr.}

finden Sie den Eintrag „LocalCacheDrive“ als Datentyp REG_SZ, hier wird der Buchstabe des Laufwerks angegeben, auf dem sich der Ordner "Msocache" befindet. Anschließend verschieben Sie noch den Ordner auf das entsprechende Laufwerk.

Microsoft stellt unter http://www.microsoft.com/downloads/details.aspx?familyid=10fa7aa3-695b-42c3-9045-b812ba0fed3e&displaylang=endas Tool "LISTool.exe" zur Verfügung, womit man den Ordner verschieben kann.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=825933

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1996.htm


Beim Speichern von Exceldateien erscheint die Meldung 'Datei wurde geändert'

Beim Speichern von Exceldateien erscheint die Meldung "Datei wurde geändert"

Wenn Sie eine Datei im Netzwerk speichern wollen, erscheint die Meldung "Die Datei [Dateiname .XLS] ist unter Umständen von einem anderen Benutzer geändert worden. Was wollen Sie in diesem Fall tun?

- Kopie speichern

- Änderung überschreiben

Diese Meldung erscheint aus Sicherheitsgründen. Windows überprüft den Zeitstempel der Datei, um festzustellen, ob sie zeitgleich von einer anderen Person geändert wurde. Das kann z.B. passieren, wenn eine Netzwerkverbindung abgebrochen ist und die Datei in dieser Zeit von einen anderen Person geladen und geändert wurde.

Ist das aber nicht der Fall, kann es auch durch den Dienst für Macintosh (Zugriff für Macs auf Windows Dateisysteme) ausgelöst werden.

Damit Sie dann nicht immer diese Meldung bekommen, müssen Sie die "Zeitstempelüberprüfung deaktivieren".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Excel\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

ändern Sie hier den Wert "QFE_Saskatchewan" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Zeitstempelüberprüfung aktivieren (Standard)
1 | Zeitstempelüberprüfung deaktivieren
2 | Dateicache vor Zeitstempelübermitlung leeren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2074.htm


Symbolgröße für die Öffnen/Speichern Dialogbox in Office festlegen

Symbolgröße für 'Öffnen/Speichern Dialogbox' in Office festlegen

Mit diesem Tipp können Sie die Symbolgröße der Icons in der Öffnen/Speichern-Dialogbox von Office festlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ Open Find\ Places

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

ändern Sie hier den Wert "ItemSize" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Große Icons
0 | Kleine Icons

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2091.htm


Indexsuche von Office konfigurieren

In Microsoft Office gibt es eine Indexsuche, welche automatisch ein Indexliste erstellt, damit Suchanfragen später schneller bearbeitet werden können

Die Index-Erstellung kann auf nicht so schnellen Rechner stören. Mit diesem Tipp können Sie die Häufigkeit der Index-Aktualisierung einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ [Version]\ Find Fast

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "SlowDown" als Datentyp REG_DWORD und geben Sie die Zeit in Millisekunden an. Der Standardwert liegt bei 1000.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2141.htm


Office: Cliparts-Pfad festlegen

Hier können Sie den Standardpfad zum Öffnen von Cliparts festlegen. Dieser Pfad ist in der Registry in Schlüssen "PICTURE-PATH" hinterlegt und kann dort verändert werden. Wenn Sie in Office Bilder (Cliparts) einbinden wollen, dann sucht Office diese Cliparts im angegeben Verzeichnis.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ [Version]\ Word\ Options

Erstellen Sie hier einen neuen Wert mit dem Namen "PICTURE-PATH" als Datentyp REG_SZ. und geben Sie hier den Pfad zum Clipart Verzeichnis an.

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2167.htm


Mailversand aus Word auch ohne MS-Mail-Programm

Wenn Sie kein Mail-Programm von Microsoft benutzen (Outlook/Explorer oder Windows Mail), dann ist unter Microsoft Office der Eintrag "Datei" -> "Sanden an" bzw. in der Menüleiste der Button "Senden" deaktiviert. Diese Funktionen werden erst aktiviert, wenn Sie ein Mail-Programm von Microsoft auf dem System einrichten.

Wenn Sie jetzt aber mit einem anderen Mailprogramm arbeiten, können Sie diese Funktion nicht benutzen. Damit Sie diese Funktion benutzen können, wurde hier der Inhalt einer REG-Datei abgelegt.

  • Kopieren Sie die Textzeilen in eine neue Textdatei, die Sie z.B. mit Notepad erstellen.
  • Speichern Sie die Datei unter einem beliebigen Namen mit der Dateiendung ".REG" ab.
  • Anschließend klicken Sie diese Datei im Explorer doppelt an, um die ergänzenden, neuen Einstellungen in die Registry zu übernehmen.

Die Einträge in der Registry lauten:

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem]

"MAPI"="1"

"MAPIX"="1"

"OLEMessaging"="1"

"CMC"="1"

"MAPIXVER"="1.0.0.1"

"CMCDLLNAME"="mapi.dll"

"CMCDLLNAME32"="mapi32.dll"

=== Hier schneiden ===

Wenn die Einträge vorhanden sind und Sie einen MAPI-fähigen E-Mail-Client benutzen, können Sie jetzt direkt über Office die Dokumente versenden.

Unter Windows 9x werden diese Einträge teilweise noch in der WIN.INI eingetragen. Sie finden die Werte dann in der Sektion [Mail]

Datei: "%SystemRoot%\WIN.INI"

[Mail]

MAPI=1

MAPIX=1

OLEMessaging=1

CMC=1

MAPIXVER=1.0.0.1

CMCDLLNAME=mapi.dll

CMCDLLNAME32=mapi32.dll

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2394.htm


Office: Zusätzliche Fragebox in der Hilfefunktion ausblenden

Mit diesem Tipp können Sie das Fragefeld der Hilfe aus der Symbolleiste ausblenden.

Microsoft hat in Office XP2003 eine zusätzliche Fragebox in seiner Hilfe eingebaut. Diese zusätzliche Drop-Down-Box findet man oben rechts in der Symbolleiste. In dieses Feld können Sie eine Frage eingeben und bekommen dann entsprechende mögliche Hilfen angezeigt. Wenn Sie diese Funktion nicht nutzen, können Sie über einen Registryeintrag das Feld zur besseren Übersicht ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ Toolbars\ Settings

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier jeweils für jedes Office-Programm folgende Einträge als Datentyp REG_DWORD

Office 2002

Eintrag | Beschreibung
Microsoft Access AWDropdownHidden | Eintrag in Microsoft Access ausblenden
Microsoft Excel AWDropdownHidden | Eintrag in Microsoft Excel ausblenden
Microsoft Word AWDropdownHidden | Eintrag in Microsoft Word ausblenden
Microsoft Outlook AWDropdownHidden | Eintrag in Microsoft Outlook ausblenden
Microsoft Powerpoint AWDropdownHidden | Eintrag in Microsoft Powerpoint ausblenden

Office 2003:

Eintrag | Beschreibung
Microsoft Office Access AWDropdownHidden | Eintrag in Microsoft Access ausblenden
Microsoft Office Excel AWDropdownHidden | Eintrag in Microsoft Excel ausblenden
Microsoft Office Word AWDropdownHidden | Eintrag in Microsoft Word ausblenden
Microsoft Office Outlook AWDropdownHidden | Eintrag in Microsoft Outlook ausblenden
Microsoft Office Powerpoint AWDropdownHidden | Eintrag in Microsoft Powerpoint ausblenden

Setzten Sie den Wert jeweils auf:

0 | Fragefeld wird angezeigt (Standard)
1 | Fragefeld nicht anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2508.htm


Excel: Euro-Zeichen wird bei kleiner Schriftart zum Strich

Excel: Euro-Zeichen wird zum Strich bei zu kleiner Schriftart

In Excel wird das Euro-Zeichen, ab einer Schriftgröße von 9 pt oder kleiner, nur noch als ein senkrechter Strich angezeigt.

Das passiert, da Excel ab 8 pt - zur besseren Lesbarkeit - auf einen Windows Font umschaltet. der an der Position des Euro Zeichens (128), einen Strich enthält.

Damit also auch bei kleineren Schriftgrößen noch ein Euro-Zeichen angezeigt wird, muss man das Umschalten auf den anderen Zeichensatz unterbinden. Das können Sie mit den Registryeintrag "FontSub" konfigurieren, der je nach Excel werden an einer anderen Stelle angelegt werden muss.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Excel 95:

HKEY_CURRENT_USER\ Software\ Microsoft\ Excel\ 7.0\ Microsoft Excel

Excel 97:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 8.0\ Excel\ Microsoft\ Excel

Ab Excel 2000

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Excel\ Options

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "FontSub" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Zeichensatz wird nicht gewechselt
1 | Ab 8 pt wird der Zeichensatz umgeschaltet (Standard)

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=829389

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2567.htm


Office: Autovervollständigung in der Dateidialogbox ausschalten

Mit diesem Tipp können Sie einstellen, ob in der Dateidialogbox (Öffnen, Speichern und Speichern unter) der Dateiname automatisch vervollständigt werden soll.

Dafür müssen Sie den Eintrag "Use AutoComplete" in der Registry auf "No" setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ General

müssen Sie den Eintrag "[Version]" durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (ab SR-1)
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "Use AutoComplete" als Datentyp REG_SZ und setzen den Wert auf:

NO | Eingaben werden nicht automatisch vervollständigt
YES | Eingaben werden automatisch vervollständigt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2594.htm


Anzahl der Vorlagen im Word Arbeitsbereich anpassen

^

Mit diesem Tipp können Sie die maximale Anzahl der verwendeten Vorlagen konfigurieren. Unter Word im Datei/Neu-Dialog werden standardmäßig im Arbeitsbereich die letzten 4 verwendeten Vorlagen angezeigt. Mit diesem Tipp können Sie die Anzahl auf maximal 9 Vorlagen erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ General

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "RecentTemplatesList" als Datentyp REG_DWORD, und geben Sie die Anzahl der Vorlagen bis zu einem maximalen Wert von 9 an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2610.htm


Microsoft Office: Zwischenspeichern von Passwörtern deaktivieren

Mit diesem Tipp können Sie einstellen, dass kein Passwort mehr beim Zugriff auf externe Datenquellen gespeichert wird.

Wenn Sie im Office 2000 eine Abfrage verwenden, um aus einer externen Datenquelle Daten abzurufen, wird das Passwort gespeichert, wenn Sie "Kennwort speichern" ausgewählt haben. Das Kennwort wird in einer Textdatei abgelegt, was ein Sicherheitsproblem darstellen kann.

Wenn Sie den Eintrag "DisablePwdCaching" aktivieren (Festlegung auf "1"), wird das Passwort nicht mehr in eine Textdatei gespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 Office 2000

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePwdCaching" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Passwörter können gespeichert werden (Standard)
1 | Passwörter können nicht mehr gespeichert werden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2628.htm


Menü: 'Datei | Öffnen... | Extras | Suchen...' deaktivieren

Menü: "Datei | Öffnen... | Extras | Suchen..." deaktivieren

Mit diesem Tipp können Sie das Menü: "Datei -> Öffnen... -> Extras -> Suchen.." deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "FileOpenToolsFind" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

4099 | Menü Suchen deaktivieren
0 | Menü Suchen ist vorhanden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1742.htm


Menü: 'Datei | Senden an | Mailempfänger' deaktivieren

Menü: "Datei | Senden an | Mailempfänger" deaktivieren

Mit diesem Tipp können Sie das Menü: "Datei -> Senden an -> Mailempfänger" deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "FileSendToMailRecipient" als Datentyp REG_SZ. Setzen Sie den Wert auf:

3738 | Senden an Mailempfänger ausblenden
0 | Senden an Mailempfänger anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1743.htm


Menü: 'Einfügen | Hyperlink...' deaktivieren

Menü: "Einfügen | Hyperlink..." deaktivieren

Mit diesem Tipp können Sie das Menü: "Einfügen -> Hyperlink..." deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ DisabledCmdBarItemsCheckboxes

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Word\ DisabledCmdBarItemsCheckboxes

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Excel\ DisabledCmdBarItemsCheckboxes

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ PowerPoint\ DisabledCmdBarItemsCheckboxes

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "InsertHyperlink" als Datentyp REG_SZ. Setzen Sie den Wert auf:

1576 | Hyperlink entfernen
0 | Hyperlink anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1744.htm


Menü: 'Extras | Onlinezusammenarbeit' deaktivieren

Menü: "Extras | Onlinezusammenarbeit" deaktivieren

Mit diesem Tipp können Sie das Menü: "Extras -> Onlinezusammenarbeit" deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Checkbox es

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "ToolsCollaboration" als Datentyp REG_SZ. Setzen Sie den Wert auf:

30468 | Onlinezusammenarbeit deaktivieren
0 | Onlinezusammenarbeit anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1745.htm


Darstellung-Hyperlinkfarbe einstellen

Mit diesem Tipp, stellen Sie die Farbe des Hyperlinks ein und legen damit fest in welcher Farbe URL-Adressen angezeigt werden sollen. Diese Einstellung finden Sie auch im Menü unter: "Extras" -> "Optionen..." -> "Allgemein" -> "Weboptionen..."

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "HyperlinkColor" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

Eintrag (Wert) | Farbe
0 | Schwarz
1 | Braun
2 | Grün
3 | Oliv
4 | Dunkelblau
5 | Violett
6 | Blaugrün
7 | Grau
8 | Silber
9 | Rot
10 | Hellgrün
11 | Gelb
12 | Blau
13 | Violett
14 | Hellblau
15 | Weiss

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1737.htm


Darstellung-Farbe für besuchten Hyperlink einstellen

Mit diesem Tipp, stellen Sie die "Farbe des besuchten Hyperlinks" ein. Diese Einstellung finden Sie auch im Menü unter: "Extras" -> "Optionen..." -> "Allgemein" -> "Weboptionen..."

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "FollowedHyperlinkColor" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

Eintrag (Wert) | Farbe
0 | Schwarz
1 | Braun
2 | Grün
3 | Oliv
4 | Dunkelblau
5 | Violett
6 | Blaugrün
7 | Grau
8 | Silber
9 | Rot
10 | Hellgrün
11 | Gelb
12 | Blau
13 | Violett
14 | Hellblau
15 | Weiss

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1738.htm


Darstellung-Hyperlinks unterstreichen

Mit diesem Tipp, stellen Sie ein, ob "Hyperlinks unterstrichen" werden sollen. Diese Einstellung finden Sie auch im Menü unter: "Extras" -> "Optionen..." -> "Allgemein" -> "Weboptionen..."

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "DoNotUnderlineHyperlinks" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Hyperlinks unterstreichen
1 | Hyperlinks nicht unterstreichen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1739.htm


Sicherheitsstufe einstellen

Mit diesem Tipp, stellen Sie die "Sicherheitsstufe" ein. Diese Einstellung finden Sie auch im Menü unter: "Extras" -> "Makro" -> "Sicherheit..." -> "Sicherheitsstufe"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Security

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "Level" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

3 | Hoch (nur signierte Makros)
2 | Mittel (es wird nachgefragt)
1 | Niedrig (alles wird ausgeführt)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1740.htm


Sicherheit: 'Allen installieren ADD-Ins vertrauen..' konfigurieren

Sicherheit: "Allen installieren ADD-Ins vertrauen.." konfigurieren

Mit diesem Tipp stellen Sie ein, ob "Allen installierten Add-ins und Vorlagen trauen" aktiv sein soll. Diese Einstellung finden Sie auch im Menü unter: "Extras" -> "Makro" -> "Sicherheit..." -> "Vertrauenswürdige Herausgeber"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Access\ Internet

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "DontTrustInstalledFiles" als Datentyp REG_SZ. Setzen Sie den Wert auf:

30468 | Allen installierten Add-ins und Vorlagen trauen
0 | Allen installierten Add-ins und Vorlagen nicht trauen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1741.htm


Gleichzeitig laufende Prozesse für Access einstellen

Mit diesem Tipp können Sie die Zahl der gleichzeitig laufenden Prozesse - ab Access 2000 - verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Jet\ 4.0\ Engines\ Jet 3.x

ändern Sie hier den Wert "Threads" als Datentyp REG_DWORD und setzen den Wert auf:

16 | 16 Prozesse
32 | 32 Prozesse
64 | 64 Prozesse
128 | 128 Prozesse

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2083.htm


Access: Konfigurieren der Laufzeitoptionen

Mit diesen Einstellungen können Sie die Konfiguration für Access mit beeinflussen und dadurch Ihre eigenen Access-Programme konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ [Version]\ Access\ Run-Time Options

Sie müssen die [Version] durch Ihre aktuelle Office Version ersetzen:

8.0 | Access 97
9.0 | Access 2000
10.0 | Access XP

Erstellen Sie hier die folgenden Einträge als Datentyp REG_SZ:

Name | Beschreibung
Titlebar | Legen Sie den Text fest, der in der Titelleiste des Hauptfensters angezeigt werden soll
StartupScreen | Pfad und Dateiname zum Image (.BMP), welches beim Start der Anwendung angezeigt werden soll
Icon | Pfad und Dateiname zur Icon-Datei (.ICO), welches in der Titelbar und Taskbar angezeigt werden soll.
AppHelpFile | Pfad und Dateiname zur Hilfedatei (.HLP) welche für die Anwendung benutzt werden soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2612.htm


Office Service Packs in die Original-Installationsdateien einbinden

Wie auch beim Windows kann man ab Office 2000/XP das Service Pack in die Originalinstallationsdateien einbinden. Das ist aber nur mit der „Enterprise Version“ möglich. Bei den OEM Versionen existiert leider nicht die Möglichkeit ein Administratorsetup durchzuführen.

Um so eine CD zu erstellen gehen Sie folgendermaßen vor:

  • Starten Sie von der Original Office CD ein Administratorsetup.
    Dadurch wird Office nicht auf Ihren Rechner installiert, sondern es werden nur die Dateien in einen entsprechenden Ordner gepackt und für eine Installation vorbereitet:
    <Laufwerk>\setup.exe /a

Geben Sie hier einen Ordnernamen an, wohin die Dateien abgelegt werden sollen ( z.B.: D:\OfficeSP). Sie werden weiterhin noch nach Ihren Lizenzangaben (Seriennummer usw.) gefragt. Das hat den Vorteil, dass Sie bei späterer Installation diese Informationen nicht mehr angeben müssen.

Info Der Ordnername darf keine Leerzeichen enthalten.

  • Laden Sie danach die benötigten Service Packs herunter (Sie benötigen die Admin-Version).

Beim Office benötigen Sie - anderes als bei Windows - alle Service Pack Dateien, und Sie müssen die dann_nacheinander auf das Verzeichnis D:\OfficeSP - anwenden müssen. Zur Zeit werden folgende Service Packs benötigt:

Office 2000

Hier gibt es zu beachten, dass es zwei CD - Versionen vom Office gibt. Eine Normale ohne Service Pack und eine mit Service Pack 1. Bitte benutzen Sie jeweils die entsprechende Beschreibung.

Office CD ohne Service Pack -> Service Pack 1a (Link: http://download.microsoft.com/download/office2000prem/SP/1/WIN98/DE/Data1.exe)
Office CD mit SP1 -> Service Pack 1a (Link: http://download.microsoft.com/download/office2000prem/SP/1/WIN98/DE/O2KSR1aDL.exe)
Service Pack 2 (Wird nicht benötigt, da in SP3 enthalten)
Service Pack 3 (Link: http://download.microsoft.com/download/office2000/SP/3/WIN98MeXP/DE/o2ksp3a.exe)

Office XP

Service Pack 1 (Link: http://download.microsoft.com/download/officexpstandard/sp/oxpsp1/w98nt42kmexp/de/oxpsp1a.exe)
Service Pack 2 (Link: http://download.microsoft.com/download/officexpstandard/sp/oxpsp2/w98nt42kmexp/DE/oxpsp2a.exe)

  • Entpacken Sie alle Service Packs in beliebige Verzeichnisse ( z.B. StartenP1 und SP2).

Office 2000

Für die Office CD ohne SP:
Data1.exe entpacken (Verzeichnis:d:\sp1a), danach finden Sie hier die zusätzliche Datei "Data1.msp"
bzw für die Office CD mit SP1:
O2KSR1aDL.exe entpacken (Verzeichnis:d:\sp1a), danach finden Sie hier die zusätzliche Datei "Data2.msp"
Service Pack 3 für beide:
O2ksp3a.exe entpacken (Verzeichnis:d:\sp3), danach finden Sie hier die zusätzliche Datei "mainsp3ff.msp"

Office XP

Danach müssen sich in beiden Verzeichnissen bei der Admin-Version zwei Steuerdateien befinden die auf.mspenden. Leider sind die Namen bei Service Packs unterschiedlich:
SP1: OWC10SP1_Admin.msp und MAINSP1_Admin.msp
SP2: OWC10SP2ff.msp und MAINSP2ff.msp

  • Jetzt müssen Sie diese Datei auf das Office Originalverzeichnis (hier D:\OfficeSP) anwenden.

Das wird mit folgenden Aufruf gemacht:

Office 2000

Für Service Pack 1a mit der Office CD ohne SP:
msiexec /a d:\officeSP\Data1.msi /p d:\sp1a\data1.msp SHORTFILENAMES=true /qb /L* d:\officeSP\sr1a.log

Für Service Pack 1a mit der Office CD mit SP1:
msiexec /a d:\officeSP\Data2.msi /p d:\sp1a\data2.msp Shortfilenames=true /qb /L* d:\officeSP\sr1a.log

Für Service Pack 3 mit der Office CD ohne SP:
msiexec /a d:\officeSP\Data1.msi /p d:\sp3\mainsp3ff.msp SHORTFILENAMES=true /qb /L* d:\officeSP\sp3.log

Für Service Pack 3 mit der Office CD mit SP1:
msiexec /a d:\officeSP\Data2.msi /p d:\sp3\sp3cd2ff.msp Shortfilenames=true /qb /L* d:\officeSP\sp3.log

Office XP

Für Service Pack 1:
msiexec /p d:\sp1\MAINSP1_Admin.msp /a d:\officeSP\PROPLUS.MSI shortfilenames=true /qb /L* d:\sp1\updsp1_p.log
und
msiexec /p d:\sp1\OWC10SP1_Admin.msp /a d:\officeSP\OWC10.MSI shortfilenames=true /qb /L* d:\sp1\updsp1_o.log

Für Service Pack 2:
msiexec /p d:\sp2\MAINSP2ff.msp /a d:\officeSP\PROPLUS.MSI shortfilenames=true /qb /L* d:\sp2\updsp2_p.log

und

msiexec /p d:\sp2\Owc10SP2ff.msp /a d:\officeSP\OWC10.MSI shortfilenames=true /qb /L* d:\sp2\updsp2_o.log

  • Für jeden weiteren Service Packs von Office müssen Sie - je nach Dateiname - diese beiden Schritte auch noch ausführen.
  • Überprüfen Sie die entrechtenden LOG-Dateien um sicherzustellen das alle Updates fehlerfrei durchgeführt wurden.

Jetzt können Sie Office aus diesen Ordner installieren bzw. diesen Ordner auf eine CD Brennen. Zu beachten ist dabei nur, das Sie die CD genauso nennen wie die Original Office CD heißt, ansonsten kann es dazu führen das Office die CD nicht richtig erkennt. Dies passiert nicht immer, aber so sind Sie auf jeden Fall auf der sicheren Seite.

Info Erscheint beim Update die Meldung "...gültiger Product Key angegeben werden", müssen Sie den CD-Key mit übergeben. Hängen Sie dafür noch folgenden Eintrag an "PIDKEY=<CD-KEY>" (ohne Bindestiche und Leerzeichen).
Beispiel:msiexec /p d:\sp2\Owc10SP2ff.msp /a d:\InfoPath\inf11.MSI shortfilenames=true /qb /L* d:\sp2\Inf_updsp2_1.log PIDKEY=XXXXXXXXXXXXXXXXXXXXXXXX
Oft wird das bei den extra Installationen von InfoPath und dem Publisher benötigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1407.htm


Service Pack in Microsoft Office 2007 einbinden

Bis jetzt konnte man die Service Pack nur über einen Adminpoint (siehe Tipp: Office Service Packs in die Original-Installationsdateien einbinden) in die Originaldateien einbinden, was für den normalen Anwender meist doch etwas umständlich und nicht gerade hilfreich war.

Mit Office 2007 stellt Microsoft jetzt auch noch eine weitere, einfache Möglichkeit zur Verfügung. Die Möglichkeit mit dem Adminpoint steht nur noch in der Enterprise-Version von Office zur Verfügung und ist mehr für große Firmen gedacht, die eine Installation über das Netzwerk durchführen.

Was wird benötigt?

  • Mindestens Windows XP ab SP2 als Betriebssystem
  • Die Original Office 2007 Sourcen
  • Das aktuelle Service Pack: <Download SP1>

Einbinden des Service Pack in Office 2007

Hier beschreiben wir das Vorgehen für das Einbinden des Service Pack SP1. Das Vorgehen lässt sich aber auch auf spätere Version der Service Packs anwenden.

  • Erstellen Sie ein Verzeichnis (z.B.: Office 2007) auf der Festplatte und kopieren den Inhalt der Office CD in das Verzeichnis
  • Erstellen Sie im Verzeichnis Office 2007, falls noch nicht vorhanden, den Ordner "Updates"
  • Entpacken Sie das Service Pack in den Ordner "Updates". Verwenden Sie dafür folgenden Aufruf:
    <Pfad>\office2007sp1-kb936982-fullfile-de-de.exe /extract:<Zielpfad>
    Geben Sie dabei als <Zielpfad> das Updateverzeichnis im oben angelegten Office-Verzeichnis an. In unserem Beispiel würde das, wenn alles auf Laufwerk ' D' liegt, folgendermaßen aussehen:
    D:\ office2007sp1-kb936982-fullfile-de-de.exe /extract:D:\Office2007\Updates
  • Nach dem Entpacken der Dateien ist die Einbindung abgeschlossen. Im Ordner Updates wurden mit SP1 folgende Dateien abgelegt:
    • ClientSharedMUIsp1-de-de.msp
    • MAINMUIsp1-de-de.msp
    • MAINWWsp1.msp Office64WWsp1.msp
    • Proofsp1-de-de.msp
    • Proofsp1-en-us.msp
    • Proofsp1-fr-fr.msp
    • Proofsp1-it-it.msp
  • Anschließend können Sie den Inhalt auf eine neue DVD/CD Brennen. Da es sich um keine Boot-CD handelt, müssen auch keine besonderen Einstellungen im Brennprogramm vorgenommen werden.

Gültige Parameter für das Service Pack

Die Service Pack Datei kann mit den folgenden Parametern aufgerufen werden:

Parameter | Beschreibung
/extract:<Pfad> | Extrahiert den Inhalt des Paketes in den durch Pfad angegebenen Ordner
/log[:<Pfad zur Protokolldatei>] | Aktiviert die ausführliche Protokollierung der Updateinstallation
/lang:lcid | Legt die Benutzeroberfläche auf das angegebene Gebietsschema fest, wenn mehrere Gebietsschemen im Paket vorhanden sind
/quit | Führt das Paket im unbeaufsichtigten Modus aus
/passive | Führt das Update ohne Benutzerinteraktionen aus
/norestart | Verhindert die Aufforderung an den Benutzer zum Neustart des Computers
/forcerestart | Erzwingt den Neustart des Computers nach der Aktualisierung
/? | Zeigt die Hilfe

Weitere Infos zu diesen Thema:

  • Schritt für Schritt: Konfigurieren des 2007 Office-Systems für ein Festplattenabbild

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2551.htm


Senden von Fehlerberichten in MS Office abschalten

Office XP hat eine neue Funktion, die beim Auftreten eines Fehlers einen Fehlerbericht als Mail an MS versenden möchte. Mit diesem Tipp können Sie einstellen, welche Informationen bei der Fehlerberichterstattung von Microsoft Office an Microsoft verschickt werden sollen.

Wenn das Office bei Ihnen mit einem Fehler abstürzt, bietet die Software die Möglichkeit ein entsprechendes Fehlerprotokoll mit Informationen an Microsoft zu verschicken. Diese Informationen werden von Microsoft dazu verwendet, um den Fehler finden und in einer der nächsten Versionen oder Service Packs beheben zu können.

Sie können die Anzeige dieses Dialoges ganz ausschalten (dann werden keine Daten an Microsoft mehr versendet), oder bei aktiver Funktion auch noch konfigurieren, welche Daten verschickt werden dürfen. Die Übertragung der Daten, wird über die Anwendung DW.EXE gesteuert.

Wer diese Abfrage nicht mehr haben will, kann das mit den folgenden Registry-Werten ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Common

oder über die Policy (überschreibt die obere Einstellung):

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Common

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Office\ [Version]\ Common

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie folgende neue Werte:

Wertname | Datentyp | Wert | Beschreibung
DWNeverUpload | REG_DWORD | 1 |
DWNoExternalURL | REG_DWORD | 1 |
DWNoFileCollection | REG_DWORD | 1 | Es werden keine Dateien mit übertragen
DWNoSecondLevelCollection | REG_DWORD | 1 | Es werden keine weiteren Daten, die zur Ermittlung des aufgetretenen Problems notwendig sind (Dateien, Dateiinfos, Registryeinstellungen usw), übertragen.

Danach will Office keine Debug-Informationen mehr an MS versenden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1250.htm


Fehlermeldung in Access 2000 nach SR1

Nach der Installation des Servicepacks SR1 für Office 2000 funktionieren die Assistenten von Access mit ActiveX nicht mehr.

Folgende Fehlermeldung wird ausgegeben:

"Objekterstellung durch ActiveX-Komponente nicht möglich."

Lösung des Problems:

Im Menü "Start ausführen" bitte folgenden Befehl ausführen:

regsvr32 "C:\Programme\Gemeinsame Dateien\Microsoft Shared\DAO\dao360.dll"

Info Den Pfad für die Datei "dao360.dll" vorher überprüfen und anpassen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1012.htm


Service Release 1 für Office 97 läuft nicht unter Windows 98

Das Update für Office 97 zeigt unter Windows 98 keine Wirkung.

Zur erfolgreichen Installation des Service Release SR1 deaktivieren Sie den Taskplaner und stellen Sie sicher, dass WALIGN.EXE nicht während der Installation von Office und Service Release 1 ausgeführt wird. Erst wenn beide Setups ausgeführt wurden, können Sie den Taskplaner wieder starten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0192.htm


WinWord meldet: Zu wenig Speicher

WinWord meldet "Zu wenig Speicher"

Sollte sich Ihr WinWord mit dieser Fehlermeldung melden, obwohl eigentlich genügend Speicher zur Verfügung steht, kann das folgende Ursachen haben:

  • Ein installierter, aber nicht mehr vorhandener Drucker im Druckermanager bzw. Printserver ist zur Zeit nicht erreichbar.
  • Die "Virtual DOS -Machine" kann auch diesen Fehler hervorrufen. Schalten Sie sie testweise aus, indem Sie mit STRG+ALT+ENTF den Taskmanager aufrufen und beenden Sie dort den Prozess "nt-vdm.exe"
  • Sie haben den Makro-Virus CAB!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0724.htm


Fehler in MSIEXEC.EXE beim Office 2000 Setup

Erscheint bei der Installation von Office 2000 bei Ihnen folgende Fehlermeldung: "MSIEXEC verursachte einen Fehler durch eine ungültige Seite im Modul MSIEXEC.EXE bei 015f:00400288", ist der Rechner mit dem CIH-Virus infiziert.

Da dieser Virus die Datei verändert, kann durch eine Reparatur der befallenen Datei der Virus zwar entfernt, aber die Dateien können nicht mehr funktionsmäßig hergestellt werden. Hier hilft oft nur das ganze System von nicht infizierten Datenträgern neu zu installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0513.htm


Office-Applikationen zeigen nach SR2 immer noch SR1 im Dialogfeld INFO

Der Logik folgend sollte man eigentlich annehmen, dass nach der Installation des SR2 dies auch im Dialogfeld "Info" der betreffenden Applikation angezeigt wird. Dem ist aber nicht so.

Das SR2 wurde ordnungsgemäß installiert, wenn die Applikationen folgende Versionsnummern zeigen:

Microsoft Access | 9.0.4402 SR-1
Microsoft Excel | 9.0.4402 SR-1
Microsoft FrontPage | 4.0.2.4426
Microsoft Outlook | 9.0.0.4527
Microsoft PowerPoint | 9.0.4527
Microsoft Word | 9.0.4402 SR-1

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=278269

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1058.htm


Installation der Update-Version von Office 2000

Bei einer Office 2000 Neuinstallation mit der Update-Version fragt das Setup nach einem updateberechtigten Office 97. Normalerweise schiebt man nun die Office 97 CD ins CD-ROM Laufwerk, gibt dieses im Setup als Quelle an und fährt mit dem Setup fort, welches gleich darauf wieder die Office 2000 CD haben will....

Man kann allerdings auch gleich die Office 2000 CD drin lassen und somit dem Setup vorgaukeln, es handle sich um Office 97. Das Setup identifiziert dann auf wundersame Weise Office 2000 als Office 97!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0510.htm


Reservierter Fehler 1104 unter Access 97

Bekommen Sie unter Access 97 die Fehlermeldung "Reservierter Fehler 1104", hat er die folgende Bedeutung: "Invalid Session handle" was bedeutet, dass Access die Verbindung zur Datenbank verloren hat.

Die Fehlermeldung kann durch folgende Fehler hervorgerufen werden:

  • Ein korruptes Formular oder korrupte Daten
  • Hardware/System-Fehler.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0306.htm


Word zeigt beim Starten keine Menüleisten und Symbole mehr an

Es kann beim Starten von Word zu dem Fehler kommen, dass die Menüleisten und Symbole nicht mehr angezeigt werden. Auch wenn Sie Word neu installieren, besteht der Fehler weiterhin. Dieser Fehler wird durch fehlerhafte Einträge in der Registry verursacht und kann nur durch das Löschen der entsprechenden Schlüssel behoben werden.

Erstellen Sie dafür am besten folgende REG-Datei, speichern diese unter einem beliebigen Namen mit der Endung <.REG> ab und führen Sie die Datei aus (Doppelklick oder Rechtsklick - Zusammenführen).

=== Hier schneiden ===
REGEDIT4

[-HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\Data]
[-HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data]

=== Hier schneiden ===

Je nach Office Version, müssen Sie die Versionsnummer durch Ihre aktuelle Office Version ersetzen:

8.0 | Office
9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Für die Version 8.0 und 9.0 sind die Einträge in der oberen Datei vorhanden.

Info Das Ausführen dieser Datei löscht alle Einträge und Unterschlüssel dieser Schlüssel.
Word erstellt beim nächsten Start diese Schlüssel mit den Standardeinstellungen neu.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1232.htm


Fehler bei der Installation vom Service Pack 2 für MS Office

Wenn bei der Installation vom Service Pack 2 eine Fehlermeldung auftritt und es sich nicht installieren lässt, gehen Sie folgendermaßen vor:

  1. Office komplett deinstallieren
  2. Office neu installieren
  3. SR1 installieren
  4. SR2 installieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0586.htm


Installationsprobleme bei Frontpage 98

Bei der Installation von Frontpage 98 kann es nach einem Neustart vorkommen, dass Frontpage eine Datei nicht ersetzen kann und darum immer wieder einen Neustart des Rechners durchführen will und die Installation somit nicht abschließen kann. Das kann zwei Gründe haben:

  • Die Datei "mfc42.dll" gibt es auf ihren PC zweimal und zwar im "Windows" und im "Windows\System" Verzeichnis. So findet Frontpage beim Hochfahren immer eine alte Version und ersetzt aber immer nur die Datei aus dem "Windows\System" Verzeichnis. Löschen Sie in diesem Fall die "mfc42.dll" aus dem Windows-Verzeichnis.
  • Die Datei "mfc42.dll" ist schreibgeschützt. In diesen Fall kann Frontpage sie nicht ersetzen. Entfernen Sie deshalb das Attribut "Read-Only"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0190.htm


Office 2000 SR1 Update sichern

Microsoft bietet jetzt auf der Homepage das Update von MS Office 2000 SR1 an. Sie können sich von der Seite aber nur eine kleine Setupdatei herunterladen, womit dann ein Onlineupdate durchgeführt wird. Nach dem Update werden die Dateien wieder gelöscht.

Wenn Sie Ihren Rechner also einmal wieder neu installieren, müssen Sie auch das Update wieder neu herunterladen. Wenn Sie das vermeiden wollen, gehen Sie folgendermaßen vor:

  1. Laden Sie sich von der Microsoft Homepage die Setup-Datei herunter:
    http://officeupdate.microsoft.com/germany/2000/downloaditems/o2ksr1a.exe
  2. Starten Sie jetzt diese Setupdatei, die über das Netz die erforderliche Updatedatei herunterladen wird. Beachten Sie, dass hier je nach Umfang Ihrer Installation unterschiedliche Daten heruntergeladen werden. Es werden nur die erforderlichen Daten heruntergeladen. Wenn Sie also später einmal mehr aus dem Office-Paket installieren, müssen Sie diesen Schritt wiederholen.
  3. Nach dem Herunterladen will das Setup sofort mit dem Update anfangen und Sie auffordern, die Office CD in das CD-ROM Laufwerk zu legen, das machen Sie aber bitte nicht.
  4. In Ihrem Temp-Verzeichnis sollten Sie jetzt ein Verzeichnis mit dem Namen "sr1patch" finden. In diesem Verzeichnis finden Sie eine Datei mit dem Namen: "{BD299CA2-1C97-11D4-AED6-00C04F022C53}". Kopieren Sie diese Datei nun an einen sicheren Ort (die anderen Dateien aus diesem Verzeichnis werden nicht benötigt).
  5. Damit Sie jetzt auch mit dieser Datei ein Update starten können, müssen Sie die Datei umbenennen. Geben Sie Ihr folgenden Namen "Office SR1 Update.msp"
  6. Jetzt können Sie das Office Update durch Anklicken dieser Datei starten. Das Update wird dann über den Windows-Installer durchgeführt (darum die Endung.MSP)

Info Das komplette Servicepack für die Premium-Version (CD 1 und CD2) incl. Windows-Installer-Update gibt es in der Admin-Version als Komplettdownload unter http://www.microsoft.com/office/ork/2000/appndx/toolbox_localized.htm#German(O2KSR1aDL.EXE, 50,8 MB).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0855.htm


Installation von Office97 scheitert mit Fehler

Nachdem die Vollversion von Windows 98 installiert wurde, wollte sich in Einzelfällen Office 97 Prof. nicht mehr installieren lassen. Es kommt eine Meldung, dass neuere Versionen der zu installierenden Dateien bereits installiert sind und deshalb das Setup abgebrochen wird.

Lösung:

Kopiere alle Dateien der CD auf die Festplatte, setze bei allen Dateien das Attribut Schreibgeschützt zurück und starte das Setup von dort.

Ein weitere Möglichkeit ist lt. der Microsoft KB:

In der WIN.INI unter [Compatibility] nach dem Eintrag BOOTSTRP= suchen und diesen mit einem Semikolon deaktivieren.

Nach einen Neustart sollte es klappen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0147.htm


Office 2000 Update schlägt fehl: 'Office ist nicht installiert'

Wenn ein Update von Office 2000 mit der Fehlermeldung "Office ist nicht installiert" abbricht, kann es daran liegen, dass die Datei Data1.msi nicht im Office-Verzeichnis vorhanden ist. Kopieren Sie diese Datei von der Office-CD in das Verzeichnis auf ihrer Festplatte und starten Sie das Update erneut.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1305.htm


SMTP after POP

Maildienste wie GMX verlangen, dass der Mailclient zuerst Mails abholt, bevor er neue versendet.

Die Reihenfolge der Abfragen muss also erst POP und dann SMTP sein.

Allerdings bieten Outlook und Outlook Express keine Option, um dieses Verhalten einzustellen. Auswirkung ist eine Fehlermeldung des Servers, da versucht wird, neue Mails zu versenden. Man kann aber wie folgt Abhilfe schaffen:

Die Konten in Outlook Express werden alphabetisch abgearbeitet. Man erstellt daher ein neues Konto mit gleichen Angaben, benennt dies aber am Anfang mit ABHOLEN, damit das Konto zuerst abgearbeitet wird.

Info Einige Outlook-Express-Versionen arbeiten die Mailkonten in der umgekehrten Reihenfolge ab! Das unterste Konto in der Liste ist somit das erste, welches abgearbeitet wird, daher ZUM ABHOLEN. Der Fehler ist Microsoft bekannt, dessen Ursache allerdings nicht.

Da jetzt 2 Mailkonten vorhanden sind (Abholen-Konto muss an 1. Stelle stehen), wählt man das VERSENDEN-Konto als Standard.

Um zu verhindern, dass der Client mit dem Versand-Konto auch abholt, geht man auf Extras -> Konten und deaktiviert unter den Eigenschaften des Versand-Kontos die Option "Dieses Konto beim Empfangen von E-Mail einbeziehen".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0828.htm


Sicher vor gefährlichen HTML E-Mails

E-Mails können als "plain-text" und im HTML-Format verschickt werden. Solche Mails werden wie Webseiten im Mailclient dargestellt und können daher alle Inhalte beinhalten, welche auch Webseiten bieten. Dies reicht von animierten GIFs bis zu aktiven Scriptinhalten.

Allerdings sollte man dies aus Sicherheitsgründen verbieten.

Sowohl Outlook Express als auch Outlook bieten unter EXTRAS-Optionen-Sicherheit eine Funktion, um Webinhalte auf eine andere Sicherheitszone zu schalten.

Beim Outlook schaltet man hierzu in dem Drop-Down-Feld "Zone" auf "eingeschränkte Sites".

Beim Outlook Express aktiviert man den Button "Zone für eingeschränkte Sites".

Was damit genau alles deaktiviert wurde, lässt sich in den Interneteinstellungen des Internet-Explorers (Systemsteuerung, Internetoptionen) unter Sicherheit einsehen und modifizieren, indem man die Zone "Eingeschränkte Sites" selektiert (ganz rechts) und unten dann auf Stufe anpassen geht. Dieses Dialogfenster lässt sich beispielsweise aus dem Outlook 2000 auch direkt aufrufen. Zuletzt sollte man hier "aktive Scripting" und "AktiveX-Steuerelemente ausführen" deaktivieren.

So ist man vor den meisten ungebetenen Mails sicher.

Als generelle Vorsichtsmaßnahme empfiehlt es sich, den Windows Scripting Host im Windows-Setup (Einstellungen: Software) zu deinstallieren, sofern man ihn nicht regelmäßig benutzt (nicht Windows 2000).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0892.htm


Standard E-Mail Client einstellen

Wenn Sie auf einer Web-Seite auf "MAILTO" (E-Mail Senden) klicken, wird auf Ihren Rechner automatisch ein E-Mail Programm geöffnet. Hier können Sie einstellen, welches E-Mail Programm gestartet werden soll.

Geben Sie dafür hier den Pfad und den Programmnamen ein und zur Parameterübergabe geben Sie %1am Ende an: "C:\programme\Outlook Express\msimn.exe" %1

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ mailto\ shell\ open\ command

Geben Sie hier bei "(Standard)" den Pfad und Dateinamen zum Standardmailprogramm ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1614.htm


RTF-Anhänge werden nicht als RTF erkannt

RTF-Anhänge werden nicht als RTF erkannt beim Versenden mit Thunderbird

Versendet man RTF-Dateien mit Thunderbird, kann es vorkommen, dass diese Anhänge vom Empfänger nicht als RTF-Datei erkannt werden und deshalb als Testdatei behandelt und auch so angezeigt werden.

Damit ein Programm eine RTF-Extension auch als solche erkennen kann, muss der Mime-Typ (Multipurpose Internet Mail Extensions) vom Versender richtig gesetzt werden.

Thunderbird ermittelt den Mime-Typ aber nicht selber, sondert befragt das Betriebssystem nach dem richtigen Typ. Durch einen fehlerhaften Eintrag, wird hier aber der falsche Typ übermittelt.

Damit der richtige Typ gesetzt werden kann, müssen Sie folgenden Wert in der Registry ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\ .rtf

Erstellen Sie hier einen neuen Wert mit dem Namen "Content Type" als Datentyp REG_SZ und setzen Sie den Wert auf "application/rtf".

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2044.htm


Mailverzeichnis von Outlook 98 anpassen

Outlook 98 speichert seine Dateien in der Datei Outlook.pst ab, welche ja nach Installation in das Programmverzeichnis abgelegt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows MessagingSubsystem\ Profiles\ MicrosoftOutlook-Interneteinstellungen\ [Ihre-SID]

können Sie den Pfad zu der Datei "Outlook.pst" anpassen.

Es geht aber auch noch anders:

Verschieben Sie die Datei Outlook.pst an den gewünschten Ort. Wenn Sie nun Outlook starten, werden Sie informiert das Outlook die PST-Datei nicht finden kann und Sie haben jetzt die Möglichkeit, die Pfadangaben in der Auswahlbox zu ändern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0657.htm


In Outlook gesperrte Dateianhänge (Level 1-Dateien) wieder anzeigen

In diesem Tipp wird beschrieben, wie unter Microsoft Outlook die gesperrten Dateianhänge wieder angezeigt werden können, die aus Sicherheitsgründen automatisch ausgeblendet werden.

Um gesperrte Dateianhänge (EXE Dateien usw.) auch ab Outlook 2000 öffnen zu können, muss man in der Registry im Wert "Level1Remove" die entsprechenden Dateiendungen angeben.

Standardmäßig werden sämtliche Anhänge, die Outlook für gefährlich hält, ausgeblendet (es ist kein Zugriff auf diese Anhänge mehr möglich). Outlook zeigt dann folgende Fehlermeldung an: "Outlook hat den Zugriff auf die folgenden potenziell unsicheren Anlagen blockiert".

Durch den Eintrag können Sie die gewünschten Dateiendungen für Outlook freischalten. Danach werden diese Dateianhänge wieder in der Mail angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie einen neuen Wert mit dem Namen "Level1Remove" als Datentyp REG_SZ. Geben Sie hier die Erweiterungen an, die in Zukunft angezeigt werden sollen. Mehrere Erweiterungen werden durch Semikolon getrennt, z.B.: "url;exe;com".

Folgende Dateiendungen sind bei Outlook standardmäßig gesperrt:

Dateiendung | Beschreibung/Typ
ADE | Microsoft Access Project Extension
ADP | Microsoft Access Project
ASX | Windows Media Audio/Video
BAS | Microsoft Visual Basic class module
BAT | Batch Datei
CHM | Compiled HTML Help Datei
CMD | Microsoft Windows NT Command Script
COM | MS-DOS ausführbare Datei
CPL | Systemsteuerungsdatei
CRT | Sicherheitszertifikat
EXE | Ausführbare Datei
HLP | Hilfe Datei
HTA | HTML Programm
INF | Setup Informationen
INS | Internet Naming Service
ISP | Internet Kommunikations Einstellungen
JS | Jscript Datei
JSE | Jscript Codierte Datei
LNK | Verknüpfung
MDB | Access Datenbank
MDE | Access Datenbank
MSC | Microsoft Konsolen Programm
MSI | Microsoft Installationspaket
MSP | Microsoft Installationspatch
MST | Microsoft Installationsprogramm; Visual Test Source Datei
PCD | Photo CD Datei; Visual kompiliertes Script
PIF | MS-DOS Shortcut
PRF | Outlook Profil Datei
REG | Registry Datei
SCF | Windows Explorer Datei
SCR | Screen Saver
SCT | Windows Script Datei
SHB | Shell Scrap Datei
SHS | Shell Scrap Objekt
URL | Internet Verknüpfung
VB | VBScript Datei
VBE | Codierte VBScriptdatei
VBS | VBScript Datei
WSC | Windows Script Komponente
WSF | Windows Script Datei
WSH | Windows Scripting Host Einstellungen
Nach Office Service Pack zusätzlich noch:
ASP | Active Server Page
TMP | Temporäre Dateien
VSMACROS | Visual Studio .NET binär-basiertes Makroprojekt (Microsoft)
VSS | Visio Stencil (Microsoft)
VST | Visio Template (Microsoft)
VSW | Visio Workspace-Datei (Microsoft)
WS | Windows-Scriptdatei (Windows Script File

Info Siehe auch "Sicherheitsstufe 1-Dateien in Outlook nach SR2 wieder anzeigen".

Info Siehe auch Tipp: "In Outlook zusätzliche Dateianhänge sperren"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=318515

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1135.htm


In Outlook zusätzliche Dateianhänge sperren

Ab Outlook 2000 ist eine Liste von gefährliche Dateianhängen hinterlegt, wo der Zugriff auf diese Dateien unterbunden wird (siehe Tipp: "In Outlook gesperrte Dateianhänge (Level1-Dateien) wieder anzeigen").

Wenn Sie noch weitere Dateiendungen in Outlook sperren wollen, können Sie die Liste mit dem Registryeintrag "Level1Add" erweitern. Alle hier angegebenen Dateiendungen werden dann auch in Outlook ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Security

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Outlook\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie einen neuen Wert mit dem Namen "Level1Add" als Datentyp REG_SZ. Geben Sie hier die Erweiterungen an, die in Zukunft nicht mehr angezeigt werden sollen. Mehrere Erweiterungen werden durch Semikolon getrennt, z.B.: ".zip;.rar;.arj".

Info Siehe auch Tipp: "In Outlook gesperrte Dateianhänge (Level1-Dateien) wieder anzeigen"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=318515

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2412.htm


Outlook 2000 Startfehler weist auf Problem hin

Outlook 2000 SR2

Beschreibung:

Nach dem Starten von Outlook 2000 SR2 erscheint folgende Fehlermeldung: "Es ist möglich, dass Microsoft Office und andere Programme mit Email-Funktionen auf Grund eines kürzlich installierten Programms nicht korrekt ausgeführt werden. Outlook kann diesen Konflikt ohne Auswirkungen auf das Programm, das den Konflikt verursacht hat, lösen. Soll Outlook dieses Problem lösen?" Wenn man mit "Ja" bestätigt, erscheint folgende Fehlermeldung: "Der Konflikt zwischen einem kürzlich installieren Programm und Microsoft Office oder anderen Programmen mit Email Funktionen kann von Outlook nicht gelöst werden. Outlook muss eine Systemkomponente ändern, die zurzeit von einem anderen Programm verwendet wird. Starten Sie Windows erneut, um dieses Problem zu lösen."

Lösung:

Tritt dieser Fehler nach dem geforderten Neustart von Windows immer noch auf, so sollte man das Programm fixmapi.exe starten, das sich in der Regel im Windows-Systemverzeichnis befindet. Danach sollte die Fehlermeldung nicht mehr erscheinen. Es handelt sich hierbei um einen Konflikt mit der MAPI.DLL.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1097.htm


Outlook meldet Registrierungsfehler beim ersten Start

Outlook 2000 benötigt einen installierten Outlook Express, damit Outlook selber richtig läuft. Ist nach der Installation kein Outlook-Express installiert, meldet Outlook einen Fehler beim Registrieren von Komponenten und schlägt als Abhilfe die Neuinstallation vor und beendet sich dann.

Sobald Outlook Express jetzt nachträglich installiert wurde, ist der Fehler beseitigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1126.htm


PST-Datei reparieren

PST-Datei (OE) reparieren

Nach einem Absturz kann es schon einmal passieren, dass die PST-Datei von Outlook beschädigt ist.

n diesem Fall schlägt Outlook sogar vor, diese zu reparieren, nur wie? Dafür gibt es auf jeder Installation das Programm Scanpost.

Diese Datei scanpst.exe befindet sich - je nach System - an unterschiedlichen Stellen der Platte. Das Programm suchen und starten. Weiteres ist selbsterklärend.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1093.htm


Sicherheitsstufe 1-Dateien in Outlook nach SR2 wieder anzeigen

Im SR2 von Office 2000 ist auch das Sicherheitsupdate für Outlook enthalten. Das Update verbietet alle Level1-Dateien, so dass sie als Anhang automatisch deaktiviert werden. Diese Einträge sind fest vorgegeben und können lediglich ergänzt werden.

Liste der Level-1-Dateien:

ADE, ADP, BAS, BAT, CHM, CHM,CMD, COM, CPL, CRT, EXE, HLP, HTA, INF, INS, ISP, JS, JSE, LNK, MDB, MDE,MSC, MSI, MSP, MST, PCD, PIF, REG, SCR, SCT, SHS, URL, VB, VBE, VBS, WSC,WSF, WSH.

Wer dennoch diese Dateitypen in Outlook weiter normal behandeln möchte, muss eine Office-Installation, bestehend aus der Installation und erfolgreichem SR 1, wie folgt editieren:

Vor dem SR2 sichert man die Dateien

outllib.dll (...\Programme\Microsoft Office\Office) und

outllibr.dll (...\Programme\Microsoft Office\Office\1031),

installiert das SR2 und kopiert die Dateien dann wieder zurück. Man sollte unbedingt aber die Dateien vom SR1 benutzen (outllib.dll Version 9.0.0.3821 und outllibr.dll 9.0.0.3821) und nicht die von der Office-CD, da es sonst zu Problemen unter Outlook kommen kann.

Siehe auch "In Outlook gesperrte Level1-Dateien öffnen".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1062.htm


Adressbuch von Outlook-Kontakten trennen

Seit Outlook 97 hat MS einen neuen Ordner „Kontakte“ eingeführt. Dieser Ordnertyp ersetzt quasi das persönliche Adressbuch (PAD-Datei). MS hat vor der Einführung von Kontakten alle Adressen in einer PAD-Datei abgelegt und gespeichert. Seit Outlook haben diesen PAD-Dateien eigentlich keine große Bedeutung mehr und werden meist nur noch für den Import und Export von Adressen benutzt.

Wird Outlook zusammen mit Outlook-Express installiert, sind neben dem Adressbuch auch noch die Kontakte in Outlook vorhanden. Wer sowieso Outlook benutzt, sollte nur hier seine Adressen verwalten.

Problematisch ist die Tatsache, dass das persönliche Adressbuch von Windows/Outlook-Express an die Kontakte von Outlook geknüpft ist (wenn dies im Internet-Modus installiert wurde). Beide Adressbestände halten sich zwar synchron; allerdings bringt diese unsaubere Trennung auch Probleme beim Editieren von Mailnamen etc.

Aus diesem Grund (oder wer nur ein anders Adressbuch für den Outlook Express will) sollte das Adressbuch gestartet und hier unter "Extras" -> "Optionen" die Gemeinsame Verwendung deaktiviert werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1079.htm


Zugriff auf Outlook Archive

Je nach Einstellung werden ältere Mails von Outlook automatisch archiviert und in die die Datei archive.pstgeschrieben. Möchte man später wieder auf Mails in diesem Archiv zugreifen, geht man wie folgt vor:

Zunächst sucht man die Datei (meist "%UserProfile% \Lokale Einstellungen\Anwendungsdateien\Microsoft\Outlook\archive.pst"). Dann startet man Outlook und wählt über den Befehl Öffnen -> Persönliche Ordner- Datei (pst)und wählt hier die archive.pst. Diese wird dann in der Baumansicht mit aufgenommen.

Um archivierte Mails wieder aufzurufen, klickt man in den Ordner "Ordner archivieren" in der Ordnerliste und wählt die gewünschte Mail.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1080.htm


Persönlichen Ordner per Passwort schützen

Unter Outlook kann man den persönlichen Ordner, welcher beim Start normalerweise geladen wird, mit einem Passwort vor unberechtigten Lesern schützen:

Dazu selektiert man den persönlichen Ordner in der Ordnerliste, wählt hier über das Kontextmenü "Eigenschaften" und findet unter "Erweitert" eine Möglichkeit, um den Passwortschutz zu aktivieren.

Info Öffnet nun jemand anderes Outlook, wird er nach dem Passwort gefragt. Kennt er dieses nicht und startet Outlook, wird die gesperrte Struktur komplett neu angelegt. Folge: wenn sich der Benutzer mit Passwort wieder einloggt, sind alle Ordner doppelt vorhanden. Problematisch ist dies, wenn Regeln zur automatischen Mailverarbeitung erstellt wurden, da sich diese inzwischen auf die neuen Ordner beziehen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1033.htm


Schutzverletzung bei "Senden an"

Benutzt man die "Senden an"-Funktion aus dem Kontextmenü oder über den Internet-Explorer, kann es mit dem Outlook 2000 zu folgender Fehlermeldung kommen:

(Details)

OUTLOOK verursachte einen Fehler durch eine ungültige Seite in Modul MSO9.DLL bei 016f:30a367ad.

Dieser Fehler tritt dann auf, wenn das Plugin "Outlook-Sicherung für PST-Datei" installiert wurde.

Man kann dies wieder deaktivieren, indem man im Outlook 2000 unter Extras, Optionen, Weitere, Erweiterte Optionen, COM-Add-Ins deaktiviert.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=240813

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0916.htm


Outlook beim minimieren im System-Tray anzeigen

Hier wird beschrieben, wie Sie Microsoft Outlook beim minimieren in das System-Tray (Infobereich) der Taskleiste ablegen können.

Ab Office XP

Wenn Sie Outlook (nicht zu verwechseln mit Outlook Express!) verwenden, um Ihre Termine usw. zu verwalten, muss dieses Programm immer aktiv sein, damit Sie an die Termine erinnert werden kann.

Über einen Eintrag in der Registry "MinToTray" können Sie dafür sorgen, dass Outlook beim minimieren als Symbol im System-Tray angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Preferences

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie einen neuen Wert mit dem Namen "MinToTray" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

Outlook minimiert im System-Tray starten

So können Sie Outlook z.B. in den Autostart-Ordner packen, damit es dabei gleich minimiert startet, gehen Sie folgendermaßen vor:

  1. Outlook ist nicht so konfiguriert, dass standardmäßig die Ansicht "Outlook Heute" geöffnet wird. Dafür unter Outlook die Startseite Outlook Heute deaktivieren bei Outlook Start.
  2. Beenden Sie Outlook.
  3. Legen Sie eine Verknüpfung der Outlook.exe auf dem Desktop an. Verweisen Sie auf die Outlook.exe aus dem Verzeichnis: (<Laufwerk>\Microsoft Office\Office[Version]\outlook.exe)
  4. Klicken Sie mit der rechten Maustaste auf die Verknüpfung, und klicken Sie dann auf Eigenschaften.
  5. Klicken Sie auf der Registerkarte Verknüpfung in der Liste Ausführen auf Minimiert, klicken Sie auf Übernehmen und anschließend auf OK.

Um Outlook beim Starten von Windows im minimierten Zustand zu starten, kopieren Sie die Verknüpfung in den Autostart-Ordner, und belassen Sie eine Kopie auf dem Desktop. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf die in den vorherigen Schritten erstellte Verknüpfung, und klicken Sie dann auf Kopieren.
  2. Klicken Sie mit der rechten Maustaste auf Start, und klicken Sie dann auf Explorer, um den Ordner Startmenü in Windows Explorer zu öffnen.
  3. Klicken Sie auf das Pluszeichen neben dem Ordner Programme, und klicken Sie dann auf den Ordner Autostart.
  4. Klicken Sie mit der rechten Maustaste in Windows Explorer in den rechten Bereich, und klicken Sie anschließend auf Verknüpfung einfügen.

Wenn Sie Windows neu starten, wird Outlook in einem minimierten Zustand ausgeführt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1222.htm


Willkommen-Mail in Outlook

Mit diesem Tipp können Sie in Outlook bestimmen, ob eine Willkommen-Mail beim ersten Start verschickt werden soll, und Sie können auch eine eigene Mail vorgeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Outlook Express:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express\ 5.0\ Default Settings\ Mail

Erstellen Sie hier einen neuen Wert mit dem Namen "Welcome Message" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Willkommens Mail
0 | Sendet eine Willkommens Mail

Mit diesem Wert "WelcomeHtmFile" als Datentyp REG_SZ können Sie festlegen, welche Mail versendet werden soll.

Die Werte "WelcomeEmail" und "WelcomeName" als Datentyp REG_SZ legen die eMail Adresse und den Namen fest unter der die Mail erscheinen soll.

Outlook 2000\XP:

Hier müssen Sie nur die Datei: "C:\Program Files\Microsoft Office\Office\Welcome.msg" löschen, bevor Sie Outlook starten. Sie können diese Datei auch bearbeiten, da es eine einfache HTML-Datei ist und somit eine eigene "Willkommens Mail" erstellen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1403.htm


Feiertage in Outlook Eintragen

Falls in Ihrem Outlook-Kalender bislang gar keine Feiertage eingetragen sind, dann können Sie das auf folgendem Weg nachholen.

Outlook 2000: "Extras" - "Optionen" - "Kalenderoptionen" - "Feiertage hinzufügen".

Microsoft hat mittlerweile eine neue Feiertagsliste als Add-In für Outlook zur Verfügung gestellt, die die Feiertage enthält.

Downloads Outlook Feiertage

  • Link Outlook 2000
  • Link Outlook 2002
  • Link Outlook 2003

Die bislang eingetragenen Daten lassen sich über "Ansicht" - "Ereignisse" anzeigen. Wenn Sie innerhalb der Kategorie "Feiertag" nach dem Feld "Serienbeginn" sortieren, können Sie dort veraltete Eintragungen auf einen Schlag löschen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1396.htm


Startparameter von Outlook

Hier finden Sie eine Auflistung der möglichen Startparameter von Microsoft Outlook.

outlook /c ipm.stickynote

outlook /c ipm.contact

outlook /c ipm.appointment

outlook /c ipm.note

outlook /c ipm.task

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0932.htm


Zertifikat Bindung mit der E-Mail Adresse unterbinden

Wenn Sie eine E-Mail mit einem Zertifikat versenden wollen, kann es sein, dass Sie ein anderes Zertifikat benutzen wollen. Mit diesem Tipp können Sie die Zertifikat Bindung zur E-Mail Adresse unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Office\ [Version]\ Outlook\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "SupressNameChecks" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Zertifikat ausschalten
0 | Zertifikat aktiv (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1607.htm


Windows Messenger (MSN) in Outlook sperren

Mit diesem Tipp können Sie einstellen, dass der Windows Messenger bei starten von Outlook nichtmit geöffnet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Outlook\ InstantMessaging

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceDisableIM" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | MSN nicht starten
0 | MSN starten (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1617.htm


Speichern des Passwortes für die Mailabholung unterbinden

Mit diesem Tipp können Sie einstellen, dass die Passwörter bei den Internetmails (IMAP, POP3 und Hotmail) nicht gespeichert werden und man die Passwörter immer beim Abholen eingeben muss.

Geht erst ab Office XP mit SP1

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Outlook\ Security

oder

HKEY_CURRENT_USER\ Microsoft\ Office\ [Version]\ Outlook\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableRememberPwd" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Passwort nicht speichern
1 | Passwort speichern (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1618.htm


'Outlook Heute' kann nach Sicherheitsupdate nicht mehr angepasst werden

"Outlook Heute" kann nach Sicherheitsupdate nicht mehr angepasst werden

Hier wird beschrieben was Sie machen müssen, wenn "Outlook Heute" nicht mehr angezeigt wird.

Problem:

Wenn Sie die Ansicht "Outlook Heute" anklicken, wird Ihnen nach dem Einspielen des Sicherheitsupdates (813489) nichts mehr angezeigt.

Damit Sie die Einstellungen von "Outlook Heute" wieder anpassen können, müssen Sie das Sicherheitsupdate teilweise deaktivieren. Aus Sicherheitsgründen sollten Sie nach den durchgeführten Anpassungen diesen Wert wieder zurückstellen, damit Ihr System nicht gefährdet ist.

Gehen Sie folgendermaßen vor:

Beenden Sie Outlook 2000

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Internet Explorer\ Application Compatibility

erstellen Sie einen neuen Eintrag mit dem Namen "Outlook.exe" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Outlook Heute" kann geändert werden (Sicherheitsupdate deaktiv)
0 | "Outlook Heute" kann nicht aufgerufen werden (Sicherheitsupdate aktiv) (Standard)

Starten Sie anschließend Outlook, rufen Sie "Outlook Heute" auf und führen Sie Ihre gewünschten Einstellungen durch. Anschließend sollten Sie Outlook wieder beenden und den Wert wieder auf 0 zurücksetzen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/default.aspx?scid=820575

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1652.htm


Outlook Temp-Verzeichnis für Dateianhänge festlegen

Wenn Sie in Outlook ein Dateianhang in einer Mail öffnen, wird diese Datei in ein TEMP-Verzeichnis abgelegt und dann angezeigt. Mit diesem Tipp können Sie den Ordner dafür festlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Security

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "OutlookSecureTempFolder" als Datentyp REG_SZ und geben Sie den entsprechenden Pfad ein.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1746.htm


Benutzung des Offline-Adressbuch im Cached Mode

Wird bei Outlook der "Cached Mode" aktiviert, benutzt Outlook automatisch immer das Offline-Adressbuch, auch wenn sich der Rechner im LAN befindet. Das führt dazu, dass Änderungen im Adressbuch immer erst nach einer gewissen Zeit bekannt werden.

Mit dem folgenden Wert kann man einstellen, dass Outlook auch im "Cached Mode" mit dem Netzwerkadressbuch gearbeitet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Cached Mode

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

Erstellen Sie hier einen neuen Wert mit dem Namen "DownloadOAB" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Offline Adressbuch benutzen und automatisch herunter laden
0 | Adressbuch nicht automatisch herunter laden

Info Wenn schon eine lokale OAB-Datei vorhanden ist, müssen Sie diese Datei löschen, damit der Client nicht weiterhin diese Datei benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2024.htm


Unsichere E-Mails nur als Text anzeigen

Dieser Tipp bietet die Möglichkeit, Microsoft Outlook so zu konfigurieren, dass alle nicht digital signierten oder nicht verschlüsselten Email-Nachrichten im Text-Format angezeigt werden.

Info Ab Microsoft Office XP Service Pack 1 (SP1)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Options\ Mail

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003

erstellen Sie einen neuen Wert mit dem Namen "ReadAsPlain" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Als Text anzeigen
0 | Normal anzeigen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2057.htm


Nachrichten werden in Outlook nicht sofort versendet

Durch die Installation von Service Pack 2 unter Windows XP kann es dazu kommen, dass der Nachrichtenversand mit Outlook 2000/2002 nicht mehr richtig funktioniert. Durch einen Fehler bleiben die Nachrichten länger im Postausgang liegen, ehe sie versendet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Office\ [Version]\ Outlook\ RPC

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)

Erstellen Sie einen neuen Wert mit dem Namen "ForcePolling" als Datentyp REG_DWORD, und setzen Sie den Wert auf 0.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2131.htm


Anpassung 'Outlook Heute': URL zur 'Outlook Heute' Seite festlegen

Anpassung "Outlook Heute": URL zur "Outlook Heute" Seite festlegen

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren.

Mit diesem Tipp können Sie eine URL zu einer eigenen "Outlook Heute" Seite festlegen. Dort müssen Sie eine entsprechende HTML-Datei abgelegt haben.

Hier sind 3 Eingabeformate gültig:

- Webverknügfungen (http://Pfad/OutlookHeute.htm)

- Dateiangabe (file://Pfad/OutlookHeute.htm)

- Ressourcenverweis (res://Pfad/Ressourcen-DLL.dll/OutlookHeute.htm)

Diese Einstellung kann an 4 Stellen vorgenommen werden, deshalb ist es etwas unübersichtlich.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

WertName | Datentyp | Beschreibung
CustomUrl | REG_SZ | Verweis zur Seite
Url | REG_SZ | Verweis zur Seite (Nur aus Kompatibilitätsgründen vorhanden)
UserDefinedURL | REG_SZ | Einstellung aus Outlook selber

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Outlook\ Webview\ mailbox

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

WertName | Datentyp | Beschreibung
Url | REG_SZ | Verweis zur Seite (als Policy)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2133.htm


Anpassung 'Outlook Heute': Einbindung des Internet Explorer konfigurieren

Anpassung "Outlook Heute": Einbindung des IE konfigurieren

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren.

Mit diesem Tipp können Sie die Einbindung des Internet Explorers konfigurieren. Bei Outlook wird eine optimierte und von der Funktionalität etwas eingeschränkte Version des Internet Explorers standardmäßig eingebunden. Wer selber einige Outlook-Heute Seiten baut, kann hier aktivieren, dass die volle Funktionalität des Internet Explorers eingebunden wird.

Dies kann allerdings zu Leistungseinbußen bei der Darstellung führen und sollte deshalb nur bei Anzeigeproblemen gemacht werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Office\ [Version]\ Outlook\ Webview\ mailbox

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "Navigation" als Datentyp REG_SZ und setzen den Wert auf:

YES | Vollversion des Internet Explorers einbinden
gelöscht | Angepasste Version

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2134.htm


Anpassung 'Outlook Heute': Sortierkriterium für Aufgaben

Anpassung "Outlook Heute": Sortierkriterium für Aufgaben

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren.

Mit diesem Tipp können Sie das Sortierkriterium und die Sortierreihenfolge für Aufgaben festlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "Sort1" für die erste Sortierung oder "Sort2" für die zweite Sortierung als Datentyp REG_SZ und setzen den Wert auf:

Werte | Beschreibung
(leer) | Keine Angabe
[DueDate] | Fälligkeitsdatum
[Importance] | Wichtigkeit
[Creation Time] | Erstellzeit
[StartDate] | Startdatum
[Subject] | Betreff

ändern Sie hier den Wert "Sort1Asc" für die erste Sortierung oder "Sort2Asc" für die zweite Sortierung als Datentyp REG_SZ und setzen den Wert auf:

Werte | Beschreibung
TRUE | Aufsteigend
FALSE | Absteigend

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2135.htm


Anpassung 'Outlook Heute': Aufgaben ohne Fälligkeitsdatum anzeigen

Anpassung "Outlook Heute": Aufgaben ohne Fälligkeitsdatum anzeigen

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren.

Mit diesem Tipp können Sie einstellen, ob auch Aufgaben ohne Fälligkeitsdatum in "Outlook Heute" angezeigt werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "IncNoDueDate" als Datentyp REG_SZ und setzen den Wert auf:

TRUE | Aufgaben ohne Fälligkeitsdatum anzeigen
FALSE | Aufgaben mit Fälligkeitsdatum anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2136.htm


Anpassung 'Outlook Heute': Seite deaktivieren

Anpassung "Outlook Heute": Seite deaktivieren

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren.

Mit diesem Tipp können Sie die Anzeige der "Outlook Heute" Seite deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "Disable" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Anzeige von "Outlook Heute" deaktivieren
0 | Anzeige von "Outlook Heute" aktiv

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2137.htm


Anpassung 'Outlook Heute': Anzuzeigende Aufgaben

Anpassung "Outlook Heute": Anzuzeigende Aufgaben

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute" Seite in Outlook konfigurieren, d.h. welche Aufgaben angezeigt werden sollen.

Mäöglich sind die Werte:

All oder Today.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

ändern Sie hier den Wert "TaskFilter" als Datentyp REG_SZ und setzen den Wert auf:

All | Alle Aufgaben
Today | Heutige Aufgaben

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2138.htm


Anpassung "Outlook Heute": Anzahl der im Kalender anzuzeigenden Tage (Terminvorschau)

Mit dieser Einstellung können Sie die Ansicht der "Outlook Heute"- Seite in Outlook konfigurieren.

Die Einstellung "CalDays" konfiguriert die Anzahl der im Kalender anzuzeigenden Tage in der Terminvorschau. Standardmäßig sehen Sie unter "Outlook Heute" nur eine Terminvorschau der nächsten 5 Tage, welche Sie über die Schaltfläche "Outlook Heute anpassen" in der Oberfläche auf maximal 7 Tage erhöhen können. Wenn Sie die Vorschau über mehr als 7 Tage erweitern möchten, müssen Sie das über selber in die Registry eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Today

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)

Ändern Sie hier den Wert "CalDays" als Datentyp REG_SZ, und geben Sie die Anzahl der Tage an. Die möglichen Werte liegen zwischen 0 - 45 Tagen. Der Standardwert ist 5.

Der Höchstwert ist "eigentlich" beliebig. Entscheidend ist, dass nur höchstens 45 Einträge angezeigt werden. Wenn also pro Tag nur ein Termin eingetragen ist, ergibt sich dadurch ein Höchstwert vom 45.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2139.htm


Pfad für *.OST und *.PST Dateien unter Outlook festlegen

Mit diesem Tipp können Sie den "Standardpfad für *.OST und *.PST Dateien" unter Outlook ab Office 2000 festlegen.

Info Bis Office 2003 - ohne Post-Service Pack 1 -, kann der Pfad für *.PST und *.OST Dateien nur über den Eintrag für die PST-Dateien bestimmt werden. Danach wurde auch für *.OST Dateien ein extra Eintrag festgelegt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Office\ [Version]\ Outlook

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (9.0)
10.0 | Office 2002 (10.0)
11.0 | Office 2003 (11.0)
12.0 | Office 2007 (12.0)

ändern Sie hier den Wert "ForcePSTPath" als Datentyp REG_EXPAND_SZ und geben Sie den Pfad für *.PST-Dateien an.

ändern Sie hier den Wert "ForceOSTPath" als Datentyp REG_EXPAND_SZ und geben Sie den Pfad für *.OST-Dateien an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2140.htm


Outlook 2007: Verbindung mit Exchange Server ohne Standardgateway

Outlook: Verbindung mit Exchange Server ohne Standardgateway

Ab Outlook 2007 wird, wenn Sie einen Proxyzugang für das Internet benutzen, von Outlook erwartet, dass der Rechner einen gültigen Eintrag im Standardgateway besitzt. Ist am Rechner kein Standardgateway eingetragen, erscheint eine Fehlermeldung, dass keine Verbindung zum Exchange Server hergestellt werden konnte.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version] \ Outlook\ RPC

Erstellen Sie hier einen neuen Wert mit dem Namen "DefConnectOpts" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

12.0 Office 2007

1 | Verbindung über Standardgateway(Standard)
0 | Ohne Standardgateway

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=913843

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2166.htm


Leiste: "Klicken Sie hier, um die Sofortsuche zu aktivieren" ausblenden

Outlook: Leiste "Klicken Sie hier, um die Sofortsuche zu aktivieren" ausblenden

In Outlook 2007 gibt es die Leiste "Klicken Sie hier, um die Sofortsuche zu aktivieren". Wenn Sie die Leiste nicht benötigen, können Sie die Leiste folgendermaßen ausblenden.

Gehen Sie in das Menü "Extras" -> "Optionen" -> auf den Tabreiter "Weitere" -> . Wählen Sie unter "Allgemein" den Button "Erweiterte Optionen" -> , entfernen Sie den Haken bei "Eingabeaufforderung zum Aktivieren der Sofortsuche anzeigen".

Info Dieser Eintrag ist nicht vorhanden, wenn Outlook unter "Windows Vista" ausgeführt wird, oder wenn auf dem Computer unter Windows XP die Windows Desktopsuche installiert wurde.

Diese Einstellung können Sie auch über die Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Search

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

12.0 Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableSearchDownloadPrompt" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag wird nicht angezeigt
1 | Eintrag wird angezeigt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2411.htm


Outlook: Suchfunktion um "Abfrage-Generator" mit AND-Suche erweitern

Die Suchfunktion in Outlook können die einzelnen Suchbegriffe nur mit "OR" verknüpften. Diese erweitere Suche finden Sie unter "Extras" -> "Suchen" -> "Erweiterte Suche..." (bzw. STRG+Umschalt+F), wo unter dem Tabreiter "Erweitert" die Suchoptionen festgelegt werden können.

Wenn Sie diesen Tipp aktivieren, wird ein weiterer Tabreiter "Abfrage-Generator" eingeblendet, wo Sie auch Abfragen mit AND-Verknüpfungen erstellen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Schlüssel mit dem Namen "QueryBuilder" und starten Sie Outlook neu. Der Eintrag müsste dann folgendermaßen aussehen:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 11.0\ Outlook\ QueryBuilder

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2458.htm


Outlook: Body Codierung für den Nachrichtentext konfigurieren

Bis Outlook 2000 war es noch möglich, die Textcodierung in der Oberfläche zu ändern. Ab Outlook 2002 wurde diese fest auf "Quoted-Printable" eingestellt und kann nicht mehr über die Oberfläche geändert werden.

Für einige Fälle (SMS-Gateway usw.) kann es aber nötig sein, die Codierung auf 8-Bit für die Kopfzeilen zu ändern.

Die Änderung kann jetzt aber nur noch über die Registry durchgeführt werden.

Folgende Arten der Codierung können in Outlook verwendet werden:

  • Base-64
  • Quoted-Printable
  • No Encoding (keine)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Options\ Mail

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "InternetMailTextEncoding" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Encode Intelligently (automatische Codierung)
1 | Quoted-Printable
2 | Base-64-codiert
3 | keine Codierung und Outlook lässt 8-Bitzeichen als 8-Bitzeichen

Info Werden die Mails über einen Exchange Server verschickt, werden die Einstellungen in Outlook auf dem Client-Rechner nicht berücksichtigt.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2506.htm


Fehlermeldung beim Aufrufen des Outlook Abwesenheitsassistent

Fehlermeldung beim Aufruf des Outlook- Abwesenheitsassistenten

Wenn man unter Outlook über das Menü "Extras" -> "Abwesenheitsassistent" auswählt, wird der Abwesenheitsassistent nicht gestartet. Es wird nur die folgende Fehlermeldung angezeigt:

Der Befehl steht nicht zur Verfügung. Sehen Sie in der Programmdokumentation nach, wie diese Erweiterung verwendet wird.

Um den Fehler zu beseitigen, müssen Sie folgenden fehlerhaften Eintrag aus der Registry löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Resiliency

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

11.0 | Office 2003
12.0 | Office 2007

Beenden Sie vorher Outlook. Löschen Sie jetzt den Schlüssel "Resiliency", um das Problem zu beheben. Wenn Sie jetzt wieder Outlook starten, können Sie den Abwesenheitsassistent fehlerfrei starten.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2554.htm


Microsoft-Outlook: Zusätzlichen Anmeldedialog deaktivieren

Mit diesem Tipp können Sie einstellen, dass kein zusätzlicher Anmeldedialog erscheint, wenn sich der Exchange Server in einer anderen Domäne befindet.

Durch einen Fehler in Outlook erscheint ein zusätzlicher Anmeldedialog, wenn Sie Outlook starten und sich der Exchange Server in einer anderen Domäne befindet als der Client. Diesen zusätzlichen Dialog können Sie deaktivieren, wenn Sie das Service Pack 1 für Office XP installiert haben und folgenden Eintrag in der Registry setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ RPC

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

10.0 Office 2002

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePWDialog" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Zusätzliche Anmeldebox wird angezeigt (Standard)
1 | Zusätzliche Anmeldebox ausblenden

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=310642

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2629.htm


Outlook-Einträge sicher löschen (gelöschte Einträge aus PST/OST-Datei sofort entfernen)

Mit diesem Tipp können Sie einstellen, dass Einträge beim Löschen sofort aus den PST/OST-Dateien entfernt werden und somit nicht mehr von Dritten gelesen werden können.

Wenn Sie normalerweise Einträge in Outlook löschen und die Funktion - Automatisches leeren des Ordners "Gelöschte Objekte" (Papierkorb) - aktiviert haben, werden diese Einträge nur als gelöscht markiert und nicht wirklich aus der Datei entfernt. Erst nach dem nächsten Lauf der Komprimierungs- oder Archivierungsfunktion werden die Einträge auch aus dem Ordner gelöscht. Bis zu diesem Zeitpunkt, kann weiterhin auf den Inhalt der Einträge (mit einem HEX-Editor) zugegriffen werden bzw. können diese Mails auch mit der entsprechenden Software auch wieder hergestellt werden.

Wenn Sie den Eintrag "PSTNullFreeOnClose" aktivieren (Festlegung auf "1"), werden gelöschte Elemente beim Beenden von Outlook aus der PST-Datei entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ PST

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000 (ab Service Pack 1)
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "PSTNullFreeOnClose" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Gelöschte Objekte werden nicht sofort gelöscht (Standard)
1 | Gelöschte Objekte werden beim Beenden von Outlook gelöscht

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2627.htm


Anhänge in E-Mails werden als "Winmail.dat" beim Empfänger angezeigt

Dieser Tipp beschreibt, wie Dateianhänge in E-Mails im Rich-Text Format von Outlook richtig eingebunden werden.

Seit langer Zeit zieht sich das Problem durch alle Outlook-Versionen, dass Anhänge welche über E-Mails im Rich-Text Format (RTF) verschickt werden, bei Anwendern, die kein Outlook benutzen, nicht richtig angezeigt werden. Diese Anwender sehen nur eine "Winmail.dat" als Dateianlage.

Ab Outlook 2007 wurde dieser Fehler mit dem Fix "957692" behoben. Nach der Installation, müssen Sie noch den folgenden Registryeintrag setzen. Dieser Hotfix wird im Service Pack 2, welcher voraussichtlich Anfang 2009 erscheinen wird, enthalten sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ 12.0\ Outlook\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableTNEF" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Outlook arbeitet mit Winmail.dat Dateien
1 | Es werden keine Winmail.dat Dateien mehr verschickt

Benutzt wird das RTF-Format für das Versenden von Terminen und Aufgaben. Dabei erhält der Empfänger keine einfache Mail, sondern kann über zusätzliche Buttons diese Einladung ablehnen oder zusagen. Die Winmail.dat gehört zum TNEF-Format, welches aber heute nicht mehr verwendet wird.

Wenn Sie noch mit einer älteren Outlook-Version arbeiten, sollten Sie die Mails an Nicht_Outlook_Anwender lieber im Text-Format versenden und nicht das RTF-Format verwenden.

Sollten Sie aber schon so eine Mail erhalten haben und benötigen Sie den Dateianhang, können Sie diesen mit entsprechenden Tools aus der Winmail.dat Dateien extrahieren. (z.B.: WinMail.DAT-Reader oder WMDecode)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2641.htm


Outlook: Aufforderung zur Installation der Windows-Desktopsuche deaktivieren

Wenn Sie Microsoft Outlook 2007 auf einem Rechner öffnen wo die Windows-Desktopsuche nicht installiert ist, werden Sie über einen Hinweis aufgefordert, diese Anwendung zu installieren.

Über einen Registryeintrag können Sie einstellen, dass diese Meldung auch beim ersten Öffnen von Outlook nicht mehr angezeigt wird, auch wenn die Anwendung Windows-Desktopsuche nicht installiert ist.

Damit das funktioniert, muss das Service Pack 1 für Outlook 2007 auf dem Rechner installiert sein (Link).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version]\ Outlook\ Search

müssen Sie [Version] durch Ihre aktuelle Office Version ersetzen:

12.0 Office 2007

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDownloadSearchPrompt" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag wird nicht angezeigt
0 | Eintrag wird angezeigt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2656.htm


Windows Messenger unter Outlook Express deaktivieren

Sie können auch in Outlook Express den Windows Messenger ausschalten, wenn Sie ihn sowieso nicht benötigen oder lieber selber starten möchten.

Starten Sie Msconfig und deaktivieren Sie unter dem Tabreiter "Systemstart" den Eintrag "msmsgs".

Weiterhin können Sie auch die Registry bemühen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express

erstellen Sie einen neuen Eintrag mit dem Namen "Hide Messenger" als Datentyp REG_DWORD und setzen den Wert auf 2.

Siehe auch "Microsoft Messenger unter Windows deinstallieren".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1285.htm


OE: Zitatzeichen in News und Mails, die als Quoted Printable formatiert sind

Beim Antworten auf Mail und News, die mit Quoted Printable codiert sind, werden von Outlook Express die Zitatzeichen (Standard: ">") leider nicht eingefügt.

Um in einer Antwort die zitierten Zeilen dennoch zu kennzeichnen, verfahren Sie wie folgt:

  1. Nachricht - Absender antworten
  2. Format - Rich-Text (HTML)
  3. Ansicht - Quelltext bearbeiten: von "Bearbeiten" auf "Vorschau" umschalten
  4. Format - Nur Text

Nun werden die Zitatzeichen in Ihrer Nachricht angezeigt.

Info Umfangreiche Tipps und Tricks zu den Einstellungen von Outlook Express finden Sie unter http://oe-faq.de.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1298.htm


Outlook Express über T-Online nutzen

Der Mail- und Newsclient des Internet Explorers (4.0), welcher bei Windows automatisch benutzt wird, kann auch für T-Online Nutzer verwendet werden.

Zunächst muss man eine PPP-Verbindung zu T-Online im DFÜ Netzwerk eingerichtet haben.

Danach startet man Outlook Express. Beim ersten Start werden die erforderlichen Angaben automatisch abgefragt. Sollte dies nicht der Fall sein, geht man auf den Eintrag Extras -> Konten und wählt dort Hinzufügen "EMAIL".

Die erste Eingabe ist der angezeigte Name in einer E-Mail. Geben Sie hier ihren richtigen Namen, nicht aber die E-Mail-Anschrift ein.

Im 2. Fenster wird die E-Mail-Anschrift verlangt, welche dann XXX@t-online.de lautet. Sollten Sie noch eine Adresse mit Zahlen haben, kann diese unter T-Online / Service in eine Alias-Anschrift geändert werden.

Das nächste Fenster verlangt 2 Eingaben:

Die erste ist der Server für den Posteingang. Hier geben Sie "pop.t-online.de" ein

Für den Postausgang ist der Server "mailto.t-online.de" zuständig.

Als Kontonmane geben Sie Ihre T-Online-Nummer + einem Bindestrich und der Mitbenutzerzusatz. Bei Kennwort geben Sie Ihr Kennwort ein.

Ab sofort können Mails über T-Online abgerufen und verschickt werden. Denken Sie daran, dass für die Nutzung eine PPP Verbindung NUR über T-Online möglich ist.

Mit einem fremden PPP Zugang (AOL, Provider) kommen Sie nicht in das T-Online-Postfach. Daher bietet es sich an, unter Eigenschaften bei dem aktivierten Konto unter der Registerkarte Verbindungen T-Online einzustellen. Sobald Mails versendet oder empfangen werden, baut der Client die Verbindung automatisch über T-Online auf.

Weiterhin sollte unter der Registerkarte Extras-Optionen-DFÜ die Einstellungen "Keine DFÜ-Verbindung herstellen" und "Hinweis beim Wechsel.." sowie "Automatisch wählen, wenn auf neue Nachrichten geprüft wird", aktiviert sein. Damit geht der Client erst online, wenn Sie Nachrichten versenden oder empfangen wollen. Um die zu versendenden Nachrichten erst alle offline zu schreiben, muss unter SENDEN die Option "Nachricht sofort senden" deaktiviert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0867.htm


Konteneinstellungen in Outlook Express schützen

Die Einstellungen für die Konten in Outlook Express können jederzeit verändert werden.

Wenn Sie aber Einstellungen vorgeben wollen, die nicht mehr geändert werden sollen, können Sie die Konteneinstellungen mit folgendem Eintrag sichern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express

erstellen Sie einen neuen Eintrag mit dem Namen "No Modify Accts" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1,

Jetzt können die Konten nicht mehr verändert werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1189.htm


Anlagen mit potenzieller Virengefahr öffnen

Mails mit virengefährlichen Dateianhängen werden von Outlook ohne den Anhang dargestellt, obwohl dieser mit empfangen wurde. Wer sein Outlook nicht patchen will oder kann (Off2k- Sicherheitsstufe1-Dateien in Outlook nach SR2 wieder anzeigen), muss sich mit Outlook Express behelfen. Man speichert die Nachricht vom Outlook in einen Ordner und importiert diese Mail über "Datei" -> "Import" -> "Nachrichten" wieder in Outlook Express. Jetzt ist der Anhang verfügbar.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1095.htm


BlindCopy Feld im OE5 darstellen

Im Outlook Express 5 suchen viele das Feld für Blindcopy (BC). Dieses ist ausgeblendet und kann über "ANSICHT" -> Alle Kopfdaten eingeblendet werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0963.htm


Fenstertitel von Outlook Express 5.x ändern

Auch bei Outlook Express können Sie den Text ändern, der oben in der Fensterleiste angezeigt werden soll. Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ Software\ Microsoft\ Outlook Express\ 5.0

Erstellen Sie hier einen neuen Eintrag mit dem Namen "WindowTitle" als Datentyp REG_SZ. Geben Sie den gewünschten Titel ein.

Siehe auch "Ändern der IE Titelleiste".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0964.htm


Ständig Nachfrage bei Outlook Express, ob Standardclient

Wird neben Outlook Express ein weiterer Mailclient installiert und dieser benutzt, ändert dieser Client die Zuordnung für den Standard-Mailclient. Wenn man danach Outlook Express wieder als Standard-Client benutzen möchte, fragt dieser nach, ob er als Standard festgelegt werden soll.

Gelegentlich kommt es vor, dass Outlook Express hierbei etwas vergesslich ist und bei jedem Start wieder mit der Frage nervt. Mit der Befehlszeile (unter "START" -> "Ausführen") "c:\programme\Outlook Express\msimn.exe" /reg sollte die Einstellung dauerhaft gespeichert werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0897.htm


Regeln exportieren und importieren

Normalerweise bietet Outlook Express keine Möglichkeit, erstellte Regeln zu exportieren. Installiert man das System neu, gehen diese leider verloren. Man kann die Regeln aber über die Registry exportieren und bei Bedarf wieder importieren:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ IDENTITIES\{"kryptische Zahlenfolge (SID der USER-ID)"}\ SOFTWARE\ MICROSOFT\ OUTLOOK EXPRESS\ 5.0\ RULES

finden sich die Regeln.

Man selektiert den o.a. Pfad und wählt im Menü unter:

Windows 9x:

Registrierung -> "Registry exportieren" und in der folgenden Dialogbox muss unten "gewählter Zweig" aktiviert sein.

ab Windows 2000:

"Datei" -> "Exportieren..." aus.

Geben Sie hier einen beliebigen Namen an und drücken Sie auf Speichern. Die Einstellungen werden anschließend in diese .REG-Datei exportiert. Die gespeicherte REG-Datei kann man bei Bedarf einfach wieder importieren (Doppelklick auf die .REG-Datei).

Wenn Sie diese Datei unter einem neuen Userprofil importieren wollen, müssen Sie die .REG-Datei vor dem ersten Start von Outlook importieren. Wenn Sie Outlook schon gestartet haben, muss die (SIDder USER-ID) in der .REG-Datei gegen die aktuelle aus der Registry vor dem Import austauscht werden. Öffnen Sie dafür wieder Regedit und gehen Sie unter "HKEY_CURRENT_USER\ IDENTITIES\". Hier finden Sie die aktuelle SID des USERS. Öffnen Sie jetzt die .REG-Datei mit Notepad und ersetzen Sie hier die alte SID gegen die neue SID.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0895.htm


Outlook Express Adressbuch sichern

Das Adressbuch von Outlook Express finden Sie unter:

Windows\Anwendungsdateien\Windows Adressbuch.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0740.htm


Splash Screen von Outlook Express deaktivieren

Um den Splash Screen von Outlook Express auszuschalten müssen Sie folgenden Schlüssel in der Registry anlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Outlook Express 4.x

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ Software\ Microsoft\ Outlook Express

Den Wert "NoSplash" als Datentyp REG_SZ anlegen und als Wert 1 zuweisen

Outlook Express 5.x

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ Software\ Microsoft\ Outlook Express\ 5.0

Den Wert "NoSplash" als Datentyp REG_SZ anlegen und als Wert 1 zuweisen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0495.htm


Adressbuch von Outlook Express verschieben

Das Adressbuch vom Outlook Express liegt normalerweise im Ordner

"Windows\Anwendungsdateien\Microsoft\Adressbuch" bzw. ab Windows 2000 unter "C:\Dokumente und Einstellungen\[Anwendername]\Anwendungsdaten\Microsoft\Address Book\" und hat die Endung *.WAB.

Möchte man das Adressbuch aber in einem anderen Pfad speichern, verschiebt man die Datei an den neuen Ort und ändert dies in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ WAB\ WAB4\ WAB File Name

den Eintrag "(Default)" als Datentyp REG_SZ. Geben Sie hier den neuen Pfad an. Anschließend müssen Sie Windows neu starten oder sich neu anmelden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0732.htm


Outlook Express: Speicherverzeichnis nachträglich ändern

Wenn Sie das Verzeichnis von OE, in welchem die Mails und News gespeichert werden, nachträglich ändern wollen, können Sie das direkt in OE oder in der Registry einstellen.

Dazu unter "Extras" -> "Optionen..." in der Registerkarte "Wartung" auf "Speicherordner..." klicken und einen anderen Ordner wählen. Sind dort schon OE-Dateien vorhanden, fragt OE nach, ob diese beibehalten oder überschrieben werden sollen. Nach einem Neustart von OE wird der neue Ordner benutzt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ MICROSOFT\ OUTLOOK EXPRESS

den Wert "STORE ROOT" nach Ihren Wünschen anpassen.

Ab Outlook Express 5.0 unter:

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ SOFTWARE\ MICROSOFT\ OUTLOOK EXPRESS\ 5.0

Zudem muss der bisherige Outlook Express Ordner (Mit Inhalt Mail und News)
C:\WINDOWS\Anwendungsdaten\Identities\{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}\Microsoft\Outlook Express
an die neue Stelle verschoben werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0741.htm


Viren über Outlook Express

Durch den neuen "Scripting Host", welcher bei Windows 98 schon automatisch eingebunden wird, ist es möglich, im HTML-Code Visual-Basic-Scripts zu verstecken und somit auf das Dateisystem des Rechners zuzugreifen. Auch als Windows 95 bzw. NT 4.0 Anwender ist man nicht sicher, da sehr viele MS-Programme den "Scripting Host" auch installieren (z.B. "Windows NT Option Pack", "Personal Web Server" usw.).

Gegen das Ausführen solcher Viren können Sie sich nur schützen, indem Sie im Internet Explorer 4 im Menü "Ansicht" -> "Internetoptionen" -> "Sicherheit 2 auf Mittel (Sicher) oder Hoch (am sichersten) einstellen. Wenn Sie die Einstellung auf Hoch einstellen, werden Sie aber nun beim Surfen im Internet auf Seiten mit Visual-Basic-Scripten mit Fehlermeldung überhäuft. Bei der anderen Einstellung werden Sie gefragt, ob das Script ausgeführt werden soll. Die Meldung sieht dann so aus:

Ein ActiveX-Objekt dieser Seite ist möglicherweise nicht sicher. Soll die Initialisierung und der Zugriff durch Skripte zugelassen werden?

Bei dieser Meldung sollten Sie sich überlegen, ob Sie auf den "Ja" Button klicken wollen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0270.htm


Outlook Express: Nur als Newsreader oder Mailreader benutzen

Outlook Express: Speziell nur als Newsreader oder Mailreader nutzen

Outlook enthält keinen Newsreader, so dass man gezwungen ist, auch noch Outlook Express zu benutzen. Möchte man Outlook Express nur als Newsreader benutzen, müssen Sie Outlook Express (ab Version 5.5) mit folgendem Parameter starten:

"C:\Programme\Outlook Express\Msimn.exe" /newsonly

Jetzt kann es nicht mehr passieren, dass Mails unter Outlook Express abgelegt werden.

Wenn Sie Outlook nur als Mailreader benutzen wollen starten Sie das Programm folgendermaßen:

"C:\Programme\Outlook Express\Msimn.exe" /mailonly

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0798.htm


Sicherheitszone für Emails in Outlook Express

Hier legen Sie fest, welche Sicherheitszone beim Lesen von Emails verwendet werden soll. Die Einstellungen für die Zone werden aus den Optionen des Internet Explorer gelesen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express\ 5.0\ Default Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Security Zone" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Sicherheitszone wird ausgelesen
0 | Sicherheitszone wird nicht benutzt

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1404.htm


Mail Vorschau bei Outlook Express deaktivieren

Hier geben Sie an, ob eine Email im Vorschaufenster geöffnet werden soll. Aus Sicherheitsgründen sollte man diese Funktion lieber deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

(nur wenn noch kein Profil angelegt wurde)

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express\ 5.0\ Default Settings\ Mail

für einen aktuellen USER mit Profil unter:

HKEY_CURRENT_USER\Identities\<SID des Users>\Software\Microsoft\Outlook Express\5.0\Mail

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowHybridView" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Vorschau der Email anzeigen
0 | Vorschau nicht anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1405.htm


Beschriftung in der Symbolleiste von Outlook Express anzeigen

Mit dieser Einstellung legen Sie fest, ob Beschriftungen in der Symbolleiste (Icons) eingeblendet werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express\ 5.0\ Default Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Toolbar Text" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Beschriftungen anzeigen
0 | Nur Icons anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1406.htm


Anlagen in Outlook Express blockieren

Mit diesem Tipp können Sie einstellen, ob Anlagen in Outlook Express blockiert werden sollen. Wenn die Funktion aktiv ist, können keine Anlagen mehr in Email als Datei gespeichert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Outlook Express

Erstellen Sie hier einen neuen Wert mit dem Namen "BlockExecAttachments" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Anlagen können nicht mehr gespeichert werden
0 | Anlagen können gespeichert werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Outlook Express konfigurieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1845.htm


Outlook Express: Ausführbare Dateianhänge sperren

Mit diesem Tipp können Sie das Speichern oder Ausführen von ausführbaren Dateianhängen ab Outlook Express 6 oder höher sperren. Es können dann keine Dateianhänge, die Viren enthalten könnten, geöffnet oder gespeichert werden. Weiterhin kann der Anwender diese Einstellung auch nicht mehr unter "Extras" -> "Optionen" -> Tabreiter "Sicherheit" -> "Speichern oder Öffnen von Anlagen, die möglicherweise einen Virus enthalten können, nicht zulassen" verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Outlook Express

Erstellen Sie hier einen neuen Wert mit dem Namen "BlockExeAttachments" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Sperren von Dateianhängen ist aktiv
0 | Sperren von Dateianhängen kann vom Benutzer festgelegt werden (Optio nen) (Standard)

Die Einstellung für den Anwender unter den "Optionen" wird unter dem folgenden Registryeintrag gespeichert:

HKEY_CURRENT_USER\ Identities\ [GUID]\ Software\ Microsoft\ Outlook Express\ 5.0\ Mail

Hier finden Sie den Wert "Safe Attachments" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Dateianhänge werden nicht gesperrt und können gespeichert werden
1 | Dateianhänge sind gesperrt (Standard)

Ist der Wert "BlockExeAttachments" auf 1 gesetzt, hat diese Einstellung keine Auswirkung mehr und kann auch nicht mehr in Outlook Express verändert werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2611.htm


Smooth Scrolling unter Outlook Express

Mit diesem Tipp können Sie das "Smooth Scrolling" (weiches Ein-/Ausblenden) für Outlook Express in den Versionen 5.0 und 6.0 einstellen.

Wenn Sie den Eintrag "SmoothScroll" aktivieren (Festlegung auf "1"), ist die Funktion aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ Software\ Microsoft\ Outlook Express\ [Version]\ Trident\ Main

Sie müssen [Version] durch Ihre aktuelle Outlook Express Version ersetzen:

5.0 | Outlook Express 5.0
6.0 | Outlook Express 6.0

Erstellen Sie hier einen neuen Wert mit dem Namen "SmoothScroll" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Smooth Scrolling deaktivieren
1 | Smooth Scrolling aktivieren

Siehe auch Tipp:

Smooth Scrolling

Smooth Scrolling unter Telnet

Smooth Scrolling in Internet Explorer

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.


Lesezeichen zwischen IE und Netscape synchronisieren

Wenn Sie den Internet Explorer und Netscape einsetzen, haben Sie das Problem, dass Sie die Lesezeichen (Favoriten bzw. Bookmarks) von IE und Netscape getrennt verwalten müssen. Um die Favoriten des IE mit den Bookmarks von Netscape auf den gleichen Stand zu bringen, finden Sie auf der MS Homepage ein Programm, welches die Lesezeichen abgleicht:

http://www.pcworld.com/downloads/file_description.asp?fid=6052(Favtool)

Durch Starten dieses Programms können Sie die Lesezeichen untereinander abgleichen. Der Nachteil ist, dass dieses Programm keine Funktionen bietet, um diesen Vorgang zu automatisieren.

Dazu finden Sie im Internet ein Sharewareprogramm, welches Sie unter:

http://www.magnusbrading.com/bmc/ herunterladen können.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0497.htm


Ein Favoriten/Lesezeichen-Verzeichnis für den Internet Explorer und Firefox

Wenn Sie den Firefox- und /oder den Internet Explorer-Browser benutzen, dann haben Sie zwei Stellen wo die Favoriten (Lesezeichen) abgelegt werden. Um diese Verzeichnisse nicht immer abgleichen (synchronisieren) müssen, wäre es vorteilhaft, nur ein Verzeichnis für die Favoriten zu benutzen.

Damit Firefox direkt auf die Favoriten des IE zugreift, benötigen Sie das AddOn "PlainOldFavorites" (Download: http://www.erweiterungen.de/detail/PlainOldFavorites/).

Nach der Installation, wird im Firefox zusätzlich zu den Menü "Lesezeichen" auch noch das Menü "Favoriten" für die IE Favoriten eingeblendet. Damit Sie jetzt nicht zwei Einträge im Firefox haben, sollten Sie jetzt noch die Anzeige der Firefox Favoriten abschalten, dazu gehen Sie folgendermaßen vor:

  • Gehen Sie in das Verzeichnis "chrome", welches Sie in Ihrem Profileverzeichnis vom Firefox finden
  • Wenn nicht vorhanden erstellen Sie hier die Datei "userChrome.css"
  • Tragen Sie in die Datei folgendes ein:
    #bookmarks-menu { Display: none! important; }
  • Wenn Sie jetzt Firefox starten, wird nur noch das Favoriten-Menü angezeigt

Einen Fehler haben wir jetzt aber noch. Wenn Sie neue Einträge über die Hotkey-Funktion "STRG+D" hinzufügen, werden die nicht in den Favoriten sondern in das Lesezeichen vom Firefox eingetragen was wir jetzt ja nicht mehr sehen. Damit auch das richtig läuft, ändern Sie noch folgendes:

  • Installieren Sie das AddOn "Keyconfig Enhanced" (Download: http://www.erweiterungen.de/detail/69/)
  • Nach einem Neustart von Firefox gehen Sie unter: "Extras" -> "Tastaturkürzel anpassen"
  • Suchen Sie die Einträge "Lesezeichen für alle Tabs hinzufügen“ und "Lesezeichen hinzufügen" und klicken Sie dort jeweils auf den Button "Deaktivieren". Jetzt werden keine Lesezeichen mehr unter Firefox eingetragen.
  • Damit Sie aber STRG+D weiterhin benutzen können, fügen wir nur einen neuen Eintrag hinzu.
  • Klicken Sie jetzt auf den Button "Bearbeitungsmodus anzeigen" es öffnet sich nun ein neues Fenster
  • Klicken Sie auf den Button "Neu"
  • Füllen Sie unteren Felder - unter dem Button "Neu" folgendermaßen aus:
    Name: Favoriten hinzufügen
    Menü/Erweiterung: Favoriten
    Tastenkombination: Drücken Sie STRG+D
    Befehl: gPofUI.openAddToFavoritesDialog();
  • Klicken Sie auf den Button "Übernehmen" (finden Sie links in der Mitte des Fensters) und schließen Sie über "OK" das Fenster
  • Die neue Hotkey-Funktion ist nun aktiv

Info Haben Sie noch Einträge im Firefox, welche Sie noch nicht in den Favoriten vom IE haben, können Sie folgendermaßen diese Einträge übertragen (Achtung: Das müssen Sie natürlich machen, bevor Sie das Menü "Lesezeichen" wie oben geschrieben ausblenden).

  • Rufen Sie unter Firefox das Menü "Lesezeichen" -> "Lesezeichenmanager" auf
  • Rufen Sie im Menü "Datei" -> "Exportieren" auf und speichern Sie die Favoriten als .bookmarks.html ab.
  • Damit Sie die Datei unter dem IE sauber importieren können, müssen die Sonderzeichen von UTF-8 in ANSI umgewandelt werden.
  • Öffnen Sie die Datei mit Notepad (Notepad.exe) und wählen Sie anschließend "Datei" -> "Speichern Unter" und stellen Sie vor dem Speichern die Codierung auf "ANSI".
  • Öffnen Sie nun den Internet Explorer und wählen Sie "Datei" -> "Importieren/Exportieren".
  • Es öffnet sich ein Assistent, klicken Sie auf "Weiter" -> "Favoriten importieren" -> "Weiter" -> gespeicherte Datei auswählen -> "Weiter" -> Zielordner auswählen "Weiter" -> "Fertig stellen"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2226.htm


Standardbrowser festlegen

Auch wenn Sie den Netscape installiert haben, kann es vorkommen, dass bei einem Klick auf HTML-Dateien diese mit dem IE geöffnet werden.

Diese Eigenart können Sie nur über einen Eingriff in der Registry verändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT\.htm

bzw.

HKEY_CLASSES_ROOT\.html

Dort ändern Sie den Eintrag (Standard) auf "NetscapeMarkup". Wenn Sie die Dateien wieder mit dem IE aufrufen wollen, müssen Sie den Wert wieder auf "htmlfile" setzen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0556.htm


Konfigurationsscript für den Webbrowser

Sie können die Konfiguration für den Webbrowser, um auf das Internet zugreifen zu können, jeweils am Rechner vornehmen.

In einem großen Netzwerk ist das aber nicht so vorteilhaft, wenn sich an der Konfiguration einmal was ändert, müssen Sie jeden Rechner neu konfigurieren. Sie können bei den meisten Webbrowsern aber auch einstellen, dass Sie ihre Konfiguration aus einer Datei auslesen sollen.

Dafür tragen Sie im Webbrowser folgendes ein:

  1. Netscape Communicator 4.7:
    "Edit" -> "Preferences" -> "Advanced" -> "Proxies" -> "Automatic proxy configuration"
  2. Internet Explorer 4.x
    "Ansicht" -> "Internetoptionen" -> "Verbindung" -> "Automatische Konfiguration" -> "Konfigurieren"
  3. Internet Explorer ab 5.x:
    "Extras" -> "Internetoptionen" -> "Verbindungen" -> "LAN-Einstellungen" -> "Adresse"

Als Pfad geben Sie an, wo das Konfigurationsscript liegt: http://www.winFAQ.de/proxy.pac

Beispiele und eine Beschreibung für den Aufbau einer proxy.pac finden Sie hier:

http://wp.NETscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1649.htm


Tabreiter 'Erweitert' der 'Internetoptionen' ausblenden

Tabreiter "Erweitert" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Erweitert" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "AdvancedTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Erweitert" wird ausgeblendet
0 | Tabreiter "Erweitert" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Seite "Erweitert" deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1796.htm


Tabreiter 'Inhalt' der 'Internetoptionen' ausblenden

Tabreiter "Inhalt" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Inhalt" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "ContentTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Inhalt" wird ausgeblendet
0 | Tabreiter "Inhalt" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Inhaltsseite deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1797.htm


Tabreiter 'Programme' der 'Internetoptionen' ausblenden

Tabreiter "Programme" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Programme" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "ProgramsTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Programme" wird ausgeblendet
0 | Tabreiter "Programme" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Programmseite deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1798.htm


Tabreiter 'Sicherheit' der 'Internetoptionen' ausblenden

Tabreiter "Sicherheit" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Sicherheit" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "SecurityTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Sicherheit" wird ausgeblendet
0 | Tabreiter "Sicherheit" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Sicherheitsseite deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1800.htm


Tabreiter 'Verbindung' der 'Internetoptionen' ausblenden

Tabreiter "Verbindung" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Verbindung" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "ConnectionsTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Verbindung" wird ausgeblendet
0 | Tabreiter "Verbindung" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Verbindungsseite deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1801.htm


Tabreiter 'Allgemein' der 'Internetoptionen' ausblenden

Tabreiter "Allgemein" der "Internetoptionen" ausblenden

Mit diesem Tipp können Sie den Tabreiter "Allgemein" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "GeneralTab" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Allgemein" wird ausgeblendet
0 | Tabreiter "Allgemein" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Seite "Allgemein" deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1799.htm


Tabreiter 'Erweitert' der 'Internetoptionen' sichern

Tabreiter "Erweitert" der "Internetoptionen" sichern

Die Einstellungen vom Tabreiter "Erweitert" der "Internetoptionen" können nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Advanced" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Erweitert" ist gesichert
0 | Tabreiter "Erweitert" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Einstellungen für die Seite "Erweitert" deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1779.htm


Tabreiter 'Datenschutz' der 'Internetoptionen' ausblenden

Mit diesem Tipp können Sie den Tabreiter "Datenschutz" der "Internetoptionen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "PrivacyTab" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Tabreiter "Datenschutz" wird ausgeblendet
0 | Tabreiter "Datenschutz" ist sichtbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Datenschutzseite deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1846.htm


Sicherheitszonen: Benutzer können keine Einstellungen ändern

Wenn Sie diese Einstellung aktivieren, können die Benutzer die Einstellungen der Sicherheitszonen nicht ändern. Dazu werden unter "Internetoptionen" im Tabreiter "Sicherheit" die Schaltfläche "Stufe anpassen" und der Schrieberegler werden deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Security_options_edit" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Die Sicherheitszonen können nicht bearbeitet werden
0 | Die Sicherheitszonen können bearbeitet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Sicherheitszonen: Benutzer können keine Einstellungen ändern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1852.htm


Sicherheitszonen: Benutzer können keine Sites hinzufügen/entfernen

Wenn Sie diese Einstellung aktivieren, können die Benutzer keine Sites in den Sicherheitszonen hinzufügen oder entfernen. Die Einstellungen von Sicherheitszonen werden unter "Internetoptionen" im Tabreiter "Sicherheit" die Schaltfläche "Sites" sind deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Security_zones_map_edit" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Es können keine Sites mehr hinzugefügt/entfernt werden
0 | Sites können hinzugefügt/entfernt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Sicherheitszonen: Benutzer können keine Sites hinzufügen/entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1853.htm


Die 'Cache Einstellungen' der 'Internetoptionen' sichern

Die "Cache Einstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Einstellungen..." die "Cache Einstellungen" (bei Temporäre Internetdateien) nicht aktiviert/verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Cache" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Cache Einstellungen" ist gesichert
0 | "Cache Einstellungen" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Einstellungen für temporäre Internetdateien deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1781.htm


Die 'Automatische Konfiguration' der 'Internetoptionen' sichern

Die "Automatische Konfiguration" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Verbindungen" -> "LAN Einstellungen..." die "Automatische Konfiguration" nicht aktiviert/verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Autoconfig" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Automatische Konfiguration" ist gesichert
0 | "Automatische Konfiguration" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Einstellungen für automatische Konfiguration deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1780.htm


'Kalender' und 'Kontakte' der 'Internetoptionen' sichern

"Kalender" und "Kontakte" der "Internetoptionen" sichern

Bei den "Internetoptionen" können unter dem Tabreiter "Programme" der "Kalender" und die "Kontakte" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "CalendarContact" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Kalender" und "Kontakte" ist gesichert
0 | "Kalender" und "Kontakte" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Einstellungen für Kalender und Kontakte deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1782.htm


'Standardbrowser' Überprüfung der 'Internetoptionen' sichern

"Standardbrowser" Überprüfung der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Programme" die Funktion "Auf Internet Explorer als Standardbrowser überprüfen" nicht deaktiviert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Check_If_Default" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Standardbrowser" Überprüfung ist gesichert
0 | "Standardbrowser" Überprüfung ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der "Überprüfung des Standardbrowsers" deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1784.htm


'Farbeinstellungen' der 'Internetoptionen' sichern

"Farbeinstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Farben" die "Farben" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Colors" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Farben" sind gesichert
0 | "Farben" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Farbeinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1785.htm


'Zertifikate' der 'Internetoptionen' sichern

"Zertifikate" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Inhalt" die "Zertifikate" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Certificates" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Zertifikate" sind gesichert
0 | "Zertifikate" sind aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1783.htm


'DFÜ-Einstellungen' der 'Internetoptionen' sichern

"DFÜ-Einstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Verbindungen" die Funktion "DFÜ-Einstellungen" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Connection Settings" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "DFÜ-Einstellungen" ist gesichert
0 | "DFÜ-Einstellungen" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Verbindungseinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1786.htm


'Schriftarten' der 'Internetoptionen' sichern

"Schriftarten" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Schriftarten..." die "Schriftart" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Fonts" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Schriftarten" sind gesichert
0 | "Schriftarten" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Schriftarteneinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1787.htm


'Verlauf' der 'Internetoptionen' sichern

"Verlauf" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Verlauf" die Einstellungen für den "Verlauf" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "History" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Verlauf" ist gesichert
0 | "Verlauf" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Verlaufseinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1788.htm


'Startseite' der 'Internetoptionen' sichern

"Startseite" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" kann die "Startseite" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "HomePage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Startseite" ist gesichert
0 | "Startseite" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Homepage-Einstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1789.htm


'Spracheinstellungen' der 'Internetoptionen' sichern

"Spracheinstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Sprachen" die "Spracheinstellungen" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Languages" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Spracheinstellungen" sind gesichert
0 | "Spracheinstellungen" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Spracheinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1790.htm


'Farbeinstellungen für Links' der 'Internetoptionen' sichern

"Farbeinstellungen für Links" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" -> "Farben..." -> "Links" die "Farben für die Links" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Links" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Farbeinstellungen für Links" sind gesichert
0 | "Farbeinstellungen für Links" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Farbeinstellungen für Links deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1791.htm


'Internetprogramme' der 'Internetoptionen' sichern

"Internetprogramme" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Programme" die Einstellungen für die "Internetprogramme" (E-Mail, Newsgroups und Internetanruf) nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Messaging" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Einstellungen der "Internetprogramme" gesichert
0 | Einstellungen der "Internetprogramme" änderbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Einstellungen für Messaging deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1792.htm


'Profileinstellungen' der 'Internetoptionen' sichern

"Profileinstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Inhalt" -> "Persönliche Informationen" -> "Profil." können die Profileinstellungen nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Profiles" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Profileinstellungen" sind gesichert
0 | "Profileinstellungen" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderungen der Einstellungen für Profil-Assistenten deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1793.htm


'Proxyservereinstellungen' der 'Internetoptionen' sichern

"Proxyservereinstellungen" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Verbindungen" -> "Lan-Einstellungen" -> "Proxyserver" die Einstellungen des "Proxyservers" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Proxy" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Proxyservereinstellungen" sind gesichert
0 | "Proxyservereinstellungen" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Proxyeinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1794.htm


'Inhaltsratgeber' der 'Internetoptionen' sichern

"Inhaltsratgeber" der "Internetoptionen" sichern

Bei den "Internetoptionen" kann unter dem Tabreiter "Inhalt" die Einstellungen des "Inhaltsratgebers" nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Ratings" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Einstellungen des "Inhaltsratgeber" sind gesichert
0 | Die Einstellungen des "Inhaltsratgeber" sind änderbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Filtereinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1795.htm


Button 'Eingabehilfen' in den Internetoptionen des Internet Explorers deaktivieren

Button "Eingabehilfen" in den Internetoptionen des IE deaktivieren

Bei den "Internetoptionen" kann unter dem Tabreiter "Allgemein" der Tabreiter "Einstellungen" deaktiviert werden. Dadurch kann der Benutzer keine Änderungen an den Einstellungen für die Eingabehilfen mehr vornehmen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Accessibility" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Einstellungen "Eingabehilfen" sind gesichert
0 | Einstellungen "Eingabehilfen" sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Einstellungen für Eingabehilfen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1834.htm


'Webeinstellungen zurücksetzen' deaktivieren

"Webeinstellungen zurücksetzen" deaktivieren

Bei den "Internetoptionen" wird unter dem Tabreiter "Programme" die Schaltfläche "Webeinstellungen zurücksetzen" deaktiviert. Es können dann nicht mehr die Einstellungen für Start-und Suchseiten zurückgesetzt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "ResetWebSettings" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Webeinstellungen zurücksetzen" ist deaktiviert
0 | "Webeinstellungen zurücksetzen" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Das Feature "Webeinstellungen zurücksetzen" deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1841.htm


Autovervollständigung für Formulare deaktivieren

Durch die Autovervollständigung wird das Ausfüllen von Formularen erleichtert. Windows merkt sich dazu die Eingaben, welche gemacht wurden und vervollständigt damit spätere Formulare automatisch.

So müssen Sie z.B. die Adresse nicht immer neu eingaben, sondern es wird Ihnen die letzte Eingabe vorgegeben.

Diese Funktion ist standardmäßig deaktiv und kann über den Internet Explorer unter dem Menü "Extras" -> "Internetoptionen..." -> Tabreiter: "Inhalte" -> Button: "AutoVervollständigen..." unter dem Abschnitt "Autovervollständigen verwenden für" durch ein häcken bei "Formulare" aktiviert bzw. deaktiviert werden.

Sie können diese Einstellung aber auch über die Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Use FormSuggest" als Datentyp REG_SZ.

Setzen Sie den Wert auf:

no | Autovervollständigung ist deaktiv und die Eingaben werden nicht im Verlauf gespeichert
yes | Autovervollständigung ist aktiv (Standard)

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "FormSuggest" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Autovervollständigung ist deaktiv und die Eingaben werden nicht im Verlauf gespeichert
0 | Autovervollständigung ist aktiv (Standard)

Aktiviert/Deaktiviert die gewünschte Einstellung und der Anwender kann diese Einstellung nicht über die Einstellung des Internet Explorers ändern.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Autovervollständigen für Formulare deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu finden Sie auch im Tipp: "Linkvorschlag der Adresszeile abschalten" oder "Autovervollständigung für Kennwörter deaktivieren"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1839.htm


Autovervollständigung für Kennwörter deaktivieren

Durch die Autovervollständigung wird das Ausfüllen der Anmeldemasken bei der Benutzernamen und Kennworteingabe erleichtert. Windows merkt sich dazu die Eingaben welche gemacht wurden und vervollständigt damit spätere Formulare automatisch. Dadurch müssen Sie den Benutzernamen und das Passwort bei einem erneuten Besuch der Seite nicht wieder eingeben.

Info Achtung: Da das Passwort nicht sicher abgespeichert wird, sollte das Passwort auf keinen Fall gespeichert werden. Andere Personen oder Programme können diese Informationen leicht auslesen und benutzen.

Die Funktion kann über den Internet Explorer unter dem Menü "Extras" -> "Internetoptionen..." -> Tabreiter: "Inhalte" -> Button: "Autovervollständigen..." unter dem Abschnitt "Autovervollständigen verwenden für" konfiguriert werden.

Sie können diese Einstellung aber auch über die Registry verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "FormSuggest Passwords" als Datentyp REG_SZ.

Setzen Sie den Wert auf:

no | Autovervollständigung ist deaktiv und die Eingaben werden nicht im Verlauf gespeichert
yes | Autovervollständigung ist aktiv (Standard)

Erstellen Sie hier einen neuen Wert mit dem Namen "FormSuggest PW Ask" als Datentyp REG_SZ.

Um festzulegen, ob eine Nachfrage zum Speichern des Passwortes erfolgen soll, setzen Sie den Wert auf:

yes | Es kommt eine Nachfrageob Passwörter gespeichert werden sollen
no | Keine Nachfrage, ob Passwörter gespeichert werden sollen. (Standard)

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "FormSuggest Passwords" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Autovervollständigung ist deaktiv und die Eingaben werden nicht im Verlauf gespeichert
0 | Autovervollständigung ist aktiv (Standard)

Aktiviert/Deaktiviert die gewünschte Einstellung und der Anwender kann diese Einstellung nicht über die Einstellung des Internet Explorers ändern.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Kennwörter in Autovervollständigen können nicht gespeichert werden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Infos dazu finden Sie auch im Tipp: "Linkvorschlag der Adresszeile abschalten" oder "Linkvorschlag der Adresszeile abschalten"

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1840.htm


Die Add-On-Verwaltung deaktivieren

Info: IE 6 Ab SP2

Mit diesem Tipp können Sie einstellen, ob Benutzer über die Add-On-Verwaltung entsprechende Add-On zulassen oder sperren können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoExtensionManagement" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Add-On-Verwaltung" deaktivieren
0 | "Add-On-Verwaltung" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Aktiverung bzw. Deaktivierung von Add-On für Benutzer nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1843.htm


Änderung der Zertifikateinstellungen deaktivieren

Änderung der Zertifikateinstellungen im IE deaktivieren

Mit diesem Tipp können Sie einstellen, das Benutzer die Zertifikateinstellungen im Internet Explorer nicht verändern können. Die Einstellungen unter "Internetoptionen" -> "Inhalte" -> "Zertifikate" werden deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Certificates" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Änderungen der Zertifikateinstellungen deaktivieren
0 | Änderungen der Zertifikateinstellungen sind erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderungen der Zertifikateinstellungen deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1838.htm


Button 'Herausgeber' in den Internetoptionen des Internet Explorers deaktivieren

Button "Herausgeber" in den Internetoptionen des IE deaktivieren

Mit diesem Tipp können Sie die Button "Herausgeber" in den Internetoptionen -> Tabreiter "Inhalte" deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "CertifPub" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Button "Herausgeber" deaktivieren
0 | Button "Herausgeber" ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2094.htm


Hinzufügen weiterer Seiten unter Sicherheit in den Internetoptionen des Internet Explorers ausblenden

Hinzufügen weiterer Seiten unter Sicherheit in den Internetoptionen des IE ausblenden

Mit diesem Tipp können Sie verhindert, dass weitere Seiten unter "Extras" -> "Internetoptionen..." im Tabreiter "Sicherheit" bei den dort aufgeführten Zonen (Internet, Lokales Intranet, Vertrauenswürdige Sites und Eingeschränkte Sites) über den Button "Sites..." hinzugefügt werden können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "SecAddSites" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Hinzufügen von weiteren Seiten unterbinden
0 | Hinzufügen von weiteren Seiten erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2095.htm


Den Button 'Stufe anpassen' und 'Standardstufe' in den Internetoptionen des Internet Explorers ausblenden

Den Button "Stufe anpassen" und "Standardstufe" in den Internetoptionen des IE ausblenden

Mit diesem Tipp werden die Button "Stufe anpassen" und "Standardstufe" unter den Internetoptionen im Tabreiter "Sicherheit" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "SecChangeSettings" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Die Button "Stufe anpassen" und "Standardstufe" ausblenden
0 | Button anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2096.htm


Eintrag 'Temporäre Internetdateien' in den Internetoptionen des Internet Explorers ausblenden

Eintrag "Temporäre Internetdateien" in den Internetoptionen des IE ausblenden

Mit diesem Tipp werden die Einstellungen "Temporäre Internetdateien" unter den Internetoptionen im Tabreiter "Allgemein" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "Settings" als Datentyp REG_DWORD und setzen den Wert auf:

1 | "Temporäre Internetdateien" ausblenden
0 | "Temporäre Internetdateien" anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2097.htm


Eintrag 'Site Zertifikate' in den Internetoptionen des Internet Explorers deaktivieren

Eintrag "Site Zertifikate" in den Internetoptionen des IE deaktivieren

Mit diesem Tipp können Sie die Button "Zertifikate" in den Internetoptionen -> Tabreiter "Inhalte" deaktivieren. (Deaktiviert den gleichen Button wie der Tipp: "Button "persönliche Zertifikate" in den Internetoptionen des Internet Explorers deaktivieren", scheint noch ein BUG zu sein).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "CertifSite" als Datentyp REG_DWORD und setzen den Wert auf:

1 | "Site Zertifikate" ausblenden
0 | "Site Zertifikate" anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2098.htm


Button 'persönliche Zertifikate' in den Internetoptionen des Internet Explorers deaktivieren

Button "persönliche Zertifikate" in den Internetoptionen des IE deaktivieren

Mit diesem Tipp können Sie die Button "Zertifikate" in den Internetoptionen -> Tabreiter "Inhalte" deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "CertifPers" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Button "Herausgeber" deaktivieren
0 | Button "Herausgeber" ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2099.htm


Internet Explorer: Abspielen von Sounds in Webseiten konfigurieren

Mit diesem Tipp können Sie einstellen, ob Sounds auf Webseiten abgespielt werden oder nicht.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Multimedia". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Play_Background_Sounds" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

No | Sounds in Webseiten nicht abspielen
YES | Sounds in Webseiten abspielen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Sound in Webseiten wiedergeben

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2159.htm


Internet Explorer: Einstellung "Auf gesperrte Server-Zertifikate überprüfen" aktivieren/deaktivieren

Mit diesem Tipp legen Sie fest, ob der Internet Explorer prüfen soll, ob Zertifikate gesperrt sind. Sind Zertifikate nicht mehr gültig (abgelaufen) werden Sie vom Server gesperrt und können somit nicht mehr verwendet werden. Durch die Aktivierung stellen Sie sichern, dass keine ungültigen Zertifikate mehr verwendet werden.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Sicherheit". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "CertificateRevocation" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Auf gesperrte Server-Zertifikate überprüfen
0 | Nicht auf gesperrte Server-Zertifikate überprüfen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Auf gesperrte Serverzertifikate überprüfen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2158.htm


Internet Explorer: Einstellung "Verschlüsselte Seiten nicht auf dem Datenträger speichern" aktivieren/deaktivieren

Mit diesem Tipp legen Sie fest, ob Informationen von verschlüsselten Seiten im Zwischenspeicher des Internet Explorers ss abgelegt werden sollen. Da verschlüsselte Seiten (HTTPS) oftmals persönliche Informationen enthalten, kann es sich dabei um eine Sicherheitslücke handeln und ist deshalb oftmals nicht erwünscht.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Sicherheit". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableCachingOfSSLPages" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Verschlüsselte Seiten nicht auf dem Datenträger speichern
0 | Verschlüsselte Seiten auf dem Datenträger speichern (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Verschlüsselte Seiten nicht auf der Festplatte speichern

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2157.htm


Internet Explorer: Einstellung "Signaturen von herunter geladenen Programmen überprüfen" aktivieren/deaktivieren

Mit diesem Tipp legen Sie fest, ob die Signatur von herunter geladenen Programmen überprüft werden soll.

Durch eine Signatur wird sichergestellt, das die Anwendung vom Hersteller kommt und nicht von dritten verändert wurde. Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Sicherheit". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Download

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Download

Erstellen Sie hier einen neuen Wert mit dem Namen "CheckExeSignatures" als Datentyp REG_SZ. Setzen Sie den Wert auf:

YES | Signaturen von herunter geladenen Programmen überprüfen
NO | Signaturen nicht prüfen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Signaturen von übertragenen Programmen überprüfen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2156.htm


Internet Explorer: Einstellung "IDN-Servernamen senden" konfigurieren

Mit diesem Tipp stellen Sie ein, ob Unicode-Domänennamen in das IDN-Format umgewandelt werden, bevor sie an einen Proxy/DNS-Server gesendet werden.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "International*".

Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung "IDN-Servernamen für Intranet-Adressen senden" und "IDN-Servernamen senden" vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "EnablePunyCode" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Unicode-Domänennamen werden nie in das IDN-Format konvertiert
1 | Nicht-Internet-Unicode-Domänennamen werden in das IDN-Format konvertiert
2 | Internet-Unicode-Domänennamen werden in das IDN-Format konvertiert
3 | Unicode-Domänennamen werden immer in das IDN-Format konvertiert

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Internationale Domänennamen senden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2179.htm


Internet Explorer: Einstellung "UTF-8 für mailto-Links verwenden" konfigurieren

Mit diesem Tipp können Sie einstellen, dass der Internet Explorer UTF-8 für "MailTo" Links verwenden soll. Ansonsten werden bei "MailTo"-Links die Emails in dem des aktuellen benutzerbasierenden Codierung gesendet.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Multimedia". Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung "UTF-8 für "mailto"-Links verwenden" vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Protocols\ Mailto

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings\Protocols\ Mailto

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings\Protocols\ Mailto

Erstellen Sie hier einen neuen Wert mit dem Namen "UTF8Encoding" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | MailTo-Links werden nach UTF-8 kodiert
0 | Benutzer Codierung benutzen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | UTF-8 für mailto-Links verwenden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2186.htm


Internet Explorer: Einstellung "Immer ClearType für HTML verwenden" konfigurieren

Mit diesem Tipp können Sie einstellen, dass der Internet Explorer die Schriften in der ClearType-Funktion anzeigt. Dadurch wurde gerade auf LCD-Bildschirmen die Lesbarkeit von Texten verbessert.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Multimedia". Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung "Immer ClearType für HTML verwenden" vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "UseClearType" als Datentyp REG_SZ. Setzen Sie den Wert auf:

YES | Anzeige von Texten über ClearType
NO | Texte ohne ClearType anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | ClearType deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2187.htm


Internet Explorer: Einstellung "Bilder anzeigen" konfigurieren

Mit diesem Tipp können Sie einstellen, ob der Internet Explorer Bilder standardmäßig anzeigen soll. Gerade bei Seiten mit vielen Bildern und langsamen Verbindungen kann es vom Vorteil sein, das Laden der Bilder auszuschalten. Sie können dann über die rechte Maustaste auf dem Bild die Bilder durch "Bild laden" dann immer noch herunter laden.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Multimedia". Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung "Bilder anzeigen" vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Display Inline Images" als Datentyp REG_SZ. Setzen Sie den Wert auf:

NO | Bilder nicht anzeigen
YES | Bilder anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Multimedia
Einstellungsname: | Bildanzeige deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2188.htm


Internet Explorer: Einstellung "Suchen in Adressleiste" konfigurieren

Mit diesem Tipp können Sie die Suche für die Adressleiste konfigurieren. Dabei gibt es folgende Möglichkeiten:

  • Ergebnisse anzeigen und zur wahrscheinlichsten Seite wechseln (nur bis IE 6)
  • Ergebnisse im Hauptfenster anzeigen
  • Nicht in Adressleiste suchen
  • Zur wahrscheinlichsten Seite wechseln (nur bis IE 6)

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Suchen in Adressleiste". Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "AutoSearch" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Nicht in der Adressleiste suchen
4 | Ergebnisse im Hauptfenster anzeigen
5 | Zur wahrscheinlichsten Seite wechseln (nur bis IE 6)
6 | Ergebnisse anzeigen und zur wahrscheinlichsten Seite wechseln (nur bis IE 6)

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "AutoSearch" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nicht in der Adressleiste suchen
4 | Ergebnisse im Hauptfenster anzeigen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Suchen
Einstellungsname: | Konfiguration der Suche in der Adressleiste verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2195.htm


Internet Explorer: Einstellung "Seitenübergänge aktivieren" aktivieren/deaktivieren

Mit diesem Tipp legen Sie fest, ob bei einem Wechsel zu einer anderen Webseite die alte Webseite aus und die neue eingeblendet werden sollen. Ist der Tipp aktiviert, wird die Webseite ausgeblendet. Wenn Sie den Tipp deaktiviere, dann wird die Webseite sofort gewechselt.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Browsen". Wenn Sie diesen Tipp als Policy konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Page_Transitions" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Webseiten ohne Ein- und Ausblenden anzeigen
1 | Webseiten Ein- und Ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Browsen
Einstellungsname: | Seitenübergänge deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2196.htm


Internet Explorer: Einstellung "Platzhalter für den Bilderdownload anzeigen" konfigurieren

Mit diesem Tipp können Sie die Einstellung "Platzhalter für den Bilderdownload anzeigen" konfigurieren. Diese Einstellung finden Sie im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Erweitert" unter der Rubrik "Multimedia".

Mit dieser Funktion legen Sie fest, ob der Browser zu Anfang für die Bilder Platzhalter anzeigen soll, während noch die Daten für die Bilder heruntergeladen werden. Dadurch entspricht der Seitenaufbau dem Original und die Seite verändert sich nicht noch mal, wenn die Bilder eingeblendet werden.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Show image placeholders" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Platzhalter für Bilder anzeigen
0 | Keine Platzhalter benutzen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Multimedia
Einstellungsname: | Anzeige von Platzhaltern für den Bilderdownload zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2247.htm


Internet Explorer: Einstellung "Optimierten Bildverlauf verwenden" konfigurieren

Mit diesem Tipp können Sie die Einstellung "Optimierten Bildverlauf verwenden" konfigurieren. Diese Einstellung finden Sie im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Erweitert" unter der Rubrik "Multimedia".

Mit dieser Funktion legen Sie fest, ob der Browser die Bilder mit einer Kantenglättung bearbeiten soll. Dadurch werden die Ränder der Bilder besser und sehen nicht so gezackt aus.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "SmartDithering" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Kantenglättung ausschalten
1 | Kantenglättung aktivieren

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Multimedia
Einstellungsname: | Kantenglättung von Bildern deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2248.htm


Internet Explorer: Einstellung "Skriptfehler anzeigen" konfigurieren

Mit diesem Tipp können Sie die Einstellung "Skriptfehler anzeigen" konfigurieren. Diese Einstellung finden Sie im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Erweitert" unter der Rubrik "Browsen".

Mit dieser Funktion legen Sie fest, ob der Browser, wenn bei der Ausführung von Scripten ein Fehler auftritt, eine entsprechende Meldung angezeigt werden soll. Für den normalen Anwender sind solche Fehlermeldungen nicht hilfreich, weshalb diese Fehler Standardmäßig nicht angezeigt werden. Wenn Sie aber Webseiten Erstellen, kann diese Funktion hilfreich sein.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Error Dlg Displayed On Every Error" als Datentyp REG_SZ und setzen den Wert auf:

YES | Scriptfehler anzeigen
NO | Scriptfehler nicht anzeigen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Browsen
Einstellungsname: | Benachrichtigungen über Skriptfehler aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2249.htm


Internet Explorer: Einstellung "Browserverlauf löschen" der Internetoptionen aus/-einschalten

Mit diesem Tipp können Sie Einstellen, ob der Benutzer im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Allgemein" unter der Rubrik "Browserverlauf" über den Button "Löschen" den Verlauf (History) des Browsers löschen kann.

Wenn Sie die Einstellung über diesen Tipp konfigurieren, wird der oben aufgeführte Button entfernt, weiterhin wird aus dem Menü "Extras" der Eintrag "Browserverlauf löschen..." entfernt. Der Anwender kann über diese Funktionen nicht mehr den Verlauf (History) des Browsers löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDeleteBrowsingHistory" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Löschen des Verlaufes (History) erlauben
1 | Löschen des Verlaufes (History) ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Funktion "Browserverlauf löschen" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2259.htm


Internet Explorer: Einstellung "Ausführen aktiver Inhalte von CDs auf dem lokalen Computer zulassen" konfigurieren

Mit diesem Tipp legen Sie fest, ob beim Ausführen von Dateien von einer CD mit aktiven Inhalten eine Dialogbox erscheint, welche der Anwender bestätigen muss oder ohne Nachfrage die Funktion ausgeführt werden soll.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Sicherheit". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main\FeatureControl\ FEATURE_LOCALMACHINE_LOCKDOWN\ Settings

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main\FeatureControl\ FEATURE_LOCALMACHINE_LOCKDOWN\ Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "LOCALMACHINE_CD_UNLOCK" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Aktive Inhalte ohne Nachfrage ausführen
0 | Ausführen muss bestätigt werden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Ausführung aktiver Inhalte von CDs auf Computern zulassen

Info Siehe dazu auch Tipp: " Ausführung aktiver Inhalte auf dem lokalen Computer zulassen (IE)"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2265.htm


Internet Explorer: Einstellung "Formulare löschen" der Internetoptionen aus/-einschalten

Mit diesem Tipp können Sie einstellen, ob der Benutzer im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Allgemein" unter der Rubrik "Browserverlauf" über den Button "Formulare löschen..." die Formulare des Browsers löschen kann.

Wenn Sie die Einstellung "DisableDeleteForms" aktivieren (Festlegung auf "1"), wird der oben aufgeführte Button entfernt. Der Anwender kann über diese Funktionen nicht mehr die Formulare des Browsers löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDeleteForms" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Löschen der Formulare erlauben
1 | Löschen der Formulare ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Funktion "Formulare löschen" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2646.htm


Internet Explorer: Einstellung "Kennwörter löschen" der Internetoptionen aus/-einschalten

Mit diesem Tipp können Sie Einstellen, ob der Benutzer im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Allgemein" unter der Rubrik "Browserverlauf" über den Button "Kennwörter löschen..." die gespeicherten Kennwörter löschen kann.

Wenn Sie die Einstellung "DisableDeletePasswords" aktivieren (Festlegung auf "1"), wird der oben aufgeführte Button entfernt. Der Anwender kann über diese Funktionen nicht mehr die gespeicherten Kennwörter löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableDeletePasswords" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Löschen der Kennwörter erlauben
1 | Löschen der Kennwörter ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Funktion "Kennwörter löschen" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2647.htm


Script-Debugger des IE ein-/ausschalten

Findet der IE einen Fehler auf einer Internetseite, erscheint die Nachfrage, ob der Script-Debugger gestartet werden soll. Für die meisten Anwender ist dieses Verhalten eher störend, da man an den Internetseiten sowieso nichts ändern kann und es deshalb nicht nötig ist, sich das Script anzusehen. Diese Funktion wird meist nur von den Autoren dieser Seiten benötigt und kann deshalb ausgeschaltet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

erstellen Sie einen neuen Eintrag mit dem Namen "Disable Script Debugger" als Datentyp REG_SZ. Setzen Sie den Wert auf YES (bzw. auf NO, damit die Abfrage wieder erscheint).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1190.htm


Ausblenden von selten verwendeten Menüpunkten im IE abschalten

Ausblenden/Abschalten von selten verwendeten Menüpunkten im IE

Auch der Internet Explorer ab der Version 5.x blendet selten verwendete Menüpunkte aus, was angeblich die Übersichtlichkeit verbessern soll.

Wenn Sie dieses Verhalten als störend empfinden, können Sie diese Funktion deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

erstellen Sie hier einen neuen Eintrag mit dem Namen "FavIntelliMenus" als Datentyp REG_SZ. Setzen Sie den Wert auf NO.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0961.htm


Startseite lässt sich nicht ändern/Änderung verhindern

Falls sich die Startseite des Internet Explorers unter Extras - Internetoptionen - Allgemein nicht ändern lässt (bei einigen Heft-Installationen), kann man dies manuell über die Registry erledigen. Schließen Sie alle Internet Explorer-Fenster, bevor Sie die Änderungen vornehmen.

Mit dieser Einstellung können Sie aber auch eine Startseite vorgeben, die dann der Anwender nicht mehr verändern kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für Internet Explorer 4.x

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Hier löscht man den Eintrag "HomePage" (Datentyp REG_DWORD) oder setzt den Wert auf 0. Um zu verhindern, dass die Startseite geändert wird, setzt man den Wert auf 1.

Ab Internet Explorer 5

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Hier löscht man den Eintrag "HomePage" (Datentyp REG_DWORD) oder setzt den Wert auf 0. Um zu verhindern, dass die Startseite geändert wird, setzt man den Wert auf 1.

Die URL der Standardseite wird unter dem folgenden Eintrag festgelegt:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Internet Explorer\ Main

oder als Policies

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Local Page" als Datentyp REG_SZ und geben Sie zum Öffnen den Pfad zu BLANK.HTM für die URL der Startseite bzw. für eine leere Seite (liegt unter %SystemRoot%\\System\Blank.htm, Sie dürfen aber in der Registry nicht mit Variablen %SystemRoot% arbeiten).

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Änderung der Homepage-Einstellungen deaktivieren

Weiterhin können folgende Registry-Einträge die Fähigkeit zum Verändern der Startseite beeinflussen:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Eintrag "NoSetHomePage", Datentyp REG_DWORD, Wert 1 (0x01000000)

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Eintrag "NoSetHomePage", Datentyp REG_DWORD, Wert 1 (0x01000000)

Info Siehe auch: "Probleme mit dem IE möglicherweise durch Werberoboter".

Info Einige Provider benutzen transparente Proxy-Server und leiten den Nutzer dennoch um (z.B. Freenet). Dies hat nichts mit dieser Einstellung zu tun.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=320159.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0971.htm


Internet Explorer Toolbar Buttons ausblenden

Wenn Sie einige Buttons aus der Toolbar des Internet Explorers ausblenden wollen, müssen Sie den Registry-Wert "SpecifyDefaultButtons" aktivieren, danach können Sie mit den folgenden Werten die gewünschten Buttons ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

erstellen Sie einen neuen Wert mit dem Namen "SpecifyDefaultButtons" als Datentyp REG_DWORD und setzen den Wert auf "1", dadurch können Sie mit den folgenden Registry-Werten einzelne Buttons ausschalten:

Wertname | Datentyp | Wert | Beschreibung
Btn_Back | REG_DWORD | 2 | Zurück
Btn_Forward | REG_DWORD | 2 | Vorwärts
Btn_Stop | REG_DWORD | 2 | Abbrechen
Btn_Refresh | REG_DWORD | 2 | Aktualisieren
Btn_Home | REG_DWORD | 2 | Startseite
Btn_Search | REG_DWORD | 2 | Suchen
Btn_Folders | REG_DWORD | 2 | Verzeichnisse
Btn_Favorites | REG_DWORD | 2 | Favoriten
Btn_Media | REG_DWORD | 2 | Medien
Btn_History | REG_DWORD | 2 | History
Btn_Fullscreen | REG_DWORD | 2 | Vollbild
Btn_Tools | REG_DWORD | 2 | Tools
Btn_MailNews | REG_DWORD | 2 | E-Mail senden
Btn_Size | REG_DWORD | 2 | Größe
Btn_Print | REG_DWORD | 2 | Drucken
Btn_Edit | REG_DWORD | 2 | Bearbeiten
Btn_Discussions | REG_DWORD | 2 | Diskussion
Btn_Cut | REG_DWORD | 2 | Ausschneiden
Btn_Copy | REG_DWORD | 2 | Kopieren
Btn_Paste | REG_DWORD | 2 | Einfügen
Btn_Encoding | REG_DWORD | 2 | Entschlüsseln
Btn_PrintPreview | REG_DWORD | 2 | Vorschau drucken

Nach einem Neustart des Explorers werden die Einstellungen übernommen.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Symbolleisten
Einstellungsname: | Symbolleistenschaltflächen konfigurieren

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1247.htm


Update Menü-Eintrag im IE ausblenden oder den Text ändern

Mit diesem Tipp können Sie den Text des Update Eintrags im IE Menü verändern. Wenn Sie hier nichts eingeben, wird der Menü-Eintrag ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "Windows Update Menu Text" als Datentyp REG_SZ. Geben Sie den gewünschten Text ein.

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1602.htm


Import und Export der Internet Explorer Einstellungen konfigurieren

Import und Export der IE-Einstellungen konfigurieren

Mit diesem Tipp können Sie die Funktion zum Import und Export der Cookies und Favoriten im Internet Explorer ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableImportExportFavorites" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | In-/Export ausschalten
0 | In-/Export aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Importieren und Exportieren von Favoriten deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1606.htm


URL und nicht 'Verknüpfung mit' im Internetexplorer anzeigen

URL und nicht "Verknüpfung mit" im Internetexplorer anzeigen

Wenn man mit der Maus über einen Link im Internet Explorer fährt, wird unten in der Statusleiste "Verknüpfung mit" angezeigt. Mit diesem Tipp können Sie einstellen, ob der vollständige Link in der Statusleiste eingeblendet werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "Show_FullURL" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | "Verknüpfung mit" anzeigen
0 | "Verknüpfung mit" nicht anzeigen (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1662.htm


Deaktivieren von ALT + F4 (Beenden)

Hiermit können Sie die Tastaturkombination [ALT + F4] des Internet Explorer deaktivieren. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBrowserClose" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Beenden ist deaktiviert
0 | Beenden ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1769.htm


Entfernen des Kontextmenüs vom IE

Hiermit können Sie das "Kontextmenü des Internet Explorer" entfernen. (ab IE 4.01 + SP2).

Wenn Sie den Eintrag "NoBrowserContextMenu" aktivieren (Festlegung auf "1"), wird das Kontextmenü wird nicht angezeigt, wenn Benutzer auf eine Webseite zeigen und dann auf die rechte Maustaste klicken.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBrowserContextMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Kontextmenü ist deaktiviert
0 | Kontextmenü ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Browser-Menüs
Einstellungsname: | Kontextmenü deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1770.htm


Internetoptionen aus dem Extra Menü entfernen

Hiermit können Sie die Internetoptionen (Browser Einstellungen) unter dem Extra Menü aus dem Internet Explorer entfernen. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBrowserOptions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Internetoptionen sind ausgeblendet
0 | Internetoptionen sind vorhanden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1771.htm


Speichern aus dem Dateimenü entfernen

Hiermit können Sie "Speichern" und "Speichern unter" Eintrag aus dem Internet Explorer entfernen. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBrowserSaveAs" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Speichern ist ausgeblendet
0 | Speichern ist sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1772.htm


Favoriten Menü kann nicht mehr verändert werden

Hiermit können Sie das "Verändern des Favoriten Menüs des IE" unterbinden. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFavorites" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Ändern der Favoriten unterbinden
0 | Favoriten können geändert werden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1773.htm


Deaktivieren von CTRL + N (Neues Fenster)

Deaktivieren von CTRL + N (Neues Fenster) im IE

Hiermit können Sie die Tastaturkombination [CTRL + N] des Internet Explorer deaktivieren. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileNew" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | CTRL+N ist deaktiviert
0 | CTRL+N ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1774.htm


Öffnen aus dem Dateimenü entfernen

Öffnen aus dem Dateimenü entfernen im IE

Hiermit können Sie den "Öffnen Eintrag" [CTRL + O] und [CTRL + L] aus dem IE entfernen. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileOpen" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Öffnen ist deaktiviert
0 | Öffnen ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1775.htm


Deaktivieren von F3 (Suchen)

Deaktivieren von F3 (Suchen) im IE

Hiermit können Sie die Tastenfunktion [F3] des Internet Explorer deaktivieren. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFindFiles" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Suchen ist deaktiviert
0 | Suchen ist aktiviert (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Suchen: Suche nach Dateien über F3-Taste im Browser deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1776.htm


Entfernen des Speichern Buttons beim Download

Entfernen des Speichern Buttons beim Download im IE

Hiermit können Sie den "Speicher Button beim Download" des IE unterbinden. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSelectDownloadDir" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Speicher Button ist deaktiviert
0 | Speicher Button ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1777.htm


Deaktivieren von F11 (Vollbild)

Deaktivieren von F11 (Vollbild) im IE

Hiermit können Sie die Tastenfunktion [F11] des Internet Explorer deaktivieren. (ab IE 4.01 + SP2).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoTheaterMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Beenden ist deaktiviert
0 | Beenden ist aktiviert (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1778.htm


Einträge aus dem Menü 'Datei' - 'Neu' ausblenden

Einträge aus dem Menü "Datei" - "Neu" ausblenden

Mit diesem Tipp werden alle Einträge außer "Fenster" aus dem Menü "Datei" -> "Neu" ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoExpandedNewMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Einträge werden ausgeblendet
0 | Die Einträge sind sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1802.htm


Veränderung der Toolbarleiste unterbinden

Hiermit können Sie das "Verändern der Toolbarleiste" unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoToolbarOptions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter "Erweitert" wird ausgeblendet
0 | Tabreiter "Erweitert" ist sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1803.htm


Die Adress-Liste ausblenden

Mit diesem Tipp können Sie die "Adress-Liste" aus der Toolbar ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoAddressBar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Adress-Liste wird ausgeblendet
0 | Die Adress-Liste ist sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1804.htm


Die Symbol-Leiste ausblenden

Mit diesem Tipp können Sie die "Symbol-Leist" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoToolbar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Symbol-Leiste wird ausgeblendet
0 | Die Symbol-Leiste ist sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1805.htm


Die Link-Leiste ausblenden

Mit diesem Tipp können Sie die "Link-Leiste" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoLinksBar" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Die Link-Leiste wird ausgeblendet
0 | Die Link-Leiste ist sichtbar (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1806.htm


Anpassung im Suchendialog ausblenden

Mit diesem Wert können Sie die Schaltfläche "Anpassen" im Such-Assistenten ausblenden. So kann z.B. nicht mehr die Standardsuchmaschine geändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSearchCustomization" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Anpassen der Suche ist deaktiv
0 | Anpassen der Suche wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Suchen: Suchanpassung deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1830.htm


Assistenten für den Internetzugang deaktivieren

Mit diesem Tipp können Sie die Schaltfläche "Setup" unter "Internetoptionen"-> "Verbindungen" deaktivieren. Weiterhin kann der Assistent auch nicht mehr über Startmenü -> Programme -> Zubehör -> Kommunikation -> Assistent für neue Internetverbindungen gestartet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Connwiz Admin Lock" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Assistent kann nicht mehr gestartet werden
0 | Assistent ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Assistenten für den Internetzugang deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1835.htm


Popup-Verwaltung deaktivieren

Mit diesem Tipp können Sie die Popup-Verwaltung des IE deaktivieren. Ist der Tipp aktiviert, sind die Informationen ausgegraut und können nicht mehr aufgerufen werden. Der IE verhält sich wie früher.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoPopupManagment" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Popupverwaltung ist deaktiviert
0 | Popupverwaltung ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Popup-Verwaltung deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1836.htm


URL-Liste der zugelassenen Popup-Seiten

Info: IE 6 Ab SP2

Mit diesem Tipp können Sie eine Liste mit Internetseiten vorgeben, wo Popups zugelassen werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ New Windows

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ New Windows

Erstellen Sie hier einen neuen Wert mit dem Namen "ListBox_Support_Allow" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Liste mit Popup wird mitgegeben
0 | Es wird keine Liste angegeben (Standard)

Wenn Sie diese Funktion aktiviert haben müssen Sie unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ New Windows\ Allow

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ New Windows\ Allow

erstellen Sie hier für jede URL einen Eintrag als Datentyp REG_SZ. Als Name und Wert benutzen Sie jeweils die URL. Sie dürfen dabei nur den Domänennamen verwenden. Es darf aber nicht "http://"" mit angegeben werden. Platzhalter (*) ist für mögliche Endungen aber erlaubt.

Beispiel:

Name | Datentyp | Wert
www.winfaq.de | REG_SZ | www.winfaq.de
*.winfaq.de | REG_SZ | *.winfaq.de

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Liste zugelassener Popup

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1837.htm


Verwaltung der Identitäten deaktivieren

Mit diesem Tipp können Sie einstellen, ob der Benutzer über den Identitäten-Manager mehrere Konten anlegen und verwalten kann

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Identities

Erstellen Sie hier einen neuen Wert mit dem Namen "Locked Down" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Verwaltung der Identitäten" deaktivieren
0 | "Verwaltung der Identitäten" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Identitätsmanager: Verwenden von Identitäten für Benutzer deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1844.htm


Anzeigen des Begrüßungsbildschirms deaktivieren

Mit dieser Einstellung können Sie den Begrüßungsbildschirm beim Start des Internet Explorers deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSplash" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Begrüßungsbildschirm wird nicht angezeigt
0 | Begrüßungsbildschirm wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Anzeigen des Begrüßungsbildschirms deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1848.htm


Wallet Funktion des Internet Explorers deaktivieren

Wallet Funktion des IE deaktivieren

Mit diesem Tipp können Sie die "Wallet" Funktion des Internet Explorers deaktivieren. Das ist eine elektronische "Brieftasche für den Zahlungsverkehr".

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

ändern Sie hier den Wert "Wallet" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Wallet Funktion deaktivieren
0 | Wallet Funktion ist aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2100.htm


'Connection Wizard' des Internet Explorers deaktivieren

"Connection Wizard" des IE deaktivieren

Mit diesem Tipp können Sie den "Connection Wizard" des Internet Explorers deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "Connection Wizard" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Connection Wizard deaktivieren
0 | Connection Wizard aktivieren (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern.Sie können das Programm unter "http://www.winfaq.de" finden.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2101.htm


Internet Explorer: Hilfemenü und Funktion deaktivieren

Ab IE 7.0 können Sie Mit diesem Tipp das Hilfsmenü ausblenden und die Hilfefunktion (F1-Taste) ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoHelpMenu" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Hilfemenü anzeigen
1 | Hilfemenü ausblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Anzeige des Internet Explorer-Menüs "Hilfe" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2205.htm


Internet Explorer: Menüeintrag "Kundenfeedbackoptionen" aus dem Hilfe Menü ausblenden

Ab dem Internet Explorer 7 können Sie Mit diesem Tipp konfigurieren, ob der Eintrag "Kundenfeedbackoptionen" im Hilfsmenü nicht angezeigt wird und weiterhin legen Sie fest, ob der Anwender am "Microsoft Customer Experience Improvement Program" (CEIP) teilnehmen soll.

Wenn der Menüpunkt wieder angezeigt werden soll, müssen Sie den Eintrag einfach löschen, was auch durch auswählen von "Standard" erreicht werden kann.

Mit dem Eintrag Kundenfeedbackoptionen, kann der Anwender am CEIP teilnehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ SQM

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ SQM

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableCustomerImprovementProgram" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag ausblenden, Anwender darf nicht am CEIP teilnehmen
0 | Eintrag ausblenden, Anwender muss am CEIP teilnehmen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Teilnahme am Programm zur Verbesserung der Benutzerfreundlichkeit verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2208.htm


Internet Explorer: Einstellung "Animationen in Webseiten wiedergeben" konfigurieren

Mit diesem Tipp legen Sie fest, ob animierte GIF-Bilder im Internet Explorer angezeigt werden sollen. Wenn Sie den Tipp konfigurieren, dann spielt der Internet Explorer die Animationen ab, ansonsten werden Animationen nicht herunterladen und abgespielt, wodurch die Seite schneller angezeigt wird.

Diese Einstellung finden Sie im Internet Explorer unter den Internetoptionen -> Tabreiter "Erweitert" im Abschnitt "Multimedia". Wenn Sie diesen Tipp konfigurieren, kann die Einstellung vom Anwender nicht mehr verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Control Panel

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableRIED" als Datentyp REG_SZ. Setzen Sie den Wert auf:

YES | Animationen wiedergeben
NO | Animationen nicht herunterladen und wiedergeben

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Animationen in Webseiten wiedergeben

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2266.htm


Internet Explorer: Eintrag "Webseite, komplett" aus der Dialogbox "Webseite speichern" entfernen

Mit diesem Tipp können Sie den Eintrag "Webseite, komplett" aus der Dialogbox "Webseite speichern" (Datei -> Speichern unter...) entfernen.

Wenn Sie den Eintrag "NoBrowserSaveWebComplete" aktivieren (Festlegung auf "1"), deaktivieren Sie das Speichern der gesamten Inhalte einer Webseite, der angezeigt oder ausgeführt wird, einschließlich Grafiken, Skripts, verknüpften Dateien und anderen Elementen. Das Speichern des Textes einer Webseite wird nicht verhindert. Webseiten können immer noch als Hypertext Markup Language (HTML)-Dateien oder als Textdateien gespeichert werden. Dabei werden jedoch Grafiken, Skripts und andere Elemente nicht gespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoBrowserSaveWebComplete" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag "Webseite, komplett" wird ausgeblendet
0 | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Browser-Menüs
Einstellungsname: | Menü: "Datei": Als komplette Webseite speichern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2623.htm


Internet Explorer: Menüeintrag "Quelltext" deaktivieren

Mit diesem Tipp können Sie den Eintrag "Quelltext" aus dem Menü Ansicht entfernen. Dadurch wird die Anzeige des HTML-Quelltextes von Webseiten unterbunden.

Wenn Sie den Eintrag "NoViewSource" aktivieren (Festlegung auf "1"), wird der Befehl "Quelltext" im Menü "Ansicht" deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoViewSource" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag "Quelltext" wird ausgeblendet
0 | Eintrag wird angezeigt (Standard)

Info Diese Einstellung verhindert nicht die Anzeige des HTML-Quelltextes einer Webseite durch das Klicken mit der rechten Maustaste auf eine Webseite, um das Kontextmenü zu öffnen und dann auf "Quelltext" zu klicken. Dazu müssen Sie noch das öffnen des Kontextmenüs wie im Tipp "Entfernen des Kontextmenüs vom IE" beschrieben aktivieren.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Browser-Menüs
Einstellungsname: | Menü: "Ansicht": Menüoption "Quelltext" deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2625.htm


Internet Explorer: Online Support Seite (URL) festlegen

Mit diesem Tipp können Sie die Seite (URL) festlegen, die aufgerufen werden soll, wenn der Eintrag "?" -> "Onlinesupport" im Internet Explorer ausgewählt wird.

Standardmäßig ist hinter diesem Button eine Microsoft Webseite hinterlegt, Sie können hier aber auch jede andere beliebige Seite hinterlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Help_Menu_Urls

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Help_Menu_Urls

Erstellen Sie hier einen neuen Wert mit dem Namen "Online_Support" als Datentyp REG_SZ und geben die gewünschte URL an (z.B.: "http://www.winfaq.de").

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2643.htm


Internet Explorer: Befehlsleiste ein-/ausblenden

ab IE 8

Die Befehlsleiste wird im Internet Explorer standardmäßig angezeigt. Diese Befehlsleiste kann aber über die Einstellung im Menü "Ansicht" -> "Symbolleisten" -> "Symbolleiste" ein-/ausgeblendet werden.

Mit der folgenden Einstellungen, können Sie festlegen ob eine Befehlsleiste angezeigt werden soll oder nicht. Weiterhin kann diese Einstellung nicht mehr über das Menü des Internet Explorers verändert werden.

Wenn Sie den Eintrag "CommandBarEnabled" aktivieren (Festlegung auf "1"), wird die Befehlsleiste angezeigt.

Wenn Sie diese Einstellung deaktivieren (Festlegung auf "0"), wird die Befehlsleiste nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Wenn Sie die Einstellung über das Menü verändert, wird die Einstellung in der Registry unter dem folgenden Schlüssel gespeichert:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ CommandBar

Wenn Sie den Wert über die Policies setzten, kann der Anwender die Einstellung nicht verändern.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ CommandBar

Erstellen Sie hier einen neuen Wert mit dem Namen "CommandBarEnabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Die Befehlsleiste wird nicht angezeigt
1 | Die Befehlsleiste wird angezeigt

Damit die Einstellung wieder über das Menü verändert werden kann, muss dieser Eintrag aus der Registry gelöscht werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2671.htm


Internet Explorer: Favoritenleiste ein-/ausblenden

ab IE 8

Die Favoritenleiste wird im Internet Explorer standardmäßig angezeigt. Diese Favoritenleiste kann aber über die Einstellung im Menü "Ansicht" -> "Symbolleisten" -> "Favoritenleiste" ein-/ausgeblendet werden.

Mit der folgenden Einstellungen, können Sie festlegen ob eine Favoritenleiste angezeigt werden soll oder nicht. Weiterhin kann diese Einstellung nicht mehr über das Menü des Internet Explorers verändert werden, wenn Sie den Wert über den Policy Eintrag setzen.

Wenn Sie den Eintrag "Enabled" aktivieren (Festlegung auf "1"), wird die Favoritenleiste angezeigt.

Wenn Sie diese Einstellung deaktivieren (Festlegung auf "0"), wird die Favoritenleiste nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Wenn Sie die Einstellung über das Menü verändert, wird die Einstellung in der Registry unter dem folgenden Schlüssel gespeichert:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ LinksBar

Wenn Sie den Wert über die Policies setzten, kann der Anwender die Einstellung nicht verändern.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ LinksBar

Erstellen Sie hier einen neuen Wert mit dem Namen "Enabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Die Favoritenleiste wird nicht angezeigt
1 | Die Favoritenleiste wird angezeigt

Damit die Einstellung wieder über das Menü verändert werden kann, muss dieser Eintrag aus der Registry gelöscht werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2672.htm


Internet Explorer: Fixierung der Symbolleisten konfigurieren

ab IE 8

Die Symbolleisten sind im Internet Explorer standardmäßig fixiert und können nicht verschoben werden. Diese Fixierung kann aber über die Einstellung im Menü "Ansicht" -> "Symbolleisten" -> "Symbolleisten fixieren" ein-/ausgeschaltet werden.

Mit der folgenden Einstellungen, können Sie festlegen ob die Symbolleisten fixiert sein sollen oder nicht. Weiterhin kann diese Einstellung nicht mehr über das Menü des Internet Explorers verändert werden, wenn Sie den Wert über den Policy Eintrag setzen.

Wenn Sie den Eintrag "Locked" aktivieren (Festlegung auf "1"), wird die Fixierung aktiviert.

Wenn Sie diese Einstellung deaktivieren (Festlegung auf "0"), wird die Fixierung aufgehoben und die Symbolleisten können verschoben werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Wenn Sie die Einstellung über das Menü verändert, wird die Einstellung in der Registry unter dem folgenden Schlüssel gespeichert:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar

Wenn Sie den Wert über die Policies setzten, kann der Anwender die Einstellung nicht verändern.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbar

Erstellen Sie hier einen neuen Wert mit dem Namen "Locked" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Keine Fixierung der Symbolleisten
1 | Die Symbolleisten werden Fixiert und können nicht verschoben werden

Damit die Einstellung wieder über das Menü verändert werden kann, muss dieser Eintrag aus der Registry gelöscht werden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2673.htm


Animiertes Logo für den Internet Explorer festlegen

Wenn Sie im Internet surfen oder in Outlook Express E-Mail/News holen, dreht sich rechts oben das MS Logo.

Dieses Logo können Sie durch ein anderes, eigenes Logo ersetzen. Genauso können Sie auch das Logo festlegen, welches bei Inaktivität angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Animierte Logos:

Erstellen Sie dafür zwei Bilder (z.B. mit MS-Paint, ändern Sie hier unter "Bild" -> "Attribute") in den folgenden Größen:

1 Bild mit 38 Pixel Breite (für BrandBitmap)

1 Bild mit 22 Pixel Breite (für SmBrandBitmap)

Die Höhe für das Bild berechnen Sie folgendermaßen, Wenn Sie z.B. ein animiertes Logo mit 10 Bildern machen wollen, dann ist die Höhe für das erste Bild 38*10 = 380 für das zweite wäre es dann 22*10 = 220. Sie müssten dann also jeweils ein Bild mit der Größe 38*380 Pixel und 22*220 Pixel erstellen.

In diesen Streifen müssen Sie nun die einzelnen Animationsbilder ablegen, die dann automatisch abgespielt werden.

Tragen Sie nun diese Bilder in die Registry unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar

ein. Erstellen Sie dafür zwei Registry-Schlüssel:

Wertname | Datentyp | Inhalt | Beschreibung
SmBrandBitmap | REG_SZ | C:\Bildname1.BMP | Das kleine Bild
BrandBitmap | REG_SZ | C:\Bildname2.BMP | Das große Bild

Feste Logos:

Erstellen Sie dafür zwei Bilder (z.B. mit MS-Paint, ändern Sie hier unter "Bild" -> "Attribute") in den folgenden Größen:

1 Bild mit 22*22 Pixel Breite*Höhe (für SeinmallBitmap)

1 Bild mit 38*38 Pixel Breite*Höhe (für BigBitmap)

Tragen Sie diese Bilder nun in die Registry unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ein. Erstellen Sie dafür zwei Registry-Schlüssel:

Wertname | Datentyp | Inhalt | Beschreibung
SeinmallBitmap | REG_SZ | C:\Bildname1.BMP | Das kleine Bild
BigBitmap | REG_SZ | C:\Bildname2.BMP | Das große Bild

Info Um das Originallogo wiederherzustellen, müssen Sie diese Einträge wieder aus der Registry löschen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=176713

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0959.htm


Ändern der IE Titelleiste

Ändern der IE Titelleiste: Werbehinweis

Wer seine Kopie des IE 5.x von Anbietern wie AOL, MSN etc. erhalten hat, hat in den meisten Fällen einen Werbehinweis in der Infotitelleiste des IE. Meistens "Internet Explorer von......." Um diesen Hinweis zu ändern oder zu löschen, müssen Sie in der Registry folgende Werte ändert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main

finden Sie den Wert "Window Title" mit dem Eintrag, der in der Infotitelleiste angezeigt wird. Dort den gewünschten Text eingeben, der in der Titelleiste angezeigt werden soll.

Weiterhin finden Sie meistens noch unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

den gleichen Eintrag, der dann natürlich auch abgeändert werden muss.

Beim nächsten Start von IE wird der eingetragene Text angezeigt.

Bei Outlook Express mit "WindowTitle" analog verfahren unter

HKEY_CURRENT_USER\ Identities\ {"kryptische Zahlenfolge (SID der USER-ID)"}\ Software\ Microsoft\ Outlook Express\ 5.x

Info Wenn Sie den Registryeintrag löschen, zeigt der IE wieder in der Titelzeile den Seitentitel der aktuellen Webseite an.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=176497

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0515.htm


IE-Fenster in bestimmter Größe starten

Der Internet-Explorer lässt sich mit einem Trick in jeder beliebigen Auflösung starten.

Dazu startet man den IE und gibt in die Adresszeile

javascript:window.resizeTo(800,600)

ein. Die Werte können dabei variieren. Nach dem RETURN wird der Browser in die angegebene Auflösung gesetzt. Mit dem Eintrag in der Adresszeile erstellt man per Drag and Drop eine Verknüpfung auf dem Desktop. Ideal für Webdesign etc.

Sie können dafür auch einen Eintrag für eine beliebige Auflösung in den Favoriten anlegen:

  • Eintrag zu den Favoriten hinzufügen
  • Name: Auflösung 800x600
  • Speichern und dann über Eigenschaften die URL ändern in:
    javascript:window.resizeTo(800,600)
  • Beim speichern kommt eine entsprechende Meldung, diese jetzt mit OK bestätigen

Sie können jetzt mit diesem Eintrag die Auflösung jederzeit ändern. Dabei wird die Adresse der aktuellen Seite nicht verändert.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0972.htm


IE Zeichensatzeinstellungen (Style-Sheets) werden ignoriert

Wenn der Internet Explorer aktuelle Style-Sheets von Webseiten ignoriert, kann das an einem alten Registry-Wert liegen, der von einer vorherigen IE-Version stammt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Finden Sie den Eintrag UseStyleSheets. Löschen Sie diesen oder setzen Sie den Wert auf 1.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=183717

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1234.htm


Symbolleiste des IE verändern

Die Symbolleiste des Internet Explorers können Sie mit einem beliebigen Hintergrundbild versehen. Dazu müssen Sie in der Registry folgenden Wert anlegen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar

erstellen Sie hier einen neuen Wert mit dem Namen "KBitmap" als Datentyp REG_SZ. Geben Sie als Wert den Pfad und die Datei des gewünschten Hintergrundbild an.

Beim IE5 kann es sein, dass "KBitmapIE5" als Datentyp REG_SZ benutzt werden muss.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0448.htm


Internet-Verknüpfungen wahlweise in einem neuen Fenster öffnen

Durch den folgenden Registry-Eintrag kann man ab sofort bei jeder Internetverknüpfung (und somit auch innerhalb der Favoriten im Internet-Explorer) wählen, ob dieser sich in einem neuen Fenster öffnet. Diese Option bietet der IE normalerweise nur bei Links innerhalb von Webseiten, nicht aber bei Verknüpfungen auf dem Desktop, Startmenü oder in den Favoriten:

Dazu kopiert man den folgenden Text in Notepad und speichert die Datei als REG-Datei.

Verwenden Sie bei der Angabe des Dateinamens doppelte Anführungszeichen. Geben Sie die Endung <.REG>mit an, also z.B. "Fenster.reg", damit Notepad die Datei nicht als <.TXT> oder gar als <.REG.TXT> speichert.

Danach klicken Sie mit der rechten Maustaste auf die soeben erstellte Datei und wählen "Zusammenführen", um die Informationen in die Registry einzufügen. So dann steht ein neuer Eintrag im Kontextmenü von Webverknüpfungen "Öffnen in einem neuen Fenster" zur Verfügung.

===== Hier schneiden =====
REGEDIT4

[HKEY_CLASSES_ROOT\InternetShortcut\shell\Öffnen in neuem Fenster\command]
@="Rundll32.exe shdocvw.dll,OpenURL %l"
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"AllowWindowReuse"=dword:0000000

===== Hier schneiden =====

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1193.htm


IE-Fenster im Vollbild öffnen

Möchten Sie, dass der Internet Explorer immer im Vollbild geöffnet wird, müssen Sie folgenden Eintrag in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

finden Sie den Eintrag "FullScreen" als Datentyp REG_SZ. Setzen Sie den Wert auf "YES"

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1070.htm


Falsche Fenstergröße beim Öffnen vom IE

Sollte der IE5 beim Öffnen eines neuen Fenster sich bei der Fenstergröße nicht an dem Standard orientieren (Vorgabe des letzten Fensters beim Schließen), kann man den Fehler in der Registry beheben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

den Eintrag Window_Placement löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0489.htm


IE in voller Bildschirmgröße starten

Wenn Sie den Internet Explorer immer in voller Bildschirmgröße starten wollen, erstellen Sie sich eine IE-Startseite mit folgendem Inhalt:

=== Hier schneiden ===
<html>
<head>
<script language="JavaScript">
<!--
window.resizeTo(screen.availWidth,screen.availHeight);
window.moveTo(0,0);
//-->
</script>
</head>
</html>
=== Hier schneiden ===

Speichern Sie den Inhalt zwischen den gestrichelten Linien als C:\Startpage.htm und tragen Sie in den Internetoptionen des IE als Startseite "file:///C:/Startpage.htm" ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1287.htm


Die Anpassungen des Browsers von anderen Anbietern unterbinden

Hiermit können Sie das Anpassen des Browsers von anderen Anbietern, das sog. "Branding" unterbinden. Damit können das Logo oder die Titelleiste vom Internet Explorer oder Outlook Express nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft \Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoExternalBranding" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Es werde keine Anpassungen (Branding) zugelassen
0 | Anpassungen sind erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Externes Branding von Internet Explorer deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1831.htm


Imagegröße der Toolbar des Internet Explorers

Imagegröße der Toolbar des IE ändern

Mit diesem Tipp können Sie die Größe der Toolbar des Internet Explorers einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "Image_Filter" als Datentyp REG_DWORD und geben Sie die Minimum Image Größe (in Pixel) an. Der Standardwert liegt bei 200.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2067.htm


Pfadsuche in der Addressleiste konfigurieren

Pfadsuche in der IE-Adressleiste konfigurieren

Mit diesem Tipp können Sie die Pfadsuche in der Adressleiste des Internet Explorers aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Band\ Address

ändern Sie hier den Wert "Use PATH" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Pfadsuche aktivieren
0 | Pfadsuche deaktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2068.htm


Automatische Bildgrößenanpassung konfigurieren

Mit diesem Tipp können Sie einstellen, ob der Internet Explorer eine automatische Bildgrößenanpassung durchführen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "Enable AutoImageResize" als Datentyp REG_SZ und setzen den Wert auf:

YES | Automatische Bildgrößenanpassung aktivieren
NO | Automatische Bildgrößenanpassung nicht aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2106.htm


Anzeigen der Bild - Toolbar im Internet Explorer aktivieren

Anzeigen der Bild - Toolbar im IE aktivieren

Mit diesem Tipp können Sie einschalten, dass der Internet Explorer eine Toolbar anzeigt, wenn sich der Mauszeiger über einer Grafik befindet. Mit dieser Toolbar können Sie die Grafik speichern und drucken.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "Enable_MyPics_Hoverbar" als Datentyp REG_SZ und setzen den Wert auf:

YES | Toolbar einblenden
NO | Toolbar nicht einblenden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2112.htm


Dialogfenster im IE automatisch in einem neuen Tabreiter öffnen

Ab dem Internet Explorer 7.x gibt es die neuen Funktion "Tabbed Browsing" (Tabreiter). Mit diesem Tipp können Sie einstellen, ob Dialogfenster (Pop-Ups) einer Webseite automatisch in einem neuen Tabreiter geöffnet werden sollen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ TabbedBrowsing

ändern Sie hier den Wert "PopupsUseNewWindow" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Dialogfenster in neuen Tabreiter öffnen
0 | Dialogfenster in gleich Tabreiter öffnen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2118.htm


Focus automatisch auf neuen Tabreiter im IE setzen

Ab dem Internet Explorer 7.x gibt es die neuen Funktion "Tabbed Browsing" (Tabreiter). Mit diesem Tipp können Sie einstellen, ob der Focus automatisch auf das neue Tabreiter gesetzt werden oder ob IE immer beim aktuellen Tabreiter bleiben soll, auch wenn eine Webseite in einem neuen Tabreiter geöffnet wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ TabbedBrowsing

ändern Sie hier den Wert "OpenInForeground" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Focus automatisch ändern
0 | Focus nicht automatisch ändern

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2119.htm


'Tabbed Browsing' im IE aktivieren

"Tabbed Browsing" im IE aktivieren

Mit diesem Tipp können Sie das "Tabbed Browsing" (Tabreiter) ab dem Internet Explorer 7.x aktivieren. Dadurch werden Webseiten - wie bekannt aus Firefox - unter neuen Tabreitern geöffnet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ TabbedBrowsing

ändern Sie hier den Wert "Enabled" als Datentyp REG_DWORD und setzen den Wert auf:

1 | "Tabbed Browsing" aktivieren
0 | "Tabbed Browsing" nicht aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2120.htm


Internet Explorer: Menüleiste oben anordnen

Ab dem Internet Explorer 7 wird die Menüleiste standardmäßig nicht mehr angezeigt.

Über den Eintrag "Extras" -> "Menüleiste" können Sie die Menüleiste einblenden. Leider wird die Menüleiste aber nicht oben, sondern in der Mitte eingeblendet. Wenn Sie möchten, dass die Menüleiste wieder oben angezeigt wird, müssen Sie folgenden Eintrag setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar\ WebBrowser

oder als Policies

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbar\ WebBrowser

Erstellen Sie hier einen neuen Wert mit dem Namen "ITBar7Position" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Blendet die Menüleiste oben ein
0 | Menüleiste in der Mitte (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Menüleiste über Navigationsleiste verschieben

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2181.htm


Internet Explorer: Suchbox aus-/einblenden

Ab IE 7.0 können Sie Mit diesem Tipp konfigurieren, ob rechts neben der Adressleiste im Navigationsbereich eine Suchbox angezeigt werden soll. In dieser Suchbox können Sie im Internet über bestimmte Suchserver (Google, MSN usw.) nach Stichwörtern suchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoSearchBox" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Suchbox aus dem Navigationsbereich ausblenden
0 | Suchbox einblenden

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Internet Explorer-Suchfeld nicht anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2207.htm


Internet Explorer: Menüleiste ein-/ausblenden

Ab IE 7.0 können Sie Mit diesem Tipp konfigurieren, ob die Menüleiste angezeigt werden soll oder nicht. Standardmäßig wird die Menüleiste nicht mehr angezeigt. Wenn Sie die Anzeige der Menüleiste Mit diesem Tipp konfigurieren, kann der Anwender nicht mehr über "Ansicht" -> "Symbolleisten" die Anzeige konfigurieren/ändern.

Info Sie müssen diesen Schlüssel löschen, damit der Benutzer selber wieder die Anzeige konfigurieren kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "AlwaysShowMenus" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Menü wird immer angezeigt
0 | Die Menüleiste ausblendenMenü wird nur durch Drücken der ALT-Taste angezeigt

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Menüleiste standardmäßig aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2209.htm


Internet Explorer: Navigationsbereich und Befehlsleiste ausblenden

Ab IE 7.0 können Sie Mit diesem Tipp den Navigationsbereich und die Menüleiste ausblenden. Im Navigationsbereich werden Adresszeile, Suchbox und die Schalter (Vorwärts/Rückwärts) eingeblendet.

In der Befehlsleiste werden die Einträge "Extras", "Seite" usw. angezeigt

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Toolbars\ Restrictions

Ausblenden der Navigationsleiste:

Erstellen Sie hier einen neuen Wert mit dem Namen "NoNavBar" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Navigationsbar ausblenden
0 | Navigationsbar anzeigen

Ausblenden der Befehlsleiste:

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCommandBar" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Befehlsleiste ausblenden
0 | Befehlsleiste anzeigen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Vollbildmodus erzwingen

Die Gruppenrichtline setzt noch den Eintrag "AlwaysShowMenus" auf "0" (Siehe dazu Tipp: "Internet Explorer: Menüleiste ein-/ausblenden")

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2210.htm


Internet Explorer: Einstellung "Links unterstreichen" konfigurieren

Mit diesem Tipp können Sie die Einstellung "Links unterstrichen" konfigurieren. Diese Einstellung finden Sie im Internet Explorer unter "Extras" -> "Internetoptionen" -> Tabreiter "Erweitert" unter der Rubrik "Browsen".

Mit dieser Funktion legen Sie fest, ob der Browser:

  • Links immer unterstreichen soll (Immer)
  • Links nur unterstreichen soll, wenn Sie mit dem Mauszeiger über den Links fahren (Beim Draufziehen)
  • Links nie unterstrichen werden sollen (Niemals).

Wenn Sie die Einstellung über diesen Tipp konfigurieren, können die Benutzer die Einstellung über den Explorer nicht mehr verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Anchor Underline" als Datentyp REG_DWORD und setzen den Wert auf:

yes | Links immer unterstreichen
hover | Links nur unterstreichen, wenn Mauszeiger auf den Link steht
no | Links nie unterstreichen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Interneteinstellungen\Erweiterte Einstellungen\Browsen
Einstellungsname: | Konfiguration von Linkunterstreichungen deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2258.htm


Internet Explorer: Entfernen der Symbolleiste

Internet Explorer: Ausblenden der Symbolleiste

Mit diesem Tipp können Sie die Symbolleiste, die im Internet Explorer ab der Version 7.0 oben rechts angezeigt wird, wieder ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ CommandBar

Erstellen Sie hier einen neuen Wert mit dem Namen "Enabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Symbolleiste nicht anzeigen
1 | Symbolleiste anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2549.htm


Internet Explorer: Kontextmenüeinträge entfernen

Wenn Sie im Internet Explorer auf einer Seite die rechte Maustaste anklicken, wird Ihnen ein Kontextmenü angezeigt. Mit der Zeit werden die Einträge in diesem Kontextmenü immer vielfältiger, da sich neue Programme bei ihrer Installation dort eintragen.

Wenn Sie die Einträge im Kontextmenü bearbeiten wollen, können Sie das über die Registry machen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ MenuExt

finden Sie für jeden Kontextmenüeintrag einen entsprechenden neun Schlüssel. Löschen Sie diejenigen Schlüssel, die nicht mehr angezeigt werden sollen. Damit Sie den Eintrag wieder herstellen können, wenn Sie ihn aber wieder benötigen wollen, sollten Sie den entsprechenden Eintrag über den Menüeintrag "Datei" -> "Exportieren..." in einer .REG-Datei sichern (vorher den entsprechenden Schlüssel in Regedit auswählen). Jetzt können Sie den ganzen Schlüssel löschen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2459.htm


Internet Explorer: Toolbar sperren

Mit diesem Tipp können Sie die Toolbar des Internet Explorer sperren, so dass die Toolbar nicht verschoben und verändert werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Toolbar

Erstellen Sie hier einen neuen Wert mit dem Namen "Locked" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Toolbar ist gesperrt
0 | Toolbar ist nicht gesperrt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2606.htm


Smooth Scrolling in Internet Explorer

Smooth Scrolling im Internet Explorer

Mit diesem Tipp können Sie das "Smooth Scrolling" (weiches Ein-/Ausblenden) für den Internet Explorer aktivieren.

Wenn Sie den Eintrag "SmoothScroll" aktivieren (Festlegung auf "1"), ist die Funktion aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "SmoothScroll" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Smooth Scrolling deaktivieren
1 | Smooth Scrolling aktivieren

Siehe auch Tipp:

Smooth Scrolling

Smooth Scrolling unter Telnet

Smooth Scrolling unter Outlook Express

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2631.htm


Java-Script funktioniert nicht mehr

Warum der IE plötzlich keine Java-Scripts mehr ausführt, ist nicht bekannt. Aber es kommt vor und zeigt sich darin, dass sämtliche aktiven Inhalte nicht mehr funktionieren. Eine Lösung besteht darin, dass man von der Windows 98 CD aus dem Verzeichnis \tools\mtsutil die Datei java.inf mit der rechten Maustaste anklickt und "Installieren" wählt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1151.htm


Java VM für IE nachinstallieren

Unter Windows XP wird beim IE 6 keine Java-VM (Virtual Machine) mehr installiert. Wenn Sie im Internet auf eine Seite stoßen, die diese Funktion aber benötigt, wird automatisch ein Download angeboten. Diesen Download können Sie sich sparen, wenn Sie vorher Java nachinstallieren.

Die letzte Version der Java VM von Microsoft erhalten Sie u. a. hier: Microsoft Java VM:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;169803

Alternativ zu "MS Java VM"

installiere die aktuelle "Sun Java(TM) Virtual Machine (JVM)" unterstützt Windows 95/98/98SE/ME/NT/2000/XP

Automatischer Download und Installationsanleitung http://java.sun.com/getjava/install-windows.html

Manueller Download und Installationsanleitung http://java.com/de/download/index.jsp

von dort durchklicken:

--> "Windows (all languages, including English) JRE" --> Download

--> "Accept"

nächstes Fenster enthält immer aktuellsten Download von Sun Java

Im XP Service Pack 1 ist die Java VM ebenfalls enthalten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1213.htm


Microsoft Garbage Collection konfigurieren

Mit diesem Tipp können Sie einstellen, wie viel Speicher Java benutzen kann, bevor der Garbage Collection (GC) freigegeben wird. Die GC belegt viele Systemressourcen und kann somit die Leistung des Systems beeinflussen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Java VM

Erstellen Sie hier einen neuen Wert mit dem Namen "Generation0Size" als Datentyp REG_DWORD. Geben Sie hier die Größe in Bytes ein. Der maximale Wert liegt bei 4194304 (Deximal) was 4 MByte entspricht.

Ist der Eintrag nicht vorhanden, wird ein Wert nach der folgenden Grundlage berechnet:

  • Bei Rechnern mit 1 CPU wird 256 KB als Standardwert benutzt
  • Bei Multi-Prozessor Rechner mit einem Arbeitsspeicher bis 256 MB wird 512 KB als Standardwert benutzt
  • Bei Multi-Prozessor Rechnern mit mehr als 256 MB wird 1 MB als Standardwert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1611.htm


Internet Explorer: Ausführen von Javaskript unterbinden

Mit diesem Tipp können Sie das Ausführen von Javaskript im Internet Explorer deaktivieren.

Viele Webseiten im Internet benutzen Java zum Anzeigen von Informationen. Leider tauchen aber immer wieder auch Sicherheitslücken auf, mit denen sich Informationen vom Rechner auslesen lassen.

Sie können Java entsprechend deaktivieren und die Seiten, die Sie kennen und wo Sie Java brauchen, in die Vertrauenswürdigen Sites aufnehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Zones\ 3

Erstellen Sie hier die folgenden neuen Werte als Datentyp REG_DWORD, und setzen Sie die Werte zum Deaktivieren wie in der Tabelle angegeben auf 3:

Name | Wert (deaktiv) | Standard | IE Name
1400 | 3 | 0 | Active Scripting
1402 | 3 | 0 | Skripting von Java-Applets
1407 | 3 | 1 | Programmatischen Zugriff auf die Zwischenablage zulassen

Die Einstellung befinden sich auch im Internet Explorer unter "Internetoptionen" -> "Sicherheit" -> "Internet" -> Button "Stufe anpassen" -> "Skripting".Die Konfiguration stehen unter dem in der oberen Tabelle bei "IE Name" angegebenen Namen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2533.htm


URL-Listen im Internet Explorer löschen

Der Internet Explorer trägt jeden Aufruf einer Internetseite in die Historyliste ein. Diese Liste wird in der Registry abgelegt. Wenn Sie Einträge aus der Liste löschen wollen, finden Sie die Einträge unter folgendem Schlüssel:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER / Software / Microsoft / Internet Explorer / TypedURLs

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0885.htm


Favoriten Einträge alphabetisch sortieren

Die Favoriten im Internet Explorer 4.x werden willkürlich angezeigt. Das Neusortieren im IE führt nicht zum gewünschten Erfolg, da diese Funktion fehlerhaft ist.

Damit Sie die Favoriten wieder sortieren können, müssen Sie einen Registry-Key löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ MenuOrder\ Favorites

hier löschen Sie den Eintrag "Order" als Datentyp REG_BINARY. Jetzt werden alle Einträge wieder sortiert angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0662.htm


Ordneransicht beim Hinzufügen von Favoriten automatisch öffnen

Wenn man in IE einen Eintrag zu den Favoriten hinzufügen möchte, wird das Fenster "Zu Favoriten hinzufügen" geöffnet. Mit diesem Tipp können Sie einstellen, ob das Fenster "Erstellen in:" geöffnet ist oder erst beim Klick auf den Button "Erstellen in >>" geöffnet und standardmäßig geschlossen angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "AddToFavoritesExpanded" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Ordneransicht geöffnet anzeigen
0 | Ordneransicht nicht geöffnet anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2117.htm


Favoriten in einem neuen IE-Fenster öffnen

Mit diesem Tipp können Sie einen neuen Eintrag zum Kontextmenü hinzufügen, mit dem Sie Einträge aus den Favoriten in einem neuen Internet Explorer Fenster öffnen können. Ab IE 7 wird die Seite in einem neuen Tabreiter angezeigt.

Wenn Sie den Eintrag hinzugefügt haben, finden Sie im Kontextmenü (Rechtsklick in den Favoriten), einen neuen Eintrag "Im neuen Fenster öffnen", mit dem Sie Favoriteneinträge in einen neuen Explorer Fenster öffnen können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CLASSES_ROOT\ InternetShortcut\ shell

erstellen Sie einen neuen Schlüssel mit den Namen "Im neuen Fenster öffnen" und anschließend unter diesem Schlüssel noch einen weiteren, neuen mit dem Namen "command". Der Pfad in der Registry sollte jetzt so aussehen:

HKEY_CLASSES_ROOT\ InternetShortcut\ shell\ Im neuen Fenster öffnen\ command

Geben Sie hier jetzt unter "(Default)" als Datentyp REG_SZ folgenden Befehl ein:

rundll32.exe shdocvw.dll,OpenURL %1

(Bitte auf die Schreibweise achten!)

Jetzt wird der Eintrag im Kontextmenü unter den Favoriten angezeigt. Wenn Sie den Eintrag wieder loswerden wollen, müssen Sie nur den Schlüssel "Im neuen Fenster öffnen" löschen.

Sie können den Eintrag auch über die folgende REG-Datei erzeugen. Speicher Sie dafür den Inhalt in eine Datei mit dem Namen "IEOpenNewFolder.REG" ab und führen die Datei mit einem Doppelkilck im Explorer aus.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\InternetShortcut\shell\Im neuen Fenster öffnen\command]

@="rundll32.exe shdocvw.dll,OpenURL %1"

=== Hier schneiden ===

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2590.htm


IE-Meldung: "Überprüfen Sie Einstellungen für den Inhaltsratgeber"

Bringt der Internet-Explorer beim Start die obige Meldung, muss man den Schlüssel

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Policies \ Rating

komplett löschen.

Außerdem ist die Datei RATINGS.POL zu löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0894.htm


Unwichtige IE Fehlermeldungen ausschalten

Ab der Version 5.x des Internet Explorers können Sie das Anzeigen von unwichtigen Fehlermeldungen (z.B. Internetseite wurde verschoben usw.) deaktivieren. Da diese Meldungen eher nerven als einen Nutzen bringen, ist es sinnvoll, diese Meldungen zu unterdrücken. Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

erstellen Sie hier einen neuen Eintrag mit dem Namen "Friendly http errors" als Datentyp REG_SZ. Setzen Sie den Wert auf No.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0958.htm


Grafiken werden nur als BMP gespeichert

Nach längeren Surf-Sessions kann es vorkommen, dass Grafiken beim "Speichern als" nur noch als BMP abgespeichert werden können. In diesem Fall hilft meist das Löschen des Caches unter den Internetoptionen und Neustart des Browsers.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1091.htm


Probleme mit dem IE möglicherweise durch Werberoboter

Autor: Michael Appelt

Aktualisierung: A. Kästner

Die Probleme mit dem Internet Explorer sind überall zu finden. In Newsgroups und sonstigen Foren wird gefachsimpelt, warum der IE auf dem einen oder anderen System sich einfach mit Fehlern verabschiedet oder keine Seiten angezeigt werden. Anstatt immer den Fehler bei Microsoft zu suchen, sollte man auch andere Fehlerquellen in Betracht ziehen.

Auf Grund eigener Erfahrungen und Feststellungen von Winmag-Autor Dave Methvin

(WinMag-Letter vom 26.01.2001 unter http://www.winmag.com/columns/insider/2001/02.htm)

sind oft sogenannte Werberoboter in AdWare für Fehlfunktionen im Internet Explorer verantwortlich.

In der KB von Microsoft finden sich dazu konkret sogar mehrere Einträge:

Invalid Page Fault Error Messages If You Run IE 5.5 and Aureate Radiate (Q259684):

http://support.microsoft.com/?kbid=259684

Invalid Page Fault Error Messages If You Install IE 5.5 and Gator Software (Q253364):

http://support.microsoft.com/?kbid=253364

Error Message: Fsg Has Caused an Error in Fsg.exe; Fsg Will Now Close (Q298762)

http://support.microsoft.com/?kbid=298762

The "Fatal Error: Could not Create Socket" Error Message Is Displayed When Starting Windows (Q299964)

http://support.microsoft.com/?kbid=299964

Error Message: Iexplore.exe Has Generated Errors and Will Be Closed By Windows (Q303728)

http://support.microsoft.com/?kbid=303728

Error Message When You Try to Browse the Web: The Page Cannot Be Displayed (Q311264)

http://support.microsoft.com/?kbid=311264

Gerade der erste Eintrag sollte einem zu denken geben. Immerhin sind Aureate und Radiate "Marktführer" in Sachen Werberoboter. Über 250 Programme finden sich auf deren Liste unter http://www.radiate.com/consumers/products.html

Bei den Werberobotern handelt es sich um Systeme, mit denen die sogenannte AdWare mit Werbebannern versorgt wird. Welche Systeme auf dem Markt sind, wie man diese erkennt und vieles mehr hat Freewareguide unter http://www.freewareguide.de/win9x/adware.shtmlin einem Special behandelt.

Warum diese Werberoboter von Adware, Alexa, Aureate/Radiate v1.0-v3.0, Comet, Cursor v1.0 and v2.0, Cydoor, Doubleclick, DSSAgent, Flyswat, Gator, TimeSink v1.0 und v2.0, Web3000 und Webhancer?

Nun, die Softwarehersteller sehen nur geringe Einnahmequellen durch die Registrierung. Daher wird die Software kostenlos vertrieben und blendet dafür Bannerwerbung ein. Gerade Software, welche für den Einsatz im Internet konzipiert ist kann hier Vorteile verbuchen, da sich bei aktiver Verbindung leicht Banner auf den heimischen PC schleusen lassen.

Ein bekannter Vertreter ist z.B. der Downloadmanager Gozilla!. Während die Systeme von Aureate und Co. noch "harmlos" zur Sache gehen, ärgert gerade der Conducent/TimeSink-Bot die Anwender, da dieser gleich Unmengen von Bannern auf den PC lädt, selbst wenn die Applikation gar nicht benutzt wird. Ob sich der Einsatz einer Software lohnt, die im Hintergrund die Datenrate mindert und dabei evtl. noch für Probleme sorgt, muss jeder selbst entscheiden.

Nicht aber jeder lumpige FTP-Client, solange es gute Freewarealternativen gibt.

Bei Problemen mit dem IE sollte man zuerst einmal prüfen, ob nicht ein Werberoboter dafür verantwortlich ist.

Ad-aware von Lavasoft (Freeware) testet das System auf mögliche Werberoboter und kann diese entfernen. Allerdings laufen danach die meisten werbefinanzierten Programme nicht mehr. Zudem werden mit dem "Cleanlauf" meist auch die Uninstall-Funktionen der Programme beeinträchtigt.

Sollte Ad-aware Alarm schlagen, gilt es die betreffende Applikation erst Normal zu deinstallieren und nach einem erneuten Testlauf mögliche Reste von Werberobotern zu entfernen.

Ad-aware können Sie von http://www.lavasoft.de herunterladen. Mit dem Programm "RefUpdate.exe" (ebenfalls von Lavasoft) können Sie nach aktualisierten Ad-aware Datenbanken suchen.

Ein weiteres hervorragendes Werkzeug zur Bekämpfung von Dialern, Spyware und unliebsamen Registryeinträgen ist Patrick Kollas "SpybotSD": http://security.kolla.de/index.php?lang=de&page=news

Radiate stellt übrigens unter http://www.radiate.com/privacy/remover.htmlein eigenes Tool bereit, um sich selber zu entfernen.

Siehe auch: "Startseite lässt sich nicht ändern/Änderung verhindern".

Info Weitere umfangreiche Informationen zu diesem Thema finden Sie unter
http://www.mvps.org/inetexplorer/Darnit.htm(englisch).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1087.htm


Der IE5 meldet: Seite kann nicht angezeigt werden

IE5 meldet: "Seite kann nicht angezeigt werden"

Unter IE5 kann es passieren, dass die Meldung "Seite kann nicht angezeigt werden" erscheint, Die Seite aber nach Betätigen von F5 (Aktualisieren) korrekt angezeigt wird. Schuld hierfür ist lt. Microsoft ein Problem im HTTP Stream, welches ab der Version 5.00.2614.3400 mit der Datei Wininet.dll behoben ist.

Patch für die deutsche Version:

http://download.microsoft.com/download/ie5/Update/1/W9XNT4/DE/de3725.exe

Patch für die englische Version:

http://download.microsoft.com/download/ie5/update/1/win98/EN-US/3725.exe

Info Dieser Tipp gilt *nicht* für Systeme mit einem IE 5 und dessen "wininet.dll" ab Version 5.00.2614.3500 oder höher.
Weitere Informationen zu diesem Thema finden Sie in der MS Knowledge Base unter: http://support.microsoft.com/?kbid=226550

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0191.htm


Browser hängt manchmal nach GetRight Installation

Beim Aufruf beliebiger Seiten bleibt der Internet-Explorer 5.x hängen?

Das könnte auch an der GetRight-Software liegen. Wie in den Newsgroups geklärt wurde, verursacht ein installierter GetRight (sowohl die Voll- als auch die Freeversion) die Ausfälle. Erst nachdem dieser deinstalliert wurde (incl. aller Registry-Einträge) funktionierten die betroffenen Systeme wieder. In Einzelfällen musste zudem noch die Java-VM neu installiert sowie die IE-Reparaturfunktion gestartet werden.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1171.htm


Internet Explorer meldet oft Time-out Fehler

Treten bei der Benutzung des IE oft Time-out Fehler auf, sollten Sie testweise folgenden Wert in der Registry anpassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

erstellen Sie einen neuen Wert mit dem Namen "Receive Timeout" als Datentyp REG_DWORD. Dieser Wert gibt die Wartezeit in Millisekunden an, bis Windows ein "Time out" meldet. Setzen Sie diesen Wert auf 600000, was einer Zeit von 10 Minuten entspricht. Die Meldungen sollten jetzt deutlich seltener auftreten.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=181050

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1236.htm


URL wird bei ''in einem neuen Fenster öffnen'' nicht mit übergeben

Wenn der Internet Explorer beim Befehl "In einem neuen Fenster öffnen" die URL an den neuen Browser nicht mit übergibt (und damit das neue Fenster einfach leer bleibt), kann folgende Vorgehensweise das Problem beheben:

Man gibt unter "Start" -> "Ausführen" -> den Befehl:

regsvr32 urlmon.dll

und

regsvr32 ole32.dll ein.

Nach einem Neustart sollte das Problem beseitigt sein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1139.htm


Plugins funktionieren nicht mehr

Seit IE 5.5 SP2 verzichtet Microsoft auf die Netscape-Plugin-Schnittstelle und ermöglicht den Erweiterungen wie Quicktime etc. nur noch eine Einbindung über ActiveX.

Leider hat bisher nicht jeder Hersteller seine Produkte auf ActiveX angepasst. Eine Lösung besteht nur darin, dass man auf den IE 5.5 SP2 oder IE 6 verzichtet oder auf eine Anpassung der Plugins wartet.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=303401

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1157.htm


Browser startet beim Hochfahren automatisch, wenn der Webwasher installiert ist

Der Webwasher von Siemens bietet unter "EXTRAS" -> "BROWSERKONFIGURATION" das Feld "Den ausgewählten Browser starten".

Wenn dies aktiviert ist, wird bei jedem Neustart auch ein leeres Browserfenster geöffnet. Man sollte diese Funktion daher deaktivieren, wenn der Webwasher beim Systemstart automatisch geladen wird. Für die manuelle Nutzung ist diese Funktion aber durchaus sinnvoll.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1092.htm


Browserstillstand beim Laden bestimmter Seiten

Auf einigen Systemen ist zu beobachten, dass beim Aufruf bestimmter Webseiten das "IE-Logo" beim Laden der Seite plötzlich "steht" und der Browser nicht mehr reagiert.

Abhilfe kann hier das manuelle Zurücksetzen der Internetzone über den Button "Standardstufe" unter "Systemsteuerung" -> "Internetoptionen" -> "Sicherheit" bewirken.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1029.htm


Download schließt IE-Fenster

Beim Download von Dateien aus dem Web kann es mit dem IE 5.5 vorkommen, dass sich das Browserfenster schließt, statt den Download zu starten. Ursache ist die Funktion "Link in einem neuen Fenster öffnen", die sich in den Internetoptionen einstellen lässt.

Trifft diese Funktion auf einen Weblink, der ebenfalls in einem neuen Fenster (_blank) geöffnet werden soll, aber keine HTML-Datei darstellt, tritt der Effekt auf. Zur Abhilfe deaktiviert man die "automatische Open in New Window"-Funktion oder speichert die Datei mit "Ziel speichern unter".

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=268976

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0979.htm


Time-Out Zeit des Internet Explores verändern

Time-Out Zeit des Internet Explorers verändern

Wenn der Internet Explorer eine Verbindung zu einer Web-Seite aufbaut und es zu einem Übertragungsfehler kommt, wartet Windows standardmäßig 1 Minute bis er wieder versucht die Verbindung herzustellen. Wenn Sie eine schlechte Verbindung zum Internet haben, kann es sinnvoll sein die Zeit zu verändern.

Standardmäßig gilt in Internet Explorer ein KeepAliveTimeout-Wert von einer Minute und ein weiterer begrenzender Faktor (ServerInfoTimeout) von zwei Minuten. Beide Einstellungen können zur Folge haben, dass Internet Explorer den Socket zurücksetzt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "KeepAliveTimeout" als Datentyp REG_DWORD. Geben Sie die Zeit in Millisekunden an (z.B.: 120000 für 2 Minuten).

Wenn Sie den Wert KeepAliveTimeout auf weniger als 60.000 (eine Minute) einstellen, können Probleme bei der Kommunikation mit Webservern auftreten, die eine ständige HTTP-Verbindungen erfordern. Eventuell erhalten Sie in einem solchen Fall die Meldung "Die Seite kann nicht angezeigt werden".

Falls Sie den KeepAliveTimeout-Wert auf einen größeren Wert als 120.000 (zwei Minuten) einstellen wollen, müssen Sie einen zusätzlichen Registrierungsschlüssel erstellen und dessen Wert auf den gleichen Eintrag wie KeepAliveTimeout setzen.

Erstellen Sie dafür unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

einen neuen Wert mit dem Namen "ServerInfoTimeout" als Datentyp REG_DWORD und setzen Sie den Wert auf den gleichen Eintrag wie "KeepAliveTimeout". Auch dieser Wert gibt die Zeit in Millisekunden an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1613.htm


Anzeigen von Fehlermeldungen bei Proxyskript konfigurieren

Anzeigen von Fehlermeldungen beim Proxyskript Konfigurieren

Mit diesem Wert können Sie festlegen, ob eine Fehlermeldung angezeigt werden soll, wenn es beim Download des Proxy-Scripts ein Fehler aufgetreten ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DisplayScriptDownloadFailureUI" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Fehlermeldung anzeigen
0 | Keine Fehlermeldung anzeigen, auch wenn ein Fehler auftritt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Fehlermeldung einer Proxyskript-Download-Fehlfunktion anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1833.htm


Systemabsturzermittlung deaktivieren

Info: IE 6 Ab SP2

Mit diesem Tipp können Sie die Absturzermittlung für die Add-On-Verwaltung deaktivieren. Wenn die Funktion nicht aktiv ist, wird bei einem Absturz des IE die Windows Fehlerberichterstattung (wenn konfiguriert) aufgerufen, wie es noch bis SP1 der Fall war.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCrashDetection" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | "Systemabsturzermittlung" deaktivieren
0 | "Systemabsturzermittlung" ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Systemabsturzermittlung deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1842.htm


Fehlerberichterstattung in Internet Explorer konfigurieren

Fehlerberichterstattung in IE konfigurieren

Wenn der Internet Explorer abstürzt, will er einen Fehlerbericht an Microsoft versenden will, wird hier gezeigt, wie Sie das Senden eines Fehlerberichtes ausschalten können, oder aber Sie können sich den Fehlerbericht auch auf einen eigenen Server ablegen lassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "IEWatsonDisabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Es wird kein Fehlerbericht gesendet
0 | Es wird ein Fehlerbericht versendet (Standard)

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "IEWatsonEnabled" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Es wird kein Fehlerbericht gesendet
1 | Es wird ein Fehlerbericht versendet (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Sie können aber auch das Senden des Fehlerberichtes aktiviert lassen und festlegen, dass der Bereich an einen eigenen Server gesendet werden soll.

Unter:

HKEY_CURRENT_USER\ Software\ Policies\ Microsoft\ Office\ 10.0\ Common

Erstellen Sie einen neuen Wert mit dem Namen "DWFileTreeRoot" als Datentyp REG_SZ und geben Sie hier den Server und Freigabenamen an (z.B.: \\ServerName\FreigabeName).

Die Anwender müssen schreibende Rechte auf diesem Share besitzen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2005.htm


Informationsleisten-Benachrichtigung konfigurieren

Mit diesem Tipp können Sie einstellen, ob der Internet Explorer die Informationsleiste einblendet, wenn eine Funktion z.B. nicht ausgeführt werden konnte.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ InformationBar

ändern Sie hier den Wert "FirstTime" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Informationsbar ausblenden
1 | Informationsbar anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2127.htm


Internet Explorer: Der Erweitert Tab in den Internetoptionen enthält keine Einträge

Im Internet Explorer 7 unter "Extras" -> "Internetoptionen" -> unter dem Tabreiter "Erweitert" sind keine Einträge mehr vorhanden.

Grund:

Der Schlüssel "HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ AdvanvedOptions" enthält keine Einträge.

Diesen Fehler können Sie über den folgenden Befehl beheben. Öffnen Sie dafür die Eingabeaufforderung und geben Sie folgendes ein:

regsvr32 /n /i /s inetcpl.cpl

Starten Sie den Internet Explorer neu, der Fehler sollte jetzt behoben sein.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2246.htm


Passwort beim IE 4.x vergessen

Wenn Sie das Passwort bei IE vergessen haben, können Sie keine Einstellungen an den Sicherheitsrichtlinien mehr verändern.

Über den Registry-Editor können Sie das Passwort aber wieder löschen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Ratings

Hier einfach alle Angaben löschen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0268.htm


Datenschutz bei WWW-Browser

Datenschutz (Cookies) bei www-Browsern

Kaum Jemandem ist bekannt, dass gängige www-Browser wie Netscape Navigator, MS Internet Explorer, Netcom NetCruser oder Quarterdeck Mosaik sog, Benutzerinformationen,die 'Cookies', auf dem lokalen Client anlegen. Diese Cookies werden von WEB-Servern mit Hilfe von CGI-Skripts erstellt. Sie können neben dem Namen des Besuchers und dem Datum des Besuches eines WWW-Servers auch noch weitere Informationen enthalten.

Heutzutage werden Cookies von fast jeder Internetseite benutzt. Alle aktuellen Browser bieten aber Möglichkeiten, zwischen "Immer Annehmen", "Nach Frage Annehmen" oder "Immer Ablehnen" auszuwählen. Meist ist aber immer die erste Variante die Voreinstellung.

Nicht nur vorsichtigen Zeitgenossen ist daher anzuraten, die Cookies abzuschalten.

Tipp 1:

Unter Windows muss man hierfür den passenden Eintrag in der Registrydatenbank ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für den IE:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

hier finden Sie den Eintrag "Cookies". Setzen Sie den Wert auf "C:\Recycler" (ab Windows 2000/XP) oder "C:\Recycled" (für Windows 9x/ME und NT).

Die Cookies werden jetzt immer im Papierkorb abgelegt. Wenn Sie den Papierkorb leeren, werden die Cookies gelöscht, ansonsten können Sie die noch benutzen.

Für den Netscape Navigator:

HKEY_USERS\.Default\ Software\ Netscape\ Netscape Navigator\ Cookies

'Cookie Files'='<path>Cookies.txt'

ändern in:

'Cookie Files'='NUL'

In Netscape kann man die Cookies über eine Option abschalten, Sie finden das unter : "Edit/Preferences/Advanced"

Tipp 2:

Öffnen Sie die Datei COOKIES.TXT und löschen - bis auf den Header - den Inhalt. Speichern Sie die Datei und versehen sie mit dem Schreibschutz-Attribut "r" (read only).

Tipp 3:

Für sicherheitsbewußte Anwender bietet sich die Installation eines Proxys auf dem Heim-PC an. Für Windows 95 verfügbar ist u.a. der Internet KBuster ( http://www.junkBuster.com), der neben der Cookie-Sperre weitere Möglichkeiten hinsichtlich der Unterdrückung von Werbebannern etc. bietet.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0095.htm


Internet Explorer: Alexa-Service als Spyware abschalten

Der Internet-Explorer verfügt in den neueren Versionen über ein Feature, mit dem die mit der aktuellen Seite verwandten Seiten angezeigt werden können.

Diese Funktion wird über die Software Alexa realisiert. Die meisten wissen aber nicht, dass dieser Dienst das Surfverhalten des Benutzers ständig überwacht. Alexa holt Informationen über die von Ihnen besuchten Websites und Webseiten ein. und zeichnet u.a. folgende Informationen auf:

  1. Ihre IP-Adresse
  2. Die kompletten URLs besuchter Webseiten
  3. Allgemeine Informationen über Ihren Browser und Ihr Betriebssystem
  4. Ihre eindeutige Alexa-Cookie-Nummer
  5. Den Zeitpunkt der Aufzeichnung.

Eine ausführliche Beschreibung der von Alexa eingeholten Informationen und deren Verwendung finden Sie auf der Website http://www.alexa.com unter "PrivacyPolicy".

Die Sammelwut von Alexa lässt sich über die Registry abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Löschen Sie den folgenden Schlüssel mit allen Untereinträgen:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Extensions\ {c95fe080-8f5d-11d2-a20b-00aa003c157a}

Ein sehr gutes Tool zum Aufspüren und Löschen von Alexa ist übrigens "Internet Cleanup" von Ontrack. Eine englische Version zum Ausprobieren können Sie unter http://www.ontrack.com/internetcleanup/herunterladen.

Ebenfalls sehr empfehlenswert zum Entfernen von Werbe- bzw. Spionagemodulen ist Ad-aware von http://www.lsfileserv.com/index.html.

Siehe auch: "Probleme mit dem IE möglicherweise durch Werberoboter".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1200.htm


Senden der Benutzerkennung zur Autorisierung von Internetsites ausschalten

Wenn Sie diese Funktion aktivieren, wird verhindert, dass Internetsites eine Benutzerkennung zur Autorisierung erhalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableNegotiate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | deaktiv
0 | aktiv (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1483.htm


Lebensdauer der IE Cache-Daten verändern

Wenn Sie oft die gleichen Internetseiten besuchen, ist es ärgerlich, wenn der IE Cache zu früh gelöscht wird und alle Bilder neu übertragen werden müssen, was Zeit kostet.

Nach welcher Zeit die Lebensdauer der im Cache befindlichen Dateien abläuft, können Sie in der Registry mit folgenden Einträgen bestimmen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Cache

hier können Sie mit den Einträgen "CleanupInterval" und "FreshnessInterval" als Datentyp REG_BINARY die Zeit in Sekunden angegeben, die verstreichen muss, bis der Cache erneuert werden soll. Sinnvoll ist ein Wert von "80 3A 09 00", was einem Zeitraum von sieben Tagen entspricht.

Der Speicherplatz, der für den Cache angegeben wurde, muss natürlich ausreichen, ansonsten werden die Daten schon früher gelöscht.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1043.htm


Speichern des Passwortes beim Internet Explorer unterbinden

Wenn man z.B. den Browser über einen Proxy laufen lässt, um eine Kennung abzufragen, wird eine Dialogbox angezeigt. In dieser Dialogbox wird in der letzten Zeile gefragt, ob das Passwort in einer Liste gespeichert werden soll. In einem Netzwerk, wo mehrere Leute einen Rechner benutzen, hat das den Nachteil, dass bei Aktivierung dieser Box der nächste Anwender kein Passwort mehr eingeben muss. Sie können diese Box und damit das Speichern des Passwortes folgendermaßen deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie einen neuen Wert mit dem Namen "DisablePasswordCaching" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1. Standardmäßig ist diesen Funktion aktiviert, also auf 0 gesetzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=229940

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1116.htm


Passwörter im Internet Explorer

Der Internetexplorer kann ab der Version 5 nicht nur die Passwörter von Webseiten speichern, sondern legt auch die Passwörter von Formularen ab. Diese Kennwörter von Formularen können über die Schaltfläche "Autovervollständigung" mit dem Button "Kennwörter löschen" entfernt werden.

Die Kennwörter für die Internetseiten können nicht direkt gelöscht werden. Wenn Sie eine kennwortgeschützte Seite wieder aufrufen, haben Sie die Möglichkeit das Kennwort wieder aus der Liste zu entfernen, dafür brauchen Sie nur den Haken bei "Kennwort in Kennwortliste speichern" entfernen.

Je nach Betriebssystem werden die Kennwörter unterschiedlich abgespeichert. Windows 9x speichert die Kennwörter noch in der Passwortdatei des Benutzers, da diese Datei aber auch noch andere Informationen enthält ist es nicht anzuraten diese Datei zu löschen.

Bei Windows NT/2000 und XP werden die Kennwörter in der Registry abgelegt. Hier liegen die Kennwörter in der Registry des Benutzers in einem abgesicherten Bereich auf dem nur das System zugreifen kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Protected Storage System Provider

hier wird für jede Webseite ein extra Schlüssel angelegt in dem das Passwort wiederum Verschlüsselt abgelegt wird.

Info Wenn Sie auf diesen Key zugreifen wollen, müssen Sie sich vorher die Rechte geben um auf den Schlüssel zugreifen zu können. Der RSW zeigt Ihnen als Administrator die Einträge auch so an, ohne dass Sie die Rechte verändern müssen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1411.htm


Zugriff für potentiell unsichere HTML-Hilfefunktion auf bestimmte Ordner beschränken

Mit dieser Einstellung können Sie potentiell unsichere Funktionen von Hilfedateien (die Befehle: Verknüpfungen und WinHelp) für bestimmte Hilfedateien freigeben oder für alle Hilfedateien sperren.

Mit Verknüpfungen sind Programmaufrufe aus der Hilfedatei heraus gemeint. Damit können also externe Programme über die Hilfedatei gestartet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ System

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "HelpQualifiedRootDir" als Datentyp REG_EXPAND_SZ und geben hier die Pfade zu den Hilfedateien an, welche die Funktionen benutzen dürfen.

Wenn Sie mehr als ein Verzeichnis dafür freigeben wollen, müssen Sie die Verzeichnisse durch ein Semikolongetrennt angeben. Alle Hilfedateien die sich nicht in diesen Verzeichnissen befinden, dürfen diese Befehle nicht ausführen.

Wollen Sie diese Befehle z.B. für alle Standard Windows Hilfedateien freigeben, geben Sie hier folgendes ein:

%windir%\Hilfe;%windir%\pchealth\helpctr;%ProgramFiles%

Wenn Sie den Wert anlegen, aber nichts eingeben, wird damit die Hilfefunktion "Verknüpfungen und WinHelp" auf dem System für alle Hilfedateien deaktiviert.

Info Als gültige Pfade können nur lokale Verzeichnisse angegeben werden. Sie können hier nicht mit UNC-Pfaden arbeiten, da diese Pfade von Windows ignoriert werden. Die Benutzung von Umgebungsvaribalen (%windir%) ist erlaubt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=810687

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1566.htm


Eigene lokale Stylesheets im Internet Explorer unterbinden

Im Internet Explorer können über Web-Seiten eigene lokale Stylesheets geladen werden.

Diese Funktion kann von entsprechenden Webseiten durch Sicherheitslücken im IE für die Beobachtung von Anwenderaktivitäten benutzt werden.

Mit diesem Tipp können Sie das laden von Stylesheets unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Styles

Erstellen Sie hier einen neuen Wert mit dem Namen "Use My Stylesheet" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Stylesheets erlauben (Standard)
0 | laden von Stylesheets unterbinden

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1631.htm


Automatische Installation von Add-On unterbinden

Mit dieser Einstellung können Sie den Download von Komponenten verhindern, die zum Anzeigen einer Webseite benötigt werden (Flashplayer usw.).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoJITSetup" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Automatische Installation unterbinden
0 | Automatische Installation ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Automatische Installation von Internet Explorer-Komponenten deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1849.htm


Sicherheitszonen: Nur Einstellungen pro Computer verwenden

Wenn Sie diese Einstellung aktivieren, gelten die Einstellungen der Sicherheitszonen für alle Benutzer und werden nicht benutzerbezogen gespeichert. Ansonsten kann jeder Benutzer seine eigenen Einstellungen vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "Security_HKLM_only" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Die Sicherheitszonen gelten pro Computer
0 | Die Sicherheitszonen gelten pro Benutzer (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Sicherheitszonen: Nur Einstellungen pro Computer verwenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1854.htm


Ausführung aktiver Inhalte auf dem lokalen Computer zulassen (IE)

Beim Aufruf von lokalen HTML-Seiten werden Skripte, ActiveX Elemente und Bilder nicht mehr ausgeführt/angezeigt

Mit diesem Tipp können Sie die Einstellungen:

- "Ausführung aktiver Inhalte von CDs auf dem lokalen Computer zulassen"

- "Ausführung aktiver Inhalte in Dateien auf dem lokalen Computer zulassen"

des Internet Explorers unter "Extras" -> "Internetoptionen" -> Tabreiter "Erweitert" konfigurieren.

Wenn Sie lokale HTML-Seiten ab Windows XP mit Service Pack 2 aufrufen wollen, wird Ihnen bei der Ausführung von Skripten und ActiveX Elementen und bei der Anzeige von Bildern eine Sicherheitswarnung angezeigt. Sie müssen erst eine Ausführungsberechtigung bestätigen. Die Skripte und ActiveX wurden durch die neue Sicherheitsfunktion deaktiviert, um den PC vor bösartigen Angriffen zu schützen. Dazu werden beim Aufruf von lokalen HTML-Seiten diesen Funktionen erst nach einer extra Bestätigung ausgeführt. Anschließend kommt noch die Meldung "Das zulassen aktiver Inhalte, wie z.B. ActiveX-Steuerelemente und Skripts, kann nützlich sein, jedoch können aktive Inhalte auf dem Computer Schaden anrichten. Diese Meldung müssen Sie dann noch mal extra bestätigen.

Wenn Sie diese Funktion nicht wünschen, können Sie das über die Registry ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

für "Ausführung aktiver Inhalte in Dateien auf dem lokalen Computer zulassen":

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main\ FeatureControl\ FEATURE_LOCALMACHINE_LOCKDOWN

ändern Sie hier den Wert "iexplore.exe" als Datentyp REG_DWORD und setzen Sie den Wert auf (siehe Tabelle unten):

0 | Ausführung aktiver Inhalte zulassen
1 | Ausführung aktiver Inhalte nicht zulassen

Unter diesem Schlüssel finden Sie diese Einschränkung noch für die Anwendungen:

explorer.exe | Windows Explorer
msimn.exe |
wmplayer.exe |

für "Ausführung aktiver Inhalte von CDs auf dem lokalen Computer zulassen":

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main\ FeatureControl\ FEATURE_LOCALMACHINE_LOCKDOWN\ Settings

ändern Sie hier den Wert "LOCKMACHINE_CD_UNLOCK" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Ausführung aktiver Inhalte zulassen
0 | Ausführung aktiver Inhalte nicht zulassen

Info Siehe dazu auch Tipp: "Internet Explorer: Einstellung "Ausführen aktiver Inhalte von CDs auf dem lokalen Computer zulassen" konfigurieren"

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=878461

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2061.htm


URLs mit dem Aufbau http[s]://User:Passwort@domain im IE erlauben

MS hat mit dem Sicherheitsupdate 834489 die Verwendung der Syntax http[s]://User:Passwort@www.xxxx.com unterbunden. Wird diese Syntax dennoch benutzt, kommt die Meldung: "Fehler: ungültige Syntax"

Mit dem folgenden Tipp können Sie diese Syntax wieder erlauben.

Info Microsoft Knowledge Base Article - 834489:
http://support.microsoft.com/default.aspx?scid=KB;[LN];834489

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Internet Explorer\ Main\ FeatureControl\ FEATURE_HTTP_USERNAME_PASSWORD_DISABLE

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Internet Explorer\ Main\ FeatureControl\ FEATURE_HTTP_USERNAME_PASSWORD_DISABLE

Erstellen Sie hier einen neuen Wert mit dem Namen "iexplore.exe" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Passwort URLs erlauben
1 | Passwort URLs nicht erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2110.htm


Digitale Signatur von Controls im IE überprüfen

Mit diesem Tipp können Sie einstellen, ob nur Control mit einer digitalen Signatur zugelassen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Download

ändern Sie hier den Wert "CheckExeSignatures" als Datentyp REG_DWORD und setzen den Wert auf:

YES | Digitale Signatur ist erforderlich
NO | Digitale Signatur ist nicht erforderlich

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2123.htm


Installation von Controls mit ungültiger oder fehlerhafter Signatur unterbinden

Installation von Controls im IE mit ungültiger oder fehlerhafter Signatur unterbinden

Mit den folgenden Tipp können Sie einstellen, ob der Internet Explorer standardmässig die Installation von Control unterbindet, die eine ungültige oder fehlerhafte digitale Signatur besitzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Download

ändern Sie hier den Wert "RunInvalidSignatures" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ungültige Signaturen nicht zulassen
1 | Ungültige Signaturen zulassen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2124.htm


'Phishing Filter' des Internet Explorers konfigurieren

"Phishing Filter" des IE konfigurieren mit Blacklist

Ab IE7.x hat MS einen "Phishing Filter" eingebaut. Dabei überprüft der IE die URL anhand einer sog. Blacklist, ob es sich um eine gefährliche URL handelt. Diese Blacklist wird von Microsoft gepflegt.

Dieser Filter kann folgendermaßen konfiguriert werden:

Ausgeschaltet | Der Filter ist nicht aktiv,. Es kann vom Anwender keine manuelle Überprüfung aufgerufen werden.
Manuell | Der Anwender kann eine Seite überprüfen lassen.
Automatisch | Jede Seite wird automatisch überprüft.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ PhishingFilter

ändern Sie hier den Wert "Enabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ausgeschaltet
1 | Manuell
2 | Automatisch

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2125.htm


Passwort im IE beim Inhaltsratgeber zurücksetzen

Hat man im Inhaltsratgeber vom Internetexplorer Einstellungen vorgenommen, musste ein Supervisorpasswort hinterlegt werden. Die Filter helfen bei der Kontrolle der Inhalte, die auf dem Computer angezeigt werden können. Zu finden unter "Extras" -> "Internetoptionen" -> Tabreiter "Inhalte" -> hier unter Inhaltratsgeber auf den Button "Aktivieren..". Jetzt öffnet sich ein neuer Dialog "Inhaltsratgeber" wo Sie die entsprechenden Einstellungen durchführen können. Hier können Sie dann auch unter "Allgemein" ein Supervisorkennwort hinterlegen.

Dieses Kennwort wird verschlüsselt in der Registry gespeichert.

Wenn Sie das Kennwort vergessen haben und Einstellungen ändern wollen, müssen Sie folgenden Schlüssel löschen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Ratings

Anschließend können Sie ohne ein Passwort die Einstellungen wieder verändern.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2150.htm


Internet Explorer: Ausführen von Browsererweiterungen anderer Hersteller zulassen

Mit diesem Tipp legen Sie fest, ob fremde Browsererweiterungen (COM-Add-Ons) von anderen Anbietern in den Internet Explorer eingebunden werden können. Diese Browsererweiterungen stellen z.B. zusätzliche Symbolleisten zur Verfügung.

Wenn Sie den Tipp aktivieren, werde alle installieren Browsererweiterungen ausgeführt, wenn Sie den Tipp deaktivieren, werden keine fremden Browsererweiterungen gestartet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Enable Browser Extensions" als Datentyp REG_SZ. Setzen Sie den Wert auf:

YES | Browsererweiterungen ausführen
NO | Keine fremden Browsererweiterungen ausführen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Browsererweiterungen von Drittanbietern zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2267.htm


Internet Explorer: Sicherheitseinstellungen exportieren/importieren

Im Internet Explorer können Sie Listen für "Vertrauenswürdige" und "Eingeschränkte Sites" pflegen. Wenn Sie Ihren Rechner aber neu installieren oder auf einen anderen Rechner arbeiten, müssen Sie diese Daten neu eingeben. Gerade wenn es sich um viele Einträge handelt, kann das sehr aufwendig sein.

Diese Einstellungen werden vom Internet Explorer in der Registry gespeichert und können über Regedit.exe in eine REG-Datei exportiert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ ZoneMap\ Domains

(enthält die Liste der zu den Zonen hinzugefügten Webseiten sowie)

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Zones

(enthält die Liste der vorhandenen Zonen)

markieren Sie den Schlüsselnamen "Domains" bzw. "Zones" und wählen aus dem Menü "Datei" den Eintrag "Exportieren..." aus. Die gespeicherte REG-Datei können Sie jetzt auf einen anderen Rechner wieder importieren (Doppelklick im Explorer auf die Datei).

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:

http://support.Microsoft.com/?kbid=301689

http://support.Microsoft.com/?kbid=182569

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2580.htm


Internet Explorer: ActiveX Programm Installation deaktivieren

Mit diesem Tipp können Sie einstellen, dass über ActiveX keine Programme mehr im Internet Explorer installiert werden können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Zones\ 3

erstellen Sie einen neuen Wert mit dem Namen "1001" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Installationsabfrage ist aktiv
3 | Installation ist deaktiviert

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2592.htm


Internet Explorer: Download immer bestätigen

bis IE 6

Wenn Sie Dateien mit dem Internet Explorer runterladen, wird eine entsprechende Bestätigung von Ihnen angefordert. Diese Bestätigung können Sie über das Kontrollkästchen "Vor dem Öffnen dieses Dateityps immer bestätigen" deaktivieren. Anschließend wird keine Bestätigung mehr für die meisten Dateitypen verlangt.

Mit diesem Tipp können Sie das Kontrollkästchen entfernen und der Anwender muss immer den Download von Dateien bestätigen. Von dieser Bestätigung sind aber die folgenden Dateitypen ausgeschlossen:

  • .htm
  • .html
  • .jpg
  • .bmp
  • .gif
  • .xml
  • .txt

Wenn Sie den Eintrag "AlwaysPromptWhenDownload" aktivieren (Festlegung auf "1"), muss der Download immer vorab bestätigt werden und kann nicht von Anwender ausgeschaltet werden.

Wenn Sie diese Einstellung deaktivieren (Festlegung auf "0"), kann die extra Bestätigung vom Anwender ausgeschaltet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "AlwaysPromptWhenDownload" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Die Bestätigung von sämtlichen Dateitypen kann ausgeschaltet werden (Standard)
1 | Der Download von Dateien, muss vorher bestätigt werden und kann nicht deaktiviert werden

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=238723

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2670.htm


Linkvorschlag der Adresszeile abschalten

Bei der URL-Eingabe in der Adresszeile bietet der Internet-Explorer (ab Version 5) sog. Linkvorschläge an, die bereits schon einmal "angesurft" wurden. Dadurch werden Übereinstimmungen mit früheren Eingaben angezeigt, um die Eingabe entsprechend zu beschleunigen.

Die Funktion kann über den Internet Explorer unter dem Menü "Extras" -> "Internetoptionen..." -> Tabreiter: "Inhalte" -> Button: "AutoVervollständigen..." unter dem Abschnitt "AutoVervollständigen verwenden für" über den Eintrag "Webadressen" konfiguriert werden.

Dabei wird folgender Registrywert verändert:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoComplete

erstellen Sie einen neuen Eintrag mit dem Namen "AutoSuggest" als Datentyp REG_SZ. Setzen Sie den Wert auf:

no | Autovervollständigung ist deaktiv und die Eingaben werden nicht im Verlauf gespeichert
yes | Autovervollständigung ist aktiv (Standard)

Info Weitere Infos dazu finden Sie auch im Tipp: "Autovervollständigung für Kennwörter deaktivieren" oder "Autovervollständigung für Formulare deaktivieren"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1026.htm


Standard Suchmaschine des Explorers ändern

Viele Leute haben eine Internet-Suchmaschine, die sie am liebsten benutzen. Da möchte man dann auch gern den Button im Internet Explorer mit dieser Suchmaschine belegen und nicht den Standard von MS verwenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKCU = HKEY_CURRENT_USER

HKLM = HKEY_LOCAL_MACHINE

Suchserver: Microsoft |  |
Schlüssel | Wert | Eintrag
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Page | http://home.microsoft.com/access/allinone.asp
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Bar | http://home.microsoft.com/search/lobby/search.asp
HKCU\ Software\ Microsoft\ Internet Explorer\ SearchURL | (Standard) | http://home.microsoft.com/access/autosearch.asp?p=%s
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | SearchAssistant | http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchasst.htm
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | CustomizeSearch | http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchcust.htm
Suchserver: Yahoo |  |
Schlüssel | Wert | Eintrag
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Page | http://de.yahoo.com/
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Bar | http://de.docs.yahoo.com/search/ie5.html
HKCU\ Software\ Microsoft\ Internet Explorer\ SearchURL | (Standard) |
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | SearchAssistant | http://de.docs.yahoo.com/search/ie5.html
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | CustomizeSearch | http://de.docs.yahoo.com/search/ie5opt.html
Suchserver: Google |  |
Schlüssel | Wert | Eintrag
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Page | http://www.google.com
HKCU\ Software\ Microsoft\ Internet Explorer\ Main | Search Bar | http://www.google.com/ie
HKCU\ Software\ Microsoft\ Internet Explorer\ SearchURL | (Standard) | http://www.google.com/keyword/%s
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | SearchAssistant | http://www.google.com/ie
HKLM\ Software\ Microsoft\ Internet Explorer\ Search | CustomizeSearch |

Info Siehe auch: "Auswahl der Suchmaschinenliste im IE erweitern".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1042.htm


Programm zum Betrachten des Quellcodes von Internet Seiten festlegen

Standardmäßig benutzt der Internet Explorer für das Anzeigen des Quellcodes von Internet Seiten (IE -> MENÜ "Ansicht" -> "Quelltext anzeigen") das Programm Notepad. Wenn Sie sich aber öfter den Quellcode von Internet Seiten ansehen und einen anderen Editor/Viewer verwenden möchten, können Sie das in der Registry einstellen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ View Source Editor\ Editor Name

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ View Source Editor\ Editor Name

(die Schlüssel "View Source Editor" und "Editor Name" sind meist nicht vorhanden und müssen erstellt werden).

Geben Sie hier nun unter "(Standard)" den Pfad und den Namen des Editors an, den Sie verwenden möchten.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1191.htm


Importieren und Exportieren von Favoriten, Cookies

Wer öfters an verschiedenen Rechnern arbeitet und seine Favoriten und Cookies immer gerne mitnehmen möchte, wird eine unbekannte Funktion im IE nicht mehr missen möchten: Über "DATEI" -> "Importieren" und "Exportieren" lassen sich die Favoriten und Cookies platzsparend speichern und auf anderen Rechnern wieder einlesen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0965.htm


Keine Nachfrage beim Download von Dateien

Wenn der IE beim Download nicht nachfragt, wohin die Datei gespeichert werden soll, muss man den entsprechenden Dateityp (z.B. rar) im Windows-Explorer unter "Ansicht" -> "Ordneroptionen" -> Dateitypen suchen und bei den Eigenschaften "Öffnen nach dem Download bestätigen" aktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0969.htm


"In einem neuen Prozess browsen" aktivieren

Bis zur Version 5.0 des Internet Explorers gab es die Option "In einem neuen Prozess browsen". War sie aktiviert, lief jedes geöffnete IE-Fenster in einem eigenen Programm-Task. In manchen Fällen konnte das verhindern, dass ein Browserabsturz das ganze System lahm legte.

Seit Version 5.01 fehlt diese Einstellung. Der Internet Explorer trifft nun selber die Entscheidung, ob ein neuer Task gestartet werden soll. Kriterium hierfür ist die Größe des vorhandenen Arbeitsspeichers: Bei weniger als 32 MB wird diese Funktion automatisch abgeschaltet. Sind mehr als 32 MB vorhanden, startet der IE einen neuen Task. Diese automatische Speichererkennung funktioniert allerdings nicht immer.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ BrowseNewProcess

kann man dies prüfen.

Bei mehr als 32 MB RAM sollte der Eintrag "BrowseNewProcess" als Datentyp REG_SZ auf "yes" gesetzt sein. Trifft dies nicht zu ("no"), tragen Sie nach Doppelklick auf "BrowseNewProcess" das "yes" manuell ein.

Sie können das unter folgendem Schlüssel auch für jeden Anwender einstellen:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ BrowseNewProcess

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=240928

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0970.htm


Keine Nachfrage zum Trennen der Verbindung beim Beenden des IE4

Sollte nach dem Beenden des IE keine Nachfrage erscheinen, ob die Verbindung getrennt werden soll, wurde die Registry verändert, oder ein im Hintergrund laufendes Programm hat (heimlich) eine Verbindung aufgebaut und verhindert somit das automatische Trennen (siehe "Probleme mit dem IE möglicherweise durch Werberoboter").

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

den Wert "EnableAutoDisconnect" als Datentyp REG_BINARY auf 01 00 00 00 setzen

HKEY_CURRENT_USER\ RemoteAccess\ Profile\ [Profilname]

den Wert "EnableAutoDisconnect" als Datentyp REG_DWORD auf 1 setzen und den Wert "EnableExitDisconnect" als Datentyp REG_DWORD auf 1 setzen

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=193555

Allerdings kann auch die Autostart-Funktion des Easy-CD-Creator 4 hierfür verantwortlich sein. Für diesen Fall sollte man die Autostart-Funktion des Easy-CD Creators unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

mittels MSCONFIG (Windows 98, Windows ME) deaktivieren.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.microsoft.com/?kbid=256302

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0703.htm


IE5-FTP Erweiterung loswerden

Die neue FTP-Erweiterung des IE5 kann man auch deaktivieren und die gewohnte Darstellung von FTP-Servern erzwingen, indem man die Datei Msieftp.dll umbennent (msieftp.dll_org).

Greift man danach auf eine FTP-Seite zu, stellt IE die Frage, ob diese Datei übertragen werden soll. Hier wählt man "nein" und aktiviert den Button "niemals eine dieser Komponenten übertragen".

Info Diese Datei wird vom IE auch für den Reparaturmodus benötigt, der danach dann nicht mehr geht. Sie sollten sich die Datei deshalb aufheben.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0589.htm


Auswahl der Suchmaschinenliste im IE erweitern

In der Internet Explorer Version 5.x wurde die Auswahl der möglichen Suchmaschinen stark eingeschränkt. So wurden in der deutschen Version alle englischen Suchmaschinen entfernt. Wenn Sie auch wieder englische Suchmaschinen angezeigt bekommen wollen, müssen Sie folgende Änderung in der Registry vornehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Search

Finden Sie die Werte "CustomizeSearch" und "SearchAssistant". Ändern Sie in diesen Einträgen den Teilstring "{SUB_RFC1766}" in "en-us" ab und schon werden Ihnen über den Suchen-Button auch die englischen Suchmaschinen angezeigt.

Die beiden Einträge sollten dann so aussehen:

CustomizeSearch = http://ie.search.msn.com/en-us/srchasst/srchcust.htm

SearchAssistant = http://ie.search.msn.com/en-us/srchasst/srchasst.htm

Info Siehe auch: "Standard Suchmaschine des Explorers ändern".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0530.htm


Internet Explorer ohne Cache benutzen

Standardmäßig legt der Internet Explorer einen Cache an, um einmal geladene Internetseiten schneller wieder anzeigen zu können. Bei Internetseiten mit gesicherten Inhalten, die über ein Passwort freigeschaltet werden müssen, kann das zu einer Sicherheitslücke führen, da sich andere Leute diesen Cache anzeigen lassen können und somit ohne Eingabe das Passwortes den Inhalt sehen können.

Durch einen Eintrag in der Registry können Sie verhindern, dass der Internet Explorer Dateien im Cache anlegt. Gehen Sie dazu folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ Cache\ Content

legen Sie hier einen neuen Eintrag mit dem Namen "Cachelimit" als Datentyp REG_BINARY an. Setzen Sie den Wert auf '0'.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0447.htm


IE Download auf Festplatte

Der komplette Internet Explorer für das aktuelle Betriebssystem lässt sich für eine spätere Installation speichern, indem man die Datei ie5setup.exe startet, die zweite Option "Minimal installieren oder Browser anpassen" selektiert und bei der Komponentenauswahl auf 'Erweitert' klickt. Hier wählt man "Nur Download" und kann dann das Speicherverzeichnis angeben. Allerdings ist die heruntergeladene Version nur mit dem aktuellen Betriebssystem kompatibel. Wer auch eine Vollversion für andere Betriebssysteme herunterladen möchte, muss etwas tricksen:

IE 5.x

Man startet über "DATEI" -> "Ausführen" die Datei ie5setup.exe und übergibt noch folgende Parameter:

/c:"ie5wzd.exe /d /s:""#E" (konkret also z.B. d:\download\ie5setup.exe /c:"ie5wzd.exe /d /s:""#E")

IE 6.x

Man startet über "DATEI" -> "Ausführen" die Datei ie6setup.exe und übergibt noch folgende Parameter:

/c:"ie6wzd.exe /d /s:""#E" (konkret also z.B. d:\download\ie6setup.exe /c:"ie6wzd.exe /d /s:""#E")

Dann erscheint eine Auswahlbox, bei der man das Betriebssystem auswählen kann. Die komplette Version wird dann auf den Rechner geladen. Wenn Sie den Schalter "/d:1" verwenden, werden die Dateien für alle Betriebssysteme heruntergeladen.

Info Umfangreiche Tipps und Tricks zum Internet Explorer finden Sie unter http://www.misitio.ch

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0896.htm


Internet-Adressen automatisch ergänzen

Der IE verfügt bereits über eine Autocomplete- Funktion eingegebener URLs. Die Eingabe von http://www. kann man sich aber sparen, da der IE4 dies bei Eingabe von z.B. Microsoft und STRG+ENTER automatisch ergänzt.

Allerdings funktioniert dies nicht bei de-Domains.

Drückt man nach der Eingabe nur ENTER, sucht der IE4 verschiedene Variationen in dieser Folge im Netz:

Microsoft

1a) www.Microsoft.com

1b) www.Microsoft.edu

1c) www.Microsoft.org

2a) Microsoft.com

2b) Microsoft.edu

2c) Microsoft.org

Um den Namenserver des Providers zu entlasten und Wartezeiten zu verkürzen, sollte auf die 2. Option verzichtet werden. Gängig ist eh die www URL, welche man bei deutschen Domains um "de" ergänzt. Zudem kann die o.a. Reihenfolge mit einer Änderung der Registry geändert werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Main\ UrlTemplate

sehen Sie die Ergänzungen der Domainmöglichkeiten. Diese können in den Schlüsseln geändert werden, wobei %s für die Eingabe im URL-Feld steht. Die Zahl des Schlüssels gibt dabei die Reihenfolge an, in welcher gesucht wird. Sinnvollerweise sollte man den www.%s.com als ersten und www.%s.deals 2. Suchfolge umstellen (durch org ersetzen)

Wollen Sie nun Ergänzungen auch für deutsche Seiten haben, suchen Sie die letzte Nummer, legen Sie einen neuen Schlüssel mit der nächsten freien Nummer an und weisen ihm als Wert "www.%s.de" zu. Wenn Sie die Nummern von "www.%s.com" nun noch mit Ihrem Eintrag vertauschen, wird immer als erstes nach deutschen Seiten gesucht.

Info %s steht als Platzhalter und wird automatisch durch den eingegebenen Text im Explorer ersetzt.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0428.htm


FTP Modus des IE konfigurieren

Mit dem folgenden Eintrag in der Registry können Sie den FTP-Modus des IE konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Ftp

erstellen Sie einen neuen Eintrag mit dem Namen Use Web Based FTP als Datentyp REG_SZ und setzen den Wert auf YES, um die Funktion zu aktivieren bzw. auf NO für den Standard.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1231.htm


Automatische Überprüfung auf Updates unterbinden

Windows überprüft automatisch, ob neue Updates für den Internet Explorer verfügbar sind. Wenn Sie diese Funktion nicht wünschen, können Sie diese Funktion mit folgendem Eintrag deaktivieren.

Wenn Sie den nicht Tipp aktivieren, sucht Windows ca alle 30 Tage im Internet nach Updates für den Internet Explorer ab. Sobald ein Update verfügbar ist, werden Sie aufgefordert das Update zu installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

oder als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "NoUpdateCheck" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es wird nicht nach Updates gesucht
0 | Etwas alle 30 Tage nach Updates nachschauen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung\Seite "Erweitert"
Einstellungsname: | Automatische Überprüfung auf Updates von Internet Explorer

Info Siehe auch Tipp: "Automatische Überprüfung auf Software-Updates unterbinden"

Info Diese Einstellung wird nicht mehr von Windows Vista unterstützt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1482.htm


Gleichzeitige Verbindungen zu einem Server mit dem IE erhöhen

Die Spezifikationen von Microsoft zu HTTP 1.1 sehen vor, dass der Internet Explorer nur 2 gleichzeitige Verbindungen zu einem Server herstellt. HTTP 1.0 erlaubte noch 4 gleichzeitige Verbindungen. Dies geschieht z.B. beim Laden einer Seite incl. der Grafiken etc.

Weiteres hierzu unter:

http://support.microsoft.com/?kbid=183110

und

http://support.microsoft.com/?kbid=282402

Man kann den Wert aber erhöhen. Downloads profitieren von einer Erhöhung nicht (einzelne Downloads werden nicht beschleunigt, Sie können aber mehr Downloads gleichzeitig starten), sehr wohl aber "Normales" Surfen, da mehrere Anfragen auf einmal an den Server gesendet werden. Standardmäßig verwendet der IE zwei Streams bei HTTP 1.1.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für Windows 2000

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Hier sind die Einträge zu finden.

MaxConnectionsPerServer für HTTP 1.1

und

MaxConnectionsPer1_0Server für HTTP 1.0

Falls nicht, erstellt man sie als neuen Eintrag als Datentyp REG_DWORD.

Beiden Keys kann man jetzt einen höheren Wert zuweisen, wobei der Standard für HTTP1.1 zwei Verbindungen und für HTTP1.0 vier Verbindungen ist (4 bis 8 hat sich bisher bewährt).

Für Windows 9x

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

erstellt man als Datentyp REG_DWORD den Eintrag für HTTP 1.1

MaxConnectionsPerServer

und gibt diesem einen höheren Wert (Standard ist 2).

Danach erstellt man einen weiteren Eintrag als Datentyp REG_DWORD für HTTP 1.0

MaxConnectionsPer1_0Server

und gibt diesem ebenfalls einen höheren Wert (Standard ist 4).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0485.htm


Internet Explorer im extra Speicherbereich starten

Standardmäßig wird der Internet Explorer 4.0 im gleichen Speicherbereich wie der Explorer geöffnet. Dadurch startet der IE zwar etwas schneller, aber bei einem Absturz des IE wird auch meist der Explorer mit beendet. Da der Explorer der Hauptteil des Systems ist, bedeutet das wiederum, dass Ihr ganzes System auch mit heruntergezogen wird.

Wenn Sie den IE in einem extra Speicherbereich starten wollen gehen Sie so vor:

Starten Sie den IE und gehen Sie über "Ansicht" -> "Internetoptionen" -> "Erweitert" dort kreuzen Sie unter "Browsing" den Punkt "In einem neuen Prozess browsen".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0158.htm


Automatisches Vervollständigen der Eingabe unterbinden

Mit dieser Funktion können Sie einstellen, ob Windows im Explorer automatisch beim Eingeben einer URL diese um bekannte Eingaben ergänzen soll oder die entsprechenden Adressen nur in einer Drop-Down-Box anzeigt, wo erst durch Auswahl der entsprechenden URL die Eingabe vervollständigt wird.

Sie können die Funktion im Explorer über das Menü "Extras" -> "Internetoptionen" unter dem Register "Erweitert" durch Setzen der Funktion "Verwenden von AutoVervollständigen im Windows Explorer" oder "Verwenden von AutoVervollständigen für Webadressen" aktivieren - in der Registry ändern Sie folgende Werte:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ AutoComplete

Für den Internet Explorer:

Erstellen Sie einen neuen Eintrag mit dem Namen "Append Completion" als Datentyp REG_SZ.

Setzen Sie den Wert auf YES bzw. zum Deaktivieren wieder auf NO.

Der Standardwert ist NO für die Autovervollständigung im Internet Explorer.

Für den Windows Explorer:

Für die Autovervollständigung der Webadressen erstellen Sie einen neuen Eintrag mit dem Namen "Use AutoComplete" als Datentyp REG_SZ. Setzen Sie diesen Wert auf YES bzw. auf NO um die Funktion zu deaktivieren. Der Standardwert ist auch hier NO.

Info Siehe auch Tipp: "Linkvorschlag der Adresszeile abschalten"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1177.htm


IE6-Download auf Festplatte speichern

Wenn Sie den Internet Explorer von der Microsoft-Seite herunterladen, wird der IE gleich installiert. Sie haben keine Möglichkeit, die Version später noch einmal zu installieren oder für andere Rechner zu verwenden.

Um den Download auf Festplatte zu speichern, gehen Sie folgendermaßen vor:

  1. Laden Sie die Datei ie6setup.exe herunter
  2. Führen Sie diese Datei nun mit folgenden Parametern aus:
    ie6setup.exe /c:"ie6wzd.exe /d /s:""#E"
  3. Jetzt erscheint ein Menü, in welchem Sie einstellen können, was Sie herunterladen wollen und wo die Dateien gespeichert werden sollen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1286.htm


Kleiner Spass im Internet Exporer

Kleiner Spass im Internet Explorer

Wenn man im Internet Explorer "about:Mozilla" als URL eingibt, erscheint eine Art pseudo bluescreen.

Info Nur für den Internet Explorer 6.0

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1588.htm


HTML-Quellcode Check im IE ausschalten

Der Internet Explorer versucht zuerst zu ermitteln, mit welchem Programm HTML-Dateien normalerweise erstellt wurden und modifiziert dann die Edit-Optionen. Dadurch werden HTML-Dateien oft mit einem anderen Editor geöffnet als erwünscht. Wenn Sie diese Funktion nicht wünschen, können Sie das hier abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "CheckDocumentForProgID" als Datentyp REG_SZ. Setzen Sie den Wert auf:

NO | Quellcode Check ausschalten
YES | Quellcode Check einschalten (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1621.htm


Automatisches Internet Explorer Proxy Caching ausschalten

Der Internet Explorer speichert die Informationen des Proxy-Servers und verwendet diese Information, um wieder auf die Seiten zurückzugreifen. Wenn der entsprechende Proxyserver ausfällt, kann es deshalb zu einer Fehlermeldung kommen und die Seite wird nicht angezeigt, obwohl die Seite über einen anderen Proxyserver noch angesprochen werden kann. Wenn Sie diese Funktion aktivieren, ermittelt der Browser den aktuellen Proxyserver immer wieder neu.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableAutoProxyResultCache" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Caching ausschalten
1 | Caching aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Zwischenspeichern von Autoproxy-Skripts deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1626.htm


Proxy Konfiguration des Internet Explorer einstellen

Mit diesem Tipp können Sie die Proxyeinstellungen des Internet Explorers konfigurieren. Wenn Sie den Proxy-Server aktivieren, müssen Sie einen Proxy-Server angeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "ProxyEnable" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Proxy aktivieren
0 | Proxy deaktiviert (Standard)

Erstellen Sie hier einen neuen Wert mit dem Namen "ProxyServer" als Datentyp REG_SZ. Geben Sie hier den Proxyserver an im Format: <IP>:<Port> z.B.: 192.0.0.1:5555

Konfiguration in Netzwerken

Für die Konfiguration der Proxyeinstellungen in Netzwerken ist die Option eine automatische Proxykonfiguration über ein Skript vorzunehmen. Dafür muss einfach nur ein Eintrag "AutoConfigURL" als Datentyp REG_SZ, mit dem Pfadnamen (z.B. http://Server/Pfad also "http://192.168.1.22/proxy.pac") gemacht werden. Der verweist auf eine "proxy.pac" die auf einem zentralen Server liegt.

Vorteil, nur diese proxyconf.pac muss editiert werden um allen PC neu Proxyinformationen zu liefern.

Eine PAC-Datei ist eine Textdatei, die eine JavaScript-Funktion definiert: FindProxyForURL(url, host). Standardmäßig heißt sie proxy.pac.

Ein einfacher Aufbau der Datei wäre:

function FindProxyForURL(url, host) { return "PROXY proxy.winfaq.de:8080; DIRECT"; }

Diese Funktion weist den Browser an, alle Seitenanfragen an den Proxy auf Port 8080 des Servers proxy.winfaq.de zu leiten. Sollte dies fehlschlagen, so wird eine direkte Verbindung ins WWW aufgebaut.

Weitere Infos zum Aufbau der .PAC-Datei finden Sie unter: http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1629.htm


Startseite des Internet Explorers einstellen

Mit diesem Tipp können Sie die Startseite des Internet Explorers festlegen. Wenn Sie auf den Button "Default" klicken, wird die Startseite auf "about:blank" gesetzt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "Start Page" als Datentyp REG_SZ und geben Sie die gewünschte Startseite ein. Wenn Sie ein leeres Fenster öffnen wollen, geben Sie hier als Startseite "about:blank" ein.

Die Startseite kann auch noch über "Default_Page_URL" festgelegt werden. Erstellen Sie dafür einen neuen Eintrag mit dem Namen "Default_Page_URL" als Datentyp REG_SZ an und geben Sie die gewünschte Seite ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1747.htm


Default Verzeichnis für IE-Download

Wenn man im IE beim Speichern eines Downloads mit Rechtsklick "Speichern unter" wählt, kann man ein Verzeichnis auswählen. Dieses Verzeichnis merkt sich der IE und benutzt beim nächsten Speichern den selben Pfad. Dieser Pfad wird in der Registry gespeichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "Download Directory" als Datentyp REG_SZ und geben Sie den gewünschten Pfad ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1748.htm


Automatische Suche von DFÜ-Einstellungen verwenden

Mit diesem Tipp können Sie die automatische Erkennung für die Konfiguration von DFÜ-Einstellungen aktivieren. Die Automatische- Erkennung verwendet einen DHCP oder DNS-Server.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "DialupAutodetect" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Automatische Suche von DFÜ-Einstellungen verwenden
0 | Automatische Suche von DFÜ-Einstellungen nicht verwenden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Automatische Suche von DFÜ-Einstellungen verwenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1832.htm


Automatische Überprüfung auf Software-Updates unterbinden

Der Browser überprüft automatisch, ob neue Updates verfügbar sind.

Wenn Sie diese Funktion nicht wünschen, können Sie diese mit folgendem Eintrag deaktivieren. Wenn Sie die Funktion nicht deaktivieren, wird standardmäßig alle 30 Tage überprüft, ob eine neue Version verfügbar ist.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Infodelivery\ Restrictions

Erstellen Sie hier einen neuen Wert mit dem Namen "NoUpdateCheck" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | deaktiv
0 | aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Periodische Überprüfung auf Internet Explorer-Softwareupdates deaktivieren

Info Siehe auch Tipp: "Automatische Überprüfung auf Updates unterbinden"

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1850.htm


Proxyeinstellungen pro Computer setzen

Mit diesem Wert können Sie einstellen, dass die Anwender keine eigenen Proxyeinstellungen für den Internet Explorer einstellen können. Damit werden für alle Anwender die selben Proxyeinstellungen verwendet

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "ProxySettingsPerUser" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Proyeinstellungen pro Computer
1 | Proxyeinstellungen pro User (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Proxyeinstellungen pro Computer vornehmen (anstelle von pro Benutzer)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1851.htm


Benachrichtigung über neu installierte Komponenten deaktivieren

Wenn Sie diese Einstellung aktivieren, wird dem Benutzer keine Benachrichtigung über neu installierte Komponenten mehr angezeigt, die über Microsoft Software Distribution Channel installiert wurden. Ist dieser Tipp nicht aktiv, werden die Benutzer vorher über die Aktualisierung von Programmen benachrichtigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoMSAppLogo5ChannelNotify" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Keine Benachrichtigung anzeigen
0 | Benachrichtigung anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Softwareupdate-Benachrichtigungen beim Programmstart deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1855.htm


Automatisches Umwandeln von Backslash in Slash

Mit diesem Tipp können Sie einstellen, dass der Internet Explorer automatisch Backslash in Slash umwandelt. Dadurch wird die Eingabe http:\\ automatisch in http:// umgewandelt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion \Explorer\ Band\ Address

ändern Sie hier den Wert "AutoCorrect" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Autoumwandlung ausschalten
1 | Autoumwandlung aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2069.htm


Hintergrundbilder und -farben im Internet Explorer mit drucken

Hintergrundbilder und -farben im IE mit drucken

Mit diesem Tipp können Sie einstellen, dass Hintergrundbilder und -farben im Internet Explorer mit gedruckt werden. Beim Drucken von Tabellen ist das bei farbigen Kopfzeilen von Vorteil.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "Print_Background" als Datentyp REG_SZ und setzen den Wert auf:

YES | Hintergrund mitdrucken
NO | Hintergrund nicht mitdrucken (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2111.htm


Verknüpfungen im gleichen Fenster öffnen

Mit diesem Tipp können Sie einstellen, dass Verknüpfungen immer im gleichen Fenster geöffnet werden oder dass der IE bei einem Klick auf eine Verknüpfung automatisch ein neues Fenster öffnet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

ändern Sie hier den Wert "AllowWindowReuse" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Verknüpfungen im gleichen Fenster öffnen
1 | Verknüpfungen im extra gleichen Fenster öffnen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2116.htm


Temporäre Dateien beim Beenden löschen vom IE löschen

Temporäre Dateien des IE beim Beenden löschen

Mit diesem Tipp können Sie einstellen, dass die Temporären Dateien beim Beenden des Internet Explorers gelöscht werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion \Internet Settings\ Cache

ändern Sie hier den Wert "Persistent" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Cache beim beenden des IE löschen
1 | Cache beim beenden des IE nicht löschen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2126.htm


Suche in der MS-Knowledge-Base als Shortcut im Internet Explorer einrichten

Suche in der MS-Knowledge-Base als Shortcut im IE einrichten

Dieser Tipp fügt einen Shortcut für die Suche in der MS-Knowledge-Base hinzu.

Für die Suche ist dann in der Linkzeile des Internet Explorers folgendes einzugeben.

Suche in der Deutschen Knowledgebase:

KBD <Suchbegriff>

Suche in der Englischen Knowledgebase:

KBE <Suchbegriff>

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Deutsche Knowledgebase:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Internet Explorer\SearchUrl\KBD

ändern Sie hier den Wert "(Standard)" als Datentyp REG_SZ die URL: "http://support.microsoft.com/search/default.aspx?qu=%s&catalog=LCID%%3D1031"

Englische Knowledgebase:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Internet Explorer\SearchUrl\KBE

ändern Sie hier den Wert "(Standard)" als Datentyp REG_SZ die URL: "http://support.microsoft.com/search/default.aspx?qu=%s&catalog=LCID%%3D1033"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2129.htm


Internet Explorer: Automatisches Update auf neuen Internet Explorer verhindern

Wenn Sie die Updatefunktion von Windows aktiviert haben, wird auch automatisch auf eine neue Internet Explorer Version gewechselt, wenn die von Microsoft freigegeben wird, wenn Sie noch den alten Internet Explorer installiert haben. Wenn das nicht gewünscht ist, müssen Sie den folgenden Registrykey setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Update auf Internet Explorer 7 unterbinden

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Setup\ 7.0

Erstellen Sie hier einen neuen Wert mit dem Namen "DoNotAllowIE70" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Update auf IE7 wird nicht automatisch durchgeführt
0 | Update wird durchgeführt(Standard)

Update auf Internet Explorer 8 unterbinden

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Internet Explorer\ Setup\ 8.0

Erstellen Sie hier einen neuen Wert mit dem Namen "DoNotAllowIE80" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Update auf IE8 wird nicht automatisch durchgeführt
0 | Update wird durchgeführt(Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2155.htm


Internet Explorer: Versionsnummer festlegen die gesendet wird

Ab IE 7.0 können Sie mit diesem Tipp die Versionsnummer festlegen, welche vom IE gesendet wird, wenn Sie eine Webseite aufrufen. Einige Webseiten werten diese Nummer aus, um die Seiten entsprechend für den Browser passend anzeigen zu können. Geben Sie hier als Text die Versionsidentifikationen des Browsers ein. Bei IE7: MSIE 7.0

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ User Agent

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ User Agent

Erstellen Sie hier einen neuen Wert mit dem Namen "Version" als Datentyp REG_SZ und geben Sie als Wert die Versionsnummer an.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Zeichenkette des Benutzer-Agents anpassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2206.htm


Internet Explorer: Fenster "Einstellungen anpassen" beim ersten Start nicht anzeigen

Ab IE 7.0 können Sie mit diesem Tipp festlegen, ob beim ersten Start des Internet Explorer das Fenster "Einstellungen anpassen" angezeigt werden soll. In diesem Fenster wird der Benutzer aufgefordert, entsprechende Einstellungen für den Internet Explorer vorzunehmen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableFirstRunCustomize" als Datentyp REG_DWORD und setzen den Wert auf:

0 | "Einstellungen anpassen" anzeigen (Standard)
1 | "Einstellungen anpassen" nicht anzeigen und mit der Startseite starten
2 | "Einstellungen anpassen" nicht anzeigen und mit der Willkommensseite starten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer
Einstellungsname: | Anzeigen von "Einstellungen anpassen" beim ersten Programmstart verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2242.htm


Internet Explorer: "Download beendet" - Nachricht de/aktivieren

Mit diesem Tipp können Sie die Information nach einem durchgeführten Download aus-/einschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

Erstellen Sie hier einen neuen Wert mit dem Namen "NotifyDownloadComplete" als Datentyp REG_SZ und setzen den Wert auf:

no | Keine Nachricht nach Download anzeigen
yes | Nachricht nach Download anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2550.htm


Internet Explorer: Verbindungen mit Unicode URL-Webseiten ermöglichen

Mit diesem Tipp ermöglichen Sie das Aufrufen von Unicode Webseiten, die Multibyte-Zeichen in der Webadresse (URL) verwenden. Ist der Eintrag nicht gesetzt, kann der Internet Explorer keine Verbindung zu diesen Seiten aufbauen. Diese Zeichen kommen oft bei Webseiten mit anderen Sprachen (Japanisch usw.) vor.

Damit diese Webseiten auch aufgerufen werden können, müssen Sie den folgenden Registryeintrag setzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "MBCSServername" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Multibyte-Zeichen in der URL zulassen
1 | Multibyte-Zeichen sind nicht zulässig (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2609.htm


Internet Explorer: Download Verzeichnis für ActiveX Dateien festlegen

Mit diesem Tipp können Sie das Verzeichnis festlegen, in dem ActiveX Dateien beim Download abgelegt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

Erstellen Sie hier einen neuen Wert mit dem Namen "ActiveXCache" als Datentyp REG_SZ, und geben Sie das gewünschte Verzeichnis an.

Zusätzlich müssen Sie noch den folgenden Eintrag anpassen:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Internet Settings\ ActiveX Cache

Erstellen Sie hier einen neuen Wert mit dem Namen "0" als Datentyp REG_SZ und geben das gewünschte Verzeichnis an.

Der Standardwert für das Verzeichnis lautet "\Windows\Downloaded Program Files".

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2607.htm


Internet Explorer: Feed-Funktion deaktivieren

Mit diesem Tipp können Sie einstellen, ob der Internet Explorer als Feed-Reader benutzt werden kann. Wenn Sie den Tipp aktivieren, kann nicht mehr auf die Feedliste im Favoritencenter zugegriffen werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableFeedPane" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

1 | Feed-Funktion deaktivieren
0 | Feed-Funktion aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\RSS-Feeds
Einstellungsname: | Feedliste deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2275.htm


Internet Explorer: Feed-Suche deaktivieren

Mit diesem Tipp können Sie einstellen, ob über den Internet Explorer automatisch auf einer Webseite nach bestehenden Feeds gesucht wird.

Wenn Sie den Tipp aktivieren, wird eine Benachrichtigung über verfügbare Feeds in der Symbolleiste angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Feed Discovery

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Feed Discovery

Erstellen Sie hier einen neuen Wert mit dem Namen "Enabled" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

1 | Feed-Suche deaktivieren
0 | Feed-Suche aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\RSS-Feeds
Einstellungsname: | Feedsuche deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2276.htm


Aktualisierung von Feeds im Hintergrund deaktivieren

Mit diesem Tipp stellen Sie ein, ob die RSS-Feeds im Hintergrund aktualisiert werden sollen. Wenn Sie diesen Tipp aktivieren, wird die Hintergrundsynchronisierung der Feeds deaktiviert, ansonsten können Feeds im Hintergrund synchronisiert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

Erstellen Sie hier einen neuen Wert mit dem Namen "BackgroundSyncStatus" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Aktualisierung von Feeds im Hintergrund deaktivieren
1 | Feeds im Hintergrund aktualisieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\RSS-Feeds
Einstellungsname: | Hintergrundsynchronisierung für Feeds deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2274.htm


Internet Explorer: Hinzufügen und Entfernen von Feeds deaktivieren

Mit diesem Tipp können Sie einstellen, ob neue Feeds abonniert (hinzugefügt) oder abonniert Feeds wieder gelöscht werden können.

Wenn Sie diesen Tipp aktivieren, können keinen Feed abonniert oder abonnierte Feeds gelöscht werden. Es werden die entsprechenden Menüeinträge entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAddRemove" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

1 | Feed-Funktion deaktivieren
0 | Feed-Funktion aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\RSS-Feeds
Einstellungsname: | Hinzufügen und Entfernen von Feeds deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2278.htm


Internet Explorer: Herunterladen von Dateien aus Feeds unterbinden

Mit diesem Tipp können Sie einstellen, ob Dateianhänge in Feeds heruntergeladen werden können. Wenn Sie diesen Tipp aktivieren, können keine Anlagen aus Feeds heruntergeladen werden. Weiterhin kann über die API die Downloadeinstellungen nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Internet Explorer\ Feeds

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableEnclosureDownload" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

1 | Anlagen können aus Feeds nicht heruntergeladen werden
0 | Anlagen können heruntergeladen werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\RSS-Feeds
Einstellungsname: | Herunterladen von Anlagen deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2277.htm


Laden des Netcenter verhindern

Beim Start des Netscape Messenger wird immer auch der Netcenter geladen. Wen dies stört, kann das Verhalten wie folgt abstellen:

Man editiert die Datei prefs.js aus dem Verzeichnis \Programme\ Netscape\ Benutzername\mit einem Texteditor wie Notepad und trägt am Ende der Datei die Zeile user_pref("mailnews.start_page.enabled", false); ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1156.htm


HTML mit Netscape öffnen

Wie kann man erreichen, dass ein HTML-Dokument anstatt mit dem IE mit Netscape geöffnet wird, wenn eine *.htm(l)-Datei im Explorer angeklickt wird?

Die Registry-Einträge der HTML- und HTM-Dateien verweisen intern auf den IE und nicht auf die Dateiendungsliste.

Starten Sie den Registry Editor.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CLASSES_ROOT

für die Endungen.HTM und .HTML sollte der Standardwert "NetscapeMarkup" sein. Also einfach die Endung auswählen und dort den Standardwert Mit diesem Wert "NetscapeMarkup" versehen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0733.htm


Firefox mit niedrigen Rechten (Integrity Level) ausführen

Ab Windows Vista gibt es die sog. "Integrity Level" (siehe Tipp: "Sicherheitsmechanismus "Integrity Level" (IL)"). So wird der Internet Explorer im Level "Low" ausgeführt, damit Viren/Trojanern möglichst wenig Angriffsmöglichkeiten geboten werden.

Wenn Sie mit dem Firefox arbeiten, sollten Sie auch dieses Tool im niedrigen Level "Low" ausführen. Zwar ist der Firefox nicht so stark gefährdet wie der IE, aber je mehr Leute auf diesen Browser umsteigen, um so mehr Angriffe wird es auch über diesen Browser geben.

Um das Integrity Level entsprechend zu ändern gehen Sie folgendermaßen vor:

  • Starten Sie eine Kommandozeilenoberfläche
  • Gehen Sie in das Programmverzeichnis von Firefox (standardmäßig: C:\Programme\Mozilla Firefox)
  • Geben Sie folgenden Befehl ein:
    icacls firefox.exe /setintegritylevel low
  • Damit der Firefox in seinem Verzeichnis schreiben kann, ändern Sie jetzt noch die Berechtigungen auf das Verzeichnis auf "Low":
    icacls <Verzeichnis> /setintegritylevel (oi) (ci) low
    Hier also: icacls "C:\Programe\Mozilla Firefox" /setintegritylevel (oi) (ci) low
  • Weiterhin müssen die Berechtigungen noch auf folgende Verzeichnisse angepasst werden:
    icacls "%Userprofile%\AppData\Local\Mozilla\Firefox" /setintegritylevel (oi) (ci) low
    icacls "%Userprofile%\AppData\Roaming\Mozilla\Firefox" /setintegritylevel (oi) (ci) low
    icacls "%Userprofile%\AppData\Local\Temp" /setintegritylevel (oi) (ci) low

Wenn Sie die Verzeichnisse an eine andere Stelle gelegt haben, müssen Sie die Verzeichnispfade entsprechend anpassen.

Sie können jetzt natürlich Dateien, die Sie herunterladen, nicht mehr in jedes Verzeichnis ablegen. Beim Internet Explorer kann der Anwender seine Downloads auch in andere Verzeichnisse ablegen, dafür gibt es im Internet Explorer einen "Broker-Prozess" (ieuser.exe), welcher im Level "Medium" läuft. Dadurch ist es möglich, einen Download im Internet Explorer auch in anderen Verzeichnissen zu speichern.

Da es einen solchen Prozess für Firefox nicht gibt, sollten Sie dafür ein spezielles Downloadverzeichnis erstellen und hier die Rechte auch auf "Low" setzen mittels:

icacls "D:\Download" /setintegritylevel (oi) (ci) low .

Ein weiterer Nachteil bei Firefox ist, dass jetzt jedesmal, wenn Sie ihn starten, eine Warnmeldung (Sicherheitswarnung) angezeigt wird, die Sie erst bestätigen müssen mit"Ausführen", damit das Firefox gestartet wird.

Mir ist leider noch nicht bekannt, wie man diese Meldung dauerhaft unterbinden kann.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2330.htm


Pipelining Funktion in Firefox aktivieren

In Firefox können Sie auch die Piplining-Funktion aktivieren. Wenn diese Funktion aktiv ist, werden mehrere Elemente einer Webseite gleichzeitig angefordert. Das Pipelining ist ein experimentelles Feature zur Beschleunigung des Seitenaufbaus.

Um zu den Einstellungen zu kommen, starten Sie Firefox und geben Sie als URL "about:config" ein.

Ihnen werden jetzt die erweiterten Funktionen angezeigt. Suchen Sie hier den unten angegeben Wert, dabei können Sie über Filter die Anzeige entsprechend eingrenzen und die Option leichter zu finden.

Filter: http

Typ: boolean

Option: network.http.proxy.pipelining

und

Option: network.http.pipelining

Durch einen Doppelklick auf den Eintrag können Sie die aktuelle Einstellung ändern.

True | Funktion ist aktiv
False | Funktion ist deaktiv (Standard)

Typ: integer

Option: network.http.pipelining.maxrequest

Mit dieser Option können Sie festlegen, wie viele Objekte maximal gleichzeitig abgefordert werden. Durch einen Doppelklick auf den Eintrag können Sie in einer Eingabebox einen neuen Wert eingeben.

0-8 | Mögliche Werte für die Anzahl der gleichzeitigen Objekte
4 | (Standard)

Info Diese Funktion ist Standardmäßig ausgeschaltet, da einige Webserver Pipelining nicht unterstützen und es dadurch zu Fehlern bei laden der Webseite kommen kann.

Info Die Einstellungen werden in der Datei "prefs.js" in Ihrem Profilverzeichnis gespeichert. Sie können die Datei auch mit einem Texteditor verändern, dabei sollte der Browser abr nicht geöffnet sein, da ansonsten die Änderungen wieder überschrieben werden können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1814.htm


Timeout für Verbindungsabbruch unter Firefox einstellen

Mit diesem Tipp können Sie die Timeout-Zeit in Firefox einstellen, bevor ein Verbindungsabbruch angezeigt wird. Gerade, wenn Sie den Tipp "Pipelining Funktion in Firefox aktivieren" aktiviert haben, sollten Sie hier die Zeit entsprechend erhöhen.

Um zu den Einstellungen zu kommen, starten Sie Firefox und geben Sie als URL "about:config" ein.

Ihnen werden jetzt die erweiterten Funktionen angezeigt. Suchen Sie hier den unten angegeben Wert, dabei können Sie über Filter die Anzeige entsprechend einkürzen und die Option leichter zu finden.

Filter: http

Typ: integer

Option: network.http.request.timeout

Durch einen Doppelklick auf den Eintrag können Sie in einer Eingabebox einen neuen Wert eingeben.

0-500 | Zeit in Sekunden
120 | (Standard)

Info Die Einstellungen werden in der Datei "prefs.js" in Ihrem Profilverzeichnis gespeichert. Sie können die Datei auch mit einem Texteditor verändern, dabei sollte der Browser aber nicht geöffnet sein, da ansonsten die Änderungen wieder überschrieben werden können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1815.htm


Elemente beim Laden unter Firefox sofort anzeigen

Wenn Sie in Firefox eine Webseite mit viele Elementen öffnen, werden diese erst angezeigt, wenn mehrere davon heruntergeladen wurden, um CPU-Zeit zu sparen. Dadurch kommt es aber, dass die Ladezeit für den Anwender entsprechend länger dauert. Mit diesem Tipp können Sie einstellen, dass die entsprechenden Elemente sofort nach dem Laden angezeigt werden.

Um zu den Einstellungen zu kommen, starten Sie Firefox und geben Sie als URL "about:config" ein.

Ihnen werden jetzt die erweiterten Funktionen angezeigt. Suchen Sie hier den unten angegeben Wert aus, dabei können Sie über <Filter> die Anzeige entsprechend eingrenzen und die Option leichter zu finden.

Typ: integer

Option: nglayout.initialpaint.delay

Da dieser Eintrag standardmäßig nicht vorhanden ist, müssen Sie Ihn neu anlegen: Rechtsklick im Webfenster und aus dem Kontextmenü den Eintrag "Neu" und den entsprechenden Typ auswählen. Jetzt geben Sie als Eigenschaftsnamen den oben hinter Option angegeben Namen ein.

0 | Element sofort nach dem laden anzeigen
nicht vorhanden | Erst mehrere Elemente laden und dann auf einmal anzeigen (Standard)

Info Die Einstellungen werden in der Datei "prefs.js" in Ihrem Profilverzeichnis gespeichert. Sie können die Datei auch mit einem Texteditor verändern, dabei sollte der Browser aber nicht geöffnet sein, da ansonsten die Änderungen wieder überschrieben werden können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1816.htm


Anzahl der gleichzeitigen Verbindungen im Firefox

Mit diesem Tipp können Sie die Anzahl der gleichzeitigen Verbindungen in Firefox verändern.

Um zu den Einstellungen zu kommen, starten Sie Firefox und geben Sie als URL "about:config" ein.

Ihnen werden jetzt die erweiterten Funktionen detailliert angezeigt. Suchen Sie hier den jeweils unten angegeben Wert. Dabei können Sie über Filter die Anzeige entsprechend einschränken und die Option leichter finden.

Filter: http

Typ: integer

Option: network.http.max-connections

Durch einen Doppelklick auf den Eintrag können Sie die aktuelle Einstellung ändern.

1-40 | Anzahl der gleichzeitigen Verbindungen
24 | (Standard)

Typ: integer

Option: network.http.max-connections-per-server

Durch einen Doppelklick auf den Eintrag können Sie die aktuelle Einstellung ändern.

16 | Anzahl der gleichzeitigen Verbindungen
8 | (Standard)

Typ: integer

Option: network.http.max-persitent-connections-per-server

Durch einen Doppelklick auf den Eintrag können Sie die aktuelle Einstellung ändern.

4 | Anzahl der gleichzeitigen Verbindungen
2 | (Standard)

Info Achtung, zu hohe Werte können dazu führen das die Webseiten nicht mehr richtig geladen werden

Info Die Einstellungen werden in der Datei "prefs.js" in Ihrem Profilverzeichnis gespeichert. Sie können die Datei auch mit einem Texteditor verändern, dabei sollte der Browser abr nicht geöffnet sein, da ansonsten die Änderungen wieder überschrieben werden können.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1817.htm


Automatisches Erwerben von Lizenzen beim MediaPlayer konfigurieren

Wenn Sie diesen Tipp aktivieren, werden die Lizenzen nicht mehr automatisch erworben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "SilentAcquisition" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Lizenzen automatisch holen
0 | Keine Lizenzen automatisch holen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1478.htm


Die Erkennung des MediaPlayer durch Internetseiten unterbinden

Mit diesem Tipp wird beschrieben, wie Sie die Möglichkeit der Identifizierung durch Internetseiten komplett abschalten können.

Wenn Sie den Eintrag "SendUserGUID" aktivieren (Festlegung auf "1"), wird die Möglichkeit der Identifizierung durch Internetseiten komplett abgeschaltet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "SendUserGUID" als Datentyp REG_BINARY. Setzen Sie den Wert auf:

1 | Keine Erkennung mehr möglich
0 | Erkennung ist möglich (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1479.htm


Automatischer Codec-Download des MediaPlayers unterbinden

Wenn Sie diese Funktion aktivieren, werden benötigte Codecs nicht mehr automatisch aus dem Internet geladen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "UpgradeCodecPrompt" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Codec wird nicht automatisch heruntergeladen
0 | Codec wird heruntergeladen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1480.htm


Netzwerk Tabreiter im MediaPlayer ausblenden

Mit diesem Tipp können Sie den Tabreiter "Netzwerk" aus dem MediaPlayer ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoDispSettingsPage" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tabreiter Netzwerk ausblenden
0 | Tabreiter Netzwerk anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1641.htm


Update-Meldung für den Media Player deaktivieren

Findet der Media Player ein Update, erscheint eine Meldung mit dem Hinweis, dass ein Update vorliegt.

Der Media Player fragt dann nach, ob er das Update herunterladen soll. Mit dem folgenden Eintrag können Sie diese Funktion deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ MediaPlayer\ PlayerUpgrade

Erstellen Sie einen neuen Eintrag mit dem Namen "AskMeAgain" als Datentyp REG_SZ und setzen den Wert auf "yes" bzw. "no" ("no" deaktiviert die Meldung).

Sie müssen sich ab- und wieder anmelden, damit die Änderung wirksam wird.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1342.htm


Titelleiste des Media Players verändern

Wenn Sie die den Text der Titelleiste vom Windows Media Player verändern möchten, können Sie das über folgenden Registryeintrag erreichen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie einen neuen Eintrag mit dem Namen "TitleBar" als Datentyp REG_SZ und geben als Wert den neuen Namen der Titelleiste ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1340.htm


Abrufen von CD- und DVD-Medieninformationen verhindern

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), Medieninformationen für CDs und DVDs aus dem Internet abrufen möchte. Wenn Sie den Tipp aktivieren, werden keine Informationen mehr aus dem Internet abgerufen. Weiterhin wird auch im Menü unter "Extras" -> "Optionen" unter dem Tabreiter "Datenschutz" die Einstellung "Medieninformationen für CDs und DVDs aus dem Internet abrufen" deaktiviert und kann nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "MetadataRetrieval" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Keine Medieninformationen aus dem Internet abrufen
3 | Medieninformationen können abgerufen werden (Standard)

oder als Policies

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventCDDVDMetadataRetrieval" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Medieninformationen aus dem Internet abrufen
0 | Medieninformationen können abgerufen werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Abrufen von CD- und DVD-Medieninformationen verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1856.htm


Abruf von Medieninformationen zu Musikdateien verhindern

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), Medieninformationen für Musikdateien aus dem Internet abrufen möchte. Wenn Sie den Tipp aktivieren, werden keine Informationen mehr aus dem Internet abgerufen. Weiterhin wird auch im Menü unter "Extras" -> "Optionen" unter dem Tabreiter "Datenschutz" die Einstellung "Eigene Musikdateien (WMA- und MP3-Dateien) durch Abrufen fehlender Medieninformationen aus dem Internet aktualisieren" deaktiviert und kann nicht verändert werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventMusicFileMetadataRetrieval" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Keine Medieninformationen für Musikdateien aus dem Internet abrufen
0 | Medieninformationen können abgerufen werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Abruf von Medieninformationen zu Musikdateien verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1857.htm


Abruf von vordefinierten Radiosendern verhindern

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), beim Starten die Radioeinstellungsliste aus dem Internet aktualisiert. Die vordefinierten Sender bleiben weiterhin erhalten, werden aber nicht mehr aktualisiert, weiterhin werden die vom Benutzer hinzugefügten Sender nicht mehr angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventRadioPresetsRetrieval" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Radiosenderliste wird nicht mehr aktualisiert
0 | Radiosenderliste wird aktualisiert (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Abruf von vordefinierten Radiosendern verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1858.htm


Automatisches Update unterbinden

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), automatisch im Internet nach Updates untersucht. Weiterhin wird aus dem Menü der Eintrag "Auf Updates prüfen" entfernt und unter "Extras" -> "Optionen" unter dem Tabreiter "Player" der Eintrag "Auf Updates prüfen" gesichert und nicht aktiv.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAutoUpdate" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Auf Updates prüfen deaktivieren
0 | Auf Updates prüfen ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Automatiche Updates verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1859.htm


Konfigurationsdialog beim ersten Start des MediaPlayers nicht anzeigen

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), automatisch beim ersten Start ein Dialogfenster für die Konfiguration des MediaPlayers anzeigt. Hier werden Informationen zu Datenschutz und Installationsoptionen abgefragt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "GroupPrivacyAcceptance" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Erstes Startdialogfenster nicht anzeigen
0 | Erstes Startdialogfenster anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Dialogfelder für die erste Verwendung nicht anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1860.htm


Die Erstellung einer Verknüpfung vom MediaPlayer in der Schnellstartleiste verhindern

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x) automatisch durch den MediaPlayer eine Verknüpfung in der Schnellstartleiste hinzufügt. Wenn dieser Tipp nicht aktiv ist, können die Anwender entscheiden, ob die Verknüpfung hinzugefügt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "QuickLaunchShortcut" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Erstellung einer Verknüpfung wird nicht angeboten
0 | Erstellung einer Verknüpfung ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Die Erstellung von Verknüpfungen auf der Schnellstartleiste verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1861.htm


Die Erstellung einer Verknüpfung vom MediaPlayer auf dem Desktop verhindern

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x) automatisch durch den MediaPlayer eine Verknüpfung dem Desktop hinzufügt. Wenn dieser Tipp nicht aktiv ist, können die Anwender entscheiden, ob die Verknüpfung hinzugefügt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "DesktopShortcut" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Erstellung einer Verknüpfung wird nicht angeboten
0 | Erstellung einer Verknüpfung ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Erstellung von Desktopverknüpfungen verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1862.htm


Videobeschleunigung vom MediaPlayer deaktivieren

Mit diesem Tipp können Sie einstellen, dass der Media-Player (ab 9.x), beim Anzeigen von Videos keine Videobeschleunigung verwendet. Weiterhin wird auch im Menü unter "Extras" -> "Optionen" unter dem Tabreiter "Leistung" -> Button "Erweitert" in der Box "Einstellungen für Videobeschleunigung" das Kontrollkästchen "Videobeschleunigung" deaktiviert und gesichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "DontUseFrameInterpolation" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Videobeschleunigung deaktivieren
0 | Videobeschleunigung ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Videobeschleunigung verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1863.htm


Aussehen (Skin) des MediaPlayers festlegen

Mit diesem Tipp können Sie einstellen, dass der Media-Player (ab 9.x), mit einem bestimmten Design (Skin) gestartet wird. Weiterhin wird dadurch auch der Eintrag "Designauswahl" entfernt, so dass der Anwender das Aussehen nicht verändern kann.

Wenn Sie den Eintrag "SetAndLockSkin" aktivieren (Festlegung auf "1"), können Sie ein Skin festlegen.

Unter "DefaultSkin" müssen Sie den Dateinamen des Skins angeben. Dieses Skin muss sich im Verzeichnis "%prgramfiles%\Windows Media Player\Skins" befinden und hat die Dateiendung ".wmz". Wenn Sie keine Datei angeben bzw. die Datei nicht vorhanden ist, wird der MediaPlayer in Standardaussehen gestartet (Corparate).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "SetAndLockSkin" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Skin festlegen
0 | Es wird kein Skin festgelegt (Standard)

Weiterhin erstellen Sie einen neuen Wert mit dem Namen "DefaultSkin" als Datentyp REG_SZ und geben Sie hier den Namen des Skins an (z.B.: Revert.wmz). Diese Datei muss sich im Verzeichnis "%prgramfiles%\Windows Media Player\Skins" befinden.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Benutzeroberfläche
Einstellungsname: | Design festlegen und fixieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1864.htm


Anchorfenster im Designmodus des MediaPlayers nicht anzeigen

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), im Designmodus unten rechts ein zusätzliches Fenster "Anchorfenster" anzeigt. Über dieses kleine Fenster kann die Anzeige umgeschaltet werden. Weiterhin wird auch im Menü, unter "Extras" -> "Optionen" unter dem Tabreiter "Player" der Eintrag "Player im Designmodus Anchorfenster anzeigen", deaktiviert und gesichert.

Wenn Sie den Eintrag "DoNotShowAnchor" aktivieren (Festlegung auf "1"), wird kein Anchorfenster angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "DoNotShowAnchor" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Es wird kein Anchorfenster angezeigt
0 | Anchorfenster kann angezeigt werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Benutzeroberfläche
Einstellungsname: | Keinen Anker anzeigen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1865.htm


Tabreiter 'Datenschutz' im MediaPlayer ausblenden

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), der Tabreiter "Datenschutz" im Menü "Extras" -> "Optionen" angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "HidePrivacyTab" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Der Tabreiter "Datenschutz" wird ausgeblendet
0 | Der Tabreiter "Datenschutz" wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Benutzeroberfläche
Einstellungsname: | Registerkarte 'Datenschutz' ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1866.htm


Tabreiter 'Sicherheit' im MediaPlayer ausblenden

Mit diesem Tipp können Sie verhindern, dass der Media-Player (ab 9.x), der Tabreiter "Sicherheit" im Menü "Extras" -> "Optionen" angezeigt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "HideSecurityTab" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Der Tabreiter "Sicherheit" wird ausgeblendet
0 | Der Tabreiter "Sicherheit" wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Benutzeroberfläche
Einstellungsname: | Registerkarte 'Sicherheit' ausblenden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1867.htm


Bildschirmschoner im MediaPlayer zulassen

Mit diesem Tipp können Sie einstellen, dass der Media-Player (ab 9.x) bei der Wiedergabe von Medien durch den Bildschirmschoner entsprechend unterbrochen werden kann.

Wenn Sie den Tipp aktivieren, wird der Bildschirmschoner entsprechend der Einstellung im System aktiv. Weiterhin wird auch im Menü unter "Extras" -> "Optionen" unter dem Tabreiter "Player" der Eintrag "Bildschirmschoner während der Wiedergabe zulassen" aktiv und gesichert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableScreenSaver" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Bildschirmschoner ist auch im MediaPlayer aktiv
0 | Bildschrimschoner ist nicht aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Wiedergabe
Einstellungsname: | Bildschirmschoner zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1868.htm


Codecs Download im MediaPlayer unterbinden

Mit diesem Tipp können Sie einstellen, dass der Media-Player (ab 9.x), keine Codecs mehr herunterladet. Weiterhin ist auch im Menü unter "Extras" -> "Optionen" unter dem Tabreiter "Player" der Eintrag "Codecs automatisch downloaden" nicht verfügbar.

Wenn Sie den Eintrag "PreventCodecDownload" aktivieren (Festlegung auf "1"), wird der Codecs Download deaktiviert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventCodecDownload" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Codecs Download deaktivieren
0 | Codes Download aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player\Wiedergabe
Einstellungsname: | Codec-Download verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1869.htm


Netzwerktab im Mediaplayer ausblenden

Mit diesem Tipp können Sie einstellen, ob der Eintrag "Netzwerk im Mediaplayer (ab Version 8.0) angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "HideNetworkTab" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

<gelöscht> | Eintrag wird angezeigt (Standard)
1 | Netzwerk wird ausgeblendet

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2017.htm


Anzeige des Media Players anpassen (Skin)

Darstellung des Media Players anpassen (Skin)

Mit diesem Tipp können Sie die Anzeige des Media Players verändern. Sie können hier z.B. ein neues Skin hinterlegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Player\ Skins

ändern Sie hier den Wert "LastViewMode" als Datentyp REG_SZ und geben Sie den gewünschten Anzeigemodus an:

0 | Vollmodus
1 | Designmodus

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Player\ Skins

ändern Sie hier den Wert "CurrentSkin" als Datentyp REG_SZ und geben Sie den Pfad und den Dateinamen des Skins an. Der Standardwert ist "C:\Programme\Windows Media Player\Skins\Windows XP.wmz".

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2108.htm


MediaPlayer: Nicht mit Medienseite öffnen

Mit diesem Tipp können Sie festlegen, ob der Media Player im Internet nach Medien-Dateien suchen soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

ändern Sie hier den Wert "StartInMediaGuide" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Suchen nach Mediadateien unterbinden
1 | Suchen nach Mediadateien im Internet zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2109.htm


MediaPlayer: 64-Bit Funktion aktivieren

Der Windows MediaPlayer unterstützt ab der Version 11 auch 64-Bit Betriebssysteme. Die 64-Bit Funktion wird aber nicht automatisch aktiviert, sondern muss von Ihnen händisch aktiviert werden.

Gehen Sie dafür folgendermaßen vor:

64-Bit Funktion aktivieren:

Befehl: unregmp2.exe /SwapTo:64

64-Bit-Funktion deaktivieren:

Befehl: unregmp2.exe /SwapTo:32

Führen Sie diesen Befehl entweder über Start -> Ausführen aus. Denken Sie aber daran, die Funktion "Als Administrator ausführen" zu aktivieren.

Weiterhin können Sie den Befehl natürlich auch in der Kommandozeilenoberfläche "CMD.EXE" ausführen. Hier werden Ihnen eventuelle Fehlermeldungen auch besser angezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2225.htm


Mediaplayer: Medienfreigabe verhindern

Mit diesem Tipp können Sie einstellen, dass im Media-Player (ab 11.x) keine Medienfreigabe gemacht werden kann. Wenn Sie diesen Tipp aktivieren, können die Benutzer keine Medien über den Mediaplayer für andere Computer im Netzwerk freigeben.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventLibrarySharing" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Medienfreigabe verhindern
0 | Medienfreigabe ist möglich (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Media Player
Einstellungsname: | Medienfreigabe verhindern

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2312.htm


Mediaplayer: Ausführen von Scripten aktivieren/deaktivieren

Mit diesem Tipp können Sie das Ausführen von eingebetteten Scriptbefehlen im Mediaplayer deaktivieren. Diese Scriptbefehle werden für synchronisierte Multimedia-Präsentationen, Werbung oder DRM-Lizenzerwerbung benötigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "PlayerScriptCommandsEnabled" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Ausführen von Scripten nicht erlauben
1 | Ausführen von Scripten zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2418.htm


MediaPlayer: Liste zuletzt verwendeter Dateien löschen

Der Windows Media Player merkt sich die zuletzt geöffneten Dateien. Dadurch kann man sehen, welche Dateien als letztes mit dem Programm geöffnet werden. Die Liste der Datei wird in der Registry gespeichert und kann dort mit Regedit gelöscht werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Player\ RecentFileList

löschen Sie hier alle vorhandenen Einträge. Für jede Datei gibt es einen Eintrag File0-FileX als Datentyp REG_SZ wo als Wert die entsprechende Datei eingetragen ist.

Wenn Sie die Einstellungen öfter löschen wollen, können Sie auch eine entsprechende REG-Datei zum Löschen erstellen. Durch einen Doppelklick auf die Datei werden die Einträge entfernt.

=== Hier schneiden ===

Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\RecentFileList]

[HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\RecentFileList]

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2464.htm


URL- und Dateiliste beim MP7 löschen

Der MediaPlayer 7 ist mehr als geschwätzig: Jede aufgerufene Datei oder URL wird in einer Verlaufsliste gespeichert. Dieses "Feature" lässt sich leider nicht ohne weiteres deaktivieren. Die Verlaufsliste und URL-Liste werden unter den Pfaden

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Player\ RecentFileList

und

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Player\ RecentURLList

gespeichert.

Anhand einer Reg-Datei, welche man am besten ins Windows-Verzeichnis kopiert und folgender Verknüpfung im Autostart-Ordner:

c:\windows\Regedit.exe /s mpmru.reg

wird diese Liste beim Hochfahren automatisch gelöscht.

Die Datei sollte folgendes beinhalten:

=== Hier schneiden ===
REGEDIT4

[-HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\RecentFileList]
[-HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\RecentURLList]

=== Hier schneiden ===

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1078.htm


Mediaplayer: Schaltfläche "Medienseite" konfigurieren

Mediaplayer 6.x: Schaltfläche "Medienseite" konfigurieren

Mit diesem Tipp konfigurieren Sie die Schaltfläche "Medienseite" des Mediaplayer 6.x. Sie können den Namen der Schaltfläche "Medienseite" und die URL, die aufgerufen werden soll, mit den folgenden Einträgen in der Registry konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

oder als Policies

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowCaseButton" und "ShowCaseURL" als Datentyp REG_SZ,

und geben Sie die gewünschten Werte ein.

Der Wert "ShowCaseButton" legt den Namen des Button fest, der im Mediaplayer angezeigt werden soll. Der Wert "ShowCaseURL" legt die URL-Fest, die aufgerufen werden sollen, wenn auf den Button geklickt wird.

Wenn Sie wieder den Standard herstellen wollen, müssen Sie die angelegten Einträge nur löschen. Die URL für den Button wird dann wieder auf "http://windowsmedia.microsoft.com/default.asp" eingestellt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2522.htm


Mediaplayer: Keine Liste der zuletzt geöffneten Dateien erstellen

Mit diesem Tipp können Sie einstellen, dass der Mediaplayer keine Liste der zuletzt geöffneten Dateien führt.

Der Mediaplayer erstellt normalerweise eine MRU-Liste mit den zuletzt geöffneten Dateien und URLs. Wenn Sie nicht wollen, dass diese Liste erstellt wird, müssen Sie den folgenden Registryeintrag deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "AddToMRU" als Datentyp REG_BINARY und setzen den Wert auf:

0 | Die MRU-Liste zuletzt geöffnete Dateien wird nicht geführt
1 | Die MRU-Liste zuletzt geöffnete Dateien wird erstellt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2523.htm


MediaPlayer: Informationen zur Benutzung nicht an Microsoft senden

Mit diesem Tipp stellen Sie ein, dass der Media Player meint, die Online-Registrierung schon durchgeführt zu haben und er deshalb keine Registrierung mehr durchführen muss.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MediaPlayer\ Preferences

Erstellen Sie hier einen neuen Wert mit dem Namen "UsageTracking" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Registrierung muss noch gemacht werden
1 | Registrierung wurde durchgeführt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2531.htm


MediaPlayer: Entfernen/Deinstallieren aktivieren

Mit diesem Tipp stellen Sie ein, dass der Media Player unter "Software" aufgeführt wird. Dadurch haben Sie die Möglichkeit das Tool vom Rechner zu entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MediaPlayer

Erstellen Sie hier einen neuen Wert mit dem Namen "BlockUninstall" als Datentyp REG_SZ. Setzen Sie den Wert auf:

yes | Der Media Player wird nicht unter Uninstall angezeigt
no | Der Media Player wird unter Uninstall angezeigt

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2532.htm


Versionscheck im Messenger unterbinden

Mit diesem Tipp können Sie den Versionscheck des MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventConsumerVersion" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Versionscheck unterbinden
0 | Versionscheck durchführen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1691.htm


Hintergrunddownload des MS Messenger unterbinden

Mit diesem Tipp können Sie den Hintergrunddownload des MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventBackgroundDownload" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Hintergrunddownload unterbinden
0 | Hintergrunddownload durchführen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1692.htm


Autoupdate des MS Messenger unterbinden

Mit diesem Tipp können Sie die Autoupdate-Funktion des MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventAutoUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Autoupdate unterbinden
0 | Autoupdate durchführen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1693.htm


Bildübertragung über den MS Messenger unterbinden

Mit diesem Tipp können Sie die Bildübertragung über den MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableVideo" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Bildübertragung unterbinden
0 | Bildübertragung durchführen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1694.htm


Telefonieren über den MS Messenger unterbinden

Mit diesem Tipp können Sie das Telefonieren über den MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePC2Phone" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Telefonieren unterbinden
0 | Telefonieren erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1695.htm


Tonübertragung im MS Messenger unterbinden

Mit diesem Tipp können Sie die Tonübertragung über den MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePC2PCAudio" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Tonübertragung unterbinden
0 | Tonübertragung erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1696.htm


Dateiübertragungen im MS Messenger sperren

Mit diesem Tipp können Sie das Übertragen von Dateien über den MS Messenger unterbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableFileTransfer" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Dateiübertragung unterbinden
0 | Dateiübertragung erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1697.htm


Whiteboard und Applikationsfreigabe im MS Messenger deaktivieren

Mit diesem Tipp können Sie das Whiteboard und die Applikationsfreigabe im MS Messenger deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableCollaborationApps" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Funktionen unterbinden
0 | Funktionen erlauben (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1698.htm


Windows Messenger aus dem Internet Explorer entfernen

Mit diesem Tipp können Sie den Messenger aus dem Internet Explorer entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Internet Explorer\ Extensions

Löschen Sie den Schlüssel "{FB5F1910-F110-11d2-BB9E-00C04F795683}" damit der Messenger aus dem IE entfernt wird.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1699.htm


Windows Messenger nicht automatisch starten

Mit dieser Einstellung können Sie das automatische Laden des Windows Messengers unterbinden. Wenn Sie den Tipp aktivieren, wird der Messenger nicht mehr automatisch gestartet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventAutoRun" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Messenger nicht automatisch starten
0 | Messenger wird automatisch gestartet (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Messenger
Einstellungsname: | Windows Messenger nicht automatisch starten

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1700.htm


SSDP Broadcast des Windows Messenger ausschalten

Der Windows Messenger sendet über den UDP Port 1900 sein Broadcast Signal. Mit diesem Tipp können Sie das ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ DirectPlayNATHelp\ DPNHUPnP

Erstellen Sie hier einen neuen Wert mit dem Namen "UPnPMode" als Datentyp REG_DWORD. Setzen Sie den Wert auf 2 um SSDP Broadcast auszuschalten. Wenn Sie die Funktion wieder einschalten wollen, müssen Sie diesen Eintrag wieder aus der Registry löschen.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1701.htm


Im Windows Messenger den Text für die Warnmeldung ändern

Wenn Sie den Messenger starten und einen Chat beginnen, wird Ihnen eine Warnmeldung gezeigt. Mit diesem Tipp können Sie den Text für die Warnmeldung anpassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MessengerService\ Policies

Erstellen Sie hier einen neuen Wert mit dem Namen "IMWarning" als Datentyp REG_SZ und geben Sie hier den Text für die Warnmeldung ein.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1702.htm


Starten vom Windows Messenger nicht zulassen

Mit dieser Einstellung können Sie das Ausführen des Windows Messengers unterbinden.

Wenn Sie den Tipp aktivieren kann das Messenger nicht mehr gestartet werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Messenger\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Messenger\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventRun" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Starten des Messengers ist nicht möglich
0 | Messenger kann gestartet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Messenger
Einstellungsname: | Ausführung von Windows Messenger nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1881.htm


Microsoft Messenger unter Windows deinstallieren

Der Microsoft Messenger lädt sich unter Windows bei jedem Start und kann normalerweise nicht deinstalliert werden.

Allerdings geht es doch, wenn man die Datei "SYSOC.INF" (liegt im Windowsordner Inf) mit einem Texteditor öffnet und in der Zeile msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 das "hide" entfernt, also:

msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7 (Doppelkomma beachten)

Dann kann man den Messenger unter "Systemsteuerung" -> "Software" -> "Windowskomponenten hinzufügen/entfernen" deinstallieren.

Info Übrigens kann man das "hide" auch aus anderen Einträgen, die auf ",7" enden, entfernen und so noch mehr Komponenten deinstallieren / installieren.

Siehe auch "Windows Messenger unter Outlook Express deaktivieren".

Wenn das Windows XP Service Pack 1 installiert ist, ist das oben genannte Vorgehen nicht mehr notwendig.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1195.htm


Werbeeinträge im Windows-Messenger ausblenden

Ab den Windows Messenger 7.x werden auch Tabreiter mit Werbung und anderen Diensten angezeigt. Hier wird beschrieben, wie Sie diese unnötigen Tabreiter ausblenden können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\ Microsoft\ MSNMessenger\ PerPassportSettings

gehen Sie hier jetzt jeden Unterschlüssel durch, der mit einer Ziffer anfängt und legen Sie dort einen neuen Eintrag mit dem Namen "DisableTabs" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Eintrag ausblenden
0 | Eintrag anzeigen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2041.htm


Windows Messenger-URL Konfiguration

Mit diesem Tipp können Sie die URL-Konfiguration des Windows Messenger verändern.

Der Standardwert für die Server URL ist:

bis Version 4.0: "messenger.hotmail.com;64.4.13.56:1863"

ab Version 4.0: "messenger.hotmail.com;64.4.13.213:1863"

Folgene Mögliche Adressen können Sie eintragen:

"messenger.hotmail.com;209.185.128.132:1863"

"messenger.hotmail.com;207.46.106.37:1863"

"messenger.hotmail.com;207.46.96.141:1863"

Info Die " dürfen nicht mit eingegeben werden!

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ MessengerService

hier finden Sie folgende Werte als Datentyp REG_SZ

Server | Server URL/Port:
SOCKS4Server | Socks 4 Server
SOCKS5Server | Socks 5 Server

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2056.htm


Blockierte Dateianhänge unter Exchange in OWA zulassen

Mit diesem Tipp können Sie einstellen, dass Blockierte Dateianhänge unter Exchange über OWA (Outlook Web Access) geöffnet werden können. Standardmäßig werden ab Exchange 2003 einige gefährliche Dateiendungen für den Zugriff gesperrt, welche extra freigegeben werden müssen. Dafür müssen Sie die entsprechende Dateiendung aus der Liste entfernen.

Um diese Funktion freizugeben, ist der folgende Registry-Key auf dem Exchange-Server (der für OWA zuständig ist) zu ändern:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ MSExchangeWeb\ OWA

hier finden Sie die Werte mit dem Namen "Level1FileTypes" und "Level2FileTypes" als Datentyp REG_SZ.

Entfernen Sie hier einfach die Dateiendungen, welche Sie zulassen wollen, dabei haben die beiden Keys folgende Bedeutung:

Level1FileTypes | Auf diese Dateitypen kann nicht zugegriffen werden (öffnen und speichern ist nicht möglich)
Level2FileTypes | Diese Dateitypen können gespeichert werden

Aus Sicherheitsgründen sollten die benötigten Dateiendungen, wenn, nur unter "Level2FileTypes" freigegeben werden und kein Öffnen über OWA zugelassen werden. Wenn Sie die Dateiendung unter "Level1FileTypes"auch entfernen, kann die Datei direkt unter OWA - ohne zu speichern - geöffnet werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1820.htm


Öffnen von Freedocs im Exchange zulassen

Mit diesem Tipp können Sie einstellen, Freedocs unter Exchange über OWA (Outlook Web Access) zu öffnen. Standardmäßig ist das ab Exchange 2003 ausgeschaltet, und es kommt nur die Fehlermeldung 403, wenn Sie versuchen, die Freedocs zu öffnen.

Was sind Freedocs?

Freedocs sind eingefügte Dateianhänge (Office-Dateien), die in Ordnern von Exchange eingefügt wurden (via Drag and Drop).

Um diese Funktion freizugeben, ist der folgende Registrykey auf dem Exchange-Server (der für OWA zuständig ist) einzutragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ MSExchangeWeb\ OWA

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableFreedocs" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Freedocs können über OWA nicht geöffnet werden (Standard)
1 | Freedocs können nur bei einem Zugriff durch den Backendserver geöffnet werden.
2 | Freedocs können nur bei einem Zugriff durch den Backendserver oder durch einen Frontendserver der einen 'host header' mit einem Eintrag in der Registry AcceptedAttachmentFrontEnds hat, geöffnet werden.
3 | Freedocs können über OWA geöffnet werden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1819.htm


Kennwortänderung über OWA zulassen

Mit diesem Tipp können Sie einstellen, dass unter OWA (Outlook Web Access) innerhalb von Optionen wieder ein Button für die Kennwortänderung angezeigt wird. Ab Echange 2003 muss dieser Button über einen Registry-Key extra freigeschaltet werden:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ MSExchangeWEB

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePassword" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

0 | Button wird angezeigt (Standard bis Exchange 2002)
1 | Button wird nicht angezeigt (Standard ab Exchange 2003

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1821.htm


Windows Desktopsuche: Deskbar deaktivieren

Mit diesen Tipp können Sie die Deskbar in der Windows-Taskleiste ausgeblendet. Bei Aktivierung des Tipps wird auch die entsprechende Anzeigeoption im Anpassungs-Assistenten entfernt, und der Anwender kann die Einstellung nicht verändern.

Die Windows-Desktopsuche bietet Ihnen mit der Windows-Deskbar eine benutzerfreundliche Möglichkeit, Ihren Computer nach Belieben zu durchsuchen.

Info Die Deskbar ist immer noch zusammen mit der Windows-Desktopsuche installiert.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunterladen können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "db" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Deskbar deaktivieren
0 | Wir angezeigt, wenn die Anzeigen unter "Anpassungs-Assistenten" aktiviert wurde.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2233.htm


Windows Desktopsuche: Windows Such-Assistenten nicht durch die Desktopsuche ersetzen

Windows Desktopsuche: Windows-Suchassistenten nicht durch die Desktopsuche ersetzen

Mit diesem Tipp können Sie einstellen, dass der Windows-Suchassistent nicht durch die Windows-Desktopsuche ersetzt wird.

Die Windows-Desktopsuche ist ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows Desktop Search\ DS

Erstellen Sie hier einen neuen Wert mit dem Namen "ShowStartSearchBand" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Such-Assistent nicht ersetzen
0 | Such-Assistent ersetzen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2183.htm


Windows Desktopsuche: Starten bei der Anmeldung unterbinden

Mit diesem Tipp können Sie einstellen, ob die Windows Desktopsuche (WDS) beim Anmelden nicht automatisch gestartet werden soll. Wird der Eintrag gelöscht oder nicht aktiviert, kann der Anwender festlegen, ob die Desktopsuche beim Anmelden gestartet werden soll.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventRunAtStartup" Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Desktopsuche nicht starten
0 | Anwender kann das Konfigurieren (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2184.htm


Windows Desktopsuche: Dateitypen festlegen, die nicht indiziert werden

Mit diesem Tipp können Sie eine Liste mit Dateitypen festlegen, die von der Indizierung ausgeschlossen werden sollen.

Info Die Liste der Dateiendungen kann in 4 Schlüsseln (DontIndexTheseExtensions0 bis DontIndexTheseExtensions3) festgelegt werden, welche automatisch von der Desktopsuche zusammengefügt werden. Die Dateiendungen müssen mit einen führenden Punkt angegeben werden. Jede Dateiendung wird voneinander durch ein Semikolon [ ;] getrennt.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier die neuen Werte mit dem Namen:

DontIndexTheseExtensions0

DontIndexTheseExtensions1

DontIndexTheseExtensions2

DontIndexTheseExtensions3

als Datentyp REG_SZ und geben Sie die Dateitypen an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2197.htm


Windows Desktopsuche: Nur "E-Mail" und "Eigene Dateien" indizieren

Windows Desktopsuche: Nur "E-Mail" und "Eigene Dateien" indizierend

Mit diesem Tipp können Sie einstellen, dass die Windows Desktopsuche nur Email und "Eigene Dateien" indiziert. Der Eintrag "E-Mail und alle Festplatten" wird ausgeblendet und "E-Mail und Eigene Dateien" wird aktiviert.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft

herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingAllHardDrives" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Alles anzeigen
1 | Nur "E-Mail" und "Eigene Dateien" können indiziert werden

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2202.htm


Windows Desktopsuche: Indizieren von Outlook-Express-Elementen deaktivieren

Die Windows Desktopsuche indiziert standardmäßig auch Outlook-Express-Elemente. Mit dem folgenden Tipp können Sie Einträge "E-Mail und alle Festplatten" und "E-Mail und Eigene Dateien" aus der Desktopsuche ausblenden. Weiterhin wird dadurch auch das Indizieren von Outlook-Express-Elementen deaktiviert. Ist die Einstellung nicht gesetzt, kann der Anwender diese Funktion konfigurieren.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingOutlookExpress" als Datentyp REG_DWORD und Setzen Sie den Wert auf:

0 | Outlook-Express-Elemente Indizieren
1 | Indizieren von Outlook-Express-Elementen ausschalten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2203.htm


Windows Desktopsuche: Ablagepfad für die Indexdatei festlegen

Mit diesem Tipp können Sie den Pfad festlegen, wo das Tool "Windows Desktopsuche" von Microsoft die Indexdatei ablegen soll. Standardmäßig wird die Datei unter "%UserProfile%\Lokale Einstellungen\Anwendungsdaten\Microsoft\Desktop Search" gespeichert.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "IndexLocation" als Datentyp REG_SZ und geben Sie den Pfad zur Indexdatei an.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2220.htm


Windows Desktopsuche: Indizieren von Netzwerkfreigaben unterbinden

Mit dem Tool "Windows Desktopsuche" von Microsoft, können Sie beliebige Laufwerke zur Indizierung hinzufügen. U.a. können dabei auch Netzwerkfreigaben hinzugefügt werden. Mit diesem Tipp können Sie verhindern, dass Anwender Netzwerkfreigaben hinzufügen können, da eine Indizierung das Netzwerk belasten kann. So ist dies gerade bei vielen Anwendern sinnvoll.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingNetworkShares" als Datentyp REG_DWORD Setzen Sie den Wert auf:

0 | Eintrag wird nicht angezeigt
1 | Eintrag wird angezeigt (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2221.htm


Windows Desktopsuche: Link "Auf Aktualisierungen überprüfen" ausblenden

Mit diesen Tipp können Sie die den Link "Auf Aktualisierungen überprüfen" im Hilfemenü für die Windows-Taskbar ausblenden.. Der Eintrag wird auch aus den "Desktopsuche-Optionen" entfernt.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, zeigt die Windows-Desktopsuche einen Link im Hilfemenü an, über den die Benutzer direkt nach Aktualisierungen suchen können.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventCheckForUpdate" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Link ausblenden
0 | Link anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2234.htm


Windows Desktopsuche: Den "Anpassungs-Assistenten" ausschalten

Mit diesen Tipp können Sie das Starten des "Anpassungs-Assistent" ausgeschaltet.

Meldet sich ein Anwender nach der Installation der Windows-Desktopsuche zum ersten Mal an, wird normalerweise automatisch der "Anpassungs-Assistent" gestartet.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, wird der "Anpassungs-Assistent" für alle Benutzer nach der Installation und beim Starten der Indizierung angezeigt.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "FRW" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Anpassungs-Assistenten ausschalten
0 | Anpassungs-Assistenten starten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2235.htm


Windows Desktopsuche: Das Senden von Nutzungsdaten durch CEIP unterbinden

Mit diesen Tipp können Sie das Senden von anonymen Nutzungsinformationen an Microsoft durch die Windows-Desktopsuche unterbinden.

Die Windows Desktopsuche sendet über CEIP (Customer Experience Improvement Program), zur Verbesserung der Benutzerfreundlichkeit, Informationen an Microsoft.

Wenn Sie den Tipp deaktivieren oder nicht konfigurieren, können Sie auswählen, ob Sie am CEIP-Programm teilnehmen möchten.

Die Windows Desktopsuche ist bis Windows Vista ein extra Tool, welches Sie bei Microsoft herunter laden können: http://desktop.msn.de/

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "NoCEIP" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es werden keinen Informationen an Microsoft gesendet
0 | Sie können auswählen, ob Sie Informationen zum CEIP senden wollen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2236.htm


Windows Desktopsuche: Dateitypen definieren, die als Textdateien behandelt werden sollen

Mit diesem Tipp können Sie eine Liste von Dateitypen festlegen, welche die Windows Desktopsuche als Textdateien behandeln und indiziert soll.

Die Dateierweiterungen müssen mit einem Semikolon getrennt angegeben werden, weiterhin wurde die Liste auf mehrere Werte aufgeteilt, welche durch die Desktopsuche automatisch zu einer Liste zusammengefügt werden.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, können die Benutzer die Liste der als Text zu indizierenden Dateien bearbeiten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier die neuen Werte mit dem Namen "TreatAsText0" und "TreatAsText1" als Datentyp REG_SZ und geben Sie die gewünschten Dateitypen durch ein Semikolon getrennt an.

Standardmäßig werden folgende Dateitypen als Textdateien behandelt:

.a;.ans;.asc;.bas;.bat;.bcp;.c;.cc;.cls;.cmd;.cpp;.cs;.csa;.csv;.cxx;.dic;.dos;.faq;.h;.hxx;.ibq;.inf;.ini;.inx;.jav;.java;.js;.jsl;.log;.m3u;.nws;.pl;.reg;.scc;.txt;.url;.vbs;.wtx

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2238.htm


Windows Desktopsuche: Indizieren bestimmter Netzwerkfreigaben unterbinden

Mit diesem Tipp, können Sie eine Liste der Netzwerkfreigaben angeben, die von der Indexerstellung ausgenommen werden sollen.

Es können keine Netzwerkfreigaben mehr angegeben werden, die mit einem der angegebenen Pfade beginnen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch\ PreventIndexingCertainNetworkShares

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch\ PreventIndexingCertainNetworkShares

Sie müssen den Schlüssel "PreventIndexingCertainNetworkShares" anlegen und können hier jetzt für jede Freigabe die Sie unterbinden wollen einen neuen Eintrag mit dem Namen der Freigabe als Datentyp REG_SZ erstellen. Als Wert geben Sie auch den Namen der Freigabe an.

Unter Regedit sieht das auf der rechten Seiten dann so aus:

Name | Typ | Wert
\\Server1\ShareName1 | REG_SZ | \\Server1\Sharename1

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2239.htm


Windows Desktopsuche: Erweiterte Indizierungsoptionen ausblenden

Mit diesem Tipp können Sie alle erweiterten Indizierungsoptionen in den Optionen zur Desktopsuche ausgeben. Der Unterabschnitt "Erweitert" wird aus der Optionsstruktur entfernt.

Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, können die Benutzer die erweiterten Optionen individuell konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventAdvancedIndexingOptions" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Indizierungsoptionen ausblenden
0 | Indizierungsoptionen anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2240.htm


Windows Desktopsuche: Indizieren bei begrenztem Festplattenspeicherplatz abbrechen

Mit diesem Tipp können Sie einstellen, ob die Indexerstellung abgebrochen werden soll, sobald der angegebene freie Festplattenspeicher auf dem Laufwerk unterschritten wird. Sie können Werte zwischen 0 und 2147483647 MB auswählen und diese Richtlinie aktivieren, wenn Computer in Ihrer Umgebung über sehr begrenzten Festplattenspeicher verfügen. Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, verwaltet die Windows-Desktopsuche die Indexgröße automatisch.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIndexingLowDiskSpaceMB" als Datentyp REG_DWORD und geben Sie einen Wert in MByte an der zwischen 0 und 2147483647 liegen darf.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2250.htm


Windows Desktopsuche: Speichern des Suchverlaufs in der Deskbar deaktivieren

Mit diesem Tipp können Sie einstellen, ob der Suchverlauf in der Windows-Deskbar gespeichert und angezeigt werden soll. Die Option zum Speichern des Suchverlaufs wird nicht in den Deskbar-Optionen angezeigt. Wenn Sie diesen Tipp deaktivieren oder nicht konfigurieren, können die Benutzer festlegen, ob der Suchverlauf gespeichert werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

als Policies [für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ DesktopSearch

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventSearchHistory" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine History speichern
0 | History von den Sucheingaben erstellen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2251.htm


Windows Suche: Position des Vorschaubereiches konfigurieren

Mit diesem Tipp können Sie einstellen, wo der Vorschaubereich bei der Windows Desktopsuche angezeigt werden soll. Standardmäßig wird der Vorschaubereich in der rechten Ecke angezeigt.

Der Vorschaubereich ist nur für Office-Dokumente ab Office XP verfügbar.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Für die Windows Suche:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Search

Diese Einstellung wird ab Windows-Suche 3.01 oder höher unterstützt.

Für die Windows Desktopsuche:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ DesktopSearch

Erstellen Sie hier einen neuen Wert mit dem Namen "PreviewPaneLocation" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Automatisch (wenn benötigt, wird der Vorschaubereich rechts eingeblendet) (Standard)
1 | Rechts einblenden
2 | Unten einblenden
3 | Ausblenden (Vorschaubereich ausblenden)

Wenn Sie den Wert festlegen, kann der Benutzer die Position des Vorschaubereichs nicht mehr selbst auswählen.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2636.htm


Windows Suche: Dateiendungen für Vorschau konfigurieren

Mit diesem Tipp können Sie einstellen,für welche Dateitypen eine Vorschauansicht angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Search

Erstellen Sie hier einen neuen Wert mit dem Namen "RichAttachmentPreviews" als Datentyp REG_SZ, und geben die gewünschten Dateiendungen ein. Mehrere Erweiterungen werden durch Semikolon getrennt, z.B.: ".bmp;.doc;.txt".

Standardmäßig sind folgende Dateiendungen eingetragen: ".bmp;.emf;.gif;.jpg;.jpeg;.png;.wmf;.wrn;.txt;.err;.xml;.cpp;.c;.h;.cxx;.hxx;.idl;.cs;.vb;.idl;.xsd;.doc;.docx;.xls;.xlsx; .ppt;.pptx;.vsd;.xlsb;.xltx;.dot;.rtf"

Diese Einstellung wird ab Windows-Suche 3.01 oder höher unterstützt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2637.htm


Durchsuchen aus dem Windows Installer entfernen

Mit diesem Tipp wird die Schaltfäche "Durchsuchen" neben der Liste "Funktionen verwenden von" im Dialogfeld "Windows Installer" deaktiviert. Damit kann der Benutzer nicht mehr im Windows Installer nach Installationsdateien suchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableBrowse" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Durchsuchen entfernen
0 | Durchsuchen anzeigen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Dialog "Durchsuchen" für die Suche nach einer neuen Quelle entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1887.htm


Benutzersteuerung bei Installationen zulassen

Mit diesem Tipp können Sie einstellen, dass Benutzer die Installationsoptionen verändern können, welche normalerweise nur von Systemadministratoren verfügbar sind.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableUserControl" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Benutzersteuerung zulassen
0 | Benutzersteuerung nicht zulassen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Benutzersteuerung bei Installation zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1886.htm


MSI Benutzerinstallation konfigurieren

Mit diesem Tipp können Sie für den Windows Installer die Benutzerinstallation konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableUserInstalls" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0 | Benutzerinstallation zulassen | Anwendungen für einzelne Benutzer werden zugelassen
1 | Benutzerinstallation ausblenden | Anwendungen für einzelne Benutzer werden ignoriert
2 | Benutzerinstallation nicht zulassen | Verhindert die Installation von Anwendungen für einzelne Benutzer

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | Nein
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Benutzerinstallation nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1885.htm


Windows Installer Suchreihenfolge für Installationsdateien

Mit dieser Einstellung können Sie die Suchreihenfolge konfigurieren, nach dem der Windows Installer nach neuen Instalationsdateien sucht. Standardmäßig durchsucht der Windows Installer zuerst das Netzwerk (n), dann Wechselmedien (m) und zum Schluss das Internet (u).

Hier können Sie jetzt anhand der Kennbuchstaben eine eigene Reihenfolge festlegen:

"n" -> Netzwerk

"m" -> Wechselmedien (Disketten, CD, DVD Laufwerke)

"u" -> Internet

Sie können Buchstaben weglassen, wenn Sie diese Datenquelle nicht verwenden wollen z.B.: nm um nicht im Internet zu suchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "SearchOrder" als Datentyp REG_SZ.

Geben Sie als Wert die entsprechenden Kennbuchstaben ein.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Suchreihenfolge

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1884.htm


Windows Installer mit System-Rechten ausführen

Mit dieser Einstellung können Sie einstellen, dass der Windows Installer, die Installation von allen Paketen mit System-Berechtigungen durchführt. Dadurch können Anwender auch Programme installieren, wenn Sie nicht die entsprechenden Rechte auf die Verzeichnisse besitzen.

Wenn der Tipp nicht aktiviert ist, wenden die Installation von Programmen die nicht vom Systemadministrator zugewiesen wurden, mit den Berechtigungen des Anwenders installiert.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Installer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "AlwaysInstallElevated" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Die Installation erfolgt mit SYSTEM-Rechten
0 | Die Installation erfolgt mit den rechten des Anwenders (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Immer mit erhöten Rechten installieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Erfahrene Anwender können diese Einstellung dazu verwenden, die Rechte auf Verzeichnisse zu verändern und somit immer einen Zugriff auf die Verzeichnisse erlangen!

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1883.htm


MSI-Installation von Wechselmedien unterbinden

Mit diesem Tipp können Sie verhindern, dass Anwender ein Programm für den MSI-Installer von einem Wechselmedium installieren können (CD-ROM, DVD usw.)

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableMedia" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird ausgeblendet
0 | Eintrag ist vorhanden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Wechselmedienquellen für alle Installationen verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1640.htm


Windows Installer Backup ausschalten

Der Windows Installer erstellt automatisch ein Backup der Dateien, um den ursprünglichen Zustand wieder herstellen zu können. Diese Sicherungen belegen Festplattenspeicher. Wenn Sie diesen Tipp aktivieren, werden keine Sicherungen mehr abgelegt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableRollback" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Installer Backup ausschalten
0 | Installer Backup aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Zurücksetzen nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1639.htm


Remoteverwaltung mit dem Windows Installer (MSI) zulassen

Wenn Sie diese Policy aktivieren, können die Administratoren über die Terminal Dienste, Programme Remote Installation und Konfigurieren. Diese Einstellung gilt nur für Systemabministratoren, andere Benutzer können keine Remoteinstallationen ausführen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableAdminTSRemote" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Es kann über TS mit dem MSI gearbeitet werden
0 | Funktion ist nicht aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Administrator erlauben, Installation von Terminaldienstesitzungen auszuführen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1545.htm


Durchsuchen für Installationen mit erhöhten Rechten aktivieren

Mit diesem Tipp wird die Schaltfäche "Durchsuchen" neben der Liste "Funktionen verwenden von" im Dialogfeld "Windows Installer" aktiviert. Damit können Benutzer während einer privilegierten Installation im Windows Installer nach Installationsdateien suchen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "AllowLockdownBrowse" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Durchsuchen zulassen
0 | Durchsuchen ist nicht aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Durchsuchen für Benutzer mit erhöhten Rechten aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1888.htm


Entfernen von Updates nicht zulassen

Mit diesem Tipp können Sie ab Windows Install Version 3.0 festlegen, ob Anwender vom Installer installierte Updates nicht entfernen können.

Wenn der Tipp aktiv ist, können die Update nur vom Windows Installer wieder entfernt werden, wenn die nicht mehr für das Produkt gültig sind, der Anwender (auch Administratoren) können diese Updates nicht entfernen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePatchUninstall" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Entfernen von Updates nicht zulassen
0 | Entfernen von Updates mit den entsprechenden Rechten ist möglich (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Entfernen von Updates nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1889.htm


Erstellen von Systemwiederherstellungspunkten von MSI deaktivieren

Mit diesem Tipp können Sie einstellen, ob bei der Installation von Software über den Windows Installer immer ein Systemwiederherstellunspunkt angelegt werden soll. Standardmäßig wird vor jeder Installation solch ein Wiederherstellungspunkt angelegt. Mit dieser Sicherung sind Sie in der Lage, bei einem evtl. Fehler, den Rechner wieder in seinem alten Zustand herzustellen.

Wenn Sie diesen Tipp aktivieren, werden keine Wiederherstellungspunkte bei der Installation mehr erzeugt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "LimitSystemRestoreCheckpointing" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Keine Wiederherstellungspunkte erzeugen
0 | Wiederherstellungspunkte werden erzeugt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Erstellung von Systemwiederherstellungsprüfpunkten deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1890.htm


IE-Sicherheitshinwiese für Windows Installer Skripts deaktivieren

IE-Sicherheitshinweise für Windows Installer Skripts deaktivieren

Wenn Sie diesen Tipp aktivieren, können webbasierende Programme, Software auf den Computer installieren, ohne den Anwender darüber zu informieren.

Standardmäßig wird vor der Installation eine entsprechende Warnung angezeigt, wenn ein Skript aus dem Internetbrowser heraus eine Anwendung auf dem System installieren möchte. Hier kann der Anwender dann entscheiden, ob er die Installation zulassen oder unterbinden möchte. Aus Sicherheitsgründen sollte diese Einstellung deshalb auch nicht aktiviert werden, da sich so schnell Software ungewollt einschleichen kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "SafeForScripting" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Installation ohne Hinweis durchführen (nicht zu empfehlen)
0 | Installation wird erst nach einer Bestätigung durchgeführt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | IE-Sicherheitshinweise für Windows Installer Skripts deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1891.htm


Installation von signierten Updates durch Anwender nicht zulassen

Ab der Version 3 des Windows Installers können Sie hier einstellen, dass die Installation von signierten Updates nicht von normalen Anwender ohne Administrative-Rechte durchgeführt werden können.

Normalerweise können Updates, die signiert sind, auch von Anwender installiert werden, die über keine Administrativen-Rechte verfügen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLUAPatching" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Nur Administratoren können signierte Updates installieren
0 | Auch normale Benutzer könne signierte Updates installieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Installation von Updates, die durch den Hersteller signiert wurden, für nicht Administratoren nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1892.htm


Größe für den Basisdateien Cache konfigurieren

Ab der Version 3.0 des Windows Installers können Sie hier die Größe des Basisdaten-Caches konfigurieren.

Der Windows Installer legt automatisch von Dateien, die über ein Binärdelta-Update geändert wurden, eine Kopie der Datei im einem Cache-Verzeichnis an. Das wird gemacht, damit bei späteren Updates diese Originaldatei zu Verfügung steht und der Anwender nicht die entsprechenden Sourcen zu Verfügung stellen muss.

Mit diesem Tipp können Sie die Größe dieses Cache-Verzeichnisses festlegen. Sie können einen Wert von 0-100% angeben. Wenn Sie den Wert auf 0 setzen, werden keine Dateien in dem Cache mehr abgelegt. Bei einen Wert von 100 wird der gesamte verfügbare Speicherplatz für den Cache benutzt. Der Standardwert liegt bei 10% der Festplattengröße.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "MaxPatchCacheSize" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

0-100

Gibt in % den zu verendenden Festplattenspeicher an. Der (Standard) liegt bei 10%

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Maximalgröße für den Basisdaten-Cache

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1893.htm


Patchverwaltung für Programme mit erhöhter Sicherheit zulassen

Mit diesem Tipp können Sie einstellen, ob Benutzer bei Programmen mit erhöhter Sicherheit, Patches für diese Programme installieren dürfen. Standardmäßig können nur Administratoren Patches bei Programmen mit erhöhter Sicherheit installieren, wenn Sie den Tipp aktivieren, können auch Benutzer diese Patches installieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "AllowLockdownPatch" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Benutzer können Patches mit erhöhten Berechtigungen installieren
0 | Nur Administratoren können Patches mit erhöhten Berechtigungen installieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Patchverwaltung für Programme mit erhöhter Sicherheit zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1894.htm


Installationen von Patches unterbinden

Mit diesem Tipp können Sie einstellen, dass Benutzer über den Windows Installer keine Patches für Programme installieren können. Standardmäßig können Benutzer Patches installieren, wenn die innerhalb des Sicherheitskontext des Anwenders liegen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisablePatch" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Anwender können keine Patches installieren
0 | Anwender können Patches Ihres Sicherheitskontext installieren (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Patchverwendung nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1895.htm


MSI Installations LOG Einstellungen

Mit diesem Tipp können Sie das LOG-Verhalten vom Windows Installer konfigurieren. Jede Installation wird in der Datei MSI.LOG im Tempverzeichnis des Systemdatenträger protokolliert.

Die Ereignisarten werden durch entsprechende Buchstaben festlegt, wenn dieser Tipp nicht aktiv ist, werden Standardmäßig die Ereignisse "iweap" protokolliert. Sie können Mit diesem Tipp diese Ereignisliste anpassen, dabei können Sie folgende Buchstaben verwenden:

Buchstabe | Bedeutung
i | Statusmeldungen
w | Warnungen
e | Alle-Fehlermeldungen
a | Start der Vorgänge
r | Vorgang spezifische Einträge
u | Benutzeranforderungen
c | Ursprüngliche Benutzeroberflächenparameter
m | Nicht genügend Arbeitsspeicher
p | Terminaleigenschaften
v | Ausführliche Ausgabe
o | Nicht genügend Speicherplatz

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "Logging" als Datentyp REG_SZ.

Setzen Sie den Wert auf die benötigten Kürzel aus der oberen Tabelle.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Protokollierung

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1896.htm


MSI Transformdateien an einem sicheren Speicherort ablegen

Wenn Sie diesen Tipp aktivieren, werden Transformdateien an einem sicheren Speicherort auf dem Computer abgelegt. Diese Transformdateien werden benötigt, wenn eine Installation repariert oder wiederholt werden soll. Wenn Sie diesen Tipp aktivieren, werden die Transformdateien in einem gesicherten Bereich abgelegt. Ist der Tipp nicht aktiv, werden die Dateien im Benutzerprofil im Verzeichnis "Anwendungsdaten" gespeichert.

Ist der Wert nicht vorhanden, gelten je nach Betriebssystem folgenden Einstellungen:

Standardeinstellung:

Windows Server 2003: Transformdateien werden gesichert gespeichert

Windows 2000/XP: Transformdateien werden im Benutzerprofil abgelegt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "TransformsSecure" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Transformdateien in einem gesicherten Bereich ablegen
0 | Transformdateien im Benutzerprofil ablegen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Transformationen an einem sicheren Ort auf der Arbeitsstation zwischenspeichern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1897.htm


Strenge Updateregeln für MSI-Installation aktivieren

Ab Version 3.0 des Windows Installers können Sie Mit diesem Tipp strengere Updateregeln für die MSI-Installation aktivieren.

Updates werden nicht durchgeführt, wenn Sie folgende Aktionen durchführen:

  1. Eine Komponente von einer Funktion entfernen.
    Dadurch ist das Ändern einer GUID von einer Komponente auch nicht zulässig.
  2. Eine neue Funktion wird innerhalb einer bestehenden Funktion hinzugefügt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "EnforceUpgradeComponentRules" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Strenge Updateregeln sind aktiv
0 | Normale Updateregeln sind aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Updatekomponentenregel erzwingen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1898.htm


Verwendung von Wechselmedien bei erweiterten Rechten für Benutzer zulassen

Mit diesem Tipp erlauben Sie Benutzer, während einer Installation, die mit erweiterten Rechten ausgeführt werden, Programme von Wechselmedien zu installieren. Standardmäßig können normale Benutzer nur Programme von Wechselmedien installieren, wenn die Installation mit Ihren Berechtigungen ausgeführt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "AllowLockdownMedia" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Wechselmedien bei der Installation mit erweiterten Rechten erlauben
0 | Wechselmedien nicht bei erweiterten Rechten erlauben (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Verwendung von Medienquellen für Benutzer mit erhöhten Rechten aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1899.htm


Installation vom IIS verhindern

Mit diesem Tipp können Sie einstellen, ob die Installation vom IIS zugelassen oder verhindert wird.

Wenn Sie diesen Tipp aktivieren, wird die Installation vom IIS verhindert, und es können auch keine Anwendungen installiert werden, die den IIS benötigen. Wenn der IIS schon vorher installiert war, hat diese Einstellung darauf keine Auswirkung.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows NT\ IIS

Erstellen Sie hier einen neuen Wert mit dem Namen "PreventIISInstall" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | IIS Installation wird verhindert
0 | IIS Installation ist erlaubt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\ Internetinformationsdienste
Einstellungsname: | IIS-Installation verhindern

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1924.htm


Aufruf von MsiExec.EXE (Parameter)

Microsoft hat für die Installation von Programmen als neuen Standard MSI eingeführt. Die meisten Programme werden heutzutage als MSI-Pakete ausgeliefert und können über MSI installiert werden.

Das Programm "MsiExec.EXE" steuert die Installation, mit dem Programm können Sie eine MSI-Installation mit zusätzlichen Parametern starten und dadurch auch eine automatische Installation erstellen.

Die Parameter von MsiExec:

Parameter

Beschreibung

/i <MSI-Datei> oder <Produkt Code>

Installiert ein Programm

Beispiel: MsiExec /i "C:\Install\office\std11.msi"

/f [p|o|e|d|c|a|u|m|s|v] <MSI-Datei> oder <Produkt Code>

Reparatur oder Nachinstallation von Funktionen

Dabei können noch folgende Optionen angegeben werden:

p -> Fehlende Dateien werden nachinstalliert

o -> Fehlende Dateien und ältere Versionen werden nachinstalliert

e -> Fehlende, gleiche oder ältere Dateien werden nachinstalliert

d -> Fehlende oder ungleiche (älter/neuere) Versionen einer Datei werden nachinstalliert

c -> Fehlende oder Dateien mit einer falschen Cecksumme werden nachinstalliert

a -> Alle Dateien neu installieren (keine Registry Keys)

u -> Benutzereinträge (HKCU) der Registry werden nachinstalliert

m -> Computereinträge (HKLM) der Registry werden nachinstalliert

s -> Verhandene Verknüpfungen werden überschrieben

v -> Installation von der Quelle und erneutes anlegen des Installations-Caches

Beispiel: MsiExec /fa "C:\Install\office\std11.msi"

/a <MSI-Datei>

Eine administrative Installation durchführen (erstellt einen Installationspunkt, wird z.B. bei Office unterstützt)

Beispiel: MsiExec /a "C:\Install\office\std11.msi"

/x <MSI-Datei> oder <Produkt Code>

Deinstallation der Programms

Beispiel: MsiExec /x "C:\Install\office\std11.msi"

/j [u|m] <MSI-Datei> </g> </t>

Ankündigen eines Programms

u -> für den aktuellen Benutzer

m -> alle Benutzer des Rechners

/t -> Zusätzliches Transform

/g -> Sprachkennung

Beispiel: MsiExec /jm "C:\Install\office\std11.msi"

Beispiel: MsiExec /jm "C:\Install\office\std11.msi" /t "C:\Install\office\config.mst"

/L [i|w|e|a|r|u|c|m|p|v|+] <log Datei>

Pfadangabe für die Logdatei und Parameter für die Loginfos

i -> Statusmeldungen aufzeichnen

w -> Warnungen aufzeichnen

e -> Fehlermeldungen aufzeichnen

a -> Starten von Aktionen aufzeichnen

r -> Vorgangsspezifische Aktionen aufzeichnen

u -> Benutzeraktionen aufzeichnen

c -> Parameter für die Benuteroberfläche aufzeichnen

m -> Arbeitsspeicher mangel aufzeichnen

p -> Terminaleigenschaften aufzeichnen

v -> Ausführliche Logausgabe

+ -> An vorhandene LOG-Datei anhängen

* -> Alle Informationen aufzeichen (außer Option v)

Wenn Sie alle Optionen aktivieren wollen, können dafür das * verwenden. Nur für ein ausführliches Log müssen Sie noch das v mit angeben.

Beispiel: MsiExec /i "C:\Install\office\std11.msi" /L *v Install.log

/p

Patchdatei auf die Installation mit anwenden, geht nur im zusammenhang mit Parameter /a

Beispiel: MsiExec /p <Patch Datei> /a <MSI Paket>

/q [n|b|r|f]

Anzeige der Benutzeroberfläche konfigurieren

n -> Keine Benutzeroberfläche anzeigen

b -> Einfache Benuteroberfläche anzeigen

r -> Zeigt eine eingeschränkte Benutzeroberfläche an und öffnet am Ende der Installation ein Dialogfeld

f -> Zeigt eine uneingeschränkte Benutzeroberfläche an und öffnet am Ende der Installation ein Dialogfeld

/? /h

Hilfe

/y <Dateiname>

DLLRegisterServer

/z <Dateiname>

DLLUnregisterServer

TRANSFORMS=

Gibt das Transformfile an, welches für die Installation verwendet werden soll.

Beispiel: MsiExec /i "C:\Install\office\std11.msi" TRANSFORMS="C:\Install\office\config.mst"

<Properties>

Sie können beliebige Properties für die Installation mitgeben.

Beispiel: MsiExec /i "C:\Install\office\std11.msi" TRANSFORMS="C:\Install\office\config.mst" PIDKEY=xxxx APPCOMMENTS="Test Installation"

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2032.htm


"Nach alternativen Quellen suchen" im Windows Installer aktivieren

Mit diesem Tipp können Sie einstellen, ob bei einem Setup nach "alternativen Quellen" für benötigte Sourcen gesucht werden darf. Ist der Tipp aktiv, wird versucht, benötigte Sourcen auf alternativen Quellen zu finden, damit die Installation damit fortgesetzt werden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "TransformsAtSource" als Datentyp REG_SZ und setzen den Wert auf:

0 | Es wird nicht nach "alternativen Quellen" gesucht
1 | Es wird nach "alternativen Quellen" gesucht.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2553.htm


Restart-Manager von Windows Installer konfigurieren

Restart-Manager für Windows Installer konfigurieren

Ab der Version 4.0 von Windows Installer gibt es den Restart-Manager, mit dem die erforderlichen Neustarts des System reduziert werden sollen. Mit diesem Tipp können Sie den Restart-Manager konfigurieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAutomaticApplicationShutdown" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Restart-Manager wird verwendet (Standard)
1 | Restart-Manager wird nicht verwendet
2 | Restart-Manager wird nur für Pakete ab Installer Version 4.0 verwendet

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Verwenden des Neustart-Managers nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2557.htm


Windows Installer: Protokollierung der Paketkonfiguration deaktivieren

Bei Installationspaketen für den Windows Installer kann die Login-Funktion für eine automatische Protokollierung, im Paket aktiviert werden. Dadurch wird bei der Installation eine entsprechende LOG-Datei erzeugt. Über diesen Tipp, können Sie das automatische Logging ausschalten, auch wenn im Setup-Paket selber die Funktion aktiv ist.

Diese Einstellung hat keinen Einfluss auf den Befehlszeilenparameter des Windows Installers. Über diesen Parameter kann beim Setup das Logging, trotz aktiver Richtlinie, aktiviert werden.

Diese Einstellung gilt ab der Windows Installer Version 4.0.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLoggingFromPackage" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Erstellen von Protokolldateien, wenn Funktion im Paket aktiviert ist (Standard)
1 | Keine Erstellung von Protokolldateien, auch wenn die Funktion im Paket aktiv ist

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Protokollierung über Paketeinstellungen deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2558.htm


Windows Installer: Flyweight Patching konfigurieren

Mit diesem Tipp legen Sie fest, ob alle Patchoptimierungen deaktiviert werden können. Wenn Sie die Einstellung "DisableFlyweightPatching" aktivieren (Festlegung auf "1"), werden alle Patchoptimierungsoptionen während der Installation deaktiviert.

Wenn die Einstellung "DisableFlyweightPatching" deaktiviert wird, ermöglicht dies eine schnellere Anwendung von Patches als sonst, indem die Ausführung unnötiger Aktionen verhindert wird. Der Flyweight-Patchmodus ist primär auf Patches ausgelegt, die nur wenige Dateien oder Registrierungswerte aktualisieren. Das Installationsprogramm analysiert den Patch auf bestimmte Änderungen, um festzustellen, ob eine Optimierung möglich ist. Ist dies der Fall, wird der Patch mit einem Minimum an Verarbeitungsaufwand angewendet.

Diese Einstellung gilt ab der Windows Installer Version 3.0.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Installer

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableFlyweightPatching" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Patchoptimierung aktivieren
1 | Patchoptimierung deaktivieren

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Installer
Einstellungsname: | Flyweight Patching nicht zulassen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2570.htm


Windows Defender: Was macht das Tool?

Der Windows Defender ist ein kostenloses Programm von Microsoft, das Ihren Computer vor Sicherheitsrisiken, Spyware usw. schützen soll. Wenn Spyware erkannt wird, wird vom Defender eine geeignete Maßnahme empfohlen. Der Windows Defender ist also eine Antispyware-Lösung von Microsoft.

Es umfasst Echtzeitschutz, ein Überwachungssystem, das bei erkannter Spyware sofort geeignete Maßnahmen empfiehlt.

Systemanforderungen:

  • Ab Windows XP mit SP2 (oder höher) oder Windows Server 2003 mit SP1 (oder höher)
  • Mindestens 64 MByte Arbeitsspeicher (empfohlen 128 MB)
  • 20 MByte freier Festplattenspeicher
  • Internet Explorer ab Version 6.0
  • Windows Installer ab Version 3.1

Download:

Die aktuelle Version vom Windows Defender können Sie von der Microsoft Seite herunterladen.

http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=435BFCE7-DA2B-4A6A-AFA4-F7F14E605A0D

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2229.htm


Windows Defender: Defender ein-/ausschalten

Mit diesem Tipp können Sie den Windows Defender ein-/ausschalten. Der Windows Defender ist ein kostenloses Programm von Microsoft, das Ihren Computer vor Sicherheitsrisiken, Spyware usw. schützen soll. Wenn Spyware erkannt wird, wird vom Defender eine geeignete Maßnahme empfohlen. Der Windows Defender ist also eine Antispyware-Lösung von Microsoft.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableAntiSpyware" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Windows Defender einschalten
1 | Windows Defender ausschalten

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Windows Defender deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2194.htm


Windows Defender: "Vor Überprüfung nach aktualisierten Signaturen suchen" konfigurieren

Mit diesem Tipp legen Sie fest, ob der "Windows Defender" vor der automatischen Überprüfung seine Signaturen über das Internet aktualisieren soll. Da eine Überprüfung nur mit einer aktuellen Signaturdatei wirklich sinnvoll ist, sollte ein Anwender diese Funktion auch nicht ausschalten können.

Wenn Sie diese Einstellung mit diesem Wert konfigurieren, kann die Einstellung "Vor Überprüfung nach aktualisierten Signaturen suchen" vom Anwender nicht mehr über "Extras" -> "Optionen" unter "Automatische Überprüfung" verändert werden.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Scan

Erstellen Sie hier einen neuen Wert mit dem Namen "CheckForSignaturesBeforeRunningScan" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Die Signaturen werden nicht automatisch erneuert
1 | Es wird nach neuen Signaturen, vor einer Überprüfung, gesucht

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Vor geplanten Scanvorgängen auf neue Signaturen überprüfen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2228.htm


Windows Defender: Einstellung für "Software, deren Risiko noch nicht eingestuft wurde" festlegen

Windows Defender: Einstellung festlegen für "Software, deren Risiko noch nicht eingestuft wurde"

Mit diesem Tipp können Sie einstellen, ob Änderungen von Softwares, deren Risiko noch nicht eingestuft wurde, gemeldet werden sollen.

Wenn Sie diese Einstellung mit diesem Wert konfigurieren, kann die Einstellung "Software, deren Risiko noch nicht eingestuft wurde" vom Anwender nicht mehr über "Extras" -> "Optionen" unter "Echtzeitschutz-Optionen" verändert werden.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Real-Time Protection

Erstellen Sie hier einen neuen Wert mit dem Namen "EnableUnknownPrompts" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Sie werden über Änderungen an Software benachrichtigt, deren Risiko noch nicht eingestuft wurde.
1 | Sie werden nur über Änderungen an einer Software benachrichtigt, deren Risiko eingestuft worden ist.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Aufforderungen des Echtzeitschutzes für die Erkennung unbekannter Dateien deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2230.htm


Windows Defender: Signatur-Satzes vollständig runterladen

Windows Defender: Signatur-Satzes vollständig herunterladen

Der Windows Defender lädt beim Updatevorgang der Signaturen, standardmäßig nur die neuen Signaturen runter. Mit diesem Tipp können Sie einstellen, dass immer alle Signaturen geladen werden (ist sinnvoll, wenn beim Signaturabgleich Fehler aufgetreten sind).

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Signature Updates

Erstellen Sie hier einen neuen Wert mit dem Namen "ForceFullUpdate" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Nur aktualisierte Signaturen herunterladen
1 | Alle Signaturen herunterladen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Gesamten Signatursatz herunterladen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2231.htm


Windows Defender: Zugelassenene Software auch protokollieren

Der Windows Defender protokolliert standardmäßig keine zugelassene Software. Mit diesem Tipp können Sie einstellen, dass auch diese Software mit protokolliert wird. Für die Suche nach einen Problem kann das vielleicht hilfreich sein, ansonsten führen die vermehrten Einträge im Protokoll eher dazu, dass man die Übersicht verliert und wichtige Einträge übersehen werden.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Reporting

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLoggingForKnownGood" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Zugelassenene Software wird auch protokolliert
1 | Zugelassenene Software wird nicht überwacht/protokolliert

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Protokollierung der Erkennungsdaten bekannter gutartiger Programme aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2232.htm


Windows Defender: Protokollierung von unbekannter Software

Der Windows Defender protokolliert Standardmäßig auch Software, deren Rsiko noch nicht eingestuft wurde. Diese Protokollierung können Sie mit diesem Tipp ein-/ausschalten.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Reporting

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableLoggingForUnknown" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Auch unbekannte Software wird protokolliert (Standard)
1 | Unbekannte Software wird nicht protokolliert

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Protokollierung der Erkennungsdaten unbekannter Programme aktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2241.htm


Windows Defender: Updates nur über WSUS-Server beziehen

Der Windows Defender versucht bei einem vorhandenen WSUS-Server (Windows Software Update Services) als erstes die Updates für Signaturen über den Server zu beziehen. Kann der Windows Defender aber den Server nicht erreichen, versucht er die Updates wieder vom Microsoft Server zu beziehen. Wenn Sie das verhindern wollen, müssen Sie folgenden Registryeintrag setzen.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ Signature Updates

Erstellen Sie hier einen neuen Wert mit dem Namen "CheckAlternateDownloadLocation" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Updates werden nur über den WSUS-Server bezogen
1 | Konnte keine Verbindung zum WSUS-Server hergestellt werden, wird beim Microsoft nach Updates gesucht(Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Definitionsaktualisierungen durch WSUS und Windows Update einschalten

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2243.htm


Windows Defender: SpyNet-Mitgliedschaft konfigurieren

Der Windows Defender versucht Sie durch die Funktion SpyNet über mögliche Spywarebedrohungen zu informieren. Wird von Windows Defender eine Änderung an Programm festgestellt, deren Risiko noch nicht eingestuft wurde, wird Ihnen über SpyNet angezeigt, was andere Personen bei dieser Veränderung reagiert haben.

Dafür werden auch Informationen von Ihnen an den Microsoft-Server verschickt. Mit diesem Tipp können Sie festlegen, welchen Grad der Mitgliedschaft die benutzen wollen. Mit dem Grad der Mitgliedschaft legen Sie fest, wie umfangreich die Informationen sind, die an Microsoft gesendet werden.

Es gibt dazu 3 Stufen:

  • 1 Stufe (keine Mitgliedschaft)
    Es werden keine Informationen an Microsoft verschickt
  • 2 Stufe (einfache Mitgliedschaft)
    Hier werden nur grundlegende Informationen verschickt und ob die Aktion erfolgreich durchgeführt werden konnte.
  • 3 Stufe (erweitere Mitgliedschaft - Premiummitglied)
    Es werden noch weitere Informationen zugeschickt, wie z.B.: Dateiname, Verzeichnispfad usw.

Wenn Sie diesen Tipp nicht konfigurieren, können die Benutzer die Optionen individuell konfigurieren.

Weitere Informationen finden Sie im Tipp: "Windows Defender: Was macht das Tool?"

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows Defender\ SpyNet

Erstellen Sie hier einen neuen Wert mit dem Namen "SpyNetReporting" als Datentyp REG_DWORD und setzen den Wert auf:

0 | keine Mitgliedschaft
1 | einfache Mitgliedschaft
2 | erweitere Mitgliedschaft

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Defender
Einstellungsname: | Microsoft SpyNet-Berichterstattung konfigurieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2244.htm


NetMeeting deinstallieren

Wenn Sie NetMeeting deinstallieren wollen, können Sie das über folgenden Aufruf tun:

Geben Sie in der Befehlszeile folgenden Aufruf ein:

%SYSTEMROOT%\System32\Rundll32.exe setupapi,InstallHinfSection NetMtg.Remove 132 msnetmtg.inf

Info Weitere Informationen dazu finden Sie auch unter: http://support.microsoft.com/?kbid=267958

Info Es kann sein, dass sich bei einigen Windows-Versionen die Rundll32.exe nicht im system32 sondern im Windows-Verzeichnis befindet. Dann muss der Aufruf entsprechend angepasst werden.

Info Nach der Deinstallation von NetMeeting funktioniert das automatische Windows-Update nicht mehr richtig!

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1515.htm


Remotedesktop-Freigabe deaktivieren

Mit diesem Tipp können Sie die Remotedesktop-Freigabe von NetMeeting deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Conferencing

Erstellen Sie hier einen neuen Wert mit dem Namen "NoRDS" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Remotedesktop-Freigabe deaktivieren
gelöscht | Remotedesktop-Freigabe ist aktiv (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Windows-Komponenten\NetMeeting
Einstellungsname: | Remotedesktop-Freigabe deaktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1847.htm


Sicherheitseinstellungen von NetMeeting konfigurieren

Mit diesen Policy können Sie die Konfiguration von NetMeeting verändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Conferencing

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Conferencing

Erstellen Sie hier folgende neuen Werte jeweils als Datentyp REG_DWORD. Setzen Sie den Wert auf 1 um die Policy zu aktivieren bzw. auf 0 (Standard) um die Policy auszuschalten:

Wertname | Beschreibung | Name in der Gruppenrichtlinie (Pfad siehe unten)
CallSecurity | Bestimmt den Sicherheitsgrad für aus-und eingehende Anrufe. Mögliche Werte: 1 = Erforderlich 2 = Deaktiviert | Anrufsicherheitseinstellungen festlegen
IntranetWebDirURL | Aktiviert bzw. Deaktiviert das Intranet Web Directory |
MaximumBandwidth | Schränkt die Bandbreite für Audio und Video in einer Konferenz ein. Maximale Bandbreite in KBit/s Min: 85000 Max: 621700 | Audio & Video\Bandbreite für Audio und Video einschränken
MaxFileSendSize | Dateigröße beschränken, die gesendet werden können. Die Angabe erfolgt in KByte, es können nur Dateien gesendet werden, die zwischen diesen Wert liegen. Min: 0 Max: 999999999 | Größe der gesendeten Dateien einschränken
NoAddingDirectoryServers | Es können keine neuen Verzeichnis-Server (ILS) hinzugefügt werden | Hinzufügen von Verzeichnis-Servern verhindern
NoAdvancedAudio | Deaktiviert die Schaltfläche "Audio" auf der Registerkarte "Allgemein" |
NoAdvancedCalling | Deaktiviert die Schaltfläche "Erweiterte Anrufoptionen" auf der Registerkarte "Allgemein" | Optionsseite\Schaltfläche "Erweiterte Anrufoptionen" deaktivieren
NoAllowControl | Verhindert, dass Benutzer anderen Anwendern das Steuern von freigegebenen Anwendungen erlauben. Dadurch wird der schreibgeschützte Modus aktiviert. Das hat zur Folge, dass keine Daten in freigegebenen Anwendungen geändert werden können. | Anwendungsfreigabe\Steuerungsübernahme verhindern
NoAppSharing | Die Anwendungsfreigabe wird deaktiviert. Es können weder Anwendungen freigegeben noch kann auf freigegebene Anwendungen von anderen Anwendern zugegriffen werden. | Anwendungsfreigabe\Anwendungsfreigabe deaktivieren
NoAudio | Deaktiviert die Audiofunktion (Senden und empfangen) | Audio & Video\Audiofunktion deaktvieren
NoAudioPage | Blendet die Registerkarte "Audio" im Dialogfeld "Optionen" im Menü "Extras" aus. | Optionsseite\Registrierkarte "Audio" ausblenden
NoAutoAcceptCalls | "Anrufe automatisch annehmen" deaktivieren | Automatische Anrufannahme verhindern
NoChangeDirectSound | Verhindert, dass Benutzer die DirectSound- Audioeinstellungen ändern können. | Audio & Video\Ändern der DirectSound-Audioeinstellungen verhindern
NoChangingCallMode | Aufrufmethode kann vom Benutzer nicht verändert werden. | Ändern der Anrufmethode verhindern
NoChat | Die Chat-Funktion deaktivieren | Chat deaktivieren
NoDirectoryServices | Deaktiviert die Verzeichnisfunktion.Es ist dann keine Anmeldung am ILS-Server mehr möglich. | Verzeichnisdienste deaktivieren
NoFullDuplex | Deaktiviert den Vollduplex-Modus, so dass Benutzer während eines Audioempfangs nicht gleichzeitig reden können. | Audio & Video\Vollduplex deaktivieren
NoGeneralPage | Blendet die Registerkarte "Allgemein" im Dialogfeld "Optionen" im Menü "Extras" aus. | Optionsseite\Registrierkarte "Allgemein" ausblenden
NoNewWhiteBoard | Das Whiteboard wird deaktiviert | Whiteboard deaktivieren
NoOldWhiteBoard | Die Funktionen vom 2.x Whiteboard werden deaktiviert | NetMeeting 2.x Whiteboard deaktivieren
NoReceivingFiles | Empfangen von Dateien verhindern | Empfangen von Dateien verhindern
NoReceivingVideo | Empfangen von Videos verhindern | Audio & Video\Empfangen von Video verhindern
NoSecurityPage | Blendet die Registerkarte "Sicherheit" im Dialogfeld "Optionen" im Menü "Extras" aus. | Optionsseite\Registrierkarte "Sicherheit" ausblenden
NoSendingFiles | Senden von Dateien verhindern | Senden von Dateien verhindern
NoSendingVideo | Senden von Videos verhindern | Audio & Video\Senden von Video verhindern
NoSharing | Verhindert, dass Benutzer Anwendungen freigeben können, Die Benutzer können aber weiterhin auf freigegebene Anwendungen zugreifen. | Anwendungsfreigabe\Freigabe verhindern
NoSharingDesktop | Verhindert, dass der Benutzer seinen Desktop freigeben kann. Einzelne Anwendungen können noch freigegeben werden. | Anwendungsfreigabe\Desktopfreigabe verhindern
NoSharingDOS Windows | Verhindert, dass Benutzer die Eingabeaufforderung freigeben können. | Anwendungsfreigabe\Freigabe der Eingabeaufforderung verhindern
NoSharingExplorer | Verhindert, dass Benutzer den Explorer freigeben können. | Anwendungsfreigabe\Freigabe von Explorer-Fenstern verhindern
NoTrueColorSharing | Verhindert, dass Anwendungen in True Color freigegeben werden, dadurch wird Bandbreite gespart. | Anwendungsfreigabe\Anwendungsfreigabe in True Color verhindern
NoVideoPage | Blendet die Registerkarte "Video" im Dialogfeld "Optionen" im Menü "Extras" aus. | Optionsseite\Registrierkarte "Video" ausblenden
NoWebDirectory | Anzeigen von Webverzeichnissen nicht möglich | Anzeigen des Webverzeichnisses verhindern
PersistAutoAcceptCalls | "Anrufe automatisch annehmen" beim Programmstart aktivieren | Dauerhaft automatische Anrufannahme zulassen
ShowFirstTimeURL | unbekannt |
Use AutoConfig ConfigFile (REG_SZ) | Die Einstellungen werden bei jedem Start von Netmeeting übertragen. Wenn Sie "Use AutoConfig" auf 1 setzen, müssen Sie unter "ConfigFile" die URL zur Konfigurationsdatei angeben. | Automatische Konfiguration aktivieren
IntranetSupportURL (REG_SZ) | Legt die URL fest, welche angezeigt wird, wenn der Benutzer im Menü ? auf "Onlinesupport" klickt. | Intranet-Supportwebseite festlegen

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\NetMeeting
Einstellungsname: | siehe Tabelle oben: Name in der Gruppenrichtlinie

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1514.htm


Acrobat Reader: Aufgaben beim Start

Wenn Sie diesen Tipp aktivieren, wird der Aufgabendialog beim Programmstart vom Acrobat Reader nicht angezeigt. Standardmäßig werden diese Informationen beim Start angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Adobe\ Acrobat Reader\ [Version]\ Downtown

Sie müssen [Version] durch Ihre aktuelle Acrobat Reader Version ersetzen:

8.0 Acrobat Reader 8.0

Erstellen Sie hier einen neuen Wert mit dem Namen "bDontShowAtLaunch" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Aufgaben beim Start anzeigen (Standard)
1 | Aufgaben nicht anzeigen

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2478.htm


EULA vom Acrobat Reader automatisch akzeptieren

Mit diesem Einträgen akzeptieren Sie die EULA vom Acrobat Reader. Dadurch kommt beim ersten Start vom Programm nicht das Fenster mit den Lizenzbestimmungen, welches noch extra bestätigt werden muss.

Dieser Wert ist mehr für eine Unattended-Installation interessant, bzw. wenn Sie eine entsprechende Softwareverteilung bei sich einsetzen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Adobe\ Acrobat Reader\ [Version]\ AdobeViewer

Sie müssen [Version] durch Ihre Acrobat Reader Version ersetzen:

6.0 | Version 6.0
7.0 | Version 7.0

Erstellen Sie einen neuen Wert mit dem Namen "TrustedMode" als Datentyp REG_DWORD und setzen Sie den Wert auf 0. Erstellen Sie einen weiteren Wert mit den Namen "EULA" als Datentyp REG_DWORD und setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2002.htm


Werbefenster von Adobe Acrobat Reader deaktivieren

Mit diesem Tipp können Sie in Adobe Acrobat Reader ab Version 6 das Werbefenster oben rechts deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Adobe\ Acrobat Reader\ [Version]\ AdsInReader

Erstellen Sie hier einen neuen Wert mit dem Namen "bShowAds" als Datentyp REG_DWORD und setzen Sie den Wert (siehe Tabelle unten).

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Adobe\ Acrobat Reader\ [Version]\ FeatureLockdown

Erstellen Sie hier einen neuen Wert mit dem Namen "bShowAdsAllow" als Datentyp REG_DWORD und setzen Sie den Wert (siehe Tabelle unten).

Sie müssen [Version] durch Ihre aktuelle Acrobat Reader Version ersetzen:

6.0 | Adobe Acrobat Reader 6.0
7.0 | Adobe Acrobat Reader 7.0

0 | Werbefenster ausblenden
1 | Werbefenster anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2060.htm


Acrobat Reader: Menüpunkt "PDF Online erstellen" ausblenden

Mit diesem Tipp können Sie in Adobe Acrobat Reader ab der Version 7 den Menüeintrag "PDF Online erstellen" ausblenden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Adobe\ Acrobat Reader\ 7.0\ FeatureLockdown

erstellen Sie hier den Wert "bCreatePDFOnline" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag PDF Online erstellen ausblenden
1 | Eintrag anzeigen (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2536.htm


Adobe Acrobat: Menüeintrag "Adobe Acrobat erwerben" deaktivieren

Mit diesem Tipp können Sie im Programm Adobe Acrobat den Eintrag "Adobe Acrobat erwerben" aus dem Menü "Hilfe" deaktivieren.

Wenn Sie den Eintrag "bPurchaseAcro" aktivieren (Festlegung auf "0"), wird der Eintrag im Menü deaktiviert (Grau hinterlegt).

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Adobe\ Acrobat Reader\ [Version]\ FeatureLockdown

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

8.0 Adobe Acrobat Version 8.x

Erstellen Sie hier einen neuen Wert mit dem Namen "bPurchaseAcro" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag wird deaktiviert
1 | Eintrag ist aktiv (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2645.htm


Adobe Acrobat: Menüeintrag "Adobe Online Dienste" entfernen

Mit diesem Tipp können Sie im Programm Adobe Acrobat den Eintrag "Adobe Online Dienste" aus dem Menü "Hilfe" entfernen.

Wenn Sie den Eintrag "bShowMeets" aktivieren (Festlegung auf "0"), wird der Eintrag im Menü entfernt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Adobe\ Acrobat Reader\ [Version]\ FeatureLockdown

Sie müssen [angezeigte Version] durch Ihre aktuelle Acrobat Version ersetzen:

8.0 Adobe Acrobat Version 8.x

Erstellen Sie hier einen neuen Wert mit dem Namen "bShowMeets" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag wird entfernt
1 | Eintrag ist aktiv (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2648.htm


Startlogo von Adaptec DirectCD ausschalten

Beim Start von Adaptec DirectCD wird ein Startlogo (Splash Screen) angezeigt. Über folgenden Eintrag in der Registry können Sie das Logo deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Adaptec\ DirectCD\ [Versionsnummer]

Erstellen Sie einen neuen Wert mit dem Namen "StartupBanner" als Datentyp REG_DWORD und setzen den Wert auf "0".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1309.htm


Anzahl der Buddies im AOL Messenger erhöhen

Die max. Anzahl der Buddies im AOL Messenger ist auf 160 Einträge beschränkt. Sollten Sie wider Erwarten mehr Leute kennen, können Sie diese Zahl in der Registry erhöhen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ America Online\ AOL Instant Messenger (TM)\ CurrentVersion\ Buddy

Erstellen Sie einen neuen Eintrag mit dem Namen "MaxBuddies" als Datentyp REG_DWORD. Geben Sie einen Wert zwischen 1-999 ein.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1308.htm


Babylon-Online-Update konfigurieren

Mit diesem Tipp können Sie das Online Update von Babylon ein-/ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Babylon\ Babylon Client\ UserInfo\ Options

ändern Sie hier den Wert "EnableDictUpdate" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Onlineupdate aktivieren (Standard)
0 | Onlineupdate ausschalten

ändern Sie hier den Wert "AutoDictUpdate" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Update ohne Nachfrage durchführen (Standard)
0 | Nachfragen bevor Update durchgeführt wird

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2092.htm


Babylon-Startbildschirm anzeigen

Wenn Sie das Programm Babylon installieren, wird beim ersten Start von Babylon das Startbildschirm angezeigt. Mit diesem Tipp können Sie das Anzeigen des Bildschirms verhindern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Babylon\ Babylon Client\ UserInfo\ Options

ändern Sie hier den Wert "ShowStartScreen" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Startbildschirm nicht anzeigen
0 | Startbildschirm anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2093.htm


EPSON CD Druck Lochdurchmesser konfigurieren

EPSON-CD-Druckertool (Lochdurchmesser) konfigurieren

Mit diesem Tipp legen Sie fest, wie weit das EPSON-Druckertool in den Rand druckt (Lochdurchmesser). Dadurch können Sie bis zum Rand drucken, so dass kein Rand mehr bleibt.

Der Standardwert liegt bei 40 mm.

Info: Aus Sicherheitsgründen werden hier nur Werte bis 15 mm zugelassen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ CORPUS\ EPSON Print CD\ Printings

ändern Sie hier den Wert "Bore" als Datentyp REG_DWORD und setzen geben Sie die Randabstand in mm. Die Werte dürfen zwischen 15 und 60 liegen, der Standardwert liegt bei 40.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2086.htm


CD/DVD vollständig bedrucken (Epson 900/950)

Bei den Drucker Epson Stylus Photot 900 und 950 liegt die Software "Print CD" mit dabei. Leider können Sie mit dieser Software nicht den Innenrand der CD/DVD bedrucken. Es bleibt immer ein Kreis von cd. 40 Millimetern unbedruckt.

Mit einem Eintrag in der Registry können Sie die Software so einstellen, dass Sie die ganze CD/DVD bedrucken können.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Corpus\ Epson Print CD\ Printings

Erstellen Sie hier den Wert "Bore" alle als Datentyp REG_DWORD auf 15 bzw. 20 Millimeter ein (müssen Sie probieren). Anschließend können Sie die ganze CD bedrucken.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2021.htm


ICQ Benutzerdatenbank in anderen Ordner sichern

ICQ speichert die Benutzerdatenbank standardmäßig im ICQ-Ordner. Wer diese Datei gerne an einen anderen Ort hätte, geht wie folgt vor.

Beenden Sie ICQ, kopieren Sie Ihre ICQ-Datenbank (meist zu finden unter \Programme\ICQ\UIN) in den neu angelegten Ordner (die Datei heißt wie Ihre ICQ-Nummer mit der Endung.UIN). Jetzt müssen Sie den Pfad zum neuen Ordner in dem Ihre ICQ-Datenbank liegt noch in der Registry Eintragen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Mirabilis\ ICQ\ DefaultPrefs

geben Sie im Key "2000a Database" oder "2000b Database" (je nach Version) den neuen Pfad an.

Mit dem Eintrag "Auto Update" als Datentyp REG_SZ können Sie durch "No" das automatische Update unterbinden bzw. mit "Yes" wieder aktivieren.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1162.htm


ImageReady 3.0: Anzahl der zuletzt geöffneten Dateien

Mit diesem Tipp können Sie festlegen, wie viele Einträge in der Liste der zuletzt geöffneten Dateien angezeigt werden sollen. Standardmäßig zeigt ImageReady die letzten 10 Dateien an.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Adobe\ ImageReady 3.0\ Preferences\ RecentFiles

ändern Sie hier den Wert "MaxCount" als Datentyp REG_DWORD und geben Sie einen Wert zwischen 0 und 50 ein. Der Standardwert liegt bei 10.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2082.htm


Tatsächliche Brenngeschwindigkeit in Nero anzeigen lassen

Mit diesem Tipp können Sie einstellen, dass Nero nicht die ausgewählte Brenngeschwindigkeit anzeigt, sondern die tatsächliche Geschwindigkeit, mit der Nero wirklich brennt.

Stellt Nero fest, dass die ausgewählte Brenngeschwindigkeit zu hoch ist, benutzt Nero automatisch eine niedrigere Geschwindigkeit.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Ahead\ Nero - Burning Rom\ Recorder

Erstellen Sie hier einen neuen Wert mit den Namen "ShowSingleRecorderSpeed" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Geschwindigkeit anzeigen mit der gebrannt wird
0 | Geschwindigkeit anzeigen, die eingestellt wurde

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2006.htm


Automatischen Zeilenumbruch in Notepad ausschalten

Wenn Sie den automatischen Zeilenumbruch in Notepad deaktivieren möchten, müssen Sie folgenden Wert in der Registry ändern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Notepad

Den Eintrag "fWrap" als Datentyp REG_DWORD auf 1 setzen, Wenn Sie den automatischen Zeilenumbruch wieder aktivieren wollen, stellen Sie den Wert einfach wieder auf 0 zurück.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1071.htm


Datum und Uhrzeit einfach unter Notepad einfügen

Datum und Uhrzeit einfach unter Notepad einfügen per F5-Taste

Wenn Sie in Notepad einen Text schreiben und das aktuelle Datum + Uhrzeit einfügen müssen, brauchen Sie nur die F5-Taste zu drücken. Jetzt wird an der aktuellen Cursorposition das Datum und die Uhrzeit eingefügt:

Format: [Uhrzeit] [Datum]

Beispiel: 14:42 2.3.2006

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2036.htm


Einstellungen von Notepad sichern

Die Einstellungen, die Sie in Notepad vornehmen, werden normalerweise von Windows nicht gespeichert. Sollen die Einstellungen der Seitenkonfiguration und der Kopf- und Fußzeilen gespeichert werden, müssen Sie folgende Einstellungen in der Registry aktiveren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Notepad

Erstellen Sie hier folgende neuen Werte als Datentyp REG_DWORD. Setzen Sie den Wert auf 1 um das Speicher zu aktivieren

fSavePageSettings | 1 zum Aktivieren
fSaveWindowsPositions | 1 zum Aktivieren

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1548.htm


Notepad Standardeinstellungen für Schriftzeichen

Mit diesem Tipp können Sie festlegen, ob bei den Zeicheneinstellungen "Durchgestrichen" und "Unterstrichen" aktiviert sein soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Notepad

ändern Sie hier den Wert "lfStrikeOut" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Grundeinstellung: durchgestrichene Zeichen
0 | Grundeinstellung: normale Zeichen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2084.htm


Statusbar in Notepad anzeigen

Mit diesem Tipp können Sie festlegen, ob die Statusbar in Notepad angezeigt werden soll.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Notepad

ändern Sie hier den Wert "StatusBar" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Statusbar anzeigen
0 | Statusbar nicht anzeigen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2085.htm


Norton Antivirus 2001 zusammen mit Outlook XP

Der Mailkontenschutz vom Norton Antivirus kann sich ohne fremde Hilfe nicht mit Outlook XP (2002) verbinden.

Zuerst deaktiviert man im Norton Antivirus die E-Mail-Konten-Schutzfunktion für alle betroffenen Accounts. Dann startet man Outlook XP und editiert die Eigenschaften des betreffenden Mailaccounts, der geschützt werden soll (am besten alle). Der Benutzername für den Mailserver-Login soll dabei auf "EigenerUserName/eigenerPop3Server" geändert werden, z.B. HansWurst/pop.gmx .NET.

Der eingehende POP3-Server muss weiter auf "pop3.norton.antivirus" umgestellt werden. Wer den Login auf seinem Mailserver mit einem gesicherten Kennwort vollzieht, muss als Pop3-Server pop3.spa.norton.antivirusEintragen. Zuletzt aktiviert man im NAV wieder den Mailkontenschutz für die zuvor editierten Mailkonten.

Das Ganze gibt es auch bebildert bei Symantec unter

http://service4.symantec.com/SUPPORT/nav.nsf/docid/2001052917533906

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1169.htm


Norton Ghost 2001 unter Windows ME starten

Norton Ghost lässt sich entgegen der Angaben von Symantec auch in der DOS-BOX starten.

Dazu führt man in der SYSTEM.INI unter "[386enh]" den Eintrag PerVMFiles=200 (der maximale Wert liegt bei 225) hinzu. Allerdings sollte man nicht Partitionen mit offenen Dateien sichern.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1031.htm


Startlogo der Norton Utilities und des Navigators ausschalten

Die Startlogos (Splash Screen) der Norton Utilities und des Navigators lassen sich über die Registry abschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Für die Norton Utilities:

HKEY_LOCAL_MACHINE\ Software\ Symantec\ Norton Utilities

finden Sie die Zeichenfolge "DisableSplashScreen" (der Eintrag kann auch gänzlich fehlen, so dass er manuell eingefügt werden muss). Setzen Sie den Wert auf "1"

Für den Norton Navigator:

HKEY_CURRENT_USER\ Software\ Symantec\ Navigator\ NN-SplashScreen

finden Sie den Binärwert "LastTime". Setzen Sie den Wert auf "FF FF FF FF FF FF FF FF".

Info Siehe auch: "Startlogo des Norton AntiVirus ausschalten".

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0318.htm


Startlogo des Norton AntiVirus ausschalten

Beim Start des Norton Antivirus wird ein Startlogo (Splash Screen) angezeigt. Über folgenden Eintrag in der Registry können Sie das Logo deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Symantec\ Norton AntiVirus\ Clinic

erstellen Sie einen neuen Wert mit dem Namen DisableSplashScreen als Datentyp REG_DWORD und setzen den Wert auf 1, um die Anzeige zu unterbinden bzw. auf 0, um das Startlogo wieder anzuzeigen.

Info Siehe auch: "Startlogo der Norton Utilities und des Navigators ausschalten".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1224.htm


Einstellungen für den Novell Network Client setzen

Einstellungen für den Novell Network Client setzen.

Info:

Diese Keys wurden mir nur geliefert. Eine genaue Beschreibung liegt mir nicht vor.

Wer diese Keys benutzt und eine Beschreibung hat, kann die mir gern zusenden, damit ich die einbinden kann.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Novell \Network Provider\ Menu Items

erstellen Sie folgende Werte als Datentyp REG_SZ und setzen Sie die Werte auf YES oder NO

Wertname | Beschreibung
Enable Logout of Tree |
Enable Logout of Server |
Enable Group Membership Dialog |
Enable Password Administration |
Enable NDS Mailing Information |
Enable NDS Work Information |
Enable NDS Personal Information |
Enable Novell Client Properties |
Enable Novell Client Help |
Enable Systray Config Dialog |
Enable Purge Dialog |
Enable Salvage Dialog |
Enable Object Properties Dialog |
Enable Send Message To Server Dialog |
Enable Send Message To User Dialog |
Enable NetWare Utilities |
Enable End Capture Dialog |
Enable Capture Dialog |
Enable Disconnect Dialog |
Enable Map Dialog |
Enable NetWare Connections Dialog |
Enable Login Dialog |
Enable Browse To Dialog |
Enable NetWare Copy Dialog |
Enable Systray Icon |
Enable Modify Container Script |
Enable Scheduler Icon |
Enable Update Novell Client |
Enable Inherited Rights Dialog |
Enable Trustee Rights Dialog |
Enable Send Message Dialog |
Enable Login Administration |
Modify Login Script |
Enable User Info |

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2104.htm


WinAmp: Zugriff auf CDDB-Datenbank unterbinden

WinAmp ist ein feiner Player und eignet sich auch zum Abspielen von Audio-CDs.

Der Player will sich aber bei jeder unbekannten CD mit der CDDB-Datenbank im Internet verbinden. Zum Abschalten dieser Funktion aktiviert man unter Options, Preferences "No Internet connection aviable".

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1197.htm


Usernamen für die Anmeldung im Yahoo Messenger konfigurieren

Usernamen für die Anmeldung im Yaho-Messenger konfigurieren

Hier können Sie den Usernamen vorgeben.

Den Yahoo Messenger können Sie unter "http://messenger.yahoo.com/" herunter laden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Yahoo\ Pager

ändern Sie hier den Wert "Yahoo! User ID" als Datentyp REG_SZ und geben Sie den Usernamen ein.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2088.htm


Return-Taste vom Yahoo-Messenger konfigurieren

Hier können Sie die Funktion der Return-Taste konfigurieren. Wenn Sie den Tipp aktivieren, wird beim Drücken der Return-Taste der Text an den anderen gesendet, ansonsten wechselt ein Klick auf Return nur in eine neue Zeile.

Den Yahoo Messenger können Sie unter "http://messenger.yahoo.com/" herunter laden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Yahoo\ Pager

ändern Sie hier den Wert "IM Enter Sends Message" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Return-Taste versendet den Text
0 | Return-Taste springt in neue Zeile (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2089.htm


URL Angaben im Yahoo-Messenger konfigurieren

Hier können Sie die Verbindungen des Yahoo Messenger einstellen.

Den Yahoo Messenger können Sie unter "http://messenger.yahoo.com/" herunter laden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Yahoo\ Pager

hier finden Sie folgende Werte als Datentyp REG_SZ

Http Server | HTTP Server
Socket Server | Socket Server
PreLogin | Erster Login Server (URL)
LatestSocketServerUrl | URL Server List beziehen von
IPLookup | IP Lookup

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2090.htm


Terminal Server mit Standard Gina (Anmeldefenster) starten

Wenn Sie bei Terminal Server Clients die Standard Gina (msgina.dll) wieder benutzen wollen, müssen Sie folgenden Wert in der Registry setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ Terminal Server\ WinStations\ RDP-Tcp

erstellen Sie einen neuen Wert mit dem Namen "fUseDefaultGina" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1319.htm


SQL-Datenbank sichern

Beim Backup einer Datenbank müssen Sie auch die aktuellen Größen der Daten/Log Devices dokumentieren. Beim Zurückspielen des Backup müssen die Größen der Devices mit der Originaldatenbank übereinstimmen, da es ansonsten zu Fehlern und Datenverlust kommen kann.

Damit Sie das nicht immer bei jeder Vergrößerung der Datenbank neu dokumentieren müssen (was schnell einmal vergessen werden kann), sollten Sie die Größenangaben der Datenbank über ein SQL-Skript automatisch sichern lassen.

Beispiel:

isql -U[Anmeldename] -P[Passwort] -S[SQL-Servername] -Q"sp_help_revdatabase" -o[Sicherungsdatei]

Bei einem Restore brauchen Sie jetzt nur noch diese Sicherungsdatei unter ISQL laden und ausführen, die Datenbank wird dann automatisch mit der richtigen Größe angelegt.

Bei einer Neuinstallation des SQL-Servers ist darauf zu achten, dass Sie bei der Installation die gleiche Codeseite und die installierte Sortierreihenfolge wie bei der alten Installation verwenden.

Diese Informationen können Sie bei einer bestehenden Installation über ISQL mit folgenden Befehl abfragen: sp_helpsort.

Auch sollten Sie das gleiche Service Pack einspielen, mit den Befehl: SELECT @@version können Sie sich die aktuellen Daten ausgeben lassen.

Dabei entspricht die Versionsnummer folgender SQL-Installation:

6.50.201 | SQL Server 6.5
6.50.213 | SQL Server 6.5 mit Service Pack 1
6.50.240 | SQL Server 6.5 mit Service Pack 2
6.50.258 | SQL Server 6.5 mit Service Pack 3
6.50.281 | SQL Server 6.5 mit Service Pack 4

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0626.htm


Senden von Infos durch 'Tool zum Entfernen bösartiger Software' unterbinden

Senden von Infos durch "Tool zum Entfernen bösartiger Software" unterbinden

Das Microsoft Windows-Tool zum Entfernen bösartiger Software überprüft Computer unter Windows XP, Windows 2000 und Windows Server 2003 auf Infektionen durch bestimmte, weit verbreitete, bösartige Software, einschließlich Blaster, Sasser und Mydoom und unterstützt Sie bei deren Beseitigung.

Nachdem Erkennung und Entfernung abgeschlossen sind, wird das Ergebnis in einem Bericht angezeigt, einschließlich der bösartigen Software, die entdeckt und entfernt wurde. Im Ordner %WINDIR%\Debug erstellt das Tool eine Protokolldatei mit dem Namen mrt.log.

Mit diesem Tool können Sie bestimmte, weit verbreitete, bösartige Software von infizierten Systemen entfernen

Findet das Tool einen Schädling, wird der Schädling entfernt. Des Weiteren sendet Windows aber eine entsprechende Infomail an Microsoft, wer dass nicht will, kann das hier ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ SOFTWARE\ Policies \ Microsoft\ MRT

Erstellen Sie hier einen neuen Wert mit dem Namen "DontReportInfectionInformation" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Keine Info-Mail versenden
0 | Info-Mail versenden (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base:
http://support.microsoft.com/?kbid=890830
http://support.microsoft.com/?kbid=891716

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1664.htm


History der Google-Suche löschen

In der Google-Suchleiste wird eine History der Suchbegriffe gespeichert. Diese Liste wird in der History abgelegt. Mit diesem Tipp können Sie die aktuelle Liste löschen.

Internet Explorer:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

HKEY_CURRENT_USER\ Software\ Google\ NavClient\ 1.1

Löschen Sie hier den Schlüssel "History"

Firefox:

Hier wird die History in der Datei "history.dat" gespeichert. Diese Datei ist im Profilverzeichnis vom Firefox zu finden. Der Ordner befindet sich normalerweise ab Windows 2000 unter "%appdata%\Mozilla\Firefox\Profiles". In der Datei "%appdata%\Mozilla\Firefox\profiles.ini" sind alle vorhandenen Profile eingetragen und abweichende Pfadangaben sind dort hinterlegt.

Alle privaten Daten können in Firefox einfach über das Menü "Extras" -> "Private Daten löschen..." gelöscht werden.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1684.htm


Ausführen vom Windows Movie Maker nicht zulassen

Mit diesem Tipp können Sie einstellen, ob der WIndows Movie Maker gestartet werden kann. Dieses Tool wird ab Windows XP ausgeliefert und kann zur Aufnahme und Bearbeitung von Videos benutzt werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ WindowsMovieMaker

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ WindowsMovieMaker

Erstellen Sie hier einen neuen Wert mit dem Namen "MovieMaker" als Datentyp REG_DWORD.

Setzen Sie den Wert auf:

1 | Der Movie Maker kann nicht gestartet werden
0 | Movie Maker kann gestartet werden (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Movie Maker
Einstellungsname: | Ausführung von Windows Movie Maker nicht zulassen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1870.htm


Verbindung mit einer Dokumentbibliothek zum Windows SharePoint Services nicht möglich

Verbindung mit Dokumentbibliothek zum Windows SharePoint Services nicht möglich

Nach der Installation von Windows XP Service Pack 2, werden Ihnen Dokumentbibliotheken vom Windows SharePoint Server nicht mehr angezeigt, in denen Windows-Shell-Befehle oder die Explorer-Ansicht verwendet werden.

Windows deaktiviert (bei XP ab SP2) aus Sicherheitsgründen die Standardauthentifizierung für den "Web Distributed Authoring and Versioning" (WebDAV) Redirector. WebDAV ist eine Erweiterung von HTTP und setzt die Verwendung von Standardauthentifizierung voraus.

Damit Sie wieder auf diese Einträge zugreifen können, müssen Sie auf dem entsprechenden Client wieder die Standardauthentifizierung aktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ WebClient\ Parameters

ändern Sie hier den Wert "UseBasicAuth" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Standardauthentifizierung aktivieren
0 | Standardauthentifizierung deaktivieren (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2053.htm


Standard-Authentifizierung über einen unverschlüsselten Kanal deaktivieren (WinInet)

Mit diesem Tipp können Sie die Standard-Authentifizierung über unverschlüsselte Kanäle blockieren. Dadurch stellen Sie sicher, dass die Kennwörter nicht im Klartext übertragen werden. Damit wird verhindert, dass WININET das BasicAuth verwendet, außer es handelt sich um einen sicheren Kanal (HTTPS oder SSL).

Ist der Tipp aktiv, können Benutzer sich an WebDAV-Servern für den Remote-Dateizugriff anmelden, ohne befürchten zu müssen, dass ihr Kennwort unverschlüsselt übertragen wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Internet Settings

ändern Sie hier den Wert "DisableBasicOverClearChannel" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Nur sichere Verbindungen zulassen
0 | Auch unsichere Verbindungen zulassen

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2080.htm


Download Accelerator History löschen

In diesem Tipp wird beschrieben, wie Sie die History des "Download Accelerator" löschen können. Der "Download Accelerator" ist ein Programm, mit dem Sie Dateien aus dem Internet herunterladen können. Dabei legt das Programm eine History an, worin aufgeführt wird, von wo welche Datei heruntergeladen wurde.

Das Programm wird verwendet, um das Downloaden schneller durchzuführen als es der Internet Explorer macht. Weiterhin bietet das Tool noch andere Funktionen. Informationen zum Programm befinden sich unter: http://wwww.speedbit.com.

Um diese History zu löschen, müssen Sie folgendes machen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ SpeedBit\ Download Accelerator\ HistoryCombo

löschen Sie hier den Eintrag "URLHistory" als Datentyp REG_SZ, um die URL-Auswahlbox zu leeren.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ SpeedBit\ Download Accelerator\ FileList

löschen Sie hier alle Einträge, die sich unterhalb dieses Schlüssels befinden, um die Download-History zu löschen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2603.htm


Automatisches Update vom Autodesk-Programmen abschalten

Beim Start vom Autodesk (DWF-Viewer oder Design Review) wird eine automatische Überprüfung auf mögliche Updates durchgeführt. Wenn Sie diese Funktion nicht wollen, können Sie diese Überprüfung mit den folgenden Einträgen ausschalten.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

Autodesk DWF Viewer:

HKEY_LOCAL_MACHINE\ Software\ Autodesk\ DWF Viewer\ Settings\ AutoUpdate

Autodesk Design Review:

HKEY_LOCAL_MACHINE\ Software\ Autodesk\ Design Review\ Settings\ AutoUpdate

HKEY_CURRENT_USER\ Software\ Autodesk\ Design Review\ Settings\ AutoUpdate

Erstellen Sie hier die folgenden Einträge:

Name | Datentyp | Wert | Beschreibung
InitialCheck | REG_DWORD | 1 |
NextCheckDate | REG_DWORD | 1466424000 | Gibt die Zeit in Sekunden bis zur nächsten Updateüberprüfung an
DoNotShowAgain | REG_DWORD | 1 | Überprüfung auf Updates auschalten
URL | REG_SZ | (leer) | Update URL (URL löschen)

Info Bei der Anwendung "Autodesk Design Review" kann das aktive Autoupdate dazu führen, dass die Software beim Start 2-5 Minuten hängt, bevor die Anwendung vollständig gestartet wird und damit gearbeitet werden kann.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2622.htm


Windows CE: Menü-Animation ausschalten

Windows CE

Mit diesem Tipp können Sie die Menü-Animation (ein/ausblenden) unter Windows CE auf einem Pocket PC ausschalten.

Dafür müssen Sie den Registryeintrag "AniType" auf 0 setzen.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ System\ GWE\ Menu

erstellen Sie einen neuen Wert mit dem Namen "AniType" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Menü-Animation ausschalten
1 | Menü-Animation aktiv (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2593.htm


Windows CE: Animation ausschalten

Windows CE

Mit diesem Tipp können Sie die Animation (minimieren/maximieren) unter Windows CE auf einem Pocket PC ausschalten.

Dafür müssen Sie den Registryeintrag "Animate" auf 0 setzen.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ System\ GWE

erstellen Sie einen neuen Wert mit dem Namen "Animate" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Animation ausschalten
1 | Animation aktiv (Standard)

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2595.htm


Windows CE: Font-Cache (Schriftspeicher) ändern

Windows CE

Mit diesem Tipp können Sie die den Font-Cache (Speicher für die Schrift) unter Windows CE auf einem Pocket PC verändern.

Windows CE verwendet einen Pufferspeicher (GlyphCache), um den Bildschirmaufbau von Textseiten zu beschleunigen. Je größer der Speicher, um so schneller können die Seiten aufgebaut werden.

Wenn Sie den Wert also vergrößern, wird der Aufbau schneller, da mehr Speicher für die Schriften benutzt wird. Dieser Speicher wird aber fest reserviert und steht somit für andere Anwendungen nicht mehr zur Verfügung.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ System\ GDI\ GLYPHCACHE

erstellen Sie einen neuen Wert mit dem Namen "limit" als Datentyp REG_DWORD und setzen den Wert auf:

4096 | Langsamer, dafür weniger Speicherverbrauch
8192 | Normale Einstellung (Standard)
16384 | Schneller, dafür mehr Speicherverbrauch
32768 | Noch Schneller

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2601.htm


Windows CE: Font-Smoothing aktivieren

Windows CE

Mit diesem Tipp können Sie das sogenannte Font-Smoothing unter Windows CE aktivieren. Mit Font-Smoothing wird eine Kantenglättung der Schriftarten aktiviert, die sich aber erst ab einer Schriftgröße von 16 Punkten richtig auswirkt. Das Font-Smoothing ist nicht so effektiv wie ClearType, es wird aber auch bei älteren CE.NET Versionen unterstützt.

Leider bringt eine Aktivierung nur dann etwas, wenn diese Funktion auch vom Grafikkartentreiber des Gerätes unterstützt wird.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ System\ GDI

erstellen Sie einen neuen Wert mit dem Namen "Fontsmoothing" als Datentyp REG_SZ und setzen den Wert auf "1". Um Font-Smoothing wieder auszuschalten, müssen Sie den Eintrag löschen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2604.htm


Windows CE: Autostart Konfiguration

Windows CE

Auch unter Windows CE gibt es unterschiedliche Stellen, um Programme für einen Autostart einzutragen, damit diese automatisch gestartet werden.

Die erste Möglichkeit geht entweder über ein Verzeichnis "\Windows\Autostart" oder "\Windows\Startup". Diese Verzeichnisse funktionieren genauso wie die Autostartordner unter Windows. Sie legen hier einfach nur entsprechende Programmverknüpfungen an, damit diese Programme gestartet werden.

Die zweite Möglichkeit gibt es über die Änderung der Registry.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ init

finden Sie die Einträge mit den Namen "Lauchxx", wobei xx durch einen laufende Nummer ersetzt wird. Die laufende Nummer legt auch die Reihenfolge fest, wie die Anwendungen gestartet werden sollen.

Z.B.: startet der Eintrag "Launch50" mit dem Wert "explorer.exe" den Explorer.

Zusätzlich zu den "Lauch"- Einträgen kann es noch einen "Dependxx"- Eintrag geben. Auch hier steht xx wieder für eine laufende Nummer und gibt zusätzlich an, zu welchem "Lauch"-Eintrag dieser Wert gehört. Mit dem Depend Wert lassen sich Abhängigkeiten festlegen, die erfüllt sein müssen, bevor der zugehörige Lauch-Eintrag gestartet wird. Dazu wird ein zweistelliger Hex-Wert für die Abhängigkeiten zu anderen Einträgen angegeben.

Der Eintrag "Depend50" mit den Wert "14 00 1E 00" legt zwei Abhängigkeiten fest.

Einmal "00 14" (entspricht dem Dezimalwert 20) und zusätzlich noch "00 1E" (Dezimalwert = 30). Der Eintrag unter "Launch50" wird also erst ausgeführt, wenn "Launch20" und "Launch30" gestartet wurden.

Info Das Überprüfen von Abhängigkeiten stellt leider nicht sicher, dass eine vorher gestartete Applikation bereits voll initialisiert ist und auf Aufrufe von anderen Anwendungen reagiert.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2613.htm


Windows CE: Warnmeldungen beim Einlegen von PCMCIA/Flasch-Karten

Windows CE

Da PCMCIA oder Flasch-Karten viel Strom verbrauchen können und dadurch die Akkustandzeit erheblich verkürzt wird, ist für das Einstecken solcher Karten eine Warnmeldung zum Batteriestatus vorgesehen. Erst nach dem Bestätigen der Meldung, werden die Karten aktiviert.

Ob diese Meldung aktiv ist oder nicht, hängt meist vom Hersteller der Geräte ab und ist oft unterschiedlich konfiguriert. Viele Geräte bieten auch die Möglichkeit, die Einstellung in der Systemsteuerung zu konfigurieren, wenn das bei Ihnen nicht möglich ist, können Sie die Einstellung über den folgenden Registryeintrag verändern.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Drivers\ PCMCIA\

Hier finden Sie den Wert "NoBatteryCheck" wo Sie folgende Werte einstellen können:

0 | Die Warnmeldung ist aktiv
1 | Es wird keine Warnmeldung angezeigt

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2614.htm


Windows CE: Synchronisierung von Dateien auf Speicherkarten konfigurieren

Windows CE

Wenn Sie Dateien synchronisieren, berücksichtigt ActiveSync standardmäßig nur Dateien im Ordner "My Documents". Wenn Sie Ihre Dateien aber auf einer Speicherkarte ablegen und lieber mit diesem Verzeichnis synchronisieren wollen, können Sie das in der Registry verändern.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows CE Services

Hier finden Sie im Eintrag "FileSyncPath" und "NoSubFolderIn". Ändern Sie hier die Pfadangabe auf das neue Verzeichnis ab (\Speicherkarten Bezeichnung\Verzeichnisname -> z.B.: \SD Card\Daten).

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2615.htm


Windows CE: Lesbarkeit der Texte mit ClearType verbessern

Windows CE

Die Technologie der ClearType-Schriftarten bewirkt, dass ein Text auf dem Bildschirm fast genau so klar und deutlich wie auf gedrucktem Papier angezeigt wird.

Hier wird beschrieben wie Sie diese Funktion aktivieren.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\

erstellen Sie einen neuen Wert mit dem Namen "ClearTypeText" als Datentyp REG_DWORD und setzen den Wert auf "1".

0 | ClearType ausschalten
1 | ClearType aktivieren

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2657.htm


Windows CE: Skript-Fehler auf dem Pocket PC im Internet Explorer anzeigen lassen

Windows CE

Mit diesem Tipp können Sie einstellen, dass bei einem Skript-Fehler eine entsprechende Warnmeldung angezeigt wird. Dazu müssen Sie in der Registry den Wert "ShowScriptErrors" setzen.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main

erstellen Sie einen neuen Wert mit dem Namen "ShowScriptErrors" als Datentyp REG_SZ und setzen den Wert auf "1".

0 | Keine Meldung anzeigen
1 | Skript-Fehler werden angezeigt

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2658.htm


Windows CE: Taskbar automatisch ausblenden

Windows CE

Mit diesem Tipp können Sie einstellen, dass die Taskbar automatisch ausgeblendet wird, wenn sie nicht verwendet wird.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Shell\ AutoHide

tragen Sie beim Wert mit dem Namen "(Default)" als Datentyp REG_SZ und setzen den Wert auf "1".

0 | Wird nicht automatisch ausgeblendet
1 | Wird automatisch ausgeblendet

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2662.htm


Windows CE: Textseitenaufbau beschleunigen

Windows CE

Mit diesem Tipp können Sie den Aufbau von Textseiten unter Windows CE beschleunigen.

Windows benutzt einen Pufferspeicher der als "GlyphCache" bezeichnet wird, um den Bildaufbau von Textdokumenten zu beschleunigen. Auf den meisten aktuellen Geräten ist hier ein Wert von "8192" eingetragen. Erhöht man diesen Wert, wird der Aufbau großer Seiten - etwa im Internet Explorer - merklich beschleunigt.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ SYSTEM\ GDI\ GlyphCache

tragen Sie beim Wert mit dem Namen "Limit" als Datentyp REG_SZ und geben hier die gewünschte Größe in Byte an (siehe Anmerkung unten).

Der Standard steht auf 8192. Ein möglicher Wert liegt bei 32768.

Info Zu verstehen ist der eingetragene Wert als Anzahl der Byte, die pro installierter Schrift und Art dieser Schrift (fett, kursiv...) für den Pufferspeicher zur Verfügung stehen. Bei aktivierten ClearType (siehe Tipp"Windows CE: Lesbarkeit der Texte mit ClearType verbessern" ) wird zudem der verwendete Pufferspeicher automatisch vervierfacht! Übertreiben sollte man die Pufferzuweisung also nicht, der Speicher wird fest reserviert und steht Anwendungen nicht mehr zur Verfügung.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2663.htm


Windows CE: Internet Explorer Versionsinfo setzen

Windows CE

Mit diesem Tipp können Sie einstellen, welche Versionsinformationen der Internet Explorer bei den Aufruf von Webseiten weitergeben soll.

Einen Registry Editor für Windows CE finden Sie hier zum Download:

Download: PHM Registry Editor

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion

tragen Sie beim den folgenden Werten als Datentyp REG_SZ die entsprechenden Informationen ein.

Name | Wert | Beschreibung
(Default) | Mozilla/4.0 | Browser
Version | MSIE 6.0 | Internet Explorer 6.0
Plattform | Windows NT 5.0" | Betriebssystem (hier Windows 2000)

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2666.htm


Microsoft Adresse

Microsoft Adresse in Deutschland

Hier finden Sie Informationen, wo und wie Sie Microsoft bei Fragen und Aktivierungen der Produkte erreichen können.

MS Direkt

Postfach 1199

33410 Verl

Windows Aktivierung

Deutschland:

00800 - 22 84 82 83

0800 - 28 48 282

Österreich/Schweiz:

00800 - 22 84 82 83

Technischer Support:

0180 - 5 67 22 55

URTL: http://support.microsoft.com/gp/kontaktinfo

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0237.htm


Was ist eine CLSID?

Eine CLSID (ClassIDentifier) ist zunächst einmal nichts weiter als ein Name für ein Objekt. Es ist eine spezielle Form eines GUID (Globally Unique Identifier), also ein weltweit eindeutiger Bezeichner. Eine CLSID ist ein 16-byte Wert, welcher 32 hexadezimal Ziffern enthält. Diese Ziffern sind in Gruppen angeordnet: 8-4-4-4-12 und in geschweiften Klammern { }.

CLSIDs werden benutzt, um OLE Objekte eindeutig identifizieren zu können. Das Aktenkoffer-Programm muss z.B. auf ein eindeutiges Objekt verweisen, um einen neuen Aktenkoffer erzeugen zu können. Einige weitere Beispiele für Objekte die eine CLSID besitzen sind:

Arbeitsplatz

Desktop

Systemsteuerung

DFÜ-Netzwerk

Drucker

Posteingang

Unter: CLSID Nummern der wichtigsten Funktionen finden Sie eine Aufstellung der wichtigsten Nummern.

In der Registry können Sie unter HKEY_CLASSES_ROOT\CLSID beliebige neue Class-ID anlegen. Wichtig ist dabei, dass diese ID noch nicht vorhanden ist. Eine Class-ID besteht immer aus 8-4-4-4-12 Hex-Ziffern. Damit Sie nicht zufällig eine ID anlegen, die bereits verwendet wird, sollten Sie von hinten hochzählen, eine mögliche ID wäre also {00000000-0000-0000-0000-000000000001}.

Objekte werden von Windows über ihre CLSID angesprochen. Diese Objekte haben Eigenschaften, z.B. einen Namen, das Icon, ob es sich um einen Shortcut handelt und etliche andere (siehe HKEY_CLASSES_ROOT) Methoden.

Eine Methode ist ein Vorgang, der ausgeführt wird, wenn mit diesem Objekt gearbeitet wird, z.B. ein Doppelklick, wenn ein anderes Objekt darauf per Maus "gedropt" wird usw. Damit ein Objekt, welches durch seine CLSID repräsentiert wird, eine Methode besitzt, muss natürlich ein Programm vorhanden sein, welches diese Methode ausführt.

Info Ein Programm zum Erzeugen von GUIDs finden Sie unter
http://www.aboutvb.de/khw/artikel/khwcreateguid.htm

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0313.htm


Was ist eine GUID?

MS benutzt in Windows immer öfter GUIDs (Globally Unique Identifier).

Im Active Directory werden diese für die einzelnen Objekte benötigt. Auch bei der Installation von Produkten werden solche GUIDs verwendet, um die Programme eindeutig identifizieren zu können.

Bei einer GUID handelt sich um eine 16-Byte-Zahl (128-Bit), die aus einer Menge von Informationen gebildet wird. So wird unter anderem die MAC-Adresse der Netzwerkkarte bei der Erstellung einer GUID verwendet, um sicherzustellen, dass die GUID weltweit eindeutig ist. Bei der Installation eines Betriebssystems wird auch eine GUID erstellt, die dann eine bestimmte Maschine identifiziert.

Diese GUIDs werden auch im Active Directory zur Identifzierung von Objekten benutzt. Der Vorteil einer GUID gegenüber einer SID (Security Identifier) ist, dass sie innerhalb eines Forests eindeutig ist und nicht wie die SID nur innerhalb einer Domäne Bestand hat.

Info Ein Programm zum Erzeugen von GUIDs finden Sie unter: http://www.aboutvb.de/khw/artikel/khwcreateguid.htm.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1137.htm


Was ist eine SID und wie ist sie aufgebaut?

Die SID (Security Identifier) werden von Windows zur Identifikation von Benutzern und Gruppen verwendet. Da z.B. Benutzernamen in einem Netzwerk doppelt vorkommen können, wird für jeden Benutzer eine eindeutige SID erstellt und zugewiesen. Windows selber arbeitet nur mit dieser SID. Werden einem Benutzer also Rechte zugewiesen, benutzt Windows dafür dessen SID.

Eine SID ist in etwa genauso aufgebaut wie ein GUID (Globally Unique Identifier), welches jedes Objekt bei Windows 2000 besitzt. SIDs erhalten aber ausschließlich sicherheitsrelevate Objekte, da die SID zur Echtheitsbestätigung verwendet wird.

Durch diese SID wird der Benutzer im ganzen Netzwerk identifiziert. Auch wenn der Name des Benutzer geändert wird, bleibt die SID erhalten, wird der Benutzer im Netzwerk gelöscht, wird auch seine SID gelöscht. Wird der Benutzer mit demselben Namen wieder erneut angelegt, so erhält er eine neue SID, weshalb ihm alle Berechtigungen wieder neu zugewiesen werden müssen.

Da in der SID auch die betreffende Domäne des Benutzer hinterlegt wird, ändert sich die SID eines Benutzers, wenn er in eine andere Domäne verschoben wird. Nur wenn die entsprechenden Domänen im "native Mode" betrieben werden, sorgt Windows für die entsprechende Rechteanpassung, und der Anwender kann ohne Probleme weiterarbeiten. Ansonsten müssen alle Rechte neu vergeben werden, weshalb eine Verschiebung eines Benutzers in eine andere Domäne gut überlegt sein sollte.

Aufbau einer SID:

S-1-5-21-515967899-920026266-1708537768-1000

Folgendermaßen ist die SID unter Windows aufgebaut; dabei haben die einzelnen Stellen folgende Bedeutungen:

S | Bedeutet, dass es sich um eine SID handelt
1 | Revisionsnummer (zur Zeit für NT und 2000 immer 1)
5 | Identifier Authority (zur Zeit für NT und 2000 immer 5)
515967899-920026266-1708537768 | Domänen ID
1000 | Benutzer ID (RID)

Ab Windows Vista können Sie sich die SID der Accounts wie folgt anzeigen lassen:

Dazu öffnen Sie die Eingabeaufforderung und geben folgenden Befehl ein:

wmic

Hier geben Sie dann hinter "wmic:root\cli>" den Befehl "USERACCOUNT" ein und drücken 'Enter'.

Suchen Sie in der Spalte "Caption" Ihren Anmeldenamen, dort finden Sie in der Spalte "SID" die SID Ihres Accounts.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0819.htm


Was ist das Option Pack?

Zu Anfang hat MS auch in den Service Packs neue Funktionen mit eingebunden. Da dadurch aber die Größe sehr angestiegen ist und die Service Packs eigentlich dafür gedacht sind, Fehler zu beheben, wurde für neue Funktionen das Option Pack eingeführt.

Aus diesen Grunde gehört zum Service Pack auch noch das Option Pack, welches zur Zeit als Version 4 vorliegt.

Das Option Pack 4 enthält zur Zeit:

  1. Internet Information Server 4
  2. Microsoft Transaction Server 2
  3. Microsoft Message Queue Server 1
  4. Internet Connection Service for RAS
  5. Certificate Server
  6. Site Server Express
  7. SMTP Server.

Dieses Option Pack ist für Anwender gedacht, die mit NT einen Internet/Intranet Server aufbauen wollen. Wenn Sie viel mit RAS arbeiten, ist es wegen der "Internet Connection Service for RAS" ebenfalls empfehlenswert.

Herunterladen können Sie es unter: http://www.microsoft.com/msdownload/ntoptionpack/askwiz.asp

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0664.htm


VDM (Virtual DOS Machine)

Simuliert eine DOS Umgebung für Programme, die nicht für Windows geschrieben sind. Dadurch können DOS Programme unter Windows ausgeführt werden. Für die Programme sieht es so aus als wenn sie sich unter DOS befinden, sie bekommen nichts von der Windows Umgebung mit.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1326.htm


Bedeutung von Dateiendungen (A - M)

Diese Aufstellung wurde von Jörg Zeitschel erstellt und von Ihm im CompuServe Forum veröffentlicht. Für die Richtigkeit übernehme ich keine Verantwortung.

Hinweise über neue Dateiendungen werden gern entgegengenommen.

Bedeutung:

wichtig | Diese Dateien gehören zum System oder zu bestimmten Programmen. Hier sollten Sie schon etwas besser überlegen, ob Sie diese Datei wirklich löschen können.
löschen | Diese Dateien können Sie ohne Bedenken für das System löschen.
entscheiden | Hier müssen Sie entscheiden, ob Sie diese Datei löschen können. Wenn Sie das Programm nicht mehr benötigen oder die Funktion nie brauchen, können Sie diese Datei löschen.

Dateiendung | Beschreibung/Typ | wichtig | löschen | entscheiden
- - - | Backupdateien von Windows 3.x | Ja | Nein | Nein
$$$ | Bufferdatei eines DOS -Spiels | Ja | Nein | Nein
$** | Temporäre Dateien DBase IV | Nein | Ja | Nein
~mp | Duplikat einer Temporären Datei | Nein | Ja | Nein
000 | Speicher-Backup von Windowsprogrammen | Ja | Nein | Nein
000 | wenn nicht TEMP.000, dann unwichtig | Nein | Ja | Nein
000 | wird vor dem Download von Wincim angelegt | Nein | Nein | Ja
1st | oft für Readme-Dateien verwendet | Nein | Ja | Nein
2gr | .VGA-Color-Init | Ja | Nein | Nein
301 | FAX Datei von Superfax 2000 | Nein | Ja | Nein
322 | Interne Telefonie Netmeeting Prog. Bibliothek | Nein | Nein | Ja
386 | wichtige Systemkomponenten, Emulatoren | Ja | Nein | Nein
3gr | .VGA-Color-Init | Ja | Nein | Nein
669 | Musikmodul mit Samples (Dualmodulplayer) | Nein | Nein | Ja
a01-a99 | Aufgeteiltes ARJ-Archiv | Nein | Nein | Ja
ac3 | Dolby Digitale Audio Datei meist auf DVD | Nein | Ja | Nein
aca | MS Agent-Datei Typ HTML | Nein | Nein | Ja
acc | Atari Programm (GEM/resident) | Ja | Nein | Nein
acf | MS Agent-Datei Typ HTML | Nein | Nein | Ja
acg | MS Agent Vorschau -Datei | Nein | Ja | Nein
acl | Access-Code-Library für Windows | Ja | Nein | Nein
acm | Advanced Color-Driver-Modul | Ja | Nein | Nein
acs | Ms Agent Charakter-Datei | Nein | Nein | Ja
acv | Audio CODEC-Files (Cerative Labs) | Ja | Nein | Nein
acw | Ms Eingabe Assistent Datei | Nein | Nein | Ja
ad | Screen-Saver (After Dark) Datei | Nein | Nein | Ja
adc | Bitmap /16 Farben (Scanstudion) | Nein | Nein | Ja
add | OS/2-Device Treiber; wird mit BASEDEV geladen | Ja | Nein | Nein
ade | Access Projekterweiterung | Nein | Nein | Ja
adf | Amiga Disketten-Image | Nein | Ja | Ja
adm | Administrations Datei für W95 | Ja | Nein | Ja
adn | Add-In (Lotus 1.2.3) Access Projekt Vorlage | Nein | Nein | Ja
adp | Zip-Drive-Treiber f. OS/2 / Access Projekt | Ja/Nein | Nein | Nein/Ja
afl | Fronst für Allways (Lotus) | Nein | Nein | Ja
afm | Postscriptfont Metric (Adobe) | Nein | Nein | Ja
ai | Adobe Illustrator Metagrafik | Nein | Ja | Nein
aif | Audio Internet File auch aifc oder aiff | Nein | Ja | Ja
ain | AIN-Archiv | Nein | Nein | Ja
all | Arbeitsblätter (Always)/Druckertreiber(WordPerfect) | Nein | Nein | Ja
amd | Anwender Profile | Ja | Nein | Nein
ani | animated Cursor (Mauszeiger) | Ja | Nein | Nein
arc | Komprimierte Datei im LHARC-Format | Nein | Ja | Ja
arh | Konfigurationsdatei des DOS navigator | Nein | Nein | Ja
arj | Komprimierte Datei im ARJ-Format | Nein | Ja | Ja
arr | Atari Arrangement (Cubase) | Nein | Nein | Ja
art | Atari Raster Graphic (Art Director) | Nein | Nein | Ja
asa | Active Server Dokument Fontpage | Nein | Nein | Ja
asc | Datei im ASCII-Format | Nein | Nein | Ja
asc | PRO-CD-Suchkriterien-Initialisierung / Textdateien | Ja | Nein /Ja | Nein/Ja
asf | Ms Media Audio/Video | Nein | Ja | Ja
asm | Assembler Quelltext | Nein | Ja | Ja
asp | ASP (Association of Shareware Professionals) Shareware Text | Nein | Ja | Nein
asp | Active Server Dokument Fontpage | Nein | Nein | Ja
asx | Verknüpfung Media Audio Video | Nein | Ja | Ja
av | Sound clip | Nein | Ja | Nein
avi | Windows Animated Video-File (Video Clips) | Nein | Ja | Ja
au | Audio-Basic-File | Nein | Nein | Ja
b8 | Farbwerte 24 bit (PicLab) | Nein | Nein | Ja
b64 | Ausführbare gepackte Datei | Nein | Ja | Ja
b~k | Kopie einer Sicherungskopie | Nein | Ja | Nein
b&W | Atari, Mac Grafik | Nein | Nein | Ja
bak | Sicherungskopie | Nein | Ja | Ja
bar | Applikationsgeneratorobjekt (DBase) | Nein | Nein | Ja
bas | Symbolleisten Initialisierung /Basic Programme | Ja | Nein | Nein
bat | Batch-Dat | Ja | Nein | Nein
bbm | IFF Brush (Deluxe Paint) | Nein | Nein | Ja
bbs | Bulletin Board System/Mailbox Liste | Nein | Ja | Nein
bch | Applikationsgeneratorobjekt (DBase) | Nein | Nein | Ja
bez | Micrografix Bitfont (Designer) | Nein | Ja | Ja
bfc | Windows 95 Aktenkoffer-Datei (Briefcase) | Nein | Nein | Ja
bfx | Fax Datei (Bitfax) | Nein | Ja | Ja
bgi | Borland Grafik Treiber | Ja | Nein | Ja
bhx | Ausführbare gepackte Datei | Nein | Ja | Ja
bif | Binary Image File | Nein | Nein | Nein
bin | Binäre Dateien / Komprimierungsprogr.-Dateien | Nein | Nein | Ja
bkf | MS Sicherungsdatei, NT Bandsicherung | Nein | Nein | Ja
bkp | Sicherungskopie (Tvision) | Nein | Ja | Nein
bl | Brettliste (Mailbox) | Nein | Ja | Ja
bmp | Windows Bitmap Grafik (Hintergrundbild etc.) | Nein | Nein | Ja
bp | Boilerplate von OzWin II | Nein | Ja | Ja
brd | DOS Eagle Layout Datei | Nein | Nein | Ja
bs2 | BSARC-Archive Version 2.xx Datei | Nein | Nein | Ja
bsn | BSARC-Archive Version 1.xx Datei | Nein | Nein | Ja
btm | OS/2 Batch-Datei | Nein | Nein | Ja
btx | btx-Decoder-File | Nein | Nein | Ja
c | C -Quelltext | Nein | Nein | Ja
c2d | Win on CD Image Datei | Nein | Nein | Ja
cab | Cabinet Komprimierte Speicherung auch der Windows-Dateien | Ja | Nein | Nein
cag | Corel Art Gallery | Nein | Nein | Ja
cal | Calenderdatei (Microsoft) | Ja | Nein | Nein
cap | Capture File | Nein | Ja | Ja
cat | Catalog (DBase IV, OzWin II u.a.) Sicherung | Nein | Nein | Ja
cb | Programmspezifische Sicherungskopie | Ja | Nein | Nein
cbf | Atari DOS Cheebase Datei | Nein | Nein | Ja
cbi | Atari DOS Cheebase Index | Nein | Nein | Ja
cbl | COBOL Quelltext | Nein | Ja | Ja
cbt | Computer Based Training Lernprogramm-Datei | Nein | Nein | Ja
CC | C++ Quelltext | Nein | Ja | Ja
cc2 | CodeClip Clipboard-Datei | Nein | Ja | Ja
cc7 | CodeClip Clipboard-Datei | Nein | Ja | Ja
cch | COREL Chart Dateien | Nein | Nein | Ja
cco | btx-Grafik | Nein | Ja | Ja
ccs | Color-Einstellung CorelDraw | Ja | Nein | Nein
cda | CD-Audio-Track | Nein | Nein | Ja
cdg | CD General CD Grund Audio Format | Nein | Ja | Nein
cdk | Atari (Calamus) Dokument | Nein | Ja | Nein
cdr | COREL Draw Bild | Nein | Nein | Ja
cdt | CD Text Grund format | Nein | Ja | Nein
cdt | COREL Symbol Infokey Modul | Ja | Nein | Nein
cdx | File Assistant (Norton Desktop f. Win)/Indexdatei (Navcis) | Nein/Ja | Ja/Nein | Ja
cfg | Konfigurationsdateien | Ja | Nein | Nein
cga | CGA Bildschirmtreiber /Grafikdateien | Ja/Nein | Nein | Nein/Ja
cgm | Computer Graphics Metafile (Freelance Vectorgrafik) | Nein | Ja | Nein
chk | Von CHKDSK/SCANDISK erstellte Sicherungsdateien verlorener Cluster oder querverbundener Dateien | Nein | Ja | Nein
chm | komprimierte Hilfedatei im HTML-Format | Nein | Nein | Ja
chr | Character File (für Borland DOS Grafikmodi) | Ja | Nein | Ja
cht | Chart, (Harvard Graphics) / Schnittstellendatei (DBase) | Nein | Nein | Ja
chz | CHARC-Archiv | Nein | Nein | Ja
cil | Clip Gallerie Download Packet | Nein | Nein | Ja
cim | Sicherungskopie für WinCIM | Ja | Nein | Nein
cla | Hot Java Browser Klassifikationen für Netscape | Ja | Nein | Nein
clp | Clip-Art (Quatro Pro) / Zwischenablage bei NT | Nein/Ja | Ja/Nein | Nein/Ja
cmd | Commanddatei zur Ausführung eines OS/2-Progr. Wird wie die Batch-Datei unter DOS verwendet, kann aber auch ein REXX-Programm beinhalten. NT4 Batchdatei | Ja | Nein | Nein
cmf | Musikdatei (Creative) | Nein | Ja | Nein
cmp | GIF Const. Backup Graphics File/Wörterbuch (MsWord-DOS ) | Ja/Nein | Nein | Nein/Ja
cmv | COREL Move Datei | Nein | Nein | Ja
cmx | COREL Präsentation | Nein | Nein | Ja
cnf | Zielwahldatei Netmeeting | Nein | Ja | Nein
cnt | Kalender Steuerelement | Ja | Nein | Nein
cnv | Word Konverter-Modul | Ja | Nein | Nein
cob | COBOL Quelltext | Nein | Ja | Nein
com | Ausführbares Programm bis 64 KB | Ja | Nein | Nein
cor | Sicherungskopie für COREL | Ja | Nein | Nein
cov | Fax KBlatt Datei Cover | Nein | Nein | Ja
cp$ | Error Code DOS Calls (Telephone) | Nein | Ja | Nein
cpe | Deckblatt Editor Datei | Nein | Ja | Ja
cpi | DOS -Font-Registry (characters per Inch?) | Ja | Nein | Nein
cpj | WinOnCD CeQuadrat Project | Nein | Nein | Ja
cpl | Geräte-Treiber (Windows) Systemsteuerungs-Option | Ja | Nein | Nein
cpl | Codepage Listing Systemsteuerungsoptionen | Ja | Nein | Nein
cpp | Programmdatei (WinImage) | Ja | Nein | Ja
cpt | COREL Photo-Paint Image/ Memodatei verschl. (DBase) | Nein | Nein | Ja
crd | Karteikastendatei (Microsoft Windows Card-Datei) | Ja | Nein | Nein
crl | Zertifikats-Sperrliste | Ja | Nein | Nein
crp | Kennwortdatei (DBase) | Nein | Nein | Ja
crt | Sicherheitszertifikat | Ja | Nein | Nein
cru | Crush-Archiv | Nein | Nein | Ja
css | Cascading Stylesheet Datei | Nein | Nein | Ja
csv | Excel Script-Format Datei | Ja | Nein | Nein
cur | Mauspfeile, Cursor | Nein | Nein | Ja
cvp | Delrina Winfax 3.0 KBlatt-Datei | Nein | Ja | Ja
cvr | Fax KBlatt (winFax) | Nein | Ja | Ja
dat | Daten-File (D-Info etc. etc.) | Ja | Nein | Nein
db | Database allgemein | Ja | Nein | Nein
db$ | temporäre Datenbankdatei | Nein | Ja | Nein
dba | Paradox-Tabelle | Nein | Nein | Ja
dbf | Datenbank im DBase-Format | Nein | Nein | Ja
dbo | compilierte Programmdatei (DBase) | Nein | Ja | Ja
dbs | Datenbank (SQL-Format)/Druckerbeschreibung (Word, Works) | Nein | Nein | Ja
dbt | Memodatei (DBase.Clipper, Foxpro) | Nein | Nein | Ja
dcl | Delphi Compiled Library | Nein | Ja | Ja
dcp | OS/2-Systemdateien für Keyboard u. Displaytreiber | Ja | Nein | Nein
dcr | Delphi Compiled Ressource | Nein | Nein | Ja
dct | Dictionary, Wörterbuch | Nein | Nein | Ja
dcu | Delphi Compiled Unit | Ja/Nein | Ja/Nein | Ja
def | Definitionsdatei | Nein | Ja | Nein
dem | Delphi Datei | Nein | Ja | Ja
dfm | Delphi Form | Ja | Nein | Ja
dfv | DruckFormatVorlage (Word) | Nein | Nein | Ja
dib | Bitmapdatei | Nein | Ja | Nein
dic | Dictionary Wörterbuchdatei | Nein | Nein | Ja
dic | Benutzerwörterbuch (je nach Anwendung) | Ja | Nein | Nein
dif | Excel Datatransfer File | Ja | Nein | Nein
dil | Lotus Library für Grafikimport | Nein | Nein | Ja
dir | Katalogdatei für Backupsatz | Nein | Nein | Ja
diz | Dateibeschreibungstext (z.B. von 4DOS : description-file) | Nein | Ja | Nein
dl | alter Library-File aus Windows 3.1 | Ja | Nein | Nein
dlg | Windows Ressourcen Script | Ja | Nein | Ja
dll | Dynamic Link Library Programmdatei | Ja | Nein | Ja
dmd | OS/2-Device Manager (SCSI u. DASD) | Ja | Nein | Nein
doc | MS Word Dokument/ Textdatei mit Dokumentation | Nein | Nein | Ja
dok | Textdatei mit Dokumentation | Nein | Ja | Nein
DOS | Windows 95 DOS -Systemdateien | Ja | Nein | Nein
dot | MS Word Dokumentenvorlage | Nein | Nein | Ja
dpr | Programmdatei (NAVISC) | Ja | Nein | Ja
dpr | Delphi Projekt | Ja | Nein | Ja
drv | Treiber | Ja | Nein | Nein
drw | Zeichnungsdatei (Designer, Draw, Autocad) | Nein | Ja | Nein
ds4 | Micrografx Designer 4.0 File | Nein | Nein | Ja
dsg | COREL Query File | Nein | Nein | Ja
dsk | Desktop-Datei (C/Pascal/Borland) | Nein | Nein | Ja
dsc | Konfigurationsdatei für Display Treiber unter OS/2 | Ja | Nein | Nein
dsp | Grafiktreiber /Dr Halo) | Nein | Nein | Ja
dsp | Konfigurationsdatei für Display Treiber unter OS/2 | Ja | Nein | Nein
dta | Daten Datei/Datei im ZKA-Format DTAUS (Inlandszahlungen) | Nein | Nein | Ja
dts | Digital Theater System Audio Datei Mehrkanal (DVD) | Nein | Ja | Nein
dtx | Index-Datei (Datenbanken) | Nein | Nein | Ja
dvi | Ausgabedatei | Nein | Ja | Nein
dvp | Programmkonfigurationsdatei (Desqview) | Nein | Nein | Ja
dcw | DCW-Archive | Nein | Nein | Ja
dwg | Mit Autocad erstellte Zeichnung | Nein | Nein | Ja
ebf | Adobe Postscript Treiber | Nein | Nein | Ja
edt | Editor Konfiguration (DOS navigator) | Nein | Nein | Ja
ega | EGA Bildschirmtreiber /Grafikdatei | Ja/Nein | Nein/Ja | Ja
eng | (z.B.: HISTORY of Revision in) English | Nein | Ja | Nein
eps | Micrografx Graphic Engine zum Konvertieren | Ja | Nein | Nein
equ | Word Equipped Symbol Konverter | Ja | Nein | Nein
err | Error, Fehlerdatei beim Erzeugen einer Windows Hilfedatei | Ja | Nein | Ja
ex_ | nicht entpackte Datei (Programm) | Nein | Nein | Ja
exe | Programm (executable) | Ja | Nein | Nein
ext | Extension-Datei des DOS navigator | Nein | Nein | Ja
fax | Fax Datei (PcTools) | Nein | Ja | Nein
fbx | Telix Phone Book | Ja | Nein | Ja
fdl | Formulardatei (Paradox) | Nein | Ja | Nein
fa /ff? | Winword Indizierungsdateien | Nein | Nein | Ja
fhb | ForeHelp Backup | Nein | Ja | Ja
fil | Overlay Datei (WordPerfect)/Applikationsgenerator (DBase) | Nein | Nein | Ja
flc | Videosequenz in erweitertem FLIC-Format | Nein | Ja | Ja
flg | Temporäre Datei des DOS navigator | Nein | Ja | Nein
fli | Videosequenz in speziellem FLIC-Format | Nein | Ja | Ja
flm | Unkomprimierte Bilder (fast) | Nein | Ja | Ja
flt | Graphics Runtime-Modul | Ja | Nein | Nein
flt | Device Treiber Filter für OS/2 | Ja | Nein | Nein
fmt | Format. Druckdatei (MS Schuld)/Bildschirmmaske(DBase) | Nein | Nein | Ja
fnd | gespeicherte Suche im Explorer (Win95) | Nein | Nein | Ja
fnt | DOS -System-Terminal-Schriften (Font) | Ja | Nein | Nein
fnt | Drucker Fonts (OS/2) | Ja | Nein | Nein
fog | Fontographer Schriftenbetrachter-Datei | Nein | Ja | Ja
for | Fortran Quelltext | Nein | Nein | Ja
fon | Font-Dateien (Windows und OS/2) | Ja | Nein | Nein
fot | Normale Schriften und Ergänzung für TrueType-Schriften | Ja | Nein | Nein
fpi | Programmdatei (Navcis) | Nein | Nein | Ja
fpt | Memofeld Liste Foxpro/ Programmdatei (Navcis) | Nein | Nein | Ja
frm | OLE-Automations-Modul/ Formulardateien | Ja/Nein | Nein/Ja | Nein
frs | Font Resource (WordPerfect) | Nein | Nein | Ja
fxd | Fax-Dateien (Winfax) | Nein | Nein | Ja
fxr | Fax-Receive Empfangsdateien (Winfax) | Nein | Nein | Ja
fxs | Fax-Send Sendedateien (Winfax) | Nein | Nein | Ja
gdb | Interbase Datenbank | Ja | Nein | Ja
ged | Vektorgrafik (Arts&Letters) | Nein | Ja | Ja
ger | (z.B.: HISTORY of Revision in German) | Nein | Ja | Nein
gem | Meta Dateien des GEM Betriebssystems v. Digital Research | Nein | Nein | Ja
geo | Applikation / Treiber (Geoworks) | Ja | Nein | Ja
gid | Hilfe Index-Datei | Nein | Ja | Nein
gif | Graphic Interchange Format Grafik Format geschützt von Unisys mit 256 Farben | Nein | Ja | Nein
gr2 | Bildschirmtreiber Datei | Ja | Nein | Ja
gra | Graph 5 - Init Datei | Ja | Nein | Nein
grf | Micrografix Meta Grafik Datei | Nein | Ja | Nein
grp | Programmgruppe unter Windows | Ja | Nein | Nein
hap | HAP-Archive | Nein | Nein | Ja
hdx | Hilfe Index Datei für Delphi | Nein | Ja | Ja
hex | Hexdump | Nein | Ja | Nein
hgl | HP Grahics Language | Ja | Nein | Ja
his | History Datei | Nein | Ja | Nein
hlp | Hilfedatei eines speziellen Programms, Help | Nein | Nein | Ja
hot | Internet-Browser Hotlists | Ja | Nein | Nein
hpg | Druckausgabe Plotter (Harvard Grafics) | Nein | Ja | Ja
hpj | Programm-Datei (WinImage) | Ja | Nein | Ja
hpp | Homepages (mit Homepage Wizard erstellt) | Nein | Nein | Ja
hpw | Homepage Wizard Dateien | Nein | Nein | Ja
hst | Netscape Host-File | Ja | Nein | Nein
ht | Hyperterminal-Systemdatei | Ja | Nein | Nein
htm | Internet Homepage/Datei im html-Format | Ja | Nein | Nein
html | Internet Homepage/Datei im html-Format | Ja | Nein | Nein
icc | Intelligent Color Charting (Farbanpassung f. Drucker) | Ja | Nein | Nein
icm | Intelligent Color Matching Library | Ja | Nein | Nein
ico | Icon-Datei | Nein | Nein | Ja
id | Identifizierungsdatei einer Installationsdiskette | Ja | Nein | Nein
idf | Midi-Instrumenten-Identifikation | Ja | Nein | Nein
idx | Index Datei (DBase,Foxpro) | Ja | Nein | Ja
iff | Amiga Audio oder Grafik-Datei | Nein | Ja | Nein
iI13 | Generischer Int.13-OS/2-Treiber | Ja | Nein | Nein
ima | Disketten Abbild (WinImage) | Nein | Ja | Ja
imc | Disketten Abbild gepackt (WinImage) | Nein | Ja | Ja
img | Bitmap komprimiert (Ventura Publisher) | Nein | Ja | Ja
in_ | nicht entpackte Datei (INI-Datei) | Nein | Nein | Ja
inc | Include Datei (Programmiersprachen) | Ja | Nein | Ja
inf | Datei zur Identifikation von Windows 95-Treibern | Ja | Nein | Nein
inf | Online-Dokumentation unter OS/2; Programm heißt VIEW.EXE | Nein | Ja | Ja
inf | Informationen über den Inhalt gleichnamiger Dateien Iexpl. 4.0. | Nein | Nein | Ja
ini | Initialisierungsdatei eines Programms | Ja | Nein | Nein
int | Borland Unit Interface | Ja | Nein | Ja
inx | Index Datei (Clipper, FoxPro) | Ja | Nein | Ja
isu | Netscape Init-Strings/ Logdatei zur Dienstallation | Ja | Nein | Nein
java | Source der Java Programmiersprache von Sun | Nein | Nein | Ja
jor | Journaldatei SQl | Ja | Nein | Ja
jpe | JPEG-Extended Bild | Nein | Ja | Ja
jpg | JPEG-Bild-Datei komprimiert auch JFIF oder JPEG | Nein | Ja | Ja
jtf | Tiff Grafik mit JPEG Kompression | Ja | Nein | Ja
kbd | Tastaturbelegungs-Modul (Keyboard) | Ja | Nein | Nein
key | interne Makrodateien | Nein | Nein | Ja
kwf | Keyword File (für Delphi Hilfe Dateien) | Ja | Nein | Ja
lbg | Labelgeneratordatei (DBase) | Nein | Nein | Ja
lbl | Labeldatei (DBase) | Nein | Ja | Ja
lda | MS Access: systemspezifische Informationen zur Tabelle | Ja | Nein | Nein
ldb | Init der MS Access Datenbank | Nein | Nein | Ja
les | Lernprogramm (Word) | Nein | Ja | Ja
lex | Lexikon-Datei | Ja | Nein | Nein
lha | Komprimierte Datei im LHA-Format | Nein | Ja | Ja
lnk | Link, Verknüpfung zu einem Programm oder einer Datei | Ja | Nein | Nein
lim | Limit -Archiv | Nein | Nein | Ja
lng | Language resource des DOS navigator | Nein | Nein | Ja
log | Log-Datei (Protokoll) | Nein | Ja | Nein
lqm | Liquid Media Audio und Video Datei | Nein | Ja | Nein
lst | Liste (Textdatei) | Nein | Ja | Nein
gif | Graphic Image Format C 89a (Bild-Datei) | Nein | Ja | Ja
lzh | Komprimierte Datei im LZH-Format | Nein | Ja | Ja
mac | Mac Paint Datei | Nein | ja | Nein
mad | Access Module-Verknüpfung | Nein | Nein | Ja
maf | Access Bericht-Verknüpfung | Nein | Nein | Ja
mah | Mahjongg Konfigurationsdateien (OS/2) | Nein | Ja | Ja
mak | OLE-Pfadzuweisung für COREL / Kompiler Link Anweisung | Ja/Nein | Nein | Nein/Ja
mam | Access Formular-Verknüpfung | Nein | Nein | Ja
map | Debugger und andere MAP Dateien | Nein | Ja | Nein
map | Access Abfrage-Verknüpfung | Nein | Nein | Ja
mat | Access Tabelle-Verknüpfung | Nein | Nein | Ja
mcc | MSN Wählprogramm | Nein | Nein | Ja
mcd | Text (Math CAD) | Nein | Ja | Nein
mda | MS Access systemspezifische Tabelle | Ja | Nein | Nein
mdb | MS Access Datenbank | Nein | Nein | Ja
mdn | Access Systemdatei | Ja | Nein | Nein
mdt | Access Add-In Dateien | Ja | Nein | Nein
mdm | Communication Config Datei des DOS navigator | Nein | Ja | Nein
mdw | Access Workgroups | Ja | Nein | Nein
mdx | DBase Index Datei | Nein | Nein | Ja
mdz | Access Wizard - Hilfe Datei | Ja | Nein | Nein
me | Textdatei (z.B. read.me) | Nein | Ja | Ja
men | Memory,Speichervariablendatei (Clipper, DBase,Foxpro) | Nein | Nein | Ja
mff | Midi-File-Format Sequencer Datei | Nein | Ja | Ja
mid | MIDI-Sound -Datei | Nein | Ja | Ja
mnf | MS Network Suchergebnisse File | Nein | Ja | Nein
mnu | Menüdatei (Norton Commander) (Menu) | Nein | Nein | Ja
mod | Speicheraufteilungsprotokoll | Ja | Nein | Nein
mod | MONO-Digitally-Remastered Audio-File | Nein | Ja | Ja
mov | Movie (Quicktime-Movie-Format) | Nein | Ja | Ja
mp3 | MPEG Audio Datei | Nein | Ja | Nein
mpa | MPEG Audio Datei | Nein | Ja | Nein
mpd | SCSI-Port-Init / NT-Treiber | Ja | Nein | Nein
mpg | Video-File nach MPEG-Standard | Nein | Ja | Ja
ms | Checklist nach Durchlaufen eines Virenchecks | Nein | Ja | Nein
msg | Nachrichtendatei für Netzwerk und Anwendungen | Nein | Nein | Ja
msn | MSN Network File | Ja | Nein | Nein
msp | MS Paintbrush, altes Format | Nein | Ja | Ja
mvs | Infodatei von ISH Shareware | Nein | Ja | Nein
mwf | COREL Move-File (Datei) | Nein | Nein | Ja

Weiter mit Dateiendungen (N - Z)

Umfangreiche Listen mit Dateiendungen und -formaten finden Sie unter den folgenden Links:

Dateiendungen:

http://extsearch.com/

http://filext.com/

http://whatis.techtarget.com/fileFormatA/0,289933,sid9,00.html

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1155.htm


Bedeutung von Dateiendungen (N - Z)

Dateiendungen weisen auf die Funktionalität der einzelnen Dateien hin. Sie unterscheiden sich grob in 3 Klassen:

wichtig | Diese Dateien gehören zum System oder zu bestimmten Programmen. Hier sollten Sie schon etwas besser überlegen, ob Sie diese Datei wirklich löschen können.
löschen | Diese Dateien können Sie ohne Bedenken für das System löschen.
entscheiden | Hier müssen Sie entscheiden, ob Sie diese Datei löschen können. Wenn Sie das Programm nicht mehr benötigen oder die Funktion nie brauchen, können Sie diese Datei löschen.

Zurück zu Dateiendungen (A - M)

Dateiendung | Beschreibung/Typ | wichtig | löschen | entscheiden
nav | MS Network Anwendungen | Nein | Nein | Ja
ndx | Indexdatei (DBase) | Nein | Nein | Ja
ned | MS Network Anwendungen | Nein | Nein | Ja
nfo | ProgrammiNFOrmationen (Text) | Nein | Ja | Ja
nfo | Systeminformationen (MSInfo) | Nein | Ja | Ja
nif | Konfigurationsdatei zur Installation von NDIS-Treibern unter OS/2 Warp Connect, Warp 4 od. LAN Server/Warp Server | Ja | Nein | Nein
nls | Dialer Wählprotokoll | Ja | Nein | Nein
nts | Tutorial-Datei (Norton) | Nein | Ja | Ja
ntx | Indexdatei (Clipper) | Nein | Nein | Ja
nvf | Text-Datei mit Schriften(NAVCIS) | Nein | Ja | Nein
obd | Office 95 Sammelmappen Datei | Ja | Nein | Nein
obt | Office 95 Sammelmappe v | Nein | Nein | Ja
obz | Office 95 Sammelmappe a | Nein | Nein | Ja
ocx | Visual Basic Programmdateien | Ja | Nein | Nein
ofm | Font Metric (Adobe Type Manager) | Nein | Nein | Ja
ofn | Win95 Office Dokumente | Ja | Nein | Nein
obj | Objekt Datei zum Linken (Datenbankprogramme) | Nein | Nein | Ja
olb | Object Library (Grafik Modus) | Ja | Nein | Nein
old | Sicherungskopie einer Systemdatei | Nein | Ja | Nein
opt | Optionen für Delphi | Nein | Ja | Ja
or2 | Lotus Organizer 2.x Datei | Nein | Nein | Ja
org | Lotus Organizer 1.x Datei | Nein | Nein | Ja
os2 | NDIS-Treiber für OS/2 | Ja | Nein | Nein
out | Outfile von OzWin Ii | Nein | Ja | Ja
ovl | Overlay, Tastatur- u. Farbtreiber unter DOS | Ja | Nein | Nein
ovr | Programmcode Overlay | Ja | Nein | Ja
pad | Keypad-Definition (Telemate) | Nein | Nein | Ja
pak | Archivdatei (PAK) | Nein | Ja | Ja
pal | Farbpalette | Nein | Ja | Ja
par | Windows Auslagerungsdatei/ Parameter Datei | Ja/Nein | Nein | Nein/Ja
pas | Pascal Quelltext | Nein | Nein | Ja
pat | COREL Pattern Datei / Gravis Audio Datei | Nein | Nein | Ja
pbk | MSN Network Phonebook (Telefonbuch) | Nein | Nein | Ja
pbm | Portable Bitmap Bilddateien unter Unix | Nein | Ja | Nein
pcd | Kodak Photo CD Grafik | Nein | Ja | Ja
pcl | Druckdatei HP (Printer Control Language) | Nein | Ja | Nein
pct | DOS -Grafik Betrachter / Mac Pict-Grafik | Ja | Nein | Nein
pcx | Paintbrush Bild | Nein | Nein | Ja
pdf | Acrobat Reader Dokument (Portable Dokument Format) | Nein | Nein | Ja
pdr | SCSI-Erkennungs-Modul | Ja | Nein | Nein
pdr | Physical Device Driver (OS/2) | Ja | Nein | Nein
pfb | Schriftart (Adobe Type Manager) | Nein | Nein | Ja
pfm | Font Metric (Adobe Type Manager) | Nein | Nein | Ja
pfp | Fontographer Schriftenbetrachter Datei | Nein | Nein | Ja
phn | Phone Book des DOS navigator | Nein | Nein | Ja
pic | Grafik (PcPaint, Lotus) (picture) | Nein | Ja | Nein
pif | Windows-Informationsdatei (Programm Information File) | Ja | Nein | Nein
pkt | Nachrichten Paket (Fido) | Nein | Ja | Nein
pmc | Grafic (Scanner) | Nein | Ja | Nein
pmm | Programmdatei (Amaris Btx) | Ja | Nein | Ja
png | Ersatz für das Gif Format (Bild-Datei) | Nein | Ja | Nein
pol | Beschreibungsdateien | Ja | Nein | Ja
pot | Office 95 Powerpoint Präsentationsvorlage | Nein | Nein | Ja
ppb | Adobe Postscript Treiber | Nein | Nein | Ja
pps | Office 95 Powerpoint Layouts | Ja | Nein | Nein
ppt | Powerpoint-Präsentation | Nein | Nein | Ja
pr2 | Druckertreiber (DBase) | Ja | Nein | Ja
pre | Präsentation (Lotus) | Nein | Nein | Ja
prf | Normal Color Matching Proof Modul | Ja | Nein | Nein
prg | Purge File von OzWin Ii | Nein | Ja | Ja
prg | Programmdatei (Datenbankprogramme) | Nein | Ja | ein
prn | Druckdatei (PRiNter) | Nein | Ja | Nein
pro | DOS -Display-Modus (abh. v. Grafikkarte) | Ja | Nein | Nein
prt | Druckfertige Datei in MS Schuld + | Nein | Nein | Ja
psd | Adobe Photoshop Bitmap Grafik | Nein | Ja | Nein
pst | COREL Post-Script-Font / Mail Beschreibungen | Ja | Nein | Nein
ptr | Mauszeiger (OS/2) | Ja | Nein | Nein
pub | COREL Ventura Publikation/public Key der elektr. Unterschrift | Nein | Nein | Ja
pul | D-Fax/D-Info Suchkriterien-Initialisierung | Ja | Nein | Nein
pvt | Lokale Pointliste (Fido) | Nein | Ja | Nein
pwl | Symbol Or Password Init (Passwort-Dateien) | Ja | Nein | Nein
pwz | Office 95 Powerpoint Assistent | Ja | Nein | Nein
px | Paradox Index | Ja | Nein | Ja
qab | Gruppendatei (Norton) | Ja | Nein | Ja
qag | Gruppendatei (Norton) | Ja | Nein | Ja
qfx | Faxdatei (QuickLinkFax) | Nein | Ja | Nein
qic | Backup-Datensatz von MS Backup | Ja | Nein | Nein
qtc | Apple Quicktime Video-Identifikation | Nein | Nein | Ja
r01-r99 | Geteiltes RAR Archiv | Nein | Nein | Ja
ra | REAL Audio Sound -File | Nein | Ja | Ja
ram | REAL Audio Mega Quality Sound -File | Nein | Ja | Ja
rar | RAR-Archiv | Nein | Nein | Ja
raw | Audio Rohdaten nicht definiert | Nein | Ja | Nein
rc | Netscape News-File /Resourcescript Windows | Nein | Ja | Ja
rc | Von Makeini.exe verwendete Befehlsdatei (OS/2) | Ja | Nein | Nein
rco | ReachOut Connectiob File | Ja | Nein | Ja
rec | Recordermakro (selbstaufgezeichnetes M.) | Ja | Nein | Nein
reg | Registry-Editor-Liste | Ja | Nein | Nein
reg | Datei requert (Fido) | Nein | Ja | Nein
rem | Bemerkungen (Text Datei) | Nein | Ja | Nein
res | Ressourcen Datei (Programmiersprachen) | Ja | Nein | Ja
rip | Metagraphik (EIPTerm) | Nein | Ja | Nein
rle | Run-length komprimierte Bitmap | Nein | Ja | Nein
rm | Real Media Video, Audio Datei (Real Networks) | Nein | Ja | Nein
rmi | Registred MIDI-File (Microsoft) | Nein | Ja | Nein
rol | Roland Midi Datei | Nein | Ja | Nein
rom | Amiga Kickstart Rom | Nein | Ja | Ja
rsc | Programmdatei (GEM/ FoxPro) | Nein | Nein | Ja
rsp | Response-file zur automatischen Installation (CID)(OS/2) | Ja | Nein | Nein
rtf | Rich-Text-Format Textdateien (in Word lesbar) | Nein | Nein | Ja
sam | Dokumenten-Datei von Ami Pro | Ja | Nein | Ja
sav | Sicherungsdatei (NAVCIS) | Nein | Ja | Nein
scd | MS Schuld + (Systemdatei) | Ja | Nein | Nein
sch | Schuld + zusätzliche Systemdatei | Ja | Nein | Nein
sys | Systemspezifische Dateien | Ja | Nein | Nein
scp | DFÜ-Script Dateien | Ja | Nein | Nein
scr | Bildschirmschoner / Script-Verwaltungs-Dateien | Nein/Ja | Nein | Ja/Nein
scz | Kopie von Schuld+ Systemdateien | Nein | Nein | Ja
sd | Sound Designer Audio Datei Macintosh | Nein | Ja | Nein
sdw | Dokument (Starwriter) | Nein | Ja | Nein
set | Backup-System-Dateien intern | Ja | Nein | Nein
sfr | Sonic Found ry Sample zum Bearbeiten von Audio Dateien | Nein | Ja | Nein
shb | COREL Show Animation | Nein | Nein | Ja
shd | Spool-Datei-Header | Ja | Nein | Nein
shr | Coerl Show RUN Präsentationssequenz | Nein | Nein | Ja
shs | Systeminterne temporäre Datei | Ja | Nein | Nein
shw | COREL Show File | Nein | Nein | Ja
sig | Signatur Text Datei (NAVCIS) | Nein | Ja | Nein
sik | Sicherungskopie (Ms Word) | Nein | Ja | Nein
slc | Salt Code (Teldix) | Nein | Nein | Ja
slk | Excel Datei-Import-File | Ja | Nein | Nein
slt | Salt Programmtext (Telix) | Nein | Nein | Ja
smi | Smarticondefinition (Lotus) | Nein | Nein | Ja
smm | Makro (AmiPro) | Nein | Ja | Nein
smp | Adlib Audio Stereo Datei/ Turtlebeach Mono Audio Datei | Nein | Ja | Nein
snd | Sound -File-Basic | Nein | Ja | Ja
snp | Konfigurations-Snooper im OS/2 Warp 4 | Ja | Nein | Nein
spl | Spool-Datei-Inhalt | Ja | Nein | Nein
sqz | SQZ Archiv-Datei | Nein | Nein | Ja
sts | Status nach Durchlaufen von MEMMAKEr | Nein | Ja | Nein
sty | Druckformatvorl.(Word) /Style Datei (Ami Pro) | Nein | Nein | Ja
swp | Windows 95 Auslagerungsdatei | Ja | Nein | Nein
sy_ | nicht entpackte Datei (Systemdatei) | Nein | Nein | Ja
syd | SYnonymDaten von diversen Full Text Search Engines, z.B bei Lotus Notes und Adobe Acrobat | Nein | Nein | Ja
tar | Komprimierte Datei im TAR-Format | Nein | Ja | Ja
taz | Komprimierte Datei im TAR-Format | Nein | Ja | Ja
tbs | Textbaustein (Word) | Nein | Ja | Nein
tco | Spea Setup Protokoll | Nein | Nein | Ja
tdw | Turbo Debugger for Windows Configuration File | Nein | Ja | Ja
tex | Dokument (TeX Source) | Nein | Ja | Nein
tga | Targa Format (Bild-Datei) | Nein | Ja | Ja
thn | Thumbnail (Miniaturbild aus Graphic Workshop 1.x) | Nein | Ja | Ja
tif | Tagged Image Format (Bild-Datei) | Nein | Ja | Ja
tlb | Type-Library (z.B. für COREL od. andere Grafikprg.) | Ja | Nein | Nein
tmp | Temporäre Datei | Nein | Ja | Nein
tms | Scriptdatei (Telemate) | Nein | Ja | Nein
tpc | Telix Terminal Konfigurationen | Ja | Nein | Ja
tpl | MIDI-Template | Ja | Nein | Nein
tre | Verzeichnisbaum Datei, Tree | Nein | Nein | Ja
trm | Êinstellung für Terminalprogramm | Ja | Nein | Nein
trn | ASCII-Code-Modul | Ja | Nein | Nein
tsk | Task File Description | Ja | Nein | Nein
ttf | True-Type Fonts (skalierbare WYSIWYG-Schriftarten) | Ja | Nein | Nein
txt | Textdatei | Nein | Nein | Ja
uc2 | Ultra Compressor Datei | Nein | Nein | Ja
url | Internet Adresszuweisungs-Datei (Uniform Ressource Locator) | Ja | Nein | Nein
UU? | Kodierte Binärdatei für den Internet-Versand ?=beliebiges Zeichen | Nein | Nein | Ja
val | Paradox Tabellenaufbau | Nein | Ja | Ja
vbx | Visual Basic Library | Ja | Nein | Nein
voc | Creative Labs Stereo Audio Datei | Nein | Ja | Nein
vcp | Disketten Image (VGACOPY) | Nein | Nein | Ja
vdd | Virtual Device Driver | Ja | Nein | Nein
vew | Datenbank (Lotus) | Nein | Nein | Ja
vid | Visual Basic Identifikation (Treiber) | Ja | Nein | Nein
voc | Vocal Sound File (Creative) | Nein | Ja | Ja
vor | Dokumentenvorlage (Starwriter) | Nein | Nein | Ja
vrs | Video Ressourcen (WordPerfect) | Nein | Nein | Ja
vue | Validating Password-File (Windows 95) | Ja | Nein | Nein
vwr | Viewers Config Datei des DOS navigator | Nein | Nein | Ja
vxd | Windows-spezifische Treiber | Ja | Nein | Nein
w31 | Sicherungsdateien z. Wiederherst. v. Windows 3.1 | Ja | Nein | Nein
w95 | wichtige Windows 95 Backups | Ja | Nein | Nein
wav | Wave Audio-Datei (Geräusche in Windows) | Nein | Nein | Ja
wbk | MS Word KBench Sicherungskopie | Nein | Nein | Ja
wbx | Visual Basic Programm-Dateien | Ja | Nein | Ja
wdb | Datenbank (Works) | Nein | Nein | Ja
wfx | Fax Datei (Winfax) | Nein | Nein | Ja
wiz | MS Word Wizard Assistent | Ja | Nein | Nein
wks | Ms Works Datei (Tabellenkalkulation) | Nein | Nein | Ja
wll | MS Word Add-In | Ja | Nein | Nein
wma | Windows Media Audio auch Video | Nein | Ja | Nein
wmf | Windows Meta File (Clipart-Grafikdatei) | Nein | Nein | Ja
wpg | DOS -Bild / WordPerfekt Grafik Format | Nein | Nein | Ja
wpk | Makro (WordPerfect) | Nein | Ja | Nein
wpm | Makro (WordPerfect) | Nein | Ja | Nein
wps | Write-Personal-Script Or Text-File | Nein | Nein | Ja
wpx | Adobe Postscript Druckerdateien | Ja | Nerin | Ja
wri | Text im Write-Format (Word-Pad) | Nein | Nein | Ja
wrk | Cakewalk Pro Sequence File | Nein | Nein | Ja
wrl | Veralm 3D-Welten-Datei | Ja | Nein | Nein
xbm | Internet Image (Autoload) | Nein | Nein | Ja
xla | Excel Add-In Dateien | Ja | Nein | Nein
xlb | MS Excel-Datei | Nein | Nein | Ja
xlc | Excel Chart (Diagramm) | Nein | Nein | Ja
xld | Excel Dialog Datei | Ja | Nein | Nein
xlk | Excel Sicherungsdatei | Nein | Ja | Nein
xll | Excel XLL-Add-In | Ja | Nein | Nein
xlm | Excel Makrovorlage | Ja | Nein | Nein
xls | Excel Tabelle | Ja | Nein | Nein
xlt | Excel Template (Vorlage) | Nein | Nein | Ja
xlv | Excel Visual Basic Modul | Ja | Nein | Nein
xlw | Excel Workgroups | Ja | Nein | Nein
xrn | Quick run Config des DOS navigator | Nein | Nein | Ja
xof | Vrml Viewer Object | Nein | Ja | Ja
zip | Komprimierte Datei im ZIP-Format | Nein | Ja | Ja
zoo | Archiv Datei (ZOO) | Nein | Ja | Nein

Umfangreiche Listen mit Dateiendungen und -formaten finden Sie unter den folgenden Links:

Dateiendungen:

http://extsearch.com/

http://filext.com/

http://whatis.techtarget.com/fileFormatA/0,289933,sid9,00.html

Dateiformate:

http://www.wotsit.org/

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1262.htm


Aufbau des SDDL Formates

Hier wird der Aufbau des SDDL (Service Descriptor Definition Language) Formates beschrieben. Hiermit können entsprechende Sicherheitsinformationen gesetzt werden, wie sie z.B. vom Befehl SC benutzt werden.

Beispiel:

D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)

O:owner_sid

G:group_sid

D:(dacl_flags)(dacl_flags)...

S:(sacl_flags)(sacl_flags)...

Aufbau eines dacl_flags

[ACE Type];[ACE Flags];[Rechte];[SID];;[Trustee]

ACE Type:

Parameter | Beschreibung
A | ACCESS ALLOWED
D | ACCESS DENIED
OA | OBJECT ACCESS ALLOWED: ONLY APPLIES TO A SUBSET OF THE OBJECT(S).
OD | OBJECT ACCESS DENIED: ONLY APPLIES TO A SUBSET OF THE OBJECT(S).
AU | SYSTEM AUDIT
AL | SYSTEM ALARM
OU | OBJECT SYSTEM AUDIT
OL | OBJECT SYSTEM ALARM

ACE Flags:

Parameter | Beschreibung
CI | CONTAINER INHERIT: Child objects that are containers, such as directories, inherit the ACE as an explicit ACE.
OI | OBJECT INHERIT: Child objects that are not containers inherit the ACE as an explicit ACE.
NP | NO PROPAGATE: ONLY IMMEDIATE CHILDREN INHERIT THIS ACE.
IO | INHERITANCE ONLY: ACE DOESN'T APPLY TO THIS OBJECT, BUT MAY AFFECT CHILDREN VIA INHERITANCE.
ID | ACE IS INHERITED
SA | SUCCESSFUL ACCESS AUDIT
FA | FAILED ACCESS

Rechte:

Parameter | Beschreibung
Allgemeine Rechte::
GA | GENERIC ALL
GR | GENERIC READ
GW | GENERIC WRITE
GX | GENERIC EXECUTE
Verzeichnisservice Rechte:
RC | Read Permissions
SD | Delete
WD | Modify Permissions
WO | Modify Owner
RP | Read All Properties
WP | Write All Properties
CC | Create All Child Objects
DC | Delete All Child Objects
LC | List Contents
SW | All Validated Writes
LO | List Object
DT | Delete Subtree
CR | All Extended Rights
Dateirechte:
FA | FILE ALL ACCESS
FR | FILE GENERIC READ
FW | FILE GENERIC WRITE
FX | FILE GENERIC EXECUTE
Registryrechte:
KA | KEY ALL ACCESS
KR | KEY READ
KW | KEY WRITE
KX | KEY EXECUTE

Trustee

Parameter | Beschreibung
AO | Account operators
RU | Alias to allow previous Windows 2000
AN | Anonymous logon
AU | Authenticated users
BA | Built-in administrators
BG | Built-in guests
BO | Backup operators
BU | Built-in users
CA | Certificate server administrators
CG | Creator group
CO | Creator owner
DA | Domain administrators
DC | Domain computers
DD | Domain controllers
DG | Domain guests
DU | Domain users
EA | Enterprise administrators
ED | Enterprise domain controllers
WD | Everyone
PA | Group Policy administrators
IU | Interactively logged-on user
LA | Local administrator
LG | Local guest
LS | Local service account
SY | Local system
NU | Network logon user
NO | Network configuration operators
NS | Network service account
PO | Printer operators
PS | Personal self
PU | Power users
RS | RAS servers group
RD | Terminal server users
RE | Replicator
RC | Restricted code
SA | Schema administrators
SO | Server operators
SU | Service logon user

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2031.htm


Begriffe von Active Directory

Hier werden einige Begriffe erläutert, die immer im Zusammenhang mit Active Directory benutzt werden.

Objekt:

Durch ein Objekt werden Attribute zusammengefasst, die eine bestimmte Sache darstellen (Benutzer, Drucker usw.). So würden z.B. die einzelnen Attribute eines Benutzers (Name, Vorname, Telefonnummer, E-Mail usw.) zusammen das Objekt darstellen.

Container:

Ein Container verfügt zwar auch über einzelne Attribute, stellt aber nicht wie ein Objekt etwas Bestimmtes dar. So enthält ein Container andere Container oder eine Gruppe von Objekten. Ein Computer oder eine Domäne ist z.B. ein Container. Auch ein einfaches Verzeichnis stellt schon einen Container da.

Name:

Durch einen Namen wird ein Objekt bezeichnet und kann darüber angesprochen werden. Im Active Directory gibt es zwei Arten von Namen.

  1. DN (Distinguished Name)
    Jedes Objekt besitzt so einen DN Namen. Ein DN enthält den vollständigen Namen und Pfad (Container + Struktur) von einem Objekt. Ein gültiger DN Name sieht ungefähr so aus:
    /O=Internet /DC=DE /DC=WINFAQ /CN=FAQ /CN=WINFAQ.ZIP
  2. RDN (Relative Distinguished Name)
    Dieser Name bezeichnet ein bestimmtes Attribut eines Objektes. In obigen Beispiel ist "CN=WINFAQ.ZIP" der RDN-Name des Objekts.

Domänen:

Active Directory besteht aus mindestens einer Domäne. Eine Domäne kann sich aus einem Rechner oder mehreren Rechnern zusammensetzen. In jeder Domäne gibt es eine Sicherheitsrichtlinie, die durch Sicherheitsbeziehungen mit anderen Domänen wiederum verknüpft werden können.

Domänenstrukturen:

Mehrere Domänen, die zusammengefasst werden und ein gemeinsames Schema und eine gemeinsame Konfiguration benutzen und somit ein zusammenhängendes "Namespace" bilden, ergeben eine Domänenstruktur.

Struktur (Tree):

Durch die Struktur werden logische Verbindungen zu den Containern dargestellt (wie z.B. in einem Verzeichnisbaum).
Strukturen können unter Windows von zwei Seiten betrachtet werden:

  1. Betrachtung über Vertrauensstellungen
    Sie können eine Domänenstruktur anhand der Vertrauensstellungen untereinander erstellen. Für Vertrauensstellungen wird unter NT das neue Sicherheitsprotokoll "Kerberos" verwendet.
    Beispiel:

    DOMÄNE A <-> DOMÄNE B
    DOMÄNE B <-> DOMÄNE C

    In diesen Beispiel wurden zwei direkte Vertrauensstellungen eingerichtet und zwar zwischen Domäne A und B und zwischen Domäne B und C.
    Durch das Kerberos-Sicherheitsprotokoll entsteht nun noch eine zusätzliche Vertrauensstellung zwischen Domäne C und A.
  2. Betrachtung über Namespace
    Sie können aber auch eine Domänenstruktur anhand des Namespace erstellen. Dadurch erhalten Sie eine Hierarchie, die Sie vom Stamm des Namespace aus durchsuchen können.

Beispiel:
root.de (Domäne A) -> subRoot.de (Domäne B) -> unterRoot.de (Domäne C)

Gesamtstrukturen (Forest):

Hier werden mehrere Strukturen, die keinen gemeinsamen Namespace haben, zu einer Gesamtstruktur zusammengefasst. Sie verwenden aber alle ein gemeinsames Schema, eine gemeinsame Konfiguration und einen "global Katalog".

Es gibt also in jedem Active Directory mindestens immer eine Gesamtstruktur, auch wenn es nur eine Struktur gibt. Mehrere Gesamtstrukturen in einer Organisation sind aber nicht erlaubt und auch nicht sinnvoll, da zwischen einzelnen Gesamtstrukturen keine automatische Synchronisation möglich ist.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0910.htm


Was ist Active Directory?

Diese Anleitung soll nur im Groben das "Active Directory" beschreiben. Für genauere Erläuterungen müssen Sie auf die Beschreibungen von MS oder Büchern von anderen Firmen zum "Active Directory" zurückgreifen. (siehe dazu: Infos und Whitepapers von Microsoft oder Buchvorstellungen in dieser FAQ)

Unter Windows 2000 wurde ganz neu das "Active Directory" eingeführt; es ist ein Verzeichnisdienst von MS (wie die NDS von Novell). Hierdurch wurden die einzelnen Verzeichnisdienste von Windows NT abgelöst und erheblich durch weitere Funktionen erweitert.

- Ersetzt die SAM als Userdatenbank

- Wird zentraler Verzeichnisdienst für alle Objekte (Drucker, Rechner, User usw.) in einer Domäne

- Ist hierarchisch gegliedert

Was müssen Sie sich unter einem Verzeichnisdienst vorstellen?

Ein Verzeichnisdienst ist eine einfache Informationsquelle, in der Informationen über Objekte abgelegt werden (etwa genauso wie in einem Telefonbuch die Telefonnummern zu bestimmten Namen abgelegt werden). In diesen Verzeichnisdienst werden nun alle Objekte die es in einem Netzwerk geben kann (Faxgeräte, Drucker, Dateien, Benutzerangaben usw.) abgelegt (wie in einer großen Datenbank).

Durch diesen Verzeichnisdienst ist ein Netzwerk für Administratoren und auch für die Anwender leichter zu benutzen. Wenn Sie ein Objekt (z.B. einen Drucker) in einem Netzwerk suchen, ist ihm meist nicht der aktuelle Name bekannt, unter dem der Drucker im Netzwerk angelegt wurde, oft kennt man aber bestimmte Attribute (Standort, Typ usw.). Da in einen Verzeichnisdienst zu jeden Objekt bestimmte Attribute mit abgelegt werden, kann man einfach nach diesen Attributen suchen (z.B. könnten Sie folgende Suchanweisung auf das Active Directory anwenden: "Zeige mir alle Farbdrucker im Hause xy an"). Sie würden jetzt eine Liste der zutreffenden Objekte (Drucker) angezeigt bekommen, die diesen Anforderungen entsprechen.

Das Active Directory ist also in erster Linie ein "Namespace". Bei einem Namespace handelt es sich um einen Bereich, in dem ein Name aufgelöst werden kann (wie in einem Telefonbuch ein Name durch eine Telefonnummer aufgelöst wird).

Info Durch Active Directory stellt MS erstmals eine sinnvolle Möglichkeit zu Verfügung, um auch große Netzwerke kostengünstig und übersichtlich verwalten zu können.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0465.htm


Was sind OU (Organizational Units)?

Organizational Units (kurz OU) sind abgegrenzte Organisationseinheiten, die delegiert werden können. Folgendes kann zu OU zusammengefasst werden:

- Anwender

- Drucker

- Anwendergruppen

- Computer

- Verzeichnisfreigaben

- Anwendungen

- Andere OUs

- Policies (Berechtigungen)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1014.htm


Was ist Floating Single Master Operations (FSMO)?

Was ist "Flexible Single Master Operations" (FSMO)?

Active Directory ist als Multimaster-Verwaltungsmodell aufgebaut. Dadurch können Inhalte von mehreren Servern gleichzeitig bearbeitet werden. Da das dazu führen kann, dass Daten gleichzeitig verändert werden, muss es Dienste (Funktionen) geben, die nur auf einem Master-Rechner ausgeführt werden dürfen. Dieser Rechner wird in einem Netzwerk als "Flexible Single Master Operations" (FSMO) bezeichnet. Einen FSMO gibt es nur einmal in einer Domäne und er ist zwingend erforderlich.

Sie können die Funktion des FSMO jederzeit auf einen anderen Computer übertragen. Starten Sie dazu einfach die MMC mit dem Snap-In "Active Directory Schema Manager", klicken Sie mit der rechten Maustaste auf den gewünschten Domänencontroller und wählen Sie den neuen Betriebsmaster (FSMO) aus.

Folgende Funktionen können nur auf einem FSMO ausgeführt werden:

- Domain Naming Master (Geltungsbereich: Gesamtstuktur)

- Infrastruktur Master (Geltungsbereich: Domänenweit)

- PDC Emulator (Geltungsbereich:Domänenweit)

- RID Master (Geltungsbereich:Domänenweit)

- Schema Master (Geltungsbereich: Gesamtstruktur)

Info Der FSMO ist in der Domäne einer der wichtigsten Server, weshalb Sie wissen sollten wie man bei einem Ausfall einen anderen Server zum FSMO macht (das Tool NTDSUTIL aus dem MS Resource Kit kann dafür sehr gute Dienste leisten).

Info Ist der FSMO in einer Domäne nicht mehr verfügbar, erhält nicht automatisch ein anderer Server diese Aufgabe!

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0821.htm


Was ist ein RID-Master?

Da für jedes Objekt in Windows 2000 eine SID (Security Identifier)benötigt wird, um das Objekt bei Sicherheitsanfragen eindeutig identifizieren zu können, muss es in jeder Domäne einen RID-Master (Relative Identifier) geben, der sich immer auf dem FSMOder Domäne befindet.

Da die SID innerhalb einer Domäne eindeutig sein muss und auf keinen Fall zweimal vorkommen darf, muss der RID-Master darauf aufpassen, dass eine SID nur einmalig vergeben wird.

Der RID-Master verwaltet einen Pool mit RID-Werten.

Wird in einem Netzwerk ein neuer Domänen-Controller hinzugefügt, bekommt er automatisch von RID einen Teilsatz von 512-SID Werten zugeordnet. Dieser Bereich wird vom RID für diesen neuen Domänen-Controller reserviert und an keinen anderen weitergegeben. Der Domänen-Controller kann nun selbständig SID-Nummern aus diesem Pool von 512-Werten vergeben.

Hat der Domänen-Controller weniger als 100 freie Nummer übrig, fordert er vom RID-Master einen neuen Pool von Nummern an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1149.htm


Installation des Active Directory

Unter Windows NT war es bis jetzt nicht möglich, einen Stand-Alone (Member-Server) in einen Domain Controller umzuwandeln. Diese Funktion wurde bei der Installation festgelegt und konnte nicht mehr geändert werden.

Ab Windows 2000 haben Sie die Möglichkeit durch das Programm "DCPROMO.EXE" (Assistent zum Installieren von Active Directory) einen Member Server zu einen Domain Controller umzuwandeln, ohne den Server neu installieren zu müssen.

Da hierbei das Active Directory installiert wird, müssen folgende zwei Dinge vorhanden sein:

  1. Ein DHCP-Server
  2. Ein DNS-Server (kann zwar auch automatisch durch "DCPROMO.EXE" mit eingerichtet werden, ist aber bei den meisten Netzwerken nicht zu empfehlen!)

Sollte das nicht der Fall sein, müssen Sie diese Dienste vorab installieren, entweder auf den gleichen Server oder auf einen anderen Server in Ihrem Netzwerk.

Wenn diese Bedingungen erfüllt sind, gehen Sie zur Installation des Active Directory folgendermaßen vor:

  1. Starten Sie das Programm "DCPROMO.EXE" aus dem Verzeichnis "%SYSTEMROOT%\system32"
  2. Bestätigen Sie den Informationsbildschirm
  3. Sie haben jetzt zwei Möglichkeiten:
    a) "New domain" -> DomänenController für eine neue Domäne
    b) "Replica domain controller in existing domain"-> Zusätzlicher DomänenController für eine bestehende Domäne
  4. Wenn es sich um den ersten Domänencontroller in Ihren Netzwerk handelt, müssen Sie selbstverständlich "New domain" auswählen
  5. Sie haben jetzt wieder die Möglichkeit zwischen:
    a) "create a new domain tree" -> Eine neue Domänenstruktur erstellen
    b) "Create new child domain" -> Eine neue untergeordnete Domänenstruktur in einer bestehenden Domänenstruktur einrichten.
  6. Auch hier müssen Sie bei Ihrem ersten Domänenkontroller "Create new child domain" auswählen.
  7. Jetzt werden Sie gefragt ob Sie einen neuen FOREST (Gesamtstruktur) erstellen wollen:
    a) "Create a new forest of domain trees"-> Neue Gesamtstruktur aus Domänenstruktur erstellen.
    b) "put this new domain tree in an existing forest" -> Diese neue Domänenstruktur in eine bestehende Gesamtstruktur eingliedern (hiermit können Sie sich einer bestehende Domänen Struktur anschließen und eine Vertrauensstellung erzielen).
  8. Auch hier müssen Sie bei Ihrem ersten Domänenkontroller wieder die erste Auswahl "create a new forest of domain trees" bestätigen.
  9. Jetzt werden Sie nach den DNS-Namen für die neue Domäne gefragt, geben Sie hier den DNS-Namen ein.
  10. Jetzt müssen Sie noch den NetBIOS -Domänennamen angeben. Dieser Name kann z.B. die ersten 15 Zeichen des DNS Namens sein oder auch ein beliebiger anderer Name.
  11. Sie müssen jetzt das Verzeichnis für das "Active Directory" (Datenbank) und das "Active Directory Log" (Protokolldatei) angeben.
  12. Jetzt müssen Sie noch einen Bereich angeben, auf dem NTFS 5.0 SYSVOL abgelegt werden soll. Standardmäßig wird hier "%SYSTEMROOT%\SYSVOL" vorgeschlagen.
  13. Nun wird der DNS-Server überprüft. Active Directory benötigt unbedingt einen DNS-Server, der an dieser Stelle automatisch eingerichtet werden kann. Diese automatische Funktion sollten Sie an dieser Stelle aber nicht benutzen, da hier der DNS-Server nur auf den gleichen Server installiert werden kann. Aus Gründen der Lastverteilung sollte in einem Netzwerk der DNS-Severr aber lieber auf einem extra Server installiert werden.
    a) "Ja, DNS automatisch auf diesem Computer installieren und konfigurieren"
    B) "Nein, DNS selber installieren und konfigurieren"
  14. Wählen Sie hier also "Nein, DNS selber installieren und konfigurieren" aus.
  15. Jetzt wird gefragt mit welchen Berechtigungen gearbeitet werden soll, Sie haben die Möglichkeit zwischen:
    a) Mit Windows NT 3.5x/4.0-Server kompatiblen Berechtigungen
    b) Nur mit Windows 2000-Server kompatible Berechtigungen.
  16. Wenn es Ihr Netzwerk zulässt und Sie nur 2000 Rechner im Netzwerk haben, sollten Sie die zweite Auswahlmöglichkeit wählen.
  17. Sie werden jetzt nach dem Administrator-Passwort für den "ActiveDirectory Server Restore Modus" gefragt.
  18. Alle Einstellungen werden noch einmal angezeigt und Sie können die Konvertierung bestätigen.

Info Wenn der Server fertig konfiguriert ist, muss Windows neu gestartet werden, damit Active Directory Server aktiviert wird.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0533.htm


DNS-Server für Active Directory, was ist dabei zu beachten?

Für Active Directory wird unbedingt ein DNS-Server benötigt. Normalerweise ist ein DNS-Server in einem Netzwerk für die Namensauflösung zuständig (wenn also ein Browser auf die Seite www.winfaq.de zugreifen will, liefert ein DNS-Server die dazugehörige IP-Adresse, damit der Browser auf die Seite zugreifen kann).

Windows benutzt den DNS-Server aber nicht nur zur Namensauflösung, sondern auch um Dienste und Ressourcen (Domänen-Controller usw.) im Netzwerk zu finden. Dieses ist ein neuer Standard, der aber noch nicht von allen DNS-Server unterstützt wird. Diese zusätzlichen Einträge "SRV-Records" werden von Windows 2000 automatisch in dem DNS-Server eingetragen, weshalb dieser DNS-Server das "Dynamic DNS" oder kurz als DDNS bezeichnet unterstützen muss.

Deshalb kann auch nicht irgendein beliebiger DNS-Server verwendet werden. Windows 2000 braucht für Active Directory einen DDNS-Server. Hier kann Windows automatisch die Dienste registrieren und der Administrator braucht sich um diese Aufgabe nicht mehr zu kümmern. Theoretisch würde es auch ohne DDNS-Server gehen, wenn die Dienste von Hand registriert werden. Aufgrund der vielen Angaben und der großen Fehleranfälligkeit ist das aber wirklich nur eine theoretische Möglichkeit.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0820.htm


Nützliche Tools für Active Directory

Active Directory Sizer Tool

Mit diesen Tool können Sie recht einfach und komfortabel die benötigte Hardware berechnen, die Sie für das Netzwerk benötigen. Es wird Ihnen sehr ausführlich und zuverlässig aufgeführt was für Server mit welcher Ausstattung benötigt werden und welche Aufgaben die Server im Netzwerk ausführen werden. Dafür müssen Sie vorab Fragen über das bestehende Netzwerk und der Firmengröße beantworten.

Für die Planung eines Windows 2000 Netzwerkes mit Active Directory ist dieses Tool sehr gut zu gebrauchen.

Link: http://www.microsoft.com/downloads/details.aspx?FamilyID=77c0a895-3dfc-469f-be40-6a0ee594821c&displaylang=en&Hash=FRL7SL4

Active Directory Migration Tool

Active Directory Migrationsprogramm.

Mit dem Active Directory Migrationsprogramm können Sie Windows NT 4.0-Domänen zu Windows 2000 - Active Directory migrieren.

Link: http://www.microsoft.com/windows2000/downloads/tools/admt/default.asp

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0978.htm


Domänenstruktur

Das Active Directory ist ein Verzeichnis von Informationen interessanter Objekte in einem Netzwerk.

Beispiele solcher Objekte sind Benutzer, Laufwerke, Drucker, Anwendungen und Richtlinien. Das Active Directory ist aus dem X.500 Modell abgeleitet und verwendet Domain Name System (DNS) und Lightweight Directory Access Protocol (LDAP).

Darüber hinaus bietet das Active Directory weitere Funktionalitäten wie Adressverzeichnis für Mail-Clients, Routing für Mail-Server, Verwaltung von Sicherheitszertifikaten und Integration und Konfiguration von Netzwerkkomponenten.

Heute gibt es Netzwerk- und Applikationsdirectories. Active Directory hat das Ziel, ein Enterprise Directory zu werden. Die Gartner Group definiert ein Enterprise Directory über folgende Eigenschaften:

  • Einziges, unternehmensweites Directory (Stichwort: „Single sign on“)
  • Zugriffssicherheit:
  • Der Zugriff auf Einträge muss über definierte Rechte abgesichert sein.
  • Flexible Verwaltung von Einträgen:
  • Administratoren, Entwicklungsabteilungen und dritte Softwarehersteller haben die Möglichkeit nach Bedarf neue Objekte zu generieren.
  • Interoperabilität:
  • Dokumentierte Standards ermöglichen den Zugriff auf Einträge im Verzeichnis.
  • Skalierbarkeit
  • Ausfallsicherheit.

Die logische Struktur des Active Directory stützt sich auf eine DNS-Baumstruktur, eine X.500-Baumstruktur, Objekte und Attribute.

Ein Objekt ist eine eindeutig definierte Ansammlung von Attributen, die eine Netzwerkressource repräsentieren. Objektattribute sind charakteristische Merkmale von Objekten, z.B. beinhalten Attribute eines Benutzer Konto-Objekts den Namen des Benutzers, den Vornamen des Benutzers und den Logon Namen. Die Werte (Values) der Attribute definieren spezifische Objekte.

Das Schema definiert die Klassen der Objekte und deren Attribute im Active Directory. Durch Modifikation des Schemas können neue Objektklassen erstellt oder bestehende verändert werden.

Der Global Catalog ist ein Repository an Informationen, in der einige wenige Attribute aller Objekte des Active Directory vorhanden sind, die für Abfragen im Active Directory benötigt werden. Diese können bei Bedarf ergänzt oder erweitert werden. Durch den Global Catalog Server ist es möglich alle Objekte im Active Directory zu lokalisieren.

Das Active Directory setzt sich aus Domänen zusammen. Eine Domäne ist eine logische Gruppe von Servern und anderen Netzwerkressourcen unter einem gemeinsamen Domänennamen und einer gemeinsamen Sicherheitsstruktur.

Zur logischen Strukturierung innerhalb einer Domäne werden Organisational Units (OUs) verwendet. Eine OU ist ein Container-Objekt, dass andere Container Objekte, Benutzer, Gruppen, Printer ...etc. enthalten kann. Durch Aufbau einer OU Hierarchie, lässt sich die organisatorische Struktur eines Unternehmens abbilden. Auf jedes OU Objekt lassen sich dezidierte, administrative Rechte vergeben, die auf darunter liegende Objekte vererbt werden können. Detailliertere Informationen über den Aufbau von OU Hierarchien befinden sich in Abschnitt 2.1.2.

Mehrere Domänen lassen sich zu einem Baum (Tree) verbinden. Dadurch ist der Aufbau einer hierarchischen Domänenstruktur möglich. Wenn eine Domäne zu einem bestehenden Baum hinzugefügt wird, so entsteht eine Tochter Domäne mit einer entsprechenden DNS Namensbezeichnung.

Mehrere Domänenbäume lassen sich zu einem sog. 'Wald' (Forest) zusammenfassen. Damit ist ein Active Directory ein hierarchisch gegliederter Domänennamensraum, der aus einem oder mehreren Domänenbäumen besteht.

Jedes Active Directory benötigt Domain Controller, die folgende fünf Aufgaben erfüllen.

  • Schema Master
  • Domain Naming Master
  • Relativ Identifier (RID) Master
  • Primary Domain Controller (PDC) Emulator
  • Infrastructure Master

Der Schema Master kontrolliert alle Updates und Modifikationen am Schema. Es kann im gesamten Wald nur einen Schema Master geben.

Info ANMERKUNG: Ein DC, dessen Schema Masterfunktion übernommen wurde, darf nie wieder online geschaltet werden.

Der Domain Naming Master überprüft das Hinzufügen und Entfernen von Domänen innerhalb des Waldes. Auch den Domain Naming Master gibt es nur einmal innerhalb des gesamten Waldes.

Wenn Benutzer, Gruppen oder Computer Objekte erstellt werden, erhält jedes dieser Objekte einen eigenen Security Identifier (SID). Diese SID besteht aus einer Domain SID, die bei allen Objekten innerhalb einer Domäne gleich istund einer RID, die einzigartig für jede SID ist. Der RID Master ist zuständig für die Vergabe und Verwaltung der RIDs pro Domäne.

Innerhalb einer Domäne mit Downlevel Clients oder Windows NT BDCs ermöglicht der PDC Emulator die Synchronisation und Replikation von Updates zu den BDCs.

Im „einheitlichen Modus“ ist der PDC Emulator der bevorzugte Replikationspartner aller anderen Windows 2000 Domain Controller.

Fehler bei der Authentifizierung, die auf einem bestimmten Domänencontroller in einer Domäne auf Grund eines fehlerhaften Kennwortes auftreten, werden zum PDC Emulator weitergeleitet, bevor dem Benutzer eine Meldung zu einem Kennwortfehler angezeigt wird. Erst wenn auch der PDC Emulator der Benutzer nicht authentifizieren kann wird der Anmeldeversuch zurückgewiesen.

Die Kennwortsperrung wird auf dem PDC - Emulator verarbeitet.

Der Infrastructure Master ist für das Update der User – Gruppenbeziehung verantwortlich.

Das Active Directory verwendet DNS und LDAP als Zugriffsprotokolle. So wohl DNS als auch LDAP sind Internet-Standards und basieren auf IP.

Ein DNS-Namensraum dient der Namenauflösung in IP - Adressen. Im Internet wird DNS zur Namensauflösung verwendet. Daher ist das Internet ein weltweiter DNS - KBone. Eine Erweiterung des DNS ist „Dynamic DNS“. Active Directory ist auf die Nutzung von „Dynamic DNS“ ausgelegt.

LDAP ist ein verbreitetes Verzeichnis-Zugriffsprotokoll, das alle wichtigen Directory-Hersteller unterstützen. LDAP legt eine Namenskonvention für Directory-Objekte fest. Der Internet-Standard LDAP v. 3 umfasst keine Definition für die Verzeichnisreplikation. Active Directory unterstützt die Internet-Standards LDAP v. 2 und v. 3.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1504.htm


OU Strukturen und Aufgabenverteilung

Zur logischen Strukturierung innerhalb einer Domäne werden sog. Organisational Units (OUs) verwendet. Eine OU ist ein Container Objekt, dass andere Container Objekte, Benutzer, Gruppen, Printer ...etc. enthalten kann. Auf jedes OU Objekt lassen sich deziderte, administrative Rechte vergeben, die auf die darunter liegenden Objekte vererbt werden können. Durch Aufbau einer OU Hierarchie, lässt sich die organisatorische Struktur eines Unternehmens abbilden. Eine Vielfalt von Modellen ermöglicht es, genau die OU Hierarchie aufzubauen, die der Unternehmensstruktur am besten entspricht. Nachfolgend sind mögliche OU Modelle dargestellt:

  • Geographisches Modell
  • Objektbasiertes Modell
  • Kostenbasierendes Modell
  • Projektbasierendes Modell
  • Business Unit Modell
  • Administrations- Modell

Diese Modelle können Beispiele und Grundlage eines unternehmensspezifischen Active Directory Modells sein. In vielen Fällen führt eine Kombination dieser Modelle zur logischen Abbildung der Unternehmensstruktur.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1505.htm


Geographisches Modell

Das Geographische Modell basiert auf der Strukturierung nach geographischen Standorten. Bei einem Unternehmen mit zahlreichen weltweiten Standorten repräsentieren die First Level OUs die Globalen Standorte. Die Second Level OUs stellen die Lokalen Standorte innerhalb der entsprechenden Globalen Standorte dar.

Vorteile:

  • Im Gegensatz zu anderen Modellen kommt es zu einer wesentlich geringeren Veränderungsrate auf der ersten OU Ebene.
  • Veränderungen im Unternehmens- Netzwerk beeinflussen die logische OU Strukturierung nicht.
  • Der physikalische Ort der Ressourcen ist z.B. für einen OU Administrator einfach zu lokalisieren.

Nachteil:

  • Ein geographisches Modell spiegelt die eigentlichen Geschäftsprozesse innerhalb eines Unternehmens nicht wieder.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1506.htm


Objektbasierendes Modell

Das objektbasierende Modell strukturiert OUs nach den Objekten, die in ihnen enthalten sind, z.B. eine OU für alle Benutzer, eine OU für alle Drucker, eine OU für Gruppen etc.

Vorteile:

  • Vereinfachte Ressourcen Administration.
  • Ressourcen- Administration kann über die verschiedenen Ebenen genau zugeordnet werden.
  • Stabilität, da Modifikationen an der Unternehmensstruktur das OU Modell nicht beeinflussen.

Nachteile:

  • Verstreute OU - Rechtevergabe.
  • Bei einem Multi-Domänen Konzept muss dieses OU Modell in allen Domänen abgebildet werden.
  • evtl. zu viele Top Level OUs.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1507.htm


Kostenbasierendes Modell

Das kostenbasierende Modell reflektiert die Verteilung der Unternehmenskosten.

Vorteil:

  • Das Modell stellt dar, wie jede einzelne OU ihre Ein- und Ausgaben verwaltet und kontrolliert.

Nachteil:

  • Das Modell orientiert sich nicht an administrativen Anforderungen, so dass die Vergabe der Rechte auf OU Ebene schwierig sein kann.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1508.htm


Projektbasierende Modell

Projektbasierendes Modell

Das projektbasierende Modell spiegelt Projektsituationen innerhalb eines Unternehmens wieder. Dieses OU Modell ist flexibel, da sich Projektsituationen laufend ändern.

Vorteile:

  • Projektkosten sind über diese OU Struktur leicht nachvollziehbar.
  • Auf Grund der Projekthierarchien lassen sich Projektsicherheitsmaßnahmen realisieren.

Nachteile:

  • Die Dauer einer OU hängt von der jeweiligen Projektdauer ab.
  • Änderungen in der Projektstruktur führen zu Änderungen in der OU Struktur.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1509.htm


Allgemeine Info

Ich werde in letzter Zeit öfters gefragt, warum in der FAQ Registrykeys von Funktionen beschrieben werden, die man auch leicht über die Windows Oberfläche aktivieren kann.

Das hat ein paar Gründe.

Erstens möchte ich gern so viele Keys wie nur möglich in der FAQ beschreiben und des Weiteren, wie man so einen Eintrag in der Registry findet und was er bedeutet. Über die Stichwortsuche in der FAQ kann man die Keys dann auch leicht finden.

Zweitens benötige ich diese Einträge für dem Registry System Wizard (RSW), da das Programm REG-Files und die neuste Version sogar ADM-Files von den aktuellen Tipps erstellen kann. Gerade als Administrator in großen Netzwerken möchte man gern Funktionen auf andere Rechner über eine Batch- oder Policydatei setzen und dafür ist es halt nötig, die entsprechenden Keys für die Funktion zu kennen.

Ich bin jetzt dazu übergegangen, bei jedem Tipp erst einmal die Möglichkeit zu beschreiben, ihn über die Windows Oberfläche zu aktivieren (wenn es so eine Möglichkeit gibt). Für viele Leute wird diese Information bestimmt schon ausreichen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1183.htm


Copyrighthinweise

Alle Firmen- und Produktnamen unterliegen den länderspezifischen Copyrightbestimmungen und sind geschützt. Die Verwendung und Verbreitung unterliegt gewissen Bestimmungen.

Der Autor dieser Seiten haftet nicht für etwaige Namesverletzungen durch Programme oder Domainnamen, auf welche verlinkt wird.

Für etwaige Schäden, welche durch Tipps dieser Seite oder durch Software dieser Seite verursacht wird, haftet der Autor ebenfalls nicht.

Ein Teil der Texte wurde mit Genehmigung des Rechteinhabers hier veröffentlicht.

Dieses Textdokument ist aufgrund des Urheberrechtgesetzes zumindest innerhalb des Geltungsbereiches der Bundesrepublik Deutschland geschützt und darf nicht ohne Einwilligung des Rechteinhabers kopiert, verändert, verbreitet oder in einer sonstigen Form beschränkt werden.

Verstöße werden wegen eines Verstoßes gegen das Urheberschutzgesetz verfolgt.

Info Alle in dieser FAQ genannten Produktbezeichnungen oder Firmennamen sind Eigentum der jeweiligen Inhaber und unterliegen als solche dem gesetzlichen Warenzeichen-, Marken- oder patentrechtlichen Schutz.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0881.htm


Nutzungsrecht

WinFAQ® ist eine Marke

Nach nun fast drei Jahren Dauerkampf um den Markennamen "WinFAQ" als Wort- und Bildmarke wurde dem nun vor dem Patentgericht ein Ende gesetzt und alle Widersprüche gegen die Marke beseitigt. WinFAQ® ist eine beim Bundespatentamt eingetragene Marke und darf nun das Zeichen ® tragen.

Die Standardfunktionen des "Registry System Wizard" (RSW) und das Helpfile WinFAQ kann von Privatpersonen kostenfrei benutzt werden.

Schulen und gemeinnützige Einrichtungen dürfen die Software kostenlos und lizenzfrei einsetzen.

Für den gewerblichen Einsatz ist eine entspechende Lizenz notwendig. Des weiteren darf das Programm und die FAQ nur auf der Homepage http://www.winfaq.de angeboten werden. Auch die Veröffentlichung von Auszügen bedarf der Genehmigung des Autors.

Auszüge aus der FAQ dürfen mit Quellenangabe ohne extra Genehmigung im FIDO-Netz und in den Newsgroups verbreitet werden.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0882.htm


Danksagungen

Für die Rechtschreibkorrektur, Überarbeitung und Pflege der Tipps bedanke ich mich besonders recht herzlich bei:

Diplom-Physiker Friedhelm Hahne

Andreas Kästner

Weiterhin bedanke ich mich bei allen, die mir mit Tipps beim Erstellen dieser FAQ geholfen haben, insbesondere bei:

Virginia Ullrich

Alice S.

Andreas Richter

Hanz Hüttel

Richard Karsch

Robert Schwarzenbauer

Tobias R.

Jürgen Vetter

Jochen Weber

Johannes Hemmerlein

Andreas Kästner

Bedanken möchte ich mich bei Michael Appelt, der die WinFAQ von Version 3.1 bis Version 5.3 mit Tipps, Anregungen und Informationen unterstützt hat. Michael hat auf seiner Homepage www.wintotal.de eine eigene Tippsammlung erstellt.

Die Firma cognitas GmbH stellt dem WinFAQ-Team die Software "MadCap Flare", in Version 2.0, zur Verfügung. MadCap Flare ist das XML-basierte Autorensystem für Online-Hilfen mit kompletter Single-Sourcing-Flexibilität. Wir sind dabei die aktuelle WinFAQ-Website von "ForeHelp" auf "Flare" umzustellen. Durch die neue Software, wird sich gerade die HTML (Online-WinFAQ) mit einem neuen und übersichtlicheren aussehen präsentieren. Wir Bedanken uns hiermit bei der Firma cognitas für die Software "MadCap Flare" und hoffen weiterhin auf eine gute Zusammenarbeit. Weitere Infos über Flare finden Sie hier.

Bedanken möchte ich mich auch bei der Firma K&R-Software, die mir das Programm ForeHelp Premier zur Erstellung der FAQ kostenlos zur Verfügung gestellt hat.

Weiterhin danke ich Frank Eschweiler der die URL und die Server kostenlos zu Verfügung stellt und darüber hinaus noch etliche andere Projekte der FAQ unterstützt. Auch kümmert er sich immer um die unberechtigten Abmahnungen etlicher Firmen und Personen, die das kostenlose Projekt gefährden wollen, um für sich selber einen finanziellen Nutzen zu ziehen.

Ein Dank geht auch an die FIDO User und an alle Anwender, die durch Hinweise und Tipps bemüht sind, die FAQ weiter zu verbessern.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0883.htm


Woher bekomme ich die FAQ?

Soweit ich genug neue Tipps bekomme, gibt es jeden Monat eine neue Version der WinFAQ. Die Online-WinFAQ auf der Homepage wird wöchentlich aktualisiert.

Die jeweils aktuellen Versionen liegen immer auf meiner Homepage zum Download bereit:

http://www.winFAQ.de

Von mir gibt es folgende FAQs:

Jede WinFAQ enthält immer die Tipps für alle Betriebssysteme.

HLP Version | Das ist noch das alte Hilfeformat von Windows 9x. Die Ansicht ist nicht so übersichtlich wie in der CHM-Version, sie wird aber noch für Fans dieser Ansicht angeboten. Info: Diese Version wurde ab 6.8 eingestellt.
CHM Version | Dieses ist die FAQ im Format der neuesten Hilfeansicht von Windows. Sie ist übersichtlich aufgebaut und läuft unter Windows.
HTML Version | Die HTML-Version ist so aufgebaut wie die Online-FAQ, sie läuft unter dem Webbrowser (IE) und benötigt Java.
Tomeraider Version | Diese Version ist sehr klein und läuft unter allen Systemen, auf denen Tomeraider installiert ist. Sie ist sehr gut für kleine Taschencomputer geeignet. Diese Version wird von Michael Gressmannbetreut und kompiliert.

Seit neuestem gibt es jetzt auch noch den "Registry-System-Wizard". Das ist ein Programm, welches das Setzen der Tipps stark erleichtert, da dafür eine menügeführte Oberfläche zur Verfügung gestellt wird.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0176.htm


WinFAQ Informationen

Da ich schon einige Anfragen bekommen habe, wie viele Tipps in der FAQ denn schon enthalten sind, hier einmal einige Daten:

Die WinFAQ besteht aus:

2559 | Seiten
53192 | Verweisen/Sprüngen
6621 | Stichworteinträgen
1225 | Internet Links
50 | Bitmaps

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1024.htm


Informationen über die Icons

Informationen über Icons in unseren FAQs

Seit Erscheinen von Windows 2000 haben wir uns Gedanken gemacht, für welches Betriebssystem ein Tipp schon getestet wurde und wie wir das mit den Infos hinbekommen können.

Allein aus zeitlichen Gründen kann man nicht alle Tipps einzeln in jedem Betriebssystem austesten bzw., wenn eine neue Version auf den Markt kommt, alle Schritte durchgehen, um die entsprechenden Infos/Tipps hinzu zu fügen.

So haben wir jetzt Folgendes gemacht. Bei jedem Tipp wird in der Kopfzeile angegeben, für welches Betriebssystem dieser geeignet ist bzw. getestet wurde. Ist ein Betriebssystem in der Liste überhaupt nicht aufgeführt, ist der Tipp für dieses Betriebssystem nicht geeignet oder wurde unter dem entsprechenden Betriebssystem nicht geprüft. Wer also den Mut bzw. das benötigte Wissen besitzt, kann selber ausprobieren, ob der betreffende Tipp auch für weitere Betriebssysteme geeignet ist.

An dieser Stelle dann auch gleich eine Bitte an alle User, die das austesten.

Es wäre nett, dann eine kurze Email (E-Mail: ) - mit der Überschrift/Nummer des Tipps an uns zu senden mit der Info: "Geht" bzw. "Geht nicht unter Betriebssystem xx".

Das kommt allen Nutzern zu Gute, die mit der Windows FAQ arbeiten.

Hier nun die Bedeutung der Icons:

Tipp ist für alle Betriebssysteme geeignet

Tipp ist für Windows 95 geeignet

Tipp ist für Windows 98 geeignet

Tipp ist für Windows Millennium geeignet

Tipp ist für Windows NT geeignet

Tipp ist für Windows 2000 geeignet

Tipp ist für Windows XP geeignet

Tipp ist ab installiertem IE 4.x geeignet

Tipp ist ab installiertem IE 5.x geeignet

Tipp ist ab installiertem IE 6.x geeignet

Tipp ist für Windows Vista geeignet

Tipp ist ab installiertem IE 7.x geeignet

Weiterhin findet man am Anfang jedes Beitrags ein Symbol, welches das Thema des Artikels charakterisiert:

Allgemeines (Einstellungen, Fehler,...) | Anschlüsse (Ports)
Anzeige (Bildschirm, Grafikkarte) | CD-Rom Laufwerke
Desktop-Einstellungen | Drucker
Hardware | Internet
Konfigurationsdateien (.INF,.INI,...) | Maus
MS-DOS | Multimedia
Netzwerk | Ordner
Registry | Setup (Windows, Programme)
Schriftarten (Fonts) | Tastatur
WinFAQ.de |

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0001.htm


CHM-Help-File Info

Ab der Version 7.0 werden keinen ActiveX-Elemente mehr verwendet, weshalb die unteren Fehler nicht mehr auftreten und die Dateien nicht mehr benötigt werden.

Einige Leute haben mir den Fehler gemeldet, dass die CHM Version immer wieder versucht, eine Verbindung zum Internet herzustellen oder dass es beim Klick auf die Buttons (z.B. Registry Editor starten) zu Fehlermeldungen kommt. Lange Zeit konnte ich den Fehler nicht nachstellen.

Der Grund liegt darin, dass für diese Help-File Version "ActiveX for Help" installiert sein muss.

Die dafür benötigten Dateien befinden sich auf meiner Homepage (http://www.winfaq.de) und können von dort heruntergeladen werden.

Wollen Sie "ActiveX for Help" nicht installieren, müssen Sie auf die alte Help-File Version bzw. auf die HTML-Version der FAQ umsteigen.

Info Ich möchte darauf hinweisen, dass ich keinesfalls Daten mit der FAQ versenden möchte!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0182.htm


Excel 97 (Flugsimulator)

In Office 97 ist im Excel einmal wieder etwas von den Programmierern versteckt worden:

  1. Excel starten
  2. F5 drücken und X97:L97 eingeben
  3. Enter drücken
  4. Tabulator drücken.
  5. STRG+SHIFT gedrückt halten und mit der Maus auf Diagramm-Assistent klicken.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0195.htm


Internet Explorer Scherz

Starten Sie den Internet Explorer 4.0 und klicken Sie auf das "?" -> "Info", nun öffnet sich ein Fenster mit den MS-Informationen.

Halten Sie die Tasten "STRG" und "SHIFT" (Umschalttaste) gedrückt und ziehen Sie mit der Maus das IE-Symbol ganz nach links (aber innerhalb dieses Fensters bleiben).

Nun einmal loslassen und dann wieder die Tasten "STRG" und "SHIFT" drücken, jetzt müssen Sie das IE-Symbol mit "Schwung" nach rechts über das Wort "Explorer" ziehen. Dabei wird das Wort mit zur Seite geschoben und ein Button kommt zum Vorschein.

Klicken Sie nun auf den Button "Aufschließen" :-)

Dann "SHIFT" + "STRG" (Umschalttaste) drücken und das IE Symbol auf die Weltkugel schieben. Nun öffnet sich ein neues Fenster... :-)

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0194.htm


Flipper unter WinWord 97 aufrufen

In WinWord von Office 97 haben die Programmierer wieder einen kleinen Scherz eingebaut. Bei einem kleinen Flipper-Spiel werden Ihnen die Programmierer von WinWord vorgestellt.

Sie können die Flipper so aufrufen:

  1. WinWord starten
  2. Ein leeres Dokument öffnen
  3. Geben Sie Blue ein (das B wird groß geschrieben)
  4. Markieren Sie das ganze Wort
  5. Über "Format" -> "Zeichen" stellen Sie die Schrift auf "Fett" und die Farbe "Blau" ein. Bestätigen Sie die Einstellung
  6. Heben Sie nun die Markierung des Textes auf, in dem Sie den Pfeiltaste nach rechts drücken.
  7. Tippen Sie nun nacheinander ein "Leerzeichen", ein "Anführungszeichen", ein "Leerzeichen" und wieder ein "Anführungszeichen".
  8. Klicken Sie nun oben im Menü auf das "?" dann auf "Info"
  9. In dem nun geöffneten Fenster klicken Sie oben links auf das WinWord-Icon

Info Es geht auch bei Word 95, hier erscheint aber nur eine Liste der Programmierer.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0196.htm


Osterei in EXCEL 7.0 (OFFICE 95)

  1. Excel mit leerer Tabelle öffnen.
  2. Zeile 95 selektieren.
  3. Mit der Tabtaste in die zweite Spalte gehen.
  4. Über "?" in der Menüleiste "INFO" aufrufen.
  5. [STRG] und [SHIFT] gleichzeitig drücken und "Software Service" anklicken.

Es öffnet sich die Halle der gequälten Seelen: "Hall of tortured souls".

Darin kann man sich mit Hilfe der Pfeiltasten bewegen: 180° umdrehen und voll auf die weiße Wand fahren bis das Bild im Fensterchen nur noch weiß ist. Danach [SHIFT] drücken und gleichzeitig EXCELKFA eintippen. Es kommt ein neues Bild.
Jetzt muss man sich nur noch auf dem schmalen Mauersims bis zur Halle bewegen, die man im Hintergrund sieht.

Das klappt aber erst, nachdem man unzählige Male heruntergefallen ist!

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0379.htm


Screensaver Text

Screensaver Text (MS-Scherz)

Diese Texte stammen noch von NT 3.51. Darum zeigen einige Texte unter NT 4.0/2000 nicht mehr die alte Wirkung.

Einträge für den 3D TEXT-Screensaver.

I Love NT | zeigt die Namen der Entwickler
rock | Namen von Rockgruppen
beer | Bier-Marken
Volcano | Die Namen von Vulkanen der Erde werden zufällig angezeigt
Not Evil |

Wenn Sie als Screen-Saver "3D-Rohre (Open GL)" und bei den Einstellungen "traditionell" und für die Verbindungen "vermischt" auswählen, werden Sie einen lustigen Effekt erleben. Beobachten Sie nun einmal einige Zeit den Bildschirmschoner, in unregelmäßigen Abständen erscheint nun ab und zu- statt eines richtigen Rohrverbindungstückes - eine Teekanne.

Info Einige Texte funktionieren bei NT 4.0/2000 nicht mehr.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0378.htm


Windows 98 Scherz

Info Ab Windows 98 SE finden Sie die Weltkarte in der Systemsteuerung unter "Ländereinstellungen".

Auch in Windows 98 gibt es ein sogenanntes "Osterei". Der versteckte Entwicklerhinweis ist allerdings nicht ganz so einfach aufzuspüren wie in der Vorgängerversion und benötigt etwas Geduld. Die Idee basiert auf "Memphis", dem Codenamen der Betriebssystems. Es gibt zwei Städte, die diesen Namen tragen: Memphis in USA (Bundesstaat Tennessee) und Memphis in Ägypten. Möchten Sie in Windows 98 das Osterei finden, gehen Sie wie folgt vor:

Klicken Sie doppelt auf die Zeitangabe, die Sie rechts unten in der Anzeige sehen. Wechseln Sie im Auswahlfenster zur Registerkarte "Zeitzonen". Halten Sie nun die Tastenkombination [Shift] gedrückt und ziehen Sie die Maus mit gedrückter linker Maustaste auf der Weltkarte von Memphis (Ägypten) nach Memphis(Tennessee). Lassen Sie die Tastenkombination und die Maustaste nun los. Drücken Sie erneut die Tasten und ziehen Sie die Maus wiederum mit gedrückter linker Maustaste von Memphis (Tennessee) nach Redmond (Bund esstaat Washington), wo sich der Hauptsitz von Microsoft befindet. Nun sollten Sie das Osterei sehen.

Als Bild habe ich die 3 Punkte einmal auf der Landkarte markiert.

Das sollte dann bei Ihnen erscheinen:

Info Wenn Ihnen dieses Geklicke zu aufwändig ist, können Sie es auch etwas leichter haben:

  1. Klicken Sie mit der rechten Maustaste auf einen freien Bereich auf Ihrem Desktop
  2. Legen Sie eine neue Verknüpfung an. Geben Sie als Befehlszeile folgendes ein:
    C:\Windows\Anwendungsdaten\Microsoft\Welcome\Weldata.exe You_are_a_real_Rascal
  3. Klicken Sie nun mit der rechten Maustaste auf die Verknüpfung und wählen Sie "Eigenschaften" -> "Verknüpfungen". Dort wählen Sie nun hinter "Anzeigen" den Eintrag "Minimiert" aus.
  4. Wählen Sie die Verknüpfung mit einem Doppelklick aus.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0377.htm


Windows Scherz

Bitte führen Sie alle Anweisungen genauso aus wie beschrieben. Das Kopieren über die Zwischenablage funktioniert nicht immer. Daher sollte der Text am besten manuell eingegeben werden. Wichtig ist, dass Sie alles hintereinander durchführen, drücken Sie zwischendurch keine andere Taste, sondern tun nur das, was hier beschrieben wird. Sie müssen auch die Groß/Kleinschreibung beachten und sollten beim Schreiben nicht korrigieren! Sollten Sie die englische Version von Windows 95 besitzen, müssen Sie Punkt 2 auslassen und bei Punkt 3 weitermachen.

Es ist eine Beschreibung für die englische Version. Sollten Sie die deutsche Version benutzen, nennen Sie den neuen Ordner erst in "New Folder" um und verfahren dann weiter wie unter Punkt 2 beschrieben.

Nur eingeben, was in ROT geschrieben wurde, alles andere sind Anweisungen

Erstellen Sie einen neuen Ordner auf dem Desktop. (mit der rechten Maustaste Desktop anklicken und ->"Neu" -> "Ordner" wählen)

  1. Bei der Deutschen Version müssen Sie den Ordner umbenennen in:
    New Folder
  2. Benennen Sie den Ordner sofort um in:
    and now, the moment you've all been waiting for
    Drücken Sie Return.
    (Wichtig: der " ' " ist das Zeichen über " # " )
  3. Benennen Sie den Ordner wieder um, Diesmal in:
    we proudly present for your viewing pleasure
    Drücken Sie Return.
  4. Benennen Sie den Ordner noch einmal um und zwar in:
    Bei Windows 95:
    The Microsoft Windows 95 Product Team!
    Bei Windows NT:
    The Microsoft Windows NT Product Team!
    Drücken Sie Return.
  5. Klicken Sie nun doppelt auf den Ordner und sehen Sie zu.

Info Es funktioniert leider nicht immer, scheinbar nur gut in der englischen Version ohne Service Pack.

Bei Windows 95:

Sollte das bei Ihnen nicht funktionieren (funktionierte aber bisher auf allen Rechner mit Windows 95

Deutsch/Englisch Version A oder B) versuchen Sie folgendes:

  1. Mit der rechten Maustaste auf den Desktop klicken, einen neuen Ordner erstellen und beim Erstellen folgendes eingeben:
    The Microsoft Windows 95 Product Team!.{869DADA0-42A0-1069-A2E7-08002B30309D}
    ENTER
  2. Mit Doppelklick die Präsentation starten.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0368.htm


Windows Scherz 1

Weitere Entwicklernamen können Sie sich anzeigen lassen, wenn Sie folgendes durchführen.

  1. Klicken Sie auf "Start" -> "Hilfe".
  2. Gehen Sie über die Registerkarte "Suchen" (sollte jetzt der Assistent für die Konfiguration der Suchfunktion erscheinen, akzeptieren Sie die Vorgaben mit "Weiter" -> "Fertigstellen").
  3. Gehen Sie über "Optionen..." in die Einstellung der Suchoptionen und stellen Sie dort folgendes ein (haben Sie dort noch nichts geändert, ist es schon voreingestellt)
    Unter "Suche nach Themen mit" wählen Sie "Alle angegebenen Suchbegriffe in beliebiger Reihenfolge" aus.
    Unter "Wörter anzeigen, die" stellen Sie "Angegebene Buchstaben am Wortanfang" ein und selektieren Sie bei "Nach jedem Tastenanschlag" und kreuzen Sie "Vor Suchbeginn auf Pause warten" an.
  4. Bestätigen Sie die Einstellung mit "OK".
  5. Geben Sie nun als Suchbegriff folgenden Text ein:
    Who knows who built this tool?
  6. Drücken Sie nun "STRG" + "Shift" (die Umschalttaste) und klicken Sie auf "Löschen".
  7. Gehen Sie nun wieder in "Optionen" und ändern Sie die Einstellungen auf:
    Unter "Suche nach Themen mit" wählen Sie "Mindestens einer der angegebenen Suchbegriffe" aus.
    Unter "Wörter anzeigen, die" stellen Sie "Angegebene Buchstaben im Wort" ein (Rest so lassen).
  8. Bestätigen Sie wieder die Einstellungen mit "OK".
  9. Geben Sie nun als Suchbegriff folgenden Text ein:
    The Shadow knows!
  10. Drücken Sie nun wieder "STRG" + "Shift" (die Umschalttaste) und klicken Sie auf "Löschen"

Jetzt sollte ein Fenster mit weiteren Informationen angezeigt werden.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0367.htm


SMS 1.2 Scherz

Hier wird mal wieder ein sogenannter "Easter Egg" für die Software SMS beschrieben.

Wählen Sie "About" und tragen Sie "Hermes" ein.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0369.htm


Internet Explorer 5.0 Scherz

Auch im neuen Internet Explorer gibt es einmal wieder ein paar lustige Scherze.

Der 1 Scherz:

Erstellen Sie mit einem Texteditor eine HTML-Seite mit folgenden kurzen Inhalt:

<!-- introducing the Trident team -->

Speicher Sie diese Datei unter einem beliebigen Namen mit der Endung "HTML" ab und öffnen Sie nun diese Datei mit dem IE 5.0

Der 2 Scherz:

Starten Sie den Internet Explorer 5.0 und wählen Sie dann "Extras" -> "Internetoptionen..." aus dem Registerkarte "Allgemein" wählen Sie "Sprachen" -> "Hinzufügen" geben Sie in das Feld "Benutzerdefiniert" ie-ee ein und bestätigen Sie die Eingabe. Verschieben Sie diese Eingabe ganz nach oben in der Sprachenliste und verlassen Sie dann das Menü.

Drücken Sie im IE auf den Button "Suchen" und wählen Sie aus der erscheinenden Dialogbox den Button "Anpassen". Ein Blick auf die Team Namen können Sie nach Auswahl der Option "Previous searches" -> "The Internet Explorer Team" werfen. Die Bilder der Leute finden Sie unter dem Link "How the magic happens".

Einen weiteren Gag ist nach einem Klick auf die Schaltfläche "Anpassen" zu sehen. Ein blaues "e" erschlägt das Netscape Maskottchen Mozilla.

Für die normale Suche müssen Sie die Sprache wieder auf Deutsch stellen.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0670.htm


Spiel: Hearts

Möchten Sie einmal in diesen Spiel schummeln und die Karten Ihrer Gegenspieler sehen? Dann gehen Sie folgendermaßen vor:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Hearts

legen Sie eine neue Zeichenfolge mit dem Namen ZB an. Geben Sie als Wert 42 ein.

Wenn Sie nun das Spiel starten und die Tastenkombination CTRL+ALT+SHIFT+F12 drücken, sehen Sie die Karten der anderen Mitspieler.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0673.htm


Schummeln im Spiel Hearts aktivieren

Wer kennt nicht das Spiel Hearts, welches bei Windows mitgeliefert wird. Wenn Sie hier nicht so recht gewinnen können, gibt es eine Funktion womit Sie etwas schummeln können.

Durch einen zusätzlichen Eintrag in der Registy können durch drücken der Tasten STRG + ALT + SHIFT + F12 werden Ihnen die Karten der Gegner angezeigt.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Applets\ Hearts

Erstellen Sie hier einen neuen Wert mit dem Namen "ZB" als Datentyp REG_SZ. Geben Sie als Wert 42 ein.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1414.htm


Spiel: Minesweeper

Auch in diesen Spiel kann man schummeln:

  1. Starten Sie das Spiel und öffnen Sie mindestens einen Spielfeld, damit die Zeit zu laufen anfängt. Halten Sie nun die beiden Maustasten fest und drücken Sie gleichzeitig auf die ESC-Taste. Die Zeit hört nun auf zu laufen, nun können Sie in aller Ruhe weiter spielen. Soll die Zeit weiterlaufen, müssen Sie das Fenster nur einmal minimieren und dann wieder öffnen.
  2. Auf ihrem Rechner ist noch Windows 3.11 installiert? Hier haben Sie sogar die Möglichkeit, Felder zu überprüfen:
  3. Starten Sie das Spiel
  4. Der Mauszeiger muss sich auf dem Spielfeld befinden
  5. Tippen Sie nun XYZZY
  6. halten Sie jetzt die Shift-Taste gedrückt und bewegen Sie den Mauszeiger über das Minenfeld. Wenn sich unter dem Mauszeiger eine Mine befindet, leuchtet in der oberen Windows-Ecke ein kleiner Punkt auf.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0674.htm


Spiel: Freecell

Hier wird mal wieder ein sogenannter "Easter Egg" für die Software Freecell beschrieben.

Auch in diesen Spiel kann man schummeln:

Starten Sie das Spiel wie immer. Sollten Sie jetzt einmal wieder nicht weiterkommen, dann drücken Sie Shift+Ctrl+F10.

Es erscheint ein benutzerfreundliches Interface, in dem Sie sich entscheiden können, ob Sie schummeln möchten.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0675.htm


MS Chat 2.5 Scherz

Auch hier gibt es wieder etwas Lustiges zu bestaunen:

  1. Starten Sie das Programm
  2. Geben Sie als ersten im Textfeld WhoIsTheGenius? ein (nicht mit ENTER bestätigen)
  3. Halten Sie nun die Tasten STRG+Shift gedrückt und wählen Sie aus dem Favoriten Menü den Punkt Favoriten öffnen aus.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0676.htm


Frontpage 97/98/2000 Scherz

Auch hier wurde wieder etwas von den Programmierern versteckt.

  1. Starten Sie den Frontpage Explorer
  2. Drücken Sie die SHIFT Taste und halten Sie die Taste die ganze Zeit gedrückt
  3. Wählen Sie "About" aus und drücken Sie OK
  4. Wählen Sie noch einmal "About" aus und drücken Sie wieder OK
  5. Wählen Sie wieder "About".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0681.htm


Microsoft Pocket Excel 97

Auch hier wurde wieder etwas von den Programmierern versteckt.

  1. Drücken Sie Ctrl+G
  2. Geben Sie AA1000 ein
  3. Drücken Sie OK
  4. Geben Sie credits ein
  5. Drücken Sie Enter

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0682.htm


Windows 95 Scherz

Dafür müssen Sie das Windows 95 Batch Setup ausführen. Das finden Sie auf der Windows 95 CD unter "Admin\Nettools\Netsetup", hier starten Sie die Datei "BATCH.EXE".

Geben Sie hier nun unter "Setup Informationen" bei "Your Name" den Namen "Zarg!" ein und klicken Sie dann in ein anderes Feld an.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0596.htm


Access 97 Scherz

Scherz 1:

Starten Sie das Programm Access 97 und legen Sie eine neue Datenbank über "Datei" -> "Neue Datenbank anlegen" an. Erstellen Sie in der Datenbank nun eine neue Tabelle über "Einfügen" -> "Tabelle" und speichern diese unter dem Namen "Go Speed Racer GO" ab. Jetzt wählen Sie in der Menüleiste das "?" -> "Info" aus und führen einen Doppelklick mit der rechten Maustaste im Infofenster aus.

Scherz 2:

  1. Starten Sie Access und erstellen eine neue Datenbank.
  2. Klicken Sie auf den Makros Button und dann auf NEU.
  3. Drücken Sie jetzt die Leertaste, schließen Sie den Dialog und speichern Sie ihn unter dem Namen "Magic Eight Ball" ab.
  4. Ziehen Sie das Makro in die Taskleiste und klicken Sie öfter einmal an :-)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0597.htm


Word 97 Scherz

Drücken Sie "Shift+F1" für Direkthilfe und klicken Sie damit auf das Symbol versteckte Zeichen einblenden/ausblenden (¶).

Jetzt wird Ihnen ein Bild angezeigt :-)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0562.htm


Excel 2000 Scherz

Wollen Sie wissen, wer bei MS das Programm erstellt hat, gehen Sie folgendermaßen vor:

  1. Die F5 Taste drücken
  2. X2000:L2000 eingeben
  3. Mit Return bestätigen
  4. Mit TAB in die Spalte M wechseln
  5. Drücken Sie die Tasten Shift+Strg und klicken Sie mit der Maus auf das Symbol "Diagramm-Assistent"

Aber auch ein Autorennen ist in Excel 2000 zu finden:

  1. Öffnen Sie ein leeres Arbeitsblatt
  2. Wählen Sie aus dem Menü "Datei" -> "Speichern unter..."
  3. Ändern Sie auf dieser Seite "Speichern unter..." folgende Einstellungen:
    "Dateityp" -> als "Webseite" auswählen, jetzt können Sie auf der Seite noch folgendes ankreuzen:
    "Auswahl: Tabelle" -> auswählen
    "Internetaktivität hinzufügen" -> ankreuzen
    Speicher Sie jetzt die Tabelle unter einem beliebigen Namen ab
  4. Öffnen Sie die Datei mit dem Internet Explorer
  5. Gehen Sie in die Zeile 2000 und Spalte WC
  6. Markieren Sie die ganze Zeile (mit der Maus auf die 2000 klicken)
  7. Drücken Sie die TAB-Taste
  8. Halten Sie die Tasten STRG+Shift+ALT gedrückt und klicken Sie mit der Maus auf das Office-Logo links oben in der Tabellenecke

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0466.htm


Powerpoint 97/2000 Scherz

Unter Powerpoint 97 bzw. 2000 können Sie sich eine kleine Präsentation über die Programmierer anschauen:

  1. Powerpoint starten
  2. Klicken Sie in der Menüleiste auf das Fragezeichen
  3. Wählen Sie im Menü "Info" aus
  4. Klicken Sie auf das Powerpoint Logo.

Dieses funktioniert in beiden Versionen, bei Powerpoint 97 können Sie noch erfahren was die Programmierer nach Abschluss der Arbeiten getan haben:

  1. Powerpoint starten
  2. Klicken Sie in der Menüleiste auf das Fragezeichen
  3. Wählen Sie im Menü "Info" aus
  4. Halten Sie die Tasten Strg+Alt+Shift gedrückt und klicken Sie im Infofenster drei einmal auf die Linie unterhalb der Lizenzinfos.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0470.htm


Outlook 2000 Scherz

Auch unter Outlook 2000 gibt es wieder einen netten Scherz.

  1. Starten Sie Outlook
  2. Wählen Sie im Menü "Ansicht" -> "Gehe zu" -> "Kontakte"
  3. Klicken Sie oben in das Feld "Kontakt suchen"
  4. Geben Sie hier "Ren Hoek" ein.
  5. Drücken Sie Enter
  6. Sie erhalten die Meldung das der Kontakt nicht gefunden werden konnte, bestätigen Sie die Meldung mit OK
  7. Wählen Sie im Menü "Extras" -> "Makro" -> "Makros"
  8. Hier geben Sie jetzt als Makronamen "OL2KRocks" ein und bestätigen das mit OK
  9. Es erscheint jetzt die Infobox "Info über Microsoft Outlook"
  10. Drücken Sie Strg+Alt+Shift und klicken Sie auf OK.

Es erscheint ein Bild, wo die Namen der Entwickler als Briefe vorbei fliegen. Über die Pfeiltasten können Sie einen Briefkasten steuern und damit die Briefe einfangen.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0483.htm


Scherz im Win98-Plus Paket

Scherz im Windows 98-Plus Paket

Auch im Plus-Paket von Windows 98 ist einmal wieder ein kleiner Scherz vorhanden, der dieses einmal musikalisch untermalt wird.

Damit Sie diesen Scherz ausprobieren können, müssen Sie das Plus-Paket und aus diesen Paket die "Deluxe CD-Wiedergabe" installiert haben, gehen Sie dann folgendermaßen vor:

  1. Legen Sie eine beliebige Musik-CD ins Laufwerk
  2. Starten Sie den "Deluxe CD-Player"
  3. Wählen Sie die Option "Wiedergabeliste"
  4. Wählen Sie die aktuelle CD aus und wählen Sie dann "Wiedergabeliste erstellen"
  5. Geben Sie als Interpreten folgendes ein "Microsoft Plus!98 Product Team" und bei CD "Credits"
  6. Halten Sie jetzt die STRG-Taste gedrückt und klicken Sie mit der Maus auf den Button "Abbrechen"
  7. Unter den Albuminformationen finden Sie nun einen neuen Eintrag mit dem Namen "Microsoft Plus!98 Product Team" unter dem die Namen der Programmierer usw. aufgeführt sind.

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0452.htm


Access 7.0 Scherz

Einige dumme Sprüche bekommen Sie unter Access 7.0 folgendermaßen angezeigt:

  1. Öffnen Sie eine beliebige Datenbank
  2. Erstellen Sie ein Makro und schreiben Sie ein paar Zeichen in die erste Kommentarzeile
  3. Speichern Sie das Makro unter "Magic Eight Ball" ab
  4. Jetzt ziehen Sie das Makro auf die Symbolleiste
  5. Klicken Sie das neue Symbol mit der rechten Maustaste an und wählen Sie "Anpassen" aus dem Kontextmenü aus.
  6. Klicken Sie noch einmal mit der rechten Maustaste auf das Icon und wählen jetzt "Schaltflächensymbol wählen" aus dem Kontextmenü aus
  7. Wählen Sie ganz unten rechts die leere Schaltfläche aus und klicken Sie dann auf die neue Schaltfläche

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0453.htm


Excel 5.0 Scherz

Unter Excel 5.0 wird Ihnen eine Animation präsentiert:

  1. Starten Sie Excel mit einem neuen Dokument
  2. Klicken Sie mit der rechten Maustaste auf die Symbolleiste
  3. Wählen Sie Benutzerdefiniert und in der Liste der Kategorien ebenfalls Benutzerdefiniert aus
  4. Ziehen Sie die Schaltfläche "Kartenspiel" auf die Symbolleiste und brechen Sie die Frage nach einer Makro-Zuweisung ab.
  5. Schließen Sie die Symbolleisten Dialogbox
  6. Drücken Sie die Tasten STRG+ALT+Shift und klicken Sie mit der Maus auf das neue Symbol

Nach zwei Seiten Text erscheint eine Animation.

siehe auch: "Excel 2000 Scherz"

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0454.htm


Developer Studio 97 Scherz

Hier ein Easter Egg für Microsoft Developer Studio 97

  1. Suchen Sie auf der Developer CD nach der Datei "DEVCRD.DLL" (sie müsste sich im Verzeichnis "\DEVSTUDIO\SHAREDIDE\BIN" befinden).
  2. Kopieren Sie DLL in das Developer Verzeichnis auf Ihren Rechner (C:\DEVSTUDIO\SHAREDIDE\BIN)
  3. Starten Sie ein Programm vom Developer Studio
  4. Klicken Sie unter "Help" -> "About" bei gedrückter CTRL-Taste in die Dialogbox

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1045.htm


Excel 95 Scherz

Hier wird mal wieder ein sogenannter "Easter Egg" für die Software Excel 95 beschrieben.

  1. Starten Sie Excel 95
  2. Gehen Sie in die 95 Zeile
  3. Markieren Sie die ganze Zeile
  4. Drücken Sie einmal die TAB Taste
  5. Öffnen Sie über "?" -> "Info"
  6. Halten Sie CTRL+ALT+Shift gedrückt und klicken Sie auf "Software Service"

Es wird Ihnen die "Hall of Tortured Souls" gezeigt.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1046.htm


Visual Basic Scherz

Hier ein Easter Egg für Microsoft Visual Basic 4.0

  1. Erstellen Sie eine Textbox. Setzen Sie den Namen für die Property auf "Thunder"
  2. Verankern Sie die Textbox
  3. Bewegen Sie die Maus über die Toolbox, es werden Ihnen nun die Namen der Tester angezeigt.

Visual Basic 5.0 / 6.0

  1. Starten Sie Visual Basic
  2. Öffnen Sie ein neues Projekt
  3. Klicken Sie im Menü auf "Ansicht" -> "Symbolleisten" -> "Anpassen"
  4. Wechseln Sie zu "Befehle"
  5. Gehen Sie zur Kategorie "Hilfe" und ziehen Sie "Info zu Microsoft Visual Basic" in das Help Menü
  6. Klicken Sie den Eintrag im Hilfe Menü an und ändern Sie den Namen auf "Show VB Credits"
  7. Klicken Sie auf "Schließen"
  8. Klicken Sie den neuen Eintrag im Hilfemenü an.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1047.htm


Word Scherz

Hier wird mal wieder ein sogenannter "Easter Egg" für die Software Microsoft Word (Office) beschrieben.

1) Öffnen Sie ein neues Word-Dokument

2) Schreiben Sie folgenden Text in die erste Zeile und drücken Sie Enter: = rand (200,99)

3) Warten Sie 3 sec.

Ich bedanke mich bei V. Dörflinger für folgenden Hinweis:

Info Mit der Formel "=rand(x, y)" lässt sich schnell und unkompliziert ein sogenannter "Blindtext" für Testzwecke erzeugen, wie er z.B. bei der Buchproduktion für Überprüfungen des Layouts benötigt wird. Mit ihr wird der Standard-Blindtext (in der engl. Version "The quick brown fox jumps over the lazy dog."; jeder Buchstabe des Alphabets kommt darin vor) in x Absätzen pro Absatz y-einmal erzeugt. Damit lässt sich genau die gewünschte Textmenge steuern und man kann mit wenig Aufwand Hunderte von Seiten mit Text füllen.

Wie gesagt - kein Scherz, Verlags- und Textverarbeitungs-Profis brauchen so etwas tatsächlich.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1113.htm


Schummeln beim Pinball

Mit den Folgenden Tipps können Sie beim Spiel "Pinball" schummeln. Starten Sie dafür das Spiel. Geben Sie danach folgendes ein:

bmax -> unendliche Anzahl Bälle

rmax -> nächst höheren Rang (kann mehrmals hintereinander eingegeben werden).

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1551.htm


Gagscreen in Office 97/2000

Ein etwas älterer Gagscreen für Office 97/2000 wurde mir von einen Leser zugeschickt für die Sammlung der sog."Ostereier" unter "Allgemeine Informationen\Ostereier (Scherze)". In diesen Gagscreens verewigen sich meistens die Programmierer der entsprechenden Anwendungen.

  1. Starten Sie Word oder Excel von Office 97/2000
  2. Über ALT+F11 der Visual-Basic-Editor starten
  3. Menü "Ansicht" -> "Symbolleisten" -> "Anpassen"
  4. Klicken Sie beim geöffneten "Anpassen-Menü" auf das Fragezeichen (?) in der Symbolleiste
  5. Markieren Sie hier den Eintrag "Info"
  6. Öffnen Sie mit einem Rechtsklick das Kontextmenü des Eintrages und geben Sie hinter Name "Show VB Credits" ein (dabei unbedingt die Groß-und Kleinschreibung beachten).
  7. Schließen Sie jetzt alle Dialoge und starten Sie aus dem Menü "?" den Eintrag "Show VB Credits"

Es wird Ihnen jetzt eine Animation mit durchlaufenden Entwicklernamen und einer laufenden MIDI-Datei als Hintergrundmusik angezeigt.

Da auch eine MIDI-Datei abgespielt wird, sollte der Sound angeschaltet sein.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2473.htm


Windows updaten (Aktuelle Updates aus dem Internet laden)

Ab IE 4.x können Sie Windows über das Netz mit neuen Treibern und Funktionen aktualisieren. Lt. Microsoft wird beim Update nur die Datei "HWINFO.DAT" aus dem Windows-Verzeichnis übertragen, welche bei der Installation von Windows mit angelegt wird. Diese Datei wird bei jedem Update auch aktualisiert (siehe auch "Detaillierte Hardwareinformationen mit HWINFO oder HWDIAG ermitteln").

Es hat sich aber herausgestellt, dass die System-ID des Rechner bei der Onlineregistrierung mit übertragen wird. Diese ID ist einmalig und kann somit zur Identifizierung benutzt werden. Lt. MS sollen diese Informationen zwar nicht gespeichert werden, aber aus welchem Grund werden sie dann erst erzeugt und seltsamerweise auch in allen Office Dokumenten mit abgespeichert?

Darum ist von einer Onlineregistrierung auch abzuraten!

Wie Sie das durch einen kleinen Trick bewerkstelligen können, finden Sie unter "Online Registrierung für Update unnötig".

Beim Start des Updates werden auf Ihren Rechner folgende Dateien heruntergeladen:

C:\Windows\Downloaded Files\

ACTSETUP.INF

CDMWU.OCX

WUDETINS.EXE
CONVEYER.INF

CONVEYER.OCX

C:\Windows\Temporary Internet Files\[zufälliger Verzeichnisname]

ACTSETUP.CAB

CONVEYER1.CAB

bzw. ab IE 5.5 unter:

C:\Programme\WindowsUpdate\Cabs\[zufälliger Verzeichnisname]

Der Update-Wizard zeigt Ihnen auf der Homepage nur die Programme an, die er für ein Update für nötig hält. Da bei einem Update die Dateien gleich installiert werden, ist es leider auch nicht vorgesehen, dass Sie die Datei speichern können, um bei einer Neuinstallation gegebenenfalls ohne den Weg über das Internet die Dateien neu zu installieren.

Die meisten Updates können Sie vom Microsoft Download Center herunterladen und speichern (siehe unten).

Sollte ein neuer Update noch nicht im Download Center verfügbar sein, können Sie folgendes versuchen:

Nach der Installation der Treiber werden Sie aufgefordert, den Rechner neu zu starten.

Führen Sie an dieser Stelle keinen Neustart durch, da sonst alle Treiber automatisch gelöscht werden.

Starten Sie den Explorer und gehen Sie in das Verzeichnis "C:\Windows\Temporary Internet Files"

bzw. "C:\Programme\WindowsUpdate\Cabs". In diesem Ordner finden Sie weitere Ordner mit komischen Namensbezeichnungen. Kopieren Sie alle Dateien mit den Endungen *.EXE und *.CAB in ein extra Verzeichnis. Diese Dateien wurden von MS für das Update von Server heruntergeladen.

Wie Sie die Updates Speichern können, finden Sie hier:

Windows XP Update-Dateien speichern

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0649.htm


Wichtige Updates und Servicepacks

Wichtige Updates für die Betriebssysteme finden Sie jeweils Unter:

Updates für Windows 95

Updates für Windows 98 und ME

Updates für Windows NT

Updates für Windows 2000

Updates für alle Betriebssysteme

Service Packs für Windows Vista und Windows 2008

Informationen und Updates finden Sie unter:

Aktuelle Updates

-

-

Das Microsoft Downloadcenter

Wenn Sie Updates oder Treiber von MS benötigen, können Sie hier gezielt danach suchen.

htp://www.microsoft.com/downloads/en/default.aspx

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0494.htm


Updates für alle Betriebssysteme

Hier finden Sie Updates, die nicht Betriebssystem abhängig sind.

Office XP Service Pack für Administratoren

-

-

http://www.microsoft.com/office/ork/xp/appndx/appb00.htm#german

Treiberupdate

-

-

Hier finden Sie mehr als 130.000 Treiber zum Download. Den passenden Treiber finden Sie über eine Suchfunktion oder über die Sortierung nach Betriebssystem bzw. Gerätetyp.

http://www.treiberupdate.de/

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1182.htm


Updates für Windows 95

Unter den folgenden Adressen finden Sie Updates aufgelistet, die Sie herunterladen und speichern können. Die Beschreibungen liegen in vielen Fällen leider nur in Englisch vor, die meisten Updates können Sie aber auch in der deutschen Version herunterladen.

http://www.microsoft.com/windows95/downloads/default.asp

Schutz für NetBIOS -Freigabe

95

156 KB

Ein Bug in der NetBIOS -Freigabe in Netzwerken ermöglicht Hackern auf lokale Ressourcen zuzugreifen, ohne das Passwort genau zu kennen.

http://download.microsoft.com/download/win95/Update/11958/W95/EN-US/273991USA5.EXE

Probleme mit AMD K6 unter Windows 95 beheben

95

650 KB

Windows 95 funktioniert nicht richtig mit einem AMD K6-2 350 und stürzt dabei des öfteren ab.
Dieser Fehler tritt bei Verwendung eines AMD K6-2- 350 unter Windows 95 auf. Lt. der c't sind die Treiber IOS.VXD, ESDI_506.PDR und SCSIPort.PDR von dem Fehler betroffen. Der Grund ist eine Zeitschleife des AMD, welche eine DIV0 verursacht. Unter Windows 98 und Windows NT tritt der Fehler nicht auf.

http://download.microsoft.com/msdownload/kb/amdk6/amdk6upd.exe

Update für das DFÜ-Netzwerk

95

2,5 MB

Das Update erweitert das DFÜ-Netzwerk um VPN (Virtuell Private Network) Connections und einige Features wie Kanalbündelung etc.

http://msdownload.microsoft.com/msdownload/msdun/1.3/de/msdun13.exe

Jahr 2000 Update

95

2,2 MB

Hier gibt es das Finale Update für Windows 95 zum Jahr 2000 Problem.

http://msdl.microsoft.com/msdownload/w95/y2kupdate/x86/de/w95y2k.exe

Euro-Zeichensatz

95

2,3 MB

Unter Windows 95 wird das Euro-Problem durch eine neue Tastaturtabelle gelöst, die mit der Tastenkombination AltGr-E den Euro beziehungsweise das an der ANSI-Position 0128 befindliche Zeichen einfügt. Die einzigen Fonts, die damit unter Windows 95 angesprochen werden können, sind derzeit die drei mitgelieferten "Core Fonts" Arial, Courier New und Times New Roman.

http://download.microsoft.com/download/win95/Update/2.0/W95/DE/D35907.exe

Update für Intel-Chipsätze

95

590 KB

Dieses Update wird benötigt, damit Windows 95 korrekt auf neueren Motherboards (mit INTEL VX/HX/TX/LX - Chipsatz) für Pentium und Pentium II läuft. Enthalten ist nun auch eine spezielle Anpassung für AGP -Support unter Windows 95, die nach dem OSR2.1-Update installiert werden sollte (siehe unten). Sollte bei dem Board bereits ein Update dabei sein (z.B. Gigabyte), ist dies nicht erforderlich, wohl aber das USB-Update.

http://www.usbman.com/Win95%20USB%20Guide.htm

Neuer Kernel für Windows 95B mit AGP und USB

95b

1 MB

Update von Windows 95 OSR2 auf OSR2.1. Neuer Kernel (Build 1212) und USB - Support. Dieses Update ist auch Voraussetzung dafür, eine AGP - Grafikkarte unter Windows 95 zum Laufen zu bekommen.
Es wird zudem der INTEL-PATCH benötigt, um AGP zu nutzen.
Für USB Support wird weiterhin die Datei usbupd2.exeenötigt.

http://www.usbman.com/Win95%20USB%20Guide.htm

Service Pack 1

95

1 MB

Das erste Service Pack für Windows 95. Es darf nicht bei den neueren Windows Versionen (A, B usw. installiert werden)

http://www.microsoft.com/windows/software/localize/ger.htm

Neuer Kernel

95/95a

310 KB

Hiermit wird der Kernel aktualisiert, welcher im Service Pack 1 noch nicht enthalten ist.

http://download.microsoft.com/download/win95upg/Update/3/W95/EN-US/Krnlupd.exe

Bugfix für IDE-Schnittstelle

95

170 KB

Mit diesem Patch werden Probleme beim Betrieb von Festplatten und CD-ROMs am gleichen IDE Port behoben.

http://download.microsoft.com/download/win95upg/tool_k/1.0/W95/EN-US/Iosupd.exe

Behebt Fehlermeldung beim Start

95

700 KB

Sollte Office 97 installiert sein, kann es beim Start von Paint zu einer Fehlermeldung kommen. Diese wird mit dem Update behoben.

http://download.microsoft.com/download/win95upg/Update/4/W95/EN-US/Paint95.exe

DialUP Network

95/95b/98

460 KB

Dieses englische Update für das DUN in Windows erweitert das Betriebssystem um verschlüsselte Einwahl und Point to Point Tunneling Protocol (PPTP) Verkehr mit 128-Bit. Nach dem Update kann Windows Verbindungen über PPTP (Virtual Private Networks) mit 40 oder 128-Bit aufbauen.
Hinweis: Nach der Installation sind Teile des DFÜ-Netzwerks englisch, was aber eher ein "kosmetisches" Problem darstellt.

95: http://download.microsoft.com/download/win95/Update/17648/W95/EN-US/dun14-95.exe

98: http://download.microsoft.com/download/win98/Update/17648/W98/DE/dun14-98.exe

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0968.htm


Updates für Windows 95, 98 und ME

Im Startmenü und im IE finden Sie Schaltflächen, über die Sie Updates für Ihr System vom MS Server herunterladen und installieren können. Der Nachteil ist aber, dass Sie alle Updates erneut downloaden müssen, wenn Sie Ihr System neu installieren.

Unter den folgenden Adressen finden Sie Updates aufgelistet, die Sie herunterladen und speichern können. Die Beschreibungen liegen in vielen Fällen leider nur in Englisch vor, die meisten Updates können Sie aber auch in der deutschen Version herunterladen.

Weitere Updates und Patches finden Sie unter
http://www.microsoft.com/downloads/search.asp?LangID=10&LangDIR=DE

http://v4.windowsupdate.microsoft.com/de/default.asp?corporate=true

http://www.microsoft.com/windows98/downloads/corporate.asp

Eine gute Zusammenstellung von Updates finden Sie auch auf folgenden Internetseiten:

Windows 98

98

-

Updates

http://web.archive.org/web/20030715163734/walbeehm.com/win98upd.html

Service Pack 2.0.2

98 SE

15,07 MB

Dieses Service Pack kommt nicht von Microsoft. Es wurde von einer anderen Person zusammengestellt und enthält alle Updates und Fixes von Microsoft für Windows 98 SE. Sie müssen diese Update also nicht mehr umständlich selber zusammensuchen.

Englisch: http://exuberant.ms11.net/98sesp.html

Deutsch: http://www.creopard.de/win98sp

Passwort liegt unverschlüsselt im Arbeitsspeicher

95/98/SE

170 KB

Windows legt das Passwort und den Benutzernamen unverschlüsselt im Arbeitsspeicher ab. Die Angaben können durch Programme ausgelesen werden. Das Update verschlüsselt diese Angaben. Weitere Informationen im Microsoft Security Bulletin MS99-052.

95: http://download.microsoft.com/download/win95/Update/168115/W95/DE/168115de5.exe

98/SE: http://download.microsoft.com/download/win98/Update/168115/W98/DE/168115de8.exe

USB-Patch

98/SE

100 KB

Dieser Patch für die Zweite Ausgabe von Windows 98 SE behebt ein Problem mit dem USB-Bus, welcher bei Rechnern mit schnellen AMD-CPUs oder VIA-USB-Controller auftreten können. Der Patch behebt einen Timingfehler, durch welchen einige USB-Geräte nicht richtig angemeldet werden konnten. Der Patch ist NUR für Windows 98 SE in Deutsch.

http://download.microsoft.com/download/win98SE/Patch/4.10.2223/W98/DE/240075DE.exe

Shutdown

98/SE

540 KB

Mit der Second Edition von Windows 98 sind die Shutdown Probleme beim Herunterfahren des Rechners bei vielen Anwendern neu hinzugekommen. Der Patch hilft auf einigen Systemen. Weitere Infos unter Q238096.

http://download.microsoft.com/download/win98SE/Update/4756/W98/DE/4756de8.exe

1 GHz CPU

98/SE

200 KB

Schnelle CPUs (ab 1 GHz) bringen Windows 98SE beim Herunterfahren aus dem Tritt. Trotz richtigem Beenden des Systems wird bei jedem Neustart Scandisk gestartet. Grund hierfür ist die Tatsache, dass die CPU schneller beendet, als die Festplatte Daten vom Cache auf die Platte schreiben konnte. Dieses Update fügt eine Zeitschleife von 2 Sekunden beim Herunterfahren ein. Weitere Infos unter Q273017.

http://download.microsoft.com/download/win98SE/Update/11956/W98/DE/273017GER8.EXE

Rechner hängt bei Verwendung von NDIS-Treibern

98/SE

223 KB

Wird unter Windows 98 SE Netzwerksoftware verwendet, die als temporärer Treiber (NDIS-Intermediate Driver) implementiert ist, kann es zu Hängern beim Hoch- und Runterfahren des Systems kommen. Auch sind Fehler im Netzwerkdurchsatz und bei der Netzwerkgesamtleistung bekannt. Der Patch behebt diese Probleme. Siehe auch den dt. Eintrag unter D42583und den englischen KB-Artikel Q243199

http://download.microsoft.com/download/win98SE/Update/Q243199/W98/DE/243199GER8.EXE

Kein Herunterfahren bei Netzwerkfreigabe

98/SE

223 KB

Ist die Option "Dateien und Ordner für andere Benutzer freigeben" aktiviert, kann unter Umständen der Rechner nicht mehr richtig herunterfahren und bleibt hängen. Weitere Infos unter Q260067.

http://download.microsoft.com/download/win98SE/Update/7602/W98/DE/260067GER8.EXE

Update für Telnet

95/98/SE

185 KB

Der Telnet-Client hat einen ungesicherten Buffer. Damit kann willkürlicher Programmcode eines Hackers auf dem Zielrechner ausgeführt werden. Weitere Infos im Security-Bulletin MS99-033.

http://download.microsoft.com/download/win98SE/Update/3780/W98/DE/TelnetUp.EXE

Update für TCP/IP

95/98/SE

200 KB

Durch fehlerhafte IMPG Pakete (TCP/IP-Protokoll) können unterschiedliche Fehler verursacht werden. Der Bug macht sich nur im TCP/IP Netzwerk und auch nur dann, wenn ein Hacker den Rechner gezielt angreift. Weiteres im Security-Bulletin MS99-034.

95: http://download.microsoft.com/download/win95/Update/238453/W95/DE/238453GER5.EXE

98/SE: http://download.microsoft.com/download/win98/Update/238453/W98/DE/238453GER8.EXE

Update für TCP/IP

95/98/SE

197 KB

Durch ungültige IP Fragmente von Hackern kann der Rechner zum Absturz gebracht werden (DOS -Attacke). Weitere Infos in dem Security-Bulletin MS00-029.

95: http://download.microsoft.com/download/win95/Update/8070/W95/DE/259728GER5.EXE

98/SE: http://download.microsoft.com/download/win98/Update/8070/W98/DE/259728GER8.EXE

Schutz vor Systemabsturz durch Angabe von DOS -Gerätenamen

95/98/SE

228 KB

Durch die Angabe von DOS -Gerätenamen im Pfad auf Webseiten kann das System zum Absturz gebracht werden. Weitere Informationen im Microsoft Security-Bulletin MS00-017.

Deutsch: http://download.microsoft.com/download/win98/Update/6467/W98/DE/256015GER8.EXE

Englisch: http://download.microsoft.com/download/win98SE/Update/6467/W98/EN-US/256015USA8.EXE

Update für RTF-Control

95/98/SE

1 MB

Das ActiveX-Control zur Anzeige von RFT-Dateien beinhaltet einen Bug, den Hacker dazu nutzen können, um das Programm zum Absturz zu bringen. Die Komponente wird von zahlreichen Applikationen benutzt. Weiteres im Security-Bulletin MS00-005.

http://download.microsoft.com/download/win98/Update/5072/W98/DE/249973GER8.exe

Scandisk meldet Fehler bei Festplatten über 32 GByte

95/98/SE

165 KB

Scandisk zeigt bei Festplatten über 32 GByte Kapazität unter Umständen (auch abhängig vom BIOS ) Clusterfehler an, obwohl keine vorhanden sind. Weiteres steht in der Microsoft Knowledge Base unter Artikel Q243450.

http://download.microsoft.com/download/win98SE/Update/5638-6151/W98/DE/243450GER8.EXE

Erlaubt Nutzung großer Festplatten

95/98/SE

200 KB

Festplatten mit einer Kapazität von größer als 64 GByte können mit FDISK nicht voll genutzt werden, da dieses Programm sich intern verrechnet. Mit dem Patch arbeitet FDISK wieder wie gewohnt.

http://download.microsoft.com/download/Win 98/Update/8266R/W98/DE/263044GER8.EXE

Schutz vor DOS -Attacke über IPX-Protokoll

95/98/SE

166 KB

Auch über das IPX-Protokoll kann eine DOS -Attacke von einem Hacker auf den Rechner gestartet werden, wenn das Protokoll benutzt wird. Der Patch behebt die Sicherheitslücke. Weiteres im Security-Bulletin MS00-054und Q265334.

http://download.microsoft.com/download/win98/Update/8982/W98/EN-US/265334USA8.EXE

DialUp Network Update (DUN 1.4)

95/98/SE/ME

460 KB

Dieses Update für das DFÜ-Netzwerk (DUN) in Windows 98 erweitert das Betriebssystem um verschlüsselte Einwahl und Point-to-Point-Tunneling-Protocol-Verkehr (PPTP) mit 128-Bit. Nach dem Update kann Windows 98 Verbindungen über PPTP (Virtual Private Networks) mit 40 oder 128-Bit aufbauen.
Hinweis: Nach der Installation der englischen Version sind Teile des DFÜ-Netzwerks englisch, was aber eher ein kosmetisches Problem darstellt.

Deutsch:

98 SE: http://download.microsoft.com/download/win98SE/Update/17648/W98/DE/dun14-se.exe

Englisch:

95: http://download.microsoft.com/download/win95/Update/17648/W95/EN-US/dun14-95.exe

98: http://download.microsoft.com/download/win98/Update/17648/W98/EN-US/dun14-98.exe

98 SE/ME: http://download.microsoft.com/download/win98SE/Update/17648/W98/EN-US/dun14-SE.exe

TCP/IP Retransmit-Patch

95/98/SE

169 KB

Bei Nutzung von stark verzögerten Verbindungen (Satellit etc.) ist der Output unter Umständen stark vermindert, da der TCP/IP-Stack das Signal neu übermittelt, weil es nach Ablauf des Timers nicht den Empfänger erreicht hat (RTT, Round Trip Time). Der Stack von Windows 95 und Windows 98 hat hier einen Bug, weshalb Pakete oft mehrmals übermittelt werden.

http://download.microsoft.com/download/win98/Update/3111/W98/EN-US/236926USA8.EXE

Behebt Problem bei langem File- oder UNC-String im Browser

95/98/SE

165 KB

Bei langen "file://" address (URL) oder Universal Naming Convention (UNC) Strings kann das System zum Stillstand kommen, wenn der obige Patch fehlt.

Deutsch
95: http://download.microsoft.com/download/win95/Update/245729/W95/DE/245729DE5.EXE
98/SE: http://download.microsoft.com/download/win98/Update/245729/W98/DE/245729DE8.EXE

Englisch
95: http://download.microsoft.com/download/win95/update/245729/w95/en-us/245729us5.exe

98/SE: http://download.microsoft.com/download/win98/update/245729/w98/en-us/245729us8.exe

Behebt Probleme im LAN

ME

150 KB

Der Patch für Windows ME behebt Probleme im LAN, welche durch einen fehlerhaften REG-Eintrag zustande kommen. Welche Fehlermeldungen mit dem Patch konkret behoben werden, ist dem unten angegebenen Link zu entnehmen.

http://download.microsoft.com/download/winme/update/13387/winme/en-us/272991usam.exe

ME-Patch für Systemwiederherstellung

ME

220 KB

Wird ein nach dem 08.09.2001 erstellter Systemwiederherstellungspunkt zurückgespielt, kann eine Fehlermeldung erscheinen, dass die Wiederherstellung nicht erfolgreich war. Ursache ist ein Fehler bei der Namesgebung von Windows für Systempunkte nach dem 08.09.2001. Achtung: Durch den Patch werden alle vorherigen Wiederherstellungspunkte gelöscht. Tritt der o.a. Fehler nicht auf, sollte man daher auf ein Update ggf. verzichten.

http://support.microsoft.com/?kbid=290700

AOL-Modem Patch

ME

156 KB

Wenn Sie einen Windows Driver Model-Treiber (WDM-Treiber) für Ihr Modem verwenden, schlägt der erste Versuch, zu AOL zu verbinden, möglicherweise fehl. Des weiteren wird nach ca. 10 bis 15 Minuten die Verbindung möglicherweise unterbrochen und Ihr Computer reagiert nicht mehr (hängt). Der Patch behebt dieses Problem, sollte aber auch nur für diesen Zweck installiert werden.

http://download.microsoft.com/download/winme/Update/11698/WinMe/EN-US/272016USAM.EXE

Schutz für NetBIOS -Freigabe

95/98/ME

209 KB

Ein Bug in der NetBIOS -Freigabe in Netzwerken ermöglicht es Hackern, auf lokale Ressourcen zuzugreifen, ohne das Passwort genau zu kennen.

Deutsch
95: http://download.microsoft.com/download/win95/Update/11958/W95/DE/273991GER5.EXE

98/SE: http://download.microsoft.com/download/win98SE/Update/11958/W98/DE/273991GER8.EXE

ME: http://download.microsoft.com/download/winme/Update/11958/Win ME/DE/273991GERM.EXE

Englisch
95/98: http://download.microsoft.com/download/win98SE/Update/11958/W98/EN-US/273991USA8.EXE

ME: http://download.microsoft.com/download/winme/Update/11958/WinMe/EN-US/273991USAM.EXE

Update für Passwörter bei komprimierten Ordnern

98/ME

200 KB

Windows 98 Plus und Windows Me verwalten "komprimierte Ordner", welche eigentlich ZIP-Dateien darstellen. Diese lassen sich auch mit Passwörtern schützen. Aufgrund eines Fehlers werden die Passwörter aber in der Datei dynazip.log im Windows-Ordner abgelegt. Nach Einspielen des Patches sollte die Datei aber erst manuell gelöscht werden. Weitere Infos im Security-Bulletin MS01-019.

Deutsch
98/SE:http://download.microsoft.com/download/win98/Update/14715/W98/DE/252694GER8.EXE

ME: http://download.microsoft.com/download/winme/Update/14715/WinMe/DE/252694GERM.EXE

Englisch
98/SE: http://download.microsoft.com/download/win98/update/14715/w98/en-us/252694usa8.exe

ME: http://download.microsoft.com/download/winme/update/14715/winme/en-us/252694usam.exe

Name-Management-Protokoll für IPX

98/SE/ME

216 KB

Ein Fehler in Windows 9x/ME hat unter Benutzung von IPX/SPX als Protokoll zur Folge, dass jeder Empfänger von Broadcastanfragen antwortet und dadurch eine Kettenreaktion entsteht, die den Netzverkehr beeinträchtigt. Der Bug tritt NUR bei Verwendung des IPX/SPX-Protokolls auf. Weitere Infos im Security Bulletin MS00-073.

Deutsch
98/SE: http://download.microsoft.com/download/win98SE/Update/11974/W98/DE/273727GER8.EXE

ME: http://download.microsoft.com/download/winme/Update/11974/Win ME/DE/273727GERM.EXE

Sicherheitsupdate für Hyperterminal

98/SE/ME

300 KB

Dieser Patch behebt ein Sicherheitsproblem in Hyperterminal. Dieses ist bei Windows 9x und ME als Standardanwendung für Telnet-Sitzung verknüpft. Ohne den Patch kann es zu einem Buffer Overflow kommen, den Hacker auslösen können. Nach dem Overflow können fremde Programme ausgeführt werden. Weitere Infos im Security-Bulletin MSMS00-079.

Deutsch
98/SE: http://download.microsoft.com/download/win98/Update/12395/W98/de/274548ger8.exe

ME: http://download.microsoft.com/download/winme/Update/12395/Win ME/de/274548germ.exe

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1180.htm


Updates für Windows NT

Hier finden Sie Service Packs (Updates) für Windows NT.

Service Packs

In der Tabelle finden Sie den Link zum letzten Servicepack von Windows NT. Microsoft hat den Support für Windows NT eingestellt, so das keine weiteren Service Packs mehr erscheinen werden.

Service Pack 6a

NT 4.0

-

Dies ist das Servicepack für Windows NT 4.0, es enthält alle vorherigen Service Packs

http://www.microsoft.com/ntserver/nts/downloads/recommended/SP6/allSP6.asp

Security Configuration Manager

NT 4.0

-

Eine GUI für die Sicherheitseinstellungen

http://www.microsoft.com/ntserver/nts/downloads/recommended/scm/default.asp

Weitere Infos zu den Servicepacks finden Sie unter: Service Pack Installation.

Info Updates und Fehlerkorrekturen, die aus Zeitgründen noch nicht in den Service Packs enthalten sind, werden durch sogenannte "Hot Fix Packs" abgedeckt. Infos dazu finden Sie unter: "Woher bekomme ich Hot Fix Packs?"

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1181.htm


Updates für Windows 2000

Service Packs für Windows 2000

Hier finden Sie die Liste der Service Packs für Windows 2000.

Art | Service Pack 4 (129 MByte)
Beschreibung | Link zur SP-Sprachenauswahl
Link | Netzwerk-Version

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0506.htm


Updates für Windows XP

Service Packs für Windows XP

Hier finden Sie die Liste der Service Packs für Windows XP.

Art | Update Builder
Beschreibung | Update Pack für Windows. Hier werden immer alle Updates zu einem Paket zusammengestellt, die nach einem Service Pack von MS herausgegeben wurden.
Link | http://download.winboard.org/files.php?cat=92

Art | Service Pack 2 (271 MByte)
Beschreibung | Windows XP Servicepack 2
Link | Netzwerk-Version

Art | Service Pack 3 (313 MByte)
Beschreibung | Windows XP Servicepack 2
Link | Netzwerk-Version

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1257.htm


Service Packs für Windows Vista und Windows 2008

Hier finden Sie die Liste der Service Packs für Windows Vista und Windows 2008.

Art | Update Builder
Beschreibung | Update Pack für Windows. Hier werden immer alle Updates zu einem Paket zusammengestellt, die nach einem Service Pack von MS herausgegeben wurden.
Link | http://download.winboard.org/files.php?cat=92

Art | Service Pack 1 (434 MByte)
Beschreibung | Windows Vista Servicepack 1
Link | Netzwerk-Version

Art | Service Pack 2 (1376 MByte)
Beschreibung | Windows Vista und Windows 2008 Servicepack 2
Link | Netzwerk-Version

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0999.htm


Windows-Unterstützung im Internet - WinFAQ stellt vor

Wir werden hier in loser Folge Webseiten vorstellen, die es uns besonders wert erscheinen, erwähnt zu werden. Diese Seiten zeichnen sich durch eine oder mehrere der folgenden Eigenschaften aus:

Konkrete Hilfe zu speziellen Windows-Problemen

Leicht nachvollziehbare Schritt-für-Schritt-Anleitungen

Hohe Aktualität

Übersichtlicher Aufbau und ansprechendes Design

Diese Serie beginnen wir mit dem Windows Support Center von James A. Eshelman.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1271.htm


Windows Support Center - James A. Eshelman

Im Windows Support Center von James A. Eshelman (http://aumha.org) finden Sie Hilfe, Tipps und Informationen u. a. zu folgenden Themen:

Windows Fehlermeldungen

Ausnahmefehler 0D | Ausnahmefehler 0E
Allgemeine Schutzverletzung | Ungültige Seite
Stackfehler | Windows Schutzverletzung
VxD Dynamic Link | STOP Fehler
Kernel32 Fehler | Verschiedenes

Windows Unterstützung im Internet

Unterstützung durch Microsoft | Microsoft Newsgroups
MVPs im Internet | Windows allgemein
Hardware, Treiber, BIOS | HTML Tutorial
IE, OE, Outlook | Sicherheit

Artikel, HOW-TOs und FAQs

Windows Upgrade (auf 98SE, ME, XP) | Speicherverwaltung
Ressourcen | Probleme mit Kernel32
Windows 98/ME "frisch" installieren | Passworteingabe unterdrücken
GIF- und JPG-Vorschau reparieren | Internet Explorer reparieren
Probleme mit dem Windows-Shutdown 15 Schritte zur Problemlösung | Partitionieren

Registry Patches

Reparieren der Systemsteuerung | Drag & Drop reparieren
"Senden an" reparieren | ShellIconCache vergrößern
Attribute im Explorer anzeigen | Kaskadierendes Startmenü
GIF- und JPG-Bildervorschau | Schnelles Herunterfahren abschalten

Artikel der Microsoft Wissensdatenbank (MS KB)

Windows-Hilfsprogramme | Systemsteuerung
Fehlermeldungen | IE & OE
Passwortprobleme | Registry
Windows starten und beenden | Fehlersuche

Freeware rund um Windows

Freeware für 95/98/ME

Freeware für NT/2K/XP

Wir werden ab der Version 5.6 der WinFAQ in mehr oder weniger regelmäßigen Abständen einzelne Seiten bzw. Themen übersetzen und hier veröffentlichen.

Über eine kurze E-Mail an (E-Mail: ) mit der Angabe, welches Thema Sie am meisten interessiert, würden wir uns freuen.

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1272.htm


Infos und Whitepapers von Microsoft

Hier finden Sie eine Liste mit Links zu Whitepapers und anderen Informationen von Microsoft.

Windows 7 RC - Leitfäden für IT Pros
Die speziell für IT-Professionals geschriebenen Leitfäden zum kommenden Betriebssystem Windows 7 wurden jetzt auf den Stand des Release Candidate gebracht. Das erste Dokument behandelt Netzwerk-Features wie DirectAccess und BranchCache, Bereitstellungsoptionen wie VHD-Boot sowie neue Sicherheitsfunktionen. Ein zweiter Leitfaden widmet sich ausschließlich dem Thema Verwaltung. Die beiden IT Pro Guides sind nur in englischer Sprache verfügbar.
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=c14b8a69-db3b-4b7c-9203-689b7719b8b6

Planen der Dokumentverwaltung
Der SharePoint Server ist in der aktuellen Version, Microsoft Office SharePoint Server 2007, ein regelrechter Alleskönner. Werkzeug für die Erstellung moderner Intranet-Portale, leistungsfähige Kollaborationsplattform oder unternehmensweite Suche - es wird alles geboten, was die Produktivität im Unternehmen beflügeln kann. Zu seinen Einsatzgebieten zählt auch das Dokumentenmanagement, also die Verwaltung des Lebenszyklus' von Dokumenten von der Erstellung, Überarbeitung und Veröffentlichung über den Gebrauch bis hin zur Archivierung bzw. Vernichtung.
http://technet.microsoft.com/de-de/library/cc263266.aspx

Windows Server 2008 R2 - Dokumentation und Whitepaper
Dokumenten rund um die neuen Technologien von Windows Server 2008 R2
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=079eb880-6e15-4381-9edf-53cfaff3ab02

Erweiterte Verwaltung von Active Directory
Mit diesem Dokument erhalten Sie eine Einführung in die erweiterte Verwaltung des Verzeichnisdienstes Active Directory mit dem MMC-Snap-In für die Active Directory Schemaverwaltung und der Möglichkeit zum Ändern von Anzeigebezeichnern. Sie können im Schema Klassen und Attribute hinzufügen/ändern und sowohl die Benutzershell als auch die Verwaltungsprogramme erweitern, indem Sie Attribute in Anzeigebezeichnern ändern.
http://www.microsoft.com/germany/technet/datenbank/articles/263837.mspx

Windows 2000 DNS Fehlermeldungen
Auflistung der Einträge des DNS Servers in der Ereignisanzeige.
http://support.microsoft.com/?kbid=259302

Windows 2000
Hier finden Sie die aktuellsten Whitepapers zu Windows 2000.
http://www.microsoft.com/windows2000/library/howitworks/default.asp

DX Setup Fehlermeldungen
Dieser Artikel beschreibt die Fehlermeldungen, die bei der Installation von DirectX auftreten können. DirectX stellt ein Paket von Komponenten dar, die durch direkten Zugriff auf Hardwarefunktionen die Leistung Ihres Systems verbessern.
http://support.microsoft.com/?kbid=177430

Sicherheit
Hier finden Sie Infos von MS zum Thema Sicherheit.
http://www.microsoft.com/security/default.mspx

Microsoft Office Kurse
Hier finden Sie mehrere kostenlose 2007 Microsoft Office System-Kurse für Outlook, Word, Excel, PowerPoint & Co.
http://co1piltwb.partners.extranet.microsoft.com/mcoeredir/mcoeredirect.aspx?linkId=12294775&s1=769bb5d7-259b-5eee-3a5d-dcf174f1ba1b

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0493.htm


Andere FAQ-Seiten im Internet

Hier finden Sie eine Aufstellung anderer FAQ-Seiten, die sich im Internet befinden.

Tipps zum Windows Betriebssystem

Tipps zu Outlook(-Express)

Tipps zu anderen bestimmten Windows Themen

Tipps zur Hardware und PC-Problemen

Tipps zum Windows Betriebssystem

WinBoard
Infos zu Windows. Hier werden auch immer alle Updates zu einem Paket zusammengestellt, die nach einem Service Pack von MS herausgegeben wurden.
Homepage: http://www.winboard.org/index.php

Windows 98 konfigurieren - ack's Home
Hier finden Sie Tipps und Einstellungen zu den Themen ShellIconCache, Netzwerk, ProductID, Sortierung in Dialogboxen, Windows-Update und einiges mehr.

Homepage: http://a-kaestner.de/

XPTweak
Diese Windows-Seite beschäftigt sich zum größten Teil mit Windows XP. Selbst verständlich finden Sie auch Unterstützung zu Windows 2000. Die Hilfe zu Windows 9x/ME und NT4.0 ist im Tipp-Archiv zu finden.

Homepage: http://www.xptweak.de

Windows Total
Wintotal bietet umfassende Infos, Downloads, Artikel und Tests rund um Windows 9x/NT/Windows 2000, ein riesiges Softwarearchiv sowie ein moderiertes Support-Forum.
Homepage: http://www.wintotal.de

NT FAQ
Auf dieser Seite finden Sie eine FAQ über Windows NT von John Savill. Die FAQ ist sehr umfangreich, kann aber leider nicht mehr zum Offlinelesen heruntergeladen werden.

Homepage: http://www.windowsitpro.com/windowsnt20002003faq/

Windows Tipps
Ganz egal, ob Windows, Office oder Visual Studio - wenn Sie Fragen zu einem Microsoft-Produkt haben, werden Sie hier fündig.
Homepage: http://web.zdnet.de/itsupport/mssupport/mssupport-wc.html

Bootdisketten
Webseiten, von denen Sie fertige Bootdisketten herunterladen können. Hier finden Sie neben den Standard-Disketten zu DOS und Windows auch echte Specials wie Dos-Disketten mit TCP/IP-Treibern, OS/2, Apple usw.
Homepage: http://www.bootdisk.com

xpboard
Hier finden Sie Diskussionsforum zu Windows 9x/NT/W2K/XP, anderen Betriebssystemen, Software, Hardware und und und ...
Homepage: http://www.windows-board.de

Windows 9x/ME/2000/XP Tipps & Tricks
Die Palette reicht von Installationshilfe über tiefgehende Speicheroptimierung und Tuning bis hin zu Problemlösungen und Tipps, die das Arbeiten mit Windows erleichtern. Ein "BIOS Tuning Guide" findet sich dort ebenso.
Homepage: http://www.windows-tweaks.info

XP-Tipps-Tricks
Auf dieser Seite finden Sie Tipps und Tricks, Tools und ein Forum zum Betriebssystem MS Windows XP.
Homepage: http://www.win-tipps-tweaks.de

Windows-Unattended
Hier wird beschrieben, wie man eine unattended Installation unter Windows durchführen kann.
Homepage: http://www.windows-unattended.de

PC-Tipps.net.ms
Neben diversen Tipps, welche die Arbeit mit Windows erleichtern, finden Sie auf www.pc-tipps.net.ms eine Fülle von Anleitungen zu verschiedenen Themen aus dem IT-Bereich, sowie eine sorgfältig zusammengetragene Auswahl der besten Downloads.
Homepage: http://www.pc-tipps.net.ms

NT-FAQ
Die NT-FAQ von Marc Grote besteht seit fast 10 Jahren und die FAQ hat einen Umfang von fast 1.000 Seiten und an die 9.000 Tipps.
Homepage: http://www.it-training-grote.de/nt_faq.php

Windows Secrets
Hier finden Sie Tipps und Tricks für Windows Vista
Homepage: http://www.windows-secrets.de/

Tipps zu Outlook(-Express)

Outlook Express 4/5/6 FAQ
Die Outlook Express Referenz schlechthin...
Homepage: http://oe-faq.de/

Outlook-NET FAQ
Alles über Microsoft Outlook
Homepage: http://www.outlook-net.de

Outlook FAQ
Microsoft Outlook FAQ
Homepage: http://www.docoutlook.de/

Outlook & Exchange Solutions Center
Soultions Center
Homepage: http://www.Slipstick.com

Outlook Tipps
Tipps und FAQs zu Outlook
Homepage: http://www.outlook-tips.net/index.html

Tipps zu anderen bestimmten Windows Themen

Internet Explorer Tipps und Tricks
Auf dieser Seite finden sich Tipps zur Problembehebung so wie Tricks zur einfacheren Bedienung des Microsoft-Browsers Internet Explorer ab Version 5.0.(Empfehlenswert)

Für Fragen und Meinungen steht ein Forum für den Internet Explorer und für Outlook Express zur Verfügung.

Die meisten der gesammelten Tipps stammen aus diversen IE-Newsgroups und der Microsoft Knowledge Base. Die Site wird unterhalten und gepflegt von Marci Castro (MS-MVP)
Homepage: http://ie6.winware.org/

NT FAX FAQ
Infos und Links zu NT FAX-Programmen.
Homepage: http://ntfaxfaq.com

Home of Peer FAQ
Hier finden Sie eine FAQ zum Thema Peer-to-Peer-Netzwerke. Leute, die sich das erste einmal mit Netzwerken beschäftigen und zu Hause ein kleines Netzwerk aufbauen wollen, finden hier viele Informationen
Homepage: http://peer-faq.dyndns.org/peerfaq/

Photoshop tutorial
Hier finden Sie Tipps/Hilfe und Anleitungen zu Photoshop
Homepage: http://www.on-design.de/tutor/photoshop/index.htm

Libe.net
Libe.net ist eine privat geführte Webseite die Anleitungen, Erkenntnisse, Ratschläge und News zum Thema Computer bzw. Video am Computer bereitstellt! Die Anleitungen sind großteils mit Bildern und auch für Laien verständlich erklärt und beziehen sich meist auf Software die im Internet frei verfügbar ist (Freeware, Open Source)!
Homepage: http://www.libe.net/

NT-Dienste sicher konfigurieren
Hier finden Sie ein Tool, womit Sie die Dienste von Windows leicht konfigurieren können.
Homepage: http://www.ntsvcfg.de

Excel Formeln
Hier finden Sie eine Übersicht von nützlichen Excel Formeln.
Homepage: http://www.excelformeln.de/uberuns.html

Neues rund um Powerpoint
Hier finden Sie Tipps und Tricks zu Powerpoint
Homepage: http://www.ppt-faq.de/

Internet Explorer Tipps
FAQs für den Microsoft Internet Explorer 5
Homepage: http://www.activewin.com/faq/ie5_faq.shtml

MS Exchange
Exchange FAQs
Homepage: http://www.msexchangefaq.de/

Service Pack 3
Hier finden Sie ausführliche Informationen über das Service-Pack für Windows
Homepage: http://www.service-pack-3.de/

Onlineschutz
Onlineschutz.org ist ein im Mai 2009 gestartetes nicht kommerzielles Privatprojekt, welches sich zum Ziel gesetzt hat, dem Computerlaien die Thematik der Internet-Sicherheit näher zu bringen und ihm bei Problemen zu unterstützen. Die Idee zu dem Projekt ist durch Erfahrungen aus dem privaten und geschäftlichen Umfeld entstanden, wo viele mit der Thematik überfordert zu sein scheinen. Daher ist es unsere Hauptprämisse das Thema Internet-Sicherheit für Jedermann leicht verständlich zu machen und so dafür zu sorgen, dass das Internet ein Stück sicherer wird.
Homepage: http://www.onlineschutz.org/

Tipps zur Hardware und PC-Problemen

PC FAQ
Hier finden Sie die PC-FAQ, die sich mit Problemen mit dem PC beschäftigt.
Homepage: http://www.pc-faq.de

BIOS FAQ
Hans Peter Schulz macht sich viel Mühe, die Geheimnisse aller BIOS -Versionen zu lösen. Viele Tipps und Hinweise zu allen Optionen sind in diesem Kompendium zusammengefasst.
Homepage: http://www.bios-info.de/

Hardware Book
Der Schwerpunkt liegt hier bei Stecker und Kabelbelegungen
Homepage: http://www.hardwarebook.info/

>
Mainboardforum
Tipps und Infos zu Mainboards
Homepage:http://www.mainboardforum.de

Glasfaserinfo
Infos über Netzwerkverkabelung, insbesondere Glasfaser.
Homepage: http://www.glasfaserinfo.de/

Userhelpdesk - PC-experience.de
Wir sind seit August 2002 online und haben uns der Hilfe für gestreßte PC-User verschworen. Wir sind ein Team aus MCSE's und anders qualifiziertem IT'lern, also keine Theoretiker, sondern kommen alle aus der Praxis.
Homepage: http://www.pc-experience.de

Sonstige Tipps

ARCHmatic-Glossar und -Lexikon
Sie können mit einem Computer-Fachbegriff nichts anfangen? Dann sollten Sie hier einmal vorbeischauen.

Das Nachschlagewerk befasst sich mit Themen wie Internet, Netzwerk, EDV allg., CAD, Grafik, Video,...

Homepage: http://www.glossar.de

Download: http://www.myglossar.de/download/glossar.exe (Windows-Archiv)

Selfhtml
Hier finden Sie alles, was Sie über HTML schon immer wissen wollten. Ein Muss für Leute, die eine Homepage erstellen.
Homepage: http://www.selfhtml.org/

Informationen zu XML
Vom World Wide Web Consortium empfohlenes deutsches Handbuch
Homepage: http://edition-w3c.de/TR/2000/REC-xml-20001006/

IT Begriffsdatenbank
Hier werden über 12.500 aktuelle IT-Begriffe beschrieben (mit Suchfunktion)
Homepage: http://glossary.ges-training.de/

CDR FAQ
Tom Muller hat FAQs rund ums CD-Brennen, welche auch offline gelesen werden kann. Die Webseite bietet weiterführende Infos und Links
Homepage: http://www.brennmeister.com/

Trojaner Info-FAQ
Der ultimative Informationskatalog rund um das Thema 'Trojanische Pferde'. Der Anwender findet hier genügend Material zur eigenen Problembehebung bzw. Lösungswege rund um Trojaner. Weiterhin finden Sie hier noch: "Wie mache ich meinen PC in 5 Schritten relativ internetsicher?" Dieses Werk soll dem Internet-Einsteiger einen ersten Überblick über die verschiedenen Möglichkeiten zum Selbstschutz im Internet vermitteln.
Homepage: http://www.trojaner-info.de/

Refill-FAQ
Die Refill-FAQs bietet ausführliche Informationen zum Thema "Wiederbefüllen von Tinten-Patronen". Neben der eigentlichen Technik für jeden Patronentyp werden auch "Basiswissen" und Hintergründe über die Patronen erläutert. Die FAQ ist zudem passend bebildert.
Homepage: http://www.refill-faq.de/

PC-Infoz
PC-Infoz stellt eine umfangreiche Tippsammlung dar.
Homepage: http://www.computerdb.de/

NetzAdmin.org
Beschäftigt sich mit der Einrichtung von Netzwerken unter Windows und DOS und der Einrichtung von Servern (Mail, WWW, Proxy...)
Homepage: http://netzadmin.org

network lab - Das Netzwerkportal
Dies ist das Portal für alle Themen rund ums 'Netzwerk'. Der Schwerpunkt liegt auf Netzwerkanalyse und Fehlersuche in Netzwerken. Testberichte, Tutorials und Sicherheitsnotizen rund en das Angebot ab.
Homepage: http://www.nwlab.net/

Gaijin
Sicherheit im Internet, Infos, Tools und Download
Homepage: http://www.gaijin.at/

Inventor FAQ
Inventor ist ein 3D CAD Programm von Autodesk.
Homepage: http://www.inventor-faq.de

Deutsche Citrix User Group (DCUG)
Benutzer-Forum zum Thema Citrix/Terminalserver.
Homepage: http://www.dcug.de

Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0491.htm


Infos über die Sicherheit von Windows

Hier finden Sie Internetseiten, die sich mit Sicherheitslücken unter Windows beschäftigen.

InSecure

Hier finden Sie eine Liste von Sicherheitsfehlern unter Windows und Informationen über die Ausnutzung der Sicherheitslöcher.

Homepage: http://www.insecure.org

IIS

Datenbank über Sicherheitslöcher von Windows NT.

Homepage: http://www.iis .NET

Articon Integralis

Weitere Seite, die sich mit Sicherheit in Netzwerken beschäftigt.

Homepage: http://www.integralis.com/

LOpht Heavy Industries

Hier gibt es das Programm "I0phtcrack" mit welchen Sie das Passwort auslesen können, auch finden Sie hier viele Infos für Programmierer.

Homepage: http://www.l0phtcrack.com/

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0492.htm


Sonstige Internetlinks

Sonstige Links

Windows Desktop

Auch hier finden Sie etliche Programme, die sich mit dem Aussehen des Desktops und der Handhabung des Windows Explorers befassen.

Homepage: http://www.shellcity .NET

Data Advisor

Festplattenanalyse

Homepage: http://www.ontrack.com/dataadvisor/

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0482.htm


Newsgroups

In den Newsgroups finden Sie etliche Themen über Windows. Hier können Sie selber Fragen stellen oder nach Antworten suchen.

de.comp.os.ms-windows.misc | Allgemeines über Windows Sprache: DEUTSCH
de.comp.os.ms-windows.nt | Allgemeine Windows NT-Diskussion Sprache: DEUTSCH
microsoft.public.de.german.windowsnt.server | Über Windows NT Server Sprache: DEUTSCH
microsoft.public.de.german.windowsnt.workstation | Über Windows NT Workstation Sprache: DEUTSCH
microsoft.public.de.german.win98.allgemein | Allgemeines über Windows 98 Sprache: DEUTSCH
comp.os.ms-windows.nt.admin.misc | Windows NT System Administration Sprache: ENGLISCH
comp.os.ms-windows.nt.admin .NETworking | Windows NT Netzwerk Administration Sprache: ENGLISCH
comp.os.ms-windows.nt.advocacy | Windows NT Advocacy Sprache: ENGLISCH
comp.os.ms-windows.nt.pre-release | Windows NT Beta-Versionen Sprache: ENGLISCH
comp.os.ms-windows.nt.software.backoffice | Windows NT Back Office Software Sprache: ENGLISCH

MS Newsgroups:

http://www.microsoft.com/germany/support/newsgroup.htm

Info Über neue Links bzw. Hinweise auf ungültige Links würde ich mich freuen. Senden Sie einfach eine E-Mail an (E-Mail: ).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0522.htm


Untergeordnete Ordner immer offline verfügbar machen

Mit diesem Tipp können Sie einstellen, ob untergeordnete Ordner offline zur Verfügung stehen, wenn deren übergeordnete Ordner offline verfügbar ist.

Durch diese Einstellung wird die Einstellung "Offline verfügbar machen" auf alle neuen und bestehenden untergeordneten Ordner eines Ordners angewendet. Benutzer können untergeordnete Ordner nicht ausschließen.

Durch Aktivieren dieser Einstellung werden alle Ordner innerhalb eines Ordners, der offline verfügbar gemacht wird, offline zur Verfügung gestellt. Zusätzlich werden neue Ordner, die innerhalb dieses Ordner erstellt werden, ebenso offline verfügbar gemacht, wenn der übergeordnete Ordner synchronisiert wird.

Wenn Sie diese Einstellung deaktivieren oder nicht konfigurieren, werden Benutzer gefragt, ob untergeordnete Ordner auch offline verfügbar gemacht werden sollen, wenn ein Ordner offline zur Verfügung gestellt wird.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "AlwaysPinSubFolders" als Datentyp REG_DWORD.

Setzen Sie den Wert zwischen:

1 | Untergeordnete Ordner werden offline verfügbar gemacht (ohne Nachfrage)
gelöscht | Es wird nachgefragt ob untergeordnete Ordner auch offline verfügbar gemacht werden sollen (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | NEIN
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Untergeordnete Ordner immer offline verfügbar machen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1970.htm


Funktion "Daten wiederherstellen" aus "Sicherungsstatus und -konfiguration" sperren

Mit diesem Tipp können Sie verhindern, dass die Funktion "Daten wiederherstellen" aufgerufen werden kann. Wenn Sie den Tipp aktivieren, kann die Funktion "Daten wiederherstellen" aus der Anwendung "Sicherungsstatus und -konfiguration" (SDCLT.EXE) nicht mehr ausgewählt werden. Es können keine Sicherungen von Daten mehr zurückgespielt (Restore) werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ Backup\ Client

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableRestoreUI" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Zugriff auf "Daten wiederherstellen" sperren
0 | Zugriff auf "Daten wiederherstellen" zulassen (Standard)

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Sicherungskopie\Client
Einstellungsname: | Wiederherstellungsfunktionen deaktivieren

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2309.htm


Umgeleitete Ordner nicht automatisch offline verfügbar machen

Mit diesem Tipp können Sie einstellen, ob umgeleitete Shellordner, wie "Eigene Dateien", "Desktop", "Startmenü " und "Anwendungsdaten", offline zur Verfügung stehen.

Mit dieser Einstellung können Sie dieses Verhalten so ändern, dass umgeleitete Shellordner nicht automatisch für die Verwendung im Offlinemodus bereitstehen. Die Benutzer können jedoch weiterhin selber Dateien und Ordner offline verfügbar machen.

Wenn Sie diese Einstellung aktivieren, müssen die Benutzer die Dateien manuell auswählen, die offline zur Verfügung stehen sollen

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ NetCache

Erstellen Sie hier einen neuen Wert mit dem Namen "DisableFRAdminPin" als Datentyp REG_DWORD.

Setzen Sie den Wert zwischen:

1 | "Umgeleitete Ordner" werden nicht verfügbar gemacht
0 | "Umgeleitete Ordner" sind verfügbar (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Netzwerk\Offlinedateien
Einstellungsname: | Umgeleitete Ordner nicht automatisch offline verfügbar machen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1969.htm


Das Datei-Menü des Explorers ausblenden

Wenn Sie diese Policy aktivieren, wird das Datei-Menü (File-Menü) vom Explorer ausgeblendet.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileMenu" als Datentyp REG_DWORD. Setzen Sie den Wert auf:

1 | Eintrag wird nicht angezeigt
gelöscht | Eintrag wird angezeigt (Standard)

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | NEIN
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Windows Explorer
Einstellungsname: | Menü "Datei" aus Windows Explorer entfernen

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1574.htm


Glossar

SideShow
Die Funktion Sideshow, ermöglicht auf einem separaten Display auch bei ausgeschaltetem Notebook Inhalte abzurufen. Beispielsweise lassen sich so Bilder und Videos anschauen, Mails lesen und Musikdateien anhören. Auch für Desktop-Systeme gibt es Zusatzdisplays, die Informationen aus dem Internet auch dann anzeigen und abrufbar machen, wenn der Rechner selbst heruntergefahren wurde oder im StandBy-Modus läuft. Die SideShow-Minianwendungen hängen direkt mit den Gadgets der Windows Sidebar zusammen.


Zugriffsrechte auf unterschiedliche Objekte setzen

Schablonen

Öffnen Sie anschließend die Kommandozeile als Administrator und geben Sie folgenden Befehl ein:

Wenn Sie den Eintrag "RecordWriteInterval" aktivieren (Festlegung auf "1"), legt der WSRM den angegebenen Wert als Kontoführungsintervall fest.

Wenn Sie diese Einstellung nicht konfigurieren, kann ein Kontoführungsintervall vom Benutzer angegeben werden (Standardwert = 10 Minuten).

[für den Anwender]

HKEY_CURRENT_USER\ Software\

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\

oder als Policies

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\

Erstellen Sie hier einen neuen Wert mit dem Namen "" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Eintrag wird nicht angezeigt
1 | Eintrag wird angezeigt (Standard)

Diese Einstellung bezieht sich auf die neue Startmenüansicht und nicht auf die alte "klassische Ansicht".

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Weitere Informationen hierzu finden Sie in der MS Knowledge Base: http://support.Microsoft.com/?kbid=xxxxxxx

Wenn Sie die Einstellung über diesen Tipp konfigurieren, können die Benutzer die Einstellung über den Explorer nicht mehr verändern.

Wenn Sie den Eintrag "NoThemesTab" aktivieren (Festlegung auf "1"), wird der Tabreiter ausgeblendet.

Sie müssen [Version] durch Ihre aktuelle Office Version ersetzen:

9.0 | Office 2000
10.0 | Office 2002
11.0 | Office 2003
12.0 | Office 2007

=== Hier schneiden ===

=== Hier schneiden ===

In der Professional Version von Windows können Sie dieses auch über die Gruppenrichtlinie konfigurieren. Starten Sie dafür über "Start" -> "Ausführen" die Datei "gpedit.msc" und gehen Sie unter:
Computerkonfiguration: | JA
Benutzerkonfiguration: | JA
Pfad: | Administrative Vorlagen\Windows-Komponenten\Internet Explorer\Internetsystemsteuerung
Einstellungsname: | Verbindungsseite deaktivieren


Dieser Artikel wird erst in einer späteren Version verfügbar sein

Dieser Artikel wird erst in einer späteren Version verfügbar sein.


Popup: Frank Ullrich

Über die Kommandozeile/Eingabeaufforderung (CMD.EXE) können Sie Befehle ausführen. Die Eingabeaufforderung öffnen Sie über den Eintrag "Eingabeaufforderung" im Startmenü, oder über die Eingabe von CMD.EXE.

Ab Windows Vista wird die Eingabeaufforderung standardmäßig nicht mit administrativen Rechten geöffnet. Suchen Sie dafür im Startmenü nach CMD.EXE und klicken Sie mit der rechten Maustaste auf die Datei. Wählen Sie aus dem Kontextmenü den Eintrag "Als Administrator ausführen" aus.


Popup: Frank Ullrich

Bei der Angabe "Ab" und "Bis" bei den Betriebssystem wird von der folgenden Reihenfolge der Betriebssysteme ausgegangen:

  • Windows 95 (auch Windows 9x)
  • Windows 98 (auch Windows 9x)
  • Windows ME
  • Windows NT
  • Windows 2000
  • Windows XP
  • Windows 2003
  • Windows Vista


Popup: Frank Ullrich

Frank Ullrich

E-Mail:

Homepage: http://www.winFAQ.de


Popup: Regedit-Info

Die Datei befindet sich im Windows-Verzeichnis und heißt REGEDIT.EXE (-> "Start" -> "Ausführen" REGEDIT eingeben)

Achtung: Unbedingt die Hinweise unter Regedit beachten!


Popup: Robert Schwarzenbauer

Schrieb die Registry FAQ, hat aber das Weiterführen der Datei aufgegeben.

Alle Tipps sind jetzt auch in dieser FAQ mit enthalten. Für seine Tipps möchte ich mich noch einmal bedanken.


Popup: für das System

Wenn dieser Schlüssel vorhanden ist, ist es egal was unter HKCU eingetragen ist. Dieser Wert überschreibt den anderen Eintrag.


Popup: Standard

Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standardwert benutzt.


Popup: AGP

AGP (Accelerated graphics port) ist eine beschleunigte Grafik-Schnittstelle, welche von Intel entwickelt wurde. Hiermit kann die Grafikkarte unter anderem auf den Hauptspeicher zugreifen und ihn mitbenutzen, wodurch die Geschwindigkeit gegenüber PCI erhöht wird.


Popup: DFS

DFS unterstützt die Erstellung eines einzigen logischen Dateisystems - basierend auf einer Vielzahl physikalischer Systeme.

So entsteht eine Umgebung, die für den Benutzer überschaubar ist und die im Hinblick auf den Geräteeinsatz auch effektiv genutzt werden kann. Mit DFS kann ein einziger Verzeichnisbaum erstellt werden, der mehrere Dateiserver und Dateifreigaben in einer Gruppe, einer Abteilung oder einem Unternehmen umfasst, so dass Benutzer Dateien oder Ordner einfach auffinden können, die über das gesamte Netzwerk verteilt sind.


Popup: Windir

Bei Angabe von %[Variablenname]% handelt es sich um Windows Variablen die den Pfad zu einem Verzeichnis enthalten.

Die Variable %WINDIR% enthält z.B. den Pfad zum Windows-Verzeichnis.

Über den Befehl "SET [Variablenname]" bzw. "Echo %[Variablenname]%" - in der Kommandozeilenoberfläche - können Sie sich den Inhalt anzeigen lassen.

Beispiel: "SET WINDIR" oder ""Echo %WINDIR%"

Der Befehl "SET" ohne Variablenname zeigt alle gültigen Variablen an.

Siehe dazu auch Tipp: "Umgebungsvariablen in Windows"


Popup: Policies

Einstellungen, die innerhalb von Schlüsseln mit POLICIES gespeichert werden, sind Konfigurationseinstellungen, welche Einstellungen, die über die Oberfläche gemacht wurden, überschreiben. Diese Einstellungen können vom Anwender nicht mehr verändert werden. Weiterhin werden damit oft auch Einstellungsmöglichkeiten für den Anwender ausgeblendet.

Ist der Wert nicht vorhanden (gelöscht), gelten die Standardeinstellungen von Windows. Diese Standardeinstellungen können oft über die Oberfläche vom Anwender geändert werden.

Weitere Infos dazu finden Sie unter: "[Betriebssystem]\Policy/Sicherheit\Systemrichtlinien und ADM" in der WinFAQ


Popup: Datei erstellen

1. Windows Explorer öffnen.

2. Unter Extras -> Ordneroptionen -> Ansicht muss "Erweiterungen bei bekannten Dateitypen ausblenden" deaktiviert sein.

3. Im Explorer - im rechten Fenster auf eine leere Fläche mit der rechten Maustaste klicken - und aus dem Kontextmenü "Neu" -> "Textdatei" auswählen.

4. Einen beliebigen Namen eingeben.

Wichtig:

ist, dass die Endung von bisher .TXT auf die Endung - wie im Tipp angegeben - (z.B.: .CMD bzw. .REG) umgeändert wird.

5. Nach ENTER den Text "Wenn Sie die Dateinamenerweiterung ändern....." bestätigen.

6. Die Datei mit der rechten Maustaste anklicken und aus dem Kontextmenü "Bearbeiten" auswählen.

7. Dem Text aus dem Tipp zwischen "=== Hier schneiden ===" markieren, kopieren und in die Datei einfügen.

8. Datei abspeichern und, wenn gewünscht, ausführen.


Sonstige Programme

Da der Inhalt nicht mehr aktuell ist und es genügend Seiten gibt, wo Programme vorgestellt werden, habe ich diese Übersicht in der WinFAQ eingestellt.

Siehe: EFB.NU - Freeware

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0027.htm


Information

Info Entweder haben Sie eine unvollständige Version oder Sie haben die Datei WINHLP.CNT gelöscht!

Damit das HLP-File richtig angezeigt wird, muss diese Datei unbedingt vorhanden sein. Besorgen Sie sich bitte die vollständige Version!

Woher bekomme ich die FAQ?

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0175.htm


MSINFO INF File

Hier die geänderte Datei:

; MSINFO INF file

[version]

signature="$CHICAGO$"

SetupClass=BASE

LayoutFile=layout.inf

; Base options only happen during Windows Setup

; Setting up the registry settings and INF file locations

[BaseWinOptions]

Msinfo.reg

[Msinfo.reg]

CopyFiles=msinfo.copyfiles.inf, Help.CopyFiles, citCopy.sys

AddReg=Online.reg

[destinationdirs]

CitCopy.sys=11 ; windows\system

Msinfo.copyfiles.inf=17 ; windows\inf

Help.CopyFiles=18 ; windows\help

[Msinfo.copyfiles.inf]

msinfo.inf

[Help.CopyFiles]

apmcp.hlp

apmcp.cnt

display.hlp

pingname.bat

pingnum.bat

rnaapp.hlp

unimdm.hlp

whatsnew.hlp

update.cnt

[CitCopy.sys]

drwatson.exe

URL: http://www.winfaq.de/faq_html/Content/tip0000/tip0381.htm


Mögliche Einstellungen mit Tweak UI 98

Die aktuellste Version von Tweak UI 1.33 finden Sie hier. Die älteren Versionen (wie z.B. diejenige auf der Windows 98-CD) sollten Sie nicht mehr verwenden.

Eine Beschreibung aller Menüpunkte finden Sie unter "Tweak UI 1.33: Alle Funktionen im Überblick".

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0516.htm


Programme zum Beschränken von Festplattenplatz (Quota Server)

Stand: 26.06.98

Was bei einem Novell-Server schon zum Standard gehört, ist bis heute bei einem NT-Server noch nicht zu finden. Erst ab der Version 5.0 soll diese Funktion auch unter NT zum Lieferumgang gehören (so wie es aussieht, wird der eine unten aufgeführt "Quota Server" von MS aufgekauft).

Bei der Verwaltung von großen Netzen ist so etwas aber schon zum heutigen Zeitpunkt recht nützlich, denn die USER bekommen auch den größten Speicherplatz voll. Will man also die Anwender heutzutage schon den Plattenplatz beschneiden, muss man sich nach Fremdprodukten auf den Mark umsehen.

Ich habe zur Zeit nur folgende Produkte gefunden:

  1. Quota Manager Enterprise 4.0
  2. SpaceGuard 4.2
  3. Quota Server 4.5a
  4. Quota Advisor 2.1

Ich weiß, dass es noch ein Produkt Namens "Miss Marpel" gibt, da aber die Demo-Version vom Server nicht funktionierte und ich nach mehrmaligen Anrufen und Versicherungen, man werde mir eine neue Version zusenden, nie was bekommen habe, ist die Firma schon durch ihren schlechten Support bei mir durchgefallen. Außerdem habe ich von einigen Firmen nichts Gutes über deren Quata-Server gehört.

Ich möchte noch darauf hinweisen, dass die Benutzung solcher Software die Performance eines Server doch sehr belastet. Das ist dadurch bedingt, dass NT keine Funktionalitäten in diesem Bereich zu Verfügung stellt und somit alle Programme immer die Verzeichnisse in bestimmten Intervallen überprüfen müssen. Je nach Funktionsweise der Software ist dadurch eine zusätzlich Belastung des Server mehr oder weniger gegeben.

Quota Manager Enterprise 4.0

Firma: | New Technologiy Partners
Internet: |
Deutscher Vertrieb: | In Europa exklusiv von der Firma: Sunbelt Software Distribution
Internet: | http://www.ntsoftdist.com
Preis: | ca. 495$

Nachteile:

  • Es ist nicht möglich, bei den Verzeichnissen einzustellen, bei z.B. 80% Belegung den Administrator zu informieren.
  • Es ist nicht möglich, für unterschiedliche Verzeichnisse unterschiedliche Gruppen/USER anzugeben, die benachrichtigt werden sollen.
  • Unterstützt kein Versenden von SNMP-Traps
  • Ausführen von Batches/Programmen für bestimmte Quoten ist nicht möglich
  • Beim Überschreiten der Größenangabe wird trotzdem die letzte Aktion noch ausgeführt. Wurde also vorher ein ganzer Ordner mit vielen Dateien markiert und kopiert, werden nun trotzdem alle Dateien noch kopiert (dadurch wurde bei mir das Limit um 40 MB zusätzlich noch überschritten).
  • Einstellen der USER/Gruppen passiert nicht durch einfaches Auswählen aus dem USER-Manager, sondern muss umständlich eingegeben werden.
  • Die Installation dieses Programms ist nicht gerade einfach und benutzerfreundlich. Werden nicht die vorgeschlagenen Optionen benutzt, ist ein erheblicher Aufwand nötig. Auch ist keine Remote- Installation von diesen Produkt möglich.
  • Keine Möglichkeit zur Unattended Installation gegeben.
  • Hat ein USER "Volle Rechte" auf ein Verzeichnis (wie es meist beim Home-Verzeichnis der Fall ist), kann er das Diskqouta umgehen!

Fazit:

Er bietet gegenüber den beiden anderen Programmen keine besonderen Funktionen und ist durch seinen eingeschränkten Funktionsumfang eher für kleiner Netze mit geringer Useranzahl zu gebrauchen.

SpaceGuard 4.2

Firma: | Simac Software
Internet: | http://www.tools4nt.com
Deutscher Vertrieb: | euro-tools
Internet: | http://www.euro-tools.de
Preis: | ca. 1000,- DM

Vorteile:

  • Das Programm greift bei allen Funktionen auf die NT USER-Datenbank zurück. Dadurch ist das Angeben von USERN, die benachrichtigt werden sollen recht einfach.
  • Alle Einstellungen können gesondert für jedes Quota eingestellt werden. So ist es auch möglich extra anzugeben, welche Gruppe benachrichtigt werden soll.
  • Es werden bis zu zwei Stufen unterschieden. So kann eine Warnung ausgegeben werden, bevor das Limit erreicht wird.
  • Wird nicht als Gerätetreiber eingebunden. Sollte es einmal einen Fehler mit dem Programm geben, wird der NT-Server nicht beeinträchtigt.
  • Alle Plattenbeschränkungen von allen Servern werden in einem Fenster übersichtlich angezeigt, man muss nicht jeden einzelnen Server jedesmal auswählen.
  • Remote Installation möglich.
  • API- Schnittstelle vorhanden
  • Bei Überschreitungen können Emails, Pop-Up-Meldungen, SNMP-Meldungen und Programme ausgeführt werden.
  • Das Anzeigen der Informationen kann beliebig geändert werden.

Nachteile:

  • Keine Möglichkeit zum Erstellen von Trendanalysen und Statistiken

Fazit:

Durch seinen übersichtlichen Aufbau und den direkten Zugriff auf die Userdatenbank ist dieses Programm für große Netzwerke gut zu gebrauchen. Der einfache und übersichtliche Aufbau hat einen geringen administrativen Zeitaufwand zur Folge.

Quota Server 4.5a

Firma: | Northern Technologies
Internet: | http://www.northern.se (Schweden)
Preis: | ca. 1190,- DM

Vorteile:

  • Volle Integration im File-Manager
  • Volle Integration in den MS-Explorer
  • Unterstützung von SMTP und SNMP
  • Export als ODBC- oder HTML-Datei
  • Stellt ein API zur Integration in eigene Anwendungen zur Verfügung
  • Trendanalysen und Statistiken ermöglichen eine effiziente Planung
  • Jeder Administrator hat über die "Pages" die Möglichkeit sich den Quota Server so zu konfigurieren, wie er möchte. Dies erlaubt z.B. Ansichten wie "Zeige mir alle Server aber nur wenn Quoten einen bestimmten Level überschritten haben"

Quota Server arbeitet eventgesteuert, was bedeutet, dass das Berechnen einer Quote nur dann erfolgt, wenn sich innerhalb dieser etwas geändert hat (Datei schreiben, speichern oder löschen).

Nachteile:

  • Kein direkter Zugriff auf die NT USER-Datenbank, diese muss erst über ein Tool für das Programm umgewandelt werden
  • Die Installation von diesen Programm ist nicht gerade einfach und benutzerfreund lich. Werden nicht die vorgeschlagen Optionen benutzt, ist ein erheblicher Aufwand nötig. Auch ist keine Remote-Installation von diesem Produkt möglich (unterstützt wird aber eine "Silent-Installation" über die Scripts von Install Shield, damit wird das dann doch wieder etwas vereinfacht).
  • Alle Daten werden in die Registry eingetragen, dadurch kann das Microsoft Clustering Services (MCS) nicht unterstützt werden.
  • Auch hier gibt es keine Möglichkeit zur Gesamtübersicht aller Server.
  • Bietet kein verzögertes Prüfen an, was eine hohe Serverlast bedeutet
  • Hat ein USER "Volle Rechte" auf ein Verzeichnis (wie es meist bei dem Home-Verzeichnis der Fall ist) kann er das Diskqouta umgehen!
  • Das Lizenzverfahren ist sehr unschlüssig und kompliziert aufgebaut!

Fazit:

Da man das Programm auch über die Kommandozeilenoberfläche steuern kann, bietet es sehr viele Möglichkeiten, Vorgänge zu erleichtern. Leider wird nicht direkt auf die NT Userdatenbank zugegriffen, sondern muss erst mit einem Tool umgewandelt werden.

Quota Advisor 2.1

Firma: |
Internet: |
Deutscher Vertrieb: | Newlog GmbH
Internet: | http://www.symark.co.uk
Preis: | ca. 1900,- DM

Dieser Quota-Server ist der einzige, der es zulässt, Speicherplatzbeschränkungen für USER und Gruppen anzulegen, alle anderen arbeiten auf Datei/Verzeichnisebene.

Vorteile:

  • Anlegen von Festplatten, Speichereinschränkungen für einzelne USER/Gruppen
  • Man kann bis zu 5 Schwellwerte einstellen, wo Warnungen und Aktionen ausgeführt werden können, ob man so viel Schwellwerte braucht ist aber fraglich!

Nachteile:

  • Das Programm muss auf jeden Server installiert werden der überwacht werden soll. Es werden alle Ein- und Ausgaben überwacht und mit der angelegten Datenbank verglichen. Dadurch ist die Auslastung des Server höher als bei allen anderen Qouta-Servern.
  • Das Programm muss auf jeden Server installiert werden der überwacht werden soll. Es werden alle Ein- und Ausgaben überwacht und mit der angelegten Datenbank verglichen. Dadurch ist die Auslastung des Server höher als bei allen anderen Qouta-Servern.
  • Das Programm muss auf jeden Server installiert werden der überwacht werden soll. Es werden alle Ein- und Ausgaben überwacht und mit der angelegten Datenbank verglichen. Dadurch ist die Auslastung des Server höher als bei allen anderen Qouta-Servern.
  • Das Programm muss auf jeden Server installiert werden der überwacht werden soll. Es werden alle Ein- und Ausgaben überwacht und mit der angelegten Datenbank verglichen. Dadurch ist die Auslastung des Server höher als bei allen anderen Qouta-Servern.
  • Bei einem Update auf eine neue NT-Version muss der Dienst deinstalliert werden!
  • Es gibt keine Möglichkeit alle Plattenbeschränkungen aller Server übersichtlich auf einen Bild zu sehen, bei mehr als 3 Server ist es dann schon immer umständlich erst jeden Server auszuwählen

Fazit:

Dieses Programm arbeitet vollkommen anders als die anderen Produkte. Es ist das einzige Programm, welches eine USER/Gruppen-Verwaltung der Plattenbeschränkung bietet. Diese gute Funktionalität wird leider mit sehr großer Serverlast erkauft.

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0729.htm


Funktionen des Desktops ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Grafik\ (Funktionen deaktivieren/ausblenden).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0808.htm


Funktionen des Explorers ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Arbeitsoberfläche und Explorer\ Explorer\ (Funktionen deaktivieren/ausblenden)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0809.htm


Funktionen zur Bildschirmsteuerung ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Grafik\ (Funktionen deaktivieren/ausblenden)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0810.htm


Funktionen zur Druckersteuerung ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Drucker\ Funktionen deaktivieren/ausblenden).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0811.htm


Funktionen zur Netzwerksteuerung ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Netzwerk\ (Funktionen deaktivieren/ausblenden).

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0812.htm


Funktionen von SYSTEM der Systemsteuerung ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Arbeitsoberfläche und Explorer\ Systemsteuerung\ (Funktionen deaktivieren/ausblenden)

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0816.htm


Funktionen des Internet Explorers ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \Anwendungsproramme\ Browser Einstellungen (IE/Netscape)\ IE\ Funktionen ein-/ausblenden

URL: http://www.winfaq.de/faq_html/Content/tip0500/tip0901.htm


Funktionen aus dem Startmenü ein/ausblenden

Diese Auflistung der Tipps wird zur Zeit aufgelöst. Jeder Tipp bekommt einen extra Eintrag, da zu viele Einträge für unterschiedliche Betriebssysteme sind.

Die Tipps finden Sie jetzt unter \<Betriebssystem>\ Arbeitsoberfläche und Explorer\ Startmenü\ (Funktionen deaktivieren/ausblenden)

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1219.htm


Sonstige Programme (2)

Der der Inhalt nicht mehr aktuell ist und es genügend Seiten gibt wo Programme vorgestellt werden, habe ich diese Übersicht in der WinFAQ eingestellt.

Siehe: EFB.NU - Freeware

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1233.htm


Zusätzliche Treiber im 'Abgesicherten-Modus' (XP)

Mit der Taste F8 können Sie Windows im Abgesicherten-Modus starten, sollten z.B. Probleme beim Start von Windows auftreten.

Im Abgesicherten-Modus werden nur unbedingt benötigte Treiber geladen, damit Windows auch nach der Installation von fehlerhaften Treibern noch startet.

Welche Treiber geladen werden, wird in der Registry festgelegt. Wird also ein bestimmter Treiber auch im Abgesicherten-Modus benötigt, können Sie die Liste erweitern.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ SafeBoot

URL: http://www.winfaq.de/faq_html/Content/tip1000/tip1313.htm


Registry System Wizard

Dieses Programm ist für alle gedacht, die gern einige Tipps aus der WinFAQ nutzen möchten, sich aber nicht so gern durch die Registry von Windows hangeln wollen.

Tipps aus der WinFAQ, die Änderungen an der Registry beschreiben, können mit diesem Programm durch einfaches Auswählen der möglichen Optionen durchgeführt werden. Des weiteren zeigt das Programm die gerade aktuellen Einstellungen an.

Welche Funktionen sind eingebunden?

  • Anzeigen und Bearbeiten von Registryschlüsseln, wobei die Einträge ausführlich beschrieben werden.
  • Ändern der Registry über das Netzwerk unter Windows NT4/2000/XP/2003
  • Automatisches Erstellen einer REG-Datei anhand der aktuellen Einstellung (von einzelnen Tipps oder von selbst zusammengestellten Tippgruppen)
  • Suchfunktion nach Stichworten in der Tippliste
  • Automatische Erstellung einer Verlaufs-Liste der durchgeführten Änderungen mit der Möglichkeit, die Änderung wieder rückgängig zu machen
  • Favoriten Liste, in der Sie Ihre oft verwendeten Tipps ablegen können. Diese Datei wird als "Favoriten.txt" auf Ihren Rechner abgelegt und kann somit leicht gesichert werden.
  • Unter Windows NT und 2000/XP/2003 wird angezeigt, welche Rechte Sie auf diesem Schlüssel haben. Bei Nur-Lese-Rechten werden die aktuellen Einstellungen angezeigt und die Buttons zum Verändern ausgeblendet.
  • Sichern und Wiederherstellen der Registry
  • RSW Registry Browser
  • Erstellen von ADM-Dateien
  • Erstellen von REG-Dateien
  • Durchsuchen der Registry nach Stichworten.
  • Speichern und Löschen der Suchergebnisse
  • Update-Funktion im Programm integriert
  • Exportieren der Änderungen die Sie mit dem RSW an der Registry durchgeführt haben
  • Navigation per <Alt + Buchstabe>
  • Hinzufügen von neuen Tipps in einer eigenen Datenbank über einen Wizard

Info Sie können das Programm von meiner Homepage runterladen: http://www.winfaq.de/download_rsw.htm

URL: http://www.winfaq.de/faq_html/Content/tip1500/tip1657.htm


Debug-Fenster mit Systemrechten

Wenn Sie eine Anmeldung oder andere Funktionen überwachen wollen und das unter einem Benutzer, der keine Rechte hat, ist eine Kommandozeile mit administrativen Rechten hilfreich.

Öffnet man so eine Konsole, wenn der Benutzer angemeldet ist, aber man muss sich öfter abmelden, wird auch dieses Fenster wieder geschlossen. Weiterhin hat man kein Fenster offen, wenn sich der Benutzer anmeldet. Mit einem Trick können Sie ein Konsolenfenster im Anmeldebildschirm öffnen, welcher auch bei An- und Abmeldevorgängen verfügbar ist

Dafür müssen Sie mit dem Befehl AT einen Job erstellen, welcher eine Komsole (CMD.EXE) öffnet. Wenn keiner angemeldet ist, gehen Sie dazu folgendermaßen vor:

  • Melden Sie sich mit einem administrativen Account an
  • Öffnen Sie die Kommandozeile (CMD.EXE) und geben Sie folgendes ein:
    at [Zeit] /interactive cmd.exe
    (Als [Zeit] geben Sie eine Zeit an, die z.B. 2-3 Minuten über der aktuellen Zeit liegt. Ihr Rechner zeigt gerade eine Uhrzeit von 14:50 an, dann würden Sie folgenden Befehl eingeben: at 14:53 /interactive cmd.exe)
  • Warten Sie nun bis die Kommandozeile geöffnet wird.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2042.htm


Windows Backup: Bringt Fehlermeldung 0x80070026

Bringt das Windows Backup bei Ihnen den Fehler "0x80070026", müssen Sie folgenden Registryeintrag setzen:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ Software\ Policies \ Microsoft\ Windows\ System

Erstellen Sie hier einen neuen Wert mit dem Namen "CopyFileBufferedSynchronousIo" als Datentyp REG_DWORD. Setzen Sie den Wert auf 1.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2180.htm


Aufrufen des Begrüßungscenters ausschalten

Mit diesem Eintrag können Sie den Start des Begrüßungscenters nach der Anmeldung ausschalten. Nach einer Installation von Windows, wird dieses Begrüßungscenter automatisch geöffnet.

Das Begrüßungscenter können Sie aber jederzeit über "Start" -> "Alle Programme" -> "Zubehör" -> "Begrüßungscenter" aufrufen.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Run

Löschen Sie hier den Eintrag "WindowsWelcomeCenter" um den Start des Begrüßungscenters zu unterbinden.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2213.htm


Standard Default- oder Mandatory-Profile verteilen

Meldet sich ein Anwender das erst Mal an und hat er kein Profil, wird automatisch ein Profil für den Anwender erstellt. Für die Erstellung eines neuen Profils verwendet Windows ein Standardprofil. Auf einem einzelnen Client-Rechner wird dafür das "Default User" verwendet. ("\Dokumente und Einstellungen\Default User").

Windows kopiert dieses Profil in das Profilverzeichnis des neuen Anwenders und benutzt die Einstellungen und Konfiguration als Grundlage für das neue Profil das Anwenders. Sie können dieses Standardprofil nach Ihren Wünschen anpassen und damit entsprechende Einstellungen für neue Anwender vorgeben.

Im Verzeichnis "\Dokumente und Einstellungen\Default User\Desktop" können Sie z.B. Icons/Verknüpfungen auf dem Desktop ablegen.

Aufpassen müssen Sie nur mit der Daten "NTUSER.DAT". Diese Datei enthält die Registryeinstellungen des Anwenders (HKCU).

Wenn Sie in einer Domäne (Netzwerk) ein einheitliches Profil verteilen wollen, müssen Sie nicht auf jedem Rechner das "Default User" Profil anpassen. Bei einer Anmeldung in einer Domäne, sucht Windows als erstes ein Default-Profil im Netlogon-Verzeichnis der Domäne, Nur wenn hier kein Profil gefunden wird, wird erst das Default Profil des Rechners geladen.

Um ein Default-Profil zu verteilen erstellen Sie folgende Verzeichnisse:

Betriebssystem | Verzeichnisname
Windows 200/XP/20003 | Default User
Ab VISTA | Default User.V2

Für Windows VISTA wurde ein neues Profilverzeichnis eingeführt, da sich der Aufbau der Profile doch erheblich unterscheiden und ein Profil von Windows 2000/XP nicht unter Windows VISTA verwendet werden kann.

Kopieren Sie in diese Verzeichnisse den Inhalt von "Default User" eines Clientrechners und passen Sie anschließend das Profil Ihren Wünschen entsprechend an.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2410.htm


Datei und Registry Virtualisierung

Ab Windows Vista wurde die Sicherheit verändert und um das Benutzerkontensteuerung - "User Account Control (UAC)" erweitert. Dadurch soll erreicht werden, dass man als Anwender nicht mehr mit "administrativen"-Berechtigungen an Rechner arbeiten muss um seine Aufgaben erledigen zu können.

Dadurch ergibt sich ein Problem. Es gibt Programme, die vor dieser Änderung entwickelt wurden und davon ausgehen, dass sie auf alle Verzeichnisse zugreifen dürfen. Damit solche Anwendungen auch noch ausgeführt werden können, wurde das "File and Registry Virtualisation - FARV" von Microsoft entwickelt.

Funktionsweise der Datei und Registry Virtualisierung

Wird ein Programm gestartet, legt Windows fest, ob diese Anwendung als "Legacyanwendung" ausgeführt wird. Greift eine Legacyanwendung auf einen globalen Systemspeicherort (Dateisystem oder Registry) schreibend zu und kommt es bei diesem Vorgang aufgrund fehlender Rechte zu einen Fehler (Zugriff verweigert), dann leitet Windows diesen Zugriff auf den Virtuellen Speicherbereich um. Bei einem lesenden Zugriff wird als erstes im Virtuellen Speicherbereich nach dieser Datei gesucht. Wird die Datei dort nicht gefunden, wird erst auf den globalen Speicherbereich zugegriffen.

Das Virtuelle-Verzeichnis für Dateizugriffe liegt unter "%UserProfile%\Anwendungsdaten\Lokale\VirtualStore". Hier werden weitere Unterverzeichnisse mit Dateien angelegt, die für den Anwender umgeleitet wurden.

Das Virtuelle-Verzeichnis für die Registry wird unter "HKEY_CURRENT_USER\ Software\ Classes\ VirtualStore" bzw. als kurzer Link unter "HKEY_CLASSES_ROOT\ VirtualStore".

Die Anwendung selber bekommt davon nichts mit und "denkt", dass es ausschließlich in seinen Verzeichnissen arbeitet.

Info Wenn Sie im Explorer auf einen Ordner gehen, wohin Dateien umgeleitet wurden, dann werden Ihnen nicht diese umgeleiteten Dateien, sondern die Originaldateien angezeigt.

Oben in der Explorerleiste wird Ihnen aber durch den Link "Kompatibilitätsdateien" (Compatibility Files) angezeigt, dass es Kopieen dieser Datei für den Anwender gibt. Wenn Sie auf die Schaltfläche klicken, wird Ihnen der virtuelle Speicher angezeigt.

Bei welchen Programmen ist die Virtualisierung aktiv?

Die Virtualisierung ist bei allen "Legacyanwendungen" aktiv. Als "Legacyanwendungen" werden folgende Programme eingestuft:

  • Es muss ein 32-Bit-Prozess sein (64-Bit-Prozesse werden nicht als Legacyanwendung behandelt)
  • Die Anwendung wird nicht mit administrativen Rechten ausgeführt
  • Die Anwendung keine Manifestdatei besitzt die angibt, dass die Anwendung für Vista geschrieben wurde
  • Netzwerk-Dateifreigaben werden nicht virtualisiert

Der Virtualisierungsstatus wird als Token im Prozess gespeichert. Im Task-Manager können Sie sich das unter dem Tabreiter "Prozesse" anzeigen lassen. Dazu müssen Sie nur die Spalte "Virtualisierungsstatus" zur Anzeige hinzufügen.

Was wird alles virtualisiert?

Welche Verzeichnisse und Registryeinträge alle virtualisiert sind, wird in Windows fest eingetragen. Dabei handelt es sich um folgende Dateien/Registrypfade.

Dateisystem (mit allen Unterverzeichnissen):

  • %SystemRoot%
    (C:\Windows)
  • %ProgramFiles%
    (C:\Programme)
  • %AllUsersProfile%
    (C:\ProgramData)

Einige Unterverzeichnisse sind von der Virtualisierung ausgenommen. Zusätzlich sind alle Binär ausführbaren Dateien (.EXE, .DLL, .COM usw.) von der Virtualisierung ausgenommen. Diese Liste - der von der Virtualisierung ausgenommen - Dateien, kann über den Registryeintrag "ExcludedExtensionsAdd" erweitern werden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Luafv\ Parameters

Erstellen Sie hier einen neuen Wert mit dem Namen "ExcludedExtensionsAdd" als Datentyp REG_MULTI_SZ. Geben Sie hier die gewünschten Dateiendungen ohne (Punkt) an.

Registrypfade (mit allen Unterschlüsseln):

  • HKEY_LOCAL_MACHINE\ Software

Dabei werden die folgenden Unterschlüssel aber ausgeschlossen:

  • HKEY_:LOCAL_MACHINE\ Software\ Microsoft\ Windows
  • HKEY_:LOCAL_MACHINE\ Software\ Microsoft\ Windows NT
  • HKEY_:LOCAL_MACHINE\ Software\ Classes

Mit dem Tool REG.EXE kann die Liste der ausgenommenen Schlüssel bearbeitet werden.

Über das Flag "REG_KEY_DONT_VIRTUALIZE" werden Schlüssel, die nicht beachtet werden sollen, markiert.

Siehe auch Tipp: "Benutzer-Konten-Steuerung (UAC) deaktivieren/aktivieren"

Info Weitere Informationen hierzu finden Sie in der Technet von Microsoft: http://www.microsoft.com/technet/technetmag/issues/2007/06/uac/default.aspx?loc=de

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2415.htm


Anpassungen an Dateitypen unter Ordneroptionen sperren

Mit diesen Tipp können Sie einstellen, ob Änderungen an den Dateitypen im Explorer unter Extras -> Ordneroptionen -> Tabreiter "Dateitypen" vorgenommen werden können.

Ist der Tipp aktiv, können die Zuordnungen von Dateitypen zu Anwendungen nicht geändert werden. Ansonsten können die Anwender die Dateitypen mit anderen Programmen verbinden.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

[für das System (alle Anwender)]

HKEY_LOCAL_MACHINE Software\ Microsoft\ Windows\ CurrentVersion\ Policies \ Explorer

Erstellen Sie hier einen neuen Wert mit dem Namen "NoFileAssociate" als Datentyp REG_DWORD und setzen den Wert auf:

0 | Änderung der Dateitypenzuweisung erlauben (Standard)
1 | Änderung der Dateitypenzuweisung unterbinden

Info Ist der Eintrag nicht vorhanden, wird von Windows automatisch der Standard-Wert benutzt.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2460.htm


Windows Systemsounds konfigurieren und sichern

Bestimmte Ereignisse werden in Windows mit diversen Klängen gemeldet. So wird z.B. beim Anschluss eines Gerätes am USB-Port ein kurzes Ping ausgegeben. Wollen Sie den Sound nicht vollständig ausschalten, können die vielen Töne doch stören, gerade wenn Sie nicht alleine in einem Büro arbeiten.

Dieses Einstellungen finden Sie in der Systemsteuerung unter Windows 95/98 als "Akustische Signale" und für die anderen Windows Versionen als "Sounds und Multimedia" oder "Sounds und Audiogeräte" im Tabreiter "Akustische Signale" oder "Sounds". Vor der Auswahl eines Schemas sollten Sie Ihre aktuellen Einstellungen sichern, um diese ggf. wieder herstellen zu können.

Über den Button "Speichern unter..." können Sie die aktuelle Konfiguration sichern. Als fertige Soundschemen finden Sie hier "Windows-Standard" und "Keine Sounds".

Unter "Programmereignisse" finden Sie die jeweiligen Einstellungen für Windows und weitere Programm die sich in dieser Liste eingetragen haben.

Diese Einstellungen finden Sie auch in der Registry:

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

unter:

HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps

Im Ordner ".Default" finden Sie die Einstellungen für Windows. Weiterhin finden Sie für jede Anwendung die sich dort Ihre Konfiguration ablegt einen weiteren entsprechenden Schlüssel. Der Windows Explorer legt seine Einstellungen im Unterschlüssel "Explorer" ab.

Wenn Sie den Schlüssel "HKEY_CURRENT_USER\ AppEvents\ Schemes\ Apps" über "Datei" -> "Exportieren..." auswählen, können Sie die Konfiguration als .REG-Datei sichern und auf andere Rechner übertragen oder nach einer Neuinstallation von Windows wieder herstellen.

URL: http://www.winfaq.de/faq_html/Content/tip2000/tip2472.htm


Flip3D Vorschau deaktivieren

Die neue Flip3D Vorschau, zeigt ein kleines Vorschaufenster der geöffneten Anwendungen, wenn die Tastenkombination WIN + TAB gedrückt wird. Diese neue Vorschau, soll das alte Umschalten zwischen Anwendungen über die Tastenkombination ALT + TAB ersetzen. Diese Tastenkombination kann aber auch weiterhin benutzt werden.

Wenn Sie diese Flip3D Vorschau aber nicht möchten, können Sie die Funktion über den folgenden Eintrag deaktivieren.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

HKEY_CURRENT_USER\ Software\ Policies \ Microsoft\ Windows\ DWM

Erstellen Sie hier einen neuen Wert mit dem Namen "DisallowFlip3d" als Datentyp REG_DWORD und setzen den Wert auf:

1 | Flip3D ausschalten
0 | Flip3D ist aktiv (Standard)

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2675.htm


Internet Explorer: "Bei Dateien dieses Typs immer fragen" wieder zurücksetzen

Wenn Sie eine Datei zum Download anklicken, kommt bei einigen Dateitypen eine Dialogbox "Öffnen oder Speichern" wo Sie festlegen können, was mit der Datei gemacht werden soll.

Hier können Sie über ein Häkchen bei "Bei Dateien dieses Typs immer fragen" (Always ask before opening this type of file) diese Abfrage für den Dateityp abstellen. Zukünftig wird die gewählte Aktion jetzt immer automatisch ausgeführt.

Leider können Sie diese Einstellung nicht wieder zurücksetzten. Wenn Sie das aber für einen Dateitypen wierder entfernen möchten, bliebt Ihnen nur der Weg über die Registry.

Starten Sie den Registryeditor und ändern Sie in der Registry die Einträge wie beschrieben ab.

Beachten Sie dazu bitte folgende Punkte:

  • Aufbau der Registrydatenbank
  • Wichtige Hinweise (Informationen zum Sichern der Registrydatenbank)
  • Unterschiede zwischen Regedit und Regedt32

Aufrufen von REGEDIT.EXE (alle Betriebssysteme) oder REGEDT32.EXE (nur Windows NT/2000)

Info Wenn der Pfad zum Schlüssel nicht vorhanden ist, müssen Sie die nötigen Schlüssel selber hinzufügen. Rechtsklick auf den letzten Schlüssel (links im Tree) aus dem Kontextmenü "Neu" -> "Schlüssel" auswählen, und die fehlenden Schlüssel mit den angegebenen Namen anlegen.

Unter:

[für den Anwender]

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ Shell\ AttachmentExecute\ {0002DF01-0000-0000-C000-000000000046}

finden Sie für jeden Dateityp, wo für eine Einstellung festgelegt wurde, einen entsprechenden Eintrag. Hier werden die Dateitypen aus "HKEY_CLASSES_ROOT" aufgeführt, welche vom Internet Explorer automatisch geöffnet werden sollen. Löschen Sie hier die Dateitypen, wo diese Aktion nicht mehr ausgeführt werden soll.

Info Diese Einstellung können Sie einfach mit dem "Registry System Wizard" (RSW) verändern. Sie können das Programm unter "http://www.winfaq.de" herunterladen.

URL: http://www.winfaq.de/faq_html/Content/tip2500/tip2688.htm